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1- INTRODUCTION

Truss Analysis and Visualization is a program for the force analysis of planar trusses and the
visualizations of the results. System requirements to run this application: 32Bit Color
QuickDraw installed, math co-processor (if using the FPU version).

Some of the features implemented cover:

* Create a new truss design,

* Alter the geometry of an existing truss design interactively through moving the joint
locations or by the addition/removal of truss members, truss supports or truss
joints,

* Apply loads on a truss,

* Produce free body diagrams of the entire truss or for selected pins,

* Produce a color (pattern) graphical display of the load distribution in the individual
members with the color (and pattern) of the members denoting tension or
compression showing the relative magnitude of the load,

* Implement Method of Sections and Method of Joints interactively,

* Create QuickTime movies of a car traveling over the truss.

A sample truss design is shown below in Fig. 1a and 1b as it would appear on the screen
after performing the force analysis (in color mode or pattern mode).

The advantage of using the pattern mode is if the application was run on a monochrome
monitor (SE/30 for example). Remember that this application requires the presence of an
FPU and Color QuickDraw even if the system does not support color.
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Fig. 1a Screen view of TRUSS 5 program in color mode.
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Fig. 1b Screen view of TRUSS 5 program in color pattern mode.

The right column has the color (pattern) scale for the members following the force analysis:
Red colors indicate tension, and Blue colors indicate compression. Gray indicates negligible
or zero loads (less than 1% of the maximum member force). The upper column has menu
short cuts which can be called by clicking in the appropriate icon after selecting the
receiving node or member (connecting nodes).

2- USAGE OF TRUSS ANALYSIS:

To initialize the program double click on the application named TRUSS.



2.1 Creating a truss

This task is very simple:

1. Choose "Create Truss " from "Edit" Menu. This will produce a triangle on the screen
which can be moved and altered by dragging the nodes.

Mumber of Nodes 4
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Erase Design
Create Truss
Add a Node %A
Delete a Node
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Delete a Member
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2. Creating a TRUSS .

Note that you have to provide the maximum number of joints that you intend to use in
order to efficiently allocate memory to the operation. If you are not sure how many
nodes you will need just enter a large enough number. This number does not have to
be exact.

2. Select any two nodes by clicking on them, or click on the member, to highlight the
member's connecting nodes.



)

Fig. 3. Selecting a member by selecting its nodes.

3. Choose "Add a Node " from "Edit " Menu. This will add a node and connect it to the
two selected nodes.

Erase Design

Add a Node

Member Width...
Hide Node Numbers

Fig. 4. The node added is selected automatically.

4. The newly created node can then be moved by dragging it with the mouse button down
to the desired location.
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Fig. 5. Moving the nodes to obtain the desired structure.



5. Subsequent addition of new members and joints is accomplished by repeating steps 3
and 4.

6. A support can be added at any selected node by clicking it. Make sure that it is the only
node selected. You can click outside the truss to de-select all nodes and then click on
the desired node.
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Fig. 6. Support buttons
Click on one of the four types of supports shown in the shortcut strip of Fig. 1
( pinned, no support, vertical roller, and horizontal roller).

7. Applying a nodal force is accomplished by first clicking on the appropriate node
followed by a click on the force option in the shortcut strip (apply/remove load).

Applyload Remowe load
Fig. 7. Loading/unloading a truss

This will bring up a dialog box to the screen prompting the user for the force
magnitude and the force direction (in degrees and measured from a right-oriented
horizontal line). Type the desired numbers and hit OK when done. Note that a positive
force points away from the node, while a negative one will point towards the node.
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Magnitude: |10.0 N

Direction: |180.0 Degrees
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Loading/unloading the truss.

2.2 Alteration of the truss loading

Note that several of these options have shortcut buttons located at the top of the main
window:
1. Any node can be moved by first clicking on the node and dragging it to a new location.

2. Any member may be removed by first clicking on the nodes of that member (or clicking
on the member) and selecting “Delete a Link ” option in the “Edit ”” menu.

3. A member may be added by first clicking on two nodes where a new member is desired
followed by selecting “Add a Link™ option from the “Edit” menu.



4. Any force, or support, can be removed by first clicking on the node on which the force,
or support, is at followed by a click on the remove force (support) shortcut button
shown as a crossed arrow (crossed support).

5. The grid can be of help while creating or altering the truss and the “Align Truss ” option
in the “Grid” menu will correct any minor misalignments in the links.

Grid Size... #b
Show Grid
Align Truss Members.
Snap Nodes to Grid

Fig. 9. Aligning the truss in case of minor misalignments.

6. The "Snap Nodes to Grid" option will cause nodes that are fairly close to the grid point
to align with it. This is very helpful when designing a bridge truss where most of the
members are at uniform distances from each other.

Grid 5ize... #b
Hide Grid

Align Truss Members
Snap Nodes to Grid -,

Fig. 10. Snapping the truss to the grid.



7. Dragging a node too close to a member will add the node to that member creating two
connected members. Also, moving a node close to another node will make them one
node.

8. The entire truss design can be removed by choosing “Erase Design® from the “Edit*
menu.

2.3 Analyzing a Truss
Once the desired truss has been created, the analysis step follows with several options:
1. Static Truss Solution: Choose "Solve Truss" Option. This will cause the truss members
to be drawn in different intensities of RED(fension) and BLUE (compression) so that

the forces in the members can be viewed relative to the color scale on the right of the
screen.

Fig. 11. The truss after analysis, each member is drawn with
the color and pattern that indicates its force value.



2. A free body diagram of the whole truss can be viewed by selecting "FBD Truss" option.
This will produce a wire frame truss and replace the supports with the appropriate
reaction forces drawn in intensities of red with a green arrow tip showing the
direction of the reaction force.

Analysis
50lve Truss
FBD of Supports
FBD of a Pin

Fig. 12. Free body diagram of the truss showing ground forces at the supports.

3. A free body diagram of a pin starts by selecting a node and choosing "FBD of a Pin".
Colored arrows with a green tip will simulate the member forces exerted at the
selected node.

S5o0lve Truss #ET
FBD of Supports
FBD of a Pin |
Hide Force Daltes
Color Mode

Fig. 13. The free body diagram of a selected node.

Force values can be called to appear on the screen or disappear by choosing either
"Show Force Values" or "Hide Force Values".



4. Member forces can be printed in a separate window if "Force List" was chosen, a
window will appear having all the member forces and ground reaction forces listed on
it.

Window

Force List
Console

S[[I=——— Force List

Truss merber loads: Reaction forces :
Fl1][2]=-16.495

F[1][3]=-52.125 RFy[1]=5z2.12
Fl2][Z]=25.925 RFx[4]=26 43
FIZ1[41=41 641 RFy[4]=-22.12

Fig. 14. Another way of obtaining numerical results.

5. If the truss is over-constrained or under-constrained, a dialog box will appear with the

appropriate warning and the program will return to the wire-frame mode.
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Fig. 15. An improper truss missing a support (indeterminate)




2.4 Method of Joints

There exist two popular methods to analyze a truss: The Method of Joints and the Method of
Sections. The Method of Sections will be discussed later.

To start the Method of Joints click the shortcut button. To see the free body diagram of a
joint simply select the node and hold the mouse button. The forces will disappear as soon as
the mouse button is released. See Fig. 16 for an illustration.
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Fig. 16. Implementing the Method of Joints

2.4 Method of Sections

The Method of Sections can be used to find the free body diagram of any member. Usually
this method is used to split the truss into two segments when the method of joints would fail
in case of an indeterminate truss or a truss with redundant members. This method will
produce the free body diagram for both pieces of the truss.

To start this procedure click the method's button.
New buttons will appear that would control this method .



Select the members that you want to cut through and click DONE to see the free body
diagram. Choose RESET to restart the process or terminate it with the OFF button. See the
figure below for an illustration.

Cut
F23 F13

Fig. 17. Implementing the Method of Sections

Note that the cut has to completely separate the truss into two independent sections for the
method to be meaningful. The application does not check if the cut is complete. It is the
user's task.

3- EXPORTING RESULTS

Truss 5.0 supports several result exporting options:

A) The main screen could be copied to the clipboard and pasted in another application.

B) The windows can be exported as a PICT file from the "Window" menu.

C) A QuickTime movie can be created to simulate a car traveling selected members.
Select "Export Car Movie..." from "File" menu and enter the desired information in the
window:



Show a car traveling over joints:
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Fig. 18. QuickTime movie options

The resulting movie can be viewed with any application that supports QuickTime format
like SimplePlayer.

QuickTime™ and a
Graphics decompressor
are needed to see this picture
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Fig. 19. QuickTime movie (double click to view)



D) If desired, The individual frames could be saved as a series of PICT files that could be
assembled with other applications like MoviePlayer from Apple. To do so, choose
"Export Car Movie Frames..." from the "File" menu.

Note: To change the car in the animation, design you own and replace the appropriate
application PICT resource with ResEdit.

4- MENU OPTIONS

About Truss... Dizplay credit logo
Help... #H | Show on-line help
Why the Beep... #/ Explain beeping

Save Truss... 35 |Save settings in an input file

Open Truss... #0 |Load the truss from an input file

Read File... List a text file in the console

Invert Screen Toggle backgmum:ll between
............................................. black and white

Copy... #C | Capy selection to clipboard

Print Window... #P | Frint the top window

Export Car Movie... Produce a Cick Tirne movie

Export Car Movie Frames... |Save movie frames as FICT files

Quit 30 |Exit application




Erase Design Erase the screen and initialize the problem
Create Truss Create a triangle which is the basis of the truss.
Add a Node #A |Add anode between 2 selected joints

Delete a Node Femove the selected node

Add a Member ¥L |Add armember between 2 selected joints
Delete a Member Delete a selected merber

List Farameters Display information about the design in console
Member Width... Change the mernbers' width

Hide Node Numbers |Hide/show node nurnbers

Solue Truss #T | Solve for the member forees and show colors
FBD of Supports chow the free body diagrarm of the supports
FBD of a Pin Show the free body diagrarm of a selected joint
Show Force Dalues Show/ hide force values

Mode Color ar wire frame mode

Truss 1 #1

Truss 2 #2

Truss 3 %3 Preset truss exarmples

Truss 4 ¥4

Method of Joints .
Method of Sections |-ratt analysis methad

Write Analysis Steps |Write the solution procedure to a file
(Gauss-Jordan matrix solver with pivoting)

Grid Size... %06 | Set grid spacing in pixels
Show Grid chow/ hide grid
Align Truss Members |Align any minor crookedness in the mermbers
snap Nodes to Grid thap the joint to the closest grid
(if it iz fairly close)




Truss

Force List Bring window to the front

Console

Color/Pattern Mode Use solid/ pattern colors to show forces
Export Window as PICT... #E |Export the front window as a PICT file

S- SHORT CUT BUTTONS

Operations on a selected joint:
Install pin support

Remowe support

¥Y-Raoller suppart

X-Roller support
/{ Add pemove a force

NEEEE

Remowve node {and connected memb ers)
Operations on 2 selected joints:

Add a member X Remove a member

>

Add anode (and two members)
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Other operations:

4{b : Move truss in armow direction

A\ || AA | Toggle Color and Wire Frame modes

. | Activate FBD mode | HF | Return to normal mode

(5]

ManE MODE
1 | Activate Method of Sections
i—iﬁi Retumn to normal mode

ootE | Select members and click to cut

RESET | Restart method




