MODELSHOP Il DEMONSTRATION
Introduction

Visualizing your ideas in three dimensions can often be a difficult and time consuming
task. ModelShop Il is a program that will make modeling and visualizing your ideas as
easy as working with a draw program, but in three dimensions. Experience with CAD
applications is a plus since ModelShop Il does follow some conventions that are fairly
commonplace in the CAD environment (ie: working in plan and elevation and with on-
screen dimensions). CAD depends on accuracy and ModelShop Il works with CAD-like
accuracy. This is extremely important because spatial designs depend largely on the
variations of the built environment and open space. What this demonstration should
allow you to do is to learn how create basic shapes in ModelShop Il then view them in
three dimensions.

Once having created a model in 3D, you have great flexibility. You can output different
views of your model as draw and paint PICT's or output a PICS file for compilation as an
animated movie (this demo disc, though, will not allow any export). In this
demonstration we will create an office, pictured below, by creating objects from scratch
and from various library items included with ModelShop II.
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To make your demo move faster we will use some conventions to pick commands from
the pallet and menus. A bold face with ">" next to it means a MENU item that follows
like the example below:

-View>Zoom>To Extents (Command-E) =
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An icon followed by a command means to pick a PALETT tool like the example below:
]|t Choose Rectangle Tool (R)=

In the lower left hand of the ModelShop Il screen are numbers that let you know where
you are in the world and when you create objects how large it is. Before you begin to
create an object you are seeing ABSOLUTE dimensions (where the cursor is in the
world):
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After you begin to build an object the values are changed to RELATIVE dimensions
(where the cursor is relative to the last click):
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Lets Begin...
MAKE A NEW FOLDER ON YOUR HARD DRIVE CALLED "MODELSHOP Il DEMO"

AND COPY THE DEMO APPLICATION AND ALL FILES ONTO YOUR HARD DRIVE.

Begin by double clicking on the ModelShop Il Demo icon and click on the splash screen
when it appears to bring up a blank plan view in the ModelShop Il world...
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To create the floor...
|:||[ Choose Rectangle Tool (R)

-Position cursor at X:-20' Y:15' Z: 0'

-Push mouse button down and drag cursor to the right and down until x:40' y:-30' z:0'
and let go of mouse button.

-A rubberband line will then appear to give the object a height. TYPE in a value of
"H:-1" and press "return". The object should look like the image below:
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To create the exterior wall...
4+ |- Choose Chain Tool (C):

-Place cursor at x:5' y:-15' z:0" and click once. A rubberband line will appear waiting for
you to place another wall segment.

-Drag rubberband line left to x:-25 y:0' z:0' and click.

-Drag rubberband line down to x:0 y:-30' z:0' and click.

-Drag rubberband line right to x:40' y:0' z:0' and double click.



-A rubberband line will appear to give the wall height. Pull the line so that H=4' and
click. The screen should look like the image below:
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To give wall color...

-While wall is still selected (if deselected drag cursor over any vertices of wall):
Colors>Red

To create interior wall partitions...
Tools>Tool Settings...>Wall thickness>0'3" (To match dialog box below)

Tool Settings...
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Wall segment #1:
q% Choose Line Tool (L):

-Place cursor at x:-5' y:15' z:0" and click.
-Drag rubberband line down to x:0' y:-10' z:0" and click.
-Drag rubberband line so H=3'6" and click.

To give the walls a different color...
Color>Blue

Wall segment #2:
A | -Choose Chain Tool (C):



-Place cursor at x:-20' y:0' z:0" and click.

-Drag rubberband line right to x:20' y:0' z:0' and click.

-Drag rubberband line down to x:0' y:3' z:0' and double click.
-Drag rubberband line to H=3'6" and click.

Wall segment #3:

’:IE Choose Line Tool (L):

-Place cursor at x:0' y:6' z:0' and click.
-Drag rubberband line to x:0' y:-9' z:0' and click.
-Drag rubberband line so H=3'6" and click.

The screen should look like the image below:
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To change your view...
View>Axonometric (Command-3)
View>Perspective>Moderate
View>Zoom>To Extents (Command-E)
Render>Hidden Line (Command-H)
The screen should look like this:
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To save this view for future reference...



(Views are used so that you can work in either plan, elevation, axonometric or any user-
defined perspective and then store these views for easy viewing from any angle,
configuration or rendering mode)

View>New View

-When the dialog box appears type a new name: "View 1"

-Click "OK" to close dialog box

Name New Uiew

[view 1 |
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To return to plan view...
View>Plan (Command-1)

To create columns...
EIE Choose Ellipse Tool (O):

-Position cursor at X:-19'Y:14' Z: 0'

-Push mouse button down and drag cursor until position is at

x:2'y:-2' z:0' and release mouse button.

-A rubberband line will then appear to give the object a height. Drag the rubberband line
until H=10" and click mouse.

The column should be placed as shown:
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To give column color...
Color>Yellow

To duplicate the column...
@Ié Double Click On Duplicate Tool:
-Type in "4" in dialog box as shown:



Duplicate...
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-Place cursor at x:-19' y:14' z:0" and click.
-Drag rubberband line down to x:0' y:-6'6" z:0" and click.

h: | _Choose Selection Tool (Tab):
-Select first column by dragging around any vertices on ellipse.

ﬁ% Double Click On Duplicate Tool:
-Type in "5" in dialog box as shown:
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time (s)
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-Place cursor at x:-19' y:14' z:0' and click.
-Drag rubberband line right to x:6'6" y:0' z:0' and click.
The screen should look like this:
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View your work so far in 3D...



Views>View 1 (Command-4)

Return to plan view...
Views>Plan (Command-1)

To create a new layer for the roof...

(Layers are used to organize large models into groups of objects in a logical and orderly
way)

Objects>New Layer

-When the dialog box appears type a new name: "Roof"

-Click "OK" to close dialog box

Name New Layer
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To create a new plane to work on...
(Working planes are used to create your own set of user defined set of custom working
planes. These can be created by clicking on 3 vertices of any selected item(s) or simply

typed in as we will do here)
’-%%‘% Double Click On Working Plane Tool:
-Type in "Roof Pane"

-Click Plane Height toggle button and type "10"
-Click "OK" to close dialog box

Working Plane...

Name |Hum‘ Plane |

3 Click Defined

1] 4 Cancel

|:||[ Choose Rectangle Tool (R):

-Position cursor at X:-22' Y:17' Z: 10'

-Push mouse button down and drag cursor until position is at

x:44'y:34' z:0' and release mouse button.

-A rubberband line will then appear to give the object a height. Drag the rubberband line
until H=1" and click mouse.

The roof should be placed as shown:
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To give it a color...
Color>Grey

To place a hole in the roof...
[J|i Choose Rectangle Tool (R):

-Position cursor at X:-15'Y:10"' Z: 10'

-Push mouse button down and drag cursor until position is at

x:25'y:20' z:0' and release mouse button.

-A rubberband line will then appear to give the object a height. A hole must have a
height of "0" so don't drag the rubberband line and keep H=0" and click mouse (or type
in "0" and return).

-Hold down the shift key and select a vertices on the roof so both the hole and the roof
are selected.

The hole should be placed as shown:
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To execute the hole...

Edit>Hole

(A beep will sound to let you know that the hole has been created. If this did not happen
1) Delete the hole object 2) Make sure that the roof was built on the new "Roof Plane"
3) Make sure that the hole was built on the same plane 4) Go through the steps to
create a hole again.)



To create a user defined view...
WE Choose the User-Defined View Tool (U):

-Place cursor at x:18' y:-7' and click to establish viewing standpoint.

-Drag rubberband line to establish a viewing height of H=6" and click.

-Drag rubberband line up and left to x:-18' y:13' and click to establish center of view.
-Drag rubberband line to establish a viewing height of H=6" and click.

Render>Hidden Line (Command-H)
The screen should look like this:
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To save this view for future reference...

View>New View

-When the dialog box appears type a new name: "Eye View"
-Click "OK" to close dialog box

Name New Uliew o
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To change your orientation with keyboard commands...
-Push the Left Arrow (<-) key two (2) times to change orientation to left.
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To save this view for future reference...

View>New View

-When the dialog box appears type a new name: "Eye View 2"
-Click "OK" to close dialog box

To change your orientation with the mouse...
EEII'Q : Choose Walk Tool (W):

-Place the cursor above the cross-hairs appearing in the middle of your screen.

-Hold down your mouse button until you "walk" to the position seen below (This goes
faster if you are in wireframe):
———
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To save this view for future reference...

View>New View

-When the dialog box appears type a new name: "Eye View 3"
-Click "OK" to close dialog box

To preview and animation...

File>Export>Animation

-Scroll the views so that the First View=Eye View and Last View=Eye View 3, then click
on preview.



Animation
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ModelShop Il will then move you through the space at 10 frames/view. These are
adjustable in the Views menu. Normally you would export to PICS and compile these
with QuickPICS™ for playback in real time.

To return to plan view...
View>Plan (Command-1)

To create a new layer for the furniture...

Objects>New Layer

-When the dialog box appears type a new name: "Furniture"
-Click "OK" to close dialog box

Name New Layer
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To add library items to the model...
Library>Toggle "Merge" and "Objects" and type "OK" as shown:

Library File
Library Function
® Merge ) Replace
Types of Objects
[Settings [ Text Styles

[<] Objects [J Working Planes
[ iews [ Lights
[JcColors [ Primitives

NOTE: The Library operation
cannot be undone!

[[ 0K ]] [Eancel]
-Pick "Conference Table" from the file named "Library ltems" on your demo file.

To change color of table...
Color>Cyan

Move the table into place...

-Place cursor at x:-13' y:9' z:0" and click.
-Drag rubberband line to x:4' y:-16' z:0' and click.

*Repeat the Library command but pick "Office Desk"
Move the office desk into place...



-Place cursor at x:-13' y:4' z:0' and click.
-Drag rubberband line to x:0' y:2' z:0' and click

*Repeat the Library command but pick "Big Table"
Move the table into place...

-Place cursor at x:8' y:-2' z:0" and click.
-Drag rubberband line to x:0' y:9' z:0' and click

The screen should look like this:
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View your additions from eye level...
View>Eye View (Command-5)

To view with shadows...
Render>Shadows (These may take a minute)

Conclusion

Congratulations! Your current view should look a lot like the view from the beginning of
the demo. As you can see ModelShop Il is a very powerful modeling and rendering tool.
This demo, though, only acquaints you with some of ModelShop Il's many features.
Now, at least, you have the working knowledge to work with program on a basic level.
Try adjusting the sunlight, change the sky and ground color and adding local light
sources. Also try building in rendered 3D! All of this is possible in ModelShop II.

Call Paracomp (415) 956-4091 if you require any further assistance.



