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SimpleImage is a simple,  all-purpose image-viewing application that
lets you view all the most popular still-image formats and movie
formats in a single, well-designed application. SimpleImage combines
much of the functionality of other image viewers and movie viewers,
plus it adds some unique abilities of its own, for example:

• Very fast display of images.
• The ability to view images with or without scroll bars.
• An intelligent  “Reopen” menu, which gives you instant access

to as many as the last 99 images and movies that you’ve opened
in SimpleImage.

• Powerful memory-management features that let you open more
windows without having to adjust the amount of memory you
give SimpleImage.

• Sophisticated integration with the Finder, including commands
that instantly locate an open file’s icon in the Finder, apply
Finder labels, and move files you don’t want to the Trash.

• The ability to transform images and movies by rotating and
flipping them.

Welcome to SimpleImage
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Opening Files

There are four ways to open a file in SimpleImage:

1. Double-click the icon in the Finder. If the file “belongs” to
SimpleImage (see below), this is the easiest way to open it. To
find out how to make a file belong to SimpleImage, see Chang-
ing Files’ Creators.

How do you know if a file belongs to SimpleImage? Look at its icon. If it has a
SimpleImage icon like one of those shown above, it’s a SimpleImage file.

2. Drag the file onto an open SimpleImage window. If you have
an image or movie window already open in SimpleImage, you
can open files by dragging their icons onto the open windows. If
the file is in a format SimpleImage can open (see File Types
SimpleImage Can Open for a complete list), the window will
highlight as you drag the file over it.

3. Choose ‘Open’ from the File menu in SimpleImage. The
standard Open File dialog box will appear. (If you’re using Mac
OS 8.5, you’ll see a new, improved Open dialog box.)

4. Choose the file from the ‘Reopen’ menu in SimpleImage. If
you’ve viewed the file recently in SimpleImage, its name should
be listed in the ‘Reopen’ menu. To find out how to change the
number of items that appear in the ‘Reopen’ menu, see Chang-
ing Preferences.

Duplicating Windows
When you try to open a file that’s already open in SimpleImage,
SimpleImage will bring the file’s window to the front and expand it if
it’s collapsed instead of opening the file in a new window. If you want
to view multiple copies of a file, open the file and choose “Duplicate”
from the Window menu. The duplicated window inherits all the char-
acteristics of the original—its view, size, selection, and transforma-
tions.

When you close a window that’s been duplicated, SimpleImage
doesn’t add the window to the Reopen menu until you close the last
copy of the window.
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Using the Reopen Menu
The Reopen menu gives you instant access to as many as the last 99
files you’ve opened in SimpleImage. Although the Reopen menu is
pretty straightforward, some of its abilities may not be immediately
obvious.

SimpleImage adds a file to the Reopen menu when you close its
window in SimpleImage (or the last copy if you have multiple copies
of the file open. See Duplicating Windows). When you open a file,
SimpleImage checks to see if it’s listed in the Reopen menu and, if it
is, removes it.

The Reopen menu remembers the files listed in it even after you quit
SimpleImage.

The Reopen menu maintains very robust links to the files it lists.
SimpleImage will still find the file even if it’s been moved or renamed.
If the file is on a disk that has been removed, SimpleImage will tell
you the name of the disk the file is on and prompt you to insert it. If
the file has been deleted, SimpleImage will tell you it can’t open the
file and remove it from the Reopen menu.

If you wish to close a window without adding its name to the Reopen
menu, hold down the Delete key while clicking in the window’s go-
away box.

If you wish to remove a file from the Reopen menu without reopening
it, select the item while holding down the Delete key. Similarly, you
can remove all the items in the Reopen menu by selecting “Reopen
All” while holding down the Delete key. SimpleImage will ask you to
confirm that you really want to remove all the items from the menu.

You can also make a fresh start and clear the contents of the Reopen
menu by holding down the Delete key while SimpleImage is starting
up.

You can specify the number of files to list in the Reopen menu in the
Preferences dialog box. (See Changing Preferences.)

Changing Files’ Creators
Every Macintosh document has an invisible code associated with it
that tells the Finder which application to open when you double-click
the document’s icon. When SimpleImage opens a file it attaches its
creator code and icon to the file, so the next time you want to open it
you only have to double-click it and the Finder will automatically open
it in SimpleImage.

If you don’t want SimpleImage to change files’ creator codes and
icons, deselect the “Change image files” and “Change movie files”
options in the Preferences dialog box.
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Viewing And Transforming Images

Tip: You can also change the
size of a window by choosing

“Larger,”  “Smaller,” or “Nor-
mal Size” from the View menu.

(Or “Double,” “Halve,” or
“Normal Size” if the frontmost

window is a movie window.)

The “move selection” pointer

The “resize selection” pointer

Tip: You can also scroll an
image in scroll-bar view by

holding down the space bar—
the pointer will change to a

grabber hand—and dragging.
The arrow keys can also be used

to scroll an image. Holding
down the option key causes the

arrow keys to scroll a screenful.

The “grab scroll” pointers

The “resize window” pointer

To Snap Or Not to Snap
SimpleImage gives you a choice of two different ways to view an
image: snap-to-window view or scroll-bar view.

When an image is in snap-to-window view, SimpleImage doesn’t
display any scroll bars or resize box and shrinks the image, if neces-
sary, to fit in the space available on the monitor. In snap-to-window
view all the image is always visible, so there’s no need for scroll bars.

Although a window in snap-to-window view doesn’t have a resize box
you can still change the size of the window by positioning the pointer
in the lower right hand corner of the window—the pointer will change
to a double-headed arrow when you’re in the right spot—and dragging
the mouse. When you resize a window in snap-to-window view the
image shrinks or grows to fit the new size of the window.

When SimpleImage displays an image in scroll-bar view, the image is
always displayed at 100%—SimpleImage never shrinks or grows the
image. Because the image is displayed at its full size not all of it may
be visible, so SimpleImage displays scroll bars to allow you to move
the image around within the window.

In scroll bar view the size of the image is independent of the size of the
window. Resizing the window changes how much of the image you
can see at once; it has no effect on the size of the image itself.

You can change the view of any image by choosing “Snap To Win-
dow” from the View menu. By default SimpleImage opens images in
snap-to-window view, but you can change this by deselecting the
“Snap To Window” option in the Preferences dialog box.

The “Snap To Window” command in the View menu  can’t be dese-
lected when the frontmost window is a movie window, because movies
are always displayed in snap-to-window view.

Making Selections in Images
When the pointer is inside an image window it changes to crosshairs to
let you know that you can drag the mouse to create a selection.

Once you’ve made a selection you can fine tune it by dragging the
corners. Position the mouse in corner of the selection you want to
resize—the pointer will change to a four-headed arrow when you’re in
the right spot—and drag. You can also move the selection marquee
around within the window by positioning the mouse inside the selec-
tion—the pointer will change to an arrow with a tiny selection mar-
quee—and dragging.
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The “drag selection” pointer

To quickly select an entire image, choose “Select All” from the Edit
menu. To quickly deselect the current selection, choose “Select None.”

When the frontmost window contains an image displayed in snap-to-
window view and the image is too large to display at its full size, the
command “Select Screen Area” is enabled in the Edit menu. “Select
Screen Area” selects the largest area of an image that will fit on the
screen if zoomed to 100%. By default, “Select Screen Area” centers
the selection within the image, but you can easily move it or resize it.

When the frontmost window contains an image in scroll-bar view and
the scroll bars are active, the command “Select Current View” is
enabled in the Edit menu. “Select Current View” selects the entire area
currently visible in the window.

Zooming And Cropping Images
Once you’ve made a selection, you can zoom or crop its contents by
choosing “Zoom Selection” or “Crop Selection” from the Edit menu.

“Zoom Selection” opens the contents of the selection in a new window
and resizes it to full size or as close as possible. “Crop Selection”
resizes the selection’s window so that only the contents of the selection
are visible. “Crop Selection” never changes the zoom level of the
image.

A window that contains only a portion of an image, whether it was
created by zooming or cropping, always contains the information
necessary to restore the original image. Choose “Uncrop” from the
Edit menu to restore the original dimensions of the image and create a
new selection representing the portion of the image that was formerly
cropped.

Copying Images
Once you’ve made a selection, you can also copy its contents, either by
moving it to the Clipboard for use in other applications or by dragging
it directly to another application.

To copy a selection to the Clipboard, choose “Copy” from the Edit
menu. To drag the contents of a selection to another application, drag
the selection while holding down the option key. The pointer will
change to an arrow with a plus sign to let you know that you’re moving
the contents of the selection and not just the selection marquee.

Rotating And Reflecting Images (QuickTime 3 Only)
If you have QuickTime 3 installed you can transform images and
movies by rotating and reflecting them.

To rotate an image or movie 90° clockwise, choose “Rotate 90° CW”
from the Transform sub-menu in the View menu. To rotate 90° coun-
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terclockwise, choose “Rotate 90° CCW.” To rotate 180°, choose
“Rotate 180°.” You can also reflect (“flip”) the contents of a window,
either horizontally (“Flip Horizontal”) or vertically (“Flip Vertical”).

No matter how many transformations you apply, you can always return
an image or movie to its original state by choosing “Remove Transfor-
mations” from the Transform sub-menu in the View menu. The “Re-
move Transformations” item is disabled if no transformations have
been applied or if the transformed window is identical to the
untransformed window. (For example, a window that has been rotated
90° twice and flipped both horizontally and vertically is identical to
the original window.)

When you transform a window that has a selection, SimpleImage also
transforms the selection to ensure that precisely the same portion of
the image remains selected. When you transform a scroll-bar view
window in which only part of the image is visible, SimpleImage will
adjust the size of the window and the position of its scroll bars to
attempt to keep the same portion of the image visible. When you rotate
a snap-to-window view image or movie, SimpleImage reduces the size
of the window, if necessary, to ensure that the rotated window fits on
the screen.

Although you can also rotate and reflect movies, please note that some
movies do not play properly when rotated 90°.

If You Have More Than One Monitor
SimpleImage is designed to work intelligently with multiple monitors.

When you open a window, SimpleImage decides which monitor to
open it on based on the settings in the Preferences dialog box. If “Open
files on main screen” is selected, SimpleImage opens the image on the
main monitor—that is, the monitor with the menu bar. If “Open files
on deepest screen” is selected, SimpleImage opens the file on the
monitor that’s currently set to display the largest number of colors (the
largest “bit depth”). If the monitors have the same bit depth,
SimpleImage uses the main monitor. If “Open files on the largest
screen” is selected, SimpleImage opens the file on the monitor that has
the largest viewable area.

When you open a file by dragging its icon onto a SimpleImage win-
dow, SimpleImage overrides the settings described in the previous
paragraph and instead opens the window on the monitor that contains
the window you dragged the file onto.

When you rotate or zoom a window that spans two or more monitors,
or resize it using the commands in the View menu, SimpleImage
calculates which monitor holds that greatest area of the window and
moves the window so that it fits entirely on that monitor.
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Viewing And Transforming Movies

Playing Movies
To play a movie
Click the Play button, hit the space bar or Return key, double-click the
movie, or choose “Play From Beginning” from the View menu.

To pause a movie
Click the Pause button, hit the space bar or Return key, or click the
movie once.

To play or pause all open movies
Choose “Play All Movies” or “Pause All Movies” from the View
menu.

To move to a specific time in a movie
Drag the slider or hit the left or right arrow keys.

To change a movie’s volume
Click the volume icon and drag the slider that appears, or hit the up or
down arrow keys.

To play a movie continuously
Choose “Loop” from the View menu. To loop the movie back and
forth, choose “Loop Back And Forth.” (Looping back and forth is also
called palindrome looping, from the Greek word palíndromos, ‘run-
ning back again.’ The author of SimpleImage is proud of his six semes-
ters of Greek.)

The Standard Movie Controller
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To change the playback rate
Choose “Faster” or “Slower” from the Playback Rate sub-menu of the
View menu to make a movie play faster or slower. To return the movie
to its original speed, choose “Normal Rate.”

Selecting And Copying Movies
You can also select and copy portions of movies, but the process is a
little different from selecting and copying images.

To make a selection in a movie window the movie controller must be
visible. Hold down the shift key and drag the slider to select the  part
of the movie you wish to copy. As you shift-drag the slider, the se-
lected portion of the scroll bar will turn black. To undo the selection,
click anywhere on the scroll bar.

Once you’ve made a selection, you can copy it to the Clipboard by
choosing “Copy” from the Edit menu.

You can also tell SimpleImage to play only the selected part of a
movie by choosing “Play Selection Only” from the View menu.

Hiding the Movie Controller
You can hide or show the movie controller by choosing “Hide Movie
Controller” or “Show Movie Controller” from the View menu. Many
of the movie controller’s functions are still available when the
controller’s hidden: the movie can still be played or paused by hitting
the space bar or Return key or clicking in the movie, the movie can be
moved ahead or back a frame by hitting the left and right arrow keys,
and the volume can be adjusted with the up and down arrow keys.

When the movie controller is hidden and the movie is not playing, an
icon—the badge—appears in the lower left-hand side of the movie to
remind you that the window is a movie window. You can make the
controller reappear by clicking the badge. The badge does not appear
while the movie is playing.

The Poster Frame
Every movie has a poster frame—a single frame that represents the
contents of the movie. The poster frame is usually specified when the
movie is created. To go to the poster frame, choose “Go To Poster
Frame” from the View menu. If the creator of the movie has not explic-
itly specified a poster frame, “Go To Poster Frame” will simply go to
the first frame of the movie.

Rotating And Reflecting Movies (QuickTime 3 Only)
Movies can be rotated and reflected just the same as images. (See
Rotating And Reflecting Images.) Some movies, however, don’t play
properly when rotated 90°, and sound-only movies can’t be trans-
formed or resized.

A movie badge
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Saving Files

In addition to opening and viewing files in SimpleImage, you can also
save files in a variety of formats. (Note: If you don’t have QuickTime 3
installed, you’ll only be able to save files as QuickTime image files.)

To save an image, choose “Save” from the File menu. If you have
QuickTime 3 installed, you’ll see a dialog box giving you a choice of
formats in which to save the image.

If an image or movie is transformed (i.e., rotated or reflected), the
transformations become permanent when the image or movie is saved.
In addition, the current zoom level of a movie becomes permanent
when the movie is saved, but images are always saved at their original
size.

If an image has been cropped, saving the image saves only the cropped
portion, unless you save the image as a picture or QuickTime image
file, in which case any cropping that has been applied to the image is
ignored and the image is saved in its original dimensions.

Printing Images

You can print any image in SimpleImage by choosing “Print” from the
File menu.

Images are printed with any cropping or transformations that have
been applied to them, but the current zoom level of the image is ig-
nored and SimpleImage always attempts to print the image at its full
size, scaling it if necessary to fit the page.

By default, SimpleImage centers the image on the page. You can
change this by deselecting “Center on page” in the Print dialog box.

You can have SimpleImage print the name of the image file below the
image by selecting “Print name” in the Print dialog box.

If the image has a selection, you can have SimpleImage print only the
selection by selecting “Print selection only” in the Print dialog box.
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Mac OS 8 Tip: You can also
move a SimpleImage file to the

Trash by holding down the Shift
key and dragging the window’s

title bar to the Trash icon.

Manipulating Files

Introduction
To understand the features that SimpleImage provides for manipu-
lating files in the Finder, it’s important first to understand the
difference between an image file and the image itself.

An image file contains the raw data that make up an image and is
stored on your hard drive by the Finder, the application that keeps
track of all your files and helps you organize them in folders. The
Finder assigns all your files an icon, like the one on the right.

When you open a file in SimpleImage, SimpleImage displays the
contents of the file in a window. When you transform the image by
choosing commands in the View menu, you are only changing the
way the image is displayed; you are not changing the image file
itself.

SimpleImage, however, also includes features which allow you to
manipulate the Finder file that an image window represents with-
out switching to the Finder.

SimpleImage can

• Move a file to the Trash
• Move a file to another folder
• Change a file’s label
• Switch to the Finder and instantly locate and display the

file’s icon
The following section describes how to use SimpleImage’s Finder
integration features.

Moving a File to the Trash
If you open a file in SimpleImage and decide you no longer want it
you can move the file to the Trash directly from SimpleImage by
choosing “Move To Trash” in the Special sub-menu of the File
menu. This moves the file to the Trash and closes its window and
any duplicates (see “Opening a new copy of a window”) open in
SimpleImage. This does not delete the file; to delete the file you
must move the file to the Trash, switch to the Finder and choose
“Empty Trash” from the Special menu.

If you change your mind you can return the file to its original
location and reopen its window in SimpleImage by choosing
“Undo Move To Trash” from the Edit menu.

Locating a file in the Finder
If you open a file in SimpleImage and then wish to locate the file’s

An image file icon in
the Finder

The image displayed in
SimpleImage
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Tip: You can shift-drag any
window in SimpleImage, not

just the frontmost window.

Tip: The shift key only needs
to be held down when you

first start dragging.

icon in the Finder, choose “Reveal In Finder” from the Special sub-
menu of the File menu. SimpleImage will switch to the Finder, open
the window that contains the file’s icon, if necessary, and select the
icon.

“Close & Reveal” works the same as “Reveal In Finder,” except that it
first closes the file’s window in SimpleImage.

If the file is on a disk that you have removed, SimpleImage will ask
you to re-insert the disk and give you the choice of cancelling the
command.

If the file has been deleted, SimpleImage will display an error mes-
sage.

Moving a File to a New Location (Mac OS 8 only)
If you open a file in SimpleImage and then decide you want to move
the file to a different folder in the Finder, you can move the file to its
new location without leaving SimpleImage if the new location is
visible on the screen.

When the shift key is held down, every window in SimpleImage acts
as a proxy for the file the window represents. That is, you can drag the
window just as if it were an icon in the Finder.

Hold down the shift key and drag the window’s title bar till the arrow
pointer is pointing to the place in the Finder where you want the file to
be moved. As you move the mouse SimpleImage will drag the file’s
icon and name to let you know that you are dragging the file the
window represents and not the window itself.

Dragging a proxy from SimpleImage works exactly like dragging a file
in the Finder. Holding down the option key (in addition to the shift
key) creates a copy of the file in the new location, and holding down
both the option key and the command key creates an alias.

Applying Labels
In addition to moving files around, you can also apply Finder labels to
files from SimpleImage.

To apply a label to a file in SimpleImage, select the file’s window and
choose the label you wish to apply to it in the “Finder Label” sub-
menu in the File menu.

Changing a file’s Finder label has no effect on the window open in
SimpleImage; it only changes the label applied to the file in the Finder.

The “drag proxy” pointer

Tip: If you have Mac OS 8’s
Spring-Loaded Folders

feature enabled, you can use
it to drag a SimpleImage
window to any folder on

your hard drive. Just shift-
drag a window over a folder
or disk icon and pause till it

springs open.
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Changing Preferences

Snap images to window Controls whether SimpleImage displays
images in snap-to-window view or scroll-bar view when they’re first
opened. See Viewing And Transforming Images.

Show zoom level in window title Controls whether SimpleImage
displays an image or movie’s current level of magnification or reduc-
tion. Applies only to windows in snap-to-window view.

Show when resizing Controls whether SimpleImage displays the
current zoom level dynamically as the window is resized.

Show icons in menus Controls whether SimpleImage displays icons
next to file names in the Window and Reopen menu.

Don’t cover Finder icons When this option is selected, SimpleImage
will not allow windows to be zoomed to cover the area of the desktop
on the right where the Finder’s disk icons are typically located.

Show recent files in Reopen menu Controls whether SimpleImage
adds files to the Reopen menu as you close them.

Show last x files Lets you specify the number of files to show, up to
99.

Ask before reopening more than 6 files Controls whether
SimpleImage asks you to confirm before reopening more than 6 files at
once.

Tab 1: View
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Tab 2: Files

Change files’ icons... By default, when you open a file in
SimpleImage that was created by another application, SimpleImage
automatically  changes the file’s creator type so that the next time you
double-click the file it will open in SimpleImage rather than the appli-
cation that created it. (Changing the file’s creator type also causes its
icon to change.) If you don’t want SimpleImage to change any files’
icons (i.e., their creator types), you can disable this feature by deselect-
ing “Change image files” and “Change movie files.” You can also
specify separately whether SimpleImage changes Photoshop files.
SimpleImage leaves them alone by default.

Open files... If you have more than one monitor you can control how
SimpleImage decides which monitor to open files on by selecting one
of the Open files... options.

“On deepest screen” causes files to be opened on the screen with the
greatest bit-depth, i.e., the screen set to display the most colors.

“On largest screen” causes files to be opened on the largest screen.

“On main screen” causes files to be opened on the screen with the
menu bar.

Open dragged files on parent screen When you open an image by
dragging its icon into SimpleImage, if this option is selected
SimpleImage overrides the monitor specified in the “Open files”
settings, and instead opens the file on the screen that contains the
window you dragged the file onto.
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Tab 3: Other

Store images in memory These settings control how SimpleImage
stores decompressed images.

“Always” causes images to always be stored in memory, and may
significantly reduce the number of windows you can open at once.

“Never” causes SimpleImage to decompress the image in a window
whenever the window needs to be drawn. This option uses the least
amount of memory, but it can make SimpleImage very slow.

“When possible” causes SimpleImage to store images in memory
whenever there’s enough memory available. This setting makes the
most efficient use of memory for the best performance.

Use temporary memory If SimpleImage doesn’t have enough
memory to open a file and keep its image decompressed, it attempts to
borrow memory from the system software. As a result you may notice
that the amount of memory that SimpleImage claims for itself grows
and shrinks with the number of images you have open. Deselect this
option to prevent SimpleImage from using any more memory than you
explicitly give it in its Info window in the Finder.

Collapse window when dragging proxy Tells SimpleImage to col-
lapse all its windows when you drag a proxy. (See Moving a File to a
New Location.) Collapsing the windows makes more of the desktop
visible, but it's visually kludgy since the windows belonging to other
applications won’t redraw. The Finder’s windows, however, will
redraw as you drag the file across them. After finishing the drag,
SimpleImage will restore its windows’ original states, expanding only
the windows that were expanded before the drag started.
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File Types SimpleImage Can Open

segamiGEPJ gpj. 5.2 .3TQeriuqerselifGEPJevissergorP

segamiFIG fig. 5.2 3TQeriuqerselifFIGdetaminA

segamiTCIP tcp. 5.2

segamitniaPcaM tnp. 5.2

segamipohsotohP dsp. 5.2 .egamidetisopmocyalpsidylnonaC

selifegamiemiTkciuQ fiq. 5.2

segamiscihparGnociliS bgr. 5.2

segamiFFIT fit. 3

segamiGNP gnp. 3

segamiagraT agt. 3

segamipamtibswodniW pmb. 3

seivomemiTkciuQ vom. 5.2

seivomswodniWrofoediV iva. 3

seivomGEPM gpm. 3 hsotnicaMrewoPaseriuqeR

The following table lists each type of image and movie file that
SimpleImage can open, its typical filename extension, the version of
QuickTime it requires, and any special issues that you should be aware
of.

Note that SimpleImage doesn’t require QuickTime 3 Pro.
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