
ADOBE® PHOTOSHOP® 6.0.1 READ ME
 

This file contains last-minute product information, updates to the Adobe Photoshop documentation, and 
troubleshooting tips. Please refer to the user guide for installation instructions. For further troubleshooting 
and performance information, see the user guide or online Help.    This file also covers the Adobe 
ImageReady component.

Fixes in Adobe Photoshop 6.0.1 

The Adobe Photoshop 6.0.1 update fixes a number of problems discovered after Photoshop 6.0 was 
released. 

The most significant fixes in the 6.0.1 release include:
- The painting tool brush picker has new usability improvements including:
          - Enter brings up and dismisses the preset picker at the current mouse location
          - Double-clicking a brush in the picker selects the brush and dismisses the picker
          - The current brush is always highlighted in the preset picker
          - The current brush indicator always displays the brush size
          - The First Brush and Last Brush keyboard shortcuts (> and <) work regardless of whether the 
current brush exactly matches a preset brush
- Image clipping paths in EPS and TIFF files saved from Photoshop 6.0.1 have been modified so 
software, such as QuarkXPress, is able to read them.
- ImageReady is able to save and preview animations under constrained memory conditions.
- There is no slow-down of performance when files in the Open Recent list are unavailable.
- Batch file naming works correctly in more cases.
- Export Paths to Illustrator retains path scaling.
- Using certain tools after using the Open, Save and Print commands under certain circumstances no 
longer generates a Program Error dialog. 
- Selecting a single color in Color Range now works correctly.
- Online help is accessible for more web browser configurations.
- New Japanese character map (CMap) files are included to resolve conflicts with ImageStyler 1.0 and 
PageMaker 6.5.2 Plus. 
- Memory usage behavior is better on all Windows OS's; the network should no longer become 
unavailable when Photoshop is running.
- Showing and hiding edges for a selection no longer requires pressing Ctrl-H twice.

------------------------------------------------------
An Important Note about Color!
------------------------------------------------------

Adobe Photoshop 6.0.1 features new color management features which will ensure that you get accurate 
color reproduction from scanning through printing and when sharing files across platforms and systems.    
The new color engine works with color management presets enabling you to save specific color 
configurations.    Upon installing Photoshop 6.0.1, your system will be set to the web color default.    If this 
does not suit your workflow, go to Edit>Color Settings to specify a new color management default or 
create your own.

For additional information on Color Management please refer to Photoshop 6.0.1 User Guide.

Important: Please complete your registration card and mail it today or use the on-line registration 
software provided with Adobe Photoshop software to register your copy. You must register to receive 
technical support and important product update information.
  



Serial Numbers 

You can find the serial number on the registration card or on the inside cover of your cd holder. Use this 
number to install the program.

If you are upgrading from an earlier version of Adobe Photoshop, use the original serial number that came 
with that version. The seven-digit number that appears on your Upgrade Registration Card (e.g. 
PWW501V) is for reporting purposes only; you cannot use this number to install the application. 

If you are upgrading from a version prior to 4.0 you will need to contact technical support at 800-685-
3658.

If you are upgrading from Adobe Photoshop LE software, your old serial number will not work; please use 
the serial number included in your upgrade package. If your serial number does not work or you did not 
receive a full version serial number with your Photoshop LE upgrade package, please contact the reseller 
from whom you purchased the upgrade, or contact Adobe Systems at    206-675-6131.
 
Initialization and Preferences Files

You can find the Photoshop 6.0.1 preference files in the following locations:

Windows 98: 
Windows\Application Data\Adobe\Photoshop\6.0\Adobe Photoshop 6 Settings

Windows NT: 
WinNT\profiles\<username>\Application Data\Adobe\Photoshop\6.0\Adobe Photoshop 6 Settings

Windows 2000:
C:\Documents and Settings\<username>\Application Data\AdobePhotoshop\6.0\Adobe Photoshop 6 
Settings.

Note: Many preferences are now in the Windows registry.    To reset your Photoshop preferences you can 
hit Shift-Ctrl-Alt upon startup. 

Installation Requirements

When installing Photoshop to a hard drive other than your system or boot drive (usually C:), you will still 
need to have at least 16MB free on your system drive to proceed with installation, regardless of how 
much space is on your installation drive.

Using Adobe Photoshop with Windows®
 
The following sections include useful information about using Adobe Photoshop 6.0.1 software with 
different versions of Windows. (Please note that Photoshop 6.0.1 does not support Windows 3.1.x or 
Windows 95.)

Shared Files
 
Many files installed by Photoshop - such as TWAIN support files and MSVCRT*.* files (Microsoft runtime 
files) are shared with other programs. When you install or uninstall other programs that use these shared 
files, the file versions used by Photoshop may be overwritten or deleted. If you experience problems with 
features that depend on shared files, reinstall Photoshop.

Windows 98
Running several Adobe applications at one time may result in problems on Windows 98 and Windows 



ME.    This is much less likely to occur on Win NT and Win 2000.

Windows NT
 
Adobe Photoshop 6.0.1 can be run under Windows NT® for Intel compatible systems only. It will not run 
under other types of Windows NT such as Windows NT for DEC Alpha or Windows NT for PowerPC®.

Running Adobe Photoshop under Windows NT with dual processors can improve by 80% the program's 
performance on mathematical or computational-intensive operations (such as converting a document 
from RGB mode to CMYK); by 20% to 30% for less intensive operations; and by 10% for screen 
redrawing.
 
Some third-party plug-in modules may not work with Adobe Photoshop under Windows NT because they 
are 16-bit plug-ins. Windows NT does not provide any backwards compatibility for 16-bit plug-ins.

Changing Monitor Bit Depth in Windows 

When using Adobe Photoshop with Windows, do not attempt to change the screen bit depth while running 
Adobe Photoshop. If you need to change your monitor's bit depth, quit Photoshop. Change your monitor's 
bit depth, then relaunch Photoshop.
 
File Associations

The Photoshop 6.0.1 installer allows you to associate file types with either Photoshop or ImageReady. 
When you associate a file type with an application, you specify which application will open when a file of 
that type is double-clicked on the desktop or in the Windows Explorer. Windows allows all its applications 
to associate themselves to various file types. If you choose the defaults in the Photoshop installer, you 
may find that Photoshop or ImageReady will open instead of another application when you double click 
on certain files. The Photoshop installer allows you to turn off this association with Photoshop or 
ImageReady if you prefer. To do so, click on each file type you do not want to associate and, for each 
type, choose "Do not change". 

If you wish to change your file associations after installing Photoshop, please refer to document number 
315812, "How to Change File Associations in Windows 95, 98, and NT 4.0" in the Adobe Systems 
Technical Solutions Database on the Adobe website, at this location: 
http://www.adobe.com/supportservice/custsupport/database.html.    Search for the document number to 
locate this document. 

Running Adobe Photoshop Over a Network 
 
Adobe Photoshop 6.0.1 is not designed (nor was it tested) to be run when Windows is multi-launched 
over a network. If you want to run Adobe Photoshop on multiple Windows systems, make sure that each 
system has its own copy of Windows and Adobe Photoshop installed on the hard drive.
 
Improving Performance and Troubleshooting

The following sections describe how to improve your system's performance when working with Adobe 
Photoshop 6.0.1, and how to correct some common problems which may occur.    For up to date 
information on optimizing Photoshop performance, refer to document #318243 in Adobe's Technical 
Solutions Database, "Optimizing Performance in Photoshop for Windows", available online at 
http://www.adobe.com/supportservice/custsupport/database.html.

Fonts, Color Profiles and Application Startup Time

Upon startup, Photoshop must initialize all of the fonts that will be available for the Type tools. If you have 
a large number of fonts installed on your system, this can cause Photoshop to take longer to startup. If 



you find the startup time for Photoshop 6.0.1 to be too long, you should remove any unnecessary fonts 
from your system.    Optionally, use a font manager such as Adobe Type Manager to enable and disable 
fonts on the fly.

Likewise, all Color Profiles installed on the system must be read.    Uninstall or remove any color profiles 
you will not be actively using to speed up the application startup time.

Detecting Watermarks When Opening Files

The Digimarc Detect Watermark plug-in automatically searches files when opened or scanned to 
determine whether they contain a watermark with copyright information. When the Detect Watermark 
plug-in is activated, you'll notice a Detect Watermark status message appear in the Photoshop status bar. 
In most cases, this automatic search will have a minimal impact on file open times. If you find that the 
plug-in is having an unacceptable impact on your file open speeds, you can remove the plug-in from your 
Plug-Ins folder. You will still be able to search for watermarks manually using the Filter>Digimarc>Read 
Watermark command.

Painting on Layers That Have Layer Effects

The use of layer effects can increase the time it takes to display layer information to the screen. If you 
experience slow response times when painting on a layer that includes layer effects, you may want to 
temporarily disable the effects. Use the Layer>Layer Style>Hide All Effects command to disable the 
effects. The Layer>Layer Style>Show All Effects command can be used to reveal the effects after you are 
finished painting.

Compressed Drives and Virtual Memory 
 
Adobe Systems recommends that you do not set either the Windows swap file or Adobe Photoshop's 
scratch disk to a compressed disk drive. For more information, see the user guide.

Redrawing Images 

When your video driver is set to 256 colors, Photoshop does not redraw an open image in the 
background when the foreground image is edited. To have Photoshop redraw every open image when a 
palette change occurs in 256-color mode, go to http://www.adobe.com/support/downloads/pswin.htm to 
download the .reg file that will automatically set this switch in your registry.

Multiprocessor Extension
 
The MThread.8bx plug-in installed with Photoshop 6.0.1 provides support for systems with multiple 
processors. If you are experiencing problems running on a multiprocessor machine, ensure that you have 
only one copy of this plug-in in your Plug-Ins folder.

Compatibility Issues

Adobe Online

We recommend that you update Adobe Online the first time you launch Photoshop to ensure that you 
have the latest product and Adobe corporate information.    You can access the Adobe Online dialog by 
clicking on the Photoshop icon at the top of the toolbar, or by selecting Help>Adobe Online. To update, 
click on the Refresh button.

Adobe Online Manager (AOM), installed when you install Photoshop, is a component of Adobe Online 
that manages downloads from the Adobe web site. Adobe Online does not send any personal information 



in this communication. The connection preferences for Adobe Online can be found by using Edit> 
Preferences> Adobe Online or by selecting Help> Adobe Online and selecting the Preferences button. 
Adobe is concerned about your personal privacy. For more information please consult our Online Privacy 
Statement on the Adobe web site.

Opening Photoshop 6.0.1 Format Files in earlier Photoshop versions

You can open Photoshop 6.0.1 format files in earlier versions of Photoshop, but unsupported features will 
be ignored in the file. Unsupported features include functionality such as new Layer Effects, Gradient Map 
adjustment layers, layer sets and the new vector support.    Type layers will appear correctly in Photoshop 
4.0, 5.0 and 5.5 but they will no longer be editable as type. All of these unsupported features will be lost if 
you save the file from the earlier version of Photoshop.

Files created with Photoshop 5.5 or earlier that use certain blend modes like Difference, Color Dodge, 
and Color Burn may appear slightly different in Photoshop 6.0.1. In particular, the dark halos at the edges 
from difference mode may disappear.

Files created with Photoshop 5.5 or earlier that use layer effects on layers with blending modes other than 
Normal or with opacities other than 100% may appear somewhat different in Photoshop 6.0.1.

Opening Photoshop 6.0.1 Type in earlier Photoshop versions

Photoshop 6.0.1 offers improved type layout algorithms from earlier Photoshop versions.    When working 
with type layers created in earlier Photoshop versions, it is possible that you will see slight changes in the 
type layout; however, these changes will only appear once you edit the text or otherwise transform the 
type layer. 

Opening Photoshop 5.5 Files with Type in Photoshop 6.0.1

It is possible that you will see subtle layout changes when opening type layers from Photoshop 5.5 in 
Photoshop 6.0.1.    However, these changes will only appear once you edit the text or otherwise transform 
the type layer.

Photoshop 6.0.1 Plug-ins

The Photoshop 6.0.1 Plug-ins rely on a more modern version of the plug-in spec and will not function with 
other applications.

Importing Photoshop Files into Adobe Illustrator

To ensure that all version 6.0.1 features, such as layer effects, are displayed properly in Adobe Illustrator, 
you should enable the "Include composited image with layered files" checkbox in the 
File>Preferences>Saving Files... dialog.

Importing    Photoshop PDF Files into Adobe Illustrator

If you want to import a PDF file including vector data into Adobe Illustrator, you will need to enable the 
"Use Outlines for Text" checkbox in the PDF Options dialog when saving.

You may not be able to open all Photoshop 6.0.1 pdf files in Adobe Illustrator.    Please refer to the 
Illustrator 9 readme file for the latest information on file interoperability between Photoshop 6 and 
Illustrator 9.

Using BMP Files in Adobe FrameMaker



Adobe FrameMaker does not support BMP files saved from Adobe Photoshop. You should use another 
graphics file format to add Photoshop images to FrameMaker documents.

Using Photoshop 6.0.1 Files in Non-Adobe Applications

Some non-Adobe applications that import native Photoshop files do not correctly open Photoshop 6.0.1 
files. To share Photoshop files with these applications, you should save the file in another format that is 
shared by both applications such as TIFF.

Manage Workflow

You must be using Internet Explorer version 4.0 or higher to take advantage of all of the Manage 
Workflow (WebDav) features in Photoshop 6.0.1.

Acrobat 4.05

You should not install the optional PDFFormat plugin from Acrobat 4.05.

Graphics Card Issues

A variety of graphics card drivers may provide intermittent cursor display problems. These problems can 
include flickering cursors, on-screen artifacts, and cursors that don't immediately update when a new tool 
or cursor type is chosen. None of these display issues will affect the functionality of Photoshop. If you are 
experiencing any of these problems with your own graphics card, ensure that you have the latest driver 
for the card.

Pressure-sensitive Pens and Tablets in ImageReady 3.0.1

In ImageReady, the stylus option will be disabled in the new Liquify plug-in.    Please go to Photoshop 
under Image>Liquify to take advantage of your tablet functionality.

Extensis PhotoTools

The PhotoBars plug-in included with Extensis PhotoTools exploits features that are unique to earlier 
versions of Photoshop and does not strictly adhere to Photoshop's plug-in specification. As such, it is 
incompatible with Photoshop 6.0.1.

Other plug-ins included as part of the Extensis PhotoTools package should continue to function correctly 
with Photoshop 6.0.1.
Note: Extensis PhotoTools 3.0.3 is not compatible with Photoshop 6.0.1.    Updates are available at 
http://www.extensis.com.

Kai's Power Tools (KPT) in ImageReady

If you are using Kai's Power Tools,    you must upgrade to version 5.0.1 to use them in ImageReady 3.0.1.

PANTONE¨ HexWrench

When Hexachrome files saved in DCS 2.0 format from the PANTONE HexWrench plug-in are opened in 
Photoshop 6.0.1, they will appear in multichannel mode.

QuickEdit
The QuickEdit plug-in is no longer included nor is it supported by Photoshop. 

Processing Files Via ImageReady Droplets 



Due to the method used to transfer file names to a droplet during a drag and drop operation, the 
combined length of all file names is limited to 202 characters. To process a large group of images, first 
drag the files into a new folder and then drag the folder onto the droplet.

Miscellaneous Installer Issues

Windows 2000 does not allow certain sections of the registry to be written to by users without 
administrative privileges. It is recommended that only those with administrator privileges and those that 
are logged on as administrator install Photoshop 6.0.1 on Windows 2000.

Undocumented Photoshop Features

The following features are incorrectly or incompletely documented elsewhere in the Photoshop User 
Guide and/or Quick Reference card.

New keyboard shortcuts

Show/Hide Guides: Ctrl-'
Show/Hide Grid: Ctrl-Alt-'
Hide Text Selection Ctrl-H

Numeric Transform

Numeric Transform now appears automatically in the tool options bar whenever you choose a command 
under Edit > Transform, Free Transform, Transform Path, or Free Transform Path.

Photoshop 6.0.1 TIFF files

Please note that Photoshop 6.0.1 has expanded its TIFF file format to support transparency, new 
compression options, as well as layers. The transparency, compression, annotation and layer options are 
off by default since many readers may not be able to read the file if it includes this information.    To take 
advantage of these new TIFF features, you must turn on the "Enable Advanced TIFF Options" check box 
in the Saving Files Preferences dialog.    It is important that you evaluate your current workflow and 
decide whether you would like to take advantage of this new functionality. 

Liquify

To temporarily save the mesh for your image, hold the shift key when pressing OK to leave the Liquify 
dialog. This will save a file to your c:\temp directory called Liquify.tmp. To load the saved mesh with your 
image, hold down the shift key while launching Liquify.    Note that you must already have a c:\temp folder 
on your system in order to take advantage of this feature.

Hitting the Reconstruct button in the Liquify dialog will automatically reconstruct your image.    To stop the 
reconstruction process, hit the space bar as it reconstructs.

Adobe Online

Adobe Online is a link to the Adobe site on the World Wide Web. You can access the Adobe Online dialog 
by clicking on the Photoshop icon at the top of the toolbar, or by selecting Help>Adobe Online.    Within 
the dialog are hot spots that can launch your Web browser and take you to specific locations on the 
Adobe Web site. (NOTE: All of your browser and proxy settings will come from your system default 
internet settings, regardless of whether you disable the "Use system default internet settings" checkbox.)

The contents of the Adobe Online dialog can be updated, based on new information from the Adobe Web 



site, when you click on the Refresh button. We recommend that you do this after installing Photoshop 
6.0.1.    By clicking the Preferences button, you can choose to configure Adobe Online to update itself 
automatically either daily, weekly, or monthly. 

Opening PDF Files With Security

Photoshop cannot open Acrobat PDF files that contain any security settings. In order to open these files 
in Photoshop, they need to be re-saved from Acrobat by a user with the access rights to disable the 
security settings.

Type

Selecting your text and holding down the shift key will cause the text operation, such as font changes, to 
apply to all text layers that are linked to the target text layer. This applies to anti-aliasing, orientation, 
fractional widths, character style (including size and font), paragraph style, color and warp. Color and 
warp changes will preview on the target layer only and apply to all the linked layers once the dialog is 
dismissed. This can be recorded and played back as an action.

Undocumented ImageReady Features

Including Layer Effects in ImageReady Actions

When creating an action that includes layer effects, ImageReady records the changes for each setting as a separate 
entry in the actions palette. To record just one entry, drag the layer effect from the layers palette to the actions palette. 
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