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PowerQuest® Single-Computer License Agreement
IMPORTANT: Read this before using your copy of PowerQuest software.

This document is a legal agreement between you (an individual or business) and PowerQuest Corporation (PowerQuest). Use of the
enclosed software indicates your acceptance of these terms. As used in this License Agreement, the term "Software" means the
software included on the CD or disk media provided with this License Agreement. The term "Software" does not include any
software that is covered by a separate license offered or granted by a person other than PowerQuest.

IF YOU DO NOT AGREE TO THESE TERMS AND CONDITIONS, EITHER DESTROY OR RETURN, INTACT, THE
SOFTWARE PACKAGE, CONTAINING THE CD OR DISK MEDIA, TOGETHER WITH THE OTHER COMPONENTS OF
THE PRODUCT TO THE PLACE OF PURCHASE FOR A REFUND OF THE PURCHASE PRICE.

1. PROPRIETARY RIGHTS. The Software and any accompanying documentation are the proprietary products of PowerQuest or
its licensors and are protected under national laws and international treaty provisions. Ownership of the Software and all copies,
modifications, translations, and merged portions thereof shall at all times remain with PowerQuest or its licensors.

2. GRANT OF LICENSE. The Software and accompanying documentation are being licensed to you, which means you have the
right to use the Software only in accordance with this License Agreement. The Software is considered in use on a computer when it
is loaded into temporary memory or installed into permanent memory. This License may not be assigned or otherwise transferred
without prior written consent from PowerQuest, and any unauthorized transfer is null and void.

PERSONAL LICENSE. This license is personal to you. You may not sublicense, lease, sell, or otherwise transfer the Software or
any of the accompanying documentation to any other person. You may use the Software only for your own personal use if you are
an individual, or for your own internal business purposes if you are a business.

COMPUTER-SPECIFIC LICENSE. Each permitted copy of the Software may be used only in connection with hard drives that are
permanently connected to ONE specific computer (either a stand-alone computer or a computer connected to a network) owned or
leased by you. Once a copy of the Software has been used on a computer, it may not be used on any other computer. If the Software
is made available on a network, it may be accessed only by ONE specific computer. Once the Software has been accessed by ONE
specific computer it may not be used on any additional computers without purchasing additional licenses.

NUMBER OF COPIES LICENSED. If you have not purchased a license that authorizes use of the Software on multiple computers
or by multiple individuals, then you are authorized to use ONLY a single copy of the Software on a single computer. Only ONE
copy of the Software may be created for archival or backup purposes. All copies of the Software must include the PowerQuest
copyright notice and other legal notices.

UPDATES AND SUPPORT. You are entitled to receive complimentary technical support as outlined in this user guide. You are
entitled to receive Software updates (updates are indicated by version number changes to the right side of the decimal) in
accordance with PowerQuest policies as announced from time to time on terms comparable to those offered to other users of the
Software under the single-user license.

TERM. This license is effective from your date of purchase and shall remain in force until terminated. You may terminate the
license and this License Agreement at any time by destroying the Software and the accompanying documentation, together with all
copies in any form.

3. NONPERMITTED USES. Without the express prior written permission of PowerQuest, you may not (a) use, copy, modify, alter
or transfer, electronically or otherwise, the Software or documentation except as expressly permitted in this License Agreement, or
(b) translate, reverse program, disassemble, decompile, or otherwise reverse engineer the Software.

4. EXPORT CONTROLS. Certain uses of the Software by you may be subject to restrictions under U.S. regulations relating to
exports and ultimate end uses of computer software. You agree to fully comply with all applicable U.S. laws and regulations,
including but not limited to the Export Administration Act of 1979 as amended from time to time and any regulations promulgated
thereunder.

5. U.S. GOVERNMENT RESTRICTED RIGHTS. If you are acquiring the Software on behalf of any unit or agency of the United
States Government, the following provision applies: It is acknowledged that the Software and the documentation were developed
at private expense and that no part is in the public domain and that the Software and documentation are provided with
RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph

-
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(c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2)
of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/Manufacturer is
PowerQuest Corporation/P.O. Box 1911/Orem, UT 84059-1911/U.S.A.

6. LIMITED WARRANTY. (a) PowerQuest warrants to you, the original end user, (i) that the Software, other than third-party
software, will perform substantially in accordance with the accompanying documentation and (ii) that the Software is properly
recorded on the disk media. This Limited Warranty extends for ninety (90) days from the date of purchase. PowerQuest does not
warrant any third-party software that is provided with the Software, but PowerQuest agrees to pass on to you any warranties of the
owner or licensor to the extent permitted by the owner or licensor. (b) This Limited Warranty does not apply to any Software that
has been altered, damaged, abused, mis-applied, or used other than in accordance with this license and any instructions included on
the Software and the accompanying documentation. (c) PowerQuest's entire liability and your exclusive remedy under this Limited
Warranty shall be the repair or replacement of any Software that fails to conform to this Limited Warranty or, at PowerQuest's
option, return of the price paid for the Software. PowerQuest shall have no liability under this Limited Warranty unless the
Software is returned to PowerQuest or its authorized representative, with a copy of your receipt, within the warranty period. Any
replacement Software will be warranted for the remainder of the original warranty period or 30 days, whichever is longer. (d) THIS
WARRANTY IS IN LIEU OF AND EXCLUDES ALL OTHER WARRANTIES NOT EXPRESSLY SET FORTH HEREIN,
WHETHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT, OR WARRANTIES ARISING FROM USAGE OF
TRADE OR COURSE OF DEALING. (e) THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS; YOU MAY HAVE
OTHERS WHICH VARY FROM STATE TO STATE. (f) Your failure to return the enclosed registration card or complete the
electronic registration included with the Software may result in PowerQuest's inability to provide you with updates to the Software,
and you assume the entire risk of performance and result in such an event.

7. LIMITATION OF LIABILITY. IN NO EVENT SHALL POWERQUEST'S LIABILITY RELATED TO ANY OF THE
SOFTWARE EXCEED THE LICENSE FEES ACTUALLY PAID BY YOU FOR THE SOFTWARE. EXCEPT FOR A RETURN
OF THE PURCHASE PRICE UNDER THE CIRCUMSTANCES PROVIDED UNDER THE LIMITED WARRANTY,
NEITHER POWERQUEST NOR ITS SUPPLIERS SHALL IN ANY EVENT BE LIABLE FOR ANY DAMAGES
WHATSOEVER ARISING OUT OF OR RELATED TO THE USE OF OR INABILITY TO USE THE SOFTWARE,
INCLUDING BUT NOT LIMITED TO DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES,
AND DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION,
OR OTHER PECUNIARY LOSS, EVEN IF POWERQUEST CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY
OF SUCH DAMAGES, WHETHER SUCH LIABILITY IS BASED ON CONTRACT, TORT, WARRANTY, OR ANY OTHER
LEGAL OR EQUITABLE GROUNDS. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION
OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO
YOU.

8. NO WAIVER. Any failure by either party to this agreement to enforce a specific part of the agreement in a specific situation is
not a waiver of rights under the agreement. The party may still enforce the rest of the agreement in that situation and may still
enforce some or all of the agreement in other situations.

9. This License Agreement constitutes the entire agreement between you and PowerQuest pertaining to its subject matter. This
License Agreement is governed by the laws of the State of Utah. Any litigation arising from this license will be pursued only in the
state or federal courts located in the State of Utah. Even if part of the agreement is held invalid, the rest of the agreement is still
valid, binding and enforceable.

Should you have any questions concerning this Agreement, or if you desire to contact PowerQuest Corporation for any reason,
please write: PowerQuest Corporation/P.O. Box 1911/Orem, UT 84059-1911/U.S.A.

Copyright 1994-2000, PowerQuest Corporation. All rights reserved. The Software is protected by U.S. patents, with other patents
pending in the U.S.A. and elsewhere. PowerQuest is a registered trademark of PowerQuest Corporation.
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Introduction

What Is Drive Image?

Drive Image is a fast, inexpensive, and complete hard-disk imaging solution. Unlike
file-by-file copying utilities, Drive Image uses SmartSector® imaging to create an exact
image of a hard disk or partition.

With Drive Image, you can create and restore a compressed image file of an entire hard
disk or individual partitions of a hard disk on a network, Jaz, Zip, MO, CD or other
removable media device. Because Drive Image uses SmartSector imaging, your Windows
optimizations are preserved when you restore an image. Drive Image provides
SmartSector imaging support for FAT, FAT32, NTFS, HPFS, Linux Ext2, and Linux
Swap, and sector-by-sector support for UNIX and NetWare. (PowerQuest ServerMagic
includes Server Image, a product optimized for imaging NetWare servers.)

Because of operating system conflicts that can result from different hardware
configurations, Drive Image was not intended to copy or image a hard drive that will be
used in a system with different hardware configurations.

What’s New in 4.0?

* CD-R and CD-RW support * Image integrity checker
* Image size estimator * Improved Drive Image File Editor
* Ability to create images on hidden * Support for Windows Me

FAT, FAT32, and NTFS partitions

In addition, the Drive Image CD includes PowerQuest® DataKeeper™. You can use
DataKeeper to monitor drives on your system and back up your files continuously. See
“PowerQuest DataKeeper” on page 79.

PowerQuest Drive Image



Drive Image System Requirements

Hardware/Software  Requirement

Processor Intel 386SX (Intel 486 or above recommended)

RAM 16 MB (32 MB recommended; 32 MB required for FAT32 or
NTES)

3.5-inch diskette drive ~ 3.5-inch diskette drive (DOS-only or OS/2 machines)

CD-ROM drive Any speed; IDE or SCSI CD-R or CD-RW drive for creating

images directly to CD
Hard disk free space 8 MB

Operating system Windows 95, 98, Windows Me, NT 3.51 or 4.0 Workstation,
Windows 2000 Professional, DOS 5.0, OS/2

Monitor VGA (SVGA recommended)

Pointing device None required (Mouse recommended)

IMPORTANT! Drive Image is not supported for use with Windows NT Server, Windows
2000 Server, or Windows 2000 Advanced Server.

If you use Drive Image on a DOS or OS/2 machine, you must run it from rescue disks. See
“Installing on an OS/2 or DOS-Only Computer” on page 6.

Drive Image File Editor requires Windows 95, Windows 98, or Windows NT Workstation.

2 Introduction
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Getting Started

This chapter includes the following information:

* Installing Drive Image

* Creating Rescue Diskettes under Windows
 Installing on an OS/2 or DOS-Only Computer
* Installing Removable Device Drivers

* Before Running Drive Image

* Running Drive Image

* Uninstalling Drive Image

* Getting Online Help
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Installing Drive Image

You can install Drive Image from any of the following operating systems:

Windows 95/98

Windows Me

Windows NT 4.0 Workstation
Windows 2000 Professional

If you are using DOS or OS/2, see “Installing on an OS/2 or DOS-Only Computer” on
page 5.

1 Insert the Drive Image CD into your CD-ROM drive.

2 If CD auto-run is enabled, the installation program automatically launches when you

place the Drive Image CD in your CD-ROM drive. If the CD auto-run is not enabled,
insert the CD, click Start » Run, then type drive : \SETUP (where drive is the
drive letter of your CD-ROM drive), then click OK.

You will be presented with the following options:
» Install Drive Image—Install Drive Image to a local hard disk.

* Create Rescue Diskettes—Create a set of diskettes including a bootable floppy
and a program disk that enable you to run Drive Image from DOS.

* Documentation—Display PDF manuals for Drive Image, error messages, or basic
concepts about hard disks.

Select the option you want, and follow the on-screen instructions.

At the end of the installation process, you will have an opportunity to create rescue
diskettes.

PowerQuest recommends that you create rescue diskettes. Then if your hard disk
becomes unbootable or you do not have access to Windows, you can boot your
computer and run Drive Image from the rescue disks.

Note that Drive Image 4.0 will not overwrite previous versions of Drive Image that
you have installed on your machine. To uninstall earlier versions, see “Uninstalling
Drive Image” on page 10.

Chapter 1: Getting Started



Creating Rescue Diskettes under Windows

You can create Drive Image rescue diskettes under Windows 95 or later. There are two
diskettes for Drive Image. The first is a DOS boot diskette. The second includes the Drive
Image program. If you experience a hard disk failure or are unable to access Windows,
you can run Drive Image from the rescue disks.

1 Choose the Create Rescue Diskettes option in the Drive Image installation program.

Rescue Diskette Limitations (Windows NT/Windows 2000)

On Windows 95, Windows 98, and Windows Me systems, Drive Image uses the operating
system’s DOS files to build the first rescue disk. On Windows NT and Windows 2000
systems, Drive Image uses Caldera DOS.

When you boot from a rescue disk with Caldera DOS, Drive Image is subject to the
following limitations:

* Cannot see NTFS partitions

» Cannot see any partition that crosses or exists past the 1024 cylinder boundary

» Cannot see any partition that resides in an extended partition that crosses or exists past
the 1024 cylinder boundary

You can avoid these limitations by using a Windows 95/98 startup disk in place of the
Drive Image bootable diskette (diskette 1 of the 2-diskette set).

Aside from these limitations, the features in Drive Image running from the rescue diskettes
are the same as those running it from a hard disk.

Installing on an OS/2 or DOS-Only Computer

Because OS/2 and DOS-only computers cannot run the Windows-based installation
program, you should run the MAKEDISK.BAT file (found on the Drive Image CD in the
SETUP\OS2DOS directory) to install Drive Image on OS/2 or DOS-only systems.

This batch file creates two rescue diskettes. The first diskette is a DOS boot diskette. It
also contains the removable media device drivers. The second diskette includes the Drive
Image program. You should be aware of the limitations of the rescue diskettes as listed
above.

PowerQuest Drive Image



Installing Removable Device Drivers

During Setup, Drive Image allows you to install drivers for lomega and Magneto-Optical
removable media storage devices.
* To install lomega drivers, select lomega drivers during installation.
* To install Magneto-Optical drivers, select MO drivers and then the required drive
type (ATAPI or SCSI).

For specific information on individual device drivers, contact your manufacturer directly.
For more information on setting up Iomega and Magneto-Optical drivers, see “Setting Up
Removable Storage Devices” on page 101.

Using Parallel Port Devices with a NetWare Client

Loading a parallel port device driver with a network client installed may cause the system
to hang. To successfully load the device driver for a parallel port drive, you must reboot
the system without loading the network client. You can use the boot diskette set created by
the install program to do this. For more information to resolve this problem, contact your
network administrator.

Before Running Drive Image

Before running Drive Image, PowerQuest recommends that you:

* Run a disk utility such as a thorough ScanDisk (Windows 95/98) or CHKDSK /F
(Windows NT Workstation or Windows 2000 Professional) on each partition of the
source drives to check for file system errors.

* Verify that each FAT partition containing OS/2 extended attributes has a minimum of
5 MB of unused space within the partition if it will be resized during the restore
process.

* Create Drive Image rescue diskettes. See “Installing on an OS/2 or DOS-Only
Computer” on page 5.

Running Drive Image

You can run Drive Image from the hard disk or a floppy diskette.

6 Chapter 1: Getting Started



Running Drive Image from a Hard Disk

1 Shut down applications you are running under Windows.

2 Click Start » Programs » PowerQuest » Drive Image 4.0 » Drive Image 4.0.

Running Drive Image from Rescue Diskettes
1 Insert a bootable diskette (such the first Drive Image rescue diskette).

To create a boot diskette and a Drive Image floppy (rescue diskettes), see “Installing
on an OS/2 or DOS-Only Computer” on page 5.

If you plan to create images to CD-R, you must load PQPACKET.EXE before
running Drive Image. If you use your own boot diskette instead of the first Drive
Image rescue diskette, you must load PQPACKET.EXE manually.

2 Reboot your machine.

DOS loads and displays an A: prompt.

3 Insert the Drive Image program floppy (Diskette #2 of the Drive Image rescue
diskette set).

4 Type PQDI, then press <Enter>.

Be aware that Drive Image has some limitations when you run from the rescue diskettes.
See “Rescue Diskette Limitations (Windows NT/Windows 2000)” on page 5. Aside from
these limitations, the features in Drive Image running from the rescue diskettes are the
same as those running it from a hard disk.

Running Drive Image at Scheduled Times

Use the Drive Image Scheduler to run Drive Image at the time and frequency you specify.
Be aware that Drive Image Scheduler only prompts you to start Drive Image. It does not
automate backing up specified drives on your computer.

IMPORTANT! The Drive Image Scheduler is based on the Scheduled Tasks feature in
Windows. Therefore, if you did not install Scheduled Tasks when you
installed Windows, the Drive Image Scheduler will not be available to you.

Starting Drive Image Scheduler

1 From the Windows Start menu, click Programs » PowerQuest Drive Image 4.0 »
Drive Image Scheduler.

PowerQuest Drive Image



The Drive Image Backup Schedule dialog appears.

|
Drive Image Backup Schedule HE

Schedule |

b scheduled:

Hew | [elete |

Schedule Task: Start time:

j I j‘ Sdvanced.. |

I | Shmvmultinle selediles:

Ok I Cancel Lpply

Scheduling a Backup Task

1 From the Drive Image Backup Schedule dialog box, make sure the Show multiple

schedules check box is selected.

To create only one backup schedule, deselect Show multiple schedules, then

continue with step 3.

2 Click New.

3 Select how often you want the back up to run from the Schedule Task drop-down list.

Choose an option to specify how frequently to run Drive Image. Then specify details

about the option you choose.

Option: Details:

Daily e Start time
*  Which days (every day, every 2 days, etc.)

Weekly e Start time

*  Which weeks (every week, every 2 weeks, etc.)

*  Which days of the week

Chapter 1: Getting Started



Option: Details:

Monthly * Start time

e Numeric date (such as 1 or 15) or relative date (such as first
Monday of the month). If you select a numeric date of 29,
30, or 31, the task will only run on months that include that
date.

* Months you want task to run (January, February, etc.)

Once * Time of day
» Exact date you want backup to occur

At System Choosing this option will launch Drive Image when you turn on
Startup your computer.
At Logon Choosing this option will launch Drive Image when you log

onto your computer.

When idle Choosing this option will launch Drive Image when your
computer is idle for the number of minutes you specify.

The daily, weekly, monthly, and once options include optional advanced settings
where you can specify a start date and end date for the task.

4 Click OK.

The scheduled task will now appear in the Windows Scheduled Tasks folder. To see
scheduled tasks, right-click My Computer on the Windows desktop, click Open,
then double-click Scheduled Tasks.

You can create additional backup schedules by repeating the steps above. For each
new backup schedule you create, the task is added to the drop-down list at the top of
the Schedule tab. (Show multiple schedules must be selected.) When you want to
trigger a specific scheduled task, just select the one you want from the drop-down list,
then click OK.

To edit an existing scheduled backup task, double-click Drive Image Backup in the
Windows Scheduled Tasks folder, then click the Schedule tab.

Deleting a Scheduled Task

If you have created multiple schedules, you can delete the schedules you no longer use
from the drop-down list.

PowerQuest Drive Image
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1 From the Drive Image Backup Schedule dialog, make sure the Show multiple
schedules check box is selected.

2 Select the scheduled task from the drop-down list at the top of the Schedule tab.

3 Click Delete.

Uninstalling Drive Image

1 Click Start » Programs » PowerQuest » Drive Image 4.0 » Uninstall Drive
Image.

You can also click Start » Settings » Control Panel » Add/Remove Programs »
Drive Image 4.0.

2 Follow the instructions on the screen.

Getting Online Help

1 Click Help » Contents to display general instructions for using Drive Image help, or
press <F1> at any time to access the help index.

The Drive Image File Editor is a Windows program and includes a full Windows help
system.

Chapter 1: Getting Started
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This chapter includes the following information:

Overview

Image Files and Hardware Configurations

Copying Windows NT or Windows 2000 Partitions
Preparation

Creating an Image File

Advanced Options

Scenarios
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Overview

You can use Drive Image to create image files on any physical or logical drive that DOS
has assigned a drive letter, including floppy drives, secondary hard drives, CD-R or
CD-RW drives, network drives, and removable media storage devices such as Jaz, Zip, and
MO drives.

You can also create image files on hidden NTFS, FAT, and FAT32 partitions and IDE or
SCSI CD-R or CD-RW drives that have not been assigned drive letters.

If you are unsure whether a drive is available to save an image file, click Browse and all of
the available drives will display.

Image Files and Hardware Configurations

Because of operating system conflicts that can result from different hardware
configurations, Drive Image was not intended to copy or image a hard drive that will be
used in a system with different hardware configurations.

If you create an image on one machine and restore the image on a machine with a different
configuration (for example, a different motherboard or video card), the operating system
may not boot correctly. Therefore, PowerQuest recommends imaging and restoring only to
machines with identical hardware configurations.

Any discussion of imaging assumes that the software, including the operating system, is
being copied in accordance with the license agreement with the software manufacturer.

Copying Windows NT or Windows 2000 Partitions

If you are using Drive Image to copy Windows NT or Windows 2000 partitions (where
Windows is installed), you may experience problems related to the BOOT.INI file. The
BOOT.INI file includes information about the boot options for Windows’ loader and the
order of the Windows partition. If you have used Drive Image to copy a Windows
partition, and the partition order has changed from the original order, then the BOOT.INI
file may not be updated to reflect the new order of the Windows N'T/2000 operating
system files. Therefore, you will be unable to boot your Windows partition.

PowerQuest has developed a solution that will allow you to update and edit the BOOT.INI
file. The executable is NTFSINI.LEXE. For additional information (in English), see the
PowerQuest web site www.powerquest.com/support/pm/pm6076.html.
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Preparation

1 Before creating an image with Drive Image, use a disk utility program such as a

thorough ScanDisk or Norton’s Disk Doctor to identify and repair any errors on your
hard disk.

Windows NT Workstation and Windows 2000 users should run CHKDSK /F.

You may also choose to run a disk defragmenting utility to further optimize your hard
drive.

You should disable virus detection in the BIOS before creating an image file.

If virus protection is enabled, Drive Image may hang after you click Finish.

Check to ensure that the drive where you want to create an image is available under
DOS. You can see the available drives by clicking Browse at the Name Image File
screen. (See step 6 on page 16 for additional information.) You may need to set up
removable media or create boot disks to access network drives before you can create
an image.

Creating Image Files on CD-R or CD-RW

Drive Image enables you to create image files directly on CD-R media. However, you
must meet the following requirements, or your CD-R drive will not be available as a
destination for an image file.

You must have an IDE or SCSI CD-R or CD-RW drive. USB and FireWire CD-R
drives are not supported.

Load HIMEM.SYS in your CONFIG.SYS file.
Do not load EMM386.EXE in your CONFIG.SYS file.

Run PQPACKET.EXE before running the Drive Image executable, PQDI. If you run
Drive Image from the main installation directory or from the rescue disks,
PQPACKET will run automatically. If you run Drive Image from a different
directory, you should browse for PQPACKET and run it manually before running
Drive Image. If you run Drive Image from a different drive, you may want to create a
batch file to run PQPACKET and then start Drive Image.

If you create an image on CD-RW media, it must be empty and unformatted.

PowerQuest Drive Image

13



14

Creating an Image File

dﬂ PowerQuest Drive Image
Joolz:  Help

LCreate Image
To create an image file of the contents of any
partitions, click hene.

¢

Restore Image

Ej"” Ta restore the partitions of an image file to any drive,
click here.
Dizk To Disk

Ta copy the partitions fram one hard drive to anaother
within the zame computer, click here.

@

Exit |

1 Run a thorough ScanDisk on your drives before imaging them.

2 At the Drive Image main screen, click Create Image.

The Select Source Drive screen appears.

Creating an Image E

Select Source Drive

Select the drive that contains the partitions to be included in the image file.

Fhyzical Drives Size ME | Drive Letters

= - Disk 2 13532 E.F:

i

Help < Back I HMext > I Lancel |

3 Select the disks that include the partitions you want to include in the image file.
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You can click All Disks to select partitions from every hard disk on your machine.

4 Click Next.

The Select Source Partitions screen appears. It displays all the partitions on the disks
that you selected. The partition map near the top of the screen is a graphic display of
your hard disk. It includes a blue indicator for the 2 GB boot code boundary and a
black indicator for the 1024 cylinder limit. The indicators can be useful when you are
creating partitions that need to be bootable, since many operating systems require that
boot code be located somewhere within the first 2 GB of the disk.

Creating an Image

Select Source Partitions

Select the partitions to include in the image file.
— Disk 1- 8220 MB

C: D:APPS I
4T18.2 MB Active FAT32 4102.5 MB FAT32

[T1 D &PPS Ay FATE2 Hone 4025 200.6 33013 Logical

Select Al | Select None |

Help | < Back I = I LCancel |

5 Select the partitions you wish to include in the image file (the source partitions) from
the partition list, or click Select All to automatically select all partitions.

You may need to scroll to view all the partitions on your machine. Note that if you
have more than one hard disk on your machine, the first column in the partition list
shows the physical hard disk where the partition is located.

To deselect partitions, click again on a partition or click Select None to deselect all
partitions at once.

6 Click Next.

PowerQuest Drive Image
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Creating an Image

~ Name Image File

Enter the image filename, specifying the drive and directory. For example:
D MYIMAGE.PQI Click Browse to browse the directary tree for the path and

filenarne.
Browese |

Image: File: I

Image File Comments:

Help | < Back I et > I LCancel |

7 Type the desired path and image filename in the Image File field (for example,

D:\MYIMAGE.PQI).

You must save your image file to a partition that you are not including in your image
file. You can click Browse to find the directory where you want to save the image
file. You should click Browse to select a CD-R or CD-RW drive because you cannot
just type the CD-R drive letter to save an image to CD. CD drives will appear in the
list as \\.\pgcdx\name of drive, where x is the number of the CD drive.

You can save an image to a hidden NTFS, FAT, or FAT32 partition by choosing it
from the New Image File dialog box that appears when you click Browse. A hidden
NTEFS partition will appear in the Drives list as W\Diskn.Partm, where n is the number
of the disk and m is the number of the partition on that disk. Drive and partition
numbers begin with zero, so if an NTFS partition were the third partition on the first
disk, it would appear as \\.\Disk(.Part2. To further identify the hidden partition, the
volume label will display, if available.

Make sure there is no existing file with the same name, unless you want the existing
file to be overwritten. Drive Image uses .PQI as the default image filename extension.

IMPORTANT! Do not include spaces or extended characters in the filename, or you
may not be able to access the image file from Drive Image, DOS, or
the Drive Image File Editor.
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You may need to create DOS boot diskettes to access network drives while running
Drive Image. Your network administrator can help you get the correct network
drivers to copy onto the first Drive Image rescue disk.

8 (Optional) Type brief comments about your image file in the Image File Comments
field.

Image file comments cannot exceed 232 characters. Drive Image will automatically
insert information about the drive, partition, and label.

9 Click Next.

Creating an Image

Compress Image File

Select the level of compression for the image file below.

' Mo Compression 1394.0 ME
 Low 834.0 MB
i E37.0 MB

Selection Information:
High compression offers a B0 average compression ratio.

If zaving the image file to a netwark drive or removable media device, high
compression can be faster than no compression.

Mate: The sizes listed are only estimates. The actual size for compreszed images
will wary depending on how well the data compres ses.

< Back I HNest > I LCancel

10 Select the desired compression level.

Drive Image estimates the size of the image file for each level of compression. If you
are creating an image file on removable media, Drive Image also estimates the
number of media that will be required to save the image file. The numbers displayed
are only estimates; the actual size for compressed images will vary according to how
well the data on the disk compresses.

* No Compression is usually the fastest method for creating an image file and is
useful if storage space is not an issue. However, if you are saving your image file
to a busy network drive or to a relatively slow removable media device, high
compression may be faster than no compression since there is less data to write to
the file. Drive Image selects No Compression by default.

* Low compression offers a 40% average compression ratio.

PowerQuest Drive Image
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* High compression offers a 50% average compression ratio.

Image files created with the current version of Drive Image are not compatible with
earlier versions. That is, you cannot read Drive Image 4.0 images with earlier
versions of Drive Image. Drive Image 4.0 can read images created with earlier
versions of Drive Image.

Click Next.

Drive Image displays all the information you have entered to this point.

Creating an Image
 Ready to Create Image File

Feview your selections. Click Back to change selections.
Click Finizh to create image file.

| »

Source Drives: Disk 1- 8220 MB
Source Partitions:

[X]1C- FAT32

[ 1+ Extended

[X10:- APPS FAT32

Image: File: F-~RETAILPOI

Comprezsion Level:  High

L«

Advanced Optiong |

< Back

LCancel

To modify any settings, click Back.

(Optional) Click Advanced Options to split an image file into multiple files (for
removable media), to disable file system error-checking or SmartSector copying, to
password protect your image file, to verify the integrity of the image file after it is
created, or to verify disk writes.

See “Advanced Options” on page 20 for additional information.

Click Finish to begin creating the image file.

If you entered a name of a current file (step 6), Drive Image displays a message that
<path and filename> already exists. You can replace the existing file or choose a new
filename. If you click Replace, the existing image file will be deleted immediately.
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If Drive Image detects that you are saving your image file to a floppy drive or
removable media, it enables a media-spanning feature that spreads the image file over
a series of disks. You must have at least 100K of available space on each disk in the
series. If you use the media-spanning feature, be sure to number the disks in order,
since you must insert them in sequence when restoring the image file.

The Creating the Image dialog appears:

Creating the Image...
Image File:  FJwiN33-2 POI

Estimated MB to Copy: 11953 MB  (Compression Level: Low)
Tatal MB Copied: 2265 MB
Entire Progress

Current Partition:  ©1of 12
olume Tupe Size ME  Used ME Unuzed ME
2 FaT32 41181 11953 23228

Copying data

Transfer Rate for Current Partition: ME ME.min
Tatal MB Copied for Current Partition: 2265 MB

Time Elapsed:  00:01:33
Estimated Time Remaining:  00:04:11

Upon completion, the following message appears: “Image was copied successfully to
file: <image filename>.*

14 Click OK to return to the Drive Image main screen.

IMPORTANT! Because operating system conflicts can result from different hardware
configurations, you should not restore the image you just created on a
system with different hardware.

PowerQuest Drive Image
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Advanced Options

The Create Image Advanced Options dialog appears when you click Advanced
Options at the Ready To Create Image File screen.

Select this: To do this:
Check for File System  Clear the Check for File System Errors check box if you
Errors want to disable error checking.

Disable SmartSector
Copying

Verify Disk Writes

If you have already used a disk utility program such as
ScanDisk to check your hard disk for errors, it is not
necessary to have Drive Image check for file system errors.
Clearing Check for File System Errors saves time in
copying the partitions.

If you did not run a disk utility program before loading
Drive Image, leave the Check for File System Errors check
box selected. Be aware that ScanDisk finds more errors than
the Check feature in Drive Image.

Drive Image’s SmartSector technology speeds up the
copying process by only copying clusters and sectors that
contain data. However, in some cases, such as high-security
environments, it may be desirable to copy all clusters and
sectors in their original layout, whether or not they contain
data.

If you wish to copy both used and unused clusters and
sectors, click Disable SmartSector Copying. Disabling
SmartSector Copying increases processing time and image
file size.

Select this option if you want Drive Image to verify that data
is being written to disk. Verifying disk writes is not
necessary and can slow image file creation substantially.

If you are creating an image file to CD-R, this option is
selected by default and performs a different function. After
burning the image file to a CD, Drive Image will check to
see that the image file can be read from the CD. If there is a
problem with the image, you will have an opportunity to
recreate it. Having this option selected for CD-R does not
affect the size of the image file.
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Select this:

To do this:

Verify Image Contents

Password Protect
Image File

Split Image File Into
Multiple Files

If you select this option, Drive Image:

* Checks to see that all of the files in the image are
available for you to open.

¢ Checks to see that the internal data structures in the
image file match the data that is available.

e Checks to see that the image file can be uncompressed
and create the expected amount of data.

e Checks that the data in the image file you created
matches the contents of the disk that was just imaged.

Drive Image reports whether the image file passes or fails
the integrity check.

To password-protect your image file, click Password
Protect Image File and type a password in the Password
field. Passwords are case-sensitive. To change or undo a
password, use the Drive Image File Editor. See “Adding a
Password to an Image” on page 72.

IMPORTANT! Store image file passwords in a safe place. If
you forget the password, you cannot restore
the file.

If you plan to copy an image file to removable media after
creating it, you can force Drive Image to split a large image
file into smaller files. To do so, click Split Image File Into
Multiple Files and enter the maximum byte size for each
file in the File Size (bytes) field. To save the files to CDs,
specify a file size of 670,000,000 bytes (approximately 670
MB) or less.

PowerQuest Drive Image
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Scenarios

Creating an Image File on a Zip Drive
Sample System Configuration

One 1.2 GB hard drive containing:

* One 800 MB active primary FAT partition (C:) running Windows 95; 300 MB used
and 500 MB unused.

* One extended 400 MB partition containing one logical FAT partition (D:); 350 MB
used and 50 MB unused.

One Zip drive (E:) with 250 MB cartridges.
Objective

Create an image file of your hard drive’s logical partition (D:) and store it on your Zip
drive.

Procedure

1 When you install Drive Image on your computer, select the option to install lomega
drivers.

2 Run a thorough ScanDisk to identify and repair any errors on the D: partition.

3 Since the image file will be too large to fit on one Zip disk, you must create a series of
Zip disks.

Label the first Zip disk as “MYIMAGE DISK #1.” During image file creation, Drive
Image prompts you to insert new media as needed. Label each successive disk
“MYIMAGE DISK #2,” “MYIMAGE DISK #3,” etc.

4 Format the Zip disks to identify and repair any errors on the cartridges.

5 Run Drive Image.

As Drive Image automatically loads the Zip drivers, be sure to note the drive letter
assigned to the Zip drive. In this case, we are referring to the Zip drive as E:.

6 Insert the Zip disk labeled “MYIMAGE DISK #1” into your Zip drive.
7 On the title screen, click Create Image.

8 Disk 1 should already be selected. Click Next.
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This step is skipped if you only have one hard disk.
9 Select the logical partition (D:), then click Next.

10 In the Image File field, type E : \MYIMAGE . PQI, or click Browse, select Drive E:,
type the image filename, and click OK.

11 Click Next.

12 Select High compression.

High compression compacts the image of your 400 MB logical partition by
approximately 50%.

13 Click Next.
14 Click Finish.

15 When Drive Image prompts you to insert the next media in the series, wait until the
busy light on the Zip drive goes out, remove “MYIMAGE DISK #1” from the Zip
drive, and insert “MYIMAGE DISK #2”.

16 After Drive Image has completed the image create process, click OK to return to the
Drive Image main screen and exit the program.

Result

Your 400 MB logical partition is stored on two Zip disks in a spanned image file. You can
restore this logical partition to any hard drive that has at least 400 MB of available
(unpartitioned) space.

For information about restoring images from a Zip drive, see “Restoring an Image File
from a Zip Drive” on page 37.

Creating an Image File on a CD-R
Sample System Configuration

One 3 GB hard drive containing one active 1.8 GB primary FAT partition (C:) running
Windows 95; 1.5 GB used and 300 MB unused.

One CD-R or CD-RW drive (E:).

PowerQuest Drive Image
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Objective

Create an image file of your hard drive’s active primary partition (C:) and store it on CD-R
or CD-RW.

Procedure

1 If you are using CD-RW media that already includes data, you must delete the
existing files from the CD.

2 Since the image file will be too large to fit on one CD (~900 MB), you must create a
series of two CDs.

3 Run a thorough ScanDisk to identify and repair any errors on your C: partition.

4 Run Drive Image.

Ensure that PQPACKET runs before Drive Image, or your CD-R drive will not be
visible. See “Creating Image Files on CD-R or CD-RW” on page 13.

On the Drive Image title screen, click Create Image.
Disk 1 (your hard drive) should already be selected.
Click Next.

Select the active primary C: partition, then click Next.

O 0 N O u

Click Browse, then choose your CD-R drive from the list of available drives.

The name will be in the form \.\pqcdO\drive name. If your CD drive is not listed, see
“Creating Image Files on CD-R or CD-RW” on page 13 for information about
making Drive Image recognize your CD drive.

10 Under File Name, type a name for your image file, then click OK.
11 Click Next.

12 Select Low compression.

Low compression compacts the image of your 1.8 GB primary partition by
approximately 40%.

13 Click Next.

14 Click Finish.
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15 After Drive Image has completed the image create process, click OK to return to the
Drive Image main screen and exit the program.

You will now have at least two CDs containing image files. Label them clearly, so
you can restore the image file later.

Result

Your 1.8 GB primary partition is stored on two CDs in two separate image files. You can
restore this primary partition to any hard disk that has at least 1.8 GB of available
(unpartitioned) space. For information about restoring images from CDs, see “Restoring
an Image File from a CD Drive” on page 39.

Creating an Image File on a Secondary Hard Drive
Sample System Configuration

Disk 1 — One 3.5 GB hard drive containing:

* One active 1.5 GB primary FAT32 partition (C:) running Windows 98; 500 MB used
and 1 GB unused.

* One 1 GB extended partition containing one logical FAT partition (E:); 400 MB used
and 600 MB unused.

* 1 GB unpartitioned free space.

Disk 2 — One 2 GB hard drive containing:
* One | GB primary FAT partition (D:); 1 GB unused.

* One 1 GB extended FAT partition containing one logical partition (F:); 600 MB used
and 400 MB unused.

Objective

Create an image file of the 1 GB logical partition (E:) that is on Disk 1 and store it in the
primary partition (D:) on Disk 2.

1 Run a thorough ScanDisk to identify and repair any errors on both hard drives.
2 Run Drive Image.
3 From the Drive Image title screen, click Create Image.

4 Select Disk 1.

PowerQuest Drive Image
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Click Next.
Select the E: partition.
Click Next.

In the Image File field, type D: \MYIMAGE . PQI.

O 0 N O u

Select No Compression.

No Compression is the fastest method for creating an image file. You may use it if
space is not an issue.

10 Click Next.
11 Click Finish.

12 After Drive Image has completed the image create process, click OK to return to the
Drive Image main screen and exit the program.

Result

An image of your 1 GB logical partition (E:) from Disk 1 is stored in an image file named
MYIMAGE.PQI on the primary partition (D:) of Disk 2. You can restore the logical
partition to any hard drive that has at least 1 GB of available (unpartitioned) space.
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Restoring Image Files

This chapter includes the following information:

Overview

Restoring Images from CD Drives
Restoring an Image File

Resize Options

Advanced Options

Scenarios
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Overview
This chapter describes restoring a Drive Image file to a different drive or partition.
If you received a demo version of Drive Image, you cannot restore image files.

IMPORTANT! If you create an image on one machine and restore the image on a machine
with a different configuration (for example, a different motherboard or
video card), the operating system may not boot correctly. Therefore,
PowerQuest recommends restoring only to machines with similar
hardware configurations.

Related Tasks

* To restore selected files from a compressed or spanned image file, see “Restoring
Files or Partitions” on page 73.

* If you are restoring an image file to set up a new hard drive on a machine with a BIOS
older than 1994, see “Using Drive Image with Drive Overlay Software” on page 92.

» To restore image files created with Ghost, see “Converting Ghost Image Files to
Drive Image” on page 97.

Restoring Images from CD Drives

Run PQPACKET.EXE before running the Drive Image executable, PQDI. If you run
Drive Image from the main installation directory or from the rescue disks, PQPACKET
will run automatically. If you run the Drive Image from a different directory, you should
browse for PQPACKET and run it manually before running Drive Image.

When you click Browse at the Select Image File screen, your CD drive will display as
\.\pgcdx, where x is the number of the CD drive. Select the drive, and the image file will
display so you can restore it.

Your CD drives may also display with drive letters. However, you should not choose the
drive letter. Instead choose the \\.\pqcdx designation.

Restoring an Image File

1 Disable virus detection in the BIOS.
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If virus protection is enabled, Drive Image may hang after you click Finish to restore
an image file.

2 At the Drive Image main screen, click Restore Image.

3 In the Image File field, enter the path and filename of the image file you want to
restore, or click Browse to select the path and image file.

Restoring an Image

Select Image File

Eriter the image filename, specifying the drive ahd directory. Faor example:
D M IMAGE.POI Click Browse to browse the directory tree for the path and
filenarne.

Image File: | P wiN3E.POI

Erowse |

Image File Comments:

Help | < Back I HNest > I LCancel

You can restore an image file from any physical or logical drive that DOS has
assigned a drive letter, including floppy drives, secondary hard drives, network
drives, and most removable media storage devices.

If you are restoring an image from a CD, refer to “Restoring Images from CD Drives”
on page 28.

You may need to run Drive Image from DOS boot diskettes to access network drives
while running Drive Image.

You can restore an image from a hidden NTFS, FAT, or FAT32 partition by choosing
it from the Open Image File dialog box that appears when you click Browse. A
hidden NTFS partition will appear in the Drives list as \\.\Diskn.Partm, where n is the
number of the disk and m is the number of the partition on that disk. The disk and
partition numbering begins with zero, so the first partition on the first hard disk would
be identified as \\.\DiskO.Part0. To further identify the hidden partition, the volume
label will display, if available.
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If you click Browse and select an image file, you will have an option to verify the
integrity of an image file before you attempt to restore it. Click Verify, and Drive
Image will check to see that all of the segments of the image (such as myfile.pqi,
myfile.002, myfile.003, and so forth) are available for you to open, the internal data
structures in the image file match the data that is available, and the image file can be
uncompressed and create the expected amount of data. Drive Image reports whether
the image file passes or fails the integrity check.

4 Click Next.

At any point prior to actual image file restore, you can click Back to return to the
previous step and change your settings.

5 From the Select Destination Drive dialog, select the disk that includes the
unallocated space or partitions where you want to restore the image file.

If you only have one hard disk, this step is omitted.

6 If you have more than one partition, you can select the partitions you want to restore.
Click partitions to select them individually, or click Select All.

Restoring an Image

Select Image File Partitions

Select the image file partiions ta be restared. Drag column
~ FWINSEPO) borders to

C: D:APPS resize

418.2 ME Active FATI2 4,102.5 MB FATI2 columns.

Letter|Label Size MB

[CD: APPS & FATI2 Nore 41025 2.6 29439 Logical

Select Al | Select None

Help | < Back = LCancel

To deselect partitions, click again on a partition or click Select None.

7 Click Next.

8 Select an existing partition or unallocated space where you want to restore the image.
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The partition list includes all the partitions on your machine. If you have more than
one hard disk, the first column in the partition list shows the disk on which a partition
is located.

Restoring an Image
Select Destination Partition or Unallocated Space

Select a destination partition or unallocated space for the image file partitions.
— Disk 1- 8220 MB

C: D:APPS
4118.2 MB Active FATIZ 41025 MB FAT32

F 3 Fy
Disk [Letter[Label [Tvpe [status | SizeMB] Used ME [Unused MB [PricLog |
1L A FATIZ  Acdtive 4182 11954 29227 Primary '

Mone 49025

Fiesize Source Partitions.... Delete Disk. Partitionz.... |

Help | < Back I HNest > I LCancel

When you restore an image to unallocated space, Drive Image creates a new partition
for the image. The unallocated space where you restore an image must be at least as
large as the used space required by the image. For example, if you created an image of
a 500 MB FAT32 partition that included 300 MB of data, the unallocated space where
you restore the image must be at least 300 MB. If you are restoring an NTFS partition,
note that NTFS partitions require some unused space to facilitate resizing and cannot
be resized below the master file table (MFT), regardless of how much data is included
in the partition.

If the destination partition or unallocated space is not large enough to accommodate
the partitions you wish to restore, or if you are restoring the image file to a larger
drive and want to set a specific size for partitions rather than use the proportional
resize option, you may want to resize the partitions.

If you do not want to resize the partitions, go to step 14.
Click Resize Source Partitions.

The Resize Partitions window displays, and the Selected Source Partitions group
box displays the partitions you selected to restore.

PowerQuest Drive Image
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Resize Partitions

Selected Source Partitions:

Letter | Label Type Status Size MB | Mew Size MB | Used ME |Unuzed MB |Pri-Log

Destination size: 41181
- Size of selected partitions after restare: 4,718.1
= Remaining gpace in destination: 0o

Help | Besize I Accept LCancel

10 Click Resize.

The Resize Partition window appears.
Resize Partition

Maximum Size: 2070.9 MB

New Size: Im 3: ME

Minimurn Size: 360.8 MB

Help | oK I LCancel |

11 In the New Size field, enter the size for the new partition (in MB), then click OK.

The size you enter must be equal to or larger than the Minimum Size and less than or
equal to the Maximum Size displayed in the dialog. Since partitions must end on a
cylinder boundary, Drive Image rounds the new size up to the next cylinder boundary.

12 Click Accept.

When you restore the image file, Drive Image will resize the partition.
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13 Click Next.

If you selected an existing partition as the destination, a message appears to remind you
that the existing partition will be deleted before your image is restored. Drive Image
does not delete the partition until you click Finish on the Ready to Restore Image
File screen; if you cancel the restore process before clicking Finish, your existing
partition will still be there.

If the unallocated space on the destination drive is greater than the space required to
restore the selected partitions, the Resize Options dialog appears. For more
information, see “Resize Options” on page 35.

The Select Disk Write Mode screen appears.

Restoring an Image

Select Disk write Mode

Safe Mode ta check the hard drive while restoring the image. This mode wil
increase the processing time.

o)
hﬁwmﬂ Select Fast Mode to quickly write ta the drive without integrity checking. Select

(" Fast Mode
(% Safe Mode

Safe Mode Options
EHT ¥ Check for Bad Sectors
; I~ Werify Disk Whites

Drive Image

I
o
h=]

< Back LCancel

14 Click Fast Mode to copy data as quickly as possible without integrity checks, or click
Safe Mode to choose integrity checks for Drive Image to perform while copying the
data.

Be aware that choosing Safe Mode can increase the time necessary to copy data. If
you choose Safe Mode, you can choose to check the hard disk for bad sectors and
verify disk writes. Checking for bad sectors is a good idea if your destination disk is
an older model or if you are not sure it is in good condition. If you choose verify disk
writes, Drive Image will check the data after it is copied to make sure it is readable.
Verifying disk writes greatly increases the time required to copy data and is optional.

15 Click Next.
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Drive Image displays all the information you have entered to this point. To change
any settings, click Back.

Restoring an Image

Ready to Restore Image File

Review pour selections. Click Back to change selections.
Click Finizh to restore image file.

| »

Image File: F=~wiiN38-2 POl

Image File Partitions:
[X1C-FAT32

Destination Drive:  Drive 1

Destination Space:
[X1C:-FAT32

[ 1 +: Extended
[1D: APPS FAT32

Resize: Mone
Advanced Options |

< Back

L«

LCancel |

16 (Optional) To enable bad-sector checking, turn on DOS disk-write verification, check
for file system errors, or hide partitions after restore, click Advanced Options. For
more information, see “Advanced Options” on page 36.

IMPORTANT! Restoring partitions can cause the drive letters of subsequent partitions
to change. This may make the computer unbootable or cause
applications to fail.

IMPORTANT! If you are restoring a primary partition that contains an operating
system, and it will not replace your existing primary partition, you
must click Advanced Options and choose to hide the partition after
restoring it. Otherwise, data corruption could occur.

17 Click Finish to begin restoring the image file.

If you assigned a password to the image file when you created it, the Get Image File
Password dialog appears. You must enter the password to restore the image file.
PowerQuest does not maintain image file passwords or have a workaround for
restoring password-protected images without the password.

If Drive Image detects that you are restoring your image file from removable media, it
enables a media-spanning feature that is capable of reading the image file from a

series of disks. As Drive Image prompts you for each media, be careful to insert them
sequentially.
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The Restoring the Image dialog appears, tracking the progress of the image restore.
Upon completion, the following message appears: “Image was restored successfully.”

18 Click OK to return to the Drive Image main screen.

Resize Options

If the unallocated space on the destination drive is greater than the space required by the
partitions you are restoring, you have three options for how to handle the extra space.

Resize Options

There will be unallocated space remaining after

the zelected partition(s) are restored.

Do you wish ba:

(% ALtomatically resize partitions proportionally to fit
" Leave remaining unused space

(" Besize partitions marually to fit

Help oK LCancel

Click this option:

To do this:

Automatically resize
partitions proportionally to
fit

Leave remaining unused

space

Resize partitions manually
to fit

Allow Drive Image to automatically expand the
partitions in equal proportions to occupy the destination
drive’s remaining free space.

Leave any remaining free space unused (unpartitioned)
on the destination drive after the partitions are restored.
This option will retain the original partition size.

Display the Resize Partition window where you can
manually set the size of the partitions to fit in the
destination drive’s remaining free space.

For more information on resizing partitions, see step 9 of
“Restoring an Image File” on page 28 (beginning of
steps).
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Advanced Options

At the Ready To Restore Image File screen, click Advanced Options to access the

following:
Restore Image Advanced Options
W Skip Bad Sector Chec
™ Werify Disk Writes
™ Hide Partitionz After Pestore
Help | Ok I Lancel
Option: Description:
Check for File Clear the Check for File System Errors check box to disable

System Errors

Skip Bad Sector
Check

Verify Disk Writes

error checking.

If you leave this option selected, Drive Image will check your
disk for errors after restoring the image file.

This is selected by default to save time in restoring the image
file.

Although most drives do not have bad sectors, the potential for
problems increases during the lifetime of the hard drive. If you
have an older hard drive, it is wise to enable bad-sector
checking by clearing the Skip Bad Sector Check box.

Click Verify Disk Writes if you want to enable DOS disk
write verification. Disk write verification is not critical to
safely restore image files. Enabling disk write verification can
slow the image restore process significantly.
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Option: Description:

Hide Partition After ~ Restoring multiple logical partitions can cause the drive letters
Restore of subsequent partitions to change. This may make the
computer unbootable or cause applications to fail.

Most operating systems only allow one primary partition to be
visible (bootable) at a time. If you are restoring an image of a
primary partition, and you do not want to make that partition
your visible (bootable) partition, click Hide Partition After
Restore. Failing to do so could cause data corruption.

For example, if you are using your secondary hard drive as a
complete backup of your primary drive, clicking Hide
Partition After Copy preserves all the secondary drive
information without changing any drive letters. When the
computer boots up, a drive letter will not be assigned to the
hidden partition. For more information about hiding partitions,
see “Hiding Partitions” on page 63.

Scenarios

Restoring an Image File from a Zip Drive
Sample System Configuration

One 2.1 GB hard drive containing:

* One 1.1 GB active primary FAT partition (C:) running Windows 95; 600 MB used
and 500 MB unused.
¢ 1 GB unpartitioned free space.

One CD-ROM drive (D:).
One Zip drive (E:).
Objective

Restore a 400 MB logical FAT partition from an image file (MYIMAGE.PQI) that spans
two Zip disks. You wish to restore the logical partition to the unpartitioned free space on
your hard drive and to resize it to 1 GB.

PowerQuest Drive Image
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Procedure
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10
11

12
13

14

15

Run Drive Image.

As Drive Image automatically loads the Zip drivers, be sure to note the drive letter
assigned to the Zip drive. In this case, we will refer to the Zip drive as E:.

From the Drive Image main screen, click Restore Image.
Insert the Zip disk you labeled as “MYIMAGE DISK #1” into your Zip drive.

In the Image File field, type E : \MYIMAGE. PQTI.

You may also click Browse to browse the directory tree for your Zip drive and the
desired image file.

Click Next.
Select the 400 MB logical partition.
Click Next.

Disk 1 should already be selected. Click Next.
This step is skipped if you only have one hard disk.

Select the 1 GB unpartitioned free space.
Click Next.

When the Resize Options window appears, select Automatically resize partitions
proportionally to fit, then click OK.

For information about other options, see “Resize Options” on page 35.
Click Finish.

When Drive Image prompts you to insert the next media in the series, remove
“MYIMAGE DISK #1” from the Zip drive and insert “MYIMAGE DISK #2”.

After Drive Image has completed the image restore, click OK to return to the Drive
Image main screen and exit the program.

Reboot your computer.
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Result

After reboot, your hard drive has an active primary partition (C:) and an extended partition
containing a 1 GB logical partition (D:). Your CD-ROM has changed to drive E: and your
Zip drive is F:.

For information about why drive letters change, run Setup from the Drive Image CD, then
click Documentation » Understanding Hard Drives.

Restoring an Image File from a CD Drive
Sample System Configuration

One 3 GB hard drive containing:

* One 1.8 GB damaged, unbootable active primary FAT partition (C:) containing
Windows 95; 1 GB used and 800 MB unused.

* One 1.2 GB extended partition containing one logical partition (D:); 1.2 GB unused.
One CD-ROM drive (E:).
Objective

Replace your damaged active primary partition (C:) with a backup image of the partition
stored on CD-ROM.

Procedure

1 Ensure you run PQPACKET before starting Drive Image, so Drive Image can
recognize your CD drive.

Type PQDTI and press <Enter>.
From the Drive Image main screen, click Restore Image.

Insert the CD-ROM you labeled as “MYIMAGE DISK #1” into your CD-ROM drive.

au A~ WO DN

Click Browse to browse the directory tree for your CD drive and the desired image
file.

CD drives display as \\.\pgcdx, where x is the number of the drive, beginning with
zero. The name of the drive is also displayed.

If you have a spanned image file, Drive Image will prompt you to insert media when
it needs to display the image filename. You should insert the last media in the series.
(The prompt may appear at this point or after you click Next in step 6.)
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6 Click Next.
7 Select the 1.8 GB primary partition (C:).
8 Click Next.
9 Disk 1 should already be selected.
10 Click Next.
11 Select the 1.8 GB damaged primary partition (C:) on your hard drive.
12 Click Next.
The following message appears:
“Item selected is not unallocated space. Disk Images can only be restored into
existing unallocated space. Drive Image will delete this partition before restoring disk
image. WARNING: Deleting a partition will DESTROY any existing data on that
partition.”
13 Click OK.
14 Click Finish.
Drive Image deletes the C: partition and labels it as unallocated space.
15 When Drive Image prompts you to insert the next media in the series, remove
“MYIMAGE DISK #1” from the CD-ROM drive and insert “MYIMAGE DISK #2.”
16 After Drive Image has completed the image restore, it prompts you to select a primary
partition to set active (bootable). Select the partition you just restored.
17 Click OK to return to the Drive Image main screen and exit the program.
18 Reboot your computer.
Result

The restored primary partition (C:) has replaced the damaged active primary partition (C:).
You should now be able to boot to Windows 95 and operate normally again. Your C:
partition contains all the data that was present on it when you originally created the image

file.

If your computer supports booting from CD, you can also boot your computer with the
Drive Image CD, run Drive Image from the CD, and restore your image file.
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Restoring an Image File from a Secondary Hard Disk
Sample System Configuration

Disk 1—One 3.5 GB hard drive containing:

* One 1.5 GB active primary FAT partition (C:) running Windows 95; 500 MB used
and 1 GB unused.

* One | GB extended FAT32 partition containing one logical partition (E:); 400 MB
used and 600 MB unused.

* 1 GB unpartitioned free space.

Disk 2 — One 2 GB hard drive containing:

* One 1 GB primary FAT partition (D:); 1 GB used by the image file, MYIMAGE.PQI,
and 0 MB unused.

* One 1 GB extended partition containing one logical partition (F:); 600 MB used and
400 MB unused.

Objective

Restore the 1 GB logical partition from the image file, D:\MYIMAGE.PQI to the
unpartitioned free space on Drive 1.

Procedure
1 Run Drive Image.
2 From the Drive Image title screen, click Restore Image.

3 In the Image File field, type D: \MYIMAGE . PQTI.

You may also click Browse to browse the directory tree for your secondary drive and
the desired image file.

Click Next.
Select the 1 GB logical partition.
Click Next.

Select Disk 1.

© N o u

Click Next.
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9 Select the 1 GB unpartitioned free space.
10 Click Next.

11 Click Finish.

12 After Drive Image has completed the image restore, click OK to return to the Drive
Image main screen and exit the program.

13 Reboot your computer.

Result

After reboot, Disk 1 has a 1.5 GB active primary partition (C:) and an extended partition
containing two 1 GB logical partitions (E: and F:). Disk 2 has a 1 GB primary partition
(D:) and an extended partition containing one 1 GB logical partition (G:).
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CHAPTEHR

Copying Disk to Disk

This chapter includes the following information:

Preparation
Procedure
Advanced Options

Scenarios
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Preparation

If you are upgrading to a new hard drive, refer to “Using Drive Image with SCSI Hard
Disks” or “Using Drive Image with Drive Overlay Software” on page 92 if needed.

It is strongly recommended that you perform the following steps before upgrading to a
new hard drive or using Drive Image to copy disk to disk.

» Create a set of Drive Image rescue diskettes. See “Creating Rescue Diskettes under
Windows” on page 5.

» Before running Drive Image, use a disk utility program such as a thorough ScanDisk
or Norton’s Disk Doctor to identify and repair any errors on your hard drive.

* Verify that the destination drive or partition is the same size or larger than the source
drive. You can copy a partition or drive from a larger to a smaller partition or drive.
However, there must be enough unallocated space on the smaller destination to
accommodate the used space on the larger source.

If you are copying from one partition to another partition on the same hard disk, go
directly to the steps outlined under “Procedure” on page 45.

IMPORTANT! If you are using Drive Image to copy a Windows NT partition, refer to
“Copying Windows NT or Windows 2000 Partitions” on page 12 for
information about the BOOT.INI.

Setting Up a Dual Hard Disk System

1 Get the manufacturer’s installation guides for both drives.

The installation guides provide information on installing the drives, setting up the
BIOS, and changing the jumper settings. If you do not have access to these guides,
contact the hard drive manufacturers directly. Most drive manufacturers maintain
sites on the Internet that offer setup information.

2 Turn off the computer’s power.

3 Discharge static electricity by touching a grounded metal object such as a metal filing
cabinet.

IMPORTANT! Do not allow static electricity to contact the inner parts of your
computer. Static electricity can damage or destroy your computer’s
electronic components.

4 Remove the computer’s cover.
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5 Determine which drive you want to be master and which drive you want to be slave,
then follow the manufacturer’s instructions to change the jumper settings on your hard
drives accordingly.

6 Attach the interface cable and the power supply cable to the second drive.
7 Mount the second drive.

8 Start the computer and enter its Basic Input/Output System (BIOS) Setup program
before the computer completes startup.

This is usually accomplished by pressing <DEL>, <F1>, or <F2>, according to the
prompt that appears at the bottom of your screen during initial startup.

9 If the BIOS Setup program includes an Auto-Detect option, select it to detect both the
master and slave drives.

If there is no Auto-Detect option, you may be required to enter the specific number of
heads, cylinders, and megabytes of the drives. This information is usually printed on
the drive’s outside cover. If it is not, contact the drive manufacturer.

10 If the BIOS does not support hard drives larger than 504 megabytes, follow the
destination drive manufacturer’s instructions to install any software included with the
drive.

Computer BIOSs made before 1994 usually do not support the EIDE standard and
cannot address hard drives larger than 504 MB. Hard drives larger than 504 MB
typically include software such as OnTrack Disk Manager, Maxtor Max-Blast Disk
Manager, or Micro House EZ-Drive which allow computers to see larger hard drives.

If your machine does not support the EIDE standard, make sure the software included
with the destination drive is correctly installed.

If Drive Image lists a drive size that is much smaller than its actual size, the EIDE
support software is not functioning properly.

11 Turn off the computer, then restart it.

Procedure

The Disk to Disk feature copies partitions directly from one place to another without
creating an image file.

If you received a demo version of Drive Image, you cannot use the Disk to Disk feature.

PowerQuest Drive Image
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It is not necessary to format your destination partition or to partition your hard drives
before performing a Disk to Disk copy. Drive Image automatically performs both these
functions.

1 At the Drive Image main screen, click Disk To Disk.
The Select Source Drive screen appears.

Disk To Disk Copy

Select Source Drive

Select the drive that containg the partitions to be copied to the destination drive.

8220 C;D:
= -Disk 2 13532 E: F-

< Back I HMext > I LCancel

2 Select the disk or disks that include partitions you want to copy, then click Next.

At any point prior to actually copying partitions, you can click Back to change your
settings.

3 Select the source partition you wish to copy, or click Select All to select all partitions.
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Disk To Disk Copy

Select Source Partitions

Select the partitions to be copied to the destination drive.
— Disk 1- 8220 ME

C: D:APPS
4718.2 MB Active FAT32 4,102.5 MB FAT32

ry

1 o APPS QFAT32 Naone 41025 2006 39019 Logical

Select Al | Select Mong

Help | < Back I Nlewt I LCancel

You may need to scroll to view all the partitions in the list. Note that if you have more
than one hard disk on your machine, the first column in the partition list shows the
physical hard disk where the partition is located.

A check appears to the left of selected partitions. To deselect partitions, click again on
a partition or click Select None to deselect all partitions at once.

4 Click Next.

5 Select the destination drive that includes the partitions or unallocated space where you
want the copied partitions to be stored, then click Next.

6 Select the destination partition or unallocated space, then click Next.
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Disk To Disk Copy

Select Destination Partition or Unallocated Space

Select a destination partition or unallocated space below for the source drive partitions.
— Dizk 2 - 13532 MB

EDATA|| [FBACKUP
20003 +| | 15,5316 ME FAT2Z
Fy Fy
Disk [Letter|Label [1vpe [Status | SizeMB| Used MB [Unused ME [PriLog |
2 * & Unallocated Mone 7.8 0.0 7.8 Primary
2 B DATA Ay FAT Mane 2,000.3 260 19742 Logical

2 F: BACKLP &FAT32 Mane 15,5316 24402 130913 Logical
36 4% Unallocated Mone 4

Besize Source Partitions... |

Help | < Back I HMext > I LCancel

You may need to scroll to view all the partitions in the list. Note that if you have more
than one hard disk on your machine, the first column in the partition list shows the
physical hard disk where the partition is located.

IMPORTANT! To copy partitions, the destination partition or drive must have
unallocated space equivalent to the total used space of the selected
source partition. If you copy to a partition that already includes data,
the existing data will be replaced.

7 If the destination partition or unallocated space is not large enough to accommodate
the partition you wish to copy, or if you are copying the partition to a larger drive and
want to set a specific size for the partition rather than use the proportional resize
option, you can click Resize Source Partitions to specify a different size for the
copied partition. If you do not want to resize the source partition, go to step 12.

8 Click Resize Source Partitions.

The Resize Partitions window appears.
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Resize Partitions

Selected Source Partitions:

Size MB | Mew Size MB

Diestination sizez 41181
- Size of selected partitions after restore: 41181
= Remaining space in destination: 0.0

Help | Resize I Accept LCancel

The Selected Source Partitions group box displays the partition you selected to
copy. The screen also displays the destination size, current size of selected partition,
and remaining free space in the destination.

Otherwise, Click Resize. (If you do not want to make changes, click Accept.)

The Resize Partition window appears.
Resize Partition

Maximum Size: 1023.8 MB
New Size: 500|T =| MB

Minimum Size: 5.9 MB

Help | ak. | LCancel |

In the New Size field, type the size for the partition (in MB), then click OK.

The size you enter must be equal to or larger than the Minimum Size and less than or
equal to the Maximum Size displayed in the dialog.

Since partitions must end on a cylinder boundary, Drive Image rounds the New Size
up to the nearest cylinder boundary.
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NTES partitions require some unused space to facilitate resizing and cannot be
resized below the master file table (MFT), so the minimum size may appear larger
than is necessary to accommodate the data in the partition.

11 Click OK, then click Accept.

Later, when you copy the partition, Drive Image resizes it.

12 Click Next.

If you selected an existing partition as the destination, a prompt will appear reminding
you that the existing partition will be deleted before copying.

Drive Image does not delete the partition until you click Finish on the Ready to
Copy Disk to Disk screen.

13 If the unallocated space on the destination drive is greater than the space required to
copy the selected partition, the Resize Options dialog appears. Click the option you
want, then click OK.

Select this option: To do this:

Automatically resize Allow Drive Image to automatically expand the
partitions partitions in equal proportions to occupy the destination
proportionally to fit drive’s remaining unallocated space.

Leave remaining Leave any remaining unallocated space unused on the
unused space destination drive after the partitions are copied.

Resize partitions Display the Resize Partitions window where you can
manually to fit manually set the size of the partitions to fit in the

destination drive’s remaining unallocated space. (See
step 8 for additional information about the Resize
Partition window.)
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The Select Copy Type screen appears.

Dizk To Disk Copy

TR
: _‘_ Select the copy type below.

Select Copy Type

" Beplace

(OF

Selection Information:
If wou select Backup, the destination partitions will be hidden after they are
copied.

< Back I Hext > I LCancel

14 Select Replace or Backup to indicate why you are running Drive Image, then click

Next.

Select Replace if you are adding a hard disk to your system and using Drive Image to
copy information from your old drive to the new drive.

If you select Replace, Drive Image will hide the source partitions after copying them.
If you select Backup, Drive Image will hide the destination partitions after copying

them.

By hiding either the source or destination partitions, Drive Image ensures that your
drive letters will not change when you reboot your computer. Hiding partitions can
also avoid problems that result when two identical operating system partitions are
visible when you reboot. If you are confident that having both your source and
destination partitions visible will not make your computer unbootable or cause
problems because of drive letter changes, you can click Advanced Options at the
Ready to Copy Disk to Disk screen (see step 17) and change Drive Image’s default

settings.
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The Select Disk Write Mode screen appears.

Dizk To Disk Copy

=

et

Drive Image

 Select Disk Write Mode

Select Fast Mode to quickly write ta the drive without integrity checking. Select
Safe Mode to check the hard diive while copying. This mode will increase the

processing time.

(" Fast Mode
(® Safe Mode

Safe Mode Options
¥ Check for Bad Sectorz
I Werify Disk Wiites

I
@
h=]

< Back.

15 Click Fast Mode to copy data as quickly as possible without integrity checks, or click
Safe Mode to choose integrity checks for Drive Image to perform while copying the

data.

Be aware that choosing Safe Mode can increase the time necessary to copy data. If
you choose Safe Mode, you can choose to check the hard disk for bad sectors and
verify disk writes. Checking for bad sectors is a good idea if your destination disk is
an older model or if you are not sure it is in good condition. If you choose verify disk
writes, Drive Image will check the data after it is copied to make sure it is readable.
Verifying disk writes greatly increases the time required to copy data and is optional.

16 Click Next.
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Drive Image displays all the information you have entered to this point.

Dizk To Disk Copy

~ Ready to Copy Disk to Disk

Review wour selections. Click Back to change selections.
Click Finizh to copy disk to dizk.

Source Drives: Disk 1- 8220 MB

Source Partitions=
[X1C- FAT32

[ 1#: Extended

[ 1D: APPS FATI2

Destination Drive:  Digk 2 - 19532 MB

Destination Space:
[ 13 Unallocated
[ 13¢: Extended
[1E:DATAFAT

F1C-DACKIID CAT2Y

Advanced Options |

Help |

< Back LCancel |

17 (Optional) To alter any settings, click Back. To set options such as disabling file

18

system error-checking or hiding partitions after copy, click Advanced Options. For
more information, see “Advanced Options” on page 54.

Copying multiple logical partitions can cause the drive letters of subsequent partitions
to change. This may make the computer unbootable or cause applications to fail. For
information on why drive letters change, run Setup on the Drive Image CD, then click
Documentation » Understanding Hard Drives.

Click Finish to begin copying the selected partition.

The Copying Disk To Disk dialog tracks the progress. Upon completion, the

following message appears: “Selected partition(s) copied successfully. Would you
like to view the results?”

19 Click OK to return to the Drive Image main screen.

If you ever want to replace the active partition with a hidden backup partition (for
instance, if you lose data from your C: partition), run Drive Image Disk To Disk again.
Select the hidden partition as the source and the active partition as the destination. After

Drive Image completes the copying process, it prompts you to set an active partition.
Select the newly copied partition.
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Advanced Options

The Disk to Disk Advanced Options dialog appears when you click Advanced Options
at the Ready To Copy Disk To Disk screen.

Select this:

Disk to Disk Advanced Options

— S

™ Dizable SmatSector Copying
™ Hide Source Partitions After Copy

— Destination Options
[V Skip Bad Sectar Check

™ Werify Disk Writes
™ Hide Destination Partitions Afer Copy

Help | ak Lancel

To do this:

Source Options

Check for File
System Errors

Disable
SmartSector
Copying

Clear the Check for File System Errors check box if you want
to disable error checking.

If you have already used a disk utility program such as
ScanDisk to check your hard disk for errors, it is not necessary
to have Drive Image check for file system errors. Clearing
Check for File System Errors saves time in copying the
partitions. If you did not run a disk utility program before
loading Drive Image, leave the Check for File System Errors
check box selected.

Drive Image’s SmartSector technology speeds up the copying
process by only copying clusters and sectors that contain data.
However, in some cases, such as high-security environments, it
may be desirable to copy all clusters and sectors in their
original layout, whether or not they contain data.

If you wish to copy both used and unused clusters and sectors,
click Disable SmartSector Copying. Disabling SmartSector
copying increases processing time.
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Select this:

To do this:

Hide Source
Partitions After
Copy

Destination Options

Skip Bad Sector
Check

Verify Disk Writes

Hide Destination
Partitions After
Copy

If you selected Replace at the Select Copy Type screen, this

option is selected by default. Hiding the source partition will
ensure that your drive letters do not change when you reboot
your computer. It can also avoid problems caused by having

two identical operating systems visible when you reboot.

You can use this option to copy an operating system to a new
disk and hide the original partitions. The new partitions will be
active. You can set the new drive to master and the old drive to
slave, reboot and test the new operating system with the old
drive still in place in case something goes wrong.

This option is selected by default to save time in copying the
partitions. Although most drives do not have bad sectors, the
potential for problems increases during the lifetime of the hard
drive. If you have an older hard drive, it is wise to enable
bad-sector checking by clearing the Skip Bad Sector Check
box.

Click Verify Disk Writes if you want to enable DOS disk write
verification.

Disk write verification is not critical to safely copy files.
Enabling disk write verification can slow the copying process
dramatically.

If you selected Backup at the Select Copy Type screen, this
option is selected by default. Most operating systems only
allow one primary partition to be visible (bootable) at a time. If
you are copying a primary partition and you do not want to
make that partition your bootable partition, the Hide
Destination Partitions After Copy box should be selected.

If you are using your secondary hard drive as a complete
backup of your primary drive, selecting Hide Destination
Partitions After Copy preserves all the secondary drive
information without changing any drive letters. When the
computer boots up, a drive letter will not be assigned to the
hidden hard drive. For additional information about hiding
partitions, see “Hiding Partitions” on page 63.
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Scenarios

Copying from Partition to Partition in a Single Hard Disk System

Sample System  One 2 GB hard disk containing one 2 GB active primary partition
Configuration  (C:) running Windows 98; 500 MB used and 1.5 GB unused.

Objective Create a backup of the active partition by copying it to the same
hard disk.
1 Use PowerQuest’s PartitionMagic to resize the existing primary partition to about half

N & u b~ O DN
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the total size of the hard drive (1 GB).

Run Drive Image.

From the Drive Image main screen, click Disk To Disk.
Disk 1 should already be selected. Click Next.

Select the primary partition (C:), then click Next.

Disk 1 should already be selected, then click Next.

Select the unallocated space you created when you resized the primary partition, then
click Next.

If the Resize Options window appears, select Automatically resize partitions
proportionally to fit, then click OK.

From the Ready To Copy Disk To Disk screen, click Advanced Options.
Under the Source Options, clear the Check for File System Errors box.

Under the Destination Options, click Hide Destination Partition(s) After Copy,
then click OK.

Click Finish.

After Drive Image has completed the copying process, click OK to return to the Drive
Image main screen and exit the program.

The computer reboots and returns to Windows 98. Because only one primary partition
may be visible at a time, the new partition does not appear in Windows Explorer.
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Copying from Drive to Drive in a Dual Hard Disk System

Sample System  Disk 1 — One 3 GB hard drive containing:

Configuration

One active 1.5 GB primary partition (C:) running Windows 98;
500 MB used and 1 GB unused.

* One extended 1 GB partition containing one logical partition
(E:); 400 MB used and 600 MB unused.

* 500 MB unpartitioned free space.

Disk 2 — One 2 GB hard drive containing:

* One primary 1 GB partition (D:); 400 MB used and 600 MB
unused.

* One extended 1 GB partition containing one logical partition
(F:); 200 MB used and 800 MB unused.

Objective Copy the E: partition from Disk 1 to the F: partition on Disk 2.

o U A~ O N -
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Run Drive Image.

From the Drive Image main screen, click Disk To Disk.
Select Disk 1, then click Next.

Select the E: partition, then click Next.

Select Disk 2. then click Next.

Select the F: partition, then click Next.

A message indicates that the selected partition will be deleted before copying.

Click OK.

From the Ready To Copy Disk To Disk screen, click Advanced Options.

Under Source Options, clear the Check for File System Errors box, then click OK.
Click Finish.

After Drive Image has completed the copying process, click OK to return to the Drive
Image main screen and exit the program.

The computer reboots and returns to Windows 98. Drive letters stay the same, but the F:
partition now contains the same data as the E: partition.
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CHAPTEHR

Common Partition
Management Tasks

This chapter includes the following information about the Tools menu:

* Displaying Drive Information
* Creating Extended Partitions
* Deleting Partitions

* Hiding Partitions

» Setting the Active Partition



The Tools drop-down menu on the Drive Image main screen lets you manually perform
some common partition-management tasks that Drive Image automatically performs when
it processes image files or when it copies partitions. The Tools menu gives you access to
these useful features without requiring you to create or restore image files or copy
partitions.

Displaying Drive Information

The Display Drive Information option lets you view information about the partitions on
your current hard drive.

* Drive letters ¢ Partition size

e Volume (partition) labels e Used MB in partitions
e Color-coded volume (partition) types e Free MB in partitions

e Status (active partition) e Primary or logical drive

1 At the Drive Image main screen, click Tools » Display Drive Information.

2 From the Physical Drives drop-down list, choose the drive where the partition you
want information about is located.

3 Select the partition from the partition list.

Drive Information Displayed on the Screen (Partition Map)

Several Drive Image dialog boxes include a partition map that shows the partitions on your
hard disk. If the selected hard disk includes logical partitions, they are shown within an
extended partition. Partitions are color coded to indicate the file system type each uses.
For example, dark green indicates a FAT32 partition. In addition, each partition is shaded
to show used and unused space within the partition.

The partition map also shows unallocated space (space not assigned to any partition).

There are triangle indicators on the partition map to mark the 2 GB boot code boundary
and the 1024 cylinder limit. The boundary markers can help you as you restore image files
or set a new partition active. If your operating system requires the boot code to be within
the first 2 GB of the hard disk, for example, you can tell at a glance if the partition is
located in a place that will make it bootable.
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Creating Extended Partitions

If you create an image of a primary partition and want to restore it as a logical partition,
you must first have an extended partition on your hard drive. For example, if you have two
hard disks that each include a primary partition (a bootable C: and a data partition D:) and
you are copying both partitions to a new hard disk that will be your master disk, you
would want the D: partition copied to a logical partition to avoid having two primary
partitions on the new hard disk. Primary partitions on the primary master drive should be

reserved for operating systems only.

It is not necessary to manually create an extended partition when you restore an image of a
logical partition. Drive Image automatically creates an extended partition if one does not

already exist.
1 At the Drive Image main screen, click Tools » Create Extended Partition.

The Create Extended Partition window appears.

Create Extended Partition [ x]

— Physical Diives ————————————— I~ FaT W LinuxSwap [ Unformatted
= Dik 2 - 196532 ME - W FaTaz MW LinuzExt2 [ Unallocated
N NTFS [~ Extended [~ Used
W HPFS [~ Other ™ Unused
E:DATA | IF:BACKUP
2000.3 k| |15.531.6 MB FATIZ2
= r
ParlitinnILetterILabel IType Status I Size MB I Lzed MB IUnused MBE I PriLog I
4 s & Unallacated Mone 78 0o 7.8 Primary
5 S 4y Extended  None 135243 17.5319 1992.4 Primary
E E: DATA Ay FAT None 2000.3 260 19743 Logical
7 F: BACKUP Ay FATI2 None 155316 24402 130913 Logical

19524 Logical

4 Unallocated None

Help [Sreate Cloze

2 Select an unallocated space from the partition list.

If there is no unallocated space on your computer, you must delete an existing
partition to create unallocated space.

3 Click Create.

Drive Image creates an extended partition in the selected free space.

4 Click Close to return to the Drive Image main screen.
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Deleting Partitions

This feature deletes existing partitions to create unallocated space on your hard drive. Be
aware that deleting existing partitions destroys any data they contain.

1 At the Drive Image main screen, click Tools » Delete Disk Partitions.

The Delete Partitions window appears.

Delete Partitions [ x]
— Physical Diives ————————————— I~ FaT W LinuxSwap [ Unformatted
= Dik 1- 8220 MB - W FaTaz MW LinuzExt2 [ Unallocated
N NTFS [~ Extended [~ Used
W HPFS [~ Other ™ Unused
C: D:APPS
41182 MB Active FATI2 4,102.5 MB FAT32
= =

2 #: 4 Extended  None 41025 41025 0.0 Primary
3 O: APPS QFATE Norne 41026 2006 35019 Logical

Help Delete | Cloze |

2 From the Physical Drives drop-down list, choose the disk where the partition you
want to delete is located.

3 Click the partition you wish to delete.

You may need to scroll to view all the partitions on your machine.

4 Click Delete.

The Delete Partition dialog appears, displaying the selected partition and its volume
label.

5 Type OK, then click OK.

Drive Image deletes the partition and displays the message: “Volume <volume name>
was deleted successfully.”

6 Click Close to return to the Drive Image main screen.
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Hiding Partitions

The Hide/Unhide feature allows you to protect partitions from unwanted user access.
Hidden partitions are not accessible because they are not assigned drive letters when you
boot your computer. If you unhide a partition, it is assigned a drive letter the next time you
boot your computer and becomes accessible again.

Before hiding and unhiding partitions, be aware of the following restrictions.

* Hiding or unhiding a partition can cause the drive letters of subsequent partitions to
change. This may make the computer fail to boot or cause applications to fail. For
information on why drive letters change and how to fix them, run Setup from the
Drive Image CD, then click Documentation » Understanding Hard Drives.

e If your hard drive contains more than one primary partition, only one is visible by
default. When you use the Set Active Partition feature, Drive Image unhides the
selected primary partition and automatically hides all other primary partitions. See
“Setting the Active Partition” on page 64.

* Because a hidden partition is not bootable or accessible, if you hide the partition
where Drive Image is installed, you must re-install Drive Image on your new active

(bootable) partition to run it again.

To hide/unhide a partition,

1 At the Drive Image main screen, click Tools » Hide/Unhide Partitions.

The Hide Partitions window appears.

Hide Partitions E
— Physical Drives —————————————— = FaT M LinuzSwap [ Unformatted
=3 Dick 1- 8220 MB - W FaTa2 W LinuzExt2 [ Unallocated
B HIFS ™ Estended [~ Used
W HPFS I~ Other I Unused
C: D:APPS
4,118.2 MB Active FAT32 4,102.5 B FATI2

Help |

43 Entended
oy FAT32

Mone
Hone

41025
41025

41025 0.0 Primary
200.6 38013 Logical

Hide Close
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2 Click the partition you want to hide.

Normally when you select a partition, the Hide button becomes available. If the
button is not available, the partition can’t be hidden.

3 Click Hide to hide the selected partition.

The partition status changes to “Hidden.”

4 Click a hidden partition.

Normally when you select a partition, the Unhide button becomes available. If the
button is not available, the partition can’t be unhidden.

5 Click Unhide to unhide the selected partition.

The partition status changes to “None.”
6 Click Close to return to the Drive Image main screen.
7 Click Exit to exit Drive Image.

8 Reboot your computer.

Setting the Active Partition

The Set Active Partition feature allows you to make a primary partition the active
(bootable) partition. Only one primary partition can be active at a time. To be bootable
under most operating systems, a primary partition must be located on the first (master)
drive, and it must contain an operating system. When your computer boots, it scans the
partition table of the first drive to find the active partition, then boots from that partition.

WARNING! Before you set an active partition, be sure it is bootable. If it is not bootable
or if you are not sure, locate the boot disk you created when you installed
Drive Image. If you restart your computer and it does not boot normally,
you must boot from the floppy disk, run Drive Image from the program disk
you created during Drive Image install, and set a different partition active.
Refer to “Drive Information Displayed on the Screen (Partition Map)” on
page 60 for explanations of the Drive Image screen that may also help you
determine if your partition is bootable.

1 At the Drive Image main screen, click Tools » Set Active Partition.

The Set Active Partition window appears.
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Set Active Partition [ x]

— Physical Drives

IQ Digk 1- 8220 ME -

I~ Far W Linux Swap
W FaTaz W Linus B2
N NTFS [~ Extended

W HFFS [~ Other

[~ Unformatted
N Unallocated
[~ Used

™ Unused

C:
|4,11B.2 ME Active FAT3Z

ID:APPS
4.102.5 MB FAT32

=
3 D= APPS Ay FAT2

Help |

3 Click Set Active.

4 Click Close.
5 Click Exit to exit Drive Image.

6 Reboot your computer.

4,102
41025

Set fctive

Used MB |Unused MB | Pri-Log

102.5
2006 39019 Logical

.0 Primary

Cloze

2 Select a primary partition that is not currently active.

The status of the selected partition changes to “Active.”
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CHAPTEHR

Drive Image File Editor

This chapter includes the following information:

Overview

Drive Image File Editor—Main Screen
Modifying Images

Restoring Files or Partitions

Verifying Image Contents

Deleting Image Files

Displaying Information About Images
Displaying Information About Partitions
Drive Image File Editor Options
Online Help

Exiting Drive Image File Editor
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Overview

PowerQuest's Drive Image File Editor simplifies management of your image files.
Working within a single screen, Drive Image File Editor gives you total control of the
image files you can access. You can view image file contents, copy image files, copy
partitions within files, restore individual program and data files from the image, or add
password protection to image files.

Drive Image File Editor also provides description capabilities, so you can easily identify
individual image files and partitions.

Drive Image File Editor runs under Windows 95, Windows 98, Windows NT Workstation,
and Windows 2000 Professional.

Drive Image File Editor—Main Screen

The Drive Image File Editor main screen is divided into three panes: Locate, Recent, and
Contents.

.ﬂ Drive Image File Editor | _ (O] x|
File Edit “iew RBecent Tools Help
=] E B 4 Powe
Up Refresh Festore AddEntry | Properies  Help " ST |
‘anate Folders/lmages Contents of F:A\DECE-93.POI*
I Locate | Recent | Mame | Dirive Letter | File System | FiifLog | Date
=8 My Computer o) | ECWwINGE C F&T32 F'rim.ary 1243018500 P
EE= N /=D DATA ) o] F&T32 Logical 12430118 5:00 P
F=h O E: [BACKUP ] E F&T Logical 12430118 5:00 P
=3 WiIN 950
=3 DATA D]

-3 BACKUF [E)
-] Datakeeper Backup o
-] POSC

-(_]] RECYCLED

=-[2] SEPT21.POI

-3 IMAGES [F)

-3 Fun

-] Images

(] License Agreements
(] License Agreements 1
£ PSFONTS

--(_]] RECYCLED

SEF O E CE-55 PO
-[2] JENNIFER.PQI

[]---@ Nowl7-2.pagi

=[] Nov17 POl

1G] B

[+

ke

-
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Screen area: Description:

Locate pane Displays a tree view of all the drives on your machine (local hard
disks and network drives).

Recent pane Displays a tree view of image files you have browsed to or opened
recently. You can clear the list of recent images by clicking Recent
» Clear Recent Images List.

Contents Displays the contents of the selected drive, folder, image file, or
partition.
Toolbar Provides quick access to common tasks. You can display or hide the

toolbar using the View menu. You can also use the View menu to
determine whether to display text labels on the toolbar buttons.

Status bar Displays a brief description of the toolbar button where the pointer
is located. You can display or hide the status bar using the View
menu.

Modifying Images

You can use the Copy to Image feature in Drive Image File Editor to copy single or
multiple partitions to new or existing image files. When you copy a file, partition, or
image, you also have an option to set the compression level for the resulting image, add a
password to the image, or split the image into multiple files.

Copying Partitions to an Image File

You can drag and drop partitions from one image file to another, or you can copy partitions
using the Edit menu. Copied partitions will not overwrite any partition already in an
image file. Therefore, you can have several partitions with the same name or drive letter
within one image file.

There are several methods to copy partitions or image files:

* Drag and drop the partition or image from the Recent or Locate pane onto a drive or
folder in the Locate pane.

* Drag and drop a partition within an image file onto another image file or onto a folder
in the Locate pane.

* Select a partition, click File » Copy to Image.
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» Right-click a partition, click File » Copy to Image.

* Select a partition, click Edit » Copy, move the insertion point to the new location,

then click Edit > Paste.

What you copy:

Result:

Entire .PQI image file

The Copy to Image dialog appears with the Destination

image text box filled in according to the currently
selected drive or folder in the Locate pane.

Partition within an image
file

If the partition is copied to another image file, the Copy
to Image dialog appears and the partition is added to

the image file and inherits the characteristics of the
target image file including compression ratio,
password, and so forth. If the partition is copied to a
folder, the Copy to Image dialog is displayed and the
partition is added to a newly created .PQI image file.

The Copy to Image dialog box displays the filename for the image file you are modifying
(or allows you to type a filename for a new image file). It also allows you to split an image
file, combine files that make up a spanned image, add a password to an image, and choose

the compression level for an image.

Copy to Image

Copy the following partitions:

Destination image:

[2] F:\Dect-39.pai
-0 E:[BACKUF )

|F:\BACKUP Pl

" | Eppend|partitions ta image:

~

—Destination image information
Dezcription:

with September 2000 archive files
added

C: and D: backup August 20,1933,

—Compression level—————————————
" Mone
i« Low

" High

I~ Splitimage into segments
FEile size (Eytes]:

IB?DDDDDDD

Image Shield

= Set password
Easzmnrd:

(St passward:

Copy I

Cancel
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Splitting an Image into Multiple Files

Use Split to save an existing image file across a series of removable media disks (for
example, floppy disks, Jaz, or Zip disks). You can use Drive Image File Editor to split
image files after they have been created. You can save split image files to a network drive
and later transfer the files to removable media, such as a CD-ROM.

You split an image by copying the whole image or selected partitions to a new image file
and then splitting the new image file.

6

Copy the image file you want to split from the Locate or Recent pane into the Locate
pane.

The Copy to Image dialog appears.
Under Destination image, type a path and filename for the new image file.
Select Split image into segments.

Type a maximum size for each segment of the image file.

For example, if you want to create an image file that will later be saved on CDs, type
670000000.

Specify any other options for the new image file (such as a description, a password, or
a compression level).

Click Copy.

When you split an image file, you are automatically prompted for new media when the
image file reaches the size you specified or when media in a removable device is full.

Combining Files that Make up an Image

If you select a file that is part of a split image (an image that is split across several files)
and copy the file to a new image file, Drive Image File Editor automatically combines all
the pieces of the image in the new Destination image.

You must ensure that the Split image into segments check box is not selected, or the new
image file will be split at the specified size instead of combined into one file.

This feature is useful if you have an image file stored on removable media, but you want to
save it on a network directory or your hard disk.
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Adding a Password to an Image

5

Copy the image file you want to add a password protection for from the Locate or
Recent pane into the Locate pane.

The Copy to Image dialog appears.
Under Image Shield, click Set Password.

Type the password in the Password and Confirm password fields.

Passwords are case-sensitive. Store the password in a safe place, since you cannot
copy, modify, or restore a password-protected image file without typing the
password. You also cannot change a password for an image file without knowing the
current password assigned to that image. PowerQuest does not have a workaround to
access password-protected image files if you lose the password.

Specify any other options for the new image file (such as a description, a compression
level, or a split size).

Click Copy.

Compressing Image Files

2

3

Copy the image file you want to compress from the Locate or Recent pane into the
Locate pane.

The Copy to Image dialog appears.
Under Compression Level, click the level of compression you want.

None No compression is usually the fastest method for saving the image
file and is useful if storage space is not an issue. However, if you are
saving your image file to a busy network drive or to a relatively slow
removable media device, it may be faster to compress the image
since there is less data to write to the file.

Low Low compression offers a 40% average compression ratio.

High High compression offers a 50% average compression ratio.

Specify any other options for the new image file (such as a description, a password, or
a split size).

4 Click Copy.

Chapter 6: Drive Image File Editor



Adding or Changing an Image File Description

2

3

4

Copy the image file you want to add a password protection for from the Locate or
Recent pane into the Locate pane.

The Copy to Image dialog appears.

Under Description, type comments about the image file.

Comments cannot exceed 232 characters.

Specify any other options for the new image file (such as a password, a compression
level, or a split size).

Click Copy.

Restoring Files or Partitions

You can use Drive Image File Editor to restore individual files or partitions from within an
image file. You can restore individual files or folders from spanned or compressed images
without restoring the entire image file.

o A~ O DN

From the Locate or Recent pane, double-click the image file that contains the partition
with the files you want to restore.

(If applicable) Type the image file password, then click OK.
Double-click the desired partition.
Select the folder or files you want to restore.

Click File » Restore.

You can also drag a file into the desired location to restore it or right-click a file and
choose Restore from the quick menu.

If you selected an image file that was created with an older version of Drive Image or
Drive Image File Editor, a progress bar displays while the Drive Image File Editor
expands the image index. To speed up the process with older image files, refer to
“Working with Images from Previous Versions of Drive Image” on page 74.

Click To this destination, then specify the location where you want to save the
restored files. Click the browse button to navigate to the location you want.
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You can also click Restore to original path if you want to restore the folders or files
to their original location. If the original location does not include a drive letter
(because the partition was hidden when you imaged it), you must enter a drive letter
for the partition before you can restore it.

7 Click Restore to restore the files.
8 When file restoration is complete, click OK.

9 Click Close to return to the Drive Image File Editor main window.

Working with Images from Previous Versions of Drive Image

If you restore files from an image that was created with an earlier version of Drive Image
File Editor (before Drive Image 4.0), you can do one of the following to speed up the
process. Note that these procedures are optional.

* Ensure that the index file (*.PQX) for the image is saved in the same directory where
the image is saved. If Drive Image File Editor finds the index file in the same
directory, it will use that index file instead of creating the index during the restore.

* If you do not have an index file for the image, you can use Drive Image File Editor to
copy the image into a new 4.0 image file.

Verifying Image Contents

Use Verify Image to determine whether an image file is valid or corrupt. Drive Image File
Editor will check to see that all of the files in the image are available for you to open, the
internal data structures in the image file match the data that is available, and the image file
can be uncompressed and create the expected amount of data.

This feature is useful if you have added partitions to an image and want to verify the
integrity of the image.

1 From the Locate or Recent pane, select the image file you want to check.
2 Click File » Verify Image.
3 When the check is complete, click OK.

You can also right-click an image file, then click Verify Image from the quick menu.
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Deleting Image Files

Use Delete to remove an entire image file, including all partitions, folders, and files. If you
delete an image file that resides on your local hard disk, it is sent to the Windows Recycle
Bin.

1 From the Locate or Recent pane, select the image file you want to delete.

You cannot delete individual partitions or selected files or folders within an image
file.

2 Click File » Delete Image.
3 Click Yes to continue or No to cancel.

You can also right-click on an image file, then click Delete Image from the quick menu or
delete the image using Windows Explorer.

Displaying Information About Images
1 From the Locate or Recent pane, select the desired image file.
2 Click File » Properties, or right-click the image file and click Properties.
The following list describes each option in the Image Properties dialog.

Description A user-assigned comment associated with the partition.
MS-DOS name A user-assigned name for the image.
Image size The total size of the image.
Image date/time The date and time that the image file was created.

Spanned Whether the image file is spanned over several disks or split
into multiple files on the same disk.

Compression Whether the selected partition is compressed or
uncompressed. The level of compression (Low or High) is
also specified. Low level compression yields an approximate
40% compression rate. High level compression yields
approximately 50%.

Password Whether the image is password protected.
Protected
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3 Click OK to exit the dialog.

Displaying Information About Partitions

1 From the Locate or Recent pane, double-click the image file that contains the desired
partition.

2 Select the partition you want.

3 Click File » Properties, or right-click partition and click Properties.

76

Display name
Description

Drive letter

A user-assigned name for the partition.
A user-assigned comment associated with the partition.

The partition drive letter.

Type The file system type (for example, FAT, NTFS, and HPFS)
used within the partition.
Primary/Logical The selected partition's drive status as either primary or

Partition size

Used space in
partition

Unused space in
partition

Physical size in
image

logical.

The total size of the partition. This total includes both used
and unused space.

The amount of used space within the partition.

The amount unused space within the partition.

The actual size of the partition within the image file. This
physical size may differ from the partition size depending
upon the amount of used and free space within the partition
and the compression level.

4 Click OK to exit the dialog.
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Drive Image File Editor Options

You can specify a default restore path or a default size for image files. The default size is
that size at which images will be split during a copy. This size will display in the Copy to
Image dialog.

1 Click Tools » Options » General.

2 (Optional) Specify the full path to the default restore location.

This path is used if you do not initiate a file restore using drag and drop or copy and
paste.

3 (Optional) Specify the default byte size for splitting an image file.

For example, if you want to save the file to the hard disk and later copy it to a CD, you
could specify a file size of 670,000,000 bytes (670 MB) or less.

4 Click OK.

You can also specify filename extensions that will display in Drive Image File Editor as
image files.

1 Click Tools » Options » Image Extensions.

2 Type the image file extension in the Extension text box.

File extensions can be up to three characters long and can contain alphanumeric
characters. You do not need to type the period. It will be added automatically.

3 Click Add.

4 Repeat steps 2 and 3 to add more file extensions, or click OK.

All image files that match the extensions you have added to the list are displayed in
the Locate and Recent panes.

To remove an extension, select it from the list box, then click Remove. To erase all
extensions you have added, click Clear. Note that *.PQI cannot be removed from the list.

Online Help

1 Click Help » Contents.
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2 Select the help topic you want to display, or click Index or Search to search for the
topic you want.

Exiting Drive Image File Editor
1 Click File > Exit.

When you run Drive Image File Editor again, your previous view settings will be used.
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Getting Started

PowerQuest DataKeeper provides an easy way for you to perform secure, automated
backups of all your important data. You can back up to your local hard disk, a second
partition that has an assigned file system (such as FAT32) and drive letter, a network drive,
or removable media such as LS-120, Jaz, or Zip drives. You can use DataKeeper to:

* Back up combinations of files and folders on your computer with options such as
password protection and file compression.

* Restore a single file (even from a compressed backup), a most recent version of a file,
or an older version of a file.

DataKeeper System Requirements

Before you install DataKeeper, you should ensure your computer meets the minimum

system requirements.

Operating .
system .

Windows 95b (or later)

Windows 98

Windows Me

Windows NT 4.0 Workstation (through Service
Pack 6)

Windows 2000 Professional

Hard-disk space 4 MB
File Systems FAT, FAT32, or NTFS

Monitor VGA or higher resolution

Installing and Configuring DataKeeper

The installation of DataKeeper involves two processes:

» Install DataKeeper. If you are running Windows NT or Windows 2000, you must
have adminstrator privileges to install DataKeeper.

* Configure the backup locations. Following installation, when you run DataKeeper
for the first time, you will need to specify the primary and substitute backup locations.
If there are multiple users sharing a single computer (usually under Windows NT or
2000), each user must run DataKeeper and setup their own primary and backup

locations.

It is recommended that you use the program’s defaults to simplify the installation and to
make file restoration easy and quick.
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1 Insert the DataKeeper CD into the CD-ROM drive.

2 Click Install in the DataKeeper setup window, then follow the on-screen instructions
to install the program.

3 When the setup is complete, deselect Yes, I want to launch DataKeeper, then click
Finish.

If the DataKeeper setup window does not appear automatically on screen, you can install
the program manually:

1 From the Windows taskbar, click Start » Run.

2 Type D:\SETUP in the Open text box.

3 If your CD-ROM drive uses a letter other than D, substitute that letter for D.
4 Click OK, then follow the on-screen instructions to install the program.

5 When the setup is complete, deselect Yes, I want to launch DataKeeper, then click
Finish.

If you are a system administrator, you are finished installing the program; each user must
now configure the primary and backup locations for their monitored files.

Configuring the Backup Location

The first time you start DataKeeper, you will be prompted to specify a primary and
substitute backup location for your monitored files. If you click Cancel anytime before
you complete the backup configuration, you will exit DataKeeper.

1 Start DataKeeper from the Windows taskbar.

DataKeeper

Biefore vou can begin monitaring drives, you must select locations where files can be
saved.

There are bwo backup locations: primary and substitute. If the primary backup location iz
unavailable, files will be backed up to the substitute location.

‘When the primary location becomes available, files will be moved from the substitute
location to the primary location.

Cancel HElR
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2 Click Next.

3 Type the full path to the primary backup location in the text box, then click Next. The
primary location can be a fixed local hard disk, a network disk, or removable media
such as LS120, JAZ, or Zip drives.

4 If the primary backup location you typed in step 3 is a fixed local hard disk, skip to
step 5 below; you do not need to specify a substitue backup location.

5 Otherwise, type the path to the substitute backup location in the text box, then click
Next. The substitute location must be a fixed local hard disk on your machine. If the
primary backup location is unavailable, your files will be stored in this substitute
backup location.

6 Click Finish.

7 Itis recommended that you create an initial back up of your files. To do so, click
Back up now.

8 You can now select to back up all files that meet the specified backup criteria (the
default choice), or you can limit the backup to files that have been created or modified
since the last backup or a specific date and time.

9 Click OK to begin the backup.

Monitoring Your System

DataKeeper is set up, by default, to monitor changes to all fixed drives on your system and
to automatically create a backup of any file that you save to your hard disk. The program
file directories, the directories specified by the environment variables Temp and Tmp, and
your primary backup location, are excluded from the automatic backup to minimize
backup time and system impact. If you want to back up these and other types of files, you
can add them as described in “Creating Custom Backups” on page 83.

Monitoring, or automatic backup, remains in effect on your system as long as DataKeeper
is running, or until you click Stop Monitoring from the Backup tab.

To restore a backed up file, see “Restoring Backups” on page 86.
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Creating Custom Backups

DataKeeper has many options, beyond the default settings, that let you customize how

your data is backed up. You can even save all the options you select to a backup
specification file (.DKS) for later use.

1 From DataKeeper, click the Backup tab.

If necessary, click Stop Monitoring to access the backup options on the Backup tab.

& Untitled - D ataKeeper A=l

File “iew Help

— Select folders to monitor

LI 3% Flappy ()

- W20 BACKUP [F)

—Files to backup
Specify File Types...

— Option
|5 3: Mumber of versions ta keep

¥ Keep dailp/weekly/monthly archive
™ Compress backup files

™ Lock backup files uzing pagzword

~Run

— Backup location:
Primary [active)

|F:\DKBAEKUP

Substitute if primary unavailable

Browsze. . | ‘

Start Monitoring |

Or

Back Up Now. .. |

Brawse... | ‘

For Help, press F1

2 Choose the following backup options:

Option: Description:

Select folders ~ In the Select folders to monitor group box, select the folders you
to monitor want to monitor and back up.

Specify file In the Files to back up group box, click Specify File Types.
types Verify the file types you want to include in the backup (if they are

found in the monitored folders), and the files types you want the
backup to ignore.
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Option:

Description:

Specify file

types
(continued)

Backup
location—
Primary

Backup
location—
Substitute if
primary
unavailable

Number of
versions to
keep

To move file types between the Backup Files Matching and
Ignore Files Matching list boxes, select the files you want, then
click the appropriate arrow (<< or >>) to move the files.

To add more file types to a list box, type *.<file extension> in the
Add file type text box, then click << or >>.

To delete file types, select the extensions you want, then click
Delete.

In the Backup locations group box, verify the specified primary
backup location. Or, click Browse to select a new location for the
backup. The primary backup location can be a fixed local hard
disk, a network disk, or removable media such as LS120, JAZ, or
Zip disks. The word “(active)” will appear at the end of the option
name “Primary” to indicate that the backup location is in effect. If
the primary backup location becomes unavailable, the “active”
status is applied to the substitute backup location.

In the Backup locations group box, verify the specified substitute
backup location if the primary location is unavailable, or click
Browse to select a new substitute backup location on your hard
disk. The word “(active)” will appear at the end of the option
name if the primary backup location becomes inactive
(unavailable). This helps you identify that the substitute backup
location is in effect.

In the Options group box, specify the number of backup versions
(1-99) you want to keep. File versioning lets you go back to a
previous backup if you have made an unwanted change to a file,
or the current backup becomes corrupted. You should check the
date and time of the backups to determine which version you
want to restore.
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Option:

Description:

Keep
daily/weekly/
monthly
archive

Compress
backup files

Lock backup
files using
password

In the Options group box, select Keep daily/weekly/monthly
archive.

This option maintains archive copies, even if the number of
copies has been exceeded. For example, if you specify that
DataKeeper keep the last five versions of a backup, then you
select Keep daily/weekly/monthly archive, DataKeeper does the
following:

* Saves the most recent five versions of the specified files.

* Overwrites the five files in rotation, replacing the oldest file
each time.

* Saves up to seven daily, five weekly, and 12 monthly archive
copies in addition to the five most recent files.

* Does not create a daily, weekly, or monthly version of files
that have not changed since the last backup.

In the Options group box, select Compress backup files.

Compressing files during backup will use less hard disk space.

In the Options group box, select Lock backup files using
password, type the password you want in the Password and
Confirm password text boxes, then click OK.

Passwords are case-sensitive. When you restore a
password-protected backup, DataKeeper will prompt you for the
password. If you do not enter the correct password, or you forget
the password, you will not be able to open the backup file.

3 (Optional) Save all the backup options you have chosen to a backup specification file
(.DKS) for later use. Click File » Save, type the filename for the backup specification
file, then click Save.

This step is helpful if you often select different options based on the type of data you
are backing up. You can later retrieve the .DKS file for use with other backups you
create. To retrieve the .DKS file, just click File » Open, select the backup
specification file you want, then click Open; all your backup options will be set.

4 It is recommended that you do an initial back up of your newly-customized backup
set. To do so, click Back Up Now.
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You can now select to back up all files that meet the backup criteria you specified (the
default choice). Or, you can limit the backup to those files that have been modified
since the last backup, or created or modified since a specific date and time.

5 Click OK to begin the backup.

6 After you have created an initial backup, click Start Monitoring to have DataKeeper
run in the background and automatically back up files that are changed.

The custom backup options you have selected remain in effect until you change them
again.

Mobile Support

If you are using a laptop computer remotely and the primary backup location (a network
disk) is unavailable when a backup is made, the files are automatically saved to the
substitute backup destination. You can change the substitute location by clicking Browse
to the right of the Substitute if primary unavailable text box in the Backup tab.

If the current backup location is the substitute destination, then at startup when monitoring
is enabled and the primary location (a network disk) is detected, you are prompted to
change your substitute backup location to the primary location. When you change to the
primary location, any backup files are copied to the specified primary location and deleted
from the substitute location.

If you choose not to change your substitute backup location to the specified primary
location, you will be prompted with the same message when monitoring is restarted and
the primary location is detected.

Restoring Backups

You can restore backed up individual or multiple files or folders in one simple operation.
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1 From DataKeeper, click the Restore tab.
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2 Select the backup location, then click OK.

If you only have files at one backup location, skip this step and go to step 3.

3 Select the files, folders, and drives you want to restore.

4 Select Only display most recent version to list only the most recent backed up
version of each file. Deselect the option to see all file versions. You can only restore

those items that you have backed up using DataKeeper.

5 Select the destination folder or drive from the drop-down list, or click Browse to

select the destination folder you want.

If you do not specify a destination folder, the items will be restored to their original

locations.

6 Click Restore to begin file restoration.

Viewing Versions of Backups

1 From DataKeeper, click the Restore tab, then go to the backup location.
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2 Check the Tag and Version columns of the Contents pane. You may need to scroll to
the right to see the columns. The Version column displays the following information:

* D - Daily backup
* W - Weekly backup
* M - Monthly backup

The Version column is blank for files that are not archived files.

The tag values in the Tag column (for example, aa, ab, or ac) are unique identifiers and are
unrelated to the sequence or age of the backup.

Starting DataKeeper from a Windows Shortcut

When you start DataKeeper from a Windows shortcut on the desktop, DataKeeper will
automatically run the backup specification file that you name. You may find it helpful to
create a shortcut for each backup specification file that you have saved.

1 Follow the Windows online Help instructions for creating a shortcut on your desktop.

2 In the Command line field of the Create Shortcut dialog, enter the full path to the
DataKeeper program (DATAKEEPER.EXE).

3 (Optional) At the end of the full path (to the right of the double quote mark) in the
Command line field, add one or more of the following commands described below.

The order that you add each command line option is not important.
Command Line Options
Be sure you replace [*.DKS] with the name of your actual backup specification file.

Command
Line option:  Description:

[*.DKS] Starts DataKeeper and loads the backup specification file you named.
Example:

"C:\Program Files\DataKeeper\DataKeeper.exe" C:\My
Backup Specs\Manuals.dks

-c [*.DKS] Starts DataKeeper, loads the backup specification file you named, and
starts monitoring. Example:

"C:\Program Files\DataKeeper\DataKeeper.exe" -c
C:\My Backup Specs\Manuals.dks
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Command

Line option:

Description:

-r [*.DKS]

-m

-s="“date”

Starts DataKeeper, loads the backup specification file you named,
performs a backup, then exits DataKeeper. Example:

"C:\Program Files\DataKeeper\DataKeeper.exe" -r
C:\My Backup Specs\Manuals.dks

Use with the -r option. Starts DataKeeper, loads the backup
specification file you named, performs a backup of all selected files,
then exits DataKeeper. Example:

"C:\Program Files\DataKeeper\DataKeeper.exe" -r -a
C:\My Backup Specs\Manuals.dks

Use with the -r option. Starts DataKeeper, loads the backup
specification file you named, performs a backup of those files that
were modified since the last backup was performed, then exits
DataKeeper. Example:

"C:\Program Files\DataKeeper\DataKeeper.exe"-r -m
C:\My Backup Specs\Manuals.dks

Use with the -r option. Starts DataKeeper, loads the backup
specification file you named, performs a back up of only those files
that were modified after the date you specify, then exits DataKeeper.
The date must be in quotes and formatted as follows:-s="yyyy/mm/dd
hh:mm:ss.” Example:

"C:\Program Files\DataKeeper\DataKeeper.exe"-r C:\My
Backup Specs\Manuals.dks -s="2000/07/25 9:15:00"

Getting Help

When you need information beyond what this Quick Start Guide provides, online Help is
your best solution. Click Help in any dialog in DataKeeper, or click Help » Help Topics

on the menu bar.

Exiting DataKeeper

1 From DataKeeper, click File » Exit.

This will close DataKeeper, and no files will be backed up.
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Clicking the “~" near the upper-right corner of the DataKeeper window will minimize the
program to the Windows system tray.
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A PPENDI

Additional Tasks

This appendix includes the following information:

Using Drive Image with SCSI Hard Disks

Using Drive Image with Drive Overlay Software
Using Drive Image on a Notebook Computer
Using Drive Image with a Castlewood ORB Drive
Assigning a CD-ROM Dirive Letter

Converting Ghost Image Files to Drive Image
Using International Keyboards

Finding Jumper Settings
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Using Drive Image with SCSI Hard Disks

To use Drive Image on a SCSI hard drive, you must have a SCSI controller card that
supports software Interrupt 13. Most SCSI controller cards let the user enable software
Interrupt 13 support in the BIOS through the card. If your SCSI controller card does not
allow you to set it to use software Interrupt 13, Drive Image will not work on drives
attached to your SCSI adapter. Contact the manufacturer of the SCSI adapter to determine
if your adapter can support software Interrupt 13. As a general rule, if FDISK can be used
to partition the drive, you can use Drive Image.

Using Drive Image with Drive Overlay Software

Drive overlay software is needed, such as Disk Manager or EZ-Drive, if the system has an
older BIOS and the disk copy is being made from IDE to IDE or IDE to SCSI.

IMPORTANT! If copying SCSI to SCSI, the older BIOS does not come into play because
SCSI has its own translation mechanism.

This section provides information on both IDE and SCSI hard drive installations. The
following are scenarios which outline, step-by-step, the installation procedures for a
variety of system configurations.

Scenario 1
* The system has a BIOS that does not support drives over 504 MB in size.

e The source drive is an IDE drive that is smaller than 504 MB. It does not have a drive
overlay program.

» The destination drive is an IDE drive that is larger than 504 MB and needs to have a
drive overlay program to be recognized by the older BIOS.

Steps

1 Install the destination drive as the master and the source drive as the slave and run the
auto-detect in the BIOS.

2 Restart the computer with the drive overlay boot disk.

3 Install the drive overlay program to the destination drive that is now set as the master
(check with manufacturer).

4 Restart the computer again, allowing the drive overlay program to load.
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5
6
7

8

Put your Drive Image bootable diskette in your diskette drive (A:).
In the drive overlay boot menu, select the option to boot from a floppy disk.

Make sure that Drive Image is showing the correct size for each drive and the correct
order for the copy sequence.

Finish the copy process.

Scenario 2

The system has a BIOS that does not support drives over 504 MB in size.

The source drive is an IDE drive larger than 504 MB and a drive overlay program is
loaded.

The destination is a SCSI drive and will not need a drive overlay program.

Steps

0 N O u »~ O DN

9

Leave the source drive set as the master.

Install the SCSI drive with the lowest SCSI ID in the SCSI chain.

Run the BIOS auto-detect and make sure it recognizes the IDE drive.

Run the SCSI BIOS to make sure the SCSI drive is recognized correctly.
Restart the computer and allow the drive overlay program to load.

Put your Drive Image bootable diskette in your diskette drive (A:).

In the drive overlay boot menu, select the option to boot from a floppy disk.

Make sure that Drive Image is showing the correct size for each drive and the correct
order for the copy sequence.

Finish the copy process.

Scenario 3

The system has a BIOS that does not support drives over 504 MB in size.

The source drive is an IDE drive larger than 504 MB and a drive overlay program is
installed.

The BIOS is upgraded to a BIOS that supports larger drives.
The destination drive is a SCSI drive that is larger than 504 MB.
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Steps

O 0 N &0 U0 h~ O DN

10

Leave the source drive set as the master.

Install the destination drive and set it as drive 0.

Run the BIOS and auto-detect the drives.

Make sure that LBA is off for the source drive.

Run the SCSI BIOS to make sure the SCSI drive is recognized correctly.
Restart the computer and allow the drive overlay program to load.

Put your Drive Image bootable diskette in your diskette drive (A:).

In the drive overlay boot menu, select the option to boot from a floppy disk.

Make sure that Drive Image is showing the correct size for each drive and the correct
order for the copy sequence.

Finish the copy process.

Scenario 4

The system has a BIOS that does not support drives over 504 MB in size.

The source drive is an IDE drive larger than 504 MB and a drive overlay program is
installed.

The BIOS is upgraded to a BIOS that supports larger drives.
The destination is an IDE drive that is larger than 504 MB.

Steps
1 Set the source drive as the master.
2 Set the destination drive as the slave.
3 Run the new BIOS and auto-detect the drives.
4 Make sure that LBA is turned on for the destination drive and off for the source drive.
5 Restart the computer and allow the drive overlay program to load.
6 Put your Drive Image bootable diskette in your diskette drive (A:).
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7 In the drive overlay boot menu, select the option to boot from a floppy disk.

8 Make sure that Drive Image is showing the correct size for each drive and the correct
order for the copy sequence.

9 Finish the copy process.

Using Drive Image on a Notebook Computer

To make PCMCIA slots on a notebook computer active for use with Drive Image, you
must load the correct drivers in DOS.

1 Determine the correct card services DOS driver for your hardware.

The driver is supplied by the hardware manufacturer. It may be called card services,
card-bus services, CardWare, or another name chosen by the manufacturer. Consult
the hardware documentation or contact the manufacturer if you do not know which
driver is required.

2 Add a statement to your CONFIG.SYS file to load the card services driver.
For example, DEVICE=PCMI80CL.SYS.

There may be additional switches to configure the device. The hardware manufacturer
can provide detailed information.

3 Add a statement to your CONFIG.SYS file to load the NIC or SCSI driver you need.

For example, DEVICE=C: \3COM\EL589ND4 . SYS.

Using Drive Image with a Castlewood ORB Drive

To use a Castlewood ORB drive with Drive Image, the drive must be correctly configured
in the computer BIOS so that DOS can assign it a drive letter and read and copy large files
to and from the drive. Drive Image recognizes the ORB drive as removable media only if
the computer BIOS can be configured to recognize the drive as removable media.

Refer to your ORB drive owner’s manual, or contact Castlewood Systems, Inc.
(www.castlewood.com or help @ castlewood.com) for more information about configuring
the ORB drive for use under DOS.

Refer to www.powerquest.com/support/orb for more information about using Drive Image
with an ORB drive.
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Assigning a CD-ROM Drive Letter

If your computer has a CD-ROM drive or any form of removable media, you should be
aware of potential problems with the way drive letters are assigned to these devices.

Drive Image does not make drive letter assignments; this is a function of the operating
system. The operating system assigns drive letters in the following order: The first
recognized primary partition on each hard disk will receive a letter, followed by all logical
partitions on each hard disk. Next, the CD-ROM drive and any other form of removable
media will be assigned a letter.

Because the CD-ROM is one of the last drives to receive a letter, any partitions that you
create or delete on any of your hard disks will affect the drive letter assignment of your
CD-ROM drive. This change in drive letter assignments is usually performed by the
operating system automatically. Occasionally, however, the operating system will fail to
assign a new drive letter to the CD-ROM drive. If this should occur, please follow the
steps:

If you are using DOS/Windows 3.11 or are loading your CD-ROM drivers under DOS
with Windows 95, perform the following:

1 AtaDOS prompt, type EDIT C:\CONFIG.SYS.
This starts the DOS editor program and opens your CONFIG.SYS file.

2 Change LASTDRIVE=drive (in which drive is any letter of the alphabet) to Z.

This allows the OS to assign all drive letters through Z.
3 Click File » Exit.
4 Click Yes to save the file.

5 You should now be back to a C:\ prompt. Type EDIT C:\AUTOEXEC.BAT.
The DOS editor program starts and opens your AUTOEXEC.BAT file.

6 Look for a line that includes the word MSCDEX. The /L:drive parameter (in which
drive is the drive letter that was assigned to your CD-ROM before you made changes
with Drive Image) may appear at the end of this line. Change this letter to Z.

Because the OS assigns all other available drive letters before assigning Z, this
ensures that partition changes you make in the future will not invalidate your
CD-ROM drive letter.

For more information, type HELP MSCDEX at a DOS prompt.
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If your computer is on a network, when you log in to the network the letter Z and
other letters at the end of the alphabet may be assigned to network search drives. In
this case, assign your CD-ROM a letter just before the first letter used by the network
search drives.

7 Select File » Exit. When you are asked whether you want to save the file, click Yes.
8 When you see the DOS prompt (C:\), reboot your machine.
If you are using Windows 95 and Windows 95 drivers for the CD-ROM:
1 Click Start » Settings » Control Panel » System.
2 From the System Properties screen, select Device Manager.
This brings up a list of the devices in your computer.
3 Double-click CDROM.
4 Click the Settings tab.

5 At the bottom of the Settings page is the heading, Reserved Drive Letters. Under
this heading are two listings, Start Drive Letter and End Drive Letter. Change the
values for these listings to Z.

Because the OS assigns all other available drive letters before assigning Z, this
ensures that partition changes you make in the future will not invalidate your
CD-ROM drive letter.

6 Click OK to close the Settings page.
7 Click OK to close the System Properties page.

8 Click Yes to restart your computer.

Converting Ghost Image Files to Drive Image

Three sample batch files are included on the Drive Image CD in the \SETUP\OS2DOS
directory to help you convert existing Ghost Image files to Drive Image files. This process
requires a computer with Ghost installed and a connection to a scratch hard disk that is
large enough to contain the largest restored Ghost image.
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The batch files restore the Ghost image to the scratch hard disk, then create a Drive Image
file from that hard disk using Drive Image. Any existing data on the scratch hard disk is
overwritten when the Ghost image is restored to it. To preserve a computer’s primary hard
disk, the scratch drive can be a second drive.

The batch files are PQCVT.BAT, PQCVT2.BAT, and PQCVT3.BAT.

You must modify the sample batch files to match your computer and network environment
by specifying the directory paths and executable file locations.

Using PQCVT.BAT

Use PQCVT.BAT when you want to specify program paths, image filenames, and working
disk information on the command line.

To run the batch file, provide the following arguments:

PQCVT <Ghost exe path> <Ghost image file path> <Drive Image exe
path> <Drive Image image file path> <disk drive numbers

Arguments Description

<Ghost EXE path> Full path to Ghost EXE program

<Ghost image file path> Full path to existing Ghost image file to be
converted

<Drive Image EXE path> Full path to Drive Image EXE program

<Drive Image image file path> Full path to the new Drive Image file

<disk drive number> Working disk drive number, 1=first, 2=second, etc.

For example:
PGCVT S:\BIN\GHO210 T:\OLD\I12345.GHO S:\BIN\DM T:\NEW\I12345.PQI 2

This example runs the Ghost program found at s: \bin\gho210, then restores the image
file t : \o1d\112345.gho to disk drive 2. It then runs the Drive Image program found at
s:\bin\dm and builds a new image file at t : \new\112345.pqgi from drive 2.

A log file can be created by executing the batch file from the command shell and
redirecting the output. For example: COMMAND/C PQCVT IMAGE.GHO >CVT.LOG
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Modifying PQCVT2.BAT

Use the PQCVT2.BAT file when you want to “hard wire” program paths and working disk
information. When you enter this information in the batch file itself, you only need to
enter one argument in the batch command line: the image file name. For example,

PQCVT2 TI12345

After the paths are edited in the PQCVT2.BAT file, it will run the Ghost Image program,
restore the image file 112345.GHO to the second hard disk, then run the Drive Image
program and create the new image file.

To modify the batch file,

1 Retrieve the PQCVT2.BAT file into a DOS text editor such as Notepad or DOS
Editor.

2 Edit the file and replace all occurrences of ggg1l, ggg2, dddl, ddd2, and 9999,
with the path information for the Ghost executable, new image files, and drive number
respectively.

3 Remove the first GOTO line following the REM statements, then save the file.

Converting Multiple Files
To convert several existing Ghost Image files, use the PQCVT3.BAT file as follows:

PQCVT3 <file path and patterns>
This batch command scans the directory looking for Ghost image files and calls the
PQCVT2 batch command for each file that matches the file pattern specified. Rather than

specify an exact file, use MS-DOS conventions where “*” equals any number of
characters and “?” equals any single character.

Using International Keyboards

When you use the Drive Image rescue disks, you may lose the ability to use your keyboard
the way you are accustomed to or to view extended characters properly. The Drive Image
rescue disks include the files you need to resolve these problems.

If you use an international keyboard or character set, you must edit the AUTOEXE2.BAT
and CONFIG.SYS files on the rescue disks.
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1 The following lines are remarked in the AUTOEXE2.BAT file. Delete the REM from
the beginning of the line, and replace the variables xx and yyy with the keyboard
code and character set code page for your language.

MODE CON CP PREP=( (yyy)EGA.CPI)
MODE CON CP SEL=yyy
KEYB xx,yyy

xx = two-letter keyboard code (for example, US or FR)
yyy = character set code page (for example, 437)

2 Save the AUTOEXE2.BAT file.

3 The following line is remarked in the CONFIG.SYS file. Delete the REM from the
beginning of the line, and replace the variable yyy with the character set code page
for your language.

DEVICE=DISPLAY.SYS CON= (EGA,yyy,)
4 Save the CONFIG.SYS file.

5 Reboot from the first rescue disk.

Finding Jumper Settings

To find the jumper settings for hard disks, consult your hard disk installation guide or
contact your hard disk manufacturer directly. In most cases, the hard disk manufacturer's
web site will contain the information you need to install the hard disk correctly.

Another valuable resource is www.thetechpage.com. In addition to listing the most
common hard disk manufacturers, this site provides the jumper settings for every hard disk
ever made. Additional jumper information is available from OnTrack at www.ontrack.com.
Please note that PowerQuest is not responsible for the content on these web sites and
cannot guarantee that the web site addresses will not change.
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A PPENDIX

Setting Up Removable Storage
Devices

This appendix describes removable media device drivers included with Drive
Image and how to manually install them on a hard drive or diskette.

Both the Drive Image install program (for Windows) and the MAKEDISK.BAT
file (for OS/2 and DOS) install and configure the drivers for removable storage
devices. This information is provided for those who want to manually configure
these drivers or alter the standard configuration. For more information about
MAKEDISK.BAT, see “Installing on an OS/2 or DOS-Only Computer” on page
5.

Using Removable Media with Network Clients

If you are using a Jaz, or Zip parallel port device with a network client, be aware
that loading a parallel port device driver with a network client installed will cause
the system to hang. To successfully install the device driver for the parallel drive,
reboot the system without loading the network client.

lomega Drivers

Tomega provides a driver loader program that allows you to load drivers from the
AUTOEXEC.BAT file. Each time the Iomega driver program loads, it must also
load an ASPI manager to communicate with the Zip or Jaz drive. The Drive
Image install program copies a large set of ASPI managers to the DRIVERS
directory for SCSI, IDE, and parallel port interfaces.
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The Iomega driver program tries to load each ASPI manager until it finds one that
matches. If it does not have to use this trial-and-error process to find the correct ASPI
manager, it can load more quickly.

Iomega has not provided a DOS driver for their Zip drives that attach to a USB (Universal
Serial Bus) port. Consequently, you cannot create or restore image files to a Zip drive that
is attached to a USB port.

You can access a document, "Using Drive Image with Iomega Removable Drivers," at the
PowerQuest support web site. Go to support.powerquest.com, and query "lomega." This
document is available in English only. For additional information about Iomega drives,
refer to the install diskettes that came with your Iomega product or the lomega web site
www.iomega.com.

Editing Your GUEST.INI File

If you use only one or two specific host adapters, you may want to edit the GUEST.INI file
and remark (using the REM command) the ASPI managers you do not need. This way
only the ASPI managers you normally use will be loaded and tested.

1 From the DRIVERS directory where you installed Drive Image, locate the
GUEST.INI file and open it using Notepad in Windows, DOS EDIT, or any other
ASCII text editor.

2 Find the ASPI manager line for the Iomega driver that supports your drive. For
example, if you routinely use an Iomega PC1616 adapter, use the line that reads
ASPI=ASPI1616.SYS.

The following table lists the supported lomega Adapters and their corresponding

ASPI managers.

Iomega Adapter ASPI Manager
Jaz jet PCI (PC/Mac model) ADVASPILSYS
Jaz jet (PC-only model) ASPISDOS.SYS
Jaz jet ISA ASPIPC16.SYS
Jaz Traveller ASPIPPM1.SYS
Parallel Port Zip drive ASPIPPM1.SYS
Zip zoom SCSI Accelerator ASPIPC16.SYS
Zip Card PCMCIA SCSI adapter ASPIPC16.SYS
Zip IDE drive ASPIIDE.SYS
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Iomega Adapter ASPI Manager
PC1616 adapter ASPI1616.SYS
PC1600 adapter ASPIPC16.SYS

If you are using a non-Iomega SCSI adapter with the SCSI Zip drive, the SCSI
adapter must be ASPI-compatible and an ASPI manager must be obtained from the
SCSI adapter manufacturer.

Add a REM at the beginning of each ASPI manager line you do not want to load.

For example, in a case where the Zip or Jaz drive is connected to an Iomega PC1616
adapter, you would remark all ASPI manager lines except ASPI1616.SYS:

REM ASPI=ASPIPPM1.SYS /INFO FILE=NIBBLE.ILM SPEED= 1
REM ASPI=ASPIIDE.SYS /INFO

REM ASPI=ASPI8DOS.SYS /D

REM ASPI=ADVASPI.SYS

REM ASPI=ASPIPC1l6.SYS INFO

ASPI=ASPI1616.SYS /SCAN /INFO

Save the changes to the GUEST.INI file and exit the text editor. If you are using a
word processor, be sure to save the file as ASCII or DOS text.

If you later need to use an ASPI manager which has been remarked, edit the
GUEST.INI file again and remove the REM command at the beginning of the ASPI
manager line.

ASPI Manager Reference

Detailed reference information on the ASPI managers used by the lomega driver program
is located in the electronic "Installation Manual" (MANUAL.EXE) on the lomega
installation diskette.

1 For either Windows or DOS, go to a DOS prompt, type A :, then press <Enter>.

2 Type MANUAL, then press <Enter>.

Assigning Specific Drive Letters for lomega Drives

To specify the first drive letter you want the lomega drive to use, add the LETTER= option
to the command line. For example, if you type GUEST . EXE LETTER=G, then G will be
assigned to the first supported drive it finds.
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If you have more that one Iomega drive, each additional drive will receive a drive letter
following G in alphabetical order. (When supporting more than one drive, drive letters are
assigned in order of SCSI ID number, from lowest to highest.)

Magneto-Optical Disk Drives

The 3.5-inch Magneto-Optical (MO) drive is available with either a SCSI or ATAPI
interface. Separate DOS device drivers are supplied for each interface type. The device
driver supports the FAT (File Allocation Table) file system, read/write, and disk change
status.

The SCSI device driver requires a SCSI host adapter card and its matching ASPI manager
software. For more information, see the “List of ASPI Managers and Supported Adapters”
on page 106 and your SCSI host adapter documentation.

The 3.5-inch Magneto-Optical disks are available in several capacities.

The volume format may be Super floppy, AT Hard disk, or NSR format. The driver
automatically detects the volume format and assigns logical drive letters (such as D:). If no
valid formats or partitions are detected, the device driver identifies the disk as
unformatted. See the driver documentation supplied with the product for additional
information about formatting MO disks.

Installation of Magneto-Optical Drivers

The ATAPI MO device driver is loaded in the CONFIG.SYS file using the following
command:

DEVICE [HIGH] = (path) \MODISKAP.SYS [/P][/Iil [/Rr]

The SCSI MO device driver is loaded in the CONFIG.SYS file using the following:

DEVICE [HIGH] = (path) \ASPIXXX.SYS
DEVICE [HIGH] = (path) \MODISK2.S8YS [/P][/Ii] [/Rr]

ASPIXXX.SYS represents the ASPI manager that matches your SCSI host adapter.
Optional Switches
/P

Pauses screen messages after the driver has been loaded and initialized. Press any key to
continue the operation. Use this option to check the messages displayed by the driver.
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/li ATAPI driver

Only the device connected to port IDE i is mounted. Otherwise, all ports are scanned MO
devices.

11s defined as:

1 = Primary Master

2 = Primary Slave

3 = Secondary Master
4 = Secondary Slave

/li SCSI driver

Only the SCSI device with ID i is mounted. Otherwise all SCSI IDs are scanned. To also
specify the host adapter number, enter /Ih:i (h is the host adapter number and i is the
SCSI-ID). To specify multiple devices, use the “+” character as a delimiter. For example:
/10:1+1:2

/Rr

Reserves the specified number of logical drive letters (r=1 to 10) for a single drive.
Otherwise, a single drive letter is reserved. The number of reserved drive letters is
independent of the number of disk partitions. The driver can access only as many
partitions as the number of reserved drive letters.

If the inserted disk contains more partitions than specified by the /r option, as many drive
letters are assigned to the disk drive as there are defined partitions. If the disk has fewer
partitions than the number of drive letters reserved, an error occurs only when the driver
attempts to access the additional drive letters.

LASTDRIVE

The CONFIG.SYS last drive command does not affect the drive letter assignment in the
MO disk drive. If the driver assigns a drive letter higher than the one specified by the
LASTDRIVE command (default is E:), the CD-ROM drive cannot be accessed. To enable
access to the CD-ROM drive, specify a larger value in the LASTDRIVE command.

If the following conditions exist, the device driver will not be loaded into memory and the
message “Driver not loaded” will display.

¢ No ASPI manager loaded
e Cannot find MO drive (with or without a disk inserted)
e Driver already loaded
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IMPORTANT! The SMARTDRY cache is turned off by default for MO disk drives. If you
attempt to write data to a write-protected disk while the SMARTDRV
write cache is on, you will need to reset the computer.

You can read more about Magneto-Optical disk drivers from the install diskettes that came
with the product and from the Fujitsu web site www.fujitsu.com.

List of ASPI Managers and Supported Adapters

The following is a list of several popular ASPI managers and the cards they support. Drive
Image will use the ASPI manager you install to support your SCSI card.

ASPI8DOS.SYS

PCI Bus

Adaptec AHA-2910A/2910B

Adaptec AHA-2930A/2930B

Adaptec AHA-2940/2940AU/2940W/2940U/2940UW

Adaptec AHA-2944W/2944UW

Adaptec AHA-3940/3940U/3940W/3940UW

Adaptec AVA-2904, AVA-2902E/1

Adaptec AIC-7850/7855/7860/7870/7880 based SCSI host adapters
Jaz jet (PC-only model)

ASPI7DOS.SYS

EISA Bus

Adaptec AHA-1740/1742/1744

Adaptec AHA-1740A/1742A

Adaptec AHA-2740/2742/2740T/2742T
Adaptec AHA-2740A/2742A/2740AT/2742AT
Adaptec AHA-2740W/2742W

Adaptec AIC-7770 based SCSI host adapters

VL BUS

Adaptec AVA-2825
Adaptec AHA-2840VL/2842VL
Adaptec AHA-2840A/2842A
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ASPI4DOS.SYS

ISA Bus

Adaptec AHA-1540B/1542B
Adaptec AHA-1540C/1542C
Adaptec AHA-1540CF/1542CF
Adaptec AHA-1540CP/1542CP
Microchannel Adaptec AHA-1640

ASPI2DOS.SYS

ISA Bus

Adaptec AVA-1502P/AP

Adaptec AVA-1505

Adaptec AVA-1515

Adaptec AHA-1510/1520/1522

Adaptec AHA-1510A/1520A/1522A

Adaptec AHA-1510B/1520B/1522B

Adaptec AHA-1530P/1532P

Adaptec AVA-1502AE/Al, AVA-1505AE/AL, AVA-1505AES
Adaptec AIC-6260/6360/6370 based SCSI host adapters
Adaptec AVA-1502AE/Al, AVA-1505AE/AL, AVA-1505AES

MCAM18XX.SYS
PCI Bus

Adaptec AHA-2920/2920A
MA160.SYS

If needed, add this adapter to the ASPI manager lines in your GUEST.INI or
LDSQSCSI.BAT files.

ISA Bus

Trantor T160
Microchannel Trantor T260

MA348.5YS

If needed, add this adapter to the ASPI manager lines in your GUEST.INI or
LDSQSCSI.BAT files.
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Parallel Port Trantor MiniSCSI Plus (T348)
Adaptec MiniSCSI Plus (APA-348)

MA358.5YS

If needed, add this adapter to the ASPI manager lines in your GUEST.INI or
LDSQSCSI.BAT files.

Parallel Port Trantor MiniSCSI EPP (T358)
Adaptec MiniSCSI EPP (APA-358)
Adaptec MiniSCSI EPP (APA-358A)

ASPIIDE.SYS

IDE

SCSI to IDE ASPI Manager
Zip IDE drive

ASPIATAP.SYS
SCSI to ATAPI ASPI Manager

ASPIPPM1.SYS and ASPIPPM2.SYS

SCSI to Parallel Port Zip Drivers
Jaz Traveller

ASPIEDOS.SYS
Adaptec AHA-1740/1742/1744 (in Enhanced Mode only)

ASPIPC16.5YS

PC1600 adapter Zip Zoom SCSI Accelerator

Adaptec APA-1460 and other AIC-6260/5360 based adapters
Jaz jet ISA adapter

Zip zoom SCSI Accelerator

Zip Card PCMCIA SCSI adapter

ASPI1616.5YS
PC1616 adapter and other NCR-53C406A based adapters

ASPI2930.SYS
AHA-2930 adapter
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A PPENDIX

Troubleshooting

This appendix gives solutions to problems that you may encounter
while using Drive Image. Included are the following:

Accessing Your CD-ROM Drive

Freeing Conventional Memory to Run Drive Image
Resolving Check Errors

Resolving Partition Table Errors

Partition Tables and Viruses

Generating Diagnostic Reports with PARTINFO

Error Messages and Solutions
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Accessing Your CD-ROM Drive

If you need to access your CD-ROM drive from Drive Image, you will need to add the
command in the CONFIG.SYS file to load your CD-ROM driver. You will also need to
add the command in the AUTOEXEC.BAT file to load the CD-ROM extensions.

1 At the DOS prompt, change to the directory of the CONFIG.SYS you want to edit.
For example, if you are editing the CONFIG.SYS on a boot diskette, type drive:
(where drive is the drive letter of the boot diskette), then press <Enter>.

2 Type EDIT CONFIG.SYS and press <Enter> to start the DOS Editor and retrieve
the CONFIG.SYS file.

3 Add either the DEVICE or DEVICEHIGH command. For example, type
DEVICE=[drive:] [path] filename [dd-parameters]
or
DEVICEHIGH= [drive:] [path] filename [dd-parameters]

where [drive:][path]filename specifies the location and name of the CD-ROM device
driver and [dd-parameters] specifies any command-line information the device driver
requires.

You may want to use DEVICEHIGH if you need to conserve conventional memory. See
“Freeing Conventional Memory to Run Drive Image” on page 111.

For more information on your device driver, consult the documentation that came
with your CD-ROM.

4 Click File » Save to save the file.

5 Click File » Open and retrieve the AUTOEXEC.BAT file.
6 Add the command line MSCDEX.EXE.

7 Click File » Save to save the file.

8 Click File » Exit to exit the editor.
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Freeing Conventional Memory to Run Drive Image

The Drive Image executable running under DOS requires a minimum of 400KB of
memory in the first 640KB of the computer's address space (conventional memory). If you
try to run Drive Image from DOS and find you do not have enough free conventional
memory, you can free enough additional memory in a number of ways.

Running MEMMAKER

MEMMAKER is a program that automatically configures your computer to save
conventional memory (while still loading all of the device drivers and other programs you
usually load when booting DOS). MEMMAKER frees conventional memory by moving
as many programs as possible out of conventional memory into high memory. Run
MEMMAKER by typing MEMMAKER at a DOS prompt. Follow the on-screen
instructions.

MEMMAKER is only available with DOS versions prior to DOS 6.0. MEMMAKER is
not available with Windows 95.

Using the F8 Key to Keep Programs From Loading

If running MEMMAKER does not free enough conventional memory, you can free more
by pressing <F8> right after booting your computer (while DOS is booting). If you press
<F8>, when DOS reads the commands from the CONFIG.SYS and AUTOEXEC.BAT
files on your hard drive, DOS will ask you if you want it to execute each command. When
you see commands that load device drivers or TSR programs that you will not need to run
Drive Image, answer N (no) to tell DOS not to execute that command (not load that
software into memory). This will conserve conventional memory.

Creating an Operating System Boot Diskette

If running MEMMAKER and using <F8> does not free enough conventional memory, you
can create a boot diskette that allows you to boot using a very minimal amount of
conventional memory.

You can create a boot diskette for any version of DOS by performing the following:

1 Place in your diskette drive (A:) any diskette that does not contain information you
want to keep.

2 Go to a DOS prompt, type FORMAT drive: /S (where drive is the drive letter of
the diskette drive).

3 Press <Enter>.
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After the diskette is formatted and the operating system files are transferred, you will be
able to boot the computer from the diskette. If you restart your computer with the diskette
in the diskette drive, your computer boots using a minimal amount of conventional
memory. After you boot from the diskette, you can run Drive Image from either the
diskette or your hard drive.

If you want to create and restore images across a network, you will need to create a
network boot diskette.

Creating a CONFIG.SYS File on the Boot Diskette

If making an ordinary boot diskette doesn't free enough conventional memory, you can
create a customized boot diskette that will free even more conventional memory. (With the
customized diskette, you will free more conventional memory by loading some of the
DOS operating system into high memory.) To customize the diskette, you must create a
CONFIG.SYS file in the root directory (A:\). To create a CONFIG.SYS in the root
directory, perform the following:

1 At the DOS prompt, type drive: (where drive is the drive letter of the diskette
drive), then press <Enter>.

Verify that you have changed to the diskette drive (you see the drive:\> prompt).

2 Type EDIT CONFIG.SYS and press <Enter>.

This starts the DOS editor. (You will see a blank screen if no CONFIG.SYS currently
exists.)

3 In the editor, type the following:
DEVICE=C:\DOS\HIMEM. SYS
DEVICE=EMM386 .EXE

DOS=HIGH, UMB

IMPORTANT! All lines must be entered in the order shown. Windows users:
substitute DEVICE=C:\WINDOWS\HIMEM.SYS.

4 Click File » Save to save the file.
5 Click File » Exit to exit the editor.

You can now reboot your computer from the customized boot diskette. When DOS loads,
much of it is loaded into high memory, saving a maximum amount of conventional
memory.
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Deleting Operating System Compression Files

If you use DOS 6.22 and your system doesn't have any compressed drives (for example,
DriveSpace, DoubleSpace, or Stacker), you can free conventional memory by deleting the
operating system compression files DRVSPACE.BIN or DBLSPACE.BIN from any boot
diskette you create. To delete these hidden system files, perform the following:

1 From the DOS prompt, type drive: (where drive is the drive letter of the diskette
drive).

2 Type ATTRIB -R -H -S *.BIN.

3 Type DEL *.BIN.

Resolving Check Errors

Drive Image checks the integrity of a partition very thoroughly prior to creating an image
file or copying a partition. These checks are substantially the same as those made by the
operating system's CHKDSK, SCANDISK, or AUTOCHK utility.

If you receive a Check error message for any partition, after backing up your hard drive,
run your operating system's CHKDSK program on that partition. CHKDSK usually shows
the same problems as Drive Image. (If you are using Windows NT CHKDSK, DO NOT
use the /F switch on the initial run.)

Run SCANDISK if you have MS-DOS 6.x or Windows 95.
The DOS CHKDSK program does not detect problems in Extended Attributes.

If CHKDSK (or SCANDISK) does not show the same errors that Drive Image shows,
contact PowerQuest at the numbers listed in Appendix D. If the CHKDSK (or
SCANDISK) program and Drive Image detect the same errors (which is usually the case),
run CHKDSK with the /F switch to fix the problem.

After running CHKDSK /F, run CHKDSK without the /F switch to make sure the partition
is free of errors. Under OS/2, you should perform this procedure twice before proceeding.
If Drive Image still reports a problem, reformat the partition and restore your files from the
backup copy to correct the error.

Drive Image also checks a partition after restoring it. If this check fails, report the problem
to PowerQuest Technical Support. The problem is usually a minor file system error that
CHKDSK /F can correct without data loss. For more extensive errors, you may need to
restore your files from a backup copy.
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Resolving Partition Table Errors

In some cases, PowerQuest technical support can help you fix partition table errors
without data loss. Check with them first before proceeding to the following steps.

To resolve some partition table errors, you must create new, error-free partition tables.

1 Make sure you have no viruses.

See “Partition Tables and Viruses” on page 114.
2 Back up the data on the affected partitions.

3 Delete the partitions.

You may need to use the FDISK program from a recent DOS version because earlier
versions of DOS may refuse to delete HPFS or hidden partitions.

If using OS/2, the OS/2 FDISK program may recognize the partition's corruption and
refuse to modify it. In this case, use the FDISK program from a recent DOS version.

4 Recreate the partitions.

5 Restore the contents of the partitions.

Partition Tables and Viruses

If partition changes made under one operating system are not reflected under the other,
and vice versa, it is possible that a master boot record (MBR) virus is present.

Use a virus check utility that can detect the latest viruses. If a virus is found, data loss is
likely. If a virus is found, perform the following:

1 Before removing the virus, run ScanDisk or CHKDSK under each of the operating
systems to evaluate the integrity of the partition.

Back up the files from any partition that passes the Check operation.
After backing up the files from all operating systems, remove the virus.
Run ScanDisk or CHKDSK under each of the operating systems again.

Delete and recreate any partitions which fail the check.

o U h~ O N

Reinstall the operating systems.
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7 Restore the backup files as necessary.

Generating Diagnostic Reports with PARTINFO

PARTINFO, a PowerQuest utility program included on the Drive Image CD, generates a
report showing the contents of your hard disk partition table. This information is helpful in
resolving various partitioning problems.

1 Boot the computer to DOS.
2 Change to the directory that includes PARTINFO.EXE.

3 You have several options for running PARTINFO.

To do this: Do this:

To display partition Type PARTINFO, then press <Enter>.
information on your screen

To send a report directly to Type PARTINFO >LPT1 or PARTINFO
your printer >PRN, then press <Enter>.

To save the report as a text file ~ Type PARTINFO >A:\PARTINFO.TXT, then
on a floppy disk press <Enter>.

PowerQuest support technicians may request a report from PARTINFO to help you
resolve any problems that you experience with Drive Image.

Error Messages and Solutions

For a list of error messages and solutions in English, run Setup, then click Documentation
» Error Documentation on the Drive Image CD, or go to the PowerQuest Knowledge
Base at www.powerquest.com/support/er/er0000.html.
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A PPENDIX

PowerQuest Technical Support

Before Contacting Technical Support

PowerQuest is committed to providing you with comprehensive technical
support. However, before contacting our technical support department, please try
to resolve your problem by using this guide, the online help for the application
you are using, the README file, and PowerQuest’s corporate web site.

Tips
e Your problem may be resolved by applying the most recent patch or upgrade

of the software. You can go to www.powerquest.com/updates to see if there
are updates to the software.

e PowerQuest technical support engineers may request information from the
PARTINFO utility program to help you resolve problems with Drive Image
Pro. See “Generating Diagnostic Reports with PARTINFO” on page 115.

e Your product serial number is required to obtain technical support.

Term of Technical Support

Technical support is available to all registered users throughout the life of the
product, which began when PowerQuest released the product to manufacturing
and ends six months after the release of the next version or when PowerQuest
discontinues development of the product.
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Upon registration, PowerQuest provides 90 days of complimentary technical support from
the day of your first call. In addition, registered users are eligible for special upgrade
pricing when PowerQuest releases a new version of Drive Image. Contact PowerQuest
Customer Service for additional information about upgrade pricing.

Contact Information

Corporate Web Site

The PowerQuest web site support.powerquest.com includes technical support information,
including answers to frequently asked questions (available in English only), an overview
of support options, and explanations for error messages.

E-mail

E-mail (for specific
Language technical problems)

Dutch eurots @ powerquest.com
English help@powerquest.com
eurots @powerquest.com
French france @powerquest.com
German germany @powerquest.com
Italian italian @powerquest.com

Portuguese latina@powerquest.com

Spanish spanish @powerquest.com

To obtain e-mail technical support for specific technical questions, you can fill out the
form at support.powerquest.com/emsupport.html (available in English only).

E-mail on Demand

PowerQuest maintains an e-mail on demand system to resolve common problems. You can
view a list of available documents at support.powerquest.com. To request one of the
documents, send an e-mail message to support@powerquest.com with the index number
of the document in the subject of the message. You can only request one document per
e-mail message. E-mail on demand documents are available only in English.
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Fax

Location

Number

USA

Europe

(801) 437-4218
+31 (0)20 581 9270

Fax a description of your problem to the technical support fax number. This service is
available in the U.S., Canada, and Europe 24 hours a day, 7 days a week. PowerQuest
technicians try to respond to all fax requests within 24 hours.

Telephone

Language Location Number

Dutch Netherlands +31 (0)20 581 3906
English Netherlands +31 (0)20 581 3907
English UK +44 (0)17 1341 5517
English USA (801) 226-6834
French France +33 (0)1 69 32 49 30
German Germany +49 (0)69 66 568 516
Italian Italy +39 (0)2 45 28 1312
Portuguese USA (801) 226-6834
Spanish Spain +34 (0)91 662 51 46
Spanish USA (801) 226-6834

The U.S.A. call center is open Monday through Friday from 7 a.m. to 6 p.m., MST/MDT.
Our European call centers are open Monday through Friday from 9:00 to 18:00, CET.
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Postal Service Mail

USA Europe

PowerQuest Corporation PowerQuest Customer Service
P.O. Box 1911 P.O. box 58287

Orem, Utah 84059-1911 1040 HG

U.S.A. Amsterdam, Netherlands

Include a detailed description of your problem and a return address, a daytime phone
number, or other relevant contact information.
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Glossary

ATA

A standard used by hard drives to communicate with the controller ports or cards that
allow the hard drive to interface with the computer. Before ATA, there were numerous
incompatible methods for interfacing hard drives to computers. ATA simplifies this
process, thus reducing the cost of developing and purchasing related hardware. ATA is the
proper term for Integrated Drive Electronics (IDE).

ATA-2
ATA-2 is the common name for a new, enhanced IDE standard. This standard is still
evolving and has not yet been submitted for approval as an official standard.

BIOS (Basic Input/Output System)
The BIOS is the program code stored in a PC-compatible ROM to boot the computer and
provide basic services such as low-level hard drive access.

Cloning
Copying a hard drive to an image file or destination disk to create an exact duplicate.

Destination
The destination hard drive is the drive that is copied to during a copy or restore operation.

Disk
A hardware device to store data. A disk contains a Master Boot Record and partitions.

EIDE (Enhanced Integrated Drive Electronics)
A marketing program that promotes certain features of ATA-2.

Extended Partition

One of the four primary partitions on a hard drive can be an extended partition. Extended
partitions do not directly hold data; rather, you can create an unlimited number of logical
partitions within the extended partition to store data. An extended partition cannot be the
active partition.

FAT File Allocation Table
File system used by DOS, Windows 95/98, NT and sometimes OS/2 to store and retrieve
files and directories.
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FAT32

FAT32 is the file system used by updated versions of Windows 95 (version 4.00.950B or
above and Windows 98). FAT32 is an enhancement of the FAT file system and is based on
32-bit file allocation table entries, rather than on the 16-bit entries the FAT file system
uses. As a result, FAT32 supports much larger volumes (up to 2 terabytes).

GB (Gigabyte)
1,073,741,824 bytes.

IDE
See ATA.

Image
An image is a snapshot of a drive’s partitions that can be used to back up a system, install
a new hard drive, or configure a new system.

Jumper

Metal prongs and a circuit completion cap on the outside of a hard drive. You can remove,
reposition, and then replace the cap to create various jumper settings such as master and
slave.

HPFS
High Performance File System, an alternative to a FAT file system which is used by OS/2.

LBA (Logical Block Addressing)

1) In EIDE, a means of specifying sector addresses by replacing CHS values with a single
linear 28-bit number. 2) Generically, a one-dimensional address of a hard-disk sector;
contrast with CHS.

Linux

Linux Ext2 file system was developed for the Linux operating system (a free-ware version
of the UNIX operating system). Linux Ext2 file system supports a maximum volume size
of 4 terabytes.

Logical Drive
A contiguous area inside an extended partition that can be used by the operating system to
store and retrieve files.

Master
The first hard drive on an IDE hard drive controller.

MB (Megabyte)
1,048,576 bytes.
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NetBIOS
A high level Network programming interface which is supported by lower level network
protocols such as IP/SP and TCP/IP.

NetWare
The Novell NetWare network operating system uses the NetWare File System, which was
developed specifically for use by NetWare servers.

NTFS (New Technology File System)
An alternative to FAT and HPFS file systems used by Windows NT.

Partition
An uninterrupted area on a disk, defined in the Master Boot Record. Every partition
contains a specific file system such as FAT, FAT32, HPFS, or NTFS.

Primary Partition

A partition referenced in the Master Boot Record partition table. Four primary partitions
can exist on a hard drive. One of these may be an extended partition. Only one primary
partition on a drive may be active at time. Data and applications are often placed on a
logical partition inside an extended partition. This enables the data to be accessed by all
primary partitions.

Restore
Downloading an image file to a destination drive.

Slave
The second hard drive on an IDE hard drive controller.

Source
The Source hard drive is the drive from which the image is made.

Spanned Image
An image file that has been created in two or more segments so that it can be placed on

media that is smaller than the image itself.

Unallocated Space
Space on a hard disk that is not assigned to any partition.

Volume
This User Guide uses the term volume interchangeably with partition.
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Index

Numerics
1024 cylinder boundary, indicators displayed for 60
2 GB boot code boundary, indicators displayed for 60

A

accessing a CD-ROM drive with Drive Image 770
accessing CD-ROM drive 110
active partition 64
adapters for ASPI managers 106
advanced options
copying disk to disk 54
creating images 20
restoring images 36
arrows displayed on partition map 60
arrows on partition map 60
ASPI managers
list and supported adapters 106
reference 103
automatically resize partitions proportionally to fit 50

backing up data with DataKeeper 79
bad sectors, checking for 55
benefits of registering PartitionMagic 117
BIOS, computers with older 92
boot diskettes
creating a CONFIG.SYS 712
creating rescue diskettes for Drive Image 5
using /11
boot disks
creating a system diskette 777

C
card-bus services, enabling for use with Drive Image
95
Castlewood ORB drive 95
CD-R support 13
CD-ROM
accessing drive 7710
creating image files 23
drive letter, assigning 96
restoring image files from 39
CD-ROM drive, assigning a drive letter to 770

check errors 115
checking for file system errors 20, 54
checking image integrity after creating an image 21
CHKDSK 6, 113
clients, using NetWare with parallel port devices 6
command line options, DataKeeper 88
common partition management tasks 59
compressing image files 17, 72
compression

deleting OS files 113

level 17
CONFIG.SYS, creating on the boot diskette 772
configuring hardware 12
contact information for technical support 778
continuous backup 79
conventional memory /71
converting Ghost image files 97
copying disk to disk 43

advanced options 54

between partitions on same disk 56

drive to drive 57

resizing partitions 48
creating

boot disks /171

extending partitions 61
creating image files 11, 14

advanced options 20

for CD-ROM 23

on CD-R 13

on secondary hard disk 25

on Zip drives 22

scenarios 22

verifying image integrity 2/

D

DataKeeper 79
command line options 88
creating custom backups 83
installing and configuring 80
mobile support 86
monitoring your system with 82
online help 89
restoring backups 86
decreasing time needed to copy 55
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deleting
compression files 713
image files 75
partitions 62

device drivers, installing 6

devices, using parallel port with NetWare 6
diagnostic reports, generating with PARTINFO 115

disabling SmartSector copying 20, 54
disk access errors 115

disk, copying 43

diskettes, creating image files on 2/
displaying drive information 60

DOS drivers, loading for PCMCIA cards 95
DOS, running Drive Image from (using rescue

diskettes) 5
downloading, see restoring image files
Drive Image
converting Ghost image files for 97
partition management 59
using computers with older BIOS 92
using with SCSI hard disks 92
Drive Image File Editor 67
password protection 72
preferences (options) 77
system requirements 68
verifying images with 74
drive letters
assigning for lomega 703
assignment by operating system 96
drive overlay software 92
drivers
installing for removable devices 6
removable storage devices 101
drives
copying between drives 57
displaying information 60

E
editing files 67
e-mail on demand technical support 718
error messages 115
estimating image file size

size of image files, estimating /7
examples

creating image files 22
see also scenarios

extended partitions, creating 6/

Index

F

F8 Key, to keep programs from loading 771

FAT check errors 715

files, managing 67

FireWire CD-R drives 13

free space, leave remaining 50
Fujitsu drivers, installing 6

G

Ghost image files conversion 97
glossary 121
GUEST.INI, edit 102

H

hard disks
creating image files on 25
jumper settings 100
restoring images from 4/
SCSI 92
help, online 70
Drive Image File Editor 77
help, technical support /17
hidden partitions, creating images on 16

hidden partitions, restoring images from 29

hiding partitions after restore 37
hiding partitions 63

hiding partitions after copying 55
HPFS check errors 115

IDE CD-R and CD-RW drives 13
image file size, estimating 17
image files
compressing 17, 72
converting Ghost files 97
creating 11, 14
deleting 75
deleting OS compression files 773
hardware configurations 72
restoring 27
restoring from CD 28
spanning media /9
verifying 74
ImageShield 21, 72
information, displaying for drives 60



installing
DataKeeper 80
Drive Image 4
removable device drivers 6
see also restoring image files
uninstalling 70
international keyboards 99
Internet technical support /78
Tomega drivers 101
ASPI managers 103
assigning drive letters /03
cannot see Zip drive attached to USB port 101
editing GUEST.INI 102
installing 6

J
Jaz drivers 101
jumper settings 100

K

KEYB.COM 99
keyboards, international 99

L

laptop computers, using Drive Image on 95
leave remaining free space 50

M

Magneto-Optical drives 104
installing drivers for 6
management tasks
Drive Image File Editor 67
image files 67
partitions 59
manually resizing partitions 50
markers on partition map 60
MEMMAKER 111
memory
freeing by not loading programs 7171
required to run Drive Image 2
menu, Tools 60
MO drives 104
installing drivers 6

NetWare client, using with parallel port devices 6
new features /

NIC drivers for PCMCIA cards 95

notebook computers, using Drive Image on 95
NTEFS check errors 715

NTFS partitions, creating images on 16

NTFS partitions, restoring images from 29
NTFSINLEXE 12

o

online help 10
DataKeeper 89
Drive Image File Editor 77
operating systems
boot diskettes 171/
deleting compression files 773
for install 4
ORB drive 95
overlay software on older computers 92

-]

parallel port devices, NetWare client 6
PARTINFO program 115
partition map 60
partition table errors, resolving 114
partitions
common management tasks 59
copying between partitions on same hard disk
56
deleting 62
hiding 63
hiding after copying 55
hiding after restore 37
information displayed on screen 60
resize manually 50
resizing 31, 48
resizing automatically to fit available space 50
setting active 64
table errors 115
passwords, adding to image files 27, 72
PCMCIA cards, using with Drive Image 95
port devices, using with NetWare client 6
PowerQuest contact information 718
PowerQuest web site 718
PQPACKET.EXE 13, 28
preferences, Drive Image File Editor 77
see also advanced options
preparing to run Drive Image 6
prerequisites to running Drive Image 6
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R
removable media

Castlewood ORB drive 95

Tomega 101

MO drives 104

setting up for use with Drive Image 10/

using with network clients 70/
removable storage devices, installing drivers 6, 101
requirements 2
rescue diskettes

creating 5

limitations under Windows NT or Windows

2000 5

running Drive Image from 7
resize options 35, 50
resizing partitions 37, 48
resizing partitions on the destination drive 50
resizing partitions proportionally 50
restoring image files 27

advanced options 36

from CD 28, 39

resize options 35

resizing partitions 37

scenarios 37
restoring images from hidden partitions 29
restoring images from secondary hard disks 47
running Drive Image

at scheduled times 7

from a floppy diskette 7

from a hard drive 7

preparation 6
running Drive Image, preparation for 73

S

saving images to hidden partitions 76
ScanDisk, before running Drive Image 6
scenarios
creating image files 22
creating image files for CD-ROM 23
creating image files on secondary hard disk 25
creating image files on Zip drives 22
restoring image files 37
restoring image files from a Zip drive 37
restoring images from secondary hard disks 4/
scheduler 7
SCSI CD-R drives 13
SCSI hard disks 92
security, adding passwords to images for 27

Index

setting active partition 64

setting up removable storage devices 10/
sizing partitions 48

skip bad sector check 55

SmartSector copying, disabling 20, 54
spanning images across media 27/
spanning media /9

speeding up copy time 20, 54

splitting image file into multiple files 21
support, term of 117

system requirements, Drive Image 2
system requirements, Drive Image File Editor 68

T

technical support 717
duration /17
e-mail 120
e-mail on demand 718
fax 119
mail 120
online help 70
telephone 719
web site /18
Tools menu 60
triangles displayed on partition map 60
troubleshooting 709
accessing CD-ROM drive 110
creating a CONFIG.SYS on boot disks 712
creating boot disks 771
creating rescue disks to run Drive Image 5
deleting OS compression files 773
Drive Image doesn’t recognize Castlewood
ORB drive 95
Drive Image hangs when I run it 7101
Drive Image hung after I clicked Finish 13, 28
generating diagnostic reports with PARTINFO
115
keep from loading programs 7171
my CD-R drive isn’t recognized 13
my CD-ROM doesn’t have a drive letter 7170
running MEMMAKER 1171
tips 117
using operating system boot disks 771
Windows NT won’t boot /2

U

unallocated space, leave remaining 50
uninstalling Drive Image 10



USB CD-R drives 13
USB port, cannot use Zip drive attached to /0!
user files, backing up with DataKeeper 79

\'
verifying disk writes 20, 55
verifying image integrity
advanced options 2/
before restoring an image 30
with Drive Image File Editor 74
virus detection 13, 28

W

Windows 2000 Professional 2
limitations of rescue diskettes under 5
Windows NT
copying partitions /2
creating images on hidden NTFS partitions /6
limitations of rescue diskettes under 5
restoring images from hidden NTFS partitions
29
Windows NT workstation 2

¥ 4

Zip drives
cause Drive Image to hang /01
creating image files on 22
drivers 101
restoring image files from 37
See also lomega drivers
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