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Installing and Starting IncWell NetAnimator

System Requirements

To run IncWell NetAnimator, you need

Hardware

• A personal computer with a Pentium 60 or higher processor

• 16 MB Ram or greater

• 16 bit color capable video adapter

• 5 MB or greater of hard disk space

• CD-ROM drive

Software

• Microsoft Windows 95/98/NT (will not run under Windows 3.1)

• Java capable Web Browser (Netscape Navigator 4.0 or Microsoft Internet Explorer 4.0 recommended)

To Install IncWell NetAnimator

1. Start your computer in Windows mode. Do not install from the MS-DOS prompt.

2. Insert the NetAnimator CD-ROM in the CD-ROM drive.

3. In My Computer, double-click the CD-ROM. Double-click Setup.exe.

4. Follow the instructions as they appear on the screen.

5. Restart your computer to complete installation.

To start IncWell NetAnimator

From the Start Menu, select Programs>NetAnimator>NetAnimator.
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What Setup installs on your Computer

After you run the NetAnimator installer, several files and folders appear on your computer hard drive.

These are-

NetAnimator.EXE

This is the IncWell NetAnimator application.

netanimator  Folder

This folder contains the Java Viewer runtime engine, consisting of several Java class files. Your

NetAnimation requires these class files for playback through a Java compatible browser. This folder with

its classes must be in the same directory as the HTML page used for playback.

PARTS Folder

NetAnimator comes with sample graphics you can use for creating your own NetAnimations. Setup

installs these in the PARTS Folder on your hard drive.

SAMPLES Folder

Setup installs some sample NetAnimatior project files (.nap) in this folder. There are also sample

NetAnimations (.nae) and sample web pages which you can use to understand how NetAnimator works.

NETANIMATOR.OCX

This is the NetAnimator playback ActiveX Control. You can embed this control in a web page for

playback through any ActiveX compatible browser, such as Microsoft Internet Explorer 4.0

(recommended).
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Introducing IncWell NetAnimator

Everywhere you see a web, the Internet, your company Intranet or the Microsoft Active Desktop, you see

flashy, dynamic graphics. Until now, unless you learned how to use an expensive designer tool and force

viewers to use browser plug-ins, the best you can achieve are slow animated GIF files, slowly loading into

a viewer's browser. It is time to put away the plug-ins and pick up a tool that puts interactive power into

everyone's hands: IncWell NetAnimator.

If you wanted to make a screen saver, you could buy a screen saver creator. If you need to put an

interactive graphic on your web site, you buy and learn another program. If you wanted to embed an

animation in a Microsoft Activex compatible application, you spent even more money.

Now you can do it all with this one versatile tool.

You can put pictures and text together, give them motion and the ability to react to user input, all without

programming. And best of all, its fun!

IncWell NetAnimator lets you reuse and redeploy your work on multiple platforms as-

Internet Web Animations

Using the NetAnimator Java engine, NetAnimator lets you deploy your animations on the Internet by

automatically creating a web page for your animation. Any Java compatible browser can view

NetAnimations that you create.

Microsoft Webs

Many corporate intranets use Microsoft solutions, both through server solutions and using Microsoft

Visual Basic applications. You can embed NetAnimations on your Microsoft Intranet, both in html pages

and in programs using the NetAnimator ActiveX control.

Active Desktop Screen Savers

NetAnimator lets you deploy your NetAnimations as Windows 95/98/NT screen savers, demonstrating

NetAnimator's power for reuse. From web pages to desktops, you can deploy a powerful, consistent

message.
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Designing NetAnimations

Creating a powerful, exciting interactive visual is easy with NetAnimator. In four easy steps, you can

create clickable, multimedia messages which you can reuse again and again on the Internet or your

network.

Create your Characters

NetAnimator uses an area called the Stage to display individual pieces of text and graphics. Your

characters can be computer graphics you create, third party clip art, photos from digital cameras, and even

text. You collect these in the Member Window, where you can add interactivity to each piece of media.

Give Life to the Stage

When a writer creates a story, they often make a timeline to chart the progress of the characters and

background. NetAnimator uses a similar metaphor. After you gather your media in the Member Window,

you can drag these to the Timeline Window. The Timeline Window is made up of individual timelines

called Character Tracks. Each character gets its own track. Once in a Character Track, your character

appears on the Stage. You can also add a Member to the Background Track, which is always behind all the

characters on the Stage. You can then define where the characters appear, move around and disappear

from the Stage.

Export Your Animation

Save your work as a NetAnimation. After you save your work as a NetAnimation (.nae) file, it is ready to

play back.

NetAnimator lets you create an HTML page with all the code you need to play back the NetAnimation in

any Java compatible web browser. You can also attach your NetAnimations to the ActiveX control, which

you can use for playback through Microsoft Internet Explorer, or in any ActiveX compatible application

created with development systems like Microsoft Visual C++ or Microsoft Visual Basic. In addition, you

can deploy your work using the Screen Saver engine on any Windows 95/98/NT desktop.
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Getting to Know NetAnimator

IncWell NetAnimator has three windows in which you create your NetAnimations. These are the Member

Window, the Timeline Window and the Stage Window. These three Windows float in the NetAnimator

Main application Window.

The Main Window

You can use almost all of NetAnimator's functions either through the menu bar or through clicking the

buttons in the tool bar in the Main Window.
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The Member Window

The Member Window is where you can store the graphics and text you use to create NetAnimations. You

can drag any bitmap (BMP) or JPEG graphic directly into one of the cells.

The Timeline Window
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The Timeline Window is where you can synchronize movement on the Stage to time. The Timeline

Window consists of the Background Track and Character Tracks. You can drag several Members onto a

track, then group them to create a Character. NetAnimator lets you drag a graphic into the Background

Track, which keeps a graphic behind all of Character Tracks.

The Stage Window

The Stage Window is where you can position your characters on the screen for playback. When you click

the Play button, NetAnimator plays back a preview of your animation on the Stage.

Distributing your Work

Registered owners of IncWell NetAnimator have the right to distribute NetAnimations with the IncWell

runtime engines and Java classes.  IncWell encourages you to include the Made with NetAnimator banner

on your web site wherever you display your animations. If you embed the ActiveX Control in an

application, you are required to credit IncWell. To credit, please include "© Portions by IncWell Software.

Made with MediaLinks NetAnimator" in the About box of your application.
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The Website Fish Tank

In this tutorial, you will learn how to create an animated fish tank that you can display on your website.

You will learn how to create a NetAnimator project, create animated members and backgrounds, and

finally, export your animation for playback on a web page.

Creating a NetAnimator Project

1. Start NetAnimator. Three windows appear, the Member Window, Timeline Window and Stage

Window. NetAnimator automatically names your project New Project.

To save your project, from the File Menu, select Save Project As, then name your project.

NetAnimator saves your work as a NetAnimator project file (.nap). You can close this file and reopen it

later to add new Members and edit your animation.
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2. Select general options to determine how NetAnimator displays your work. Select File>Project

Options…, and select general options for your project.

Set the size of the Stage to determine the maximum display area of your animations. NetAnimator displays

the size in pixels. Click the Stage Size option, and from the menu, select a size, such as 400 x 400 pixels.

Selecting a large Stage size uses more computer memory. On older computers, large animations display

slowly.

3. Next, select a background options.

The background color appears behind any image you add to the Background Track of the

Timeline Window.

To select a solid color for the Background, click the Select Color… button, and select a

background color.

To determine how Background Track Members appear, from the Background Member Options,

select Center.  Any Member you add to the Background Track is automatically centered on the

Stage.

4. Click OK. Select File>Save Project to save your work.
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Adding Members to your Project

NetAnimator comes with sample images that you can use. In this tutorial, you can create a fish swimming

around a fish tank.

1. In the Member Window, right-click in an empty box and select Load Image.

2. In the Sample Parts folder, open the Fish folder and select FISHTANK.BMP. Click OK.

 

 

 

 The FISHTANK.BMP image appears in the Member box.
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3. From the FISH folder, drag the FISH01.BMP to the Member Window.

Place the pointer inside the Fish Member, right-click and select Properties…. The Member Properties

Window appears. You can select a transparent color for the Member, as well as select the angle of the

Member through the  Rotation option.

You are not limited to using the sample graphics in your animations. You can bring in graphics from a

photo-retouching program, without any limits on the size or number of colors. The only limit is available

memory.
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Adding a Background to your Project

1. Click the Member Window. Drag the FishTank Member into the Timeline Window Background

Track..

 A Member marker appears on the Background Track and the Member from Box 1, the FishTank

Member, appears on the Stage.

 

 

 

2. Again, drag the FishTank Member from the Member Window to the Background Track at frame 150.

If you make a mistake and place it at the wrong frame number, drag the marker to the frame 150. A

timeline connects the two copies of the FishTank Member. The contents of box 1 on the Member

Window, the FishTank Member, appears on all frames from 0 to 150.
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A line connects both FishTank Members in the Background Track. The FishTank is visible for the

duration of the 150 frames of your animation.
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Adding Characters to Your Animation

1. Click the Fish Member in box 2. Drag the Fish Member to the Timeline and into the line 1 Character

Track.

 Handles appear around the Fish Member. You can use these to resize the it on the Stage.

 

 

 

2. Drag the Fish Member from the Member Window to the same Character Track, line 1, at frame 150.

Repeat at frame 50 and frame 100.

 

 Four markers are in the first Character Track (line 1). On the Toolbar, click the Play button. The

animation plays, and the Fish appears and disappears at frames 50, 100 and 150. Click the Stop button.

 

3. Click the marker at frame 50. Drag the Fish  on the Stage to a different place. Do the same for the

members at  frames 100 and 150.

 

4. Click to the left of the Character Track. From the Edit menu, select Select All. From the Toolbar,

select Timeline>Link>Curve.
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 A wavy line appears in Character Track 1 connecting the markers. A curved path appears on the Stage

joining the four versions of the Fish Member.

 

5. Click the Play button.

The Fish swims across the Stage, from point to point. Click the Stop button, and save your work.

Set a Transparent Color

When you play the Fish animation, you may notice that a black square surrounds the fish. The FISH.BMP

has a black background. You can make the black background transparent through setting Transparency

options for the Member.

To make the black background transparent on the Stage, right-click the Fish Member in the Member

Window, and select Properties….

From the Transparent Color box, select the Black option and click OK. On the Stage, the black

background on the Fish disappears.
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Flipping Members

The fish in your animation moves across the Stage, but only in one direction. You can flip Members at any

marker on a Character Track.

On the Stage, click the box representing frame 100. The Fish Member appears. From the menubar, select

Stage>Flip Horizontal. Click the Play button. The fish appears to turn suddenly and swim in a different

direction.
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Fine Tuning your Animation

You can fine tune the acceleration of movement on your animation on the Stage or the Timeline. On the

Stage, drag the markers on the animation path. Or, on the Timeline, you can drag markers along a

Character Track. Changes on either the Stage or the Timeline also appear on each other.
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Adding Interactivity to your Animation

NetAnimator lets you add interactivity to the Members in your animation. It gives you control both inside

your animation, as well as browser direction. When a user clicks on a Member, it can trigger a jump to

another frame in the animation. Or, a click can send a message to a web browser to open up a URL.

1. In the Member Window, right-click the Fish Member and select Jump to….

The Jump to box appears.

2. Select the Jump to Frame option, and enter 0 in the box.

When a user clicks the Fish in your animation, it automatically returns the animation to Frame 0, restarting

the animation.

Other Jump to Options

Jump to URL

If you select Jump to URL, the URL option box is enabled. Enter a URL in the option box. When a user

clicks on the Member, it automatically jumps to the URL. You can create powerful, animated buttons with

this feature.

Jump to Options are ignored in NetAnimator Screen Savers.

You can also use your animation with the NetAnimator ActiveX Control. You need to set

ActiveX Control parameters in your web page or application development environment.
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Previewing Your Animation

You should do a final check to confirm that the characters you create from Members move smoothly.

Click the Play button on the NetAnimator button bar.

The fish character swims slowly across the tank floor, turning suddenly.

To move forward one frame at a time, click the Single Frame button.

Fine Tune Animation Speed

You can adjust the playback speed of the entire animation.

1. Select File>Animation Speed….

 

 The Animation Speed box appears. Move the arrow to Fast to accelerate the speed of the Fish.

 

2. Click OK.

The actual playback speed is dependent on the processor of the playback machine, and may

vary depending on the browser used. If an animation uses large, or many graphics, it will slow

the animation.
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Export and Play Your Animation

You can now create your final animation for playback through a Java-compatible web browser.

1. Select File>Save Project to save your work.

 

 A NetAnimator Project file is editable. You can return to it later and add more information or change

what is already there.

 

2. Select File>Export Animation…. In the Export Animation box, name your animation " Fish" and save

it.

 

 Your animation is saved as a NetAnimator animation file (.nae).

 

3. Select File>Generate HTML. From the Generate HTML box select your options.

In the Title box, name the web page that NetAnimator creates.

In the Object Name box, select the name for the Java Viewer you will create. The default name is test

1.

In the Codebase box is the name of the folder that must contain the Java Viewer engine.

Select any other options for the web page that NetAnimator generates.
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1. Click OK. Name your web page and save your work.

Adding the Java Viewer Engine

You need the Java Viewer runtime engine in order to play back an animation on a web page.

1. Copy the netanimetor folder into the same folder or directory as the playback web page.

 

2. Copy your animation file (.nae) into the netanimetor folder.

   

3. Play your animation. Now you can play back your animation in any web browser. Open the web page

in any browser, and watch your finished animation.

Advanced users can change the parameters in the web page to change how the animation plays back. You

can create very sophisticated animations within your web page by changing these parameters dynamically

with Javascript.
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Putting NetAnimations on the Internet with Java Viewer

One of NetAnimator's most powerful features is its ability to play back your NetAnimations in a web

page. You can deploy your project using NetAnimator Java Viewer, a small and stable program that

plays back your animation through any Java-capable web browser. Now you will learn how to add your

NetAnimation to a web page using the Java Viewer applet.

Creating NetAnimations for Java Viewer

From the File Menu, select Save Animation, and save your animation (.nae file) to a folder or directory.

The NetAnimation file (.nae) collects all of your graphics and interactions from your NetAnimator

project file. Keep your project file though, since you cannot edit a NetAnimation file.

Next, you create an HTML file to host the NetAnimation Java Viewer.

From the File Menu, select Generate HTML.

The Generate HTML File dialog appears.



IncWell NetAnimator User Guide

Chapter 4  Putting NetAnimations to Work

4 - 2

Select the Java Viewer Tab.

Using the tabs, you can select to use either the Java Viewer or the ActiveX Control. You can select many

options for the HTML page and animation you generate. Many of them already include default values

from your project file:

Title

The name of the HTML page that NetAnimator generates.

Object Name

Displays the name of the Java Viewer. This name allows you to control the applet through Javascript.

Code Base

Displays the folder or directory path from the HTML page to the Java Viewer. By default, the HTML

file is in the same directory as the folder containing the Java Viewer.

NetAnimator File

Displays the name of your NetAnimator project file.

Click Type

Determines if your NetAnimation responses to the press of the mouse button or the release of the mouse

button.

Play Type

Determines how the NetAnimation plays back through your browser. If you select Normal, the

NetAnimator Java Viewer uses as much memory as possible to speed playback of your animation.

Memory Saving allows simple, smaller animations to play back smoothly when the user's computer has

less memory.

Background Color

This option determines the background color of the HTML page. By default, NetAnimator selects Red

255, Green 255 and Blue 255, which is white.
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Letter Color

This option determines the color of the text on the HTML page. By default, NetAnimator selects Red 0,

Green 0 and Blue 0, which is black.

After you finish selecting options, click OK and select a directory to contain your HTML file.

NetAnimator creates an HTML file using your specifications. You can edit this file in any HTML editor,

such as Microsoft Frontpage or NetObjects Fusion. You can also copy and paste the code NetAnimator

generates for use in other web pages.

You need to make sure that the Java Viewer is located in the correct folder for your animation to play

back correctly. The Java Viewer files are found in the NetAnimator folder.

Copy the NetAnimator folder into the same directory where you place your HTML file. Then, copy your

NetAnimation (.nae file) into the NetAnimator folder.

Many HTML editors such as Microsoft Frontpage allow you to copy folders into their file structure and

then automatically publish them. You can also use an FTP program to upload the NetAnimator folder to

your web server.

You can also change the HTML by hand to designate a different location for the NetAnimator folder.

  Java Compatible Browsers

You can view the NetAnimation through any Java compatible browser. Playback speed varies from

browser to browser.

  Free Java Viewer Upgrades

As web browser companies upgrade their products, they introduce changes to the way Java works. You

can download the newest version of the Java Viewer from the IncWell web page. This ensures that your

animations are running at peak performance.
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.Faster Playback

NetAnimator lets you create huge animations, limited only by your imagination. However, any

downloadable web object, including streaming video, music or animations are limited by the speed of

the end user's computer connection. You should always be aware of your project size. Also, we

recommend the following:

Limit the size and number of colors used in characters. NetAnimator lets you import huge, beautiful

graphics files, and dynamically lowers the resolution to match the capabilities of your web browser,

which is typically 256 colors. Using 8-bit graphics is always faster than using 16-bit graphics.

Limit the size of the Stage. Make the Stage only as big as it needs to be. A smaller Stage means you

animation will play back more quickly.
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Customizing Java Viewer

This example code shows you the support HTML code NetAnimator creates to display the Java Viewer.

You can modify the italic entries to customize how your NetAnimation plays back.

Sample Applet Code

<APPLET NAME="Animation name" CODE= netanimator" CODEBASE="netanimator"

WIDTH=300 HEIGHT=200>

<PARAM name=FileName value="filename.nae">

<PARAM name=Playspeed value=2>

<PARAM name=ClickType value=0>

<PARAM name=PlayType value=0>

<PARAM name=Member1 value="f,100">

<PARAM name=Member2 value="u,URL">

<PARAM name=Frame100 value="f,0">

<PARAM name=Frame200 value="u,URL">

</APPLET>

Defining Java Viewer Parameters

<APPLET NAME="Animation name" CODE= netanimator" CODEBASE="netanimator"

WIDTH=300 HEIGHT=200>

This code identifies the Java Viewer. This name is important if you create a script based web solution

using Javascript and want to integrate the Java Viewer. CODEBASE shows the folder location of the

Java Viewer. If you move the Java Viewer to a different folder, then you must update the path . If you

put it in one folder deeper in the directory, it would need to include this path, such as "/new folder".

WIDTH and HEIGHT indicate the size of your NetAnimation in pixels.

<PARAM name=FileName value="filename.nae">

This determines the name of your NetAnimation. It cannot be omitted.
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<PARAM name=Playspeed value=2>

Determines the playback speed of your NetAnimation. This value can range from 1 (fastest) to 10

(slowest).

<PARAM name=ClickType value=0>

This determines if a jump in your NetAnimation occurs when the mouse button is pressed or released (a

mouse up or mouse down). A value of 0 is a mouse up jump. A value of 1 is a mouse down jump.

<PARAM name=Frame100 value="f,100">

<PARAM name=Frame200 value="u,URL">

These parameters determine what happens when your animation reaches a frame. It can either jump to

another frame, or jump to a URL. The Frame number determines the Frame in which the jump begins.

When the NetAnimation reaches this Frame, the Jump occurs. The "f" number is the target frame for the

Jump. The "u, URL" parameter shows a target URL of a jump.
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Using  Java Viewer With JavaScript

Your HTML file has many different parameters to control your NetAnimation. Using a scripting

language such as JavaScript, you can create very sophisticated animation effects that dynamically

change the NetAnimation's parameters. Here is an example:

<APPLET NAME="Animation name" CODE=netanimator CODEBASE="netanimator"

WIDTH=300 HEIGHT=200>

<PARAM name=FileName value="filename.nae">

<PARAM name=Playspeed value=2>

<PARAM name=ClickType value=0>

<PARAM name=PlayType value=0>

<PARAM name=Member1 value="f,100">

<PARAM name=Member2 value="u,URL">

<PARAM name=Frame100 value="f,0">

<PARAM name=Frame200 value="u,URL">

</APPLET>

When you select the Java Viewer option when you Generate HTML, NetAnimator creates HTML code

that looks very similar to this:

<BODY BGCOLOR="#ffffff" TEXT="#000000" onLoad="sample()">

<APPLET NAME="Animation name" CODE=netanimator CODEBASE="netanimator"

WIDTH=300 HEIGHT=200>

<PARAM name=FileName value="filename.nae">

<PARAM name=Playspeed value=2>

<PARAM name=ClickType value=0>

<PARAM name=PlayType value=0>

</APPLET>
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<SCRIPT LANGUAGE="JavaScript">

function sample(){

document.Animation name.goframe(0);

document.Animation name.setmember(1, "f,100");

document.Animation name.setmember(2, "u,URL");

document.Animation name.setframe(100, "f,0");

document.Animation name.setframe(200, "u,URL");

}

</SCRIPT>

</BODY>

In this example, the first line runs a script in Java Script  called "sample()" when the animation is loaded.

JavaScript can control the goframe, setmember and setframe parameters.

document.Animation name.goframe(0);

This line shows the target frame of a jump.

  

document.Animation name.setmember(1, "f,100");

This line sets the target frame of Member 1 to 100. Clicking on Member one causes a jump to Frame 100.

document.Animation name.setframe(100, "f,0");

This line causes a jump to happen on reaching Frame 100. When the NetAnimation reaches Frame 100,

it jumps back to Frame 0.

You can create very sophisticated animation effects by changing these parameters in Java Script.
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Putting NetAnimations on the Web with the ActiveX Control

You can use the NetAnimator ActiveX Control in programs and in web pages. Here is an example how

to use the ActiveX Control in a web page.

Name and save a project file (.nap file) as a NetAnimation file (.nae file)  by selecting File>Export

Animation.

Select the ActiveX Tab.

Using the tabs, you can select to use either the Java Viewer or the ActiveX Control. You can select many

options for the HTML page and animation you generate. Many of them already include default values

from your project file:

Title

The name of the HTML page that NetAnimator generates.
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Object Name

Displays the name of the control.

Code Base

Displays the folder or directory path from the HTML page to the Java Viewer. By default, the HTML

file is in the same directory as the folder containing the Java Viewer.

NetAnimator File

Displays the name of your NetAnimator project file.

Click Type

Determines if your NetAnimation responses to the press of the mouse button or the release of the mouse

button.

Play Type

Determines how the NetAnimation plays back through your browser. If you select Normal, the

NetAnimator Java Viewer uses as much memory as possible to speed playback of your animation.

Memory Saving allows simple, smaller animations to play back smoothly when the user's computer has

less memory.

Background Color

This option determines the background color of the HTML page. By default, NetAnimator selects Red

255, Green 255 and Blue 255, which is white.

Letter Color

This option determines the color of the text on the HTML page. By default, NetAnimator selects Red 0,

Green 0 and Blue 0, which is black.

After you finish selecting options, click OK and select a directory to contain your HTML file.

NetAnimator creates an HTML file using your specifications. You can edit this file in any HTML editor,

such as Microsoft Frontpage or NetObjects Fusion. You can also copy and paste the code NetAnimator

generates for use in other web pages.



IncWell NetAnimator User Guide

Chapter 4  Putting NetAnimations to Work

4 - 11

You need to install the NetAnimator ActiveX Control in the same directory as the HTML page. Your

animation replays when the HTML page is loaded in an ActiveX compatible web browser.

Using the right browser

The ActiveX Control requires a compatible browser. Microsft Internet Explorer for Windows 3.0 or

higher supports ActiveX Controls.

 Using the lastest version of the OCX

IncWell Software upgrades the NetAnimator OCX as web browsers are upgraded. Visit the IncWell web

site where you can download the newest version of the ActiveX Control.

Using the NetAnimator ActiveX Control with VB Script

You can use Microsoft's VB Script to automate and change the parameters of the ActiveX Control at

runtime. Experienced web and application designers can automate the ActiveX Control using VB Script,

using the following paramenters:

<BODY BGCOLOR="#ffffff" TEXT="#000000" onLoad = "init()">

<OBJECT ID="Animation name"  CODEBASE="netanimator.ocx"

 CLASSID="CLSID:067A1825-5748-11D2-AAE8-0000C53800CB"

 WIDTH=300 HEIGHT=200 >

 <PARAM NAME = "READYSTATE" VALUE = 0>

</OBJECT>

<SCRIPT LANGUAGE = "VBScript">

  function init()

    netanimator1.filename = "filename.nae"

    netanimator1.animationspeed = 2

    netanimator1.clicktype = 0
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    netanimator1.setframe 100 ,"f,0"

    netanimator1.setmember 1,"f,100"

   end function

</SCRIPT>

Defining NetAnimator ActiveX Control  Parameters

Using VB Script, you can change the values of the NetAnimator ActiveX Control at runtime. Here is a

description of the VB Script code that NetAnimator generates when you Generate HTML and select the

ActiveX Control option:

<BODY BGCOLOR="#ffffff" TEXT="#000000" onLoad = "init()">

The first line, "init()", initializes the page.

  

<OBJECT ID="Animation name"  CODEBASE="netanimator.ocx"

 CLASSID="CLSID:067A1825-5748-11D2-AAE8-0000C53800CB"

 WIDTH=300 HEIGHT=200 >

Object ID and CODEBASE identify the name of your NetAnimation and the name of the ActiveX

Control. VB Script uses CODEBASE to identify the relative path of the ActiveX Control as well.

CLASSID identifies the ActiveX Control and includes version information. If you download an update

to the NetAnimator ActiveX Control from the IncWell web site, the newer version will have a different

CLASSID.

WIDTH and HEIGHT identify the size of your NetAnimation in pixels.

<PARAM NAME = "READYSTATE" VALUE = 0>

This is automatically inserted. Do not change it through scripting.

<SCRIPT LANGUAGE = "VBScript">
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This identifies the scripting language used in the web page as VB Script.

netanimator1.animationspeed = 2

This line determines the playback speed of your NetAnimation. Speed ranges from 1 (Fast) to 10 (Slow).

netanimator1.clicktype = 0

ClickType determines if a Jump Event occurs when the mouse button is pressed or released. A value of 0

equals a mouse-up event. A value of 1 equals a mouse-down event.

netanimator1.setframe 100 ,"f,0"

This sets a Jump to Frame to occur when a replaying animation reaches a frame. The setframe parameter

determines the frame in which a Jump begins. The "f, 0" parameter determines the end frame of the

Jump. In this example, the target frame is Frame 0. Both the beginning and ending frames can range

between 0 and 1000.

netanimator1.setmember 1,"f,100"

This sets a Jump to URL to occur when a Member is clicked. The setmember parameter determines the

Member number. The "f, 0" parameter determines the end frame of the Jump. In this example, the target

frame is Frame 0. Both the beginning and ending frames can range between 0 and 1000.

Designates a place where it is jumped when clicking a specific member with mouse. It can be omitted.

Using the NetAnimator ActiveX Control for Application Development

ActiveX Controls are used in many application development environments, such as Microsoft Visual

C++ and Microsoft Visual Basic, for creation of standalone alone programs. You can use the

NetAnimator ActiveX Control in developing applications with sophisticated animation. Please refer to

the parameters in the sections on scripting in this manual for more information.
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Creating NetAnimator Screen Savers

You can create native Windows screen savers from your completed NetAnimator files. In this section

you can learn how to export and install a NetAnimator Screen Saver.

1. Save your NetAnimator project file (.nap file) as a NetAnimation (.nae file).

2. From the File menu, select Export Screen Saver.

The Save dialog box appears. Choose a folder where you want to keep your NetAnimator Screen Savers

and name your file (.SCR file).

3. Drag the NetAnimator Screen Saver file into the Windows folder on your computer.

4. From the Start menu, select Settings>Control Panel. Click the Display applet, and select the Screen

Saver Tab.

5. From the Screen Saver options, select your new Screen Saver. Click OK.

Refer to your Microsoft Windows documentation for further information about managing screen savers

on your computer.

  Screen Savers replay best in 16-bit color.
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