
Adobe® Encore™ DVD Read Me 
 
August, 2003 
 
 
Welcome to Adobe Encore DVD!  
This file contains late-breaking product information, updates to the Adobe Encore 
DVD documentation, and troubleshooting tips. Please print this document for 
future reference. 
 
Please refer to the Installation Read Me for installation instructions.  
 
The Help menu in Adobe Encore contains the entire User Guide. The online 
version of the User Guide has additional technical information and examples not 
found in the printed documentation. For your convenience, PDF versions of the 
online documentation are located on your DVD. 
 
For further troubleshooting and information, see the User Guide, online Help, or 
Adobe.com.  
 
This file includes the following sections: 
 
* Important: Registration Information 
* System Requirements 
* Serial Number 
* Installation Notes 
* User Guide Addendum 
* General Notes 
* Other Resources 
 
 



Important: Registration Information 
Please complete your registration card and mail it today or register on-line (Help 
> Registration...). You must register to receive technical support and important 
product update information: www.adobe.com/products/encore/main.html. 
 
System Requirements 
Intel® Pentium® III 800MHz or faster processor (Pentium 4 and/or 
multiprocessor recommended) 
Microsoft® Windows® XP Professional or Windows XP Home Edition 
256MB of RAM (512MB or more recommended) 
500MB of available hard-disk space required for installation 
2GB of additional hard-disk space recommended for extra content 
10GB or larger hard disk or disk array recommended for ongoing work 
1,280x1,024 32-bit color, DirectX compatible video display adapter (dual 
monitors recommended) 
DVD-ROM drive 
Supported DVD burner (list available at www.adobe.com/encore) 
Stereo sound card 
 
Serial Number  
You can find your serial number on the back of the DVD case. Use this number 
to initialize the program. If your serial number does not work, please contact 
Adobe Customer Support: www.adobe.com/support/main.html 
 
Installation Notes  
You must have administrator permissions to run the Windows installer on 
Windows XP. 
 
On some systems with Windows XP, having System Restore enabled during 
installation causes the installation to take an extremely long time. The computer 
may appear to be locked up. To avoid this, turn off System Restore before 
installing (Start > Control Panel > System > System Restore). It is also 
recommended that System Restore be turned off before uninstalling. 
 
To uninstall or repair an Adobe Encore DVD installation, use Start > Control 
Panel > Add/Remove Programs.  
 
 



User Guide Addendum 
The following features are not documented in the User Guide: 

Embedding chapter points in MPEG-2 files from Adobe® 
Premiere® Pro 
Encore can read markers in MPEG-2 files exported from Adobe Premiere Pro 
and automatically create chapter points within a Timeline. 

Creating chapter markers in Adobe Premiere Pro 
Adobe Premiere offers a number of different marker types. See the Adobe 
Premiere Pro User Guide for more information. To make markers that will be 
recognized by Adobe Encore, do the following: 

• Use numbered markers  
• To flag a numbered marker as a chapter point, you must enter text in the 

Chapter field of the marker info dialog. Text entered in the Comments field 
for the marker will also be imported into Adobe Encore DVD  

Exporting from Adobe Premiere Pro 
Note: for more details on exporting from Adobe Premiere, see the Adobe 
Premiere Pro User Guide. 
To export the file, do the following: 

• Select the Sequence in the Adobe Premiere Project window  
• Choose File > Export > Adobe Media Encoder…  
• Choose MPEG-2 DVD from the list of formats in the Transcode Settings 

window  
• Select the desired preset  
• Make sure that Multiplexing is set to “None”.  
• Export the file  

Using the file in Adobe Encore DVD 
When you add the file to a Timeline in Adobe Encore, the chapter points will 
automatically be added in the same location as the original Adobe Premiere 
project.  
Note that after importing, the chapter points are independent of the markers in 
the original Adobe Premiere project. 
For more details on working with files in Adobe Encore, see the Adobe Encore 
DVD User Guide. 
 
 
 
 
 
 



Edit Original for files exported from Adobe Premiere Pro and 
Adobe® After Effects® 
Adobe Encore DVD supports Edit Original for files that are exported from After 
Effects and Adobe Premiere Pro. This means that you can send a file back to the 
application that created it for more changes. Once changes have been made and 
a new file rendered, Adobe Encore will automatically update your DVD project to 
use the new file. 

Exporting files from Adobe Premiere Pro 
MPEG-2 files that are exported from Adobe Premiere automatically include a 
project link, so Edit Original is available from within Adobe Encore. 
For AVI files, you must export via File > Export > Movie… and embed the project 
using the General Export Movie Settings. 

Exporting files from After Effects 
Export an AVI file from After Effects 6.0 and choose “Embed Project Link” from 
the output options in the Render Queue. When the file is imported into Adobe 
Encore DVD, Edit Original will be available as an option (see below for more 
information).  

Edit Original in Adobe Encore DVD 
In Adobe Encore, when you select a file that has an embedded project link, Edit 
Original becomes available. You may select the file in the Project Window or 
within a Timeline. 
To Edit Original, do the following: 

• Select the file  
• Choose Edit > Edit Original  

The application that created the file will launch and the project file will open. 
  
To make changes to the project and update the file in Adobe Encore, do the 
following: 

• Make changes to the original project  
• When finished, export a new AVI or MPEG-2 file using the same name as 

the original file, click Yes to overwrite the file when prompted  
• When the export finishes, Adobe Encore will reimport the file and update 

the project with any changes that were made.  
 
 
 
 
 
 
 
 



Known Issues and Limitations 
 
Display Adapters 
Certain video cards, including the ATI Fire GL E1 video adapter, are known to 
cause problems in Adobe Encore during video playback and while working in the 
Menu Editor. To remedy this, you must turn down hardware acceleration. 
Updating video cards to the latest drivers may also fix the problem. 
To turn down hardware acceleration, do the following: 

• Right-click on the Desktop and choose “Properties” 
• In the dialog that appears, choose the ‘Settings” tab and press the 

“Advanced” button 
• In the dialog that appears, click the “Troubleshoot” tab 
• Move the “Hardware acceleration” slider three notches to the left 
• Hit OK in all dialogs to confirm the changes 

Adobe Encore will now run correctly. 
 

MPEG I-Frames 
When linking buttons with video thumbnail layers to chapter points in timelines 
containing MPEG-2 video assets, the frame displayed in the thumbnail layer may 
not be correct- it could be the frame up to two GOP headers ahead of the chapter 
point or poster frame being linked to. To work around this problem, create a 
poster frame that is offset negatively by the same amount. This may require 
some trial and error. 
 
AVI Playback 
High data rate AVI files may not play back in perfect sync with audio in the 
Monitor or Preview windows. For accurate audio sync, transcode the file before 
playing it back in Preview or Monitor window. 
 
DVD Burning 
Adobe Encore may freeze if you attempt to write to a DVD burner while it is being 
used by another application. You must quit any other DVD burning applications 
before writing discs from within Adobe Encore. 
 
When burning projects to DVD-R/RW, writing the lead-out may take up to 10 
minutes to complete. This is a format requirement for DVD-R/RW; writing the 
lead out on DVD+R/RW is significantly faster. 
 
Compatibility: Canopus AVI Files 
Adobe Encore is not entirely compatible with AVI files that have been exported 
using the Canopus DV codec.The workaround is to export using the Microsoft DV 
codec, or encode directly to MPEG-2. 
 
Canopus Reference AVI files are not supported.  When using the Canopus 
encoder, please be sure that standard rather than reference AVI files are 
created. 



 
Compatibility: DirectShow  
On some systems, an error “Error setting Subpicture” may be seen when working 
with subtitles or motion menus. This is a DirectShow problem that may be 
remedied by setting the color depth for your monitor to 16-bit color. 
 
Transcoding 
Automatic transcoding settings do not take into account the field dominance of 
the source file. Lower-field dominance is always used. For DV, this presents no 
problems. However, if you are using progressive frame or upper-field dominant 
content you must choose a transcoding preset that has the correct field 
dominance settings. 
 
Source files are always transcoded in their entirety, even if they have been 
trimmed in the Timeline. This is so that you can change the trim point in the 
Timeline after transcoding has taken place. However, it means that transcoding 
very long files that have been trimmed significantly will take a long time. A 
workaround to this is to trim the file before you bring it into Adobe Encore. 
 
Variable bit-rate MPEG audio files are not supported. In general, we recommend 
using Dolby Digital audio, either created outside Adobe Encore or using the built-
in Dolby Digital encoder. However, if you must use MPEG audio, make sure it is 
constant bit rate. 
 
Menu Editor 
When using the Create Subpicture command to generate button highlights within 
Adobe Encore, any existing highlight layers for that button will be overwritten. 
 
Adobe Premiere Pro Interoperability 
Markers in Adobe Premiere Pro AVI files are not available for use as chapter 
points in Adobe Encore. You must use MPEG-2 export from Premiere. See the 
User Guide Addendum section in this document for more information on how to 
do this. 
 
Project Preview 
Project Preview of a motion menu that loops a specified number of times (i.e. not 
Forever) will display black for a second or two at each loop. This is a Project 
Preview problem only. On the final disc, the last frame will be held while the 
player seeks to the start of the loop. No black frame will be seen. 
 
Subtitles 
It is recommended to use box text for creation of subtitles within Encore. If, 
however you do create subtitles using point text, do not allow the text to run off of 
the monitor’s viewable area. You may lose, or have problems when editing the 
off-screen text. 
 



 
Hitting the Enter key while in the Import Subtitles dialog when the cursor is in a 
text field will start the import, rather than confirming the value in the text field. If 
this happens, cancel the import and start again. Note: tabbing through the dialog 
will avoid this problem. 
 
Shift and Alt keys provide control over scaling objects in the Menu Editor, but 
these shortcuts are not available for subtitles. 
 
Using the “Trim Subtitle to Here” buttons in the Monitor window during playback 
can cause subtitles to be trimmed from the wrong end. We recommend using this 
feature while in pause mode. 
 
When working with subtitles, be careful not to scale them outside of the Monitor 
window area, which may cause them to disappear. If this happens, delete the 
subtitle block from the Timeline, and re-enter it. 
 
The top part of some Japanese characters can be cut off in subtitles if “Align from 
Top” is set to 0% and text orientation is horizontal. Workaround: Adjust the “Align 
from Top” value until the characters show correctly. 
 
Motion Menus 
In some cases, motion menus may have to be re-rendered if the project is closed 
and menus are unrendered. Rendering once more fixes the problem. 
 
Timelines 
In some cases with 24fps content that was transcoded on import, the play head 
will stop moving in the Timeline during playback, even though the video 
continues playing. This is a visual defect and causes no other known problems.  
 
Links 
The Links list in the Properties tab remembers the 20 last-used items in your 
project. However, this list is not remembered when a project is closed and 
reopened. You may find that some of the items in your project don’t show up in 
the list. You can fix this by opening up the Menus and Timelines in your project. 
Alternatively, use the pickwhip or “Specify Other” dialog to choose link 
destinations.  
 
Copy Protection 
Copy protection can only be applied to DVD projects which will be mastered to 
DLT for mass replication in a facility. If you inadvertently turn on copy protection 
and select a Macrovision setting, you will get an error about sector headers that 
will prevent you from burning your DVD. Click the Project Settings button in the 
Disc tab, select No Copies are Allowed in the CGMS popup menu, and then set 
the Macrovision setting to Off. Finally, set CGMS back to Unlimited Copies Are 



Allowed. You should now be able to burn the DVD without the sector header 
error. 
 
 
Other Resources 
Visit the Adobe Encore DVD page on the Adobe Systems Incorporated Web site: 
www.adobe.com/encore 
 
You will find links to tutorials, Adobe Customer Support, and more. 
 
Also, sign up for our free Technical Announcements - timely e-mails that will 
keep you up-to-date with technical information, patches and more: 
www.adobe.com/support/emaillist.html 
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