
Connected Diagrams

For an overview of the best way to create a connected diagram, see
“The Big Picture.”

To create a flowchart, network diagram, organization chart, or cause
and effect diagram as quickly as possible, turn directly to the “Creat-
ing...” topic for the diagram you want to draw.

For detailed information, see the In Depth topics in this and other
chapters.
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Printing 

We recommend that you print this document in sections. Printing the entire document may cause printing errors due to insufficient memory.

If you're printing to a Laserjet 4 using a HP Laserjet 4 printer driver, you need to change these printer options: 
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3. In the Graphics Mode section, choose the Raster option.
4. Click OK to exit the Options dialog box.
5. Click OK.

Note: Acrobat only supports PostScript and PCL printers.
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T H E  B I G  P I C T U R E

1Open a template for the kind of
connected diagram you want to create.

2 Set up the drawing page.

3Title your diagram. 4 Drag and drop to connect two-
dimensional shapes.
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5 Add text to the shapes.

7 Save and produce the diagram.

6 Refine the diagram.
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C R E A T I N G  A  F L O W C H A R T

We’ve provided complete instructions for creating a flowchart. To
create your particular flowchart, you may not need to complete each
of the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open the flowchart template:

1. Start Visio.

2. In the New box, under Based On, choose Flowchart Template,
then click OK.

Visio opens a new file with a blank drawing page.
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Or, you can choose to open the Flowchart Wizard template in the
New box. The Wizard guides you through the process of creating a
flowchart, and of choosing page size, orientation, and other layout
features.

To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size, then click OK until you
return to the drawing page.

For more details, see:

Setting Up a Diagram ........................................ 202

To title a flowchart:

1. From the toolbar, choose the text tool.

2. With the crossbar, point to where you want your flowchart title
to start, then click and drag a box about the size you think your
title will be.

3. Type the title.

4. From the Format menu, choose Font.

5. In the Font box, choose the title text’s font, size, color, and style,
then click OK.
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6. From the toolbar, choose the pointer tool.

7. Click the title text block to select it.

8. Drag a selection handle to change the text block width or height.

9. Position the pointer over the text block. When the pointer turns
white, drag the text block to where you want it to appear on the
page.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

To drag shapes onto the drawing page and connect them:

1. From the toolbar, choose the connector tool.

2. Drag and drop a two-dimensional shape.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

3. With the first shape selected, drag and drop a second shape. Visio
automatically connects the shapes.

4. Drag and drop enough shapes to build the flowchart. Each new
shape connects to the selected shape.

5. Use the grid to align shapes on the page.

For more details, see:

Connecting Shapes .............................................. 32
Dragging and Dropping Shapes ......................... 26
Positioning Shapes on the Page .......................... 92
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To add text to shapes:

1. Select the shape or connector you want to add text to.

2. Type the text. Visio zooms in on the selected shape as you type.

3. Press the ESC key to return to the original magnification.

For more details, see:

Working with Text ............................................. 168

Refine the look of a flowchart

To change the way a shape looks:

1. Select the two-dimensional shape or connector you want to
format.

2. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

3. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

To change the way text looks:

1. Select the shape that includes text or the text block you want to
change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

To rearrange shapes on the page:

1. Select the shape you want to rearrange, then drag it to a new
location. The shape retains its connections, although the
connector may move to another point on the shape.

Lorem

Lorem
Lorem
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To move a connection from one shape to another:

1. Select the connector you want to move.

2. Place the pointer over a connector endpoint, where it turns into a
four-headed arrow.

3. Press the CTRL key and drag the connector’s endpoint from the
original shape to the new shape you want to connect.

For more details, see:

Connecting Shapes .............................................. 32
Formatting Shapes with Styles .......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

To link a flowchart shape to a page or document:

1. Right-click the shape you want to link.

2. From the shortcut menu, choose Link To Page or Link To Doc.

3. In the Link To Page box, choose the options you want and click
OK; or, in the Link To Document box, choose the document you
want to link to, then click Open.

For more details, see:

Linking Shapes to Pages and Files ...................... 38

To associate data with a flowchart shape:

1. Right-click the shape, then choose Custom Properties from the
shortcut menu.

2. In the Custom Properties box, enter values for the properties,
then click OK.

For more details, see:

Associating Properties with Shapes .................... 74
Generating Numerical Reports ........................... 47
Take an Inventory of Your Diagram ................... 69
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Save and produce the flowchart

To name and save a completed flowchart:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the flowchart, choose the
other options you want, then click Save.

To print a flowchart:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the flowchart in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your flowchart file to another document (so that when you
update the original you’ll also update the linked copy in the docu-
ment):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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C R E A T I N G  A
N E T W O R K  D I A G R A M

We’ve provided complete instructions for creating a network dia-
gram. To create your particular diagram, you may not need to
complete each of the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open the network template:

1. Start Visio.

2. In the New box, under Based On, choose Network Template,
then click OK.

Visio opens a new file with a blank drawing page.
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size, then click OK.

For more details, see:

Setting Up a Diagram ........................................ 202

To title a network diagram:

1. From the toolbar, choose the text tool.

2. With the crossbar, point to where you want your network
diagram title to start, then click and drag a box about the size
you think your title will be.

3. Type the title.

4. From the Format menu, choose Font.

5. In the Font box, choose the title text’s font, size, color, and style,
then click OK.

6. From the toolbar, choose the pointer tool.

7. Click the title text block to select it.

8. Drag a selection handle to change the text block width or height.

9. Position the pointer over the text block. When the pointer turns
white, drag the text block to where you want it to appear on the
page.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168
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To drag shapes onto the drawing page and connect them:

1. Drag and drop a Ring shape, Bus shape, or Ethernet shape.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Drag and drop computer and box shapes in the vicinity of the
Ring, Bus, or Ethernet shape.

3. Select the Ring, Bus, or Ethernet shape.

4. Place the pointer over a control handle. When the pointer
changes to a four-way arrow, drag it to the connection point on
one of the computer or box shapes.

5. Continue dragging control handles to connection points until all
the computer and bus shapes are connected.

For more details, see:

Control Handles ................................................ 101
Dragging and Dropping Shapes ......................... 26
Positioning Shapes on the Page .......................... 92

To add text to shapes:

1. Select the shape or connector you want to add text to.

2. Type the text. Visio zooms in on the selected shape as you type.

3. Press the ESC key to return to the original magnification.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

Lorem
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Refine the look of a network diagram

To change the way a shape looks:

1. Select the shape you want to format, or select the shape and then
click one of its parts to subselect it.

2. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

3. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

To change the way text looks:

1. Select the shape that includes text or the text block you want to
change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

To move a connection from one shape to another:

1. Select the connector you want to move.

2. Place the pointer over a connector endpoint, where it turns into a
four-headed arrow.

3. Drag the connector’s endpoint from the original shape to the
new shape you want to connect.

To rearrange shapes:

1. Select the shape you want to move, then drag it to a new loca-
tion. The shape retains its connections.

For more details, see:

Connecting Shapes .............................................. 32
Formatting Shapes with Styles .......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

Lorem
Lorem
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To link a Cloud or City shape to a page or document:

1. Right-click the Cloud or City you want to link.

2. From the shortcut menu, choose Link To Page or Link To Doc.

3. In the Link To Page box, choose the options you want and click
OK; or, in the Link To Document box, choose the document you
want to link to, then click Open.

For more details, see:

Linking Shapes to Pages and Files ...................... 38

To associate data with a network shape:

1. Right-click the shape, then choose Custom Properties from the
shortcut menu.

2. In the Custom Properties box, enter values for the properties, the
click OK.

For more details, see:

Associating Properties with Shapes .................... 74
Generating Numerical Reports........................... 47
Take an Inventory of Your Diagram ................... 69

Save and produce a network diagram

To name and save a completed network diagram:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the network diagram, choose
the other options you want, then click Save.

To print a network diagram:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.
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To place a copy of the network diagram in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your network diagram file to another document (so that when
you update the original you’ll also update the linked copy in the
document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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C R E A T I N G  A N
O R G A N I Z A T I O N  C H A R T

We’ve provided complete instructions for creating an organization
chart. To create your particular chart, you may not need to complete
each of the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open the organization chart template:

1. Start Visio.

2. In the New box, under Based On, choose Orgchart Template,
then click OK.

Visio opens a new file with a blank drawing page.
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Or, you can open the Orgchart Wizard template in the New box. The
Wizard guides you through the process of creating an organization
chart based on data in a text or spreadsheet file. It also helps you lay
out and format organization chart shapes, connectors, and text.

To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size, then click OK.

For more details, see:

Setting Up a Diagram ........................................ 202

To title an organization chart:

1. Drag and drop the Title shape, then position it where you want
the title to appear on the page. Type to replace existing company
name text. The date is a field that will update automatically.

For more details, see:

Adding Page Numbers and Other Fields ......... 164
Finding and Correcting Text ............................. 160
Working with Text ............................................. 168
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To drag shapes onto the drawing page and connect them:

1. Drag and drop the organization chart shapes you want to use.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Select a shape that you want to connect to another shape above it
in the hierarchy.

3. Place the pointer over a control handle on the selected shape.
When the pointer changes to a four-way arrow, drag it to a
connection point on the shape to which you want the selected
shape to connect.

4. Continue dragging control handles to connection points until all
the shapes are connected.

For more details, see:

Control Handles ................................................ 101
Dragging and Dropping Shapes ......................... 26
Positioning Shapes on the Page .......................... 92

To add text to shapes:

1. Select the shape you want to add text to.

2. Type the text. Visio zooms in on the selected shape as you type.

3. Press the ESC key to return to the original magnification.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

Lorem
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Refine the look of an organization chart

To change overall organization chart appearance:

1. Click the page where there are no shapes.

2. Right-click and from the shortcut menu, choose Orgchart
Properties.

3. In the Custom Properties box, choose the options you want for
hiding or showing boxes and dividers, and for connector offset.

To change the way a shape looks:

1. Select the shape you want to format.

2. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

3. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

4. Right-click the shape, then choose Executive Properties, Manager
Properties, or Position Properties from the shortcut menu.

5. In the Custom Properties box, choose the options you want for
hiding or showing boxes and dividers, and for connector offset.

To change the way text looks:

1. Select the shape that includes text or the text block you want to
change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

For more details, see:

Formatting Shapes with Styles .......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

Lorem
Lorem
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To link a department page to a shape:

1. Right-click the shape you want to link.

2. From the shortcut menu, choose Make Department.

3. In the Make Department box, choose the options you want and
click OK. Visio cuts all the shape’s subordinates from the original
chart, opens a new page, and drops them on it. Use the right
mouse button to move between the page and the shape it’s linked
to.

For more details, see:

Linking Shapes to Pages and Files ...................... 38

To associate data with an organization chart shape:

1. Right-click the shape, then choose Executive Properties, Manager
Properties, or Position Properties from the shortcut menu.

2. In the Custom Properties box, enter the data you want, then click
OK.

For more details, see:

Associating Properties with Shapes .................... 74

Save and produce the organization chart

To name and save a completed organization chart:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the organization chart,
choose the other options you want, then click Save.

To print an organization chart:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.
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To place a copy of the organization chart in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your organization chart file to another document (so that
when you update the original you’ll also update the linked copy in
the document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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C R E A T I N G  A
C A U S E  A N D  E F F E C T  D I A G R A M

We’ve provided complete instructions for creating a cause and effect
diagram. To create your particular diagram, you may not need to
complete each of the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To begin a cause and effect diagram:

1. Start Visio.

2. In the New box, under Based On, choose Total Quality Manage-
ment Wizard template, then click OK.

Visio starts the wizard.
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3. When the Wizard prompts you to choose the type of process you
want to draw, check Cause and Effect.

4. Follow the Wizard’s instructions to choose the major categories
and the effect, and to choose page size, orientation, and other
page layout features.

To drag and drop cause shapes:

1. Choose a cause shape (Cause 1, Cause 2, or Cause 3), then drag
and drop the number of shapes you need.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Select a cause shape, then choose Flip Horizontal from the Shape
menu to get the shape to face the direction you want.

3. Align the tips of the cause arrows with the category lines.

4. Select a cause shape and type to replace the existing text.

For more details, see:

Positioning Shapes on the Page .......................... 92
Rotating Shapes ................................................. 140

Refine the look of the cause and effect diagram

To change the way a shape looks:

1. Select the shape you want to format.

2. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

3. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

1
2

3
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To change the way text looks:

1. Select the shape that includes text or the text block you want to
change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

For more details, see:

Formatting Shapes with Styles ......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

To link a cause and effect shape to a page or document:

1. Select the shape you want to link.

2. From the Tools menu, choose Run Add-on, then choose Link To
Page or Link To Document.

3. In the Link To Page box, choose the options you want and click
OK; or, in the Link To Document box, choose the document you
want to link to, then click Open.

For more details, see

Linking Shapes to Pages and Files ...................... 38

Save and produce the cause and effect diagram

To name and save a completed diagram:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the diagram, choose the
other options you want, then click Save.

To print a diagram:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

Lorem
Lorem
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To place a copy of the diagram in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your diagram file to another document (so that when you
update the original you’ll also update the linked copy in the docu-
ment):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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D R A G G I N G  A N D  D R O P P I N G  S H A P E S

In Visio, the easiest way to draw is to
drag shapes from stencils and drop them
onto a drawing page.

Shapes you drag and drop have a stacking
order. The first shape you drop is on the
bottom and the last shape is on the top.

In many situations, the top, or primary,
shape determines how other shapes behave.
You can make any shape primary by
selecting it or by changing its stacking
order.

For related information, see online Help:
press F1, click Search, click Index, then
type “drag” or “stack.”

To drag and drop a shape on the drawing page:
1. From the toolbar, choose the pointer

tool.

2. In the stencil window, point to the
icon for the shape you want to place
on the drawing page.

3. Hold down the left mouse button and
drag.

When you select shapes by dragging a
selection net around them, the top shape is
automatically primary.

When you shift-click to select
multiple shapes, the shape you
select first is primary.

➊

Pause while dragging to see
the shape itself rather than
just an outline of the shape.

➋

➌
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To copy a shape on the drawing page:
1. Hold down the mouse button on the

shape.

2. Press the CTRL key, then drag a copy
of the shape to the new location.

3. Press the F4 key to add more shapes
offset the same amount.

Tip: You can also quickly add multiple
copies of a shape using the stamp tool.
From the connection tool menu on the
toolbar, select the stamp tool. On the
stencil, click the master shape on the
stencil that you want to copy, then click
on the page where you want the copies.

To copy a shape and align the copies with the original:
1. Hold down the mouse button on the

shape.

2. Press the CTRL and SHIFT keys, then
drag a copy of the shape to the new
location.

3. Press the F4 key to add more shapes
offset the same amount.

More Ø

➊

➋

➌

➊

➋ ➌
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➊

How to Select Shapes
To Do This

Select one shape Click the shape with the pointer tool.

Select several shapes by clicking Select the first shape, hold down the Shift key, then click the other shapes one at a
time.

Select several shapes by dragging With the pointer tool, drag a selection net around all the shapes you want to select.

Select all shapes on a page From the Edit menu, choose Select All.

Select all of a particular kind of object, From the Edit menu, choose Select Special. In the Select Special box, check Shape
such as shapes, groups, guides, and so on Type, then check the kind of object you want to select.

Cancel a selection Click away from the selected shape.

Cancel the selection of one shape Hold down the shift key and click the shape.
when several are selected

To bring a shape to the top of the stack:
1. Select the shape you want on top.

2. From the Shape menu, choose Bring To
Front.

The shape you selected is brought to
the top of the stack.

➋
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➋

➊

To send a shape to the bottom of the stack:
1. Select the shape you want on the

bottom.

2. From the Shape menu, choose Send To
Back.

The shape you selected is sent to the
bottom of the stack.

To move a shape one position in the stack:
1. Select the shape you want to move.

2. From the Shape menu, choose Bring
Forward or Send Backward.

The shape you selected has moved one
position in the stack.

➊

➋
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S N A P P I N G  A N D  G L U I N G  S H A P E S

Snap and glue are Visio tools that allow
you to accurately position and move
shapes.

Snapping pulls shapes toward the objects
you want them to line up with. You can
control when you snap, what objects
shapes snap to, and snap strength.

Glue connects shapes to other objects.
Once shapes are glued, you can move
them and still retain their connections.
Glue is particularly useful in flowcharts,
organization charts, and network diagrams.
(You can control when to glue and which
points objects glue to on shapes.)

You can also control the strength with
which shapes snap and glue to rulers, grid
lines, guides, and connection points. If you
increase snap and glue strength for
connection points, for example, and
decrease it for a guide, shapes will jump
toward a connection point even with a
guide nearby.

For related information, see online Help:
press F1, click Search, click Index, then
type “snap” or “glue.”

Shapes line up more easily when they snap to grid lines, ruler
subdivisions, or guides.

Turn off snap options you don’t want so they don’t interfere with your
work. For example, if you want shapes to snap to guides, turn off the grid
line and ruler subdivision options.

When you glue shapes to a guide, if you move the guide, you also
move the shapes.

2.50 in.
0.88 in.

By gluing a dimension line to a shape’s selection handles, you can
measure the shape while you resize it.
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To set snap and glue options:
1. From the Tools menu, choose Snap and

Glue.

2. In the Snap and Glue box, check the
options you want and uncheck the
options you don’t want, then click OK.

Snap and Glue options

A Check Snap or Glue to make them
active. Uncheck to make them inactive.

B Check the objects you want shapes to
snap to. Uncheck the objects you don’t
want shapes to snap to.

C Drag the box in the appropriate bar to
increase or decrease snap and glue
strength.

D Check the objects you want shapes to
glue to. Uncheck the objects you don’t
want shapes to glue to.

A

B

C

D

➊ ➋
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C O N N E C T I N G  S H A P E S

In some types of diagrams, such as
flowcharts, organization charts, and
network diagrams, the connections between
shapes are as important as the shapes
themselves.

Usually, when you connect shapes, the
connection is point-to-point, that is, from a
specific point on one shape to a specific
point on another. If you move the shapes,
the two specific points remain connected.
Point-to-point connections are useful in
hierarchical diagrams such as organization
charts, where information, such as
reporting structure and levels of responsi-
bility, is indicated by how shapes connect.

You can also make shape-to-shape, or
dynamic, connections between shapes. In
shape-to-shape connections, two shapes
rather than any specific points on them
are connected. When you move the shapes
the connector also moves to connect the
two points closest to one another. Dynamic
connections are useful in diagrams such as
flowcharts, where connections indicate a
process and it doesn’t matter which
specific points are connected.

For related information:
Snapping and Gluing Shapes. ...................... 30

See online Help, press F1, click Search,
click Index, then type “connect.”

In Visio, you use one-dimensional connectors to connect two-dimensional
shapes. Blue x’s on two-dimensional shapes are connection points where
you can glue connector endpoints.

When you make a point-to-point connection, a box appears around the
connection point and connectors have identifiable beginning and ending
points. If you move the shapes, the two specific points remain connected.

When you make a shape-to-shape connection, a box appears around the
shape, and connectors have unmarked endpoints. If you move the shapes,
the connector also moves to connect the two closest points.



C O N N E C T E D   D I A G R A M S 33

Suggested Methods for Connecting Shapes
To Use This Tool Do This

Create flowcharts Connector Tool Choose the connector tool. Drag and drop
shapes.

Connect shapes Connect Shapes Select the shapes you want to connect.
already on the page Command From the Tools menu, choose Connect Shapes.

Create organization charts Control handle on Drag and drop a shape with a connector control
or network diagrams a shape handle. Drag the control handle on one shape to

a connection point on another shape.

Connect specific Connector shapes Drag and drop two two-dimensional shapes. Drag
points on shapes on stencils and drop a connector. Drag the connectors’

endpoints to connection points on the two-
dimensional shapes.

Connect specific points on shapes Stamp tool and Drag and drop two two-dimensional shapes.
connector shapes From the connection tool menu, choose the

stamp tool. On the stencil, click a connector
master shape. On the drawing page, position
the pointer over a connection point on
one 2-D shape and drag to a connection point
on the second shape.

More Ø
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To add a connection point to a shape:
1. Select the shape you want to add a

connection point to.

2. From the connection tool menu on the
toolbar, choose the connection point
tool.

3. Hold down the CTRL key and click on,
inside, or outside a shape’s boundaries.

Tip: To delete a connection point, choose
the connection point tool, click the point
you want to delete, then press the Delete
key.

For related information, see online Help:
press F1, click Search, click Index, then
type “displaying: connection.”

Connection point tool

➊

➋

➌
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To convert a point-to-point connection to a shape-to-shape connection:
1. Hold down the CTRL key.

2. Drag a connector endpoint away from
the two-dimensional shapes’ connection
points, then, drag it back.

3. Repeat with the other connector
endpoint.

Tip: To convert a shape-to-shape
connection to a point-to-point connection,
repeat the same procedure but don’t hold
down the CTRL key.

➊ ➋

➌
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P R E V I E W I N G  D I A G R A M S

Before you open a Visio diagram you can
preview it to be sure you’re opening the
diagram you want.

To preview a diagram before you open it:
1. From the Windows 95 Start menu,

choose Program, then choose Windows
Explorer.

2. Right-click a Visio file, then choose
Quick View from the shortcut menu.

3. To open the Visio diagram from the
preview, click the icon in the upper-
left corner of the window.

Tip: To open subsequent previews in the
same Quick View window, choose Replace
Window from the Quick View menu.

When you preview a diagram, you see a thumbnail of the
first page. If it’s the diagram you want, you can open it from
the preview page.

➊

➋

➌
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C H A N G I N G  M A G N I F I C A T I O N

When you’re working on a Visio diagram,
you can change the magnification. This
allows you to see the whole diagram when
you’re dragging shapes onto the drawing
page, or to focus on one particular section
when you’re fine-tuning a shape’s position
or appearance.

For related information, see online Help:
press F1, click Search, click Index, then
type “zoom.”

Changing the magnification of an open diagram
To Do This

Zoom in Press Ctrl + Shift + left mouse click

Zoom out Press Ctrl + Shift + right mouse click

Zoom in on a selected area Hold down Ctrl + Shift + left mouse button and drag a rectangle around the area
you want to zoom in on

Automatically scroll Hold down Ctrl + Shift + right mouse button and drag the page

Tip: You can also zoom in or out by
choosing a magnification from the Set
Zoom list on the toolbar.
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L I N K I N G  S H A P E S  T O  P A G E S  A N D  F I L E S

In Visio you can link shapes to other Visio
pages or to documents created in other
programs. You can also link shapes to
programs. For example, you can attach a
page to a computer shape in a network
diagram specifying the computer’s owner,
purpose, and location. Or, you can attach
a Microsoft Word document to a flowchart
process shape that explains the steps in
the process and the personnel involved.

Once you’ve created an annotation, you
can attach it to additional shapes.

You can link more than one shape to the same page or document.

You can link information about shapes to an Excel file.

Shapes on the Flowchart and Total Quality Management stencils are
programmed to make linking easier. Right-click a shape and choose a link
option from the shortcut menu.
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More Ø

To link a shape to a Visio page:
1. Select the shape you want to link.

2. From the Tools menu, choose Run Add-
On, then choose Link To Page.

3. In the Link box, type a name for the
page, click Add Drop Shadow if you
want a shadow to indicate a linked
shape, then click OK.

To link a shape to a document or program:
1. Select the shape you want to annotate.

2. From the Tools menu, choose Run Add-
On, then choose Link To Doc.

3. In the Link box, locate the document
or program you want to link the shape
to, then click OK.

➊ ➋

➌

➊ ➋

➌
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To link more than one shape to a page:
1. Select the new shape you want to link.

2. From the Tools menu, choose Run Add-
On, then choose Link To Page.

3. In the Link box, under Page Name,
choose the name of the page you want
to link the new shape to, then click
OK.

To link more than one shape to a document or program:
1. Select the new shape you want to link.

2. From the Tools menu, choose Run Add-
On, then choose Link To Doc.

3. In the Link box, choose the name of
the document or program you want to
link the new shape to, then click OK.

➊ ➋

➌

➊ ➋

➌
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To move between a shape and its link:
1. Right-click the shape, then choose Go

To from the shortcut menu.

2. If the link is to a page, right-click the
page, then choose Go To Shape to
return to the original page.

If the link is to a document, press ALT
+ TAB to return to the Visio page.

➊

➋
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S T A R T I N G  A  V I S I O  D I A G R A M

The best way to start a new diagram is to
open a template for the kind of diagram
you’re creating. For example, if you need
to draw a directional map, begin by
opening the Map template.

When you open a template, you actually
open a copy rather than the original
template file. That way, you won’t
inadvertently modify the original.

To use shapes not available on the stencils
that open with a template, you can open
additional stencils. Stencils are stored in
the Stencils subfolder of the Visio folder.

Tip: When you work in Visio, you can
choose how the toolbar will look. From
the Visio View menu, choose Toolbars. In
the Toolbars box, choose style and display
options for the toolbar. The display
resolution of your monitor and the size of
the Visio main window affect how many
toolbar buttons display.

For related information, see online Help:
press F1, click Search, click Index, then
type “starting.”

Opening a template gives you a head start on setting up your file.

A template includes stencils
that contain the shapes
most frequently used for
that specific type of
diagram.

The drawing page that opens with a
template is set up with the size, orientation,
scale, grid, and measurement system best
suited to the type of diagram you chose.

Lorem Ipsum

A template includes styles for text, lines, and fills. The shapes you drag
and drop have a consistent look.



C O N N E C T E D   D I A G R A M S 43

To start Visio and open a template:
1. If you’re using Windows 95, click Start,

choose Programs, then choose Visio.

If you’re using Windows 3.1, open the
Visio Program Group in Program Manager.
Double-click the icon of the template you
want to open.

Tip: To open a drawing page with no
stencils, click Visio instead of a template.
In the New box, under Based on, choose
No Template. ➊
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A
B

C
D

F
E

Properties Options

A Type to add properties to a document.
B Check to have a preview of the diagram appear when

you choose the file in the Open box.

B

A

Save As Options

A Choose to display the drive where you want to save your
diagram.

B Choose the folder where you want to save your diagram.
C Type a name for your diagram.
D Choose the type of file you want your diagram saved as.
E Check to prevent your diagram from being modified.
F Check to save the arrangement of stencil and drawing

windows as well as the diagram content.

S A V I N G  V I S I O  F I L E S

When you save a Visio diagram, you can:

• Save it as a drawing file or template;

• Save it in Visio 2.0 or 3.0 file format,
if you want to open the diagram using
earlier versions of Visio (the diagram
will lose information, such as layers or
shapes created with the freeform tool,
that are specific to Visio 4.0);

• Save it as read-only so no one else can
change it.

Save a diagram as a template when you
want to use its print, snap and glue,
drawing page and other settings, and the
arrangement of its stencil and drawing
page windows as a model for other
diagrams.

The first time you save a file, Visio
prompts you for document properties, such
as title, creator, keywords, and description.
Filling in the properties fields makes it
easier to identify the file later.

By inserting a special text field in a
diagram, you can display the diagram’s
document properties. When you update the
properties, the text field updates
automatically.

For related information, see:
Adding Page
Numbers and Other Fields ..................... 164

See online Help, press F1, click Search,
click Index, then type “saving.”
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More Ø

To save a new Visio file:
1. From the File menu, choose Save or

Save As.

2. In the Save As box, under Save As,
choose the file type you want to save
your file as.

3. Under Save In, locate the drive and
folder where you want your file saved.

4. Type a name for the file, then click
Save.

5. In the Properties box, enter the
summary information you want to save
with the file, check Save Preview
Picture if you want to be able to
preview the diagram before you open
it, then click OK.

➊

➋

➌

➍

➎

To revise document properties:
1. From the File menu, choose Properties.

2. In the Properties box, revise the
relevant information, then click OK.

Tip: To stop Visio from prompting you
for properties when you save, choose
Options from the Tool menu. In the
Options box, under General, uncheck
Prompt For Document Properties on Save.

➊

➋
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To save a diagram as a template:
1. Open the drawing file that contains

the stencils you want to save in a
template.

2. Set the settings and arrange the
windows the way you want them to
appear in the template.

3. From the File menu, choose Save As.

4. In the Save As box, under Save As,
choose Template (*.VST) from the list.

5. Type a name for the file, choose the
location where you want the file saved,
then click Save.

For related information, see online Help:
press F1, click Search, click Index, then
type “template.”

➊

➋

➌

➍

➎
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Lorem Ipsum
Dolor Sit Amet Nonummy

Title
TotalProperty

Cost $2,400.50
Duration  23
Resources  28

G E N E R A T I N G  N U M E R I C A L  R E P O R T S

If you associate numerical properties, such
as cost, duration, or resources with a
diagram’s shapes, you can use the Property
Reporting Wizard to perform calculations
using those properties and to generate
reports. For example, you could find the
cost for all equipment in a computer
network.

Generating reports involves two steps:

• Associate each shape with data.

• Run the Property Reporting Wizard and
perform the calculations you want.

For related information, see:
Associating Properties with Shapes ............ 74
Taking an Inventory of Your Diagram ...... 69

To generate reports using shape properties:
1. Create a diagram by dragging and

dropping shapes onto the drawing
page.

2. Associate the shapes with numerical
data on which you want to perform
calculations. (See Associating Properties
With Shapes, pp 74).

3. From the Tools menu, choose Run Add-
on, then choose Property Reporter.

4. Follow the instructions in the Property
Reporting Wizard boxes.

➊ ➋

➌ ➍
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Page 1 of 3

Name:

Prompt:

Wall square

Stretch rectangular wall to
desired dimensions.

Name:

Prompt:

Wall corner

Stretch corner wall to desired
dimensions.

Name:

Prompt:

Wall 2

Use stamp tool to layout walls
(glue to guides). Draw clockwise
to match interior dimensions.

Name:

Prompt:

Corner 2

Attach your wall sections to this
shape.

Name:

Prompt:

Table

Rectangular table. Resize table
to desired dimensions.

Name:

Prompt:

Door

Place over wall section. Stretch
width to size of door opening,
stretch height to thickness of wall.

Name:

Prompt:

Desk

Resize desk to desired
dimensions.

Name:

Prompt:

Conference table

Conference table with 8 chairs.
Open group to move chairs.

Name:

Prompt:

Desk chair

Resize desk chair to desired
dimensions.

Name:

Prompt:

Circular table

Circular table. Resize table to
desired dimensions.

Name:

Prompt:

Sofa

Stretch sofa to desired
dimensions.

Name:

Prompt:

Chair

Resize chair to desired
dimensions.

Office Layout Stencil

C:\VISBETA\STENCILS\OFFICE.VSS

P R I N T I N G  S T E N C I L S

Using the Stencil Report Wizard, you can
print copies of Visio stencils. Having a
printed copy can make it easier to locate
a specific shape and to compare shapes or
stencils to one another.

You can decide how many shapes to print
per page, whether or not to separate the
shapes with grid lines, whether or not to
include headers or footers in the report,
and what information about the shapes the
report should include.

To print a stencil report:
1. Open the stencils you want to print.

2. From the Tools menu, choose Run Add-
on, then choose Stencil Report Wizard
(Stndoc).

3. Follow the instructions onscreen to
identify the stencils and choose the
print options you want.

➊ ➋

➌



Office Layout

For an overview of the best way to create an office layout, see “The Big
Picture.”

To create a chart as quickly as possible, turn directly to “Creating an
Office Layout.”

For detailed information, see the In Depth topics in this and other
chapters.

Topics in this chapter

The Big Picture ................................................................................... 50

Creating an Office Layout .................................................................. 52

In Depth .............................................................................................. 60
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T H E  B I G  P I C T U R E

1Measure the dimensions of the space you want to
create a layout for before you draw.

2 Open the office
layout template.

3Choose the correct
drawing scale.

4 Set up the
drawing page.

5 Assemble the walls; add doors
and windows.

6 Add furniture, cubicles, and
other shapes.
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7 Add text to shapes.

8Title the office layout.

10 Refine the look of the
layout.

9 Check for
adequate space.

11Save and produce.
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C R E A T I N G  A N
O F F I C E  L A Y O U T

We’ve provided complete instructions for creating an office layout.
To create your particular layout, you may not need to complete each
of the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

Before you start to draw:

• Measure the dimensions of the office space you want to plan.

• Measure the size of the objects you want to include in the office
you’re planning.

• Measure the size of the windows and note which direction doors
open.
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To open the office layout template:

1. Start Visio.

2. In the New box, under Based On, choose Office Layout Template,
then click OK.

Visio opens a new file with a blank drawing page.

Or, you can open the Office Layout Wizard. The Wizard guides you
through the process of creating the wall structure, setting the drawing
scale, and choosing page size, orientation, and other layout features.

To change the drawing scale:

1. Display the drawing page, which, by default, has a drawing scale
of 1cm = 1 m.

2. From the Edit menu, choose Drawing Page, then choose Size &
Scale.
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2. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

3. In the Drawing Size/Scale box, under Drawing Scale, click
Architectural and choose a standard scale from the list, or click
Custom Scale to enter a custom scale, then click OK.

For more details, see:

Drawing to Scale .................................................. 60

To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size, then click OK.

For more details, see:

Drawing to Scale .................................................. 60
Setting Up a Diagram ........................................ 202

To assemble the walls:

1. Drag guides from the horizontal and vertical rulers to indicate
the dimensions of the room on the page.

2. Hold down the CTRL key and drag the zero point from the
intersection of the two rulers to the upper-left corner of the
room.

Ctrl

0

0
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3. Drag and drop a Wall Corner shape and place it in a corner so
the wall thickness is outside the room’s perimeter. If necessary,
choose an option from the Shape menu to flip or rotate the shape
so it fits in each of the four corners.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

4. Drag and drop Wall Section shapes, and glue their ends to the
wall corner shapes. The selection handles turn red when the
shapes are glued.

5. To create an angled wall, glue one end of a wall section to a wall
corner shape, then drag the other endpoint. The glued end
remains anchored in place.

6. Continue dragging, dropping, and aligning wall shapes until
you’ve defined the outline of the room.

7. Align Window and Door shapes on top of wall shapes to add
windows and doors. They snap into place.

8. If necessary, choose an option from the Shape menu to flip or
rotate window shapes so their endpoints snap to the guides on
the inside of the walls. Flip or rotate door shapes so they open in
the appropriate direction.

For more details, see:

Placing Information on Layers ........................... 64
Positioning Shapes on the Page .......................... 92
Rotating Shapes ................................................. 140
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To add cubicles, furniture, and other shapes, and check for
adequate space:

1. Drag cubicle corners and panels, desks, and other furniture onto
the drawing page. Use the rulers to position them.

2. Use the control handles on some shapes to check for clearance.
For example, drag a control handle to spin the desk chair or open
a file cabinet drawer.

For more details, see:

Control Handles ................................................ 101
Dragging and Dropping Shapes ......................... 26
Placing Information on Layers ........................... 64
Positioning Shapes on the Page .......................... 92

To add text to shapes:

1. Select the shape you want to add text to.

2. Type the text. Visio zooms in on the selected shape as you type.

3. Press the ESC key to return to the original magnification.

For more details, see:

Working with Text ............................................. 168
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To title an office layout:

1. From the toolbar, choose the text tool.

2. With the crossbar, point to where you want your office layout
title to start, then click and drag a box about the size you think
your title will be.

3. Type the title.

4. From the Format menu, choose Font.

5. In the Font dialog box, choose the title text’s font, size, color, and
style, then click OK.

6. From the toolbar, choose the pointer tool.

7. Click the title text block to select it.

8. Drag a selection handle to change the text block width or height.

9. Position the pointer over the text block. When the pointer turns
white, drag the text block to where you want it to appear on the
page.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168



58   C R E A T I N G   B U S I N E S S   D I A G R A M S   W I T H   V I S I O

Refine the look of an office layout:

To change the way a shape looks:

1. Select the shape you want to format.

2. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

3. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

To change the way text looks:

1. Select the shape with text or the text block you want to change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

For more details, see:

Formatting Shapes with Styles .......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

To change a shape’s layer assignment:

1. Select the shape you want to assign to a different layer.

2. From the Format menu, choose Layer.

3. In the Layer box, choose the layer you want to assign the shape
to, then click OK.

For more details, see:

Placing Information on Layers ........................... 64



O F F I C E   L A Y O U T   59

Save and produce the office layout

To name and save a completed office layout:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the office layout, choose the
other options you want, then click Save.

To print an office layout:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the office layout in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link the office layout file to another document (so that when you
update the original you’ll also update the linked copy in the docu-
ment):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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Scale: 1 cm = 1 m

Scale: 8 cm = 1 m

D R A W I N G  T O  S C A L E

When creating an office layout, you need
to recreate the exact spatial relationships
of a large space in the small space of
the drawing page. You can maintain the
correct proportions by drawing to scale.

Some Visio templates open with particular
drawing scales in place. For example, in
the Office Layout template, 1 cm on the
drawing page represents 1 m.

The smaller the drawing scale, the larger
the area you can represent. For example,
a small scale (such as 1 cm = 1 m) lets
you draw an entire floor on one page. A
larger scale (such as 10 cm = 1 m)
allows you to focus in on one cubicle.

When you drop Visio shapes on a scaled
drawing page, they adjust automatically
to the scale you’ve set. If you want to
change the scale after you’ve already
dropped shapes, cut the shapes, change
the scale, and then paste the shapes
back onto the page.

Tip: Shapes adjust automatically when
you change scales as long as the new
scale ratio is no more than eight times
larger or smaller than the original ratio.
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B

A

C

D

➊ ➋

➌
➍

To set a drawing scale:
1. Display the drawing page.

2. From the Edit menu, choose Drawing
Page, then choose Size/Scale.

3. In the Drawing Size/Scale box, click
Architectural, then select a scale from
the list.

4. Click OK until you return to the Visio
drawing page.

Drawing Size/Scale Box

A Displays the printed drawing size.

B Displays the drawing page size in
scaled units.

C Click to choose a standard Architectural
scale.

D Click to enter a custom scale.
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P L A C I N G  I N F O  O N  B A C K G R O U N D  P A G E S

When you open a Visio file, the drawing
page on the screen is a foreground page.
You can create background pages to use
in connection with the foreground page.
Each Visio file can have multiple
foreground pages, and you can assign a
background page to each foreground page.
Since pages are transparent, everything on
the background is also visible on the
foreground.

Use foreground and background pages
when you want to repeat the same shapes
in the same places in several diagrams, or
when you want to include two different
page settings (for example, scale or
shadow offset) in the same diagram.

For related information, see online Help:
press F1, click Search, click Index, then
type “background.”

➊ ➋

➌

Duis Autem

Duis Autem

When you open a Visio file, the drawing page on the screen is a
foreground page. If you want to use background pages, you need to
create them.

➍

To create a background page:
1. From the Insert menu, choose Page.

2. In the Page box, under Type, click
Background.

3. Under Name, type a name if you want
to use a different name from the one
Visio assigns, then click OK.

4. To see both the foreground and
background at the same time, in the
Page box check Open Page in New
Window. Then, from the Window
menu, choose Tile.

Tip: To delete a background page,
choose Drawing Page from the Edit menu,
then choose Delete. In the Delete box,
select the background you want to delete,
then click OK.
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To assign a background page:
1. Display the foreground page (or

background page) to which you want
to assign a background page.

2. From the Edit menu, choose Drawing
Page, then choose Properties.

3. In the Page Properties box, from the
background list, choose the name of
the background you want to assign,
then click OK.

Tip: To remove a background page from
a foreground, display the foreground page.
Follow the procedure to assign a
background, but from the background list,
choose None.

To display foreground or background pages:
1. While the foreground is displayed,

choose Go To from the Edit menu,
then choose Background.

2. While the background is displayed,
choose Go To from the Edit menu,
then choose Foreground.

Tip: To display a foreground and
background in different windows, display
the foreground. From the Edit menu,
choose Go To, then choose Page. In the
Page box, select the background, check
Open Page In New Window, then click OK.

➊ ➋

➌

➊ ➋
Duis Autem
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P L A C I N G  I N F O R M A T I O N  O N  L A Y E R S

By assigning shapes to different layers, you
can selectively view, edit, print, lock, snap,
and glue them. For example, if you’re
drawing an office plan, you can assign
walls, doors, and windows to one layer,
electrical outlets to another layer, and
furniture to a third layer. That way, when
you plan the electrical system, you don’t
have to worry about accidentally
rearranging the walls. After locking the
wall and electrical outlet layers, you could
distribute the office plan to coworkers, who
could arrange the furniture in their offices
without disturbing the foundation. Shapes
on the Office Layout stencil are already
assigned to pre-existing layers. If you want
to use layers with shapes from other
stencils, you can create layers and assign
shapes to them yourself.

For related information, see online Help:
press F1, click Search, click Index, then
type “layers.”

Furniture layer

Walls,
doors, and
windows
layer

Electrical outlets layer

A shape can belong to more than one layer.

Grouped shapes all belong to the same layer but each individual
shape can also belong to a different layer.
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Layer anatomy
Layer Properties Box

A Check to remove layers with no shapes
on them.

B Click to remove a selected layer. All
the shapes on the layer will be
deleted.

C Click to add a new layer.

D Click to add color to a layer, then
choose the color in the list at the
bottom of the box.

E Check to turn glue on for a layer.

F Check to turn snap on for a layer.

G Check to prevent shapes on a layer
from being altered.

H Check to make all new shapes that
aren’t already assigned to layers
automatically belong to this layer.

I Check to print shapes on a layer.

J Check to see shapes on a layer.

K Click to display the number of shapes
on a layer.

Layer Box

A Choose the layer(s) you want selected
shapes to belong to.

B Check to allow grouped shapes to
belong to a separate layer as well as
the layer the group belongs to.

C Click to add a new layer.

D Click to assign a selected shape to all
layers.

A

B
C

DEFGHIJK

A

C

D

B
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To create a layer:
1. From the View menu, choose Layer

Properties.

2. In the Layer Properties box, click New.

3. In the New box, type a name for the
layer, then click OK.

4. In the Layer Properties box, check the
properties you want the layer to have,
then click OK.

More Ø

➊

➋

➌

➍
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To assign a shape to a layer:
1. Select the shape.

2. From the Format menu, choose Layer.

3. In the Layer box, choose the layer you
want the shape to belong to, then
click OK.

Tip: To assign a shape to more than one
layer, press the CTRL key to choose
multiple layers.

To delete a layer:
1. From the View menu, choose Layer

Properties.

2. In the Layer Properties box, choose the
layer you want to delete. When you
delete a layer, you also delete the
shapes assigned to the layer.

3. Click Remove, then click OK.

Tip: To delete a layer but not the shapes
on the layer, first reassign the shapes to
new layers.

➊ ➋

➌

➊

➋

➌
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M E A S U R I N G  W H I L E  Y O U  D R A W

Often, particularly when you’re drawing to
scale, you need know the dimensions of a
shape as you size it. For example, it’s
easier to create a 3 meter couch when
you can see its dimensions change as you
drag.

In Visio, there are two ways you can
measure while you draw:

1. Watch the status bar.

2. Glue a dimension line to the shape
you want to size.

To glue a dimension line to a shape:
1. From the Tools menu, choose Snap and

Glue.

2. In the Snap and Glue box, under Glue
to, check Shape Handles, then click OK.

3. Drag the dimension line over the shape
you want to measure so that the
dimension line’s endpoints glue to the
selection handles on either end of the
shape.

7' 0" 10' 0"

➊ ➋

➌

0.9375

If you glue a dimension line to a shape, the shape and the line stretch together.
The dimensions on the line give you the dimensions of the shape. The Office Layout
stencil includes a Dimension Line shape.

When you select a shape, the status bar at the bottom of the Visio window
displays its dimensions. As you size the shape, the dimensions in the status bar
reflect changes in width and height.
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Lorum Ipsum Lorum Lorum

T A K E  A N  I N V E N T O R Y  O F  Y O U R  D I A G R A M

Take an inventory when you want to
develop a bill of materials for a building
project, keep track of the location of
equipment and furniture, or account for
every modem, printer, and workstation in
a computer network.

To take an inventory, follow these steps:

• If you want the inventory to include
special data, such as serial numbers or
company location numbers, associate
each shape with that data.

• Choose what information to include in
the inventory list.

• Choose whether you want to place the
inventory in the Windows clipboard, or
save it as a text file you can export to
a spreadsheet or database program.

• Generate the inventory.

If you have a multi-page diagram,
remember that you can generate an
inventory for only one page at a time.
Even if certain shapes are selected when
you generate the inventory, it will include
data on all the shapes on a page. Grouped
shapes are treated as a single shape. To
generate an inventory for the shapes in a
group, first open the group.

For related information:
Associating Properties with Shapes ............ 74
Generating Numerical Reports ..................... 47

See online Help, press F1, click Search,
click Index, then type “inventories.”

More Ø

Serial #
M003-8860 502101 X11

Take inventories in Visio to generate text files for tracking information
about individual shapes in a diagram.
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Choosing inventory content
You can choose what data fields to include
in an inventory. Unless you add additional
fields, an inventory will include only
Quantity (Qty) and Master fields. Qty lists
the number of times identical shapes
appear in a drawing. Master lists the
shape names.

Qty and Master data are automatically
assigned to Visio shapes. Other data
automatically assigned include ID, Name,
Height, Width, and Type.

Your inventory can also include fields for
custom data, such as serial numbers,
you’ve associated with shapes.

For related information:
Associating Properties with Shapes .......... 74

This office-layout inventory lists the identification number and tracks the
quantity and size of each shape in the diagram.
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More Ø

A

To choose inventory content:
1. If you want to include custom data in

your inventory, follow the procedure on
page 74 to associate custom properties
with shapes.

2. From the Tools menu, choose Shape
Report.

3. In the Shape Report box, click Select.

4. In the Select box, select fields in the
left list and click Add to add them to
the right list.

5. Select fields in the right list and click
Up or Down to determine the order in
which they appear in the inventory.

6. For Field, select a field you want to
sort on, select the sorting order, then
click OK.

Select Box Options

A Lists the fields you can inventory,
including custom property fields you
entered in the ShapeSheet.

B Data you associate with a shape by
using the Special command on the
Format menu.

C Moves selected fields from one list to
another.

D Choose how to sort a field.

E Orders selected fields in the inventory
fields list.

F Lists the fields you’ve included.

B

C

F

E

D

➊

➋

➌

➍ ➎

➏
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Generating an inventory
Visio gives you options for generating an
inventory. You can:

• Copy the inventory to the Windows
Clipboard so you can paste it into
another program;

• Save the inventory as a text file so
you can export it to a spreadsheet or
database.

If you intend to export an inventory, you
need to set the text delimiters and field
separators for the data so the destination
program can read the inventory. For
information about what delimiters and
separators a program reads and for
information about how to import the
inventory text file, see the documentation
for that program.

Before you generate an inventory, decide
how you want it to look. For example,
you can choose to display field names at
the top of each inventory column. The
inventory can list each shape individually,
or list total instances of the same shape.
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To generate an inventory:
1. Follow the procedure described on page

71 to choose inventory content.

2. In the Shape Report box, under
Destination, click Clipboard or File.

3. If you clicked File, click Browse to
choose a location and name for the
text file.

4. If you’re exporting the inventory, select
the Format options appropriate for the
destination program.

5. Check the Options you want for
displaying the inventory, then click OK.

Choices for generating an
inventory

A Click to copy the inventory to the
Windows Clipboard.

B Click to save the inventory as a text
file that can be exported.

C Select the Text Delimiter and Field
Separator options the program you’re
exporting the inventory to can read.

D Choose to display field names at the
top of inventory columns.

E Check to total duplicate shapes.
Uncheck to list each shape individually.

A
B

C
D

E

➋ ➌

➍

➎
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A S S O C I A T I N G  P R O P E R T I E S  W I T H  S H A P E S

Behind each Visio shape is a ShapeSheet,
or spreadsheet, that includes data, or
properties, about the shape as well as
formulas that tell the shape how to
behave. For example, a shape’s ShapeSheet
includes the shape’s name, height, and
width. You can generate reports that
compile this data for all the shapes on a
page.

If you associate custom properties with
shapes you can also generate custom
reports. For example, you can associate a
total quality management shape with the
cost, duration, and resources required to
complete a step in a process. Or, you can
associate a chair with a serial number and
office location.

For related information:
Generating Numerical Reports .................. 47
Take an Inventory of Your Diagram ........ 69
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To associate properties with a shape:
1. Open a Visio drawing and select a

shape with which you want to associate
properties.

2. From the Tools menu, choose Run Add-
on, then choose SmartShape Wizard.

3. In the Wizard box, choose Custom
Properties & Shape Data, click Change
Option, then follow the instructions on
the screen.

To assign values to a shape’s custom properties:
1. Select the shape with values you want

to assign.

2. From the Shape menu, choose Custom
Properties.

3 In the Custom Properties box, enter
values for the properties associated
with the shape.

➊ ➋

➌

➊ ➋

➌





Relationship Diagrams

For an overview of the best way to create relationship diagrams, see
“The Big Picture.”

To create a relationship diagram from scratch as quickly as possible,
turn directly to the “Creating a...” topic that corresponds to the type
of diagram you want to create.

For detailed information, see the In Depth topics in this and other
chapters.

Topics in this chapter

The Big Picture ................................................................................... 78

Creating a Block Diagram .................................................................. 80

Creating a Mind Mapping Diagram .................................................. 86

In Depth .............................................................................................. 92
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T H E  B I G  P I C T U R E

1Open the Block Diagram or
Mindmapping Template.

4Add related ideas.

3Create the diagram’s main image
or central theme.

2Set up the drawing page.
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7Save and produce.

6Refine the diagram.

5Add text.
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C R E A T I N G  A  B L O C K  D I A G R A M

We’ve provided complete instructions for creating a block diagram.
To create your particular diagram, you may not need to complete
each of the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open a block diagram template:

1. Decide whether you want to create a block, raised block, or
perspective block diagram.

2. Start Visio.

3. In the New box, under Based On, choose Block Diagram
Template to create a block or raised block diagram, or choose
Block Diagram (Perspective) Template to create a perspective
block diagram. Click OK.

Consectetuer
Quis Dolor

Elit wisi enim minim
veniam, quis nostrud
erat volutpat.

Sit amet, consectetuer
adipiscing, sed diam ad
minim veniam autem vel.

Duis autem vel eumiriure
dolor in hendrerit wisi ut
enim nonummy, nibh.

Enim R. Nostrud

Duis W. Autem

Nibh B. Euismod

Vel C. Allamcorper

Amet A. Laoreet

Dolore T. Magna

Sed diam
nonummy nibh.
Ad minim quis.

Sed diam
nonummy nibh.
Ad minim quis.

Hendrerit In Vulputate
Elit Esse

Hendrerit
Ea Volutpat

Sed diam
nonummy nibh.
Ad minim quis.

Hendrerit
Ea Volutpat

Tincidun
Laoreet

Minim
Veniam

Volutpat
Aliquam
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size, then click OK.

For more details, see:

Setting Up a Diagram ........................................ 202

Create the diagram’s main image:

To create the main image:

1. Decide what shape or shapes to use to represent the main idea
you want to communicate.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Drag and drop the shapes you want to use. For example, using
the Block Diagram (Raised) Stencil, you might want to create a
four-headed arrow by dragging and dropping an Up/Down
Arrow, a Left Arrow, and a Right Arrow shape. Right-click the
left and right arrow shapes and choose Open Tail from the
shortcut menu.

3. Choose a magnification from the Zoom Control list on the
toolbar to zoom in, then align the open-tailed shapes with the
up/down arrow. To hide lines, if they’re showing, select the open-
tailed arrows and choose Bring To Front from the Shape menu.
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To create a 3-D perspective diagram:

1. Decide what shape or shapes to use to represent the main idea
you want to communicate.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. If the drawing page doesn’t already have a vanishing point on it,
drag and drop the Vanishing Point shape before you drag and
drop any other shapes.

3. Drag and drop the 3-D perspective shapes that represent the
central idea. They automatically position themselves according to
the position of the vanishing point.

For more details, see:

Dragging and Dropping Shapes ......................... 26
Positioning Shapes on the Page .......................... 92
Using 3D Perspective ........................................... 98

To add related ideas:

1. Drag and drop tree-shapes (included only on the Block Stencil),
arrows, and other shapes to create branch diagrams and add
information related to the main idea.

To add text:

To add text to a shape

1. Click the shape, then type the text you want.

To title the block diagram:

1. From the toolbar, choose the text tool.

2. With the crossbar, point to where you want your flowchart title
to start, then click and drag a box about the size you think your
title will be.

3. Type the title.
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4. From the Format menu, choose Font.

5. In the Font dialog box, choose the title text’s font, size, color, and
style, then click OK.

6. From the toolbar, choose the pointer tool.

7. Click the title text block to select it.

8. Drag a selection handle to change the text block width or height.

9. Position the pointer over the text block. When the pointer turns
white, drag the text block to where you want it to appear on the
page.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

Refine the diagram

To format block shapes:

1. Select the shape you want to change.

2. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

3. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

To format 3-D shapes:

1. Select a 3-D shape, then click to subselect the part of the shape
you want to format.

2. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

3. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.
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To open or close the ends of an open-ended block shape:

1. Right-click a shape, then choose the option you want from the
shortcut menu.

To change the depth of a 3-D perspective shape:

1. Right-click a shape, then choose Set Depth from the shortcut
menu.

2. In the Custom Properties box, choose the depth you want, then
click OK.

To change the vanishing point for a 3-D Perspective shape:

1. Select the shape with the vanishing point you want to change.

2. Drag the control handle from the vanishing point to the position
where you want the shape’s new vanishing point.

To format text:

1. Select the text block or the shape with text you want to change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

For more details, see:

Formatting Shapes with Styles ......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

Save and produce the diagram

To name and save a completed block diagram:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the diagram, choose the
other options you want, then click Save.
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To print a block diagram:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the block diagram in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your block diagram file to another document (so that when
you update the original you’ll also update the linked copy in the
document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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C R E A T I N G  A
M I N D  M A P P I N G  D I A G R A M

We’ve provided complete instructions for creating a mind mapping
diagram. To create your particular diagram, you may not need to
complete each of the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open the mindmapping template:

1. Start Visio.

2. In the New box, under Based On, choose Mindmapping Tem-
plate, then click OK.
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size, then click OK.

For more details, see:

Setting Up a Diagram ........................................ 202

To create the diagram’s central theme:

1. Drag and drop a Central Theme shape.

(For details about how to use a shape, right-click it on the page or
on the stencil, then choose Shape Help.)

2. The central theme automatically moves to the center of the page
(you can move it if you want). Click the shape and type to replace
existing text.

For more details, see:

Dragging and Dropping Shapes ......................... 26
Positioning Shapes on the Page .......................... 92

CENTRAL

THEMECENTRAL

THEMECENTRAL

THEME
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To add related ideas:

1. Drag and drop an Inner Branch or Ordering idea shape and
connect it to a connection point on the central theme. Type text
for the idea the branch represents.

2. If you want, drag an Inner Branch or Ordering idea endpoint to
change the orientation of the line.

3. Drag the control handle at the center of the inner branch line to
add one or more second tiers. Type text for the ideas the second
tier branches represent.

4. Drag and drop an Outer Branch shape and connect it to the
connection point on the end of an inner branch second tier. Type
text for the idea the inner branch represents.

5. Drag the control handle at the center of the outer branch line to
add one or more fourth tiers. Type text for the ideas the fourth
tier branches represent.

6. If you want to add paragraphs of text to branches or tiers, drag
and drop an Auto-size Box shape, then drag its control handle to
a connection point on a branch or tier.

7. If you want, drag and drop a Big Cloud or Small Cloud shape to
enclose an inner branch and all its tiers. Drag selection handles to
change cloud size and control handles to change cloud shape.
(You can also choose the freeform tool from the drawing tool
menu on the toolbar and draw cloud shapes around ideas).

8. Drag and drop clip art to enhance the meaning of the diagram.

For more details, see:

Connecting Shapes .............................................. 32
Control Handles ................................................ 101
Drawing Your Own Shapes ............................... 138
Positioning Shapes on the Page .......................... 92
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To add independent text:

1. Drag and drop the Rounded Stamp, Growing Bubble, Auto-size
Box, or other shapes.

2. Select the shape, then type the text you want to add.

3. You can also choose the text tool from the toolbar. With the
crossbar, point to where you want the text to start, drag a box
about the shape you want the text block to be, then type the text.
When you’re finished typing, click the pointer tool.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

Refine the diagram

To resize the entire mind mapping diagram:

1. From the Edit menu, choose Select All.

2. From the Shape menu, choose Grouping, then choose Group.

3. Drag a selection handle until the diagram is the size you want.

4. From the Shape menu, choose Grouping, then choose Ungroup.

To color a mind mapping diagram by ideas:

1. Select all the inner and outer branches that make up an idea.

2. From the Format menu, choose Line.

3. In the Line box, choose the color you want for the idea, then click
OK.
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To color a mind mapping diagram by tier:

1. From the View menu, choose Layer Properties.

2. In the Layer Properties box, choose the tier you want to color.

3. Click in the Color column, then choose the color you want from
the Layer Color list at the bottom of the box.

4. When you’ve colored all the tiers, click OK.

For more details, see:

Formatting Shapes with Styles ......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

Save and produce the diagram

To name and save a completed mind mapping diagram:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the cluster diagram, choose
the other options you want, then click Save.

To print a mind mapping diagram:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the mind mapping diagram in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.
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To link your mind mapping diagram to another document (so that
when you update the original you’ll also update the linked copy in
the document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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P O S I T I O N I N G  S H A P E S  O N  T H E  P A G E

Visio has several features that help you
position shapes on the drawing page:

• Each drawing page has vertical and
horizontal rulers. You can specify ruler
measurement units and place the zero
point anywhere on the page.

• Each drawing page is crisscrossed by
grid lines. You can control how many
lines appear in the grid and change
the point where the grid originates. If
your diagram requires a specialized
grid (for example, an office layout
organized around a 60 cm x 60 cm
ceiling grid), you can even set the
Visio grid to match it.

• You can drag guides and guide points
from the ruler onto the drawing page.
Guides are easier to see than grid
lines and can be placed anywhere on
the drawing page.

• Once several shapes are on a page,
you can align or distribute them with
respect to one another.

For related information, see online Help:
click Search, click Index, then type
“rulers,” “guides,” “grid,” “align,” or
“distribute.”

Align and Distribute commands

Rulers

Guide

Grid lines

Guide point

Visio’s drawing page is designed to make positioning shapes
easy, flexible, and accurate.

When you begin to drag a shape on the drawing page, lines
appear on the rulers. Use the lines to position the shape.

Use guide points to align shapes with respect one another.
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More Ø

Preparing to Position Shapes
To Do This

Set ruler measurement units From the Edit menu, choose Drawing Page, then choose Properties. In the Page
Properties box, under Measurements, choose the units you want, then click OK.

Change the position of the Hold down the CTRL key, then drag from the intersection of the two rulers to where
ruler zero point on both rulers you want the new zero point. Unless you’ve customized the grid origin, it moves

along with the ruler zero point.

Change the position of the ruler Hold down the CTRL key, then drag from the other ruler.
zero point on one ruler

Return the zero point to its default location Hold down the CTRL key, then double-click on the intersection of the two rulers.

Change ruler subdivisions From the Tools menu, choose Ruler and Grid. In the Ruler and Grid box, under
Rulers, choose the kind of subdivisions you want.

Place a guide on the drawing page Point to the ruler from which you want to drag a guide. Horizontal guides come
from the horizontal ruler and vertical guides from the vertical ruler. Drag to where
you want the guide.

Place a guide point on the drawing page Point to the intersection of the two rulers. Drag to where you want the guide point.

Align shapes with guides or guide points Drag shapes until their selection handles, endpoints, or connection points align with
the guides or guide point.

Delete guides or guide points Click to select the guide or guide point you want to delete. They turn green when
selected. From the Edit menu, choose Clear.

Set the coarseness of the grid From the Tools menu, choose Ruler and Grid. In the Ruler and Grid box, under Grid
Spacing, choose the horizontal and vertical coarseness you want.

Change the spacing of the grid From the Tools menu, choose Ruler and Grid. In the Ruler and Grid box, under
Minimum spacing, type the horizontal and vertical grid spacing you want.

Change the point where the grid originates From the Tools menu, choose Ruler and Grid. In the Ruler and Grid box, under Grid
Origin, type the coordinates where you want the grid to originate. By default the grid
origin is in the lower left corner of the drawing page.
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To distribute shapes:
1. Select three or more shapes.

2. From the Tools menu, choose Distribute
Shapes.

3. In the Distribute box, click the
distribution option you want.

Distribution Options
From here Choose this Distribute option To get here

Horizontal ends distribution

Left distribution

Horizontal center distribution

Right distribution

Vertical ends distribution

Top distribution

Vertical center distribution

Bottom distribution

➊ ➋

➌



R E L A T I O N S H I P   D I A G R A M S  95

Alignment Options
From here Select Choose this Align option To get here

Shape A first Top align

Shape B first Horizontal align

Shape C first Bottom align

Shape A first Left align

Shape B first Vertical align

Shape C first Right align

A
B

C
A

B C

A
B

C
A B C

A
B C

A
B

C

A

B

C

A

B

C

A

B

C

A

B

C

A

B

C

A

B

C

To align shapes:
1. Select the shape you want to align

other shapes to.

2. Hold down Shift and select the other
shapes.

3. From the Tools menu, choose Align
Shapes.

4. In the Align box, click the alignment
option you want. Click the red X to
deselect an option.

➊ ➋ ➌

➍
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Lorem Ipsum

G R O U P I N G  A N D  U N G R O U P I N G  S H A P E S

Grouping means joining separate shapes
into one group. Grouping is handy when
you regularly use several shapes together
or when you want to move, size, rotate,
or format them all at the same time.

You can:

• Group any shapes or objects on the
same drawing page, including guides
and objects from other applications;

• Group any shapes or objects on the
same or different layers;

• Add or delete shapes from groups
without ungrouping; and

• Edit all the shapes in a group at the
same time or edit one shape
individually.

When you format a group, formatting
affects all shapes in the group. When you
add text to a group, the text appears only
on the frontmost or primary shape. The
primary shape is the first shape you
selected when you originally grouped the
shapes.

For related information:
Merging Shapes ............................................. 134

In online Help: press F1, click Search, click
Index, then type “grouping.”



R E L A T I O N S H I P   D I A G R A M S  97

Working with groups
To Take these steps

Group shapes and objects Select the shapes and objects you want to group. Press the Shift key to select
multiple shapes From the Shape menu, choose Grouping, then choose Group.

Ungroup shapes and objects Select a group. From the Shape menu, choose Grouping, then choose Ungroup.

Edit an entire group Select the group. Size, move, format, or add text to the group as you would for any
other shape.

Add a shape to a group Select the group, then press the Shift key and select the shape you want to add.
From the Shape menu, choose Grouping, and then choose Add To Group.

Subselect a shape in a group Select the group, then click the shape you want to subselect. Its selection handles
turn gray.

Remove a shape from a group Select the group, then click to subselect the shape you want to remove. From the
Shape menu, choose Grouping, then choose Remove From Group.

Make one shape the frontmost shape Select the group, then subselect the shape you want at the front. From the Shape
menu, choose Bring To Front.

Edit a shape within a group Select the group, then click to subselect the shape you want to edit. From the
Format menu, choose commands to format the shape the way you want.

Add text to a particular shape in group Select the group, then subselect the shape you want text added to.

Size one shape differently Select the group. From the Edit menu, choose Open Group. In the group window,
from other shapes in the group select the shape you want to size differently. From the Format menu, choose Behavior.

In the Behavior box, under Resize Behavior, click Reposition Only, then click OK. Click
the X in the upper-right corner to close the group window. When you resize the
group, the selected shape doesn’t resize.

Assign a group to a layer Select the group. From the Format menu, choose Layer. In the Layer box, choose the
layer you want the group to belong to, then click OK.

Preserve the separate layer assignments Select the group. From the Format menu, choose Layer. In the Layer box, check
of shapes in a group Preserve Group Member Layers.
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U S I N G  3 - D  P E R S P E C T I V E

In a 3-D perspective diagram, Visio orients
the 3-D shapes to a vanishing point. You
can create block diagrams with 3-D
perspective using Visio’s Perspective Block
Diagrams template. You can set up a block
diagram so that Visio orients all the 3-D
shapes to the same vanishing point. You
can also adjust the vanishing point for a
particular shape.

Built in to Visio’s 3-D perspective template
are some features that make creating and
revising diagrams easier. For example,
when you’re working with the shapes, you
can hide their 3-D appearance so they’re
easier to place on the page. You can also
quickly change shape appearance and
shape depth.

To create a 3-D perspective diagram:
1. Start Visio and open the Block Diagram

(Perspective) template.

2. Drag and drop the 3-D shapes you
want to include in your drawing. They
orient themselves to the vanishing
point.

3. Drag the vanishing point so that the
3-D shapes look the way you want.

Tip: To orient a shape to a different
vanishing point from the other shapes,
select the shape, then drag its control
handle (which is glued to the vanishing
point) to a new location or glue it to a
different vanishing point.

The Perspective Block Diagrams template includes a vanishing point
shape on the drawing page. When you drag and drop 3-D shapes,
they automatically find the vanishing point and adjust their appearance
accordingly.

➊ ➋

➌
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To hide a shape’s 3-D appearance:
1. In a 3-D perspective diagram, from the

View menu, choose Layer Properties.

2. In the Layer Properties box, under
Name, choose 3-D Depth.

3. Click under Visible to make the shape
disappear, then click OK.

4. When you’re finished, click under
Visible in the Layer Properties box to
make the shape appear.

5. To arrange the 3-D shapes on the
page, select shapes and, from the
Shape menu, choose Bring Forward or
Send Backward.

To change a 3-D shape’s appearance:
1. Select the shape, then click part of the

shape to subselect it.

2. From the Format menu, choose Define
Styles.

3. In the Define Styles box, under Change,
click Fill or Line.

4. In the Fill or Line box, choose the
options you want, then click OK.

5. In the Define Styles box, click Apply.

Tip: To change shape depth, right-click a
shape, then choose Set Depth from the
shortcut menu. In the box, under Depth,
choose the depth you want, then click OK.

➊

➋

➌
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M A K I N G  S H A P E S  S M A R T E R

Using the SmartShape Wizard, you can
change the way existing Visio shapes, or
shapes you’ve created, behave. For
example, you can:

• Associate custom data, or properties,
with a shape;

• Change the position of a shape’s text
block;

• Add a control handle that controls text
block position;

• Set protection behavior that prevents a
shape from being modified in certain
ways.

To make a shape smarter:
1. Select the shape you want to make

smarter.

2. From the Tools menu, choose Run Add-
On, then choose SmartShape Wizard.

3. In the SmartShape Wizard box, choose
the options you want, then click OK.

Tip: The ShapeSheet offers many other
ways to change shape behavior.

For related information, see online Help:
press F1, click Search, click Find, then type
“shapesheet.”

Lorem
Lorem

Lorem
Lorem

➊ ➋

➌



R E L A T I O N S H I P   D I A G R A M S  101

Drag the control handle on a road shape from the Map
stencil to control the thickness of the road.

C O N T R O L  H A N D L E S

Control handles are special handles
associated with some Visio shapes. The
function of control handles is specific to a
shape’s design and purpose.

For related information, see online Help:
press F1, click Search, click Index, then
type “control.”

Drag the control handle on the file cabinet from the Office
Layout stencil to open the drawer and check for clearance.

Pause the pointer over a control handle to learn how
moving the handle affects the shape.
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The Big Picture ................................................................................. 104

Creating a Project Timeline ............................................................. 106

In Depth ............................................................................................ 112

Project Timelines

For an overview of the best way to create a project timeline, see “The
Big Picture.”

To create a project timeline as quickly as possible, turn directly to
“Creating a Project Timeline.”

For detailed information, see the In Depth topics in this and other
chapters.
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T H E  B I G  P I C T U R E
Prepare the data for the project
timeline, under headings such as
task names, duration, start and end
dates, and resources.

1

2 Open the Project Management
Wizard template.

3 Create a Microsoft Excel spreadsheet,
or a text file, or read data from an
existing spreadsheet or text file.
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4 Follow the steps in the Wizard
to lay out, format, and create
the project timeline.

5 Refine the timeline.

6 Save and produce.
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C R E A T I N G  A
P R O J E C T  T I M E L I N E

We’ve provided complete instructions for creating a project timeline.
To create your particular timeline, you may not need to complete
each of the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

Prepare project timeline data

• Prepare your data to fall under the following column headings:
Task Number, Task Name, Duration, Start Date, End Date,
Dependency, and Resource. For Dependency, enter the Task
Number that the current task depends on.

• If your data is in a comma- or tab-delimited text file or a
spreadsheet file, you can use that file to create the project
timeline.

• If your data doesn’t exist in electronic form, start Visio’s Project
Timeline Wizard and use one of its templates to enter it.
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To open the Project Timeline Wizard:

1. Start Visio.

2. In the New box, under Based On, choose Project Timeline
Wizard, then click OK.

To enter your project timeline data:

1. On the first screen of the Project Timeline Wizard, click Next.

2. When Visio asks you to Select a Data Source, choose Read Data
From Existing File, then click Browse to locate the text or
spreadsheet file in which you listed the tasks. If you haven’t
created a text or spreadsheet file, click Enter Data for the type of
file you want to create, or click None to have Visio lay out a
timeline grid and a specified number of tasks.

3. Follow instructions onscreen to lay out, format, and create the
project timeline.

Revise and update the timeline

To set task and milestone formatting properties for the entire timeline:

1. Click the page where there are no shapes.

2. Right-click and from the shortcut menu, choose Layout Proper-
ties.

3. In the box, under Tasks, specify formatting options for all the
timeline bars on the page.

4. Under Milestones, specify formatting options for all the mile-
stone shapes on the page.

5. Click OK.

The Wizard’s second screen
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To set grid line, dependency connector and other formatting properties
for the entire timeline:

1. Click the page where there are no shapes.

2. Right-click the page and from the shortcut menu, choose the
line, bar height, or connector option you want.

To change task start and end dates:

1. Select the timeline bar with dates you want to change.

2. Drag an end selection handle until the bar is aligned with the
correct date.

To change the look of a timeline bar or a milestone:

1. Right-click the timeline bar or milestone you want to change,
then choose Task Layout or Milestone Layout from the shortcut
menu.

2. In the box, select the options you want, then click OK.

To create or break dependencies between tasks:

1. Right-click the page (with no shapes selected) or a timeline bar.

2. From the shortcut menu, choose Layout Properties or Task
Properties.

3. In the box, under Dependencies, follow the instructions to create
or break dependencies between tasks.

To edit text:

1. Double-click the text you want to edit.

2. Type the new text with which you want to replace the old text.

3. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

Duis
Autem

M T W Th F
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To delete the text associated with a timeline bar or milestone:

1. Double-click the text you want to delete, then press the Delete
key.

To add a task name or label not associated with a timeline bar or
milestone:

1. Drag and drop a Task Label, Task Names, or Task Name Text
Block shape, then place it where you want it in the Gantt grid.

To add a task to the end of the timeline:

1. Click a line in the text column to select the shape.

2. Drag the bottom center selection handle to extend the column.

3. Click a line in the Gantt grid to select the shape.

4. Drag the bottom center selection handle to extend the grid.

5. Drag and drop a Timeline shape, so that the left edge of the bar
lines up with the start date for the task.

6. Drag the right end of the bar until it lines up with the end date of
the task.

7. Drag the timeline bar control handle until it aligns with the left
border of the text column.

To insert a task into the timeline:

1. Click a line in the text column to select it.

2. Drag the bottom center selection handle to extend the column.

3. Click on a line in the Gantt grid to select it.

4. Drag the bottom center selection handle to extend the grid.

5. Press the Shift key and select all the timeline bars above which
you want the task inserted.

6. Drag the timeline bars down one row in the text column and
Gantt grid.

7. Drag and drop a Timeline shape into the empty row, so that the
left edge of the bar lines up with the start date for the task.

Lorem
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8. Drag the right end of the bar until it lines up with the end date of
the task.

9. Drag the timeline bar control handle until it aligns with the left
border of the text column.

To reorder timeline tasks:

1. Click a timeline bar to select the first task you want to reorder.

2. Drag the bar off the Gantt grid.

3. Click a timeline bar to select the second task you want to reorder.

4. Drag the bar into the space originally occupied by the first task.

5. Drag the bar for the first task into the space originally occupied
by the second task.

To delete a task:

1. Click a timeline bar to select the task you want to delete.

2. Press the Delete key.

3. Press the Shift key to select all the bars below the deleted task,
then drag them up one row in the text column and Gantt grid.

4. Click a line in the text column to select the shape.

5. Drag the bottom center selection handle to shorten the column.

6. Click on a line in the Gantt grid to select the shape.

7. Drag the bottom center selection handle to shorten the grid.

To modify the text column, Gantt grid, or year, month, or week label:

1. Right-click the shape you want to modify and choose an option
from the menu for displaying grid lines.

2. Select the shape you want to modify, and choose Line from the
Format menu. In the Line box, choose the formatting options
you want, then click OK.

For more details, see:

Formatting Shapes with Styles .......................... 122
Working with Text ............................................. 168
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Save and produce the project timeline

To name and save a completed timeline:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the timeline, choose the
other options you want, then click Save.

To print a timeline:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the timeline in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your timeline to another document (so that when you update
the original you’ll also update the linked copy in the document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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O P E N I N G  A N D  M O V I N G  S T E N C I L S

Stencils are collections of ready-made
master shapes you can drag and drop onto
the drawing page to create diagrams.
When you open a Visio template, you open
a drawing page and the stencils you need
to draw a particular type of diagram. If
you want to use shapes from stencils that
didn’t open with the template, you can
open the stencils separately.

Stencils open as read-only by default. That
means you can drag and drop shapes from
them but you can’t edit their master
shapes or change the original stencils in
any way.

Visio lets you control how master shape
icons display on a stencil. You can show
both icons and icon names, icons only, or
names only. If you show both icons and
names, you may need to scroll to see all
the shapes on the stencil.

For related information:

Creating and Editing Stencils .................... 114

See online Help: press F1, click Search,
click Index, then type “stencils.”

Many Visio templates open with just one read-only stencil positioned along the
left side of the drawing window. Drag a master shape from a stencil to
include a copy of that shape in a diagram.

If you open additional stencils, they cascade on top of the first stencil.
To use the shapes on a particular stencil, click that stencil's name.

To view more than one stencil at a time, right-click the icon in the stencil’s
upper-left corner, then choose Float or Switch Sides from the shortcut menu.
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To change how master shape icons display:
1. Right-click the green background of the

stencil.

2. From the menu, choose the display
option you want.

The master shape icons change to
reflect your choice.

To open a stencil:
1. From the Visio File menu, choose

Stencils.

2. In the Stencils box, choose the stencil
you want to open, then click OK.

Tip: To close, float, or dock a stencil on
the other side of the drawing page, right-
click the icon in the upper-left corner of
the stencil then choose an option from the
shortcut menu.

➊ ➋

➊

➋
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C R E A T I N G  A N D  E D I T I N G  S T E N C I L S

Whenever you create a Visio diagram, Visio
creates a stencil specific to that drawing
file. A drawing file stencil includes all the
shapes used in your diagram, no matter
which stencil you originally dragged them
from. You can edit master shapes on the
drawing file stencil. Changes you make in
a master shape affect all instances of that
shape in your diagram. If you frequently
draw diagrams that use the same shapes,
you can save the drawing file stencil as an
independent stencil. Then, you can open
that stencil whenever you want to include
its master shapes in a diagram.

For some purposes, you may want to edit
one of Visio’s original stencils. For example,
you might want to add a shape you use
frequently from the Network stencil to the
Block Diagram stencil. To edit a stencil,
it’s best to open a copy of the original.
Then, the original is still available for you
to use in the future.

You can also create a new stencil from
scratch. The new stencil can either be
based on an existing stencil, in which case
it includes all the master shapes from that
stencil, or it can be blank. In either case,
you can create masters on the stencil from
shapes you draw or bring into Visio from
other programs.

For related information:

Opening and Moving Stencils ..................... 112

See online help: press F1, click Search,
click Index, then type “stencils.”

The quickest way to update all the copies of a particular shape you've used
in a diagram is to edit the master shape on the drawing file stencil.

When you open a copy of an original stencil or a drawing file stencil, the
stencil opens in a separate window from the drawing page and has its own set
of menus and commands.
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To open a drawing file stencil and edit a master shape:
1. From the Window menu, choose Show

Master Shapes to open the drawing file
stencil.

2. In the drawing file stencil, double-click
the master shape you want to edit.

3. In the master shape drawing window,
edit the master shape.

4. Click the x in upper-right corner to
close the drawing window. When Visio
asks if you want to update the master
and its instances, click Yes.

Tip: To save a drawing file stencil as a
stand-alone stencil you can use in other
diagrams, click the stencil’s title bar to
make it active. From the File menu,
choose Save As. In the Save As box, under
Save As, choose Stencil (*.VSS). Type a
name for the stencil, then click OK.

More Ø

➊ ➋

➌ ➍
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To open a copy of and edit an original stencil:
1. From the File menu, choose Open.

2. In the Open box, choose the stencil
you want to open. If you don’t see
the stencil, locate the stencil folder in
the Visio folder, then double-click the
Standard folder.

3. Under Open, check Copy, then click
OK.

4. Add master shapes to the new stencil
by dragging them from the drawing
page or from another stencil.
Rearrange master shapes on the
stencils by dragging the icons into the
order you want.

5. From the File Menu, choose Save As.

6. In the Save As box, locate the folder
where you want to place the stencil,
type a name, then click OK.

➊

➌

➍

➎

➏

➋
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To create a new stencil:
1. From the File menu, choose New.

2. In the New box, under New, click
Stencil.

3. Under Based On, choose No Stencil to
create a blank stencil, or choose a
stencil you want to base the new
stencil on, then click OK.

4. From the File menu, choose Save As.

5. In the Save As box, locate the folder
where you want to place the stencil,
type a name for the stencil, then click
OK.

6. To add a master shape to the new
stencil, drag the shape from the
drawing page or from another stencil.

➊

➋

➌

➍

➎

➏
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H A N D L I N G  M U L T I P L E  P A G E S

Some drawings, such as large organization
charts with many reporting levels, require
multiple pages. When you open a Visio
template to start a diagram, the diagram
has only one drawing page. You can,
however, add as many pages as you need.

For related information:
Placing Information
on Background Pages ........................... 62

See Online Help: press F1, click Search,
click Index, then type “pages.”

To create a new page:
1. From the Insert menu, choose Page.

2. In the Page box, under Name, type a
name if you want, then click OK.
Unless you change them, the new page
settings match the settings of the page
displayed when you chose the Insert/
Page command.

Tip: To move from one page to another,
click the Next Page and Previous Page
toolbar buttons. If you don’t see the
buttons, maximize the Visio window, or
choose Go To from the Edit menu, then
choose the page you want.

Aut VelSedConNisVelit Esse

Vel eumiriure

Duis autem velAliquam Erat

Consectetuer Nonummy

Once you have added your pages, you can move between,
reorder, or delete them. You can also open two pages in different
windows so you can move shapes from one to another or work
on both at the same time.

➊

➋
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To display more than one page at a time:
1. From the Edit menu, choose Go To,

then choose the first page you want to
display.

2. From the Window menu, choose New
Window. A new window opens
displaying a copy of the first page.

3. From the Edit menu, choose Go To,
then choose the second page you want
to display.

4. From the Window menu, choose Tile to
see both windows on the screen.

To reorder pages:
1. From the Edit menu, choose Drawing

Page, then choose Reorder.

2. In the Reorder box, choose the page
you want to move.

3. Click Move Up or Move Down until the
pages are in the order you want, then
click OK.

Tip: To delete a page, choose Drawing
Page from the Edit menu, then choose
Delete. In the Delete box, choose the page
you want to delete, then click OK.

➊

➋

➌

➊ ➋

➌

➍
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Q U I C K L Y  F O R M A T T I N G  S H A P E S

The fastest way to change a shape’s
appearance is to use Visio’s toolbar buttons
and toolbar text, line, or fill lists. For
example, if you have a white rectangle
with a 1-point black line and 10-point
black Arial text, you can use the toolbar
buttons and lists to change it to a blue
rectangle with a 9-point red line and 12-
point yellow Times text.

Once a text block or a shape looks the
way you want, you can quickly copy its
formatting to other shapes by using the
Format Painter tool.

If you consistently apply several attributes
to shapes you drag and drop or draw, you
should create a style.

For related information:
Formatting Shapes with Styles .................. 122

See Online Help: press F1, click Search,
click Index, then type “formatting.”

Buttons and lists on the main toolbar. The main toolbar is visible during most of
your work in the drawing window.

Text color
Decrease font size

Increase font size

Line style list

Line color
Line ends

Fill style list

Fill color
Fill pattern

Fill shadow

Round corners

Text style list
Text style list

Set font list

Font size list

Text color
Decrease font size

Increase font size

Underline
Superscript

Subscript

Left align
Center align

Right align
Justify align

Top align
Center align

Bold
Italic

Buttons and lists on the text toolbar. The text toolbar is visible when you have
text selected.

Lorem
Ipsum

Lorem
Ipsum

Lorem
Ipsum

Lorem
Ipsum

Lorem
Ipsum

Lorem
Ipsum

Lorem
Ipsum

Lorem
Ipsum

Lorem
Ipsum

The Format Painter tool transfers the attributes of a selected shape to another
shape.

Format Painter tool

Bottom align
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To quickly format a shape or text:
1. Select the shape or text you want to

format.

2. On the Visio toolbar, click the buttons
for the formatting you want to apply,
or choose options from the text, line,
and style lists.

The selected shape reflects your
choices.

Copying formatting from one shape to others
To Do this

Copy formatting from Select the shape with the formatting you want to copy. On the Visio toolbar
one shape to another click the Format Painter tool. Click the shape you want to copy

formatting to.

Copy formatting from one shape Select the shape with the formatting you want to copy. Press the CTRL key,
to more than one other shape sequentially then, click the Format Painter tool on the Visio toolbar. Click the shapes you

want to copy formatting to.

Copy formatting from one shape Select the shape with the formatting you want to copy, then press Shift to
to several others simultaneously select the shapes you want the formatting to copy to. On the Visio toolbar,

click the Format Painter tool.

Copy only the text attributes from Double-click a shape to select the text with attributes you want to copy. On
one shape to another the Visio toolbar, click the Format Painter tool. Click the shape you want to

copy the text formatting to.

➊ ➋
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1 2 3

1 2 3

1 2 3

Apply one style (5-point line; 30% gray fill; 12-point, bold text) to three
shapes to make them look the same.

Then change the style (5-point line; 70% gray fill; 10-point, white,
bold text) to change the appearance of all three shapes.

F O R M A T T I N G  S H A P E S  W I T H  S T Y L E S

A style is a combination of attributes you
can save with a template or drawing.
When you apply a style, you apply all the
attributes at once. Using a style not only
makes it easy to format several shapes, it
also guarantees that all the shapes will
look exactly alike. If you decide to change
an attribute (for example, change fill color
from red to green), you can change the
style. All the shapes you’ve applied the
style to also change.

Most Visio templates come with some styles
built in. For example, the Flowchart
template includes the style Flow Normal.
You can modify existing styles, create your
own from scratch, and delete styles you no
longer need.

Save styles you’re likely to use again in a
template. That way, when you open the
template to create a new diagram, the
styles will be available.

For related information, see online Help:
press F1, click Search, click Index, then
type “styles.”

1

2

3

1

2

3

To apply an existing style:
1. Select the text or shape you want to

format.

2. Choose the style you want to apply
from the Text, Line, and Fill Style lists
at the top of the Visio window.

Tip: All existing styles appear in the Text,
Line, and Fill Style lists. When you create
a style, Visio automatically adds it to one
or more lists.

➊ ➋
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A
B

C

D

E

F

G

1 2 3

To create a new style:
1. From the Format menu, choose Define

Styles.

2. In the Define Styles box, choose the
options you want.

3. Apply the new style to the shapes you
want to change.

Tip: You can delete or rename a style. In
the Define Styles box, find the name of the
style in the Style list that you want to
delete or rename. Click Delete or Rename.
If you’re deleting, click OK. If you’re
renaming, in the Rename Styles box, type
the new name, then click OK.

Define Styles Options

A Type a name for the style.

B To base a new style on an existing style, choose the existing one here.

C If your style includes text, check Text. Repeat for Line and Fill.

D To specify text formatting, click Text, then choose the characteristics you
want. Repeat for Line and Fill.

E Check here to preserve shapes’ special formatting–italic text, for example–
even after you apply the new style.

F If shapes were selected when you chose Define Styles, this button says Apply.
If no shapes were selected, it says OK.

G Click to save a style and start creating another.

To save styles to a template:
1. Create the styles you want to save.

2. From the File menu, choose Save As.

3. In the Save As box, under Save As
Type, choose Template (*.VST), then
type the name of the template you
want to save.

4. Under Save in, choose where you want
to save the template, then click Save.

➊ ➋

➊

➌

➍

➋





Directional Maps

For an overview of the best way to create a map, see “The Big Picture.”

To create a map as quickly as possible, turn directly to “Creating a
Directional Map.”

For detailed information, see the In Depth topics in this and other
chapters.

Topics in this chapter

The Big Picture ................................................................................. 126

Creating a Directional Map .............................................................. 128

In Depth ............................................................................................ 134
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T H E  B I G  P I C T U R E

2

4

1Open the
Map template.

Set up the
drawing page.

Drag and drop landmarks and
structures and edit the shapes.

3 Drag and drop road
and metro line shapes.

5 Label roads and other shapes.
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8

9

6 Add scale and directional
indicators.

7 Add written directions.

Refine the look of the map.

Save and produce.
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C R E A T I N G  A
D I R E C T I O N A L  M A P

We’ve provided complete instructions for creating a map. To create
your particular map, you may not need to complete each of the fol-
lowing steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open a map template:

1. Start Visio.

2. In the New box, under Based On, choose Map Template, then
click OK.

Visio opens a new file with a blank drawing page.

N

   Sit amet, consectetuer adipiscing
elit, sed diam nonummy nibh.

Euismod tincidunt ut laoreet dolore

magna aliquam erat volutpat.

   Ut wisi enim ad minim veniam,

quis nostrud exerci tation

allamcorper susipit lobortis nisl ut
aliquip ex ea commodo consequat.

Duis autem vel eumiriure dolor in

hendrerit in vulputate velit esse

molestie consequat.

Facilisis at vero

eros et

accumsan et

iusto odio
dignissim.

Duis autem

vel eumiriure

dolor in

hendrerit.

Euismod

susipit nisl

ut aliquip.

 Duis autem vel eumiriure

esse molestie consequat.

Eccumsan

et iusto odio.

N103

A5

3

N103

N103

R67

2
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size. Leave the scale set as No
Scale (1:1). Click OK.

For more details, see:

Setting Up a Diagram ........................................ 202

To add roads and metro lines:

1. Drag and drop road, metro line, or smart road shapes. To make
black roads, use road shapes. To make colored roads, use metro
line shapes. To make motorways, dual carriageways, primary or
secondary routes, or narrow streets, use smart road shapes.

(For details about how to use a shape, right-click it on the page or
on the stencil, then choose Shape Help.)

2. Make longer roads and metro lines and create curves and
intersections by gluing an endpoint from one shape to a connec-
tion point on another shape.

3. Use the flexible road and metro line shapes to create winding
roads and hairpin turns.

4. Drag and drop Station and Transfer Station shapes to create
metro line transfer stations. Right-click a transfer station shape
and choose Shape Help from the shortcut menu for help in
creating a metro transfer station.

For more details, see:

Connecting Shapes .............................................. 32
Positioning Shapes on the Page .......................... 92
Motorway network map .................................... 141
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To add landmarks:

1. Drag and drop shapes, such as buildings, parks, lakes, and trees,
and position them along the roads and in other areas of the map.

2. Add stop signs, stop lights, and railroad crossings.

3. If necessary, draw your own landmarks.

For more details, see:

Dragging and Dropping Shapes ......................... 26
Drawing Your Own Shapes ............................... 138
Positioning Shapes on the Page .......................... 92

To add scale and directional indicators:

1. Drag and drop the Scale shape and add numbers to indicate the
map’s approximate scale (the scale is set at 1:1, so the map is not
actually a scaled drawing). You can also use the Graph Scale
shape from the Chart stencil.

2. Drag and drop the Direction or North shape and rotate it, if
necessary, to point north.

For more details, see:

Rotating Shapes ................................................. 140

To add written directions:

1. From the toolbar, choose the text tool.

2. With the crossbar, point to where you want the written directions
to start, then drag a box about the size you think the directions
will be.

3. Type the directions.

4. From the Format menu, choose Font.

5. In the Font box, choose the font, size, color, and style for the text.

6. From the toolbar, choose the pointer tool, then click the text
block to select it.

N
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7. Drag a selection handle to change the text block width or height.

8. Position the pointer over the text block. When the pointer turns
white, drag the text block to where you want it to appear on the
page.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

To label roads and other shapes:

1. Select the shape you want to label.

2. Type the text. Visio zooms in on the selected shape as you type.

3. Press the ESC key or click outside the shape to return to the
original magnification.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

Refine the look of the directional map

To change the type of road a smart road shape represents:

1. Right-click the smart road shape you want to change, then
choose the type of road you want from the shortcut menu.

To change the relative width for all road and metro shapes at once:

1. Click the page where there are no shapes.

2. Right-click, and from the shortcut menu choose Road Properties.

3. In the Custom Properties box, type the width for a thin road.
Standard and thick road widths are multiples of this number.

To change the relative width for all smart road shapes at once:

1. Click the page where there are no shapes.

2. Right-click, and from the shortcut menu choose Road Properties.

3. In the Custom Properties box, choose a width for each type of
road.

Lorem
Ipsum
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To change the width of one road or metro shape:

1. Right-click the road, then choose the width you want from the
shortcut menu.

To change the width of one smart road shape:

1. Right-click the road, then choose Road Properties from the
shortcut menu.

2. In the Custom Properties box, type the road width you want,
then click OK.

To change the curves of a flexible road shape:

1. From the drawing tool menu on the toolbar, choose the freeform
tool.

2. Select the flexible road you want to change.

3. Place the freeform tool over a control point on the curve and
drag until the curve looks the way you want.

To extend a flexible road shape:

1. From the drawing tool menu on the toolbar, choose the freeform
tool.

2. Place the crosshairs over a flexible road shape endpoint, then
draw a curving road.

To change the way text looks:

1. Select the shape with text or the text block you want to change.

2. From the Format menu, choose Font. In the Font box, choose the
options you want, then click OK.

For more details, see:

Drawing Your Own Shapes ............................... 138
Formatting Shapes with Styles .......................... 122
Quickly Formatting Shapes ............................... 120
Working with Text ............................................. 168
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Save and produce a directional map

To name and save a completed map:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the map, choose the other
options you want, then click Save.

To print a map:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the map in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your map file to another document (so that when you update
the original you’ll also update the linked copy in the document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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Union

Combine

Subtract

Intersect

Fragment

M E R G I N G  S H A P E S

Sometimes the easiest way to create an
unusual or complex shape is to draw
simple shapes, then merge them.

In Visio, you can merge shapes using
several different operations:

• Union

• Combine

• Subtract

• Intersect

• Fragment

The merge operations apply to two-
dimensional, closed, filled shapes. (The
Fragment command also works on lines
and curves.)

New shapes created when you merge
separate shapes inherit their formatting
from the shape you select first. For
example, if you select a magenta square
first and then merge it with a white circle,
the merged shape has a magenta fill. In
all the illustrations on this page, the
darker shape was selected first.

For related information, see online Help:
press F1, click Search, click Find, then type
“joining.”
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To merge shapes:
1. Select the shapes you want to

merge.

2. From the Shape menu, choose
Operations, then choose the kind of
merging operation you want.

➊ ➋
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E D I T I N G  S H A P E S

Visio shapes are flexible. You can change
the angle at which two sides of a shape
meet, add and delete line and arc
segments, and change several aspects of
arcs. You can also alter the way lines and
arcs curve.

Editing some Visio shapes would interfere
with their function, so these shapes are
protected. For example, you can’t edit
segments on the chair shape from the
Office Layout template since editing the
shape would destroy the proportions of the
chair.

For related information:
Drawing Your Own Shapes ......................... 138

See online Help: press F1, click Search,
click Index, then type “segments.”

Vertex

Control point
Control point

To edit shape segments, select the shape with the pencil tool, then add,
select, and drag shape vertexes and control points. Selected vertexes and
control points turn magenta.

Use the pencil tool to change the curvature of a segment.

Add a segment to a shape by adding a vertex. Drag the new vertex
to change the way the shape looks.

Delete vertex A

A

A B

C

Delete vertex A Delete vertex B Delete vertex C

Delete a segment by deleting a vertex associated with it.

Change the symmetry of an arc by dragging
the handles associated with its control point.
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How to edit shapes
To Select the shape and use the pencil tool to

Select a vertex Click the vertex you want to select. The vertex turns magenta.

Move shape vertexes Select one or more vertexes and drag. Hold down the Shift key to select
more than one.

Add a vertex Point to where you want to add a vertex, hold down the CTRL key and click.

Delete a segment Select a vertex associated with the segment you want to delete, then press the Delete
key.

Change the curvature of an Drag a control point until the segment looks the way you want.
arc or freeform curve

Change the symmetry of an arc Select a control point, then hold down the CTRL key and drag the pointer slightly
away from the point to display two handles. Drag one handle farther or closer to the
control point or rotate it around the control point until the arc is aligned the way
you want.

Move the end of a freeform curve Select the curve, then drag a handle associated with the curve’s  endpoint.
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To draw a straight or curved line:
1. From the drawing tool menu, select the

pencil or line tool to draw a straight
line, the pencil or arc tool to draw an
arc, or the freeform tool to draw a
freeform curve.

2. Point to where you want the line to
start.

3. Drag in a straight or curving motion
until the line is the length you want.

Tip: When you draw an arc with the
pencil tool, holding down the Shift key
constrains the arc to a quarter of a circle.

D R A W I N G  Y O U R  O W N  S H A P E S

Visio provides six drawing tools you can use
to draw freeform curves, arcs, straight lines,
rectangular and elliptical shapes, and more.

Visio’s pencil tool is smart. Because it
anticipates what you’re drawing, you can
use it to draw either straight lines or arcs.
(You can also draw arcs with the arc tool,
but each arc you draw is a quarter ellipse.)

The freeform tool works like a pencil on
paper. Use it to draw freeform curves.

Tip: To draw smoother freeform curves,
turn snapping off before you draw. From
the Tools menu, choose Snap and Glue,
then, under Currently Active, uncheck Snap.

For related information:
Editing Shapes ............................................... 136

See online Help: press F1, click Search,
click Index, then type “arcs,” “lines,”
“freeform,” “rectangles,” or “ellipses.”

Pencil tool Line tool

Arc tool Freeform tool

Rectangle tool Ellipse tool

➊

➋

➌
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To draw a rectangle or ellipse:
1. From the drawing tool menu, select

the rectangle or ellipse tool.

2. Point to where you want the shape
to start.

3. Drag until the shape is the size you
want.

Tip: To draw a perfect square or
circle, hold down the Shift key before
you drag.

To draw a shape with several segments:
1. From the drawing tool menu, select

the tool you want to use.

2. Point to where you want the shape
to start.

3. Drag to create the first segment.

4. Release the mouse button.

5. To draw the next segment, select the
tool you want to use, point to either
endpoint of the first segment, and
then drag. When you finish, release
the mouse button.

6. Repeat step 5 until all the segments
are drawn.

Tip: To close a shape with several
segments, drag its beginning point to its
endpoint and release the mouse button.

➊

➋

➌

➊

➋

➌

➍

➎

➏
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Flip shapes horizontally or vertically

Reverse to flip shapes
both vertically and
horizontally

Rotate a shape in 90 degree increments or to any angle of rotation.

When you select a shape with the rotation
tool, rotation handles appear in the corners.

When you place the pointer over a rotation
handle, it changes to two arrows in a circle.

You can rotate a shape around any point by
moving its center of rotation.

Center of rotation

Rotation handles

Rotate shapes using the rotation
tool and commands on the Shape
menu.

R O T A T I N G  S H A P E S

Using Visio’s tools, you can easily flip,
reverse, or rotate shapes to face any
direction or angle you want.

As you rotate shapes, information on the
status bar at the bottom of the Visio
window displays the exact angle of
rotation.

For related information, see online Help:
press F1, click Search, click Index, then
type “rotating.”

Rotating anatomy
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Carlisle

Bournemouth

Torbay

Leeds

Sheffield

Ipswich

How to rotate shapes
To Use this tool Take these steps

Rotate a shape by 90 degrees Select the shape. From the Shape menu, choose Rotate
Left to rotate the shape counterclockwise or Rotate
Right to rotate the shape clockwise.

Rotate a shape by any amount Select the shape. Click the rotation tool on the toolbar.
Drag a rotation handle. For greater control, drag the
pointer farther from the center of rotation.

Move a shape’s center of rotation Select the shape. Click the rotation tool on the toolbar.
Drag the center of rotation to its new location.

Flip or reverse a shape Select the shape. From the Shape menu, choose Flip
Vertical, Flip Horizontal, or Reverse Ends.
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➌

➋

To create a road network map:
1. Drag and drop a geographic shape and

Main Cities shape on the page.

2. Select all the shapes.

3. Right-click one shape, then choose
Arrange to Page from the shortcut
menu. The cities will take their
appropriate places on the geographic
shape.

4. Select the Main Cities shape, choose
Grouping from the Shape menu, then
choose Ungroup.

5. Drag and drop smart road shapes from
the Map stencil to create a road
network connecting the cities.

Tip: To create smooth connections
between road shapes, right-click a smart
road shape, then choose Show Align. A
control handle appears just above the end
of the shape. Glue the control handle to
the corresponding connection point on an
adjoining road shape.
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When you create a region, Visio resizes
selected shapes and scales them
appropriately.

C R E A T I N G  G E O G R A P H I C  R E G I O N S

Visio provides a number of stencils that
include geographical shapes. For example,
the Africa stencil includes shapes for each
of the African countries.

All the geographical shapes are approxi-
mately the same size, so shapes for very
small areas are visible when you first drag
and drop them and shapes for very large
areas are not too large to fit on a page.

Using Visio’s region builder, you can
combine selected shapes into appropriately-
sized geographic regions. You can also
build regions based on the relative size
and shape of a particular country.

To create a geographic region:
1. Drag and drop the geographic shapes

you want to include.

2. From the Edit menu, choose Select All.

3. Right-click one shape and from the
shortcut menu, choose Arrange To Page.

Tip: You can also change the way a
geographic shape looks, then create a
region in which all the shapes arrange
themselves relative to the shape you
changed. Drag and drop the shapes, select
them, then choose Arrange To Shape from
the right-click shortcut menu. When
prompted, select the shape you want to
change, change it, then click OK.

Denmark, Norway, Finland, and Sweden
are actually quite different in size. On
the page, however, their shapes look
approximately the same.

➊ ➋

➌



Forms

For an overview of the best way to draw a form, see “The Big Picture.”

To create a form from scratch as quickly as possible, turn directly to
“Creating an Invoice.” (While this process refers to creating an in-
voice, the same steps apply to any type of form you’re creating.) If
you want to base your form on one of the form shapes provided on
the stencil (fax cover sheet, business card), use the procedure “Cus-
tomizing a Fax Cover Sheet” as an example of how to customize an
existing form.

For detailed information, see the In Depth topics in this and other
chapters.

Topics in this chapter

The Big Picture ................................................................................. 144

Creating an Invoice ........................................................................... 146

Customizing a Fax Cover Sheet ....................................................... 151

In Depth ............................................................................................ 156
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T H E  B I G  P I C T U R E

1Using existing data or
procedures, plan the layout
of the form.

2Open the Forms Template.

3Set up the drawing page.

4 Add the framework for the
form you want to draw.
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5 Add content to the form.

Refine the look of
the form.6

7 Save and produce.
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C R E A T I N G  A N  I N V O I C E

We’ve provided complete instructions for creating an invoice. To cre-
ate your particular form, you may not need to complete each of the
following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open the Forms template:

1. Start Visio.

2. In the New box, under Based On, choose Forms Template, then
click OK.

Eumiriure Ex:    004031

Duis:    03179

Consectetuer
Adipiscion

Vel  8 Facilisis at Vero
Vex Dignissim Quis WC 2E8 PS

44 31 555 5656 VEL
44 31 555 5659 VEX

Allamcorper susipit loboritis - Nisl

Duis autem - Loboritis

Tincidunt

DIAM 270.00

Ad Mininim Vel Esse Autem: Eumiriure: Vulputate:

6

2

1

39.00

18.00

27.00

234.00

36.00

27.00
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Size/Scale box, click Same As Printer or choose a standard
or custom drawing page size, then click OK.

For more details, see:

Drawing to Scale .................................................. 60
Setting Up a Diagram ........................................ 202

To add the form framework:

1. Drag and drop column, line, box, and grid shapes to create the
spaces you want.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Drag selection handles to make columns, lines, boxes, and grids
the size you want.

3. Duplicate lines and boxes to create repeating elements on the
form.

4. Drag a border shape for the form onto the drawing page, and
size the border to the size you want the form.

5. Choose a magnification from the Zoom Control list on the
toolbar to zoom in and align parts of the form framework with
one another and with the border.

For more details, see:

Duplication Techniques .................................... 172
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Add content to the form

To title the form:

1. Drag an 8-, 10-, or 18-point text block shape to where you want
the upper-left corner of the title.

2. Select the text block and type the text you want. As you type, the
shape expands to accommodate the text.

3. Drag a selection handle to change the text block size.

To add text to rows and columns:

1. Drag an 8-, 10-, or 18-point text block over a row. You can’t
change a text block’s height so choose a block that fits vertically
within the grid lines. Drag a selection handle horizontally until
the text block is the length of the row.

2. Select the text block, then choose Tabs from the Format menu.

3. In the Tabs box, set tabs to correspond to where you want text to
align in the columns.

4. With the text block selected, type the text you want.

To emphasize certain rows, columns, or locations:

1. Drag and drop arrow and callout shapes onto the form.

2. Select the shapes, then type the text you want.

For more details, see:

Setting Tabs ........................................................ 156
Working with Text ............................................. 168
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Refine the look of the form

To change the appearance of lines, boxes, columns, and grids:

1. Select the shape you want to change.

2. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

3. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

To add a colored background to boxes, columns, rows, or a grid:

1. From the drawing tool menu on the toolbar, choose the rectangle
tool.

2. Draw a rectangle the size of the box, column, row, or grid to
which you want to add a background.

3. From the Format menu, choose Fill.

4. In the Fill box, under Fill/Foreground, choose the background
color you want, then click OK.

5. From the Shape menu, choose Send To Back, to put the back-
ground rectangle behind the text in the box, column, row, or
grid.

To change the appearance of text:

1. Select the text block you want to change.

2. From the Format menu, choose Font. In the Font box, choose the
options you want, then click OK.

To add graphics to a form:

1. Copy and paste, import, embed, or link the graphics you want to
add.

For more details, see:

Formatting Shapes with Styles .......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

LOREM LOREM
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Save and produce the form

To name and save the completed form:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the form, choose the other
options you want, then click Save.

To print your form:

1. Choose Print from the File menu.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the form in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram.

2. From the Edit menu, choose Copy.

3. In the destination document, choose Paste (or the equivalent)
from that program’s Edit menu.

To link your form file to another document (so that when you update
the original you’ll also update the linked copy in the document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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C U S T O M I Z I N G  A
F A X  C O V E R  S H E E T

The Forms template includes a shape called Fax Cover. Drag and
drop the shape to create a complete fax cover sheet you can custom-
ize for your organization.

For the cover sheet you want to draw, you may not need to complete
each of the following steps.

To open the Forms template:

1. Start Visio.

2. In the New box, under Based On, choose Forms Template, then
click OK.

F A X
Et:
Lobortis:
Fax Minim:
Dolor Minims:

Duis:
Veniam:
Fax Minim:
Phone Minims:

Consectetuer
Adipiscion

Vel  8 Facilisis at Vero
Vex Dignissim Quis WC 2E8 PS

44 31 555 5656 VEL
44 31 555 5659 VEX
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Size/Scale box, click Same As Printer or choose a standard
or custom drawing page size, then click OK until you return to
the drawing page.

For more details, see:

Drawing to Scale .................................................. 60
Setting Up a Diagram ........................................ 202

To put a fax cover sheet on the drawing page:

1. Drag and drop the Fax Cover shape.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Drag a selection handle to make the cover sheet the size you
want.

To customize cover sheet text:

1. Select the cover sheet, then click to subselect the text you want to
customize to subselect it. The subselected area is surrounded by
gray selection handles. (You can’t edit the big word “fax.”)

2. Choose the text tool, select the text you want to replace, then
type the new text.
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3. From the Format menu, choose Font. In the Font box, choose
the options you want.

4. From the Format menu, choose Paragraph. In the Paragraph
box, choose the options you want.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

To delete the word “fax:”

1. Select the cover sheet, then click the word “fax” to subselect it.
The subselected area is surrounded by gray selection handles.

2. From the Shape menu, choose Grouping, then choose Remove
From Group. The gray selection handles turn green.

3. Press the Delete key.

To customize cover sheet lines:

1. Select the cover sheet, then click the line you want to customize
to subselect it. The subselected area is surrounded by gray
selection handles.

2. From the Format menu, choose Line. In the Line box, choose the
options you want.

For more details, see:

Quickly Formatting Shapes .............................. 120
Formatting Shapes with Styles .......................... 122

Lorem:

Et:

Dolor:
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To add additional text:

1. Drag an 8-point, 10-point, or 18-point text block shape to where
you want the upper-left corner of the text.

2. Select the text block and type the text you want. As you type, the
shape expands to accommodate the text.

3. Drag a selection handle to change the text block size. If you want
to change font size, choose Font from the Format menu. In the
Font box, choose a font size, then click OK.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

Save and produce the cover sheet

To name and save the completed cover sheet:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the cover sheet, choose the
other options you want, then click Save.

To print the cover sheet:

1. Choose Print from the File menu.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the cover sheet in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram.

2. From the Edit menu, choose Copy.

3. In the destination document, choose Paste (or the equivalent)
from that program’s Edit menu.

LOREM
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To link your cover sheet file to another document (so that when you
update the original you’ll also update the linked copy in the docu-
ment):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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S E T T I N G  T A B S

Use tabs to line text up in table form or
to create bulleted lists. An individual text
block can have up to ten tab stops.

Tab positions reflect distances from where
the text block begins, not the distance
from the edge of the page. Make setting
tabs easier by moving the zero point to
the edge of the text block before you
choose tab positions.

For related information:
Working with Text ....................................... 168

See Online Help: press F1, click Search,
click Index, then type “tabs.”

Duis autem vel:
Eros Dolor Odio

29.95 29.95 29.95 29.95
4.630 4.630 4.630 4.630
134.29 134.29 134.29 134.29
.250 .250 .250 .250

In Visio, tabs can be left-, center-, and right-aligned. Use decimal tabs to align
columns of numbers.

• Lorem Ipsum dolor sit amet
• Consectetuer adipiscing elit
• Sed diam nonummy nibh euismod

Tincidunt ut laorett dolore magna
• Aliquam erat volutpat Ut wisi enim

ad nimim
Using tabs in combination with paragraph indent settings, you can create
bulleted lists with hanging indents.

Lorem 01 31 22
Ipsum 22 03 09

Select a text block to set tabs for the whole paragraph at once.

Select a sentence to set tabs for part of a text block.
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Tab Anatomy
Tabs Box

A Type the distance from the edge of the
text block where you want the tab.

B Choose the tab alignment you want.
C Click to delete the tab stop selected in

the Tab Stops list.
D Click to add a tab setting to the Tab

Stops list.
E Click to open the Font box if you

want to change the way selected text
looks.

F Click to apply the tab settings to
selected text and leave the Tabs box
open.

G Click to apply the tab settings and
close the Tabs box.

H Lists the tabs set for selected text.

B

D

E
F

G

Making bullets

To make a standard bullet in Visio, type CTRL + Shift + 8. Select the bullet and
use the Font Size list on the toolbar to change its size.

A C

H

• • • • • •

More ➤
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To create a bulleted list:
1. Choose the text tool and draw a text

block or select an existing text block
or shape.

2. From the Format menu, choose
Paragraph.

3. In the Paragraph box, under Horizontal
Alignment, choose Left.

4. Under Indents, for From Left, type
5mm, or any setting that will leave
enough room for a bullet and blank
space.

5. For First Line, type -5mm, or the
negative of whatever setting you chose
in step 4, then click OK.

6. From the Format menu, choose Tabs.

7. In the Tabs box, under Position, type
5mm, or whatever indent setting you
chose in the Paragraph box, click Add,
then click OK.

8. Type a bullet, press Tab, then type
text to create a bulleted list.

Sit amit, conectetuer
dipiscing elit, sed diam
nonummy nibh.

• Sit amet, consectetuer adipiscing
elit, sed diam nonummy nibh.

• Sit amet, consectetuer adipiscing
elit, sed diam nonummy nibh.

• Sit amet, consectetuer adipiscing
elit, sed diam nonummy nibh.
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To set tabs for table text:
1. Choose the text tool and draw a

text block or select an existing text
block.

2. From the Format menu, choose
Paragraph.

3. In the Paragraph box, set Horizontal
Alignment to Left and Indents to
zero, then click OK.

4. Hold down the CTRL key and drag
the crossbar to move the zero point
to the left edge of the text block.

5. From the Format menu, choose
Tabs.

6. In the Tabs box, enter the tab
positions and alignments you want,
then click OK.

Lorem 01 31 22
Ipsum 22 03 09

Lorem 01 31 22
Ipsum 22 03 09

0

0

Lorem 01 31 22
Ipsum 22 03 09
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F I N D I N G  A N D  C O R R E C T I N G  T E X T

Visio can automatically correct spelling or
find and replace all uses of particular
words. You can specify whether you want
Visio to search a selection, a page, or the
whole diagram.

When Visio searches for or checks text, it
examines text in shapes, in independent
text blocks, on stencils, in the Properties
box, and in data fields.

If you frequently use words that aren’t in
the dictionary (for example, the word
Visio), you can create a user dictionary
that includes these words. Then, when Visio
checks your spelling, it won’t highlight the
words. You can even create different user
dictionaries for different purposes.

Find and Replace Options

A Type the search string you want to
find or replace.

B Type the text you want to replace the
search string with.

C Click to search for a special character
such as a Tab or Manual Return.

D Click to search selected text, the
current page, or all pages.

E Check to locate only words that match
the case of the search string.

F Check to locate only whole words that
match the search string.

G Click to replace all occurrences of a
search string.

H Click Find Next to find the next
occurrence of the search string, then
click Replace to replace the selected
text.

Sit amit, conectetuer
dipiscing elit, sed diam
nonummy nibh.

Sit amit, conectetuer
dipiscing elit, sed diam
nonummy nibh.

Sit amet, conectetuer
dipiscing elit, sed diam
nonummy nibh.

A
B

E

F

H

G
D

C
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A
B
C

D

E F

I

H
G

A

B
C

More Ø

J

E

D

Spell Checking Options

A Displays words not found in the
dictionary.

B Displays an alternative to the word in
A. You can also type your own
alternative.

C Displays a list of suggested alternatives.
Click an alternative to display it in B.

D Choose the user dictionary to which you
want to add a word.

E Click to add the word in A to the user
dictionary you chose in D.

F Click to choose what text to search and
to add or remove a user dictionary.
(see Spelling Options below).

G Click to change all occurrences of a
word in A to the word in B.

H Click to ignore future occurrences of
the word in A.

I Click to change the word in A to the
word in B.

J Click to leave the word in A as it is.

E

Spelling Options

A Check the part of the diagram you
want to search.

B Click to add a user dictionary. In
the Add User Dictionary box, type a
name for the dictionary.

C Click to use the Microsoft Word
Dictoionary.

D When checked, Visio won’t flag
words that include numbers as
spelling errors. Uncheck to flag
words with numbers as misspelled.

E Under Active, choose a user
dictionary.

F Click here to remove the user
dictionary you chose in E.

F
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To search for a word or phrase:
1. From the Edit menu, choose Find.

2. In the Find box, choose the options
you want, type the word or phrase
you want to find or choose an option
from the Special list, then click Find.

3. Close the Find box to edit the word or
phrase.

4. To find the same word or phrase
again, click Find Next.

To replace a word or phrase:
1. From the Edit menu, choose Replace.

2. In the Replace box, under Find What,
type the word or phrase you want to
replace or choose an option from the
Special list.

3. Under Replace With, type the new
word or phrase or choose an option
from the Special list.

4. Choose the search and other options
you want.

5. Click Find Next or Replace All.

6. When Visio has finished replacing, a
message box appears. Click OK.

➊

➋

➌
➍

➊

➋

➌

➍

➎
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To check spelling in a Visio diagram:
1. From the Tools menu, choose Spelling.

Visio begins searching your diagram.

2. For each word not in the dictionary,
click the option you want, or type an
alternative.

3. When Visio has finished searching, a
message box appears. Click OK.

To create a user dictionary:
1. From the Tools menu, choose Spelling.

2. In the Spelling box, click Options.

3. In the Options box, under User
Dictionaries, click Add.

4. In the Add User Dictionary box, under
File name, type a name for the
dictionary, then click Open.

5. In the Spelling Options box, click OK.

➊ ➋

➌

➊ ➋

➌ ➍
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To insert a page number field:
1. Select the text tool, then drag to

create a text block on the drawing
page.

2. From the Insert menu, choose Field.

3. In the Field box, under Category,
choose Page Info.

4. Under Field, choose Page Number, then
click OK.

Tip: To have page numbers appear on
each page in a multi-page diagram, copy
the field, then paste it onto each page.
Or, place the page number field on a
background page, then assign the
background to each foreground page.
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Visio can update certain kinds of
information in a diagram automatically.
This information appears in fields you can
size and position on a page.

For example, you can add a page number
field to automatically number your
diagram pages or a date/time field to
display the last date a document was
edited. You can also add data and
geometry fields to shapes. Geometry fields
calculate amounts, such as how far a
shape is rotated from its original position.

For related information, see online Help:
press F1, click Search, click Index, then
type “fields.”
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More Ø

To insert a creation date field:
1. Select the text tool, then drag to

create a text block on the drawing
page.

2. From the Insert menu, choose Field.

3. In the Field box, under Category,
choose Date/Time.

4. Under Field, choose Creation Date.
Under Format, choose the format you
want, then click OK.

The creation date field appears on the
drawing page.

To number shapes:
1. Select the shapes you want to number.

2. From the Insert menu, choose Field.

3. In the Field box, under Category,
choose Object Info.

4. Under Field, choose ID, then click OK.

5. The shapes are numbered according to
the order in which you dropped them
on the drawing page.

Tuesday, August
01, 1995

1

2
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1.5x1.5

1x1

To add dimension fields to a shape:
1. Select the shape to which you want to

add dimension fields.

2. From the Insert menu, choose Field.

3. In the Field box, under Category,
choose Geometry, then under Field,
choose Width.

4. Under Format, choose the format in
which you want the field information
to appear, then click OK.

5. Choose the text tool, and select the
shape. Place the insertion point after
the width number and type “x.”

6. Follow steps 2 through 4 above, but
choose Height instead of Width.

7. Resize the shape and the dimensions
will change.

➊ ➋

➌

➍

➎

➏
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Fields you can add to diagrams
To add any of the following fields to a
diagram, drag a text block where you
want the field or select the appropriate
shapes, choose Field from the Insert menu,
then choose the options you want.

Field Use to display

Date/Time Date and time a file was created, revised, or printed, or display the current date and
time. Date and time information are based on the date and time you set in the
Windows Control Panel.

Geometry Width, height, and angle information. Use to update technical specifications in a
diagram, create dimension lines, or measure the angle of rotation.

Document Info Information entered in the Properties box for a file. Includes information such as
creator name, file name, subject, key words, and description. Open the Properties box
by choosing Properties from the File menu.

Object Info Information entered in the Special box, such as a shape’s name, ID number, and
anything you enter in the Data fields. Open the Special box by choosing Special
from the Format menu.

Page Info Information about a foreground page. Some of the information, such as page and
background name, comes from the Page Properties box. Use the Page Number field to
include a page number on a page.

Lotus Notes Information from Lotus Notes. For example, you can create a date field in Lotus Notes
that automatically updates a Visio timeline. Or, you can enter information in the Visio
Properties box and read it in Lotus Notes.

Custom Formula The result of a calculation you define by entering a formula. For more information, in
Online Help, click Search, click Index, then type “custom formulas.”



168   C R E A T I N G   B U S I N E S S   D I A G R A M S   W I T H   V I S I O

W O R K I N G  W I T H  T E X T

Most drawings are accompanied by text in
the form of labels, legends, or titles. In
Visio, you can either attach text directly to
shapes or type it independently anywhere
on the drawing page. When you rotate or
move a shape, text attached to it rotates
and moves along with it. You can also
size, rotate, or move text separately from
its shape.

You can change the appearance of both
shape and independent text and control its
horizontal and vertical alignment.

Lorem
Ipsum Lore

m

Ipsu
m

Lorem Ipsum

Text Smaller Larger Bold Italic Underline Super- Sub-
color font font script script

Left Center Right Justify Top Center Bottom Rotation
align align align align align align tool

Text block tool
Text tool

Text anatomy
Text in Visio is surrounded by a text block.
Use text block selection handles to size the
text block or rotate text.

Use the pointer tool to select text blocks
and text. Use the text tool to type and
edit text. Use the text block tool to size,
move, or rotate a text block separately
from its shape.

When text is selected, these toolbar
buttons apply the indicated formatting.

For related information, see online Help:
press F1, click Search, click Index, then
type “text.”

Lorem Ipsum

Lorem Ipsum

Lorem Ipsum

Lorem ipsum amet
consectetuer elit, sed

diam nonummy.

Lorem ipsum amet
consectetuer elit, sed

 iam nonummy.

Lorem ipsum amet
consectetuer elit, sed
diam nonummy.
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Font Box

A Choose a font.

B Choose font size, color, case, and
position.

C Choose font style.

D Click these buttons to open other text
formatting boxes.

E Click these buttons to format the
shape associated with the text block.

F Click to see the effects of your choices
without closing the box.

Paragraph Box

A Choose horizontal alignment.

B Set the indents between a paragraph
and the edge of the text block.

C Set the spacing between paragraphs
and between lines of text.

D Click to open the Font box.

E Click to see the effects of your choices
without closing the box.

Text Block Box

A Choose vertical alignment.

B Set the margins between text and the
edges of the text block.

C Click for no text block background.

D Click to add a colored background to
the selected text block.

E Choose the background color.

F Open the Font box.

G Click to see the effects of your choices
without closing the box.
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C
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How to work with shape text
To Use this tool Take these steps

Attach text to a shape Select the shape and start typing. If the shape already
had text, what you type replaces it. When you finish
typing, press the ESC key.

Open a shape text block Click the shape.

Select shape text Double-click the shape.

Select a shape text block Click the shape.

Select a paragraph, sentence, word, Click the shape and, with the insertion point, highlight
or character in a shape text block the text you want.

Change shape text appearance Select the text you want to change. Select the toolbar
button, Format menu command, or popup menu
selection you want.

Add a colored background to a Select the shape, and from the Format menu, choose
shape text block Text Block. Under Text Background, click Solid Color,

choose the color you want, then click OK.

Align shape text horizontally Double-click the shape, then click the toolbar
button for the horizontal alignment you want.

Align shape text vertically Double-click the shape, then click the toolbar
button for the vertical alignment you want.

Resize a shape text block Click the shape and drag one of the square selection
handles to change the text block’s height or width.

Move a shape text block Click the shape, place the cursor in the text
block, and drag.

Rotate a shape text block Click the shape, place the cursor over a round
selection handle, and drag in the direction you want
the text block to rotate.
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How to work with independent text
To Use this tool Take these steps

Type independent text Click where you want to start typing, or drag to choose
the size of the independent text block. Type the text,
and then press the Esc key.

Open an independent text block Click the text block.

Select an independent text block Click the text block.

Select independent text Double-click the text block.

Select a paragraph, sentence, word, or Click the text block, then with the insertion point,
character in an independent text block highlight the text you want.

Change independent text appearance Select the text you want to change, then choose
the toolbar button, Format menu command, or popup
menu selection you want.

Add a colored background to an Select the text block, then, from the Format menu,
independent text block choose Text Block. Under Text Background, click Solid

Color, choose the color you want, then click OK.

Align independent text horizontally Double-click the text block and then click the toolbar
or vertically button for the horizontal or vertical alignment you

want.

Resize an independent text block Select the text block, then drag one of the square
selection handles to change the text block’s height or
width.

Move an independent text block Select the text block, hold down the mouse button, and
drag.

Rotate an independent text block Select the text block, then place the cursor over a
round selection handle and drag in the direction
you want the text block to rotate. When you
finish, release the mouse button.
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D U P L I C A T I O N  T E C H N I Q U E S

In Visio, you can duplicate shapes to
quickly create diagrams, such as forms or
borders, that are made up of repeating
elements. Which technique you use
depends upon the kind of duplication you
want.

To do this: Take these actions:

Duplicate a shape Select the shape. From the Edit menu,
choose Duplicate (or press CTRL+D).

Quickly make several Select the shape. Press CTRL+D for each
duplicated copies of copy you want.
a shape.

Duplicate a shape at a Select the shape. Hold down the CTRL key
specific location and drag to where you want the copy.

Repeatedly duplicate a shape and Select the shape. Hold down the CTRL key
the offset between duplicated and drag to where you want the copy.
shapes Release the mouse button. Press

F4 for each copy you want. The space
between the shapes is the offset, and will
also be duplicated.
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Charts

For an overview of the best way to create a chart, see “The Big Picture.”

To create a chart as quickly as possible, turn directly to the “Creating
a...” topic that corresponds to the type of chart you want to create.

For detailed information, see the In Depth topics in this and other
chapters.

Topics in this chapter

The Big Picture ................................................................................. 172

Creating a Pie Chart ......................................................................... 174

Creating a Bar Chart ......................................................................... 179

Creating a Line Chart ....................................................................... 184

In Depth ............................................................................................ 190
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T H E  B I G  P I C T U R E

Set up the drawing page.2

Determine the type of chart that works
best for the data you want to represent.

Set up the chart scale or axes.3

Add data.

4

Open the Chart Template.1
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Refine the look of
the chart.6

Add a title, caption,
and other text.5

Save and produce.7
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C R E A T I N G  A  P I E  C H A R T

We’ve provided complete instructions for creating a pie chart. To cre-
ate your particular chart, you may not need to complete each of the
following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open the chart template:

1. Start Visio.

2. In the New box, under Based On, choose Chart Template, then
click OK.

Visio opens a new file with a blank drawing page.
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size. Leave the scale set as No
Scale (1:1). Click OK.

For more details, see:

Setting Up a Diagram ........................................ 202

To add pie slices:

1. Drag and drop the Super Smart Slice onto the drawing page.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Select the slice, then press the CTRL key and drag the shape to
duplicate it.

3. Move the duplicate over the first piece so the shapes glue at the
center of the pie. (The endpoint turns red).

4. Drag the duplicate piece’s endpoint to position the piece to the
left of the original piece.

5. Drag the duplicate piece’s control handle to size it.

6. Repeat steps 2 through 5 to create the rest of the slices, moving
counterclockwise around the pie.

25 % 25 %

25 %

25 %

36 %

39 %

25 %25
 %

Drag the endpoint.

25 %
39 %

25 %25 %

Drag the control handle.
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To emphasize one pie slice:

1. Choose Snap & Glue from the Tools menu, then uncheck Glue.

2.  Select each pie slice and move it slightly to break the glue (the
endpoints change from red to green), then snap it back into
place.

3. Move the slice you want to emphasize away from the other slices.

To add a title or caption:

1. Drag and drop an 8-point, 10-point, or 12-point Text Block
shape where you want the upper-left corner of the caption or
title.

2. With the text block selected, type the text you want. As you type,
the shape expands to accommodate the text.

3. Drag a selection handle to change the text block size. From the
Format menu, choose Font to change the attributes of the text.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

To add callouts:

1. Drag and drop one of the callout shapes near the shape you want
to call out.

2. Select the callout shape and type the text you want. Drag a
selection handle to resize the shape.

3. Drag a selection or control handle (depending on the shape) to
adjust the length and angle of the pointer.

For more details, see:

Control Handles ................................................ 101

Lorem ipsum amet
consectetuer elit.

Lorem
ipsum
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Refine the look of the chart

To change the way a pie slice looks:

1. Select the pie slice you want to change.

2. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

3. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

To change the way text looks:

1. Select the text block you want to change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

For more details, see:

Adding Special Effects to Charts ...................... 192
Formatting Shapes with Styles .......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

Save and produce the chart

To name and save a completed pie chart:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the chart, choose the other
options you want, then click Save.

To print a pie chart:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

25 %
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To place a copy of the pie chart in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your chart file to another document (so that when you update
the original you’ll also update the linked copy in the document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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C R E A T I N G  A  B A R  C H A R T

We’ve provided complete instructions for creating a bar chart. To
create your particular chart, you may not need to complete each of
the following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open the chart template:

1. Start Visio.

2. In the New box, under Based On, choose Chart Template, then
click OK.

Visio opens a new file with a blank drawing page.
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same As Printer or choose a
standard or custom drawing page size. Leave the scale set as No
Scale (1:1). Click OK.

For more details, see:

Setting Up a Diagram ........................................ 202

To set up the chart scale or axes:

1. Drag and drop a Graph Scale shape onto the drawing page.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Drag a selection handle to make the graph scale the height you
want.

3. With the graph scale selected, type a number for the topmost
point on the scale.

To add bars:

1. Decide whether you want a black-and-white or color chart and
whether you want the bars to represent numbers or percentages,
then drag the appropriate Bar Graph shape onto the drawing
page. Line it up with the graph scale.
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2. Drag the control handle on the non-printing bar to the left of the
bar graph to change the height of the shape. The value in the
non-printing bar determines the scale.

3. Drag the control handle at the bottom of the bar graph to change
the width of the bars. As you widen the bars, the number of bars
decreases.

4. Select the bar graph, then click a bar to subselect it. Type a value
for the height of the particular bar. Continue subselecting bars
and typing values until all the bars are the correct height.

5. Select the bar graph, then drag the control handle in the red area
to the left of the first bar to change the relative height of all the
bars.

To add a title and captions:

1. Drag and drop an 8-point, 10-point, or 12-point Text Block
shape where you want the upper-left corner of the caption or
title.

2. With the text block selected, type the text you want. As you type,
the shape expands to accommodate the text.

3. Drag a selection handle to change the text block size. If you want
to change font size, choose Font from the Format menu. In the
Font box, choose a font size, then click OK.

4. Drag and drop Vertical Bar Text or Horizontal Bar Text shapes to
add x- and y-axis labels. Select a text shape and type the text you
want.

5. Drag and drop Row/Column Header shapes at the base of each
bar. If you want to rotate the shapes, select the Rotate tool on the
toolbar and rotate row/column Headers until they face the
correct direction. Select a row/column header and type the text
you want.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

The nonprinting bar
determines graph height.

Drag the control handle to set bar width.
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To add callouts:

1. Drag and drop one of the callout shapes near the data point you
want to call out.

2. With the callout shape selected, type to add the text you want.
With the pointer tool, drag a selection handle to resize the shape.

3. Drag a selection or control handle (depending on the shape) to
adjust the length and angle of the pointer.

Refine the look of the chart

To change the way a bar looks:

1. Select the bar graph, then click to subselect the bar you want to
change.

2. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

3. From the Format menu, choose Line. In the Line box, choose the
options you want, then click OK.

To change the way the graph scale looks:

1. Select the graph scale, and from the Format menu, choose Line.

2. In the Line box, choose the line thickness and pattern you want,
then click OK.

To change the way text looks:

1. Select the text block you want to change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

For more details, see:

Adding Special Effects to Charts ...................... 192
Formatting Shapes with Styles .......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

Lorem ipsum
amet, sed
diam.
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Save and produce the chart

To name and save a completed bar chart:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the chart, choose the other
options you want, then click Save.

To print a bar chart:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.

To place a copy of the bar chart in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your chart file to another document (so that when you update
the original you’ll also update the linked copy in the document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224
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C R E A T I N G  A  L I N E  C H A R T

We’ve provided complete instructions for creating a line chart. To
draw your particular chart, you may not need to complete each of the
following steps.

Shape Help is the best source of information about particular shapes.
To open it, right-click a shape, then choose Shape Help from the
shortcut menu.

To open the chart template:

1. Start Visio.

2. In the New box, under Based On, choose Chart Template, then
click OK.

Visio opens a new file with a blank drawing page.

Lorem       Ipsum       Susipt       Diam
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To set up the drawing page:

1. From the File menu, choose Page Setup.

2. In the Page Setup box, click Portrait (tall) or Landscape (wide)
orientation, choose a paper size, then click OK.

3. From the Edit menu, choose Drawing Page, then choose Size &
Scale.

4. In the Drawing Size/Scale box, click Same as Printer or choose a
standard or custom drawing page size. Leave the scale set as No
Scale (1:1). Click OK.

For more details, see:

Setting Up a Diagram ........................................ 202

To set up the chart scale or axes:

1. Drag and drop a Graph Scale shape onto the drawing page.

(For details about how to use a shape, right-click it on the page
or on the stencil, then choose Shape Help.)

2. Drag a selection handle to make the Graph Scale shape the
height you want.

3. With the graph scale selected, type a number for the topmost
point on the scale.

To add and position data points:

1. Drag the Line Graph shape onto the drawing page and line it up
with the graph scale.

2. If you need to add more data points, align a second Line Graph
shape at the end of the first, then flip the second shape horizon-
tally.
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3. If you need to delete data points, drag them to the right edge of
the graph.

4. Select the line graph and drag side selection handles to change its
height and width.

5. Drag the control handles associated with each data point to the
appropriate value on the scale.

For more details, see:

Control Handles ................................................ 101

To add x- and y-axis labels to the line graph:

1. Select the line graph, then click below the x-axis to subselect the
x-axis text block. Type the label you want.

2. Select the line graph, then click to the left of the y-axis to
subselect the y-axis text block. Type the label you want.

For more details, see:

Working with Text ............................................. 168

To add a title and captions:

1. Drag and drop an 8-point, 10-point, or 12-point Text Block
shape where you want the upper-left corner of the caption or
title.

2. With the text block selected, type the text you want. As you type,
the shape expands to accommodate the text.

3. Drag a selection handle to change the text block size. If you want
to change font size, choose Font from the Format menu. In the
Font box, choose a font size, then click OK.

4. Drag and drop Vertical Bar Text or Horizontal Bar Text shapes to
add x- and y-axis labels. Select a text shape and type the text you
want.

For more details, see:

Finding and Correcting Text ............................. 160
Working with Text ............................................. 168

Drag data point control handles.

Data point contol handle

Lorem     Ipsum     Arnet     Cons     Sect     Elit



C H A R T S  189

To add callouts:

1. Drag and drop one of the callout shapes near the data point you
want to call out.

2. With the callout shape selected, type to add the text you want.
With the pointer tool, drag a selection handle to resize the shape.

3. Drag a selection or control handle (depending on the shape) to
adjust the length and angle of the pointer.

Refine the look of the chart

To change the length of the black border along the x- and y-axes:

1. Drag the control handles at the upper-left and lower-right
corners of the line graph.

To add horizontal or vertical grid lines to a line graph:

1. Select the Line tool from the drawing tool menu on the toolbar,
then draw the lines you want.

To change the look of the area below the line:

1. Select the line graph, then click to subselect the area.

2. From the Format menu, choose Fill. In the Fill box, choose the
options you want, then click OK.

To emphasize the data points:

1. Drag and drop Data Point shapes on top of each data point on
the line graph.
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To create a heavy line that follows the fluctuations of the chart:

1. Drag and drop Graph Line shapes over each line segment on the
line graph, aligning the endpoints with data points.

To change the way text looks:

1. Select or subselect the text block you want to change.

2. From the Format menu, choose Font. In the Font box, choose
the options you want, then click OK.

For more details, see:

Adding Special Effects to Charts ...................... 192
Control Handles ................................................ 101
Formatting Shapes with Styles ......................... 122
Quickly Formatting Shapes .............................. 120
Working with Text ............................................. 168

Save and produce the chart

To name and save a completed line chart:

1. From the File menu, choose Save As.

2. In the Save As box, type a name for the chart, choose the other
options you want, then click Save.

To print a line chart:

1. From the File menu, choose Print.

2. In the Print box, choose the print options you want, then click
OK.
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To place a copy of the line chart in another document:

1. Choose Select All from Visio’s Edit menu to select the entire
diagram, then, from the Edit menu, choose Copy.

2. Open the destination document, then choose Paste (or the
equivalent) from that program’s Edit menu.

To link your chart file to another document (so that when you update
the original you’ll also update the linked copy in the document):

1. Make sure nothing is selected, then choose Copy Drawing from
Visio’s Edit menu.

2. In the destination document, choose Paste Special (or the
equivalent) from that program’s Edit menu.

3. In the Paste Special box, choose the format for the linked file,
click Paste Link, then click OK.

For more details, see:

Placing Visio Information ................................. 206
Printing Diagrams ............................................. 198
Saving Visio Files ................................................. 44
Using the Binder ................................................ 224



192   C R E A T I N G   B U S I N E S S   D I A G R A M S   W I T H   V I S I O

A D D I N G  S P E C I A L  E F F E C T S  T O  C H A R T S

Use Visio’s stretchable and stackable shapes
to add interest to your charts. For
example, a stretchable arm or flower can
indicate growth more effectively than a
bar. Columns of stackable dollars or people
show budgetary or population variations
more dramatically than a fluctuating line.

The Chart stencil includes some stretchable
and stackable shapes, which you can
identify by name (Stretchable Dollars) or
by icon (the People icon has several
people shapes on it). You can also create
stretchable and stackable shapes of your
own.

Creating stretchable shapes
Stretchable shapes can be two- or three-
part shapes. Each part can be a shape
from a Visio stencil, a shape you draw, or
a piece of clip art. Where you place the
parts determines which part stretches.
Simple, drawn shapes make the best
stretchable parts. Complex shapes may
distort when they stretch.

When you increase the size of a stretchable shape,
part of the shape stretches.

When you increase the size of a stackable shape, the
shape duplicates itself.

In a two-part stretchable shape, the left part stretches.

In a three-part stretchable shape, the middle part stretches.

Stretchable shapes can be solid or they can include gaps between parts.
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To create a stretchable shape:
1. Assemble the parts of the stretchable

shape you want to create, placing the
stretchable part on the left or in the
middle of the shape.

2. From the Tools menu, choose Run Add-
on.

3. Choose GraphMaker.

4. In the GraphMaker box, click Extend-o
shape, then click Next.

5. In the Extend-o Shapes Options box,
choose the options you want.

6. Click Select Shapes, then follow the
instructions in the Select Shapes boxes.

7. In the Extend-o Shapes Options box,
click Create.

Tip: You can modify a stretchable shape
after you’ve created it. Right-mouse click
the shape, then choose Shape Properties to
change height, width, or the offsets
between shape parts.

GraphMaker options

A Click to determine the number of
pieces in the stretchable shape.

B Type the amount of space you want
between shapes.

C Choose which way you want the
stretchable shape to stretch.

B C

A

More Ø

➊ ➋

➌

➍ ➎

➏
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To create a stretchable shape from parts of a single shape:
1. Drag and drop the shape you want to

use onto the drawing page.

2. Select the shape, then copy it.

3. From the Edit menu, choose Paste
Special.

4. In the Paste Special box, select Windows
Metafile Data, then click OK.

5. Repeat steps 3 and 4 until you have
as many instances of the shape as you
want.

6. Select the crop tool and crop each
instance to create the parts for the
stretchable shape.

Creating stackable shapes
Any shape or piece of clip art can be
stacked.

You can control how shapes stack. For
example, you can stack shapes horizontally
or vertically. You can fix the number of
shapes in a stack or make the number
change as the stack is stretched. Shapes in
a stack can have spaces between them and
the alignment between shapes can vary.

Horizontal stack Fixed stack

Vertical stack Variable stack alignment between shapes

➊ ➋ ➌

➍

➎

➏
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➊ ➋

➍

A

B
C
D
E

➎

➌

To create a stack:
1. Drag and drop the shape you want to

stack onto the drawing page and select
it.

2. From the Tools menu, choose Run Add-
on.

3. Choose GraphMaker.

4. In the GraphMaker box, click Stack Of
Shapes, then click Next.

5. In the Stackable Shapes Options box,
choose the options you want, then
click Create.

Tip: You can modify a stack after you’ve
created it. Right-mouse click the stack,
then choose Shape Properties to change
the height, spacing or offset between
shapes, and the stack’s background color.

Graphmaker options
A Choose a variable length or fixed

length stack.
B Type the number of shapes in the

stack.
C Type the amount of space you want

between shapes.
D Type the amount you want each shape

offset from the one before.
E Type the length or height of a

horizontal or vertical stack.
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U S I N G  C L I P  A R T  I N  V I S I O  D I A G R A M S

Visio shapes are more than clip art. Each
shape has a ShapeSheet™ spreadsheet
attached to it that contains information
about the shape’s geometry and behavior.
When you change ShapeSheet information,
you change shape appearance and
behavior.

Because they have ShapeSheets, Visio
shapes are smart. Not only can you resize,
flip, and rotate them, you can also predict
their behavior and control it in special
ways.

In addition to smart shapes, Visio includes
clip art. Clip art shapes are available on a
stencil from which you drag and drop
them onto a drawing page. You can also
import clip art from other sources into
Visio diagrams.

Although you can’t expect clip art to
behave like Visio’s shapes, you can modify
it in several ways. You can also convert
clip art in Windows metafile format to
Visio shapes. The converted shapes act like
Visio shapes.

You can also use clip art for adding
special effects to charts and other
diagrams.

Tip: When you crop clip art, Visio retains
the part you crop so you can always
adjust the crop by choosing the Crop tool
and dragging a selection handle.

When you stretch the
arrow, its arrowhead size
doesn’t change.

Use the arrow’s control
handles to customize the
arrowhead and the tail.

What you can do with clip art:

Sizing

Repositioning Converting to a Visio shape

What you can do with Visio shapes:

Original shape

ShapeSheet
Flipped shape

Rotated shape

Cropping
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Working with Clip Art
To Use this tool Follow these steps

Change the size of a piece of clip art. Select the clip art. Drag a side or corner selection
handle until the clip art is the size you want.

Crop a piece of clip art. Select the clip art. Drag a selection handle until the
object’s borders are the size you want.

Reposition a piece of clip art. Select the clip art. Point inside the object and press the
left mouse button. Drag until the object is positioned
where you want it.

Convert a piece of clip art to a Visio shape. Select the clip art. From the Shape menu, choose
Grouping, then choose Convert To Group.

Crop tool

Crop tool

To import a piece of clip art:
1. Choose the pointer tool, and from the

Insert menu, choose Picture.

2. In the Picture box, under Files Of
Type, choose the type of file you want
to import.

3. Under Look In, locate and choose the
file you want to import, then click
Open.

➊

➋

➌
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P R I N T I N G  D I A G R A M S

Unless you reduce or enlarge a diagram
before you print, the size of the final Visio
diagram will match the size of the drawing
page. Large diagrams, therefore, print
across several sheets of regular-sized
printer paper. Small diagrams print on
part of a page.

Visio never crops a diagram to fit within
the margins. You can, however, center a
diagram, reduce or enlarge it before you
print, or force it to fit on one or more
printed pages.

To make sure you’ll get the printed results
you expect, preview a diagram before you
print.

For related information:
Setting Up a Diagram ............................ 202

See online Help: press F1, click Search,
click Index, then type “printing.”

Ipsum

Lo
re

m

Ipsum

Lo
re

m

Tile area for
upper-left corner

Overlap

Tile area for
lower-left corner

A flowchart on an 297 x 420 mm drawing page will print across
several 210 x 297 mm sheets of printer paper.

By default, a small diagram prints in the upper left corner of an
210 x 297 mm printer page. By changing the margin settings, you
can change where the diagram prints.
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To preview how a diagram will print:
1. From the File menu, choose Print

Preview.

2. In the Print Preview window, preview
how the drawing fits within the
margins or prints across several pages.

3. Click Close to return to the drawing
window.

Print Preview options

A Click to see individual printer pages,
also called tiles.

B Click to see the entire drawing page
divided into tiles by gray borders.

C Click to move to the last tile.

D Click to move to the next tile.

E Click to move to the previous tile.

F Click to move to the first tile.

D C B AEF

More Ø

➊

➋

➌
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To set margins:
1. From the File menu, choose Page

Setup.

2. In the Page Setup box, under Margins,
type the margin settings you want.

➊

To reduce or enlarge a diagram:
1. From the File menu, choose Page

Setup.

2. In the Page Setup box, under Reduce/
Enlarge, check Scale, then enter the
percent you want the diagram to scale,
or check Fit On, then choose the
number of pages across and down on
which you want your diagram to print.

➋

➊

➋
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To force a diagram to fit on a page:
1. From the Edit menu, choose Drawing

Page, then choose Size & Scale.

2. In the Drawing Size/Scale box, under
Drawing Size, check Fit Page To
Drawing Contents, then click OK.

3. From the File menu, choose Page
Setup.

4. In the Page Setup box, under Reduce/
Enlarge, check Fit On, then click OK.

➌

To print a diagram:
1. From the File menu, choose Print.

2. In the Print box, choose the options
you want, then click OK.

➊ ➋

➍

➋➊
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S E T T I N G  U P  A  D I A G R A M

When you open a Visio template for a
particular type of diagram, the drawing
page is already set up. You’ll only need to
change the settings if your diagram will be
an unusual size or if you want to set a
particular drawing scale.

It is important, however, to choose printer
settings, including printer paper size and
orientation. Be sure the orientation of the
printer page matches the orientation of
the drawing page.

While the printer page size and the
drawing page size don’t have to be the
same, there is a relationship between
them. For example, you might want to
draw a 420 x 297 mm flowchart, so that
would be the size of your drawing page.
Your printer, however, might accept only
210 x 297 mm sheets, so that would be
the printed page size. The drawing would
print, or tile, across two sheets of printer
paper.

You can set the final Visio diagram size to
equal the size of a rectangle that tightly
encloses the shapes on the page. This
feature is particularly useful when you
want to include Visio diagrams in other
documents, such as PowerPoint presenta-
tions or Microsoft Word reports. By tightly
enclosing a diagram, you eliminate extra
white space around its edges.

For related information:
Printing Diagrams ................................... 198

See online Help: press F1, click Search,
click Index, then type “pages: setting up.”

The rulers and drawing page you see in the drawing window reflect the Visio
drawing page settings.

Printer paper and drawing page size are not always the same. For example,
an 297 x 420 mm flowchart will print across several 210 x 297 mm sheets
of printer paper.

If you change the drawing page settings, you’ll also need to change the
printer page settings or your printed results may not be what you expect.
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To set up the printed page:
1. From the File menu, choose Page

Setup.

2. In the Page Setup box, choose the
printed page size and orientation
options you want, then click OK. Use
the display at the top of the box to
see the effect of your choices.

➊ ➋

More ➤
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To set up the drawing page:
1. From the Edit menu, choose Drawing

Page, then choose Size & Scale.

2. In the Drawing Size/Scale box, under
Drawing Size, choose the options you
want, then click OK.

Drawing Size/Scale Options

A Check to make the drawing page size
and orientation settings match the
printed page settings. In most
templates, this option is checked by
default.

B Check to choose a standard size for
the final Visio diagram, then choose
the size you want from the list.

C Check to enter custom dimensions for
the final Visio diagram, then enter the
dimensions you want.

D Check to make the final Visio diagram
size equal to the size of a rectangle
that tightly encloses the shapes on it.

E If you’re drawing to scale, check to
enter custom scale dimensions for the
final drawing size.

➊

➋

A
B

C

D
E



Using Visio with Other Programs

For an overview of which methods to use when moving information
between Visio and other programs, turn to Placing Visio Information
or Placing Information in Visio.

Consult the documentation for programs you want to use with Visio,
they don’t all move information the same way.

Topics in this chapter

Placing Visio Information ................................................................ 206
To copy and paste selected Visio shapes ..................................... 208
To copy and paste an entire Visio diagram ................................. 208
To create a Visio diagram within another program ................... 209
To link a Visio file to another document .................................... 210
To export a Visio file into another format .................................. 211
Export Visio files to these formats .............................................. 211

Placing Information in Visio ............................................................ 212
To copy and paste outside information in a Visio diagram ....... 214
To copy and paste other information in a particular format .... 215
To create an object in another program from within Visio ....... 216
To link an outside file to a Visio document ................................ 217
Managing links between Visio and other files ............................ 218
To edit a link................................................................................. 219
To manually update a link ........................................................... 219
To import a file into a Visio drawing .......................................... 220
File formats Visio imports if you

install all the available import filters ...................................... 221
To open selected file formats from within Visio ........................ 221
File formats you can open from within Visio ............................. 221
Modifying objects placed in Visio ............................................... 222
Modifying outside objects ........................................................... 223

Using the Binder ............................................................................... 224
To include a Visio document in the Microsoft Binder ............... 225
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P L A C I N G  V I S I O  I N F O R M A T I O N
When you want to include Visio
shapes or diagrams in other
documents, you can choose among
several methods. For example, you
can paste a Visio flowchart in a
PowerPoint presentation or link an
office layout to a Word report. See
the chart on the following page for
help in choosing a method.

Copying and pasting

Creating Visio diagrams from
within other programs

Linking Visio files

Exporting Visio shapes and diagrams into a
format other programs can use



U S I N G   V I S I O   W I T H   O T H E R   P R O G R A M S  207

To Do this Conditions Advantages

Place a Visio shape into Copy and Paste. The other program must Almost all programs support
another document. See procedure on page 208. support the Windows Clipboard. copy and paste.

Be able to edit a Visio shape Copy and Paste. The other program must You can edit the Visio diagram
or diagram you’ve placed into See procedure on page 208. support the Windows Clipboard without leaving the other
another document. and Object Linking and program. Move the document

Embedding (OLE). file to another system without
also moving the Visio file.

Include a Visio shape or Create a Visio diagram within The other program must Create a diagram without
diagram in another document another program. support in-place editing or leaving the program where
where you’re currently working. See procedure on page 209. editing-in-context and Object you’re currently working.

Linking and Embedding (OLE).

Place a Visio diagram that you Link the Visio file The other program must When you update the original
update frequently into another See procedure on page 210. support Object Linking and Visio diagram, changes appear

Embedding (OLE). If you move in the other document. The
the document to another entire Visio file is not included
system, you must also move in the other document, so the
the Visio file. file size remains relatively small.

Place a Visio diagram you Link the Visio file. The other programs must When you update the original
update frequently in several See procedure on page 210. support Object Linking and Visio diagram, changes appear
different documents. Embedding (OLE). If you move in all the other documents.

any of the document files to The entire Visio file is not
another system, you must also included in the other documents,
move the Visio file. so file size remains relatively

small.

Convert a Visio diagram to Export the Visio file. You must have the appropriate Convert a Visio diagram into a
another file format to import See procedure on page 211. Visio export filters installed. format you can open in
it into another document. another program. Allows you to

share Visio diagrams with people
who don’t have Visio.

For related information, see online Help:
press F1, click Search, click Index, then
type “copying, “embedding,” “linking,” or
“exporting.”

More Ø
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To copy and paste selected Visio shapes:
1. In Visio, select the shapes you want to

paste.

2. From the Edit menu, choose Copy.

3. In the document where you want to
paste the shapes, from the Edit menu,
choose Paste (or the equivalent
command).

Tip: You can also copy and paste Visio
information by dragging and dropping it
into another file (as long as the file’s
program supports OLE 2). Display the Visio
and destination files side by side. Select
the Visio shapes you want to copy, hold
down the CTRL key, and drag the shapes
into the destination file.

N

5

520

90

   Sit amet, consectetuer adipiscing
elit, sed diam nonummy nibh.
Euismod tincidunt ut laoreet dolore
magna aliquam erat volutpat.
   Ut wisi enim ad minim veniam,
quis nostrud exerci tation
allamcorper susipit lobortis nisl ut
aliquip ex ea commodo consequat.
Duis autem vel eumiriure dolor in
hendrerit in vulputate velit esse
molestie consequat.

Facilisis at vero
eros et accumsan
et iusto odio
dignissim.

Duis autem
vel eumiriure
dolor in
hendrerit.

Euismod
susipit nisl
ut aliquip.

 Duis autem vel eumiriure
esse molestie consequat.

Eccumsan
et iusto odio.

To copy and paste an entire Visio diagram:
1. In Visio, make sure nothing is selected.

2. From the Edit menu, choose Copy
Drawing.

3. Copy Drawing copies the entire
document, including shapes on
background pages and on foreground
pages other than the current one.

4. In the document where you want to
paste the diagram, from the Edit
menu, choose Paste (or the equivalent
command).

Tip: Even though Copy Drawing copies all
the shapes in a Visio diagram, in the
document where you paste the diagram,
you’ll only see the shapes on the displayed
foreground page and its backgrounds.

➊ ➋

➌

➊ ➋

➌ ➍
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To create a Visio diagram within another program:
1. In the document created in the other

program, choose Insert Object (or the
equivalent command) from the
appropriate menu.

2. In the Insert Object (or equivalent)
box, click the option for creating a
new file, under Object Type, choose
Visio Drawing, then click OK.

3. In the Visio New box, select a template
for the type of drawing you want to
create.

4. Create the Visio diagram.

5. If Visio is running in its own window,
shut it down. If it’s running within the
outside document, click somewhere in
the document outside the Visio
diagram.

6. To edit the Visio diagram from within
the outside document, double-click the
diagram.

Tip: You can also paste or link an
existing Visio drawing from within another
program. In the program’s Insert Object
(or equivalent) box, click the option for
creating an object from an existing file,
locate the Visio file, and paste or link it.

More Ø

➊

➋

➌
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To link a Visio file to another document:
1. In Visio, save the file you want to

link.

2. To link the entire diagram, make sure
nothing is selected. To link a specific
shape, select that shape. To link
several shapes, select the shapes and
group them.

3. Choose Copy Drawing (or Copy, if
you’re linking selected shapes), and
leave Visio running. Copy Drawing
copies the entire document, including
shapes on background pages and on
foreground pages other than the
current one.

4. In the other document, from the Edit
menu, choose the command to link a
file.

Tip: You can also link a Visio file by
dragging and dropping it into another file
(as long as the destination file supports
OLE 2). Display the Visio and destination
files side by side. Select the shapes you
want to link, hold down the CTRL and
SHIFT keys, and drag the shapes to the
destination file.

46 %

21 %

19 %

14 %

Lorem

Lorem
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➊ ➋
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To export a Visio file into another format:
1. In Visio, select the shapes you want to

export. If no shapes are selected, Visio
exports a rectangular area just large
enough to hold all the shapes on the
current page.

2. From the File menu, choose Save As.

3. In the Save As box, choose the format
you want, type a name for the
exported file, then click OK.

Tip: To export (or paste or link) an area
around a Visio drawing, in Visio, draw a
rectangle around the area you want to
export, paste, or link. Choose a fill style of
None. If you don’t want a border, choose
a line style of None. From the Shape
menu, choose Send To Back. Then, follow
the steps for exporting, pasting, or linking.

Export Visio files to these formats:

Adobe Illustrator (.AI) Windows Metafile (.WMF)

Computer Graphics Metafile (.CGM) Initial Graphics Exchange Specification (.IGS)

Encapsulated PostScript File (.EPS) ZSoft PC Paintbrush Bitmap (.PCX)

Macintosh PICT format (.PCT)

Tag Image File Format (.TIF)

Windows Bitmap (.BMP or DIB)

100%
90%

80%
70%

➊ ➋
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P L A C I N G  I N F O R M A T I O N  I N  V I S I O

Opening other file types from within Visio
Importing outside information into Visio files

When you want to include objects
created in other programs in Visio
diagrams, you can choose among
several methods. For example, you
can paste a logo into a directional
map you create in Visio or link an
Excel spreadsheet to a Visio
organization chart.

Creating outside information
from within Visio

Linking outside files to diagrams

Copying and pasting
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To Do this Conditions Advantages

Place an outside object into Copy and Paste. The other program must Almost all programs support
a Visio diagram. See procedure on page 214. support the Windows Clipboard. copy and paste.

Be able to edit an outside Copy and Paste. The object’s program must You can edit the outside object
object you’ve placed into a See procedure on page 214. support the Windows Clipboard without leaving Visio. You can
Visio diagram. and Object Linking and move the Visio file to another

Embedding (OLE). system without also moving the
outside file.

Include an outside object in a Create an outside object from The other program must You don’t have to exit or close
Visio file where you’re within Visio. support Object Linking and Visio to create the outside
currently working. See procedure on page 216. Embedding (OLE). object.

Place an outside object that Link the outside object’s file. The object’s program must When you update the original
you update frequently in a See procedure on page 217. support Object Linking and file, changes appear in the
Visio diagram. Embedding (OLE). Visio file. The entire original

file is not included in Visio, so
file size remains relatively small.

Place an outside object you Link the outside object’s file. The other program must When you update the original
update frequently into a Visio See procedure on page 217. support Object Linking and file, changes appear in the
diagram and into several other Embedding (OLE). copies in Visio and other
documents. documents. The entire original

file is not included in Visio, so
file size remains relatively small.

Bring files saved in a variety Import the outside file. You must have the appropriate You can bring objects into Visio
of formats into Visio. Open files created in other Visio import filters installed. that were created in programs

programs from within Visio. Only certain types of files can you don’t have access to.
See procedures on page 220. be opened from within Visio. You can bring objects into Visio

even if the programs that
created them don’t support
Object Linking and Embedding
(OLE).

For related information:
Modifying Objects Placed in Visio ............ 222

See online Help: press F1, click Search,
click Index, then type “copying,”
“embedding,” “linking,” or importing.”

More Ø
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To copy and paste outside information in a Visio diagram:
1. In the outside document, select and

copy the information you want to
paste.

2. In Visio, display the diagram where you
want the information pasted.

3. From the Edit menu, choose Paste.

4. To edit the information from within
Visio, double-click it.

Tip: If nothing happens when you
double-click the information you’ve pasted,
it means the outside application doesn’t
support OLE.

➊

➋

➌

➍
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To copy and paste outside information in a particular format:
1. In the outside document, select and

copy the information you want to
paste.

2. In Visio, display the diagram where you
want the information pasted.

3. From the Edit menu, choose Paste
Special.

4. In the Paste Special box, click Paste,
choose the particular format you want,
then click OK.

Tip: You can also paste outside
information by dragging and dropping it
into a Visio file (as long as the outside
information’s program supports OLE 2).
Display the outside and Visio file side by
side. Select the information you want to
paste, hold down the CTRL key, and drag
the information into the Visio file.

More Ø

➊

➋ ➌

➍
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To create an object in another program from within Visio:
1. From the Insert menu, choose Object.

2. In the Insert Object box, check Create
New.

3. From the Object Type list, choose the
type of object you want to create, then
click OK.

4. Create the object you want.

5. From the File menu in the object’s
program, choose Exit to return to
Visio. The object is embedded in the
Visio diagram.

Tip: You can also embed or link an
existing object created in another program
from within a Visio diagram. From the
Visio Insert menu, choose Object. In the
Insert Object box, click Create From File,
click Link if you want to link the file, then
type the path and filename for the file you
want to embed or link.

For related information, see online Help:
press F1, click Search, click Find, then type
“creating objects.”

➊ ➋

➌

➍
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To link an outside file to a Visio document:
1. Save the outside file.

2. In the outside file, select the
information you want to link.

3. Choose the command used by the
outside file’s program to place
information on the Clipboard. (The
command is usually Copy on the Edit
menu.)

4. In Visio, from the Edit menu, choose
Paste Special.

5. In the Paste Special box, check Paste
Link, then click OK.

6. To edit the linked information from
within Visio, double-click it.

Tip: You can also link an outside file by
dragging and dropping it into a Visio file
(as long as the outside file’s program
supports OLE 2). Display the outside and
Visio files side by side. Select the
information you want to link, hold down
the CTRL and SHIFT keys, and drag the
information into the Visio file.

For related information:
Managing Links
Between Visio and other files ................ 218

More Ø

�

➊ ➋

➌ ➍
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Managing links between Visio and other files
Links consist of information about where to
find linked files. For example, a link to an
Excel file for a spreadsheet included in a
Visio drawing might be
C:\PROJECTS\BUDGETS\3RDQTR.XLS. If you
rename, move, or delete the Excel file,
Visio still tries to follow the link but can’t.

To allow Visio to find linked files, you
must keep links up to date. From within
Visio, you can view, change, or break links.
You can also decide whether to update
linked information in Visio files automati-
cally or manually.

Links Management

A Choose the link you want to change.

B Lists the path, filename, and type of
file for the link chosen in A.

C Click Automatic to automatically update
linked information when you open the
Visio file. Click Manual to update linked
information by opening the Links box
and clicking Update Now.

D Click to break the chosen link. Visio
converts the linked object to a
Windows Metafile.

E Click to change the path and filename
to another file of the same format.

F Click to open the linked file.

G Click to manually update the linked
information in the Visio file.

For related information, see online Help:
press F1, click Search, click Index, then
type “managing links.”

A

B

C

G
F
E

D
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To edit a link:
1. From the Edit menu, choose Links.

2. In the Links box, under Links, choose
the link you want to change.

3. Choose options to make the changes
you want, then click Close.

To manually update a link:
1. Update the linked file, then save it.

2. In Visio, choose Links from the Edit
menu.

3. In the Links box, under Links, choose
the link you want to update.

4. Click Update Now, then click Close.

More Ø

➊

➋

➌

➋

➌
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A
B
C

D
E

F
GH

To import a file into a Visio drawing:
1. From the Insert menu, choose Picture.

2. In the Picture box, choose the File
Type you want to import, and locate
the drive and folder containing the file.

3. From the File Name list, choose the
file you want, then click OK.

4. If the EPS Import box appears, choose
the import options you want, and then
click OK.

EPS Import Options

A Click to retain gradient fills.

B Click to have Visio create a rectangle
similar in color to the background in
the original program.

C Draws thick or patterned lines as
polygons rather than using the line
style and width capabilities of the
display or printer driver.

D Uses color exactly as specified in the
original file.

E Inverts all colors to create a
photographic negative effect.

F Inverts only black, white, and grays.

G Converts all colors to shades of gray.

H Converts all colors to shades of gray
then inverts them.

➊

➋

➌
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More Ø

File formats you can open from within Visio:

ABC FlowCharter 2.0, 3.0, 4.0 (*.AF3, *.AF2) Macintosh PICT Format (*.PCT)

CorelFLOW 2.0 (*.CFL) Tag Image File Format (*.TIF)

Adobe Illustrator (*.AI) Windows Bitmap (*.BMP, *.DIB)

Computer Graphics Metafile (*.CGM) Windows Metafile (*.WMF)

Encapsulated Postscript File (*.EPS) ZSoft PC Paintbrush Bitmap (*.PCX)

Enhanced Metafile (*.EMF)

File formats Visio imports if you install all the available import filters:

Adobe Illustrator (.AI) Windows Metafile (.WMF)

Computer Graphics Metafile (.CGM) ZSoft PC Paintbrush Bitmap (.PCX)

Encapsulated PostScript File (.EPS) CorelDraw! 3.0, 4.0, 5.0 (.CDR)

Macintosh PICT format (.PCT) Micrografx Designer

Tag Image File Format (.TIF) Initial Graphics Exchange Specification (.IGS)

Windows bitmap (.BMP or DIB)

To open selected file formats from within Visio:
1. In Visio, from the File menu, choose

Open.

2. In the Open box, under Files Of
Type, choose the type of file you
want to open, then locate the drive
and folder that contains the file.

3. From the File Name list, choose the
file you want, then click OK.

4. In the Conversion Options box,
choose the options you want, then
click OK.

➊

➋

➌
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Sizing an object

Panning an object

Modifying objects placed in Visio
While you can’t rotate, flip, or add text to
embedded, linked, and imported objects in
Visio, you can:

• Size, crop, and pan them.

• Change the line style and color of the
area between the object and its
borders.

• Convert some outside objects to other
file formats or to Visio shapes.

If you convert a linked object to a Visio
shape, you break the link between the
object and its original file. Edits to the
original file will no longer affect the object
in Visio.

Any file you import, except a bitmap, is
converted to a Windows Metafile in Visio.
Bitmaps are imported as bitmaps.

For related information:
Using Clip Art in Visio Diagrams .............. 196

See online Help: press F1, click Search,
click Find, then type “editing an object.”

Change the line style of an object’s border and
the color of the area between the object and the
border.
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More Ø

Modifying Outside Objects
To Use this tool Do this

Size or change the dimensions Pointer tool Select the object. Drag a side or corner selection
of an object handle until the object is the size you want.

Crop an object Cropping tool Select the object. Drag a selection handle until the
object’s borders are the size you want. Visio doesn’t
delete the part of the object you crop so you can
recrop if you want.

Pan or reposition an object Cropping tool Select the object. Point inside the object and press the
within its borders left mouse button. Drag until the object is positioned

the way you want.

Format the line and fill of the area Pointer tool Select the object. From the Format menu, choose Line
between an object and its borders or Fill, then choose the formatting options you want.

Convert an OLE object to another format Pointer tool Select the object. From the Edit menu, choose the
command provided by the OLE object’s original
program for converting to other formats. (The
command is usually Convert.)

Display an OLE object as an icon Pointer tool Select the object. From the Edit menu, choose the
command provided by the OLE object’s original
program for displaying as an icon. (The command is
usually Display As Icon.)

Convert an object to a Pointer tool Select the object. From the Shape menu, choose
grouped Visio shape Grouping, then choose Convert To Group.

Convert an object to several Pointer tool Select the object. From the Shape menu, choose
individual shapes Grouping, then choose Ungroup.
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U S I N G  T H E  B I N D E R

Use the Microsoft Binder when you want to
include a Visio document in a report or
presentation that also includes other
documents, such as Word files, Excel
spreadsheets, or PowerPoint slides.

Once all the related documents are
gathered into the Binder, you can work on
them as a group. For example, you can
check the spelling of all the documents at
once and assign consecutive page numbers
for the whole report. At the same time,
you have the option of working on any
one of the documents individually.

You can print an entire binder or one document in a binder.
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To include a Visio document in the Microsoft Binder:
1. In Windows 95, from the Start menu,

choose Programs, then choose Microsoft
Binder.

2. Drag the Visio diagram you want to
add into the left pane of the Binder
window.

3. From the Binder File menu, choose
Save Binder As to save the Binder file.

4. For information about how to work
with documents in a Binder, see
Microsoft Binder Help.

Tip: You can also add a blank Visio
diagram to the Binder. From the Binder
Section menu, choose Add, choose Visio
Drawing from the list, then click OK.

➊

➋

➌





Working Efficiently in Visio

Use these techniques to speed up the process of creating diagrams
and make it easier to update and revise your work.

Preview your diagrams before you open them

In the Windows 95 Explorer, right-click a file icon, then choose
Quick View from the shortcut menu.

For related information:
Previewing Diagrams ............................................... 36

Make your diagrams easier to track and find

Fill out the fields in the Properties box when you save your file for the
first time. The description information appears at the bottom of the
Open box.

For related information:
Saving Visio Files ...................................................... 44

Get information about shapes when you need it

Right-click a shape on the stencil or on the drawing page, then
choose Shape Help from the shortcut menu.

Quickly change shape appearance, associate data with shapes, or
run special Wizards

In most Visio templates you can right-click the drawing page or a
shape and choose an option from a shortcut menu.
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Speed up tasks you do frequently

Learn the keyboard shortcuts for tasks, such as zooming and dupli-
cating shapes, that you perform often .

For related information, see online Help: click Contents, double-
click Reference, double-click Keyboard Shortcuts, then double-click
Command shortcuts.

Experiment with your diagrams without being afraid of ruining
them

Remember the Undo command on the Edit menu. Since Visio sup-
ports ten undos, you can try several variations and then undo them
all to return to your original diagram.

For related information, see online Help: click Search, click Index,
then type “undo.”

Use guides to align shapes and move several shapes at once

Drag guides onto the drawing page and glue shapes, such as a row of
plants in an office plan, to them. When you move the guide, you’ll
also move all the shapes.

For related information:
Snapping and Gluing Shapes ................................... 30
Positioning Shapes on the Page ............................... 92

Make one set of changes that affects several shapes at once

Shift-click shapes or drag a selection net around them to select and
edit several shapes at once.

For related information:
Dragging and Dropping Shapes .............................. 26
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Move a group of shapes without changing their relationships to one
another

Shift-click shapes or drag a selection net around them to select sev-
eral shapes at once.

For related information:
Dragging and Dropping Shapes .............................. 26

Make it easier to work on shapes you use together regularly

Group related shapes into one composite shape. Once shapes are
grouped, you can edit them all at the same time or subselect indi-
vidual shapes and edit them individually.

For related information:
Grouping and Ungrouping Shapes ......................... 96

Change the way several shapes look or behave without having to
change each shape individually

Create a style that includes line, fill, and text formatting, then apply
that style to as many shapes as you want. If you revise the style, you’ll
also change all the shapes that use the style.

For related information:
Formatting Shapes with Styles ................................ 122

Make changes to a master shape on the drawing file stencil. Changes
you make to the master are reflected in every instance of that master
you’ve used in your diagram.

For related information:
Creating and Editing Stencils .................................. 114
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Work on one category of shapes, such as the chairs in an office lay-
out, without being distracted by the other shapes in your diagram

Place each category of shapes on a separate layer. Then, you can view,
edit, and print each category separately.

For related information:
Placing Information on Layers ................................ 64

Turn a shape you’ve modified or created from scratch into a master
shape on a stencil

If you use a shape a lot, it’s best to make it a master shape. Then, you
can drag and drop it whenever you need to use it. You can create your
own shapes and stencils or modify one of the stencils that comes with
Visio.

For related information:
Creating and Editing Stencils .................................. 114

Quickly edit text in a diagram

Using Visio’s Spell-checker and Find/Replace commands, you can
spell-check and find/replace independent text, text in shapes, text on
stencils, text in data fields, and the text you entered in the Properties
box.

For related information:
Finding and Correcting Text .................................... 160

Make shapes you draw yourself easier to modify

With the pencil tool, you can add vertexes to shapes you draw using
Visio’s drawing tools. Since you can drag vertexes to change the way
shapes look, the more vertexes you add, the more finely you can con-
trol shape appearance.

For related information:
Drawing Your Own shapes ...................................... 138
Editing shapes ........................................................... 136
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Set up your diagrams to generate reports, such as inventories or
cost comparisons

In Visio, you can associate the shapes you use in a diagram with
properties. For example, in a network diagram, you can associate
each shape with a serial number. Or, in a flowchart, you can associate
each process with cost, duration, and resources information. Once
shapes have properties, you can easily generate informational or
mathematical reports.

For related information:
Associating Properties with Shapes ......................... 74
Generating Numerical Reports ............................... 47
Take an Inventory of Your Diagram ........................ 69

Build special behavior into shapes to make them easier and more
convenient to use

Using Visio’s SmartShape Wizard, you can easily change the way
shapes behave. For example, you can control the way parts of a shape
expand when the whole shape is stretched or change the way a
shape’s text block expands when you enter text.

For related information:
Making Shapes Smarter ........................................... 100

Prepare your diagram to incorporate it into another document

You can set Visio drawing size to equal the size of rectangle that
tightly encloses the shapes on the drawing page. That way, when you
paste the diagram into another document, you eliminate extra white
space around its edges.

For related information:
Setting Up a Diagram............................................... 202

Plan ahead with Visio diagrams you intend to present in a slideshow

Slides usually have dark backgrounds so shapes included on slides
show up better when the shapes have dark background and light-col-
ored text.





Index
3-D arrow shapes  81
3-D block and perspective

block diagrams  80, 82, 98–99
3-D shapes  82, 83, 98–99
4-headed arrow shapes  81

A
ABC FlowCharter  221
Activating layers  65
Add User Dictionary box  161, 163
Add-ons

GraphMaker  193, 195
Link To Doc add-on  8, 39, 40
Link To Page add-on  8, 39, 40
Property Reporter  47
Region add-on  142
SmartShape Wizard  75, 100
Stencil Report Wizard  48

Adobe Illustrator files  211, 221
.AF2 or .AF3 files  221
.AI files  211, 221
Align Shapes box  95
Aligning shapes

guides  228
lining up copies  27
positioning on pages  92, 93, 95
primary selected shape  26
stacked shapes  194–195
vanishing points  82

Aligning tabs  156
Aligning text  168, 170–171
Angles in shapes  136–137
Angles of eccentricity (arc symmetry)  136–137
Angles of rotation  140, 167

Annotations, attaching to shapes  8, 38–41
Applications

attaching to shapes  8, 38–41
using Visio with other programs  205–225

Applying styles  122, 229
Arc tool  138
Architectural drawing scales  60
Arcs  136–137, 138
Arrange To Page command  142
Arrow shapes  81
Assigning background pages  63
Assigning properties to shapes  8, 69, 74–75
Assigning shapes to layers  58, 64–67, 97
Associating shapes with data  8, 69, 74–75
Attaching

files to other documents  208, 224–225
properties to shapes  8, 69, 74–75
shapes to pages or files  8, 38–41
shapes together. See Gluing shapes
text to shapes  170–171

Automatically updating objects  218
Automatically updating text  164–167
Auto-size Box shapes  89
Axes on charts  182, 187, 188

B
Background colors

shapes  149
slides  231
text  169, 170–171

Background pages
adding and assigning  62–63
displaying page information  167
numbering pages  164
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Bar charts  181–185, 192–195
Bar Graph shapes  182
Baseline position of text  169
Behavior

adding to shapes  230
resizing shapes in groups  97
SmartShapes  100

Big Cloud shapes  88
Big pictures

charts  174–175
connected diagrams  2–3
directional maps  126–127
forms  144–145
office planning  50–51
project timelines  104–105
relationship diagrams  78–79

Bills of materials  69
Binding drawings

with other documents  208, 224–225
Bitmaps  211, 221, 222–223
Black and white in imported graphics  220
Blank drawings  42–43, 202–204, 225
Blank stencils  114, 117
Block Diagram template  80
Block diagrams  78–79, 80–85
Block shapes  83
.BMP files  211, 221
Bold button  120, 168
Bottom align button  120, 168
Bows of arcs (curvature)  137
Brainstorming maps

(mind maps)  78–79, 86–91
Branch diagrams  82, 88
Branches in organization charts  20
Breaking apart shapes  134–135
Breaking dependencies in timelines  108
Breaking links to files  218, 222
Bring Forward command  29
Bring To Front command  28
Bubble shapes  89
Building regional maps  142
Building shapes  130
Bulleted lists  156, 158
Bullets  157

Bundling drawings
with other documents  208, 224–225

Bus shapes  12
Business forms  143–155

big picture  144–145
fax cover sheets  151–155
invoices  146–150
setting tabs  156–159

Buttons
drawing tools  138–139
shape formatting buttons  120–121
text formatting buttons  168

C
Calculating numbers of shapes  47, 73
Callout shapes  178
Canceling background assignments  63
Canceling selections  28
Captions  171, 178
Case of text  169
Cataloging drawings  69–73
Cataloging stencils  48
Categorizing shapes on layers  229
Cause and effect diagrams  22–25
Cause shapes  23
.CDR files  221
Center align button  120, 168
Center-aligned tabs  156
Centers of rotation  140
Central images

block diagrams  81
mind maps  87

.CFL files  221

.CGM files  211, 221
Character formatting  168
Characters

formatting  168
text delimiters and separators  72

Chart stencil  192
Chart template  176, 181, 186
Charts  173–191

bar charts  181–185
big picture  174–175
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Charts (continued)
clip art  196–197
connecting shapes  32, 33
creating  42–43
flowcharts  4–9
grid lines  189
line charts  186–191
organization charts  16–21
pie charts  176–180
scales  182, 187
special effects  192–195

Checking spelling  160–163, 230
Circle shapes  138–139, 139
City shapes  14
Clearance in office plans  101
Clip art  142, 196–197
Clipboard  69, 72–73
Closing

ends of block shapes  84
shapes  139
stencils  113

Cloud shapes  14, 88
Cluster diagrams (mind maps)  78–79, 86–91
Color

background color of text  169, 170–171
backgrounds of shapes or forms  149
fill color button  120
ideas in mind maps  89
imported pictures or objects  220, 222–223
layers  65, 90
line color  89
slides  231
text characters  168

Column charts  192, 194–195
Column Header shapes  183
Columns

forms  148
numbers in tables  156
reports  72

Combine command  134
Combining drawings

with other documents  224–225
Combining shapes  96–97, 134–135
Comma-delimited timeline data  106

Computer Graphics Metafiles  211, 221
Computer shapes  12
Concept maps (mind maps)  78–79, 86–91
Connect Shapes command  33
Connected diagrams  1–25

cause and effect diagrams  22–25
flowcharts  4–9
network diagrams  10–15
organization charts  16–21

Connecting shapes  32–35
connection points  32, 33, 34
connectors  6
control handles  12, 33
moving connections  8
snapping and gluing  30–31

Connection points  34, 100
Connector tool  33
Connectors  6, 32, 33
Consistent looks for shapes  122
Constraining shapes while drawing  139
Continental maps  142
Control handles  101

bar chart shapes  183
connecting shapes  12, 33
smart shapes  100

Control points  136–137
Conversion Options box  221
Convert To Group command  197, 223
Converting

clip art to shapes  196–197
objects to metafiles  222–223
other file formats to Visio  221
point-to-point connections to dynamic  35
Visio drawings to other formats  207, 211

Copies of stencils  116
Copy command  208, 210
Copy Drawing command  208, 210
Copying

bar chart shapes  194
formatting  120–121
outside information into Visio  212–223
shapes  27, 172
Visio drawings

into other files  9, 207, 208, 210, 231
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CorelDRAW files  221
CorelFLOW files  221
Costs

assigning to shapes  74
calculating  47

Counting numbers of shapes  47, 73
Country maps  142
Cover sheets  151–155
Creating

layers  66
master shapes  114, 117, 229
new drawings  42–43
objects within Visio  216
shapes  138–139
stencils  114, 117
styles  123
user dictionaries  163

Creation dates  165
Creators of files  44, 167
Crop tool  197, 223
Cropping  196–197, 222–223
Cubicles in office plans  56
Current time or date  167
Curvature of arcs  137
Curves

changing arcs  136–137
drawing  138
road shapes  132

Custom drawing scales  60
Custom Formula fields  167
Custom properties  74
Custom Properties box  8, 19, 75
Cutting apart shapes  134–135

pie charts  177
stretchable chart shapes  194

D
Data

associating shapes with data  8, 69, 74–75
attaching annotations or files  8, 38–41
calculating shape data  47
displaying in fields  167
reading from spreadsheets  107

Data fields in reports  70–71, 164–167. See also
Fields

Data Point shapes  189
Dates

changing in timelines  108
displaying on drawings  165, 167
project timeline data  106

Date/Time fields  165, 167
Decimal-aligned tabs  156
Decrease font size button  120
Default layers  65
Define Styles box  123
Deleting

background pages  62
connection points  34
layers  65, 67
pages  119
segments from shapes  136–137
shapes from groups  96–97
shapes on layers  65
styles  123
tabs  157
text in groups  153
timeline tasks  110

Delimiter characters  72
Departments in organization charts  20
Dependency fields  106
Dependency shapes  108
Depth perspective  84, 99
Descriptions of files  44, 167
Desks in office plans  56
Detaching stencils  113
Diagrams

3-D perspective diagrams  98–99
block diagrams  80–85
cause and effect diagrams  22–25
clip art  196–197
connected diagrams  1–25
connecting shapes  32, 33
mind maps  86–91
network diagrams  10–15
printing  198–201
project timelines  103–111
relationship diagrams  77–91
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Diagrams (continued)
setting up pages  202–204
space planning  49–59
starting drawings  42–43

.DIB files  211, 221
Dictionaries  160, 161, 163
Dimension fields in shapes  166
Dimension lines on shapes  30, 68
Dimensions

drawing to scale  60–61
measurements for office plans  52
page measurements  202–204
shape measurements  30, 68, 166

Direction shapes  130
Directional indicators  130
Directional maps  125–133
Directions on maps  130–131
Display As Icon command  223
Displaying

3-D shape appearance  99
annotations or attached documents  41
document information on pages  44
foreground and background pages  63
icons on stencils  113, 116
imported objects as icons  223
multiple pages  119
page breaks for printing  199
reports  69, 72–73
statistics on layered shapes  65

Distances for tabs  156
Distribute Shapes box  94
Distributing shapes  94
Dividing org charts into departments  20
Docking stencils  113
Document Info fields  167
Document property information  44, 45
Documents. See Files
Doors in office plans  52, 55
Dragging

connectors  33
control handles  33, 101
selecting shapes by dragging  28
shapes into drawings  6

Dragging and dropping
drawing into other files  208, 210
information into Visio  215, 217
shapes into drawings  6, 26

Drawers on furniture shapes  101
Drawing

adding vertices to shapes  230
dragging and dropping shapes  26
freeform shapes  138–139
reshaping shapes  136–137

Drawing file stencils  114–115
Drawing pages. See Pages
Drawing scale  53–54, 60–61, 142
Drawing size  198, 202–204
Drawing Size/Scale box  61, 201, 204
Drawings

adding clip art  196–197
adding pages  118
adding shapes  26
attaching to other documents  224–225
changing drawing appearance  19
creating integrated documents  205–225
dating  165
drawing file stencils  114–115
drawing scale  53–54, 60–61
fitting onto pages  198, 200–201
identifying easily  227
inventorying shapes  48, 69–73, 230
layers  62–67
placing into other files  9, 206–211
placing outside

information into Visio  212–223
previewing files  36, 44, 227
previewing printouts  199
printing  9, 198–201
saving  9, 44–46
saving previews  44
setting up for reports  230
setting up pages  202–204
size  198, 202–204
starting  42–43
streamlining work  227–231
types of drawings

cause and effect diagrams  22–25
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Drawings (continued)
types of drawings (continued)

charts  173–191
connected diagrams  2–3
directional maps  125–133
flowcharts  4–9
forms  143–155
network diagrams  10–15
office plans  49–59
organization charts  16–21
project timelines  103–111
relationship diagrams  77–91
space planning diagrams  49–59

Drop shadows on pages  39
.DRW files  221
Duplicate shapes in inventories, totaling  47, 73
Duplicating

bar chart shapes  194
counting duplicate shapes  47, 73
form elements  147
repeating shapes on each page  62
shapes  27, 172

Duration fields  106
Durations  47, 74, 106
Dynamic connections between shapes  32–35

E
Eccentricity (arc symmetry)  136–137
Editing

linked files  217
links  219
pasted Visio drawings  209
shapes  230

control handles  101
curves in road shapes  132
editing by changing masters  114–115
grouped shapes  96–97
locking shapes on layers  65
multiple shapes  228
segments in shapes  136–137
stacked shapes  195
stretchable shapes  193

stencils  114–116

Editing (continued)
styles  122
text  152, 230

Efficiency  227–231
Ellipse tool  138
Ellipses  136–139
Embedding objects

changing objects in Visio  222–223
outside information into Visio  212–223
Visio drawings

into other files  9, 207, 208, 209, 231
.EMF files  221
Encapsulated PostScript files  211, 221
End Date fields  106
End dates in timelines  106, 108
Endpoints  32, 33
Enhanced Metafiles  221
Enlarging. See Resizing
.EPS files  211, 221
Equipment shapes  69
Ethernet shapes  12
Executive Properties command  19, 20
Exporting drawings  9, 207, 211
Exporting reports  69, 72–73
Extend-o shapes  193

F
Fax cover sheets  151–155
Field box  164–167
Field separator characters  72
Fields (imported timeline data)  106
Fields (report text)  70–71, 72
Fields (updatable shape text)

dimension lines  30, 68
displaying information on drawings  44
inserting fields  164–167
searching and replacing text  160

File creator names  167
File formats

exporting drawings  211
importing files  221
opening in Visio  221
pasting in special formats  215
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File formats (continued)
saving drawings in older formats  44

Filenames  167
Files

attaching drawings to other files  224–225
attaching files to shapes  8, 38–41
breaking links  218
complex documents  205–225
displaying file information  167
exporting drawings  9, 206–211
exporting reports  69, 72–73
importing files  212–223
importing project timeline data  106
opening outside files in Visio  221
pasting in special formats  215
previewing  36, 44, 227
printing  198–201
property information  44, 45
saving  44–46
setting up pages  202–204
starting drawings  42–43
updating linked files  219

Fill color button  120
Fill command  223
Fill pattern button  120
Fill shadow button  120
Fill style list  120, 122
Fills

applying to shapes  120, 122, 179
changing fill format  83
in imported pictures  220, 223

Filters
export filters  207, 211
import filters  213, 221

Find box  160, 162
Finding and replacing text  160–162, 230
First tile, moving to  199
Fit Page To Drawing Contents option  201
Fitting drawings on pages  198, 200–201
Fixed stacks of shapes  194–195
Flexible road shapes  129, 132
Flipping shapes  23, 140–141
Float command  112
Floating stencils  112, 113

Floating text shapes  171
Flowchart stencil  38
Flowchart Wizard template  5
Flowcharts  4–9, 32, 33
Font box  169
Font size list  120, 168
Fonts  169
Forcing drawings to fit on pages  201
Foreground pages  62–63, 167
Format Painter tool  120–121
Formats for files. See File formats
Formatting

3-D shapes  83, 99
changing multiple shapes  228
consistently with styles  122–123
copying formatting from shape to shape  120–

121
grouped shapes  96–97
lines and fills  83
milestones and task shapes  107
objects  222–223
reports  72
road shapes  131–132
shapes  120–122
text  120–121, 168–171
timelines  107

Forms  143–155
big picture  144–145
fax cover sheet  151–155
invoices  146–150
setting tabs  156–159

Forms template  146, 151
Formula results  167
Four-headed arrow shapes  81
Fragment command  134
Fragmenting shapes  134–135
Frameworks for forms  147
Freeform drawing  138–139
Freeform shapes  136–139

editing road shapes  132
in older Visio versions  44

Freeform tool  138
Furniture in space plans  56, 69
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G
Gannt charts  103–111
Generating inventories  69–73
Generating reports  47
Geographic maps  142
Geometry fields  167
Gluing shapes  30–31

connecting shapes  32–35
dimension lines  68
options for layers  65
point-to-point or dynamic connections  32
to guides  30, 228

Go To command  41, 118
Go To Shape command  41
Gradient fills in imported pictures  220
Graph Line shapes  190
Graph Scale shapes  182, 187
GraphMaker add-on  193, 195
Grayscale conversions of color  220
Green handles  26
Grid lines  92–93, 189
Grids for forms  147
Groups

assigning shapes to layers  64, 65
converting objects to groups  223
grouping shapes  96–97, 228–229
inventorying shapes  69
removing text from groups  153
selecting all groups on pages  28

Growing Bubble shapes  89
Guides and guide points  92–93, 228

adding to groups  96–97
gluing shapes to guides  30
selecting guides  28

H
Hairpin turn shapes  129
Handles

control handles  12, 33, 101
gluing dimension lines to handles  68
green handles  26
rotation handles  140
text block handles  168

Hanging indents  156, 158
Headings in reports  72
Height of shapes  70, 166, 167
Help for shapes  4, 227
Hiding 3-D shape appearance  99
Hiding lines in diagrams  81
Hierarchy. See Organization charts
Hints for streamlining work  227–231
Holes in shapes  134–135
Horizontal Bar Text shapes  183, 188
Horizontal flipping  140
Horizontal shape alignment  95
Horizontal shape distribution  94
Horizontal stacks of shapes  194–195
Horizontal text alignment  169, 170–171

I
Icons

master shape icons  112, 113, 116
OLE object icons  223

ID numbers  70, 165, 167
Ideas for streamlining work  227–231
Identifying files  44, 45, 227
.IGS files  211, 221
Import filters  213, 221
Importing

changing imported objects  222–223
clip art  196–197
outside information into Visio  212–223
project timeline data  106
Visio drawings into other files  9, 207, 211,

231
Increase font size button  120
Indenting text  156, 158, 169
Independent text  171
Information about shapes, attaching  8, 38–41
Initial Graphics

Exchange Specification  211, 221
Inner Branch shapes  88
Insert Object command and box  209, 216
Inserting

fields  164–167
objects into Visio  216, 220–223
pages  118
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Left align button  120, 168
Left-aligned tabs  156
Legends on drawings  168
Line charts  186–191
Line color button  120
Line command  223
Line ends button  120
Line Graph shapes  187
Line styles

imported objects  220, 222–223
Line style list  120, 122

Line tool  138
Lines

changing curvature  136–137
changing fax forms  153
coloring  89
dimension lines  68
drawing  138
formatting  83, 120–121
hiding  81
in imported pictures  220, 222–223
road shapes  131
styles  120, 122

Lining up shapes. See Aligning shapes
Link To Doc add-on  8, 39, 40
Link To Page add-on  8, 39, 40
Linking annotations to shapes  8, 38–41
Linking objects

changing objects in Visio  222–223
editing links  219
linking drawings into other files  9, 207, 210
linking outside information into Visio  212–

223
managing links  218–219
updating linked files  219

Linking shapes to pages or files  8, 38–41
Links box  219
Lists

bulleted lists  156, 158
bullets  157
fields in reports  71
shapes in drawings  69–73

Locking shapes  65, 100
Lotus Notes fields  167
Lowercase text  169

Inserting (continued)
tasks in timelines  109–110
updatable text  164–167
Visio drawing in other files  209, 211

Integrating drawings with other files  205–225
Intersect command  134
Intersecting shapes  134–135
Inventories  48, 69–73, 230
Inverting colors in imported pictures  220
Invoice forms  146–150
Italic button  120, 168

J
Jumping between shapes and annotations  41
Justify align button  120, 168

K
Key commands  228
Keywords for files  44, 167

L
Labels

drawing labels  5–6, 168
line charts  188
rows in ShapeSheets  75
timeline tasks  110

Lake shapes  130
Landmark shapes  130
Landscape orientation  5, 202–204
Large print jobs  198–201
Last tile, moving to  199
Layer command or box  58, 65–66, 67
Layer Properties box  65–66, 67, 99
Layers  58, 64–67, 229

background and foreground pages  62–63
coloring shapes on layers  90
deleting layers  67
grouped shapes  96–97
in older Visio versions  44
shape stacking order  26, 28–29

Laying out pages  53, 202–204
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M
Macintosh PICT files  211, 221
Magenta endpoints  136
Magnifying pages  37
Main images in diagrams  81
Make Department command  20
Manager Properties command  19, 20
Managing links  218–219
Manually updating links  218–219
Map template  128
Maps

big picture  126–127
directional maps  125–133
geographic regions  142
mind maps  86–91

Margins
measuring tabs from margins  156
page margins  200
small drawings  198
text block margins  169

Margins box  200
Master shape icons  112, 113, 116
Master shapes

adding shapes to drawings  6, 26
drawing file stencils  114–115
editing to update instances  114–115, 229
icons  112, 113, 116
identifying in reports  70
inventorying stencils  48
saving shapes as masters  114, 117, 229
using stencils  112–117

Measurements
dimension lines  30
displaying in fields  166
drawing to scale  60–61
measurement units  92–93
measuring shapes  68
office plans  52
page size  202–204
tab settings  156

Merging
drawings into other files  9, 206–211
outside information into drawings  212–223

Merging (continued)
shapes  134–135

Metafiles  211, 221, 222–223
Metro line shapes  129
Micrografx Designer files  221
Microsoft Binder  208, 224–225
Milestone Layout command  108
Milestones  107–110
Mind maps  78–79, 86–91
Mindmapping template  86
Month labels on timelines  110
Moving

between shapes and annotations  41
centers of rotation  140
clip art  197
connections  8
shapes  7, 94–95, 228

forward or backward  26, 28–29
snapping into position  30–31

stencils  112, 113
text blocks  170–171
through pages  118
through tiles  199
vanishing points  98

Multiple layers  64, 67
Multiple pages  62, 63, 118–119, 208
Multiple shapes

changing shapes  228
copying shapes  172
selecting shapes  28
stamping copies of shapes  27

Multiple stencils  112

N
Names

fields in reports  72
files  44
master shape icons  112
page names  62, 118, 167
shape names  70, 167
stencils  117
templates  46
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Navigating
between shapes and annotations  41
through pages  118
through previewed tiles  199

Network diagrams  10–15, 32, 33, 69
New box  209
New drawings  42–43, 202–204, 225
New Layer box  66
New layers  65, 66
New pages  62
New stencils  114, 117
New Window command  119
Next Page button  118
Next tile, moving to  199
North shapes  130
Notepad  69, 72–73
Numbering pages  164, 167, 224
Numbers

aligning with tabs  156
assigning to shapes  74
numbering shapes  165
representing in bar charts  182

Numerical reports  47

O
Object command  216
Object Info fields  167
Object Linking and Embedding  205–225
Objects  205–225
Office Layout stencil  64
Office Layout template  53
Office Layout Wizard  53
Office layouts  49–59, 64
Offsetting copies of shapes  27, 172
OLE objects  205–225
Onscreen display of reports  69, 72–73
Open box  116
Opening

block shapes  84
copies of stencils  116
new drawings  42–43
outside files in Visio  213, 221
previewing files  36

Opening (continued)
read-only files  42
stencils  112–113, 116
templates  42–43
text blocks  170–171
Visio  43

Operations submenu  135
Order of pages  119
Order of report fields  71
Order of shapes  26, 28–29
Order of timeline tasks  109–110
Organization charts  16–21, 32, 33
Orgchart Properties command  19
Orgchart template  16
Orgchart Wizard template  17
Orientation of pages  5, 202–204
Orienting shapes to vanishing points  98
Outer Branch shapes  88
Outlines of shapes  26
Overall drawing appearance  19
Overviews. See Big pictures

P
Page box  118
Page breaks  199
Page command  62, 118
Page Info fields  167
Page Number fields  164
Page numbers  164, 167, 224
Page Properties box  63
Page Setup box  200, 203
Page Size/Scale box  61, 201, 204
Pages  118–119

adding  118
annotation pages  8, 38–41
changing view  37
deleting  119
department pages in org charts  20
displaying page information  167
foreground and background pages  62–63
inventorying shapes  69–73
layers  64–67
margins  200
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Pages (continued)
names  167
numbering  164, 167, 224
page breaks  199
page orientation  5, 202
page scale  53–54, 60–61
page setup  202–204
page size  198, 202–204
previewing  36
reordering and displaying  119
setting up  5, 42, 202–204
turning  118

Panels in office plans  56
Panning outside objects  222–223
Paper size  198, 202–204
Paragraph box  158, 159, 169
Paragraph formatting  156–159, 169
Park shapes  130
Paste command  208, 214
Paste Special command  215, 217
Pasting

outside information into Visio  212–223
pasting in special formats  215
shapes  172
Visio drawings into other files  9, 207, 208,

209, 231
Paths in shapes  139
Paths to linked objects  218
Pattern button  120
Patterned lines in imported pictures  220
PC Paintbrush files  211, 221
.PCT files  211, 221
.PCX files  211, 221
Pencil tool  138
Percentages in bar charts  182
Perimeters of shapes, changing  134–135
Perspective block diagrams  80, 82, 98–99
Perspective Block Diagram template  80, 98
Phrases  160–162
PICT files  211, 221
Picture command and box  197, 220
Pictures

adding to drawings  196–197
importing into Visio  220–223

Pie charts  176–180
Placing drawings into other files  9, 206–211
Placing outside information into Visio  212–223
Planning

networks  10–15
office space  49–59
projects  103–111

Plotting charts  182, 187
Point size of text  168
Points  33, 34
Point-to-point connections  32, 33, 35
Portrait orientation  5, 202–204
Position of text  169
Position Properties command  19, 20
Positioning shapes on pages  92–95
Power-pasting shapes  27, 172
Pre-programmed shapes with annotations  38
Previewing files  36, 44, 227
Previewing printouts  199
Previous Page button  118
Previous tile, moving to  199
Primary selected shapes  26
Print preview  199
Print Preview command  199
Printer paper size  198, 202–204
Printing

drawings  9, 198–201
inventories of stencils  48
page and paper size choices  198, 202–204
shapes on layers  65

Procedures
charts  173–191
connected diagrams  2–3
forms  143–155
maps  125–133
office plans  49–59
project timelines  103–111
relationship diagrams  77–91

Programs
attaching to shapes  8, 38–41
using Visio with other programs  205–225

Project Timeline Wizard  106
Project timelines  103–111
Prompting for document properties  44, 45
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Properties (drawing properties)  19
Properties (shape properties)  74–75
Properties box (file properties)  44, 45, 167, 227
Properties box (page properties)  167
Property Reporter  47
Property Reporting shapes  47
Protecting shapes  65, 100

Q
Quantities of shapes on pages  70
Quick View command  36

R
Railroad crossing shapes  130
Raised block diagrams  80
Reading data from spreadsheets  107
Read-only files  42, 44, 112
Rearranging icons  113, 116
Rearranging stencils  112
Rectangle tool  138
Rectangles  138–139
Reducing. See Resizing
Region add-on  142
Regional maps  142
Relationship diagrams  77–91

big picture  78–79
block diagrams  80–85
mind maps  86–91

Remove From Group command  153
Removing. See Deleting
Renaming styles  123
Reorder command  119
Reordering

pages  119
shapes  26, 28–29
timeline tasks  110

Repeating elements in drawings  147, 172
Repeating information on each page  62
Replace box  160, 162
Replacing text  160–162, 230

Reports
choosing fields  70–71
displaying  69, 72–73
inventorying shapes  47, 69–73
inventorying stencils  48
setting up files  230

Reshaping shapes  136–137
Resizing

chart shapes  183, 192–194
clip art  197
drawing scale  60–61
drawings  60–61, 198, 200–201
grouped shapes  97
objects  222–223
regional map shapes  142
resize behavior  100
shapes  68
text blocks  170–171

Resource fields  106
Resources  47, 74, 106
Returning to Visio from attached documents  41
Reversing shapes  140–141
Right align button  120, 168
Right-aligned tabs  156
Right-clicking shapes  4
Ring shapes  12
Road shapes  101, 129, 131–132
Road Thickness command  131
Rotating shapes  140–141
Rotating text  168, 170–171, 183
Rotation handles  140
Round corners button  120
Rounded Stamp shapes  89
Row/Column Header shapes  183
Rows in forms  148
Rubber-stamping shapes  27
Rulers  92–93
Run Add-on command  100
Running add-ons

GraphMaker  193, 195
Link To Doc add-on  8, 39, 40
Link To Page add-on  8, 39, 40
Property Reporter  47
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Running add-ons (continued)
Region add-on  142
SmartShape Wizard  75, 100
Stencil Report Wizard  48

S
Save As box  44, 45, 211
Saving

arrangements of open windows  44
drawing file stencils as stand-alone  114–115
drawings  9, 44–46, 211
previews of files  44
reports  69, 72–73
stencils  115
styles  123
templates  46

Scale shapes  130
Scales

charts  182, 187
indicating on drawings  130
regional map shapes  142
scaling drawings  53–54, 60–61, 200

Schedule. See Timelines
Screen display of reports  69, 72–73
Scrolling pages  37
Searching and replacing text  160–162, 230
See-through shapes  134–135
Segments in shapes  136–137, 139
Select All command  28
Select box  71
Select Special command  28
Selecting

categories of objects  28
fields for reports  71
grouped shapes  97
page contents  28
selection handles  26
text  170–171

Selection handles  26
Send Backward command  29
Send To Back command  29
Separator characters  72
Serial numbers  69, 70, 74
Set Depth command  99

Set font list  120
Setting up pages  202–204
Shadow button  120
Shadows on pages  39
Shape Help  4, 227
Shape Report command  71
Shapes. See also Master shapes

adding to stencils  114, 117
attaching annotations or files  8, 38–41
behavior  230
closing  139
compared to clip art  196
connecting  6, 8, 30–31, 32–35
connection points  34
control handles  12, 101
control points  136–137
converting objects to shapes  223
copying shapes  27, 172, 194
dimension lines  30, 68
dimensions  30, 68, 166, 167
drawing  138–139
drawing scale  60
duplicating  27, 172, 194
editing  136–137

behavior  230
copying shape formatting  120–121
hiding 3-D appearance  99
merging into new shapes  134–135
vertices  136–137, 230

formatting  99, 120–123
freeform shapes  138–139
gluing  30–31
grouping and ungrouping  96–97, 228–229
ID numbers  167
information on shapes  4, 227
inventorying  69–73

assigning data or properties  8, 74–75
calculating shape numbers and data  47, 70

layers  58, 64–67, 67
moving and positioning  7, 92–95

aligning or distributing  27, 94–95
dragging and dropping  26
moving connections  8
rotating and flipping  23, 140–141
snapping into place  30–31
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Shapes (continued)
names  167
numbering  165
pasting into other files  208, 210, 231
protecting  100
repeating on each page  62
saving as master shapes  229
segmented shapes  136–137, 139
selecting  28
ShapeSheets  74–75, 196
SmartShapes  100
stackable chart shapes  194–195
stacking order on page  26, 28–29
stretchable chart shapes  192–194
text blocks  170
text-only shapes  171

ShapeSheets  74–75, 196
Shape-to-shape connections  32, 33, 35
Show Master Shapes command  115
Showing. See Displaying
Size/Scale box  61, 201, 204
Sizing behavior  97
Slide shows  231
Small Cloud shapes  88
Small drawings  198
Smart shapes  100, 196, 230
SmartShape Wizard  75, 100, 230
Snap & Glue box  31
Snapping shapes  30–31, 65
Sorting fields in reports  71
Space planning diagrams  49–59, 64
Special box  167
Special characters  72
Special effects  192–195
Speeding up work  227–231
Spelling  160–163, 224, 230
Spelling box  161, 163
Spelling options box  161
Splitting shapes  134–135
Spreading out shapes  94
Spreadsheets  106, 107
Square shapes  138–139, 139
Stackable chart shapes  194–195

Stacking order of shapes  26, 28–29
Stacking pages  62–67
Stamp tool  27, 33
Stand-alone stencils  114–117
Standard connections between shapes  32–35
Start Date fields  106
Start dates in timelines  108
Starting Visio  43
Station shapes  129
Statistics on shapes  65, 69–73
Status bar  68
Stencil Report Wizard  48
Stencils  112–117

adding master shapes  116
adding shapes  117
Chart stencil  192
creating and editing  114–117
displaying icons on stencils  113, 116
docking or floating  113
dragging and dropping shapes  6, 26
drawing file stencils  114–115
editing  116
Flowchart stencil  38
inventorying and printing shapes  48
moving  112
Office Layout stencil  64
opening  112–113, 116
opening drawings without stencils  43
opening with templates  42
rearranging icons  116
Total Quality Management stencil  38

Stencils box  113
Step-by-step instructions. See Procedures
Stop light shapes  130
Stop sign shapes  130
Streamlining work  227–231
Strength of snap  30
Stretchable chart shapes  192–194
Strings of text  160–162
Styles  122–123, 229
Subdivisions on rulers  92–93
Subjects of files  167
Subscript button  120, 168
Subselecting shapes in groups  97, 152
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Subsidiary pages for shapes  8, 38–41
Subtract command  134
Subtracting one shape from another  134–135
Super Smart Slice shapes  177
Superscript button  120, 168
Switch Sides command  112
Switching between

foreground and background  63
Switching stencils  112
Switching toolbars  42
Symmetry of arcs  136–137

T
Tab-delimited timeline data  106
Tables in text  156–159
Tabs  156–159, 169
Tabs box  157, 159
Tag Image File Format files  211, 221
Tall orientation  5, 202–204
Task Label shapes  109
Task Layout command  108
Task lists for projects  106
Task Name fields  106
Task Name shapes  109
Task Name Text Block shapes  109
Task Number fields  106
Task Properties command  108
Tasks  106–110
Techniques for streamlining work  227–231
Templates

Block Diagram template  80
Chart template  176, 181, 186
drawing scales  60
Flowchart Wizard template  5
Forms template  146, 151
Map template  128
Mindmapping template  86
Office Layout template  53
opening  42–43
Orgchart template  16
Orgchart Wizard template  17
page setup  202
Perspective Block Diagram template  80, 98

Templates (continued)
saving  44, 46
styles  122, 123
Total Quality

Management Wizard template  22
Text and text blocks

adding to groups  96–97
adding to shapes  7
aligning  168
background color  169, 170–171
color button  120
copying formatting  120–121
deleting in groups  153
directions on maps  130–131
editing  230
fields  30, 44, 68, 164–167
finding and replacing  160–162
formatting  168–171
independent and shape text  170–171
margins  169
rotating  183
selection handles  168
size  168
spelling  160–163
tables  159
tabs  156–159
Text Block shapes  178
titles on drawings  5–6

Text Block box  169
Text Block shapes  178
Text color button  120
Text delimiter characters  72
Text fields  164–167. See also Fields

dimension lines  30, 68
document information  44
inserting  164–167
searching and replacing text  160

Text files  69, 72–73, 106
Text style list  120, 122
Text toolbar  120
Text-only shapes  171
Three-D shapes  83–84, 98–99
Thumbnails of files  36, 44
Tier shapes  88
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Tiers in mind maps  90
.TIF files  211, 221
Tightly enclosing page objects  201, 202
Tiling printouts  198–201
Tiling windows  119
Timeline shapes  107–110
Timelines  103–111
Times and dates  167
Tips for streamlining work  227–231
Title shapes  17
Titles of files  44
Titles on drawings  5–6, 168
Toolbar buttons  120–121, 138–139, 168
Toolbars  42
Toolbars command  42
Tools  120–121, 138–139, 168
Top align button  120, 168
Total Quality Management stencil  38
Total Quality Management Wizard template  22
Totaling shapes in inventories  73
Tracking equipment  69
Transfer station shapes  129
Transferring formatting to shapes  120–121
Transparent layers. See Layers
Tree shapes  82, 130
Tricks for streamlining work  227–231
Turning off features

file information prompts  45
hiding 3-D appearance  99
snap and glue  30, 31

Turning pages  118
Types of shapes  70

U
Underline button  120, 168
Undo command  228
Undoing actions  228
Ungroup command  223
Ungrouping shapes  96–97, 223
Union command  134
Uniting shapes  134–135
Units of measurement. See Measurements
Unreferenced layers  65

Updating
copies of master shapes  114–115
linked objects  218, 219
outside information in drawings  213
shapes  115, 229
text field information  164–167
timelines  107

Uppercase text  169
User dictionaries  160, 161, 163

V
Values, assigning to shapes  75
Vanishing Point shapes  82, 98
Vanishing points  84, 98
Vertical Bar Text shapes  183, 188
Vertical flipping  140
Vertical shape alignment  95
Vertical shape distribution  94
Vertical stacks of shapes  194–195
Vertical text alignment  169, 170–171
Vertices

adding or deleting  136–137, 230
drawing segmented shapes  139

Viewing
annotation pages  41
foreground and background pages  63
page views  37
previewing files  36
shapes on layers  65
stencils  112

Visible 3-D shape appearance  99
Visio

older file formats  44
starting  43

W
Wall shapes in space plans  54–55
Week labels on timelines  110
Wide orientation  5, 202–204
Width of road lines  131–132
Width of shapes  70, 166, 167
Winding road shapes  129
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Windows
displaying different pages  63, 118–119
in office plans  52, 55
print preview window  199
stencil windows  114

Windows Bitmap files  211, 221
Windows Clipboard  69, 72–73
Windows Explorer  36
Windows Metafiles  211, 221, 222
Windows Notepad  69, 72–73
Wizards

Flowchart Wizard template  5
Office Layout Wizard  53
Orgchart Wizard template  17
Project Timeline Wizard  106
SmartShape Wizard  75, 100, 230
Stencil Report Wizard  48
Total Quality Management Wizard template

22
.WMF files  211, 221
Words

adding to dictionaries  161
finding and replacing  160–162

Working efficiently  227–231
Workspaces  44

X
X- and y-axis labels  188

Y
Year labels on timelines  110

Z
Zooming  37
ZSoft PC Paintbrush Bitmaps  211, 221


	Connected Diagrams
	The Big Picture
	Creating a Flowchart
	Creating a Network Diagram
	Creating an Organization Chart
	Creating a Cause and Effect Diagram
	Dragging and Dropping Shapes
	Snapping and Gluing Shapes
	Connecting Shapes
	Previewing Diagrams
	Changing Magnification
	Linking Shapes to Pages and Files
	Starting a Visio Diagram
	Saving Visio FilesConnected Diagrams
	Generating Numerical Reports
	Printing Stencils

	Office Layout
	The Big Picture
	Creating an Office Layout
	Drawing to Scale
	Placing Information on Background Pages
	Placing Information on Layers
	Measuring While You Draw
	Take an Inventory of Your Diagram
	Associating Properties With Shapes

	Relationship Diagrams
	The Big Picture
	Creating a Block Diagram
	Creating a Mind Mapping Diagram
	Positioning Shapes on the Page
	Grouping and Ungrouping Shapes
	Using 3-D Perspective
	Making Shapes Smarter
	Control Handles

	Project Timelines
	The Big Picture
	Creating a Project Timeline
	Opening and Moving Stencils
	Creating and Editing Stencils
	Handling Multiple Pages
	Quickly Formatting Shapes
	Formatting Shapes With Styles

	Directional Maps
	The Big Picture
	Creating a Directional Map
	Merging Shapes
	Editing Shapes
	Drawing Your Own Shapes
	Rotating Shapes
	Creating Geographic Regions

	Forms
	The Big Picture
	Creating an Invoice
	Customizing a Fax Cover Sheet
	Setting Tabs
	Finding and Correcting Text
	Adding Page Numbers and Other Fields
	Working With Text
	Duplication Techniques

	Charts
	The Big Picture
	Creating a Pie Chart
	Creating a Bar Chart
	Creating a Line Chart
	Adding Special Effects To Charts
	Using Clip Art in Visio Diagrams
	Printing Diagrams
	Setting Up a Diagram

	Using Visio with Other Programs
	Placing Visio Information
	Placing Information in Visio
	Using the Binder

	Working Efficiently in Visio
	Index

