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DOUBLE-CLICK ON A TOPIC IN THE HELP LIST. 
Double-clicking on a topic shows you information on that specific subject.  For 
more instructions on how to use this Help Presentation:

1. Click on the Title Sorter Button, then 

2. Double-click on the title of Slide 2, entitled “Using This Help 
Presentation.” 

This is the 
Title Sorter Button

Copyright © 1987, 1988 Microsoft Corporation
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    Using This Help Presentation (Demo Version)

• To choose a topic 

Choose Title 
Sorter from the View 
menu.

Or 

Click on the Title 
Sorter button to see the 
Title Sorter view.

Then

Double-click on 
the topic you want.

• To scan the list 
of topics

Drag the vertical scroll 
bar on the right side of the 
window.

Or

Click on the scroll 
arrows.

• To get back to your 
presentation

Choose the 
presentation’s name from 
the Window menu.

Or

Click on its 
window, if it’s visible.

• For more about this topic, refer to page(s) 101-103 in your PowerPoint User Manual.

• To close the Help 
Presentation

Choose Close 
from the File menu.

Or

Click on the Close 
Box at the top left of the 
window.
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MENUS

You choose from the eight PowerPoint menus at the top of the window 
in the usual way:

1. Press the mouse button while on a menu title to pull it down;
2. Drag the pointer until the command you want is highlighted;
3. Release the mouse button.

When choosing a command or option for an object, such as Framed 
from the Draw menu, select the object first before choosing the option.

The next few slides in this Help presentation describe the commands and options. 

• For more about this topic, refer to Chapter 5 in your PowerPoint User Manual.
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    Sub-Menus and Pop-Up Menus

Font
Size
-

The small arrow symbols indicate a sub-menu.  When you 
choose a command that has the arrow symbol next to it, a 
sub-menu appears.  Drag over to the sub-menu and choose 
from it as you do from a regular menu.

A box with an outline indicates a pop-up menu.  These 
menus only appear in dialog boxes.  Put the pointer on 
the box, hold down the mouse button, and the pop-up 
menu appears.  Drag onto the pop-up menu and 
choose from it just as you do from a regular menu.

• For more about this topic, refer to page(s) 99-101 in your PowerPoint User Manual.
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    The File Menu
File

New...
Open...
Save S⌘
Save as...
Close

Paste from...

Page Setup...
Print...
Slide Show...

Quit Q⌘

• For more about this topic, refer to page(s) 288-300 in your PowerPoint User Manual.

Opens a new presentation, optionally using format of the active one. 

Open an existing presentation with or without its original title. 

Saves a presentation and overwrites its earlier version.

Saves a presentation under a new name.

Closes a presentation, reminds you to save it if necessary.

Pastes from a file into your presentation.  The files must be in Paint, PICT, PICT 
II, EPSF, or MORE/ThinkTank format.

Shows dialog boxes for paper size, orientation, slide size, and screen size.  Set 
slide size to overheads, 35mm, or a custom size.

Shows the Print dialog box.  Choose what you want printed here. 

Shows the Slide Show dialog box.  Choose a manual or automatic show and the 
duration between slides here.

Quits PowerPoint.    
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    The Edit MenuEdit
Undo Z⌘

Cut X⌘
Copy C⌘
Paste V⌘
Clear
Select All A⌘

Bring to Front ⌘=
Send to Back ⌘-

Paste as Picture

Omit Master
Set as Title
New Slide N⌘

• For more about this topic, refer to page(s) 300-306 in your PowerPoint User Manual.

Cancels the last change to the presentation.

Removes selection and puts it on the clipboard.

Copies selection onto the clipboard.

Pastes selection from the clipboard. 

Removes a selection from the presentation.

Selects:  1) all objects on a slide, 2) all text in an object, or 3) all 
slides in the Slide or Title Sorter views.

Puts selected object on top of all others.

Puts selected object underneath the others.

Creates a single picture from multiple objects on the 
 clipboard.

Removes the Master format from the current slide or notes.  

Makes the selected object the slide title.

Inserts a new slide into the presentation. 
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    The View Menu

• For more about this topic, refer to page(s) 306-310 in your PowerPoint User Manual.

Changes the scale of view on slides or notes pages.  
In the Slide Sorter view, changes the sizes of the 
miniatures.

Shows the current slide.

Shows the notes page for the current slide.

Shows the master format for slides.

Shows the master format for notes pages.

Shows the template for the handouts pages.

Switches to the Title Sorter view.

Switches to the Slide Sorter view.

View

Full Size
66% Size
50% Size
33% Size

Slides (#1) D⌘
Notes (#1) E⌘

Slide Master
Notes Master
Handout Page

Title Sorter
Slide Sorter
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    The Style Menu

• For more about this topic, refer to page(s) 310-314 in your PowerPoint User Manual.

These options change the typestyle of the selected text.  
Select the text first, then choose the typestyle you want 
for it.  You can choose more than one typestyle, for 
instance, bold underlined.  Choose Plain to remove the 
other typestyles from the selected text.  Checkmarks next 
to the typestyles indicate which ones pertain to the 
selected text. 

The Font and Size sub-menus show your choices for 
selected text.  The fonts and sizes come from the System 
file.  

Text Styles consist of fonts, typestyles, sizes, and colors.  
The Styles sub-menu shows choices for styles.  Choosing 
Define Styles shows a dialog box for adding, removing, or 
rearranging styles on the list.  

Style

Plain P⌘
Bold B⌘
Italic I⌘
Underline U⌘
OutlineOutline
ShadowShadow

Font
Size

Styles
Define Styles...
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    The Text Menu

• For more about this topic, refer to page(s) 314-322 in your PowerPoint User Manual.

Determines text alignment.  Choosing an alignment 
option before typing will set that alignment until you 
change it.  To realign existing text, select it first,
then choose an option.

Changes the indenting of the selected text to the
Right or the Left.  The indentation is set on the text 
ruler (only applies to word processing objects). 

Shows the text ruler for indenting and tabs.

Shows the dialog box for setting line spacing.

Sets indents, tabs, line spacing, and text alignment
as defaults for new word processing objects.

Text

Left
Center
Right
Justify

Indent » R⌘
Indent « L⌘

Show Text Ruler
Line Spacing...
Set as Default...

Find/Replace...
Find Next F⌘
Spelling...   

Finds and can replace text that you specify.
Finds the next instance of text that you specify.
Shows the dialog box for checking spelling.  
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    The Draw MenuDraw

Opaque
Framed
Filled
Shadowed
Sized to Text

Pattern
Line Style
Arrowheads

Ignore Grid
Show Guides G⌘
Show Edges

• For more about this topic, refer to page(s) 322-326 in your PowerPoint User Manual.

Makes the selected objects opaque.

Puts a frame around the selected objects.

Fills the selected objects with a pattern.

Puts a drop shadow behind the selected objects.

Makes the selected text objects fit exactly around the 
text within them.  

Turns off the automatic grid alignment.  If it’s already
off, this option becomes Snap to Grid.

Shows the two on-screen “straightedges.”  If they’re
already on the screen, this option becomes Hide Guides.

Shows a dotted outline around all unframed objects.  If
Show Edges is on, this option becomes Hide Edges.  

Shows sub-menus for these drawing features.  See the next 2 
slides for details.
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    The Pattern Sub-Menu

• For more about this topic, refer to page(s) 324 in your PowerPoint User Manual.

These are the patterns that can be used for the frame or the 
interior fill of an object.  
To give an object a patterned frame:
1. Select the object.
2. Choose Framed from the Draw menu.
3. Choose a pattern from the Pattern sub-menu.    
To give an object a patterned fill:
1. Select the object
2. Choose Filled from the Draw menu.
3. Choose a pattern from the Pattern sub-menu.       (Frame
—if any—will be solid.)

If you’re working in color, the pattern colors are determined by the 
Pattern Contrast setting on the Color menu, and the object’s fill or 
line color.



• Choose Title Sorter from the View menu to see the Help list again.

    Sub-Menus for Line Style
and Arrowheads

• For more about this topic, refer to page(s) 324, 325 in your PowerPoint User Manual.

These options set the thickness and style of lines.
Select one or more objects, then choose one of
these options.  The lines in the objects, including
the frames, will become that line width and style.
If you also choose an arrowhead from the 
arrowheads sub-menu, it will be proportional
to the line thickness.  Checkmarks indicate the
thickness and style of the selected lines.

These options only apply to lines, not to frames.
Draw the line and then choose one of the options 
for arrowheads.  The single arrowhead points in 
the direction you drew the line.  
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    The Color Menu

Shows sub-menus of color choices.  The choices are the 
color scheme and any extra colors you have added.  
Select an object and then choose a color from one of the 
sub-menus.  For instance, to fill an object with a color, 
select the object, choose Fill from this menu, then choose 
the color from the sub-menu.  You do not have to choose 
Fill first from the Draw menu. 

Shows the Color Scheme dialog box. 

Shows the dialog box for recoloring pictures 
copied to your presentation.

Shows the dialog box for adding extra colors to
the sub-menus for color choices.

Color

Fill
Line
Shadow
Pattern Contrast
Text

Color Scheme...
Recolor Picture...
Add Extra to Menu...

• For more about this topic, refer to page(s) 326-340 in your PowerPoint User Manual.
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    The Window Menu

• For more about this topic, refer to page(s) 340 in your PowerPoint User Manual.

Each time you open a presentation or desk
accessory, it’s listed on the Window 
menu.  Certain PowerPoint dialog boxes
are also listed.  Choosing a window here 
makes it the active window on the 
screen.  The main use of the Window menu
is to help you move among presentations 
and dialog boxes quickly without having to
resize windows to find the one you need. 

Window

Training Presentation
PowerPoint Presentation
Columbus
PowerPoint Help
Color Scheme
Spelling
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OPENING A PRESENTATION

 File

New...
Open...
Save S

PowerPoint has four ways to open a presentation.  All four use the File menu.

1. If another presentation is active and you want to re-use its format, but not 
its slides, choose New, then click on the button labeled Use Format of Active 
Presentation.

2. To open a presentation with PowerPoint’s default format, choose New, 
then click on Use Default Format.  If you’ve saved your own custom default 
choices and slides in a presentation named Default Format, a new presentation 
with those defaults will open.                 

3. To re-open an existing presentation and maintain its current name, 
choose Open.  On the dialog box that appears, double click on the name of the 
presentation.

4. To open a new copy of an existing presentation and give it a new name, 
choose Open, then click on Open an Untitled Copy.

• For more about this topic, refer to page(s) 107-111 in your PowerPoint User Manual.
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    The Slide View

The tools for drawing diagram objects

The labeler tool

The word processor tool

The slide changer bar
(with slide changer marker)

The Slide Sorter button

The Title Sorter button

The Zoom Box

The Slide view is where you see and can work with 
(1) slides, (2) the slide master, (3) notes pages, (4) 
the notes master, and (5) the handout page.  

The slide counter The size box

• For more about this topic, refer to page(s) 93-97 in your PowerPoint User Manual.
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    The Slide Master

The Slide Master is where you design the format for all the 
slides.  Use the tools at the left of the window to draw your 
master format.  You can also copy artwork, such as your 
business logo, to the Slide Master.  But remember, objects on 
the Slide Master cannot be selected on the slides themselves 
(except the slide title).  Therefore, don’t draw, for instance, a text 
box on the Slide Master if you intend to enter text into it on the 
slides.   The title on the Slide Master does not itself appear on 
the slides,  but whenever you start a new slide, its title is created 
for you by copying the title from the Master.

You’ll know when the Slide Master is in view because the slide 
counter will read:

1. To see the Slide Master,
choose Slide Master from the
View menu.

2. To get back to your slides
when you’re through with the 
Slide Master, choose Slides
from the View menu.

 • For more about this topic, refer to page(s) 123-126 in your PowerPoint User Manual.

Slide Master
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    Seeing Notes Pages

PowerPoint creates a single notes page for each slide in a presentation.  
The notes page contains a small image of its corresponding slide.  If 
you’re using color, the image will be the same colors as the slide.  Using 
the diagram tools or text tools at the left of the window, you can write 
notes for each slide, or paste information (e.g., an Excel table for 
backup).
To see a slide’s notes page:
1. Get the slide in the Slide view.
2. Choose Notes on the View menu. 
To get back to the slide, choose Slides on the View menu. 

You can cycle through your notes pages - just like you can with slides - 
with the slide changer, Sorter views, etc.  From the Sorter views, double-
clicking on a slide or title shows you the corresponding notes page, if you 
arrived in the sorter from viewing a notes page.

This is the small
image of the slide,
with room for
notes below.

A notes page.

The slide counter lets 
you know which notes 
page is in the window.  
For example:

 • For more about this topic, refer to page(s) 211-213 in your PowerPoint User Manual.

Notes 22



• Choose Title Sorter from the View menu to see the Help list again.

    The Notes Master
You use the Notes Master for creating the master format for your 
presentation’s notes pages.  You can move and resize the small 
slide image, and using the tools at the left side of the window, draw 
objects or add text.  Except for the slide image, objects drawn on 
the Notes Master cannot be selected on the notes page, therefore 
don’t draw a text box if you intend to add text to it on each notes 
page.  Instead, create the box individually on each page.  Hint: An 
easy way to get all the boxes in the same position on the notes 
pages is to draw it on one page, then select it, choose Copy from 
the Edit menu, get to the next page and choose Paste.  Continue 
pasting on all the notes pages in your presentation.

You’ll know when the Notes Master is in view because the slide 
counter will read: 

1. To see the Notes Master, 
choose Notes Master from the
View menu.

2. To get back to the notes
page, choose Notes.
3. And to get back to the slides, 
choose Slides.

• For more about this topic, refer to page(s) 214-216 in your PowerPoint User Manual.

Notes Master
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    The Handout Page

For more about this topic, refer to page(s) 216-217 in your PowerPoint User Manual.

I

II

A

B

C

1 2

3 4

5 6

Handouts pages can have 2, 3, or 6 slide images as represented 
in the template at the left (I, II; A, B, C; and 1, 2, 3, 4, 5, 6 
respectively.)  You choose which combination you want 
PowerPoint to print from the Print dialog box (choose Print on the 
File menu).  The outlines on the template show you where the 
slides will be positioned on the printed handout pages.  You can 
add text or other objects to the handouts pages here.  Whatever 
you add to the template will be printed on each handout page.  
Use the outlines to position your text and objects so they don’t 
overlap the images when the handouts pages are printed. 

You’ll know when the Handout Page is in view because the slide 
counter will read:        

1. To see the Handout Page,
choose Handout Page from the
View menu.
2. To get back to your slides,
choose Slides from the View
menu. Handout Page
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    The Slide Sorter View

• For more about this topic, refer to page(s) 101-102 in your PowerPoint User Manual.

The Slide Sorter view shows all your slides in miniature.  
To get to the Slide Sorter view:
• Choose Slide Sorter from the View menu, or • Click on 
the Slide Sorter Button.
To get back to the Slide view:
• Choose Slides from the View menu, or            • Double 
click on the slide miniature.

The Slide Sorter view (and the Title Sorter view) is where 
you:
• Rearrange the order of slides in a presentation
• Delete slides, cut, paste, and copy slides
• Copy slides to and from other presentations
To see all the miniatures in the Slide Sorter view, scroll 
using the vertical scroll bar.

This is a reduced image of the Slide
Sorter view.
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    The Title Sorter View

The Title Sorter view shows the title of your slides.  To 
get to the Title Sorter view:
• Choose Title Sorter from the View menu, or • Click on 
the Title Sorter Button.
To get back to the Slide view:
• Select a title (click on it) and choose Slides       from 
the View menu, or                                 • Double click on 
the title.

The Title Sorter view (and the Slide Sorter view) is where 
you:
• Rearrange the order of slides in a presentation
• Delete slides, cut, paste, and copy slides
• Copy slides to and from other presentations
To see all the titles in the Title Sorter view, scroll using the 
vertical scroll bar.

This is a reduced image of the Title
Sorter view.

• For more about this topic, refer to page(s) 102-103 in your PowerPoint User Manual.

1    Business Plan
2    World Trade Routes
3    A New Trade Route
4    World Trade Market Share
5    Proposed Expedition
6    Expedition Plan
7    Fleet Organization
8    Risks to be considered
9    Estimated Budget
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WORKING WITH OBJECTS

Objects are the building blocks of your slides and notes pages.  You draw 
diagram objects using the four tools at the left of this window.  The tools draw 
their respective shapes.

The other two tools are for writing labels and for writing with the PowerPoint 
word processor.

Pictures from other slides or other programs are also objects.  The 
next few slides in this Help Presentation tell you how to create, edit,
and design objects for your presentation.

• For more about this topic, refer to page(s) 133-141,185-196 in your PowerPoint Manual.

A
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    Adding Frames, Fills, and Shadows

1. Create an object with any of the tools at the left side of the window, or copy and paste a 
picture (or other object) onto your slide.  For instance:

2. Select the object.

3. Choose Framed, Filled, or Shadowed  from the Draw menu.   Choose from the Line Style 
sub-menu to change the width of the frame, choose from the Pattern sub-menu to change the 
pattern of the fill.  If you’re working in color, you can choose Fill, Line, and Shadow from the 
Color menu.

Framed Framed 
and Filled Framed, Filled

and Shadowed

See the next slide in this Help
Presentation for details about
mixing frames and fills on objects.

• For more about this topic, refer to page(s) 192-195 in your PowerPoint User Manual.
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    Aligning and Cropping

• For more about this topic, refer to page(s) 196-199, 210-211 in your PowerPoint Manual.

To align objects, choose Show Guides from the Draw menu.  
The two dotted guides appear.  Drag the guides to the 
position where you want to align objects.  Now drag the 
objects to the guides.  The edges and centers of the objects 
“stick” to the guides for easy alignment.  The numbers on the 
guides measure the distance from the center of the slide or 
notes page. Turn off the guides by choosing Hide Guides on 
the Draw menu.This number shows the

distance from the center
of the slide or notes page.

Pictures (artwork from another program or PowerPoint objects 
Pasted as a Picture) may be cropped to reduce the visible 
part.  To crop a picture, select it, hold down the ⌘ key and 
drag a resize handle.  The picture is cropped from the corner 
inward.  If you forget to press the ⌘ key, you’ll resize the 
picture and change its dimensions.  Choose Undo right away 
and start over.

This object’s edge
is aligned with
the vertical guide

0.58

Cropped from the
top left corner to
the middle

The full picture

®

®



• Choose Title Sorter from the View menu to see the Help list again.

    Copying an Object From One Slide to Another

You can copy objects from slides and notes page 
in the same presentation or between 
presentations.

1. Select the object (or objects).
2. Choose Copy (or Cut) from the Edit menu.
3. To copy to a different presentation, choose it 

from the Window menu.
4. Get to the slide or notes page you want to 

copy to.
5. Choose Paste from the Edit menu.  The 

object (s) is pasted to the same position as on the 
original (if visible). 

Slide 1 Slide 2

1. Select the object
   Choose Copy or
   Cut

2. Get to the slide
to paste to

3. Choose Paste Slide 2

The object is pasted
to the same spot as
on the original, if 
that spot is visible.

One note:  if you copy from a slide and paste 
back to it, the objects are slightly offset
so you can distinguish them, like this

• For more about this topic, refer to page(s) 222-223 in your PowerPoint User Manual.

egg
study

egg
study
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    Deleting Objects

You delete objects at the Slide view.
To delete objects, select them, then:

Choose Clear from the Edit menu,
or
Press the Backspace key.

If you delete the wrong objects, choose Undo from the Edit menu 
right away, before doing anything else.  The deleted objects will 
return.

You can also delete objects by selecting them and choosing Cut 
from the Edit menu.  Then you can paste the objects to the same or 
to other slides.  See the previous slide for details about pasting to 
another slide.

Slide 1

Select the object,
then choose Clear
or press Backspace

Slide 1

The selected object(s)
is deleted.

• For more about this topic, refer to page(s) 137 in your PowerPoint User Manual.

egg 
study

egg 
study
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    Drawing

PowerPoint’s four drawing tools are for creating diagrams.  The shape of each tool indicates the 
type of diagram it can create: 
line      oval         rectangle with rounded corners        and rectangle        . 

To draw a diagram:
1. Click on one of the tools.
2. Put the pointer on the window.  It will 

become crosshairs:
3. Drag to draw the diagram. It will follow the 

crosshairs like this:

The diagrams can also be constrained (shift 
key) to be circles and squares.

The drawing tools are meant for  creating 
diagrams such as organization charts, system 
diagrams, process charts, and the like.

You can also use your other Macintosh 
programs to create art, then paste it into your 
presentation from the clipboard, scrapbook, or 
by using the Paste from command (on the File 
menu). 

• For more about this topic, refer to page(s) 185-195 in your PowerPoint User Manual.

And end here

Start here
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    Selecting and Deselecting One or More Objects
To select an object, click on it.  The pointer must be an arrow in order to 
select an object.  If it is a crosshair or other shape, change it back to an 
arrow by clicking on the arrow tool at the top left of the window, or by 
clicking on a blank spot on the window.  The selection box indicates an 
object is selected.  Selection boxes for single objects have resize handles.

You can select multiple objects three ways:
• Hold down the Shift key and click on each of the objects
• When the pointer is an arrow, drag around the objects.  A dotted 

box follows the arrow.  Objects fully within the box will be selected when 
you release the mouse button.  

• Choose Select All from the Edit menu.
Resize handles aren’t on multiple selection boxes.

To deselect an object, click on it.  To deselect one object of a group, shift-
click on it.  To deselect a group within another group, shift-drag around the 
group to deselect.

• For more about this topic, refer to page(s) 134-136 in your PowerPoint User Manual.

An object with
a selection
box around it

Multiple objects with
selection boxes 
around them

Sales
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    Moving and Resizing an Object

To move an object, select it first, then:
1. Put the arrow pointer on one of the sides of the selection box 

(not on a solid corner).
2. Drag the arrow pointer and the object moves with it.

To move multiple objects, select them and drag any part of their 
multiple selection boxes.  All the objects move together maintaining 
their relative positions. 

Drag on the  
selection box.

A dotted outline
tracks the move.

Release the mouse
button when the
object is where you want it.

To resize an object, select it first, then drag on one of the solid 
resize handles.  A dotted outline shows the resizing.  Release the 
button and the object takes on its new size and shape.  Constrain 
with Shift to horizontally, vertically, or proportionally resize.  Choose 
Undo right away to change an object back to its earlier size.

• For more about this topic, refer to page(s) 187, 191 in your PowerPoint User Manual.
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    Pasting a Group of Objects as a Single Picture

You paste a group of objects as a picture so that you can:
• Treat them as a unit and maintain their relative positions
• Crop and resize the picture.

To paste objects as a picture:
1. Select them.
2. Choose Cut from the Edit menu.
3. Choose Paste as Picture from the Edit menu.
The picture is pasted to the center of the window.  You can now move 
it as a single object.

If you also want to keep the objects as individuals, make a copy first
——Paste as Picture cannot later be reversed!

Select the objects

After being pasted
as a picture, they’re
a single unit.

• For more about this topic, refer to page(s) 208-210 in your PowerPoint User Manual.
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WORKING WITH SLIDES

PowerPoint has specific features for working with your slides in a presentation.  For instance, 
the features include ways to rearrange the slides’ order and move slides between presentations 
so you can build one presentation from one or more previous presentations.  The next few 
slides explain how to do it. 

• For more about this topic, refer to page(s) 218-224 in your PowerPoint User Manual.
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    Adding Slide Borders

In the case of overheads, borders around the edges make them 
more visually appealing.  Always create the border on the Slide 
Master so it will appear on each slide automatically, and in the 
same position.

To get the border centered on the slide, choose Show Guides 
from the Draw menu, then click on the tool that you want for the 
border.  Put the crosshair at the intersection of the guides, hold 
down the option key and drag outward.  The border is centered 
on the slide area.

See the booklet that accompanies PowerPoint, Using 
PowerPoint Templates, for some border ideas.

Title Title

Some typical borders on slides

Option-drag from the center
of the guides centers the border.

• For more about this topic, refer to page(s) 196-201 in your PowerPoint User Manual.
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    Adding Slide Numbers, Date, and Time

• For more about this topic, refer to page(s) 125 in your PowerPoint User Manual.

The three special codes are:
Slide Number   34 (pound pound) ——also page numbers
Date                2/15/25  (slash slash)
Time               09:09:22 AM    (colon colon)

On the Slide Master, Notes Master, or Handout Page, create a label or 
word processing object containing any of the codes.  When you print 
the presentation, PowerPoint substitutes the date and time of the 
printing for the 2/15/25 and 09:09:22 AM  respectively.  On the slide 
and notes page, the 34 is the slide number.  On the handout page 
(which has more than one slide on it,) the 34 is the number of that 
handout page.
The date and time are used to help you keep track of drafts.  Their 
codes are usually removed before final printing.

Title

Page 34

The codes on the Slide Master
will be printed as number and
date on each slide.

2/15/2
5
 

Sales YTD

Page 384/20/88



• Choose Title Sorter from the View menu to see the Help list again.

    Arranging Slides
You arrange the order of the slides on the Slide Sorter view or the Title 
Sorter view.  There are two methods you can use:

• Select the slides or titles, then drag them.  Put the pointer where 
you want the slides to be relocated.  Release the mouse button.  If the 
pointer is on another slide or title, the rearranged slides will be put in 
front of it.

• Select the slides or titles, then choose Cut from the Edit menu.  Put 
the pointer where you want them to be re-positioned.  Choose Paste 
from the Edit menu.  The slides reappear.
Remember that at the Title Sorter view, you can select slides either by 
clicking on their titles, or by dragging over the slide numbers at the left 
side of the screen.  
When they’re rearranged, the slides and their corresponding notes 
pages are automatically re-numbered. 
 

Select a slide, then
drag or Cut it.

The slides will be 
rearranged, and re-
numbered as well.

• For more about this topic, refer to page(s) 220-221 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Copying Slides From One Presentation to Another

Using Copy and Paste, you can copy slides from previous presentations into 
your new one. 

1. Open your new presentation and the presentations with the slides that 
you want to copy.  Choose from the Window menu the presentation that has the 
slides you want to copy.

2. At either Sorter view, select the slides to copy, then choose Copy from 
the Edit menu.

3. Again from the window menu, choose the presentation that you want 
to copy slides to, and get to either Sorter view.

4. Put the pointer where you want the slides to be copied.
5. Choose Paste from the Edit menu.  The slides are copied to your new 

presentation.
The copied slides assume the format of the presentation they’re copied to.  If 
the formats are different, you may have to move objects on the copied slides to 
fit their new format.  

Presentation 1; copying
slides 4 and 5 

Presentation 2

Presentation 2; with
the copied slides

• For more about this topic, refer to page(s) 223-224 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Deleting Slides
You delete slides from the Slide Sorter view or the Title Sorter view. 
 You cannot delete slides from the Slide view.
Select the slides at the Slide Sorter view, or the Titles at the Title 
Sorter view.  Then:

Choose Clear from the Edit menu
or
Press the Backspace key.

The remaining slides rearrange themselves to fill in the space left 
by the deleted slides.
If you delete the wrong slides, choose Undo from the Edit menu 
right away before doing anything else.  The deleted slides will 
return.
You can also delete slides by selecting them and choosing Cut 
from the Edit menu.  You can then paste them to another 
presentation.

• For more about this topic, refer to page(s) 127-128 in your PowerPoint User Manual.

Select the slides
to delete; choose
Clear.

The slides are deleted
and the remaining ones
are renumbered
accordingly.



• Choose Title Sorter from the View menu to see the Help list again.

WRITING TEXT

PowerPoint has three ways to write text:  as an attached label, with the labeler tool, and with the 
word processor tool.  The text can have different fonts, styles, and colors.  It can also be 
indented or tabbed to create bulleted lists.  The next few slides in this Help Presentation explain 
the different ways you can write text.  

• For more about this topic, refer to page(s) 141-143 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Creating Text Objects

You create text objects just like you create diagram objects.  Click on either text tool and 
move the pointer onto the window.  For the labeler tool, the pointer becomes an insertion 
point like this   .   Put it where you want to start your label, click and begin typing.  For the 
word processor tool, the pointer becomes crosshairs      .  Drag to create a word processor 
box and begin typing.  

You can have 
more than one 
word processor 
box at a time...

...if, for 
example, you 
want two 
columns of text 
on a slide

Labels are for “hanging” text...

8

...or for labeling
    diagram objects

Behind the 8 Ball

And both types of text object
can be framed, filled, shadowed 
and the text can be in different

styles styles and  sizes and Colors!

• For more about this topic, refer to page(s) 146-150 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Indenting and Tabbing
You indent and tab text using the Text Ruler.  Select a word processor object, then choose Show Text 
Ruler on the text menu.  

Each indent symbol controls the indenting for a 
different level.  Drag a symbol along the ruler to 
set its indent distance.  To indent text, choose 
Indent » (right) or Indent « (left) from the Text 
menu and begin typing.  To indent (or “un-indent”) 
existing text, select it, then choose Indent » or 
Indent «.  The shape of the symbol indicates the 
left margin for its level like this:

texttexttext
 

texttextte
 

texttextte

 
texttext
texttextte
texttextte

To set tabs, drag a tab symbol from its box at the 
top right to underneath the ruler.  The plain triangle 
is a normal tab; the one with a dot in it is a decimal 
tab.  Numbers align on their decimal points at a 
decimal tab (text aligns at its right).   You can have 
multiple tabs for each word processor box.

To remove the ruler, click off the box.

Tab symbols
in place

Indent symbols

• For more about this topic, refer to page(s) 169-177 in your PowerPoint User Manual.

.
1



• Choose Title Sorter from the View menu to see the Help list again.

   Creating a Bullet Chart

Sales Factors

To sell effectively:
• Know the 

product
• Know the 

client
• Know the 

competition

This is a typical bullet chart
with indented text...

...and “hanging” bullets because
the text does not wrap around all
the way back to the bullet, 
like this: • know the

competition

To create this sample bullet chart, first create a word 
processing object.  Choose Show Text Ruler from the 
Text menu.  Drag the second indent marker, so its top 
is where you want the bullets to appear.  Drag the 
bottom of the marker to where you want the indented 
text to wrap to.  You can adjust the top and bottom of 
the marker independently.  Type the first line, To sell 
effectively.  Press return.  Then choose Indent >> from 
the Text menu.  Type the bullet, press the tab key, and 
type the bullet text.  Press Return at the end of each 
bullet text (not at the end of each line).  Type the next 
bullet, its text, and press Return.  Continue until all the 
bullets are done.  Choose Indent << to get the pointer 
back to the original left margin.  It’s easier than it 
sounds!!        

• For more about this topic, refer to page(s) 181-185 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Checking Spelling

Spelling

Change Ignore

Suggest Add

Added Words...

Check Spelling

Forcast

Forecast
Forest
Formats
Forests

Forgets

Forces

To check the spelling in your presentation, choose Spelling from 
the Text menu, and the Spelling dialog box appears.  

Click the Check Spelling button.

A misspelled word appears.  Edit it here and click Change 

To ignore the misspelling (for instance if it’s a proper name) click 
Ignore.  To add the word to your custom dictionary, click Add.

If you want PowerPoint to suggest the proper spelling, click 
Suggest and possible spellings appear here.  Select the spelling 
you want for the word and click Change.  Then click Check 
Spelling to search for the next misspelled word in the 
presentation.

To see the words in your custom dictionary, or to create a new 
custom dictionary, click Added Words.

• For more about this topic, refer to page(s) 154-160 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Find and Replace

Choose Find/Replace from the Text menu and this dialog box appears.  At the Find Text space, enter the 
text for PowerPoint to find.  At the Replace With space, enter the replacement text.  Click on either or both 
of the boxes, Match only Whole Words or Match Case.  Then click on one of the buttons to start the 
search. Find finds the next instance of text; Replace, then Find replaces the selected text and finds the 
next instance; Replace replaces the current selection; and Replace All replaces all instances.

• For more about this topic, refer to page(s) 150-153 in your PowerPoint User Manual.

Find Text:

Replace with:

Match only Whole Words Match Case

Replace, then Find Replace AllReplaceFind

Smythe

Smith

Find/Replace



• Choose Title Sorter from the View menu to see the Help list again.

GIVING AN ON-SCREEN PRESENTATION

• For more about this topic, refer to page(s) 227-232 in your PowerPoint User Manual.

So you can preview your slides and practice giving the presentation, or give a 
small group an on-screen presentation, PowerPoint can show your slides as a 
slide show.  Choose Slide Show from the File menu.  The dialog box that 
appears has choices for controlling the show, manually or automatically.  (You 
can choose a second monitor—or video projector—to receive just the show, if 
you have one attached.)  The slides are shown without the distractions of the 
menus at the top of the screen and without the window features.  All you see is 
the slide contents.  Click the mouse button to advance the slides manually, 
type ⌘ . (period) to stop the show.  (Other commands also are defined, and 
you can use an equivalent remote control device.)
To design your presentation for best appearance on the screen— so it will 
show at full size:   Specify the size of your computer screen in the For Screen 
box of the Page Setup dialog box.  The setting for a standard Mac Plus or Mac 
SE screen is 342 pixels tall by 512 pixels wide.  The setting for the larger 
Macintosh II screen is 480 pixels tall by 640 pixels wide. 

Slides appear on the
screen without any
distractions

Images can be inverted
by typing the letter I. 



• Choose Title Sorter from the View menu to see the Help list again.

SAVING A PRESENTATION

• For more about this topic, refer to page(s) 114-115, 290 in your PowerPoint User Manual.

The two commands Save and Save as on the File menu save your presentation.  Save replaces the 
existing presentation of the same name with the current version on your screen.  Save as saves the 
current version under another name.  PowerPoint also has a special feature to save a presentation as 
a series of scrapbook pictures that can then be “placed” into your other files, such as desktop 
publishing documents.  

• If your presentation is untitled,  PowerPoint will always show 
you the Save as dialog box.

• To save the presentation as scrapbook pictures, choose 
Save as, then click on the button labeled “Save Slides as 
Pictures in a Scrapbook.”  Make sure to first save the 
presentation normally.  When the slides are pictures in a 
scrapbook, they’re no longer a PowerPoint presentation and 
cannot be edited as such.

File

New...
Open...
Save S⌘
Save as...



• Choose Title Sorter from the View menu to see the Help list again.

PRESENTATIONS IN COLOR
With PowerPoint’s color capabilities, you can add the full range of 16.8 million colors to 
objects, text, and pictures copied from other presentations or programs.   PowerPoint runs on 
both monochrome and color Macs, and a presentation created on either can be edited on both 
kinds of machines.  Even if a presentation is originally created in color, you can still view it on a 
monochrome computer.  (Colors other than the background will be black on the monochrome 
screen.)  To print in color you’ll need a color printer, but you can also print in gray scale or 
inverse gray scale on a monochrome printer.  You can make color 35mm color slides from a 
PowerPoint presentation if you have a film recorder, or by using a slide production service 
such as Genigraphics®.

PowerPoint’s color has been designed to take full advantage of the color capabilities of the 
Mac II, dynamically handling the display of up to 16.8 million colors on the standard Mac II 
color monitor and standard Mac II video card.  For full display of 256 colors at a time—rather 
than only 16— your Mac II video card should have the Memory Expansion Kit installed 
(Apple’s part number M0213, available from dealers at a cost of about $150).

• For more about this topic, refer to Chapter 4 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    About the Color Scheme

The Color Scheme shows the eight basic colors you choose for a 
presentation.  Some important features of the color scheme:

• The first color is the slide background like this:

• The codes (like BU2, RD8) on the colors refer to the colors on 
the Change a Color dialog box.  

• Position on the scheme is important.  If you drag OR8 to RV8, 
objects colored with RV8 change to OR8 like this: 

• When you choose New Slide from the Edit menu, the new slide 
has the color scheme of the previous slide.  To use the scheme from 
another slide, make that slide active, choose Color Scheme from the Color 
menu, then make the new slide active, choose Color Scheme from the 
Window menu, click on Apply to this slide, and click on the Apply button.  A Reminder:  Choose an 

“Apply to” choice before 
clicking Apply.

• For more about this topic, refer to page(s) 245-259 in your PowerPoint User Manual.

BU8

WT

BU2

YW8

OR8

RD8

RV8

BU4



• Choose Title Sorter from the View menu to see the Help list again.

    Choosing a Color Scheme
Your Color Scheme choices (over 5,000) have been 
prepared by professional artists of Genigraphics® 
Corporation to enhance presentations. To choose a color 
scheme:

1. Choose Color Scheme from the Color menu.

2. Click on Choose a Scheme.

3. Choose a Background color.

4. Choose a Foreground color.

5. Choose a set of accent colors.

6. Click OK.

7. Choose one of the “Apply to” options.

8. Click Apply.

Note:  Extra colors are not affected by the change.  

When you change the Color
Scheme, and Apply it to All
Slides, all the objects change
to their new colors.  You don’t 
have to re-color objects
individually.

• For more about this topic, refer to page(s) 250-255 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Copying a Color Scheme From Another Presentation

Once you get the exact Color Scheme you want, you can reuse 
that scheme for a later presentation by copying it to the new 
presentation.

1. Open a New presentation.

2. Open the presentation that has the scheme you want.

3. Choose Color Scheme from the Color menu.

4. Make the New presentation active.

5. Choose Color Scheme from the Window menu.

6. Click Apply to all slides.

7. Click Apply. 

See the booklet, Using PowerPoint Templates for suggestions 
about re-using Color Schemes.

OR2

YO6

YO5

RD2

RD3

GN3

BU3

GY3

When you change
the Color scheme
by copying it 
from another
presentation...

BU6

RV3

BU5

BU1

RV4

GN3

BG4

BU3

...you get the exact 
colors you want 
without having to 
remember color 
codes.

• For more about this topic, refer to page(s) 264-266 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Coloring Objects and Text

The Text The Text

To change the color
of the fill from
 red to blue,
select the object,

choose Fill from the Color menu, then 
choose the color blue from the sub-menu.
Only the fill changes.  The other attributes 
remain their original colors.

The Text The Text
To change all of the
colors at the same
time, change the 
Color Scheme.

An example: You change individual colors by choosing 
from the Color menu.  The sub-menu shows 
your currently chosen color scheme. You can 
also use colors not on the menu by choosing 
Other on the sub-menu.  Select multiple 
objects to change all their colors at once.

Changing the Color Scheme provides you 
with a new set of color choices.  Applying the 
new scheme to a slide changes all of the 
colors to the new ones.  The change is 
relative to the position on the scheme.  So, if 
the first color on the scheme was red, and it is 
blue on the new scheme, all reds on the slide 
become blue. 

• For more about this topic, refer to page(s) 268-270, 276-278 in your PowerPoint Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Recoloring a Picture
Pictures copied to your presentation, including black-
and-white pictures, can be recolored.  You can change 
the black and white to colors, or if the picture contains 
patterns, you can change each pattern to a color.

1. Select the picture and choose Recolor Picture 
from the Color menu.

2. Click Change Colors or Change Patterns.

3. In the column labeled To, choose new colors 
for the patterns or colors in the picture.

4. Click Preview to see how the new colors work.

5. Click OK.

A Hint:  To change the colors and patterns, change 
patterns then repeat the process for colors. 

You can recolor a
picture copied from
another program or
presentation...

Change Colors
Solid black is
now red; black-
and-white patterns
are now yellow
and blue patterns.

Change Patterns
The three patterns
are changed to
three solid colors.

• For more about this topic, refer to page(s) 280-282 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Printing in Color
You’ll need a color printer in order to create color overhead slides. 
 However, you can print on the LaserWriter so that various gray 
tones represent the colors.  You choose how you want to print the 
colors from the Print dialog box.  Choose Print from the File 
menu.

• Normal Colors print in color on a color printer.  Colors 
print in black-and-white on any printer that doesn’t print in color 
(and all colors—even white—print black).

• Gray Scale substitutes gray tones for the colors (usually 
what you want for a LaserWriter).

• Inverse Gray Scale prints lighter grays for darker colors, 
and darker grays for lighter colors.  You usually use this option for 
printing slides that were originally created for a 35mm 
presentation.

The original slide

Gray Scale

Inverse Gray Scale

• For more about this topic, refer to page(s) 226, 297 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Color on a Monochrome Computer

Presentations that have been created in color can be 
shown on a monochrome computer, however, each 
color except the background color will be shown in 
black.  Therefore, if you expect a color presentation to 
be viewed on a monochrome computer, here are a few 
hints:

• Always keep the object’s fill color the same as 
the background (which is always shown as white), 
otherwise the whole object will appear as solid black.

• Use patterns, not colors, to distinguish 
information such as bar graphs.

TEXT

An object
in color...

..looks like this  on a
monochrome computer

TEXT

TEXT TEXT

• For more about this topic, refer to page(s) 278-279 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

REFERENCE TABLES

The reference tables on the next five slides in this presentation are copies 
of the tables in your PowerPoint user’s manual.  Having them here on-
screen saves you the time of looking for them in the manual.

• For more about this topic, refer to Chapter 5 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Constraint Keys for Rectangles and Ovals

Key Draw Resize Move

Shift Circles and squares only Vertical, horizontal Vertical or
or diagonal only horizontal

Option From center outward Maintains center No effect

Shift-Option Circles and squares only Vertical, horizontal, Vertical and
from center outward or diagonal only, and horizontal 

maintains center (same as Shift)

• For more about this topic, refer to page(s) 185-188 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Constraint Keys for Lines

Key Draw Resize Move

Shift Vertical, horizontal, and Change length but Vertical or
45° only. not angle. horizontal only

Option From center outward Both ends outward No change
from center; change
length and angle

Shift-Option Vertical, horizontal, and Both ends outward Vertical and
45° only from center from center; only horizontal 
outward along line (same as Shift)

• For more about this topic, refer to page(s) 189-192 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Keyboard Equivalents
Key Menu Function
⌘ S File Save the current presentation
⌘ Q File Quit PowerPoint
⌘ Z Edit Undo the last action
⌘ X, C, V Edit Cut, Copy, Paste the selected text, object, or slide
⌘ A Edit Select All
⌘ =, - Edit Bring to Front, Send to Back
⌘ N Edit Add a new slide to the presentation
⌘ D View Return to the current slide in the Slide view
⌘ E View Return to the current notes page in the Slide view
⌘ P, B, I, U Style Plain, Boldface, italicize, or underline the selected text
⌘ 1(2,3..) Style Change the style of selected text to the 1st (2nd, 3rd) listed
⌘ R, L Text Indent the selected text to the next indent level to the right, left
⌘ F Text Find next instance of word or phrase in Find/Replace dialog box
⌘ G Draw Show guides/Hide guides
⌘ Tab Move to next slide or notes page
⌘ Shift-Tab Move to previous slide or notes page

• For more about this topic, refer to page(s) 341-342 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Slide Show Keys

Function Mouse Keyboard

Show next slide Click Spacebar or N or Up arrow or Right arrow

Show previous slide ⌘  Click Backspace or P or Down arrow or Left arrow

Show slide number number Return or number Enter

Show/Hide Arrow pointer A or = (equals)

Invert Image I or / (slash)

Black/Unblack screen B or . (period)

Return to the Slide Show ⌘ . (Command period) or - (minus)                  dialog 
box

Start/Stop Automatic Show S or + (plus)

White/Unwhite screen W or , (comma)               

• For more about this topic, refer to page(s) 298-300 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Types of Pasting

What You’re                     Where You Are Pasting To
Pasting Sorter View Slide View

Slides Put at the insertion point All objects are added to the
or in front of the selected current slide 

in their same
slide. relative positions.

Objects Does not apply. Pasted at their original positions
on the new slide if the positions
are visible.  If the positions are 
not visible, the objects are 
pasted to the middle of the window.

Text Does not apply. Replaces selected text on the slide.

Picture Does not apply Pastes a new object centered in the
window.

• For more about this topic, refer to page(s) 301-303 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

TROUBLE-SHOOTING

The remaining slides in this Help Presentation offer assistance if things go wrong or if you 
need a hint about getting more work out of PowerPoint.  For example, one Help slide tells you 
how to make sure the fonts in your Macintosh System File are the right ones for PowerPoint, 
while another Help slide gives you hints to make printing go faster.   

• For more about this topic, refer to Chapter 5 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Be Sure You Have the Fonts You Need

• For more about this topic, refer to page(s) 12-13 in your PowerPoint User Manual.

The fonts available to PowerPoint are the ones installed into the System file that you use to start your 
Macintosh.  For instance, if your System file contains the fonts Helvetica and Times, those are the 
fonts you can use for text on your slides.  As long as the Macintosh you are using to print the 
presentation has those fonts in its System file, there's no problem.   But, if you create the presentation 
on a Macintosh that uses a System file with one set of fonts, and then later want to view the slides or 
print them on a Macintosh that uses a System file with different fonts, you may get some unexpected 
results.  (The same thing is true for individual sizes of each font.)

What will happen is this:  if a font that you used to create the text is not in the new System file, the 
Macintosh substitutes a different font.  That substituted font may be a slightly different size, and that 
will make the lines of text different lengths on the slides.  Thus, lines of text may be misaligned, or run 
out of the margins.  This problem with fonts occurs with any Macintosh program.  A similar problem is 
that some models of Macintosh handle fonts slightly differently than other models.  In any case, 
however, what you see on the screen is exactly what the Macintosh will print.

How do you solve this problem with fonts?  The easiest solution is to always use the same System file 
for creating, viewing, or printing presentations.  You can use the Font/DA mover to add additional fonts 
and sizes of fonts as needed.



• Choose Title Sorter from the View menu to see the Help list again.

    Covering One Object With Another

You make an object opaque by drawing it, then choosing Opaque from the Draw menu.

A problem may arise when the object that you want to do the covering is drawn before the object that 
you want to cover.  Objects are “stacked” in the order they’re drawn so that an object on the bottom of 
the stack can only be covered by one above it.

a
b
c
d

For instance, if you draw the objects in the order a,b,c,d, then object b can only cover 
object a, object c can cover a and b, and object d can cover them all.  But what if you want 
b to cover d?  Select object b (the one you want to do the covering), and choose Bring to 
Front from the Edit menu.  The selected object is put on top of the stack.  (Cutting and 
pasting an object does the same thing.)  To put an object at the bottom of the stack, select it 
and choose Send to Back from the Edit menu.  Being able to change the “stacking order” 
means that you do not have to keep track of which object to draw first.  Filled or shadowed  
objects are always opaque.  The title is always on the bottom.    

Opaque objects can cover other objects like this:

• For more about this topic, refer to page(s) 195-196 in your PowerPoint User Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Objects Off the Edge of a Slide

• For more about this topic, refer to page(s) 210-211 in your PowerPoint User Manual.

Objects can extend off the edge of a slide when you:  
• Paste From a file containing a large picture-area
• copy and paste a picture to a slide and it is too big

• change the slide orientation on the Page Setup and some 
slides are already in the other orientation

• copy slides from another presentation that has a different 
format than the receiving presentation.
Because the picture or object is off the slide, its resize handles 
will not be visible (although you can scroll to see them).  The 
solution is to choose a smaller view (usually 33%) from the View 
menu.  You will then see the edges—including the resize 
handles—of the large object or picture and can crop or resize it.  
If it is a picture, you will probably want to crop it (hold down the 
⌘  key while dragging the resize handle) to preserve its 
proportions.

If the object is too big,
choose a small view (33%)
then crop or resize it.

Title

Slide

Object



• Choose Title Sorter from the View menu to see the Help list again.

    Printing
Sometimes, a LaserWriter or ImageWriter may take a while to print a slide, especially if it contains 
detailed graphics.  To get your presentation printed as quickly as possible: 

LaserWriter

1. On the Page Setup dialog box, turn off the Smoothing option.   When the Smoothing option is 
turned on,  bit-mapped graphics (such as those created by MacPaint or fonts that are installed in your 
system file but not installed in your printer) will require your printer to do more calculations and will 
therefore take longer to print. 

  Also, TURN OFF “Print Bitmaps Faster” for the usual landscape-orientation presentations (this option 
really makes them print, not faster, but SLOWER!).

2. Large objects print more slowly if they are opaque,  or if they contain patterns  (but the gray 
scale patterns—the top four lines on the Pattern menu—don’t have this effect).

ImageWriter

1. On the Print dialog box, choose the Faster option.  

Note:  Some application programs state in their manual that they may take a long time to print.  If you 
copy information from one of those programs, print times for your slides will also be long.

• For more about this topic, refer to page(s) 224-227, 296-298 in your PowerPoint Manual.



• Choose Title Sorter from the View menu to see the Help list again.

    Requested Memory under MultiFinder
The suggested memory size for running PowerPoint 2.0, and the amount that PowerPoint requests under 
MultiFinder, is 750K.  PowerPoint will actually run in less memory for presentations of modest size, 
especially on a Mac Plus or a Mac SE.  For very large presentations, or for working on a number of 
presentations simultaneously, PowerPoint may require much more memory (and will use as much as it is 
given).  Especially on a 1-Megabyte Mac Plus or Mac SE, the suggested size should be reset. 

The application memory under MultiFinder is set by selecting PowerPoint (when it is not running, and on a 
disk that is write-enabled) and choosing Get Info from MultiFinder's File menu; the Application Memory Size 
can be typed into the box at the bottom of the window.

• On a Mac Plus or SE with 1 Megabyte:  (normal) use MultiFinder and set memory in the range of 
400K to 500K; (power) to use more than 500K, don't use MultiFinder. 

• On a Mac Plus or SE with 2 Megabytes: (normal) use MultiFinder and set memory in the range of 
400K to 600K; (power) use MultiFinder and set memory as needed.

• On a Mac II with 1 Megabyte: (normal) don't use MultiFinder; (power) buy more memory.

• On a Mac II with 2 Megabytes or more: (normal) Use MultiFinder and set memory in the range of 
500K to 800K; (power) use MultiFinder and set memory as large as needed.


	Slide 1
	Slide 2
	Slide 3
	Slide 4
	Slide 5
	Slide 6
	Slide 7
	Slide 8
	Slide 9
	Slide 10
	Slide 11
	Slide 12
	Slide 13
	Slide 14
	Slide 15
	Slide 16
	Slide 17
	Slide 18
	Slide 19
	Slide 20
	Slide 21
	Slide 22
	Slide 23
	Slide 24
	Slide 25
	Slide 26
	Slide 27
	Slide 28
	Slide 29
	Slide 30
	Slide 31
	Slide 32
	Slide 33
	Slide 34
	Slide 35
	Slide 36
	Slide 37
	Slide 38
	Slide 39
	Slide 40
	Slide 41
	Slide 42
	Slide 43
	Slide 44
	Slide 45
	Slide 46
	Slide 47
	Slide 48
	Slide 49
	Slide 50
	Slide 51
	Slide 52
	Slide 53
	Slide 54
	Slide 55
	Slide 56
	Slide 57
	Slide 58
	Slide 59
	Slide 60
	Slide 61
	Slide 62
	Slide 63
	Slide 64
	Slide 65

