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Drawing Diagrams
You can create diagrams quickly and easily with the software. To do this, you can
use the following tools:

• Industry solution templates

• Symbols

• Connectors

• Annotations

Tip  You can learn how to draw a diagram with a tutorial in the Learning Center.
Click the Help menu and then click Learning Center.

 

Templates (Illustration contains content delivered in full product.)

When you first open the software, you can select a template based on the industry
solution that you need. The best templates to select for drawing diagrams are in the
General Diagramming template folder. For example, you can select the Network
Diagram (Imperial).igr template.

When you open the Network Diagram (Imperial).igr template, the Schematic toolbar
automatically displays the buttons that you would need most often to create a
diagram. These commands include Connector, Grid Display, Grid Snap, Text Box,
and others.

Tip  You can still draw lines, circles, and so forth with buttons on the Draw
toolbar. To display the Draw toolbar, you can click Toolbars on the View menu.
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Connectors
The Connector button on the Schematic toolbar allows you to place connectors
anywhere you need. You can connect lines, circles, symbols, or points in free
space.

There are special connector styles that you can use in the diagram. Some examples
in the Network Diagram template include Thick line, Normal line, and Dashed line.
On the Connector ribbon bar, you can click the style that you want in the Style box.

 

On the Connector ribbon bar, you can also select the line start and line end
terminators that you want. The following connectors display some of the different
types of terminators that you can apply.

 

Symbols (Illustration contains content delivered in full product.)

The template automatically displays the symbols that you need for a diagram in the
Symbol Explorer. For example, the Network Diagram template offers you many kinds
of symbols to include modems, servers, annotation, and others.

 

To place these symbols, you can drag them from the Symbol Explorer into the
document.
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You can manipulate symbols with special handles that appear when you select the
symbol. (Illustration contains content delivered in full product.)

• Black boxes on the outside corners of the range box lines represent scale
handles (A). You can drag a scale handle to resize the entire symbol.

• Yellow boxes in the middle of the range box lines represent standard
parametric handles (B). You can drag a parametric handle to resize part of the
symbol.

• A green plus sign represents a mirror handle (C). You can drag a mirror handle
to create a copy of the symbol directly horizontal or vertical to the original
symbol.

• A large green circle represents a rotate handle (D). You can drag this handle to
rotate the entire symbol. Specific increments are displayed by the pointer while
you rotate the symbol.

• A series of small green circles represents drag points (E). You can use these
points to attach the symbol at a precise point to another symbol or element.

• A small green lock represents a lock handle (F). You can click the lock handle
to unlock the symbol. Unlocking allows you to move a symbol away from the
element to which the symbol was associated.

Tip  A lock handle appears only if you drag the symbol to an element with one
of the drag points on the symbol.

Text and Labels
You can also drag labels from the Symbol Explorer. For example, the Network
Diagram template offers a collection of Smart Labels in the \Modems folder.

Some Smart Labels display a question mark in the Symbol Explorer. You can also
double-click on some Smart Labels and edit the text.
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Smart Labels can assume the attributes of the element or symbol that you drag the
Smart Label to. You can edit the attributes of the Smart Label in the Attribute
Viewer. (Illustrations contain content delivered in full product.)

 

If you want to quickly add text that is associated to an element, you can double-
click any element in the diagram. A text label appears in the center or below the
element. When you type in text and press Enter, the text label orients itself with the
element. When you move the element, the text label moves with it.

Tip  To add text that is not associated to an element, you can click the Text Box
button on the Schematic toolbar.

Grids
You can use a grid view and grid snap to place the items in your diagram at precise
intervals. You can view the grid by clicking the Grid Display option on the View
menu. When you set the Grid Snap option on the View menu, elements always
align with the grid lines or nearest intersection of the grid lines.
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Reports
The software delivers some reports that you can update automatically when you
add symbols to a document. The reports work with symbols that have specific
attributes assigned to them. You must have Microsoft® Excel™ 97 or later
installed on your computer. The software includes several example reports.

Tip  For detailed information about symbols, connectors, and annotations, see the
following chapters:

• Using Symbols

• Drawing Elements

• Using Annotations and Fonts



Drawing Elements Chapter 3

87

Connectors and Symbols
Some symbols are created with connect points. When you attach a connector to a
connect point, the connector automatically attaches to the point at a predefined
angle. Otherwise, the connector locates and attaches to a keypoint or point along
any elements in the symbol.

The connect points appear as red circles with Xs. The keypoints appear as gray
circles with Xs.

 

Tip  If you press the Alt key while drawing a connector, the connector attaches to a
connect point at any angle.
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Procedures to Explore in On-line Help
• Create a Symbol

• Edit a Symbol

• Place a Connector

• Place a Smart Label

• Create a Text Label

• Edit Attributes
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Drawing Basic Elements
An element is any line, circle, or other part of the drawing. The Draw toolbar on the
left side of the drawing sheet contains most of the buttons that you can use to draw
any type of basic geometric element—freeform shapes, lines, arcs, circles, and so
forth.

 

You can place most basic elements with just a few clicks. For example, if you want
to place a line, you can click the Line/Arc Continuous button on the Draw toolbar.
Then, you click two points to indicate where to start and finish the line. If you do
not want to place another line, you click the right mouse button to end the
operation.

Tip  Clicking the right mouse button ends most operations in the software.

You can also place the line by clicking the Line/Arc Continuous button and then
clicking and dragging the pointer. When you release the mouse, the line appears on
the drawing sheet. With this method, you drag the cursor as if it were a pen. You
can draw most elements, such as rectangles, circles, and arcs, with this method,
sometimes called mouse-down drawing. The mouse-down method is typically used
to place most elements in conceptual sketching and modification.

If you want to place a precise line, you can click the Line/Arc Continuous button,
type values into the ribbon bar that appears, and then press ENTER. You can then
click on the drawing sheet to place the line. This method, sometimes called mouse-
up drawing, is typically used for precision placement and when you want to draw
elements that are related to each other.

In some cases, you might want to click points on the drawing sheet and type values
in the ribbon bar to place an element. For example, you can click the Line/Arc
Continuous button and then type 3.0 in the Length box on the ribbon bar box and
press ENTER to lock the length value.
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When a line that is three inches long appears next to the pointer, you can click
anywhere on the drawing sheet to indicate where to place one end of the line. Then,
you move the line around and click again to set the line’s orientation angle.

If you do not like the results of what you drew, you can click the Undo button on
the Main toolbar. If you want to repeat an action, you click the Redo button on the
Main toolbar.
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Drawing Lines
If you want to place a line, you click the Line/Arc Continuous button on the Draw
toolbar. Then, you click a point on the drawing sheet to indicate where to start the
line. You click a second point to indicate where to end the line. If you do not want
to place another line, you click the right mouse button to end the operation.

You can also place the line by clicking the Line/Arc Continuous button and then
clicking and dragging the pointer. When you release the mouse, the line appears on
the drawing sheet.

If you want to place a precise line, you can click the Line/Arc Continuous button,
type values into the ribbon bar that appears, and then press ENTER. You then click
on the drawing sheet to place the line.

You can also use a combination of clicks and ribbon bar input to place the line. For
example, you can type a line length in the ribbon bar box to lock the length value
and then set the line’s orientation angle graphically. You can set the color and line
type by clicking a style in the Style list box.
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Connecting Elements
You can use a connector to join two elements together. The Connector button on
the Schematic toolbar or Draw toolbar provides a convenient way to draw
schematic. (Illustration below contains content delivered in full product.)

 

The Connector button allows you to place connectors anywhere you need. You can
connect lines, circles, symbols, or points in free space.

 

When you point to an element or symbol, the connect points appear as red circles
with Xs. The keypoints appear as gray circles with Xs.

You can also modify the connector after you place it by inserting or moving a line
segment, inserting or moving a vertex, or moving an element with a connector.

There are special connector styles that you can use in the diagram. On the
Connector ribbon bar, you can click the style that you want in the Style box. You
can then draw a connector that displays the line style that you selected. For
example, in documents based on the Process Block Diagram template, you can
select Future and Phantom in the Line Style box on the ribbon bar. When you
select Future and draw a connector, the connector appears as a dashed line.

 

When you select Phantom and draw a connector, it appears grayed out; the
connector is highlighted when you point to it.
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Besides line styles, you can also select line start and line end terminators on the
Connector ribbon bar. The following connectors display some of the different types
of terminators that you can apply.
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Drawing Circles, Arcs, and Ellipses
If you want to draw a circle, you can click the Circle By Center Point button on the
Draw toolbar. Then, you click a point to define the center of the circle. To place the
circle, you click a second point to define the distance of the circle radius from the
first point. You can use other commands on the Draw toolbar to place arcs,
ellipses, and other types of circles.

Besides clicking the pointer, you can also place circles by clicking the Circle By
Center Point button and then holding the mouse button down and drawing
freehand. After you close the loop, the circle appears.

You can also place a precise circle by clicking the Circle By Center Point button
and then typing values into the ribbon bar. After you press Enter, a circle appears
around the pointer. You can then place the defined circle by clicking the point you
want on the drawing sheet.
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 Drawing Squares and Rectangles
To draw a rectangle or square, you click the Rectangle button on the Draw toolbar.
Then, you click two different points to define the rectangle. If you want to precisely
define the dimensions of the square, you can type values into the ribbon bar and
press Enter.

If you place dimensions on a rectangle, these are always driven dimensions. This
means that if you edit the dimensional value of the dimension, the rectangle does
not change. You need to edit the values on the rectangle ribbon bar to change the
rectangle. Also, you cannot ungroup a rectangle into individual lines.

Tip  If you want to place a rectangle that has driving dimensions, you need to place
four separate lines in the shape of a rectangle by selecting the Line/Arc Continuous
button on the Draw toolbar.
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Drawing FreeForm Shapes
As you draw, you can place precisely defined lines, arcs, and circles by clicking
and typing values in the ribbon bar. You can also use tools to quickly sketch a
design and let the software convert it into a precision drawing.

FreeSketch and FreeForm allow you to quickly place fluid lines and let the
software convert these into precision shapes. FreeSketch draws lines, arcs, circles,
and rectangles, and FreeForm draws curves (splines).

You can begin sketching anywhere on the drawing sheet. You can draw in free
space or use key points or end points of elements as reference points.

How FreeSketch and FreeForm Work
As you drag the pointer, a rough sketch of your design appears. When you release
the pointer, the software recognizes the shapes in your sketch and turns the sketch
into a precise drawing. You can control the accuracy of the shape recognition using
the ribbon bar options.
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FreeSketch and FreeForm Options
The FreeSketch Adjust options control how closely FreeSketch interprets mouse
movements. When Adjust On is set, the software interprets all lines as either
horizontal or vertical, and all arcs as tangent. The first figure shows how the
software interprets a rough sketch when Adjust On is set.

The next figure shows how the software interprets a rough sketch when Adjust Off
is set.

The FreeForm Smoothing options controls how closely the software interprets
mouse movements when drawing curves. The first figure shows how FreeForm
interprets a rough sketch when Smoothing On is set.

The next figure shows how the software interprets a rough sketch when Smoothing
Off is set.
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Isometric Drawings
If you want to create 2D drawings that represent 3D elements, such as cubes, you
can create an isometric drawing. An isometric drawing is not a true 3D drawing,
because you cannot view the drawing in perspective or from another angle.
However, you can create a 3D effect by aligning the elements and objects in a
drawing along three major axes.

The software supplies several tools to create these types of documents:

• Isometric Rectangle button

• Isometric Circle button

• Isometric Line button

• Segmented Styles button

Tip  To access these commands, you must place them on a toolbar or menu with
the Customize command on the Tools menu. On the Toolbars tab of the Customize
dialog box, click the Draw category.

You can also access dimension styles that you configure to appear at an angle for
isometric drawings. These styles are available for any type of dimension, except for
chained dimensions and angular dimensions. You can create a document based on
one of the Technical Drawing templates and access these dimension styles.

Special fonts for isometric drawings are also available in any template. These fonts
are displayed at an angle. The fonts are stored in a resource file in the following
location: <Drive Letter>:\PROGRAM
FILES\SMARTSKETCH\TEMPLATE\STYLES\ISOFONTS.RSC. You must set
the location for these fonts on the File Locations tab of the Options dialog box.
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Procedures to Explore in On-line Help
• Draw a Line

• Draw a Circle by Defining 3 Points

• Draw an Arc by Defining 3 Points

• Draw a Curve

• Draw an Ellipse by Defining 3 Points

• Draw with FreeSketch

• Draw a Rectangle or Square
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Using Feedback from the Pointer as You Draw
As you move the pointer, the software automatically updates values in the ribbon
bar, giving you constant feedback on the size and position of the element you are
drawing. As you draw, the software shows a temporary, dynamic display of the
element you are drawing by the pointer––this feedback is called a relationship
indicator. This temporary display shows the look of the elements if you place the
element at the current location.

The software gives you more information about the element that you are drawing
by displaying relationships between the temporary, dynamic element and the
following items:

• Other elements in the drawing

• Horizontal and vertical orientations

• Origin of the element that you are drawing

When the software recognizes a relationship, it displays a relationship indicator at
the pointer. As you move the pointer, the software updates the indicator to show
new relationships. If a relationship indicator appears by the pointer when you click
to draw the element, the software applies that relationship to the element.

Relationship Relationship Indicator

End point

Midpoint

Intersection

Horizontal

Vertical
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Point On Element

Perpendicular

Parallel

Tangent

Center

For example, if the horizontal relationship indicator appears when you click to
place the second end point of a line, then the line is exactly horizontal.

 

Relationships
You can set the types of relationships you want the software to recognize with the
SmartSketch Settings command on the Tools menu. The software can recognize
one or two relationships at a time. When the software recognizes two relationships,
it displays both relationship indicators at the cursor.

Locate Zone
You do not have to move the pointer to an exact position for the software to
recognize a relationship. The software recognizes relationships for any element
within the locate zone of the pointer. The circle around the pointer crosshair or at
the end of the pointer arrow indicates the locate zone. You can change the size of
the locate zone with the SmartSketch Settings command on the Tools menu.
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Infinite Elements
The software recognizes the Point On Element relationship for lines and arcs as if
these elements were infinite. In the following example, the software recognizes a
Point On Element relationship when you position the pointer directly over an
element and also when you move the pointer off the element.
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Intent Zones
As you draw and modify elements, small quadrants called intent zones appear next
to the pointer. The software uses intent zones to interpret your intentions as you
draw. Intent zones allow you to draw and modify elements many ways using few
commands. You do not need to select a different command for every type of
element.

How Intent Zones Work
When you click to begin drawing certain elements, the software divides the region
around the clicked position into intent zones. By moving the pointer into one of
these intent zones on the way to your next click location, you can tell the software
what you want to do next.

The last intent zone you move the pointer into is the active zone. To change the
active intent zone, move the mouse cursor into the zone you want to use, then move
it to the position where you want to click next. You can change the size of the
intent zones with the SmartSketch Settings command on the Tools menu.

Drawing Tangent or Perpendicular Arcs
You can use intent zones to change the result of the Tangent Arc command. To
draw an arc tangent to a line, first click a point on the line to place the first end
point of the arc. Then move the pointer through the tangent intent zone and click to
place the second end point of the arc.

If you want to draw a perpendicular arc instead, you can move the pointer back into
the intent zone region and out through the perpendicular zone before clicking to
place the second end point of the arc. The arc is then perpendicular to the line.

You can also use intent zones to define the arc direction.
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Drawing Arcs by Three Points
When you use the Arc by 3 Points command, intent zones allow you to input the
three points in any order. You can also use intent zones to change the arc direction.

Drawing Lines Tangent or Connected to Curved
Elements
Using intent zones with the Line/Arc Continuous command, you can draw a line
tangent to a circle or arc. Or you can draw a line that is connected to the circle or
arc, but not tangent to it.
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Using Relationships as You Draw
You can use relationships to capture and remember your design intent as your
sketch. You can make your drawings associative by applying those relationships—
or you can sketch designs that do not use relationships.

How Relationships Affect a Drawing
You can move and change an element that does not use relationships in various
ways without affecting other parts of the design. For example, when no
relationships exist between two lines, you can move and change each line without
affecting the other.

When you modify a part of a drawing that has a relationship to another part of the
drawing, the other part updates automatically. For example, if you apply a
perpendicular relationship between the two lines and move one line, the other line
moves with it. The software remembers the relationship between these two
elements and always maintains the perpendicular relationship between the lines.
You can manipulate either of the two lines and the software will move or modify
the line automatically to maintain the relationship.

Applying and maintaining relationships in the design simplifies changes to the
design later. In the following drawing, all the relationships were automatically
established as the design took shape on the drawing sheet. If you want to change
the design, you simply modify one segment of it and all the relationships are
maintained.
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Applying and Maintaining Relationships
You can place elements that are related to each other as you draw. First, you must
set the Maintain Relationships option on the Tools menu. Then, as you click
commands on the Draw toolbar and place lines, arcs, and circles, you should watch
the relationship indicators that appear by the pointer. When a relationship indicator
appears by the pointer, you can click to apply that relationship to the element that
you are drawing.

Visualizing Maintained Relationships.
When you apply relationships, relationship handles appear on the related elements.
The handles are symbols that show how elements are related. You can display or
hide the relationship handles in your drawings by setting or clearing the
Relationship Handles option on the Tools menu.

Relationship Relationship Handle

Colinear

Connect

Concentric

Equal

Horizontal/Vertical

Tangent

Symmetric
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Parallel

Perpendicular

Lock

For example, the following four lines appear with relationship handles (A) turned
off and with relationship handles (B) displayed.

Applying Relationships to Existing Geometry
You can apply relationships to geometry after you place it with the buttons on the
Relationship toolbar. These buttons include parallel, tangent, connect, and so on.
You can use relationships created with these buttons if you set the Maintain
Relationships option on the Tools menu.

Removing Relationships
You can quit using all the relationships that you have applied to the drawing if you
clear the Maintain Relationships option. You can also remove individual
relationships by selecting a relationship handle and deleting it. Clearing the
Relationship Handles option on the Tools menu hides the handles, but the
relationships are still maintained and used in the design.

When to Maintain Relationships
Maintaining relationships makes designing more productive and revisions much
easier. However, relationships can slow drawing and changes on large data sets.
You should decide whether to use relationships depending on the speed of your
computer and the importance of easy revision.

For conceptual sketching and diagrams, you might want to use relationships by
setting the Maintain Relationships option. This method allows you to quickly get
your ideas on paper and revise them easily using direct modification and driving
dimensions. The kinds of projects in which you might want to use relationships
include mechanical concepts, architectural details, layouts, and schematic
diagrams.
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When to Design Without Relationships
For more complex projects where you initially need to draw with precision, you
should not use relationships in the document. You can then draw with precision by
using the PinPoint tool and entering values on ribbon bars. You can still use
relationships within symbols. The kinds of projects in which you might want to
draw without relationships include multiple-view drawings, floor plans, maps, and
detailed designs.

Note  If you switch between using relationships and not using them while you
draw, you can receive confusing results.

Example: Draw a Horizontal Line

You can use relationships to draw a line that is exactly horizontal. You can apply a
horizontal relationship as you draw the line, or draw the line without a horizontal
relationship.

1. Click Tools > SmartSketch Settings.

2. On the Relationships tab, set the Horizontal Or Vertical option, and then
click OK.

3. On the Draw toolbar, click the Line/Arc Continuous button.

4. Click where you want to place the first end point of the line, anywhere in the
application window.

5. Move the pointer around in the window. Notice that the dynamic line display
always extends from the end point you just placed to the current cursor
position. You may also see relationship indicators displayed at the cursor.

6. Move the pointer to make the dynamic line approximately horizontal.
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7. When the horizontal relationship indicator is displayed at the pointer, click to
place the second end point.

 

If the Maintain Relationships option on the Tools menu is set, the software
places a horizontal relationship handle on the new line.

If you do not want to place a horizontal relationship, you can follow the same
procedure with the Maintain Relationships option cleared. The line will still be
exactly horizontal when you draw it.

Note  Relationship handles can be displayed or hidden with the Relationship
Handles button on the Relationship toolbar.
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Example: Draw a Line

You can use relationships to connect an element you are drawing with an existing
element. You can apply a connect relationship as you draw the lines, or draw the
line without a connect relationship.  

 

1. Click Tools > SmartSketch Settings.

2. On the Relationships tab, set the End Point option, and then click OK.

3. On the Draw toolbar, click the Line/Arc Continuous button.

4. Move the pointer to the end of a line in the application window. The
software displays the End Point relationship indicator at the cursor.

5. While the software displays the relationship indicator, click to place the first
end point of the new line. This end point is connected to the end point of the
previous line.

 

6. Click where you want to place the second end point of the new line.

7. The new line and the previous line have connected end points.

 

If the Maintain Relationships option on the Tools menu is set, the software
places a connect relationship handle at the point where the two lines connect.

 

If you do not want to place a connect relationship, you can follow the same
procedure with the Maintain Relationships option cleared. The end points of the
two lines will still be exactly coincident when you draw them.
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Note  Relationship handles can be displayed or hidden with the Relationship
Handles button on the Relationship toolbar.
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Procedures to Explore in On-line Help
• Draw with Relationships

• Display or Hide Relationship Handles

• Maintain Relationships
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Symbols Overview
Symbols increase drawing productivity because they allow you to access existing
graphic data quickly and easily. With a symbol, you can place graphic information
repeatedly without re-creating it. Symbols save you time by eliminating the need to
re-create information, as well as help you maintain accurate graphic data
throughout a project. Symbols are contained in documents with an .SYM
extension.

Parametric symbols are also available. You can modify these symbols by changing
a parameter value.
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Creating Symbols
A symbol is a document with an .SYM extension. You can create a symbol by
selecting any geometry and clicking the Create Symbol button on the Draw toolbar.
You must then define the origin by clicking the point that you want in the select set.
After defining the origin, you can save the select set as a symbol with the Save As
dialog box.

Symbols that you create display the following default behaviors:

• 90 degree rotation angles

• Automatic alignment with a target element or object when the symbol is placed
in a document

• Automatic association with a target element or object.
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The Symbol Explorer
You can use the Symbol Explorer to drag symbols from a directory to the current
document. You can also use the Symbol Explorer to view document directories on
your computer or a network drive. The Symbol Explorer can also display HTML
pages on the World Wide Web or your computer.

When you click the Symbol Explorer button on the Main toolbar, the Symbol
Explorer is displayed on the right side of the main window. The buttons on the
Symbol Explorer are similar to the ones in the Windows Explorer. For example,
you can click a Favorites button to go to one of your favorite web sites.

If you set the path of the Symbol Explorer to point to a directory, you see a tree
view, the contents of the directory, and the Attribute Viewer. If you set the path to
an HTML page, you see the contents of that page, if Microsoft Internet Explorer
3.0 or later is installed. If Internet Explorer is not installed, then the software
prompts you to install it.

Placing Symbols
The main use of the Symbol Explorer is to drag symbols from a directory to the
current document. The Symbol Explorer acts much like the Windows Explorer. To
view symbols, you can type the name of the directory in the Address Box at the top
of the Symbol Explorer; or you can click the Explore Elsewhere button and set the
directory path that the Symbol Explorer looks in.

If you click the Home button at the top of the Symbol Explorer, it displays the
home page for the symbols that are associated with the template on which the
active document is based. You can override this property by setting a new address
with the Properties command on the File menu. On the Properties dialog box, you
click the Browser tab to set the option.

After the Symbol Explorer displays the symbols, you can drag a symbol from the
Symbol Explorer to the current document.

Displaying HTML Pages
The Symbol Explorer can display HTML pages on the World Wide Web or your
computer. To view an HTML page in the Symbol Explorer, you must enter the
entire directory path and filename in the Address Box at the top of the Symbol
Explorer.
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To view HTML pages on the World Wide Web, you must type the HTTP address
in the Address Box at the top of the Symbol Explorer. When you do this, the
Symbol Explorer displays the HTML page of the address you entered. The Symbol
Explorer can display any web site that you have permissions to access.

Caution  HTML pages appear only if Microsoft Internet Explorer 3.0 or later is
installed.

Searching Document Directories
You can view the Symbols of any directory on your computer or the network with
the Symbol Explorer. You can type the path of the directory in the Address Box; or
you can click the Browse button and set the directory path on the dialog box.

After the Symbol Explorer displays the symbols of the directory that you want, you
can double-click any document, much like the Windows Explorer, and the software
that created the document opens and displays the document for editing.

You can drag and drop any document created by software that supports OLE 2.0
into the current document. These documents can include .IGR, .DGN, .DWG, and
.DXF types.

Symbol Explorer Settings
When you set options for the Symbol Explorer, the current document stores and
uses these the next time you open the document. You can define a different home
page for each document in the Symbol Explorer with the Properties command on
the File menu.

On the Properties dialog box, you click the Browser tab to set the option. When
you set the address for the home page on the Properties dialog box, the Symbol
Explorer goes to that address when you click the Home button at the top of the
Symbol Explorer.

Tip  The address can be a directory on a local or network drive or an HTTP
address to a web page.
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Placing Symbols
To place a symbol, you can drag the symbol from the Symbol Explorer or
Windows Explorer into the current document.

Symbol Libraries
After starting the software, you can open a template or document. For most
standard templates, the Symbol Explorer automatically opens and displays a default
directory for all the symbols that would be appropriate to use with that template.
For example, templates in the Process category point to directories with process
diagram symbols.

Tip  To open the Symbol Explorer, you can also click the Symbol Explorer button
on the Main toolbar. You might need to click the Home button in the Symbol
Explorer. The Home path is stored on the Browser tab of the File Properties dialog
box.

Dragging a Symbol
When you click a symbol in the Symbol Explorer to drag it into a document, the
pointer attaches to the origin of the symbol by default to drag it in. At that instance,
the origin is the drag point.

Some symbols contain more than one drag point. These appear as green dots on the
symbol. These drag points are useful if you want to place a symbol using a
particular part of the symbol.  You can change to another drag point by pressing the
Up and Down arrow keys on the keyboard.

By default, every element in a symbol does not appear when you place the symbol
in a document. For example, if you place a symbol that contains dimensions in a
document, the dimensions are not displayed.
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Discovering Symbol Behavior and Handles
Symbols can display different types of behavior depending on how the symbol was
created. When you drag and drop a symbol into a document, you can check out
different characteristics of the symbol to see what it can do.

Depending on how the symbol was created, some symbols automatically ungroup
into individual elements in the document when you place the symbol. For example,
if you place a symbol that contains a circle and a rectangle in a document, the
symbol immediately ungroups. The parts of the symbol, the circle and rectangle,
act as a separate circle and rectangle, not a symbol.

Labels
Some symbols have a label that appears as a question mark under the symbol. To
change the text in the label, you can double-click the question mark. When the
Attribute Viewer appears, you can then edit the text in the Value column and press
Enter.

Commands on the Shortcut Menu
While the symbol is selected, right-click and look at the shortcut menu. Some
symbols have special commands on the shortcut menu that run custom processes
for the symbol. If the shortcut menu has a Help command, you can access a Help
file that displays special information about the symbol.

Commands on the shortcut menu can also activate different representations of the
same symbol. For example, you can access different representations of the same
valve symbol, with a flanged globe, a welded globe, and so forth.

  

Drop Points
You can move the symbol around in the document with the Select Tool. You can
discover special behaviors by dragging the symbol over an element or another
symbol.
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Some symbols automatically connect to other symbols. These symbols were
created with drop points for symbol-to-symbol connections. When you click a drag
point on a symbol and drag it over another symbol, the drop points appear as red
dots. A bull’s eye appears when you exactly align the drag point and drop point.
You can then attach the symbol to the other at a precision point.

ToolTips
If you pass the pointer over the drop points on a symbol, you might see ToolTips.
These ToolTips display special information about different parts or points on the
symbol. For example, the serial number for networking diagramming equipment
can appear in a ToolTip.

 

Custom Processes
Some symbols actually run special processes when you drag them, double-click
them, or perform other actions. If you select the symbol and click the right mouse
button, you might also see special custom commands for the symbol on the
shortcut menu.

Displaying Attributes on an Element
Some symbols can display attributes that are assigned to an element. When you
drag the symbol to the element with attributes, the symbol automatically displays
the values of those attributes.

Handles
When you select a symbol, different handles appear on the symbol.



Using Symbols Chapter 6

123

Some symbols have several different kinds of handles:

 

• Black boxes on the outside corners of the range box lines represent scale
handles (A). You can drag a scale handle to resize the entire symbol.

• Yellow boxes in the middle of the range box lines represent standard
parametric handles (B). You can drag a parametric handle to resize part of the
symbol.

• A green plus sign represents a mirror handle (C). You can drag a mirror handle
to create a copy of the symbol directly horizontal or vertical to the original
symbol.

• A large green circle represents a rotate handle (D). You can drag this handle to
rotate the entire symbol. Specific increments are displayed by the pointer while
you rotate the symbol.

• A series of small green circles represents drag points (E). You can use these
points to attach the symbol at a precise point to another symbol or element.

• A small green lock represents a lock handle (F). You can click the lock handle
to unlock the symbol. Unlocking allows you to move a symbol away from the
element to which the symbol was associated.

Tip  A lock handle appears only if you drag the symbol to an element with one
of the drag points on the symbol.
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Editing Symbols
To edit a symbol, you should select it and click Open on the shortcut menu.

Tip  To display the shortcut menu, you can highlight a symbol with the pointer and
then click the right mouse button.

For some special symbols, you can also edit the properties and parameters to
change the symbol. When you drag and drop these special symbols into a
document, the Attribute Viewer automatically displays the properties and
parameters. The properties are in plain text. The parameters are identified with
bold text. You cannot edit the names of the parameters.

Tip  If the Symbol Explorer is closed, you can also access the properties and
parameters of a symbol by selecting it and clicking the Symbol Explorer button.

Editing Embedded or Linked Symbols
If the symbol is linked, you can open the symbol and edit it. The symbol that you
placed on the drawing sheet updates automatically. Those same changes are saved
in the .SYM document on the hard drive.

You can also edit the symbol while viewing the other drawing graphics by using
the Object Edit command on the Edit menu. As you edit, all graphics except the
symbol become disabled until you finish editing the symbol. When you want to
stop editing, you can click Update on the File menu to update the document that
contains the symbol and then click Close to close the symbol document.

Embedding the symbol means that a copy of the symbol was placed in the
document. If you edit one instance of the embedded symbol in a document, all
copies of that symbol within the current document reflect those changes.

Tip  Before placing a symbol, you can set an option to link or embed the symbol
when you drag and drop the symbol into the document. You can do this by clicking
the Options command on the Tools menu and then setting the option you want on
the Symbols tab.

Editing Parts of a Symbol
To edit parts of a symbol as individual elements on the drawing sheet, you can
convert the symbol to a group of individual graphics. To do this, you place the
symbol on a drawing sheet, select it, and then click the Convert command on the
shortcut menu to convert the symbol into an element group. To ungroup the
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elements so that you can edit them individually, you can click the Ungroup button
on the Change toolbar. You can now edit the individual elements.

Tip  You must place a symbol in a document at the default scale (1:1) if you want
to use the Convert command. If you scale the symbol, you cannot convert the
symbol to individual elements.

Symbol Labels
To create a label, you can double-click the symbol. A blinking pointer appears
below the symbol so that you can start typing the text that you want.

Formatting a Symbol
You can change the attributes of a symbol with the Attribute Viewer or the
Parameters tab on the Properties dialog box. You can change the value of the
symbol attribute, but you cannot change the name of the attribute or add an
attribute.
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Scaling Symbols
You can use scale handles on a symbol to resize it. Four black scale handles are
displayed on the corners of the range box of a symbol. You can drag any of the four
handles up or down. (Illustration below contains content delivered in full product.)

You can also change the size of the symbol by clicking the Scale button on the
Change toolbar.

You can modify different parts of some symbols with parametric handles. Standard
parameter handles represent up to four driving dimensions that have been applied
to the graphics in a symbol. The four standard positions where parameter handles
can appear are top center, bottom center, left center, and right center of a symbol’s
range box. Dragging a parameter handle changes the value of the dimension by the
length readout precision set on the Units tab of the Properties dialog box when the
symbol is created. (Illustration below contains content delivered in full product.)

You can also scale a parametric symbol by selecting the symbol and then editing
the values in the Attribute Viewer. The Attribute Viewer automatically appears
when you select the symbol. For example, if you select the Para Tower symbol,
you can change the Top attribute from 7.29 to 9.00 so that the height of the symbol
increases. (Illustration below contains content delivered in full product.)
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Mirroring Symbols
You can use mirror handles to mirror a symbol about its center. The mirror handle
appears at the right center of a symbol’s range box. Dragging the mirror handle
across the center of a symbol’s range box causes the symbol to mirror about its
center in dynamics. A center line for the X and Y axis appears through the range
box of the symbol. The axes appear as solid when the pointer crosses one or both
axes.

When you manipulate a symbol, you see the same behaviors unique to that symbol
that existed when you placed the symbol in the document.
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 Rotating Symbols
You can rotate a symbol by using one of the following methods:

• Clicking the Rotate button.

• Selecting the symbol’s rotate handle to turn it.

• Using a rotation angle.

• Using relationships applied to the symbol.

Rotate Button
To rotate a symbol, you can select the symbol and click the Rotate button on the
Change toolbar.

Rotate Handles
You can also rotate a symbol about its center with the appropriate handle. The
rotate handle appears as a green circle to the right of the symbol. Dragging the
rotate handle closer to the center of a symbol’s range box causes the symbol to
rotate at larger angles. Dragging the rotate handle further away from a symbol’s
center causes the symbol to rotate at smaller angles.

Rotation Angle
You can also rotate a symbol by the rotation angle. When you drag a symbol or
align it to an element, you can press the left or right arrow keys on the keyboard.
This rotates the symbol in 15 degree increments by default. Some symbols are
designed to rotate at different increments.

If the symbol is created with a rotation angle other than zero, you can rotate it by
the defined step angle using the left and right arrow keys.
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Relationships
By default, when you rotate a symbol, it maintains its orientation on the drawing
sheet. In the following example, the line and symbol share a dimensional
relationship. The lower end of the symbol is set in place with a lock relationship.
When you edit the dimensional value of the driving dimension, the symbol does not
change its orientation. The driving dimension changes to a driven dimension that is
not to scale.

You can also allow symbols to change orientation on the drawing sheet according
to the relationships applied to them. This is handy if you want to change the
orientation of whole sets of geometry with one driving dimension or relationship. In
the example, when you edit the driving dimension between the line and symbol, the
symbol changes orientation on the drawing sheet, maintaining the relationships
applied to it.

For a symbol to rotate according to the relationships applied to it, you must first set
an option by opening the symbol document (.SYM) directly. You can open the
document with the Open command on the File menu. Then, you must click the
Properties command on the File menu. On the Behavior tab, you must set the
Allow Rotation By Relationships check box. After saving and closing the symbol
document, you can drag and drop the symbol into a document.

You can create kinematics animations by editing dimensional relationships between
elements and symbols.
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Manipulating Symbols
You can manipulate a symbol just like you would manipulate other graphics. For
example, you can edit symbol properties, apply relationships, move it, or copy it.
When you manipulate a symbol, it behaves as a single unit. You can view
properties for the symbol in the Attribute Viewer that appears at the bottom of the
Symbol Explorer.

You can click any part of a symbol to move it around in a document.

Some symbols are created with drag points that appear as green dots on the
symbol. When you move the symbol around in the document, the pointer
automatically attaches to the drag point that you used most recently. You can
change drag points by pressing the Up and Down arrow keys on the keyboard.

If you drag and drop a symbol on an element in the document, the symbol is
automatically associated with that element. When the element moves, the symbol
moves with it. You must click one of the green drag points on the symbol and then
move the symbol to the element.

Tip  Some symbols cannot be associated with an element depending on what
options were set when the symbol was created.

Aligning a Symbol with an Element
Many symbols align automatically with elements in the document.
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When associated with an element, these symbols display a green lock handle.
When the element moves, the symbol moves with it.

You can click the lock handle to free the symbol from the associated element.
When you unlock the handle, you can move the symbol away from the element. If
you move the element, the symbols stays in its original position.

You can use the lock behavior in many ways. For example, you can ensure that a
door symbol moves with the wall to which it is attached if the lock handle on the
door symbol is locked. If you want to move the wall, and not the door, you must
click the lock handle on the symbol to unlock the door symbol from the wall. The
door now remains in its current position when you drag the wall away from it.

Aligning a Symbol with Another Symbol
Some symbols can be placed only on other symbols. These symbols are created
with drop points that allow you to align the symbol to a precise point on another
symbol. You cannot place a symbol with drop points on an element, such as line,
arc, or circle.
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When a symbol has drop points, red dots appear to indicate the drop points defined
on the symbol. These drop points let you know where you can place the symbol on
the target symbol. When you click a drag point on a symbol and drag it over
another symbol, the drop points appear as red dots. A bull’s eye appears when the
drag point and drop point are exactly aligned. You can then attach the symbol to
the other with precision.
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Procedures to Explore in On-line Help
• Create a Symbol

• Place a Symbol

• Edit a Symbol
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Reports
The software delivers some reports that you can update automatically when you
add symbols to a document. The reports work with symbols that have specific
attributes assigned to them. You must have Microsoft® Excel™ 97 or later
installed on your computer. The software includes several sample reports.

When you open a template, that specific template displays a default directory of
symbols in the Symbol Explorer. You can find reports in the Reports directory of
the default symbol directory. Examples that you can drag into your document
include the following reports:

• Network Reports—In the Network template, you can drag in reports listing
network equipment contacts and reports inventorying equipment.

• Process Reports—In the Process Flow template, you can drag in heat
exchanger, pump and tower equipment reports and a stream report.

The software prompts you to update the report when you add it to a document.
After you add more symbols to the document, you can update the existing report by
double-clicking it.
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Smart Labels  (Illustrations in this section contain content delivered in full product.)

Technical drawings often have many labels that display important information
about the objects or elements in the document. There are two types of labels: text
labels and Smart Labels.

A Smart Label is associated to an object or element’s text attributes. A Smart Label
sometimes displays a question mark, indicating that you can edit the text in the
question mark position.

 

A Smart Label displays the attributes of the element or object as text in the
document. You can drag and drop Smart Labels from the Symbol Explorer into the
current document. Smart Labels have an .SYM extension. As you change an
element’s or object’s attributes in the Attribute Viewer or the Properties dialog box,
the Smart Label’s text displays those changes.

 

 

If an element or object has no attributes, and you drag a Smart Label to it, the
element or object picks up the attributes of the Smart Label. For example, you
might want to assign attributes to a heat exchanger, such as pressure and material
type. If the Smart Label has the pressure and material type defined, and the heat
exchanger does not, the Smart Label’s pressure and material type are copied to the
heat exchanger.
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If an element already has values assigned to its attributes, a Smart Label placed on
the element displays the values that are already assigned to the element. The values
for the Smart Label are erased. For example, if the heat exchanger already has
values for pressure and material type attributes, the values of those attributes
override any values for a Smart Label placed on the heat exchanger.

Tip  Not all Smart Labels assume the text attributes of an element or object. Some
Smart Labels contain shapes that grow automatically if you add text to the Smart
Label.
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Attributes
Attributes can help you work more efficiently by allowing you to enter and edit
values for a symbol, object, or element. Attributes can include such items as the
manufacturer, price, and other data. Attributes include user-defined properties and
parameters.

A user-defined property is an attribute assigned to an element or object that defines
a characteristic about that element or object. A property is usually in the form of a
text notation, such as cost, weight, color, and so forth. You can change user-
defined properties, but these changes have no affect on the appearance of the
element or object.

A parameter is a mechanism to change a property. A parameter is an attribute
assigned to an element or object, usually a numerical value representing a
dimension.

The Attribute Viewer displays the user-defined properties and parameters for a
selected item. The viewer also allows you to edit the values of the properties or
parameters.

Tip  User-defined properties also appear on the User tab of the Properties dialog
box. Parameters appear only in the Attribute Viewer.

You cannot edit the names of attributes; you can edit only their values. The viewer
displays two columns, one for the name of the attribute and one for the value. User-
defined properties appear in plain text. Parameters appear in bold text.

When editing attributes, you can only work on one element or object at a time.
When more than one item in the document is selected, no attributes are displayed in
the Attribute Viewer.
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Procedures to Explore in On-line Help
• Create a Symbol Report

• View the Attribute Viewer

• Place a Smart Label
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Selecting Elements
To select an element, you must use the Select Tool at the top of the Draw toolbar.
You can select lines, arcs, or annotations, such as dimensions or fills. You can also
select element groups, embedded or linked objects, symbols, or handles on
elements that indicate relationships.

Selecting Single Elements
To select an element, you can click the Select Tool on the Draw toolbar.

When you click the Select Tool button, the pointer changes to an arrow with a
locate zone indicator at the end. As you move the pointer, any element that the
locate zone passes over is displayed in the highlight color. When an element is
highlighted, you can click to select it.

When you select an individual element, the following things happen:

• The element changes to the selection color. You can change the selection color
with the Options command on the Tools menu.

• The element’s handles are displayed. Handles are solid squares at significant
positions on a selected element, such as end points and center points. Handles
allow you to directly modify the element—drag a handle to change the
element's shape. Although you can select more than one element at a time, only
one element can have handles at a time.

• The element's important properties are displayed on a ribbon bar.

• If the element is linked or embedded into the current document, selecting it
allows you to double-click it for editing.

When you select multiple elements or grouped elements, they change to the
selection color.

Selecting Multiple Elements
You can select more than one element at a time by clicking the Select Tool and
then holding the SHIFT or CTRL key as you click the elements you want to select.
Or, you can click the Select Tool and then drag the mouse to fence elements.
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You can use the ribbon bar to select whether you want only elements completely
enclosed by the fence to be selected or any element that is partly enclosed by the
fence. Many manipulation commands, like delete, move, copy, and rotate, act upon
all elements in the selection set.

Selecting an Element That Overlaps Other Elements
If you want to select an element that overlaps other elements, and you cannot
highlight the element you want by moving the pointer over it, you can use a tool
called PickQuick. To use it, you should move the pointer over the elements and
pause the mouse. When the software displays an ellipsis, or three small circles, by
the pointer, you can click the left or right mouse button to display a small toolbar
that shows the number of selectable elements. You can move the pointer over the
numbers; and, when the element that you want highlights, you can click on the
corresponding number to select it.

Deselecting Elements
To deselect an element or group of elements, you can click any point on the
drawing sheet.
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Moving Elements
You can move elements on the drawing sheet with one of several methods:

• Dragging elements with the Select Tool.

• Specifying precision points with the Move button on the Change toolbar.

Tip  You can also click the Scale and Rotate buttons on the Change toolbar to
move elements.

Using the Select Tool
To move an element, you must first select it with the Select Tool on the Draw
toolbar. You can drag the selected element to move it without changing its shape.

Tip  The element’s handles do not need to be displayed for you to move it. If they
are displayed, and you want to move the element and not modify it, position the
pointer so it is not over a handle.

You can move an element with precision if you use the relationships indicators.

When you modify a drawing, elements with maintained relationships automatically
update to honor the relationship. For example, if you move an element that shares a
maintained parallel relationship with another element, the other element moves as
needed to remain parallel. If a line and an arc share a maintained tangent
relationship, they remain tangent when either is modified.
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Moving Elements by Specifying Precision Points
You can move a line that shares a tangent relationship with an arc if you select the
line and click the Move button on the Change toolbar. As you move the line, the
line moves without maintaining the relationship with the arc. You can then specify
a from point and a to point by clicking on the drawing sheet or by entering values in
the ribbon bar. You can move any element by specifying precision points with the
Move button.
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Cutting or Deleting Elements
You can delete elements by selecting them and clicking the Cut button on the Main
toolbar or by pressing DELETE. Clicking the Cut button allows you to paste the
element in another location. Pressing DELETE removes the element permanently.

Relationships that are no longer applicable after you delete an element are
automatically deleted. For example, if you delete one of a pair of parallel lines, the
parallel relationship is deleted from the remaining line.
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Copying Elements
You can copy any element, dimension, or object by selecting it and using the Copy
button on the Main toolbar. Copying places the selected item on the Clipboard.
When you click the Paste button on the Main toolbar, the item is placed on the
drawing sheet.

You can also copy an element with the Select tool. You click the Select tool on the
Draw toolbar, select the element, and press CTRL as you drag the element across
the drawing sheet. You can also copy several selected elements in the same
manner.

When you copy elements that have relationships, the relationships are copied and
retained when possible. For example, if you make a copy of two related lines, the
relationship is also copied. However, if you copy one of two lines that are related to
each other, the relationship is not copied.

Tip  You can also click the Offset, Move, Scale, and Rotate buttons on the Change
toolbar to create copies.
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Creating Patterns
Patterns are useful if you want to create several elements quickly that are the same
without using several commands. You can create patterns by selecting one or more
elements and making several copies of it with the Rectangular Pattern or Circular
Pattern button on the Change toolbar.

To modify individual members of the pattern, you can select an individual member
of the pattern and change it the way you would any other element.
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Procedures to Explore in On-line Help
• Select and Move an Element

• Copy an Element

• Paste an Element

• Offset Elements

• Draw a Circular Pattern

• Draw a Rectangular Pattern
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Tip  For more information about how to change symbols, see Chapter 6.
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Changing the Shape of an Element
You can change the size, position, or orientation of an element with your pointer.
When you select an element with the Select Tool, its handles are displayed at key
positions.

You can change the shape of a selected element by dragging one of its handles. The
first figure shows the effect of dragging an end point handle. The second figure
shows the effect of dragging the mid point handle.
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Rotating Elements
With the Rotate button on the Change toolbar, you can rotate one or more elements
a precise angle about a specified point.

You can first select the element and then click the Rotate button or you can click
the button and then the element.

As you click to define the reference points for the rotation, the software
dynamically displays a reference axis for the rotation. If you want to define a
precise location for the rotation, you can enter values in the ribbon bar. You can
enter increments in the Step Angle box if you want to dynamically view the results
of the rotation. For example, if the box is set to 30.0, the rotation is displayed in 30
degree increments. The default setting is 0 degrees so that the rotation is fully
dynamic.

The Rotation Angle box on the ribbon bar displays the angle of change between the
old and new positions with a positive value. The Position Angle box displays an
absolute angle of the new position of the rotation. You can type values in both of
these boxes and preview the results. You then click to complete the rotation of the
element.

By default, a copy is made of the element when you rotate it. If you do not want a
copy, you should clear the Copy option on the ribbon bar.

Tip  For more information about rotating symbols, see Chapter 6.
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Mirroring Elements
To mirror an element, you can click the Mirror button on the Change toolbar. The
software mirrors one or more selected elements about a line or axis that you define.
You can mirror with or without making a copy.

Tip  For more information about mirroring symbols, see Chapter 6.
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Scaling Elements
The Scale command on the Change toolbar reduces or enlarges selected elements
by a scale factor that you define. The scale factor is the same along the x and y
axes. Scalable elements include framed elements, such as text boxes. You cannot
use the Scale command to scale or scale and copy elements in a drawing view
because a scale factor has already been applied to the drawing view.

Relationships within the selection set are maintained if the relationships are still
applicable after the elements have been scaled. If not, the relationships are deleted.

To define the new scale, you can click points on the drawing sheet or you can type
a value in the Scale Factor box on the ribbon bar. You can also use the Step box on
the ribbon bar to make the Scale Factor increase or decrease incrementally as you
move the mouse.
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Extending or Trimming Elements
You can trim or extend elements with buttons on the Draw toolbar.  You can also
add fillets or chamfers by clicking the Fillet or Chamfer buttons on the Draw
toolbar.

Relationships are added or removed as necessary when you trim or extend an
element. For example, if you trim part of a circle and more than one arc remains,
concentric and equal relationships are applied between the remaining arcs.

You can also draw a chamfer on two different elements with the Chamfer button
on the Draw toolbar. The elements must be linear, but do not have to intersect. The
elements cannot be parallel to each other.

When two lines intersect, you can draw a chamfer simply by clicking the corner
and then moving the pointer in the distance that you want. A final click on the
drawing sheet places the chamfer (B).
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To place a fillet, you can click the Fillet button on the Draw toolbar and then select
the elements you want to modify. As with any command, you can use a
combination of clicks and ribbon bar input.



Chapter 9 SmartSketch Getting Started Guide

158

Applying Relationships to Change Existing
Elements

You can apply relationships as you draw and place elements by using the
relationship indicators that appear by the pointer. You can also apply relationships
to elements that you have already placed on the drawing sheet.

Applying Relationships to Existing Elements
To apply relationships to elements that you have already placed on the drawing
sheet, click a button on the Relationship toolbar and then select the elements you
want to relate. When you apply a relationship between elements, the elements are
modified to reflect the relationship. If Maintain Relationships is set when you use
the commands on the Relationship toolbar to add relationships to your drawing, the
added relationships will be maintained.

For example, selecting the Equal command and clicking two circles makes the
circles equal in size.

If a line and arc are not tangent, applying a tangent relationship modifies one or
both elements to make them tangent.

When you use commands on the Relationship toolbar, the software allows you to
select only elements that are valid input for that command. For example, when you
use the Concentric command, the command allows you to select only circles, arcs,
and ellipses.
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Perhaps you begin designing with a few key design parameters. You would usually
draw known elements in relation to one another and then draw additional elements
to fill in the blanks.

As you draw and add elements to the drawing, the relationships are maintained and
additional relationships are applied.
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Modifying Elements That Share Relationships
If two elements share a relationship, the relationship is maintained when you
modify either one of the elements. For example, if you move a circle that has a
tangent relationship with a line, the line also moves. The elements remain tangent.

If you move a circle that does not have a tangent relationship with a line, the line
does not move.

 

Other elements that share relationships maintain them in the following ways:

• If a line and an arc share a tangent relationship, they remain tangent when
either is modified.

• If a line and arc share a connect relationship, they remain connected when
either is modified.
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• If two lines are horizontal, they remain horizontal even if you change the
position and length of one of the lines.

Deleting Relationships
You can delete a relationship as you would delete any other element. You select a
relationship handle, and then select the Delete command. Relationships are
automatically deleted when their deletion is necessary to allow a modification to
occur. For example, if you rotate an element that has a horizontal relationship
applied to it, the relationship is automatically deleted.

If you want to change an element by adding or removing a relationship, and the
element does not change the way you expect, it may be controlled by a driving
dimension. You can toggle the dimension from driving to driven, then make the
change.
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Using Dimensions to Change Existing Elements
You can change dimensions on the drawing sheet to change existing elements.
Driving dimensions are relationships that allow you to maintain characteristics such
as the size, orientation, and position of elements. When you place a driving
dimension on or between elements, you can change the measured elements by
editing their dimensional values—you do not have to delete or redraw elements at
different sizes.

For example, dimensioning the radius of an arc maintains its size. Editing the value
of the radius dimension changes its size.

To create dimensional relationships, select a dimension command and click the
elements you want to relate.

Tip  You must set the Maintain Relationships option on the Tools menu before
drawing the elements or applying your dimensions.
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Procedures to Explore in On-line Help
• Modify an Element with the Select Tool

• Rotate an Element

• Mirror an Element

• Scale an Element

• Trim an Element

• Extend an Element

• Draw a Chamfer

• Draw a Fillet

• Make Elements Tangent

• Make Elements Concentric

• Place a Driving Dimension
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Placing Elements in Precise Locations
PinPoint is a tool that helps you draw and modify elements relative to known
positions in a drawing. You can place a target point and then the software
dynamically displays the horizontal and vertical distance between the cursor and
the target point. You can use PinPoint with all element drawing commands. You
can run PinPoint from the Tools menu or the Main toolbar.

How PinPoint Works
PinPoint allows you to provide coordinate input to commands as you draw. The x
and y coordinates are relative to a target point that you can position anywhere in the
window. You can change the location of the target point at any time by clicking the
Reposition Target button on the ribbon bar and then clicking a new position in the
window.

As you move the pointer around, PinPoint dynamically displays the horizontal and
vertical distance between the cursor position and the target point. Help lines show
the PinPoint x and y axes and the PinPoint orientation.

Locking and Freeing Values
You can lock the x coordinate or the y coordinate using the X and Y boxes on the
ribbon bar. When one coordinate value is locked, you can position the other
coordinate by clicking a position in the window. Or you can set both values using
the ribbon bar boxes. If you want to free the dynamics for a locked value, you can
clear the value box by double-clicking in the box and pressing the Backspace or
DELETE key.

PinPoint Orientation
In its default orientation, PinPoint’s x axis is horizontal. You can re-orient the x axis
to any angle by setting the angle on the PinPoint ribbon bar. The figure shows the
PinPoint angle set to 20 degrees.
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Example: Draw a Line

You can use PinPoint to draw a line starting at a specific x and y distance from a
known position in your drawing.  

1. On the Main toolbar, click the PinPoint button.

2. Click where you want the target point to be.

3. Change the step value in the PinPoint Ribbon Bar if it is not already set to a
value that is appropriate for the operation.

4. On the Draw toolbar, click the Line/Arc Continuous  button.

5. Move the pointer around on the drawing sheet. PinPoint displays at the cursor
its current x and y positions in relation to the target point.

6. Click when the pointer is positioned where you want the line to begin.

7. Click where you want the second point of the line to be, or type the length
and/or angle on the Line/Arc Continuous  ribbon bar and then click to draw the
line.
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Placing Elements with a Grid
The grid and its grid lines allow you to place elements in the document by aligning
them with the grid lines or nearest intersection of the grid lines. You can use the
grid if you want the elements to line up at regular intervals in the document.  

The grid is an invisible set of lines in the document. When you set the Grid Snap
option on the View menu, elements always align with the grid lines or nearest
intersection of the grid lines. You can view the grid by clicking the Grid Display
option on the View menu. The grid lines do not print.

You can change the display of the grid from static to dynamic by setting options on
the View tab of the Options dialog box.

When you zoom in or out, the grid lines for a dynamic grid are generated
dynamically. You can set dynamic grid lines to appear at fine, medium, or coarse
levels.  The grid lines appear at common major measurement increments. A
dynamic grid displays index lines that intersect with the darker, solid grid lines.

A static grid displays solid grid lines that do not move as you zoom in or out. You
can set up the increment settings on the View tab of the Options dialog box.
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Element Groups
A group is a set of elements that you have selected. The set behaves like any other
select set. Grouping elements allows you to work with them as a unit. For example,
you could place the holes and center lines of a bolt hole pattern into a group. This
would allow you to move, copy, or delete the entire pattern at once, as if it were a
single element.

The following list describes some of the properties of groups:

• An element can be a member of only one group.

• Grouped elements must reside in the same document and be on the same
drawing sheet.

• Any locatable element can be grouped.

• Any combination of elements, such as lines, text, circles, and so forth, can be
grouped.

You can use the Group command to nest two or more entire groups within a larger
group, or you can nest individual elements and groups within a larger group.

Once elements are grouped, you can use the Ungroup command to ungroup all of
the elements at the same time. You can also use the Ungroup command and
PickQuick to remove one or more elements from a group.

Selecting Groups and Members of Groups
The options on the Select Tool ribbon bar allow you to select an entire group or
individual members of a group. If you set the bottom-up option, you can select
individual members. If you select the top down option, you can select all the
members.

You can also use PickQuick to select one or more group members or an entire
group.

Performing Tasks on Groups
Once you select a group, you can use a command or ribbon bar option on all of its
members. For example, when you move, copy, or delete a group, all of its
members are moved, copied, or deleted. You can move or apply relationships to a
member of a group and the changes do not affect the position of the other members
of the group.
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When you copy an entire group, all of its members are copied, including nested
groups. The software creates a new group that contains all of the members of the
original group. When you copy one member of a group, only that member is
copied.

If you use PickQuick to select a member of a group, you can perform tasks on the
member individually, without affecting other members.
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Element Display Priority
When 2-D elements overlap, their display priority determines which is in front. The
first element you draw is displayed behind all other elements—it has the lowest
display priority. A newly created element is displayed in front of all other
elements—it has the highest display priority.

For example, if you draw a circle, then an ellipse, and then a rectangle, the circle is
displayed in back. The ellipse is displayed between the circle and the rectangle, and
the rectangle is displayed in front.

Changing the Element Display Priority
You can change an element's display priority by pulling it up one position, pushing
it down one position, sending it to the back, or bringing it to the front. One click on
the striped box changes the display priority.

You can change the display priority of a group the same way. The display priority
of elements within the group does not change.
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Using Layers to Arrange Elements
Layers and display settings can help you group elements so that you can
manipulate them more easily on a drawing sheet. Layers and display settings also
make it easier to keep track of different types of elements. Each drawing sheet in a
document can contain several layers.

When you draw an element, it is assigned to the active layer. To see which layer is
active, or to change the active layer, you can use the Layers button on the Main
toolbar.

Controlling the Display of Elements and Objects
After assigning an element or object to a layer, you can set display criteria to
control the way items appear in a window with the Display Manager command on
the Tools menu. With this command, you can set display criteria for any sheet and
its associated layers in the current document. The display settings can include the
color or line type and line width of elements or objects.

Tip  If two windows are open for the same document, the display settings that you
select with the Display Manager dialog box affect every window view of the
drawing sheet.

Displaying Layers
To view elements on specific layers, you can turn on one or more layers with the
Layers button. When you turn layers off, you cannot see the elements assigned to
the layers on the drawing sheet. For example, you can assign lines to one layer and
closed elements to another layer. Then, if you turn off the layer for closed elements
and turn on the layer for lines, you see only lines on the drawing sheet.
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You can still see relationships between elements that are assigned to different
layers on a drawing sheet. For example, suppose a line and a circle are tangent and
they are assigned to different layers. If the line’s layer is displayed and the circle’s
layer is hidden, you can still see the tangent relationship handle on the line. If the
line’s layer is hidden as well, the tangent relationship handle is hidden.

With the Display Manager command on the Tools menu, you can control the way
elements appear on sheets or layers by changing settings, such as the line type or
color. You can also create custom colors for the display.

Layers and Layer Groups
While layers provide a way to control the display of elements on a drawing sheet,
layer groups give you another way to control the display of elements on drawing
sheets. You can use the Layer Groups command on the Tools menu to define layer
groups.

Creating New Layers
You can create new layers with the Layer Groups command or by typing a new
layer name on the ribbon bar. You cannot give the same name to two layers on the
same drawing sheet.

Assigning Elements to Layers
Although you can assign an element to only one layer, you can change the layer to
which an element is assigned. You can find out which layer an element is assigned
to by selecting it and using the Properties command on the Edit menu.
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Procedures to Explore in On-line Help
• Draw with PinPoint

• Group or Ungroup Elements

• Send an Element to the Back of the Display Order

• Control the Display of Elements in a Window

• Change the Active Layer

• Display or Hide Layers
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Viewing Your Work
You can manipulate windows and views to affect how you see a document on the
computer screen. A window can be compared to a camera. When you look through
a camera, you see a view of a real-world object. When you look through a window
on the computer screen, you see a view of the objects in the document. In both
cases, you can change the view by zooming in and out, and focusing on different
parts of the document. You can also use the Microsoft IntelliMouse to zoom or pan
views.

Windows
When you start  the software, the application window displays a blank document.
You can use commands on the File menu to create a new document or open an
existing one.

With the commands on the Window menu, you can create and arrange new
windows that allow you to see more than one section of a document or more than
one document. You can minimize open windows and display them as icons in the
application work space.

Views
Views are what you see in software windows. With the view commands, you can
do the following:

• Use the Zoom Area command to set the zoom area to see more detail in the
document.

• Use the Zoom In command to enlarge the display of elements around a
specified point in the document.

• Use the Zoom Out command to reduce the display of elements around a
specified point in the document.

• Use the Pan command to position another part of the document in the center of
a view, fit all of the document in a view, or identify the area of the document
you want to see.

• Use the Fit command to restore the previous view of the document.

• Use the Previous command to restore the previous view.

• Use the Toolbars command to display or hide toolbars in the application
window.
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Drawing Sheets
With drawing sheets, you can place different drawings on different sheets in a
document. Working sheets are the drawing sheets on which you place most of your
graphics. Background sheets are drawing sheets that allow you to define and
display the border of a drawing sheet.

Layers
Within each drawing sheet, you can place several layers so that you can group
elements. Layers allow you to keep track of elements in the document and
manipulate them more easily. You can also specify the way you want elements to
be displayed in a window.

Note  For more information about drawing sheets, see Chapter 15. For more
information about layers, see Chapter 7.
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Microsoft’s IntelliMouse
You can use the Microsoft IntelliMouse® with the software so that you can
manipulate different views of the document faster and more efficiently.

Caution  The newest version of Microsoft IntelliPoint Drivers (2.2) supports
universal scrolling. Universal scrolling allows you to scroll up and down in any
window that displays scroll bars by using the wheel button on the IntelliMouse.
Universal scrolling prohibits the recognition of the scrolling behavior defined for
the software. You must, therefore, identify the name of the software and any other
applications as exceptions to universal scrolling.

When you do this: The view does this:

Rotate the wheel button
forward

Zooms in at the current pointer
location

Rotate the wheel button
backwards

Zooms out at the current
pointer location

Drag the wheel button Pans from one location to
another

Press Ctrl and drag the wheel
button

Zooms the area of the window
that you defined by dragging
the pointer

Press Shift and click the wheel
button

Fits the graphics on the
document to the window

Press Alt and click the wheel
button

Restores the previous view

Tip  You can perform any of these actions with a three-button mouse; you click the
middle mouse button, instead of the wheel button. No action occurs when you click
the wheel button just one time.
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Procedures to Explore in On-line Help
• Fit All Elements in the Active Window

• Pan a View

• Zoom Out

• Zoom In
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Dimensions Overview
Dimensions supply information about the size, location, and orientation of
elements, such as the length of a line, the distance between points, or the angle of a
line. Dimensions are associative to the elements they refer to, so you can make
design changes easily.

You can use the commands on the Dimension toolbar to place the following types
of dimensions:

(A) Linear dimensions

(B) Angular dimensions

(C) Diameter dimensions

(D) Radial dimensions

(E) Dimension groups

Dimension commands on the Dimension toolbar have a ribbon bar that sets options
for placing the dimension. When you select a dimension in the drawing, the same
ribbon bar options appear. You can use the options to change the selected
dimension.
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Placing Dimensions
To dimension elements, you can use a dimension command on the Dimension
toolbar, such as SmartDimension, and then select the elements you want to
dimension.

As you place dimensions, the software shows a temporary, dynamic display of the
dimension you are placing. This temporary display shows what the new dimension
will look like if you click at the current pointer position. The dimension orientation
changes depending on where you move the pointer.

For example, when you click Distance Between on the Dimension toolbar and
select an origin element and an element to measure to, the dimension dynamically
adjusts its orientation depending on where you position your pointer.

Because you can dynamically control the orientation of a dimension during
placement, you can place dimensions quickly and efficiently without having to use
several commands. Each of the dimension commands uses placement dynamics
that allow you to control how the dimension will look before you place it.

Placing Dimensions with the Dimension Axis
The Axis button on the Dimension toolbar sets the orientation of the dimension axis
on the drawing sheet. You can use the new dimension axis, rather than the default
axis of the drawing sheet, while you are using the Distance Between or Coordinate
Dimension command. You must set the Explicit option on the Dimension ribbon
bar to place dimensions that are perpendicular or parallel to new dimension axis.

Dimensioning While You Draw
To dimension elements as you draw them, you can set Dimension Keyin Values
Automatically with the Options command on the Tools menu. Although placing
dimensions as you draw is convenient, it might be necessary to delete unneeded
dimensions when you have finished your design.
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Note  Dimensions placed with this option are only driven dimensions.

Using Dimensions to Drive Elements
You can place a dimension that controls the size or location of the element to which
it refers. This type of dimension is known as a driving dimension. If you use the
ribbon bar to change the dimensional value of a driving dimension, the element
updates.

Dimensions that are not driving dimensions are called driven dimensions. The
value of a driven dimension is controlled by the element it refers to. If the element
changes, the dimensional value updates.

Because both driving and driven dimensions are associative to the element they
refer to, you can change the design more easily without having to delete and re-
apply elements or dimensions when you update the design.

If you want to create a driving dimension, you must first set the Maintain
Relationships command on the Tools menu. When you are placing dimensions, an
option on the ribbon bar allows you to specify whether a dimension is driving or
driven. A driving dimension and a driven dimension are distinguished by color.
There are different colors for driving dimensions and driven dimensions in a
dimension style.

Not-to-Scale Dimensions
You can override the value of a driven dimension by editing its dimensional value.
This makes the dimension not-to-scale. For example, if you override the
dimensional value that is 15 millimeters to be 30 millimeters, the actual size of the
line that you see would still be 15 millimeters.
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Formatting Dimensions
If you want two or more dimensions to look the same, you can select the
dimensions and apply a style with the ribbon bar. If you want to format dimensions
so that they look unique, you can select a dimension and edit its formats on the
ribbon bar or with the Properties command on the Edit menu.

Using Expressions in Dimensions
There are many instances when the dimensions of individual features in a design
are related. For example, the bend radius used to manufacture a sheet metal part is
usually a function of the stock thickness. You can define and automate these types
of design relationships with expressions. You can select a dimension and then use
the Variables command on the Tools menu to enter a formula. When the formula is
solved, the dimensional value changes to the value that the formula calculates.

You might want to use dimensions with expressions for the following purposes:

• Drive a dimension by another dimension; Dimension A = Dimension B

• Drive a dimension by a formula; Dimension A = pi * 3.5

• Drive a dimension by a formula and another dimension; Dimension A = pi
Dimension B

Setting or Modifying Units of Measure
To set the units of measure for a dimension, you can use the Properties command
on the Edit menu. To set the units of measure for a document, you can click the
Properties command on the File menu and then click the Units tab.
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Types of Dimensions
A linear dimension measures the length of a line or the distance between two points
or elements. You can place linear dimensions with the Distance Between and
SmartDimension commands.

An angular dimension measures the angle of a line, the sweep angle of an arc, or
the angle between two or more lines or points. You can place angular dimensions
with the Angle Between and SmartDimension commands.

A radial dimension measures the radius of elements, such as arcs, circles, ellipses,
or curves.  You can place a radial dimension with the SmartDimension command.

A diameter dimension measures the diameter of elements, such as circles and
ellipses. You can place a diameter dimension with the SmartDimension command.

The components of a dimension are as follows:

(A) Projection line (E) Break line

(B) Dimension line (F) Symbol

(C) Dimensional value (G) Connect line

(D) Terminator
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Dimension Groups
You can place dimensions in dimension groups with several commands. This
makes the dimensions easier to manipulate on the drawing sheet. All members of a
stacked or chained dimension group share the same dimension axis.

• Stacked dimension group

• Chained dimension group

A coordinate dimension group is another type of dimension group. Coordinate
dimensions measure the position of key points or elements from a common origin.
All the dimensions within the group measure from a common origin. You should
use coordinate dimensions when you want to dimension elements in relation to a
common origin or zero point.

When you are placing dimension groups with the Distance Between or Angle
Between commands, the cursor position determines what type of dimension group
will be placed. After you place the first dimension in a group and click the second
element you want to measure, if the cursor is below the first dimension, then the
dimension group will be a chained group.
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If the cursor is above the first dimension, then the dimension group will be a
stacked group.

You can place dimension groups with the following buttons on the Dimension
toolbar:

• Distance Between

• Angle Between

• Symmetric Diameter

• Coordinate Dimension
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 Measuring Distances and Areas
You can also measure the length of a line or the diameter of a circle by selecting
the element and looking at the value on the ribbon bar. For more detailed work, the
software provides commands for measuring distances or areas in a drawing. Even
when you are in the middle of a task, you can measure distances or areas with these
commands.

• The Measure Distance command measures the distance between points on
elements and points in free space.

• The Measure Area command measures the area inside one or more closed
boundaries.

The distances are shown using the current units of measure for the document.  To
set the units for measuring distances or areas, you can use the Properties command
on the File menu.

Example:  Measure the Length of a Line

Even when you are in the middle of a task, you can measure distances with the
Measure Distance command.  For example, consider the following workflow.

1. On the Draw toolbar, select the Line/Arc Continuous button and draw a line.

2. On the Tools menu, click the Measure Distance command and measure a
distance.

Note  You do not need to exit the Line command before measuring a distance.
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3. To exit the Measure Distance command, click the right mouse button.  The
Line/Arc Continuous command is still active—you can pick up where you left
off and continue using the Line/Arc Continuous command.
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Bearing and Azimuth
You may want to orient your drawing in an environment with a specific bearing
and azimuth. This tool may be useful for applications such as civil engineering.

Tip  The Bearing and Azimuth command is available only if you use the
Customize command on the Tools menu to place it on a toolbar or menu. On the
Toolbars tab of the Customize dialog box, click the Tools category to access the
command.
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Variables
You can use the Variable Table to define and edit functional relationships between
the dimensions of a design in a familiar spreadsheet format. The Variable Table is
accessed with the Variables command on the Tools menu. There are two types of
variables: dimensions displayed in the design and variables you create directly in
the Variable Table. Dimension variables directly control elements of a design. A
user variable must be set equal to a value or mathematical expression; for example,
PI = 3.14159.

You can use variables to do the following:

• Drive a dimension with another dimension; Dimension A = Dimension B

• Define a constant; pi=3.14

• Drive a dimension with a formula; Dimension A = pi * 3.5

• Drive a dimension with a formula and another dimension; Dimension A = pi *
Dimension B

• Drive a dimension with a formula that includes a function;  Dimension A =
Dimension B + cos(Dimension C)

• Drive a dimension with a value from a spreadsheet, such as a Microsoft Excel
document, by copying the value from the spreadsheet into the Variable Table.
Besides Excel, you can use any other spreadsheet software that can link or
embed objects.

• Drive a dimension with a value from a spreadsheet, such as a Microsoft Excel
document, by copying the value from the spreadsheet into the Variable Table.
Besides Excel, you can use any other spreadsheet software that can link or
embed objects.

Accessing the Variable Table
Once you select the Variables command on the Tools menu, a table appears with
the following columns:  Type, Name, Value, and Formula. Each row of the table
displays a variable.
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Entering Data into the Variable Table
When you open the Variable Table in the document, all the dimensional values for
the dimensions on the drawing sheet appear in the columns. The name that appears
in the Name column is automatically generated by the software. You can change
the name to something more logical if you want.

Restricting the Display of Variables
You can restrict the display of variables in the table with the Filter button on the
Variable Table window:

• You can display only the variables for dimensions that the software created.

• You can also display variables that are associated with elements in the current
document or the active window

• You can also display a set of elements that you have selected in the document.

Creating Expressions
The system provides a set of standard mathematical functions. The functions can
be typed in with the proper syntax or you can use the Function Wizard to select and
define the function. The Function Wizard is convenient when you forget the proper
syntax for a math function. You start the Function Wizard by clicking the Fx button
in the Variable Table. The function is written in the Formula column of the selected
row.

Examples
Suppose you draw a sheet metal bracket and you want to build a relationship
between the bend radius and stock thickness. You can use a formula in the
Variable Table to build and manage this relationship. The following example
illustrates how the Variable Table would look if you built a relationship that
changes the bend radius when the stock thickness changes.

Type Name Value Formula

Variable Stock_thickness .25

Dimension Bend_radius .375 1.5 * stock_thickness
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Here are some more examples of how you might set up the Variable Table:

Type Name Value Formula

Variable c 2.0 kg

Variable d 10.0 rad @c:\bearing.xls!sheet1!R6
C3

Variable e 20 mm @c:\bearing.xls!sheet1R!6
C3

Argument Conventions
The following argument conventions are used in the Variable Table:

• In the syntax line, required arguments are bold and optional arguments are not.

• Argument names should follow the rules for Visual Basic.

• In the text where functions and arguments are defined, required and optional
arguments are not bold. Use the format in the syntax line to determine whether
an argument is required or optional.
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Example:  Using Variables to Calculate Dimensional Values

You can use the Variable Table to create expressions that change dimensions in the
drawing when you change the expressions.

1. Open a drawing document.

2. On the Tools menu, click the Variables command. The Variable Table appears
in a window.

3. On the Variable Table window, click the Filter button and define which
variables you want to display in the Variable Table. For example, on the Filter
dialog box, if you select Dimensions in Type and then select Window, this
displays all the dimensions that appear in the active window.

4. In the Variable Table, click the Formula cell that displays the dimension that
you want to edit and type an arithmetic expression to calculate the value of the
dimension: V681/2. When you type an entry in the cell, the entry also appears
in the Formula Bar.

Type Name Value Formula

Dimension V680 4.25 mm V681/2

Dimension V681 3.00 mm

5. On the Formula Bar, click the Enter button or press ENTER to calculate the
result of the expression. In this example, when V681 is modified, V680 is
automatically updated to reflect the relationship.

Type Name Value Formula

Dimension V680 1.50 mm V681/2

Dimension V681 3.00  mm
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Paper and Model Units
Each document has both paper and model units. Paper units represent units on an
actual sheet of paper. Model units indicate real-world distances and can fit a sheet
of paper.

The paper units manage the printable size of dimensions, annotations, and styles.
The paper units always appear at a 1:1 scale. The model units represent the
scaleable geometry in its real-world size. Both paper and model unit elements are
displayed at the same time.           

Because the drawing sheet dimensions, annotations, and styles use paper units by
default, scaling issues can arise as you set the sheet scale for the model unit
geometry.

Dimension text and annotations do not scale when you use the Scale command on
the Change toolbar; the scale of dimension text and annotations is based on the
sheet size that you select with the Sheet Setup command on the File menu.

Tip  If you insert an .IGR or .SYM document into the drawing sheet with the
Object command, the terminators, spaces, text, and styles appear in paper units
relative to the source document. The dimension lines and extension lines scale as
though they are in real-world units. This behavior can cause the dimensions and
text to appear very large or small in the container document.

You can set or change the size for dimension text and annotations by clicking the
Style command on the Format menu. On the Style dialog box, you select the type
of style you want to set or modify (dimension or text), and then click the New or
Modify button to set the font size for dimension text or a text box. Changing the
font size of dimension-text style or a text-box style changes only the dimension text
or annotations with the modified style applied to them.

You can also set the font size for individual dimension text or annotations by
overriding the style that you applied. You do this by selecting the dimension or text
box and editing its properties with the Properties command on the shortcut menu or
from the Edit menu.

You can adjust how the model units fit within the printable sheet area by clicking
the Sheet Setup command on the File menu. On the Size and Scale tab, you can
select a scale setting by clicking an item on the Select Scale dropdown list. The
value that you select causes the model to resize within the printable area, but
neither the paper unit information (dimensions and annotations) or model unit
information is scaled.
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Procedures to Explore in On-line Help
• Place a Linear, Angular, or Radial Dimension

• Place a Dimension Group

• Place a Symmetric Diameter Dimension

• Place a Driving Dimension

• Change a Driven Dimension to a Driving Dimension

• Move a Dimension

• Set the Dimension Units

• Format a Dimension or Annotation

• Measure an Area

• Measure a Distance

• Set Bearing and Azimuth

• Create a Variable with a Value or Expression

• Create a Variable with a Link to a Spreadsheet

• Create a Variable Using a Function or Subroutine
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