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Automatic Exposure

A button in the front panel that selects exposure settings for the image being scanned.

Before Automatic Exposure can be used, a selection area must be created in the Preview Area.

To use Automatic Exposure

1. Click Preview, if you have not already.
2. Create a selection area.
3. Click the Automatic Exposure button.

The Automatic Exposure settings are set for the part of the image in the selection area only. The 
settings, however, affect the entire image in the Preview Area.

The exposure settings that are affected by Automatic Exposure include Brightness, Contrast, and 
Highlight and Shadow.

To return to default values

Adjust the Brightness and Contrast controls to a setting of 125.

For more information about using Automatic Exposure, refer to your DeskScan II User's Guide.

Automatic Exposure and Automatic Find

When Automatic Find is active, DeskScan II will automatically perform Automatic Exposure on the image 
after it does a Preview Scan. Automatic Find is turned on or off with a check box in the Preferences 
dialog box under the Edit menu.



Automatic Find

A feature of DeskScan II software that automatically creates a selection area around the image during a 
Preview scan, performs Automatic Exposure on the image in the selection area, and selects an image 
type for the image. The selection area can be adjusted, if necessary, by dragging the sides to new 
positions. If the selection area is altered, click the Automatic Exposure button to re-adjust the brightness 
and contrast for the selected portion of the image. The image type can also be changed by selecting a 
new image type in the Type pop-up on the front panel.

Automatic Find functions only when there is no selection area already drawn in the Preview Area. It is 
turned on or off with a check box in the Preferences dialog box under the Edit menu.

If you are scanning more than one image and want to take advantage of Automatic Find, delete the 
selection area after you finish each scan by clicking outside the selection area. 

The Automatic Find feature does not take up additional memory or slow the operation of the DeskScan II 
software.

Related topics:
Setting Automatic Find for Preview scans
Setting Automatic Exposure for Preview scans
Setting Automatic Type for Preview scans
Setting the default type for Preview scans



Brightness

A control located in the front panel that changes the lightness or darkness of a scanned image.

For example, at a higher Brightness setting, the scanned image becomes lighter. At a lower Brightness 
setting, the image becomes darker.

The effects of adjusting Brightness can be seen immediately in the Preview Area if Live Preview is on.

To change the brightness setting, click or drag on the Brightness control. The Brightness settings range 
from 1 to 250. The default setting is 125.

Related topics:
Automatic Exposure
Contrast
Highlight and Shadow



Calibration

A process that compensates for the effects that particular printers, screens, and software applications 
can have on the scanned image's appearance after it is printed or when it is displayed on a monitor 
screen. DeskScan II lets you adjust for these effects by calibrating the monitor screen, the printer, and 
the application package used to print the image.

For best results displaying scanned images, calibrate your monitor by selecting Screen Calibration, from 
the Help menu.

For best results printing scanned images, use the pre-calibrated print paths found in the Path pop-up 
menu on the front panel.

You can also calibrate a printer or a print path that does not appear in the pop-up menu on the front 
panel.

Related topics:
Screen Calibration
Calibrating a print path



Color Adjustment

A tool available in the Tools menu that can be used to adjust hue and saturation. The Color Adjustment 
tool can be moved anywhere on the screen. This tool is not available if you are using an HP grayscale 
ScanJet scanner.

A Final Scan must be done prior to closing the Color Adjustment tool for the hue and saturation changes 
to affect the scanned image file. When the tool is closed, the hue and saturation settings change back to 
the default settings. 

All the adjustments made with the Color Adjustment tool are visible immediately in the Preview Area if 
Live Preview is on.

To adjust hue

1. Move the pointer over a desired color inside the color hexagon.
2. Click the mouse button.
3. View the results of the adjustment in the Preview Area.

To adjust saturation

1. Click on one of the arrows at either end of the saturation control.
2. View the results in the Preview Area.

To return to the default settings

Close the tool window.



Contrast

A control in the front panel that adjusts the difference between the light and dark areas of an image.

For example, on a monochrome monitor the highest contrast setting displays every dot in the image as 
black or white. The lowest contrast setting displays only gray dots -- no black or white.

The effects of changing the Contrast setting can be seen in the Preview Area if Live Preview is on.

To change the contrast level, click or drag the Contrast control to a new position. The settings range 
from 1 to 250. The default setting is 125.

Related topics:
Automatic Exposure
Brightness
Highlight and Shadow



Copy

The Copy command scans the portion of the image in the selection area to the Clipboard.

To scan to the Clipboard, select Copy from the Edit menu.

Although the Clipboard is often the easiest and quickest way of moving images to another application, 
the Clipboard is limited in the kinds of images it can transport. The limitations of the Clipboard are 
usually determined by the applications used with the Clipboard.

For simple black and white drawings, the Clipboard works well. For other kinds of images, you may need 
to use Final or Save to have DeskScan II send the scanned data directory to a file.



Custom Image Size

A menu command for creating, selecting, or removing a custom image size and for changing the units of 
measure.

To create a custom image size

1. Type a measurement in the Width box.
2. Type a measurement in the Height box.
3. Type a name for the custom size in the Name box and click Add (optional).
4. Click OK.

If you perform step 3, the image size is saved as a selection in the list box in the upper right corner of 
the dialog box. You can select the image size later by clicking on it.

After step 4, a selection area with the desired dimensions is created in the Preview Area. Drag the 
selection area over the portion of the image that you want to scan.

To remove a custom size

To remove a custom size from the box in the upper right corner of the dialog box, select the name of the 
Custom Image Size and click Remove.

Locking issues

If Lock is active when a custom image size is set, the new image size becomes locked.

To change the units of measure

1. Select the unit of measure from the Units pop-up menu.
2. Click OK.

Related topics:
Locking an Image Size
Scaling an Image to Fit a Specific Size



Custom Image Type

Lets you customize the selections in the Type pop-up menu in the front panel.

A Custom Image Type consists of Color Content and Style selections. The selections include gray-level 
and color choices, halftone patterns, drawing options, and sharpening levels.

The list on the right side of the dialog box shows the available image types. An image type with a 
diamond in front of it is a standard image type. Other image types may have been added.

Once a new image type is added, its name is included in the box and in the Type pop-up menu. The new 
image type automatically becomes the selected image type.

To create a custom image type

1. Click Black and White or Color from the Color Content section.
2. Click Drawing, Halftone, or Photo in the Style section.
3. Select options from any of the pop-up menus that are available.
4. Type a name in the Name box and click Add (optional).
5. Click OK.

In step 3, some pop-up menus are unavailable because they are inappropriate for the selections already 
made or because the menu selection is made automatically.

If you perform step 4, the image type is saved as a named custom image type and is available until it is 
removed. If step 4 is omitted, the new image type is available only until DeskScan II is closed. An 
unnamed image type is referred to as "Custom" in the Type pop-up menu.

Checked image types are ones that appear in the Type pop-up menu. They can be removed from the 
Type pop-up menu in the front panel by clicking on the check.

To remove a custom image type

1. Select an Image Type in the box in the right corner of the dialog box.
2. Click Remove.

Image types with diamonds in front of them are standard image types and cannot be removed. You can 
use them, however, as templates for creating your own custom image types.



Custom Preview Size

A menu command for changing the size of the Preview Area. The Preview Size dialog box also shows 
the amount of memory required for the current size of the preview area.

To change the size of the Preview Area

The two rectangles in the Screen section represent the front panel and the preview area. Drag the 
bottom right corner of the right rectangle to change the size of the preview area.

One reason to change the size of the Preview Area is to allow for a larger Preview Scan or Zoom Scan. 
By enlarging the Preview Area, you display the image on a larger area of the screen, which increases 
the amount of detail that you can see.

Alternately, one reason to reduce the size of the Preview Area is to minimize the amount of memory 
being consumed by DeskScan II.

To minimize memory usage

1. From the Edit menu, select Preferences.
2. Click the Color Preview check box to turn off Color Preview if it is on.
3. Click the Live Preview check box to turn off Live Preview if it is on.
4. Click OK to save the new settings and close the Preferences dialog box.
5. Reduce the preview area size.

Black and white Live Preview requires only one-third as much memory as color Live Preview.

Live Preview uses system memory first and then disk space if needed. If the Preview Area is using disk 
space, the speed of DeskScan II becomes slower.



Custom Print Path

A menu command used to add custom print paths for particular scanning and printing situations. A 
custom print path includes a resolution setting and a calibration for a particular output device and 
application. Once a custom print path is given a name and added to the other print paths, it is included in 
the box in the upper right side of the Custom Print Path dialog box and in the Path pop-up menu in the 
front panel.

Print paths with diamonds in front of them are standard print paths and cannot be removed. You can use 
them, however, as templates for creating your own custom print paths.

Related topics:
Adding a print path
Removing a print path
Resolution
Calibration
Calibrating a Print Path



Custom Print Path dialog box

The custom Print Path dialog box lets you select an existing print path or create your own custom print 
path. To create a custom print path you must enter the appropriate resolutions for the path and then 
calibrate the print path or select an existing calibration and create a new print path name.

Related topics:
Resolution
Calibration



Drawing options

Options for scanning drawings, line art, and spot color images. Drawing options are selected in the 
Custom Image Type dialog box.

Options

* Spot Color
* Detailed

The standard option for black and white drawings is Detailed. The standard option for color images is 
Spot Color.

Spot Color

Spot Color identifies the dominant colors in an image and changes each scanned dot in the image to 
match one of those colors.

Use the Spot Color option when scanning images containing a few solid colors and when you plan to 
edit the image in an image editor. With Spot Color selected, the scanning process creates an image file 
with large areas of a single color rather than dappled colors that need to be edited pixel by pixel.

Spot color can also be used effectively to scan black and white images that have just a few shades of 
gray.

Using Spot Color to scan color images can save you time and work if you plan to edit the image. 
However, even with Spot Color, you will need to do some editing to match the colors. Also, the scanner 
takes longer than usual to scan and process an image when Spot Color is used.

Sharpening options are unavailable when Spot Color is selected.

Detailed

Detailed matches all the scanned dots to one of the colors of a standard set. For example, if black and 
white is selected, then every dot is either black or white. If 16 colors are used, then each dot is adjusted 
to the nearest color.

Use Detailed to scan black and white line art, such as logos and text. Sharpening can be used with the 
Detailed option.



Emphasis

A tool used to adjust the midtones in an image. The Emphasis tool is available from the Tools menu and 
can be moved to any part of the screen.

The Emphasis tool is intended for experienced scanner users. The tool contains a tone map with three 
control points. The bottom control point adjusts the darker shades and the upper control point adjusts 
the lighter shades.

A pop-up menu at the bottom of the tool window offers pre-defined Emphasis settings which adjust the 
control points to achieve a specific effect. New selections can be saved and added to the pop-up menu.

To use the Emphasis tool

1. Position the pointer on one of the control points in the tool window.
2. Drag the control point to a new position.
3. Click Apply.
4. Click Save and type a name (optional).

After Apply is clicked, Live Preview shows the results of new Emphasis settings in the Preview Area.

A Final Scan must be done prior to closing the Emphasis tool for the changes to affect the scanned 
image file. When the tool is closed, the Emphasis settings change back to the default settings. 

Refer to your DeskScan II User's Guide for more information about the Emphasis tool.

To return to the default Emphasis settings

Select Normal from the pop-up menu and then click Apply. Another way to return to the default settings 
is to close the Emphasis tool.

Remove

The Remove button deletes an option from the pop-up menu. (Remove does not eliminate the effects in 
the Preview Area caused by using the Emphasis tool.)



Final Scan (Save, Save As)

A button in the front panel that saves the selected portion of an image to a file.

The Final button and the Save and Save As commands in the File menu are nearly equivalent. The 
difference is that the Save command automatically saves the image to the last file name entered.

Usually, a selection area is created in the Preview Area prior to a Final Scan. If a Final Scan is done 
without a selection area, the entire scanner copyboard is scanned and saved.

To save a file

1. Click Final.
2. Select the file format.
3. Type the file name.
4. Click Save.

In step 1, Save or Save As can be used instead of Final.

Be sure to keep the image in the same place on the scanner copyboard during the scanning process to 
ensure a good scan. Final Scan does not re-paint the image to the screen. Instead, the Preview Scan or 
Zoom Scan image remains in the Preview Area. 

In the Save Image dialog box, several file formats are provided. Select one that is accepted by the 
application(s) you intend to use with the scanned image.



Halftone options

Halftones are a style of scanning that uses dot patterns to simulate the many shades in a photograph. 
Halftones are used to print photos on desktop printers that can print only a small range of colors or just 
black.

Use a halftone image type if the image is to be printed on a desktop printer, and you do not intend to edit 
the image. Do not use image editing software to resize or adjust the color or tone of halftones.

Halftone options are available in the Custom Image Type dialog box. Each halftone pattern has a 
different effect when used with a photo. Samples shows how a photo looks when scanned with each 
halftone pattern and printed.

Diffusion is the default option and often provides the best scanned image. Use Normal if the image is to 
be photocopied.

Refer to your DeskScan II User's Guide for more information about halftones and for printed examples.



Highlight and Shadow tool

A tool for adjusting the highlight and shadow points in an image. The Highlight and Shadow tool is 
available from the Tools menu. The tool can be moved anywhere on the screen.

The Highlight and Shadow tool provides a way to adjust the exposure settings. Exposure can also be set 
with Automatic Exposure, Brightness, and Contrast.

To adjust the highlight and shadow points

1. Click the Highlight button (in the upper right corner of the tool window).
2. Using the mouse, move the bubble cursor to the highlight point in the image and click.
3. Click the Shadow button (in the lower right corner of the tool window).
4. Using the mouse, move the bubble cursor to the shadow point in the image and click.

Usually, use the darkest point in the selection area as the shadow and the lightest point as the highlight.* 
The effects of changing the Highlight and Shadow settings can be seen in the Preview Area if Live 
Preview is on.

Refer to your DeskScan II User's Guide for more information about the Highlight and Shadow tool.

To return to the default settings

Set the Highlight and Shadow controls to 125.

Contrast and Brightness adjustments

Whenever the Highlight and Shadow settings are adjusted, the Brightness and Contrast controls on the 
front panel are automatically adjusted to their corresponding values, and vice-versa.

* For critical applications, where precise Highlight and Shadow adjustments are important, perform three 
or four Preview or Zoom Scans to warm up the lamp prior to using the Highlight and Shadow tool.



Information tool

The Information option on the Tools menu displays information about your scanning process including 
scanning resolution, image type, whether you have an automatic document feeder ("ADF" on the dialog 
box button) or a transparency adapter (scanner designation with "/T" on the dialog box button), and the 
level of sharpening currently applied. The information displayed in the Information tool also depends on 
the Print Path or Image Type currently selected.

To display the Information tool
From the Tools menu, select Information.

To change data that is shown in the Information tool

You cannot change anything directly in the Information tool. You must make changes to this information 
in other dialog boxes, or by changing the configuration of your scanner.

Related topics:
Preferences
Custom Print Path



Lock

A button in the front panel used to maintain a constant image size by locking the height and width 
dimensions. The lock button is useful when scanning images to a specific size.

To size an image using lock

1. Create a selection area with the desired height and width dimensions.
2. Click the lock button.
3. Drag the sides of the selection area until the desired portion of the image fits within the selection 
area.

With Lock on, the portion of the image in the selection area and the Scaling control on the front panel 
work together to keep the image size constant. As the portion of the image in the selection area 
changes, the scaling percentage changes. The same image dimensions remain for the final scanned 
image.

Locking remains on until the Lock button is clicked again or DeskScan II is closed.

Custom Image Size

If locking is on when a new image size is selected in the Custom Image Size dialog box, the new size is 
accepted and is locked.



Mirror

A button in the front panel that creates a mirror image of the original in the Preview Area.

The Preview Area shows the effects of changing the Mirror button if Live Preview is on.



Negative

A button in the front panel that converts the white areas of an image to black and black areas to white. 
For color images, the complementary color is displayed.

In general, Negative is useful for drawings and spot color images.

The Preview Area shows the effects of Negative if Live Preview is on.



Non-uniform scaling

A scaling method that lets you control height and width separately while stretching or shrinking an 
image. When Non-Uniform Scaling is active, separate controls are available for adjusting the image 
width and height.

The opposite, Uniform Scaling, maintains a proportional relationship between height and width when you 
scale an image. Uniform scaling is the default scaling setting.

Related topics:
Scaling an Image to a Specific Size



Path

A pop-up menu in the front panel that describes the target printer and any software applications used 
with the image.

The Path pop-up menu provides print path selections. The print path contains the following items of 
information:

        -    Resolution-Drawings & Halftones
        -    Resolution-Photos
        -    Calibration
        -    Path

When you select a print path, this information is automatically set for you. You can find the values for 
any of these items by opening the Custom Print Path dialog box and selecting the item.

To create a custom print path, select Custom Print Path from the Custom menu.

Every printer and screen, and some software applications, affect the appearance of the images they 
display. The predefined print paths in the Path pop-up menu have been designed to compensate for 
these factors.

When viewing scanned images in other applications, the tone or color of the image may appear different 
than in the Preview Area. If you intend to modify the tone or color in the application, use the "Screen" 
print path selection.



Photo options

Settings used when scanning images with many shades of gray or color. Original photographs, 
magazine and newspaper photographs, and shaded illustrations are examples.

Color variations in each dot of the image are measured and saved when a photo image type is used.

Typically, use photo image types to scan images that are to be printed or displayed on grayscale or color 
monitors, imagesetters, and typesetters. The files can be edited and modified with image editing 
software applications.

Photo options are selected in the Type pop-up menu in the front panel and in the Custom Image Type 
dialog box.

Photo Options in Type Pop-up Menu

* Black and White: 256 Grays
* Color: 256 Colors
* Color: Millions of Colors

Other photo settings, such as Black and White (16 Grays), Color (16 Colors), and Sharpening are 
available in the Image Type dialog box in addition to any custom types that you create.

Sharpening options for photos can also be selected in the Custom Image Type dialog box.

Related topic
Color Content



Preferences

A dialog box that contains settings for customizing how DeskScan II scans and displays images. You 
can use it to set the following preferences:

Using less memory
Image quality
Automatic Find
Automatic Exposure
Automatic Type
Default Types

To open the Preferences dialog box

From the Edit menu, select Preferences.



Preview Area

The rectangular framed area to the right of the DeskScan II control panel. 

The ability to display the effect that changing a setting has on an image in the Preview Area is called 
Live Preview.

The size of the Preview Area can be changed to accommodate large Zoom Scans or to reduce the 
amount of memory used by DeskScan II.

Related topics:
Changing the Size of the Preview Area
Custom Preview Size



Preview scan

A button in the front panel that starts a low-resolution scan of the scanner copyboard. The scanned 
image resulting from the Preview scan appears in the Preview Area.

When Automatic Find is active, DeskScan II automatically creates a selection area around the image, 
selects an image type, and performs Automatic Exposure during a Preview scan.

Once a Preview scan is done and the image is adjusted using DeskScan II controls and tools, clicking 
Final Scan saves the selected portion of the image to a file.

Related topics:
Creating a selection area
Using less memory
Setting Automatic Find for Preview scans
Setting Automatic Exposure for Preview scans
Setting Automatic Type for Preview scans
Setting default type for Preview scans



Resolution

The number of dots per inch to be scanned with a Final Scan. Resolution is selected in the Custom Print 
Path.

To get the best quality image, the printer or screen resolution needs to be considered. DeskScan II 
provides scanning resolution settings to be used for some popular printers and displays. However, for 
others, resolution settings must be adjusted.

Setting the resolution

1. Type the printer resolution in the boxes for Drawing or Halftone Resolution.
2. Divide by two the value of the resolution used in step 1 and type it in the boxes for Photo 
Resolution.

The steps above demonstrate a typical situation. For photos, a scanner resolution of 150 dpi provides 
good quality.

Once a high level of quality is achieved, increasing the resolution creates only a slight improvement in 
the quality of the scanned image. However, every time the resolution is doubled, the resulting file size of 
the scanned image quadruples.

Resolution and scaling

The resolution settings also determine the scaling range. For instance, on an HP ScanJet 4c scanner 
with a Drawings and Halftones resolution setting of 300 dpi, the scaling range is from 4% to 800%. With 
a resolution setting of 75 dpi, the scaling range is from 16% to 32600%. With a resolution setting of 2400 
dpi, the scaling range is from 1% to 100%. Other HP ScanJet scanners have different relationships 
between resolution and scaling.



Samples

A command in the File menu that prints halftone samples of the image in the selection area. 

One halftone sample per page is printed. The samples can be Black and White or Color, or Both. If you 
choose Both, 12 pages of samples are printed.



Scanner Tests

A program which evaluates the scanner, cables, and scanner driver. Once the tests begin, instructions 
and help are provided in the Scanner Test screens.

If your computer uses Windows 3.1x or Windows for Workgroups 3.11

1. Double-click the Scanner Test icon in the HP DeskScan II Program Manager group.
2. Click the button for the item you want to test.

If your computer uses Windows 95

1. Open the Control Panel and double-click on the HP ScanJet Properties icon
2. When the utility opens, choose the Test tab.
3. Click the button for the item you want to test.



SCSI Addresses

A program which displays a diagram of the peripherals in the SCSI system connected to your computer 
system. If a Scanner is correctly connected to your computer, a picture of a scanner is displayed in the 
SCSI chain in the diagram. If you haven't connected a scanner yet, use the program to identify the 
available SCSI addresses.

If your computer uses Windows 3.1x or Windows for Workgroups 3.11

1. Double-click the SCSI Addresses icon in the HP DeskScan II Program Manager group.
2. Click on the scanner picture to select the scanner as your default.

If your computer uses Windows 95

1. Open the Control panel and double-click on the HP ScanJet Properties icon.
2. When the utility opens, choose the SCSI tab to see the available SCSI addresses.
3. Choose the SCSI tab and select the scanner you want to use from the drop down list. If you want 
to make the selected scanner the default, click Default.



Selection Area

The portion of the Preview Area that you want to scan. The selection area is shown by a dashed outline 
in the Preview Area.

When Automatic Find is active, DeskScan II software automatically creates a selection area around the 
image during a Preview Scan. When Automatic Find is not active, the user must create a selection area.

To make a selection area

1. Position the pointer in the Preview Area.
2. Drag the mouse in any direction.
3. Release the mouse button.

If a selection area is not made, the entire scanner copyboard is scanned and saved during a Final Scan.

Some features in DeskScan II are available only if a selection area is made. The Zoom Scan, Lock, and 
Automatic Exposure are examples.

To adjust the size of the selection area

1. Position the cursor on any side or corner of the selection area.
2. Press the mouse button and drag the side to a new position.
3. Release the mouse button.

If Lock is on, the sides and corners of the selection area cannot be adjusted.

To move the selection area

1. Position the cursor inside the selection area.
2. Press the mouse button and drag the selection area to a new position.
3. Release the mouse button.

To remove a selection area

Click anywhere in the Preview Area outside of the selection box.

Lasso

Another way of selecting an area is called Lasso. It can be used to create an irregularly shaped 
selection area inside the Preview Area.



Sharpening

A style of scanning that enhances the details of most images. Sharpening options are available in the 
Custom Image Type dialog box.

Use Sharpening to:

* Enhance low resolution scans of drawings and photos.
* Embellish fine details in photos to make them more noticeable than in the original image.
* Highlight the subtleties in drawings.

Avoid Sharpening when:

* Scanning printed or previously halftoned images.
* Scanning images that contain small blemishes.

Sharpening may accentuate undesirable patterns that sometimes arise when a printed or halftoned 
image is scanned. Sharpening may also accentuate any flaws or blemishes contained in the original 
image.

Sharpening is available to use with every image type option except Spot Color. The Preview Area 
displays the effects of changing the Sharpening setting, if Live Preview is on.

Refer to your DeskScan II User's Guide for more information and examples of sharpening.



Size

An indicator in the front panel that estimates the file size needed to store the selected portion of the 
image.

The size of the selection area and the file format, scaling percentage, resolution, and image type 
selected affect the file size.



Transparency Adapter

The optional Transparency Adapter lets you scan either opaque (paper) documents or transparencies 
from an HP ScanJet IIcx, 3c, or 4c scanner. Once the Transparency Adapter is installed and turned on 
the procedure for scanning an image is the same as for scanning photos or other paper documents. The 
Transparency Adapter will act like a standard scanner lid if its switch is turned off or if its lid is up. You 
can use the Information tool to see the current status of the Transparency Adapter.



TWAIN

TWAIN is a standard for letting applications call scanning software and receive data automatically from 
that software. It saves the user from having to separately open the scanning software and use the 
clipboard to transfer the image. TWAIN is used from within the calling application (such as an image 
editor). It will automatically open DeskScan II and initiate a Preview scan. When you click Final it will 
automatically put the scanned image into the calling application.

For more detailed instructions see Basic Steps to Scanning from Within an Application. You can get 
additional technical information about TWAIN (and other subjects) from HP FIRST.



Type

A pop-up menu in the front panel that lets you select how the image is to be scanned and processed.

The Type pop-up menu provides image type selections. The image contains the following items of 
information:

-    Color content (Black and White or Color)
-    Color depth (16 grays and 256 grays for Black and White, and 16 colors, 256 colors, or Millions of 
Colors for Color images)
-    Scan style (Drawing, Halftone, or Photo)
-    Sub-styles (Spot Color or Detailed for Photos and Normal, Diffusion, Fine, Extra fine, Horizontal 
Line, and Vertical Line for Halftones)

When you select an image type, this information is automatically set for you. You can find the values for 
any of these items by opening the Custom Image Type dialog box and selecting the item.

When Automatic Find is active, DeskScan II will automatically select an image type for the image after it 
does a Preview Scan. Automatic Find is activated by a check box in the Preferences dialog box under 
the Edit menu.

There are two basic image types: drawings and photos. The other selections are provided for special 
purposes.

Black and white and color options for both drawings and photos are available. The Black and White and 
Color descriptions refer to whether an image should be scanned for a black and white printer (or screen) 
or for a color printer (or screen).

Color and Black and White do not refer to the content of the image being scanned.

Drawing
Used for images with large areas of a single color. Line art, logos, and solid color images are examples 
of the kinds of images to be scanned with a Drawing image type.

Files created with a Drawing image type can be edited easily in an image editor.

Photo
Used for images with many shades of gray or color. The color variation in an image is captured pixel-by-
pixel when a photo image type is used.

A photo image type is used to scan images that are to be printed or displayed on imagesetters or color 
screens. Also, use a photo image type to scan an image that is to be edited.

Original photographs and pictures in books, magazines, and newspapers are examples of the kind of 
images to scan.



Halftone
Used to optimize the quality of scanned photos when printed on desktop printers.

Images scanned as a halftone image type are processed in a way that simulates the many shades of 
color in the image when it is printed. The halftone process is needed for images printed on desktop 
printers because they can only print a small range of colors.

Millions of Colors
Used to scan images that are to be displayed or printed on 24-bit color displays or imagesetters.

Files created with the Millions of Colors setting often contain more than a megabyte of data. For 
example, a half-page scanned image creates a 12 MB file.

Other image type considerations
* Drawings and halftones take less memory than photos.
* Drawings and photos can be edited with most image editing applications.
* Halftones should not be edited with image editing applications.
* Halftone examples can be printed by selecting Samples.

Besides the standard image types (types with diamonds in front of them), custom image types can be 
created in the Custom Image Type dialog box.



Uniform scaling

A scaling method that maintains the proportional relationship of the height and width when you scale an 
image. When Uniform Scaling is active, only one scaling control is available for adjusting the image 
width and height. Uniform scaling is the default scaling setting.

The opposite, Non-Uniform Scaling, lets you control height and width separately while stretching or 
shrinking an image.

Related topics:
Scaling an Image to a Specific Size



Zoom scan

A button in the front panel that rescans and enlarges the selected portion of an image to the maximum 
size allowed by the Preview Area.

Zoom Scans allow you to select a more precise area of the image for scanning.

If the selected portion includes most of the Preview Area, the Zoom Scan only slightly magnifies the 
view. To solve that, enlarge the size of the Preview Area or create a smaller selection area.

To use Zoom

1. Click Preview.
2. Create a selection area.
3. Click Zoom.

To return to the normal view

Click Preview to return to the normal view. The Zoom button is unavailable until a selection area is 
created.



Glossary

AccuPage
acquire
ASPI
automatic document feeder (ADF)
automatic exposure
automatic find
CAM
clipboard
color hexagon
color separation
copyboard
diffusion
dots per inch (dpi)
drawing
Encapsulated Postscript (EPSF)
file format
front panel
gamma correction
gray levels
halftone
highlight
HP FIRST
hue
image size
image type
lasso
live preview
lock
midtone
non-uniform scaling
OCR
OLE
photo
pica
PCX
pixel
point
posterization
print path
resolution
saturation
scaling
select source
selection area
shadow
sharpening
spot color
SCSI
TIFF
tone
tone map
TWAIN



transparency adapter
uniform scaling



About DeskScan II

A dialog box that provides copyright information and version number of DeskScan II.



Scanning into an application with TWAIN

TWAIN compliant applications let you start a scan from inside the application. When you click Final in 
DeskScan II, the scanned image appears in the current frame or at the current cursor location. The 
following steps show the general procedure for scanning directly into TWAIN compliant applications. The 
steps needed in some TWAIN compliant applications may not match these steps. See your application 
documentation if you have any questions.

Put an image on the scanner copyboard.

1. If you have more than one possible scanning source:
        -    From the application's File menu choose Select Source.
        -    Choose DeskScan II as the source.

2. Open the document you want to scan into, and go to where you want the image placed.

3. From the File menu, select Acquire. DeskScan II starts, and automatically performs a Preview 
scan.

        Make adjustments (optional)
        -    Adjust the selection area to include only the part of the image you need.
        -    Change the exposure settings.
        -    Choose a new image type from the Type pop-up menu.
        -    Choose a print path from the Path pop-up menu.
        -    Sharpen the image.
        -    Scale the image to just the right size.

4. Click Final.

DeskScan II closes, and the image appears in your application.



Scanning into an application with OLE

OLE compliant applications let you start a scan from inside the application. When you click Final in 
DeskScan II, the scanned image appears in the current frame or at the current cursor location. The 
following steps show the general procedure for scanning directly into OLE compliant applications. The 
steps needed in some OLE compliant applications may not match these steps. See your application 
documentation if you have any questions.

Put an image on the scanner copyboard.

1. Open the document you want to scan into, and go to where you want the image placed.

2. From the application's Insert menu choose Object.
        -    Choose DeskScan II as the object type.

3. Click OK. This opens DeskScan II.

        Make adjustments (optional)
        -    Adjust the selection area to include only the part of the image you need.
        -    Change the exposure settings.
        -    Choose a new image type from the Type pop-up menu.
        -    Choose a print path from the Path pop-up menu.
        -    Sharpen the image.
        -    Scale the image to just the right size.

4. Click Final.

DeskScan II closes, and the image appears in your application. If you double-click on the image, the 
an image editor will open with the image displayed for editing.



Bringing an image into your image editor

Images scanned with DeskScan II can be brought into many image editors and "paint" programs. The 
following instructions are a general outline of how to bring scanned images into image editors. You may 
need to adjust the steps slightly for your image editor. Some of these techniques may work better than 
others for various image types.

File method

1. Scan an image and save it using the TIFF format.
2. Open your image editor.
3. From the image editor File menu, choose Open.
3. Select the file scanned in step 1 and click OK.

Clipboard method

Although the clipboard method it easier than saving the image to a file, some images may be modified 
as they pass through the clipboard. If this happens, use the File method for bringing the image into your 
image editor.

1. Preview the image.
2. From the DeskScan II Edit menu, choose Copy.
3. Open your image editor.
4. From the image editor File menu, choose New.
5. From the image editor Edit menu, select Paste.

Direct method (OLE or TWAIN compliant applications only)

Some applications let you start a scan from inside the application. When you click Final in DeskScan II, 
the scanned image appears in the current frame or at the current cursor location. You will need to 
experiment to determine if your image editor can import directly without modifying the particular image 
you are scanning. If you cannot get the results you want, use the File method for bringing the image into 
your image editor.

Direct scanning can be accomplished through OLE (object linking and embedding) and/or TWAIN, 
depending on the application. Check the user's manual for the application to see if is supports either of 
these methods.



Color content

Determines the gray levels or the number of colors used when scanning an image. Select Color Content 
options in the Custom Image Type dialog box.

Black and white options
* Automatically defined for drawings and halftones
* 16 Grays for photos
* 256 Grays for photos

Color options
* Automatically defined for drawings and halftones
* 256 Colors for photos
* Millions of Colors for photos



Exit

Exit closes DeskScan II.



Selecting a file format

1. Click on a file format in the Save Image dialog box.
2. Type the file name.

A file extension is automatically added to the file name for the file format selected. For example, if TIFF 
is selected, the extension ".TIF" is added to the file name.

Some applications that accept scanned images can do so only in a particular file format. Choose a file 
format that is accepted by the application you will use with the image file.

One of the most widely accepted file formats is TIFF. If the application accepts TIFF, select it from the 
pop-up menu.

File format options
* EPSF(EPS)
* EPSF with screen image(EPS)
* OS/2 Bitmap (BMP)
* Publisher's Paintbrush (PCX)
* TIFF 5.0(TIF)
* TIFF 5.0 Compressed(TIF)
* Windows 3.0 Bitmap (BMP)

TIFF 5.0
TIF is widely accepted by general purpose applications and is the recommended format for most 
scanned images.

TIFF 5.0 Compressed
The amount of compression achieved in the TIFF Compressed format varies widely with the image type 
and the content in the image. Images with large areas containing the same color compress well.

The compressed TIFF format is not as widely accepted as the standard format. It can take longer to load 
an image if it has been compressed.

EPSF
EPSF is used primarily for saving files that are to be used with Postscript illustration applications. Two 
different EPSF formats are available, one that can display the screen image and one that cannot. 

EPSF files cannot be edited. However, using "EPSF with screen" you can view the image in some 
applications. One drawback to the "EPSF with screen" format is that it creates larger files than the 
ordinary EPSF files.

File format problems
If an application accepts scanned files, but not in a file format available in the Save Image dialog box, 
you might use an image file conversion program to convert from TIFF to the accepted file format.



DeskScan II Help

Quick Help, Getting Started, Tasks, and Index Help are provided to make DeskScan II easy to learn and 
easy to use. The "DeskScan II User's Guide" and "DeskScan II Quick Reference Guide" complement 
these Help items.

The user's guide explains and guides you through basic scanning concepts. The on-line help describes 
the features and functions in DeskScan II and it gives step-by-step instructions for doing scanning tasks.

Getting around in Help

When the Help window is open, three buttons are provided to help you travel through the Help topics. 
The buttons allow you to browse forward, browse backward, and to go back to the previous topic.

Words that have a solid underline "jump" to another topic when they are clicked. Words with a dotted 
underline provide definitions.

To read a definition, position the pointer on a word with a dotted underline word. Press and hold the 
mouse button until you are done reading.

To print a Help topic, select Print under the File menu. Help topics print quickly, but those with graphics 
take longer than those with just text.

Quick Help

A context-sensitive method for selecting Help on the menus or any part of the front panel. Start Quick 
Help by pressing the Shift and F1 keys at the same time.

When Quick Help is on, the cursor changes into a question mark with an arrow. Use the top part of the 
arrow to select any control, pop-up menu, button, or menu item that you want help on.

To cancel Quick Help, select the Quick Help menu with the question mark cursor.

Getting Started
A brief guide to the basic steps of scanning.

Index Help
A list of Help topics. To get help on a topic, click on it. The F1 key starts Index Help.

Tasks
A list of topics that provide step-by-step instructions for doing typical scanning tasks.

To see the list of Tasks once you are in the Help program, click the Home button and then click    on 
"Tasks."



Lasso

A selection tool used to create a non-rectangular selection area.

To use the Lasso

1. Position the mouse cursor in the Preview Area.
2. Press and hold the Control key and then press the mouse button.
3. Draw an enclosed area around the desired portion of the image in the Preview Area.

To change back to a rectangular selection area

1. Click outside the existing selection area but still in the Preview Area.
2. Drag the mouse to create a new selection area.

Zoom, Automatic Exposure, and Lock are unavailable until a selection area is made.



Print

A command in the File menu that sends the portion of an image in the selection area to the selected 
printer. If a selection area has not been created, the entire scanner copyboard is scanned and printed.

Steps to printing

1. Select a print path from the Path pop-up menu.
2. Click Print in the File menu.

Printer Setup, a Windows system command in the File menu, sets up or changes a printer, sets the 
page orientation, loads fonts, and provides other printer options.

To set up a printer

1. Click Printer Setup from the File menu.
2. Select a printer from the Printer list box in the Printer Setup dialog box.
3. Click Setup in the Printer Setup dialog box.
4. Select the proper resolution.
5. Click OK in the Print dialog box.
6. Click OK in the Setup dialog box.

To install a new printer on your system, you need to use the Windows Control Panel. For more 
information about installing a printer, refer to your Windows documentation or use the Control Panel 
Help.

Related topics: 
Calibrating a Print Path
Adding a New Print Path



Rotating an image

DeskScan II cannot rotate an image while it is scanning. If you need a rotated image (e.g. you are 
scanning a landscape-mode photo) you will need to bring the scanned image into your image editor and 
rotate it appropriately.



Save Image

1. Select a file format.
2. Type the file name in the Name box.
3. Click Save.

When typing the file name, you do not need to type the file extension. DeskScan II automatically adds a 
file extension based on the file format you select.



Screen calibration

Adjusts the computer screen to improve the way the Preview Area displays shades and colors. Screen 
calibration is available only for computer screens that can display 256 or more colors.

VGA monochrome and 16-color screens cannot be calibrated using this program.

Screen calibration is needed because of the differences in the way each screen displays color images. 

The calibration process is similar to gamma correction.

Instructions for doing a screen calibration are provided in the Screen Calibration dialog box. You may 
want to repeat the calibration if lighting conditions change.



Save Calibration dialog box

Type in the name for the calibration.

The name is added to the Calibration pop-up menu as a new selection.



Save Emphasis dialog box

Type in a name that describes the Emphasis settings.

The name is added to the Emphasis pop-up menu as a new selection.



Scanning from an ADF
Using the ADF, you can scan multiple pages without reloading the scanner. If you are using an HP 
ScanJet color scanner with an ADF, you can preview each image before scanning it.

Scanning and storing pages as the same type
Scanning and storing pages as different types

You can also use the ADF through Visioneer PaperPort. This lets you scan stacks of paper into a single 
file.

Related topics: 
ADF Scanning Options



Setting ADF Scanning options

If you have an Automatic Document Feeder (ADF) you can select the paper size you will be scanning.

1. From the Edit menu, select Preferences.
2. Click the Allow Preview Scans check box to enable or disable Preview scanning.
3. Select the paper size you will be scanning.
4. Click OK.



Scanning the same type pages from an ADF
If you want all of the pages scanned from the ADF to be stored as the same type image, with the same 
settings, perform the following steps:

1. Put the pages in the ADF (see the directions that came with the ADF).
2. Change pages to the desired type/values on the DeskScan II window.
3. Click Final. The Save As dialog box appears.
4. Specify a file type and name.
5. Click OK. After the page is saved as a file, the ADF ejects it.
6. Repeat steps 3 through 5 until all pages are scanned.

Tip: Clicking Final without clicking Preview lets you bypass auto find, auto exposure, and auto type. This 
lets you feed pages continuously from the ADF because the initial type/values are used for the rest of 
the scans. A new page is scanned each time you click Final and specify a file type and name.

Related topics: 
ADF Scanning Options
Scanning and storing pages as different types



Scanning different type pages from an ADF
With an HP ScanJet color scanner, you can scan pages with the ADF to be stored as different type 
images, or with different settings. Perform the following steps:

1. Put the pages in the ADF (see the directions that came with the ADF).
2. Click Preview in the DeskScan II window. DeskScan II loads and scans the first page and shows an 
image in the preview area.
3. Click outside the selection area in the preview window. The selection box disappears and 
DeskScan II defaults to the page size you set in the Preferences dialog box.
4. Change the settings as desired.
5. Click Final to scan and save the page with the desired settings. The Save As dialog box appears.
6. Specify a file type and name.
7. Click OK
8. Repeat steps 2 through 7 until all pages are scanned.

Tip: Clicking Preview lets you apply auto find, auto exposure, and auto type to each page.

Related topics: 
ADF Scanning Options
Scanning and storing pages as the same type



Scanning tasks

Scanning an image

Using DeskScan II
          Scanning to a file with DeskScan II
          Scanning from within an application with DeskScan II
          Zooming in on a selected area
          Scanning images to the Clipboard
          Changing the size of the Preview Area
          Printing a proof of an image before saving it
          Printing halftone samples
          Scanning from an ADF
Using Visioneer PaperPort
          Scanning a single page to the desktop
          Scanning multiple pages to the desktop
          Annotating scanned documents
          Faxing scanned documents
          Sending scanned documents via e-mail
          Converting scanned documents to text
          Managing scanned documents
Examples (Using DeskScan II as a Standalone application)
          Scanning a black and white drawing for a desktop-printed document
          Scanning a color drawing for a desktop-printed document
          Scanning a photograph for a desktop-printed document
          Scanning a black and white drawing for a typeset document
          Scanning a color drawing for a typeset document
          Scanning a photograph for a typeset document
          Scanning a color drawing for a color printer
          Scanning a color photograph for a color printer
          Scanning an image For Position Only (FPO)
          Scanning an image for display on a computer screen

Adjusting an image

Scaling an image to a specific size
Adjusting exposure
Sharpening an image
Bringing an image into your image editor
Rotating an image with your image editor
Adjusting color

Customizing DeskScan II

Changing the units of measurement
Locking images to one size
Changing the size of the Preview Area
Setting Preferences
          Using less memory



          Image quality
          ADF Scanning Options
          Automatic Find
          Automatic Exposure
          Automatic Type
          Default Type
Adding a print path
Adding a custom image type
Calibrating a print path
          Printing a calibration target
          Scanning a calibration target
          Creating a print path
          Removing a print path
Calibrating the computer screen



Getting started with your scanner

Put the drawing on the scanner copyboard.

Scan a drawing

1. Click Preview.

Make adjustments
        -    Select Black and White Drawing from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu.
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control.

2. Click Final.

Once you have tried scanning a drawing to see how the basic process works, you should calibrate your 
computer screen before you try to do any additional scanning. You should only need to calibrate your 
computer screen once unless you get a new monitor or the lighting conditions in your work area change 
drastically.

1. Select Screen Calibration from the Help menu.
2. Follow the instructions in the dialog box to calibrate your screen.

Related topics:
Scanning from within an application
Advanced Scanning
Task Index
Using Help



Scanning to a file

Put an image on the scanner copyboard.

1. Click Preview

        Make adjustments (optional)
        -    Adjust the selection area to include only the part of the image you need.
        -    Change the exposure settings.
        -    Choose a new image type from the Type pop-up menu.
        -    Choose a print path from the Path pop-up menu.
        -    Sharpen the image.
        -    Scale the image to just the right size.

2. Click Final.



Scanning a single page to the Visioneer PaperPort desktop

You must scan pages onto the PaperPort desktop before you can use any of the other Visioneer 
PaperPort features. To scan a single image to the desktop, do the following:

1. Put a page on the scanner.
2. Start Visioneer PaperPort. The Visioneer PaperPort desktop appears.
3. Click the Scan button on the Visioneer PaperPort command palette. Visioneer PaperPort opens 
DeskScan II, which starts an automatic preview scan of the image.
4. Change the settings on the DeskScan II windows as desired.
5. Click Final on the DeskScan II window. The image is scanned and put on the Visioneer PaperPort 
desktop as a thumbnail.



Scanning multiple pages to the Visioneer PaperPort desktop

You must scan pages onto the PaperPort desktop before you can use any of the other Visioneer 
PaperPort features. To scan a single image to the desktop, do the following:

1. Put pages into the automatic document feeder (ADF).
2. Start Visioneer PaperPort. The Visioneer PaperPort desktop appears.
3. Click the Scan button on the Visioneer PaperPort command palette. Visioneer PaperPort opens 
DeskScan II.
4. Change the settings on the DeskScan II windows as desired.
5. Click Final on the DeskScan II window. All pages are scanned and appear on the Visioneer 
PaperPort desktop as a stack of thumbnails.



Scanning a black and white drawing for a desktop printer*

Put the drawing on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select Black and White Drawing from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu.
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control.

2. Click Final.

To save the image to the Clipboard instead of to a file, select Copy from the Edit menu instead of 
clicking Final. 

Refer to the DeskScan II User's Guide for more information about choosing an image type and scanning 
basics.

* black and white



Scanning a color drawing for a desktop printer*

Put the drawing on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select Black and White Halftone from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu.
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

To save the image to the Clipboard, select Copy from the Edit menu instead of clicking Final.

Refer to your DeskScan II User's Guide for more information about choosing an image type and 
scanning basics.

* black and white



Scanning a photograph for a desktop printer*

Put the photograph on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select Black and White Halftone from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu.
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

To save the image to the Clipboard, select Copy from the Edit menu instead of clicking Final.

Refer to your DeskScan II User's Guide for more information about choosing an image type and 
scanning basics.

* black and white



Scanning a black and white drawing for a phototypesetter

1. Click Preview.

Make adjustments
        -    Select Black and White Drawing from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu. 
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

If this is the first time you are scanning to a phototypesetter, you may need to calibrate and add a print 
path before selecting a print path in step 1.

For best results, use a calibrated print path.

To save the image to the Clipboard, select Copy from the Edit menu instead of clicking Final.

Refer to your DeskScan II User's Guide for more information about choosing an image type and 
scanning basics.



Scanning a color drawing for a phototypesetter

Put the drawing on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select Black and White Photo from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu. 
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

If this is the first time you are scanning to a phototypesetter, you may need to calibrate and add a print 
path before selecting a print path in step 1.

For best results, use a calibrated print path.

To save the image to the Clipboard, select Copy from the Edit menu instead of clicking Final.

Refer to your DeskScan II User's Guide for more information about choosing an image type and 
scanning basics.



Scanning a photograph for a phototypesetter

Put the photograph on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select Black and White Photo from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu. 
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

If this is the first time you are scanning to a phototypesetter, you may need to calibrate and add a print 
path before selecting a print path in step 1. 

For best results, use a calibrated print path.

To save the image to the Clipboard, select Copy from the Edit menu instead of clicking Final.

Refer to your DeskScan II User's Guide for more information about choosing an image type and 
scanning basics.



Scanning a color drawing for a color printer

Put the drawing on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select Color Drawing from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu. 
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

If this is the first time you are scanning to a color printer, you may need to calibrate and add a print path 
before selecting a print path in step 1.

For best results, use a calibrated print path.

To save the image to the Clipboard, select Copy from the Edit menu instead of clicking Final.

Refer to your DeskScan II User's Guide for more information about choosing an image type and 
scanning basics.



Scanning a photograph for a color printer

Put the photograph on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select Color Photo or Millions of Colors from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu.
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

If this is the first time you are scanning to a color printer, you may need to calibrate and add a print path 
before selecting a print path in step 1.

For best results, use a calibrated print path.

To save the image to the Clipboard, select Copy from the Edit menu instead of clicking Final.

Refer to your DeskScan II User's Guide for more information about choosing an image type and 
scanning basics.



Scanning an image For Position Only (FPO)

Put the image on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select Black and White Drawing or Black and White Halftone from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu.
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

In step 1, consider selecting Screen as your calibration. It provides an adequate representation of the 
image without using much memory or file space.



Scaling an image to a specific size

1. Scan an image.
2. Create a selection area around the portion of the image to scan.
3. Use the Scaling control to adjust width and height.

As the scaling percentage is changed in step 3, the resulting image width and height are shown beneath 
the scaling control.

Another way to select a specific image size is to use Image Size from the Custom menu. There, just type 
in the specific dimensions for image width and height.

Related topic:
Locking images to one size



Scanning an image for display on a computer screen

Put the image on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select an image type from the Type pop-up menu.
        -    Select Screen from the Path pop-up menu.
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Click Final.

Before doing step 1 you need to calibrate your computer screen. To do that, select Screen Calibration in 
the Help menu.



Adjusting color

1. Select Color Adjustment from the Tools menu.
2. Move the mouse pointer over a hue in the color hexagon in the Color Adjustment tool window.
3. Click the mouse button to select a hue.
4. Adjust the Saturation control in the tool window.

If Live Preview is turned on, the Preview Area shows the results of the changes you make to the image 
with the Color Adjustment tool. The tool must stay open for the changes to remain in effect. When the 
tool is closed, the hue and saturation are reset to the default settings.



Adjusting exposure

Adjusting Contrast and Brightness

1. Create a selection area in the Preview Area.
2. Click or drag the Brightness control to select a new brightness setting.
3. Click or drag the Contrast control to select a new contrast setting.

Using Automatic Exposure

1. Click Preview.
2. Select an appropriate image type in the Type pop-up menu.
3. Create a selection area in the Preview Area.
4. Click the Automatic Exposure button.

Adjusting Highlight and Shadow

1. Select Highlight and Shadow from the Tools menu.
2. Click on the Highlight button (in the upper right corner of the tool window).
3. Position the bubble cursor over the highlight point in the image and click the mouse.
4. Click the Shadow button (in the lower right corner of the tool window).
5. Position the bubble cursor over the shadow point in the image and click the mouse button.

Using the Emphasis tool to modify the midtones

1. Select Emphasis.
2. Adjust any of the three midpoints on the curve by dragging it to a new position.
3. Click Apply.

For more information about adjusting exposure, refer to your DeskScan II User's Guide .



Locking images to one size

1. Create a selection area with the desired height and width dimensions.
2. Click the lock button.
3. Drag the sides of the selection area until the desired portion of the image fits within the selection 
area.

Once the image size is locked to specific dimensions, the same image dimensions are used for all 
scans. The final dimensions of the image will not change but the image will be enlarged or reduced to fit 
the locked dimensions. 

The image size remains locked until the lock button is clicked again or until DeskScan II is closed. 

Scanning images to a single size is useful when scanning images for catalogs or any page formats that 
require graphics to be the same size.



Adding a custom image type

1. Select Image Type from the Custom menu.
2. Click Black and White or Color from the Color Content box.
3. Click Drawing, Halftone, or Photo from the Style box.
4. Make selections from the available menus in the Color Content and Style pop-up menus.
5. Type a name for the custom Image Type in the Name box and click Add.
6. Click OK.

When you select OK, the Custom Image Type dialog box is closed and the name of the new image type 
is added to the Type pop-up menu in the front panel. The new image type become the active image 
type.



Adding a print path

1. Select Print Path from the Custom menu.
2. Type resolution settings for Drawings and Halftones in both the Vertical and Horizontal boxes.
3. Type a resolution setting for Photos in both the Vertical and Horizontal boxes.
4. Select an option from the Calibration pop-up menu.
5. Type a name for the new print path in the Name box and click Add.
6. Select OK.

DeskScan II software includes several calibration settings in the Calibration pop-up menu. If your printer 
uses a ColorSmart driver, choose ColorSmart from the Calibration pop-up menu. If your printer is a 
PostScript printer, choose Default Gamma 1.8 from the Calibration pop-up menu. If you are only going to 
use the image on your screen, choose Screen from the Calibration pop-up menu. Otherwise, try the 
existing values to see which gives you the best results, or create a new print path calibration.

Once the new print path has been named, it appears in the Print Path list in the dialog box, and in the 
Path pop-up menu on the front panel, and becomes the selected path.

Related topic:
Calibrating a Print Path



Calibrating the computer screen

1. Select Screen Calibration from the Help menu.
2. Follow the instructions in the dialog box for calibrating your screen type.



Changing the units of measurement

1. Select Image Size from the Custom menu.
2. Select a new unit of measurement from the pop-up menu at the bottom of the Image Size dialog 
box.
3. Click OK.



Scanning images to the Clipboard

1. Click Preview.

Make adjustments
        -    Select an image type from the Type pop-up menu.
        -    Select a print path from the Path pop-up menu.
        -    Create a selection area in the Preview Area.
        -    Click Zoom (optional).
        -    Click the Automatic Exposure button.
        -    Adjust the size of the image with the Scaling control (optional).

2. Select Copy from the Edit menu.

The Copy command copies the selected portion of the image to the Clipboard. If you have not created a 
selection area, the entire scanner copyboard is scanned and copied to the Clipboard.



Changing the size of the Preview Area

1. Select Preview Size from the Custom menu.
2. Drag the right bottom corner of the rectangle in the Screen box to a new position.
3. When you have the Preview Area size you desire, release the mouse button.
4. Click OK.

Usually, you change the size of the Preview Area to see more detail in images that fill the Preview Area 
and which cannot be enlarged much by rescanning with Zoom. By enlarging the Preview Area, you can 
Zoom the image to a larger Preview Area to see more image detail.

Other times you may want to reduce the size of the Preview Area to minimize the amount of system 
memory being used by DeskScan II.

Whenever you change the size of the Preview Area, you must do a new Preview Scan.

Related topic:
How to use less memory



Sharpening an image

1. Select Image Type from the Custom menu.
2. Select a Sharpening option from the Sharpening pop-up menu in the Style box.
3. Type a name in the Name box and click Add (optional).
4. Click OK.

A new image type appears in the Type pop-up menu that includes Sharpening. Sharpening cannot be 
selected with the Spot Color drawing option.

The Heavy Sharpening selection works well for drawings. Photos, on the other hand, usually look best 
with the Normal Sharpening option.



Using less memory

1. From the Edit menu, select Preferences.
2. Click the Color Preview check box to turn off Color Preview if it is on.
3. Click the Live Preview check box to turn off Live Preview if it is on.
4. Click OK to save the new settings and close the Preferences dialog box.
5. Reduce the Preview Area size.

The Memory Space gauge in the bottom left of the Preview Size dialog box shows the amount of system 
memory and disk space used by DeskScan II.

You should turn off Live Preview only when available system memory is critically low.



Setting image quality

You can control how fast the scanning lamp warms up by setting the Image Quality option.

1. From the Edit menu, select Preferences.
2. Click Faster Lamp Warm-up if you want the scanning lamp to warm up faster so you can scan 
more quickly.
3. Click Better Illumination if you want better illumination on your image. The scanner takes longer to 
scan using this option.
4. Click OK.



Setting Automatic Find for Preview scans

Automatic Find automatically creates a selection area around the image during a Preview scan. It also 
enables the Automatic Exposure and Automatic Type check boxes so that you can enable these 
features. This feature is on when you first start DeskScan II.

1. From the Edit menu, select Preferences.
2. Click the Automatic Find check box to enable or disable Automatic Find on Preview scans.
3. Use the slidebar under the check box to set the sensitivity of the function.
4. Click OK.

Sensitivity

The slidebar under the check box lets you change the sensitivity threshold that DeskScan II uses during 
Automatic Find. Some images can have very fine lines or faint print and require more sensitivity for 
Automatic Find to work correctly. Other images may have a "dirty" background that you do not want 
DeskScan II to detect as part of the image and will require less sensitivity for Automatic Find to work 
correctly. Sliding the bar toward Smaller increases the sensitivity. Sliding the bar toward Larger 
decreases the sensitivity.



Setting Automatic Exposure for Preview scans

If Automatic Find is on, you can also have DeskScan II perform Automatic Exposure during a Preview 
scan.

1. From the Edit menu, select Preferences.
3. Make sure that Image Find is on (the check box should contain an "X").
2. Click the Image Exposure check box to enable or disable Image Exposure on Preview scans.
4. Click OK.



Setting Automatic Type for Preview scans

If Automatic Find is on, you can also have DeskScan II automatically select the image type during a 
Preview scan.

1. From the Edit menu, select Preferences.
2. Make sure that Image Find is on (the check box should contain an "X").
3. Click the Image Type check box to enable or disable Image Exposure on Preview scans.
4. Set the default image type if necessary.
5. Click OK.



Setting the default type for Preview scans

If Automatic Type is on, you can tell DeskScan II which types of images it should "tend" to find during a 
Preview scan, and which image types it should use for scanning when it finds a certain type of image.

1. From the Edit menu, select Preferences.
2. Make sure that Automatic Find is on (the check box should contain an "X").
3. Click Default Types... to open the Automatic Type Defaults dialog box.
4. Click Drawings or Photos, or No Preferences depending on which type of images you scan most 
often. This "biases" DeskScan II towards the selected type of drawing. It will select according to this 
bias if it cannot determine the image type conclusively.
5. For each image type that DeskScan II can detect, select the specific scanned image type using 
each of the pop-up menus in the dialog box.
6. Click OK.



Calibrating a print path

DeskScan II software includes pre-calibrated Print Paths for some popular printers and application 
packages. These are listed on the front panel in the Path pop-up menu. If your printer and target 
application are not on this list, you should create a new print path with the correct values, including the 
calibration.

If your printer has a ColorSmart driver, choose ColorSmart from the Calibration pop-up menu. If your 
printer is a postscript printer, choose Default Gamma 1.8 from the Calibration pop-up menu. Otherwise, 
you can try all of the values to see which works best, or create a new calibration for your printer.

Creating a new calibration for a printer or a printer and application involves three steps:

1. Print the calibration target.
2. Scan the calibration target.
3. Create a print path name for the new calibration standard.

DeskScan II software makes a target image file that you import into your application package and print. 
The printed target is then scanned to create a new calibration setting. The last step is to create the print 
path for your printer and application by selecting the new calibration, giving it a name and adding it to 
the list of print paths.



Printing a calibration target

You can make a print path which takes into account only your printer by printing a calibration target 
directly to your printer. You can also create a print path that accounts for your printer and a specific 
application by saving the calibration target to a file, bringing it into your application, and printing it from 
your application.

Sending a calibration target directly to your printer

1. From the Custom Menu, select Print Path .
2. In the Printer box, click New.
3. In the Calibrate a Print Path dialog box, click Create. You will see the Create a Calibration Target 
dialog box.
4. In the Printer box, select black and white or color.
5. In the Native Printer Resolution box, type in the resolution of your printer.
6. In the Send To box, click Printer.
7. Click OK.

Sending a calibration target to your printer through an application

1. From the Custom Menu, select Print Path .
2. In the Printer box, click New.
3. In the Calibrate a Print Path dialog box, click Create.
You will see the Create a Calibration Target dialog box.
4. In the Printer box, select black and white or color.
5. In the Native Printer Resolution box, type in the resolution of your printer.
6. In the Send To box, click File.
7. Click OK.
8. Select the proper file format for your application.
9. Name the file.
10. Click Save. If you are calibrating a color printer, you will be asked to save the color file. Give the 
color file a different name.
11. Click Quit.
12. Click Cancel.
13. Close DeskScan II, (optional).
14. Open your application you are planning to calibrate.
15. Create a new file in your application with a page size large enough to receive the target file 
(approximately 4" by 6").
16. Put the target file in portrait orientation on a page in the application without making any changes 
to the size of the target.
17. Print the page with the target from the application. If you are calibrating a color printer, repeat 
these steps to print the color target.



Scanning a calibration target

1. Reopen DeskScan II.
2. From the Custom Menu, select Print Path.
3. In the Printer Calibration box, click New.
4. From the Calibrate a Print Path dialog box, click Scan.
5. Put the target face down on the scanner copyboard with the top of the target next to the document 
set mark.
6. Close the copyboard cover.
7. Click OK.

The scanner now scans the printed target. If you are calibrating a color printer, you are prompted to 
scan the second target. When the target(s) is(are) scanned successfully, you will see the Save 
Calibration dialog box.

8. In the Save Calibration dialog box, type a name that uniquely describes the new Calibration option.
9. Click Save.
10. Click Quit.

Your printer and application are now calibrated and its name appears in the Calibration pop-up.



Removing a print path

1. Open the Custom menu and select Print Path.
2. Select a print path from the box in the upper right corner of the dialog box.
3. Click Remove.

Print paths with diamonds in front of them are standard print paths and cannot be removed.



Create a Calibration Target dialog box

1. Click Black and White or Color in the Create a Calibration Target dialog box. Color is unavailable if 
you are using an HP grayscale ScanJet scanner.
2. Type in the resolution of your printer in dots per inch in the Native Printer Resolution box.
3. Click File or Printer. Select File if the scan will be placed into a document and then printed. Select 
Printer if the path is directly to the printer rather than to an application.
4. Click OK.



Calibration Information dialog box

The printer resolution and the calibration status are shown in this dialog box.

The minimum and maximum screen dot range refers to a measure of the smallest and largest dot that 
can be printed reliably on an offset press. Those settings are intended for experienced users who are 
scanning images for offset printed documents.

For a typeset document, leave the minimum and maximum screen dot settings at the default settings.



Zooming in on a selected area

1. Click Preview.
2. Create a selection area.
3. Click Zoom.

Zoom Scan is only available when a selection area is made.



Printing a proof of an image before saving it

Put the image on the scanner copyboard.

1. Click Preview.

Make adjustments
        -    Select an image type from the Type pop-up menu.
        -    Select a print path for your printer from the Path pop-up menu.
        -    Make a selection area in the Preview Area (optional).
        -    Click the Automatic Exposure button.

2. Select Print from the File menu.

You can print an image at any point in the scanning process. Select an image type that matches the 
printer being used for the proof. 

Printing a proof copy on a desktop printer using the Millions of Colors image type takes much longer and 
is of lower quality than one using a halftone or a drawing image type.



Printing halftone samples

1. Click Preview.
2. Create a selection area.
3. From the File menu, choose Samples....



Annotating scanned documents
You can add notes or comments to images or text scanned into the Visioneer PaperPort desktop. To add 
a "sticky note," highlight an area, draw lines, add arrows, or circle scanned documents, do the following:

1. Scan item(s) onto the Visioneer PaperPort desktop.
2. Display item(s) in Page View by selecting the items and clicking on the Page View button, or by 
double-clicking on the item.
3. Select an annotation tool from the annotation tool bar.
4. Put the tool on the area to be annotated.
5. Add your annotation(s).



Faxing scanned documents
By customizing a print path and image type in DeskScan II, you can anticipate and correct for influences 
of the fax device. You can also optimize the image quality for your image type and size., fax output 
device, and the intended purpose of the fax communication.

1. Put the pages onto the scanner or ADF.
2. Start Visioneer PaperPort. The Visioneer PaperPort desktop appears.
3. Click the Scan button in Visioneer PaperPort. Visioneer PaperPort opens DeskScan II.
4. From the DeskScan II Custom menu, choose Print Path. The Customize Print Path dialog box 
appears.
5. Select one of the predefined FAX settings or change the settings to values appropriate to your fax 
device.
6. Click OK to close the dialog box.
7. Change the type on the DeskScan II window to Black and White Drawing for text-only documents 
or to Black and White Photo for documents with text and images.
8. Click Final. The image is scanned and appears on the Visioneer PaperPort desktop.
9. Use the fax link to send the fax. See the Visioneer PaperPort documentation for details on how to 
do this.



Sending scanned documents via e-mail
By customizing a print path and image type in DeskScan II, you can anticipate and correct for influences 
of the fax device. You can also optimize the image quality for your image type and size., fax output 
device, and the intended purpose of the fax communication.

1. Put the pages onto the scanner or ADF.
2. Start Visioneer PaperPort. The Visioneer PaperPort desktop appears.
3. Click the Scan button in Visioneer PaperPort. Visioneer PaperPort opens DeskScan II.
4. Set the type on the DeskScan II window to Black and White Drawing or Black and White Photo. 
These settings create smaller file sizes than the color settings. If you want to e-mail a color image, 
check you e-mail systems color capabilities.
5. Click Final. The image is scanned and appears on the Visioneer PaperPort desktop.
6. Use the e-mail link to send the e-mail. See the Visioneer PaperPort documentation for details on 
how to do this.



Converting scanned documents to text
If you have installed the OCR Package that came with your scanner, and have selected the OCR 
package in the PaperPort Preferences, you can use PaperPort to manage your scanned documents, 
and to link to the OCR software.

1. Put the pages onto the scanner or ADF.
2. Start Visioneer PaperPort. The Visioneer PaperPort desktop appears.
3. Click the Scan button in Visioneer PaperPort. Visioneer PaperPort opens DeskScan II.
4. From the DeskScan II Custom menu, choose Print Path. The Customize Print Path dialog box 
appears.
5. Adjust the DPI setting.    Use 300dpi to scan text larger than 8 points. Use higher resolutions to 
scan text smaller than 8 points.
6. Click OK to close the Custom Print Path dialog box.
7. Adjust the brightness and contrast so that you have a white background and black text.
8. Set the type on the DeskScan II window to Black and White Drawing. This matches the image you 
produce to the OCRs binary recognition capability, and creates a faster line-art scan that if you used 
other settings.
9. Click Final. The image is scanned and appears on the Visioneer PaperPort desktop.
10. Use the OCR or word processor link to convert the image to editable text. See the Visioneer 
PaperPort documentation for details on how to do this.

Hint

If you have pages with a colored background, pages with very small text, or pages on which you wish to 
preserve the formatting, you may get better results if you open DeskScan II directly from the OCR 
package. This lets the OCR package take advantage of HP AccuPage features. See the documentation 
for the OCR package for details.



Managing documents with Visioneer PaperPort
Visioneer PaperPort lets you manage scanned images and text by combining and arranging multiple 
scanned pages.

To create stacks of scanned items

- Scan the items onto the desktop with an ADF. When it scans multiple pages to the desktop, 
Visioneer PaperPort automatically puts all of the pages from one session in a single stack.

                                or
- Drag and drop one item onto another.

                                or
- Select the items(s) and click the Stack button on the command bar.

To unstack scanned items

1. Select the stack.
2. Click the Unstack button on the command bar.

To unstack a page

1. Select the page.
2. Click the Unstack 1 button on the command bar.



Technology used to optimize data from a scanner for page processing applications such as Optical 
Character Recognition (OCR), Document Management, and PC assisted fax. Text regions of the page 
are optimized for OCR and image regions are optimized for high quality image capture.



A menu item present in the menu bar of most applications that support TWAIN. Selecting Acquire takes 
the user directly to the scanning software selected using Select Source. If the software is DeskScan II it 
also automatically executes a Preview scan of the image.



(Automatic Document Feeder) An accessory that permits the automatic feeding and scanning of 
document pages. An ADF is usually used for scanning documents with optical character recognition 
(OCR) software.



(Advanced SCSI Interface Protocol) A de facto industry standard, originated by Adaptec Corporation, for 
communication between SCSI controllers and SCSI devices.



A button that automatically sets the exposure for the selected portion of an image in the Preview Area.



A feature of DeskScan II that automatically creates a selection area around the image and performs 
Automatic Exposure on the selected area.



(Common Access Method) An ANSI (American National Standards Institute) standard for communication 
between SCSI controllers and SCSI devices.



A temporary electronic storage area that allows for cutting and pasting of text and graphics.



A tool used to adjust the image hue.



A process for printing a color image in which four halftones are produced, one each for cyan, magenta, 
yellow, and black. The halftones can be produced with a camera and a film screen or with a computer 
and specialized software.



The flat glass surface on a scanner where you put documents to be scanned.



A process similar to halftoning that simulates the color tones in a scanned photo when it is printed on a 
desktop printer.



The file in which you store the content created by your application. This can be an electronic version of a 
traditional paper document if you are in a word processing or page layout application, a slide show if you 
are in a presentation application, or a drawing if you are in a graphics application.



The number of dots across one inch of the medium used to display images or text. Dots per inch 
measures the resolution of printers and displays.



An image containing large areas with a single color. For example, a black and white drawing contains 
only black and white areas that have no shades of gray.



(Encapsulated PostScript Format) A standard image file format used in the publishing industry to save 
an image to a file. Sometimes also referred to as EPS.



A particular way of saving information in a file. Many software applications can save and accept files in 
only a few file formats. A commonly used file format for scanned images is TIFF.



A tool that permits selection of irregularly shaped areas of an image for scanning.



The main window of DeskScan II that contains the primary controls, pop-up menus, and buttons.



Gamma correction adjusts the brightness of gray levels in the image so that the lightest and darkest 
portions of the image can be properly displayed on your monitor. For example, all 25% grays might be 
changed to 35% grays while 75% grays are adjusted to 65% grays.



The number of levels of gray used to digitally represent each pixel of the original image when scanning. 
Typical gray levels are bilevel (1-bit), 16 levels (4-bit), and 256 levels (8-bit).



An image type that simulates the tones in photographs by varying the size of the dots in the image when 
printed. Dark areas consist of large black dots while light areas consist of smaller black dots.



The whitest portion of the image. In the highlight area, a printer will print either the smallest possible dot 
or no dots.



(HP Fax Information Retrieval SysTem) An automated system for retrieval of information via audio tips or 
return fax. Please consult your installation manual to find out how to use HP FIRST.



The attribute of color that describes its dominant wave length and other distinguishing characteristics. 
Red, green, and blue are hues.



The height and width of an image when saved. Image size is also a menu command in DeskScan II. The 
scaling controls in the front panel can be used to change image size.



The kind of image to be scanned. An image is either a drawing or a photograph. However, a halftone 
image type is also available for scanning photos to be printed on desktop printers.



A feature that automatically updates the image in the Preview Area whenever settings are changed. It 
can be turned on and off in the Preferences dialog box which is accessed through the Edit menu.



A feature that keeps the image width and height locked to specific dimensions.



A proprietary graphics format used by Macpaint.



The tones in the middle of the range between the highlight and shadow points.



A kind of scaling that lets you change the height and width of an image.



(optical character recognition)    A technology that can recognize letters from a scanned image and 
convert them into ASCII characters to be saved as an editable text file.



(object linking and embedding)    An industry term for a process that lets applications capture and embed 
objects from other applications. in most cases, double-clicking on an object will open the application that 
created the object so that you can edit it.



A commonly used file format, originally developed by Z-Soft corporation, for saving images in PCs.



An image containing many shades of gray or color.



A unit of measurement used in traditional printing. A pica is 1/6 inch or 12 points.



The primary file format available on the Macintosh that supports text, vector drawings, and scanned 
images.



An abbreviated version of the phrase "picture element." Pixels are the small dots that make up a screen 
image. Pixels are used to measure screen resolution.



A unit of measurement in traditional printing. Twelve points equal a pica; 72 points equal one inch.



An effect produced by scanning a color photo with the Detailed Drawing option. The scanned image has 
fewer colors than the original image, creating an effect similar to that of an impressionistic painting.



The route or "path" a scanned file passes to be printed or displayed. A typical print path might include an 
image editing application, a desktop publishing application, and a laser printer.



A measure of the dots per inch in an image. As the resolution increases, so does the quality of the image 
and the file size.



The vividness or purity of a color, as measured by its freedom from mixture with white.



The process of stretching and shrinking an image. Also called "sizing."



(Small Computer System Interface) An industry-standard method of connecting peripheral devices to 
personal computers. Up to seven SCSI devices can be connected to a single SCSI controller in your 
computer. Some computers can be set up with multiple controllers.



A menu item present in the menu bar of most applications that support TWAIN. This menu item lets the 
user choose which scanning device will be the source for the application.



An area created in the Preview Area that defines the area to be scanned. A selection area is created by 
dragging the mouse pointer anywhere in the Preview Area.



The darkest area of an image is designated as the "shadow." The range between highlight and shadow 
determines the contrast of the image.



A style of scanning that emphasizes the small lines and subtleties in an image.



Images that have large areas of a single color. Examples of spot color images include logos and 
cartoons. Spot Color is also the name of a scanning style in the Custom Image Type dialog box.



(Tag Image File Format) A commonly used graphics format for storing and transporting files. 
Compressed TIFF is a compressed version of the same file format.



The overall effect produced by the combination of lighting, shade and color.



A graph where one axis represents gray level in the original image, the second axis represents adjusted 
gray levels, and a diagonal line shows how original levels are mapped to new levels. Moving points on 
this line changes how the original gray levels are mapped to the output file.



A replacement for the standard scanner cover that lets you scan transparencies rather than paper 
documents.



An industry term for a process that lets word processing, desktop publishing, and image editing 
applications access scanning devices directly.



A method of stretching or shrinking an image equally in both the vertical and horizontal directions.




