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INTRODUCTION

Corporate Vision: Making The Internet Easier To Build And Use

The Macromedia MX Vision

Macromedia is committed to empowering people to efficiently create and deliver the best
experiences on the Internet. Our products are standards for millions of developers and designers,
and hundreds of thousands of companies rely on our software to create the most compelling
content and applications on the Internet today.

During the last 6 years, the web has seen explosive growth. With about 4 billion static pages,
more than 100 million computers, and 400 million users, the impact of the web is now felt
everywhere. But despite the growth and success of the web, the full potential of the Internet is
untapped. The content lacks the richness and interactivity found in other media. Moreover, today
the web provides a user experience for applications that makes even simple activities like online
shopping difficult, and more complex interactions almost impossible.

The web of today is primarily used for browsing content. We believe the Internet of tomorrow will
about doing. It will provide a radically better user experience with richer content, more intuitive
and responsive applications, and accessibility through a wide variety of devices. With the
advances being made in client and server technologies, we see the next wave of growth on the
Internet bringing content, communications, and applications together into significantly more
usable and compelling user experiences.

For organizations investing in these technologies, the new content and applications promise a
higher return. By significantly improving the user experience of their Internet and intranet
solutions, organizations can increase the effectiveness of their investments. Whether the solution
is online commerce, customer self-service, elearning, content portals, business automation or
any number of other solutions, making the experience more responsive, instantaneous, intuitive,
and compelling will increase the success of the users, lower training costs, increase customer
loyalty, and make it straightforward to build solutions on the Internet that are, for all practical
purposes, impossible today.

The release of Macromedia Flash MX and the new Macromedia Flash Player are the first releases
in a new Macromedia MX product family designed to enable the next-generation of Internet
content and applications. The Macromedia MX products will bring together the most widely
distributed rich client technology on the Internet, with highly-productive development tools, and
powerful, open server technologies.
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THE SIGNIFICANCE OF A RICH CLIENT

Evolution of the “Thin-Client”
In the mid-1990s, explosive growth in the Internet and the World-Wide-Web drove widespread
adoption of a new model for content and applications using personal computers connected to the
Internet.  Coined ‘thin-client’ computing, this new model promised to lower the cost of developing and
delivering applications to end-user desktops and customers and business partners, and to increase
the range of application types that could be delivered.   This model centered around a very thin client
based on HTML, and powerful application servers that dynamically composed and delivered ‘pages’
to web browsers.

While this model has proven quite successful, it has also suffered from significant drawbacks and
limitations, especially around the richness of the application interfaces, media and content, and overall
sophistication of the applications that could be built and delivered.  Indeed, for many traditional
application developers, while the web has offered significant conveniences in terms of ease of
deployment, the capabilities of the programming model and user interaction model have forced users
to suffer.  In many respects, much of the technology of the late 1990s geared towards web application
development and deployment has adapted to the challenges imposed by the architecture inherent in
the web.

The Internet of the future will be different.  End-users and businesses are demanding more from their
investments in Internet technology, and the ability to deliver true value to users is forcing many
companies to look towards richer models for Internet applications, models that combine the power of
the traditional desktop with the deployment and content-rich nature of Internet applications.
Companies are also anticipating a growth in the use of web services, or reusable software components
that are used as services over the network, and towards a world where applications will need to share
functionality and data across many types of client devices.  These trends are driving the industry
towards next-generation rich clients.

Rich Clients Defined and Next Generation Internet Applications
A rich client, upon which next-generation Internet applications are based, must adhere to the
following:

Provide an efficient, high-performance runtime for executing code, content and
communications.
The end-user experience of HTML-based web applications can face from a variety of performance
related challenges, ranging from the request-response page rendering model; the need to dynamically
generate large text blocks for transmission of simple data; the lack of client-side data storage; the
inability to easily invoke and use remote business logic, and even the graphic model. Rich clients must
provide an optimized model for data exchange between the client and server.

Integrate content, communications and application interfaces into a common
environment.
The end-user experience of the Internet today is fragmented into the HTML browser for textual
content and basic application interfaces; multiple messaging clients for performing communications
functions; multiple media players for handling audio, video and other forms of media.  Rich clients
need to provide deep integration for all of these types of interaction in a single environment.

Provide powerful and extensible object models for interactivity.
While web browsers have progressed significantly in terms of their support for interactivity through the
Document Object Model (DOM) and JavaScript or DHTML, they still lack the richness needed for
building serious applications.  Rich clients need to provide a powerful, object-oriented model for
applications and events, integrating user interface, communications and system level services into a
common object model.

Enable the use of web services and data services provided by application servers.  The
promise of rich clients is also the ability to cleanly separate presentation logic and user interfaces from
application logic hosted in the network.  Rich clients should provide a model for easily using remote
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services provided by back-end components, whether hosted in an application server or accessed as
XML Web Services.

Embrace Connected and Disconnected Clients.
While many users have gotten used to having to be online and in a web browser to perform work, the
reality is that most applications would benefit from being able to be used offline on occasionally
connected devices such as PDAs and laptops.  Likewise, many applications require being connected
all the time, and need support for persistent connections with two-way, notification-based
communications.  Rich clients should enable both of these application types to be easily built and
deployed.

Enable Easy Deployment on Multiple Platforms and Devices.
Internet applications are all about reach.  The promise of the Internet is of content and applications
anywhere, no matter the PC platform or device.  Rich clients must embrace and support all popular
desktop operating systems, as well as the broadest range of emerging device platforms such as smart
phones, PDAs, set-top boxes, game consoles, and new Internet appliances.
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THE MACROMEDIA FLASH MX SOLUTION
With Macromedia Flash MX, we are offering the most powerful solution for developing rich Internet
content and applications.

Broad Adoption and Industry Support of Macromedia Flash Technology
Since its introduction in 1996, Macromedia Flash has become the standard for rich Internet content.
Global brands such as General Motors, Disney, CNN, IBM, Yahoo, Boeing, Merrill Lynch and Coca-
Cola along with seven of the top ten most trafficked websites deploy Flash content as it provides the
richest and most consistent viewing experience across all major platforms, browsers, and devices.

Macromedia Flash Player is the enabling technology for these rich experiences and is widely available
through successful distribution partnerships with Microsoft®, Apple®, Liberate®, Netscape®, and AOL®.
According to the latest independent NPD Online study (December 2001), over 414 millions users
(97% of the online audience) can immediately view Macromedia Flash content, making the Flash
Player the most widely distributed rich client technology on the Internet. Macromedia Flash Player is
the broadest client available for desktop and device platforms including Windows 98, 2000 and XP®,
Macintosh® OS 9.x and OS X, Solaris™, Linux® desktop operating systems and additional device
platforms including MicrosoftTV®, Symbian EPOC, PocketPC, Sony PlayStation® 2, Liberate, QNX,
VXWrks, OpenTV and more.

To further the widespread adoption of Flash technology, Macromedia provides the Flash file format
(SWF) SDK to the Internet community for free. The Flash File Format SDK has been available since
April of 1998 and has been downloaded by over 12000 individuals, institutions and corporations
worldwide. The widely accessible file format enables content, tool and device developers to utilize
Flash content within their products. Licensees of the Macromedia Flash file format include companies
such as Quark®, Corel®, Apple® and AutoDesk®.

Macromedia and its partners are committed to furthering the adoption of the Macromedia Flash
technology standard through broad distribution of Flash Player and broad implementation of the Flash
file format specification.

Proven Return on Investment Using Macromedia Flash
Tens of thousands of organizations have deployed Flash content as it provides the best user
experience while providing a better return on investment. Three successful examples are:

Salomon Sports

Salomon is a leading manufacturer of high-performance skis, snowboards, and outdoor equipment.

Their challenge was to build a Salomon Dealer extranet that replaces a print-based product catalogue.
By using Macromedia Flash, they achieved the following ROI:

• Reduced bandwidth requirements by approximately 95% by replacing an HTML menu
system with Macromedia Flash menu system.

• 20% decrease in pageload time

• 83% reduction in HTTP requests
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Emerils.com

Chef Emeril Lagasse is one of the most celebrated chefs in the world today. Emerils.com offers a
glimpse into his world: the restaurants, recipes, TV shows, books and kitchenware that add up to
cooking with a bam!

Their challenge was to improve site usability, performance, and aesthetics, as well as develop an
intuitive and easy-to-update navigation scheme. Using Macromedia Flash, the following ROI was
achieved:

• · Better user experience—greatly enhanced site navigation and aesthetics

• · Easier to access information—achieved zero-to-one click-through rate

• · Redesigned site in 36 days (as opposed to initial six-month estimate)

• · 60% decrease in time required to maintain the site

• · 85% reduction in site maintenance costs

• · Reduced total page load time (56K connection) by three to five seconds

• · Annual revenue projected to increase by 21%

USABancshares

USABancshares.com is a next-generation, FDIC approved online bank that is developed entirely
using Macromedia Flash.

Their challenge was to provide a familiar application experience to the broadest possible audience on
both desktop and device platforms. Using Macromedia Flash, the following ROI was achieved:

• 5x faster than HTML UI equivalent

• 40% less server load

• Ability to deploy content across all desktops and devices without complex redesign process

Powerful Development Environment
Over the past few years, Macromedia Flash has migrated beyond being “just an animation tool,” and
has become a “must have” tool used by over 1 million professionals to develop distinctive and
compelling content, revolutionary user interfaces and rich applications for the web. The release of
Macromedia Flash MX provides both designers and developers an approachable and powerful
environment needed to build and deliver cutting edge Internet content and applications.

Macromedia Flash MX provides a broad range of multimedia design and rich Internet application
development in one product.  With Macromedia Flash MX, designers have the ability to create
graphics, sophisticated user interfaces and synchronized animation with audio and new video
playback to provide supreme, branded experiences.  Designers can also begin to take advantage of
Internet application development trends by using templates, approachable scripting tools and
interface components to begin rudimentary application design. Developers can leverage the
multimedia capabilities along with sophisticated tools including a powerful ActionScript editor, support
for multiple developers on a project, a robust debugger and predefined Flash components to build rich
Internet applications.

Making Rich Internet Applications Accessible
Macromedia is committed to making Macromedia Flash content accessible to everyone who uses the
Internet and to enabling our customers to comply with Section 508 by delivering accessible solutions
for the Macromedia Flash authoring tool. We have partnered with standards bodies and organizations
focused on accessibility issues to deliver improved accessibility options for the Macromedia Flash
solution. We are committed to working with international disability organizations to test accessible
Flash solutions and establish working guidelines for rich media.

Flash MX has integrated the process of creating accessible content into the content creation
workflow. To add descriptive text to your animations and user interface elements simply select the
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item you wish to tag, enter the appropriate text description, and when users with assistive technologies
(ex: screen readers, Braille output, etc.) encounter your content they will be able to navigate and take
part in your content in the same manner as an HTML document authored with accessibility in mind.

Integrated and Open Client-Server Application Development Model
As more customers, such as Cisco, Broadmoor Hotel and Solomon, have adopted Flash as a
technology for rich Internet applications, the need for a clear, flexible client-server development
workflow has emerged.  Today, Macromedia Flash Player supports a number of methods for
integrating server generated data with Flash movies including support for XML-based and URL-
encoded data delivered through standard HTTP POST and GET requests. While these mechanisms
are widely used, they offer a limited development model and do not provide optimal runtime
performance.

Shortly after the release of Flash MX, developers will have a new structured development model and
set of server-side technologies for building Flash applications.  In mid-2002, Macromedia will deliver
a set of solutions to make client-server development with Flash MX faster, more flexible and extremely
powerful.  These solutions will enable a new class of rich application development on the Internet.
Macromedia Flash Server Solutions will consist of an application server gateway and a breakthrough
communications server. The application server gateway offers a framework designed to make it easier
to exchange data between Flash Player and today’s leading web application servers.  The new
communications server will make it possible for developers to create real-time messaging, audio and
video applications with Flash MX.  With the tools for application server integration and new
communications capabilities, Flash MX will allow developers to deliver applications that go well
beyond traditional Internet applications.  Flash MX developers leveraging these new solutions will be
able to create next-generation applications such as a calendar application that automatically synchs
data when users are connected, a shared whiteboard application that allows a group of users to
contribute ideas from across the world, an employee directory that allows you to see an interactive
map of employee locations, and an eLearning application which allows instructors to train across
multiple participants simultaneously.

These server-side solutions will be closely integrated with Macromedia ColdFusion MX and will also
be available for .NET and J2EE solutions. Macromedia is committed to maintaining an open rich
application development model with Flash MX and will ensure compatibility with a broad application
server base.

Promoting User-Centric Design
Macromedia is working closely with the design and development community and usability experts to
provide the necessary guidelines to develop user-centric content and applications. Our goal is to
empower the community to maximize what a usable Internet can be and continue to build cutting-edge
content and applications that provide the best user experience.

With Flash MX, we are providing a series of resources, templates, user interface components and
other materials to ensure these goals are achieved. In addition, we continue to maintain a Usability
website to further promote these goals at:

http://www.macromedia.com/software/flash/productinfo/usability/



Macromedia® Flash™ MX Reviewer’s Guide

10

ANNOUNCING MACROMEDIA FLASH MX
With the increasing development of next generation Internet applications, we proudly announce:
Macromedia Flash MX, offering a new solution for easy development and reliable deployment of rich
web content and applications across multiple platforms and devices.

Product Offerings
Macromedia Flash Player
The Standard Rich Client for Internet Content and Applications

The Macromedia Flash Player ensures all Flash (SWF) content is viewable and accessible
consistently and across the broadest range of platforms, browsers and devices. Flash Player
continues to be distributed with every major partner, including Microsoft® and AOL, to bring rich
content and applications immediately to over 414 million people worldwide.

Macromedia Flash MX
The Solution For Developing Rich Internet Content and Applications

Macromedia Flash MX is an essential tool for designers and developers who want to rapidly develop a
broad range of content and applications that provide a rich, interactive experience which are viewable
consistently across all bandwidth connections and platforms.

Coming in mid 2002
Macromedia ColdFusion MX
The Proven Standard for Rapid Internet Application Development

ColdFusion MX will make it easy to develop powerful Internet applications that leverage Macromedia
Flash. Combining an extraordinarily approachable and productive development model, effortless
connectivity to enterprise systems, and a powerful suite of built-in application services, the flexible
ColdFusion MX environment provides portability across operating systems, integrates with Java and
.NET standards, and offers built-in support for SOAP-based web services

Application Server Gateway

The application server gateway for Macromedia Flash MX and included framework will deliver a set of
developer tools for easily building rich Flash applications on Macromedia Server products in addition
to other popular web application servers including .NET and J2EE compatible servers.  The solution
will provide a clear workflow and infrastructure for easily exchanging data between Flash Player and
today’s leading web application servers.

Communication Server

Our communication server will make it possible for Flash developers to easily add realtime
communication features to their applications.  Developers will be able to create simple client-server
applications for communication features like audio and video messaging, video greeting cards,
discussion groups, chat applications, and more.

Macromedia Dreamweaver MX

The Next Generation in Development Tools for Web Professionals

Dreamweaver MX products will feature enhanced integration with leading software including
Macromedia Flash and Fireworks as well as enable access to the latest web standards and
technologies, including XML, web services, ASP.NET, XHTML, JSP, PHP, and Macromedia
ColdFusion MX. Enhancing the best-loved features of Macromedia Dreamweaver, HomeSite,
UltraDev and ColdFusion Studio, the new Dreamweaver Platform will revolutionize web development
for coders, designers and application developers.
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SHOWCASE CUSTOMERS USING MACROMEDIA FLASH
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MACROMEDIA FLASH CUSTOMER PROFILE

Today Macromedia Flash customers are creating a broad spectrum of rich content and applications.
Over 50% of Flash developers are creating rich, interactive content including web applications
integrating with back-end application servers, user interfaces, eLearning content, presentations, and
Flash websites.  The remaining 40% are creating animation including motion graphics, character
animation and text effects.

Macromedia Flash Content Make-up

Other
12%

Web Page & 
User Interface

33%

Web 
Applications

16%

Motion Graphics/
Character 
Animation

39%

The 50% of rich Internet applications developed with Flash can be segmented into the following
categories:

• Web applications (The Broadmoor Hotel, Franklin Planner, Salomon)

• User Interfaces (General Motors, Audi, Emerils, Pirelli Tires, National Geographic)

• Merchandising (Coca Cola, Tiffany & Co., Fox Sports)

• eLearning (Cisco, CNN, 1800Contacts)

• Product tours (Microsoft, PeopleSoft, Symantec)

For more example sites or for links on the sites listed above, please visit
http://www.macromedia.com/software/flash/special/inspiration/

The following are profiles of a typical Macromedia Flash user:

Professional Web Designer

The web designer’s primary emphasis is on web page layout and website design. The majority of these
individuals work in small web teams or as a part of a larger advertising or branding agency and use an
array of software packages for creating websites. Their sole focus is to make beautiful, engaging web
designs for their demanding client base. Macromedia Flash MX provides a single environment for
creating the necessary graphics, animation, interactivity and integration with Dreamweaver for
efficient site deployment.
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Web Application Developer

Application developers are the individuals who build the logic and back-ends to every Internet
application. Their primary emphasis is on developing the necessary application server logic and
database interaction that is required to implement productive web applications.   Developers turn to
Macromedia Flash MX to create rich front-ends to their Internet applications and to utilize rich client
capabilities including complex data relationship processing, simplification of UI, streaming data,
multimedia and sophisticated client-side logic outside of browser scripting to avoid discrepancies
between browser functionality.
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MACROMEDIA FLASH MX FEATURE OVERVIEW
The most powerful solution for developing rich Internet content and applications

Experience
Flash MX enables the best Internet experiences that result in better ROI

• The leading rich client - Over 414 million Internet users can see Flash content immediately,
offering a ubiquitous rich client while reducing server load and content download time

• Video, vector graphics, animation, audio and interactivity - Complete multimedia support
including vectors, bitmaps, animation, audio, video and 2-way messaging enable new breeds
of rich content and applications

• Accessible content and applications - Assistive technologies can interpret Flash content and
applications enabling full accessibility support to everyone, including those with disabilities

• Content and data stream - Content and data streams (plays back as downloaded) providing an
immediate experience regardless of the connection speed

• No page refresh - Information exchanged between Flash Player and the application server
does not require a page refresh providing a smooth application experience

• Multiple device platforms - Flash Player is supported across multiple device platforms
(wireless handsets, iTV, game consoles) allowing content and applications to be viewed
everywhere

Powerful
Flash MX is a powerful solution for creating a broad range of high-impact content and rich Internet
applications that go beyond the boundaries of the browser

• Scalable development environment - Professional set of multimedia design and web
application development tools in one product

• Interactive video - The easiest way to build interactive video that can be deployed widely

• Internet standards support – Flash content and applications leverage many Internet standards
including ECMAScript (ActionScript), HTML, MP3, H.263 and XML

• eLearning building blocks - Access to broad range of resources including templates, code
samples, and pre-defined components to develop rich, eLearning applications

• Extensible template and component libraries - Custom templates and application interface
components can be developed, extended and reused providing significant productivity gains
across multiple projects
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Applications
Flash MX is a powerful solution to rapidly develop rich Internet applications

• Sophisticated development tools - Sophisticated ActionScript programming tools, code
reference and powerful debugger provide a complete Internet application development
environment

• Application Components - Robust set of UI components enable developers to create
advanced Internet applications quickly. Components also allow designers to leverage existing
skills to develop Internet application interfaces

• Robust XML support - Enhanced XML support provides a 20x gain in performance when
integrating data from any application server for data-rich web applications

• Close integration with ColdFusion - Close integration with ColdFusion MX provides a clear,
flexible client-server development workflow enabling rapid deployment of rich applications

• Framework for ColdFusion, J2EE, .NET integration - Integration with ColdFusion, J2EE, and
.NET servers through a new, optimized data exchange protocol and application server
gateway.

• Communication applications server - A new Flash audio and video server with Realtime
Messaging Protocol (RTMP) ushers in a new generation of communication applications for the
Internet
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Top 10 Reasons to Buy Macromedia Flash MX
1. Macromedia Flash is the industry-standard chosen by over one million web professionals for

creating high-impact web content and application interfaces.

2. The Macromedia Flash Player is pre-installed on all major operating systems and browsers,
ensuring that content and applications are viewed consistently and reliably across all browsers,
platforms and devices. The open Macromedia Flash File Format (SWF) is an optimized, tag-
based, binary file format that is compact and efficient.

3. A professional solution with a familiar and flexible development environment, built in lessons and
tutorials, Quick Start templates, Macromedia University and a vast community of 3rd party sites,
books and other resources devoted to Macromedia Flash.

4. Tools to rapidly develop data-driven Internet applications.  A new robust ActionScript
development environment, new ActionScript objects and predefined Flash components.  The
component architecture is open and based upon a common architecture allowing for the flexibility
of building new components.

5. Rich media support including video (through the adoption of Sorenson Spark technology), audio,
vector graphics, bitmap graphics to create multi-sensory content.

6. Integration with any application server, and transport protocols (HTTP/HTTPS/Wireless) using
URL-encoded or XML data.  Integrate Flash content and business logic through XML data
transfer to develop e-commerce, data visualization, and communication applications.

7. Accessibility support makes it easy to develop Flash content and applications that are useable and
accessible by everyone, including those with disabilities.

8. Close integration with Macromedia products such as Macromedia Dreamweaver®, Macromedia
Fireworks, Macromedia FreeHand®, Macromedia Sitespring® and Macromedia ColdFusion.

9. Macromedia Flash Player offers a consistent and familiar experience for end users across all
browsers and platforms through client-side interactivity, no required page refresh on data
exchange, and allows streaming delivery of content and application logic.

10. Multi-lingual support (11 languages) allows for Flash content to be viewed globally.  Flash MX
supports Vertical Text and Unicode Standards.  New languages supported include: Korean, and
Traditional and Simplified Chinese.
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Top 10 Reasons to Upgrade to Macromedia Flash MX
1. Learn Macromedia Flash quickly with an improved familiar and flexible development environment,

built in lessons and tutorials, Quick Start templates, Macromedia University and a vast community
of 3rd party sites, books and other resources devoted to Macromedia Flash.

2. Rapidly develop data-driven Internet applications with a new robust ActionScript development
environment, new ActionScript objects and predefined Flash components.  The component
architecture is open and based upon a common architecture allowing for the flexibility of building
new components.

3. Rich media support including video (through the adoption of Sorenson Spark technology), audio,
vector graphics, bitmap graphics to create multi-sensory content.

4. Timeline and Animation Enhancements: improved cursor feedback, resizing, cutting and pasting
multiple frames and more now make it easier to use the Timeline. New Folder layers make it easy
to organize and access layered content in the timeline.

5. Enhanced graphic design tools including Free Transform, Pixel level control, Color Management.
Easily align your bitmaps, lines and fills with precision to pixel boundaries on the stage.  Color
Mixer Enhancements in Flash MX make it easier to mix colors and create color swatches

6. Integration with any application server, and transport protocols (HTTP/HTTPS/Wireless) using
URL-encoded or XML data.  Integrate Flash content and business logic through XML data
transfer to develop e-commerce, data visualization, and communication applications.

7. Accessibility support makes it easy to develop Flash content that is useable and accessible to
everyone, including those with disabilities.

8. Named Anchors let you develop your Flash content and applications so that they can be book
marked.  This will allow users viewing your Flash content to use familiar browser functions such as
the Back/Forward buttons to navigate to specific areas of Flash content defined by the content
author.

9. Multi-lingual support (11 languages) allows for Flash content to be viewed globally.  Flash MX
supports Vertical Text and Unicode Standards.  New languages supported include: Korean, and
Traditional and Simplified Chinese.

10. Dynamic loading of images and sound– Download MP3 and JPEG files at runtime. Save on file
size and production time by not having to package images and sounds into Flash content for
playback.



Macromedia® Flash™ MX Reviewer’s Guide

18

TOP 10 FLASH MX AUTHORING FEATURES IN DEPTH

1. Flexible and Familiar Environment
Learn Macromedia Flash quickly with a familiar and flexible workspace environment,
built in lessons and tutorials, quick start templates, and more.

With over a million users, Macromedia Flash is used by many different users to create a broad range of
content and applications. The Flash MX environment has an intuitive, easy to learn interface that at the
same time is highly configurable. This allows Flash to be just as approachable to a designer or
animator as it is to an application developer.

Flash MX introduces a newly streamlined user interface built upon Macromedia standards also found
in Macromedia Dreamweaver and Macromedia Fireworks, and represents the first iteration of the
Macromedia MX standard.

Key enhancements of the familiar workspace environment include:

• Panel Management – Collapsible, dockable panels can be grouped together and collapsed
or expanded as needed, providing a smooth, highly configurable workflow (see below)

 Flash MX Authoring Environment
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• Property Inspector – As found in Macromedia Dreamweaver, the property inspector shows
only relevant, context-sensitive settings for tools and objects, dramatically reducing the
number of panels required to be open at any point in time

 

Context-sensitive property inspector

• Integrated Library Window – the Library window can now be grouped or docked with any
other panels, allowing for easy integration into the workspace environment

Library docked with other panels

• Timeline Organization – Animation timeline can be minimized or expanded with a single
click, maximizing the workspace area

• Keyboard Shortcuts – Default shortcut keys are consistent across Macromedia
applications, or can be easily customized
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• Toolbox Layout – Tool layout and groupings are consistent, making tool selection across
applications seamless

• Menu Structure – Menu items and containing sub-menus maintain common structures

• Color Selection – Color selection models and interfaces are similar, ensuring easy color
application to designs

In addition to a familiar workspace, numerous included learning materials and third party resources
make it easy to learn Macromedia Flash. These include:

• Quick Start Templates – New pre-built templates make it simple to create professional-
looking presentations, photo albums, advertisements, and learning content. Designers and
developers can create their own templates easily.

QuickStart Templates make it easier for new users to build Flash content quickly

• Built-in Lessons – Flash MX features interactive lessons that help new users get up to
speed quickly.

• Macromedia University – Macromedia authorized online courses, as well as certification,
are available for additional in-depth training on several levels.

• Third Party Resources – Dozens of third party community sites, over one hundred
dedicated Flash books, and several annual conferences worldwide add to the Macromedia
supplied resources available to users.
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2.  Enhanced Timeline, animation and graphic design tools

The timeline in Flash is where all of the animation and object layering takes place, an essential
interface at the core of authoring content. In Flash MX, numerous improvements have been made to
increase the productivity of Flash users. Clear, consistent cursor feedback for moving, adjusting and
resizing frames, enhanced predictability of copy and paste operations, and organized menu items and
shortcuts improve upon the reliability of the timeline.

Layer folders are a new type of layer in the Flash MX timeline, allowing nested layers to be collapsed
or expanded much like folders in Windows Explorer or the Macintosh Finder.  Users are able to
organize layers in a structure that works best for them, and collapsibility makes it easier to manage
large numbers of layers.

Organize your Timeline with Layer folders

New Free Transform tool, Pixel level control, and Color Management Enhancements
Flash MX provides designers with greatly enhanced creative freedom and control over their content.
The new Free Transform tool combines scale, rotation, skew, and distortion into one, easy to use tool.
This powerful combination provides creative flexibility and improved productivity when modifying
shapes, symbols, and graphic elements. A movable transformation point means effects can be applied
in many different ways.  Separate modifiers allow the tool to be locked into separate modes for Rotate
and Skew, Scale, Distort, and Enveloping. Enveloping adds a degree of flexibility in warping and
distorting shapes.  With the Shape Distort modifier, shapes can be tapered or freely distorted.

The new Free Transform tool combines scale, rotation, skew, and distortion into one,
easy to use tool.
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New Pixel Snapping provides designers the precision of object placement down to exact pixels.
Designers can specify that objects should be locked to exact pixels upon creation or when they are
moved, helping guarantee the layout of their designs will be rendered exactly how they wish. A pixel
grid is displayed when the stage is zoomed beyond 400%, providing the user with a visual means of
validating that geometry is aligned.

Easily align your bitmaps, lines and fills with precision to pixel boundaries on the stage

The color mixer in Flash MX has been improved to add greater control over color selection and
manipulation. The mixer now includes an expanded mode with a new Hue/Saturation picker,
Brightness slider, before/after color indicator, and integrated HEX value display.  Integrated color
gradient editing means gradients can be mixed and applied without using secondary panels.  The
Swatches panel now allows users to easily add and delete swatches, as well as provide more intuitive
cursor feedback for color selection.

Flash MX makes it easier to mix colors and create swatches
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3. Rich media support
Flash MX adds new video support (through the adoption of Sorenson Spark technology) to existing
support for audio, vector graphics, and bitmap graphics to create multi-sensory content.

Flash MX features new support for the import and streaming playback of video, ideal for short clips for
use within Flash sites and applications. Flash can import any standard video file supported by
QuickTime or Windows Media Player, including MPEG, DV (Digital Video), MOV (QuickTime), and
AVI.

Sorenson Spark is a motion video codec included in Flash MX that enables you to add
video content to your Flash. Now designers and developers can import full-motion

video into their Flash content and applications.

Upon import, users are presented with a dialog with compression settings, and the video is embedded
directly into the Flash MX document file (.fla). The audio compression can also be set with any of the
standard compression settings supported by Flash, such as MP3 or a new codec optimized for
speech. Importing video now provides designers with creative and innovative ways to integrate video
playback within sites and applications.
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Video objects inside of Flash can be manipulated much like bitmaps, for example scaled, rotated, or
skewed, masked and animated with motion tweens. Multiple instances of video objects are also
permitted, and video can be contained inside movie clip objects enabling them to be scriptable,
interactive objects as well.  This allows for creative, innovative ways to integrate video playback within
sites and applications.

Utilizing video clips within Macromedia Flash MX allows for creative, innovative ways
to integrate video playback within sites and applications.

Video is streamed through normal HTTP protocol and larger video files can be
streamed as a separate Flash movie to keep the download size of the primary site to a

minimum.
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4. Dynamic Loading of images and sound at runtime
Download MP3 and JPEG files at runtime. Save on file size and production time by not having to
package images and sounds into Flash content or applications for playback.

When building complex applications using Macromedia Flash many developers wish to leverage
existing media assets without first having to turn them into Flash movies.  Using Flash Player 6,
content creators can now dynamically load JPEG and MP3 media files during runtime without any
changes to their existing content. This enables Flash to serve as a fully controllable web interface for
the vast majority of existing bitmap and audio sources, alleviating the necessity of building custom
media for the explicit purpose of viewing in the Flash Player.

Developers with existing media can quickly move into the development of Flash applications using
their existing investments in media and tools for the creation of JPEG and MP3 data.

Easy to author support for loading JPEG & MP3 media
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5. Robust Development Environment
Rapidly develop data-driven Internet applications with a robust ActionScript development
environment.

Flash MX builds upon its existing ActionScript editing environment, adding support for such features
as:

• Colored Syntax Highlighting – A fully customizable text engine is now at the heart of
the ActionScript editing environment. This allows the customization of font, font size,
color, and the syntax highlighting itself through a fully editable XML data file.

• Code Hinting – As code is typed in the editor, the editor will provide code hints for
parameters, properties, and events, eliminating the need to hunt through pages of
reference to find the code you need.

Code hinting provides guidance for novices and experts alike
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• Full Debugger – Greatly improved ActionScript debugger with support for breakpoints
and code stepping (Step In, Step Out, Step Over).

A full ActionScript debugger with breakpoints, and code hinting
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In addition to the improvements made for expert users, the interface for novice users has been greatly
refined and improved to assist in quickly learning the power of ActionScript.

• Jump Bar – Quickly navigate through objects in your Flash movie that have had scripts
associated with them, as well as giving context to the current script being edited.

• Cues – A dedicated area of the Actions Panel which is reserved for displaying
information that guides users on using the actions they have applied to their movie.

• Reference Panel – Those who want in-depth information about particular ActionScript
functionality can now receive reference information immediately within the application.

Improved Actions Panel for novice and intermediate users. The reference panel for
quick access to documentation and ActionScript code samples.
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• Named Anchors
Enables Flash content and applications to be book marked.  This will allow users
viewing Flash content to use familiar Browser functions such as the Back/Forward
buttons to navigate to specific areas of Flash content defined by the content author.

 

Integrated support for named anchors
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6. Component-based authoring
Modern application development demands that common patterns and behaviors be easily
encapsulated into components that can be shared and re-used by other developers.  Until now,
building true visual components for Internet applications has been nearly impossible.  With Flash MX,
we’ve introduced a new Flash Component model that enables incredibly powerful capabilities to be
shared and used by developers of any skill set.

Integrated environment for building Internet application user interfaces using Flash
Component based authoring

• Included Pre-build Components for Common User Interfaces.  Flash MX includes a core set of
pre-built components for the most common application interfaces, including scrollbars, rich
text fields, input buttons, radio and check boxes, and list and combo boxes.  These component
frameworks will help accelerate development, and also ensure a common experience for users
across Flash MX applications.  However, the pre-built components can also be customized
through interface skins.

• Create reusable visual components with properties, methods and events.  Flash Components
can define customizable properties, methods and events.  Properties can be set at design-
time by users of the component, and these could be visual properties such as style or behavior
oriented properties.  Flash Component methods provide well-defined APIs for developers to
easily integrate and manipulate the component in a custom way within their own applications.

• Package components for drag-n-drop use in visual development.  Flash Components can be
easily redistributed through the Macromedia Exchange for Flash and can be installed and
visible in the Flash MX Components Panel.  Developers can then drag-n-drop components
into their interfaces, and even drag components onto other existing interface elements to
apply behaviors dynamically.

• Customizable Design-Time Interfaces.  Component developers can easily build custom
design-time interfaces for their components.  Components can include custom Property
Inspectors that provide a richer configuration interface for the components settings and
behaviors.  Components can also include a LivePreview SWF file that provides an inline
rendering of how the component will look in the application.
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7. Integration with Web Application Servers
Integrate rich Flash interfaces with any business logic through XML data transfer to develop
eCommerce, data visualization, and communication applications. New Flash application server
gateway and communication server will enable a faster, breakthrough way to develop next-generation
Internet applications

Today, Macromedia Flash MX allows developers to utilize XML structured data within their Flash-
based applications for a broad range of application purposes. Using XML for rich data and Flash for
logical and intuitive user interfaces, companies can create sales forms, virtual shopping carts,
customer surveys and stock availability matrixes. Continuous XML connectivity allows immediate
updates of any mission-critical information to be displayed.

Macromedia Flash Player 6 has greatly improved the performance of native functionality such as
XML, in many cases over 20x faster. In conjunction with enhanced performance, using enhanced
language support in Flash MX, content creators can now build a single user interface with XML data
that stores multiple text encoding for each of the languages they choose to support. This allows for
playback in 11 international languages with a single front end.

Robust support for XML data transfer, with integrated Unicode support.

Rich clients are made much more valuable when combined with logic and data delivered from
application servers and XML Web Services.  The new services-centric application model being
ushered in by web services is the perfect compliment to rich client environments like Flash Player.
Macromedia Flash MX enables a faster and more powerful way to deliver rich Internet applications
through the following:

Rapidly develop rich Internet applications through an optimized server framework
The fastest and most efficient way Flash MX communicates with application servers and Web
Services will be the Flash application server gateway, a new server component included with
ColdFusion MX and available for other J2EE and .NET servers.

Easily integrate logic and data on remote servers using AMF
Flash’s Action Message Format (AMF) provides a high-performance, optimized binary
protocol that runs over HTTP and enables ActionScript to invoke and use data and logic
hosted on an application server, or an XML Web Service out on the Internet.  AMF provides an
object-based remote procedure call (RPC) mechanism, and supports passing both simple and
complex data types between Flash ActionScript and any server-side programming language.
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Coherent model for connecting rich clients to web services
The services-based application model provided by XML Web Services promises to marshal in
a new wave of loosely coupled applications, where component re-use and application
integration flourish.  Rich clients such as Flash Player provide a complementary model to Web
Services by combining user interfaces with behavior and data hosted by services in the
network.  With Flash MX and ColdFusion MX, developers can easily connect their rich Internet
applications with SOAP-accessible web services hosted on their own or other servers on the
Internet.

Integration between visual components and server components
Flash MX introduces a new component model for encapsulating behavior and data associated
with visual interfaces.  This component model is complemented by ColdFusion Components, a
new server-side component model for encapsulating scripts and data used in ColdFusion MX.
Flash Components can be combined with ColdFusion Components to form rich, client-server
interactions.

Real-time messaging between client and server
Flash MX introduces a new set of services for publishing and accessing shared data between
multiple client computers in real-time, using the Real Time Messaging Protocol (RTMP) and
the communication server.  For the first time, rich client applications can be shared and used
by multiple users, enabling a new generation of communication applications.  RTMP supports
real-time, n-way streaming of text, audio and video data, as well as SharedObjects, which
provide a model for sharing any ActionScript object between multiple connected client
computers.
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8. Multi-lingual and Unicode support
Macromedia Flash MX now supports 11 international languages including new language support for
Korean and Chinese.  In addition, Flash MX supports Vertical Text and Unicode Standards.

In addition to accessibility for persons with disabilities (see next page), it is important that content on
the web can be authored and displayed in multiple languages.  Macromedia Flash MX will ship in
eleven international languages including English, French, German, Spanish, Italian, Brazilian
Portuguese, Swedish, Japanese, Korean, and Traditional as well as Simplified Chinese.  Adopted
worldwide, the Flash authoring tool and Flash Player will now included integrated support for Unicode
character standards.

Unicode allows for the representation of multiple languages without the necessity of having to change
your machine's language locale. Unicode accomplishes this by assigning a unique code to each
character rather than encoding it using existing character sets that may not support that language. 

If you have the appropriate fonts installed, you can for example see Japanese, Korean, Chinese and
English simultaneously in separate movies or in a single movie by using ActionScript to import the
character sets for each language. In past versions of Flash this was not possible unless you embedded
the character outlines, increasing file size appreciably. 

A new feature in Flash MX that is present for all languages is support for vertical text. Text fields can
now be set to display text that reads from top to bottom, and can flow from right to left or vice versa.
This feature is useful for text that reads vertically in any language, but is especially critical for Asian
languages such as Japanese, Korean and Chinese.

Text fields can now be set to display text that reads from top to bottom, and can flow
from right to left or vice versa.
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9. Accessibility
Develop Flash content that is useable and accessible to everyone, including those with disabilities.

When creating content and applications for the Internet, ensuring content is viewable by everyone,
including those with disabilities is something that every professional Flash developer needs to be
aware of. Flash MX has integrated the process of creating accessible content into the development
workflow. To add descriptive text to your animations and user interface elements, simply select the
item you wish to tag, enter the appropriate text description, and when users with assistive technologies
(ex: Screen Readers, brail output, etc.) encounter your content they will be able to navigate and take
part in your content in the same manner as an HTML document authored with accessibility in mind.

Easy to use tools for providing descriptive content
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10.  Easy Development and Deployment on Multiple Platforms and Devices.
The promise of the Internet is content and applications anywhere and on any device.  The incredible
growth of the Internet was fueled by the fact that websites and applications can be viewed on any PC
operating system.  In the coming years, we are seeing an explosion in the types of devices that are
connected to the Internet, creating even greater challenges for content and application developers.
The Macromedia Flash Player provides the widest support possible for development and deployment
content and applications on multiple client devices.

A Common Runtime across Operating System, Browser and Chip sets

Internet-enabled client devices typically consist of a combination of operating system, micro-chip
architecture and additional Internet software such as a browser. Macromedia Flash Player functions
the same across any combination of these components, ensuring that developers can easily create
applications that work the same across these client platforms/devices. The programming model and
runtime work exactly the same for developers, no matter the device platform. Developers are also able
to deploy the same Flash content or application to different devices, without recompiling.

Support for major PC platforms

Macromedia Flash Player supports the broadest range of all major versions of Windows, Macintosh,
Linux and Solaris, addressing all popular desktop systems. Developers seeking to build rich client-side
content and applications that work across multiple systems can do so easily with the reliable
deployment of the Flash Player.
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Broad support for industry-leading devices
Macromedia Flash Player extends well beyond desktop systems into new categories of device
platforms. Flash Player is available for Windows CE, PocketPC, Windows XP Embedded, Microsoft
TV, Embedded Linux, QNX, Symbian EPOC, OpenTV, Liberate, and a variety of other device
platforms. Based on support for these platforms, the Flash Player is finding its way into many popular
consumer and corporate devices including wireless handhelds, iTV boxes, tablet computers, and
gaming and home entertainment consoles.

Easy to design interfaces for multiple form-factors
While the runtime is consistent across platforms, often the form factor of devices are quite different.
With Macromedia Flash MX, developers can use templates that constrain the design environment to
the physical properties of a device.  Templates can provide default screen sizes, color constraints, and
can even include common libraries of assets that can be shared across different device types.

Authoring a personal information client for a mobile handheld device
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MACROMEDIA FLASH MX FEATURES AND BENEFITS OVERVIEW

Features for Professional Designers
For the Professional Designer, Flash MX provides sophisticated illustration, motion graphics and video
tools for high-impact website design while also providing a great introductory way to get into rich
Internet application design

* Denotes a new feature of Macromedia Flash MX

New Cross Product Workspace* The Flash MX workspace environment is an intuitive, easy-
to-learn and highly configurable workspace. This allows
Flash to be just as approachable to a designer or animator as
it is to a developer. Features include customizable panel
layout, accelerator keys, publish settings, and even custom
panel usage.

Intuitive Natural and Bezier Drawing
Tools

Flash MX offers both natural drawing tools, familiar to the
traditional artist or Bezier-based tools such as Pen and Sub-
selection providing an intuitive model for creating graphics.

Property Inspector* Just as in Macromedia Dreamweaver, the Flash MX property
inspector shows only relevant, context-sensitive settings for
tools and objects, dramatically reducing the number of
panels required to be open at any point in time.

Video Support* Flash MX features new support for the import and streaming
playback of video, ideal for short clips for use within Flash
sites and applications.

High-Fidelity Audio Support Flash MX supports ADPCM, MP3 and new speech audio
compression technologies making the addition of audio to
any website easy.

Timeline Enhancements* The industry standard Flash MX Timeline includes improved
cursor feedback, collapsible layer folder, resizing, cutting
and pasting of multiple frames, cel-based and object-based
editing modes to improve the motion graphics workflow.

Layer Folders* New Folder layers make it easy to organize and access
layered content in the timeline.

Author-Time Shared Libraries* Flash MX can now automatically track symbols as they are
copied from one document to another, and will remember
the location of the original symbol. This allows users to share
symbols across multiple documents, and if they update the
original symbol, they can choose to either manually or
automatically update the referring symbols to the latest
version.

Quick Start Templates* New pre-built templates make it simple to create
professional looking presentations, photo albums,
advertisements, and learning content.

Macromedia Answers Panel* A new interface offering immediate access to support, tips
and other resources available on Macromedia.com and other
community websites.

New languages: Korean and Chinese* Macromedia Flash MX now supports 11 international
languages.
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Library Enhancements* Flash MX makes it easier to add library content from other
Flash by maintaining folder structures, and resolving
duplicate names. In addition, users can import media directly
into a library without adding it to the stage.

Author time Vertical Text* Text fields can now be set to display text that reads from top
to bottom, and can flow from right to left or vice versa. This
feature is useful for text that reads vertically in any language,
but is especially critical for Asian languages such as
Japanese, Korean and Chinese.

Develop Accessible Content* With Macromedia Flash Player 6 users with disabilities will
now be able to interact with content developed with
accessibility in mind.

New Free Transform Tool* The new Free Transform tool combines scale, rotation, skew,
and distortion into one, easy to use tool.

Pixel-Level snapping Control* New Pixel Snapping provides designers the precision of
object placement down to exact pixels. Designers can
specify that objects should be locked to exact pixels upon
creation or when they are moved, helping guarantee the
layout of their designs will be rendered exactly how they wish.

Guaranteed Layout Control Designs layouts, text and imagery created in Flash MX are
viewed identical across all browsers, platforms and devices
as originally authoring without conforming to cumbersome
table layout or layering techniques using traditional
technologies.

Improved Color Mixer* Color selection models and interfaces are similar, ensuring
easy color application to designs.

Missing Font Substitution* Missing Font Substitution notifies Flash authors that one or
several of the fonts used in their document are missing and
provides the option to pick the substitute or to accept the
default mappings provided by Flash.

Text Break Apart* When using the “Break Apart” command on text fields, Flash
MX introduces an intermediate step that now breaks the text
apart into separate, editable letters before breaking them into
vector shapes. This makes creating and updating text
animations much simpler.

Distribute to Layers* Flash MX enables designers to select multiple objects and
use the “Distribute to Layers” command to automatically
create and name a layer for each object and move the
objects to their own respective layers. Flash will even name
the layers appropriately; if the object is a symbol or a bitmap,
the new layer will be named the same as the objects.

Scriptable Masks* Designers and Developers can create complex effects easily
using the dynamic masking capabilities in Flash MX. Movie
clip symbols can be used to create animated mask effects,
and masking can now be scripted using ActionScript.

Macromedia FreeHand® and Adobe
Illustrator® import*

Improved import of FreeHand 10 and Illustrator files
improves the workflow between commonly used vector
illustration packages.
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Integration with Macromedia
Dreamweaver®*

Flash MX and Dreamweaver integration has never been
closer with the integration of launch and edit capabilities
between the two products.

Fireworks® PNG import* Improved native Fireworks PNG import allows layered
objects, native text and vector graphics to be easily
integrated into any Flash MX document. Launch and edit
from Flash MX make bitmap updating a breeze.

Save as Flash 5* Flash 5 users will be able to save their projects in the
Macromedia Flash 5 Document format so you can upgrade
now and still work on Flash 5 projects.

Complete lessons & samples* Flash MX features interactive lessons that help new users
get up to speed quickly.  In addition, a variety of Flash
samples provide designers and developers real-world
examples of features in action.

Web-Native Printing Flash MX offers the ability to create high-quality, printable
designs compatible with low-bandwidth connections without
having to rely on other technologies.

Export to Multiple File Formats Flash MX allows publishing capabilities to multiple formats
including Macromedia Flash (SWF), PNG, GIF, animated
GIF, JPEG and QuickTime®.

Enhanced Designer Scripting Significant improvements to “Normal” mode of the
ActionScript editor enable a drag and drop mechanism for
applying interactivity along with reference descriptions and
context sensitive links to samples and documentation.
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Features for Application Developers
For the Application Developer, Macromedia Flash MX provides a stable and consistent
platform for developing and deploying rich data-driven Internet applications.

* Denotes a new feature of Macromedia Flash MX
** Denotes part of a new server solution from Macromedia expected mid-2002
Exceptional ActionScript Editor* Develop powerful ActionScript directly within Flash MX. This

highly customizable code environment includes
enhancements for both expert and novice users. Code
hinting, color-coding, search/replace, and auto formatting
make the environment more powerful for true coders.

Robust Code Debugger* Debug complex applications through the new debugger
including breakpoints and code stepping. Debugging can be
done within the development environment or within a web
browser.

Optimized Application Server
Integration**

Through the new Flash application server gateway and
Action Message Format (AMF), application developers can
rapidly develop high-performance, rich Internet applications.

Develop Communication
Applications**

The new Macromedia communication server will allow the
development of 2-way messaging, audio and video that can
be broadly deployed on a standard client.

New ActionScript Object and Event
Model*

Building upon existing ActionScript support, Flash MX
introduces a sophisticated Object and Event model. This
gives advanced application developers low level of control of
the Macromedia Flash Player.

Pre-defined Flash Components (List
Box, Combo Box, Radio Buttons,
Scroll Box)*

Flash Components allow developers and designers to
quickly build user interfaces that are immediately familiar and
usable. In addition to encapsulating complex interactions in a
reusable and sharable development environment. All
interface components are completely customizable at
development or runtime

Live Preview for Components* Get immediate feedback as to the look and feel of user
interfaces built using Flash Components without having to
compile your movie.

Persistent client data through
SharedObjects*

Flash MX includes a feature called SharedObjects, which is
used to store complex data for reuse across or within an
application session.  SharedObjects allows developers to
persist complex object data on the local disk, and re-use it
during later sessions. This improves application performance
by reducing the number of requests made to servers, and the
amount of data needed to transmit before a user can begin
working; also enables offline applications that can
synchronize data with servers when a user is online.

Dynamically Load in JPEGs and MP3
files*

Developers can now insert JPEG and MP3 media files
during runtime without making any changes to their existing
assets.

Improved performance for native
ActionScript functions*

Commonly used ActionScript functions have been optimized
to be up to 100x faster, while still maintaining compatibility
with existing Flash content.
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Visual View of Application States Leveraging the built-in Timeline, application developers
receive a visual layout of different states along a horizontal
access unlike any other application development
environment.

Code Hinting* Speed development time with customizable inline code hints
for both novice and expert developers.

Shape Drawing API* Create sophisticated vector graphics on the fly using
ActionScript. Advanced developers now have direct access
to the shape drawing functionality with Macromedia Flash
Player.

Develop Accessible Applications* With Macromedia Flash Player 6, users with disabilities will
now be able to interact with applications developed with
accessibility in mind.

Enhanced sound control* Develop sound driven applications with added control over
sound duration, position, and completion.

HTML text Incorporate HTML 1.0 text formatting to effectively deploy
text-rich Internet applications.

Named Anchors* Develop Flash movies so that they can be book marked,
allowing for the use of the browser back and forward buttons.

Macromedia Answers Panel* A new interface offering immediate access to support, tips
and other resources available on Macromedia.com and other
community websites.

New languages: Korean and Chinese* Macromedia Flash MX now supports 11 international
languages through new Unicode support in Flash Player,
enabling applications to be deployed to a broader range of
regions.

Develop for multiple mediums:
Desktop, web, PocketPC, MSTV,
PlayStation 2, Nokia 9200
Communicator Series*

With Macromedia Flash MX, content can be designed and
deployed to any browser, platform or device supporting the
Macromedia Flash Player.
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QUOTES ABOUT MACROMEDIA FLASH

Beta User Quotes
"With Flash MX, we finally have the web development platform we've been waiting years for.  It's the
first solution to allow development of rich user interface experience (previously only available with
traditional application development) in a truly cross platform manner.  Flash has finally succeeded
where Java, Dynamic HTML and even traditional HTML development have failed, providing a
consistent, robust user interface.”  - Mark Belanger, Fluid

“Flash MX offers Java-like flexibility and power in a mature, approachable GUI. Rapid internet
application development is finally a reality.” - Colin Moock, Ice Inc.

"Unlike any other web technology, Flash MX empowers my fellow developers and me with the tools
we need to rapidly create visually compelling, highly interactive, data-driven web applications. With a
solid set of built-in skinnable components, robust debugging tools, and numerous methods for server
interaction Flash MX has brought rapid application development to the web!" - Brendan Hall,
FigLeaf Software

Industry Quotes

Forrester Research

(1) "Firms can use Macromedia's Flash technology to add compelling, cross-platform interactivity
to their sites.  But companies must avoid common pitfalls by focusing design teams on
functional tools that support user goals."

(2) "Flash's ubiquity means that firms should embrace it for interactive site features like
configurators and comparison tools. To best leverage Flash's potential, companies should force
Flash 'experts' to server user goals...Companies should use...resources to build value-add Flash
applications, not gratuitious interface elements and cartoon-like movies that distract  users from
their goals."
Randy Souza, Analyst, Forrester Research, September 2001

Web Review

"What I love about Flash is that you can have animation and interactivity, yet still keep the file size
small enough to stream smoothly across a dial-up connection. No other technology can do what
Flash can do with such a small file-size, and still function smoothly and uninterrupted."

"For the beginner who knows nothing about computers, Flash makes learning the program easy
with its high-quality tutorials. Using the drawing tools is a snap for any beginner after sitting down
with the program for an hour or so, and you can quickly create very clean, complex graphics using
Flash."
Steve McCannell, Senior Writer, Web Review, July 2001
http://www.webreview.com/mmedia/2001/07_06_01.shtml

ZDNet

"The web offers a big blank canvas and a host of new tools for giving outlet to creative
experimentation. Plus, it's cost effective. Macromedia's Flash works as well on TV as the computer
screen. You can produce it once and use it in both mediums."
Patrick Houston, Editor, ZDNet, May 2001
http://www.zdnet.com/anchordesk/stories/story/0,10738,2766166,00.html
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Business 2.0

"As HTML can no longer handle the strain of the "next level" of interactivity, businesses are
looking to plug-ins like Flash to manage the strain."
David Lidsky, Editor, Business 2.0, September 2001
http://www.business2.com/articles/mag/0,1640,16862,FF.html?ref=cnet

Customer Quotes

SFMOMA, 010101, Perimetre-Flux
"With the museum's enthusiasm, we decided to push the envelope with the design and the experience
of the 010101 site, and Macromedia Flash was the only choice," said Alex Lord, interactive designer,
Perimetre-Flux. "We experimented with every section, applying information and techniques that were
visually unique from the rest. Using the streaming technology in Macromedia Flash, we created effects
with movement, transparencies, and masks to ensure a seamless experience for the user. With
Macromedia Flash 5 and its rich programming environment, we knew that it would be the fastest way
to achieve the desired result while allowing us the most control."

The Chopping Block and They Might Be Giants, The Chopping Block
"In a studio where graphic design has always come first, Macromedia Flash provides us with a visually
boundless space within which we build interactive projects that are not limited by the visual and
technical shortcomings of traditional web development," said Matthew Richmond, partner/designer,
The Chopping Block.

"Macromedia Flash is a write once, work everywhere solution, offering designers and artists the ability
to make and deploy almost anything imaginable. As the scripting component in Macromedia Flash has
matured, we have been able to develop data driven projects while still keeping complete control over
the look, feel, and interaction of a project."

Inventions & Inspirations: The History of Recorded Sound, Second Story Interactive
Studios
"We used Macromedia Flash technology to create the History of Recorded Sounds kiosk primarily
because our studio is Macromedia Flash literate, and it is our rich media authoring tool of choice," said
Brad Johnson, creative director, Second Story Interactive Studios. "The beautiful thing is that the
Macromedia Flash technology works well online or in kiosks--and when museums want to migrate
their kiosk content to web audiences, content developed with Macromedia Flash is easier to
repurpose than any other content."

Shorn, Juxt Interactive
"Most publishing on the web is built more around how to get content in and out of a database and less
about touching people in a unique and meaningful way," said Todd Purgason, creative director, Juxt
Interactive. "Macromedia Flash takes content and makes it an experience unmatched by any other
medium, which goes beyond telling stories to letting users participate in stories. Macromedia Flash is
the only way the Shorn site could exist."

The Remedi Project, ioResearch®
"There are many reasons our studio chooses to use Macromedia Flash for our work – its cinematic
narrative qualities, the small file sizes, its streaming capabilities - but for The Remedi Project, one of
our clearest reasons for using Macromedia Flash is its object oriented nature," said Josh Ulm, director,
ioResearch. "Macromedia Flash allows us to build systems that are modular and therefore, very easy
to add to, update, or change. With Remedi, we are adding to the work every few months. To keep the
site and content as powerful and dynamic as it needs to be, and to do so easily, Macromedia Flash is
really the only solution."
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FLASH SUCCESS STORIES

Here is just a snapshot of what companies are doing today with the Macromedia Flash Solution.  For
examples of what our 1 million developers are doing with Macromedia Flash today, please visit
http://www.macromedia.com/software/flash/special/inspiration/

Macromedia Flash for Applications

Broadmoor

Webvertising's iHotelier oneScreen interface collapses the reservation process into a single step and
a single screen, making the reservation process easier and faster. The use of a single screen to
graphically display calendar information, inventory information, and reservation information allows
customers to vary their purchasing parameters at will and immediately view those results.  OneScreen
is a new user interface for hotel guests built in Macromedia Flash to work with an existing Cold Fusion
application.

Macromedia Flash and Macromedia ColdFusion working together enabled Webvertising's iHotelier to
create a one-of-a-kind application for the hotel industry that every hotel wants to have.  OneScreen is
huge advantage over their competitors, because no one has anything that even approaches it.  Rapid
development is important in the hotel industry.

Webvertising's iHotelier chose Macromedia Flash because of it allowed them the ability to create a
truly innovative business and commerce applications.

View the site: http://www.ihotelier.com/onescreen.html
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Salomon Extranet

When Salomon first engaged NetXposure to create a new extranet site for the employees at Salomon
dealerships, the company's objective was to improve employee productivity.

By replacing a print-based catalog system with an online application, NetXposure enabled
administrative personnel at Salomon's head office to monitor inventory and update content for the
dealerships. Automating the catalog/telephone/fax order system promised to also reduce customer
service costs and increase order accuracy and fulfillment speed.

Initially, NetXposure implemented its application engine called Exogen, with a web-based
administrative interface developed in HTML. However, there were several drawbacks to the HTML
version. With less than compelling aesthetics and a slow, clunky interface, users were forced to sit
through page reloads every time they updated content. HTML doesn't provide users with an
application feel, and it lacks any kind of ability to process data, rendering the site's knowledgebase
under utilized. Additionally, searching the site's product database proved time consuming and
repetitive for Salomon users.

The Salomon Dealer Extranet's new Macromedia Flash application presentation layer greatly
enhances the productivity benefits of the original HTML site. Employees no longer spend valuable
time waiting for pages to load, one after another.

"Because Macromedia Flash re-uses space and uploads only that portion of a page that's required,
we've increased page load time by approximately 20% over the old site," says Wehling.
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Macromedia Flash for eLearning

Cisco®

In efforts to provide mobile training to its sales force, Cisco Systems created a Macromedia Flash
based training application for the Pocket PC. The Pocket PC edition of the quick reference guide
presents detailed information about interface modules and port adapters for the Catalyst 8540 MSR
Multiservice Switch Router. Users can browse functional descriptions of the modules and port
adapters; find which chassis slots accept them; identify connectors for the required cabling; and view
animated illustration instructions. Cisco now provides a more convenient way for customers to access
information from remote locations.

Because Macromedia Flash platform is format independent, Cisco uses Macromedia Flash for both
classroom and device based training.

View the site: http://www.cisco.com/mm/quickstart/8540msr/8540hh/

Read more about the success story:
http://dynamic.macromedia.com/bin/MM/showcase/scripts/showcase_cs_cover.jsp?Showcase_OID=
190325
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1-800Contacts

1-800 CONTACTS (www.1800contacts.com/vision101) used Macromedia Flash to create Vision101 in
order to educate customers about how the eye works, the way visual imperfections are corrected, and
general issues pertaining to ocular health. Vision101 uses Macromedia Flash to deliver an e-learning
site that instructs users about basic eye anatomy, proper contact lens usage and care, prescription
parameters, the different types of lenses, and potential eye problems and diseases.

"The choice to use Macromedia Flash for Vision101 was simple,'' said Bruce Christy, corporate design
director, 1-800 CONTACTS. "The wide reach of the Macromedia Flash Player provided the essential
tools to illustrate an otherwise difficult subject to grasp. It was evident early on that the project would
be a success because of its ability to demonstrate vision in a both animated and interactive way.''
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Asthma

A ten-minute movie, What's Asthma All About? uses the web and Macromedia Flash technology to
educate the public about asthma. Launched in English and Spanish by Neomedicus, the movie is
freely available to people around the world. Since its release, the movie has received a remarkable
response from the medical community and from persons with asthma around the world.

"The release of this movie as a freely available resource was met with a phenomenal response," said
Rajeev Venkayya, M.D., an Assistant Professor of Medicine at the University California, San
Francisco.

In fact, within the first week of its release, the movie was featured on numerous well-respected medical
sites, including those of the American Lung Association, the American Academy of Allergy, Asthma,
and Immunology, and the Asthma Society of Canada. "This brought significant attention to asthma
management and the potential of web-based technologies to more effectively educate people about
issues related to their health," said Venkayya.

Neomedicus used Macromedia Flash to combine the precision and flexibility of vector graphics with
bitmaps, audio, and animation. Designers also used Macromedia Flash MP3 streaming audio
capabilities to deliver high-quality sound (narration) in concert with the movie.

"Macromedia Flash allowed us to animate our medical illustrations and turn a simple informational
piece into an animated storyline that interacts with the viewer. Another great benefit of Flash is that all
of the functionalities—sound, layout, and animation— will essentially be the same, irrespective of the
platform or browser that someone uses to view our piece," said Petro Papahadjopoulos, Flash
Director, Neomedicus.

View the site: http://www.whatsasthma.org/

Read more about the case study:
http://dynamic.macromedia.com/bin/MM/showcase/scripts/showcase_cs_cover.jsp?Showcase_OID=264723
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PRODUCT AND COMPANY FACTS

Trademarks

Macromedia® Flash™ MX

PR Contact

Suzy Ramirez
sramirez@macromedia.com
(415) 252-4053

Availability

Macromedia Flash MX for Power Macintosh or OS X 10.1 or higher and Windows 98 SE, Windows
Me, Windows NT4, Windows 2000, or Windows XP will be available online at the Macromedia Store
and in the U.S. and Canada in March of 2002. Localized versions for French, German, Japanese,
Swedish, Spanish, Italian and Brazilian Portuguese will be available shortly thereafter and Korean,
Traditional and Simplified Chinese will be available in mid-2002. Macromedia Flash MX Server
Solutions will be available mid-2002.

Flash MX Full Pricing

$499   Packaged product, including manual and CD-ROM
$499 (Electronic Software Download or ESD)*
$15 Manual and CD (for ESD purchasers)

Flash MX Upgrade Pricing

From all previous versions of Flash:

$199 (Electronic Software Download or ESD)*
$199 (Packaged product, including manual and CD-ROM)
$15 Manual and CD (for ESD purchasers)

*All Electronic Software Download (ESD) versions include tutorials, examples and full documentation
in electronic form.

International upgrade options are available through Macromedia authorized distribution partners. Visit
http://www.macromedia.com/store/ for a listing of international distributors.

Distribution

Macromedia Flash MX will be available in the U.S., Canada and on the web through standard software
distribution channels, retail dealers and mail order. Visit http://www.macromedia.com/buy/ to
purchase from the Macromedia website.

More than 80 partners in over 50 countries worldwide provide Macromedia with a strong international
distribution channel. Visit http://www.macromedia.com/buy/ or call 800 326 2128 for the name of a
Macromedia authorized reseller in your area.

Educational customers should contact their educational reseller. Visit
http://www.macromedia.com/buy/ to find an educational reseller or bookstore or call 800 326 2128
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Macromedia Offices

Macromedia, Incorporated
600 Townsend Street
San Francisco, California 94103
Tel (415) 252-2000
Fax (415) 626-0554
http://www.macromedia.com/macromedia/
275 Grove Street
Newton, MA 02466
Tel (617) 219-2000
http://www.allaire.com

Macromedia Europe (UK)
Century Court
Millennium Way
Bracknell
Berkshire
RG12 2XN
United Kingdom
Tel 44 1 344 458 600
Fax 44 1 344 458 666
E-mail europe@macromedia.com
http://www.macromedia.com/uk/

Macromedia Northern Europe
(Germany, Austria & Eastern Europe)
Gewerbepark 6
93333 Neustadt
Germany
Tel 0049-9445-95490
Fax 0049-9445-21908
http://www.macromedia.com/de/

Macromedia Southern Europe
(Benelux, France, Spain, Italy, Middle East & Africa)
1, avenue Morane Saulnier
Immeuble St Exupéry
78140 Vélizy Villacoublay
France
Tel 33 139 45 11 60
Fax 33 139 45 91 74
http://www.macromedia.com/fr/

Macromedia Nederland BV
Siriusdreef 17 -27
2132 WT Hoofddorp
Tel. +32 (0)23 5689160
Fax. +32 (0)23 5689343
http://www.macromedia.com/nl/

Macromedia Switzerland
Hauptstrasse 65
9400 Rorschach
Switzerland
Tel 41 71 844 98 98
Fax 41 71 844 98 99
http://www.macromedia.ch

Macromedia Japan
13F Main Building of
Akasaka Twin Tower
2-17-22 Akasaka
Minato ku
Tokyo 107-0052, Japan
Tel 81 3 5563 1980
Fax 81 3 5563 1990
E-mail japan@macromedia.com
http://www.macromedia.com/jp/

Macromedia Asia Pacific
1 Princess St., Suite 207
Kew
Victoria
Australia 3101
Tel 61 3 9853 0900
Fax 61 3 9853 0600
E-mail asiapacific@macromedia.com
http://www.macromedia.com/ap/

Macromedia South Asia
165B Telok Ayer Street
Singapore 068617
Tel 65-325 9932
Fax 65-4239 200

Macromedia Hong Kong Ltd
Unit A, 27/F, EIB Centre,
40-44 Bonham Strand E, Sheung Wan,
Hong Kong
Tel 852-2191-2562
Fax 852-2191-2391

Macromedia Korea
11F. Woori Investment Bank Bldg.
826-20, Yeoksam-Dong,
Kangnam-Ku, Seoul
Tel 82-2-3466-2881
Fax 82-2-3466-2888
E-mail korea@macromedia.com
http://www.macromedia.com/kr/

Macromedia Latin America
600 Townsend Street
San Francisco, California 94103
Tel (415) 252-2000
Fax (415) 626-0554
E-mail latinamerica@macromedia.com
http://www.macromedia.com/la/

Macromedia Brazil
Av. Roque Petroni Jr, 999 13oandar
São Paulo, SP, 04707-910
Tel: 55-11-5185-2824
Fax: 55-11-5185-2802
E-mail brasil@macromedia.com
http://www.macromedia.com/br/
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Sales Contact Information

Macromedia
600 Townsend Street
San Francisco, CA 94103
415 626 0554 Fax
800 457 1774 Telesales in North America
415 252 2000 International
U.S. and Canada: http://www.macromedia.com/software/flash/
or http://www.macromedia.com/software/
Int’l: http://www.macromedia.com/macromedia/international/

Technical Support

In the U.S. and Canada, new registered users of Macromedia Flash MX and users upgrading to
Macromedia Flash MX receive 90 days of complimentary technical support beginning with their first
call. Priority Access subscription technical support plans are also available in addition to free technical
support through the Macromedia Flash news group. For details, visit
http://www.macromedia.com/support/ or call 800-455-7031. Macromedia Flash users outside North
America should contact their local distributor for support options.
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 SYSTEM REQUIREMENTS

Macromedia Flash MX

Windows®
  

Macintosh®

200 MHz Intel Pentium processor
Windows 98 SE, Windows Me, Windows
NT4, Windows 2000, or Windows XP

  
Power Macintosh with Mac OS 9.1 or higher,
or OS X 10.1 or higher

64 MB of free available system RAM   64 MB of free available system RAM

100 MB of available disk space   100 MB of available disk space

256-color monitor capable of 1024 x 768
resolution

  
256-color monitor capable of 1024 x 768
resolution

CD-ROM drive  CD-ROM drive

Integrates with any application server  Integrates with any application server

Macromedia Flash Player 6

Windows   Macintosh   Linux   Solaris

Windows 95, Windows 98,
Windows Me, Windows NT4,
Windows 2000, Windows XP
or later

 
System 8.6 or later
System OS X 10.1 or
higher

  

Linux Redhat
7.0 or above
(Pentium-based
only)

 

Solaris 2.6 or 8
(24-bit color,
SPARC only)

Netscape plug-in works with
Netscape 4.07 or later
Opera 6.5
CompuServe 7  

Netscape plug-in works
with
Netscape 4 or later,
Microsoft Internet
Explorer 4.5 or later,
CompuServe 7, and
Opera 6

 

Netscape
Navigator 4 or
later, with
standard install
defaults

(available mid-
2002)

 

Netscape
Navigator 4 or
later, with
standard install
defaults

(available mid-
2002)

ActiveX control works with
Microsoft Internet Explorer 4 or
later (Windows 95, Windows
98, Windows Me, Windows
NT4, Windows 2000 XP),
and AOL 7
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FLASH TUTORIALS

Application Walkthrough

1) In a browser, navigate to “global.htm” located in “FlashMX_Tutorial > rentalApp”.

2) In the login screen, enter your name in the “Username” field and enter “macromedia” in the
password field.

3) Click “Login”. The page you see in front of you is a sample application that could be used in a
call center environment. For this example, the call center is for a rental car company and call
center representatives use the application to log new rentals for calling customers.
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4) Click the tabs in the promotional banner located on the right side of the page. The promotional
banner is used to inform call center reps of bonus points given for rental extras. In the designer
portion of this tutorial, you’ll recreate the animation for the cell phone promotion.

5) Click the “LEARN MORE ABOUT GPS” button, , on the lower right side of the
page. This window is used to train call center reps on the GPS available to customers.

In the “Training” window, notice the vertical text, “VIDEO”, the GPS video and the “Vehicle
Guide” text. Press the video controls to watch the GPS video. In the designer portion of this
tutorial, you’ll add the elements you see in this window.

6) Close the “Training” window by clicking the “X” on the upper right.
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7) In the “Message Center” panel, located on the lower left of the stage, select a contact from the
“Contacts” ComboBox.

8) In the “Message” text field, ask when the GPS bonus points expire then click “Send”. Wait for
an answer from your contact.

9) In the “Search” panel in the upper left, verify that “Name” is selected from the ComboBox. In
the search field, enter “rich” then click “Search” to search for people with last name beginning
with “rich”.

10) Click on any of the names in the list box and the form in the “Profile” tab populates with each
person’s data.

11) Click the “New Rental” tab to open the “New Rental” section. Notice that the previewed car
type matches the customer’s preferred car type from the “Profile” tab.

12) Select a pick up and drop off date by clicking any of the days in the calendar. Once a day has
been selected, click it again to deselect it. To clear all days, click the “Clear” button. Notice the
availability of car types changes depending on the days selected.

13) In the pick up “Location” text field, enter “san” and then select “San Francisco, CA” from the
list. Repeat for the drop off location.

14) Select a pick up time from the ComboBox displaying times. Repeat for the drop off time.

15) Click a car type to select it. If none is available, reselect the dates until there is one.

16) Check off any of the extras.

17) Add any comments in the comments field.

18) Click “Add Rental”. If you did not select a GPS as an extra, an upsell for it will appear in the
dialog box, click “Yes” or “No”. Click “OK” to add the rental.

19) After adding the rental, the application will move to the “History” tab. In the “History” tab, you’ll
be able to see the new rental at the top of the history list with the detail in the bottom form. To
view another history item, click an item from the list. You may also sort the data according to
the column headers.
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File Structure

The reviewer’s guide files are organized into four top level folders. The first folder, “completedFiles”,
contains completed versions of all of the tutorial files. The second folder, “designer”, contains all of the
files needed for the designer tutorials. The third folder, “developer”, contains all of the files needed for
the developer tutorials. The final folder, “rentalApp”, contains the files used in the rental car
application. In each step of the tutorial, you will recreate some of the functionality from the application.
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Designer Tutorial 1: New from Template
New in Flash MX is a set of pre-built templates that make it easier to create professional looking
presentations, photo albums, advertisements, menus and e-learning content.  In addition, designers
can create their own templates to use as a starting point.  In this tutorial, you will create a new
template, and then use that template as a starting point to create a new Flash document.

Step 1: Open “template.fla”

ACTIONS

a) Open “template.fla” by going to “File > Open…” and then navigating to “Tutorial> Designer >
template.fla”.

Step 2: Save File as Template

ACTIONS

a) Save “template.fla” as a template by going to “File > Save as Template…”

b) In the “Save as Template” dialog box, enter “Pop-up Bg” in the Name field. In the Category
drop-down menu, enter “Pop-up”. In the Description field, enter “Pop-up window
background.”

c) Click “Save” to save the file as a template.
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NOTE: Template files are stored in your system’s user configuration folder (for example, on
Windows 2000 or XP this might be something like c:\Documents and
Settings\<username>\Application Data\Macromedia\Flash
MX\Configuration\Templates\<category>).

d) Close “template.fla”.

Step 3: Open a New File and Apply Template

ACTIONS

a) Open a new file from a template by going to “File > New From Template…”

b) In the “New Movie” dialog box, select “Pop-Up” from the “Category” pane. From the
“Category Items” pane, select the template created in the previous step, “Pop-up Bg”.

c) Click “Create” to create a new file from a template. You now have a new movie that contains
all of the elements included in the original template file. This template is available to apply to
any new Flash MX file.

d) Save the file as “des_Tutorial1.fla” by going to “File > Save As…”

e) Close the file.
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Designer Tutorial 2: Author-Time Shared Libraries
Shared library assets enable you to use assets from a source movie in multiple destination movies.
Using shared library assets can optimize your workflow and movie asset management in numerous
ways. For example, you can use shared library assets to share a font symbol across multiple sites,
provide a single source for elements in animations used across multiple scenes or movies, or create a
central resource library to use for tracking and controlling revisions. In this tutorial, you’ll first add a
logo to “des_Tutorial2.fla” from “sharedSymbols.fla”.  The Shared symbols folder is a Flash document
that contains assets that can be shared across many Flash documents. Next, you’ll update the logo in
“sharedSymbols.fla” and then see how easy it is to have that updated logo reflected in
“des_Tutorial2.fla”.

Step 1: Open “des_Tutorial2.fla”

ACTIONS

a) Open “des_Tutorial2.fla” by going to “File > Open…” and then navigating to “Tutorial> Designer
> des_Tutorial2.fla”.

Step 1: Open “sharedSymbols.fla”

ACTIONS

b) Open “sharedSymbols.fla” by going to “File > Open…” and then navigating to “Tutorial>
Designer > sharedSymbols.fla”
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c) If the Library panel is not open, open it by going to “Window > Library”. In the Library panel,
navigate to the folder named “Tutorial 2: Shared Library”.

Step 2: Add Symbol to “des_Tutorial2.fla”

ACTIONS

a) Go back to “des_Tutorial2.fla” by going to “Window > des_Tutorial2.fla”.

a) Verify that the layer “shared library” is selected by going to the timeline and checking that the
layer is highlighted. If it is not selected, click on the title area of the layer to select it.

b) From the library of “sharedSymbols.fla”, drag and drop the folder, “Tutorial 2: Shared Library”,
onto the lower left corner of “des_Tutorial2.fla”.

NOTE: To verify that you are in the correct Library, check the top of your Library panel.
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After dragging the symbol, “Logo”, onto the stage, your stage should look similar to the
following:

Step 3: Modify Symbol in “sharedSymbols.fla”

ACTIONS

a) Go back to “sharedSymbols.fla” by going to “Window > sharedSymbols.fla”.

b) Verify that you have the Arrow tool active. If it is not active, click the “Arrow Tool” icon, , in
the tool bar. Next, double-click the “Global Car Rental” logo, to go into symbol edit mode.

c) Change the color of the “Car Rental” text from orange to white by first clicking the text with the
Arrow tool to select it. If the Properties inspector is not open, open it by going to “Window >

Properties”. In the Properties inspector, click the “Color Picker” icon, , and select white or
enter “#FFFFFF” in the text field.

d) Save the file by going to “File > Save”

e) Close the file.

Step 5: Update Symbol in “des_Tutorial2.fla”

ACTIONS

a) Verify that you are in “des_Tutorial2.fla”.
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b) If the Library panel is not open, open it by going to “Window > Library”. In the Library panel,
navigate to the symbol named “Global logo” located in the folder named, “Tutorial 2: Shared
Library”.

NOTE: Notice that the folder structure for the imported symbol remains the same as the folder
structure for the original file, “sharedSymbols.fla”.

c) In the library panel, (PC) right-click or (MAC) CTRL+click on the name and select
“Properties…”

d) In the “Symbol Properties” dialog box, if the dialog box is not expanded, click the Advanced

Button,  to display the expanded dialog box.

e) In the expanded “Symbol Properties” dialog box, check the “Always update before publishing”
check box.

NOTE: It is also possible to update a symbol without publishing a movie by (PC) right-clicking
or (MAC) CTRL+click on a symbol name in the Library and then choosing “Update…”

f) Save the file by going to “File > Save”.

Step 6: View Updated Symbol

ACTIONS

a) To view the updated symbol, go to “Control > Test Movie”.

b) Verify that the symbol has been updated, with the words “CAR RENTAL” in white.

c) Close the test movie mode.

d) Close the file.
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Designer Tutorial 3: Vertical Text
In Macromedia Flash MX, text fields can now be set to display text which reads from top to bottom,
and can flow from right to left or vice versa. This feature is useful for text which reads vertically in any
language, but is especially critical for Asian languages such as Japanese, Korean and Chinese. In this
tutorial, you’ll walk through the new Vertical Text feature in Flash MX. The vertical text will be used on
the tab in the video panel.

Step 1: Open “des_Tutorial3.fla”

ACTIONS

a) Open “des_Tutorial3.fla” by going to “File > Open…” and then navigating to “Tutorial> Designer
> des_Tutorial3.fla”.

Step 2: Add Symbol

ACTIONS

a) Verify that the layer “vertical text” is selected by going to the timeline and checking that the
layer is highlighted. If it is not selected, click on the title area of the layer to select it.

b) If the Library panel is not open, open it by going to “Window > Library”. In the Library panel,
navigate to the symbol, “videoBg”, located in the folder, “Tutorial 3: Vertical Text”. Double-
click on the folder icon to expand the folder.
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c) From the Library panel, drag and drop the symbol, “videoBg”, onto the stage so it is roughly
aligned horizontally and towards the bottom of the stage. To reposition the symbol, first select

the Arrow tool by clicking the “Arrow Tool” icon, , in the tool bar to make it active. Next, use
the arrow keys to move the symbol so it is positioned similarly to the below:

Step 3: Add Vertical Text

ACTIONS

a) Verify that the layer “vertical text” is selected by going to the timeline and checking that the
layer is highlighted. If it is not selected, click on the title area of the layer to select it.

b) Next, select the Text tool by clicking the “Text Tool” icon, , in the tool bar. If the Properties
inspector is not open, open it by going to “Window > Properties”. In the Properties inspector,
set the font to “Arial” by selecting “Arial” from the font drop-down menu. Next, set the size to
11 in the number field and set the letter spacing to 4 in the field below. Next, click the “Color

Picker” icon,  and select white on the left or enter “#FFFFFF” in the text field. Next, click

the “Change direction of text” icon, , and select “Vertical, Left to Right”.

c) With the Text tool still active, click over the tab in the middle of the symbol and enter “VIDEO”
in the text field. To reposition the text field, first select the Arrow tool by clicking the “Arrow
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Tool” icon, , in the tool bar to make it active. Next, use the arrow keys to move the text field
so it is positioned similarly to the below:

d) Save the file by going to “File > Save”.

e) Close the file.
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Designer Tutorial 4: Envelope and Free Transform Tools
Flash allows you to transform graphic objects, as well as groups, text blocks, and instances, by using
any of the Transform tools. Depending on the type of element you select, you can freely transform,
rotate, skew, scale, or distort the element. In the following steps, you’ll see how easy it is to modify
graphic objects using the new Envelope and Free Transform tools. In this tutorial, the modified graphic
objects will comprise the “Up” and “Over” states of a button. After the button states are modified,
you’ll add a few lines of basic ActionScript, which will link the button to the vehicle guide site,
“Carpoint”.

Step 1: Open “des_Tutorial4.fla”

ACTIONS

a) Open “des_Tutorial4.fla” by going to “File > Open…” and then navigating to “Tutorial> Designer
> des_Tutorial4.fla”

Step 2: Add Button

ACTIONS

f) Verify that the layer “envelope” is selected by going to the timeline and checking that the layer
is highlighted. If it is not selected, click on the title area of the layer to select it.

a) If the Library panel is not open, open it by going to “Window > Library”. In the Library panel,
navigate to the symbol, “Vehicle Guide”, located in the folder, “Tutorial 4: Envelope”.
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b) From the Library panel, drag and drop the symbol, “Vehicle Guide”, on to the stage so it
positioned above the GPS video panel. To reposition the symbol, first select the Arrow tool by

clicking the “Arrow Tool” icon, , in the tool bar to make it active. Next, use the arrow keys to
move the symbol so it is positioned similarly to the below:

Step 3: Edit Button

ACTIONS

a) If the Arrow tool is not active, click the “Arrow Tool” icon, , in the tool bar to make it active.
Next, double-click the symbol, “Vehicle Guide”, that was just placed on the stage, to “Edit in
Place”.

NOTE:  The timeline in front of you is a Button timeline. Buttons contain four states: Up, Over,
Down and Hit. In the next few steps, you will modify the “Up” state and create the “Over”
based on the “Up” state.

b) Select the “Up” frame by clicking on it in the timeline. Next, select the “Free Transform” tool

from the tool bar by clicking the icon, , in the tool bar. Next, at the bottom of the tool bar

select the “Envelope” tool by clicking the icon, .

c) With the “Envelope” tool selected, drag the top center points up to alter the image.

d) Next, duplicate the “Up” frame on the “Over” frame. To do this, first click on the “Over” frame
in the timeline.
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Next, go to “Insert > Keyframe”.

e) Select the “Free Transform” tool from the tool bar by clicking the “Free Transform Tool” icon,

. With the “Free Transform” tool, position the cursor above the top line until you get a
horizontal, two way arrow, then click and drag until the image slants to the right.

Step 4: Add Action to Button

ACTIONS

a) Navigate back to the main timeline, by either clicking the back icon or the “scene 1” link in the
upper left.

Your stage should look similar to the below:

a) If the Arrow tool is not active, click the “Arrow Tool” icon, , in the tool bar to make it active.
Next, select the button, “Vehicle Guide”, by clicking it. If the Actions panel is not open, open it
by going to “Window > Actions”. In the Actions panel, check to see if you are in “Normal Mode”
by clicking the “View Options” icon,  , and verifying that there is a check mark next to
“Normal Mode”. If there is a check mark next to “Expert Mode”, select “Normal Mode”.
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b) In the Actions panel, navigate to the action “getUrl” located in “Actions > Browser/Network”
and then double-click “getUrl”. The “getUrl” action will cause a window to open when a user
clicks and then releases the “Vehicle Guide” button.

NOTE: To open a book in the Actions panel, a single-click is all that is needed.

c) In the Script pane of the Actions panel, highlight the second line, “getURL(“”);”. At the top of
the Actions panel, in the URL field, enter “http://www.carpoint.com”.

d) Save the file by going to “File > Save”.

Step 5: Test Button

ACTIONS

a) To view the button, go to “Control > Test Movie”.

b) Verify that the button works by clicking it. A browser window will open to Carpoint.com.

c) Close the test movie mode.

d) Close the file.
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Designer Tutorial 5: Import Video
Flash MX features new support for the import and streaming playback of video, ideal for short clips for
use within Flash sites and applications. Flash can import any standard video file supported by
QuickTime or Windows Media Player, including MPEG, DV (Digital Video), MOV (QuickTime), and
AVI. Video objects inside of Flash can be manipulated much like bitmaps, such as scaled, rotated, or
skewed, masked and animated with motion tweens. Multiple instances of video objects are also
permitted, and video can be contained inside movie clip objects, which make them scriptable,
interactive objects as well.  This allows for creative, innovative ways to integrate video playback within
sites and applications.  In this tutorial, you’ll import a QuickTime clip into your Macromedia Flash
document.

Step 1: Open “des_Tutorial5.fla”

ACTIONS

a) Open “des_Tutorial5.fla” by going to “File > Open…” and then navigating to “Tutorial> Designer
> des_Tutorial5.fla”

Step 2: Import Video File

ACTIONS

a) Select frame one of the layer, “video”, by clicking in frame one of the layer.
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b) Import the video file, “gpsVideo.mov”, by going to “File > Import…” and then navigating to
“Tutorial> Designer > gpsVideo.mov”. In the “Import” dialog box, select “All Formats” from the
drop-down menu, “Files of type”.

c) In the “Import Video” dialog box, select “Embed video in Macromedia Flash document”, then
click “OK”.

d) In the “Import Video Settings” dialog box, set the quality to 95 and the scale to 70%. Click
“OK” to import the video.
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e) After the video has been imported, reposition the symbol, by first selecting the Arrow tool by

clicking the “Arrow Tool” icon, , in the tool bar to make it active. Next, use the arrow keys to
move the imported video so it is positioned similarly to the below:

f) Save the file by going to “File > Save”.

Step 3: View Video

ACTIONS

a) To view the video, go to “Control > Test Movie”.

b) Close the test movie mode.

c) Close the file.



Macromedia Flash MX Reviewer’s Guide

73

Designer Tutorial 6: Create Animation
In this tutorial, you will create the animation used in the cell phone promotion. As you complete your
animation, you’ll also use Layer Folders to help organize the timeline.
NOTE: The following tutorial guides you through using the Timeline using the default preferences.
Verify that the “Span Based Selection” checkbox under the Timeline options section of the General
Preferences is unselected by going to “Edit > Preferences”

Step 1: Open “des_Tutorial6.fla”

ACTIONS

a) Open “des_Tutorial6.fla” by going to “File > Open…” and then navigating to “Tutorial> Designer
> des_Tutorial6.fla”

Step 2: Create Animation

ACTIONS

a) Add a keyframe to frame 20 of the “phone” layer within the mask layer, “animation mask”,
by first clicking on frame 20 of the layer, “phone".

NOTE: To deselect a frame or an object on the stage, press “ESC” or click the playhead,
the red rectangle, at the top of the timeline.

Next, insert a keyframe at frame 20 by going to “Insert > Keyframe”.
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b) Now that we have both the beginning and ending keyframes of the animation set, we will
alter the first keyframe and then let Flash automatically create a smooth animation using a
tween.  Select the phone by clicking on frame one of the layer “phone”.

c) Use the “Right” arrow key to move the phone so that it is positioned off  to the right of the
stage.

d) Select the “Free Transform” tool from the tool bar by clicking the icon, , in the tool bar.
Click and drag the upper right corner towards the center of the phones images to scale
the image down to about half of the original size.
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e) Verify that you have the Arrow tool active. If it is not active, click the “Arrow Tool” icon, , in
the tool bar.  In the Property Inspector, change the color effect to “Alpha” and set the amount
to 0% by using the slider or typing in the value.  This will create a “fade in” effect.

f) To have Flash automatically animate the frames in between the two keyframes, choose “Insert
> Motion Tween”.  The timeline will represent this tween with a blue span with a solid black
arrow.

g) Save the file by going to “File > Save”.

Step 4: View Animation

ACTIONS

a) To view the animation, go to “Control > Test Movie”.

b) Close the test movie mode.

c) Close the file.
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Developer Tutorial 1: Add ScrollBar Component
 New in Flash MX are predefined Flash components including List Box, Combo Box, Radio Buttons,
Scroll Bar, Scroll Pane and a Push button.  Flash Components allow developers and designers to
quickly build user interfaces that are immediately familiar and usable. In addition, developers can
encapsulate complex interactions in a reusable and sharable development environment.  In this
tutorial, you will add the ScrollBar component to a dynamic text field. The ScrollBar component
provides drag and drop functionality for adding vertical and horizontal scroll bars to dynamic and input
text fields. Adding scroll bars to dynamic and input text fields allows the text field to accept infinite
amounts of text without the field growing to accommodate the text. In the sample application, the text
field will be used for call center reps to enter comments about a customer’s rental. Since the length of
the text will sometimes be longer than the box framing the text, the ScrollBar component is needed to
view all of the comment.

Step 1: Open “dev_Tutorial1.fla”

ACTIONS

a) Open “dev_Tutorial1.fla” by going to “File > Open…” and then navigating to “Flash MX _Tutorial
> Developer > dev_Tutorial1.fla”.

Step 2: Add ScrollBar Flash UI Component

ACTIONS

a) Verify that “Snap to Objects” is turned active by going to “View” then making sure a check
mark is next to “Snap to Objects”. If a check mark is not present, select “Snap to Objects”.

b) Verify that you have the Arrow tool active. If it is not active, click the “Arrow Tool” icon, , in
the tool bar. Next, double-click the “New Rental” tab, located towards the top in the middle of
the stage, to “Edit in Place”.
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c) Verify that the layer “ScrollBar” is selected by going to the timeline and checking that the layer
is highlighted. If it is not selected, click on the title area of the layer to select it.

d) If the Library panel is not open, open it by going to “Window > Library”. In the Library panel,
navigate to the symbol named “ScrollBar” located in “Flash UI Components”.
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e) On the stage, locate the large text field in the lower left of the “New Rental” section. This is the
text field that you will add the ScrollBar to. From the Library panel, drag and drop the symbol,
“ScrollBar”, directly onto the right side of the text field but within the dotted lines.

NOTE: The ScrollBar component scrolls a text field based on the name of the text field. In this
case, the ScrollBar will scroll the text field, “txtComments”, which will contain comments about
a customer’s rental. After dragging and dropping the text field onto the promotional text, the
ScrollBar will resize vertically.

f) Save the file by going to “File > Save”.

Step 3: View Working ScrollBar

ACTIONS

a) To test the ScrollBar, go to “Control > Test Movie”.

b) Navigate to the “New Rental” tab by clicking the “New Rental” tab. Enter text in the comments
text field until the scroll bar resizes.

c) Close the test movie mode.

d) Close the file.
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Developer Tutorial 2: ActionScript Editor
In an improved Development environment, both developers and designers can build powerful
ActionScript. This highly customizable code environment includes enhancements for both the expert
and novice user. In-line code hints for both novice and expert developers help speed development
time.  In this tutorial, you will add an action to a button. The action will call a function, which opens the
GPS training video window. As you add the action to the button, you’ll use code hinting, auto indent
and a reference panel.

Step 1: Open “dev_Tutorial2.fla”

ACTIONS

a) Open “dev_Tutorial2.fla” by going to “File > Open…” and then navigating to “Tutorial>
Developer > dev_Tutorial2.fla”

Step 2: Add Action to Button

ACTIONS

b) Verify that you have the Arrow tool active. If it is not active, click the “Arrow Tool” icon, , in

the tool bar. Next, click the “LEARN MORE ABOUT GPS” button, , on the
lower right side of the page.

c) If the Actions panel is not open, open it by going to “Window > Actions”. In the Actions panel,
check to see if you are in “Expert Mode” by clicking the “View Options” icon, , and verifying
that there is a check mark next to “Expert Mode”. If there is a check mark next to “Normal
Mode”, select “Expert Mode”. Next, if line numbers are not turned on, click the “View Options”
icon, , and select “View Line Numbers”.
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d) In the script pane of the Actions panel, position your cursor on line one and enter “on(“. In the
code hint that appears, navigate with the arrow keys until the “release” event is selected, then
hit “Enter”. Complete the line by entering “){“.

e) To view the reference material for the “On” handler, position your cursor in the middle of the
word “on”. Next, click the “Reference” icon, , to view the reference material.

f) In the Script pane of the Actions panel, begin a new line after the statement added above by
pressing “Enter”. On the new line, enter “openVideo();”. Begin another new line by pressing
“Enter”. On the new line, close the “On” handler by entering a “}”.

g) After adding the above statements, your ActionScript should look like the following:

h) Save the file by going to “File > Save”.

Step 3: View Working Button

ACTIONS

a) To test the button, go to “Control > Test Movie”.

i) Click the “LEARN MORE ABOUT GPS” button, , on the lower right side of the
page.

b) Close the test movie mode.

c) Close the file.
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Developer Tutorial 3: Customizing CheckBox Component
All the Flash UI components are fully customizable and re-useable. Some of the properties you can
change include: color, text, font, and font size.  A complete listing of all the properties and the changes
are available in the documentation.   In this tutorial, you will customize the CheckBox component so
that the check mark is now red instead of the default black.

Step 1: Open “dev_Tutorial3.fla”

ACTIONS

a) Open “dev_Tutorial3.fla” by going to “File > Open…” and then navigating to “Tutorial>
Developer > dev_Tutorial3.fla”

Step 2: Open Symbol From Library

ACTIONS

a) If the Library panel is not open, open it by going to “Window > Library”. In the Library panel,
navigate to the symbol named “fcb_check” located in “Flash UI Components > Component
Skins > FCheckBox Skins”.
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b) Go into edit symbol mode by double-clicking the “Movie Clip” icon, , next to the name of the
symbol, “fcb_check”. On your stage, verify that you have the check mark as seen below.

NOTE: If you would like to view the check in more detail, you can change the magnification of
the movie from the drop-down menu on the upper right of the application.

Step 3: Modify Symbol

ACTIONS

a) Verify that you have the Arrow tool active. If it is not active, click the “Arrow Tool” icon, , in
the tool bar. Next, click the check mark to select it.

If the Properties inspector is not open, open it by going to “Window > Properties”. In the
Properties inspector, select “Tint” from the “Color” drop-down menu. Next, click the “Color

Picker” icon,  and select an orange from the palette or enter “#FF6600” in the text field.
Next, enter “100%” in the percent text field.
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b) Save the file by going to “File > Save”.

Step 3: View Modified CheckBox

ACTIONS

a) To view the modified CheckBox, go to “Control > Test Movie”.

b) Click the “NEW RENTAL” tab to navigate to the New Rental section.

c) Click one of the CheckBoxes in the middle of the stage in the “Accessories” section and verify
that the CheckBox is orange.

d) Close the test movie mode.

e) Close the file.
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Developer Tutorial 4: Add ComboBox Component
In the following steps you will use the ComboBox Flash component. The ComboBox component lets
you add scrollable single-selection menus to Macromedia Flash documents with a minimum level of
ActionScript. When a user interacts with a component a small amount of ActionScript is executed.
This is called a change handler. In this example, when the selection is changed using the ComboBox a
predefined handler will be called. The handler is a function that sets the search criteria. The result
being, when a user clicks the “Search” button, the proper criteria will be searched.

Step 1: Open “dev_Tutorial4.fla”

ACTIONS

a) Open “dev_Tutorial4.fla” by going to “File > Open…” and then navigating to “Tutorial>
Developer > dev_Tutorial4.fla”

Step 2: Add the ComboBox Flash UI Component

ACTIONS

a) Verify that you have the Arrow tool active. If it is not active, click the “Arrow Tool” icon, , in
the tool bar. Next, double-click the “Search” panel, located on the upper left of the stage, to
“Edit in Place”.
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g) Verify that the layer “ComboBox” is selected by going to the timeline and checking that the
layer is highlighted. If it is not selected, click on the title area of the layer to select it.

h) If the Library panel is not open, open it by going to “Window > Library”. In the Library panel,
navigate to the symbol named “ComboBox” located in “Flash UI Components”.

b) From the Library panel, drag and drop the symbol, “ComboBox”, so it is located at the top of
the search panel.

c) If the Properties inspector is not open, open it by going to “Window > Properties”. In the
Properties inspector, name the ComboBox, “cbSearch”, by entering “cbSearch” in the field
with the value “<Instance Name>”. In the “Width” field, enter “135”.
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d) Open the frame actions for frame one of the layer, “ComboBox”, by first clicking on frame one
of the layer, “ComboBox”. If the Actions panel is not open, open it by going to “Window >
Actions”.

After opening the Actions panel, it should look similar to the following:

e) In the Script pane of the Actions panel, add a new line and enter
“cbSearch.setChangeHandler(”. In the code hint that appears,

, click the arrow to navigate through additional
syntax hints. Complete the line by entering “"setSearch");”

NOTE: To view your preferences for the ActionScript editor, click the pop-up menu icon, ,
in the upper right of the Actions panel and select “Preferences”.

f) After adding the above statement, your ActionScript should look like the following:

NOTE: The ActionScript added above assigns the handler, “setSearch”, to the ComboBox.
“setSearch” sets the search criteria as a user changes the menu selection.

g) Save the file by going to “File > Save”.

Step 3: View ComboBox

ACTIONS

a) To view the ComboBox, go to “Control > Test Movie”.

b) In the search panel, select “Customer ID” from the ComboBox. Next, enter a search string,
then click “Search”. After clicking “Search”, you will get an error message.
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c) Select “Name” from the ComboBox menu. Next, enter “rich” for a search string, then click
“Search”. After clicking “Search”, you will see results for your search.

d) Close the test movie mode.

e) Close the file.
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Developer Tutorial 5: Breakpoint
In the following steps, you will add a breakpoint to the ActionScript and then test the movie in debug
movie mode. A breakpoint allows you to stop a movie running in the Flash Player at a specific line of
ActionScript. You can use breakpoints to test possible trouble spots in your code. For example, if
you've written a set of if..else if statements and can't determine which one is executing, you can
add a breakpoint before the statements and step through them one by one in the Debugger.

Step 1: Open “dev_Tutorial5.fla”

ACTIONS

a) Open “dev_Tutorial5.fla” by going to “File > Open…” and then navigating to “Tutorial>
Developer > dev_Tutorial5.fla”

Step 2: Open “dev_Tutorial5.fla”

ACTIONS

a) Open the frame actions for frame one of the layer, “functions”, by first clicking on frame one of
the layer, “functions”. If the Actions panel is not open, open it by going to “Window > Actions”.

After opening the Actions panel, it should look similar to the following:
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b) In the Script pane of the Actions panel, position your cursor on line twenty, then click the

“Debug Options” icon, , and select “Set Breakpoint”.

After setting a breakpoint you will have a red dot on line twenty in the line gutter.

c) Test the movie in debug mode, by going to “Control > Debug Movie”.

In debug movie mode, the Debugger panel will appear and the Flash Player will be paused.

Click the “Continue” icon, , to play the movie. After clicking “Continue”, the “Output” panel
will appear. You can minimize the “Output” panel by double clicking the title bar of it.

d) While you are still in debug movie mode, enter “rich” for a search string, then click “Search”.

After clicking “Search”, your Debugger panel should look similar to the following:

Since a breakpoint was set a line 11, the debugger will pause the movie once it reaches this
breakpoint.

e) Click the “Step Over” icon, , to advance the Debugger over a line of code.

f) Click the “Continue” icon, , to resume playing the movie.
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g) Close the debug movie mode.

h) Close the file.
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THE MACROMEDIA WEB PUBLISHING PRODUCT LINE
The new Macromedia MX product family is designed to enable the next-generation of Internet content
and applications.  Available in 2002, the Macromedia MX product family will introduce new
technologies and build on the leadership of the existing Macromedia product line.

The Macromedia products today empower millions of designers and developers to create the most
usable Internet experiences in the most cost effective way. Our solutions include Macromedia
ColdFusion®, FreeHand®, Fireworks®, Macromedia Flash, Director®, Dreamweaver® and Dreamweaver
UltraDev™.   Macromedia Flash MX works with Macromedia products available today, and will deliver
enhanced performance and integration in the future, as additional MX products are available.

MACROMEDIA COLDFUSION
Macromedia ColdFusion is the fastest way to build and deploy powerful Internet applications. Used by
hundreds of thousands of developers worldwide, ColdFusion makes it easy to quickly develop content
publishing systems, business intelligence solutions, self-service applications, and more.

Macromedia Flash MX developers will find ColdFusion to be both the easiest and the most powerful
server-side environment for their rich applications, and the upcoming release of ColdFusion MX will
provide integration with J2EE and Microsoft .Net application servers.

Macromedia ColdFusion 5 can be used to create Flash MX applications today with its approachability
and rapid development capabilities, its easy yet powerful integration with a broad variety of back-end
systems, and its strong support for XML.

In order for rich applications to be truly compelling, they must be able to exchange data with a wide-
variety of back-end systems.  ColdFusion 5 provides easy, built-in connectivity to a complete set of
back-end systems including all major databases, mail servers, file servers, enterprise directories, and
cross-platform component interfaces.  ColdFusion 5 includes high performance database drivers for
all leading databases and makes it easy to set up data sources in minutes through a simple web-based
interface.  ColdFusion developers can easily send and retrieve messages from email servers, connect
to enterprise directories, and exchange documents with file servers.  ColdFusion also provides
connectivity to existing applications via the COM, CORBA, or EJB component interfaces.

ColdFusion 5 also supports XML-based data exchange with the Flash Player.  By exchanging
structured dynamic data with ColdFusion, Flash MX rich application developers can harness all the
logic processing power and back-end connectivity that ColdFusion 5 provides.  To learn more about
best practices for integration between ColdFusion 5 and Flash MX, see the Macromedia Flash and
ColdFusion Resource Center at
http://www.macromedia.com/software/coldfusion/resources/flash_coldfusion/

While ColdFusion today works with Flash MX, the next major release of ColdFusion, code named
“Neo”, will make it significantly faster and easier to build Flash MX applications.  The version of
ColdFusion will support native integration with the Flash Player, extensive new language features
specifically designed for Flash application development, and a powerful new Java technology-based
architecture that supports stand-alone operation, and deployment on leading Java application servers
such as IBM WebSphere and BEA WebLogic.  The new release of ColdFusion will provide the best
server environment for building Flash MX applications.
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MACROMEDIA DREAMWEAVER
Dreamweaver 4 offers everything you need to create a professional website, whether you prefer to
work with familiar visual layout tools or demand the control of a robust text-editing environment. The
intuitive Macromedia user interface makes it easy to create and manage your site. Instantly create
high-impact Macromedia Flash graphics directly in Dreamweaver, drop in content from Microsoft
Office and easily import Fireworks 4 rollovers, pop-up menus and buttons to create engaging web
experiences.

Dreamweaver UltraDev 4 is the solution for ensuring the presentation quality of professional websites
with dynamic content.  See what a database will generate on your page and change it to look the way
you want it to within the application development environment. Dreamweaver UltraDev 4 includes all
the great features of Dreamweaver 4—such as Macromedia Flash buttons, pop-up menus, layout view
and code reference—along with an optimal design environment for ASP, JSP and CFML sites.
Pioneering a simultaneous split-pane view of design and code, use the tight integration of
Dreamweaver UltraDev and Fireworks to create, edit and optimize web graphics.

The combination of Macromedia Flash and Dreamweaver/Dreamweaver UltraDev lets you easily
create, deploy and maintain engaging and dynamic websites and content.

These tips ensure an easy and successful integration of Macromedia Flash into your Dreamweaver
site.

1. Use Macromedia Flash Buttons
Add Macromedia Flash Buttons for navigation directly in Dreamweaver. Through the Object
palette you can select button styles, enter text and specify an URL destination—all within
Dreamweaver. Create styles in Macromedia Flash or download them from the Dreamweaver
Exchange.

2. Use Macromedia Flash Text
Like Macromedia Flash Buttons, this feature lets you turn type into anti-aliased Macromedia Flash
text. Your viewers’ browsers will display the font, regardless of whether the font is installed on their
computers.

3. Download Custom Objects and Behaviors
The Dreamweaver Exchange offers more than a dozen custom Macromedia Flash objects and
behaviors that let you provide specific options for your Macromedia Flash files in Dreamweaver.

4. Delineate Parameters
When you place a Macromedia Flash file in Dreamweaver, you can delineate any set of
parameters for the file by using the Property Inspector when you select the file on your
Dreamweaver page. If you don't see the option you need in the Inspector, use the Parameters
Button on the lower right of the Inspector to add any parameters and values you need.

5. Dynamically Pass Name/Value Pairs
Macromedia Flash lets you dynamically pass name/value pairs to a movie by passing them
through the URL loading the movie. For example, you could use this technique to create a movie
that’s used as the navigational element for an HTML site. The variables passed to the movie would
tell the Macromedia Flash navigation movie where the user was in the site, and thus, which menu
sections to highlight.

6. Turn off HTML Rewriting for Special Characters
If you’re using special characters in your URLs to access Macromedia Flash, you can prevent
Dreamweaver from converting them to URL-encoded strings. Just set the Edit/Preferences/Code
Rewriting to not Encode Special Characters in URLs using percent.
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7. Use the JavaScript Macromedia Flash Integration Kit
Available from the Dreamweaver Exchange, this kit provides some essential functions:

• Macromedia Flash Player Controls: Provides VCR-like controls to Macromedia Flash
animations. Using Dreamweaver Behaviors lets you easily add play, stop, fast-forward,
rewind and zoom controls to any HTML object on the page.

• Advanced Form Validations: Use Dreamweaver to add 18 prewritten client-side form
validations to your Macromedia Flash forms.

• Browser Scripts for Macromedia Flash: Easily reference a library of common JavaScript in
Macromedia Flash ActionScript. Browser scripts for Macromedia Flash provide
encapsulated JavaScript for working with cookies, interacting with HTML forms, opening
new windows and controlling images.

• Macromedia Flash Deployment Kit: This comprehensive tool set lets you consistently and
seamlessly deploy Macromedia Flash websites. Tools include examples, scripts, templates
and step-by-step instructions for implementing Macromedia Flash Player detection on any
website.

• Macromedia Flash Dispatcher Behavior: This detection tool, included in the Macromedia
Flash Deployment Kit, comprises several files that together detect whether a suitable
version of the Macromedia Flash Player is installed in a user's browser. You can then direct
the user to the appropriate content based on that information.

8. Preview Macromedia Flash files in Dreamweaver
Play Macromedia Flash files in Dreamweaver as you author them. The Play/Stop button on the
Macromedia Flash Property Inspector lets you preview the Macromedia Flash object in the
Dreamweaver document window at authoring time. Click the green Play button to see the object in
Play mode; click the red Stop button to stop the movie and edit the object.

9. Review Flash files using Control Shockwave or Macromedia Flash Action
Use the Control Shockwave or Macromedia Flash Action to play, stop, rewind or go to a frame in a
Macromedia Flash movie. To apply the behavior, simply select an anchor or an image, and then
select the Control Shockwave or Macromedia Flash behavior from the Behaviors palette.

For more information on the integration between Macromedia Flash and Dreamweaver, please see
http://www.macromedia.com/software/flash/resources/integration/
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MACROMEDIA FREEHAND

Vector Graphics for Print and the Web

The Macromedia Flash/FreeHand solution is designed to create beautiful printed materials and high-
impact web experiences with minimal effort. FreeHand and Macromedia Flash give you powerful,
cross-media publishing tools to effectively convey your creative vision and communications.

Illustrate in FreeHand
Storyboarding a Macromedia Flash site is an integral part of the design process that only FreeHand
makes possible through its tight integration with Macromedia Flash and broad range of creative
features. While FreeHand provides all of the traditional Bézier tools users expect in a professional
drawing package, it has five essential features that expand the creative relationship with Macromedia
Flash:

1. Vector Transparency lets you create beautiful effects with transparent objects in FreeHand
that print reliably and transfer to Macromedia Flash as transparent objects. Now you can
maintain the integrity of the original printed artwork—and avoid the extra effort of creating the
transparency in Macromedia Flash.

2. Release to Layers quickly creates four different types of animations from blends, text and
groups on any FreeHand layer; these can be used to create Macromedia Flash animations.
Releasing a blend to layers moves the individual blend steps to individual layers to create a
frame-by-frame animation of the blend. Releasing text to layers moves each character to a
separate layer. Releasing a group releases each object to a new layer based on its stacking
order.

3. Macromedia Symbol Library lets you store frequently used images, animations and buttons
in a symbol library similar to the Macromedia Flash Library. If you modify a library symbol, it will
automatically update all the instances in the file, just as in Macromedia Flash. If you import or
copy FreeHand files into Macromedia Flash MX, all of the original symbols from the FreeHand
symbol library are retained. This expedites workflow while optimizing the file size of the
Macromedia Flash movie.

4. Flash Anti-Alias Display gives you a preview of how your illustrations and designs will look
when imported into Macromedia Flash. In fact, FreeHand uses the same underlying
Macromedia Flash anti-alias display engine for this mode.

5. Perspective Grids offer limitless creative possibilities for creating and importing animated or
static 3D vector graphics directly into Macromedia Flash. Previously, designers had to draw
their own grids on background layers and then draw their perspective objects on top of them,
hiding the layers before final output.

Design with FreeHand
FreeHand is the ideal place to begin producing a Macromedia Flash site, thanks to its professional
illustration tools and strong production capabilities, such as multiple pages, styles and Graphics Find
and Replace.

1. Multiple pages in FreeHand provide flexibility:

• Storyboard an entire Macromedia Flash site

• Create a design-intensive, multi-page brochure and reuse it in Macromedia Flash

• Experiment with different looks for scenes

2. Styles for text and graphics let you make lightning-fast changes

3. Graphics Find and Replace searches graphics and text in a document and makes quick
changes based on your criteria
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Communicate with FreeHand

FreeHand supports numerous output formats across several types of media, letting you present it
to as many people as possible.

1. Output a FreeHand storyboard as an interactive Macromedia Flash file, then e-mail it to a
client or use it as part of a screen-based presentation:

• Use the FreeHand URL Editor to create page links to add basic interactivity to your
Macromedia Flash file when exported from FreeHand

• Transparent objects in FreeHand retain transparency in Macromedia Flash

• Repeated elements are intelligently converted to symbols to keep files small

• FreeHand layers and pages can be converted into frame-by-frame animations

2. Design print layouts with FreeHand for use with Macromedia Flash Player to create web-
native print applications:

• Create print documents, export them as Macromedia Flash with the “high-quality print”
option enabled, and then use them as part of your Macromedia Flash site

3. Output high-quality PostScript print materials:

• Print materials and easily adapt them for the web with Macromedia Flash

• Print storyboards of Macromedia Flash sites

• Create professional print presentations from FreeHand and use in Macromedia Flash after
client approval

4. Import your FreeHand work into Macromedia Flash without missing a beat:

• Pages can be mapped to scenes or frames

• Layers are maintained or can be mapped to frames

• Named symbols and instances are maintained to keep files organized and small

• Transparent lenses convert to alpha color transparencies in Macromedia Flash
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MACROMEDIA FIREWORKS

Efficient Web Graphics Production

Macromedia Fireworks brings efficiency to web graphics production. Quickly create buttons,
animations and page comps. Everything remains editable, including files from leading graphics
applications. Save production time with the History panel, step-by-step button maker and the Library.
Only Fireworks lets you script the entire application to automate workflow.

Macromedia Flash MX and Fireworks 4 give Macromedia Flash developers and designers a roundtrip
workflow between their bitmap production tool environment and Macromedia Flash.

While Fireworks exports HTML customized for many popular HTML editors, the tight integration
between Macromedia Flash and Fireworks makes it the ideal production tool for combining optimized
bitmap graphics into vector-based Flash websites.

The following Macromedia Flash MX features make it even easier for customers to combine the power
of the two tools.

• Launch and Edit with Fireworks - From the context menu of a bitmap stored in the Flash
Library, you can directly launch and edit any bitmap within Fireworks. Once you edit the
bitmap, saving it automatically updates the library item in Macromedia Flash. You can edit the
graphic or the original source image.

• Import Fireworks PNG Files - Directly import native Fireworks PNG files into Macromedia
Flash MX. Vectors shapes, lines, layers and guides remain editable. You can also bring in
flattened bitmaps. Once you import the files into Macromedia Flash MX, you can add
sophisticated interactivity, effects and animation. Import Photoshop® .PSD files into Fireworks
and save as layered PNG files for importing into Macromedia Flash.

• Export Flash Movies from Fireworks - Fireworks supports exporting native Macromedia
Flash movies (SWF), so you can publish to Macromedia Flash directly from Fireworks. Create
animated ad banners and export them to Macromedia Flash movies for smaller, compact files.
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MACROMEDIA DIRECTOR 8.5 SHOCKWAVE STUDIO

Director integrates the most comprehensive array of multimedia elements to create fast-rendering,
high-performance, media-rich applications. Director combines interactive 2D and 3D animation,
RealVideo, RealAudio, Flash, MP3, QuickTime, bitmaps, vectors, text, and more to create streaming,
interactive, multiuser content that is easy to deploy online or on fixed media. Director 8.5 Shockwave
Studio now includes Intel Internet 3D Graphics software.  This combination, for the first time ever,
provides an easy way for developers to deliver scalable, bandwidth-friendly, interactive three-
dimensional web content to the web mainstream.

Using Macromedia Flash and Director together

Director content can be used within Flash sites, and Macromedia Flash content can be imported into
Director.  Together, Director and Macromedia Flash enable developers to create powerful web
experiences:

Macromedia Director creates highly extensible interactive multimedia content, including advanced 3D
games, merchandizing, and learning applications deployable across multiple mediums.

Flash developers often add Director to their toolkits in order to:

• Add interactive 3D to web content - Well-executed, interactive 3D content makes a
wide range of applications (including games, e-merchandising, online learning, and
product demonstrations) more compelling and effective. For example, online retail sites
that have used 3D demos of their products have shown increased sales and reduced
returns. 3D technologies can also make online entertainment more fun and heighten the
sense of realism. In addition, web 3D offers new opportunities for traditional game
vendors, who can create browser-based versions of their existing games, develop new
games exclusively for the web, and show 3D trailers or demos on the web.

• Customize applications with Xtras - Director has an extensible plug-in architecture that
enables developers to add custom features and functionality.  For example, Xtras can be used
to access external input devices such as joysticks, for more exciting gameplay.  File systems
can be accessed to read and write files locally or on a network. Playback of MPEG movies
within Director content is also made possible through the use of Xtras.  With Xtras, the power
of Director is limited only by the imagination of the developer.

• Incorporate streaming RealAudio and RealVideo into applications - With Director 8.5
Shockwave Studio, developers can stream RealAudio and RealVideo as assets in Director
movies.  This content can be fully integrated into Director's audio and video rendering so that
developers can apply all of the controls to this content that are available in Director.  For
instance, developers can use Director's precision sound controls to adjust the panning and
volume in the Real Streaming Media content.  The developer can also apply other effects such
as quad modification and imaging Lingo for special effects never before achievable with
RealVideo.

For more information on the integration between Macromedia Flash and Director, please see
http://www.macromedia.com/software/director/resources/integration/


