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Installing Scotland Yard for the First Time

When installing SCOTLAND YARD for the first time, you should install SCOTLAND YARD to a network 
drive (and directory).    Make sure that all users will have access to this directory. 

After installing SCOTLAND YARD to the network, SCOTLAND YARD is ready to run.    To install 
SCOTLAND YARD for other users, you simply need to create a shortcut on their desktop to the 
SCOTLAND.EXE and/or SIGN_IN.EXE. 

Advanced Features:

Scotland Yard allows companies to customize the Status Descriptions and the Icons that represent each 
status description.    For more information on changing the Status Descriptions, check out the “Status 
Description Setup” page.

DO NOT run the SETUP.EXE again on other computers.    Doing so will re-install the data files that came 
with SCOTLAND YARD.    Employee and/or department information you had previously entered would be 
replaced with the sample data files!

It is a good idea to put the SCOTLAND.EXE or the SIGN_IN.EXE shortcut in the Startup Folder 
for each user. 



Scotland Yard File Descriptions

SIGN_IN.EXE: This is the program that lets a user Sign In/Out and check their messages.

SCOTLAND.EXE:    This is the program that lets a user Sign In/Out, check their messages, and run the 
Employee Detective. The Employee Detective lets the user see the status of all users, 
change the status of any user, and create phone messages for any user.

EMP.DBF The Employee Data File.

EMP.CDX The Employee Index Data File.

DEPT.DBF The Department Data File.

DEPT.CDX The Department Index Data File.

MESSAGES.DBF The Messages Data Files
MESSAGES.FPT

MESSAGES.CDX The Messages Index Data File



Setting up Scotland Yard

Department Set-up
Employee Set-upStatus Description Set-up



Department setup

To add, edit, or delete a department, Select the Department Setup command from the File menu.

Add a department.    Select the Add Button, type in the Department Name and then select the Ok button

Edit a department.    Select the department to edit by clicking on the department name.    Then select the 
Edit Button, type in the changes and then select the Ok button

Delete a department.    Before deleting a department, make sure that there are no employees assigned 
with this department.    If you attempt to delete a department and there are employees assigned to that 
department, you will receive an error. 

To delete a department, select the department to delete by clicking on the department name, then select 
the Delete Button.



Employee setup

To add, edit, or delete an employee, Select the Employee Setup command from the File menu.

Before adding employees, make sure that you have already added departments in the Department Setup 
screen.

Add an employee.    Select the Add Button, type in the following information and then press the Ok button.

Employee Name.    We recommend you enter the name in the format: Last Name, First Name.

Department.    Select the department by clicking in the department field box. If you want to add an 
additional department, you need to go into the Department Setup screen.

Phone Number:    Enter the employee’s Phone Number or Extension Number.

Password:    Enter the employee’s password.    The password can contain alpha characters and numeric 
characters up to 12 characters in length. 

Security Level:    You can assign a security level to each employee.    Security levels are used for 
deciding what each employee can do in Scotland Yard.    There are 3 security levels.

Level 1:    No Limitations.    (Administrative) 

This level gives the employee unlimited access to everything in Scotland Yard.

Level 2:    Emp. Detective Read/Write, No Emp. or Dept. file access.

This level gives the employee the rights to view and change all employees status in the 
Employee Detective, but can not get into the Employee File Management or Department 
File Management windows.

Level 3:    Emp. Detective Read Only, No. Emp. or Dept. file access.

This level gives the employee the rights to “view only” all employee status in Employee 
Detective.    This employee also does not have access to the Employee or Department 
File Management windows.

Edit the Employee information.    Select the employee to edit by clicking on the employee name.    Then 
select the Edit Button, type in the changes and then select the Ok button

Delete a Employee.    To delete an employee, select the employee to delete by clicking on the Employee’s 
name, then select the Delete Button.



Status Description Set-up

Scotland Yard allows companies to customize the Status Descriptions that are used by their companies.    
You can edit the existing status description or add your own to fit your companies needs.    For Instance, 
Law Firms can add a status description of “In Court”.    The icons that are used to represent each status 
description can also be changed in the set-up screen.      To change or add Status Descriptions, select the 
Status Description Setup command from the File menu.

On the left side of the screen is the list of Status Descriptions.    On the right hand side of the screen is the 
icon representing the Status Description and the behavioral settings.    The behavioral settings allow you 
to customize the default behavior for each Status Description (i.e., “At Lunch” has an Expected Return 
Time of “1 Hour”).

Status Descriptions:    The listing of status descriptions that will appear in the Sign In/Out screen and 
Employee Detective.

Displayed Icon:    The icon to be displayed when the Status Description is selected.    To change the Icon, 
click on the up/down arrows to toggle through the available icons that can be used.

Enter the defaults for the Status Description

Expected Return Time
The expected return time can be a specific time (i.e.    8:00am) or a calculated time (i.e. 45 minutes from 
now).    To enter an expected return time, click on the “Specific Time” or “Calculated Time” radio button 
and then select a time from the list.

Expected Return Date
Select the Expected Return Date by choosing one the return dates from the list.

Button:    Reload System Defaults:      Press this button if you wish to reload the system defaults for 
Status Descriptions and the standard behaviors of these descriptions.



Command Line Parameters

Scotland Yard can be run with command line parameters to automatically pass in the user’s password so 
they do not have to enter it every day.      To pass in a password with Scotland Yard, add the users name 
in quotes to the shortcut properties in Windows 95.      (This works with the registered versions of 
SCOTLAND.EXE and SIGN_IN.EXE)

Example:      Target:      F:\APPS\SCOTLAND\SIGN_IN.EXE    “KATIE”

Scotland Yard will also look for the “User” environment variable for the user’s password.    If a command 
line password isn’t entered and there is no “User” environment variable, then Scotland Yard will prompt 
the user to enter a password. 

It is important to optimize and reindex the files periodically.    We recommend that you reindex the files at 
least once a month. To help facilitate this, we have added “AUTOINDEX” as a command line parameter 
to SCOTLAND.EXE that can be run with the Microsoft System Agent or any other scheduling program. 

Example:    Target:    F:\APPS\SCOTLAND\SCOTLAND.EXE    “AUTOINDEX” 

will cause Scotland Yard to reindex and optimize all files - without user assistance.      Most of our 
customers run Scotland Yard with the “AUTOINDEX” feature every Wednesday Night or Friday Night 
after all the other users have been logged off.
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Changing your status

In the Sign In/Out screen, you can change your status by clicking on one of the radio button options in the 
“Where are you” section.    After selecting a new status (and after you select the Ok button), your program 
Icon will display your current status.    Plus, anyone running the Employee Detective will see that your 
status has changed.

When some status codes are selected, you will see that the expected return time and return date will be 
automatically entered for you.    For instance, if you select that you are “At Lunch”, the expected return 
time will automatically add 1 hour to the current time.    If the expected time is incorrect, you can re-enter 
the new expected return time.



Changing your expected return time

In the Sign In/Out screen, you can change your expected return time 2 ways. You can enter the expected 
return time manually, or you can use the “Quick-Set Return Times” section.

Enter the expected return time manually.    To enter the expected return time manually,    enter the Hour, 
Minute, and Am/Pm in the designated boxes, or you can click on each box an get a pop-up window with 
valid choices in which you can choose your selection.

Quick-Set Return Times.    The quick set section can be used to quickly set the expected return time.    
There are 6 selections to choose from.    Selecting one of the items will automatically add the selected 
item minutes to the current time.      Example: if you select the 30 Minutes choice, the expected return time 
will be the current time + 30 minutes.    The Quick-Set Return Time can be very helpful to quickly enter 
your expected return time. 



Changing your return date

The return date is the date in which you will be returning.    When you go to lunch, or go into a meeting, 
the Return Date will default to today.    The return date is helpful when you are going on a Vacation or 
when you may be Out Sick for a couple of days.    To change your return date, type in the date in the 
format:    Month/Day/Year.    Example:    10/28/97

Pop-up Calendar:    To select your return date by using the pop-up calendar, double left click on the date 
field to view the calendar window.    Select the date from the calendar by double clicking on the new date. 

You also can use the numeric key pad “+” key or “-“ key to quickly add or subtract days to currently 
displayed date in the Return Date field.



Comments

Enter comments in the Sign In/Out screen if you want to give additional information about your 
whereabouts or other information that may be useful.      Examples:    If you are in a meeting, you might put 
in the comments who you are meeting with.    If you are Out running errands, you can put in the 
comments section where you are going and how you can be reached.



Viewing Messages

To view your messages, select the Message Icon (found in the New Phone Messages Box in the Sign 
In/Out Screen) or for users running the Scotland Yard EXE, select the Messages command from the File 
menu. 

When viewing the messages, you can see the messages in 2 displays.    The first way to view the 
messages is in a List View where you can see an Icon representing the message, when the message 
was taken, the name and company of the person who left the message. The second way to view the 
messages is in the Icon View where you can see the Icon representing the message and the date of the 
message.    You can switch back and forth between the different views by selecting Icon View or List View 
commands from the View menu, or    you can also select the different views by selecting the appropriate 
buttons on the toolbar.

TIP!    When viewing messages in the list view format, you can click on any one of the column names, and 
the messages will be sorted on that column.    If you click on the column a second time, the column in sort 
in reverse order.

NOTE!    The message icon will display in RED if the message is urgent!

Viewing new messages:    To see your new messages, click the New Messages folder. After a message 
is read, the program will ask if you want to save the message in your Save Messages folder, or delete the 
message.

Viewing saved messages:    To view the saved messages, select the Saved Messages folder.    
Messages that have been read and saved are put into this folder. 
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Viewing employees in the Employee Detective

To see a list of employees and their current whereabouts, select the Employee Detective command from 
the File menu (or select the Employee Detective button from the toolbar). 

When the Employee Detective is selected, you will see a list of all employees.    You can also choose to 
see the employees by department or by their current status. 

When viewing the employees, you can see the employees in 2 displays.    The first way to view the 
employees is in a List View where you can see an Icon representing the employees status, the 
employee’s name, status description, return time and date, phone extension, and comments. The second 
way to view the employees is in the Icon View where you can see the Icon representing the employees 
status and the employees name.    You can switch back and forth between the different views by selecting 
Icon View or List View commands from the View menu, or    you can also select the different views by 
selecting the appropriate buttons on the toolbar.

TIP!    When viewing employees in the list view format, you can click on any one of the column names, 
and the Employee Detective will do a sort on that column.    If you click on the column a second time, the 
Employee Detective will sort the column in reverse order.

TIP!    The Tree View/List View window is a re-sizable window.    If you want to see more employees on 
the screen, you can click on the vertical bar separating the Tree View and List View window and re-size 
the window by moving the vertical to the left or to the right.

Viewing all employees:    To see all employees, click on the All Employees folder.

Viewing employees by department:    To view the employees by department, select the View employees 
by department folder, then select the department name to wish to see.

Viewing employees by status:    To view the employees by status, select the View employees by status 
folder, then select the status name to wish to see.



View/Edit employee status
To view or edit an employee’s status, select the employee by double clicking on the employee’s name, or 
right click once on the employee’s name and select View/Edit Employee Status from the pop-up menu 
that will be displayed.    Either way, a window will be displayed with the employee’s name, current status, 
return date and time, and comments that employee may have added.    To change the current status of 
the employee, click on the Change Status button.    This will display the Sign In/Out window with the 
employee’s name.    Use the Sign In/Out window to change the employee’s status.    For information on 
the Sign In/Out window, see the Sign In/Out help section.

New!
In the Employee Detective, you can now quickly change multiple employee's
status.    Using the Windows 95/NT Explorer methods (Ctrl-Left Click and Shift-Left Click), you can 
highlight many employees at once.    After the employees are highlighted, simply right click to get the new 
"pop-up" menu.    You can quickly change the employees to in, out, or display the sign in/out screen to 
change their status.



Create phone message

You can create phone messages if you are running the Scotland Yard program.    If you are running the 
smaller, Sign_In.exe, then you do not have the ability to create phone messages.

To create phone messages, you need to be in the Employee Detective.    From the Employee Detective 
window, right click once on the employee’s name and select Create Phone Message from the pop-up 
menu that will be displayed.

The messages window will be displayed.    Enter the Name, Company, Phone Number, and message from 
the person who is leaving the message.    The Date and Time are automatically entered for you, so you do 
not need to enter these.    You can also select any one of the 6 standard message descriptions ( Urgent, 
Returned Call, Call Back, etc.).    After entering the message information, press the Ok button to save the 
message.    The message will instantly be available for the employee.



Phone Messages

Creating Messages in Scotland Yard
Viewing Messages



Technical Support

Scotland Yard includes an easy-to-use on-line reference system that 
provides information about its functions and features.    Please refer to 
Scotland Yard’s help system before contacting technical support.    In many 
cases you will find that your questions are covered in this help system. 

If Scotland Yard stops working as expected, you may find that reindexing
the files will fix your problem. 

You can get help in several ways:

Open the Help system to the contents section by choosing Index from the 
Scotland Yard Help menu or by pressing F1.

Double-click on the Scotland Yard Help file icon in the Scotland Yard’s 
program group.

Yale & Associates, Inc.    Contact Information:

Phone Support:                (619) 447-9984

(Monday through Friday 9 a.m. to 4 p.m. PST)

Email Support:                    scott@yale-software.com

Yale & Associates, Inc.    Mailing Address:

Yale & Associates, Inc.

PO Box 2536

La Mesa, CA    91943



How to order

When you register Scotland Yard for    $99.00, you will receive a Registration Number that you can use to 
register your copy of Scotland Yard.        We accept Visa, Mastercard, American Express and company 
checks.    Call us at 619-447-9984 to process your order.

We offer secure online ordering of Scotland Yard on our web site.    Please visit our site and order 
your copy today! 

http://www.yale-software.com

After you place your order online, you instantly receive your registration number and can start 
using Scotland Yard.




