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PowerQuest® End User License Agreement

IMPORTANT: Read this before using your copy of PowerQuest software.

This document is a legal agreement between you (an individual or business) and PowerQuest Corporation (PowerQuest). Use of the 
software indicates your acceptance of these terms. As used in this License Agreement, the term "Software" means the software 
included on the CD or disk media provided with this License Agreement. The term "Software" does not include any software that is 
covered by a separate license offered or granted by a person other than PowerQuest.

IF YOU DO NOT AGREE TO THESE TERMS AND CONDITIONS, EITHER DESTROY OR RETURN, INTACT, THE 
SOFTWARE PACKAGE, CONTAINING THE CD OR DISK MEDIA, TOGETHER WITH THE OTHER COMPONENTS OF 
THE PRODUCT TO THE PLACE OF PURCHASE FOR A REFUND OF THE PURCHASE PRICE.

1. PROPRIETARY RIGHTS. The Software and any accompanying documentation are the proprietary products of PowerQuest or 
its licensors and are protected under national laws and international treaty provisions. Ownership of the Software and all copies, 
modifications, translations, and merged portions thereof shall at all times remain with PowerQuest or its licensors.

2. GRANT OF LICENSE. The Software and accompanying documentation are being licensed to you, which means you have the 
right to use the Software only in accordance with this License Agreement. The Software is considered in use on a computer when it 
is loaded into temporary memory or installed into permanent memory. This License may not be assigned or otherwise transferred 
without prior written consent from PowerQuest, and any unauthorized transfer is null and void.

You are authorized to use ONLY a single copy of the Software on the number of computers for which you have purchased a license 
as indicated on the accompanying license certificate. Each permitted copy of the Software may be used only in connection with a 
single computer owned or leased by you. If the Software is made available on a network, it may be accessed only by ONE specific 
computer. Once the Software has been accessed by ONE specific computer it may not be used on any additional computers without 
purchasing additional licenses. All copies of the Software must include the copyright, trademark, and patent notices.

This license is personal to you. You may not sublicense, lease, sell, or otherwise transfer the Software or any of the accompanying 
documentation to any other person. You may use the Software only for your own personal use if you are an individual, or for your 
own internal business purposes if you are a business. If you are a service bureau, integrator, value added reseller, or other type of 
service provider and wish to use this software on your clients' computers, you must purchase a Configuration License.

BACKUP COPY. In addition to any copies authorized under this license agreement, you may make a single copy of the Software 
solely for backup purposes.

UPDATES AND SUPPORT. You are entitled to receive technical support as outlined in the Software documentation. You are 
entitled to receive Software updates (updates shall include any patches or bug fixes that PowerQuest makes generally available at 
www.powerquest.com) in accordance with PowerQuest policies as announced from time to time on terms comparable to those 
offered to other users of the Software under similar licenses.

TERM. This license is effective from your date of purchase and shall remain in force until terminated. You may terminate the 
license and this License Agreement at any time by destroying the Software and the accompanying documentation, together with all 
copies in any form.

3. NONPERMITTED USES. Without the express prior written permission of PowerQuest, you may not (a) use, copy, modify, 
alter or transfer, electronically or otherwise, the Software or documentation except as expressly permitted in this License 
Agreement, or (b) translate, reverse program, disassemble, decompile, or otherwise reverse engineer the Software.

4. EXPORT CONTROLS. Certain uses of the Software by you may be subject to restrictions under U.S. regulations relating to 
exports and ultimate end uses of computer software. You agree to fully comply with all applicable U.S. laws and regulations, 
including but not limited to the Export Administration Act of 1979 as amended from time to time and any regulations promulgated 
thereunder.

5. U.S. GOVERNMENT RESTRICTED RIGHTS. If you are acquiring the Software on behalf of any unit or agency of the 
United States Government, the following provision applies:  It is acknowledged that the Software and the documentation were 
developed at private expense and that no part is in the public domain and that the Software and documentation are provided with 
RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) 
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of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/Manufacturer is 
PowerQuest Corporation/P.O. Box 1911/Orem, UT 84059-1911/U.S.A.

6. LIMITED WARRANTY. (a) PowerQuest warrants to you, the original end user, (i) that the Software, other than third-party 
software, will perform substantially in accordance with the accompanying documentation and (ii) that the Software is properly 
recorded on the disk media. This Limited Warranty extends for ninety (90) days from the date of purchase. PowerQuest does not 
warrant any third-party software that is provided with the Software, but PowerQuest agrees to pass on to you any warranties of the 
owner or licensor to the extent permitted by the owner or licensor. (b) This Limited Warranty does not apply to any Software that 
has been altered, damaged, abused, mis-applied, or used other than in accordance with this license and any instructions included on 
the Software and the accompanying documentation. (c) PowerQuest's entire liability and your exclusive remedy under this Limited 
Warranty shall be the repair or replacement of any Software that fails to conform to this Limited Warranty or, at PowerQuest's 
option, return of the price paid for the Software. PowerQuest shall have no liability under this Limited Warranty unless the 
Software is returned to PowerQuest or its authorized representative, with a copy of your receipt, within the warranty period. Any 
replacement Software will be warranted for the remainder of the original warranty period or 30 days, whichever is longer. (d) THIS 
WARRANTY IS IN LIEU OF AND EXCLUDES ALL OTHER WARRANTIES NOT EXPRESSLY SET FORTH HEREIN, 
WHETHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT, OR WARRANTIES ARISING FROM USAGE OF 
TRADE OR COURSE OF DEALING. (e) THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS; YOU MAY HAVE 
OTHERS WHICH VARY FROM STATE TO STATE. (f) Your failure to return the enclosed registration card or complete the 
electronic registration included with the Software may result in PowerQuest's inability to provide you with updates to the Software, 
and you assume the entire risk of performance and result in such an event.

7. LIMITATION OF LIABILITY. IN NO EVENT SHALL POWERQUEST'S LIABILITY RELATED TO ANY OF THE 
SOFTWARE EXCEED THE LICENSE FEES ACTUALLY PAID BY YOU FOR THE SOFTWARE. EXCEPT FOR A RETURN 
OF THE PURCHASE PRICE UNDER THE CIRCUMSTANCES PROVIDED UNDER THE LIMITED WARRANTY, 
NEITHER POWERQUEST NOR ITS SUPPLIERS SHALL IN ANY EVENT BE LIABLE FOR ANY DAMAGES 
WHATSOEVER ARISING OUT OF OR RELATED TO THE USE OF OR INABILITY TO USE THE SOFTWARE, 
INCLUDING BUT NOT LIMITED TO DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, 
AND DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, 
OR OTHER PECUNIARY LOSS, EVEN IF POWERQUEST CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY 
OF SUCH DAMAGES, WHETHER SUCH LIABILITY IS BASED ON CONTRACT, TORT, WARRANTY, OR ANY OTHER 
LEGAL OR EQUITABLE GROUNDS. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION 
OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO 
YOU.

8. NO WAIVER. Any failure by either party to this agreement to enforce a specific part of the agreement in a specific situation is 
not a waiver of rights under the agreement. The party may still enforce the rest of the agreement in that situation and may still 
enforce some or all of the agreement in other situations.

9. This License Agreement constitutes the entire agreement between you and PowerQuest pertaining to its subject matter. This 
License Agreement is governed by the laws of the State of Utah. Any litigation arising from this license will be pursued only in the 
state or federal courts located in the State of Utah. Even if part of the agreement is held invalid, the rest of the agreement is still 
valid, binding and enforceable.

Should you have any questions concerning this Agreement, or if you desire to contact PowerQuest Corporation for any reason, 
please write: PowerQuest Corporation/P.O. Box 1911/Orem, UT 84059-1911/U.S.A.

© 1994-2001 PowerQuest Corporation. All rights reserved. The Software may be protected by U.S. patents, with other patents 
pending in the U.S.A. and elsewhere. PowerQuest is a registered trademark of PowerQuest Corporation.
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Introduction

What Is Drive Image?

Drive Image is a fast, inexpensive, and complete hard-disk imaging solution. Unlike 
file-by-file copying utilities, Drive Image uses SmartSector® imaging to create an exact 
image of a hard disk or partition.

With Drive Image, you can create and restore a compressed image file of an entire hard 
disk or individual partitions of a hard disk on a network, Jaz, Zip, MO, CD or other 
removable media device. Because Drive Image uses SmartSector imaging, your Windows 
optimizations are preserved when you restore an image. Drive Image provides 
SmartSector imaging support for FAT, FAT32, NTFS, HPFS, Linux Ext2, and Linux Swap 
file systems, and sector-by-sector support for UNIX and NetWare.

Because of operating system conflicts that can result from different hardware 
configurations, Drive Image was not intended to copy or image a hard drive that will be 
used in a system with different hardware configurations.

In addition, the Drive Image CD includes PowerQuest® DataKeeper™. You can use 
DataKeeper to perform secure, automated backups of all your important data to your local 
hard disk, a second partition, a network drive, or removable media. For more information, 
please see “PowerQuest DataKeeper” on page 73.

What’s New in 5.0?
• QuickImage—Simplifies the process for creating and restoring backup images and 

enables you to schedule automatic backups from within Windows.

• CD-R and CD-RW support—Ability to create images to and restore images from 
more IDE, SCSI, and PCMCIA drives. Improved speed for supported drives.

• Large drive support—Ability to image hard disks up to 80 GB in size.

• ImageExplorer—Enhanced ImageExplorer (formerly called Drive Image File Editor) 
for extracting single files or copying image partitions to another PQI file.

• Bootable CD—Ability to boot your computer from the Drive Image product CD.

• VF Editor—A powerful tool to help you build your virtual floppy files.

• Support for Windows XP.

• Performance enhancements—Improved speed for creating and restoring images.
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Drive Image System Requirements

IMPORTANT! Drive Image is not supported for use with servers, including Windows NT 
Server, Windows 2000 Server, and Windows 2000 Advanced Server.

Dynamic disks are not supported. You cannot install Drive Image on a dynamic disk or 
create an image file of a dynamic disk.

If you use Drive Image on a DOS or OS/2 machine, you must run it from rescue disks. See 
“Running Drive Image from Rescue Diskettes” on page 8.

Hardware/Software Requirement

Processor Intel 386SX (Intel 486 or above recommended)

RAM 16 MB (32 MB recommended; 32 MB required for FAT32 or 
NTFS)

3.5-inch diskette drive 3.5-inch diskette drive (DOS-only or OS/2 machines)

CD-ROM drive Any speed; An MM2-compliant IDE, SCSI or SCSI PCMCIA 
CD-R or CD-RW drive for creating images directly to CD

Hard disk free space 26 MB

Operating system Windows 95, Windows 98, Windows Me, Windows NT 3.51 
or 4.0 Workstation, Windows 2000 Professional (with or 
without Service Packs 1 or 2), Windows XP, DOS 5.0, OS/2

Monitor VGA (SVGA recommended)

Pointing device None required (Mouse recommended)
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C H A P T E R1
Getting Started
This chapter includes the following information:

• Installing Drive Image

• Creating Rescue Diskettes under Windows

• Installing on an OS/2 or DOS-Only Computer

• Installing Removable Device Drivers

• QuickImage or Drive Image DOS?

• Before Running Drive Image DOS or QuickImage

• Running QuickImage

• Running Drive Image DOS

• Uninstalling Drive Image

• Getting Online Help
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Installing Drive Image

You can install Drive Image from any of the following operating systems:

• Windows 95/98 
• Windows Me
• Windows NT 4.0 Workstation
• Windows 2000 Professional
• Windows XP

For DOS or OS/2, see “Installing on an OS/2 or DOS-Only Computer” on page 5.

1 Insert the Drive Image CD into your CD-ROM drive.

2 If CD auto-run is enabled, the installation program automatically launches when you 
place the Drive Image CD in your CD-ROM drive. If the CD auto-run is not enabled, 
insert the CD, click Start ➤ Run, then type drive:\AUTORUN (where drive is 
the drive letter of your CD-ROM drive), then click OK.

You will be presented with the following options:

• Install—Install Drive Image, including QuickImage and ImageExplorer, to a local 
hard disk.

• Create Rescue Diskettes—Create a set of diskettes including a bootable floppy 
and a program disk that enable you to run Drive Image from DOS.

• Documentation—Display PDF manuals for Drive Image or Drive Image error 
messages. You can use Adobe Acrobat to view and search PDF manuals.

• Install DataKeeper—Install DataKeeper to your hard disk.

• Select Language—Select the language for the Drive Image software you want to 
install.

• Exit—Exit the installation program.

3 Select the option you want, then follow the on-screen instructions.

4 At the end of the installation process, you will have an opportunity to create rescue 
diskettes.

PowerQuest recommends that you create rescue diskettes. Then if your hard disk becomes 
unbootable or you do not have access to Windows, you can boot your computer and run 
Drive Image from the rescue disks. If you do not create rescue disks during the product 
installation, you can create them later by running the installation program from the Drive 
Image CD.
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You cannot install Drive Image on a dynamic disk. Dynamic disks are not supported.

Drive Image 5.0 will not overwrite previous versions of Drive Image that you have 
installed on your machine.

Creating Rescue Diskettes under Windows

You can create Drive Image rescue diskettes under Windows 95 or later. There are two 
diskettes for Drive Image. The first is a DOS boot diskette. The second includes the Drive 
Image program. If you experience a hard disk failure or are unable to access Windows, 
you can run Drive Image from the rescue disks.

1 Choose the Create Rescue Diskettes option in the Drive Image installation program.

You can also click Start from the Windows taskbar, then click Programs ➤ 

PowerQuest Drive Image 5.0 ➤ Create Rescue Diskettes.

Rescue Diskette Limitations (Windows NT/2000/XP)

On Windows 95, Windows 98, and Windows Me systems, Drive Image uses the operating 
system’s DOS files to build the first rescue disk. On Windows NT/2000/XP systems, Drive 
Image uses Caldera DOS.

When you boot from a rescue disk with Caldera DOS, Drive Image is subject to the 
following limitations:

• Cannot see any partition that crosses or exists past the 1024 cylinder boundary
• Cannot see any partition that resides in an extended partition that crosses or exists past 

the 1024 cylinder boundary

You can avoid these limitations by using a Windows 95/98 startup disk in place of the 
Drive Image bootable diskette (diskette 1 of the 2-diskette set).

Aside from these limitations, the features in Drive Image running from the rescue diskettes 
are the same as those running it from a hard disk.

Installing on an OS/2 or DOS-Only Computer

Because OS/2 and DOS-only computers cannot run the Windows-based installation 
program, you should run the MAKEDISK.BAT file (found on the Drive Image CD in the 
SETUP\OS2DOS directory) to install Drive Image on OS/2 or DOS-only systems.
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This batch file creates two rescue diskettes. The first diskette is a DOS boot diskette. It 
also contains the removable media device drivers. The second diskette includes the Drive 
Image program. You should be aware of the limitations of the rescue diskettes as listed 
above.

Installing Removable Device Drivers

During Setup, Drive Image allows you to install drivers for Iomega and Magneto-Optical 
removable media storage devices.

• To install Iomega drivers, select Iomega drivers during installation.

• To install Magneto-Optical drivers, select MO drivers and then the required drive 
type (ATAPI or SCSI).

For specific information on individual device drivers, contact your manufacturer directly. 
For more information on setting up Iomega and Magneto-Optical drivers, see “Setting Up 
Removable Storage Devices” on page 95.

QuickImage or Drive Image DOS?

There are two ways to create and restore images: using the Windows program QuickImage 
or using Drive Image DOS. Both programs have a graphical user interface.

ImageExplorer and DataKeeper are separate applications and are not run from 
QuickImage or Drive Image DOS.

QuickImage

New to Drive Image 5.0 is a Windows-based interface called QuickImage, which you can 
use to create and restore images. You can also use QuickImage to automate the backing up 
and restoring of specified drives on your computer. With QuickImage you can specify, for 
example, which partitions you want to include in your image file, then define a schedule 
for backing up the specified drives. Drive Image will execute the task automatically; there 
is no need to input the information again and again.

After you have defined what you want in your QuickImage (the partitions, the filename, 
etc.), you can then edit and delete what will be imaged, define advanced options, or even 
create a shortcut on your desktop.
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Drive Image DOS

You should use Drive Image DOS if you want to perform one of the following tasks:

• You want to do a disk to disk operation (for upgrading a hard disk).

• You want to perform partition management tasks, such as creating extended 
partitions, deleting and hiding partitions, or setting the active partition.

• If you regularly change your partition configuration, you will need to use the DOS 
interface to create and restore image files.

You can also use Drive Image DOS to create and restore image files if you do not regularly 
change your partition configuration.

Before Running Drive Image DOS or QuickImage

• Use a disk utility program such as ScanDisk (thorough scan) or Norton’s Disk Doctor 
to identify and repair any errors on your hard disk. Windows NT Workstation, 
Windows 2000, and Windows XP users should run CHKDSK /F.

• Create Drive Image rescue diskettes.

• Disable virus detection in the BIOS before creating an image file. You should also 
turn off any low-level disk utilties, such as incremental backup software (for example, 
GoBack®). If virus protection is enabled, Drive Image may hang or report erroneous 
viruses.

• Check to ensure that the drive where you want to create an image is available under 
DOS. You can see the available drives by clicking Browse at the Name Image File 
screen. You may need to set up removable media or create boot disks to access 
network drives before you can create an image.

• Removable drives (Jaz, Zip, etc.) must be set up as removable devices in the BIOS, or 
Drive Image will not recognize them as removable media and will not enable the 
media spanning feature.

• (Optional) Run a disk defragmenting utility to further optimize your hard drive.

• Verify that each FAT partition containing OS/2 extended attributes has a minimum of 
5 MB of unused space within the partition if it will be resized during the restore 
process.
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Running QuickImage

QuickImage is a Windows-based product and must be run from your hard disk.

1 From the Windows Start menu, click Programs ➤ PowerQuest Drive Image 5.0 ➤ 
QuickImage.

The PowerQuest QuickImage main screen appears.

First, you create a QuickImage definition, which determines which partitions to back 
up, the path and filename for the image file, and other options for the backup you 
want to create. After you create the definition, you can schedule a task to create or 
restore image files.

For information about using QuickImage, see “QuickImage” on page 11.

Running Drive Image DOS

You can run Drive Image DOS from the hard disk or a floppy diskette.

Running Drive Image from a Hard Disk

1 Shut down applications you are running under Windows.

2 Click Start ➤ Programs ➤ PowerQuest Drive Image 5.0 ➤ Drive Image 5.0.

A prompt appears to tell you that all programs will be shut down, so Drive Image can 
run in DOS mode.

3 Click Yes to continue.

You may need to wait a moment before Windows shuts down. Then Drive Image reboots 
using PowerQuest’s Virtual Floppy™ technology, and the Drive Image DOS main screen 
appears.

You may need to modify the virtual floppy to make Drive Image DOS run properly if you 
have a removable media device such as a Zip or Jaz drive. See “Editing the Virtual Floppy 
Disk” on page 92.

Running Drive Image from Rescue Diskettes

1 Insert a bootable diskette (such as the first Drive Image rescue diskette).

To create a boot diskette and a Drive Image floppy (rescue diskettes), see “Installing 
on an OS/2 or DOS-Only Computer” on page 5.
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2 Reboot your machine.

DOS loads and displays an A: prompt.

3 Insert the Drive Image program floppy (Diskette #2 of the Drive Image rescue 
diskette set).

4 Press <Enter>.

Using Drive Image without a Mouse

You can navigate through Drive Image using a mouse, or you can use keyboard 
commands.

Press Alt and the mnemonic (underlined character on the button or menu command) as a 
substitute for buttons and menu commands. For example, you can press <Alt+C> at the 
main screen instead of clicking Create Image.

Use the arrow keys to make selections from a list (such as the list of disks or partitions on 
a disk). You can also press <Alt+down arrow> to open a drop-down list, such as the 
Drives list in the Browse dialog.

Use the space bar to select and deselect items in a list (such as partitions on a disk).

Press <Enter> to choose the highlighted button on a screen (such as the Next button).

Uninstalling Drive Image

1 Click Start ➤ Settings ➤ Control Panel ➤ Add/Remove Programs ➤ Drive 
Image 5.0.

2 Follow the instructions on the screen.

Getting Online Help

1 Click Help ➤ Contents to display general instructions for using Drive Image help, or 
press <F1> at any time to access the help index.

ImageExplorer, QuickImage, VF Editor, and DataKeeper are Windows programs and 
include a full Windows help system.
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C H A P T E R2
QuickImage
This chapter includes the following information:

• Overview

• Creating a QuickImage Definition

• Opening an Existing QuickImage Definition

• Deleting a QuickImage Definition

• Creating an Image or Scheduling a Task

• Editing a Scheduled Task

• Deleting a Scheduled Task

• Restoring an Image with QuickImage
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Overview

Use QuickImage to create or restore an image file from within Windows and to run Drive 
Image at the time and frequency you specify. QuickImage automates the backing up and 
restoring of specified drives on your computer.

When you start QuickImage, first you create a QuickImage definition that specifies which 
partitions to back up, the filename for the backup image, and any comments and advanced 
options you wish to save. After you have created a definition, you can schedule a task to 
create or restore image files that were created with QuickImage.

Creating a QuickImage Definition

1 From the Windows Start menu, click Programs ➤ PowerQuest Drive Image 5.0 ➤ 

QuickImage.

The PowerQuest QuickImage main screen appears.

2 Type the desired image path and filename in the Image Filename field (for example, 
D:\MYIMAGE).

The file extension .PQI is automatically added to the filename when you save the 
QuickImage definition.
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If desired, you can enter a path to specify removable media, such as a CD-R drive or 
Zip drive. (You cannot browse to a CD drive from within QuickImage. Instead, type 
the full path and filename to specify a CD-R or CD-RW drive.) If QuickImage does 
not recognize the drive letter when it is time to create the image file, you will be 
prompted to browse for the drive. After you locate it, the drive will be saved, and you 
will not have to browse before creating subsequent images.

If you are saving to floppy disks, be aware that drive letter A: is temporarily assigned 
to the virtual floppy used to boot QuickImage. Save to B: to save the image on floppy 
disks.

3 (Optional) Type a brief description about your image file in the Image Description 
field.

4 Click Select Partitions.

The Select Source Partitions screen appears. It is a graphic display of the hard disks 
in your machine.

5 Select the partitions you want to include in the image file from the partition list.

To select multiple partitions, hold down the Control key while clicking partitions in 
the list. (To select multiple partitions without using the mouse, use the arrow keys to 
highlight the partitions you want, then press <Ctrl + Spacebar> to select each 
partition.)

The partition where the image file will be stored cannot be selected. If your computer 
has one hard disk formatted only as drive C: (one partition), you must save image 
files on removable media.
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6 (Optional) Click Advanced Options to check for file system errors, verify disk 
writes, verify image contents, split an image file into multiple files (for copying later 
to removable media), select a compression level, or password protect your image file. 

See page 27 for additional information about compression levels. See “Advanced 
Options” on page 30 for additional information about the other options.

7 Click Save to save the QuickImage definition for later use, or click Create Image.

See “Creating an Image or Scheduling a Task” on page 15 for instructions on how to use 
the QuickImage definition you created.

Opening an Existing QuickImage Definition

QuickImage will automatically open the last saved QuickImage definition file. You can 
also open another QuickImage definition that you have previously saved. It is useful to 
open a definition if you cannot remember the settings you chose or if you want to edit the 
settings.

1 Click File ➤ Open.

2 Select an existing QuickImage definition.

3 Click Open.

Deleting a QuickImage Definition

1 Click File ➤ Open.

2 Right-click an existing QuickImage definition that you no longer want.
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3 Click Delete.

Creating an Image or Scheduling a Task

After you have created a QuickImage definition, you can either create the image 
immediately or choose to schedule the task at a later time.

IMPORTANT! QuickImage uses the Task Scheduler feature in Windows. Therefore, if 
you did not install Task Scheduler when you installed Windows, the 
Schedule task button and the Scheduled Task command on the View 
menu are disabled.

1 At the QuickImage main screen, click Create Image to create the image immediately 
or click Schedule Task to schedule the task at a later time. 

2 If you select Create Image, you will receive a prompt that QuickImage need to boot 
to DOS. Click OK. QuickImage reboots your computer using PowerQuest virtual 
floppy technology and creates the image.

If you select Schedule Task, the Image Creation Schedule dialog box appears.

3 If you want to create more than one backup schedule, make sure Show multiple 
schedules is selected on the Schedule tab.
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To create only one backup schedule, deselect Show multiple schedules, then 
continue with step 4.

4 Click New.

5 Select how often you want the back up to run from the Schedule Task drop-down 
list.

Choose an option to specify how frequently to run Drive Image. Then specify details 
for the option. 

The daily, weekly, monthly, and once options include optional advanced settings 
where you can specify a start date and end date for the task.

6 Click OK.

7 Click the Settings tab to select the settings you want.

Option: Details:

Daily • Start time.
• Which days (every day, every two days, and so on).

Weekly • Start time.
• Which weeks (every week, every two weeks, and so on).
• Which days of the week.

Monthly • Start time.
• Numeric date (such as 1 or 25) or relative date (such as first 

Monday of the month). If you select a numeric date of 29, 
30, or 31, the task will only run on months that include that 
date.

• Months you want task to run (July, October, and so on).

Once • Time of day.
• Exact date you want backup to occur.

At System 
Startup

Launches Drive Image when you turn on your computer.

At Logon Launches Drive Image when you log onto your computer.

When idle Launches Drive Image when your computer is idle for the 
specified number of minutes.
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IMPORTANT! The three options “Stop the task if it runs” for a specified number of 
hours or minutes, “Stop the task if the computer ceases to be idle,” and 
“Stop the task if battery mode begins,” are disabled and do not work 
with Drive Image because the program runs in DOS mode. Instead, 
these three options are available for programs that run in Windows 
only. 

8 (Optional) In the Scheduled Task Completed group box, select Delete the task if it 
is not scheduled to run again. 

Scheduler will delete the task if it is not scheduled multiple times.

9 (Optional) In the Idle Time group box, select the check box, then specify the number 
of minutes you want the computer to be idle before starting the task.

You can also specify how long you want to retry starting the task if the computer has 
not been idle for the number of minutes you defined.

10 Under Power Management, you can choose to not start the task if the computer is 
running on batteries or to wake the computer to run the task.

11 Click the QuickImage tab to review your QuickImage definition.

12 (Optional) Deselect Prompt before rebooting to Drive Image if you do not want to 
be prompted before Drive Image runs.

The check box is selected by default. 



Chapter 2: QuickImage18

13 (Optional) Select Wait until shutdown to run Drive Image if you want to wait until 
you shut down the computer to run Drive Image.

An icon appears in the task tray. When this option is selected, the QuickImage or 
Drive Image task will only run when the computer is shut down and the scheduled 
date and time to run the task has expired.

14 Click OK.

The scheduled task will now appear in the Windows Scheduled Tasks folder. 

To see all scheduled tasks under Windows 9x, double-click My Computer on the 
Windows desktop, then double-click Scheduled Tasks. To see all scheduled tasks under 
Windows 2000, double-click My Computer on the Windows desktop, then double-click 
Control Panel ➤ Scheduled Tasks.

If you want to see the scheduled tasks associated only with Drive Image, from the 
QuickImage main screen, click View ➤ Scheduled Tasks.

Creating a Shortcut

Once you have created a QuickImage definition, you can create a shortcut on the desktop 
that lets you create an image by selecting the shortcut icon.

1 With a definition created and saved, click Actions ➤ Create Shortcut.

2 Click OK to create the shortcut icon on your desktop.

The name of the icon is the same name you entered in the Definition name field of the 
Save QuickImage Definition As dialog box.

3 To run the task, double-click the shortcut icon on your Windows desktop.

You are reminded that Drive Image runs in DOS mode, and that all programs will be 
closed and your computer will reboot to DOS.

4 Click OK to continue.

Editing a Scheduled Task

1 From the QuickImage main screen, click View ➤ Scheduled Tasks.

2 Select the existing task you want to edit.
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3 Click Edit.

Make the changes you want to the definition.

4 Click Apply then click OK.

Deleting a Scheduled Task 

If you have created multiple schedules, you can delete the schedules that you no longer 
use.

1 From the QuickImage main screen, click View ➤ Scheduled Tasks.

2 Select the existing task you want to delete.

3 Click Delete.

Restoring an Image with QuickImage

You can use QuickImage to restore an image. 

1 From the QuickImage program, click Open.

2 Select an existing QuickImage definition that contains the image you want to restore.

The image file you are restoring must have been created using QuickImage. 

3 Click Open.

4 Select Actions ➤ Restore image now.

If the hard disk configuration has changed since you created the image file, you will get an 
error telling you that the configurations are different and you will not be allowed to 
automatically restore the image. Instead, you must use Drive Image DOS, which will let 
you manually select the partitions you want to restore.

QuickImage closes all programs and reboots to DOS using PowerQuest virtual floppy 
technology. The restored image replaces all of the partitions listed in the definition with 
the contents of the last saved image. When the image is restored, QuickImage boots back 
into Windows.

For more information about restoring images, see“Restoring an Image File” on page 34.
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C H A P T E R3
Creating Image Files with 
Drive Image DOS
This chapter includes the following information:

• Overview

• Image Files and Hardware Configurations

• Copying Windows NT or Windows 2000 Partitions

• Creating Image Files on CD-R or CD-RW

• Creating an Image File

• Advanced Options
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Overview

You can use Drive Image to create image files on any physical or logical drive that DOS 
has assigned a drive letter, including floppy drives, secondary hard drives, network drives, 
and removable media storage devices such as Jaz, Zip, and MO drives.

You can also create image files on NTFS, FAT, and FAT32 partitions and IDE or SCSI 
CD-R or CD-RW drives that have not been assigned drive letters. If you are unsure 
whether a drive is available to save an image file, click Browse and all of the available 
drives will display.

The steps under “Creating an Image File” beginning on page 23 include all the 
considerations that may be associated with each step. Some of the information will not 
apply to your configuration or the task you are completing. For example, if you are 
creating an image file from a computer that only has one hard disk, you will not see a 
screen where you can select the hard disk because it is automatically selected for you.

Image Files and Hardware Configurations

Because of operating system conflicts that can result from different hardware 
configurations, Drive Image was not intended to copy or image a hard drive that will be 
used in a system with different hardware configurations.

If you create an image on one machine and restore the image on a machine with a different 
configuration (for example, a different motherboard or video card), the operating system 
may not boot correctly. Therefore, PowerQuest recommends imaging and restoring only to 
machines with identical hardware configurations.

Any discussion of imaging assumes that the software, including the operating system, is 
being copied in accordance with the license agreement with the software manufacturer.

Copying Windows NT or Windows 2000 Partitions

If you are using Drive Image to copy Windows NT or Windows 2000 partitions (where 
Windows is installed), you may experience problems related to the BOOT.INI file. The 
BOOT.INI file includes information about the boot options for Windows’ loader and the 
order of the Windows partition. If you have used Drive Image to copy a Windows 
partition, and the partition order has changed from the original order, then the BOOT.INI 
file may not be updated to reflect the new order of the Windows NT/2000 operating 
system files. Therefore, you will be unable to boot your Windows partition.
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PowerQuest has developed a solution that will allow you to update and edit the BOOT.INI 
file. The executable is NTFSINI.EXE. For additional information (in English), see the 
PowerQuest web site www.powerquest.com/support/primus/id381.html. 

Creating Image Files on CD-R or CD-RW

Drive Image enables you to create image files directly on CD-R or CD-RW media. 
However, you must meet the following requirements, or the drive will not be available as a 
destination for an image file.

• You must have an IDE, SCSI, or SCSI PCMCIA CD-R or CD-RW drive. USB and 
FireWire CD-R drives are not supported. (The drive must be MMC2-compliant.)

• Do not load EMM386.EXE in your CONFIG.SYS file.

• If you create an image on CD-RW media, it must be empty and unformatted.

Creating an Image File 

1 Run a thorough ScanDisk (or CheckDisk) on your drives before imaging them.

2 At the Drive Image DOS main screen, click Create Image.

You can also choose buttons and menu commands using the keyboard. See “Using 
Drive Image without a Mouse” on page 9.

http://www.powerquest.com/support/primus/id381.html
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If you have multiple hard disks in your machine, the Select Source Drive screen 
appears. If you only have one hard disk, go to step 5

3 Select the disks that include the partitions you want to include in the image file.

You can click All Disks to select partitions from every hard disk on your machine.

4 Click Next.

The Select Source Partitions screen appears. It displays all the partitions on the disks 
that you selected. The partition map near the top of the screen is a graphic display of 
your hard disk. It includes a blue indicator for the 2 GB boot code boundary and a 



PowerQuest Drive Image 25

black indicator for the 1024 cylinder limit. The indicators can be useful when you are 
creating partitions that need to be bootable, since many operating systems require that 
boot code be located somewhere within the first 2 GB of the disk. 

5 If there are multiple partitions on the hard disks you selected previously, select the 
partitions you wish to include in the image file (the source partitions) from the 
partition list, or click Select All to automatically select all partitions.

If there is only one partition on the hard disk or disks you selected, the Select Source 
Partitions screen does not appear. Skip to step 7.

You may need to scroll to view all the partitions on your machine. Note that if you 
have more than one hard disk on your machine, the first column in the partition list 
shows the physical hard disk where the partition is located.

To deselect partitions, click again on a partition or click Select None to deselect all 
partitions at once.

6 Click Next.
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7 Type the desired path and image filename in the Image File field (for example, 
D:\MYIMAGE.PQI).

You must save your image file to a partition that you are not including in your image 
file. You can click Browse to find the directory where you want to save the image 
file. Click Browse to select a CD-R or CD-RW drive because you cannot just type the 
CD drive letter to save an image to CD. CD drives will appear in the list as 
\\.\pqcdx\name of drive, where x is the number of the CD drive.

You can save an image to a hidden NTFS, FAT, or FAT32 partition (a partition that 
has not been assigned a drive letter) by choosing it from the New Image File dialog 
box that appears when you click Browse. A hidden NTFS partition will appear in the 
Drives list as \\.\Diskn.Partm, where n is the number of the disk and m is the number 
of the partition on that disk. For example, the third partition on the first disk would 
appear as \\.\Disk1.Part3. To further identify the hidden partition, the volume label 
will display, if available.

Make sure there is no existing file with the same name, unless you want the existing 
file to be overwritten. Drive Image uses .PQI as the default image filename extension.

IMPORTANT! Do not include spaces or extended characters in the filename, or you 
may not be able to access the image file from Drive Image, DOS, or 
ImageExplorer.
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If you are saving to floppy disks, be aware that drive letter A: is temporarily assigned 
to the virtual floppy used to boot Drive Image. Save to B: to save the image on floppy 
disks.

You may need to create DOS boot diskettes to access network drives while running 
Drive Image. Your network administrator can help you get the correct network 
drivers to copy onto the first Drive Image rescue disk.

8 (Optional) Type brief comments about your image file in the Image File Comments 
field.

Image file comments cannot exceed 232 characters. Drive Image will automatically 
insert information about the drive, partition, and label.

9 Click Next.

10 Select the desired compression level.

Drive Image estimates the size of the image file for each level of compression. If you 
are creating an image file on removable media, Drive Image also estimates the 
number of media that will be required to save the image file. The numbers displayed 
are only estimates; the actual size for compressed images will vary according to how 
well the data on the disk compresses.



Chapter 3: Creating Image Files with Drive Image DOS28

• No Compression is usually the fastest method for creating an image file and is 
useful if storage space is not an issue. However, if you are saving your image file 
to a busy network drive or to a relatively slow removable media device, high 
compression may be faster than no compression since there is less data to write to 
the file. Drive Image selects No Compression by default.

• Low compression offers a 40% average compression ratio.

• High compression offers a 50% average compression ratio.

Image files created with Drive Image 5.0 are not compatible with Drive Image 
version 3.0 and earlier. That is, you cannot read Drive Image 5.0 images with Drive 
Image 3.0 or an earlier version. Drive Image 5.0 can read images created with earlier 
versions of Drive Image.

11 Click Next.

Drive Image displays all the information you have entered to this point. 

To modify any settings, click Back.

12 (Optional) Click Advanced Options to split an image file into multiple files (for 
copying later to removable media), to disable file system error-checking or 
SmartSector copying, to password protect your image file, to verify the integrity of 
the image file after it is created, or to verify disk writes.

See “Advanced Options” on page 30 for additional information.

13 Click Finish to begin creating the image file.
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If you entered a name of a current file (step 6), Drive Image displays a message that 
<path and filename> already exists. You can replace the existing file or choose a new 
filename. If you click Replace, the existing image file will be deleted immediately.

If Drive Image detects that you are saving your image file to a floppy drive or 
removable media, it enables a media-spanning feature that spreads the image file over 
a series of disks. You must have at least 128K of available space on each disk in the 
series. If you use the media-spanning feature, be sure to number the disks in order, 
since you must insert them in sequence when restoring the image file.

The Creating the Image dialog appears, tracking the progress of the image creation. 

Drive Image will prompt you if it is necessary to insert new media for the image file. 
If you are saving to a Zip disk, wait for the busy light to go out before you exchange 
Zip disks.

Upon completion, the following message appears: Image was copied successfully to 
file: <image filename>.

14 Click OK to return to the Drive Image main screen.

IMPORTANT! Because operating system conflicts can result from different hardware 
configurations, you should not restore the image you just created on a 
system with different hardware.
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Advanced Options

The Create Image Advanced Options dialog appears when you click Advanced 
Options at the Ready To Create Image File screen.

Select this: To do this:

Check for File System 
Errors

Clear the Check for File System Errors check box if you 
want to disable error checking.

If you have already used a disk utility program such as 
ScanDisk or CheckDisk to check your hard disk for errors, it 
is not necessary to have Drive Image check for file system 
errors. Clearing Check for File System Errors saves time 
in copying the partitions.

If you did not run a disk utility program before loading 
Drive Image, leave the Check for File System Errors check 
box selected. Be aware that ScanDisk/CheckDisk finds more 
errors than the Check feature in Drive Image.

Disable SmartSector 
Copying

Drive Image’s SmartSector technology speeds up the 
copying process by only copying clusters and sectors that 
contain data. However, in some cases, such as high-security 
environments, it may be desirable to copy all clusters and 
sectors in their original layout, whether or not they contain 
data.

If you wish to copy both used and unused clusters and 
sectors, click Disable SmartSector Copying. Disabling 
SmartSector copying increases processing time and image 
file size.

Verify Disk Writes Select this option if you want Drive Image to verify that data 
is being written to disk. Verifying disk writes is not 
necessary and can slow image file creation substantially.

If you are creating an image file to CD-R, this option is 
selected by default and performs a different function. After 
burning the image file to a CD, Drive Image will check to 
see that the image file can be read from the CD. If there is a 
problem with the image, you will have an opportunity to 
recreate it.
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Verify Image Contents If you select this option, Drive Image:

• Checks to see that all of the segments ofthe image (such 
as myfile.pqi, myfile.002, myfile.003, and so forth) are 
available for you to open.

• Checks to see that the internal data structures in the 
image file match the data that is available.

• Checks to see that the image file can be uncompressed 
and create the expected amount of data.

• Checks that the data in the image file you created 
matches the contents of the disk that was just imaged.

Drive Image reports whether the image file passes or fails 
the integrity check.

Password Protect 
Image File

To password-protect your image file, click Password 
Protect Image File and type a password in the Password 
field. Passwords are case-sensitive. Do not include extended 
characters in a password. To change or undo a password, use 
ImageExplorer. See “Adding a Password to an Image” on 
page 66.

IMPORTANT! Store image file passwords in a safe place. If 
you forget the password, you cannot restore 
the file.

Split Image File Into 
Multiple Files

If you plan to copy an image file to removable media after 
creating it, you can force Drive Image to split a large image 
file into smaller files. To do so, click Split Image File Into 
Multiple Files and enter the maximum byte size for each 
file in the File Size (bytes) field. To save the files to CDs, 
specify a file size of 670,000,000 bytes (approximately 650 
MB) or less.

Select this: To do this:
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C H A P T E R4
Restoring Image Files with 
Drive Image DOS
This chapter includes the following information:

• Overview

• Restoring Images from CD Drives

• Restoring an Image File

• Resize Options

• Advanced Options
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Overview

This chapter describes restoring a Drive Image image file to a different drive or partition. 
To restore only selected files from a compressed or spanned image file, see “Restoring 
Files or Partitions” on page 67.

If you received a demo version of Drive Image, you cannot restore image files.

IMPORTANT! If you create an image on one machine and restore the image on a machine 
with a different configuration (for example, a different motherboard or 
video card), the operating system may not boot correctly.

If you are restoring an image file to set up a new hard drive on a machine with a BIOS 
older than 1994, see “Using Drive Image with Drive Overlay Software” on page 86.

Restoring Images from CD Drives

When you click Browse at the Select Image File screen, your CD drive will display as 
\\.\pqcdx, where x is the number of the CD drive. Select the drive, and the image file will 
display so you can restore it.

Your CD drives may also display with drive letters. Although you can restore using drive 
letters, PowerQuest recommends that you click Browse and choose the \\.\pqcdx 
designation instead.

Restoring an Image File

1 Disable virus detection in the BIOS.

If virus protection is enabled, Drive Image may hang after you click Finish to restore 
an image file.

2 At the Drive Image main screen, click Restore Image.

You can also choose buttons and menu commands using the keyboard. See “Using 
Drive Image without a Mouse” on page 9.
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3 In the Image File field, enter the path and filename of the image file you want to 
restore, or click Browse to select the path and image file. 

You can restore an image file from any physical or logical drive that DOS has 
assigned a drive letter, including floppy drives, secondary hard drives, network 
drives, and most removable media storage devices.

If you are restoring an image from a CD, refer to “Restoring Images from CD Drives” 
on page 34.

If you have a spanned image file, Drive Image will prompt you to insert media when 
it needs to display the image filename. You should insert the last media in the series. 
(The prompt may appear at this point or after you click Next in step 4.)

You may need to run Drive Image from DOS boot diskettes to access network drives 
while running Drive Image.

You can restore an image from an NTFS, FAT, or FAT32 partition that has not been 
assigned a drive letter by choosing it from the Open Image File dialog box that 
appears when you click Browse. A hidden NTFS partition will appear in the Drives 
list as \\.\Diskn.Partm, where n is the number of the disk and m is the number of the 
partition on that disk. The first partition on the first hard disk would be identified as 
\\.\Disk1.Part1. To further identify a partition, the volume label will display, if 
available.

If you click Browse and select an image file, you will have an option to verify the 
integrity of an image file before you attempt to restore it. Click Verify, and Drive 
Image will check to see that all of the segments of the image (such as myfile.pqi, 
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myfile.002, myfile.003, and so forth) are available for you to open, the internal data 
structures in the image file match the data that is available, and the image file can be 
uncompressed and create the expected amount of data. Drive Image reports whether 
the image file passes or fails the integrity check.

4 Click Next.

At any point prior to actual image file restore, you can click Back to return to the 
previous step and change your settings.

5 From the Select Destination Drive dialog, select the disk that includes the 
unallocated space or partitions where you want to restore the image file.

If you only have one hard disk, this step is omitted.

6 If you have more than one partition, you can select the partitions you want to restore. 
Click partitions to select them individually, or click Select All.

To deselect partitions, click again on a partition or click Select None.

7 Click Next.

8 Select an existing partition or unallocated space where you want to restore the image.

Drag column 
borders to 
resize 
columns.
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The partition list includes all the partitions on your machine. If you have more than 
one hard disk, the first column in the partition list shows the disk on which a partition 
is located. 

When you restore an image to unallocated space, Drive Image creates a new partition 
for the image. The unallocated space where you restore an image must be at least as 
large as the used space required by the image. For example, if you created an image of 
a 500 MB FAT32 partition that included 300 MB of data, the unallocated space where 
you restore the image must be at least 300 MB. If you are restoring an NTFS partition, 
note that NTFS partitions require some unused space to facilitate resizing and cannot 
be resized below the master file table (MFT), regardless of how much data is included 
in the partition.

If the destination partition or unallocated space is not large enough to accommodate 
the partitions you wish to restore, or if you are restoring the image file to a larger 
drive and want to set a specific size for partitions rather than use the proportional 
resize option, you may want to resize the partitions.

If you do not want to resize the partitions, go to step 14.

9 Click Resize Source Partitions.

The Resize Partitions window displays, and the Selected Source Partitions group 
box displays the partitions you selected to restore.
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10 Click Resize.

The Resize Partition window appears.

11 In the New Size field, enter the size for the new partition (in MB), then click OK.

The size you enter must be equal to or larger than the Minimum Size and less than or 
equal to the Maximum Size displayed in the dialog. Since partitions must end on a 
cylinder boundary, Drive Image rounds the new size up to the next cylinder boundary.

12 Click Accept.

When you restore the image file, Drive Image will resize the partition.
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13 Click Next.

If you selected an existing partition as the destination, a message appears to remind you 
that the existing partition will be deleted before your image is restored. Drive Image 
does not delete the partition until you click Finish on the Ready to Restore Image 
File screen; if you cancel the restore process before clicking Finish, your existing 
partition will still be there.

If the unallocated space on the destination drive is greater than the space required to 
restore the selected partitions, the Resize Options dialog appears. For more 
information, see “Resize Options” on page 41.

The Select Disk Write Mode screen appears.

14 Click Fast Mode to copy data as quickly as possible without integrity checks, or click 
Safe Mode to choose integrity checks for Drive Image to perform while copying the 
data.

Be aware that choosing Safe Mode can increase the time necessary to copy data. If 
you choose Safe Mode, you can choose to check the hard disk for bad sectors and 
verify disk writes. Checking for bad sectors is a good idea if your destination disk is 
an older model or if you are not sure it is in good condition. If you choose verify disk 
writes, Drive Image will check the data after it is copied to make sure it is readable. 
Verifying disk writes greatly increases the time required to copy data and is optional.

15 Click Next.
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Drive Image displays all the information you have entered to this point. To change 
any settings, click Back.

16 (Optional) To enable bad-sector checking, turn on DOS disk-write verification, check 
for file system errors, or hide partitions after restore, click Advanced Options. For 
more information, see “Advanced Options” on page 41.

IMPORTANT! Restoring partitions can cause the drive letters of subsequent partitions 
to change. This may make the computer unbootable or cause 
applications to fail.

IMPORTANT! If you are restoring a primary partition that contains an operating 
system, and it will not replace your existing primary partition, you 
must click Advanced Options and choose to hide the partition after 
restoring it. Otherwise, data corruption could occur.

17 Click Finish to begin restoring the image file.

If you assigned a password to the image file when you created it, the Get Image File 
Password dialog appears. You must enter the password to restore the image file. 
PowerQuest does not maintain image file passwords or have a workaround for 
restoring password-protected images without the password.

If Drive Image detects that you are restoring your image file from removable media, it 
enables a media-spanning feature that is capable of reading the image file from a 
series of disks. As Drive Image prompts you for each media, be careful to insert them 
sequentially. (You may need to insert the last media first, then insert the first media.)
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The Restoring the Image dialog appears, tracking the progress of the image restore. 
Upon completion, the following message appears: “Image was restored successfully.”

18 Click OK to return to the Drive Image main screen.

Resize Options

If the unallocated space on the destination drive is greater than the space required by the 
partitions you are restoring, you have three options for how to handle the extra space. 

Advanced Options

At the Ready To Restore Image File screen, click Advanced Options to access the 
following: 

Click this option: To do this:

Automatically resize 
partitions proportionally to 
fit 

Allow Drive Image to automatically expand the 
partitions in equal proportions to occupy the destination 
drive’s remaining free space.

Leave remaining unused 
space

Leave any remaining free space unused (unpartitioned) 
on the destination drive after the partitions are restored. 
This option will retain the original partition size.

Resize partitions manually 
to fit

Display the Resize Partition window where you can 
manually set the size of the partitions to fit in the 
destination drive’s remaining free space.

For more information on resizing partitions, see step 9 
(beginning of steps is on page 34).

Option: Description:

Check for File 
System Errors

Clear the Check for File System Errors check box to disable 
error checking.

If you leave this option selected, Drive Image will check your 
disk for errors after restoring the image file.
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Skip Bad Sector 
Check

This is selected by default to save time in restoring the image 
file.

Although most drives do not have bad sectors, the potential for 
problems increases during the lifetime of the hard drive. If you 
have an older hard drive, it is wise to enable bad-sector 
checking by clearing the Skip Bad Sector Check box.

Verify Disk Writes Click Verify Disk Writes if you want to enable DOS disk 
write verification. Disk write verification is not critical to 
safely restore image files. Enabling disk write verification can 
slow the image restore process significantly.

Hide Partitions 
After Restore

Restoring multiple logical partitions can cause the drive letters 
of subsequent partitions to change. This may make the 
computer unbootable or cause applications to fail.

Most operating systems only allow one primary partition to be 
visible (bootable) at a time. If you are restoring an image of a 
primary partition, and you do not want to make that partition 
your visible (bootable) partition, click Hide Partition After 
Restore. Failing to do so could cause data corruption.

For example, if you are using your secondary hard drive as a 
complete backup of your primary drive, clicking Hide 
Partitions After Restore preserves all the secondary drive 
information without changing any drive letters. When the 
computer boots up, a drive letter will not be assigned to the 
hidden partition. For more information about hiding partitions, 
see “Hiding Partitions” on page 58.

Option: Description:
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C H A P T E R5
Copying Disk to Disk
This chapter includes the following information:

• Preparation

• Procedure

• Advanced Options

Preparation

If you are upgrading to a new hard drive, refer to “Using Drive Image with SCSI 
Hard Disks” or “Using Drive Image with Drive Overlay Software” on page 86 if 
needed.

It is strongly recommended that you perform the following steps before 
upgrading to a new hard drive or using the Drive Image to copy disk to disk.

• Create a set of Drive Image rescue diskettes. See “Creating Rescue Diskettes 
under Windows” on page 5.

• Before running Drive Image, use a disk utility program such as ScanDisk or 
Norton’s Disk Doctor to identify and thoroughly repair any errors on your 
hard drive. Windows NT Workstation, Windows 2000, and Windows XP 
users should run CHKDSK /F.

• Verify that the destination drive or partition is the same size or larger than 
the source drive. You can copy a partition or drive from a larger to a smaller 
partition or drive. However, there must be enough unallocated space on the 
smaller destination to accommodate the used space on the larger source.



Chapter 5: Copying Disk to Disk44

If you are copying from one partition to another partition on the same hard disk, go 
directly to the steps outlined under “Procedure” on page 45.

IMPORTANT! If you are using Drive Image to copy a Windows NT partition, refer to 
“Copying Windows NT or Windows 2000 Partitions” on page 22 for 
information about the BOOT.INI.

Setting Up a Dual Hard Disk System

1 Get the manufacturer’s installation guides for both drives.

The installation guides provide information on installing the drives, setting up the 
BIOS, and changing the jumper settings. If you do not have access to these guides, 
contact the hard drive manufacturers directly. Most drive manufacturers maintain 
sites on the Internet that offer setup information.

2 Turn off the computer’s power.

3 Discharge static electricity by touching a grounded metal object such as a metal filing 
cabinet.

IMPORTANT! Do not allow static electricity to contact the inner parts of your 
computer. Static electricity can damage or destroy your computer’s 
electronic components.

4 Remove the computer’s cover.

5 Determine which drive you want to be master and which drive you want to be slave, 
then follow the manufacturer’s instructions to change the jumper settings on your hard 
drives accordingly.

6 Attach the interface cable and the power supply cable to the second drive.

7 Mount the second drive.

8 Start the computer and enter its Basic Input/Output System (BIOS) Setup program 
before the computer completes startup.

This is usually accomplished by pressing <DEL>, <F1>, or <F2>, according to the 
prompt that appears at the bottom of your screen during initial startup.

9 If the BIOS Setup program includes an Auto-Detect option, select it to detect both the 
master and slave drives.
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If there is no Auto-Detect option, you may be required to enter the specific number of 
heads, cylinders, and megabytes of the drives. This information is usually printed on 
the drive’s outside cover. If it is not, contact the drive manufacturer.

10 If the BIOS does not support hard drives larger than 504 megabytes, follow the 
destination drive manufacturer’s instructions to install any software included with the 
drive.

Computer BIOSs made before 1994 usually do not support the EIDE standard and 
cannot address hard drives larger than 504 MB. Hard drives larger than 504 MB 
typically include software such as OnTrack Disk Manager, Maxtor Max-Blast Disk 
Manager, or Micro House EZ-Drive which allow computers to see larger hard drives.

If your machine does not support the EIDE standard, make sure the software included 
with the destination drive is correctly installed.

If Drive Image lists a drive size that is much smaller than its actual size, the EIDE 
support software is not functioning properly.

11 Turn off the computer, then restart it.

Procedure

The Disk to Disk feature copies partitions directly from one place to another without 
creating an image file.

If you received a demo version of Drive Image, you cannot use the Disk to Disk feature.

It is not necessary to format your destination partition or to partition your hard drives 
before performing a Disk to Disk copy. Drive Image automatically performs both these 
functions.

1 At the Drive Image DOS main screen, click Disk To Disk.

You can also choose buttons and menu commands using the keyboard. See “Using 
Drive Image without a Mouse” on page 9.



Chapter 5: Copying Disk to Disk46

The Select Source Drive screen appears.

2 Select the disk or disks that include partitions you want to copy, then click Next.

At any point prior to actually copying partitions, you can click Back to change your 
settings.

3 Select the source partition you wish to copy, or click Select All to select all partitions.
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You may need to scroll to view all the partitions in the list. Note that if you have more 
than one hard disk on your machine, the first column in the partition list shows the 
physical hard disk where the partition is located.

A check appears to the left of selected partitions. To deselect partitions, click again on 
a partition or click Select None to deselect all partitions at once.

4 Click Next.

5 Select the destination drive that includes the partitions or unallocated space where you 
want the copied partitions to be stored, then click Next.

6 Select the destination partition or unallocated space, then click Next. 

You may need to scroll to view all the partitions in the list. Note that if you have more 
than one hard disk on your machine, the first column in the partition list shows the 
physical hard disk where the partition is located.

IMPORTANT! To copy partitions, the destination partition or drive must have 
unallocated space equivalent to the total used space of the selected 
source partition. If you copy to a partition that already includes data, 
the existing data will be replaced.
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7 If the destination partition or unallocated space is not large enough to accommodate 
the partition you wish to copy, or if you are copying the partition to a larger drive and 
want to set a specific size for the partition rather than use the proportional resize 
option, you can click Resize Source Partitions to specify a different size for the 
copied partition. If you do not want to resize the source partition, go to step 12.

8 Click Resize Source Partitions.

The Resize Partitions window appears. 

The Selected Source Partitions group box displays the partition you selected to 
copy. The screen also displays the destination size, current size of selected partition, 
and remaining free space in the destination.

9 Otherwise, Click Resize. (If you do not want to make changes, click Accept.)

The Resize Partition window appears.
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10 In the New Size field, type the size for the partition (in MB), then click OK.

The size you enter must be equal to or larger than the Minimum Size and less than or 
equal to the Maximum Size displayed in the dialog.

Since partitions must end on a cylinder boundary, Drive Image rounds the New Size 
up to the nearest cylinder boundary.

NTFS partitions require some unused space to facilitate resizing and cannot be 
resized below the master file table (MFT), so the minimum size may appear larger 
than is necessary to accommodate the data in the partition.

11 Click OK, then click Accept.

Later, when you copy the partition, Drive Image resizes it.

12 Click Next.

If you selected an existing partition as the destination, a prompt will appear reminding 
you that the existing partition will be deleted before copying. 

Drive Image does not delete the partition until you click Finish on the Ready to 
Copy Disk to Disk screen.

13 If the unallocated space on the destination drive is greater than the space required to 
copy the selected partition, the Resize Options dialog appears. Click the option you 
want, then click OK.

Select this option: To do this:

Automatically resize 
partitions 
proportionally to fit

Allow Drive Image to automatically expand the 
partitions in equal proportions to occupy the destination 
drive’s remaining unallocated space.

Leave remaining 
unused space

Leave any remaining unallocated space unused on the 
destination drive after the partitions are copied.

Resize partitions 
manually to fit

Display the Resize Partitions window where you can 
manually set the size of the partitions to fit in the 
destination drive’s remaining unallocated space. (See 
step 8 for additional information about the Resize 
Partition window.)
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The Select Copy Type screen appears.

14 Select Replace or Backup to indicate why you are running Drive Image, then click 
Next.

Select Replace if you are adding a hard disk to your system and using Drive Image to 
copy information from your old drive to the new drive.

If you select Replace, Drive Image will hide the source partitions after copying them. 
If you select Backup, Drive Image will hide the destination partitions after copying 
them.

By hiding either the source or destination partitions, Drive Image ensures that your 
drive letters will not change when you reboot your computer. Hiding partitions can 
also avoid problems that result when two identical operating system partitions are 
visible when you reboot. If you are confident that having both your source and 
destination partitions visible will not make your computer unbootable or cause 
problems because of drive letter changes, you can click Advanced Options at the 
Ready to Copy Disk to Disk screen (see step 17) and change Drive Image’s default 
settings.
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The Select Disk Write Mode screen appears.

15 Click Fast Mode to copy data as quickly as possible without integrity checks, or click 
Safe Mode to choose integrity checks for Drive Image to perform while copying the 
data.

Be aware that choosing Safe Mode can increase the time necessary to copy data. If 
you choose Safe Mode, you can choose to check the hard disk for bad sectors and 
verify disk writes. Checking for bad sectors is a good idea if your destination disk is 
an older model or if you are not sure it is in good condition. If you choose verify disk 
writes, Drive Image will check the data after it is copied to make sure it is readable. 
Verifying disk writes greatly increases the time required to copy data and is optional.

16 Click Next.
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Drive Image displays all the information you have entered to this point.

17 (Optional) To alter any settings, click Back. To set options such as disabling file 
system error-checking or hiding partitions after copy, click Advanced Options. For 
more information, see “Advanced Options” on page 53.

Copying multiple logical partitions can cause the drive letters of subsequent partitions 
to change. This may make the computer unbootable or cause applications to fail.

18 Click Finish to begin copying the selected partition.

The Copying Disk To Disk dialog tracks the progress. A message prompts you when 
the copy is complete.

19 Click OK to return to the Drive Image main screen.

If you ever want to replace the active partition with a hidden backup partition (for 
instance, if you lose data from your C: partition), run Drive Image Disk To Disk again. 
Select the hidden partition as the source and the active partition as the destination. After 
Drive Image completes the copying process, it prompts you to set an active partition. 
Select the newly copied partition.
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Advanced Options

The Disk to Disk Advanced Options dialog appears when you click Advanced Options 
at the Ready To Copy Disk To Disk screen.

Select this: To do this:

Source Options

Check for File 
System Errors

Clear the Check for File System Errors check box if you want 
to disable error checking.

If you have already used a disk utility program such as 
ScanDisk or CheckDisk to check your hard disk for errors, it is 
not necessary to have Drive Image check for file system errors. 
Clearing Check for File System Errors saves time in copying 
the partitions. If you did not run a disk utility program before 
loading Drive Image, leave the Check for File System Errors 
check box selected.

Disable 
SmartSector 
Copying

Drive Image’s SmartSector technology speeds up the copying 
process by only copying clusters and sectors that contain data. 
However, in some cases, such as high-security environments, it 
may be desirable to copy all clusters and sectors in their 
original layout, whether or not they contain data.

If you wish to copy both used and unused clusters and sectors, 
click Disable SmartSector Copying. Disabling SmartSector 
copying increases processing time.
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Hide Source 
Partitions After 
Copy

If you selected Replace at the Select Copy Type screen, this 
option is selected by default. Hiding the source partition will 
ensure that your drive letters do not change when you reboot 
your computer. It can also avoid problems caused by having 
two identical operating systems visible when you reboot.

You can use this option to copy an operating system to a new 
disk and hide the original partitions. The new partitions will be 
active. You can set the new drive to master and the old drive to 
slave, reboot and test the new operating system with the old 
drive still in place in case something goes wrong.

Destination Options

Skip Bad Sector 
Check

This option is selected by default to save time in copying the 
partitions. Although most drives do not have bad sectors, the 
potential for problems increases during the lifetime of the hard 
drive. If you have an older hard drive, it is wise to enable 
bad-sector checking by clearing the Skip Bad Sector Check 
box.

Verify Disk Writes Click Verify Disk Writes if you want to enable DOS disk write 
verification.

Disk write verification is not critical to safely copy files. 
Enabling disk write verification can slow the copying process 
dramatically.

Hide Destination 
Partitions After 
Copy

If you selected Backup at the Select Copy Type screen, this 
option is selected by default. Most operating systems only 
allow one primary partition to be visible (bootable) at a time. If 
you are copying a primary partition and you do not want to 
make that partition your bootable partition, the Hide 
Destination Partitions After Copy box should be selected.

If you are using your secondary hard drive as a complete 
backup of your primary drive, selecting Hide Destination 
Partitions After Copy preserves all the secondary drive 
information without changing any drive letters. When the 
computer boots up, a drive letter will not be assigned to the 
hidden partitions. For additional information about hiding 
partitions, see “Hiding Partitions” on page 58.

Select this: To do this:
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C H A P T E R6
Common Partition 
Management Tasks
This chapter includes the following information about the Tools menu 
in Drive Image DOS:

• Displaying Drive Information

• Creating Extended Partitions

• Deleting Partitions

• Hiding Partitions

• Setting the Active Partition

Overview

The Tools drop-down menu on the Drive Image DOS main screen lets you 
manually perform some common partition-management tasks that Drive Image 
automatically performs when it processes image files or when it copies partitions. 
The Tools menu gives you access to these useful features without requiring you 
to create or restore image files or copy partitions.
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Displaying Drive Information

The Display Drive Information option lets you view information about the partitions on 
your current hard drive.

1 At the Drive Image DOS main screen, click Tools ➤ Display Drive Information.

2 From the Physical Drives drop-down list, choose the drive where the partition you 
want information about is located.

Drive Information Displayed on the Screen (Partition Map)

Several Drive Image dialog boxes include a partition map that shows the partitions on your 
hard disk. If the selected hard disk includes logical partitions, they are shown within an 
extended partition. Partitions are color coded to indicate the file system type each uses. 
For example, dark green indicates a FAT32 partition. In addition, each partition is shaded 
to show used and unused space within the partition.

The partition map also shows unallocated space (space not assigned to any partition).

There are triangle indicators on the partition map to mark the 2 GB boot code boundary 
and the 1024 cylinder limit. The boundary markers can help you as you restore image files 
or set a new partition active. If your operating system requires the boot code to be within 
the first 2 GB of the hard disk, for example, you can tell at a glance if the partition is 
located in a place that will make it bootable.

A graphic display of your partitions will display, as well as a partition list.

Creating Extended Partitions

If you create an image of a primary partition and want to restore it as a logical partition, 
you must first have an extended partition on your hard drive. For example, if you have two 
hard disks that each include a primary partition (a bootable C: and a data partition D:) and 
you are copying both partitions to a new hard disk that will be your master disk, you 
would want the D: partition copied to a logical partition to avoid having two primary 
partitions on the new hard disk. Primary partitions on the primary master drive should be 
reserved for operating systems only.

• Drive letters
• Volume (partition) labels
• Color-coded volume (partition) types
• Status (active partition)

• Partition size
• Used MB in partitions
• Free MB in partitions
• Primary or logical drive
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It is not necessary to manually create an extended partition when you restore an image of a 
logical partition. Drive Image automatically creates an extended partition if one does not 
already exist.

1 At the Drive Image DOS main screen, click Tools ➤ Create Extended Partition.

The Create Extended Partition window appears.

2 Select an unallocated space from the partition list.

If there is no unallocated space on your computer, you must delete an existing 
partition to create unallocated space. 

3 Click Create.

Drive Image creates an extended partition in the selected free space.

4 Click Close to return to the Drive Image DOS main screen.

Deleting Partitions

This feature deletes existing partitions to create unallocated space on your hard drive. Be 
aware that deleting existing partitions destroys any data they contain.

1 At the Drive Image DOS main screen, click Tools ➤ Delete Disk Partitions.
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The Delete Partitions window appears. 

2 From the Physical Drives drop-down list, choose the disk where the partition you 
want to delete is located.

3 Click the partition you wish to delete.

You may need to scroll to view all the partitions on your computer.

4 Click Delete.

The Delete Partition dialog appears, displaying the selected partition and its volume 
label.

5 Type OK, then click OK. 

Drive Image deletes the partition and displays the message: “Volume <volume name> 
was deleted successfully.”

6 Click Close to return to the Drive Image DOS main screen.

Hiding Partitions

The Hide/Unhide feature allows you to protect partitions from unwanted user access. 
Hidden partitions are not accessible because they are not assigned drive letters when you 
boot your computer. If you unhide a partition, it is assigned a drive letter the next time you 
boot your computer and becomes accessible again.
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Before hiding and unhiding partitions, be aware of the following restrictions.

• Hiding or unhiding a partition can cause the drive letters of subsequent partitions to 
change. This may make the computer fail to boot or cause applications to fail.

• If your hard drive contains more than one primary partition, only one is visible by 
default. When you use the Set Active Partition feature, Drive Image unhides the 
selected primary partition and automatically hides all other primary partitions. See 
“Setting the Active Partition” on page 60.

• Because a hidden partition is not bootable or accessible, if you hide the partition 
where Drive Image is installed, you must re-install Drive Image on your new active 
(bootable) partition to run it again.

To hide/unhide a partition,

1 At the Drive Image DOS main screen, click Tools ➤ Hide/Unhide Partitions.

The Hide Partitions window appears.

2 Click the partition you want to hide or unhide.

3 Click Hide or Unhide.

The partition status changes. If the Hide or Unhide button is dimmed, the partition 
cannot be hidden or unhidden.

4 Click Close to return to the Drive Image DOS main screen.

5 Click Exit to exit Drive Image, then reboot your computer.
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Setting the Active Partition

The Set Active Partition feature allows you to make a primary partition the active 
(bootable) partition. Only one primary partition can be active at a time. To be bootable 
under most operating systems, a primary partition must be located on the first (master) 
drive, and it must contain an operating system. When your computer boots, it scans the 
partition table of the first drive to find the active partition, then boots from that partition.

WARNING! Before you set an active partition, be sure it is bootable. If it is not bootable 
or if you are not sure, locate the boot disk you created when you installed 
Drive Image. If you restart your computer and it does not boot normally, 
you must boot from the floppy disk, run Drive Image from the program disk 
you created during Drive Image install, and set a different partition active. 
Refer to “Drive Information Displayed on the Screen (Partition Map)” on 
page 56 for explanations of the Drive Image screen that may also help you 
determine if your partition is bootable.

1 At the Drive Image DOS main screen, click Tools ➤ Set Active Partition.

The Set Active Partition window appears.

2 Select a primary partition that is not currently active, then click Set Active.

The status of the selected partition changes to “Active.”

3 Click Close.

4 Click Exit to exit Drive Image, then reboot your computer.
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C H A P T E R7
ImageExplorer
This chapter includes the following information:

• Overview

• PowerQuest ImageExplorer—Main Screen

• Modifying Images

• Restoring Files or Partitions

• Verifying Image Files

• Deleting Image Files

• Displaying Information About Images

• Displaying Information About Partitions

• Viewing Files within an Image File

• ImageExplorer Options

• Online Help

• Exiting ImageExplorer

Overview

PowerQuest ImageExplorer simplifies management of your image files. Working 
within a single screen, ImageExplorer gives you total control of the image files 
you can access. You can view image file contents, copy image files, copy 
partitions within files, restore individual program and data files from the image, 
or add password protection to image files.
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ImageExplorer also provides description capabilities, so you can easily identify individual 
image files and partitions.

ImageExplorer runs under Windows 9x, Windows Me, Windows NT Workstation and 
Server, Windows 2000 Professional, and Windows XP.

PowerQuest ImageExplorer—Main Screen

The ImageExplorer main screen is divided into three panes: Locate, Recent, and Contents.

Screen area: Description:

Locate pane Displays a tree view of all the drives on your machine (local hard 
disks and network drives).

Recent pane Displays a tree view of image files you have browsed to or opened 
recently. You can clear the list of recent images by clicking Recent 
➤ Clear Recent Images List.

Contents Displays the contents of the selected drive, folder, image file, or 
partition.



PowerQuest Drive Image 63

Modifying Images

You can use the Copy to Image feature in ImageExplorer to copy single or multiple 
partitions to new or existing image files. When you copy a file, partition, or image, you 
also have an option to set the compression level for the resulting image, add a password to 
the image, or split the image into multiple files.

Copying Partitions to an Image File

You can drag and drop partitions from one image file to another, or you can copy partitions 
using the Edit menu. Copied partitions will not overwrite any partition already in an 
image file. Therefore, you can have several partitions with the same name or drive letter 
within one image file.

There are several methods to copy partitions or image files:

• Drag and drop the partition or image from the Recent or Locate pane onto a drive or 
folder in the Locate pane.

• Drag and drop a partition within an image file onto another image file or onto a folder 
in the Locate pane.

• Select a partition, click File ➤ Copy to Image.

• Right-click a partition, click File ➤ Copy to Image.

• Select a partition, click Edit ➤ Copy, move the insertion point to the new location, 
then click Edit ➤ Paste.

Toolbar Provides quick access to common tasks. You can display or hide the 
toolbar using the View menu. You can also use the View menu to 
determine whether to display text labels on the toolbar buttons.

Status bar Displays a brief description of the toolbar button where the pointer 
is located. You can display or hide the status bar using the View 
menu.

What you copy: Result:

Entire .PQI image file The Copy to Image dialog appears with the 
Destination image text box filled in according to the 
currently selected drive or folder in the Locate pane.

Screen area: Description:
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The Copy to Image dialog displays the filename for the image file you are modifying (or 
allows you to type a filename for a new image file). It also allows you to split an image 
file, combine files that make up a spanned image, add a password to an image, and choose 
the compression level for an image.

When you copy an image to removable media, it will split into segments to fit on the 
media, whether you check the Split image into segments check box or not. The Split 
image into segments check box enables you to artificially limit the size of image file 
segments, so they can later be copied to removable media. 

Partition within an image 
file

If the partition is copied to another image file, the Copy 
to Image dialog appears and the partition is added to 
the image file and inherits the characteristics of the 
target image file including compression ratio, 
password, and so forth. If the partition is copied to a 
folder, the Copy to Image dialog is displayed and the 
partition is added to a newly created .PQI image file.

What you copy: Result:
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Splitting an Image into Multiple Files

You can use ImageExplorer to split image files after they have been created. Use Split to 
save split image files to a fixed drive or network drive and later transfer the files to 
removable media, such as a CD-RW.

You split an image by copying the whole image or selected partitions to a new image file 
and then splitting the new image file.

1 Copy the image file you want to split from the Locate or Recent pane into the Locate 
pane.

The Copy to Image dialog appears.

2 Under Destination image, type a path and filename for the new image file.

To save an existing image file directly to a series of removable media disks (for 
example, floppy disks, Jaz, or Zip disks), specify the removable media drive in the 
Destination image box.

To copy an image file to CD-R or CD-RW media, you should split it into segments on 
your hard disk, then use an application like Roxio’s Easy CD Creator to burn the 
image to CD media. (You can also create an image directly to CD media from within 
Drive Image or QuickImage.)

3 Select Split image into segments.

If you selected removable media in step 2, the image file will be split into 
appropriately-sized segments, whether or not you specify this option and enter a value 
in step 4. Steps 3 and 4 of this process are useful when you want to break an image 
file into segments and save it on a fixed disk (or network drive) for copying later to 
removable media.

4 Type a maximum size for each segment of the image file.

For example, if you want to create an image file on CDs, type 670000000.

5 Specify any other options for the new image file (such as a description, a password, or 
a compression level).

6 Click Copy.

When you copy an image file to a removable media device, you are automatically 
prompted for new media when media in a removable device is full.
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Combining Files that Make up an Image

If you select a file that is part of a split image (an image that is split across several files) 
and copy the file to a new image file, ImageExplorer automatically combines all the pieces 
of the image in the new Destination image. This feature is useful when you copy an image 
file stored on removable media to save a network directory or your hard disk.

You must ensure that the Split image into segments check box is not selected, or the new 
image file will be split at the specified size instead of combined into one file.

Adding a Password to an Image

1 Copy the image file to which you want to add a password from the Locate or Recent 
pane into the Locate pane.

The Copy to Image dialog appears.

2 Under ImageShield, click Set Password.

3 Type the password in the Password and Confirm password fields.

Do not include extended characters in the password. Also, passwords are 
case-sensitive. Store the password in a safe place, since you cannot copy, modify, 
restore, or change the password for a password-protected image file without knowing 
the assigned password. PowerQuest does not have a workaround to access 
password-protected image files if you lose the password.

4 Specify any other options for the new image file (such as a description, a compression 
level, or a split size).

5 Click Copy.

Compressing Image Files

1 Copy the image file you want to compress from the Locate or Recent pane into the 
Locate pane.

The Copy to Image dialog appears.

2 Under Compression Level, click the level of compression you want.

None No compression is usually the fastest method for saving the image 
file and is useful if storage space is not an issue. However, if you are 
saving your image file to a busy network drive or to a relatively slow 
removable media device, it may be faster to compress the image 
since there is less data to write to the file.
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3 Specify any other options for the new image file (such as a description, a password, or 
a split size).

4 Click Copy.

Adding or Changing an Image File Description

1 Copy the image file you want to add a comment for from the Locate or Recent pane 
into the Locate pane.

The Copy to Image dialog appears.

2 Under Description, type comments about the image file.

Comments cannot exceed 232 characters.

3 Specify any other options for the new image file (such as a password, a compression 
level, or a split size).

4 Click Copy.

Restoring Files or Partitions

You can use ImageExplorer to restore individual files or partitions from within an image 
file. You can restore individual files or folders from spanned or compressed images 
without restoring the entire image file.

1 From the Locate or Recent pane, double-click the image file that contains the partition 
with the files you want to restore.

2 (If applicable) Type the image file password, then click OK.

3 Double-click the desired partition.

4 Select the folder or files you want to restore.

5 Click File ➤ Restore.

You can also drag a file into the desired location to restore it or right-click a file and 
choose Restore from the quick menu.

Low Low compression offers a 40% average compression ratio.

High High compression offers a 50% average compression ratio.
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If you selected an image file that was created with an older version of Drive Image or 
ImageExplorer, a progress bar displays while the ImageExplorer expands the image 
index. To speed up the process with older image files, refer to “Working with Images 
from Previous Versions of Drive Image” on page 68.

6 Click To this destination, then specify the location where you want to save the 
restored files. Click the browse button to navigate to the location you want.

You can also click Restore to original path if you want to restore the folders or files 
to their original location. If the original location does not include a drive letter 
(because the partition was hidden when you imaged it), you must enter a drive letter 
for the partition before you can restore it.

7 Click Restore to restore the files.

8 When file restoration is complete, click OK.

9 Click Close to return to the ImageExplorer main window.

Working with Images from Previous Versions of Drive Image

If you restore files from an image that was created with Drive Image or Drive Image File 
Editor 3.0 or earlier, you can do one of the following to speed up the process. Note that 
these procedures are optional.

• Ensure that the index file (*.PQX) for the image is saved in the same directory where 
the image is saved. If ImageExplorer finds the index file in the same directory, it can 
use the index file instead of recreating it during the restore.

• If you do not have an index file for the image, you can use ImageExplorer to copy the 
image into a new ImageExplorer image.

Verifying Image Files

Use Verify Image to determine whether an image file is valid or corrupt. ImageExplorer 
will check to see that all of the files in the image are available for you to open, the internal 
data structures in the image file match the data that is available, and the image file can be 
uncompressed and will create the expected amount of data.

This feature is useful if you have added partitions to an image and want to verify the 
integrity of the image.

1 From the Locate or Recent pane, select the image file you want to check.
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2 Click File ➤ Verify Image.

3 When the check is complete, click OK.

You can also right-click an image file, then click Verify Image from the quick menu.

Deleting Image Files

Use Delete to remove an entire image file, including all partitions, folders, and files. If you 
delete an image file that resides on your local hard disk, it is sent to the Windows Recycle 
Bin.

1 From the Locate or Recent pane, select the image file you want to delete.

You cannot delete individual partitions or selected files or folders within an image 
file.

2 Click File ➤ Delete Image.

3 Click Yes to continue or No to cancel.

You can also right-click on an image file, then click Delete Image from the quick menu or 
delete the image using Windows Explorer.

IMPORTANT! If you use Windows Explorer to delete a split image, you must delete each 
segment of the image (such as myfile.pqi, myfile.002, myfile.003, and so 
forth). If you leave segments of an image file and later try to create an 
image with the same name, the image creation will fail.

Displaying Information About Images

1 From the Locate or Recent pane, select the desired image file.

2 Click File ➤ Properties, or right-click the image file and click Properties.

The following list describes each option in the Image Properties dialog.

Description A user-assigned comment associated with the image.

MS-DOS name A user-assigned name for the image.

Image size The total size of the image.
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3 Click OK to exit the dialog.

Displaying Information About Partitions

1 From the Locate or Recent pane, double-click the image file that contains the desired 
partition.

2 Select the partition you want.

3 Click File ➤ Properties, or right-click the partition and click Properties.

Image date/time The date and time that the image file was created.

Spanned Whether the image file is spanned over several disks or split 
into multiple segments.

Compression Whether the selected partition is compressed or 
uncompressed. The level of compression (Low or High) is 
also specified. Low level compression yields an approximate 
40% compression rate. High level compression yields 
approximately 50%.

Password 
Protected

Whether the image is password protected.

Display name A user-assigned name for the partition.

Description A user-assigned comment associated with the partition.

Drive letter The partition drive letter.

Type The file system type (for example, FAT, NTFS, or HPFS) 
used within the partition. 

Primary/Logical The selected partition's drive status as either primary or 
logical.

Partition size The total size of the partition. This total includes both used 
and unused space.

Used space in 
partition

The amount of used space within the partition.
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4 Click OK to exit the dialog.

Viewing Files within an Image File

PowerQuest ImageExplorer enables you to view files within an image file.

1 In the Contents pane, select the file you wish to view.

You can select multiple files to view.

2 Click File ➤ View File.

If you select an executable file (or a file with a .DLL, .COM, or .PIF extension), the 
View File command will be dimmed.

.BAT, .CMD, and .INF files will be opened with Notepad. Files that are registered 
will be opened with the registered application. Files that are not registered will 
display the Open with dialog.

You can also view a file by right-clicking it and choosing View File or by 
double-clicking the file.

ImageExplorer Options

You can specify a default restore path or a default size for image files. The default size is 
that size at which images will be split during a copy. This size will display in the Copy to 
Image dialog.

1 Click Tools ➤ Options ➤ General.

2 (Optional) Specify the full path to the default restore location.

This path is used if you do not initiate an image restoration using drag and drop or 
copy and paste.

Unused space in 
partition

The amount unused space within the partition.

Physical size in 
image

The actual size of the partition within the image file. This 
physical size may differ from the partition size depending 
upon the amount of used and free space within the partition 
and the compression level.
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3 (Optional) Specify the default byte size for splitting an image file.

For example, if you want to save the file to CD, you could specify a file size of 
670,000,000 bytes (650 MB) or less.

4 Click OK.

You can also specify filename extensions that will display in ImageExplorer as image 
files.

1 Click Tools ➤ Options ➤ Image Extensions.

2 Type the image file extension in the Extension text box.

File extensions can be up to three characters long and can contain alphanumeric 
characters. You do not need to type the period. It will be added automatically.

3 Click Add.

4 Repeat steps 2 and 3 to add more file extensions, or click OK.

All image files that match the extensions you have added to the list are displayed in 
the Locate and Recent panes.

To remove an extension, select it from the list box, then click Remove. To erase all 
extensions you have added, click Clear. Note that *.PQI cannot be removed from the list.

Online Help

1 Click Help ➤ Contents.

2 Select the help topic you want to display, or click Index or Search to search for the 
topic you want.

Exiting ImageExplorer

1 Click File ➤ Exit.

When you run ImageExplorer again, your previous view settings will be used.
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C H A P T E R8
PowerQuest DataKeeper
This chapter includes the following information:

• Getting Started

• Monitoring Your System

• Creating Custom Backups

• Mobile Support

• Restoring Backups

• Starting DataKeeper from a Windows Shortcut

• Getting Help

• Exiting DataKeeper
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Getting Started

PowerQuest DataKeeper provides an easy way for you to perform secure, automated 
backups of all your important data. You can back up to your local hard disk, a second 
partition that has an assigned file system (such as FAT32) and drive letter, a network drive, 
or removable media such as LS-120, Jaz, or Zip drives. You can use DataKeeper to:

• Back up combinations of files and folders on your computer with options such as 
password protection and file compression.

• Restore a single file (even from a compressed backup), a most recent version of a file, 
or an older version of a file.

DataKeeper System Requirements

Before you install DataKeeper, you should ensure your computer meets the minimum 
system requirements.

Installing and Configuring DataKeeper

The installation of DataKeeper involves two processes: 

• Install DataKeeper. If you are running Windows NT or Windows 2000, you must 
have adminstrator privileges to install DataKeeper. 

• Configure the backup locations. Following installation, when you run DataKeeper 
for the first time, you will need to specify the primary and substitute backup locations. 
If there are multiple users sharing a single computer (usually under Windows NT or 
2000), each user must run DataKeeper and set up their own primary and backup 
locations.

It is recommended that you use the program’s defaults to simplify the installation and to 
make file restoration easy and quick.

Operating system • Windows 95b (or later)
• Windows 98
• Windows Me
• Windows NT 4.0 Workstation (through Service Pack 6)
• Windows 2000 Professional
• DataKeeper is NOT supported under Windows XP.

Hard-disk space 4 MB

File Systems FAT, FAT32, or NTFS

Monitor VGA or higher resolution
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1 Insert the Drive Image CD into the CD-ROM drive.

2 Click Install DataKeeper in the installation browser, then follow the on-screen 
instructions to install the program.

3 When the setup is complete, deselect Yes, I want to launch DataKeeper, then click 
Finish.

If the DataKeeper setup window does not appear automatically on screen, you can install 
the program manually:

1 From the Windows taskbar, click Start ➤ Run.

2 Type D:\AUTORUN in the Open text box.

If your CD-ROM drive uses a letter other than D:, substitute that letter for D.

3 Click OK, then follow the on-screen instructions to install the program.

4 When the setup is complete, deselect Yes, I want to launch DataKeeper, then click 
Finish.

If you are a system administrator, you are finished installing the program; each user must 
now configure the primary and backup locations for their monitored files.

Configuring the Backup Location

The first time you start DataKeeper, you will be prompted to specify a primary and 
substitute backup location for your monitored files. If you click Cancel anytime before 
you complete the backup configuration, you will exit DataKeeper.

1 Start DataKeeper from the Windows taskbar.

2 Click Next.
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3 Type the full path to the primary backup location in the text box, then click Next. The 
primary location can be a fixed local hard disk, a network disk, or removable media 
such as LS120, JAZ, or Zip drives.

4 If the primary backup location you typed in step 3 is a fixed local hard disk, skip to 
step 5 below; you do not need to specify a substitue backup location.

5 Otherwise, type the path to the substitute backup location in the text box, then click 
Next. The substitute location must be a fixed local hard disk on your machine. If the 
primary backup location is unavailable, your files will be stored in this substitute 
backup location.

6 Click Finish.

7 It is recommended that you create an initial backup of your files. To do so, click Back 
up now.

8 You can now select to back up all files that meet the specified backup criteria (the 
default choice), or you can limit the backup to files that have been created or modified 
since the last backup or a specific date and time.

9 Click OK to begin the backup.

Monitoring Your System

DataKeeper is set up, by default, to monitor changes to all fixed drives on your system and 
to automatically create a backup of any file that you save to your hard disk. The program 
file directories, the directories specified by the environment variables Temp and Tmp, and 
your primary backup location, are excluded from the automatic backup to minimize 
backup time and system impact. If you want to back up these and other types of files, you 
can add them as described in “Creating Custom Backups” on page 77.

Monitoring, or automatic backup, remains in effect on your system as long as DataKeeper 
is running, or until you click Stop Monitoring from the Backup tab.

To restore a backed up file, see “Restoring Backups” on page 80.
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Creating Custom Backups

DataKeeper has many options, beyond the default settings, that let you customize how 
your data is backed up. You can even save all the options you select to a backup 
specification file (.DKS) for later use.

1 From DataKeeper, click the Backup tab. 

If necessary, click Stop Monitoring to access the backup options on the Backup tab.

2 Choose the following backup options:

Option: Description:

Select folders 
to monitor

In the Select folders to monitor group box, select the folders you 
want to monitor and back up.

Specify file 
types

In the Files to back up group box, click Specify File Types. 
Verify the file types you want to include in the backup (if they are 
found in the monitored folders), and the files types you want the 
backup to ignore.



Chapter 8: PowerQuest DataKeeper78

Specify file 
types 
(continued)

To move file types between the Backup Files Matching and 
Ignore Files Matching list boxes, select the files you want, then 
click the appropriate arrow (<< or >>) to move the files.

To add more file types to a list box, type *.<file extension> in the 
Add file type text box, then click << or >>.

To delete file types, select the extensions you want, then click 
Delete.

Backup 
location– 
Primary

In the Backup locations group box, verify the specified primary 
backup location. Or, click Browse to select a new location for the 
backup. The primary backup location can be a fixed local hard 
disk, a network disk, or removable media such as LS120, JAZ, or 
Zip disks. The word “(active)” will appear at the end of the option 
name “Primary” to indicate that the backup location is in effect. If 
the primary backup location becomes unavailable, the “active” 
status is applied to the substitute backup location.

Backup 
location– 
Substitute if 
primary 
unavailable

In the Backup locations group box, verify the specified substitute 
backup location if the primary location is unavailable, or click 
Browse to select a new substitute backup location on your hard 
disk. The word “(active)” will appear at the end of the option 
name if the primary backup location becomes inactive 
(unavailable). This helps you identify that the substitute backup 
location is in effect.

Number of 
versions to 
keep

In the Options group box, specify the number of backup versions 
(1-99) you want to keep. File versioning lets you go back to a 
previous backup if you have made an unwanted change to a file, 
or the current backup becomes corrupted. You should check the 
date and time of the backups to determine which version you 
want to restore.

Option: Description:
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3 (Optional) Save all the backup options you have chosen to a backup specification file 
(.DKS) for later use. Click File ➤ Save, type the filename for the backup specification 
file, then click Save. 

This step is helpful if you often select different options based on the type of data you 
are backing up. You can later retrieve the .DKS file for use with other backups you 
create. To retrieve the .DKS file, just click File ➤ Open, select the backup 
specification file you want, then click Open; all your backup options will be set.

4 It is recommended that you do an initial backup of your newly-customized backup 
set. To do so, click Back Up Now.

Keep 
daily/weekly/ 
monthly 
archive

In the Options group box, select Keep daily/weekly/monthly 
archive.

This option maintains archive copies, even if the number of 
copies has been exceeded. For example, if you specify that 
DataKeeper keep the last five versions of a backup, then you 
select Keep daily/weekly/monthly archive, DataKeeper does the 
following:

• Saves the most recent five versions of the specified files.

• Overwrites the five files in rotation, replacing the oldest file 
each time.

• Saves up to seven daily, five weekly, and 12 monthly archive 
copies in addition to the five most recent files.

• Does not create a daily, weekly, or monthly version of files 
that have not changed since the last backup.

Compress 
backup files

In the Options group box, select Compress backup files.

Compressing files during backup will use less hard disk space.

Lock backup 
files using 
password

In the Options group box, select Lock backup files using 
password, type the password you want in the Password and 
Confirm password text boxes, then click OK.

Passwords are case-sensitive. When you restore a 
password-protected backup, DataKeeper will prompt you for the 
password. If you do not enter the correct password, or you forget 
the password, you will not be able to open the backup file.

Option: Description:
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You can now select to back up all files that meet the backup criteria you specified (the 
default choice). Or, you can limit the backup to those files that have been modified 
since the last backup, or created or modified since a specific date and time.

5 Click OK to begin the backup.

6 After you have created an initial backup, click Start Monitoring to have DataKeeper 
run in the background and automatically back up files that are changed. 

The custom backup options you have selected remain in effect until you change them 
again.

Mobile Support

If you are using a laptop computer remotely and the primary backup location (a network 
disk) is unavailable when a backup is made, the files are automatically saved to the 
substitute backup destination. You can change the substitute location by clicking Browse 
to the right of the Substitute if primary unavailable text box in the Backup tab.

If the current backup location is the substitute destination, then at startup when monitoring 
is enabled and the primary location (a network disk) is detected, you are prompted to 
change your substitute backup location to the primary location. When you change to the 
primary location, any backup files are copied to the specified primary location and deleted 
from the substitute location.

If you choose not to change your substitute backup location to the specified primary 
location, you will be prompted with the same message when monitoring is restarted and 
the primary location is detected.

Restoring Backups

You can restore backed up individual or multiple files or folders in one simple operation.
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1 From DataKeeper, click the Restore tab.

2 Select the backup location, then click OK.

If you only have files at one backup location, skip this step and go to step 3.

3 Select the files, folders, and drives you want to restore.

4 Select Only display most recent version to list only the most recent backed up 
version of each file. Deselect the option to see all file versions. You can only restore 
those items that you have backed up using DataKeeper.

5 Select the destination folder or drive from the drop-down list, or click Browse to 
select the destination folder you want. 

If you do not specify a destination folder, the items will be restored to their original 
locations.

6 Click Restore to begin file restoration.

Viewing Versions of Backups

1 From DataKeeper, click the Restore tab, then go to the backup location.
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2 Check the Tag and Version columns of the Contents pane. You may need to scroll to 
the right to see the columns. The Version column displays the following information:

• D - Daily backup
• W - Weekly backup
• M - Monthly backup

The Version column is blank for files that are not archived files.

The tag values in the Tag column (for example, aa, ab, or ac) are unique identifiers and are 
unrelated to the sequence or age of the backup.

Starting DataKeeper from a Windows Shortcut

When you start DataKeeper from a Windows shortcut on the desktop, DataKeeper will 
automatically run the backup specification file that you name. You may find it helpful to 
create a shortcut for each backup specification file that you have saved.

1 Follow the Windows online Help instructions for creating a shortcut on your desktop.

2 In the Command line field of the Create Shortcut dialog, enter the full path to the 
DataKeeper program (DATAKEEPER.EXE).

3 (Optional) At the end of the full path (to the right of the double quote mark) in the 
Command line field, add one or more of the following commands described below.

The order that you add each command line option is not important.

Command Line Options

Be sure you replace [*.DKS] with the name of your actual backup specification file.

Command 
Line option: Description:

[*.DKS] Starts DataKeeper and loads the backup specification file you named. 
Example:

"C:\Program Files\DataKeeper\DataKeeper.exe" C:\My 
Backup Specs\Manuals.dks

-c [*.DKS] Starts DataKeeper, loads the backup specification file you named, and 
starts monitoring. Example:

"C:\Program Files\DataKeeper\DataKeeper.exe" -c 
C:\My Backup Specs\Manuals.dks
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Getting Help

When you need information beyond what this user guide provides, online Help is your 
best solution. Click Help in any dialog in DataKeeper, or click Help ➤ Help Topics on 
the menu bar.

Exiting DataKeeper

1 From DataKeeper, click File ➤ Exit.

This will close DataKeeper, and no files will be backed up.

-r [*.DKS] Starts DataKeeper, loads the backup specification file you named, 
performs a backup, then exits DataKeeper. Example:

"C:\Program Files\DataKeeper\DataKeeper.exe" -r 
C:\My Backup Specs\Manuals.dks

-a Use with the -r option. Starts DataKeeper, loads the backup 
specification file you named, performs a backup of all selected files, 
then exits DataKeeper. Example:

"C:\Program Files\DataKeeper\DataKeeper.exe" -r -a 
C:\My Backup Specs\Manuals.dks

-m Use with the -r option. Starts DataKeeper, loads the backup 
specification file you named, performs a backup of those files that 
were modified since the last backup was performed, then exits 
DataKeeper. Example:

"C:\Program Files\DataKeeper\DataKeeper.exe"-r -m 
C:\My Backup Specs\Manuals.dks

-s=“date” Use with the -r option. Starts DataKeeper, loads the backup 
specification file you named, performs a backup of only those files that 
were modified after the date you specify, then exits DataKeeper. The 
date must be in quotes and formatted as follows:-s=“yyyy/mm/dd 
hh:mm:ss.” Example:

"C:\Program Files\DataKeeper\DataKeeper.exe"-r C:\My 
Backup Specs\Manuals.dks -s="2000/07/25 9:15:00"

Command 
Line option: Description:
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Clicking the “–” near the upper-right corner of the DataKeeper window will minimize the 
program to the Windows system tray.
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A P P E N D I XA
Additional Tasks
This appendix includes the following information: 

• Using Drive Image with SCSI Hard Disks

• Using Drive Image with Drive Overlay Software

• Using Drive Image on a Notebook Computer

• Using Drive Image with a Castlewood ORB Drive

• Assigning a CD-ROM Drive Letter

• Editing the Virtual Floppy Disk

• Using International Keyboards

• Finding Jumper Settings
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Using Drive Image with SCSI Hard Disks

To use Drive Image on a SCSI hard drive, you must have a SCSI controller card that 
supports software Interrupt 13. Most SCSI controller cards let the user enable software 
Interrupt 13 support in the BIOS through the card. If your SCSI controller card does not 
allow you to set it to use software Interrupt 13, Drive Image will not work on drives 
attached to your SCSI adapter. Contact the manufacturer of the SCSI adapter to determine 
if your adapter can support software Interrupt 13. As a general rule, if FDISK can be used 
to partition the drive, you can use Drive Image.

Using Drive Image with Drive Overlay Software

Drive overlay software is needed, such as Disk Manager or EZ-Drive, if the system has an 
older BIOS and the disk copy is being made from IDE to IDE or IDE to SCSI. 

IMPORTANT! If copying SCSI to SCSI, the older BIOS does not come into play because 
SCSI has its own translation mechanism. 

This section provides information on both IDE and SCSI hard drive installations. The 
following are scenarios which outline, step-by-step, the installation procedures for a 
variety of system configurations. Each scenario assumes that all the bulleted items listed at 
the beginning apply for the system configuration. To ensure you are choosing the right 
procedure, choose the scenario that matches your system configuration completely.

Scenario 1
• The system has a BIOS that does not support drives over 504 MB in size.

• The source drive is an IDE drive that is smaller than 504 MB. It does not have a drive 
overlay program.

• The destination drive is an IDE drive that is larger than 504 MB and needs to have a 
drive overlay program to be recognized by the older BIOS.

Steps

1 Install the destination drive as the master and the source drive as the slave and run the 
auto-detect in the BIOS.

2 Restart the computer with the drive overlay boot disk.

3 Install the drive overlay program to the destination drive that is now set as the master 
(check with manufacturer).
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4 Restart the computer again, allowing the drive overlay program to load.

5 Put your Drive Image bootable diskette in your diskette drive (A:).

6 In the drive overlay boot menu, select the option to boot from a floppy disk.

7 Make sure that Drive Image is showing the correct size for each drive and the correct 
order for the copy sequence.

8  Finish the copy process.

Scenario 2
• The system has a BIOS that does not support drives over 504 MB in size.

• The source drive is an IDE drive larger than 504 MB and a drive overlay program is 
loaded.

• The destination is a SCSI drive and will not need a drive overlay program.

Steps

1 Leave the source drive set as the master.

2 Install the SCSI drive with the lowest SCSI ID in the SCSI chain.

3 Run the BIOS auto-detect and make sure it recognizes the IDE drive.

4 Run the SCSI BIOS to make sure the SCSI drive is recognized correctly.

5 Restart the computer and allow the drive overlay program to load. 

6 Put your Drive Image bootable diskette in your diskette drive (A:).

7 In the drive overlay boot menu, select the option to boot from a floppy disk.

8 Make sure that Drive Image is showing the correct size for each drive and the correct 
order for the copy sequence.

9 Finish the copy process.

Scenario 3
• The system has a BIOS that does not support drives over 504 MB in size.

• The source drive is an IDE drive larger than 504 MB and a drive overlay program is 
installed.



Appendix A: Additional Tasks88

• The BIOS is upgraded to a BIOS that supports larger drives.

• The destination drive is a SCSI drive that is larger than 504 MB.

Steps

1 Leave the source drive set as the master.

2 Install the destination drive and set it as drive 0.

3 Run the BIOS and auto-detect the drives.

4 Make sure that LBA is off for the source drive.

5 Run the SCSI BIOS to make sure the SCSI drive is recognized correctly.

6 Restart the computer and allow the drive overlay program to load. 

7 Put your Drive Image bootable diskette in your diskette drive (A:).

8 In the drive overlay boot menu, select the option to boot from a floppy disk.

9 Make sure that Drive Image is showing the correct size for each drive and the correct 
order for the copy sequence.

10 Finish the copy process.

Scenario 4
• The system has a BIOS that does not support drives over 504 MB in size.

• The source drive is an IDE drive larger than 504 MB and a drive overlay program is 
installed.

• The BIOS is upgraded to a BIOS that supports larger drives.

• The destination is an IDE drive that is larger than 504 MB.

Steps

1 Set the source drive as the master.

2 Set the destination drive as the slave.

3 Run the new BIOS and auto-detect the drives.

4 Make sure that LBA is turned on for the destination drive and off for the source drive.
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5 Restart the computer and allow the drive overlay program to load. 

6 Put your Drive Image bootable diskette in your diskette drive (A:).

7 In the drive overlay boot menu, select the option to boot from a floppy disk.

8 Make sure that Drive Image is showing the correct size for each drive and the correct 
order for the copy sequence.

9 Finish the copy process.

Using Drive Image on a Notebook Computer

To make PCMCIA slots on a notebook computer active for use with Drive Image, you 
must load the correct drivers in DOS.

1 Determine the correct card services DOS driver for your hardware.

The driver is supplied by the hardware manufacturer. It may be called card services, 
card-bus services, CardWare, or another name chosen by the manufacturer. Consult 
the hardware documentation or contact the manufacturer if you do not know which 
driver is required.

2 Add a statement to your CONFIG.SYS file to load the card services driver.

For example, DEVICE=PCMI80CL.SYS.

There may be additional switches to configure the device. The hardware manufacturer 
can provide detailed information.

3 Add a statement to your CONFIG.SYS file to load the NIC or SCSI driver you need.

For example, DEVICE=C:\3COM\EL589ND4.SYS.

Using Drive Image with a Castlewood ORB Drive

To use a Castlewood ORB drive with Drive Image, the drive must be correctly configured 
in the computer BIOS so that DOS can assign it a drive letter and read and copy large files 
to and from the drive. Drive Image recognizes the ORB drive as removable media only if 
the computer BIOS can be configured to recognize the drive as removable media.
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Refer to your ORB drive owner’s manual, or contact Castlewood Systems, Inc. 
(www.castlewood.com or help@castlewood.com) for more information about configuring 
the ORB drive for use under DOS.

Refer to www.powerquest.com/support/orb for more information about using Drive Image 
with an ORB drive.

Assigning a CD-ROM Drive Letter

If your computer has a CD-ROM drive or any form of removable media, you should be 
aware of potential problems with the way drive letters are assigned to these devices.

Drive Image does not make drive letter assignments; this is a function of the operating 
system. The operating system assigns drive letters in the following order: The first 
recognized primary partition on each hard disk will receive a letter, followed by all logical 
partitions on each hard disk. Next, the CD-ROM drive and any other form of removable 
media will be assigned a letter.

Because the CD-ROM is one of the last drives to receive a letter, any partitions that you 
create or delete on any of your hard disks will affect the drive letter assignment of your 
CD-ROM drive. This change in drive letter assignments is usually performed by the 
operating system automatically. Occasionally, however, the operating system will fail to 
assign a new drive letter to the CD-ROM drive. If this should occur, please follow the 
steps:

If you are using DOS/Windows 3.11 or are loading your CD-ROM drivers under DOS 
with Windows 95, perform the following:

1 At a DOS prompt, type EDIT C:\CONFIG.SYS.

This starts the DOS editor program and opens your CONFIG.SYS file. 

2 Change LASTDRIVE=drive (in which drive is any letter of the alphabet) to Z.

This allows the OS to assign all drive letters through Z.

3 Click File ➤ Exit.

4 Click Yes to save the file.

5 You should now be back to a C:\ prompt. Type EDIT C:\AUTOEXEC.BAT.

The DOS editor program starts and opens your AUTOEXEC.BAT file. 
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6 Look for a line that includes the word MSCDEX. The /L:drive parameter (in which 
drive is the drive letter that was assigned to your CD-ROM before you made changes 
with Drive Image) may appear at the end of this line. Change this letter to Z. 

Because the OS assigns all other available drive letters before assigning Z, this 
ensures that partition changes you make in the future will not invalidate your 
CD-ROM drive letter. 

For more information, type HELP MSCDEX at a DOS prompt.

If your computer is on a network, when you log in to the network the letter Z and 
other letters at the end of the alphabet may be assigned to network search drives. In 
this case, assign your CD-ROM a letter just before the first letter used by the network 
search drives.

7 Select File ➤ Exit. When you are asked whether you want to save the file, click Yes.

8 When you see the DOS prompt (C:\), reboot your machine.

If you are using Windows 95 and Windows 95 drivers for the CD-ROM:

1 Click Start ➤ Settings ➤ Control Panel ➤ System.

2 From the System Properties screen, select Device Manager.

This brings up a list of the devices in your computer. 

3 Double-click CDROM.

4 Click the Settings tab.

5 At the bottom of the Settings page is the heading, Reserved Drive Letters. Under 
this heading are two listings, Start Drive Letter and End Drive Letter. Change the 
values for these listings to Z. 

Because the OS assigns all other available drive letters before assigning Z, this 
ensures that partition changes you make in the future will not invalidate your 
CD-ROM drive letter.

6 Click OK to close the Settings page. 

7 Click OK to close the System Properties page.

8 Click Yes to restart your computer.
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Editing the Virtual Floppy Disk

You may wish to modify the Virtual Floppy disk to include custom information, such as 
required drivers. Be aware that PowerQuest cannot support customized virtual boot disks. 
However, you can modify the Virtual Floppy with a utility like PowerQuest VF Editor, 
which is included on the Drive Image CD.

For information about VF Editor beyond what is included in this user guide, refer to the 
VF Editor online help.

1 Click Start ➤ Programs ➤ PowerQuest Drive Image 5.0 ➤ VF Editor.

2 Open the Virtual Floppy file.

The default Virtual Floppy file, DEFAULT.VFD, is located in the VFD folder in the 
Drive Image install directory.
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3 Drag the file you wish to change to your desktop, then right-click it and choose Edit.

To add a custom driver that is not currently included in the Virtual Floppy file, drag 
the file into the VF Editor window, then go to step 7.

4 Make any changes you want.

5 Save the file, and exit the text editor.

6 Drag the edited file back into the VF Editor window.

7 Click Yes twice to overwrite the current file.

8 (Optional) To update more than one file within the Virtual Floppy, repeat steps 3 - 7 
as needed.

9 Click File ➤ Save to save the modified Virtual Floppy.

10 Exit PowerQuest VF Editor.

Using International Keyboards

When you use the Drive Image rescue disks, you may lose the ability to use your keyboard 
the way you are accustomed to or to view extended characters properly. The Drive Image 
rescue disks include the files you need to resolve these problems.
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If you use an international keyboard or character set, you must edit the AUTOEXEC.BAT 
and CONFIG.SYS files on the rescue disks.

1 The following lines are remarked in the AUTOEXEC.BAT file. Delete the REM from 
the beginning of the line, and replace the variables xx and yyy with the keyboard 
code and character set code page for your language.

MODE CON CP PREP=((yyy)EGA.CPI)
MODE CON CP SEL=yyy
KEYB xx,yyy

xx = two-letter keyboard code (for example, US or FR)
yyy = character set code page (for example, 437)

2 Save the AUTOEXEC.BAT file.

3 The following line is remarked in the CONFIG.SYS file. Delete the REM from the 
beginning of the line, and replace the variable yyy with the character set code page 
for your language.

DEVICE=DISPLAY.SYS CON=(EGA,yyy,)

4 Save the CONFIG.SYS file.

5 Reboot from the first rescue disk.

Finding Jumper Settings

To find the jumper settings for hard disks, consult your hard disk installation guide or 
contact your hard disk manufacturer directly. In most cases, the hard disk manufacturer's 
web site will contain the information you need to install the hard disk correctly.

Another valuable resource is www.thetechpage.com. In addition to listing the most 
common hard disk manufacturers, this site provides the jumper settings for every hard disk 
ever made. Additional jumper information is available from OnTrack at www.ontrack.com. 
Please note that PowerQuest is not responsible for the content on these web sites and 
cannot guarantee that the web site addresses will not change.
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A P P E N D I XB
Setting Up Removable Storage 
Devices
This appendix includes general information about using removable storage 
devices with Drive Image. It also describes removable media device drivers 
included with Drive Image and how to manually install them on a hard drive or 
diskette.

Both the Drive Image install program (for Windows) and the MAKEDISK.BAT 
file (for OS/2 and DOS) install and configure the drivers for removable storage 
devices. This information is provided for those who want to manually configure 
these drivers or alter the standard configuration. For more information about 
MAKEDISK.BAT, see “Installing on an OS/2 or DOS-Only Computer” on page 
5.

Using Removable Media with Network Clients

If you are using a Jaz or Zip parallel port device with a network client, be aware 
that loading a parallel port device driver with a network client installed will cause 
the system to hang. To successfully install the device driver for the parallel drive, 
reboot the system without loading the network client.

BIOS Settings for Removable Media

Removable media devices must be set up in the BIOS as removable devices, or 
Drive Image will not enable the media spanning feature for images that are larger 
than one removable media.
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Iomega Drivers

Iomega provides a driver loader program that allows you to load drivers from the 
AUTOEXEC.BAT file. Each time the Iomega driver program loads, it must also load an 
ASPI manager to communicate with the Zip or Jaz drive. The Drive Image install program 
copies a large set of ASPI managers to the DRIVERS directory for SCSI, IDE, and 
parallel port interfaces.

The Iomega driver program tries to load each ASPI manager until it finds one that 
matches. If it does not have to use this trial-and-error process to find the correct ASPI 
manager, it can load more quickly.

Iomega has not provided a DOS driver for their Zip drives that attach to a USB (Universal 
Serial Bus) port. Consequently, you cannot create or restore image files to a Zip drive that 
is attached to a USB port.

You can access a document, "Using Drive Image with Iomega Removable Drivers," at the 
PowerQuest support web site. Go to support.powerquest.com, and query "Iomega." This 
document is available in English only. For additional information about Iomega drives, 
refer to the install diskettes that came with your Iomega product or the Iomega web site 
www.iomega.com.

Editing Your GUEST.INI File

If you use only one or two specific host adapters, you may want to edit the GUEST.INI file 
and remark (using the REM command) the ASPI managers you do not need. This way 
only the ASPI managers you normally use will be loaded and tested.

1 From the DRIVERS directory where you installed Drive Image, locate the 
GUEST.INI file and open it using Notepad in Windows, DOS EDIT, or any other 
ASCII text editor.

2 Find the ASPI manager line for the Iomega driver that supports your drive. For 
example, if you routinely use an Iomega PC1616 adapter, use the line that reads 
ASPI=ASPI1616.SYS.

The following table lists the supported Iomega Adapters and their corresponding 
ASPI managers.   

Iomega Adapter ASPI Manager

Jaz jet PCI (PC/Mac model) ADVASPI.SYS

Jaz jet (PC-only model) ASPI8DOS.SYS

Jaz jet ISA ASPIPC16.SYS
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If you are using a non-Iomega SCSI adapter with the SCSI Zip drive, the SCSI 
adapter must be ASPI-compatible and an ASPI manager must be obtained from the 
SCSI adapter manufacturer.

3 Add a REM at the beginning of each ASPI manager line you do not want to load.

For example, in a case where the Zip or Jaz drive is connected to an Iomega PC1616 
adapter, you would remark all ASPI manager lines except ASPI1616.SYS:

REM ASPI=ASPIPPM1.SYS /INFO FILE=NIBBLE.ILM SPEED= 1

REM ASPI=ASPIIDE.SYS /INFO

REM ASPI=ASPI8DOS.SYS /D

REM ASPI=ADVASPI.SYS

REM ASPI=ASPIPC16.SYS INFO

ASPI=ASPI1616.SYS /SCAN /INFO

4 Save the changes to the GUEST.INI file and exit the text editor. If you are using a 
word processor, be sure to save the file as ASCII or DOS text.

If you later need to use an ASPI manager which has been remarked, edit the 
GUEST.INI file again and remove the REM command at the beginning of the ASPI 
manager line.

ASPI Manager Reference

Detailed reference information on the ASPI managers used by the Iomega driver program 
is located in the electronic "Installation Manual" (MANUAL.EXE) on the Iomega 
installation diskette.

1 For either Windows or DOS, go to a DOS prompt, type A:, then press <Enter>.

2 Type MANUAL, then press <Enter>.

Jaz Traveller ASPIPPM1.SYS

Parallel Port Zip drive ASPIPPM1.SYS

Zip zoom SCSI Accelerator ASPIPC16.SYS

Zip Card PCMCIA SCSI adapter ASPIPC16.SYS

Zip IDE drive ASPIIDE.SYS

PC1616 adapter ASPI1616.SYS

PC1600 adapter ASPIPC16.SYS

Iomega Adapter ASPI Manager
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Assigning Specific Drive Letters for Iomega Drives

To specify the first drive letter you want the Iomega drive to use, add the LETTER= option 
to the command line. For example, if you type GUEST.EXE LETTER=G, then G will be 
assigned to the first supported drive it finds.

If you have more that one Iomega drive, each additional drive will receive a drive letter 
following G in alphabetical order. (When supporting more than one drive, drive letters are 
assigned in order of SCSI ID number, from lowest to highest.)

Magneto-Optical Disk Drives

The  3.5-inch Magneto-Optical (MO) drive is available with either a SCSI or ATAPI 
interface. Separate DOS device drivers are supplied for each interface type. The device 
driver supports the FAT (File Allocation Table) file system, read/write, and disk change 
status.

The SCSI device driver requires a SCSI host adapter card and its matching ASPI manager 
software. For more information, see the “List of ASPI Managers and Supported Adapters” 
on page 100 and your SCSI host adapter documentation.

The 3.5-inch Magneto-Optical disks are available in several capacities.

The volume format may be Super floppy, AT Hard disk, or NSR format. The driver 
automatically detects the volume format and assigns logical drive letters (such as D:). If no 
valid formats or partitions are detected, the device driver identifies the disk as 
unformatted. See the driver documentation supplied with the product for additional 
information about formatting MO disks.

Installation of Magneto-Optical Drivers

The ATAPI MO device driver is loaded in the CONFIG.SYS file using the following 
command:

DEVICE[HIGH]=(path)\MODISKAP.SYS [/P][/Ii][/Rr]

The SCSI MO device driver is loaded in the CONFIG.SYS file using the following:

DEVICE[HIGH]=(path)\ASPIXXX.SYS
DEVICE[HIGH]=(path)\MODISK2.SYS [/P][/Ii][/Rr]

ASPIXXX.SYS represents the ASPI manager that matches your SCSI host adapter.



PowerQuest Drive Image 99

Optional Switches

/P

Pauses screen messages after the driver has been loaded and initialized. Press any key to 
continue the operation. Use this option to check the messages displayed by the driver.

/Ii ATAPI driver

Only the device connected to port IDE i is mounted. Otherwise, all ports are scanned MO 
devices. 

i is defined as:

1 = Primary Master
2 = Primary Slave
3 = Secondary Master
4 = Secondary Slave

/Ii SCSI driver

Only the SCSI device with ID i is mounted. Otherwise all SCSI IDs are scanned. To also 
specify the host adapter number, enter /Ih:i (h is the host adapter number and i is the 
SCSI-ID). To specify multiple devices, use the “+” character as a delimiter. For example: 
/I0:1+1:2

/Rr

Reserves the specified number of logical drive letters (r=1 to 10) for a single drive. 
Otherwise, a single drive letter is reserved. The number of reserved drive letters is 
independent of the number of disk partitions. The driver can access only as many 
partitions as the number of reserved drive letters.

If the inserted disk contains more partitions than specified by the /r option, as many drive 
letters are assigned to the disk drive as there are defined partitions. If the disk has fewer 
partitions than the number of drive letters reserved, an error occurs only when the driver 
attempts to access the additional drive letters.

LASTDRIVE

The CONFIG.SYS last drive command does not affect the drive letter assignment in the 
MO disk drive. If the driver assigns a drive letter higher than the one specified by the 
LASTDRIVE command (default is E:), the CD-ROM drive cannot be accessed. To enable 
access to the CD-ROM drive, specify a larger value in the LASTDRIVE command.
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If the following conditions exist, the device driver will not be loaded into memory and the 
message “Driver not loaded” will display.

• No ASPI manager loaded
• Cannot find MO drive (with or without a disk inserted)
• Driver already loaded

IMPORTANT! The SMARTDRV cache is turned off by default for MO disk drives. If you 
attempt to write data to a write-protected disk while the SMARTDRV 
write cache is on, you will need to reset the computer.

You can read more about Magneto-Optical disk drivers from the install diskettes that came 
with the product and from the Fujitsu web site www.fujitsu.com.

List of ASPI Managers and Supported Adapters

The following is a list of several popular ASPI managers and the cards they support. Drive 
Image will use the ASPI manager you install to support your SCSI card.

ASPI8DOS.SYS
PCI Bus

Adaptec AHA-2910A/2910B
Adaptec AHA-2930A/2930B
Adaptec AHA-2940/2940AU/2940W/2940U/2940UW
Adaptec AHA-2944W/2944UW
Adaptec AHA-3940/3940U/3940W/3940UW
Adaptec AVA-2904, AVA-2902E/I
Adaptec AIC-7850/7855/7860/7870/7880 based SCSI host adapters
Jaz jet (PC-only model)

ASPI7DOS.SYS
EISA Bus

Adaptec AHA-1740/1742/1744
Adaptec AHA-1740A/1742A
Adaptec AHA-2740/2742/2740T/2742T
Adaptec AHA-2740A/2742A/2740AT/2742AT
Adaptec AHA-2740W/2742W
Adaptec AIC-7770 based SCSI host adapters

VL BUS
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Adaptec AVA-2825
Adaptec AHA-2840VL/2842VL
Adaptec AHA-2840A/2842A

ASPI4DOS.SYS
ISA Bus

Adaptec AHA-1540B/1542B
Adaptec AHA-1540C/1542C
Adaptec AHA-1540CF/1542CF
Adaptec AHA-1540CP/1542CP
Microchannel  Adaptec AHA-1640

ASPI2DOS.SYS
ISA Bus

Adaptec AVA-1502P/AP
Adaptec AVA-1505
Adaptec AVA-1515
Adaptec AHA-1510/1520/1522
Adaptec AHA-1510A/1520A/1522A
Adaptec AHA-1510B/1520B/1522B
Adaptec AHA-1530P/1532P
Adaptec AVA-1502AE/AI, AVA-1505AE/AI, AVA-1505AES
Adaptec AIC-6260/6360/6370 based SCSI host adapters
Adaptec AVA-1502AE/AI, AVA-1505AE/AI, AVA-1505AES

MCAM18XX.SYS
PCI Bus

Adaptec AHA-2920/2920A

MA160.SYS
If needed, add this adapter to the ASPI manager lines in your GUEST.INI or 
LDSQSCSI.BAT files.

ISA Bus

Trantor T160
Microchannel  Trantor T260

MA348.SYS
If needed, add this adapter to the ASPI manager lines in your GUEST.INI or 
LDSQSCSI.BAT files.
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Parallel Port Trantor MiniSCSI Plus (T348)
Adaptec MiniSCSI Plus (APA-348)

MA358.SYS 
If needed, add this adapter to the ASPI manager lines in your GUEST.INI or 
LDSQSCSI.BAT files.

Parallel Port Trantor MiniSCSI EPP (T358)
Adaptec MiniSCSI EPP (APA-358)
Adaptec MiniSCSI EPP (APA-358A)

ASPIIDE.SYS
IDE

SCSI to IDE ASPI Manager
Zip IDE drive

ASPIATAP.SYS

SCSI to ATAPI ASPI Manager

ASPIPPM1.SYS and ASPIPPM2.SYS

SCSI to Parallel Port Zip Drivers
Jaz Traveller

ASPIEDOS.SYS

Adaptec AHA-1740/1742/1744 (in Enhanced Mode only)

ASPIPC16.SYS

PC1600 adapter Zip Zoom SCSI Accelerator
Adaptec APA-1460 and other AIC-6260/5360 based adapters
Jaz jet ISA adapter
Zip zoom SCSI Accelerator
Zip Card PCMCIA SCSI adapter

ASPI1616.SYS

PC1616 adapter and other NCR-53C406A based adapters

ASPI2930.SYS

AHA-2930 adapter
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A P P E N D I XC
Troubleshooting
This appendix gives solutions to problems that you may encounter 
while using Drive Image. Included are the following:

• Accessing Your CD-ROM Drive

• Freeing Conventional Memory to Run Drive Image

• Resolving Check Errors

• Resolving Partition Table Errors

• Partition Tables and Viruses

• Generating Diagnostic Reports with PARTINFO

• Error Messages and Solutions
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Accessing Your CD-ROM Drive

If you need to access your CD-ROM drive from Drive Image, you will need to add the 
command in the CONFIG.SYS file to load your CD-ROM driver. You will also need to 
add the command in the AUTOEXEC.BAT file to load the CD-ROM extensions.

1 At the DOS prompt, change to the directory of the CONFIG.SYS you want to edit. 
For example, if you are editing the CONFIG.SYS on a boot diskette, type drive: 
(where drive is the drive letter of the boot diskette), then press <Enter>.

2 Type EDIT CONFIG.SYS and press <Enter> to start the DOS Editor and retrieve 
the CONFIG.SYS file.

3 Add either the DEVICE or DEVICEHIGH command. For example, type

DEVICE=[drive:][path]filename [dd-parameters]

or

DEVICEHIGH=[drive:][path]filename [dd-parameters]

where [drive:][path]filename specifies the location and name of the CD-ROM device 
driver and [dd-parameters] specifies any command-line information the device driver 
requires.

You may want to use DEVICEHIGH if you need to conserve conventional memory. See 
“Freeing Conventional Memory to Run Drive Image” on page 105.

For more information on your device driver, consult the documentation that came 
with your CD-ROM.

4 Click File ➤ Save to save the file.

5 Click File ➤ Open and retrieve the AUTOEXEC.BAT file.

6 Add the command line MSCDEX.EXE.

7 Click File ➤ Save to save the file.

8 Click File ➤ Exit to exit the editor.
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Freeing Conventional Memory to Run Drive Image

The Drive Image executable running under DOS requires a minimum of 400KB of 
memory in the first 640KB of the computer's address space (conventional memory). If you 
try to run Drive Image from DOS and find you do not have enough free conventional 
memory, you can free enough additional memory in a number of ways.

Running MEMMAKER

MEMMAKER is a program that automatically configures your computer to save 
conventional memory (while still loading all of the device drivers and other programs you 
usually load when booting DOS). MEMMAKER frees conventional memory by moving 
as many programs as possible out of conventional memory into high memory. Run 
MEMMAKER by typing MEMMAKER at a DOS prompt. Follow the on-screen 
instructions.

MEMMAKER is only available with DOS versions prior to DOS 6.0. MEMMAKER is 
not available with Windows 95.

Using the F8 Key to Keep Programs From Loading

If running MEMMAKER does not free enough conventional memory, you can free more 
by pressing <F8> right after booting your computer (while DOS is booting). If you press 
<F8>, when DOS reads the commands from the CONFIG.SYS and AUTOEXEC.BAT 
files on your hard drive, DOS will ask you if you want it to execute each command. When 
you see commands that load device drivers or TSR programs that you will not need to run 
Drive Image, answer N (no) to tell DOS not to execute that command (not load that 
software into memory). This will conserve conventional memory. 

Creating an Operating System Boot Diskette

If running MEMMAKER and using <F8> does not free enough conventional memory, you 
can create a boot diskette that allows you to boot using a very minimal amount of 
conventional memory.

You can create a boot diskette for any version of DOS by performing the following:

1 Place in your diskette drive (A:) any diskette that does not contain information you 
want to keep. 

2 Go to a DOS prompt, type FORMAT drive: /S (where drive is the drive letter of 
the diskette drive).

3 Press <Enter>.
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After the diskette is formatted and the operating system files are transferred, you will be 
able to boot the computer from the diskette. If you restart your computer with the diskette 
in the diskette drive, your computer boots using a minimal amount of conventional 
memory. After you boot from the diskette, you can run Drive Image from either the 
diskette or your hard drive. 

If you want to create and restore images across a network, you will need to create a 
network boot diskette.

Creating a CONFIG.SYS File on the Boot Diskette

If making an ordinary boot diskette doesn't free enough conventional memory, you can 
create a customized boot diskette that will free even more conventional memory. (With the 
customized diskette, you will free more conventional memory by loading some of the 
DOS operating system into high memory.) To customize the diskette, you must create a 
CONFIG.SYS file in the root directory (A:\). To create a CONFIG.SYS in the root 
directory, perform the following:

1 At the DOS prompt, type drive: (where drive is the drive letter of the diskette 
drive), then press <Enter>. 

Verify that you have changed to the diskette drive (you see the drive:\> prompt).

2 Type EDIT CONFIG.SYS and press <Enter>. 

This starts the DOS editor. (You will see a blank screen if no CONFIG.SYS currently 
exists.)

3 In the editor, type the following:

DEVICE=C:\DOS\HIMEM.SYS

DEVICE=EMM386.EXE

DOS=HIGH,UMB

IMPORTANT! All lines must be entered in the order shown. Windows users: 
substitute DEVICE=C:\WINDOWS\HIMEM.SYS.

4 Click File ➤  Save to save the file. 

5 Click File ➤ Exit to exit the editor.

You can now reboot your computer from the customized boot diskette. When DOS loads, 
much of it is loaded into high memory, saving a maximum amount of conventional 
memory.
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Deleting Operating System Compression Files

If you use DOS 6.22 and your system doesn't have any compressed drives (for example, 
DriveSpace, DoubleSpace, or Stacker), you can free conventional memory by deleting the 
operating system compression files DRVSPACE.BIN or DBLSPACE.BIN from any boot 
diskette you create. To delete these hidden system files, perform the following:

1 From the DOS prompt, type drive: (where drive is the drive letter of the diskette 
drive).

2 Type ATTRIB -R -H -S *.BIN.

3 Type DEL *.BIN.

Resolving Check Errors

Drive Image checks the integrity of a partition very thoroughly prior to creating an image 
file or copying a partition. These checks are substantially the same as those made by the 
operating system's CHKDSK, SCANDISK, or AUTOCHK utility.

If you receive a Check error message for any partition, after backing up your hard drive, 
run your operating system's CHKDSK program on that partition. CHKDSK usually shows 
the same problems as Drive Image. (If you are using Windows NT CHKDSK, DO NOT 
use the /F switch on the initial run.)

Run SCANDISK if you have MS-DOS 6.x or Windows 95. 

The DOS CHKDSK program does not detect problems in Extended Attributes.

If CHKDSK (or SCANDISK) does not show the same errors that Drive Image shows, 
contact PowerQuest at the numbers listed in Appendix D. If the CHKDSK (or 
SCANDISK) program and Drive Image detect the same errors (which is usually the case), 
run CHKDSK with the /F switch to fix the problem. 

After running CHKDSK /F, run CHKDSK without the /F switch to make sure the partition 
is free of errors. Under OS/2, you should perform this procedure twice before proceeding. 
If Drive Image still reports a problem, reformat the partition and restore your files from the 
backup copy to correct the error.

Drive Image also checks a partition after restoring it. If this check fails, report the problem 
to PowerQuest Technical Support. The problem is usually a minor file system error that 
CHKDSK /F can correct without data loss. For more extensive errors, you may need to 
restore your files from a backup copy.
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Resolving Partition Table Errors

In some cases, PowerQuest technical support can help you fix partition table errors 
without data loss. Check with them first before proceeding to the following steps.

To resolve some partition table errors, you must create new, error-free partition tables.

1 Make sure you have no viruses. 

See “Partition Tables and Viruses” on page 108.

2 Back up the data on the affected partitions.

3 Delete the partitions.

You may need to use the FDISK program from a recent DOS version because earlier 
versions of DOS may refuse to delete HPFS or hidden partitions.

If using OS/2, the OS/2 FDISK program may recognize the partition's corruption and 
refuse to modify it. In this case, use the FDISK program from a recent DOS version.

4 Recreate the partitions.

5 Restore the contents of the partitions. 

Partition Tables and Viruses

If partition changes made under one operating system are not reflected under the other, 
and vice versa, it is possible that a master boot record (MBR) virus is present.

Use a virus check utility that can detect the latest viruses. If a virus is found, data loss is 
likely. If a virus is found, perform the following:

1 Before removing the virus, run ScanDisk or CHKDSK under each of the operating 
systems to evaluate the integrity of the partition. 

2 Back up the files from any partition that passes the Check operation.

3 After backing up the files from all operating systems, remove the virus.

4 Run ScanDisk or CHKDSK under each of the operating systems again.

5 Delete and recreate any partitions which fail the check. 

6 Reinstall the operating systems.
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7 Restore the backup files as necessary.

Generating Diagnostic Reports with PARTINFO

PARTINFO, a PowerQuest utility program included on the Drive Image CD, generates a 
report showing the contents of your hard disk partition table. This information is helpful in 
resolving various partitioning problems. 

1 Boot the computer to DOS.

2 Change to the directory that includes PARTINFO.EXE.

3 You have several options for running PARTINFO. 

PowerQuest support technicians may request a report from PARTINFO to help you 
resolve any problems that you experience with Drive Image.

Error Messages and Solutions

For a list of error messages and solutions in English, run Setup, then click Documentation 
➤ Error Documentation on the Drive Image CD, or go to the PowerQuest Knowledge 
Base at support.powerquest.com.

To do this: Do this:

To display partition 
information on your screen

Type PARTINFO, then press <Enter>.

To send a report directly to 
your printer

Type PARTINFO >LPT1 or PARTINFO 
>PRN, then press <Enter>.

To save the report as a text file 
on a floppy disk

Type PARTINFO >A:\PARTINFO.TXT, then 
press <Enter>.
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A P P E N D I XD
PowerQuest Technical Support

Before Contacting Technical Support

PowerQuest is committed to providing you with comprehensive technical 
support. However, before contacting our technical support department, please try 
to resolve your problem by using this guide, the online help for the application 
you are using, the README file, and PowerQuest’s corporate web site.

Tips
• Your problem may be resolved by applying the most recent patch or upgrade 

of the software. You can go to www.powerquest.com/updates to see if there 
are updates to the software.

• PowerQuest technical support engineers may request information from the 
PARTINFO utility program to help you resolve problems with Drive Image 
Pro. See “Generating Diagnostic Reports with PARTINFO” on page 109.

• Your product serial number is required to obtain technical support.

Term of Technical Support

Technical support is available to all registered users throughout the life of the 
product, which began when PowerQuest released the product to manufacturing 
and ends six months after the release of the next version or when PowerQuest 
discontinues development of the product.
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Upon registration, PowerQuest provides 30 days of complimentary technical support from 
the day of your first call. In addition, registered users are eligible for special upgrade 
pricing when PowerQuest releases a new version of Drive Image. Contact PowerQuest 
Customer Service for additional information about upgrade pricing.

Contact Information

Corporate Web Site

The PowerQuest web site support.powerquest.com includes technical support information, 
including answers to frequently asked questions (available in English only), an overview 
of support options, and explanations for error messages.

E-mail

To obtain e-mail technical support for specific technical questions, you should fill out the 
form at support.powerquest.com/emsupport.html (available in English only).

Fax

Fax a description of your problem to the technical support fax number. This service is 
available in the U.S., Canada, and Europe 24 hours a day, 7 days a week. PowerQuest 
technicians try to respond to all fax requests within 24 hours.

Language E-mail Address

English support@powerquest.com
eurots@powerquest.com

French france@powerquest.com

German germany@powerquest.com

Italian italian@powerquest.com

Location Number

U.S.A. (801) 437-4218

Europe +31 (0)20 581 9270

http://support.powerquest.com
http://support.powerquest.com/emsupport.html


PowerQuest Drive Image 113

Telephone

The U.S.A. call center is open Monday through Friday from 7:00 a.m. to 6:00 p.m., 
MST/MDT. The European call center, located in the Netherlands, is open Monday through 
Friday from 9:00 to 18:00, CET.

Postal Service Mail

Include a detailed description of your problem and a return address, a daytime phone 
number, or other relevant contact information.

Language Location Number

English Netherlands +31 (0)20 581 3906

English UK +44 (0)20 7341 5517

English U.S.A. (801) 226-6834

French France +33 (0)1 69 32 49 30

German Germany +49 (0)69 66 568 516

Italian Italy +39 (0)2 45 28 1312

USA Europe

PowerQuest Corporation
P.O. Box 1911
Orem, Utah 84059-1911
U.S.A.

PowerQuest Customer Service
P.O. Box 58287
1040 HG
Amsterdam, Netherlands
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Numerics
1024 cylinder boundary, indicators displayed for  56

2 GB boot code boundary, indicators displayed for  56

A
accessing a CD-ROM drive with Drive Image  104

accessing CD-ROM drive  104

active partition  60

adapters for ASPI managers  100

advanced options
copying disk to disk  53
creating images  30
QuickImage  14
restoring images  41

arrows displayed on partition map  56

arrows on partition map  56

ASPI managers
list and supported adapters  100
reference  97

automatic backups with QuickImage  15

automatically resize partitions proportionally to fit  49

B
backing up data with DataKeeper  73

bad sectors, checking for  54

benefits of registering PartitionMagic  111

BIOS, computers with older  86

boot diskettes
creating a CONFIG.SYS  106
creating a system diskette  105
creating rescue diskettes for Drive Image  5
using  105

C
card-bus services  89

Castlewood ORB drive  89

CD-R support  23

CD-ROM
accessing drive  104
drive letter, assigning  90,  104

check errors  109

checking for file system errors  30,  53

checking image integrity after creating an image  31

CHKDSK  107

command line options, DataKeeper  82

common partition management tasks  55

compressing image files  27,  66

compression
deleting OS files  107
level  27

CONFIG.SYS, creating on the boot diskette  106

configuring hardware  22

contact information for technical support  112

continuous backup  73

conventional memory  105

copying disk to disk  43
advanced options  53
resizing partitions  48

creating
boot disks  105
extending partitions  56
QuickImage definitions  12

creating image files  11,  21,  23
advanced options  30
on CD-R  23
verifying image integrity  31
with Drive Image DOS  21
with QuickImage  11

D
DataKeeper  73

command line options  82
creating custom backups  77
installing and configuring  74
mobile support  80
monitoring your system with  76
online help  83
restoring backups  80
system requirements  74

decreasing time needed to copy  54

definitions, QuickImage
creating  12
deleting  14
opening  14

deleting
compression files  107
image files  69

Index
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partitions  57
QuickImage definitions  14
scheduled QuickImage tasks  19

device drivers, installing  6
diagnostic reports, generating with PARTINFO  109

disabling SmartSector copying  30,  53

disk access errors  109

Disk to Disk feature for upgrading hard disks  43

disk, copying  43

diskettes, creating image files on  31

displaying drive information  56

DOS drivers, loading for PCMCIA cards  89

DOS, running Drive Image from (using rescue 
diskettes)  5

downloading, see restoring image files
Drive Image

using computers with older BIOS  86
using with SCSI hard disks  86

Drive Image (DOS)
partition management  55
why run the DOS version of Drive Image  6

Drive Image File Editor
see ImageExplorer

drive letters
assigning for Iomega  98
assignment by operating system  90

drive overlay software  86

drivers
installing for removable devices  6
removable storage devices  95

drives, displaying information  56

dynamic disks  2

E
editing files  61

error messages  109

estimating image file size  27

extended partitions, creating  56

F
F8 Key, to keep programs from loading  105

FAT check errors  109

files
managing  61
viewing from within an image file  71

FireWire CD-R drives  23

free space, leave remaining  49

Fujitsu drivers, installing  6

G
GoBack compatibility with Drive Image  7
GUEST.INI, edit  96

H
hard disks

jumper settings  94
SCSI  86

help, online  9
ImageExplorer  72

help, technical support  111

hidden partitions, creating images on  26

hidden partitions, restoring images from  35

hiding partitions  58

hiding partitions after copying  54

HPFS check errors  109

I
IDE CD-R and CD-RW drives  23

image file size, estimating  27

image files
compressing  27,  66
creating  11,  21,  23
deleting  69
deleting OS compression files  107
hardware configurations  22
restoring  33
restoring from CD  34
spanning media  29
verifying  68

ImageExplorer  61
password protection  66
preferences (options)  71
system requirements  61
verifying images with  68

ImageShield  31,  66

information, displaying for drives  56

installing
DataKeeper  74
Drive Image  4
removable device drivers  6
see also restoring image files
uninstalling  9

international keyboards  93

Internet technical support  112
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Iomega drivers  96
ASPI managers  97
assigning drive letters  98
cannot see Zip drive attached to USB port  96
editing GUEST.INI  96
installing  6

J
Jaz drivers  96

Jaz drivers cause Drive Image to hang  95

jumper settings  94

K
KEYB.COM  93

keyboard, navigating with the  9
keyboards, international  93

L
laptop computers, using Drive Image on  89

leave remaining free space  49

M
Magneto-Optical drives  98

installing drivers for  6
management tasks

image files  61
ImageExplorer  61
partitions  55

manually resizing partitions  49

markers on partition map  56

MEMMAKER  105

memory
freeing by not loading programs  105
required to run Drive Image  2

menu, Tools  55

MO drives  98
installing drivers  6

modifying scheduled QuickImage tasks  18

mouse, disabled  9

N
new features  1
NIC drivers for PCMCIA cards  89

notebook computers, using Drive Image on  89

NTFS check errors  109

NTFS partitions, creating images on  26

NTFS partitions, restoring images from  35

NTFSINI.EXE  22

O
online help  9

DataKeeper  83
ImageExplorer  72

opening QuickImage definitions  14

operating systems
boot diskettes  105
deleting compression files  107
for install  4

ORB drive  89

overlay software on older computers  86

P
PARTINFO program  109

partition map  56

partition table errors, resolving  108

partitions
common management tasks  55
deleting  57
hiding  58
hiding after copying  54
information displayed on screen  56
resize manually  49
resizing  37,  48
resizing automatically to fit available space  49
setting active  60
table errors  109

passwords, adding to image files  31,  66

PCMCIA cards, using with Drive Image  89

PowerQuest contact information  112

PowerQuest web site  112

preferences, ImageExplorer  71

preparing to run Drive Image  7
prerequisites to running Drive Image  7

Q
QuickImage  11

advanced options  14
creating definitions  12
deleting definitions  14
deleting scheduled tasks  19
modifying scheduled tasks  18
opening definitions  14
restoring images from  19
scheduling tasks  15
shortcuts  18
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why run QuickImage  6

R
removable media

Castlewood ORB drive  89
Iomega  96
MO drives  98
setting up for use with Drive Image  95
using with network clients  95

removable storage devices, installing drivers  6,  95

requirements  2
rescue diskettes

creating  5
limitations under Windows NT/2000  5
running Drive Image from  8

resize options  41,  49

resizing partitions  37,  48

resizing partitions on the destination drive  49

resizing partitions proportionally  49

restoring image files  33
advanced options  41
from CD  34
resize options  41
resizing partitions  37
using QuickImage  19

restoring images from hidden partitions  35

running Drive Image
from a floppy diskette  8
from a hard drive  8
preparation  7

running Drive Image, preparation for  23

S
saving images to hidden partitions  26

scheduling QuickImage tasks  15

SCSI CD-R drives  23

SCSI hard disks  86

security, adding passwords to images for  31

setting active partition  60

setting up removable storage devices  95

shortcut, creating QuickImage  18

size of image files, estimating  27

sizing partitions  48

skip bad sector check  54

SmartSector copying, disabling  30,  53

spanning images across media  31

spanning media  29
BIOS settings required  95

speeding up copy time  30,  53

splitting image file into multiple files  31

support, term of  111

system requirements
DataKeeper  74
Drive Image  2
ImageExplorer  61

T
technical support  111
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e-mail  113
fax  112
mail  113
online help  9
telephone  113
web site  112

Tools menu  55

triangles displayed on partition map  56

troubleshooting  103
accessing CD-ROM drive  104
can’t use mouse to navigate or choose 

commands  9
creating a CONFIG.SYS on boot disks  106
creating boot disks  105
creating rescue disks to run Drive Image  5
deleting OS compression files  107
Drive Image doesn’t recognize Castlewood 

ORB drive  89
Drive Image hangs when I run it  95
Drive Image hung after I clicked Finish  7,  34
generating diagnostic reports with PARTINFO  

109
I cannot overwrite existing segments of an old 

image file  69
keep from loading programs  105
my CD-R drive isn’t recognized  23
my CD-ROM doesn’t have a drive letter  104
my image file won’t span media  95
running MEMMAKER  105
tips  111
using operating system boot disks  105
Windows NT won’t boot  22

U
unallocated space, leave remaining  49

uninstalling Drive Image  9
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upgrading your hard disk  43

USB CD-R drives  23

USB port, cannot use Zip drive attached to  96

user files, backing up with DataKeeper  73

V
verifying disk writes  30,  54

verifying image files  68

verifying image integrity
advanced options  31
before restoring an image  35

VF Editor  92

viewing files within an image file  71

virtual floppy disks, editing  92

virus detection  7,  34

W
Windows 2000 Professional  2

limitations of rescue diskettes under  5
Windows NT

copying partitions  22
creating images on hidden NTFS partitions  26
limitations of rescue diskettes under  5
restoring images from hidden NTFS partitions  

35

Windows NT workstation  2
Windows, creating backups from  11

Z
Zip drives

cause Drive Image to hang  95
drivers  96
See also Iomega drivers
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PowerQuest Documentation Feedback

If you would like to provide feedback on the Drive Image documentation, please complete this 
survey and fax it to (801) 437-4480, or e-mail your comments to doc@powerquest.com. Thank 
you for your feedback.

PowerQuest product and version:

1. How do you rate the quality of the documentation? (1=Poor - 5=Excellent)

Accuracy 1   2   3   4   5

Completeness 1   2   3   4   5

Ease of use 1   2   3   4   5

2. How can PowerQuest improve the documentation?

3. What do you use the most to get answers? What do you use least?

User guide-printed

User guide-PDF

Online Help

Readme

Another user

Web site (knowledge base)

Technical support

4. What do you use to find what you are looking for in the documentation?

User Guide
Find (PDFs only)
Quick Reference Guide
Other

Online Help
Table of Contents
Index
Search
Other
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