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“ For ease-of-use and basic accounting,
QuickBooks can’t be beaten.”**

Computer Shopper

BUSINESS MANAGEMENT SOFTWARE

Guaranteed Set-Up
30-day free support from time of registration.

FREE

Manage your business with
the QuickBooks edition
that’s right for YOU!
QuickBooks comes in different editions, all designed to suit
the type and size of your business. Whichever edition you
choose, QuickBooks will:
� SAVE YOU TIME
� PROVIDE COMPLETE CASHFLOW MANAGEMENT
� INCLUDE SUPERB BUSINESS MANAGEMENT TOOLS
� BE CUSTOMISED FOR CERTAIN INDUSTRY SECTORS

QuickBooks 2004 — the next generation of
business management software.

For more information about the complete QuickBooks range:
� Visit www.quickbooks.co.uk
� Phone 0845 606 2161
� Or visit your local PC dealer
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System requirements
To use TaxCalc, your computer must
meet the following minimum
requirements:
� IBM PC compatible
� Pentium processor (Pentium II

recommended, 300 MHz for
Windows® XP)

� Windows® 98/ME/2000/NT4/XP
� 16 MB of RAM (32 MB recommended,

128 MB for Windows® XP)
� 40 MB of hard disk space
� Bubblejet or laser printer
� SVGA monitor
� 800 x 600 minimum resolution
� 256 (or better) colour display
� CD-ROM drive
� Internet connection to file online or

obtain software updates (LiveUpdate)

Registration
If you purchased TaxCalc directly from
Intuit, you are automatically a 
registered user.

If you purchased TaxCalc from a retail
store, you can register for free support
by returning the enclosed pre-paid
registration card or online at
www.taxcalc.com. To receive TaxCalc
automatically each year, select the Auto-
Renewal option on the card or the web
form.

30 minutes or your money back
If your return takes you more than 
30 minutes to do, we will refund your
purchase price (excluding postage 
and packing). For full details, see
www.taxcalc.com/30_min_
challenge.html.

License
The full license agreement appears
during installation of TaxCalc and at
www.taxcalc.com/eula.html.

Completing the installation of TaxCalc
indicates your acceptance of all the
terms in the license agreement.

Copyright
©2004, TaxCalc print and electronic
documentation is copyrighted to Intuit
Ltd. All rights reserved. Unauthorised
duplication is prohibited without the
express permission of Intuit Ltd. Crown
copyright forms are reproduced with the
permission of the Controller of Her
Majesty’s Stationery Office and the
Queen’s Printer for Scotland. The Inland
Revenue leaflets are reproduced in
TaxCalc 2004 by permission of the
Board of Inland Revenue.
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Make the most of TaxCalc 
� You can now prepare up to six indivi-

dual tax returns for family members,
making TaxCalc even greater value!

� File returns electronically
(recommended), or print and submit
approved paper forms.

� Even if you do not need to file a tax
return, you can check whether or not
you have paid too much tax.

Live Update
This is the simple way to update your
program over the Internet. We are
refining Live Update to minimise the
download time.

TaxCalc 2004 and 2003 
The 2004 edition of TaxCalc includes
TaxCalc 2003 so that you can still
access your 2003 return, or, if you 
are one of the 10% who missed the
January 31, 2004 filing deadline,
you can still use it to prepare your 
2003 return.

Feedback
We are very grateful to everyone who
completed our in-product survey or who
otherwise gave us feedback on TaxCalc
and how we can make it even better.

While we cannot respond to each
comment individually, we read and value
all feedback and continue to use it to
improve the program.

When you file your return, you will have
the opportunity to complete a survey.
Alternatively, you can email us at
support@taxcalc.com or write to: 

TaxCalc Feedback, Intuit Ltd 
PO Box 2234, Maidenhead, SL6 8WQ

Important If you use TaxCalc to
prepare returns or to provide tax
information or advice for payment, you
must use TaxCalc Pro. Upgrade online
by selecting Help > Upgrade.
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Introducing TaxCalc 2004

TaxCalc has been widely praised (www.taxcalc.com/accolades) for its ease-of-use
and value, and is popular for securing quick rebates and ensuring you pay only the
correct tax. We continually improve the program in response to your feedback while
retaining the familiar, easy-to-use interface.
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What’s New
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Help with online filing
registration
EasyStep helps you to obtain and store
your Inland Revenue User ID and
password. If the Inland Revenue ever
changes the registration process,
LiveUpdate will make sure TaxCalc can
handle the change.

Rounding
Choose to round figures in your tax
return.

Change your mind later and the actual
figures are restored. See the difference
rounding (or any other what-if scenario)
makes in the Monitor at the bottom 
of the window.

More calculation detail
EasyStep includes extra summaries for
employment and self-employment
income, partnership trade entries and
the calculation of capital gains.

Partners
Import details of partnership income
directly from the partnership return
statement to each partner’s individual
tax return. Select Import data from
SA800 in the Tasks panel.

Jump to a specific box
Enter a box number or a form number in
the Go field and press <Enter> to jump
to that box. In the Forms mode, the Go
field is at the top of the Forms list, on
the left side of the screen. Press <F4>
to move the cursor into the Go field.

Printing
TaxCalc automatically provides a print
preview of your return and finds the
optimum printer settings for your
computer and printer.

CHANGE OF ADDRESS Don’t miss out
on TaxCalc 2005 just because you
move! Use the enclosed, pre-paid
change of address card to give us your
new address.
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Filing online
The ease, speed and accuracy of online
filing are proving very popular with our
users.

This year, we are providing more help
with Inland Revenue registration and the
storage of your User ID and password
(see page 13 for details).

The Inland Revenue has eased some of
its restrictions (see Help for details),
including allowing more capital gains
disposals. TaxCalc now also logs and
saves all filing submissions to your hard
drive.

More returns = more value
Prepare up to six individual returns to
cover all your family’s needs.

Plus, you don’t need to have received a
tax return in order to check whether or
not you paid the correct tax. Just enter
the details into TaxCalc and check the
result.

TaxCalc 2004 includes 2003
For your convenience, we have included
TaxCalc 2003 as part of TaxCalc 2004.

Quicken XG 2004
Import details of investment income
directly from Quicken XG 2004, when
released.

EXTENDED SUPPORT HOURS During
January 2005, we will offer support
between 9 a.m. and 8 p.m., Monday to
Friday, and 10 a.m. to 4 p.m. on
Saturdays (see page 18 and check
www.taxcalc.com for changes to
support hours).

Even easier Help 
Our support has always been of a high
quality and now it is even easier to get.

Select Help > Contact Support to
email a system “snapshot” and/or your
tax file to our support team. Visit our
website or telephone our support team
(see page 17 for details).

Find help with online filing directly from
the filing window.

Display previous-year entries
When you bring forward a file from
2003, move your cursor over the field to
display the previous-year entry.

PARTNERSHIPS If you need to prepare
a partnership tax return (form SA800),
upgrade online. Connect to the
Internet, go to Help > Upgrade to
purchase the partnership return for
£19.99. 



The paperwork you’ll need
Use the following list to help you gather
the paperwork you need to complete
your return. EasyStep includes a full
checklist. The list below contains the
most common items.

EMPLOYMENT
� P60 form showing your pay and 

tax paid if you were employed on 
April 5, 2004

� P45 form showing your pay and tax
paid if you left your place of
employment before April 5, 2004

� P11D form showing the employment
benefits (such as a company car) 
you received

INLAND REVENUE FORMS
� P2 forms (tax code notices) for the

2003-2004 and 2004-2005 tax years
� Any statements of account
BUSINESS INFORMATION
� If you are self-employed, the accounts,

or records of income and expenditure,
for your business

� If you are a partner in a business, a
copy of your partnership statement
(from the partnership tax return)
showing your profit or loss

BENEFITS AND PENSIONS
� P45U or P60U for any incapacity

benefit or job seeker’s allowance
� Amount of state pension received
� P60 forms for any occupational

pension
� Statement of the amount received and

tax paid for any other pension 

INVESTMENTS AND SAVINGS
� Details of share options exercised

during the year
� Tax vouchers for dividend income
� Bank statements or summaries

showing interest earned and tax paid
� Record of payments into a personal

pension (such as a pension or 
FSAVC certificate)

� Details of the cost, proceeds and
expenses for any asset sold

Register with the Inland Revenue
We recommend filing online.
Registration can take three to five days
but EasyStep will help you to do this.

Rounding and filing method
To receive the best advice as you enter
information, select the filing method
before you start entering information
(see page 13). Also decide whether 
or not you want to round your entries
(see page 7).

Installation
To install TaxCalc from the CD:
1Close all other programs running,

including anti-virus software.
2 Insert the TaxCalc CD into your CD-

ROM drive.
3 The installation program should run

automatically. If not, use Windows
Explorer to browse to your CD-ROM
drive and double-click the file called
tcsetup.exe.

4Follow the on-screen instructions to
install TaxCalc.

Following installation, please take a
minute to read the ReadMe file as it
may contain important late-breaking
information.

If you close the ReadMe file without
reading it, you can open it again 
by clicking on the Windows® Start
button and selecting All Programs 
> Intuit > TaxCalc 2004 > TaxCalc
2004 Readme.

Uninstall TaxCalc 2003
Since TaxCalc 2004 includes the 2003
tax return, you can uninstall TaxCalc
2003 if you wish. This will not affect
your saved tax files.

Click on the Windows® Start button and
select All Programs > TaxCalc 2003 
> Uninstall TaxCalc 2003.

LiveUpdate
We occasionally provide updates to
TaxCalc, so as to add new features,
incorporate legislative changes and to
comply with changes in the Inland
Revenue online filing system.

LiveUpdate regularly checks to see if
there is an update available from our
website.

To turn off automatic LiveUpdate,
remove the checkmark next to Help >
LiveUpdate.

You can check at any time (providing
you are connected to the Internet) 
by selecting Help > Check for 
updates now.
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Installation and updates Before you start
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Which return should I use?
SA100 INDIVIDUAL TAX RETURN
If you received a self-assessment tax
return (SA100), you must submit one.
You may claim any repayment within the
SA100; but do not use the R40 return
to claim it.

R40 REPAYMENT RETURN
Use this if you are not required to
complete a self-assessment return and
you regularly receive repayments, such
as those for a non-working spouse or a
minor child with investment income.

SA800 PARTNERSHIP RETURN
While TaxCalc Standard 2004 includes
the partnership page (SA104) required
for the individual return, you will also
need to file a partnership return
(SA800). Select Help > Upgrade to
purchase a partnership return.

Personal representatives and
Executors 
To complete a return for someone who
has died, enter the capacity in which
you are completing the return (executor
or personal representative) and the date
of death.

If the death occurred before 
April 6, 2004, TaxCalc produces a return
as normal.

If the death occurred after April 5, 2004
and before April 6, 2005, TaxCalc adds
the period to which the return applies to

at the top of each page. This allows you
to finalise any tax liability and the
administration of the estate without
having to wait until April 6, 2005.

We recommend you leave the Inland
Revenue to calculate the tax, as the
rates, allowances, etc. may differ from
the 2003-2004 tax year. The calculation
within TaxCalc will therefore only
indicate the approximate tax due or
amount refundable.

EasyStep, Forms and Dual 
TaxCalc offers three different ways to
complete your return: 
� Use EasyStep if you have no tax or

computer expertise. It will guide you
through completing your return.

� Use the Forms mode if you are
confident enough with the Inland
Revenue return forms, to know where
to enter information into your return.

� Use the Dual display to view EasyStep
in the top half of the window and the
forms in the bottom half.

Click the buttons on the toolbar to
switch between EasyStep, Forms and
Dual modes.

10

Using TaxCalc
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New users
If you are using TaxCalc for the first time,
we recommend you use EasyStep to
guide you through completing your
return with “as-you-type” advice.

Answer each question or enter the
required amount on each screen.
EasyStep only asks you for information
relevant to your tax situation.

On the Start screen, select Create a
new 2004 return (see page 10 to find
out which return you should use).

Use the Previous and Next buttons to
move from one step to the next. The
panel on the right side of your screen
tracks your progress through the return.
Click on the name of a step to jump to
that step.

HELP PANEL
In EasyStep, the Help panel at the
bottom of the window offers advice
relating to the step you are on. Click
More Help to read detailed information.

Previous users
BRING FORWARD YOUR 2003 FILE
Save time this year by bringing forward
information from your 2003 return 
into 2004.

TaxCalc transfers information such as
your name, address and employment
details to the new return. The only
amounts brought forward are items you
need for 2004, such as losses.

View last year's entry by moving your
cursor over any tan coloured field.
TaxCalc will also show the amount by
which this year’s entry varies from last
year.

11

New and previous users
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Filing online
More and more people are using
TaxCalc to benefit from filing online.

Why should I file online?
� Get immediate confirmation that the

Inland Revenue received your tax
return and agrees with the calculation
of tax.

� Receive your repayments within three
to five days (typically).

� Avoid the risk of an Inland Revenue
transcription error, unlike with paper
returns.

� TaxCalc calculates your tax, which is
then agreed by the Inland Revenue,
so you will not be one of the 5% of
taxpayers (more than 450,000) 
whose tax bill the Inland Revenue
miscalculates.

� Connect for only a matter of seconds
to the Inland Revenue system, using
the highest level of encryption
available (the same as online
banking).

� Save costs and protect the
environment by using less paper.

� View your statement of account on the
Inland Revenue website.

� Choose to have your tax collected
through your tax code between April
2005 and March 2006, if you file
online by December 30, 2004, and
owe less than £2,000, and have a
PAYE tax code. Otherwise, you must
pay the tax in a lump sum by January
31, 2005.

NOTE TaxCalc transmits only
information entered into tax return
fields. No memos, notes or other
information are sent to the 
Inland Revenue. 

Registration
Use TaxCalc to register to file online with
the Inland Revenue.

After you register, you will receive an
Activation PIN through the post. Make
sure you use this PIN to activate your
enrolment to the filing service within 28
days. Otherwise, you will need to obtain
another PIN.

TaxCalc stores your User ID and
password and helps you obtain
replacements if you misplace them. You
can change your password on the Inland
Revenue website.
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Electronic filing
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The Forms Navigator provides access to
all TaxCalc forms. It is only visible when
you are in Forms mode. Use it to:
� view tax summaries and calculations
� open the return forms and working

sheets
� see which forms already contain

information
� display a lists of tasks associated with

a particular form

Open a form
Click the plus symbol (+) beside a form
category (for example, Employment) to
display all the forms in that category.
Click the name of a form to open it.

Click the Navigator button on the
toolbar to open and close the Forms
Navigator and increase the area of the
forms you can see.

Status indicator
When the status indicator to the left of
the form icon is:
� RED, the form contains errors or

provisional entries
� GREEN, the form is error-free

Task list
The Task list on the left side of the
window (in Forms mode) allows you 
to carry out tasks related to the
information you are entering.

Tabs
In Forms or Dual mode, each form
opens on a tab at the top of the
window. Click on the tabs to move
between open forms.
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Automatic print settings 
Print your return on A4 paper, in portrait
orientation. TaxCalc automatically
detects the optimum settings for your
computer and printer. TaxCalc will ask
for confirmation before it changes the
existing settings. It may take two or
three attempts.

Print Setup
To manually change print settings, select
File > Print Setup.

Increase the left and right margins to
shrink forms to fit on a page.

In most cases, we recommend that you
allow TaxCalc to select the optimum
settings.

If you have problems with printing,
select Help > Contact Support and
send us a system snapshot together
with the description of the problem.

If you choose to file on paper rather
than online, TaxCalc prints the required
set of approved forms, according to your
personal tax situation.

TaxCalc supports duplex printing to
minimise the amount of paper you use.

Printing
To print your complete tax return, select
File > Print.

TaxCalc first checks to see if there are
any outstanding audit messages you
need to resolve.

If TaxCalc finds outstanding messages,
click the Cancel button to stop printing.

Click on the Forms button and press
<F9> on the keyboard to jump to the
first message and related field on the
tax return, or click on the Auditor button
to see the list of messages. Once you
resolve the audit messages, select
File > Print.

If there are no outstanding messages,
the Print Selection dialog box list
shows you what will print. By default
TaxCalc prints one copy for your 
records and one for you to send to the
Inland Revenue.

Click the +/- symbols to display or hide
a detailed list of forms. Select or clear
checkboxes next to the forms to change
which forms print.

WARNING To ensure you file a
complete return, we recommend you do
not change the automatic selection of
forms in the copy for the Inland
Revenue. 

Printing a single page or form
� Select File > Print and choose which

pages or forms to print in the Print
Selection dialog box; or 

� Right-click on a form, and select Print
and then the pages you wish to print.
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Paper filing Print setup
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TaxCalc includes resources to answer
your questions about the program or
about your tax return requirements.

Help as you work
In EasyStep, the Help panel provides
assistance as you work. Click More Help
for additional information.

In the Forms mode, press <F1> from
any form to display help related to the
form you are currently viewing.

Online TaxCalc Help
To access online help, select 
Help > Contents.

Click the Tax Help button for tax-
related assistance. Click the Program
Help button for assistance with using
the software.

Frequently Asked Questions
We provide answers to frequently asked
questions (FAQs) at www.taxcalc.com.
From the Help menu in TaxCalc, select
TaxCalc website. Check the Support
menu on the website for the latest
software news.

Contact Support
Select Help > Contact Support to get
quick and free support.

Send us an email with a snapshot of
your system or attach a tax file to your
email. No personal information is sent
in a snapshot — you can verify the
contents of this snapshot by opening
the email attachment. All tax files are
treated with absolute confidentiality and
deleted as soon as any issue is
resolved.

Before sending, you can remove
personal details from your file by ticking
the “Anonymise my tax return” box.
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TaxCalc helps you review your return
before you file it, according to the filing
method you chose (online or paper).

Choose between two ways to review your
return:
� The Check tab in Easy Step lets you

view each audit message and circles
the related entry in red. Type in the
field to correct the entry or click the
Sign-off button if you feel it is correct.

� In Forms mode, click <F9> or the
Auditor button on the toolbar to open
the Auditor at the bottom of the
window.

� Double-click on a message to jump to
the related entry. Type in the field to
correct the entry or right-click on the
message and select the Sign-off
button if you feel it is correct.

Signing off a message
While some messages are not critical
when filing by paper, they may prevent
you from filing online. For example, the
length of an employer’s name may print
correctly on a form but may be too long
for the Inland Revenue online filing
system.

Once you sign off an audit message, you
will not see it again. Always try to
correct an entry rather than sign-off.

WARNING Only sign off on an audit
message when you are certain that it
will neither affect your return or your
ability to file it. 

Sign your return!
If you are filing by paper, do not forget
to sign your return on page 10. This is
one of the most common reasons for
the Inland Revenue rejecting a return.

Page 10 also contains a list of the
forms you must submit with your return.
Check that you have all those forms and
that they printed correctly.
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TaxCalc Standard 

Use Help > Contact Support to email
your question, system snapshot and tax
file question.

You can also contact us by telephone
between 9 a.m. and 5:30 p.m., Monday
to Friday (excluding bank holidays).

TaxCalc Pro
Includes priority support. Select Help >
Contact support for the priority email
address and telephone number.

TaxCalc Lite 2004 
Support is provided by email only at
support@taxcalc.com.

Extended support in January
2005
Between January 3 and 31, 2005, we
will be open from 9 a.m. to 8 p.m.,
Monday to Friday and from 10 a.m. to 4
p.m. on Saturdays.
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Contact us

In addition to resources listed on page 17, check the our website www.taxcalc.com
for the latest news.

Sleep better when you use TaxCalc to do your tax return.
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Why not try the new Quicken today?
For immediate savings, subscribe online
www.quicken.co.uk or call the order hotline
0845 0755 058.

The FASTEST and EASIEST way
to manage your money.
� Easy to learn and use
� Customisable for your unique needs
� Integrated with online services

Take control of your
personal finances
in as little as 5 minutes with NEW Quicken!
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