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About TestTrack Pro

Introduction
About TestTrack Pro

Welcome to TestTrack Pro!
You have an important job to do - deliver a quality product on time and within budget. And, whether 
you are developing, testing, fixing bugs, or managing the team, you do not have time to learn another 
complex application. TestTrack Pro helps you control your bug tracking process. Design a complex 
tracking structure, or simply install the software, and start tracking the TestTrack Pro way!

In this section:

About the guide, 2

Conventions used in the guide, 3

Before you start, 4

Contacting Seapine support, 4
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About the guide
Using TestTrack Pro provides step-by-step instructions for all the tasks you perform when working with 
TestTrack Pro. This guide is not necessarily meant to be read from start to finish. It includes information 
for users, and administrators, at a variety of levels. To get the most out of the documentation, start by 
reading the chapters that are most relevant to your use of TestTrack Pro.

The guide includes two sections: the User Guide (user-related tasks) and the Administrator Guide (admin-
related tasks). Information included in some chapters can be for both a user and an administrator. 
Admin-related tasks are clearly marked in the User Guide chapters.

! Chapter 1, �Getting Started,� page 5, includes instructions for starting TestTrack Pro, opening databases, 
and connecting to the server.

User-related tasks

! Chapter 2, �Personalizing TestTrack Pro,� page 13, includes instructions for personalizing TestTrack Pro by 
setting user and local options.

! Chapter 3, �Learning the Basics,� page 19, provides an overview of the TestTrack Pro interface.

! Chapter 4, �Working with Defects,� page 29,  explains how to work with defects, including adding, editing, 
deleting, and numbering defects.

! Chapter 5, �Using SCC Integration,� page 55,  includes information about integrating SCC applications with 
TestTrack Pro.

! Chapter 6, �Managing the Workflow,� page 69,  explains how to assign defects and move a defect through 
the lifecycle. 

! Chapter 7, �Using Filters,� page 91,  explains how to use filters, including adding, editing, and deleting 
filters. 

! Chapter 8, �Managing Test Configs,� page 99,  explains how to set up test configurations, including adding, 
editing, and deleting test configs.

! Chapter 9, �Generating Reports,� page 103,  explains how to create and print reports.

! Chapter 10, �Using the Workbook,� page 125,  explains how to add, change, view, and delete To Do tasks in 
the Workbook. 

! Chapter 11, �Integrating with Developer Tools,� page 129,  includes instructions for programmers who are 
using the add-in to access TestTrack Pro.

Admin-related tasks

! Chapter 12, �Configuring Databases,� page 141,  explains how to create and customize a database and set 
database options.
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! Chapter 13, �Customizing Fields,� page 161,  explains how to add custom fields, customize field values, 
rename filed labels, define required and default values, and set up field relationships.

! Chapter 14, �Configuring SCC Integration,� page 175, includes SCC integration information.

! Chapter 15, �Managing User Groups,� page 185,  explains how to add, edit, and delete user groups. It also 
explains how user groups provide security. 

! Chapter 16, �Managing Users,� page 193,  explains how to manage TestTrack Pro users, including adding 
and deleting users and editing user information.

! Chapter 17, �Managing Customers,� page 203,  explains how to manage customers, including adding and 
deleting customers and editing customer information.

! Chapter 18, �Importing and Exporting Files,� page 213,  includes instructions for importing and exporting 
data using XML or text files.

! Chapter 19, �Customizing Email Templates,� page 227, explains how to customize email templates that are 
used with notifications and email acknowledgements.

! Chapter 20, �Working with SoloBug,� page 231, includes information about customizing and distributing 
SoloBug to customers and importing SoloBug files.

Conventions used in the guide
There are a few conventions used throughout the guide that are designed to be completely predictable � 
making it is easy to understand what you are reading and what you�re supposed to do. Many of the 
TestTrack Pro commands are available from menus, toolbars, shortcut menus, and shortcut keys. 
Throughout this guide, most commands are explained using both the menu command and the toolbar 
button. As you become more familiar with TestTrack Pro, you may find shortcut menus and shortcut 
keys more efficient to work with. When you are instructed to select a menu command, you will find the 
menu name, followed by an arrow. For example, to add a defect, choose Create > Defect. Indented text, 
set off with icons and rules, is also used to draw attention to notes, tips, examples, etc.

Icon Description

 Notes generally provide additional information about a command, �one-time only� 
information, or a reference to additional documentation.

 Tips provide helpful suggestions for using TestTrack Pro.

Indicates supplemental information, such as examples.

Indicates an admin command.
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Before you start
This guide assumes your PC, printer, and network (if applicable) are set up and ready to use. It also 
assumes you know how to perform the basic skills needed to use them. If you need more information on 
basic features, refer to the user guide that came with your computer.

Contacting Seapine support
We offer technical support, 9 AM - 6 PM, EST, Monday through Friday.

Documentation feedback

Seapine Software welcomes your feedback on the documentation included with this product. If you have 
comments or suggestions about the documentation, please email: documentation @seapine.com. This 
email address is provided for documentation only. You may not receive a reply to your email. For 
technical questions or support, contact support@seapine.com.

Telephone: 513-754-1655

Email: support@seapine.com

Web site: http://www.seapine.com

Check our web site for the latest news and updates. You can also find help in our 
Knowledgebase.

mailto:support@seapine.com
http://www.seapine.com
http://www.seapine.com
http://www.seapine.com/kb.html
mailto:documentation@seapine.com
mailto:support@seapine.com
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Chapter 1
Getting Started

Start Tracking!
This chapter includes instructions for starting TestTrack Pro, opening databases, and connecting to 
the server - everything you need to begin tracking bugs!

In this section:

Starting TestTrack Pro server, 6

Starting TestTrack Pro, 6

Setting up server connections, 9

Opening a database, 11

Connecting to a server, 12

Viewing project information, 12

Logging out, 12
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Starting TestTrack Pro server

The server must be running before users can access TestTrack Pro databases. The server can be run as an 
application, as an NT/2000 service, or as a Windows pseudo service. Refer to the TestTrack Pro Installation 
Guide for more information.

If the TestTrack Pro server is running as an NT/2000 or Windows service, it starts automatically. If the 
TestTrack Pro server is running as an application, you have to manually start the server each time the 
computer is restarted.

Manually starting TestTrack Pro server

1 On the Start menu, choose Programs > TestTrack Pro > TestTrack Pro Server. 

Active databases are loaded when the TestTrack Pro server is started.

When the TestTrack Pro server is running, an icon is placed in the server PC�s status bar. If the bug is 
green, the server is running correctly. If the bug is yellow or red, the server is not running correctly.

Starting TestTrack Pro
1 On the Start menu, choose Programs > TestTrack Pro > TestTrack Pro Client.

The Login dialog box opens.

2 Enter your Username and Password.

3 Select a database from the Database menu and click OK.

You are logged in and ready to start using TestTrack Pro.

The TestTrack Pro administrator is responsible for maintaining and running the 
TestTrack Pro server application.
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4 If there is a problem connecting to the server, check the following and try reconnecting to the server:

! Double-check the IP address and/or port number. 

! Make sure you are connected to the network, intranet, or Internet.

! Contact your TestTrack Pro administrator for help.

If you are the TestTrack Pro administrator, check the following:

! Make sure the server computer is on.

! Make sure the TestTrack Pro Server application is running on your server computer.

Initially starting TestTrack Pro

1 The first time you start TestTrack Pro, the Welcome to TestTrack Pro dialog box opens.

The Welcome to TestTrack Pro dialog box opens.

2 Enter your Name and Organization.

3 Select a License information option.

! If you are using a floating license, the serial number is entered on the server. 

! If you are using a dedicated license, you must enter your serial number. The serial number can be 
found on your registration card or your TestTrack Pro license card. 

4 Click OK.

The Server Connection dialog box opens.
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5 Select a server from the Connect to TestTrack Pro Server menu.

Select Always connect to this server to automatically connect to the selected server.

6 Click Connect.

The Login dialog box opens.

7 Enter your Username and Password.

8 Select a database from the Database menu and click OK.

You are now ready to start using TestTrack Pro.

If the menu is not populated, you need to configure the server connections. See 
Setting up server connections, page 9.

During installation, a default user named �Admin� is added to the system. This 
user has no password. You must log in as Admin the first time.
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Setting up server connections
Server connections, used to access TestTrack Pro databases, need to be set up. The TestTrack Pro 
administrator can enter server connection information using the Server Admin Utility or users can set up 
server connections. Depending on your company�s process, you may be required to set up server 
connections.

Adding server connections

The databases you use can be located on different servers. You need to add a server connection to access 
the TestTrack Pro server. 

1 Choose File > New Server Connection.

The Server Connection dialog box opens.

Where do I start?

If you are the Project Manager, start with the Defects list to view all the defects 
in the database. You will probably want to create filters to view specific 
defect information. For example, create a filter that displays all defects 
currently in an Open state. You may also want to print a report that lists all 
defects opened in the past week.

If you are the Lead Engineer, start with the Defects list. Create a filter that 
displays all defects created, fixed, or verified in the last week and are not 
currently assigned and not in the closed state. Then, assign the defects to the 
appropriate person.

If you are an Engineer/Developer, start with the Workbook. The Workbook 
displays all the defects assigned to you and any to do tasks you added. You 
can also start with the Defects list and create a filter to displays only the 
defects assigned to you.

If you are the Lead QA person, start with the Defects list and create a filter 
that displays all defects that are currently released to testing. Then, assign 
these defects to a QA team member for verification. You can also create a 
filter that displays defects that failed verification. 

If you are a member of the QA team, start with the Workbook. The Workbook 
displays all the defects assigned to you and any to do tasks you added. If you 
need to add new defects, start with the Defects list.
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2 Click Setup.

The Setup Server Configurations dialog box opens.

3 Click Add.

The Add TestTrack Pro Server dialog box opens.

4 Enter a Server Name and Server Address. 

The server address is the IP address of the computer where the TestTrack Pro server application is 
installed. Your TestTrack Pro administrator can tell you the server address.

5 Enter the Port number.

TestTrack Pro clients connect to the server on this port via TCP/IP. Valid values are 1-65535. The default 
value is 99.

6 Click OK.

The server connection is added. You return to the Setup Server Configurations dialog box. To change the 
order of the servers, select a server entry and click Up or Down.

7 Click Close to close the Setup Server Configurations dialog box.
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Editing server connections

1 Choose File > New Server Connection.

2 Click Setup.

3 Select the server and click Edit.

4 Make any changes and click OK.

Deleting server connections

1 Choose File > New Server Connection.

2 Click Setup.

3 Select the server and click Delete.

You are prompted to confirm the deletion.

4 Click Yes.

The server is deleted.

Opening a database
Use this command to open a database that is located on the server you are connected to.

1 Choose File > Open Database or click the Open Database toolbar button.

You are prompted to close the open database.

2 Click Yes. 

The Login dialog box opens.

3 Enter your Username and Password.

4 Select a database from the Database menu.

5 Click OK.

The database is opened.
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Connecting to a server
Use this command to connect to a different server and open a database on that server.

1 Choose File > New Server Connection.

The Server Connection dialog box opens.

If you are logged in to a database, you are prompted to close the database. Click Yes.

2 Select a server from the Connect to TestTrack Pro Server menu and click Connect.

The Login dialog box opens.

3 Enter your Username and Password.

4 Select a database from the Database menu and click OK.

Viewing project information
You can view information about the database you are logged in to.

1 Choose Help > Project Info.

The Project Information dialog box opens. It includes the project name, description, and creation date.

2 Click OK to close the dialog box.

Logging out
Logout of TestTrack Pro when you finish working with defects. This is important if your company uses 
floating licenses. The license you are using is not available to other users until you logout.

1 Choose File > Logout and Disconnect.

You are logged out from the database and disconnected from the server.

To close the TestTrack Pro application, choose File > Exit.
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Chapter 2
Personalizing TestTrack Pro

Up Close and Personal!
This chapter includes instructions for personalizing your copy of TestTrack Pro. Take the time to set 
the options that will make your job easier!

In this section:

Setting local options, 14

Setting user options, 15

Setting passwords, 18

Changing passwords, 18

Removing passwords, 18
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Setting local options
Local options are global. You do not need to log in to a specific database to set these options.

1 Choose Edit > Options > Local Options.

The Local Options dialog box opens with the General tab selected.

2 Select the general options.

! Select Show the Server Connection Dialog if you connect to different servers. When you start TestTrack 
Pro, the server connection dialog box opens so you can choose a server.

! Select Always connect to the last TestTrack server if you always connect to the same server.

! Select Automatically log last user into last database if security is not a concern. You are automatically 
connected to the server and logged in to the last database used.

! Select Allow multiple instances of this application if you want to login to different databases at the same 
time. You can open multiple instances of TestTrack Pro.

3 Click the Stylesheets tab to select the default stylesheet you want to use when printing from list windows.
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4 Select a Report Type from the list.

Each Report Type corresponds to a list window. For example, the Filter View Detail Report prints a detail 
report for all filters in the database.

5 Select a Default Stylesheet for the selected report or click Browse to use a customized stylesheet.

For more information, see Using stylesheets, page 104.

6 Click OK to save the local options you set.

Setting user options
Set user options and customize such things as notification options, display options, email notifications, 
etc. User options are database-specific. Any options you set only affect the database you are logged in to.

Setting general options

1 Choose Edit > Options > User Options.

The User Options dialog box opens with the General tab selected.
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2 Select a Notification Option.

TestTrack Pro can either play a sound or open a dialog box to notify you of defect assignments. You can 
also clear both options.

3 Select a Double-clicking on items... option.

This option affects records displayed on list windows. For example, you set this option to open the edit 
dialog box. If you double-click a user on the Users list window, the Edit User dialog box opens.

4 Select a Display names as... option.

Names can be displayed on First/Last or Last/First order.

5 Select a Status option.

You can display the status or the status and the assignment information.

6 Select a Display option.

! Select Grey out closed defects if you want closed defects to appear dimmed on the list window. If you 
work with a large number of defects, this option can help you quickly view closed defects.

! If your database uses field relationships, select Warn me when values are changed due to field 
relationship rules to display a warning if you change a value that affects field relationship rules. This 
option helps enforce field relationship rules.

! You can also clear both options.

7 Select an Adding Multiple Defects option.

This option affects the Add Defect dialog box and the action that is applied when you are adding new 
defects.

! Select Set all fields to default values if you want fields on the Add Defect dialog box reset with their 
default values.

! Select Retain pop-up menu values, but set other fields to their default values to keep the values you 
choose for pop-up fields and reset all other fields with default values. Pop-up fields include: Type, 
Product, Disposition, Priority, Component, and Severity. The other fields include: Entered By, Found 
By, Version Found, Reproduced, Computer Config, and Custom fields.

! Select Close the Add Defect window if you want the Add Defect dialog box to close after a defect is 
added.
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Setting email options

Email notifications provide a way to stay up to date with changes to defects. You can choose as many 
email notifications as you want.

1 Choose Edit > Options > User Options.

2 Click the Email tab and select the options.

Choose options carefully so you do not receive an email each time a defect moves to another state in the 
lifecycle. You can also select filters to further restrict the email notifications you receive.

! If you are a team lead, you might want to receive an email notification when a defect is added to the 
database. Select Send me mail when new defects are added.

! If you are a developer, tech writer, or QA person, you are probably interested in defects that are 
assigned to you. Select Send me mail when new defects are added then select Only tell me about new 
defects that are assigned to me. You will receive an email if the new defect is assigned to you. 

The TestTrack Pro administrator can also set user notification options. When 
adding or editing a user or customer, click Notification Options.



18 TestTrack Pro
Setting passwords

Setting passwords
1 Choose File > Set Password.

The New Password dialog box opens.

2 Enter a password and click OK.

The Verify Password dialog box opens.

3 Retype the password and click OK.

Changing passwords
1 Choose File > Set Password.

The Old Password dialog box opens.

2 Enter your old password and click OK.

The New Password dialog box opens.

3 Enter a new password and click OK.

The Verify Password dialog box opens.

4 Retype the password and click OK.

The password is saved.

Removing passwords
1 Choose File > Set Password.

The Old Password dialog box opens.

2 Enter your old password and click OK.

The New Password dialog box opens.

3 Leave the field blank and click OK.

The Verify Password dialog box opens.

4 Leave the field blank and click OK.

The password is removed.
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Chapter 3
Learning the Basics

Take a tour! 
This chapter provides an overview of the TestTrack Pro interface. TestTrack Pro is easy to use, but it 
is even easier when you understand the basics and learn a few shortcuts.

In this section:

TestTrack Pro interface, 20

TestTrack Pro toolbar, 22

List windows, 23

Adding columns, 26

Adding column contents, 27

Sorting columns, 27

Changing column widths, 27

Removing columns, 28

Printing, 28
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TestTrack Pro interface
TestTrack Pro provides complex functionality with an easy to use, and learn, interface. The interface 
includes eight list windows: Defects, Customers, Users, User Groups, Test Configs, Filters, Reports, and 
Workbook. Features, such as the title bar, command buttons, menu bar, toolbar, status bar, and tooltips 
are common to all list windows. Some features and options, such as active menus and commands, 
depend on the list window and your security permissions.

Title bar

Lists the name of the open database or the name of the open list window.

Menu bar

The menu bar, located below the title bar, contains the available menus. Menu commands vary 
depending on the function you are performing, your security permissions, and the list window you are 
working on. If a menu command is greyed out and unavailable, you do not have access to that command 
or the command is not available for the list window you are on. For example, you are working with users 
on the Users list window. The edit commands are all user-specific (Edit > Delete User).

Toolbar

The TestTrack Pro toolbar, located below the menu bar, provides access to TestTrack Pro commands and 
list windows. For more information, see Printing, page 28.

Status bar

Defect indicator

List window

Command buttons

Toolbar

Title bar
Menu bar
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Command buttons

Command buttons are located at the top of every list window. These buttons provide another way to 
access the View, Add, Edit, and Delete commands.

Status bar

A status bar is located at the bottom of list windows. It includes information such as the number of 
defects assigned to you or a toolbar button description.

Tooltips

When you place the cursor over a toolbar button, a command description opens.

Button Description

Opens the corresponding View dialog box

Opens the corresponding Add dialog box

Opens the corresponding Edit dialog box

Deletes the selected item
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TestTrack Pro toolbar
The toolbar contains buttons that give you access to TestTrack Pro commands and list windows�just a 
click away!

Click To do this...

Open a database

Open the Print Option dialog box

Open the Find Defects dialog box

Open the Advanced Find Defects dialog box

Open the Defects list window

Open the Customers list window

Open the Test Configs list window

Open the Users list window

Open the User Groups list window

Open the Filters list window

Open the Reports list window

Open the Workbook list window

You can also access these commands from TestTrack Pro menus. For example, 
to open the Defects list window, choose View > Defects.
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List windows
List windows are used to display basic record information. TestTrack Pro includes the following list 
windows: Defects, Customers, Users, User Groups, Test Configs, Filters, Reports, and Workbook.

Opening list windows

Click the corresponding TestTrack Pro toolbar button. Or select the list window you want to open from the 
View menu.

Selecting records

Before you can work with records, you need to select the records on the list window.

! To select all records, choose Edit > Select All or press Ctrl + A.

! To select more than one record, hold down the Ctrl key while clicking the records.

! To select a range of records, click the first record, then hold down the Shift key and click the last 
record.

Defects list window

The Defects list window provides access to defects and defect actions. For more information, see 
Chapter 4, �Working with Defects,� page 29.

This list window also includes defect indicates that point out new, changed, and closed defects and the 
defects assigned to you. You can also filter the records that are displayed in the list window.
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Defect indicators

Defect indicators are icons on the Defects list window that point out new defects, changed defects, closed 
defects, and the defects that are assigned to you.

Customers list window

The Customers list window provides access to customers and customer commands. For more 
information, see Chapter 17, �Managing Customers,� page 203.

Users list window

The Users list window provides access to users and user commands. For more information, see 
Chapter 16, �Managing Users,� page 193.

Icon Name Indicates

New Defect Defects added since you last logged in

Changed Defect Defects that changed since you last logged in

Closed Defect Closed defects

Assigned Defect Defects assigned to you
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User groups list window

The User Groups list window provides access to user groups and user group commands. For more 
information, see Chapter 15, �Managing User Groups,� page 185.

Test configs list window

The Test Configs list window provides access to test configs and test config commands. For more 
information, see Chapter 8, �Managing Test Configs,� page 99.

Filters list window 

The Filters list window provides access to filters and filter commands. For more information, see 
Chapter 7, �Using Filters,� page 91.
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Reports list window

The Reports list window provides access to reports and reports commands. For more information, see 
Chapter 9, �Generating Reports,� page 103.

Workbook list window

The Workbook list window provides access to your personal workbook, your assigned defects, and tasks 
you add to the Workbook. For more information, see Chapter 10, �Using the Workbook,� page 125.

Adding columns
List window information is displayed in a column format. This lets you customize the information that is 
displayed. For example, you can add and remove columns or sort columns to easily view information 
that�s important to you.

1 Right-click the column heading you want to add a column next to. 

2 Select Insert Column from the shortcut menu. An empty column is added to the left of the selected column. 

3 Select a field name to add column contents.
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Adding column contents 
To add or change column contents, select a new field for the column.

1 Right-click the column heading you want to change.

The shortcut menu lists all the available fields.

2 Select the field name from the menu. 

The column heading changes to the field name and the selected field contents are displayed.

Sorting columns
You can sort by any column and you can perform primary and secondary sorts.

! To sort a primary column, click the column heading. A single tick mark appears to the right of the 
column heading. Click the column heading again to toggle the sort order between ascending and 
descending.

! To sort a secondary column, Shift+click the column heading. Two tick marks appear to the right of the 
column heading. Shift + click the column heading again to toggle the sort order between ascending 
and descending. For example, the following list is sorted first by Status and then by Product.

Changing column widths
To make a column wider or narrower:

1 Move the cursor to the divide bar located between the column headings.

The cursor changes to a resize cursor.

2 Click and drag the divide bar to change the width of the column to the left of the divide bar.
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Removing columns
1 Right-click the column heading you want to remove.

2 Select Remove Column from the shortcut menu.

Printing

1 Choose File > Print or click the Print toolbar button.

The Print Options dialog box opens.

2 Select print options.

! Print as list prints all the records in a list format. Select the check box if you want grid lines to print.

! Print as detail prints the details for each record. Select the check box if you want each item printed on 
a separate page.

! Create report file from template lets you print a report based on a previously created template. After 
choosing this option, click Save (the Print buttons changes to a Save button). The Select Report 
Template dialog box opens. Select the report template you want to use and click Open. The Save 
Report As dialog box opens. Select a directory and enter a filename. The report is saved as a text 
document.

3 Click Print.

You can also click Preview to open the report in preview mode.

If you do not want to print every record in the list, select the items you want to 
print on the list window. Make sure you select the Only Print Selected Items 
check box on the Print Options dialog box!
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Chapter 4
Working with Defects

Squash the bugs... 
...and move on to the next challenge! This chapter includes detailed information about defects - 
everything from adding defects to finding defects to logging historical defect information. 

In this section:

About defects, 30

Adding defects, 30

Adding additional reports to a defect, 34

Attaching files to a defect, 35

Finding defects, 36

Using advanced find, 37

Viewing defects, 39

Viewing attached files, 40

Editing defects, 41

Opening attached files, 42

Extracting attached files, 43

Duplicating defects, 43

Merging defects, 43

Editing additional defect reports, 44

Using deferred defect numbering, 45

Assigning defect numbers, 45

Renumbering defects, 45

Changing bulk fields, 46

Deleting additional defect reports, 52

Deleting attached files, 52

Deleting defects, 53
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About defects
A defect is a bug, enhancement, change request, question, or any other product-related issue you need to 
track and resolve. It can be as simple as a typo in a Help file or as complicated as a system crash. 
Depending on your needs, you can configure complex tracking methods or simply use TestTrack Pro as 
a �to do� list.

Adding defects
1 Choose Create > Defect or click Add on the Defects list window.

The Add Defect dialog box opens. This dialog box includes the following tabs: Detail, Workflow, 
Workaround, Source Code, Notify, History, and Custom Fields (optional). 

The Detail tab includes 4 mini tabs: Found By, Reproduce, Computer Config, and Attachments.

The New and Remove buttons on the Detail tab are used to add or remove 
additional defect reports. See Adding additional reports to a defect, page 34.

These buttons are used to 
add or delete additional 
defect reportsA mini tab is 

a small, 
horizontally 
oriented tab. 
The Detail 
tab includes 
4 mini tabs.
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2 Enter the information in the top portion of the Add Defect dialog box.

! Enter a defect summary. You can enter up to 255 characters.

! Displays the defect status and whether it is assigned.

! Select the defect disposition. 

! Select the defect type.

! Select the defect priority.

! Select the product name.

!  Select the component name.

! Enter a reference number pertinent to the defect.

! Select the defect severity.

! Entered by defaults to the current user or you can select a user from the menu.

! Date Entered defaults to the current date or you can enter another date.

3 Enter the information on the Detail: Found by mini tab.

! Found by defaults to the current user or you can select a user from the menu. To search for a user or 
customer, click the Find button located next to the Found by field. Enter the search criteria. If matching 
users or customers are found, select one to populate the Found by field.

! Date defaults to the current date or you can enter another date.

! Select the version of the software containing the defect.

! Enter a detailed defect description.

Click to search for a user or 
customer. Select the user or 
customer to populate the 
Found by field.
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4 Enter the information on the Detail: Reproduce mini tab.

! Select a reproduced level.

! Enter the detailed steps to reproduce the defect. This information helps programmers, testers, etc., fix 
and test the problems.

5 Enter the information on the Detail: Computer Config mini tab.

! Select a computer configuration. The default is the current user�s configuration.

! Enter information about other hardware and software that could be affecting the problem.

6 If necessary, attach a file to the defect using the Detail: Attachments mini tab. For more information, see 
Attaching files to a defect, page 35.
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7 Optionally, click the Custom Fields tab.

If a database uses custom fields, up to two custom fields may be displayed in the main area of the Add 
Defect dialog box. Custom fields can also all be displayed on the Custom Fields tab � make sure you click 
this tab to enter or check custom field information.

8 Skip the Workflow tab.

This tab is populated with defect action information and is useful when editing or viewing defects.

9 Click the Workaround tab.

Enter a workaround solution for the bug that can be used until it is fixed or implemented.

10 Skip the Source Code tab.

This tab is used for SCC application functions. Most users do not attach source code files while adding 
defects. For more information, see Chapter 5, �Using SCC Integration,� page 55.

You may not have access to this tab, depending on your security permissions 
and database configuration.
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11 Click the Notify tab.

! To add users or customers to the notification list, click Add. 

! Select the users or customers from the Add Mail Recipients dialog box and click Add. 

! To remove users, highlight the user /customer and click Remove.

12 Skip the History tab.

This tab is populated with defect historical information and is useful when editing or viewing defects.

13 When you finish entering information, click Add on the Add Defect dialog box.

The defect is added to the database.

Adding additional reports to a defect
Users, customers, or beta sites often report the same defect. To eliminate duplicates in your database, 
you should add the defect once and add all additional reports to the same defect. 

1 Select the defect you want to add an additional report to.

2 Choose Edit > Edit Defect or click Edit on the Defects list window.

The Edit Defect dialog box opens. 

3 On the Detail tab, click New.

4 Enter the additional report information. 

For more information, see Adding defects, page 30.
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5 Click OK when you finish adding the additional report.

Attaching files to a defect
When you add a defect, you can attach related files. For example, if a defect is corrupting a file, you can 
attach the corrupt data file for reference. If you want to point out a cosmetic changes to a dialog box, you 
can attach a screen shot that includes the changes.

1 Select the defect you want to attach a file to.

2 Choose Edit > Edit Defect.

3 On the Detail tab, click the Attachments mini tab.

4 Click Attach.

The Attach File dialog box opens.

5 Navigate to the directory containing the file, select the file and click Open.

The file is attached to the defect.

The Detail tab includes a counter. If a defect is reported multiple times, the 
counter increases and shows the number of times the defect is reported. 

You can attach multiple files to a defect. You can also attach zipped files. 
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Finding defects
You can search against the summary field, the description field, or all notes. If you do not have security 
access to these fields, the Find Defects command is disabled.

1 Choose Edit > Find Defects.

The Find Defects dialog box opens. 

2 Select the search field from the Find menu.

Fields you have security access to are listed in the menu.

3 Enter the text you want to search for in the Contains field.

Select Based on Current Filter if you only want to search the filtered defects.

4 Click Find. If matching defects are found, the search results are displayed on the Defects list window. 
Notice the Find Results filter is applied.

5 If matching defects are not found, a warning message opens. Click OK.

You return to the Defects list window, which is empty since no defects matched the search criteria. 
Notice the Find Results filter is applied.

If you know the number of a defect, you can jump directly to that defect. 
Choose Edit > Go To Defect Number, enter the defect number, and click OK.
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Go to command
If you know the number of a specific defect, use the go to command to quickly find the defect.

1 Choose Edit > Go To Defect Number.

The Go To Defect Number dialog box opens.

2 Enter the defect number and click OK.

The corresponding defect is opened.

Using advanced find
Advanced find lets you perform a more powerful search using filters and Boolean logic. You can also 
search on multiple restrictions. For more information, see About filters, page 92.

1 Choose Edit >Advanced Find Defects or click the Advanced Find toolbar button.

The Advanced Find Defects dialog box opens.

Use these buttons to 
add and modify 
search restrictions.
Filter restriction

Click Clear to 
remove all 
restrictions and 
start over.
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2 Click Add to add a search restriction. 

The Restriction dialog box opens.

3 Select the field you want to include from the Restrict By menu.

When you select a field from the Restrict By menu, the restrictions you can set for the field appear in the 
Restrictions box.

4 Select the restriction options.

The restriction is added to the search. 

5 Click OK.

You return to the Advanced Find Defects dialog box.

6 Optionally, select NOT/AND/OR operators and parentheses to build the boolean logic for the filter. For 
more information, see About Boolean searches, page 92.

7 Click Validate to validate the search criteria.

! If the criteria is valid, click OK.

! If the criteria is not valid, an error message opens. Click OK to return to the Advanced Find Defects 
dialog box and correct the error. 

! Click Clear to clear all restrictions and start over.

8 Click Make Filter to save the search criteria as a filter. For more information, see Creating filters, page 93.

If your defects are filtered, and you choose Advanced Find, the Advanced Find 
Defects dialog box is populated with the filter restrictions. Click Clear to 
remove the restrictions.

When you 
select a Restrict 
by field...

...the restrictions 
you can set 
appear here.
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9 When you finish adding restrictions and the criteria is validated, click Execute.

10 If matching defects are found, the search results are displayed on the Defects list window. Notice the Find 
Results filter is applied.

11 If matching defects are not found, a warning message opens. 

You return to the Defects list window, which is empty because matching defects were not found. Notice 
the Find Results filter is applied.

Viewing defects
1 Select the defect on the Defects list window.

2 Choose Edit > View Defect or click View on the Defect list window.

The View Defect dialog box opens. All fields are read-only.

Click to view information 
about the customer or 
user who found the 
defect. The corresponding 
View dialog box opens.

Click the arrows to 
move to the next or 
previous defect record.
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3 Click the Workflow tab.

This tab includes an overview of where the defect is in the workflow, what defect actions were assigned, 
who the actions were assigned to, and any comments or additional information a user entered.

4 Click the History tab.

Each time a defect action is assigned, TestTrack Pro adds this information to the defect�s history. The 
History tab includes who created the defect, when the defect was created, the creation method, who last 
modified the defect, and the date of the last modification.

5 Click OK to close the View Defect dialog box.

Viewing attached files
You can view text files (.txt) and bitmaps (.bmp) without extracting the files. 

1 Select the defect with the attached file you want to view.

2 Choose Edit > Edit Defect.

3 On the Detail tab, click the Attachments mini tab.

4 Select the attached file and click View.

The text file or graphics file is displayed.
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Editing defects
1 Select the defect on the Defects list window.

2 Choose Edit > Edit Defect or click Edit on the Defects list window.

The Edit Defect dialog box opens.

Click the arrows to 
move to the next or 
previous defect record.

These shortcut buttons are 
used to edit 
customer/user information 
and search for 
customers/users.
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If another user is editing a defect you open, a read-only icon opens next to the OK button. Click the icon to 
see who is editing the record. When the user finishes, the icon closes and the record is updated.

3 Make any changes and click OK.

Your changes are saved.

Opening attached files
Open saves a copy of an attached file and opens it with the application used to create it. For example, if a 
customer sends a Microsoft Word document, TestTrack Pro can open the file in Word. 

1 Select the defect you want to extract an attached file from.

2 Choose Edit > Edit Defect.

3 On the Detail tab, click the Attachments mini tab.

4 Select the attached file and click Open.

The Save and Open Extracted File As dialog box opens.

5 Select the file location and enter a file name.

6 Click Save.

The file is extracted and opened.

TestTrack Pro checks the database every 10 seconds for changes. Read-only 
records become available as soon as users finishes editing the records.

read-only icon
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Extracting attached files
Extract saves a copy of an attachment. For example, if a customer attaches a corrupted data file to a 
defect, you can extract the file to a specific folder.

1 Select the defect you want to extract an attached file from.

2 Choose Edit > Edit Defect.

3 On the Detail tab, click the Attachments mini tab.

4 Select the attached file and click Extract.

The Save Extracted File As dialog box opens.

5 Select the file location, enter a file name, and click Save.

The file is extracted to the folder you selected. You can now open the file.

Duplicating defects

If you are adding defects with the same basic information, you can save time by duplicating and editing 
a defect.

1 Select the defect on the Defects list window.

2 Choose Edit > Duplicate Defects.

TestTrack Pro duplicates the defect and assigns a new defect number. The duplicated defect is added to 
the Defects list window.

3 Edit the defect and save your changes.

Merging defects
Merging defects helps avoid confusion and keep your database organized. For example, two defects 
report the same issue. JoeDeveloper is assigned one defect and JaneDeveloper is assigned the other one. 
The developers are working on the same issue and do not realize it.

1 Select the defects on the Defects list window.

To select a range of defects, click the first defect in the range, then Shift+click the last defect. To select 
multiple defects not in a range, Ctrl+click each defect. 

Depending on your security level, you may not have access to this command.
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2 Choose Edit > Merge Defects.

A warning message opens, letting you know the defects will be merged and deleted from the database.

3 Click OK.

The defects are merged. 

! The resulting defect assumes the lowest defect number and the type, priority, and severity of that 
defect. All defect information is retained as multiple defect records. For example, if you merge three 
defects, the Detail tab shows three defect records. Each defect record includes the original defect 
information.

! If one or more fields conflict, you are prompted to view the merged defect.

Editing additional defect reports
1 Select the defect with the record you want to edit on the Defects list window.

If you are on the Edit Defect dialog box, skip to step 3. 

2 Choose Edit > Edit Defect or click Edit on the Defects list window.

The Edit Defect dialog box opens. 

3 Click the Detail tab and select the report you want to edit.

4 Make any changes and click OK.

Select the report 
you want to edit.

You can also use 
these buttons to move 
through the reports.
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Using deferred defect numbering

During product testing, bug reports are submitted from a variety of sources. Many are new bugs or 
feature requests you need to track, some are not unique or don�t need tracking. You can store new 
defects in the database and number them after confirming they are unique defects. This feature is 
deferred defect numbering. When deferred defect numbering is active, new defects have a dash instead of 
a defect number. These are unnumbered defects. You should periodically review unnumbered defects and 
assign defect numbers, merge them with existing defects, or delete them.

1 Select Edit > Options > Database Options.

The Database Options dialog box opens.

2 Click the Defects tab and select the deferred numbering options.

Assigning defect numbers
1 Select the unnumbered defect on the Defects list window.

2 Choose Activities > Defect Actions > Assign Defect Numbers.

The defect is assigned the next defect number.

Renumbering defects

Over the duration of your project, you may delete or merge defects that leave gaps in the defect numbers 
sequence. Or, at the start of a new development cycle, you may want to purge all closed defects from the 
project and use it as a fresh starting point for testing. In both cases, you will need to renumber defects.

1 Select the defect you want to renumber and choose Activities > Defect Actions > Renumber Defect.

The Renumber Defects dialog box opens. The starting number is set to the next available defect number.

2 Enter an unused defect number and click OK. 

The Renumber Defects dialog closes and the defect is renumbered.

You may not have access to this administrator command.

You may not have access to this administrator command.
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! If the renumbered defect uses a number that is higher than the next available defect number, the next 
available defect number is set to one higher than the renumbered defect. For example, if the next 
defect added to the database would be numbered 1011 and you renumber a defect to 1200, the next 
defect added will be 1201. 

! If you renumber the entire defect list, you still need to set the next available defect number to one 
greater than the highest defect number.

Changing bulk fields

You can quickly, and easily, update multiple records in the TestTrack Pro database. Use this command 
to replace values for specific fields, search for and replace strings in text fields, or add text. 

You can replace values for the following field types: General, Reported By, Steps to Reproduce, 
Computer Config, Defect Actions, and Custom Fields. For example, you can change the disposition for 
100 records to on hold. Or you can change the Found by User for specific records.

Replacing general field values
1 Select the defects on the Defects list window. 

2 Choose Activities > Defect Actions> Bulk Field Changes.

The Bulk Field Changes dialog box opens with the General tab selected.

The following security options must be enabled to access this command: Edit 
Defect, Edit Database Options, and Import from XML.
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3 Make any changes.

! To add text, enter the text in the Summary field and select Prepend or Append.

! To replace text, enter the string you want to search for in the Replace field and the string you want to 
replace it with in the With field. 

! To change values, select the value from the corresponding menu.

4 Click OK.

You are prompted to confirm the changes.

5 Click OK.

The records are updated.

Replacing reported by field values
1 Select the defects on the Defects list window.

2 Choose Activities > Defect Actions> Bulk Field Changes.

The Bulk Field Changes dialog box opens. 

3 Click the Reported By tab.
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4 Make any changes.

! If defects are reported multiple times and you want to change all reported by records, select Apply 
changes to all Reported by records. If you only want to change the first reported by record, do not select 
this option. For example, you want to change the Found by user for 50 defects. Some of the defects 
were reported multiple times. Select this option to change the found by user for each reported by 
record. If you do not select this option, only the first reported by record is changed.

! To change values, select the value from the corresponding menu.

! To add text, enter the text in the Description field and select Prepend or Append.

! To replace Description text, enter the string you want to search for in the Replace field and the string 
you want to replace it with in the With field.

5 Click OK.

You are prompted to confirm the changes.

6 Click OK.

The records are updated.

Replacing steps to reproduce field values
1 Select the defects on the Defects list window. 

2 Choose Activities > Defect Actions> Bulk Field Changes.

The Bulk Field Changes dialog box opens. 

3 Click the Steps to Reproduce tab.
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4 Make any changes.

! If defects are reported multiple times and you want to change all reported by records, select Apply 
changes to all Reported by records. If you only want to change the first reported by record, do not select 
this option.

! To change values, select the value from the corresponding menu.

! To add text, enter the text in the Steps to Reproduce field and select Prepend or Append.

! To replace Steps to Reproduce text, enter the string you want to search for in the Replace field and the 
string you want to replace it with in the With field.

5 Click OK.

You are prompted to confirm the changes.

6 Click OK.

The records are updated.

Replacing computer config field values
1 Select the defects on the Defects list window.

2 Choose Activities > Defect Actions> Bulk Field Changes.

The Bulk Field Changes dialog box opens. 

3 Click the Computer Config tab.
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4 Make any changes.

! If defects are reported multiple times and you want to change all reported by records, select Apply 
changes to all Reported by records. If you only want to change the first reported by record, do not select 
this option.

! To change values, select the value from the corresponding menu.

! To add text, enter the text in the Other Hardware and Software field and select Prepend or Append.

! To replace Other Hardware and Software text, enter the string you want to search for in the Replace field 
and the string you want to replace it with in the With field.

5 Click OK.

You are prompted to confirm the changes.

6 Click OK.

The records are updated.

Replacing defect actions field values
1 Select the defects on the Defects list window.

2 Choose Activities > Defect Actions> Bulk Field Changes.

The Bulk Field Changes dialog box opens. 

3 Click the Defect Actions tab.
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4 Select a Defect Action.

The fields on this tab change based on the defect action you select.

5 Make any changes.

! If you want to change all defect actions select Apply to all actions. If you only want to change the 
newest defect action, do not select this option. For example, you need to change by Assign By user 
for 100 defects. Most of these defects have been manually assigned multiple times. Select this option 
to change every assign by record for all defects. If you do not select this option, only the newest assign 
by record is changed.

! To change values, select the value from the corresponding menu.

! To add text, enter the text in the Notes field and select Prepend or Append.

! To replace Notes text, enter the string you want to search for in the Replace field and the string you 
want to replace it with in the With field.

6 Click OK.

You are prompted to confirm the changes.

7 Click OK.

The records are updated.

Replacing custom field values
1 Select the defects on the Defects list window. 

2 Choose Activities > Defect Actions> Bulk Field Changes.

The Bulk Field Changes dialog box opens. 

3 Click the Custom Fields tab.
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4 Select a Custom Field.

The fields on this tab change based on the custom field you select.

5 Make any changes.

6 Click OK.

You are prompted to confirm the changes.

7 Click OK.

The records are updated.

Deleting additional defect reports
1 Select the defect with the record you want to delete.

2 Choose Edit > Edit Defect or click Edit on the Defects list window.

3 Click the Detail tab and select the report you want to delete.

4 Click Remove.

The additional report is deleted.

Deleting attached files
1 Select the defect you want to delete an attached file from.

Make sure you want to permanently delete the attached file. You are not prompted to confirm the 
deletion and the action cannot be undone.

2 Choose Edit > Edit Defect.

3 On the Detail tab, click the Attachments mini tab.

4 Select the file you want to delete and click Remove.

The attached file is deleted.
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Deleting defects
1 Select the defect on the Defects list window.

You can select more than one defect to delete.

2 Choose Edit > Delete Defect or click Delete on the Defects list window.

You are prompted to confirm the deletion.

3 Click OK.
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Chapter 5
Using SCC Integration

Integrate TestTrack Pro... 
with your SCC application! This chapter includes information about integrating SCC applications 
with TestTrack Pro. It also includes detailed instructions for performing SCC functions.

In this section:

Using source code control with TestTrack Pro, 56

Configuring SCC integration, 57

Disabling SCC integration, 58

General source code tab information, 59

Attaching files, 60

Detaching files, 61

Getting files, 62

Checking in files, 63

Checking out files, 64

Undoing check out, 66

Viewing files, 66

Viewing file history, 67
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Using source code control with TestTrack Pro
You can integrate the following SCC applications with TestTrack Pro: CS-RCS, CVS, ClearCase, PVCS, 
Perforce, SourceOffSite Classic, StarTeam, Surround SCM, and Visual SourceSafe. You must configure 
the integration before you can access your SCC application through TestTrack Pro. SCC integration 
includes the following commands:

Attach file: Attaches files in the SCC application to a defect.

Detach file: Detaches files that are associated with a defect.

Get: Copies a read-only version of the selected files into your working folder.

Check in: Checks in a file after changes are made to the file. Updates the SCC project with the 
changes you made.

Check out: Checks out and locks an attached file so you can make changes to the file.

Undo Check out: Cancels a checked out file and undoes all changes. This action may overwrite the file 
on your hard drive with the current copy in the SCC application.

View: Opens and displays a copy of the selected file, using the corresponding editor.

History: Displays a file�s history including version and user information, dates, and 
comments.

For more information about specific SCC applications and their integration 
with TestTrack Pro, see Chapter 14, �Configuring SCC Integration,� page 175.
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Configuring SCC integration

1 Choose Activities > Configure > SCC Integration.

The Configure SCC Integration dialog box opens with the Local Options tab selected. The Local Options 
tab lists the installed SCC providers.

2 Select the application you want to use from the Available Providers list and click Make Current.

The application you selected is listed in the Current box. The Local Options tab is the only tab available 
until you select an SCC application.

Depending on your database configuration, you may not have access to the 
Source Code Control (SCC) functions.

 CVS is always displayed in the Available Providers list. Do not set up CVS 
integration unless CVS is installed on your computer. 

You probably use one source code control program. You must still select the 
application and click Make Current.
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3 Click the User Options tab.

This tab is used to select the project database and enter a username and password to connect to the 
database.

The user options settings are stored in the TestTrack Pro database for the currently logged in user. If you 
log in to multiple TestTrack Pro databases, SCC user options must be configured for each database.

4 Click Browse to select the project database.

If you use Visual SourceSafe or PVCS you must also enter a valid username and password for the 
database.

5 Click Validate Connection to test the connection parameters. If you receive an error message, correct the 
error and try again.

Disabling SCC integration
1 Choose Activities > Configure > SCC Integration.

The Configure SCC Integration dialog box opens.

2 Select the provider you want to disable and click Disable SCC Integration.
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3 You are prompted to confirm that you want to disable the SCC integration.

4 Click Yes to disable the integration.

General source code tab information

The source code tab provides the following information about the source files attached to a defect.

How do I know if source files are attached to a defect?

Add a new column to the Defects list window and select Has SCC files? for the 
heading. Yes appears in the column if source files are attached to a defect. 

Source Files All files attached to the defect.

Fixed Revision Each revision number where the file was checked in from the defect. Revision 
numbers are obtained from the SCC application. If the file is not checked in through 
TestTrack Pro, the revision number is not updated. 

Fixed Timestamp The timestamp of the latest fixed revision found in the Fixed revision column.

Locked By The username is displayed if it can be determined. If the username cannot be 
determined, �current user� or �another user� is usually displayed.
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Attaching files
This command is used to attach files to a defect. You should attach any file in SCC that is related to the 
defect. For example, you might attach a source file that changed while fixing the defect.

1 Select the defect you want to attach a file to on the Defects list window.

2 Choose Edit >Edit defect or click Edit on the Defects list window.

3 Click the Source Code tab.

4 Click Attach File.

The Attach File(s) dialog box opens.

5 Select the project you want to work with from the SCC Projects list.

A list of available files opens in the Files in project list.

6 Select the files you want to attach from the Files in project list and click the right arrow button (>>).

You can attach a source code file when adding a defect, but you will probably 
attach files when editing defects. Generally, QA, support, or customers add 
defects. A developer, or other team member (such as a documentation team 
member), usually attache source code files to a defect after the bug is added.

The SCC application is not queried for data after the Attach File(s) dialog box 
opens for the first time. If you add files or directories to your SCC project, click 
Refresh. The TestTrack Pro client will call the PVCS or Perforce interface to 
obtain the list of files that are under source code control.
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The files are listed in the Files to attach list. If you make a mistake, select the file in the Files to attach list 
and click the left arrow button (<<).

7 Click OK when you are finished.

Detaching files
This command is used to detach files from a defect. When you detach files, it removes the association of 
the SCC file to the defect. This action does not make any changes in the SCC application.

1 Select the defect you want to detach a file from on the Defects list window.

2 Choose Edit >Edit defect or click Edit on the Defects list window.

3 Click the Source Code tab.

4 Select the source file and click Detach File.

You are prompted to make sure you want to detach the selected file. 

5 Click Yes.

The file is detached.

If you are using ClearCase, PVCS, or Perforce, make sure you only attach 
relevant files. Due to the program interfaces, attaching files can cause a small 
delay in performance depending on the number of files in the database. This 
slow down is based on the number of attached files, not the number of files in 
ClearCase, PVCS, or Perforce.

The first time you attach SCC files, the Attach File(s) dialog box may take a 
longer time than expected to open. The TestTrack Pro client must call the 
program to obtain a list of files that are under source code control. The next 
time you access the Attach function, it will be a faster process because the list 
of SCC files are cached by TestTrack Pro.
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Getting files
This command is used to view, and not edit, a file. When you get a file, a read-only file is copied to the 
directory you specify.

1 Select the defect you want to get SCC files from on the Defects list window.

2 Choose Edit >Edit defect or click Edit on the Defects list window.

3 Click the Source Code tab.

4 Select the source file(s) and click Get.

The Get File(s) dialog box opens.

5 Enter a directory path or click Browse to select a path. You can leave the path field empty to use the default 
location.

! If you are getting a single file, the value of the path field is determined by the SCC user configuration.

! If you are getting multiple files, the path field may be empty since each file can have a different default 
location.

6 Select Make writable if you want to be able to edit the file.

7 Select Only show dialog when Shift key is down if you do not want the Get File(s) dialog box to open.

If you select this option, the settings you entered are used each time you get a file. To display the dialog, 
hold down the Shift key before clicking Get.

8 Click OK.

The file is copied to the directory you specified.

If you are using Perforce, the Get command syncs the local file with the depot 
file. If a file is checked out or locked, the Get command does not work.
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Checking in files
This command updates the SCC application with the changes you made and unlocks the file. When 
another user accesses the file in the SCC application, the file includes all the modifications you made. If 
you check in files outside of TestTrack Pro, the fixed revision and fixed timestamp information is not 
captured in the TestTrack Pro database.

1 Select the defect with the file you want to check in on the Defects list window.

2 Choose Edit >Edit defect or click Edit on the Defects list window.

3 Click the Source Code tab.

4 Select the source file(s) and click Check in.

The Check in File(s) dialog box opens.

If you are using Perforce, you can only check in files from the default changelist.

This option is enabled for files that are checked out by an SCC user.
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5 Check the path.

This field defaults to the directory path you chose when the file was checked out. You can enter a 
different path or click Browse to select a path.

6 Select Keep checked out to update the master copy of a file while keeping the file checked out.

7 Select Remove local file to remove the copy from your working folder. 

8 Enter any comments.

Your database may include a check in comments template that automatically populates the comments 
field. You can add comments to the field or delete the comments and add your own. Select Apply 
comments to all files to use the same comment for each source file. This only applies if you are checking in 
multiple files at the same time.

9 Click Check in & Fix to check in the selected file(s) and then fix the defect(s).

The files are checked in and the Fix Defect dialog box opens.

10 Click Check in to check in the file(s) without fixing the defect.

Checking out files
This command lets you check out one or more files for editing. A writable copy of the file is placed in the 
directory you specify. Any user can attempt to check out a file in TestTrack Pro. If the SCC application is 
not configured to allow multiple checkouts, or a user has exclusively locked the file, the user trying to 
check out the file will be notified of the check out failure.

1 Select the defect you want to check out a file from on the Defects list window.

2 Choose Edit >Edit defect or click Edit on the Defects list window.

3 Click the Source Code tab.

Check in & Fix is only available if the defect is in the Open state.
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4 Select the source file(s) and click Check out.

The Check Out File(s) dialog box opens.

5 Enter a description of the reason for the check out in the Comment field.

Perforce does not support the Comment field.

6 Enter a directory path or click Browse to select a path. 

If you leave the Path field empty, the default location is used. The default location is determined by the 
SCC application, based on the SCC user configuration.

If you are checking out a single file, the value of the path field is determined by the SCC user 
configuration. If you are checking out multiple files, the path field may be empty because the default 
location can differ for each file.

7 Select a Replace writable option.

This option determines what happens if you try to check out a file that is already marked as writable.

! Ask prompts you to confirm that you want to overwrite the file.

! Replace automatically overwrites the writable file.

! Skip ignores the check out operation for the writable file.

8 Select a Set file time option.

! Current sets the current time (time of check out).

! Check in sets the time to the check in time.

! Modified sets the time to the last modification time.

This option is not available if you are using StarTeam.
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9 Click OK.

The file(s) is checked out.

Undoing check out
This command undoes a check out operation.

1 On the Source Code tab, select the source file and click Undo Check out.

The Undo Check out dialog box opens.

2 Select a Local file option.

! Replace the file in your local directory.

! Leave the file in your local directory.

! Delete the file from your working folder.

3 Click OK.

Viewing files
This command displays a copy of the selected file.

1 On the Source Code tab, select the source file and click View.

The View File dialog box opens.

2 Select a Viewing option and click OK. 

A copy of the file is opened.



Chapter 5 67
Viewing file history

Viewing file history
This command displays a file�s history.

1 On the Source Code tab, select the source file and click History.

The File History dialog box opens.

2 Click Close when you are finished.



68 TestTrack Pro
Using SCC Integration



Chapter 6 69
Managing the Workflow

Chapter 6
Managing the Workflow

Assign a defect…
...and get ready for some action! This chapter includes instructions for assigning defect actions and 
moving defects through the workflow.

In this section:

About the defect workflow, 70

Understanding defect assignments and actions, 72

Defect action toolbar, 73

Assigning defects, 74

Estimating defect fix time, 75

Fixing a defect, 76

Releasing a fix to testing, 77

Verifying a defect fix, 78

Releasing a fix to customer testing, 79

Releasing a fix to customer verification, 80

Closing defects, 81

Re-opening defects, 82

Adding comments to a defect, 83

Adding release notes to a defect, 84

Creating release notes, 85

Viewing defect actions, 86

Editing defect actions, 87

Deleting defect actions, 88

Replying to a defect submitter, 88

Sending mail from TestTrack Pro, 89



70 TestTrack Pro
About the defect workflow

About the defect workflow
The worfklow defines the path a defect takes from initial reporting to a resolution and consists of states. 
To move a defect from state to state, the defect is assigned to users who perform the action assigned to 
them. 

Defects can be assigned manually. You can also create auto-assign rules that assign defects to users 
based on specific criteria. For example, if a defect is added without being assigned, TestTrack Pro can 
automatically assign the defect to a specific user. For more information, see Configuring auto-assignment 
rules, page 155.

The status field, on the Edit Defect dialog box, corresponds to the defect state. The status field changes 
based on the defect action. For example, the status field changes to Fixed when the defect is moved to the 
Fixed state.

State State Description

Open The defect is added to the database.

Open (Re-opened) The defect is re-opened.

Open (Verify Failed) The fix failed verification.

Fixed The defect is fixed. 

Release to Testing The defect is fixed and released to testing.

Needs Customer Verification The fix needs to be verified by the customer. (optional)

Released to Customer Testing The defect is fixed and ready to be tested by the customer. (optional)

Closed (Verified) The fix is verified and the defect is closed. 

Closed (Customer Verified)  The customer verified the fix and the defect is closed. (optional)

Closed (Fixed) The defect is fixed and closed.

Closed The defect is closed.

The TestTrack Pro administrator is generally responsible for setting the 
optional workflow states, such as Closed (Customer Verified). For more 
information, see Setting workflow options, page 147.



Chapter 6 71
About the defect workflow

Defect workflow example

Following is a simple workflow example: 

When a defect is added, it is in the Open state. A project manager assigns a developer to fix the defect. 
After fixing the defect, and entering the fix information, the defect moves to the Fixed state. The project 
manager then assigns the defect to QA to verify the fix. After verifying the defect is fixed, a QA team 
member closes the defect. The defect moves to the Closed (Verified) state.

The following graphic shows a more complex workflow process:
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Understanding defect assignments and actions
Accountability, such as who is responsible for estimating, fixing, or verifying a fix, is an important 
component of defect tracking. Defects, and defect actions, are assigned to users to ensure someone is 
accountable and to move the defect through the workflow states. Depending on your security level and 
the database configuration, you may not have access to all, or some, of the defect actions. 

Each company uses defect assignments and actions differently. One company might let all users assign 
defects. Another company might only want team leads to be responsible for assigning defects while the 
users are responsible for such things as estimating a fix, fixing a defect, or verifying the fix.

Following is an example of how defect actions move a defect through the 
lifecycle: 

The Lead Engineer is notified when a defect is added to the database. After 
reviewing the defect, the Lead Engineer assigns the defect to Joe Estimator. 
The next day, Joe Estimator is notified of the defect assignment in two ways: 
the Assigned defect indicator appears next to the defect on the Defects list 
window and he receives an email notification. Joe Estimator opens the defect 
and views the Workflow tab. He can view who assigned the defect and what 
action he needs to perform.

He decides what needs to be done to fix the defect and enters the estimate 
information. The Lead Engineer is notified that the defect changed. She 
reviews Joe Estimator�s work and assigns the fix to Jane User. When Jane User 
logs in, she is notified of the defect assignment. Jane User opens the defect 
and views the Workflow tab. She can view her current defect assignment 
information and also view Joe Estimator�s notes � this helps her begin working 
on the fix. When Jane User finishes entering the Fix Defect information, the 
Lead Engineer is notified that the defect changed. The Lead Engineer reviews 
Jane User�s fix and assigns the next defect action. This process continues until 
the defect is fixed, tested, verified, and closed. 
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Defect action toolbar
Each defect action has a corresponding button located in a toolbar at the bottom of the Add Defect and 
Edit Defect windows. If you prefer, choose the defect action from the Activities menu.

Icon Action Description

Assign Assign the defect to a user

Estimate Estimate the time needed to fix a defect or 
implement a new feature

Fix Describe the fix

Release to Testing Release the defect to testing

Verify Verify the defect fix

Release to Customer 
Testing (optional)

Release the defect to customer testing

Customer Verify 
(optional)

Customer verify the defect fix

Close Override the lifecycle and close the defect

Re-open Re-open a closed defect

Comments Add comments to the defect

Release Notes Add release notes to a defect
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Assigning defects
To move a defect through its lifecycle, you need to assign the defect to a user. 

1 Choose Activities > Defect Actions > Assign or click the Assign Defect toolbar button.

The Assign Defect dialog box opens.

2 Select a user from the Assign to menu.

3 Check the date. 

This field defaults to the current date or you can enter a date. 

4 Select a user from the Assign by menu.

This field defaults to the logged in user.

5 Enter Notes about the defect action you are assigning or any additional information.

6 Click OK.

When you are assigned a defect, open the defect (Edit/View Defect dialog 
box) and click the Workflow tab. You can review the assignment notes. The 
person who assigned you the defect should let you know what defect action 
you are responsible for and provide any detailed information. If you need 
more information about the defect, select Mail > Reply to Submitter. The Send 
Mail dialog box opens. Enter your question and click Send. 
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Estimating defect fix time
1 Choose Activities > Defect Actions > Estimate or click the Estimate Fix toolbar button.

The Estimate to Fix Problem dialog box opens.

2 Select a user from the Estimate provided by menu. 

This field defaults to the logged in user.

3 Check the date. 

This field defaults to the current date or you can enter a date. 

4 Enter the Estimated effort in hours to complete the fix.

5 Enter the Estimated completion date.

6 Select a Version from the menu.

7 In the Notes field, enter detailed notes about the estimate such as modules that need to be changed or the 
developer who should work on the fix.

8 Click OK.

You can also click Save & Assign to save the defect action and assign the defect to a user.
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Fixing a defect
1 Choose Activities > Defect Actions > Fix or click the Describe Fix toolbar button. 

The Fix Defect dialog box opens.

2 Select a user from the Fixed by menu. 

This field defaults to the logged in user.

3 Check the date. 

This field defaults to the current date or you can enter a date. 

4 Select the Version of the product in which the defect was fixed. 

5 Select a Fix option.

6 Select a Resolution.

7 Enter the Hours to Fix.

This information is useful for future planning and estimating the time needed to fix similar defects.

8 Select the Affects Documentation check box or the Affects Test Plan check box if either applies.

9 In the Notes field, enter any detailed information about the fix.

10 Click OK.

You can also click Save & Assign to save the defect action and assign the defect to a user.
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Releasing a fix to testing
1 Choose Activities > Defect Actions > Release to Testing or click the Release to Testing toolbar button. 

The Release to Testing dialog box opens.

2 Select a user from the Released by menu.

This field defaults to the logged in user.

3 Select the Version number of the product to be released. 

4 Check the date. 

This field defaults to the current date or you can enter a date. 

5 In the Notes field, enter testing information.

6 Click OK.

You can also click Save & Assign to save the defect action and assign the defect to a user.
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Verifying a defect fix

After a defect is fixed, the fix should be verified. Verification results in one of the following outcomes: 

! The defect passed the verification and can be closed. 

! The defect passed but needs customer verification before it can be closed. This is optional, based on the 
database configuration.

! The defect failed the verification and still needs to be fixed.

1 Choose Activities > Defect Actions > Verify or click the Verify Fix toolbar button.

The Verify Defect dialog box opens.

2 Select a user from the Verified by menu. 

This field defaults to the logged in user.

3 Select the Version number. 

4 Check the date. 

This field defaults to the current date or you can enter a date. 

5 Select a Verification option.

6 In the Notes field, enter information such as the steps to reproduce the bug. 

If a fix fails, it is a good idea to record why the fix failed. It can help with future planning. 

7 Click OK.

You can also click Save & Assign to save the defect action and assign the defect to a user.

A defect must be fixed before it can be verified! 
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Releasing a fix to customer testing
1 Choose Activities > Defect Actions > Release to Customer Testing or click the Release to Customer Testing 

toolbar button. 

The Release to Customer Testing dialog box opens.

2 Select a user from the Released by menu. 

This field defaults to the logged in user.

3 Select the Version number of the product to be released. 

4 Check the date. 

This field defaults to the current date or you can enter a date. 

5 In the Notes field, enter testing information such as areas in the program that need to be tested or if the fix 
needs to be tested against a specific build.

6 Click OK.

You can also click Save & Assign to save the defect action and assign the defect to a user.
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Releasing a fix to customer verification

1 Choose Activities > Defect Actions > Customer Verify or click the Customer Verify toolbar button.

The Customer Verify Defect dialog box opens.

2 Check the Verified by field. 

This field defaults to the logged in user. 

3 Select the Version number. 

4 Check the date. 

This field defaults to the current date or you can enter a date. 

5 Select a Verification option.

! Select Pass and close if the fix works and the defect can be closed.

! Select Fail if the fix failed.

6 In the Notes field, enter testing information such as areas in the program that need to be tested or if the fix 
needs to be tested against a specific build.

7 Click OK.

You can also click Save & Assign to save the defect action and assign the defect to a user.

Customers with access to the TestTrack Pro database generally enter this 
information. Some companies give customers access to add and verify defects. 
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Closing defects
The resolution of some defects does not follow the standard fix/verify model. For example, a defect 
might not actually be a bug. In this situation, you can close the defect immediately, without going 
through the other defect actions.

1 Choose Activities > Defect Actions > Close or click the Close Defect toolbar button.

The Close Defect dialog box opens.

2 Select a user from the Closed by menu. 

This field defaults to the logged in user.

3 Check the date. 

This field defaults to the current date or you can enter a date. 

4 Select a Resolution.

5 In the Notes field, explain why you closed the defect.

6 Click OK.
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Re-opening defects
Occasionally, a closed or verified defect resurfaces. To return the defect to the Open state and restart its 
lifecycle, you need to re-open the defect.

1 Choose Activities > Defect Actions > Re-open or click the Re-open Defect toolbar button.

The Re-Open Defect dialog box opens.

2 Select a user from the Re-opened by menu. 

This field defaults to the logged in user.

3 Check the date. 

This field defaults to the current date or you can enter a date. 

4 In the Notes field, explain why the defect was re-opened.

5 Click OK.

You can also click Save & Assign to save the defect action and assign the defect to a user.



Chapter 6 83
Adding comments to a defect

Adding comments to a defect
You can add comments to a defect to point something out to other users, clarify an issue, or just as a 
reminder. Other users can view your comments on the Workflow tab.

1 Choose Activities > Defect Actions > Comment or click the Add Comments toolbar button.

The Defect Comments dialog box opens.

2 Select a user from the Comment by menu. 

This field defaults to the logged in user.

3 Check the date. 

This field defaults to the current date or you can enter a date. 

4 Enter the comments.

The comments are recorded with the defect history. 

5 Click OK.

To view defect comments, select the defect, click View or Edit, and then click 
the Workflow tab. All comments are included on the Workflow tab. 
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Adding release notes to a defect

1 Choose Activities > Defect Actions > Release Notes or click the Release Notes toolbar button.

The Release Notes About Fix or Feature dialog box opens.

2 Select a user from the Released by menu. 

This field defaults to the logged in user.

3 Select the Version number the release note affects.

4 Check the date. 

This field defaults to the current date or you can enter a date. 

5 Enter the release notes.

The notes are recorded with the defect history.

6 Click OK.

You can add multiple release notes to a defect. 

After you add release notes to a defect, you need to create the release notes 
for distribution. For more information, see Creating release notes, page 85.
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Creating release notes
You can create a text file containing all the release notes entered for any defect. You may want to include 
the text file in a Read-me file or include the Release Notes with your installer to inform users of new 
features and bug fixes.

The release notes file only contains the notes added to the Release Notes About Fix or Feature defect 
action. Release notes do not include the Defect description field. The process of generating release notes 
usually includes the following steps: add defect, fix defect, verify defect (pass), add release notes, 
generate release notes.

1 Choose Activities > Create Release Notes.

The Create Release Notes dialog box opens.

2 Enter Released Versions to Include information.

! Enter the From version and the Through version you want to include in the release notes. If the release 
notes are specific to one version, enter the same version number in both of these fields.

! Select a filter from the Use Filter menu to generate release notes for defects that meet the filter criteria.

! Select a product name from the Limit to Product menu to generate release notes for a specific product. 

! Select Include defects selected in defect list to generate release notes only from the defects selected on 
the Defects list window.

3 Select Presentation options.

! Select Sort versions from newest to oldest if you want TestTrack Pro to output the versions from newest 
to oldest.

! Select Insert a blank line� if you want a blank line between each release note. 

! Enter a character in the Begin each release note with field if you want each release note to start with 
the specific character (e.g., a bullet). You can also enter ASCII characters or leave the field empty.

4 Click Preview.

The Release Notes preview dialog box opens. If you need to make changes, you can edit the release notes 
in the preview window.

To generate release notes for just a few defects, select those defects on the 
Defects list window. If you do not know which defects contain release notes, 
add a column to the Defects list window to display the Has Release Notes? field. 
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5 Click Save As.

The Save Release Notes As dialog box opens.

6 Select the directory where you want to save the release notes and enter a file name.

7 Click Save.

TestTrack Pro generates the release notes and saves the text file in the directory you specified.

Viewing defect actions

You can view the defect action details.

1 Select the defect on the Defects list window.

2 Choose Edit > Defect or click Edit on the Defects list window.

The Edit Defect dialog box opens.

3 Click the Workflow tab.

This tab includes a list of all the defect actions.

4 Select the defect action you want to view.

5 Choose Edit > View Action.

A read-only dialog box for the defect action you chose opens. For example, the Verify Defect dialog box 
opens if you view a Verified action.

6 Click OK when you are finished.

Depending on your security level, you may not have access to this command.
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Editing defect actions

You can edit defect actions to add more information or correct mistakes. For example, a defect resolution 
affects documentation, but you forgot to select the Affects Documentation check box. You can edit the 
action to select the check box.

1 Select the defect on the Defects list window.

2 Choose Edit > Defect or click Edit on the Defects list window.

The Edit Defect dialog box opens.

3 Click the Workflow tab.

This tab includes a list of all the defect actions.

4 Select the defect action you want to edit.

5 Choose Edit > Edit Action.

A dialog box for the defect action you chose opens. For example, the Verify Defect dialog box opens if 
you edit a Verified action.

6 Make any changes and click OK.

Depending on your security level, you may not have access to this command.
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Deleting defect actions

1 Select the defect on the Defects list window.

2 Choose Edit > Defect or click Edit on the Defects list window.

The Edit Defect dialog box opens.

3 Click the Workflow tab.

This tab includes a list of all the defect actions.

4 Select the defect action you want to delete.

5 Choose Edit > Delete Action.

You are prompted to confirm the deletion.

6 Click OK.

The defect action is deleted.

Replying to a defect submitter
If you need more information or have questions about a defect, you can send an email directly to the 
defect�s submitter. 

1 Select the defect on the Defects list window.

2 Choose Mail > Reply to Submitter.

The Reply to Submitter dialog box opens.

Depending on your security level, you may not have access to this command.
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! The To field is populated with the name of the user or customer who submitted the defect. 

! The Subject field contains the defect�s summary text. 

! The message body contains the defect description.

3 Enter your question or the information you need clarified.

4 Click Send.

The email is sent.

Sending mail from TestTrack Pro
If the database you are using is enabled to send mail, you can send email directly from TestTrack Pro. 
This lets you easily communicate with other users and customers, without switching to your email 
program.

1 Choose Mail > Send Mail.

The Send Mail dialog box opens.

2 Click Add.

The Add Mail Recipients dialog box opens. All available users and customers are listed.

3 Highlight the users/customers you want to send mail to and click Add.

4 Enter a subject and message.

5 Click Send.

The email is sent.
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Chapter 7
Using Filters

Filter Out the Noise! 
This chapter includes instructions for creating and using filters to sort data. You can create as many 
filters as you need. The filters you create can be shared or kept private.

In this section:

About filters, 92

Creating filters, 93

About Boolean searches, 92

Using filters, 97

Viewing filters, 97

Editing filters, 97

Duplicating filters, 97

Deleting filters, 98
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About filters
TestTrack Pro provides extensive filtering capabilities. You can use filters to sort defect records and list 
only those defects that meet the criteria you select. You can create a simple filter, for example a filter that 
only shows fixed defects. Or, you can use Boolean logic to create more complex filters. Filters only apply 
to defects. 

If your database has a large number of defects, or you only need to work with certain types of defects, 
you should create a filter and use it to keep your defects list short and manageable. 

About Boolean searches
You can use Boolean logic to create complex and highly precise filters. Boolean logic uses three 
connecting operators (AND, OR, NOT) to narrow or broaden a search or to exclude a term from a search.

And is a narrowing term. When you use the �and� operator, the filter or search returns records that match 
all of the criteria you choose. For example, if you search for Component A AND Component B, TestTrack 
Pro only lists defects containing both components. 

Or is a broadening term. When you use the �or� operator, the filter or search returns records that match 
any of the criteria you choose. For example, if you search for Component A OR Component B, TestTrack 
Pro lists defects in which either term is found.

Not is an excluding term. When you use the �not� operator, the filter or search returns records that do not 
contain any of the criteria you choose. For example, if you search for NOT Component A, TestTrack Pro 
lists all defects�except for those containing the term Component A.

Nesting - with Boolean operators

You can combine searches in a variety of ways using the different combinations of Boolean operators. 
Parentheses are important because they keep the logic straight. In the grouping (Component A OR 
Component B) AND (Component C OR Component D) the parentheses around the first set tells the database 
to create a final set of records that may include either Component A OR Component B, but only when 
the records also include either Component C OR Component D.

Create custom filters to quickly view defect lists. For example, you can create 
a filter to track bugs by priority or a filter to track opens bugs that need to 
be fixed by a specific release, etc. 
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Creating filters

1 Choose Create > Filter or click Add on the Filters list window.

The Add Defect Filter dialog box opens.

2 Enter a Name and Description.

3 Select an option from the Share menu.

The default is private. If you share the filter, other users can edit the filter.

4 Click Add to add a filter restriction. 

The Restriction dialog box opens.

5 Select the field you want to include in the filter from the Restrict by menu.

Depending on your security level, you may not have access to all of the filter 
commands.

Most defect actions include Notes fields. You can select the All Action Notes 
field from the Restrict by menu to search these fields. After selecting All Action 
Notes, select an option, and enter the search text. 

When you 
select a field...

...the restrictions 
you can set 
appear here.
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6 Select the restriction options.

The restrictions you can set changed based on the Restrict by field.

! When selecting restrictions options, <Unknown> represents an empty field. For example, if you select 
<Unknown> with Restrict by set to Assigned To, it is interpreted as �Show all defects not assigned to 
anyone.� 

! If you are creating or editing restrictions with fields that include a text value, you can leave the text 
value empty. When the filter is applied, TestTrack Pro searches for the Restrict by field with an empty 
text value. This is useful if you are cleaning up your defect records and want to make sure that every 
defect includes a summary. Select Restrict by: Summary and leave the text value empty. When you 
apply the filter, all defects with an empty Summary field are listed.

7 Click OK.

You return to the Add Defect Filter dialog box. 

8 Select NOT/AND/OR operators and parentheses to build the Boolean Logic for the filter (optional step).

The Boolean search criteria appear in the Selected Restrictions box at the bottom of the dialog box. For 
more information, see About Boolean searches, page 92.

Repeat steps 4-7 to add more restrictions to your filter.

The Boolean 
search criteria 
you selected is 
listed here.

Use these buttons 
to add and 
modify filter 
restrictions.
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9 Click Validate.

! If the filter criteria is valid, click OK.

! If the filter criteria is not valid, an error message opens. Click OK to return to the Defect Filter dialog 
box and correct the error. 

10 Click Add. 

The Add Defect Filter dialog box clears and you can add another filter. Click Close when you finish 
adding filters.

Adding restrictions

1 Click Add on the Advanced Find Defects dialog box.

The Restriction dialog box opens.

2 Select the field you want to include in the search from the Restrict by menu.

When you select a field from the Restrict by list, the restriction options for that field open. These options 
change based on the Restrict by field you choose. 

3 Select any options and enter the field restrictions.

! If a List box opens, click the items you want in the filter. A check mark indicates an item is selected.

! If a From/Through Number box opens, enter the corresponding numbers.

! If a Date Restriction box opens, select a date.

! If option buttons opens, select one. 

4 Click OK.

The restriction is added. You return to the Advanced Find Defects dialog box.

Click Clear to clear all restrictions and start over. 

Repeat Steps 1-4 to continue adding restrictions.
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Viewing restrictions

1 Select the restriction on the Advanced Find Defects dialog box.

2 Click View.

The selected restriction opens in the Restriction dialog box. All fields are read-only and cannot be edited. 

3 Click OK to close the Restriction dialog box.

Editing restrictions

1 Select the restriction on the Advanced Find Defects dialog box. 

2 Click Edit.

3 Make any changes and click OK.

Your changes are saved and you return to the Advanced Find Defects dialog box. 

Inserting restrictions

If your filter contains a large number of restrictions, you can insert a new restriction in a specific position. 

1 Select the restriction you want to insert the new restriction above on the Advanced Find Defects dialog 
box.

2 Click Insert.

The Restriction dialog box opens.

3 Add the restriction and click OK.

The new restriction is inserted above the selected restriction.

Deleting restrictions

1 Select the restriction you want to delete on the Advanced Find Defects dialog box.

2 Click Delete.

The restriction is deleted.

You are not prompted to confirm the deletion and the action cannot be 
undone.
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Using filters
1 Select the filter from the Filter menu on the Defects list window.

2 The filter is applied to the defects.

! Defects that meet the filter criteria are listed on the Defects list window. 

! To return to a list of all defects, select Not Filtered from the Filter menu.

Viewing filters
1 Select the filter on the Filters list window.

2 Choose Edit > View Filter or click View on the Filters list window.

The View Defect Filter dialog box opens. All fields are read-only.

3 Click OK when you are finished.

Editing filters
1 Select the filter on the Filters list window.

2 Choose Edit > Edit Filter or click Edit on the Filters list window.

The Edit Defect Filter dialog box opens. 

3 Make any changes and click OK.

Your changes are saved and you return to the Filters list window. 

Duplicating filters
1 Select the filter on the Filters list window.

2 Choose Edit > Duplicate Filter.

The filter is duplicated. A number is added to the end of the filter name. For example, if you duplicate 
Priority Filter 2 times, the duplicated filters are named Priority Filter 1and Priority Filter 2.
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3 Modify the duplicated filter and save your changes.

Deleting filters
1 Select the filter on the Filters list window.

You can select more than one filter to delete. 

2 Choose Edit > Delete Filter or click Delete on the Filters list window.

You are prompted to confirm the deletion.

3 Click OK.

The filter is deleted.
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Chapter 8
Managing Test Configs

Track the nuts and bolts! 
This chapter includes test configuration instructions. It is important to pay attention to the computers 
defects are found on. Is it a hardware problem or a display driver bug? Track your test configurations 
and identify the patterns.

In this section:

About test configs, 100

Adding test configs, 100

Viewing test configs, 101

Editing test configs, 101

Duplicating test configs, 101

Deleting test configs, 101
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About test configs
A test configuration refers to a specific computer used for testing and the hardware and software found 
on this computer. You should track all your systems to see if bugs are computer-specific. Tracking test 
configurations helps you identify patterns in defects that may be related to specific hardware 
configurations or software configurations. You can verify that your application functions the same, or in 
an appropriately similar manner, across all supported platforms or configurations.

Adding test configs
1 Choose Create > Test Config or click Add on the Test Configs list window.

The Add Test Config dialog box opens with the CPU tab selected.

2 Enter a test configuration Name.

3 Enter the information on the CPU tab.

! Click Capture Config. TestTrack Pro can automatically fill in some of the fields (for example, Operating 
System). 

! Enter information in the other CPU fields. This information is optional but you should provide as 
much detail as possible. 

4 Click the Peripherals tab and enter the peripherals information.

These fields are optional but you should enter as much information as possible. 

5 Click Add.

The Test Config is added.

Click Capture Config to 
automatically capture 
some computer 
configuration 
information.
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Viewing test configs
1 Select the test config on the Test Configs list window.

2 Choose Edit > View Test Config or click View on the Test Configs list window.

The View Test Config dialog box opens. All fields are read-only.

3 Click OK when you are finished.

You return to the Test Configurations list window.

Editing test configs
1 Select the test config on the Test Configs list window.

2 Choose Edit > Edit Test Config or click Edit on the Test Configs list window.

The Edit Test Config dialog box opens. 

3 Make any changes and click OK.

Duplicating test configs
1 Select the test config on the Test Configs list window.

2 Choose Edit > Duplicate Test Config.

The test configuration is duplicated. A number, incremented by 1, is added to the end of the test config 
name. For example, if you select and duplicate Eng-cube, the duplicated test config is named Eng-cube1.

3 Modify the duplicated test config and save your changes.

Deleting test configs
1 Select the test config on the Test Configs list window.

You can select more than one test config to delete.

2 Choose Edit > Delete Test Config or click Delete on the Test Configs list window.

You are prompted to confirm the deletion.

3 Click OK.
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Chapter 9
Generating Reports

Analyze and Report! 
You will be running reports in no time! TestTrack Pro makes reporting simple�point, click, print, 
and read. You can design and preview each report before printing. You can also share your report 
with other users or keep it private.

In this section:

About reports, 104

Using stylesheets, 104

Creating text file report templates, 106

Creating detail reports, 107

Creating distribution reports, 110

Creating list reports, 113

Creating trend reports, 116

Charting report data, 119

Viewing report settings, 121

Editing reports, 121

Previewing reports, 121

Printing reports, 122

Saving a copy of a report, 122

Deleting reports, 123
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About reports
Reports are used to analyze the data collected in your database. You can use filters to build reports that 
focus on the data you need. You can also share your reports with others or keep them private. You can 
create the following four kinds of reports:

! Detail reports include detailed information about defects, customers, users, user groups, or test 
configurations.

! Distribution reports include the distribution of defects. You can choose options such as defects found 
by user, defect status by component, etc. You can add a chart to the report for additional impact. For 
example, you could build a distribution report that shows the number of fixed defects for each user.

! List reports include summary information about defects, customers, users, user groups, or test 
configurations. You select the fields to include in the report.

! Trend reports include defect events over time. For example, how many defects have been fixed this 
week? You can add a chart to the report for additional impact. Use this report to determine how well 
you are managing defects.

Using stylesheets
Stylesheets are templates you can use to quickly generate formatted reports. Several Extensible Style 
Language (XSL) stylesheets are installed with TestTrack Pro to help you easily create reports with 
predefined layout and design options. The stylesheets are available to all TestTrack Pro users with access 
to the database.

Customizing stylesheets

You can customize an existing XSL stylesheet or create your own and add it to the TestTrack Pro 
database. Stylesheets are generally located in the Program Files/TestTrack Pro/StyleSheets directory or the 
Program Files/ Seapine/ TestTrack Pro/ Stylesheets directory. Each report type has a corresponding folder in 
the Stylesheets directory.

! To customize an existing stylesheet, open the corresponding report folder, select the stylesheet, and 
modify it using a third-party tool, such as Altova�s XML Spy.

! To add a new stylesheet, use a third-party tool to create the stylesheet. Copy the completed stylesheet 
to the corresponding report folder. 

! To include an image with a stylesheet, copy the image to the Images folder in the TestTrack Pro 
directory. Add the following script to the stylesheet:

<img>
<xsl:attribute name=�src�>
<xsl:value-of select=�external:get-server-image(�imagename.gif�)� />
</xsl:attribute>

</img>
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Setting default stylesheets

You can select default stylesheets to use when printing from list windows.

1 Choose Edit > Options > Local Options.

The Local Options dialog box opens.

2 Click the Stylesheets tab.

3 Select a Report Type from the list.

Each Report Type corresponds to a list window. For example, the Filter View Detail Report prints a detail 
report for all filters in the database.

4 Select a Default Stylesheet for the selected report or click Browse to use a customized stylesheet.

5 Click OK.

Refreshing stylesheet menus

The server periodically searches the database for new stylesheets and updates the stylesheet menu 
options. You can determine the frequency of this update by modifying your database options.

1 Choose Edit > Options > Database Options.

2 Click the Reports tab.

3 Select how often the server looks for new stylesheets.

4 Click OK.
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Creating text file report templates

You can create custom report templates using a text editor, TestTrack Pro field codes, and alphanumeric 
characters. You can even create a tab or comma-delimited document for use with other databases/tools.

1 Using Notepad, or another text editor, create the text document using field codes for TestTrack Pro-
specific information. You can use other alphanumeric characters.

The report is formatted based on the text code layout. Field codes are replaced with the corresponding 
text. For example, you can set up the following report template:

%ASSD% - %ASST%
---------------------- 
%DESC%

This creates a report that includes the date the defect was most recently assigned, followed by a dash, 
followed by the user the defect is assigned to. The next line is a dashed line. On the next line is the defect 
description. This pattern repeats until all selected records are displayed.

2 Save the document.

You can now print a report based on the template you created.

Using text file report templates

1 Choose File > Print.

If you do not want to print every item in the list, select the items you do want to print. Make sure you 
select the Only Print Selected Items check box on the Print Options dialog box. If you apply a filter only the 
defects that pass the filter will be used as the basis of the ad hoc report.

2 Select Create report file from template.

The best way to customize a report to meet your requirements is to create a 
stylesheet. See Using stylesheets, page 104 for more information.

For a list and description of field codes, see Appendix A, �Field Codes 
Reference�, page 243.
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3 Click Save. 

The Select Report Template dialog box opens.

4 Select the report template you want to use and click Open. 

The Save Report As dialog box opens.

5 Select a directory and enter a filename.

6 Click Save.

The report is saved as a text file.

Creating detail reports
1 Choose Create > Report > Detail or click Add on the Reports list window. 

2 Select Detail and click OK.

The Add Detail Report dialog box opens.

3 Enter a Name and Title.

The title appears at the top of the report when it is viewed or printed.

4 Select an option from the Share menu.

If you share the report, users with the proper command-level security can edit the report. Select Private to 
protect your report.

Select Text Files or All Files from the Files of type menu.
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5 Select the Report On options.

! Select the record type from the Report contains menu.

! If you select Customers, Users, User Groups, Customers, or Test Configs you can build a report on all, or 
selected, records.

6 Click the Options tab.

! Select a Stylesheet or click Browse to use a customized stylesheet.

! If you select Defects you can also choose a filter on the Options tab. 

! Optionally, select a Filter if you are reporting on defects. The report only contains defects that meet 
the filter criteria.

! Select Print items on separate pages to insert page breaks between each item in the report. Internet 
Explorer is the only browser that supports page breaks.

Detail reports display the creation and modified time at the bottom of the 
report. Configure the report to use the server�s time zone or GMT. 

Choose Edit > Options > Database Options. Click the Reports tab. Select a time 
zone and click OK.
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7 Click the Sorting tab.

Optionally, select a Primary and Secondary sort column. You can also set the column to sort ascending 
or descending.

8 Click Add.

The Add Detail Report dialog box clears. You can add another report if you want.

9 Click Close when you are done adding reports.
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Creating distribution reports
1 Choose Create > Report > Distribution or click Add on the Reports list window. 

2 Select Distribution and click OK.

The Add Distribution Report dialog box opens.

3 Enter a Name and Title.

The title appears at the top of the report when it is viewed or printed.

4 Select an option from the Share menu.

If you share the report, users with the proper command-level security can edit the report. Select Private to 
protect your report.

5 Select the Report On options.

! Select Defects <field> by User to build a report that includes action by user. For example, Defects 
Found by User.

! Select Defects report by <field> to build a report that includes the number of defects based on the 
chosen category. For example, Defects reported by Status.

! Select Defect status by <field> to build a report that includes the defect status based on the chosen 
category. For example, Defects status by Type.

! Select Defect <field> By <field> to build a report that includes the defect status using two criteria. For 
example, Defect Type by Priority.
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6 Click the Options tab.

! Select the report date parameters for your report using the Period and through menus.

! Select a Stylesheet or click Browse to use a customized stylesheet.

! Optionally, select a Filter if you are reporting on defects. The report only contains defects that meet 
the filter criteria.

! Select Include totals to include totals for the selected report items. If you select this option, you can add 
the totals to a chart using the Data to Graph menu on the Graphing tab.

! Enter a number in the Records per printed page field to insert page breaks between rows in the report.

7 Click the Sorting tab.

Optionally, select a Primary and Secondary sort column. You can also set the column sort order to 
ascending or descending.
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8 Click the Graphing tab

This tab is used to add a chart to the report. For more information, see Charting report data, page 119.

9 Click Add.

The Add Distribution Report dialog box clears. You can add another report if you want.

10 Click Close when you are done adding reports.
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Creating list reports
1 Choose Create > Report > List or click Add on the Reports list window. 

2 Select List and click OK.

The Add List Report dialog box opens.

3 Enter a Name and Title.

The title appears at the top of the report when it is viewed or printed.

4 Select an option from the Share menu.

If you share the report, users with the proper command-level security can edit the report. Select Private to 
protect your report.

5 Select the Report On options.

! Select the record type from the Report contains menu.

! Select the fields from the Available Fields list and click Add.

! To change the field order, select a field from the Fields in Report list and click Up or Down.
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6 Click the Options tab.

! Select a Stylesheet or click Browse to use a customized stylesheet.

! Optionally, select a Filter if you are reporting on defects. The report only contains defects that meet 
the filter criteria.

! Enter a number in the Records per printed page field to include page breaks between detail rows.

7 Click the Sorting tab.

Optionally, select a Primary and Secondary sort column. You can also set the column to sort ascending 
or descending.
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8 Click the Formatting tab.

Field and table settings are defined by the default stylesheet. This tab lets you override the stylesheet 
settings for a list report. For example, you can change the report header font style, size, color, or 
alignment. Select Report Header from the list and use the field settings to make any changes.

9 Click Add.

The Add List Report dialog box clears. You can add another report if you want.

10 Click Close when you are done adding reports.
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Creating trend reports
1 Choose Create > Report > Trend or click Add on the Reports list window. 

2 Select Trend and click OK.

The Add Trend Report dialog box opens.

3 Enter a Name and Title.

The title appears at the top of the report when it is viewed or printed.

4 Select an option from the Share menu.

If you share the report, users with the proper command-level security can edit the report. Select Private to 
protect your report.

5 Select the Report On options.

! Select Defect status in period to report on the number of defects in each state (Open, Fixed, etc.) over 
the specified reporting period.

! Select Defects <field> by <field> to report on the number of defects that are Open, Fixed, Closed, etc. 
by Type, Priority, or Resolution.

! Select Defect open age in period to report on the number of defects open over the specified reporting 
period.

! Select Actual vs. Estimated hours to report on the difference between the actual and estimated time for 
fixing defects.
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6 Click the Options tab.

! Select the date parameters for the report using the Period, From, and through menus.

! Select a Stylesheet or click Browse to use a customized stylesheet.

! Optionally, select a Filter if you are reporting on defects. The report only contains defects that meet 
the filter criteria.

! Select Include totals to include totals for the selected report items. If you select this option, you can add 
the totals to a chart using the Data to Graph menu on the Graphing tab.

! Enter a number in the Records per printed page field to insert page breaks between detail rows.
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7 Click the Graphing tab.

This tab is used to add charts to the report. For more information, see Charting report data, page 119.

8 Click Add.

The Add Trend Report dialog box clears. You can add another report if you want.

9 Click Close when you are done adding reports.



Chapter 9 119
Charting report data

Charting report data
You can add charts to distribution and trend reports. The available charts include pie, 3D pie, bar, 3D 
bar, area, 3D area, line, and 3D line.

Bar, area, and line charts

You can design a bar, area, or line chart using the available graphing fields.

Graphing field: Use to:

Type Select the type of report

Data to Chart Select report data

Title Enter a chart title

Size Select the chart title size

Color Select the chart title font color

Height Select the chart height

Width Select the chart width

Background Color Select the chart background color

X Axis Title Enter an X axis title

Y Axis Title Enter a Y axis title

Size Select the X and Y axis title size

Color Select the X and Y axis title font colors

Show Labels Show chart component labels

X Axis Size Select the X axis label size

Y Axis Size Select the Y axis label size

Spacing Enter the amount of space between labels

Color Select the X and Y axis label color

Density Enter a density percentage. 80% displays all labels, 40% displays half, etc.

Show Grid Select to show the chart grid pattern

Show X Axis Select to show the X axis

Show Y Axis Select to show the Y axis

Color Select the color for the grid lines and the X and Y axis lines
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Pie charts

Use the graphing fields to add and design pie charts.

Graphing field: Use to:

Type Select the report type

Data to Chart Select report data

Title Enter a chart title

Size Select the chart title size

Color Select the chart title font color

Height Select the chart height

Width Select the chart width

Background Color Select the chart background color

Show Labels Show chart data labels

Show Percents Show chart data in percents

Label Size Select the chart label size

Color Select the label font colors

Label Position Set the spacing of the chart labels

Pie charts are scaled based on a number of factors, including image size, 
label size, and number of labels. You may need to change the image height 
and width dimensions for the pie chart to display correctly.
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Viewing report settings
1 Select the report on the Reports list window.

2 Choose Edit > View Report or click View on the Reports list window.

The View Report dialog box opens. All fields are read-only.

3 Click OK when you are finished.

Editing reports
1 Select the report on the Reports list window.

2 Choose Edit > Edit Report or click Edit on the Reports list window.

The Edit Report dialog box opens.

3 Make any changes and click OK.

Previewing reports
1 Select the report on the Reports list window and click Preview.

The report opens in preview mode.

2 Click the Next and Previous arrows, or use the scroll bar, to move through the report.

3 Click Page Setup to change the page options or click Print to print the report.

You can also click Save As to save the report as a text file.
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Printing reports
1 Select the report on the Reports list window and click Print.

The print dialog box opens.

2 Make your selections and click Print.

Saving a copy of a report
You can save a copy of a report as an HTML file and open it later to modify the data.

1 Select the report on the Reports list window and click Preview.

2 Choose File > Save As.

The Save Report Files dialog box opens.

3 Select a location from the Save in menu.

4 Enter a report name in the File name field.

5 HTML Files is automatically selected from the Save as type menu.

6 Click Save.

The report file is saved in the location you specified.
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Deleting reports
1 Select the report on the Reports list window.

You can select more than one report to delete.

2 Choose Edit > Delete Report or click Delete on the Reports list window.

You are prompted to confirm the deletion.

3 Click OK.

The report is deleted.
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Chapter 10
Using the Workbook

So much to do!
So little time to do it? This chapter includes instructions for using the Workbook to view defects and 
track other tasks. TestTrack Pro, and the Workbook, can help you stay organized!

In this section:

About the workbook, 126

Adding to do tasks, 126

Viewing to do tasks, 127

Editing to do tasks, 127

Duplicating to do tasks, 127

Deleting to do tasks, 127
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About the workbook
Use the Workbook to keep track of defects, loose ends, and various other tasks. For example, you can 
add To Do tasks to remind you about upcoming deadlines.

Understanding Workbook tasks

You can track defect tasks and To Do tasks in the Workbook. Task indicators in the type column of the 
Workbook list point out your assigned defects and the To Do tasks you added to the Workbook.

Adding to do tasks
1 Choose Create > To Do or click Add on the Workbook list window.

The Add To Do dialog box opens.

2 Enter a task name in the To Do field.

3 Select the task priority from the Priority menu.

4 Check the date.

5 Select a Need by date or Version.

6 Enter a description.

7 Click Add.

The task is added to TestTrack Pro.

Icon Name Indicates

Defect tasks Defects assigned to you. TestTrack Pro adds these tasks to the Workbook.

To Do tasks Defects that changed since you last logged in

The Workbook tracks 
bugs assigned to you...

...and any To Do tasks you 
add.
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Viewing to do tasks
1 Select the task or defect on the Workbook list window.

2 Choose Edit > View Task or click View on the Workbook list window.

The View To Do or View Defect dialog box opens. All fields are read-only.

3 Click OK when you are finished.

Editing to do tasks
1 Select the task or defect on the Workbook list window.

2 Choose Edit > Edit Task or click Edit on the Workbook list window.

The Edit To Do or Edit Defect dialog box opens.

3 Make any changes.

If the task is complete, select Done.

4 Click OK.

Your changes are saved and you return to the Workbook list window. 

Duplicating to do tasks
1 Select the task on the Workbook list window. You can only duplicate tasks, you cannot duplicate defects. 

2 Choose Edit > Duplicate Task.

The task is duplicated.

3 Modify the duplicated task and save your changes.

Deleting to do tasks
1 Select the task on the Workbook list window. You can only delete tasks. You cannot delete defects.

2 Choose Edit > Delete Task or click Delete on the Workbook list window.

You are prompted to confirm the deletion.

3 Click OK.

The task is deleted.
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Chapter 11
Integrating with Developer Tools

Use the TestTrack Pro Add-In…
and never leave your development environment! This chapter includes instructions for programmers 
who are using the add-in to access TestTrack Pro functions, from within Visual Basic, Visual C++, 
and Visual Studio .NET.

In this section:

About the TestTrack Pro Add-In, 130

Installing the Add-In, 130

Add-In toolbar, 131

Connecting to a database, 132

Setting options, 133

Working with defects, 136

Using the workbook, 138

Disconnecting, 140
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About the TestTrack Pro Add-In
The TestTrack Pro Add-In can be used with Visual Basic 6.0, Visual C++ 6.0, and Visual Studio .NET. 
The Add-In lets you stay in your development environment while accessing TestTrack Pro functions. A 
dockable TestTrack Pro toolbar is added to the IDE.

The TestTrack Pro Add-In functions the same regardless of your development environment. There are a 
few exceptions:

! Visual Basic has no concept of a workspace. If you are working in the Visual Basic development 
environment, there is no provision for connecting to a database. Also, you cannot set TestTrack Pro Add-
In options in Visual Basic.

! Visual C++ refers to workspaces. Visual Studio .NET refers to solutions.

Installing the Add-In
During TestTrack Pro client installation, the Add-In Options dialog box opens if Visual Basic 6.0, Visual 
C++6.0, or Visual Studio .NET are installed on your computer. The TestTrack Pro Add-In is 
automatically installed.

! If Visual C++ 6.0 is installed on your computer, make sure you read the Note information. It include 
instructions for enabling the Add-In.

! If Visual Basic 6.0 or Visual Studio .NET is installed on your computer, select the corresponding 
development environment check box. You do not need to manually enable the Add-In.
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Add-In toolbar
The TestTrack Pro toolbar contains buttons that give you access to TestTrack Pro functions and list 
windows�just a click away!

Button Name Action

Connect Connects you to the server

Disconnect Disconnects your server connection

Defect List Opens the Defects list window

Add Defect Opens the Add Defect dialog box

Task List Opens the Workbook/Task list window

Add Task Opens the Add To Do dialog box

Options Opens the Options dialog box

About Opens the About dialog box

The Options button is not available with Visual Basic.
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Connecting to a database
1 Click the Connect toolbar button.

The Server Connection dialog box opens.

2 Select a server from the Connect to TestTrack Pro Server menu and click Connect.

The Login dialog box opens.

3 Enter your username and password. 

4 Select a database from the Database menu and click OK.

You are connected to the TestTrack Pro server and database.

Where to go next...

If you are the Lead Engineer, start with the Defects list. Use a filter to display 
all defects created, fixed, or verified in the last week and that are not 
currently assigned and not in the closed state. Then, assign the defects to the 
appropriate person.

If you are an Engineer/Developer, start with the Task list. The Workbook Task 
list displays all the defects assigned to you and any to do tasks you added. 
You can also start with the Defects list and choose a filter that displays the 
defects you need to work with.
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Setting options
You can set Open Workspace and Login options that are specific to Visual C++ and Visual Studio .NET.

Each workspace/solution can be associated with a single TestTrack Pro database. Multiple 
workspaces/solutions can also be associated with one TestTrack Pro database. The TestTrack Pro 
database does not have a direct link to a workspace/solution. 

When a workspace/solution is opened, and a TestTrack Pro database is associated with the 
workspace/solution, the TestTrack Pro Add-In receives a message. A connection with the TestTrack Pro 
server is established and you are logged into the database. When a workspace/solution is closed, you 
are logged out of the current database.

Open Workspace tab

1 Click the Options toolbar button.

The Developer Studio Add-In Options dialog box opens with the Open Workspace tab selected.

2 Select Do nothing (leave the TestTrack connection as is) if you do not want to connect to the TestTrack Pro 
Server and log in to a TestTrack Pro database.

3 Select Always login to the default TestTrack database to automatically log in to your default database. You 
can specify the default database on the Login tab.

4 Select Login to the TestTrack database associated with this workspace to automatically log in to a database. 
After selecting this option, you need to choose an option from the dropdown list. The dropdown list 
determines what happens when a TestTrack Pro database is not associated with the workspace.

Remember, Visual Studio .NET refers to solutions and Visual C++ refers to 
workspaces. The following examples and screenshots use Visual C++. If you 
are working in a Visual Studio .NET development environment, the dialog 
boxes and text may be different.
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Setting default login information

The Login tab lets you set the default login information and associate Visual Studio workspaces with 
TestTrack Pro databases. When you open a workspace, you can automatically login and connect to a 
specific TestTrack Pro database.

1 Click the Options toolbar button.

The Developer Studio Add-In Options dialog box opens.

2 Click the Login tab.

3 Click Edit in the Default TestTrack Login area.

4 The Associate Workspace with TestTrack dialog box opens.

5 Select a server. 

Click Configure to add a server. For more information, see Adding server connections, page 9.
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6 Select a database.

7 Enter your Username and Password.

8 Click OK.

The Default TestTrack Login area is populated with the information you entered. Click Edit to change 
any information.

Associating a workspace with TestTrack Pro

1 Click the Options toolbar button.

The Developer Studio Add-In Options dialog box opens.

2 Click the Login tab.

3 click Add in the Associate TestTrack area.

The Associate Workspace with TestTrack dialog box opens.

4 Click Use Current or the Browse button to select the workspace you want to associate with the database.

Selecting Save full pathname for the workspace gives you greater control of the workspace association. For 
example, you have two workspace files with the same filename. This option lets you associate each 
workspace with a different TestTrack Pro database.
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5 Select a server.

Click Configure to add a server. For more information, see Adding server connections, page 9.

6 Select a database. 

7 Enter your Username and Password.

8 Click OK.

The Associate TestTrack area is populated with the information you entered.

Working with defects
The defect list tracks all defects entered in a database. For more information, see About defects, page 30.

Opening the defect list

1 Click the Defect List toolbar button.

The Defects list window opens.

Adding defects

1 Click the Add Defect toolbar button or click Add on the Defect list window.

The Add Defect dialog box opens.

Select a row and click Edit to make changes. If you want to delete an 
association, select a row and click Delete. Make sure you want to delete the 
association - you are not prompted to confirm the deletion and this action 
cannot be undone!
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2 Enter the defect information.

For more information, see Adding defects, page 30.

3 Click Add to save the defect information and add the defect.

Click Close to close the Add Defect dialog box.

Viewing defects

1 Select the defect on the Defects list window.

2 Click View.

The View Defect dialog box opens. All fields are read-only.

Editing defects

1 Select the defect on the Defects list window.

2 Click Edit.

The Edit Defect dialog box opens.

3 Make any changes and click OK.

Deleting defects

1 Select the defect on the Defects list window.

2 Click Delete.

You are prompted to confirm the deletion. 

3 Click OK.
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Using the workbook
The workbook tracks your defects, loose ends, and other tasks. For example, you can add tasks to remind 
you about meetings or upcoming deadlines.

Task indicators appear in the type column of the Workbook list window. These indicators point out your 
assigned defects and tasks you added.

Opening the Workbook task list

1 Click the Task List toolbar button.

The Workbook list window opens.

Adding tasks

1 Click the Add Task toolbar button or click Add on the Workbook list window.

The Add To Do dialog box opens.

Icon Name Indicates

Defect tasks Defects assigned to you. TestTrack Pro adds these tasks to the workbook.

To Do tasks Project-related tasks you add to the workbook.
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2 Enter the task information.

For more information, see Adding to do tasks, page 126.

3 Click Add.

The dialog box clears and you can add another task. Click Close when you finish.

Editing tasks

1 Select the task or defect on the Workbook list window. 

2 Click Edit.

The Edit To Do or Edit Defect dialog box opens.

3 Make any changes and click OK.

If the To Do task is completed, select Done. The task appears greyed-out and a check mark is displayed in 
the first column of the Workbook list window.

Viewing tasks

1 Select the task or defect on the Workbook list window.

2 Click View.

The View To Do or View Defect dialog box opens. All fields are read-only.

Deleting tasks

1 Select the task on the Workbook list window.

You can only delete To Do tasks. You cannot delete defects.

2 Click Delete.

You are prompted to confirm the deletion. 

3 Click OK.

The To Do task is deleted.
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Disconnecting
When you finish working with your defects, make sure you disconnect from the database and server.

1 Click the Disconnect toolbar button.

A warning message opens, stating the open database and server connection will be closed.

2 Click Yes.

The database is closed and you are disconnected from the server.
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Chapter 12
Configuring Databases

Lay the foundation! 
Databases are one of the most important components of TestTrack Pro - take the time to configure 
your databases and keep your users productive! This chapter includes detailed information about 
setting database options.

In this section:

About databases, 142

Setting general options, 143

Setting defect options, 144

Setting send mail options, 145

Setting workflow options, 147

Setting import mail options, 148

Setting SoloBug options, 150

Setting SoloSubmit options, 151

Setting report options, 153

Setting password options, 154

Configuring auto-assignment rules, 155

Logging historical defect information, 159
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About databases
A TestTrack Pro database contains all the information you track, including defects, user groups, users, 
customers, filters, test configurations, and workbook tasks. 

Databases are initially created and stored on the computer where the TestTrack Pro Server is installed. 
Databases can be also be moved to another computer, separate from the computer where the TestTrack 
Pro Server is installed. For more information, see the Server Admin Utility Guide.

Creating databases

The TestTrack Pro administrator, or another user with high level security, creates all the databases using 
the Server Admin Utility. If you need a new database, see your administrator. If you are the TestTrack Pro 
administrator, see Creating a database in the Server Admin Utility Guide.

TestTrack Pro
Server

TestTrack Pro
Server

TestTrack
Pro

Database

TestTrack

Database
Pro

TestTrack

Database

TestTrack

Database
Pro Pro

Database
Server

Sample server/database configurations
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Setting general options
1 Chose Edit > Options > Database Options.

The Database Options dialog box opens, with the General tab selected.

2 Enter a Project Name and Description. 

The project name does not change the database name.

3 Select Hide navigation buttons if no security access to hide the Web navigation buttons. 

If you do not select this option, and the user does not have security access, the buttons appear on the web 
page but are disabled. This option only affects the web client.

4 Click OK or click another tab to continue setting options.
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Setting defect options
1 Chose Edit > Options > Database Options.

2 Click the Defects tab.

3 Select the Defer numbering defects options.

For each of the options, select the check box to automatically assign a defect number.

4 Select the Next number options.

! The Next defect number can be set to any value greater than the largest defect number.

! The Next sequence number can be set to any value greater than the largest sequence number.

5 Select the Version fields options.

You can configure version field menus to accept text entries or restrict version fields to pop-up menus.

Version fields options affect the following fields: version found, version fixed, 
version verified, version released, and estimated completion.
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6 Select Enable logging of historical defect information to log historical information.

For more information, see Logging historical defect information, page 159.

7 Click OK or click another tab to continue setting options.

Setting send mail options
1 Chose Edit > Options > Database Options.

2 Click the Send Mail tab.

3 Select Enable sending of mail for this project to enable mail.

If you do not select this option, users cannot use the Send Mail command or receive email notifications. 

4 Select the Return address for email notifications options.

! Always use the notification email account for the return address is the default option. 

! Only use notification account if no TestTrack user is logged in uses the notification account information. 
For example, a user might not be logged in during email import or while using SoloSubmit. In either 
case, the notification account information is used.
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! Only use notification account if the logged in user�s email address is blank ensures that an email address 
is available if the logged in user did not provide his or her email information. 

! Enter a notification account name. The notification account name defaults to �TestTrack.� You will 
probably want to customize the account name for your company

! Enter an email address. If you do not enter an email address, your email may be rejected. Some 
Internet providers will not accept email without a return address. 

5 Select the Recipient list for email notifications options.

If privacy is an issue, select Each email has a single recipient. If you select Email contains multiple recipients, 
each person who receives an email can view the list of recipients and their email addresses.

6 Select the Notification options for closing defects.

! The notification can be limited to submitters (same as Found By person) who are users, customers, or 
both. If a defect is submitted by more than one person, each submitter is sent an email. 

7 Select Don�t send notification if defect is added in a closed state if you do not want a notification sent when 
a defect is added in a closed state. For example, you add a defect, enter defect information, add a fixed 
event, and add a verify & close event. You probably do not want to send a notification since the defect 
was added in the closed state.

8 Click OK or click another tab to continue setting options.
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Setting workflow options
1 Chose Edit > Options > Database Options.

2 Click the Workflow tab.

3 Select the Defect Workflow Options.

You can add optional states to the defect workflow.

! Enable �Release to Test� State adds the testing state to the workflow, indicating the defect fix needs to 
be tested.

! Enable �Needs Customer Verification� State adds the customer verification state to the workflow, 
indicating the defect is fixed and needs customer verification.

! Enable �Release to Customer Testing� State adds the customer testing state to the workflow, indicating 
the defect is fixed and needs to be tested by the customer.

4 Select the Field Relationship Options.

These options force a child field�s value to <not set> if a parent field changes and the child field value is 
no longer valid.

! When a defect is added, you want to enforce the field relationship and prevent data that does not 
make sense from being entered. Select the option to force the child field�s value to <not set> on the 
Add Defect window.
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! When a defect is edited, you need to preserver the original information so historical defect 
information is not lost. Do not force the child field�s value to <not set> on the Edit Defect window. 

5 Click OK or click another tab to continue setting options.

Setting import mail options
1 Chose Edit > Options > Database Options.

2 Click the Import Mail tab.

3 Select Enable importing defects via email to enable email import.

If Version Found is a child field, and users can add text entries, the value cannot 
be forced to <not set> because field relationship rules cannot be enforced. 
Text entries in version fields decreases the power of the field relationship 
feature.
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4 Enter the POP3 host IP address or domain name.

Do not use a personal email address as the import mail account. TestTrack Pro imports everything, 
including personal email like jokes, into the database.

5 Enter the Account Name and Password.

If a password is not required, leave the password field empty.

6 Select a time interval from the Look for new files every menu.

You can override the selected interval at any time. Choose File > Import > Perform Server Import. 

7 Select Email an acknowledgement to the submitter to automatically acknowledge the email.

8 Select Enter next sequence number in defect�s reference field to automatically enter the next defect sequence 
number.

9 Enter the Time to wait for initial connection response.

This is the time the TestTrack Pro server waits for an initial response from the email server.

10 Enter the Time to wait for other connection responses.

This is the time the TestTrack Pro server waits for other connection responses from the email server.

11 Click OK or click another tab to continue setting options.

Why does TestTrack Pro require a dedicated email address?

All email from the specified account is imported. TestTrack Pro cannot 
determine which database an email should be imported into. In addition, 
TestTrack Pro cannot differentiate between personal and business emails.

In addition, make sure the import email account is not the same as the return 
email account configured on the Send Mail tab. TestTrack Pro can get stuck in 
a loop if an email account uses an auto-reply and you configure TestTrack Pro 
to send an acknowledgment after importing mail.
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Setting SoloBug options 
1 Chose Edit > Options > Database Options.

2 Click the SoloBug tab.

3 Select a time interval from the Look for new files every menu.

To manually import files, choose File > Import > Perform Server Import.

4 Select an After importing option.

5 Select Email an acknowledgement to the submitted to automatically send an acknowledgement.

6 Select Enter next sequence number in defect�s reference field to automatically enter the next sequence number 
in the reference field.

7 Click OK or click another tab to continue setting options.
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Setting SoloSubmit options

1 Chose Edit > Options > Database Options.

2 Click the SoloSubmit tab.

3 Select Enable entering defects via the SoloSubmit web page to enable SoloSubmit.

Remember, this option is database-specific. SoloSubmit must be enabled for each database.

4 The SoloSubmit HTML page field defaults to solosubmit.htm.

If you use a customized SoloSubmit HTML page, enter the file name. Make sure the HTML file is in the 
correct TestTrack Pro directory on your web server.

5 Select Email an acknowledgement to the submitter to automatically send an email acknowledging the 
submission.

This lets users and customers know their defect was received.

6 Select Enter next sequence number in defect�s reference field to automatically enter the next defect number.

The TestTrack Pro SoloSubmit Admin Guide includes detailed information about 
configuring and customizing SoloSubmit.
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7 Select Enforce required field validation to ensure that values are entered for all required fields.

The required field validation is not enforced for the Entered By field. If Entered By is a required field, 
defects entered via SoloSubmit cannot pass the required field validation check.

8 Select Use default values to initially populate the SoloSubmit web page with default values.

SoloSubmit cannot determine which time zone to use as default values for date/time custom fields. When a 
defect is submitted via SoloSubmit, there is no associated user in the database. Consequently, there are 
no user options to check to determine which time zone to use. The current time of the computer the 
SoloSubmit CGI is running on, when the SoloSubmit page is loaded, is used as the default value for 
date/time custom fields. In addition, the date is assumed to be in the server�s time zone. The date/time 
is converted to GMT.

9 Select fields you do not want JavaScript to handle field relationships for on the SoloSubmit web page. 

You would choose not to include the JavaScript for one of the following reasons: 

! The SoloSubmit web page includes hidden fields. For example, you comment out a field you do not 
want the customer to see. You can delete the HTML, but the field, and its values, will still show up 
in the JavaScript. If the customer chooses View Source on the SoloSubmit web page, the field and its 
values will be shown. Choosing not to include the JavaScript resolves this issue.

! The SoloSubmit web page is customized and you do not want to overwrite the customization. For 
example, you only want a customer to be able to choose 3 out of 6 values for a field. You hard code a 
list of field values in the HTML. If you include the JavaScript, your customization is overwritten. By 
ignoring JavaScript for the field, the hard coded list values are used 

If neither reason applies, and you select a field from the list, it could result in unexpected behavior. For 
example, you ignore JavaScript for Component, which is a child of Product. When SoloSubmit is accessed, 
Product and Component are populated with the initial values. If the user chooses a different Product, the 
Component values are not changed.

10 Click OK or click another tab to continue setting options.

Remember to give users and customers the SoloSubmit URL. To submit bug 
reports or feature requests, they simply open a browser and enter the 
SoloSubmit URL (e.g., http://WysiCorp.com/ttweb/loginSoloSubmit.htm).
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Setting report options
1 Chose Edit > Options > Database Options.

2 Click the Reports tab.

3 Select a time interval from the Look for new stylesheets every menu.

The server periodically searches the database for new stylesheets and updates the stylesheet menus.

4 Select a time zone option.

Detail reports display the creation and modified time at the bottom of the report. Configure the report to 
use the server�s time zone or GMT.

5 Click OK or click another tab to continue setting options.
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Setting password options
1 Chose Edit > Options > Database Options.

2 Click the Passwords tab.

3 Enter the Password requirements.

The sum of the minimum number of letter characters, numeric characters, and non-alphanumeric 
characters should be less than or equal to the minimum password length value.

4 Select the Password restrictions.

5 Click OK or click another tab to continue setting options.
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Configuring auto-assignment rules
Auto-assignment rules ensure a defect is efficiently moved through the workflow by automatically 
assigning a user to defect action. 

You can create and administrate rules that are checked when each of the eight main defect actions occur.

! Defect is created

! Defect is fixed

! Defect is released to testing

! Defect fails verification

! Defect passes verification, but needs customer verification

! Defect is released to customer testing

! Defect fails customer verification

! Defect is re-opened

Rule processing

When a defect action occurs, TestTrack Pro checks the auto-assignment rules in top-down order. If the 
defect passes a filter, the assignment action is applied. If the defect does not pass the filter, the next rule 
is checked until the defect passes a filter. If the defect does not pass any of the filters, the default action is 
applied.

For example, if your team is in Beta testing, you want to make sure that defects failing verification get 
immediate attention. If the Defect fails verification, two auto-assignment rules are checked.

! If the defect�s filter is Failed Fix, the defect is automatically assigned to the last Fixed by User. This 
user can review why the fix failed and make the necessary adjustments so the defect can pass. If the 
filter is not Failed Fix, the second rule is checked.

! If the defect�s filter is On hold, the defect is automatically assigned to the project administrator. The 
project administrator can determine whether the issue needs to be resolved in Beta or at a later time.

For example, JoeDeveloper and ShirleyQA are working on a specific project. 
When a defect is created, it is automatically assigned to JoeDeveloper, who 
is responsible for fixing all defects for the project. When a defect is fixed, it 
is automatically assigned to ShirleyQA. She verifies the fix and makes sure it 
moves through the rest of the workflow.
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Auto-assignment rule exceptions

Auto-assignment processing is skipped when a defect is created using XML import, text import, or by 
duplication. For example, if you duplicate a defect that is unassigned, the new defect is also unassigned. 
If you duplicate a defect that is assigned to Barry, the new defect is also assigned to Barry.

Adding auto-assignment rules

1 Choose Activities > Configure > Auto-Assignment Rules.

The Configure Auto-Assignment Rules dialog box opens.

2 Select a defect action and click Configure Rules.

The Configure Rules dialog box opens.
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3 Click Add.

The Add Rule dialog box opens.

4 Enter a Rule Name.

5 Select a filter from the If defect passes the following filter menu.

The filter menu displays the public and private filters have access to.

6 Select an Action for the defect event.

The assignment actions change based on the defect action you are creating the rule for.

7 Select Disable rule to disable the rule you are creating.

If two or more rules use the same filter, only one rule is valid. To avoid conflicts, disable rules that use 
the same filter.

8 Click OK.

Setting default actions

You can set a default action for each defect action if you do not want to configure auto-assignment rules.

1 Choose Activities > Configure > Auto-Assignment Rules.

The Configure Auto-Assignment Rules dialog box opens.

2 Select a defect action and click Configure Rules.

The Configure Rules dialog box opens.

3 Select a Default action and click OK.

You should set a default action for each defect event.
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Inserting auto-assignment rules

1 Choose Activities > Configure > Auto-Assignment Rules.

The Configure Auto-Assignment Rules dialog box opens.

2 Select a defect action and click Configure Rules.

3 Select a rule and click Insert. The rule is inserted above the selected rule.

4 Enter a Rule Name.

5 Select a filter from the If defect passes the following filter menu.

6 Select an Action for the defect event.

7 Select Disable rule to disable the rule you are inserting.

Select this option if you are inserting a rule that conflicts with another rule.

8 Click OK.

Editing auto-assignment rules

1 Choose Activities > Configure > Auto-Assignment Rules.

The Configure Auto-Assignment Rules dialog box opens.

2 Select a defect action and click Configure Rules.

3 Select a rule and click Edit.

You can change the rule�s name, filter, or action.

4 Select Disable Rule to disable the selected rule. 

This option lets you disable a rule instead of deleting it. Disabled rules are greyed-out in the rules list.

5 Click OK.

Deleting auto-assignment rules

1 Choose Activities > Configure > Auto-Assignment Rules.

2 Select a defect action and click Configure Rules.

3 Select a rule and click Delete.

The rule is deleted.
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Logging historical defect information
Historical defect logging is an optional feature used to record the changes made to a specific defect. 
Users can view what has changed in a particular defect record, who made the change, and when the 
change was made on the History tab. Following are some of the functions that generate a historical 
defect log message: Adding or editing a defect or adding, editing, or deleting a defect action; Adding, 
editing, or deleting a found by record; Merging defects; or Assigning a defect number or renumbering 
defects.

Enabling historical defect logging

1 Choose Edit > Options > Database Options.

2 Click the Defects tab.

3 Select Enable logging of historical defect information.

Disabling this option does not affect any information already logged in the database.

Deleting historical defect log information

If the database becomes too large because of historical log entries, you can delete entries. Deleting 
historical defect log entries does not reduce the amount of disk space used until the database is 
compressed. For more information, see Understanding database settings in the Server Admin Utility Guide.

1 Choose Activities > Configure > Delete Historical Defect Info.

The Delete Historical Defect Info dialog box opens.

To delete log entries for specific defects, select the defects before 
proceeding.
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2 Select the Delete Log Entry options.

! Delete historical information regardless of log date deletes all log entries.

! Delete historical information with dates prior to and including this date: deletes log entries prior to and 
including the date you enter.

3 Click a Delete Log Entries For Which Defects? button.

You are prompted to confirm the deletion.

4 Click Yes.

The defect historical log information entries are deleted.
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Chapter 13
Customizing Fields

Customize fields...
to collect the data you need. The data you collect is one of the most important parts of the defect 
tracking process. TestTrack Pro lets you customize fields to meet your company�s requirements and 
make sure users are providing the information you need. You can also rename field labels and change 
existing field data.

In this section:

Configuring field names, 162

Configuring custom fields, 164

Defining required fields and default values, 167

Configuring field relationships, 169

Renaming field labels, 172
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Configuring field names
You configure menu field names to customize TestTrack Pro with your company�s terminology. The 
field names you configure are database-specific. You can configure type names, priority names, severity 
names, product names, component names, disposition names, reproduced names, fixed resolutions, 
closed resolutions, and version names.

Adding field names
1 Choose Activities > Configure, then select the group you want to add the field to. This example uses 

disposition, which is a child field.

The Setup Disposition Names dialog box opens.

2 Click Add.

The Add Disposition dialog box opens.

The setup dialog box changes based on the field type. For example, if you 
add a value to a parent field, you are reminded to configure field 
relationships for the new value.
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3 Enter a disposition field name and click OK.

You return to the Setup Disposition Names dialog box.

4 Select the association for the field. Remember, in this example, disposition is a child field.

You can associate the new child field with all of the parent menu items or none of the parent menu items.

5 Click OK when you finish adding field values.

Editing field names
1 Choose Activities > Configure, then select the group containing the field value you want to edit.

2 Select the name and click Edit.

The Edit Defect Type dialog box opens.

3 Enter a new name and click OK.

The list is updated with the new name. To reorder field names, select the name and click the Up or Down 
button. You can also sort all field names in ascending or descending order.

Deleting field names
1 Choose Activities > Configure, then select the group containing the field name you want to delete.

2 Select the name and click Delete.

If the field name is used by a defect, you are prompted to reassign the field name to one of the existing 
field values. The field value cannot be deleted until it is reassigned.

You can also manually configure the parent-child field relationship. Go to 
Activities > Configure > Field Relationships. For more information, see Defining 
required fields and default values, page 167.

If your database uses field relationships and you delete an item from a menu, 
you may cause a child field�s value to no longer follow field relationship rules. 
If you try to delete a field that is used in a field relationship, you will receive 
a warning indicating the action may result in defects that do not follow the 
field relationship rules.
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Configuring custom fields
You can add up to ten custom fields to a database. All custom fields can be displayed on the Custom 
Fields tab or up to two custom fields can be displayed in the main area of the Add Defect, Edit Defect, 
and View Defect dialog boxes.

Adding custom fields

1 Choose Activities > Configure > Custom Fields.

The Set Up Custom Fields dialog box opens.

2 Click Add.

The Add Custom Fields dialog box opens.

Make sure all users are logged out of TestTrack Pro. You cannot add custom 
fields if other users are logged in.
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3 Enter a Field name.

The name can be up to 20 characters long.

4 Select a Field type.

! Edit box lets users enter a value. After choosing this field type, select string, integer, or decimal 
number as the Field format and enter the Maximum field size.

! Date/Time creates a date/time field. When users select this type of custom field, the current date and 
time is set. Users can change the date and time

! Check box creates a check box field. The check box custom field works the same as other check boxes; 
users select or clear the check box.

! Pop-up menu lets you define the menu values. After choosing this field type, click Setup Pop-Up Menu 
Items to add values to the pop-up menu.

5 Click OK.

You return to the Setup Custom Fields dialog box.

6 Select the Display Location options.

You can display all custom fields on the Custom Fields tab or display up to two custom fields on the 
Add, Edit, and View Defect dialog boxes.

7 Click OK.

Editing custom fields
1 Choose Activities > Configure > Custom Fields.

2 Select the custom field and click Edit.

The Edit Custom Fields dialog box opens.

If you add a field that will be used in a field relationship, select Pop-Up Menu. 
This field type lets you restrict the information users can enter.

TestTrack Pro assigns a field code to the custom field. The field code lets you 
use the custom field in an email template or in a report template.
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3 Make any changes and click OK.

4 Click OK.

Deleting custom fields
1 Choose Activities > Configure > Custom Fields.

2 Select the custom field and click Delete.

You are prompted to confirm the deletion.

3 Click Yes.

The custom field is deleted.

4 Click OK.

You cannot change the Display Location option if other users are logged in to 
TestTrack Pro. To edit this option, all users must be logged out!
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Defining required fields and default values
TestTrack Pro lets you select any defect or defect action input field, including custom fields, and make it 
a required field. When a field is required, it means a user must enter data in that field before TestTrack Pro 
will add the defect or defect action to the database or save any edit changes. You can also define default 
values for most fields on the Add Defect or Defect Action dialog box. Required fields and default field 
values are database-specific. 

1 Choose Activities > Required Fields & Default Values.

The Required Fields & Default Values dialog box opens. 

2 Select the field group from the menu.

Field types are grouped together for easy reference.

Required fields are set for all users. Field level security is set for Customer and 
User Groups. For example, the Priority field is required but does not have a 
default value. A Customer Group is created, with permissions to add defects. 
The Priority field is hidden for both Add and Edit privileges. Customers find 
out they are not able to add defects. Why? The Priority field is required but 
the Customer Group does not have access to the field. An easy workaround is 
to grant access to the Priority field when adding defects and hide the Priority 
field when editing defects. 

The required field must be populated for all instances of actions. For example, 
the Found By field is required and does not have a default value. When 
multiple detail records are created for a single defect, the Found By field must 
be populated for all of the detail records.

Select the 
field group 
from the menu

You can also click 
these arrows to move 
through the groups.
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3 To set a required field, select the corresponding check box. 

A field that is set using check boxes and/or radio buttons cannot be set as a required field.

4 To set a default value, select a value from the corresponding menu.

5 Repeat steps 2 - 4 until required fields and default values are set for each group.

6 Click OK.

If a field is always required, the check box is selected and inactive. If a field cannot be set as a required field, 
the check box is not selected and it is inactive. If a default value cannot be set for a field, the menu value is 
labeled <blank> and it is inactive.

Editing required fields and default values
1 Choose Activities > Required Fields & Default Values.

The Required Fields & Default Values dialog box opens. 

2 Select the field group you want to edit from the menu.

3 To clear a required field, click the corresponding check box.

The field is no longer required.

4 To change a default value, select a different value from the corresponding menu.

This field is always 
required

Cannot be set 
as a required filed

Default value cannot 
be set for this field
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5 Click OK to save your changes.

Configuring field relationships
You can define parent-child field relationships that create dependent items in the database. This lets you 
configure the menus so users can only select values based on the parent-child field relationship. This 
helps users input better data and make more logical choices. Before you begin configuring field 
relationships, you should think about how to best use this powerful feature.

! The following fields can be set as parent fields: type, product, disposition, priority, component, severity, 
custom fields.

! The following fields can be set as child fields: type, product, disposition, priority, component, severity, 
version found, reproduced, computer config, custom fields.

! The following fields cannot be set as parent or child fields: entered by, found by, fixed by.

How do default values affect field relationships?
A child field�s default value may be invalid, depending on the parent field�s 
default value. If a default value is selected, and it does not follow the defined 
field relationships, the default value can still be used but the child field�s value 
will no longer follow field relationship rules.

How do hidden fields affect field relationships?
A child field that is hidden can cause unintended changes. If you change a 
parent field, you may cause a child field�s value to no longer follow field 
relationship rules. Additionally, if the child field is required, any changes that 
are made cannot be saved.

When a field is chosen from a menu, and there is a parent-child relationship, 
the child field is populated with values based on the parent field. 

For example, Product is the parent field of Component and Version. 
Component is the parent field of Routine, which is a custom field. When a user 
adds a defect, the Component and Version fields are populated based on the 
selected Product field value. The Routine field is populated with values based 
on the selected Component field value.
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Adding field relationships
1 Choose Activities > Configure > Field Relationships.

The Field Relationship Selection dialog box opens.

2 Click Add.

The Setup Parent-Child Relationship dialog box opens.

3 Select the parent field from the menu then select the child field and click OK.

The Setup Field Relationships dialog box opens.

If you are use a custom field in a field relationship, it must be configured as a 
pop-up menu field. For more information, see Adding custom fields, page 164.
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4 For each field in the parent list, enable or disable the child list fields.

The child list displays each of the child field values with the default state for each value selected. If you 
add additional field values to the child list, the values automatically appear unless they are disabled.

5 Click OK when you finish setting up the field relationship.

You return to the Field Relationship Selection dialog box. 

6 Click OK to close the dialog box or click Add to add another field relationship.

A parent field can have one or more child field relationships. A child field can 
only have one parent. A child field can also be the parent of another field.

When a field is set as a child field, it is excluded from the child field list. For 
example, Priority is the child field of Severity. When you add a field 
relationship, you cannot select Priority as a child field. 

To prevent a circular reference, fields that are a parent or grandparent of the 
selected parent field are excluded from the parent list. For example, Product 
is the parent field of Component. Component is the parent field of Version. 
You cannot set Version as the parent field of Product because a circular 
reference is created.

What if a database uses default values?
The child field�s default value may be invalid, depending on the parent field�s 
default value. If a default value is selected, and it does not follow the defined 
field relationships, the default value can still be used. 

What if a database uses hidden fields?
Hidden fields can cause unintended changes. If a parent field is changed, 
causing the child field value to be, the child field may be changed to <not set>, 
depending on database options. Additionally, if the child field is required, 
any changes that are made cannot be saved.
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Editing field relationships
1 Choose Activities > Configure > Field Relationships.

The Field Relationship Selection dialog box opens.

2 Select the field relationship and click Edit.

The Setup Field Relationships dialog box opens.

3 Make any changes and click OK.

Deleting field relationships
1 Choose Activities > Configure > Field Relationships.

The Field Relationship Selection dialog box opens.

2 Select the field relationship and click Delete.

You are prompted to confirm the deletion. 

3 Click Yes.

The field relationship is deleted.

Renaming field labels
You can rename defect field labels to match your company�s terminology. This helps you customize your 
tracking system and decrease user confusion. Renaming a field label does not change the functionality or 
format of the field, it only changes the label displayed in TestTrack Pro.

! The following field labels can be renamed: Summary, Type, Disposition, Priority, Product, Component, 
Reference, Severity, Entered By, Date Entered, Status, Found By, Date Found, Date, Version Found, 
Version, Description, Reproduced, Steps to Reproduce, Computer Config, Other Hardware and Software, 
and the Custom Fields tab label. 

! The following words can be renamed: Defect / defect, Defects / defects, Defect(s) / defect(s).

For example, your company uses case numbers. Rename reference to case 
numbers so users know where to enter the case number information. Or, your 
your company refers to issues instead of defects. Rename all instances of 
defect (Defect, defects, defect(s), etc.) to issue. If you are a service-oriented 
organization, and use the Custom Fields tab to track service issues, you can 
rename the tab to Service.
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1 Choose Activities > Configure > Rename Field Labels.

The Rename Field Labels dialog box opens.

2 Select the field you want to rename and click Edit.

The Edit Field Label Value dialog box opens.

3 Enter the Field Label and click OK.

Field labels cannot be resized in the user interface and should not be longer than 32 characters. Field 
labels that do not fit in the allotted space are truncated.

4 Repeat steps 2 and 3 for each field label you want to rename.

Date is the short form of Date Found. Version is the short form of Version Found. 
If you rename these field labels, use the same terminology. The short and long 
field names are both used. The short name is used to allow fields to fit in the 
user interface.
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5 When you finish, click OK on the Rename Field Labels dialog box.

Your changes are saved and the database is updated with the new field labels.

Restoring original labels
You can restore the field labels to their original values at any time.

1 Choose Activities > Rename Field Labels.

The Rename Field Labels dialog box opens.

2 Click Restore to Original Values.

The field labels revert to the original values.

3 Click OK to save the changes. If you do not want to save the changes, click Cancel then click No.

Field renaming does not affect image files. In the Web interface, the tabs are 
image files (.gif). For example, if you rename the Custom Fields tab to 
Services, it will only affect the Windows client. To change the tab name in the 
Web interface, you can manually modify the graphic. Image files are 
generally stored in: Inetpub/wwwroot/ttweb/images. Most graphics include two 
images: one for a selected tab and one for a non-selected tab.

Changes you make to field labels do not show up in SoloBug. As a stand-alone 
product, SoloBug is not necessarily associated with one database. Field names 
can be changed when you customize the SoloBug executable.

Field codes do not change. For example, Disposition (%DISP) is renamed to 
Substatus. You want to include the Substatus field data in an email template. 
You would use %DISP% to return the field data. There are field codes that can 
be used to return the label name. For more information, see Appendix A, 
�Field Codes Reference� , page 243.

Database columns are not renamed. When you use the ODBC driver, you need 
to use the original field name in your queries.
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Chapter 14
Configuring SCC Integration

Integrate your SCC solution...
with TestTrack Pro! This chapter includes information about configuring SCC integration. 
Application-specific notes are also provided to help you resolve most simple integration issues.

In this section:

About SCC applications and TestTrack Pro, 176

Configuring SCC integration, 177

Disabling SCC integration, 180

SCC application notes, 181
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About SCC applications and TestTrack Pro
SCC integration enhances your ability to associate specific defects logged in TestTrack Pro with your 
source code. Among other SCC functions, users can attach and detach source files to and from defects. 
Users can also check out the code to fix a defect, while viewing the defect. When checking in code, users 
can apply the same comment to all components.You will know when and why code changed and what 
new changes need to be included in your next build. 

The following SCC applications can be integrated with TestTrack Pro:

! CS-RCS

! CVS

! ClearCase

! PVCS

! Perforce

! SourceOffSite Classic

! StarTeam

! Surround SCM

! Visual SourceSafe
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Configuring SCC integration
1 Choose Activities > Configure > SCC Integration.

The Configure SCC Integration dialog box opens with the Local Options tab selected. The Local Options 
tab lists the installed SCC providers.

2 Select the application you want to use from the Available Providers list and click Make Current.

The application you selected is listed in the Current box. The Local Options tab is the only tab available 
until you select an SCC application.

 CVS is always displayed in the Available Providers list. Do not set up CVS 
integration unless CVS is installed on your computer. 

You probably use one source code control program. You must still select the 
application and click Make Current.
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3 Click the User Options tab.

This tab is used to select the project database and enter a username and password to connect to the 
database.

4 Click Browse to select the project database.

If you use Visual SourceSafe or PVCS you must also enter a valid username and password for the 
database.

5 Click Validate Connection to test the connection parameters. 

If the connection fails, make sure you selected the right project database and entered the correct 
username and password information.

The user options settings are stored in the TestTrack Pro database for the 
currently logged in user. If you log in to multiple TestTrack Pro databases, SCC 
user options must be configured for each database.
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6 Click the Database Options tab.

You can customize check in comments, using field codes. When users check in files, the comments field 
is populated automatically. For more information, see  Appendix A, �Field Codes Reference�, page 243.

7 Click the Project Paths tab.

Select the project paths you want users to have access to. Expand the root directory, select a path, and 
click Add.

8 Click OK when you finish configuring the SCC integration.

For more information, see Using source code control with TestTrack Pro, page 56.

If you select the root directory, users can access everything in the database. To 
limit the files users can access, select specific directories.

Make sure you create a user group that can access source code 
control commands, including the SCC tab. Remember, all users must 
configure their local and user options.
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Disabling SCC integration
1 Choose Activities > Configure > SCC Integration.

The Configure SCC Integration dialog box opens.

2 Select the provider you want to disable and click Disable SCC Integration.

3 You are prompted to confirm that you want to disable the SCC integration.

4 Click Yes.
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SCC application notes
The following application-specific information is provided to help you easily integrate SCC applications 
with TestTrack Pro.

CS-RCS

If you configure CS-RCS to work in CVS mode, the Check out, Check in, and Undo Check out buttons 
are still shown on the SCC tab, which can be confusing. The buttons may also be enabled/disabled for 
certain files, depending on the state of the file. Generally, these buttons are always enabled when CS-
RCS is running in CVS mode.

CVS

Valid CVS working directories must be setup before you try to use the integration. The integration 
cannot be used to get the first copy of a your working files. This includes any local directories, which 
must exist before you can use the integration. To set up the integration:

1 Enter the local working path in the Project working path field.

The Project Paths settings are based on the information you enter. After you enter a working directory, 
go to the Project Paths tab and add specific paths to use in the Attach dialog.

2 Enter the connection string in the Repository connection string field.

This string should be what you use for the -d option on the CVS command line

3 If you use a password, enter it in the SCC Password field.

You can also enter the password as part of the connection string. If you enter the password in the 
connection string, it can be viewed by anyone looking at your computer. If security is an issue, enter it in 
the password field.

4 If a merge is required when checking in a file, you must manually perform the merge. When you try to 
check in the file, you will receive a message letting you know a merge is needed. You have to manually 
perform the merge and then check in the file.
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ClearCase

! The Get command is only valid for snapshot views. It is not valid for dynamic views.

! Files from different views are displayed on the Source Code tab. If you configure TestTrack Pro to connect 
to a dynamic view, and you have also attached files that are part of a snapshot view, all files are displayed. 
In this case, the Get command is invalid for any files that were attached in the dynamic view.

PVCS

! PVCS uses its own dialogs to handle opening the project and authenticating the user. PVCS prompts you 
for login data each time you open the project database.

! Two different TestTrack Pro users cannot configure PCVS integration, to separate PVCS projects, under 
one Windows user account.

Perforce

! The Browse button is disabled on the User Options tab. The client name is used for the project database. 
The login for the Perforce depot comes from the Perforce registry keys. The P4USER and P4PASSWD keys 
must be set correctly before the TestTrack Pro integration will work.

! Only the first 31 characters of a file�s check in comments can be displayed when viewing file history (SCC 
tab, History button).

SourceOffSite Classic

! You must have the SourceOffSite GUI client installed on each computer you are using SourceOffSite 
integration with in TestTrack Pro. You also need to install the command line version and place it in the 
same directory as the SourceOffSite client.

! You should not run the SourceOffSite client and the TestTrack Pro integration at the same time. This is a 
SourceGear recommendation.

! SourceOffSite does not provide an easy way for TestTrack Pro to get the local path for a VSS file. TestTrack 
Pro looks at the databasex.sos cache file to get the directory information. If that does not work, the calls rely 
on the SourceOffSite GUI client to access the cache and provide the information.

! The Get, Check out, and Undo check out commands overwrite files without prompting you for 
permission.

! The SourceOffSite command line API has a bug in it and cannot copy files to root drives correctly. If 
TestTrack Pro does not get the local path information from the cache, the Get and Check out commands 
will not work with files that use a root drive for the working path. The View command will not work 
because TestTrack Pro does not know the file location.

! A valid cache file must exist for each user�s server/database configuration.
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! Logging into a server with two different names (e.g., 127.0.0.1 and localhost) results in two separate cache 
files. If you set up the SourceOffSite client to log in to 127.0.0.1 and configure TestTrack Pro to login to 
localhost, the integration will not work as expected. The localhost cache file will not have any working 
paths setup. This problem also occurs if you do not set up working paths in your SourceOffSite client. 
SourceOffSite will put the files in the current directory (e.g., c:\Program) instead of returning an error.

! The Login area of the User Options tab includes Server and Port fields that let you enter the server�s 
connection data. After entering this data, click Browse. A list of available databases available on the server 
opens.

! The SourceOffSite command line application does not create directories when retrieving files. If you 
attempt to Get or Check out a file to a directory that does not exist, the call fails. You can create the 
directory path then perform the Get or Check out command.

! If the SourceOffSite server or the command line application crash, you need to close the TestTrack Pro 
client, restart the SourceOffSite server, then restart the TestTrack Pro client. TestTrack Pro is still usable if 
SourceOffSite crashes. The SourceOffSite integration will not work until you restart TestTrack Pro.

StarTeam

! Make sure your files are set up before configuring the SCC integration. If files are not set up in the project 
working path, and you configure the SCC integration, you will receive an error message in the Project 
Tree.

! StarTeam uses its own dialogs to handle opening the project and authenticating the user. StarTeam 
prompts you for login data each time you open the project database.

! Two different TestTrack Pro users cannot configure StarTeam integration, to separate StarTeam projects, 
under one Windows user account.

Surround SCM

none

Visual SourceSafe

none
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Chapter 15
Managing User Groups

Safe and Secure! 
This chapter describes user groups and includes information about security and assigning security 
to each group. Protect your data integrity, and security, by creating user groups for all security levels.

In this section:

About security, 186

User groups and security, 187

Adding user groups, 189

Adding users to a user group, 191

Viewing user groups, 192

Editing user groups, 192

Deleting user groups, 192
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About security
TestTrack Pro�s security options let you configure your database to provide as much, or as little, access 
as needed. TestTrack Pro includes the following security options:

! Password security, which users set, limits access to databases.

! Command security limits which commands a group of users can execute. 

! Field security limits who can enter data into, or alter the contents of, each defect field. 

! Defect security limits the defects that are visible to each user group.

! Advanced defect logging can track who changed defect fields and states and when the change was made.

! Server logging records unusual activity, critical, and non-critical system issues.

About user groups
A user group is a collection of users who share responsibilities and perform similar tasks. Users must be 
assigned to a user group before they can work with TestTrack Pro databases. Access to TestTrack Pro 
functions, such as adding a defect or using SCC integration, is controlled by the group security.

When you set up a database, create the user groups first. This lets you create a security structure for the 
users. You can create an unlimited number of security groups and levels. Security determines what 
databases users can access, what their view and edit rights are for authorized projects (on a per-field 
level), and what they can do at each stage of the workflow process. For example, deleting defects, or 
attaching files are all privileges that can be assigned to a user group. You can create many kinds of 
security structures. For example, create the following structure and name user groups according to 
security level: 

Or, using the same structure, name the user groups according to job description:

Group Name Clearance Level Commands Granted

Level 1 Low View

Level 2 Medium View, Add

Level 3 High View, Add, Edit

Level 4 Highest View, Add, Edit, Delete

Group Name Clearance Level Commands Granted

Tech Writer Low View

Engineer Medium View, Add
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Before you start creating user groups, you may find it helpful to list the types of users you will be adding 
to the database and what their needs are. You can add as many or as few user groups as you need, and 
make their security levels as general or as command-specific as you need.

User groups and security
TestTrack Pro security is assigned at the user group level. Each user group can be assigned different 
levels of security. You can set command, field, and defect security in TestTrack Pro.

Command-level security

Command security limits the commands a group of users can execute. This type of security is set by 
category. For example, Can a user fix a defect?

Command security includes the following categories: General, Administration, Defects, Customers, 
Users, User Groups, Test Configurations, Filters, Reports, and Workbook.

For example, you created a SOAP user group for developers using the TestTrack SOAP SDK. To give the 
user group access to the SOAP SDK, enable Allow log-in via SOAP in the General category.

Defect-level security

Defect security restricts limits which defects are visible to the user group based on an existing filter 
and/or whether the user reported the defect. Defects that do not pass the filter are not displayed in the 
defect list or included in reports.

For example, you have a group of managers who only need information about feature requests. Select 
the Open Feature Requests filter for this group. The managers can only view defects that meet the filter 
criteria.

QA Tester High View, Add, Edit

Manager Highest View, Add, Edit, Delete

If you want all users to have access to all commands, you do not need to create 
user groups. TestTrack Pro adds an Administration user group when a 
database is created. This user group has access to every command. Simply 
add the users to this default user group. 

For a list of the categories and commands available for command security and 
the groups and fields available for field security, see  Appendix C, �Security 
Reference�, page 259.
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Field-level security

Field security affects defects and defect actions and restricts a user�s ability to enter, or edit, field data. 
For example, can a user enter a resolution in the fix defect action field?

Three types of field security can be assigned: Read/Write, Read Only, and Hidden. In addition, Add and Edit 
privileges are set separately. For example, assign a restricted user group read/write add privileges for 
the Type field. Assign the same user group read only edit privileges for the Type field. When adding a 
new defect, users can enter information for the type field. When editing a defect, users can view the Type 
field but will not be able to make any changes.

Security can be assigned to the following fields: General, Found By, Assigned, Estimated, Fixed, Release 
to Test, Verified, Release to Customer Test, Customer Verified, Closed, Reopen, Release Notes, 
Comment, and Custom fields.

Field security cannot be applied to the following areas: email templates, SoloSubmit, SoloBug, and 
import/export.

System-generated fields cannot be assigned field security. This includes the following fields: defect 
number, defect status, has attachments?, has workaround?, date created, created by, creation method, 
date last modified, last modified by, found by group, found by company, how many?, and has release 
notes?

This example shows how to use Add privileges to set up field security:

Assign the Department Manager group Read/Write access to the Priority 
field. Users in the Department Manager group can set the priority level. 

Assign the Programmer group Read Only access to the Priority field. Users in 
the Programmer group can view, and not edit, the priority level.

Assign the Customer group Hidden access to the Priority field. Users in the 
Customer group cannot view the priority level assigned to defects.
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Adding user groups
1 Choose Create > User Group or click Add on the User Group list window.

The Add User Group dialog box opens.

2 Enter a Name and Description.

These fields are required.

3 Select Include users in pop-up menus to list users in pop-up menus.

Clear the check box if the user group is intended for users who only report defects and do not need to be 
assigned any defect actions.

4 Select Include customers in pop-up menus to list the customers in pop-up menus.

Clear the check box if the user group is intended for customers who only report defects and do not need 
to be assigned any defect actions.
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5 Click the Command Security tab and set the security for each category.

When you select a Category, all the corresponding commands appear in the Command list. A check mark 
next to a command means the user group has access to that command. Click the check mark to disable 
access to a command.

6 Click the Defect Security tab and set the defect security for the group.

7 Click the Field Security tab and set field security for this group.

When a new user group or database is created, field security defaults to full security. Users in this group 
can view and edit every defect field. Be sure to set Add and Edit privileges for all field groups.

Be sure to set the commands for each category in the Category list box. 
TestTrack Pro defaults to Enable All commands in each category. 

A field can be represented by an edit box, check box, radio button, or a list 
box. Remember, setting field security affects all field types.

...all the General 
commands appear in the 
Command list.

When you select 
General from the 
Category list...



Chapter 15 191
Adding users to a user group

8 Click the Notes tab and enter any information about the user group.

9 Click Add.

The Add User Group dialog box clears and you can add another user group. Click Close when you finish 
adding user groups.

Adding users to a user group

1 Select the user group on the User Groups list window.

2 Choose Edit > Edit User Group or click Edit on the User Group list window.

The Edit User Group dialog box opens.

3 Select a user from the Available Users list and click Add.

The user is added to the Users in Group list. To add multiple users, Ctrl+click each user.

4 Click OK when you finish adding users.

A user can only belong to one user group. 
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Viewing user groups
1 Select the user group on the User Groups list window.

2 Choose Edit >View User Group or click View on the User Group list window.

The View User Group dialog box opens. All fields are read-only and cannot be edited.

3 Click OK when you are finished.

Editing user groups
1 Select the user group on the User Groups list window.

2 Choose Edit > Edit User Group or click Edit on the User Group list window.

The Edit User Group dialog box opens. 

3 Make any changes and click OK.

Your changes are saved. 

Deleting user groups
1 Select the user group on the User Groups list window.

You can select more than one user group to delete. 

2 Choose Edit >Delete User Group or click Delete on the User Group list window.

You are prompted to confirm the deletion.

3 Click OK.

The user group is deleted.
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Managing Users

Defect, defect, who has the defect?
Users, the people who find, fix and verify defects�who found it, who fixed it, who should be 
verifying it? By tracking users, TestTrack Pro improves communications and accountability in your 
software development process.

In this section:

About users, 194

Adding users, 194

Viewing users, 197

Editing users, 198

Duplicating users, 198

Making a customer a user, 199

Inactivating users, 199

Activating users, 199

Deleting users, 200

Viewing logged in users, 200

Logging out users, 201
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About users
TestTrack Pro users can only access commands granted to the user group they belong to. The TestTrack 
Pro administrator is generally responsible for creating, and managing, users. 

Adding users
1 Choose Create > User or click the Add button on the User list window.

The Add User dialog box opens with the Info tab selected.

2 Enter the user information.

You must enter a First Name, Last Name, and Username. You may want to assign the user a password. 
Users can set their own password the next time they log in.

What is the difference between users and customers?
One company might consider users to be internal employees who use 
TestTrack Pro and set up each department of the company as a customer. 
Another company might set up all internal employees as users and set up all 
external companies as customers. 

User and customer information is tracked on the Info, CPU, Peripherals, Notes, 
and Statistics tabs. Customer information includes two additional tabs. The 
Address tab is used to enter the customer�s contact information. The History tab 
lets you quickly view information about defects a customer reports (e.g., 
Open, assigned to Jane Tester). 



Chapter 16 195
Adding users

3 Enter the information on the Info tab.

You must select a user group. All other information is optional.

4 Click Notification Options to set email notification options.

The Notification Options dialog box opens. 

5 Select notification options for the user. 

You can set options to notify a user of a defect assignment, when a defect is added to the database, or 
when a defect is modified, among other options. Users can also set notification options. Refer the user to 
Setting email options, page 17.

Make sure you accurately enter the user�s email information. Email 
notifications are sent to this email address.
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6 Click the CPU tab and enter the CPU information.

These fields are optional but you should enter as much information as possible. Click Capture Config to 
automatically capture some of the fields, such as operating system and CPU type. 

7 Click the Peripherals tab and enter the peripherals information.

These fields are optional but you should enter as much information as possible. 

8 Click the Notes tab and enter any notes.

9 Skip the Statistics tab.

This read-only tab contains user statistical information.



Chapter 16 197
Viewing users

10 Click the Display Settings tab.

The Display Settings tab is used to specify a filter for the Defects list window and select which columns 
to display on each of the eight list windows. Users cannot change the settings you select.

TestTrack Pro performance can be negatively affected when databases contain a large number of 
records. It can take an excessively long time for TestTrack Pro to populate the Defects list window. You 
can also control the amount of data being displayed by limiting the columns on some, or all, of the list 
windows.

! To filter the Defects list window, select a filter from the Filter menu.

! To limit which columns to display, select a list window from the List Window menu. Select the 
columns you want to include and click Add. To reorder the columns, select the column and click Up 
or Down.

11 Click Add.

The user is added to TestTrack Pro.

Viewing users
1 Select the user on the Users list window.

2 Choose Edit >View Users or click the View button.

The read-only View User dialog box opens. 
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3 Click the Statistics tab.

This tab includes user stats that are gathered and calculated for you. 

4 Click OK to close the View User dialog box.

Editing users
1 Select the user on the Users list window.

2 Choose Edit > Edit Users or click the Edit button.

The Edit User dialog box opens.

3 Make any changes and click OK.

Duplicating users
If you are adding multiple users with similar information you can save time by duplicating users.

1 Select the user on the Users list window.

2 Choose Edit > Duplicate User.

TestTrack Pro duplicates the user, and a number, incrementing by one, appears after the user�s last 
name. For example, if you duplicate Jane User, a user named Jane User1 is added to the User list 
window.

3 Modify the duplicated user and save your changes.

You can also view the read-only information on the other tabs.



Chapter 16 199
Making a customer a user

Making a customer a user
Use this command if you made a mistake and entered a user as a customer.

1 Select the customer on the Customers list window.

2 Choose Edit >Make Customer a User.

The customer is transferred to the users list. Assign a username and password add the user to a user 
group.

Inactivating users
Inactivate a user to save the historic information. Inactive users cannot login to TestTrack Pro, receive 
email via TestTrack Pro, or be assigned defects.

1 Select the user on the Users list window.

2 Choose Edit > Inactivate User.

A confirmation message appears warning you that an inactive user cannot log in to TestTrack Pro, 
receive email, or be assigned defects.

3 Click Yes.

The user becomes inactive.

Activating users
1 Select the user on the Users list window.

2 Choose Edit >Activate User.

The user becomes active.
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Deleting users

1 Select the user on the Users list window.

2 Choose Edit >Delete User or click Delete.

You are prompted to confirm the deletion.

3 Click Yes.

The user is deleted.

Viewing logged in users
To view the users who are currently logged in to the database you are using:

1 Choose Activities > Show Logged In Users.

The Logged In Users dialog box opens.

To save the historic information, do not delete the user, make the user inactive. 
Historic information, such as Reported By or Defect Action records, are deleted 
with the user.
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Logging out users
A user requires a license to run TestTrack Pro. If a user does not exit TestTrack Pro correctly, the license 
is not released. When this happens, you can free the license by logging out the user. 

You can also log out users if you need to perform maintenance or make changes that require all users to 
be logged out.

1 Choose Activities > Show Logged In Users.

The Logged In Users dialog box opens.

2 Select the user(s) you want to log out.

To select more than one user, Ctrl+click each user.

3 Click Log out User(s).

The user(s) is logged out and the dialog box closes. When you log out users, they are notified their 
session was dropped by an administrator.
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Chapter 17
Managing Customers

Customers—your most valuable asset!
This chapter includes information for creating, and maintaining, customers. TestTrack Pro makes it 
easy to track customers and the issues they report.

In this section:

About customers, 204

Adding customers, 204

Viewing customers, 207

Searching for customers, 209

Editing customers, 210

Duplicating customers, 210

Making a user a customer, 210

Inactivating customers, 211

Activating customers, 211

Deleting customers, 211
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About customers
Customers provide valuable feedback in the form of bug reports, feature requests, and questions. 
Typically, customers are the end users of your products or services. Unlike users, customers usually do 
not have access to the database.

Adding customers
1 Choose Create > Customer or click Add on the Customers list window.

The Add Customer dialog box opens.

What is the difference between users and customers?

Each company uses TestTrack Pro differently, including setting up users and 
customers. One company might consider users to be internal employees who 
use TestTrack Pro and set up each department of the company as a customer. 
Another company might set up all internal employees as users and set up all 
external companies as customers.

Information for users and customers is tracked using the Info, CPU, Peripherals, 
Notes, and Statistics tabs. Customer information includes two additional tabs. 
The address tab is used to maintain address information for the company. The 
history tab gives an overview of the defects a customer has reported. If a 
customer calls and wants more information, you can quickly let the customer 
know the status of a defect (e.g., Open, assigned to Jane Tester). 
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2 Enter the customer information.

You must enter a First Name and Last Name. To enable database access for this customer, enter a Username 
and Password.

3 Enter the information on the Info tab.

You must select a user group if you enabled database access for this customer. All other information is 
optional.

4 Click Notification Options to set email notification options.

The Notification Options dialog box opens.

5 Select the notification options for the customer. Click OK when you finish selecting the options.

6 Click the Address tab and enter the address information.
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7 Click the CPU tab and enter the CPU information.

These fields are optional but you should enter as much information as possible. 

8 Click the Peripherals tab and enter the peripherals information.

These fields are optional but you should enter as much information as possible.

9 Click the Notes tab and enter any notes.

10 Skip the Statistics tab.

This read-only tab contains customer statistical information.

11 Skip the History Tab.

This read-only tab contains information about defects the customer reported.
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12 Click the Display Settings tab.

The Display Settings tab is used to specify a filter for the Defects list window and select which columns 
to display on each of the eight list windows. Customers cannot change the settings you select.

TestTrack Pro performance can be negatively affected when databases contain a large number of 
records. It can take an excessively long time for TestTrack Pro to populate the Defects list window. You 
can also control the amount of data being displayed by limiting the columns on some, or all, of the list 
windows.

! To filter the Defects list window, select a filter from the Filter menu.

! To limit which columns to display, select a list window from the List Window menu. Select the 
columns you want to include and click Add. To reorder the columns, select the column and click Up 
or Down.

13 Click Add.

The customer is added to the database.

Viewing customers
1 Select the customer on the Customers list window.

2 Choose Edit >View Customer or click View on the Customers list window.

The View Customer dialog box opens. All fields are read-only.
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3 Click the Statistics tab.

The Statistics tab includes customer stats that are automatically generated. 

4 Click the History tab.

The History tab shows all defects reported by the customer. Double-click a defect to view more detailed 
information.

5 Click OK to close the View Customer dialog box.

You can also view the read-only information on the other tabs.
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Searching for customers
Most databases include a large number of customers. Searching provides an easy way to find a customer 
and edit their information.

1 Click the Search command button on the Customers list window.

The Find Customer dialog box opens.

2 Enter the search criteria.

! Enter full, or partial, first name, last name, and company information.

! Leave a field blank if you do not want to include it in the search.

3 Select an option from the Search Options menu.

! Name/Company begins with this text looks for values beginning with the entered text.

! Name/Company contains this text looks for values containing the entered text.

4 Click Find.

Customers that meet the search criteria are displayed in alphabetical order.

5 Select a customer and click Edit to modify their information.

For more information, see Editing customers, page 210.
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Editing customers
1 Select the customer on the Customers list window.

2 Choose Edit > Edit Customer or click Edit on the Customers list window.

The Edit Customer dialog box opens. 

3 Make any changes and click OK.

Your changes are saved and you return to the Customers list window.

Duplicating customers
If you are adding multiple customers with similar information, you can save time by duplicating 
customers.

1 Select the customer on the Customers list window.

2 Choose Edit > Duplicate Customer.

TestTrack Pro duplicates the customer, and a number, incrementing by one, appears after the customer�s 
last name. For example, if you duplicate Joe Customer, a customer named Joe Customer1 is added to the 
Customers list window.

3 Modify the duplicated customer and save your changes.

Making a user a customer
Use this command if you made a mistake and entered a customer as a user.

1 Select the user you want to convert to a customer on the Users list window.

You can select more than one user at a time. 

2 Choose Edit > Make User a Customer.

The user is transferred to the customer list.
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Inactivating customers
Inactivate a customer to save the historic information. Inactive customers cannot log in to TestTrack Pro, 
receive email, or be assigned defects.

1 Select the customer on the Customers list window.

2 Choose Edit > Inactivate Customer.

You are prompted to confirm that you want to inactivate the customer(s). 

3 Click Yes.

The customer becomes inactive.

Activating customers
1 Select the customer on the Customers list window.

2 Choose Edit > Activate Customer.

The customer becomes active again.

Deleting customers

1 Select the customer on the Customers list window.

2 Choose Edit >Delete Customer or click Delete on the Customers list window.

You are prompted to confirm the deletion. 

3 Click Yes.

The customer is deleted.

Deleting a customer results in the loss of historic information, such as Reported 
By or Defect Action records. To save historic information, inactivate the customer.
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Chapter 18
Importing and Exporting Files

Save time…
�when you learn how to import or export record information. This chapter includes instructions for 
importing and exporting data using XML or text files. 

In this section:

XML import and export, 214

Importing XML files, 214

Exporting to XML, 217

XML import/export notes, 218

XML import/export warnings and errors, 219

Sample XML, 220

Text file import and export, 221

Importing text files, 221

Creating text file import templates, 223

Using text file import templates, 223

Exporting to text files, 224

Creating text file export templates, 225

Using text file export templates, 225
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XML import and export
XML import/export is the recommended method for importing and exporting files. This method 
includes the following advantages over text file import/export:

! You do not need to match fields when importing or exporting records.

! You can import and/or export multiple Reported By records.

! You can import and/or export multiples of the same defect actions.

! You can import and/or export more than one record type. For example, you can import/export defects 
and users in a single file.

Importing XML files

With XML, you can quickly import a large amount of data. Email notifications are not sent when you 
import files; the volume of email messages generated could cause some email servers to crash.

1 Choose File > Import > XML Import.

The XML Import dialog box opens.

2 Click Browse to select an XML file to import.

The Open XML File dialog box opens.

Import security access should be limited to administrative user groups. The 
misuse of this feature can result in a significant number of unwanted records in 
your database. The administrator grants access to import/export commands. 
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3 Select the file and click Open.

The file you selected is listed in the Import File area on the XML Import dialog box.

4 Select the Defect Number Import options. 

! Assign the next available defect number automatically assigns the next available defect number for 
each defect being imported.

! Import defect number field information imports defect number information from the XML file. If the 
defect number already exists, an error will be generated and the defect record will not be imported.

5 Select the Pop-up Menu Item options. 

These options apply to pop-up menu fields such as Disposition and Priority and do not apply to user 
fields. 

! Add the pop-up menu item to the database automatically adds the pop-up menu item to the database.

! Use the default value uses the default value and ignores any value in the imported XML file.

6 Click Validate XML File to validate the file.

Validate the XML file before importing the file. Resolving problem(s) before importing is easier than 
cleaning up data in the TestTrack Pro database.

The Defect Number Import options may be disabled depending on your 
database options.



216 TestTrack Pro
Importing XML files

7 The XML Import Warnings and Errors dialog box opens, showing the results of the validation testing. 

If the XML format is invalid an error will be reported and data will not be imported. Click Save As to save 
the contents of the Warnings and Errors dialog box as a text file.

8 If the XML format is valid, click Import.

The XML Import dialog box closes and you return to the list window.

! When a user field (such as Found By or Fixed By) is imported, TestTrack Pro tries to match the first 
name and last name with an existing user or customer. If an exact match is not found, the 
user/customer is created.

! A defect�s historical data is not imported. The historical data fields are system-generated. The created 
by and modified by fields are populated with the currently logged in user�s name. The date created 
and date last modified fields are populated with the current date and time. The creation method field 
is populated with �XML Import.�

! When importing, the password field can be either encrypted or in plain text. If TestTrack Pro 
generated the XML file, the password is encrypted. If a third-party XML file is imported, the 
password is in plain text.

! File attachments cannot be imported and/or exported.
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Exporting to XML
You can export defects, users, customers, and test configurations to an XML file. 

1 Choose File > XML Export.

The XML Export dialog box opens.

2 Select the type of information you want to export.

To export more than defects, Ctrl+click each record type. For example, Ctrl+click Users and Test 
Configurations to export this type of information.

3 Click Export. 

The Export XML File dialog box opens. 

4 Select the file location, enter a file name, and click Save.

A progress indicator opens and lets you know the file is being exported.

If you only want to export specific defects, you must select the defects before 
continuing. You can select records from the following list windows: Defects, 
Users, Customers, and Test Configurations.

If you are exporting defect information, you can also export historical log 
information. This information contains an historical account of changes made to 
a defect.
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5 The Export XML dialog box closes and you return to the list window.

XML import/export notes
! If you manually generate XML files or use a third-party application, you can import these XML files into 

TestTrack Pro. Refer to the TestTrackData.dtd file for proper formatting of your XML file.

! Do not modify the TestTrackData.dtd file. Modifying this file may result in validation errors or errors 
importing XML data.

! TestTrack Pro does not support namespaces in XML files that are being imported.

! Leave elements that you need to set to <�not set�> empty.

! Control characters cannot be imported into TestTrack Pro and will be removed when exporting text fields. 
This includes the following:

All calculated fields for a defect will be exported, but they will not be 
imported. Calculated fields are exported in case you want to import the XML 
file into a third-party application. Calculated fields that will be exported for 
a defect include status and assigned to.

User statistical data will be exported, but it will not be imported. User 
statistical data includes the following information: defects found and defects 
assigned.

Usernames and passwords are both exported. Usernames are exported in 
plain text; passwords are always exported as encrypted text.

Hex Value Explanation

0x01 Start of Heading

0x02 Start of Text

0x03 End of Text

0x04 End of Transmission

0x05 Enquiry

0x06 Acknowledge

0x07 Bell

0x08 Backspace
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XML import/export warnings and errors
A warning means the record can be imported but some of the information could not be imported. 
Following are some of the warning messages that might be displayed as a result of the XML file 
validation:

! Could not find match for custom field (applies only to defects). 

! Could not find match for pop-up menu item value.

! Could not generate custom field value. 

! A default value will be used instead of the specified value. 

0x0B Vertical Tabulation

0x0C Form Feed

0x0E Shift Out

0x0F Shift In

0x10 Data Link Escape

0x11 Device Control One

0x12 Device Control Two

0x13 Device Control Three

0x14 Device Control Four

0x15 Negative Acknowledge

0x16 Synchronous Idle

0x17 End of Transmission Block

0x18 Cancel

0x19 End of Medium

Due to XML specifications, you cannot export an item with a string field 
containing control characters. There is no way to escape this type of character 
data.

Hex Value Explanation
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An error means the record cannot be imported. Following are some of the error messages that might be 
displayed as a result of the XML file validation: 

! Defect number already exists (applies only to defects and only if using the import defect number field 
information option).

! Name already exists (applies only to users, customers, or test configs).

! Username already exists (applies only to users or customers).

! Two defects with same defect number in XML file (applies only to defects and only if using the 
import defect number field information).

! Two entries with same name in XML file (applies only to users, customers, or test configs).

! Two entries with same username in XML file (applies only to users or customers).

Sample XML
The first three lines of every file TestTrack Pro generates when exporting to XML is the same. If you are 
generating your own XML files to import into TestTrack Pro, the first three lines must be the same, with 
the following exception; the value for the encoding attribute does not need to be specified. 

Following is a sample from a TestTrack Pro XML document:

<?xml version=�1.0� encoding=�iso-8859-1� 8 standalone=�no�?>
<!DOCTYPE TestTrackData SYSTEM 8 �TestTrackData.dtd�>
<TestTrackData>
<! - -elements - - >
</TestTrackData>

The document begins with a processing instruction: <?xml ...?>. This is the XML declaration. It 
identifies the document as an XML document and indicates the version of XML to which it was 
authored. This declaration indicates that this document conforms to Version 1.0 of the XML standard. 
The encoding=�iso-8859-1� indicates the character set used in encoding the XML document. The 
standalone=�no� attribute informs the program that an outside DTD (document type definition) is 
needed to correctly interpret the document. The DTD will reside in a separate file called 
TestTrackData.dtd.

The second line points out the root element of the document, as well as the DTD that validates each of 
the document elements that appear inside the root element. The root element is the outermost element in 
the document that the DTD applies to. It typically denotes the document�s starting and ending points. In 
this example, the <TestTrackData> element serves as the root element of the document. The system 
keyword indicates that the DTD of the document resides in a separate local file named TestTrackData.dtd.
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Text file import and export
You can use TestTrack Pro to import and export records as comma- and tab-delimited text files. You can 
also import/export files created in other database programs such as FileMaker Pro.

Seapine Software recommends you use XML import/export record information. For more information, 
see XML import and export, page 214.

Importing text files 

1 Choose File > Import > Text File Import.

The Import dialog box opens.

2 Select the field type you want to import from the Import fields menu.

You can import defect, user, and customer information.

3 Click Browse to select a file to import.

The Open dialog box opens.

Import security access should be limited to administrative user groups. The 
misuse of this feature can result in a significant number of unwanted records in 
your database. The system administrator grants access to import/export 
commands. 



222 TestTrack Pro
Importing text files

4 Select the file you want to import and click Open.

The file information appears in the Import dialog box. The column on the left previews the fields as they 
appear in the file. Click the Previous and Next arrows to move from record to record.

5 Select the Import options.

! Select Ignore first record to ignore the first record, which often contains field names.

! Select Handle quoted text if the program you used to export the records supports quoting fields. When 
you export a file from a database, quotes are often inserted around comma- and tab-delimited 
records; otherwise, a comma or tab appearing in a block of text (e.g., a description) would be 
interpreted as a new record. 

! Select Map vertical tab to return to restore the formatting of multi-line fields. Some applications map 
carriage returns in multi-line fields to vertical tab characters. 

! Select Tab or Comma Delimiter if either character is used to separate fields.

6 Match the TestTrack Pro fields in the right column to the fields in the left column.

Click and drag the fields in the right column up or down to the proper position. If you cannot find an 
exact match, use the closest equivalent.

7 Select the fields to import.

To select a field, click in the middle column next to the field. A check mark appears next to selected 
fields. Click again to deselect the field.
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8 Click Import.

A progress indicator opens. Email notifications are not sent when you import files. The volume of email 
messages generated could cause some email servers to crash.

Creating text file import templates
If you import text files with the same field layout often, save the format as a Text File Import Template. 

1 Map the fields as described in Importing text files, page 221.

2 Click Save in the Import Templates area on the Import dialog box.

The Save Import Template dialog box opens.

3 Select the file location, enter a file name, and click Save.

The Import Template is saved. You return to the Import dialog box. 

Using text file import templates
1 Choose File > Text File Import.

The Import dialog box opens.

2 Click the Load button in the Import Templates area on the Import dialog box.

The Load Import Template dialog box opens.

3 Select the Import Template and click Open.

The template is loaded. You return to the Import dialog box. 

Create a text file import template if you are going to import a file using this 
layout again.
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Exporting to text files

1 Choose File > Text File Export.

The Export dialog box opens.

2 Select the field type you want to export from the Export fields menu.

If you have a Text File Export Template that matches the file format, load it now and skip the following 
steps.

3 Select the fields to export.

4 Repeat steps 2 and 3 for all record types.

5 Select the Export options.

! Select Export selected records only to only export records selected in the list window.

! Select Include column headings to export the column headings.

To export just a few records, select the records on the list window now. You can 
select records from any list window.

If you want to export all fields, click Check All. If you want to deselect all fields, 
click Check None.



Chapter 18 225
Creating text file export templates

! Select Convert EOLs to spaces to convert carriage returns/line feeds to spaces. This simplifies 
importing multi-line fields (e.g., defect description) into programs that do not handle fields with 
embedded carriage returns correctly such as Microsoft Excel.

! Select Tab or Comma Delimiter to insert the character between fields.

6 Click Export.

The Export file dialog box opens.

7 Select the file location, enter a file name, and click Save.

A progress indicator opens and lets you know the file is being exported.

Creating text file export templates
If you export text files with the same field layout often, save the format as a Text File Export Template. 

1 Set up the fields as described in Exporting to text files, page 224.

2 Click the Save button in the Export Templates area on the Export dialog box.

The Save Export Template dialog box opens.

3 Select the file location, enter a file name, and click Save.

You return to the Export dialog box. 

Using text file export templates
1 Choose File > Text File Export.

The Export dialog box opens.

2 Click the Load button in the Export Templates area on the Export dialog box.

The Load Export Template dialog box opens.

3 Select the Export Template and click Open.

The template is loaded and you return to the Export dialog box.

If you are going to export a file using this layout again, save this format as a 
Text File Export Template.
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Chapter 19
Customizing Email Templates

Give your users the information they need!
This chapter includes detailed information for customizing email templates to keep your users and 
customers up-to-date! Email templates affect email messages sent with notifications and email 
submissions.

In this section:

About email templates, 228

Configuring email templates, 228
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About email templates
Email templates are used to standardize email messages sent to users and customers who request email 
notifications and for sending confirmations to users/customers who submit items via email.

TestTrack Pro email templates can be used as provided or the template contents can be customized. You 
can customize the templates by using field codes, entering text, or a little of both!

Email templates support field codes, sequences of characters and letters that TestTrack Pro replaces with 
corresponding data from the database. For example, %CREL% is replaced with the method used to create 
the defect (e.g., SoloBug import).

Configuring email templates
1 Choose Activities > Configure > Email Message Templates.

The Edit Email Templates dialog box opens.

 Appendix A, �Field Codes Reference�, page 243 includes a complete list of field 
codes supported by TestTrack Pro.
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2 Select an email template and click Edit. 

The Edit Email Template dialog box opens. 

3 Make any changes.

You can edit both the subject and body of message fields. The following email template includes 
customized text and field codes:

4 Click OK.

The email template is saved and the dialog box closes. You return to the list of email templates.

When you customize a template, any spaces and lines that you add are saved 
with the template. As you type, text is automatically wrapped to the next line. 
When an email message notification is sent, all field codes are automatically 
replaced with the corresponding data from the TestTrack Pro database.
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Chapter 20
Working with SoloBug

Simplified customer bug reporting! 
This chapter includes information about customizing and distributing SoloBug to customers and 
importing SoloBug files into TestTrack Pro.

In this section:

About SoloBug, 232

Customizing SoloBug for Windows, 233

Customizing SoloBug for Palm OS, 237

Distributing SoloBug, 241

Customizing the SoloBug user guide, 241

Automatically importing SoloBug files, 241

Manually importing SoloBug files, 242
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About SoloBug
SoloBug is a stand-alone bug reporting application that works with TestTrack Pro to simplify the way 
you receive bug reports and feature requests from customers and users. SoloBug includes the following 
benefits:

! Eliminates data entry of bug reports and feature requests by automatically importing bug reports into 
TestTrack Pro. When TestTrack Pro receives an email with a SoloBug file, it is automatically added to your 
database.

! Limits customers to your bug reporting terminology, saving data entry time.

! Captures customers� computer information, making it easier to track configuration-specific issues.

! Lets your customers and users include file attachments with bug reports and feature requests.

What are SoloBug files?

A SoloBug file contains a single bug report, or feature request, created by customers and users. The 
SoloBug file is emailed to an address you specify. You can import the file into any TestTrack Pro 
database. A SoloBug file contains:

! The customer�s or user�s personal information and computer setup.

! A description of the problem or feature request.

! Any additional data or files attached to the SoloBug file.
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Customizing SoloBug for Windows
Before distributing SoloBug, customize the executable to make sure your customers and users provide 
you with all the information you need. You can customize such things as the title, instructions, or field 
names. You can also rename fields, add field values, and make fields required.

1 Start TestTrack Pro and login to the database you want to customize SoloBug for.

2 Choose Activities > Configure > Customize SoloBug > Windows. 

The Customize SoloBug for Windows dialog box opens.

3 Click Browse to select the SoloBug executable you want to customize.

The Open SoloBug Application dialog box opens. 

4 Select a SoloBug executable and click Open.

To make sure the correct SoloBug executable is distributed for each database, 
copy and rename the executable to match the database name.
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5 You return to the Customize SoloBug for Windows dialog box, with all fields populated.

6 Enter the General SoloBug Settings. 

! Title appears in the title bar of the SoloBug application, preceding the name of the open bug report file. 

! File Name Prefix becomes the first part of the SoloBug file name. The remaining portion of the bug 
report file name is a sequence number SoloBug generates to distinguish one file from another. This 
field can help you visually organize SoloBug files. For example, if you customize SoloBug for three 
different products, you can enter the product name in the File Name Prefix field.

! Instructions provide users with information specific to your use of SoloBug, such as the email address 
you want the files sent to. Instructions are not displayed if this field is empty.
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7 Customize the pop-up menu fields and select field options.

The following fields can be customized: type, severity, product, version, reproduced, and component. 

8 Click Use Database�s Settings to synchronize the information in the SoloBug executable with the TestTrack 
Pro database settings.

Selecting this option customizes all fields in the Field to Customize list.

9 To customize a field, select the field from the Field to Customize list.

This example uses the Severity field. The field name changes based on the selected field.

10 Pop-up menu control will be visible for the Severity field is selected by default. 

Clear the check box to make the field and its label invisible.

11 Select User is required to select a value for the Severity field to make this field required. 

The SoloBug file cannot be saved until values are entered for all required fields.

12 Select User can enter a free form text entry in the Severity field to let users enter a value for this field.

If you customize field names, the customized name is listed. For example, 
Element is displayed if you rename Component to Element.

If you use the database settings, required fields, field names, and field values 
are synchronized with the TestTrack Pro database.
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13 To rename the field, enter the new name in the text box. In this example, Severity is named Level.

14 The default field values appear in the Field Values list. 

You can add, edit, or delete any field value. To reorder the values, click the arrow next to the field and 
drag it up or down to a new position.

15 When you finish configuring field names and values, click Update SoloBug & Close.

TestTrack Pro modifies the SoloBug executable. The following message opens:

16 Click OK. 

The customized SoloBug executable is ready for distribution.

The values in the Field to Customize list are populated from the TestTrack Pro 
database. The In SoloBug, the...field is named value is populated from the 
SoloBug executable and might not match the Field to Customize selection.
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Customizing SoloBug for Palm OS
SoloBug for Palm OS lets your users and customers easily submit bug reports and feature requests. You 
can customize such things as the title, instructions, and field names. In addition, you can rename fields, 
add field values, and make fields required. You can also provide a customized SoloBug database for 
each customer!

1 Start TestTrack Pro and login to the database you want to customize SoloBug for.

2 Choose Activities > Configure > Customize SoloBug > Palm OS.

The Customize SoloBug for Palm OS dialog box opens.

3 Select Create new Palm OS configuration database to create a new configuration database. Skip to step 5 to 
continue customizing the configuration database.
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4 Select Edit existing Palm OS configuration to edit a configuration database.

5 Click Browse to select a Palm configuration database. 

The Open Palm OS SoloBug Configuration Database dialog box opens.

6 Select the database you want to edit and click Open. 

You return to the Customize SoloBug for Palm OS dialog box, with all fields populated.
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7 Enter the General SoloBug Settings.

! Title appears in the title bar of the SoloBug application, preceding the name of the open bug report file. 

! File Name Prefix becomes the first part of the SoloBug file name. The remaining portion of the bug 
report file name is a sequence number SoloBug generates to distinguish one file from another. This 
field can help you visually organize SoloBug files. For example, if you customize SoloBug for three 
different products, you can enter the product name in the File Name Prefix field.

! Instructions provide users with information specific to your use of SoloBug, such as the email address 
you want the files sent to. Instructions are not displayed if this field is empty.

8 Customize the pop-up menu fields and select field options.

The type, severity, product, version, reproduced, and component fields can be customized.

9 Click Use Database�s Settings to synchronize the information in the SoloBug executable with the TestTrack 
Pro database settings.

Selecting this option customizes all fields in the Field to Customize list.

10 To customize a field, select the field from the Field to Customize list.

This example uses the Severity field. The field name changes based on the field selected in the list.

11 Pop-up menu control will be visible for the Severity field is selected by default. Clear the check box to make 
the field, and its label, invisible.

If the TestTrack Pro database uses customized field names, that name is listed. 
For example, Component is renamed to Element. Element is displayed in the 
list.

If you use the database settings, required fields, field names, and field values 
are synchronized with the TestTrack Pro database.
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12 Select User is required to select a value for the Severity field to make this field required. Users will not be able 
to save the SoloBug file if a value is not selected.

13 Select User can enter a free form text entry in the Severity field to let users enter a value for this field.

14 To rename the field, enter the new name in the text box. In this example, Severity is named Level.

15 The default field values appear in the Field Values list. 

You can add, edit, or delete any field value. To reorder the values, click the arrow next to the field and 
drag it up or down to a new position.

16 Click Save when you finish customizing the configuration database.

! If you are creating a new database, the Save Palm OS SoloBug Configuration Database dialog box 
opens. Enter a file name and click Save.

! If you are editing an existing database, your changes are automatically saved.

17 The customized SoloBug executable is ready for distribution.

The values in the Field to Customize list are populated from the TestTrack Pro 
database. The In SoloBug, the ...field is named value is populated from the 
SoloBug executable and might not match the Field to Customize selection.
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Distributing SoloBug
You can freely distribute SoloBug to customers, users, beta sites, etc. Refer to the SoloBug license 
included with TestTrack Pro for rules governing distribution of SoloBug applications. SoloBug is 
available for Windows, Macintosh, and the Palm OS. 

SoloBug comes with a user guide you can edit and distribute. Every topic in the guide is included in the 
online Help, so you do not need to distribute the hard copy with SoloBug. You may want to customize the 
guide to include your company�s name, email addresses, URLs, etc.

Customizing the SoloBug user guide
SoloBug comes with a user guide you can edit, print, copy, and distribute. Every topic in the guide 
appears in the online Help, so you do not need to distribute the hard copy with SoloBug. You may want 
to customize the guide with your company�s name, email, URLs, etc. 

The following SoloBug user files are located in the TestTrack Pro folder: 

! Solobug.doc the SoloBug user guide in Microsoft Word format. 

! Solobug.pdf the SoloBug user guide in Adobe Acrobat Reader format. 

! Solobug.hlp the SoloBug Help file. The Help file cannot be customized. 

Automatically importing SoloBug files
1 Choose Edit > Options > Database Options.

The Database Options dialog box opens.

2 Click the SoloBug tab and select the import options.

Overriding SoloBug automatic import settings

When you set the automatic import options, you select the interval you want TestTrack Pro to look for 
new SoloBug files; you can override this update interval at any time.

1 Choose File > Import > Perform Server Import.

The server checks for, and imports, new SoloBug files.

Make a backup copy of the SoloBug user�s guide before you customize it! 
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Manually importing SoloBug files
1 Choose File > Import > Load SoloBug Files.

The SoloBug Files to Import dialog box opens.

2 Select the SoloBug file(s) you want to import.

Remember, SoloBug files are saved with the .sbg extension.

3 Click Open.

The imported file(s) appears in the Defects list window at the end of the list. Notice the new defect icon 
appears next to it.

You can also drag and drop the SoloBug file onto the Defects list window. 
Notice the cursor becomes a plus sign when you drag a file onto the Defects 
list window.
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Appendix A
Field Codes Reference

Use field codes to automatically generate data!
This appendix includes a list of all field codes that can be used with email notification templates, ad 
hoc reporting, and SoloSubmit. 

Field codes return the corresponding information from the database. For example, the sequence 
%DATS% is replaced with the current date format. The sequence %DNUM% is replaced with the 
defect number.

In this section:

About field codes, 244

Field codes, 245

Label field codes, 248

Field code notes, 250
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About field codes
Field codes are used to build customized email messages that provide information specific to the defect 
that triggered the notification or, in the case of an email acknowledgment, was imported via email. If you 
are creating an ad hoc report, you can use field codes to include specific database information for the 
report. You can also use field codes to build personalized SoloSubmit Web pages that provide 
information specific to your company and your customers� use of SoloSubmit.
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Field codes

Field Code Description

%ASSB% The user who made the defect assignment.

%ASSD% The date the defect was most recently assigned.

%ASST% The user to which the defect is assigned.

%ASSN% The most recent defect assignment notes.

%CF01% - 
%CF10%

Custom fields 1-10. 

%CLSB% The user who closed the defect.

%CLSD% The date the defect was closed.

%CLSN% The notes about closing the defect.

%CLSR% The close resolution.

%CHNG% The changes to the defect (only applies to Defect Changed notification).

%CMTA% All of the defect's comments.

%CMTL% The most recent defect comment.

%COMP% The component containing the defect.

%CREB% The user who was logged in when the defect was created.

%CRED% The date the defect was created.

%CREL% The method used to create the defect (e.g., SoloBug import).

%CUEM% The currently logged in user's email address (does not apply to Email 
Acknowledgement notification).

%CUSR% The currently logged in user's first and last name (does not apply to Email 
Acknowledgement notification). 

%DATL% The current date in long date format (mmmm, dd yyyy). 

%DATS% The current date in short date format (mm/dd/yy).

%DESC% The first defect description.

%DISP% The defect's disposition.

%DNUM% The defect�s number.

%DOCA% Whether the most recent defect fix affects documentation.
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%ENTB% The user who entered the defect.

%ENTD% The date the defect was entered.

%ESTB% The user who most recently estimated the defect fix.

%ESTD% The date of the most recent defect estimate.

%ESTE% The most recent estimated effort to fix the defect.

%ESTN% The notes of the most recent defect estimate.

%ESTV% The defect's most recent estimated fix version.

%ESTW% The defect�s most recent estimated fix date.

%FILE% The database�s file name.

%FIXB% The user who most recently fixed the defect.

%FIXD% The date the defect was most recently fixed.

%FIXN% The most recent notes about fixing the defect.

%FIXS% The Fix Verify/Close value from the most recent fixed action.

%FIXT% The total time required to fix the defect.

%FIXV% The version in which the defect was fixed.

%FNDB% The person who found the defect.

%FNDD% The date the defect was found.

%FNDV% The version in which the defect was found.

%MODB% The user who last modified the defect.

%MODD% The date the defect was last modified.

%NUMR% The number of users and customers reporting the defect.

%PRIO% The defect�s priority.

%PRNM% The Project Name field in the Project Info dialog.

%PROD% The product containing the defect.

%REFR% The defect�s reference field.

%RELB% The person who created the release notes.

Field Code Description
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%RELD% The date the release notes were created.

%RELH% Whether the defect has release notes.

%RELN% The defect�s most recent release notes.

%RELV% The version in which the defect fix was released.

%REPR% The defect�s reproducible status.

%RESO% The defect�s fix resolution.

%SEQN% The sequence number associated with the defect (applies only to Email 
Acknowledgment notification).

%SEVR% The defect�s severity.

%STAT% The defect�s status.

%STEP% The steps to reproduce the defect.

%SUMM% The defect�s summary.

%TCFG% The defect�s test configuration name.

%TPLA% Whether the most recent defect fix affects the test plan.

%TYPE% The defect�s type.

%VERB% The user who most recently verified the defect.

%VERD% The date the defect was most recently verified.

%VERN% The most recent notes about verifying the defect.

%VERV% The version in which the defect was verified.

%VPAS% The Verify Pass/Close value from the most recent verify action.

%WORK% The defect�s workaround.

%WRKH% Whether the defect has a workaround.

Field Code Description
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Label field codes
TestTrack Pro lets you rename defect field labels. The renamed field labels have corresponding field 
codes. These field codes return the field label, not the field data. 

The Defects Renumbered email notification template can only use the following 
field codes:

%CHNG% Changes that were made (information about renumbered defects).

%CUSR% Currently logged in user's first/last name.

%CUEM% Currently logged in user's email address.

%PRNM% The project name field in the Project Info dialog.

%FILE% The database's file name.

This template cannot use field codes that refer to an individual defect�s 
information.

Field Code Field Name

%DFUS_L% Defect - upper case, singular

%DFUP_L% Defects - upper case, plural

%DFUM_L% Defect(s) - upper case, singular/plural

%DFLS_L% defect - lower case, singular

%DFLP_L% defects - lower case, plural

%DFLM_L% defect(s) - lower case, singular/plural

%SUMM_L% Summary Type

%TYPE_L% Type

%DISP_L% Disposition

%PRIO_L% Priority

%PROD_L% Product

%COMP_L% Component
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%REFR_L% Reference

%SEVR_L% Severity

%ENTB_L% Entered by

%ENTD_L% Date Entered

%STAT_L% Status

%FNDB_L% Found by

%FNDD_L% Date Found

%DATE_L% Date

%FNDV_L% Version Found

%VERS_L% Version

%DESC_L% Description

%REPR_L% Reproduced

%STEP_L% Steps to Reproduce

%TCFG_L% Computer Config

%HWSW_L% Other Hardware and Software

%CFTB_L% Custom Field tab

Remember, renamed label field codes only return the label name and not the 
field data. For example, you rename Reference to Case Number. You 
customize an email template to notify managers of a problem, including the 
case number in the subject line. In the subject line of the template, enter 
%REFR_L%: %REFR%. When a manager is sent an email, the subject line 
includes: Case Number (label): case number (data).

Field Code Field Name
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Field code notes
! All dates use system-defined date formats. TestTrack Pro uses the short-date style of the Regional Settings 

Properties defined in the Windows Operating System.

! To include a percent sign (%) in the body of a message, include two percent signs in a row (e.g., �%%�).

! Email notifications support field codes in the email subject line. Therefore, you can include personalized 
subjects such as �Re:%SUMM%� which expand to include the defect�s summary field in the email�s 
subject.
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About Defect Fields
This appendix includes tables that define every defect field and lists whether they can have default 
values or if they can be set as required fields. For more information, see Defining required fields and 
default values, page 167.

In this section:

Defect record, 252

Found by record in a defect, 253

Defect assignment record, 253

Estimate to fix record, 254

Fix defect record, 254

Release to testing record, 255

Verify defect record, 255

Release to customer testing record, 255

Customer verify defect record, 256

Re-open defect record, 256

Close defect record, 256

Defect comments record, 257

Release notes record, 257
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Defect record
The following table lists the fields that are part of the defect record.

Field name Set default 
value?

Initial default 
value

Configure as 
required?

Initially configured 
as required?

Summary no NA yes yes

Status no NA no NA

Type yes <not set> yes yes

Product yes <not set> yes no

Reference no NA yes no

Entered by yes <current user> yes yes

Disposition yes <not set> yes no

Priority yes <not set> yes no

Component yes <not set> yes no

Severity yes <not set> yes no

Date Entered yes <current date> yes no

Custom fields 
(pop-up menu)

yes <not set> yes no

Custom fields 
(edit box)

no NA yes no

History no NA yes no

Workaround no NA yes no

Notify no NA no NA
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Found by record in a defect
The following table lists the fields that are part of the found by record in a defect. The default values are 
used every time a new found by record is created in the defect. The fields marked as required must be 
filled in for every found by record in the defect.

Defect assignment record
The following table lists the fields that are part of the defect assignment record.

Field name Set default 
value?

Initial default 
value

Configure as 
required?

Initially configured 
as required?

Found by yes <current user> yes yes

Date Found yes <current date> yes no

Version Found yes <not set> yes no

Description no NA yes no

Reproduced yes <not set> yes no

Steps to 
Reproduce

no NA yes no

Computer Config yes �User Config� yes no

Other HW & SW no NA yes no

Attachments no NA no NA

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Assign to yes <blank> yes yes

Assigned by yes <current user> yes yes

Date yes <current date> always NA

Notes no NA yes no
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Estimate to fix record
The following table lists the fields that are part of the estimate to fix record.

Fix defect record
The following table lists the fields that are part of the fix defect record.

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Estimated by yes <current user> yes yes

Date yes <current date> always NA

Estimated effort no NA yes no

Completion date yes <not set> yes no

Completion 
version

yes <not set> yes no

Assumption no NA yes no

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Fixed by yes <current user> yes yes

Date yes <current date> always NA

Version no NA yes no

Resolution yes <not set> yes yes

Hours to fix no NA yes no

Affect 
documentation

yes not checked no NA

Affect test plan yes not checked no NA

Notes no NA yes no
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Release to testing record
The following table lists the fields that are part of the release to testing record.

Verify defect record
The following table lists the fields that are part of the verify defect record.

Release to customer testing record
The following table lists the fields that are part of the release to customer testing record.

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Released by yes <current user> yes yes

Date yes <current date> always NA

Notes no NA yes no

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Verified by yes <current user> yes yes

Date yes <current date> always NA

Version yes <not set> yes no

Pass or fail yes Pass and close no NA

Notes no NA yes no

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Released by yes <current user> yes yes

Date yes <current date> always NA

Notes no NA yes no
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Customer verify defect record
The following table lists the fields that are part of the customer verify defect record.

Re-open defect record
The following table lists the fields that are part of the re-open defect record.

Close defect record
The following table lists the fields that are part of the close defect record.

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Verified by yes <current user> yes yes

Date yes <current date> always NA

Version yes <not set> yes no

Pass or fail yes Pass and close no NA

Notes no NA yes no

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Re-opened by yes <current user> yes yes

Date yes <current date> always NA

Notes no NA yes no

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Closed by yes <current user> yes yes

Date yes <current date> always NA

Notes no NA yes no
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Defect comments record
The following table lists the fields that are part of the defect comments record.

Release notes record
The following table lists the fields that are part of the release notes record.

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Commented by yes <current user> yes yes

Date yes <current date> always NA

Notes no NA yes no

Field name Set default 
value?

Initial default 
value selection

Configure as 
required

Initially configured 
as required?

Released by yes <current user> yes yes

Date yes <current date> always NA

Notes no NA yes no
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Appendix C
Security Reference

User Groups and Security…
protect your data. This appendix includes a list of the categories and commands available for 
command security and the groups and fields available for field security. For information about 
creating user groups and setting up security, see User groups and security, page 187.

In this section:

Command security, 260

Field security, 265
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Command security
Command security restricts access to a command and is set by category. For example, Can a user fix a 
defect? 

Command security includes the following categories: General commands, Administration commands, 
Defect commands, Customer commands, User commands, User Group commands, Test Configuration 
commands, Filter commands, Report commands, and Workbook commands.

General commands

Assign Defect Numbers

Renumber Defects

Edit Own Notifications

Modify own password

Modify own general user settings

Allow login via Windows client

Allow login via Web client

Allow login via add-in DLL

Allow login via SOAP

Change Own List Columns

Administration commands

Edit Database Options

Setup Project Fields

Setup Version Field

Configure Field Relationships

Configure Required Fields & Default Values

Rename Field Labels

Configure Auto-Assign Rules

Configure Email Templates
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Configure SCC DB Options

Delete Historical Defect Info

Show Logged In Users

Logout Other Users

Import From Text File

Export To Text File

Import From XML File

Export to XML File

Create Release Notes Output

Defect commands

Add Defects

View Defects

Edit Defects

Delete Defects

Duplicate Defects

Assign Defects

Estimate Resolution

Fix Defects

Release to Testing

Verify Defects

Release to Customer Testing

Customer Verify Defects

Close Defects

Re-open Defects

Edit Closed Defects
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Edit Defects Assigned to Anyone

Add a Comment

Add/Edit Release Notes

Merge Defects

Edit Own Historical Actions

Edit Other�s Historical Actions

Delete HIstorical Actions

See Notify Tab

See Workflow Tab

See SCC Tab

See History Tab

Add Attachments

Remove Attachments

View/Extract Attachments

Add Notify User

Remove Notify User

Add Reported by Record

Remove Reported by Record

Perform SCC Actions

Customer commands

Add Customers

View Customers

Edit Customers

Delete Customers

Duplicate Customers
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Make Customer a User

Activate/Inactive Customer

User commands

Add Users

View Users

Edit Users

Delete Users

Duplicate Users

Edit User Login

Edit User Group Setting

Make User a Customer

Activate/Inactive User

User Group commands

Add User Groups

View User Groups

Edit User Groups

Delete User Groups

Duplicate User Group

See Security Tabs

Test Configuration commands

Add Test Configs

View Test Configs

Edit Test Configs

Delete Test Configs

Duplicate Test Configs
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Filter commands

Add Filters

Mark Own Filters As Shared

Mark Shared Filters As Shared

View Own Filters

View Shared Filters

Edit Own Filters

Edit Shared Filters

Delete Own Filters

Delete Shared Filters

Duplicate Own Filters

Duplicate Shared Filters

Report commands

Add Reports

Mark Reports As Shared

View Own Reports

View Shared Reports

Edit Own Reports

Edit Shared Reports

Delete Own Reports

Delete Shared Reports

Duplicate Own Reports

Duplicate Shared Reports

Run Own Reports

Run Shared Reports



Appendix C 265
Field security

Workbook commands

Add Tasks

View Tasks

Edit Tasks

Delete Tasks

Field security
Field security affects defects and defect actions and restricts a user�s ability to enter, or edit, field data. 
For example, can a user enter a resolution in the fix defect action field?

Security can be assigned to the following fields: General fields, Found By fields, Assigned fields, 
Estimated fields, Fixed fields, Release To Test fields, Verified fields, Release To Customer Test fields, 
Customer Verified fields, Closed fields, Reopen fields, Release Notes fields, Comment fields, and 
Custom fields.

General fields

Defect Number

Summary

Type

Priority

Status

Disposition

Product

Component

Reference

Severity

Entered by

Date Entered

Has Attachments?
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Has Workaround?

Has SCC files?

Workaround

Date Created

Created By

Creation Method

Date Last Modified

Last Modified By

All Action Notes

Found By fields

Found by

Found By Group

Found By Company

Date Found

Version Found

Description

Reproduced

Steps to Reproduce

Computer Config

Other Hardware and Software

How Many? 

User or Customer

Assigned fields

Assigned To

Assigned By
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Date Assigned

Assigned Notes

Estimated fields

Estimated By

Date Estimated

Estimated Effort

Completion Date

Estimated Version

Estimated Notes

Fixed fields

Fixed By

Fixed Verify/Close

Date Fixed

Fixed Resolution

Fixed In Version

Hours to Fix

Affects Documentation?

Affects Test Plan?

Fix Notes

Release To Test fields

Release To Test By

Date Released To Test

Version Released To Test

Released To Test Notes

Verified fields
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Verified By

Verify Pass/Failed

Date Verified

Version Verified

Verified Notes

Release To Customer Test fields

Released To Customer Test By

Date Released To Customer Test

Version Released To Test

Released To Customer Test Notes

Customer Verified fields

Customer Verified By

Customer Verified Pass/Failed

Date Customer Verified

Customer Version Verified

Customer Verified Notes

Closed fields

Closed By

Date Closed

Closed Resolution

Closed Notes

Reopen fields

Reopened By

Date Reopened

Reopened Notes
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Release Notes fields

Has Release Notes?

Release Notes By

Date Released

Version Released

Release Notes

Comment fields

Comment By

Date Commented

Comment

Custom fields

Security can be set for custom fields. The names of these fields depend on the custom fields you set up.
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Index

A

About
customers 204
databases 142
defects 30
email templates 228
field codes 244
reports 104
SCC applications and TestTrack Pro 176
security 186
SoloBug 232
test configs 100
TestTrack Pro Add-In 130
the workbook 126
user groups 186
users 194

Activating
customers 211
users 199

Adding
additional defect reports 34
auto-assign rules 156
column contents 27
columns 26
comments 83
custom fields 164
customers 204
defects 30
field names 162
field relationships 170
filters 93
new stylesheets 104
release notes 84
restrictions 95
test configs 100
To Do tasks 126
user groups 189
users 194
users to user group 191

Additional defect reports
adding 34

deleting 52
editing 44

Advanced find
adding restrictions 95
defects 37
deleting restrictions 96
editing restrictions 96
inserting restrictions 96
viewing restrictions 96

Assigning
defect numbers 45
defects to users 74

Attached files
deleting 52
extracting 43
opening 42
viewing 40

Auto-assign rules
adding 156
configuring 155
deleting 158
editing 158
exceptions 156
inserting 158
processing 155
setting default 157

B

Boolean operators
and 92
nesting 92
not 92
or 92

Boolean searches 92

Bug icon 24

C

Changing
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column contents See Adding column contents
column width 27
field values 46
password 18

Check mark icon 24

Closed (Customer Verified) state 70

Closed (Fixed) state 70

Closed (Verified) state 70

Closed state 70

Closing defects 81

Columns
adding 26
adding contents 27
changing contents see adding contents
changing width 27
deleting 28
removing 28
sorting 27
sorting primary 27
sorting secondary 27

Command buttons 21

Command-level security 187
Administration category 260
Customers category 262
Defects category 261
Filters category 264
General category 260
reference 260
Reports category 264
Test Configurations category 263
User Groups category 263
Users category 263
Workbook category 265

Configuring
auto-assign rules 155
custom fields 164
email templates 228
field names 162
field relationships 169
SCC integration 57, 177

Connecting to a server 12

Contacting Seapine support 4

Creating
databases 142
detail reports 107
distribution reports 110
filters 93
list reports 113
release notes 85
report templates 106
text file export templates 225
text file import templates 223
trend reports 116

Custom fields
adding 164
check box 165
configuring 164
date/time 165
deleting 166
edit box 165
editing 165
pop-up menu 165
types 165

Customer testing
releasing fix to 79

Customer verification
releasing fix to 80

Customers
about 204
activating 211
adding 204
deleting 211
duplicating 210
editing 210
inactivating 211
list window 24
making user 199
searching 209
verify fix 80
viewing 207

Customizing
existing stylesheets 104
SoloBug for Palm OS 237
SoloBug for Windows 233
SoloBug user guide 241
stylesheets 104
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D

Databases
about 142
configuring 141
creating 142
opening 11

Dedicated license 7

Default values
defining 167
editing 168

Defect action toolbar 73
assign 73
close 73
comments 73
customer verify 73
estimate 73
fix 73
release notes 73
release to customer testing 73
release to testing 73
re-open 73
verify 73

Defect actions
deleting 88
editing 87
understanding 72
viewing 86

Defect assignments
understanding 72

Defect field table
close defect record 256
customer verify defect record 256
defect assignment record 253
defect comments record 257
defect record 252
estimate to fix record 254
fix defect record 254
found by record in a defect 253
release notes record 257
release to customer testing record 255
release to testing record 255
re-open defect record 256
verify defect record 255

Defect fields
reference 251

Defect fix
verifying 78

Defect indicators 24
assigned defect 24
bug icon 24
changed defect 24
check mark icon 24
closed defect 24
exclamation point icon 24
new defect 24
pencil icon 24

Defect numbers
assigning 45

Defect options
setting 144

Defect states
description 70

Defect status 70

Defect workflow 70

Defect-level security 187

Defects
about 30
adding 30
adding comments to 83
adding release notes to 84
advanced find 37
assigning to user 74
attaching files to 35
closing 81
deleting 53
duplicating 43
editing 41
estimating time to fix 75
finding 36
fixing 76
list window 23
merging 43
renumbering 45
re-opening 82
viewing 39
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Deferred defect numbering 45

Defining
default values 167
required fields 167

Deleting
additional defect reports 52
attached files 52
auto-assign rules 158
columns 28
custom fields 166
customers 211
defect actions 88
defects 53
detail reports 123
distribution reports 123
field relationships 172
field values 163
filters 98
historical defect log information 159
list reports 123
password 18
restrictions 96
server connection 11
test configs 101
To Do tasks 127
trend reports 123
user groups 192
users 200

Detail reports
creating 107
deleting 123
editing 121

Disabling
SCC integration 58, 180

Distributing SoloBug 241

Distribution reports
creating 110
deleting 123
editing 121

Drag and drop
SoloBug files 242

Duplicating
customers 210
defects 43

filters 97
test configs 101
To Do tasks 127
users 198

E

Editing
additional defect reports 44
auto-assign rules 158
custom fields 165
customers 210
default values 168
defect actions 87
defects 41
detail reports 121
distribution reports 121
field names 163
field relationships 172
filters 97
list reports 121
required fields 168
restrictions 96
server connection 11
test configs 101
To Do tasks 127
trend reports 121
user groups 192
users 198

Email
about templates 228
configuring templates 228
enabling 145
setting options 17

Enabling
historical defect logging 159
sending mail 145

Estimating
time to fix defect 75

Exceptions
auto-assign rules 156

Exclamation point icon 24

Exporting
to text files 224
to XML files 217



Index 275
 

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Extracting
attached files 43

F

Field codes 245
about 244
label 248
notes 250
reference 243

Field labels
renaming 172
restoring original 174

Field names
adding 162
configuring 162
editing 163

Field relationships
adding 170
child fields 169
configuring 169
deleting 172
editing 172
parent fields 169
parent-child 169

Field values
changing 46
deleting 163
replacing computer config 49
replacing custom 51
replacing defect actions 50
replacing general 46
replacing reported by 47
replacing steps to reproduce 48

Field-level security 188
add privileges 188
Assigned fields 266
Closed fields 268
Comment fields 269
Custom fields 269
Customer Verified fields 268
edit privileges 188
Estimated fields 267
Fixed fields 267
Found by fields 266

General fields 265
read only 188
read/write 188
reference 265
Release Notes fields 269
Release To Customer Test fields 268
Release To Test fields 267
Reopen fields 268
Verified fields 267

Files
attaching to defects 35

Filters
about 92
adding 93
creating 93
deleting 98
duplicating 97
editing 97
list window 25
using 97
viewing 97

Finding defects 36
advanced find 37

Fixed state 70

Fixing
defects 76

Floating license 7

G

General database options
setting 143

General options
setting 15

Go to command 37

H

Help me! 4

Historical defect information
deleting 159
enabling 159
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logging 159

I

Icon
bug 24
check mark 24
exclamation point 24
pencil 24
read-only 42

Import mail options
setting 148

Importing
SoloBug files automatically 241
SoloBug files manually 242
text files 221
XML files 214

Inactivating
customers 211
users 199

Inserting
auto-assign rules 158
restrictions 96

Installing
Visual Studio add-in 130

Integrating
SCC applications and TestTrack Pro 176

Interface 20
command buttons 21
menu bar 20
status bar 21
title bar 20
toolbar 20
tooltips 21

L

Label field codes 248

Licenses
dedicated 7
floating 7

List reports

creating 113
deleting 123
editing 121

List windows 23
customers 24
defects 23
filters 25
opening 23
reports 26
test configs 25
user groups 25
users 24
workbook 26

Loading
text file export templates 225
text file import templates 223

Local options
setting 14

Logged in users
viewing 200

Logging historical defect information 159

Logging in
default username 8
TestTrack Pro 6

Logging out 12
other users 201

M

Mail
enabling 145

Making
customers users 199
users customers 210

Manually starting
TestTrack Pro server 6

Merging
defects 43

N

Need Customer Verify state 70
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Nesting
Boolean operators 92

Notes
field codes 250
XML import/export 218

Notification options
setting 17

O

Open (Re-opened) state 70

Open (Verify Failed) state 70

Open state 70

Opening
attached files 42
databases 11
list windows 23

P

Parent-child field relationships 169

Password
changing 18
deleting 18
removing 18
setting 18
setting options 154

Pencil icon 24

Previewing reports 121

Printing 28
records 28
reports 122

Processing
auto-assign rules 155

Project information
viewing 12

R

Read-only icon 42

Records
import/export text files 221
printing 28
selecting 23

Reference
command-level security 260
defect fields 251
field codes 243
field-level security 265
security 259

Refreshing stylesheets 105

Release notes
creating 85

Release to Customer Testing state 70

Release To Testing state 70

Releasing fix
to customer testing 79
to customer verification 80
to testing 77

Removing
columns 28
password 18

Renaming field labels 172

Renumbering defects 45

Re-opening defects 82

Replacing
computer config field values 49
custom field values 51
defect actions field values 50
general field values 46
reported by field values 47
steps to reproduce field values 48

Report options
setting 153

Report templates
creating 106

Reports
about 104
creating detail 107
creating distribution 110
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creating list 113
creating trend 116
deleting 123
editing 121
list window 26
previewing 121
printing 122
viewing 121

Required fields
defining 167
editing 168

Restoring field labels 174

Restrictions
adding 95
deleting 96
editing 96
inserting 96
viewing 96

S

Sample XML 220

Saving
copy of a report 122

SCC
application notes 181

SCC applications
integrating with TestTrack Pro 176

SCC integration
attaching files 60
checking in files 63
checking out files 64
configuring 57, 177
detaching files 61
disabling 58, 180
getting files 62
undoing check out 66
viewing file history 67
viewing files 66

SCC notes
ClearCase 182
CS-RCS 181
CVS 181

Perforce 182
PVCS 182
SourceOffSite Classic 182
StarTeam 183
Surround SCM 183
Visual SourceSafe 183

Searching for customers 209

Security
about 186
command-level 187
defect-level 187
field-level 188
reference 259
structure 186
user groups 187

Selecting records 23

Send mail options
setting 145

Sending mail
enabling 145

Server
connecting 12
manually starting 6
starting 6

Server connection
adding 9
deleting 11
editing 11

Setting
default auto-assign rules 157
default stylesheet 105
defect options 144
email options 17
general database options 143
general options 15
import mail options 148
local options 14
password 18
password options 154
report options 153
send mail options 145
SoloBug options 150
SoloSubmit options 151
user options 15
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workflow options 147

SoloBug
about 232
customizing for Palm OS 237
customizing for Windows 233
customizing user guide 241
distributing 241
importing files automatically 241
importing files manually 242
overriding automatic import settings 241
setting options 150
solobug.doc 241
solobug.hlp 241
solobug.pdf 241

SoloBug files 232
drag and drop 242

SoloSubmit
setting options 151

Sorting
columns 27
primary column 27
secondary column 27

Source code control
using with TestTrack Pro 56

Starting
TestTrack Pro 6
TestTrack Pro server 6

States
Closed 70
Closed (Customer Verified) 70
Closed (Fixed) 70
Closed (Verified) 70
Fixed 70
Need Customer Verify 70
Open 70
Open (Re-opened) 70
Open (Verify Failed) 70
Release to Customer Testing 70
Release to Testing 70

Stylesheets
adding images to 104
adding new 104
customizing 104
customizing existing 104

refreshing 105
setting default 105
using 104

Support
getting help 4

T

Test configs
about 100
adding 100
deleting 101
duplicating 101
editing 101
list window 25
viewing 101

Testing
releasing fix to 77

TestTrack Pro
integrating SCC applications 176
interface 20
logging in 6
manually starting server 6
starting 6
starting server 6
starting the first time 7

TestTrack Pro Add-In
about 130
installing 130

TestTrack Pro toolbar 22

Text file import/export 221
creating export templates 225
creating import templates 223
using export templates 225
using import templates 223

Text file report templates
using 106

Text files
exporting to 224
importing 221

To Do tasks
adding 126
deleting 127
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duplicating 127
editing 127
viewing 127

Transferring
customers to users list 199
users to customers list 210

Trend reports
creating 116
deleting 123
editing 121

U

Understanding
defect actions 72
defect assignments 72
Workbook tasks 126

User groups
about 186
adding 189
adding users to 191
and security 187
deleting 192
editing 192
list window 25
viewing 192

User guide
conventions 3
documentation feedback 4

User options
setting 15

Users
about 194
activating 199
adding 194
adding to user group 191
deleting 200
duplicating 198
editing 198
inactivating 199
list window 24
logging out 201
making customers 210
viewing 197

Using
deferred defect numbering 45
filters 97
source code control 56
stylesheets 104
text file export templates 225
text file import templates 223
text file report templates 106

V

Verifying
defect fix 78

Viewing
attached files 40
customers 207
defect actions 86
defects 39
filters 97
logged in users 200
project information 12
reports 121
restrictions 96
test configs 101
To Do tasks 127
user groups 192
users 197

Visual Studio
about integration 130
add-in toolbar 131
adding defects 136
adding tasks 138
connecting to a database 132
deleting defects 137
deleting tasks 139
editing defects 137
editing tasks 139
installing add-in 130
open workspace options 133
opening defect list 136
opening task list 138
setting options 133
using the workbook 138
viewing defects 137
viewing tasks 139
working with defects 136
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W

Warnings and errors
XML import/export 219

Workbook
about 126
defect task 126
list window 26
tasks 126
to do task 126

Workflow 70

Workflow options

setting 147

Workflow states 70

X

XML
exporting to 217
import/export 214
import/export notes 218
import/export warnings and errors 219
importing files 214
sample 220
warnings and errors 216
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