
________________________________________________________________________ 

 Page 1 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

 

 
 

 
 

 
 

 
 

 
 

 
 

 
 

 
 
 

 
 

 
Auction X2 

 

(Microsoft ® Windows 9x, ME, 2000, XP) 

 
User Guide 

 
Version 1.0 



________________________________________________________________________ 

 Page 2 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

Contents 
 

 
 

 
 

 
 

 

Auction X2 ............................................................................................... 1 

(Microsoft ® Windows 9x, ME, 2000, XP) ...................................................... 1 

User Guide .............................................................................................. 1 

Contents ................................................................................................. 2 

About This User Guide ............................................................................... 4 

Getting Started ........................................................................................ 5 

Importing your ebay Invoice Data ............................................................... 20 

Automated Marketing ............................................................................... 22 

Searching For Items ................................................................................. 26 

Filtering Items ......................................................................................... 27 

Exporting Sales To Excel (CSV) .................................................................. 28 

Backing Up Your Data ............................................................................... 29 

Restoring Your Backup Data ...................................................................... 30 

Printing Your Sales Data ........................................................................... 31 

Compacting Your Database ........................................................................ 32 

The Auction X2 User Interface .................................................................... 33 

Managing Locations .................................................................................. 38 

Managing Overheads ................................................................................ 43 

Options .................................................................................................. 48 

Other Menu Items .................................................................................... 50 

Reporting ............................................................................................... 52 

Profit Cost Analysis ..................................................................53 

Overheads Analysis ..................................................................56 

Annual Profit Graph ..................................................................58 

Annual Overheads Graph ..........................................................59 

Returning Buyers Report ...........................................................60 

Profit By Location Report ...........................................................61 

Profit By Category Report ..........................................................62 

Profit By Hour Of Listing Report .................................................63 



________________________________________________________________________ 

 Page 3 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

Profit By Day Of Listing Report ...................................................64 

Profit By Pictures Bought Report ................................................65 

Ten Most Profitable Items Report ...............................................66 

Bottom Ten Sales Report ..........................................................67 

In Summary ........................................................................................... 68 



________________________________________________________________________ 

 Page 4 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

About This User Guide 
 

 

 

 

 

 

 

 

Welcome to the Auction X2 1.0 User Guide.  By reading the chapters 

in this guide you will be able to learn how to get the best out of 
Auction X2 and be on the way to discovering how to sell more 
effectively on ebay and of course to make more profit! 

 
This user guide covers all the features found within Auction X2 and 

includes a handy Getting Started guide at the beginning just in case 
you want to leave reading the guide more fully until a little later. 
 

Amongst the new features we have added to version 1.0 of Auction 
X2 by far the most exciting is the new Marketing tools which provide 

features to allow you the ebay seller to automate emails to your 
previous buyers when you have new items for sale similar to those 
they have bought from you before. 

 
 

________________________________________________________________ 

Note For further information relating to Auction X2 please visit us at 

www.auctionx2.com 
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Getting Started 
   

 

 

 

 

 

 

 
When you start Auction X2 for the first time you will be presented 
with the following window. 

 

 
 
Fig 1.1 Auction X2 without ebay item data. 

 

 

_______________________________________________________________ 

Note Please ensure you are connected to the Internet before attempting to 

use any of the Import features within Auction X2. 
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Auction X2 works by importing your sold and unsold item data from 
ebay using the Import Menu Option.  Before importing your Sold 

Item data, there are a couple of changes that you may need to make 
to customise your Sold Items ebay page which will allow Auction X2 

to successfully import your data. 
 
Which ebay page you customise depends on whether or not you use 

ebay’s Selling Manager or not.  If you do not use ebay’s Selling 
Manager please read on.  If you are an ebay Selling Manager user 

then please read ahead to page 15 to see how to import your sold 
and unsold items. 
 

_______________________________________________________________ 

Note You can configure Auction X2 to look for its data on ebay either in the 

basic ebay pages or alternatively within ebay’s Selling Manager pages.  

Auction X2 will prompt you which you prefer when it is first launched and 

you may also set this preference from the Options screen in Auction X2. 
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Ø  To configure Back To Basics ebay Sold Items page 
 

1. Using your preferred Internet Browser (i.e Internet Explorer)  
     Log on to ebay and go to “My ebay”. 

 
2. Click on “Sold Items”. 

 

3. To the right of your screen click on “Customise Display”. 
 

4. The following view will be shown. 
 

 
 

Fig 1.2 My ebay Customise Items I’ve Sold 
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5. Ensure that in the “Columns To Display” list all of the available 
columns are included as shown in Fig 1.2 above. 

 
6. Ensure your other settings are the same as in Fig 1.2 above. 

 
7. Ensure you Click on “Save” to remember these settings. 

 

8. You are now ready to start importing your recent sales from the 
last 60 days into Auction X2! 

 
 

 

Ø  How to import your sold items to Auction X2 
 

1. From the Auction X2 main window click on the File menu. 
 

2. Move to the Import menu and then click on the Sold Items menu 

option. 
 

3. A secure browser window will now appear asking you to logon to 
ebay.  Logon to ebay. 

 
 

_______________________________________________________________ 

Note If you were previously logged onto ebay already then the Auction X2 

browser will take you straight to your sold items page. 

 

Security Assurance: Auction X2 uses the Microsoft Internet Explorer 

browser engine during all item imports. 
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4. When the ebay Sold Items page is displayed in the Auction X2 
browser window as seen below, then simply press the “Start” 

button to import your sold items. 
 

 
Fig 1.3 Import Sold Items dialog within Auction X2 
 

 
 

_______________________________________________________________ 

Note If after Items I’ve Sold (xxx items) you can see a button or link 

stating view all items then please click on this in order that Auction X2 can 

also import all visible sold items. 
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5. Once the import has finished Auction X2 will pop up a dialog box 
informing you of how many sold items were successfully 

imported.   
 

 
 

Fig 1.4 Auction X2 displaying imported sold items from ebay. 

_______________________________________________________________ 

Note Auction X2 will automatically resize its columns to fit all of your 

imported sales data into view. You can continue working with Auction X2 

whilst importing for example you may want to run a report whilst your sales 

are being imported. 
 

 

You may also have some Unsold Items in ebay, which Auction X2 can 
also import to provide you with a more complete picture of how well 

you are doing. 

 
The next section of Getting Started will help you to import this 

information also. 
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Before importing your Unsold Item data, there are a couple of 
changes that you need to make to customise Unsold Items ebay 

page which will allow Auction X2 to successfully import your data. 
 

Ø  To configure Back To Basics ebay Unsold Items page 
 

1. Using your preferred Internet Browser (i.e Internet Explorer) Log 
on to ebay and go to “My ebay”. 

 

2. Click on Unsold Items. 
 
3. To the right of your screen click on Customise Display. 

 
4. The following view will be shown. 

 

 
 

Fig 1.5 My ebay Customise Unsold Items 
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5. Ensure that in the Columns To Display List all of the available. 
 

6. Ensure your other settings are the same as in Fig 1.5 above. 
 

7. Ensure you click on “Save” to remember these settings. 
 
8. You are now ready to start importing your recent Unsold items 

into Auction X2! 
 

 
 

Ø  How to import your unsold items to Auction X2 

 
1. From the Auction X2 main window click on the File menu. 

 
2. Move to the Import menu and then click on the Unsold Items 

menu option. 

 
3. A secure browser window will now appear asking you to logon to 

ebay.  Logon to ebay. 
 

4. When the ebay Sold Items page is displayed in the Auction X2 
browser window as seen below, then simply press the “Start” 
button to import your Unsold items. 

 
 

_______________________________________________________________ 

Note If you were previously logged onto ebay already then the Auction X2 

browser will take you straight to your unsold items page. 

 

Security Assurance: Auction X2 uses the Microsoft Internet Explorer 

browser engine during all item imports. 
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Fig 1.6 Import Unsold Items dialog within Auction X2 

 

 

_______________________________________________________________ 

Note Also, if after Unsold Items (xxx items) you can see a button or link 

stating view all items then please click on this in order that Auction X2 can 

also import all unsold items.



________________________________________________________________________ 

 Page 14 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

Once the import has finished Auction X2 will pop up a further dialog 
informing you of how many unsold items were successfully imported.  

 

 
 
Fig 1.7 Auction X2 displaying imported unsold items from ebay. 
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Ø  To configure ebay Sold Items page using ebay’s Selling 
Manager 

 
1.  Using your preferred Internet Browser (i.e Internet Explorer)  

     Log on to ebay and go to “My ebay”. 
 

2.  Click on “Sold” found under Selling Manager. 

 
3.  To the right of your screen click on “Customise Display”. 

 
4.  The following view will be shown. 

 

 
 

Fig 1.8 My ebay Customise Items I’ve Sold 
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5. Ensure that in the “Columns To Display” list all of the available 
columns are included as shown in Fig 1.8 above.   

 
6. Ensure your other settings are the same as in Fig 1.2 above. 

 
7. Ensure you Click on “Save” to remember these settings. 

 

8. You are now ready to start importing your recent sales into 
Auction X2! 

 
 

 

Ø  How to import your sold items to Auction X2 
 

This step is carried out in exactly the same way as described above. 
 
 

Ø  To configure ebay Unsold Items page using ebay’s Selling 
Manager 

 
1. Using your preferred Internet Browser (i.e Internet Explorer) Log 

on to ebay and go to “My ebay”. 
 

2. Click on Unsold found under Selling Manager. 
 
3. To the right of your screen click on Customise Display. 

 
4. The following view will be shown. 
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Fig 1.9 My ebay Customise Unsold Items 
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5. Ensure that in the Columns To Display List all of the available 
columns are included as shown in Fig 1.9 above. 

 
6. Ensure your other settings are the same as in Fig 1.5 above. 

 
7. Ensure you click on “Save” to remember these settings. 

 

8. You are now ready to start importing your recent Unsold items 
into Auction X2! 

 
 

 

Ø  How to import your unsold items to Auction X2 
 

This step is carried out in exactly the same way as described above. 
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How to import your categories into Auction X2 
 

Now that you have successfully imported your recent sold and unsold 
items from ebay you will need to import category and description 

information for all of your items. 
 
1. From the Auction X2 main window click on the File menu. 

 
2. Click on Import Categories & Descriptions. 

 
Your category and description information will now be imported.  The 
import progress bar in Auction X2 will keep you up to date of 

progress. 
 

Congratulations! You are now ready to start expertly analysing 
your sales by making use of Auction X2’s range of reports that can all 
be found under the Reports menu. 

 
 
_______________________________________________________________ 

Note Read on to see how you can import your ebay invoices into Auction X2 

to add further detail to your reports. 
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Importing your ebay Invoice Data 
 

 

 

This section details how you can import your ebay Invoices into 

Auction X2. Please refer to the Getting Started section for importing 
sold items, unsold items and categories and descriptions. 

 
Auction X2 can import five different types of ebay data.  These are: 

 
Ø  Sold items 

 
Ø  Selling items 

 

Ø  Unsold items 
 

Ø  Categories and Descriptions 
 

Ø  ebay Invoices 

 
 

 
Ø  How to import your ebay invoice into Auction X2 

 

1. Using your preferred Internet Browser (i.e Internet Explorer) Log 
on to ebay and go to “My ebay”. 

 
2. Click on “Seller Account” in the left hand menu. 

 

3. Click on the link “View Account Status”. 
 

4. From the Account Status page click on the Download option 
towards the top right hand of the screen. 

 

5. You will now be prompted to save your current invoice as follows. 
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Fig 2.1 Saving your ebay invoice 
 

 
 

6. Save the invoice file to your computer and take note where it is 

saved e.g. “My Documents” folder. 
 

7. From the Auction X2 main window click the File menu. 

 
8. Click on the Import menu and then the Invoice menu option. 

 
9.  A file open dialog will appear, use the dialog to locate and open 

your invoice file that you saved earlier. e.g. “My Documents” 

folder. 
 

10. Your invoice information will now be imported into Auction X2. 
During the import the progress bar will update accordingly and 
once finished Auction X2 will popup a dialog telling you how many 

fees have been imported. 
 

 
Congratulations! If you have worked through all of the getting 
started sections, you are now ready to start expertly analysing your 

sales by making full use of Auction X2’s range of reports that can all 
be found under the Reports menu. 
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Automated Marketing 
 

 

 

Automated Marketing works by comparing items you have previously 

sold to items you are currently selling and then generating Emails to 
send to your previous buyers to let them know where to find your for 

sale items. 
 

There are two features in the new marketing menu the first of which 
is an Email designer which allows you to put a template together that 

forms the basis of your marketing Email to previous buyers. 
 
The Email designer screen appears as below. 

 

 
 
Fig 3.1 Designing your marketing Email 
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The designer allows you to key in your email with the added benefit 
of placing templates into the mail that get replaced with actual 

selling item information when Auction X2 creates your Emails for 
you.  The following templates can be inserted in the Email anywhere 

and as many times as you like.  The templates are: 
 

• Item Web Link – places an http web link to your selling item in 

the Email.  This allows your previous buyers to go straight to 
your item by simply clicking on the link in the Email sent to 

them by Auction X2. 
 
• Sale Days Left – places the time your auction has left to run in 

the Email e.g. 6d 5h 44m would represent 6 days, 5 hours and 
44 minutes. 

 
• Current Price – places the current bid price of your selling item 

in the Email. 

 
• Description – places the selling item’s decription in the Email. 

 
• Number of Bids – places the current number of bids your 

selling item has received in the Email. 
 

• Prev Buyer Id – places the ebay name of the previous buyer of 

similar item(s) in the Email. 
 

Once you have designed your template, and Auction X2 comes with a 
sample template to help you then press OK and move on to the next 
feature in the Marketing Menu which is View Pending Emails. 
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View Pending Emails is where Auction X2 lists for you all the matches 
it has found between items previous buyers bought from you and 

similar items you currently have for sale. 
 

When you start the View Pending Emails option you are presented 
with the following screen as shown below. 
 

 
 
Fig 3.2 Managing your pending Emails 

 
 

 

Pending Emails shows you a list of Emails it can send for you to 

previous buyers.  The details shown in the list are for items you 
currently have for sale that are similar to items previous buyers have 

bought from you. 
 
A match is only found if a valid buyers Email address is present for 

previously sold items.  If you use Auction X2 with ebay’s Selling 
Manager then Auction X2 will import buyer’s Email addresses for you 

automatically. 
 
If you are using the basic ebay pages you can still use Automatic 

Marketing in Auction X2 but you must provide buyer’s emails against 
sold items by double clicking on a sold item in the main screen of 

Auction X2 and entering the buyer’s Email address where indicated. 
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A number of buttons are provided in the View Pending Emails screen 
these are: 

 
• Refresh – imports selling item information and looks for new 

matches. 
 
• Preview – allows you to click on any item in the list and 

preview how the Email will appear going to the previous buyer 
as shown below 

 

 
 
Fig 3.3 Previewing a pending Email 
 

 
• Send – to send any Emails click on the check box to the far 

left of each item to indicate you want to send that Email.  

When you have selected one or more Emails press send and 

Auction X2 will then send Emails to your previous buyers. 
 
• Remove – allows you to click on any item in the list and 

remove it preventing it from ever being sent as an Email. 
 

• Close – closes the Pending Emails screen. 
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Searching For Items 
 

 
 

 
Searching for a previously imported item couldn’t be easier using 
Auction X2. 

 
You will see two tabs near the bottom of the main window you can 

click on these to switch between your sold items and unsold items. 
 
Search criteria is applied to the items in the currently selected tab. 

 
You can search for an item in three different ways by typing search 

information in the search box at the bottom of the main window: 
 

Ø  Use an ebay item number 

 
Ø  Use part of an item description or full item description  

     e.g. comp or computer 
 

Ø  Use part of a category name or full category name  

     e.g. collect or collectables 
 

 
After typing in your search criteria press the search button or hit the 
enter key and the available data will be quickly filtered to match your 

search criteria. 
 

By combining your search criteria with the filter options of Month and 
Year you are able to quickly locate the item or items you need. 
 

 
_______________________________________________________________ 

Note Many of the reports in Auction X2 are filtered by the filter options and 

search criteria you select.  This provides you with the powerful ability to 

extensively interrogate your sales. 
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Filtering Items 
 

 

 

 

Further filtering your list of items within Auction X2 can be done 

using search criteria that you type into the search box. Additionally 
you can further refine the filtering by the month and year you are 
interested in examining. 

 
The month and year filter boxes can be found in the bottom left hand 

part of the main window. 
 
The month drop down box provides you with any given month but in 
addition at the top of the list you can select ‘All’ which will filter all 

data for the currently selected year. 
 
The year drop down box allows you to filter your sold and unsold 

items by year. 
 

All of the search criteria and filter options can be combined to 
provide a very powerful tool to view your sales. 
 

 
_______________________________________________________________ 

Note When you close Auction X2 all of your filter settings and any 

configured options will be saved. 
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Exporting Sales To Excel (CSV) 
 

 

 

 

 

Auction X2 allows you to export (Save a file) in Excel Comma 

Separated Format (CSV) of all of your currently filtered sales data. 
 
 

To export your currently selected sales 
 

1. From the Auction X2 main window click on the File menu. 
 

2. Select the Export menu and then click on the Export sales to CSV 

menu option. 
 

3. A file save as dialog window will now appear asking you to name 
the export file and prompting for a location to save the file to. 

 
4. Once the file has been exported you can then open it with 

applications such as Microsoft’s Excel. 

 
 

_______________________________________________________________ 

Note To obtain the best results from exporting your data please ensure you 

have imported your ebay invoices, which informs Auction X2 of all of your 

fees for your sold and unsold items. 
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Backing Up Your Data 
 

 

 

 

It is important to periodically back up or save copies of your Auction 

X2 data.  Over time you build up a valuable view of your business, 
which it is important to retain in the event that your computer fails 
for some unforeseen reason. 

 
To create a back up of your Auction X2 database 

 

1. From the Auction X2 main window click on the File menu. 

 
2. Click on the Backup Database menu item. 

 

3. A file save as dialog window will now appear prompting for a 
location to save the file to.  Your backup file is automatically 

named for you using the current date time. 
 

4. Once the file has been backed up you can then restore it back 
into Auction X2 using the Restore Database menu item. 
 

 
_______________________________________________________________ 

Note It is recommended that you save your back up file in a separate 

location for example copy it to a different directory on your PC or better still 

copy it to a CD. 
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Restoring Your Backup Data 
 

 

 

 

 

If you need to restore a previous backup of your Auction X2 data it is 

important to realise that a restore “Will Overwrite All” of the 
information currently present in Auction X2. 
 

 
To restore a back up of your Auction X2 database 

 
1. From the Auction X2 main window click on the File menu. 

 

2. Click on the Restore Database menu item. 
 

3. Auction X2 will prompt you to ensure you want to carry out the 
operation. 

 
4. If you click yes a file open dialog window will now appear 

prompting for a location of a back up file that you would like to 

restore. 
 

5. Open the back up file and your back up will be restored to Auction 
X2. 
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Printing Your Sales Data 
 

 

 

 

 

Auction X2 allows you to print your currently filtered sold items.  To 

do this 
 
 

1. From the Auction X2 main window click on the File menu. 
 

2. Click on the Print menu item. 
 

3. The Windows Print dialog will appear prompting you to choose a 

printer. 
 

4. Press the print button to print out all of your currently filtered 
sales information. 
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Compacting Your Database 
 

 

 

 

 

Auction X2 provides the facility to compact its database each time 

you close the application.  It is useful to do this periodically to ensure 
your database is running as efficiently as possible. 
 

 
To compact your database on exiting 

 
1. From the Auction X2 main window click on the File menu. 

 

2. Click on the Exit & Compact Database menu item. 
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The Auction X2 User Interface 
 

 

In the previous sections we have already discussed some of the 

features found in the main Auction X2 user interface.  This is the 

main window you see when you launch Auction X2.  So far we have 
described the import and export, searching and filtering functions 

that let you import your sales data from ebay and then start to filter 
and search through it. 

 
This section will go on to discuss the other additional features of the 

Auction X2 user interface.  Firstly, lets take a further look at the 
main window and annotate the functions so you can see what is 
available at a glance. 

 

 
 
Fig 4.1 The main Auction X2 window 

 

 
Additional features & information available from the main window of 
Auction X2 excluding the menu options are listed below. 

 
1st column key 

 
Ø  How an item was paid for 
 

  Buyer paid using PayPal 
 

  Buyer paid with cheque, postal order or cash 



________________________________________________________________________ 

 Page 34 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

 

  Buyer has not yet paid for the item 
 

 
The filter drop down boxes of Month and Year with Month containing 

an ‘All’ option at the top of the list. 
 
Ø  The Search box allowing you to enter further search criteria. 

 
Ø  The Import Progress Bar and Cancel button, which allows you to 

cancel any imports that are in progress. 
 

Ø  You can click on any column in the view to change the order in 

which it is sorted for example in Fig 3.1 above the sale price has 
been clicked on to list the items in descending order of sale price.  

It could be clicked on again to reverse the order. 
 

Ø  You can right click on any item or multi selected items which will 

open the following menu 
 

 
 
Fig 4.2 The shortcut menu 

 

 
By clicking on Enter Purchase Cost… the following dialog is 

displayed 
 

 
 
Fig 4.3 Enter Item(s) Purchase Price Dialog 

 
 

You can now enter a purchase price for the currently selected 
item(s) and press the Apply button to save the price. 
 



________________________________________________________________________ 

 Page 35 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

By clicking on Enter Location Bought… the following dialog is 
displayed 

 

 
 
Fig 4.4 Enter Item(s) Location Bought From Dialog 

 
 

You can now select the location bought from for the currently 
selected item(s) and press the Apply button to save the location. 
 

 
_______________________________________________________________ 

Note The location bought from dialog will need you to configure your 

buying locations.  Please refer to the section on Managing Locations and 

Overheads. 
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Ø  You can double left click on any item which will open the following 
detailed item dialog 

 

 
 
Fig 4.5 Update Item Dialog 

 
All of your fees can be imported into Auction X2, however you still 
have the option to change these if required through the Update Item 
Dialog shown in Fig 3.5 above. 

 
This dialog provides you with the following 

 
Ø  A link to take you straight to your item on ebay’s web site. 
 

Ø  The date your item sold or if an unsold item the date the item’s 
listing ended. 
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Ø  A link to allow you to contact the buyer directly in ebay. 
 

Ø  The Buyer’s email, if you are an ebay Selling Manager user this 
will be imported automatically for you. 

 
Ø  The ebay category that your item was in. 

 

Ø  The item description. 
 

Ø  A drop down box allowing you to record the location you bought 
your item from. 

 

Ø  The purchase price. 
 

Ø  The sale price. 
 

Ø  The Postage Cost i.e. what it cost to send. 

 
Ø  The Postage Charged i.e. what you charged on ebay to post. 

 
Ø  The PayPal fees if any. 

 
Ø  The total ebay fees for this item. 

 

Ø  The total profit you have made on the item. 
 

Ø  The postal service you shipped the item with. 
 

Ø  The delivery service used. 

 
Ø  Any tracking number issued. 
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Managing Locations 
 

 

 

 

Auction X2 allows you to manage a list of all of the locations or 

sources you purchase your items from.  This information is then used 
for the reports provided by Auction X2 for example the Profit By 
Location Bought report, which tells you which locations you have 

bought items from are the most profitable. 
 

You are also able to manage the types of locations and Auction X2 

has some types built in for you already.  These are 

 
Ø  Market 
 

Ø  Car Boot Sale 
 

Ø  Auction 
 

Ø  Antique Fair 

 
Ø  House Clearance 

 
Ø  Internet 

 

 
You may of course want to remove some of these types or indeed 

add to the list your own types.  To manage locations two menu items 
are available in the Edit menu of Auction X2 these are 
 

Ø  Locations 
 

Ø  Location Types 
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Choose the “Location Types” menu option in the Edit menu and a sub 
menu will appear with two options 

 
Ø  Add New Location Type… 

 
Ø  Edit Location Type… 

 

 
Click on the “Add New Location Type” menu item and the following 

dialog is shown 
 

 
 
Fig 5.1 Add New Location Type Dialog 

 

 
Type in the new location type you want to create for example “High 
Street Shop” and click on the Add button.  The new type will be 

created and available for selection as a location type elsewhere in 
Auction X2. 
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To change a location type choose “Location Types“ from the Edit 
Menu and select “Edit Location Type”. 

 
The following dialog is shown 

 

 
 
Fig 5.2 Edit Location Type Dialog 

 
 
Select an existing location type by choosing it from the drop down 
box and then editing.  Once you have finished making your changes 
press the Update button to save them. 

 
From this dialog you are also able to select a location type and then 

delete it by pressing the Delete button. 
 
Now that you have created your location types you are able to add 

and edit some actual locations. 
 
_______________________________________________________________ 

Warning: If you choose to Delete a “Location Type” it will permanently 

remove “location type” association (link) to any item(s) using it in the 

Auction X2 database. 
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Choose the “Locations” menu option from the Edit menu and a sub 
menu will appear with two options 

 
Ø  Add New Location 

Ø  Edit Location 
 
Click on the Edit menu and choose the “Location” menu option and 

select “Add New Location”. 
 

The following dialog is shown 
 

 
 
Fig 5.3 Add New Location Dialog 

 

 
To create a new location, type in a location name and then select a 
location type from the drop down list.  Press the Add button and your 

location is created ready to be used elsewhere in Auction X2. 
 

e.g.  
Location Name: The Red Lion Pub 

Locations Type: Car Boot 
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To edit a location choose “Locations” from the Edit Menu and select 
the “Edit Location” menu item. 

 
The following dialog is shown 

 

 
 
Fig 5.4 Edit Location Dialog 

 
 
You can select an existing location by choosing it from the location 
name drop down box and then editing.  You may also choose a 
different location type for your location if needed.  Once you have 

finished making your changes press the Update button to save them. 
 

From this dialog you are also able to select a location and then delete 
it by pressing the Delete button. 
 

 
 
_______________________________________________________________ 

Warning: If you choose to Delete a “Location” it will permanently remove 

“location” association (link) to any item(s) using it in the Auction X2 

database. 
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Managing Overheads 
 

 

 

 

 

Auction X2 allows you to manage all of the overheads or additional 

costs you incur outside of your ebay and PayPal fees, which you have 
previously imported into Auction X2.  This information is then used 
for the reports provided by Auction X2 for example the Annual 

Overheads and the Annual Profits Graphs. 
 

You are also able to manage the types of overheads and Auction X2 
has some types built in for you already.  These are 

 

Ø  Postage 
 

Ø  Software 
 

Ø  Refunds 
 

Ø  Repairs 

 
Ø  Packaging 

 
Ø  Internet 

 

 
 

You may of course want to change some of these types or indeed 
add to the list your own types.  To manage overheads two options 
are available from the Edit Menu of Auction X2.  

 
Ø  Overheads 

 
Ø  Overhead Types 

 

 
Choose “Overhead Types” from the Edit Menu and a sub menu will 

appear with two options. 
 
Ø  Add New Overhead Type… 

 
Ø  Edit Overhead Type… 
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Click on the “Add New Overhead Type” option and the following 
dialog is shown 

 

 
 
Fig 6.1 Add New Overhead Type Dialog 

 
 
Type in the new overhead type you want to create for example 
Shipping Labels and click on the Add button.  The new type will be 

created and available for selection as an overhead type elsewhere in 
Auction X2. 
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To change an overhead type choose the “Overhead Types” menu 
option and select “Edit Overhead Type” 

 
The following dialog is shown 

 

 
 
Fig 6.2 Edit Overhead Type Dialog 

 
 
Edit an existing overhead type by choosing it from the drop down 
list.  Once you have finished making your changes press the Update 
button to save them. 

 
From this dialog you are also able to select an overhead type and 

delete it by pressing the Delete button. 
 
 
_______________________________________________________________ 

Note: Now that you have created your overhead types you are able to add 

and edit some actual item overheads. 

 

Warning: If you choose to Delete an “Overhead Type” it will permanently 

remove the “Overhead Type” association (link) using it in the Auction X2 

database. 
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Choose the “Overheads” menu option from the Edit Menu and a sub 
menu will appear with two options 

 
Ø  Add New Overhead 

Ø  Edit Overhead 
 
The following dialog is shown 

 

 
 
Fig 6.3 Add New Overhead Dialog 

 

 
To create a new overhead select an overhead type from the drop 

down box and then key in the amount of the overhead.  Finally using 
the date picker, which is opened by clicking on the Date Paid drop 
down you can select a date that the overhead was incurred.  

 
Press the Add button and your overhead is created ready to be 

reported on in Auction X2. 
 
e.g.  

 
Overhead Type: Software 

Over Cost: 24.95 



________________________________________________________________________ 

 Page 47 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

To edit an overhead choose the “Overheads” menu option from the 
Main Menu and select “Edit Overhead”. 

 
The following dialog is shown 

 

 
 
Fig 6.4 Edit Overhead Dialog 

 

 
Edit an existing overhead by clicking on it in the overhead list shown 

above in Fig 5.4.  Doing this will take you to the Edit Overhead 
Dialog and allow you to alter the overhead type, the overhead 

amount or cost and the date the overhead was incurred. 
 
Once you have finished making your changes press the Update 

button to save them. 
 

From this dialog you are also able to select an overhead by clicking 
on it in the list and then delete it by pressing the Delete button. 
______________________________________________________________ 

Note Overheads have date(s) they were incurred; the data shown in the 

dialogs above will be filtered by your currently selected Month and Year in 

Auction X2. 

 

Warning: If you choose to Delete an “Overhead” it will permanently 

remove the “Overheads” association (link) using it in the Auction X2 

database. 
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Options 
 

 

 

 
To configure the options within Auction X2 choose “Options” from the 
Edit Menu. 

 
The following options are available. 
 

Ø  Are you a PayPal member? 
 

Ø  Do you want to record itemised postage information in Auction 
X2. 

 

Ø  Your ebay Username. 
 

 

The options dialog appears as below in Fig 6.1 
 

 
 
Fig 7.1 Options Dialog 
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The PayPal member option allows you to import PayPal status 
updates on whether your items are paid or not using PayPal and also 

allows PayPal fees to be calculated where applicable. 
 

Recording itemised postage fees if set to Yes will allow you to record 
individual item postage costs.  If set to No you should use the add 
new overhead menu item to enter postage costs. 

 
Supplying your ebay username simply allows Auction X2 to take you 

through the Import windows more rapidly. 
 
ebay Selling Manager User informs Auction X2 whether to import 

data from the basic ebay pages or from the ebay Selling Manager 
pages.  Uses ebay Selling Manager has the benefit of allowing you to 

automatically capture buyer’s email addresses.  These are vital for 
Auction X2’s Automatic Marketing feature which sends email to your 
previous buyers. 

 
SMTP E-Mail Server allows you to specify the smtp address of your 

mail server for outgoing emails.  This is needed for Auction X2’s 
Automatic Marketing feature. 

 
Email Address is your email address and again this is used by 
Auction X2’s Automatic Marketing feature. 

 
The Locale allows you to set Auction X2 up for either ebay.co.uk 

where pound sterling fees will be used or ebay.com where dollar fees 
will be used. 

 
_______________________________________________________________ 

Note Any information you supply to Auction X2 is entirely private and only 

ever retained locally on your PC for your own personal use. 
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Other Menu Items 
 

 
 

 
From the “Edit Menu” the following Items are also available. 

 
Ø  “Select All” – selects all items currently listed (displayed) in the 

Auction X2 Main Window. 
 
Ø  “Delete Item(s)” – will delete any items selected in the main 

Auction X2 window.  You will be prompted that you are sure you 
want to delete before proceeding. This will “Permanently” delete 

the selected item(s) from Auction X2. 
 

 

From the “View Menu” the following menu items are available. 
 

Ø  The “View Item Description” dialog displays the ebay description 
you used for the sale of the selected item, which includes any 

formatting characters (HTML).  This can prove useful if you are 
re-listing a similar item and want to copy and paste an existing 
description into your new listing. This menu item applies to any 

“one” currently selected item in the main Auction X2 window. 
 

 
 
Fig 8.1 View Item Description 



________________________________________________________________________ 

 Page 51 
  

Copyright © 2005 – 2007, BDS Computer Systems. All Rights Reserved 

 
Ø  Highlight Rows – provides alternating coloured banding across the 

main Auction X2 window.  This is useful if you are reading all the 
way across an item.  The highlighted view appears as shown 

below 
 

 
 
Fig 8.2 Highlighted Auction X2 main window 

 
 
Ø  Toggle Grid Lines – this menu item allows the grid lines in the 

main Auction X2 window to be switched on or off. 

 
Ø  Refresh – this menu item manually updates the data in the main 

Auction X2 window. 
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Reporting 
 

 

 

Auction X2 provides an extensive range of reports that allow you to 

examine your sales data from many different angles and provide you 
with the business information you need to improve your sales. For 
example: 

 
Q. What is the best day of the week for me to end listed items to 

maximise profit? 
 

Q. What is the best time of the day for me to end listed items to 
maximise profit? 
 

Q. Who are my returning buyers and what types of item are they 
interested in? 

 
Q. What are my most profitable types of sales i.e. what categories 
should I focus on more? 

 
Q. How many pictures do I need to buy from ebay when listing items 

to maximise my profit? 
 
These are just a small selection of the business questions to which 

Auction X2 provides you with answers.  The following selection takes 
you through all of the reports available and explains the business 

information that each report provides. 
 

 
_______________________________________________________________ 

Note Many of the reports in Auction X2 can be filtered by month, year and 

search criteria allowing you to expertly ‘drill’ into your data. 
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Profit Cost Analysis 
 

The Profit Cost Analysis report can be displayed as either a Bar Chart 
or Pie Chart and you will be prompted to select which format you 
would like to use and also to save this selection as a preference if 

required. 
 

 
 
Fig 9.1 Report Style Selection Dialog 
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As a pie chart the Profit Cost Analysis Report will appear as 
something similar to below 

 

 
 
Fig 9.2 Profit Cost Pie Chart 

 
 

The chart provides a visual break down of turnover i.e. how much 
money have you received in total, expenditure i.e. what you have 

spent in acquiring or manufacturing items, overheads i.e. additional 
expense you have incurred which includes all of your ebay and 
PayPal fees, any ebay refunds and finally your total profit! 

 

 

Note: This report can be filtered by month and year.  To show a complete 

year’s analysis select ‘All’ as the month and then the year you are 

interested in seeing. 
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Alternatively you can view the same report as a bar chart as shown 
below 

 

 
 
Fig 9.3 Profit Cost Bar Chart 
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Overheads Analysis 
 

 

The Overheads Analysis report can be displayed as either a Bar Chart 
or Pie Chart and you will be prompted to select which format you 
would like to use and also to save this selection as a preference if 

required. 
 

The Pie Chart appears as shown below 
 

 
 
Fig 10.1 Overheads Analysis Pie Chart 

 

The Overheads Analysis chart provides a visual guide to the amount 

of expenditure incurred for all types of ebay and PayPal fees.  The 
chart also includes any further overheads you may have entered 
through Add Overheads; in Fig 9.1 above an example of “Internet 

Overheads” for November 2005 can be seen of 39.99. 
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The Overheads Analysis chart can also be seen as a bar chart as 

shown below. 
 

 
 
Fig 10.2 Overheads Analysis Bar Chart 

 

 

 
_______________________________________________________________ 

Note PayPal fees in Auction X2 are accurately “estimated” but can be 

manually adjusted through the Update Item Dialog.  In the current release 

Auction X2 does not take currency conversion of PayPal fees into account. 
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Annual Profit Graph 
 

 

 

 

 

The Annual Profit Graph provides a bar chart view for the total profit 

you have made for the currently filtered year displayed by month i.e. 
January through to December.  The chart appears as shown below 

 

 
 
Fig 11.1 Annual Profit Graph 
 

 

 

From the chart above it can be seen that no profit was earned for 

January and February 2007 and we are yet to make any sales June. 
 
This report is useful in that it provides you with a very quick 

overview of how well your business is performing month on month 
and also highlights any seasonal effects. 
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Annual Overheads Graph 
 

 

 

 

 

 

The Annual Overheads Graph provides a bar chart view for the total 

overheads you have incurred for the currently filtered year displayed 
by month i.e. January through to December.  The chart appears as 

shown below 
 

 

 

Fig 12.1 Annual Overheads Graph 
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Returning Buyers Report 
 

 

 

 

 

The Returning Buyers Report allows you to see quickly which of your 
buyers have made repeat purchases from you and what those 

purchases were.  The buyer with the highest number of repeat 
purchases appears at the top of the report and the repeat buyer with 

the lowest number of repeat buys at the bottom. 
 
The Returning Buyers Report can be filtered by both month and year 

and appears as shown below. 
 

 

 
 

Fig 13.1 Returning Buyers Report 
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Profit By Location Report 
 

 

 

 

The Profit By Location Report allows you to see quickly which of your 

location that you buy items from have gone on to sell and make you 
the most profit.  The location with the highest profit appears at the 

top of the report and the location with the lowest profit at the 
bottom. 

 
The Profit By Location Report can be filtered by both month and 
year. 

 
 

 

 

Fig 14.1 Profit By Location Report  
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Profit By Category Report 
 

 

 

 

The Profit By Category Report allows you to see quickly which 

category of sales have made the most profit for you.  The category 
with the highest profit appears at the top of the report and the 

category with the lowest profit at the bottom. 
 

The Profit By Category Report can be filtered by both month and year 
and appears as shown below. 
 

 
 
Fig 15.1 Profit By Category Report 
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Profit By Hour Of Listing Report 
 

 

The Profit By Hour Of Listing Report allows you to see quickly which 
hour of listing in any given day is the most profitable for you taking 
into account the number of items sold in that hour. 

 
The first column of the report is the hour listing ended starting at 

00:00:00 which represents midnight and moving down all the way to 
23:00:00.  The second column shows the number of items sold in 
each hour and the third the total profit for each hour listing ends. 

 
The Profit By Hour Of Listing Report can be filtered by both month 

and year and appears as shown below. 
 
Based on the report (below), our sample data highlighted that no 

sales occurred during the early hours of the day. 
 

 
 
Fig 16.1 Profit By Hour Of Listing Report 
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Profit By Day Of Listing Report 
 

 

 

 

The Profit By Day Of Listing Report allows you to see quickly which 

day of listings ending in any given week is the most profitable for 
you taking into account the number of items sold using that day of 

listings ending. 
 

The first column of the report is the day listed starting at Monday 
and moving down to Sunday.  The second column shows the number 
of items sold in each day and the third the total profit for each day 

listing ends. 
 

The Profit By Day Of Listing Report can be filtered by both month and 
year and appears as shown below. 
 

 

 
 
Fig 17.1 Profit By Day Of Listing Report 
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Profit By Pictures Bought Report 
 

 

 

 

The Profit By Pictures Bought Report allows you to see quickly how 

many pictures you need to buy from ebay when listing your items.  
This report can help save you money by ensuring you don’t buy too 

many pictures needlessly. 
 

The first column of the report shows the number of pictures you have 
bought per item.  The second column shows the number of items 
sold for each volume of pictures bought and the third the total profit 

for each volume of pictures bought. 
 

The Profit By Pictures Bought Report can be filtered by both month 
and year and appears as shown below. 
 

 

 
 
Fig 18.1 Profit By Pictures Bought Report 
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Ten Most Profitable Items Report 
 

 

 

 

 

 

 

 

The Ten Most Profitable Items Report simply lists your top ten sales 

by profit and can be filtered by month and year.  The report appears 
as shown below 

 

 
 
Fig 19.1 Top Ten Sales Report 
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Bottom Ten Sales Report 
 

 

 

 

The Ten Least Profitable Items Report simply lists your bottom ten 

sales by profit and can be filtered by month and year.  The report 
appears as shown below. 

 
 

 
 

 
 
Fig 20.1 Bottom Ten Sales Report 
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In Summary 
 

 

 

 

 

 

Auction X2 provides you as a seller with a quick and easy way to 

produce management information reports. 
 
The Auction X2 reports will allow you to analyse your business efforts 

thoroughly and tell you what works well and what perhaps isn’t 
working quite so well. 

 
Auction X2 allows you to focus your efforts and to work out exactly 
how much profit you are really making! 

 
Using Automatic Marketing we hope you will find Auction X2 a 

powerful tool in helping you to maximise your profits through ebay. 
 

We trust you will enjoy using Auction X2 as much as we have 
enjoyed developing it. 
 

 
Sincerely, 

 
The Auction X2 Team. 
 

 


