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Welcome to PagePlus 8 PDF Edition!

    Welcome to PagePlus 8.0 PDF Edition from Serif: the latest in the best-selling, award-winning 
PagePlus line—still the easiest way to get professional desktop publishing results—now supporting PDF publishing capabilities 
for universal document distribution. For a brief illustrated overview of PagePlus features, be sure to check out the Introducing 
PagePlus 8 QuickTour. For help on specific new features, click the links in the list below.

If you've used PagePlus in the past, you know that PagePlus does it all—from glossy corporate marketing materials (including 
full-color printing from color separations) to "fun stuff" like party invites, ads, brochures, business stationery, cards, letterheads, 
compliments slips, invoices, flyers, forms, newsletters, notices, handouts, event programs, posters, price lists, reports, 
announcements, greeting cards, and much more. And of course, Web sites, too! With your PC, printer, and PagePlus, you can 
save time and money—no experience required.

This new edition of PagePlus includes an unprecedented number of new features! If you've upgraded, we hope you enjoy the 
additional power and performance edge. And if you're new to the product, we hope you'll find it's got everything you need. Either 
way, the Resource CD-ROM has something special for you. Choose Tutorials... from the Help menu to access a guide to new 
features (geared for returning users) and an in-depth, hands-on learning sequence created especially for beginners.

As always, if you have comments or suggestions—or samples of the work you create with PagePlus—we'd like to hear from you. 
For complete contact information, see the Support topic. 

And don't forget to register your new copy, using the Serif Registration Wizard. That way, we can keep you apprised of new 
developments and future upgrades. 

What's New in PagePlus 8 PDF Edition...
n Introducing (Drum Roll)... PDF!

PDF (Portable Document Format) export is now just a few clicks away. Step up to the worldwide standard for cross-platform, 
WYSIWYG electronic information delivery. Your PDF output will look just like your PagePlus publication... in one compact 
package, easily printable or viewable in a Web browser. 

n Create Hyperlinks in Paper Publishing Mode
You don’t have to switch to Web Publishing mode to incorporate hyperlinks in your paper-based PDF output. Simply insert the 
links in your publication! They’ll appear in the PDF to connect readers to document pages, Web pages, e-mail feedback, or 
external files. Use hyperlinks to create a linked table of contents... or to connect one PDF file to another.

n Bookmarks for User Convenience
PDF bookmarks can point to pages or to specific text- or object-level locations in your document. Use the new Bookmark 
Manager to compile a link list that appears in a separate pane alongside PDF content... a handy navigation aid for your 
readers!

n Font Embedding
To ensure that your readers get precisely the typographic effects you intended, you can incorporate the fonts you’ve used in 
the single-file PDF package. 

n Expanded PageHint Capabilities
No longer just "sticky notes" to yourself, PageHints now afford a range of annotation options for PDF files. More icons to 
choose from... Titling and date-stamping... Work with multiple open notes at the same time. Fully supported by the Adobe 
Acrobat Reader (included free with PagePlus PDF Edition)!

What's New in PagePlus 8...
n Artistic Text Tool

An entirely new text tool to complement traditional text in frames. Just click and type anywhere on the page, format with the 
customary tools, then apply colorful lines and fills directly at the character level. Scale it, rotate it, flip it... discover a host of 
new possibilities!

n Table Tool with Editable Calendars
Now you can create and edit tables right in your publication, with no need for a separate utility. Choose from a range of preset 
formats or design your own by customizing lines, cells, rows, and columns. Powerful text manipulation features include 
AutoClear, AutoFill, and cell merge. And calendars are now table-based for enhanced functionality!

n Multipage View
A brand-new working mode option that lets you see an array of pages, not just one at a time. Easily manipulate the view 
dimensions, drag objects from one page to another, and get the "big picture" of your publication's layout.

n Multiple Master Pages
For complex documents requiring distinct treatments for body pages, chapter pages, picture spreads, and the like—you can 
now design as many separate background templates as you need. Break through the single-background barrier!

n Enhanced Studio Bar with Page Manager
More convenient and powerful than ever, the Studio's tabs can now be floated, redocked, shown or hidden individually. It's 



easier to select gallery categories, assign text, line, and fill colors, and vary shading. Plus the all-new Pages tab provides a 
graphical overview that lets you drag and drop to add or subtract pages and assign master pages, with instant access to the 
Page Manager for total control over page content.

n Bitmap Fills and Transparencies
Choose from a multi-faceted Studio gallery of picture-based effects, ready to work their magic on shapes or artistic text. You 
can even import your own images as Bitmap fills. Get set for fun with Photo Edge Effects and a host of other Bitmap 
transparencies!

n Curved Line Tool and Freehand Shapes
QuickShapes are still superb, but now you can "have it all"... Just choose a line tool (including a new one specifically for 
curves), draw a line... connect other segments if you wish... then just connect the end points to create any shape you like! 
Customize the line and fill, apply transparency, even freely edit the outline.

n Precise Editing of Lines, Shapes, Wrap and Crop Outlines
Try the new Curve Toolbar to fine-tune the contours of any line, closed shape, text wrap boundary or cropping edge. Simply 
drag the curve's segments or edit its Bézier nodes to achieve exactly the result you want.

n Striking Shadow, Glow, and Bevel Effects
One dialog serves as your "creation station," where you can select and preview a spectacular range of special effects for text 
or any object. Choose from soft-edged transparent Drop Shadow, Inner Shadow, Inner Glow, or Outer Glow, plus four Bevel 
and Emboss effects!

n Replicate Tool
Instantly multiply any object into a line or grid arrangement, with pinpoint control over offset and spacing.. Ideal for perfectly 
aligned montages! Add rotation, skew, or resizing for eye-catching transformations.

n Borders
Here's an elegant new way to add picture frames to your imported pictures and shape art... even frame a text frame! Simply 
pick from the preset choices, then customize corner style.

n Enhanced Web Page Creation
PagePlus 8.0 adds new power to its unparalleled ease-of-use in designing Web sites! Add your own responsive buttons with 
the multi-layered Rollover graphics option. Select from expanded format and compression choices for picture export. Insert 
header as well as body HTML code, optimize overlapping objects, and optionally maintain original image filenames.

n Improved Text Handling
Behind the scenes, our text engine works faster and better than ever—with secondary font caching, better handling of default 
text styles, and automatic removal of blank fields in MailMerge output.    We've added vertical alignment options for frame, 
table, and artistic text, and now you can add or remove words from your personal spell-check dictionary.

n More Amazing Image Manipulation
Import images inline as part of frame text flow, and create your own 32-bit anti-aliased TIFFs and PNGs. Convert to Picture 
allows instant, in-place format changes! There's more control over imported metafiles and OLE options, and TIFFs retain 
CMYK color data for full color separation. Linked images are easier to maintain... and each export filter now remembers its 
own settings.

n More Powerful Printing
If you're serious about printing, you'll appreciate solid features like more efficient transparency output, with bitmap stripping if 
your printer driver needs an assist. Improved image spooling, more imposition controls, and new color bars and registration 
marks for professional job requirements.

n Our Interface... An Old Friend, Now Even Friendlier
Now you can drag and drop objects into PagePlus from other applications. AutoScroll automatically adjusts your view as you 
move or resize. The revised ChangeBar features context sensitivity and popup sliders to save screen space. Better window 
control so you can work on the same page at two zoom levels. It's details like these that have made the difference in 
PagePlus' engineering, version after version!

...plus all the powerful PagePlus features you've come to expect!
DTP revolutionized the graphics arts industry, and PagePlus revolutionized the DTP market—with high-impact design available 
to everyone. Features such as...

n Integrated Wizard Technology for "Smart Documents"
With the optional PagePlus 8 PDF Edition Resource CD, just pick the type of publication you want to produce and answer a 
few simple questions. PagePlus does the rest! Revisit your color scheme and text selections at any time as you continue to 
work with a publication. Basic user details are stored for automatic reuse.

n Versatile Setup with Auto-Imposition
Just click to specify layouts for greeting cards, business cards, folded brochures, and more. You see your publications the right 
way up on-screen—and let PagePlus take care of orienting and ordering the printed output for correctly assembled masters!

n Intelligent Color Schemes
Choose from dozens of preset color schemes to change the overall appearance of your Page Wizard publications with a 
single click. You can customize the scheme colors, create brand new schemes, and apply any scheme to a "from-scratch" 
publication.

n Web Publishing Mode
Create your own Web site using Web Page Wizards. Or convert an existing PagePlus publication to a Web site! The Layout 
Checker helps you fine-tune your design. Add animated GIFs, marquee effects, sound, and video—even Java and HTML code
—to spice up your pages! Preview your site in a Web browser and publish it to a local folder or a remote server using HTML 



4.0. 

n On-screen Studio Combines Convenience with Functionality
The Studio's tabs provide rapid drag-and-drop access to commonly-used controls such as fonts, line settings, and the color 
table. Use the Portfolio to store your favorite designs for use in any publication... and tap the Gallery, with built-in mastheads, 
logos, and lots of other page elements you can customize to suit your needs! 

n Professional Layout Tools
Intelligent text fitting. Movable rulers and guides. Precision placement, rotation, and text wrap. Flip, crop, watermark, and 
recolor graphics. Text formatting with bullets, lists, kerning, hyphenation, drop caps, smart quotes, and named styles. Master 
pages, facing pages display, and much more! 

n Text Composition Tools
PagePlus includes word count, search and replace, spell-checking, thesaurus, and proof reader. Break out of the boring box 
with shaped text frames—variable molds to add impact to your text. And you get over 400 TrueType fonts that let you express 
yourself with flair! 

n QuickShapes 
Long an exclusive feature of other Serif solutions, QuickShapes work like intelligent clipart... or the most powerful set of 
drawing tools you can imagine. Just choose a template shape, drag on the page... then adjust handles to customize each 
angle and dimension. 

n Powerful Drawing Options
An arsenal of new drawing tools are at your command... Sketch freehand lines and curves. Extend existing lines with ease. 
Apply line styles to all kinds of shapes—even add line endings like arrowheads and diamonds. 

n Gradient Fills
For sophisticated illustrations and impressive typographic effects, select from a wide variety of Linear, Radial, and Conical fills. 
Use the interactive fill tool for drag-and-drop updating of fill nodes and colors.

n Transparency Effects
Both solid and variable transparency let you add new depth to your print and Web creations. Apply transparency directly from 
the Studio, then edit nodes and opacity with the interactive tool. 

n Versatile Text Shape and Flow
You can rotate or reshape text frames and still edit their text. Enhanced text wrap options and separate crop and wrap outlines 
mean you have greater control over where text flows and how it appears.

n Photo Optimizer
If your publication includes color or grayscale photographs, use the Photo Optimizer to get the best results for each photo on 
your particular printer. Pick the best result from the thumbnail sheet—and PagePlus remembers the optimum settings for that 
image!

n Index, Table of Contents, and Calendar Wizards
Compile a professional index complete with headings, subheadings and page references... especially useful for longer 
publications! Automatically collect newsletter headlines (or any styled text you specify) into a table of contents list! Choose 
from a wide variety of sizes and design options, then just click and drag to fit your calendar to a column or a whole page!

n Versatile Printing and Mail Merge
Impressive results on your dot-matrix, ink-jet, or laser printer in black and white or full color. Print your current publication 
multiple times, merging data from any character-delimited address list file.

n Professional Output
Use the high-end features of PagePlus to achieve the highest possible quality. Features the PANTONE® color library, color 
mapping of vector images, and full spot and process color separation with savable printer schemes.

n Total Ease-of-Use
Hideable, customizable toolbars for extra workspace area. Right-click menus. AutoCorrect and AutoSpell proofing options. 
Multiple Undo and Redo actions selectable from a handy list. Plus HintLine, Wizards, and context-sensitive cursors to make 
PagePlus as friendly as a puppy! 



Help on Help: A quick overview

The PagePlus online help system is designed to work for you.    For suggestions based on your specific needs, see the Where 
do I begin...? section below. Whatever your background, you'll find it easy to navigate through online help:

n To begin learning about PagePlus tools and menus, just move the mouse pointer around the screen. Watch the HintLine 
window at the lower right for capsule descriptions of each feature. 

n Choose PagePlus Help (or press F1) to display the help window, which initially displays its Contents panel on the left, and the 
Visual Reference menu on the right. Click directly on Visual Reference graphics to browse interface features like menus and 
toolbars. Click the book icons in the Contents list to expand topics, and click a document icon to display a particular topic.

n Click the Index tab to pop up the list of key terms, or the Search tab to look up specific terms using full-text search.

n Click the << (Previous) and >> (Next) buttons at the top of the help window to step through the topic sequence.

Where do I begin...?
...If you are new to PagePlus or to Desktop Publishing, we suggest you begin with the introductory QuickTour, followed by the 
PagePlus Companion's chapters on "Getting Started" and "Creating a Publication." The Resource CD-ROM includes a 
learning sequence (choose Tutorials... from the Help menu) to guide beginners step by step through PagePlus objects and 
basic procedures. For somewhat more advanced exercises emphasizing typographic techniques, try the "QuickRef Project" 
sequence in the Companion—culminating in a useful Desktop Publishing QuickRef document you can print out and keep handy.

...If you're the sort who likes to dive in and try things, chances are you've already used the Resource CD's Page Wizards and 
created a publication or two. By now, you probably know about all the context-sensitive help that's available in PagePlus: Tool 
Tips and the HintLine. But since we've got your attention, don't overlook the tutorials noted above—and may we suggest the 
Visual Reference (again in online help). There you'll find more detailed information on every aspect of the interface, with cross-
references to procedural (How To) help. If you like to learn by doing, it's a great place to learn by browsing.

...If you're upgrading from a previous edition of PagePlus, or have worked with another high-level DTP program, you'll want to 
get up to speed quickly with new features, and the Resource CD-ROM's Tutorial #1 is just for you! If you're more interested in 
knowing "What's a shortcut to adjust kerning?" or "How can I insert HTML framgments in Web Publishing mode?" If so, go 
directly to the Index or the sequence of How To topics listed in the Help Contents. For direction on new features, click the links 
from the special section on What's New in PagePlus 8 in the previous topic.



Troubleshooting and support

Troubleshooting a problem
Don't panic! Remember that all technical problems, no matter how bizarre they may seem, have a cause and a solution. By 
patiently applying a logical approach, you can often identify the source of the problem and fix it yourself. In general, try 
simplifying your PC's setup until the problem is no longer present. Then, incrementally restore the original setup, testing to see 
which component makes the problem recur. Be careful!

Initially, try to establish:

n Is the problem most likely arising within PagePlus? 

n Is it a Windows problem? 

n Or is it a "hardware" problem having to do with your PC or its peripherals? 

n Have you made any recent changes to your system configuration that might be responsible for the problem?

If it's a PagePlus issue, perhaps there's a procedure you need to know more about. Check online Help for information on the 
specific task you're trying to accomplish.

For Windows or hardware issues, click the Start button and choose Help for troubleshooting information—or check the specific 
manuals for the peripheral. 

Printing problems with Windows are generally caused by using an incorrect or outdated printer driver, or a third-party printer 
driver. Make sure that you use the Windows printer driver designed specifically for your printer. To check printer drivers, click 
Start, choose Settings > Printers.

Contacting Serif technical support
Our support mission is to provide fast, friendly technical advice and support from a team of on-call experts. Serif customers are 
entitled to free, unlimited phone support for the first 30 days following receipt of the product. After that time, pricing policies (per-
call or per-year) go into effect.

You can reach our main Web support page at http://www.serif.com/support.aspTechnical support is provided by telephone and e-
mail, as well as through FAQs and forums on our Web site (see below).

Europe Technical Support (0115) 914 9090

(0845) 345 6770          [Local rate, UK only]

e-mail: support@serif.co.uk

USA Technical Support (603) 886-6642

e-mail: support@serif.com

International Technical Support +44 (115) 914 9090

Please do not fax technical support queries.

Additional Serif contact information
World Wide Web:

Serif Web Site http://www.serif.com 

Support http://www.serif.com/support.asp

Frequently Asked Questions http://www.serif.com/faq.asp

Forums http://www.serif.com/forums.asp

Serif Newsgroups news://news.serif.com

Main office (UK, Europe): 

The Software Centre, PO Box 2000, Nottingham, NG11 7GW, UK

Main (0115) 914 2000

Registration (0800) 376 1989

Sales (0800) 376 7070

Customer Service (0115) 914 9090

(0845) 345 6770          [Local rate, UK only]

General Fax (0115) 914 2020

American office (US, Canada): 



The Software Center, 13 Hampshire Drive, Unit 12, Hudson NH 03051, USA

Main (603) 889-8650

Registration (800) 794-6876

Sales (800) 55-SERIF or 557-3743

Customer Service (800) 489-6720

General Fax (603) 889-1127

Sales Fax (603) 886-4919

International enquiries

Please contact our main or European office as appropriate.
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rights reserved.
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n The ThesDB Thesaurus Engine © 1993-97 Wintertree Software Inc.
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are the property of Pantone, Inc. © 2001 Pantone, Inc.

n Pantone, Inc. is the copyright owner of color data and software which are licensed to Serif (Europe) Ltd. to distribute with use 
only in combination with PagePlus. PANTONE Color Data and software shall not be copied onto another disk or into memory 
unless as part of the execution of PagePlus.

All Serif product names are trademarks of Serif (Europe) Ltd. Microsoft, Windows, and the Windows logo are registered 
trademarks of Microsoft Corporation. All other trademarks acknowledged.

Serif PagePlus 8.0 PDF Edition © 2002 Serif (Europe) Ltd.

Many thanks to our million PagePlus users for supporting us… We couldn't do it without you. 



File Menu
Commands for opening, saving, and printing publications 
Shortcut: Alt+F

New
Displays the Startup Wizard, which gives you four options: 
· Design a new publication using a Page Wizard
· Start a new publication from scratch
· Open a saved publication
· View a QuickTour 
(See the topic Starting a new publication.)
Tip: You can also use the New button on the Standard toolbar, or press 
Ctrl+N.

Open...
Displays a standard Windows dialog which allows you to open an existing 
PagePlus publication (*.PPP) or template (*.PPX) file. (See the topic Opening 
an existing publication.)
Tip: You can also use the Open button on the Standard toolbar, or press 
Ctrl+O.

Revert
Restores the saved version of the current publication, abandoning any unsaved 
changes.

Close
Closes the current publication. If it's still unsaved ("Untitled") or there are 
unsaved changes, you'll be prompted to save changes.

Save
Saves the current publication under its current name. If it's still unsaved 
("Untitled"), the Save As... dialog automatically appears. (See the topic Saving 
your publication.)
Tip: You can also use the Save button on the Standard toolbar, or press 
Ctrl+S.

Save As...
Displays a dialog prompting you to enter a directory and file name for the 
publication, then saves it under that name.

Export as Picture…
Creates (or exports) a graphic file version of either your whole page or the 
currently selected objects, using the format you specify. Useful for generating 
logos and pictures to be placed in another application. (See the topic Exporting 
as a picture.)

Properties...
Displays a dialog that lets you enter publication summary information (such as 
author and keywords) and view statistics (such as revision date and number of 
pages).

Web Site Properties...
(Web Publishing mode only) Displays a dialog that lets you view and edit 
various properties of your Web site. Click the Page tab to change the Web 
page file name and/or extension, and set an optional title or background sound. 
Click the Search tab to enter optional search engine descriptors and keywords. 
Click the Graphics tab to set global Web picture export options. 

Preview Site in Browser...
(Web Publishing mode only) Exports your entire publication as a temporary, 
local Web site, without saving it to disk, then opens the site for preview in your 
World Wide Web browser. (See the topic Previewing your Web site in a 
browser.)
Note: To save the site to disk, use Publish to Disk Folder....

Publish Site>
(Web Publishing mode only) Displays a submenu with the following choices:

· to Disk Folder...
Displays a dialog that lets you save your entire publication, or selected pages, 
to disk while exporting it as a Web site. You'll then have the option of 
previewing it in your browser. (See the topic Publishing a Web site to a local 
folder.)

· to Web...
Displays a dialog that lets you export your entire publication, or selected pages, 
as a site on the World Wide Web. (See the topic Publishing to the World Wide 
Web.)



Page Setup...
Displays a dialog for modifying the publication dimensions and format. (See the 
topic Setting publication dimensions.)
Note: To set page margins and row/column guides, choose Layout Guides.... 
To set page numbering, choose Page Number Format... from the Format 
menu.

Layout Guides...
Displays a dialog that lets you change the page margin and row/column guide 
settings. (See the topic Setting guides for page margins, rows, and columns.)
Shortcut: Right-click on a blank part of the page and choose Layout 
Guides....

Print...
Displays a dialog providing options for selecting which part of the publication 
file to print and how to print it. The Properties button displays a standard 
Windows printer setup dialog. Click the Layout tab to set options for special 
printing, multiple pages, tiling, and mail merge. Click the Separations tab to set 
options for spot and process color printing. Click the Prepress tab to set 
special printing options such as crop marks or file information. (See the topic 
Basic printing.)
Tip: You can also use the Print button on the Standard toolbar, or press 
Ctrl+P.

Print Preview
Changes the screen view to display the layout without frames, guides, rulers, 
and other screen items. Special options such as tiled output or crop marks are 
not displayed. (See the topic Previewing the printed page.)
Tip: You can also use the Print Preview button on the Standard toolbar.

Publish as PDF...
Displays a dialog that lets you set options and proceed to export the publication 
as a PDF file.

Export Text...
(WritePlus only) Displays a dialog that lets you save the current story as a 
WritePlus (.STT), formatted (.RTF), or unformatted (.TXT) text file. (See the 
topic Exporting story text.)

Send...
Opens a new message in your default e-mail program, with the current 
publication as an attachment.

Switch to Web Publishing...
(Paper Publishing mode only) Opens the current publication in Web Publishing 
mode.

Switch to Paper Publishing...
(Web Publishing mode only) Opens the current publication in Paper Publishing 
mode.

Recent Files List
Lists the names of the four most recently saved PagePlus files. Click a file 
name to open that file. 

Exit
Closes PagePlus. You'll be prompted to save changes made since the last 
save.



Edit Menu
Commands for Clipboard (cut & paste) and OLE 
Shortcut: Alt+E

Undo <action>
Undoes the most recent change to the current publication. Undo is grayed out 
when not available. To set the number of levels of Undo, pull down the Tools 
menu and choose Options/General. 
Tip: You can also use the Undo button on the Standard toolbar (which allows 
multiple undo's in a single action), or press Ctrl+Z.

Redo / Repeat <action>
If the last action was Undo, Redo reverses the effect of the undo. If the last 
action was a text action, Repeat performs the action again.
Tip: You can also use the Redo button on the Standard toolbar (which allows 
multiple redo's in a single action), or press Ctrl+Y.

Cut
Deletes the selected object(s) from the page or pasteboard AND places a copy 
on the Windows Clipboard. 
Tip: You can also use the Cut button on the Standard toolbar, or right-click on 
the object, or press Ctrl+X.

Copy
Copies the selected object(s) to the Windows Clipboard. 
Tip: You can also use the Copy button on the Standard toolbar or right-click on 
the object, or press Ctrl+C. To duplicate the object, press the Ctrl key after 
selecting it, then drag the copy to a new position.

Paste
Inserts the contents of the Windows Clipboard at the insertion point. Defaults to 
the PagePlus object format, if available. To paste as a particular format, use 
Paste Special.
Tip: You can also use the Paste button on the Standard toolbar, or right-click 
on the object, or press Ctrl+V.

Paste Special...
Displays a dialog box that lets you choose one of several formats (e.g. Picture, 
Bitmap, OLE) to be used when pasting. Then inserts the contents of the 
Windows Clipboard at the insertion point, using the selected format.

Replicate
Displays a dialog that lets you create multiple copies in a single step, with 
precise control over how the copies are arrranged, either as a linear series or a 
grid. (See the subtopic Replicating objects.)

Clear
Deletes the selected object(s) or text without placing a copy on the Windows 
Clipboard. To delete a text object, use Delete Object.
Tip: You can also press the Delete key. If you accidentally delete a selection, 
immediately choose Undo from the Edit menu.

Delete Object
Deletes the selected object(s) without placing a copy on the Windows 
Clipboard. Useful for deleting a text object without having to select the object's 
bounding box. To delete text within a text object, select it and use Clear (or 
press Delete).
Tip: You can also press Ctrl+Delete.

Select All
Creates a multiple selection, including all the objects on both the current page 
and the pasteboard. 
Tip: You can also press Ctrl+A.

Delete Page...
Displays the Page Manager dialog, preset to delete one or more pages. You 
can also add pages or go to a specific page in the publication. 
Shortcut: Double-click the Current Page box on the HintLine toolbar and select 
the Delete Page tab.

Edit Story
Launches WritePlus, the built-in story editor, and displays the text of the 
selected frame or artistic text object. Disabled unless such an object is 
selected; tables aren't editable with WritePlus. (For details on using WritePlus, 
see the topic Editing story text with WritePlus.)
Tip: You can also press Ctrl+E.

Find and Replace...



Displays a dialog that lets you search publication text for words or parts of 
words. You can search all text, or just the currently selected text object or story. 
When the target text is found, PagePlus displays it and the Replace options 
become available.
Tip: You can also press Ctrl+F.

Links...
Opens linked documents or changes links.

Object
Allows editing of an OLE object. This is the standard OLE Object menu 
command; it changes according to the type of object selected.



View Menu
Commands for setting display options 
Shortcut: Alt+V

Normal
Click to display a single page at a time in the workspace.

Multipage
Click to display a number of pages at a time in the workspace. To set the 
number of pages, use the Multipage button on the View toolbar.

Go to / Leave Master Page
Switches the screen view between page (foreground) and master page 
(background) levels. Choose Go to Master Page when you wish to edit master 
page objects.
Tip: You can also click on the Current Page box (at left on the HintLine toolbar) 
to switch between levels.

Master Page Objects...
Brings up a dialog that lets you set which pages should display master page 
objects. For example, you may not want a page number on a "new chapter" 
page.

Page Manager...
Click to display the Page Manager, which provides multiple options for inserting 
and deleting pages or master pages, assigning master pages to pages, and 
navigating to a page.

Zoom>
Displays a submenu that lets you select the zoom percentage at which your 
page is displayed. Options include Full Page (fit the whole page in the 
window), Page Width (fit the page width to the window width), and various 
scaling percentages.
Tip: You can also use the Fit Page and Actual Size buttons, along with other 
Zoom and Pan buttons, on the View toolbar.
Shortcut: Right-click any object and choose Zoom In or Zoom Out.

Toolbars
Displays a submenu with toolbars listed. Check or uncheck an individual 
toolbar item to show or hide the toolbar. (See the topic Customizing PagePlus 
toolbars and Studio tabs.)
Tip: You can also right-click on any toolbar region.

Studio Tabs
Displays a submenu with the various Studio tabs listed. Check or uncheck an 
individual item to show or hide that tab. (See the topic Customizing PagePlus 
toolbars and Studio tabs.)
Tip: You can also right-click on any Studio tab.

Studio
When checked, the Studio is visible. Uncheck to hide the Studio. 
Tip: You can also click the button on the HintLine toolbar.

Changebar
When checked, the ChangeBar is visible. Uncheck to hide the ChangeBar. 
Tip: You can also click the button on the HintLine toolbar.

Rulers
When checked, rulers are visible at the top and left of the document window. 
Uncheck to hide rulers. (See the topic Using the rulers.)

Guide Lines 
When checked, ruler guides and page row/column/margin guides are visible. 
Uncheck to hide guides. (See the topics Using the rulers and Setting guides for 
page margins, rows, and columns.)

Frames 
When checked, the borders and margins of text frames are visible. Uncheck to 
hide frames. (See the topic Understanding text frames.)

Dot Grid 
When checked, the dot grid is visible. Uncheck to hide the dot grid. (See the 
topic Aligning objects.)

Stylenames
(WritePlus only) When checked, the Stylenames window is shown to the left of 
the Text Entry window. When visible, the window shows you the named style of 
each paragraph. Uncheck to hide the Stylenames window. 
Tip: You can also click the Stylenames button on the Story toolbar.



Formatting
(WritePlus only) When checked, text appears in Layout mode, showing font 
and point size variations. Uncheck to display text without formatting. 
Tip: You can also click the Formatting button on the Story toolbar.

Special Characters
(WritePlus only) When checked, any special characters—such as spaces, tabs, 
paragraph marks, and index marks—are displayed. Uncheck to hide special 
characters. 
Tip: You can also click the Special Characters button on the Story toolbar



Insert Menu
Commands for inserting content and layout elements into your publication 
Shortcut: Alt+I

Page...
Displays the Page Manager dialog, preset to add one or more pages. You can 
also delete pages or go to a specific page in the publication. 
Shortcut: Double-click the Current Pages box on the HintLine toolbar.

Picture...
Displays a submenu that lets you select the source of the picture to be 
inserted. 

· PhotoCD...
If a PhotoCD is loaded, displays the PhotoCD Gallery, displaying image 
thumbnails from which you can select the PhotoCD image to import. (See the 
topic Importing PhotoCD images.)

· TWAIN>
Displays a submenu. Choose Acquire to display the acquisition dialog for the 
selected TWAIN source, such as a scanner or digital camera. Choose Select 
Source to specify which TWAIN-compatible device to use. (See the topic 
Importing TWAIN images.)

· From file...
Displays a file selection dialog. (See the topic Importing images.)
Tip: You can also use the Import Picture button on the Tools toolbar, or press 
Ctrl+G.

Text File…
Displays a file selection dialog that lets you import a word processor file into 
your publication. You can set your preferred text format using the General tab 
of the Tools/Options... dialog. (See the topic Importing text from a file.)
Tip: You can also press Ctrl+T.

Object...
Displays the standard Windows Insert Object dialog for inserting an OLE 
object.

PageHint...
Displays a dialog that lets you type the text of a PageHint (reminder or 
comment) and insert it into your publication. Click a PageHint icon on the 
publication page to view, edit, or delete it. (See the topic Using PageHints.)

Headers & Footers...
Starts a Wizard that helps you create or edit header and footer text that repeats 
on every page.

Table of Contents...
Starts a Wizard that helps you create a table of contents. You can designate 
which text styles in your publication will be used to compile first- and second-
level headings. (See the topic Creating a table of contents.)

Index...
Starts a Wizard that helps you create an index. Use WritePlus to mark index 
entries before running the Index Wizard. (See the topic Creating an index.)

Hyphenation Point
(Paper Publishing mode only) Inserts/removes a hyphenation point to mark a 
character as suitable for creating a line-end using a hyphen. (See the topic 
Using Hyphenation.)
Tip: It's more convenient to use the keyboard shortcut, Ctrl+'-'.

Break>
Displays a submenu with the following choices (grayed out unless there is an 
insertion point in text):

· Line Break
Starts a new line at the insertion point, continuing the existing paragraph. Also 
known as a "soft return." (To insert a paragraph break or "hard return," press 
Enter.) 
Tip: You can also press Shift+Enter.

· Column Break
Flows text to the next column, starting at the insertion point. If the current 
column is the last in the current frame, text flows to the following frame.
Tip: You can also press Ctrl+Shift+Enter.

· Frame Break
Flows text to the next frame, starting at the insertion point. 



Tip: Make sure the current frame is linked to a following frame. You can also 
press Alt+Enter.

· Page Break
Flows text to the next page, starting at the insertion point.
Tip: Make sure the current frame is linked to a frame on the next page. You 
can also press Ctrl+Enter.

Page Number
(Paper Publishing mode only) Inserts a page number field at the text cursor 
position. If page numbering changes, the field updates automatically.

Symbol>
Displays a submenu to let you insert standard symbols not found on the 
keyboard. The selected symbol is inserted at the text cursor position. Choose 
Other to display Windows' Character Map applet.

Information>
Displays a submenu with the following choices (grayed out unless there is an 
insertion point in text):

· Date or Time...
Displays a dialog letting you select a date/time format, then inserts a date/time 
field at the text cursor position. Uncheck Update Automatically to keep the 
original date/time in place indefinitely. (See the topic Inserting date/time.)

· Publication Info...
Displays a dialog letting you select a publication property such as title or file 
name, then inserts it at the text cursor position. (See the topic Viewing and 
changing document information.)

· User Details
Displays a dialog letting you select a defined User Detail field (such as name or 
address), then inserts it the text cursor position. To define User Details, choose 
Set User Details... from the Tools menu. (See the topic Inserting user details.)

Mark Index...
(WritePlus only) Displays the Mark Index Entry dialog, to insert index entry 
marks. (See the topic Creating an index.)
Tip: You can also click the Mark Index button on the WritePlus Story toolbar.

Bookmark...
Displays a dialog that lets you define the text and destination for a bookmark, 
an item in an optional list you can add if you plan to export the publication as a 
PDF file. PagePlus automatically builds the list downward, placing each new 
bookmark below the previous one. (See the topic Creating a PDF bookmark 
list.) 
Tip: You can also press Ctrl+R.

Hyperlink...
(Web Publishing mode only) Displays a dialog that lets you define a hypertext 
jump for the selected object. You can link to a specific Internet address (URL), 
a specific page in your publication, an Internet e-mail address (for example, if 
you want your readers to be able to send you e-mail), or a file (such as sound 
or video) on your hard disk. If you link to a file, the file will be published to the 
Web as part of your site.
Tip: You can also press Ctrl+K.

Web Object>
(Web Publishing mode only) Displays a submenu with the following choices:

· Sound...
Displays a dialog that lets you select a sound file to add to a Web page. (See 
the topic Adding sound and video.)

· Video...
Displays a dialog that lets you select a video file to add to a Web page. (See 
the topic Adding sound and video.)

· Animated Marquee...
Starts a Wizard that lets you add scrolling motion to a headline or catch phrase 
for a Web page. (See the topicAdding animation effects.)

· Animated GIF...
Starts a Wizard that lets you preview a variety of small, animated images to 
use in your Web site. (See the topicAdding animation effects.)

· Java Applet...
Displays a dialog that lets you select a Java applet and supporting files to add 
to a Web page. (See the topic Adding Java applets.)

· Rollover...
Displays a dialog that lets you construct a multi-layer graphic that changes 



appearance in response mouse events. Usually this serves as a button with 
"up" and "down" states plus a hyperlink. (See the topic Adding rollovers.) 

· DrawPlus Rollover...
Displays a dialog that lets you import the HTML and associated image files for 
a rollover graphic created with Serif DrawPlus.

· HTML...
Displays a dialog that lets you enter an HTML code fragment to add to a Web 
page. (See the topic .Adding HTML.)



Format Menu
Commands for setting attributes of text, text objects, and graphics 
Shortcut: Alt+O

 

Character...
Displays a dialog for setting properties of text characters, such as font, font 
style, case, size, width, color, etc. 
Tip: You can also use the ChangeBar, as well as the Styles, Font, and 
PointSize list boxes and the Bold, Italic, and Underline buttons on the Text 
toolbar. You can also right-click on text and choose Text Format.

Paragraph...
Displays a dialog for setting properties of paragraph alignment, spacing, 
hyphenation, breaks, and ruled lines. 
Tip: You can also use the text alignment buttons on the Text toolbar, or right-
click on text and choose Text Format.

Tabs...
Displays a dialog for specifying tab position, alignment, and leader type. Enter 
values manually into the boxes. 
Tip: You can also choose Text Format, but to place a tab stop directly in a 
selected paragraph, click the ruler intersection to select a tab type, then click 
on the horizontal ruler.

Bullets & Numbering...
Displays a dialog for setting properties of paragraph bullet and numbering. The 
Preview window shows the effect on selected text. 
Tip: You can also right-click on text and choose Text Format.

Drop Cap… 
Displays a dialog for setting properties of dropped and raised initial capitals. 
The Preview window shows the effect on selected text. 
Tip: You can also right-click on text and choose Text Format.

Kern>
Displays a submenu to let you adjust spacing between a pair of characters. 
Before kerning, click between two characters for an insertion point. Choose 
Positive to increase kerning, Negative to decrease, or Custom to enter a kern 
value specified as a percentage of the text size. Kern is grayed when there is 
no text insertion point.
Tip: It's more convenient to use the keyboard shortcuts Ctrl+Alt+'+' to increase 
kerning, or Crl+Alt+'-' to decrease.

Vertical Text Alignment
Displays a submenu to let you adjust the vertical alignment of all text in a text 
object as Top, Center, Bottom or Justified. For frames and table cells, it 
moves the text. For artistic text, it anchors that part of the object when new 
lines of text are added. 

Line and Border...
Displays a dialog with two tabs: Line and Border.
· The Line tab combines various line properties, such as weight (thickness), 
color, shading, style, and corners. For no line, select "None" as the style. (See 
the topic Setting line properties.)
· The Border tab lets you select border side and corner style and customize 
weight, alignment and other properties for a repeating element that encloses 
an object. (See the topic Adding borders.)
Tip: You can also use the Line panel of the Studio's Attributes tab, or right-
click on an object and choose Line and Border....

Fill...
Displays a dialog combining various fill properties, including color and shading 
(for solid fills) and key colors (for gradient fills). For no fill, select "None" as the 
type. (See the topics Applying solid colors and Working with gradient and 
Bitmap fills.)
Tip: You can also use the Color and Fill panels of the Studio's Attributes tab, 
or right-click on an object and choose Fill....

Transparency...
Displays a dialog combining various transparency properties, including percent 
(for solid transparencies), type and extent (for gradient transparencies) and 
category (for Bitmap transparencies). For no transperancy, select "None" as 
the type. (See the topic Working with transparency effects.)
Tip: You can also right-click on an object and choose Transparency....

Filter Effects...



Displays a dialog that lets you select and customize a variety of special effects, 
including shadows, glow, bevel, emboss, and color fill. (See the topic Applying 
filter effects.)
Tip: You can also right-click on an object and choose Filter Effects....

Picture>
Displays a submenu with the following choices (grayed out if no picture is 
selected):

· Properties...
Displays a dialog that lets you recolor (tint) a bitmap image. 
Tip: You can also right-click on an object and choose Picture Properties....

· Color Mapper…
Displays a dialog that lets you change the colors used in vector-type images 
and LogoPlus objects. (See the topic Changing or copying image colors .) 
Tip: You can also right-click on an object and choose Color Mapper....

· Photo Optimizer...
Helps you to improve the print quality of a selected bitmap picture on a specific 
printer. The Wizard lets you print test samples and choose the best settings, 
which are then applied when the publication is printed. (See the topic 
Optimizing pictures for printing .) 
Tip: You can also right-click on an object and choose Photo Optimizer....

· Picture Transparency...
Displays a dialog that lets you set a specific RGB value as a transparent color 
in a bitmap image or metafile. (See the subtopic Setting single-level 
transparency.)
Tip: You can also right-click on an object and choose Picture Transparency....

· Replace Picture...
Displays the Import Picture dialog to let you choose an image to replace the 
selected picture.
Tip: You can also double-click the picture.

Update Text Style
Updates the current text style (shown in the Styles box on the Text toolbar) to 
match the properties of the selected text. All text using the named style, 
throughout the publication, takes on the new properties. (See the topic Using 
text styles.)
Tip: You can also right-click the text and choose Update Text Style. 

Text Style Palette...
Displays a dialog for editing and managing text styles in your publication.

Update Object Default
Updates the local default settings for the currently selected type of object, 
using the current object's properties. In other words, the next time you create 
an object of this type in this publication, it will have these properties. To save 
local defaults globally so they'll apply to new publications, use Tools/Save 
Defaults.... (See the topic Setting defaults.) 
Tip: You can also right-click on the object.

Update Text Default
Updates the local default settings for text as initially typed within a new frame, 
table, or artistic text object, using the currently selected text. Use Update 
Object Default (see above) for frame object defaults.

Frame Setup...
Displays a dialog for editing the current frame margins and columns. (See the 
subtopic Frame margins and columns.)
Tip: You can also click the Frame Setup button on the Frame toolbar, or right-
click on a frame.

Page Number Format...
Displays a dialog that lets you set the style of page numbers used in the 
publication, and the first page number. (See the topic Using page numbering.)

Add Fill to Studio
Stores the fill of the selected object as a gallery thumbnail in the Fill panel of 
the Studio's Attributes tab. You can use the thumbnail to re-apply the fill to 
other objects. (See the topic Working with gradient and Bitmap fills.)

Add Transparency to Studio 
Stores the transparency of the selected object as a gallery thumbnail in the 
Transparency panel of the Studio's Attributes tab. You can use the thumbnail 
to re-apply the transparency to other objects. (See the topic Working with 
transparency effects.)





Table Menu
Commands for editing tables created with the Table tool 
Shortcut: Alt+B

You can also access these commands from a submenu by right-clicking a table and choosing Table.    For details, see the topic 
Creating text-based tables.

AutoFormat...
Displays a dialog that lets you choose style presets to customize the selected 
table's appearance. You can select which attributes (Lines, Fill, Font, and/or 
Alignment) of the style will be applied.

Insert>
Displays a submenu that lets you insert new Rows or Columns into the 
selected table. In the dialog, specify how many to add, and whether to add 
them before or after the selected cells.

Select>
Displays a submenu that lets you select one or more Row(s) or Column(s) 
continuous with the currently selected cell(s). Choose All to select all cells in 
the table.

Delete>
Displays a submenu that lets you delete the Row(s) or Column(s) continous 
with the currently selected cell(s). Choose Table to delete the entire table 
object.

Merge Cells
Collapses multiple selected cells into one larger cell that spans more than one 
row or column. The merged cell displays only the text originally visible in the 
top left selected cell, but the original cell content is preserved (see Separate 
Cells).

Separate Cells
Restores a merged cell to its original component cells and their content.

Cell Properties...
Displays a dialog that lets you customize the table's Border, Fill, and 
Transparency properties.



Tools Menu
General program tools and options
Shortcut: Alt+T

Layout Checker...
(Web Publishing mode only) Starts a Wizard that searches your publication for 
potential Web page layout problems. (See the topic Automatic layout 
checking.)

Spell Checker...
Starts a Wizard that helps you check your publication for spelling mistakes. 
Click the Quick Spell button on the first screen to check the spelling of a single 
word. (See the topic Spell-checking.)
Tip: You can also press F7.

Proof Reader…
Starts a Wizard that helps you proof your publication text for grammar and 
readability errors. (See the topic Automatic proofreading.)

Thesaurus…
Displays the Thesaurus, which lets you find synonyms, definitions, and 
variations of words in your publication text. (See the topic Using the thesaurus.)
Tip: You can also press Shift+F7.

Color Manager...
Displays a dialog that lets you add, modify, or delete colors in the PagePlus 
palette. (See the topic Creating your own colors.)

Scheme Manager... 
Displays a dialog that displays existing color schemes and lets you modify 
them or create new ones. (See the topic Using color schemes.)

Resource Manager...
Displays a dialog that lists the fonts and resources (such as pictures, sounds, 
and video) used in your publication, and shows if the resources are linked or 
embedded. Useful when copying or moving publication files to another 
computer. (See the topic Checking fonts and resources used.)

Text Manager...
Displays a list of all the text stories used in your publication. (See the topic 
Reviewing text content with the Text Manager.)

Bookmark Manager...
Bookmarks are optional links you can insert if you plan to export the publication 
as a PDF file. The Bookmark Manager lets you view all your bookmarks at a 
glance, organize them into a hierarchy of entries and subentries, and modify or 
delete existing bookmarks as needed. (See the topic Creating a PDF bookmark 
list.)

Hyperlink Manager...
Displays a dialog showing all hyperlinks used in the current publication, listed 
by page number. To go to a link, double-click it in the list. To delete a link, select 
it and click Remove. To modify a link (for example, designate a different target 
URL), select it and click Modify, which displays the HyperLinks dialog.

Web Picture Manager...
(Web Publishing mode only) Starts a Wizard that helps you set the properties 
of objects that will be converted to pictures when the publication is exported. 
For each object, you can choose GIF (for small images), JPEG (for photos), or 
PNG (for images with variable transparency) or apply customizable global 
default settings. In addition, you can enter an identifying tag for Web site 
visitors to read while the image is downloading. (See the topic Setting Web 
picture display options.)

Convert to Picture
Deletes the selected object or group and replaces it with an embedded picture 
representation. It's useful for combining several objects into a permanent 
graphic, creating a composite shape from multiple graphics, or specifying a 
preferred image format for a particular need. (See the topic Converting an 
object to a picture.)

AutoFit
Scales story text in the selected frame by adjusting its point size (and leading 
or paragraph spacing, if necessary) so it fits exactly into the available frames.
Tip: You can also click the AutoFit button on the Frame toolbar in PagePlus, or 
press Ctrl+Alt+X.

Word Count
(WritePlus only) Runs a wizard that counts total words or characters, or the 



number of occurrences of a specified word.
Tip: You can also click the Word Count button on the Story toolbar.

Mail Merge
Displays a submenu with the following choices. (See also the topic Using mail 
merge.)

· Insert Address Field...
Displays a dialog that lets you select and insert a specific address field marker 
at the current cursor position.

· New Address List...
Displays a dialog that lets you create a new PagePlus address list (*.SDB) file. 
Each record in an address list has 20 fields.

· Open Address List...
Displays a dialog that lets you locate a PagePlus address list file to open. You 
also can open character-delimited files (from a schedule or contact 
management program, for example) and use the built-in Address List Mapper 
to convert them to PagePlus address list (*SDB) files.

· Edit Address List...
Displays a dialog that lets you add or delete records, and edit field data, in the 
current address list.

· View Data
Check to display actual record data from the current address list in the 
publication, and reveal the MailMerge toolbar, which lets you specify which 
record's data to display. If unchecked, you'll see only address field placeholders 
and the MailMerge toolbar will be hidden. 

Save Defaults...
Records the current publication's object defaults (for text, graphics, frames, text 
styles, and color palette) as global settings. To set local defaults for a particular 
object type, use Update Object Default or Update Text Default from the 
Format or right-click menu. (See the topic Setting defaults.)

Set User Details...
Displays a dialog that lets you review and change User Details (such as name, 
address, etc.) you've supplied as "answer text" in Page Wizards or Gallery 
objects. By default, User Details are continually updated from Wizard entries. 
Uncheck "Update from Wizard entries" to leave the current details intact. (See 
the topics Creating a publication using a Page Wizard and Inserting user 
details.)

Options...
Displays a dialog that lets you customize a wide range of PagePlus settings, 
including layout choices, ease-of-use features, etc. (See the topic Setting 
PagePlus options.)
Shortcut: Double-click on the pasteboard area. For a shortcut to the Toolbars 
tab, right-click on any tool region.



Arrange menu
Commands for adjusting the relative positions and properties of PagePlus objects
Shortcut: Alt+A

Snapping
Check or uncheck to turn the snapping feature on and off. When checked, 
snapping is on, and objects you move or resize will jump to align with the 
nearest visible grid dot or guide line. (See the topic Snapping.)
Tip: You can also press the Snapping button on the HintLine toolbar.

Send to Back
Sends the selected object to the rearmost layer, behind other objects.
Tip: You can also use the Send to Back and Send to Front buttons on the 
Standard toolbar, or right-click on the object and use the Layer> submenu.

Bring to Front
Brings the selected object to the frontmost layer, on top of other objects. Tip: 
You can also use the Send to Back and Send to Front buttons on the 
Standard toolbar, or right-click on the object and use the Layer> submenu.

Back One
Shifts the selected object's position one layer toward the rear.
Tip: You can also right-click on the object and use the Layer submenu.

Forward One
Shifts the selected object's position one layer toward the front. 
Tip: You can also right-click on the object and use the Layer submenu.

Align Objects...
Displays a dialog to let you align objects in a multiple selection in various ways. 
Check Include Page to make objects align with page edges. (If only one object 
is selected, page-edge alignment is automatic.) 
Tip: You can also right-click on an object and choose Align Objects.

Group/Ungroup Objects
Turns a multiple selection (when two or more objects are selected) into a group 
object, or vice versa. (See the topic Creating groups.)
Tip: You can also click the Group/Ungroup button on a multiple selection.

Wrap Settings...
Displays a dialog to let you control how text wraps around the selected object. 
(See the topic Wrapping text around objects.) 
Tip: You can also right-click on the object.

Lock Object
When checked, the selected object's position and size are fixed so the object 
cannot be moved or resized. Convenient in situations where many objects 
overlap, or to avoid accidental changes. 
Tip: You can also right-click on the object.



Window menu
Commands for arranging publication windows
Shortcut: Alt+W

New Window
Opens another window for the active publication.

Cascade
Arranges the windows as overlapping tiles.

Tile Horizontally
Arranges the windows as horizontal, non-overlapping tiles. Useful for side-by-
side comparisons.

Tile Vertically
Arranges the windows as vertical, non-overlapping tiles.

Arrange All
Arranges the windows.

Window List
Shows the names of open publication windows, with the current window 
checked. Click a window name to work in that publication. 
Tip: You can also press Ctrl+Tab to switch between open windows.



Help Menu
Help, hints, tips, and options for learning PagePlus
Shortcut: Alt+H

See Also the introductory topic Help on Help. 

PagePlus Help
Displays the PagePlus Help window.

Visit the PagePlus Web Site
Connects to the World Wide Web and displays the PagePlus Web site section 
in your Web browser. (By default, this feature activates periodically. To change 
the defaults, choose Options from the Tools menu and use the General tab.) 

Visit the Serif Web Site
Connects to the World Wide Web and displays the Serif Home Page in your 
Web browser. 

View PagePlus QuickTour
Displays the introductory QuickTour.

Tutorials...
If you've installed the PagePlus 8 PDF Edition Resource CD-ROM, displays the 
menu of tutorials in your Web browser. 

Registration Wizard...
Helps you to register your own personal copy of PagePlus.

About PagePlus...
Displays version and copyright information.



 Standard toolbar
To hide/show toolbars: Right-click any tool region. 

 
New
Click to display the Startup Wizard, which gives you four options: 
· Design a new publication using a Page Wizard
· Start a new publication from scratch
· Open a saved publication
· View a QuickTour 
Same as menu command File/New.

 
Open
Click to display a standard Windows dialog which allows you to open an 
existing PagePlus publication (*.PPP) or template (*.PPX) file. Same as 
menu command File/Open.

 
Save
Click to save the current publication under its current name. If it's still 
unsaved ("Untitled"), the Save As... dialog automatically appears. Same as 
menu command File/Save.

 
Print
Click to display a dialog providing options for selecting which part of the 
publication file to print and how to print it. The various tabs let you control 
scaling, tiling, color separations, and other useful features. The Setup 
button displays the standard Windows printer setup dialog. Same as menu 
command File/Print.

 
Print Preview
Click to change the screen view to display the layout without frames, 
guides, rulers, and other screen items. Special options such as tiled output 
or crop marks are not displayed. Same as menu command File/Print 
Preview. (See the topic Previewing the printed page.)

 
Cut
Click to delete the selected object(s) from the page or pasteboard AND 
place a copy on the Windows Clipboard. Same as menu command 
Edit/Cut.

 
Copy
Click to copy the selected object(s) to the Windows Clipboard. Same as 
menu command Edit/Copy.

 
Paste
Click to insert the contents of the Windows Clipboard at the selection point. 
Defaults to the PagePlus object format, if available. To paste as a particular 
format, use Paste Special. Same as menu command Edit/Paste.

 
Undo
Click to undo the most recent change to the current publication. To undo 
multiple changes with a single action, click the down arrow and select 
from the list of recent changes. Undo is grayed out when not available. 
To set the number of levels of Undo, pull down the Tools menu and 
choose Options (the General tab). Same as menu command 
Edit/Undo.

 
Redo
Click to reverse the effect of a previous Undo action. To reverse multiple 
undo's with a single action, click the down arrow and select from the list 
of recent undo's. Same as menu command Edit/Redo.



 Arrange toolbar
To hide/show toolbars: Right-click any tool region. 

 
Send to Back
Click to shift the selected object's position to the bottom layer, behind all 
other objects. To shift just one layer back, choose Back One from the 
Arrange menu. Same as menu command Arrange/Send to Back. (See the 
topic Layering objects.) 

 
Bring to Front
Click to shift the selected object's position to the top layer, in front of all 
other objects. To shift just one layer forward, choose Forward One from 
the Arrange menu. Same as menu command Arrange/Send to Front.

 
Rotate Left 
Click to rotate the selected object 90° counter-clockwise. (See the topic 
Rotating an object.)

 
Rotate Right 
Click to rotate the selected object 90° clockwise.

 
Flip Horizontal
Click to flip an object left to right. Top and bottom stay the same. (See the 
topic Flipping a picture.) 
Tip: You can also right-click on an object and choose Flip.

 
Flip Vertical
Click to flip an object top to bottom. Left and right stay the same.

 
Wrap Settings
Click to display the Wrap Settings dialog, which lets you select among all 
the text wrap options, and set the manner in which text will wrap around the 
sides of the object. (See the topic Wrapping text around objects.)
Tip: You can also choose Wrap Settings... from the Arrange menu.

 
Edit Wrap
Click (once you've chosen a wrap shape) to edit the object's text wrap 
outline for more precise text fitting. You can drag nodes and segments, 
adjust node control handles to change curvature, add or delete nodes, etc. 
(See the topic Wrapping text around objects.)



 View toolbar
To hide/show toolbars: Right-click any tool region. 

See also the Visual Reference for the View menu and the topic Changing views.

 
Zoom Out
Click to view more of the page in the window. Shortcut: Right-click an 
object and choose Zoom Out.

 
Current Zoom box
Displays the current zoom percentage, with 100% representing an 
actual-size page. To set a specific zoom view, type the number in 
the box, then press Enter. 

 
Zoom In 
Click to view the page area more closely. Shortcut: Right-click an object 
and choose Zoom In.

 
Zoom Tool
Click the button, then drag out a rectangular marquee on the page to define 
a region to zoom in to. The zoom percentage adjusts accordingly, fitting the 
designated region into the window. To zoom out, hold down the Shift key 
when dragging. Double-click the button to display the page at actual size 
(100%).

 
Pan Tool
Click to enter Pan mode, indicated by a hand cursor. In Pan mode, you can 
click anywhere on the page and drag to reposition the page in the window.

 
Actual Size
Click to display the page at a zoom percentage of 100%.

 
Fit Page
Click to scale the current page (or pages, in Multipage mode) to fit in the 
window. 
Tip: You'll find other    can also choose Wrap Settings... from the Arrange 
menu.

 
Multipage
Click to display a number of pages at a time in the window. Drag to choose 
an array within the flyout, for example 2x4 Pages or 3x3 Pages. To expand 
the number of choices, drag further down and to the right. To restore single 
page view, click Normal on the flyout or choose Normal from the View 
menu.



 Text toolbar
To hide/show toolbars: Right-click any tool region. 

Styles
Displays the named style of text at the cursor 
position: either a character style (if one is applied 
locally) or the paragraph style. To apply a named 
style, click in the text, then select the style name in 
the drop-down list. To define a style based on the 
selected text's properties, type a style name into 
the box and press Enter. (See the topic Using text 
styles.) 

Font
Displays the font of text at the cursor position. To 
change the font of selected text, click a new font 
name in the drop-down list. Tip: You can also use 
the Font   panel   of the Studio's Attributes tab. (See 
the topic Setting text properties.)

Point Size
Displays the point size of text at the cursor position. To 
change the size of selected text, click a new point size in 
the drop-down list, or type in a value and press Enter.

 

Font style buttons
"Down" buttons indicate font style properties of text at the 
cursor position (Bold, Italic, Underline). To apply or 
remove a style, click the appropriate button.

 

Alignment buttons
The "down" button indicates the paragraph alignment of 
text at the cursor position (Left, Centered, Right, or 
Justified). To change the alignment of selected text, click a 
different button.



 Frame toolbar
To hide/show toolbars: Right-click any tool region. 

See also Understanding text frames.

 
Previous Frame
Click to display the previous frame in the story.

 
Next Frame
Click to display the next frame in the story.

 
Link Frame
Click to link the selected frame to another frame. Then click with the 
Textflow cursor on the frame to be linked to.

 
Unlink Frame
Click to unlink the selected frame from a frame sequence. 

 
AutoFit
Click to scale the story's text size so it fits exactly into the available frames. 
(See the topic Fitting text to frames.)
Tip: You can also press Ctrl+Alt+X.

 
Enlarge Story Text
Click to increase the story's text size one increment. Double-click for a 
bigger increase.

 
Shrink Story Text
Click to reduce the story's text size one increment. Double-click for a 
greater reduction.

 
Frame Setup
Click to display a dialog for editing the current frame margins and columns.



 Tools toolbar
To hide/show toolbars: Right-click any tool region.

 
Pointer Tool
Click to use the Pointer tool to select, move, copy, and resize objects, and 
to edit text.
· To select an object, click on it. A gray bounding box appears, with small 
"handles" appear defining the object's corners and edges. (See the topic 
Selecting an object.)
· To move the selected object, drag from the inside of the object or the 
bounding box (not from a handle). (See the topic Moving objects.)
· To copy the selected object, hold down the Ctrl key as you start dragging. 
(See the topic Copying objects.)
· To resize the selected object, drag one of its handles. (See the topic 
Resizing objects.)
· To add the selected object to a multiple selection, hold down the Shift key 
as you click on it. (See the topic Selecting multiple objects.)
· You can also edit the selected object's wrap and crop outlines. (See the 
topics Wrapping text around objects and Cropping an object.)

 
Rotate Tool
Click to use the Rotate tool to rotate an object around its top left handle. 
Select the object, then drag one of its handles. You can also use the Rotate 
tool to move and copy objects.
· To constrain rotation in 15-degree steps, press the Shift key after you've 
begun rotation, and hold it down until after you release the mouse button. 
· To unrotate (restore the original orientation), double-click the object. To 
restore the rotated position, double-click again.
Shortcut: To switch quickly to the Rotate tool, position the cursor over an 
object's handle and press the Alt key.
(See the topic Rotating an object.)

Crop Tools
Click to display a flyout menu including both the Square Crop Tool and the 
Irregular Crop Tool. The button's icon shows the most recently selected 
tool. 

The Square Crop tool lets you crop (or trim) an object while preserving its 
original rectangular outline. You can also use the Crop tools to move and 
copy objects. The Irregular Crop Tool lets you distort the outline. Select 
the object, then drag one of its handles inward with the tool. 
· To scroll the visible portion of a cropped object within the crop area, select 
the object and drag its center area. 
· To uncrop (restore full visibility), double-click the object. To restore the 
cropped state, double-click again.
· Use the Curve toolbar to edit the crop outline by dragging nodes and 
segments, adding or deleting nodes, and altering the curvature of the 
outline.
(See the topic Cropping an object.)

 
Standard Frame Tool
Click to create a standard rectangular (box) text frame—the basic container 
for text in story form. To define a new frame, click on the page or 
pasteboard (drag to adjust the frame). (See the topic Understanding frame 
text.)
Note: Normally, the tool reverts to the Pointer after you draw a shape. To 
retain the Frame tool after drawing, hold down the Shift key when you first 
click the button.

 
Table Tool
Click to create a container for text-based data in row-and-column format. 
click on the page or pasteboard, or drag to set the table's dimensions. In 
the Create Table dialog, select a preset format (or Default for a plain table). 
(See the topic Creating text-based tables.)

 

Shaped Frame Tool
Click to display a flyout menu (as shown) of 
various irregularly shaped text frames. The 
button's icon shows the most recently selected 
frame shape. Click the desired frame shape to 
select it, then click on the page or pasteboard. 

 
Artistic Text Tool
Click to create standalone text directly on a page. Click anywhere on the 
page for an insertion point using a default point size, or drag to specify a 



particular size. Set initial text properties as needed, then type normally to 
enter text. (See the topic Using artistic text.)

Line Tools
Click to display a flyout menu including the three line tools. The button's 
icon shows the most recently selected tool.
(See the topics Drawing and editing lines and Setting line properties.)

Straight Line Tool
Click the button, then click and drag to draw a straight line on your page.
· To constrain the angle of the line to 15-degree increments, hold down the 
Shift key as you drag. 
· To extend an existing line, begin drawing from one of the line's end 
nodes. 
Tip: To access Line properties, right-click on the object. 

Freehand Line Tool
Click the button, then click and drag to draw a freehand line on your page. 
· To extend an existing line, begin drawing from one of the line's end 
nodes. 
Tip: To access Line properties, right-click on the object and choose Line 
and Border....

 
Curved Line Tool
Click the button, then click and drag out an attractor node from the initial 
point. Click (or click and drag) again where you want the segment to end.
· To extend an existing line, repeat the process for each new end point. 
· To end the line, press Esc, double-click anywhere or choose a different 
tool.

 

QuickShape Tool
Click to display a flyout menu (as 
shown) of special shapes. Tooltips over 
each icon indicate the name of the 
shape. Click a button to select a shape, 
then click on the page to create the 
shape (drag to adjust its size). 

    When the shape is the right size, release the mouse button. Now you can 
alter the shape by dragging on its handles. 
· To draw a constrained shape (a circle, for example), hold down the Shift 
key as you drag. 
· Normally, the tool reverts to the Pointer after you draw a shape. To retain 
the QuickShape tool after drawing, hold down the Shift key when you first 
click the button.
Tip: To access an object's Line and Fill properties, right-click on the object. 
(See the topic Drawing shapes.)

 
Fill Tool
Select an object that can use a gradient fill, then use the Fill tool to edit the 
object's fill properties.
· Click and drag on an unfilled object to apply a simple Linear fill. Click on a 
filled object for a new start node and drag out a new fill path.
· Drag the nodes of the fill path to alter the color spread. 
· Select a node and click a color sample on the Color panel of the Studio's 
Attributes tab to change the node's key color.
Tip: To access Fill properties, right-click on the object and choose Fill....
(See the topic Working with gradient and Bitmap fills.)

 
Transparency Tool
Select an object, then use the Transparency tool to edit the object's 
transparency properties.
· Click and drag on an unfilled object to apply a simple Linear transparency, 
grading from opaque to clear. Click and drag again for a new start node 
and path.
· Drag the nodes of the transparency path to alter the effect. 
· Select a node and click a sample on the Transparency panel of the 
Studio's Attributes tab to change the node's transparency. 
Tip: To access Transparency properties, right-click on the object and 
choose Transparency....
(See the topic Working with transparency effects.)

Insert Calendar
Click to create a colorful calendar. Click again on your page (or drag out 
the desired size). The built-in Calendar Wizard then helps you pick a 
design and define options for your calendar.



 
Insert LogoPlus
Click to create a shape, headline, or complex logo using the built-in 
LogoPlus module. Click again on your page (or drag out the desired size). 
LogoPlus launches with a dialog that lets you preview various logo 
templates.

 
Insert TablePlus
Click to use the built-in TablePlus module to create a table. Click again on 
your page (or drag out the desired size). TablePlus launches with a dialog 
that lets you preview various table templates.

 
Import Picture
Click to display a file selection dialog that lets you select a picture to insert. 
Same as menu command Insert/Picture/From File.... You can also press 
Ctrl+G. (See the topic Importing images.)

 
Hotspot Tool (Web Publishing mode only)
Click to define a transparent hyperlink region on a Web page. Hotspots on 
top of text and graphics act like "buttons" that respond when clicked in a 
Web browser. Click and drag with the tool to draw a rectangular hotspot 
region. The Hyperlinks dialog appears, prompting you to enter the URL or 
other target for the hotspot.
· You can edit rectangular hotspots into freeform shapes. To create an 
extra node, click anywhere along the hotspot's edge. To change the shape 
of the edge, click and drag a node. 
(See the topic Adding hotspots.)



 HintLine toolbar
To hide/show toolbars: Right-click any tool region.

 
First Page
Click to view the first page in your publication. 

 
Previous Page
Click to view the previous page in your publication. Shortcut: Press the 
Page Up key.

Current Page box
Displays the current page number and the total number of 
pages in the publication. Click or double-click to switch between 
page and master page levels. (See the topic Viewing pages and 
master pages.)

 
Next Page 
Click to view the next page in your publication. Double-click to view the last 
page. Shortcut: Press the Page Down key.

 
Last Page
Click to view the last page in your publication. 

 
Page Manager
Click to display the Page Manager, which provides multiple options for 
inserting and deleting pages or master pages, assigning master pages to 
pages, and navigating to a page.

 
HintLine
Displays helpful, context-sensitive messages about PagePlus 
interface elements, status information for selected operations, 
and information about selected objects.

 
Snapping
Click to turn the snapping feature on and off. When the button is down, 
snapping is on, and objects you move or resize will jump to align with the 
nearest visible grid dot or guide line. When the button is up, snapping is off. 
To set the visible guide features, use the View menu or 
Tools/Options.../Layout. (See the topic Snapping.)

 
ChangeBar
Click to hide/show the ChangeBar, which includes a variety of convenient 
controls for fine-tuning object position and orientation. When the button is 
down, the ChangeBar is shown; when it is up, the ChangeBar is hidden.

 
Studio 
Click to hide/show the Studio. When the button is down, the Studio is 
shown; when it is up, the Studio is hidden.



 Story toolbar (WritePlus only)
To hide/show toolbars: Right-click any tool region. 

To learn about WritePlus, see Editing story text with WritePlus.

 
Story
Displays the name of the story currently being edited. To 
edit a different story, select its name in the list. To 
rename a story, simply type over the old name.) 

 
Zoom Factor
To view the text larger or smaller, select a zoom percentage 
from the list. 

 
Stylenames
Click to show or hide the Stylenames window (to the left of the Text Entry 
window). When visible, the Stylenames window shows you the named style 
of each paragraph. Same as menu command View/Stylenames.

 
Formatting
Click to switch between draft and layout modes. In Layout mode, the Text 
Entry window shows font and point size variations applied to the text. Same 
as menu command View/Formatting.

 
Special Characters
Click to show or hide special characters in the story text, such as spaces, 
tabs, paragraph marks, and index marks. Same as menu command 
View/Special Characters.

 
Word Count
Click to run a wizard that counts total words or characters, or the number of 
occurrences of a specified word. 

 
Mark Index
Click to display the Mark Index Entry dialog, to insert index entry marks. 
Same as menu command Insert/Mark Index.... (See the topic Creating an 
index.)

Finish
Click to close the WritePlus window and return to PagePlus.

 
Help
Click to display the topic Editing story text with WritePlus. 



 Studio
To hide/show toolbars: Right-click any tool region.

The Studio includes five separate tabs that provide a variety of elements for customizing your publication. In general, you can 
drag and drop items from the Studio into a publication (when no object is selected), or click a Studio item to apply it to the 
currently selected object. Procedures for each tab vary. 

For details on customizing the arrangement of Studio tabs, see Customizing Studio tabs.

Click a tab button to jump to its subtopic below:

 

To hide or show the entire Studio:

n Click the  Studio button on the HintLine toolbar.
OR
Check (or uncheck) Studio on the View menu.

Note: To hide the Studio, you can also click its  Close button.

To display a particular Studio tab:
n Click its button on the right-hand Studio toolbar.

To adjust the width of the Studio:

n Drag its left edge.

Attributes tab
The Attributes tab includes five separate panels—Color, Fill, Transparency, Font, and Line—that let you customize these 
properties of onscreen elements. To change the default properties to be used by new graphics or text, select a sample object 
and choose Update Object Default from the Format or right-click menu.

Color panel
The Color panel lets you apply a color and/or shading to an object. Left-click any gallery sample to apply that color as a solid fill 
to the selected object. Right-clicking a sample gives you a choice of applying the color to the selected object's line, fill, or both—
or to text. You can also drag from the sample to an unselected object to apply a solid fill. 

To edit PagePlus colors, right-click any color sample and choose Color Manager.... For details, see topics under the Contents 
heading "How to Work with Color, Fills, and Transparency." 

         
Fill/Text/Line buttons
Click to select which object property will be affected by 
clicking a sample in the color gallery.

      Color Gallery
The numbered samples in the gallery represent the five 
"placeholder" colors (1-5) in the publication's color scheme (see 
the topic Using Color Schemes). As with paint-by-numbers, 
when you assign a color number to an object, the object takes 
on the corresponding color in the current scheme. For example, 
if the third color in the current scheme is blue, objects marked 
with "Scheme Color 3" will appear blue. 

 
 

The rest of the gallery colors comprise the PagePlus palette 
(color table). The currently selected object's solid fill color is 

highlighted. The top left cell shows , which represents either 
None (a transparent interior for objects with line/fill properties) 
or Original (for pictures only, to reset the object to its original 
colors).
 

 

Shade/Tint Slider
Drag to vary the color selected in the color gallery. 
Dragging left (-) for Shades progressively adds 
black to the starting color for a darkening effect, 
while dragging right (+) for Tints progressively 
adds white for a lightening effect.

 

Fill panel



The Fill panel lets you apply a gradient fill to an object. You can apply Gradient and Bitmap fills to shapes, text frames), tables, 
and characters inside an artistic text object. For details on using fills, see the topic Working with gradient and Bitmap fills.

 

Categories
Select a fill category to display a gallery of available fills.

 

Fill Gallery
Displays samples of available fills in the selected 
category.
· Select one or more object(s) and click a gallery sample 
for the fill you want to apply.
OR
· Drag from the gallery sample onto any object (the 
cursor changes to include a plus sign over suitable 
objects), and release the mouse button.

 

Shade/Tint Slider
Drag to vary the colors of the current fill. Dragging 
left (-) for Shades progressively adds black to the 
starting colors for a darkening effect, while 
dragging right (+) for Tints progressively adds 
white for a lightening effect.

 

Transparency panel
The Transparency panel lets you apply a transparency effect to an object. You can apply Solid, Gradient, or Bitmap transparency 
to images, shapes, text frames, tables, and characters inside an artistic text object. For details, see the topic Working with 
transparency effects.

 

Categories
Select a transparency category to display a gallery of 
available transparencies.

 

Transparency Gallery
Displays samples of available transparencies.
· Select one or more object(s) and click a gallery sample 
for the transparency you want to apply.
OR
· Drag from the gallery sample onto any object (the 
cursor changes to include a plus sign over suitable 
objects), and release the mouse button.

 

Font panel
The Font panel lets you change the font of existing text objects (see the topic Setting text properties). To change the default text to 
be used by new text, select sample text and choose Update Object Default from the Format or right-click menu. 

 
Fonts
Displays available fonts. To change the font of the selected text 
object, click a new font name in the list. You can also drag and 
drop a font onto any text object.

 

Line panel
The Line panel lets you set the weight, type, and start/end termination of lines and shape outlines (see the topic Drawing and 
editing lines).

 
Sample Gallery
Displays thumbnails for lines of varying type and termination. To 
apply the properties to a selected line, click the sample. Click 
None to remove the line from an object. Note that the line's 
weight won't be affected by applying a gallery sample.

 
Weight
Displays the weight (thickness) of the selected object's line. To 
change the weight, click a different value in the drop-down list, 
or type a value and press Enter.

 

Type
Displays the type of the selected line. To change the type, click 
a different example in the drop-down list.



 

Start Style
Displays the style of the start point of the selected line. To 
change the style, click a different example in the drop-down list.

 

End
Displays the style of the end point of the selected line. To 
change the style, click a different example in the drop-down list.

 

Schemes tab
The Schemes tab displays a list of available color schemes (see the topic Using color schemes).

 Gallery
The publication's current color scheme is highlighted. Left-click 
any scheme to apply it to the current layout.
To add, modify, or delete a color scheme, right-click in the tab 
and choose Scheme Manager... (or choose Scheme 
Manager... from the Tools menu).

 

Pages tab
The Pages tab displays thumbnail representations of the master pages (upper panel) and pages (lower panel) in the publication 
(see the topic Adding, removing, and rearranging pages).

 

Page Thumbnail
Each page or master page is depicted with a thumbnail. 
· To select a page or master page for insertion or deletion (see 
below), click its thumbnail. 
· To work on a page or master page, double-click its thumbnail.
· To rearrange pages, drag a page thumbnail to a new place in 
the page sequence.
· To assign a specific master page to a specific page, drag the 
master page thumbnail 

 
Insert Page
Click to add a page (or master page) before the one whose thumbnail is 
currently selected in the panel.

 
Page Manager
Click to display the Page Manager, which provides multiple options for 
inserting and deleting pages or master pages, assigning master pages to 
pages, and navigating to a page.

 
Delete Page
Click to delete the page (or master page) whose thumbnail is currently 
selected in the panel.

Gallery tab
The Gallery tab includes a wide variety of predesigned elements—graphics that you can customize and use as a starting point for 
your own designs. (See the topic Using the Gallery.)

 

Gallery Categories
To choose a Gallery category, click its name in the list.

 

Gallery Objects
Displays the Gallery choices for the selected category. 
To use a Gallery object, drag it onto the page. To edit 
the components of a group object, select it and click its 
Group/Ungroup button. To edit the answer text of a 
Gallery object, use the Wizard tab (see below).

 

Portfolio tab
The Portfolio tab is a container for storing design objects (such as pictures, text blocks, even unlinked text frames or HTML 
fragments) you'd like to reuse in different publications. Once you've copied a design to your Portfolio, the design is available in any 
publication—simply open the Portfolio! 



The Portfolio has two parts: (1) an upper Categories 
group and    (2) a lower Designs group where you can 
drag items for storage. (To copy an item, hold down 
the Ctrl key while dragging.) Right-click to access 
functions for new categories, deleting designs, etc.

For details, see the topic Using the Portfolio.)

 

Wizard tab
The Wizard tab lets you revisit choices you made when creating a publication using a Page Wizard. You can customize the 
publication's answer text or its color scheme. (See the topic Customizing Page Wizard text.) 

 

Wizard Categories
Lists the categories that you can customize, such as 
answer text and color schemes. To review or change 
a category, click its name. The tab is empty if the 
publication does not employ Page Wizard elements.

 

 

Edit Area
This is where you make actual changes to the 
publication or gallery object. The "Color Scheme" 
selection list works just like the regular Color 
Schemes tab (see above). To change answer text, 
simply retype it.
Note: Normally, answer text you enter into question 
fields is instantly stored as User Details, so it will be 
available the next time you use a Page Wizard. For 
details, see the topic Inserting user details.

 



 ChangeBar
To hide/show toolbars: Right-click any tool region.

About the ChangeBar

The ChangeBar combines a host of controls for dynamically fine-tuning object placement and properties. It's a "floating" toolbar 
that sits on top of the work area and can be dragged to the most convenient location (unlike other toolbars, it's not dockable). To 
move the ChangeBar around, simply click and drag on its title bar.

To show the ChangeBar, click the  ChangeBar button on the HintLine toolbar, or right-click on any toolbar and choose 
ChangeBar. To hide the ChangeBar, click its 

 Close button or click the ChangeBar button again.
To collapse the ChangeBar, so it takes up less space but remains available, click its  Minimize button. Click the button again to 
restore full size.

To change an object property, select the object and alter the ChangeBar setting. There is no OK button—selected objects change 
"on the fly" as you adjust their properties.

To undo a change made with the ChangeBar, press Ctrl+Z or click the  Undo button on the Standard toolbar.

ChangeBar controls

The ChangeBar is context-sensitive and the controls displayed vary according to the type of object you've selected. The controls 
are versatile and you can choose from the following techniques to make adjustments:

n Click the small up- or down-arrow "spinwheel" buttons to adjust incrementally; OR 
n Click the small right-arrow buttons, then drag the revealed slider to adjust continously, or click a point on the slider to select a 

value; OR

n Click in the text box, then press the up or down arrows on the keyboard to change the values shown; OR
n Type in an exact value and press the Enter key. 

 
Horizontal position
Change the horizontal placement of the object's top left corner, 
with respect to the ruler's zero point. The higher the value, the 
further to the right.

 
Vertical position 
Change the vertical placement of the object's top left corner, with 
respect to the ruler's zero point. The higher the value, the lower on 
the page.

 
Object width
Move the object's right edge with respect to its left edge. The left 
edge stays the same.

 
Object height 
Move the object's bottom edge with respect to its top edge. The 
top edge stays the same.

 
Object rotation
Rotate the object's bottom right corner counter-clockwise around 
its top left corner.

 
PointSize
Change the text point size. 

 
Width
Change the text width.

 
Letterspacing (tracking)
Change the inter-letter spacing.

 
Leading
Change the leading, or distance from one text baseline to the 
next. The baseline is the line on which a line of text appears to sit.

 
Advance
Change the position of a character, or set of characters, in relation 
to their baseline. The change is measured in points and a 
negative value moves the selected text upwards.

 Columns
Change the number of columns in a text frame.



Creating a publication using a Page Wizard

The first time you launch PagePlus, you'll see the Startup Wizard, with a menu of four choices. The first of these is Use a Page 
Wizard. PagePlus ships with a selection of Page Wizards, and many more are available on the PagePlus 8 PDF Edition 
Resource CD. (For more details about the Resource CD, contact Serif.)

Page Wizards are built-in design assistants that speed you through the process of creating professional publications. Whether 
you're just beginning to work with PagePlus—or an old hand exploring new design possibilities—put Page Wizards to work for 
you!

To create a Page Wizard publication:

1 Launch PagePlus, or choose New... from the File menu, to display the Startup Wizard.

2 Click Use a Page Wizard, select a publication category on the left, and examine the samples on the right. Click the sample 
that's closest to what you want, then click Finish.

The publication opens in Wizard Preview mode, with only the Studio's Wizard tab displayed on the right. The upper group of the 
Wizard lists the categories of information that you can customize. Further down are boxes where you can review and/or re-enter 
the sample "answer text" in the category.

3 Type into the fields to replace the sample text. As you enter information, you'll see the publication update to reflect your 
choices.

You can change as much or as little as you like at this point—it's always possible to revisit the choices later. For details on 
altering answer text, see the topic Customizing Page Wizard text. For more information on color schemes, see the topic Using 
color schemes.

4 When you're done with each category, select another until you're done. Then click the Finish button. 

Note: The Startup Wizard is the only way to access Page Wizards. If you've switched it off (and don't see it when you start up or 
choose File/New...), you can switch it on again. Choose Options... from the Tools menu and check Use Startup Wizard on the 
General tab.



Starting a new publication from scratch

The first time you launch PagePlus, you'll see the Startup Wizard, with a menu of four choices. The second choice is Start from 
Scratch. 

To start a new publication from scratch using the Startup Wizard:

1 Click Start from Scratch.

2 Select a publication type on the left and examine the samples on the right. Click the one that's closest to what you want, you 
can select from the given publication types or define a custom publication by clicking Create Custom....
Note: You can always adjust the publication's page setup later. For details, see Setting up a publication. 

3 Click Finish.

The new publication opens with a blank page.

Tip: If you click Cancel (or press Escape) from the Startup Wizard, you'll get a blank document using default page properties.

To start a new publication during your PagePlus session:

1 Choose New... from the File menu. 
OR

Click the  New button on the Standard toolbar.

2 If the Startup Wizard is turned on, follow the steps above.

3 If the Startup Wizard is turned off, a new publication opens with a blank page, using default settings.

To turn off the Startup Wizard:

n Choose Options from the Tools menu and uncheck Use Startup Wizard on the General page. 

Note: You'll have to turn the Startup Wizard back on to be able to access Page Wizards.



Opening an existing publication

The first time you launch PagePlus, you'll see the Startup Wizard, with a menu of four choices. The third choice is Open a 
Publication.

To open an existing publication from the Startup Wizard:

1 Select the Open a Publication option and click Next. You'll see a list of recent PagePlus publications (if any), with preview 
thumbnails on the right.

2 Click a file name or sample, then click Finish. 
OR 
Click Browse to locate a different file. In the Open dialog, select the folder and file name and click the Open button.

The publication opens to the first page.

To open an existing publication during your PagePlus session:

1 Choose Open... from the File menu. 

OR

Click the  Open button on the Standard toolbar.

2 In the Open dialog, select the folder and file name and click the Open button.

Note: Alternatively, if you prefer to preview publication thumbnails, you can choose File/New to display the Startup Wizard, then 
follow the steps above.

To revert to the saved version of an open publication:

n Choose Revert... from the File menu. 

Open dialog options
The Open dialog has two options for intermediate to advanced users.

In the Files of type list, you can select either PagePlus publication (*.PPP) files or template (*.PPX) files. Files saved in the 
usual way use the .PPP extension. For details on working with template files, see Using templates.

Check the Open as Untitled box if you want a saved file to open as Untitled—for example, if you're about to create a new 
publication from an old one and want to leave the old one intact. This is the default option for template files.



Working with more than one publication

PagePlus lets you open more than one publication at a time, and work with more than one window for a given publication. You 
can drag and drop objects between publication windows.

Each new publication you open (see the preceding topics) appears in a separate window with its own settings. For example, you 
can work with one publication in Paper Publishing mode and another in Web Publishing mode (see the next topic).

Multiple windows for a single publication are useful, for example, if you need to work on a page using two different zoom views. 
(You can also set a given window to display multiple pages at a particular zoom view. For details, see Changing views.) 

To close the current window:

n Choose Close from the File menu or click the window's  Close button. If it's the only window open for the publication, the 
command closes the publication and you'll be prompted to save changes.

Note: You can close all open publications without exiting the main PagePlus application. To exit PagePlus, choose Exit from the 
File menu.

The Window menu lets you create new windows and arrange the open document windows in various ways:

n Click New Window to open a new window for the current publication. Multiple windows appear with sequential numbers 
following the publication name in their title bars, for example "My Newsletter:1" and "My Newsletter:2".

n Click Cascade to arrange the windows as overlapping tiles. 

n Click Tile Horizontally to arrange the windows as horizontal, non-overlapping tiles. This is a useful mode when you need to 
make side-by-side comparisons of two tall (portrait aspect) publications.

n Click Tile Vertically to arrange the windows as vertical, non-overlapping tiles. Choose this mode to compare wide (landscape 
aspect) publications.

n Click Arrange to arrange the open windows.

The Window menu also lists the names of open publication windows, with the current window checked. The easiest way to 
switch between windows, of course, is simply to click in the window you want. However, if one window is obscuring another, 
press Ctrl+Tab or click a window's name on the menu to switch to another window.

When you use WritePlus, the built-in story text editor, it opens in a separate window. You can switch back and forth between the 
WritePlus window and the main window just as you would between publication windows.



Switching between Paper Publishing and Web Publishing modes

Paper Publishing mode is the familiar PagePlus environment for creating print publications. Web Publishing mode includes 
special features, such as menu items and custom settings, to facilitate creation of World Wide Web pages.

n If you're new to Web publishing using PagePlus, check out the sequence of help topics under the Contents heading "How to 
Prepare a Publication for the World Wide Web." The sequence begins with Getting started in Web mode. 

To turn an existing PagePlus (paper) publication into a World Wide Web site: 

n Open the publication in Paper Publishing mode and choose Switch to Web Publishing from the File menu. 



Saving your publication

To save your work:

n To save the publication under its current name, choose Save... from the File menu. 

OR 

n Click the  Save button on the Standard toolbar.

OR 
n To save under a different name, choose Save As... from the File menu. 

Note: You can also use WritePlus to export the text of a particular story in several different formats: WritePlus (.STT), formatted 
(.RTF), or unformatted (.TXT) text file. For details, see the topic Exporting story text.



Using templates

Once you've settled on a particular layout, you can save the layout as a template to be used as a basis for other publications. 
You can save any PagePlus publication as a template (*.PPX) file. When opening a saved template file, PagePlus automatically 
opens an untitled copy, leaving the original template intact. Templates help ensure continuity between your publications by 
preserving starting setups for such elements as:

n Page layout(s): A pre-designed, general-purpose grid, or a single- or multi-page solution for, say, a letter-size, 3-fold brochure 
or a corporate newsletter.

n Content: Some content will be intended for the final publication (typically drawn graphics, column dividing rules or clipart 
samples). Other elements (the text and pictures) will be placeholders for you to replace.

n Styles: A set of text styles appropriate to the elements in the template publication.

n Color palette: A preferred palette of complementary colors.

 

To save a publication as a template:

n Choose Save As... from the File menu. Under "Type," click to select the Template option. Enter a file name, leaving the .PPX 
extension intact, and click Save. 

To open a template file:

1 Choose Open... from the File menu and select PagePlus Templates (*.PPX) in the "Files of type" box.

2 If you want to open the original template (wizard) file, uncheck the Open as Untitled option. To open an untitled copy, leave 
the box checked.

3 Click the Open button.



Closing PagePlus

To close the current window:

n Choose Close from the File menu or click the window's  Close button. If it's the only window open for the publication, the 
command closes the publication and you'll be prompted to save changes.

You can close all open publications without exiting the main PagePlus application.

To close PagePlus:

n Choose Exit from the File menu.

You'll be prompted to save changes to any open publications.



Using the page and pasteboard

Most of the PagePlus display is taken up by a page or "artwork" area and a surrounding "pasteboard" area. This arrangement is 
an electronic equivalent of the system used by traditional graphic designers. They kept design tools and bits of text and graphics 
on a large pasteboard, and then carefully pasted final arrangements of material onto a page-sized artwork sheet pinned down in 
the middle of the board.

In PagePlus, the page area is where you put page layout guides, and of course the text, shapes, and pictures that you want to print. 
The pasteboard area is where you generally keep any text, shapes, or pictures that are being prepared or waiting to be positioned 
on the page area.

PagePlus lets you switch between two viewing modes: Normal view, which displays one page at a time, and Multipage view, 
which displays a number of pages at a time in the workspace. (For details, see Changing views.) In either mode, the pasteboard 
is shared by all pages. Especially in Normal view, it's useful for copying or moving objects between pages. 

To move or copy an object between pages via the Pasteboard:

1 Drag the object onto the pasteboard (hold down the Ctrl key to copy).

2 Use the page navigation buttons on the HintLine toolbar to change pages.

3 Drag the object from the pasteboard onto the new page. 

PagePlus can handle nearly unlimited page sizes (see the next topic). In practice, your working limit is likely to be set by the 
capabilities of your desktop printer.

An object must be entirely on the pasteboard—not overlapping the page edge—for it to be stored on the pasteboard rather than 
the current page. When printing, anything which overlaps your page edge is printed, while anything entirely on the pasteboard is 
not. Objects which partially overlap the page, known as "bleeds," will be printed in entirety. Only if the size of the desktop 
printer's page is insufficient will they be cropped.

In Paper Publishing mode, the pasteboard color is determined by the Windows setting for "Application Background Color." You 
may wish to change this specific setting if you're having trouble seeing objects or cursors over the pasteboard.



Setting up a publication

A publication's page size and orientation settings are fundamental to your layout, and are defined when the new publication is 
first created, either using a Page Wizard or as a Start from Scratch choice via File/New... and the Startup Wizard. If the Startup 
Wizard is turned off, or you cancel the setup dialog, a new publication defaults to Letter size (US) or A4 (Europe). 

For publications (like books or booklets) where the layout of double-page spreads (left and right pages) is significant, you can set 
up a facing page mode, with or without mirrored margins. 

Master pages store background elements that you want to repeat on multiple pages. 

You can adjust these aspects of a publication at any time—but as a rule, make changes before you've gone too far with laying 
out page elements! 

To adjust the dimensions of the current publication (Paper Publishing mode):

1 Choose Page Setup... from the File menu.

2 For Regular publications, you can select a paper size and enter values for page width and height, as well as setting the 
orientation (wide or tall). 
For other publication categories, you can select from the given publication types or define a custom publication by clicking 
Create Custom....
· For Regular publications, click in the page size list to specify page dimensions and select either "Wide" or "Tall" as the page 
orientation.
· For other publications, choose a group: Small (for example, business cards), Large (banners or posters), or Folded 
(booklets). Click in the publication list to preview available choices. To define a new custom publication, click New... and use 
the dialog to enter the new publication's name and attributes.

3 Click OK to accept the new dimensions. The updated settings will be applied to the current publication.

To adjust the dimensions of the current publication (Web Publishing mode):

1 Choose Page Setup... from the File menu.

2 Set page dimensions as Standard for VGA monitors, Wide for SVGA, or Custom. For a custom setting, enter page dimensions 
in pixels. 

Hint: To accommodate most users, choose the Standard size. It's better to have the layout appear a bit tight at 800x600 than to 
have text and graphics spill beyond the edges of a 640x480 display.

Facing pages
In Paper Publishing mode, you can choose whether to set up your publication so that the PagePlus window displays pages 
either singly or in pairs—as two facing pages side by side. You'll need facing pages if you're creating a publication where you 
need to see both the left-hand (verso) and right-hand (recto) pages, or one that employs double-page spreads where a headline 
or other element needs to run from the left-hand page to the right-hand page. 

Normally, facing pages initially share a dual master page (see below) that functions as a spread on the master page level and 
lets you run background elements across both left and right. You also have the option of using only single master pages in 
facing page mode.

See the next topic for how to define margin guide lines using "mirrored margins," where the "left" margin setting becomes the 
"inside" on both facing pages, and the "right" margin becomes the "outside."

To set up facing pages (Paper Publishing mode):

n In the Page Setup dialog (see above), check Facing Pages. 

n If you plan to use background elements that span a double-page spread, check Dual master pages. This will provide a 
master page with paired "left page" and "right page" components.
OR
For a facing-page layout where both left and right pages initially share the same master page, and you don't need to run 
background elements across the spread, uncheck Dual master pages.

Master pages
The master page level is the background of your publication, where you can place objects you'd like to appear on every page—
such as headers and footers, page numbers, or a border design. Every publication has a master page level, which can include 
one or more different master pages. Every page has a specific page assigned to it. 

In a simple publication, you may not need to use the master page level at all—or you can get by with just one master page. 
Facing pages (see above) and multiple master pages prove valuable with longer, more complex documents. Using the Pages 
tab or Page Manager, you can quickly add or delete master pages; for example, you could set up different master pages for 
"title" or "chapter divider" pages. For details, see Adding, removing, and rearranging pages. 

Once you've defined master pages, you can quickly switch back and forth between the page and master page levels for editing 
purposes. 



To switch between page and master page levels:

n Click the Current Page box at the left of the HintLine toolbar. 

OR 
n Choose Go to Master Page or Leave Master Page from the View menu.

Note: You can also double-click a page thumbnail in the upper panel of the Studio's Pages tab to go directly to that master page 
and automatically switch to the master page level; for details, see Viewing pages and master pages. 

As described above, if you set up a publication to use facing pages, you can specify either a single or dual master page. A dual 
master page has both a left- and right-side component, allowing you to run elements across a spread in the background of the 
publication. For example, you could position left-side page numbers and right-side page numbers at opposite corners. The upper 
panel of the Pages tab shows single master pages with a standard page thumbnail, and dual master pages with a split-page 
thumbnail.

Each new page you add to the publication is assigned a master page. If the publication uses more than one master page, you 
can reassign specific master pages to specific pages.

To assign a master page to a page:

n On the Studio's Pages tab, click on the master page thumbnail (in the upper panel) and drag onto the page thumbnail (in the 
lower panel).

You can also use the Page Manager tab to assign master pages. For details, see Assigning master pages. 

Note: You always assign master pages to individual pages, one page at a time. Thus it takes two separate drag-and-drop steps 
on the Pages tab to assign a dual master page to both left and right facing pages. This ensures that left and right publication 
pages can use different master pages if necessary. For example (see below), a left-hand "body text" page might use the left-side 
component of one master page, while a right-hand "chapter divider" page could use the right side of a different master page.

      Facing pages/Dual master pages



Setting guides for page margins, rows, and columns

Layout guides are visual guide lines that help you position layout elements, either "by eye" or with snapping (see below) turned 
on. They can include page margins, row and column guides, and/or ruler guides.

Page margin settings are fundamental to your layout, and usually are among the first choices you'll make after starting a 
publication from scratch. The page margins are shown as a blue box which is actually four guide lines—for top, bottom, left, and 
right—indicating the underlying page margin settings. If you like, you can set the margins to match your current printer settings. 

You also have the option of setting up row and column guides as an underlying layout aid. PagePlus represents rows and 
columns on the page area with dashed blue guide lines. 

In addition, you can define free-floating ruler guides on a page by clicking on the PagePlus rulers. For details, see the topic 
Using the rulers.

Note: Unlike frame margins and columns, these layout guides don't control where frame text flows. Rather, they serve as visual 
aids that help you match the frame layout to the desired column layout. Usually the frame column width matches the underlying 
page column guides, but sometimes (for example in six-column or seven-column grids) the frame column will take up two, or 
even three, of the page columns.

To define layout guides:

n Choose Layout Guides... from the File menu. 

OR
n Right-click on a blank part of the page and choose Layout Guides....

The Margins tab lets you set guide lines for page margins, rows, and columns. You can set the left, right, top, and bottom 
margins individually, or click the From Printer button to derive the page margin settings from the current printer settings. The 
dialog also provides options for balanced margins (left matching right, top matching bottom) or for two mirrored margins on 
facing pages where the "left" margin setting becomes the "inside," and the "right" margin becomes the "outside." (See the 
previous topic for more on facing pages.)

Use the Row and Column Guides section to define guides for rows and columns. If you want rows or columns of uneven width, 
first place them at fixed intervals, then later drag on the guides to reposition them as required.

To show or hide layout guides you've defined:

n Check or uncheck Guide Lines on the View menu. 

This setting also affects any ruler guides you've placed on the page area.

Snapping
When the snapping feature is turned on, objects you create, move, or resize will jump to align with nearby, visible layout guides. 
To prevent objects from snapping to layout guides, hide the guides by unchecking Guide Lines on the View menu. This also 
hides ruler guides. You can set specifically which elements are snapped to using the Tools/Options.../Layout tab. (See the topic 
Snapping.)



Using the rulers

The PagePlus rulers mimic the paste-up artist's T-square, and serve several purposes:

n To act as a measuring tool

n To set and display tab stops

n To set and display paragraph indents

n To create ruler guides for aligning and snapping 

Ruler units
To select the basic measurement unit used by the rulers:

n Choose Options... from the Tools menu and select the Rulers page. 

In Paper Publishing mode, the default unit is inches or centimetres; in Web Publishing mode, the default is pixels.

The actual interval size of the ruler marks depends on the current zoom percentage. In zoomed-out view, for example at 50%, 
there's more distance between ruler marks than when zoomed-in to 150%. To handle work where you want finer control or 
smaller snapping increments, click a zoom button to magnify the page.

Adjusting    rulers
By default, the horizontal ruler lies along the top of the PagePlus window and the vertical ruler along the left edge. The default 
ruler intersection is the top left corner of the pasteboard area. The default zero point (marked as 0 on each ruler) is the top left 
corner of the page area.

 
To define a new zero point:
n Click and drag the arrow on the ruler intersection to the new zero point on the page or pasteboard.

To move the rulers:

n With the Shift key down, click and drag the arrow on the ruler intersection. The zero point remains unchanged.

n Double-click on the ruler intersection to make the rulers and zero point jump to the top left-hand corner of the currently 
selected object. This comes in handy for measuring page objects.

To restore the original ruler position and zero point:

n Double-click the arrow on the ruler intersection.

To lock the rulers and prevent them from being moved:

n Choose Tools/Options... and select the Rulers page, then check Lock Rulers.

If the ruler intersection is grayed, the rulers are currently locked.

Rulers as a measuring tool
The most obvious role for rulers is as a measuring tool. As you move the mouse pointer, small lines along each ruler display the 
current horizontal and vertical cursor position. When you click to select an object, white ruler regions indicate the object's left, 
right, top, and bottom edges. Each region has a zero point relative to the object's upper left corner, so you can see the object's 
dimensions at a glance.

 

Setting tab stops
To set a tab stop:

1 Select the paragraph(s) in which you want to set tab stops.



2 Click the ruler intersection button until it changes to the type of tab you want: (Left, Center, Right, or Decimal). 

 

3 Click on the horizontal ruler where you want to set a tab stop.

n To move a tab stop, click and drag it to a new ruler position.

n To delete a tab stop, click and drag it off the ruler.

Note: If you want to set precise measurements for tabs, right-click the frame and choose Text Format, then select Tabs... from 
the submenu.

Setting paragraph indents
When a text object is selected, markers on the horizontal ruler indicate the left indent, first line indent, and right indent of the 
current paragraph. You can adjust the markers to set paragraph indents, or use a dialog.

 
n The left indent is set in relation to the object's left margin.

n The first line indent is in relation to the left indent.

n The right indent is in relation to the object's right margin.

For details on setting frame margins, see the subtopic Frame setup and layout.

To set the indents of the current paragraph:

n Drag the appropriate ruler marker(s).

OR
n To adjust indent settings numerically, choose Character... from the Format menu (or Text Format/Character... from the right-

click menu), then click the Details button. You can enter values for Left, Right, 1st Line, or Hanging indents.

Creating ruler guides
PagePlus lets you to set up horizontal and vertical ruler guides—non-printing, red lines you can use to align headlines, pictures, 
and other layout elements.

 
n To create a ruler guide, click on a ruler. The red ruler guide line appears. 

Note: If a text object is selected, clicking within the object's ruler region adds a tab stop. Clicking elsewhere on the ruler creates 
a guide.

n To move a guide, drag it. 

n To remove a guide, drag and drop it anywhere outside the page area. 

n To lock ruler guides, choose Tools/Options... and select the Rulers page, then check Lock Ruler Guides.

n To fine-position ruler guides, choose Layout Guides... from the File menu (or right-click menu) and select the Ruler tab. You 
can use the tab to create or delete individual guides. To delete all ruler guides at once,    click the Clear All button.

Snapping
When the snapping feature is turned on, objects you create, move, or resize will jump to align with nearby, visible ruler guides. To 
prevent objects from snapping to ruler guides, hide the guides by unchecking Guide Lines on the View menu. Unchecking this 
item also hides page margin, row, and/or column guide lines. As an alternative, you can uncheck Ruler guides under "Snap to:" 
on the Tools/Options.../Layout tab.

See Also:

n Aligning objects 

n Snapping 



Using headers and footers

Headers and footers are layout elements that go at the top and bottom (respectively) of your master page(s), and are repeated 
on every page of your publication. The Headers and Footers Wizard lets you create these elements easily.

To create headers and/or footers, with the option of including page numbers:

n Choose Headers & Footers... from the Insert menu, and follow the Wizard instructions.

To edit existing headers and footers, or create more complex master page elements:

n Switch to the master page layer by clicking the Current Page box on the HintLine toolbar (or to simply edit them, you can rerun 
the Wizard).



Using page numbering (Paper Publishing mode only)

Page number fields automatically display the current page number. Typically, page number fields are used on the master page 
level so they will appear on every page, but you can insert a page number field anywhere in your text.

To define a header or footer that includes page number fields:

n Choose Headers & Footers... from the Insert menu.

To insert a page number field:

1 In Paper Publishing mode, switch to the master page layer (if desired) by clicking the Current Page box on the HintLine 
toolbar.

2 Create a new text object if necessary. Click for an insertion point where you want to place the page number field.

3 Choose Page Number from the Insert menu.

To display a dialog that lets you change the page numbering style used in your publication:

n Choose Page Number Format... from the Format menu.

You can select from standard numbering schemes such as Arabic numerals (1, 2, 3...) or Upper Roman (I, II, III...). You can also 
specify the starting page number in the sequence. For example, Chapter Two of a long publication might be in a separate file 
and begin numbering with page 33.



Changing views

PagePlus makes it easy to see exactly what you're working on—from a wide view of multiple pages to a closeup view of a small 
region. For example, you can use the scrollbars at the right and bottom of the main window to move the page and pasteboard 
with respect to the main window. The view automatically recenters itself as you drag objects to the edge of the screen. 

The View toolbar at the top of the screen provides the  Pan tool as an alternative way of moving around, plus a number of 
buttons that let you zoom in and out so you can inspect and/or edit the page at different levels of detail. 

To review the zoom view options, see the Visual Reference topic View toolbar.

In addition, you can switch between two viewing modes: Normal view, which displays one page at a time, and Multipage view, 
which displays a number of pages at a time in the workspace. In Multipage view, it's especially easy to move or copy objects 
between pages using drag-and-drop. You can easily switch between modes and set the number of pages displayed.

To view multiple pages in the workspace:

1 Click the  Multipage View button on the View toolbar. An array selector appears.

2 Click and drag to choose an array within the selector, for example 2x4 Pages or 3x3 Pages. To expand the number of choices, 
drag down and to the right. Click Cancel if you change your mind.

The publication appears in Multipage mode with the specified page array in view. 

To switch between Normal and Multipage view:

n Choose Normal or Multipage from the View menu. 

Tip: From Multipage mode, you can also return to Normal mode by clicking the word Normal View on the Multipage array 
selector.

In either mode, you can use the  Previous Page and 

 Next Page buttons on the HintLine toolbar to step between pages. In Multipage view, you have the additional option of scrolling 
from one set of pages to the next using the vertical scrollbar or the Pan tool. 
Tip: As an alternative to Normal view, you can select a 1x1 Page array using the Multipage button, which lets you view one page at 
a time but also lets you scroll between pages.



Viewing pages and master pages

Every publication has a background master page level and every page has a specific master page assigned to it. (See also 
these topics: Assigning master pages, Adding, removing, and rearranging pages, and Changing views.) It's easy to jump to the 
level or page you want to work on. If you don't want background objects to appear on a particular page, you can hide them with a 
single setting.

In order to add or edit master page elements, you first need to switch from the regular page level of the publication to the master 
page level.

To switch between page and master page levels:

n Click the Current Page box at the left of the the HintLine toolbar.

OR 
n Choose Go to Master Page or Leave Master Page from the View menu.

Note: You can also double-click a page thumbnail on the Studio's Pages tab to go directly to that page or master page (see 
below). This will automatically switch to the appropriate level.

Whether you're working on the page level or the master page level, you'll often need to navigate from one page to another. 
PagePlus provides a variety of ways of getting quickly to the place you need to work.

To go to a specific page/master page:

n On the Studio's Pages tab, double-click the thumbnail for the page (or master page) you want to go to. Thumbnails for master 
pages appear in the top panel, while thumbnails for pages appear in the lower panel.

OR
1 Switch to the level (page or master page) you want to work on.

2 Click the  Page Manager button on the HintLine toolbar. 
OR
Right-click the page or pasteboard and choose Page Manager... (or choose the item from the View menu).

3 Select the Goto Page tab, type the page number to go to, and click OK.

To go to an adjacent page/master page:

n Switch to the level (page or master page) you want to work on, then click the  Previous Page or 

 Next Page button on the HintLine toolbar.

To go to the first page/master page:

n Switch to the level (page or master page) you want to work on, then click the  First Page button on the HintLine toolbar.

To go to the last page/master page:

n Switch to the level (page or master page) you want to work on, then click the  Last Page button on the HintLine toolbar.

You may not want master page objects to appear on a particular page (for example, a page number on a "new chapter" page). 

To hide master page objects on a particular page:

1 Choose Master Page Objects... from the View menu.
OR

Double-click the Current Page box at the left of the HintLine toolbar (or click either  Page Manager button on the Studio's 
Pages tab), then select the Set Master Page tab.

2 Select a page or range of pages from the "Document page(s)" list, and uncheck Show master page objects.

Note: The same dialog also lets you reassign master pages to specific pages. If you're using more than one master page and 
select a range of pages, be careful not to unintentionally alter your master page assignments. When in doubt, hide objects on 
one master page at a time.



Adding, removing, and rearranging pages

The Studio's Pages tab features two panels, with the thumbnails in the upper panel representing master pages, and those in the 
lower panel representing single publication pages. Using the tab, you can quickly rearrange publication pages using drag-and-
drop, and add or delete either pages or master pages without having to switch to a particular level first. The Page Manager 
provides additional options, such as duplicating a particular page, assigning a specific master page, or adding/deleting multiple 
pages.

Note: If the procedures below don't distinguish between "pages" and "master pages," you can assume they apply to both.

To rearrange pages:

n In the lower panel of the Studio's Pages tab, drag a page thumbnail to a new place in the page sequence.
Note: You can't rearrange master pages, since their order makes no difference. However, you can use the Pages tab to 
assign master pages to pages (see the next topic).

To add a single page/master page:

1 On the Studio's Pages tab, select a page (or master page) by clicking its thumbnail. 

2 To add a page (or master page) before the one selected in a panel, click the  Insert Page button above that panel. 
OR
To add a new page at the end of the publication, first deselect all pages by clicking in the neutral gray region of the lower 
panel, then click the 

 Insert Page button. 
A new page takes the initial master page defined in the publication ("Master 1"). 

n If there's more than one master page, you can assign a particular master page when creating a new page, by dragging from 
that master page thumbnail to the neutral region in the lower panel. The new page is created and assigned to that master 
page.

To change master page assignments later, use the Page Manager as described in the next topic.

Note: The page that's shown as "selected" on the Pages tab is independent of which page you're currently working on.

For more page/master page insertion options:

1 Click the  Page Manager button above the appropriate panel of the Pages tab.
OR
Switch to the appropriate level (see the previous topic), then choose Page... from the Insert menu. 
OR
Navigate to the last page of the appropriate level (see the previous topic), then click the 

 Next Page button on the HintLine toolbar. 
2 In the dialog, select the Insert Page/Master Page tab and specify the following:

· The number of pages to add
· The page before (or after) which pages should be added
· Which master page to assign to the new page
· Whether to duplicate a particular page by copying objects from it

To delete a single page/master page:

1 On the Studio's Pages tab, select the page (or master page) to delete by clicking its thumbnail.

2 Click the  Delete Page button above the appropriate panel to delete the page.

For more page/master page deletion options:

1 Click the  Page Manager button above the appropriate panel.
OR
Switch to the appropriate level and choose Delete Page... from the Insert menu. 

2 In the dialog, select the Delete PageMaster Page tab and specify the following:
· The number of pages to delete
· The page after which pages should be deleted



Assigning master pages

Each new page you add to the publication is assigned a master page (see the previous topic for details on adding pages and 
master pages). If the publication uses more than one master page, you can reassign specific master pages to specific pages at 
any time.

To assign a master page to a page:

n On the Studio's Pages tab, click on the master page thumbnail (in the upper panel) and drag onto the page thumbnail (in the 
lower panel).

Note: Using the Pages tab, it takes two separate drag-and-drop steps to assign a dual master page to both left and right facing 
pages. (See "Master page logic" below.)

OR

1 Click the  Page Manager button in the upper panel of the Studio's Pages tab and select the Set Master Page tab. (You 
can also choose Master Page Objects... from the View menu, or double-click the Current Page box at the left of the HintLine 
toolbar and select the tab.)

2 Select a page or range of pages from the "Document page(s)" list.

3 In the "Uses master page" list, select the master page you want to assign to the selected page(s).

Note: The same dialog also lets you hide master page objects on specific pages. If you select a range of pages, be careful not to 
unintentionally alter this setting for any pages in the range.

Master page logic
The key thing to remember is that each publication page uses only one master page. This holds true regardless of the number of 
master pages in the publication—or the type of master page. If you set up a publication to use facing pages, you can specify 
either a single or dual master page. A dual master page has both a left- and right-side component, allowing you to run elements 
across a spread in the background of the publication. Logically, it takes two separate drag-and-drop steps on the Pages tab to 
reassign a dual master page to both left and right facing pages: one "drop" onto the left page, the other onto the right.

Left and right publication pages can use different master pages if necessary. You can even assign half of a dual master page to 
one side of a double-page spread. For example (see below), a left-hand "body text" page might use the left-side component of 
one master page, while a right-hand "chapter divider" page could use the right side of a different master page.

 Facing pages/Dual master pages



Customizing Page Wizard text

When you create a publication using a Page Wizard, any text you enter in the course of answering the Wizard's questions 
appears in the publication as answer text fields. Answer text, which you can easily edit with the Studio's Wizard tab, behaves 
quite differently from ordinary text. If you don't use Page Wizards, you won't encounter answer text. If you do, your publications 
will generally include a mix of both varieties of text and you'll need to understand both methods of editing.

To learn about editing ordinary text, see the topic Editing text on the page.

To customize Page Wizard text using the Studio's Wizard tab:

1 Click Wizard on the Studio toolbar.

2 In the upper group, click a question category. 

3 In the lower group, review the answer text for the category and retype as needed. 

4 Click anywhere else to insert the changed information into the publication's answer text field(s).

Notes

n There is no Undo for Wizard tab entries—simply retype the entry. 

n If you're editing ordinary text in a publication that contains a mix of ordinary and answer text, you'll notice that you cannot 
select only part of an answer text field. As soon as you click answer text, the whole field highlights—a sure sign that you're not 
dealing with ordinary text! You can use this approach to change the text's character or paragraph properties, or cut/copy/paste 
answer text fields within the document if necessary. However, if you retype over highlighted answer text, it will no longer be an 
answer text field; the newly typed text will be ordinary text, no longer updatable via the Wizard tab. To preserve answer text 
fields, use the steps shown above.

n Many basic answer text items (such as name, address, etc.) are normally recorded as User Details to save you the trouble of 
re-entering them a second time. Via the Set User Details dialog, you can update the information in User Details or include a 
User Detail in any publication.



Importing text from a file

Importing text from a word-processor file is the traditional way to create text content for Desktop Publishing layouts (but you can 
also create a story using WritePlus). If you use your current word processor (such as Microsoft Word) to create the text file for 
your publication, you can import any number of files into one publication. Each file becomes a story consisting of a self-
contained section of text like a single article in a newspaper, which resides in one or more linked text frames. (For an overview 
of how frame text works, see the next topic.) 

Note: Each story is a copy of the text file that you imported, which means that any changes you make in PagePlus only apply to 
the PagePlus story, not the original imported file. This means you cannot damage your word-processor files by importing them 
into PagePlus.

Tip: PagePlus will preserve the formatting of imported word-processor text. However, if you're using your word processor to 
create text specifically for PagePlus, you'll save time by typing as text only, and applying formatting later in PagePlus.

To import text:

1 Choose Text File... from the Insert menu, or right-click an existing frame and choose Text File.... The Import Text dialog 
appears. 

2 Select the format of the source file to be imported and locate the file itself. (See below for details on setting the preferred text 
import format.)

3 Check the "Retain Format" box to retain the source file's formatting styles—that is, if you've defined and applied text styles 
(including font, point size, leading, or color) in the word processor, and want PagePlus to import and convert as much of this 
formatting as possible. Uncheck the box to discard this information. In either case, PagePlus will preserve basic character 
properties like italic, bold, and underline, and paragraph properties like alignment (left, center, right).
For details on how PagePlus handles text styles, see the topic Using text styles.

4 Check the "Ignore Returns" box to ignore returns in the source text—that is, only if the file has been saved with a carriage 
return at the end of every line, and you want to strip off these extra returns. Otherwise, leave the box unchecked.

5 Click OK.

PagePlus will import the designated text into the preselected text object or a new text frame.

Note: Two special options exist to help you fit imported text into a series of frames. AutoFlow can automatically create text 
frames and pages until all the text has been imported; a Registry change is required to activate it. On the other hand, you can 
apply AutoFit (which fits text exactly to the available frame area) at any time after the text has been imported. For details, see 
Fitting text to frames.

For details on changing frame column and margin settings, see the subtopic Frame setup and layout (part of the next topic).

Setting the preferred text import format
PagePlus supports direct text import from a number of major word processing applications, including Microsoft Word, Corel 
WordPerfect, and Lotus Word Pro. Direct import means that in order to import files of a particular format, the word processing 
application itself must be present on your machine. During installation, PagePlus checks for an installed word processor. You can 
change the preferred setting to any of the supported applications.

To designate the preferred text import format:

1 Choose Options... from the Tools menu.

2 On the General page, select your preferred word processor in the "Import text using" drop-down list.

If you find that PagePlus does not list your word processor, or if text import from the designated application fails, choose the 
"Standard Converters" setting, which provides additional formats. If necessary, go back to your word processor and save your 
text file in a format that is supported. Try the following:

n In a Windows word processor, save your file as .RTF (Microsoft Rich Text Format) or as plain text. As a fallback, use cut and 
paste instead.

n In a DOS word processor, save your file as ASCII (plain text).

Word-processing conventions
Certain word-processing conventions can be problematic when files are converted for desktop publishing. Here are some points 
you should be aware of:

Double spaces at the start of a paragraph: Avoid typing multiple spaces. If you want a space (or "indent") at the start of a 
paragraph, choose Tabs and Indents... from the Format menu to specify the first line indent. This can also be saved as part of 
your text styles. Alternatively, you could type a tab character at the start of the paragraph.

Typing returns: When PagePlus imports text, it treats each carriage return as the end of a paragraph. Use returns only when 
you want a new paragraph, and don't insert returns at the end of every line in your word processor; let it wrap text instead. Avoid 
typing multiple returns to get space between paragraphs. It's better to specify "Before" and "After" spacing values in the 
Format/Paragraph... dialog. Again, these values can be saved as part of your style definitions.



Double hyphens for a dash: Typists often enter "--" (two hyphens) as a dash or separator between parts of a sentence. The 
typographic equivalent is an em dash. To insert this character, choose Symbol from the Insert menu and select Em Rule—or 
press Alt and then "0151" on the numeric keypad.

Inch marks as quotes: Most people use the inch mark as opening and closing quotes. Unless you're entering text in a 
typewriter-style font (such as Courier) you should use real quote marks. By default, PagePlus will automatically convert inch 
marks to quotes ("smart quotes"). You can change this setting by unchecking the "Change straight quotes to typographic quotes" 
box on the AutoCorrect page of Tools/Options. For details, right-click the dialog check box.



Understanding text frames 

Typically, text in PagePlus goes into text frames, which work equally well as containers for single words, standalone 
paragraphs, or multipage articles or chapter text. You can also use artistic text (see the next topic) for standalone text with 
special effects, or table text (see Creating text-based tables) for row-and-column displays. 

This extended topic provides an introduction to frame text. To jump to a particular subtopic, click its title below:

What's a text frame? 

Creating frames 

Putting text into a frame 

Frame setup and layout 

How a story flows through a sequence of frames 

Linking frames 

Graphic properties of frames 

What's a text frame?
A text frame is effectively a mini-page, with:

n Margins and column guides to control text flow

n Optional preceding and following frames

n Text and optional inline images that flow through the frame (from the previous frame and on to the next).

The text in a frame is called a story.

n When you move a text frame, its story text moves with it.

n When you resize a text frame, its story text reflows to the new dimensions.

Frames can be linked so that a single story continues from one frame to another. But text frames can just as easily stand alone. 
Thus in any publication, you can create text in a single frame, spread a story over several frames, and/or include many 
independent frame sequences. By placing text frames anywhere, in any order, you can build up newspaper or newsletter style 
publications with many stories flowing from one page to another.

When you select a frame you'll see its bounding box, indicated by a gray border line plus corner and edge handles, and (if you 
clicked with the Pointer tool) a blinking insertion point in the frame's text. In this mode, you can edit the text with the Pointer tool. 
As in a word processor, double-clicking selects a word, and triple-clicking selects a paragraph. (For details, see the topic Editing 
text on the page.)

Text frames behave like other PagePlus objects—you can resize, move, and even crop or rotate them. You can also apply line, 
fill, and transparency properties to frames. For some operations, it's more convenient if you get rid of the text insertion point and 
select only the frame. 

To select only the frame (no insertion point):

n Click the frame's bounding box.

When only the frame is selected, you can move it more easily. And only in this mode can you directly adjust the frame margin 
and column guides (which constrain the flow of text), as described in Frame setup and layout below. 

To move a text frame:

n Drag the frame's bounding box.

OR
n Select only the frame and drag from the inside of the frame.

To resize a text frame:

n In any selection mode, drag a corner or edge handle.



 

Creating frames
You add frames to a page as you would any other object. PagePlus supports a wide variety of frame shapes. You can resize any 
frame, but cannot alter its basic shape.

To create a frame: 

1 For a standard (rectangular) frame, click the     Standard Frame button.
OR
For an irregular frame, click the 

 Shaped Frame button (its icon will display the most recently selected shape) and select a shape from the flyout submenu.
2 Click on the page or pasteboard to create a new frame at a default size. Drag to adjust the frame's dimensions. 

Note: You can use the Update Object Default from the Format or right-click menu to set properties for future new frames you 
create. See Updating and saving defaults.

To delete a frame:

n Select the frame object and press the Delete key. (If there's a selection point in the text, pressing Delete will remove 
characters after the cursor.)

OR
n With or without an insertion point, choose Delete Object from the Edit menu. 

Putting text into a frame 
You can put text into a frame in one of five ways:

1    WritePlus story editor: 
n Right-click on a frame and choose Edit Story (shortcut Ctrl+E) to start WritePlus. 

This opens the PagePlus integrated story editor—useful for typing, formatting, and proofing large amounts of text. If the frame 
already contains text, it is automatically loaded into WritePlus for editing. (See Editing story text with WritePlus.) 

2    Importing text: 

n Right-click on a frame and choose Text File... (shortcut Ctrl+T) to import text. 

If there's an insertion point in existing text, the new text appears at that point. If there's a range of text selected, the new text 
replaces it. If only the frame is selected, the new text is inserted at the beginning of the story.

If you want to create a simple document with just one story running from page to page, use the Text File... command with no 
frame selected. PagePlus automatically adds frames matching the underlying page layouts you've set up. The AutoFlow option 
can add pages as needed, until all your text has been imported.

3    Typing into the frame: 

n Select the Pointer tool, then click for an insertion point to type text straight into a frame, or edit existing text. (See Editing text 
on the page.)

4    Pasting via the Clipboard: 

n Select the Pointer tool and click for an insertion point in the text, then press Ctrl+V. 
Tip: Using the Edit/Paste Special... command gives you a choice of formatting options.

5    Drag and drop:

n Select text (e.g. in a word processor file), then drag it onto the PagePlus page. 

If you drop onto a selected a frame, the text is pasted inline after existing text. Otherwise, a new frame is created for the text.

Frame setup and layout 
The frame layout includes controls how text will flow in the frame. The frame can contain multiple columns. When a frame is 
selected, its column margins appear as dashed gray guide lines. Note that unlike the page margin and row/column guides, which 
serve as layout guides for placing page elements, the frame column guides actually determine how text flows within each frame. 
Text won't flow outside the column guides.

You can drag the column guides or use a dialog to adjust the top and bottom column blinds and the left and right column 



margins.

To edit frame properties directly:
n Select the frame object, then drag column guide lines to adjust the boundaries of the column. 

The illustration above shows how the cursor changes to show when you're (1) over the frame's bounding box or (2) over one of its 
column boundaries. In (3), the left frame margin has been dragged in slightly. Notice how paragraph indents are preserved relative 
to the margin guide.

To edit frame properties using a dialog: 
1 Right-click on the frame and choose Frame Setup....

OR

Select the frame and click the  Frame Setup button on the Frame toolbar.
OR
Choose Frame Setup... from the Format menu. 

2 To change the number of columns, gutter (gap), or left/right frame margins, enter values in the appropriate boxes.

3 To change the column blinds (top and bottom frame margins), click a cell in the table and enter a new value. 
Hint: If the frame has more than one column, you only need to enter top/bottom values for the first one. Then click Top and/or 
Bottom to repeat the entries instantly in the cells below.

 

How a story flows through a sequence of frames 
You can have just one frame on its own, or you can have many frames. Frames can be connected in linked sequences.
The story associated with a given frame sequence flows through the first frame on to the next and keeps flowing into frames in the 
link sequence.
A key difference from a word processor is that PagePlus does not normally add or remove frames according to the amount of text. 
The text simply flows until the text runs out (and some frames are left empty), or the frames run out (and some text is left over).

If there is still more text to go after filling the last frame, PagePlus stores it in an invisible overflow area, remembering that it's 
part of the story text. If you later add more frames or reduce the size of text in a frame, the rest of the story text is flowed in.

If the text runs out before the last frame, you have some empty frames. These frames will be filled with text if you add more text 
to the story, or if you increase the size of the story text.

You can use the PagePlus AutoFit function to scale a story's text size so it fits exactly into the available frames. See Fitting text 
to frames.

PagePlus keepts track of multiple linked frame sequences, and lets you flow several stories in the same publication. The Text 
Manager (accessed via the Tools menu) provides an overview of all stories and lets you choose which one you want to edit. 

Linking frames 
When selected, a text frame includes a Link button at the bottom right which allows you to import text files or control how the 
frame's story flows to following frames. The icon inside each frame's Link button denotes the state of the frame and its story text:

 No Overflow
The frame is not linked to a following frame (it's either a standalone 
frame or the last frame in a sequence) and the end of the story text is 
visible.

 
Overflow
The frame is not linked (either standalone or last frame) and there is 
additional story text in the overflow area.

 
Continued
The frame is linked to a following frame. The end of the story text may 



be visible, or it may flow into the following frame.
Note: The button icon will be red if the final frame of the sequence is 
overflowing, or green if there's no overflow.

There are two basic ways to set up a linked sequence of frames:

n You can link a sequence of empty frames, then import the text. 

OR 
n You can import the text into a single frame, then create and link additional frames into which the text automatically flows. 

Note: When frames are created by the AutoFlow option when importing text, they are automatically linked in sequence.

To create a link or reorder the links between existing frames, you can use the Link button or the buttons on the Frame toolbar. 
Remember to watch the cursor, which changes to indicate these operations...

To link the selected frame to another frame as the next frame:

n Click the frame's Link button.
OR

Select the frame, then click the  Link Frame button.

n Click with the Textflow cursor on the frame to be linked to. Only empty frames are valid frames to link to. 

To unlink the selected frame from the sequence:

n Click the  Unlink Frame button.
OR
Click on the frame's Link button, then click with the Textflow cursor on the same frame. 

Story text remains with the "old" frames. For example, if you detach the second frame of a three-frame sequence, the story text 
remains in the first and third frames, which are now linked into a two-frame story. The detached frame is always empty.

Note: If you click on a frame's Link button, and then change your mind about linking or unlinking, press the Esc key or click on a 
blank area of the page or pasteboard to cancel.

To navigate from frame to frame: 

n Click the  Previous Frame or 

 Next Frame button on the Frame toolbar. 

Graphic properties of frames
Like graphics, frames have line, fill, and transparency properties—initally an outline of zero weight, a clear fill, and transparency 
set to None. As with graphics, you can edit these properties, for example adding a gray or light-colored fill as shading behind a 
frame's text. You can also import images inline with frame text, and wrap text around any type of frame. 
Note that the text inside a frame can take a solid color, but doesn't have line and fill properties as such—for fancy line/fill effects with 
text, you can employ artistic text (see the next topic).

For details on changing a frame's line, fill, or transparency properties, see the topics Setting line properties, Applying solid colors, 
Working with gradient and Bitmap fills, and Working with transparency effects.

For details on placing images inline with text, see Importing images.

For details on wrapping text around a frame, see the topic Wrapping text to an object.



Using artistic text

Artistic text is standalone text you type directly onto a page. Especially useful for headlines, pull quotes, and other special-
purpose text, it's easily formatted with the standard text tools but has some artistic advantages over frame text. For example, you 
can initially "draw" artistic text at a desired point size, and drag it to adjust the size later. And unlike the characters in a text 
frame, an artistic text object can take different line styles, fills (including gradient and Bitmap fills), and transparency for stunning 
pictorial effects. You can even flip artistic text and it will remain editable!

 
Here are other similarities and differences between frame text and artistic text.
n With artistic text, you can vary character and paragraph properties, apply named text styles, edit text in WritePlus, access it 

with the Text Manager, track font usage with the Resource Manager, embed inline images, apply filter effects, and use 
proofing options such as AutoSpell/Spell Checker, Proof Reader, and Thesaurus. 

n However, you cannot import text from a file, or wrap artistic text around objects. And because artistic text doesn't flow or link 
the way frame text does; the Frame toolbar's text-fitting functions aren't applicable.

To create artistic text:

1 Choose the  Artistic Text Tool from the Tools toolbar.

2 Click anywhere on the page for an insertion point using a default point size, or drag to specify a particular size as shown here.

                      

3 Set initial text properties (font, style, etc.) as needed before typing, using the Text toolbar, Format menu, right-click menu 
(choose Text Format), and/or Attributes tab.

4 Type normally to enter text.

Notes: 
n You can also enter new artistic text by pasting from the Clipboard at the insertion point. 

n If you're having trouble seeing the artistic text cursor, you may wish to change your Windows setting for "Application 
Background Color," which determines the pasteboard color.

n Artistic text shares default properties with frame text and table text. The "extra" properties of artistic text, such as line and 
gradient fill, are also included in the text defaults, but of course they will only show up on artistic text objects. For details, see 
Default text properties. 

n If you output your publication as a Web site, any artistic text that uses a non-solid fill, a line style other than "None," a filter 
effect, transparency, or resizing will be exported as a graphic. Other artistic text will be exported as text.

Once you've created an artistic text object, you can select, move, resize, delete, and copy it just as you would with a text frame. 

To resize or reproportion an artistic text object:

n Drag the object's handles. Normally the object's proportions are maintained. To resize freely, hold down the Shift key while 
dragging.

Note: Using this method actually scales the graphic object rather than altering its point size. Thus the Text toolbar "Point Size" 
readout will stay the same, but the horizontal and vertical "Scale" values on the HintLine will change.

To edit artistic text:

n Select a range of text by dragging. Double-click to select a word, or triple-click to select a paragraph.

Now you can type new text, apply character and paragraph formatting, edit the text in WritePlus, apply proofing options, and so 
on. (Follow the links above for details on specific editing procedures.)

Note: With artistic text, the vertical alignment setting anchors a particular part of the object—for example, a "top" setting 
anchors the top line and forces new text to come in below, while a "bottom" setting anchors the bottom (most recent) line and 
pushes previous lines up as you type new lines.

To apply a solid color line or fill:

n Select a range of artistic text, or the entire object, then click the Studio's Attributes tab.



n To set line properties such as weight and style, use the Line panel or the Format/Line and Border... command.
For details, see Setting line properties.

n To apply a solid color, use the Color panel's Line button or Fill button, or the Format/Fill... or Format/Line and Border... 
commands. 

For details, see Applying solid colors.

To apply a gradient or Bitmap fill:

n Select a range of artistic text, or the entire object, then use the Fill tool, the Studio's Attributes tab (Fill panel), or the 
Format/Fill... or Format/Line and Border... commands. 

For details, see Working with gradient and Bitmap fills.

To apply transparency:

n Select a range of artistic text, or the entire object, then use the Studio's Attributes tab (Transparency panel), or the 
Format/Transparency command. 

For details, see Working with transparency effects.



Creating text-based tables

Tables are ideal for presenting text and data in a variety of easily customizable row-and-column formats. 

 
Each cell in a table behaves like a mini-frame. There are many similarities (and several key differences) between frame text and 
table text.
n With table text, you can vary character and paragraph properties, apply named text styles, embed inline images, apply filter 

effects, fills and transparency at the cell level, track font usage with the Resource Manager, and use proofing options such as 
AutoSpell/Spell Checker, Proof Reader, and Thesaurus.

n However, tables don't support importing text from a file, editing text with WritePlus or viewing it with the Text Manager, or 
wrapping text around objects. And table text doesn't flow or link the way frame text does; the Frame toolbar's text-fitting 
functions aren't applicable.

n Tables also have a number of unique features like AutoFormat, QuickClear, and QuickFill for rapid editing and revision. See 
below for details.

For advanced spreadsheet-editing features, you might also consider using the TablePlus utility included with PagePlus. Note that 
TablePlus objects are incompatible with text-based tables.

To create a table:

1 Choose the  Table Tool from the Tools toolbar and click on the page or pasteboard, or drag to set the table's dimensions. 

The Create Table dialog appears with a selection of preset layouts.

2 Step through the list to preview the layouts and select one. To begin with a plain table, select Default. 

3 Click OK.

The new table appears on the page.

Once you've created a table, you can select, move, resize, delete, and copy it as an object, just as you would with a text frame.

To manipulate the table object:

n To select the table object, click its bounding box. Now you can resize it like a text frame by dragging a node, or move it by 
dragging an edge.

n To delete the table object, select it and press the Delete key, or select any part of its text and choose Delete from the Table 
menu (Table/Delete from the right-click menu), then Table from the submenu. You can also choose Delete Object from the 
Edit menu.

n To duplicate the table object and its text, first make sure no text is selected (an insertion point is OK), then use the Copy and 
Paste commands. As a shortcut, select the object and drag with the Ctrl key down.

Other operations involve selecting text within the table, or parts of the table. Within each cell, you can click for an insertion point 
or drag to select a range of text. You can also drag to select multiple cells, rows, or columns, which in effect selects all the text in 
that region. Once you've made a selection, you can edit text in the table and modify the structure and appearance of the table 
and/or its components.

To select and edit text in cells, rows, and columns:

n To select a cell, click for an insertion point or drag to select text. To select more than one cell, click in one cell and drag across 
the others.

                     

n To move between cells, use the keyboard arrow keys. You can also press Tab to move to the cell in the next column, and 
Shift+Tab to move to the cell in the previous column. 

n To enter text, simply type at the insertion point. You can also use the QuickFill feature (see below). Cells expand vertically as 



you type to accommodate extra lines of text. To enter a Tab character, press Ctrl+Tab.

n To select a row or column, click its control button along the left or top of the table. To select more than one row or column, drag 
across their control buttons. You can also select cell(s) first, then choose Select from the Table menu (Table/Select from the 
right-click menu), then either Row or Column from the submenu.

n To select all text (all rows and columns), choose Select from the Table menu (Table/Select from the right-click menu), then All 
from the submenu.

n To delete selected text, press the Delete key. This won't alter the table structure; all rows and columns remain. You can also 
use the QuickClear feature (see below).

n To copy selected text, use the Copy command, click for a new insertion point, then use the Paste command. You can also use 
the QuickFill feature (see below).

n To format selected text, apply character and paragraph properties (see the next topic) or text styles as with any text.

n Table text shares default properties with frame text and artistic text. For details, see Default text properties. 

To change the table's structure and appearance:

n To adjust row or column size, drag the line separating control buttons. Note that you can adjust a row's height independent of 
the amount of text it contains.

n To delete one or more rows or columns, select them (or cell text) as described above, then choose Delete from the Table 
menu (Table/Delete from the right-click menu), then either Row(s) or Column(s) from the submenu.

n To insert new rows or columns, select one or more cells as described above, then choose Insert from the Table menu 
(Table/Insert from the right-click menu), then either Rows... or Columns... from the submenu. In the dialog, specify how 
many to add, and whether to add them before or after the selected cells.

n To use style presets to customize the table's appearance, choose AutoFormat... from the Table menu (Table/AutoFormat... 
from the right-click menu). The dialog presents a list of sample tables, which differ in their use of Lines (inner and outer cell 
borders), Fill (cell fill), Font (bold, italic, etc.), and Alignment (left, center, etc.). You can pick any sample and use the 
checkboxes to specify which of the sample's attribute(s) to apply to your actual table. This lets you "mix and match," for 
example by applying (in two passes) the Color from one sample and the Font from another. You can choose Default to restore 
plain formatting.

n To customize the appearance of one or more cells "by hand," select them and choose Cell Properties... from the Table menu 
(Table/Cell Properties... from the right-click menu). Use the dialog's Border, Fill, and Transparency tabs to apply cell 
formatting, then click OK. 
Note: On the Border tab, you can select from preset edge line configurations, then click in the Edge Selection box to add 
additional lines as needed. Shift-click to toggle the selection. To edit the style of specific lines, click to deselect any you don't 
want to change (remaining arrows designate the selected edges), then click the Line Style... button and set options. Click the 
empty preset to remove all lines.
Tip: Fill properties apply to cells, not to the table as a whole. To give the whole table the appearance of a unified fill, place a 
rectangular shape behind an unfilled table and fill the shape.
Tip: If you use the Studio to change the line color of selected cells, you can choose whether to change just the outer line of 
the selection, or include interior lines as well. Right-click a solid color sample in the Studio's Attributes tab Color panel and 
choose either Apply to Outer Line or Apply to Line.

n To merge cells into larger cells that span more than one row or column (for example, a column head), select a range of cells 
and choose Merge Cells from the Table menu (Table/Merge Cells from the right-click menu). The merged cell displays only 
the text originally visible in the top left selected cell. The original cells and their text are preserved, however—to restore them, 
select the merged cell and choose Separate Cells from the Table menu (Table/Separate Cells from the right-click menu).

Using QuickClear and QuickFill
QuickClear and QuickFill are handy shortcuts built into tables. Both employ the small "QuickFill handle" which you may have 
noticed at the lower right of each selected cell (or range of cells).

QuickClear lets you instantly clear a range of cells.

To QuickClear a range of cells:

1 Select the range to be cleared.

2 Drag the QuickFill handle upward until no cells are specified.

QuickFill lets you quickly enter a standard sequence of numbers or entries, for example the months of the year, the days of the 
week, or any arithmetic progression (see below). You can also use QuickFill to replicate one cell's contents over a range of cells.

To QuickFill a sequence of entries:

1 Type the first entry of the sequence into the starting cell.

2 Drag the selected cell's QuickFill handle out to the range of cells to be quickfilled, as shown below. The function works both 
backwards and forwards!



If there are not enough items in the QuickFill sequence, the entries wrap back to the beginning value in the sequence.

To replicate a cell's contents over a range of cells:

1 Click to select the cell whose contents you want to replicate.

2 Drag out the cell's QuickFill handle over the range you want to fill.

                     

The sequences that QuickFill knows about are:
n January, February, March, ...

n JANUARY, FEBRUARY, MARCH, ...

n january, february, march, ...

n Jan, Feb, Mar, ...

n JAN, FEB, MAR, ...

n jan, feb, mar, ...

n Monday, Tuesday, Wednesday, ...

n MONDAY, TUESDAY, WEDNESDAY, ...

n monday, tuesday, wednesday, ...

n Mon, Tue, Wed, ...

n MON, TUE, WED, ...

n mon, tue, wed, ...

n a, b, c, ...

n A, B, C, ...

n Any arithmetic progression, that is, any series of numbers with a common difference.

For numerical sequences, if the starting selection contains two or more cells, QuickFill uses the difference between them as the 
common difference. For example, if the first two cells contain the numbers 10 and 20, then the 'quickfilled' sequence would be: 
10, 20, 30, ... If only a single number is specified, then the common difference between the numbers will be 1.

Similarly, for non-numerical sequences, you can specify a step between any entries, for example, enter "January" in the first 
cell, "March" in the second. QuickFill will place every other month in the sequence: "January, March, May, July, ..."

You can type also phrases including known sequences, and QuickFill will fill the sequence, along with the other words. For 
example, type "Week 1" and QuickFill would give you the sequence "Week 1, Week 2, Week 3, ..." or "Jan Sales" would give: 
"Jan Sales, Feb Sales, Mar Sales, ..."



Editing text on the page

You can use the Pointer tool to edit frame text, table text, or artistic text directly. For editing longer stories, and for more 
advanced options, choose WritePlus (see the next topic).

Note: To edit answer text stored as fields in a Page Wizard publication, use the Studio's Wizard tab.

Selecting and entering text
To edit text on the page:

n Select the Pointer tool, then click or drag in the text object. A standard insertion point appears at the click position, or a range 
of text is selected, ready for the text to be edited. (If a range of text highlights instantly, or you can't click inside a range of text, 
you're probably dealing with "answer text"—see the note above.)
Tip: You can double-click to select a word, or triple-click to select a paragraph.

To start a new paragraph:
n Press Enter. 

To start a new line within the same paragraph (using a "line break" or "soft return"):

n Press Shift+Enter.

The following three options apply only to frame text. You can use these shortcuts or choose the items from the Insert/Break 
submenu.

To flow text to the next column (Column Break):

n Press Ctrl+Enter.

To flow text to the next frame (Frame Break):

n Press Alt+Enter.

To flow text to the next page (Page Break):

n Press Ctrl+Shift+Enter.

To repeat a text action:

n Choose Repeat from the Edit menu, or press Ctrl+Y.

For example, if you've applied new formatting to one paragraph, you can click in another paragraph and use the Repeat 
command to apply the same formatting there. 

Setting paragraph indents
When a text object is selected, markers on the horizontal ruler indicate the left indent, first line indent, and right indent of the 
current paragraph. You can adjust the markers to set paragraph indents, or use a dialog.

n The left indent is set in relation to the object's left margin.

n The first line indent is in relation to the left indent.

n The right indent is in relation to the object's right margin.

For details on setting frame margins, see the subtopic Frame setup and layout.

To set the indents of the current paragraph:

n Drag the appropriate ruler marker(s).

OR



n To adjust indent settings numerically, choose Character... from the Format menu (or Text Format/Character... from the right-
click menu), then click the Details button. You can enter values for Left, Right, 1st Line, or Hanging indents.

Setting tab stops
To set a tab stop:

1 Select the paragraph(s) in which you want to set tab stops.

2 Click the ruler intersection button until it changes to the type of tab you want: (Left, Center, Right, or Decimal).

3 Click on the horizontal ruler where you want to set a tab stop.

n To move a tab stop, click and drag it to a new ruler position.

n To delete a tab stop, click and drag it off the ruler.

Note: If you want to set precise measurements for tabs, right-click the frame and choose Text Format, then select Tabs... from 
the submenu.

Setting text properties
To format characters and paragraphs, use the controls on the Text toolbar, the ChangeBar, and/or the commands available on 
the Format menu. As a shortcut to these commands, right-click on text and choose Text Format, then select from the submenu. 

For a table summarizing text properties, see the topic Setting text properties. For topics covering specific formatting operations, 
expand the Contents heading How to Format Characters and Paragraphs.

Using text styles
PagePlus lets you define named text styles that establish the main text formatting to be used in your publication. A text style is a 
set of character and/or paragraph attibutes saved as a group. When you apply a style to text, you apply the whole group of 
attributes in just one step. A paragraph style is a complete specification for the appearance of a paragraph, including all its font 
and paragraph format attributes. A character style includes only font attributes (such as font name, point size, bold, italic, etc.), 
and you apply it at the character level—that is, to a range of selected characters—rather than to the whole paragraph.

For details on working with text styles, see the topic Using text styles.



Editing story text with WritePlus

WritePlus is the story editor built into PagePlus. For certain tasks, such as viewing and editing the full text of an entire story that 
may be spread over many frames or pages, it's much more convenient than editing text on the page (see the previous topic). 
And for other tasks, such as exporting story text or marking index entries, it's essential!
Note: You can also use WritePlus to edit artistic text, but not table text.

To launch WritePlus:

n Right-click on a text frame or artistic text object and choose Edit Story (or press Ctrl+E or choose Edit Story from the Edit 
menu). WritePlus opens with the object's story text.

OR
n Choose Text Manager... from the Tools menu. Select a story and click Edit. WritePlus opens with the specified text.

The WritePlus environment
WritePlus opens in a separate window that shares many of the standard PagePlus menus and toolbars. You can resize the 
window or use the commands on the Window menu to arrange it in relation to the main publication window. As you make 
changes in WritePlus, story text in the main window updates instantly.

For tooltips and HintLine information while using WritePlus, move the mouse over the various WritePlus elements. 

The WritePlus workspace can have one or two windows. Initially, you'll see the Text Entry window. You can also display a 

Stylenames window on the left by clicking the  Stylenames button. 

 
WritePlus opens in Layout Mode, displaying text with formatting applied. You can quickly switch to Draft Mode, which doesn't 
display formatting variations. 

To switch between Draft Mode and Layout Mode: 

n Click the  Formatting button on the Story toolbar.

The Story toolbar, unique to WritePlus, includes other tools to assist you in working with story text. For example, the Story list 

lets you select the story to be edited, or change the name of a story by typing in the list. Click the  Word Count button to run 
a wizard that counts total words or characters, or the number of occurrences of a specified word. For details on individual tools, 
see the Visual Reference topic on the Story toolbar. 

Text editing procedures in WritePlus are the same as you'd use when editing text on the page (see the previous topic). Use the 
basic controls on the Text toolbar to change the text font and size or apply a font style to selected text. To review text properties, 
see the next topic.

Note: Blue text between angled brackets is field text. <Company address>, for example, is probably an "answer text" field in 
a Page Wizard publication. Other examples might include date or time fields, or MailMerge fields. You can't alter the actual text of 
a field using WritePlus, but you can select a field and change its formatting or style properties.

To close WritePlus and return to PagePlus:

n Click the  Finish button or the window's 

 Close button.



Setting text properties

PagePlus gives you a high degree of typographic control over characters and paragraphs, whether you're working with frame 
text, table text, or artistic text. To review standard techniques for editing text, see the topics Editing text on the page and Editing 
story text with WritePlus. 

Consult the summary table below for links to details on specific character and paragraph properties.

To apply basic text formatting:

1 Select the text.

2 Use buttons on the Text toolbar to change font, point size, font style, and paragraph alignment.
OR
Right-click the text and choose Text Format, then select from the submenu: Character..., Paragraph..., Tabs..., Bullets and 
Numbering..., or Drop Cap..., Kern, or Vertical Alignment. (You can also select these items from the Format menu.)
OR
Change font using the Font   panel   on the Studio's Attributes tab.
OR
Use the ChangeBar to adjust special properties, including point size, width, letterspacing (tracking), leading, and advance. 

Default text properties
Default text properties are the settings used for text you type into any new text object, whether it's in a frame, a table that uses 
the "Default" style, or artistic text. You can change these settings directly from selected text, or using the Text Style Palette. The 
Palette has the advantage of letting you review all the settings at a glance. (For more on setting defaults, see Updating and 
saving defaults.) 

To change default text properties:

1 Create a single sample of text and fine-tune its properties as desired—or use existing text that already has the right properties. 

2 Select the text or container and Update Text Default from the Tools or right-click menu.

OR
1 Choose Text Style Palette... from the Format menu.

2 Click Default Text, then click Modify... to view current settings.

3 Use the Attributes button to alter character, paragraph, or other properties.

Note: The "extra" properties of artistic text, such as line and gradient fill, are also included in the text defaults, but of course they 
will only show up on artistic text objects.

Text Properties Summary
Below, you'll find an at-a-glance table of most text properties you can control in PagePlus, with a brief description plus links to the 
specific tool(s) that adjust each property. Click the links to access the Visual Reference entries for the Format (or right-click) 
menu, Text toolbar, Studio Font panel, and ChangeBar. See the Notes below the table for additional options and details. 
Note: Many options are also available on the right-click menu for text objects (right-click, then choose Text Format to see the 
submenu).

Character
Property: Definition / Options: Set using:

Font 
(type face)

A particular rendering of a character set 
that uses a consistent design. 

Note: PagePlus includes over 400 
TrueType fonts. You can install them 
from the Serif/Fonts folder of the 
Program CD, using the Control 
Panel/Fonts option from the Windows 
Start Menu.

Studio (Attributes tab, Font 
panel) 

Format/Character/Font 

Text toolbar 

Point size, 
Width

Point size: Vertical text measure
(1 point = 1/72 inch)

Width: Horizontal text measure

Format/Character/Font 

Text toolbar

ChangeBar 

Font style Regular, italic, bold, bold italic Format/Character/Font 

Text toolbar

Uppercase None, all caps, small caps Format/Character/Font 



Color, shading Various effects Format/Character/Font 

Studio (Attributes tab, Color 
panel)

Effects Underline, outline, single/double 
strikethru

Format/Character/Font 

Letterspacing Regular spacing between letters in a 
paragraph: normal, expanded, 
condensed
(See Adjusting letterspacing and 
kerning))

ChangeBar

Format/Character/Character 
Spacing 

Kerning Spacing between one pair of characters
(See Adjusting letterspacing and 
kerning))

Format/Character/Character 
Spacing 

Position Subscript, superscript; raised, lowered Format/Character/Character 
Spacing 

Advance Position of character in relation to 
baseline (line on which text appears to 
sit)

ChangeBar

Paragraph
Property: Options / Description: Set using:

Paragraph 
alignment

Left, right, centered, justified Text toolbar

Format/Paragraph/Align 

Vertical
alignment

Top, center, bottom, justified
(see Note below)

Format/Vertical Text Alignment

Line spacing 
(Leading)

Distance from one text baseline to the 
next: Single, 1.5, double, triple, 
multiple, at least, exactly

Format/Paragraph/Spacing 

ChangeBar

Tab settings Tab stop positions, alignment, leader Ruler

Format/Tabs 

Indents Left, right, hanging Ruler 

Format/Paragraph/Align 

Bullets & 
Numbering

Paragraph bullet character, font, 
indents; numbering format, 
punctuation, indents
(See Creating a bulleted or numbered 
list))

Format/Bullets & Numbering 

Space 
before/after 

Offset between one paragraph and 
preceding & following paragraphs

Format/Paragraph/Spacing 

Word spacing Minimum, maximum, and optimum 
values for automatic word spacing in a 
text block

Format/Paragraph/Spacing 

Hyphenation Number of successive hyphens, hot 
zone, Auto hyphenation settings
(See Using hyphenation)

Format/Paragraph/Hyphenation

Breaks Pagination settings: Keep together, 
Keep with next, Widow/Orphan 
control, Page break before 

Format/Paragraph/Breaks 

Ruled lines 
above/below

Ruled lines: Left/right indent and gap 
(See Creating ruled lines)

Format/Paragraph/Line 

Other properties



n Characters in artistic text objects (but not in frames or tables) can take line, gradient, and Bitmap fill properties. 

n Filter effects such as drop shadow can be applied to any kind of text object, and they apply to all the text in the container (i.e. 
frame or table cell).

n Vertical alignment applies to all the text in a container. For frames and table cells, it moves existing text to the top, bottom, or 
center of the container. For artistic text, the setting anchors a particular part of the object—for example, a "top" setting anchors 
the top line and forces new text to come in below, while a "bottom" setting anchors the bottom (most recent) line and pushes 
previous lines up as you type new lines.

n Some of the more unusual text properties in the above list work fine on the printed page, but aren't supported in Web 
Publishing mode, owing to HTML limitations. For a complete list of these trouble spots, see the topic Automatic layout 
checking.



Using text styles

It's a good idea to establish the main text and graphic formatting to be used in your publication early in the creative process. 
PagePlus facilitates this by letting you define named text styles, which can be applied to frame text, table text, or artistic text. A 
text style is a set of character and/or paragraph attibutes saved as a group. When you apply a style to text, you apply the whole 
group of attributes in just one step. For example, you could define named paragraph styles for particular layout elements, such 
as "Heading," "Sidebar," or "Body Text," and character styles to convey meaning, such as "Emphasis," "Price," or "Date 
Reference." Using styles not only speeds the task of laying out a publication but ensures consistency and ease of updating.

To jump to a particular subtopic, click its title below:

Paragraph styles and character styles

Working with named styles

Importing styles

Using special styles for a Table of Contents or Index

Paragraph styles and character styles
A paragraph style is a complete specification for the appearance of a paragraph, including all its font and paragraph format 
attributes. Note: Every paragraph in PagePlus has a paragraph style associated with it. 

n PagePlus includes one built-in paragraph style called "Normal," with a specification consisting of generic attributes including 
left-aligned, 12pt Times New Roman. Initially, the "Normal" style is the default for any new paragraph text you type. You can 
modify the "Normal" style by redefining any of its attributes, and create any number of new styles having different names and 
attributes. 

n Applying a paragraph style to text updates all the text in the paragraph except sections that have been locally formatted. For 
example, a single word marked as bold would remain bold when the paragraph style was updated.

A character style includes only font attributes (such as font name, point size, bold, italic, etc.), and you apply it at the character 
level—that is, to a range of selected characters—rather than to the whole paragraph. 

n Typically, a character style applies emphasis (such as italics, bolding or color) to whatever underlying font the paragraph 
already uses; the assumption is that you want to keep that underlying font the same. That's why PagePlus includes a built-in 
character style with the name "Default Paragraph Font," which has no specified attributes but basically means "whatever 
font the paragraph style already uses." Suppose a paragraph uses a style called "Body," and the "Body" style uses regular 
10pt Arial. Then the "Default Paragraph Font" style for that particular paragraph means regular 10pt Arial. 

n The "Default Paragraph Font" style comes in handy if you have applied local formatting but then decide to restore the original 
text attributes for the paragraph. (You can think of it as a sort of "Revert to Unaltered Text" command.) Let's take the above 
example of a paragraph using the "Body" style, and suppose several words have been bolded. As noted earlier, reapplying the 
"Body" style to the paragraph would not undo the local bold marking. However, selecting the paragraph and applying the 
"Default Paragraph Font" style would set all the text back to regular 10pt Arial. 

n As with paragraph styles, you can define any number of new character styles using different names and attributes. Custom 
character styles don't usually include a specific font name or point size, but there's no rule against including them. 

 

Working with named styles

The named style of the currently selected text appears in the     Styles box on the Text toolbar. The box may show a character 
style (if one is applied locally); otherwise it indicates the paragraph style. You can use either the Styles box or a dialog to apply a 
particular style to existing text, modify an existing style, or define a new style. 

To apply a named style:
1 Using the Pointer tool, click in a paragraph (if applying a paragraph style) or select a range of text (if applying a character 

style).
Note: If you apply a paragraph style, it will be applied to the whole paragraph regardless of the amount of text selected. If 
you've selected text in more than one paragraph, the change takes place in all selected paragraphs.

2 Click the down arrow on the Styles box and select the style name in the drop-down list.
OR
Choose Text Style Palette... from the Format menu, select a style name, and click Apply. The paragraph or selected text 
takes on the properties of the named style.

To update a named style using the properties of existing text:

1 Make any desired changes to some text that uses the named style as shown in the Styles box.

2 Right-click on the changed text and choose Update Text Style (or choose Update Text Style from the Format menu).
OR
Click the arrow on the Styles box and select the current style name again from the list. Click OK to confirm the option to 
"Update the style to reflect recent changes."



All text using the named style, throughout the publication, takes on the new properties.

To define a new style using the properties of existing text:

1 Format the text as desired. 

2 To define a character style, select a range of reformatted text. To define a paragraph style, deselect text but leave a blinking 
cursor (insertion point) within the newly formatted section.

3 Type a new style name into the Styles box and press Enter.

The new style is defined with the properties of the selected text.

Note: New styles in PagePlus are actually just modified styles, stored under new names. Every new style is derived from a 
previously defined base style, and so consists of all the base style's unchanged attributes as well as any attributes you've 
redefined. 

Tip: The Text Style Palette's tree menu makes clear the hierarchical relationship between styles in your publication. Because 
style names are displayed alphabetically in the Styles box, you'll find it helpful to assign new style names that will keep related 
styles clustered in the list, for example "Body,", "Body-Small," and "Body-Large," or "Heading 1," "Heading 2," and "Heading 3." 

To modify an existing style or define a new one using a dialog:

1 Choose Text Style Palette... from the Format menu.

2 To modify an existing style, select the style name and click Modify....
OR
To create a new style, click Create....

3 Use the Style Properties dialog to define (or change) the style name, base style, and following style. Click the Attributes 
button to access dialogs that let you specify any text attributes you want to include in the style definition. 

4 Click OK to accept style properties, or Cancel to abandon changes.

5 Click Apply to update text, or click Close to maintain the style in the publication for future use.

Tip: When you define a character style, PagePlus only records attributes that differ from the default values used to initialize or 
"seed" the Style Properties dialog. For example, if the seeded value is 12pt, PagePlus won't include a point size in the new 
character style unless you choose a value other than 12pt. So what if you want to include 12pt in your style definition? Here's a 
solution: (1) In the dialog, change the attribute to some other value and click OK. This creates a temporary, interim style. (2) 
Immediately click Modify and return to the dialog, which is now seeded with the interim value. (3) Now you can select the value 
you really want, and click OK again.

To import one or more styles from another PagePlus file:

1 Choose Text Style Palette... from the Format menu. 

2 Click the Import... button and use the dialog to locate the file from which styles should be imported, and the specific style(s) to 
be imported.

Note: Normally, new or updated styles are in effect only for the current publication; they are saved with the publication, but don't 
carry over to new publications. You can even save an empty document and the defined styles will be saved along with it! If you 
wish, you can use Tools/Save Defaults... to record the set of styles (along with other defaults) as a global setting so it will 
remain in effect for future publications. For information, see Updating and saving defaults.

 

Importing styles
When you use the Insert/Text File... command to import text from a word-processor file, you can choose whether or not to retain 
the source file's named styles. 
n Check Retain Format in the Import Text dialog if you want PagePlus to import and retain these styles. Any text not tagged 

with a style will be marked with the "Normal" style as used in your publication.

Note: If duplicate style names exist but the underlying styles are different, the duplicate imported style will be renamed (for 
example, from Normal to Normal 1). New styles will be added to those already in the Styles list. Use the Text Style Palette 
(see above) to review the properties of imported text styles.

n Uncheck Retain Format to discard styles; PagePlus will mark all text with the "Normal" style, as for unstyled text in the case 
above. 

 

Using special styles for a Table of Contents or Index
The Table of Contents Wizard (Insert/Table of Contents...) helps you create a table of contents with a title and first- and second-
level headings derived from named styles in your publication. PagePlus includes three built-in text styles intended specifically for 



table of contents preparation: Contents-Title, Contents-1st, Contents-2nd. Using the Wizard, you'll specify which named styles 
should map to the three Contents styles. For example, you could map all text using the Heading style to Contents-1st. You can 
update the Contents styles as needed. 

For details, see Creating a table of contents.

PagePlus includes four built-in text styles intended specifically for use in an index: Index-Main, Index-Separator, Index-Sub, and 
Index-Title. You can update these Index styles as needed.

For details, see Creating an index.



Adjusting letterspacing and kerning

Letterspacing (tracking)
The spacing between characters in a paragraph can have a subtle effect on the reader. PagePlus lets you experiment with the 
letterspacing of text. The normal value is expressed as 0%. Increase the value to spread text apart, and reduce it to tighten 
letterspacing. 

To adjust letterspacing between characters:

1 Select a range of text with the Pointer tool.

2 Display the ChangeBar and choose a value from the  Letterspacing drop-down list box, or type in a new value.
OR
Right-click the text and choose Text Format/Character... (or choose Character... from the Format menu), then select the 
Character Spacing tab. Set the Spacing value to "Expanded" or "Condensed," and select a point value in the list. To enter a 
relative (percent) value, uncheck the Absolute box. 

Note: In Web Publishing mode, letterspacing variations are preserved when you publish the Web page.

Kerning
Kerning is normally applied where two large, adjacent characters look over- or under-spaced due to the shape of the characters, 
and is used to reduce or increase the space between the pair of characters.

For example, the letters 'A' and 'V' look over-spaced when 
placed adjacent to each other.

Kerning solves this problem by bringing the two letters closer 
together.

To adjust kerning between a letter pair:

1 Using the Pointer tool, click between the two characters for an insertion point.

2 To increase space (positive kerning), press Ctrl+Alt+'+'.
To decrease space (negative kerning), press Ctrl+Alt+'-'. 

OR
Choose Kern... from the Format menu. You'll see a submenu to let you adjust the spacing. Choose Custom to enter a kern 
value specified as a percentage of the text size.

Typically the advantages of kerning are only noticeable on larger text, so the most detailed attention is applied to kerning when 
creating display text: headlines or text logos. As a rule of thumb, you should apply pair-kerning to text over 16 points. You can 
turn auto pair-kerning on or off, and change the point size above which it is applied.

 

To set the automatic pair kerning value:

1 Right-click the text and choose Text Format/Character... (or choose Character... from the Format menu), then select the 
Character Spacing tab. 

2 To turn automatic pair kerning on, check the Auto kerning box. Uncheck to turn it off.

3 To change the minimum point size for automatic pair kerning when it is switched on, click the nudge buttons or enter a new 
value in the box.

Note: Auto pair kerning will only have an effect on text which uses a TrueType font containing "pair kerning" information.



Fitting text to frames  

To review the basics of frame text, see Understanding text frames, and in particular the subtopic How a story flows through a 
sequence of frames.

Fitting story text precisely into a sequence of frames is part of the art of laying out publications. 

If there's too much story text to fit in a frame sequence, PagePlus stores it in an invisible overflow area and the Link button on 

the last frame of the sequence displays . You might edit the story down or make more room for it by adding an extra frame or 
two to the sequence. 

If there's too little text, on the other hand, you'll have some empty frames, and may need to fill the blank space with additional 
graphics or text.

As your layout progresses, you can adjust frames and story text so you get closer and closer to a perfect fit.

The Frame toolbar includes several tools that can simplify the task of fitting text to frames:

AutoFit
Click to scale the story's text size so it fits exactly into the 
available frames. You can use this early on, to gauge how the 
story fits, or near the end, to apply the finishing touch. AutoFit first 
applies small point size changes, then small leading changes, 
then adjustments to the paragraph space below value, until the 
text fits. Other settings are not affected. (Also see Note below.)
Tip: You can also press Ctrl+Alt+X to apply AutoFit.

Enlarge Story Text
Click to increase the story's text size one increment. Double-click 
for a bigger increase.

Shrink Story Text
Click to reduce the story's text size one increment. Double-click for 
a greater reduction.

AutoFlow
When importing text, it's a good idea to take advantage of the AutoFlow feature, which will automatically create text frames and 
pages until all the text has been imported. This way, enough frames are created to display the whole story. Then you can gauge 
just how much adjustment will be needed to fit the story to the available "real estate" in your publication. You can make the major 
changes first, then proceed to the fine-tuning.

 If you're comfortable altering Registry settings, you can change whether PagePlus presents the "Do you want to...?" dialogs for 
AutoFit and/or AutoFlow each time you import a text file. Run REGEDIT and drill down to:
                HKEY_CURRENT_USER\Software\Serif\PagePlus\8.0\Attributes\

Then adjust the data values for "Text Import Autofit" and/or "Text Import Autoflow" as follows:

                0 - No dialog choice, no action
                1 - No dialog choice, always AutoFit or AutoFlow
                2 - Present dialog choice

The defaults are "0" for AutoFit and "2" for AutoFlow.



Wrapping text to an object

PagePlus lets you wrap frame text (not artistic text or table text) around the contours of an object automatically. Usually, this 
means wrapping text to a picture that overlaps or sits inside a text frame. But you can wrap frame text around an artistic text 
object, around a table or another frame, or even flow text inside a graphic (a circle, for example). Wrapping is accomplished by 
changing the wrap setting for the object to which text will wrap.

Note: You can also achieve special shape effects with text by creating frames with the  Shaped Frame button.

Wrap options are accessible via the Wrap Settings dialog, which includes these useful illustrations of how text flows in each 
instance:

 

To wrap text around an object:
n Right-click the object and choose Wrap Settings....

OR

Click the  Wrap Settings button on the Arrange toolbar, or choose Wrap Settings... from the Arrange menu. 

The Wrap Settings dialog lets you select the manner in which text will wrap around the sides of the object. With Tight wrapping, 
text wraps closely around the object's contours.

 

In addition, you can specify the standoff or distance between the object's wrap outline and adjacent text. The wrap outline is a 
contour that defines the object's edges for text wrapping purposes. Different object types have different initial wrap outlines. For 
QuickShapes the wrap outline corresponds exactly to the object's edges, while for closed shapes the outline is a rectangle to start 
with. 

You can manually adjust the wrap outline using the Curve toolbar for more precise text fitting. The list below gives a quick 
summary of options. For more options when using the Curve Toolbar, see the subtopic Editing lines. 

To adjust the shape of the wrap outline:

n Select the object and click the  Edit Wrap button on the Arrange toolbar. 
The Curve Toolbar appears, and you'll see the nodes and connecting segments that define the object's wrap outline.

n To move a node (control point) where you see the  cursor, drag the node.

n To move a line segment (between two nodes) where you see the  cursor, drag the segment.

n To convert an outline from straight lines to curves, click the  Fit Curves button on the Curve toolbar.

n To adjust the curvature of a segment, drag the control handle(s) of the adjacent nodes.

n To add or delete nodes for more or less complex outlines, select a node and click the  Add Node or 

 Delete Node button on the Curve toolbar.
n To move the object relative to its wrap outline, drag its interior when you see the hand cursor.

Notes on wrapping text 
n Each text frame has a "Text will wrap" setting (normally turned on) which determines whether its text actually wraps around 

overlapping objects. You can switch this property off to disable wrapping, if desired, using the Frame Setup dialog (via the 
Format menu or the frame's right-click menu). 

n Objects also have a crop outline which is initially set to match the crop outline. For adjustment purposes, the two are 
independent. You can adjust the crop outline to subtract visible portions of the object (for details, see Cropping an object.) Or, 
to crop an object according to its wrap outline, check the Crop object to wrap outline box in the Wrap Settings dialog.



n The objects that comprise a group are intact, but can't be edited individually. In general, any operation you carry out on the 
group affects each member of the group. Each object in a group retains its original wrap setting. If you apply a wrap setting to 
the group, each object (rather than the group as a whole) takes that setting. To flow text around several separated objects, first 
extend the wrap outline of one of the objects to encompass all the objects, then you can carry out the grouping operation.

n Text wrap makes it more difficult to achieve aesthetic composition (especially inside objects), so you may want to check for the 
following problems:
· Right edge of the text does not follow the wrap outline
· Single words in spaces too small for them
· Large gaps appear in the text

These problems can be corrected by using auto-hyphenation, justifying the text, changing the size of the text slightly, or 
discreetly editing the text itself.



Creating a bulleted or numbered list

You can turn a paragraph into a bulleted or numbered list. Each time you insert a following return, the new line will begin with the 
specified symbol.

To create a bulleted or numbered list:

1 Right-click the paragraph and choose Text Format/Bullets & Numbering.... 
OR
Click in the text and choose Bullets & Numbering... from the Format menu. 

2 Click either the Bulleted tab or the Numbered tab.

3 Click one of the preset formats (otherwise, the Details button is grayed out). 

4 Click the Details button if you want to customize the list formatting. The Preview window shows the effect on selected text.

To turn off bullets or numbering for a selected paragraph:

n In the Bullets & Numbering... dialog, click the None preset option on either the Bulleted tab or the Numbered tab.



Creating ruled lines

You can use ruled lines to set a block of text apart from its surroundings. For example, you might employ ruled lines above and 
below a "pull quote" inserted alongside a newsletter article. 

To create a ruled line:

1 Right-click the paragraph and choose Text Format/Paragraph.... 
OR
Click in the text and choose Paragraph... from the Format menu.

2 Click the Line tab.

3 In the Line Selection box, click one of the upper squares to select a line above, or one of the lower squares for a line below. 
Clicking the middle square selects both.

4 To customize the line style, select one or both of the line previews (Shift-click to toggle), then click the Line Style... button.

5 In the Line dialog, choose line properties including width, style, color, and corners. To restore no lines above/below, click 
None. Click OK when you're done.

6 Back on the Line tab, specify left/right indent and gap settings for the line(s). The Preview window shows the effect applied to 
a sample paragraph. 

7 Click OK to apply the effect to the selected paragraph.



Inserting a symbol

You can insert symbol characters using either the Insert menu or (for common symbols) keyboard shortcuts.

To insert a symbol character using the Insert menu:

1 Select the Pointer tool and click in the text for an insertion point.

2 Choose Symbol... from the Insert menu, and select a symbol from the submenu. 

3 If you need a symbol not shown on the submenu, select Other to display Windows' Character Map applet. In Character Map, 
select the symbol font (such as Wingdings) and double-click on the desired character(s). Click Copy, then Close. In 
PagePlus, with the text cursor correctly positioned, press Ctrl+V to paste the selection into your text. Note that special 
characters may be pasted at a default size and may require resizing. You may also have to reformat the character in the 
desired font. 

To insert a symbol character using keyboard shortcuts:

n Consult the table of Character Shortcuts.



Inserting date/time

You can insert a date/time field into your text, stamped with current date/time information. Various date and time formats are 
available. By default, the date/time field updates itself automatically. You can turn auto-updating off if necessary.

To insert a date/time field:

1 Select the Pointer tool and click in the text for an insertion point.

2 Choose Information from the Insert menu, then select Date or Time... from the submenu. Select a date/time format.

3 To keep the original date/time stamp in place indefinitely, uncheck Update Automatically. 

To edit the information in a date/time field:

n Select the field and choose Information/Date or Time... from the Insert menu.

Note: You cannot edit date/time fields using the Pointer tool.



Inserting user details

When you create a publication using a Page Wizard or edit answer text in a Gallery object, certain basic information you enter 
(such as name, address, etc.) is stored separately as User Details. This means you don't need to re-enter the same information 
the next time it's required in a Page Wizard.

There are two ways to alter your User Details: You can simply enter different information the next time you create a Page Wizard 
publication; by default, this will update the User Details. Or you can employ the Set User Details dialog to review all your User 
Details at a glance, and update fields directly. 

To review or change User Details:

1 Choose Set User Details... from the Tools menu.

2 Enter new information into the spaces on the Home, Business, or Custom tab.

3 To leave stored User Details intact (that is, prevent them from being updated by subsequent Page Wizard entries), uncheck 
the "Update from Wizard entries" box.

Note: Changing a User Details entry as described above won't affect existing answer text in a Page Wizard publication or 
Gallery object. To edit such existing answer text, use the Studio's Wizard tab as described in the topics Customizing Page 
Wizard text. and Using the Gallery.

Apart from the Wizard process, you can insert a User Detail field into any publication. The Custom tab of the Set User Details 
dialog includes blank, renameable fields where you can enter any information you may frequently need to "plug into" your 
publications.

Note: Like date or time fields (see the previous topic), the User Detail fields you insert can be either self-updating or fixed, as 
you choose. A self-updating field remains linked to the User Details so that altering the related entry instantly updates the field on 
the page. Use caution with self-updating fields! Remember that the User Details normally update each time you enter different 
information in a Page Wizard. Because of the risk of accidental updating, the default setting is for a fixed field.

To insert a User Detail field:

1 Select the Pointer tool and click in the text for an insertion point.

2 Choose Information from the Insert menu, then select User Details... from the submenu. Select a User Detail.

3 To make the field self-updating (see note above), check Update Automatically. 



Viewing and changing document information

PagePlus maintains basic properties and statistics for each publication file. 

To view or change document properties:

1 Choose Properties... from the File menu. 

2 Click the Summary tab to view or change fields for Title, Subject, Author, Keywords, and Comments. 

3 Click the Statistics tab to view key dates, page count, etc. 

In WritePlus, you can change the title of a story or click the Word Count button to view its word count and character count. 

For tracking version history, especially if layout work is being shared, you may wish to display current properties so they show up 
on the screen or on a printout. Properties you can insert include Title, File Name, Author, Last Edit Time, Revision Count, and 
Page Count.

To insert document information in your text: 

1 Select the Pointer tool and click in the text for an insertion point.

2 Choose Information from the Insert menu, then select Publication Info... from the submenu. Select a property to insert and 
click OK.

If the document information changes, the document information field in the text is automatically updated.



Using hyphenation

Hyphenation is usually accomplished automatically in PagePlus using auto-hyphenation. This feature recognizes and corrects 
lines which would otherwise be too ragged or use overly large word spacing. You can turn it off, if desired, or change the 
hyphenation settings.

To access auto-hyphenation settings:

1 Choose Paragraph... from the Format menu and select the Hyphenation tab.

2 To turn off auto-hyphenation, uncheck Auto Hyphenation.

3 Use the controls to adjust auto-hyphenation settings for successive hyphens, hot zone, word size, and letters before/after (see 
below). 

The hot zone is the amount of extra space at the end of each line that is considered acceptable. If the amount of extra space 
exceeds this value, then auto-hyphenation will try to split words to reduce the excess. This only affects the hyphenation of left-, 
right-, and center-aligned text.

The minimum word size is the minimum number of characters that a word must have before it is considered valid to hyphenate 
the word at the end of a line.

Letters before and after determine the minimum number of letters each part of a word must contain if the word is split by auto-
hyphenation.

Whether auto-hyphenation is on or off, you can insert a hyphenation point between two characters, marking that point as 
suitable for creating a line-end using a hyphen. 

To insert a hyphenation point:

1 Using the Pointer tool, click in the text where you want to mark a hyphenation point.

2 Press Ctrl+'-'. 
OR
Choose Hyphenation Point from the Insert menu. 

Note: Inserting a hyphenation point is not the same as typing a hyphen. You can't remove a hyphenation point by backspacing 
over it.

To remove a hyphenation point:

n Press Ctrl+'-'.

OR
n Using the Pointer tool, click in the text in front of the marked character or hyphen. 

Checking and fixing hyphenation points is usually one of the "finishing touches" to a publication. For example, an auto-
hyphenated text block using "justified" alignment may have some lines with large, ugly gaps between words. To fill a line out, you 
can insert a hyphenation point in a word a bit further on, so that the line breaks at a more attractive place.

A hyphenation point in a word overrides auto-hyphenation of the word. To ensure a word is never broken by auto-hyphenation 
(for instance, to reduce the number of hyphens in a narrow column of text), insert a hyphenation point before the first character 
of the word.

Hyphenation points work even if auto-hyphenation is turned off.

Tip: If you're not sure, check your dictionary before placing hyphenation points!



Using AutoCorrect and AutoSpell

PagePlus includes two powerful support tools to nip possible spelling errors in the bud. The AutoCorrect feature overcomes 
common typing errors and lets you build a custom list of letter combinations and substitutions to be applied automatically as you 
type. You can also turn on AutoSpell feature to mark possible problem words in your story text in red. Both features apply to 
frame text, table text, and artistic text.

If you prefer to address spelling issues in larger doses, at any point along the way you can run the Spelling Checker Wizard, 
which also includes a handy QuickSpell option for checking the spelling of any word you type.

AutoCorrect
To set options for automatic text correction:

1 Choose Options... from the Tools menu and select the AutoCorrect page.

2 Check your desired options to:
· Correct two initial, consecutive capitals
· Capitalize the first letter of sentences
· Capitalize the names of days
· Capitalize accidental usage of the Caps Lock key
· Change straight quotes to typographic ("smart") quotes
· Create a correction list (see below)

3 Check Replace text while typing to turn on AutoCorrect.

To create a correction list:

1 In the Replace field, type a name for the AutoCorrect entry. This is the abbreviation or word to be replaced automatically as 
you type. For example, if you frequently mistype "product" as "prodcut," type "prodcut" in the Replace box. 

2 In the With field, type the text to be automatically inserted in place of the abbreviation or word in the Replace field.

Tip: If you select some text before displaying the AutoCorrect screen, the selected text appears in the With field, formatted just 
as it appears on the page. Choose either the Plain text or Formatted text option:
· Plain text to insert only the With characters into instances of the Replace text
· Formatted text to also update the formatting of the Replace text to match that of the With text. For example, using this 
option E=mc2 can be automatically replaced with E=mc2

3 Click the Add button to add the new entry to the list.

4 To modify an entry in the correction list, select it in the list, then edit it in the Replace and With field above. Click the Add 
button below. 

5 To remove an entry, select it and click Delete. 

To turn off AutoCorrect:

n Uncheck Replace text while typing.

AutoSpell
To turn AutoSpell on (or off): 

1 Choose Options... from the Tools menu.

2 On the General tab, check (or uncheck) Autospell.

When AutoSpell is activated, possible problem words in your story text are marked in red, and you can view a list of suggested 
alternatives.

To view alternatives:

1 Right-click a marked word.

2 To replace a marked word, choose an alternative spelling from the menu.

3 To tell PagePlus to ignore (leave unmarked) all instances of the marked word in the publication, choose Ignore All from the 
right-click menu.

4 To add the marked word (as spelled) to your personal dictionary, choose Add from the right-click menu. This means PagePlus 
will ignore the word in any publication.

5 To run the Spelling Checker Wizard, choose Check Spelling... from the menu.



Exporting story text (WritePlus only)

If you've prepared a story in PagePlus and need to view or edit it in another word processing environment, you can export the 
story using WritePlus. Several text export formats are available:

n Use .RTF to preserve formatting across programs, for example if the story will be opened in Microsoft Word.

n Use the proprietary WritePlus .STT format to preserve formatting if you plan to re-import the story into PagePlus. For example, 
this would be a the most efficient way to move story text from one PagePlus publication to another. You'll find ".STT" among 
the dialog options when importing text from a file.

n Use .TXT for unformatted text. 

To export the text of a story: 

1 Right-click the text object and choose Edit Story. 
OR
Click in the text and choose Edit Story from the Edit menu. 

2 In WritePlus, choose Export Text... from the File menu.

3 Select an export format and specify the file name and location.



Using mail merge (Paper Publishing mode only)

Mail merge lets you print your publication any number of times, merging data from an address file. You can preview the data 
directly in your publication, and work with character-delimited data files from other programs.
Note: Mail merge works in conjunction with frame text, not table or artistic text.

To create a new PagePlus address list file:

1 Choose MailMerge from the Tools menu and select New Address List... from the submenu.

2 Enter a folder and file name for the new address list (*.SDB) file, and click Open. 

3 The Edit Address List dialog appears, showing a blank first record,    with six fields in view. Scroll down to view additional 
fields. You can start entering information now, or wait until later. To enter information, simply type into a field. To create a new 
record, click Add. (For more pointers, see Editing address lists below.)

4 To record any changes and dismiss the dialog, click Close.

You can create any number of address list files, but can only have one open at a time. When you start a PagePlus session, the 
most recent address list file is automatically opened for you. 

To open a PagePlus address list file: 

1 Choose MailMerge from the Tools menu and select Open Address List... from the submenu.

2 Locate the address list (*.SDB) file to open. 

The Edit Address List dialog appears, showing the first record of the address list.

Editing address lists
Each record in a PagePlus address list contains 20 standard fields. Use the Edit Address List dialog to create or delete records, 
enter information, or find occurrences of specific text. 

To edit a PagePlus address list file: 

1 Choose MailMerge from the Tools menu and select Edit Address List... from the submenu. The first record of the current 
address list appears, with six fields in view.

2 Scroll down to view additional fields.

3 To enter information, simply type into a field.

4 To create a new record, click Add.

5 Use the arrow buttons to navigate between records, or type in a record number and press Enter.

6 To delete the current record, click Delete. If you click Delete on the first record, its information is cleared, but the record form 
remains. 

7 To record any changes and dismiss the dialog, click Close.

Note: Closing the Edit Address List dialog does not actually "close" the address list file. It's still the current address list. However, 
any changes you've made are saved to disk at this time.

Inserting placeholders for your data
In order to merge information from an address list file into a publication, you need to insert address field placeholders so 
PagePlus knows which fields' data to use. You can insert placeholders either in the main window or in WritePlus.

To insert an address field placeholder:

1 Using the Pointer tool, click in the text where you want to insert the address field.

2 Choose MailMerge from the Tools menu and select Insert Address Field... from the submenu. From the scrolling list in the 
dialog, select the address field to insert, and click Insert.

3 The Insert Address Field dialog remains open so you can insert additional fields if needed. To dismiss the dialog, click Close.

Previewing data in the publication
The View Data option lets you inspect your publication with actual data from the address list substituted for the placeholders. You 
can step through the data records, previewing the final appearance and making any necessary layout adjustments (for example, 
to allow extra space for long lines).

To preview merged data in the publication:

n Choose MailMerge from the Tools menu and check View Data on the submenu.

In View Data mode, the MailMerge toolbar becomes available. The current record number appears in the center box.



 
To specify which record's data to display in the publication:
n Click the First, Previous, Next and Last buttons, or type a number into the Current box.

Merging and printing
Once you've inserted all necessary placeholders, you're ready to print the publication. MailMerge options are accessible via the 
Print dialog's Layout tab. For details on other print options, see the topic Basic printing.

Note: Don't worry if not all records you're merging include data for each of the placeholders. PagePlus trims away any excess 
spaces and lines after empty placeholders in the merged document.

To merge and print:

1 Choose Print... from the File menu and select the Layout tab. 

2 In the Mail Merge section, set your options. 
· The default setting, All records, results in printing one copy of each record. 
· Select Ignore Mail Merge to print the publication without merging address data (placeholder text appears instead).
· To print only selected records, select Records and type the number(s) of the record(s) to be printed.
Hint: You can print multiple copies of a record by typing its number more than once. For example, type "1,1,1" to print three 
copies of record 1. To identify record numbers, refer to the address list file or use View Data mode.

3 Set any other desired print options and then click Print.

Using data files from other programs
To use a character-delimited output file from another program (such as a contact manager or e-mail address book), you first 
need to convert the outside file to the PagePlus address list format using the Database Import Wizard. 

Supported file formats include: Comma Delimited (*.CSV), Semicolon or Space Delimited (*.TXT), and Tab Delimited (*.TAB), 
etc. 

To convert a character-delimited file to a PagePlus address list file:

1 Choose MailMerge from the Tools menu and select Open Address List... from the submenu.

2 In the dialog, click the down arrow on the "Files of type" box and select Text Files.

3 Locate the outside file and click Open. The Database Import Wizard appears.

4 The Wizard shows a preview of the selected file's data. Step through the Wizard screens, entering the requested information 
(renaming fields is optional). Click Next when you've completed each step. 

5 When you're done, click Finish to open the converted address list. 



Creating a table of contents

A table of contents is a useful addition to a longer newsletter or any document with complex organization. The Table of 
Contents Wizard helps you create a table of contents with first- and second-level headings derived from named styles in your 
publication. 

To review named styles, see Using text styles.

To create a table of contents:

1 Decide which named styles you want to designate as first- or second-level headings.

2 Check your publication to make sure these styles are used consistently.

3 Review the choices you'll need to make when you run the Table of Contents Wizard (see below).

4 Choose Table of Contents... from the Insert menu to run the Wizard.

5 You can easily modify the look of your table of contents, or run the Wizard again to update the information.

Using styles to prepare a table of contents
The Wizard will show you a list of all the style names used in your publication, and you will check boxes to include text of a given 
style as either a first- or second-level heading. For example, you could include all text using the "Heading" style as a first-level 
heading.

Headings in the resulting table of contents will appear in the order the text occurs in your publication.

When the table of contents is created, PagePlus uses three built-in text styles intended specifically for table of contents 
preparation: "Contents-Title," "Contents-1st," and "Contents-2nd." Using the Wizard, you'll be shown a list of styles in your 
publication, and can check boxes to include text of a given style as a first- or second-level heading. For example, you could map 
all text using the Heading style to Contents-1st. You can change the look of your table of contents by changing the built-in style 
definitions.

Table of Contents Wizard choices
Before building your table of contents, decide how you want it to look, so you'll be ready to answer the Wizard's questions.

Placement options: Should the new table of contents...

n Follow in the selected frame sequence? (Grayed out if none is selected.)

OR
n Replace the current table of contents? (Grayed out if there is none.)

OR
n Go on a blank page at the start of your publication? 

OR
n Go on a blank page at the end of your publication?

Display options: Do you want to...

n Display a title? If so, the title you enter will be placed at the top of the new table of contents.

n Display page numbers? If so, you'll be asked to pick a character for a tab leader that can appear between each heading and 
its corresponding page number. Typical choices include dots (ellipses) or underscore, or "None."

Changing the look of your table of contents:

You can update the built-in Contents styles as needed, as explained in Using text styles.



Creating an index

An index is a valuable reader aid in a longer document such as a report or manual. The Index Wizard helps you create an index 
with main entries and subentries, based on index entry marks you insert. Creating an index involves considerable time and 
thought—but the results can be well worth the effort.

A suggested plan of action...
In order to build a good index, you must become familiar with the content of the publication, and put yourself in the place of a 
reader approaching the material. Here are suggested general steps, with specifics given below.

1 Start by making a preliminary list of possible index entries, using key vocabulary terms and concepts. 

2 Go through the text of each story using WritePlus and mark the entries wherever they occur. Insert additional entries as they 
occur to you, grouping them where appopriate using multiple subentries under a single entry. You can either proceed 
systematically down your list of entries or work your way through the publication—or a bit of both. 

3 Periodically (often, that is), build an index from the marked text, each time replacing the previous index. This will let you 
maintain a current, top-level view of how the index is developing. 

4 You can print out the index or export it to rework the list and use it as a plan for the next revision.

5 Repeat the process until you're satisfied (or exhausted, or both!). Be sure to check your spelling for consistency.

Marking index entries
n Choose Edit Story from the File menu or the right-click menu to display WritePlus. 

You use the Mark Index Entry dialog to insert or edit index entry marks.

Note: Index entry marks are invisible on the PagePlus screen and can only be edited in WritePlus.

To display the Mark Index Entry dialog:

1 Select the term to be included in the index, or click for an insertion point where the index mark should go.

2 Click the     Mark Index button.

OR
n To edit a specific index entry, select it before clicking the button.

Note: You'll need to click the  Special Characters button to display index marks.

If you selected a word or phrase in the story, it appears as the main entry in the dialog. You can use the entry as it is, or type new 
text for the main entry and sub-entry (if any). You must include a main entry for each sub-entry. The dialog's scrolling list records 
entries and sub-entries alphabetically. 
n To reuse an entry, click it in the list.

n For a standard index entry, leave the Current page box checked. 

n To insert a cross-reference with the term(s) preceded by "See:", select Cross-reference (to include a word other than "See," 
simply replace it in the box.

n You can also specify a bold and/or italic page number format.

n Click Mark to insert the new entry mark or update a selected mark. 

n To undo a mark entry, click the Undo button or press Ctrl+Z.

Entries use the following format:

MAIN ENTRY: {weapons}
ENTRY + SUB-ENTRY: {weapons:trebuchet}
CROSS-REFERENCE: {siege engines[weapons]}

You can select index marks and then cut, copy, or delete them just like regular text. One efficient strategy is to proceed one index 
entry at a time, pasting copies of its particular entry mark wherever they belong, throughout the text.

To build an index:

First mark the entries as described above. Then in PagePlus...

1 Review the choices you'll need to make before running the Index Wizard (see below).

2 Choose Index... from the Insert menu.

You can easily modify the look of your index, or run the Wizard again to update the information.



Index Wizard choices
Before building your index, decide how you want it to look, so you'll be ready to answer the Wizard's questions.

Placement options: Should the new index...

n Follow in the selected frame sequence? (Grayed out if none is selected.)

OR
n Replace the current index? (Grayed out if there is none.)

OR
n Go on a blank page at the start of your publication? 

OR
n Go on a blank page at the end of your publication?

Display options: Do you want to...

n Display a title? If so, the title you enter will be placed at the top of the new index.

n Right-align page numbers? If so, you'll be asked to pick a character for a tab leader that can appear between each entry and 
its corresponding page number. Typical choices include dots (ellipses) or underscore, or "None."

n Include an index separator (A, B, C, etc. for first-letter groupings)?

Changing the look of your index:
You can update the built-in Index styles (Index-Title, -Separator, -Main, and -Sub) as needed, as explained in the topic Using text 
styles. For example, indent the "Index-Sub" text slightly, and introduce some space above the "Index-Separator" text.



Drawing and editing lines

PagePlus provides Freehand Line, Straight Line, Curved Line, and QuickShape tools for creating simple graphics. Using the line 
tools (found on a Tools toolbar flyout), you can draw single lines, connect line segments together, and join line ends into closed 
shapes (see Drawing shapes for details). Use the Pointer tool and the Curve toolbar to resize or reshape lines once you've 
drawn them. 

 
You might use the Straight Line tool for vertical lines (for example, drawn in the column gutter to separate columns); rules at the top 
and/or bottom of the page; or horizontal lines to separate sections or highlight headlines. The Freehand Line tool is well suited for 
freeform shapes and decorative elements, while the Curved Line tool lets you adjust the curvature of each line segment with 
precision. 

To draw a line:

1 Click the  Straight Line, 

 Freehand Line, or 

 Curved Line button on the Tools toolbar's Line Tool flyout.
2 To draw a straight line or freehand line on your page, simply click and drag. (To constrain the angle of a straight line to 15-

degree increments, hold down the Shift key as you drag.)
OR
To draw with the Curved Line tool, click where you want the line to start. Then:
· For a straight line segment, don't drag—click again where you want the segment to end. A straight line appears after the 
second click.
· For a curved line segment, click and drag out a control handle from the initial point. (These handles act like "magnets," 
pulling the curve into shape. The distance between handles determines the depth of the resulting curved line.) Click again 
where you want the segment to end. A curved line appears after the second click.
To end the line, press Esc, double-click anywhere, or choose a different tool.

 

3 To extend an existing line, begin drawing with any line tool from one of the line's end nodes.

You can reshape the line after it's drawn (see below), or apply different weight, color, or other attributes (see the next topic).

Editing lines
Use the Pointer tool in conjunction with the Curve toolbar (see below) to adjust lines once you've drawn them. The techniques 
are the same whether you're editing a separate line object or the outline of a closed shape. 

To move or resize a line:

n Select the line with the Pointer tool and drag its bounding box to move or resize. When resizing, use the Shift key if you wish 
to keep the line constrained.

To reshape a line:

1 Select a line segment with the Pointer tool. You'll see the  cursor.

2 Drag the line to reshape it. PagePlus automatically applies curve-smoothing to help you achieve a pleasing result.
Note: Dragging from the middle of a a straight line segment doesn't reshape the segment—it moves the whole line. To 
reshape a straight line segment, first convert it to a curved line using the the Sharp, Smooth, or Symmetric Corner buttons on 
the Curve toolbar (see below).

OR

1 Select one of the line's nodes with the Pointer tool; you'll see the  cursor.

2 Drag the node.
OR



Adjust one or both of the node's control handles to change the profile of the adjacent segment(s). 
Note: You can use the Curve toolbar to change the node type for finer control.

Curve toolbar
The Curve toolbar appears when you select a line or closed shape, and provides a variety of adjustment controls, as shown 
below. In particular, notice how different node types affect the slope and depth of the line segments they join. 

 Add Node
Adds a new node halfway along a line segment. Select the leading node of 
the segment (the node nearer the start of the line), then click this button.

 Delete Node
Click to delete the selected node. The line or shape takes a new contour.

 
Close Curve
Turns a curved line into a closed shape. Select the line, then click this 
button to connect the line's two end nodes.

 
Break Curve
Breaks open a curve (creating two lines) or a closed shape (creating a 
curved line). Select the node where you want the break to occur, then click 
this button.

 
Straighten Line
Turns a curved line segment into a straight line segment. Select the leading 
node of the segment (the node nearer the start of the line), then click this 
button. To make a straight segment curved, use the Sharp, Smooth, or 
Symmetric Corner buttons.

 
Sharp Corner
Click to change a selected node so the segments on either side are 
completely independent, and the corner can be pointed.

 
Smooth Corner
Click to change a selected node so the slope of the segments on either 
side is the same, but the depth of the two joined segments can be different. 

 
Symmetric Corner
Click to change a selected node so the segments on either side have equal 
slopes and equal depth.

 
Straighten All Lines
Changes all segments in the selected object to straight lines.

 Fit Curves
Optimizes the editibility of the selected shape by changing most segments 
to curved lines and eliminating extra nodes.



Setting line properties

Line properties include attributes such as weight (thickness), termination, corners, scaling, and color. You can vary these 
properties for any freehand, straight, or curved line, as well as for the outline of a shape (see the next topic). Text frames, tables, 
and artistic text objects have line properties, too. For details on reshaping lines, see the previous topic.

To change line properties of a selected object:

n Use the Color   panel   of the Studio's Attributes tab to change the line's color and/or shade. (If changing the outline color of a 

shape or other object, click the  Line button so that the line, not the fill, will change.) Click a sample in the Color panel to 
apply it to the selected object, or drag and drop from the panel onto any object. 

n Use the Line   panel   of the Studio's Attributes tab to change the line's weight (thickness), type, or other properties. Click a 
sample in the Line panel to apply it to a selected line.

To access all Line properties:

n Right-click on the object and choose Line and Border.... The dialog lets you adjust all line properties, including several 
additional options applicable to outlined shapes: 
· You can set the line corners to be either sharp or rounded; the effect is more noticeable on thick lines.
· If Behind contents is checked, the the inner half of the outline will appear behind the object's interior. For example, if you 
had some red text with a black line border, you might set the line behind the shape in order to adjust the line's weight while 
keeping the letter shape constant. If the box is unchecked, the whole line appears in front (the wider the line, the more it 
encroaches on the filled region).
· If Scale with object is checked, both outline and shape change together if you resize the object. For example, you could 
scale a text object up or down while maintaining the relative thickness of the line border around the characters. If the box is 
unchecked, the line weight remains constant during resizing.

Note: You can use Update Object Default from the Format or right-click menu to set properties for any new graphics you 
create. See Updating and saving defaults.



Drawing shapes

PagePlus provides Freehand Line, Straight Line, Curved Line, and QuickShape tools for creating simple graphics. QuickShapes 
are pre-designed objects that you can instantly add to your page, then adjust and vary using control handles. Another way of 
creating shapes is to draw a line (or series of line segments) and then connect its start and end nodes, creating a closed shape. 
Once you've drawn a shape, you can adjust its properties—for example, apply gradient or Bitmap fills (including your own bitmap 
pictures!) or apply transparency effects. 

First we'll look at the unique features of QuickShapes and closed shapes, then review the customary ways of editing shapes in 
general. 

QuickShapes
The QuickShape flyout contains a wide variety of commonly used shapes, including boxes, ovals, arrows, polygons and stars. 
You might use the QuickShape button for: 

 
n Decorative circles or polygons

n Functional arrows, stars, callouts, 
and so on

n "Clickable button" objects on Web 
pages. (Use the Hotspot tool to 
overlay hyperlinks.)

n A border framing your page, e.g. a box around the whole page.

n Shaded panels, also known as screens, behind pictures to draw attention to them. The effect works equally well behind text.

To create a QuickShape:

1 Click the QuickShape button on the Tools toolbar and select a shape from the flyout. The button takes on the icon of the 
shape you selected. (To select the previous shape again, double-click the button.)

2 Using the QuickShape tool, click on the page to create a new shape at a default size. Drag to adjust its dimensions. To 
constrain the aspect ratio (for example, to obtain a square or circle), hold down the Ctrl key while dragging.

3 When the shape is the right size, release the mouse button. Now you can alter the shape by dragging on its handles.

4 Click outside the QuickShape when you're done.

Note: Normally, the tool reverts to the Pointer after you draw a shape. To retain the QuickShape tool after drawing, hold down 
the Shift key when you first click the button.

To draw a constrained shape (such as a circle):

n Hold down the Shift key as you drag.

All QuickShapes can be positioned, resized, rotated, and filled. What's more, you can adjust their designs using the Pointer tool. 
Each shape changes in a logical way to allow its exact appearance to be altered. The ability to alter the appearance of 
QuickShape objects makes them more flexible and convenient than clipart pictures with similar designs. For example:

n Dragging the handles on a Polygon will change the number of sides to make a triangle, pentagon, hexagon, or other polygon.

n Dragging the handles on a Rectangle alters the box corners to make them more or less rounded.

n Dragging the handles of a Ellipse will convert it into a "pie" shape.

 

To adjust the appearance of a QuickShape:

1 Select it with the Pointer tool. One or more sliding handles appear next to the shape. Different QuickShapes have different 
handles.

2 To find out what each handle does for a particular shape, move the Node tool over the handle and read the HintLine.

3 To change the appearance of a QuickShape, drag its handles.

For more on editing QuickShapes, see "Editing shapes in general" below.

Closed shapes
As soon as you draw or select a line, you'll see the line's nodes appear. Nodes show the end points of each segment in the line. 
Freehand curves typically have many nodes; straight or curved line segments have only two. You can make a shape by 
extending a line back to its starting point.

 



To turn a selected line into a shape:

n Select the line with the Pointer tool and click the  Close Curve button on the Curve toolbar.

OR

1 Select the line, then choose one of the line tools and position the cursor over an end node. The cursor changes to . 
Drawing from this point will extend the line.

2 Click and draw a line from one end node to the other. When you reach the other node, the cursor changes to . Releasing 
the mouse button here will create a shape.

Closed shapes have an interior which is filled with the current default fill when the shape is closed.

Because a closed shape consists of line segments, it's easy to adjust its contours by adjusting individual segments and nodes, 
using the Pointer tool and Curve toolbar. For details, see the subtopic Editing lines.

You can go the other way, too—break open a shape in order to add one or more line segments.

To break open a line or shape:

1 With the Pointer tool, select the node where you want to break the shape.

2 Click the  Break Curve button on the Curve toolbar. A line will separate into two lines. A shape will become a line, with the 
selected node split into two nodes, one at each end of the new line.

3 You can now use the Pointer tool to reshape the line as needed.

Editing shapes in general
n To move or resize the shape, select it with the Pointer tool and drag its bounding box. When resizing, use the Shift key if you 

wish to constrain the shape.

n Use the Flip buttons on the Standard toolbar to reorient directional shapes like arrows or callouts.

n New shapes take the default line and fill (initially a black line with no fill).

n Use the Line panel of the Studio's Attributes tab to change the weight (thickness) or type of the shape's border. Click a sample 
in the Line panel to apply it to a selected shape. Note that some properties available for lines and boxes (dashed lines, for 
example) are not available for these other shapes. (See the previous topic for more on editing line properties).

n Use the Color panel of the Attributes tab to change the shape's line or fill color and/or shade. Select the shape and right-click 
a sample in the Color panel, then choose either Apply to Line or Apply to Fill. Left-clicking a sample applies the color or 
shade to the selected object's fill. For details, see Applying solid colors. 

n Use the Fill panel of the Attributes tab to apply a gradient or Bitmap fill. For details, see Working with gradient and Bitmap fills.

n Use the Transparency panel of the Attributes tab to apply a gradient or Bitmap transparency effect. For details, see Working 
with transparency effects.
Note: The .GIF format only allows one transparent color. To take full advantage of PagePlus' support for variable 
transparency, we recommend exporting to the .PNG format.

To access all Line, Fill, and Transparency properties:

n Right-click on the shape and choose Line and Border..., Fill..., or Transparency.... The dialogs let you adjust all Line or Fill 
properties.

Note: You can use Update Object Default from the Format or right-click menu to set properties for any new graphics you 
create. See Updating and saving defaults.



Applying filter effects

Filter effects are creative manipulations—particularly well adapted to text—that you can apply to any object: drawn shapes, text 
objects, imported metafiles, even 32-bit images with transparency. Here are a few examples:

 
The available filter effects include:
n Drop Shadow adds a diffused shadow effect outside the edge of an object.

n Inner Shadow adds a diffused shadow effect inside the edge of an object.

n Outer Glow adds a color border (stroke) outside the edge of an object.

n Inner Glow filter adds a color border (stroke) inside the edge of an object.

n Bevel and Emboss/Inner Bevel adds a rounded-edge effect inside an object.

n Bevel and Emboss/Outer Bevel adds a rounded-edge effect (resembling a drop shadow) outside an object.

n Bevel and Emboss/Emboss adds a convex rounded edge and shadow effect to an object.

n Bevel and Emboss/Pillow Emboss adds a concave rounded edge and shadow effect to an object.

n Color Fill adds a single-color layer to the object. It's especially useful for recoloring Bitmap fills.

To apply a filter effect:

1 Choose Filter Effects... from the Tools menu, or right-click the object and choose Filter Effects....

2 Check the Automatic box to preview the effect continually applied to the image as you make adjustments, or uncheck it and 
click the Manual button when you want to update the preview. Preview speed may vary depending on the size of the target 
object.

3 To apply a particular effect, check its box in the list at left. For certain effects, also select an effect type from the drop-down list. 
You can apply multiple effects to a given object.

4 To adjust the properties of a specific effect, select its name and vary the dialog controls. Adjust the sliders or enter specific 
values to vary the combined effect. (You can also select a slider and use the keyboard arrows.) Options include:

· Opacity (0 to 100%) controls the opacity of shadow pixels

· Blur (0 to 20) controls the linear extent of the shadow effect (see the next step)

· Distance (0 to 40) controls the apparent separation between the original shape(s) and the plane on which the shadow is cast. 
With 0 depth and a larger extent, you can achieve a unique "glow" effect

·    Intensity (0 to 100) or Depth (0 to 1000) varies the strength of the effect

· The Angle/Elevation dial controls the direction of the cast shadow or effect

· Click the Color swatch to display the Adjust Color dialog and change the base highlight or shadow color from its default (either 
white or black)

5 Click OK to apply the effect to the selected object, or Cancel to abandon changes.

Notes:
n Filter effects are applied to the entire object—in the case of text objects, to all the text in the container (i.e. frame or table cell). 

n Effects drawn behind or outside text or shapes will not interfere with any CMYK data stored within the object. Effects drawn 
inside pictures, text, or shapes containing CMYK data will result in an RGB version being used instead.

n The Tools/Options... dialog includes a Filter Effects page where you can fine-tune your system's performance. The Screen 
resolution and Print resolution settings determine the resolution at which effects are rendered on screen and paper, 
respectively. Check Filter effect smoothing under "Smoothing" to create smoother-looking effects without increasing 
resolution or memory usage (performance may be a bit slower).



Adding borders

A border in PagePlus is a repeating element that can be set to enclose an object, giving the appearance of a picture frame. 
Borders work especially well with imported pictures.

 

To add a border to an object:
1 Right-click on the object and choose Line and Border... (or choose the item from the Format menu), then select the Border 

tab.

2 In the "Side" list, select a border preset. You can use the up/down arrows to move through the list, and preview each border in 
the window at the right.

3 To keep the corner pattern the same as the side, leave Keep side and corners the same checked. To mix and match, 
uncheck the box and select a preset from the "Corner" list.

4 Set other properties as needed:
· To vary the border width, select or type a value in the "Weight" list.
· If Behind contents is checked, the the inner half of the border extends behind the object. If unchecked, the whole border 
appears in front (the wider the border, the more it encroaches on the filled region).
· If Scale with object is checked, both border and object change together if you resize the object. If unchecked, the border 
weight remains constant during resizing.

5 Click OK when you're done. 



Using the Gallery

The Studio's Gallery tab includes a wide variety of predesigned elements—graphics that you can customize and use as a 
starting point for your own designs.

To use a Gallery object:

1 Click a category name in the upper group to preview the available objects as thumbnails in the lower group.

2 Drag and drop a thumbnail out onto the page. 

Many Gallery objects are groups that can be moved around and resized like other objects. You can ungroup an object to edit its 
individual components, and then regroup them. To apply a hyperlink to a group object from the Gallery, first ungroup the object, 
then apply the hyperlink to the uppermost object and regroup all the objects.

Masks
The Gallery's Masks category provides a selection of special vector files that you can use to quickly mask imported pictures 
(providing your page uses a solid background). Each mask has a "hole" so that the when it's laid on top of a picture, the picture 
is framed by the hole. We've included both standard geometric shapes and some offbeat examples

To use a mask:

1 Select a mask from the Gallery and drag it onto the page.

2 Set the mask's solid fill color to match that of the page background.

3 Position the mask over an image. Of course, you can adjust the mask's dimensions as needed.



Importing images

See Also: For details on other key aspects of working with images in PagePlus, see these topics: Converting an object to a 
picture, Exporting as a picture, and Setting Web picture display options.

PagePlus lets you insert images from a wide variety of file formats. Here's a quick overview—also check the "More about..." 
sections below:

n Bitmapped images, also known as bitmaps or raster images, are built from a matrix of dots ("pixels"), rather like the squares 
on a sheet of graph paper. They are typically created with a "paint" program or photo editor such as Microsoft Paint, Adobe 
Photoshop, or Serif PhotoPlus. 

n Draw graphics, also known as vector images, are resolution-independent and contain drawing commands such as "draw a 
line from A to B." Compact draw images, produced with software like Serif DrawPlus, are often easier to edit and print out 
better than paint graphics. 

n Metafiles are the native graphics format for Windows and combine raster and vector information.

You can also acquire images directly from PhotoCDs or via TWAIN devices (scanners or digital cameras). If PagePlus cannot 
import your file directly, check your application to see if it can save the file in one of the supported formats. For instructions on 
importing animated GIF images, see Adding animation effects.

There are several ways to bring an image into PagePlus. Decide in advance where you want to place the picture, and whether to 
insert it by embedding or by linking. 

n Detached images float freely on a page, while inline images sit inside a text object.

n Embedded images become part of the publication file, while linking places a reference copy of the image on the page and 
preserves a connection to the original file. Each approach has its pros and cons (see "Embedding vs. Linking" below). 

To import an image from a file:

1 If you want to place the image inline, click for an insertion point in a text object. For a detached image, make sure text objects 
are deselected.

2 Click the  Import Picture... button on the Tools toolbar. 
OR
Choose Picture... from the Insert menu and select From file. 
OR
Press Ctrl+G.
OR
To replace an existing picture, select it and choose Picture/Replace Picture... from the Format menu, or right-click it and 
choose Replace Picture....

3 Use the dialog to select the image file to open. Select Embed Picture or Link Picture, and click Open.

4 If there's a text insertion point, you'll be prompted whether to insert the image at the current cursor position. Click Yes if that's 
what you want.

If there was no insertion point (or you answer "No" to the insertion prompt), you'll see the mouse pointer change to the     
Picture Paste cursor. What you do next determines the initial size and placement of the detached image.

5 To insert the picture at a default size, simply click the mouse. 
OR
To set the size of the inserted picture, drag out a region and release the mouse button. 

Other ways to import an image:

n For an inline image, first click for an insertion point in a text object. 

n Drag the image file icon into the PagePlus window.
OR
Copy the image to the Windows Clipboard, then...
· Choose the Paste command in PagePlus. The image will be embedded as a PagePlus picture.
      OR
· Choose the Paste Special command in PagePlus and select an option from the submenu. 

Notes
n You can always resize a picture as required, after it's been placed, by dragging its handles. For the finer points of resizing, see 

Resizing objects. 

n You can select and resize inline images, but not paste them via the Clipboard. 

n To set the vertical alignment of an inline image, right-click it and choose Align, then select Top, Bottom, or Center.

n You can also convert a line/shape graphic drawn in PagePlus (or any selection, for that matter) to a picture, with a range of 
image format and transparency options. For details, see Converting an object to a picture.



Embedding vs. linking
Embedding means the image in PagePlus is now distinct from the original file. Embedding results in a larger PagePlus file, and 
if you need to alter an embedded image you'll need to re-import it after editing. Still, it's the best choice if file size isn't an issue 
and graphics are final.

Linking inserts a copy of the image file into the PagePlus publication, linked to the actual file so that any changes you later 
make to it in the native application will be automatically reflected in PagePlus. Linking is one way of avoiding "bloat" by limiting 
the size of the publication file. On the other hand, you'll need to manage the externally linked files carefully, for example making 
sure to include them all if you move the PagePlus file to a different drive. If file size isn't an issue, consider using linking just for 
images that are still "in flux", and embedding them all once they're final. 

By default, PagePlus prompts you to embed pictures that are smaller than 256K, by preselecting the "Embed Picture" option in 
the Insert Picture dialog (but you can always select "Link Picture" instead). If you like, you can change the threshold file size or 
even switch off the automatic selection.

You can use the Resource Manager later on, to change an item's status from linked to embedded, or vice versa.

To preselect embedding or linking based on file size:

1 Choose Options... from the Tools menu. You'll see the General tab.

2 To preselect the "Embed Picture" option for images under a certain size, select the threshold size in the "Embed if smaller 
than" list. ("Link Picture" will be preselected for images larger than the threshold.)

3 To choose whether to embed or link each image, uncheck Suggest embed/link picture. You can still select either option in 
the import dialog; it will now remember and preselect the last setting you used.

More about bitmap images...
Bitmap reproduction quality can vary dramatically. These images are created at a fixed resolution and hence lose quality when 
resized. High resolution bitmaps counter this problem, but tend to be very large files. In general, file size depends on factors 
such as:

n How many dots per inch are stored in the original file

n How many dots per inch are used to reproduce the picture

n Whether it is color, bi-level (monochrome), or gray-scale

n What scaling is applied to the picture

Imported bitmaps are treated as separate images and inserted with their original file names unaltered, using a default screen 
resolution setting of 96dpi. If the bitmap has a different internal setting, PagePlus will observe this and scale the image 
accordingly.

Imported TIFFs retain any CMYK color data embedded in the file ready for full color separation. An RGB version is displayed 
onscreen and the CMYK data is automatically used on output when it exists. Filter effects drawn behind or outside text or shapes 
will not interfere with any CMYK data stored within the object. However, TIFFs used as Bitmap fills, or filter effects drawn inside 
pictures, text, or shapes containing CMYK data will result in an RGB version being used for printed output.

Imported GIF, JPEG, and PNG images are commonly used in Web Publishing mode. Even if these are scaled down on the 
publication page, the original file size is preserved and (if exported to a Web page) the image will take longer to display. As a 
rule, downscale these images first in a paint program, then import them to PagePlus. GIFs are imported at a 1:1 pixel ratio 
(unscaled). For details on bitmap formats for the Web, see the subtopic About Web picture formats.

More about draw images and metafiles...
Draw-type pictures are typically created a number ways, such as:

n Exporting from an EPS (Encapsulated PostScript) generating program

n Auto-tracing a paint-type picture using a draw-type program

n Drawing the picture yourself using a drawing program such as Serif DrawPlus

PagePlus supports a wide variety of industry standard draw-type files including Encapsulated PostScript (EPS) and Windows 
Metafile (WMF). Draw-type pictures can be enlarged, reduced or stretched and then printed out on any printer, at any resolution, 
without any loss of quality.

Encapsulated PostScript (EPS) is a special case of a draw-type picture which contains the PostScript coding needed to 
produce output on a PostScript printer. Typically such files also include a screen representation, which PagePlus can display as 
an onscreen bitmap image and print out to most printers. If there's no picture embedded in the EPS, you'll see only a box on the 
screen and printout. You can check the application that created the file—it may have an option to include a screen 
representation. 

If you plan to generate final PostScript for a print job, we recommend you use EPS for imported pictures. When you output to 
PostScript using "Print to File," PagePlus automatically sends out the raw EPS data for markedly superior results! 

Windows Metafiles (WMF) are quite common. They can easily be modified, edited and recolored using Serif DrawPlus. If you're 
not using PostScript, this is the recommended vector format. Metafiles include multiple "records" for maximum portability 
between applications. By default, PagePlus uses an enhanced metafile player to convert and anti-alias metafiles on import. For 



maximum control, the Options dialog lets you pick an alternate method of drawing metafile objects—for example if you need to 
import a metafile that contains complicated records not supported by the PagePlus renderer.

To set metafile options:

1 Choose Options... from the Tools menu and select the Layout tab.

2 In the Options section, select a preferred method of drawing metafiles. 
Note that there are separate settings for metafiles inserted as embedded or linked pictures ("Picture Metafile Draw"), and 
those imported specifically as OLE objects ("Object Metafile Draw")—such as those placed by LogoPlus or TablePlus. 
· Interpreted EMF (the default) employs the latest PagePlus metafile player with anti-aliasing.
· Interpreted WMF reverts to the PagePlus 7.0 version player.
· Raw (not antialiased) brings in the metafile using the specification in the original file. Use this, for example, for an Excel 
table object, or if a graphic includes effects like line fills or shade brushes that aren't supported in PagePlus. Note that the 
resulting object won't be anti-aliased, and cannot be rotated, color separated, or recolored.
· Placeholder Only inserts a box on the publication page and printout rather than attempting to draw it. Use this for complex 
metafiles that will be handled separately from the publication.

These settings are saved on a per-document basis. If you update your defaults (Tools/Save Defaults), PagePlus will use the 
new settings in subsequent sessions. 



Using the Portfolio

The Studio's Portfolio tab serves as a container for storing your own design objects (such as pictures, text blocks, even unlinked 
text frames or HTML fragments) you'd like to reuse in different publications. Once you've copied a design to the Portfolio, it 
becomes available in any publication—simply open the Portfolio! For example, if you're creating a Web site and want to borrow a 
logo or other motifs from various paper publications, copy the elements to the Portfolio. 

To view the Portfolio:

n Click Portfolio on the Studio toolbar.

The Portfolio has two parts: (1) an upper Categories group and    (2) a lower Designs group where you drag designs for storage. 
The Designs group shows a list of thumbnails representing the designs in the selected category.

 

You can maintain your own collection of Portfolio designs by adding and deleting items, with the option of naming individual 
elements to facilitate rapid access. There's even a Find feature that lets you search for designs by name or text content.

To add, delete, or rename Portfolio categories:

1 Right-click in the Categories group and choose Add Category..., Delete Category..., or Rename Category....

2 Use the dialog to enter and/or confirm your change.

To move or copy an object into the Portfolio:

1 To move, drag the object from the page and drop it onto the Designs group. To copy, press the Ctrl key before starting to drag. 

2 If the Prompt for Name option is turned on (see "Naming Designs"), you'll be prompted to type a name for the design. (You 
can name or rename the design later, if you wish.) By default, unnamed designs are labeled as "Unnamed Design." 

3 A thumbnail of the design appears in the Designs group, and its name or label appears in the list above.

Note: To undo a Portfolio move or copy operation, press Ctrl+Z or click the Undo button on the Standard toolbar.

To use a design from the Portfolio:

n Click its thumbnail in the Designs group and drag it out onto the page. The Portfolio retains a copy of the design until you 
expressly delete it.

To delete a design from the Portfolio:

n Right-click its thumbnail and choose Delete Design from the submenu. 

If you want the Portfolio to present a confirmation dialog each time you delete a design, right-click anywhere on the Portfolio and 
select Confirm on Delete. (Or check the box in the Confirm Delete dialog.) Uncheck to bypass confirmation.

Note: You cannot undo a Portfolio delete operation.

To import an earlier PagePlus Portfolio file:

1 Choose Open... from the File menu and select the "All Files" option.

2 Locate the old PagePlus Portfolio file—it will have a .PPL extension—and open it.

The .PPL file is a publication containing all the objects in a particular portfolio category.

3 Drag the items you wish to retain into a new Portfolio, as described above.

Tip: Here's a trick for copying entire .PPL files from their old location (such as Program Files\Serif\PP70\Portfolio) to the 
equivalent PagePlus 8.0 location. Note the base name of the .PPL file you copied, and create a category of the same name in 
PagePlus 8. It will be empty at first, but the next time you launch PagePlus 8, you'll see the contents of the copied .PPL file. 

Naming designs
To rename a design:

n Double-click on it, or right-click its thumbnail and choose Rename Design. Type the new name and click OK. The new name 
appears immediately in the Designs group list.

If you want the Portfolio to prompt you for a name each time you drag in a new design, right-click on the Designs group and 
select Prompt for Name. (Or check the "Always prompt" box in the Edit Design Name dialog.) Uncheck to bypass the prompt.

Tip: Since the Designs group sorts designs alphabetically by name, you can use initial number or letter sequences to group your 
designs logically. For example, use abbreviations like HDL or LG for headlines and logos, or PIC and TXT to separate picture 
and text objects. This will help you manage a large set of Portfolio items within one category. If the set gets too big, create a new 
category (see above).



Finding designs
To locate a design based on its name or the text it contains:

1 Right-click on the Portfolio and choose Find Design.... 

2 Type the text to find and click Find Next. Starting from the first item displayed, PagePlus searches for the next design (if any) 
whose name or text includes the search text. The search spans all your Portfolio categories.

3 Click Find Next to continue the search, or Close to exit.



Importing PhotoCD images

PhotoCDs contain high-quality, color photographic images at several different resolutions so you can choose which resolution or 
quality is appropriate. You can import Kodak PhotoCD images into PagePlus. 

To import a PhotoCD image:

1 Insert a PhotoCD disc in your CD-ROM drive.

2 Choose Picture... from the Insert menu and select PhotoCD... from the submenu. 

You'll see the PhotoCD Gallery, displaying image thumbnails.

3 Use the Next and Previous buttons to find the desired picture and then click OK. 

4 In the dialog, specify the number of colors and resolution (pixel dimensions) at which to import the image. 

More about PhotoCD images...
At higher sizes, PhotoCD images are very cumbersome to work with, so use moderate sizes is possible. For print work, the 
"768x512" resolution generally gives best results. 

For Web publications, first estimate the pixel dimensions the image will occupy on your Web page. There's no need to start with 
a much larger image.

You can use most photo (paint) editing programs to resize or otherwise manipulate the image. Use the JPEG (.JPG) format    to 
save photographic images in compressed form, but don't repeatedly save as JPEG—image quality may suffer.

If you'll be including photographs on the printed page, use the Photo Optimizer to ensure the best possible reproduction on your 
specific printer. See Optimizing pictures for printing.



Importing TWAIN images

If your scanner or digital camera provides TWAIN support, you can scan pictures directly into PagePlus using the TWAIN 
standard. Or, save the scanned image separately and then import into PagePlus.

To set up your TWAIN device for importing:

n See the documentation supplied with your scanner for operating instructions. 

To import a scanned image:

n Choose Picture... from the Insert menu, then select TWAIN and Acquire from the submenu to open a file selection dialog.

If you have more than one TWAIN-compatible device installed, you may need to select which source you wish to scan with. 

To select a different TWAIN source for scanning:

1 Choose Picture... from the Insert menu, then select TWAIN and Select Source from the submenu.

2 Identify the device you want to use as your TWAIN source.

Suggestions for image scanning
First the tips... then the theory!

n As a general rule, the optimal scanning resolution for print work (in dpi) is about one-third the dots-per-inch setting (i.e. twice 
the resultant lines per inch) on the printer or other device that will be used. If you're printing at 600dpi, then 200 dpi scanning 
is fine.

n For an image that will end up on a Web page, it's possible you can get great results scanning at 100dpi, using exactly the 
screen dimensions you need. If you're going to edit the image, increase the dpi to be on the safe side.

n For line art and halftone images, save as a black-and-white TIFF, PCX, or GIF. 

n For grayscale photographic images, scan using grayscales and save as a grayscale TIFF file. If you have a color scanner, 
save a color TIFF. You can resize these images and still maintain reasonable quality, provided you don't make them 
significantly larger than the original. In general, the number of grayscales or colors is a more important issue than the actual 
resolution (dpi).

Scanned images, especially color, can get very large and you need to take this into consideration. Large files take a long time to 
load, save and print and eat your disk space! One myth is that the higher the resolution of your scanner, the better results you'll 
achieve. While that's true in theory, the real limit to quality is how the image will ultimately be reproduced. Will it end up on the 
printed page or on-screen? Either way, the real issue is how many "extra pixels" you'll need in the original scan.

Printed output: If the image will be professionally printed, will that be onto a sheet of newsprint or a glossy coated stock? Paper 
itself puts a ceiling on reproduction quality. Lower-grade paper tends to spread ink around more easily, so the dots of ink used to 
print a picture need to be larger. This means a wider halftone screen with fewer lines per inch (lpi). 

If you'll generate your output on a desktop printer, the device will be putting bits of toner or droplets of ink on the paper. On a 
laser printer, shades of gray result from variations in toner coverage. Desktop color printers create color by laying down dots of 
cyan, magenta, yellow, and black ink. Again, printer resolution and paper type are quite variable. Dpi (dots per inch) is the most 
common measure of print quality. But the lines per inch, based on halftone reproduction, is equally useful. A print resolution of 
600 dpi corresponds to about 100 lpi—that's how we arrived at the 200 dpi scanning recommendation above.

Screen output: If your image will end up on-screen instead of in print, it will no doubt be viewed at standard screen resolution of 
96 dpi. (That's why this is the default resolution in PagePlus.) If you're producing Web images, it makes more sense to regard 
resolution as a fixed factor, and think in terms of image dimensions instead. This means that, for an image that will end up on a 
Web page without any editing, you can get away with scanning at 100dpi, using the screen dimensions you'll need on the Web 
page. But that's cutting it close, especially if you'll be editing the image at all.



Inserting a calendar

The Calendar Wizard helps you design a month-at-a-glance calendar to use in any publication. You can create a postage-stamp 
graphic or a full-page "planner." Options include year, month, week and day labeling, room to write, and numerous format 
options. The calendar is created as a text-based table so you can edit it using the standard text tools.

To insert a calendar:

1 Click the Insert button on the Tools toolbar and choose  Calendar from the flyout submenu. 

2 Click again on your page, or drag out to indicate the desired size of the calendar.

The Calendar Wizard then helps you pick a preset and define options for your calendar.



Selecting an object

Before you can change an object, you need to select it.

To select an object:

n Choose a tool (see below).

n Click on the object. A gray bounding box appears, with small "handles" appear defining the object's corners and edges. 

n If objects overlap, click with the Alt key down until the desired object is selected. See below for notes on selecting text objects.

When selecting a text object with the Pointer tool:

n Clicking on a text object with the Pointer tool selects the object and also positions the blinking text selection cursor within the 
object's text. In this mode, you can edit the text. 

n Double-click to select a word, and triple-click to select a paragraph.

n Press the Delete key to delete characters after the cursor. To delete the frame itself, choose Delete Object from the Edit 
menu. 

n To select only the frame (for example, to adjust its margin and column guides), click the frame's bounding box. 

Ruler regions
When you click to select an object, white ruler regions indicate the left, right, top, and bottom edges of the object.

 

For details on using the rulers, see the topic Using the rulers.

Selection tools on the Tools menu:

 Pointer tool
Click to use the Pointer tool to select, move, copy, and resize objects.

 Rotate tool
Click to use the Rotate tool to rotate an object around its top left handle. 
Select the object, then drag one of its handles. You can also use the Rotate 
tool to move and copy objects. See Rotating an object.

 Square Crop and Irregular Crop tools
Click to use one of the Crop tools to crop (or trim) objects. Select the 
object, then drag one of its handles inward. You can also use a Crop tool to 
move and copy objects. See Cropping an object.



Selecting multiple objects

Selecting more than one object at a time (creating a multiple selection) lets you:

n Position or resize all the objects at the same time.

n Create a group object from the multiple selection, which can then be treated as a single object, with the option of restoring 
the individual objects later.

See also Creating groups.

To create a multiple selection:

n Click in a blank area of the page and drag a "marquee" box around the objects you want to select. 

OR
n Hold down the Shift key and click each object in turn.

To create a group from a multiple selection:

n Click the  Group button below the selection.
OR
Choose Group Objects... from the Arrange menu.

To add or remove an object from a multiple selection:

n Hold down the Shift key and click the object to be added or removed.

To deselect all objects in a multiple selection:

n Click in a blank area of the page.



Copying, pasting, and replicating objects

Besides using the Windows Clipboard to copy and paste objects, you can duplicate objects easily using drag-and-drop, and 
replicate multiple copies of any object in precise formations. 

To copy an object (or multiple selection) to the Windows Clipboard:

n Right-click the object and choose Copy from the submenu. 

OR

n Select the object and press Ctrl+C, or choose Copy from the Edit menu, or click the  Copy button on the Standard 
toolbar.

If you're using another Windows application, you can usually copy and paste objects via the Clipboard. 

To paste an object from the Clipboard:

n Right-click on the page and choose Paste from the submenu.

OR

n Press Ctrl+V, or choose Paste from the Edit menu, or click the  Paste button on the Standard toolbar.

The Paste command defaults to the PagePlus object format, if available. Pasted text will come in as a new frame. In some cases 
an application places several formats on the Clipboard. There are various Clipboard formats, including "picture" (i.e. metafile), 
"bitmap," "text," and "OLE."

To choose between alternative Clipboard formats:

n Choose Paste Special... from the Edit menu.

(For details on resizing standard-format pictures, see "Defining the size of pasted pictures" below.)

Note: If you're copying/pasting large images in bitmap rather than picture (metafile) format, having a metafile version on the 
Clipboard just consumes unnecessary memory. To reduce memory requirements in this situation, you can deselect the "Metafiles 
on Clipboard" option (Tools/Options.../General).

To duplicate an object:

1 Select the object, then press the Ctrl key. The cursor changes to the Copy cursor. 

2 Drag the outline to a new location on the page. You can release the Ctrl key once you've started the drag.

3 To constrain the position of the copy (to same horizontal or vertical), press and hold down the Shift key while dragging. 

A duplicate of the object appears at the new location.

Tips: 
n For making multiple copies, see "Replicating objects" below.

n In Normal view, with only one page displayed, if you intend to use an object on another page, but aren't quite ready to paste it 
into place, you can drag a duplicate to the pasteboard area. When you're ready to paste, go to the new page and drag the 
copy (or a copy of the copy) from the pasteboard. In Multipage view, of course, you can simply drag the copy from one page to 
another. (For details, see Changing views.)

n The Portfolio can store design objects you'd like to reuse in different publications. For details, see the topic Using the 
Portfolio.

Defining the size of pasted pictures
When you use Paste Special... and select a standard picture format (Bitmap, Device Independent Bitmap, or Metafile), you'll see 

the     Picture Paste cursor. What you do next determines the initial size and placement of the image:

n To insert the picture at a default size, simply click the mouse.

OR
n To set the size of the inserted picture, drag out a region and release the mouse button. 

When you click to paste in a picture, you can tell in advance what size PagePlus thinks the picture should be—white regions 
appear in the rulers. If you don't want this size, drag instead.

Notes: 
n Bitmaps are inserted using a default screen resolution setting of 96dpi. If the bitmap has a different internal setting, PagePlus 

will observe this and scale the image accordingly.

n GIF, JPEG, and PNG images are commonly used in Web Publishing mode. Even if these are scaled down on the publication 



page, the original file size is preserved and (if exported to a Web page) the image will take longer to display. As a rule, 
downscale these images first in a paint program, then import them to PagePlus. For details on bitmap formats for the Web, 
see the subtopic About Web picture formats.

Replicating objects
Duplicating an object (see above) means making just one copy at a time. The Replicate command lets you create multiple 
copies in a single step, with precise control over how the copies are arrranged, either as a linear series or a grid. You can include 
one or more transformations to produce an interesting array of rotated and/or resized objects. It's great for repeating 
backgrounds, or for perfectly-aligned montages of an image or object.

 

To replicate an object:
1 Select the object to be replicated and choose Replicate... from the Edit menu. The Replicate dialog appears.

2 To arrange copies in a straight line, select Line. For an X-by-Y grid arrangement, select Grid.

3 Specify the number of objects (including the original) in the arrangement, or the grid dimensions.

4 Set spacing between the objects as either a Gap (measured between the top left corners of successive objects) or an Offset 
(between the bottom right and top left corners). You can specify a Horizontal and/or Vertical shift, and/or an angular 
Rotation. To set a specific horizontal or vertical interval, check Absolute; uncheck the box to specify the interval as a 
percentage of the original object's dimensions.

5 Click OK. 

The result is a multiple selection. Click its  Group button if you want to keep the separate objects linked for additional 
manipulations.



Moving objects

To move an object (including a multiple selection):

n Click within the object (not on a handle) and drag it to the new location while holding down the left mouse button. 

OR
n Drag the object's gray bounding box.

The view automatically recenters itself as you drag objects to the edge of the screen. 

Tip: In Multipage view, you can drag and drop objects between pages. Use the  Multipage button on the View toolbar to set 
up a convenient viewing mode. 

To constrain the movement of an object to horizontal or vertical:
n Select the object and use the keyboard arrows (up, down, left, right).

OR
1 Press and hold down the Shift key after you begin dragging the object.

2 Release the Shift key after you release the left mouse button.

See also Aligning objects.

Specifying an object's position with the ChangeBar
The ChangeBar includes controls for fine-tuning the position of a selected object:

 
Horizontal position
Changes the horizontal placement of the object's top left corner, with 
respect to the ruler's zero point. The higher the value, the further to the 
right.

 
Vertical position 
Changes the vertical placement of the object's top left corner, with respect 
to the ruler's zero point. The higher the value, the lower on the page.



Resizing objects

To resize an object (in general):

1 Select the object.

2 Click one of the object's handles and drag it to a new position while holding down the left mouse button.

Dragging from an edge handle resizes in one dimension, by moving that edge. Dragging from a corner handle resizes in two 
dimensions, by moving two edges. You can also constrain the resizing—note that pictures normally behave differently from lines, 
shapes, and text objects.

Resizing lines, shapes, frame objects, and table objects
Text in frames and tables doesn't change size when the container object is resized. 

To resize freely:

n Drag from a corner (or line end) handle.

To constrain a shape, frame object, or table object when resizing:

n Hold the Shift key down and drag from a corner (or line end) handle.

Note: For shapes, this has the effect of keeping a square as a square, a circle as a circle, etc. Unless the object was a square or 
circle to start with, this will alter the aspect ratio. There is no specific command to preserve the aspect ratio of a box or ellipse. 

Resizing pictures and artistic text objects
These objects are normally constrained when resized, since you'll typically want to preserve their proportions. 

To resize while maintaining aspect ratio (proportions):

n Drag from a corner handle.

To resize freely:

n Hold the Shift key down and drag from a corner handle.

Note: Imported GIF and JPEG images, commonly used in Web Publishing mode, are treated as separate images and inserted 
with the original file name unaltered. Even if these are scaled down on the publication page, the original file size is preserved and 
(if exported to a Web page) the image will take longer to display. As a rule, downscale these images first in a paint program, then 
import them to PagePlus. 

Resizing groups
You can resize a group object. The size of images, graphic objects, and text objects in the group will change. The size of text 
inside frames or tables won't change, only the size of the text container.

Note: You can move, but cannot resize, a multiple selection. Turn the multiple selection into a group first, by clicking the  
Group button below the selection.

Setting the size of an imported picture
When using the Import Picture command, after you've selected the file to open, the dialog disappears and the mouse pointer 

changes to the     Picture Paste cursor. What you do next determines the initial size and placement of the image:
n To insert the picture at a default size, simply click the mouse.

OR
n To set the size of the inserted picture, drag out a region and release the mouse button. 

When you click to paste in a picture, you can tell in advance what size PagePlus thinks the picture should be—white regions 
appear in the rulers. If you don't want this size, drag instead.

Note: PagePlus imports paint-type (bitmap) pictures at screen resolution (96dpi). If the bitmap has a different internal setting, 
PagePlus will observe this and scale the image accordingly.



Locking an object's size or position 

To prevent accidentally moving, resizing, flipping, or rotating an object, you can lock it in position. 

To lock an object:

n Right-click on the object and check Lock Object.

To unlock an object:

n Right-click on it and uncheck Lock Object.



Layering objects

As objects are created, they are layered in such away that the most recently created object will overlap earlier ones. You can 
change the layering order, which affects how objects appear on the page. 

To change the object's position in the layering order: 

n Right-click on the object and choose Layer. 

OR
n Click the Arrange menu.

Then:

n To shift the selected object's position to the bottom layer, behind all other objects, select Send to Back. You can also use the 

 Send to Back button on the Standard toolbar.

n To shift the selected object's position to the top layer, in front of all other objects, select Bring to Front. You can also use the 

 Bring to Front button on the Standard toolbar.

n To shift the object's position one layer toward the front, select Forward One.

n To shift the object's position one layer toward the back, select Back One.



Aligning objects

Precise alignment is one key to a professional layout. You can use menu commands to align the edges of any two or more 
objects with one another, or align objects with a page edge. In addition, layout tools such as rulers and the dot grid provide 
guides to assist you in placing objects on the page. Snapping (see the next topic) lets you align objects with nearby guides.

To align the edges of two or more objects:

1 Using the Pointer tool, Shift-click on all the objects you want to align, or draw a marquee box around them, to create a 
multiple selection.

2 Choose Align Objects... from the Arrange or right-click menu.

3 In the dialog, check one or more options for vertical and/or horizontal alignment. To uncheck all options (the default), click the 
No Change buttons. 

To align one or more objects with a page edge:

n Follow the steps above, but check the Include Page option. (If only one object is selected, page-edge alignment is automatic.)

Using ruler guides
PagePlus lets you to set up horizontal and vertical ruler guides—non-printing, red lines you can use to align headlines, pictures, 
and other layout elements "by eye," and also as a snapping aid.

n To create a ruler guide, click on a ruler. The red ruler guide line appears. 

Note: If a text object is selected, clicking within the object's ruler region adds a tab stop. Clicking elsewhere on the ruler creates 
a guide.

n To move a guide, drag it. 

n To remove a guide, drag and drop it anywhere outside the page area. 

n To lock ruler guides, choose Tools/Options... and select the Rulers page, then check Lock Ruler Guides.

n To fine-position ruler guides, choose Layout Guides... from the File menu (or right-click menu) and select the Ruler tab. You 
can use the tab to create or delete individual guides. To delete all ruler guides at once,    click the Clear All button.

Using the dot grid
The dot grid is a matrix of dots or lines based on ruler units, covering the page and pasteboard areas. Like ruler guides, it's 
handy for both visual alignment and snapping.

To turn the dot grid on and off:
n Check (or uncheck) Dot Grid on the View menu. 

OR
n Choose Options... from the Tools menu and display the Layout page. Check or uncheck Grid Dots.

 

You can set the grid spacing, style, and color in the Options dialog. 

To change the grid spacing, style, and/or color:

1 Choose Options... from the Tools menu and display the Layout page. 

2 To set the grid interval, enter a value in the "Grid lines every" box.

3 To display the grid using dots, select "Dotted" as the "Grid style." To display grid lines, select "Solid."

4 To change the color of grid dots, click the Color button and then select a color thumbnail.



Snapping

The snapping feature simplifies placement and alignment by "magnetizing" grid dots and guide lines. When snapping is on, 
objects you create, move, or resize will jump to align with the nearest visible grid dot or guide line. Objects normally snap to the 
page edge, too.

The dot grid (see the previous topic) is a matrix of dots or lines based on ruler units, covering the page and pasteboard areas.

Guide lines include ruler guides (see previous topic) as well as layout guide lines based on page margins, rows, and columns 
(see the topic Setting guides for page margins, rows, and columns).

To turn snapping on and off:

n Click the  Snapping button on the HintLine toolbar. When the button is down, snapping is on. 

Selective snapping
You control which points and lines are snapped-to by showing or hiding the individual guide elements, and by changing options 
settings for visible elements.

To show or hide guide elements:

n Check (or uncheck) the element's name on the View or menu. 

OR 
Right-click on the page or pasteboard and choose Display, then check or uncheck the element's name.

Note: The "Guide Lines" setting controls ruler guides you've placed as well as page margin guides and row/column guides. 
"Frames" controls frame borders, margins, and columns. "Dot Grid" controls the dot grid.

To set which visible elements are snapped to:

1 Choose Options... from the Tools menu.

2 Under "Snap to:" on the Layout tab, uncheck any elements you don't want to snap to. The choices include Grid dots, Page 
edge, Page margins, Ruler guides, and Row/column guides.



Converting an object to a picture 

See Also: For details on other key aspects of working with images in PagePlus, see these topics: Importing images, Exporting 
as a picture, and Setting Web picture display options.

The Convert To Picture function deletes the selected object or group and replaces it with an embedded picture representation. 
It has many practical uses, for example:

n Combining objects into a permanent graphic, such as a logo created from multiple text, graphic, and picture objects. The 
resulting graphic can then be sized, positioned, and rotated as a single object.

n Creating a composite shape from multiple graphics.

n Specifying a preferred image format for a particular need, for example to minimize file size or optimize Web quality.

You can select from a variety of standard image file formats—either metafile (which in PagePlus can include mixed text, vector, 
and bitmap information) or the common bitmap formats. The default bitmap format is .PNG for best quality, but you might 
choose .JPG or .GIF to reduce file size, or another format depending on the publication. (For details on image formats, see 
Importing images and Setting Web picture display options.)

Remember that Convert to Picture is a one-way process, so any objects which are converted will no longer exist as separately 
editable objects.

To convert one or more objects to a picture:

1 Select the object or Shift-click (or drag a marquee) to select multiple objects.

2 Choose Convert To Picture from the Tools or right-click menu.

3 Select an image type, either Metafile or Bitmap.

4 For bitmap output, choose a specific image format from the list. To specify settings such as compression or transparency, click 
the Settings button. 

5 Click OK.



Exporting as a picture

See Also: For details on other key aspects of working with images in PagePlus, see these topics: Importing images, Converting 
an object to a picture, and Setting Web picture display options.

Exporting as a picture lets you convert all the objects on the pasteboard and page, or just the currently selected object(s), to an 
image file, using a file format you specify. It's particularly useful for generating logos and pictures to be used in publications 
created in other applications, such as a word processor.

To export as a picture:

1 (If exporting objects, not the whole page) Select the object or Shift-click (or drag a marquee) to select multiple objects.

2 Choose Export As Picture... from the File menu.

3 In the "List files of type" box, select an image file format.

4 Specify a folder and file name for the picture.

5 To export just selected object(s), check Selected object(s). To export the whole page, uncheck this box.

6 To choose from export options such as resolution, color, and transparency, check Show Filter Options. 

7 Click Save. You'll see export options, if available and requested, for the particular export filter in use.

The "Resolution" and "Color" options are only available for bitmap type pictures. Remember that the higher the resolution the 
larger the resulting picture file. Note, there is little point in generating color pictures if you are printing to a monochrome printer!



Creating groups

You can easily turn a multiple selection (see Selecting multiple objects) into a group object. When objects are grouped, you can 
position, resize, or rotate the objects all at the same time.

To create a group from a multiple selection:

n Click the  Group button below the selection.
OR
Choose Group Objects... from the Arrange menu.

To ungroup (turn a group back into a multiple selection):

n Click the    Ungroup button below the selection.
OR
Choose Ungroup Objects... from the Arrange menu.

Notes: 

n The objects that comprise a group are intact, but can't be edited individually. In general, any operation you carry out on the 
group affects each member of the group. Each object in a group retains its original wrap setting. If you apply a wrap setting to 
the group, each object (rather than the group as a whole) takes that setting. To flow text around a group, extend the wrap 
outline of one of the group's objects (to encompass all the objects) and then carry out the grouping operation.

n To apply a hyperlink to a group object (such as a button or other Web object from the PagePlus Gallery), first ungroup the 
object, then apply the hyperlink to the uppermost object and regroup all the objects.



Rotating an object

You can rotate objects, including text objects and groups. (You cannot rotate a multiple selection.)

Note: In Web Publishing mode, rotated text is published as a graphic.

To rotate an object counter-clockwise around its top left handle:

n Select the  Rotate tool on the Tools toolbar.

n Click to select the object, then drag one of its handles. 

Note: You can also use the Rotate tool to move and copy objects.

Tip: As a shortcut, you can position the cursor over an object handle, then press the Alt key. This temporarily switches to the 
Rotate tool. 

To constrain rotation in 15-degree steps:

n Press the Shift key after you've begun rotation, and hold it down until after you release the mouse button.

To unrotate (restore the original orientation):

n Double-click the object. 

n To restore the rotated position, double-click again.

To rotate an object 90 degrees left or right:

n Select the object and click the  Rotate Left or 

 Rotate Right button on the Standard toolbar.

To fine-tune rotation:

1 Display the ChangeBar. Using the  Object rotation control...

2 Click the right arrow and drag the slider to adjust rotation continuously.
OR
Click the small up or down "nudge" buttons to adjust in increments. 

OR 
Click in the text box, then press the up or down arrows on the keyboard to adjust values incrementally.

OR 
Type in an exact value and press the Enter key.

To prevent a picture object from accidentally being rotated:

n Right-click on the object and select Lock Object from the submenu.



Flipping an object

You can flip objects horizontally or vertically. You can flip text frames, but not their text. 

To flip an object horizontally (left to right; top and bottom stay the same):

n Select the object and click the  Flip Horizontal button on the Standard toolbar.

To flip an object vertically (top to bottom; left and right stay the same):

n Select the object and click the  Flip Vertical button on the Standard toolbar.

To prevent an object from accidentally being flipped:

n Right-click on the object and select Lock Object from the submenu.



Cropping an object

Cropping means masking (hiding) parts of an object, for example to improve composition or create a special effect. The 
underlying object is intact. You can use either the Square or Irregular Crop tool to adjust the object's crop outline. 

Both Crop tools work with single objects, not with multiple selections or group objects. You can use either Crop tool to select, 
move, or copy objects. You can even rotate a cropped object or crop a rotated object.

The Studio's Gallery tab includes a category of pre-shaped masks you can drag onto the page as a quick way of cropping photos 
or other content. The Attributes tab's Transparency panel includes a category of "Photo Edge Effects" that provide soft-edge 
(vignette) masking.

To crop using the object's original outline:

1 Select the  Square Crop tool on the Tools toolbar.

2 Click to select the object, then drag one of its edge or corner handles inward. Press the Shift key for free (unconstrained) 
cropping.

You can manually adjust the crop outline using the Curve toolbar for more precise text fitting. The list below gives a quick 
summary of options. For more options when using the Curve Toolbar, see the subtopic Editing lines. 

To crop by modifying the object's outline:

n Select the object and click the  Irregular Crop tool on the Tools toolbar.
The Curve Toolbar appears, and you'll see the nodes and connecting segments that define the object's crop outline.

n To move a node (control point) where you see the  cursor, drag the node.

n To move a line segment (between two nodes) where you see the  cursor, drag the segment.

n To convert an outline from straight lines to curves, click the  Fit Curves button on the Curve toolbar.

n To adjust the curvature of a segment, drag the control handle(s) of the adjacent nodes.

n To add or delete nodes for more or less complex outlines, select a node and click the  Add Node or 

 Delete Node button on the Curve toolbar.
n To move the object relative to its crop outline, drag its interior when you see the hand cursor.

To scroll the visible portion of a cropped object within the crop area:

n Select the object and drag its center area. 

To uncrop (restore full visibility):

n Double-click the object.

n To restore the cropped state, double-click again.

To prevent a picture object from accidentally being cropped:

n Right-click on the object and select Lock Object from the submenu.

Objects also have a wrap outline which determines how text flow changes if the object overlaps a text frame. Initially the wrap 
outline is set to match the crop outline, but for adjustment purposes the two are independent unless you specify that the crop 
outline should match the wrap outline. If you're planning to wrap text around an object and also need to crop it somewhat, it will 
save effort to adjust the wrap outline first, then set the crop outline to match.

To crop a selected object to its wrap outline:

1 Right-click the object and choose Wrap Settings....
OR

Click the  Wrap Settings button on the Arrange toolbar, or choose Wrap Settings... from the Arrange menu.

2 Check the Crop object to wrap outline box.

For details, see Wrapping text to an object.



Applying solid colors

PagePlus offers a number of ways to apply solid colors to objects of different kinds:

n You can apply solid colors to an object's line or as a solid fill. As you might expect, QuickShapes and closed shapes (see 
Drawing shapes) have both line and fill properties, whereas straight and freehand lines have only a line property. (For a 
discussion of line attributes besides color, see the topic Setting line properties.)

Note: You can also apply a multi-color gradient fill to a shape and vary the colors used in the fill. For details, see the next 
topic.

n Characters in text objects can have color, and text frames and table cells can have a background fill independent of the 
characters they contain.

n You can colorize a paint-type (bitmap) picture—that is, recolor it to use a different color. If you recolor a full-color picture, the 
colors will convert to tints or shades of the specified color. You can also apply tinting to a full-color picture to produce a low-
intensity picture (useful for backgrounds behind text).

         

You can use either the Studio's Attributes tab or a dialog box to apply solid colors to an object. The Studio's Shade/Tint gallery 
displays variants of the original color selected in the Color gallery. Shades (shown with negative values) progressively add black to 
the starting color for a darkening effect, while tints progressively add white for a lightening effect. For example, a "-90%" shade 
means one part black to nine parts of the original color, while a "90%" tint means one part white to nine parts of the original color. 

To apply a solid color using the Studio:

1 Select the object(s) or highlight a range of text.

2 Click Attributes on the Studio toolbar and display the Color panel.

The Color gallery provides samples of available colors from the PagePlus color palette. For details on using the numbered 
Scheme Colors, see the topic Using color cchemes.

3 Click the  Fill, 

 Text, or 

 Line button above the Color gallery to determine where color will be applied. Left-click a sample in the Color or Shade/Tint 
gallery to apply the color.
OR
Right-click a sample, then choose either Apply to Line, Apply to Fill, Apply to Both, or Apply to Text depending on the desired 
effect.

To apply a solid color using a dialog box:

1 Right-click the object and choose Fill... (or Line and Border...), or select it and choose Fill... (or Line and Border...) from the 
Format menu.

2 Adjust the dialog settings for Color and Shade/Tint.    When defining a fill, use the "Solid" type if applying a solid color, but note 
that you can also use the Fill dialog to apply a gradient fill.

More on using solid colors...
n To modify a color or define a new color, right-click any color sample and choose Edit or New..... For details, see the topic 

Creating your own colors.

n The top left cell in the gallery shows , which represents either None (a transparent interior for objects with line/fill 
properties) or Original (for pictures only, to reset the object to its original colors).

n The [Register] color shown in certain dialog lists is used to create custom registration marks for color separations. It will 
appear as black on all output sheets.

n Pictures: To colorize a picture, right-click it and choose Picture Properties.... To set a specific color as transparent, right-click 
the picture and choose Picture Transparency.... 

n Draw-type images: Using the Color Mapper, you can make extensive color changes to draw-type (vector) images and vector-
based OLE objects. See Changing or copying image colors.

For notes on the 256-color .GIF format, commonly used for transparent Web images, see Setting Web picture display options.





Working with gradient and Bitmap fills

Gradient fills provide a gradation or spectrum of colors spreading between two or more colors. A gradient fill has an editable 
path with nodes that mark the origin of each of these key colors. A Bitmap fill uses a named bitmap—often a material, pattern, 
or background image—to fill an object. PagePlus supplies over 200 preset Bitmap fills on the Fill tab, and you can import your 
own. You can recolor Bitmap fills using the "Color Fill" filter effect. (For details on applying a solid color fill, see the previous 
topic.)

 
You can apply gradient and Bitmap fills from the Studio to shapes, text frames, table cells, and to the actual characters in artistic text 
objects. Using the Fill tool, you can vary the fill's path on an object for different effects.

Click the links below for subtopics on:
Applying a gradient or Bitmap fill 
Editng the fill path 
Editing the gradient fill spectrum 

Changing the set of gradient gallery fills 

Changing the set of Bitmap gallery fills

Setting the default fill 

Note: Transparency is also applied locally to each object; the default is "None." Applying different transparency effects (using the 
Transparency panel of the Attributes tab) won't alter the object's fill settings as such, but may significantly alter a fill's actual 
appearance. For details, see the topic Working with transparency effects.

Applying a gradient or Bitmap fill
There are three ways to apply a gradient or Bitmap fill: using the Fill tool, the Studio's Attributes tab, or a dialog. The dialog lets 
you add or subtract key colors from the gradient (see Editing the fill spectrum below), apply different key colors to individual 
nodes, or vary the overall shading of the effect applied to the object.

To apply a gradient fill with the Fill tool:

1 Select an object.

2 Click the  Fill Tool button on the Tools toolbar.

3 Click and drag on the object to define the fill path. The object takes a simple Linear fill, grading from the object's current color 
to white.

To apply a gradient or Bitmap fill using the Studio:

1 Click the Studio's Attributes tab and select the Fill panel.

2 Display the desired fill gallery, select the object(s), and click a gallery sample for the fill you want to apply. 
OR
Drag from the gallery sample onto any object and release the mouse button. 

3 Adjust the fill's shade/tint as needed with the Fill tab slider.

To apply or edit a gradient or Bitmap fill using a dialog:

1 Right-click the object and choose Fill..., or select it and choose Fill... from the Format menu.

2 Choose the fill type and the desired fill category. Note that you can also use the Fill dialog to apply a solid fill, or no fill.

3 For a two-color gradient, click the From button to pick a starting color, and click the To button to pick an ending color. A two-
color gradient has two nodes, one at each end of its path. For Bitmap fills, click a gallery sample.

4 For gradient fills, click the Edit button if you want to add or subtract key colors from the gradient (see Editing the fill spectrum 
below), apply different key colors to individual nodes, or vary the overall shading of the effect applied to the object. You can 
adjust the fill's shade/tint as needed using the list.

5 Click OK to apply the effect of the fill to the object.

 

Editing the fill path
When you select a fillable object, the Fill tool becomes available (otherwise it's grayed out). If the object uses a gradient fill, 



you'll see the fill path displayed as a line, with nodes marking where the spectrum between each key color begins and ends. 
Adjusting the node positions determines the actual spread of colors between nodes. You can also edit a gradient fill by adding, 
deleting, or changing key colors (see below). 

  

To adjust the gradient fill path on a selected object:

1 Click the  Fill Tool button on the Tools toolbar. The object's fill path appears.

2 Use the Fill tool to drag the start and end path nodes, or click on the object for a new start node and drag out a new fill path. 
The gradient starts where you place the start node, and ends where you place the end node.

Each gradient fill type has a characteristic path. For example, Linear fills have single-line paths, while Radial fills have a two-line 
path so you can adjust the fill's extent in two directions away from the center. 

Experiment to discover new effects! For example, you can widen or narrow the gradient's extent, even drag either node 
completely outside the object. Or, for Radial fills on a round shape, try placing the start node near the figure's upper edge, off-
center, to create a reflection highlight. 

If the object uses a Bitmap fill, you'll see the fill path displayed as two lines joined at a center point. Nodes mark the fill's center 
and edges. 

Unlike the other fill types, Bitmap fills 
don't simply "end" at the edges of their 
fill path. Rather, they tile (repeat) so you 
can fill indefinitely large regions at any 
scale. By dragging the edge nodes in or 
out with the Fill tool, you can "zoom" in 
or out on the fill pattern.

For example, these two shapes use identical Bitmap fills with different fill path settings:

  
  
To adjust the path of a Bitmap fill on a selected object:

1 Click the  Fill Tool button on the Tools toolbar. The object's fill path appears.

2 Use the Fill tool to drag the center and/or edge nodes, or click on the object for a new center node and drag out a new fill path.

3 To reposition the fill's center, drag the center node.

4 To adjust the fill's extent and tiling, drag one or both edge nodes in or out with respect to the center.

5 To create a skewed or tilted fill region, drag one or both edge nodes sideways.

6 To tilt the fill path in 15-degree increments, hold down the Shift key while dragging. The fill path is unskewed and "regularly 
sized"—that is, its size jumps in steps. To preserve the fill's aspect ratio, hold down the Ctrl key. For a combined effect, use 
both keys together.
Tip: The Ctrl-constrain technique is convenient if you want a Bitmap fill to extend to fill a box without tiling. One of the 
"regular" steps includes a setting where the fill matches the object's bounding box.

Tip: To combine bitmap-filled objects for a montage effect, experiment with transparency settings to allow one image to merge 
with another. (See the topic Working with transparency effects.)

 

Editing the gradient fill spectrum
Whether you're editing a gradient fill that's been already been applied to an object, or redefining one of the gallery fills, the basic 
concepts are the same. Whereas solid fills use a single color, all gradient fills utilize at least two key colors, with a spread of 



hues in between each key color, creating a "spectrum" effect. You can either edit the fill spectrum directly, using the Fill tool in 
conjunction with the Color panel of the Studio's Attributes tab, or use a dialog. 

To edit a gradient fill directly:

1 Select the filled object and select the Fill tool to display the object's fill path. Nodes mark the key colors where color spread(s) 
begin and end.

2 Click the Studio's Attributes tab and display the Color panel.

3 To add a key color, drag from a color sample onto a portion of the fill path where there is no node. A new node appears.

  

 
Note: Be sure the tip of the pointer is over the node or path (watch the cursor) when you release the mouse button. Otherwise 
the color will be applied to the whole object as a solid fill.

4 To change a key color, click its node, then click a color sample. 

  

 
OR
Drag from a color sample onto any node to change the key color of the node. 

  

 
5 To move a key color (except the end colors), simply use the Fill tool to drag its node to a new position along the fill path.

6 To delete a key color (except the end colors), select it and press Delete.

To edit a gradient fill using a dialog:

1 (On an object) Right-click the filled object and choose Fill.... In the dialog, click the Edit button.
OR
(Gallery fill) Right-click the fill sample and choose Edit....

In either case, an edit dialog appears displaying the gradient spectrum, with pointers marking the key colors where color 
spread(s) begin and end. 

  

In this example, the gradient has just one spread, between blue and yellow key colors. The dialog also includes a gallery with the 
solid colors from the PagePlus palette. Click More Colors... to choose colors from outside the palette.
Note: The color of the gradient's start node appears at the left, and that of the end node at the right.

2 To add a key color for more complex banding, click either on the spectrum or just below it, where you want to place the new 



key color. A new pointer appears, using black in this example. Note that the new pointer's arrow is black, indicating that it's 
selected; unselected pointers have white arrows.

3 To change a key color, click to select its pointer, then click the gallery sample for the color you want. In this example, we've 
changed the new key color to red. Note that the pointer shows the new key color, and is still selected.

4 To move a key color (except the end colors), simply drag its pointer to a new position along the spectrum.

5 To delete a key color (except the end colors), right-click its pointer, or select the pointer and press Delete. 

Note: Key color deletion is not reversible using Undo.

6 Click OK to accept changes, or Cancel to abandon changes.

Note: If the color gallery doesn't contain precisely the right colors for the gradient effect you want, you can add, delete, or 
redefine palette colors as needed. For details, see the topic Creating your own colors.

 

Changing the set of gradient gallery fills
If you've defined a new gradient fill by setting fill path and/or key colors, you can add it to the set of gallery fills shown on the Fill 
panel so that it will be available to use again. You can also define new fills or delete any of the existing gallery fills.

To add an object's fill to a fill gallery:

n Right-click the object and choose Add Fill to Studio.

OR
Select the object and choose Add Fill to Studio from the Format menu.

To define a new gallery fill: 

1 Right-click any gallery sample and choose Add....

2 Use the dialog as described for editing a gradient fill (see above)

3 Click OK to accept changes, or Cancel to abandon changes.

To delete a gallery fill:

n Right-click its sample and choose Delete.

Deleting a gallery fill doesn't affect any objects that have already been given that fill.

Note: There's no Undo for this action.

 

Changing the set of Bitmap gallery fills
The Bitmap gallery on the Fill tab provides a large selection of bitmaps, grouped into categories like Abstract, Material, Patterns, 
and so on. You can add or delete a bitmap or an entire category. In addition, if you've imported a bitmap onto your page, you can 
add that bitmap to the gallery to be used as a fill or transparency. (The Bitmap transparency gallery "mirrors" the contents of the 
fill gallery, so images added as fills automatically become available as transparencies.) 

To add a category to the Bitmap fill gallery:

1 Right-click any thumbnail and choose Add Category.... 

2 Type a category name into the dialog, and click OK. A new empty gallery category appears.

To delete a category from the Bitmap fill gallery:

1 Choose the category to delete in the drop-down list.

2 Right-click any thumbnail and choose Delete Category.... Click Yes to confirm deletion.



Note: There's no Undo for this action. To restore deleted categories, run the PagePlus Setup again, choosing the "Repair" 
option..

To delete a Bitmap fill from the gallery:

n Right-click the thumbnail and choose Delete. Click Yes to confirm deletion.

Deleting a gallery fill doesn't affect any objects that have already been given that fill.

Note: There's no Undo for this action. To restore the original set of Bitmap fills, run the PagePlus Setup again, choosing the 
"Repair" option.

 

To import a bitmap image file to the Bitmap fill gallery:

1 Choose the category to which you want to add a bitmap.

2 Right-click any thumbnail and choose Add.... The standard Import Picture dialog appears.

3 Use the dialog to locate the bitmap image file to import, and click Open.

A bitmap thumbnail appears, labeled with the image file name, in the selected gallery.

Note: Bitmap fills will not maintain CMYK data as stored in some TIFFs. If this is important, import the TIFF file and crop it to the 
desired shape rather than using it as a Bitmap fill.

Setting the default fill
The default fill means the fill that will be applied to the next new object you create. The default fill is just one attribute among 
many that are stored as defaults for each particular type of object: character text, text frames, and shapes. It's often easier to set 
up the defaults before you create new objects, rather than changing the properties later. 

To set local defaults for a particular type of object:

1 Create a single sample object and fine-tune its properties as desired—or use an existing object that already has the right 
properties. (For QuickShapes, you can use any QuickShape; all share the same set of defaults.)

2 Select the object that's the basis for the new defaults and choose Update Object Default from the Format menu.
OR
Right-click the sample object and choose Update Object Default. 

For more on setting defaults, see the topic Updating and saving defaults.

 



Using color schemes

A color scheme in PagePlus is a cluster of five complementary colors that you can apply to specific elements in one or more 
publications. The Studio's Schemes tab displays over 50 preset schemes from which to choose when you create a Page Wizard 
publication. Each publication can have just one color scheme at a time; the current scheme is highlighted in the Schemes tab. 
You can easily switch schemes, modify scheme colors, apply schemes to any publication, even create your own custom 
schemes. Color schemes are saved globally, so the full set of schemes is always available.

You'll probably first encounter color schemes after creating a Page Wizard publication. You can choose a particular scheme while 
completing the Wizard process, and later try out a different set of colors.

To select a different color scheme:

1 Click Schemes on the Studio toolbar. (For Page Wizard publications, the Wizard tab also displays the color scheme samples; 
click the Color Schemes category.)
You'll see the current scheme highlighted in the list.

2 Click a different color scheme sample. Any regions in the publication that have been assigned one of the five color scheme 
numbers (see below) are updated with the corresponding color from the new scheme.

You can repeat this selection process indefinitely. When you save a publication, its current color scheme is saved along with the 
document.

How color schemes work
Color schemes in PagePlus work much like a paint-by-numbers system, where various regions of a layout are coded with 
numbers, and a specific color is assigned (by number) to each region. For example, imagine a line drawing coded with the 
numbers 1 through 5. To fill it in, you'd use paint from jars also numbered 1 through 5. Swapping different colors into the paint 
jars, while keeping the numbers on the drawing the same, would produce quite a different painting.

 

n In PagePlus, the "paint jars" are five 
numbers you can assign to objects in 
your publication. They're known as 
"Scheme Color 1," "Scheme Color 2," 
and so on. When you apply Scheme 
Color 1 to an object, it's like saying, 
"Put the color from jar number 1 
here."

n The Schemes tab shows the various available schemes, each with a different set of five colors in the five "jars." Whichever 
named color scheme you select, that scheme's first color (as shown in its sample) will appear in regions defined as Scheme 
Color 1, its second color will map to Scheme Color 2, and so on throughout the publication.

The example below shows three different schemes as applied to a design that's been marked with Scheme Colors 1 through 5 
as in the example above. 

 

Modifying and creating color schemes
If you've tried various color schemes but haven't found one that's quite right, you can modify any of the colors in an existing scheme 
to create a new one, or create your own named scheme from scratch.

To modify or create a color scheme:
1 Right-click any color scheme sample (in the Schemes or Wizard tabs) and choose Scheme Manager..., or choose Scheme 

Manager... from the Tools menu. The Scheme Manager appears, with the current scheme highlighted on the Schemes tab.

2 To modify a different scheme, select its name in the scrolling list. 

3 Select the Custom tab. 

Each of the five scheme color numbers has its own drop-down list, showing available colors in the PagePlus palette. 

4 To set or change the color assigned to a particular number, simply select a color from the corresponding list. 

5 When you're done, click Save Scheme.... In general, enter a new name rather than leaving the old name unaltered. 

Notes

n Each publication stores a locally defined scheme which may or may not correspond to a named scheme. Modifying a scheme 
in the Scheme Manager updates the named scheme, but does not apply it to the publication. To ensure the publication uses 
the latest copy of the named scheme, reapply the named scheme using the Schemes tab. And when modifying a scheme 
repeatedly, first make sure the publication uses the latest copy.

n The Custom tab also lets you edit the special components associated with particular color schemes in Web publishing mode 



(see the topic Choosing Web site colors). By convention, Web Page Wizards use Scheme Color 1 for text.

n You can click More Colors... in any drop-down color list to add custom colors to the PagePlus palette (see the next topic). 

Applying scheme colors to new objects
If you create new elements in a Page Wizard publication, or start a publication from scratch, how can you extend a color scheme 
to the new objects? Although you'll need to spend some time working out which color combinations look best, the mechanics of 
the process are simple. Recalling the paint-by-numbers example above, all you need to do is assign one of the five scheme color 
numbers to an object's line and/or fill. 

To assign a scheme color to an object:

1 Display the Color panel of the Studio's Attributes tab. The five colors in the current scheme appear as numbered samples at 
the top of the panel.

2 Select the object and right-click the sample of the scheme color you want to apply. Choose Apply to Line, Apply to Fill, or 
Apply to Text, depending on the desired effect.

If an object's fill uses a scheme color, the corresponding sample will be highlighted whenever the object is selected.

Notes

n If you copy an object using scheme colors to another publication, it will take on that publication's color scheme. Don't be 
surprised if the object's color(s) change—they're supposed to!

n You can use the Color Mapper to apply scheme colors to draw-type (vector) images and vector-based OLE objects. See 
Changing or copying image colors.



Creating your own colors

The solid colors in the PagePlus palette are displayed as a gallery in the Color panel of the Studio's Attributes tab, and also in 
the Color Manager. You can use either of these to add, remove, or modify palette colors.

Note: Normally, the contents of the PagePlus color palette are just saved locally, along with a publication's current defaults. That 
is, they don't carry over to new publications. If you've created new colors, you can use the Save Defaults command to record 
the color settings globally, so they will be available whenever you create a new publication. For details, see Updating and saving 
defaults.

Using the Studio's Color panel

To add an object's solid fill color to the palette:

n Right-click the object and choose Add Fill to Studio.

OR
Select the object and choose Add Fill to Studio from the Format menu.

To edit a specific palette color:

1 Right-click a sample in the Color panel gallery and choose Edit.... The Color Picker appears.

2 Follow the steps below for modifying a selected color.

To add a custom color to the palette:

1 Right-click a sample in the Color panel gallery and choose New.... The Color Picker appears.

2 Follow the steps below for adding a custom color.

To remove a color from the PagePlus palette:

n Right-click a sample in the Color panel gallery and choose Delete.

Using the Color Picker and Color Manager

The Color Manager and Color Picker are complementary dialogs. 

n The Color Picker lets you choose a color to apply or mix custom colors. Its Models tab displays the color space of several 
established color models: RGB (red, green blue), HSL (hue, saturation, luminosity), CMYK (cyan, magenta, yellow, black), and 
PANTONE. For all color models, the values are in the range of 0 to 255. Its PagePlus Palette tab provides the gallery of 
PagePlus colors for you to choose from.

n The Color Manager lets you add, modify, or remove specific colors in the PagePlus palette.

To display the Color Manager:

n Right-click any color sample on the Attributes tab (Color panel) or Schemes tab and choose Color Manager.... 

OR
n Choose Color Manager... from the Tools menu.

To add a custom color to the PagePlus palette:

1 (From the Color Manager) Click the New... button.

2 On the Color Picker's Models tab, use the sliders or click a value to define or pick the new color, and enter an optional name.

3 When you're satisfied with the new color, click Add to Palette or OK. 

To modify a selected color in the PagePlus palette:

1 (From the Color Manager) Select the color you want to modify and click the Modify... button.

2 On the Color Picker's Models tab, choose a new color value to replace the old color. Enter an optional name.

3 When you're satisfied with the new color, click Add to Palette or OK. The old color is replaced with the new.

To remove a color from the PagePlus palette:

1 In the Color Manager, select the color to be removed.

2 Click the Remove button. 

To add a PANTONE® color to the PagePlus palette:



n Follow the steps above for adding a new color. On the Models tab, select PANTONE® in the Model list.

PANTONE refers to Pantone, Inc.'s check-standard trademark for color reproduction and color reproduction materials. For 
details, see Specifying PANTONE® colors.



Changing or copying image colors

Using the Color Mapper, you can make extensive color changes to draw-type (vector) images and vector-based OLE objects, or 
add selected colors to the PagePlus palette. The Color Mapper works well with .WMF files. It does not work with paint-type 
(bitmap) images—for these, use a dedicated photo editing tool such as Serif PhotoPlus. 

To open the Color Mapper: 

n Right-click the image and choose Color Mapper....

OR
n Select the image, choose Picture from the Format menu, and select Color Mapper... from the submenu. 

On the left, the Original Color list shows all the original colors used in the picture; on the right, the Current Color list displays new 
mapped colors. Initially, the two lists are the same. The PagePlus palette appears below.

To remap colors in the picture:

n Select a color from the Original Color list, then click a different color in the palette. The Current Color list and preview image 
are updated.

Note: You can use the Ctrl and Shift keys to select more than one color, or a range of colors.

To undo color changes:

n Select the color(s) to be restored, then click the Unmap button. Each selected color's Current Color value is reset to match its 
Original Color value.



Specifying PANTONE® colors

You can create virtually any color in PagePlus and add it to your color palette, and subsequently apply it to various objects. 
Unfortunately, color matching between your screen and printer will be poor. To overcome this, PagePlus includes PANTONE 
colors which can be added to your palette. When a PANTONE color is output, PagePlus is able to use printer-optimized color 
values to achieve a better color match.

In all cases, the screen displays an approximate color representation of the final printed color. You are cautioned not to use the 
screen for precise color matching, however; for accurate color reproduction, use official PANTONE color reference materials. In 
all cases, get a color proof of any color-separated work before you approve a print run. For details, see the "Production Issues" 
chapter in the PagePlus Companion.

To display the PANTONE Color Picker:

1 Choose Color Manager... from the Tools menu. The Color Manager appears.

2 On the Models tab, click PANTONE® in the Model list. 

Initially, the PANTONE Solid tab is displayed, showing solid (spot) colors. The Color Type box lets you adjust the screen display 
for different paper/printing situations. Coated Paper is the default; Uncoated Paper mutes the screen colors slightly. Convert to 
Process is applicable if you have the "Convert Pantone Spot Colors to Process" option set for CMYK separations in color 
printing. 

To choose a process color, click the PANTONE Process tab.

Both tabs of the PANTONE Color Picker feature a central swatch window displaying color samples and their PANTONE 
numbers; scroll horizontally (or use the keyboard arrows) to view the full range. Click any portion of the color spectrum below the 
window to see that region's swatches. The small numbers above the spectrum bar represent page numbers in the corresponding 
PANTONE color guide. To find a specific color, type its number (or name) into the Find Color Name box and press Enter. 

As you scroll in the swatch window, the currently selected color changes and appears as the "New" swatch in the small window 
at the lower left. To compare two colors in different parts of the spectrum, double-click the "New" swatch to display it as the 
adjacent "Original" color. Double-click the "Original" color to locate it again in the swatch window.

To add a PANTONE color to the palette:

1 In the PANTONE Color Picker, select the color to add.

2 Click OK (or double-click the color).

3 Click the Options button and select Add to Custom Palette.

The newly selected PANTONE color appears as a new color in the PagePlus palette.



Working with transparency effects

Transparency effects are great for highlights, shading and shadows, and simulating "rendered" realism. They can make the 
critical difference between flat-looking illustrations and images with depth and snap. PagePlus fully supports variable 
transparency and lets you apply gradient or Bitmap transparencies to create your own 32-bit, anti-aliased images. You can 
export transparent graphics as GIFs, PNGs, or TIFs and preserve transparency effects in both your printed output (see the 
subtopic Transparency-related print options) and your Web pages (see Setting Web picture display options).

In the illustration below, the pentagonal shape has had a Linear transparency applied, with more transparency at the lower end 
of the path and less at the upper end. It makes a difference which object is in front (here, the pentagon); where there's more 
transparency, more of the object(s) behind will show through. 

 

Click the links below for subtopics on:
The concept of transparency
Applying transparency
Editing transparency effects

Changing the set of gallery transparencies

Setting the default transparency

Setting single-level transparency

The concept of transparency
Transparency may seem a bit tricky because by definition, you can't "see" it the way you can see a color fill applied to an object. 
In fact, it's there all the time in PagePlus. Each new object has a transparency property: the default just happens to be None—
that is, no transparency.

Varying the transparency of an object gives the effect of variable erasure, but it leaves the original object intact—you can always 
remove or alter the transparency later. Transparencies work rather like fills that use "disappearing ink" instead of color. A gradient 
transparency varies from more "disappearing" to less, as in the illustration above. Transparency gallery samples show gradations 
from light to dark, with the lighter portions representing more transparency.

In PagePlus, the available transparency effects are all comparable to grayscale fills of the same name, and most transparency 
effects have a path you can edit—in this case, with the Transparency tool.

n Solid transparency distributes the transparency evenly across the object.

n Linear, Radial, and Conical, transparencies provide a simple gradient effect, with a range from clear to opaque. (To review 
the concept, see Working with gradient and Bitmap fills.

n The Bitmap gallery includes texture maps based on 
the Fill tab's selection of bitmaps, plus a special 
category of "Photo Edge Effects" for soft-edge 
masking.

At left, a Photo Edge Transparency (with skewed path) 
on a metafile

 

Applying transparency
There are three ways to apply transparency: using the Transparency tool, the Studio's Attributes tab, or a dialog. The dialog lets 
you add or subtract nodes from the gradient, apply different key colors to individual nodes, or vary the overall shading of the effect 
applied to the object (see "Editing transparency effects" below).

To apply a transparency effect with the Transparency tool:
1 Select an object.

2 Click the  Transparency Tool button on the Tools toolbar.

3 Click and drag on the object to define the transparency path. The object takes a simple Linear transparency, grading from 
opaque to clear.



To apply a transparency effect using the Studio:

1 Click the Studio's Attributes tab and select the Transparency panel. You'll see the Transparency gallery, displaying available 
choices. The lighter portions of the samples represent more transparency.

2 Select the object(s) and click a gallery sample for the transparency you want to apply.
OR
Drag from the gallery sample onto any object (the cursor changes to include a plus sign over suitable objects), and release the 
mouse button. 

To apply or edit a transparency using a dialog:

1 Right-click the object and choose Transparency..., or select it and choose Transparency... from the Format menu.

2 Choose the desired type and (for a gradient effect) the desired transparency category. 
· For a Bitmap fill, simply click a thumbnail.
· For a simple gradient with two nodes—one at each end of its path—click the From button to pick a starting opacity value, 
and click the To button to pick an ending value. 
· Click the Edit button if you want to add or subtract nodes from the gradient (see "Varying a gradient fill" below), or apply 
different values to individual nodes.

3 Click OK to apply the transparency effect to the object.

 

Editing transparency effects
Once you've applied a transparency, you can adjust its path on the object. For gradient fills (but not Bitmap fills), you can adjust the 
level of transparency along the path by altering the opacity values of the nodes. Simple gradient transparency effects have only two 
nodes, one at each end of the path. Multi-level gradient transparency effects include extra nodes along the gradient path. 

To adjust the transparency path:

1 Select the object and click the  Transparency Tool button on the Tools toolbar. The object's transparency path appears.

2 Use the tool to drag individual nodes, or click on the object for a new start node and drag out a new transparency path. The 
effect starts where you place the start node, and ends where you place the end node. For Bitmap transparencies, the path 
determines the center and two edges of the effect.

Editing a transparency path is similar to editing a comparable gradient or Bitmap fill path, as described in Editing the fill path. 

To adjust the level of a Solid transparency: 

1 Right-click on the object and choose Transparency..., or select the object and choose Transparency... from the Format 
menu.

2 Drag the Level slider on the Transparency tab: left toward opaque, right toward clear. You can also type a value directly in the 
"Value" box. 

Adding a level of transparency means varying the transparency gradient by introducing a new node and assigning it a grayscale 
value. For gradient transparencies with multiple nodes, each node has its own level, comparable to a key color in a gradient fill. 
You can alter the levels of gradient transparency nodes (not those of Bitmap transparencies) to vary the transparency effect. 

 

To edit a gradient transparency directly:

1 Select the object and click the  Transparency Tool button. The object's transparency path appears, with nodes visible.

2 Display the Transparency panel of the Studio's Attributes tab.

3 To add a node, drag from any solid transparency sample in the gallery to the point on the path where you want to add the 
node. (The solid transparency samples look just like grayscale colors.)

4 To change the transparency value of any existing node, including the start and end nodes, drag the corresponding solid 
transparency sample from the gallery onto the node. For example, to set a node to 30%, drag from the 30% sample onto the 
node.

5 To move a node you've added, simply drag it to a new position along the transparency path.

6 To delete a node you've added, select it and press Delete.

To edit a gradient transparency using a dialog:

1 (On an object) Right-click the filled object and choose Transparency.... In the dialog, click the Edit button.



OR
(Gallery fill) Right-click the fill sample and choose Transparency....

In either case, an edit dialog appears displaying the gradient, with pointers marking the nodes that define specific opacity 
values, and a gallery with grayscale samples, each representing an opacity value.

2 To add a node, click either on the gradient or just below it, where you want to place the new node. A new pointer appears. 
Note that the new pointer's arrow is black, indicating that it's selected; unselected pointers have white arrows.

3 To change the value of a node, click to select its pointer, then click the greyscale sample for the value you want. 

4 To move a node (except the end nodes), simply drag its pointer to a new position along the gradient.

5 To delete a node (except the end nodes), right-click its pointer.

6 Click OK to accept changes, or Cancel to abandon changes.

 

Changing the set of gallery transparencies
If you've defined a new gradient transparency by setting path and/or level, you can add it to the set of gallery transparencies shown 
on the Transparency panel so that it will be available to use again. You can also delete any of the gallery transparencies.

To add an object's transparency to the gallery: 
n Right-click the object and choose Add Transparency to Studio.

OR
Select the object and choose Add Transparency to Studio from the Format menu.

Note: Bitmap transparencies are a special case. The Bitmap transparency gallery "mirrors" the contents of the Bitmap gallery in 
the Attributes/Fill panel. To add a Bitmap transparency, add the image to the Fill panel gallery and it will appear in the 
Transparency panel as well. (See Changing the set of Bitmap gallery fills.)

To delete a gallery transparency:

n Right-click its sample and choose Delete.

Deleting a gallery transparency doesn't affect any objects that have already been given that effect.

Note: There's no Undo for this action.

 

Setting the default transparency 
The default transparency means the transparency that will be applied to the next new object you create. The default transparency 
is just one attribute among many that are stored as defaults for each particular type of object: text characters, text frames, and 
shapes. It's often easier to set up the defaults before you create new objects, rather than changing the properties later. 

To set local defaults for a particular type of object:
1 Create a single sample object and fine-tune its properties as desired—or use an existing object that already has the right 

properties. (For shapes, you can use any QuickShape; all share the same set of defaults.)

2 Select the object that's the basis for the new defaults and choose Update Object Default from the Format menu.
OR
Right-click the sample object and choose Update Object Default. 

For more on setting defaults, see the topic Updating and saving defaults.

 

Setting single-level transparency
It's also possible to designate any one color of a bitmap or metafile image as a transparent color. This single-level 
transparency technique can be a useful alternative to cropping if there's a solid color surrounding the area of interest. 
Transparency is especially useful if you're preparing a publication for the World Wide Web or some other non-paper format, and 
need to place an odd-shaped logo or graphic over some other element. 

Tip: When exporting low-color Web images with single-level transparency, the GIF format (see About Web picture formats) 
works well.

To set picture transparency:

1 Select the picture, right-click, and choose Picture Transparency....

2 Check the "Use Transparency" box.

3 Click on the image preview to designate the color you want to make transparent. The preview updates to show the result. 



Alternatively, you can enter specific RGB values in the boxes.

4 Click OK. 

 

Note on printing transparent objects
Problems arise with some printer drivers when bitmaps in a publication use transparency. If you experience such difficulties, you 
may be able to overcome them using special settings on the Print dialog's Prepress tab. For details, see the subtopic 
Transparency-related print options.



Printing with color and transparency

PagePlus includes a host of features for preparing and printing high-quality color publications. Here's a quick summary, with 
cross-references to other help topics...

Preparing color publications
Unlimited color mixing. You can create virtually any color using the HSL or RGB color models, and specify custom CMYK 
colors. See Creating your own colors.

Industry standard PANTONE® Colors. Choose from the Process Color System or Spot Color System palettes, with automatic 
conversion of PANTONE Spot colors into process colors if required. See Specifying PANTONE® colors.

Apply colors and shades, gradient and bitmap fills, and transparency to pictures, text, and graphic objects. See 
Applying solid colors, Working with gradient and Bitmap fills, and Other print options.

"Colorize" pictures. This allows you to change full-color images to a single color or shade. You can adjust the intensity of the 
original colors to generate a low-intensity version for use as a background image. See Applying solid colors.

Color Mapper for vector images. The Color Mapper allows all imported vector images, and vector-based OLE objects, to have 
their included colors replaced by existing PagePlus palette colors (or standard PANTONE colors). The Color Mapper can also 
extract any required image color(s) to the PagePlus color palette. See Changing or copying image colors. 

Photo Optimizer for printer calibration. For printing photographs, the Photo Optimizer lets you print test samples and choose 
the best settings, which are then applied when the publication is printed. See Optimizing pictures for printing.

Printing color separations
For details on printing in color, see the topics Basic printing and Printing color separations. For more advanced information, see 
the "Production Issues" chapter in the PagePlus Companion.

Color-separate full-color images. PagePlus imports, displays and process-color separates 24-bit color images in virtually every 
industry standard format, including TIFF, PCX, JPEG, GIF, and Kodak PhotoCD.

Import pre-separated CMYK TIFFs. PagePlus can generate the ultimate in picture separation quality by importing pre-
separated TIFF files from Adobe PhotoShop and equivalent programs. Imported TIFFs retain CMYK color data embedded in the 
file ready for full color separation. An RGB version of CMYK TIFFs is displayed onscreen and the CMYK data is automatically 
used on output when it exists.

Spot-color separate vector files and vector-based OLE objects. PagePlus can produce spot-color separations from any 
vector-based imported image or OLE object. This includes LogoPlus and DrawPlus as well as other Windows applications like 
CorelDRAW! and Microsoft Excel.

Standard and customizable screen angles and frequencies.

Support for the Adobe OPI specification.

Create custom registration marks using objects and the [Register] color.

Suppress picture output option to facilitate traditional picture stripping.

Automatic color trapping on output for both text and graphic elements.



Getting started in Web mode

This topic and those that follow provide you with the details you'll need to know to create a successful site on the World Wide 
Web using PagePlus.

n For background information (especially tailored for desktop publishing designers transitioning to the Web), see the "Designing 
for the World Wide Web" section in the PagePlus Companion. 

How easy is it to create your own Web site with PagePlus? It can be as simple as answering a few questions in a Web Page 
Wizard. And no matter how much customizing you choose to do after that, the whole job won't be nearly as complicated as 
developing your own newsletter. So, if you're already comfortable using PagePlus for paper publications, you'll find it easy going. 
If you're just beginning, you'll learn to use PagePlus tools as you go. 

What is a Web site?
The Internet is a global network that interconnects computers around the world. The World Wide Web began as a way of using 
the Internet to access information stored in a file format known as HTML, or Hypertext Markup Language. Broadly defined, a 
Web site is a collection of (mostly) HTML files stored on a file server that someone with a Web browser can get to. Actually, 
Web sites don't depend on the Internet at all—they can be (and often are) accessed just as well over a local area network or 
private intranet. Remember, a Web site is just a collection of files.

The HTML format is a way of describing the layout of a page. An HTML file uses plain text with various embedded codes to 
describe a page that somebody has designed, consisting of text and clickable hypertext links. Besides HTML files, a Web site 
generally includes other files (pictures, for example) that the designer has seen fit to incorporate. A Web browser (such as 
Netscape Navigator or Microsoft Explorer) is a program that can read an HTML file and display the page (one hopes) the way the 
designer intended it to look. 

Typically, a Web site has a single Home Page using a standard file name like INDEX.HTML. The Home Page is the first page a 
visitor sees. It usually will contain links to other pages on the site, which in turn have links to others. To the person using a Web 
browser to access the site, the information appears seamlessly linked—navigable with a click of the mouse.

PagePlus takes the pages you've laid out and converts them to HTML. In fact, the Web Page Wizards simplify things further 
by providing you with a variety of starter layouts, professionally designed expressly for World Wide Web display. Whether you're 
looking for a business, community, or personal Web site, you're bound to find the Web Page Wizards a convenient point of 
departure. 

What will I need to publish my Web site?
Publishing a site with PagePlus is a one-step operation that both: (1) converts your publication to files for the Web, and (2) 
copies the Web files to a location you specify, either to a local folder or to a World Wide Web host. 

To publish to a local folder, you don't even need a connection to the Internet. Of course, you'll need a Web browser to preview 
your site.

To publish to the World Wide Web, you'll need a host for your Web site—that is, disk space on a server connected to the 
Internet—so that others can access your site. This usually means opening an account with an online service provider: either a 
large network such as America Online or a specialized Internet service provider (ISP). The big subscription networks typically 
allocate to each user 1-2 megabytes of server space for a "personal web site," and many plans are available from smaller ISPs. 
Once you've set up your account and can connect your computer to the host, publishing to the Web is simply a matter of 
transferring your files. The Web Publishing utility included with PagePlus takes care of this.

Starting a new Web publication
Paper Publishing mode is the familiar PagePlus environment for creating print publications. Web Publishing mode includes 
special features, such as menu items and custom settings, to facilitate creation of World Wide Web pages.

Anyone using Web Publishing mode for the first time should begin by creating a simple Web site using a Page Wizard. You'll find 
lots of Web Page Wizards on the PagePlus 8 PDF Edition Resource CD. (For more details about the Resource CD, contact 
Serif.)

To create a new Web publication using a Page Wizard:

1 Launch PagePlus or choose New... from the File menu. You'll see the Startup Wizard.

2 Select the Use a Page Wizard option, select a publication category on the left, and examine the samples on the right. Click 
the sample that's closest to what you want, then click Finish.

The publication opens in Wizard Preview mode, with only the Studio's Wizard tab displayed on the right. The upper group of the 
Wizard lists the categories of information that you can customize. Further down are boxes where you can review and/or re-enter 
the sample "answer text" in the category.

3 Type into the fields to replace the sample text. As you enter information, you'll see the publication update to reflect your 
choices.

You can change as much or as little as you like at this point—it's always possible to revisit the choices later. For details on 
altering answer text, see the topic Customizing Page Wizard text. For more information on color schemes, see the topic Using 
color schemes.



4 When you're done with each category, click another until you're done. Then click the Finish button. 

Just as in Paper Publishing mode, you also have the option of starting a new publication from scratch, or opening an existing 
publication (see the topics on: Starting a new publication and Opening an existing publication).

If you'd like to build on previous work you've done with PagePlus, you can also take an existing paper publication and convert it 
to a Web publication.

To turn an existing PagePlus (paper) publication into a World Wide Web site: 

n Open the publication in Paper Publishing mode and choose Switch to Web Publishing from the File menu. 

What's involved in creating a Web site?
Even if you've used the Web Page Wizard to "create" your site, there are lots of creative choices to be made. While the Wizard 
simplifies your design tasks considerably, chances are you'll want to put your personal stamp on the site before publishing it. As 
you proceed through the following help topics, you'll learn about... 

1 The basics of using text on Web pages: Using Web text styles to make the most of HTML's constraints.

2 The basics of hypertext linking: Connecting your readers to other Web pages or Web sites through hyperlinks or hotspots.

3 Visual design options: For example, background color or picture variations and optional animation effects.

4 Fine-tuning your pages for both aesthetics and performance: Setting picture formats, adding search engine descriptors, 
setting service provider options, and so on. 

5 Using the Layout Checker to help optimize your pages for efficient display.

6 Publishing your site.



Web page layout fundamentals

One advantage PagePlus has over a dedicated Web-page creation program is that you can take your newsletter layout, or a 
print ad with a wild mix of multicolor graphics and fancy typography, and publish them intact to the World Wide Web. In fact, your 
page can look as great on the Web as it did on your screen! 

While you don't have to know HTML (the description language for Web pages) to use PagePlus, you should understand that: 

1 The time it takes a visitor to load your page is directly related to the size of the HTML file plus any accompanying image files. 
The images take up considerably more space—and slow down loading time.

2 Those parts of your layout that PagePlus cannot translate to HTML will be output as images. The more of your layout that 
PagePlus can translate into HTML, the better. 

About HTML 4.0
If you're used to working in a Desktop Publishing environment, you may have to scale back your typographic expectations 
somewhat when designing for the Web. With its built-in support for HTML 4.0, however, PagePlus gives you a lot of design 
latitude.

HTML 4.0 produces high-quality Web pages that can be viewed on Internet Explorer 3 and above, or Netscape Navigator 4 and 
above. In laying out text, you can specify any point size, use variable leading and letterspacing, and even justify paragraphs! The 
result, compared with the table-based layouts used with earlier versions of HTML, is a much closer WYSIWYG match between 
what you see on-screen in WebPlus and what ends up in the Web browser. Because HTML 4.0 positions elements using 
absolute coordinates, PagePlus can output your pages without using tables. Overlapping is no longer as serious an issue in 
page design, and file sizes are reduced.

In theory, you can use any font you like. However, if a specified font isn't present on a visitor's computer, an available font will be 
substituted, with unpredictable results for your beautifully designed layout! As a rule, stick with the standard Windows fonts 
(Times New Roman, Arial, Courier New, and Symbol). 

Note: A number of the more esoteric typographic effects that work on the printed page are still unsupported in HTML 4.0. To help 
you trap these problems, the PagePlus Layout Checker Wizard will warn you if your publication uses nonstandard fonts or 
character properties, text that must be output as a graphic, or other problems. For a complete list of these trouble spots, see the 
topic Automatic layout checking.

 

About Web graphics
Bear in mind that not all your visitors' computers will match your own for speed or graphic display. A few monitors are still limited 
to 256 colors, as is the GIF image format which is a standard for Web graphics. If there are problem objects, always test the 
page in a browser and/or switch to 256-color mode before finally publishing it. 

The file size of an image is directly proportional to its linear dimensions. As a rule, keep picture dimensions to the minimum 
needed to convey your point. Plan your layouts so as to avoid large graphic areas.

Use photographic images sparingly. These tend to be larger and require more colors to display satisfactorily.



Hyperlinking an object

Hyperlinking an object such as a box, a word, or a picture means that a visitor to your Web site can click on the object to trigger 
an event. The event might be a jump to a Web page (either on your site or somewhere else on the Web), the appearance of an 
e-mail composition window, or the display of a graphic, text, audio, or video file. Hyperlinking enables visitors to navigate through 
your Web site or PDF document. In Web Publishing mode, you can also place hyperlink hotspots over parts of the page (see 
the next topic), and add hyperlinks to graphic objects that employ rollover states (see Adding rollovers).

To hyperlink an object:

1 Use the Pointer tool to highlight the region of text.

2 Choose Hyperlink... from the Insert menu. The Hyperlinks dialog appears.

3 Click to select the link destination type, and enter the specific hyperlink target (see Selecting a hyperlink target below).

4 Click OK.

Note: To apply a hyperlink to a group object (such as a button or other Web object from the PagePlus Gallery), first ungroup the 
object, then apply the hyperlink to the uppermost object and regroup all the objects.

As a visual cue, hyperlinked words are underlined and appear in the color you've specified for Hyperlinks in the Web Site 
Properties dialog (see Choosing Web site colors).

To modify or remove a hyperlink:

1 Use the Pointer tool to select the object, or click for an insertion point inside the linked text. (It's not necessary to drag over a 
hyperlinked region of text.)

2 Choose Hyperlink... from the Insert menu. The Hyperlinks dialog appears with the current link target shown. If the link is in 
text, the whole text link highlights.

n To modify the hyperlink, select a new link destination type and/or target.

n To remove the hyperlink, click the Remove button.

Note: Removing a hyperlink does not remove the underlying object or text.

Suppose you want to edit hyperlinked text—for example, take away some of the "hot" text or extend the hyperlinked region—
while retaining the link itself. Simply use the Pointer tool and type (or delete characters) within the linked text. Any contiguous 
characters will share the same link. Likewise, you can cut/copy/paste linked text and objects without affecting their link 
properties.

For an overview of all the hyperlinks in your publication, use the Hyperlink Manager. See Viewing the links in your publication.

Selecting a hyperlink target
To link to a World Wide Web page:

1 As the link destination type, select An Internet Page.

2 Specify the correct Uniform Resource Locator (URL) for the target Web page. The list shows URLs previously used in your 
publication. Choose one of the listed URLs, or enter a different one.

Clicking this type of link will display the target page in the visitor's browser.

To link to a page on your own Web site:

1 As the link destination type, select A Page in your Publication.

2 Select the target page number.

Clicking this type of link will display the target page in the visitor's browser.

To link to an e-mail address:

1 As the link destination type, select An Internet e-mail address.

2 Enter the full e-mail address (usually your own).

Clicking this type of link will display an e-mail composition window so a reader can send e-mail to the specified address. 
Typically, this option lets visitors to your site send you feedback. 

To link to a file (for example, a sound or video file):

1 As the link destination type, select A file on your hard disk.

2 Enter the full hard disk path name of the file to display (click the Browse... button if necessary). Make sure it's a file that a 
Web browser can display, such as an HTML, TXT, or GIF file.

Clicking this type of link will display the specified file in the visitor's browser. When PagePlus publishes your site, the specified file 
will be copied along with your Web pages. This is a convenient way to attach supplementary content. For example, you could 



include small, thumbnail pictures on your Web page, each linked to a full-size image file. The page would load more quickly, and 
visitors could select which images to view at full resolution. 

For details on other ways of linking to sound or video files, see the topic Adding sound and video.



Adding hotspots (Web Publishing mode only)

A hotspot is a transparent hyperlink region on a Web page. Usually placed on top of images, hotspots act like "buttons" that 
respond when clicked in a Web browser. They are especially useful if you want the visitor to be able to click on different parts of 
a picture (such as a graphic "menu" or map of your site).

To define a hotspot:

1 Click the  Hotspot button on the Tools toolbar.

2 Click and drag to draw a rectangular hotspot region. The Hyperlinks dialog appears. 

3 Click to select the link destination type, and enter the specific hyperlink target (see the previous subtopic Selecting a hyperlink 
target).

4 Click OK.

To modify a hotspot hyperlink:

n Using the Pointer tool, double-click the hotspot. 

OR 
n Click to select the hotspot and choose Hyperlink... from the Insert menu. 

The Hyperlinks dialog appears with the current hotspot link target shown.

n To modify the hyperlink, select a new link destination type and/or target.

n To remove the hyperlink, click the Remove button.

Editing hotspots
You can move and resize hotspots on the page, just like other objects. A selected hotspot has both an outer bounding box and 
an inner outline, which serve different purposes.

 
To move or resize a hotspot:
n Click to select the hotspot.

n To move, click and drag from the center, or from the hotspot's bounding box. To constrain the hotspot to vertical or horizontal 
movement, hold down the Shift key while dragging.

n To resize, click and drag on its outer (bounding box) handles. 

By editing the inner outline, you can convert rectangular hotspots into freeform shapes that closely match the parts of the 
underlying graphic you want to be "hot." To edit the outline, first move the mouse pointer over the hotspot's inner outline until the 
cursor changes to indicate whether you're over a node or a line. 

 
To create an extra node on a hotspot:

n Click anywhere along the hotspot's outline when you see the  cursor. 

To change the shape of a hotspot's outline:

n Click and drag a node when you see the  cursor.



Adding rollovers (Web Publishing mode only)

The term rollover refers to an interaction between a mouse and a screen object. For example, you've can point your mouse at a 
graphic (such as a navigation bar button) on a Web page, and see it instantly change color or become a different picture. When 
you point to a Web page object, your mouse pointer physically enters the screen region occupied by the object. This triggers an 
event called a "mouseover" and, if the underlying code is there to "trap" this event, it can trigger some other event—such as 
swapping another image into the same location. An object whose appearance changes through image-swapping in response to 
mouse events is called a rollover graphic. 

 
PagePlus lets you add rollover graphics to your Web publications; the necessary event-trapping code is generated for you 
automatically. You can also directly import rollover graphics created in Serif DrawPlus (see below). 

Rollover options
Adding rollovers is basically a matter of deciding which rollover state(s) you'll want to define for a particular object, then specifying 
an image for each state. DrawPlus provides four basic choices:
n Normal is the "resting" state of the graphic before any rollover, and is always defined.

n Over is the state triggered by a mouseover— when the mouse pointer is directly over the object. For example, a button's text 
might change color, or an outline appear, to show the button is "alive." Prior to a mouse click (see Down), moving the pointer 
in and out of the graphic's area will alternate between Over and Normal.

n Down is triggered by a mouse click on the graphic. The term derives from a typical button's behavior: its "up" state changes to 
"down" once it's been clicked. On a Web page, this click will normally activate the graphic's hyperlink and take the user to a 
different page.

n Down+Over implies a mouseover that occurs when the graphic is already Down, i.e. after it's been clicked. If you don't 
activate this rollover state, then the Over image appears by default when a mouseover occurs, even after a click. If you do 
activate this state, then the Down+Over image you provide (typically the same as the Down image) appears on a mouseover. 
Down+Over is useful as a precaution to ensure that the button stays in its "clicked" state and doesn't switch back to "Over" if 
the user happens to mouse over it again before leaving the page. 

You'll also have the option of specifying a hyperlink event—for example, a jump to a targeted Web page—that will trigger if the 
user clicks on the object. And you can even group buttons on a page so they work together and only one at a time can be down.

To create a rollover graphic:

1 In a suitable image-editing program, create the variant source images for each state you'll be defining. (See "Creating variant 
graphics" below.) 

2 Choose Web Object from the Insert menu and select Rollover... from the submenu.

3 Specify which rollover states (see above) you want to activate for each graphic by checking boxes in the Rollover dialog. For 
each one, use the Browse button to locate the corresponding source image.

4 Check Embed files in publication if you want to incorporate the image(s) in the PagePlus file. (For details, see Embedding 
vs. linking.) 

5 Check either Normal or Down as the button's initial rollover state. 
For example, common sense dictates that on a site's actual Home page you should initially show the "Home" button itself as 
down, and/or unresponsive to mouse actions—after all, the viewer is already on that page—whereas buttons that link to other 
pages should be in their normal "up" state and responsive.

6 Click Set... to define a hyperlink target for the button. (For details, see Hyperlinking an object.)

7 Check Radio button if you want to link all the buttons (on a given page) that have this option checked, so that only one of 
them at a time can be down. 
If you use this technique, make sure all rollover graphics you want to link have the option checked. Although it doesn't matter 
how the buttons are distributed on the page, typically they'll constitute a visible unit like a navigation bar. Any buttons with the 
option unchecked are independent.

8 Click OK. The first time you define a rollover state, you'll see rollover layers established in the document (see below).

PagePlus displays the image assigned to the Normal state. It's a good idea to preview the page in a Web browser and test each 
rollover object, then return to PagePlus and revise as needed. When you preview or publish the Web site, PagePlus takes care 
of exporting one image file for each rollover state, and the HTML file for the published page incorporates the JavaScript code for 
the rollover event trapping.

To revise a rollover graphic:

1 Right-click the graphic and choose Edit Rollover....

2 Make new selections as needed and click OK.



Creating variant source images
For each object with at least one activated rollover state, you'll need to provide a source image. It's the often subtle differences 
between the Normal image and the "variants" that make the object appear to switch from one state to another. For example, if 
you've checked the "Over" state for an object, you need to include a variant image that the Web page can display when the 
button is moused over. If you want the button's text to change from black to yellow, then the "Over" state will need an image with 
yellow text. 

 
You'll need to create these source images in a separate image-editing program. Here are some things to consider:
n Variant images will stretch to fit into the region occupied by the Normal image, so all the source images should have the same 

dimensions.

n Make sure the variants are all in precise registration with the Normal image, so there's no unintended movement when images 
are swapped on rollover. To simplify matters, use an image editor with layering capability and create each variant on a 
separate layer directly above the Normal image.

n PagePlus displays only the Normal image, so preview the effect of swapping graphics by hiding and showing layers in the 
image editor.

n You only need to provide variant source images for the rollover states you've activated.

n Once you're satisfied with the source images, export each layer to a separate file, and then return to PagePlus to define the 
rollovers.

n When assigning the source images, you'll need to choose between linking and embedding. As long as a source image is 
linked (not embedded), PagePlus will always use the latest version of a file. So as a rule, until you're truly sure your source 
images are final, you may wish to uncheck the Embed files box so that linked images will be used. You can easily repeat the 
assignment process, using embedding instead, once the source images are final. If you do find yourself needing to update an 
image that's already been embedded, the best way is to save the revised file under a different name, then repeat the 
assignment process and specify the new file instead of the old.

Importing DrawPlus rollovers
Serif DrawPlus provides not only advanced image editing and layering capabilities, but built-in tools for producing rollover 
graphics. For example, you can preview just a region of your screen in a Web browser, and set export options. DrawPlus outputs 
of a series of image files (for example, MYFILE_01.GIF, MYFILE_02.GIF, etc.) with variants for each rollover state, and a single 
HTML file (for example, MYFILE.HTML) that includes the JavaScript code.

To import a DrawPlus rollover graphic:

1 Choose Web Object from the Insert menu and select DrawPlus Rollover... from the submenu.

2 Locate the HTML file for the rollover graphic. Keep Embed graphic files checked to incorporate the images into the 
publication, or uncheck to link them.

3 Click OK.

PagePlus automatically inserts a placeholder for the object.



Choosing Web site colors (Web Publishing mode only)

Like all PagePlus publications, each Web publication has a color scheme, selected either while making Page Wizard choices, or 
subsequently using the Studio's Schemes tab. (For details, see the topic Using color schemes.) The selection of schemes 
includes ten specifically designed for Web use (named "WWW 1" through "WWW 10").

Web publications have several special Web color settings, usually defined as part of their color scheme. You'll need to know 
about these, even if you haven't applied scheme colors to other elements in your publication: 

n The Hyperlink color applies to hyperlinked text before it's been clicked on, while the same text after a visitor has clicked to 
"follow" the link takes on the Followed Hyperlink color. 

n A Web site's Background (blue in the sample below) can be either a solid color or a tiled (repeated) picture, usually a bitmap 
pattern. The tiled picture option works just like desktop "wallpaper"—so a small bitmap can go a long way. The color scheme 

sample shows     if the scheme uses a tiled bitmap.

n The Web Text color is applied to body text in Web publications. PagePlus 8.0 Page Wizard publications are designed so that 
the Web Text color takes Scheme Color 1. For example, if Scheme Color 1 is black, body text will appear black.

In Web Publishing mode, color scheme samples 
show the Web colors along with the five basic 
scheme colors, as shown at left. The easiest way 
to apply new Web colors is to select a different 
color scheme by clicking a sample on the Studio's 
Schemes tab. 

You can also change any of the Web colors within a scheme using the Scheme Manager, in the same way that you'd modify the 
scheme's five basic colors.

To modify a scheme's Web colors:

1 Right-click the color scheme sample (in the Schemes or Wizard tab gallery) and choose Scheme Manager..., or choose 
Scheme Manager... from the Tools menu. The Scheme Manager appears, with the current scheme (if any) highlighted on the 
Schemes tab. A preview window shows the hypertext and background colors associated with the scheme. (As noted, body text 
will match Scheme Color 1.)

2 To modify the selected scheme, select the Custom tab.

Each of the five scheme color numbers (plus the Hyperlink, Followed Hyperlink, and Page Background settings) has its own 
drop-down list, showing available colors in the PagePlus palette. 

3 To set or change the color assigned to a particular number, simply select a color from the corresponding list.

4 To use a picture as a background, check the Picture background box and use the Browse... button to locate an image to be 
tiled on the page background.

5 When you're done, click OK.

Note: The Scheme Manager's Web Colors tab is used for converting a PagePlus 5.0 publication (see below). Unless you need 
to do this, you won't need to use this tab. 

Web colors in PagePlus 5.0 publications

Web publications created with PagePlus 5.0 did not use color schemes as defined in PagePlus 8.0. They did, however, include 
definitions for the various Web colors (body text, hyperlinks, and background). 

Body text: PagePlus 5.0 used a variable color called the  [Web] color to mark body text. Since there's no [Web] color in 
PagePlus 8.0, body text in a converted 5.0 publication remains whatever color it was. As noted above, PagePlus 8.0 color 
schemes assume that Scheme Color 1 will apply to Web body text. So if you'd like to apply one of these schemes to your 5.0 
publication's body text, here's a suggested workaround.

To apply Scheme Color 1 to Web body text:

1 Select a sample of body text that uses a PagePlus 5.0 style (for example, "Web Body 1").

2 Click the Studio's Attributes tab and select the Color panel, then click the Scheme Color 1 sample to apply it to the text.

3 On the Text toolbar, select the current style name (again in the example, "Web Body 1") from the list and re-apply it to the text. 
Choose the option to "update the style to reflect recent changes."

This will force all text in the publication using that named style to use Scheme Color 1. If the publication uses body text of 
different sizes (e.g. "Web Body 2"), you'll need to repeat this step for each such style.

Hyperlink and background text: For hyperlink text and background colors, the conversion process is slightly different. You can 
apply scheme colors to the hyperlink text and background, provided you first tell PagePlus to "attach" a color scheme to these 
elements. 

If you open a version 5.0 Web publication and display the Scheme Manager's Web Colors tab, you'll see a checked box 
indicating that the Web colors are detached from the publication's color scheme—that is, they are defined independently.



    (In more recent Web publications, this box will not be checked as the Web colors are 
part of the color scheme.)
Before selecting one of the PagePlus 8.0 color schemes for a version 5.0 publication, you should first "attach" the Web colors, then 
choose a color scheme as you would with any new publication. (You can choose the scheme first, but won't see an immediate effect 
on the publication as long as Web colors are still "detached" from the scheme.)

To apply (attach) a scheme's Web colors to a PagePlus 5.0 publication:

1 Display the Scheme Manager and select the Web Colors tab.

2 Uncheck the "Detach Web colors from color scheme" box.

As soon as you uncheck the box, the lists become grayed out because you can no longer define them independently. Should you 
change your mind at this point, click Cancel to restore the detached colors.

3 To accept using the scheme's colors, click OK. The publication updates with the new values and at this point you can no 
longer retrieve the old ones. (For this reason, if you've any doubt, it's wise to jot down the old settings before replacing them.) 

 



Choosing Web page titles (Web Publishing mode only)

The Web page title, which will appear in the title bar of the visitor's Web browser, can serve to unify the pages and focus the 
site's identity, as well as aid navigation. Once you've chosen a page name, copies of that page will have the same name. An 
easy way to have every page of your site display the same title (in effect, a site title) would be to start with a blank page, give it a 
name, then replicate that page.

You can use the same dialog to change the file name and/or extension to be used when the page is published.

Note: Leaving the page title undefined won't affect the performance of your site in any way.

To enter a title for a Web page:

1 Choose Web Site Properties... from the File menu. 

2 Click the Page tab, type the title of your choice, and click OK.

 



Viewing the links in your publication (Web Publishing mode only)

The Hyperlink Manager gives you an overview of all the hyperlinks in your publication. (To review hyperlink basics, see 
Hyperlinking an object.)

To display the Hyperlink Manager:

n Choose Hyperlink Manager... from the Tools menu.

The Hyperlink Manager dialog displays both object and text hyperlinks in your publication, listed by page number. The entries are 
in "from/to" format, showing each link's source object type and its destination page or URL. 

To display a hyperlink for closer inspection:

n Click to select the link entry and click the Display button. 

OR 
n Double-click the link entry.

PagePlus "zeroes in" on the selected hyperlink.

To remove a hyperlink: 

n Click to select the link entry and click the Remove button. 

Note: Removing a hyperlink does not remove the underlying object.

To modify a hyperlink: 

n Click to select the link entry and click the Modify button. The Hyperlinks dialog appears. 

n To modify the hyperlink, select a new link destination type and/or target.



Setting Web picture display options (Web Publishing mode only)

See Also: For details on other key aspects of working with images in PagePlus, see these topics: Importing images, Converting 
an object to a picture, and Exporting as a picture.

When you export a publication as a Web site, PagePlus applies certain global settings to determine how each image—whether 
drawn, pasted in, or imported—ends up as a separate bitmap displayed on the Web page. (See "About Web picture formats" 
below for details on the various formats.)

Note: The picture conversion settings that apply to exporting graphics for Web publicatons are separate from those that govern 
the Convert to Picture or Export as Picture functions. Any references in this topic to "exporting" graphics apply only to the Web 
publishing process. 

Here's a quick summary of the conversion settings as they're initially defined for Web publishing:

n Each image in the publication is exported as a separate file.

n Any image you inserted as a GIF or JPEG is exported as the original file, using its original file name.

n Inserted PNG images, metafiles, and all other graphics are converted to JPEG images, using a compression quality setting of 
10 (low compression, high detail). For these images, PagePlus automatically generates file names, using incremental 
numbering (IMG1, IMG2, etc.) that continues each time you export.

You can alter these settings, but before doing so you should review the "logic" PagePlus applies to publishing Web graphics. 
First, PagePlus has one default format to which all graphics will be converted on export—but you can make exceptions to this 
rule by specifying that certain image types should remain as their original file. Initially, JPEG is the default format, but with 
overrides set for GIFs and JPEGs. That's why, using the initial settings above, GIFs and JPEGs stay as they are while all other 
graphics get converted to JPEGs. You can check and change these settings in the Web Site Properties dialog. The settings 
there are global and apply to all graphics in the publication—but again you can make exceptions, in this case for individual 
graphics. To do so, you could either use the Web Picture Properties Wizard to set the export format of particular images on a 
case-by-case basis—or convert certain images to a specific format beforehand using the Tools/Convert to Picture command. 

This combination of global and local settings gives you almost total control (if you care to exercise it) over how your graphics 
make it onto your Web pages! Let's look first at how the global settings work.

To set global export options for Web graphics:

1 Choose Web Site Properties... from the File menu and select the Graphics tab. Then set options as follows:

2 Select a default export format under "Publish graphics by default as" and set any applicable options. This is the format to 
which all graphics will be converted on export unless you set overrides (see the next step). Note: Format options you set here 
are distinct from the export filter settings used by the Convert to Picture or Export as Picture functions.

3 To override conversion for images of certain formats (inserted JPEGs, GIFs, and/or PNGs), check which format(s) to preserve 
under "Override default (use original file) for all". Checking a format means that any image using that format will stay in its 
original file format—exempt from conversion to the default format. 
You can set a couple of additional options for original-format images:
· Uncheck Use original file names if you want PagePlus to generate a new file name with incremental numbering, as 
opposed to using the original name. 
· Check Remove spaces from file names to revise graphic file names accordingly—useful if you find your Web server can't 
handle the spaces.
Note: You can also use the Web Picture Properties Wizard (see below) to set a local override, forcing PagePlus to export a 
particular image to a particular format.

4 Check Optimize overlapping graphics to have PagePlus analyze the publication and (where a smaller file would result) 
output overlapping graphics as a single graphic. Whether this option makes sense will depend on your particular layout. 
Rather than use this global approach, you might consider using Tools/Convert to Picture in specific cases.

5 Check Restart file numbering with each 'publish' if you want file names that PagePlus generates for converted graphics to 
begin again from "001" rather than incrementing indefinitely each time you publish the Web site. This is useful if you intend to 
overwrite a set of previously published files.

Setting export formats and alternate text for individual graphics
The Web Picture Properties Wizard lets you set the export file format for individual graphics in the publication, or for objects 
such as rotated text that will be converted to pictures on export. These local, picture-by-picture settings override the global 
settings (as set in File/Web Site Properties, see above) which PagePlus uses to determine the export format. You can run the 
Wizard to check a single, selected picture; one or more specified pages; or the entire site. For each image, you can choose a 
specific format (.JPG, .GIF, or .PNG) or defer to the global settings. 

Let your own eye be the judge. Your best bet is to retain the Use global settings option for all pictures to start with. Using the 
original global settings, this means that GIFs and JPEGs will be exported as their original files, while any others, including 
QuickShapes and closed shapes, will be published as JPEGs. Then preview your site and determine if you want to vary the 
global settings or try a different output format for specific pictures. See "About Web picture formats" below for format details and 
tips. 

Even if you don't change any format settings, the Wizard provides a way of entering alternate text for Web site visitors to read 



while an image is downloading. Each "tag line" you provide will appear inside the image frame during the time the image is being 
loaded into the visitor's Web browser. Depending on the speed of the connection, this could be either a short interval or a "World 
Wide Wait"! It's good practice to enter a concise, descriptive phrase describing each picture.

To run the Web Picture Properties Wizard:

1 If you're checking just a single picture, select it first.

2 Choose Web Picture Manager... from the Tools menu.

3 Select which object or page(s) you want the Wizard to check, then click Finish.

The Wizard cycles through graphics in the specified range, and displays each one in turn along with a Web Picture Properties 
dialog.

4 To specify the export format for a graphic, select the format. Otherwise, leave Use global settings selected.

5 To enter alternate text for a graphic, type it in.

About Web picture formats
The .GIF (Graphics Interchange Format) file format is universally supported in Web browsers for both static and animated Web 
graphics. It's a lossless format (there's no image degradation) with excellent compression but a limitation of 256 colors (the GIF 
export filter applies an optimized 256-color palette). Use it for low-color, non-photographic images with sharp edges and 
geometrics—for example buttons, bursts, decorative elements, and text or chart graphics. It's fine for grayscale photos as well. 
The format also supports single-level transparency.That is, any portion of the image may be either fully opaque or fully 
transparent. For example, you could use this to eliminate a box-shaped frame or border around a graphic. Elements with 
rounded edges, such as characters or shapes, preserve their contours over any background color or pattern. 

The .JPG or JPEG (Joint Photographic Experts Group) file format, like .GIF, is universally supported in Web browsers. 
Unlike .GIF, it encodes 24-bit images but is a lossy format depending on the selected compression setting. .JPG is clearly the 
format of choice for full-color photographic images. For "black and white" (256-level, 8-bit grayscale) photos, it has no particular 
advantages over .GIF. Using the default export settings in PagePlus, graphics other than original GIFs will export as JPEGs, 
using a default 10% compression setting. This means high detail with relatively low compression, so you may be able to use a 
higher setting on a per-image basis. 

The .PNG format is relatively new, yet it offers distinct advantages, such as "lossless" 24-bit images and support for variable 
transparency. Whereas .GIF supports only single-level (on-off) transparency, .PNG allows up to 254 levels of partial transparency 
for normal images. The image file includes an "alpha channel" that directs pixels in the foreground image to merge with those in 
a background image. Most commonly used with 24-bit images, anti-aliasing creates the illusion of smooth curves by varying pixel 
colors-—for rounded images that look good against any background, not just against a white background. It's especially useful 
for the small graphics commonly used on Web pages, such as bullets and fancy text. Unfortunately, not all browsers fully support 
transparent regions in PNGs—for example, Internet Explorer 5 renders them as grey.

n For additional background information and tips, see the PagePlus Companion chapter, "Designing for the World Wide Web." 



Adding animation effects (Web Publishing mode only)

PagePlus lets you add two varieties of eye-catching animation effects to any Web page: animated marquees and GIF 
animations. Either way, you can preview the animation and/or customize the effect. Once placed into your Web publication, the 
animations appear static, but they will spring to life once the site has been exported and a visitor views your page in a Web 
browser. 

Note: Bear in mind that animations do add to the "overhead" or load time your page requires, and may not display as quickly on 
the Web as when previewed in a Wizard or dialog.

Animated marquees
The Animated Marquee Wizard prompts you through the steps of adding horizontally scrolling motion to a headline or catch 
phrase. You can choose the background color, enter from one to three lines of text, and define text properties, scroll direction, 
speed and alignment for each line. If you like, you can define a URL hyperlink for the marquee. For the most compelling effect, 
select two lines with strongly contrasting text colors and opposing scroll directions.

To run the Animated Marquee Wizard:

n Choose Web Object from the Insert menu and select Animated Marquee... from the submenu. 

Animated marquees appear as static images on the publication page. You can cut, copy, move, and resize them just like other 
graphics. They will animate when viewed in a Web browser.

To edit an animated marquee you've already defined:

1 Double-click the marquee. The Wizard restarts, with the current settings in place.

2 Step through the Wizard and change the settings as desired.

GIF animations
Inserting an animated GIF is just like inserting a static picture. PagePlus lets you preview, then pick and choose from hundreds 
of supplied animations—small pictures grouped into categories. Use them to illustrate particular themes or just add some fun to 
your page!

To preview and insert an animated GIF:

n Choose Web Object from the Insert menu and select Animated GIF... from the submenu. 

n Use the dialog to preview available GIF files and select the image file to open. To keep the image separate from the PagePlus 
file (using a link to the source file) uncheck Embed Picture. Click Open.

Note: If you chose the default install option, you'll need to have the PagePlus CD-ROM in your CD drive to access the 
animations.

GIF animations appear as static images on the publication page. You can cut, copy, move, and resize them just like other 
graphics. They will animate when viewed in a Web browser.



Adding sound and video (Web Publishing mode only)

PagePlus lets you augment your Web pages with sound and video files in a variety of standard formats, including both non-
streaming and streaming media. (Non-streaming files must download in entirety to a user's computer before they begin playing; 
streaming files require a special player that buffers incoming data and can start playing before the whole clip has arrived.)

There are actually two sound playback options—background sound, where a sound loads and plays automatically when a 
specific page is first displayed in the visitor's Web browser, and linked sound, triggered by a mouse click (for example on an 
icon or hyperlinked object). The supported audio formats are .WAV, .AIFF, .AU, MIDI (.mid, .midi), and RealAudio (.ra, .ram).

Linked video works like linked sound. Supported video formats are .AVI, QuickTime (.mov, .qt), MPEG 
(.mpg, .mpeg, .mpe, .mpv), and RealVideo (.ram, .rv).

With both background and linked sound (or video), you have the option of embedding the source file in your publication, as 
opposed to keeping it separate. Although embedding any file adds to the size of the publication, it is the default option because 
you'll no longer have to worry about juggling separate files or the chance of accidentally deleting one of them. When you publish 
your site, PagePlus takes care of exporting and copying both embedded and non-embedded files.

You won't be able to play back or edit sound or video files in PagePlus; you'll need to use an external media editor. Both types of 
files tend to take up a lot of space, more or less depending on the method of compression you've used. The large file size 
translates to long download times for non-streaming files. Media files also tend to be platform-specific: for example, there are 
different Windows, Mac, and Unix sound file formats. For these reasons, except for very short audio clips, one rarely encounters 
non-streaming media on the Web. However, if a fast connection is guaranteed, you can get away with using longer/larger non-
streaming files. A technically complex alternative is to use streaming media such as RealAudio and RealVideo.

To add background sound to a page:

1 Choose Web Site Properties... from the File menu and select the Page tab.

2 Browse to the sound file you want to add, or enter its path name directly.

3 If you do not wish to embed the file in your publication, uncheck the "Embed" option.
Note: If you choose not to embed your source files, we suggest you keep them together in a subfolder named "Media" or the 
like. When you publish your site, PagePlus exports and copies both embedded and non-embedded files into a common folder.

4 To have the sound play back as a continuous loop, check "Loop sound". Otherwise, it will play just once.

The sound file will download and play back when the Web page displays in a browser.

With both linked sound and linked video, the basic question is how you want the visitor to be able to trigger the playback of a 
given media file. PagePlus offers the same basic options for both kinds of media:

1.    From a hyperlinked object or hotspot: You start with an existing object in the publication, and hyperlink it to the media file, 
or use a hotspot over an image.

2.    From an icon: PagePlus provides an icon pre-linked to the media file. You then position the icon on your page.

3.    From a picture: You select an external picture file, which PagePlus then imports and links to the media file. 

4.    Inline: A media "player" will be visible on your published Web page (rather than appearing after the user clicks a link, icon, or 
picture). In PagePlus, you'll see a marker on the page where the player will appear.

With option 1, the media file remains external and can't be embedded in your publication. Options 2 to 4 give you the choice of 
embedding the media file.

To add linked sound or video to a page:

n To link from an object or hotspot (option 1 above), choose Hyperlink... from the Insert menu and select A file on your hard 
disk as the link target, then locate the media file. For details, follow the links given in option 1.

OR
1 To link from an icon, picture, or inline player (options 2 to 4), choose Web Object... from the Insert menu and select either 

Sound... or Video... from the submenu.

2 Browse to locate the media file name.

3 Select a link display option. 

4 If you do not wish to embed the file in your publication, uncheck the "Embed" option.
Note: If you choose not to embed your source files, we suggest you keep them together in a single subfolder, named "Media" 
or the like. When you publish your site, PagePlus exports and copies both embedded and non-embedded files into a common 
folder.

5 Click OK to close the dialog, then click (or click and drag) with the cursor to place the icon, picture, or marker on your page.



Adding Java applets (Web Publishing mode only)

Java is a cross-platform, object-oriented programming language used to create mini-applications called applets that can be 
attached to Web pages and that run when the page is viewed in a Web browser. PagePlus lets you add Java applets to your 
Web publications. You don't have to write your own! Plenty of applets are available online—for example animation, interface 
components, live information updating, two-way interaction, graphics rendering, live updating, streaming audio and video, 
games, and many more. 

Downloaded applets typically consist of a main ".class" file and one or more associated files (such as other .class files, picture 
files, media files, etc.). Again, you don't need to understand the underlying code, but it's essential to make sense of any "Read 
Me" documentation that comes with the applet. When using PagePlus to embed an applet, you must list its component files as 
well as any necessary parameters (as described in the applet's documentation) that specify exactly how the applet should run.

When adding a Java applet in PagePlus, you have the option of embedding its files in your publication, as opposed to keeping 
them separate. Although embedding any file adds to the size of the publication, it is the default option because you'll no longer 
have to worry about juggling separate files or the chance of accidentally deleting one of them. When you publish your site, 
PagePlus takes care of exporting and copying both embedded and non-embedded files.

Bear in mind that Java applets won't execute instantly in a visitor's browser. As with image or media files, it will take time to 
download the applet files to the user's computer before anything "happens" on screen. Take the combined applet file sizes into 
account when figuring the time it will take the Web page to display.

PagePlus inserts a marker into your publication at the place where the applet will appear on your Web page. You can't actually 
see the applet running until you preview the exported site. The marker's dimensions probably won't correspond exactly to those 
of the applet when it's running, so plan your page layout accordingly. Also, bear in mind that a Java applet's user interface may 
look slightly different on each browser that displays it, even on the same operating system. The more preview tests you can run, 
for example using both Netscape Navigator and Microsoft Internet Explorer, the better.

To add a Java applet to a page:

1 Choose Web Object... from the Insert menu and select Java Applet... from the submenu.

2 In the dialog, click Browse... to locate the Applet Class File. 

3 Click the upper Add.. button to locate any other files required by the applet. You can hold down the Ctrl or Shift key to select 
multiple files in the dialog. To delete a file once you've added it to your list, click the file name and then click the Delete button.

4 If you do not wish to embed the files in your publication, uncheck the "Embed" option.

5 Click the lower Add... button to enter any required parameters (see documentation supplied with the Java applet). Add 
parameters one at a time, typing the Name and Value (excluding quotation marks) in the fields provided. To delete a 
parameter from the list (for example if you typed it wrong), click the Up or Down buttons to select the parameter, then click the 
Delete button below the list.
Note: When you publish your site, PagePlus will export and copy both embedded and non-embedded files into a common 
folder along with the HTML pages and graphics. Keep this in mind when entering file paths. If the applet's documentation 
insists on certain components being placed into separate subdirectories, you'll need to place them there "by hand" using an 
FTP utility.

6 Click OK to close the dialog, then click (or click and drag) with the cursor to place the Java marker on your page.



Adding HTML (Web Publishing mode only)

While PagePlus's Web Publishing mode doesn't support full-fledged HTML editing, it does allow you to add extra HTML code to 
a page. Using this approach, you can include HTML fragments generated by another application, copied from another Web 
page, or perhaps those you've written yourself. 

PagePlus inserts a marker into your publication at the site where the HTML code will run. Since you won't be able to see the 
effect of the HTML until you preview the exported site, be careful to place the marker correctly. You'll definitely want to check 
your Web page in a browser! If there's a problem, double-check the code you entered and its position on the PagePlus page. If 
you have some grasp of HTML, examine the page source in a text editor such as Notepad or use your browser's "View Source" 
mode.

To add HTML code to a page:

1 Choose Web Object... from the Insert menu and select HTML... from the submenu.

2 The dialog includes one scrolling field for Body code, another for Header code. Enter one or more HTML code fragments into 
the appropriate field. To indent lines, press Ctrl+Tab to insert a tab. You can also use Ctrl+C to copy, Ctrl+X to cut, and 
Ctrl+V to paste via the Clipboard.

3 If the code calls for external files, use the Add button to locate them. Uncheck Embed files in publication if you want to keep 
the file(s) separate from your publication file. 

4 Click OK to close the dialog, then click (or click and drag) with the cursor to place the HTML marker on your page.



Adding search engine descriptors (Web Publishing mode only)

Although they're optional, if you want to increase the likelihood that your Web site will be "noticed" by major Web search 
services, you should enter search engine descriptors. Search services maintain catalogs of Web pages, often compiled 
through the use of "crawlers" or other programs that prowl the Web collecting data on sites and their content. By including 
descriptive information and keywords, you'll assist these engines in properly categorizing your site. Note that you generally need 
to register your site's URL with a search provider before it can be included for data collection.

To enter search engine descriptors:

1 Choose Web Site Properties... from the File menu and click the Search tab.

2 In the top window, type in a brief description of your site. Although the description can be any length, the first ten words or so 
are the most important.

3 In the bottom window, enter any number of keywords (separated by commas) that you think fairly categorize your site. Put 
yourself in the place of a potential visitor. What keywords might they enter if they were searching for exactly what your site has 
to offer?



Setting service provider options (Web Publishing mode only)

Check the instructions from your Web service provider as to their naming conventions for Home Pages and file extensions. 
Typically, Home Pages are named INDEX.HTML. Depending on the particular server in use, however, some other name may be 
required. Likewise, the extension .HTM is sometimes used for pages.

To change the Home Page name and/or file extension (if necessary):

1 Choose Web Site Properties... from the File menu.

2 On the Page tab, enter a new file name and/or extension, as required by your service provider.



Optimizing your Web site (Web Publishing mode only)

As with a paper publication, preparing a Web site for its unveiling means checking and rechecking the content.

You can use the regular PagePlus checking functions: see the series of topics in the "How to Check Your Work" section, starting 
with Spell-checking. 

The Web Site Layout Checker can inspect for (and often correct) text-specific problems, overlapping objects, or other 
conditions that will result in file sizes that are larger than necessary. For details on using the Layout Checker, see Automatic 
layout checking.

In Web Publishing mode, you also need to minimize the time each of your Web pages will take to load into a visitor's Web 
browser—which is directly related to the total file size of the HTML page plus any associated images. (To review tips on 
optimizing text and graphics, see Web page layout fundamentals.)

Prior to publishing your Web site to the World Wide Web, you'll want to "publish" it to a local hard disk (see next topic) and 
preview it in your own Web browser. Bear in mind that load times will be considerably slower over the Web, unless a visitor has 
an exceptionally fast connection. 

Using Windows Explorer, you can check the file sizes of the items in your site's folder. As a rule of thumb, keep the total size 
(HTML plus images) per page to around 50K. The Home Page can be larger—people expect to wait a bit longer for this—but 
again, the smaller the better.



Publishing a Web site to a local folder (Web Publishing mode only)

Even though you may have saved your Web site as a PagePlus publication, it's not truly a "Web site" until you've converted it to 
HTML files and image files in a form that can be viewed in a Web browser. In PagePlus, this conversion process is called 
publishing the site. You can publish the site either to a local folder (on a hard disk) or to the World Wide Web itself. To review the 
basics, see Getting started in Web mode.

Publishing the site to a local folder lets you preview the pages in your own browser prior to publishing them on the Web. You may 
find it convenient to keep your browser program open, and go back and forth between PagePlus and the browser. This way you 
can make changes to a single page in PagePlus, publish just the one page, then switch to your browser and preview that page to 
make sure everything appears just as you want it. 

To publish the site to a local folder:

1 Choose Web Site Properties... from the File menu and double-check export settings, particularly those on the Graphics tab. 
(See "Page and file names" below, and see Setting Web picture display options for details.)

2 Choose Publish Site from the File menu and select to Disk Folder... from the submenu.

3 In the Publish to Folder dialog, locate the folder where you wish to store the output files, or click New Folder to create a new 
folder. 

4 To publish only one page (or a range of pages), specify the page (or pages) to publish. This can save a lot of time by skipping 
the export of pages you haven't changed.

5 Click OK.

After PagePlus has finished exporting the selected pages, you'll be asked if you want to run a Web browser to preview your 
pages. Answering Yes will open a new instance of your designated Web browser on the first exported page. To preview pages if 
your browser is already open, answer No (to avoid opening a new instance of the browser), then switch to the browser and open 
the HTML file for the page using the browser's Open File or Reload command. See the next topic for more information on 
previewing your site. 

Page and file names
By default, the published page 1 (the Home Page) has the file name INDEX.HTML so that Web browsers can locate it. (You can 
change this default if necessary using Web Site Properties.) Subsequent pages (which must of course have unique file names) 
are named "index-2.html, index-3.html," and so on, by default. If you're about to overwrite an existing file name, PagePlus will 
prompt you before proceeding.

As for image files, uncheck the Use original file names setting on the Graphics tab of File/Web Site Properties... if you want 
WebPlus to generate a new file name with incremental numbering, as opposed to using the original name (i.e. overwriting old file 
names). Check Restart file numbering with each 'publish' if you want file names that WebPlus generates for converted graphics 
to begin again from "001" rather than incrementing indefinitely each time you publish the Web site. This is useful if you intend to 
overwrite a set of previously published files.



Previewing your Web site in a browser (Web Publishing mode only)

Previewing your site in a Web browser is an essential step before publishing it to the World Wide Web. It's the only way you can 
see just how your PagePlus publication will appear to a visitor. Bear in mind that pages generally load much more quickly from a 
hard disk than they will over the Web. If performance is sluggish from a hard disk, it's time to subtract some graphics, divide the 
content into more (and smaller) pages, or run the Layout Checker again.

To preview your Web site from a local hard disk:

n Choose Publish Site from the File menu and select to Disk Folder... from the submenu. After publishing the site (or selected 
pages), answer Yes when asked if you want to run a Web browser to preview your pages. 

OR
n Choose Preview Web Site in Browser... from the File menu and specify the page range. Then the publication is exported to a 

temporary folder. 

OR
n (if you've previously published the site to a folder) Open your Web browser and use its Open File command to display a page 

from the site, usually the INDEX.HTML (Home Page) file.

You may find it convenient to keep your browser program open, and go back and forth between PagePlus and the browser. This 
way you can make changes to a single page in PagePlus, publish just the one page, then switch to your browser and preview 
that page to make sure everything appears just as you want it. See the previous topic, Publishing to a local folder. 



Publishing to the World Wide Web (Web Publishing mode only)

Publishing to the World Wide Web involves a few more steps, but is basically as simple as publishing to a local folder! Read 
through the following steps carefully before you try, and have the necessary information at hand. If you still have basic questions 
about the process, you may wish to revisit the topic Getting started in Web mode.

To publish your site to the World Wide Web:

1 Choose Web Site Properties... from the File menu and double-check export settings, particularly those on the Graphics tab. 
(See "Page and file names" below, and see Setting Web picture display options for details.)

2 Choose Publish to Web... from the File menu and select to Web... from the submenu. The Web Publishing Options dialog 
appears.

· The dialog is preset to publish all the pages in your document. To publish one page, or a range of pages, check Pages and 
enter the starting and ending page under Page Range. This can save a lot of time by skipping the export of pages you haven't 
changed. 

3 Click OK, and PagePlus begins exporting pages to temporary files. Once exporting is complete, the Specify Account Details 
dialog appears. 

· Choose an FTP Account you previously defined from the list, or to define a new account, type the FTP Address

 of the Web server. (See "Gathering server information" below.)
Note: To delete an FTP account from the list, simply delete its name. The list will be updated when you click OK.

· Type your Username and Password as needed. Be sure to enter the password exactly as given to you, using correct upper- 
and lower-case spelling, or the host server will not recognize it.

· If you wish, check the "Save Password" box and PagePlus will "remember" your password the next time you publish.

· Type the complete path in the Folder box, as specified by your provider (for example, "Webspace/Users/J_Smith"). 

4 Click OK, and PagePlus seeks an Internet connection, then transfers your Web files to the host server you've designated. Any 
files with duplicate names are overwritten. You'll see a message when all files have been successfully copied. 

5 You'll be able to see your page(s) "live" on the Web immediately. Point your Web browser to the URL including the path to the 
host server plus the folder to which you published. 

6 Congratulations! (And when you're done admiring your site, don't forget to disconnect from the Internet...)

Page and file names
By default, the published page 1 (the Home Page) has the file name INDEX.HTML so that Web browsers can locate it. (You can 
change this default if necessary using Web Site Properties.) Subsequent pages (which must of course have unique file names) 
are named "index-2.html, index-3.html," and so on, by default. If you're about to overwrite an existing file name, PagePlus will 
prompt you before proceeding.

As for image files, uncheck the Use original file names setting on the Graphics tab of File/Web Site Properties... if you want 
WebPlus to generate a new file name with incremental numbering, as opposed to using the original name (i.e. overwriting old file 
names). Check Restart file numbering with each 'publish' if you want file names that WebPlus generates for converted graphics 
to begin again from "001" rather than incrementing indefinitely each time you publish the Web site. This is useful if you intend to 
overwrite a set of previously published files.

Gathering server information
The first time you publish to a particular server, you'll be prompted to enter basic information, such as server's URL. On many 
services, your personal publishing directory is just your screen (user) name appended to a standard URL.

However, if your account is with a specialized Internet service provider, or you're using a dial-up networking connection or some 
other arrangement, you may need to do a bit more research to determine the required information. For example, you should 
verify beforehand:

n The steps needed to connect to the server, whether via LAN (intranet) or Dial-up Networking connection

n Your user name and password

n Which transfer protocol the server supports: FTP or Windows file transfer

n Whether the Web server can accommodate spaces in file names. If you find it cannot, then choose Web Site Properties... 
from the File menu, select the Graphics tab, and check Remove spaces from file names to revise graphic file names 
accordingly when they are published. (If you've already published your site, you'll need to do so again to fix the problem.)



Spell-checking

The Spelling Checker Wizard lets you check the spelling of a single word, selected text, a single story, or all text in your 
publication. (To help trap spelling errors as they occur, use the PagePlus AutoCorrect and AutoSpell features.) You can 
customize the built-in dictionary by adding your own words.

To start the Spelling Checker Wizard:

1 To check a single story, first make sure the text or text object is selected.

2 Choose Spell Checker... from the Tools menu.
OR

(In WritePlus) Click the  Spell Check button.

3 Click Next.

4 Click to select the scope of the search. To ignore words in certain categories, click I want to set the spell options. 

When a problem is found, WritePlus opens with the problem word highlighted, and the Check Spelling correction dialog appears. 
In the dialog, you can choose to change or skip this instance (or all instances) of the problem word, with the option of adding the 
problem word to your dictionary.

5 Spell checking continues until you click the Close button or the spell-check is completed. 

To check the spelling of a single word:

1 With the AutoSpell feature turned on, select in a marked word, then right-click. You'll see alternative spellings on the context 
menu.

2 To replace the word, choose an alternative spelling from the menu.

3 To tell PagePlus to ignore (leave unmarked) all instances of the marked word in the publication, choose Ignore All.

4 To add the marked word (as spelled) to your personal dictionary, choose Add. This means PagePlus will ignore the word in 
any publication.

5 To run the Spelling Checker Wizard, choose Check Spelling....

OR
1 Start the Spelling Checker Wizard and click the QuickSpell... button.

2 Type a word and click Spell. The dialog reports a possible spelling error and suggests alternative spellings.

Modifying your dictionary
The Spelling Checker relies on a built-in dictionary that's quite extensive but may not contain certain words you use frequently in 
your publications. To make spell-checking more efficient, you can add words to your own User Dictionary as described below so 
they won't pop up as "misspelled" in the future, and (if necessary) delete new words you previously added—especially handy if 
you misspelled one when you typed it in!

 

To add or delete a word in the User Dictionary:

1 Choose Options... from the Tools menu and select the Dictionary page. 

The contents of the dictionary appear in an alphabetical list.

2 To add a word, type it into the box and click Add.

3 To delete a word, select it in the list and click Delete. 
Note: When selecting words, you can press Ctrl to select multiple words, or Shift to select a contiguous range.



Automatic proofreading

The Proof Reader Wizard checks for grammar and readability errors in selected text, a single story, or all text in your 
publication. You can use the Wizard from either PagePlus or WritePlus.

To start the Proof Reader Wizard:

1 To check a single story, first make sure the text or text object is selected.

2 Choose Proof Reader... from the Tools menu.

3 In the Wizard, click to select the scope of the search. To set options for spell-checking, level of formality, and rule types, click I 
want to set the proof options. 

When a possible problem is found, the Wizard highlights the problem text a suggestion dialog appears. In the dialog, you can 
choose to correct or ignore the problem, skip the sentence, or ignore the grammar rule in future, with the option of adding the 
problem instance to your database. 

Proofreading continues until you click the Close button or the check is completed. To save any alterations made to the last story 
checked, close WritePlus in the normal way.



Using the thesaurus

The Thesaurus lets you find synonyms, definitions, and variations of words in text objects throughout the publication. You can 
use the Thesaurus from either PagePlus or WritePlus.

To display the Thesaurus:

1 To look up a specific word, first drag to highlight it.

2 Choose Thesaurus... from the Tools menu or press Shift+F7.

3 To look up a different word, type it into the "Replace/Look Up" box and click the Look Up button.

Using the Thesaurus:

If the word entered is found in the thesaurus database:

n The word is shown in the "Looked Up" box. 

n The "Meanings" list shows definitions for the word in the "Looked Up" box. Initially, the first definition is selected. 

n The "Synonyms" list shows synonyms for the definition selected in the "Meanings" box. Initially, the first synonym appears in 
the "Replace/Look Up" box.

To pop a new word into the "Replace/Look Up" box:

n Click the word in the "Synonyms" list. 
OR
Type a new word directly into the "Replace/Look Up" box.

You can navigate indefinitely through the thesaurus by selecting the specific meaning, followed by the specific synonym you are 
interested in and then clicking on the Look Up button to get a new range of meanings and synonyms for the new word.

To replace the original word (selected in your text) with the word in the "Replace/Look Up" box:

n Click the Replace button. 

To exit the thesaurus:

n Click the Cancel button.



Checking fonts and resources used

The Resource Manager lists the fonts and resources used in your publication, and shows if the pictures are linked to external 
picture files or embedded within the document.

To display the Resource Manager:

n Choose Resource Manager... from the Tools menu.

Resources tab
The Resources tab lists imported pictures, media, Java applets, etc. It shows whether each is linked or embedded and lets you 
switch a resource from one mode to the other. "Linked" data consists of a reference to the original file. If you copy or move a 
publication with linked resources, for example from one computer to another, you should also copy any resource files linked to 
the publication. 

To display the path name for a resource:

n Click on the resource name. 

n The path appears below the Resources section.

To view a particular item:

n Double-click its name in the list.
OR
Select the item's name and click Display.

To switch an item from linked to embedded:

1 Select the item's name.

2 Click Break Link to embed a linked item.
OR
Click Create Link to link an embedded item.

To control whether pictures you import are linked or embedded:

n Choose Options... from the Tools menu and click the Picture tab.

n Set your preferences for linking and embedding.

Fonts tab
The Fonts tab lists fonts used in text objects throughout the publication. If you are copying a publication to take to a different 
computer, you should check that the fonts used are available on the new computer. 

To display the font category:

n Click on the font name. 

The font category (TrueType, Printer, or System) appears below the Fonts section.

To view a particular item:

n Double-click its name in the list.
OR
Select the item's name and click Display.

In general, use only TrueType fonts. These are standard, printer-independent Windows fonts. Take particular care using printer-
dependent fonts, as the new machine may be using a different printer driver.



Optimizing pictures for printing

The Photo Optimizer Wizard helps you to improve the print quality of a selected bitmap picture on a specific printer. The Wizard 
lets you print test samples and choose the best brightness/contrast settings, which are then applied on-screen and when the 
publication is printed. You'll see the most dramatic results with photographic images using many colors or shades of gray.

To optimize a bitmap picture for printing:

1 Select the picture.

2 Choose Picture from the Format menu and select Photo Optimizer... from the submenu.

3 Follow instructions in the Photo Optimizer Wizard.



Reviewing text content with the Text Manager

The Text Manager displays a list of all the frame text and artistic text used in your publication. (It doesn't include table text, which 
isn't editable in WritePlus.)

To display the Text Manager:

n Choose Text Manager... from the Tools menu.

The window displays stories, arranged alphabetically by story title (or source file name) as shown in the Object Description box 
on the HintLine. The list includes the first line (if any) of each text block.

To display any text:

n Select the entry and click the Display button.

To edit the text in WritePlus:

n Select the entry and click the Edit button. 

WritePlus opens, displaying the selected text. For details on using WritePlus, see the topic Editing story text with WritePlus.



Automatic layout checking (Web Publishing mode only)

The Layout Checker Wizard searches your Web publication for common layout problems, such as objects off the page, unused 
text in a story, and empty frames. If problems are found, the Layout Checker displays a recommended solution and in many 
cases can fix the problem automatically.

To run the Layout Checker Wizard:

n Choose Layout Checker... from the Tools menu.

You can specify which problems the Wizard should check for. Depending on the publishing mode, options include:

n Text problems (properties that cannot be displayed correctly on a Web page):

-- Font other than Arial, Times New Roman, Courier, or Symbol

-- Outline font style or small caps

-- Set width not 100% (relative), or other than actual point size (absolute)

-- Tabs

-- Fill other than solid

-- Auto pair kerning on

-- First line indent not 0

n Text that must be converted to a graphic

-- Text under an overlapping object that uses transparency

-- Text that wraps around another object (option to turn wrap off, or convert to a graphic)

-- Rotated or cropped text

-- Artistic text that uses a non-solid fill, line border, filter effect, transparency, or stretch (resizing)

n Long download times (your publication will be slow to download from the Web for the average user):

-- Area that will become a graphic results in graphic larger than 300 x 200 pixels

n Other problems:

-- Objects not on the page or not entirely on the page

-- Unreachable pages (pages that cannot be reached by hyperlinks from page 1)

-- More than 1" (96 pixels) of blank space between highest object and top of page

-- Unused text (overflow text) in story

The Wizard proceeds through the selected range of pages and displays each problem region in turn. You can examine the 
problem, fix it on the spot, and/or click the Continue button to continue checking.

Note: Several other format attributes can cause problems during Web page conversions, but are beyond the scope of the Layout 
Checker. These include: Dropped or raised caps, justified paragraphs, and text lines set above or below. 



Exporting PDF files

PDF (short for Portable Document Format) is a cross-platform file format developed by Adobe. In a relatively short time, PDF has 
evolved into a worldwide standard for document distribution which works equally well for electronic or paper publishing. You can 
export a PagePlus publication as a PDF file.

The word "portable" sums up PDF’s key advantage, and is the common thread in all of these key features:

n PDF preserves the publication’s original layout and font properties, incorporating graphics and even hyperlinks along with text.

n Anyone with the free Adobe Acrobat® Reader (the latest version is supplied with PagePlus) can view PDF files, either from 
within a Web browser window or directly—for example, delivered over a network or on CD-ROM. 

n PDF documents are uniformly supported in the Windows, Macintosh, and UNIX® environments. 

n Since the format incorporates the standard PostScript language, PDF documents print well on nearly all printers. 

n Document content is resizeable: readers can zoom in or out to view at different resolution levels. 

n Content is navigable: besides using page navigation buttons, readers can click bookmarks with links to section headings and 
key elements. 

n Annotations in the form of pop-up "sticky notes" allow comments and sidebars. 

n PDF documents are compact—one-fifth the size of comparable HTML files—for faster transmission.

To export your publication as a PDF file:

1 Prepare the publication following standard print publishing guidelines, and taking the distribution method into account. (See 
"Layout and design tips for PDF publications" below.)

2 (Optional) Insert hyperlinks as needed, for example to link table of contents entries to pages in the document.. 
Note: Hyperlinks can open a Web page, a page in your publication, a new e-mail message, or an external file (such as a 
sound or movie). Certain Web-specific features other than hyperlinks—such as hotspot graphics, rollovers, Java, and HTML 
code—are not supported in PDF documents. Only the first frame of animated GIFs will appear. 

3 (Optional) To create pop-up annotations, insert PageHints as needed. (For details, see the topic Using PageHints.]

4 (Optional) Once the publication is final, prepare a bookmark list as described in the next topic. 
Note: Bookmarks appear as a separate list in a special pane when the PDF file is viewed. They can link to a specific page or 
to an anchor (for example, a piece of text or a graphic object) in your publication.

5 Choose Publish as PDF... from the File menu and check your export settings. (To export the whole publication using default 
settings, you won’t need to change any settings.)

General tab

Print range
To export less then the whole publication, specify the range of pages to 
export.

Options
· Select Impose pages for viewing to output pages using the same page 
order as in the PagePlus publication. Select Impose pages for printing to 
produce a page sequence suitable for a folded publication or one that uses 
facing pages. (We suggest you check with your print vendor before selecting 
the "for printing" option. Note that when using this option, hyperlinks, 
PageHints, and bookmarks are disabled.)
· When you impose for viewing, hyperlinks and bookmarks in your 
publication will be included by default in the exported PDF file. To suppress 
an element, deselect it here. For example, you might not wish to include 
bookmarks in a version of the publication intended for professional printing. 
Note: Hyperlinks and bookmarks are ignored in any case when a PDF file is 
printed.
· Check Preview PDF file in Acrobat to display the document in the Adobe 
Acrobat Reader immediately after exporting. If unchecked, you won’t see a 
preview.

Advanced tab

Render complex fills as bitmaps
Objects that use Linear, Radial, and Conical fills display rather slowly in 
Acrobat Reader. Check this option to export such objects as bitmapped 
graphics, at the expense of larger PDF file size. Uncheck the box to leave 
the objects as vector graphics.

Embed fonts
If your publication uses TrueType or PostScript fonts that your readers are 
unlikely to have (and if display accuracy is important, which is usually the 
case), check this option to include the fonts in the PDF file. That way, the 
publication will appear exactly as you intended. Note that this is an "all or 
nothing" option—i.e. you cannot select particular fonts for embedding—and 



file size will increase according to the total number of fonts you’ve used.

If Exclude common fonts is checked, standard Windows fonts like Arial, 
Times New Roman, Symbol, or Wingdings will not be embedded. It's safe to 
assume any Windows users viewing the PDF will already have these fonts. 
Note: If you feel comfortable using the Windows Registry, you can edit the 
list of excluded fonts using the key "PDF Settings/Excluded Fonts".

Transparency
These settings enable PagePlus objects using applied semi-transparency to 
be rendered successfully in Acrobat Reader.
· For the Transparent Area DPI setting, we recommend 300 dpi for printer 
output and 96 for online viewing. (600 won’t improve the visible results, and 
some print bureaus won’t accept this level of output.)
· Check Mask Images to output these graphics line by line; if unchecked, an 
opaque rectangular region will be output. You may need to experiment with 
the Strip Size value to achieve best results. Smaller values mean smoother 
lines, but more complex PDF files—with the worst case possibility that older 
versions of Acrobat Reader may have difficulty opening the file.

Compression 
Images included in the publication can be downsampled and/or compressed 
for smaller, more efficient PDF delivery. You may wish to alter the default 
settings for specific types of images, for example if a print bureau requests a 
specific setting. For details on common image formats, see the topic 
Importing images and the subtopic About Web picture formats.
· Check Downsample images to and select a setting (we suggest 300 for 
print output and 96 for online viewing). If unchecked, images will be output at 
their original dpi.
· Check Compress images and select a Quality setting (Best Quality, 
High, Average, Low, and Smallest File) to apply a compression algorithm, 
ranging from least to most compression.

6 Click OK to proceed to export. 

If you checked Preview PDF file in Acrobat, the resulting PDF file appears in the version of Acrobat Reader installed on your 
system.

Layout and design tips for PDF publications
n As with any publication, take advantage of the range of proofing tools PagePlus affords. See the series of topics in the "How 

to Check Your Work" section, starting with Spell-checking.

n With PDF, even if you decide to use hyperlinks and/or are working in Web publishing mode, you are essentially creating a 
paper-based document so you don’t have to worry about most of the limitations of publishing to HTML (nonstandard fonts, 
special text properties, overlapping graphics, etc.).

n While you can stick to paper-based design conventions, don’t overlook the fact that some readers may want to peruse your 
PDF onscreen. For example, text readability is an important consideration. Conventional wisdom states that sans-serif fonts 
are more legible onscreen, but run some tests and let your own eye be the judge. As a rule of thumb, increase leading 
somewhat and use slightly narrower line lengths for onscreen text.

n Font accuracy is of course a big reason for using PDF in the first place... but you still need to plan ahead. Acrobat Reader will 
substitute fonts for those you’ve used if it turns out the fonts are neither available on the user’s system nor embedded in your 
PDF. Acrobat Reader v3.0 doesn’t support TrueType fonts and will always substitute! And even using "plain vanilla" Windows 
fonts won’t guarantee WYSIWYG display on another operating system. Ideally, you can employ just one or two attractive fonts 
(that’s a good design rule anyway), and embed them without increasing the file’s size too much. Embedding fonts has less of 
a relative impact on the file size of documents that are longer/larger to begin with. The alternative is to use more ordinary fonts 
(e.g. Arial/Helvetica or News Gothic families) without embedding.

n Complex fills output in vector format slow down the onscreen display of a PDF page; but if converted to bitmaps they expand 
the file size. So there’s no easy solution but to use them sparingly!



Creating a PDF bookmark list

Bookmarks are optional links that appear in a separate pane of the Acrobat Reader when a PDF file is displayed. Typically, a 
bookmark links to a specific location such as a section heading in the publication, but it can also link to a document page.

If you’re exporting a multi-page or multi-section publication to the PDF format for onscreen viewing (see the previous topic for 
details), creating a bookmark list will make the content a great deal more accessible. In general, the list should include top-level 
headings such as chapter heads, contents, or menu. See "Tips for PDF bookmarks" below for further design suggestions.

The mechanics of creating a PDF bookmark list are quite simple. For example, to create a basic list with bookmarks to section 
heads, you simply proceed forward through the publication, inserting a bookmark for each heading. Bookmarking a specific 
location (for example, a piece of text or a graphic object) entails placing an anchor at that location; the anchor serves as the 
target for the bookmark link. The Bookmark Manager enables you to view all your bookmarks at a glance, organize them into a 
hierarchy of entries and subentries, and modify or delete existing bookmarks as needed.

To insert a bookmark:

1 (Optional) To bookmark a specific location in the publication, first place the cursor at that point or select an object. You can 
select a range of text (for example, a section heading) to use it as the actual text of the bookmark.

2 Press Ctrl+R or choose Bookmark... from the Insert menu (or Insert Bookmark... from the right-click menu).
OR
Choose Bookmark Manager... from the Tools menu. In the bookmark tree, display the entry below which you want to create 
the new bookmark. (Check Create as sub-entry if you want the new bookmark nested as a "child" of the selected entry.) Then 
click the Create... button.

Either action displays the Create Bookmark dialog, with a choice of destinations. 

Tip: If you’re simply adding bookmarks in series, it’s quicker to use the Insert/Bookmark... command as you move through the 
publication, thus avoiding the need to reopen the Bookmark Manager each time. When you use the menu command, PagePlus 
automatically builds the list downward, placing each new bookmark below the previous one. (To add bookmarks in the middle of 
the list, simply open the Bookmark Manager and select any existing bookmark below which new bookmarks should be added.) 
Once you’ve created your bookmarks, you can return to the Bookmark Manager to double-check and (if necessary) reorder the 
list.

3 In the Create Bookmark dialog, the Text field shows the range of text you selected if any (for example, a section heading). You 
can leave this if it’s suitable for the bookmark text or edit it as needed; otherwise enter new text if the field is empty.

4 Click to select the bookmark destination type, then enter the destination.
· To bookmark a specific location, choose An anchor in your publication. To place a new anchor at the cursor location, 
select <Anchor at current selection> from the list below. You’ll be prompted to enter an anchor name (with the bookmark 
text as the default); edit the name if you like and click OK. To bookmark a previously placed anchor, simply choose it from the 
list.
· To bookmark a specific page in the publication, select A page in your publication and select the target page number.

5 Click OK to confirm your choices.

Unlike hyperlinks, bookmarks also work as actual links within PagePlus publications. You can use the Bookmark Manager as a 
jumping-off point to any bookmarked entry.

To locate a bookmarked entry:

1 Choose Bookmark Manager... from the Tools menu.

2 Select the bookmark and click the Go To button.

To organize or modify bookmarks:

n Choose Bookmark Manager... from the Tools menu. 

The dialog displays the bookmarks in your publication as a tree with collapsible entries and sub-entries. The Create... button lets 
you add new bookmarks, as explained above.

n To move a bookmark to a new location in the tree, drag it into position. 

n To edit a bookmark, select it and click Modify.... The Modify Bookmark dialog appears, and you can edit the bookmark text or 
redefine its destination. Click OK to confirm choices and return to the Bookmark Manager.

n To delete a bookmark, select it and click Remove.

Tips for PDF bookmarks
n As a publication designer, keep in mind that to the user, a bookmark list is a convenient jumping-off point to the major 

sections. In Acrobat Reader, it’s always available (can even be undocked as a floating window) regardless of where the user 
happens to be in the document. 

n By all means, provide a basic bookmark list to top-level headings—but (especially for complex publications) make hyperlinking 
the table of contents your next priority. Despite their convenience, bookmarks are no substitute for a detailed TOC. If the 
document structure has lots of headings or nested subheads, scrolling the bookmark list and expanding bookmark levels 
becomes a thankless chore for the user. A table of contents can show the whole expanded structure, and it’s printable as well. 



You can create the table of contents right in PagePlus, then add hyperlinks to each page listed. 

n Acrobat Reader’s bookmark pane is initially rather narrow. Users can expand it, and recent versions of the Reader display 
tooltips for overlong bookmarks, but you should still try to shorten bookmark text as much as possible. Deleting extraneous 
bookmark text makes for easier at-a-glance viewing. 

n Double-check your spelling! Bookmark errors won’t get trapped by the spell checker, and it’s an embarrassment to have your 
misspellings "front and center" for all to see! 



Previewing the printed page

The Print Preview mode changes the screen view to display your layout without frames, guides, rulers, and other screen items. 
Special options, such as tiled output or crop marks, are not displayed.

To preview the printed page:

n Click the  Print Preview button on the Standard toolbar. 

OR
n Choose Print Preview from the File menu.

In Print Preview mode, the lower toolbar provides a variety of familiar view options, plus the Multipage View button, which lets 
you preview your publication using a page array.

To arrange multiple pages in the preview window:

1 Click the  Multipage View button. An array selector appears.

 
2 Click and drag to choose an array within the selector, for example 2x4 Pages or 3x3 Pages. To expand the number of choices, 

drag up and to the right.

To return to single page view:

n Click the  Fit Page button. 

OR

n Click the  Multipage View button and select the "1x1 Page" array.

To cancel Print Preview mode:

n Click the Close button.



Basic printing

PagePlus supports scaling, tiling, color separations, and many other useful printing options. If you're working with a service 
bureau or commercial printer and need to provide PostScript output, see the topic Generating professional output. See the 
previous topic for details on Print Preview mode.

To set up your printer or begin printing:

n Click the  Print button on the Standard toolbar. 

OR
n Choose Print... from the File menu, or after right-clicking on the page or pasteboard.

The Print dialog appears.

To print:

1 On the General tab, select a printer from the list. If necessary, click the Properties button to set up the printer for the correct 
page size, etc.
Note: Depending on your printer driver, to print text with shading or custom settings, you may need to select the Fonts tab 
and check the option to "Download TrueType Fonts as bitmap soft fonts."

2 If necessary, click the Layout, Separations, or Prepress tab(s) to set special print options, or choose a saved print profile for 
use in later sessions.
· To set options for scaling, thumbnails, multiple pages, tiling, or mail merge, select the Layout tab. For details, see Printing 
special formats. Mail merge is covered in the topic Using mail merge.
· To specify settings for color separations, select the Separations tab. For details, see Printing color separations.
· To set professional print options including printer marks, file and OPI (open press) information, transparencies, bleeds, and 
so on, select the Prepress tab. For details, see Generating professional output. 

3 Select the print range to be printed.

4 Select the number of copies.

5 The Preview window shows how your publication maps to the selected paper size. You can click the dialog's Preview button 
to hide and show the window.

6 Click OK. 

The pages will be printed in color on a color printer or in shades of gray on a black and white printer.

Notes: 

n If the AutoFit option is activated, PagePlus will intelligently determine the best print orientation (Portrait or Landscape) for a 
particular job. This may mean that the setting shown in the Print dialog doesn't match your publication's layout. For example, if 
you're printing business cards, PagePlus will pick whichever orientation that maximizes the number of cards most cards per 
sheet. To switch AutoFit on or off, use the General tab of the Tools/Options... dialog.

n Print options are reset each time PagePlus is restarted. Changes you make during a session are "remembered" for the 
duration of the session. For details on saving printer settings for later use, see Saving print profiles.

For more information...
For a discussion of desktop printing techniques, or if you are considering using commercial print services to reproduce your 
work, see the "Production Issues" chapter in the PagePlus Companion for a discussion of commercial and color printing.



Printing special formats

Using PagePlus setup and printing options, you can set up pages for a variety of publication types, such as booklets, posters, 
and banners. The Print dialog's Layout tab lets you specify other printing options, including scaling, thumbnails, multiple pages, 
and tiling.

Printing booklets
PagePlus automatically performs imposition of folded publications when you use File/Page Setup... and select or define a 
Folded Publication type. The settings ensure that two or four pages of the publication are printed on each sheet of paper, with 
pages printed following the booklet sequence. This saves you from having to calculate how to position and collate pairs of pages 
on a single larger page, and lets you use automatic page numbering for the booklet pages.

To produce double-sided sheets, use your printer's double-sided option or run sheets through twice, printing first the front and 
then the back of the sheet (reverse top and bottom between runs). The sheets can then be collated and bound at their center to 
produce a booklet, with all the pages in the correct sequence. With complex setups, you may wish to use commercial printing.

Printing posters and banners
Posters and banners are large-format publications where the page size extends across multiple sheets of paper. To have 
PagePlus take care of the printing, set up your publication beforehand using File/Page Setup... (with the "Large Publications" 
option) to preview and select a particular preset arrangement. 

Even if the publication isn't set up as a poster or banner, you can use tiling and scaling settings (see below) to print onto multiple 
sheets from a standard size page. Each section or tile is printed on a single sheet of paper, and the various tiles can then be 
joined to form the complete page. To simplify arrangement of the tiles and to allow for printer margins, you can specify an overlap 
value.

To print a poster or banner from a standard page:

1 First create your standard (e.g. letter) sized page.

2 On the Print dialog's Layout tab, set the "Tiling" option for overlapped multiple sheets, and set "Scaling" to print at a larger 
size (e.g. 300% ).

Scaling
n Under "Special Printing" on the Print dialog's Layout tab, set the "As in document - Scale factor" option to specify a custom 

scaling percentage. The default is 100% or normal size. To scale your work to be printed at a larger size, specify a larger 
value; to scale down, specify a smaller value. Check Fit Many to have PagePlus fit as many pages as possible on each sheet
—for example, two A5 pages on a landscape A4 sheet. 

n Set "Scale to fit paper size" values to adjust artwork automatically to fit neatly on the printed page. 

n Note that the Fit Many option ignores printer margins, while Scale to Fit takes them into account. So if you use Fit Many, make 
sure your page layout borders don't extend beyond the printable region. 

Printing thumbnails
n Under "Special Printing" on the Print dialog's Layout tab, set the "Print as thumbnails" option to print multiple pages at a 

reduced size on each printed sheet, taking printer margins into account. Specify the number of thumbnails per sheet in the 
value box. 

PagePlus will print each page of the publication at a reduced size, with the specified number of small pages or "thumbnails" 
neatly positioned on each printed sheet.

Multiple pages
n Under "Multiple pages per sheet" on the Print dialog's Layout tab, select an option. 

The multiple page options are enabled when you are working with a page from the Small Publications category in Page Setup. 
You can select the number of times to repeat each page, and tell PagePlus to skip a certain number of regions on the first sheet 
of paper. Skipping regions is useful if, for example, you've already peeled off several labels from a label sheet, and don't want to 
print on the peeled-off sections. Check the Preview window to see how the output will look.

n If you haven't set up the publication as a Small Publication, but still want to print multiple pages per sheet, try using the Fit 
Many option (see "Scaling" above). Note that this option ignores printer margins and doesn't change the imposition 
(orientation) of output pages.

Tiling
n Under "Tiling" on the Print dialog's Layout tab, check the "Print tiled pages" option to print large (or enlarged) pages using 

multiple sheets of paper. 

Each section or tile is printed on a single sheet of paper; the various tiles can then be joined to form the complete page. Use this 
option for printing at larger sizes than the maximum paper size of your printer, typically for creating banners and posters. To 
simplify arrangement of the tiles and to allow for printer margins, you can specify an overlap value.





Printing color separations

Using PagePlus, you can print both spot-color and process-color separations. The Print dialog's Separations tab lets you 
specify options. For further information on color separations, see the "Production Issues" chapter in the PagePlus Companion.

To set color separation options:

1 Choose File/Print... and select the Layout tab.

2 Check the Enable Separations box.

3 Set options as described below.

Choosing the color separation type
n Select Process to select process color output. 

This option is only available if the currently selected Windows printer is a PostScript printer.

Normally, process color output gives you four sheets or "separations" per publication page: one each for the Cyan, Magenta, 
Yellow, and blacK (CMYK) ink components of the objects on the page.

If any PANTONE Spot Colors are used in your publication and the "Convert Pantone Spot Colors to Process" option is not 
checked, the PANTONE Spot colors used in the publication will also be shown in the "colors used" list and a separate "Spot 
Color Separation" sheet will be printed for each of the PANTONE Spot colors used.

Only the color separations that are selected (checked) in the colors list will be printed. To select or deselect a separation, check 
or uncheck it.

n Select Spot to select spot color output.

Spot color output gives you one sheet or "separation" for each color used on each publication page. The colors list shows how 
many separations will be produced for each page. Only the color separations that are selected in the colors list will be printed. 

n To select or deselect a separation, check or uncheck it. 

n To change a Frequency or Angle value, click to select it, then type the new value.

n To overprint a specific color, check the corresponding box in the "Overprint" column (see below). 

Notes: 

n Bitmaps cannot be color-separated in spot color. 

n Imported TIFFs retain CMYK color data embedded in the file ready for full color separation. An RGB version of CMYK TIFFs is 
displayed onscreen and the CMYK data is automatically used on output when it exists. Filter effects drawn behind or outside 
text or shapes will not interfere with any CMYK data stored within the object. However, TIFFs used as Bitmap fills, or filter 
effects drawn inside pictures, text, or shapes containing CMYK data will result in an RGB version being used for printed 
output.

n Darkened colors that have not been added to the PagePlus palette will be spot-separated incorrectly, using the base (100%) 
value. To ensure that these colors are properly handled, add them to the palette using the as described in Creating your own 
colors. To use darkened PANTONE colors without adding them to the palette, make sure the "Convert Pantone Spot Colors to 
Process" box is checked. 

Selecting other options
Overprint

Select this option so that a specific color component (black is normally selected) prints on top of the other colors. This may 
sound strange, but because black ink is very dark, it can be printed on top of other colors without affecting its own color. This 
reduces "trapping" errors as there is no edge between a black object and the object it overlaps. Because of this, the thin white 
gaps normally caused by trapping problems will not occur with black objects.

Overprinting is especially useful when printing fine black text on colored tint (shaded) backgrounds, as it is notoriously difficult to 
prevent trapping problems if the black is not overprinted. 

Note that the overprint black setting does not affect how imported vector pictures are color separated.

Convert Pantone Spot Colors to Process

Select this option if you create your publication using colors from the Pantone Spot color palette (see Specifying PANTONE 
colors) and want to print your page using the standard four-color (CMYK) process separation colors. This will cause the 
PANTONE colors to be converted to the best process color (Cyan, Magenta, Yellow, and Black) equivalent. The option also 
allows you to use darkened PANTONE color without adding them to the PagePlus palette.

Trapping

Select this option to reduce the alignment problems that occur when printing using several color separations. In brief, if you have 
two different colored objects which overlap, they will appear on different printing plates. Because printing presses can never 
exactly align the multiple printing plates, a small "gap" can be left at the edge where the two objects overlap.



Auto trapping tries to reduce this error by making the edges where the objects overlap very slightly intersect. The auto-trapping 
values can be changed, but typically the default values will suffice.

Paper Type

Select the appropriate paper type on to which your printer will print your work. The associated "screen angle" and "screen 
frequency" settings are automatically set.

If you are a printing expert and require nonstandard settings, select the "Custom" paper type and adjust the values in the 
printer's Properties dialog (from the General tab).



Generating professional output

Beyond printing your own copies on a desktop printer, or having copies photoreproduced at a quick print shop, you may wish to 
consider professional (offset) printing. For example, if you need to reproduce more than about 500 copies of a piece, 
photocopying begins to lose its economic advantages. Or you may need spot color or process color printing (see the previous 
topic) for a particular job. The Print dialog's Prepress tab (see "Setting prepress options" below) includes special choices that 
may prove useful.

A standard way of delivering a desktop publication to a commercial printer or service bureau is to generate one or more 
PostScript® files that can be passed along on disk or via modem to the bureau. (PostScript is a page description language 
developed by Adobe to handle communication between computers and printers.) Producing a PostScript file is a straightforward 
process. When printing your PagePlus publication, you specify a PostScript printer (or printer driver) as the target, and instead of 
printing out sheets of paper, you check the "Print to File" option. The driver takes care of generating the PostScript file(s), and 
you deliver the file(s) to the print firm. 

In practice, there are so many options for setting up a PostScript driver, and so many different imagesetting systems in use by 
commercial print firms, that you'll need to fine-tune your system settings precisely to match the requirements of the printer with 
whom you're working. Good communication with your printing partner is really the key here, and cannot be overemphasized. 
Make sure you're using a satisfactory PostScript printer driver and have set it up exactly the way the firm has advised. For a 
comprehensive overview of commercial printing options, and suggestions on how to get great results, see the "Production 
Issues" chapter in the PagePlus Companion.

Among the points to consider are:

n What type of output your require: a single composite containing all colors, process (CMYK) color separations, or spot color

n What type of paper your document will be printed on

n Which installed PostScript printer driver you'll be using

n The publication's page size

n Whether you want to print each page to a separate file and/or print each separation to a separate file. (Smaller output files are 
more easily transferable to a service bureau.)

Notes

n Each time PagePlus restarts, the print options are reset to standard defaults. You can double-check the option settings from 
the Print dialog (click the Properties button) prior to actually printing to the PostScript file. Should you need to make further 
last-minute changes (for example, a custom setting required by your print bureau, or a limited set of spot color separations), 
you can do so at this point. Those changed settings will then be "remembered" for the duration of your session. 

n Another option for delivering files to a bureau or commercial printer is Adobe's PDF (Portable Document Format). PDF is 
being used increasingly to distribute documents as electronic "replicas" over the Web. Anyone using Adobe's Acrobat Reader, 
regardless of their computer platform, can view and/or print out your publication in its original form. To generate a PDF file, 
you'll need to "distill" your publication (or an existing PostScript file) using a utility such as Acrobat Distiller or PDFWriter. 

Setting prepress options

Printing page marks and/or file information

n Select any required options from the "Page Marks" section. 
· File Information will include information such time, date, and publication name below the actual artwork (PagePlus page). 
· Crop marks are small markers on the printed page, marking the page dimensions of the artwork. Also check Edge only 
crop marks if you want to suppress interior crop marks.
· Registration targets serve to help the printer align subsequent press runs with the first one. Various styles are available in 
the "Registration style" list.
· A densitometer bar is a reference strip consisting of 11 squares, with tint values ranging from 0% to 100% in 10% intervals, 
used to gauge output accuracy with a densitometer. The strip appears as shades of gray on each separation sheet; these will 
appear in the respective process or spot colors when separations are printed.
· A solid color bar is a reference strip consisting of 8 squares, with 100% values for cyan, blue, magenta, red, yellow, green, 
process black (C+Y+M) and pure black.

The printer page size must be at least 1" x 1" larger than the actual artwork being printed, to ensure that the marks will be 
entirely visible on the final print. For PostScript printing, the Windows printer driver normally has some "extra" page sizes which 
can be used with standard artwork paper sizes.

Suppressing pictures

n Check Suppress pictures to print hairline place holder boxes in place of the pictures in the publication. 

This has two uses: (1) to speed up printing of quick proofs, and (2) to leave markers for pictures to be added manually at a later 
stage of the production process.

Including OPI comments



The Open Prepress Interface (OPI) is a set of PostScript language comment conventions that allow PagePlus to pass layout 
information about imported bitmap images to an OPI-compatible system. OPI comments describe the placement, size, rotation 
and cropping of imported bitmap pictures so that the OPI server can insert high-quality pictures before printing the page(s). 

n Check Include OPI comments to include these comments.

Setting a bleed limit

If your design incorporates bleeds—elements that run to the page edges—you'll customarily lay out these elements so they 
extend slightly beyond the page edges, then print to an oversized sheet which is later trimmed to the correct publication 
dimensions. Overextending the elements ensures that your bleed design survives any inaccuracies in that trimming process, so 
there are no slivers of white showing at the edges. If you use bleeds, you should set a bleed limit to extend the printable area 
beyond the page edges where printing would otherwise stop. This ensures that the bleed elements you've overextended so 
carefully survive onto the printed page. The default value of 2mm (0.79 inches) provides a slight (but usually sufficient) 
extension.

n Check Bleet limit and specify a value to extend the printable area.

Other print options
Normally, PagePlus 8.0 outputs to the printer driver a mix of vector and raster (bitmap) data. The Rasterize resolution sets a 
limit on the amount of data needed for those parts of each page that are "rasterized"—that is, output as box-shaped bitmaps. 
This helps to speed up printing and reduce PostScript file sizes. If you enter a value of "0," the printer's current DPI setting is 
used; but beware—this may maximize quality but will also greatly slow things down.

Problems arise with some printer drivers when bitmaps in a publication use transparency. If you are getting poor results, you can 
select the Rasterize entire page option to output whole pages as bitmaps. While slower, this approach virtually guarantees 
successful printing. 

Stripped transparency, the default option, prints transparent areas by sending out bitmaps line by line, using lines one pixel 
high, and feeding only solid image data to the printer, ignoring any blank regions—rather like a scanning process. Especially 
recommended for inkjet printers, this is again a slow method but works in most cases.

The Clipped transparency option is another way of working around printer driver limitations. If the box is checked, the printer is 
instructed to ignore the transparent region surrounding a QuickShape that's normally there when PagePlus sends it out as a box-
shaped bitmap. Unfortunately, not all drivers deal well with the clipping command (resulting in data overload), so the option is not 
selected by default. It's available as a possible remedy for transparency-related driver issues. 

Occasionally, bitmaps have solid color borders that you may have hidden by setting them transparent. To avoid problems printing 
such images, try dragging a mask (from the Studio's Gallery tab) over the bitmap to cover its edges. The approach works 
because the mask is vector-based and there's no need to output transparent bitmap data to the printer. 



Saving print profiles

You can save the current combination of settings made in the Print dialog as a print profile with a unique name.

To save current print settings as a print profile:

n On the Print dialog's General tab, click the Save As... button next to the Print Profile list.

n Type in a new name and click OK.

The settings are saved as a file with the extension .PPR.



Customizing PagePlus toolbars and Studio tabs

The Visual Reference describes the default arrangement of PagePlus toolbars and Studio tabs, which are initially arranged in a 
convenient layout around the perimeter of the work area. However, you have full control over this arrangement, and can 
customize the display any way you want—by showing or hiding toolbars and tabs, or repositioning them onscreen in a way that 
suits your style. 

Customizing toolbars

To show (or hide) a toolbar:

1 Right-click on a neutral region of any toolbar and choose Toolbars.
OR
Choose Toolbars from the View menu.
OR
Choose Options... from the Tools menu and select the Toolbars page.

2 Check (or uncheck) the toolbar name.

 

You may wish to keep the original arrangement of toolbars exactly the same. 
But if you like, you can reposition any toolbar by clicking and dragging the 
gripper bar at the left or top of the bar.

Toolbars can float anywhere onscreen, or dock (join) with the edges of the PagePlus window. 

To dock a toolbar:

1 Click its gripper bar and drag to the desired location.

2 Drop the item into position when the interface responds. 

The Options dialog includes command icons and other items you can assign to any toolbar. Note that certain toolbars (like the 
Curve and MailMerge toolbars) are only displayed under program control in specific modes. 

To add an item to a toolbar:

1 Choose Options... from the Tools menu, expand the Toolbars category, and select the Customize page.

2 Select a category to view the items available for that category.

3 Click any command icon or item to see its description.

4 To add an item to a toolbar, drag it directly onto the toolbar. An "I-beam" mark appears to guide you in placing the item 
precisely.

To remove an item from a toolbar:

n Simply drag it off the toolbar (there's no need to open the Options dialog).

To create a new toolbar:

1 Choose Options... from the Tools menu and select the Toolbars page.

2 Click New....

3 Type a name for the new toolbar and click OK.

OR
n Follow the steps above for adding an item to a toolbar, but instead of dragging an item to a toolbar, drag it to a non-toolbar 

region. The item becomes the first one on a new toolbar with a default name.

To remove a custom toolbar: 

1 Choose Options... from the Tools menu and select the Toolbars page.

2 Select to toolbar to be removed and click Delete.

To reset all toolbars to their default arrangments: 

1 Choose Options... from the Tools menu and select the Toolbars page.

2 Click Reset.

Customizing Studio tabs
To show (or hide) a particular Studio tab:

1 Right-click on a neutral region of any tab and choose Studio Tabs, or choose Studio Tabs from the View menu.



2 Check (or uncheck) the tab name.

To hide and show the Studio tabs as a group:

n Click the  Studio button on the HintLine toolbar.
OR
Check (or uncheck) Studio on the View menu.

n Note: To hide the Studio, you can also click its  Close button.

 

Initially, the Studio consists of a cluster of tabs at the right edge of the workspace. In this form it behaves as a single multi-tabbed 
toolbar, including a gripper bar (see above) at the top that lets you reposition the whole cluster.

To dock a Studio cluster:

1 Click its gripper bar and drag to the desired location.

2 Drop the item into position when the interface responds. 

You can undock individual Studio tabs as floating "tab windows" and/or group them into different cluster arrangements which can 
either float or dock as toolbars at the left or right side of the workspace.

To undock a Studio tab as a separate window:

n Click on the tab's label and drag it to the new position.

 

To reposition a floating tab window frame on the screen:
n Drag the window frame by its title bar.

To close a floating tab window:

n Click the window frame's  Close button.

All the tabs in the window are hidden.

Within a given Studio cluster, you can only view one one tab's contents at a time. You can pick the arrangement that works best 
for you—separate tabs that you can view simultaneously, or clustered tabs to conserve screen space.

Note:

In general, tabs behave in a common-sense way, so that the groupings you've laid out are preserved and convenient to use:

n When you hide a tab using the View/Studio Tabs flyout, its label disappears from the window frame (or Studio). If you then 
redisplay the tab, it appears in the same frame as before, as part of the same tab grouping.

n If a frame has only one tab and you hide the tab, the window closes.

n If you close a window by clicking its Close button, all its tabs are hidden. 

n If you redisplay a tab when none of its former neighbor tabs are visible, it appears in its own frame. If you then show one of the 
neighbors, it appears in the same frame, preserving the tab grouping.

n PagePlus remembers your arrangement of tabs and toolbars from one session to the next.



Setting units

Ruler units
To select the basic measurement unit used by the rulers:

n Choose Options... from the Tools menu and click the General tab. 

You can select independent measurement units for the horizontal and vertical rulers. In Paper Publishing mode, the default unit 
is inches or centimetres; in Web Publishing mode, the default is pixels.

The actual interval size of the ruler marks depends on the current zoom percentage. In zoomed-out view, for example at 50%, 
there's more distance between ruler marks than when zoomed-in to 150%. To handle work where you want finer control or 
smaller snapping increments, click a Zoom button to magnify the page.

The dot grid
The dot grid is a matrix of dots, based on ruler increments, covering the page and pasteboard areas. It's especially useful as an 
alignment and snapping aid. You can set the grid spacing and style in the Options dialog. 

To change the grid spacing, style, and/or color:

1 Choose Options... from the Tools menu and display the Layout page. 

2 To set the grid interval, enter a value in the "Grid lines every" box.

3 To display the grid using dots, select "Dotted" as the "Grid style." To display grid lines, select "Solid."

4 To change the color of grid dots, click the Color button and then select a color thumbnail.



Updating and saving defaults

Object defaults are the stored property settings PagePlus applies to newly created text, graphics, and frames. When you create 
text in your publication, it will have default properties for font, size, color, alignment, etc. New graphics will have default 
properties for line and fill color, shade, pattern, etc. New frames will have default properties for margins, columns, etc. You can 
easily change the defaults for any type of object. 

Default settings are always local—that is, any changed defaults apply to the current publication and are automatically saved with 
it, so they're in effect next time you open that publication. However, at any time you can use the Save Defaults command to 
record the current defaults as global settings that will be in effect for any new publication you subsequently create. 

Whenever defaults are saved, whether locally or globally, the set of named styles (as shown on the Text toolbar) and the 
PagePlus color palette (shown on the Attributes tab's Color panel) are also recorded. For information about modifying these 
settings, see Using text styles and Creating your own colors.

To set local defaults for a particular type of object:

1 Create a single sample object and fine-tune its properties as desired—or use an existing object that already has the right 
properties. (For graphics, you can use a line, shape, or rectangle; all share the same set of defaults.)

2 Select the object that's the basis for the new defaults and choose Update Object Default from the Tools menu.
OR
Right-click the sample object and choose Update Object Default. 

Note on text defaults: In the case of text frames, use Update Object Default to set the default properties of the frame object 
(container). Use Update Text Default to set the default properties of text you type into any new text object. The "extra" 
properties of artistic text, such as line and gradient fill, are also included in the text defaults, but of course they will only show up 
on artistic text objects. You can also view and change the current default text properties in the Text Style Palette.

To view and change default text properties:

1 Choose Text Style Palette... from the Format menu.

2 Click Default Text, then click Modify... to view current settings.

3 Use the Attributes button to alter character, paragraph, or other properties.

To save all current defaults as global settings:

1 Choose Save Defaults... from the Tools menu.

2 Click OK to confirm that you want new publications to use the current publication's defaults.

Notes: 
n Saving the defaults as global settings only affects objects you create in new publications. Objects you create in any pre-

existing publication will still use the local defaults in effect for that publication.

n Color schemes are handled differently from the object defaults. They are automatically saved globally—so the full list of 
schemes is available in every publication.



Setting PagePlus options

The Options dialog lets you customize a wide range of PagePlus preference settings, including picture and layout options, 
ease-of-use features, and so on. As a rule, Options settings are global—that is, changing them affects all open publications, and 
when you close PagePlus, your current Options settings remain in effect the next time you open the program.

To set PagePlus options:

n Right-click on a blank area and select Options.... 

OR
n Choose Options... from the Tools menu.

Use the branching menu to display one of the dialog pages, and then set your options. Settings include:

General page: Language, Import text using, Auto-save, Number of Undo(s), Number of export fill bands, Show object contents 
while dragging, Auto-fit print layout, Metafiles on Clipboard, Autospell, Use Startup Wizard 

Layout page: Dot Grid settings, Lock guide lines, Lock frames, Snapping, PageHints, Display guide lines, Display frames, 
Picture/OLE metafile drawing
See Setting guides for page margins, rows, and columns, Using PageHints, and Importing images.

Rulers page: Origin, Units, Lock rulers, Display rulers
See Using the rulers.

Toolbars page: Toolbars checklist, Show Tooltips, New toolbar, Delete toolbar, Reset toolbars
See Customizing PagePlus toolbars.

Toolbars/Customize page: Categories list, Button icons. 
See Customizing PagePlus toolbars.

Filter Effects page: Screen and Print resolution, Filter effect smoothing
See Applying filter effects.

Auto-Correct page: AutoCorrect options and Replace/With lists
See Using AutoCorrect.

Dictionary page: Type a word, then click Add to add it to your dictionary list, or select a word in the list and click Delete to 
remove it.



Using shortcuts

Keypad shortcuts
n Press Pg Up to display the previous page.

n Press Pg Dn to display the next page.

Menu shortcuts
Every menu item has a keyboard shortcut (useful in the event your mouse stops working!). 

To display a menu:

n Press the Alt key followed by the underlined letter in the menu name. The menu appears. For example, pressing Alt+F 
displays the File menu.

To select an item from a displayed menu:

n Press the key underlined in the menu item. For example, pressing Alt+F+S is the same as choosing Save from the File menu.

Certain commonly used menu items have their own shortcuts. Most people are familiar with Ctrl+C for Copy, Ctrl+V for paste, 
and so on. Ctrl+S accomplishes a Save operation. Inspect the PagePlus menus to see listed shortcuts.

Function-key shortcuts
F1 Display the Help Contents screen

F7 Run the SpellChecker

Shift+F7 View the Thesaurus

Esc (Escape)-key shortcut
n Cancelling operations: To cancel a sizing, moving or creation operation in the middle of the operation, press the Esc key.

Shift-key shortcuts
n Moving: When moving an object in PagePlus, hold down the Shift key to constrain the movement to horizontal or vertical. To 

switch directions, release and then press the Shift key again.

n Creating and resizing: In general, hold down the Shift key to constrain the operation. When drawing a line, the line angle will 
be a multiple of 15 degrees. With a box, you'll get a square; with an oval, a circle, and so on. For pictures, however, the 
behavior is opposite: with no Shift key, the aspect ratio (proportion) of the original picture is preserved, while dragging with the 
Shift key down allows free resizing.

n Selecting objects: To add or subtract an object from a multiple selection, hold down the Shift key and click on the object. The 
other objects in the multiple selection remain selected.

n Selecting a text region: To highlight a region of text, click once for an insertion point, then Shift-click to mark the end of the 
selection region.

n QuickShapes: Normally, the selected tool reverts to the Pointer after you draw a line, box, or oval. To retain the QuickShape 
tool after drawing, hold down the Shift key when you first click the button. This is useful, for example, if you want to draw a 
series of QuickShapes.

n Tables: Press Shift+Tab to move to the cell in the previous column. Press Tab to move to the cell in the next column. (Or use 
the keyboard arrows.)

n Use the Thesaurus: Press Shift+F7.

Ctrl (Control)-key shortcuts
n Duplicating an object: To duplicate an object, select it, then press the Ctrl key. Drag the outline to a new location on the 

page. You can release the Ctrl key once you've started the drag. 

n Switching windows: To cycle through the open PagePlus windows, press Ctrl+Tab. (If there's an insertion point in a table, 
this enters a Tab character.)

n Editing a story in WritePlus: Select the text frame or artistic text object and press Ctrl+E.

n Run Find & Replace: Press Ctrl+F.

n Apply AutoFit in a selected frame: Press Ctrl+Alt+X.

n Importing a picture: Press Ctrl+G.

n Insert a hyperlink: Press Ctrl+K.

n Importing a text file: Select the text frame or artistic text object and press Ctrl+T.

n Switching to a particular zoom view: Press Ctrl and then a number (1 = 100%, 2 = 200%, etc.). You'll find the complete list 
on the View/Zoom submenu.



Alt-key shortcut
n Rotating: To switch temporarily to the Rotate tool, press the Alt key when the cursor is over an object handle.

Character shortcuts
To insert a special character in a standard font, use the keyboard shortcut listed below. For other symbol options, see Inserting a 
symbol.

KEYBOARD CHAR CHAR NAME

Ctrl+Alt+8 · Bullet

Ctrl+Alt+D † Dagger

Ctrl+Alt+G ‡ Double dagger

Ctrl+Alt+U — Em-rule or dash

Ctrl+Alt+C © Copyright symbol

Ctrl+Alt+R ® Registered symbol

Ctrl+Alt+T ™ Trademark symbol

Ctrl+Alt+Q ‘ Single open quote

Ctrl+Alt+W ’ Single close quote

Ctrl+Alt+2 " Double open quote

Ctrl+Alt+3 " Double close quote

Ctrl+Alt+4 € Euro symbol (European keyboards)

Ctrl+Alt+A ' ' Comma space (width equal to that of comma 
in the typeface; for lining up columns of 
numbers with commas as separators)

Ctrl+Alt+0 (zero) '    ' Digit space (width equal to that of ‘0' in the 
typeface; for lining up columns of numbers)

Ctrl+Alt+M '        ' Em space (equal to point size of typeface)

Ctrl+Alt+N '      ' En space (equal to half of point size)

Ctrl+Alt+I '' Inch mark

Ctrl+Alt+F ' Foot mark



Using PageHints

PageHints are like "sticky notes" that you can attach to your publication at any position on any page. They won’t appear on the 
printed page, but if you publish a publication as a PDF file, PageHints become pop-up annotations that readers can view. You 
can choose from various icons to identify different types of PageHint:

 

To create a PageHint:

1 Choose PageHint... from the Insert menu. You’ll see the  cursor.

2 Click where you initially want to place the PageHint.

A text box and an icon appear onscreen. The two objects together comprise the PageHint. The text box titlebar initially shows the 
publication’s Author as defined in File/Properties... (or "Default" if there’s no Author listed) as well as the date. If you wish, you 
can change the title text as described below.

3 Type your text into the box.

As long as the text box remains open, you can type into it and edit its text. You can leave the box open as you continue to work 
in PagePlus, and have more than one open at once.

To edit a PageHint:

n To access standard Cut, Copy, Paste, and Delete commands, right-click on the text.

n To move the text box, drag its titlebar. To move the icon, drag it.
Note: In order to be included in PDF documents, PageHint icons must be within the page area, not on the pasteboard.

n To close or reopen the text box, click the associated icon. The box reopens at its last location. You can also right-click the 
titlebar and choose Close PageHint.
Note: If you publish the publication as a PDF document, the PageHint will appear as either open or closed according to how it 
appeared at the time of export.

n To change the PageHint’s icon type or titlebar text, right-click the icon or titlebar and choose Properties.... 

n To realign the text box with its icon, right-click the icon and choose Reset PageHint Location.



Using LogoPlus to insert a layered graphic

LogoPlus is the logo/headline module built into PagePlus. Use it to create shapes, fancy text, and combinations to make 
powerful headlines and logos that add impact to your publications. 

n For an illustrated introduction to LogoPlus, take a moment now to view the QuickTour, Using LogoPlus.

n For tool tips and HintLine information, move the mouse over the various LogoPlus elements. (HintLine messages end with 
">>" if double-clicking that element brings up a submenu or dialog.) 

LogoPlus topic sequence
LogoPlus help continues with the following topics:

1 Running LogoPlus (see below)

2 Entering and editing text 

3 Previewing your design 

4 Creating and manipulating layers 

5 Modifying layers 

6 Editing shadows and lines 

7 Applying color 

8 Updating PagePlus 

Running LogoPlus

To launch LogoPlus:

1 Click the Insert button on the Tools toolbar and choose  Logo from the flyout submenu. 

2 Click again on your page, or drag out to indicate the desired size of the LogoPlus object.

LogoPlus launches with a dialog that lets you preview various logo templates. Choose Blank to start from scratch, or one of the 
sample designs to use as a starting point. If you wish, you can alter the dimensions now; but you can also do so later. 

Once you've chosen a template, click OK.

LogoPlus builds up a design using layers, starting with a single text layer. Using the intuitive interface, you can enter text, add 
new layers with various geometric shapes, modify the attributes of any layer, add special effects, and reorder the layers as you 
wish. When you're done creating, simply click to insert the design into PagePlus.

To insert a design into PagePlus:

n In LogoPlus, click the  Accept button.

The current design is inserted as an OLE object.



LogoPlus: Entering and editing text Main topic 

LogoPlus builds up a design using layers. When LogoPlus starts, it automatically creates a single text layer, ready for you to type 
into. 

To create a new text layer:

Click the  Add Text button.

To enter or edit text in a layer:
1 Click the layer's tab to select the layer.

2 Type into the Text Entry window. 

To undo text changes while the cursor is still in the Text Entry window:

n Click the window's  Cancel button.

To accept changes to the text layer:

n Click anywhere in the Preview window (just below the Text Entry window). 

OR

n Click the  Accept button.

 



LogoPlus: Previewing your design Main topic

The Preview window displays both individual layers and the composite (final) image.

The dotted, magenta rectangle shows the actual area which will be displayed when the object is put back into PagePlus. 
Anything outside this dotted box will get "clipped."

LogoPlus builds up a design using layers. Each item you create (using the buttons in the Create panel) occupies a single layer, 
and each layer has a corresponding tab to the left of the Preview window.

To work on a particular layer:

n Click the layer's tab.

To zoom in on a specific area:

n Drag out a region in the Preview window. 

OR
n Double-click the Preview window to display a dialog that lets you enter a specific value for the zoom view. 

OR
n To fit the design in the window, click the dialog's Auto button.

When you're working on a particular layer, other layers appear dimmed in the Preview window.

To de-select all layers and fully display the design:

n Click the Preview window's  Update tab.

To accept changes to the text layer:

n Click anywhere in the Preview window. The working text layer remains selected.



LogoPlus: Creating and manipulating layers Main topic

Click one of the Create panel's buttons to establish a new object on a new layer. At the same time, a new tab appears on the tab 
bar.

The original size of your design was specified by the area that you dragged out when starting LogoPlus. Click the  Size button 
to change the size of your design.

You can tell from the tab positions whether one layer is behind, or in front of, another. Each new layer is initially in front of the others.

To reorder layers:

n Drag individual layer tabs up or down. 

To delete a layer:

n Click the layer's tab to select the layer, then press the Delete key.

To cut, copy, and paste a layer using the Clipboard:

n Select the layer, then click the Cut, Copy, or Paste button. 



LogoPlus: Modifying layers Main topic

The Modify panel is the heart of LogoPlus. Its appearance depends on what kind of object occupies the selected layer. 
Size/position/rotation controls are available for every kind of object. Special attribute controls are also available for text, 
polygons and starbursts. To switch between the two sets of controls, click the button at the upper left of the Modify panel.

To learn what individual buttons do, check their ToolTips and HintLine messages. (HintLine messages end with ">>" if double-
clicking that button displays additional options.) So click, double-click, and have fun!

Size/position/rotation controls

 
The leftmost Rotation button turns rotation off. The rightmost button is a "custom" button that applies the value currently entered in 
the box next to it. All the other Rotation buttons apply preset values.

Text attribute controls

The Text Effect buttons mold the text into a wide variety of baseline, curve, and envelope styles. Click for a preset style; double-click 
any button to display the Edit Outline dialog, which lets you customize the style.

Starburst attribute controls

The rightmost button in each row is a "custom" button that applies the value currently entered in the box next to it. All the other 
buttons apply preset values.

Polygon attribute controls



The rightmost button applies the value currently entered in the box; all others apply preset values.



LogoPlus: Editing shadows and lines Main topic

The Edit panel lets you set the line thickness and shadow options for the selected item. 

The leftmost button in each row turns the effect off.

The rightmost Line Thickness button applies the value currently entered in the box; all others apply preset values.

Double-click the Shadow buttons for Edit dialogs that let you customize the effect. 



LogoPlus: Applying color Main topic

The three Color panels let you control the  line, 

 fill, and 

 shadow color of any object.
Double-click any color to display the Edit Color dialog, which lets you set patterns, shades, and custom colors.



LogoPlus: Updating PagePlus Main topic

To exit LogoPlus and insert the current design into PagePlus:

n Click the  Accept button. This closes LogoPlus and accepts changes.

If you close the LogoPlus window using Alt+F4 or the window's Close button, you'll be prompted to update PagePlus.

To exit LogoPlus without updating PagePlus:

n Click the  Cancel button. This closes LogoPlus and abandons changes.



Using TablePlus to insert a table

TablePlus is a table and spreadsheet editor built into PagePlus. Use it to design attractive spreadsheets, charts, and tables and 
insert them into your publication. (To present ordinary static text in easily customizable row-and-column format, we suggest you 
use the Table tool. Note that TablePlus objects are incompatible with text-based tables.) 

n For an illustrated introduction to TablePlus, take a moment now to view the QuickTour, Using TablePlus.

n For tool tips and HintLine information, move the mouse over the various TablePlus elements. (HintLine messages end with 
">>" if double-clicking that element brings up a submenu or dialog.)

TablePlus topic sequence
TablePlus help continues with the following topics:

1 Running TablePlus (see below)

2 Creating tables 

3 Entering text 

4 Previewing your table 

5 Changing the zoom view 

6 Inserting formulas 

7 Using QuickFill and QuickClear 

8 Rearranging the table 

9 Formatting text 

10 Formatting numbers 

11 Using QuickFormats 

12 Setting grid lines 

13 Joining cells 

14 Changing table size 

15 Applying color 

16 Updating PagePlus

Running TablePlus

To launch TablePlus:

1 Click the Insert button on the Tools toolbar and choose  Table from the flyout submenu. 

2 Click again on your page, or drag out to indicate the desired size of the TablePlus object.

TablePlus launches with the Create New Table dialog, which lets you preview various built-in table templates. You can set the 
number of columns and rows, and preview the table design. 

3 Once you've chosen a template, click OK.

TablePlus displays the table in its Preview window. You can enter text and numbers, rearrange rows and columns, reformat the 
entire table and/or its contents, enter formulas, and control how the table appears. 

To insert a table into PagePlus:

n In TablePlus, click the  Accept button.

The current table is inserted as an OLE object.

To edit an existing table:

n Double-click the table to launch TablePlus.

TablePlus hints and tips
n To remove all the lines in a table: Select the whole table, double-click the Outer Edges button, and choose the first button in 

the submenu. Then click the first Line Style button (Hide Lines).

n To make the background transparent: Select the whole table, double-click any of the Background Color buttons, and set the 
color to [Clear].

n To add a table border: Make the table bigger then you need by 2 rows and 2 columns, and use the extra space for the border.

n To make a headline span several columns: Join cells together.



TablePlus: Creating tables Main topic 

To launch TablePlus and create a new table:

1 Click the  Insert Table button on the Tools toolbar. 

2 Click again on your page, or drag out to indicate the desired size of the TablePlus object.
TablePlus launches with the Create New Table dialog (see below), which lets you preview various table templates.

3 Set options for your new table:
Table Format: A list of the QuickFormat styles. These let you create tables effortlessly, letting TablePlus do most of the layout 
work. (For a plain table, click OK without choosing any format—or choose the Default format.)
Sample: An example of how tables look with the current format. 
Table Size: Lets you set the number of columns and rows in your new table.

To edit an existing table:

n Double-click the table to launch TablePlus.



TablePlus: Entering text Main topic

To start entering text:

n Click on a cell to select it. 

OR
n Click in the Text Entry window above the worksheet and type your text.

Anything you type will be entered immediately into the currently selected cell as new text. To undo text changes while the cursor 

is still in the Text Entry window, click the  Cancel button or press the Escape key.

To edit existing text:
n Click in the Text Entry window.

OR
n Press F2.

Normally, TablePlus wraps entered text to fit in the cell. If a word is too wide to fit in the cell, TablePlus displays the text as red 
asterisks (*). To display the text normally, make the cell wider (see "Resizing" in the next topic).

Types of text
TablePlus treats text in three ways: as numbers, formulas and ordinary text.

n Numbers: TablePlus can format numbers in special ways. See the topic Formatting numbers . 

n Formulas: TablePlus will treat any text entry beginning with a hash (#) or equals symbol (=) as a formula. Formulas can be 
formatted the same as numbers. See also the topic Inserting formulas . 

n Ordinary text: Any other text entry. To force a text entry to be treated by TablePlus as ordinary text, start the entry with a 
single quote (') character. (The quote will not be displayed.)

You can use all the normal Windows editing keys, including cut and paste from the clipboard (the best way to import a long text 
string). To enter a return (for a new line), press Ctrl + Enter. See also "Importing from other applications" (below).

Note: When working in the Text Entry box, use Ctrl+X to Cut, Ctrl+C to Copy, and Ctrl+V to Paste. These Clipboard commands 
only affect text, and only in the current cell. The Cut, Copy and Paste buttons in TablePlus are for operations involving cells and 
ranges of cells.

Special characters
To insert a special character in a standard font, use the keyboard shortcuts shown in the subtopic Character shortcuts. 

QuickFill and QuickClear
QuickFill is a feature that lets you quickly enter a standard sequence of numbers or entries, for example the months of the year, 
the days of the week, or any arithmetic progression. You can also use QuickFill to replicate one cell's contents over a range of 
cells, or use QuickClear to clear a range of cells. For details, see the topic Using QuickFill and QuickClear.

Importing from other applications
You can import and export tab-delimited text or Metafiles from and to other applications just by copying and pasting. 

n To paste into multiple cells in TablePlus, use the  Paste button. 

n To paste into another application, use Edit/Paste for the text format or Edit/Paste Special... for the picture format. 



TablePlus: Previewing your table Main topic

The Preview window shows you what your table will look like. It consists of two parts: the worksheet, a collection of cells; and 
cell labels.

This is cell A1 (Column A, Row 1) with its labels:

To select a cell:
n Click on the cell. 

Clicking in another cell enters the text into the currently selected cell, and moves you to the new selected cell.

To select multiple cells:

n Drag out a range of cells or hold down the Shift key and click.. 

To select a whole row or column:

n Click on its row label (at left) or column label (at top). 

To select the whole table:

n Click on the top-left button to the left of the A label.

To move between cells:

n Press Tab to move to the cell in the next column. Press Shift+Tab to move to the cell in the previous column. 

OR
n Use the keyboard arrow keys.

If you have a range of cells selected, then the movement is confined within that range.

Resizing
To resize columns, use the column labels at the top of the worksheet. For example, to change the width of the first column, 
position the mouse over the line separating the A and B column labels. The mouse cursor will change into a double-headed 
arrow. Drag to make the column wider or narrower. The current width appears in the box to the left of the X-button. Any text will 
be rewrapped to fit the new cell widths. If necessary, the cells will get taller or shorter automatically. To adjust several columns to 
the same size, select them all and resize any one of them.

You can adjust the depth of cells in the same way, using the row numbers. However, this is not needed so often. TablePlus works 
out the cell depth automatically by looking at the size of the text inside it, and does the work for you.



TablePlus: Changing the zoom view Main topic

Being able to change zoom is especially useful if you have a large table. You can alternate between a zoomed-out view which 
shows the whole table and a zoomed-in one for fine, close-up work.

To change the zoom view, click one of the Zoom buttons:

Zoom Out
Click to view more of the page in the window.

Zoom In 
Click to view the page area more closely. 

Actual Size
Click to display the page at a zoom percentage of 100%.

Auto Zoom
Click to fit the table in the window.

Custom Zoom
Click to view at 50%. Double-click to display the Edit Zoom dialog, where 
you can select a zoom percentage from the list or type in a custom value.



TablePlus: Inserting formulas Main topic

A cell can display the result of a formula combining values of other cells with arithmetic operators and functions. Formulas are 
recalculated whenever values in the table change, so they're always up to date. 

To display a cell's formula for editing in the Text Entry window:

n Click to select the cell containing the formula.

To enter a formula:

n Click the  Equals button.

OR
n Start the entry in the text edit window with an equals sign (=). 

Either action makes TablePlus switch to formula mode. A calculator appears for entering formulas.

QuickSum
To quickly sum cells in a row or column:

n Click the  QuickSum button.

QuickSum works by inserting formulas into cells, so the totals are recalculated when any of the cells change. 

If you have a range of cells selected, TablePlus applies the following rules when you click on the Sum button:

n It looks for columns which contain numbers but not in their last cell. If it finds any, it fills the last cell with the sum of the 
column.

n If there are no blank cells at the bottom of the range, it looks at the right edge cells of the range. If there are rows which 
contain numbers and have a blank cell at the right, it sums the row and places the total in the blank cell.

n If there are no numbers in the range, or no blank cells at its bottom or right edge, it displays an error message.

Blank cells are taken to have the value 0.

If you have only a single cell selected, TablePlus applies these rules when "guessing" a range of cells to be summed:

1 It looks above the selected cell for numbers, and selects those cells automatically.

2 If there are no numbers above the selected cell, then TablePlus looks left of the select cell for numbers, and selects those cells 
automatically.

3 After guessing a range of cells to be summed, TablePlus switches to formula mode and waits for you to click the OK button. If 
the range of cells selected is wrong, then drag out a new range of cells to be summed (see "Values" below).

Formulas
Formulas can be made up from any of the following:

n Operators

n Percentages

n Values

n Functions

Operators

TablePlus allows use of the +, -, * and / arithmetic operators. The usual order of evaluation is used, with multiplication and 
division being evaluated before addition and subtraction. For example:

4 + 3 * 2 = 10 not 14

Operators with equal order of evaluation are performed left to right. To override the default order, enclose portions of the formula 
in parentheses:

(4 + 3) * 2 = 14

Percentages

TablePlus understands percentages. TablePlus treats percentage calculations differently depending on the operator (+, -, * or /) 
used with percentage symbol (%). For example:

2000 + 10% = 2200 Adds 10% to 2000.

2000 - 10% = 1800 Subtracts 10% from 2000.

2000 * 10% = 200 Returns 10% of 2000.



200 / 2000% = 10 Returns the percentage 200 is of 2000.

Values

Values in formulas can be the following:

n Numbers e.g. 1, 13, -89.5.

n Single cell references, e.g. A3, B6, C12. (See "Cell references" below.)

n Ranges of cells. These are specified by the starting cell followed by a colon, then the end cell. For example: A1:B5 specifies 
every cell between A1 and B5 inclusive.

The simplest way to enter cell references or ranges of cells is to click on a cell or drag out a range. Clicking on the column or row 
label selects the whole column or row respectively.

Functions

TablePlus has some built-in functions:

n SUM - returns the sum of its arguments.

n AVERAGE - returns the arithmetic mean of its arguments.

n COUNT - counts how many numeric values are in its arguments.

n SQRT - returns the square root of its argument.

You can use these on ranges of cells, so that =AVERAGE( A1:B2 ) returns the average of the four cells in top-left corner of the 
table.

Cell references

TablePlus formulas can refer to cells in two ways: relative reference or absolute reference. 

Relative cell references are stored 'relative' to the cell containing the formula, not by the cell's actual position. By default, 
TablePlus inserts cell references in a formula as relative references.

For example, if you entered the formula =B1 + A1 in cell C1, then TablePlus internally stores this as "Sum the values in the two 
cells above this one." If you then copy the formula to C2, TablePlus will convert the formula to =B2 + A2.

Absolute references are useful if you wish to store a value in a cell that all formulas refer to. TablePlus formulas will always refer 
to absolutely referenced cells, rows and columns no matter where you move or copy the formula.

To make a row or column reference absolute:

n Prefix the reference with a dollar symbol ($). 

For example, you could store number of employees in cell A1, and then refer to it in a formula by $A$1. If you then copy this 
formula TablePlus will always refer to cell A1 in every formula.

Since TablePlus stores relative cell references by default, it is dangerous to move a cell containing a formula without also moving 
all the cells that it references. If you do not, then TablePlus will look for the values 'relative' to the cell's new position! You could 
prevent this from happening by declaring all the cell references in the formula as absolute—bearing in mind that you then would 
not be able to copy the formula.

Formula errors
When TablePlus can not understand a given formula, it returns an error in the cell containing the formula.

Width This sets how wide each character is, as a proportion of the text 
size. The default setting is 100%, which gives normal, squarish 
characters.

#DIV/0! Divide by Zero Error. Your calculation involves a divide by zero, 
e.g. A1/0, or A1/B1 if B1 has no number.

#VALUE! Value Error. You have used a value which TablePlus was not 
expecting, e.g. providing a range of cells when a single cell is 
expected or vice-versa, or =A1:A2 instead of =SUM(A1:A2).

#CIRC! Circular Reference Error. This cell refers to another cell which 
refers back to this one, in a loop.

#SYNTAX! Syntax Error. You have entered a formula that TablePlus cannot 
interpret, e.g. =/-.

#NAME! Name Error. You have used a function name that TablePlus does 
not know, e.g. =FRED(1).

#REF! Reference Error. You have referenced a cell that does not exist. 



Usually a result of dragging or copying cells with relative 
references.

#N/A Not Available Error. TablePlus does not have an available 
number. Usually because the formula refers to cell which 
contains an error.

Note: You can type in error codes explicitly if you want to, e.g. type #N/A if you're preparing a table and do not know all the 
values yet.



TablePlus: Using QuickFill and QuickClear Main topic

QuickFill is a feature that lets you quickly enter a standard sequence of numbers or entries, for example the months of the year, 
the days of the week, or any arithmetic progression. You can also use QuickFill to replicate one cell's contents over a range of 
cells, or use QuickClear to clear a range of cells.

The sequences that TablePlus knows about are:

n January, February, March, ...

n JANUARY, FEBRUARY, MARCH, ...

n january, february, march, ...

n Jan, Feb, Mar, ...

n JAN, FEB, MAR, ...

n jan, feb, mar, ...

n Monday, Tuesday, Wednesday, ...

n MONDAY, TUESDAY, WEDNESDAY, ...

n monday, tuesday, wednesday, ...

n Mon, Tue, Wed, ...

n MON, TUE, WED, ...

n mon, tue, wed, ...

n a, b, c, ...

n A, B, C, ...

n Any arithmetic progression, that is, any series of numbers with a common difference.

To QuickFill a sequence of entries:

1 Type the first entry of the sequence into the starting cell.

2 Move the cursor to the selected cell's QuickFill handle.

3 Drag out the range of cells to be quickfilled.

If there are not enough entries in the QuickFill sequence, then TablePlus wraps back to the beginning value in the sequence.

For numerical sequences, if the starting selection contains two or more cells, QuickFill uses the difference between them as the 
common difference. For example, if the first two cells contain the numbers 10 and 20, then the 'quickfilled' sequence would be: 
10, 20, 30, ... If only a single number is specified, then the common difference between the numbers will be 1.

Similarly, for non-numerical sequences, you can specify a step between any entries, for example, enter "January" in the first 
cell, "March" in the second. QuickFill will place every other month in the sequence: "January, March, May, July, ..."

You can type phrases including known sequences, and QuickFill will fill the sequence, along with the other words. For example, 
type "Week 1" and QuickFill would give you the sequence "Week 1, Week 2, Week 3, ..." or "Jan Sales" would give: "Jan Sales, 
Feb Sales, Mar Sales, ..."

To replicate a cell's contents over a range of cells:

1 Click to select the cell whose contents you want to replicate.

2 Drag out the cell's QuickFill handle over the range you want to fill.

To QuickClear a range of cells:

1 Select the range to be cleared.

2 Drag the QuickFill handle upwards until no cells are specified.

Copying cell formatting
By default, QuickFill only affects the text, not the cell's formatting (font, color etc). To include the text formatting, hold down the 
Shift key while dragging.



TablePlus: Rearranging the table Main topic

You can use the Cut, Copy, and Paste buttons to rearrange the table, perhaps adding new rows or columns, without having to 
redo everything from scratch. You can cut and paste whole ranges of cells, complete with their formatting, or use drag-and-drop 
editing to rearrange content.

To edit the table using Cut/Copy/Paste:

1 Select the part of the table that you want to cut or copy to the Clipboard. To select a row or column, click its label.

2 Click either the Cut or Copy button. 
Note: To copy the cell formatting as well as the cell contents, hold down the Shift key when clicking Cut or Copy.

3 Click in the table where you want to place the information, and click the Paste button. 

When pasting a row or column, if you select a cell, TablePlus inserts the row or column before the selected cell. If you select the 
whole row or column via its label, TablePlus will overwrite the selected range of cells.

Drag-and-drop editing
TablePlus supports drag-and-drop editing of cell contents.

To move or copy the contents of one or more cells:

n Click to select the cell(s).

n Move the mouse cursor to the edge of the cell(s). The mouse cursor will change to an arrow.

n Click and drag to the new cell and release the mouse button to move the selected contents into the new cell.

n To copy the contents, hold down the Ctrl key while dragging.

By default, TablePlus only copies cell contents, not the formatting associated with the cell(s).

n To move or copy cell formatting as well as contents, hold down the Shift key while dragging.



TablePlus: Formatting text Main topic

Using the standard text formatting buttons, you can change the text font and size, apply styles, set alignment, or rotate text by 
90° or a user-defined angle. 

To rotate text by a user-defined angle:

n Double-click the  Custom Angle button. The Rotate Text dialog appears.

For additional text formatting options:

n Double-click any of the alignment buttons.  The Edit Text Format dialog appears.

Additional options in the Edit Text Format dialog include:

Width Sets how wide each character is, as a proportion of the 
text size. The default setting is 100%, which gives 
normal, squarish characters.

Word space Sets how wide the spaces between words are, as a 
percentage of the text size. The default setting is 
100%. This field is ignored if the alignment is set to 
justified. 

Letter space Used to add/subtract space to/from each character. The 
default is zero. Negative values make the text look 
bunched up tight; positive values make it looser. The 
units are percentages of the text size.

Leading Sets the vertical spacing between lines, as a 
percentage of the text size. The default value is 120%.

Border X, Border Y Control the distance between the edges of the cells and 
the text inside the cell. 

Alignment Controls how the text is placed vertically in the cells: 
either at the top, in the center, or on the bottom of the 
cell.



TablePlus: Formatting numbers Main topic

Using the standard number formatting buttons, you can vary how numbers are displayed. Number formats let you add commas 
and currency signs to numbers, express numbers as percents, control how many decimal places are displayed, etc. Number 
formats do not alter numbers internally; only alter the way numbers are displayed.

 
For additional number formatting options:
n Double-click any of the number formatting buttons. The Edit Number Format dialog appears.

Additional options in the Edit Number Format dialog include:

Format Codes The currently available formats. Some codes are supplied with 
TablePlus, others are taken from the 'International' settings of 
Windows, and you can define custom codes of your own (see 
below).

Delete Removes custom codes from the list. Disabled when 
TablePlus codes are selected.

Code The currently selected code. You can edit existing codes here 
or type in a new custom code.

Samples Shows samples of various numbers in the selected format.

Custom Formats
You can create your own number formats by combining TablePlus symbols. Here is what the various symbols mean:

# Display a digit if the number has one. If there are more digits in the 
number than #'s specified, then the extra digits left of the decimal 
place separator will be displayed.

0 Always displays a digit. If a number does not have a digit in this 
position then a zero (0) is displayed. If there are more digits in the 
number than 0's specified, then the extra digits left of the decimal 
place separator will be displayed.

- Display a negative symbol if the number is negative. No symbol is 
displayed if the number is positive.

+ Display a positive symbol if the number is positive, or a negative 
symbol if the number is negative.

(code) Display the formatted number in parentheses if the number is 
negative.

[color] Display a negative number in the specified color, e.g. RED.

$ Display a currency symbol with the number. The currency symbol can 
be placed before or after the number.

. Decimal separator

% Display fractions as percentages, e.g. 0.4 as 40%

/ Display decimal places as fractions, e.g. 0.4 as 2/5.

0 Display no decimal places, e.g. 0.4 as 0

0.0 Display one decimal place, e.g. 0.4 as 0.4

0.00 Displays two decimal places, e.g. 0.4 as 0.40

0. Automatically calculate the number of decimal places to be displayed, 
e.g. 0.4 as 0.4

e Display number as an exponential (or scientific format), e.g. 0.4 as 
4e-01.

TablePlus is not strict about the order in which the format codes are specified, and tries to interpret whatever you type. For 
example, if you want a negative number to be displayed in a color, you can specify this at the beginning or end of the code—
TablePlus still understands what you mean.

As you can see, there are many options to explore. Try looking at the example formats, and experiment with your own. One way 
to do this is to create your own series of numbers of different lengths and with varying decimal places, then apply the formats to 
these.

Entering values in different units



In TablePlus, some of the controls can take values in more than one unit. The default units are taken from your Windows 
International settings. If you have specified Metric, the values will be in centimetres; if English, they will be in inches.

To enter values in other units, enter the value required followed by the abbreviation for the unit:

"i" or "in" inches

cm" centimetres

"mm" millimetres

"p" points

"pp" picas

"d" didots

"cd" ciceros

For example, when using the text size control to set the point size, enter "1in" in the control to set the point size to 72 points.

If you have entered a value in a control that cannot be converted to a equivalent unit, TablePlus ignores the unit abbreviation and 
takes that value in the control's default units. For example, if you enter "30p" in a control that is expecting degree units, then 
TablePlus will ignore the "p" and treat the value as 30 degrees.



TablePlus: Using QuickFormats Main topic

QuickFormats apply a style to your table, letting you easily change the appearance of entire tables. Click the  
QuickFormat Table button to bring up a dialog with a list of known formats, and a small sample table so that you can see what 
they do.

In the dialog, click the Options button to reveal more buttons that control which parts of your table the style will affect. Check or 
uncheck options until the preview looks the way you want it.

Lines Line style and weight, line position, and the color of lines.

Alignment Text alignment - left, right, centered, or justified.

Font Fonts, with bold, italic, underline, and stikethrough styles, and 
text size.

Number Number formats, number of decimal places, and so on.

Width/Height Formats the table with cells the width and height as in the 
sample table.

Color Apply color to the cells and text; does not affect line color.



TablePlus: Setting grid lines Main topic

Vertical and horizontal lines help separate the columns and rows visually. Lines in TablePlus run along the edges of cells. You 
can apply lines to groups of cells with a single action, for example to draw a box around the whole table. You can control the line 
styles, widths, and colors.

Before you apply a line, select both the cells you want to affect and which edges of those cells. 

 
To set grid lines:

1 Select the cells you want to change.

2 Click one of the Edge buttons to select which edges you want to change: left, top, right, or bottom—or double-click the  
Outer Edges button for a submenu that lets you chose from other combinations.

3 Click one of the Line Style buttons to apply a grid line style: no line, dotted line, hair line, double line, or thick line.

To apply a grid line with a specific thickness:

1 Select the cells and edges to change.

2 Double-click the Thick Line button. 

3 In the dialog, specify the line weight in points.

To delete all the grid lines in a table:

1 Drag to select the whole table.

2 Double-click the Outer Edges button and choose the first button in the submenu to select all edges.

3 Click the first Line Style button (Hide Lines).

You can also change the color of grid lines. See the topic Applying color. 



TablePlus: Joining cells Main topic

Sometimes—as with headlines, for example—you need to spread text across several cells. To do so, join the cells.

To join cells:

1 Select the cells you want to merge.

2 Click the  Join Cells button.

The text in the cell in the top-left corner of the selection will then cover all the cells. If the other cells have text of their own, it's 
hidden, and you are prevented from entering new text in them.

To unjoin cells:

1 Select the joined cells.

2 Click the  Separate Joined Cells button.

TablePlus sometimes forces cells to separate, to ensure all cell areas are rectangular.

Note: TablePlus cannot split a cell in half directly, but you can achieve a similar effect by using two columns and joining all pairs 
of cells except the ones you want split.



TablePlus: Changing table size Main topic

You can add or remove rows and columns, or change the total table width and height.

To change table size:

1 Click the  Resize table... button. A dialog appears showing the average cell width and the total width of the table. 

2 Edit the width values, if desired.

For example, you may want a table which exactly fits a given page size. If you change the values for an existing table, all the 
columns will be scaled in proportion. The text size won't change, so the text will rewrap, possibly changing the total depth of the 
table.

You can also add or remove individual rows and columns using Clipboard (cut/copy/paste) operations. For details, see the topic 
Rearranging the table. 

You can change the width of individual rows and columns using the mouse. See the topic Previewing your table. 



TablePlus: Applying color Main topic

Using the Color buttons, you can change the color of text, cell backgrounds, or grid lines.

To apply color:

n Select the part of the table you wish to change. Use the Edge buttons to select grid lines (see Setting grid lines ).

n Locate the row of Color buttons for the part you clicked:

 buttons for text 

 buttons for cell backgrounds

 buttons for grid lines
The five Color buttons in each row show the last five effects you applied.

n Click one of the Color buttons to apply the color to the selected parts. 

OR
n Double-click any Color button to display the Edit Color dialog to apply a custom color effect.

Custom color effects
The Edit Color dialog includes a variety of custom effects:

Color Selects a color from the palette. Double-clicking on a color 
automatically selects Edit for that color. The color [clear] is 
transparent and allows the background to be seen.

New Click to define a new color using the Custom Color Selector.

Edit Edits the selected color via a standard Windows color dialog.

Delete Deletes the selected color.

Tint Sets the tint (shade). The default is 100%, which produces the full 
color from the palette. The lower the tint, the less intense the color. 

Pattern Fills the button with hatched lines or some other effect (not available 
for Text color).

Sample Shows the current color.



TablePlus: Updating PagePlus Main topic

To load the current table into PagePlus:

n Click the  Accept button. This closes TablePlus and accepts changes.

If you close the TablePlus window using Alt+F4 or the window's Close button, you'll be prompted to update PagePlus.

In addition to updating PagePlus (the client program), Accept puts a copy of your document onto the Windows clipboard, as a 
metafile and as an OLE object. Most DTP programs will allow you to insert the object using a menu entry typically labeled 
Edit/Paste.

To exit TablePlus without updating PagePlus:

n Click the  Cancel button. This closes TablePlus and abandons changes.
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