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File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Save Text Clip Saves selected formatted text for later use.
Print Prints a document.
Print Preview Displays the document on the screen as it would appear printed.
Print Setup Selects a printer and printer connection.
Send Mail Sends Final Writer formatted document via e-mail.
Exit Exits Final Writer.



Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.
Paste Special Pastes from the clipboard with options.
Clear Deletes the selected text or object.
Select All Selects all text or objects in the document depending upon the tool in 

use.
Insert New Object Inserts a new embedded object.
Links List and edit links to embedded documents.
Object Conversion and activate options for object.



View menu commands

The View menu offers the following commands:

Zoom Accesses magnification options.
Left Master 
Page 

Displays Left Master page of document.

Right Master 
Page 

Displays Right Master page of document.

Body Displays the working pages of the document.
Go To Page Display a given page.
Options Set the visual properties of your work area.



Layout Menu

The Layout menu offers the following commands, which enable you to set the visual characteristics of 
your document.

Font Opens the Font dialog      for setting font characteristics.
Paragraph Opens the Paragraph dialog for setting paragraph characteristics.
Section Opens the Section dialog for setting the characteristics of the current 

working section.
Page Opens the Page Setup dialog for setting the size and orientation of the 

page.
Styles Opens the Paragraph Style dialog    for the definition of paragraph styles.
Bullet Places a bullet at the beginning of each selected paragraph.
Hanging Indent Applies the hanging indent style to each selected paragraph.
Indent Right Moves the selected paragraphs one tab stop to the right.
Indent Left Moves the selected paragraphs one tab stop to the left.
Page Break Begins a new page at the current insertion point.
Insert Item Displays list of insertable text fields in the Insert Item dialog .
Update Item Displays list of dynamic text fields for updating in the Update Item dialog .



Section Menu Commands

The Section menu offers the following commands, which enable to you to create and alter document 
sections.

Create Displays a list of section types for creation or updating.
Go To Selects a section in the document for editing.
Delete Deletes a section in the document and its contents.
Edit Bibliography Displays dialog for the addition and editing of Bibliography entries.
Insert Endnote Places an endnote mark at the current position in the document and 

prompts for entry.
Edit Endnotes Displays the endnotes in the document for editing.
Add To Index Adds word or words to the index.
Edit Index Displays the index contents for editing.



Graphics menu commands

The Graphics menu offers the following commands, which enable you work with the graphics in your 
document.

Insert Displays a list of graphic object types for insertion in your document.
Properties Sets the default properties for all graphic types and the specific 

properties for selected graphics.
Bring To Front Places the selected graphics in front of other graphics.
Send To Back Places the selected graphics behind other graphics.
Group Combines the selected graphic objects into one object.
UnGroup Extracts the objects comprising a group.
Lock Freezes graphic in current position.
UnLock Removes Lock from graphic object.
Rotate 90 Rotates the graphics 90 degrees.
Flip Horizontal Flips the graphic along the horizontal.
Flip Vertical Flips the graphic along the vertical.



Tools menu commands

The Tools menu offers the following commands which enable you to perfect the contents of your 
document.

Find Search for words in the document.
Replace Find and replace words and phrases in the document.
Speller Check the spelling of words.
Thesaurus Suggests alternate words to use.
Word Counts Displays statistical information on the document contents.
Sort Arrange selected paragraphs in ascending or descending order.
Mail Merge Print form letters.
Easy Header/Footer Automatically creates header and footer areas in the document.
Easy Page Number Automatically creates formatted page number entries in the document.
Customize Sets formatting and other options for the document.



Windows menu commands
The Window menu offers the following commands, which enable you to arrange multiple views of multiple 
documents in the application window:

Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 2, ... Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this application: 

Index Offers you an index to topics on which you can get help.
Using Help Provides general instructions on using help.
About Displays the version number of this application.



New (File Menu)

Use this command to create a new document in Final Writer.

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open (File Menu)

Use this command to open an existing document in a new window.    You can open multiple documents at 
once.    Use the Window menu to switch among the multiple open documents.    See Window 1, 2, ... 
command.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:

File Name
Type or select the filename you want to open.    This box lists files with the extension you select in the 
List Files of Type box. 

Files of Type
Select the type of file you want to open:

Look in
Select the directory in which Final Writer stores the file that you want to open.



Close (File Menu)

Use this command to close all windows containing the active document.    Final Writer suggests that you 
save changes to your document before you close it.    If you close a document without saving, you lose all 
changes made since the last time you saved it.    Before closing an untitled document, Final Writer 
displays the Save As dialog box and suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown below:



Save (File Menu)

Use this command to save the active document to its current name and directory.    When you save a 
document for the first time, Final Writer displays the Save As dialog box so you can name your document. 
If you want to change the name and directory of an existing document before you save it, choose the 
Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As (File Menu)

Use this command to save and name the active document.    Final Writer displays the Save As dialog box 
so you can name your document. 

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:

File Name
Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.    Final Writer adds the extension you specify in the 
Save File As Type box.

Drives
Select the drive in which you want to store the document.

Save In
Select the directory in which you want to store the document.

Save as type
Select the format your document will be saved in.    Choose FWRITE to save the document with full 
formatting information.    Choose Text Files to save the document text to an ASCII file.



1, 2, 3, 4 (File Menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four documents you 
closed.    Choose the number that corresponds with the document you want to open.



Exit (File Menu)

Use this command to end your Final Writer session.    You can also use the Close command on the 
application Control menu.    Final Writer prompts you to save documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Undo/Can't Undo (Edit Menu)

Use this command to reverse the last editing action, if possible.      The name of the command changes, 
depending on what the last action was.    The Undo command changes to Can't Undo on the menu if you 
cannot reverse your last action or Redo to reverse the last Undo.

Shortcuts

Toolbar:
Keys: CTRL+Z or

ALT-BACKSPACE



Cut (Edit Menu)

Use this command to remove the currently selected text or graphic from the document and put it on the 
clipboard.    This command is unavailable if there is no text or graphic currently selected.

Cutting text or graphic to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy (Edit Menu)

Use this command to copy selected text or graphic onto the clipboard.    This command is unavailable if 
there is no text or graphic currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste (Edit Menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This command is 
unavailable if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Cascade (Window Menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile (Window Menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal (Window Menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped fashion.



Tile Vertical (Window Menu)

Use this command to arrange multiple opened windows side by side.



Arrange Icons (Window Menu)

Use this command to arrange the icons for minimized windows at the bottom of the main window.    If 
there is an open document window at the bottom of the main window, then some or all of the icons may 
not be visible because they will be underneath this document window.



1, 2, ... (Window Menu)

Final Writer displays a list of currently open document windows at the bottom of the Window menu.    A 
check mark appears in front of the document name of the active window.    Choose a document from this 
list to make its window active. 



Index (Help Menu)

Use this command to display the opening screen of Help.    From the opening screen, you can jump to 
step-by-step instructions for using Final Writer and various types of reference information. 

Once you open Help, you can click the Contents button whenever you want to return to the opening 
screen.



Using Help (Help Menu)

Use this command for instructions about using Help.



About (Help Menu)

Use this command to display the copyright notice and version number of your copy of Final Writer.



Title Bar

The title bar is located along the top of a window.    It contains the name of the application and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging their title 
bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside the scroll bars 
indicate your vertical and horizontal location in the document.    You can use the mouse to scroll to other 
parts of the document.

<< Describe the actions of the various parts of the scrollbar, according to how they behave in your 
application. >>



Size (System Menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow keys.

After the pointer changes to the four-headed arrow:

1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the 
border you want to move. 

2. Press a DIRECTION key to move the border.

3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move (application Control Menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with 
the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize (application Control Menu)

Use this command to reduce the Final Writer window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize (System Menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window (document Control Menu)

Use this command to switch to the next open document window.    Final Writer determines which window 
is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window (document Control Menu)

Use this command to switch to the previous open document window.    Final Writer determines which 
window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the document 
Control menu closes only one window at a time.    You can close all windows at once with the Close 
command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore (Control Menu)

Use this command to return the active window to its size and position before you chose the Maximize or 
Minimize command.



Switch to (application Control Menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to or close an 
application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following 
options:

Task List
Select the application you want to switch to or close.

Switch To
Makes the selected application active.

End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar.    This option does not 
affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not affect 
applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Left Master (View Menu)

Use this command to display and work on the Left Master page of your document.    You can set up 
different master pages for each section in your document.    The information on the master page appears 
on each body page in its section.    Use the master page for headers and footers, page numbers, 
watermarks, etc.

Note:    The Left Master Page menu selection is only available if the Left & Right is selected from the Page 
setup dialog.



Right Master Page (View Menu)

Use this command to display and work on the Right Master Page of your document.    You can set up 
different master pages for each section in your document.    The information on the master page appears 
on each body page in its section.    Use the master page for headers and footers, page numbers, 
watermarks, etc.



Body (View Menu)

Use this command to display and work on the Body text of    your document.



Go To Page (View Menu)

Use this command to quickly move to a specific page in the current section of your document.
When you select this command,    enter the desired page in the dialog which appears, then click OK to 
move to that page.

Shortcut 
Keys: CTRL + G



Options (View Menu)

Use this command to set the visual properties of your work area.    Selecting this command displays the 
View Options dialog.



Font (Layout Menu)

Use this command to display the Type Specs dialog box where you can set the characteristics of the font 
in use.



Paragraph (Layout Menu)

Use this command to open the Paragraph dialog for setting the layout of the current paragraph.



Section (Layout Menu)

Use this command to display the Section dialog where you can set the characteristics of the section you 
are currently working with. 



Page (Layout    Menu)

Use this command to open the Page Setup dialog to set the characteristics of the pages in your 
document.



Styles (Layout Menu)

Use this command to open the Styles dialog to define the paragraph styles in your dialog.



Bullet (Layout Menu)

Use this command to add bullets to your text.

If you have selected a range of text, the bulletted text style will be applied to all paragraphs in the 
selected range when you select this command.

If a range of text is not selected, the bulletted text style will be applied only to the paragraph containing 
the insertion point.



Hanging Indent (Layout Menu)

Use this command to apply the hanging indent style to paragraphs in your document.

If a range of text is selected, each paragraph in the range will receive the hanging indent style.

If a range of text is not selected, only the paragraph containing the insertion point will receive the hanging 
indent style.

Shortcut
Key: CTRL+T



Indent Right (Layout Menu)

Use this command to indent paragraphs one tab stop to the right.

If a range of text is selected, each paragraph in the selected range will be indented one tab stop to the 
right.

If a range of text is not selected, only the paragraph containing the insertion point will be indented.

Shortcut:
Key: CTRL+M



Indent Left (Layout Menu)

Use this command to move paragraphs one tab stop to the left.

If a range of text is selected, each paragraph in the range will be moved one tab stop to the left.

If a range of text is not selected, only the paragraph containing the insertion point will be moved one tab 
stop to the left.

Shortcut
Key: CTRL+SHIFT+M



Page Break (Layout Menu)

Use this command to begin a new page at the insertion point.



Insert Item (Layout Menu)

Use this command to insert a text field into your document. Choose the type of field you wish to create 
from the list that appears when you select this command.

Field types:
Date The current date in the format you have set for the document.
Time The current time in the format you have set for the document.
Page Number The page number as determined by the position of the page in the 

document and the page number options.
Merge Field A user definable placeholder for data which will be inserted from a text 

file.
Text Clip Formatted text saved as file.



A placeholder for formatted text such as the time or date.
 



Update Item (Layout Menu)

Use this command to update the text fields in contained in your document. 
Check which field types you wish to update from the dialog that appears when you choose this command. 

If a range of text is selected, all the checked field types in the paragraphs in that range will be updated.

If a range of text is not selected, only those checked field types in the paragraph containing the insertion 
point will be updated.

If a single text field is selected, and that field's type is checked, it will be the only field updated.

Note:
The Merge Item can only be checked if a single merge field has been selected in    the document.



Create (Sections Menu)

Use this command to create or update a new section in your document using the Sections dialog.



Go To (Sections Menu)

Use this command to select a section in your document for viewing or editing.    Choose the section you 
wish to view or edit from the list of available sections that appears in the Choose Section dialog.

This command is not available if there is only one section in your document.



Delete (Sections Menu)

Use this command to remove a section and its contents from your document.    Select the section you 
wish to delete from the list of available sections that appears Choose Section dialog.

This command is not available if there is only one section in your document as Final Writer requires that 
there be at least one Main section.



Edit Bibliography (Sections Menu)

Use this command to add to or edit entries in your documents Bibliography.    The Edit Bibliography dialog 
appears when you choose this command.

Note:    You must select the Create command to add a Bibliography section to your document or update 
the existing Bibliography section after using this command.



Insert Endnote (Sections Menu)

Use this command to add an endnote at the current insertion point in your document.    Enter the 
comment for the endnote in the Insert Endnote dialog that appears when you choose this command.    
Final Writer will automatically insert the proper endnote mark in your document based upon the preceding 
endnotes, if any.

This command is not available if a range of text is selected.

Note:    You must choose the Create command to create or update an Endnote section in your document 
in order for the newly entered data to appear.



Edit Endnotes (Sections Menu)

Use this command to edit the endnote entries in your document.    The Edit Endnotes dialog appears 
when you choose this command.

This command is not available when no endnotes have been inserted in your document.

Note: This command does not create or update an existing Endnote section in your document.    You must 
use the Create command for this purpose.



Add To Index (Sections Menu)

Use this command to add words or phrases to your document's index.

If a range of text is selected, the Add To Index dialog will appear offering you a choice of adding the 
selected words as a phrase or as individual entries for each of the selected words.

If a range of text is not selected, the word following the insertion point is added to the index.

Note:    This command does not create or update an existing Index section in your document. You must 
use the Create command for this purpose.



Edit Index (Sections Menu)

Use this command to edit or add index entries to your document.    You can create new entries, edit 
existing entries, or delete entries from the Edit Index dialog box that appears when you choose this 
command.

Note:    This command does not create or update the Index section in your document.    You must use the 
Create command for that purpose.



Insert (Graphics Menu)

Use this command to insert a graphic object into your document.    Choose the type of graphic object you 
wish to insert from the Insert Graphic dialog that appears when you choose    this command.    Click the 
Properties button in this dialog to set the properties for the object you are about to create.

When you click the OK button, the chosen object will appear in your document.    You may then resize, 
position, or use other graphics tools to adapt the object to your needs.

Note:    To insert OLE items in your document, choose Insert New Object    from the Edit menu.



Properties (Graphics Menu)

Use this command to set the properties of graphic objects in your document.

If no graphics objects are selected when you choose this command, the Graphics Properties dialog 
appears with property tabs for each of the graphic object types available.    Any changes made to the 
properties will be reflected in the creation of any subsequent objects in the document.

If one or more graphic objects are selected the Properties command sets the properties for the selected 
only.



Bring To Front (Graphics Menu)

Use this command to move the selected graphic objects in front of other graphic objects.

This command is not available if not graphic objects are selected.



Send To Back (Graphics Menu)

Use this command to place the selected graphic objects behind other graphics objects.

This command is not available if no graphic objects are selected.



Group (Graphics Menu)

Use this command to combine the selected graphic objects into a single object.    Grouping objects is 
desirable when you want to maintain the relative position and size among several objects.    You can use 
the UnGroup command to extract the individual items from the group.

This command is not available if no graphic objects are selected.



UnGroup (Graphics Menu)

Use this command to extract the individual graphic objects of a group.    This is useful when you need to 
change the properties of one or more of the items in the group.    You can regroup the objects with Group 
command.

This command is not available unless at least one of the selected graphic objects is a group.



Rotate 90 (Graphics Menu)

Use this command to rotate the selected graphic objects 90 degrees clockwise.

This command is not available if no graphic objects are available or if none of the selected graphic 
objects can be rotated.

Note:    Some graphic objects cannot be rotated.    Only the rotatable objects of a group or multiple graphic 
object selection will rotate when this command is chosen.



Flip Horizontal (Graphics Menu)

Use this command to flip the selected graphic objects on their horizontal axis.

This command is not available if no graphic objects are selected or if none of the selected objects can be 
flipped.

Note:    Some graphic objects cannot be flipped.    Only the flippable objects of a group or multiple graphic 
object selection will flip when this command is chosen.



Flip Vertical (Graphics Menu)

Use this command to flip the selected graphic objects on their vertical axis.

This command is not available if no graphic objects are selected or if none of the selected objects can be 
flipped.

Note:    Some graphic objects cannot be flipped.    Only the flippable objects of a group or multiple graphic 
object selection will flip when this command is chosen.



Find (Tools Menu)

Use this command to display the Find dialog for finding words or phrases in your document.

Shortcut
Key: CTRL+F



Replace (Tools Menu)

Use this command to display the Find & Replace dialog for finding words and phrases in your documents 
and optionally replacing them.



Speller (Tools Menu)

Use this command to display the Speller dialog.    If there is a range of selected text when this command 
is chosen, the first word in the selected range is automatically verified.

Shortcut
Key F7



Thesaurus (Tools Menu)

Use this command to display the Thesaurus dialog and search for alternate words.    If a range of text is 
selected when this command is chosen, alternate words for the first word in the range of selected text will 
automatically be provided when the dialog opens.

Shortcut
Keys: CTRL+SHIFT+F7



Word Counts (Tools Menu)

Use this command to display information on the counts and averages of characters, words, lines, 
sentences, paragraphs, and pages in your document.



Sort (Tools Menu)

Use this command to reorder the selected paragraphs in alphabetical order.    You can choose whether 
you want the paragraphs to be arranged in ascending (low-to-high) or descending (high-to-low) order.

This command is not available if less than two paragraphs are selected.



Mail Merge (Tools Menu)

Use this command to merge a data file with your document and print the results.    You will be asked the 
name of the data file and which records in that file you wish to merge with your document.

See Also
Select Merge Records Dialog



Easy Header/Footer (Tools Menu)

Use this command to display the Easy Header/Footer dialog where you can easily setup header and 
footer in your document by specifying your preferences in a dialog.



Easy Page Number (Tools Menu)

Use this command to display the Easy Page Number dialog where you can easily specify the appearance 
and location of automatic page numbers in your document.



Customize (Tools Menu)

Use this command to display the Customize dialog where you can set the properties for the current 
document and default properties for future documents.



Save Text Clip (Files Menu)

This command will save the currently selected text with all of its formatting intact.    The file in which you 
saved the text can then be inserted into your documents at a later time by using the Insert Item command 
in the Layout Menu or by assigning a toolbar button to the clip.

You'll find this command handy for use with addresses, letterheads, and the like.



Clear (Edit Menu)

Use this command to remove the selected text or graphic object from the document.

This command is not available if text or graphics are not selected.

Shortcut
Key Delete



Select All (Edit Menu)

Use this command to select all the text or every graphic object in the current section of your document.    If 
the Text Tool is active when you choose this command all the text in your document is selected and 
highlighted.    If one of the graphic tools is active then all of the graphic objects will be selected.

Note:    Like other selection operations, Select All affects only those components that are in the current 
section and page area.    For example, if you want to delete items on the Right Master page in the Index 
section, you must be working in the Right Master page of the Index section.



Zoom (View Menu)

Use this command to display the Zoom dialog box and select the degree of magnification at which to view 
the current document.



Send Mail (File Menu)

Use this command to send a Final Writer document through your computer's mail system.    Sending 
methods include FAX and E-Mail depending upon the components installed on your computer.

Note:    This command communicates with programs compliant with the Windows MAPI mail system, such 
as the Microsoft Exchange program provided with Windows 95.    If no MAPI compliant programs are 
installed on your system, this command will report an error to that effect.



Lock (Graphics Menu)

Use this command to prevent changes to the size and position of selected graphic objects.
Select the graphics that you wish to lock with your mouse, then choose this command. 

This command is not available when no lockable objects are selected.



UnLock (Graphics Menu)

Use this command to remove the lock placed on selected graphic objects.    Once
the lock is freed, you may once again reposition and resize the objects.

This command is not available when no locked objects are selected.



Paste Special (Edit Menu)
Choose this command to provide specific information as to how you want the clipboard data pasted in 
your document.





Print (File Menu)

Use this command to print a document.      This command presents a Print dialog box, where you may 
specify the range of pages to be printed, the number of copies, the destination printer, and other printer 
setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:

Printer
This is the active printer and printer connection.    Choose the Setup option to change the printer and 
printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:

All Prints the entire document.
Selection Prints the currently selected text.
Pages Prints the range of pages you specify in the From and To boxes.

Copies
Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each page.

Print Quality
Select the quality of the printing.    Generally, lower quality printing takes less time to produce.



Print Progress Dialog

The Printing dialog box is shown during the time that Final Writer is sending output to the printer.    The 
page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview (File Menu)

Use this command to display the active document as it would appear when printed.    When you choose 
this command, the main window will be replaced with a print preview window in which one or two pages 
will be displayed in their printed format.    The Print Preview toolbar offers you options to view either one 
or two pages at a time, move back and forth through the document, zoom in and out of pages, and initiate 
a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:

Print
Bring up the print dialog box, to start a print job.

Next Page
Preview the next printed page.

Prev Page
Preview the previous printed page.

One Page / Two Page
Preview one or two printed pages at a time.

Zoom In
Take a closer look at the printed page.

Zoom Out
Take a larger look at the printed page.

Close
Return from print preview to the editing window.



Print Setup (File Menu)

Use this command to select a printer and a printer connection.    This command presents a Print Setup 
dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.

Printer
Select the printer you want to use.    Select one of the current installed printers shown in the box.    
You install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.



Page Setup (File Menu)

Use this command to change the different attributes of your page.    This command presents a Page 
Setup dialog.





Paste Special (Edit Menu)

Use this command to paste an object from the clipboard either as a link or in an alternate format.



Links (Edit Menu)

Use this command to display a Links dialog box which lets you edit links between your document and 
other documents.

This command is unavailable if you have no links in your document.



Links dialog box

The following options are available in the Links dialog box:

Links
Displays all links in a document. The four columns contain the application, filename, item name, and 
type or status of link.

Update
Select the type of link you want for the selected links in the Links box:
Automatic Inserts new data as soon as it is available.
Manual Inserts new data only when you ask for it by choosing the Update Now button.

Locked
Prevents updates to a selected link. If you lock a link, the Update Now option is unavailable.

Open Source
Opens the source of a selected link -- for example, choosing the Open Source button opens up a 
linked chart in Microsoft Excel if you have a Microsoft Excel chart linked to your document.

Update Now
Updates all links selected in the Links box, and then closes the dialog box.

Cancel Link
Breaks links for all selected links between data and the document, and then closes the Links dialog 
box.

Change Link
Displays a dialog box so you can change the selected link to receive data from another application, 
file, or item. 



Object verb (Edit Menu) 

Use this command to open the application in which the selected object was created and display the object 
so you can edit it.    This command is available only when you have selected an existing object in your 
document.    When you finish editing and close the application window, Final Writer incorporates the 
changes into your document.    This menu name changes depending on the object you select.

Shortcut
Mouse: Double-click the object with the left mouse button.



Insert New Object (Edit Menu)

Use this command to insert an object from another application.    The application supplying the object will 
become active on your screen.

Select the object you want to insert into your document using the Insert New Object dialog box.



Insert New Object dialog box

Choose the Object command from the Insert menu to insert an object from another application.    Select 
the object you want to insert into your document from the Insert New Object dialog box.

Object Type
Some common objects are drawings, graphs, spreadsheets, and equations.



Perfecting a Document
Now that you have created, edited, and formatted your document, it’s time to turn to Final Writer’s speller, 
thesaurus, and statistics features to help make your document as perfect as possible.

How to...

Use the Speller
Use the Thesaurus
Obtain Statistics



Using the speller
Final Writer’s built-in spelling detector will scan your document for words it does not recognize and give 
you the opportunity to revise the spelling.    Final Writer’s spelling corrector will provide spelling 
suggestions for words that it flags as possible misspellings.

All spelling functions are accessed through the Speller dialog.    Once the Speller dialog is open, it can 
be moved to any place on the screen, or depth arranged behind a document window.

There are two ways the speller can be used: "Word Verify" mode, and "Document Scan" mode.    In "Word 
Verify" mode you instruct the speller to verify a single word in your document text.    In "Document Scan" 
mode, you instruct the speller to scan a document starting at the insertion point, and continue until the 
end of the document, or until you tell it to stop.

How to...
Check a single word in your document
Begin a document spell check
Correct spelling errors
Ignore a word the speller thinks is misspelled
Add words to dictionary
Delete words from dictionary



To check a single word in your document:
1. Double-click the mouse on the word to be verified.

2. Choose "Speller..." from the "Tools" menu.

The Speller dialog will appear, and the word is verified.    The speller will display a message indicating 
whether or not the word is spelled correctly.

If the word is not spelled correctly, you can use any of the Speller dialog’s options for obtaining 
suggestions or adding the word to your user dictionary.

3. Click the mouse in the Speller dialog’s close box when you are finished using it.



To begin a document spell check:
1. Set the insertion point where you want the spell check to begin, and choose Speller... from the 

Tools menu.

2. Click on the "Spell" button.

The spelling check will begin at the insertion point, wrapping around if necessary to examine the 
entire document for errors.    As they are found, potentially incorrect words will be highlighted in your 
document and the highlighted word will appear in the Word edit box of the Speller dialog.    A message 
indicating the potential error simultaneously appears in the Alternatives section of the dialog.



Correcting spelling errors
Once a potential error has been identified, Final Writer offers you several ways in which to correct it.    You 
may enter the replacement from the keyboard, ask Final Writer to provide a list of potential alternatives 
from which to choose, or you may skip a word that has been incorrectly flagged by the spell checker.    If 
you have checked the Auto Suggest feature in the Speller tab of the Customize dialog, spelling 
alternatives will be provided automatically for every flagged word.

In any of these correction scenarios, the spell checker will automatically resume its document scan after 
the revision has been made.

How to...
Correct an error from the keyboard
Ask for spelling suggestions
To make a correction using the "Alternatives" list



To correct an error from the keyboard:
1. Click the mouse in the edit box next to Change To, and type in the correct word.

2. After verifying that the word you have typed appears as you wish it to, click on the Replace 
button.

The original highlighted word in your document text will be replaced with the characters you typed.



To ask for spelling suggestions:
1. After the word has been highlighted on the screen, click the Suggest button.

A list of correctly spelled alternatives will appear in the "Alternatives" section of the dialog.    The first 
word in the list is the one the spell checker considers the most likely replacement for the word 
highlighted in your document.    This most likely word will automatically appear in the Change To edit 
box.

2. If the spell checker’s most likely alternative is not the correct replacement, you may examine 
the remainder of the list.    If the list is lengthy, use the scroll bar to move through the 
remaining alternatives.



To make a correction using the Alternatives list:
1. Once you have determined which of the alternatives is the correct replacement, select that 

word by clicking the mouse on it.

The word you selected will appear in the Change To edit box in the dialog.

2. Click on the Replace button.

The highlighted word in your document will be replaced with the alternative word you selected.



To ignore a word the speller thinks is misspelled:
1. Determine if the word highlighted by the spell checker is actually spelled correctly.

Final Writer’s spell checker will automatically flag any word that does not appear in the main or user 
dictionaries.    It is always a good idea to verify the correct spelling of such words before skipping the 
word.

2. Click on the dialog’s Skip button.

The spell checker will automatically skip over other instances of the same word as long as the Speller 
dialog is open.



Adding words
Final Writer flags words as possible misspellings when it cannot find them in either the main or user 
dictionary.    You can add any word to the user dictionary so it will not be flagged again.
 

How to...
Add a word to the user dictionary during a spelling check



To add a word to the user dictionary during a spelling check:
1. Verify that the highlighted word is spelled correctly and that it should be added to the user 

dictionary.

2. Click on the Add button.

The word will be added to the user dictionary.    If you are examining your entire document for errors, 
the spell checker will automatically continue its scan.    All future instances of the word will be verified 
against the spelling you have entered in the user dictionary.    The word will only be highlighted in the 
future if it does not match the entry in the user dictionary.



Deleting words
You can remove a word from the user dictionary when you no longer want that word to be accepted as a 
correctly spelled word. 

How to...
Delete a word from the user dictionary



To delete a word from the user dictionary:
1. Click on the dialog’s User button to bring up the list of words in the user dictionary.

The list will appear in the "Alternatives" section of the dialog.

2. Click on the word to be deleted.

3. Click on the Delete button.



Using the thesaurus
Final Writer’s thesaurus is a tool that helps you find the best word for a given situation. The thesaurus 
gives a list of synonyms for words you specify.

How to...
Use the thesaurus for a word in a document



To use the thesaurus for a word in a document:
1. Double click on the desired word.

2. Choose Thesaurus... from the Tools menu.

The Thesaurus dialog will appear on your screen.    Notice that the selected word appears in the Word 
edit box, and that a number of definitions and alternatives are listed.

3. Review the list, using the scroll bar if necessary.

4. If you would like to view additional lists of alternatives, click on any word in the current list, 
then click on the Find button.

A new list of definitions and synonyms will appear.

5. Once you have found the desired word to replace the selected word in your document, click 
on that word in the list.

6. Click on the Replace button.

The selected word in your document will be replaced with the word from the list.



Obtaining document statistics
Final Writer’s document statistics feature is helpful if you are writing a document that has certain 
limitations on the number of words, number of pages, etc.

How to...
Obtain document statistics



To obtain document statistics:
1. Choose Word Counts... from the Tools menu.

The Document will appear on the screen.



Sections
A section is a part of a document that can consist of text and page settings that are different from other 
parts of the document.    For example, if you are writing a novel, you might want to place each individual 
chapter in its own section.    Even if you are not writing a novel, you can use sections to go from one page 
layout setting to another within the same document.    For example, you might change some of the 
following settings for each section in a document:

• Number of columns
• Page number prefix
• Page number format
• Master page items
• Header and footer areas
• Edit area margins
• Section title or name

Final Writer sets up one section automatically when you begin a new document.    If you do not intend to 
use multiple sections, section settings and text entered will be consistent for the entire document.    If you 
do not wish to use multiple sections in your document, think of the entire document as a single section.

When using multiple sections, text from one section can not flow into another.    In other words, when you 
enter text at the end of a section, the section simply gets bigger -- the text does not go into the next 
section.    Furthermore, you can only edit and view one section at a time. 

Special sections
Normal sections
Creating a new section
Going from one section to another
Deleting a section
Printing sections
Section types
Updating special sections
Reformatting special sections



Special sections
Some of the section types that can be created in Final Writer are called "special sections".    Special 
sections are ones that Final Writer generates for you, as opposed to you creating the text for the section 
yourself.    Special sections in Final Writer include:

Outline
Table of Contents
Table of Illustrations
Endnotes
Bibliography



Normal sections
Normal sections are those in which you enter text.    The three types of normal sections are:

Title Page
Preface
Main

A document can have more than one "Main" section, but it can only have one of each of the other section 
types.    For example, your document might be an instruction book consisting of the following sections:

• Title Page
• Preface
• Table of Contents
• Chapter 1 (Main)
• Chapter 2 (Main)
• Chapter 3 (Main)
• Index

The manner in which Final Writer positions sections within a document is consistent with the way you 
would expect certain section types to appear in a book.    For example, if you have been working in a Main 
section and decide to create a Title Page section, Final Writer will automatically place the Title Page 
section before the Main section.



To Create a new section:
1. Select Create... from the Sections menu.

2. Choose the section type you wish to create from the list in the Sections dialog.

3. Click the Properties... button to modify properties and options for that section type, then click 
OK.

4. Click OK in the Sections dialog to create the section.



Going from one section to another
In Final Writer you may only edit and view one section at a time.    The vertical scroll bar which you use to 
move through text will only let you move within the current section.

How to...
Access a different section than the one you are working in



To access a different section than the one you are working in:
1. Select Go to... in the Sections menu.

2. Choose the section you want to access from the list.

NOTE:    The "Go To Section" list    will consist only of sections that already exist in your document.    
You can not begin a new section using the "Go To Section" command.



Deleting a section
You can remove all but one Main section from your document at any time.    When you delete a section, 
Final Writer deletes all text and graphics that are in the section.    If you want to keep any text or graphics 
in a section that you are deleting, you should copy the text or graphics to a different section.

How to...
Delete a section



To delete a section:
1. Select Delete... from the Sections menu.

2. Choose the section you wish to delete from the list of sections.



Printing sections
When you print a document you can print one section at a time or all sections.    Final Writer will print 
multiple sections in the order in which they exist in your document.



Section types
You can create sections of the types below in Final Writer.    Remember that each section can have its 
own page layout settings.    For example, your Table of Contents might have 2 columns, your Main 
sections 1 column, and your Index 3 columns.

Title Page
Preface
Main 
Outlines
Table of Contents
Table of Illustrations
Endnotes
Bibliography
Index



Title Page
Final Writer will position the Title Page section as the first page of your document.    Use this section for 
titles of papers, stories, novels, etc.    Title Page sections use the same set of paragraph styles as Main 
sections.    You are responsible for entering any text and graphics that need to appear in your Title Page 
section. 



Preface
Use the Preface section to introduce your document.    A Preface is usually a statement or essay that 
introduces a book and explains its scope, intention, or background.    Final Writer will place the Preface 
section after any Title Page section.    You can use the same set of paragraph styles for a Preface section 
that you use for Main and Title Page sections.    You are responsible for entering any text and graphics 
that need to appear in your Preface section.



Main
Use Main sections for the body of your document.    You can create as many Main sections as you want 
for a document.    Typically you would use Main sections for different chapters of a book or paper.    You 
can also use Main sections simply as a way of changing page layout and/or master pages within the 
same document.    Final Writer places all Main sections together after any Title Page or Preface sections. 
Paragraph styles created for one Main section are shared with other Main sections, as well as Title Page 
and Preface sections.



Outlines
An Outline section is a summary of a document analyzed in headings and subheadings.    To produce an 
outline of your document you are required to:

• Define which Main section paragraph styles you want to trigger the creation of an outline entry.    You 
do this by assigning an outline level to the style.    See paragraph styles.

• Create your document and assign the appropriate Main section paragraph style to each paragraph 
that you want in your outline.

When Final Writer creates an outline, it scans a document looking for paragraphs that are supposed to 
generate an outline entry.    When it finds one of these paragraphs it creates an outline entry by prefixing 
the paragraph's text with a sequential letter or number that is determined by the level being created and 
where the entry falls sequentially within the outline.    It formats the outline entry according to the Outline 
section's paragraph style corresponding with the level being created.    Typically you would set up Main 
section paragraph styles for topics, headings, and sub-headings in such a way as to generate an outline 
in the order these items should appear in an outline.    For example, if you look at the default paragraph 
styles Final Writer uses, you will see the following styles and their outline assignments:

Style 
Name

Outline assignment

Section 
Name

Level 1

Topic 
Name

Level 2

Sub 
Topic 1

Level 3

Sub 
Topic 2

Level 4

An example of an outline created using the above styles is:

1. Section Name
A. Topic Name
B Topic Name

1. Sub Topic 1
2. Sub Topic 1

a. Sub Topic 2
b. Sub Topic 2

3. Sub Topic 1
C. Topic Name

You can assign one of 8 outline levels to any Main section paragraph style.    In the above example only 4 
levels of outline are used. You can also modify the outline section's paragraph styles to suit your needs. 

How to...
Set up a document so an outline can be created
Create an outline



To set up a document so an outline can be created:
1. Either use Final Writer's default paragraph styles with outline levels already assigned, or 

create your own.

2. Create your document, and whenever you enter a paragraph such as a heading or topic name, 
assign it one of the paragraph styles that has been set up to generate an outline entry level.



To create an outline:
1. Choose Create... from the Tools menu.

2. Choose Outline from the list of sections.

3. Click the Properties button to make any desired changes to the outline appearance properties.

4. Click OK.

Final Writer will create and then display the Outline section.



Table of Contents
The Table of Contents section is a list of your document's headings and subheadings and includes page 
numbers where these items appear in the document.    To produce a Table of Contents you are required 
to:

• Define which Main section paragraph styles that you want to trigger the creation of a Table 
of Contents entry.    You do this by assigning a Table of Contents level to the style.    See 
paragraph styles.

• Create your document and assign the appropriate Main section paragraph style to each 
paragraph that you want in your Table of Contents.

When Final Writer creates a Table of Contents, it scans a document looking for paragraphs that are 
supposed to generate a Table of Contents entry.    When it finds one of these paragraphs it creates an 
entry in the Table of Contents using the paragraph's text along with the page number the paragraph is on. 
It formats the entry according to the Table of Contents section's paragraph style corresponding with the 
level being created.    Typically you would set up Main section paragraph styles for topics, headings, and 
sub-headings in such a way as to generate a Table of Contents in the order of importance these items are 
to appear.    For example, if you look at the default paragraph styles Final Writer uses, you will see the 
following styles and their Table of Contents assignments:

Style Name Table of Contents assignments
Section 
Name

Level 1

Topic Name Level 2
Sub Topic 1 Level 3
Sub Topic 2 Level 4

An example of a Table of Contents created using the above styles is:

Section Name
Topic Name 1
Topic Name 2

Sub Topic 1 3
Sub Topic 1 3

Sub Topic 2 3
Sub Topic 2 3

Sub Topic 1 4
Topic Name 5

You can assign one of 8 levels of Table of Contents to any Main section paragraph style.    In the above 
example, only 4 levels are used. You can also modify the Table of Contents section's paragraph styles to 
suit your needs. 

How to...
Set up a document so a Table of Contents can be created
Create a Table of Contents section



To set up a document so a Table of Contents can be created:
1. Either use Final Writer's default paragraph styles with Table of Contents levels already 

assigned, or create your own.

2. Create your document, and whenever you enter a paragraph such as a heading or topic name, 
assign it one of the paragraph styles that has been set up to generate a Table of Contents 
entry.



To create a Table of Contents section:
1. Choose Create... from the Tools menu.

2. Select Table of Contents from the sections list.

3. Click the Properties... button to make any desired changes to the Table of Contents 
appearance.

4. Click OK.

Final Writer will create and then display the section.



Table of Illustrations
A Table of Illustrations section consists of a list of titles of graphics and image objects in your document, 
along with the page numbers on which these objects appear.    To produce a Table of Illustrations, you are 
required to assign titles to all graphics and imported images within your document that you want 
referenced in the Table of Illustrations.

When Final Writer creates a Table of Illustrations, it scans a document's graphics and imported image 
objects looking for objects containing an "Illustration Title". When it finds one of these objects it generates 
a Table of Illustrations entry using the "Illustration Title" text along with the page number the object 
appears on.

How to...
Indicate that a graphic or imported image is to appear in the Table of Illustrations
Create a Table of Illustrations section



To indicate that a graphic or imported image is to appear in the Table of 
Illustrations:
1. Access the object's Properties by either 1) double-clicking the mouse on an object, or 2) 

selecting the object and choosing Properties from the Graphics menu.

2. Enter the title or name of the object in the dialog's Illustration Title edit box.    If you do not 
enter anything in this area, the object will not be included in the Table of Illustrations.



To create a Table of Illustrations section:
1. Choose Create... from the Tools menu.

2. Select Table of Illustrations from the section list.

3. Click the Properties... button to make any desired changes to the Table of Contents section.

4. Click OK. 

Final Writer will create and display the section.



Endnotes
Endnotes are bibliographical information linked to a source and placed at the end of the document.    Final 
Writer creates the Endnotes section using endnote text you enter as you insert endnotes into your 
document.    The Endnotes section is always placed after the last Main section in your document.

How to...
Insert an endnote in your document
Access the "Edit Endnotes" dialog
Edit an existing endnote
Remove an endnote form a document
Create the Endnotes section



To insert an endnote in your document:
1. Set the insertion point (click the mouse) in your document where you want to insert an 

endnote.

2. Choose Insert Endnote... from the Sections menu.

Final Writer will display the "Insert Endnote" dialog. 

3. Enter the text for the endnote in area provided.

4. Click on the "OK" button.

Final Writer will save the endnote text and place an endnote marker in your document at the insertion 
point.    The marker is a number whose value depends upon where the endnote's location is in relation 
to other endnotes in the document.    Final Writer will automatically calculate which number to use.

Endnotes that you have inserted into a document may be edited or viewed at any time using the Edit 
Endnotes dialog.    Formatted endnotes only appear when you create the Endnotes section.



To access the Edit Endnotes dialog:
1. Choose Edit Endnotes from the Sections menu.

Final Writer will display the Edit Endnotes dialog.



To edit an existing endnote:
1. Select Edit Endnotes... from the Sections menu.

2. Choose the endnote you wish to edit from the list of endnotes.

Final Writer will enter the complete text of the selected endnote in the data entry area titled "Endnote 
Text". 

3. Click the mouse in the area of the endnote text where you want to begin editing.

4. When you are finished editing the endnote, click the Save button.    If you don't click the Save 
button before making another selection from the List of Endnotes, your changes will not be 
saved.

5. Repeat steps 2-4 for each endnote you wish to edit.



To remove an endnote from a document:
1. In the document text, delete the marker of the endnote to be removed.

Final Writer will remove the marker and the endnote text associated with it.



To create the Endnotes section:
1. Choose "Create..." from the Sections menu.

2. Click Endnotes in the sections list.

3. Click the Properties... button to make any desired changes to the appearance of the Endnote 
section.

4. Click OK.

Final Writer will create and display the Endnotes section.



Endnote Property Settings
The Marker, Indent, and Format settings in the Options tab of the Endnotes Property dialog instruct Final 
Writer how to format endnotes.    The Indent setting defines the amount of white space that is to appear 
between the endnote marker and the endnote text.    Marker and Format settings are as follows:

Marker options
Superscript
7 Ibid., p. 223.

Normal.
7. Ibid., p. 223.

Format options:
Flush Left
1. John E. Warriner and Francis Griffith, English Grammar and Composition (New York: 
Harcourt Brace Jovanovich, 1977), p. 208.
2. Ruth I. Anderson et al., The Administrative Secretary: Resource (New York: McGraw-
Hill, 1970), p. 357.

Flush and Hang
1. John E. Warriner and Francis Griffith, English Grammar and Composition (New York: 

Harcourt Brace Jovanovich, 1977), p. 208.
2. Ruth I. Anderson et al., The Administrative Secretary: Resource (New York: McGraw-

Hill, 1970), p. 357.

Indented
1. John E. Warriner and Francis Griffith, English Grammar and Composition (New 

York: Harcourt Brace Jovanovich, 1977), p. 208.
2. Ruth I. Anderson et al., The Administrative Secretary: Resource (New York: 

McGraw-Hill, 1970), p. 357.



Bibliography
Use Final Writer's Bibliography feature to create a list of all works you have found relevant in writing a 
document.    Final Writer places your Bibliography after the Endnotes section and before the Index 
section.    You can create and/or edit Bibliography entries at any time during the creation of a document.    
Final Writer will save your entries with the document.    When you instruct the program to create the 
Bibliography, Final Writer will create the Bibliography section consisting of your entries automatically 
arranged in alphabetical order.    Bibliography entries are added, edited, and deleted using the Edit 
Bibliography Entries dialog.

How to...
Access the "Edit Bibliography Entries" dialog
Add a new bibliography
Delete an existing entry
Create the Bibliography section



To access the Edit Bibliography Entries dialog:
1. Choose Edit Bibliography from the Sections menu.

Final Writer will display the Edit Bibliography Entries dialog.



To add a new bibliography entry:
1. Click the mouse in the data entry area titled Bibliography Entry.

After you click the mouse you should see an insertion point.

2. Enter the text for the entry and press the Save button.

Final Writer will add the new entry to the list of bibliography entries it keeps for your document.



To edit an existing entry:
1. In the list titled List of Entries, click the mouse on the line containing the entry you wish to 

edit.

Final Writer will copy the full text of the entry into the data entry area.

2. Set the insertion point (click the mouse) where you want to edit, make your edits, and press 
the Save button.

Final Writer will replace the old text with the new text.



To delete an existing entry:
1. In the list titled List of Entries, click the mouse on the line containing the entry you wish to 

delete.

2. Click on the Delete button.



To create the Bibliography section:
1. Choose Create... from the Sections menu.

2. Select Bibliography from the list sections.

3. Click the Properties... button to make any desired changes to the appearance of the 
Bibliography section.

4. Click OK.

Final Writer will create the Bibliography section by arranging your entries in alphabetical order.



Index
Final Writer's Index feature makes it very easy to create an excellent index for your document.    You can 
index the current word, a phrase, or all words in a selected range.    If what you index is on more than one 
page, Final Writer will automatically add those pages to the index.    When you ask Final Writer to create 
your index, the program scans the document looking for every occurrence of the entries you have 
indexed.    It formats the index in the Index section, and places this section as the very last one in the 
document.

How to...
Index a word
Index a phrase or words as one index entry
Index all words in a selected range
Access the Edit Index Entries dialog
Edit an index entry
Delete an index entry
Delete all indexed entries
Create the Index section



To index a word:
1. Set the insertion point (click the mouse) on or before the word you want to index.

2. Choose Add To Index from the Sections menu.

Final Writer will add the word to a list of indexed words.



To index a phrase or words as one index entry:
1. Select the text that you want to index as one entry.

2. Choose Add To Index from the Sections menu.

3. Check Single Entry in the dialog that appears, then click OK.



To index all words in a selected range:
1. Select the text that you want indexed.

2. Choose Add To Index from the Sections menu.

3. Check Entry for each word in the dialog that appears, then click OK.

Final Writer will scan the selected range of text for words.    Every time it finds a word or number it will 
add the word to the list of indexed entries.

You can edit or delete indexed entries at any time.    Indexed entries are edited and deleted from the Edit 
Index Entries dialog.



To access the Edit Index Entries dialog:
1. Choose Edit Index from the Sections menu.

Final Writer will display the dialog.



To edit an index entry:
1. In the list titled Index Entries click the mouse on the entry you want to edit.

2. Change the entry to whatever you want it to be and click on the Save button.

Final Writer will replace the old entry with the edited one.



To delete an index entry:
1. In the list titled Index Entries click the mouse on the entry you want to delete.

2. Click on the Delete button.

Final Writer will remove the entry from its list of indexed entries.



To delete all indexed entries:
1. Click the mouse on the Delete All button.

Final Writer will remove all words from the list of indexed entries.



To create the Index section:
1. Choose Create... from the Sections menu.

2. Select Index from the list of sections.

3. Click the Properties button to make any changes to the appearance of the Index section.

4. Click OK.



Updating special sections
Final Writer creates the content of the Outline, Table of Contents, Table of Illustrations, Endnotes, 
Bibliography, and Index sections. If you have already created one or more of these special sections, and 
then modify the document so that these special sections need to be updated, you will need to instruct 
Final Writer to create the section again.    When the program creates the section again, it will remove 
anything that is already in it.    For example, if you have created an Index section, and then add pages in 
the middle of the document, the Index is now probably invalid.    To update the index to reflect the new 
state of the document, simply instruct Final Writer to create the Index section.    When it creates the Index 
section again, it will remove the old Index section automatically.

Warning:    You can modify any text that Final Writer creates in a special section, but if you make 
modifications to your document that force you to create a new special section, you will lose all 
modifications you made within the special section.



Reformatting special sections
Final Writer formats all text within the Outline, Table of Contents, Table of Illustrations, Endnotes, 
Bibliography, and Index sections by using paragraph styles assigned to the respective section.    By 
redefining these paragraph styles you can reformat existing sections or change the format of sections to 
be created. 



Form Letters
With Final Writer, you can create a form letter, a list of recipients, and print an individualized copy of the 
form letter for each recipient.    Included in this chapter are instructions on:

Producing form letters
Creating a data file
Saving a data file
Creating a form letter.
Merging data with a form letter



Producing form letters
To print form letters in Final Writer, you need:

• A form letter document containing text that is the same for every copy of the letter, and 
indication where custom data unique for each copy is to be inserted.

• A data file containing actual information that is different for each letter, such as the names 
and addresses of recipients. 

The form letter and the data file are combined using the Print Merge command to print individualized form 
letters.



Creating a data file
In the discussions that follow, "row" is used to refer to a collection of related data, and "field" is used to 
refer to a piece of data within a row.    For example, in a name and address data file, a row refers to all 
information for a person, while field refers to a person's name.

A data file is an ASCII disk file where fields are separated by comma or tab characters, and rows are 
separated by a newline (0x0a) or return (0x0d) character.    For example, in a name and address data file, 
each person's name and address information (row) is separated from another person's name and address 
by a new line or return character.    Within each row the name, address, city, state, etc., fields are 
separated from each other by either a comma or tab character.    Although either a tab or comma can be 
used to separate data, only one method can be used in any given data file.    Therefore, if data is 
separated with a tab for one row of data, a comma cannot be used to separate data on another row.

Final Writer uses the first row of a data file to determine the names of fields.    Therefore, in a name and 
address data file, the first row could contain the words "First", "Last", "Address", "City", etc. Subsequent 
rows would contain the actual names and addresses.

To summarize, the rules governing the format of data files that can be used in Final Writer's Form Letter 
feature are:

• Data file must be an ASCII data file.

• Rows within a data file are separated by either a new line or a return character.

• Fields within a row are separated by either a tab or a comma character.    Only one method 
of separating fields can be used in any given data file.

• The first row of a data file must contain the names of the fields contained in the file.

• The sequence of fields within a row must follow the sequence of field names used in the 
first row.

A typical name and address data file might appear as:

First Middle Last Street City State Zip
Woody Williams 1200 Company St. Tempe AZ 12345
Terry B. Wright 43 Sailboat Ave. Tempe AZ 32321
Kelly L. Jones 55 Golf St. Phoenix AZ 39393
Lori T. Sanchez 23 Fitness Rd. Tempe AZ 38290
Ric A. Fischer 553 Amiga Ln. Mesa AZ 32342
Joe G. Rosenberg 25 Bullseye Blvd. Glendale AZ 10025

NOTE. Where a field does not exist within a row, only the separating character is entered.

Tips for setting up a data file document



Tips for setting up a data file document
You may want to modify two preference settings to make entering, saving, and opening a data file more 
convenient.    These preferences are:

"Tabs every" value
Final Writer has a default tab distance value that is set on the Doc Items tab in the Customize dialog.    
This value specifies the distance the program will move the insertion point whenever you press the Tab 
key where no tab stops are set.    When you are creating a data file, and intend to use a tab character to 
separate data, you may want to set this value larger than Final Writer's original default value. We 
recommend setting the "Tabs Every" value in the Doc Item tab of the Customize dialog to at least .75 
inches.

ASCII I/O Preferences
We recommend the following settings for the ASCII I/O Preferences used to read and write your data file. 
You can set these in the ASCII File I/O tab of the Customize dialog.

Under Input Options:
check Make a paragraph at each 'New Line" character
uncheck Make a paragraph at each blank line.

Under Output Options:
check Insert 'New Line' character after each line.
uncheck Insert blank line after each paragraph.



Saving a data file
If you use Final Writer to edit and save your data file, you will need to save it as an ASCII file.    In order to 
do this properly, always use Save As,,, from the file menu than Save....    The reason for this is that Save... 
will always save an existing file as a formatted Final Writer document.    By using the Save As... feature, 
you can specify that ASCII format is to be used.

How to...
Save a date file in Final Writer



To save a data file in Final Writer:
1. Choose Save As... from the File menu.

A file dialog will appear.

2. Specify the name of the file and the folder in which to save it.
3. Choose Text Files from the Save as type drop down list.
4. Click the Save button.

The file will be saved as an ASCII file.



Creating a form letter
A form letter is created in Final Writer like any other document.    The only difference is that wherever you 
want data to be merged into the text from a data file, you will choose the "Insert Merge Field" menu item 
and specify the name of the field that is to be merged.    Once a merge field definition has been inserted, 
you can change it, remove it, and even change its type attributes.
How to...
Insert a merge field definition
Change type attributes
Change data name
Remove a merge field
Save a form letter



To insert a merge field definition:
1. Make sure the insertion point is where you want data to be inserted from the data file.

2. Choose Insert Item from the Layout menu.

3. Choose Merge field from the list of insertable items and click OK.

4. If you have not already selected a data file, a file dialog appears. Locate the name of the data 
file containing the names of the merge fields that you wish to use. Click Open.

5. A list of fields for your data file is displayed in a list.    Choose the name of the field you wish to 
insert into your document from this list, then click OK to insert it into your document.

6. Continue typing your form letter and repeat the above steps for each merge field.



Changing a merge field's type attributes
A merge field created by Final Writer can have its own unique type attributes.    For example, your form 
letter could be in Times-Roman while data merged into a particular merge field could be Times-Bold. 

How to...
Change a merge field's type attributes



To change a merge field's type attributes:
1. Click the mouse on the merge field whose attributes are to be changed.

Final Writer will select the entire merge field including its surrounding brackets.

2. Set the type attributes with the Font dialog or the toolbar entries.



Changing a merge field's data name
You can change your mind as to what field is to be merged in a merge field that is already defined.

How to...
Change a merge field's data name



To change a merge field's data name:
1. Click the mouse on the merge field whose data name is to be changed.

Final Writer will select the entire merge field including its surrounding brackets.

2. Choose Update Item from the Layout menu.

3. Check the Merge Field option in the dialog that appears, then click OK.

4. If you have not already selected a data file, a file dialog appears.    Locate the name of the data 
file containing the names of the merge fields that you wish to use. Click Open.

5. A list of fields for your data file is displayed in a list.    Choose the new name of the field from 
this list, then click OK to make the document change.

Final Writer will remove the dialog, and insert the field's name into your document replacing the name 
that was there before.



Removing a merge field
You can remove a merge field from a form letter at any time.

How to...
Remove a merge field
Save a form letter



To remove a merge field:
1. Click the mouse on the merge field to be removed.

Final Writer will select the entire merge field including its surrounding brackets.

2. Press the DELETE or BACKSPACE key.

The merge field will be removed from the document.



Saving a form letter
A form letter is saved as a Final Writer document.    There is nothing special about saving a form letter 
-- do it just as you save any other document. 



Merging data with a form letter
Once you have created a form letter and a data file, you can instruct Final Writer to merge the data file 
with the form letter.    This process will print an individualized copy of the letter for each recipient in the 
data file.

How to...
Merge data with a form letter



To merge data with a form letter:
1. If the form letter document is not already open, choose Open from the File menu, and open the 

form letter as you do any other document.

2. Choose Mail Merge... from the Tools menu.

Final Writer will display the Select Merge Data file dialog.

3. Use the file dialog to locate the data file you want to use for the merge.

4. Once the data file is located, double-click the mouse on its name in the file dialog's list.

The Select Merge Records dialog will appear.

Final Writer will analyze the data file and determine the number of rows (records) contained in the file. 
It will put the number "1" in the From range, and the last record number found in the To range.    This 
gives you the ability to select which group of data records are to be merged.    This feature is handy if 
you have to restart a merge because of a printer error or some other problem.

5. If you want to print all rows in the data file, click the mouse on All.    If you want to print a range 
of rows, click the mouse on Range, enter the beginning row # in the area labeled From, and 
enter the ending row # in the area labeled To.

6. Click on the OK button in the Select Merge Rows dialog.

Final Writer will display the Print Document dialog. 

7. Use this dialog just as you would if printing a single document. 

Final Writer will display the Printing Document... dialog and will begin to merge rows of data with the 
form letter.    Each page of the form letter will be printed for each data record merged.    You can 
cancel this process at any time by clicking the mouse on the Stop button.



Setting Options
Final Writer’s options settings let you inform the program of your preferred way of doing certain 
operations.    Final Writer comes to you with these options set to SoftWood’s default values.    You can 
modify any of these settings as you see fit.    This chapter describes the preference settings so you can 
modify them to suit your needs.    Options described in this chapter are:

User Toolbar options
View Options
ASCII Input/Output options
Speller/Hyphenation options
Document item options
Document save options



User Toolbar Options
Final Writer's toolbars contain buttons that you click on to activate commonly used program operations.    
Each button can be designated to activate one of the following types of operations:

• Open a text clip.
• Activate a Final Writer menu command.

You specify which buttons and commands are to appear in Final Writer's toolbars with the User Button tab 
in the Customize dialog. 

How to...
Access the User Button Tab in the Customize dialog
Access a different toolbar
Add a new button to a toolbar
Set a command for a button
Attach a text clip to a button
Remove a button from a toolbar
Change the order of buttons in a toolbar
Rename a toolbar



To access the User Button Tab in the Customize dialog
1. Choose Customize... from the Tools menu.

Final Writer will display the dialog.

Final Writer gives you six toolbars in which to place buttons.



To access a different toolbar
1. Choose the desired toolbar from the drop down list in Toolbar group.



To add a new button to a toolbar
1. Locate the button to be added in the list of button images titled "Buttons".

Most of the images in this list have a default menu command associated with them.    You can view 
the default command for the image by clicking once with the left mouse button on the image.

2. Select the button you wish to add with the left mouse button and while holding it down, drag 
the button from the Buttons list into the list of buttons being displayed for the strip you are 
modifying.

3. The button will be added to the strip at the position in the list where you release the mouse 
button.

If a default command exists for the button, it will appear alongside it in the list.



Setting a command for a button
1. Open the Customize dialog from the Tools menu and select the User Buttons tab.

2. Select the toolbar and button you wish to edit.

3. Click the Commands radio button in the Show group.

4. Find the desired command in the list of commands.

5. Attach the selected command to the selected button by clicking the Set Button or by double 
clicking on the command.



To attach a text clip to a button
1. Open the Customize dialog from the Tools menu and select the User Buttons tab.

2. Select the toolbar and button you wish to edit.

3. Click the Macros radio button in the Show group to display the list of available text clips.

4. Find the desired text clip in the list of text clip names.

5. Attach the selected text clip to the selected button by clicking the Set Button or by double 
clicking on the text clip name.



To remove a button from a toolbar
1. Open the Customize dialog from the Tools menu and select the User Buttons tab.

2. Select the toolbar containing the button you wish to remove from the drop down list.

3. Click the left mouse button on the button you wish to remove and while holding it down, drag 
the button out of the list, then release the mouse button.



To change the order of buttons in a toolbar
1. Open the Customize dialog from the Tools menu and select the User Buttons tab.

2. Select the toolbar containing the buttons you wish to reorder from the drop down list.

3. Click the left mouse button on the button you wish to move and while holding it down, drag 
the button up or down in the list, then release the mouse button.



To rename a toolbar

1. Open the Customize dialog from the Tools menu and select the User Buttons tab.

2. Select the toolbar you wish to rename from the drop down list.

3. Select the portions of the name you wish to edit with the mouse and change with the 
keyboard.



View Options
Final Writer’s View Options define various elements that affect the way a document is displayed on your 
computer screen.

How to...
Set General View Options
Toolbar and Click Tab View Options



To set general view options
1. Select Options from the View menu.

2. Click the General tab.

From here you can set the following:

Measure in
Rulers
Page Guides



The measure in setting is used to specify the measurement system for the document.



The rulers setting is used to define which screen rulers, if any, will be displayed.    The Top option will 
display only the horizontal ruler at the top of your window.    The Left and Top option will display both the 
horizontal top ruler and the vertical ruler at the left of the window.    None will produce a window in which 
neither the horizontal nor vertical ruler are shown.



The page guides options are used to turn on or off gray lines that appear as guides in a Final Writer 
document.    These lines provide a visual representation of your print area, edit area, header/footer areas, 
and columns.



To set toolbar and click tab view options
1. Select Options from the View menu.

2. Click the Toolbars tab.

Here you can set the following

Toolbars
Click Tabs



Selects which toolbars are displayed. Click the Customize button to select which buttons appear in the 
toolbars.



Determines whether Page and Section click tabs are displayed.



ASCII file input/output options
Final Writer options determine how an ASCII file is read and/or written. 

ASCII Input options are used for:
• Opening and reading an ASCII file.

• Pasting data from the clipboard created in another program.

ASCII Output options are used for:
• Writing an ASCII data file.

• Copying data to the clipboard that will be used in another program.

How to...
Set ASCII I/O options



To Set ASCII I/O options
1. Select Customize... from the Tools menu.

2. Click the ASCII File I/O tab.

The Input options determine how Final Writer creates new paragraphs when importing an ASCII file.
The Output Options determine what line formatting Final Writer applies when exporting an ASCII file.



Speller/Hyphenation options
These options let you define options the program will use during spell checking and paragraph 
hyphenation.    For spell checking you can indicate whether spelling alternatives are given automatically 
and specify error reporting tolerances.    For hyphenation you can indicate whether hyphenation is to be 
on or off and what method to use to determine the hyphenation.

How to...
Set Speller/Hyphenation options



To set Speller/Hyphenation options:
1. Choose Customize... from the Tools menu.

2. Click Spelling or Hyphenation tabs to set the respective options. 

Spelling options:

Automatic Suggestions
Report As Errors
Type & Spell

Hyphenation Options:
Hyphenation
Method



Check this option to enable automatic hyphenation.    Uncheck the option to prevent hyphenation.    
Individual paragraphs also have a hyphenation setting which must be ON in order for hyphenation to 
occur in the paragraph.



Set the method used to determine the hyphenation points.

Algorithm method uses linguistic rules. It is faster but less accurate than the Dictionary method.

Dictionary method uses the hyphenation points found in a dictionary entry.    It is slower but more accurate 
than the Algorithm method.

Dictionary & Algorithm uses the above two methods in combination.



When this option is on, suggested words will be automatically given for each word not found in the 
dictionaries during spell checking.



These options let you turn off the reporting of some conditions detected by the spell checker.



When this option is checked, Final Writer will automatically check your spelling as you type and play a 
sound to alert you to possibly misspelled words.



Document Item options
Document Item options tell Final Writer how much space to insert when you press the TAB key and no tab 
stop has been set, how to format dates and times when inserted via the insert date and insert time 
commands, what character to use for decimal points in amounts, and whether to use drag and drop 
editing. 

How to...
Set Document Item options



To set Document Item options:
1. Choose Customize... from the Tools menu.

2. Click the Doc Items tab and set the options according to your needs. 

Document Item options:
Tabs Every
Decimal
Date Format & Order
Time Format
Drag & Drop Editing



Sets the increment at which default tab stops are placed. Tab stops set with the Document Item Options 
dialog are always Left Tab stops.    If you want to use other types of tab stops, you must set them using 
the ruler.



Preset tab stops that do not appear on the ruler. If you set normal tab stops using the ruler, any default 
tab stops up to and including the position of a normal tab stop are removed.    Default tab stops will 
continue to exist past the final normal tab stop.



You may specify one of two decimal styles--period or comma--for your documents.    If period is chosen, 
decimals will be displayed as periods; if comma is chosen, they will appear as commas.



Define the format and order for dates that you insert in your documents with the Insert Date command.



Set the time format for time of day inserted in your document with the "Insert Time" command.



When this option is enabled, you can drag and drop selected text to new positions in the current 
document, or other open Final Writer documents.



Document Save options
This set of options is used to specify how much information you want saved with each document and to 
set the program's Auto-Save feature to ON or OFF.

How to...
Set Document Save options



To set Document Save options:
1. Choose Customize... from the Tools menu.

2. Click the Save Items tab and set the options according to your needs. 

Document Save options:
Save With Each Document
Auto-Save



Specifies which settings are saved with your document.    Any saved settings will replace the default 
settings when the document is reloaded.    To save disk space, save only those settings
which differ from your normal defaults.



When the Auto-Save feature is ON, the program will wait the specified length of time and then 
automatically save the document.    If    Ask First is checked, Final Writer will display a dialog asking if you 
want to save the document.



Page Setup
This describes the process of defining page attributes.    In Final Writer some page attributes are set for 
the entire document and others are set for individual sections. 

How to...
Set Page Attributes
Set Section Attributes



Page Setup dialog
Page attributes that affect the entire document are defined in Final Writer's Page Setup dialog.    These 
attributes are originally set to SoftWood's default values, and may be modified to suit your needs.    When 
a document is saved, its page setup instructions can be saved with it.    When a document is opened, any 
page setup instructions saved with the document are used.

How to...
Define page attributes that affect the entire document



To define page attributes that affect the entire document

1. Choose Page from the Layout menu.

2. Make the desired settings in the Page Setup Dialog.

3. If you wish to make these settings the default values for new documents, check the Set 
Default box before clicking OK.



Paper Size is used to define the physical dimensions of the page you are using for the document.    The 
paper types available are dependent upon the current printer selected.    If you wish to have a document 
page size other than one of the predefined types, choose "Custom Size" from the list and specify the 
width and height of the page.



This setting is used to tell Final Writer whether to print your document in the Portrait or in the Landscape 
mode.    A document printed in Portrait mode will have its top at the narrow end of a page.



Use this setting to indicate whether you want to use Left/Right or simply Right only pages.    Usually the 
only time you will use Left/Right pages is when your document will be bound with pages facing each other 
like the ones in a book.    For letters and other documents, Right only pages are generally used. 



Section Setup dialog
When you begin a new document Final Writer creates the document with one section.    You can leave 
your document containing only the one section or you can insert additional ones.    Each section can have 
its own master pages and page attributes.    Page attributes defined for each section are found in the 
Section Setup dialog. 

How to...
Define page attributes that affect a section



To define page attributes that affect a section
1. Choose Section... from the Layout menu.

2. Use the Section dialog to set the attributes.



Define the area in which text may appear on a page.    Final Writer uses them as limits for the left margin, 
right margin, first line indent, tab stop, and hyphenation hot-zone margin.    When you specify any of these 
settings, Final Writer will not let you specify a value that is outside the edit area.

You will need to enter separate settings for the top, bottom, inside, and outside boundaries of the edit 
area.    If you have selected Left/Right pages, the outside boundary will be on the left side of the left page 
and the right side of the right page.

Typically, when using left/right pages, you should set the inside margin larger than the outside margin.    
By doing this, when the document is printed, the printed area of a page will be offset into the page to 
allow room for binding.    If your document is a letter, memo, or other document that will not be bound, you 
will normally set the inside and outside margins to the same value, and not use the "left/right page" 
option.



You can define each section with up to 6 side-by-side, newspaper style columns.    You may also define 
the space that is to appear between each column.

Text entered in a document with multiple columns will automatically flow from the bottom of one column to 
the top of the next as you type.    If you are revising a document that has already been saved and wish to 
change the number and/or width of columns, your text will automatically reformat when you alter the 
column settings.



Header and footer margins define the portion of a master page where header and footer information 
appears. These margins redefine the size of the Body area of a page so that text entered into it will not 
cover up areas where header and footer information show.



The area at the top of a page that contains text and/or graphics that repeat on pages throughout the 
document.    NOTE: The header and footer areas reside within the edit area. Therefore if you set your Edit 
Area Top at 1 inch, and your Header margin at 2 inches, the body of your document will be 3 inches down 
from the top of the page.



The area at the bottom of a page that contains text and/or graphics that repeat on pages throughout the 
document.    NOTE: The header and footer areas reside within the edit area. Therefore if you set your Edit 
Area Bottom at 1 inch, and your Footer margin at 2 inches, the body of your document will be 3 inches up 
from the bottom of the page.



You can change the name of section by clicking in the edit control and entering a new name.



Select the text, if any, you want to be printed with adjacent the page number.



Determines whether the page numbers used are relative to the section's position in the document, or the 
section itself.



Define text that you want prefixed to any page numbers in your section.    For example, the pages of 
chapter four of book might be prefixed with "4 - " resulting in the pages being numbered 4-1,4-2, etc.



Defines the starting value for page numbering in this section.



This attribute defines how you want page numbers to appear.



Creating and Saving a New Document
How to...

Create a new document
Insert text
Correct mistakes as you go
Select text
Delete text
Save a newly created document
Close a document
Create text clips



To create a new document 
1. Start the Final Writer program and select New from the Files menu.

A blank document window with "Untitled" in the title bar will appear.    The insertion point is 
automatically set in the upper left corner of the new window.

2. Begin typing your document.

As you type, if the last word of a line does not fit in its entirety on a line, the word will either be wrapped 
around to the next line or hyphenated.    Because of this feature, there is no need to press the RETURN 
key at the end of each line as you type, unless you want to force a line to end, or start a new paragraph.



Inserting Text
"Inserting" is the term used to describe the process of adding characters to existing text in a document.    
For example, as you are typing a document, you may wish to add a sentence in the middle of a 
paragraph you have already written.    Or, you may need to insert spaces or blank lines in your document.

In our discussion here, text will refer to any typed character contained in a Final Writer document.    
Numbers, letters, punctuation marks, blank lines, and spaces will all be considered text.

How to...
Set the insertion point
Insert characters
Insert blank lines



Setting the insertion point
Text can only be inserted at the insertion point.    The insertion point may be moved within the text by 
pressing the keyboard arrows or by using the mouse.    In a new document window, the insertion point is 
preset in the upper left corner of the window.

To set the insertion point using the mouse:

1. Move the mouse to the area in the document where you wish to enter text.

2. Click the mouse button.

If you click the mouse at any point beyond the last character in a document, Final Writer will automatically 
place the insertion point just after the last character in the document (if any). 



Inserting characters
When you enter characters on the keyboard, Final Writer inserts them into your document at the location 
of the insertion point.

To insert characters:

1. Set the insertion point where you wish to add new text.

2. Type the characters you wish to insert.



Inserting blank lines
Blank lines may be inserted by using the RETURN key.

To insert blank lines:

1. Set the insertion point where you wish to add blank lines.

2. Press the RETURN key once for each line you wish to add.

If you are at the end of a line when you first press the RETURN key, Final Writer will go to the next 
line.    It is from that point that blank lines may be entered.



Correcting mistakes as you go
1. Use the BACKSPACE key to delete the characters you wish to remove.

Each time you press the BACKSPACE key, the character or space immediately to the left of the 
insertion point will be deleted.

2. Type the correct characters once you have removed the mistake.



Selecting text
Selecting text is often performed during the creation of a document to specify an area of text where you 
would like to make a change.    For example, you might decide to change text to bold, that a certain 
phrase should be replaced by another, or that an entire paragraph should be deleted.    When you have 
selected text in Final Writer, it is highlighted on the screen.    You may select individual characters, words, 
lines, sentences, paragraphs, or even the entire document.

How to...
Select a block of text
Select a single word quickly



Selecting a block of text
You may select a block of text by dragging the mouse over it.

To select a block of text:

1. Position the mouse at the beginning of the text to be selected.

2. Press the mouse button and drag the mouse until all desired text is selected.

As you drag the mouse, Final Writer will highlight the selected text.    If you drag the mouse above or 
below the window border, the document will automatically be scrolled for you.



To select a single word quickly:
1. Double click the mouse on the word to be selected.

When you double-click on a word, Final Writer selects all characters that could be part of that word, 
plus the space following the word.



Deleting text
Deleting is the act of removing text from a document.    Characters may be deleted one at a time or in 
selected blocks of text.    As text is deleted, your document will reformat automatically to fill in where the 
deleted text used to be.

How to...
Delete a character with the BACKSPACE key
Delete selected text
Delete a blank line (RETURN character)



To delete a character with the BACKSPACE key:
Deleting a character
You can use the BACKSPACE key to remove characters in a right to left direction from the insertion point.

1. Set the insertion point to the right of the text to be deleted.

2. Press the BACKSPACE key.



Deleting selected text
When you need to delete several characters at once, it is sometimes more efficient to first select the text 
to be deleted and then delete it using one of the following methods.

To delete selected text:

1. Select the text to be deleted.

2. Press the BACKSPACE key one time, or choose Clear or Cut from the Edit menu.

If you choose the Cut command, the deleted text may later be Pasted in another place in the 
document.    If you choose Clear, the text is permanently removed and cannot be pasted.    Use Clear 
only when you know you do not want the text.



Deleting a blank line (RETURN character)
A blank line is one that contains only a RETURN character.

To delete a blank line with the BACKSPACE key:

1. Place the insertion point at the left margin of the line below the blank line you wish to delete.    
If there is not a line below the blank line to be deleted, place the insertion point on the blank 
line itself.

2. Press the BACKSPACE key.



Saving a newly created document
Once you have finished writing your new document, you should save it to either the hard drive or to a 
floppy disk.    Once saved, the document can be reopened for editing or formatting.    Even if you are going 
to edit your document immediately after completing the first draft version, you should still save the 
document to safeguard it in case of power outage or other unforeseeable events.

How to...
Save a document for the first time



To save a document for the first time:
1. Select Save from the File menu.

A file dialog will appear in which you can give your document a name and choose where you wish to 
save it.

2. Choose a disk drive and folder to save your document in from the Save in drop down list.
3. Click in the File name data entry area and type the desired document name.
4. Click the Save button.



Closing a document
1. Click the mouse in the window close box or select Close from the File menu.

If you have made any changes to the document, and have forgotten to save them, a dialog will 
appear to remind you to do so.



Text Clips
Many times when you create a document, you will enter text that has previously been entered in other 
documents.    A good example is your name and address as it appears at the top of a letter.    Other 
examples include:

• FAX headings
• Memo headings
• Names and addresses of clients
• Common text used over and over

You can automate the task of entering these and other commonly used bits of text by using Final Writer's 
text clip feature.    For example, you can save your name and address, complete with type and paragraph 
settings, in a text clip.    Then, when you create a document and need to insert your name and address in 
it, you instruct Final Writer to place the text clip in your document, saving yourself the bother of typing it all 
over again.    This process is especially useful when you assign a text clip to a User Button.    Let's say 
you have assigned your name and address to a button labeled "M".    To have Final Writer insert the 
contents of the text clip in your document, complete with formatting, all you need do is click the mouse on 
the "M" button.

How to...
Create a text clip
Define a button for a text clip



To create a text clip:
1. Enter and format the text that is to be in the text clip.

2. Select the text that is to comprise the text clip.

3. Choose Save Text Clip from the Files menu.

4. Enter a descriptive name for the clip in the dialog that appears.



Revising a Document

How to...
Open an existing document
Move through text
Replace text
Copy text
Move text
Find and replace text
Insert date and time
Update date and time
Sort paragraphs



Opening a document
A document must be open and visible on the screen before it can be edited.

To open an existing document from Final Writer:

1. Choose "Open..." from the Files menu.

A file dialog will appear on your screen.

2. Select the disk and folder containing the document from the Look in drop down list.

3. Find the name of your document in the list of files and click on it, or enter the name directly in 
the File name edit area.

4. Click on the "Open" button to open the document.



Moving through text
In order to see parts of the document which are not currently visible on the screen, it is necessary to 
move the document through the window.

How to...
Scroll text in small increments
Scroll text in larger increments using the scroll bar
Scroll text in larger increments using the scroll drag bar
Use the "Go To" commands



Scrolling text
The scroll bars allow you to move your document up, down or sideways within the document window.

To scroll text in small increments:

1. Click the mouse on the scroll arrow that points in the direction you wish to move in the 
document.

For example, to move toward the bottom of the document, click on the down arrow.    If you click and 
hold on the down arrow, you will eventually scroll the document to its end.



To scroll text in larger increments using the scroll box:
1. Click the mouse in the region of the scroll box that corresponds with your desired direction of 

scrolling.



To scroll text in larger increments using the scroll drag bar:
1. Drag the horizontal or vertical scroll drag bar until you reach your desired destination.



Using the "Go To" commands
Final Writer’s Go To commands, found in the View and Section menus, allow you to move directly to any 
page or to previously selected text within your document.    This method of moving through text is 
especially helpful when your document is very large and scrolling would take too much time.

How to...
Go to a specific page in a document
Go to a section in a document



To go to a specific page in a document:
1. Choose Go To Page... from the View menu.

2. Type the desired page number.

3. Click OK.



To go to a specific section in    the document
1. In the Sections menu, select Go To....

2. Choose the desired section from the list of document sections

Note:    If there is only one section in the document, the Section Go To command is disabled.



Replacing text
Replacing text is a common editing technique in which new text is entered in place of existing text.    One 
way in which text may be replaced is to backspace over the unwanted text and type in the new text.    The 
following are two more efficient ways.

How to...
Replace selected text with new text
Replace text using the "Paste" command



Replacing selected text with new text
You can replace selected text by entering one or more characters from the keyboard.    The first character 
entered replaces the entire range of selected type.

To replace selected text with a character from the keyboard:

1. Select the text to be replaced.

2. Enter the desired character or characters from the keyboard and continue typing.



Replacing text using the Paste command
Selected text can also be replaced with the contents on the Clipboard.

To replace text with the contents of the Clipboard:

1. Select the text to be replaced.

2. Choose Paste from the Edit menu.

The selected text will be replaced with whatever is on the Clipboard.



Copying text
Final Writer’s Copy and Paste commands enable you to make a copy of text in one location in your 
document and paste the copied text in another location.    You can also paste copied text in another Final 
Writer document.

1. Select the text to be copied.

2. Choose Copy from the Edit menu.

The selected text will be copied onto the clipboard.

3. Set the insertion point at the location in the document where you wish to paste the copied 
text.

4. Choose Paste from the Edit menu.

The text on the clipboard will be pasted into the document at the insertion point.

Note:    Only one block of text can be placed on the Clipboard.



Moving text
Blocks of text may be moved within a document using the Cut and Paste commands found in the Edit 
menu.    Text may also be moved between separate documents.

To move text:
1. Select the text to be moved.

2. Choose Cut from the Edit menu.

3. Set the insertion point at the location in the document where you wish to paste the cut text.

4. Choose Paste from the Edit menu.



Finding/replacing text
When revising a document, you may wish to locate and/or replace certain words, phrases, or numbers.    
Final Writer’s Find and Replace commands enable you to do so without having to read the entire 
document on the screen. 

How to...
Find specific text in a document
Find the next occurrence of specified text
Search for specific text and automatically replace it with alternate text



To find specific text in a document:
1. Set the insertion point at the document location where you wish to begin the search.

For example, if you wish to search an entire document, you would set the insertion point to the left of 
the document’s first word.

2. Choose Find... from the Tools menu.

3. Enter the desired character, word, number or phrase in the Find what data entry.

4. Set the search parameters by clicking in the appropriate option boxes to add or remove check 
marks.

5. Click on the Find Next button to begin the search.

Final Writer will begin to search for the specified text.    When the text is located, it is selected.    If you 
wish to edit the text, simply click on the document and edit the text as you wish.



To find the next occurrence of the specified text:
1. Click the mouse on the Find Next button again.



To search specific text and automatically replace it with alternate text:
1. Set the insertion point in the document location where you wish the word search to begin.

If you wish to search an entire document, set the insertion point to the left of the document’s first 
word.

2. Choose Replace... from the Tools menu.

The Replace dialog will appear on your screen.

3. Enter the character, word, number or phrase you wish to find in the Find What data entry area.

4. Enter the replacement text in the Replace with data entry area.

5. Set the search parameters by clicking in the appropriate option boxes to add or remove check 
marks.

Placing a check mark in the box preceding Match case will cause Final Writer to find the specified text 
regardless of case or capitalization.    The absence of a check mark means that Final Writer will 
search for the word exactly as you entered it in the data entry area.    Any variation in case will cause 
the word to be passed by in the search. 

Button functions:
Find Next
Replace
Replace All



Finds the next occurrence of the search phrase in the document and selects it.



Replaces the selected text in the document with the replacement text and finds the next occurrence.



Finds each occurrence of the search phrase and replaces it automatically with the replace phrase.



Inserting the date or time
You may occasionally want to have the current date or time inserted in your document.

How to...
Insert date or time in your document



To insert the date or time in your document:
1. Set the insertion point where you would like the date or time to appear.

2. Select Insert Item... from the Layout menu.

3. Choose Date or Time from the Insert Item dialog.

The current date or time will appear in your document formatted according to the settings in the 
Document Options.    Final Writer inserts the date or time to the right of your insertion point.



Updating date and time
If you have inserted a date or time in your document using the Insert Item command in the Edit menu, you 
may want to update those items later to make them current.    Dates and times are updated with the 
current date or time from the system clock.

How to...
Update dates or times in your document



To update dates or times in your document:
1. Select the paragraph(s) in your document containing the dates or times you want to update. 

NOTE. To update all dates or times in the document, choose Select All from the Edit menu - this will 
select all paragraphs in the document. 
NOTE.    If the dates or times are in a master page, you will have to first access the master page 
before selecting the paragraphs.

2. Choose Update Item... from the    Layout menu,

3. Check the Date or Time boxes in the Update Item dialog as desired, and click OK.



Sorting paragraphs
This feature lets you alphabetize paragraphs according to their textual content.    You may choose to sort 
either from low to high or high to low.    The Sort command is only active when two or more paragraphs 
are selected.

How to...
Sort two or more paragraphs



To sort two or more paragraphs
1. Select the paragraphs to be sorted.

2. Choose Sort...    from the Tools menu.

3. In the Sort dialog, choose Low to high to sort in ascending order, or High to low to sort in 
descending order.

4. Click OK.

The paragraphs will be sorted from the first to the last character.



Formatting a Document
Setting the way your text appears.

How to...
Set page view
Set paragraph format
Set text and fonts
Set paragraph styles
Set master pages
Set page breaks



Page view
From time to time when you are formatting your document, you may wish to alter the size of your page on 
the screen.    A smaller page view lets you see a greater portion of the page on the screen, while a larger 
page view enables you to see part of your page with a greatly enlarged perspective.

Final Writer also lets you perform full editing at any magnification.

How to...
Change your view magnification



To change your view magnification:
1. Select Zoom... from the View menu.

2. In the Zoom dialog, select the desired magnification.

Choosing Page Width or Full Page automatically adjusts the magnification to display the entire page 
width or a full page regardless of the window.



Paragraph setup
Final Writer is a paragraph-based word processor.    That means you can give each paragraph its own 
unique set of characteristics.    This assignment of characteristics may be accomplished in two different 
ways.    One way is by using the Final Writer ruler.    The other way is by using the Paragraph dialog.

Using the ruler

The Final Writer ruler contains all the tools you will need to set up your paragraphs.    The various 
elements on the ruler may be changed for a single paragraph by clicking in that paragraph, then making 
the desired changes.    Settings for multiple paragraphs may be altered by first selecting the desired 
paragraphs and then making changes to the ruler.

Using the Paragraph dialog

For certain paragraph settings, it may be desirable in some situations to use the Paragraph dialog.    The 
settings for left margin, right margin, first line indent, and hyphenation hot-zone can be set with a numeric 
value using the dialog.    Using the ruler, you move a marker horizontally along the ruler until you reach 
the desired location.    If you need to specify a precise value for these settings, you may wish to use the 
Paragraph dialog.

You will also need to use the Paragraph dialog if you want your settings to be used as default values for 
new documents.

How to...
Open the Paragraph dialog
Change the left or right margin using the ruler
Change the left or right margin using the dialog
Change the first line indent margin using the ruler
Set tab stops
Move a tab stop using the ruler
Delete a tab stop using the ruler
Move the Hot Zone marker using the ruler
Move the Hot Zone marker using the dialog
Set justification using the ruler
Set justification using the dialog
Set line spacing using the dialog
Set hyphenation status using the dialog



To open the Paragraph dialog:
1. Choose Paragraph... from the Layout menu.

The Paragraph dialog will appear.



To change the left or right margin using the ruler:
Left and right margins
The left and right margins define your text’s distance from the sides of the page.

1. To change the margin(s) of a single paragraph, click the mouse in the paragraph to be 
changed.    To change the margin(s) of multiple paragraphs at once, select the desired 
paragraphs by dragging the mouse through them.

2. Position the mouse on the appropriate margin marker.

3. Press and hold the mouse button and drag the appropriate margin marker horizontally along 
the ruler.

4. Release the mouse button when the margin marker is where you want it to be on the ruler.

Final Writer will automatically reformat the paragraph or paragraphs to reflect the new margin.



To change the left or right margin using the dialog:
1. To change the margin(s) of a single paragraph, click the mouse in the paragraph to be 

changed.    To change the margin(s) of multiple paragraphs at once, select the desired 
paragraphs by dragging the mouse through them.

2. Choose Paragraph... from the Layout menu.

3. Enter the appropriate values in the Left and Right Indents area in the Paragraph dialog.

4. Click on the OK button.

Final Writer will automatically reformat the paragraph or paragraphs to reflect the new margin.



To change the first line indent margin using the ruler:
First line indent margin
The first line indent margin tells Final Writer how far to indent the first line of a paragraph. 

1. To change the first line indent margin of a single paragraph, click the mouse in the paragraph 
to be changed.    To change the first line indent margin of multiple paragraphs at once, select 
the desired paragraphs by dragging the mouse through them.

2. Position the mouse on the first line indent margin marker.

3. Press and hold the mouse button and drag the marker horizontally along the ruler.

4. Release the mouse button when the first line indent margin marker is where you want it to be 
on the ruler.

Final Writer will automatically reformat the paragraph or paragraphs to reflect the new first line indent 
margin.



To change the first line indent margin using the dialog:
First line indent margin
The first line indent margin tells Final Writer how far to indent the first line of a paragraph. 

1. To change the first line indent margin of a single paragraph, click the mouse in the paragraph 
to be changed.    To change the first line indent margin of multiple paragraphs at once, select 
the desired paragraphs by dragging the mouse through them.

2. Choose Paragraph... from the Layout menu.

3. Enter the desired value in the First Indents area in the Paragraph dialog.

4. Click on the "OK" button.

Final Writer will automatically reformat the paragraph or paragraphs to reflect the new first line indent 
margin.



To set tab stops using the ruler:
1. To set tab stops for a single paragraph, click the mouse in the paragraph to be changed.    To 

set tab stops for multiple paragraphs at once, select the desired paragraphs by dragging the 
mouse through them.

2. Select a tab type, left, center, right, or decimal,    from the tool bar.

3. Click on the ruler at the point where you wish to insert the tab stop.

All default tab stops to the left of the new tab stop will be removed.

4. Repeat this procedure as often as you like until all tab stops are set.



Tab stops
Tab stops let you align text to form lists, outlines, tables, and other elements precisely.    When you press 
the TAB key while typing, the insertion point will automatically advance to the location of the next tab stop. 
The Final Writer ruler has four different tab stop options, Left tab, Right tab, Center tab, Decimal tab.



Text is aligned left justified at the tab stop



Text is aligned right justified at the tab stop.



Text is centered at the tab stop.



Decimal points are aligned at the tab stop.    This tab type is used mostly for numbers that must be 
properly lined up in a column.    Characters to the left of the decimal point are inserted to the left of the tab 
stop.    Characters to the right of a decimal point are inserted to the right of the tab stop.    Numbers 
without decimals and other text are aligned to the left of the tab stop.



To move a tab stop using the ruler:
1. To move a tab stop for a single paragraph, click the mouse in the paragraph to be changed.    

To move a tab stop for multiple paragraphs at once, select the desired paragraphs by dragging 
the mouse through them.

2. Click and hold the mouse on the tab stop you would like to move.

3. Drag the tab stop horizontally along the ruler until it is located where you want it.

4. Release the mouse button.



To delete a tab stop using the ruler:
1. To delete a tab stop for a single paragraph, click the mouse in the paragraph to be changed.    

To delete a tab stop for multiple paragraphs at once, select the desired paragraphs by 
dragging the mouse through them.

2. Click and hold the mouse on the tab stop you would like to delete.

3. Drag the tab stop below the ruler.

4. Release the mouse button.



Hyphen Hot Zone margin
This margin marker tells Final Writer that when the last word of a line starts before the marker, it is eligible 
for hyphenation.    When you set the "Hot Zone" marker too close to the right margin, your lines will 
appear less ragged along the margin, but you may have excessive hyphenation.    If you set the "Hot 
Zone" marker too far from the right margin, you will have less hyphenation, but your lines will appear 
more ragged.



To move the Hot Zone marker using the ruler:
1. To move the Hot Zone marker for a single paragraph, click the mouse in the paragraph to be 

changed.    To move the Hot Zone marker for multiple paragraphs at once, select the desired 
paragraphs by dragging the mouse through them.

2. Click and hold the mouse on the Hyphen Hot Zone marker.

3. Drag the marker horizontally along the ruler until it is located where you want it.

4. Release the mouse button.



To move the Hot Zone marker using the dialog:
1. To move the Hot Zone marker for a single paragraph, click the mouse in the paragraph to be 

changed.    To move the Hot Zone marker for multiple paragraphs at once, select the desired 
paragraphs by dragging the mouse through them.

2. Choose Paragraph... from the Layout menu.

3. Click the mouse in the Hot Zone data entry area, and enter the desired value.

4. Click on the OK button.



To set justification using the ribbon bar
1. To set justification for a single paragraph, click the mouse in the paragraph to be changed.    

To set justification for multiple paragraphs at once, select the desired paragraphs by dragging 
the mouse through them.

2. Click on the desired justification button.



How paragraph text is aligned or positioned.    In Final Writer, you can align paragraph text in the following 
ways:
Left Justified, Right Justified, Centered, Full Justified.



Text is aligned so that lines start at the left margin (except the first line which starts at the first line indent).



Text is aligned so that lines end at the right margin.



Text is aligned so that lines are centered between the left and right margins (except the first line which is 
centered between the first line indent and the right margin).



Text is aligned so that lines start at the left margin (except the first line which starts at the first line indent) 
and end at the right margin.    In order to do this the program may expand spaces between words.



To set justification using the dialog:
1. To set justification for a single paragraph, click the mouse in the paragraph to be changed.    

To set justification for multiple paragraphs at once, select the desired paragraphs by dragging 
the mouse through them.

2. Choose Paragraph... from the Layout menu.

3. Choose    the desired Text Alignment option.

4. Click on the "OK" button.



Spacing
When text is entered in a document, the space between lines depends mostly on the size of the font 
being used.    Large fonts will have larger areas between lines to allow room for letters that descend below 
the main line of type, such as "y", "j", "p", and "q".

Final Writer enables you to choose from four spacing options--single, 1-1/2, double, and variable.    The 
chart below shows you important information for each type of spacing.

Spacing 
Style

Height of Line Maximum Line 
Height

Single 120% of line's largest font 240 pts.
1-1/2 180% of line's largest font 18 pts.
Double 240% of line's largest font 24 pts.

To set line spacing using the dialog:
1. To set line spacing for a single paragraph, click the mouse in the paragraph to be changed.    

To set line spacing for multiple paragraphs at once, select the desired paragraphs by dragging 
the mouse through them.

2. Choose "Paragraph..." from the "Layout" menu.

3. Click on the desired line spacing option.

4. Click on the "OK" button.



To set hyphenation status using the dialog:
1. To set hyphenation status for a single paragraph, click the mouse in the paragraph to be 

changed.    To set hyphenation status for multiple paragraphs at once, select the desired 
paragraphs by dragging the mouse through them.

2. Choose Paragraph... from the Layout menu.

3. Set the desired status in the On check box.

4. Click on the "OK" button.

NOTE.    In order for hyphenation to occur for a paragraph, the hyphenation feature itself must be turned 
on for the document.



Text and fonts
How to...

Select a font
Select a font size
Set a text style
Set Text Position
Set text case
Set text color



To select a font:
Selecting a font
You may select a font prior to entering text, or you may change the font of existing text.    All font 
commands are executed through the "Font" sub-menu of the "Text" menu.

1. If you are changing the font of existing text, select the text to be changed.    If you are setting a 
font for text that has not yet been entered, set the insertion point where the text is to appear.

2. Choose the desired font from the drop down list on the ribbon bar or open the Font dialog by 
selecting Font... from the Layout menu.

If text was selected, it will be redrawn in the new font.



To set font size:
1. If you are changing the size of existing text, select the text to be changed.    If you are setting 

the size for text that has not yet been entered, set the insertion point where the text is to 
appear.

2. Choose the desired size from the drop down list on the ribbon bar or open the Font dialog by 
selecting Font... from the Layout menu.

If text was selected, it will be redrawn in the new size.



To set text style:
Text may be entered in one of the following styles:

Normal Underline       Strikeout

1. If you are changing the style of existing text, select the text to be changed.    If you are setting 
the style for text that has not yet been entered, set the insertion point where the text is to 
appear.

2. Open the Font dialog by choosing Font... from the Layout menu and select the desired styles 
with the check boxes in the Effects group 



To set text position:
Text may be positioned in one of the following three ways:

Text may be in the normal position.
Text may be in the superscript position.
Text may be in the subscript position.

1. If you are changing the position of existing text, select the text to be changed.    If you are 
setting the position for text that has not yet been entered, set the insertion point where the 
text is to appear.

2. Open the Font dialog by choosing Font... from the Layout menu then choosing the desired 
position from the Position drop down list. 



To set text case:

You may choose from three different case settings for your text.    These settings are:

Normal SMALL CAPS ALL CAPS

1. If you are changing the case of existing text, select the text to be changed.    If you are setting 
the case for text that has not yet been entered, set the insertion point where the text is to 
appear.

2. Open the Font dialog by selecting Font... from the Layout menu and select the desired case 
options in the Effects group.

If text was selected, it will be redrawn in the new case.



To set text color:
1. If you are changing the color of existing text, select the text to be changed.    If you are setting 

the color for text that has not yet been entered, set the insertion point where the text is to 
appear.

2. Open the Font dialog by selecting Font... from the Layout menu and select the desired color 
from the drop down list of colors.



Paragraph styles
In Final Writer you can define, name, and save paragraph styles.    Each paragraph style can have 
paragraph attributes, tab stops, and text attributes assigned to it.

Paragraph styles provide a powerful way of formatting a document.    With a single style you can set the 
font and its size, type style, text alignment (left, right, centered, or full), margins, and tab stops. Paragraph 
styles free you from the need to apply many formatting attributes individually to every paragraph.    For 
example, if you want all section titles to be size 18, in Arial Bold, centered, and underlined, you can apply 
all of these attributes at once, rather than having to set each of these formats to every section title you 
create.    Styles also make changing formats of existing paragraphs easy -- you simply change the 
definition of the style and the changes are automatically applied throughout the document. 

Final Writer also uses styles to format the paragraphs it creates for special sections such as Outline, 
Index, Table of Contents, Table of Illustrations, Endnotes, and Bibliography.    The number of styles that 
can be defined for these types of sections is fixed -- you can not add or remove any of them, only modify 
them.    You can, however, add and remove "Main" styles.    "Main" styles are used for Main, Title Page, 
and Preface sections. 

How to...
Apply a paragraph style
To access the Define Paragraph Styles dialog
Define a new style
Modify an existing style
Delete an existing style
Access the Define Tabs dialog
Define a new tab stop
Modify an existing tab stop
Remove an existing tab stop



To apply a paragraph style:
1. Set the insertion point in a paragraph, or drag the mouse through multiple paragraphs that 

you want to apply a paragraph style to.

2. Choose the desired style from drop down list on the ribbon bar.

Paragraph styles are defined, modified, and deleted using the Define Paragraph Style dialog.



To access the Define Paragraph Styles dialog:
1. Select Styles from the Layout menu.

The Define Paragraph Styles dialog contains a list of paragraph styles along with areas used to define a 
paragraph style.



To define a new style:
New styles can only be defined for the Main sections.

1. Open the Define Paragraph Styles dialog.

2. Choose Main section from the listed section types.

3. Click on the button labeled New.

4. Define the style's attributes.

5. Repeat steps 3 and 4 for each style you want to define.



To modify an existing style:
Only styles defined for the Main sections can be modified.

1. Open the Define Paragraph Styles dialog.

2. Choose Main from the listed section types.

3. In the Style Names list click the mouse on the name of the style you want to modify.

4. Make the desired modifications to the style's attributes.

5. Repeat steps 3 and 4 for each style to be modified.



To delete an existing style:
Only styles defined for the Main sections can be deleted.

1. Open the Define Paragraph Styles dialog.

2. Choose the Main from the list section types.

3. In the "Style Names" list click the mouse on the name of the style you want to delete.

4. Repeat steps 3 and 4 for each style to be deleted.



To access the Define Tabs dialog:
1. Click on the Tab Settings Define... button.

Using the Define Tabs dialog
When you click on the Define... button in the Tab Settings area of the dialog, the Tabs dialog will appear.    
Within this dialog is a list of existing tab stops and a series of action buttons that you use to define new, 
edit existing, and remove existing tab stops from a style.    Up to 8 tab stops may be defined for a style.



To define a new tab stop
1. Access the Define Tabs dialog and click on New.

Default settings for the new tab stop will be provided in the definition area. 

2. Modify the default settings to what you wish them to be.

3. Click on the OK button when you are finished defining the style's tab stops.



To modify an existing tab stop:
1. Access the Define Tabs dialog and click the mouse on the line in the list of tab stops showing 

the tab stop you want to modify.

2. Modify the default settings to what you wish them to be.

3. Click on the OK button when you are finished defining the style's tab stops.



To remove an existing tab stop:
1. Access the Define Tabs dialog and click the mouse on the line in the list of tab stops showing 

the tab stop you want to remove.

2. Click on the OK button when you are finished removing the style's tab stops.



Master Pages
A master page is a place in a Final Writer document where you can define text and graphics that are to 
appear on each of your document’s pages.    There are many uses for master pages, including document 
titles, chapter names, special graphics, dates, page backgrounds, headers, footers, and page borders. 

Every time a new document is created, blank master pages are also created.    If you leave master pages 
blank, they will have no effect on the body of your document.    However, once you have entered text 
and/or graphics on a master page, those items will appear on each page of your document except the 
optional title page. 

If you have set the Left/Right page option , the left master page will be used for items that are to be 
repeated on left-sided pages, and the right master page will be used for items on right-sided pages.    If 
you have not set the Left/Right page option, only items entered on the right master page will affect your 
pages.

Master pages are accessed through entries in the View menu.

How to...
Define left and/or right master pages



To define left and/or right master pages:
1. Select the Left Master or Right Master Page entry in the View menu.

The selected master page will appear and the window title will show which master page is being 
edited.

2. Enter any text or graphics you wish to include as master items.

Remember that any text or graphics placed on a left master page will appear on every left-sided page 
of a document.    Similarly, any text or graphics entered on a right master page will appear on every 
right page of a document.    If you are not using the Left/Right page option, nothing you enter in the 
left master page will appear on your body pages.

3. Return to the body of your documents by selecting Body from the View menu.



Headers and Footers
There are a number of ways in which you may utilize a header or footer.    The most common use for 
headers and footers is for page numbering.    Other common uses are for inserting the date and time that 
the document was written or printed, and for running headlines at the top of each page.

In Final Writer you create headers and footers inside a master page.    At the top of a master page you 
place header items, and at the bottom of the same master page, you place any footer items.

Final Writer is a word processor where text must be entered sequentially from the top of the first page 
down through a document.    This is in contrast to desktop-publishing programs that allow you to start a 
text block wherever you wish.    For example, in a desktop-publishing program, if you want to place text at 
the bottom of a page, you start a new text block at the bottom of a page.    In a word-processor, however, 
you need to advance the insertion point to the bottom of the page by pressing the RETURN key or by 
entering text.    Therefore, when you want to place a footer at the bottom of a Final Writer master page, 
you advance the insertion point to the bottom of the master page.

When you use a master page to define header and footer items, you will probably not want text you enter 
on a body page to be placed on top of the header and footer items.    In order to accomplish this, you will 
need to limit the size of the "Body" area of your page by specifying the height you are using for header 
and footer areas.

Setting Headers and Footers



Page Breaks
Page breaks will occur naturally as you type your document.    Final Writer inserts a page break whenever 
it gets to the end of a page.    You may also manually insert page breaks at any place in your document.

How to...
Insert a page break
Remove a page break



To insert a page break:
1. Set the insertion point where you want the page break to appear in your document.

2. Choose Page Break from the Layout menu.



To remove a page break:
1. Set the insertion point at the beginning of the line of text immediately following the page break 

you wish to remove.

2. Press the Backspace key on the keyboard.



Graphics and Text Blocks
Nothing adds interest to a word processing document like a carefully created, well placed graphic. Using 
Final Writer you can create:

· Diagonal, horizontal, and vertical lines
· Boxes and perfect squares
· Rounded-corner boxes and perfect squares
· Ovals and perfect circles
· Movable text blocks

In addition, you can also import into Final Writer various raster image file types including .bmp, 
dib, .tif, .gif,    .jpg, and others.

Each graphic in Final Writer is treated as an independent object and can be deleted, sized, rotated, 
grouped, or moved according to your needs.    Text can be made to automatically flow around or on top of 
any graphic objects according to your instructions. 

How to...

Use the properties dialog
Create graphics
Import images
Change graphic properties
Create text blocks
Select graphics
Delete graphics
Size graphics
Move graphics
Rotate graphics
Modify an object's settings
Specify exact size and position of graphics
Crop an image
Cancel a graphic operation
Group objects



Graphic Properties Dialog Tabs
There are seven properties dialog tabs each corresponding to one of the graphic types supported in Final 
Writer.    These dialogs are:

Imported Graphic Properties
Line Properties
Box Properties
Oval Properties
Polygon Properties
Text Block Properties
OLE Properties 

These dialogs may be used in several ways:

· Set permanent default values for a type of graphic object.    When a new document is created, 
these default values define the attributes for graphic objects placed in the document.

· Set temporary default values for a type of graphic object.    When a new graphic object is 
created, these temporary default values are used as the attributes for the objects, however the 
permanent default values remain the same.

· Reset the attributes of existing objects.    Attributes of any existing graphic or text block object 
can be modified at any time.



Change graphic properties
To change the properties of an individual graphic element in your document:

1. Select the graphic.
2. Choose Properties from the Graphics menu.



Creating lines, boxes, and ovals
Graphic elements like lines (horizontal, vertical, and diagonal), rectangles/squares, and ovals/circles may 
be created in your document using the tool icons found in the Drawing Tools toolbar 

When you create a graphic, Final Writer creates it using the default settings for the type of graphic being 
created.    For example, if the default settings for a line are 2 points thick and colored in red, when you 
draw a new line, it will be drawn as a 2 point, red line. You can, of course, change a graphic's current or 
default settings at any time.

You have two choices of how a new graphic is to be drawn when you create it.    One choice is to set the 
default settings to the way you want the graphic drawn and then create the graphic.    The other choice is 
to create the graphic using the default settings, and then after the graphic is drawn, change its settings to 
suit your needs.    In the instructions that follow for creating graphics, the default settings are defined and 
then the graphic is created. 

How to...
Create lines
Create boxes
Create ovals



Lines
In Final Writer you can draw lines at any angle with its thickness ranging from hairline (thinnest at any 
given resolution) to 12 points.    Lines may be created in any of the 16 colors defined.    Text can be made 
to flow around or on top of lines.

Lines are drawn to conform with the default settings for new lines.    If you want to override these settings, 
you can either access the Line properties tab and define line properties before you draw a line, or draw a 
line and while it is selected access the dialog to change its settings. 

How to...
Draw a line
Access the Line properties tab



To draw a line:
1. Click on the desired line tool icon.

The Constrained Line tool will produce perfectly horizontal, vertical, or 45° diagonal lines.    The Line 
tool will produce lines of any angle.    Once a line is drawn, you can change its angle no matter which 
tool you used to create it.

2. Position the mouse pointer at the place in your document where you wish your line to begin.

3. Hold the mouse button down and drag the mouse in the direction you want the line to be 
drawn. 

4. Once the line has reached the desired length, release the mouse button.



To access the Line Properties tab:
1. Select Properties... from the Graphics menu.

2. Click the Lines tab.

Set the Text Flow, Text Flow Distance, Weight and Color..



Text Flow options
This setting defines the way in which text is to flow around (or over) a graphic object.    Text may flow on 
the left or right side of the object, following either the object's contour or a vertical line created by the 
object’s frame.    If None is selected, the line will become a background element, and text will flow over it.



Text Flow distance
The amount of space between the objects outline and any text that flows next to it.    For example, a 
setting of 0.25 will leave 1/4" of empty space between the object and text flowing around it. 



Line Weight
The thickness of the object's border. 



Color
The fill or border color.



Boxes
Final Writer lets you create boxes in any width and height combination.    A box can have a border and be 
filled with a color or left empty.    Special options for boxes are the ability to make boxes with rounded 
corners and/or perfect squares.

Boxes are drawn to conform with the default settings for new boxes.    If you want to override these 
settings, you can either access the Box properties tab and define settings before you draw a box; or draw 
the box and while it is selected access the dialog and change the settings. 

How to...
Draw a box
Access the Box properties tab
Draw a perfect square



To draw a box
1. Click on the    Rectangle tool icon in the Drawing Tools toolbar.

2. Position the mouse pointer at the place in your document where you wish your box's corner to 
begin.

3. While holding the mouse button down, drag the mouse in the proper direction to draw the box. 

4. Once the box has reached the desired size and shape, release the mouse button.



To access the Box properties tab
1. Select Properties from the Graphics menu and click the Box tab.

Set the Text Flow, Text Flow Distance, Borderand Interiorproperties.



The outline of a graphic object.    You can set the border's Weight and Color. in the properties tab.



The fill pattern and Color.of the shape. A transparent interior indicates that the shape is left empty.



To draw a rounded-corner box:
1. When drawing a box, hold the left ALT key before pressing the mouse button, and continue to 

hold the ALT key down while dragging the mouse. 



To draw a perfect square:
1. When drawing a box, hold a SHIFT key before pressing the mouse button, and continue to 

hold the SHIFT key down while dragging the mouse. 



Ovals
Final Writer lets you create ovals in any width and height combination.    An oval can have a line as a 
border and can be filled with a color, or left empty.    A special option for ovals is the ability to make ovals 
as perfect circles.

Ovals are drawn to conform with the default settings for new ovals.    If you want to override these 
settings, you can either access the Oval properties tab and define settings before you draw an oval or 
draw the oval and while it is selected access the dialog and change its settings. 

How to...
Draw an oval
Access the Oval properties tab
Draw a perfect circle



To draw an oval:
1. Click on the Oval tool icon.

2. Position the mouse pointer at the place in your document where you wish your oval to begin.

3. While holding the mouse button down, drag the mouse in the proper direction to draw the 
oval. 

4. Once the oval has reached the desired size and shape, release the mouse button.



To access the Oval properties tab
1. Select Properties... from the Graphics menu and click the Oval tab.

Set the Text Flow, Text Flow Distance, Border and    Interior properties.



To draw a perfect circle:
1. When drawing an oval, hold the left SHIFT key before pressing the mouse button, and 

continue to hold the SHIFT key down while dragging the mouse.



Importing graphics
In addition to graphics drawn with Final Writer’s drawing tools, you may also import pictures in most raster 
file formats. Imported graphics may be inserted before or after text is entered.    Text will always reformat 
to flow around a graphic according to that graphic’s text flow settings.

Imported graphics are drawn to conform with the default settings for new imported graphics.    If you want 
to override these settings, you can either access the Import properties dialog and define settings before 
you import a graphic; or import the graphic and while it is selected access the dialog and change its 
settings. 

How to...
Import a graphic
Access the Import properties tab



To import a graphic:
1. Select Insert... from the Graphics menu.

2. Select Picture from the list of graphic objects, then click OK.

3. Use the file dialog to select the graphic you want to import.

4. Click the OK button.



To access the Imports properties tab
1. Select Properties... from the Graphics menu.

Set the Text Flow, Text Flow Distance, Borderand    Storageoptions.



Storage Options
The Embedded option actually stores a copy of the inserted graphic in your document.

The Link option does not save the graphic itself in your document, but rather saves a link to that graphic 
in the form of a filename.

The Link option is helpful when your graphic takes up a great deal of memory or when you anticipate 
changing your graphic before your document reaches its final draft stage.    In this latter instance, the link 
will open the revised graphic and insert it when you reopen your document.



Text blocks
You can use Final Writer's text block feature to create short lengths of text that are independent of the text 
in your document.    Text blocks may be moved anywhere on a page, resized, rotated, and modified.

How to...
Create a text block
Change the text or settings used in a text block



To create a text block
1. Click Text Block button on the toolbar.

2. In the Content edit box, enter the text of the text block you are creating.

3. Modify or define Text Flow, Text Flow Distance, and Type Specs to suit your needs, 
or use the settings as they are.

4. Click the OK button.



To change the text or settings used in a text block
1. Double-click the mouse on the text block.

2. Make any desired modifications.

3. Click the OK button.

The text block will be redrawn according to the new settings.



Selecting objects
Final Writer treats all lines, boxes, ovals, images, and text blocks as independent objects.    In order to 
size, move, crop, delete, rotate, or redefine a graphic you must first select it.

How to...
Select a single object
Select one or more objects by drawing a marquee



To select a single object or multiple objects with the mouse:
1. Click the mouse on the Select tool in one of the toolbars.

2. Click the mouse on the object you want to select.

3. To select additional objects, hold the SHIFT key down, and click on them.

Notice that "anchor points" (tiny boxes in the corners and midpoints of the graphic) appear around or 
on the object.    The presence of anchor points indicates that the object has been selected.



To select one or more objects by drawing a marquee
1. Click the mouse on the Select tool in one of the toolbars.

2. Position the mouse pointer above and to the left of the first object you want to select.

3. Hold down the left mouse button and drag the mouse to the right and bottom of the last object 
you want to select.

As you drag the mouse the program will draw a marquee rectangle on the screen.    When you 
release the mouse, all graphics that fit within the marquee will be selected.

4. Release the mouse button.



Deleting objects
Lines, boxes, ovals, images, and text blocks may be deleted at any time.

How to...
Delete one or more objects



To delete one or more objects:
1. Select the object(s) you wish to delete.

2. Press the Delete key on your keyboard, or choose Clear from the Edit menu.

The selected objects will be deleted.



Sizing objects
A graphic object already inserted in a document can be made smaller or larger at any time.

How to...
Change the size of an object in your document



To change the size of an object in your document:
1. Select the object to be sized.

2. Press and hold the mouse on one of the anchor points at the corners or midpoints of the 
selected graphic.

3. Drag the mouse inward toward the middle of the graphic to reduce its size.    Drag the mouse 
outward away from the middle of the graphic to increase its size.

4. Release the mouse when the graphic has reached the desired size.



Moving objects
An object can be moved anywhere within a document.

How to...
Move an object from one location to another



To move an object    from one location to another:
1. Select the object to be moved.

2. Click and hold the mouse button on the selected object while dragging the mouse to the 
desired new location.



Rotating objects
Most graphic objects can be rotated in 90 degree increments.    In addition, they can be flipped along their 
horizontal and vertical axis.

How to...
Rotate an object



To rotate an object:
1. Select the object to be rotated.

2. Rotate or flip the object using the two rotation buttons or the two flip buttons in the Drawing 
Tools toolbar.



Modifying an object's settings
An existing object can have its settings modified at any time.    These settings are the ones that comprise 
the settings dialog for that type of object. 

How to...
Modify an existing object's settings



To modify an existing object's settings:
1. Choose the Select tool from the Drawing Tools toolbar.

2. Double-click the mouse on the object that is to be modified, or click once on the object to be 
modified, and choose the Properties... from the Graphics menu.

3. Change any of the settings you wish to change. 

4. When you are finished making changes, click on the "OK" button.



Specifying exact size and location
An alternative way of sizing and moving graphics with the mouse is to use the Position dialog.    Access to 
the Position dialog is only possible when viewing an object's properties.

How to...
Specify exact size and/or position settings



To specify exact size and/or position settings:
1. Open the object's property dialog.

2. Click on the "Position" button.

3. Modify the size and position data to your desired values. 

4. When you are finished making changes, click on the OK button.

The program will return to the settings dialog.

5. Click on the "OK" Button.

Final Writer will redraw the selected object using the new values.



Cropping images
Cropping is the process of cutting out unwanted portions an image.    The cut portions are limited to 
rectangular areas on the left, top, right, or bottom of an image.    An image inserted in a document can be 
cropped at any time.

How to...
Crop an image



To crop an image
1. Click the Crop tool on the Drawing Tools toolbar.

2. With the mouse, select the image you want to crop.

Anchor points will appear.

3. Press and hold the mouse on one of the anchor points in the corners or midpoints of the 
selected image.

4. Drag the mouse to crop the area of the image the anchor point is in.

5. Release the mouse when you have cropped the desired amount of the image.



Canceling graphic actions
You can cancel a size, move, or crop operation by pressing the right mouse button before releasing the 
left mouse button.



Grouping objects
Many times it is convenient to group more than one object together.    A group of objects can be selected, 
moved, rotated, and resized all together, rather than each object separately. 

How to...
Group objects
Ungroup objects



To group objects:
1. Select the objects that are to be grouped.

2. Choose Group from the Graphics menu.

Group is disabled if less than two objects are selected.



To ungroup objects:
1. Select the group to be ungrouped.

2. Choose UnGroup from the Graphics menu.

UnGroup is disabled in the menu if the selected object is not a group.



All capital letters.



ascender
The part of a lowercase letter that moves above the x-height (letters with ascenders include h, t, f, and l). 
Leading or line spacing must allow enough room for ascenders.

ASCII      File format used in most text editors.

baseline      An imaginary line that runs along the bottom of letters.    A portion of some letters descend 
below the baseline. 

body copy      A page or column of body type.

body type      Type sized 12 points or smaller.

boldface type      Type that is blacker and heavier than its normal appearance.

bullet      A bold dot or mark that is used to draw attention or to set off an element in a series or list.

cache      An internal memory listing used by the speller to store recently used words, thereby eliminating 
the need for disk accesses to verify their spelling.

column      A section of a page that runs from top to bottom. 

copy     A word used to refer to written material.

crop      The act of removing unwanted areas of a graphic.

descender      The part of a lowercase that descends below the baseline.    Leading or line spacing must 
leave enough room for descenders.

display type      Any type larger than 12 points, such as that used for headlines and titles.

flush left      Type that is aligned even with the left margin.

flush right      Type that is aligned even with the right margin.

font      The word used to refer to a complete family of type in a particular style or design.

gadgets      Areas on a window or requester that are clicked on to perform some action.

hanging indent      An indent where the second and all following lines of a paragraph are indented a 
preset amount of space.

hyphen hot zone      The point in a line of text where a word becomes eligible for hyphenation.

italic type      Type that slants to the right.    May be used instead of underlining to designate names of 
publications, etc.    Also may be used for emphasis or decoration.

leading      The amount of space between lines of type, as measured in points.    Leading rhymes with 
bedding.

lowercase      Small (non-capitalized) letters.

orphan      A solitary line of type at the top of a page or column; usually the continuation of text in the 
previous column.

pica      One-sixth of an inch, or 12 points.

point      A unit of measure applied to type.    There are 72 points in an inch.

RAM      The abbreviation for random access memory.    This is your computer's internal memory bank 



which is used for running programs such as Final Writer.

sans serif type      A typeface in which all strokes in the letters are similar in size and do not have serifs.    
The beginning words of this entry, "sans serif type" appear in a sans serif type.

script      Type that resembles calligraphy or handwriting.

scroll gadget      The Final Writer gadget that enables you to scroll through your document.    The scroll 
gadget has three components:    the scroll bar, the scroll box, and the scroll arrows.

serif    Small finishing strokes appearing at the end of a letter stroke.    The definition portion of this entry appears in 
a serif typeface.    The beginning word "serif" appears in a sans-serif face.



Capital letters that appear smaller than regular capital letters for a specified point size.



Side-by-side headlines in the same size and style - An undesirable occurrence.

typeface      A particular style of type.

upper case      Capital letters.

white space      The space on a page that is not occupied by text or graphics.

widow      A line of type at the bottom of a page or column; usually the beginning of text in the next page 
or column.

x-height      The height of the lowercase x in a certain typeface.



Paragraph Dialog

This dialog is displayed by using the Paragraph command in the Layout menu or the Define Paragraph 
button in the Styles dialog.

Indents

Sets the paragraph indentation relative to the page margins.
Left
Right
First

Line Spacing

Sets the distance between lines within the paragraph
Single
1 1/2
Double

Text Alignment

Sets the arrangement of text lines within the paragraph
Left
Right
Center
Full

Hyphenation 

Sets the hyphenation options for the paragraph
On
Hot Zone

Set Default



Check this box to save the current settings in this dialog as Final Writer’s defaults.



The distance from the document’s left page margin to the paragraph’s left edge.



The distance from the document's right page margin to the paragraph’s right edge.



The distance from the document's left page margin to the beginning of the paragraph’s first line.



Lines are spaced according to point size and leading values of the largest font in the line.



Lines are spaced according to 1 1/2 times the point size and leading values of the largest font in the line.



Lines are spaced according to 2 times the point size and leading values of the largest font in the line.



Check this option to enable hyphenation for this paragraph.    For hyphenation to occur it must also be 
enabled for the document.



Define Tabs Dialog
This dialog is used to define the tab stops in a paragraph style.    It is accessed from the Styles dialog in 
the Layout menu.

Tabs

A list of defined tabs.    Alter any entry by selecting it and using the following dialog controls.
Type

Sets the tab type.
Position

Sets the position of the tab relative the left margin.
New

Adds a new tab stop to the list.    Alter the tab type and position using the controls above after adding it to 
the list.    This button is disabled when the maximum number of tab stops has been defined.
Remove

Remove the selected tab stop from the list.
Undo

Restores the selected tab stop to its previous settings.    This control is not available if a restoration cannot 
be performed.



Section Dialog

This dialog is used to set the properties of the current section in the document. It is accessed by choosing 
Section from the Layout menu.

Attributes set in this dialog are:
Layout Tab

Edit Area
Columns
Headers & Footers
Name

Pages Tab

Text
Number By
Prefix
First #
Format



Page Setup Dialog

Use this dialog to set the page characteristics in your document.

Attributes set in this dialog are:
Paper Size
Orientation
Pages



Styles Dialog

Use this dialog to create and edit paragraph style entries to aid in formatting your document.

Section List
Styles List
New, Remove, and Revert
Style Name
Paragraph Settings
Tab Settings
Type Settings
Table of Contents
Outline
Set Default

See Paragraph Styles for additional information.



New adds a new style to the list of styles.    Remove removes the selected style from the list of styles.    
Revert returns a selected style to its previous settings.    These buttons are only available for Main section 
styles.



Choose a section type from this list to view the paragraph style available for that section.



Defined paragraph styles for the selected section.



Name assigned to paragraph style.



The Define... button accesses the Paragraph dialog. Check the Apply if you want Paragraph dialog 
attributes assigned with the style.



The Define... button accesses the Tabs dialog. Check the Apply box if you want the tab stops set in the 
Tab dialog to be assigned with the style.



The Define... button is used to access the Type Specs dialog.    Check the Apply box if you want Type 
Specs settings to be assigned with the style.



If paragraphs set with the style being defined are to generate an entry when the Table of Contents section 
is created, select from this list the level of Table of Contents entry to be generated.    If no Table of 
Contents entry is to be generated, choose No.



If paragraphs set with the style being defined are to generate an entry when the Outline section is 
created, select from this list the level of Outline entry to be generated.    If no Outline entry is to be 
generated, choose No.



Create & Choose Sections Dialogs
Use these dialogs to create and update sections.    Choose sections to work with in your document, or you 
may delete sections.    You access these dialogs from the commands in the Sections menu.

Section List
Properties

See also:
Section Dialog
Sections



From the entries in this list choose the section you want to create, update, go to, or print.



Click this button to set the properties for the selected section.    This button is only visible when creating or 
updating a section.



Choose Section Dialog

Use this dialog to choose a section in your document.    Access the Choose Section dialog from Go To in 
the Sections menu,    Delete in the Sections Menu, or Print in the Files menu.

From the list of available sections choose the section you wish to go to, delete, or print and then click on 
OK.



Delete Section Dialog

Use this dialog to remove a section and its contents from your document.    Access this dialog from Delete 
in the Sections menu.

Choose the section you wish to delete from the list of available sections, then click OK.

Note: Your document must have at least one Main section.



Edit Bibliography Dialog

Use this dialog to add to and edit the Bibliography entries for your document.    Access this dialog from 
Edit Bibliography in the Sections menu.

The Bibliography Dialog has the following components:

List of Entries
Bibliography Entry
New
Save
Delete

See Also:
Bibliography



Contains the bibliography entries in your document. Select an entry in this list to view or edit a 
bibliography entry.



The complete text of the bibliography entry is displayed in this space for editing.



Click this button to clear the contents of bibliography entry box and begin a new entry.



Click this button to save the current contents of the bibliography entry box in your document.    If you do 
not click this button before clicking the New button, selecting a different entry from the entry, or closing the 
dialog, the changes made will not be saved.



Click this button to remove the selected item in the entry list from the bibliography.



Insert Endnote Dialog
Use this dialog to enter the contents of a newly inserted endnote.    This dialog appears when you select 
the Insert Endnote command from the Sections menu.

Enter the text you wish to associate with the endnote mark in the box provided in this dialog.



Edit Endnotes Dialog
Use this dialog to edit the comments for endnotes you have inserted in your document.

The Endnote Dialog has the following components:

List of Endnotes
Endnote Text
Save

See Also
Endnotes



Shows a list of the endnotes inserted in your document.    Choose an item in this list to view or edit its 
complete text in the Endnote Text Box.



Contains the complete text for the endnote selected in the List of Endnotes for editing and viewing.



Click this button to save any changes you make to the text in the Endnote Text box.    If you do not click 
this button before selecting another entry, or closing the dialog, the changes you made will not be saved.



Edit Index Dialog
Use this dialog to add and edit index entries to your document.    Access this dialog from the Edit Index 
command in the Sections menu.

The Edit Index dialog has the following components:

Index Entries
Enter Word or Phrase
New
Save
Delete
Delete All

See also
Index



Contains the words and phrases which will appear in the document's index.



Enter a word or phrase to be added to the index here.



Clears the contents of the Enter Word or Phrase box without saving it.



Remove the word or phrase selected in the Entry List from the index.



Add word or phrase in the Enter Word or Phrase box to the list of index entries.



Remove all words and phrases from the index entry list.



Insert Graphic Dialog
Use this dialog to insert a graphic object in your document.    Access this dialog from the Insert command 
in the Graphics menu.

Graphic Type

Check the box of the graphics object you wish to insert.
Properties

Click this button to change the graphic properties from the defaults.



Graphic Properties Dialog

Use the tabs in this dialog to set the properties for the graphic objects in your document. 
You can access this dialog from the Properties command in the Graphics menu, the Properties button in 
the Insert Graphics dialog, and by doubling clicking with your mouse on an object in your document.
Choose the tab corresponding to the graphic object types whose properties you wish to set.

Some or all of the following components appear in this dialog depending upon the properties associated 
with object being set.

Text Flow

Options
Distance
Border
Interior
Storage
View As

See Also
Creating Graphic Objects



This option is available for imported images.    Select Image to view the actual picture.    Select 
Placeholder to display a crossed box where the image would be.    Displaying a placeholder rather than 
the image results in faster screen updates.    The image is always used for printing regardless of how this 
option is set.



Find Dialog
Use this dialog to search for text in your document.    Access this dialog from the Find command in the 
Tools Menu.

The Find dialog has the following components:

Find What
Match Case
Find Next



Enter the word or phrase you wish to search for in your document



Check this box to find only that text that matches the case of the text entered.



Replace Dialog
Use this dialog to search for text in your document and optionally replace it with other text.    Access this 
dialog from the Replace command in the Tools menu.

The Replace dialog has the following components:

Find What
Replace With
Match Case
Find Next
Replace
Replace All



Enter the text you wish to substitute for the found text.



Click this button to replace the currently selected text in the document with the Replace With entry and 
find the next occurrence of the text you're searching for in the document..



Find the next occurrence of the Find What entry in your document.



Find each occurrence of the Find What entry in your document and replace it without asking with the 
Replace With entry.



Speller Dialog
Use this dialog to verify the spelling of words in your document.    Access this dialog with the Speller 
command in the Tools menu.

The Speller dialog has the following components:

Word
Change To
Alternatives
Spell
Find
Replace
Suggest
Skip
Add
Delete
User

See Also
Using the Speller



The Speller places possibly misspelled words in this box for your verification.    You can also type a word 
in this box and verify by clicking the Find button.



The word which will be used to replace the currently selected word in the document appears here.    You 
can fill this box by picking a word in the Alternatives list, or by directly entering text in it.



Displays a list of possible correct spellings of the misspelled word.    This list of words is created when you 
click the Suggest button, or automatically if the Auto Suggest option is checked in the Speller tab of the 
Customize dialog.    If you click the User button, the contents of the User dictionary is displayed in this list. 
In either case clicking on a word in this list causes it to be placed in the Change To box.



Clicking this button causes the speller to begin or continue searching your document for misspelled 
words.    When a misspelled word is found, it is selected in the document and placed in the Word edit box.



Clicking this button instructs Final Writer to check the spelling on the word that is currently in the Word 
edit box.



Click this button to replace the highlighted text in your document with the text in the Change To edit box.



Click this button to instruct the speller to ignore other misspellings of this word in the document and to 
continue the spell checking of your document.



Click this button to add the word displayed in the Word edit box to the user dictionary.



Click this button to delete the user dictionary entry currently selected in the Alternatives list.    This button 
is only enabled when the user dictionary is displayed in the Alternatives list.



Click this button to display a list of correctly spelled alternatives to the misspelled word.



Click this button to display the contents of the user dictionary in the Alternatives list.    You may delete 
entries from the user dictionary by selecting them in the list, then clicking the Delete button.



Thesaurus Dialog
Use this dialog to find alternative words for your document.    Access the Thesaurus dialog with the 
Thesaurus command in the Tools menu.

The Thesaurus dialog contains the following components:

Word
Find
Replace
Display Area

See Also
Using the Thesaurus



Displays the word whose meaning is being displayed or will be found when the Find button is clicked.    
You can enter text directly into this box from your keyboard, or click on a word in the display area.



Instructs the thesaurus to display the meanings and alternatives to the word currently in the Word edit 
box.



Replaces the selected text in the document with the word in the Word edit box.



Displays the definition and alternatives for the most recently found word.



Easy Header/Footer Dialog
Use this dialog to conveniently define header and footer areas for your document. Access this dialog with 
the Easy Header/Footer command in the Tools menu.

The Easy Header/Footer dialog has individual tabs for defining the header and the footer each containing 
the following components:

Text
Inside, Center, Outside
Define Type Specs



Enter the text you wish to include in your header/footer in this edit box.    It will be placed in the 
header/footer according to which area, if any, Inside, Center, or Outside has the text option checked.



Specify what text you want to appear in these areas of the header/footer by checking the appropriate box 
for each.



Click this button to choose the font characteristics for the text appearing in the header/footer.



Easy Page Number Dialog
Use this dialog to conveniently set up page numbers in the header or footer area of your document.    
Access this dialog from the Easy Page Number command in the Tools menu.

The Easy Page Number Dialog consists of the following components:

Insert In
Position
Pages



Select where you wish to place the page number.



Choose whether the page number will be left, right, or center page.



Choose which pages are to show the page number.



Doc Items Dialog Tab
Use this tab to set general property options in your document.    This tab is part of the Customize dialog 
which is accessed from the Customize command in the tools menu.

The Doc Items dialog tab has the following components

Date Order
Date Format
Time Format
Language
Decimal
Drag & Drop Editing
Tabs Every



Select the order in which you want the day, month, and year to appear in dates that Final Writer inserts in 
your document.



Select the format of the dates that Final Writer inserts in your document.



Select the format of time text that Final Writer inserts in your document.    If you choose 12 hour, the time 
will be appended with AM or PM as appropriate.



Specify the language to be used by the spelling, hyphenating, and thesaurus features of Final Writer.    
Only one language is provided with Final Writer.    You may purchase and install additional languages 
which will then appear in this list.



Choose whether to represent decimal points as commas or periods in your document.



Check this box to enable the drag and drop editing feature



Enter the number, in measurement units, at which to space the document's default tabs.



User Buttons Dialog Tab
Use this dialog to configure the Final Writer's toolbars.    This tab is part of the Customize dialog which is 
accessed through the Customize command in the Tools menu.

The User Buttons dialog tab consists of the following components:

Buttons
Toolbar Names
Toolbar Buttons
Show
Commands/Macros List
Set Button

See Also
User Toolbar Options



A list of button icons you can use in your toolbar. Although you can assign any command or macro to any 
image, most button images have default commands assigned for your convenience.    Click an image in 
this list to display its default command.



Choose a name from this drop down list to edit the buttons in that toolbar.    You can change the name of 
a toolbar by clicking your mouse in the edit box and entering a new name.



The buttons and their associated commands in the selected toolbar.



Select Commands to display the list of commands that can assigned to buttons or select Macros to 
display the list of text clips that can be assigned to buttons.



Contains a list of commands or text clip macros that can be assigned to toolbar buttons.



Click this button to assign the selected command or text clip macro to the selected button in the toolbar 
button list.



ASCII I/O Dialog Tab
Use this tab in the Customize dialog to set how Final Writer imports and exports data in ASCII files.    
Access this dialog with the Customize command in the Tools menu.

The ASCII I/O Dialog Tab contains the following components:

Input Options
Output Options



The Input options determines when Final Writer creates new paragraphs when importing an ASCII file.



The Output Options determines what line formatting Final Writer applies when exporting a document as 
an ASCII file.



Spelling Dialog Tab
Use this tab in the Customize dialog to configure the Final Writer speller.    Access this dialog with the 
Customize command in the Tools menu.

The Spelling dialog tab has the following components:

Automatic Suggestions
Report As Errors
Type & Spell



Hyphenation Dialog Tab
Use this tab in the Customize dialog to set the document hyphenation options.    Access this dialog with 
the Customize command in the Tools menu

The Hyphenation dialog tab has the following components:

Hyphenation
Method



Save Items Dialog Tab
Use this tab in the Customize dialog to set which options are saved as part of the document file.    Access 
this dialog with the Customize command in the Tools menu.

The Save Items dialog tab has the following components:

Save With Each Document
Auto-Save



Sections Dialog Tab
Use this tab in the Customize dialog to set the layout of the various section types in your document.    
Access this dialog with the Customize command in the Tools menu.

The Sections dialog tab has the following components:

Sections List
Set Button



Choose the section whose characteristics you wish to set from this list.



Click this button to display the Section dialog for the section selected in the list.



Zoom Dialog
Use this dialog to set the magnification factor at which to view your document.    Access this dialog with 
the Zoom command in the View menu.

The Zoom dialog has the following components:

Zoom To %
Page Width
Full Page
Set



Choose one of the fixed percentages to display your document at that magnification



Choose this option to always view the entire page width regardless of the size of your window.



Choose this option to always display an entire page regardless of the size of your window.



Choose this option to set the magnification to a percentage you enter in the edit box.



View Options Dialog
Use the tabs in this dialog to configure the visible components of your work area.    Access this dialog with 
the Options command in the View menu.

The View Options dialog has the following components:

General Tab

Measure In
Rulers
Page Guides

Toolbars Tab

Toolbars
Click Tabs
Customize



Choose the measurement unit type to display in rulers and dialogs.



Choose which rulers are visible.



Choose which page guides are visible.



Choose which toolbars are visible.



Choose which click tabs are visible.



Click this button to display the customize user buttons dialog.



Go To Page Dialog
Enter the page number of the page in the current section you wish to go to.



Type Specs Dialog
Use this dialog to set the type characteristics of text in your document.    Access this dialog from the Font 
command in the Layout menu and style and property dialogs where font specification is an option.

The Type Specs Dialog has the following components:

Font
Size
Script
Font Style
Position
Color
Effects
Set Default



Choose the name of the font you wish to use from this list containing the fonts available on your system 
and chosen printer.



Choose the point size of the type from the drop down list, or enter the size directly into the edit box with 
your keyboard.



Choose the type of script from this list.



Choose the attributes you wish the type to have from this list.



Choose Normal, Subscript, or Superscript positioning here.    If you choose subscript or superscript, Final 
Writer will also adjust the size of the font as appropriate for the specified point size.    The change in point 
size is not reflected in the sample text displayed in the dialog.



Choose the text color from this list.



Check the effects you wish to apply to the text.    You may select only one of the capitalization options.
Capitalization options are not reflected in the sample text displayed in the dialog.



Save Text Clip Dialog
Use this dialog to save the selected text as a formatted text file which can later be inserted into Final 
Writer documents as Text Clips.    Access this dialog from the Save Text Clip command in the Files menu.

Enter a descriptive name for the selected text in the space provided then click OK to save.    This name 
will appear in the list of text clips that appears in the Insert dialog and the Macro command list in the 
toolbar configuration dialogs.



Insert Item Dialog
Use this dialog to insert a text field into your document.    Access this dialog from the Insert Item command 
in the Layout menu.

Choose the type of field you wish from the list in this dialog and click OK.    The selected field will be 
inserted in your document at the current insertion point.



Text Clips Dialog
This dialog displays a list of available text clips for insertion in your document.    This dialog appears when 
you select the Insert Item command from Layout menu and you select Text Clip from the list of insertable 
items. 

To Insert a Text Clip

Choose the text clip you wish to insert from the list and click the Insert button to place it in your document 
at the current insertion point. 

The names that appear in the list are those of text clips that have been saved with the Save Text Clip 
command in the Files menu. 

If you have no further use for a saved Text Clip, you may use this dialog to delete it.

To Delete a Text Clip

Choose the name of the Text Clip you wish to delete from the list, then click the Delete button.

See Also
Creating a text clip



Update Item Dialog
Use this dialog to choose which text fields in your document you wish to update.    Access this dialog from 
the Update Items command in the Layout menu.

Check the item types you wish to update, the click OK.

See Also
Updating dates and times in your document



Sort Dialog
Use this dialog to choose the sort order of selected paragraphs in your document.    Access this dialog 
with the Sort command in the Tools menu.

High To Low
Low To High

Click OK to rearrange the selected paragraphs in the sorted order.



Sort in alphabetical order.



Sort in reverse alphabetical order.



Select Merge Records Dialog
Use this dialog to specify which records in your data files will be used for the merge print.
This dialog appears when the Mail Merge command is selected from the Tools menu.

Rows
Range



Check All to merge all the records in your data file.    Check Range to set a starting and ending record in 
the From and To edit boxes.



Enter the number of the first data record you wish to merge in the from box and the number of the last 
record in the To box.    The Range option under Rows must be checked for these controls to be available.



Add To Index Dialog
This dialog appears when the Add to Index command is selected from the Sections menu and more than 
one word is selected in the document. 

Single Entry
Entry for each word



Select this to have the selected words appear in the index a phrase.



Select this to have an individual entry for each of the selected words.



Customize Dialog
This dialog is accessed with the Customize command in the Tools menu.    Use the tabs in this dialog to 
set default properties for the current and other documents.

Doc Items
User Buttons
ASCII I/O
Spelling
Hyphenation
Save Items
Sections



Add To User Dictionary

Specify how you want the word you are adding to be capitalized.

· If you click Exactly As Typed, the capitalization will appear just as you enter it regardless of the word’s 
position in the sentence.

· Clicking Only At First of Sentence capitalizes the word only when it is the first one in the sentence.




