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ABC OLE Automation 

You can control this version of ABC Viewer using OLE Automation. (You can also control ABC 
FlowCharter.) This is an advanced feature that requires Visual Basic, knowledge of programming in Visual 
Basic or C++, knowledge of ABC FlowCharter, and knowledge of ABC Viewer.

Using ABC OLE Automation is described in a help file that comes with ABC FlowCharter. When you 
installed ABC FlowCharter, it installed that help file and its related ABC FlowCharter help file.

This help system is contained in the file AUTOMATE.HLP. If you wish, you can order the ABC OLE 
Automation Programmer's Guide with the order form included in your copy of ABC FlowCharter. 
Alternatively, you can order the book by calling 1-800-603-0074. The guide is a printed version of the 
information included in the help system.

There are several ways you can access the ABC OLE Automation help file. You can run the file from this 
help. You can run it using the Windows File Manager. You can run it using Excel 5.0 (which also lets you 
browse through the language elements and see quick descriptions of them).

Click a topic to learn how to access ABC OLE Automation help
Accessing ABC OLE Automation Help from ABC FlowCharter Help
Accessing ABC OLE Automation Help using Excel 5.0
Accessing ABC OLE Automation Help using the File Manager
Accessing ABC OLE Automation Help from Visual Basic

Related Topics
Jumping to Visual Basic help



Accessing ABC OLE Automation Help from ABC FlowCharter Help 

The help for ABC OLE Automation is linked to the ABC FlowCharter help. To the right of selected buttons, 
commands, dialog boxes, and areas of dialog boxes are buttons labeled Automation. (There is one to the 
right of the title of this help topic. It goes to the Contents of the help for ABC OLE Automation.) If you click 
one of those buttons, you go to the ABC OLE Automation help for a related property or method. Be sure 
to check the Related Topics in the ABC OLE Automation help to find other properties or methods that are 
related to the ABC FlowCharter area you are working in.

When a property or method has an equivalent ABC FlowCharter command, a button labeled "ABC 
Equivalent" appears to the right of the topic title. You can click on the button to go to the ABC FlowCharter 
topic that includes a description of the related command, button, option, or other ABC FlowCharter 
element.

If no button or a gray button appears to the right of a topic, then there is not an ABC FlowCharter or 
Viewer equivalent.

To access the ABC OLE Automation help file from the ABC FlowCharter help:

1. Click the  button immediately to the right of the command, option, or area that you 
want to know the ABC OLE Automation equivalent for. For example, if you want to know the 
equivalent for the Align to Rulers option in the Preferences dialog box, go to the topic Alignment 
Options. Find the paragraph about Align to Rulers and click the 

 button. The ABC OLE Automation help file runs showing the topic on the equivalent ABC OLE 
Automation property or method.

2. To return to this help from the ABC OLE Automation help, click on the button  
that appears at the right of the topic title.

Related Topics
ABC OLE Automation
Accessing ABC OLE Automation Help from Visual Basic
Accessing ABC OLE Automation Help using Excel 5.0
Accessing ABC OLE Automation Help using the File Manager
Jumping to Visual Basic help



Accessing ABC OLE Automation Help Using the File Manager

To access ABC OLE Automation help using the File Manager:

1. Open the Windows File Manager.
2. Locate the directory where ABC FlowCharter is installed (C:\ABC, by default).
3. Double click the file AUTOMATE.HLP. The ABC OLE Automation help file runs showing the 

Contents topic.

Related Topics
ABC OLE Automation
Accessing ABC OLE Automation Help from ABC FlowCharter Help
Accessing ABC OLE Automation Help from Visual Basic
Accessing ABC OLE Automation Help using Excel 5.0
Jumping to Visual Basic help



Accessing ABC OLE Automation Help Using Excel 5.0

To access ABC OLE Automation help using Excel 5.0:

1. Run Excel 5.0.
2. Open the Insert menu and choose the Macro command. A submenu opens.
3. Choose Module. The module interface displays.
4. Open the Tools menu and choose the References command. The References dialog box opens.
5. Click ABC OLE Automation 1.0 so an X appears in the box in front of it.
6. Click OK to close the dialog box.
7. Open the View menu and choose the Object Browser command. The Object Browser dialog box 

opens.
8. Click the down arrow to the right of the Libraries/Workbooks text box. A list of available libraries 

and workbooks appears.
9. Click ABC FlowCharter to select it. The Objects/Modules list box shows the objects available in 

ABC FlowCharter OLE Automation.
10. Click the object you want information about in the Objects/Modules list box. A short explanation 

appears at the bottom of the dialog box.
11. Click the button with a question mark in it, if you wish. ABC OLE Automation help appears 

showing the topic about that object.
or
Click the method or property you want information about in the Methods/Properties list box. A 
short explanation appears at the bottom of the dialog box.

12. Click the button with a question mark in it. ABC OLE Automation help appears showing the topic 
about that method or property.

Note: If the button with a question mark in it is gray, then the help file is not installed. You must install the 
help file using the Installation program.

Related Topics
ABC OLE Automation
Accessing ABC OLE Automation Help from ABC FlowCharter Help
Accessing ABC OLE Automation Help from Visual Basic
Accessing ABC OLE Automation Help using the File Manager
Jumping to Visual Basic help



Jumping to Visual Basic Help

You can jump to the Visual Basic help by clicking Visual Basic Help. However, the jump will succeed only 
if you have the Visual Basic directory in your DOS path, or if you copy the Visual Basic help file (VB.HLP) 
to your ABC FlowCharter directory.

Related Topics
ABC OLE Automation
Accessing ABC OLE Automation Help from ABC FlowCharter Help
Accessing ABC OLE Automation Help from Visual Basic
Accessing ABC OLE Automation Help using Excel 5.0
Accessing ABC OLE Automation Help using the File Manager



Accessing ABC OLE Automation Help from Visual Basic

There are several ways you can access this help from Visual Basic. Each way brings up an appropriate 
topic.

· Select the ABC Events VBX and press F1.
· Highlight a procedure name in the Proc: combo box and press F1.
· Highlight a property or method from ABC OLE Automation and press F1.

Related Topics
ABC OLE Automation
Accessing ABC OLE Automation Help from ABC FlowCharter Help
Accessing ABC OLE Automation Help using Excel 5.0
Accessing ABC OLE Automation Help using the File Manager
Jumping to Visual Basic Help



Other Programs in ABC FlowCharter 4.0

ABC Viewer is one of the programs in the ABC FlowCharter package.

Click a button to go to the help system for the program you want to learn about.

Note: If you only have ABC Viewer, the other programs and their help systems are not available.

ABC FlowCharter 4.0 is the latest version of the popular charting program. It provides the tools you need 
for Total Process Management and for all your other charting needs.

ABC DataAnalyzer 1.1 give you the tools to draw data-driven charts, including histograms, run charts, 
Pareto charts, control charts (including P charts, PN charts, C charts, U charts, Moving Range, and X 
Avg, R charts), scatter charts, and pie charts.

ABC SnapGraphics 2.0 is the quick tool for creating graphics for all your business needs.

ABC Viewer 1.0 is the latest program in the ABC family. It lets anyone view and work with the charts 
created using ABC FlowCharter.

ABC OLE Automation is an advanced feature of ABC FlowCharter 4.0 that requires Visual Basic, 
knowledge of programming in Visual Basic or C++, and knowledge of ABC FlowCharter. You can control 
ABC FlowCharter and ABC Viewer using OLE Automation. For more information, see ABC OLE 
Automation.

If you have the CD ROM version of ABC FlowCharter 4.0, you will find copies of Designer and Picture 
Publisher included on it. These special versions have the full functions of the retail versions. After you 
have used them for 30 days, however, they will stop working. Contact Micrografx or your dealer to 
purchase retail versions. See the Read Me for more information.

Related Topics
Contents 



Getting Started with ABC Viewer

ABC Viewer provides a simple way to use charts prepared in ABC FlowCharter. ABC Viewer is easy to 
use because of its simple interface. ABC Viewer's toolbar contains buttons you can click to access the 
features, such as opening, printing, and saving charts. Step-by-step Cue Cards are provided to help you 
with major features of the program.

You can use ABC Viewer to open a chart and view it in different ways. You can quickly and easily open 
associated charts using the Link Back and Link Ahead buttons, and switch to any chart you have opened 
using the Show Link Summary button. You can select shapes in a chart to enter data into their fields. You 
can use the charts to give a "chalk talk" using the Full Screen button.

Click a topic to learn more about it.

Possible uses of ABC Viewer
Examples of charts appropriate for ABC Viewer
Features of ABC Viewer
Using the Help system to learn about ABC Viewer

Related Topics
Other programs in ABC FlowCharter 4.0 
Using ABC Viewer 
Subject Index 
Using Cue Cards
Contents



Using the Help System to Learn about ABC Viewer

This help system describes how to use ABC Viewer.

· If you are not familiar with Windows, click the topic Learning Windows basics.

· To learn about the commands in the menu bar, click ABC Viewer commands.

· To learn about the buttons on the screen, click ABC Viewer toolbar and buttons.

· For detailed on-screen instructions on how to do basic tasks, click the Cue Cards button  on the 
screen at any time. Some help topics also contain a Cue Card button that you can click to use the 
Cue Cards. Cue Cards remain visible on-screen as you perform the task described.

Related Topics
Possible uses of ABC Viewer
Examples of charts appropriate for ABC Viewer
Features of ABC Viewer
Getting started with ABC Viewer



Possible Uses of ABC Viewer

Here are some possible uses of ABC Viewer.

· As a tutorial for a new employee to learn company procedures
· As a repository of company rules
· For project control
· For project specifications
· As a visual front-end to database information
· As an information kiosk
· For on-screen "chalk talk" presentations

Related Topics
Using the Help system to learn about ABC Viewer
Examples of charts appropriate for ABC Viewer
Features of ABC Viewer
Getting started with ABC Viewer



Examples of Charts Appropriate for ABC Viewer

Here are some examples of charts you might use with ABC Viewer.

· The chart shows the steps in the creation of a book, from conception, approval, first draft, and second 
draft through final draft and production. You enter a starting date and the number of pages in the 
manual, and the chart estimates the amount of time each step will take, the dates that each will be 
finished, and the cost of each step. You can view notes on each step. As the process continues and 
you put in the actual dates, the chart changes the estimates for the remaining steps. This kind of chart 
is useful for project control.

· The chart shows a picture of a bicycle. (See BICYCLE.AF3 in the SAMPLES directory.) When you 
click on any part of it, you go to another chart that shows a blow up of that part and a description of it, 
including its part number, cost, retail price, and how many are currently in stock. Notes describe how 
to install the part and suggest related parts that should also be used. This kind of chart is useful for 
many types of product sales.

· The chart shows a list of the departments in your company. When you click on a department, you see 
another chart with a list of the people in that department. When you click on one of those people, you 
see their job title, their telephone number, their supervisor, and other related information.

· The chart shows a list of customers. When you click on one of them, you see the status of their most 
recent shipment and their credit rating. If you click on the shipment information, you see their previous 
order.

· The main chart shows a list of the topics in a presentation you are giving. You can click on each chart 
to go to a linked chart with the specifics, and show each one on the full screen.

Preparing charts such as these requires ABC FlowCharter and, possibly, ABC OLE Automation. Using 
them with ABC Viewer, however, is easy.

Related Topics
Using the Help system to learn about ABC Viewer
Possible uses of ABC Viewer
Features of ABC Viewer
Getting started with ABC Viewer
Other programs in ABC FlowCharter 4.0 



Features of ABC Viewer

Here are some of the features of ABC Viewer that make using charts fast, easy, and compatible with your 
day-to-day work.

Simple Toolbar Interface
ABC Viewer's interface lets you perform the most common activities by clicking a button in the toolbar at 
the top of the window. See ABC Viewer Toolbar for more information.

Notes
You can view notes associated with a shape in a separate Notes window. Just select the shape, click the 

Notes button , and view the notes. See Note Button for more information.

Data Fields
ABC FlowCharter lets you enter information in data fields attached to shapes. See Entering Field Data for 
more information.

Data Field Reports
You can generate formatted reports, files, or Windows Clipboard copies of the data saved in data fields. 
Clipboard data can be pasted directly into ABC DataAnalyzer, Microsoft Excel, and many other Windows 
applications. See Report Command for more information.

Password Protection
Each chart can be password protected to prevent unauthorized alteration of data. See Protecting a Chart 
for more information.

Indexing
ABC FlowCharter provides an index that lets you display, copy, and print information about charts and 
shapes. You can use the index to find charts and shapes, and the text inside them, as well as the link 
structure between charts. You also can use the index to find text in a shape and to open the chart that 
contains that shape. See Index Button for more information.

Linked Charts
ABC FlowCharter lets you double click on a shape to go to an associated chart, or run another program 
without switching to the Windows Program Manager. See Going to a Linked Chart for more information.

Linked File Movement
With ABC Viewer, you can move a set of linked files and still maintain the links between them. (You must 
move all of the files in the set to the same location.) For example, you may want to move a set of linked 
files from a hard disk to a floppy disk for transporting them. When you open the files on the floppy disk, 
the links are intact.

Bubble Help and Interactive Hint Lines 
Bubble Help identifies buttons and other screen elements. When you point to a button, a small window 
pops up after a slight delay, telling you the button's name. In addition, the hint lines at the bottom of the 
ABC Viewer window change based on the cursor position. As you move the pointer, the hint line provides 
the exact advice you need. See Using Bubble Help for more information.

Copy to Windows Metafile
ABC Viewer lets you copy selected chart elements to a file in Windows Metafile format so you can import 
the chart into other Windows applications. See the Copy To Command for more information.

Related Topics
Using the Help system to learn about ABC Viewer
Possible uses of ABC Viewer



Examples of charts appropriate for ABC Viewer
Getting started with ABC Viewer



Using Cue Cards

You use Cue Cards to get started with basic tasks. The cards are small windows that stay on top of ABC 

Viewer while you follow their instructions. Click the Cue Card button  at any time to get help on basic 
tasks.

In this help, some commands and buttons have Related Topics entries, marked with the Cue Card button 

 that takes you to a Cue Card that will help you with a task related to them.

Click Cue Cards Main Menu to see the cards available.

Related Topics
Getting started with ABC Viewer
Using ABC Viewer 

        See instructions on using Cue Cards  
Subject Index 
Contents



Speed Keys

Charts and Windows
Open chart file Ctrl+O
Next chart window Ctrl+F6
Close chart Ctrl+F4
Save chart file Ctrl+S
Print chart Ctrl+P
Exit program Alt+F4
Open and close Note window F7
Open and close Field Viewer F6

Editing
Undo/redo change Ctrl+Z (or Alt+Bksp)
Copy Ctrl+C (or Ctrl+Ins)
Select all Ctrl+A

Full-screen View
Leave full-screen view Esc, End, X
Erase chart annotations Delete, Spacebar, E
Go to next chart window Tab, Page Down, N
Go to previous chart window Shift+Tab, Page Up, P

On-Line Help
Context-sensitive help topic F1

Use the additional shortcut keys listed next to the menu commands and in the hint line.

 



Bubble Help Command

Use the Bubble Help command in the Help menu to turn Bubble Help on or off.

When Bubble Help is turned on, you can point to a button in the toolbar, hold the mouse still for a short 
period of time, and see the name of the button.

Related Topics
         Using bubble help  

        Use bubble help  



Using Bubble Help

To use Bubble Help:

1. Open the Help menu. If a check mark does not appear beside the Bubble Help command, choose 
the Bubble Help command. This enables Bubble Help.

2. Point to a button in the window, and hold the mouse still for a short period of time. A short 
message (bubble) appears, explaining the button.

To turn off Bubble Help:

1. Open the Help menu. A check mark appears beside the Bubble Help command.
2. Choose Bubble Help. The next time you open the Help menu, a check mark will not appear 

beside the Bubble Help command.

Related Topics
         Bubble Help command  

        Use bubble help  



About ABC Viewer Command

The About ABC Viewer command in the Help menu opens a dialog box with the program version number 
and copyright date. In addition, it contains icons that you click for information about other Micrografx 
products and services, including technical support.

Related Topics
Dialog Box information



About ABC Viewer Dialog Box

The top portion of the About ABC Viewer dialog box contains the program version number and copyright 
date.

Click the telephone icon for information about how to contact Micrografx Technical Support. Click the 
other icons for information about additional Micrografx products.

Related Topics
Command information

 



 Learning Windows Basics

Click a topic below to learn more about it.

Choosing menus and commands
Choosing options in a dialog box
Maximizing and restoring a window
Minimizing and restoring a window
Moving in a dialog box
Moving windows and icons
Resizing windows
Switching among application windows

Related Topics
Getting started with ABC Viewer
Contents



Choosing Menus and Commands

Commands in ABC Viewer are organized in menus on the menu bar. Many commands are also included 
on the toolbar.

An inactive command appears gray in the menu or on the toolbar. You may have to select something in 
the window before the command is active. For example, you have to select a shape before you can 
choose the Copy command in the Edit menu.

Using the Mouse to Choose Menus and Commands

It is often most convenient to use the mouse to choose the commands you want. When a command has a 
button on the toolbar, all you have to do is click the button, which has the same effect as choosing the 
command in the menu.

To choose a button with the mouse:

· Move the pointer to the button and click the left mouse button.

If there is not a button on the toolbar, or if you prefer, you can choose the command from the menu.

To open a menu with the mouse:

· Move the pointer to the menu title and click the left mouse button. The menu remains open until 
you choose a command or click the mouse button again.

To choose a command with the mouse:

1. Open the menu.
2. Point to a command and click the left mouse button.

Using the Keyboard to Choose Menus and Commands

You can choose commands from the menus using the keyboard.

To open a menu with the keyboard:

· Press Alt and the underlined letter of the menu title to open a menu. For example, Alt+F opens 
the File menu.

After you have chosen a menu, you can press the Right Arrow and Left Arrow to move to the menus to 
the left and right of the selected menu.

To choose a command with the keyboard:

· Press Alt and the underlined letter of the menu, followed by the underlined letter of the command, 
to execute the command. For example, press Alt+F and then P to execute the Print command in 
the File menu.

After you have opened a menu, you can press Down Arrow to highlight the command you want and then 
press Enter to select it.

Related Topics
Learning Windows basics



Choosing Options in a Dialog Box

Options in a dialog box have square check boxes or round option buttons. In a group of options with 
square check boxes, you can select several options at the same time. In a group of options with round 
option buttons, you can select only one option at a time.

To choose an option with the mouse:

· Point to the option you want and click the left mouse button. Click again to deselect the option.

To choose an option with the keyboard:

1. Press Tab to move to the option area you want. Press Shift+Tab to move in the reverse direction 
in the dialog box.

2. Press the Arrow keys to move among options within the area.
3. Press the Spacebar to select an option.

Related Topics
Learning Windows basics



Maximizing and Restoring a Window

You can enlarge a window to cover the entire screen.

To maximize a window with the mouse:

· Click the Maximize box (containing an up arrow) in the upper-right corner of the window. The 
window fills the entire screen.

To restore a window to its previous size with the mouse:

· Click the Restore box (containing both up and down arrows).

To maximize a window with the keyboard:

1. Press Alt+Spacebar to open the Control menu.
2. Press X for the Maximize command. The window fills the entire screen.

To restore a window to its previous size with the keyboard:

· Press Alt+Spacebar and then R to choose the Restore command. The window returns to its 
previous size.

Related Topics

        Open a chart file that Is an icon (maximize a chart file)  

      Arrange chart windows when several are open  
              Learning Windows basics  



Minimizing and Restoring a Window

When you minimize a window, it becomes an icon. The icon then appears at the bottom of the screen. 
You can remove ABC Viewer from the screen, but keep it in memory, by minimizing its window. When you 
want to work in ABC Viewer again, you can bring it back on screen by restoring the window.

When you minimize a window, another window becomes active.

To minimize a window with the mouse:

· Click the Minimize box (containing a down arrow) in the upper-right corner of the window.

To restore a window with the mouse:

· Double click the icon. The icon expands into a window.

To minimize a window with the keyboard:

· Press Alt+Spacebar and then N to choose the Minimize command.

To restore a window with the keyboard:

1. Press and hold Alt.
2. Press Tab repeatedly until the icon and name of the program you want to restore is chosen.
3. Release Alt. The icon expands into a window.

Related Topics

      See information about minimizing and restoring a window  
              Arrange Icons Command  
              Learning Windows basics  



Moving in a Dialog Box

To move to an area in a dialog box with the mouse, you simply point and click.

To move to an area in a dialog box with the keyboard, press Tab to move the cursor through the options 
and Shift+Tab to move in the reverse direction.

Some areas have descriptive names with an underlined letter. You can press Alt and the underlined letter 
to move to that area.

Related Topics
Learning Windows basics



Moving Windows and Icons

Several windows can be displayed at the same time. You can rearrange them by moving one window at a 
time anywhere on the screen.

The window with the highlighted title bar is the active window. To make another window the active window 
with the mouse, click anywhere in that window. With the keyboard, press Alt+Tab to switch among the 
windows and icons. The title bar for the icon (below the icon) is highlighted when it is active.

To move a window with the mouse:

1. Point to the title bar and press and hold the left mouse button. The border of the window changes 
color.

2. Drag the outline of the window to another location.
3. Release the mouse button.

To move a window with the keyboard:

1. Press Alt+Spacebar and then M to choose the Move command in the Control menu. A four-
headed arrow appears on the title bar.

2. Press the Arrow keys to move an outline of the window to a new location.
3. Press Enter.

To move an icon with the mouse:

1. Point to the icon and press and hold the left mouse button.
2. Drag the icon to another location.
3. Release the mouse button.

To move an icon with the keyboard:

1. Press Alt+Esc to highlight the icon.
2. Press Alt+Spacebar to open the Control menu.
3. Press M to choose the Move command. A four-headed arrow appears on the icon.
4. Press the Arrow keys to move the icon.
5. Press Enter.

Related Topics

      Arrange chart windows with several open  
              Learning Windows basics  



Resizing Windows

You can make the ABC Viewer window larger or smaller, resizing it in any direction. With the mouse, you 
can resize horizontally and vertically at the same time from the corner of a window.

To resize the window with the mouse:

1. Point to a border or corner and press and hold the left mouse button. The pointer changes to a 
double-headed arrow.

2. Drag the border or corner until the new border indicates the desired size.
3. Release the mouse button.

To resize the window with the keyboard:

1. Press Alt+Spacebar and then S to choose the Size command. A four-headed arrow appears in 
the center of the window.

2. Press an Arrow key to move the four-headed arrow to the border you want to move. To move to 
a corner, press the two Arrow keys that point to that corner.

3. Press the Arrow keys repeatedly to change the window to the desired size.
4. Press Enter. The active window changes to the new size.

Related Topics
Learning Windows basics



Switch To Command (Control Menu)

Use the Switch To command in the Control menu to open the Task List dialog box, which lets you switch 
among currently open applications and rearrange their windows and icons on your screen.

Related Topics
Dialog Box information
Procedure information
Learning Windows basics



Task List Dialog Box

The Task List dialog box opens when you choose the Switch To command in the Control menu.

Task List
The Task List displays the open (running) applications. Highlight the application you want to switch to or 
close.

Switch To button
Click the Switch To button to switch to the highlighted application and make it active.

End Task button
Click the End Task button to close the highlighted application.

Cascade button
Click the Cascade button to cascade the windows of the applications in the Task List. The windows 
overlap so that each title bar is visible.

Tile button
Click the Tile button to tile the windows of the applications in the Task List. The windows are resized on 
the screen so none of the windows overlap.

Arrange Icons button
Click the Arrange Icons button to align the application icons at the bottom of the screen.

Related Topics
Command information
Procedure information



Switching among Application Windows

To switch among application windows:

1. Open the Control menu and choose Switch To, or press Ctrl+Esc. The Task List opens.
2. Double click the name of the application you want, or select the application name and click Switch 

To.

Related Topics
Command information
Dialog Box information



Next Command (Control Menu)

Use the Next command (Ctrl+F6) in the Control menu to move to the next open chart window, making it 
the active window. ABC Viewer determines which window by the order in which you opened the windows.

Related Topics
Procedure information
Learning Windows basics



Moving to the Next Chart

To move to the next open chart:

· Open the Control menu in the chart window and choose Next, or press Ctrl+F6.



Close Command (Control Menu)

Use the Close command (Ctrl+F4) in the Control menu to close the active window or dialog box. The 
Close command in the main Control menu closes ABC Viewer. The Close command in the Control menu 
of the chart window closes only the active chart.

Double clicking a Control menu box  is the same as choosing the Close command.

Related Topics
Procedure information
Exit command
Learning Windows basics



Closing a Window

To close the active chart window:

· Open the Control menu in the chart window and choose Close, or press Ctrl+F4.

To close the ABC Viewer window:

· Open the Control menu in the ABC Viewer window and choose Close, or press Alt+F4.

To close the active dialog box:

· Open the Control menu in the dialog box and choose Close, or press Alt+F4.



Restore Command (Control Menu)

Use the Restore command in the Control menu to return the active window to its size and position before 
you chose the Maximize or Minimize command.

Clicking  in the upper-right corner of a maximized window is the same as choosing the Restore 
command.

Double click the title bar to restore the window quickly.

Related Topics
Maximizing and restoring a window
Minimizing and restoring a window
Learning Windows basics



Move Command (Control Menu)

Use the Move command in the Control menu to display a four-headed arrow so that you can move the 
active window or dialog box with the arrow keys.

Note: This command is unavailable if you maximize the window.

Related Topics
Procedure information
Learning Windows basics



Size Command (Control Menu)

Use the Size command in the Control menu to display a four-headed arrow so that you can size the 
active window with the arrow keys.

Note: This command is unavailable if you maximize the window.

Related Topics
Procedure information
Learning Windows basics



Minimize Command (Control Menu)

Use the Minimize command in the Control menu to reduce the ABC Viewer window to an icon.

Clicking  in the upper-right corner of the window is the same as choosing the Minimize command.

Related Topics
Procedure information
Moving windows and icons
Learning Windows basics



Maximize Command (Control Menu)

Use the Maximize command in the Control menu to enlarge the active window to fill the available space. 
For example, a chart window expands to fill the ABC Viewer window. The ABC Viewer window expands to 
fill the entire screen.

Clicking  in the upper-right corner of the window is the same as choosing the Maximize command.

Double click the title bar to maximize the window quickly.

Related Topics
Procedure information
Learning Windows basics

 



ABC Viewer Commands

File Menu The File menu contains commands that let you open existing charts and workspaces; 
and save and close files. You also use the commands in the File menu go from one chart 
to another, to define the page layout, print and protect charts, and exit the program.

Edit Menu The Edit menu contains commands that let you select objects; copy selected objects; 
open the object application for you to edit a linked or embedded object; and undo and 
redo actions.

View Menu The View menu contains commands that let see more detail, see more of a chart, see the 
entire chart; or show the chart with no menu bars or tools. You also use the commands in 
the View menu to show and hide the Note Viewer window and the Index window.

Fields Menu The Fields menu contains commands that let you show or hide the Field Viewer, update 
fields to the latest values based on other sources of information, and clear the values in 
all data fields. You also use the Fields menu generate to data field reports.

Window Menu The Window menu contains commands that arrange open chart windows, and bring a 
selected chart to the front.

Related Topics
Using the toolbar and buttons
Getting started with ABC Viewer

 



Edit Menu Commands

Click a command below to learn more about it.

Undo/Redo Lets you undo and redo changes made to a chart.
Copy Copies the selected objects to the Clipboard.
Select Lets you select all objects, all shapes, or all lines in a chart.
Copy To Lets you choose a file to copy the selected objects to.
Object Opens the object application for you to edit the linked or embedded object.



Undo/Redo Command

The Undo command in the Edit menu reverses the last change you made to a chart; the Redo command 
restores the change. If a change cannot be reversed, Nothing to Undo appears in the menu.

Related Topics
Procedure information
Edit menu



Reversing a Change

To reverse (undo) a change:

· Open the Edit menu and choose Undo, or press Ctrl+Z. The change is undone. The menu 
changes to Redo.

To reverse (redo) an undo:

· Open the Edit menu and choose Redo, or press Ctrl+Z. The undo is undone. The menu changes 
back to Undo.

Related Topics
Command information



Copy Command

The Copy command in the Edit menu copies the selected objects in a chart and places the copy on the 
Clipboard.

Related Topics
Procedure information
Edit menu



Copying Objects

To copy an object:

1. Select the object or objects you want to copy.
2. Open the Edit menu and choose Copy, or press Ctrl+C.

Related Topics
Command information



Select Command

The Select command in the Edit menu lets you select all objects, all shapes, or all lines in a chart. When 
you choose the command, the Select submenu opens. You then choose whether to select all objects, 
shapes, or lines.

Related Topics
Procedure information
Edit menu



Selecting Objects, Shapes, and Lines

To select objects, shapes, or lines:

1. Open the Edit menu and choose Select. The Select submenu opens.
2. Choose one of the Select commands.

Related Topics
Command information



Object Command

The Object command in the Edit menu varies, depending upon the object linked to or embedded in the 
chart. For example, it may state Edit Linked <Name> Object. Choose the command to open the object 
application and edit the linked object.

Related Topics
Editing an object linked to a chart
Editing an object embedded in a chart
Edit menu



Copy To Command

You use the Copy To command in the Edit menu to save selected shapes in a file. The file is in Windows 
Metafile (WMF) format. Several programs, including Word for Windows, can insert .WMF files.

Related Topics
Dialog Box information
Procedure information
Edit menu



Copy To Dialog Box

File Name text box
Type the name of the file you want to copy to in the File Name text box.

Files list box
The Files list box displays the file names in the current directory. Click a file name in the list box to display 
it in the File Name text box.

In the Files list box, type the first letter of a file name to move the cursor to the first file beginning with that 
letter.

File Type list box
The File Type list box contains the file formats that ABC Viewer supports. Files saved with the Copy To 
command are always in Windows Metafile (.WMF) format.

Directory list box
The Directory list box displays directories on the current drive. To see the file names in another directory, 
double click the directory name in the list box.

Drive list box
The Drive list box displays disk drives. If you choose A:, for example, the directories on the diskette in 
drive A appear in the Directory list box.

Related Topics
Command information
Procedure information



Saving a Shape

You save a shape in Windows Metafile (WMF) format so you can place it in a program that can read that 
format, such as Word for Windows.

To save a copy of a shape:

1. Select the shape or shapes you want to save.
2. Open the Edit menu and choose Save To. The Save To dialog box opens.
3. Type a file name.

Note: Pressing a character key when a file name is highlighted in the text box makes the name 
disappear. To edit the file name, press the Right Arrow key to remove the highlight. Then press the Right 
Arrow or Left Arrow key to move the text cursor. To delete characters to the left of the text cursor, press 
Backspace.

4. Choose the drive and directory in which you want to store the copy.
5. Click OK. The selected shapes are stored in a file in Windows Metafile format.

If you entered an existing file name, a message appears, asking if you want to replace the existing file.

· Click No if you do not want to replace the file. You return to the Save File dialog box. Type a 
different name in the File Name text box or choose another directory.

· Click Yes if you want to replace the file.

Related Topics
Command information
Dialog Box information
Select command

 



Working with Objects

Selecting objects
Undoing a change
Using the scroll grid
Using the scroll keys



Selecting Objects

ABC Viewer gives you several ways to select objects in a chart.

To select Do this
A single object Point to the object and click the left mouse button.
A group of adjacent objects Press and hold the left mouse button, and drag the pointer around the 

objects.
A group of nonadjacent objects Press Shift and click each object.

To deselect one of a group of objects, press Shift and click the selected object.

All objects Open the Edit menu, choose Select, and then choose All.
All shapes Open the Edit menu, choose Select, and then choose Shapes.
All lines Open the Edit menu, choose Select, and then choose Lines.

Press Ctrl+A to select all objects.

Related Topics
Working with objects



Using the Scroll Grid

The scroll grid, located below the down scroll arrow, works like the scroll arrows, with the added 
advantage that you can scroll diagonally across your chart. The squares in the grid represent directions 
for scrolling.

To scroll using the scroll grid:

1. Point to the square in the grid that represents the direction you want to scroll. For example, to 
scroll down and to the right, point to the square in the lower-right corner.

2. Press and hold the left mouse button. The selected square is highlighted and your view scrolls in 
the specified direction. To change the scroll direction, drag to a different square. To end scrolling, 
drag to the center square.

3. Release the mouse button.

Related Topics
Button information
Using the scroll keys
Working with objects



Using the Scroll Keys

You can use the Page Up and Page Down keys to scroll up and down one screen, respectively.

To scroll up or down one screen:

· Press the Page Up or Page Down key, depending upon the direction you want to scroll.

Related Topics
Using the scroll grid
Working with objects

 



Fields Menu Commands

Click a command below to learn more about it.

Show/Hide Viewer Shows the Field Viewer so that you can enter field data.
Report Lets you generate reports on the data stored in the charts data fields.
Update Lets you automatically update linked data in fields.
Clear Fields Lets you clear the values in all data fields in your chart.



Report Command

The Report command in the Fields menu lets you output the data in a charts shapes. You can generate 
three types of reports from the entered field data: Input, Output, and Metrics.

When you choose the Report command, the Report submenu opens and displays the following 
commands:

Input
Output
Metrics

Related Topics

      Make a report  
              Fields menu  



Input Command

The Input command in the Report submenu generates a report that lists the charts shapes, each followed 
by the lines coming into them. This type of report is commonly used to find redundant activities.

Related Topics
Procedure information
Dialog Box information
Report command



Reporting Field Data

You can send the data to a printed report, to a file, or to the Windows Clipboard. For printed reports, the 
selected shape information is printed in a tabbed-column format, with column headings based on field 
names and column results based on the accumulation method. For file and Clipboard output, the selected 
shape information will be in a tab-delimited format, suitable for import into spreadsheets and databases, 
excluding result information.

To send the report to the printer:

1. Open the Fields menu and choose Report. The Report submenu opens.
2. Click the type of report you want: Input, Output, or Metrics. The Field Report dialog box opens.
3. Click the Output to Printer option to select it.
4. Click the Options button. The Field Report Options dialog box opens.
5. Select a sort method, and choose the items to be included in the report.
6. Click OK to close the dialog box. The Field Report dialog box appears.
7. Click OK. The Print Field Report dialog box appears.
8. Select the number of copies you want to print.
9. Click Setup if you want to make changes in the Printer Setup dialog box.
10. Click OK. The field report is printed to the selected printer.

To save a field report to a file:

1. Open the Fields menu and choose Report. The Report submenu opens.
2. Click the type of report you want: Input, Output, or Metrics. The Field Report dialog box opens.
3. Click the Output to File option to select it.
4. Click the Options button. The Field Report Options dialog box opens.
5. Select a sort method, and choose the items to be included in the report.
6. Click OK to close the dialog box. The Field Report dialog box appears.
7. Click OK. The Save Field Report dialog box appears.
8. Type a name in the File Name text box. (The tab-delimited file type is selected by default.)
9. Click OK. The field report is saved in a file.

To copy a field report to the Clipboard:

1. Open the Fields menu and choose Report. The Report submenu opens.
2. Click the type of report you want: Input, Output, or Metrics. The Field Report dialog box opens.
3. Click the Copy to Clipboard option to select it.
4. Click the Options button. The Field Report Options dialog box opens.
5. Select a sort method, and choose the items to be included in the report.
6. Click OK to close the dialog box. The Field Report dialog box appears.
7. Click OK. A dialog box message states that the field report has been copied to the Clipboard.
8. Click OK.

Note: Field data can be copied through the Clipboard and pasted in another chart for use as text only, not 
as data fields.

Related Topics
         Input command information  
         Output command information  
         Metrics command information  
         Field Report Dialog Box information  
         Options Dialog Box information  

      Make a report  



Field Report Dialog Box

Destination Selector
Click on the destination where you want to send the data.

Output to Printer generates a report to a printer. The selected shape information is printed in a tabbed-
column format, with column headings based on field names and column results based on the 
accumulation method.

Output to File generates a report to a file. The selected shape information is in a tab-delimited format, 
suitable for import into spreadsheets and databases, excluding result information.

Copy to Clipboard generates a report to the Windows Clipboard. The selected shape information is in a 
tab-delimited format, suitable for pasting into spreadsheets and databases, excluding result information.

Options
Click this button to open the Field Report Options dialog box.
Related Topics
         Procedure information  
         Input command information  
         Output command information  
         Metrics command information  
         Options Dialog Box information  
         Print Field Report Dialog Box information  

      Make a report  



Field Report Options Dialog Box

Sort Method Selector
Select the method to be used for sorting the data in the Field Report. Select Name to sort the data by the 
name of the shape. Select Number to sort the data by the shape number. Select Text to sort the data by 
text in the shape. Select First Data Field to sort the data by the contents of the first data field.

Include Check Boxes
Click the items to include in the report to select them. A check mark to the left of an item indicates it has 
been included. To exclude an item, click it again.

Select Sub Totals to include subtotals for the fields in addition to grand totals according to the 
Accumulation Method selected. Select Hidden Fields to include the data for fields that have been hidden 
in the chart.

Related Topics
Field Report Dialog Box information



Print Field Report Dialog Box

This dialog box lets you specify the number of copies of a data field report to be printed. It also gives you 
the option of printing the report to a file.

Destination Printer
This read-only text block shows the current printer. Click the Setup button to choose a different printer.

Print to File Selector
Select this option to print the report to a file (save the report in a file). A Print to File dialog box opens that 
lets you specify the file drive, directory, and file name.

Copies Selector Box
The selector box shows the number of copies to be printed. The default is 1. Click on the up arrow to the 
right of the box to increase the number of copies. Click on the down arrow to decrease the number of 
copies.

Setup Button
Click the Setup button to choose a different printer or to change the setup for the current printer.



Save Field Report Dialog Box

This dialog box lets you save a report as a file so you can print the file later or send it via e-mail.

File Name text box
Type the name of the file you want to save in the File Name text box.

Files list box
The Files list box displays the file names in the current directory. Click a file name in the list box to display 
it in the File Name text box.

File Type list box
The File Type list box contains the file formats that ABC Viewer supports. Click the down arrow to the right 
of the list box to display the file formats, then choose the one you want.

Directory list box
The Directory list box displays directories on the current drive. To see the file names in another directory, 
double click the directory name in the list box.

Drive list box
The Drive list box displays disk drives. For example, if you choose A:, the directories on the diskette in 
drive A appear in the Directory list box.



Output Command

The Output command in the Report submenu generates a report that lists the charts shapes, each 
followed by the lines leaving them. This report is commonly used to find unused activities.

Related Topics
Procedure information
Dialog Box information
Report command



Metrics Command

The Metrics command in the Report submenu generates a report that lists the charts shapes and other 
elements, followed by all the lines for the chart. This report is commonly used to find total cycle times.

Related Topics
Procedure information
Dialog Box information
Report command



Update Command

The Update command in the Fields menu lets you automatically update linked field data. If there are no 
linked fields in your chart, this command is gray.

Related Topics
Procedure information
Fields menu



Updating Data Fields

To update field data:

· Open the Fields menu and choose Update.

Note: You will also be asked whether to update data when a linked chart that requires updating is 
opened.

Related Topics
Command information



Show Viewer and Hide Viewer Commands

The Show Viewer command in the Fields menu and the Field Viewer button open the Field Viewer dialog 
box. When you choose the Show Viewer command, the menu item changes to Hide Viewer.

Note: If no field types have been defined for this chart, the Field Viewer option will be gray.

Related Topics
         Procedure information  
         Dialog Box information  
         Field Viewer button  

      View or enter information (use the field viewer)  
              Fields menu  



Showing and Hiding the Field Viewer

To show the Field Viewer:

1. Select a shape in the chart.
2. Open the Fields menu and choose Show Viewer.

or

Click the Field Viewer button  in the toolbar at the top the ABC Viewer window.
The Field Viewer window opens. The Fields menu changes to Hide Viewer.

Note: A message is displayed in the Field Viewer if no shape is selected or more than one shape is 
selected. In this case, you need not close the Field Viewer; simply click the shape you want to select it.

You can leave the Field Viewer open. The contents will change to display the field contents for each 
shape you select.

To hide the Field Viewer:

· Open the Fields menu and choose Hide Viewer.
or

· Click the Field Viewer button in the toolbar at the top the ABC Viewer window.
The Field Viewer window closes. The Fields menu item changes to Show Viewer.

You also can press F6 to open and close the Field Viewer window.

Related Topics
         Command information  
         Dialog Box information  

      View or enter information (use the field viewer)  



Field Viewer Dialog Box

This dialog box is used to view or enter data in the data fields in a chart. The dialog box displays the chart 
name and name of the selected element in the title bar. It displays the field names and their contents. You 
can enter or change the data if the chart is not protected.

Fields
Shows the value that is currently in each field. You enter or edit a new value if the chart is not protected.

Note: The names of fields that are hidden are followed by an asterisk (*). If the chart is protected by 
password, no hidden fields are shown in the Field Viewer.

Field Type
The field Type for the current field (the field in which the text cursor is currently located) is displayed 
below the box.

You can press Tab to switch between fields.

Related Topics
         Procedure information  
         Command information  
         Field Viewer Dialog Box information  

      View or enter information (use the field viewer)  
              Unprotecting a chart  



Entering Field Data

To display the field data for a shape:

1. Select the shape in the chart.
2. Click the Field Viewer button in the toolbar at the top the ABC Viewer window. The Field Viewer 

window opens, displaying the field names and data entered earlier.

To enter field data for a shape:

1. Select a shape in the chart.
2. Open the Fields menu and choose Show Viewer.

or
Click the Field Viewer button in the toolbar at the top the ABC Viewer window.
The Field Viewer window opens.

3. Click in the text box after the field name you want and type data that corresponds to the field type 
shown. (The Field Type at the bottom shows the format required for the field type.)

4. Press Enter or Tab to save the field data for the shape and move to the next field.
5. Repeat step 4 for the remaining data fields you want for the shape.

Note: You can leave data fields blank. Blank fields will not be added to the shape. Additional fields 
move up to space the field data properly on the chart.

6. If you want to enter field data for another shape, click another shape from the chart. (You need 
not close the dialog box.) Repeat this procedure from step 3 until you have entered field data for 
all the text fields you want.

7. When you are done, click the Close button to close the dialog box, or double click the Control 
menu box in the window.

Note: You also can enter field data into lines, bitmaps, and OLE objects.

Related Topics
         Command information  
         Field Viewer Dialog Box information  

      View or enter information (use the field viewer)  



Field Viewer Button

The Field Viewer button and the Show/Hide Viewer command in the Fields menu open the Field Viewer 
window.

Note: If no field types have been defined for this chart, the Field Viewer button is gray.

You can press F6 to open and close the Field Viewer window.

Related Topics
         Field Viewer Dialog Box information  
         Procedure information  
         Show Viewer and Hide Viewer commands  

      View or enter information (use the field viewer)  
              ABC Viewer Toolbar  



Clear Fields Command

The Clear Fields command in the Fields menu and the Clear Fields button remove all values from all 
fields for all shapes.

Related Topics
         Procedure information  
         Clear Fields button  

      Clear data field values  
              Fields menu  



Clearing Data Fields

To clear fields:

1. Open the Fields menu and choose Clear Fields.
or

Click the Clear Fields button .
 A confirmation dialog box appears.

2. Choose OK. All values in all fields for all shapes are deleted.

If you clear data fields by mistake, restore them using the Undo command.

Related Topics
         Command information  
         Button information  

      Clear data field values  

 



File Menu Commands

Click a command below to learn more about it.

Open Opens an existing chart, template, or workspace.
Close Closes the active chart.
Recall Opens a submenu that lists the last nine charts you opened or saved.
Close All Closes all open charts.
Save Saves the file on which you are working, using the current file name.
Save As Lets you make a copy of the file under a new name or directory.
Link Opens a submenu that lets you go to the next chart associated with a selected 

shape or return to a previous chart.
Show Link Summary Lets you see the charts that you have linked to and quickly return to one of them.
Page Layout Lets you choose options that affect the orientation and dimensions of the pages in a 

chart.
Print Lets you choose print range and other options before printing a chart.
Printer Setup Lets you choose a printer and printer options.
Protect Chart Prevents unauthorized editing of your chart's field data.
Unprotect Chart Lets you enter field data into a chart that has been protected.
Exit Closes open chart files and the program.



Open Command

Each chart is stored in a separate file on disk. Use the Open command in the File menu or the Open 
button to open these file types.

· Charts (file names ending with an AF3 or AF2, extension; files that contain the shapes, lines, and 
text that comprise your charts)

· Workspaces (file names ending with the AFW extension; files that contain information about your 
current work environment, including the names of charts used in a project and their window 
arrangement)

Note: You cannot create a workspace file with ABC Viewer. You only have a workspace file if the person 
who created your chart gave you one.

Related Topics
         Dialog Box information  
         Procedure information  

      Open a chart file  
              Opening a workspace  
              Open button  
              File menu  



Open File Dialog Box

File Name text box
Type the name of the file you want to open in the File Name text box.

Files list box
The Files list box displays the file names in the current directory. Click a file name in the list box to display 
it in the File Name text box.

In the Files list box, type the first letter of a file name to move the cursor to the files beginning with that 
letter.

File Type list box
The File Type list box contains the file formats that ABC Viewer supports (AF3, AF2, and AFW). Click the 
down arrow to the right of the list box to display the file formats, then choose the one you want.

Directory list box
The Directory list box displays directories on the current drive. To see the file names in another directory, 
double click the directory name in the list box.

Drive list box
The Drive list box displays disk drives. For example, if you choose A:, the directories on the diskette in 
drive A appear in the Directory list box.

Related Topics
         Open button  
         Open command  
         Procedure information  

      Open a chart file  



Opening a File

To open a file:

1. Open the File menu and choose Open.
or
Click the Open button.
The Open File dialog box opens.

2. Choose the drive and directory that contain the file you want to open.
3. Choose the type of file you want to open in the File Type list box, if necessary.
4. Click the file you want to open.
5. Click OK. The selected file opens in the window.

Related Topics
         Open button  
         Open command  
         Dialog Box information  

      Open a chart file  



Close Command

The Close command in the File menu lets you close the active chart.

Related Topics
         Procedure information  

      Remove a chart file from the screen (close a file)  
              File menu  



Closing the Active Chart

To close only the active chart:

· Open the File menu and choose Close, or double click the Control menu box in the upper-left 
corner of the chart window.

If the active chart contains changes that you have not saved, ABC Viewer displays a message asking if 
you want to save the changes. Respond to the message in one of three ways.

· Click Yes to save the changes. ABC Viewer saves the changes and closes the active chart.
· Click No to discard the changes. The active chart closes without saving the changes.
· Click Cancel to cancel the Close command. You return to the chart.

Related Topics
         Command information  

      Remove a chart file from the screen (close a file)  
              Close All command  



Close All Command

The Close All command in the File menu lets you simultaneously close all charts that are currently open 
in ABC Viewer.

Related Topics
Procedure information
Close command
File menu



Closing All Charts

To close all open charts:

· Open the File menu and choose Close All. ABC Viewer closes the open charts in the order they 
are arranged on the screen.

If any chart contains changes that you have not saved, ABC Viewer displays a message asking if you 
want to save the changes. Respond to the message in one of three ways.

· Click Yes to save the changes. If you saved the chart previously, ABC Viewer saves the changes 
and closes the active chart. If you have not saved the chart yet, the Save File dialog box opens.

· Click No to discard the changes. The active chart closes without the changes being saved.
· Click Cancel to cancel the Close All command. You return to the active chart.

Related Topics
Command information



Recall Command

Use the Recall command in the File menu to quickly open charts you recently viewed. The names of the 
last nine charts you opened or saved appear in the Recall submenu. The complete path name appears 
for charts outside the current directory.

A number appears beside each chart name. You can type the number to open the chart or click the chart 
name in the submenu.

Related Topics
         Procedure information  

      Open a chart you looked at recently (recall a file)  
              File menu  



Recalling Charts

To recall a chart:

1. Open the File menu and choose Recall. The Recall submenu opens, and a list containing up to 
nine previously opened or saved files appears.

2. Choose the chart you want to recall. The selected chart opens in the window.

Note: If the chart you choose is already open, ABC Viewer displays a message asking if you want to 
revert to the last saved version of the chart.

Related Topics
         Command information  

      Open a chart you looked at recently (recall a file)  



Save Command

Use the Save command in the File menu or the Save button to store a changed chart in a file on disk. 
Each chart (including each chart attached to a shape) is saved in a separate file.

Related Topics
         Procedure information  
         Save button  

      Save the Changes You Made to a Chart (Save a Chart File)  
              Save As command  
              File menu  



Saving a Chart

To save a chart:

· Open the File menu and choose Save. Your changes are saved in the file.

Related Topics
         Command information  

      Save the Changes You Made to a Chart (Save a Chart File)  



Save As Command

Use the Save As command in the File menu to rename a chart, so that you have the original chart and a 
new version. This option is useful for making a copy of a file without using the Windows Copy command.

Related Topics
         Dialog Box information  
         Procedure information  

      Make a copy of a chart file  
              Save command  
              File menu  



Save File Dialog Box

File Name text box
Type the name of the file you want to save in the File Name text box.

Files list box
The Files list box displays the file names in the current directory. Click a file name in the list box to display 
it in the File Name text box.

In the Files list box, type the first letter of a file name to move the cursor to the first filename beginning 
with that letter.

File Type list box
The File Type list box contains the file formats that ABC Viewer supports. Click the down arrow to the right 
of the list box to display the file formats, then choose the one you want.

Directory list box
The Directory list box displays directories on the current drive. To see the file names in another directory, 
double click the directory name in the list box.

Drive list box
The Drive list box displays disk drives. If you choose A:, the directories on the diskette in drive A appear in 
the Directory list box.

Related Topics
Command information
Procedure information



Saving a Chart Copy

To save a copy of a chart:

1. Open the File menu and choose Save As. The Save File dialog box opens.
2. Type a file name for the chart copy. Use a different name to distinguish between the copy and the 

original.

Note: Pressing a character key when a file name is highlighted in the text box makes the name 
disappear. To edit the file name, press the Right Arrow to remove the highlight. Then press the Right or 
Left Arrow to move the text cursor. To delete characters to the left of the text cursor, press Backspace.

3. Choose the drive and directory in which you want to store the copy.
4. Click OK. A copy of the active chart is stored with the new file name.

If you entered an existing file name, a message appears, asking if you want to replace the existing file.

· Click No if you do not want to replace the file. You return to the Save File dialog box. Type a 
different name in the File Name text box or choose another directory.

· Click Yes if you want to replace the file.

Related Topics
         Command information  
         Dialog Box information  

      Make a copy of a chart file  



Opening a Workspace

You can create a workspace using ABC FlowCharter. You can open a workspace (which contains the 
screen locations of a group of files) in ABC Viewer.

To open a workspace:

1. Open the File menu and choose Open. The Open File dialog box opens.
2. Choose Workspace in the File Type list box.
3. Choose the drive and directory that contain the workspace file you want.
4. Click the file you want to open.
5. Click OK. The charts saved in the workspace file open and ABC Viewer restores the chart 

arrangement.

Note: You cannot create a workspace file with ABC Viewer. You only have a workspace file if the person 
who created your chart gave you one.

Related Topics
Open button
Open command
Procedure information



Page Layout Command

Use the Page Layout command in the File menu to set the size of the page, the size of the page margins 
(borders), and the orientation of the page (portrait or landscape). You also can choose to allow blank 
pages to print and choose the measurement unit (inches or centimeters). If you wish, you can set all 
options to match the current printer. The default page size is determined by the selected printer.

Related Topics
Dialog Box information
Procedure information
File menu



Page Layout Dialog Box

Paper Size option
You should choose the paper size on which you plan to print your chart. ABC Viewer provides many 
popular paper sizes, including letter (8 1/2" x 11"), legal (8 1/2" x 14"), tabloid (11" x 17"), and C sheet 
(17" x 22").

Click the down arrow in the Paper Size area and choose one of the preset paper sizes from the list, or 
select the Width and Height text boxes and type the page dimensions you want (in inches or centimeters, 
depending upon your Measure setting). The maximum paper size is 100" x 100".

Margins option
ABC Viewer uses the margins you specify to define the print area on each page. For example, if you 
choose an 8 1/2" x 11" (letter) page size and specify a 0.5" margin on all sides, the print area is 7 1/2" x 
10".

Select each of the Margins text boxes individually and type the margin you want (in inches or centimeters, 
depending upon your measure choice). The numbers you enter are rounded to the nearest hundredth of 
an inch or tenth of a centimeter.

Orientation option
You can choose either Portrait (tall) or Landscape (wide) for your page orientation. To fit your chart on the 
fewest pages, click Portrait if your chart is vertically oriented or Landscape if your chart is horizontally 
oriented.

Measure option
You can choose inches or centimeters for your measurement units. The units you choose are used in 
margins and page size. Click Inches or Centimeters to choose the units you want.

Match Printer button
Click the Match Printer button to use the settings defined for the current printer. (You select the current 
printer using the Printer Setup command.) The printer settings include paper size, page orientation, and 
measurement units. If you choose a metric paper size, centimeters are used for the measurement units.

Print Blank Pages option
You can choose to print or omit pages that do not have any objects on them.

Select to print blank pages when assembling a poster of a chart.

Related Topics
Command information
Procedure information



Setting Up the Page

To define the page layout:

1. Open the File menu and choose Page Layout. The Page Layout dialog box opens.
2. Choose the page layout options you want.
3. Click OK. ABC Viewer applies your page layout choices to the chart.

Related Topics
Command information
Dialog Box information



Print Command

Use the Print command in the File menu or the Print button to print your charts and add them to 
presentations and reports.

ABC Viewer lets you print all the pages, a range of pages, or only selected objects in the chart. To print 
only selected objects, select the objects you want to print before you choose the Print command.

You also have an option to fit the chart to a single page. The entire chart is reduced proportionally, 
including the TrueType fonts. (Bitmap and printer fonts do not necessarily reduce properly.) When 
multiple-page charts are reduced to one page, the master items are printed only once and the All, 
Selection, and Pages print range options are still valid.

Note: Charts cannot be enlarged with the Fit to Page option.

You also can print to a file, print multiple copies, and include or exclude notes attached to the shapes in 
the chart.

Related Topics
         Dialog Box information  
         Procedure information  
         Print button  

      Print a chart  
              Printer Setup dialog box.  
              File menu  



Print Dialog Box

Print Range options
· Click All to print all the pages in the chart.
· Click Selection to print only the objects selected in the chart.
· Click Pages and type starting and ending page numbers to print a range of pages.

Fit to Page option
Click Fit to Page if you want a multiple-page chart reduced proportionally to a single page.

Print to File option
Click Print to File if you want to send the output to a file instead of a printer.

Print Notes option
Click Print Notes to print the notes attached to the shapes in the chart. The notes print (after the chart has 
printed) in the order the shapes are numbered.

Copies text box
Click the up or down arrow to choose the number of copies, or type a number in the text box.

Setup button
Click the Setup button to open the Printer Setup dialog box..

Related Topics
         Command information  
         Procedure information  

      Print a chart  



Printing a Chart

To print a chart:

1. Open the File menu and choose Print. The Print dialog box opens. Information about the current 
printer appears at the top of the dialog box. (The current printer is the printer to which the next 
print job will be sent.)

2. Choose a Print Range option.
3. Click the Fit to Page box if you want the chart reduced to a single page.
4. Type the number of copies you want in the Copies text box.
5. Click the Print to File box if you want to send the output to a file instead of a printer.
6. Click the Print Notes box to print the notes attached to the shapes in the chart. The notes print 

(after the chart has printed) in the order the shapes are numbered.
7. Click OK to save the changes in the Print dialog box and to print your chart.

Note: If you choose the Print to File option, a dialog box opens. Type the file name you want and click 
OK. The chart information is saved in a file in the current directory.

Drag an ABC Viewer file from the File Manager to the open Print Manager (or its minimized icon). ABC 
Viewer opens and displays the chart file and the Print dialog box for you to print the chart.

Related Topics
         Command information  
         Dialog Box information  

      Print a chart  



Printer Setup Command

Use the Printer Setup command in the File menu to choose the current printer and printer options.

If you do not change the current printer, ABC Viewer uses the default printer as the current printer. The 
default printer is the printer selected in the Windows Control Panel. See your Windows documentation for 
information about changing the default printer.

Related Topics
         Dialog Box information  
         Procedure information  

      Set printer options  
              File menu  



Printer Setup Dialog Box

Printer area
The Printer area lists the currently installed Windows printer drivers. Click the name of the printer you 
want to be the active printer. Printer drivers can be added or deleted through the Windows Control Panel. 
Any installed printer driver can be activated and used by ABC Viewer.

Options button
Click the Options button to open the currently selected printer's dialog box. Choose printer options (page 
size, orientation, etc.) and click OK.

Related Topics
         Command information  
         Procedure information  

      Set printer options  



Selecting a Printer

To select a printer:

1. Open the File menu and choose Printer Setup. The Printer Setup dialog box opens.
2. Select the printer you want to use.
3. Click OK.

Related Topics
         Dialog Box information  
         Command information  

      Set printer options  



Mouse Shortcut for Links

Some shapes may be set so that they link to another chart or so they run another application. Those 
shapes are marked with an indicator.

ABC Viewer lets you use a mouse shortcut for running applications and opening linked charts quickly and 
efficiently.

To open the linked chart or run the application, double click on the shape.

Related Topics
Indicators for link and notes
File menu



Indicators for Link and Notes

ABC Viewer uses indicators to identify shapes that serve a special purpose or contain a note.

Indicators are symbols added to shape numbers. They identify shapes that are used to open linked 
charts, run other applications, or that have notes attached to them.

An indicator can be a symbol or an icon, or the shape may have a shadow. Check with the person who 
created the chart to find out the indictors used.

Common indicators are the symbol , which may be used for all situations. Sometimes the indicators 
are different, such as a shadow for link, an asterisk (*) for running another program, and -N for notes.

Related Topics
Going to a linked chart
Opening and closing the Note window
Mouse shortcut for links



Protect Chart Command

Use the Protect Chart command in the File menu to protect your chart from unauthorized changes or to 
unlock a chart so you can work with it.

At times, you may want to prevent other people from entering field data into your chart. You can protect a 
chart by assigning it a password. No one is able to enter field data into it until the password is entered 
correctly. If the chart contains hidden data fields, they are hidden from view until the password is entered 
correctly.

You can use password protection to manage attached (linked) chart files. By assigning each person in a 
workgroup a different password, you can ensure that each person has access only to his or her own 
charts.

Related Topics
         Dialog Box information  
         Procedure information  

      Use passwords  
              Unprotect Chart command  
              File menu  



Protect Chart Dialog Box

Password text box
Type a password in the Password text box. The password is not case-sensitive. This means that 
uppercase and lowercase letters are considered to be the same. For example, flowchrt is recognized as 
the same password as FlowChrt. The password appears as a series of asterisks (****) as you type. This 
prevents unauthorized persons from viewing the password as you enter it.

Verify text box
Type the password again exactly as you typed it in the Password text box. This verifies that the password 
you typed was not typed incorrectly.

Note: If you want to remove password protection, the Unprotect Chart dialog box opens when you 
choose the Unprotect Chart command in the File menu.

Related Topics
         Command information  
         Procedure information  

      Use passwords  



Protecting a Chart

To protect a chart:

1. Open the File menu and choose Protect Chart. The Protect Chart dialog box opens.
2. Type a password. Press Tab.
3. Type the password again, exactly as before.
4. Click OK. The chart is protected from unauthorized changes.

Related Topics
         Command information  
         Dialog Box information  

      Use passwords  
              Unprotecting a chart  



Unprotect Chart Command

Use the Unprotect Chart command in the File menu to remove protection from a chart.

Related Topics
         Dialog Box information  
         Procedure information  

      Use passwords  
              Protect Chart command  
              File menu  



Unprotect Chart Dialog Box

Password text box
Type the password in the Password text box. The password is not case-sensitive. This means that 
uppercase and lowercase letters are considered to be the same. For example, flowchrt is recognized as 
the same password as FlowChrt. The password appears as a series of asterisks (****) as you type. This 
prevents unauthorized persons from viewing the password as you enter it.

Related Topics
         Command information  
         Procedure information  

      Use passwords  



Unprotecting a Chart

To remove chart protection:

1. Open the File menu and choose Unprotect Chart. The Unprotect Chart dialog box opens.
2. Type the correct password.
3. Click OK. The chart is no longer protected.

If you enter the wrong password, ABC Viewer displays a message telling you that the password is 
incorrect. Click OK and enter the correct password. Click Cancel in the Unprotect Chart dialog box if you 
do not know the password. You can enter field data into the chart after you enter the correct password.

Related Topics
         Command information  
         Dialog Box information  

      Use passwords  
              Protecting a chart  



Exit Command

The Exit command in the File menu closes ABC Viewer. Use this command when you finish working with 
the program, or when you want to free memory to work in another program.

Related Topics
Procedure information
Close command
File menu



Closing ABC Viewer

To close ABC Viewer:

· Open the File menu and choose Exit, or press Alt+F4.

If any open chart has changed, and you did not save it before closing ABC Viewer, a dialog box opens 
and requests that you select one of three choices: Yes, No, or Cancel.

· Click Yes to save changes to the current chart before closing ABC Viewer.
· Click No to discard the changes to the chart and close ABC Viewer.
· Click Cancel to cancel the Exit command and return to the active chart.

Related Topics
Command information



Link Command

The Link command in the File menu opens a submenu that lets you choose the Link Ahead command or 
the Link Back command.

Related Topics
         Link Ahead command  
         Link Back command  

      See an attached chart (use links)  
              File menu  



Link Ahead Command

The Link Ahead command in the Link submenu of the File menu and the Link Ahead button are available 
if you have selected a shape that is linked (attached) to another chart or application. You also can double 
click the shape to open the linked chart.

This command, along with the Link Back command, lets you navigate among linked charts.

Symbols and shadows may be used to identify shapes that open linked charts.

You can use the Link Summary window to list the charts that you have viewed and quickly go to one.

You can use the Index window to view a list of charts, their shapes, and their linked charts.

Related Topics
         Procedure information  

      See an attached chart (use links)  
              Link Ahead button  
              Indicators for Link and Notes  
              Link Back command  
              Link Back button  



Link Back Command

The Link Back command in the Link submenu of the File menu and the Link Back button let you view a 
previous chart listed in the Link Summary dialog box. You normally use the command to return to a chart 
that contains a related shape.

This command, along with the Link Ahead command, lets you navigate among linked charts.

You can use the Link Summary window to see the charts that you have viewed and quickly go to one.

You can use the Index window to view a list of charts, their shapes, and their linked charts.

Related Topics
         Link Back button  

      See an attached chart (use links)  
              Indicators for Link and Notes  
              Link Ahead command  
              Link Ahead button  
              Link Summary dialog box  



Going to a Linked Chart

To go to a linked (associated) chart:

1. Select a shape in the chart. If the shape is linked, the Link Ahead button is no longer gray.
2. Double click on the shape.

or
Click the Link Ahead button.
or
Open the File menu, choose the Link command, and choose the Link Ahead command. The 
associated chart appears on your screen.

Related Topics
         Link Ahead command  
         Link Ahead button  

      See an attached chart (use links)  
              Link Back command  
              Link Back button  



Show Link Summary Command

The Show Link Summary command in the File menu and the Show Link Summary button open the Link 
Summary dialog box, which lets you see the chart files that you have linked to and go to one.

Related Topics
         Procedure information  
         Dialog Box information  
         Show Link Summary button  

      Return to a previous chart (use the link summary)  
              File menu  



Link Summary Dialog Box

File area
The chart files that you have linked to are shown in the file area. The active chart is highlighted.

Related Topics
         Show Link Summary button  
         Show Link Summary command  
         Procedure information  

      Return to a previous chart (use the link summary)  



Going to a Previous Chart

To go to a previous chart:

1. Click the Show Link Summary button.
or
Open the File menu and choose the Show Link Summary command.
The Link Summary dialog box opens.

2. Select the chart you want to go to.
3. Click the Go To button. The chart you selected becomes the active chart.

Click the Close button to close the Link Summary dialog box.

Related Topics
         Show Link Summary button  
         Show Link Summary command  
         Dialog Box information  

      Return to a previous chart (use the link summary)  

 



Using On-line Help

On-line help messages provide detailed information about commands, dialog boxes, buttons, and tools; 
procedural information about using ABC Viewer; and additional concepts specific to ABC Viewer and the 
Windows environment.

Accessing On-line Help
You can access help one of three ways. The first way involves pressing F1 to access context-sensitive 
help. When you press F1, you receive a help message specific to the command, dialog box, or button the 
mouse pointer is on.

The second way involves using the Help menu. The Help menu provides commands that give you access 
to the complete help system.

The third way is with the Cue Cards button. Clicking this button opens a menu of the Cue Cards so you 
can choose the one you want.

How Help Messages are Organized
Finding information in the ABC Viewer help system is easy; it is much like using a road map. It provides 
landmarks (related topics) and pointers (jump terms) to get you where you want to go easily.

Help messages are organized hierarchically. Topics are "linked" to subtopics by jump terms.

All ABC Viewer commands contain a Related Topics section that points you to additional information 
related to the following: topic information, dialog box information, and procedure information. Some 
Related Topics sections include a jump to Cue Cards.

Command Messages
Command messages define and describe commands in ABC Viewer.

Dialog Box Messages
Dialog Box messages list and explain the areas of a dialog box.

Procedure Messages
Procedure messages contain step-by-step instructions for performing tasks.

Jump Terms
Some help messages contain underlined words and phrases called "jump" terms. A jump term takes you 
to a related message for that term. Jump terms let you move throughout the help system without returning 
to the Help menu.

Glossary Terms
Words underlined with a dashed line have definitions attached to them. To view a definition for a word, 
point to the word and click the left mouse button. After reading the definition, click the mouse button to 
close the definition.

Printing Help
You can print a help message using the Print Topic command in the File menu of the Help window.

Closing Help
You can close help and return to the chart window in one of four ways.
· Click the Exit button near the top of the Help window. To close a cue card, click the Close button near 

the top of the window.



· Double click the Control menu box in the Help window.
· Choose the Exit command in the File menu of the main Help window.
· Choose the Close command in the Control menu of the main Help window, or press Alt+F4.

ABC Viewer Help
Written and produced by Robert Whitsitt.

 



Index Button

The Index button and the Show Index command in the View menu open and close the Index window. The 
Index window displays a list of charts, shapes, numbers, text, and links.

Related Topics
         Index menu  
         Collapse/Expand button  
         Go To button  
         Show Index command  

      See what charts are available (use the index)  



Index Window

You can display either a list of charts only or charts, shapes, numbers, text, and links in the Index window. 
ABC Viewer lets you copy this information to the Clipboard, print it, and export it to a file using the 
commands in the Index menu.

You can use the index to examine shapes and the text inside them, as well as the link structure between 
charts. ABC Viewer also lets you use the index to find text in a shape and to open the chart that contains 
the shape.

Index information appears inside the Index window. You can view charts while the Index window is open.

To display the Index window:

· Click the Index button in the ABC Viewer toolbar.
or

· Choose the Show Index command in the View menu.
 The Index window opens.

Related Topics
         Index menu  
         Index button  
         Show Index command  

      See what charts are available (use the index)  



Index Menu

The Index menu appears in the Index window. It contains commands you use to choose the charts and 
information you want to include in the index, choose index preferences, find text in charts, and copy or 
print the index information.

View Lets you choose what to include in the index.
Find Finds specified text in charts.
Copy Copies the index.
Copy To Exports the index to a text file.
Print Prints the index.
Preferences Sets index preferences.

Related Topics
         Index button  
         Show Index command  

      See what charts are available (use the index)  



View Command (Index Menu)

The View command in the Index menu opens a submenu of commands that let you choose what 
information to include in the index.

Related Topics
Charts and Shapes command
Charts Only command
Index menu



Charts And Shapes Command

Choose the Charts And Shapes command in the View submenu to display a list of charts in the current 
directory and their shapes. The shapes are listed in numerical order and organized by chart. The phrase 
is linked to -> appears after shapes linked to other charts and points to the linked chart. Linked chart 
information is indented. The list displays the number and text associated with each shape in the list.

Related Topics
Procedure information
View command



Charts Only Command

Choose the Charts Only command in the View submenu to list only the charts in the current directory. The 
charts are listed by name, and the chart links are displayed.

Related Topics
Procedure information
View command



Choosing Information to View

Use the commands in the View submenu to list only the charts in the current directory or the charts and 
their shapes.

To choose the information you want to view:

1. Open the Index menu in the Index window and choose View. The View submenu opens.
2. Choose Charts And Shapes or Charts Only. The items you selected are listed in the index.

Related Topics
Charts and Shapes command
Charts Only command



Copy Command (Index Menu)

The Copy command in the Index menu places a copy of the index information in the Clipboard.

ABC Viewer only copies the information currently displayed. For example, if you collapse a chart listing 
with the View Command (Index Menu), the collapsed information is not copied.

The information copied to the Clipboard is formatted with tabs to indicate linked charts and the shapes 
inside charts.

Related Topics
Procedure information
View command (Index menu)
Index menu



Copying Index Information to the Clipboard

You can copy index information to the Clipboard and then paste it into other applications, such as word 
processing and presentation programs.

To copy index information:

1. Display the information in the index you want to copy.
2. Open the Index menu in the Index window and choose Copy. The index information is copied to the 

Clipboard.

Related Topics
Command information



Copy To Command (Index Menu)

The Copy To command in the Index menu lets you export the index information to a text file.

This feature lets you use index information in reports and presentations created in word processing, 
presentation, and other applications.

The exported index information uses tabs to indicate shapes inside charts and linked charts. The 
exported information includes only the information in the window when you exported it. For example, if 
only chart information is displayed, then only chart information is exported.

Related Topics
Dialog Box information
Procedure information
Index menu



Copy Index To Dialog Box (Index Menu)

When you choose the Copy To command, the Copy Index To dialog box opens. Use this dialog box to 
choose where to store the index information.

Related Topics
Command information
Procedure information



Exporting Index Information

You can export index information to an ASCII text file, which you then can import into other programs.

To export index information:

1. Display the information in the index you want to export.
2. Open the Index menu in the Index window and choose Copy To. The Copy Index To dialog box 

opens.
3. Type a name for the file that will contain the information.
4. Choose the drive and directory where you want to store the file.
5. Click OK. The index information is saved in an ASCII text file.

Related Topics
Command information
Dialog Box information



Print Command (Index Menu)

The Print command in the Index menu prints the index to the currently selected printer.

Related Topics
Dialog Box information
Procedure information
Index menu



Print Index Dialog Box

The Print Index dialog box opens when you choose the Print command in the File menu, and lets you 
choose printing options.

Print to File option
Click Print to File if you want to send output to a file instead of a printer.

Copies area
Click the up or down arrow to choose the number of copies.

Setup button
Click the Setup button to open the Printer Setup dialog box.

Related Topics
Command information
Procedure information



Printing the Index

To print the index:

1. Display the information in the index you want to print. (See Choosing Information to View.)
2. Open the Index menu in the Index window and choose Print. The Print Index dialog box opens.
3. Choose the print options you want. (See Printer Setup command.)
4. Click OK. The index is printed to the current printer.

Related Topics
Command information
Dialog Box information



Preferences Command (Index Menu)

The Preferences command in the Index menu lets you choose the directory that contains the charts you 
want to include in the index, and the font and size in which the text is displayed and printed.

Related Topics
Dialog Box information
Procedure information
Index menu



Index Preferences Dialog Box

When you choose the Preferences command, the Index Preferences dialog box opens. Use this dialog 
box to choose the appropriate directory and subdirectories, and to choose the font and size for index text.

Start at Current Directory
Click the Start at Current Directory button to include the chart files in the current directory.

Start at button
Click the Start at button to include the chart files in another directory. Type the pathname of the directory 
you want in the Start at text box or use the Browse button to locate the directory.

Search Subdirectories button
Click the Search Subdirectories button to include charts in the subdirectories of the current directory.

Browse button
Click the Browse button to locate the directory that contains the charts you want to include in the index.

To browse for a directory:

1. Click Start at.
2. Click the Browse button in the Index Preferences dialog box. A dialog box opens.
3. Choose the drive and directory that contains the charts you want.
4. Click OK. You return to the Index Preferences dialog box. The pathname of the selected directory 

appears in the Start at text box.

Font Selector
Click on the down arrow to drop down a menu of fonts and click on the font you want for the text in your 
index.

(Type) Size
Click on the down arrow to drop down a menu of type sizes and click on the size you want for the text in 
your index.

Related Topics
Command information
Procedure information



Using the Preferences Command in the Index

Use the Preferences command in the Index menu to choose the current directory or another directory and 
to include or exclude chart files in subdirectories.

To choose a directory:

1. Open the Index menu in the Index window and choose Preferences. The Index Preferences dialog 
box opens.

2. Click the Start at Current Directory button to include chart files in the current directory, or click the 
Start at button to include chart files in the directory named in the Start at text box.

3. Type the pathname of the directory you want or click the Browse button to choose the directory, if you 
selected the Start at option. Locate the directory and click OK, if you clicked the Browse button.

4. Click the Search Subdirectories check box to include charts in the subdirectories of the current 
directory. Click the check box again to exclude charts in the subdirectories.

5. Click OK to close the Index Preferences dialog box and list the charts in the current directory.

You can also use the Preferences command to choose the font and point size for the text displayed in the 
index. The chart names appear in bold type in the chosen font; shapes appear in normal type.

To choose the font and size for index text:

1. Open the Index menu in the Index window and choose Preferences. The Index Preferences dialog 
box opens.

2. Click the down arrow to the right of the Font text box and click the font you want.
3. Click the down arrow to the right of the Size text box and click the point size you want.
4. Click OK. The text in the index is changed to the font and size you selected.

Related Topics
Command information
Dialog Box information



Find Command (Index Menu)

The Find command in the Index menu lets you search for text in the shapes listed in the index and open 
the chart that contains the text.

Related Topics
Dialog Box information
Procedure information
Index menu



Find Dialog Box

When you choose the Find command, a dialog box opens. Use this dialog box to find the text you want 
and to display the shape in which the text appears.

Find text box
Type the text that you want to search for in the Find text box.

Whole Word option
Choose the Whole Word option to have ABC Viewer find only whole words with the text you typed in. For 
example, choose this option to find "overflow" and not "overflowing."

Match Upper/Lowercase option
Choose the Match Upper/Lowercase option to have ABC Viewer find only words that have a specific 
pattern of upper and lowercase letters. For example, choose this option to find "Overflow" and not 
"overflow."

Find Next button
Click the Find Next button to find the next instance of the text for which you are searching.

Found in area
The Found in area displays information about the chart or charts found. For example, the chart name, 
shape type, label name, and context of the text are displayed.

Open button
Click the Open button to open the chart

Related Topics
Command information
Procedure information



Finding Text

Choose the Find command in the Index menu to search for any text, whole words only, and exact case 
matches. When ABC Viewer finds the text, information about the shape and chart that contain the text is 
displayed. You then can open the chart.

To find text in shapes in the index:

1. Display the charts in the index you want to search.
2. Open the Index menu in the Index window and choose Find. The Find dialog box opens.
3. Type the text you want to find in the Find text box.
4. Click the Whole Word check box to find text that matches all the characters in the Find text box. For 

example, if you search for process, this option finds Process but not processing.
5. Click the Match Upper/Lowercase check box to find text that exactly matches the case of the text in 

the Find What text box. For example, if you search for process, this option finds processing but not 
Process.

6. Click Find Next. ABC Viewer searches the shapes in the index. When the matching text is found, 
information about the chart and shape containing the text appears in the Find dialog box.

7. Repeat step 6 to find the next text match in the index.
8. Click Open to open the chart and display the shape containing the text.

Related Topics
Command information
Dialog Box information



Collapse/Expand Button

The Collapse/Expand button in the Index window collapses or expands the shape list in the selected 
chart.

When you collapse a chart, all the indented information (shapes and linked charts) associated with the 
level you choose is removed from view. If you are looking at the hierarchy of many linked charts, this 
feature lets you focus on certain parts of the index.

Related Topics
Procedure information
Index window



Expanding and Collapsing Information

Click the Collapse/Expand button in the Index window to expand and collapse the chart information in the 
index.

To collapse information:

1. Click the chart in the Index window you want to collapse.
2. Click the Collapse/Expand button in the Index toolbar or press Enter. The shape and linked chart 

information associated with the selected chart is hidden.

To expand information:

1. Click the chart in the Index window you want to expand.
2. Click the Collapse/Expand button in the Index toolbar or press Enter. The shape and linked chart 

information associated with the selected chart appears in the index.

Related Topics
Command information



Go To Button

The Go To button in the Index window displays the selected chart or shape.

You can scan the index and go directly to the chart or shape you want. This feature is especially useful 
when working with many linked charts that contain numerous shapes.

Related Topics
Procedure information
Index window



Displaying Charts and Shapes Quickly

Click the Go To button in the Index window to quickly open charts and shapes.

To display a chart or shape:

1. Click the chart or shape in the Index window you want.
2. Click the Go To button in the Index toolbar. The selected chart or shape opens.

Double click the name of a chart to quickly open it.

If the chart you select already is open, the chart moves to the front to become the active chart window. 
When you open a shape, the selected shape appears in its chart window.

Related Topics
Button information

 



Messages and Solutions

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A
ABC Automation Type Information incomplete in (table). Call Technical Support.
ABC Viewer cannot edit the (filename).
ABC Viewer is already running.
ABC Viewer is unable to open this file.
C
Cannot find linked chart. Please make sure you have all the necessary files.
Cannot insert an ABC Viewer file.
Cannot locate (filename) to launch.
Cannot open (chart name). ABC cannot find the required external application (program name). Make sure 
(program name) is in the Windows System directory or in the DOS path and try to open (chart name) 
again.
Cannot open (chart name). There is not enough memory to run the required external application (program 
name). Quit one or more Windows applications and then try to open (chart name) again.
Cannot open Clipboard.
Cannot open file.
Cannot open temporary file.
Cannot print.
Cannot read drive.



Cannot register ABC Automation VBX event. The event (event) is not supported. Check spelling.
Cannot register the (event) ABC Automation VBX event.
Cannot register the (event) ABC Automation VBX event. There is a conflict between the running 
(program1_name) program and the (program2_name) program trying to register with ABC Automation. 
Close (program1_name) before running (program2_name) again.
Cannot save to an open chart.
Cannot save to that name. Chart was opened as Read-Only.
Cannot send ABC Automation VBX event. The running ABC Automation VBX is the wrong version.
Cannot update link. Either the Source File, Item, or Server associated with the object is not available.
Can't find ABC Automation Type Information. Make sure (table) is in the same directory as ABC.EXE.
Can't read (value) as (field type). Re-enter the data in this format.
Can't read (value) as a date. Enter a date as month/day, month/year, month/day/year or in (time) format.
Can't read (value) as a number. Enter a number for this field.
Can't read (value) as a percentage. Enter a number for this field.
Can't read (value) as currency. Enter a number for this field.
Can't read (value) as days. Enter a number for this field.
Can't read (value) as hours. Enter a number for this field.
Can't read (value) as hours. Enter a number of hours, or a time in (time) format.
Can't read (value) as minutes. Enter a number for this field.
Can't read (value) as minutes. Enter a number of minutes, or a time in (time) format.
Can't read (value) as seconds. Enter a number for this field.
Can't read (value) as TMUs. Enter a number for this field.
Can't read (value) as weeks. Enter a number for this field.
Chart is already open. Revert to saved version?
(Chart name) has special optional behavior in an external application called (program name). There is not 
enough memory to run (program name). If you wish to run it, close (chart name). Then, quit one or more 
Windows applications and open (chart name) again.
(Chart name) has special optional behavior in an external application called (program name). ABC cannot 
find (program name). If you wish to run it, close (chart name). Then, make sure (program name) is in your 
Windows System directory or in the DOS path and open (chart name) again.
(Chart name) is a protected file.
D
Drive does not exist. Please make sure the correct drive is given.
E
Ending page not within range.
F
Failed to change link source update type.
Failed to get source of the link!
Failed to get update option of the link!
File (filename) does not exist.
(Filename) is already open. Please select another filename, or close the chart and try again.
(Filename) is not a valid workspace file.
I
Incorrect password.
Invalid margins. Usable page area must be greater than 1 square inch.
Invalid margins. Usable page area must be greater than 2.54 square centimeters.
Invalid spacing value.
N
Not a valid filename.
Not a valid page range.
Not enough disk space. Please delete files or use a different drive.
Not enough disk space to print.
Not enough memory.
Not enough memory to print.
Not enough memory to run ABC Viewer.



Number of copies must be between 1 and 99.
O
OLE 2.0 DLLs too old. Reinstall ABC Viewer.
P
Page dimensions must be between 1 and 100 inches.
Page dimensions must be between 2.54 and 254 centimeters.
Page size exceeds paper size. Please check page setup.
Paper and page orientations are different. Please check printer setup.
S
Save changes in (chart name)?
Some open charts of type (type) have special optional behavior in an external application called (program 
name). (Program name) is shutting down. Do you want to close these charts now?
Some open charts of type (type) have special required behavior contained in an external application 
called (program name). (Program name) is shutting down. These charts will now close.
Starting page not within range.
T
Text not found.
The Clipboard is empty.
The document name or path is not valid. (File or path name)
The file already exists. Would you like to replace it?
The file does not exist. Please make sure the correct file is given.
The file name is invalid.
The filename (filename) is not valid.
The path does not exist. Please make sure the correct path is given.
This file is in use by another user. Please choose another file name.
This file is in use by another user. Would you like to open it as a read-only file?
This file is not a chart.
Too many open charts. Please close a chart before continuing.
U
Unable to launch (filename).
Unable to load ABC Automation Type Information. (Table) is the wrong version. Reinstall.
Unable to match printer. Printer driver could not supply page orientation.
Unable to match printer. Printer driver could not supply paper size.
Unable to open file (filename). Access denied.
Unable to open file (filename). General failure.
Unable to open file (filename). Sharing violation.
V
Value entered is out of range. Enter a value between [value] and [value].
Y
You cannot launch (filename) from (filename).
You do not have access rights to this file.



ABC Viewer is already running.

You are trying to open ABC Viewer, and it is already open.

Click OK and use the copy of ABC Viewer that is open.



ABC Viewer is unable to open this file.

The file format has been altered or corrupted, or you are trying to open a file that is not an accepted file 
format.

Load your backup copy of the file and try again, or try another file.



Cannot find linked chart. Please make sure you have all the necessary files.

You are attempting to link to a file that cannot be found..

Locate the missing file if possible.



Cannot open Clipboard.

Another program is not allowing access to the Clipboard.

Close other open programs that may be controlling the Clipboard.



Cannot open file.

The filename you typed does not exist in the specified directory. You also may be trying to open a linked 
file.

Check to see if you typed the filename correctly and if you are using the correct drive and directory. Your 
system also may be low on memory; therefore, close one or more open files and programs and try again.



Cannot open temporary file.

There is not enough room on your disk to open a temporary file.

Delete any unnecessary files or directories from your disk.



Cannot print.

ABC Viewer is unable to print the chart.

Be sure the printer paper is properly installed and the printer is connected and turned on.



Cannot read drive.

You may be trying to read a diskette that is not inserted in the drive properly or is not formatted.

Check to see if the diskette is in the correct drive and the drive door is closed. Also, confirm that the 
diskette is formatted.



Cannot save to that name. Chart was opened as Read-Only.

You are trying to save a file that is read-only, which means you are not allowed to save changes to it.

Type a different filename or save the file in another directory. The original file will not be changed or 
erased.



Chart is already open. Revert to saved version?

You are trying to open a file that is currently open.

Click Yes to open the file that is saved on disk, click No to keep the copy currently on the screen, or click 
Cancel to cancel the operation.

Note: If you click Yes, the changes you have made to the file since saving it last will be discarded.



Drive does not exist. Please make sure the correct drive is given.

You have typed a drive that does not exist or is not available.

Check to see if you typed the correct drive and if you have access to that drive.



Ending page not within range.

The last page you are trying to print is greater than the last page in the chart.

Check the number of pages in the chart by clicking the Entire Chart button. Then select the last page in 
the chart.



(Filename) is not a valid workspace file.

The file you are trying to open is not a workspace file.

Select a different file type in the Open File dialog box and try again.



Incorrect password.

The password you have typed does not match the password of the protected document.

Type the correct password and try again.



Invalid margins. Usable page area must be greater than 1 square inch.

The margins you have selected leave a usable page area that is too small.

Select margins that leave a page area of at least 1 square inch.



Invalid margins. Usable page area must be greater than 2.54 square centimeters.

The margins you have selected leave a usable page area that is too small.

Select margins that leave a page area of at least 2.54 square centimeters.



Invalid spacing value.

You have typed a number that is too large.

Type a number that is smaller than 100 inches or 254 centimeters.



Not a valid filename.

The name you typed does not fit the requirements for filenames.

Be sure you have typed the correct filename. It can be up to eight characters in length, with up to three 
additional characters in the extension. It can start with a letter or number, but cannot contain spaces.

See your Windows or MS-DOS documentation for more information about filenames.



Not a valid page range.

You are trying to print a page range that is invalid. For example, you may have typed page 5 to page 3 as 
the range.

Check the page range you typed or type a new one.



Not enough disk space. Please delete files or use a different drive.

You have tried to save a file or carry out an action that requires more space than is available on disk.

Select another drive, insert a different diskette, or delete any unnecessary files and directories from the 
current drive or diskette.



Not enough disk space to print.

There is not enough space available on your disk to complete the print job.

Delete any unnecessary files and directories from the disk and try again.



Not enough memory.

You have carried out an action that requires more memory than is available. This error message may 
occur while you are trying to open a linked chart file.

Close one or more open files and programs and try again.



Not enough memory to print.

The print job requires more memory than is available.

Close one or more open files and programs and try again.

Note: Be sure to save the file first.



Not enough memory to run ABC Viewer.

Opening ABC Viewer requires more memory than is available.

Close one or more open files and programs and try again.



Number of copies must be between 1 and 99.

You have typed an invalid number of copies to be printed.

Type a number between 1 and 99 and try again.



Page dimensions must be between 1 and 100 inches.

The page dimensions you have selected are not valid.

Type page dimensions between 1 and 100 inches.



Page dimensions must be between 2.54 and 254 centimeters.

The page dimensions you have selected are not valid.

Type page dimensions between 2.54 and 254.0 centimeters.



Page size exceeds paper size. Please check page setup.

The page size of your chart is larger than the paper specified for your printer.

Use the Page Layout dialog box to reduce the page size, or use a larger paper size in your printer. If you 
use a larger paper size, you will have to change the printer setting with the Printer Setup command.



Paper and page orientations are different. Please check printer setup.

The paper and page orientations set for your printer and those specified in the Page Layout dialog box do 
not match. For example, you may have set up your page for landscape mode, but your printer is in 
portrait mode.

Click Yes if you want to let ABC Viewer set the printer to the correct mode. ABC Viewer will set the printer 
back to the previous mode after printing is completed. Click No to cancel the print job.



Save changes in (chart name)?

Changes have been made to the chart that have not been saved.

Click Yes to save the changes. Click No to discard the changes. Click Cancel to stop the operation and 
return to the chart.



Starting page not within range.

The first page you are trying to print is not within the number of pages in the chart.

Check the number of pages in the chart by clicking the Entire Chart button. Then select a page within the 
chart as the starting page.



Text not found.

The text you are searching for cannot be found in the charts or notes in the document.

Check to see if you have typed the text correctly or if you have selected the Match Upper/Lowercase 
option in the Find dialog box. Then repeat the search.



The Clipboard is empty.

Nothing has been copied or cut to the Clipboard.

Try copying or cutting items to the Clipboard again.



The file already exists. Would you like to replace it?

The filename you are using to save the file already exists.

Click Yes to replace the existing file or No to type a different filename.



The file does not exist. Please make sure the correct file is given.

The file you are trying to open does not exist.

Try typing the filename again.



The path does not exist. Please make sure the correct path is given.

You are trying to open a file using a drive or directory that does not exist or is not available.

Check to see if you typed the correct path and if you have access to the specified drive and directory.



This file is in use by another user. Would you like to open it as a read-only file?

You are trying to open a file that is read-only or currently in use.

Click OK to open the file. You cannot save changes to the file using the current filename and directory. If 
you want to save changes, give the file a new name or store it in another directory.



The filename is invalid. Please make sure the correct filename is given.

The name you typed does not fit the requirements for filenames.

Be sure you have typed the correct filename. It can be up to eight characters in length, with up to three 
additional characters in the extension. It can start with a letter or number, but cannot contain spaces.

See your Windows or MS-DOS documentation for more information about filenames.



This file is not a chart.

The file you are trying to open is not the type you specified.

Select a different file type in the Open File dialog box and try again.



Too many open charts. Please close a chart before continuing.

You have opened too many charts to continue working. This error message may occur while you are 
trying to open a linked chart file.

Save and close some of the open chart files.



Unable to match printer. Printer driver could not supply page orientation.

ABC Viewer could not match the printer because the printer driver could not provide the page orientation.

Open the Page Layout dialog box and select the page orientation that matches your printer.



Unable to match printer. Printer driver could not supply paper size.

ABC Viewer could not match the printer because the printer driver could not provide the paper size.

Open the Page Layout dialog box and select the paper size that matches your printer.



You do not have access rights to this file.

You are on a network and are trying to open or change a file to which you do not have network access.

Open another file or see your LAN administrator about getting access rights to the file.



The filename (filename) is not valid.

A directory you typed in the path name does not exist or the filename does not fit the requirements for 
filenames.

Be sure the path you typed includes directories that currently exist. Also, make sure you have typed the 
correct filename. It can be up to eight characters in length, with up to three additional characters in the 
extension. It can start with a letter or number, but cannot contain spaces.

See your Windows or MS-DOS documentation for more information about filenames.



Unable to open file (filename). Access denied.

You have tried to open a file to which you do not have read access.

Select another file, or see your LAN administrator about getting access rights to the file.



Unable to open file (filename). General failure.

You have tried to open a file that ABC Viewer cannot open.

The file may be corrupt or your system may be low on memory. Close one or more open files and 
programs and try again.



Unable to open file (filename). Sharing violation.

You have tried to open a file at the same time someone else on the network is writing to the file.

Wait briefly and try to open the file again.



File (filename) does not exist.

You have selected a file whose associated program file has been deleted. This error message probably 
occurred while you were changing icons.

Select another file to display its icons.



Failed to get source of the link!

ABC Viewer has failed to execute the link because the link source is no longer available.

Check to see that the source file has not been moved or deleted and is available to you.



Failed to get update option of the link!

ABC Viewer has failed to recognize the Update option (automatic or manual) selected for the link.

Run ABC FlowCharter, open the file, open the Edit menu and choose Links. Reset the Update option in 
the Links dialog box.



Failed to change link source update type.

ABC Viewer cannot change the Update option (automatic or manual) for the link.

Open the file in ABC FlowCharter and reset the Update option in the Links dialog box to the original 
selection.



ABC Viewer cannot edit the (filename).

ABC Viewer cannot edit the OLE object you double clicked or execute the Object command you selected.

The object application may be unavailable, or your system may be low on memory. Check to see that the 
object application has not been moved or deleted, and close other programs and files you may have 
open.



Cannot insert an ABC Viewer file.

You have tried to insert an ABC Viewer file into ABC Viewer.

Open the ABC Viewer file using the Open command in the File menu, or select a file in another program 
to insert.



Cannot save to an open chart.

You have tried to save the active chart with the same name and directory as a file that is already open.

Rename the file or choose another directory and try again.



Not enough memory.

You have carried out an action that requires more memory than is available. This error message may 
occur while you are trying to open a linked chart file.

Close one or more open files and programs and try again.



Not a valid page range.

You are trying to print a page range that is invalid. For example, you may have typed page 5 to page 3 as 
the range.

Check the page range you typed or type a new one.



The document name or path is not valid. (File or path name)

The filename you typed contains more than eight characters, a character such as a colon, or an extension 
with more than three characters. You also may have typed an incorrect path.

Retype the filename using only valid characters, or select a filename in the Files list box. Also, make sure 
that you typed the correct path.



Not enough disk space to print.

There is not enough space available on your disk to complete the print job.

Delete any unnecessary files and directories from the disk and try again.



Cannot update link. Either the Source File, Item, or Server associated with the 
object is not available.

The source file, item, or object application (server) necessary to update the link is not available.

Check to see that the source file and object application have not been moved or deleted and are available 
to you. Also, make sure that the item in the Links dialog box is still available in the source file.



This file is in use by another user. Please choose another file name.

You are trying to open a file that is currently in use by someone else on the network.

Select another file to open.



Unable to launch (filename).

You have tried to run a file by clicking on a shape. ABC Viewer has found the file, but cannot run it.

Your system memory may be low, or the application file you tried to run may be corrupt. In addition, the 
file you specified may not be an executable file. (It must be an EXE, COM, BAT, or PIS file.)

Close other open files or programs to free more memory, and check to see that the selected file can be 
used to run a program.



Cannot locate (filename) to launch.

ABC Viewer cannot find the file you selected in order to run the application.

ABC Viewer has searched your Windows and System directories for the file, using the extensions EXE, 
COM, BAT, and PIS to search. It cannot locate the file.

Check to see that the application file you are trying to run has not been moved or deleted and that the file 
is executable.



You cannot launch (filename) from (filename).

You have tried to run ABC Viewer from within ABC Viewer.

Use ABC FlowCharter to change the launch file from ABCVIEW.EXE to another filename.



(Filename) is already open. Please select another filename, or close the chart and 
try again.

You have tried to open a file that is already open in ABC Viewer.

Use the file that is currently open, select a different file to open, or close the open chart file and try again.



Value entered is out of range. Enter a value between [value] and [value].

You made an invalid entry to a field in the Field Viewer.

Re-enter the value within the specified range, or clear the entry.



Can't read (value) as (field type). Re-enter the data in this format.

You have tried to enter a field value that does not correspond to the designated field type.

Re-enter the value.



Can't read (value) as TMUs. Enter a number for this field.

You have tried to enter a field value that is not a TMU.

Re-enter the value as an integer or decimal number.



Can't read (value) as seconds. Enter a number for this field.

You have tried to enter a field value that is not seconds.

Re-enter the value as an integer or decimal number.



Can't read (value) as minutes. Enter a number for this field.

You have tried to enter a field value that is not minutes.

Re-enter the value as an integer or decimal number.



Can't read (value) as hours. Enter a number for this field.

You have tried to enter a field value that is not hours.

Re-enter the value as an integer or decimal number.



Can't read (value) as days. Enter a number for this field.

You have tried to enter a field value that is not minutes.

Re-enter the value as an integer or decimal number.



Can't read (value) as weeks. Enter a number for this field.

You have tried to enter a field value that is not weeks.

Re-enter the value as an integer number.



Can't read (value) as minutes. Enter a number of minutes, or a time in (time) 
format.

You have tried to enter a field value that is not minutes.

Re-enter the value as an integer number, or use the specified format.



Can't read (value) as hours. Enter a number of hours, or a time in (time) format.

You have tried to enter a field value that is not hours.

Re-enter the value as an integer or decimal number, or use the specified format.



Can't read (value) as a date. Enter a date as month/day, month/year, 
month/day/year or in (time) format.

You have tried to enter a field value that is not a date.

Re-enter the value as a date, separated by "/", or enter the date in the specified format. For example, 5/3, 
6/94, or 4/25/95.



Can't read (value) as currency. Enter a number for this field.

You have tried to enter a field value that is not currency.

Re-enter the value as an integer or decimal number. Do not enter the currency symbol.



Can't read (value) as a percentage. Enter a number for this field.

You have tried to enter a field value that is not a percentage.

Re-enter the value as an integer or decimal number. Do not enter the currency symbol.



Can't read (value) as a number. Enter a number for this field.

You have tried to enter a field value that is not a number.

Re-enter the value as an integer number.



This object has been changed. Update (object) before proceeding?

You have edited the embedded OLE object.

Click Yes to accept the edits, or click No to discard the edits.



Cannot register the (event) ABC Automation VBX event.

An OLE Automation program is running and is unable to register an event as requested, probably 
because of VBX conflicts.

The program must be changed so there are no VBX conflicts. Conflicts occur when two programs are 
asking to register the same event for the same chart type. If you define the chart types to be different from 
each other, then the conflict should not occur.

For more information, see Type Property (Chart Object) in the ABC OLE Automation help.



Cannot register the (event) ABC Automation VBX event. There is a conflict 
between the running (program1_name) program and the (program2_name) 
program trying to register with ABC Automation. Close (program1_name) before 
running (program2_name) again.

An OLE Automation program is running and is unable to register an event as requested, probably 
because another OLE program has already registered an event with the same name.

Close the running program and then run the second program again. If you need to run both at the same 
time, then the programs must be changed so there are no VBX conflicts. Conflicts occur when two 
programs are asking to register the same event for the same chart type. If you define the chart types to 
be different from each other, then the conflict should not occur.

For more information, see Type Property (Chart Object) in the ABC OLE Automation help.



Cannot register ABC Automation VBX event. The event (event) is not supported. 
Check spelling.

An OLE Automation program is running and is unable to register an event as requested, probably 
because the event is not spelled exactly correctly.

The program must be changed so the name of the event is spelled correctly.



Cannot send ABC Automation VBX event. The running ABC Automation VBX is 
the wrong version.

An OLE Automation program is running and ABC Viewer is attempting to notify the program of an event.

The ABC Automation VBX must be replaced with a version that is the same version as the 
ABCVIEW.EXE. To ensure that, search for ABCAUTO.VBX. It should only be in the Windows System 
directory. If it is in another directory, delete it. Then reinstall ABC Viewer.



Unable to load ABC Automation Type Information. (Table) is the wrong version. 
Reinstall.

ABC Viewer is unable to find a necessary file.

Reinstall ABC Viewer.



Can't find ABC Automation Type Information. Make sure (table) is in the same 
directory as ABC.EXE.

ABC Viewer is unable to find a necessary file.

Make sure that the table is in the same directory as ABC.EXE. If necessary, reinstall ABC Viewer.



ABC Automation Type Information incomplete in (table). Call Technical Support.

A file needed by ABC Viewer is incomplete.

Call Micrografx Technical Support.



OLE 2.0 DLLs too old. Reinstall ABC Viewer.

The libraries used for OLE 2.0 are out of date.

Reinstall ABC Viewer.



Some open charts of type (type) have special required behavior contained in an 
external application called (program name). (Program name) is shutting down. 
These charts will now close.

One or more charts that you have open require that a specific program be running while the chart is open. 
That program is closing, so the charts must close.

The program must run for the charts to be open. If you want the charts to be open, you must run the 
program. Run the program again and then open the charts. It is possible that opening the charts will start 
the program running again so you can proceed.

Note: The ABC OLE Automation property that prescribes this behavior is TypeRequiresEXE.



Some open charts of type (type) have special optional behavior in an external 
application called (program name). (Program name) is shutting down. Do you 
want to close these charts now?

One or more charts that you have open optionally have a specific program running while the chart is 
open. That program is closing, so you may want to close the charts.

The program may provide some of the behavior for the chart, so it may be to your advantage for the 
program to be running.

· If you want the program to run, answer No, then run the program. It is possible that closing the charts 
(answer Yes) and then opening them again will start the program running again so you can proceed.

· If you do not want the program to run, answer No. You may then continue working without the 
program running.

Note: The ABC OLE Automation property that prescribes this behavior is TypeUsesEXE.



Cannot open (chart name). There is not enough memory to run the required 
external application (program name). Quit one or more Windows applications and 
then try to open (chart name) again.

The chart you tried to open requires that a specific program be running. There is not enough memory to 
run the program, so the chart cannot be opened.

Quit one or more Windows applications to free memory and then try to open the chart again.

Note: The ABC OLE Automation property that prescribes this behavior is TypeRequiresEXE.



Cannot open (chart name). ABC cannot find the required external application 
(program name). Make sure (program name) is in the Windows System directory 
or in the DOS path and try to open (chart name) again.

The chart you tried to open requires that a specific program be running. ABC OLE Automation cannot find 
the required program.

The program should be in the Windows System directory or in the DOS path. Find the program and put it 
there, then try to open the chart again.

Note: The ABC OLE Automation property that prescribes this behavior is TypeRequiresEXE.



(Chart name) has special optional behavior in an external application called 
(program name). There is not enough memory to run (program name). If you wish 
to run it, close (chart name). Then, quit one or more Windows applications and 
open (chart name) again.

The chart that you are trying to open optionally can run with a special program. There is not enough 
memory to run the special program.

The program may provide some of the behavior for the chart, so it may be to your advantage for the 
program to be running. If you want the program to run, close the chart, quit one or more Windows 
applications to free memory, and then try to open the chart again. If you do not want the program to run, 
you may proceed to work with the chart.

Note: The ABC OLE Automation property that prescribes this behavior is TypeUsesEXE.



(Chart name) has special optional behavior in an external application called 
(program name). ABC cannot find (program name). If you wish to run it, close 
(chart name). Then, make sure (program name) is in your Windows System 
directory or in the DOS path and open (chart name) again.

The chart that you are trying to open optionally can run with a special program. ABC OLE Automation 
cannot find the program.

The program may provide some of the behavior for the chart, so it may be to your advantage for the 
program to be running. If you do not want the program to run, you may proceed to work with the chart.

If you want the program to run, close the chart. The program should be in the Windows System directory 
or in the DOS path. Find the program and put it there, then try to open the chart again.

Note: The ABC OLE Automation property that prescribes this behavior is TypeUsesEXE.



(Chart name)is a protected file. You will not be able to make changes to the file 
without first unprotecting with a password.

The chart you opened is protected by a password.

To unprotect the chart so you can work with it, choose the Unprotect Chart command in the File menu, 
enter the password, and choose OK.

 



Note Button

The Show/Hide Note button in the ABC Viewer toolbar and the Show/Hide Note Viewer command in the 
View menu open and close the Note window. The Note window contains text attached to shapes.

Notes can contain detailed information about a step or process that does not appear in a chart.

You view notes inside the Note window. The Note window displays the text attached to the shape. You 
can move and resize the Note window like other windows.

If you select a different shape while the Note window is open, the text is updated. If the shape does not 
have a note, <Object has no note> appears in the Note window.

Related Topics
Opening and closing the Note window
Show Note Viewer command

      View notes attached to shapes  
Note menu
Indicators for link and notes
ABC Viewer Toolbar



Opening and Closing the Note Window

To open and close the Note window:

· Click the Show/Hide Note button in the ABC Viewer toolbar. When the button is selected, the 
Note window is displayed; when the button is deselected, the window is closed. You also can 
double click the Control menu box on the Note window to close it.
or

· Choose the Show/Hide Note Viewer command in the View menu. You also can double click the 
Control menu box on the Note window to close it.

Note: You also can press F7 to open and close the Note window.

Related Topics
         Note button  
         Show Note Viewer command  

      View notes attached to shapes  



Note Menu

The Note menu appears in the Note window. You use the Note window to attach text information to 
shapes. The Note menu contains commands you use to copy the text in the Note window.

Copy command

Related Topics
         Opening the Note window  
         Note button  

      View notes attached to shapes  



Copy Command (Note Menu)

The Copy command in the Note menu copies the text in the Note window and places the copy in the 
Clipboard.

Note: You also can press Ctrl+C to copy text in the Note window.

Related Topics
Procedure information
Note menu



Copying Notes

To copy text in the Note window:

1. Click the Note button to open the Note window (if necessary).
2. Select the shape to which the note is attached.
3. Open the Note menu and choose Copy or press Ctrl+C. The text in the Note window is placed in 

the Clipboard.

Related Topics
Command information

 



Object Linking and Embedding (OLE)

ABC Viewer offers object linking and embedding (OLE) capabilities, letting you place charts in other 
documents.

Object linking and embedding lets you combine information created by different programs in a single 
document. With OLE, your focus is on the document, rather than the program. Documents that contain 
information from two or more OLE-compatible programs are called compound documents.

With OLE, you do not have to worry about having the right file filter or translator. You can share charts, 
spreadsheets, text, drawings, sounds, video, and animation among any OLE-compatible programs.

Click a topic below to learn more about using OLE in ABC Viewer.

Related Topics
Editing a linked ABC Viewer object
Editing an object linked to a chart
Moving linked files
Embedding a chart in a document
Editing an embedded ABC Viewer object
Editing an object embedded in a chart



Linking a Chart to a Document

You can link a chart in ABC Viewer to a document in another OLE-compatible program. The chart 
becomes the object, and the document becomes a compound document.

To link an ABC Viewer object to a document:

1. Open a chart in ABC Viewer.
2. Open the Edit menu and choose Select.
3. Choose All to select the chart (object).

Press Ctrl+A to select the chart in one easy step.

4. Open the Edit menu and choose Copy.
5. Minimize ABC Viewer.
6. Open an OLE-compatible container application, such as Microsoft Word for Windows.
7. Open the document to which you want to link the object.
8. Choose the Paste Link option in the container application. (It probably will appear in the Edit 

menu or a Paste dialog box.)

The object is linked from ABC Viewer (the object application) to the document.

Note: The link may be broken if the source file is deleted or moved to another directory. If a link is broken, 
the chart still can be produced in the container application. It will appear similar to the last time it was 
updated. However, it can no longer be updated from the container application. You must reestablish the 
link within the container application.

Related Topics
Editing a linked ABC Viewer object
Object linking and embedding



Editing a Linked ABC Viewer Object

To edit a linked ABC Viewer object:

1. Double click the ABC Viewer object in the container application. ABC Viewer opens and displays 
the object.

2. Change the chart.
3. Open the File menu and choose Exit. An ABC Viewer dialog box prompts you to save the 

changes.
4. Click Yes. ABC Viewer closes and the compound document displays the changes to the object.

Note: Only data fields can be modified in ABC Viewer.

Related Topics
Object linking and embedding



Editing an Object Linked to a Chart

To edit an object linked to a chart:

1. Double click the object in the chart. The object application opens.
2. Make changes to the object in the application.
3. Minimize the object application. ABC Viewer displays the changes to the object.

Note: If you try to exit the object application, it displays a message asking if you want to save the 
changes to the object. Click Yes to save the changes in the source file. The application then reminds you 
that remote links to a document currently exist and asks if you want to close the program anyway. Click 
Cancel to keep the object application open and maintain the link to ABC Viewer. Click OK to close the 
application and break the link to the chart.

Related Topics
Object linking and embedding



Embedding a Chart in a Document

You can embed a chart created in ABC Viewer in a document in another OLE-compatible program. The 
chart becomes the object, and the document becomes a compound document.

To embed an ABC Viewer object in a document:

1. Open a chart in ABC Viewer.
2. Open the Edit menu and choose Select.
3. Choose All to select the chart (object).

Press Ctrl+A to select the chart in one easy step.

4. Open the Edit menu and choose Copy.
5. Minimize ABC Viewer.

Note: It is not necessary to save an object in a source file before it can be embedded in a document.

6. Open an OLE-compatible container application, such as Microsoft Word for Windows.
7. Open the document in which you want to embed the object.
8. Paste the object into the document. The object is embedded in the document.

Related Topics
Editing an embedded ABC Viewer object
Object linking and embedding



Editing an Embedded ABC Viewer Object

To edit an embedded ABC Viewer object in a document:

1. Double click the ABC Viewer object in the container application. ABC Viewer opens and displays 
the object.

2. Change the chart.
3. Open the File menu and choose Exit & Return to <Compound Document Name>. An ABC Viewer 

dialog box warns that the object has been changed and prompts you to update the compound 
document before proceeding.

4. Click Yes. ABC Viewer closes and the compound document displays the changes to the object.

Note: Only data fields can be modified in ABC Viewer.

Related Topics
Embedding a chart in a document
Object linking and embedding



Editing an Object Embedded in a Chart

To edit an object embedded in a chart:

1. Double click the object in the chart. The object application opens.
2. Make changes to the object in the application.
3. Open the File menu in the object application and choose Update.
4. Minimize the object application. ABC Viewer displays the changes to the object.

Note: If you try to exit the object application without choosing Update, it displays a message asking if you 
want to update the object. Click Yes to update the object in ABC Viewer. The object application closes.

Related Topics
Object linking and embedding



Placing Charts in Other Programs

Using OLE, you can include an ABC Viewer chart in any document created in an OLE-compatible 
program. For example, you can include a chart in a word-processing document. The chart then appears in 
the document each time you open it. The chart is the object. The program in which it was created (ABC 
Viewer) is the object application. The word-processing program is the container application because it 
contains the object.

You can edit the chart directly from the word-processing program just by double clicking on the chart. ABC 
Viewer opens automatically, with the chart already open and waiting to be edited. If the chart is linked, 
you can make changes to it in ABC Viewer, and the changes will appear automatically in the word-
processing document.

Note: Only data fields can be modified in ABC Viewer.

Related Topics
Embedding a chart in a document
Object linking and embedding



Moving Linked Files

You can move a set of linked files and still maintain the links between the files. For example, you may 
want to move a set of linked files from a hard disk to a floppy disk for transporting them. When you open 
the files from the floppy disk, the links are intact.

Note: You must move all the linked files together to the same location.

Related Topics
Object linking and embedding

 



Link Ahead Button

The Link Ahead button and the Link Ahead command in the Link submenu of the File menu are available 
if you have selected a shape that has another chart attached to it (is linked to another chart). You also can 
double click the shape to open the linked chart.

This button, along with the Link Back button, lets you navigate among linked charts. One chart can 
provide an overview of the main topics and contain links to subcharts that provide detailed information 
about the various topics.

Symbols, icons, and shadows are used to identify shapes that open linked charts.

You can use the Link Summary window to see the charts that you have viewed and quickly go to one.

You can use the Index window to view chart links and quickly display shapes in various charts.

Related Topics
Procedure information

      See an attached chart (use links)  
Link Ahead command
Indicators for link and notes
Link Back command
Link Back button
ABC Viewer Toolbar



Opening Related Charts and Running Programs

A shape may have a related chart attached (linked) to it. It also may have another program linked to it. 
Indicators, such as a shadow, a chain link icon, or a text symbol, may indicate a shape that has a related 
chart or program.

To open a related chart or run a program:

· Double click the shape. The related chart opens and becomes the active chart or the program 
runs.
or

· Click the linked shape to select it and click the Link Ahead button or choose the Link Ahead 
command in the Link submenu of the File menu. The linked chart opens and becomes the active 
chart.

Related Topics
Link Ahead button
Link Ahead command

      See an attached chart (use links)  
Indicators for link and notes
Link Back command
Link Back button

 



Window Menu Commands

Click a command below to learn more about it.

Tile Resizes and arranges all open chart windows so that a portion of each chart is visible.
Cascade Arranges all open chart windows so that the title bar of each chart is visible.
Arrange Icons Aligns all the chart icons in the ABC Viewer workspace.
Full Screen Shows all of the elements of your chart on the screen without menus or tools.
Chart List Displays the names of the charts currently open in ABC Viewer.



Tile Command

The Tile command in the Window menu arranges all open chart windows side by side so that a portion of 
each chart is visible.

Related Topics
         Procedure information  

      Arrange chart windows when several are open  
              Window menu  



Tiling Windows

To tile windows:

· Open the Window menu and choose Tile.

Related Topics
         Command information  

      Arrange chart windows when several are open  



Cascade Command

The Cascade command in the Window menu overlaps all open chart windows diagonally. The title bar of 
each chart is visible.

Related Topics
         Procedure information  

      Arrange chart windows when several are open  
              Window menu  



Cascading Windows

To cascade windows:

· Open the Window menu and choose Cascade.

Related Topics
         Command information  

      Arrange chart windows when several are open  



Arrange Icons Command

The Arrange Icons command in the Window menu aligns all the chart icons (charts that have been 
minimized) in the ABC Viewer workspace.

Related Topics
Procedure information
Minimizing and restoring a window
Window menu



Arranging Icons

To arrange window icons:

· Open the Window menu and choose Arrange Icons.

Related Topics
Command information



Full Screen Command

Choose the Full Screen command in the View menu or click the Full Screen button to show all of the 
elements of your chart on the screen without menus or tools. You can use the mouse to draw on the 
screen with three colors of "chalk." Press Esc to return to the previous view.

Related Topics
         Procedure information  
         Full Screen button  

      Give a chalk talk  
              Entire Chart button  
              Zoom In button  
              Zoom Out button  
              View menu  



Chart List

The chart list in the Window menu displays the names of the charts currently open in ABC Viewer. The 
numbers indicate the order in which the charts were opened. A check mark indicates which chart is active.

Related Topics
Procedure information
Window menu



Activating an Open Chart

To activate an open chart:

· Open the Window menu and choose the chart you want in the chart list.

Related Topics
Command information

 



View Menu Commands

Click a command below to learn more about it.

Zoom In command Enlarges the elements of the chart.
Zoom Out command Shows more of the chart.
Entire Chart command Fits the entire chart on the screen.
Show Note Viewer command Opens and closes the Note window.
Show Index command Opens and closes the Index window.



Zoom In Command

Choose the Zoom In command in the View menu or click the Zoom In button to enlarge the elements of 
your chart. To concentrate on a particular element, click on it to select it. When you choose Zoom In, that 
element is centered on your screen.

Related Topics
         Procedure information  
         Zoom In button  
         Zoom Out command  
         Entire Chart command  

      Zoom in or out (change the view)  
              Full Screen button  
              View menu  



Zoom Out Command

Choose the Zoom Out command in the View menu or click the Zoom Out button to see more of your 
chart. Each chart element is made smaller in order to fit more of the chart on your screen.

Related Topics
         Procedure information  
         Zoom Out button  
         Zoom In command  
         Entire Chart command  

      Zoom in or out (change the view)  
              Full Screen button  
              View menu  



Entire Chart Command

Choose the Entire Chart command in the View menu or click the Entire Chart button to fit all of the 
elements of your chart on the screen.

Related Topics
         Procedure information  
         Entire Chart button  
         Zoom Out command  
         Zoom In command  

      Zoom in or out (change the view)  
              Full Screen button  
              View menu  



Show Note Viewer Command

The Show/Hide Note Viewer command in the View menu and the Show/Hide Note button in the ABC 
Viewer toolbar open and close the Note window. The Note window displays text attached to the selected 
shape.

You can show or hide the notes, depending upon your needs. Notes can contain detailed information 
about a step or process that you do not want to clutter the chart.

The Note window displays the text attached to the shape. You can move and resize the Note window like 
other windows.

If you select a different shape while the Note window is open, the text is updated.

Related Topics
         Opening and closing the Note window  
         Note menu  
         Note button  

      View notes attached to shapes  
              View menu  



Show Index Command

The Show/Hide Index command in the View menu and the Show/Hide Index button open and close the 
Index window. The Index window displays a list of charts, shapes, numbers, text, and links.

Related Topics
         Index menu  
         Collapse/Expand button  
         Go To button  
         Index button  

      See what charts are available (use the index)  
              View menu  
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ABC FlowCharter OLE Automation



About ABC Viewer command
Activating an open chart
Arrange Icons command
Arranging icons
B
Bubble Help command
C
Cascade command
Cascading windows
Changing your view of a chart
Chart list
Chart, closing
Chart, printing
Chart, protecting
Charts, unprotecting
Chart, saving
Chart, saving a copy
Charts And Shapes command
Charts, closing all
Charts, displaying
Charts, opening related
Charts Only command
Charts, placing in other programs
Charts, recalling
Choosing information to view
Choosing menus and commands
Choosing options in a dialog box
Clear Fields button
Clear Fields command
Clearing data fields
Close All command
Close command
Closing ABC Viewer
Closing all charts
Closing the active chart
Closing the note window
Collapse/Expand button
Collapsing information
Commands
Commands, choosing
Contents
Copy command (Edit menu)
Copy command (Index menu)
Copy command (Note menu)
Copy To command (Edit menu)
Copy To command (Index menu)
Copying notes
Copying objects
Coping index information to the Clipboard
Cue Cards
Cue Cards button
D
Data fields, clearing
Displaying charts and shapes quickly
E



Editing a linked ABC Viewer object
Editing an embedded ABC Viewer object
Editing an object embedded in a chart
Editing an object linked to a chart
Embedding a chart in a document
Entering field data
Entire Chart button
Entire Chart command
Exit command
Exiting ABC Viewer
Expanding and collapsing information
Exporting index information
F
Field data, reporting
Field data, updating
Field menu commands
Field Viewer button
Field viewer, showing and hiding
File Open button
File Print button
File Save button
Find command (Index menu)
Finding text
Full Screen button
Full Screen command
G
Getting started with ABC Viewer
Go To button
Going to a linked chart
Going to a previous chart
H
Help system to learn about ABC Viewer
I
Index button
Index information, copying
Index information, exporting
Index menu
Index, printing
Index window
Indicators
K
Keyboard shortcuts
L
Link a chart to a document
Link Ahead button
Link Back button
Link command
Link indicators
Link summary
Linked files, moving
M
Maximizing and restoring a window
Menus
Menus, choosing



Minimizing and restoring a window
Mouse shortcut for links
Moving in a dialog box
Moving linked files
Moving windows and icons
N
Note button
Note indicators
Note menu
Note window, opening and closing
Notes, copying
Notes, printing
O
Object command
Object linking and embedding
Objects, copying
Objects, selecting
OLE Automation
Open button
Open command
Opening a file
Opening a workspace
Opening and closing the note window
Opening related charts
Options in a dialog box, choosing
P
Page Layout command
Placing charts in other programs
Preferences command (Index menu)
Preferences command in the index, using
Print button
Print command (File menu)
Print command (Index menu)
Printer, selecting
Printer Setup command
Printing a chart
Printing notes
Printing the index
Programs, running
Protect Chart command
Protecting a chart
R
Recall command
Recalling charts
Redo command
Report Input command
Report Metrics command
Report Output command
Reporting field data
Resizing windows
Reversing a change
Running programs
S
Save As command
Save button



Save command
Saving a chart
Saving a chart copy
Saving a shape
Scroll Grid button
Scroll grid, using
Scroll keys, using
Select command
Selecting a printer
Selecting objects
Selecting objects, shapes, and lines
Setting up the page
Shape, saving
Shortcut for links
Shortcut keys
Show Field Viewer command (Fields menu)
Show Index command
Show Link Summary button
Show Link Summary command
Show Note Viewer command
Showing and hiding the Field Viewer
Speed keys
Switching among application windows
T
Text, finding
Tile command
Tiling windows
Toolbar
Toolbar, using
U
Undo/Redo command
Undoing a change
Unprotect Chart command
Unprotecting a chart
Update command (Fields menu)
Updating data fields
Using full screen view
Using on-line help
Using the Preferences command in the index
Using the scroll grid
Using the scroll keys
Using the toolbar
V
View command (Index menu)
View of a chart
View menu commands
Viewing information
Visual Basic
W
Windows basics
Working with objects
Workspace, opening
Z
Zoom In button
Zoom In command



Zoom Out button
Zoom Out command

 



Using ABC Viewer

Getting started with ABC Viewer
ABC Viewer commands
Using the toolbar and buttons
Working with objects
Indicators for link and notes
Going to a linked chart
Running an application
Opening and closing the Note window
Using Cue Cards
Learning Windows basics
Contents

 



Cue Card Main Menu

Click  to Select What You Want to Do

See Instructions on Using Cue Cards

Open, Save, and Close Charts

Print Charts

Work with Windows and Icons

Change the View of a Chart

See Information Attached to a Shape

Enter Information

Use Passwords and Bubble Help

Go to the Main Help Contents



Open, Save, and Close Charts

Click  to Select What You Want to Do

 See What Charts Are Available (Use the Index)

 Open a Chart File

Open a Chart You Looked at Recently (Recall a File)

 Save the Changes You Made to a Chart (Save a Chart File)

Make a Copy of a Chart File

Remove a Chart File from the Screen (Close a File)

See Instructions on Using Cue Cards



Work with Windows and Icons

Click  to Select What You Want to Do

Change a Chart File to an Icon (Minimize a Chart File)

Open a Chart File that Is an Icon (Maximize a Chart File)

Arrange Chart Windows when Several Are Open

See Instructions on Using Cue Cards



See Information Attached to a Shape

Click  to Select What You Want to Do

 

 See an Attached Chart (Use Links)

 Return to a Previous Chart (Use the Link Summary)

 View Notes Attached to Shapes

See Instructions on Using Cue Cards



Change the View of a Chart

Click  to Select What You Want to Do

 

 

 Zoom In or Out (Change the View)

 Give a Chalk Talk

See Instructions on Using Cue Cards



Enter Information

Click  to Select What You Want to Do

 View or Enter Information (Use the Field Viewer)

 Clear Data Field Values

Make a Report

See Instructions on Using Cue Cards



Use Passwords and Bubble Help

Click  to Select What You Want to Do

Use Passwords

Use Bubble Help

See Instructions on Using Cue Cards



Print Charts

Click  to Select What You Want to Do

 Print a Chart

Set Printer Options

See Instructions on Using Cue Cards





Using ABC Viewer Cue Cards

ABC Viewer Cue Cards help you with the basics of ABC Viewer.

This Window Stays on Top

This window stays on top of ABC Viewer so you can always see the steps. You can move the window by pointing to the title bar, 
pressing and holding the left mouse button, and dragging the window. When it is where you want it, release the mouse button.

Use the Buttons

Two buttons may appear at the bottom of cards. Point to them with the mouse and click.

Takes you to the previous Cue Card in a sequence.

Takes you to the next Cue Card in a sequence.

(Click the button below.)



Using ABC Viewer Cue Cards (cont.)

Use the Buttons (cont.)

There are two buttons at the top of the window. You can point to them with the mouse and click.

Takes you to the Cue Card Main Menu.

Closes the Cue Cards.

Scroll this Window to See More

If there is more information than will fit in the Cue Card window, there is a scroll bar to the right of the window.

To see additional information, press the Page Down key or point the mouse below the button in the scroll bar and click.

To scroll back up, press the Page Up key or point the mouse above the button in the scroll bar and click the mouse button.

You can also point to the button in the scroll bar, press and hold the mouse button, drag the button in the scroll bar where you want 
it, and release the mouse button.



Open a Chart File 

You open a chart file so you can work with it.
1. Point to the Open button in the toolbar.

2. Click the left mouse button. The Open dialog box opens.

3. Click the down arrow to the right of the Drives area and click the drive where the file is located, if necessary.

4. Double click the directory in the Directories area where the file is located, if necessary.



Open a Chart File (cont.) 

5. Click the file you want to open in the File Name area.

6. Click OK. The file opens.

What do you want to do next?

See Information about the Open Button

Open a Chart You Looked at Recently (Recall a File)

See an Attached Chart

See Instructions on Using Cue Cards



Open a Chart File (cont.) 

5. Click the file you want to open in the File Name area.

6. Click OK. The file opens.

What do you want to do next?

See Information about the Open Button

Open a Chart You Looked at Recently (Recall a File)

See an Attached Chart

See Instructions on Using Cue Cards



Open a Chart You Looked at Recently (Recall a File)

ABC Viewer remembers the last nine files that you opened or saved. You can recall one of them quickly.

1. Point to the word File in the upper left corner of the ABC Viewer window.

2. Click the left mouse button. The File menu opens.

3. Click the Recall command. The Recall submenu opens.

4. Click the file you want to open. The file opens.

What do you want to do next?

See Information about the Recall Command

Open a Chart File

See Instructions on Using Cue Cards



Open a Chart You Looked at Recently (Recall a File)

ABC Viewer remembers the last nine files that you opened or saved. You can recall one of them quickly.

1. Point to the word File in the upper left corner of the ABC Viewer window.

2. Click the left mouse button. The File menu opens.

3. Click the Recall command. The Recall submenu opens.

4. Click the file you want to open. The file opens.

What do you want to do next?

See Information about the Recall Command

Open a Chart File

See Instructions on Using Cue Cards



Save the Changes You Made to a Chart (Save a Chart File) 

If you make changes to a chart file, you can save those changes.
1. Point to the Save button in the toolbar.

2. Click the left mouse button. The file is saved over the existing file.

What do you want to do next?

See Information about the Save Button

Open a Chart File

Make a Copy of a Chart File

See Instructions on Using Cue Cards



Save the Changes You Made to a Chart (Save a Chart File) 

If you make changes to a chart file, you can save those changes.
1. Point to the Save button in the toolbar.

2. Click the left mouse button. The file is saved over the existing file.

What do you want to do next?

See Information about the Save Button

Open a Chart File

Make a Copy of a Chart File

See Instructions on Using Cue Cards



Make a Copy of a Chart File

If you wish, you can make a copy of chart file under a different name.

1. Point to the word File in the upper left corner of the ABC Viewer window.

2. Click the left mouse button. The File menu opens.

3. Click the Save As command. The Save File dialog box opens.

4. Type a file name for the chart copy. Use a different name to distinguish between the copy and the original.

5. Choose the drive and directory in which you want to store the copy, if they are different from the current drive and directory.

6. Click OK. A copy of the active chart is stored with the new file name.



Make a Copy of a Chart File (cont.)

If you entered an existing file name, a message appears, asking if you want to replace the existing file.

· Click No if you do not want to replace the file. You return to the Save File dialog box. Type a different name in the File Name 
text box or choose another directory.

· Click Yes if you want to replace the file.

What do you want to do next?

See Information about the Save As Command

Save the Changes You Made to a Chart

See Instructions on Using Cue Cards



Make a Copy of a Chart File (cont.)

If you entered an existing file name, a message appears, asking if you want to replace the existing file.

· Click No if you do not want to replace the file. You return to the Save File dialog box. Type a different name in the File Name 
text box or choose another directory.

· Click Yes if you want to replace the file.

What do you want to do next?

See Information about the Save As Command

Save the Changes You Made to a Chart

See Instructions on Using Cue Cards



Remove a Chart File from the Screen (Close a File)

You can remove a file from the screen by closing it. If you have made changes and have not yet saved the changes, ABC Viewer 
offers to let you save the changed file. If you want to come back to the chart shortly, you can change it to an icon.

1. Point to the word File in the upper left corner of the ABC Viewer window.

2. Click the left mouse button. The File menu opens.

3. Click the Close command. The chart file closes.

Note: If you prefer, you can close all open charts by choosing the Close All command instead of the Close command.



Remove a Chart File from the Screen (Close a File) (cont.)

If a closing chart contains changes that you have not saved, ABC Viewer displays a message asking if you want to save the 
changes. Respond to the message in one of three ways.

· Click Yes to save the changes. ABC Viewer saves the changes and closes the active chart.

· Click No to discard the changes. The active chart closes without saving the changes.

· Click Cancel to cancel the Close command. You return to the chart.



Remove a Chart File from the Screen (Close a File) (cont.)

What do you want to do next?

See Information about the Close Command

See Information about the Close All Command

Change a Chart File to an Icon (Minimize a Chart File)

Save the Changes You Made to a Chart (Save a Chart File)

Open a Chart File

See Instructions on Using Cue Cards



Remove a Chart File from the Screen (Close a File) (cont.)

What do you want to do next?

See Information about the Close Command

See Information about the Close All Command

Change a Chart File to an Icon (Minimize a Chart File)

Save the Changes You Made to a Chart (Save a Chart File)

Open a Chart File

See Instructions on Using Cue Cards



Remove a Chart File from the Screen (Close a File) (cont.)

What do you want to do next?

See Information about the Close Command

See Information about the Close All Command

Change a Chart File to an Icon (Minimize a Chart File)

Save the Changes You Made to a Chart (Save a Chart File)

Open a Chart File

See Instructions on Using Cue Cards



Change a Chart File to an Icon (Minimize a Chart File) 

Rather than closing a chart file, you can minimize it to an icon at the bottom of the ABC Viewer window. Then you can quickly open it 
again when you want to work with it.

1. Point to the Minimize button  for the chart window (not the Minimize button for ABC Viewer). Every window has a Minimize 
button.

Note: If the Minimize button is not visible, click the Restore button . The window becomes smaller. (To make the window cover 
the entire ABC Viewer window, click the Maximize button 

.)



Change a Chart File to an Icon (Minimize a Chart File) (cont.) 

2. Click the left mouse button. The chart file becomes an icon at the bottom of the ABC Viewer window.

What do you want to do next?

See Information about Minimizing and Restoring a Window

Open a Chart File that Is an Icon (Maximize a Chart File)

Remove a Chart File from the Screen (Close a File)

See Instructions on Using Cue Cards



Change a Chart File to an Icon (Minimize a Chart File) (cont.) 

2. Click the left mouse button. The chart file becomes an icon at the bottom of the ABC Viewer window.

What do you want to do next?

See Information about Minimizing and Restoring a Window

Open a Chart File that Is an Icon (Maximize a Chart File)

Remove a Chart File from the Screen (Close a File)

See Instructions on Using Cue Cards



Open a Chart File that Is an Icon (Maximize a Chart File)

You can quickly open the window of a chart file you turned into an icon.

1. Point to the icon.

2. Double click the mouse button (click twice quickly). The icon expands to a window.

Note: To make the window cover the entire ABC Viewer window, click the Maximize button .

What do you want to do next?

See Information about Maximizing and Restoring a Window

Change a Chart File to an Icon (Minimize a Chart File)

See Instructions on Using Cue Cards



Open a Chart File that Is an Icon (Maximize a Chart File)

You can quickly open the window of a chart file you turned into an icon.

1. Point to the icon.

2. Double click the mouse button (click twice quickly). The icon expands to a window.

Note: To make the window cover the entire ABC Viewer window, click the Maximize button .

What do you want to do next?

See Information about Maximizing and Restoring a Window

Change a Chart File to an Icon (Minimize a Chart File)

See Instructions on Using Cue Cards



Arrange Chart Windows when Several Are Open

If you have several chart files open, you can arrange them so you can see them all.

One choice is to arrange the windows so none of the windows overlap.

Tile ABC Viewer Chart Windows

1. Point to the word Window in the ABC Viewer menu bar.

2. Click the left mouse button. The Window menu opens.

3. Click the Tile command. The windows are arranged on the screen so a portion of each of them is visible.



Arrange Chart Windows when Several Are Open (cont.)

Alternatively, you can arrange the charts so the title bar of each one is visible.

Cascade ABC Viewer Chart Windows

1. Point to the word Window in the ABC Viewer menu bar.

2. Click the left mouse button. The Window menu opens.

3. Click the Cascade command. The windows are arranged one on top of the other so the title bars of each are visible.



Arrange Chart Windows when Several Are Open (cont.)

After you display all the windows, you can work with one by clicking anywhere in it to make it the active window.

To make a window cover the entire ABC Viewer window, click its Maximize button .

What do you want to do next?

See Information about the Tile Command

See Information about the Cascade Command

See Information about Maximizing and Restoring a Window

See Information about Moving Windows and Icons

Change a Chart File to an Icon (Minimize a Chart File)

Remove a Chart File from the Screen (Close a File)

See Instructions on Using Cue Cards



Arrange Chart Windows when Several Are Open (cont.)

After you display all the windows, you can work with one by clicking anywhere in it to make it the active window.

To make a window cover the entire ABC Viewer window, click its Maximize button .

What do you want to do next?

See Information about the Tile Command

See Information about the Cascade Command

See Information about Maximizing and Restoring a Window

See Information about Moving Windows and Icons

Change a Chart File to an Icon (Minimize a Chart File)

Remove a Chart File from the Screen (Close a File)

See Instructions on Using Cue Cards



Arrange Chart Windows when Several Are Open (cont.)

After you display all the windows, you can work with one by clicking anywhere in it to make it the active window.

To make a window cover the entire ABC Viewer window, click its Maximize button .

What do you want to do next?

See Information about the Tile Command

See Information about the Cascade Command

See Information about Maximizing and Restoring a Window

See Information about Moving Windows and Icons

Change a Chart File to an Icon (Minimize a Chart File)

Remove a Chart File from the Screen (Close a File)

See Instructions on Using Cue Cards



Arrange Chart Windows when Several Are Open (cont.)

After you display all the windows, you can work with one by clicking anywhere in it to make it the active window.

To make a window cover the entire ABC Viewer window, click its Maximize button .

What do you want to do next?

See Information about the Tile Command

See Information about the Cascade Command

See Information about Maximizing and Restoring a Window

See Information about Moving Windows and Icons

Change a Chart File to an Icon (Minimize a Chart File)

Remove a Chart File from the Screen (Close a File)

See Instructions on Using Cue Cards



Arrange Chart Windows when Several Are Open (cont.)

After you display all the windows, you can work with one by clicking anywhere in it to make it the active window.

To make a window cover the entire ABC Viewer window, click its Maximize button .

What do you want to do next?

See Information about the Tile Command

See Information about the Cascade Command

See Information about Maximizing and Restoring a Window

See Information about Moving Windows and Icons

Change a Chart File to an Icon (Minimize a Chart File)

Remove a Chart File from the Screen (Close a File)

See Instructions on Using Cue Cards



Print a Chart 

You can print a chart at any time. If you wish, you can first confirm or change the printer setup. (You only need to set up the printer if 
you want to change it from the standard printer chosen in the Windows Control Panel.)

1. Point to the Print button .

2. Click the mouse button. The active chart is printed to the selected printer using its options.
What do you want to do next?

See Information about the Print Button

Set Printer Options

Open a Chart File

See Instructions on Using Cue Cards



Print a Chart 

You can print a chart at any time. If you wish, you can first confirm or change the printer setup. (You only need to set up the printer if 
you want to change it from the standard printer chosen in the Windows Control Panel.)

1. Point to the Print button .

2. Click the mouse button. The active chart is printed to the selected printer using its options.
What do you want to do next?

See Information about the Print Button

Set Printer Options

Open a Chart File

See Instructions on Using Cue Cards



Set Printer Options

You can first confirm or change the printer setup. You only need to set up the printer if you want to change it from the standard 
printer chosen in the Windows Control Panel.

1. Point to the word File in the upper left corner of the ABC Viewer window.

2. Click the left mouse button. The File menu opens.

3. Click the Printer Setup command. The Printer Setup dialog box opens.

4. Click the printer you want to use to select it.



Set Printer Options (cont.)

5. Click the Options button to open the dialog box for the printer, if you wish. You can set various options such as page size, 
orientation, etc. Click OK when the options are as you wish.

6. Click OK in the Printer Setup dialog box. The dialog box closes. Anything you print will go to the printer you selected.

What do you want to do next?

See Information about Setting Printer Options

Print a Chart

See Instructions on Using Cue Cards



Set Printer Options (cont.)

5. Click the Options button to open the dialog box for the printer, if you wish. You can set various options such as page size, 
orientation, etc. Click OK when the options are as you wish.

6. Click OK in the Printer Setup dialog box. The dialog box closes. Anything you print will go to the printer you selected.

What do you want to do next?

See Information about Setting Printer Options

Print a Chart

See Instructions on Using Cue Cards



See an Attached Chart (Use Links)  

Some of the shapes in a chart may access other charts or let you run another program. There are two ways you can open the chart 
attached (linked) to a shape.

Note: Many shapes that access another chart, or run another program, display the chain link indicator .
· Double click on the shape. (If the shape is set up to run a program instead of to go to a linked chart, this runs the program.)

· Click on the shape to select it and then click the Link Ahead button  or select the Link Ahead command in the Link 
submenu of the File menu.

Note: If the Link Ahead button or command is gray, then there is not a chart linked to the chart element you selected.



See an Attached Chart (Use Links) (cont.)  

You can return to a previous chart using the Link Back button  or command.
· Click the Link Back button or select the Link Back command in the Link submenu of the File menu. The previous chart appears 

on your screen.

Note: If the Link Back button or command is gray, there is no previous chart.

What do you want to do next?

See Information about the Link Ahead Button

See Information about the Link Back Button

Return to a Previous Chart (Use the Link Summary)

Open a Chart File

See Instructions on Using Cue Cards



See an Attached Chart (Use Links) (cont.)  

You can return to a previous chart using the Link Back button  or command.
· Click the Link Back button or select the Link Back command in the Link submenu of the File menu. The previous chart appears 

on your screen.

Note: If the Link Back button or command is gray, there is no previous chart.

What do you want to do next?

See Information about the Link Ahead Button

See Information about the Link Back Button

Return to a Previous Chart (Use the Link Summary)

Open a Chart File

See Instructions on Using Cue Cards



See an Attached Chart (Use Links) (cont.)  

You can return to a previous chart using the Link Back button  or command.
· Click the Link Back button or select the Link Back command in the Link submenu of the File menu. The previous chart appears 

on your screen.

Note: If the Link Back button or command is gray, there is no previous chart.

What do you want to do next?

See Information about the Link Ahead Button

See Information about the Link Back Button

Return to a Previous Chart (Use the Link Summary)

Open a Chart File

See Instructions on Using Cue Cards



Return to a Previous Chart (Use the Link Summary) 

If you have looked at several charts, you can return quickly to one of them.
1. Click the Show Link Summary button. The Link Summary dialog box opens. It lists all charts that you have looked at in the ABC 

Viewer session.

2. Double click the chart you want to go to, or click on the chart you want to go to and then click the Go To button . That 
chart becomes the active chart.

What do you want to do next?

See Information about the Show Link Summary Button

See an Attached Chart

See Instructions on Using Cue Cards



Return to a Previous Chart (Use the Link Summary) 

If you have looked at several charts, you can return quickly to one of them.
1. Click the Show Link Summary button. The Link Summary dialog box opens. It lists all charts that you have looked at in the ABC 

Viewer session.

2. Double click the chart you want to go to, or click on the chart you want to go to and then click the Go To button . That 
chart becomes the active chart.

What do you want to do next?

See Information about the Show Link Summary Button

See an Attached Chart

See Instructions on Using Cue Cards



Zoom In or Out (Change the View)  

 

You can look more closely at a chart or get a broader view. You can also see the entire chart (all of the elements of the chart).

Look More Closely at a Chart 
1. Click the chart element you want to be in the center of the chart window to select it, if you wish.

2. Click the Zoom In button. You see a closer view of the chart. If you selected an element, it is centered in the window.



Zoom In or Out (Change the View) (cont.)  

 

Get a Broader View of a Chart 
1. Click the chart element you want to be in the center of the chart window to select it, if you wish.

2. Click the Zoom Out button. You see a broader view of the chart. If you selected an element, it is centered in the window.



Zoom In or Out (Change the View) (cont.)  

 

See the Entire Chart 
1. Click the Entire Chart button. The view gets closer or broader to show the entire chart in the window.

What do you want to do next?

See Information about the Zoom In Button

See Information about the Zoom Out Button

See Information about the Entire Chart Button

Give a Chalk Talk

See Instructions on Using Cue Cards



Zoom In or Out (Change the View) (cont.)  

 

See the Entire Chart 
1. Click the Entire Chart button. The view gets closer or broader to show the entire chart in the window.

What do you want to do next?

See Information about the Zoom In Button

See Information about the Zoom Out Button

See Information about the Entire Chart Button

Give a Chalk Talk

See Instructions on Using Cue Cards



Zoom In or Out (Change the View) (cont.)  

 

See the Entire Chart 
1. Click the Entire Chart button. The view gets closer or broader to show the entire chart in the window.

What do you want to do next?

See Information about the Zoom In Button

See Information about the Zoom Out Button

See Information about the Entire Chart Button

Give a Chalk Talk

See Instructions on Using Cue Cards



Zoom In or Out (Change the View) (cont.)  

 

See the Entire Chart 
1. Click the Entire Chart button. The view gets closer or broader to show the entire chart in the window.

What do you want to do next?

See Information about the Zoom In Button

See Information about the Zoom Out Button

See Information about the Entire Chart Button

Give a Chalk Talk

See Instructions on Using Cue Cards



View Notes Attached to Shapes 

A shape may have a note attached to it. You can hide or show the notes.
If a chart element has notes, it probably has an indicator. The indicator is often "-N" near the top of the shape, or a shape shadow. If 
the person who prepared the chart has changed the indicator, he or she should tell you what the new indicator is.
You see notes by opening the Note window. Its contents vary depending on the shape you select.
If you select a different shape while the Note window is open, the note for the new shape is shown. You can leave the Note window 
open, if you wish.



View Notes Attached to Shapes (cont.) 

Open and Close the Note Window 
1. Click the chart element you want to see notes about to select it.

2. Click the Show/Hide Note button. The Note window opens so you can read    notes about the selected chart element.

3. Click a different chart element to read notes about it.

4. Click the Show/Hide Note button again to close the Note window.

Note: You also can press F7 to open and close the Note window.

What do you want to do next?

See Information about the Show/Hide Note Button

Save the Changes You Made to a Chart (Save a Chart File)

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



View Notes Attached to Shapes (cont.) 

Open and Close the Note Window 
1. Click the chart element you want to see notes about to select it.

2. Click the Show/Hide Note button. The Note window opens so you can read    notes about the selected chart element.

3. Click a different chart element to read notes about it.

4. Click the Show/Hide Note button again to close the Note window.

Note: You also can press F7 to open and close the Note window.

What do you want to do next?

See Information about the Show/Hide Note Button

Save the Changes You Made to a Chart (Save a Chart File)

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



View or Enter Information (Use the Field Viewer) 

The Field Viewer dialog box shows values for the shape you selected if the chart is designed to accept information in fields. You can 
enter information if you wish.
Note: If no field types are defined for the chart, the Field Viewer button is gray.



View or Enter Information (Use the Field Viewer) (cont.) 

Open and Close the Field Viewer 
1. Click the shape you are interested in to select it.

2. Click the Field Viewer button. The Field Viewer window opens so you can view or enter information about the selected shape.

3. Click a different shape to view or enter information about it.

4. Click the Field Viewer button again to close the Field Viewer window.

Note: You can leave the Field Viewer window open, if you wish.

Note: You also can press F6 to open and close the Field Viewer window.



View or Enter Information (Use the Field Viewer) (cont.) 

Enter Field Information

1. Open the Field Viewer window.

2. Select the shape you want to enter information about.

3. Enter the information.

4. Save the file with the new information.

Note: You can press Tab to switch between fields.

What do you want to do next?

See Information about the Show Field Viewer Button

See Information about Entering Field Data

Clear Data Field Values

View Notes Attached to Shapes

Save the Changes You Made to a Chart (Save a Chart File)

See Instructions on Using Cue Cards



View or Enter Information (Use the Field Viewer) (cont.) 

Enter Field Information

1. Open the Field Viewer window.

2. Select the shape you want to enter information about.

3. Enter the information.

4. Save the file with the new information.

Note: You can press Tab to switch between fields.

What do you want to do next?

See Information about the Show Field Viewer Button

See Information about Entering Field Data

Clear Data Field Values

View Notes Attached to Shapes

Save the Changes You Made to a Chart (Save a Chart File)

See Instructions on Using Cue Cards



View or Enter Information (Use the Field Viewer) (cont.) 

Enter Field Information

1. Open the Field Viewer window.

2. Select the shape you want to enter information about.

3. Enter the information.

4. Save the file with the new information.

Note: You can press Tab to switch between fields.

What do you want to do next?

See Information about the Show Field Viewer Button

See Information about Entering Field Data

Clear Data Field Values

View Notes Attached to Shapes

Save the Changes You Made to a Chart (Save a Chart File)

See Instructions on Using Cue Cards



Clear Data Field Values 

If you wish, you can clear all values from all fields in a chart. You might want to clear the information so you can enter new 
information for a new project.
Note: If no field types are defined for the chart, the Clear Fields button is gray.
1. Click the Clear Fields button. A confirmation dialog box appears.

2. Click OK. All field information is cleared from all fields in the chart.

What do you want to do next?

See Information about the Clear Fields Button

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



Clear Data Field Values 

If you wish, you can clear all values from all fields in a chart. You might want to clear the information so you can enter new 
information for a new project.
Note: If no field types are defined for the chart, the Clear Fields button is gray.
1. Click the Clear Fields button. A confirmation dialog box appears.

2. Click OK. All field information is cleared from all fields in the chart.

What do you want to do next?

See Information about the Clear Fields Button

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



See What Charts Are Available (Use the Index) 

You can see a list of charts and their shapes, numbers, text, and links in the Index window.
1. Click the Index button. The Index window opens. After a moment, it shows a list of the charts and the shapes in them.

2. Use the Collapse/Expand button  to see more or less detail

3. Use the Go To button  to go to a specific chart.
4. Use the commands in the Index menu to choose another directory.
5. Click the Index button again. The Index window closes.



See What Charts Are Available (Use the Index) (cont.) 

What do you want to do next?

See Information about the Index Button

See Information about the Index Window

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



See What Charts Are Available (Use the Index) (cont.) 

What do you want to do next?

See Information about the Index Button

See Information about the Index Window

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



See What Charts Are Available (Use the Index) (cont.) 

What do you want to do next?

See Information about the Index Button

See Information about the Index Window

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



Use Passwords

A chart you open may be protected by a password. Before you can make changes to the chart, you must enter the password.

Enter a Password

1. Point to the word File in the upper left corner of the ABC Viewer window.

2. Click the left mouse button. The File menu opens.

3. Click the Unprotect Chart command. The Unprotect Chart dialog box opens.

Note: If the chart is not protected, the File menu contains the Protect Chart command instead of the Unprotect Chart command. You 
can work with the chart without entering a password.



Use Passwords (cont.)

4. Type the correct password. The password appears as a series of asterisks (****) as you type. The password is not case-
sensitive, so uppercase and lowercase letters are considered to be the same.

5. Click OK. The chart is no longer protected.



Use Passwords (cont.)

You can give a password to a chart if you don't want anyone to change it unless they know the password.

Assign a Password

1. Point to the word File in the upper left corner of the ABC Viewer window.

2. Click the left mouse button. The File menu opens.

3. Click the Protect Chart command. The Protect Chart dialog box opens.

Note: If the chart is already protected, the File menu contains the Unprotect Chart command instead of the Protect Chart command. 
You must enter the correct password before you can work with the chart.



Use Passwords (cont.)

4. Enter a password. The password appears as a series of asterisks (****) as you type. The password is not case-sensitive, so 
uppercase and lowercase letters are considered to be the same.

5. Press Tab to move to the Verify text box.

6. Enter the password again exactly the same as you entered it the first time.

7. Click OK. The chart cannot be edited by anyone who does not know the password.



Use Passwords (cont.)

What do you want to do next?

See Information about the Unprotect Chart Command

See Information about the Protect Chart Command

See Instructions on Using Cue Cards



Use Passwords (cont.)

What do you want to do next?

See Information about the Unprotect Chart Command

See Information about the Protect Chart Command

See Instructions on Using Cue Cards



Use Passwords (cont.)

What do you want to do next?

See Information about the Unprotect Chart Command

See Information about the Protect Chart Command

See Instructions on Using Cue Cards



Make a Report

ABC Viewer can make a report of the data in a chart's fields. These steps are for a printed report

1. Point to the word Fields in the    ABC Viewer menu bar.

2. Click the left mouse button. The Fields menu opens.

3. Click the Report command. The Report Submenu opens.

4. Click the type of report you want: Input, Output, or Metrics. The Field Report dialog box opens.

5. Click the Output to Printer option to select it.

6. Click the Options button. The Field Report Options dialog box opens.

7. Click a sort method to select it.



Make a Report (cont.)

8. Click the items to be included in the report to select them.

9. Click the orientation of the paper you want.

10. Click OK to close the dialog box. The Field Report dialog box appears.

11. Click OK. The Print Field Report dialog box appears.

12. Enter the number of copies you want to print.

13. Click the Setup button to open the dialog box for the printer, if you wish. You can set various options such as page size, 
orientation, etc. Click OK when the options are as you wish.



Make a Report (cont.)

14. Click OK. The field report is printed to the selected printer.

Note: See the Information about Reporting Field Data for information on sending the report to a file or to the Windows Clipboard.

What do you want to do next?

See Information about the Report Command

See Information about Reporting Field Data

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



Make a Report (cont.)

14. Click OK. The field report is printed to the selected printer.

Note: See the Information about Reporting Field Data for information on sending the report to a file or to the Windows Clipboard.

What do you want to do next?

See Information about the Report Command

See Information about Reporting Field Data

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



Make a Report (cont.)

14. Click OK. The field report is printed to the selected printer.

Note: See the Information about Reporting Field Data for information on sending the report to a file or to the Windows Clipboard.

What do you want to do next?

See Information about the Report Command

See Information about Reporting Field Data

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



Use Bubble Help

If you place the mouse cursor over an ABC Viewer button and hesitate briefly, a "bubble" appears with the name of the button. You 
can turn the Bubble Help off and back on.

Turn Off Bubble Help

1. Point to the word Help in the ABC Viewer menu bar.

2. Click the left mouse button. The Help menu opens. The Bubble Help command has a check mark beside it to show that Bubble 
Help is turned on.

3. Click the Bubble Help command. Bubble Help is turned off.



Use Bubble Help (cont.)

Turn On Bubble Help

1. Point to the word Help in the ABC Viewer menu bar.

2. Click the left mouse button. The Help menu opens. The Bubble Help command does not have a check mark beside it because 
it is turned off.

3. Click the Bubble Help command. Bubble Help is turned on.

What do you want to do next?

See Information about the Bubble Help Command

See Instructions on Using Cue Cards



Use Bubble Help (cont.)

Turn On Bubble Help

1. Point to the word Help in the ABC Viewer menu bar.

2. Click the left mouse button. The Help menu opens. The Bubble Help command does not have a check mark beside it because 
it is turned off.

3. Click the Bubble Help command. Bubble Help is turned on.

What do you want to do next?

See Information about the Bubble Help Command

See Instructions on Using Cue Cards



Give a Chalk Talk 

You can show a chart on the entire screen and draw on it with three colors of "chalk.".
1. Click the Full Screen button. ABC Viewer shows the entire chart on the screen.

2. Press the left mouse button and drag to draw in red, press the right mouse button and drag to draw in green, or press both 
mouse buttons and drag to draw in yellow.

3. Press the Esc key to leave the full-screen view. The "chalk" is erased.

What do you want to do next?

See Information about the Full Screen Button

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards



Give a Chalk Talk 

You can show a chart on the entire screen and draw on it with three colors of "chalk.".
1. Click the Full Screen button. ABC Viewer shows the entire chart on the screen.

2. Press the left mouse button and drag to draw in red, press the right mouse button and drag to draw in green, or press both 
mouse buttons and drag to draw in yellow.

3. Press the Esc key to leave the full-screen view. The "chalk" is erased.

What do you want to do next?

See Information about the Full Screen Button

View or Enter Information (Use the Field Viewer)

See Instructions on Using Cue Cards

 



ABC Viewer Toolbar and Buttons

The ABC Viewer main window contains the following features. Click one to learn more.

ABC Viewer Toolbar

 Scroll Grid button

Related Topics
ABC Viewer commands
Getting started with ABC Viewer



ABC Viewer Toolbar

The buttons on the Toolbar give you easy access to the tasks you do most.

Click an icon below to read more information about the button.

Click the Open button to open a chart. Clicking this button is the same as choosing the Open 
command in the File menu.

Click the Save button to save the changes you have made to a chart. Clicking this button is the 
same as choosing the Save command in the File menu.

Click the Print button to print a chart. Clicking this button is the same as choosing the Print 
command in the File menu.

Click the Link Back button to go to the previous open chart. Clicking this button is the same as 
choosing the Link Back command in the Link submenu of the File menu.

Click the Link Ahead button to go to the chart linked to the currently selected shape. Clicking this 
button is the same as choosing the Link Ahead command in the Link submenu of the File menu.

Click the Show Link Summary button to see a list of the charts that you have opened and quickly 
open one of them. Clicking this button is the same as choosing the Show Link Summary command in the 
File menu.

Click the Note button to open and close the Note window. Clicking this button is the same as 
choosing the Show Note Viewer command in the View menu.

Click the Field Viewer button to open and close the Field Viewer dialog box. Clicking this button is 
the same as choosing the Show Viewer command in the Fields menu.

Click the Clear Fields button to remove all values from all fields for all shapes. Clicking this button 
is the same as choosing the Clear Fields command in the Fields menu.

Click the Zoom Out button to see more of your chart. Clicking this button is the same as choosing 
the Zoom Out command in the View menu.

Click the Zoom In button to enlarge the elements of your chart. Clicking this button is the same as 
choosing the Zoom In command in the View menu.

Click the Entire Chart button to fit all of the elements of your chart on the screen. Clicking this 
button is the same as choosing the Entire Chart command in the View menu.

Click the Full Screen button to show all of the elements of your chart on the screen without 
menus or buttons. Clicking this button is the same as choosing the Full Screen command in the View 
menu.

Click the Index button to open and close the Index window. Clicking this button is the same as 
choosing the Show Index command in the View menu.



Click the Cue Cards button to open Cue Cards that help you work with a specific task. Clicking 
this button is the same as choosing the Cue Cards command in the Help menu.

Related Topics
ABC Viewer commands
ABC Viewer Toolbar and buttons



Scroll Grid Button

The scroll grid, located below the down scroll arrow, works like the scroll arrows, with the added 
advantage that you can scroll diagonally across your chart. The squares in the grid represent directions 
for scrolling.

Related Topics
Procedure information
Using the scroll keys
ABC Viewer Toolbar



Open Button

Each chart is stored in a separate file on disk. Use the Open button or Open command in the File menu to 
open these file types.

· Charts (file names ending with an AF3 or AF2, extension; files that contain the shapes, lines, and text 
that comprise your charts)

· Workspaces (file names ending with the AFW extension; files that contain information about your 
current work environment, including the names of charts used in a project and their window 
arrangement)

Related Topics
         Dialog Box information  
         Procedure information  

      Open a chart file  
              Open command  
              ABC Viewer Toolbar  



Save Button

Use the Save button or the Save command in the File menu to store a changed chart in a file on disk. All 
charts (including linked charts) are saved in separate files.

Related Topics
         Procedure information  
         Save command  

      Save the Changes You Made to a Chart (Save a Chart File)  
              Save As command  
              ABC Viewer Toolbar  



Print Button

Use the Print button or the Print command in the File menu to print your charts and add them to 
presentations and reports.

ABC Viewer lets you print all the pages, a range of pages, or only selected objects in the chart. To print 
only selected objects, select the objects you want to print before you choose to print.

You also have an option to fit the chart to a single page. The entire chart is reduced proportionally, 
including the TrueType fonts. (Bitmap and printer fonts do not necessarily reduce properly.) When 
multiple-page charts are reduced to one page, the master items are printed only once and the All, 
Selection, and Pages print range options are still valid.

Note: Charts cannot be enlarged with the Fit to Page option.

Related Topics
         Dialog Box information  
         Procedure information  
         Print command  

      Print a chart  
              Printer Setup dialog box.  
              ABC Viewer Toolbar  



Link Back Button

The Link Back button and the Link Back command in the Link submenu of the File menu let you go to a 
previous chart listed in the Link Summary dialog box. You normally use the command to return to a chart 
that contains a shape that the current shape is linked to.

This button, along with the Link Ahead command, lets you navigate among linked charts. One chart can 
provide an overview of the main topics and contain links to subcharts that provide detailed information 
about the various topics.

You can use the Link Summary window to see the charts that you have viewed and quickly go to one.

You can use the Index window to view a summary of all charts in a directory, their shapes, and their text.

Related Topics
         Link Back command  

      See an attached chart (use links)  
              Indicators for Link and Notes  
              Link Ahead command  
              Link Ahead button  
              Link Summary dialog box  
              ABC Viewer Toolbar  



Show Link Summary Button

The Show Link Summary button and the Show Link Summary command in the File menu open the Link 
Summary dialog box, which lets you see the chart files that you have linked to and go to one, if you wish.

Related Topics
         Procedure information  
         Dialog Box information  
         Show Link Summary command  

      Return to a previous chart (use the link summary)  
              ABC Viewer Toolbar  



Clear Fields Button

The Clear Fields button and the Clear Fields command in the Fields menu remove all values from all 
fields for all shapes.

Related Topics
         Procedure information  
         Clear Fields command  

      Clear data field values  
              ABC Viewer Toolbar  



Zoom Out Button

Click the Zoom Out button or choose the Zoom Out command in the View menu to see more of your 
chart. Each chart element is made smaller in order to fit more of the chart on your screen.

Related Topics
         Procedure information  
         Zoom Out command  
         Zoom In button  
         Entire Chart button  

      Zoom in or out (change the view)  
              Full Screen button  
              ABC Viewer Toolbar  



Zoom In Button

Click the Zoom In button or choose the Zoom In command in the View menu to enlarge the elements of 
your chart. To concentrate on a particular element, click on it to select it before choosing Zoom In. That 
element is then centered on your screen.

Related Topics
         Procedure information  
         Zoom In command  
         Zoom Out button  
         Entire Chart button  

      Zoom in or out (change the view)  
              Full Screen button  
              ABC Viewer Toolbar  



Entire Chart Button

Click the Entire Chart button or choose the Entire Chart command in the View menu to fit all of the 
elements of your chart on the screen.

Related Topics
         Procedure information  
         Entire Chart command  
         Zoom In button  
         Zoom Out button  

      Zoom in or out (change the view)  
              Full Screen button  
              ABC Viewer Toolbar  



Full Screen Button

Click the Full Screen button or choose the Full Screen command in the View menu to show all of the 
elements of your chart on the screen without menus or buttons. Press Esc to return to the previous view.

Related Topics
         Procedure information  
         Full Screen command  

      Give a chalk talk  
              Entire Chart button  
              Zoom In button  
              Zoom Out button  
              ABC Viewer Toolbar  



Changing Your View of a Chart

To change your view of a chart:

1. Select the object you want centered in the window, if you wish.
2. Click the Zoom In button (or choose the Zoom In command in the View menu) to enlarge the 

objects.
or
Click the Zoom Out button (or choose the Zoom Out command in the View menu) to enlarge the 
area of the chart that is shown.
or
Click the Entire Chart button (or choose the Entire Chart command in the View menu) to show all 
of the chart.
or
Click the Full Screen button (or choose the Full Screen command in the View menu) to show all 
of the elements of your chart on the screen without menus or buttons.
ABC Viewer displays the chosen view.

To leave the Full Screen view, press the Esc key.

Related Topics
         Using Full Screen View  
         Entire Chart command  
         Entire Chart button  
         Zoom In command  
         Zoom In button  
         Zoom Out command  
         Zoom Out button  

      Zoom in or out (change the view)  
              Full Screen command  
              Full Screen button  
              Using full screen view  



Using Full Screen View

You can use the Full Screen view when you want to show the chart and do a "chalk talk" about it. While 
you are in full-screen mode, you can draw on the screen. Press the left mouse button and drag to draw in 
red. Press the right mouse button and drag to draw in green. Press both buttons and drag to draw in 
yellow.

When you finish, press the Esc key to return to the previous view.

To use full-screen mode:

1. Click the Full Screen button. ABC Viewer shows all of the elements of your chart on the screen 
without menus or buttons.

2. Press the left mouse button and drag to draw in red.
or
Press the right mouse button and drag to draw in green.
or
Press both mouse buttons and drag to draw in yellow.

3. Press the Esc key to leave the full-screen view.

The following keys are available in full-screen view.

· Esc, End, X Leave full-screen view
· Delete, Spacebar, E Erase chart annotations
· Tab, Page Down, N Go to the next chart window
· Shift+Tab, Page Up, P Go to the previous chart window

Related Topics
         Full Screen command  
         Full Screen button  

      Give a chalk talk  
              Changing your view of a chart  



Cue Cards Button

Click the Cue Card button to open Cue Cards that help you perform a specific task. The instructions stay 
on top of the Viewer window so you can refer to them. You can also get a list of the available Cue Cards 
in the Cue Cards menu.

Related Topics
Using Cue Cards
ABC Viewer Toolbar

 



Glossary



Active window

The window in which you are working. The active window appears in front of other windows and receives 
the next action. The color of the title bar in the active window distinguishes it from the other windows.



Clipboard

A temporary storage area for objects that are cut or copied from a Windows program.



Control menu

A menu common to all windows. You use the Control menu to move, resize, minimize, maximize, or close 
an ABC Viewer window. You also can use the Control menu to go to the next ABC Viewer window.



Control menu box

The box, located in the upper-left corner of the window, that you click to open the Control menu or double 
click to close the window.



Control Panel

A Windows accessory for installing printers and fonts, setting up printers and ports, and choosing 
program options.



Dialog box

A window that opens when the program needs information from you before it can carry out an action.



Icon

A small graphic symbol that represents a program or a file. For example, in ABC Viewer the chart 
windows can be minimized to appear as icons in the workspace.



Menu

A list of commands organized under a name in the menu bar near the top of the ABC Viewer window. To 
open a menu, you click the menu name or press Alt and the letter underlined in the menu name.



Menu bar

The bar, located under the title bar of the ABC Viewer window, that contains the names of menus in the 
program.



Page orientation

The position of the page on the screen. Portrait (vertical) orientation displays a page taller than it is wide. 
Landscape (horizontal) orientation displays a page wider than it is tall.



Select

To choose an object in the window by clicking it with the mouse. A border appears on the object to 
indicate it is selected. After an object is selected, you can work with it using commands and buttons.



Window

A rectangular area on the screen that displays the ABC Viewer program or a chart file. You can have 
several chart windows open at the same time. Each window has its own title bar.



Tab-delimited format

Text, usually meant to be in columns, that has a tab character (instead of multiple spaces) between the 
columns. This type of text is suitable for import into spreadsheets and databases.

 




