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What is Home Page Wizard?

Home Page Wizard is a Windows application program created by CompuServe to help CompuServe 
members create their very own pages on the World Wide Web.

With Home Page Wizard, you can

· Create a project, or related collection of Web pages, totalling up to 1 megabyte

· Link the pages together so that they can all be accessed from one starting point 

· Include a wide variety of components on each page:    blocks of text, headlines, graphic images, 
and divider bars

· Lay out each page to arrange components in any order you like

· Size graphic images and change their proportions

· Choose background colors or images for individual pages

· Create external links that visitors can use to access other pages on the World Wide Web

· Create e-mail links so that people who visit your Web pages can send you messages

· See what your pages look like and how they work before you put them on the Web

Once you're satisfied with your Web pages, you can publish them on the World Wide Web with Publishing 
Wizard, another CompuServe application program that automatically performs all the administrative tasks 
necessary to get your pages on the Web. 



Creating Your Web Pages

To create Web pages, follow the steps below:

1. Start up Home Page Wizard. 

If you do not yet have a project started, Home Page Wizard automatically takes you to the New 
Project window. 

If you have one or more projects already, Home Page Wizard takes you to the main Home Page 
Wizard window and displays the page most recently worked on.    To start a new project from 
within an existing project, choose New Project from the File pull-down menu.

2. Provide a title for your home page and a project name for the entire collection of linked pages in 
the New Project window.

3. Provide information about yourself in the Personal Information window.

4. Choose a template for your pages in the New Project Template window.

5. Create the individual Web pages that make up your project, starting with your home page.    If 
your project has more than one page, make sure to include the internal links that connect the 
pages to each other.

6. Test the project, and make any changes.

7. To save the project so that you can update it later on, choose Save Project from the File pull-
down menu.

8. To publish your pages on the World Wide Web, choose Publish Pages from the File pull-down 
menu.    This starts up Publishing Wizard.



Testing Your Web Pages

See your Web pages the way your visitors will!    Home Page Wizard has a test facility that lets you check 
out their look and feel before you actually publish them.    It's always a good idea to test before you "go 
live," just to make sure you haven't missed something essential.

Home Page Wizard can test your Web pages with any Web browser that you can access.    (It can be on 
your computer or on a network or mainframe that your computer is connected to.) If you have more than 
one Web browser, you can perform multiple tests, selecting    a different browser for each, and thus find 
out what your Web pages will look like to visitors using the different browsers.

To test your pages, follow the steps below:

1. If you have more than one Web browser, you can select the one you want to test with.    Choose 
Select Web Browser from the Options pull-down menu and then identify the browser in the Web 
Browser window.    The browser you select remains selected until you select a different one. 

The reason you should select a browser first is that Home Page Wizard will use the default 
browser (whatever is currently selected) if you don't. 

2. Click the Test button on the toolbar.    Home Page Wizard starts the test by displaying the Project 
Test Results window.

If you have never previously selected a Web browser, you must select one now.    Home Page 
Wizard takes you to the Web Browser window before the Project Test Results window. 

3. In the Project Test Results window, check the project size to make sure that it does not exceed 
one megabyte (1 million bytes).

4. Check the project files to make sure they are the ones you want to use.

5. When you're ready to go on with the test, click the Proceed button.    This displays your home 
page as it appears to anyone using the selected browser.

6. Review the appearance of your home page.

7. Test your links to be sure they work the way you expect them to.

8. View your other pages, testing the links in each one.

9. When you're finished, click the OK button.

10. To test your Web pages with another browser, repeat Steps 1-9.



Publishing Your Web Pages

Once you've finished creating and testing a project with one or more Web pages, you can publish the 
project on the Web by choosing Publish Pages from the File pull-down menu.    This command starts up 
Publishing Wizard, Home Page Wizard's companion program for publishing Web pages.

Another way to start up Publishing Wizard is to click the Publish button (shown below) on the toolbar at 
the top of your screen.

Once you've gone through Publishing Wizard's simple process, your pages will be on the Web in minutes.

You can update your Web pages, or publish a whole new project, any time you like.    To update pages, 
choose Open Project from the File pull-down menu and then select the project and edit it.    To publish a 
new project, choose New Project from the File menu and then create the project.    When you publish a 
new or updated project, Publishing Wizard automatically replaces the project that you currently have on 
the Web.



Creating an Individual Web Page

When you start a new project, Home Page Wizard takes you to its main window, where you create the 
home page for the project -- that is, the page your visitors see when they first arrive.    You can add a page 
to your project any time you like by choosing Add Page from the Page pull-down menu. 

You use the same procedure to create a page, whether it's the original home page or a page that you 
add:

1. Provide a page title.    If you are creating your original home page, you do this in the New Project 
window, before you open the main window.    If you are adding a page to your project, you do it by 
choosing Add Page from the Page pull-down menu and then entering the title in the New Page 
Title window.

If you are creating the home page, Home Page Wizard takes you directly to the main Home Page 
Wizard window, which shows the title of the home page.    If you are adding another page, Home 
Page Wizard takes you to the Save File window.

2. If you are adding a page to your project, you must identify the file where the new page is to be 
stored.    Then you proceed to the main Home Page Wizard window, which shows the title for the 
new page.

3. Add individual components to your page:    headlines, blocks of text, graphic images, horizontal 
lines, internal links, external links, and e-mail links.    Any one page can include any combination 
of the available components, and any number of text blocks, images, and so on.

4. Change the attributes or properties of this page, if you like.    (This step is optional.)    You can 
change page properties by choosing one of the following from the Page pull-down menu:    
Background, Text Color, or Link Color.

5. When you're satisfied with the page, save it to the project by choosing Save Project from the File 
pull-down menu.    It's always a good idea to save what you do every so often.

6. To create another page, repeat Steps 1 through 5.

Related Information

Add Page command

Headline command

Text command

Image command

Line command

Internal Link command

External Link command

E-Mail Link command

Background command

Text Color command

Link Color command



Save Project command

Save Project As command



Home Page Wizard window

The main Home Page Wizard window is where you create or edit a Web page.

Home Page Wizard takes you to this window whenever you start up the program, and displays the last 
page you worked on in your most recent Home Page Wizard session.    If you do not have any projects, 
you stop first at a series of windows where you provide information about your new project:    the New 
Project window, the Personal Information window, and the New Project Template window.

The Home Page Wizard window has all the tools you need to create and edit a Web page:

· The largest part of the window shows the page you are working on.    At first, the only thing on the 
page is its title.    Then, as you create each new component, it appears in the position you 
designate.    As your page outgrows the window, Home Page Wizard scrolls down to display new 
material.

· The pull-down menus along the top of the window include commands that enable you to perform 
every function of Home Page Wizard.

· The toolbar of iconic buttons just beneath the menus provides click-n-easy access to the most 
frequently used functions.    The toolbar is especially helpful when you are creating or editing 
page components such as headlines, text blocks, or graphic images.

· The bookmarks along the left side of your screen identify the pages in your project by page title.    
At first, there is only one bookmark; as you create more pages, Home Page Wizard lists them in 
the order of creation.    The title for the page you are currently working on is underlined.    You can 
switch to a different page by clicking on the bookmark.

· The status bar along the bottom of the window shows important information about the status of 
the project.    It may tell you when an operation is completed or what you can do at a certain point.

Related Information

Creating Your Web Pages

Creating an Individual Web Page

Add Page command

Headline command

Text command

Image command

Line command

Internal Link command

External Link command

E-Mail Link command

Background command



Text Color command

Link Color command



Creating and Editing Page Components with the Toolbar

Here are the various techniques you can use to creat and edit page components with icon buttons in the 
toolbar.

· To create a new component, just click the existing component that is immediately below where 
you want the new component to go, and then click the appropriate toolbar button.    Home Page 
Wizard opens the window where you provide all the information needed to create the component, 
and puts it on the page for you when you are finished.

· Note:    If the component you click is the same kind as the button, Home Page Wizard will edit the 
existing component instead of creating a new one.    If you dont click any component before 
clicking the button, the new component will be placed at the top of the page.

· Another way to create a page component is to drag and drop the iconic button to wherever you 
want the component to go.    When you release the button, Home Page Wizard opens the window 
for creating the component.    (You can only use drag-and-drop to create a component, not to edit 
an existing one.)

· To edit a component, click it and then click the appropriate toolbar button.    Home Page Wizard 
opens a window that shows the current information for that component.    Just make whatever 
changes you want and then click the OK button, and Home Page Wizard will replace the original 
component with the modified one.



New Project window

The New Project window is where you start creating a personal project.    A project can consist of one or 
more World Wide Web pages, with one page serving as the "home page" or initial access point for 
visitors, and other pages linked to that page and/or to each other. 

If you don't yet have any projects, the New Project window automatically appears when you start up 
Home Page Wizard.    If you already have one or more projects, you can reach this window by choosing 
New Project from the File pull-down menu.    You can also reach it by holding down the Control key while 
you press the N key.

There is no limit to the number of projects that you can create, but you can publish only one project (per 
account) at a time on the World Wide Web.    The project on the Web can have up to 1 megabyte of text 
and/or graphics, with any number of individual pages.

The information in the New Project window is required.

Title:    Whatever you type here will become the title of your home page.

Project:    Whatever you type here is what Home Page Wizard will use as a name for the collection of 
inter-connected pages associated with this project.    Every project name must be unique, and it can have 
any combination of up to eight letters, digits, underscore characters (_), and hyphens (-). 

Home Page Wizard creates a subdirectory with the name you specify, and places it in the directory for 
Home Page Wizard projects.    If you used the defaults when you installed Home Page Wizard, the 
directory of projects is C:\CSERVE\HPWIZ\PROJECT, and the project name you type in becomes a 
subdirectory of that directory.    As you create pages for your project, Home Page Wizard creates a file for 
each page and places the file into the individual project subdirectory.

There are three action buttons at the bottom of the window:

Back

This button is inactive.

Next

Click this button when you are satisfied with your title and project.    Home Page Wizard takes you to the 
Personal Information window.

Close

Click this button to cancel the new project.    Home Page Wizard closes the New Project window, discards 
whatever you may have typed in it, and takes you to the main Home Page Wizard window.



New Project Template window

The New Project Template window is where you select a template for your project, or tell Home Page 
Wizard that you want to start from scratch -- that is, build your project without using a template. 

You reach this window by clicking the Next button in the Personal Information window.

A template is only a starting point, designed to show you one popular pattern for Web pages.    Selecting a 
template does not mean that you must conform to it; you are free to change it in any way you like.    The 
main advantage of using a template is that it can serve as a sort of checklist for the kinds of things that 
are most frequently included in Web pages. 

There are two option buttons:

Blank Page:    Click this option button to create your project without using a template.

Template:    Click this option button to select one of the templates supplied by CompuServe.    The 
available templates are listed below.    You select the one you want by clicking once on it.    The adjacent 
box shows a miniature image of the currently selected template.    (If you click a different template, it takes 
a few moments to replace the image.)

There are three action buttons at the bottom of the window:

Back

Click this button to return to the Personal Information window if you want to change anything you typed 
there.

Finish

Click this button when you are satisfied with your selection.    Home Page Wizard takes you to the main 
Home Page Wizard window.    The window will show either a blank page or a page with the selected 
template.    To the top left of the page will be a bookmark with the home page title.

Close

Click this button to cancel the new project.    Home Page Wizard closes the New Project Template 
window, discards anything typed in the New Project window and the Personal Information window, and 
takes you to the main Home Page Wizard window.



Edit Headline window

The Edit Headline window is where you create or edit a headline for the page you are working on.    You 
can also use this window to select the size of the characters in the headline, and to center the headline 
on the page. 

You reach this window by clicking the toolbar button shown above or by dragging and dropping the button 
to where you want to put the link, or by choosing Headline from the HTML pull-down menu.    You can 
also reach it by double-clicking an existing headline.

The Edit Headline window has two tabs:

Text tab

This tab is where you create or edit the textual contents of the headline:

· If you are creating a new headline, the text box starts out empty.    All you have to do is type in the 
headline text.

· If you are editing an existing headline, that headline appears in the text box.    You can edit its 
contents in the normal Windows fashion, by positioning the mouse pointer where you want to 
make a change, typing text to be inserted, deleting, backspacing, and so on.

Styles tab

This tab is where you select a headline size and/or center the headline on the page:

· To select a headline size, click one of the option buttons..    The sizes range from Headline 1 
(largest) to Headline 6 (smallest).    You should be aware that the size of the headline as it 
appears to someone visiting your page depends on the browser used by the visitor.

· To center the headline on the page, check the box next to Center on Page.    (Clicking the box 
checks it if it is not already checked, or vice versa.)

There are two action buttons at the bottom of the window:

OK

Click this button to exit the Edit Headline window and insert the new or changed headline into the current 
page.

Cancel

Click this button to exit the Edit Headline window without making any changes to the current page.



Edit Text window

The Edit Text window is where you create or edit a block of text for a Web page.    You can also use it to 
center the text horizontally, set up paragraphs or columns, or place a bullet in front of each text 
paragraph.

You reach the Edit Text window by clicking the toolbar button shown above or dragging and dropping the 
button to where you want to put the link, or by choosing Text from the HTML pull-down menu.    You can 
also reach it by double-clicking an existing text block.

The Edit Text window has two tabs:

Text tab

This tab is where you create or edit the block of text:

· If you are creating a new text block, the text box starts out empty.    All you have to do is type in 
the text.

· If you are editing an existing text block, it appears in the text box.    You can edit its contents in the 
normal Windows fashion, by positioning the mouse pointer where you want to make a change, 
typing text to be inserted, deleting, backspacing, and so on.

Styles tab

This tab is where you determine the layout of the text in the block.

· To center each line horizontally (from right to left), click the box next to Center on Page. (Clicking 
the box checks it if it is not already checked, or vice versa.)

· To preserve paragraphs, blank lines, and tabs, click the box next to Pre-Formatted Text. (Clicking 
the box checks it if it is not already checked, or vice versa.)    If you do not apply this option, all the 
text in the block will be displayed as one single paragraph, and any tabs will be lost. 

· To place a bullet in front of each paragraph and indent the paragraph text, click the box next to 
Bulletted.    (Clicking the box checks it if it is not already checked, or vice versa.)

There are two action buttons at the bottom of the window:

OK

Click this button to exit the Edit Text window and insert the new or changed text block into the current 
page.

Cancel



Click this button to exit the Edit Text window without making any changes to the current page.



Edit Image window

The Edit Image window is where you select a graphic image to insert in the page you are currently 
working on, and identify the format of the image file.    You can also adjust the size and proportions of the 
image and/or center it on the page.

You reach this window by clicking the toolbar button shown above or dragging and dropping the button to 
where you want to put the link, or by choosing Image from the HTML pull-down menu.

Note:    Some image options are available only if extended HTML features are enabled.    Such options are 
dimmed when Allow Extended HTML Features is not checked in the Options pull-down menu.

The Edit Image window has three separate tabs:

Image tab

Use this tab to identify the image you want to put on the page.    You can select one of the images 
provided by CompuServe from the list at the far left, or identify a different image by clicking the Browse 
button to select the image file from a standard file identification window. 

If you select an image that is not in the list, Home Page Wizard will add the image to the list to make it 
available for future selection.    Home Page Wizard will also copy the image to its image library, which is 
stored in the directory specified for the Home Page Wizard.    (If you accepted the defaults during program 
installation, Home Page Wizard files are stored in C:\CSERVE\HPWIZ.)

The box at the right shows the currently selected image.

To provide something for visitors to read if they can not see the image, type whatever you want them to 
see into the box next to Alternate Text.    Some Web browsers do not display images, and others display 
only certain types of images (which may or may not include the type you are using).

Size tab

Use this tab to change the size or aspect ratio (height relative to width) of the image.    Initially, all these 
attributes are determined by the image file.

· To change the height, type the desired height in inches.    This automatically changes the width to 
preserve the current aspect ratio.

· To change the width, type the desired width in inches.    This automatically changes the height to 
preserve the current aspect ratio.

· To change the aspect ratio, click the box next to Maintain aspect ratio, and then type in the 
desired height.    The height is the numerator of the aspect ratio. 



· To cancel any changes that you have made to the size attributes, and return them to their initial 
default settings, click the Reset button.

Styles tab

Use this tab to center the image horizontally (from left to right) on your page.    Home Page Wizard 
centers the image if the box next to Center on Page is checked; if the box is not checked, Home Page 
Wizard aligns the image with the left side of the page. (Clicking the box checks it if it is not already 
checked, or vice versa.)

There are two action buttons at the bottom of the Edit Image window:

OK

Click this button to exit the Edit Image window and insert the new or changed image into the current 
page.

Cancel

Click this button to exit the Edit Image window without making any changes to the current page.



Horizontal Line window

The Horizontal Line window is where you create or modify a horizontal line to provide a visual break in the 
page. You can create as many such lines as you like.

You reach the Horizontal Line window by clicking the toolbar button shown above or dragging and 
dropping the button to where you want to put the link, or by choosing Line from the pull-down HTML 
menu.

To create a new line, position the pointer where you want the line to be.    To modify an existing line, select 
the line you want to modify.

Dimensions -- Use this box to specify the dimensions of the horizontal line:

· Length -- Type in the length of the line as a percentage of the total width of the page.    Initially, 
Length is set to 100%, meaning that the line extends across the whole page.    You can change 
the percentage to any number up to 100.

· Height -- Type in the height of the horizontal line in pixels.

Alignment -- Click the button next to the desired alignment to reposition the line relative to the sides of 
the page.    Initially, the alignment is set to Left.

Note:    If the length of the line is set to 100% of the total page width, all Alignment settings are effectively 
the same.    Also, Alignment options are only available if Allow Extended HTML Features is checked on 
the Options pull-down menu.

There are two action buttons at the bottom of the Horizontal Line window:

OK

Click this button to exit the Horizontal Line window and insert the new or changed horizontal line into the 
current page.

Cancel

Click this button to exit the Horizontal Line window without making any changes to the current page.



Edit External Link window

The Edit External Link window is where you create or modify an external link for the current page.    An 
external link provides both a description and a method of accessing any Web page that is outside your 
project, such as the CompuServe Home Page.

You reach this window by clicking the toolbar button shown above or dragging and dropping the button to 
where you want to put the link, or by choosing External Link from the HTML pull-down menu.

To create a new link, position the mouse pointer where you want the link to appear.    To modify an existing 
link, select the link.

The Edit External Link window has two tabs:

External Link tab

This tab is where you supply the information required for every external link.    If you are creating a new 
link, both the Text box and the URL box start out empty.    If you are editing an existing link, they show the 
link's current information.

· The box next to Text is where you supply what your visitors actually see.    Remember, the link is 
where your visitors must click to go to the Web page, so you should not only give them a good 
idea what to expect, but also tell them they need to click to go there.    You can type as much as 
you like; if you type in more than the text box will hold, it simply scrolls to the right.

· The box next to URL is where you supply the Uniform Resource Locator (URL) for the outside 
Web page -- its address on the World Wide Web, which Home Page Wizard needs to transmit to 
the visitor's browser so that it can access the Web page.    For example, 
http://www.compuserve.com is the URL for CompuServe's home page on the Web.

Styles tab

Use this tab to center and/or bullet the external link text:

· To place the description of the external Web page in the center of your page, check the Center on 
Page box.

· To place a bullet in front of the description, check the Bulletted box. 

If you have multiple links, it is usually best to be consistent with position and bullets.

There are two action buttons at the bottom of the window:



OK

Click this button to exit the Edit External Link window and insert the new or changed external link into the 
current page.

Cancel

Click this button to exit the Edit External Link window without making any changes to the current page.



Edit Internal Link window

The Edit Internal Link window is where you create or modify an internal link for the current page.    An 
internal link provides both a description and a method of access for any other page in this same project.

You reach this window by clicking the toolbar button shown above or dragging and dropping the button to 
where you want to put the link, or by choosing Internal Link from the HTML pull-down menu.

To create a new link, position the mouse pointer wherever you want to place the link.    To modify an 
existing link, select the link.

The Edit Internal Link window has two tabs:

Internal Link tab

Use this tab to supply the information required for every internal link.    If you are creating a new link, both 
the Text for the homepage box and the Page to link to box start out empty.    If you are editing an existing 
link, they show the link's current information.

· The box next to Text for the homepage is where you supply what your visitors actually see.    
Remember, the link is where visitors must click to go to the other page, so the text of the link 
should not only give visitors a good idea of what to expect, but also tell them they need to click to 
go there.    You can type as much as you like; if you type in more than the text box will hold, it 
simply scrolls to the right.

· The box next to Page to link to is where you supply the title of the page that the visitor sees after 
clicking the internal link.    To select an existing page, click one of the bookmarks at the left of your 
screen.    To identify a page that does not yet exist, click the Add New Page button in the large 
box at the right of the tab.    That takes you to the New Page Title window.

Styles tab

Use this tab to center and/or bullet the internal link text:

· To place the description of the internal Web page in the center of your page, check the Center on 
Page box.

· To place a bullet in front of the description, check the Bulletted box. 

There are two action buttons at the bottom of the Edit Internal Link window:

OK

Click this button to exit the Edit Internal Link window and insert the new or changed internal link into the 
current page.



Cancel

Click this button to exit the Edit Internal Link window without making any changes to the current page.



Edit E-Mail Link window

The Edit E-Mail Link window is where you create or modify an e-mail link for the current page.    Any visitor 
who clicks on the e-mail link will be able to compose and send you an e-mail message.

You can reach this window by clicking the toolbar button shown above or dragging and dropping the 
button to where you want to put the link, or by choosing E-Mail Link from the HTML pull-down menu. 

To create a new e-mail link, position the mouse pointer wherever you want to place the link.    To modify 
an existing link, select the link.

The Edit E-Mail Link window has two tabs:

E-mail tab

Use this tab to supply the information needed to create an e-mail link.    If you are creating a new link, 
both the Text box and the E-mail Address box start out empty.    If you are editing an existing link, they 
show the link's current information.

· The box next to Text is where you supply what your visitors actually see.    Remember, it is also 
where a visitor must click to send you an e-mail message, so the text of the e-mail link should 
mention that fact.    You can type as much as you like; if you type in more than the text box will 
hold, it simply scrolls to the right.

· The box next to E-mail Address is where you supply your e-mail address on the Internet.    The 
Internet address for any CompuServe member is the User ID number followed by 
@compuserve.com.

Example: 75140,1070@compuserve.com

Styles tab

Use this tab to center and/or bullet the internal link text:

· To place the text for the e-mail link in the center of your page, check the Center on Page box.

· To place a bullet in front of the text, check the Bulletted box. 

There are two action buttons at the bottom of the Edit E-Mail Link window:

OK

Click this button to exit the Edit E-Mail Link window and insert the new or changed e-mail link into the 
current page.



Cancel

Click this button to exit the Edit E-Mail Link window without making any changes to the current page.



Web Browser window

The Web Browser window enables you to select a Web browser.    The selected browser will be used 
when you test your project to see what it will look like on the World Wide Web.

You can reach this window by choosing Select Web Browser from the Options pull-down menu.    If you 
choose Test Pages from the File pull-down menu without having selected a browser, Home Page Wizard 
will take you to the Web Browser window automatically.    You must have a Web browser selected before 
you can test your project.

You can select a Web browser in either of two ways:

· Type in the complete file identification 

· Click the Browse button and then select the browser from the resulting Open window.    When you 
OK the selection, you return to the Web Browser window.

There are two    action buttons at the bottom of the window:

OK

Click this button to exit the Web Browser window and confirm your selection.

Cancel

Click this button to exit the Web Browser window without selecting a Web browser.



Tip of the Day window

The Tip of the Day window automatically displays helpful hints when you start Home Page Wizard.    You 
can reach the Tip of the Day window from anywhere in Home Page Wizard by choosing Tip of the Day 
from the Help pull-down menu.

Note: If you do not want to see the Tip of the Day window whenever you start up Home Page Wizard, 
click the box next to Show tips on startup.    Clicking the box removes the checkmark if it is present, or 
vice versa.

There are three action buttons along the right side of the Tip of the Day window:

Previous

Click this button to display the previous Tip of the Day.

Next

Click this button to display the next Tip of the Day.

Close

Click this button to close the Tip of the Day window. 



Personal Information window

The Personal Information window is where you supply personal information for a Home Page Wizard 
project:    your name, city of residence, occupation, hobbies, and e-mail address.    You can also use this 
window to specify whether or not you want your personal information to appear on your home page.

You proceed to this window when you first start a new project, as soon as you click the Next button in the 
New Project Window.    If Home Page Wizard already has one or more projects, the Personal Information 
window will contain information from the last time a new project was started. 

To provide each item of information, just click on the associated text box and type.    Here's some things 
you might want to know about the various information items:

· First Name -- A first name is required.

· MI -- A middle initial is optional.

· Last Name -- A last name is required.

· City -- A city name is required.

· State/Province -- A state is optional for residents of the U.S., and a province is optional for 
residents of Canada.    If you reside in any other country, you have the option of typing in any 
administrative subdivision.

· Country -- A country is required.

· Occupation -- An occupation is optional.    If you plan to have Home Page Wizard use your 
personal information in your home page (see below), you should specify your occupation in the 
form of a noun or noun phrase.    Otherwise, the grammar of the home page entry will be wrong.

· Hobbies -- One or more hobbies or leisure interests are optional.    If you plan to have Home Page 
Wizard use your personal information in your home page (see below), you should specify multiple 
hobbies with appropriate punctuation and place the word "and" between them (for example, 
"boating and horseback riding" or "bridge, stamp collecting, and mountain-climbing").    Otherwise, 
the grammar of the home page entry will be wrong.

· E-Mail Address -- An e-mail address is optional.    If you include one, it should be your 
CompuServe User ID number followed by @compuserve.com (for example, 
76003,511@compuserve.com).

If you want to have the information that you supply in this window appear on your home page, check the 
box next to Use Personal Information in Home Page.    If you do, Home Page Wizard will display a 
paragraph in the following format:

Hello! My name is first-name middle-initial last-name. I live in city, state/province, country.

I am a occupation and enjoy hobbies.



There are three action buttons at the bottom of the Personal Information window:

Back

Click this button to return to the New Project window.

Next

Click this button to proceed to the New Project Template window.

Close

Click this button to exit the Personal Information window and discard any information that you have typed 
here or in the New Project window.    Home Page Wizard will take you to the main Home Page Wizard 
window, which will be open to the last page that you worked on (or blank, if you have not yet worked on 
any pages).



Save Project As window

The Save Project As window enables you to save a project under a different project name.    This option is 
especially useful when you make changes and want to keep both the original version and the new 
version.

You reach this window by choosing Save Project As from the File pull-down menu.

Type the name that you want to use for the project in the box next to Name.    If you type a project name 
that is already in use, Home Page Wizard will replace the existing project with the one that you are 
working on.    (You will be asked for confirmation before the replacement actually occurs.)

Typing in just the project name saves the project to the \CSERVE\HPWIZ\PROJECT directory.    You can 
save the project to a different directory by including the complete file specifications.

There are two action buttons at the bottom of the Save Project As window:

OK

Click this button to exit the Save Project As window and save your project in the specified file.

Cancel

Click this button to exit the Save Project As window without saving your project.



New Page Title window

The New Page Title window is where you provide a title for a new page that you are about to create.    You 
can also use this window to change the title of an existing page.

You can reach the New Page Title window by choosing Add Page or Change Title from the Page pull-
down menu.

Type the title of the page in the box next to Title.

There are two action buttons at the bottom of the New Page Title window:

OK

Click this button to exit the New Page Title window and save the title of the new page.    If you are creating 
a new page, the title will appear at its top when you return to the main Home Page Wizard window.    The 
new title willl also appear in the bookmark for this page (along the left side of the window).    If you are 
changing the title of an existing page, the changed title will not appear until your next Home Page Wizard 
session.

Cancel

Click this button to exit the New Page Title window without saving the title of the new page.



Select Fonts window

The Select Fonts window enables you to change the fonts or typefaces used in Home Page Wizard. 

Note:    Any font you select affects only the way your pages look in Home Page Wizard.    The appearance 
of the pages you publish is determined by the Web browsers used by your viewers.

You can reach this window by choosing Fonts from the Options pull-down menu.

To change either the proportional fontor the fixed font, click the appropriate Select button.    This takes you 
to the Font window, where you can select a font, a style (such as bold or italic), and a size.    When you 
finish with the Font window, you return to the Select Fonts window.

Note:    The selected proportional font is used for all text componentuals of every page in your project, 
except for text blocks that you identify as pre-formatted (in the Styles tab of the Edit Text window).    Pre-
formatted text always requires a fixed font.

There are two action buttons at the bottom of the Select Fonts window:

OK

Click this button to save the fonts that are currently selected.

Cancel

Click this button to exit the Select Fonts window without changing the original font selections.



Font window

The Font window enables you to select the font, font style, and point size that Home Page Wizard uses to 
display the text (including links) of your pages.

Note:    Your font selections affect only the way your pages look in Home Page Wizard.    The appearance 
of the pages you publish is determined by the Web browsers used by your visitors.

You can reach this window by clicking one of the Select buttons found in the Select Fonts window.

To select a new font, style, or size, use the vertical scroll bars to scan the selections. Then click on the 
font, style, or point size you want.    You can select any combination of font, style, and size.

The Sample box illustrates the appearance of a group of characters with the current font selections.    It 
changes every time you change one of the font attributes.

There are two buttons at the bottom of the Font window:

OK

Click this button to return to the Select Fonts window, which will display the font you selected in the Font 
window.

Cancel

Click this button to return to the Select Fonts window without making any changes to the font selections.



Color window

The Color window enables you to select a specific color, or define a custom color, for any property of the 
page you are currently working on: background, text, or links.

You can reach this window by clicking the Select button for color in any tab of the Page Properties 
window.

To select one of the colors shown, click the color and then click the OK button.

To define a custom color, click the Define Custom Color button.    This takes you to the standard window 
for custom color definition in Microsoft Windows.    When you are finished defining a color, you return to 
the Color window, which shows the color you have defined. 

There are two action buttons at the bottom of the Color window:

OK

Click this button to apply the color that you have selected to the page background, text, or links.

Cancel

Click this button to exit this window without changing the color of any page property.



Page Properties window

The Page Properties window enables you to select a background for the Web page you are creating, and 
to select colors for your text and your links (internal links, external links, and e-mail links).

You can reach this window by choosing Background, Link Color, or Text Color from the Page pull-down 
menu, or by choosing Page Properties from the Options pull-down menu.

To change your background, link color, or text color, click the appropriate tab and then select the option 
button you want.

The Page Properties window has three tabs:

Background tab

Use this tab to alter the background of your home page:

· To use the original default background, click the Default option button.

· To select a different background color for the page (the current color appears in the box next to 
the Color option button), click the Color option button and then click the Select button.    This 
takes you to the Color window.

· To select a graphic image as the page background, click the Image option button and then select 
a picture from the adjacent box.

Links tab

Use this tab to select the color for link text in the current page:

· To use the original default link color, click the Default option button.

· To select a different background color for the page (the current color appears in the box next to 
the Color option button), click the Color option button and then click the Select button.    This 
takes you to the Color window.

You can also use the Links tab to select a color for links that have been visited.    If someone visits a 
linked page, the link text will be changed to the selected color and remain that color throughout the 
remainder of that person's visit.    Specifying a different color for visited links can help your visitors avoid 
wasting time by visiting the same page twice.    The process is the same as that for changing the color of 
other (unvisited) links. 

Note:    Color changes made here apply only to the current page, so if you have other pages with links to 
the same page, the color of those links will not be affected. 

Text tab

Use this tab to change the color of the text on the current page:



· To use the original default text color, click the Default option button.

· To select a different text color for the page (the current color appears in the box next to the Color 
option button), click the Color option button and then click the Select button.    This takes you to 
the Color window.

There are two option buttons at the bottom of the Page Properties window:

OK

Click this button to exit the window and have Home Page Wizard apply any changes that you have made 
to the page properties.

Cancel

Click this button to exit the window without making any changes to the page properties.



Save File window

The Save File window is where you supply a name for the file that contains the Web page you are 
creating.    Every page is stored in a separate file, which must have a unique file name.    All the page files 
for any    are stored in the subdirectory for that project.

You reach this window by clicking the OK button in the New Page Title window.

By default, Home Page Wizard uses the first eight valid characters (letters, digits, underscores, and 
hyphens) of the page title as the page file name.    To use a different name, type it into the box next to 
Filename.

There are two action buttons at the bottom of the Save File window:

OK

Click this button to exit the Save File window and proceed with page composition.    Home Page Wizard 
creates the specified page file, and takes you to the main Home Page Wizard window.    The window 
shows the title at the top of a blank page, and also on a new bookmark along the left side.

Note:    If the filename you specify is already in use, Home Page Wizard will ask you whether you wish to 
overwrite the current page or specify a different file name.

Cancel

Click this button to exit the Save File window and cancel new page composition.    Home Page Wizard 
returns you to the page you were working on.



Open Project window

The Open Project window enables you to open an existing project.

You can reach this window by choosing Open Project from the File pull-down menu.

To select the project you want to open, click on its name.

There are two action buttons at the bottom of the Open Project window:

OK

Click this button to open the selected project selected.

Cancel

Click this button to exit the Open Project window without opening a project.



Project Test Results window

The Project Test Results window is where you can preview your Web pages to see what they will look like 
on the Web.    This window displays the pathnames of the files in your current project and the size of the 
project.

You reach this window by clicking the toolbar button shown above or by choosing Test Project from the 
File pull-down menu.    If you haven't previously selected a Web browser, you'll stop at the Web Browser 
window to select one before moving on to the Project Test Results window.

To preview your Web page, click the Proceed button.    The browser you selected will launch and your 
home page will appear.

There are two action buttons at the bottom of the Project Test Results window:

Proceed

Click this button to launch your selected browser and preview the current Web page project.

Cancel

Click this button to exit this window without previewing the current Web page project.



About Home Page Wizard window

The About Home Page Wizard window is where you can find out what version of Home Page Wizard you 
are using and when it was released.

You reach this window by choosing About Home Page Wizard from the Help pull-down menu.    The 
window appears on top of whatever window you are in when you make the choice.

The About Home Page Wizard menu has only one action button:

OK

Click this button to close the window. 



Home Page Wizard Menus

Home Page Wizard has seven pull-down menus:

File menu 

Edit menu 

Page menu

HTML menu

View menu 

Options menu 

Help menu



File menu

The File menu has seven commands:

New Project

Open Project

Save Project

Save Project As

Test Pages

Publish Pages

Exit



New Project command (File menu)

This command starts a new project.    It takes you to the HPW New Project window, where you supply a 
title for the main home page and a name for the project.

Another way to start a new project is to hold down the Control key while you press the N key.

You can create as many projects as you like, but you can only have one (per account) at a time on the 
World Wide Web.    Any project can have an unlimited number of pages.    While there are no limits on the 
overall size of a project while you're creating it, a project on the Web can not exceed one megabyte (1 
million bytes).



Open Project command (File menu)

This command opens an existing project.    It takes you to the main Home Page Wizard window.

Another way to open an existing project is to hold down the Control key while you press the O key.



Save Project command (File menu)

This command saves the project you are currently working on.

Another way to save the current project is to hold down the Control key while you press the S key.

Related Topics

Save Project As command



Save Project As command (File menu)

This command saves the project you are working on under a new project name.    It takes you to the Save 
Project As window, where you supply the new name for the project.

Saving a project with a new name in this way does not affect the current contents of any other 
existing project, so you can use the Save Project As command to "clone" a project in order to 
create a new version while preserving the old.    Saving a project under a new name does not close 
the project or otherwise affect Home Page Wizard operation.

Related Topics

Save Project command



Test Pages command (File menu)

This command gives you a visitor's-eye view of the Web pages in the project you are working on.    In 
other words, it enables you to find out what the Web pages would look like and how well their links would 
work if the pages were on the World Wide Web and someone visited your home page.

Another way to test your pages is to click the Test button (shown below) in the toolbar at the top of your 
screen.

If you have not yet selected a Web browser, the Test Pages command takes you to the Web Browser 
window.    If you have already selected a Web browser, the Test Pages command takes you to the Project 
Test Results window, where you can see how many bytes your project takes up and which files it uses.    
From this window, you can test your project by clicking the Proceed button.

Related Topics

Publish Pages command



Publish Pages command (File menu)

This command starts up Publishing Wizard, the program that publishes your Web pages on the World 
Wide Web.

Another way to start up Publishing Wizard is to click the Publish button (shown below) in the toolbar at the 
top of your screen.

Before you publish your pages, you should test them to see how they will actually look on the Web, and 
make sure that all your links work as expected.    You can test your pages with the Test Pages command.



Exit command (File menu)

This command exits Home Page Wizard and returns you to wherever you were when you started the 
program.    If there are unsaved changes to any of your projects, Home Page Wizard will prompt you to 
save them before actually shutting down.



Edit menu

The Edit menu has five commands:

Undo

Cut

Copy

Paste

Delete



Undo command (Edit menu)

This command undoes (reverses) the most recent editing operation.    For example, if you mistakenly 
delete a headline or a block of text, you can put it back with the Undo command.

Another way to undo an editing operation is to hold down the Control key while you press the Z key.



Cut command (Edit menu)

This command removes the selected component from the page to the Clipboard, so that you can put it 
elsewhere, either on the current page or on a different page.    (To put the component in its new location, 
use the Paste command.)

You can cut only one component at a time.    A component that you cut replaces whatever is in the 
Clipboard and stays there until you replace it with something else. 

Another way to cut a component is to hold down the Control key while you press the X key.

Related Topics

Copy command

Delete command



Copy command (Edit menu)

This command copies the selected component from the page to the Clipboard, so that you can put it 
elsewhere, either on the current page or on a different page.    (To put the component in its new location, 
use the Paste command.)

You can copy only one component at a time.    A component that you copy replaces whatever is in the 
Clipboard and stays there until you replace it with something else.

Another way to copy a component is to hold down the Control key while you press the C key.

Related Topics

Cut command



Paste command (Edit menu)

This command copies the contents of the Clipboard to the current page, immediately above the selected 
component.    If no component is selected, the Clipboard contents are placed at the top of the page, 
above any existing components.

The Paste command does not affect the contents of the Clipboard.    They remain there until you replace 
them by cutting or copying a page component. 

Another way to paste is to hold down the Control key while you press the V key.



Delete command (Edit menu)

This command deletes the selected component.

If you delete a component by mistake, you can replace it immediately with the Undo command. 

Another way to delete a page component is to select it and then press the Delete key.

Related Topics

Cut command



Page menu

The Page menu has six commands:

Add Page

Delete Page

Background

Link Color

Text Color

Change Title



Add Page command (Page menu)

This command enables you to add a new page to the project you are working on.

Another way to add a page to the current project is to hold down the Control key while you press the A 
key.

The Add Page command takes you to the New Page Title window, where you supply the title for the new 
page.



Delete Page command (Page menu)

This command enables you to delete an existing page from the project you are working on.    Before the 
page is actually deleted, you will be prompted to confirm your intention.

Another way to delete a page from the current project is to hold down the Control key while you press the 
D key.



Background command (Page menu)

This command enables you to change the background color of the current page or select an image to use 
as page wallpaper. 

The Background command takes you to the Page Properties window, with the Background tab on top.    
You can switch to a different tab by clicking on it.



Link Color command (Page menu)

This command enables you to change the color of the links on the current page. 

The Link Color command takes you to the Page Properties window, with the Links tab on top.    You can 
switch to a different tab by clicking on it.



Text Color command (Page menu)

This command enables you to change the color of the text on the current page.    The text color applies to 
both normal running text and headline text.

The Text Color command takes you to the Page Properties window, with the Text tab on top.    You can 
switch to a different tab by clicking on it.



Change Title command (Page menu)

This command enables you to change the title of the page you are working on.

The Change Title command takes you to the New Page Title window, where you can enter the new title 
for the page.

You should be aware that page title changes are recorded right away, but not executed until you exit 
Home Page Wizard.    So you won't actually see the new title on the page or the related bookmark until 
the next time you start up Home Page Wizard and open this project.



HTML menu

The HTML menu has seven commands:

Headline

Text

Image

Line

Internal Link

External Link

E-mail Link



Headline command (HTML menu)

This command enables you to create a new headline in the page you are working on, or to modify an 
existing headline.    The Headline command takes you to the Edit Headline window. 

Another way to create or edit a headline is to click the Headline button (shown below) on the toolbar 
along the top of your screen.

When you create a new headline, it can go in one of two places on the page:

· If some component of the page (other than an existing headline) is selected, the new headline will 
be placed immediately above the existing component.

· If no component is selected, the new headline will be placed at the top of the page.



Text command (HTML menu)

This command enables you to create a block of text for the page you are working on, or to modify an 
existing text block.    The command takes you to the Edit Text window.

Another way to create or edit a text block is to click the Text button (shown below) in the toolbar at the top 
of your screen.

When you create a new text block, it can go in one of two places on the page:

· If some component of the page (other than an existing text block) is selected, the new text block 
will be placed immediately above the existing component.

· If no component is selected, the new text block will be placed at the top of the page.



Image command (HTML menu)

This command enables you to place a graphic image in the page you are working on, or to modify an 
existing image.    It takes you to the Edit Image window. 

Another way to place or modify an image in the current page is to click the Image button on the toolbar at 
the top of your screen.

When you supply a new image, it can go in one of two places on the page:

· If some component of the page (other than an existing image) is selected, the new image will be 
placed immediately above the existing component.

· If no component is selected, the new image will be placed at the top of the page.



Line command (HTML menu)

This command enables you to create a horizontal line in the page you are working on, or to modify an 
existing line.    The command takes you to the Edit Horizontal Line window. 

Another way to create or modify a horizontal line is to click the Lines button (shown below) in the toolbar 
at the top of your screen.

When you supply a new line, it can go in one of two places on the page:

· If some component of the page (other than an existing line) is selected, the new line will be 
placed immediately above the existing component.

· If no component is selected, the new line will be placed at the top of the page.



Internal Link command (HTML menu)

This command enables you to create a link from the page you are working on to another page within your 
current project, or to modify an existing internal link.    The command takes you to the Edit Internal Link 
window. 

Another way to create or modify an internal link is to click the Internal Link button in the toolbar at the top 
of your screen.

When you create a new internal link, it can go in one of two places on the page:

· If some component of the page (other than an existing internal link) is selected, the new link will 
be placed immediately above the existing component.

· If no component is selected, the new link will be placed at the top of the page.



External Link command (HTML menu)

This command enables you to create a link from the page you are working on to a page elsewhere on the 
World Wide Web, or to modify an existing external link.    The command takes you to the Edit External 
Link window. 

Another way to create or modify an external link is to click the External Link button (shown below) in the 
toolbar at the top of your screen.

When you create a new external link, it can go in one of two places on the page:

· If some component of the page (other than an existing external link) is selected, the new link will 
be placed immediately above the existing component.

· If no component is selected, the new link will be placed at the top of the page.



E-Mail Link command (HTML menu)

This command enables you to set up a link that your visitors can click on to send you an e-mail message, 
or to edit an e-mail link you have already set up.    The command takes you to the Edit E-mail Link 
window. 

Another way to create or modify an e-mail link is to click the E-mail Link button (shown below) in the 
toolbar at the top of your screen.

When you create a new e-mail link, it can go in one of two places on the page:

· If some component of the page (other than an existing e-mail link) is selected, the new link will be 
placed immediately above the existing component.

· If no component is selected, the new link will be placed at the top of the page.



View menu

The View menu has two commands:

Toolbar

Status Bar



Toolbar command (View menu)

This command hides the Home Page Wizard toolbar if it is visible or makes the toolbar visible if it is 
hidden.    If there is a checkmark next to the command, the toolbar is visible; if there is no checkmark, the 
toolbar is hidden.



Status Bar command (View menu)

This command hides the Home Page Wizard status bar if it is visible, or makes the status bar visible if it is 
hidden.    If there is a checkmark next to the command, the status bar is visible; if there is no checkmark, 
the status bar is hidden.



Options menu

The Options menu has three commands:

Fonts

Select Web Browser

Allow Extended HTML Features



Fonts command (Options menu)

This command enables you to select different fonts for your project.    You can select a different 
proportional font and/or a different fixed font.    The command takes you to the Select Fonts window.

Font settings are "for your eyes only."    In other words, they have no effect on how your project looks to a 
visitor.    That is determined solely by the visitor's browser software.



Select Web Browser command (Options menu)

This command enables you to select the Web browser that Home Page Wizard will emulate when you 
test your project.    The command takes you to the Web Browser window.

Related Topics

Test Pages command



Allow Extended HTML Features command (Options menu)

This command tells Home Page Wizard whether or not your project supports extended HTML features, 
such as the use of color for the page background.      If there is a checkmark next to the command, your 
project supports extended HTML features; if there is no checkmark, your project does not support 
extended HTML features.

Related Topics

Page Properties window



Page command (Options menu)

This command enables you to supply your full name and city of residence.    The command takes you to 
the Personal Information window.



Help menu

The Help menu has four commands:

Index

Using Help

Tip of the Day

About Home Page Wizard



Index command (Help menu)

This command enables you to find help about a particular command, window, term, or any other aspect of 
Home Page Wizard by looking it up in an index.



Using Help command (Help menu)
This command enables you to learn how to use the help system for Home Page Wizard.



Tip of the Day command (Help menu)
This command enables you to review tips for using Home Page Wizard.    The command takes you to the 
Tip of the Day window, which shows the current tip and offers the options of accessing the previous tip or 
the next one.



About Home Page Wizard command (Help menu)
This command enables you to determine which version of Home Page Wizard you are using and when it 
was released.    The command opens the About Home Page Wizard window.





Glossary

aspect ratio
bookmark
Clipboard
CompuServe home page
CompuServe Mosaic
drag and drop
e-mail link
extended HTML features
file format
fixed font
graphic image
Graphics Interchange Format (GIF)
headline
home page
horizontal line
Hypertext Markup Language (HTML)
Hypertext Transfer Protocol (HTTP)
Image Library
internal link
link
Mosaic
page background
page components
page properties
page title
pixels
project
project name
project template
proportional font
publish
Publishing Wizard
status bar
test
text
text block
toolbar
Uniform Resource Locator (URL)
wallpaper
Web browser
Web page
World Wide Web



aspect ratio

The ratio of the dimensions of a graphic image (height to width).    For example, if the aspect ratio is 3 to 
1, and the height of the image is 12 inches, then the width of the image is 4 inches.



bookmark

The small tab on the left of your page template that shows the name of the page.    If you have more than 
one page in your project, the name of the one you currently are working on is underlined.



Clipboard

In Windows, the standard storage place associated with various editing functions, such as Cut, Copy, 
and Paste.    These are found in the Edit pull-down menu.



CompuServe home page

CompuServes page on the World Wide Web.    Its a great place to start your voyage on the Web.    It also 
can provide some ideas for constructing your own Web page.    The Uniform Resource Locator (URL) for 
the CompuServe home page is http://www.compuserve.com



CompuServe Mosaic

A World Wide Web browser produced by CompuServe and provided as part of Release 2.0 of the 
CompuServe Information Manager, Windows version.



drag and drop

The method of moving text and graphics around your home page while constructing it.    You do this by 
clicking on the page component you want to shift and dragging it while keeping the mouse button 
depressed.    When you have it positioned correctly, drop it by releasing the mouse button.    Home Page 
Wizard will put the component where you want it.

You can also drag and drop a button from the toolbar to the desired position on the page.    When you 
release the mouse button, Home Page Wizard opens the window for editing the appropriate component.



e-mail link

A link you can create in your Web page that will allow visitors to easily send e-mail to you.    To create an 
e-mail link, you must supply its text and your e-mail address.    The text of the link should make it clear 
that visitors must click there to send you a message.

The e-mail address format for a CompuServe member is the user I.D. number followed by 
@compuserve.com.    Heres an example:

76003.511@CompuServe.com



extended HTML features

These are properties of the page that you can leave at the default settings (settings provided by Home 
Page Wizard) or change to suit your tastes.    They include background, link color, page color, and text 
color.

You must put a checkmark next to Allow Extended HTML Features from the Options pull-down menu to 
utilize these features.

You should be aware that a visitors Web browser may or may not support viewing extended HTML 
features.



external link

An electronic connection to a Web page outside your collection of Web pages.    This might be another 
page you like and think viewers of your page would like, too.



file format

The method used to electronically store data in a file.    Some examples are ASCII Text, binary data, or 
GIF.    When you choose a graphic image for your Web page, you should choose one whose file has a 
common format, such as GIF, so that most visitors to your pages will be able to view your graphics.



fixed font

A font where each character is stored as a bitmap.    Scaling such fonts is difficult (in contrast to 
proportional fonts like those used in Postcript).    The only text created in Home Page Wizard that is in a 
fixed font is pre-formatted text in text blocks.    You can specify which fixed font to use by choosing Fonts 
from the Options pull-down menu.



graphic image 

An electronic picture that you can add to your home page.    Home Page Wizard provides some graphics 
in its image library, and you can easily add more of your own.



Graphics Interchange Format (GIF)

A popular format for files used to store graphic images, photographs, etc.    GIF files can be displayed on 
many different kinds of computers.



headline

Any text in your pages that you want to emphasize.    This can be a section title or anything else you want 
to call attention to.    Home Page Wizard lets you select from six different of headline sizes. 

If you want to edit a headline, double-click on it.    A dialog containing the headline will appear.    Just make 
the changes you want and click the OK button.



home page

The first page that visitors see when they connect to your URL.    This can have internal links to other Web 
pages in your project.



 horizontal line

A bar you place across a page to separate various elements.    For example, you might put a horizontal 
bar between a headline and the following text.    Home Page Wizard lets you choose the height (in pixels) 
and width (by percentage of the page width) of the line.    It also lets you align the horizontal line at the 
right, left, or center of the page.



Hypertext Markup Language (HTML)

The language for Internet documents.    It allows your Web pages to be made available over the Internet 
and read by other computers.    Home Page Wizard automatically translates your pages into HTML.



Hypertext Transfer Protocol (HTTP)

The communication protocol used to transfer pages on the World Wide Web.    Protocols are the 
electronic rules that govern how computers communicate with each other.



image library

A storehouse of graphics that is already installed in the Home Page Wizard.    You access the Image 
Library by clicking the Image button on the toolbar and choosing the image from the list provided.    You 
can add images of your choosing to this library if you want.



internal link

An electronic connection from one of your Web pages to another.    If your project has more than one 
page (your home page), you should provide internal links so that visitors starting at the home page can 
find their way to the other pages in your project.    These other pages can be graphics, text, or both.



link

An electronic connection from one Web page to another that can be activated by a simple mouse click.    
You can create an internal link to other pages in your project, external link to other home pages on the 
Web, and/or an e-mail link to help visitors send you e-mail messages.



Mosaic

A graphical World Wide Web browser.



page background

The solid color or pattern that underlies all the components you put on a page.    The default page 
background is a solid ligth gray, but you can select a different color or color blend, or a graphic image.



page components

The page components in Home Page Wizard are headlines, text, graphic image, horizontal lines, external 
links, internal links, and e-mail links.



page properties

Various characteristics and features of a Web page, such as background color or background image, link 
color, and text color.    Page properties are initially determined by the project template, but you can 
change them for individual pages.



page title

The name, or title, given to each Web page.    You supply the title for the main home page when you start 
a project, and you supply the title for any other page when you add the page.    You can change a page 
title by choosing Change Title from the Page pull-down menu.



pixels

The individual dots of color on your computer monitors screen.    The height of a horizontal line is 
measured in pixels.



project

The collective name for one or more interconnected Web pages.    For example, a project might include a 
brief introduction about yourself and your interests, a link to a picture of yourself or a pet, and other links 
to more detailed discussions of things mentioned in your home page.



project name

The name you give to a Web page project when you begin creating it.    A project name can be up to eight 
characters long, and can include any combination of letters, numeric digits, underscore characters ( _ ), 
and hyphens (-).    Home page Wizard creates a subdirectory with that name within the Home Page 
Wizard\PROJECT directory to hold the files that contain individual Web pages.

For example, assuming that you installed Home Page Wizard in the default C:\CSERVE\HPWIZ directory, 
if you name your project SMITH, then the Web page files will be stored in C:
\CSERVE\HPWIZ\PROJECT\SMITH.



project template

A standardized form for Web pages.    A template provides a basic form and helps you fill in text and 
graphics.    Home Page Wizard includes templates to make building your Web page project easier.



proportional font

A font created with lines and curves, as opposed to a fixed font.    A proportional font, such as Postcsript 
or True Type) can be scaled to any size, and otherwise transformed more easily than a fixed font.    All 
textual portions of a page created in Home Page Wizard are in a proportional font except for pre-
formatted text in text blocks.    You can specify which proportional font to use by choosing Fonts from the 
Options pull-down menu.



publish

To make your collection of pages available on the World Wide Web.



Publishing Wizard

The software provided by CompuServe that allows CompuServe members to place their home pages on 
the World Wide Web. 



status bar

The bar at the bottom of your computer screen that gives you information pertinent to the project.



test

A way to see your pages as they will look on the World Wide Web before actually publishing them.    To 
test your page, click the Test icon on the toolbar, or choose Test Pages from the File pull-down menu.



text

The words you want people to read in your home page.    Generally speaking, it means the body of your 
page as opposed to graphics, but links and/or headlines contain text.

You create a block of text by clicking the Text icon on the toolbar.    Once you have typed it in, you can 
move the text to the right position by using the drag and drop feature of Home Page Wizard.



text block

A grouping of text in your Web page.    You can have more than one text block per page, and each one 
can be moved by using the drag and drop feature of Home Page Wizard.    To install an individual text 
block, click the Text icon in the toolbar, type in the text you want, and click OK.    Repeat this process for 
each block you want.

If you want to edit a text block, double-click on it and make the corrections in the dialog that appears.    
When you finish the corrections, click OK.



toolbar

The row of icon buttons across the top of the Home Page Wizard, such as the ones shown below. These 
help you to design and construct your own home page.    Just click on the one you want to use and the 
Wizard helps you add it to your home page.

Headline    Allows you to give 
emphasis to important text.

Text    Allows you to add the 
written part of your Web page; 
as opposed to graphics.

Image    Allows you to insert 
graphics into your Web page.

Lines    Allows you to add a 
horizontal line to your web 
page.

External Link    Allows you to 
connect your Web page to other 
pages on the Web.

Internal Link    Allows you to 
connect your home page to 
other Web pages in the same 
project.
E-Mail    Allows you to add an e-
mail link to your web page so 
visitors to your pages can send 
you electronic messages.
Background    Allows you to add 
a colorful wallpaper under your 
text and graphics.

Test    Allows you to preview 
your Web pages before you 
publish them on the World Wide 
Web. 
Publish    Places your pages on 
the World Wide Web. 

Help    Takes you to the answers 
to your questions about Home 
Page Wizard.

Uniform Resource Locator (URL)

The electronic address for a destination on the World Wide Web.    URLs always start with http:// and 
CompuServes URL is http://www.CompuServe.com



wallpaper

An optional background for your Web pages, typically a graphic image.    Home Page Wizard lets you 
choose from clouds, coins, coffee beans, rain drops, sand, test patterns, and more.    You choose one by 
clicking on the Background button on the toolbar.



Web browser

A software program that allows you to navigate the World Wide Web and view its pages on your computer 
screen.    SPRY Mosaic is a World Wide Web browser produced by CompuServe and provided as part of 
Release 2.0 of the CompuServe Information Manager, Windows version.



Web page

The general name given to any document accessible via the World Wide Web.    A Home Page Wizard 
project can have one Web page, or several that are linked together.    The first page that a visitor 
encounters, which may or may not be the only one, is called a home page.



World Wide Web

A vast interconnected electronic system for the exchange of information and ideas among people all over 
the world.




