
  

What is Thomson Classified?
Tel-Me Thomson Classified allows you to find addresses and telephone numbers of businesses in a 
particular locality according to their trade classification. As well as locating up to twenty appropriate 
businesses in the requested area, Thomson Classified also produces a UK map showing the relative 
densities of such businesses within the country as a whole. As an additional service you can also 
choose to download many more businesses of the required type and automatically produce call sheets, 
posting labels and/or exportable data files. 

Thomson Classified provides full access to all UK businesses that have opted to take a free listing in the 
Thomson directory. Please note that information for businesses in Northern Ireland, Kingston-upon-Hull 
and the Channel Islands is not available through Thomson Classified, however, specific Northern Ireland 
telephone numbers can be obtained using Tel-Me Teledirectory. 

See also
Making a Thomson Classified Enquiry
Viewing the Response
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Viewing the Response
When the response is received, Thomson Classified will display a summary of up to twenty received 
businesses within two information boxes in the Product Area. Further details are contained within the 
Extended Information Screen.

Once in the Extended Information Screen you can toggle between viewing the address details and a 
distribution map.

The following options are also available from the View menu:

 to view the address details.

 to view the distribution map.

See also
Using the Map
Making a Thomson Classified Enquiry
Thomson Classified Menus and Toolbar
Transferring to and from the Extended Information Screen. 



  

Business Data Download
Thomson Classified is an invaluable tool to those who wish to contact many businesses of a certain kind 
at local or national level. By using the inclusive Data Download feature after a normal enquiry, you can 
obtain contact details for up to five thousand companies, either centering around a particular location or 
as a geographic spread. The downloaded details can then be printed as call sheets or labels, or 
alternatively exported as a basic data file.

Points to Bear in Mind When Downloading Data

To download multi business data:

1. Make a normal Thomson Classified enquiry based on the required Business Type and Location.

2. Click on the  button from the toolbar or select the Download Data option from the Data menu.
3. Choose the required options from the subsequently displayed Business Download dialog and 
click the Download button.
4. When the data has been downloaded you can then choose to:

Printing Labels and/or Call Sheets
Export the data to a file



  

Business Download Dialog
When the Download Data option is selected, the following is displayed:

                
To make a download request:

1. Choose the required Quantity Selection.

2. Choose the required Intended Usage.

3. Click the Download Button.                                                                      



  

Business Data Export
Using this option you can create data files containing company information that can be used within other 
programs. You must first have perfomed a successful Data Download session using the Multiple Use 
option.

To export data:

1. Click on the  button from the toolbar or select the Export downloaded data option form the Data 
menu. The following dialog is displayed:

Click on the required item for more information.

2. Select the required Start and Finish record numbers.

3. Click on the Select Target File button to determine the location and name of the new file.

4. Click on the OK button to proceed with the file export.

The file is created in a comma separated ASCII format using your entered name and the .TXT extension 
unless altered otherwise. 



  

Printing Labels and Call Sheets
Using this option you can create sales call sheets for telemarketing purposes. You must first have 
performed a successful Data Download session using either the Single Use or Multiple Use options.

For more information:
      Printing Labels
      Printing Call Sheets



  

Printing Labels
To print labels

1. Select the Label Settings option from the Options menu to view the Label Printing Options dialog.

2. Click on the  button from the toolbar or select the Print Label option from the Data menu.
3. Click on the OK button within the subsequent dialog to proceed to a standard Windows printer 
selection dialog where you can choose and configure the target printer (if required) before printing.



  

Printing Call Sheets
To print call sheets:

1. Click on the  button from the toolbar or select the Print Call Sheets option from the Data menu. 
The following dialog is displayed:

Click on the required item for more information.

2. Enter the appropriate Campaign Name, Agent/Employee and Client Reference details into the 
relevant fields.

3. Click on the OK button to proceed to a standard Windows printer selection dialog where you can 
choose and configure the target printer (if required) before printing.



Map

The map provides an instant indication of the density of businesses throughout the UK mainland that are 
trading under the current classification. Each coloured dot on the map gives an indication of the number 
of like businesses trading within a 5km squared area. The key allows you to quickly discover the density 
figure for each displayed colour.

Choose the Using the Map option at the foot of this screen to find out more about changing the map 
size, zooming in and out, panning around and changing the level of detail.



Quantity Selection

This section allows you to control the range of business details that are returned during the download 
operation. You can opt to place restrictions on the geographical range, the numerical quantity or a 
mixture of both. 

To define a geographical range (centered around your original enquiry location): Enter a radius (in 
kilometres) into the Maximum Range field. If you wish, you can then click the Preview button to discover 
how many businesses will be included within that area. The response will be presented as follows:

Using the returned preview information you can then decide whether you wish to limit the size of the 
download. 
To limit the quantity of downloaded business details: enter a value in the Maximum Number to 
Download field. As the returned business details are automatically placed in order of proximity to the 
original enquiry location, limiting the number of them, using this field, will remove those that are furthest 
away. 
A statutory limit of 5000 is placed on all downloads.



Maximum Range Option

This field allows you to optionally define a geographical range that is centered around your original 
enquiry location. To use this option, enter a radius (in kilometres) into field. If you wish, you can then 
click the Preview button to discover how many businesses will be included within that area.    The 
response will be presented as follows:

Using this information you can then decide whether you need to increase or decrease the range or 
whether you wish to place an additional limit on the enquiry using the Maximum Number to Download 
field. 
When the Range is correct, click on the Download button to retrieve the business data. 



Maximum Number to Download

This option allows you to place an upper limit on the number of business details to be downloaded. This 
option can be used as the sole download restriction or in conjunction with the Maximum Range entry.

To use this option, enter the required number of businesses that you wish to retrieve in the field provided 
and click on the Download button. As the returned business details are automatically placed in order of 
proximity to the original enquiry location, limiting the number of them, using this field, will remove those 
that are furthest away.

A statutory limit of 5000 is placed on all downloads.



Intended Usage Section

This section allows you to specify how the information will be used and thus which tariff level you will 
incur as a result:

If you wish to use the downloaded data for printing labels and/or call sheets in a one-off situation, 
choose the first option.

If you wish to use the downloaded data for printing labels and/or call sheets and/or export the 
data to an ASCII file (subject to Thomson Directories conditions) for use more than once, choose the 
second option.

If you wish the telephone numbers for each downloaded business to be omitted, uncheck the 
Include tel numbers option. 



Single Use Option

Choose this option if you wish to use the downloaded data for printing labels and/or call sheets in a one-
off situation.



Multiple Use Option

Choose this option if you wish to use the downloaded data for printing labels, call sheets and/or export 
the data to an ASCII file (subject to Thomson Directories conditions) for use more than once.



Include Telephone Numbers Option

Uncheck this box if you wish the telephone numbers for each downloaded business to be omitted.



Download Button

Begins the data download procedure using the entered parameters.



Cancel

Exits from the dialog box and returns to the previous screen.



Start At

Enter the record number at which you would like to begin exporting. If you plan to export all downloaded 
business details, then enter "1" in this field.



Finish At

Enter the record number at which you would like to the export to end. If you plan to export all 
downloaded business details, then enter the number displayed in the "Number of records available for 
export:" entry in this field.



Select Target File Button

Click on this button to reveal a standard Windows file dialog. Using this you can enter a name and 
location for the new export file.



Target file name

This entry displays the expected name and location of the export file to be created once you have made 
a configuration using the Select Target File button. 



Number of records available for export

This entry shows the total number of records that were previously downloaded and hence are avilable 
for export. If you wish to export all records, enter the number displayed here into the Finish At field.



OK

Exits from the dialog and proceeds with the requested action.



Campaign Name

Use this optional field to enter the name of the telemarketing campaign for which the call sheets are 
being produced. The entered information will be printed at the top of each call sheet.



Agent/Employee

Use this optional field to enter the name of the telemarketing person for whom the call sheets are being 
produced. The entered information will be printed at the top of each call sheet.



Client Reference

Use this optional field to enter a reference for the telemarketing campaign. The entered information will 
be printed at the top of each call sheet.



Points to Bear in Mind When Downloading Data
An additional charge is made for addresses that are downloaded. The standard charge is 

available from PhoneLink Customer Services.
In general, each business record downloaded occupies roughly 100 bytes. Before beginning a 

download, check that your system has enough free space on the drive that holds Tel-Me: 
Space Required = Number of Records x 100 bytes.

For large downloads, the transfer process can be reasonably lengthy so it is best carried out 
during off-peak times when the system is not so busy and connection charges are cheaper.

As the download process occurs, you will be presented with the message shown below. By 
proceeding with the download you are accepting the conditions of the licence:

© Thomson Directories
Reminder: The information that you are downloading is the property of Thomson Directories. At the 
tariff you have paid it may be used (once only/more than once)* for your company's marketing 
activities, however, it may not be added to a database or re-sold. Substantial parts should not be 
disclosed to third parties. Please refer to clause 6.5 of the Standard Conditions of Provision of Tel-Me 
for full details of your rights and obligations. 
Warning: Seed business information may be added to your selection to monitor its use.
* Depending on whether you select the Single or Multiple use options.




