
  

Making a Thomson Classified Enquiry
When using Thomson Classified, your first action is to use the input area to enter details about the type 
and location of businesses that you wish to view.

The Thomson Classified Input Area is arranged as follows:

Click on the required item for more information.

The actions required to make a Thomson Classified enquiry are as follows:

1. Enter the required trade classification into the Business Type field.

2. Enter the name of the area into the Location field.

3. Click on the Send button or press ENTER to begin the enquiry.

Once the enquiry is made, a corresponding entry is added to the top of the library using either the 
Business Type or the Reference (if one was entered) as the heading.

See also
Viewing the Response



  

Using the Map
The map provides an instant indication of the density of businesses throughout the UK mainland that are 
trading under the current classification. Each coloured dot on the map gives an indication of the number 
of like businesses trading within a 5km squared area. The key allows you to quickly discover the density 
figure for each displayed colour. 

The map has two viewing sizes:

    Selects the full screen map. Alternatively, select Distribution Map from the View menu. 

    Selects the address details. Alternatively, select Address Details from the View menu.

You can zoom into and out of either map size:

    This button zooms-in one level. Alternatively, select Zoom In from the Map menu.

    This button zooms-out one level. Alternatively, select Zoom Out from the Map menu.

You can pan around within either map size:

    This button pans left. Alternatively, select Pan Left from the Map menu.

    This button pans up. Alternatively, select Pan Up from the Map menu.

    This button pans down. Alternatively, select Pan Down from the Map menu.

    This button pans right. Alternatively, select Pan Right from the Map menu.

On the full screen map you can alter the level of place names displayed:

    Increases the detail displayed. Alternatively, select More Place Names from the Map menu. 

    Decreases the detail displayed. Alternatively, select Less Place Names from the Map menu.



  

Thomson Classified Menus and Toolbar
The menus and toolbar within the Teledirectory Extended Information Screen are arranged as follows:

Click on the required item for more information.

See also
Making a Thomson Classified Enquiry
Viewing the Response 



  

Label Printing Options
This dialog allows you to configure Classified precisely according to your printer and label sheets.

Click on the required item for more information.

1. Set the Number of Labels on Page fields according to your label sheets.

2. Set the Space Between Labels and Size of Each Label fields.

3. Set the Position of Address within Label fields and the Margin at the Edge of the Page fields.

5. Click OK. 
  

  



  

Address Details

Click on the required item for more information.

See also
Using the Map
Viewing the Response



Business Type

Enter the trade classification until the text changes to green. At this point an initial enquiry is made and a 
list of possible matches is returned.    Further typing refines the list until a single match is left.    
Alternatively, scroll through the list using the cursor up/down or page up/down keys to highlight the 
required entry. Use the TAB key to select.



Location

Enter the name of the village, town or city that will form the origin of the search into this field. Typing the 
first character makes a list of possible matches appear. Further typing refines the list until a single match 
is left. Alternatively, scroll through the list using the cursor up/down or page up/down keys to highlight 
the required location. Use the TAB key to select the highlighted location.

Because the list is held locally, the text does not change colour to indicate the gathering of information.



No. of Entries
Once the catagory name(s) have been returned, this field indicates the number of businesses in the 
chosen catagory.



File 

Print...      Sends the retrieved business information to the currently selected printer for output. Press Ctrl 
and P as a shortcut for this option.

Print Preview    Displays a preview of how the information to be sent to the printer is expected to appear 
when it is output. Within the preview you can zoom in and out to view specific areas and move between 
the various pages to be printed.

Print Setup...    Selects the Windows Printer Setup dialog box so that you may configure a selected 
printer. 

Exit    Closes the Extended Information Screen and returns to the Tel-Me product area.



Edit 

Cut This option is not available within this product and remains greyed-out.

Copy    Places a copy of the retrieved business information into the Windows clipboard so that it can be 
transferred to another program. Press Ctrl and C as a shortcut for this option. 

Paste    This option is not available within this product and remains greyed-out.



Data

Download Data    Allows you to specify criteria that will search for and download a large number of 
business details to a given classification and, if required, a particular location. 

Export Downloaded Data    Allows you to export previously downloaded multiple-use business details 
to an ASCII file for use with another program.

Print Call Sheets    Allows you to produce call sheets from previously downloaded business details for 
use in telemarketing operations.

Print Labels    Allows you to produce address labels from previously downloaded business details for 
use in mailshot operations.



View
Address Details    Displays the list of returned businesses and their addresses.

Distribution Map    Displays the full screen map that can include place name details.



Options
Font    Displays a standard Windows font dialog that allows you to set the typeface used to display the 
returned business details within the Extended Information Screen. These settings affect the screen 
display only.

Label Settings    Displays the Label Printing Options dialog that allows you to configure Thomson 
Classified so that it prints precisely according to your printer and label sheet setup.



Map 

Zoom In    Increases the magnification of the displayed map to show more detail. 

Zoom Out    Decreases the magnification of the displayed map to show a greater area.

Pan Left      Moves the view of the currently displayed map to the left. 

Pan Right      Moves the view of the currently displayed map to the right.

Pan Down      Moves the view of the currently displayed map downwards.

Pan Up      Moves the view of the currently displayed map upwards.

More place names    Increases the level of location detail included on the displayed map.

Less place names    Decreases the level of location detail included on the displayed map.



Help

Contents      Displays the main contents page of this help program.

Help on Classified      Displays the initial page and contents of the Classified help. Press F1 as a 
shortcut for this option.

About Classified      Provides copyright and version details for the current version of Classified and also 
indicates the system resources available. 



Copy Button 

Places a copy of the retrieved business information into the Windows clipboard so that it can be 
transferred to another program. Press Ctrl and C as a shortcut for this option.

This option is also selectable from the Edit menu.



Print Button

Sends the retrieved business information to the currently selected printer for output. Press Ctrl and P as 
a shortcut for this option.

This option is also selectable from the File menu.



Print Preview Button

Displays a preview of how the information to be sent to the printer is expected to appear when it is 
output. Within the preview you can zoom in and out too view specific areas and move between the 
various pages to be printed.

This option is also selectable from the File menu.



Exit Button 

This is the same as using Alt-F4 and will close the Extended Information Screen to return control to the 
Product Area. This action has no effect on the data which will still be available in the Library for re-
examination.

This option is also selectable from the File menu.



Export Downloaded Data Button 

Allows you to export previously downloaded multiple-use business details to an ASCII file for use with 
another program.

This option is also selectable from the Data menu.



Download Data Button 

Allows you to specify criteria that will search for and download a large number of business details to a 
given classification and, if required, a particular location. 

This option is also selectable from the Data menu.



Print Call Sheets Button

Allows you to produce call sheets from previously downloaded business details for use in telemarketing 
operations.

This option is also selectable from the Data menu.



Print Labels Button

Allows you to produce address labels from previously downloaded business details for use in mailshot 
operations.

This option is also selectable from the Data menu.



Zoom In Button 

Increases the magnification of the displayed map to show more detail.

This option is also selectable from the Map menu.



Zoom Out Button 

Decreases the magnification of the displayed map to show a greater area.

This option is also selectable from the Map menu.



Pan Left Button 

Moves the view of the currently displayed map to the left.

This option is also selectable from the Map menu.



Pan Up Button 

Moves the view of the currently displayed map upwards.

This option is also selectable from the Map menu.



Pan Down Button 

Moves the view of the currently displayed map downwards.

This option is also selectable from the Map menu.



Pan Right Button 

Moves the view of the currently displayed map to the right.

This option is also selectable from the Map menu.



Full Size Map Button 

Displays the full screen map that can include place name details.

This option is also selectable from the View menu.



Address Details 

Displays the list of returned businesses and their addresses.

This option is also selectable from the View menu.



More Places Button 

Increases the level of location detail included on the full size map.

This option is also selectable from the Map menu.



Less Places Button 

Decreases the level of location detail included on the full size map.

This option is also selectable from the Map menu.



Help Button 

Displays the initial page and contents of the Classified help. Press F1 as a shortcut for this option.

This option is also selectable from the Help menu.



Ref 

An optional field for entering a reference for the enquiry. Thomson Classified will assign a reference 
automatically if nothing is entered.



Send

Begins an enquiry using the details entered in the input area.



Clear

Removes any entered information from the input fields.



OK 

Exits from the dialog box and saves any changes made.



Cancel 

Exits from the dialog box and discards any changes made.



Nearest 20

This section provides a listing of up to twenty businesses of the appropriate classification centering on 
the location given. As an entry in the list is highlighted, full information for that business is provided in the 
Business Details and Information boxes.



Information

This section indicates various details for the chosen classification. The information provided includes the 
Business Type (trade classification), the original central Location that was requested and the total 
number of businesses trading under this classification within the UK.



Business Details

This section provides full address details for the business currently highlighted in the Nearest 20 box 
below.



Number of Labels on Page

Across
This field allows you to specify the number of labels that you wish to print horizontally across your page.

Down
This field allows you to specify the number of labels that you wish to print vertically down your page.



Space Between Labels

Across
This field allows you to specify a space (in millimetres) between each label, going horizontally.

Down
This field allows you to specify a space (in millimetres) between each label, going vertically.



Size of Each Label

Height
This field allows you to specify the height (in millimetres) of each label.

Width
This field allows you to specify the width (in millimetres) of each label.



Position of Address with Label

From Left
This field allows you to position the printed address horizontally (in millimetres) from the left hand edge 
of each label. 

From Top
This field allows you to position the printed address vertically (in millimetres) from the top edge of each 
label.



Margin at the Edge of the Page

From Left
This field allows you to define a margin on the left hand side of the page to account for any horizontal 
spacing imposed by the printer.

From Top
This field allows you to define a margin at the top of the page to account for any vertical spacing 
imposed by the printer.

Initial Setup
When configuring a label print for the first time it is advisable to print a single page first to check the 
printer and label sheet alignment. From this print-out you can then judge whether further adjustment is 
required to the margins.




