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What is Internet E-Mail?

Tel-Me Internet E-Mail allows you to create Electronic Mail links to friends, colleagues and business
associates via the ever expanding global Internet network. Through Tel-Me's intuitive user interface
technology and state-of-the-art data processing centre, the usual difficulties encountered with using the
Internet are already solved for you.

When you first use Tel-Me Internet E-Mail, you are given the opportunity to choose your own unique E-
Mail Identification Name. Once the ID name is accepted by the Tel-Me system, you can disclose it to
others as your E-Mail address on the Internet and then they can contact you.

See also

What is an Internet E-Mail Address?
Setting up your Internet E-Mail Address
Creating a New Message

Scanning for Incoming Mail
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What is an Internet E-Mail Address?

A Personal E-Mail Address is required for each Tel-Me user with Internet E-Mail. Your Internet E-Mail
Address will consist of three parts. The first part is a name that identifies you personally and always
appears with an @ symbol after it. The second part is typically the name of your organisation and is

usually referred to as the subdomain. The identifies you as being a Tel-Me Internet E-Mail
user and cannot be changed.

For example:

ibloggs @xyzcompany.telme.com
B Your Personal Mail ID.

B The Subdomain Name for your organisation.
_ | ltems added automatically by Tel-Me.

Each Tel-Me licence is allowed to have its own subdomain name which is set up by the supervisor. All
users within the licence will share this subdomain and will therefore need to specify different Personal

Mail IDs. When there is only one user on the licence, the same arrangement is retained and you
become the sole user within your chosen subdomain.

See also
Setting up your Internet E-Mail Address
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Setting up your Internet E-Mail Addesss

When entering the E-Mail product for the first time, you will be unable to type anything. This is because
you need to register an Internet E-Mail Address before sending or receiving any messages.

Near the centre of the screen the following button will be displayed. Simply click on it to register your
Internet E-Mail address.

Beaqizster E-Mail
Address

In order to determine whether an addresss already exists for your licence, Tel-Me will need to contact the
PhoneLink data processing centre

See also
What is an Internet E-Mail Address?

Register Mail Address
Changing a Personal Mail ID
Changing your Subdomain
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Register Mail Address

You set up your Internet E-Mail Address using the following dialog:

= Register Mail Address

Y'ou are either un-registered or have changed your Tele uzer D and must
pravide a mail ID and [if neceszany] a subdamain.

YWhen registening a subdomain you need o enter your supervisor passward.
Thiz waz zupplied with your Tel-te user |0 and password.

| @ | -TelMe.com

Your Full Hame: I Extra__. I

Supervisor Pazsword: | Advanced. . I

0K || Cancel I

Click on the required item for more information.
Supervisors will need to complete all four fields, whereas other users on the licence will only need to
supply their Personal Mail ID and Full Name.

See also

Changing a Personal Mail ID
Changing your Subdomain



Postmaster Tel-Me ID

This identification number is used as the recipient for mail that arrives to your subdomain that is not
addressed to a particular individual. If it is acceptable to have such mail sent to the supervisor, then you
do not need to change it. If you wish unaddressed mail to go to a different user, then enter the personal

Tel-Me ID for that user.
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Changing a Personal Mail ID

Your first action when using Internet E-Mail is to set up your Internet E-Mail Address. Having done so
you are free to change the Personal Mail ID part of the address at any time, though it is important to
note that all mail that is sent to your previous address will be lost.

To change a Personal Mail ID:

1. Select Register E-Mail Address from the Tools menu.

2. A prompt with the current address is displayed. Select Change to continue.

3. Awarning appears indicating the consequence of this action. To continue select Yes.
4

. The Register Mail Address screen is displayed.
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General Configuration Options

Tel-Me Internet E-Mail provides you with a number of options so that you can alter and customise the
way that it operates. These include a Signature Block which is a piece of text that you create and which
is automatically added to the end of each email message that you send. Also you can configure how the
program treats existing messages when replying to them and which font is used within the Internet E-
Mail editor.

To set general configuration options:

1. Select the Configuration... option from the Options menu of the Internet E-Mail Product Area.
2. Enter the required information into the resulting E-Mail Configuration Options dialog.

3. Click the OK button within the E-Mail Configuration Options dialog to save the entered details.

To configure the editor font:

1. Select the Editor Font... option from the Options menu of the Internet E-Mail Product Area.
2. Select the required font configuration from the resulting dialog.

3. Click the OK button within the Font dialog to save the selected details.
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Creating and Editing Groups

Tel-Me Internet E-Mail allows you to create mailing groups using the individual entries from the Address
Book. This means that if there are a number of people that you regularly contact collectively, you can
include them in the same group and select them with a single action. Each person within your Address
Book can belong to as many groups as required and still be individually selectable.

You can perform the following group operations:

- Create a new group
. Change an existing group

. Remove an existing group
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Scanning for Incoming Mail

When messages are received for your attention from other email users, they are temporarily stored at
the PhonelLink data processing centre until you decide to download them. The presence of incoming
messages can be discovered in any of four situations:

By performing a message scan whenever Tel-Me starts-up, or

By scanning for messages while outgoing emails are sent, or

By automatic message scan during other Tel-Me product enquiries, or

By clicking on the Scan button to make an immediate search for messages.

See also

Selecting and Viewing Incoming Mail
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Selecting and Viewing Incoming Malil

Selecting Messages
Following a successful scan where incoming messages are discovered, brief headlines for each

message will be displayed in the lower section of the Product Area. The entries have the following
layout:

2 johnd @& xpz coouk Friday's meeting 0/03/95 <1k

|:| E= jgmith @ widgets inc.us Mew zehedule for completion 0s/03/95 <1k
{® fredb @& cyberrut.co.uk Fioge & Crown on Thursday? 03/03/95 <1K

Click on the required item for more information.

You can now use the displayed headlines to choose which messages to download:
1. Tag the headline(s) for the messages that you wish to read.

2. Click the Retrieve Items button to initiate the download enquiry.

As each message is retrieved the corresponding grey document icon against the tagged headline
changes into a colour document. As soon as this happens, even while more messages are being
retrieved, you can begin viewing the message.

Note: If there are received messages that you do not wish to read, avoid cluttering the PhoneLink
system by tagging the appropriate headlines and clicking the Delete Items button.

See also

Replying to, and Forwarding Malil
Internet E-Mail Menus and Toolbar
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Selecting and Viewing Incoming Malil

Viewing Messages
As soon as a greyed document icon becomes coloured you can view the message for the adjacent
headline by:

. Double clicking on the required headline, or

. Moving the highlight bar to the required line and clicking the View button.

The selected message is displayed in the Internet E-Mail Extended Information Screen.

If the message appears garbled, it may have been encrypted using a key code. To unscramble the
message, you need to discover the contents of key code from the originator and then select the Decrypt
option from the Mail menu.

If multiple messages have been retrieved, you can move between them by:

" Using the Next >> and << Prior buttons at the foot of the window, or

. Selecting the next message from the mail list window displayed just below the toolbar, or

. Clicking on the Return to main screen button and choosing from the list of headlines.
See also

Transferring to and from the Extended Information Screen

Setting Mailbox Window Preferences

Replying to, and Forwarding Malil
Internet E-Mail Menus and Toolbar
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Replying to, and Forwarding Mail

When viewing a retrieved message, you can choose to:
Create a reply and send it to the originator plus any additional recipients, or
Create a reply and send it to all addressees associated with the original, or
Forward the message, with comments if required, to other recipients.




@ Internet E—Maill
&B Internet E—Maill
Setting Editor Preferences

When creating a new message or replying to/forwarding received mail, you can configure various
aspects of the text editor within the Extended Information Screen. Select the Preferences option from
the Special menu to display the following dialog box:

= E-Mail Editor Preferences

2 Word wrap
[] Show E-Mail Header

Audible Warmning Bell

O] Beep when waming column iz reached

Waming column:

| oK I|Eam::el|

Click on the required item for more information.
[Return to Previous ||
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Setting Mailbox Window Preferences

When viewing a received message, you can configure various aspects of the text editor within the
Extended Information Screen. Select the Preferences option from the File menu to display the following
dialog box:

= Mailbox Window Preferences
 Mail List Window

Default Size: EI Lines

] Save Last Position

~ Mail ltem Window
(<] Show E-Mail Header

I 1] 4 I|Eancel|

Click on the required item for more information.
[Return to Previous ||
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Internet E-Mail Menus and Toolbar

Internet E-Mail displays one of two Extended Information Screens depending on whether a retrieved
message is being viewed or a message is being replied to/forwarded:

When Viewing Retrieved Mail

= Tel-Me - Internet E-Mail nn
File Edit Mail Help

BEIRNIRIRREREE

Click on the required item for more information.

When Creating New/Replying to/Forwarding Mail

Tel-Me - Internet E-Mail - New Message un
File Edit Special Help

2] [c] 8] [F1R] (=] (=] [&] (2]

Click on the required item for more information.



The Internet

The Internet is a collective of some of the largest and most powerful computer networks in the world. By
forming links between differing networks around the globe, the Internet offers an unparalleled spread of
users in excess of 20 million people.

The Internet began as a US military research project in 1969 to evaluate how remote computers could
be efficiently and resiliently connected together. Since that time, the number of computers connected to
the Internet has grown steadily. In recent times, with the advent of wider computer ownership, the
Internet has become the most desirable way to become connected and to forge electronic links with
other computer users.

Ease of use, however, has never been the strong point of the Internet and it can present a number of
problems when initially connecting to it and in learning some of the standard text-based programs.
Hence, Tel-Me Internet E-Mail provides an intuitive user interface and takes care of any connection
problems.



Name

This field holds the name of the person and is displayed in the Address Book list. This is a mandatory
entry.



E-Mail Address

Enter the full email address for the person in this field. The full address must be entered exactly with the
correct use of full stops. This is a mandatory entry.



Address/Organisation

This field allows you to optionally enter postal address details for the person.



Phone

This field allows you to optionally enter a phone number for the person.



Notes

This field allows you to optionally enter notes in connection with the person.



Adding and Removing Names to/from the Selected Names List

You can add names to the Selected Names list by:

. Double-clicking on a single Available Name, or
. Highlighting one or more Available Names and click on the Add-> button, or
. Holding the CTRL key and click on all of the required Available Names and then click on the Add-
> button.
You can remove names from the Selected Names list by:
" Double-clicking on a single Selected Name, or
" Highlighting one or more Selected Names and click on the <-Remove button, or
" Holding the CTRL key and click on all of the required Selected Names and then click on the <-

Remove button.



AutoScan During Tel-Me Start-up

Within the E-Mail Configuration Options dialog you can set Internet E-Mail to perform an automatic
message scan when Tel-Me is started. An enquiry will be made each time Tel-Me is loaded and the
system will inform you if any incoming messages are discovered by displaying an envelope icon in the
Product Area status bar.

To select the E-Mail Configuration Options dialog, select the Configuration... option from the Options
menu in the Product Area. Within the dialog, select the Check mailbox status on startup option.



AutoScan While Sending Messages

Within the E-Mail Configuration Options dialog you can set Internet E-Mail to search for incoming
messages while other, outgoing, messages are sent.

To select the E-Mail Configuration Options dialog, select the Configuration... option from the Options
menu in the Product Area. Within the dialog, check the Scan mailbox during send mail option.



AutoScan During Other Tel-Me Enquiries

Tel-Me performs an automatic message scan whenever another product enquiry is made and the
system will inform you if any incoming messages are discovered. You will be informed if any incoming
messages are discovered by the appearance of an envelope icon in the Product Area status bar.



Manual Scan

Within Internet E-Mail you can perform an incoming message search at any time by clicking the Scan
button in the Input Area. An enquiry will be made and if any incoming messages are discovered,
headline details about the sender(s), the title(s), the date(s) and file size(s) will be displayed in the lower
section of the Product Area ready for selection.



Tagging Message Headlines

You can tag any number of message headlines individually by:

. Double-clicking on them (double-click again to un-tag), or

. Moving the highlight bar to the required line and pressing the space bar (press again to un-tag),
or

" Moving the highlight bar to the required line and clicking the Tag button.

You can select all of the message headlines by:
" Clicking the Tag All button.

Conversely, when all entries are tagged, you can deselect them all by:
" Clicking the Un-Tag All button.

The message box in the lower right corner of the window indicates the number of headlines currently
tagged as well as the total amount of text, in bytes, that they represent.



Tag Icon

This icon is displayed next to each message headline that you tag before you make the enquiry.



Greyed Document Icon

This icon replaces the tag symbol when an enquiry is initiated and is displayed until the respective new
message is received.



Coloured Document Icon

This icon replaces the greyed document symbol to signify that the respective new message has been
received.



Unopened Letter Icon

This symbol indicates that the respective message is new and unread.



Opened Letter Icon

This symbol indicates that the respective message has been viewed.



Sender's Name

This is the sender's email name (in bold) and address.



Message Title

This is the title of the message and, if written well, allows you to quickly ascertain what the message is
about.



Date

This is the date that the message was sent.



Message Size

This indicates the message file size in bytes and provides a rough guide to the size of the email.



Names List

This window provides a listing of all names and email addresses that are stored in the Address Book.



Details Button

Displays the stored information for the currently highlighted entry in the Names List.



Add Button

Adds a new person to the Address Book.



Remove Button
Deletes the currently highlighted entry from the Address Book.



Close Button
Exits from the Address Book dialog.



Default Size

Sets the standard size, in lines, of the received mail window that appears above the edit area. The
selected size will be implemented as you next enter the message viewing screen. However, if the Save
Last Position option is checked, then the size of the received mail window will be determined by how the

window border has been positioned using the mouse.



Save Last Position

When checked, this option retains the size of the received mail window as set by clicking and dragging
the horizontal window border using the mouse. This setting overides the Default Size entry when
checked.



Personal Mail ID

This is the part of the Internet E-Mail address that identifies you. It is usual to use an abbreviated form
of your name, for example, your Christian Name together with the first character(s) of your Surname.

Remember that the name chosen will be seen and used by anyone who you converse with via Internet
E-Mail.

In your chosen name you can use letters, numbers and certain other characters, but none of the
following: space () <>@ .,;: []]|



Subdomain Name

Each Tel-Me licence has one subdomain name that is then shared by all the users. This must be set up
by the licence supervisor and is usually the company name.

Remember that the name chosen will be seen and used by anyone who you converse with via Internet
E-Mail.

In your chosen name you can use letters, numbers and certain other characters, but none of the
following: space () <>@ .,;: []]|



Your Full Name

You should type the name that you are known by as it is used to identify you to the people that you
converse with via Internet E-Mail.



Extra...

Select the Extra button to be able to type in additional details about yourself and your company.



Supervisor Password

Enter the password that you use to access the User Admin program. The Supervisor password is
originally supplied with the Tel-Me package but can then be altered to suit your requirements so be sure

to use the one that is currently registered.



Advanced...

By default the supervisor is also the postmaster. Should you wish to make one of the other users the
postmaster, the supervisor will need to click on Advanced and enter their ID in the Postmaster ID field.



OK

Exits from the dialog box and saves any changes made.



Cancel

Exits from the dialog box and discards any changes made.



File
Save As Saves the current message text as a plain text (*. TXT) file.

Print... Sends the displayed information to the currently selected printer for output. Press Ctrl and P
as a shortcut for this option.

Print Preview Displays a preview of how the information to be sent to the printer is expected to appear
when it is output. Within the preview you can zoom in and out to view specific areas and move between
the various pages to be printed.

Print Setup... Selects the Windows Printer Setup dialog box so that you may configure a selected
printer.

Preferences Displays the Mailbox Window Preferences dialog to allow default settings to be
configured.

Exit Closes the Extended Information Screen and returns to the Tel-Me product area.



File

Send Sends the message.

Insert File... Allows you to insert a plain ASCII text file into the current document.
Attach File... Allows you to attach any file to the current document.

Print Prints the current document.

Exit Closes the Extended Information Screen and returns to the Tel-Me product area.



Edit

Copy Copies the selected information into the Windows clipboard. Press Ctrl and C as a shortcut for
this option.



Edit
Cut Cuts the selected information into the Windows clipboard. Press Ctrl and X as a shortcut for this
option.

Copy Copies the selected information into the Windows clipboard. Press Ctrl and C as a shortcut for
this option.

Paste Pastes information from the Windows clipboard into the selected position. Press Ctrl and V as a
shortcut for this option.



Mail
Decrypt Allows a key code to be entered that can then be used to decipher an encrypted message.
Reply Prepares the currently displayed message so that you can create a reply to the sender.

Reply All  Prepares the currently displayed message so that you can create a reply to all original
addressees.

Forward Prepares the currently displayed message so that you can forward it to other recipients.



Special
Preferences Displays the Email Editor Preferences dialog to allow default settings to be configured.
Editor Font... Allows you to modify the default font.

Append Signature Block Adds your predefined signature block to the end of the message.



Help
Contents Displays the main contents page of this help program.

Help on Internet E-Mail Displays the initial page and contents of the Internet E-Mail help. Press F1 as
a shortcut for this option.

About Internet E-Mail Provides copyright and version details for the current version of Internet E-Malil
and also indicates the system resources available.



Copy Button

Places a copy of the displayed information into the Windows clipboard. Press Ctrl and C as a shortcut
for this option.

This option is also selectable from the Edit menu.



Send Button
Sends the current message in the same way as pressing the Send button in the Product Area.

This option is also selectable from the File menu.



Insert ASCII Text File Button
Allows you to send a plain ASCII text file into the current document.

This option is also selectable from the File menu.



Attach Files Button
Allows you to attach any file to the current message.

This option is also selectable from the File menu.



Font Button
Change the default font.

This option is also selectable from the Special menu.



Print Button

Sends the displayed information to the currently selected printer for output. Press Ctrl and P as a
shortcut for this option.

This option is also selectable from the File menu.



Print Preview Button

Displays a preview of how the information to be sent to the printer is expected to appear when it is
output. Within the preview you can zoom in and out to view specific areas and move between the

various pages to be printed.
This option is also selectable from the File menu.



Reply Button
Prepares the currently displayed message so that you can create a reply to the sender.

This option is also selectable from the Mail Menu.



Reply All Button
Prepares the currently displayed message so that you can create a reply to all original addressees.

This option is also selectable from the Mail menu.



Forward Button
Prepares the currently displayed message so that you can forward it to other recipients.

This option is also selectable from the Mail menu.



Show Header Button

Toggles the display of the message header that provides addressing and subject information.



Append Signature Block Button
Adds your predefined signature block to the end of this particular message.

The default setting is selectable from the Options menu in the Product Area.



Exit Button

This is the same as using Alt-F4 and will close the Extended Information Screen to return control to the
Product Area. This action has no effect on the data which will still be available in the Library for re-

examination.
This option is also selectable from the File menu.



Help Button
Displays the initial page and contents of the Internet E-Mail help. Press F1 as a shortcut for this option.

This option is also selectable from the Help menu.



Retrieving Messages

When you click the Retrieve Items button, each of the tag icons against the selected message headlines
changes into a greyed document icon to indicate that a request is in progress. As each item is returned,
the greyed document icons become coloured to signal that the message is available for viewing.

Tag Icon
£l Greyed Doc. Icon
Coloured Doc. Icon



Warning Column

Sets the width of the editor page in terms of characters. The minimum width is 40 characters and the

maximum is 132, although it is advised to remain at or around the standard 78 characters as it can be
frustrating reading large-width messages.



Show Margin Guide Bar

When checked, this option places a dotted red vertical line at the position of the right margin specified in
the Number of Columns field.



Beep when Warning Column is Reached

When checked, this option causes a beep to be sounded when an entered line reaches the right margin
specified in the Number of Columns field. This acts like the bell on a typewriter and reminds you perform
a carriage return at your earliest convenience.



Word Wrap

If Word Wrap is checked then the text being typed automatically moves onto a new line when the right
hand margin is reached.



Show E-Mail Header

When checked, this option displays the header section at the top of the edit area that details the
addressees and the subject title.






