
  

What is Tel-Me User Admin?
Tel-Me User Admin allows you to tailor the operation of Tel-Me so that it fits seamlessly into your 
organisation. From small enterprises with a few users to large organisations with many hundreds, Tel-Me 
User Admin provides full control to structure and update the use of Tel-Me within departments, functions, 
teams etc.

Tel-Me User Admin allows you to: 
Register and update Unique Identity Numbers, Passwords and access rights to products across 

the whole organisation or within a department.
Designate Licence Supervisors and Departmental Supervisors who will administer the use of Tel-

Me within their domains. 
Designate users within departments with Unique Identity Numbers, Passwords and access rights 

to products and Product Profiles.
Prevent potential conflicts when changes are made by temporarily locking-out other Supervisors. 
Change the departmental positioning of users to mirror their movements within the organisation. 

See also
Getting Started
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Getting Started
Before you can begin to use Tel-Me User Admin you must have a Unique Identity Number and a 
Supervisor password. Tel-Me User Admin accesses central records that are held at the PhoneLink data 
processing centre so you will need a working communications system. 

To use Tel-Me User Admin:

1. Launch the Tel-Me User Admin icon from the Windows Program Manager. The program will run and 
display the following login dialog:

Click on the required item for more information.

2. Enter your Unique ID (if it is not already displayed) and the accompanying supervisor password. If 
you do not intend to make any changes then check the View only option as this will not lock-out other 
supervisors.

3. Click on the OK button to make the initial enquiry that is required to proceed further.

4. When using Tel-Me User Admin for the first time, it is recommended that you change both default 
passwords immediately. 

  



  

Saving Changes
When changes are made within Tel-Me User Admin, they are held only locally until such time as you exit 
the program or select the save option. No changes are effective within the Tel-Me system until they have 
been registered (saved) at the PhoneLink data processing centre. 

When you have completed all necessary changes, register them by:
Clicking on the 

 button from the toolbar, or
Selecting the Save option from the File menu, or
Exiting the program and answering Yes to the Save changes dialog. 



  

Tel-Me and Screen Savers
Tel-Me does not include a screensaver that is independent to the standard Windows screen saver. 
However, as a supervisor you can impose a "password lock" either globally, by department or for 
particular users. With the password lock set, a user will be presented with a dialog following a certain 
period of inactivity whereby further operation cannot proceed until a valid password is entered.

If that user also has a passworded Windows Screensaver, they may also be presented with a password 
request from the screensaver, which is independent of the security features built into Tel-Me. With both 
Tel-Me inactivity detection and a Windows screensaver, the sequence of events is:

1. Tel-Me Password request appears after timeout period.

2. Windows Screensaver appears after further timeout.

3. Windows screensaver password dialog appears on keypress/mouse movement.

4. Once correct Windows screensaver password has been entered, Tel-Me password dialog appears.

5. Tel-Me is operational once Tel-Me user password has been correctly entered.

Note that if the Cancel button is pressed on the Tel-Me password request, Tel-Me will exit.



  

Using Tel-Me User Admin
Once an initial contact has been made with the PhoneLink data processing centre, the Tel-Me User 
Admin window will display the details for your account in the following way:

Click on the required item for more information.

Within the licence tree you can perform a number of operations:
      Add objects
      Remove objects
      Change objects
      View details about each object
      Move users



  

Data Locking Feature
To ensure that conflicting changes are not made, Tel-Me User Admin grants exclusive configuration 
rights to a supervisor in any given area. This means that when a supervisor logs-in, the areas available 
to that supervisor are temporarily barred from others:

For department supervisors, only their immediate department is locked.
For licence supervisors, the whole Tel-Me configuration is locked.

Locks may be overridden in two situations:
When a supervisor has access and another supervisor of the same status wishes to make 

changes.
When a supervisor has access and another, higher level supervisor wishes to make changes.



  

Adding Objects to the Licence Tree
You can add the following objects to the licence tree:
      New Departments
      New Users
      New Profiles



  

Removing Objects from the Licence Tree
You can remove the following objects from the licence tree:
      Departments
      Users
      Profiles



  

Changing Objects in the Licence Tree
You can change various aspects of the following objects in the licence tree:
      The Licence 
      Departments
      Users
      Profiles



  

Viewing Information for Objects in the Licence Tree
You can view various types of information for the following objects in the licence tree:
      The Licence 
      Departments
      Users
      Profiles



  

Adding a New Department
To add a new department to the licence tree:

1. Highlight the Licence object.

2. Select the New Department option from the Licence menu. The following dialog is displayed:

Click on the required item for more information.

3. Enter a name for the new department, the maximum number of users and change any of the options 
if necessary.

4. Click on the OK button to enter the details into the licence tree.



  

Adding a New User
To add a new user to the licence tree:

1. Highlight either the Licence object or an existing department into which you wish to add the new 
user.

2. Select the New User option from the either the Licence menu or the Department menu (depending 
on where the user is being added). The following dialog is displayed:

Click on the required item for more information.

3. Enter a name for the new user, a password and change any of the options if necessary.

4. Click on the OK button to enter the details into the licence tree and display the Accessible products 
dialog.



  

Removing a Department
Departments can be removed from the licence tree either individually or collectively:

To remove a department individually:

1. First remove all users from the department. 

2. Highlight the required department in the licence tree.

3. Select the Remove Department option from the Department menu.

To remove all departments collectively:

1. First remove all users from all departments.

2. Highlight the licence object in the licence tree.

3. Select the Remove All Departments option from the Licence menu. 

See also 
Confirm Remove Actions



  

Removing a User
Users can be removed from the licence tree either individually or collectively:

To remove a user individually:

1. Highlight the required user in the licence tree. 

2. Select the Remove User option from the User menu.

To remove users collectively from a Department:

1. Highlight the required department in the licence tree. 

2. Select the Remove All Users option from the Department menu.

To remove users collectively from the licence item:

1. Highlight the licence object in the licence tree. 

2. Select the Remove All Users option from the Licence menu.

See also
Confirm Remove Actions



  

Removing a Product Profile
Profiles can be removed from the licence tree either individually or collectively:

To remove a profile individually:

1. Highlight the required profile in the licence tree. 

2. Select the Remove Profile option from the Profile menu.

To remove profiles collectively from a Department:

1. Highlight the required department in the licence tree. 

2. Select the Remove All Profiles option from the Department menu.

To remove profiles collectively from the licence item:

1. Highlight the licence object in the licence tree. 

2. Select the Remove All Profiles option from the Licence menu.

See also
Confirm Remove Actions



  

Changing Licence Details
To change licence details:

1. Highlight the licence object.

2. Select the Change option from the Licence menu. The following dialog is displayed:

Click on the required item for more information.

3. Make any necessary changes to any of the options. The name cannot be changed.

4. Click on the OK button to enter the details into the licence tree.



  

Changing Department Details
To change department details:

1. Highlight the required department object.

2. Select the Change option from the Department menu. The following dialog is displayed:

Click on the required item for more information.

3. Make any necessary changes to the name, the maximum number of users and/or any of the options.

4. Click on the OK button to enter the details into the licence tree.



  

Changing User Details
You can change three main aspects of user details:
      Name, password and other standard options
      Supervisor status
      Accessible products 



  

Changing User Details
To change the name, password or other options for a user:

1. Highlight the required user object.

2. Select the Change User Details option from the User menu. The following dialog is displayed:

Click on the required item for more information.

3. Make any necessary changes to the name, password and any of the options.

4. Click on the OK button to enter the details into the licence tree.



  

Changing User Details
To change the supervisor status of a user:

1. Highlight the required user object.

2. Select the Change Supervisor Details option from the User menu. The following dialog is displayed:

Click on the required item for more information.

3. Select the required status level for the user.

4. If either the Licence Supervisor or Department Supervisor options are selected, enter a password for 
the user. 

5. Click on the OK button to enter the details into the licence tree.



  

Viewing Licence Information
You can view four main aspects of licence information:
      Standard licence details, such as name, reference, total users, etc. 
      Overall department information,
      Overall user information,
      Overall product profile information. 



  

Viewing Licence Information
To view standard licence details:

1. Highlight the licence object.

2. Select the View Details option from the Licence menu, or the Details option from the View menu. 

The information window to the right of the licence tree displays the following information:
Licence Name,
Licence Reference,
Maximum Users allowable within the licence,
Current Users installed within the licence,
Status of the licence. 



  

Viewing Licence Information
To view overall information for all departments:

1. Highlight the licence object.

2. Select the View Departments option from the Licence menu, or the Departments option from the 
View menu. 

The information window to the right of the licence tree displays the following information:
All Department Names,
The Number of Users currently set in each department,
The Maximum Number of Users allowable in each department,
The Number of Profiles configured in each department.



  

Viewing Licence Information
To view overall information for all users:

1. Highlight the licence object.

2. Select the View Users option from the Licence menu, or the Users option from the View menu. 

The information window to the right of the licence tree displays the following information:
All User Names sub-divided into their respective departments,
The Unique ID numbers for each user,
The Active status of each user (entry reads N if a user is temporarily disabled),
The Profiles that are set for each user.



  

Viewing Licence Information
To view overall information for all product profiles:

1. Highlight the licence object.

2. Select the View Products option from the Licence menu, or the Products option from the View menu. 

The information window to the right of the licence tree displays the following information:
All Profile Names,
The Tel-Me Products included in each profile,
The department in which each profile is situated.



  

Viewing Department Information
You can view three main aspects of information for any department:
      Standard department details, such as name, users and profiles, 
      Departmental user information,
      Departmental product profile information. 



  

Viewing Department Information
To view standard department details:

1. Highlight the required department object.

2. Select the View Details option from the Department menu, or the Details option from the View menu. 

The information window to the right of the licence tree displays the following information:
Department Name,
Maximum Users allowable within the department,
Current Users installed within the department,
Number of Profiles defined within the department.



  

Viewing Department Information
To view departmental user information:

1. Highlight the required department object.

2. Select the View Users option from the Department menu, or the User's option from the View menu. 

The information window to the right of the licence tree displays the following information:
All User Names within the department,
The Unique ID numbers for each user,
The Active status of each user (entry reads N if a user is temporarily disabled),
The Profiles that are set for each user.



  

Viewing Department Information
To view departmental product profile information:

1. Highlight the required department object.

2. Select the View Products option from the Department menu, or the Products option from the View 
menu. 

The information window to the right of the licence tree displays the following information:
All Profile Names contained within the department,
The Tel-Me Products included in each profile,
The Department name.



  

Viewing User Information
You can view two main aspects of information for any user:
      Standard user details, such as name, ID, options status and basic profile information,
      User product profile information. 



  

Viewing User Information
To view standard user details:

1. Highlight the required user object.

2. Select the View Details option from the User menu, or the Details option from the View menu. 

The information window to the right of the licence tree displays the following information:
User Name,
Unique ID number,
Department name,
The Status of all user options,
The Profiles that are set for the user,
Any Additional Products that are set for the user.



  

Viewing User Information
To view user product profile information:

1. Highlight the required user object.

2. Select the View Products option from the User menu, or the Products option from the View menu. 

The information window to the right of the licence tree displays the following information:
All Profile Names that are set for the user,
The Tel-Me Products included in each profile,
A Breakdown of Product Availability showing which products are provided via profiles and those 

that are set as additional products.



  

Viewing Profile Information
You can view three main aspects of information for any profile:
      Standard profile details, such as name, department and products included, 
      User information showing which users are using the profile,
      Product information showing which products are included.



  

Viewing Profile Information
To view standard profile details:

1. Highlight the required profile object.

2. Select the View Details option from the Profile menu, or the Details option from the View menu. 

The information window to the right of the licence tree displays the following information:
Profile Name,
Department in which the profile is situated, 
Products contained within the profile.



  

Viewing Profile Information
To view product profile user information:

1. Highlight the required profile object.

2. Select the View Users option from the Profile menu, or the Users option from the View menu. 

The information window to the right of the licence tree displays the following information:
Department Name for each user registered with the current profile,
User Name of each user registered with the current profile,
Unique ID for each user registered with the current profile.



  

Viewing Profile Information
To view profile products information:

1. Highlight the required profile object.

2. Select the View Products option from the Profile menu, or the Products option from the View menu. 

The information window to the right of the licence tree displays the following information:
Profile Name,
The Tel-Me Products included in the profile,
The Department name.



  

Moving Users
As Tel-Me users move within your organisation, you can quickly rearrange their position within the User 
Admin licence tree. 

You can move a user with either of two methods:
      Using the mouse,
      Using the Move option.



  

Moving Users with the Mouse
To move a user with the mouse:

1. Click on and hold the required user object within the licence tree.

2. Drag the user object on to the new department object (the sheet icon displayed while dragging will 
show a + when a suitable department is reached).

3. Release the mouse button to drop the user on to the new department.

Note: When moving users to new departments all existing product profile configurations will be lost. New 
profiles, however, may be applied within the new department.



  

Moving Users with the Move Option
To move a user with the Move option:

1. Highlight the required user object within the licence tree.

2. Select the Move option from the User menu. 

3. From the subsequent dialog, highlight the required department name and click on the OK button.

Note: When moving users to new departments all existing product profile configurations will be lost. New 
profiles, however, may be applied within the new department.



  

Creating New Supervisors
To create a supervisor:

1. Create a new user in the required department (or from the licence object) or select an existing one.

2. Select the Change Supervisor Details option from the User menu. The following dialog is displayed:

Click on the required item for more information.

3. Select the required status level for the user.

4. Enter a supervisor password for the user and confirm it. 

5. Click on the OK button to enter the details into the licence tree.



Licence Object

This standard object represents the main licence for your Tel-Me installation. All departments, users and 
profiles emanate from this object.

By double-clicking on the minus box to the right of the blue square, the immediate contents of the 
licence can be temporarily hidden to help simplify complex licence trees. The box changes to a plus and 
double-clicking again will reveal the licence contents.

This object cannot be deleted or changed within Tel-Me User Admin.



All Products Profile Object 

This is the standard profile which is created as a default in every Tel-Me licence. As its name suggests, 
this profile contains all of the standard range of Tel-Me products. This profile can be quickly applied to 
any users in any departments to allow them to use all Tel-Me products.

The All Products profile can be altered to suit requirements, replaced or deleted altogether if necessary. 



Initial User Object 

This standard user object is created as a default in every Tel-Me licence. The Initial User object has full 
licence supervisor privileges and is used to create the inaugural organisation configuration.

This object cannot be deleted or changed within Tel-Me User Admin.



Department Object

This is a department object, in this case created for the Sales Department, that then allows users and 
profiles to be added within. All department objects are signified by the yellow square button.

By double-clicking on the minus box to the right of the yellow square, the contents of the department can 
be temporarily hidden to help simplify complex licence trees. The box changes to a plus and double-
clicking again will reveal the department contents.



Departmental Profile

This is a profile that has been created within a department. This profile can then be applied, if necessary, 
to any users within the same department.



User Object

This is a user that has been added to a department. Users can be altered and moved to other directories 
at any time. Users may also be created directly from the Licence Object without belonging to a particular 
department. 



Information Window

This area provides various details about the currently selected object in the licence tree depending on 
which display mode is selected in the View menu. 



View Only Mode

The view only mode allows you to view the layout and details of the chosen Tel-Me configuration, 
however, you are prevented from making any alterations.

Using this method to merely view the configuration is preferable as other supervisors will not be locked 
out as a result.



Unique ID Number

A unique code that identifies a particular Tel-Me user. This is the number required to enter Tel-Me User 
Admin and to use the Tel-Me package itself. 

For multi-user licences the supervisor uses the first Unique ID within Tel-Me User Admin to create more 
Unique IDs for other users in the organisation. 



Supervisor Password

This password when used in conjunction with the Unique ID obtains full supervisor privileges within the 
Tel-Me User Admin program.



Changing Passwords

If you are using Tel-Me User Admin for the first time it is highly advisable to change both the standard 
and supervisor passwords that are supplied with the Unique ID number.

To change the standard password (can also be changed in the Tel-Me product):

1. Highlight the Initial User object from the Tel-Me User Admin licence tree.

2. Select the Change User Details option from the User menu and enter the new password into the 
Password and Confirm Password fields of the subsequent dialog.

3. Click on the OK button to enter the details into the licence tree. 

To change the supervisor password:

1. Highlight the Initial User object from the Tel-Me User Admin licence tree.

2. Select the Change Supervisor Details option from the User menu and enter the new password into 
the Supervisor Password and Confirm Password fields of the subsequent dialog.

3. Click on the OK button to enter the details into the licence tree.



Confirm Remove Actions

If the Confirm Remove Actions option in the File menu is ticked then all remove operations will cause a 
warning dialog to be displayed before the required object is deleted.



Licence Name

This entry displays the configured licence name and cannot be altered within Tel-Me User Admin.



Department Name 

Enter a name to describe the new department.



User Name

Enter the name of the new user.



Password

Enter a password for the user. For security reasons the entered characters are not echoed on the 
screen and instead an asterisk is displayed to represent each character entry. The Confirm Password 
field then allows you to double check the correct entry of the password.



Confirm Password

Re-enter the password to confirm that it was correctly entered in the Password field. 



User temporarily disabled

When checked, this option prevents the current user from accessing the Tel-Me system. This option 
would be used prior to moving the user or making other significant changes to their account.



Use default settings

Click this button if any option settings have been changed and you wish to apply the default 
configuration set. 



Disable on-line updating

When this option is checked, the user is prevented from carrying out any on-line updating of the Tel-Me 
products.



Disable EMail name change

When this option is checked, the user is prevented from changing their EMail name.



Maximum Users

The department Maximum Users entry should be set so that the total number of users in all departments 
does not exceed the Maximum Users entry for the Licence Supervisor. A warning dialog will be 
displayed if the number of users exceeds the main Maximum Users entry. 



User can change password

When this option is checked, users within the new department are given the option to change their 
passwords.



Always ask user password

When this option is checked, users within the new department will be prompted to enter their passwords 
whenever Tel-Me is started.



Lock user's screen after idle period

When this option is checked, each user's Tel-Me screen within the department will be locked after a 
period of inactivity. When a Tel-Me screen locks, a dialog is displayed to request the password before 
further operation can continue.

Refer to the section Tel-Me and Screen Savers in this help file for more information about the interaction 
of the Tel-Me password lock and Windows Screen Savers.



Licence Supervisor Option

Grants Licence Supervisor privileges to the user with the ability to add, change and delete all users and 
departments. A password must be entered when this option is selected.



Department Supervisor Option

Grants Department Supervisor privileges to the user with the ability to add, change and delete users 
within the current department only. A password must be entered when this option is selected.



Normal User Option

Selects normal user status with no special supervisor privileges. No password is required when 
selecting this option. 



Exit Program Button

Exits from the dialog and the Tel-Me User Admin program.



OK

Exits from the dialog and enters the information into the licence tree.



Cancel 

Exits from the dialog and discards the entered information. 




