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Recording and Playing    Back

To record a song:

1.    Click on the RECORD button 

2.    Sit as close to the computers microphone as possible and play the song.
NOTE:    All background noise will be recorded also.    Try to play in a quiet environment because any 
extra noise will detract from the sound quality.

3.    When you are finished playing the song, click on STOP. 
4.    You can choose the quality of the recording by selecting Low, Medium, or High from the Options 
menu. 

NOTE:    You may have to make adjustments to the microphone input level using the software 
supplied with your particular sound card.    Please consult the documentation that came with your 
sound card if you think that the recorded sound is too low.    Also, you may use the Set Volume 
Options menu item to adjust the sound output level.

To play back your most recent recording:

1.    Click on the PLAY button. 

The entire song will play.

2.    Click on the STOP button     if you want to stop or pause the playback.
NOTE:    The STOP button is only visible when you are recording or playing a song.    When the song 
is stopped you may move forward or backward by clicking on the scrollbar with the mouse and 
dragging it forward or backward.

To save a recording:

1.    From the File menu choose Save Recording As...

You will be prompted for a file name.

2.    Type a name in the File Name box, optionally including the complete path and file name using 
the '.WAV' extension.

3.    Choose the OK button.

The recording is saved to disk for later loading and playback.

To play back a song you recorded earlier:

1.    From the File menu choose Load Recording....

NOTE: Any currently recorded song will be lost by loading a new song.

See below for directions on saving if you would like to keep the current song.

2.    In the File Name box, type or select the name of the recording you want to load.    If you don't see 
the recording you want to load, select a new drive or directory. 

3.    Choose the OK button. The recording is loaded and ready to play.

To hear the song, press the play button. 



Navigating through the System

To get to the previous or next lesson:

1.    Click on the left or right arrow in the bottom right corner of your screen to move to the previous or 
next lesson.

OR
1.    Type the left or right arrow key on your keyboard to move to the previous or next lesson.

NOTE:    This won't work if any button on the screen is highlighted.    If the arrow keys don't appear to 
be working, use the tab key on the keyboard deselect the buttons.

Using the Goto menu to jump to a specific lesson, technique, or song.



Using the Button Symbols

Chord Chart Hot Spots

Wherever they appear, chord charts may be clicked to hear the chord they represent.

The Video Button 
Wherever it appears, the video button can be clicked to play a movie relating to the current lesson. 

To stop video playback, click the STOP button     on the video frame

NOTE: When the song is playing you can move forward or backward by clicking on the scrollbar with the 
mouse and dragging it forward or backward.

The Comment Button 
Wherever it appears, the mouth button can be clicked to listen to the guitar instructors comments or 
tips relating to the current lesson. To stop audio playback, click elsewhere in the window or press the 
escape key or the spacebar.

The Speaker Button 
Wherever it appears, the speaker button can be click to play the current lesson's song. To stop audio 
playback, click elsewhere in the window or press the escape key or the spacebar. 

The Arrow Buttons 

These two buttons located in the lower right corner of the window are used to navigate forwards and 
backwards through the lessons.

More information about navigation.

Record and Playback Buttons

Clicking the Buttons using the Keyboard 

Buttons can be accessed using the keyboard by pushing the tab key until the desired button is 
highlighted and then pushing the spacebar to click the button.



File

File menu
Load Recording
Save Recording
Print Screen



Load Recording

Use the Load Recording File menu option to load a previously saved recording to be played back.

1.    From the File menu choose Load Recording.

NOTE: Any currently recorded song will be lost by loading a new song. See Save Recording As... for 
directions on saving if you would like to keep the current song.

2.    In the File Name box, type or select the name of the recording you want to load. If you don't see 
the recording you want to load, select a new drive or directory. 

3.    Choose the OK button.    The recording is loaded and ready to play.

To hear the song, press the play button. 



Save Recording

Use the Save Recording File menu option to save the current recording to a file on your disk.

1.    From the File menu, choose Save Recording.

2.    Type a name in the File Name box, optionally including the complete path and file name using 
the '.WAV' extension.

3.    Choose the OK button.

The recording is saved to disk for later loading and playback.

4.    You can choose the quality of the recording by selecting Low, Medium, or High from the Options 
menu. 



Path - Information you type to find or point to a file or other information.    For example, you might 
type C:\JOE\GTRSONGS\BLUES\MY_BLUES.WAV to specify the drive name, directory name, and 
file name for a file of type "WAV".



Print Screen

Use the Print Screen File menu option to print the current lesson on your printer.

1.    Choose Print Screen from the File menu.

The current lesson screen will be printed to the current Windows printer.

NOTE:    If you have printing problems, please consult the documentation that came with your printer.



Options

Options menu
Set Volume
Music Tracking
Set Recording Quality
Song Notation



Set Recording Quality
Use the Set Recording Quality Options menu item to choose the quality of your recordings

1.    Select Set Recording Quality from the Options menu

A pop-up menu will appear.

2.    Choose Low, Medium or High.    This sets the size of the samples and the number of samples per 
second. 

Low sets the default quality to be 8 bits/11 Khz.

 Medium sets the default quality to be 8 bits/22 Khz

High sets the default quality to be 16 bits/22 Khz

A check mark will appear next to the chosen option.

The recording quality is now set to the new level.

NOTE:    Setting the recording quality to high will result in better recordings on most soundcards, but 
the saved files will take up more space on the disk.    Likewise, setting recording quality to Low will 
save space on disk, but the recordings will be poorer.



Music Tracking

Use the Music Tracking Options menu item to turn off and on the colored highlighting that tracks 
songs as they are played back. Note that only long songs have music tracking. Short exercises 
which are easy to follow do not have music tracking.

1.    Select Music Tracking from the Options menu.
A submenu with On and Off appears, allowing you to turn Music Tracking on or off.



Song Notation

Use the Song Notation Options menu item to display songs in either Tablature or Music Notation. 
The default setting is Tablature and music notation is only available for songs. Short, simple 
exercises are presented only in tablature.

1.    Select Song Notation from the Options menu.

A submenu with Tablature and Music Notation will appear, allowing you to choose the one you 
desire.



Set Volume

Use the Set Volume Options menu item to set your computer's sound output level.

1.    Select Set Volume from the Options menu.

A pop-up menu will appear.

2.    Choose the number value corresponding to the sound level desired.

A beep will sound in the chosen sound level.

The volume is now set to the new output level.



Goto

The Goto menu gives you three ways to jump directly to a specific lesson without having to 
navigate through each lesson in between.

Goto menu

Lesson...

Song...

Technique...



Goto Lesson...

To move to a specific lesson:

1.    Select Lesson... from the Goto menu.

A window will appear with a list of lessons.

2.    Scroll down until you find the lesson you want.

3.    Click on the lesson name.

4.    Click OK.

The lesson you selected will appear.



Goto Song...

To move to a specific song:

1.    Select Song... from the Goto menu.

A window will appear with a list of songs.

2.    Scroll down until you find the song you want.

3.    Click on the song name.

4.    Click OK.

The lesson corresponding to the song you selected will appear.



Goto Technique...

To move to a specific technique:

1.    Select Technique... from the Goto menu.

A window will appear with a list of techniques.

2.    Scroll down until you find the technique you want.

3.    Click on the technique name.

4.    Click OK.

The lesson corresponding to the technique you selected will appear.



Tuner

Using the Guitar Tuner

(See Lesson v - Tuning the Guitar)

Use the Goto menu to access Lesson v.



Metronome

Using the Metronome Tool

(See Lesson vii - Using the Metronome)

Use the Goto menu to access Lesson vii.



Chords and the Chord Dictionary

A note on chord notation equivalents 

Sometimes chords found in The On-Line Guitar Archives or elsewhere are written using a different 
notation.    If you can't find the chord you are looking for in the Chord Dictionary, check the following 
chart:

Symbol Equivalent Example

o dim Ao      =   Adim *
o7 dim7 Ao7     =   Adim(7)

dim7 dim(7) Adim7   =   Adim(7)

+ aug A+      =   Aaug

- m A-      =   Amin

M maj AM7     =   Amaj7

major maj Amajor7 =   Amaj7

* NOTE: In nearly all cases, a 'dim(7)' chord can be used in place of a 'dim' chord.

Also, 'dim' stands for a diminished chord.    'dim7' stands for a diminished 7 chord.    'aug' stands 
for an augmented chord.    'maj' stands for a major chord. 'maj7' stands for a major 7 chord.    'min' 
stands for a minor chord.    'min 7' stands for a minor 7 chord.

In addition, diminished chords can be moved up in increments of three frets and still be the same 
chord. Likewise, augmented chords can be moved up in increments of four frets. 

Using the Chord Dictionary

Sometimes when you are learning songs from song books or The On-Line Guitar Archives, you 
come across unfamiliar chords.    The Chord Dictionary is a reference containing over 900 chords.    
Choose the chord you are looking for by name, and the Chord Dictionary will display the 
corresponding chord charts for three different voicings of the same chord, each of which can by 
played by clicking on the respective chord chart or audio button underneath.

The first time you click on the Chord menu, the A chord will automatically show up.    After that, the 
most recent chord you looked at appears.    You can navigate throughout the program and the chord 
window will remain in the upper right corner until you close it.

To select a chord:

1.    Click on the Chord menu.

The Chord window will display chord A (or most recently chosen chord).

2.    Click on the arrow next to the chord name.

A drop down menu of chord names will appear.

3.    Use the scroll bar to locate the chord you want to see.

Clicking the name will hide the drop down menu and display the chord chart.

NOTE:    You may type in the chord name in the Chord window before step two to aid in finding the 
particular chord variation.

To hear a chord:

1.    Click on the chord chart.

The currently selected chord will play.



To close the Chord window:

1.    Click on the box in the upper left corner of the Chord window.

2.    Click on CLOSE.

See also

Lesson vi - Reading Chord Charts

Use the Goto menu to access Lesson vi.



Root - The note from which a chord is built.    For example, the root of the A minor chord is the note 
A.    Conventionally, the root of the chord carries the lowest pitch of the chord being played.



Glossary

Musical terms used in eMedia Guitar Method:

Accent Special stress given to a note within a phrase.

Accidental A sign placed before a note to alter its pitch, usually by a semi-tone; see Sharp, 
Flat and Natural.

Adagio Indication that the music should be played at a speed not as slow as larghetto. 66 
- 76 ticks per minute.

Aeolian mode One of the traditional Greek modes, comprised of the white keys from A to A on 
the piano: a, b, c, d, e, f, g;    mode on which modern minor scale is based.

Allegro Lively, or happy.    Often used to indicate a fast piece, but not as fast as presto. 
120 - 168 ticks per minute.

Alternate bass note Secondary bass note of a chord, usually the fifth or third, and often sounded on 
the weak beat of the measure.

Andante Indication of tempo (at a walking pace).    76 - 108 ticks per minute.

Arpeggio Notes of a chord sounded in succession rather than simultaneously. On the 
guitar arpeggio patterns are often combinations of notes in ascending or 
descending order. 

 
Barre chord A chord in which the first finger of the left hand covers several strings in one 

position, often 5 or 6 though there are 3-and 4-string barres as well; these are 
distinct from 'open'    or first position chords in which open string are sounded. 
Chord shapes created by barres are moveable.

  
Bass strum Technique that involves striking the bass note of a chord, then strumming the 

chord.

Bass walk A series of notes in the bass register, often one measure long, that connect two 
chords. 

Bend Method of changing the pitch of a note by displacing the guitar string; 
done by pushing or pulling the string perpendicular to the frets.

Blues rhythm A rhythm characterized by a three-note division of of the primary beat where the 
first and third of this division are usually sounded creating the characteristic 
'shuffle' rhythm of the blues.

Bottleneck slide A glass or metal tube worn around the 3rd finger of the left    hand; used instead 
of the fingers to play notes on the guitar by touching the strings rather than 
depressing them.

Bridge Section of a song, often linking the chorus to the verse.



Capo Another word for "barre;" with guitar the term usually implies the mechanical 
device attached to the neck of the instrument to shorten the vibrating length of 
the string.

Chord A combination of three or more tones sounded simultaneously.

Chord chart A standard notation used to represent chord fingerings on the fretboard of a 
guitar. (See Lesson vi - "Reading Chord Charts.")

Closed position As opposed to open position, which includes open strings, closed implies the use 
of no open strings in the use of scales or barre chords.

 
Coda Literally, the "tail" or ending; the section that ends the piece of music.

Diatonic scale A scale built on eight tones.

Double-stop Two strings on the guitar played at once.

Fermata A symbol signifying that a note should be held longer than its notated rhythmic 
value.

Flat Symbol placed before a note, indicating pitch is to be lowered one semi-tone, or 
half-step (one fret).

Grace note A note usually played before the beat; written with a slash through its stem to 
indicate it does not figure into the time value.

Harmonized bass walk A bass walk in which two notes are struck simultaneously, the higher 
note harmonizing with the bass note.

Hammer-on A slur, accomplished by playing a single note and then sounding a higher note by 
hammering onto it with a left-hand finger.

Harmonics A bell-like sound accomplished by lightly touching (not depressing) a string 
directly above a fret then plucking it normally; harmonics are most easily created 
at the 5th, 7th and 12th frets, where they are called natural harmonics.

 
Key signature Found at the beginning of a piece of music and indicated by the number of 

sharps or flats; no sharps or flats indicates the key of either C major or A minor. 

Larghetto Indication that the music should be played at a tempo not quite so slow as largo. 
60 - 66 ticks per minute.

Largo Indication that the music should be played slowly, in a broad manner.    40 - 60 
ticks per minute.

Ledger line Line added above or below the staff as needed, to extend the tonal range of the 
staff.



Lento Indicates to play at a slow tempo.

Lick Guitarist's slang for a short, melodic passage.

Major scale One of the two scales upon which most Western music is based; characterized 
by succession of notes in the ascending sequence: w, w, 1/2, w, w, w, 1/2    (w= 
whole step or two frets, 1/2 = half step or one fret) (See Appendix B, Lesson B2.)

Measures Sections with equal numbers of beats.

Melody A rhythmically organized sequence of single tones so related to one another as to 
make up a particular musical phrase or idea.

Metronome A device that marks time at a steady beat in adjustable intervals, to help keep a 
steady beat while playing music.

Minor scale One of the two scales upon which most Western music is based; of the three 
forms of the minor scale, the natural minor is the most common in popular music 
and is defined by the succession of notes in the ascending order: w, 1/2, w, w, 
1/2, w, w. (See Appendix B, Lesson B4.)

 

Moderato Moderate, as in a moderate speed tempo.    108 - 120 ticks per minute.

Muffled strings Deadened strings where no pitched sound is heard, created by either releasing 
pressure with the left hand and letting the fingers lay loosely across the strings or 
by placing the left hand palm on the strings while continuing to pluck the strings; 
the technique creates a percussive sound.

Natural Symbol Placed before a sharped or flatted note and indicates the note is returned to its 
original pitch.

N.C. "No Chord;" indicates no chord is to be played.

Octave The distance from any note up through the following seven diatonic notes    (i.e.: 
from A to A, C to C, etc.).

Open position Describes a chord or scale in which open strings are used.

Open string String that is sounded without being held down with the left hand.

Palm muting Technique in which the palm of the right hand is laid on the strings just ahead of 
the saddle, so that the strings are slightly muted; this is different than muffling 
where the strings are deadened.

Pattern picking Fingerpicking style in which a repeating right-hand melodic pattern is picked 
throughout the song; typically used for accompaniment.

Pentatonic scale Scale built on five tones between the octave.

Power chord Chord in which only the lower two or three strings of a barre form are played; 



creates a 'chord' that has only the root and fifth of a chord, omitting the third, and 
thus is often indicated in music by a "5": E5 or C5, for example.

Prestissimo Very fast indeed.    Faster than presto.    200 - 208 ticks per minute.

Presto Fast.    Indication that the music be played at a fast tempo.    168 - 200 ticks per 
minute.

Pull-off Slur technique accomplished by playing a fretted note, then pulling off that note 
to either an open string or another fretted note.

Reference notes Properly tuned notes used to tune another instrument by comparison.

Repeat sign Symbol that indicates a section of music is to be repeated.

Rhythm A regular pattern formed by a series of notes of differing duration and stress.

Riff Guitarist's slang for a short, melodic passage.

Root The note from which a chord is built.    For example, the root of the A minor chord 
is the A note.

Semi-tone One half-step; equal to one fret's distance on the fretboard.

Sextuplet Six notes beamed together; equal to one quarter note.

Sharp Symbol placed before a note, indicating pitch is to be raised one semi-
tone, or half-step (one fret).

Shuffle rhythm Rhythm in which the beat is subdivided into threes and the first and third of that 
division is played; distinguished from straight rhythm which uses even or equal 
subdivision of the beat; most blues music uses shuffle rhythm.

Slash chord A chord to which a bass note different from the usual tonic has been added and 
indicated by a slash between two letters: D/B indicates to play a D chord with a B 
bass note.

Slide Slur technique in which a note is played, and the left-hand finger then 
slides to a new note.

Slur In guitar music the slur indicates a group of notes to be played with a 
single attack of the right hand and the remaining notes sounded by the left either 
by the use of hammer-ons, pull-offs or slides and occasionally bends; this 
technique is indicated by a curved line over the notes and results in a smooth, 
connected sound.

 
Staff Consists of five horizontal lines, and the four spaces between the lines; 

the notes are placed on or between the lines.

Straight rhythm A rhythm characterized by even or equal subdivision of the beat; as distinguished 



from shuffle rhythm often found in the blues.
 
Sustained notes Notes held for a long duration.

Syncopation Shifting the beat away from its usual placement and occurring just ahead or 
behind the written or implied beat.

Tablature Method of notating guitar music; six horizontal lines signify each string, and 
numbers indicate which fret to hold down.

Tacet Literally, silence; indicates a short period of silence in music.

Tempo Rate of speed at which music is played.

Time signature A sign at the beginning of a piece of music which indicates the organization of 
time and pulse; two numbers are given, the top indicates the number of units in 
each measure and the bottom indicates the note that gets the beat. (See 
Appendix A, Lessons A5-A8.)

  
Travis-style picking Style of fingerpicking which involves the thumb alternating back and forth 

between two bass strings while the fingers play notes either on or off the beat.

Trill Musical ornament consisting of a rapid alternation of a note with other 
notes a tone or semi-tone above or below; on guitar this is done with rapid 
hammer-ons and pull-offs.

Triplet A group of three notes to be played in the time of two, in 4/4 time a triplet would 
be equal to one quarter note beat; the three notes of a triplet are beamed 
together and have a 3 place above or below the beam.

 
12-bar blues A typical blues chord progression (See Lesson 13.)

Vibrato Rapid wavering of a pitch produced by rocking a left-hand finger in place on a 
string.

Whole tone One whole step; equal to the distance of two frets on the guitar.




