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Using Macintosh files with Windows applications

Files you want to open on the PC should be saved from the Macintosh in a suitable PC format. For 
example, with Microsoft Word you should save from the Macintosh in Word for Windows format.

If your Macintosh program cannot save files in a suitable PC format you should use a standard 
interchange format, as shown in the following table, which almost all PC and Macintosh applications 
support:

To save this Choose this format

Text or data Plain text (ASCII), Rich Text Format (RTF), or Comma Separated Values 
(CSV).

Bitmapped graphics TIFF graphics format.

Illustrations Encapsulated PostScript (EPS).

You can usually exchange files between versions of the same application running on the Macintosh and 
on the PC.

Note that because Macintosh filenames do not usually have extensions, it may not be obvious to your 
application what type of file each file is.

For example, a Microsoft Word document saved from the Macintosh on to a Macintosh disk may not have 
a .DOC extension, and will therefore not be recognized.



Opening files from a Macintosh disk

MacDisk allows you to open files on Macintosh disks from within Windows applications.

To open a file from a Macintosh disk

u Choose Open... from the applications File menu.

The applications Open File dialog box appears:

u Choose the drive containing the Macintosh disk from the Drives box.

u Locate the file you want to open.

u Choose OK to open it.

See also:
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Seeing Macintosh files

Because Macintosh filenames do not usually have extensions, it may not be obvious to your application 
what type of file each file is.

To see all files on the disk or in a directory

u Choose All Files (*.*) from the List Files of Type drop-down list box in the Open dialog box.



Saving files to a Macintosh disk

u Choose Save... or Save As... from the applications File menu.

The applications Save or Save As dialog box appears. For example:

u Choose the drive your Macintosh disk is in and enter a name for the file you are saving.

The name should be a valid MS-DOS filename.

u Click OK.



Listing the contents of a Macintosh disk

MacDisk allows you to see a list of the files on a Macintosh disk.

To list the files on a Macintosh disk

u Insert the disk into the floppy disk drive A: or B:.

u Open the MacDisk group in the Program Manager.

u Double-click the MacDisk icon.

The MacDisk window will show a list of the files on the disk.

For example:

If you have two 3.5" drives, select the drive you want to use by choosing Select A: or Select B: from the 
Disk menu, or click the appropriate disk icon below the menu bar.

Click the disk icon to re-list the files.

See also:
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Searching for files in a Macintosh directory

u Choose List... from the File menu. This dialog box shows a list of directories on the Macintosh disk:

u Double-click a directory name to open it and show its subdirectories.

u Choose OK to list the files in the directory you have chosen.



Choosing how files are displayed

You can choose how the files are listed in the MacDisk window using the options on the View menu.

u Choose Sort by PC Name or Sort by Mac Name to determine the order in which files and directories 
are listed.

u Choose Display PC Name First or Display Mac Name First to determine which name is shown first 
in the window.



Choosing what details are shown

The MacDisk window displays the list of files on a disk under headings explaining what is in each 
column.

It also includes a two-line summary at the bottom of the window showing the number of files in the 
currently displayed disk or folder, the number of bytes occupied by these items, the name of the disk, and 
the number of bytes free space it contains.

You can choose whether or not each of these is displayed using these commands on the Options menu:

u Choose Headings to turn off or on the headings. 

u Choose Summary to turn off or on the summary. 

When either option is on, a tick appears next to the option in the menu.



Making resource forks available

By default, MacDisk makes the resource forks of Macintosh disks invisible, as they are not usually of 
relevance to PC work. However, you can make resource forks visible if you need to use them.

To display resource forks

u Choose Configuration... from the MacDisk Options menu. This dialog box appears:

u Choose Visible to see the resource forks, or Invisible to hide them.

If you choose Visible, the resource forks will be displayed in a subdirectory called RESOURCE.FRK.

u Click OK to confirm your choice and exit from the dialog box, or Cancel to leave the settings 
unchanged.



Formatting disks

MacDisk allows you to format disks in Macintosh format.

To format a disk

u Insert the disk you want to format into the floppy drive.

u Choose Format... from the Disk menu. This dialog box appears:

u Check that the correct drive, A: or B:, is selected in the dialog box.

If you have only one 3.5" drive the other drive will be grayed out.

u Enter a name for the disk in the box marked Disk label.

This can contain up to 27 characters which can be any combination of letters, spaces, and punctuation 
marks.

u Select Quick format to re-initialize a disk that has already been formatted in the high-density format. 
WARNING: All data on the disk will be lost.

u Click Format to format the disk, or Cancel to abandon the operation.

A warning box reminds you if you have not inserted a disk into the drive.

u Click OK to confirm the format, or Cancel to abandon it.

This dialog box informs you of the progress of the format:

u Click on the Abort button to abandon the format at any point.

A dialog box informs you when the format is complete.



u Click OK.

 The newly formatted disk is now ready to use.



The MacDisk menus

File menu

Options menu

Disk menu

View menu



File menu

The commands on the File menu allow you to list the contents of a Macintosh disk, or exit from MacDisk.

List...

Lists the contents of the Macintosh disk.

Exit

Exits from MacDisk.



Options menu

The commands on the Options menu allow you to change the operation of MacDisk.

Configuration...

Allows you to make resource forks visible if you need to use them.

u Choose Configuration... from the MacDisk Options menu. This dialog box appears:

u Choose Visible to see the resource forks, or Invisible to hide them.

If you choose Visible, the resource forks will be displayed in a subdirectory called RESOURCE.FRK.

u Click OK to confirm your choice and exit from the dialog box, or Cancel to leave the settings 
unchanged.

Headings

The headings explain what is in each column in the MacDisk window.

u Choose Headings to turn off or on the headings. 

When the option is on, a tick appears next to the option in the menu.

Summary

The summary at the bottom of the window shows the number of files in the currently displayed disk or 
folder, the number of bytes occupied by these items, the name of the disk, and the number of bytes free 
space it contains.

u Choose Summary to turn off or on the summary. 

When the option is on, a tick appears next to the option in the menu.



Disk menu

The commands on the Disk menu allow you to format a disk, and select whether you want to use the A: 
or B: drive.

Format...

Allows you to format a disk in Macintosh format.

This dialog box appears:

u Check that the correct drive, A: or B:, is selected in the dialog box.

If you have only one 3.5" drive the other drive will be grayed out.

u Enter a name for the disk in the box marked Disk label.

This can contain up to 27 characters which can be any combination of letters, spaces, and punctuation 
marks.

u Click Format to format the disk, or Cancel to abandon the operation.

A warning box reminds you if you have not inserted a disk into the drive.

u Click OK to confirm the format, or Cancel to abandon it.

This dialog box informs you of the progress of the format:

u Click on the Abort button to abandon the format at any point.

A dialog box informs you when the format is complete.

u Click OK.

 The newly formatted disk is now ready to use.

Select A:

Selects the A: drive

Select B:



Selects the B: drive.



View menu

The options on the View menu allow you to choose how the files are listed in the MacDisk window.

Sort by PC Name

Sort by Mac Name

Determine the order in which files and directories are listed.

Display PC Name First 

Display Mac Name First 

Determine which name is shown first in the window.



Macintosh disks

This section gives technical information about the Macintosh disk formats, MacDisk's filename translation, 
and the special information stored on Macintosh disks.
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Macintosh disk formats

All current Macintosh computers, and most Macintosh computers sold since 1989, support a high density 
1.44 Mbyte format which is compatible with PC drives. This is the format supported by MacDisk.

The Macintosh recognizes high density disks by the extra hole opposite the write-protect tab:

When using MacDisk to format disks in Macintosh format you must use only high-density disks, with the 
extra hole; otherwise they will not be recognized as a formatted disk by a Macintosh.

Other Macintosh formats

Current Macintosh computers also provide an 800 Kbyte format, which uses low-density disks. This 
format is not compatible with PC drives, and so MacDisk cannot read Macintosh disks in this format.

The following early Macintosh models use an obsolete 400 Kbyte format: Macintosh 128K, Macintosh 
512K, Macintosh 512 XE. This format cannot be used with MacDisk.

Other PC drives

MacDisk works with a high-density 3.5" drive, as fitted to most current PCs. Some older PCs and portable 
PCs have only low-density (720 Kbyte) 3.5" drives, or 5.25" drives, and these PCs are not compatible with 
MacDisk unless upgraded with a high-density 3.5" drive.



Translating filenames

The Macintosh operating system and MS-DOS use different conventions for naming files, summarized in 
the following table:

Macintosh filenames MS-DOS filenames

Up to 32 characters. Up to 8 characters, followed by an optional extension consisting of a 
period and up to three more characters.

May contain any May contain only the letters A-Z, the 
characters except: (colon). numbers 0-9, extended characters (eg é and ü), and the symbols :

_^$~!#%&-{}()@'`

MacDisk automatically translates Macintosh filenames so that they appear to MS-DOS as valid filenames. 
The translation not only ensures that every Macintosh file gets a different MS-DOS name, but is also 
designed so that the MS-DOS names stay the same even if files are added to or deleted from the disk. 
The Macintosh filenames are unaltered.

The following table shows how various Macintosh filenames are translated by MacDisk:

This Macintosh name Is translated to

A valid MS-DOS filename; The same name, 
eg GOOD.EXT. GOOD.EXT.

A name of more than The name truncated to 7 characters,
8 characters; eg followed by !, with a unique 3 
REORGANIZATION. character extension; eg REORGAN!.00K.

A name containing spaces The name with illegal characters
or illegal characters; eg replaced by !, and a unique 3
READ ME*. character extension; eg 

READ!ME!.00L.



Special directories on Macintosh disks

MacDisk may show some special directories on Macintosh disks. These correspond to folders and 
information used by the Macintosh operating system.

The DESKTOP! directory

Files that the Macintosh user has moved from the disks window on to the desktop are stored in a special 
directory on the disk called DESKTOP!.xxx, where xxx is a unique 3-character extension. You can access 
this directory via MacDisk and store files in it just like any other directory, but when the disk is returned to 
the Macintosh the files will appear on the desktop rather than the disks window.

The TRASH directory

Files dragged into the Trash from a Macintosh disk are stored in a directory called TRASH until the Trash 
is emptied. You can access these files from the PC.

Note that deleting files from a Macintosh disk on the PC will remove them completely. If you want to put 
them in the Trash for the Macintosh user, move them to the TRASH directory.

The RESOURCE.FRK directory

Macintosh files can consist of two parts; a data fork and a resource forks. The resource forks usually 
contains information used by Macintosh applications, and so is usually not relevant to PC applications.

MacDisk includes an option to give access to the resource forks of each Macintosh file. If this option is 
selected, the resource forks are stored in a directory RESOURCE.FRK, in the directory containing the file.



Types and creators

On the Macintosh each application is identified by a unique four-character code, called a creator 
signature. Likewise, each document has a creator, to identify the application that created it, and a type, to 
identify the type of file.

MS-DOS files copied to a Macintosh disk, using MacDisk, are given the type TEXT and the creator 
MACD. If you double-click them on a Macintosh you will be given the option of opening them with 
TeachText. Alternatively you can open them from any application that can read plain text files.



Glossary

Creator

Data fork

Desktop file

Desktop Folder

FDHD SuperDrive

Folder

Initializing

Resource fork

TRASH

Type

Wildcard



Creator

A four character code which identifies the application associated with each file on the Macintosh. The 
creator application provides icons for each type of document it recognizes. Files saved on Macintosh 
disks using MacDisk have creator MACD.



Data fork

The section of a Macintosh file which contains the data; eg the text in a word-processing document.



Desktop file

A special file, invisible to Macintosh users, which contains information about the contents of a disk and 
the way they are displayed.



Desktop folder

A directory on Macintosh disks which contains any files the user has moved onto the desktop.



FDHD SuperDrive

The dual-format Macintosh floppy disk drive which supports the 1.44 Mbyte disk format used by MacDisk.



Folder

The Macintosh name for a directory.



Initializing

The process of copying a filing system on to a disk so that it can be used for storing files.



Resource fork

An additional section of a Macintosh file which can contain information used by the Macintosh operating 
system and Macintosh applications.



TRASH

A directory on Macintosh disks which contains any files the user has moved to the Trash, before it is 
emptied.



Type

A four character code which identifies the type of document created by an application on the Macintosh. 
Files saved on Macintosh disks using MacDisk have type TEXT.



Wildcard

A special character you can include in MS-DOS filenames to match a set of files: * matches any 
sequence of characters and ? matches any single character.




