
Welcome to NewsMonger™

Welcome to NewsMonger™. You have chosen a unique Internet newsgroup search aid 
that will save countless hours in repetitious work. NewsMonger can be set up to constantly 
monitor the Internet’s largest source of new information, the USENET Newsgroups. 

NEW FEATURE: You can now search any news server your computer can access. This 
can help you find information directly from the news servers you use most frequently.

This Help file is designed to get you started with NewsMonger quickly. In just a few 
minutes, you’ll understand how NewsMonger can be used to do work for you while you 
concentrate on other things. Click on one of the subjects below to get the overview picture 
of NewsMonger!
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NewsMonger is created by TechSmith Corporation. TechSmith also sells SnagIt®, the most powerful Windows screen capture 
utility.

    NOTE:

Clicking on the link to TechSmith above will start your Web browser. If you have more than one browser on your system, you 
may be asked which one you want to use.



USENET Newsgroups

USENET is a facet of the Internet which allows public notices to rapidly travel around the world. Anybody with Internet access 
can both read these messages and post their own message. Certain categories, called newsgroups, exist on virtually every 
imaginable subject. These newsgroups are maintained on various news servers throughout the Internet which you can access 
from your news browser. In fact, your Internet Service Provider (ISP) probably maintains a news server with a wide range of 
newsgroups. If you do not know the address of your news server, ask your system administrator.



What is the USENET?

While web (WWW) sites have received most of the attention from software developers and the press, the Internet’s news and 
conferencing service, USENET, represents another major Internet resource. USENET is based on newsgroups, such as 
comp.client-server or misc.education.adult, that contain postings similar to e-mail messages. These postings contain the very 
latest information about what is happening in the world, with emphasis on computing and the Internet.

Some USENET newsgroups subject postings to a screening prior to publication; others automatically distribute all submissions. 
Worldwide, over a gigabyte of information is posted each day to over 15,000 newsgroups. Because of the massive storage 
requirements, individual messages may disappear a few days after publication.

Standalone news client software (news browsers) are available from several sources. News readers are also built into 
Netscape’s Navigator and Microsoft’s Internet Explorer. As users of these web browsers become more experienced, they are 
able to “graduate” to the world of USENET news by clicking a button within the web browser.

For an in-depth description, see http://www.ou.edu/research/electron/internet/zen-4.htm 

    NOTE:

Clicking on the link above will start your Web browser. If you have more than one browser on your system, you may be asked 
which one you want to use.



Why would this information interest me?

Newsgroups exist for virtually every conceivable professional and personal interest. Some newsgroups serve as problem-solving 
forums and as the “help desks” of the Internet. Most newsgroups are public and can be viewed anywhere the Internet reaches. 
Anyone with a news client (news browser) and an Internet connection can submit a posting and view responses.

Your company or product may be mentioned on the USENET! If it currently is not being mentioned in these messages, you can 
“encourage” mention if you know how. NewsMonger can help you find the on-going discussions that relate to your company or 
product and respond privately to the original poster (helping answer their query, perhaps) or posting information to the 
newsgroup (while carefully complying with posting guidelines regarding the relevancy of your submission). In either case, it can 
result in generating more interest world-wide for your product or company. And this may translate to higher revenues as interest 
builds.

Here is an example.



How does NewsMonger help?

NewsMonger allows you to concentrate on other work while it does USENET searching for you. After you invest a little time in 
creating searches and defining how often you want them run, NewsMonger does the rest!

Here are some of the ways NewsMonger can help you keep an eye on business:

2 NEW FEATURE: Search for information on ANY news server.

NewsMonger is able to be configured to search any news server, not just the USENET archives on the Digital AltaVista 
Search engine. This makes NewsMonger more up-to-the-minute than ever and assures you the availability of the news you 
want, when you want it.

2 Find out where on the USENET your company’s products are being mentioned.

Many times, specific products are mentioned in USENET newsgroup discussions as a solution to a problem an individual 
queried the group about. If your product is being mentioned, you need to find that news and read it!

2 Find opportunities on the USENET.

Use NewsMonger to find the general areas you can help individuals who send in queries to newsgroups. If you have a product 
and an answer for these queries, you can increase product awareness by finding these queries and responding as an expert.

2 Find out who is misusing your trademarks or service marks.

If someone is trying to get information and mentions your product by name, that’s one thing. If someone comes out with a 
competitive product and names it similarly to yours, that’s another issue you have to be aware of. A timely message from the 
trademark owner is sometimes all that is needed.

2 Find out what your competitors are up to.

Product news travels fast on the USENET. If your competitor announces something, you will likely hear of it first as a rumor in 
the newsgroups. This advance warning can be critical to your company’s success. Also, regular postings discuss the 
strengths and weaknesses of various products. You can evaluate your competitive position by keeping track.

2 Do you have individuals or organizations you want to keep an eye on?

NewsMonger can repetitively search for the names you specify. If they get active on USENET, you know about it.

2 Has someone forged your name or your company’s name to false postings?

This happens occasionally. You need to respond quickly that the message was not from your company.

2 Are messages from your organization inappropriate?

By searching for all postings from your domain, you can quickly find out who in your own organization is saying what. Also, if 
someone in your group is posting to inappropriate newsgroups, you can find out and take action to protect your organization’s 
good name.

NewsMonger is an invaluable tool in finding all sorts of information that impacts your company daily. Once you determine what 
searches produce the best information, let NewsMonger run every day to do the “grunt” work.



How can I use NewsMonger to Find What I Need?

Let’s look at brief examples for each of several search scenarios you may encounter.

2 Where on the USENET are your company’s products being mentioned?

Many times, specific products are mentioned in USENET newsgroup discussions as a solution to a problem an individual 
queried the group about. If your product is being mentioned, you need to find that news and read it!

Example: Find Company Product Mention 

2 NEW FEATURE: Search Your Local Intranet News Server

Your company sponsors an Intranet with access to an internal news server that has articles and discussion groups of 
employee interest. Your department needs to keep up-to-date on policy changes. By determining either typical titles in the 
header of such articles or the From: entry and setting NewsMonger News Server search to perform daily searches of the 
internal newsgroups, you can find the information when you need it.

Example: Results from a News Server Search 

2 Find opportunities on the USENET

Use NewsMonger to find the general areas where you can help individuals who send in queries to newsgroups. If you have a 
product and an answer for these queries, you can increase product awareness by finding these queries and responding as an 
expert.

Find Opportunities on the USENET 

2 Find out who is misusing your trademarks or service marks

If someone is trying to get information and mentions your product by name, that’s one thing. If someone comes out with a 
competitive product and names it similarly to yours, that’s another issue you have to be aware of. A timely message from the 
trademark owner is sometimes all that is needed.

Find Trademark Abuse 

2 Find out what your competitors are up to

Product news travels fast on the USENET. If your competitor announces something, you will likely hear it first as a rumor in the 
newsgroups. This advance warning can be critical to your company’s success. And now, with the ability to search any news 
server, you get the word even quicker because you are searching the live USENET, not archives. Also, regular postings 
discuss the strengths and weaknesses of various products. You can evaluate your competitive position by keeping track.

Keep an Eye on Competitors 

2 Do you have individuals or organizations you want to keep an eye on?

NewsMonger can repetitively search for the names you specify. If they get active on USENET, you know about it.

2 Has someone forged your name or your company’s name to false postings?

This happens occasionally. You need to respond quickly that the message was not from your company.

2 Are messages from your organization inappropriate?

By searching for all postings from your domain, you can quickly find out who in your own organization is saying what. Also, if 
someone in your group is posting to inappropriate newsgroups, you can find out and take action to protect your organization’s 
good name.

Monitoring Outbound USENET Postings 

2 Find employee candidates

Like many companies today, you may find a need to use innovative recruiting techniques. The USENET newsgroups are 
where the experts gather. What better place is there to look for new employees? 

Rather than posting a job to the whole newsgroup, you may get better results by using NewsMonger to search for mention of 
the expertise you need, then sending e-mail only to those individuals who seem as if they would fit well in your organization. 
And if you have a person’s resume in hand, you can also search the newsgroups for any articles they may have published to 
get an unguarded, unbiased view of their abilities.



The NewsMonger Main Screen

Click on screen areas below to get information about them.



Drop-Down Menus

The position of the NewsMonger Drop-Down Menu area is shown on the NewsMonger Main Screen.

File Menu 

Edit Menu 

View Menu 

Search Menu 

Article Menu 

Options Menu 

Help Menu 



NewsMonger Toolbar

The position of the NewsMonger Toolbar is shown on the NewsMonger Main Screen.

Save As 

Print 

Copy 

Start 

Stop 

Search Now! 

Wizard 

Create Search 

Delete Search 

Search Properties 

Reply by Mail 

Reply by News 

Next Article 

Previous Article 

Stop Getting Article 

NewsMonger Help 



What is the Tree View?

The position of the Tree View Area is shown on the NewsMonger Main Screen.

Feedback 

EventLog 

AltaVista News Search 

Searches: AltaVista 

List of Individual Searches: AltaVista 

News Server Search 

Servers 

Searches: News Server 

List of Individual Searches: News Server 



What is the Status/Results View?

The position of the Status/Results View Area is shown on the NewsMonger Main Screen.

When you select an 
AltaVista search in the 
Tree View area… The Status/Results View area shows information about the AltaVista search…

When you select a News 
Server search in the Tree 
View area… The Status/Results View area shows information about the News Server search…

When You Select an Individual Search Name (Click for Details):

Name 

Status 

Hit Count 

AutoSearch 

Query 

Description 



What is the Article View Area?

The Article View Area is the lower, sizable portion of the NewsMonger Main Screen. When an article is selected to be browsed, 
the Article View Area shows the article as it appeared in the newsgroup. The scroll bars on the bottom and right hand side of the 
area allows you to navigate through wide or long articles.

¨ When the Status/Results View Area shows status information for searches, the Article View Area is blank.

¨ When a list of articles is shown and none is selected, the Article View Area shows the message : “Double-click or Press 
ENTER to View Article.”

¨ If you want to save the article currently shown in the Article View Area, click File > Save As…. You will be prompted to 
provide a file name and location to save the file as ASCII text.



What is the Event Log?

When the Event Log is selected in the Tree View area, the Status/Results View Area shows details contained in the Event 
Log. These elements are shown on the NewsMonger Main Screen and the graphic below.

Date/Time 

Type 

Source 

Event 

If you call TechSmith Technical Support to report a problem with NewsMonger, you may be asked to provide the contents of the 
Event Log to help in troubleshooting the problem. With the Event Log in the Status/Results View area, you can save the event 
log as an ASCII text file. Use File > Save As….



Viewing Search Status

Search status is only shown when the “Searches” item is selected in the Tree View. To see search status:

1 Click “Searches” in the Tree View once with the primary mouse button.

2 Read the status of all searches in the Status/Results View area.

The positions of these elements are shown on the NewsMonger Main Screen.



Viewing Search Results List

Search Results are only shown when an individual search is selected in the Tree View. To see search results:

1 Click the name of the search you want to see in the Tree View once with the primary mouse button.

2 Read the list of search results in the Status/Results View area.

The positions of these elements are shown on the NewsMonger Main Screen.



Setting Options » General

Items required for setting options are configured when you install NewsMonger. Use these steps to view or modify options.

1 Click Options > General… with the primary mouse button.

2 From the General Preferences dialog, review the general configuration:

¨ AltaVista query URL - this is the address of the Digital AltaVista search engine being used for USENET searches. Do 
not change the default location (http://altavista.digital.com/cgi-bin/query) unless you are notified your area requires a 
different address.

¨ Maximum number of network connections - This is the number of simultaneous connections to be permitted. If you set 
it too high, NewsMonger will be too busy trying to make connections. If you set it too low, NewsMonger performance may 
degrade. The default setting of 4 connections should work for most installations.

¨ Start all AutoSearches when program starts - If checked and AutoSearch is enabled for a search, it will begin the 
sequence at the defined interval when the program starts. If unchecked and AutoSearch is enabled, search sequence will 
begin when the search is manually started.

NOTE: The option to start all AutoSearches when the program starts in the Options > General dialog is global and 
always starts all searches (AltaVista and News Server) which have AutoSearch enabled.

¨ Retry AutoSearch on network error every XX minutes - Allows repetitive retry when the network returns errors. Try 
checking this option at the default 10 minutes if you are having network problems. Not recommended for dial-up modem 
connections.

¨ Event Logging - We recommend leaving the default settings when you begin using NewsMonger, then consider 
changing it later to reduce logging activity.

· If “Log error and informational events” is checked, the event log grows quickly as all events are logged.

· If “Log error events” is checked, only errors are logged and the log grows more slowly. Consider selecting this 
option after you have used NewsMonger for a while.

· If “None” is checked, the event log is disabled.

¨ Maximum events to keep in log - The event log keeps up to the number specified and discards old entries when the 
number is exceeded.

¨ Clear Event Log Now - This button empties the event log. The file does not occupy much disk space at the default 
settings, so you should not need to worry about keeping the log empty.



Setting Options » Proxy Setup

Items required for setting options are configured when you install NewsMonger. Use these steps to view or modify options. If you 
are unsure whether you need to configure NewsMonger to work with a proxy, ask your network administrator.

1 Click Options > Proxy Setup… with the primary mouse button.

The HTTP Proxy Setup dialog appears.

2 To use a Proxy (or firewall) server, click “Use Proxy.”

3 Type the proxy server IP Address in the text box. If you do not know this number, ask your network administrator. Alternatively, 
you can enter the domain name of the proxy server.

4 If you want to save Proxy Authentication information (you will not be prompted on every program start), click the Proxy 
Authentication button. An example of proxy authentication is a login ID and password combination.

The Proxy Authentication dialog appears.

5 Check “Enable HTTP Proxy Authentication.”

6 Type your Proxy User Name and Password.

7 Select the HTTP Proxy Authentication Type. If you do not have this information, ask your network administrator.

8 Click [OK] twice to exit Proxy Setup.



Setting Options » Browser Setup

Items required for setting options are configured when you install NewsMonger. Use these steps to view or modify options.

1 Click Options > Browser Setup… with the primary mouse button.

2 If the Web Browser Filename text box is blank or incorrect and you want to use a web browser in conjunction with 
NewsMonger, you should specify one.

3 Either type the full path filename to the web browser you want to use or use the Browse button to locate it on your computer.

NOTE: If you have more than one Internet web browser on your computer, you can select a different one using this option 
setup.



Setting Options » Mail and News Setup

Items required for setting options are configured when you install NewsMonger. Use these steps to view or modify options.

1 Click Options > Mail and News Setup… with the primary mouse button.

2 From the Mail and News Setup dialog, review the options and change if necessary:

¨ User Information - Type corrections or changes in the text boxes for the following, if required:

· Your Name (optional)

· Your Internet Mail Address (required)

· Your Reply-to Mail Address (optional)

· Your Organization/Company (optional)

¨ Signature File (optional) - If you use an ASCII text file on your system for message signatures and you want to use it 
with the NewsMonger SMTP Mail Client or NNTP News Client for outgoing messages, supply the full path filename here.

¨ Servers - You must supply the Internet domain address for both the Internet Mail (SMTP) and News (NNTP) servers. If 
you do not have this information, try the following:

· review the configuration of your existing web browser (if it is working properly)

· ask your network administrator

· call your Internet Service Provider

¨ Mail Notification - If you want mail notification of search results (hits), select one of the two mail clients. If you want to 
use the NewsMonger SMTP Mail Client, select SMTP. If you have another MAPI-compliant mail program such as 
Microsoft Mail or Exchange, select MAPI.

¨ Mail Reply - Select the mail client you want to use for outgoing mail messages when using NewsMonger.

¨ News Reply (recommended) - Select the news client program you want to use for USENET article replies.

¨ Identification - Select “Prevent Indexing of replies (X-No-Archive)” if you want your replies to news articles to not be 
included in the archives. This means you can send replies without them appearing in anyone else’s search results.

¨ Mail and News Reply - Select the options you need to allow quoting of the original article you are replying to and to send 
a copy of your reply to an e-mail address which you can specify. You can use this feature to send a copy to yourself or 
anyone else.



Setting Search Properties: AltaVista

Search properties are set when you create a search. You can change the properties any time you want to refine or change your 
search. To set search properties:

1 Select an AltaVista search in the Tree View list.

2 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

3 The General tab contains the name and description of your search. Type a new description if needed.

NOTE: If you need to change the name of a search, you can do so without re-creating the search, but not within Search 
Properties. For details on changing search names, see also: How Can I Rename an Existing Search?.

4 In the box labeled “Query Construction Interface,” select either Simple Query or Advanced Query, then go to the tabbed 
dialog for the search type selected.

5 If you select Simple Query, see Creating a Simple Query.

6 If you select Advanced Query, see Creating an Advanced Query.

7 Click the AutoSearch tab. See Enabling AutoSearch.

8 If you want either a search notification or a list of hits to be delivered to your e-mail address, check “Send new search hit 
notification by e-mail” and supply the address. If you want a list of the hits, enter the number you want delivered.

9 Click the Search Filters tab. On this dialog, you can set up special filters for your search that can further limit or refine results. 
See Using the Search Filters.

10 Click the Search History tab. See What is Search History and how do I change it? 

11 Click the Raw Query tab. This is read-only and cannot be modified.

12 Click [OK] to exit the Search Properties tabbed dialogs. Your new search properties are saved for future searches. If you 
made changes, you are asked if you want to clear the current search results. If you answer YES, the existing search history 
results will be deleted.



Setting Search Properties: News Server

NEW FEATURE: Search properties for news server searches are set when you create a one. You can change the properties any 
time you want to refine or change your search. To set search properties:

1 Select a News Server search in the Tree View list.

2 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

3 The News Server Query tab contains the name and description of your search. Type a new description if needed.

NOTE: If you need to change the name of a search, you can do so without re-creating the search, but not within Search 
Properties. For details on changing search names, see also: How Can I Rename an Existing Search?.

4 To add a news server, click [Add News Server]. (You can also add a news server by clicking the secondary mouse button 
anywhere in the "Servers" branch of the Tree View and selecting “Add...")

5 The News Server Properties dialog appears.

6 In the “News Server Name” text box, type a valid news server address. You may be able to discover this information from your 
existing Internet browser or you can check with your System Administrator or Internet Service Provider.

7 Type your User Name and Password for the news server, if required.

8 Click [OK] to exit the News Server Properties dialog. After adding a news server, the server will be listed in the drop-down list 
of news servers and in the    "Servers" branch of the Tree View.

9 On the Search Properties dialog, click [Select Newsgroups…] to select the USENET newsgroups you would like to include 
in your search.

NOTE 1: In selecting newsgroups, NewsMonger will query the news server you indicated in step 6. If you get an error, check 
the news server name and re-enter if necessary.

NOTE 2: The process of selecting newsgroups may take several minutes, especially using a dial-up connection. The length of 
time depends on how many newsgroups are maintained on the news server you select.

For more information on selecting newsgroups, see also: Selecting Newsgroups to Search 

10 The drop-down list under “Search News Server:” allows the user to select a news server from the list of available servers 
(this is the same list of news servers as under the "Servers" branch in the Tree View). While you are able to change a news 
server for an existing search, you would rarely need to.

11 In the “Search Subject for” text box, type the keywords you want to search. It is better to use a few very specific words than a 
greater number of vague terms.

12 Select one of the radio buttons to tell the search if you want it to find All terms in the Subject line or Any of them. This can 
have a dramatic impact on the number of hits returned.

n If you tell the search to find “All” terms and specify several, the returned list will be short.

n If you tell the search to find “Any” term and specify several, the returned list will be much longer.



n If you only specify one term, the results should be the same for “All” and “Any.”

13 If you want to search for specific names in the From line of news articles, specify it in the “Search From for” text box. Select 
the All or Any radio button. This can be combined with a Subject line search to further refine results.

For examples of the terms you can enter, see also: News Server Search Terms and Methods.

14 Click a check mark in the “Ignore Case” checkbox if you want the search to consider both capitalized and lower case letters 
for both the Subject line and the From line.

15 Click [OK] to exit the Search Properties tabbed dialogs. Your new search properties are saved for future searches. If you 
made changes, you are asked if you want to clear the current search results. If you answer [YES], the existing search history 
results will be deleted.

NOTE: There are two other tabs on the Search Properties tabbed dialogs for News Servers. For information on these tabs, see 
also:

n Enabling AutoSearch 

n What is Search History and how do I change it? 



News Server Search Terms and Methods

Use the following guidelines to make decisions about what to enter in the “Search Subject for” and “Search From for” boxes. As 
in all search engines, the more accurate and concise your search terms, the better the results will be.

Search Subject for All/Any of the following words:

This directs the search to news article Subject header lines for the selected news groups for All or Any of the words entered.

n NewsMonger news server search currently only handles single words separated by spaces (for example: running shoes 
fitness).

n Quoted phrases are not currently supported (for example: "Jogging Trail").

n Searching for All words is a Boolean AND operation (all of the words must appear in the article Subject).

n Searching for Any of the words is a Boolean OR operation (find articles with any of the words in the article Subject).

n Ignore Case performs a case insensitive search if enabled (it does not matter if the search words are capital letters or lower 
case).

Search From for All/Any of the following words:

This directs the search to news article From header lines (for example, the person sending the article) for the selected news 
groups for All or Any of the words entered.

n NewsMonger news server search currently only handles single words separated by spaces (for example: publicrelations 
techsmith).

n Quoted phrases are not currently supported (for example: "John Smith").

n There is no facility to find the person’s name if it is not included in the From header line as published. For example, if the 
article header shows it was submitted by jgrimes, it will be ignored if you are using the search terms Judy Grimes.

n There is no facility to perform “sounds like” searches. The entered terms must be matched exactly with the exception of case 
when Ignore Case is chosen.

n Ignore Case performs a case insensitive search if enabled (it does not matter if the search words are capital letters or lower 
case).

n Searching for All words is a Boolean AND operation (all of the words must appear in the article From).

n Searching for Any of the words is a Boolean OR operation (find articles with any of the words in the article From).



Performing a News Server Search

You can begin your search for newsgroups on news servers the same way AltaVista searches are started. All of the same 
features apply.

For related information about performing searches, see also:

n Enabling AutoSearch 

n Search Menu 

n Stop Getting Article 

n Using Edit > Find 

n Using Edit > Find Again 

n Using the Search Now! Button 

n Using the Start Search Button 

n Viewing Search Results List 



Creating a Simple Query

NOTE: This topic applies only to AltaVista Searches.

1 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

2 Click the Simple Query tab. On the Simple Query dialog:

¨ Keywords - Review the search keywords. You can change or add terms if needed. See the examples on the dialog for 
guidance on using the Simple Query language.

¨ Ignore Case - Check this box if you want your query to find the terms whether they contain capitalized letters or not. If 
checked, your search is likely to return more hits.

¨ Use Wildcards - Check this box if you want your query to find the whole term by itself or embedded in any text string. If 
checked, your search is likely to return more hits.

¨ Search Focus - Set the slider to adjust the sensitivity of the search. Narrow will return fewer and, theoretically better hits. 
Wide will encompass a greater number, perhaps lower quality hits.

¨ Test Search Button - Use the Test Search button to kick off a search in your selected Internet browser. This can give 
you an idea if anything will be returned in periodic searches and a snapshot of the quality of the hits. Not required.

3 Click [OK] to exit the Search Properties tabbed dialogs. Your new search properties are saved for future searches. If you 
made changes, you are asked if you want to clear the current search results. If you answer YES, the existing search history 
results will be deleted.



Creating an Advanced Query

NOTE: This topic applies only to AltaVista Searches.

1 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

2 Click the Advanced Query tab. On the Advanced Query dialog:

¨ If you know the AltaVista Advanced Query language, you can enter it directly on this panel (if also selected on the 
General panel). You can get more information on the Advanced Query format on the Internet at the AltaVista page.

¨ After entering the advanced criteria, you can test your search on this panel, if desired.

3 Click [OK] to exit the Search Properties tabbed dialogs. Your new search properties are saved for future searches. If you 
made changes, you are asked if you want to clear the current search results. If you answer YES, the existing search history 
results will be deleted.



Using the Search Filters

NOTE: This topic applies only to AltaVista Searches.

1 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

2 Click the Search Filters tab. On the Search Filters dialog, you can specify:

¨ A Newsgroup Filter - With this text box, you can specify newsgroups that you want to specifically include or exclude 
from the search. For example, to exclude the entire alt branch of newsgroups, type alt*.

¨ A Keyword Filter - With this text box, you can specify words that, if present in the article, will exclude the article from 
your results. For example, to exclude articles that contain the word “Windows,” you would check the selection box and 
type “Windows” in the text box. If the word appears in either the subject line or article body, it will be excluded.

¨ A Subject Filter - With this text box, you can specify words that, if present in the article subject line, will exclude the 
article from your results. For example, to exclude articles that contain the word “Contract” in the subject line, you would 
check the selection box and type “Contract” in the text box. If the word appears in the subject line, it will be excluded.

¨ A From Filter - With this text box, you can specify e-mail addresses from which articles will not be selected. This can be 
handy for excluding articles from individuals. Type the e-mail or customary return address you want to exclude. NOTE: 
Many newsgroup posters use aliases instead of actual SMTP mail addresses to hide their identity.



How Can I Limit the Amount of Data Returned?

NOTE: This topic applies only to AltaVista Searches.

There are several ways you can limit or refine the data you get back from NewsMonger.

1 Type more terms in the Simple or Advanced Query dialog. The more terms you can define before starting the search, the 
more likely the results will be satisfactory. For example, instead of just using the terms “Cajun Cooking,” add any refinements 
you can, such as “Recipes,” “Louisiana,” or “New Orleans.”

2 Make your query case-sensitive by unchecking Ignore Case. This may help eliminate articles that do not apply. For example, 
a case-sensitive search for “Windows” may help eliminate articles about glass portals and increase hits for Microsoft 
Windows. Of course, also adding “Microsoft” to the search text will help.

3 Do not use wildcard searches. This will eliminate returns of other word forms that may not apply to the information you are 
interested in.

4 Use the narrow search focus. Some guidelines about the Search Focus slider on the Search Properties > Simple Query 
dialog:

¨ WIDE FOCUS - This setting creates a query based on the OR operator. In other words, in a two-word query, the 
presence of either term 1 OR term 2 will result in a hit.

¨ MIDDLE SETTINGS - Settings at or near the middle of the slide scale creates a query based on the AND operator. In 
other words, in a two-word query, the presence of both term 1 AND term 2 will result in a hit. (Theoretically, the absence 
of one or the other will not be found.)

¨ NARROW FOCUS - This setting creates a query based on the NEAR operator. In other words, in a two-word query, the 
presence of both term 1 and term 2 will result in a hit if they are located NEAR each other within the text of the article. 
(Theoretically, the absence of one or the other will not be found and if both are present but they are separated by a 
number of words, the article will not be found.)

5 Use Search Filters on the Search Properties tabbed dialog. These filters will help you eliminate spurious news articles.

6 Consider using an Advanced Query rather than a Simple Query. With advanced techniques, you can refine your search query 
to retrieve exactly the results you want.



Using the Start Search Button

There are several ways to start a search:

1 Click the Start Search button on the NewsMonger toolbar.

2 Click the Search Now! Button on NewsMonger Toolbar.

3 Modify Search Properties. When you exit the tabbed dialog, you will be asked if you want to start the changed search now.

4 Select one of the Start options on the Search drop-down menu.

5 Start the NewsMonger program with “Enable AutoSearch” checked on the Search Properties > AutoSearch tabbed dialog. 
Also, checkmark the box: Options > General Preferences > Start all AutoSearches when program starts.



Using the Search Now! Button

Click the Search Now! button (or select it on the Search Drop-Down Menu or secondary mouse click menu) to update 
AutoSearch results.

1 Click the Search Now! button on the NewsMonger toolbar (for a stopped search).

2 Observe that the search has started.



Enabling AutoSearch

AutoSearch can help perform repetitive searches with little user intervention. However, you should select search intervals in the 
steps below that meet your needs without searching too often.

1 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

2 Click the AutoSearch tab. On the AutoSearch dialog:

¨ Click the checkbox to enable AutoSearch.

¨ Type the interval. The more often you allow AutoSearch to operate, the more active NewsMonger will be. Consider this 
factor, especially for dial-up searches.

¨ Select minutes, hours or days. This defines the AutoSearch interval.

3 Click [OK]. Your search will kick off when:

¨ The interval elapses after starting a search or,

¨ You start NewsMonger and at the regular timed intervals if you have checkmarked the box:
Options > General Preferences > Start all AutoSearches when program starts.



Using the NewsMonger News Browser

The default method of browsing news articles is to use the browser included with NewsMonger. To use this browser:

1 Click on the search name you want to select in the Tree View area.

2 Article headers (subject line and miscellaneous information) appear in the Status/Results View area.

3 Double-click on any article. Use the scroll bars to view additional article titles.

4 Observe that the selected article appears in the Article View area. Use the scroll bars to view the entire article.

5 Use Edit > Find to find terms within the article that you are interested in.



Using Another News Browser

You can use another NNTP news client to browse newsgroups under certain conditions. You can browse the thread the article is 
from or browse recent newsgroup contents. This can be handy to get a general overview of the contents of a newsgroup you see 
in your search results.

To browse a thread related to an article:

1 Select an article whose thread you want to review.

2 Click Article > Browse Article Thread….

This will kick off your default news browser to view related articles.

To browse the whole newsgroup an article has come from:

1 Select an article whose newsgroup you want to review.

2 Click Article > Browse Newsgroup….

This will kick off your default news browser to view the newsgroup from which the article came.

NOTE: Alternatively, you can select both options using the secondary mouse button over the selected article.



How do I delete an existing search?

If you want to substantially change a search or stop using a search, you can delete it from your list of searches in NewsMonger.

1 In the Tree View area, select the search name you want to delete.

2 Press <Del>. You are asked if you are sure you want to delete the item.

3 Click Yes to delete the search permanently.



How can I make the results more meaningful?

The best way to make NewsMonger results more meaningful is to determine your goals before you start, then develop searches 
to accomplish those goals.

Review the list of potential uses in “ How can I use NewsMonger to Find What I Need?”   From that list, determine what it is you want   
NewsMonger to accomplish. Then determine the best way to create a search to accomplish what you need.

For example, suppose your hobby is fishing and you want to create an occasional search for information on fishing lures. 
Consider some possible implications for your search:

¨ Since this is a hobby, you may not want to execute the search on a daily basis. Consider setting AutoSearch to only work 
once a week, for example.

¨ Since you are interested in all types of fishing lures, use loose search criteria and visually scan the results to select those 
articles whose subject are of interest.

¨ Since you may not want to spend a lot of time or computer resources on this, consider limiting the number of hits to be 
returned.

Another example: You need to find out everything being said on the newsgroups about Artificial Intelligence.

¨ Since this is a very specific area, you can design the search to limit the amount of unrelated information you will get back. 
Use exact terminology in the search criteria, such as “Computer Artificial Intelligence.”

¨ Avoid wildcards and make the search narrow to ensure relevance.

¨ Since this search is work-related, consider using the default search frequency and number of hits to return.

A third example: Your trademark is constantly being misused. You need to respond to frequent assaults in timely fashion to 
discourage misuse.

¨ By definition, a registered trademark is unique. Therefore, your search criteria can be very specific. There is no need to 
search for terms other than your trademark.

¨ Avoid wildcards and make the search narrow to ensure relevance. NOTE: You may not want to run case-sensitive searches 
since someone misusing a trademark may ignore capitalization.

¨ Since this search is critical to your work, consider frequent searches allowing a large number of hits to be returned.



How can I use results to accomplish business goals?

The possibilities are endless, limited only by the user’s imagination. After defining the goals to be met by an individual search, 
design the search to meet those goals. Then after the results begin coming in, determine if they meet your needs. If not, modify 
the search until you get the results that meet you or your company’s needs.

See also:

How does NewsMonger help? 

Why would this information interest me? 

How can I make the results more meaningful? 



What type of information does NewsMonger HELP contain?

NewsMonger HELP contains information about using the program. There are general information sections, such as:

2 Why Use NewsMonger?

2 NewsMonger User Interface

2 How Do I Create a New Search?

2 How Can I Schedule the Searches to Fit My Needs?

2 Making the Most of Search Results

2 Modifying Searches to Maximize Results

2 Using NewsMonger HELP

2 General Information

2 Contacting TechSmith

In addition, you can use NewsMonger HELP from several dialogs where you are likely to need information. Just click the Help 
button where it appears or press <F1> on the screen where you need help.

To get the contents list, go to Welcome to NewsMonger. 



How can I find the information I need?

This section has some tips for finding NewsMonger user information when you need it.

Screen Help

On many screens, you can use NewsMonger HELP where you are likely to need information. Just click the Help button where it 
appears or press <F1> on the screen where you need help.

Help Menu

Also, when you click on the Help drop-down menu and select Index, you are taken to a search facility where you can type terms 
you would like to find in the Help system.

Contents

To get the contents list, go to Welcome to NewsMonger. 



How can I get HELP for a screen or task I am using?

Screen Help

On many screens, you can use NewsMonger HELP where you are likely to need information. Just click the Help button where it 
appears or press <F1> on the screen where you need Help.

Contents

To get the contents list, go to Welcome to NewsMonger. 



Installing NewsMonger

Installing NewsMonger is accomplished using the Install Wizard shipped with the product. For all installations, the Install Wizard 
helps you to make decisions about where to store files and how to begin to set up the program.

See the README.TXT file shipped with NewsMonger for the latest installation instructions.



Uninstalling NewsMonger

Uninstall NewsMonger when you no longer need it. Since NewsMonger is a Windows 95/NT program, installation information is 
recorded in the Windows Program Registry. To uninstall properly, use the Windows Uninstall program.

1 Click Windows 95/NT 4.0 Start.

2 Select Settings > Control Panel.

3 Double-click Add/Remove Programs.

The Add/Remove Programs Properties dialog appears.

4 Select the Install/Uninstall tab.

5 Select NewsMonger from the scrollable list on the lower portion of the dialog.

6 Click the Add/Remove button.

7 The Uninstall program starts and asks you to select an uninstall method: Automatic or Custom. Automatic is recommended 
unless you wish to monitor the process of file deletion and modification. If so, select Custom.

8 Click Finish to complete the uninstall.

Progress of the uninstall is shown graphically and in words.



Upgrading NewsMonger

If you are upgrading from unregistered to registered NewsMonger, full instructions are included in Help > How to Register. 
Follow these instructions.

If you are installing a new release or patch, follow instructions in the README.TXT file that comes with the new program. In 
most cases, installation will be performed by an Install Wizard.



Sales Information

NOTE: TechSmith is located in the US Eastern Standard Time Zone.

For more information about NewsMonger availability and pricing, see the README.TXT file shipped with the product. For further 
sales information, please contact:

Mail:
TechSmith Corporation
Attn.: NewsMonger Sales
PO Box 4758
East Lansing, MI    48826-4758

Phone:
(800) 517-3001 or
(517) 333-2100

Fax:
(517) 333-1888

E-mail:
newsmonger@techsmith.com

Internet:
http://www.techsmith.com

Copyright © 1996, 1997
TechSmith Corporation
All Rights Reserved.



Example Search for Information about Cajun Cooking

Bayou Basics sells an online cookbook featuring Cajun dishes. A little research tells their marketing director that the USENET 
newsgroup rec.food.cooking has many individual postings regarding Cajun cooking. She decides an e-mail response to each 
person who sends a question about Cajun recipes would be a good way to promote the cookbook.

The marketing director uses NewsMonger to create a permanent, repetitive search of the rec.food newsgroups. Each day, a 
number of new “hits” show up in the results list; each hit represents a posting to one of the selected newsgroups and each has 
the e-mail address of the person who posted. Using a template to respond to such postings, the marketing director is able to 
send a personalized e-mail letter to each. This encourages sales of the new book, because she has also included an order form 
with the e-mails she sends out.

See set up example to see how such a search would be built.



Example: Find Company Product Mention

1 Click on Search > Create….

2 On the General tab, type the search name.

3 Type the Description.

4 Click Simple Query.

5 On the Query tab, type the terms you want to search. Leave Ignore Case and Use Wildcards unchecked for now (you can 
change these later if needed to refine your search).

6 Leave Search Focus at the default position (you can change this later if needed to refine your search).

7 Click [OK].

Conduct a few searches to see the results. You can see that using a unique product name can return excellent results, while 
using terms that have more than one meaning or can be interpreted in more than one way will return less useful results.

After reading the results, you may decide that a direct e-mail response to each one is the best approach.



Find Opportunities on the USENET

Many USENET newsgroups are conducted in threads that may run for several days. Use NewsMonger to find these threads, 
then chip in to the discussion as an expert. You can respond directly to newsgroup postings (using either the NewsMonger news 
reader or your own). Try to find opportunities where your product solves a particular problem being discussed in the postings.

These responses, if carefully and strategically worded, can contribute to the success of your product. Be aware that some 
newsgroups discourage blatant commercialism. If appropriate to the newsgroup, respond privately to the original poster instead.



Find Trademark Abuse

After doing a search using your company’s trademark or service mark, visit each article found and determine how it is being 
used. Unless your are being slandered, users’ mention of your trademark in newsgroups does not constitute abuse. However, if 
you feel your trademark is being unfairly or improperly used by someone with malicious intent, you can take action. This may just 
mean sending an e-mail response to clarify proper use of your trademark.

For example, the trademark SnagIt® (another TechSmith product) is properly followed by the phrase “Brand Screen Capture 
Utility.” This is to help keep it from becoming a misused trademark. The folks at Johnson & Johnson go to considerable trouble to 
protect their product: BAND-AID® Brand Adhesive Bandages.

While you may not feel like contacting every person or organization that uses your registered trademark in a way you don’t 
approve, you certainly may want to follow up on intentional or malicious misuse. An example would be associating your 
trademark with products or causes your organization does not support.

SnagIt® is a Registered Trademark of TechSmith Corporation.
BAND-AID® is a Registered Trademark of Johnson & Johnson.



Keep an Eye on Competitors

It is good business practice to keep an eye on your competitors. Rumors or announcements that can affect your market position 
can be of vital import to you.

For example, by searching the newsgroups, you find there is a rumor that your competitor is going to come out with a new 
software release at a lower price than current. Considering the source of the rumor, you may decide it is in your company’s best 
interest to move first: speed up your own release schedule and consider price reductions.



Monitoring Outbound USENET Postings

The NewsMonger query, used in conjunction with the default AltaVista search engine, searches every word of recent USENET 
postings (including header and signature information). Design a search that includes the unique part of your domain name. You 
may be surprised at the information going out from your domain. And you may want to communicate with individuals in your 
organization about what is appropriate to publish on the USENET from company-owned resources.



Example: Setting Up a Search Query about Cajun Cooking

1. Click Search > Create…. The Search Properties window appears.

2. Click the General tab.

¨ For Search Name, type “Cajun Cooking” without the quotes.

¨ Type a short description of the search.

¨ Select Simple Query.

3. Click the Simple Query tab.

¨ For the Search Keywords, type “Cajun Cooking Recipes” without the quotes.

¨ Click Ignore Case (to allow the search to find the terms regardless of capitalization).

¨ When setting up new searches, set the Search Focus to “Narrow” until you get an idea how many hits you will get.

4. Click the Search Filters tab.

¨ Click ON “Newsgroups to exclude…in search.”

¨ To exclude the noise in the alt newsgroups, type “alt*”. This tells the search engine to ignore this entire branch of 
newsgroups.

5. Click the Simple Query tab again.

¨ Click the Test Search button. A test search will be performed and the browser you specified under the Options menu will 
be launched.

¨ Check the search results in your browser to see if they are appropriate and as you expected. If not, modify Search 
Properties and try again.

¨ If the results look good, go to the next step to schedule the search frequency.

6. Under Search > Properties, click the AutoSearch tab.

¨ Click the Enable AutoSearch box and then set the frequency.

¨ Click [OK].

You are now set up to search the terms you selected on a regular basis. You can design as many searches as you need to cover 
the topics you are interested in.



Thread

A USENET topic of discussion in one or more newsgroups that may run for several days.



File Menu

The following items are available:

Save As… This option allows you to save an article in the Article View area as 
an ASCII text file. This is helpful for saving articles you want to 
respond to later.

Save Results 
As…

NEW FEATURE: This option allows you to save a search results list 
in three forms: as an HTML formatted document (with web 
links--.HTM); as a plain ASCII text file (.TXT); as a formatted text file 
(.PRN).

Print…
Ctrl+P

This options sends the article in the Article View area to the 
selected printer.

Print PreView Shows on screen the article in the Article View area as it will appear 
when printed.

Print Setup… Brings up the Windows print setup screen to allow you to change 
printer settings or destination.

Exit Exits NewsMonger and prompts the user to save searches/articles.



Edit Menu

The following items are available:

Copy
Ctrl+C

This allows you to copy text from an article in the Article View area. 
Text is placed on the Windows clipboard for use elsewhere.

Find…
Alt+F3

This brings up a dialog box that allows you to enter a search string to 
find in the current article in the Article View    area. This is helpful for 
finding terms that occur in your NewsMonger search query.

Find Again
F3

This repeats the last find action using the same term as search 
criterion.



View Menu

The following items are available:

Toolbar This control toggles when clicked. If a check mark is before the 
menu item, the toolbar is visible at the top of the NewsMonger main 
screen.

Status Bar This control toggles when clicked. If a check mark is before the 
menu item, an area at the bottom of the NewsMonger main screen 
reports status as you use the product. For example, the status of a 
selected search is shown when a search is selected and the Status 
Bar is checked.

Unread Articles 
Only

This control toggles when clicked and acts in the opposite of All 
Articles. If a check mark is before the menu item, only unread 
articles (with a red page icon) are shown in the Results area.

All Articles This control toggles when clicked and acts in the opposite of Unread 
Articles Only. If a check mark is before the menu item, both 
previously read (with a black page icon) and unread (with a red page 
icon) articles are listed in the Results area.

Results Sorted 
By >

Date:

Subject:

NewsGroup:

From:

Articles in the Results are listed by Date, with 
most recent articles listed first.
Articles are sorted by Subject in alphabetical 
order.
Articles are sorted by NewsGroup in alphabetical 
order.
Articles are sorted by the From name in 
alphabetical order.

Fixed Width 
Font

This selection shows article contents in Courier typeface with fixed 
letter spacing. This is a broader typeface.

Variable Width 
Font

The default, this selection shows article contents in Arial font with 
variable letter spacing. This option is more compact than Fixed.



Search Menu

The following items are available from both the Search Menu and when you click the secondary mouse button over a search 
name:

Start Starts the selected search, if stopped or inactive. See Using the Start 
Search Button.

Stop Stops a search in progress. Use this button to abandon the search if 
you did not intend to start it. You can also stop searches using the 
Stop button on the NewsMonger toolbar or by using the secondary 
mouse button on the selected search.

Search Now! Starts a selected search that has been deactivated. See Using the 
Search Now! Button.

Start All Auto Starts all searches for which you have activated AutoSearch. See 
also: Enabling AutoSearch.

n If you are in the AltaVista News Search branch and do a Search 
> Start All Auto, it will start all AltaVista News searches which 
have AutoSearch enabled.

n If you are in the AltaVista News Search branch and do a Search 
> Start All Auto, it will start all AltaVista News searches which 
have AutoSearch enabled.

Stop All Stops all searches in progress.

n If you are in the AltaVista Search branch and do a Search > 
Stop All, it will stop all AltaVista searches.

n If you are in the News Server Search branch and do a Search > 
Stop All, it will stop all News Server searches.

Wizard… Starts the Create a Search Wizard. You can also create a new 
search using Create… or by selecting either function on the toolbar 
or by using the secondary mouse button in the Status/Results View 
area.

n If you are in the "AltaVista News Search" branch of the Tree 
View, Search > Wizard creates an AltaVista search.

n There is no Search Wizard for News Server searches.

Create… Opens the Create Search tabbed dialog. 

n If you are in the "AltaVista News Search" branch of the Tree 
View, Search > Create creates an AltaVista search. 

n If you are in the "News Server Search" branch of the Tree View, 
Search > Create creates an News Server search.

Rename Allows you to rename searches in the Tree View. Makes the listed 
search name editable.

Delete Deletes a selected search. You can also delete a search using the 
Delete button on the toolbar or by using the secondary mouse button 
in the Status/Results View area.

Clear Results Clears search results.

Properties Opens the Search Properties tabbed dialog. See also:
Search Properties.

NOTE: All Search menu options are context sensitive depending on where you are in the Tree View:



Article Menu

The following items are available:

View Article When an article in the Status/Results View area is selected, this 
option opens that article in the Article View area. 

Reply by Mail… Available when a article is in the Article View area. Allows you to 
reply to a USENET post by sending e-mail to the originator. 
Brings up the NewsMonger SMTP Mail Reply by default. If you 
selected another mail client to send mail, it is brought up. The 
original article is quoted, so you can type your reply right in the 
same window and send. You message will be sent only to the 
originator.

Reply by News… Available when a article is in the Article View area. Allows you to 
reply to a USENET post by sending a posting to the public 
newsgroup. Brings up the NewsMonger NNTP News Client by 
default. If you selected another news client to send posts, it is 
brought up. The original article is quoted, so you can type your 
reply right in the same window and post. Be aware that your 
message will be available to all subscribers of the newsgroup, 
perhaps thousands of individuals worldwide.

Browse Article 
Thread…

Available whenever an individual article is selected. Allows you to 
see related postings. You may want to review the contents of a 
thread before posting your own reply, just to be aware of other’s 
comments.

Read 
NewsGroup…

Available whenever an individual article is selected. Allows you to 
see all recent articles in a newsgroup. You may want to review 
the contents of a newsgroup before posting your own reply, just 
to be aware of the nature of the group.

Next Article Brings up the next article in the list in Status/Results View.

Previous Article Brings up the previous article in the list in Status/Results View.

Mark Article Read Marks the current article as having been read to alert you that 
you need not read it again.

Mark All Articles 
Read

Marks all articles in the Status/Results View as having been 
read.

Mark Article 
Unread

Undoes Mark Article Read.

Mark all Articles 
Unread

Undoes Mark all Articles Unread.

Stop Getting 
Article

Stops the process of retrieving an article that is listed in the 
Status/Results View. This may be helpful for lengthy articles 
that you do not want to wait for.



Options Menu

The following items are available:

General… Allows you to set up or change NewsMonger General Options. 
See also: Setting Options >> General 

Proxy Setup… Allows you to set up or change NewsMonger Proxy Setup 
Options. See also:
Setting Options >> Proxy Setup 

Browser Setup… Allows you to set up or change NewsMonger Browser Setup 
Options. See also:
Setting Options >> Browser Setup 

Mail and News 
Setup…

Allows you to set up or change NewsMonger Mail and News 
Setup Options. See also:
Setting Options >> Mail and News Setup 



Help Menu

The following items are available:

Help Index Allows you access to NewsMonger Help.

About 
NewsMonger

Brings up information about NewsMonger. If your copy of the 
program has not yet been registered, this option brings up the 
Registration dialog. If your copy of the program is registered, this 
option brings up release information.

Feedback/
Problem 
Reporting

Brings up the NewsMonger Feedback/Problem Reporting that 
contains important options for sending reporting problems, sending 
the EventLog, and sending information about the current 
NewsMonger settings. Produces an e-mail message to send the 
information, combined with your own comments, back to TechSmith 
Corporation.

How to 
Register

If your copy of the program has not yet been registered, this option 
brings up the Registration dialog.

Sales 
Information

This option contains information about how to contact TechSmith 
Corporation, the maker of NewsMonger.



Save As

Allows you to save the active article (if selected). If the event log is shown, allows you to save that information in an ASCII text 
file.



Print

Allows you to print the active article (if selected).



Copy

Allows you to copy highlighted portions of text in an active article.



Start

Starts the selected search.



Stop

Stops the selected search.



Search Now!

Starts a stalled or inactive search immediately.



Search Create Wizard

Brings up the Create a Search Wizard to allow you to create a new search.



Create Search

Brings up the Create Search tabbed dialog to allow you to create a new search.



Delete Search

Deletes the selected search. You are asked if you are sure you would like to delete it.



Search Properties

Brings up the Search Properties tabbed dialog to allow you to change an existing search.



Reply by Mail

Replies to the article currently in the Article View area. The reply is an e-mail message directed to the originator of the posting.



Reply by News

Replies to the article currently in the Article View area. The reply is a newsgroup posting to all subscribers of the newsgroup.



Next Article

Selects the next listed article for view.



Previous Article

Selects the previous listed article for view.



Stop Getting Article

Abandons the process of retrieving a selected article.



NewsMonger Help

Brings up this Help system.



Feedback      

Send your comments about NewsMonger to TechSmith. Allows you to also send the latest 100 events from the event log and 
configuration information to help in understanding problems you report. Brings up a mail send window.



EventLog      

A chronological record of NewsMonger events. To set the items to be logged, use the NewsMonger menus: Options > General 
Preferences > Event Logging.



AltaVista News Search      

NewsMonger uses the Digital AltaVista Search engine to search USENET newsgroups. This is non-configurable, except location 
of the search engine. (See Options > General Preferences > AltaVista query URL.)

Click plus [ + ] to open the list in the Tree View; click minus [ - ] to close the list.



Searches: AltaVista      

A list of all the searches you have created for AltaVista search. Click plus [ + ] to open the list in the Tree View; click minus [ - ] to 
close the list.



List of Individual Searches: AltaVista      

When this item is opened, it shows is a listing in both the Tree View area and the Status/Results View area of all of your 
AltaVista searches. 

Click plus [ + ] to open the list in the Tree View (if there is more than one); click minus [ - ] to close the list.



Name

The name you have assigned to the search is displayed.



Status

Shows:

¨ whether NewsMonger is Searching... or Search Finished

¨ how many hits were found on the last search performed

¨ any error messages that relate to the last search performed



Hit Count

Shows the number of articles found matching the query from the last search performed.



AutoSearch

Shows:

¨ “Enabled” for searches that have AutoSearch enabled or

¨ “Disabled” for searches that have AutoSearch disabled.



Query

Shows "Simple Query" or "Advanced Query," depending on the selection made in Search Properties.



Description

Repeats the Description text you typed when creating the search.



Date/Time

Shows the date and time the event occurred in the format:

¨ numeric Year/Month/Day and Hour:Minutes (24-hour clock style).



Event Type

The type of event is listed:

¨ Error (an error number will also be listed)

¨ Info (an informational message)



Source

Shows the source of the event message. Some examples of message sources:

¨ NewsMonger (program started or stopped)

¨ The search engine reporting problems

¨ The Internet Thread message that reports search results



Event

The event that caused the message. Some examples:

¨ Program Started

¨ Search Stopped

¨ Search Started

¨ Search Finished

¨ Results of Query



Using Edit > Find

After search results are returned, you still may need help finding the terms you are searching. The Edit > Find function can be 
used:

To find terms in article subject lines:

1 Click on an article subject in the Status/Results View area.

2 Click Edit > Find. The Find dialog appears. NOTE: You can also display the Find dialog by pressing <Alt> + <F3>.

3 Type the term you want to find in the subject lines.

4 Select Match case if you want an exact capitalization match.

5 Select the direction you want to find: either up or down through the list.

6 Click Find Next.

The terms you specify are located and highlighted in the subject lines if they exist. If they are not there, you will hear a sound 
(if equipped for audio).

To find terms in articles:

1 Double-click on an article subject in the Status/Results View area. The article you want to find terms in must be displayed in 
the Article View area.

2 Click Edit > Find. The Find dialog appears.

3 Type the term you want to find in the subject lines.

4 Select Match case if you want an exact capitalization match.

5 Select the direction you want to find: either up or down through the list.

6 Click Find Next.

The terms you specify are located and highlighted in the subject lines if they exist. If they are not there, you will hear a sound 
(if equipped for audio).

To find the same term repetitively without going through all of these steps, see Using Edit > Find Again.



Using Edit > Find Again

The Edit > Find Again function can be used to find previously found terms:

To find terms in article subject lines (assuming you have already found the term once):

1 Click on an article subject in the Status/Results View area.

2 Press <F3>.

The terms you specify are located and highlighted repeatedly in the subject lines if they exist. If they are not there, you will 
hear a sound    (if equipped for audio).

To find terms in articles (assuming you have already found the term once):

1 Double-click on an article subject in the Status/Results View area. The article you want to find terms in must be displayed in 
the Article View area.

2 Press <F3>.

The terms you specify are located and highlighted repeatedly in the subject lines if they exist. If they are not there, you will 
hear a sound (if equipped for audio).



Using the NewsMonger SMTP Mail Client

The NewsMonger SMTP Mail Client window is used in replies to articles. You will use this feature when you want to reply to the 
individual who originated the article but do not want to post a reply to the USENET newsgroup to which it was posted.

1 Select the article in the Status/Results View area by double-clicking. The article contents appear in the Article View area.

2 Click Article > Reply by Mail…. The SMTP Mail Reply window appears.

3 Check the To: address at the top. If you want to add more addresses, separate them with a comma.

4 Add a CC: address if you wish.

5 The Subject: line reflects the title of the original article, prefixed with “Re:”

6 The body of the article to which you are replying is shown in the main reply window. Each line of the article is preceded with 
“>” to designate that it is quoted material.

7 Type your message to the originator in the space at the top of the text window (just below the Subject: line).

8 Click Send when you are ready for the message to be sent.



Setting Search Properties - General

Use the Search Properties dialog to set up your search. The General tab in the tabbed dialog is the first screen you encounter.

1 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

2 The General tab contains the name and description of your search. Type a new description if needed. You cannot change the 
name here.

See also:

Setting Search Properties: AltaVista 



What is Search History and how do I change it?

Search history options are set from the Search Properties tabbed dialog.

1 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

2 Click the Search History tab. The Search History tabbed dialog appears.

3 Set the number of days of news to search. The default seven days will result in a reasonable archive size to search; if you 
make it much longer, you will be searching older news. If you make the number of days shorter, you will search only the latest 
news. This factor impacts the number of hits returned (and possibly the quality of results).

4 Set the maximum number of hits to be reported for any search. The default 500 will result in reasonable search time; if you set 
it higher, you may get more hits, but the search time will be longer.

5 Use the Clear History Now button to remove results in the Status/Results View area from previous searches. This is handy 
if you are substantially changing the search parameters and the old results are no longer valid.

6 When you are finished with this dialog, click [OK].



How can I view my query?

Search Raw Query is viewed from the Search Properties tabbed dialog.

1 Click Search > Properties… with the primary mouse button. The Search Properties tabbed dialog appears.

NOTE: You can also get to the Properties dialog by using the search properties button on the NewsMonger toolbar or by 
clicking the secondary mouse button on the search name.

2 Click the Raw Query tab. The Raw Query tabbed dialog appears.

This read-only panel shows you the query language that is submitted to AltaVista. If you need to make changes, go back to 
either the Simple or Advanced Query tabs.



Using the NewsMonger NNTP News Client

The NewsMonger NNTP News Client window is used in replies to articles. You will use this feature when you want to post a 
reply to the USENET newsgroup to which it was originally posted.

1 Select the article in the Status/Results View area by double-clicking. The article contents appear in the Article View area.

2 Click Article > Reply by News…. The NNTP News Client window appears.

3 Check the Newsgroups: address(es) at the top. If you want to add more newsgroups, separate them with a comma.

4 Add a CC: address if you wish.

5 The Subject: line reflects the title of the original article, prefixed with “Re:”

6 The body of the article to which you are replying is shown in the main reply window. Each line of the article is preceded with 
“>” to designate that it is quoted material.

7 Type your message to the newsgroup in the space at the top of the text window (just below the Subject: line).

8 Click Send when you are ready for the message to be sent.

NOTE: Be aware that your message will be available to all subscribers of the newsgroup, perhaps thousands of individuals 
worldwide.



News Server Search      

NEW FEATURE: NewsMonger is able to search any news server you can point it to. This branch of the Tree View allows you to 
add news servers and shows searches you have created. This feature is designed to give you quick access to relevant news 
articles that may not be on the AltaVista archives. This includes:

n Intranet news servers (within your company’s firewall)

n Special purpose news servers (such as those established to support a product)

n News servers supported by your Internet Service Provider (ISP)

Click plus [ + ] to open the list in the Tree View; click minus [ - ] to close the list.

Click the secondary mouse button on the Servers branch to pop up a news server Add/Delete/Properties menu. 

n Add. Goes to the News Server Properties dialog to allow the user to add a news server to the list of available servers.

n Delete. Deletes the news server and any searches which search this server.

NOTE: A warning message alerts you that your searches will be deleted when you delete an associated news server. 

n Properties. Lists the properties (the name and authentication information) for an existing news server.

Click the secondary mouse button on the Searches branch or your list of searches to pop up the same menu as the Search drop-
down menu on the NewsMonger main screen. For the options, see also: Search Menu.



Servers      

NEW FEATURE: This branch of the Tree View shows a list of existing news servers you have defined and allows you to add 
news servers. Add a news server to the list with three methods:

1 Select or add a search and click [Add News Server] in the Search Properties dialog.

2 Click the Servers branch in the Tree View with the secondary mouse button.

3 Click the search properties button on the NewsMonger toolbar.

In both methods, the News Server Properties dialog pops up, allowing you to add the news server address, User ID, and 
Password.

Click plus [ + ] to open the Servers list in the Tree View; click minus [ - ] to close the list.



Searches: News Server      

A list of all the searches you have created for News Server search. Click plus [ + ] to open the list in the Tree View; click minus [ - 
] to close the list.

When you select a news server under the "Servers" branch, the List View displays the searches for that server. So, you can use 
this to list the searches for a specific server, view status, and click on a search to view the results.



List of Individual Searches: News Server      

When this item is opened, it shows is a listing in both the Tree View area and the Status/Results View area of all of your News 
Servers searches. 

Click plus [ + ] to open the list if there is more than one in the Tree View; click minus [ - ] to close the list.



How Can I Rename an Existing Search?

NEW FEATURE: You can easily rename a search using the same techniques used to rename files and directories in Windows 
Explorer (Windows 95 and NT 4.0).

Method 1:

1 Select and highlight the search name in the Tree View.

2 After a couple of seconds, click the search name a second time. (Do not double-click rapidly, as this will bring up the 
Properties dialog.)

3 Retype the name in the small highlighted box to rename the search.

4 Click elsewhere to save the new name.

Method 2:

1 Select and highlight the search name in the Tree View with the secondary mouse button.

2 From the list of commands that pops up, select Rename.

3 Retype the name in the small highlighted box to rename the search.

4 Click elsewhere to save the new name.

Method 3:

1 On the NewsMonger Main Screen, click Search > Rename.

2 Retype the name in the small highlighted box to rename the search.

3 Click elsewhere to save the new name.



Adding a News Server to Search

This procedure adds a news server to the list in the Tree View.

1 Click with the secondary mouse button the “Servers” item in the News Server Search branch of the Tree View.

The News Server Properties dialog appears.

2 Type the Server Name and User Name and Password, if required.

3 Click [OK] to save or [Cancel] to abandon.

If you clicked [OK] the news server is added to the list of servers and is available to build searches against.

See also:

Setting Search Properties: News Server 



Selecting Newsgroups to Search

To search for articles on a news server, you must define the newsgroups you want to include.

1 Click [Select Newsgroups…] on the Search Properties > News Server Query tab.

The Select Newsgroups to Search dialog box appears.

2 It takes some time for the newsgroup listing to be retrieved. When they arrive, the list box labeled “Newsgroups” will contain 
all available newsgroups on the news server.

3 Type some portion of the newsgroup name(s) you want to search in the text box labeled “List newsgroups which contain:” By 
entering very specific parts of newsgroup names, you can limit the number listed. In the example shown, the term “running” 
only appears in two newsgroups: pdx.running and rec.running.

NOTE: Used to easily find newsgroups in the list of Newsgroups. The Newsgroups list is updated automatically as you type, 
so you can experiment with different words to see what newsgroups are available in the bigger listing below.

4 Select the newsgroups you want from the list in the upper box by highlighting one or more, then click [Add] to include them in 
the “Selected Newsgroups” in the lower box. These are the newsgroups that your query will search. Use [Delete] to remove 
them. See Guideline Notes below.

5 You can repeat steps 3 and 4 as often as necessary to select other terms and newsgroups.

6 Click [Update List] any time to refresh the list of available newsgroups. This gets the current group list from the news server 
and may take some time to download, so frequent updates may not be useful or practical. Once a week is often enough 
unless you know a relevant newsgroup has been added to the news server and need to have it.

7 When you are satisfied that you have the right newsgroups selected, click [OK].

You are back on the Search Properties dialog. Complete the entries.

Guideline Notes:

n The list of the newsgroups available on the news server initially appears in the “Newsgroup” box.

n Newsgroups can be added to “Selected Newsgroups” either by a double click on a group in the list, or by selecting a group (or 
multiple groups) with the mouse and then clicking [Add].

n You can also select multiple items using standard selection methods for list controls:

¨ Select multiple groups by holding down the <Ctrl> key



¨ Select a series of groups by selecting the first and holding down the <Shift> key while selecting the last group in the 
series.

n A double click on an added group deletes it from the "Selected Newsgroups" list.

n A binocular icon shows which newsgroups have been added to the "Selected Newsgroups" list. This list is modified when you 
type in the "List newsgroups which contain" text box.

See also:

Setting Search Properties: News Server 



Optimizing News Server Searches

The best way to make NewsMonger results more meaningful is to determine your goals before you start, then develop news 
server searches to accomplish those goals.

For example, suppose you are in the sneaker business. Your company will soon be coming out with a hot new line of running 
shoes. You need information now about the market, potential buyers, their exercise preferences and habits, willingness to pay, 
and so forth. Consider some possible implications for your news server search:

¨ Since this is your business and you need a steady flow of really recent information, you might be right to consider searching 
the news servers instead of the AltaVista archive. That way, as soon as an article is published, it will be available for you 
search to find.

¨ Find out if there are any private industry news servers, or special interest newsgroups which are not part of public USENET 
news. For example, if your competitor hosts a news server for their customers, consider searching their newsgroup(s) as 
well as the generally available ones.

¨ You will want to keep on top of this quest! You may want to perform your searches manually and frequently or consider 
setting AutoSearch to frequently, at least once per day, for example.

¨ Since you are interested in only one type of shoe, you can construct your query to be very specific, eliminating noise in the 
results. Our example (seen in Setting Search Properties: News Server) searches three newsgroups (pdx.running, 
rec.running, and misc.fitness.aerobic) on one news server. The Subject line search terms are very specific: “jogging,” 
“running,” and “shoes” but the search is set up to look for the occurrence of ANY of the terms (because the chances of 
finding ALL of them in the same Subject line are slim). Some potential results are shown in: Example: Results from a News 
Server Search.

¨ Since this is a critical search and you do not really care how much time the computer takes to find the information you need, 
consider adding any other newsgroups or resources you can think of. Consider increasing the maximum number of results 
higher than the default 500.

Another example: You want to search for specific marketing announcements about Exchange Server product.

1 Add news server: msnews.microsoft.com to the Tree View list.

2 On the Create a Search screen, type the Search Name “Exchange Server Sales Info.”

3 Type a Description of the search, if desired.

4 Click [Select Newsgroups…].

5 On the Select Newsgroups to Search screen, select newsgroup(s) of interest. There are over a dozen Exchange-related 
newsgroups maintained by Microsoft in the microsoft.public.* batch of newsgroups.

6 Since you are interested in sales and marketing, you enter the terms: “exchange” and “sales” in the “List newsgroups which 
contain:” box. This narrows the list to one newsgroup: microsoft.public.usasalesinfo.exchange.

7 Click [Add] to add the newsgroup to the Selected Newsgroups list.

8 Click [OK] on the Select Newsgroups to Search screen.

9 On the Create a Search screen, click ON “Search Subject for” ALL, type “server” in the text box, and leave Ignore Case 
checked ON.

10 On the NewsMonger Main Screen, click the [Start Search] toolbar button. This is a fairly small search and will return results 
in a few seconds.

11 You will find this results in a very focused batch of results. You may now consider ways to broaden your search if you need 
additional sources of information.



Example: Results from a News Server Search

The example below shows results from the news server search that was set up in Setting Search Properties: News Server. 




