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Foreword
Nowadays information changes with the speed of light. To succeed, you have to know
about changes before your competitors. TimelyWeb will help you – it will notify you
about web resource change and will deliver the changed resource to your computer.
Whether you want to succeed in your business or just devote your free time to your
hobby, you have to be the first. So, stay informed with TimelyWeb.
Using TimelyWeb is not just easy – it's very easy. One click in Internet Explorer toolbar –
and you're sure you won't miss the resource change – TimelyWeb will periodically check
the resource and notify you whenever the change takes place. And that's not all – you
can tune up the application so that it will open the web page in browser or download the
file to your computer (1). If you are on a trip, the application will send a message to e-mail
or SMS (2).
You can also use the application to monitor availability of your own web site. If the site is
unavailable for some reason, you will be immediately notified (3). And – TimelyWeb is
completely free (4) to use! No advertisements, no nag screens, no time bombs!
(1) Requires Reget or Net Vampire or GetRight download manager.
(2) SMS is delivered via e-mail and requires presence of e-mail-sms gateway service offered by your mobile operator.
(3) Requires check interval of 5 to 10 minutes.
(4) TimelyWeb is absolutely free, but in order to utilize the full range of features you need to register (see V.2. TimelyWeb Registration
on page 49).

EldoS TimelyWeb™
Copyright © 2002 by EldoS Group. All rights reserved.

Copyright © 1998-2001 by Mikhail Chernyshev. All rights reserved.
http://www.eldos.org
support@eldos.org

http://www.eldos.org/
mailto:support@eldos.org
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I.1. What Is TimelyWeb
Is there a web page you visit to stay informed about changes of information? TimelyWeb
will watch this page for you and notify you in a number of ways. Save your time, money
and nerves – visit the pages when they are updated. Don't waste time looking at old web
pages!
TimelyWeb is capable not only for tracking changes, but also for downloading the
changed resources to your computer. Using TimelyWeb, you will always have the latest
version of your applications, drivers, or any other information you need on your
computer!
TimelyWeb is very easy to use! You add new link to your FTP file, Web page or directory
on the FTP server, you tune up some settings if necessary, and that's all! When the
resource is changed, you will be notified.

I.2. Main Features
TimelyWeb offers you a complete set of features that will automate the process of
updated content delivery to your computer:

 Monitoring of WWW and FTP resources;
 Analysis of dynamically generated web pages;
 Support for WWW, FTP and SOCKS proxies;
 Support for Secure HTTP (HTTPS) protocol (1);
 Monitoring of unlimited number of resources (2);
 Different notification methods –
• send an e-mail;
• display message;
• open web page;
• download file automatically (3);
• create visual difference page;
• execute any external application;
• send network message;
 Individual schedule for every task;
 Easy-to-use tree-like organization of data;
 Import and export of links to files in various formats;
 Automatic creation of web page screenshots;
 Integration with web browsers and download managers.

(1) In version 3.10 or better.
(2) Unregistered version can be used to monitor up to 10 links.
(3) Requires Reget or Net Vampire or GetRight download manager.

I.3. How Does It All Work?
TimelyWeb can track changes of any information that can be obtained using http://,
https:// and ftp:// protocols – no matter if it is a Web-page, some application
package or something else.
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TimelyWeb tracks the changes by obtaining the information about resource's size and
time of the last modification from the server, and comparing this information with the
previously stored one. Some web servers don't give any information about the size and
time of the resource. In this case TimelyWeb downloads the resource and checks its
size.

I.4. How to Use TimelyWeb
To monitor changes in net resources, you need to add their locations (often named
URL’s or links) to the application and set their properties. Once a link is added, it is
checked automatically once a specified period (you can change the default period using
default link properties or set a period for a link in Link properties (see III.2. Link
Properties on page 23).
When you have lots of links, it is reasonable to organize them into tree-like structure by
building a tree of folders where each folder can contain links and other folders. You can
add descriptions and notes to the links to make your structure more distinct.
In order to view selected links only (e. g. only the modified resources), you can use
filters located in the left panel of the main window (see II.1.4. Left Panel on page 12).
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II.1. Main Window
The EldoS TimelyWeb main window consists of standard elements like the toolbar and
the status bar and several panels and sub-widows that display different information.
These panels are fully resizable. To resize a panel, drag its boundary to a desired
direction.

II.1.1. Link Window
The link window is the main part of the TimelyWeb interface that represents the tree of
folders and links you want to monitor. Here you can make use of the tree structure to
organize your links to your convenience.
In the root folder called All interests you can create subfolders representing different
fields of your interests and containing links to web resources you want to monitor. Each
entry of the tree can have a description to remind you its purpose. Web resource entries
also have several fields that concern their modification status. An icon beside a web
resource entry also reflects current status of the link.
Right-click the table header to customize the table layout.
Right-click to open the pop-up menu that you can use to perform the same operations
that are available from the toolbar (see II.3. Main Toolbar on page 15).

Link Window

Information Window

Left Panel Protocol Window
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II.1.2. Information Window
The information window always shows the modification status of currently focused link.
You can hide or show the left panel the menu (see II.2.3. View Menu on page 14).
Right-click to open the pop-up menu that allows you to hide the information window.

II.1.3. Protocol Window
The Protocol window shows a report of what was done in order to track modifications of
a focused link. Here you can see all actions done by TimelyWeb and their results. You
can hide or show the left panel the menu (see II.2.3. View Menu on page 14).
Right-click to open the pop-up menu that allows you to select and copy the report
contents to the clipboard, to clear the log and to hide the protocol window.

II.1.4. Left Panel
The pane to the left of the other windows contains various additional controls and
information about your links’ status. These controls are organized into the following
boxes.
The Filter box allows you to temporarily hide some category of links in order to analyze
the others. For example, you would like to hide all non-modified links in order to
concentrate on the modified ones and visit the appropriate sites for updates. To use the
filter, clear the checkboxes of those categories that you don’t want to be displayed. For
the above example, uncheck the Not modified checkbox.
The Notes box always displays the memo (a long description) of a focused link (see
III.2.7. Memo on page 26).
The Statistics box displays the total number of monitored links, the number of links being
checked, the number of unreachable links etc.
You can hide or show the left panel the menu (see II.2.3. View Menu on page 14). Also
you can roll up or drop down an individual information box by clicking an arrow at the top
right of a box.
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II.2. Main Menu

II.2.1. File Menu
The File menu is used to load and save data to your hard drive and to exit the
application. Following commands are available:

Command Shortcut Description
Save Ctrl+S saves the links list
Import Ctrl+I imports links from a list on disk. You can import text files,

browser favorites, etc.
Export Ctrl+E exports links to an external file
Sleep F7 temporarily suspends scheduled modification tracking
Exit exits the TimelyWeb application

II.2.2. Edit Menu
The Edit menu is used to load and save data to your hard drive and to exit the
application. Following commands are available:

Command Shortcut Description
Copy Ctrl+Ins copies currently focused link to clipboard
Paste Shift+Ins pastes link from clipboard
Delete Del deletes currently focused link or folder
Find Ctrl+F searches a text in links, descriptions, URL’s, etc (see

IV.5. Search on page 32)
Find next F3 searches for the next occurrence of the search text
Properties F2 exits the TimelyWeb application
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II.2.3. View Menu
The View menu is used to hide and display elements of the TimelyWeb interface.
Following commands are available:

Command Description
Show horizontal lines shows horizontal lines in the tree of link window
Show vertical lines shows vertical lines in the tree of link window
Show information window shows/hides the information window (see page 12)
Show protocol window shows/hides the protocol window (see page 12)
Show left panel shows/hides the left panel (see page 12)
Show changed links displays a list of modified web resources (see IV.1. Link

States on page 29)
Show errors displays a list of errors occurred (see IV.8.2. Listing Errors

on page 35)
Options displays the application options dialog box (see III.1.1. Main

Options on page 19)

II.2.4. Links Menu
The Links menu is used to manage your links and the tracing process. Following
commands are available:

Command Shortcut Description
Add new link Ins adds a new link to the links’ tree
Create folder creates a new folder in the links’ tree
Check F8 checks the focused link for modifications
Open opens a submenu allowing you to choose one of

the browsers installed in your system to open the
focused link

Reset link state resets the focused link’s state to unchanged

Disable disables the focused link’s check
Check all F9 checks all links for modifications
Check unreachable rechecks all unreachable links for modifications
Default link properties opens default link properties (see III.2.3. Check

Period and III.2.4. Notifications on page 24)
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II.2.5. Help Menu
The Help menu is used to access the TimelyWeb help system, to contact the support
team, to reach the TimelyWeb web site, etc. Following commands are available:

Command Shortcut Description
Contents F1 opens the help contents
Feedback using a submenu, allows to request an information, report a

bug or suggest a feature
Homepage opens the TimelyWeb homepage
Tell a friend allows to tell a friend about TimelyWeb using an e-mail
Languages using a submenu, allows to choose an interface language or

to learn how to install new languages
Enter code prompts to enter the registration code (see V.2. TimelyWeb

Registration on page 49)
About opens the About TimelyWeb screen

II.3. Main Toolbar
Clicking the Save button of the toolbar saves your links’ tree to disk in
the TimelyWeb format. Shortcut: Ctrl+S. This is different from
exporting your links to an external file (see IV.6. Load and Save on
page 32 for details).
Clicking the Exit button exits the TimelyWeb application.

Clicking the Copy button copies currently focused link to clipboard.
Shortcut: Ctrl+Ins.

Clicking the Paste button pastes link from clipboard.
Shortcut: Shift+Ins.

Clicking the Delete button to delete the focused link or folder.
Shortcut: Del.

Clicking the Add new link button to add a new link. Shortcut: Ins.

Clicking the Create folder button to add a new folder.

Clicking the Properties button to edit the focused link or folder
properties (see III.2. Link Properties on page 23 and III.3. Folder
Properties on page 26).
Clicking the Reset link state button resets the status of the focused
link to unchanged.
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Clicking the Disable button disables monitoring for the focused link.

Clicking the Open link in browser button opens the focused link in
your default browser. Clicking the down arrow opens the drop-down
list allowing you to choose a browser to open the focused link.
Clicking the Check button starts checking the focused link.

Clicking the Check all button starts checking all links.

Clicking the Sleep button suspends all scheduled checks.

Clicking the Contents button opens the help contents.

Clicking the Request information buttonallows you to request
information about TimelyWeb using e-mail.

II.4. Hot keys
Hot keys are applicable when you work with main application window where your folders
and links are shown. Some of hot keys are only valid when some folder or link is
focused, e. g. check focused link command can be applied after you set focus to some
link.

Hot key Description
F1 launch TimelyWeb help
Ins add new link
Del delete selected links and/or folders
F2 modify link properties or folder properties
F3 reset link status to not modified

F8 check the focused link
F9 check all links
Ctrl-C copy link's address to clipboard
Ctrl-V paste link from clipboard
Ctrl-N create new file with links (registered version only)
Ctrl-O open other file with links (registered version only)
Ctrl-S save the links list
Ctrl-G open the focused link in browser
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III.1. TimelyWeb Options
TimelyWeb is a highly flexible application that you can tune up according to your own
preferences and needs. Application options’ dialog consists of several pages containing
logically grouped settings.

III.1.1. Main Options
The Main page of TimelyWeb options contains general TimelyWeb options –

• Start when Windows starts – when the option is enabled, every time you start
Windows, TimelyWeb is started automatically. This option places a link to Start
Menu, Programs -> StartUp folder. You can remove the link from that folder
manually if needed.

• Watch already modified links – this setting tells TimelyWeb to check the link on
schedule even if it is marked as modified. See IV.2.2. Checking Links on page 29
for details.

• Set state to "not modified" when the link is opened – TimelyWeb will reset link state
to not modified when you open the link in browser.

• Take description from Web page – enables importing description from the web
page META tags.

• Integration with Microsoft Explorer – this option enables a toolbar button and menu
item in Microsoft Explorer.  See IV.7.2. Integration with Browsers on page 34 for
details.

• Make screenshots – enables or disables automatic screenshot capturing. See
IV.13. Making Web Site Screenshots on page 42 for details).

• Show Tip Of The Day on startup – enables or disables Tip Of The Day dialog that
is shown when TimelyWeb is started.

• Save links list automatically – when the option is set the list is saved to disk
automatically once a specified period. When the options is not set, you need to
click Save button on the toolbar or use File -> Save menu command in the main
menu to save the list.

• Save backup copy – this setting determines whether a backup copy of the file is
created when you override it. When you save a file with the name that already
exists, it could be necessary to preserve the old file as a backup. This option is
useful only in the registered copy that lets you open and save files with different
names.

• Save application log – enables and configures the application log.
• Folder with data files – lets you to specify the folder where copies of downloaded

pages are stored.

III.1.2. Connection
The Connection page of TimelyWeb options lets you configure connection properties –

• Maximum number of attempts to connect – this is how many times TimelyWeb will
try to connect to WWW or FTP server and get information about the resource
before changing link state to error.

• Interval between attempts – defines the time interval between connection attempts.
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• Maximum number of concurrent connections – defines the number of links that
may be checked at the same time.

• Connection timeout – defines the period of time after which a server that does not
respond is regarded unreachable

• Use Passive mode for FTP connection – if your computer is behind a firewall, or
TimelyWeb is unable to connect to FTP servers, you may need to enable this
setting to solve the problem.

• Use this agent string for HTTP connections – lets you to specify how TimelyWeb
identifies itself to a web server. Default is TimelyWeb/<version>.

• Send cookies in HTTP requests – you can enable sending cookies to a remote
server when a resource is requested. Please note that cookies are collected
regardless of this option; thus, if you decide to use cookies in future, you will
already have a set of probably valid cookies. You can edit, add or delete cookies
for every link in the link's Advanced HTTP properties (see III.2.1. Main Link
Properties on page 24).

III.1.3. Proxy
The Proxy page of TimelyWeb options governs access to proxy servers. Proxy servers
are used in corporate networks and by some ISPs to reduce network load and/or for
security reasons. Due to errors in proxy server implementations, it is advisable not to
use proxy servers with TimelyWeb when possible. Let TimelyWeb try to access internet
resources directly.

• Use HTTP proxy – enables and configures use of HTTP proxy. This proxy is used
for Web links whose URLs start with http://). You need to specify location of a
proxy server in format http://address:port, where address is the name or IP
address of the proxy server, and port is a port number (commonly used values are
3128, 8080, 80; however, your server can have different port). Username and
password are optional; specify them when you are told to do so by your network
administrator or ISP support.

• Use FTP proxy – enables and configures use of FTP proxy. This proxy is used for
Web links whose URLs start with ftp://. You need to specify location of a proxy
server either as http://address:port or as ftp://address:port, where
address is the name or IP address of the proxy server, and port is a port number
(commonly used values are 3128, 8080, 80; however, your server can have
different port). Username and password are optional; specify them when you are
told to do so by your network administrator or ISP support.

Note that in most cases it is possible to use HTTP proxies to access FTP resources.
When you use FTP proxy to access FTP resources, set Proxy type to user@site. If you
are using HTTP proxy to access FTP resources, set Proxy type to HTTP.

III.1.4. Dial-up
If you use a dialup connection, it is handy to tell TimelyWeb about it. This way, if
TimelyWeb cannot access a resource because the dialup fail, it will not mark the link as
erroneous. Also TimelyWeb will not check the links when no connection is present.

• Always online.– set this option if you have a leased line (Local Area Network, xDSL
modem which is always online, etc).
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• Dial-up – when this option is on, TimelyWeb will check the selected connections,
and links will be checked only when there is a connection established. If there is no
connection, no checking is done. You can select "Use any connection" or choose
specific connections by checking the appropriate checkboxes.

• Dial using 2Connect – If you use EldoS 2Connect as a default dialer, TimelyWeb
can integrate with 2Connect and manage connections automatically (Please note
that 2Connect integration is smart enough to track when connection may be broken
and when you still use it). See more about 2Connect at
http://www.advanced-dialer.com.

III.1.5. E-Mail
When the link is changed or error is detected, you can choose to be notified by e-mail or
SMS. On the E-Mail page of TimelyWeb options you can setup e-mail delivery –

• From: address – the address that will be placed to From field of the e-mail letter.
This must be a valid e-mail address, otherwise some servers may fail to pass the
mail.

• Recipient address – the address to which e-mail notifications will be sent.
• Recipient address for SMS notifications – the address that is used to deliver SMS

message to your mobile phone. See IV.16. E-mail and SMS Notifications on
page 44 for details.

• Subject field for e-mail – you can specify the text that will be placed to Subject
field of your e-mail notifications. Please note that subject is added to e-mails only
(not to SMS).

• SMTP server address and port – here you specify the address of the server used
to send outgoing mail. This is the address that your Internet Service Provider (ISP)
has told you. If you are connected to a corporate network, you will probably need to
ask your system administrator or IT department specialist for an advice.

• POP3 server address and port – this information in needed if your SMTP server
requires ‘POP3 before SMTP’ authentication. This is usually not needed if you use
a public Internet connection (ISP).

• Delivery method – this option specifies, whether you send e-mail via MAPI (use
this option when you have MS Outlook Express or other MAPI-compliant e-mail
application and you want it to be used) or via your own SMTP client. Please note
that SMTP and POP3 server addresses are only needed when you use "Own
SMTP client" delivery method.

• Use authorization – defines whether authorization must be used to access the
SMTP server. Username and password can be specified for both MAPI and Own
SMTP client delivery methods. In MAPI delivery method user name and password
are used to create MAPI session. For the Own SMTP client delivery method. there
are two authorization schemes –
 POP3 before SMTP – In this scheme SMTP client establishes connection to

POP3 server and then uses SMTP as usual. User name and password are used
to connect to POP3 server.

 SMTP authorization – In this scheme the client uses username and password
during SMTP conversation with the server.

http://www.advanced-dialer.com/
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III.1.6. View
The View page of TimelyWeb options you can customize visual appearance of the
application –

• Show horizontal lines – specifies whether horizontal lines should be visible in the
links tree.

• Show vertical lines – specifies whether vertical lines should be visible in the links
tree.

• Show information panel – shows or hides the information window (see
II.1.2. Information Window on page 12)

• Show protocol window – shows or hides the protocol window (see II.1.3. Protocol
Window on page 12).

• Show left panel – shows or hides the left panel (see II.1.4. Left Panel on page 12).
• Highlight header captions – when you move the mouse cursor over a caption, it is

highlighted if this option is on.
• Highlight links – when you move the mouse cursor over a link, it is highlighted if

this option is on.
• Tree column contains... – here you specify the contents of the main (left-hand)

column of the links’ list. You can choose from the URLs and the descriptions.
• Action when the link is double-clicked group lets you choose the action to be taken

when you double-click a the link in links’ list
• System tray group lets you choose whether TimelyWeb places its icon to the

taskbar tray  –
 Minimize to tray – TimelyWeb icon is shown in tray when the application is

minimized.
 Always in tray – TimelyWeb icon is always shown in tray.
 Don't use – do not appear in tray.

• Hide program – lets you make the application invisible. In the invisible mode
TimelyWeb does not show an icon in the tray and in the taskbar. To show the
application window, restart TimelyWeb (first instance will be shown instead).

• Restore on double-click – when TimelyWeb is hidden to tray, this option allows you
to restore the application window by double-clicking on its icon in the tray.

III.1.7. Confirmations
On the Confirmations page of TimelyWeb options you can specify whether you will be
asked to confirm your action in the following cases –

• when you delete a link;
• when you delete several links at once;
• changing check period to less than one day.

III.1.8. Basket
In the Basket page of TimelyWeb options you can enable or disable the Drop Basket
and configure its properties. See more about using the Drop Basket on page 41.

• Show Drop Basket – choose if you want to display the Drop Basket.
• Open dialog to select destination folder – if this option is set, when you drop the

link to the basket, you are prompted to select a TimelyWeb folder to place the link
to.
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• Drop to selected folder – if this option is set, when you drop the link to the basket,
the link is placed to a pre-selected folder of TimelyWeb.

• Drop to root folder – if this option is set, when you drop the link to the basket, the
link is placed to the root TimelyWeb folder.

• Transparency level – can be set if you are running Windows 2000 or Windows XP.
Transparency level 255 makes the basket non-transparent.

III.1.9. Sound
You can configure TimelyWeb to play a sound when the link is changed or error is
detected. On the Sound page of TimelyWeb options you select what sounds will be
played.

• Click the Browse button to select a sound file.
• Use Disable all sounds option to mute the application. The sound options are not

cleared, so you will be able to return to previous settings by turning the Disable all
sounds option off.

III.1.10. Download
TimelyWeb supports integration with Reget, Net Vampire and GetRight download
managers. On Download page you can specify paths to download managers' executable
files. See more about integration with download managers on page 34.

• Click the Browse button to select the executable.
• Use Load path from system registry button to try to read the path from Windows

registry.

III.1.11. Browser
On the Browser page of TimelyWeb options you specify the browser that will be used to
open the links. You can select –

• System default browser (the one that is used when you click on Internet links in
different applications or help files);

• MS Internet Explorer;
• Netscape Navigator;
• Opera;
• Mozilla;
• Other browser (You will have to specify path to the browser’s executable file).

Please note that if you have selected system default browser, a link from TimelyWeb
may be opened in an existing browser window thus overriding its previous contents. To
prevent this, select specific browser.

III.2. Link Properties
Links have numerous properties; however, you don’t need to review all of them when
you set up a link. Some parameters can be defined globally, for all links at once. To do
so, it is necessary that a link has Use Extended settings option turned off. Extended
settings include check periods and error notifications. Use the Links -> Default link
properties menu command to set up the common options.
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III.2.1. Main Link Properties
• URL to monitor – this is the location of resource that is monitored. Please refer to

the detailed description on page 37.
• Advanced HTTP options are described in the IV.10. Advanced HTTP Properties on

page 38.
• URL to open – this is the location to open if you tell TimelyWeb to open this link in

browser. It may be different from the monitored link, because for some web pages
you will want to monitor a specific sub-resource of a page, but you need to open
the page itself.

• Description – description of the link. Here you can put any text that will remind you
later what is the link for. The experience of the current users tells us that it is not
reasonable to leave the description empty. Let the description be the most brief but
meaningful information about this link. Do not delay filling the link's description
field, or you may forget to do it later.

• Disable link check – enables or disables monitoring of the link. When you need to
temporarily disable monitoring of the given link, you can use this check box to mark
the link as ‘disabled’. A disabled link is not automatically checked for updates and
errors; however, you can always check the link manually.

• Use extended settings – overrides default link properties (check period and update
and error notifications). When you check this box, Check period and Notifications
pages appear. When a specific link needs special settings of the check period and
set actions on the link change or error, you have to check Use Extended Settings
and edit the settings using the appropriate Link properties pages.

• Use content analysis – enables or disables content analysis. Content analysis is
useful when the resource time and/or size cannot be determined or when only
some part of the text is important. See more about it in IV.14. Using Web Page
Content Analysis on page 42.

• Track differences in Web pages – enables or disables difference tracking. Please
refer for the details to IV.15. Web Page Difference Highlighting on page 44.

III.2.2. Login to Server
Here you specify user name and password necessary to access the password-protected
web resource.  If the link is protected, you have to enter the your username and
password so that TimelyWeb is able to access the resource. Note that if you don't
specify username and password, the link will be marked as erroneous, and no further
checking will be done.

III.2.3. Check Period
This page is visible when you check Use extended settings on the Main page of the Link
properties. Its contents are identical to the Check period page in the Default link
properties dialog –

• Check period – determines how often the link is checked. You can also limit checks
to certain time of day (specifying when the period starts and when it ends) and
certain days of week. Please note that if you have specified use of dial-up
connection in the application options (page 20) and no connection is present at the
time to check the link, no check will occur unless TimelyWeb is set to use
EldoS 2Connect to establish connection itself.

http://www.advanced-dialer.com/
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•  Check on startup – determines whether the link will be checked when TimelyWeb
is started. If this option is on, after TimelyWeb is started each link will be scheduled
for immediate check. Please note that if you have specified use of dial-up
connection in the application options (page 20) and no connection is present when
TimelyWeb is started, no check will occur unless TimelyWeb is set to use
EldoS 2Connect to establish connection itself.

• Check at any period of day – if you uncheck this option, you will be able to specify
the interval of the day when check is allowed. This way you limit checks to certain
time of day (specifying when the interval starts and when it ends) and certain days
of week. Please note that if you have specified use of dial-up connection in the
application options (page 20) and no connection is present at the time to check the
link, no check will occur unless TimelyWeb is set to use EldoS 2Connect to
establish connection itself.

• Check on any day of week – if you uncheck this option, you will be able to specify
the days of week when check is allowed. Please note that if you have specified use
of dial-up connection in the application options (page 20) and no connection is
present at the time to check the link, no check will occur unless TimelyWeb is set
to use EldoS 2Connect to establish connection itself.

III.2.4. Notifications
This page is visible when you check Use extended settings on the Main page of the Link
properties. Its contents are identical to the Notifications page in the Default link
properties dialog.
When TimelyWeb detects change of resource being monitored, or an error occurs, you
will be notified in one of the following ways –

• play a sound;
• show notification window;
• send e-mail notification. You can set e-mail delivery options in the application

options (page 21). See more in IV.16. E-mail and SMS Notifications on page 44).
Also some actions can be taken –

• copy resource address (URL) to clipboard;
• open the link in browser automatically;
• show web page changes that have been previously tracked (see IV.15. Web Page

Difference Highlighting on page 44);
• update screenshot. You can enable screenshots in the application options

(page 19). See more in IV.13. Making Web Site Screenshots on page 42).
• download file automatically using download manager (see IV.7.3. Integration with

Download Managers on page 34);
• execute an external application;
• send a message via local area network (see More ...)

If you want to change the notification type, invoke Default properties dialog using the
View menu and set the notification type on the Notifications page. See more about
notifications in IV.8. System Notifications on page 34.
Note: The above changes won't affect the links with Use extended settings option
turned off.

http://www.advanced-dialer.com/
http://www.advanced-dialer.com/
http://www.advanced-dialer.com/
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III.2.5. Analysis
This page is visible if you turn Use contents analysis option on the Main page. See more
in IV.14. Using Web Page Content Analysis on page 42.

III.2.6. Status
On the Status page you will find the following information –

• Current status – this field displays the state of the link.
• Size of the link contents – this is the size of the resource referenced by the link.
• Last changed – this is the date and time of the resource on server. Some servers

don't report this information, so the field may be blank. In this case you may
consider using context analysis for more correct monitoring.

• Last checked – this is the time of the most recent attempt to check the link.

III.2.7. Memo
Here you can place any information about the link. This is different from the description
of the link that will be displayed in the links’ tree. Use the Memo page to enter more
verbose description that will be displayed in the Notes box in the left panel (see
page 12).

III.2.8. Screenshot
TimelyWeb is capable of taking small screenshots of web pages being monitored. To
use this feature, you need to enable screenshots in the application options (page 19),
otherwise the Screenshot page will not be visible.
Click the Reload Now! button to update the screenshot. To allow automatic updates of
screenshots, turn the Update screenshot option on (Notifications page in the default link
properties or in link properties, see page 25).

III.3. Folder Properties
TimelyWeb folders have the following properties –

• name;
• description.

For easier navigation in folders with links, it is reasonable to add explicative descriptions
to folder names. For instance, a folder with links to different antiviral software could be
named ‘Antiviruses’ and described as ‘Antivirus software and news’.
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IV.1. Link States
Link can be in one of the following states: never checked, not modified, modified, not
found, connection error. If the link is marked as modified, you can reset its state to not
modified either manually via Links menu or automatically when you open a browser.
Automatic reset is turned on globally in application options (see page 19).

IV.2. Managing Links

IV.2.1. Adding a New Link
Adding new links is easy and can be done from TimelyWeb or a browser window, or
even from any other application!
To add a new link you can –

• press the Add New Link button on the toolbar;
• use Links -> Add new Link menu command;
• press Ins key when you are in main TimelyWeb window;
• drag a link from a browser window or any other application to the basket (see

IV.12. Using Drop Basket on page 41);
• use TimelyWeb toolbar button or ->TimelyWeb context menu item in Internet

Explorer (see IV.7.2. Integration with Browsers on page 34). In this case the
description for the new link can be added automatically from the page title (you
need to enable this option in the application options, see page 19).

• If you see a web page with Add to TimelyWeb link and TimelyWeb logo near this
link, you can click on this link, and the page will be added for monitoring
automatically.

The new link will be created in the currently focused folder (or in the folder of currently
focused link).
After that the dialog box will appear prompting you to enter the name of the link and
customize its properties.

IV.2.2. Checking Links
The links are checked automatically once a period that is specified in links’ properties
(see III.2.3. Check Period on page 24).
Also you can check a link at any time using the following procedure:
1. Select the link you want to check.
2. Click the Check the link button on the toolbar, or

use Links -> Check menu item, or
press F8.

You can adjust check period in the Link Properties dialog (see page 23; make sure that
Use Extended Settings option is on). You can also set default check period in the default
links’ properties (menu Links -> Default link properties).
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If a link is marked as modified, it is not checked again unless you have watch already
modified links option set in the application options (page 19). Normally you won’t
recheck already modified links in order to make sure you don’t forget to go to the link
and review the update.

IV.2.3. Deleting a Link
To delete the link, press the "Delete Link" button on the tool bar, or

use Edit -> Delete menu item, or
press Del.

When you do so, you will be prompted for the confirmation. If you like, you can turn off
the confirmation in the application options (page 19); however, it is better to keep this
confirmation on to help you keeping important links safe.

IV.3. Managing Folders
The web resources you are interested to monitor usually break down into several
categories that can help you organizing your work. It is reasonable to group resources of
categories in separate folders.
To do so,
1. create a folder and name it according to the chosen category;
2. drag all links of the category to this folder;
3. if necessary, add new links to this folder.
4. repeat from step 1 until all links will be categorized.

IV.3.1. Creating a New Folder
To create a new folder, click the Create folder button on the toolbar, or

use Links -> Create folder menu item
Note: Please note that a new folder will be created as a sub folder of the currently
focused folder. In order to create a folder of the first level, focus to the first line in the list
named All interests.
After that the dialog box will appear prompting you to name and describe the folder.

IV.3.2. Deleting a Folder
To delete a folder,

click Delete folder button, or
use Edit -> Delete menu item, or
select the folder and press Del.

Note: The focused folder or the folder with the focused link will be deleted. All folder
contents will be deleted too.



Part IV. Doing Things

TimelyWeb User Manual © 2002 by EldoS Group 3311

IV.4. Changing Options and Properties

IV.4.1. Changing Application Options
To change application options, you use View -> Options... menu item. The application
options dialog will appear. See III.1. TimelyWeb Options on page 19 for how to use the
application options.

IV.4.2. Changing Link Properties
To change the link properties, do the following –
1. Focus to the link;
2. Invoke Link properties dialog. To do so,

click Properties button on the toolbar, or
use Edit -> Properties menu item, or
press F4 (make sure that the proper link is focused).

See III.2. Link Properties on page 23 for how to use link properties.

IV.4.3. Changing Default Link Properties
To change a link’s properties used by default, invoke Default Link properties dialog by
Links -> Default link properties menu item. Please see III.2.3. Check Period and
III.2.4. Notifications on page 24 for details.

IV.4.4. Changing Folder Properties
To change a folder properties, do the following –
1. Focus the folder;
2. Invoke Folder properties dialog. To do so,

click the Folder properties button on the toolbar, or
use Edit -> Properties menu item, or
press F4 .

See more about folder properties in III.3. Folder Properties on page 26.
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IV.5. Search
You can search for any text string in your
links, and TimelyWeb supports search in the
link URLs, descriptions and ling descriptions.
To start a search, use Edit -> Find menu
item, or

press Ctrl+F.
The Search for… dialog will appear where
you can choose the search options. Click OK
button to find the first occurrence.
Now you can go through all the following
occurrences of the search text by using
Edit -> Find Next menu item, or

pressing F3.

IV.6. Load and Save
TimelyWeb supports an original file format that allows you to save the links’ tree you
create in the application. This tree will be loaded automatically on start of the application.
You can save the links by clicking the Save button on the toolbar, or

using menu File -> Save, or
pressing Ctrl+S.

EldoS TimelyWeb can also import and export links in several formats. Import and export
functionality is accessible via main menu, File -> Export and File -> Import commands.

IV.6.1. Importing Links
You can import links from files of the following formats:

 Plain list of links. Such list consists of links, one per line.
 Raw link import. In this mode the input file is parsed for WWW and FTP URLs and

all URLs that were found are imported.
 Import from Internet Explorer Favorites. In this mode you can import your collection

of favorite web pages.
To perform import of links, choose File -> Import command from the main menu (the
import wizard will appear).
On the first page of the wizard, you have to select one of the three options –

• File with links list (plain list of links). After you select this option and click the Next
button, you specify files to be imported on the second page of the wizard. Press
Finish to perform import.

• File with links (raw link import). After you select this option and click the Next
button, you specify files to be imported on the second page of the wizard. Press
Finish to perform import.
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• Internet Explorer favorites. After you select this option and click the Next button,
you will be prompted to specify the folder with IE favorites. Normally you use the
default folder (when you import IE favorites from your computer), or alternatively
you can select another folder with favorites saved from another system. Click
Finish to perform import.

IV.6.2. Exporting Links
You can export links to files of the following formats:

 Plain list of links. Such list consists of links, one per line.
 Internet Explorer Favorites. In this mode you can export your collection of

monitored links to the Internet Explorer or to some other application that can import
data from Internet Explorer Favorites

 HTML page. This lets you to create a series of HTML pages that contain all or
selected links.

To perform import of links, choose File -> Export command from the main menu (the
export wizard will appear).
On the first page of the wizard, you have to select one of the three options –

• Simple links list. On the next page of the wizard, you can choose what data will be
included to the list (URL, description) and specify the name of the file to export to.
Press Finish to perform export.

• Internet Explorer Favorites. On the next page of the wizard, you choose to use
default folder (if you want to export links to IE favorites on your computer) or select
a custom folder (when you want to transfer links to some other application or
export links to another computer). Press Finish to perform export.

• Generate web pages. On the next page of the wizard, you select a template file
that will be used for generation, and choose how many links will be placed on
single page. Press Finish to perform export.

IV.7. Working with Browsers
EldoS TimelyWeb supports integration with several popular browsers and download
managers in order to make your web link management easier.

IV.7.1. Opening a Link in Browser
You can configure TimelyWeb to open a link in a browser automatically. To use this
feature, you specify a browser to be used in the application options dialog (see
III.1.11. Browser on page 23).
Depending on the type of resource you are using, the browser offers you to download
this resource to your computer or to perform some other action. Make sure to check how
your selected browser behaves when trying to open the link before using this feature.
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IV.7.2. Integration with Browsers
EldoS TimelyWeb supports integration with Internet Explorer 4 and better. When you are
using Internet Explorer (IE), you can configure TimelyWeb to –

• add a button to IE toolbar. When you click this button, the address of the page
displayed in IE is added to TimelyWeb for monitoring;

• add a menu item to IE context menu. Context menu is the one that is displayed
when you right-click over some link. When you select this menu item, the link will
be added to TimelyWeb for monitoring.

When you add a link using a button or menu item, description of the link can be imported
from the page title and the link text respectively. You can enable this options in the
application options (see III.1.11. Browser on page 23).
You can enable or disable the integration with Internet Explorer in the application options
(see III.1.1. Main Options on page 19). Make sure to restart Internet Explorer after
switching the integration feature in order to make changes come into effect.

IV.7.3. Integration with Download Managers
EldoS TimelyWeb can automatically download the resource using one of the supported
download managers. The supported download managers are Reget, NetVampire and
GetRight.
Integration with other download managers like GetRight and GoZilla is planned for next
versions of TimelyWeb.
We recommend you to use Reget, the award-winning download manager with some
really effective features that are missing in other download managers.
You can configure integration (e. g. specify path to NetVampire and GetRight) using
application options (see III.1.10. Download on page 23).

IV.8. System Notifications
EldoS TimelyWeb can notify you about resource change or error during attempt to check
the resource for modifications. TimelyWeb can –

• play a sound;
• show the notification window;
• perform an automated action:
• copy resource location (URL) to the clipboard;
• open link in browser automatically;
• automatically schedule resource download using a download manager;
• update web site screenshot;
• send e-mail notification

Usually you specify what actions are taken in the Default link properties (menu item
Links -> Default link properties). If necessary, you can configure notifications for every
link using Link properties (make sure the Use extended settings option is on for the
chosen links).
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IV.8.1. Listing Changed Links
When TimelyWeb detects a resource update, it can notify you with a pop-up window with
the list of links that were changed (see III.2.4. Notifications on page 25).

This visual way is very handy to –
• see the name and description of the changed link;
• immediately open the link in a browser window;
• command a download manager to download the resource;
• just close the window;
• mark the link as unchanged;
• close the window and mark all links as unchanged.

IV.8.2. Listing Errors
When TimelyWeb detects an error, it can notify you with a pop-up window with the list of
errors (see III.2.4. Notifications on page 25).
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IV.8.3. Execution of External Applications
When TimelyWeb detects a resource update, it can execute external application. To
enable this feature, check the Execute external application option on in the Notifications
page. This page is available globally in the Default link properties dialog
(Links -> Default link properties menu item) or locally in the Link properties when you
override the default options (set the Use extended settings option on in the Link
properties, see page 24).
To set up the application execution, you specify its name and optionally some
parameters. In other words, you specify the external application’s command line. The
command line may contain macros that are expanded with values for the link that was
changed.
Macro is inserted as %mMacroName where MacroName is one of predefined macro
values. When the command line is to be executed, the whole macro (including %m and
braces) is replaced by the value calculated using the macro name. For example,
net send * %mDESC (%mURL) was updated

will be resolved as
net send * TimelyWeb homepage (http://www.timelyweb.com/) was
updated

The predefined macros are –
• DESC – short description of the link;
• URL – address of the link.

Note: Macro names are currently not case sensitive; however this may change in future,
so it is recommended to use the exact spellings.

IV.8.4. Network Messages
When TimelyWeb detects a resource update or an error, it can send a notification
message via LAN (local area network). To enable this feature, check the Send network
messages option on in the Notifications page. This page is available globally in the
Default link properties dialog (Links -> Default link properties menu item) or locally in the
Link properties when you override the default options (set the Use extended settings
option on in the Link properties, see page 24).
To configure the message sending, you specify one or more recipients and the message
text. Note: Recipients should be destination computer names, not the user names.
You can specify a domain name to send the message to all computers of the specified
domain, or specify * as a domain to send the message to all computers in the primary
domain.
The message text may contain macros that are expanded with values for the link that
was changed.
Macro is inserted as %mMacroName where MacroName is one of predefined macro
values. When the command line is to be executed, the whole macro (including %m and
braces) is replaced by the value calculated using the macro name.For example,
%mDESC (%mURL) was updated
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will be resolved as
TimelyWeb homepage (http://www.timelyweb.com/) was updated

The predefined macros are –
• DESC – short description of the link;
• URL – address of the link.

Note: Macro names are currently not case sensitive; however this may change in future,
so it is recommended to use the exact spellings.

IV.9. Resource Addresses

IV.9.1. Forming Resource Addresses
An address is a location (URL) of the resource that is being monitored. If you are adding
a link manually, you need to specify the URL. When the link is added using the Basket
or the context menu item in the Internet Explorer, the address is imported automatically.
The address is the only mandatory field in the link properties. Other properties will be set
to default values automatically.
An address usually looks like xxx:yyy/zzz, where

• xxx: – the protocol name. e. g. http://, https:// or ftp://. Note: The
protocol should be specified for TimelyWeb to work correctly.

• yyy – the server address, e. g. www.yahoo.com or ftp.cdrom.com.
• zzz – the resource location, e. g. /pub/.

For example, http://www.yahoo.com/ or ftp://ftp.cdrom.com/pub/ are valid
Internet addresses. You can set partial addresses also, but the protocol should be
specified.
Note that with links to FTP resources EldoS TimelyWeb can monitor both files and
directories on a server. For instance, you can add a link to ftp.cdrom.com/pub/, and
when any file in this directory is changed, added or deleted, you will be notified.

IV.9.2. Using Macros in Addresses
Starting from version 3.2, EldoS TimelyWeb supports macros in URLs. Macros let you
monitor URLs that are changed from time to time or wait for some resources to appear
(for example, if you want to get a fresh issue of the online magazine, you can monitor
the link of the monthly issue page. Such link usually includes the number or the month of
the magazine release).
Macro is inserted as %m{MacroName} where MacroName is one of the predefined
macro values.
When the URL is to be monitored, the whole macro (including %m and braces) is
replaced by the value calculated using the macro name. For example,
http://www.journal.org/issue-%m{CUR_YEAR_4}.html will be resolved as
http://www.journal.org/issue-2002.html.
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The predefined macros are –
• CUR_DAY – today's day of month number in short format (i. e. 1 for the first day of

month);
• CUR_DAY_Z – today's day of month number in 2-digit format (i. e. 01 for the first

day of month);
• PREV_DAY – yesterday's day of month number in short format (i. e. 1 for the first

day of month);
• PREV_DAY_Z – yesterday's day of month number in 2-digit format (i. e. 01 for the

first day of month);
• CUR_MONTH – current month number in short format (i. e. 1 for January);
• CUR_MONTH_Z – current month number in 2-digit format (i. e. 01 for January);
• PREV_MONTH – yesterday's month number in short format (i. e. 1 for January);
• PREV_MONTH_Z – yesterday's month number in 2-digit format (i. e. 01 for

January);
• CUR_YEAR_2 – current year number in 2-digit format (i. e. 02 for year 2002);
• CUR_YEAR_4 – current year number in 4-digit format (i. e. 2002 for year 2002);
• PREV_YEAR_2 – yesterday's year number in 2-digit format (i. e. 02 for year 2002);
• PREV_YEAR_4 – yesterday's year number in 4-digit format (i. e. 2002 for year

2002).
Yesterday's values are important when the resource is available only the next day: for
example server log for 1 Jan 2002 is available only on 2 Jan 2002, and to track when
resource is available, you need to use PREV_* macros.
Note: Macro names are currently not case sensitive; however this may change in future,
so it is recommended to use the exact spellings.

IV.10. Advanced HTTP Properties
When checking HTTP links, you can
set custom referrer string or tell
TimelyWeb to use POST request and
specify parameters for such request.
The advanced properties are invoked
using the Advanced HTTP button in the
main link properties (see page 24).

IV.10.1. Custom Referrer
A referrer is a field in HTTP request
that tells a server where the client has
obtained the link he is requesting. In
other words, this is the way a servers
‘learns’ about ‘from whom did you learn’
the address of the resource you
request. Some servers require specific
referrer to be specified (a sort of security feature).
If you can reach the page with a browser but get a server-generated error when using
TimelyWeb, you can try to find out the right value for referrer and specify it here.
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IV.10.2. POST Request
Usually data is requested using the GET command. However some pages can only be
accessed after you provide some information to server (POST this information); for these
cases you use the Post request option.
Post request parameters are specified as parameter-value pairs:
Param1=value1

Param2=value2

...

ParamN=valueN

TimelyWeb will post all parameters as specified.

IV.10.3. Cookies
Cookies are small pieces of information
that are stored by a server on the client
side and later sent back to server by
the client. Cookies are used to save
information that should not be lost
between requests to the same page or
the same site.
For example, when you go shopping in
an electronic store, you need to keep
your basket when you navigate through
the store. The server stores information
about your basket in cookies
associated with the site, and your
browser sends them back to the server
when you go to next page or to the
checkout. Some servers use cookies to
store your ID information, so you don't need to enter your username and password next
time you visit the site.
You can add the cookies manually using cookie manager that is located in Advanced
HTTP properties dialog. Each cookie consists of a name and a value. The cookie can be
applied to a single document, to a directory or to the whole site. To specify the target,
use the Path parameter.
Note: Cookies must be enabled if you use Extended Login feature for a link (see
IV.11. Extended Login on page 40).



Part IV. Doing Things

TimelyWeb User Manual © 2002 by EldoS Group4400

IV.11. Extended Login
Extended login lets you monitoring pages that are accessible only after you fill some
login form on a separate page.

IV.11.1. What is Extended Login
Extended login feature queries one or more URLs, optionally passing the data to an
URL, and gets the cookies from the server. Those cookies are later used to access the
actual page that is to be monitored. Please note that cookie management must be
turned on for the whole application (in the application options, see page 19) and for the
monitored page (in the Advanced HTTP properties (see IV.10.3. Cookies on page 39) in
the main link properties, see page 24).

IV.11.2. How to Use Extended Login
To use extended login, you have to do the
following.
1. Find out the URL of the page that is used

to enter login information (usually user
name/id and password). This is the page
that will be added as Extended login URL
in the Extended Login dialog (see
III.2.2. Login to Server on page 24).

2. Take a look through the page source to
find out which method is used to send the
user name and password to the server.
This requires from you some knowledge
of HTML. In brief, the text <form ...
method="post"> means that the data
are sent using POST method, while
<form ... method="get"> says about the GET method. Select the method in
Extended Login dialog.

3. Find out the parameters that are sent. Usually they look like <input type="text"
name="XXX"> and <input type="password" name="YYY">. You have to take
these XXX and YYY and create the parameters to be passed. In the Parameters box
of Extended Login dialog you enter
XXX=<your user name or user id or whatever you are asked for>
YYY=<your password>
where XXX and YYY are the names of the corresponding fields in the HTML form.

4. You can optionally specify a referrer page URL. This is the page from which you
usually get to login page. This can be a home page of the site or some ‘member
login’ page, etc.

All this information has to be set for one specific extended login URL.
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IV.11.3. Multi-level Extended Login
There are much more complex sites that require you to use some title page, then
proceed to login page and then get to the actual site. How do you know that you have
come across such site? Copy a login URL and paste it to the address field of the
browser. Then press Enter key to go to this location. If you finally are brought to some
‘welcome’ or ‘title’ page instead of the login page you wanted, then this is the case! Such
kind of sites requires a multi-level login. This is not a problem for TimelyWeb! You can
enter as much extended login URLs as necessary. Not all of them require parameters to
be passed. In this case leave Parameters box blank.
Not all the complex login scenarios can be handled by TimelyWeb. Some sites have
dynamically generated URLs for login pages, which can not be saved in TimelyWeb.
Other sites pass dynamic information in the text of web pages and require it to be
passed back in some way. Such sites can not be handled either. One of examples is
Yahoo Mail that attempts to block any automatic logins.

IV.12. Using Drop Basket
Using the drop basket is easy. First you need to make the basket visible and adjust its
transparency (Windows 2000 and XP only) in the application options (see page 22).
When the drop basket is visible, you can drag a link from a browser or other application
and drop it to the basket. To drag a link, press left mouse button when mouse cursor is
over the link, hold the button and move the mouse so that cursor is over the drop basket.
Release the mouse button.
When you drop the link to the basket, the window appears.
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You can choose to which folder the links will be added to, whether you want to specify
link properties after this window is closed, and whether you want to see this window next
time or let the links be dropped automatically to some folder.
If you specify to drop the links automatically, next time this window will not appear. You
can bring the window back using the application options (see page 22).

IV.13. Making Web Site Screenshots
EldoS TimelyWeb is capable of taking small screenshots of web pages being monitored.
To use this feature, you enable Make screenshots option in the application options
(see page 19).
You can allow the screenshots to be updated automatically by setting Update
screenshot option in Default link properties (Link -> Default link properties menu item).
You can also update screenshots manually with Update Now! button in the Link
properties dialog on the Screenshot page (see III.2.8. Screenshot on page 26).
Note: Screenshots feature requires Internet Explorer 5.0 or better.

IV.14. Using Web Page Content Analysis
There are web pages that, if TimelyWeb uses regular modification checking techniques,
will be reported as modified though no actual modification of significant contents took
place.
These pages can be split into two groups:

• resources for which TimelyWeb is not able to get the time and/or size;
• resources that are really changed but the changes are not important for you.

TimelyWeb is capable of handling both types of pages for you.
In the first case you just need to set Use content analysis option on in the Link properties
dialog (see page 24). Instead of checking the time and the size of the resource,
TimelyWeb will download the resource and compare it with the copy that was download
during the previous check.
In the second case, when you need to monitor only some specific changes (for example,
you need to monitor changes in a specific part of a web page), you can help TimelyWeb
a little bit by specifying blocks of page contents that must be included to or excluded
from monitoring. This is done on Analysis page in Link properties dialog (see page 26).
You add one or more rules that define the beginning and the end of fragment to include
or exclude. The fragment can be defined as you see it in a browser window (only visible
text) or as source code block (HTML page source).
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To specify the block to be included or excluded, you need to define the beginning and
the end of the block as follows:
<MyTag>This is sample data</MyTag>

To include or exclude This is sample data data block, you add <MyTag> as the
beginning of the block and </MyTag> as the end of the block.

Naturally, if the data changes and <MyTag> or </MyTag> are not found, the block will
not be detected. This means that you need to select the beginning and the end of block
in such a way that they are not likely to be changed or removed.

IV.14.1. Keywords Monitoring
From version 3.3 on TimelyWeb supports watching for keywords. There are cases when
even watching for content fragments is not enough – if you need to know when some
words or phrases appear on the web page. In this case you need to specify that only a
set of keywords is to be watched.
You can define one or more keyword watch rules that include present and not present
keywords. For example, you specify keyword sets as follows –
+include_word_1 +include_word_2 -exclude_word_1 -exclude_word_2

+include_word_3 +include_word_4 -exclude_word_3 -exclude_word_4
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This is how the above setting processed:
The fragment is considered as updated if at least one of the two keyword rules is true –

• include_word_1 and include_word_2 are present in the monitored resource,
and exclude_keyword_1 and exclude_keyword_2 are not present; or

• include_word_3 and include_word_4 are present, and
exclude_keyword_3 and exclude_keyword_4 are not present.

IV.15. Web Page Difference Highlighting
EldoS TimelyWeb is able to track differences between web page revisions and highlight
these pages. In other words, when some content on the web page is changed, you can
see old and new variants at the same time.
To use difference tracking, check Track differences in Web pages option in the Link
settings (see page 24). When a change is detected, you can open the web page with all
differences highlighted in one of two ways –

• manually using Links -> Open -> Highlight changes menu command, or
• automatically if you enable Show recent web changes option on the Notifications

page (see page 25). This page is available globally in the Default link properties
dialog (Links -> Default link properties menu item) or locally in the Link properties
when you override the default options (set the Use extended settings option on in
the Link properties, see page 24).

Note that if a link uses extended settings, the default link properties are not applied to
this link.

IV.16. E-mail and SMS Notifications
When some resource is updated or an error occurs, you can be notified by an e-mail or
SMS message. You will receive a message with resource name and time of change (or
error code and description).
To enable e-mail or SMS notification, do the following:
1. configure e-mail delivery in the application options (see III.1.5. E-Mail on page 21);
2. enable e-mail notification either in the Default link properties dialog (Links -> Default

link properties menu item), or in the Link properties when you override the default
options (set the Use extended settings option on in the Link properties, see page 24).

Note that if a link uses extended settings, the default link properties are not applied to
this link.
For a specific link, you can use one of two notification methods – e-mail or SMS. Both of
them are actually sending e-mail messages, but the letter format is different.
For e-mail notification (Use SMS format option is off), the complete template is used
(see page 21). Template includes description of the link (or description of error) and a
regular To: address (the address of the recipient) is used to send the message.
The SMS format is used to send messages to mobile phones and sometimes pagers. In
this case TimelyWeb uses a compact message template and the SMS To: address (the
address of the recipient).
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Usually you use your mobile number as a ‘name’ of the e-mail address. For example,
your mobile phone number is 3108432. Your mobile communications company runs an
e-mail-to-sms gateway, and they told you to use @sms.celltelecom.net as
a domain name. Then you need to put 3108432@sms.celltelecom.net as SMS
To: address.
Please note that in some cases you need to put your mobile number with you country
and area code, so your address may look like

1-435-3108432@sms.celltelecom.net or

14353108432@sms.celltelecom.net.
Before you use TimelyWeb SMS feature, please consult your mobile communications
provider about how to deliver SMS by e-mail. Then use the advised address as SMS
To: address in TimelyWeb.

IV.16.1. Recipient Address
You can specify one or more addresses in the To: field. Use semicolon (;) so separate
addresses in the list. For example, johndoe@mycompany.com;
billlee@affiliate.com.

You can also specify a filename of the recipient list. To do so, put @<full name of
the file with addresses> into the To: field, for instance,
@C:/Files_recepients.lst.
The list file should contain only the list of addresses, one address per line, e. g.
johndoe@mycompany.com

billlee@affiliate.com

IV.16.2. Remote Notification Templates
There are two templates available – one for SMS and one for regular e-mail. Templates
are located in the Template subfolder in the folder where TimelyWeb is located
(C:\Program Files\EldoS\TimelyWeb\ by default). Current version of TimelyWeb
does not support template editing; however, this feature is planned for future releases of
TimelyWeb.
In any case you can modify templates using a text editor like NotePad; however you
have to know exactly what you are doing to have the modified templates work properly.
Also please note that when you install a new version of TimelyWeb, it will override your
modifications.
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V.1. TimelyWeb Feedback
You may want to contact our software support team in order to request some
information, to report a bug or to suggest a new feature. This can be easily done by
e-mail using the Help -> Feedback menu command. You can also visit the EldoS
TimelyWeb home page http://www.timelyweb.com to check for updates, or send e-mail
to –

• support@eldos.org – TimelyWeb technical support;
• sales@eldos.org –  TimelyWeb sales and registration questions;
• info@eldos.org – other questions.

If you have not found an answer to your question in this manual and the TimelyWeb
help, please submit your question using the online form at
http://www.eldos.org/feedback.html or send your question to support@eldos.org. We will
answer your question promptly.

V.2. TimelyWeb Registration
You can use EldoS TimelyWeb without purchasing a license when you need to monitor
no more than 10 links. If you want to monitor more than 10 links, you need to purchase a
license.
The price of one single-user license is only $29.95 (1); we also offer flexible volume
discounts system (see below).
(1) We keep the right to change the price without special notification; please check http://www.timelyweb.com for an update.

V.2.1. How to Register
You can register the application –

• online (using secure internet connection);
• by faxing and order form;
• by phone call;
• by wire transfer;
• by check or cash.

If you don't receive the license and accompanying information during the defined time
(two business days when registering online with a credit card, or two weeks when
registering in other ways), please notify us immediately.
You can register EldoS TimelyWeb using –
https://www.regnow.com/softsell/nph-softsell.cgi?item=2126-5
or via secure registration service RegSoft –
http://www.regsoft.net/purchase.php3?productid=44139
(please use this latter link to get volume discounts!)
The above links offer you several ways of registering the software online, via phone call,
wire transfer or other mentioned ways of registration.

http://www.timelyweb.com/
mailto:support@eldos.org
mailto:sales@eldos.org
mailto:info@eldos.org
http://www.eldos.org/feedback.html
mailto:support@eldos.org
http://www.timelyweb.com/
http://www.regsoft.net/purchase.php3?productid=44139
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Volume discounts offered via RegSoft registration service are (1):
Number of license copies Cost of one license, USD
2-4 24.95
5-9 19.95
10-24 14.95
25 or more 9.95
Site license 249.95
Use the following link to order the site license:
http://www.regsoft.net/purchase.php3?productid=44139&pc=95w4F
(1) We keep the right to change the prices and discounts without special notification; please check http://www.timelyweb.com for
an update.

http://www.regsoft.net/purchase.php3?productid=44139&pc=95w4F
http://www.timelyweb.com/
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