
Welcome

JewelCase Maker is an easy-to-use utility that allows you to create and print your own CD labels and 
jewel case inserts as easy as one, two, three…

1. Simply design your custom label adding your own graphics and text.

2. Choose a paper type like the Avery 8931 or create one of your own.

3. Print your custom label.

Use NTI's JewelCase Maker    to create and print one or two-page front-cover inserts, back-cover 
inserts and CD labels. Adding text and graphics is easy with JewelCase Maker. Create your own 
menus or play lists then add in your favorite graphics and you have a new label for your personal CDs. 
You can use choose from existing graphics or create your own and all labels can be saved for later 
printing or editing.



Contacting Technical Support

Many different types of on-line help are available with JewelCase Maker within the specified 
applications.    You can browse through the JewelCase Maker Help file to become familiar with all the 
features available within that application.

You can also use context-sensitive help to display information about specific commands, dialog boxes, 
and other window elements.

If you still experience problems using JewelCase Maker that this documentation cannot solve, please 
submit the Technical Problem Report form which can be found on the CD-ROM disc (also available on 
our web site for download).    Help and information on the latest upgrades as well as a Technical Forum 
on Frequently Asked Questions (FAQs) can be found on our web site. 

Ê To request technical support from NTI:

If you have questions or technical issues to report to NTI, please COMPLETE and SUBMIT 
the TECHSUPT.DOC and email it to Support@NTIus.com. Without submission of this form, 
we regret that we will be unable to respond. 

You may download the Software Problem Reporter or locate it in the original product disc by 
following these steps: 

1. Put the JewelCase Maker product disc in your CD drive.

2. Click on My Computer.

3. Click on your CD-R/RW drive.

4. Click on techsupt.doc or techsupt.txt or techsupt.wri.

5. Fill it out and email it to Support@NTIus.com or FAX it to
(714) 259-9727.

THANK YOU FOR YOUR COOPERATION!



Answers to common questions

TO DO: Enter topic text here!



Online Help

Visit our online support page for additional information about our JewelCase Maker program. You will 
find items such as frequently asked questions (FAQs), tutorials and the latest downloads on our 
support site.



 Align Center

Centers the text displayed in the text object.



 Align Left

Left justifies the text displayed in the text object.



 Align Right

Right justifies the text displayed in the text object.



Delete

Deletes the selected object from the editing area. No copy is left on the clipboard. Use the Undo operation to restore a object 
deleted by mistake.



Font

Allows you to select the font, size and various other properties of the selected text.



Insert Text

Create and insert a new text object in the editing area. Use the mouse to position the text object and the format toolbar to control 
the look of the displayed text.



Edit Text

Enters edit mode for the selected text object.



HID EDIT JUSTIFICATION

TO DO: Enter topic text here!



Text Color

Allows you to select the color of the selected text object.



Move up one

Click this to move the selected object up one level from its current position on this page.



Bring to back

Click this to move the selected object to the bottom of all objects on this page.



Move down one

Click this to move the selected object down one level from its current position on this page.



Move up one

Click this to move the selected object up one level from its current position on this page.



Bring to front

Click this to move the selected object to the top of all objects on this page.



Rotate

Rotates the selected text object 90-degrees counter clockwise.



Zoom Select

Selects the zoom magnification of the editing area.



100% Zoom

Display the objects in the editing area at 100% magnification.



150% Zoom

Display the objects in the editing area at 150% magnification.



200% Zoom

Display the objects in the editing area at 200% magnification.



25% Zoom

Display the objects in the editing area at 25% magnification.



50% Zoom

Display the objects in the editing area at 50% magnification.



75% Zoom

Display the objects in the editing area at 75% magnification.



Custom Zoom

Select a user defined zoom setting.



Zoom

Selects the zoom magnification of the editing area.



Centimeters

Selects centimeters as the unit of measure for the ruler.



Inches

Selects inches as the unit of measure for the ruler.



Back Insert

Select this page to create the back cover for your jewel case.



CD Label

Select this page to create a label for your CD.



Front Insert

Select this page to create an outside of the front cover for your jewel case.



Inside Insert

Select this page to create an inside of the front cover for your jewel case.



Options

Customize JewelCase Maker settings.

Undo/Redo

Up to - Enter the maximum number of operations that can be undone/redone.

Print Outline

Click the line style to be used to print the label outline.

None - Do not print the label outline.

Dash - Print the label outline with a dashed line.

Solid - Print the label outline with a solid line.



Spot 1    X offset

Enter the offset from the far left side of the page. See the Paper Layout for the offset for this page type.



Spot 1 Y offset

Enter the offset from the top of the page. See the Paper Layout for the offset for this page type.



Custom Zoom

Enter your custom zoom setting and click OK to save or Cancel to exit the dialog box without saving.



Add Paper Name

Enter the name of the custom paper definition.



Spot 2 X offset

Enter the offset from the far left side of the page. See the Paper Layout for the offset for this page type.



Spot 2 Y offset

Enter the offset from the top of the page. See the Paper Layout for the offset for this page type.



Spot 3 X offset

Enter the offset from the far left side of the page. See the Paper Layout for the offset for this page type.



Spot 3 Y offset

Enter the offset from the top of the page. See the Paper Layout for the offset for this page type.



Include Spot 1

Include this spot in the page setup.



Include Spot 2

Include this spot in the page setup.



Include Spot 3

Include this spot in the page setup.



Standard Paper Size

Selects the standard paper size. (8.5" x 11" or 21.6 x 27.9 cm)



Paper Type

Click one of the defined paper types to use for this label.



Name

Enter a name for the label definition you are creating.



Height

Displays the height of the label paper. If the standard option is not checked, enter the height of the paper here.



Width

Displays the width of the label paper. If the standard option is not checked, enter the width of the paper here.



Add Button

The Add button allows you to create a custom label definition.



Edit Button

The Edit button allows you to edit your custom label definitions.



Remove Button

The Remove button allows you to delete the selected label definition.



Back (U-Card)

Use this for jewel case back cover inserts.



CD Label

Use this option for CD labels.



Front/Inside

Use this for single or two-sided front jewel case inserts



Centimeter

Use centimeters as the unit of measure for this label.



Inch

Use inches as the unit of measure for this label.



Landscape

Prints your labels so that the long edge of the paper is the top of the label.



Portrait

Prints your labels so that the short edge of the paper is the top of the label.



None

Do not print the label outline.



Dash

Print the label outline with a dashed line.



Solid

Print the label outline with a solid line.



Undo/Redo Count

Enter the maximum number of operations that can be undone/redone.



Undo/Redo Count

Enter the maximum number of operations that can be undone/redone.



Paper Layout

Shows how your label(s) will look with the selected options.



Orientation

Selects the paper orientation for this label definition.



Page

Select the type of label definition you are creating.



Paper Size

Select the size of the paper you are using for the desired label type. Checking the "Standard" option disables the height and 
width items and selects 8.5" x 11" paper.



Spot 1

Set the offset for the first label on this page. Spots must be included (Include checked) and a valid x & y offset specified. An 
outline of the included spot(s) will be visible in the paper layout window.



Spot 2

Set the offset for the second label on this page. Spots must be included (Include checked) and a valid x & y offset specified. An 
outline of the included spot(s) will be visible in the paper layout window.



Spot 3

Set the offset for the third label on this page. Spots must be included (Include checked) and a valid x & y offset specified. An 
outline of the included spot(s) will be visible in the paper layout window.



Spot Offset

Set the label offset for one to three labels for this definition. The offset will be measured from the upper left corner for inserts and 
u-cards and from the center for CD labels.



Standard Paper Size

Selects the standard paper size. (8.5" x 11" or 21.6 x 27.9 cm)



Unit

Selects measurements in either inches or centimeters.



Options

Customize JewelCase Maker settings.

Undo/Redo

Up to - Enter the maximum number of operations that can be undone/redone.

Print Outline

Click the line style to be used to print the label outline.

None - Do not print the label outline.

Dash - Print the label outline with a dashed line.

Solid - Print the label outline with a solid line.

OK 

Applies and saves any changes you have made and then closes this dialog box.

Cancel Button

The Cancel button closes this dialog box without saving any changes you have made.



Add/Edit printing paper

Create or modify your own custom label paper definition.

Name (Up to 50 characters)

Enter a name for the label definition you are creating.

Page

Select the type of label definition you are creating.

Front/Inside 

Use this for single or two-sided front jewel case inserts.

Back (U-Card) 

Use this for jewel case back inserts.

CD Label 

Use this option for CD labels.

Paper Size 

Select the size of the paper you are using for the desired label type. Checking the "Standard" option disables the height and 
width items and selects 8.5" x 11" paper.

Standard Checkbox 

Selects the standard paper size. (8.5" x 11" or 21.6 x 27.9 cm)

Width

Displays the width of the label paper. If the standard option is not checked, enter the width of the paper here.

Height

Displays the height of the label paper. If the standard option is not checked, enter the height of the paper here.

Unit 

Selects measurements in either inches or centimeters.

Inch 

Use inches as the unit of measure for this label.

Centimeter 

Use centimeters as the unit of measure for this label.

Orientation 

Selects the paper orientation for this label definition.

Portrait 

Prints your labels so that the short edge of the paper is the top of the label.

Landscape 

Prints your labels so that the long edge of the paper is the top of the label.

Spot Offset 

Set the label offset for one to three labels for this definition. The offset will be measured from the upper left corner for inserts and 
u-cards and from the center for CD labels.

Spot 1 

Set the offset for the first label on this page. Spots must be included (Include checked) and a valid x & y offset specified. 
An outline of the included spot(s) will be visible in the paper layout window.

Include 

Include this spot in the page setup.

X offset

Enter the offset from the far left of the page.

Y offset

Enter the offset from the top of the page.



Spot 2

Set the offset for the second label on this page. Spots must be included (Include checked) and a valid x & y offset 
specified. An outline of the included spot(s) will be visible in the paper layout window.

Include 

Include this spot in the page setup.

X offset

Enter the offset from the far left of the page.

Y offset

Enter the offset from the top of the page.

Spot 3

Set the offset for the third label on this page. Spots must be included (Include checked) and a valid x & y offset 
specified. An outline of the included spot(s) will be visible in the paper layout window.

Include 

Include this spot in the page setup.

X offset

Enter the offset from the far left of the page.

Y offset

Enter the offset from the top of the page.

Paper Layout 

Shows how your label(s) will look with the selected options.

OK

Applies and saves any changes you have made and then closes this dialog box.

Cancel Button 

The Cancel button closes this dialog box without saving any changes you have made.

Help Button

The Help button displays help for this dialog box.



Page Setup

The page setup dialog allows you to select the paper definition to be used for each page of your CD label or jewlelcase inserts. 
You can also add or edit your own custom paper definitions from this dialog.

Front/Inside Tab 

Select the desired paper definition to be used to print your front/outside and inside jewel case inserts. 

Paper Type 

Click one of the defined paper types to use for this label.

Edit 

The Edit button allows you to edit your custom label definitions.

Remove 

The Remove button allows you to delete the selected label definition.

Add 

The Add button allows you to create a custom label definition.

Back (U-Card) Tab 

Select the desired paper definition to be used to print your jewel case back cover insert.

Paper Type 

Click one of the defined paper types to use for this label.

Edit 

The Edit button allows you to edit your custom label definitions.

Remove 

The Remove button allows you to delete the selected label definition.

Add 

The Add button allows you to create a custom label definition.

CD Label Tab 

Select the desired paper definition to be used to print your CD label.

Paper Type 

Click one of the defined paper types to use for this label.

Edit 

The Edit button allows you to edit your custom label definitions.

Remove 

The Remove button allows you to delete the selected label definition.

Add 

The Add button allows you to create a custom label definition.

Layout 

Shows how your label(s) will look with the selected paper type..

OK 

Applies and saves any changes you have made and then closes this dialog box.

Cancel Button



The Cancel button closes this dialog box without saving any changes you have made.

Help Button 

The Help button displays help for this dialog box.



About JewelCase Maker

Displays version and program information about JewelCase Maker.



Context Sensitive Help

Displays help information for the selected item. Click the context help button and the cursor changes to the help cursor. Then 
click on the item you want more information about.



Help Topics

Displays the JewelCase Maker online help system.



Status Bar

The status bar contains the following information about the operation and state of the JewelCase Maker program. It can be 
hidden or displayed from the view menu to allow more room for editing when necessary.

· Message Area
The message area provides prompts and other information about objects under the cursor. When over a toolbar or 
menu item it will display a short message indicating what that item does within the JewelCase Maker program. If the 
cursor is positioned over the edit area the exact x-y offset of the cross-hair cursor is displayed.

· Zoom
Displays the magnification (zoom) of the editing area.

· Caps Lock
Displays the current state of the Caps Lock key on your keyboard.

· Num Lock 
Displays the current state of the Num Lock key on your keyboard.

· Scroll Lock 
Displays the current state of the Scroll Lock key on your keyboard.

{button See Also,AL(`Hide_Status;View_Status',0,`',`')}



Editing Area

This is where you insert and arrange your graphic and text objects. You are allowed to create your own graphic object or select 
one from a previously saved file. Graphic objects can be positioned in on top of or under other objects, selected, moved and 
resized with the mouse or even edited by double clicking and entering the graphics application that you have previously installed 
for that type of graphics file.

Text objects can be added to create play lists or other labels. They can be rotated and the format toolbar gives you full control 
over fonts and other properties.

Ruler
The ruler in positioned at the top and left side of the editing area. It can be displayed or disabled at your convenience and the 
unit of measure can be set to either inches or centimeters from the Options dialog.

Label/Insert outline
The label outline is displayed to show the boundaries for the label you are editing. The page selected on the Page toolbar 
determines the type of outline displayed.

Cross-hair cursor

Cross-hairs are displayed when moving the mouse over the editing area. The exact x-y offset is displayed in the message area 
of the status bar.



View Menu - Status Bar

The status bar contains the following information about the operation and state of the JewelCase Maker program. It can be 
hidden or displayed from the view menu to allow more room for editing when necessary.

· Message Area
The message area provides prompts and other information about objects under the cursor. When over a toolbar or 
menu item it will display a short message indicating what that item does within the JewelCase Maker program. If the 
cursor is positioned over the edit area the exact x-y offset of the cross-hair cursor is displayed.

· Zoom
Displays the magnification (zoom) of the editing area.

· Caps Lock
Displays the current state of the Caps Lock key on your keyboard.

· Num Lock 
Displays the current state of the Num Lock key on your keyboard.

· Scroll Lock 
Displays the current state of the Scroll Lock key on your keyboard.

{button See Also,AL(`Hide_Status;View_Status',0,`',`')}



Insert New Object

Create a new graphic object from and existing graphic file or create your own using the graphic editor. Graphic objects can be 
edited using graphics applications previously installed on your computer. For example, bitmap files can be created using the 
graphic editor installed with Windows. Help information is available with from the documentation or help files installed with the 
corresponding application.



Bold

Allows you to change the font of the selected text object to bold face



Font

Selects the current font for the text being displayed in the text object.



Font Size

Selects size of the current font for the text being displayed in the text object.



Italic

Allows you to change the font of the selected text object to italic.



Underline

Allows you to underline the selected text object.



Copy

Copies the selected object to the clipboard for later use.



Cut

Removes the selected object from the editing area but leaves a copy of the object in the clipboard for later paste operations.



Edit - Object

Allows you to edit the selected graphic object.



Paste

Pastes the contents of the clipboard in the editing area.



Redo

Re-applies the last undone operation to the current label design.



Edit - Select All

Selects all objects in the editing area for the current page.



Undo

Removes the last operation done to the current label design. The maximum number of operations allowed to be removed and 
restored can be set from the Options dialog. The default value is seven operations.



File - Exit

Exits the JewelCase Maker program.



New

Allows you to create a new label set definition.



Open

Allows you to open a previously saved label set for editing or printing.



File - Page Setup

Select or create paper type definitions for printing labels.



Preview

Allows you to view the current label set before printing.



Print

Prints the current label set.



File - Recent Files

Displays the more recently used label sets.



File - Save As

Allows you to save the current label set to a disk file on your computer.



Save

Allows you to save the current label set to a jewel case file (.jwc) on your computer.



JewelCase Maker Main Toolbar

The main menu give you easy access to many of the basic JewelCase Maker functions and features. It can be removed from the 
View menu to provide additional editing room if necessary.

New
Allows you to create a new label set definition.

Open
Allows you to open a previously saved label set for editing or printing.

Save 
Allows you to save the current label set to a jewel case file (.jwc) on your computer.

Preview 
Allows you to view the current label set before printing.

Print
Prints the current label set.

Undo
Removes the last operation done to the current label design. The maximum number of operations allowed to be removed and 
restored can be set from the Options dialog. The default value is seven operations.

Redo
Re-applies the last undone operation to the current label design.

Delete
Deletes the selected object from the editing area. No copy is left on the clipboard. You can use the Undo operation to effectively 
“undelete” the object if necessary.

Cut
Removes the selected object from the editing area but leaves a copy of the object in the clipboard for later paste operations.

Copy
Copies the selected object to the clipboard for later use.

Paste
Pastes the contents of the clipboard in the editing area.

About JewelCase Maker
Displays the version and program information about JewelCase Maker.

Help
Displays help information about the next object you select with the mouse.

{button See Also,AL(`Hide_Main;View_Main',0,`',`')}



View - Toolbar

The main menu give you easy access to many of the basic JewelCase Maker functions and features. It can be removed from the 
View menu to provide additional editing room if necessary.

New
Allows you to create a new label set definition.

Open
Allows you to open a previously saved label set for editing or printing.

Save 
Allows you to save the current label set to a jewel case file (.jwc) on your computer.

Preview 
Allows you to view the current label set before printing.

Print
Prints the current label set.

Undo
Removes the last operation done to the current label design. The maximum number of operations allowed to be removed and 
restored can be set from the Options dialog. The default value is seven operations.

Redo
Re-applies the last undone operation to the current label design.

Delete
Deletes the selected object from the editing area. No copy is left on the clipboard. You can use the Undo operation to effectively 
“undelete” the object if necessary.

Cut
Removes the selected object from the editing area but leaves a copy of the object in the clipboard for later paste operations.

Copy
Copies the selected object to the clipboard for later use.

Paste
Pastes the contents of the clipboard in the editing area.

About JewelCase Maker
Displays the version and program information about JewelCase Maker.

Help
Displays help information about the next object you select with the mouse.

{button See Also,AL(`Hide_Main;View_Main',0,`',`')}



Page Layout

Displays the layout of the selected paper type.    For paper types containing more than one label, select the lable to use for this 
printing. Select multiple spots to create additional copies of this CD label or jewelcase insert.





Hiding the Toolbar

To Hide the Toolbar:

1. Click the Toolbar item from the View Menu. You should see a small check mark to the right of the Toolbar item and the 
Toolbar should now be displayed at the top of the main program window.



Viewing the Toolbar

To View the Toolbar:

1. Click the Toolbar item from the View Menu. You should no longer see a small check mark to the right of the S Toolbar item 
and the Toolbar should now be invisible.



Hiding the Status Bar

To Hide the Status Bar:

1. Click the Status Bar item from the View Menu. You should see a small check mark to the right of the Status Bar item and 
the Status Bar should now be displayed at the bottom of the main program window.



Viewing the Status Bar

To View the Status Bar:

1. Click the Status Bar item from the View Menu. You should no longer see a small check mark to the right of the Status Bar 
item and the Status Bar should now be invisible.



Opening an existing label set

To Open an existing label set:

1. Click the Open button from the Main    toolbar or select Open from the File Menu.

2. Locate the desired label set file (.jwc) using the Open dialog controls.

3. Click the Open button. The label definition should be displayed in the JewelCase editing area and is ready for printing or 
modification.



Saving a label set

To Save the current label definition:

1. Click the Save button on the Main toolbar or select Save from the File Menu.

2. Select the directory in the Save In combo box.

3. Enter the name for this label set in the Name box.

4. Click Save. JewelCase Maker will save the current label set definition file (*.jwc) to the file you specified.



Creating a new label set

To create a new label set:

1. Click the New button from the Main toolbar or select New from the File Menu.

2. JewelCase Maker resets the editing area and is ready to create a new label set.



Printing with JewelCase Maker

Printing with JewelCase Maker is easy. In a few clicks of your mouse you can be printing your own CD labels and jewelcase 
inserts. JewelCase Maker uses easy Window's printing features to print the labels you designed. You can even use the Print 
Preview feature to see what your label will look like before it is printed.

It is easier to print each page of your label set individually. It is also recommended that you use your printer's manual feed option 
if available. Every label set can contain up to four different pages: 

1. Front/Outside cover 

2. Inside insert

3. Back (U-Card) insert 

4. CD Label

Each page above corresponds to pages 1 to 4 in the Print Range option of the Print dialog. To print a jewelcase cover from the 
Print dialog, simply select the Pages option and then enter from 1 to 1 in the Print Range option. Load the proper paper into your 
printer and click OK to print the Front/Outside insert. All other pages are printed just as easily. Remember that the inside insert, 
when desired, is printed on the reverse side of the Front/Outside insert. You will have to feed it through the printer reversed once 
the front side has been printed. Always let the ink dry before printing the inside insert.



Previewing a label set before printing

To preview a label set before printing:

1. Load the desired label set into the editing area. See Opening or Creating a New label set definition.

2. Click the Preview button from the Main toolbar or select Preview from the File Menu.

3. JewelCase Maker displays all defined pages in the preview window. You can see your label just like it would appear if it 
were printed. You can print the label from the preview window or return to the editing area for additional modifications or 
saving.

Note: All pages must have a paper type selected before they can be printed or previewed. If you have not selected a paper 
type for each page the Page Setup dialog will be displayed to allow you to make the appropriate selections before the preview 
window is displayed.



Printing a label set

To print a label set:

1. Load the desired label set into the editing area. See Opening or Creating a New label set definition.

2. Click the Print button from the Main toolbar or select Print from the File Menu.

Note: All pages must have a paper type selected before they can be printed or previewed. If you have not selected a paper 
type for each page the Page Setup dialog will be displayed to allow you to make the appropriate selections before the preview 
window is displayed.



Printing multiple copies of the same CD label on the same page.

To print multiple copies of the same CD label on the same page:

1. Load the desired label set into the editing area. See Opening or Creating a New label set definition.

2. Select the Page Setup item from the File Menu to open the Page Setup dialog.

3. Select a paper type that has multiple spots (labels) per page.

4. Click on the numbers of spots in the page Layout area.

5. Click the Print button from the Main toolbar or select Print from the File Menu.

Note: JewelCase Maker will print the defined label to the selected spots in the layout area. Paper types with multiple spots can 
be used to create more than one copy of the same label per page.



Using Paper Types

You can use predefined label stock like Avery 8931 Insert or Avery 5824 Disc for your jewel case and CD labels. These 
predefined papers are perforated for easy use. JewelCase Maker comes with several predefined paper definitions. In addition to 
these predefined paper types, JewelCase Maker allows you to create you own custom paper types. You can select, add, edit or 
remove any of these custom paper types from the Page Setup dialog.

In some cases you may not be using a predefined label stock or your label stock is not listed in JewelCase Maker's selection of 
paper types. In these instances, you can define a new paper type by selecting the type of label and other parameters like paper 
size, orientation, unit of measure and how many labels (spots) can be printed on this page. All settings are available on the Add 
paper dialog. The paper layout area shows the location of the label(s) and the printed page. As noted below, the spot offset is 
measured from the upper left corner for inserts and from the center of the label for CD labels. You may include from one to three 
spots per page.



Selecting a paper type

To select a paper type:

1. Select the Page Setup item from the File Menu.

2. Choose the tab for the desired page type.

3. Select the desired paper type.

4. Click OK to save the paper type selection.

Note: All pages must have a paper type selected before you can preview or print your labels. JewelCase Maker will display the 
Page Setup dialog should you try to print or preview a page before selecting the proper paper type for that page.



Creating a new paper type

You define a new paper type by selecting the type of label and other parameters like paper size, orientation, unit of measure and 
how many labels (spots) can be printed on this page. All these settings are available on the Add paper dialog. The paper layout 
area shows the relation between the spot offsets and the printed page. As noted below, the offset is measured from the upper left 
corner for inserts and from the center of the label for CD labels. You may include from 1 to 3 spots per page.

To create your own paper type:

1. Select the Page Setup item from the File Menu.

2. Choose the tab that will be using the paper type you are creating.

3. Click the Add button.

4. Use the Add printing paper dialog to create the new paper type.

5. Click OK to save the paper type you just created.

Note: Use the Paper Layout area of the Add printing paper dialog to view your settings for the new paper type you are 
defining. 



Editing an existing paper type

To edit an existing paper type:

1. Select the Page Setup item from the File Menu.

2. Choose the tab that will be using the paper type you are creating.

3. Select the custom paper type to be edited.

4. Click the Edit button.

5. Use the Edit printing paper dialog to modify the selected paper type.

6. Click OK to save your changes.

Notes:

· Use the Paper Layout area of the Edit printing paper dialog to view your settings for the paper type you are modifying. 

· Only custom paper types can be edited. The Edit button will be disabled when a predefined paper type is selected.



Removing an existing paper type

To remove an existing paper type:

1. Select the Page Setup item from the File Menu.

2. Choose the tab that will be using the paper type you are creating.

3. Select the custom paper type to be removed.

4. Click the Remove button.

5. You will be prompted to confirm the removal of the selected paper type. Click Yes at this prompt if you do wish to remove 
this paper type.

6. Click OK to close the Page Setup dialog.

Note: Only custom paper types can be removed. The Remove button will be disabled when a predefined paper type is 
selected. 



Graphic Objects

You can add existing graphic objects to your inserts and labels directly from JewelCase Maker's editing area. Graphic objects are 
edited using the program that you have installed on your computer for that particular type of object. For example, the Microsoft 
Paint program installed with Windows 95 usually handles bitmap images. The type of objects that you can insert depends on 
what graphic programs you have installed on your machine. You will need to consult the help system and program 
documentation that comes with these programs for assistance in using these programs for creating and editing graphic objects.



Inserting a new object from an existing graphics file

To Insert a new object from an existing graphics file:

1. Click the Insert new object button on the toolbar or select the New Object item from the Insert menu.

2. Use the mouse to position and size the object. The first click selects the position of the upper left corner of the object. Then 
drag the mouse to position the lower right corner of the new object.

3. Select Create from file in the Insert Object dialog.

4. Enter the name of the file or use the Browse button to select the graphic file for this object.

5. Uncheck the Display as Icon option.

6. Click OK to create the new object using the specified file.



Creating a new graphic object

To Insert a new graphic object:

1. Click the Insert new object button on the toolbar or select the New Object item from the Insert menu.

2. Use the mouse to position and size the object. The first click selects the position of the upper left corner of the object. Then 
drag the mouse to position the lower right corner of the new object.

3. Select Create New in the Insert Object dialog.

4. Select the object type from the list. For example, choose bitmap image to create a new bitmap graphic image.

5. Uncheck the Display as Icon option.

6. Click OK to create the new object using the specified file.



Editing a graphic object

To edit a graphic object:

1. Select the object to edit.

2. Click the Bitmap Image Object item from the Edit menu. A sub-menu will be displayed.

3. Click the Edit option to edit the graphic in place or Open to edit the option in the actual graphic program.

4. Make desired changes using the graphics program.

5. If you chose in place editing in step 3 then just click outside the graphic object to return from the graphics program. If you 
opened the object in the graphics program in step 3 then you will need to choose Exit & Return item from the File Menu of 
the graphics program.



Deleting a graphic object

To delete a graphic object:

1. Select the object to delete.

2. Click the Delete button on the Main toolbar or select Delete from the Edit menu.

Note: You can use the undo/redo feature to recover an item deleted by mistake.



Working with text objects

Text objects can be inserted in your labels to create play lists, tables of contents or any other place you want to add labels or 
text. You can select text properties like font, font size and color easily with JewelCase Maker. Other properties like justification, 
bold, italic and underline may be modified for your custom inserts. Text objects can be repositioned or edited directly from the 
editing area.



Inserting a text object

To insert a text object:

1. Click on the Insert Text button on the Main toolbar or select the Text item from the Insert menu.

2. Use the mouse to position the upper left corner of the text object being created.

3. Enter the text to be inserted.

4. Click outside of the text box to exit the edit mode.



Editing a text object

To edit a text object:

1. Select the text object to be edited.

2. Double Click on the object or select the Text item from the Edit menu.

3. The text box is displayed in edit mode with the entire string selected. Make the necessary changes as desired.

4. Click outside of the text box to exit the edit mode.



Deleting a text object

To delete a text object:

1. Select the object to delete.

2. Click the Delete button on the Main toolbar or select Delete from the Edit menu.

Note: You can use the undo/redo feature to recover an item deleted by mistake.



Changing the properties of a text object

To change the properties of a text object:

1. Select the text object to be modified.

2. Use the formatting toolbar or select the property to change from the format menu.

Note: Property changes affect all text in a text box.



Rotating a text object

To rotate a text object:

1. Select the text object to be rotated.

2. Click the rotate button on the formatting toolbar or select rotate from the format menu.

Note: All text in the selected text box will be rotated 90 degrees counter-clockwise.



Positioning Objects

Objects are printed based on their position on the page. Think of it as a stack of objects and each object can be in front of or 
behind any other object(s). Any part of an object positioned behind another object may not be visible in the printed label. If you 
have added an object to your label definition but can not see it on the printed output be sure to check the positioning of all 
objects in your label definition. This feature allows a layering effect but care must be used when positioning the objects on your 
labels and inserts.



Moving an object to the back

To move an object to the back:

1. Select the object to be moved.

2. Click the Bring to back button on the Arrange Items toolbar or select it from the Order Objects sub-menu of the Format 
Menu.



Moving an object to the front

To move an object to the front:

1. Select the object to be moved.

2. Click the Bring to front button on the Arrange Items toolbar or select it from the Order Objects sub-menu of the Format 
Menu.



Moving an object up one

To move an object up one:

1. Select the object to be moved.

2. Click the Move up one button on the Arrange Items toolbar or select it from the Order Objects sub-menu of the Format 
Menu.



Moving an object down one

To move an object down one:

1. Select the object to be moved.

2. Click the Move down one button on the Arrange Items toolbar or select it from the Order Objects sub-menu of the Format 
Menu.



Formatting Text Objects

JewelCase Maker allows you to change the appearance of the text in a text object. You may change the font style and size, the 
color and other attributes like bold, italic and underlined fonts. Text may be aligned to the left, right or centered. Text objects may 
be rotated in 90° increments using the rotate function. It is important to note that changes made to a text object apply to all text in 
that object.



Label Set



Front Cover

A front cover are inserts is printed on a single-side of the paper. They are typically folded in half giving you a front and back side 
to the insert. 



Inside Insert

Inside inserts are created by designing and printing an additional page that will be printed on the back of the single-sided insert. 
When folded, you now have both and inside and outside jewel case insert.



Back Cover (U-Card)

Back cover inserts are printed on one side and the edges are folded back for insertion into the back cover of the jewel case.



CD Label

CD Labels are circular labels with an adhesive side to stick to the top side of you CD.



Paper Type

A description of a label stock like Avery’s 8931 or you may define your own paper type using the Page Setup item from the File 
Menu. Each page must have a paper type selected in order to be printed or viewed with the Print Preview feature.



Spot

A spot is another word for label. You may define up to three spots (labels) per paper type. It is possible to print more than one 
copy of a label on the same page.



Unit

The JewelCase Maker program can work in either inches or centimeters for your convenience. The Unit of measure can be 
selected in the Add printing paper dialog for paper type definitions or from the Ruler item in the View menu.. 



Editing Area

This is where you insert and arrange your graphic and text objects. You are allowed to create your own graphic object or select 
one from a previously saved file. Graphic objects can be positioned in on top of or under other objects, selected, moved and 
resized with the mouse or even edited by double clicking and entering the graphics application that you have previously installed 
for that type of graphics file.

Text objects can be added to create play lists or other labels. They can be rotated and the format toolbar gives you full control 
over fonts and other properties.



Ruler

The ruler in positioned at the top and left side of the editing area. It can be displayed or disabled at your convenience and the 
unit of measure can be set to either inches or centimeters from the Ruler item in the View Menu. The exact position of the cursor 
appears as a dashed line on the ruler while working in the editing area. It is also displayed in the message area of the status bar 
if visible.



Spot Outline

The spot outline is displayed to show the boundaries for the label you are editing. The page selected on the Page toolbar 
determines the type of outline displayed. It may be printed to act as a guide for cutting out your labels and inserts from non-
perforated paper types.



Main Toolbar

Toolbar buttons are used as shorthand for menu commands.    Each toolbar button represents a frequently used command.    The 
display of these buttons is context-sensitive in that only buttons relevant to the current context are shown and enabled.

The following is a run-down of the Main toolbar buttons and their respective menu commands.

Button Icon Button Name Corresponding Menu Command

New File Menu:      New

Open File Menu:      Open...

Save File Menu:      Save

Preview File Menu:      Print Preview

Print File Menu:      Print…

Undo Edit Menu:      Undo

Redo Edit Menu:      Redo

Delete Edit Menu:      Delete

Cut Edit Menu:      Cut

Copy Edit Menu:      Copy

Paste Edit Menu:      Paste

About Help Menu:      About JewelCase…

Help None.



Format Toolbar

Toolbar buttons are used as shorthand for menu commands.    Each toolbar button represents a frequently used command.    The 
display of these buttons is context-sensitive in that only buttons relevant to the current context are shown and enabled.

The following is a run-down of the Format toolbar buttons and their respective menu commands.

Button Icon Button Name Corresponding Menu Command

Bold Format Menu:      Bold

Italic Format Menu:      Italic

Underline Format Menu:      Underline

Align text to left Format Menu:      Justification:      Left

Align text to right Format Menu:      Justification:      Right

Align text to center Format Menu:      Justification:      Center

Text color Format Menu:      Color

Rotate Format Menu:      Rotate



Add Items Toolbar

Toolbar buttons are used as shorthand for menu commands.    Each toolbar button represents a frequently used command.    The 
display of these buttons is context-sensitive in that only buttons relevant to the current context are shown and enabled.

The following is a run-down of the Format toolbar buttons and their respective menu commands.

Button Icon Button Name Corresponding Menu Command

Insert text Insert Menu:      Text

New Object Insert Menu:      New Object…



Arrange Items Toolbar

Toolbar buttons are used as shorthand for menu commands.    Each toolbar button represents a frequently used command.    The 
display of these buttons is context-sensitive in that only buttons relevant to the current context are shown and enabled.

The following is a run-down of the Format toolbar buttons and their respective menu commands.

Button Icon Button Name Corresponding Menu Command

Bring to front Format Menu:      Order Object:      Bring to front

Bring to back Format Menu:      Order Object:      Bring to back

Move up one Format Menu:      Order Object:      Move up one

Move down one Format Menu:      Order Object:      Move down one



Page Toolbar

The Page menu buttons select the type of insert or label you are currently working on in the editing area.

The following is a run-down of the Format toolbar buttons and their respective actions.

Button Icon Button Name Action

Front Insert Selects front cover insert for editing.

Inside Insert Selects inside insert for editing.

Back Insert Selects back cover insert for editing.

CD Label Selects CD label for editing.



File Menu

The File Menu give you easy access to many of the basic JewelCase Maker functions and features. 

New

Allows you to create a new label set definition.

Open…

Allows you to open a previously saved label set for editing or printing.

Save 

Allows you to save the current label set to a jewel case file (.jwc) on your computer

Save As…

Allows you to save the current label set to a disk file on your computer.

Print…

Prints the current label set.

Print Preview

Allows you to view the current label set before printing.

Page Setup 

Select or create paper type definitions for printing labels.

Recent File 

Displays the more recently used label sets.

Exit 

Exits the JewelCase Maker program.



Edit Menu

The Edit Menu give you easy access to edit functions and features. 

Undo

Removes the last operation done to the current label design. The maximum number of operations allowed to be removed and 
restored can be set from the Options dialog. The default value is seven operations.

Redo

Re-applies the last undone operation to the current label design.

Delete 

Deletes the selected object from the editing area. No copy is left on the clipboard. Use the Undo operation to restore a object 
deleted by mistake.

Cut

Removes the selected object from the editing area but leaves a copy of the object in the clipboard for later paste operations.

Copy

Copies the selected object to the clipboard for later use.

Paste 

Pastes the contents of the clipboard in the editing area.

Select All

Selects all objects in the editing area for the current page.

Text

Enters edit mode for the selected text object.

Bitmap Image Object 

Edit

Allows you to edit the selected object directly from within the JewelCase Maker window.

Open



Opens the selected object in the program installed to edit this object type. 

Convert… 

Converts the selected object in to a picture (device independent bitmap) format. Converted objects will no longer be 
modifiable from within the JewelCase Maker program.

Options… 

Allows you to customize JewelCase Maker settings.



Insert Menu

The Insert Menu allows you to create new graphic and text object for your custom labels and inserts.

Text

Create and insert a new text object in the editing area. Use the mouse to position the text object and the format toolbar to control 
the look of the displayed text.

New Object…

Create a new graphic object from and existing graphic file or create your own using the graphic editor. Graphic objects can be 
edited using graphics applications previously installed on your computer. For example, bitmap files can be created using the 
graphic editor installed with Windows. Help information is available with from the documentation or help files installed with the 
corresponding application.



Format Menu

Provides easy access to JewelCase Maker’s formatting commands.

Bold

Sets the type face to bold for the selected text object.

Italic

Italicizes the selected text object.

Underline 

Underline the selected text object.

Color

Changes the color of the selected text object.

Font

Selects the current font for the text being displayed in the text object.

Justification 

Left

Left justifies the text displayed in the text object.

Right

Right justifies the text displayed in the text object.

Center

Centers the text displayed in the text object.

Rotate

Rotates the selected text object 90-degrees counter clockwise.

Order Object 



Bring to front

Moves the selected object to the top of all objects on this page.

Bring to back

Moves the selected object to the bottom of all objects on this page.

Move up one

Moves the selected object up one level from its current position on this page.

Move down one

Moves the selected object down one level from its current position on this page.



View Menu

Toolbar

Hides or views the main toolbar. When checked the toolbar is displayed below the JewelCase Maker menu bar.

Status Bar

Hides or views the Status Bar. When checked the status bar is displayed on the bottom of the JewelCase Maker program 
window.

Zoom 

50%

Display the objects in the editing area at 50% magnification.

100%

Display the objects in the editing area at 100% magnification.

150%

Display the objects in the editing area at 150% magnification.

200%

Display the objects in the editing area at 200% magnification.

Custom

Select a user defined zoom setting.

Ruler 

Centimeter

Display centimeters as the unit of measure for ruler.

Inch

Display inches as the unit of measure for ruler.



Help Menu

Help Topics

Displays the JewelCase Maker online help system.

About JewelCase…

Displays version and program information about JewelCase Maker.



Quick Command Menu

The Quick Command Menu gives you easy access to many useful edit functions and features.    Selecting one or more objects in 
the editing area and then clicking the right mouse button displays this menu.

Delete 

Deletes the selected object from the editing area. No copy is left on the clipboard. Use the Undo operation to restore a object 
deleted by mistake.

Cut

Removes the selected object from the editing area but leaves a copy of the object in the clipboard for later paste operations.

Copy

Copies the selected object to the clipboard for later use.

Paste 

Pastes the contents of the clipboard in the editing area.

Bring to front

Moves the selected object to the top of all objects on this page.

Bring to back

Moves the selected object to the bottom of all objects on this page.

Edit Text

Enters edit mode for the selected text object.

Zoom 

50%

Display the objects in the editing area at 50% magnification.

100%

Display the objects in the editing area at 100% magnification.

150%

Display the objects in the editing area at 150% magnification.



200%

Display the objects in the editing area at 200% magnification.

Custom

Select a user defined zoom setting.

Ruler 

Centimeter

Display centimeters as the unit of measure for ruler.

Inch

Display inches as the unit of measure for ruler.



NTI Web Resources
NTI is committed to your success! We hope to make your experience with JewelCase Maker the best 
possible by making available news and information, product updates and upgrades, Frequently Asked 
Questions and our Technical Support from the Internet. Our web site is at http://www.ntius.com.



Company or Product News and Information
Find out the latest about NTI what we are doing at http://www.ntius.com/corporate/inthenews.htm or any 
of our world-class products at http://www.ntius.com/products/index.htm. Learn about the latest features or 
supported drives for JewelCase Maker You can even download a trial version of any of our products 
directly from our web site giving you the easiest way to give our software a test drive before you buy.



Frequently Asked Questions (FAQs)
You can browse the latest information and commonly asked questions about JewelCase Maker from our 
web site at http://www.ntius.com/faq.htm. Find out what questions other JewelCase Maker users had 
about it. Get quick answers to the most commonly asked questions.



Updating your JewelCase Maker Software
From time to time, we release product updates and upgrades from our web site. Product updates 
generally contain patches and other corrections to the JewelCase Maker software and are available for 
registered users to download for free. Upgrades involve major product enhancements along with patches 
to reported problems. They will also be available for download but may involve a nominal fee. 

Updates can be installed by executing the downloaded file. All updated files and patches will be applied to 
your JewelCase Maker software automatically! It is highly recommended that you download and install 
any updates prior to contacting our Technical Support Department.

Visit our web site at http://www.ntius.com/download/index.cfm for the latest updates for all NTI products!




