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I N T R O D U C T I O N

A new way to draw

You may not be an artist, but you probably communicate through

drawings every day. Many people draw ideas, processes, and direc-
tions instead of writing them out—pictures are often faster to create
and easier to understand than words for the same information.

The Visio drawing application enables you to communicate ideas
quickly through the powerful medium of drawing. It is designed for

business people, people in technical fields, and for everyone else who
needs to create high-quality drawings quickly and easily. You don’t
have to be a graphic artist to use Visio—you just need to know what

message you want to communicate and how to use Microsoft
Windows.
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Visio basics

Before you start working in Visio, it’s helpful to understand the basics
of drawing in Visio and how Visio differs from other drawing pro-

grams you might have used. The big difference is this: you can create
drawings without having to draw.

Drag and drop drawing

The easiest way to create a drawing in Visio is by dragging shapes

from a stencil to a drawing page. This method is called drag and drop
drawing.

Stencils are collections of master shapes. When you open a stencil,
you see its master shape icons on a green background. When you

open the drawing window, you see the drawing page—which looks
like a piece of paper—on a blue background. You drag a master shape
from the stencil to the drawing page and drop an instance of the mas-

ter shape into your drawing.

Document

Document
Document

Document

Process Process Decision

Process

ProcessDecision

Process

Yes Yes

1. Point to a shape on the stencil.

2. Drag the shape into the
drawing window.

3. Drop an instance on the page.

Pointer tool
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For details about dragging and dropping master shapes, see Chap-

ter 2, “Adding, arranging, and connecting shapes.”

Stencils and templates

You can open a stencil and drawing separately, but the easiest way to
start a drawing is with a template. A template not only opens the cor-

rect stencil and a new drawing file for you, but also sets the drawing
scale and copies styles into the new drawing file.

Visio comes with a variety of task-specific stencils, many of which
can be opened by a corresponding template. All together, the stencils
provided with Visio contain hundreds of master shapes. Use these

master shapes as they are, modify them, or create your own master
shapes.

For details about starting a drawing with a template, see Chapter 1,
“Getting started with Visio.” For details about creating and modify-
ing master shapes, see Chapter 6, “Creating masters, stencils,

templates, and styles.”

SmartConnectors and glue

SmartConnectors are one-dimensional master shapes designed for

connecting shapes in flowcharts, organization charts, and other
drawings. There are several ways to add SmartConnectors to a draw-
ing: You can drag and drop a SmartConnector master shape or add

SmartConnectors automatically using the connector tool or the
Connect Shapes command. When you move the shapes the Smart-
Connector is attached to, the shapes stay connected and Visio flips

the connector line or redraws it to avoid crossing over the shapes.

Connector tool
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Process

Document

Process

Document

Shapes can be glued to each other. They stay glued after you move them.

You can also attach SmartConnectors to shapes using dynamic glue.
If you move a shape attached to a connector with dynamic glue, the
connector moves and reglues itself to the nearest connection point

given the shape’s new location.

Process

Decision Process

Decision

Process

DecisionProcess

Decision

With dynamic glue, connectors can move between connection points so connectors don’t
cross over shapes.

For details about connecting shapes, see Chapter 2, “Adding, arrang-

ing, and connecting shapes.”
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Click and type text

Every shape, including lines and connectors, can have text. To add

text to a shape, you click the shape and then type. That’s all. To add a
title or other text not associated with a shape, you click with the text
tool where you want to start the text and then type.

When you rotate or move a shape, its text rotates and moves with it.
But you can also rotate and move a shape’s text independently of the

shape.

Visio
Visio

Visio

Visio

V
isio

...and type.

A rotated shape
with text

Text moved away from
its shape

Text rotated independently
of its shape

Select the shape with the
pointer tool...

Visio also has dynamic fields that update automatically. You can in-
clude fields in a drawing to hold information that’s laborious to

update by hand. For example, a field can contain the current date
and time, or dimension information for a dimension line.

Text tool
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For details about working with text and fields, see Chapter 4, “Add-
ing text to drawings.”

Click and drag editing

When you want to edit a shape, you just grab a part of the shape and

move it to where you want it. For example, to rotate a shape, click the
shape with the rotation tool, grab one of the rotation handles, and
then drag until the shape is oriented on the page the way you want.

To change the shape of a shape—even to change a line segment of a
shape into an arc segment—grab the appropriate vertex or control
point and drag it to where you want it.

Rotation tool

To reshape, click with the pencil tool, then drag.

To rotate, click with the
rotation tool, then drag.

To move, click with the
pointer tool, then drag.
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For details about moving and editing shapes, see Chapter 2, “Adding,

arranging, and connecting shapes,” and Chapter 3, “Creating shapes.”

Streamlined drawing tools

You don’t have to use the master shapes on stencils. You can draw
your own shapes or use a combination of the master shapes and the

shapes you draw. You can also save the shapes you draw as master
shapes.

Curved movements create arcs. Straight movements create lines.

In other drawing programs, you might have used tools similar to the

Visio line, arc, rectangle, and ellipse drawing tools. Visio also includes
an all-purpose drawing tool: the pencil tool.

The pencil tool is especially powerful because you can use it to draw
both lines and arcs. As you begin to move the mouse, Visio quickly
calculates the path the mouse pointer is traveling. If you move the

mouse along a straight path, Visio draws a line; if you move the
mouse along a curved path, Visio draws an arc.

For details about drawing your own shapes, see Chapter 3, “Creating
shapes.”

Pencil tool
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Extensive OLE 2.0 support

Visio supports Windows object linking and embedding (OLE),

which lets you create an active link between applications. That means
you can insert Visio drawings directly into reports, memos, and pre-
sentations without tedious conversions, and edit them in place. You

can also insert objects from other Windows applications into Visio
drawings and run the application from within Visio to edit the ob-
ject. And you can control Visio through programs written in

languages that support OLE Automation, such as Visual Basic. For
details, see Chapter 7, “Using Visio with other applications” and
Chapter 9, “Writing programs to control Visio.”

SmartShapes

Every Visio shape is more than just a piece of clip art (although
Visio comes with clip art as well). Each shape is backed by a

ShapeSheet™ spreadsheet that contains information about the
shape’s geometry and other properties. You can change information
in a ShapeSheet to make a Visio shape smart—in other words, to cre-

ate a Visio SmartShape™ shape.

ShapeSheet
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SmartShapes are shapes designed to act the way you need them to in

a particular context. SmartShapes minimize your work. For example,
Visio’s SmartConnectors automatically flip themselves depending on
which way you drag them, and many of the arrows can be stretched

without distorting the arrowheads.

For details about the ShapeSheet, see Chapter 8, “Using ShapeSheets

to create SmartShapes.”

Familiar toolbars and menus

For maximum productivity, Visio lets you choose the working envi-
ronment that’s most familiar to you. You can use Visio’s standard

menus and toolbars, or you can use menus and toolbars that re-
semble Microsoft Office or Lotus SmartSuite applications. You can
easily switch from one toolbar and menu set to another by moving

the pointer to the toolbar at the top of the Visio window, clicking the
right mouse button, and then choosing the option you want.

For details about switching between Visio’s toolbar and menu sets,
see Chapter 1, “Getting started with Visio.”
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Gallery of Visio drawings

Visio is designed to create a wide range of drawings, from organiza-
tion charts to space plans and maps. The drawings in this section

were created using Visio stencils and tools.
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About this manual

The following sections cover several conventions and issues you
should keep in mind when using this manual.

Illustrations

Some of the illustrations you see in this manual may vary from what
you see on your screen. If so, don’t worry. The Visio window content
varies depending on whether:

• Your monitor is a VGA or a higher resolution display, and
whether it is color or monochrome. The screen shots in this

manual were produced using a Super VGA display with 800 x
600 pixel resolution. If you use another resolution, your screen
will look different.

• Your Visio window is sized large or small.

• You are working with text or graphics.

• The drawing or stencil window, or the window for ShapeSheets,
is active.

• Whether you’re using Visio’s standard, Microsoft Office, or Lotus
SmartSuite menu and toolbar set.

Most shapes used in the illustrations come from the Practice stencil,
which ships with all Visio products. However, you may occasionally
see shapes you don’t recognize. Those shapes may be from a stencil

that’s not included in the particular Visio product you’re using, or
they may be shapes drawn to illustrate a specific point.

Finally, some dialog boxes shown in this manual contain Browse and
Network buttons, which are features of Windows for Workgroups. If
you don’t use Windows for Workgroups, these buttons will not ap-

pear in the dialog boxes you see.



                     

Procedures

Because the content of the Visio toolbar varies with the resolution of

your monitor and the toolbar and menu set you’re using, the proce-
dures in this manual refer to menu commands (which are always
available). Elements of Visio that provide shortcuts  (such as buttons

on the toolbar) are suggested as alternatives wherever applicable.

Procedure steps are based on the Visio standard toolbar and menu

set. If a step in a procedure varies for the Lotus SmartSuite or Mi-
crosoft Office menu set, the alternate step follows the standard step
and is preceded by a v. If a toolbar button looks different in the Vi-

sio standard, Microsoft Office, and Lotus SmartSuite toolbars, each
button is illustrated and labeled in the margin.

Terminology

It’s helpful to understand how the terms shape and object are used in
this book and in other Visio documentation.

A shape is a graphic element that you create in Visio, either by drag-
ging and dropping a master shape onto a drawing page, drawing
with the drawing tools, grouping other shapes, or converting an ob-

ject from another application into a Visio shape.

The term shape is used throughout this manual unless reference is

made to items from other applications. In that case, the term object
is used. Object also has a special meaning in object linking and em-
bedding (OLE) protocol. Object is used only when those topics are

being discussed.
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Online help

The Visio online help displays helpful information on your computer
screen when you press F1, choose a command from the Help menu,

or click Help in a dialog box. The online help also contains informa-
tion that does not appear in Using Visio, including a command and
tool reference, a programming  language reference, and a Shape-

Sheet reference.

There are two Help windows. The main window displays a list of

topics and command descriptions. The procedure window, which
appears to the right of the main window, displays step-by-step in-
structions for completing tasks. The procedure window opens on top

of the Visio window so you can easily follow the instructions on the
screen while you work.

For details about Help, choose Using Help from the Help menu.




Getting started with Visio
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Getting started with Visio

During a typical work session, you’ll probably open at least one sten-

cil and one drawing file. With both of these files open, you can drag
master shapes from a stencil to a drawing.

Visio offers several ways to open the files you need. You can:

• Open individual drawing and stencil files.

• Open a template. Each template provided with Visio opens one
or more stencils and a new drawing file and copies styles and

other settings to the new drawing file.

• Open a file saved as a workspace. This opens all the files that
were open when you last saved the workspace file.

This chapter explains how to install Visio, start a work session, open
files, and end a work session. It also describes the parts of the Visio

window and how to change the window display.
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Installing Visio

If you have not installed Visio, do so now.

To install Visio:

1. Insert Disk 1-Setup into a disk drive.

2. In Windows Program Manager, choose Run from the File menu.

3. In the Command Line box, type a:\setup.

If Disk 1-Setup is in drive B, type b:\setup.

4. Choose OK.

5. Follow the instructions on the screen.

For details about installing Visio on a network and information
about installation troubleshooting, see the installation card that
comes with Visio. For a complete list of the files installed with Visio,

see the README.TXT file installed in the Visio directory.

Understanding Visio files

Before you begin working in Visio, it’s important to understand the

basic relationships between the four types of Visio files: templates,
stencils, drawings, and workspaces.

Templates provide the foundation for creating drawings quickly and
easily. Think of a template as a kit for building a particular type of
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drawing. For example, if you want to create a flowchart, you open a

template for flowcharts. The template opens a blank drawing page,
which is scaled appropriately for the drawing, and displays a grid to
help guide you in creating the drawing. The template also makes a set

of styles and settings available. Most important, the template opens a
stencil—a file containing ready-made master shapes you can use to
create a particular type of drawing. For example, if you open a flow-

chart template, Visio also opens a stencil that contains flowchart
shapes you can drag and drop into drawings.

preparation
Preparation

Manual
operation

Flowchart
template

Templates provide the shapes, styles, and other settings you need for building a drawing.

If you want to use shapes from other stencils, you can open the sten-
cils independently. You don’t need to open a template to open a

stencil.

When you’ve finished creating a drawing, you save the drawing file.

Next time you open that drawing, the drawing page opens in the
drawing window.

You can also save a file as a workspace. A workspace contains infor-
mation about the size and position of windows open at the time you
save the workspace. When you open a workspace, Visio re-creates the

arrangement of windows for you.
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Starting Visio

You start Visio the same way as other Windows applications. You can
start Visio, then open the files you need, or you can start Visio and

open a new drawing file with a template in one step.

You can start Visio by double-clicking the Visio program icon. When

the Visio main window and the New dialog box appear, open the files
you need.

To start Visio:

1. If Windows is not running, start it by typing win at the DOS

prompt.

2. If the Visio program group is not already open, double-click the
Visio program group icon in Program Manager.

3. In the Visio program group window, double-click the Visio icon.

The Visio main window and the New dialog box appear.

If you just installed Visio, a dialog box appears asking if you want
the Quick Tour, an online introduction to Visio. To see the Quick

Tour, choose Run Quick Tour Now, or choose Skip Tour And
Continue to start working in Visio.

Shows the location and
filename of the chosen file.

Describes the file chosen
in the Based On list.

Choose Stencil to
list stencil files.
You can create a
stencil based on
an existing stencil
or no stencil.

Choose Drawing
to list template
files. You can
create a new
drawing based on
a template or no
template.
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In the New dialog box, you can choose to create a new drawing

or a new stencil. You can base the new file on an existing file or
start your own from scratch.

4. Select the file you want to base the new file on, and then choose OK.

The new file opens in the Visio main window. For a description
of the window, see “The Visio main window” later in this

chapter.

You can also start Visio and open a new drawing file by opening a
template.

To start Visio and open a template:

1. In the Visio program group in Program Manager, double-click
the icon for the template.

The template opens a stencil and a new drawing file, and copies
styles and other settings to the new drawing file. For details
about templates and drawing files, see “Starting a new drawing

with or without a template” later in this chapter.

Opening files
Visio uses four different file types: templates, stencils, drawing files,

and workspaces. There are several ways to open each file type. The
table below summarizes the simplest methods.

The easiest way to Is to

Start a new drawing Choose New from the File menu, and
then choose the name of a Visio
template from the Based On list.

Open an existing drawing Choose Open from the File menu, and
then choose the name of the drawing
file. Drawing filenames have a .VSD

extension.

continued
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The easiest way to Is to

Open a stencil Choose Open Stencil from the File
menu, and then choose the name of

the stencil file.

Open a workspace Choose Open from the File menu, and
then choose a workspace file. Work-

space filenames have a .VSW extension.

Which type of file you open depends on what kind of work you want
to do. Each file type, its use, and the various ways to open it are de-

scribed in detail in the following sections.

Starting a new drawing with or without a template

The best way to start a new drawing is to open a new drawing file
with a template. The advantages of using a template are:

• It opens one or more stencils containing related shapes.

• It sets up the drawing page using a uniform grid and measure-

ment system, saving you the time it takes to set up pages.

• It copies related styles to the drawing file, saving you the time it

takes to define your own styles.

You can start Visio and open a new drawing file with a template pro-

vided with Visio in one step. For details about starting Visio by
opening a template, see “Starting Visio” earlier in this chapter.

Once Visio is running, you can open new drawing files by using the
New command on the File menu.
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To open a new drawing file based on a template:

1. From the File menu, choose New.

Alternatively, click the New button on the toolbar. For details

about the toolbar, see “The Visio main window” later in this
chapter.

The New dialog box appears.

2. In the New section, make sure Drawing is chosen.

3. From the Based On list, choose a template.

Choose the template that is associated with the stencil you will
use most in the drawing. Template filenames have a .VST

extension.

If you need additional stencils, open the stencil files without
their templates by using the Open Stencil command. For details,
see “Opening a stencil file” later in this chapter.

4. Choose OK.

In the Visio main window, the stencil and a blank drawing page

based on the template settings are displayed.

Standard and Microsoft
Office toolbar

Lotus SmartSuite toolbar

To start a new
drawing, make
sure the Drawing
option is chosen,
then choose a
template from
the list.
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New drawing files usually have only one page, although tem-

plates can create drawing files that contain more than one page.
For details about creating new pages and changing the drawing
page size and scale, see Chapter 5, “Creating and printing

drawing pages.”

To create a drawing from scratch—without a set of styles, shapes,

and page settings—open the drawing without a template.

To open a new drawing file without basing it on a template:

1. From the File menu, choose New.

Alternatively, click the New button on the toolbar.

2. In the New section, make sure Drawing is chosen.

3. From the Based On list, choose No Template.

Visio displays a blank drawing page in the Visio main window.

Opening an existing file

When you want to work on an existing drawing file, use the Open

command. You also use the Open command to open a workspace
and to open a template so you can edit it. For details about
workspaces, see “Saving a workspace” later in this chapter. For details

about editing templates, see Chapter 6, “Creating masters, stencils,
templates, and styles.”

To open an existing file:

1. From the File menu, choose Open.

Alternatively, click the Open button on the toolbar.

Standard and Microsoft
Office toolbar

Lotus SmartSuite toolbar

Standard and Microsoft
Office toolbar

Lotus SmartSuite toolbar
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The Open dialog box appears.

2. From the File Name list, choose the name of the file you want.

Alternatively, type a path and filename in the text box.

Template filenames have a .VST extension, drawing files have a
.VSD extension, stencil filenames have a .VSS extension, and

workspace filenames have a .VSW extension.

If the file you want is not listed, examine the List Files Of Type
box and the current drive and directory. If you need a different

file type, choose the type from the List Files Of Type list. If you
need a file on a different drive or in a different directory, choose
the drive or directory.

3. In the Open section, choose to open the original, a copy, or a
read-only version of the file.

4. Choose OK.

The selected file opens in the Visio main window.

Opens the original file, which you can change

Opens a copy that you can change

Opens a copy that you can’t change
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If you open a drawing file that contains several pages, you may need

to go to a particular page. To display a page, choose Go To Page from
the Page menu. In the dialog box, choose the page you want to dis-
play and then choose OK, or double-click the page you want to

display. Alternatively, click the Previous Page and Next Page buttons
on the toolbar.

You can save Visio files in formats that are compatible with earlier
versions of Visio. For details about these files, see “Finishing up” later
in this chapter.

Opening a stencil file

In some cases, you may want to open a stencil without opening a
template. For example, you may want to use shapes from several
stencils in a drawing.

To open a stencil:

1. From the File menu, choose Open Stencil.

Alternatively, click the Open Stencil button on the toolbar.

The Open Stencil dialog box appears.

Standard and Microsoft
Office toolbar

Lotus SmartSuite toolbar

Standard and Microsoft
Office toolbar

Lotus SmartSuite toolbar

Next Page

Previous Page

Describes the shapes contained
in the chosen stencil

Opens a copy
you can’t
change

Opens the
original file,
which you can
change
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2. From the Select Stencil list, choose the name of the stencil you
want to open.

If you don’t see the stencil name, click the Browse button and
locate the stencil file.

3. When you’ve located the file, choose OK.

The stencil opens in a separate stencil window.

Opening and saving files with different status options

The ways you can work with an open file vary depending on whether
you open a copy or the original, and whether the file was saved as
read-only. By default, templates are saved as read-only and they open

as copies so that you don’t inadvertently alter the original files. Draw-
ing and workspace files, however, open as originals because they’re
the files that contain your work. You can, however, change the status

of any file by setting options in the Save As dialog box.

If you check Read Only in the Save As dialog box when you save a file,

you cannot open the original file and save changes to it. You can only
open a copy. When you open a file as read-only, its name appears in
brackets in the window title bar.

The Visio main window
The main window usually contains a stencil window and a drawing
window, although it can contain several of each. Only one window

within the main window is active at a time.

The main window toolbar and menu bar vary depending on whether

a drawing or stencil is active, the display resolution of your monitor,
which tool you are using, and the size of the window. They also vary
depending on whether you’re using the standard Visio menu and

toolbar set, or the toolbar and menu sets designed for people who
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use Lotus SmartSuite and Microsoft Office applications. The follow-

ing sections describe the content of the main window when the
standard Visio toolbar and menu set is displayed. For details about
Visio’s Lotus SmartSuite and Microsoft Office menus and toolbars,

see “Changing the toolbar and menu sets ” later in this section, and
Appendix A, “Toolbars.”

The Visio main window usually contains a stencil window and a drawing window.

Visio toolbars

The toolbar and the status bar in the Visio window provide buttons
and lists you can use as shortcuts to choosing commands from
menus. There are also several specialized toolbars you use in particu-

lar views or when working with text.

The illustrations in the following sections show the toolbars and sta-

tus bar as they appear on a Super VGA display with 800 x 600 pixel
resolution, with the main window maximized. The number and lo-
cation of toolbar items vary depending on the display resolution of

Toolbar

Stencil window

Pasteboard

Drawing window

Master shape

Status bar

Drawing page
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the monitor and the size of your window. Therefore, you may see

items in the illustrations that don’t appear on your toolbars or you
may see items on your toolbars that aren’t listed here. For a complete
list and descriptions of the toolbar contents at any resolution, see

Appendix A, “Toolbars.”

Main toolbar and status bar

The main toolbar (the toolbar visible during most of your work in
the drawing window) contains the following buttons and tools:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31

1 New button 17 Increase Font Size button

2 Open button 18 Line Weight button

3 Open Stencil button 19 Line Pattern button

4 Save button 20 Line Ends button

5 Print button 21 Corners button

6 Print Preview button 22 Shadow button

7 Previous Page button 23 Snap button

8 Next Page button 24 Glue button

9 Align Shapes button 25 Zoom Out button

10 Distribute Shapes button 26 Zoom In button

11 Connect Shapes button 27 Pointer tool

12 Flip Horizontal button 28 Drawing tool menu

13 Flip Vertical button 29 Connection tool menu

14 Rotate Right button 30 Text tool menu

15 Rotate Left button 31 Supplemental tool menu

16 Decrease Font Size button
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The content of the status bar changes depending on the location of

the pointer. The following illustration shows how the status bar ap-
pears when the pointer is over the drawing window or the toolbar.

1 2 3 4 5

1 Text style list

2 Line style list

3 Fill style list

4 Zoom box

5 Status prompt

When the pointer is over the stencil window, the style lists are re-
placed by prompts that provide helpful information about the
master shape under the pointer.

For details about buttons and lists that are not illustrated here but are
visible on higher resolution monitors, see Appendix A, “Toolbars.”
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Text toolbar

When you are working with text, the toolbar and status bar display

text formatting buttons and lists.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18

1 Undo button 10 Subscript button

2 Redo button 11 Left Align Text button

3 Text Color button 12 Center Align Text button

4 Decrease Font Size button 13 Right Align Text button

5 Increase Font Size button 14 Justify Text button

6 Bold button 15 Top Align Text button

7 Italic button 16 Middle Align Text button

8 Underline button 17 Bottom Align Text button

9 Superscript button 18 Zoom Text 100% button

For details about text toolbar buttons and lists (including items that

are not illustrated here but are visible on higher resolution moni-
tors), see Appendix A, “Toolbars.”
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The stencil toolbar and menus

When the stencil window is active, the toolbar and menu bar display

buttons and menus for working in the stencil window. The menus
display commands for creating and editing master shapes.

1 2 3 4 5 6 7 8 9 10 11 12 13 14

1 Cut button 8 New Window button

2 Copy button 9 Tile button

3 Paste button 10 Cascade button

4 Delete button 11 Icons And Names button

5 Undo button 12 Icons Only button

6 Redo button 13 Names Only button

7 Repeat button 14 Arrange Icons button

For details about stencil toolbar buttons, see Appendix A, “Toolbars.”

The ShapeSheet menus

When the ShapeSheet window is active, the toolbar is not visible. The
menus display commands for programming shape behavior and
controlling the display of ShapeSheet information.

For details about using the ShapeSheet, see Chapter 8, “Using
ShapeSheets to create SmartShapes.”
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The status bar, dynamic pointers, and other on-screen help

Visio provides on-screen hints to help you determine what to do next

and what you can do with a particular tool:

• In the status bar, Visio displays information about the command

or tool that the pointer is on, or about the current task.

• If you pause with the pointer over a button or tool, Visio displays

a ToolTip to identify the button or tool.

• In the drawing window, the pointer changes shape depending on
which tool you are using and where the pointer is. For a com-

plete list and description of pointers, see Appendix C, “The
pointer library.”

• Handles and points on shapes vary in appearance depending on
where they are on the shape and what you are doing with the
shape.

Adjusting the view
To make working in Visio easier, you can change toolbar and menu

sets, magnify your drawing, arrange windows, and change other
parts of the display.

Changing the toolbar and menu sets

For maximum productivity, Visio lets you choose the working envi-

ronment that’s most familiar to you. You can use Visio’s standard
menus and toolbars, or you can use menus and toolbars that re-
semble those in Microsoft Office or Lotus SmartSuite applications.
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To switch toolbar and menu sets:

1. From the View menu, choose Toolbars.

v In Visio’s SmartSuite menu set, choose SmartIcons from the

Tools menu.

Visio displays a dialog box containing several display options.

Alternatively, click between toolbar buttons with the right

mouse button, and then choose the name of the menu and
toolbar set you want from the shortcut menu.

2. When you’re finished, choose OK.

Visio displays the new toolbar and menu set.

Getting quick access to common commands

You can quickly display a menu of common commands when you are
working with a drawing page, a stencil, or a selected shape. For ex-
ample, when a shape is selected, the menu displays commands for

copying the shape, editing the shape’s text, formatting the shape, and
for adjusting your view of the drawing.

To display the shortcut menu:

1. Point to the item you are working with. If you are working with

a shape, select the shape.

Displays no toolbar

Displays Visio standard
toolbars and menus

Toggles between color and
gray scale button display

Displays Microsoft Office
toolbars and menus

Toggles between regular
and large button display

Displays Lotus SmartSuite
toolbars and menus

Turns ToolTips on and off
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2. Click the right mouse button.

3. From the menu, choose the command you need.

Tip: This shortcut menu also provides easy access to the Actual Size
and Whole Page view options.

Zooming in or out

Depending on your task, you might need to see your entire drawing
in the drawing window, or you might need to magnify a part of the
drawing so you can work on details.

To zoom into or out of your drawing:

1. If you want to zoom into a particular area of your drawing,
select a shape in the area you want to zoom.

If you are zooming out to a wider view, you can skip this step.

2. From the View menu, choose  Actual Size, Whole Page, Page
Width, or Zoom.

If you choose Zoom, the Zoom dialog box appears, which
contains more zoom options than the View menu. Choose or

type a magnification percentage. When you finish, choose OK.

You can also choose a magnification percentage in the Zoom box
on the status bar.

The Whole Page command displays the entire drawing page within
the drawing window. The Actual Size command displays a drawing at

approximately its actual printed size. The size varies slightly depend-
ing on the display resolution of your monitor. The Page Width
command displays the entire width of the drawing page. The Last

Zoom command returns the view to the previous setting.

Alternatively, you can click the appropriate button to zoom in or out.

Decreases the
drawing page display

with each click

Magnifies the drawing page
display with each click
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You can also use the following shortcuts to adjust the view.

To Do this

Zoom in Ctrl+Shift+left mouse click

Zoom out Ctrl+Shift+right mouse click

Zoom in on selected area Hold down Ctrl+Shift+left mouse
button and drag a rectangle around
the area you want to zoom in on

Automatically scroll Hold down Ctrl+Shift+right
mouse button and drag the page

Arranging windows and changing window displays

When you have several drawing and stencil windows open, you may
need to arrange them so you can see them all.

To tile windows so each window is visible:

1. From the Window menu, choose Tile.

To cascade windows so you can see the title bar of each:

1. From the Window menu, choose Cascade.

To size a window:

1. Click the Minimize, Maximize, or Restore button in the upper-
right corner of the window, or drag a window border.

For details about opening multiple drawing windows, see Chapter 5,
“Creating and printing drawing pages.” For details about arranging

windows, see the Microsoft Windows documentation.

You can also change how the master shape icons appear in the stencil

window.
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To change the stencil window display:

1. Click the title bar of the stencil window to make the window
active.

2. From the View menu, choose the view you want.

To display both icons and names, choose Icons And Names. To
display just icons, choose Icons Only. To display just the names,

choose Names Only.

Alternatively, you can use the buttons on the stencil toolbar.

Setting display options

When you start Visio the first time, the status bar, rulers, and grid
lines appear in the window. If your drawing contains shapes with

connection points, they appear as blue Xs. If your drawing contains
guides, the guides are visible. You can turn these displays on and off.

To turn the display of an item on or off:

1. From the View menu, choose the appropriate command—

Rulers, Grid, Guides, Connection Points, or Status Bar.

If a command is checked, the item is displayed. If a command is
unchecked, the item is not displayed.

Tip: You can also turn the toolbar display on and off. For details, see

“Changing the toolbar and menu sets” earlier in this section.

These settings are saved by Visio, so they remain in effect until you
set them again.

For details about using guides and connection points, see Chapter 2,
“Adding, arranging, and connecting shapes.” For details about
changing display options for a specific page, see Chapter 5, “Creating

and printing drawing pages.”

Icons And
Names button

Icons Only button

Names Only button
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Finishing up

When you finish working, you need to save files you’ve changed,
close files, and quit. You may want to save the arrangement of open

files as a workspace, so you can open them all at once. It’s also a good
idea to create a summary for each file so you can easily identify files
later. This section explains how to finish up a Visio work session.

Saving files

When you have done substantial work on a drawing, you should save
the drawing file. When you change a stencil or template, you should
also save these files.

To save a new file:

1. From the File menu, choose Save or Save As.

Alternatively, click the Save button.

The Save As dialog box appears.

2. In the File Name box, type a valid DOS filename for your

drawing file.

If you don’t type a filename extension, Visio uses the default

extension for the file type.

Standard and Microsoft
Office toolbar

Lotus SmartSuite toolbar

Saves the drawing as a workspace

Locks the file so it can’t be changed
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If you want to save the file to a directory or drive other than the

current one, choose the directory or drive.

3. In the Save section, if you want to save a workspace with the file
you are saving, make sure Workspace is checked. For details, see

“Saving a workspace” later in this chapter. If you want to save a
file so it opens as a read-only file, choose Read Only. Otherwise,
leave both options unchecked.

4. If you like, choose a file format from the File Type list.

For example, if you want to be able to open a Visio 3.0 drawing

file in Visio 2.0, choose Visio 2.0 Drawing (*.VSD) from the File
Type list. For details about choosing a file format see “About file
formats” next in this chapter.

5. Choose OK.

By default, Visio prompts you for document summary informa-

tion when you save a new file. To change the default setting,
choose Options from the Tools menu, and then uncheck the
Prompt For Document  Information On Save option in the

Options dialog box.

6. If necessary, enter summary information, and then choose OK

to close the Summary Info dialog box. For details, see “Summa-
rizing files” later in this chapter.

v If you’re using Visio’s SmartSuite toolbar and menu set,  the
name of the dialog box is Doc Info.

Saving existing files is fast, easy, and something you should do fre-
quently while you work.

To save changes to an existing file:

1. From the File menu, choose Save.

For details about saving stencils and templates, see Chapter 6, “Creat-
ing masters, stencils, templates, and styles.”
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About file formats

By default, new drawing, stencil, and template files are saved in Visio

3.0 format. Visio saves existing files in the same format in which they
were created. You can change the format of a file by choosing a differ-
ent format from the File Type list in the Save As dialog box.

You can also change the default file format if you want. To change the
default file format, choose Options from the Tools menu. In the

General section of the Options dialog box, check Save New Files In
2.0 Format.

Here are a few things to keep in mind about file formats:

• Files that you save in Visio 3.0 format are smaller. Saving these

files takes a little longer, but the files require less storage space
and open faster.  The Visio 3.0 file format works well for stencils
and other files that aren’t changed or saved frequently but that

you open often.

• Files saved in Visio 2.0 format require more storage space, but

can be opened in Visio 2.0 or later versions.

• If a drawing file contains shapes that use Visio 3.0 features (such

as connectors that use dynamic glue, wide dashed lines, or lines
that have square end caps), those shapes may look or behave
differently if the file is saved in Visio 2.0 format and opened in

an earlier version of Visio.

• If a Visio 3.0 file contains text intended for use in Lotus Notes
and you save the file in Visio 2.0 format, the Lotus Notes text is

deleted.

• Visio 3.0 files are compound files, which means that summary

information about the file (for example, the creator or descrip-
tion) can be read by other Windows applications.
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Saving a workspace

By saving a workspace, you save the arrangement of open files so you

can open the files again in the same arrangement. You can save a
workspace either within a drawing, stencil, or template file (usually
within a drawing file), or as a workspace file, which has a .VSW

filename extension.

To save a workspace within a drawing file:

1. From the File menu, choose Save As.

2. In the Save section, check Workspace.

3. Complete the dialog box as necessary, and then choose OK.

Saving a drawing file with the Workspace option checked gives two
different results when you open it, depending on how you created the
drawing file. If you:

• Based the drawing file on a template, Visio opens only the
drawing file and the stencil associated with the drawing’s

template.

• Did not base the drawing file on a template, Visio opens all of

the files that were open when you saved the file in the same
arrangement as when the file was saved.

Another approach to saving a workspace is to use the Visio
workspace file type. By saving a workspace with the Save Workspace
command, you can later open your arrangement of files.

To save a workspace file:

1. Save the files you have edited.

2. From the File menu, choose Save Workspace.

3. In the dialog box, type a name for the file. Change the drive and
directory if necessary.
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Visio uses the .VSW filename extension unless you specify a

different extension.

4. Choose OK.

Summarizing files

It’s a good idea to create a summary for each file so you and others can
easily identify the file later. When you choose a file’s name in the New
or Open dialog box, the description contained in the file’s summary

information appears in the Description section of the dialog box.

To create or edit file summary information:

1. While the file you want to summarize is open in the active
window, choose Summary Info from the File menu.

v In Visio’s SmartSuite menu set, choose Doc Info from the File
menu.

2. In the dialog box, enter the file title, subject, creator, keywords,
and a description.

The dialog box also displays the filename and the directory

where the file is stored.

3. Choose OK.

The information you enter here is
displayed in the Description section

of the Open or New dialog box
when you choose the filename.
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You can include file summary information in the drawing by insert-

ing Document Info fields. For details about text fields, see Chapter 4,
“Adding text to drawings.”

For details about including summary information in a Lotus Notes
database, see Chapter 7, “Using Visio with other applications.”

Closing files

When you finish working with any file—a stencil, for example—

close it so you have more room to work.

To close files:

1. From the File menu, choose Close.

Alternatively, double-click the window’s Control-menu box.

Quitting Visio

When you finish a work session, quit Visio before you quit Windows.

To quit Visio:

1. From the File menu, choose Exit.

Alternatively, double-click the Visio window’s Control-menu
box.

If an unsaved file is open when you choose the Exit command, Visio
asks if you want to save the file before exiting. Choose Yes to save

changes, No to close Visio without saving changes, or Cancel to can-
cel the Exit command and continue working in Visio.
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Adding, arranging, and
connecting shapes

There are several ways to place shapes in a drawing. You can drag

master shapes from stencils, draw your own shapes, or import or
paste objects from other applications into Visio drawings. Once
shapes are on the drawing page, you may need to position, size, and

rotate them. You can also glue connector shapes between other
shapes so the shapes stay connected even when you move them in re-
lation to each other.

This chapter explains how to drag and drop master shapes into draw-
ings. It also explains how to arrange and connect shapes.

For details about creating your own shapes, see Chapter 3, “Creating
shapes.” For details about using objects from other applications, see

Chapter 7, “Using Visio with other applications.” For details about
adding text to shapes, see Chapter 4, “Adding text to drawings.”
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Anatomy of a shape

Before you use master shapes, there are a few things you should know
about shapes and master shapes.

Typical 1-D shapes

Yes

Document

Satellite Dish

Typical 2-D shapes

Selection handles appear when you select a
shape with the pointer tool. You can drag a
handle to size the shape.

Most shapes are 2-D shapes, which means
they have corner selection handles that you
can use to size the shape proportionally.

Shapes such as SmartConnector master
shapes and lines are 1-D shapes. 1-D shapes
have a beginning and ending point so you
can glue them between 2-D shapes.

Corner selection handle Beginning point Ending point

Selection handle

Rotation handle

Vertex

Rotation handles appear when you select
a shape with the rotation tool. You can
drag a handle to rotate the shape.

Vertices appear when you select a shape
with the pencil, line, or arc tool. You can
drag a vertex to reshape a shape.
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Beginning point

Ending point

A control point appears on a line or an arc when the line or arc is selected with the
pencil tool. You can drag a control point to change the curvature of a segment.

Connection points appear as blue Xs on some master shapes. You can glue either endpoint
of a one-dimensional shape to a connection point or to other points on a shape.

Type text

and press RETURN

to get to the next row.

A control handle lets you work with a shape in special ways, such as adjusting a rounded
corner, reshaping an arrow, or dragging a connector directly out of a shape. For example,
you can drag a control handle to change the height of a row.

A lock protects one or more characteristics of a shape.

Control point

Connection point

Control handle

Lock
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For details about locking and unlocking shapes, see Chapter 3, “Cre-

ating shapes.” For details about connecting shapes, see “Connecting
shapes by dragging and dropping” and “Special techniques for con-
necting shapes” later in this chapter.

You can convert a shape from two-dimensional to one-dimensional
so you can use it as a connector, and you can convert a one-dimen-

sional shape to a two-dimensional shape, which lets you size it
proportionally by dragging its corner handles. For details about con-
verting one-dimensional and two-dimensional shapes, see chapter 3,

“Creating shapes.”

Dragging and dropping master shapes into drawings

A master shape is a shape stored in a stencil. When both a stencil and
a drawing page are open, you can drag master shapes from the sten-
cil into the drawing.

Although you can drag and drop master shapes with most tools, it’s
best to use the pointer tool so if you need to move shapes after you

drag them, you can do so easily.

To drag a master shape into a drawing:

1. From the toolbar, choose the pointer tool.

2. In the stencil window, point to the icon for the master shape.

3. Hold down the left mouse button and drag the master from the
stencil window into the drawing window.
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As you drag, a box representing a two-dimensional shape or a

line representing a one-dimensional shape shows the shape’s
location on the page. If you pause while dragging, you’ll see the
shape instead of a line or box representing the shape. This lets

you position the shape more precisely.

When you drag, Visio displays a line
or box to represent the shape.

Pause, then drag to see the shape itself.

…into the drawing

Process Process Decision

Process

ProcessDecision

Process

Yes Yes

Document

Document
Document

Document

Drag the master shape
from the stencil…
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4. Release the mouse button to drop an instance of the master

shape on the drawing page.

All shapes, including lines and connectors, can have text. Some mas-
ter shapes include text. To replace text, or to type text on a master

that does not include text, select the shape and start typing. For de-
tails, see Chapter 4, “Adding text to drawings.”

You may need to rotate some shapes after you drag them into a draw-
ing to orient them the way you want on the page. For details about
rotating shapes, see “Flipping, reversing, and rotating shapes” later in

this chapter.

Connecting shapes by dragging and dropping

In charts and diagrams such as organization charts and flowcharts,

it’s helpful to connect two shapes so when you rearrange the shapes
in your drawing, the connector shape between them moves, rotates,
or sizes appropriately. To connect shapes in your drawing, you can

drag and drop connector master shapes.

You drag the connector shape toward the shape you want to glue it

to. The connections are made at connection points, which appear as
blue Xs on the screen. Connection points can be on a shape’s perim-
eter, inside the shape, or even outside the shape. You can glue the

endpoint of a connector shape to points on two-dimensional shapes,
groups, objects from other applications, or to an endpoint or con-
nection point on another one-dimensional shape.

To use a connector master shape to connect two shapes:

1. Drag the two-dimensional shapes you want to connect into
position on the drawing page.

2. In the stencil, select a connector master shape.
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Visio stencils contain a variety of connector shapes. Most are

designed to connect specific points on two-dimensional shapes.
The points they connect are indicated by the shape names (for
example, Top to Top, Top to Side, Bottom to Top, and so on).

Several other connectors are designed to connect shapes in a
variety of ways. The most useful of these shapes is the Universal
connector, which can bend to connect any two points on two

shapes. For details about the Universal connector, see “About
connectors and the Universal connector shape” later in this
chapter.

3. As you drag the connector into the drawing window, position
one end over a connection point on one of the two-dimensional
shapes.

4. Release the mouse button.

If the endpoint is successfully glued to the connection point, the

endpoint turns red.

If the connector shape does not glue to the connection point,

make sure the appropriate glue settings are active. For details, see
“Setting glue options” later in this chapter.

5. Point to the other endpoint on the connector.

When the mouse pointer is over an endpoint, it changes from an
arrow to a four-headed arrow.

6. Drag the endpoint to a connection point on the other two-
dimensional shape.

7. Release the mouse button.

For details about other methods of connecting shapes, see “Special

techniques for connecting shapes” later in this chapter.
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Interpreting master shape icons

The stencil window contains icons that represent each master shape

in the stencil. The icons provide clues about how to use the shape:

• A yellow background identifies a connector, a one-dimensional

shape that is designed for connecting two-dimensional shapes.

• A green square in the lower-right corner indicates that the shape

has one or more control handles.

• Two red bars on the bottom border of the icon indicate the
shape has a special double-click behavior.

• A light gray illustration indicates how the shape can be trans-
formed by dragging its handles.

Viewing the drawing file stencil

The first time you drag a master shape into a drawing file, Visio
places a copy of the master in the drawing file stencil. The drawing file
stencil is a stencil stored within the drawing file that contains an in-

ventory of all masters used in the file.

When you edit a master stored in the drawing file stencil, you update

all instances of the master in that drawing file at the same time. An
instance within the drawing file inherits characteristics from the
master on the drawing file stencil unless you ungroup the instance or

delete the master from the drawing file stencil.

To view the drawing file stencil:

1. From the Window menu, choose Show Master Shapes.

The drawing file stencil appears.

For details about editing the masters in a drawing file stencil, see

Chapter 6, “Creating masters, stencils, templates, and styles.”
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Arranging shapes on the drawing page

Once shapes are in your drawing, you’ll need to organize them on the
drawing page. Visio provides the following tools and features to help

you arrange shapes easily and precisely:

Rotating and flipping turn shapes so they are oriented on the draw-

ing page the way you want.

Snapping pulls shapes to grid lines, ruler intervals, guides, and other

items you specify so you can move shapes into place quickly.

Distribution places the selected shapes at regular intervals on the

drawing page on the basis of the distribution parameters you specify.
You can distribute shapes both horizontally and vertically.

Aligning places the selected shapes using the alignment parameters
you specify. For example, you can align right or left edges, centers,
and so on.

Ruler intervals and grid lines help you align shapes and space them
evenly on the page.

Guides—non-printing lines that you drag out from rulers—also
help you align shapes. You can glue shapes to a guide, then move the

guide and the shapes with it.

Gluing attaches shapes to each other while allowing you to move the

shapes in relation to each other (with some restrictions). This way
you can reposition connected shapes without having to redraw the
connecting lines.

To use these features, you’ll need to understand how to select shapes
and how various points and handles on shapes work. For details

about points on shapes and shape handles, see “Anatomy of a shape”
earlier in this chapter. For details about selecting shapes, see the next
section, “Selecting shapes.” For details about copying and sizing

shapes, see Chapter 3, “Creating shapes.”
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Selecting shapes

You often need to select a shape before you can work with it. For ex-
ample, to flip a shape, you first select it. To group several shapes

together, you first select them. This section explains how to select
shapes.

In most cases, you’ll select shapes using the pointer tool. In some
cases, you use other tools. For example, to rotate a shape, you select it
with the rotation tool to display rotation handles on the shape.

To Do this

Select one shape Click the shape with the pointer
tool.

Select several shapes Select the first shape, hold down
by clicking the Shift key, then click to select

other shapes one at a time.

Select several shapes With the pointer tool, drag a
by dragging selection net around all the

shapes you want to select.

Select all the shapes Choose Select All from the
on the page Edit menu.

Select all of a particular kind Choose Select Special from the
of item, such as shapes, Edit menu. In the dialog box,

groups, guides, and so on choose the kind of item you want
to select.

Cancel a selection Click away from selected shapes.

Cancel the selection of one Hold down the Shift key and click
shape when several are selected the shape.

Click to select one shape.

Hold Shift key and click to select
several shapes.

Drag to select several shapes.
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Here are some things to bear in mind when selecting shapes:

• When you select a shape, Visio displays a selection rectangle
around the shape. Visio uses the rectangle’s boundaries when

you align and distribute shapes. For details about aligning and
distributing shapes, see “Aligning shapes” and “Distributing
shapes” later in this chapter.

• When the mouse pointer is over the shape, the pointer changes
from a black arrow to a white arrow. When the arrow is white,
you can click to select the shape.

• After you select a shape, green selection handles appear on it.
When you hold down the Shift key and select multiple shapes,

the first shape you select displays green selection handles and
subsequent shapes display blue handles. When you select
multiple shapes with a selection net, the topmost shape in the

stacking order has green handles and the other shapes have blue
handles. The handle color distinction is helpful when you want
to align shapes or connect them using the Connect Shapes

command. For details about the stacking order, see the next
section, “Changing the stacking order of shapes.”

Changing the stacking order of shapes

Shapes have a stacking order on the page. The first shape you draw or
drop on the page is at the back of the stack, and the most recently

created shape is at the front.

The stacking order affects the way shapes look on the page. It also af-

fects the way shapes are selected and the way shapes are aligned when
you use the Align Shapes command. For example, if you drag a selec-
tion net around several shapes, the top shape in the stacking order is

the first shape selected (primary selection). The other shapes in the
selection are aligned in relation to the location of the primary shape.



         

To move shapes in front of or behind other shapes, use the Bring To

Front, Bring Forward, Send To Back, and Send Backward commands
on the Shape menu.

To change the stacking order of shapes:

1. Select the shape whose position you want to change.

2. From the Shape menu, choose the appropriate command.

ThirdSecond

FirstFirst

Second
Third

The circle was drawn first, the rectangle
second, and the triangle third.

After applying Bring To Front to the
circle and Send Backward to the triangle

Bring Forward and Send Backward move the shape forward or
backward one position in the stack. Bring To Front and Send To

Back move the shape all the way to the front or back of the stack.

Flipping, reversing, and rotating shapes
You’ll often need to flip, reverse, or rotate shapes so they face the
proper direction. You can flip a shape vertically or horizontally, or
use the Reverse Ends command to flip a shape both vertically and

horizontally. You can rotate shapes by 90 degree increments with the



     ,           ,                          

Rotate Left or Rotate Right command. You can rotate a shape by any

amount with the rotation tool. You can also rotate a one-dimen-
sional shape around one of its endpoints.

Original shape Flip Horizontal Flip Vertical Rotate Left

Note that some shapes based on actual objects may be locked against
being flipped, rotated, or reversed.

To flip or reverse a shape:

1. Select the shape.

2. From the Shape menu, choose the appropriate command: Flip
Vertical, Flip Horizontal, or Reverse Ends.

To rotate a shape 90 degrees:

1. Select the shape.

2. From the Shape menu, choose Rotate Left to rotate the shape 90

degrees counterclockwise, or Rotate Right to rotate the shape 90
degrees clockwise

To rotate a shape any amount:

1. From the supplemental tool menu, choose the rotation tool.

Flip Horizontal

Flip Vertical

Rotate Right

Rotate Left
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2. Select the shape you want to rotate.

Round rotation handles appear on the shape’s selection rect-
angle. On a two-dimensional shape, a plus sign in a circle
appears at the center of rotation (usually at the center of the

shape’s selection rectangle).

Rotation handles

Center of rotation

3. Drag a rotation handle.

When you point to a shape’s rotation handle, the mouse pointer

changes to two arrows forming a circle. When you press the left
mouse button and move the mouse slightly, a line appears
through the shape’s center of rotation and the mouse pointer,

showing the shape’s angle of rotation. The shape’s selection
rectangle shows the shape’s orientation on the page, and the
status bar shows the angle of rotation in degrees.

For finer control, drag the rotation handle farther from the
center of rotation.

4. Release the mouse button.

Rotating the shape around its centerRotation handles

Center of rotation
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You can rotate a two-dimensional shape around any point in the

drawing window, not just around the shape’s center, by moving the
center of rotation.

To move the center of rotation:

1. With the rotation tool, drag the center of rotation.

Rotating the shape around a non-central point

You can also rotate a one-dimensional shape around one of its end-

points without using the rotation tool. Be careful not to size the
shape as you rotate it.

To rotate a one-dimensional shape around an endpoint:

1. With the pointer tool, select the shape.

2. Drag one of the shape’s endpoints to rotate the shape around its
other endpoint.

When you point to a shape’s beginning point or ending point,
the mouse pointer changes from an arrow to a four-headed
arrow, indicating that you can move the endpoint.
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Moving and snapping shapes

As you drag shapes—or afterward—you’ll need to move the shapes
into place on the page. You can align shapes with rulers and grid lines

and with each other. You can also create guides and align shapes to
the guides. When snapping is on, shapes can snap to the items that
you align them with.

This section explains the basics of moving and snapping shapes.

Moving shapes

To move a shape, just drag it to where you want it. Use the grid lines

and rulers to help you place the shape.

To move a shape:

1. With the pointer tool, point to the shape.

When the mouse pointer is over the shape but not over a handle,
the pointer changes from a black arrow to a white arrow. Be
careful not to point to a handle; dragging a handle will resize

a shape.

2. Drag the shape to where you want it.

When you press the left mouse button, selection handles appear
on the shape. As you drag, a box for a two-dimensional shape or
a line for a one-dimensional shape shows the location of the

shape on the page. Faint lines on each ruler also indicate the
shape’s location.

If you pause while moving the shape but continue to hold down

the left mouse button, you will see the shape instead of the box
or line that represents the shape. This allows you to move the
shape more precisely.
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If snapping is on, the shape may jump into place.

You can move a shape to a new location within the same window or
into another open drawing window.

Tip: You can also move shapes or text from the page to the paste-
board (the area outside the drawing page boundary). Each page has

its own pasteboard. Therefore, if you view a different page, you will
no longer see the text or shape you placed on the pasteboard of the
page you were working on. For details on viewing different pages, see

Chapter 5, “Creating and printing drawing pages.”

Snapping shapes into place

It’s easier to place shapes where you want them if snapping is on.

Snapping pulls shapes toward the item you want to align them with.
You determine when to snap, what to snap to, and the snap strength.

To turn snapping on or off:

1. From the Tools menu, choose Snap & Glue Setup.

Satellite Dish

These lines help align the top,
middle, or bottom of the shape

with a ruler subdivision.

These lines help align the left,
center, or right of the shape
with a ruler subdivision.

Use grid lines to align shapes
both vertically and horizontally.
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2. In the Currently Active section, check the Snap option, and then

choose OK.

Alternatively, click the Snap button on the toolbar.

To specify what to snap to:

1. From the Tools menu, choose Snap & Glue Setup.

2. In the dialog box, check the Snap To options you want.

You can snap to as many items as you want. The Ruler Subdivi-

sions, Grid Lines, and Guides options are useful for aligning
shapes. The Shape Handles (selection handles), Shape Vertices,
and Connection Points options are useful when connecting

shapes together.

3. Make sure the Snap option in the Currently Active section is

checked.

4. Choose OK.

You can change the snap strength. Increasing the snap strength
means Visio will pull a shape toward the item from farther away.

Check this to turn snapping on.

Check the items you want
shapes to snap to.
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To change the snap strength:

1. From the Tools menu, choose Options.

2. In the Snap & Glue Strength section, drag the box in the appro-
priate bar to increase or decrease the snap strength.

The Points bar controls the snap strength of selection handles,
vertices, and connection points.

3. Choose OK.

Keep these things in mind when you set snap options:

• Turn off the snap options you don’t need so they don’t interfere
with the options you want. For example, you might turn off the
Grid Lines option if you are primarily interested in snapping to

guides.

• To place shapes as precisely as possible, set a strong snap

strength, zoom into your drawing, and then move the shapes
into place.

Distance at which snap
and glue become active
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Aligning shapes

As you move shapes, you can visually align them with ruler intervals,
grid lines, and guides. This section describes how to align shapes us-

ing the various methods.

Aligning shapes using the Align Shapes command

With the Align Shapes command, you can align selected shapes with
the primary selection. The primary selection is the shape with green

handles—either the first shape you selected or the shape at the top-
most layer of the stacking order. (For details, see “Selecting shapes”
earlier in this chapter.) You can also align shapes with an automati-

cally created guide. Use the methods described in this section for
precise alignment.

To align shapes with the primary selection:

1. Select the shape that you want to align other shapes to.

2. Hold down the Shift key and select subsequent shapes.

3. From the Tools menu, choose Align Shapes.

4. In the dialog box, choose the alignment options you want.

Each alignment option is represented by an illustration. You can

choose one Up/Down Alignment and one Left/Right Alignment
option.

Top Align Horizontal Align Bottom Align

Left Align Vertical Align Right Align

Up/Down Alignment options

Left/Right Alignment options
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To cancel the selection of the Up/Down Alignment or the

Left/Right Alignment options, choose the red X in that section.

Alternatively, choose an alignment button from the toolbar.

5. If you want to create a guide and glue shapes to it so you can
move the guide and the shapes with it, check Create Guide And
Glue Shapes To It.

The guide location is determined by the shape you selected first
and the alignment options you chose.

6. Choose OK.

Visio aligns the shapes. If you checked Create Guide And Glue
Shapes To It, Visio creates the guide and glues the shapes to it.

For more details, see “Aligning and gluing to guides and guide
points” later in this chapter.

To align the centers of shapes both horizontally and vertically:

1. Select the shapes.

2. From the Tools menu, choose Align Shapes.

3. Choose the vertical center alignment option.

Visio aligns the shapes vertically at their centers.

4. Choose the horizontal center alignment option.

Visio aligns the shapes horizontally at their centers.

5. Choose OK.

Original shapes After vertical alignment… …and horizontal alignment



         

Aligning and gluing to guides and guide points

Guides are non-printing horizontal and vertical bars that help you

align shapes. You drag guides from the drawing page rulers or create
them automatically with the Align Shapes command.

Guides are helpful in some ways that rulers and grid lines are not. For
example, you can move guides. This is particularly useful if shapes
are glued to guides, because when you move the guides the shapes

move too. Guides are also easier to see, and you can space them any
way you want on the page.

To create a guide:

1. Make sure both Guides and Rulers are checked on the View

menu.

2. Point to the ruler from which you want to drag a guide.

To create a horizontal guide, point to the ruler at the top of the
drawing window. To create a vertical guide, point to the ruler at

the left of the drawing window.

The mouse pointer changes to a two-headed arrow.

3. Drag to where you want the guide on the drawing.

The guide is visible as you drag.

4. Release the mouse button.

Tip: You can’t create diagonal guides. To align shapes diagonally,

draw a diagonal line, align the shapes to the line, and delete the line
when you’re finished.



     ,           ,                          

To align shapes with a guide:

1. Drag the shapes to the guide.

You delete guides the same way you delete shapes.

To delete a guide:

1. Select the guide.

2. From the Edit menu, choose Clear.

Alternatively, press the Delete key.

Guide points are crossbar-shaped guides that you drag from the in-

tersection of the two rulers. You can align a shape’s endpoint, center,
or sides to a guide point.

To create a guide point:

1. In the upper-left corner of the drawing window, point to the

crossbar at the intersection of the two rulers.

The mouse pointer changes to a four-headed arrow.
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2. Drag to where you want the guide point.

Two intersecting guides are visible as you drag.

3. When the guide point is positioned where you want it, release

the mouse button.

The guide point looks like a crossbar.

To align a point on a shape with a guide point:

1. Drag the shape and position the center or corner of a two-

dimensional shape’s selection rectangle or an endpoint of a
one-dimensional shape on the guide point.

Shape corner aligned with
guide point

Shapes centered on
guide point

To delete a guide point:

1. Click the guide point to select it.

You may need to zoom in to see it. Guide points on the primary

selection turn green when selected; all others turn blue.

2. From the Edit menu, choose Clear.

Alternatively, press the Delete key.

Gluing a shape to a guide is similar to gluing a shape to another

shape. You drag the shape that you want to glue toward the guide you
want to glue it to. You can glue an endpoint of a one-dimensional
shape to a guide or a guide point. You can also glue selection handles

of a two-dimensional shape to a guide or guide point. For example,
you can glue an entire side of a two-dimensional shape to a guide.
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To glue a shape to a guide:

1. Make sure glue options are set appropriately.

2. Point to the shape that you want to glue to a guide.

3. Drag the shape to the place on the guide you want to glue it to:

• If you’re gluing a one-dimensional shape, drag an endpoint to

the guide. When the shape is successfully glued, the endpoint
turns red.

• If you’re gluing a two-dimensional shape, drag the shape

toward the guide. When the shape is successfully glued, the
selection handles on the part of the shape that is glued to the
guide turn red.

You can glue a point, a side, or the middle of a two-dimensional shape to a guide.

You can automatically create a guide and glue shapes to it with the

Align Shapes command. For details, see “Aligning shapes using the
Align Shapes command” earlier in this chapter.

For details about gluing instances of master shapes as you drag and
drop master shapes, see “Connecting shapes by dragging and drop-
ping” earlier in this chapter.
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Centering the drawing on the page

In some cases, you may find that your finished drawings are not cen-

tered on the page. For example, you might create an organization
chart block by block and find that the finished chart extends off one
side of the page and onto the pasteboard.

To center the drawing on the page:

1. From the Tools menu, choose Center Drawing.

Visio shifts the drawing to the center of the drawing page.

Jackie Shrader
Director

Robert Mitchell
Course Designer Trainer

Ellen Eggleston
Trainer

Robert Mitchell
Course Designer Trainer

Ellen Eggleston
Trainer

If you are using the grid to align shapes in your drawing,
the shapes may no longer be aligned with the grid units after using

this command.
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Moving the zero point on rulers

By default, rulers appear along the edges of the Visio drawing win-

dow. These rulers indicate the scale of the drawing and are helpful
for aligning shapes on the page. If you don’t see the rulers on the
drawing window, make sure Rulers is checked in the View menu.

Sometimes it’s useful to change the position of the zero point on the
rulers. For example, you might want to measure the distances be-

tween shapes that aren’t near the current zero point.

To move the zero point on both rulers at once:

1. Hold down Ctrl and drag from the intersection of the two rulers.

To move the zero point on the ruler at the top of the window:

1. Hold down Ctrl and drag from the ruler at the left of the

drawing window.

To move the zero point on the ruler at the left of the window:

1. Hold down Ctrl and drag from the ruler at the top of the

drawing window.

Distributing shapes
Visio offers a quick method for creating equal distances between

three or more selected shapes. You can distribute shapes both verti-
cally and horizontally. For vertical distribution, the top and bottom
shapes in the selection define the distribution boundaries. For hori-

zontal distribution, the leftmost and rightmost shapes define the
distribution boundaries.
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To distribute shapes:

1. Select three or more shapes.

2. From the Tools menu, choose Distribute Shapes.

3. Choose the appropriate option. Each distribution option is
represented by an illustration.

Horizontal Ends Left Distribution Horizontal Center Right Distribution
Distribution Distribution

Vertical Ends Top Distribution Vertical Center Bottom Distribution
Distribution Distribution

Alternatively, choose a distribution button on the toolbar.

Tip: If the Create Guides And Glue Objects To Them option is
checked in the Distribute Shapes dialog box, Visio creates multiple

guides. Select and move the outermost guides to move the shapes
without changing the distribution.

Special techniques for connecting shapes
By dragging and dropping connector master shapes (described ear-
lier in this chapter), you can connect shapes in any type of drawing.
However, Visio provides several techniques for connecting shapes

that make specific drawing tasks faster and easier. The following
table summarizes these techniques and refers you to the section that
describes the technique in detail.
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To Do this

Connect shapes in Drag and drop two-dimensional shapes
a flowchart using the connector tool. Connectors are

glued automatically from one shape to
another. For details, see “Quickly creating
a flowchart.”

Connect shapes in Drag control handles to create connectors,
an organization chart or use the connector tool to draw connec-

tors between specific points on two-

dimensional shapes. For details, see
“Quickly creating an organization chart
and similar drawings.”

Connect a series Choose Connect Shapes from the Tools
of shapes menu. For details, see “Other ways to

connect shapes.”

Connect a callout Drag and drop a callout master shape
line to a shape and glue it to a two-dimensional shape.

For details, see “Connecting shapes by
dragging and dropping” earlier in this

chapter.

About connectors and the Universal connector shape

You can glue any one-dimensional shape—a line you draw or a one-
dimensional master shape—between two-dimensional shapes as a

connector. But in order to make it fast and easy to connect shapes
and modify a drawing after shapes are connected, Visio provides spe-
cial connector master shapes.

These connector shapes—called SmartConnectors—are one-dimen-
sional master shapes that behave intelligently when you use them to

connect other shapes. For example, if you connect two shapes with a
connector and then move one of the shapes, the connector reposi-
tions itself automatically and, in some cases, changes its own shape

to avoid crossing over the shapes it connects.
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The smartest and most useful connector shape is the Universal con-

nector, which bends to create any connection you need.

Process

Decision

Process

Process

Process

The Universal connector shape can connect any point on one shape to any point
on another.

To adjust the way the connector bends, drag the control handles. The
number of control handles varies depending on the number of bends

in the shape.

Process

Decision

Process

Decision

Move the control handles to adjust the location of the connector’s segments.

For more details about the Universal connector and other connector
shapes, see “Which shapes can use dynamic glue?” later in this
chapter.
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Connector tool

About connections and glue

The bond Visio creates between a connection point on a shape and

an endpoint of a connector varies depending on the technique you
use to connect the shapes and which connector shape you use:

• When you drag the connector tool between connection points
on two-dimensional shapes, Visio glues a connector solidly to
the connection points. If you move the shapes the connector is

glued to, the connector stays connected to those points. Visio
creates the same kind of connection when you use the drag and
drop technique to add connectors to your drawing.

Process

Decision

Process Decision

The connector stays glued to the same points when you move the 2-D shapes.

This kind of connection is useful in drawings where it’s impor-
tant to connect specific points on two-dimensional shapes. For

example, to indicate levels of responsibility and relationships in
an organization chart, connectors lead from certain points on
some boxes to certain points on others. No matter where those

boxes are in relation to each other, the lines should connect a
specific point on one box to a specific point on the next.

• When you use the Connect Shapes command, or hold down the
Ctrl key and drag the connector tool from one shape to another,
Visio glues a connector to the shapes using dynamic glue. With

dynamic glue, as you move one shape, the endpoint of the
connector moves to the connection point closest to the other
shape.

Connect Shapes button
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Process

Decision

Process

Decision Process

Decision

Process

DecisionProcess

Decision

With dynamic glue, the connector moves to connect the two closest connection
points.

Dynamic glue is best suited for drawings where it doesn’t matter

which specific points are connected on the shapes. In a flow-
chart, for example, connections between Process shapes indicate
the path of a task or decision. Which points the connector is

attached to is less important than having the correct shapes
connected to each other.

You can tell whether a connection uses dynamic glue by selecting the

connector and looking at its endpoints. In a standard connection,
the connector’s beginning point is marked by an X, and the ending
point is marked by a plus sign. Both endpoints also have borders. In

a connection that uses dynamic glue, the endpoints are not marked
or surrounded by a border.
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Which shapes can use dynamic glue?

Visio stencils contain a variety of connector shapes. Most are de-

signed to connect specific points on two-dimensional shapes. The
points they connect are indicated by the shape names (for example,
Top to Top, Top to Side, Bottom to Top, and so on). Because you use

these connectors to connect specific points, these connectors are
programmed to create solid (non-dynamic) connections.

Several other connectors are designed to connect shapes in a variety
of ways. (The most useful of these shapes is the Universal connector,
which can bend to connect any two points on two shapes.) You can

use this kind of connector to create both solid and dynamically glued
connections.

The following sections describe techniques for connecting shapes.
No matter which technique you use, you can always switch between a
solid connection and dynamic glue, as long as the connector is de-

signed to work with dynamic glue.

Tip: By default, Visio creates an instance of the Universal connector
shape when you use the Connect Shapes command and the connec-

tor tool. Although you can in some cases select another connector
shape to use with the tool or command, it’s often best to use the Uni-
versal connector because of its flexibility.

For details about switching between dynamic glue and a solid con-
nection, see “Converting the glue” later in this chapter.

Quickly creating a flowchart

The fastest and easiest way to create a flowchart is to drag and drop
shapes with the connector tool. As each shape is dropped onto the
drawing page, it is automatically connected to the previous shape.



         

To connect a series of shapes as they’re dropped onto the drawing
page:

1. From the connection tool menu, choose the connector tool.

2. Drag and drop a two-dimensional shape from the stencil onto
the drawing page.

3. With the first shape still selected, drag and drop another two-

dimensional shape onto the drawing page.

Visio automatically connects the shapes with an instance of the

Universal connector.

If you drag and drop a third two-dimensional shape, Visio adds
a Universal connector between the second and third shapes.

As long as the connector tool is selected, Visio adds a connector
between the last two shapes dropped onto the drawing page,

creating a linear flow. To create new branches in the chart, click
the drawing page to deselect the last shape you dropped, select
the shape you want to branch from, and then drag a new shape

onto the drawing page. Visio adds a connector between the
selected shape and the new shape.

Connectors added with this technique are connected to the
shapes using dynamic glue. For details about dynamic glue, see
“About connections and glue” earlier in this chapter.
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one

two three

four

Visio adds connectors between shapes 1 and 2, then shapes 2 and 3. To begin
branching from shape 2, deselect shape 3, and then select shape 2 before you drag
and drop shape 4.

If the shapes are already in position on the drawing page, you can
still use the connector tool to connect them with dynamic glue.

To connect shapes that are already on the drawing page:

1. From the connection tool menu, choose the connector tool.

2. If you’d like, choose a connector shape from the stencil.

This is an optional step. If you don’t choose a connector, Visio
uses the Universal connector by default. If you do choose a
connector, be sure it’s one that can work with dynamic glue. For

details, see “Which shapes can use dynamic glue?” earlier in this
chapter.

3. Hold down the Ctrl key and position the pointer over one of the

shapes you want to connect.
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Visio displays a box around the shape to indicate that you’re

creating a dynamic connection.

4. Drag the pointer and position it over the second shape.

5. Release the mouse button.

Visio creates an instance of the connector and connects it to the
points using dynamic glue.

Tip: If you need to modify a drawing in which shapes are connected

with a Universal connector, move the two-dimensional shapes first.
Then, if necessary, use control handles on the Universal connector to

adjust the connector’s bends. For details, see “Adjusting the bends in
a Universal connector” later in this chapter.

Quickly creating an organization chart and similar drawings

Many of the shapes designed to create an organization chart have

control handles that you can drag to create connectors. You can tell
which shapes produce connectors by looking at the master shape
icon. Connectors appear as yellow lines extending from the main

shape.

To create an organization chart by dragging connectors from
a shape:

1. Drag organization chart master shapes into position on the

drawing page.
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Name
Title

Name
Title Title Title

2. Drag the control handles on the shapes you want to connect and
glue them to connection points on the shapes you want to glue

them to.

Name
Title

Name
Title

Name
Title

Name
Title

Drag control handles on the Position shapes to create connectors that show the
organizational reporting structure.

Visio glues the end of the connector to the connection point. If
you move the shape the connector is glued to, the connector
remains attached to that point.

Executive shape

Three Position shapes
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For details about control handles, see Chapter 3, “Creating shapes.”

In some cases, you may want to create similar drawings using shapes
that don’t have control handles. For example, you could create a fam-

ily tree or a technical diagram using other master shapes or shapes
you create. To connect specific points on these shapes, use the con-
nector tool.

To connect specific points on two-dimensional shapes:

1. Drag the two-dimensional shapes into position on the drawing
page.

2. If you’d like, choose a connector shape from the stencil.

This is an optional step. If you don’t choose a connector, Visio
uses the Universal connector by default.

3. From the connection tool menu, choose the connector tool.

4. On the first shape, position the pointer over a connection point.

Visio displays a box around the connection point nearest the
pointer.

Some master shapes have connection points at their centers that
you can glue connectors to. However, if you position the connec-
tor tool over the middle of a shape that does not contain a center

connection point, Visio displays a box around the entire shape to
indicate that you’re using dynamic glue. For details, see “About
connections and glue” earlier in this chapter.

5. Drag the pointer and position it over a connection point on the
second shape.

6. Release the mouse button.
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Visio creates an instance of the connector and glues it to the two

points.

Document

Decision Decision

Document

No matter where the shapes are in relation to each other, the

endpoints of the connector remain glued to the same points. If
you move the two-dimensional shapes, Visio redraws the
connector so it flows as directly as possible between the connec-

tion points without crossing over the connected shapes.

Tip: If you need to modify a drawing in which shapes are connected
with a Universal connector, move the two-dimensional shapes first.

Then, if necessary, use control handles on the Universal connector to
adjust the connector’s bends. For details, see “Adjusting the bends in
a Universal connector” later in this chapter.

Other ways to connect shapes

In addition to the techniques described in the previous sections, Vi-
sio provides several other tools for connecting shapes.

You can use the Connect Shapes command to connect shapes that
are already on the drawing page.



         

To connect a series of shapes using dynamic glue:

1. Hold down the Shift key and click each two-dimensional shape
you want to connect in the order you want to connect them.

Green selection handles appear on the first shape you select. The
other shapes have blue selection handles.

2. If you’d like, choose a connector shape from the stencil.

This is an optional step. If you don’t choose a connector, Visio
uses the Universal connector by default. If you do choose a

connector, be sure it’s one that can work with dynamic glue. For
details, see “Which shapes can use dynamic glue?” earlier in this
chapter.

3. From the Tools menu, choose Connect Shapes.

Alternatively, click the Connect Shapes button on the toolbar.

Visio creates an instance of the connector and uses dynamic glue
to connect the shapes.

If you select shapes by holding down the Shift key and clicking
each shape, Visio connects shapes in the order they were se-
lected. For example, Visio connects the first and second shape,

the second and third shape, the third and fourth shape, and so
on. If you select shapes by dragging a selection net around the
shapes or if you use the Select All command, Visio connects

shapes in the stacking order of the shapes.

The rubberstamp tool, which is typically used for duplicating master

shapes on a drawing page, is also handy for gluing connectors to spe-
cific points on two-dimensional shapes.

To stamp a connector master shape between shapes:

1. Position the two-dimensional shapes on the drawing page.

2. From the connection tool menu, choose the rubberstamp tool.

3. In the stencil window, select a connector master shape.
Rubberstamp tool



     ,           ,                          

4. In the drawing window, position the rubberstamp tool over a

connection point on one of the two-dimensional shapes.

5. Hold down the left mouse button and drag to a connection
point on the second shape.

6. Release the mouse button.

Visio adds an instance of the connector you selected between the

points on the two-dimensional shapes.

Tip: The rubberstamp tool does not use dynamic glue, but you can
change the connection’s glue type. For details, see “Converting the

glue” later in this chapter.

For details about using the rubberstamp tool to duplicate instances

of a master shape, see Chapter 3, “Creating shapes.”

Glue and connectors: The finer points

This section describes some of the finer points of using connectors
and glue, including some of the ways you can adjust connectors once
they’re in a drawing.

Maintaining and breaking connections

It’s important to understand that you glue one shape to another. Af-
ter shapes are glued, you can move the shape that has another shape
glued to it without breaking the glue. For example, if you glue a con-

nector to a box, you can move the box without breaking the glue.
However, there are restrictions on how you can move the connector
without breaking the glue.
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The following actions do not break glued connections:

• Moving a shape or guide that has other shapes glued to it.

• Moving the free endpoint of a one-dimensional shape whose

other endpoint is glued to a shape.

• Reversing a shape using Reverse Ends.

The following actions break glued connections:

• Moving the glued endpoint of a one-dimensional shape.

• Moving a shape glued to a guide away from the guide.

• Flipping or rotating a shape that is glued to another shape.

Converting the glue

No matter which technique you use to add connectors to your draw-
ing, you can switch between a solid connection and one that uses

dynamic glue, providing the connector is designed to work with dy-
namic glue. For details, see “Which shapes can use dynamic glue?”
earlier in this chapter.

To switch from a solid connection to dynamic glue:

1. Choose the pointer tool and select the connector in the drawing.

2. Hold down the Ctrl key.

3. Drag each endpoint of the connector away from the connection
point it is glued to.

4. Drag the endpoints back to the shape to glue the endpoints with
dynamic glue.

Visio displays a box around the shape to indicate that you are

creating a dynamic connection.

Once you get the shapes in their final positions, you may want to

switch from dynamic glue to solid connections.
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To switch from dynamic glue to a solid connection:

1. Drag the endpoints of the connector shape away from the
connection points.

2. Drag the endpoints back to the connection points.

For details about identifying the glue type in a connection, see

“About connections and glue” earlier in this chapter.

Creating and deleting connection points

Whenever you glue a shape to a vertex or selection handle on an-
other shape, Visio creates a connection point. You can also create

connection points at other locations on a shape or even outside a
shape’s boundaries.

To add a new connection point to a shape:

1. Select the shape.

2. From the connection tool menu, choose the connection point
tool.

3. Hold down the Ctrl key and click where you want to add the
connection point. You can click on, inside, or outside the shape’s
boundaries.

Visio adds an X to show the new connection point.

When multiple shapes are selected, the connection point is

added only to the primary shape (the first shape you selected).

To delete a connection point from a shape:

1. From the connection tool menu, choose the connection point
tool.

2. Click the connection point you want to delete.

When selected, the connection point turns magenta.

Connection point tool
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3. From the Edit menu, choose Clear.

Alternatively, press the Delete key.

Visio deletes the connection point.

You can also create connection points by using the ShapeSheet. For
details about the ShapeSheet, see the Visio online help and Chapter

8, “Using ShapeSheets to create SmartShapes.”

Setting glue options

Before you glue shapes, you may need to specify glue settings in the
Snap & Glue Setup dialog box. Each template uses glue settings that

are appropriate for the master shapes on the stencil associated with
the template.

Tip: Glue options you set in the Snap and Glue Setup dialog box only

apply when you use the drag and drop technique described earlier in
this section and when you use the rubberstamp tool to connect
shapes. You do not need to set glue options to use the Connect

Shapes command and connector tool.

To turn glue on:

1. From the Tools menu, choose Snap & Glue Setup.

2. Check the Glue option in the Currently Active section, and then

choose OK.

Alternatively, click the Glue button on the toolbar.

To specify the points to glue to:

1. From the Tools menu, choose Snap & Glue Setup.

2. In the dialog box, check the Glue To options you want.

You can check as many items as you want. If you want to glue the
endpoints of one-dimensional shapes to the endpoints of other
one-dimensional shapes, check either Shape Handles or Shape
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Vertices. If you want to glue to selection handles on shapes,

groups, and objects from other applications, choose Shape
Handles.

3. Make sure the Glue option in the Currently Active section is

checked.

4. Choose OK.

If you want to glue to guides, handles, or connection points, make
sure these items are visible.

To display connection points or guides:

1. From the View menu, choose Connection Points or Guides.

When the command is checked, the item is visible.

Adjusting the bends in a Universal connector

The Universal connector uses the geometry of the shapes and the lo-
cation of the connection points to calculate the most direct route
between two shapes. When you move the shapes the connector is at-

tached to, the connector adjusts itself to avoid crossing over the
shapes it connects.

If you use a control handle to adjust the location of a connector seg-
ment, Visio will then maintain the segment's location in relation to
the shapes. If you move the shapes the connector is glued to, the ad-

justment you made to the segment's location may cause the
connector to cross over the connected shapes. You can easily reacti-
vate the Universal connector’s self-adjusting behavior by dragging an

endpoint away from the shape and then reconnecting the endpoint
to the shape.

Tip: To create a connnection using dynamic glue, hold down the Ctrl
key as you reconnect the endpoint to the shape.
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Adding text to connectors

Connectors are just like any other Visio master shape: Some connec-

tor master shapes have text and others don’t. As with any other Visio
shape, you can add text to connectors by selecting the shape and typ-
ing the text. You can also use the text tool to add or edit text.

To add or edit text for a connector:

1. From the text tool menu, choose the text tool.

2. Select the connector.

Visio opens the connector shape’s text block.

3. To add text, simply type.

If the shape already has text, Visio replaces the text with the text
you type. To edit existing text, select the text in the text block
and then edit the text.

4. To close the text block, click the drawing page.

For details about working with text, see Chapter 4, “Adding text to
drawings.”

Adding, removing, and switching arrowheads

Connector master shapes are formatted with a template-based style.

Template styles are designed to match the requirements of the draw-
ing type. For example, the connector shapes in flowchart-related
stencils have arrowheads; the connector shapes in organization

chart-related stencils do not.

You can override the style settings for a connector and add, delete, or

move the location of the arrowheads.
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To add or delete arrowheads for a connector shape:

1. Select the connector.

2. From the Format menu, choose Line.

v In Visio’s SmartSuite menu set, choose Line from the Style
menu.

3. In the Arrows section, change the appropriate settings.

To add an arrowhead to the beginning point, ending point, or
both, choose an arrowhead style from the Begin and End lists.
To delete an arrowhead from the beginning or ending points,

choose None from the Begin or End lists.

4. Choose OK.

Alternatively, select the connector shape and click the Line Ends
button. The button adds and deletes arrowheads from each end
of the connector shape with each consecutive click.

In some cases, you may need to adjust the direction of the connector
shape. For example, you may draw a connector and find that the ar-

rowhead is pointing at the wrong shape.

Determines whether an arrowhead
appears on the connector’s ending

point (marked by a plus sign).

Determines whether an arrowhead
appears on the connector’s

beginning point (marked by an x).
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To move the arrowhead from one end of the connector to the other:

1. Select the connector.

2. From the Format menu, choose Line.

v In Visio’s SmartSuite menu set, choose Line from the Style
menu.

3. In the Arrows section, change the appropriate settings.

To switch the arrowhead from the beginning point to the ending point, choose None
in the Begin list and choose an arrowhead style from the End list.




Creating shapes
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Creating shapes

Visio supplies all the shapes you need to create many types of draw-

ings. But what if you need certain unique symbols, or you want to
add creative touches to your drawings? You can create your own
shapes by drawing them or by editing the shapes that come with

Visio. And any shape you create can be saved as a master shape on a
new or existing stencil, so you can reuse it at any time. For details
about creating master shapes, see Chapter 6, “Creating masters, sten-

cils, templates, and styles.”

The Visio drawing tools are straightforward, so it’s easy to draw your

own shapes. In addition, Visio includes unique commands and tools
that simplify the process of creating complex shapes. The Union and
Combine commands create one shape from several other shapes, and

the Fragment command breaks up shapes into smaller parts that you
can rearrange, edit, or discard. Also, you can group shapes to create
more complex shapes.

This chapter explains what shapes are (something you need to un-
derstand fully before you can successfully draw and edit shapes) and

how to draw, edit, group, and format shapes. For details about add-
ing text to shapes, see Chapter 4, “Adding text to drawings.”
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Before you draw or edit shapes

Before you draw or edit shapes, it’s helpful to understand the parts
you draw to create a shape, what you can do with a shape, and how a

shape behaves. This section explains these topics. In addition, it’s im-
portant to understand the points on shapes—especially endpoints,
vertices, and control points—that you use to reshape shapes. For an

overview about the points on shapes, see “Anatomy of a shape” in
Chapter 2, “Adding, arranging, and connecting shapes.”

A shape is one line or arc, a series of line and arc segments, or several
shapes grouped together. A single line, for example, is a shape. So is
a rectangle. So is a symbol composed of several simpler shapes

grouped together.

A shape is either closed or open. You can fill closed shapes such as

circles with colors and patterns. You can format the ends of open
shapes such as lines, zigzag shapes, and half-circles. For example, any
open shape can have an arrowhead at each end.

Most shapes have one path. A path is a continuous series of segments.
Shapes can also have more than one path. For example, you might

create a recycle symbol composed of several paths.

Path 2

Path 3

Path 1

Path 4
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You can do these things with a shape:

• Size, move, and rotate it, and change its position in the stacking
order.

• Add text to it.

• Format it.

• Copy, paste, duplicate, and delete it.

• Glue it to other shapes and guides.

• Specify whether the shape prints, how it appears on screen, how
it sizes in a group, and what happens when you double-click it.

• Edit it with the pencil tool.

• Unless the shape is a group, you can also unite and combine it
with other shapes, or fragment it into separate shapes.

You can also specify behavior for a shape through its ShapeSheet. For
details, see Chapter 8, “Using ShapeSheets to create SmartShapes.”

Drawing shapes
Drawing shapes is straightforward in Visio. Visio contains some stan-

dard drawing tools—plus some powerful additions. The pencil tool
is especially powerful because you can draw both lines and arcs with
it. As you begin to move the mouse, Visio quickly calculates the path

along which the pointer appears to be traveling. If the path of the
mouse is straight, the pencil tool draws a straight line segment. If the
path curves, the pencil tool draws an arc.

Pencil tool



         

It’s worth practicing with the pencil tool to get comfortable with it.

Try drawing arcs and lines at different angles. Move the mouse as if
you were drawing the same shapes with a pencil on paper. As you
draw, you’ll see how Visio interprets your gestures.

When you drag in a straight path,
Visio draws a line.

When you drag in a curved path,
Visio draws an arc.

When you first draw a shape with any tool, don’t be concerned if it
doesn’t look exactly right. You can modify the shape later. You can
change arcs into lines and lines into arcs, and add and delete seg-

ments as necessary. For details, see “Editing shape segments” later in
this chapter.

Drawing a single line or arc

Use the pencil, line, or arc tool to draw a single line or arc shape.

Lines are the same regardless of which tool you draw them with. Arcs
differ depending on which tool you use to draw them. However, you
can edit arcs considerably after you draw them so it doesn’t matter

whether you first use the pencil tool or the arc tool for drawing arcs.

Each arc you draw with the pencil tool is a portion of a circle. The

portion and size of the circle vary depending on the way you move
the mouse.

Line tool

Arc tool
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The arcs you draw with the arc tool are always a quarter of an ellipse.

Like the pencil tool, the arc tool uses the path along which the
pointer travels to determine which way the arc bows. Where you
place the endpoint determines the arc’s eccentricity (or how asym-

metrical it is).

An arc drawn with the pencil tool An arc drawn with the arc tool

To draw a line or an arc:

1. From the drawing tool menu, choose the pencil tool.

Alternatively, choose the line tool or the arc tool, whichever
is appropriate.

2. Point to where you want to start the line or arc.

3. Drag to draw the line or arc.

+

As you start drawing, the pointer changes to a crossbar, and then

displays a line or an arc depending on what kind of segment you
are drawing.

4. Release the mouse button.

+ +
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The line or arc is initially a one-dimensional shape, so it has end-

points. When you select it with the pencil tool you’ll also see a circle
between its endpoints. That’s the control point for changing lines to
arcs and arcs to lines, and for changing the bow of an arc.

Beginning point

Ending point

Control point

Drawing shapes with several segments

When you draw a shape with more than one segment, you start each
subsequent segment at the endpoint or vertex of the previous seg-

ment. If you don’t like a segment, you can delete it immediately by
choosing Undo from the Edit menu. You can also adjust, add, and

delete segments after you complete the shape.

To draw a shape with several segments:

1. From the drawing tool menu, choose the pencil tool.

If you prefer, choose the line or arc tool.

2. Point to where you want to start the shape.

3. Drag to create the first segment.
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4. Release the mouse button.

This single segment is a one-dimensional shape.

Endpoints

Control point

5. To draw the next segment, point to either endpoint of the first
segment, and then drag. When you finish, release the mouse
button.

Be careful not to select the endpoint of the first segment. If you
select an endpoint, it turns magenta. If you drag a selected

endpoint, Visio resizes the existing segment instead of starting a
new one.

Note that the shape is now two-dimensional and it displays

vertices at the ends of segments, not endpoints. When the shape
is selected with the pencil tool, each segment also displays a

control point.

6. To draw subsequent segments, point to a vertex, drag to draw the
new segment, and then release the mouse button.

Point to an endpoint and drag to
draw the new segment.

When you release the mouse button,
the shape displays vertices, not
endpoints.

Endpoints Vertices

Control
points

You close a shape in Visio just as you close a shape when you draw on
paper: you drag the last vertex of the shape to the first vertex.
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To close a shape:

1. When you draw the last segment of the shape, drag until the
crossbar of the mouse pointer is over the vertex at the beginning
of the first segment of the shape.

2. Release the mouse button.

The shape’s fill color is white unless you have specified a differ-

ent fill color or pattern for the shape.

Keep these things in mind when you are drawing shapes:

• You can switch between the pencil, arc, and line tools. Before
you start a segment, choose the tool you want.

• To constrain lines to 45 degree intervals, hold down the Shift key
as you draw the lines.

• To draw a complex shape, draw the shape’s simple components
first, and then use the Group, Union, Combine, or Fragment
command to create the complex shape. For details, see “Group-

ing shapes” and “Joining and breaking up shapes” later in this
chapter.

• To create shapes with multiple paths that don’t touch each other,
use the Combine command. For details, see “Joining and
breaking up shapes” later in this chapter.

Undoing segments

You can start a segment over before you finish drawing it, and undo
segments one at a time.

To start a segment over:

1. Before you release the mouse button at the end of a segment,

drag back to the vertex at the beginning of the segment.

Make sure you hit the vertex precisely or you might not com-
pletely delete the segment.
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2. Redraw the segment.

Drag back over the segment to erase it.

Immediately after you draw segments, you can undo them in the re-

verse of the order in which you created them.

To undo segments one at a time:

1. After you draw segments but before you perform other actions,
choose Undo from the Edit menu.

Alternatively, press Ctrl+Z or Alt+Bksp.

Visio deletes the last segment you drew.

2. Repeat step 1 to delete other segments one at a time starting
with the last segment you drew.

Drawing ellipses and rectangles

An easy way to draw ellipses and rectangles is with the ellipse and
rectangle tools. The ellipse tool also provides the best way to draw a
circle, and with the rectangle tool you can easily draw a square.

To draw an ellipse or a rectangle:

1. From the drawing tool menu, choose the ellipse or rectangle
tool, whichever is appropriate.

2. Point to where you want to start the shape.

For ellipses, point to where you want a corner of the shape’s
selection rectangle.

For rectangles, point to where you want a corner.

Rectangle tool

Ellipse tool



         

3. Drag until the shape is the size you want.

For a circle or square, hold down the Shift key as you drag.

4. Release the mouse button.

Hold down the Shift key
as you drag to create a
square.

Hold down the Shift key as
you drag to create a circle.

Sizing shapes
The method you use to size shapes depends on whether the shape is

one-dimensional or two-dimensional.

To size a one-dimensional shape:

1. With the pointer tool, select the shape.

2. Drag an endpoint until the shape is the size you want.

By dragging an endpoint, you can size
and rotate a 1-D shape simultaneously.

Yes

Yes
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If the shape is not a straight line, you can also size it by dragging
a selection handle.

Drag a selection handle to size the shape.

3. Release the mouse button.

You can size a two-dimensional shape one direction at a time or both

directions at once, depending on which handle you drag.

To size a two-dimensional shape:

1. With the pointer tool, select the shape.

2. Drag a handle until the shape is the size you want.

To size the shape proportionally, drag a corner handle.

Tip: If you see fewer than eight handles on a two-dimensional shape,

zoom in to see the rest of the handles and size the shape more accu-
rately. For details about zooming, see Chapter 1, “Getting started

with Visio.”
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Editing shape segments

Visio shapes are flexible. You can change the angle at which two sides
of the shape meet, add and delete arc and line segments, and change

several aspects of arcs.

In most cases, you can make these changes by selecting the shape

with the pencil tool and dragging a part of the shape until it looks the
way you want it to.

This section explains how to move, add, and delete shape segments.
For details about how to edit arcs, see “Reshaping arcs” later in
this chapter.

Note that control handles may cause a shape to behave in ways that a
standard one-dimensional or two-dimensional shape would not. For

details, see “Working with control handles” later in this chapter.

Changing shape angles by dragging a vertex

By dragging a vertex, you can change the angle where two segments
meet. Dragging a vertex often makes the segments longer or shorter.

To reshape angles by dragging a vertex:

1. With the pencil tool, select the shape.

2. Click the vertex whose position you want to change.

The vertex turns magenta and the pointer tool changes to a four-
headed arrow.
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3. Drag the vertex to its new position.

A shape before and after dragging a vertex

You can select several vertices and drag them all at the same time.

The selected vertices maintain their relationship to each other but
move with respect to the rest of the shape. To select the vertices, se-
lect the first vertex, and then hold down the Shift key to select the

others. To move the vertices, place the pointer over one of the se-
lected vertices (the pointer changes to a four-headed arrow), and
then drag.

Adding and deleting segments

You add and delete segments to change the look of a shape. For ex-
ample, you can add a segment to a triangle to make it a rectangle, or
delete a segment from a rectangle to make it a triangle.

To add a new segment:

1. With the pencil tool, select the shape.

2. Point to where you want to create a new vertex.

It’s helpful to zoom into your drawing so you can see clearly
when the pencil is over a line or arc segment.
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3. Hold down the Ctrl key and click.

By pressing Ctrl and
clicking the diagonal
segment…

…you can add a vertex
to create two segments
from one.

You can then drag the
new vertex to any
location you want.

Visio creates a vertex where you clicked. The vertex indicates

where one end of the new segment meets the end of an existing
segment. Each segment, including the new one, displays a
control point at its center.

If you clicked a line segment, the new segment is a line. If you clicked
an arc segment, the new segment is an arc.

Tip: Adding a segment is sometimes easier when snapping is turned

off. For details about snapping, see Chapter 2, “Adding, arranging,
and connecting shapes.”

If you want fewer segments in a shape, delete the segments you don’t
want. You delete a segment by selecting a vertex associated with the
segment, and then deleting it. After you delete segments, you may

need to adjust the shape by dragging vertices and control points un-
til the shape looks the way you want.

To delete a segment:

1. With the pencil tool, select the shape.

2. Point to a vertex associated with a segment you want to delete.

When the pointer is directly over a vertex, it changes from a

pencil to a four-headed arrow.
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3. Click the vertex to select it.

The vertex changes to magenta.

4. Press the Delete key.

…are replaced with a
diagonal segment between
the vertices at either end.

…the two segments…
When you delete a
vertex at the corner
of two segments…

How Visio redraws the shape when you delete a vertex depends on

whether the vertex is at the beginning or end of an open shape, the
order in which the segments were created, and whether the segment
that follows the vertex you delete is a line or an arc.

This shape was
created in this order.

Delete this vertex… …and you get this result.

Delete this
vertex…

…and you get this result.

Delete this vertex… …and you get this result.
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Reshaping arcs

Whether you draw an arc with the pencil tool or the arc tool, you can
edit an arc until it looks exactly as you want it to—even change it

into a line. By dragging the arc’s control point or eccentricity
handles, you can change its bow and its eccentricity.

Changing arcs to lines and lines to arcs

You can flatten an arc until it becomes a line, or bow a line until it

becomes an arc. An arc has an invisible snap point in the middle of
an invisible line between its two endpoints. When you drag the con-
trol point to that snap point, the arc becomes a line.

To change an arc to a line or a line to an arc:

1. Select the arc or line with the pencil tool.

If the segment is in a multiple-segment shape, select the shape.

A control point appears on the arc or line.

2. Point to the control point.

The pointer changes to a four-headed arrow.

3. To change an arc to a line, drag the control point until it flattens

to form a line. To change a line to an arc, drag the control point
until it forms an arc.

x +

x

Drag the control point to convert an arc to a line.
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x +

Drag the control point to convert a line to an arc.

Changing the bow of an arc

Every arc follows the perimeter of an invisible circle or an ellipse. You
can change the bow of an arc so that it becomes a larger or smaller
portion of the invisible ellipse. The bow is the curve in an arc. The

greater an arc’s bow, the greater the distance between the ends of the
arc and the farthest point out on the arc.

To change the bow of an arc:

1. Select the arc or the shape that contains the arc with the

pencil tool.

2. Point to the arc’s control point.

The pointer changes to a four-headed arrow.

3. Drag the control point up or down until the arc looks the way
you want it to.

x
+

x

Drag the control point to change the bow of an arc.
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Changing an arc’s magnitude of eccentricity

Eccentricity is the measure of how elongated an ellipse is; it’s the ra-

tio between the ellipse’s length and width. To change the eccentricity
of an arc, you change the shape of the invisible ellipse that the arc is
based on. An arc drawn with the pencil tool is based on an invisible

circle and has an eccentricity of zero. The eccentricity of an arc you
draw with the arc tool is determined by how you move the mouse as
you draw.

By dragging one of the arc’s eccentricity handles, you can reshape the
invisible ellipse on which the arc is based, and make the arc more ec-

centric, or less.

To change an arc’s magnitude of eccentricity:

1. With the pencil tool, select the arc or the shape that contains
the arc.

2. Point to the control point on the arc, and then click to select the
control point.

The control point turns magenta, and if the arc is not circular,
you’ll see the eccentricity handles. On circular arcs, the eccen-

tricity handles are under the control point.

3. If you don’t see the eccentricity handles, hold down Ctrl and
drag the pointer slightly away from the control point.

Visio displays the eccentricity handles.

Click the shape with the
pencil tool to see the
control point…

…click the control point, then
hold down Ctrl, and drag the
pointer slightly away from the
control point…

…to see the
eccentricity handles.
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4. To change the magnitude of the arc’s eccentricity, drag an

eccentricity handle farther from or closer to the control point.

+

Changing the magnitude of eccentricity

Changing an arc’s angle of eccentricity

You can change how an arc leans by rotating its eccentricity handles
to change its angle of eccentricity.

To change an arc’s angle of eccentricity:

1. With the pencil tool, select the arc or the shape that contains

the arc.

2. Point to the control point on the arc, and then click to select the

control point.

The control point turns magenta, and if the arc is not circular,
you’ll see the eccentricity handles.

3. If you don’t see the eccentricity handles, hold down Ctrl and
drag the pointer slightly away from the control point.

Visio displays the eccentricity handles.
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4. Drag an eccentricity handle to rotate it around the control point

until the arc is aligned the way you want.

+

Click with the pencil tool, and then drag an
eccentricity handle to change the angle.

Working with control handles
Some Visio shapes have special handles called control handles. A
control handle lets you work with a shape in ways that are inde-

pendent of standard one-dimensional and two-dimensional
characteristics.

You can tell which shapes have control handles by looking at the
master shape icon in the stencil. These icons have a green square in
the lower-right corner.

Control handles work differently depending on the shape’s design
and purpose. For example, you might drag a control handle on one

shape to adjust a rounded corner; on another, to reshape an arrow;
and on another, to pull a connector directly out of a shape. The illus-
tration shows some examples of how control handles work.
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Name
Position

Text, Text, Text,
Text, Text

Adjusting the location of the
horizontal segment

Dragging a connector from
a shape

Moving the balloon
pointer to another side
of a balloon shape

Changing the shape
of an arrow

When a control handle creates another shape such as a connector, the
shapes may behave differently from how they would if you had cre-
ated them independently of each other. For example:

• If you select a shape from which you’ve dragged a connector, the

connector is also selected.

• To add text to a connector dragged from a shape, you must
subselect the connector.

Duplicating, copying, and deleting shapes

You can duplicate, copy, paste, cut, and clear shapes in Visio the same
way you do in other Windows applications. You can also duplicate a

shape at a specific location on the page or use the rubberstamp tool
to create multiple instances of a master shape. For details about cut-
ting, copying, and pasting between applications, see Chapter 7,

“Using Visio with other applications.” For shortcut keys related to
these actions, see Appendix B, “Shortcuts.”
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Duplicating shapes in the current drawing

When you duplicate a shape, you can either create the copy at a stan-

dard distance from the original shape or specify exactly where you
want the copy. If you create multiple copies, each copy is offset from
the previous copy by the same amount the first copy is offset from

the original.

To duplicate a shape:

1. Select the shape.

2. From the Edit menu, choose Duplicate.

A copy of the shape appears slightly offset from the original.

Original shape Duplicated shape

To create more copies quickly:

1. Immediately after you duplicate a shape, press F4 for each
additional copy you want to create.
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Press F4 to make
additional copies of
a shape and offset
them by a default
amount from the
previous shape.

By specifying exactly where you want Visio to place a copy of the
shape, you can quickly create borders, evenly space boxes in organi-
zation charts, and build other drawings that use several copies of the

same shape. Consider using this technique instead of dragging and
dropping the same master shape several times—it’s often quicker.

To duplicate a shape at a specific location:

1. With the pointer tool, select the shape.

2. Hold down Ctrl and drag the shape to where you want the copy.

+

Select the shape, press Ctrl, and
drag.

Visio copies the shape at the location
you dragged to.

When you press Ctrl, the pointer changes to an arrow with a
plus sign indicating that dragging will copy the shape. As you

drag, you’ll see an outline of the shape.



         

3. Release the mouse button.

The copy appears where you release the mouse button.

4. To create other copies, press F4 for each copy you want.

Each copy is offset by the same amount as the first copy is offset from the
original shape.

Using the rubberstamp tool to duplicate shapes

Stamping is often the easiest way to create multiple instances of a
master shape.  You can use the rubberstamp tool with both one-

dimensional and two-dimensional shapes.

To stamp a master shape:

1. From the connection tool menu, choose the rubberstamp tool.

2. In the stencil window, select a master shape.

3. In the drawing window, place the pointer where you want the
center of the shape.

4. Click the left mouse button.

An instance of the master shape appears on the drawing page.

Tip: You can also use the rubberstamp tool to quickly connect two-

dimensional shapes.  For details, see Chapter 2, “Adding, arranging,
and connecting shapes.”
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Placing a copy of a shape into another drawing

To place a copy of a shape into a different drawing, you can copy the

shape to the Clipboard and then paste the shape from the Clipboard
into the other drawing—or you can drag the shape there.

To copy a shape and paste it into another drawing:

1. Select the shape.

2. From the Edit menu, choose Copy.

A copy of the shape is placed on the Clipboard.

3. Display the drawing that you want to paste the shape into.

If the drawing is in the same drawing file, choose Go To Page

from the Page menu, and then choose the page you want to
display. If the drawing is in a different file, open the file, and
then display the correct page.

4. From the Edit menu, choose Paste.

A copy of the shape appears in the center of the drawing.

If you want, you can use the Copy and Paste commands to create du-

plicates of shapes in your current drawing, but the Duplicate
command is easier. Also, you can cut shapes with the Cut command,
and then paste them.

Visio has a shortcut for copying a shape and pasting it into another
drawing.

To place a copy by dragging:

1. Display the drawing page that contains the shape you want to
copy and the drawing page you want to copy the shape into.

For details about opening multiple drawing windows for the

same file, see Chapter 5, “Creating and printing drawing pages.”
For details about opening files, see Chapter 1, “Getting started
with Visio.”
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2. Point to the shape you want to copy.

3. Hold down Ctrl and drag the shape into the other drawing
window.

A copy of the shape appears in the second drawing.

For information about dragging shapes from Visio into another
application, see Chapter 7, “Using Visio with other applications.”

Cutting and clearing shapes

If you no longer want a shape, you can cut or clear it to remove it
from a drawing. When you cut a shape, Visio deletes the shape from
your drawing but places a copy of it on the Clipboard so you can

paste it if you want. When you clear a shape, Visio deletes it and does
not copy it to the Clipboard. The way to restore the shape is by
choosing Undo from the Edit menu (or press Ctrl + Z) before per-

forming any other action.

To cut or clear a shape:

1. Select the shape.

2. From the Edit menu, choose Cut or Clear.
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Joining and breaking up shapes

When you want to draw a complex shape, first think about how you
can break the shape into simpler shapes. You can often create a com-

plex shape by drawing the simple parts that make up the shape, then
putting them together. You can use the Union, Combine, and Frag-
ment commands to easily create shapes that are often difficult to

draw in other programs.

Each of these commands has a specific purpose:

• Union creates one shape from the perimeter of other shapes.

• Combine cuts holes in shapes.

• Fragment breaks one or more shapes into smaller shapes.

When you unite, combine, or fragment shapes, you are creating new
shapes. The old shapes no longer exist, so their ShapeSheets—in-
cluding their formulas—are discarded. Each new shape has its own

ShapeSheet. For details about ShapeSheets, see Chapter 8, “Using
ShapeSheets to create SmartShapes.”

If lines in a multiple segment shape are formatted with rounded cor-
ners, Visio discards this formatting when you unite, combine, or
fragment shapes and replaces the round corners with arcs. For details

about formatting, see “Formatting shapes” later in this chapter.

Uniting shapes

The Union command creates one shape from the perimeter of other
shapes.

You can unite two or more overlapping closed shapes. If the shapes
do not overlap, Union creates one shape out of them but the shapes

might appear unchanged. If a shape is open, Visio discards the open
shape when you choose Union.

The new shape inherits the formats and text of the first shape you se-
lect. The formats and text of other shapes are discarded.
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To unite shapes:

1. Select the overlapping closed shapes that you want to unite.

2. From the Shape menu, choose Union.

Three circles... ...united into one shape

Combining shapes

The Combine command creates shapes with holes in them—such as
picture frame shapes and doughnut shapes—and any other kinds of

shapes with multiple paths.

Usually, you combine a pair of two-dimensional shapes. When you

combine two shapes, Visio discards the area where the two shapes
overlap. For example, to create a doughnut shape, place a small circle
in the middle of a large circle, then combine the shapes. Visio dis-

cards the area of the small circle to create the doughnut shape.

You can also combine one-dimensional shapes with each other and

combine one- and two-dimensional shapes together. In these cases,
Visio creates one shape from the selected shapes, but the new shape
might not look different from the old ones. The difference is in the

ShapeSheets. Each original shape has a ShapeSheet. Once the shapes
are combined, the new shape only has one ShapeSheet.

As with Union, the new shape created with Combine inherits the for-
mats and text of the first shape you select. The formats and text of
other shapes are discarded.
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To combine shapes:

1. Select the overlapping shapes that you want to combine.

2. From the Shape menu, choose Combine.

Select overlapping shapes. Choose Combine. The resulting
shape is hollow.

Fragmenting shapes

The Fragment command provides an ideal way to create Venn dia-
grams and marketing pyramids. With Fragment you can:

• Break a two-dimensional shape into smaller parts.

• Break a one-dimensional shape (except lines) into smaller parts.

• Create new shapes where two or more two-dimensional shapes
overlap.

• Create a new shape from three or more intersecting lines.

After you fragment shapes, delete the pieces that you don’t need.

To break a two-dimensional shape into smaller parts:

1. Draw lines through the shape where you want to break it.

2. Select the shape and the lines.
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3. From the Shape menu, choose Fragment.

A circle fragmented by intersecting lines.

To create new shapes where two-dimensional shapes overlap:

1. Select the overlapping shapes.

2. From the Shape menu, choose Fragment.

Fragments are created where the circles overlap.

To create a new shape from intersecting lines:

1. Select the intersecting lines.

2. From the Shape menu, choose Fragment.

The new shapes appear in the interior of the intersections.

Fragments are created where the lines intersect.
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Example: Creating the No symbol

It could be difficult to draw the international No symbol in another

program. In Visio it’s easy: just create the simple shapes that make up
the symbol, and then use the Combine command, the rotation tool,
and the Union command to finish the shape.

Draw these two circles with
the ellipse tool.

Place the smaller one on
top of the larger, select
both, then choose Combine.

Draw this rectangle with the
rectangle tool then rotate it
45 degrees.

Arrange the circle and
rectangle shapes like this,
select them, then choose
Union.
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Grouping shapes

A group is a shape composed of other shapes. Several of the master
shapes provided with Visio are groups of simple shapes that together

make up a more complex shape. You can move and size a group as a
single shape, but you can also edit the shapes in a group individually.

Although a group is considered a shape, technically it is different in
some ways from other shapes. You cannot edit the group itself with the
pencil tool, although you can edit the shapes in it. A group can include

guides and objects from other applications as well as shapes. A group
has a ShapeSheet, but so does each shape and each object in the group.

This section explains how to group and ungroup shapes, edit the en-
tire group, and edit shapes in the group.

Grouping and ungrouping shapes

You can group any shapes on the same drawing page, regardless of

their proximity. Consider grouping shapes that you use together
regularly, such as a table and chair.

To group shapes:

1. Select the shapes you want to include in the group.

2. From the Shape menu, choose Group.

A selection rectangle appears around the shapes in the group.

Individual selected shapes After grouping

Name
Title

Name
Title

Text, text,
text

Name
Title

Name
Title

Text, text,
text
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A group can be disassembled with the Ungroup command.

To ungroup shapes:

1. Select the group.

2. From the Shape menu, choose Ungroup.

When you ungroup shapes, Visio discards the group’s ShapeSheet. If
you ungroup an instance of a master shape, the shape no longer in-
herits characteristics from the master on the drawing file stencil.

Editing a group

You can size, move, rotate, and format all the shapes in a group
in much the same way as you size, move, rotate, and format

other shapes. You can also add or remove shapes from a group.

To edit the entire group:

1. Select the group.

2. Size, move, rotate, format, or add text to the group as you would

for other shapes.

When you format the entire group, the formatting affects all the

shapes in the group. When you add text to a group, the text
appears on the frontmost shape in the group.

To add or remove a shape from a group:

1. Select the group.

2. From the Shape menu, choose Ungroup.

3. Hold down the Shift key and select the shapes you want to add
to or remove from the group.

4. From the Shape menu, choose Group.
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Alternatively, you can add and delete shapes without ungrouping the

group. To add a shape to a group, choose Open Group from the Edit
menu to open the group window, drag the shape you want to add
into the group window, and then close the group window. To delete a

shape from a group, open the group window, delete the shape you
want to remove from the group, and then close the group window.

All shapes, groups, and objects from other applications are sur-
rounded by a selection rectangle, which is displayed when the item is
selected and can be used to align the items to the grid and with each

other. If you add or remove a shape in a group and close the Group
window, you may notice that the selection rectangle no longer fits
the new group dimensions.

To adjust the selection rectangle:

1. Select the group.

2. From the Tools menu, choose Update Alignment Box.

Note that some master shapes included with Visio have unusually
large or small selection rectangles that are specifically designed to
match the selection rectangles on related shapes. You should not ad-

just selection rectangles on instances of these shapes unless you don’t
plan to use the shape with another related shape.

Editing the shapes in a group

A group’s members can be modified individually by opening the

group in the group window. The window looks just like the normal
drawing window, with the same menus and tools. However, the
group appears unrotated in the group window even if it is rotated on

the drawing page, so you can align shapes with grid lines and ruler
intervals. Also, the shapes behave as if they are not grouped.
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To open the group window and edit a shape:

1. Select the group, then choose Open Group from the Edit menu.

The group window appears, and within the window, the shapes

in the group behave as if they are not grouped.

Note that by default, when you double-click a group, the group
window opens. However, double-clicking may cause different

behavior. If you double-click a group for which a different
double-click behavior has been specified, that action happens.
For details, see “Specifying a shape’s double-click behavior” later

in this chapter.

2. Edit the shapes in the group as you would edit ungrouped

shapes on the drawing page.

As you make changes, you can see the changes in both the group
window and the drawing window. You may need to reposition or

tile the windows to see the changes in both windows.

3. To close the group window, double-click the Control-menu box

in the upper-left corner of the window.

In the group window,
shapes appear upright and
independent of each other.

In the drawing window,
shapes appear grouped

and may be rotated.



         

You can format and add text to a member of a group without open-

ing the group window. Just subselect the shape you want to
work with.

To subselect a shape in a group:

1. Select the group, then pause.

Green selection handles appear on the group.

2. Select the shape.

Gray selection handles appear on the shape.

3. Format or add text to the shape, just as you would to an

ungrouped shape.

Keep these things in mind as you work with groups:

• You can add a guide and the shapes glued to it to a group. Be
sure to select both the guide and shapes before you add them to

the group; otherwise the glue breaks. You can add guides to
rotated groups only when the group is displayed in the group
window. For details about guides, see Chapter 2, “Adding,

arranging, and connecting shapes.”

• If you want to rotate a group’s shapes independently of each

other, do so in the group window.

• Bitmaps (imported objects) will not rotate even when you rotate
the group they are included in.

Controlling a shape’s behavior when you size a group

When you resize a group in most applications, its members also
resize. In Visio, you have a choice. When you resize a group, a shape
in the group can either scale with the group or maintain its original

size. Each shape in a group can be set to behave differently.
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To set the sizing behavior for a shape in a group:

1. Open the group window by first selecting the group, then
choosing Open Group from the Edit menu.

Name
Title

Name
Title

Text, text,
text

Name
Title

2. Select the shape.

3. From the Format menu, choose Behavior.

v In Visio’s SmartSuite menu set, choose Behavior from the Style
menu.

4. In the Resize Behavior section of the dialog box, choose the
resizing behavior for the shape.

Choose Scale With Group to resize the shape when the group is
resized. Choose Reposition Only to keep the shape’s original size
when the group is resized. Choose Use Group’s Setting if you

want the shape to inherit sizing behavior set for the group.

In the group window, select the
shape and apply the resize behavior.
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Name
Title

Name
Title

Text, text,
text

Name
Title

Name
Title

Name
Title

Text, text,
text

Name
Title

If you choose Reposition Only, the shape stays the same
when you resize the group.

5. Choose OK.

6. To close the group window, double-click the Control-menu box.

To set the sizing behavior for a group:

1. Select the group.

2. From the Format menu, choose Behavior.

v In Visio’s SmartSuite menu set, choose Behavior from the Style
menu.

3. In the Resize Behavior section of the dialog box, choose the

option you want, and then choose OK.

Formatting shapes

Formatting shapes can transform your drawing from a rough draft

to a presentation-quality graphic. You can apply attributes individu-
ally—for example line weight, fill color, and font size—or use styles
to apply more than one attribute at a time.
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You can change the following attributes:

• Line pattern (solid, dashed), line weight, and line color.

• Line ends (arrowheads, dots, boxes) and line caps (round or

square).

• Corners (to make them more or less rounded).

• Fill color and pattern.

• Shadow color, pattern, and location.

• Font, size and color, position, case, style (bold, italic), alignment
within the text block, indentation, spacing, tabs, margins, and
background color of the text block.

Document Document Document

Document shape with various formats

Quick ways to format shapes

For most drawings, you’ll want to take the simplest approach to for-

matting shapes: Either choose from a style list or use buttons on the
toolbar. For a complete list of ways to format shapes, see “All the ways
to format shapes” later in this chapter.

When you choose from a style list, you are applying a style, and when
you use a button you are applying attributes as local formatting.

There’s a difference, which can be significant in some cases, but for
many drawings, it won’t matter which one you use. For details, see
“Understanding local formatting and styles” later in this chapter.
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To apply a style from a style list:

1. Select the shape you want to format.

2. From a style list on the status bar at the bottom of the Visio

window, choose a style.

v In Visio’s Microsoft Office toolbar, choose from a style list on the
toolbar.

For example, if you want to apply the style to the shape’s lines
and arcs, choose the style from the Line style list.

Visio applies the style to the selected shape.

Original shape

After applying the Arrow end style

Some styles contain attributes for not just a line or fill or text, but for
two or three of these items. If you choose such a style from the Line

or Fill style list, a dialog box appears asking if you want to include
other attributes of the style. Choose Yes if you want to apply all at-
tributes in the style, and No if you want to apply only the attributes

for the item indicated by the style list name (line, fill, or text).

You can use buttons on the toolbar to change some attributes. From

the toolbar, you can change line ends (such as arrowheads), shadows,
and corner rounding. From the text toolbar (which appears when a
text block is open), you can apply bold, italic, underline, size, super-

script, subscript, and color attributes to text.

To format a shape with a toolbar button:

1. Select the shape.

To format text, choose the text tool, and then click the shape to

select it and open its text block.
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2. Click the appropriate button on the toolbar to apply a local

format to the shape.

Visio cycles through various choices. For example, clicking
the Shadow button cycles through shadows of various shades
of gray.

You can format more than one shape at a time.

To Do this

Format all shapes in a group Select the group, and then the
style or attribute.

Format several shapes at once Select all the shapes, and then

the style or attribute.

Quickly repeat formatting Format one shape, select

other shapes, and then press
F4 to format the others.

If you can’t see the effect of formatting, try these things:

• Click the Zoom In button for a closer look.

• If the shape is selected, click away from the shape to cancel the
selection. That way, the selection handles won’t block your view.

• Choose Behavior from the Format menu and turn off the display
of handles that might block your view. (Don’t forget to turn the

display back on when you need to see the handles.)

v In Visio’s SmartSuite menu set, choose Behavior from the
Style menu.

• Print the page.

Corners button

Shadow button
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Understanding local formatting and styles

There are two ways to change the look of a shape. One way is with

local formatting, and the other is with styles. You can also use a com-
bination of both.

Local formatting. You can apply a formatting attribute to any shape
by selecting the shape and choosing either the appropriate option
from a dialog box or the appropriate toolbar button. This kind of

formatting is called local formatting. In general, use local formatting
to give one or just a few shapes a unique look.

Styles. If there are several attributes you want to apply to multiple
shapes in your drawing, you could apply each attribute separately to
each shape. However, the simplest way to format several shapes using

the same set of attributes is to use a formatting shortcut called a style.

A style is a named set of attributes that is saved with a template or a

drawing. When you apply a style to a shape, you can apply several at-
tributes at once. Styles make it easy to create a uniform look for any

number of shapes. And if you want to change the look, all you need
to do is edit the style. The new attribute will be applied globally to
any shape that uses that style. In general, use styles to give many or

all shapes in a drawing or group of drawings a consistent look.

You can define and apply line, fill, and text styles separately or combine them into
a single style.

ABC

Line style

Fill style

Text style
RECYCLE

RECYCLE
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Keeps these things in mind when you work with styles:

• One style can be based on another style. If you change a style, all
styles based on that style also change.

Style A

Style A1

Style A2

Style A3

Style A21

Style A22

Style A23
A style can be based on
another style. If you change
Style A, all the styles based
on Style A also change.

The attributes in these styles take precedence over
the attributes defined in Style A. An attribute for
font size defined in one of these styles overrides

the font attribute in Style A. If one of these styles
does not include an attribute for font size, then it

uses the font size defined in Style A.

• Many of the styles that come with Visio templates include

attributes for only one item: either line, fill, or text. These styles
are usually based on the Normal style.

• Typically, the styles that come in Visio templates include at-
tributes for one item. A few include attributes for all three: lines,
fills, and text. These styles are often based on one basic style for

the template. For example, an organization chart stencil might
have a basic style called Org Normal. The names of other styles
that are based on Org Normal will also start with Org, such as

Org Exec.
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• Styles follow a “home team wins” rule. This rule determines

what happens when a master shape and a drawing file each
contain a style with the same name, but the styles are defined
differently. When you drag the master shape into the drawing

file, it will use the style as it is defined in the drawing file.

• When you edit a style, the effect it has depends on where you
edit it. If you edit the style in a template file, from that point on

all future drawing files based on that template will use the new
style definition. If you edit the style in a drawing file, only that
drawing file will use the new style definition.

• If you have applied line ends (such as arrowheads) to a shape
and the style specifies no line ends, checking Preserve Local

Formatting applies the style without removing the arrowheads
from the lines.

All the ways to format shapes

There are many ways to apply styles and attributes. This section lists

all the methods.

To apply all attributes (text, line, and fill) defined in a style:

1. Choose the style from the Text, Line, or Fill style list. If a dialog
box appears asking if you want to include other aspects of the

style, choose Yes.

Alternatively, choose Style from the Format menu. In the dialog

box, choose the same style name from each of the lists.

v In Visio’s SmartSuite menu set, choose Style from the Style
menu.
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To apply only the text attributes of a style:

1. Select the shape with the text tool, and then choose the style

from the Text style list. If a dialog box appears asking whether
you want to include other aspects of the style, choose No.

Alternatively, choose Style from the Format menu, and then

choose the style you want from the Text style list.

v In Visio’s SmartSuite menu set, choose Style from the Style

menu.

To apply only the line attributes of a style:

1. Choose the style from the Line style list. If a dialog box appears
asking whether you want to include other aspects of the style,
choose No.

Alternatively, choose Style from the Format menu, and then
choose the style you want from the Line style list.

v In Visio’s SmartSuite menu set, choose Style from the Style
menu.

Check to retain local formatting you
previously applied to the shape.

Choose styles from the lists.
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To apply only the fill attributes of a style, either:

1. Choose the style from the Fill style list. If a dialog box appears
asking whether you want to include other aspects of the style,
choose No.

Alternatively, choose Style from the Format menu, and then
choose the style you want from the Fill style list.

v In Visio’s SmartSuite menu set, choose Style from the Style
menu.

To apply a style but protect the local formatting:

1. From the Format menu, choose Style.

v In Visio’s SmartSuite menu set, choose Style from the Style
menu.

2. Choose the styles you want in the dialog box.

3. Check Preserve Local Formatting.

Oval

Oval

Shape with italic text
applied directly to the shape
as local formatting.

After applying a style that contains
line, fill, and text attributes.

After applying a style that contains
line, fill, and text attributes but
preserving the local formatting.

Oval

To revert to a master shape’s styles after applying local formats to an
instance of a master shape:

1. From the Format menu, choose Style.

v In Visio’s SmartSuite menu set, choose Style from the Style
menu.
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2. In the dialog box, choose Use Master’s Format from the appro-

priate lists.

The formatting reverts to the original formatting applied to the mas-
ter shape. The Use Master’s Format item appears at the top of each

style list; you may need to scroll up to see it.

To locally format lines, fills, or text:

1. Choose the appropriate command from the Format menu.

To format text, choose Font to change character fonts. Choose
Paragraph or Tabs to change paragraph alignment. Choose Text
Block to align the text within the text block or to choose a

background color for text.

v In Visio’s SmartSuite menu set, choose Font, Paragraph, Tabs or
Text Block from the Style menu.

2. Choose the attributes you want in the dialog box.

3. To view the effect of the local formatting before you close the

dialog box, choose Apply.

If necessary, move the dialog box out of the way so you can see

the shape.

4. Choose OK to close the dialog box.

Alternatively, choose Cancel to cancel the formatting.

For line ends such as arrowheads, corner rounding, shadow place-
ment, and several text attributes, you can also use buttons on the

toolbar. Click the buttons to see variations of the attribute.
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Creating specific visual effects

Keep these tips in mind for formatting lines and arcs:

• Removing shape borders. You can make the outline of a shape
invisible by choosing None from the Line Pattern list in the Line

dialog box. You can also use this option to hide open shapes.
None is the first item in the Pattern list. You may need to scroll
up to see it.

• Creating dashed lines. To create dashed lines, choose a dashed
line pattern from the Line Pattern list in the Line dialog box.

Alternatively, you can apply a dashed line or another pattern to
the selected line by clicking the Line Pattern button in the
toolbar. Consecutive clicks apply different patterns to the line.

1 pt. Solid

Dashed Long/Short

Dashed Short

Dashed Long

No Line

The Line Pattern button applies these styles in progression.

• Creating round corners. To round the corners where two
segments meet, choose an option from the Round Corners
section in the Line dialog box or enter the number of screen

units that you want to set the corner back from its original
position. If you unite, combine, or fragment shapes, round
corners are replaced by arcs.

Corners rounded to varying degrees

Line Pattern button
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Alternatively, you can choose Corners from the Format menu

and select the appropriate setting in the dialog box. You can also
format the corners of the selected shape by consecutively clicking
the Corners button in the toolbar.

v In Visio’s SmartSuite menu set, choose Corners from the Style
menu.

• Creating arrows. You can turn any open shape into an arrow. In
the Arrow section of the Line dialog box, choose a format from
Begin to apply an arrowhead or other line end to the beginning

of the shape, and choose a format from End to apply an arrow-
head to the end of the shape.

Begin Arrow styles

End Arrow styles

Alternatively, you can apply arrowheads to one or both ends of
an open shape by clicking the Line Ends button on the toolbar.

Consecutive clicks add an arrowhead to the beginning point, the
ending point, to both ends, and to neither end.

Corners button

Line Ends button
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Document

Shapes with a None fill
are transparent.

Document

Shape with shadow

Keep these tips in mind for formatting fills and shadows:

• Creating a transparent shape. From the Fill Pattern box in the
Fill dialog box, choose None. To hide a shape completely, also

choose None from the Line Pattern list in the Line dialog box.
You can also create shapes with transparent holes in them by
using the Combine command. For details, see “Joining and

breaking up shapes” earlier in this chapter.

• Adding and deleting shadows. You can specify shadows using
either the Fill or Shadow dialog box. To add a shadow, choose an

item from the Shadow Pattern list. To change the shadow’s
colors, choose from the Shadow Foreground and Shadow
Background lists. To delete a shadow, choose None from the

Shadow Pattern list.

Alternatively, you can apply a preset series of shadow depths to
the selected shape by consecutively clicking the Shadow button
on the toolbar.

• Creating patterned fills and shadows. To fill a shape or shadow
with a pattern, choose an item other than 0 or 1 from the

appropriate pattern list. Then from the Foreground and Back-
ground lists, choose the colors you want. The Foreground color
changes the lines in the pattern. The Background color changes

the background color in the pattern.

Shadow button



                

Shapes with a variety of fill and shadow patterns applied.

• Changing the shadow offset. Each shape’s shadow can be a
different color and pattern, but all shadows on the same page are
offset from their shapes by the same distance.

To change the shadow offset:

1. From the Page menu, choose Page Setup.

2. In the Page Setup dialog box, choose Options.

The Page Setup Options dialog box appears.

Decision

Decision

Decision

Decision

Decision

Shadow offset is specified through
the Page Setup dialog box.
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3. In the Shadow Offset section, type offset amounts in the Right

and Down boxes.

Your choices affect both the size and angle of the shadow. To
move the shadow from the right to the left of the shape, enter a
negative number in the Right box. To move a shadow from the

bottom to the top of a shape, enter a negative number in the
Down box.

4. Choose OK.

5. In the Page Setup dialog box, choose OK.

Using the Size & Position command for precision

You can determine the exact size and location of a shape by choosing

the Size & Position command. You can also use options in the Size &
Position dialog box to move and size a shape. The options available
vary depending on whether you’re working with a one-dimensional

or two-dimensional shape.

Working with one-dimensional shapes

The options in the Size & Position dialog box for a one-dimensional
shape vary depending on which option you choose in the Show

section.

Decision
Decision



                

To resize a one-dimensional shape using the Size & Position
command:

1. Select the shape.

2. From the Format menu, choose Size & Position.

v In Visio’s SmartSuite menu set, choose Size & Position from the

Style menu.

Choose this option to size and move
shapes vertically and horizontally.

Choose these options to size and
move shapes, leaving one point as

an anchor.

These options control which
options are displayed...

...in this section
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The Size & Position dialog box appears.

By default, the Begin And End Points option is selected in the
Show section and the Parameters section values show the current
x- and y-coordinates of the shape’s beginning and ending points.

3. Enter new values for any or all of the options.

To resize the shape vertically, enter values for either or both the

Begin Y or End Y options. To resize the shape horizontally, enter
values for either or both the Begin X and End X options.

The line extends to match the new endpoint coordinates.

Alternatively, choose either the Begin, Length, Angle or the End,
Length, Angle option in the Show section and enter new values

for the options in the Parameters section:

• If you choose Begin, Length, Angle, specify a new value for Begin

X to resize the shape horizontally or Begin Y to resize the shape
vertically. The shape’s ending point remains a stationary anchor
point.

Decreasing the Begin X value by
1 inch moves the beginning point

1 inch to the left.

Increasing the End X value by
1 inch moves the ending point

1 inch to the right.

Original shape
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• If you choose End, Length, Angle, specify a new value for End X

to resize the shape horizontally or End Y to resize the shape
vertically. The shape’s beginning point remains a stationary
anchor point.

4. Choose Apply to see the results before you close the dialog box,
or choose OK to apply the change and close the dialog box.

To specify a new position for a one-dimensional shape:

1. Select the shape.

2. From the Format menu, choose Size & Position.

v In Visio’s SmartSuite menu set, choose Size & Position from the

Style menu.

The Size & Position dialog box appears.

By default, the Begin And End Points option is selected in the
Show section and the Parameters section values show the current
x- and y-coordinates of the shape’s beginning and ending points.

3. Enter new values for any or all of the options.

To move the shape to a new location without resizing or rotating

it, increase or decrease the X and Y values by the same amount.
For example, to move the shape down the page by 1/2 inch
decrease the values of Begin Y and End Y each by 1/2 inch.

Original shape

Decreasing the Begin X value by
1 inch moves the beginning point

1 inch to the left.

The ending point is stationary.
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4. Choose Apply to see the results before you close the dialog box,

or choose OK to close the dialog box.

If you enter new values for both the x- and y-coordinates, you
can resize and rotate the shape too.

Working with two-dimensional shapes

Using the Size & Position dialog box options, you can specify exact
dimensions for a two-dimensional shape instead of dragging a
handle to resize the shape.

To size a two-dimensional shape using the Size & Position
command:

1. Select the shape.

2. From the Format menu, choose Size & Position.

v In Visio’s SmartSuite menu set, choose Size & Position from the
Style menu.

Original shape

Decreasing the values of Begin
Y and End Y by ½ inch
moves the shape down.
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The Width and Height options display the current dimensions of
the selected shape.

3. Enter new values for either or both the Width and Height
options.

4. Choose Apply to see the results without closing the dialog box,
or choose OK to close the dialog box.

To specify a new location for a two-dimensional shape:

1. Select the shape.

2. From the Format menu, choose Size & Position.

v In Visio’s SmartSuite menu set, choose Size & Position from the
Style menu.

The Size & Position dialog box appears.

The shape diagram in the dialog box shows the current location
(x-and y-coordinates) of the shape’s center of rotation (by

default, the center of a shape). The diagram section surrounding
the center of rotation is highlighted by a dark line.

This option shows the
current angle of rotation.

These options flip the selected
shape vertically or horizontally.

These options resize
the selected shape.
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3. To specify a new location for the shape, enter new values for
either or both the X and Y options.

4. Choose Apply to see the results without closing the dialog box,
or choose OK to close the dialog box.

Visio moves the shape, placing the center of rotation at the
location you specified.

You can also use the Size & Position dialog box to change the location
of a two-dimensional shape’s center of rotation (the point around
which it rotates).

To change the center of rotation:

1. Choose the rotation tool and select the shape.

A plus sign surrounded by a circle indicates the shape’s center of
rotation.

Document

Document

Entering 3 for the X value moves
the shape horizontally so the center

aligns with the 3 on the ruler.

Original shape

Center of rotation
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2. From the Format menu, choose Size & Position.

v In Visio’s SmartSuite menu set, choose Size & Position from the
Style menu.

A section of the shape diagram at the bottom of the dialog box is
highlighted to indicate the current location of the center of
rotation.

3. Choose a different section in the diagram to move the shape’s
center of rotation to that area.

4. Choose OK to close the dialog box.

The shape’s center of rotation moves to the area you specified in
the dialog box and is positioned at the coordinates specified in
the X and Y boxes.

To refine the location, use the rotation tool to drag the center of
rotation to the location you want. For details about rotating

shapes, see Chapter 2, “Adding, arranging, and connecting
shapes.”

Original center of rotation

After choosing a new location
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Switching shapes between one- and two-dimensional behavior

A Visio shape can be either one-dimensional or two-dimensional in
its behavior. One-dimensional shapes are often used as connectors

between two two-dimensional shapes.

You can convert a shape from two-dimensional to one-dimensional

so you can use it as a connector, and you can convert a one-dimen-
sional shape to a two-dimensional shape, which allows you to size it
proportionally by dragging its corner handles.

To set a shape’s behavior as one-dimensional or two-dimensional:

1. Select the shape.

2. From the Format menu, choose Behavior.

v In Visio’s SmartSuite menu set, choose Behavior from the Style
menu.

The Behavior dialog box appears.

3. In the Interaction Style section, choose Line (1-Dimensional) or
Box (2-Dimensional).

4. Choose OK.
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Note that control handles may cause a shape to behave in ways that a

standard one-dimensional or two-dimensional shape would not. For
details, see “Working with control handles,” earlier in this chapter.

Locking and unlocking shapes

You can protect various shape behaviors from changes by locking
them with the Protection command. When a shape is locked, it dis-

plays padlocks. The protected behaviors cannot be changed unless
you unlock the shape.

Several of the master shapes that come with Visio are locked to pro-
tect their angles and dimensions. It’s best to leave these shapes locked
so they behave correctly, however you can unlock and edit them if

you want.

Shapes can also exhibit lock-like behavior because of programming

in their ShapeSheets. For details about ShapeSheets, see the Visio
online help and Chapter 8, “Using ShapeSheets to create
SmartShapes.”

To lock or unlock shape behaviors:

1. Select the shape.

2. From the Format menu, choose Protection.

v In Visio’s SmartSuite menu set, choose Protection from the Style
menu.

Satellite Dish
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The Protection dialog box appears.

3. Choose the shape behaviors that you want to lock or unlock.

When a behavior is checked, it is locked. To protect a shape from
being selected, you must check the From Selection option in the

Protection dialog box, and check Shapes in the Protect Docu-
ment dialog box.

4. Choose OK.

For details about protecting files and about displaying and editing

master shapes, see Chapter 6, “Creating masters, stencils, templates,
and styles.”

Specifying a shape’s double-click behavior
You can create shapes that behave in special ways when they are
double-clicked. For example, if you want a multiple page drawing file

to function as a presentation, you can create shapes that, when
double-clicked, display the next or previous page in the presentation.
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To specify a shape’s double-click behavior:

1. Select the shape.

2. From the Format menu, choose Double-Click.

v In Visio’s SmartSuite menu set, choose Double-Click from the
Style menu.

The Double-Click dialog box appears.

3. Choose a behavior for the shape from the dialog box, and then
choose OK.
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Adding text to drawings

Many drawings require labels, legends, and titles. All Visio shapes,

including lines, can have text. When you size, rotate, or move a
shape, its text block sizes, rotates, or moves too. You can also size,
move, and rotate a text block separately from its shape.

This chapter explains how to create, edit, move, and format text, and
how to insert fields into text.
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Typing text into shapes

To type text into a shape, just select the shape and start typing. If the
shape is a group, the text appears on the frontmost shape in the

group or on the shape that you subselect before you type. For details
about editing in groups, see “Grouping shapes” in Chapter 3, “Creat-
ing shapes.”

To type text into a shape:

1. Select the shape.

If necessary, choose the Actual Size command from the View
menu so you can see what you are typing.

2. Type the text.

As soon as you start typing, Visio opens the shape’s text block.

If the shape already contains text, the existing text is replaced by
the new text. For details about editing text, including how to add

new text to existing text, see “Editing text” later in this chapter.

3. When you are finished typing, press Esc, or click outside the

text block.

Diat
omDiatom

In a rotated shape… …the text block is
not rotated…

…but the text is when
you close the text block.
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Pasting text into shapes

You can paste text from another application by inserting it into a
shape’s text block or by replacing the entire text of a shape. To paste

text from the Clipboard into the text block of a shape, select the
shape with the text tool, and then choose Paste from the Edit menu.
The text is inserted at the insertion point, or replaces selected text.

To paste the text in a freestanding text block, drag the text tool to cre-
ate the text block, and then paste the text.

For details about copying and pasting information from another ap-
plication into a Visio drawing, see Chapter 7, “Using Visio with other

applications.”

Typing freestanding text

To type freestanding text such as a title, just click with the text tool
where you want to start typing, and then type. Visio uses a default-
size invisible shape to hold the text. If you want, you can specify a

different size before you type the text.

To type freestanding text:

1. From the text tool menu, choose the text tool.

If necessary, choose the Actual Size command from the View
menu so you can see what you are typing.

2. Click where you want to start typing.

Visio places an insertion point where you clicked.

Text tool
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3. Type.

As soon as you start typing, Visio creates an invisible shape and
opens its text block.

Insertion point

D

Visio opens a text block
automatically.

4. When you are finished typing, press Esc.

Diamond

Tip: Although you can’t type text in an object from another applica-
tion, you can type text over the object by creating a freestanding

text block.

You can specify the text block width before you type freestanding

text.

To specify a freestanding text block width:

1. With the text tool, point to where you want to start the free-
standing text block.

2. Drag left or right until the text block is the width you want.
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3. Release the mouse button, and then type.

Drag the text tool to create the text block.

For details about sizing the text block after you type text, see “Select-
ing, sizing, moving, and rotating a text block” later in this chapter.

Editing text

Editing text in Visio is similar to editing text in most word processing
programs. To edit text, you must first open the shape’s text block.

To open a shape’s text block:

1. Click the shape with the text tool.

Visio opens the text block and places the insertion point in the

text block.

Alternatively, select the shape using any tool except the text tool
and either choose Edit Text from the Edit menu or press F2 to

open the text block. (If you select a shape with the text tool and
then press F2, the text block is selected so you can resize or
move it.)

Tip: Many of the master shapes that come with Visio provide an easy

method for opening their text blocks: just double-click an instance of
the master shape. You can set the double-click behavior for a shape

using the Double-Click command. For details, see “Specifying a
shape’s double-click behavior” in Chapter 3, “Creating shapes.”
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To insert text into existing text or to select text, you first have to place

the insertion point.

To place the insertion point and add text to existing text:

1. Open the text block.

2. Click where you want to place the insertion point.

3. Type the new text.

You can move the insertion point by clicking anywhere in the text
block. You can also move the insertion point by using the keyboard,
as shown in the following table.

To move the insertion point to the Press

Beginning of text block Ctrl+Home

End of text block Ctrl+End

Beginning of paragraph Ctrl+Up Arrow

End of paragraph Ctrl+Down Arrow

Preceding line Up Arrow

Following line Down Arrow

Beginning of line Home

End of line End

Beginning of word Ctrl+Left Arrow

End of word Ctrl+Right Arrow

Character to left Left Arrow

Character to right Right Arrow
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Before you copy, delete, paste, or format text, you must open the text

block and select the text you want to work with. If no text is selected,
the changes you make affect the entire text block. The following table
shows some ways to select text in an open text block.

To Do this

Select all text Choose Select All from the Edit menu

Select character(s) Click and drag

Select word Double-click

Select paragraph Triple-click

You copy, cut, or paste text in Visio the same way as in most word

processing programs. Remember that you can reverse text changes
with the Undo command just as you reverse other actions in Visio.
Also keep in mind that you can quickly repeat an action—for ex-

ample, pasting text—by pressing the F4 key.

To copy or cut selected text:

1. With the text block open, select the text.

2. From the Edit menu, choose the appropriate command—Copy
or Cut.

Visio copies or cuts the text and places the text on the Clipboard.

You can copy the entire contents of a text block without selecting
anything. Just place the insertion point in the text block and then

choose Copy.

To paste text:

1. With the text block open, place the insertion point where you
want to paste the text.

2. From the Edit menu, choose Paste.

Visio pastes text from the Clipboard.
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You can type special characters in Visio by pressing a combination of

keys on the keyboard. You can also insert special ANSI characters
into text. The ANSI character set consists of 256 characters estab-
lished by the American National Standards Institute. The appearance

of the character that is displayed when you type a special character or
an ANSI character code depends on the font you are using.

To type ANSI characters:

1. Hold down the Alt key. Using the keys on the numeric keypad,

type 0, and then the ANSI code for the character you want.

For example, to type an em dash (—), hold down the Alt key
and type 0151.

For information on the special character key-combinations and the
character codes for special ANSI characters, see Appendix B, “Shortcuts.”

Selecting, sizing, moving, and rotating a text block

When you size, move, or rotate a shape, its text block also sizes,
moves, or rotates. However, you can also size, move, or rotate a text
block independently of its shape, as explained in this section.

Before you can rotate, size, or move a text block, you must select it.

To select a text block:

1. From the text tool menu, choose the text block tool.

2. Click the shape whose text block you want to select.

Alternatively, select the shape with the text tool, and then press

F2 to select the text block.

Text block tool
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Decision

The text block displays selection handles; in addition, two-
dimensional shapes display rotation handles at their corners.
When you select the text block of a line, it appears that the line

itself is selected, but it’s really the text block that’s selected.

When you type text into a shape, the text block width is deter-

mined by the shape width. When you type freestanding text,
Visio uses a default text block width unless you specify a differ-
ent width before you type. The text block height is determined

by how much text you type and the text block width. You can
change the text block width or height without changing the size
of a shape.

To change the text block width or height:

1. Choose the text block tool, and then click the shape to select its

text block.

2. Drag a selection handle until the text block is the width or

height that you want.

The pointer changes to a double-headed arrow when it is over a
selection handle.

ManagerManage
r

Drag the handle. The text wraps to fit the new width.
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Moving a text block away from its shape is a good way to create a la-

bel that moves with the shape. You can move a shape’s text block
partially or completely outside the shape’s borders. Even if the text
block is not touching the shape, it moves, rotates, and sizes with the

shape. It’s often helpful to move a line’s text away from the line to
improve its legibility.

To move text independently of its shape:

1. Choose the text block tool, and then click the shape to select its

text block.

2. Point to the text block.

When the pointer is over the text block, it changes to two
rectangles. Do not point to a selection handle or rotation handle
unless you want to size or rotate the text block.

Decision

Decision

Decision

Drag the text block
with the text block tool.

3. Drag the text block to where you want it and release the mouse

button.

Text does not have to be oriented on the drawing page the same way
as its shape. You can rotate text to any angle independently of

its shape.
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To rotate text independently of its shape:

1. Choose the text block tool, and then click the shape to select its
text block.

2. If you don’t see rotation handles on the text block, drag the
middle selection handle out until you see the rotation handles.

When the pointer is over a rotation handle it changes to two

arrows in a circle.

3. Drag a rotation handle.

For details about rotating shapes, see Chapter 2, “Adding, arranging,
and connecting shapes.”

Document

D
oc

um
en

t

D
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You can rotate text independently of the shape.

Formatting text

This section provides guidelines for formatting text, including how
to format individual paragraphs, words, and characters. You format
an entire text block the same way you format a shape’s lines and fill.

For details about applying attributes and styles to shapes, see “For-
matting shapes” in Chapter 3, “Creating shapes.” For details about
creating styles, see “Creating and editing styles” in Chapter 6, “Creat-

ing masters, stencils, templates, and styles.”

There are several ways to format text. Visio has four text formatting

dialog boxes; each controls a visual attribute of text. You can also for-
mat text using the Style dialog box and the Text style list, the Font
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list, and formatting buttons (such as the Bold button) on the toolbar.

You can format an entire text block, or you can format selected text,
such as individual paragraphs and characters.

To format an entire text block:

1. Select the shape.

When you want to format an entire text block, it’s best to select
the shape with the text tool so that the text toolbar and text
formatting lists appear.

1 Text style list 10 Subscript
2 Font list 11 Left Align Text

3 Font size list 12 Center Align Text
4 Text Color 13 Right Align Text
5 Font size 14 Justify Text

6 Bold 15 Top Align Text
7 Italic 16 Center Align Text
8 Underline 17 Bottom Align Text

9 Superscript 18 Zoom Text 100%

v In Visio’s Microsoft Office toolbar and menu set, the Text Style

list, the Font list, and the Font size list appear on the text toolbar.

2. Choose the formats or styles you want.

Visio applies the formatting to the text.

3. Press Esc.

1 2 3

4 5 6 7 8 9 10 11 12 13 14 15 16 17 18Visio standard toolbar

Visio standard status bar
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You can color just the background of the text block without coloring

the entire shape.

To color the text block background:

1. Select the shape.

2. From the Format menu, choose Text Block.

v In Visio’s SmartSuite menu set, choose Text Block from the Style
menu.

3. Choose a color from the Text Background section of the dialog
box, and then choose OK.

Triangle

Visio applies color to the text block, which may be sized differently from the shape.

To format individual paragraphs, words, or characters, you must first
select them. The options listed in the Paragraph and Tabs dialog
boxes apply to entire paragraphs. So do the alignment options you

specify in the Paragraph or Text Block dialog boxes or by clicking the
appropriate alignment button on the toolbar. You can also apply at-
tributes such as font styles to individual characters.

To format individual paragraphs, words, or characters:

1. Open the text block using the text tool.

2. Select the text you want to format.

If you want to format a paragraph, select all or part of the
paragraph.

3. Choose the attributes you want.
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Visio has four text formatting dialog boxes. Each controls a set of

text attributes.

To specify font attributes and character position:

1. Select the characters or text block you want to format.

2. From the Format menu, choose Font.

v In Visio’s SmartSuite menu set, choose Font from the Style
menu.

Visio displays the Font dialog box, which contains options for
specifying the font, font color, font size, style, case, and the
character position relative to the text line.

3. Choose the attributes you want, and then choose OK to format
the text and close the dialog box.

Alternatively, choose Apply to format the text without closing
the dialog box so you can see the change.

To specify horizontal alignment and vertical line spacing:

1. Select the paragraph or text block you want to format.

2. From the Format menu, choose Paragraph.

v In Visio’s SmartSuite menu set, choose Paragraph from the Style

menu.

These buttons open the other
text formatting dialog boxes.

Choose these buttons to
format the shape associated

with the text block.
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Visio displays the Paragraph dialog box, which controls how

paragraphs align with the left and right text block margins and
how paragraphs and lines are spaced vertically within the
text block.

3. Choose the attributes you want, and then choose OK to format
the text and close the dialog box.

Alternatively, choose Apply to format the text without closing

the dialog box so you can see the change.

To specify the tab indentations for selected paragraphs:

1. Select the paragraph you want to format.

2. From the Format menu, choose Tabs.

v In Visio’s SmartSuite menu set, choose Tabs from the Style

menu.

Opens the Font
dialog box for
setting character
attributes.

Sets the distance between paragraphs
and between lines of text.

Sets the distance between a paragraph
and the edge of a text block.
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Visio displays the Tabs dialog box, which contains options for

setting tab stops in the selected paragraph.

3. Choose the attributes you want, and then choose OK to format

the text and close the dialog box.

Alternatively, choose Apply to format the text without closing
the dialog box so you can see the change.

To specify the margins and vertical alignment:

1. Select the text block you want to format.

2. From the Format menu, choose Text Block.

v In Visio’s SmartSuite menu set, choose Text Block from the Style
menu.

Visio displays the Text Block dialog box, which contains options
for setting the margins between text and the edges of the text
block, the vertical alignment of text in relation to the text block,

and the text block background. These formats apply to the entire
text block.

Lists the tabs currently set for
the selected text block.

To add a tab stop, enter the
settings here and choose Add.
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3. Choose the attributes you want, and then choose OK to format
the text and close the dialog box.

Alternatively, choose Apply to format the text without closing
the dialog box so you can see the change.

For more details about the text formatting dialog boxes, see their en-
tries in the Visio online help.

Using fields
A field is a placeholder in a text block that displays information—for
example, a date, time, or measurement—that changes automatically as

you update a drawing. You can use fields in drawings to add dimension
lines, callouts, and legends that reflect the drawing’s current state.

Some field categories, such as Geometry and Date/Time, are useful
for providing up-to-the-minute information in final drawings.
Other field categories, such as Document Info, Object Info, and Page

Info, help you keep track of information as you work on a drawing.
For example, one of the Object Info fields displays a shape’s ID num-
ber and another displays its name. You might want to use this

information to ensure that a technical drawing includes its required
elements. However, you might delete these fields before you print the
final drawing.

Opens the Font
dialog box for
setting character
attributes.
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You can use predefined fields or create your own formulas for fields.

You can also specify a format for each field. A text block can contain
as many fields as you want. You can format or delete fields in the
same way as you format or delete other text.

You can choose fields from the following field categories:

• Custom Formula. Displays the result of a calculation you
define by entering a formula. Formulas use ShapeSheet func-
tions. For details, see Chapter 8, “Using ShapeSheets to create

SmartShapes.”

• Date/Time. Displays file creation, revision, printing date and
time information, and the current date and time. These fields

are based on the system date and time.

• Document Info. Displays the information entered in the Sum-

mary Info dialog box for a drawing file, such as the file’s name,
creator, and description. For details about the Summary Info
command, see its entry in the Visio online help.

v In Visio’s SmartSuite menu set, the name of the command and
the dialog box is Doc Info.

• Geometry. Displays width, height, and angle information. Use
the Width field for dimension lines. Use the Angle field to show
how far a shape is rotated from its original position. Use any of

these fields to automatically update technical specifications in
a drawing.

• Object Info. Displays the information entered in the Special
dialog box, such as the shape’s master shape name and ID
number. The Data fields can contain any information you

choose. For details about the Special command, see its entry in
the Visio online help.

• Page Info. Displays information about the foreground page of a

drawing based on information in the Page Setup dialog box.
Even if these fields are on a background page, they display
information about the foreground of the drawing. Use the

Number field to include a page number. For details about the
Page Setup command, see its entry in the Visio online help.
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• Lotus Notes Field. Lotus Notes can read file summary informa-

tion from a Visio drawing. Likewise, Visio can read text from
Lotus Notes. For details about this field category, see Chapter 7,
“Using Visio with other applications.”

To insert a field into text:

1. With the text block open, click with the text tool where you want

to insert the field.

If you want the field to replace all the existing text in the shape,

just select the shape. You don’t have to open the text block and
place an insertion point.

2. From the Edit menu, choose Text Field.

The Text Field dialog box appears.

The Field and Format lists vary depending on the category you choose.

3. Choose a field category.

Unless you choose Custom Formula, Visio displays the fields for
the category.

4. Choose a field.

If you chose Custom Formula as the category, enter the formula
in the Custom Formula box.

5. Choose a format for the field information.
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6. Choose OK.

Visio inserts the field at the insertion point. The field displays its
current information. For example, the Current Date field
displays the current system date in the format you chose.

Tip: Consider adding phrases before or after fields. For example, be-

fore the Current Date field you might type the phrase “Today’s date
is” followed by a space.

To create custom formulas, you use the same functions and syntax
used to create ShapeSheet formulas. For details about the

ShapeSheet, see Chapter 8, “Using ShapeSheets to create
SmartShapes,” and the Visio online help.

Dynamic dimension lines are a valuable addition to many types of
drawings. This procedure explains how to create a dimension line us-
ing a field.

To create a dimension line:

1. Draw a line. Add arrowheads to it if you want.

2. To create the text for the dimension line, select the line, and then
choose Text Field from the Edit menu. In the dialog box, choose

Geometry as the category and Width as the field. Choose a
format if you want, and then choose OK.
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The field appears on the line.

You can make the line look better by adding a background to the
field text.

3. To add the background, select the line, and then choose Text
Block from the Format menu.

v In Visio’s SmartSuite menu set, choose Text Block from the Style
menu.

In the dialog box, choose white as the solid color in the Text
Background section, and then choose OK.
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4. To test the field, resize the line by dragging one of its endpoints.

The field text changes as the line length changes.




Creating and printing drawing pages
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Creating and printing
drawing pages

The drawings you create may often be parts of larger projects that in-

clude several related drawings or other documents. In many cases,
you may need to maintain visual standards, use special symbols, or
adhere to certain industry specifications such as page sizes and scales.

And in the end, you’ll probably need to print your drawings for other
people to see.

This chapter explains how to:

• Create and store several pages in a drawing file, so you can

easily access and modify them as a set.

• Give a set of drawings a similar look by using backgrounds.

• Set page size and scale to meet industry or corporate
requirements.

• Print drawings, including printing at certain sizes and page
orientations.

To help maintain a consistent look in your drawings you can also cre-
ate your own master shapes, templates, and stencils. For details, see
Chapter 6, “Creating masters, stencils, templates, and styles.” If

you want to use a Visio drawing in a word processing document such
as a report, or use another file in Visio, see Chapter 7, “Using Visio
with other applications.”
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Working with drawing pages

This section describes foreground and background pages, how to
create new drawing pages, and how to work with the pages in a draw-

ing file.

The New Page and Page Setup commands display similar dialog

boxes. To create and set options for a new page, use New Page. To
change the displayed page, use Page Setup.

About foreground and background pages

A drawing can be composed of layers of information. Each drawing

you create has a layer called a foreground page. Each foreground page
can be assigned a layer called a background page, which is useful for
adding shapes that appear on every page in the drawing file (for ex-

ample a corporate logo or the outer walls in a home design).

A foreground page can be assigned only one background page.

However, a background page can be assigned to more than one fore-
ground page. In addition, each background page can be assigned its
own background page, allowing you to create multiple levels in your

drawing.

The following sections describe how to create and display pages and

how to arrange foreground pages in a drawing file. For details about
assigning background pages, see “Working with backgrounds” later
in this chapter.

Creating a new page

Unless you specify otherwise in the New Page dialog box, a new page
you create uses the same Page Setup settings as the page displayed in

the drawing window. If you want to change page size and scale, see
“Changing the drawing size and scale” later in this chapter.
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To create a new page based on the displayed page:

1. From the Page menu, choose New Page.

2. In the dialog box, name the page if you want, or use the default

name provided by Visio.

Using the default name can be advantageous when reordering

pages. For details, see “Rearranging foreground pages” later in
this chapter.

3. Choose OK.

Visio displays the new page in the current window or in a new
window if you check Open Page In New Window in the New

Page dialog box.

Displaying pages

Visio displays one page in a drawing window at a time. You can dis-
play a different page in the window, or you can open other drawing

windows so you can see more than one page at a time or see more
than one view of the same page.



         

To display a different page in a drawing window:

1. From the Page menu, choose Go To Page.

2. In the dialog box, choose the page that you want to display in the
current window.

3. Choose OK.

Alternatively, if you are working on a foreground page, you can

click the Next Page or Previous Page button on the toolbar to
turn a single page at a time.

Tip: In Windows applications, you can hold down the Alt key and
type the underlined letters in the menu and command names to

open dialog boxes automatically. For example, to display the Go To
Page dialog box, press Alt+P+G.

To open a new drawing window and display a page in it:

1. From the Window menu, choose New Window.

If you choose New Window when a drawing window is open, the
new window displays a duplicate of the contents of the open

window. If no drawing window is open, New Window opens a
copy of the active stencil window.

2. To see the open windows, choose Tile from the Window menu.

Alternatively, you can display a page in a new window by
checking Open Page In New Window in either the New Page or

Go To Page dialog box.

Lists all foreground and
background pages.

Visio standard and
Microsoft Office toolbar

Lotus SmartSuite toolbar
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Rearranging foreground pages

Drawings print in the order in which their foreground pages are

stored. You can view and change the order of foreground pages by
using the Reorder Pages command. When you create a new fore-
ground page, Visio stores it last in the order of all the foreground

pages in the file.

To change the order of foreground pages:

1. From the Page menu, choose Reorder Pages.

2. In the dialog box, choose the page you want to move.

The list displays the page names in the order that the pages are
stored in the file.

3. Choose Move Up or Move Down to move the page to a
new position.

The list order changes.

4. If you want the default page names to reflect the new page order,

check Update Page Names.

If a page has a name other than its default name, checking this
option has no effect.

5. Choose OK.

This option updates only the default
names, not custom names.
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Deleting pages

If you no longer need a page, delete it. However, you cannot delete a

background page that is assigned to another page. For details about
canceling a page’s background assignment, see “Working with back-
grounds” later in this chapter.

To delete a page:

1. From the Page menu, choose Delete Pages.

2. In the dialog box, choose the page or pages you want to delete.

To delete a range of pages, choose a page, and then hold down
the Shift key and choose another page. Those pages and any
pages between them are selected. To delete non-consecutive

pages, choose a page, and then hold down the Ctrl key and
choose another page.

3. If you want the default page names to reflect the new page order,
check Update Page Names.

If a page has a name other than its default name, checking this

option has no effect.

4. Choose OK.

If you try to delete the last remaining page in a file, Visio replaces that
page with a blank page.
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Setting page display options

For each page, you can specify units of measure for rulers as well as

spacing for ruler subdivisions and grid lines.

To change the ruler units of measure:

1. From the Page menu, choose Page Setup.

The Page Setup dialog box appears.

2. From the Measurements list, choose a unit of measure.

3. Choose OK.

Setting a drawing scale often changes the units of measure on the
rulers. For details, see “Changing the drawing size and scale” later in
this chapter.

To set grid line and ruler subdivisions:

1. From the Page menu, choose Page Setup.

The Page Setup dialog box appears.

2. Choose Options.
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The Page Setup Options dialog box appears.

3. In the Subdivision Spacing section, choose Fine, Normal, or
Coarse for grid line and ruler subdivisions.

Fine grid Normal grid Coarse grid

4. Choose OK.

5. In the Page Setup dialog box, choose OK.

You can also adjust the page magnification and other aspects of the
screen display. For details, see Chapter 1, “Getting started with Visio.”

For details about changing the page orientation, see “Changing the
drawing page, printed drawing, and paper size together” later in
this chapter.

Working with backgrounds

You can assign one background page to each foreground page. And
each background page can have a background, so you can effectively

create drawings that are several layers deep. A foreground, its back-
ground, and other backgrounds progressively assigned to a drawing
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work like transparent sheets. From the foreground, you can see

through to the shapes on the backgrounds.

Every drawing must have a foreground page. Foreground pages can-

not be assigned to other pages; the foreground is always the topmost
layer of a drawing. A drawing, however, does not have to have a back-
ground page.

This section describes some typical uses of backgrounds and then ex-
plains how to create, assign, and edit background pages.

Working in layers

Use layered drawings to:

• Show the same shapes in the same place in several drawings. If
you want a logo, border, title, or other shapes to appear in
several drawings, place the shapes on a background page and

assign that background to as many pages as you want. When you
edit the background page, you’ll see the changes in all of the
drawings that use that background.

Background page

Foreground page with
background page assigned to it
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The same background assigned to several foregrounds

• View, edit, and print part of a drawing without affecting other
parts. By placing some information on the foreground and other
information on one or more backgrounds, you can build a

drawing progressively and, if necessary, view, edit, or print parts
of the drawing separately. For example, you might use a fore-
ground and several backgrounds to show how a river changes

course over time, or to show the skeletal, muscular, and circula-
tory systems of an animal.

Background page
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Visio

Visio
Final drawing: what you see when you
view the foreground page with the
assigned backgrounds

Background 1

Background 2

Background 3

Background 4

Foreground with no
backgrounds assigned

Background 1 assigned
to Background 2

Background 2 assigned
to Background 3

Background 3 assigned
to Background 4

• Use different scales for parts of a drawing. You might need to

scale a map without scaling its legend. Or you might need to
reduce an organization chart for an annual report without
changing the registration marks used for printing the report. If a

drawing requires shapes created at different scales, use a fore-
ground page and one or more background pages to separate the
shapes by scale. You can also use layered pages to include shapes

with different shadow offsets in the same drawing.
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# 16038a

# 18037

# 17011a

# 17012

No. Description Quantity
# 17011aChair 4
# 17012 Circular Table 1
# 16037 Desk 1
# 16038aDesk Chair 1
# 18037 Plant 3

No. Description Quantity
# 17011aChair 4
# 17012 Circular Table 1
# 16037 Desk 1
# 16038aDesk Chair 1
# 18037 Plant 3

# 16037# 17012

# 16038a
# 17011a

# 18037

No. Description Quantity
# 17011aChair 4
# 17012 Circular Table 1
# 16037 Desk 1
# 16038aDesk Chair 1
# 18037 Plant 3

Creating a background page

You can create a new page as a background, or convert a foreground

page to a background.

To create a background page:

1. From the Page menu, choose Page Setup or New Page.

The Page Setup or New Page dialog box appears.

2. In the Type section, choose Background.

3. Choose OK.

Visio adds the background name to the Background list in the New

Page and Page Setup dialog boxes.

Background page is
unscaled (one-to-one scale).

Foreground page with scale
of 1/2 inch = 1 foot.

Foreground page with scale
of 1/4 inch = 1 foot.
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Assigning a background page

You can assign only one background page to each existing or new

page. However, you can assign the same background page to as
many pages as you want. If you decide you no longer want a back-
ground page assigned to a particular page, you can cancel the

assignment.

To assign a background to a page:

1. Display the page to which you want to assign the background.

2. From the Page menu, choose Page Setup. The Page Setup dialog
box appears.

3. From the Background list, choose the name of the background

that you want to assign to the page.

4. Choose OK.

Tip: You can assign a background to a new page by choosing a back-

ground from the Background list in the New Page dialog box.

To cancel a page’s background assignment:

1. Display the page to which the background is assigned.

2. From the Page menu, choose Page Setup.

3. From the Background list, choose None.

4. Choose OK.

Guidelines for editing a background

You edit a background the same way you edit a foreground, but you
may want to do something extra. It’s helpful to display the back-

ground in one window and the page it’s assigned to in another
window, so you can see how your changes affect both.
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To display a page and its background in separate windows:

1. Display the page to which the background is assigned.

2. From the Page menu, choose Go To Page.

3. Choose the background name and check the Open Page In New
Window option.

4. Choose OK.

Another drawing window opens, displaying the background.

5. From the Window menu, choose Tile.

When the pointer is over a background shape in the window that dis-
plays the foreground, the pointer remains black. This means you

cannot edit the background shape from the foreground view.

Tip: To move between the foreground and the background pages in a
drawing, use the Edit Foreground and Edit Background commands

on the Tools menu. While the foreground is displayed, choose Edit
Background to display its background. Choose Edit Background
again to cycle through all the background pages for the drawing. To

return to the foreground, choose Edit Foreground.

…you’ll also see the
changes in the window

that displays the
foreground.

When you edit this
shape on the

background…
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Changing the drawing size and scale

Some drawings such as floor plans are drawn on a scale of feet to
inches. Other drawings are very large or very small and require a

drawing page other than the standard letter-size page. This section
explains the relationship between the drawing page, the printed
drawing, and the paper size. The section also shows you how to

change the drawing size and scale.

About the drawing page, printed drawing, and paper size

If you open a new file without a template (or if the template with
which you open a file does not change the drawing page size or

scale), the drawing page, printed drawing, and paper size are the di-
mensions you specified in the default paper size settings in Windows,
and the drawing scale is one to one. These settings are displayed in

the Print Setup dialog box.

Understanding the differences between the drawing page, printed

drawing, and paper size is important if you want to adjust the draw-
ing size or scale or the print settings. Here are the differences:

• The drawing page is the page you see in the drawing window.
The rulers indicate its size, although it might look larger or
smaller than its actual size depending on the magnification of

the page display.

• The printed drawing is the drawing page when it is printed. The

drawing page and the printed drawing are the same size unless
you specify a drawing scale other than one to one or you reduce
or enlarge the drawing when you print it.

• The paper size is the size of the paper on which you print
drawings. Most laser printers accept only standard paper sizes,
such as 8.5-by-11-inch paper. The drawing page and printed

page are the same size as the paper unless you specify a drawing
page size that is different from the paper size.
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By default, the drawing page in the drawing window, the printed

drawing, and the paper on which the drawing is printed are the
same size.
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However, the drawing page, the printed drawing, and the paper size
can be different from each other.
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Changing the drawing page, printed drawing, and
paper size together

You can change the drawing page, printed drawing, and paper to a

new size by setting options in the Print Setup dialog box. To ensure
that the drawing page is the same size as the paper size specified in
the Print Setup dialog box, you must verify a setting in the Page

Setup Size/Scale dialog box.
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Visio saves the Print Setup dialog box settings with each drawing file.

A drawing page inherits the Print Setup settings unless you specify a
different size for the drawing page. A new drawing file uses the de-
fault Print Setup settings or the Print Setup and Page Setup settings

saved in the template with which you opened the new file.

To change the drawing page, printed page, and paper size:

1. From the File menu, choose Print Setup.

The Print Setup dialog box appears.

2. In the Orientation section, choose Portrait or Landscape.

For tall pages, choose Portrait. For wide pages, choose
Landscape.

3. In the Paper section, choose a size from the Size list.

4. Choose OK.

Changing the Print Setup settings affects a drawing page only if Same
As Print Setup is checked in the Page Setup Size/Scale dialog box.

The printed drawing is the same size as the drawing page and paper
if the drawing scale is one to one and if you do not reduce or enlarge
the page during printing.

Portrait Landscape
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To ensure that a drawing page and printed drawing inherit the Print
Setup settings:

1. Display the drawing page.

2. From the Page menu, choose Page Setup.

3. In the dialog box, choose Size/Scale.

The Page Setup Size/Scale dialog box appears.

4. In the Drawing Size section, make sure Same As Print Setup
is chosen.

5. In the Drawing Scale section, make sure No Scale (1:1) is chosen.

6. Choose OK.

7. In the Page Setup dialog box, choose OK.
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Setting the drawing page size independently of the
paper size

To make a complex drawing (for example, a flowchart for a large

project) easy to read,  you might need to create it on a drawing page
larger than the paper in your printer. You may also want to create
a small drawing that you will print at various locations on a sheet

of paper.

You can create drawing pages that are a different size from the paper

specified in the Print Setup dialog box. A large drawing page is auto-
matically tiled (printed over several sheets of paper). A small drawing
page easily prints at various locations on a sheet of paper. For details

about printing large and small drawings, see “Printing” later in
this chapter.

Printing
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Large drawing tiled to fit 8.5-by-11-inch paper Small drawing printed at various
locations on 8.5-by-11-inch paper

To size a drawing page independently of the paper size:

1. Display the drawing page.

2. From the Page menu, choose Page Setup.
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3. In the Page Setup dialog box, choose Size/Scale.

The Page Setup Size/Scale dialog box appears.

4. In the Drawing Size section, choose an option other than Same

As Print Setup.

5. Choose OK.

6. In the Page Setup dialog box, choose OK.

If you change the drawing page size in relation to the paper size, keep
in mind that:

• The Standard list reflects page orientation as well as size. The
first measurement is the width and the second is the height. So,

to change a letter-size drawing page from tall to wide, choose
Letter Wide (11 in. x 8.5 in.).

• Changing the drawing page orientation by changing its size does
not change the paper orientation. Mismatched orientations
could result in your drawing not printing correctly. To change

the orientation, use the Print Setup dialog box.

• Changing the size of a drawing page does not change the size of
a background page assigned to it. You must change the size of a

background separately.
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• The printed drawing is the same size as the drawing page unless

you set a drawing scale other than one to one or reduce or
enlarge the drawing for printing.

• If you choose Tightly Enclose Page’s Objects in the Page Setup/

Size Scale dialog box and then edit your drawing, the page may
no longer tightly enclose the shapes. To reapply the Tightly
Enclose Page’s Objects option, choose Page Setup from the Page

menu, and then choose OK.

Setting a drawing scale

To create accurate architectural, engineering, and scientific drawings,
you need to draw them to scale. The scale determines the relation-

ship of the drawing page to the printed drawing (unless you also
reduce or enlarge the printed drawing in the Print Setup dialog box).

To create drawings that represent very small or very
large areas, set a drawing scale.

To set a drawing scale:

1. Display the drawing page.

2. From the Page menu, choose Page Setup.

3. In the Page Setup dialog box, choose Size/Scale.

The Page Setup Size/Scale dialog box appears.

Rulers reflect the
drawing scale.
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4. In the Drawing Scale section, choose a standard architectural or

engineering scale or enter a custom scale.

5. Choose OK.

6. In the Page Setup dialog box, choose OK.

If you change the drawing scale, keep in mind that:

• The ruler units are the same as those specified in the drawing

scale unless you specify different units in the Measurements list
in the Page Setup dialog box.

• Changing the scale of a drawing page does not change the scale
of a background page assigned to it.

• Most master shapes are designed for drawings with a scale of one

to one. A few, such as the space planning master shapes, are
designed for drawings with a specific scale. Visio compensates
for an instance whose scale differs greatly from the drawing’s

scale. In some cases, however, if you drag a master into a draw-
ing that has an inappropriate scale, its instance (or part of its
instance) might be too large or too small.

…or enter a custom scale.

Choose a standard scale…

Displays the printed drawing size.

Displays the drawing
page size in scaled units.

Unit size on the drawing page,
as indicated by the rulers in

the drawing window.
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To change the drawing size for printing, use the Print Setup dialog

box. For details, see “Reducing and enlarging drawings for printing”
later in this chapter.

Printing

To print most drawings you simply choose Print from the File menu,
and then choose OK in the Print dialog box. However, for some

drawings you may need to adjust margins, set how color prints on
monochrome printers, or determine whether the drawing page
should print full-size or reduced. This section covers how to print

and how to adjust print settings.

To print a drawing:

1. From the File menu, choose Print.

The Print dialog box appears.

2. In the Print Range section, choose All Pages, Current Page, or
enter a range of pages in the Pages From and To boxes.

Visio prints drawings in the order in which their foreground
pages are stored in the drawing file.

If a foreground is displayed, Current Page prints the entire

drawing, including the foreground page and all the background
pages for the drawing. If a background is displayed, Current
Page prints that background page and all the other background

pages for the drawing.
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3. In the Print Quality box, choose the quality setting you want.

The quality settings vary by printer. For details, see the docu-
mentation for your printer.

4. To print multiple copies, in the Options section, specify the num-
ber of copies you want. To collate the copies, check Collate Copies.

5. To print to a file, in the Options section check Print To File.

For details, see “Printing to a file” later in this chapter.

6. To print colors as black, in the Options section check Color

As Black.

For details, see “Printing colored drawings on monochrome

printers” later in this chapter.

7. Choose OK.

To print the current page:

1. Click the Print button on the toolbar.

Visio prints the page currently displayed.

To print a page without its background:

1. Display the page you want to print.

2. From the Page menu, choose Page Setup.

3. Cancel the background assignment by choosing None from the

Background list.

Alternatively, you can select each shape on the background,

choose Behavior from the Format menu, and check Non-
Printing Shape.

v In Visio’s SmartSuite menu set, choose Behavior from the

Style menu.

Visio standard and
Microsoft Office toolbar

Lotus SmartSuite toolbar



                                       

To print a background page and its backgrounds:

1. Display the background in an open window.

2. From the File menu, choose Print.

3. Check the Current Page option, and then choose OK.

Alternatively, click the Print button on the toolbar.

Note that this procedure prints the background page plus any
background pages assigned to it. For details about canceling a
background assignment, see “Assigning a background page”

earlier in this chapter.

Printing large and small drawings

Visio tiles drawings that are larger than the paper size.

Tile area for
upper-left corner

Tile area for
lower-left corner

Overlap

Printing

A
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x

Printing
A

ja
x

Visio standard and
Microsoft Office toolbar

Lotus SmartSuite toolbar



         

By changing margin settings, you can print a small drawing at vari-

ous locations on a sheet of paper.
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You can move a drawing by setting margins and options for centering the drawing in the
Print Setup dialog box. The illustration at the left uses no centering option. In the middle
illustration, the image is centered horizontally (Left/Right). In the illustration at the right,
the image is centered both horizontally and vertically.

Previewing a printed drawing

Before you print a drawing, you can preview it to see how it will ap-
pear when it is printed. Previewing a drawing is especially helpful if

you need to know if a drawing fits within the margins of a page or if
you want to see how a large drawing tiles.

To preview the printed version of the current drawing:

1. From the File menu, choose Print Preview.

Alternatively, click the Print Preview button on the toolbar.

Leb
oMountain

B i k e s

By default, a small drawing prints
in the upper-left corner within the
margins. The default margins are
0.25 inches wide.

Visio standard and
Microsoft Office toolbar

Lotus SmartSuite toolbar
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Visio displays the current drawing in the print preview window.

The preview image reflects the current settings in the Print
Options dialog box. If the drawing page is larger than the paper
specified in the Print Setup dialog box, Visio displays the entire

drawing and shows where the drawing will be tiled when
printed.

By previewing a drawing, you can see how the drawing fits within the margins
of a page.

In the print preview window, you can preview any drawing in the
file. You can also look at a close-up view of any tile in a tiled drawing
and zoom in on a tile to view it at its actual size.

To view other drawings in the same drawing file:

1. From the View menu, choose the appropriate command:
Previous Tile, Next Tile, or Go To Page.

Alternatively, use the First Tile, Previous Tile, Next Tile, and Last
Tile buttons on the toolbar.

Printable area

Zooms the view of the drawing

Closes the print preview window
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To switch between the whole page view and single tile view of a tiled
drawing:

1. From the View menu, choose the appropriate command:  Single
Tile or Whole Page.

Alternatively, you can click a tile area to view it close up, or click
the background of the print preview window to return to Whole

Page view.

 You can also use the Zoom In and Zoom Out buttons to change
the view in the print preview window.

Visio previews a large drawing as it will be tiled when printed. The gray lines
outline the edges of each tile.

To close the print preview window:

1. Choose the Close button on the toolbar.

Viewing how a drawing fits on the page

When working in the drawing window, you can quickly check how a

drawing fits within the printable area of the paper specified in the
Print Setup dialog box. You can check to make sure that a drawing

Switches the display of pages
or tiles depending on the view.

Displays the whole page.

Displays a single tile.

Click a tile to display
the tile close up.

Click the background to
display the whole page.
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will fit on one page or see where a large drawing will tile. If the draw-

ing will not fit on one page, or if a tile does not show the shapes you
want, you can adjust your drawing to make it fit.

To view how a drawing fits on the page:

1.  From the View menu in the drawing window, choose Page

Breaks.

If the drawing will be tiled, Visio outlines the edges of the tiles.
If the drawing fits on the currently chosen paper size, Visio

outlines the border of the page.

Page breaks show how an 11 x 17 inch drawing page is tiled to fit on 8½ x 11
inch paper.

If a drawing does not fit within the printable area of a piece of paper,
you can adjust the drawing in the following ways to make it fit:

• In the drawing window, move shapes away from the edges of the
drawing page. Alternatively, choose Center Drawing from the
Tools menu to center the drawing on the page. For details, see

Chapter 2, “Adding, arranging, and connecting shapes.”

Gray lines indicate page breaks.
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• Before you print, reduce the drawing by a small amount. For

details, see “Reducing and enlarging drawings for printing” next
in this chapter.

• Set margins, and then specify that you want to fit the printed

drawing on one page. For details, see “Setting margins” later in
this chapter.

Reducing and enlarging drawings for printing

You can reduce or enlarge a drawing for printing. This is helpful if
you need to print the same drawing at various sizes or if you need to
fit a drawing within the printable area of the paper. You can also

specify the number of sheets of paper across and down on which to
print a drawing. When you specify the number of sheets, Visio re-
duces or enlarges the drawing to fit that number.

To reduce or enlarge a drawing:

1. From the File menu or the Print dialog box, choose Print Setup.

The Print Setup dialog box appears.

2. In the Reduce/Enlarge section, type a percent in the Scale
percent box.

To reduce a drawing, type a number less than 100. To enlarge a

drawing, type a number greater than 100.

3. Choose OK.

To specify the number of sheets for a tiled drawing:

1. From the File menu or the Print dialog box, choose Print Setup.

The Print Setup dialog box appears.

2. In the Reduce/Enlarge section, choose Fit On, and then type the
number of sheets across and the number of sheets down in the
Fit On boxes.

3. Choose OK.
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The number of sheets down and across must represent an area with

proportions similar to those of the drawing page. If the drawing is
square, for example, and you specify two sheets down and four sheets
across, Visio will reduce or enlarge the drawing to fit within a square

area that is no more than two sheets either way. Visio will not print
on the nonessential sheets.

Setting margins

By setting margins you can:

• Create a non-printable area of any width around a drawing that
prints on one sheet of paper.

• Create a non-printable area around a tiled drawing and increase
the area where the tiles of the drawing overlap.

• Move a small drawing to various locations on the page.

Visio never clips a drawing at the margins. Therefore, when you

print on a sheet of paper that is the same size as the drawing page, the
margins have no effect unless you also use the Fit On option in the
Print Setup dialog box to specify that you want to print the drawing

on one sheet down by one sheet across. When you specify to print on
a single sheet, Visio reduces the drawing (if necessary) to fit within
the margins.

Small margins Larger margins

Margin area

Printed area

Margin area

Printed area
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To set margins:

1. From the File menu or the Print dialog box, choose Print Setup.

The Print Setup dialog box appears.

2. In the Margins section, type a number in the Left, Right, Top,
and Bottom boxes to specify the size of each margin.

3. If you are printing a drawing page that is the same size as the
paper, in the Reduce/Enlarge section, type 1 in each of the Fit
On boxes.

4. Choose OK.

Printing colored drawings on monochrome printers

When you print on a monochrome printer, Visio translates the colors

on your screen into gray tones on the printed page. White prints as
no color and black prints as black. Other colors print as grays.

For the best gray tones in a printed drawing, use the grays in the Vi-
sio default color palette. If you use patterned fills, try using a solid
color for the fill background and a shade of gray for the foreground.

These patterns print better than some other patterns.

If a shape does not appear in the printed drawing, and you did not

check Non-Printing Shape for the shape in the Behavior dialog box,
it probably means that Visio translated the color of the shape’s line
and fill as white. To correct this problem:

• Change the color of the shape’s line or fill to a darker color. Visio
interprets the color as a darker gray, so the shape prints.

• In the Print dialog box, choose Color As Black. Visio prints the
lines and fills of all shapes as black, so all the shapes are visible in
the printed drawing. This is helpful if you can’t determine which

shapes are missing from the printed drawing.
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Some printer drivers provide gray-scale print options in the Options

dialog box that you can open from the Print Setup dialog box. Ex-
periment with the gray-scale options to find the one that works best.

To specify a gray-scale option:

1. From the Print Setup dialog box, choose Options.

The Options dialog box appears.

2. Change settings that affect the gray scale.

3. When you are finished with the dialog box, choose OK.

4. In the Print Setup dialog box, choose OK.

Choosing a printer

If you have difficulty printing, choose Print Setup from the File
menu and make sure a printer is available and selected. For details
about printers and printing in Windows, see your Microsoft Win-

dows documentation.

To choose a printer:

1. From the File menu or the Print dialog box, choose Print Setup.

The Print Setup dialog box appears.

2. In the Printer section, choose the default printer, or choose a
printer from the Specific Printer list.

3. Choose OK.
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Printing to a file

There may be times when you need to print to a file. For example,

you can print a drawing file to another file, and then print that file
on a computer that has a setting you want to use for printing.

To print to a file:

1. From the File menu, choose Print.

The Print dialog box appears.

2. In the Options section, choose Print To File.

3. Choose OK.

The Print To File dialog box appears.

4. Type the name of the file that you want to print the drawing
file to.

5. Choose OK.

To send a file to the printer:

1. In Windows Program Manager, double-click the MS-DOS icon
in the Main group.

2. At the DOS prompt, type a command to send the file to the
printer, such as:

copy /b c:\project\pfile lpt1:

where /b copies the entire file, c:\project is the path where the file

is stored, pfile is the file to which you printed your Visio file, and
lpt1: is the port to which your printer is connected.

Tip: If you have problems printing, see Appendix D, “Troubleshoot-
ing,” for some helpful information.
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Creating masters, stencils,
templates, and styles

Visio comes with master shapes, stencils, templates, and styles de-

signed to help you create drawings quickly, but you can also develop
your own to make your work faster and easier or to set up drawing
standards for your department or company. You can:

• Draw your own master shapes, or modify the master shapes that
come with Visio.

• Create your own stencils so they include the master shapes you
use most frequently.

• Design your own templates to create drawings with the shapes,
size, scale, and styles you use most.

• Modify existing styles or create your own styles.

This chapter explains how to create and edit master shapes, master
shape icons, stencils, templates, and styles. It also explains how to

protect files from unauthorized or accidental changes.
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Creating master shapes

Creating custom master shapes is a powerful way to increase your ef-
ficiency with Visio. This section explains how to make new master

shapes and how to specify master shape characteristics.

There are two ways to create master shapes:

• Add a shape from a drawing to a stencil, and then specify its
master shape characteristics (name, master shape prompt, and

so forth).

• Add a blank master shape icon to a stencil and specify the master
shape characteristics, and then draw the associated master shape

in the master shape drawing window.

The following sections describe both techniques.

To create and edit master shapes and their icons, you use the com-
mands on the Master menu. The Master menu commands are

available only when the stencil window is active and when the stencil
is opened as a copy or an original file (not as read-only). To activate

the stencil window, click the title bar on the stencil window.

Note that you can also use objects from other applications as masters

by using the same techniques described in this section. However, you
may not be able to edit an object from another application in all the
ways you edit a shape. For details about objects from other applica-

tions, see Chapter 7, “Using Visio with other applications.”

Creating a master shape from an existing shape

It’s easy to use a master shape in a drawing: you just drag the shape
from the stencil into the drawing. It’s just as easy to turn any shape in

a drawing into a master shape stored in a stencil.
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To create a master shape from a shape in a drawing:

1. In the drawing window, display the page that contains the shape
you want to use as a master shape.

Alternatively, display a drawing page and draw the shape you
want to use as a master shape.

2. Open the stencil in which you want to store the new master

shape.

By default, stencil files open as read-only. Make sure the Original

option is checked in the Open Stencil dialog box when you open
the stencil or you won’t be able to add a new master shape.

3. Make sure the drawing window is active.

4. With the pointer tool, point to the shape that you want to use
as a master.

5. Drag the shape from the drawing into the stencil window.

Alternatively, you can move a copy of the shape to the stencil

window by holding down the Ctrl key while you drag the shape.

An icon based on the shape and a default name for the new

master shape appear in the stencil window.

No brackets indicates you
can add a master shape

to this stencil.

Process

Process

Decision

Yes

Yes

Yes

Milestone

Drag the shape from the
drawing window to the

stencil window.
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6. To realign icons after adding a master shape, choose Arrange

Icons from the Window menu.

For details, see “Arranging icons” later in this chapter.

To finish creating the master shape, you need to specify its master
shape characteristics. You name the master shape, position its name
and adjust its icon, and write a prompt that appears when you point

to the master shape’s icon.

To specify master shape characteristics:

1. Make sure the stencil window is active.

2. Click the new master shape icon to select it.

3. From the Master menu, choose Properties.

The Properties dialog box appears and displays a default name
for the master shape.

4. In the Master Name section, type a name for the master.

5. Choose an alignment option to align the name to the left, right,
or center of the icon.

Default name

The text you type here appears
when you point to the shape.
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6. In the Icon Size section, leave the icon at its default size (Nor-

mal) or, if you want a larger icon, choose Tall, Wide, or Double.

7. In the Icon Update section, choose Automatic if you want the
icon to automatically reflect changes you make to the master

shape it represents. Choose Manual if you want to update the
icon manually by choosing the Update Icon command from the
Master menu.

If you plan to create a custom icon for the master shape, choose
Manual. That way you won’t accidentally replace the custom

icon when you edit the master shape. For details about creating
custom icons, see “Arranging, updating, and creating master
shape icons” later in this chapter.

8. In the Prompt section, type information that will appear when
you point to the master shape icon. The prompt should provide
helpful information (such as suggesting uses for the shape,

providing dimensions, and so on).

9. Choose OK.

When you’re finished, you have a fully defined master shape, ready to
be dragged and dropped onto a drawing page.

Another method: Creating master shapes from scratch

You can also create master shapes from scratch using the New Master
command on the Master menu.

You create and edit master shapes using the same tools and com-
mands that you use to create and edit shapes in a drawing. However,
you work on master shapes in the master shape drawing window, not

the main drawing window. The master shape drawing window looks
like the main drawing window, except that:

• The window background is green.

• The drawing page is usually only slightly larger than the shape.
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To create a master shape from scratch:

1. Click the stencil window title bar to make the stencil window
active.

2. From the Master menu, choose New Master.

The New Master dialog box appears.

3. Complete the dialog box the same way you complete the Proper-
ties dialog box, and then choose OK. For details about the
Properties dialog box, see “Creating a master shape from an

existing shape” earlier in this chapter.

A blank master shape icon appears in the stencil window.

4. To create the master shape itself, double-click the master shape
icon to open the master shape drawing window.

Alternatively, choose Edit Master from the Master menu.

5. Draw the master shape.

6. Close the master shape drawing window.

Visio displays an icon based on the shape you drew.

Now you can drag the shape from the stencil into a drawing.
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Arranging, updating, and creating master shape icons

The first things you see when you open a stencil are the master shape
icons. Icon design can convey important information about a shape’s

behavior or use. Visio provides a variety of options for both custom-
izing the look of master shape icons and arranging them in a stencil.

You can let Visio arrange icons or you can arrange them yourself.
Similarly, you can have Visio update an icon automatically when you
edit a master shape, or you can choose when to update the icon. You

can also create a custom icon that looks different from the master
shape it represents.

This section explains how to work with master shape icons. To work
with master shape icons, the original or a copy of the stencil must be
opened and the stencil window must be active. (Click the title bar to

activate the stencil window.)

Arranging icons

You might want to change the order of icons in a stencil so that the
icons you use most are most accessible. Also, you might want to

straighten out icon rows after you add, delete, or reorder icons.

To automatically arrange the icons each time you modify the stencil

window contents, choose Auto Arrange on the View menu. Other-
wise, choose Arrange Icons from the Window menu to realign the
icons after each change.

To change the order of icons in the stencil window:

1. Drag each icon to approximately where you want it.

When Auto Arrange is checked, the other icons move to accom-

modate it. If Auto Arrange is not checked, choose Arrange Icons
from the Window menu.

For details about setting other aspects of the stencil window display,
see Chapter 1, “Getting started with Visio.”
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Updating an icon to reflect changes in the master shape

When you create or update a master shape, you can create your own

master shape icon or you can let Visio create an icon based on the
master shape. The latter option usually produces the best results with
simple master shapes. Whenever you edit the master shape, you can

have Visio update the icon to reflect changes.

One way to ensure the icon is updated when you update the master is

to set the update option in the Properties dialog box.

Tip: You can also specify whether the icon will be updated when you
create a new master by checking the update option in the New Mas-

ter dialog box.

To automatically update an icon to reflect master shape changes:

1. Select the icon you want to update.

2. From the Master menu, choose Properties.

The Properties dialog box appears.

3. In the Icon Update section, choose Automatic.

4. Choose OK.

Even if you leave the setting on Manual, you can also choose to up-
date an icon at specific times.

To update a master shape icon at a specific time:

1. Select the icon you want to update.

2. From the Master menu, choose Update Icon.

Visio updates the icon with a miniature version of the master

shape.
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Creating a custom icon

A master shape’s icon should reflect the master shape’s purpose. For

example, you might use a color to represent the purpose (as some Vi-
sio master shape icons use a yellow background to represent
connectors). You could also use a completely different image for the

icon. Sometimes an icon that looks different from its master can best
represent the master.

Window master shape icon Window master shape

You create a custom icon in the edit icon window. Before you create

the icon, make sure you choose the following options in the Proper-
ties or New Master dialog box:

• The icon size you want, because the size you choose determines
the area for creating the icon in the edit icon window.

• Manual as the icon update option, so you don’t accidentally
replace the custom icon when you edit the master shape.

As you edit an icon, Visio updates the icon in the stencil window so
you can see how it looks. You cannot cancel changes to the icon after
you close the edit icon window, so before you close the window,

make sure the icon looks the way you want. However, as long as the
edit icon window is open, you can use the Undo command to undo
changes to the icon.

To work in the edit icon window:

1. Make sure the stencil window is active.

2. Select the master shape icon that you want to edit.
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3. From the Master menu, choose Edit Icon.

The edit icon window appears. If an icon exists for the master,
the icon appears in the window. Also, the icon editing tools
appear on the toolbar.

4. If necessary, move the edit icon window so that you can see
changes to the icon in the stencil as you edit the icon.

5. Edit the icon or create a new icon.

6. When you are finished, close the edit icon window.

Visio updates the icon.

To create or edit an icon, you change the colors of the individual
blocks of display information (known as pixels) that make up the

icon. When you use the icon pencil tool or the paint bucket tool to
change colors, you can “load” the left mouse button with one color
and the right mouse button with another color, and then use the

same mouse button to apply the color. For example, you can load the
left mouse button with blue and the right mouse button with red.
When you click a pixel with the left mouse button, the pixel turns

blue; when you click a pixel with the right mouse button, it turns red.

To change the color of one pixel at a time:

1. Choose the icon pencil tool.

2. Point to a color in the color palette.

Left and Right Color boxes
Color palette

Editing tools

Stencil background color

Icon pencil tool
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Paint bucket tool

Lasso tool

Selection net tool

3. Click the color with the left or right mouse button.

The color appears in the Left or Right Color box on the toolbar.

If you want to create icons that appear to have holes cut in them,
use the stencil background color.

4. Point to the pixel you want to change.

5. Click the pixel with the mouse button that is assigned the color

you want.

To change an area of color:

1. Choose the paint bucket tool.

2. Click a color, then, pressing the same mouse button, click a pixel
within the area you want to change.

Visio colors the pixel you clicked and all pixels of the same color

within the area.

You can select part of an icon, then delete or move it.

To delete part of an icon:

1. With the lasso tool or selection net tool, select the area you want
to delete.

2. From the Edit menu, choose Cut.

The deleted area is replaced with the stencil background color.

To move part of an icon:

1. With the lasso tool or selection net tool, select the area you want
to move.

2. Drag the selection to where you want it.

You can also copy and paste selected parts of an icon. For details
about working in the edit icon window, see the the Visio online help.
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Revising stencils

There are two types of stencils:

• A stand-alone stencil is a stencil file with the extension .VSS,
which can be opened separately or with associated templates.

• A drawing file stencil is a stencil stored within a drawing file. It

contains copies of all the master shapes used in the drawing file.

Changing a master shape in a stand-alone stencil does not affect instances of that
shape in a drawing; changing a master shape in a drawing file stencil does.

For example, if you create a new drawing based on the Practice tem-

plate, the stand-alone stencil that the template opens is PRACTICE.VSS.
If you use the Arrow, Process, and Decision master shapes in your
drawing, the drawing file stencil stored with your drawing contains

those shapes.

Stand-alone stencil Display the
drawing file
stencil with the
Show Master
Shapes command.

Process Process Decision

Process

Decision Process

Process

Yes Yes

NO

No

No
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The effect of revising a stand-alone stencil is different from that of

revising a drawing file stencil. The type of stencil you choose to re-
vise depends on how far-reaching you want the changes to be:

• When you add or edit master shapes in a stand-alone stencil file,
you change a stencil that may be associated with one or more
templates. The new or revised master shapes become available

in any new drawing you create that is based on that stencil or
template file. Existing instances of the master shapes in a
drawing are not affected.

• When you add or edit master shapes in a drawing file stencil,
the changes affect only that drawing file. The new or revised
master shapes are available only in that drawing. However, these

master shapes are linked to their instances in your drawing.
When you modify the master shapes in a drawing file stencil,
the changes are reflected in each instance of the shape contained

in the drawing.

The following sections describe how to edit master shapes in each

kind of stencil file. For details on adding new master shapes, see
“Creating master shapes” earlier in this chapter.

Editing master shapes in a stand-alone stencil file

By default, stand-alone stencils open as read-only to prevent
changes. To add, delete, or modify master shapes in a stand-alone
stencil, you need to open the original files or copies of those files. To

determine whether a stencil that’s already open can be modified,
look at the stencil name in the title bar. If the name appears between
brackets, the stencil was opened as read-only. If there are no brack-

ets, you can modify the stencil.
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To revise a stand-alone stencil:

1. From the File menu, choose Open Stencil.

Alternatively, click the Open Stencil button on the toolbar.

The Open Stencil dialog box appears.

2. Choose the name of the stencil containing the shape you want
to edit.

3. In the Open section, choose Original to open the original
version of the stencil file.

Visio opens the stencil in the stencil window.

4. In the stencil window, double-click the icon for the master shape
you want to edit.

If nothing happens when you double-click the icon, make sure
the stencil window is active by clicking the stencil window

title bar.

5. In the master shape drawing window, edit the master shape.

6. To close the master shape drawing window, double-click the
Control-menu box.

Standard and Microsoft
Office toolbar

Lotus SmartSuite toolbar

Visio lists the names of the stencils
found in each directory listed in the
VISIO.INI setting for “Template Path”
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Visio asks if you want to update the master. Choose Yes to make

the changes, or No to ignore them. If you choose Yes, the master
shape is revised and your changes will appear in the next
instance you create. Existing instances are not changed.

Editing master shapes in a drawing file stencil

The quickest way to update every instance of a master shape in a
drawing file is to edit the master shape stored in the drawing file
stencil. When you edit the master shape, you change every instance

of the shape in that drawing file. You do not, however, change the
master shape in any stand-alone stencil you may have used to create
the drawing.

To revise a drawing file stencil:

1. Make sure the drawing window is active by clicking the title bar.

2. To display the drawing file stencil, choose Show Master Shapes

from the Window menu.

3. In the drawing file stencil, double-click the icon for the master
shape you want to edit.

4. In the master shape drawing window, edit the master shape.

5. To close the master shape drawing window, double-click the

Control-menu box.

Visio asks if you want to update the master and all its instances.

Choose Yes to make the changes, or No to ignore them.

Deleting a master shape from a stencil

When you no longer need a master shape, you can delete it. Deleting
a master from a drawing file stencil breaks the link between the mas-

ter and any instances in the drawing.
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To delete a master shape:

1. Make sure the stencil window is active.

2. Select the master shape icon.

3. From the Edit menu, choose Clear.

Alternatively, choose Cut, or press the Delete key.

When you try to delete a master shape from a drawing file
stencil, Visio warns you that deleting the master shape severs the
connection between the master and its instances. Choose OK to

delete the master or Cancel to cancel deletion.

4. If Auto Arrange is not checked in the View menu, choose

Arrange Icons from the Window menu to realign the icons.

What if you can’t edit or delete a master shape?

If you double-click a master shape in a stand-alone stencil to open
the master shape drawing window (or if you try to delete a master

shape) and nothing happens, it probably means that:

• The stencil window is not active. Click the title bar to activate

the window.

• You opened a read-only copy of the stencil (which is the default).

You can tell the file is read-only because its name in the title bar
is in brackets. You must open the original stencil or a copy of it
to change the master shapes.

• The document’s master shapes are protected. You can tell when a
master shape is protected because instances of the master shape
display locks when they are selected. To turn off the protection,

choose Protect Document from the Tools menu and uncheck the
Master Shapes option. For details about protecting and
unprotecting shapes, see “Locking and unlocking shapes” in

Chapter 3, “Creating shapes.”
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Creating stencils and templates

You aren’t limited to the stencils and templates provided with Visio.
You can create your own. You might want to create new stencils ei-

ther to mix and match master shapes from several stencils and store
them in one place, or to store a new set of masters for a particular
type of drawing unique to your business. You create a new stencil by

opening and saving a new stencil file or by saving a drawing file sten-
cil as a stand-alone stencil file.

If you frequently use the same stencil, styles, and page settings in
your drawings, create a new template with these settings. The easiest
way to create a template is to save a drawing file that contains the set-

tings you want as a template.

Tip: The master shapes in stencils you create will seem better related

to each other if you standardize the master shape names, prompts,

styles, grid size, scale, icons, and file summary information.

Once you create files, you can protect them by using the Protect

Document command, or by saving them as read-only.

Creating a new stencil file

You can base a new stencil file on an existing stencil file. When you
do so, the new stencil file contains a copy of all the master shapes in

the original stencil file. You can also create a new, blank stencil and
then add master shapes to it.
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To create a new stencil:

1. From the File menu, choose New.

2. In the New section, choose Stencil.

3. From the Based On list, choose No Stencil to create a blank

stencil, or choose the stencil on which you want to base the
new stencil.

4. Choose OK.

Visio opens the new stencil.

As soon as you create a new stencil, save it.

To save a stencil file:

1. Make sure the stencil window is active.
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2. From the File menu, choose Save As.

The Save As dialog box appears.

3. In the File Type section, make sure Stencil (*.VSS) is chosen.

If you share stencils with someone who uses an earlier version of
Visio, save the stencil in Visio 2.0 format. For details about Visio

file formats, see Chapter 1, “Getting started with Visio.”

4. In the File Name box, type a name for the stencil file.

5. If you want to protect the stencil from accidental changes, check
Read Only in the Save section.

When you save a file as read-only, it opens as a read-only file
unless you check Original or Copy when you open the file. For
details about protecting files, see “Protecting stencils, templates,

and drawing files” later in this chapter.

6. To save the file to a different drive or directory, choose the drive
or directory.

7. Choose OK.

Saving a drawing file stencil as a stand-alone stencil

If a drawing file stencil contains a set of master shapes that you fre-

quently use, save a copy of the drawing file as a stencil file. The
drawing file stencil becomes a new stand-alone stencil file.

Save stencil as read-only



         

To create a stand-alone stencil file from a drawing file stencil:

1. From the File menu, choose Open.

Alternatively, click the Open button.

The Open dialog box appears.

2. From the File Name list, choose the drawing file.

3. In the Open section, choose Copy, and then choose OK.

Visio opens a copy of the file.

4. From the Window menu, choose Show Master Shapes.

Visio displays the drawing file stencil.

5. Make the drawing window active, and then choose Delete Pages
from the Page menu.

6. In the Delete Pages dialog box, click a page, hold down the Shift
key and choose all other pages, and then choose OK.

Visio deletes all the drawings from the copy of the drawing file,

so that the file contains only its drawing file stencil.

7. From the File menu, choose Save As.

8. From the File Type list, choose Stencil (*.VSS).

9. Name the stencil file, and then choose OK.

For details about saving stencil files, see “Creating a new stencil file”
earlier in this chapter.

Moving master shapes between stencils

You can drag a master shape from one stencil to another, the same
way you drag a master into a drawing. For convenience, you might
want a master shape to appear on more than one stencil. If you hold

down the Ctrl key and drag, the master appears in both stencils.

Standard and Microsoft
Office toolbar

Lotus SmartSuite toolbar
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Creating templates

Creating a template is a convenient way to open a stencil and

store styles, a color palette, and page settings so you can use them
any time.

Templates can include:

• Links to one or more stencils, which are not actually stored in

the template, but are opened when you open a new drawing file
with the template.

• One or more drawing pages, including background pages. Each
page can contain a drawing and use a unique size and scale. For
details about creating pages, see Chapter 5, “Creating and

printing drawing pages.”

• Print settings from the Print Setup dialog box. For details, see
Chapter 5, “Creating and printing drawing pages.”

• Styles for lines, text, and fills. For details about creating styles,
see “Creating and editing styles” later in this chapter.

• Snap and glue settings from the Snap & Glue Setup dialog box.
For details, see Chapter 2, “Adding, arranging, and connecting

shapes.”

• A color palette. For details, see “Choosing a color palette” later
in this chapter.

• Window size and position. For details about arranging windows,
see Chapter 1, “Getting started with Visio,” or see your Microsoft

Windows documentation.

You create a template by saving a drawing file that contains the set-

tings you want for the template or by saving a new drawing file as a
template.
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To create a template from a drawing file:

1. Open the drawing file.

2. If you want the template to open one or more stencils, open the

stencil files.

3. Arrange the stencil and drawing windows as you want them to
appear when you open a new drawing file with the template.

4. If the drawing window is not active, click its title bar.

5. From the File menu, choose Save As.

The Save As dialog box appears.

6. In the Save section, make sure Workspace is checked.

7. From the File Type list, choose Template (*.VST).

8. In the File Name box, enter a name for the template.

Because you chose Template in the File Type list, Visio supplies
the .VST filename extension.

9. Choose OK.

When you create templates, keep these things in mind:

• Make sure the shapes you develop work well with the drawing

scale and grid you’re using in your template. Master shapes can
behave in unexpected ways if the master shape and drawing page
scales differ greatly. For example, the shape may appear tiny or

huge, and scaled shapes containing fixed measurements can
come apart when you use them in unscaled drawings. The scale
of a drawing page is set by the template. The scale of a master

shape is set by the scale at which the master shape is drawn. To
avoid unexpected behavior, the master shapes and drawing pages
should either use the same scale or one scale should be no more

than eight times greater than the other.

• If you don’t want to include drawings in the template, open a
copy of the drawing file. Delete the drawings and the master

shapes on the drawing file stencil. Save the copy of the drawing
file as the template.
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• You can create a template from a new drawing file. Just open the

new file, set the options and open the stencils you want, and
then save the new drawing file as a template.

• To edit a template, choose Open from the File menu, then either

open the original template file and edit it, or if you want to
prevent modification of the original, open a copy of the template
and edit it.

Protecting stencils, templates, and drawing files
Once master shapes, stencils, templates, and drawing files look the

way you want them to, you might want to protect them from acci-
dental or unauthorized changes.

Protecting a file

You can prevent changes to the styles, backgrounds, shapes (includ-

ing objects from other applications), and master shapes in a file.

To protect a file:

1. From the Tools menu, choose Protect Document.

2. In the Protect Document dialog box, type a password.

You can protect a document without a password, but if you use
one, remember it or write it down. After you close the dialog

box, the password is not visible.

3. Choose the items that you want to protect.

Options include styles, backgrounds, shapes (Visio shapes and
objects from other applications), and master shapes.

4. Choose OK.
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When you no longer need to protect a file, you can remove the

protection.

To remove protection:

1. From the Tools menu, choose Unprotect Document.

2. Type the password if you used one.

3. Choose OK.

Saving a file as read-only

If you want to prevent changes to a file, it’s helpful to save the file as

read-only. That way, the original file cannot be accidently edited.
However, you can open and edit a copy of the file. For details about
saving files, see Chapter 1, “Getting started with Visio.”

To save a file as read-only:

1. From the File menu, choose Save As.

The Save As dialog box appears.

2. In the Save section, choose Read Only.

3. Complete the rest of the dialog box.

4. Choose OK.

Creating and editing styles

If there are several attributes you want to apply to multiple shapes in
your drawing, you could apply each attribute separately to each

shape. However, the simplest way to format several shapes using the
same set of attributes is to use a formatting shortcut called a style.
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A style is a named set of attributes that is saved with a template or a

drawing. When you apply a style to a shape, you apply several at-
tributes at once. Styles make it easy to create a uniform look for any
number of shapes. And if you want to change that look, all you need

to do is edit the style. The new attribute will be applied to all the
shapes that use that style.

You can create new styles and save them in templates and drawing
files. You can also edit existing styles. A style’s name appears in the
Line, Fill, or Text style list and in the Style dialog box.

For details about styles and how to apply them, see “Formatting
shapes” in Chapter 3, “Creating shapes.”

Creating a new style

You create new styles by using the Define Styles dialog box. You can
create a new style from scratch or base a new style on an existing one.

To create a style:

1. Make sure the drawing window is active.

2. From the Format menu, choose Define Styles.

v In Visio’s SmartSuite menu set, choose Define Styles from the

Style menu.

The Define Styles dialog box appears.

Check to maintain attributes
previously applied to a shape.
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3. In the Style box, type a name for the new style.

Note that if you use the same style names in both the drawing
file and the stencils associated with a template, you must make
sure that the styles’ definitions are the same. If you don’t, shapes

may behave in unexpected ways when dragged from a stencil to a
drawing. For details, see Chapter 3, “Creating shapes.”

4. From the Based On list, do one of the following:

• If you’re creating a style based on another style, choose the
style name from the list.

• If you’re creating a style from scratch, choose No Style from
the list.

5. If you want the style to include text, line, or fill attributes and to
be displayed in the associated style list, check the appropriate
item in the Includes section. To exclude the attributes, make sure

the item is not checked.

If you are creating a style based on another style, the new style

inherits the base style’s attributes (instead of default attributes)
and the new style name appears on the related style list.

If you are creating a style from scratch and you check the Text,
Line, or Fill item in the Includes section, the new style automati-
cally uses default attributes for text, line, and fills. In addition,

the new style name appears on the related style list by default.

6. To specify or change text, line, and fill attributes for the new
style, choose the appropriate button in the Change section,

complete the dialog box, and then choose OK.

When you open each dialog box, the attributes of the style on

which the new style is based appear. Make the changes necessary
to define the new style. After you close the dialog box, a green
line appears under the corresponding button in the Change

section to indicate you made changes.
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For details about the formatting dialog boxes, see Chapter 3,

“Creating shapes,” and the Line, Fill, Font, Paragraph, Tabs, and
Text Block entries in the Visio online help.

7. If a shape was selected when you chose Define Styles, and you

want the local formatting for a shape to remain intact when you
use the Apply button, check the Preserve Local Formatting On
Apply option.

For example, if you check this option, text which you have
formatted as bold without using a style will remain bold even

when you apply a style that specifies normal text.

Keep in mind that if you checked the Text, Line, or Fill item in
the Includes section of the Define Styles dialog box, the style has

attributes associated with that item even if you don’t make
changes to them. If you don’t check Preserve Local Formatting
On Apply, the default attributes will replace local formatting.

8. When the style contains the attributes you want, choose OK.

If any shapes are selected, choose Apply to apply the style and

close the dialog box.

You can also choose Add or Change to save the new style and

leave the Define Styles dialog box open for further work.

Editing, deleting, and renaming styles

Editing styles is a quick way to change the look of multiple shapes in
a drawing. When you edit a style, the change is reflected in each

shape which uses that style in the drawing.
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To edit a style:

1. From the Format menu, choose Define Styles.

v In Visio’s SmartSuite menu set, choose Define Styles from the

Style menu.

2. From the Style list in the Define Styles dialog box, choose the
name of the style you want to edit.

3. Edit the style.

4. Choose Change.

5. Choose OK.

The changes you make are reflected in any shape with that style

applied to it.

To delete a style:

1. From the Style list in the Define Styles dialog box, choose the
name of the style you want to delete.

2. Choose Delete.

3. Choose OK.

All shapes that use the deleted style are changed to the style in
the Based On box.

To rename a style:

1. From the Style list in the Define Styles dialog box, choose the
name of the style you want to rename.

2. Choose Rename.

The Rename dialog box appears.

3. Type a new name for the style.
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4. Choose OK.

5. In the Define Styles dialog box, choose OK.

The new name appears in the style list.

Choosing a color palette

The templates provided with Visio use the default color palette. You

can specify a different color palette for a template or a drawing file by
choosing one of the color palettes provided with Visio, or by copying
a color palette from an existing file into your file.

To choose a color palette:

1. From the Tools menu, choose Color Palette.

The Color Palette dialog box appears.

2. In the Copy Colors From list, either choose a color palette or
filename from the list.

Choosing a filename from the list copies the color palette. Only
the names of open files appear in the list.

3. Choose OK.

For details about the color dialog boxes, including the options for
creating your own colors, see the Color Palette entry in the Visio

online help.
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Using Visio with other
applications

Visio is probably only one of many tools you use in your work. You

may want to combine Visio shapes and drawings with reports, charts
and graphs, spreadsheets, and other kinds of information. This chap-
ter explains how to integrate Visio drawings with documents created

in other applications, and how to import and export information in
other file formats.
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About linking, embedding, importing, and exporting

Linking, embedding, importing, and exporting—as well as copying
and pasting—are methods of integrating a Visio shape or drawing

with another document. You can use these features to put a shape or
drawing created in Visio into another application, or bring objects
from another application into a Visio drawing. Visio offers a wide

choice of methods for accomplishing these tasks:

• You can copy or paste information to or from another applica-

tion by copying the information to the Clipboard and then
pasting it from the Clipboard into another application.

• If the other application supports object linking and embedding

(OLE), you can link or embed information for easy updating
and editing. For example, if you’re working in Microsoft Word,
you can run Visio and embed a flowchart in a Word document.

You can then edit the flowchart from within Word.

If you want to use a Visio drawing in several different docu-

ments, you can link the drawing. The drawing is updated in each
document whenever you edit the drawing. For example, if you
use an organization chart in multiple documents and then

change the chart, the changes will be reflected in each document
the chart is linked to.

• If the application you want to exchange information with
doesn’t support copying and pasting or embedding and linking,
you can also export and import files and convert objects in Visio

to another file format.

The following table summarizes the different methods for integrat-

ing a Visio shape or drawing with another document. Which method
you use depends on the capabilities of the other application and how
you want to use the material at its destination.
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To Do this Limitations

Transfer text or graphic Copy and paste You might not be able
information to or from an to update the pasted

application that supports the information.
Windows Clipboard

Update multiple instances Link information You need to update a link

of an object automatically if a file is renamed, moved,
or copied to another directory.

Link to an external file so you Link information Both applications must sup-
can use it with other port OLE.
applications or drawings

Create an object that you Embed information The document is larger be-
want in only one document cause it contains a copy of

the embedded information.

Paste an object without Embed information Both applications must sup-
maintaining an external port OLE.

file on disk

Quickly move, copy, or paste Drag and drop the Both applications must sup-

an object from one application object port OLE 2 and the drag and
to another to embed or link drop method.
the object

Create an OLE object in Create an object Both applications must sup-
an application you start from within another port OLE.
within Visio or create a Visio application

shape or drawing from
within another application

Send a file to another computer Mail a file Requires MAPI and CMC
mail systems like Microsoft
Mail.

Bring a file in another format Import a file You must have the appropri-
into a Visio drawing ate import filters installed.

Convert a Visio drawing into Export a file You must have the appropri-
another file format ate export filters installed.
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Linking versus embedding

OLE is a powerful method for sharing information between Visio
and other Windows applications. Both linking and embedding create

an active link between the application that creates the OLE object
and the OLE container, the application into which you paste it.
When you embed or link objects, your document contains or refers

to data created in different applications, and you can edit the data
from within your document. For example, you can create an organi-
zation chart in Visio. By linking or embedding the organization chart

into another application, you can update it from within the applica-
tion. Visio supports OLE 2, which lets you edit an object in place and
drag and drop objects from one application to another. For details,

see “Editing an embedded Visio object in place” and “Dragging and
dropping a Visio object into other applications” later in this chapter.

When you link an OLE object, you link only a reference to the data,
not the data itself. When you embed an object, you embed a copy of
the data in the container application. For example, if you link the or-

ganization chart to another application, the data remains in the Visio
file; if you embed the organization chart, a copy of the data is stored
in the container’s file. Because linking and embedding differ in where

the actual data of the object is stored, whether you choose to link or
embed an object depends on how you intend to work with it.
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Microsoft Excel chart
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Visio shape
embedded in
Microsoft Publisher
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When to link information

Linked information can be updated every time you open the docu-

ment that contains the reference to the source data (the link), so any
changes made to the original file appear automatically in documents
that are linked to it. If you need to use the same information in more

than one document and it’s important that the most current version
be used, link the information rather than embed it.

Links take a little more care to maintain than embedded informa-
tion, because the original file must be available so Visio can update
the linked information. If the original file is renamed or moved to a

different directory, the link to the document may need to be up-
dated. This also means that if you copy the Visio document to
another system, you must also copy the original file, and the link may

have to be updated the first time the document is opened on that sys-
tem. For details, see “Managing links between Visio drawings and
other documents” later in this chapter.

When to embed information

Documents that contain embedded information can be easier to
work with because there are no links to maintain and the document

does not need access to other files. Therefore you can copy the docu-
ment to another system without having to copy additional files.
Because the information is not linked, changes to the original file are

not reflected in the document. Embedding information makes the
document larger because the document contains a copy of the infor-
mation itself rather than a link to another file. In addition, you can

edit embedded objects without leaving the container application. For
details, see “Editing an embedded Visio object in place” later in this
chapter.
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What Visio needs to link or embed information

Visio can link or embed information from any Windows OLE-object

application. Information from Visio can be linked to or embedded in
any Windows application that supports OLE as a container. An OLE
container is an application that can link or embed objects from other

applications. For details about a particular application’s capabilities
for object linking and embedding, see its documentation.

Tip: If you want to take advantage of OLE, make sure your system

has enough RAM for both the OLE-object application and the con-
tainer application to run simultaneously.

Linking or embedding Visio drawings into other applications
The drawings you create in Visio may be only part of the message
you’re trying to communicate. You may want to create diagrams and

flowcharts to illustrate a technical report, or simply to include a floor
plan in a memo. You can embed or link selected shapes, a drawing, or
an entire file. Then, from within the other application, you can

double-click the Visio object to edit it. You can also create Visio
shapes or drawings from within other applications (most often by
using the application’s Insert Object command.) For related infor-

mation, see “Creating a new shape or drawing in Visio from within
another application” later in this chapter. For details, see the docu-
mentation for that application.

Embedding Visio shapes in another document

You can embed shapes from a Visio drawing in another document by
copying the shapes to the Clipboard and then pasting them into the
container application. You can also embed Visio shapes by dragging

and dropping them into another OLE 2 container application. For
details, see “Dragging and dropping a Visio object into another ap-
plication” later in this chapter.
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To embed selected shapes in another document:

1. In your drawing, select the shapes that you want to embed in the
other document.

2. From the Edit menu, choose Copy.

Even if you are finished using Visio, don’t close it. To embed
shapes, the other application needs certain information which is

obtained more quickly if Visio is still running.

3. In the other application, display the document in which you

want to embed the shapes.

4. Choose the command used by that application to embed objects
in its documents.

This command is usually Paste on the Edit menu, but may be
Paste Special, Paste Object, or a command unique to the applica-

tion. For details, see the OLE documentation for that
application.
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Embedding or linking a drawing

If you want to use an entire Visio drawing in another document, you
can embed the drawing in much the same way as you embed selected
shapes, or you can link the Visio file that contains the drawing to the

document. When you embed or link an entire drawing, the whole
drawing page is not displayed. Instead, you see an area just large
enough to hold all the shapes on the page. If you want to view more

of the drawing, you can define a larger area to embed or link.

A Visio shape embedded in
another application
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To embed or link a drawing in another document:

1. Make sure nothing in the drawing is selected.

If any shapes are selected, Visio will embed or link only those

shapes instead of the whole drawing.

2. If you want to create a link to the drawing rather than just
embed a copy of it, save the drawing file.

Because a link consists of a reference to the original file, you
must save the file before you can link to it.

3. From the Edit menu, choose Copy Drawing.

Copy Drawing selects all the shapes on the foreground page and

the shapes on any background page.

Even if you are finished using Visio, don’t close it. To embed or
link the drawing, the other application needs certain informa-

tion which is more quickly obtained if Visio is still running.

4. Display the document in which you want to embed or link the

Visio drawing.

5. Choose the command used by that application to embed or

link objects.

For embedding, this command is usually Paste on the Edit
menu. For linking, this command may be Paste Special, Paste

Link, or another command unique to the application. For
details, see the OLE and Clipboard documentation for the
application.

To include a border around the drawing, you can increase the area
Visio copies by creating a rectangle that encloses the area you want.

To embed or link a larger area of the drawing:

1. In Visio, draw a rectangle that encloses the area you want to
embed or link.

2. Make the rectangle transparent by applying the fill style None to
the rectangle, or move it behind the shapes by choosing Send To
Back from the Shape menu.
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3. If you don’t want the drawing to have a border, make the border

transparent by applying the line style None to the rectangle.

4. Follow the steps in the preceding procedure to copy the drawing
and embed or link it into the other document.
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For details about formatting shapes, see “Formatting shapes” in
Chapter 3, “Creating shapes.”

You can also extend the area around embedded Visio shapes or draw-
ings by choosing Page Setup from the Page menu and then choosing
Size/Scale. In the Page Setup Size/Scale dialog box, type the width

and height of the drawing in the Dimensions boxes. If you are edit-
ing an object in place, you can enlarge the drawing area by dragging
a handle on the border.

Tip: You can link only one object at a time. To link multiple objects at

one time, group the objects, and then link the group.

Editing an embedded Visio object in place

You can edit an embedded Visio object without leaving the OLE 2

container application. A special set of Visio menus and toolbars tem-
porarily replaces the existing menus and controls of the active
window while you are editing the Visio object.

The rectangle defines an area that
extends past the shapes in the

drawing’s foreground.
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To edit an embedded Visio object in place:

1. In the container application, double-click the embedded object.

A special set of Visio menus and controls appears.

2. Edit the object.

3. Click anywhere outside the drawing to exit in-place editing.

You cannot edit an object embedded in Visio in place.

Creating a new shape or drawing in Visio from within
another application

If an application supports OLE, you can create shapes or drawings in

Visio from within the other application by using the Insert Object
(or equivalent) command. For example, if you are working in
Microsoft Word, you can open Visio and create a shape without leav-

ing your Word document. New Visio shapes or drawings you create
from within other applications are either linked or embedded. For
related information, see “Creating an object in another application

from within Visio” later in this chapter. For details, see the documen-
tation for that application.

Dragging and dropping a Visio object into other
applications

As an alternative to cutting—or copying—and pasting, you can drag
and drop an object from one application to another. You can use this
method only if both the OLE object and container applications sup-

port OLE 2. By dragging and dropping an object, you do not use the
Clipboard; therefore no information on the Clipboard is affected.



                                       

When you drag and drop an object from one application to another
it will be embedded, linked, or pasted into the container application

depending on what keys you hold down as you move the object and
what formats the application supports.

To move an object from Visio to another application:

1. Hold down the Shift key as you drag an object from Visio to the
container application.

The object will be embedded in the container application and
deleted from Visio. If you do not want to delete the object,
choose Undo from the Visio Edit menu after moving the object.

To copy an object from Visio to another application:

1. Hold down the Ctrl key as you drag an object from Visio to the
container application.

The object will be embedded in the container application but
not deleted from Visio.

Dragging a Visio shape and
dropping it in Microsoft Publisher
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To link an object from Visio to another application:

1. Select the object. While still pressing the mouse key, hold down
the Ctrl and Shift keys and drag an object from Visio to the
container application.

You cannot move an object from a read-only Visio file, or move a
master shape from a stencil to another application. However, you can

copy a master shape from a stencil to another application.

If you are moving, copying, or linking an object, the mouse pointer

changes to indicate the action. The mouse pointer will also change to
indicate if the application does not support drag and drop embed-
ding or linking.

Mouse pointer Action

Move

Copy

Link

Unable to link or embed object

Linking or embedding objects into a Visio drawing

Just as you use Visio drawings to enhance the message in another
document, you may want to enhance your Visio drawings with infor-
mation you create in other applications. You can embed or link

information into a Visio drawing from any Windows application that
supports OLE.

Most linked or embedded objects in Visio look exactly as they do in
the original application. However, what you see in Visio is a repre-
sentation provided by the OLE-object application. Some OLE-objectSound application icon
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applications can’t provide a realistic representation of their objects,

so they provide a representation such as an icon. For example, a
sound application would probably provide an icon to represent its
object.

An OLE object’s representation is usually a Windows Metafile,
which means you can convert most linked or embedded objects to

Visio shapes. Doing so breaks the link, but you can then work with
the component shapes like any others. For details about converting
objects to Visio shapes, see “Converting objects to Visio shapes” later

in this chapter.

Embedding an object into a Visio drawing

If an application supports OLE, Visio can embed an object so you
can modify it in its original application. The embedded object

doesn’t retain an association with its original file, so changes to the
original don’t affect the embedded object in your drawing.

To embed an object from another application into a Visio drawing:

1. Display the document that contains the information you want

in its application window.

2. In the document, select the information you want to embed in

your Visio drawing.

3. Choose the command used by that application to place infor-
mation on the Clipboard.

This will usually be the Copy command on the Edit menu.

4. Display the drawing in which you want to embed the object in

the Visio window.
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5. From the Edit menu, choose Paste.

Visio pastes the information from the Clipboard into the
drawing as an object. The object is placed in the center of the
view. You can select and move the object just like a Visio shape.

Linking an object’s file to a drawing

If you need to use the same OLE object in more than one drawing or
application, and it’s important that the most current version be used,
you can link your drawing to the original file that contains the ob-

ject. A linked OLE object can be updated automatically every time
you open the drawing, or only when you explicitly request it. Any
time a link is updated, changes made to the object in its original file

appear in the document that the file is linked to. You link a drawing
to the file that contains an object by pasting and linking it.

To link a file to a drawing:

1. Save the original file.

Because a link consists of a reference to the original file, you
must save the file before you can link to it.

2. In the original file, select the information you want in your Visio
drawing.

3. Choose the command used by the OLE-object application to
place information on the Clipboard.

This will usually be the Copy command from the Edit menu.

4. Display the Visio drawing you want to link the file to.

5. From the Edit menu in Visio, choose Paste Special.

6. In the Paste Special dialog box, check Paste Link.

Visio pastes the information from the Clipboard into the

drawing as an object; the drawing contains a link to the object’s
original file.
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Paste Link will not be available if you cut the object (instead of copy-

ing it), or if the application does not support linking.

Pasting information in a particular format

Most applications place information on the Clipboard in more than
one format to make the information usable by more applications.

When you paste information from the Clipboard into an application,
it uses only one of the available formats by default. However, you
may want to use a different format. For example, you may want to

paste something as a bitmap or a Windows Metafile, rather than em-
bed it in your drawing. You can paste information from the
Clipboard in a particular format by using the Paste Special command

instead of Paste.

To paste information from the Clipboard in a particular format:

1. Copy the information you want to the Clipboard.

2. Display the Visio drawing into which you want to paste the
information.

3. From the Edit menu, choose Paste Special.

The Paste Special dialog box appears.

Choose Paste Link to link an object.

Choose Paste to embed an object.
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4. In the dialog box, choose Paste, and then choose the format you

want from the list.

5. Choose OK.

Creating an object in another application from within Visio

Because Visio supports OLE, you can create objects in other applica-

tions from within a Visio drawing. (However, you cannot edit an
object embedded in Visio in place.) For example, if you are working
in Visio, you can open Microsoft Excel and create a spreadsheet with-

out leaving Visio. You can run another application from within Visio
and either create a new object or open an existing file. New objects
you create from within Visio are always embedded. Objects from ex-

isting files are either linked or embedded.

Depending on the OLE-object application, objects or files that are

linked or embedded through the Insert Object command may ap-
pear as icons. You can specify that a file appear as an icon by choosing
Display As Icon in the Insert Object dialog box.

To create a new object in another application:

1. From the Page menu, choose Insert Object.

The Insert Object dialog box appears.
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2. Choose Create New.

3. From the Object Type list, choose the type of object you want to
create, and then choose OK.

Visio runs the application for creating that object.

4. Create the object you want.

5. From the File menu in the application, choose Exit.

To create an object from a file:

1. From the Page menu, choose Insert Object.

The Insert Object dialog box appears.

2. Choose Create From File.

3. Choose Link if you want to link the file to the Visio drawing.

4. Type a path and filename in the text box. Alternatively, click

Browse and choose the name of the file you want.

5. Choose OK.

Editing an embedded or linked object

You can modify an embedded or linked object in its original applica-

tion from within your Visio drawing. When you modify an
embedded file, you are modifying a copy of the original file. When
you modify a linked file, you are changing the original file. The OLE-

object application provides a command on the Visio Edit menu espe-
cially for editing its objects.
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Most applications provide a command that displays a submenu of

actions you can perform on an OLE object. Usually the command on
the submenu for editing an OLE object is Edit. Whatever the com-
mand is, the submenu usually appears below the Links command on

the Edit menu in Visio. For details about the <OLE object> Edit
command, see the Visio online help.

To edit an embedded or linked object:

1. Select the object you want to edit.

2. From the Edit menu in Visio, choose the command to edit the
object.

This command will usually be Edit on the <OLE object>
submenu.

As a shortcut, you can select and edit the object by double-

clicking the object in your drawing.

Windows runs the OLE-object application and displays the

object in the application window. If the object is linked, the
application opens the original file that contains the object.

Note: If you have embedded a Visio 3.0 object and then try to open it

in Visio 2.0, you can see the object but you won't be able to edit it.

Managing links between Visio drawings and other documents

Linked OLE objects can be extremely useful in a drawing because

you can update the drawing with the most current version of the ob-
ject from its original file and edit the object in its original
application. And unlike an embedded object, a link consists of a ref-

erence to the file that contains the object rather than all the data
associated with the object itself, so the drawing file is smaller than it
would be with embedded objects.
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However, because links refer to other files, they can take a little more

work to maintain. A link’s file reference consists of a drive letter and
the full directory path to the file on disk. If a file is renamed, deleted,
or moved to another drive or directory, Visio won’t be able to find

the file to update the linked object and you’ll have to change the link
to refer to the file in its new location, or cancel the link if the file no
longer exists. This can also occur when you give a drawing and its

linked files to another person. Unless the files are copied to the
same—or relative—drive and directory path as on your system, Visio
may not be able to update the linked objects in the drawing.

Tip: OLE 2 supports relative linking so you can move the linked files

to corresponding drives. For example, if the original linked files were
in c:\projects\homeplan.vsd and c:\budget.xls you can move them to

a:\projects\homeplan.vsd and a:\budget.xls.

Opening a drawing that contains linked objects

When you open a drawing that contains a linked object, Visio may
display a message asking you whether to update links in the docu-

ment. This message appears when the drawing contains a link and
the OLE-object application for that linked object is unavailable.

If the OLE-object application is not available—for example, if you
open a drawing on a system that doesn’t have that application in-
stalled—Visio displays a message to that effect. The visible

representation of the object in the drawing is not affected, but you
cannot edit the object.

Viewing and updating links

You can view all of the links for a drawing and set a link to be manu-

ally or automatically updated. If Visio cannot find the file to update a
link, you can change the file reference to the correct file.
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To view the links between a drawing and other files:

1. From the Edit menu, choose Links.

The Links dialog box appears.

To change a link:

1. In the Links dialog box, choose the link you want to change.

2. If you want Visio to update the link automatically, choose

Automatic. If you want to update the link by using the Links
command, choose Manual.

3. If you want to change the link, choose Change Source and select
a new file reference in the Change Source dialog box.

4. When you finish viewing and changing links, choose OK in the

Change Source dialog box, and then choose Close in the Links
dialog box.

You can change a link’s file reference to any other file of the same for-
mat as the original file. For example, you can change the link for a
.BMP file to a different .BMP file to display its image in a drawing, or

change the link to an Excel spreadsheet to display the same range of
cells from a completely different spreadsheet file.

You can update manual or automatic links at any time by using the
Links command.
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To update a link manually:

1. From the Edit menu, choose Links.

2. Choose the link you want to update.

3. Choose Update Now.

Breaking links

You may want to break the link between an object in a drawing and

another file. Perhaps you want to give the drawing to someone with-
out having to provide the linked files with it, or the information in
the linked file has stabilized and you don’t need to update the object

in the drawing any more. You can break a link between an object and
a file by canceling the link.

To break a link between a drawing and another file:

1. From the Edit menu, choose Links.

2. In the Links dialog box, choose the link you want to break.

3. Choose Break Link.

Visio converts the object to a Windows Metafile in the drawing
and discards the reference to its original file.

You can also break a link between an object and its original file by
converting the object to a Visio group. For details, see “Converting
objects to Visio shapes” later in this chapter.

Exchanging information with Lotus Notes

Visio supports a two-way exchange of information between Visio
and Lotus Notes. With Lotus Notes/FX, you can use fields in draw-
ings to manage information such as shape details, shape

measurements, and date of creation. For example, you can create a
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date field in Lotus Notes that automatically updates a Visio timeline.

Or, you can enter information into the Summary Info dialog box for
a drawing file and read it in Lotus Notes.

v In Visio’s SmartSuite menu set, the name of the dialog box is
Doc Info.

For more information about fields, see “Using fields” in Chapter 4,
“Adding text to drawings,” or see your Lotus Notes documentation.

To create a field for exchanging information with Lotus Notes:

1. From the File menu, choose Lotus Notes Fields.

2. In the Field Name And Direction box, type a name for the field.

3. To read information from Lotus Notes, check Read From Notes.
To write information to Lotus Notes, check Write To Notes.

4. Choose the type of data you want to exchange: Text, Time, or
Number.

5. To create a new field that exchanges information between Visio

and Lotus Notes, choose Add.

To update information in an existing field, choose Change.
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Importing and exporting

If the application you want to exchange information with doesn’t
support copying and pasting or embedding and linking, Visio also

supports importing and exporting.

Importing brings a file in another format into a Visio drawing. Visio

creates a placeholder in your drawing to hold the imported informa-
tion. The way Visio imports a file depends on what kind of file it is:

• If the file is in Windows bitmap (.BMP), device-independent
bitmap (.DIB), or metafile (.WMF) format, Visio pastes the
contents of the file into the drawing.

• Otherwise, Visio uses an import filter to convert the contents of
the file from its original format into a metafile.

Exporting a Visio drawing converts it into another file format so that
another application can use it. To export a drawing to any format ex-
cept a Windows Metafile, Visio must have an export filter to convert

the drawing to the desired format.

Tip: If you want the entire contents of a file in your drawing, import-
ing can be faster than copying the contents of the file and pasting it

from the Clipboard.
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Importing files in other formats into Visio drawings

You can import an entire file into a Visio drawing. Visio can import

files in any of these formats:

• Adobe Illustrator (.AI)

• AutoCAD Drawing Interchange Format (.DXF)

• Computer Graphics Metafile (.CGM)

• Encapsulated PostScript File (.EPS)

• Macintosh PICT Format (.PCT)

• Tag Image File Format (.TIF)

• Windows bitmap (.BMP or .DIB)

• Windows Metafile (.WMF)

• ZSoft PC Paintbrush Bitmap (.PCX)

When you import a file, its contents appear in the center of the view.

You can select and move the object just like any other Visio shape.

To import a file into a Visio drawing:

1. From the Page menu, choose Insert Picture.

The Insert Picture dialog box appears. The import filters

installed with Visio determine the types of files you can import.
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2. In the File Type list, choose the format you want.

Visio lists the files in that format. If the file you want is not in
the list, change to the drive and directory that contains the file.

3. From the File Name list, choose the file you want.

4. Choose OK.

Depending on the type of file you are importing, Visio may ask
you to choose options that affect the file’s appearance. For
details, see “Specifying graphic import options” next in this

chapter.

When you finish choosing import options, Visio imports the file into

the drawing.

Specifying graphic import options

For files imported with an import filter, you can control aspects of
the way an imported file is displayed in the drawing. When you im-

port such a file, Visio displays the Graphics Import dialog box.
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The following table summarizes graphic import options.

Option Description

Retain Gradients Retains gradient fills.

Retain Background Retains the background specified in the

original application by creating a rectangle
of that color.

Emulate Line Styles Draws thick or patterned lines as polygons

to more closely represent the way they appear
in the image, rather than using the line style
and width capabilities of the display or

printer driver.

Normal Uses colors exactly as specified in the image

file.

Inverse Inverts all colors. For example, black
becomes white and white becomes black, to

create the effect of a photographic negative.

Inverse Grays Only Inverts only black, white, and grays; all other

colors retain their original color. This is
useful for accentuating shading or patterns.

Gray Scale Converts all colors to shades of gray.

Inverse Gray Scale Converts all colors to shades of gray and then
inverts them to create the effect of a black-

and-white photographic negative.
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Exporting a Visio drawing into another file format

You can export a Visio drawing into any of these file formats:

• Adobe Illustrator (.AI)

• AutoCAD Drawing Interchange Format (.DXF)

• Computer Graphics Metafile (.CGM)

• Encapsulated PostScript File (.EPS)

• Macintosh PICT Format (.PCT)

• Tag Image File Format (.TIF)

• Windows bitmap (.BMP or .DIB)

• Windows Metafile (.WMF)

• ZSoft PC Paintbrush Bitmap (.PCX)

You can export any selected shape or shapes from a Visio drawing
into another document. If no shapes are selected, Visio exports a

rectangular area just large enough to hold all the shapes on the cur-
rent page, but you can define a larger area to export. For details, see
“Embedding or linking a drawing” earlier in this chapter.

To export shapes or a drawing to another file format:

1. Select the shapes you want to export.

If no shapes are selected, Visio exports a rectangular area large
enough to hold all the shapes on the current page.

2. From the Page menu, choose Export Picture.

The Export Picture dialog box appears.
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3. In the File Type list, choose the format you want.

4. In the File Name box, type a filename for the exported file.

5. Choose OK.

Visio exports the drawing to the file in the format you chose.
You can use the file in any application that can read files in
that format.

You can use Visio to convert a file from one format to another by im-
porting the file into Visio and then exporting it to the format you

want. For details about importing files, see “Importing files in other
formats into Visio drawings” earlier in this chapter.

Modifying an object from another application in a Visio drawing
Although you can’t do everything to an object from another applica-
tion that you can to a Visio shape, you can do quite a few things to
make the object look the way you want. You can:

• Size the object.

• Crop or expand the object’s borders without altering its
appearance.



                                       

• Reposition the object within its borders.

• Apply styles or formats for the object’s line and fill.

• Edit a linked or embedded object using the application in which

the object was created.

• Convert most objects to another file format.

• Convert most objects to Visio shapes.

Scaling, cropping, and panning an object from another
application

After you paste an OLE object into a Visio drawing, you’ll probably
want to adjust its appearance. You may want to make the object

larger or smaller, or you may want to see only part of it. When you
paste an object into a Visio drawing, the object initially is the same
size as in its original application. To adjust the object, you can:

• Size the object to change its dimensions.

• Crop the object to shrink or expand its borders without sizing it.

• Pan the object to move it within its borders.

To size an object from another application:

1. With the pointer tool, select the object.

2. Drag a selection handle until the object is the size you want.

Drag a corner handle to size the object proportionally. Drag a side

handle to stretch or shrink the object vertically or horizontally.

To preserve the
object’s original
proportions, be
sure to drag a
corner selection
handle.
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To crop an object from another application:

1. From the supplemental tool menu, choose the crop tool.

2. Select the object.

3. Drag a selection handle until the object’s borders are the size you
want.

Visio retains the entire object so you can crop it differently if you want.

Drag a selection handle with the You can expand an object’s borders to create empty
crop tool to shrink an object’s space around the object.
borders without shrinking or
stretching the object.

Although you don’t see the cropped parts of an object, they’re still

present in your drawing and can occupy valuable memory when you
print. For more efficient printing, try to paste objects at the size you
want, rather than cropping large areas of the object.

To pan an object from another application:

1. From the toolbar, choose the crop tool.

2. Point inside the object and press the left mouse button.

3. Drag until the object is positioned the way you want inside its
borders.

Crop tool

You can point inside the
borders of an object with the

crop tool to reposition the
object within its borders.
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Formatting an object from another application

You can format an object from another application in the following

ways:

• You can apply a line style or format to change the appearance of

the object’s border. For example, you might choose a distinctive
outline for embedded or linked objects to indicate that they can
be edited from within a drawing.

• You can apply a fill style or format to change the fill color and
pattern of the object. In order to see the fill color and pattern of

an object, there must be some empty space around the object
within its border.

For details about formatting shapes, see “Formatting shapes” in
Chapter 3, “Creating shapes.”

Converting objects to other formats

You can convert some embedded objects to other file formats if the
application of the embedded object supports the other file format.

You can also specify that an object appears as an icon by selecting
Display As Icon.

As with an object’s representation, the OLE-object application pro-
vides a command on the Visio Edit menu especially for converting its
objects. Most of the time this command is Convert. Some applica-

tions use a different command, or may display a submenu of actions
you can perform on that object. Whatever the command is, it usually
appears below the Links command on the Visio Edit menu.

When you apply a fill color and
pattern to an object, the color

and pattern appear in the space
between the object and its borders.
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To convert an embedded object to another format:

1. Selected the embedded object you want to convert.

2. From the Edit menu, choose the command to convert the object.

This command will usually be Convert on the <OLE object>
submenu.

Converting objects to Visio shapes

You can convert a pasted or imported Windows Metafile into a Visio

group or shape. If a linked or embedded object is represented by a
metafile, you can also convert the object to a Visio group or shape,
although doing so breaks the object’s link to its original file and its

ability to be edited in its original application. You can convert a
metafile to a Visio group or shape in two ways:

• To preserve the relationship of the shapes to each other, use the
Convert To Group command from the Shape menu to change
the metafile into a Visio group.

• To separate the metafile into individual shapes, use the Ungroup
command. You don’t need to convert the metafile to a group first

before ungrouping it.

A metafile may contain a bitmap as a component, or a metafile may

consist solely of a bitmap. Bitmaps cannot be converted to Visio
shapes. However, a metafile that consists of a single bitmap usually
stores the bitmap in segments. When you convert such a metafile to

Visio shapes, each segment of the metafile becomes an individual
bitmap object, and you will probably want to convert the metafile to
a group to keep the bitmaps together.

To modify shapes within a group, use the Open Group command on
the Edit menu or double-click the group. For details about editing

groups, see “Grouping shapes” in Chapter 3, “Creating shapes.”
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A metafile stores graphic information in a more compact form than
Visio does, so converting a metafile to Visio shapes increases the size
of the drawing file. Keep this in mind when considering whether to

convert a metafile to Visio shapes. If you don’t need to work with the
shapes individually, you may want to leave the metafile unconverted.

Sending a Visio drawing through electronic mail

You can quickly send a Visio drawing through electronic mail that
supports Messaging Application Program Interface (MAPI) or the

Common Messaging Call (CMC) protocol.

To send a drawing file by mail:

1. While the drawing file is open, from the File menu, choose Send.

If your mail application was not previously running, it starts and
asks for your password. After you type your password, a mail
message containing the Visio icon and the filename appears.

2. Address, type a message, and send the mail message as you
would any other message.

To view a Visio file sent by mail:

1. Open the mail message, then double-click the Visio icon.
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Using ShapeSheets
to create SmartShapes

You’ve probably noticed that some of the master shapes in the Visio

stencils behave differently from the shapes you draw. The behavior of
these master shapes is determined by the formulas in the cells of their
ShapeSheets. These formulas make the shapes smart.

This chapter gives you an overview of the Visio ShapeSheet and the
mechanics of making shapes smart. The book Developing Visio

Shapes (published by Shapeware) is a detailed guide to creating
SmartShapes. For details about the ShapeSheet sections, commands,
and formulas, see the Visio online help.
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How shapes become smart

Most drawing programs are based on two-dimensional geometry.
When you draw an object, the program records the object as a collec-

tion of horizontal and vertical locations. These locations (called vertices
in Visio) are measured from a point of origin on the page and are
connected with line segments, just as if you were drawing the object

on a piece of graph paper.

Like any drawing program, Visio records each shape vertex as a set of

x,y coordinates. When you move the shape or change its size, Visio
records the changes to the shape’s vertices and redraws the shape at
its new position or size.

The difference between Visio and other drawing programs is that you
can enter formulas in the shape’s ShapeSheet to control the location

of a vertex. Instead of simply recording a new position when a shape
is moved or sized, you can calculate a vertex in relation to other ver-
tices or other shapes, or constrain it to a fixed position on the page.

1,1

Width=1
Height=1

2,2
4,2.5

x

y

0,0

1,1

x

y

0,0

Width=3
Height=Width*0.5

When you create a formula for a shape, Visio recalculates the shape’s vertices on the
basis of your formula.

Formulas control not only the locations of a shape’s vertices; they can

control the position, format, and even the content of a shape’s text,
or they can change a shape’s color or pattern. The ability to program
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shapes with formulas opens a wealth of possibilities for making

shapes behave in sophisticated ways—in other words, for making
shapes smart.

The role of ShapeSheets

Every shape, group, and object from another application has a
ShapeSheet. All masters have ShapeSheets. In groups, both the group

and each shape or object in the group has its own ShapeSheet. Each
guide and guide point also has a ShapeSheet.

Visio uses a ShapeSheet to store information about a shape or other
object, such as its dimensions, its angle and center of rotation (its
pin), and the formatting attributes that determine the shape’s ap-

pearance. The ShapeSheet also contains information such as the x-
and y-coordinates of each vertex relative to the shape’s origin. Visio
automatically maintains ShapeSheets and creates new ones as you

make changes in your drawing.

Each ShapeSheet is divided into sections that control an aspect of a

shape’s behavior or appearance, such as its geometry or its formatting.
Each section consists of cells that contain formulas. These can be the
default formulas created by Visio or formulas you create. A formula

might be simple and always evaluate to the same value, or the formula
might be built from functions, operators, and other elements that
evaluate to different values depending on the circumstances. You

change a shape’s behavior by editing formulas in cells. Editing  formu-
las provides a way to change a shape with greater precision than is
possible in the drawing window. By entering and editing formulas in

the ShapeSheet,  you can turn ordinary shapes into SmartShapes.

While a shape is selected, you can display its ShapeSheet. You can

display a ShapeSheet for more than one shape at a time to compare
values or to copy and paste formulas between the ShapeSheets.
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The Height formula in the Object Transform section causes Visio to calculate the shape’s
height as one-half its width.

Displaying the ShapeSheet

ShapeSheets are displayed in the ShapeSheet window within the Vi-
sio main window.

To display a shape’s ShapeSheet:

1. Select the shape.

To select a shape within a group, open the group window and

select the shape. To select a master, open the stencil as an
original or copy, click the title bar of the stencil window, double-
click the master to open the master shape drawing window, and

then select the shape.

2. From the Window menu, choose Show ShapeSheet.

The ShapeSheet window
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3. If you want, choose Tile from the Window menu to see both the

drawing page and the ShapeSheet window.

This allows you to see how changes you make in a shape’s
ShapeSheet affect that shape.

Tip: Press Ctrl and choose Tile from the Window menu to tile all

open windows horizontally.

When the ShapeSheet window is active, the menu bar changes to dis-
play menus and commands you use to work in the ShapeSheet.
When a ShapeSheet cell is selected, a formula bar appears, which you

use to enter and edit ShapeSheet formulas.

To close a ShapeSheet window:

1. From the Control menu, choose Close.

Alternatively, double-click the ShapeSheet window’s Control-
menu box.

Anatomy of a ShapeSheet

The sections that appear in a ShapeSheet depend on the shape itself
and the sections you choose to display. By default, each ShapeSheet

has at least one section. For example, shapes and other objects always
have at least an Object Transform section; guides and guide points
always have a Guide Info section. Visio automatically adds other sec-

tions required for the shape or object as it’s drawn.
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Parts of a ShapeSheet

A ShapeSheet may not have every possible section—for example, a
two-dimensional shape doesn’t have a 1-D Endpoints section, and
only an object from another application has an Image Info section.

Guides and guide points have ShapeSheets that contain a Guide Info
section and can have only a few additional sections, for example Pro-
tection and Scratch. Knowing what information is contained in a

shape’s ShapeSheet gives you an idea of how you can control the
shape with formulas.

Not all ShapeSheet sections refer to a shape’s position or size. For ex-
ample, a cell in the Protection section contains either zero or a
non-zero value, depending on whether the aspect of the shape repre-

sented by that cell is unlocked or locked. A cell in the Line Format
section might contain a number that corresponds to a particular line
pattern. Another might contain a measurement indicating the line

weight.

A ShapeSheet can contain the following sections:

• Object Transform—General positioning information about a
shape, such as its width, height, angle and center of rotation

(pin), whether the shape has been flipped, and how the shape
should behave when resized within a group.

Section

Cell

Row heading Column heading
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• Geometry—The coordinates of the vertices for the lines and arcs

that make up the shape. If the shape has multiple paths, the
ShapeSheet contains a Geometry section for each.

• Protection—The lock settings set with the Protection command,

plus a few additional locks that can be set only in the ShapeSheet.

• Line Format—The line formatting attributes for the shape,

including pattern, weight, and color, the type of line cap,
whether the line has an arrowhead at the beginning or end, the
arrowhead’s size, and the radius of the rounding circle applied to

the line.

• Fill Format—The fill formatting attributes for the shape and the
shape’s drop shadow, including pattern, foreground color, and

background color.

• Character Format—The formatting attributes for the shape’s

text, including font, color, text style, case, position in relation to
the baseline, and point size.

• Paragraph Format—The paragraph formatting attributes for the

shape’s text, including indents, line spacing, and horizontal
alignment of paragraphs.

• Text Block Format—The alignment and margins of text in the
shape’s text block.

• Text Fields—Custom formulas inserted in the shape’s text using
the Insert Field command.

• Text Transform—Positioning information about the shape’s text

block, including its width, height, and angle and center of
rotation (pin).

• Scratch—Work area for entering and testing formulas that other
cells refer to.

• Connection Points—The coordinates of each connection point

defined for the shape.

• Glue Info—Information for a connector shape.
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• 1-D Endpoints—The coordinates of the beginning point and

ending point of a one dimensional shape.

• Alignment—The alignment of a shape relative to the guide to
which the shape is glued.

• Guide Info—The coordinates of a guide or guide point.

• Image Info—The width and height of an object from another

application and the distance the object’s image is offset within its
borders.

• Controls—The coordinates of each control handle defined for
the shape and how they should behave.

• Events—Behavior when the shape is double-clicked or another

event such as moving or rotating a shape occurs.

• Miscellaneous—Miscellaneous object properties including

selection highlighting and visibility.

Working with formulas

If you’ve used a spreadsheet, you’ve probably created formulas that
calculate new values based on the values in other cells. You’ve prob-
ably used functions such as SUM to add a range of values or SQRT to

obtain the square root of a number, and used constants and opera-
tors to get the results you want. Visio formulas are similar to typical
spreadsheet formulas in many ways:

• Like most spreadsheet programs, Visio regards anything in a cell
as a formula, even if it’s a numeric value or simple cell reference.

Every formula begins with an equal sign (=) when it is entered in
the formula bar.

• Visio supports standard mathematical and comparison opera-
tors as well as a full set of mathematical, trigonometric,
statistical, and date and time functions (plus several functions

that are unique).
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• Formulas can contain references to other cells in the ShapeSheet

and to cells in other ShapeSheets.

The similarities essentially stop there, however. Here are some of the

ways in which ShapeSheets differ from typical spreadsheets:

Default formulas. When you create a shape, Visio automatically cre-

ates default formulas. To see what the default formulas are, draw a
simple shape (such as a rectangle, ellipse, or line) and take a look at
its ShapeSheet.

This ShapeSheet contains the default formulas for the rectangle on the right.

Automatic updates. Visio automatically updates certain cells when-

ever you change the shape in a drawing. This means that under some
circumstances your formulas can be replaced with formulas from Vi-
sio. For example, if you drag a corner handle to resize the shape,

Visio resets formulas in the PinX, PinY, Width, and Height cells.

Visio automatically updates the ShapeSheet contents to reflect the shape’s
new size.
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If necessary, you can protect formulas against changes by using the

GUARD function. For details about the GUARD function, see the Vi-
sio online help.

Coordinate systems. Visio uses coordinate systems to refer to posi-
tions of vertices in relation to the origin of a shape and to the origin
of the group or page that contains the shape. Most formulas for con-

trolling the position and size of a shape are expressed as coordinates.

Units of measure. Because many drawings represent physical objects,

Visio accepts units of measure in the English and metric systems, and
you can specify angles in radians or degrees, or minutes and seconds
of arc. You can also use standard typographical measurements such

as picas, points, ciceros, and didots. As in spreadsheet formulas, it’s
important to use the right numbers in a calculation. For example,
you shouldn’t add angles to lengths.

The smart arrow: An example

The quickest way to see how formulas can make a shape smart is by

looking at an example. Changing a simple arrow shape into a full-
powered smart arrow demonstrates how to add intelligence to a shape.

An unschooled arrow

When you draw a closed arrow with the line tool, Visio creates default

formulas in its ShapeSheet. These default formulas cause the arrow
shape to scale proportionally when you size it horizontally or vertically.
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The following illustration shows the formulas Visio creates for the

arrow’s vertices. Each vertex is calculated as a fraction of width and
height, and its formulas are placed in the Geometry section of the
ShapeSheet.

Height * 0.75

Height * 0.25

y

x
Width * 0.6667

Width

Height

➋

➊

➌

➍

➎

➏

➐➑

An unschooled arrow and the default formulas for its vertices

Segment type X Y

➊ Start = Width * 0 = Height * 0.75

➋ LineTo = Width * 0 = Height * 0.25

➌ LineTo = Width * 0.6667 = Height * 0.25

➍ LineTo = Width * 0.6667 = Height * 0

➎ LineTo = Width * 1 = Height * 0.5

➏ LineTo = Width * 0.6667 = Height * 1

➐ LineTo = Width * 0.6667 = Height * 0.75

➑ LineTo = Geometry1.X1 = Geometry1.Y1

This arrow looks fine until you resize it in one direction; then, be-
cause it scales proportionally, the shape of the arrowhead becomes

distorted.

All y-coordinates are
multiples of Height.

All x-coordinates are
multiples of Width.

Unschooled arrow

Resized width

Resized height
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Making the arrow slightly smarter

By adjusting formulas in the ShapeSheet, you can make the arrow

smart enough to keep its arrowhead at a fixed size, even if the arrow
itself is stretched horizontally.

Height * 0.75

Height * 0.25

y

x
Width - 2 in.

Width

Height

➋

➊

➌

➍

➎

➏

➐➑

2 in.

The slightly smarter arrow’s formulas keep its arrowhead from stretching horizontally.

Segment type X Y

➊ Start = Width * 0 = Height * 0.75

➋ LineTo = Width * 0 = Height * 0.25

➌ LineTo = Width - 2 in. = Height * 0.25

➍ LineTo = Geometry1.X3 = Height * 0

➎ LineTo = Width * 1 = Height * 0.5

➏ LineTo = Geometry1.X3 = Height * 1

➐ LineTo = Geometry1.X3 = Height * 0.75

➑ LineTo = Geometry1.X1 = Geometry1.Y1

Arrowhead shape is pre-
served if Width changes.

The x-coordinates of all
vertices along base of

arrowhead are Width - 2 in.

Slightly smarter arrow

Resized width

Resized height
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This can be done by changing the values of the x-coordinates of

points along the base of the arrowhead (vertices 3, 4, 6, and 7) to a
fixed distance, such as 2 inches, measured from the right end of the
arrow. The formula looks like this:

= Width - 2 in.

This formula is entered in cell X3 of the Geometry1 section, which
determines the x-coordinate of vertex 3. Rather than repeat this for-
mula in the cells that control the x-coordinates of the other base

vertices, it’s more efficient to enter a formula that refers to the value
of cell X3. This also allows more flexibility for adjusting the arrow’s
behavior later, because you can change the formula in one cell in-

stead of several.

Now the arrow can be stretched to any width and its arrowhead al-

ways remains the same length: 2 inches measured from the right end
of the arrow.

That takes care of when the arrow becomes wider. However, the ar-
rowhead still distorts when the height of the arrow changes.

Making the arrow even smarter

To prevent the arrowhead from distorting when the height of the ar-

row changes, replace the formula in cell X3 with a slightly different
formula—one that calculates the location of the arrowhead’s base as
a fraction of its height:

= Width - Height/2
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This formula gives the arrowhead a constant 90-degree tip. Because

the x-coordinates of the other vertices along the base already refer to
this cell, no other formulas need to be changed.

Height * 0.75

Height * 0.25

y

x
Width - Height/2

Width

Height

➋

➊

➌

➍

➎

➏

➐➑

The smarter arrow’s formulas keep its arrowhead from stretching horizontally or vertically.

Segment type X Y

➊ Start = Width * 0 = Height * 0.75

➋ LineTo = Width * 0 = Height * 0.25

➌ LineTo = Width - Height/2 = Height * 0.25

➍ LineTo = Geometry1.X3 = Height * 0

➎ LineTo = Width * 1 = Height * 0.5

➏ LineTo = Geometry1.X3 = Height * 1

➐ LineTo = Geometry1.X3 = Height * 0.75

➑ LineTo = Geometry1.X1 = Geometry1.Y1

Arrowhead shape is preserved if
Width or Height changes.

The x-coordinates of all vertices
along base of arrowhead are

Width - Height/2

Smarter arrow

Resized width

Resized height
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A sophisticated arrow

You can create a sophisticated arrow that can easily be customized for

different situations by adding a Scratch section to the ShapeSheet.
You enter values in the Scratch section and refer to them in cells in
the Geometry section. The cells affect how close the arrow’s ends

come to the selection rectangle, and the relative shapes of the arrow
shaft and the arrowhead. In addition, the arrow is designed so that its
base won’t appear behind its beginning—in other words, the arrow

can’t be turned inside out by shrinking its width too much. This is
accomplished by defining the formula for locating the base of the ar-
rowhead on the arrow shaft as follows:

= Width - MIN(Geometry1.X1 + Height * Scratch.B1,Width/2)

This formula ensures that the arrowhead base never moves past the
middle of the arrow.

These Scratch cells affect the arrow’s behavior in the following ways:

Scratch.X1. A value that the ends of the arrow are offset from the
arrow’s selection rectangle. This is useful for block diagrams in
which you want to preserve a uniform distance between the boxes

and arrows.

Scratch.A1. A value between 0 and 1 that represents the arrow shaft’s

thickness relative to the thickness of the arrowhead’s base (the value
in the Height cell). The higher the value of Scratch.A1, the thicker
the shaft becomes in relation to the arrowhead’s base. For example, if

the value of this cell is 0.5, the shaft of the arrow is one half the thick-
ness of the base of the arrowhead.

Scratch.B1. A value greater than 0 (and generally no more than 2)
that represents the length of the arrowhead relative to the thickness
of the arrowhead’s base. The higher the value, the sharper the

arrowhead’s point becomes.
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Segment type X Y

➊ Start = Scratch.X1 = Height - Geometry1.Y2

➋ LineTo = Geometry1.X1 = 0.5 * Height *(1 - Scratch.A1)

➌ LineTo = Width - MIN(Geometry1.X1 + = Geometry1.Y2
Height * Scratch.B1,Width/2)

➍ LineTo = Geometry1.X3 = Height * 0

➎ LineTo = Width - Geometry1.X1 = Height * 0.5

➏ LineTo = Geometry1.X3 = Height * 1

➐ LineTo = Geometry1.X3 = Geometry1.Y1

➑ LineTo = Geometry1.X1 = Geometry1.Y1

Height - Geometry 1.Y2

0.5 * Height *(1 - Scratch.A1)

y

x

Width - Scratch.X1 Width

Height

➋

➊

➌

➍

➎

➏

➐➑

Scratch.X1

Height * Scratch.B1

A sophisticated arrow can be customized by adding values to its Scratch cells.

Tip: You can add even more flexibility and control to the arrow by

adding control handles to it. For an example, see the Flexi-Arrow

shape on the Practice stencil.

Scratch.A1 is the thickness of the arrow shaft in relation
to the thickness of the base of the arrowhead.

Scratch.X1 is the inset from the left
and right edges of the selection

rectangle to each end of the arrow.

Scratch.B1 is the length
of the arrowhead in
relation to the thickness
of the arrowhead base.
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Working within the ShapeSheet

This section discusses techniques you can use to work efficiently in
the ShapeSheet. It describes how to move around the ShapeSheet,

change the display, and modify the structure of the ShapeSheet.

Tip: If you don’t see ShapeSheet commands on the Edit, View, or In-

sert menu, make sure the ShapeSheet window is active.

Moving around the ShapeSheet

To move from cell to cell in the ShapeSheet, use the arrow and Tab
keys. You can also just click a cell to activate it, or scroll the
ShapeSheet without changing the active cell.

To Do this

Activate a cell Click the cell with the mouse pointer

Select a numbered Click the row number

row of cells

Move left one cell Press the Left Arrow key or Shift+Tab

Move right one cell Press the Right Arrow key or Tab

Move up one cell Press the Up Arrow key

Move down one cell Press the Down Arrow key

Move to the last Press End
cell in a row

Move to the first Press Home
cell in a row

Scroll down Press the Page Down key
one screen

Scroll up one screen Press the Page Up key

continued
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To Do this

Scroll right Press Ctrl+Page Down
one screen

Scroll left one screen Press Ctrl+Page Up

Scroll to the Press Ctrl+End

ShapeSheet’s lower-
right corner

Scroll to the Press Ctrl+Home

upper-left corner

Displaying values or formulas in cells

Sometimes it’s helpful to display formulas in the cells of a ShapeSheet

to see how the formulas relate to each other. You can display formu-
las or values in cells. A value is the result you get when Visio
calculates a cell’s formula.

To display formulas in cells:

1. From the View menu, choose Formulas.

Visio displays formulas in cells, widening the cells if necessary.
Some long formulas, however, may be truncated.

To display values in cells:

1. From the View menu, choose Values.

Visio displays values in cells, shrinking the cells to their default

size.

Showing, hiding, adding, and deleting sections

You can change the display of sections to best suit your task. You can
collapse and expand sections, hide and show them, add new ones,

and delete those you don’t need.
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If you hide the cells in a section but leave the section heading visible,

you can expand the section to see its cells again.

To collapse or expand a section:

1. Point to the section title.

If the mouse pointer changes to a minus sign, you can collapse

the section.

If the mouse pointer changes to a plus sign, you can expand the

section.

2. Click the section title.

Visio changes the display to either hide or show the section’s
cells.

To completely hide sections you don’t need or to show sections you
do need, use the Sections command on the View menu.

To show or hide sections:

1. From the View menu, choose Sections.

The Sections dialog box appears.

2. Check the sections you want to show, or uncheck the sections

you want to hide.

If a section is dimmed in the dialog box, it is not available for the

selected shape. For example, Image Info is available only for
objects from other applications.

3. Choose OK.

Visio adjusts the display of the ShapeSheet to either hide or show
the selected sections.

By adding new sections to the ShapeSheet, you can add new charac-
teristics to the shape. For example, you can add a Connection Points

section so you can specify the coordinates of the shape’s connection
points. When you no longer need a section, you can delete it.
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To add a section:

1. From the Insert menu, choose Section.

The Insert Section dialog box appears.

2. Choose the sections you want to add.

If a section is dimmed in the dialog box, it is already included

in the ShapeSheet or is not available for the selected shape or
object.

3. Choose OK.

Visio adds the section to the ShapeSheet.

If you use the Section command to add a section to the ShapeSheet,

but you don’t see the new section in the ShapeSheet window, use the
Sections command to make sure the section is set to display.

You can delete sections from a ShapeSheet by using the Delete Sec-
tion command. You must first select a cell in the section before you
can delete it.

To delete a section:

1. Select a cell in the section you want to delete.

2. From the Edit menu, choose Delete Section.

Visio deletes the section from the ShapeSheet.

There are certain sections that cannot be deleted. For example, you
cannot delete an Object Transform section because it specifies a
shape’s position. If you cannot delete a section, Delete Section is

dimmed on the menu.

Adding and removing rows

You can add rows to ShapeSheet sections to hold additional formu-
las. You might insert a row in the Geometry section to add a new

segment to the shape, add a row to the Connection Points section to
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define a new connection point, or insert a row in the Scratch section

to make more room for storing parameters used in the formulas of
several cells. Similarly, you can remove rows you no longer need.

To add a new row before an existing row:

1. Select a cell in the row in the position where you want to add the

new row.

2. From the Insert menu, choose Row.

Visio inserts the new row above the row you selected.

To add a new row after an existing row:

1. Select a cell in the row that’s one row above the position where
you want the new row.

2. From the Insert menu, choose Row After.

Visio inserts the new row below the row you selected.

To delete a row:

1. Select a cell in the row you want to delete.

2. From the Edit menu, choose Delete Row.

Visio removes the selected row and moves any following rows up
by one row in the section.

Entering and editing formulas in a ShapeSheet

By editing a cell’s formula, you change how the value of the cell is cal-
culated and, therefore, change a particular behavior of the shape.

A formula always starts with an equal sign. You don’t have to type the
equal sign; Visio inserts it. What follows may be as simple as a single-

digit number. For example = 6 is a valid formula that always
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evaluates to the number 6. On the other hand, what follows the equal

sign can be considerably more sophisticated. For example, you can
create a formula that changes a shape’s default proportional scaling
so that when a shape is scaled, specific vertices remain offset a fixed

amount from the left of the shape.

The formula in a cell can be the Visio default formula, one that you

enter in the cell, or one that is inherited from a master shape.

A formula can contain these elements:

Element Description

Numbers Used in formulas to specify a wide range of
values, for example, measurements, angles,
styles, and colors. A number can include a plus

or a minus sign and can be entered in exponen-
tial notation (for example, 1.2E-6) or as a
fraction (for example, 5 9/16).

Units of measure Used after a number to specify the unit of
measure that the number represents. If you

don’t specify a unit of measure, Visio uses
default units of measure in cells that require a
unit of measure.

Cell references Used in formulas to calculate the value of one
cell based on the value of another cell.

Functions The mathematical, trigonometric, logical, date
and time, statistical, and miscellaneous func-
tions in Visio that are used for a variety of

purposes in formulas.

Operators Used to create mathematical expressions in

and parentheses formulas.

Special terms Used to refer to page properties and text in
formulas.
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Typing formulas

You can type formulas in the formula bar, much as you do in a

spreadsheet program.

To type a new formula for a cell:

1. In the ShapeSheet, click the cell to select it.

The cell’s formula appears in the formula bar.

2. Type the formula.

The formula you type replaces the cell’s previous formula.

If you type a number but don’t supply units of measure, Visio
uses the units from the cell’s previous value (if there was one).

Otherwise, Visio uses the default units of measure for the cell.

3. To accept the formula, click the Enter box in the formula bar or

press Enter.

To cancel your changes, click the Cancel box in the formula bar

or press Esc.

If the number or formula contains an error, Visio displays a
message and highlights the error in the formula bar. Correct the

error, and then click the Enter box or press Enter to accept the
correction.

If you don’t want to replace an entire formula, you can select and edit
the part you want to change.

To edit a selected part of a formula:

1. In the ShapeSheet, select the cell you want.

2. In the formula bar, edit the formula using the following
techniques.

Cancel box

Enter box
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To Do this

Place the insertion point Click where you want the
insertion point to appear

Move the insertion point Press the Left or Right Arrow key

Delete the character to the left Press Backspace

Delete the character to the right Press Delete

Select text Drag the mouse over the text

Extend the selection to the left Press Shift+Left Arrow

Extend the selection to the right Press Shift+Right Arrow

Select a word Press Ctrl+Shift+Right Arrow or
double-click the word

Select to the end Press Shift+End

Select to the beginning Press Shift+Home

Replace selected text Type the new text

Delete selected text Press Delete or choose Cut or

Clear from the Edit menu

Building a formula by pasting

You can build formulas by typing, but Visio also has commands for
pasting cell names and functions into a formula.

To paste a cell name into a formula:

1. In the formula bar, place the insertion point where you want to
paste the name.

Until you place the insertion point, the Name command is

unavailable.

2. From the Insert menu, choose Name.

The Insert Name dialog box appears.
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3. Choose the name you want from the list.

4. When the formula is finished, click the Enter box in the formula
bar to accept the formula. Click the Cancel box to cancel your
changes.

Alternatively, you can paste the name of a cell into a formula by plac-
ing the insertion point in the formula bar, then clicking the cell you

want. Visio inserts the name of the cell at the insertion point.

To paste a function into a formula:

1. In the formula bar, place the insertion point where you want to
paste the function.

Until you place the insertion point, the Function command is
unavailable.

2. From the Insert menu, choose Function.

The Insert Function dialog box appears.

3. Choose the function you want from the list.

4. If you want Visio to include the syntax for the function’s argu-

ments, check Insert Arguments.

5. Choose OK.

6. Supply the arguments for the function by typing them,  by click-
ing cells in the ShapeSheet, or by using the Name command.

7. When the formula is finished, click the Enter box in the formula
bar to accept the formula. Click the Cancel box to cancel your
changes.

Copying and pasting formulas between cells

Often the formula you want is similar to a formula in another cell,
either in the same ShapeSheet or another ShapeSheet. Rather than
retype the formula, you can save time by copying and pasting it into

a cell, and then editing the formula as needed.
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To copy and paste a formula:

1. Select the cell that contains the formula you want to copy.

2. In the formula bar, select the formula.

3. From the Edit menu, choose Copy.

Visio copies the formula to the Clipboard.

4. Cancel the activation of the source cell by clicking the Cancel
box or pressing Esc.

If you don’t cancel the source cell, the cell reference of the next
cell you click will be added to the source cell’s formula.

5. Select the cell where you want to paste the formula.

6. In the formula bar, select the formula.

7. From the Edit menu, choose Paste.

Visio pastes the formula into the formula bar.

8. Click the Enter box or press Enter to accept the formula.

To discard the formula, click the Cancel box or press Esc.

Working with local and inherited formulas

Each cell in a ShapeSheet can be defined with a local formula, or it

can inherit its formula from the shape’s master or style. Visio uses
color in the ShapeSheet to indicate whether a cell’s formula is local:
local formulas are blue and inherited formulas are black.

In general, you should use inherited formulas. You should be aware
that some Visio commands cause cells to gain or lose local formulas

and that there are different ways to protect a cell’s formula.
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Visio uses inherited formulas whenever possible. This means that an

instance uses the formulas in its master rather than making local
copies of them. Using inherited formulas requires less memory and
results in uniform behavior. If you add local overrides—for example,

if you format an instance of a master shape—you are adding local
formulas to the shape. After you add a local override, changing the
master no longer changes the local value for the overridden cell—the

value comes from the local formula instead.

To delete a local formula and use an inherited one, enter an “empty”

formula in the cell.

To enter an “empty” formula:

1. Select the cell.

2. In the formula bar, delete the formula’s text.

3. Press Enter.

Try this with a newly created Scratch cell after inserting a local for-
mula. It reverts to No Formula, because there’s no formula to inherit
from the master. If No Formula is displayed in a cell other than a

Scratch cell, you’ve probably made a mistake—choose Undo from
the Edit menu to restore the previous formula.

An easy way to delete all local formulas in a format section (line, fill,
text, character, or paragraph) is to apply an appropriate style to the
shape. Applying a style deletes all local formulas in the related cells

unless the Preserve Local Formatting option is checked in the Styles
dialog box when the style is applied.
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Writing programs to
control Visio

In earlier chapters you learned how to control Visio by using Visio

menus and commands. This chapter introduces you to controlling
Visio by writing programs.

This chapter provides only an overview of what you must know to
write programs that control Visio. The book Programming Visio
(published by Shapeware) is a detailed guide to creating these pro-

grams. For a list of terms you can use in writing programs for Visio,
see the Visio online help.

To understand this chapter, you should be familiar with basic pro-
gramming terms and concepts.
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How programs work

You can write programs that are external and independent of  Visio
to create and control shapes in Visio. To write these programs, you

use an OLE Automation controller such as Visual Basic 3.0 (or an-
other programming language that supports OLE Automation).

The OLE Automation controller interacts with applications through
the OLE 2.0 libraries. These libraries are installed on your system
when you install either Visual Basic or Visio. The following illustra-

tion shows how a Visual Basic program and Visio interact through
OLE Automation.

A program written
in an OLE

Automation
controller such as

Visual Basic

The OLE
libraries

An application
such as Visio that
exposes objects

The program calls the The OLE libraries Visio processes the
OLE Automation libraries, forward the calls calls and returns the
specifying Visio as the to Visio. results.
target application.

The program you write can control the drawing and diagramming

capabilities of Visio. For example, it can automate simple repetitive
tasks like:

• Printing all the master shapes on a particular stencil.

• Creating a floating list to turn pages.

• Generating an organization chart from a list of names and
positions.

Programs can also incorporate Visio into a larger custom solution.

For more information about OLE Automation, see the Object Link-
ing and Embedding Programmer’s Reference, published by Microsoft

Press.
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Writing programs

Visio provides objects, methods, and properties so that programs
can communicate with it:

• Objects represent the documents, drawing pages, styles, and
shapes you work with in Visio.

• Methods are actions associated with objects. For example, in a
program you can employ a method that opens documents. This
method is equivalent to opening a document using the Open

command on the File menu in Visio.

• Properties are attributes that affect the appearance or behavior of

objects. For example, a document or page object has a Name
property, which represents the name of the object.

For information about the objects, methods, and properties pro-
vided by Visio, see the Visio online help.

Writing a program to control Visio is similar to creating any com-
puter program.

To write a program to control Visio:

1. Describe what you want to do in statements called pseudo code.

For an example, see “A sample program” later in this chapter.

Alternatively, illustrate the process by drawing a flowchart using

Visio.

2. Use Visual Basic 3.0 (or another programming tool that supports
OLE Automation) to write code representing what you want

to do.

3. Compile the code into an executable program.

4. If you plan to run the program as an add-on in Visio, save the
compiled program in the Visio Add-ons directory.

Alternatively, save the executable file in the appropriate location
for your program application.
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Running programs

There are several ways to run programs.

You can run a program from a program icon, just as you run other
Windows programs. First create a program, and then create an icon
and add it to the Visio program group (or the group of your choice).

To run a program from a Windows icon:

1. Open the Windows program group containing the icon.

2. Double-click the icon representing the program.

From within Visio, you can run an add-on from the File or Tools
menu. (If the drawing window is active, you run the add-on from the
Tools menu; otherwise, you run it from the File menu.)

To run a program from Visio’s File or Tools menu:

1. From the menu, choose Run Add-On.

2. In the Run Add-On dialog box, choose the name of the add-on

you want to run, and then choose OK.

You can automate the process of running a program by associating it

with a particular shape in a drawing.

To associate a program with a shape and run the program:

1. Select the shape.

2. From the Format menu, choose Double-Click.

❖ In Visio’s SmartSuite menu set, choose Double-Click from the
Style menu.

3. In the Double-Click dialog box, choose the Run Add-On option.

4. From the list of add-on programs, choose the one you want

to run.
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5. Choose OK.

6. Double-click the shape to run the program.

A sample program

This section illustrates a program that examines the open drawings
in Visio and then prints the name of each drawing, followed by the

names of the pages in the drawing.

In pseudo code, the program does the following:

1. Finds a drawing that is open in Visio.

2. Prints the name of the drawing.

3. Prints the name of each page in the drawing.

4. Repeat steps 1 through 3 until there are no more open drawings.

In a flowchart, these steps look like:

Start Another
Drawing

Print Name

Another
Page?

Print Page Name

No Stop

No

Yes

Yes
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The following table shows the Visual Basic program that implements

this pseudo code.

This Visual Basic code Does this

Sub ShowNames ()
Dim iDoc As Integer, iPag As Integer Variable declarations

Dim appVisio As Object
Dim pagObj As Object, docObj As Object
Dim docsObj As Object

Set appVisio = GetObject(,"visio.application")
Set docsObj = appVisio.Documents Gets all open drawings

For iDoc = 1 To docsObj.Count
Set docObj = docsObj(iDoc) Gets one drawing
Printer.Print docObj.Name Prints its name

For iPag = 1 To docObj.Pages.Count
Set pagObj = docObj.Pages(iPag) Gets a page

Printer.Print Tab(5); pagObj.Name Prints its name
Next iPag

Next iDoc

Printer.EndDoc
End Sub

The following table illustrates the sample output.

Sample output Description

c:\drawings\pages.vsd The name of the first drawing
Background-1 The name of page 1
Background-2 The name of page 2

c:\drawings\recycle.vsd The name of the second drawing
Page-1 The name of page 1
Page-2 The name of page 2

Page-3 The name of page 3
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Toolbars

The toolbars and menus available in Visio vary depending on several

factors, including whether a drawing or stencil window is active, the
resolution of your display, and which tools you are using. This ap-
pendix illustrates the Visio standard toolbars and menus as they

appear on a Super VGA monitor with 800 x 600 pixel resolution with
the screen maximized.

The tables that follow each toolbar illustration describe every item
available on the toolbar at the highest resolution displays. These
tables also show buttons as they appear on Visio’s Lotus SmartSuite

and Microsoft Office toolbar options.

Finally, if a button has been identified earlier in the appendix, it isn’t

identified again in the illustrations of the toolbars.
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Visio standard toolbar

Visio standard and Description Lotus SmartSuite
Microsoft Office

New button. Opens the New dialog box.

Open button. Opens the Open dialog box.

Open Stencil button. Opens the Open Stencil

dialog box.

Save button. Saves the active file.

Print button. Prints the current drawing page.

Print Preview button. Displays a window that

shows how the current drawing will appear

when it is printed.

Previous Page button. Displays the page

previous to the currently displayed page.

Next Page button. Displays the page following

the currently displayed page.

Left Align button. Aligns the left edges of the

selected shapes with the left edge of the first
shape selected.

Vertical Align button. Aligns the centers of the

selected shapes vertically  with the center of the
first shape selected.
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Visio standard and Description Lotus SmartSuite
Microsoft Office

Right Align button. Aligns the right edges of

the selected shapes with the right edge of the

first shape selected.

Top Align button. Aligns the tops of  selected

shapes with the top of the first shape selected.

Horizontal Align button. Aligns the centers of

the selected shapes horizontally with the center
of the first shape selected.

Bottom Align button. Aligns the bottom edges

of the selected shapes with the bottom edge of
the first shape selected.

Horizontal Ends Distribution button. Distributes
three or more selected shapes horizontally so that

there are uniform gaps between the shapes.
The leftmost and rightmost shapes do not move.

Horizontal Center Distribution button. Dis-
tributes three or more selected shapes horizontally
so that their centers are uniformly spaced. The

leftmost and rightmost shapes do not move.

Vertical Ends Distribution button. Distributes
three or more selected shapes vertically so that

there are uniform vertical gaps between the
shapes. The top and bottom shapes do not move.

Vertical Center Distribution button. Distributes
three or more selected shapes vertically so that
their centers are uniformly spaced. The top and 

bottom shapes do not move.



          

Visio standard and Description Lotus SmartSuite
Microsoft Office

Connect Shapes button. Glues a one-
dimensional shape between the closest

connection points on selected two-dimensional
shapes.

Flip Horizontal button. Reverses the left and

right sides of the selected shape.

Flip Vertical button. Reverses the top and

bottom of the selected shape.

Rotate Right button. Rotates the selected shape
90 degrees clockwise.

Rotate Left button. Rotates the selected shape
90 degrees counterclockwise.

Decrease Font Size button. Reduces the font
size of the selected text.

Increase Font Size button. Enlarges the font
size of the selected text.

Line Weight button. Applies a series of line
weights to the selected shape.

Line Pattern button. Applies a series of

patterns to the selected shape.

Line Ends button. Adds arrowheads to one or

both ends of the selected shape.

Corners button. Applies a series of rounded
corner styles to the selected shape.

Shadow button. Applies a series of shadows
to the selected shape.

Snap button. Turns the snapping feature on
and off.
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Visio standard and Description Lotus SmartSuite
Microsoft Office

Glue button. Turns the glue feature on and off.

Zoom Out button. Decreases the page magnifi-

cation, centering the selected shape in the new view.

Zoom In button. Magnifies the page view, centering

the selected shape in the new view.

Pointer tool. A general tool for dragging masters
and selecting, moving, and resizing shapes.

Pencil tool. Draws line and arc segments.

Line tool. Draws straight line shapes.

Arc tool. Draws elliptical arc shapes.

Rectangle tool. Draws rectangular or square shapes.

Ellipse tool. Draws elliptical or circular shapes.

Connector tool. Draws a connector between

shapes.

Connection point tool. Adds a connection point
to the selected shape.

Rubberstamp tool. Stamps instances of the
selected master shape into a drawing.

Text tool. A specialized tool for working with

text and displaying the text toolbar.

Text block tool. Selects the text block for moving

and rotating independently of the shape.

Rotation tool. Rotates the selected shape
by any amount.

Crop tool. Sizes the border or frame that surrounds
an imported, linked, or embedded object.
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Text toolbar

The following table describes the buttons available only on the text

toolbar.

Visio standard and Description Lotus SmartSuite
Microsoft Office

Undo button. Reverses the last action.

Redo button. Reverses the last undo command.

Text Color button. Applies a series of colors to
the selected text.

Bold button. Adds or removes bold face from
the selected text.

Italic button. Adds or removes italics from the
selected text.

Underline button. Adds or removes an
underline from the selected text.

Superscript button. Elevates the selected text
into superscript position.

Subscript button. Drops the selected text into

subscript position.

Left Align Text button. Aligns the text to the

left edge of the selected text block.

Center Align Text button. Centers the text
horizontally within the selected text block.

Right Align Text button. Aligns the text to the
right edge of the selected text block.

Justify Text button. Evenly distributes the text
within the boundaries of the selected text block.
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Visio standard and Description Lotus SmartSuite
Microsoft Office

Top Align Text button. Aligns the selected text

to the top of the text block.

Middle Align Text button. Centers the selected

text vertically within the text block.

Bottom Align Text button. Aligns the selected

text to the bottom of the text block.

Zoom Text 100% button. Magnifies the view of

the selected text to 100%.

Stencil toolbar

The following table describes the buttons available only on the stencil
toolbar.

Visio standard and Description Lotus SmartSuite
Microsoft Office

Cut button. Removes the selected shape or text

and places it on the Clipboard.

Copy button. Places a copy of the selected shape

or text on the Clipboard.

Paste button. Pastes the contents of the

Clipboard into the current drawing.

Delete button. Deletes the selected shape or text.
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Visio standard and Description Lotus SmartSuite
Microsoft Office

Repeat button. Repeats the last action.

New Window button. Opens a new window that

 contains a copy of the current window’s contents.

Tile button. Places the open windows

side by side across the screen.

Cascade button. Positions the open

windows on top of each other so that their title
bars are visible.

Icons And Names button. Displays the master

shape icons and names in the stencil window.

Icons Only button. Displays only the master

shape icons in the stencil window.

Names Only button. Displays only the names

of master shapes in the stencil window.

Arrange Icons button. Arranges the icons in

the stencil window.
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Edit icon toolbar

The following table describes the buttons available only on the edit

icon toolbar.

Visio standard and Description Lotus SmartSuite
Microsoft Office

Icon pencil tool. Applies the selected color to

single pixels as you click or drag the tool.

Paint bucket tool. Applies the selected color to
all adjacent, like-colored pixels when you click

the tool in an area.

Lasso tool. Selects a non-rectangular area.

Selection net tool. Selects a rectangular area.
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Print preview toolbar

The following table describes the buttons available only on the print

preview toolbar.

Visio standard and Description Lotus SmartSuite
Microsoft Office

First Tile button. Displays the first page or tile

in the print preview window.

Previous Tile button. Displays the previous page
or tile in the print preview window.

Next Tile button. Displays the next page or tile in
the print preview window.

Last Tile button. Displays the last page or tile in
the print preview window.

Whole Page button. Displays the entire drawing
page in the print preview window.

Single Tile button. Displays a single tile in the
print preview window.
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Shortcuts

This appendix lists keyboard shortcuts that you can use to work

more efficiently in Visio. Keyboard shortcuts for some commands are
also listed on Visio’s menus and are the same regardless of which
menu set you’re using (Visio standard, Microsoft Office, or Lotus

SmartSuite).

Also included in this appendix are methods for typing special char-

acters, either by using Visio’s shortcuts or by accessing the ANSI
character set.

Some keyboard shortcuts use the F11 or F12 keys. If your keyboard
has only 10 function keys, use Alt+F1 for F11 and Alt+F2 for F12.
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Keystroke shortcuts

To choose this tool Press

Arc Ctrl+4

Connection point Ctrl+8

Connector Ctrl+7

Ellipse Ctrl+6

Line Ctrl+3

Pencil Ctrl+2

Pointer Ctrl+1

Rectangle Ctrl+5

Rotation Ctrl+0

Text Ctrl+9

To insert a field in text Press

Height field Ctrl+Shift+H

Rotation angle field Ctrl+Shift+A

Width field Ctrl+Shift+W

To choose this command Press

Actual Size Ctrl+I

Bring To Front Ctrl+F

Clear Delete

Copy Ctrl+C

Cut Ctrl+X

Duplicate Ctrl+D

continued
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To choose this command Press

Flip Horizontal Ctrl+H

Flip Vertical Ctrl+J

Group Ctrl+G

New Ctrl+N

Open Ctrl+O

Paste Ctrl+V

Print Ctrl+P

Redo Ctrl+Backspace

Rotate Left Ctrl+L

Rotate Right Ctrl+R

Save Ctrl+S

Select All Ctrl+A

Send To Back Ctrl+B

Undo Ctrl+Z

Ungroup Ctrl+U

Whole Page Ctrl+W

To format text in a text block Press

Bold Ctrl+Shift+B

Italic Ctrl+Shift+I

Small caps Ctrl+Shift+Y

Subscript Ctrl+Shift+X

Superscript Ctrl+Shift+Z

Underline Ctrl+Shift+U
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View shortcuts

To change the view Press

Actual size Ctrl+I

Drag drawing Ctrl+Shift+press the right

mouse button and drag

Whole page Ctrl+W

Zoom in Ctrl+Shift+click the left mouse button

Zoom into Ctrl+Shift+left mouse button and drag

defined area rectangle to designate area to zoom into

Zoom out Ctrl+Shift+click the right mouse button

Function key shortcuts

You can use function keys to perform many tasks more quickly

in Visio.

Function Keys To Press

F1 Display online help F1

F2 Open or select a shape’s F2
text block

F3 Fill command F3
Line command Shift+F3

F4 Repeat command F4

Exit command Alt+F4

continued



         

Function Keys To Press

F5 Go To Page command F5
Page Setup command Shift+F5

F6 Zoom command F6

F7 New Window command F7

Tile command Shift+F7
Cascade command Alt+F7

F8 Align Shapes command F8

F9 Glue F9
Snap Shift+F9

Text Field command Ctrl+F9
Snap & Glue Setup Alt+F9
command

F10 Activate menu bar F10

F11 Font  command F11

Paragraph command Shift+F11
Tabs command Ctrl+F11

Text Block command Alt+F11

F12 Save As command F12
Save command Shift+F12

Open command Ctrl+F12
Print command Ctrl+Shift+F12
Save Workspace Alt+F12

command
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Typing special characters

Use these key combinations to type commonly used special charac-
ters in text.

To type Press

‘ beginning single quote Ctrl+[

’ ending single quote Ctrl+]

“ beginning double quote Ctrl+Shift+[

” ending double quote Ctrl+Shift+]

• bullet Ctrl+Shift+8

– en dash Ctrl+=

— em dash Ctrl+Shift+=

- discretionary hyphen Ctrl+hyphen

- nonbreaking hyphen Ctrl+Shift+hyphen

/ nonbreaking slash Ctrl+Shift+/

\ nonbreaking backslash Ctrl+Shift+\

§ section marker Ctrl+Shift+6

¶ paragraph marker Ctrl+Shift+7

© copyright symbol Ctrl+Shift+C

® registered trademark Ctrl+Shift+R

ANSI extended characters

You can type characters from the ANSI extended character set by

using the numeric keypad on your keyboard.



         

To type a character from the ANSI character set:

1. Press the Alt key.

2. On the numeric keypad, type 0 (zero).

3. Type the three-digit code for the character you want.

The following table lists codes for extended characters from the ANSI

character set.

Character ANSI code

” 148

• 149

– 150

— 151

˜ 152

™ 153

š 154

› 155

œ 156

• 157

ž 158

Ÿ 159

  160

¡ 161

¢ 162

£ 163

¤ 164

¥ 165

Character ANSI code

¦ 166

§ 167

¨ 168

© 169

ª 170

« 171

¬ 172

­ 173

® 174

¯ 175

° 176

± 177

² 178

³ 179

´ 180

µ 181

¶ 182

· 183

continued

Character ANSI code

‚ 130

ƒ 131

„ 132

… 133

† 134

‡ 135

ˆ 136

‰ 137

Š 138

‹ 139

Œ 140

• 141

Ž 142

• 143

• 144

‘ 145

’ 146

“ 147
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Character ANSI code

¸ 184

¹ 185

º 186

» 187

¼ 188

½ 189

¾ 190

¿ 191

À 192

Á 193

Â 194

Ã 195

Ä 196

Å 197

Æ 198

Ç 199

È 200

É 201

Ê 202

Ë 203

Ì 204

Í 205

Î 206

Ï 207

Ð 208

Character ANSI code

Ñ 209

Ò 210

Ó 211

Ô 212

Õ 213

Ö 214

× 215

Ø 216

Ù 217

Ú 218

Û 219

Ü 220

Ý 221

Þ 222

ß 223

à 224

á 225

â 226

ã 227

ä 228

å 229

æ 230

ç 231

è 232

Character ANSI code

é 233

ê 234

ë 235

ì 236

í 237

î 238

ï 239

ð 240

ñ 241

ò 242

ó 243

ô 244

õ 245

ö 246

÷ 247

ø 248

ù 249

ú 250

û 251

ü 252

ý 253

þ 254

ÿ 255
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The pointer library

In Visio, the pointer changes to reflect the action you can perform

with the current tool, in the current window, or at the current
pointer location. The table in this appendix illustrates each pointer
and describes the cases in which you see that pointer.
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Drawing and stencil window pointers

With a You can To see this pointer

Move a shape Point to shape with

pointer tool

Duplicate a shape Press Ctrl, then point

to a shape with the
pointer tool

Drag an endpoint Select shape, then point
or a control point to an endpoint

Size a shape Point to handle of shape

selected with pointer tool

Draw line or arc Point to drawing window

with pencil tool

Draw line Point to drawing window

with line tool

Draw arc Point to drawing window

with arc tool

Draw ellipse Point to drawing window

with ellipse tool

Draw rectangle Point to drawing window
with rectangle tool

Connect shapes Point to a shape with the

connector tool

Create an instance Select master, point to

of a master drawing window with
the rubberstamp tool

Rotate a shape Point to drawing window
with rotation tool

continued
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With a You can To see this pointer

Rotate a shape or Point to rotation handle
text block with rotation tool

Move a center of rotation Point to center of rota-

tion with rotation tool

Crop a shape Point to drawing window

with crop tool

Move an object from Point to object with
another application crop tool

within its frame

Add a connection point Point to drawing window

to a shape with connection point
tool

Add text to a drawing Point to drawing window

with text tool

Place insertion point Point to open text block

in text

Insert text in text block Click in an open text

block with text tool

Move a text block Select text block with text
block tool

Zoom into or out of Press Ctrl+Shift
drawing window

Cannot drop a master Drag master to inappro-

priate location
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ShapeSheet pointers

With a You can To see this pointer

Select a row Point to left column of
the ShapeSheet

Select a cell Point to ShapeSheet cell

Expand a section Point to heading of a col-
lapsed section

Collapse a section Point to heading of an
expanded section

Edit icon window pointers

With a You can To see this pointer

Edit individual pixels Point to edit icon

window with the icon
pencil tool

Change color of an area Point to edit icon

window with paint
bucket tool

Select pixels Point to edit icon
window with either lasso

or selection net tool
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Troubleshooting

Support technicians diagnose problems by asking questions related

to specific problem types (for example, installation, printing, display
errors, and so on). This appendix lists questions you may be asked if
you call for technical support. Each section of the appendix is de-

voted to a specific problem area.

The purpose of this appendix is to help you make the most of your

time and effort. In some cases, answering the questions may lead you
to a solution on your own. If not, by answering these questions you’ll
gather critical information that will help a support technician pro-

vide you with faster, more efficient service.

Important: Some of the procedures in this appendix involve modify-
ing files that affect the way Windows and your operating system

function. If you are not sure about any of the instructions, do not at-
tempt to complete the procedure on your own. This is especially
important if you’re using a shared version of Visio or Windows over a

network. Contact your network administrator or information system
manager for help.
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If you follow the steps outlined in this appendix and still need tech-

nical support, it’s always best to be at the computer on which the
problem occurred. In addition, please have the following informa-
tion on hand:

• Your product serial number, which is located on the registration
card.

• A complete description of what you were doing when the
problem occurred and, if applicable, the wording of the error
message you received.

• A description of what you’ve done to diagnose the problem and
the results of your research.

The more information you can provide up front, the faster you’ll be
up and running.

Getting more information from Shapeware

This appendix covers only general diagnostic procedures. Some

problems are more specialized, and others may result from the intro-
duction of new operating systems, hardware, or applications.

To provide you with up-to-the-minute information, Shapeware has a
Fax Information System. To receive information by fax, call (206)
521-4550 and follow the recorded instructions. For an index of avail-

able documents, request document #1000.

The Shapeware technical support team is also ready to assist you. For

details about technical support services, see the Visio online help.
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Installation problems

For information related to installing Visio, see the Visio installation
card. For late-breaking information, see the README.TXT file. For

information about installing Visio 3.0 on a network, see the
NETWORK.TXT file. Both files are located on Visio Disk 1-Setup.

If you have questions during installation, choose the Help button in
the setup dialog box.

To receive late-breaking installation details by fax, call the Fax Infor-
mation System and request document #4000.

Printing problems

To print drawings, Visio relies on printer drivers installed in Win-
dows. Printing errors in Visio can often be related to printer driver

problems or to a faulty connection between your printer and com-
puter. For example, you may not be using the most current driver for
your printer.

The following sections describe common printing problems and
some of the ways to solve them.

If only part of a drawing prints

Are the missing or incomplete shapes outside the drawing page?

If shapes in your drawing are positioned outside the edges of the

drawing page (the white area in the Visio drawing window), they
may not print. You can preview a printed drawing to check the posi-
tion of the shapes. For details about previewing a drawing before you

print, see Chapter 5, “Creating and printing drawing pages.”
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Is your print file exceeding the memory of your printer?

When the complexity of the print file exceeds the available memory
of the printer, pages may not print completely or you may see
memory-related error messages on the display panel of your printer.

(According to printer manufacturers, a typical page of text and
graphics printed at 300 dpi resolution may require as much as 1MB
of printer memory.) To test whether low memory is a problem,

choose a lower print quality setting in the Print dialog box, and then
print the drawing again. You can also try printing the drawing on a
printer that has more memory. If no other printer is available, try

streamlining the drawing. For details, see “Optimizing performance”
later in this appendix.

Tip: The display panels on some printers—for example, Hewlett-

Packard LaserJet 4 printers—provide clues to memory problems by
displaying messages related to printer memory or “print overruns.”

For current information about memory and other specific printers,
call the Fax Information System described earlier in this appendix,
and see the README.TXT file installed with Visio.

If the drawing doesn’t print at all

How many stencils and drawing files do you have open?

If you have more than one stencil or drawing file open, try closing

some files to provide more memory for printing.

Tip: To see a list of open Visio files, open the Window menu. Open
files are listed at the bottom of the menu.
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Can you print other Visio drawings on the same printer?

If some drawings print successfully but others do not, try to deter-
mine what the drawings that don’t print have in common. (Do they
contain a common shape or imported object? Do they contain sub-

stantially more shapes than the drawings that print? Do they contain
any bitmap graphics?) If there is a common element, remove that el-
ement temporarily and try printing again. If the drawing still doesn’t

print, try the techniques suggested in the section “Optimizing per-
formance” later in this appendix.

Can you print successfully to the same printer from another Win-
dows application?

Try printing a file from another Windows application using the same
printer driver and print settings. (It’s best to use a test file that in-
cludes graphic elements.) If you can print from another application,

continue researching the questions below. If you can’t print from an-
other application, there may be several causes:

• The printer driver may not be installed properly. Try removing
the printer driver and then reinstalling it. For details, see your

Windows documentation.

• The information Windows has about your printer setup may be
inaccurate. To update the information, open the Windows Main

program group, double-click the Control Panel icon, and then
double-click the Printers icon. In the Printers dialog box, select
the printer again, and then choose Setup. Choose OK in the

Setup dialog box, and then choose Close in the Printers dialog
box to update the information in Windows.

• System resources required by Windows may be low. To check
system resources, open Windows Program Manager and choose
About Program Manager from the Help menu. The dialog box

shows a percentage of available system resources. If the percent-
age is below 30 percent, close some Windows applications before
you print or restart Windows. Be sure to close any applications

that Windows starts automatically before you print.
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Are you connected directly to the printer, or do you share a printer
through a switchbox, print-sharing device, or network?

If possible, connect your computer directly to the printer to rule out
any communication-related problems. Also, make certain that cables

between your computer and printer are firmly connected.

The drawing prints incorrectly

Are you using the current version of the printer driver?

Microsoft and printer vendors frequently update Windows printer
drivers. To determine the version of most printer drivers, open the

Control Panel window and then double-click the Printers icon. Se-
lect the printer from the Installed Printers list, choose the Setup
button, and then choose the About button in the next dialog box that

appears. For information about the current release of your printer
driver, contact your printer manufacturer or Microsoft.

If lines and fills in your printed drawing are missing or print incor-
rectly, there may be a problem with the way Windows and your
display driver are interacting.

When you print, Visio communicates with the printer using the
Windows Graphics Device Interface (GDI). GDI supplies a common

language for Windows applications and converts that language to
printer language such as PCL or PostScript. Sometimes GDI cannot
translate graphic information into an equivalent function in the

printer language. When this occurs, GDI uses the display driver to
produce a bitmap version of the graphic and sends that version to the
printer. If the display driver can’t provide adequate information, you

will see problems in your printed output.

For details about display-related printing problems, see the following

section, “Display problems.”
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Display problems

Display problems show up in a variety of ways. For example, you may
see an error message when you scroll in a window, size or drag a

shape, or change views. You may also notice that colors are displayed
incorrectly, or that lines and fills are not visible at some views.

Tip: Error messages regarding display drivers often contain filenames

ending with the extension .DRV.

Visio relies on display drivers installed in Windows to display draw-

ings on the screen. As a result, display errors in Visio can often be
attributed to incompatibilities with particular display drivers. For ex-
ample, you may not be using the correct settings or the most

up-to-date driver.

If you suspect you might be having display problems, it’s important

to first determine which display mode you’re using.

To check your current display mode:

1. In the Windows Main program group, double-click the Windows
Setup icon.

2. In the Windows Setup dialog box, check the Display line for a
description of the mode you’re using.

A typical description contains a reference to both resolution and
the number of colors supported under the mode of the driver.
For example, the description might read 800 x 600-256 colors.

3. If the display mode is something other than VGA or Super VGA
and you know that your display card can emulate a VGA card,
consider installing the standard VGA driver files from your

Windows disks to test whether display problems are related to
the mode you’re using.

For details about specifying a different display driver and
changing display settings, refer to your Windows or display card
documentation.
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If you can’t reproduce the print or display problem using the

VGA driver (a basic Windows driver file), there may be a
problem with the display driver you’re using. It is possible that
there are incompatibilities with some display modes but not

others. To test this, try using drivers for other supported display
modes. For example, you may solve the problem by using the 16-
color display mode instead of the 256-color mode. For

information about the most current release of your display
driver, contact the display card manufacturer.

Optimizing performance
There are many factors that can affect the performance of a software
application. Large file sizes and faulty system configuration are the
most common factors. The following sections describe several ways

you can optimize performance in Visio.

Check your system first

If Visio’s performance is less than optimal, the first thing to check is
your system. At a minimum, Visio requires a 386-based computer

with 4MB of RAM running at 25 Mhz, and a VGA graphics card and
monitor. Like other applications, Visio performs better on a system
with a faster processor (for example, a 486-based computer running

at 66 Mhz), additional memory, and a faster graphics card.

Tip: Although a math coprocessor is not required to run Visio, it can
improve performance.
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Streamline your drawings

If your system meets the minimal requirements outlined in the pre-

vious section, try using the following techniques to reduce file size
and increase on-screen performance:

• Save files in Visio 3.0 format. Visio 3.0 creates smaller files than
earlier versions of Visio. Smaller files require less time to open
and less disk space. For details about saving files in the Visio 3.0

format, see Chapter 1, “Getting started with Visio.”

• Use master shapes instead of custom shapes. Drawings that use

master shapes require less disk space than custom shapes. If you
find you use custom shapes frequently (whether you draw them
or copy them from another application), save those shapes as

master shapes on a stencil instead of creating and duplicating
custom shapes within a drawing. For details about creating
master shapes, see Chapter 6, “Creating masters, stencils,

templates, and styles.”

• Avoid creating groups within groups. Creating groups within

groups can quickly increase file size and the time it takes to draw
the shapes on the screen. If you create small groups in the
process of creating a complex shape, it’s best to ungroup the

small groups before you group all the shapes into a large group.

• Convert complex shapes to Windows metafiles. If you plan to
change only the size or position of a complex shape (and not

edit its color, text, lines, and so on), consider converting the
shape to a Windows metafile to speed up the time it takes to
redraw the image on the screen and to reduce the file size. To do

so, select the shape, choose Copy from the Edit menu, and then
choose Paste Special from the Edit menu. In the Paste Special
dialog box, choose Windows Metafile from the As list, and then

choose OK

• Use styles instead of local formatting. When you use styles, Visio

stores only a reference to the style. When you use local format-
ting, Visio stores information about the individual attributes of
each shape. For details about styles and local formatting, see

Chapter 3, “Creating shapes.”



          

• Delete styles and master shapes you don’t use. The less the file

contains, the smaller the file. For details about deleting these
items, see Chapter 6, “Creating masters, stencils, templates, and
styles.”

• Add only the connection points you need. Fewer connection
points means fewer lines in the ShapeSheet, which means a
smaller file size. For details about adding connection points, see

Chapter 2, “Adding, arranging, and connecting shapes.”

• Close extra stencils before you save a drawing. For details about

saving drawing and workspace files, see Chapter 1, “Getting
started with Visio.”

For a comprehensive list of optimizing techniques, call the Fax Infor-
mation System. For details, see “Getting more information from
Shapeware” earlier in this appendix.

OLE-related errors

Object linking and embedding (OLE) is a feature of the Windows

operating system that is used by many applications to facilitate data
exchange. Windows keeps track of the OLE capabilities of each of
your OLE applications in the REG.DAT file. Applications must register

information in the Windows REG.DAT file in order to perform OLE-
related tasks such as linking and embedding. If an application is not
properly registered when you attempt to use it, Windows displays an

error message. For example, when you double-click a Visio object
embedded in another application when Visio is not properly regis-
tered, Windows may display a message saying that it cannot find the

source application or that OLE is not registered properly.

Some registration errors occur when Visio is improperly registered in

the REG.DAT file. You can register Visio manually using the following
procedure.
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To manually register Visio:

1. In Windows Program Manager, choose Run from the File menu.

2. In the Run dialog box, type the Visio path and command line
followed by /r. For example:

c:\visio\visio.exe /r

Visio starts and is registered in the REG.DAT file.

For details about copying and pasting information between Visio
and other applications and about using OLE, see Chapter 7, “Using

Visio with other applications.” For additional information about
OLE, see the README.TXT file installed with Visio.

Exchanging data between applications

In general, the easiest and best way to exchange data between appli-
cations is to use OLE, which is often as simple as choosing Copy in

one application, switching to the other application, and then choos-
ing Paste. There may be times, however, when you need to use

import or export filters that come with Visio to exchange data be-
tween applications. For example, you may need to import a piece of
clip art into your drawing. The following section contains guidelines

for making importing and exporting successful.

Importing and exporting tips

Like most other applications, Visio uses filters when you import or
export data. Filters translate files from one format to another. Precise

translation from one graphic language to another is not always pos-
sible. Lines, fills, text, and colors often look different or may not
appear at all in some file formats. Fonts may not be translated and

sizes may be altered in translation. Precision in translation depends
mainly on three factors: the quality of the translation made by the
export filter, the format used for the exported data (some are better

than others), and the quality of the import filter’s interpretation.
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Visio is a vector-based application, which means importing and ex-

porting files that are written in vector-based formats usually
produces better, more flexible results. If you plan to use Visio shapes
or files in another application, check to see which formats the other

application reads. In general, Windows Metafile (.WMF) is the best
format to use when exchanging data between Visio and other Win-
dows applications.

General Protection Faults and related error messages

A General Protection Fault is a Windows 3.1 error that occurs when

two applications try to use the same bit of memory to look up or
store information. (Later versions of Windows may display errors
with different wording, but the cause is the same.)

When you get a General Protection Fault or related error while
using Visio:

1. Write down what you were doing when the error occurred.

2. Write down the full error message, including the module name
and address.

3. Exit Windows and restart your computer.

4. Restart Windows.

5. Press Ctrl+Esc to display the Windows Task List and close any

applications that are loaded automatically when you start
Windows (except Windows Program Manager).

6. Open Visio and try to reproduce the General Protection Fault by
re-creating the situation that caused the error.

If you cannot reproduce the error, the General Protection Fault

may have resulted from low system resources, which are replen-
ished when you restart your computer.



               

If you can reproduce the error, the information you gather by

following this procedure may help the support technician
isolate the problem more quickly.

For additional suggestions, see your Windows documentation.

Adjusting settings in the VISIO.INI file
The VISIO.INI file contains several settings that you can adjust to ac-

commodate your own work style. To adjust the settings, you need to
edit the VISIO.INI file.

To edit the VISIO.INI file:

1. Close Visio.

2. In the Windows Main program group, double-click the File
Manager icon.

3. In the Visio directory, locate the VISIO.INI file.

4. Double-click the filename to open the VISIO.INI file in Notepad.

5. Locate the setting you want to edit.

6. Change the setting.

7. Save the changes to the VISIO.INI file and close Notepad.

8. Start Visio.

The new settings take effect immediately.
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Making items more visible on screen

If you are using Visio with a gray-scale monitor or have difficulty see-

ing some items on your color screen, you may want to adjust some of
the settings in the [color] section of the VISIO.INI file.

The table below shows the default values for each setting. The values
that follow the setting’s name represent red, green, and blue, respec-
tively. For example, with the ColorStencilBackground setting, the

default value for red is 128; for green, 255; and for blue, 128. The val-
ues 0 0 0 represent black and 255 255 255 represent white.

To modify Change this setting

Stencil window color ColorStencilBackground=128 255 128

Major grid line color ColorGridMajor=80 80 80

Minor grid line color ColorGridMinor=192 192 192

Adjusting the size of the stencil window

In some cases, the Visio stencil window may be too small to display
all of the master shape icons completely. To adjust the width of the

window, modify the value of the following setting in the [applica-
tion] section of the VISIO.INI file:

TileStencilWindowWidth=172

The value 172 represents the width (in screen pixels) of the stencil

window, including the scroll bar, when tiled. To increase the width of
the window, increase the value of the setting.
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Adjusting the size of the Visio window for in-place editing

To change the default size of the Visio window that appears when you

edit in place, adjust these settings in the [application] section of the
VISIO.INI file:

InPlaceWidth=5.5in

InPlaceHeight=3.0 in

 Changing the way you edit embedded Visio objects

To switch between in-place editing and working in the full Visio win-
dow when creating an embedded Visio object, change the value of

the following setting in the [application] section of the VISIO.INI file:

EditInPlaceOnInsertObject=1

There are two possible values:

1 The default. Enter this value to create an embedded Visio object
in place (if the container application supports in-place editing).

0 Enter this value to open a full Visio window when creating an

embedded Visio object.

 Adjusting the number of undo actions

The setting that controls the number of consecutive actions you can
reverse using the Undo command is:

MaxUndo=10

This setting is in the [document] section of the VISIO.INI file. Ten is
the default value. A higher value may require more memory, but will
let you undo more actions. A lower value requires less memory.



Glossary

Alignment box. The rectangle that appears around shapes and ob-
jects from other applications as you move them. This rectangle is

used for aligning and distributing shapes and objects from other ap-
plications. See also selection rectangle.

Attribute. An individual formatting element—such as line color, fill
color, and line weight—that you can apply to shapes. A style can have
several attributes. See also format, style.

Background. A page that can be assigned to another page to create
multiple layers in a drawing. You can see shapes on a background

when the page it is assigned to is displayed, but you can’t select or
change any of the background’s shapes without displaying the back-
ground page. You can assign the same background to more than one

page. A background can also have a background. See also foreground.

Bitmap. An image stored as a pattern of dots. A scanned photograph
or graphic you create in a paint program is usually stored as a
bitmap.

Center of rotation. The point around which a shape or text block
moves when you rotate the shape. When you select a shape with the

rotation tool, its center of rotation is marked by a circle with a plus
sign inside it. Initially, the center of rotation is in the center of the
shape. You can move the center of rotation by dragging it with the

rotation tool.

Clipboard. A temporary storage location in Windows that is used to

transfer data between documents and applications. You can use the
Clipboard to copy text and shapes between drawings in Visio or be-
tween Visio and other Windows applications.



       

Connection point. A point on a shape where a connector can be

glued to the shape. Any vertex and most handles can be connection
points. You can also create connection points inside, outside, or on
the boundary of a shape by using the connection point tool. Gluing a

connector to a shape automatically defines a connection point in the
shape’s ShapeSheet. You can also define connection points directly in
the ShapeSheet. Once defined, each of a shape’s connection points is

marked with a blue X when Connection Points is checked on the
View menu.

Connector. Any one-dimensional shape that can be glued between
two shapes in a drawing to connect the shapes. Some master shapes
are connectors. You can also use lines and other shapes you draw as

connectors. See also SmartConnector, Universal connector.

Control handle. A handle that makes shapes behave in special ways.

For example, you might use a control handle to adjust the roundness
of a shape’s corners, to reshape an arrow, or to drag a connector
shape directly out of another shape. How a control handle changes a

shape is programmed in the Controls section of its ShapeSheet.

Control point. The circle that appears on a line or an arc (or a line or

an arc segment) when the line or arc is selected with the pencil tool.
You can drag a control point to change the curvature of an arc or
ellipse.

Coordinates. A pair of numbers that specifies the distance of a point
from the origin of a shape, a group, or the page. The x-coordinate

specifies the horizontal distance and the y-coordinate specifies the
vertical distance. See also origin.

Crop. To reduce or expand an object from another application used
in a Visio drawing without changing the size of the image within its
borders. Cropping an object can give the visual effect of clipping

parts of the object, except Visio doesn’t discard any part of the object.
You crop an object by selecting it with the crop tool and dragging
one of its handles.
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Drag and drop drawing. To create an instance of a master shape in a

drawing by dragging the master shape from a stencil into the draw-
ing. To drag a master shape, point to it with the mouse, hold down
the left mouse button, and then move the mouse until the shape is

where you want it in the drawing. To drop the shape, release the
mouse button.

Drawing. All the shapes on a foreground page and any backgrounds
associated with the foreground page.

Drawing file. A Visio file that contains one or more drawings. You
can create a new drawing file by using the New command from the
File menu. A drawing file can be based on a template. Every drawing

file also has its own stencil, which contains an inventory of all the
master shapes used in all of the drawings in the file. See also template.

Drawing file stencil. A stencil stored in a drawing file, which contains
an inventory of the master shapes used in the drawings in the file.
Master shapes on the drawing file stencil are linked to their instances

in the drawings. To display the drawing file stencil for the current
drawing file, choose Show Master Shapes from the Window menu.
See also stand-alone stencil, stencil.

Dynamic glue. A type of glue that allows the endpoint of a connector
shape to move from one connection point to another as the con-

nected shapes are moved. (When dynamic glue is not used, the
endpoints of the connector are attached to specific connection
points. When the connected shapes are moved, the connector

changes shape to avoid crossing over the shapes.)

Eccentricity handle. The circle that appears at each end of a dotted

line when a control point of an elliptical arc is selected with the pen-
cil tool. You can drag eccentricity handles to change the angle and
magnitude of an arc’s eccentricity.

Endpoint. One of the square handles that appear at the beginning or
end of a selected line, arc, or other one-dimensional shape. The end-

point at the beginning of the shape (beginning point) is marked by
an X. The endpoint at the end of the shape (ending point) is marked
by a plus sign (+). See also vertex.
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Field. A placeholder in a text block that displays dynamic informa-

tion such as a dimension, date, or time. A field might display the date
and time a drawing is printed, a shape’s angle of rotation, or the re-
sult of a formula you define.

Fill. The color and pattern inside a closed shape. Visio’s default fill is
solid white.

Foreground. A page on the topmost layer of a drawing. Shapes on
the foreground are not visible when a background is displayed. See

also background.

Format. To affect the visual appearance of a shape—for example the

thickness and color of its lines, the color and pattern inside the
shape, and its font—either by using a style or by applying individual
attributes. See also attribute, style.

Glue. A property of shapes that causes them to stay connected, even
when a shape that was glued to is moved. See also dynamic glue.

Grid lines. The faint vertical and horizontal lines that appear in the
drawing window when the grid is turned on. You can use grid lines

to help position shapes precisely.

Group. A shape that is composed of other shapes. A group can also

include other groups and objects from other applications. A group
can be moved and sized as a single shape, but its members retain
their original appearance and properties. A group’s members can be

modified individually by selecting the group and choosing Open
Group from the Edit menu to display the group in a drawing
window.

Guide. A reference line that is dragged into the drawing window to
help position shapes precisely. A horizontal guide is dragged from

the top ruler, a vertical guide from the left ruler, and a guide point
from the upper-left corner of the drawing window where the rulers
meet.
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Handle. A control that appears on a selected shape. You can use a

handle to alter a shape. Handles differ depending on the type of
shape and the tool you use to select it. For example, when you select
a shape with the pointer tool, it displays selection handles you can

drag to change the shape’s size and proportions. When you select a
shape with the rotation tool, it displays rotation handles you can
drag to rotate the shape. See also control handle, eccentricity handle,

rotation handle, selection handle.

Instance. A “copy” of a master shape you create by dragging the mas-

ter shape from a stencil into a drawing. An instance is more than just
a copy: when the first instance of a particular master shape is created
in a drawing file, Visio adds a copy of the master shape to the draw-

ing file stencil. Instances of the master shape are linked to the master
shape in the drawing file stencil. If you change the master in the
drawing file stencil, all of its instances inherit those changes.

Link. To establish a dynamic connection between an object in a Visio
drawing and another application’s file by using the object linking and

embedding (OLE) protocol. When the original file changes, the most
current version of the object appears in the drawing. Link also refers
to the connection between a master shape in a drawing file stencil

and instances of it in a drawing. Changes made to the master in the
drawing file stencil are inherited by its instances.

Master shape. A shape in a stencil. You drag and drop a master shape
from a stencil into a drawing to create an instance of the master
shape. Many of the master shapes in the stencils provided with Visio

are SmartShapes—shapes with programming that controls how the
shape behaves when it is moved or sized.

Object. A Visio shape or material created in another application and
imported, embedded, or linked in a Visio drawing.

Object linking and embedding (OLE). A Windows protocol that
makes it possible to embed an object created in one Windows appli-
cation into a document created in a different Windows application,

or to link an object to a file that contains the original object.
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One-dimensional shape. A shape that can be sized or rotated by its

endpoints and that does not have corner selection handles. A single
line or arc is one-dimensional when you first draw it. Connectors on
stencils are also one-dimensional. You can define any shape as one-

dimensional. A one-dimensional shape has a beginning point and an
ending point and can be glued between other shapes to connect
them.

Origin. The lower-left corner of the selection rectangle of a shape, a
group, or the drawing page. The x- and y-coordinates of the origin

are always 0,0. Dimensions of a shape such as its width, height, and
center of rotation are measured from its origin. The location of a
shape in relation to its parent (a group or the page) is measured from

the parent’s origin. See also coordinates.

Page. The area in the drawing window that contains a drawing. A

page can be either a foreground or a background. The size of a page
usually corresponds to a standard paper size. A page also has a scale.
A drawing file can contain more than one page.

Pan. To shift text or graphic information from another application
within its borders in a Visio drawing.

Paste. To insert information from the Windows Clipboard into a Vi-
sio drawing or another Windows document.

Pasteboard. The area that surrounds a page in the drawing window.
You can store shapes on the pasteboard. Each page has its own paste-

board.

Path. A series of contiguous line or arc segments in a shape. A shape

can have more than one path. For example, a shape with an interior
hole has two paths: one that describes its outside perimeter and an-
other that describes the perimeter of its interior hole. See also

segment.

Pixel. An individual block of display information. The term pixel is

derived from the phrase “picture element.”
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Rotation handle. One of the round handles that appear at a corner of

a shape’s selection rectangle when you select the shape with the rota-
tion tool.

Scale. A measure of the relationship between actual distances and
those distances as they are represented in a Visio drawing. For ex-
ample, a floor plan might have a scale of one foot of actual distance to

one inch in the drawing.

Segment. A line or arc that is part of a more complex shape. See

also path.

Selection. Shapes in a drawing or text in a text block that are the tar-

get of your next action. Selected shapes display handles. Selected text
is highlighted.

Selection handle. One of the square handles that appear on a shape
selected with the pointer tool. Selection handles indicate that you can
size or move the shape. See also handle.

Selection net. A means of selecting shapes by dragging the pointer
tool over a rectangular area.

Selection rectangle. The dotted line that surrounds selected shapes or
objects from other applications. See also alignment box.

Shape. A line, arc, ellipse, or rectangle; a closed or open series of line
and arc segments; or a group. You create a shape by dragging a master

shape from a stencil into a drawing, by using Visio’s drawing tools, by
copying shapes, by grouping shapes, or by converting an object from
another application. See also group.

ShapeSheet. The spreadsheet that contains information about a
shape, such as its dimensions, its angle and center of rotation, and the

styles that determine the shape’s appearance. ShapeSheets can con-
tain formulas that define how the shape behaves when it is moved or
sized.
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Size. To change the dimensions of a shape by dragging one of its

handles after it has been selected with the pointer tool.

SmartShape. A shape that is programmed to behave correctly when

you move or size it, usually by means of formulas in the shape’s
ShapeSheet. See also SmartConnector.

SmartConnector. A connector shape in a Visio stencil. Smart-
Connectors are programmed to behave intelligently when the shapes
they connect are moved. See also connector, Universal connector.

Snap. The ability of guides, grid lines, and other elements in Visio to
pull shapes toward them when the shapes are moved and sized.

Stacking order. The front to back relationship of shapes on a drawing
page. The first shape added to the page is behind all shapes added to

the page after it. You can change the stacking order of shapes by using
the Bring Forward, Send Backward, Bring To Front, and Send To
Back commands on the Shape menu.

Stamp. To create an instance of a master shape with the rubberstamp
tool. To stamp a master shape, select the master shape in the stencil,

choose the rubberstamp tool, and click where you want the instance
to appear. To glue a connector with the rubberstamp tool, select the
connector in the stencil, and then drag between connection points

on the shapes you want to connect.

Stand-alone stencil. A Visio file with a .VSS filename extension that

contains master shapes and is usually referred to simply as a stencil.
Unlike a drawing file stencil, a stand-alone stencil’s master shapes are
not linked to instances of masters in a drawing. See also stencil, draw-

ing file stencil.

Status bar. The area at the bottom of the Visio window that displays

helpful prompts, information about the location, size, and angle of
the selected shape, the magnification of the view, and Visio’s current
status. When the Visio standard or Lotus SmartSuite toolbar and

menu set is displayed, the status bar also contains style lists. When
Visio’s Microsoft Office toolbar and menu set is displayed, style lists
appear in the toolbar. See also toolbar.
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Stencil. A collection of master shapes you can drag and drop into a

drawing. Stencils are stored in stencil files, which are opened auto-
matically when you create a new drawing based on the stencil’s
associated template. You can also open a stencil file independently of

a template. Each drawing file also has its own stencil (known as a
drawing file stencil), which contains an inventory of the master
shapes used in the drawings in that drawing file. See also drawing file

stencil, stand-alone stencil, template.

Style. A collection of attributes that has a name and is saved with a

template or drawing file. You can use a style to apply a predefined set
of attributes to a shape with a single action. Many of Visio’s templates
contain styles. See also attribute.

Subdivision. The division between grid lines and between ruler in-
tervals. This option is set using the Page Setup Options dialog box.

The choices are Fine, Normal, and Coarse.

Template. A Visio file that contains styles and settings for a particular

kind of drawing (for example, the appropriate scale and grid) and
that can open one or more stencils. You can create a new drawing
with a template’s styles and settings by opening the template. See

also stencil.

Text block. The text area associated with a shape that appears when

you click the shape with the text tool or the text block tool, or when
you select the shape and start typing. You can size a text block and
move a text block in relation to its shape.

Tile. A command on the Window menu that arranges open windows
side by side in the Visio main window. Also, a printing technique

whereby oversized drawing pages are printed on multiple sheets of
paper. Each individual page is a tile.

Toolbar. The row of boxes, buttons, and tools that appears below the
menu bar in the Visio window. In the toolbar, you turn options such
as snap and glue on and off and choose tools to create and modify

shapes. The Visio main window, the stencil window, and the
ShapeSheet window all have specialized toolbars.
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Two-dimensional shape. A shape that has corner selection handles

which you can use to size the shape proportionately. You can define
any shape as two-dimensional. Most rectangles, ellipses, and free-
form shapes are defined as two-dimensional. See also one-

dimensional shape.

Units of measure. The type of measurement system used in a draw-

ing. You specify the units of measure (inches, feet, miles, points,
meters, and so on) in the Page Setup or New Page dialog box.

Universal connector. A master shape that is programmed to connect
any two points without crossing over the shapes it connects. By de-
fault, an instance of the Universal connector is created when you use

the connector tool and the Connect Shapes command. See also con-
nector, SmartConnector.

Vertex. One of the diamond-shaped handles that appear between
two segments or at the end of a segment when you select a multiple-
segment shape with the pencil tool. You can reshape a shape by drag-

ging its vertices. See also endpoint.

Workspace. A Visio file that contains information about the size and

position of drawing and stencil windows at the time you save the
workspace. When you open a workspace, Visio re-creates the ar-
rangement of stencil and drawing windows for you. You can store a

workspace within a drawing file or save a workspace as a workspace
(.VSW) file.

Zoom. To increase or decrease the display size of a drawing in the
drawing window. A display size of 100% displays the drawing in the
same size it will be when it is printed, unless you reduce or enlarge

the printed output in the Print Setup dialog box.



Index
[ ]  (brackets) on filenames  31, 239
=  (equal sign)  302, 315
=  (equal sign) and arrow pointer  270
-  (minus sign) in formulas  316
-  (minus sign) pointers  313, 354
+  (plus sign)

ending points  52
in ShapeSheets  316

+  (plus sign) pointers  270, 313, 352, 353, 354
1-D Endpoints section in ShapeSheet  302
1-dimensional shapes. See one-dimensional shapes
2-dimensional shapes. See two-dimensional shapes
16-color display mode  362
50%–400% views. See viewing
256-color display mode  362

actions, double-click  135, 162–163, 171, 328–329
activating menu bars  347
Actual Size command  39, 344
adding

dimension lines to shapes  186–188
fields to shapes  183–188
glued shapes and guides to a group  136
group text blocks  133
guides and guide points  72–75
pages  192–193
segments to shapes  106–108, 113–114
shadows  150–152
shapes

by stamping  124
to drawings  51, 54–57
to groups  133–134

text  133, 167–188
vertices  113–114

add-ons, running  163, 328–329
Adobe Illustrator files (.AI)  282, 285
Align Shapes button and command  33, 70–71, 347
aligning

function key shortcut  347
group selection rectangles  134
master shape names under icons  230
paragraphs in text blocks  179, 180–181, 182–183
shapes  59, 70–75

diagonally  72
distributing across page  77–78
with guides  72–75
with rulers or grid lines  66
with snap  67–68

ShapeSheet alignment information  301
alignment boxes (selection rectangles)  64, 134, 371
alignment buttons  35, 71, 178, 334–335
Alignment section in ShapeSheet  302
alternate toolbars. See toolbars
American National Standards Institute character set  174,

348–350
Angle text fields  183
angles

in ShapeSheet formulas  297, 300, 316

angles (continued)
of eccentricity  119–120
of rotation

displaying in status bar  64
displaying in text fields  184, 344
locking angles of shape segments  162
two-dimensional shapes  157

of shadows  151–152
ANSI extended characters  174, 348–350
applying

alignment formatting to paragraphs  179, 181, 182–183
colors to fills, shadows, or objects  150, 289
fill formatting  139, 144, 146
formatting with shortcuts  139–141
line formatting  139–141, 144, 145, 148–149, 289
local formatting  139, 142, 147, 253
paragraph formatting  147, 179, 180–183
pattern formatting  150, 289
styles  139–140, 142–147

changed styles  253
fill, line, or text attributes  144–147
from style lists  139–140

tab formatting  147, 181–182
text formatting  139–141, 144, 145, 178–183

arc pointer  105, 352
arc tool  337

displaying vertices  52
drawing arcs and shapes  104–106
shortcut for choosing  344

architectural drawing scale  211–212
See also drawing scale

arcs
changing with control points  53, 106, 116–120
drawing with pencil or arc tool  9, 104–106
eccentricity  105, 118–120
formatting lines, weights, and ends  148–149
reshaping bow  116–120
ShapeSheet information  301

arguments pasted into formulas  318–319
Arrange Icons button and command  36, 230, 233, 242, 340
arrow key navigation in ShapeSheets  311–312
arrow pointers  61, 66, 270, 352, 353
arrows and arrowheads

applying arrowheads to lines  140, 149
connectors  96–98
preserving formatting  144
ShapeSheet formulas  304–310
ShapeSheet information  301

art, clip  10
art gallery  12–15
aspect ratio of shapes, locking  162
attributes  371

applying formatting to shapes  138–139
all attributes in a style  144
local formatting  142
specific attributes in a style  145–146
with styles  139–140, 142–147

defining in styles  250–251
default attributes  252
limiting styles to one attribute  143
styles based on other styles  143

Auto Arrange command  233, 242
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AutoCAD Drawing Interchange Format (.DXF)  282, 285
automatically updating links  278
automatically updating master shape icons  231, 234
automating tasks with programs  326–327
Automation, OLE  326

background colors  150
in monochrome printing  222
of text blocks  179
retaining imported file colors  284
ShapeSheet information  301

background fill and shadow options  150
background pages  192, 198–204, 371

See also foreground pages; pages
assigning or canceling assignments  203
creating  202
deleting  196, 203
differing page size and scale  201–202, 210, 212
printing  213, 215
protecting  249

backslash characters  348
Based On options for files  25–27, 244
Based On options for styles  143, 254
baseline position of text  180, 301, 345

See also subscripted text; superscripted text
basing

drawing files on templates or stencils  24–25
new files on templates or stencils  25–27
new stencils on existing ones  243–244
styles on existing ones  143, 254

Begin, Length, Angle options  154–155
Begin And End Points options  154, 155–156
Begin arrow options  149
Begin X or Begin Y options  154–155
beginning points  52

See also endpoints; one-dimensional shapes
arrowheads  97–98
coordinates in ShapeSheets  302
locking in place  162
specifying location  154–156

behavior  160–161
associating programs with shapes  328–329
changing by editing ShapeSheet formulas  297
double-click behavior  135, 162–163, 171, 328–329
identifying master shapes with special behaviors  58
locking and unlocking shapes  161–162
non-printing shapes  214
resizing groups  136–138
shape handle display settings  141
switching between one- and two-dimensional behavior

160–161
Behavior command and dialog box  137, 138, 141, 160–161,

214
bitmaps  371

converting to segmented objects  290
exporting drawings as  285
importing into drawings  281, 282
pasting into Visio  273, 281
rotation disabled  136
Windows Bitmap (.BMP)  281, 282, 285
Windows Device-independent Bitmap (.DIB or .BMP)

281, 282, 285

black arrow pointer  61, 66
black text in ShapeSheets  320
black-and-white negative effects, importing objects with  284
black-and-white printers, printing color to  222–223
blank master shape icons  228, 232
blue crossbar guide points  74
blue selection handles  61

See also selection order
blue text in ShapeSheets  320
blue X marks  53

See also connection points
.BMP file format  281, 282, 285

See also bitmaps
Bold button  35, 178, 338
bold text formatting  140, 345
borders

around glued endpoints  82
creating with multiple copies of shapes  123
on exported objects  266–267
on imported objects  287, 288

Bottom Align button and option  70, 335
Bottom Align Text button  35, 178, 339
Bottom Distribution option  78
bowing lines into arcs  116–117
bows of arcs  117
Box (2-dimensional) interaction style  160
boxes  109–110

See also shapes; two-dimensional shapes
brackets ([ ]) on filenames  31, 239
breaking

glue  91–92
links to other files  279, 290
pages  218–219
shapes apart. See fragmenting shapes; Ungroup

command
Bring Forward and Bring To Front commands  62, 344
Browse button  16, 31
bullets  348
bull’s eye pointer  352
buttons  333–342

See also toolbars; tools
applying formatting  139, 140–141, 142
cycling through formatting choices  141
differences in screen toolbar display  17
Microsoft Office and Lotus SmartSuite differences  17
missing on toolbars  17, 32–33
Open button  28
Windows for Workgroups dialog box buttons  16

callout lines  79
Cancel box  317
canceling

alignment selections  71
background page assignments  203
links to other files  279, 290
quitting actions  47
removing shapes from groups  133–134
shape selections  60

Cascade button and command  36, 40, 340, 347
case of text  180, 301, 345
categories of fields  184–185
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cell references
in ShapeSheets  302, 307, 316
pasting names into formulas  318–319

cells, ShapeSheet  297
copying and pasting formulas  318–320
displaying values or formulas  312
hiding  312–313
navigating through  311–312
pasting names into formulas  318–319
referring to in formulas  302, 307, 316
selecting  311
updating automatically  303

Center Align Text button  35, 178, 338
Center Drawing command  76, 219
center of rotation  64, 65, 371

See also rotating
coordinates  157, 158–159
ShapeSheet information  297, 300

center of rotation pointer  352
centering

drawings on pages  76
shapes horizontally and vertically  71

.CGM file format  282, 285
Change Source dialog box  278
Character Format section in ShapeSheet  301
characters

See also text; text blocks
formatting  177–180
selecting  173, 318
ShapeSheet information  301
typing special characters  174, 348–350

check marks on menus  41
ciceros  304
circles  109–110
circular arcs  104–105

See also arcs
circular arrows pointer  352
Clear command  73, 94, 126, 242
client applications. See OLE (object linking and embedding)
clip art  10
Clipboard  372

copying shapes and drawings  125
cutting shapes  126
during dragging and dropping to other applications  268
embedding shapes in another document  264
linking objects  272
pasting

compared to importing  281
data into Visio files  273
text into shapes  169

cloning. See copying; duplicating shapes
Close command  47, 299
closed shapes  102, 107–108

See also shapes; two-dimensional shapes
closing

files  47
group drawing window  135
master shape drawing window  240
print preview window  218
ShapeSheets  299
Visio  47
windows  47

CMC protocol  261, 291
code. See programming Visio
collapsing ShapeSheet sections  312–313
collating printed pages  214
collections of shapes. See stencils
color

adjusting Visio color settings  368
applying to imported objects  289
display problems  361–362
editing master shape icon pixels  236–237
fill and shadow colors  139, 150, 301
importing or exporting graphic file colors  284, 365
line color  139, 301
palettes. See color palettes
printing to monochrome printers  222–223
ShapeSheet text  320
solid and gray patterns  222–223
specifying in ShapeSheet formulas  316
text  140, 147, 180, 301
text block backgrounds  149
window background color  231

Color As Black printing option  222
color boxes  236–237
Color Palette command and dialog box  255
color palettes  255

for master shape icons  236
saving settings as a template  247
using grays  222

Combine command  131
combining shapes  127, 128–129

See also groups; uniting shapes
by uniting  127–128
with rounded corners  148

commands  17
See also the Visio online help
editing OLE objects  275–276
programming Visio  10
quick display of common commands  38–39
shortcuts for choosing  194, 344–345, 346–347
switching menu sets  11, 32, 37–38

Common Messaging Call (CMC)  261, 291
compiling programs  327
complex shapes, creating  127–131
compound files  44
Computer Graphics Metafile (.CGM)  282, 285

See also metafiles
configuration, optimizing  362
Connect Shapes button and command  33, 81, 89–90, 336
connecting shapes. See connection points; glue; groups
connection point tool  93, 337, 344
connection points  53, 372

See also glue
adding or deleting  93–94
displaying  41, 95
dynamic glue  6
optimizing shape performance  364
ShapeSheet information  301
snapping to  68

Connection Points command  41, 95
Connection Points section in ShapeSheet  301
connection tool menu  33
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connector tool  337
connecting shapes while drawing  83–84
gluing connectors  81
shortcut for choosing  344

connectors  372
adding text  96
adjusting bends  95
arrowheads  96–98
connecting existing shapes  85–86, 89–91
connecting specific points on shapes  88–89
connecting techniques  78–79
creating with control handles  53, 86–87, 120-121
dragging and dropping connectors  56–57
dragging from control handles  53, 120–121
gluing  81
identifying master shape icons  58
moving around perimeters of shapes  81–83
SmartConnectors  5–6, 11, 79–80
using dynamic glue  81–83

constraining
lines to 45-degree angles  108
shapes to squares or circles  110

container applications  264
control handles  53, 120–121, 372

adding in ShapeSheet  310
adjusting connector bends  95
adjusting SmartConnectors  80
behavior of control handle shapes  161
connecting chart elements with  86–87
identifying master shape icons  58
ShapeSheet information  302

control points  8, 372
displaying  53, 106
in segmented shapes  107
magenta  118, 119
reshaping arcs and lines  53, 116–120

Control-menu box  47, 135, 240, 299
Controls section in ShapeSheet  302
Convert command  289–290
Convert To Group command  290
converting

files to other formats  261
objects to shapes or other formats  271, 289–291
one- to two-dimensional shapes  160–161
shapes to metafiles  363

coordinates  372
center of rotation  159
in arrowhead formulas  305–310
in proportional resizing formulas  305
locking shapes in position  162
one-dimensional shapes  153–156, 302
origins  296, 304, 376
ShapeSheet information  301
two-dimensional shapes  157–158
vertices  296, 297, 304

copies
of files  29, 31, 242
of master shapes. See instances

Copy button and command  36, 339
copying shapes  125
copying text  173
embedding shapes  265

Copy button and command (continued)
linking data into Visio  272
shortcut for  344
using in ShapeSheet cells  320

Copy Drawing command  266
copying

See also embedding; linking
color palettes from another file  255
comparing methods of importing  260–261
formulas into cells  319–320
master shapes to another stencil  246
OLE objects  272
pixels in edit icon window  237
shapes  121–126, 268–270
stencils  243–244
text  173

copyright symbols  348
corner selection handles. See selection handles
Corners button and command  33, 141, 149, 336
corners on shapes  127, 148–149
correcting mistakes. See canceling; restoring; Undo button

and command; undoing
Create From File option  275
Create Guide And Glue Shapes To It option  71
Create New option  275
creation dates, displaying in text fields  184
creators of files

displaying in text fields  184
including in summary info  46

crop tool  288, 337
crop tool pointer  353
cropping  288, 373
crossbar guide points. See guide points
crossbar pointers  313, 352, 353, 354
cursors  204, 270, 351–354

See also names of pointers
curved lines or curves. See arcs
Custom Formula fields  184, 185
customer service. See the Visio online help
customizing

drawing scales  211–213
master shape icons  231, 235–237
master shapes in stencils  239–241
page names  193, 195
page sizes  209–211
stencils or templates  243–249

Cut button and command  36, 339
cutting and pasting shapes  126
cutting icon pixels  237
cutting text  173
deleting master shapes  242
shortcuts for choosing  344

cutouts in shapes  127, 128–129
See also combining shapes

cutting
guides and guide points  73, 74
holes in shapes  127, 128–129

See also combining shapes
icon pixels  237
master shapes  241–242
OLE objects  273
shapes  126, 268–270
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cutting (continued)
text  173

cycling through formatting choices  141

dashed lines  44, 148
dashes  348
Data fields  184
date functions in ShapeSheet formulas  302
Date/Time fields  7, 184
Decrease Font Size button  33, 35, 336
defaults

arrow formulas  304–305
color palettes  255
drawing size, paper size, and scale  205
new master shape names  230
page names  193, 195
read-only files  31
ShapeSheet formulas  303
ShapeSheet units of measure  316
text, line, or fill attributes  252

Define Styles dialog box  251–255
degrees  64, 304
Delete button  36, 339
Delete key  74
Delete Pages command and dialog box  196
Delete Row command  315
Delete Section command  314
deleting

characters in formulas  318
connection points  93–94
guide points  74
guides  73
icon pixels  237
local formulas  321
master shapes  241–242
non-consecutive pages  196
pages  196
segments of shapes  106, 108–109, 114–115
shadows  150
shapes  126, 268–270

from a group  133–134
preventing deletion  162

ShapeSheet rows or sections  314–315
styles  254
text  173
text fields  184
vertices  114–115

descriptions of files  46–47, 184
deselecting shapes  60
designed shapes  10–11, 378

See also master shapes; SmartShapes
device-independent bitmaps. See bitmaps; Windows Device-

independent Bitmaps (.DIB or .BMP)
diagonal alignment  72
dialog boxes

shortcuts for opening  194
Windows for Workgroups buttons  16

diamond-shaped handles. See vertices
.DIB file format  281, 282, 285
didots  304
dimensions

displaying in text fields  7, 183, 184

dimensions (continued)
displaying on lines  186–188
locking shape dimensions  162
ShapeSheet information  297
specifying exactly  156

directly formatting shapes. See formatting; local formatting
directories

changing directories  29
linked source files  263, 277
listing contents in VISIO.INI file  240
Visio Add-ons directory  328

disassembling groups. See Ungroup command
discretionary hyphens  348
disk space, reducing file size  363–364
Display As Icon option  289
display problems  361–362
displaying

alternate menu and tool sets  37–38
angle of rotation  64, 184
connection points  41, 95
control points  53, 106
dimensions  7, 183, 184, 186–188
drawing file stencils  241, 246
eccentricity handles  118
filenames  184
grids  41
guides  95
help  18, 346
information in text fields  7, 183–184, 186–188
line dimensions  183, 184, 186–188
Master menu  228
master shape icons  233
measurements  183
name of shape’s master  184
objects as icons  270–271, 289
page numbers  184
page setup information  184
page size  212
screen display differences  16, 17, 31–33, 333
shape height, width, or angle of rotation  184
ShapeSheet formulas  312
ShapeSheet sections  312–313
ShapeSheets  297–299
size of printed drawings  212
specific pages  30
summary file information  184
text toolbar  178
times or dates  7, 183, 184
values or formulas in cells  312
vertices  52

Distribute Shapes button  33
Distribute Shapes command and dialog box  78
distributing shapes  59, 77–78
distribution buttons  335
distribution options  78
dividing shapes. See fragmenting shapes
Doc Info command and dialog box  46

See also Summary Info command and dialog box
displaying information in text fields  184
exchanging data with Lotus Notes  280
prompting for information  43

Document Info fields  184
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documents. See drawing files; files; stencils;
templates; workspaces

DOS filenames. See filenames
DOS printing commands  224
Double-Click command and dialog box  163, 171, 328–329
double-clicking

groups to open group window  135
identifying master shapes with special behaviors  58
master shape icons  232, 242
master shapes to edit text  171
objects to edit  264
running Visio add-ons or programs  328–329
ShapeSheet behavior information  302
specifying double-click actions  162–163

double-headed arrow pointer  175, 352, 354
double-rectangle pointer  176, 353
drag and drop drawing  4, 54–57, 373

comparing methods of importing and exporting  261
connecting shapes  56–57, 83–84
dragging shapes to another application  264, 268–270
dragging shapes to another page  125–126
glued connections  81
shortcuts  268–270

drawing
arcs  104–106

changing shape of  116–120
circular or elliptical  104–106
control points  116–120

closed shapes  107–108
complex shapes  108
copying or duplicating shapes  121–126
drag and drop drawing  4, 54–57, 373
drawing tools  103–104
ellipses  109–110
file size with custom shapes  363
grouping and ungrouping shapes  132–138
lines  104–106

changing lines to arcs  116–117
constraining to 45-degree angles  108
control points  116–117

master shape icons  236–237
master shapes  231–232
pencil tool techniques  9
rectangles  109–110
segmented shapes  106–108

adding or deleting segments  113–115
changing angles of segments  112–113
undoing drawn segments  108–109

shapes with untouching paths  108
uniting, combining, and fragmenting shapes  127–131

drawing file stencils  58, 238, 241, 373
See also stand-alone stencils; stencils
deleting master shapes  241–242
saving as stand-alone stencil  245–246

drawing files  22–23, 373
advantages of using templates  26
background and foreground pages  192
breaking links to other files  279
centering drawings on pages  76
closing  47
copying shapes to another file or page  125–126
drawing file stencils. See drawing file stencils

drawing files (continued)
duplicated style names in shapes or files  144, 252
exporting drawings  281, 285–286
file formats  44
file size with embedded objects  263
filename extensions  25, 29
opening  21, 24–30

files with linked objects  277
with templates  5, 25–27
without templates  28

page size and scale  201–202, 205–213
previewing printed drawings  216–218
printing  213–224
printing names of each drawing and page  329–330
protecting  249
rearranging pages  195
saving  42–43, 245–246
saving as templates  247
styles  142–143, 144, 252
summary file information  46–47
turning pages  30, 125, 194
using master shapes in drawings  51

Drawing option  27
drawing pages. See drawings; pages
drawing scale  377

changing scale  211–213
compared to page and printed drawing size  211
defaults  205
designing for  243, 248
in templates  5, 23
pages with different drawing scales  201–202
using master shapes with scaled drawings  212

drawing tool menu  33, 103
drawing tools  9, 103–104, 108

See also tools
drawing windows  31–37

closing  47
edit icon window  235–237
group drawing window  134–135, 137
master shape drawing window  231–232
opening  194
pointer descriptions  352–354
scrolling  40, 346
viewing all open windows  194
viewing background and foreground pages simulta-

neously  203–204
drawings  373

See also drawing; drawing files; pages; printed drawings
adding shapes to  51
centering on page  219
closing stencils before saving files  364
deleting  196
displaying dates, measurements, or shape information

183
drawing scale  211–213
exporting  285–286
fitting on paper  218–219
foreground and background pages  192
gallery  12–15
linking or embedding into other applications  264–270
page or paper orientation  207, 210
page size  207–208, 209–211, 212
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drawings (continued)
previewing  216–218
printing names of each drawing  329–330
repeating shapes on several pages  199
streamlining and optimizing  363–364
viewing and editing in layers  198–204
working with shapes  59
working with text  167–188

drivers
display drivers  360–362
printer drivers  223, 357, 359

drop shadows. See shadows
dropping. See drag and drop drawing
.DRV extension  361
Duplicate command  122, 125, 344
duplicating shapes  121–126

See also copying
duplicating style names  144, 252
.DXF file format  282, 285
dynamic dimension lines  186–188
dynamic glue  6, 81–83, 373

connecting existing shapes  85–86, 89–91
connecting shapes while drawing  83–84
converting to solid connections  92–93
shapes saved in 2.0 version files  44

eccentricity  105, 118–120
eccentricity handles  118–120, 374
Edit Background and Edit Foreground commands  204
Edit Icon command  236
edit icon toolbar  341
edit icon window  235–237, 354
Edit Master command  232
Edit <OLE object> command  276
editing

background pages  203–204
formulas  315–321
imported objects  275–276
individual shapes in groups  134–136
instances by editing masters  58, 239
linked or embedded objects  262, 263
master shape icons  235–237
master shapes in stencils  239–241
protected master shapes  242
shapes  112–115

by editing masters  58, 239
in a group  133–136
shape segments  112–120
with Size & Position options  152–159

stencils  31, 239–242, 241
styles  142–143, 144, 253–254
templates  31, 249
text  171–174
Visio objects in other applications  267–268
VISIO.INI file  367–369

electronic mail file transmission  261, 291
ellipse pointer  352
ellipse tool  109, 337, 344
ellipses  109–110
elliptical arcs  104–105, 117

See also arcs
em dashes  348

Email file transmission  261, 291
embedding  262–264

See also OLE (object linking and embedding)
adding text to embedded objects  170
comparing methods of

importing and exporting  260–261
converting objects to shapes or other formats  261, 271,

279, 289–291
creating embedded objects  274–275
displaying embedded objects as icons  270–271, 274
dragging and dropping  268–270
editing and updating objects  267–268, 275–276
file size effects  263
objects into Visio files  270–276
pasting as particular format  273–274
switching between in-place and full-size windows  369
troubleshooting problems  364–365
Visio objects into other applications  264–269

empty formulas  321
Emulate Line Styles importing option  284
Encapsulated PostScript files (.EPS)  282, 285
End, Length, Angle options  154–155
End arrow options  149
End X or End Y options  154–155
ending points  52
endpoints  52, 374

See also lines; one-dimensional shapes
aligning with guide points  73
arrowheads  97–98
coordinates in ShapeSheets  302
formatting  149
gluing

connector endpoints  56–57
determining type of glue  82
moving glued shapes  91–92
to connection points  93
to shapes or guides  75

in segmented shapes  106
locking  162
magenta  112
red  75

See also glue
ShapeSheet information  302
specifying location  154–156

engineering drawing scale  211–212
See also drawing scale

enlarging drawings  220
enlarging shapes. See sizing
Enter box  317
entering formulas in ShapeSheets  315–321
entering text. See typing
.EPS file format  282, 285
equal sign (=) and arrow pointer  270
equal sign (=) in formulas  302, 315
error messages

diagnostic suggestions  366–367
display problems  361
OLE problems  364–365

errors in formulas  317
Esc key  317
Events section in ShapeSheet  302
examples of programs  329–330
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Exit command  47, 275, 346
exiting

in-place editing  268
Visio  47

expanding sections in ShapeSheets  312–313
exponential notation in ShapeSheets  316
export filters  261, 281
Export Picture command and dialog box  285–286
exporting

compared to OLE or pasting  260–261
data to or from Lotus Notes  279–280
drawings  281, 285–286
tips for exchanging data  365–366

extended character set  174, 348–350
extensions

.AI  282, 285

.BMP  281, 282, 285

.CGM  282, 285

.DIB  281, 282, 285

.DRV  361

.DXF  282, 285

.EPS  282, 285

.PCT  282, 285

.PCX  282, 285
saving files  42
.TIF  282, 285
.VSD  25, 29
.VSS  29, 238, 245, 246
.VST  28, 29, 248
.VSW  26, 29, 45, 46
.WMF  281, 282, 285

Fax Information System  356
fields  7–8, 183–188, 374

adding dimensions to lines  186–188
categories of  184–185
deleting  184
exchanging data with Lotus Notes  279–280
inserting into text blocks  183–188
ShapeSheet information  301

file creation dates, descriptions, and creators, displaying in
text fields  184

file extensions. See extensions
file formats  44

See also names of specific formats
converting objects to another file format  261, 289–290
exporting  281, 285
importing  281–282
pasting in particular formats  273–274
saving smaller files  363
saving stencils in 2.0 format  245
tips for exchanging data  365–366
Visio 2.0 and 3.0 file formats  43, 245, 363

file names. See filenames
file revision dates, displaying in text fields  184
file size

2.0 and 3.0 version files  44
reducing  363–364
with embedded objects  263
with large cropped images  288
with metafile shapes  291

file summary information  46–47, 243

File Type list  43, 246, 283
file types  22–23

See also names of specific file types
drawing file stencils  238, 373
drawing files  21, 373
Open dialog box options  29
stand-alone stencil files  5, 238–241, 243–246, 379
templates  5, 243, 247–249, 379
workspaces  21, 45–46, 381

filename extensions. See extensions
filenames

brackets in title bar  31, 239
displaying on page  184
existing files  29
exported files  286
extensions. See extensions
saving files  42

files
See also file formats; file types; file size; OLE (object

linking and embedding); names of specific file types
2.0 version files  44
closing files and windows  47
compound files  44
copying shapes to other files  125–126
creating new  24–31, 243–249
drawing files  22–23
exporting and importing  260–261, 281–286
extensions. See extensions
formats. See file formats
installed with Visio. See the README.TXT file in the

Visio directory
linking to original files  263, 272–273
Name property  327
naming

drawing files  42
exported files  286
stencils  246

opening  21, 24–30, 242
printing to  224
problems with printing  357–360
protecting  249
reducing file size  363–364
saving options  31, 42–43

read-only  31, 42–43, 250
stencils  245–246
templates  247–249

sending through electronic mail  261, 291
sending to a printer  224
sizes  263, 288, 291
stencils  22–23, 240, 243–246
summary information  43, 44, 46–47
templates  5, 22–23, 25–27, 247–249
Visio file types  22–23
workspaces  21, 23, 45–46, 381

Fill command and dialog box  150, 346
Fill Format section in ShapeSheet  301
Fill option  253
Fill style list  34

applying all or selected style attributes  144, 146
applying styles  140
creating new styles for  250–253

Fill Style options  146–147
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fills  374
See also Fill style list
applying  139, 144, 146
colors and patterns  150–151, 222
creating new styles  250–253
default attributes  253
display problems  361–362
gray scale patterns  222
imported objects  284, 289
in imported or exported files  365
missing or printed incorrectly  360
ShapeSheet information  301

filters  261, 281, 282, 283–284, 365–366
finding stencil files  31
First Tile button  217, 342
Fit On printing options  220, 221
flattening arcs into lines  116–117
Flip Horizontal and Flip Vertical buttons  33, 336
Flip Horizontal and Flip Vertical commands  63, 345
flipping shapes  59, 62–63

glued shapes  91–92
ShapeSheet information  300
with Size & Position options  157

flowcharts
charting program steps  329
dragging and dropping shapes to create  83–84

Font command and dialog box  147, 180, 347
Font list  177–178
font size  140, 178, 180
Font size buttons  178
Font size list  178
fonts

See also text; text blocks
Font list  177–178
Font size list  178
in imported or exported files  365
ShapeSheet information  301
specifying face, style, and size  178, 180

foreground colors  222, 301
foreground fill and shadow options  150
foreground pages  192, 374

See also background pages; pages
assigning background pages to  203
converting to background  202
deleting  196
differing page sizes and scales  201–202, 210, 212
printing  213, 214
reordering  195
sizes of  210

formats, file. See file formats; names of specific file formats
formatting  138–152, 374

after combining or uniting shapes  127, 128
attributes  138–139, 371
corners or endpoints  148–149
cycling through formatting choices  141
fill colors and patterns  139, 144, 146, 150–151, 222, 289
groups  133, 141
imported objects  289
lines  139, 144, 145, 148–149
local  139, 142, 146–147, 253
multiple shapes  141, 142
optimizing shape performance  363

formatting (continued)
repeating formatting choices  141
rounded corners  127, 148–149
shadows  150–152
ShapeSheet information  301
shortcuts for  139–141
styles  139–140

applying fill, line, or text attributes  144–147
applying with style lists  139–141
creating new  250–253
protecting  249
removing styles  253–254

text and text blocks  139, 144–145, 177–183
alignment  178, 180–181, 182–183
field data  184, 185
fonts and characters  178, 180
line spacing  180–181
margins and tabs  147, 181–182
paragraphs  147, 179, 180–183
shortcuts for  140, 345

formula bar  299, 317–318
formulas  297, 302–304

arrowheads  304–310
copying and pasting  318–320
default ShapeSheet formulas  303
displaying  312
displaying result in text fields  184
elements of  316
empty formulas  321
entering and editing  315–321
errors in  317
inherited and local formulas  320–321
protecting against changes  304
referring to cells  306–307, 318–319
text fields  185, 186
vertex locations  296

Formulas command  312
four-headed arrow pointer  352

dragging guide points  73
moving endpoints  65
moving vertices  112
reshaping lines and arcs  116

fractions in ShapeSheets  316
Fragment command  127, 129–130
fragmenting shapes  127, 129–130
From Selection option  162
Function command  319
function keys

on different keyboards  343
shortcuts  346–347

functions in ShapeSheet formulas  302, 316, 318–319

gallery of Visio drawings  12–15
GDI (Graphics Device Interface)  360
General Protection Faults  366–367
Geometry fields  184
Geometry section in ShapeSheet  301

arrow formulas  305, 306–310
proportional resizing formulas  305

glossary  371–381
glue  81–83, 374

See also connection points
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glue (continued)
adding glued guides and shapes to a group  136
aligning and gluing to guides  71, 75
arranging shapes  59
breaking  91–92
connecting

dragging endpoints of connector shapes  56–57
existing shapes  85–86
shapes while drawing  83–84
specific points on shapes  88–89

connection points  53, 93, 95
control handle connectors  86–87
converting solid to dynamic glue  92–93
dynamic glue  6, 81–83, 92–93, 373
gluing shapes  56–57
moving glued shapes  91–92
one- and two-dimensional shapes  52, 75, 89–90
saving glue settings in a template  247
setting options for  94–95
shapes saved in 2.0 version files  44
ShapeSheet information  301
solid connections  81–83, 92–93
turning off or on  94–95
with Connect Shapes command  89–90

Glue button and command  33, 94, 337, 347
Glue Info section in ShapeSheet  301
Glue To options  94–95
Go To Page command and dialog box  30, 125, 194, 217, 347
grabber hand pointer  288, 353
gradient fills in imported objects  284
Graphic Import dialog box  283–284
graphic object import options  283–284
graphics cards  362
Graphics Device Interface  360
gray backgrounds on master shape icons  58
gray handles  136

See also groups
Gray Scale importing option  284
gray scale printing options  222–223
gray-scale monitor settings  368
green boxes on master shape icons  120
green crossbar guide points. See guide points
green handles. See control handles; selection handles
green lines in Define Styles dialog box  252
Grid command  41
grid lines  374

adjusting color settings  368
aligning and spacing shapes  59, 66
drawings misaligned after centering  76
setting measurements  197–198
snapping to  68

grids
designing master shapes and templates for  248
in templates  23, 26, 243

Group command  132, 133, 345
group drawing window  134–135, 137
group origin coordinates in ShapeSheets  304
groups  132–138, 375

adding guides and glued objects  136
adjusting selection rectangle  134
controlling shape behavior  136–138
converting objects to groups  290

groups (Continued)
editing individual shapes  134–136
file size implications  363
gluing to  95
group drawing window  134–135, 137
group origin coordinates  304
rotating  133, 134–135, 136
ShapeSheets  297

displaying for grouped shape  298
resizing information  300

sizing, moving, and formatting  133–138, 141
subselecting shapes in  136
text  136, 168

GUARD function  304
Guide Info section in ShapeSheet  299, 302
guide points  73–74

deleting  74
ShapeSheet information  297, 299, 302

guides  59, 375
creating and aligning shapes with  59, 71, 72–75
deleting  73
displaying  95
gluing shapes to  71, 74, 75
in groups  136
moving glued shapes and  91–92
ShapeSheet information  297, 299, 302
shortcuts for creating  71
snapping shapes to  68

Guides command  41, 95

handles  375
blue  61
control handles  372

behavior  161
creating shapes from  53, 120–121
identifying in master shape icons  58
ShapeSheet information  302, 310

diamond-shaped. See vertices
eccentricity handles  118–120, 374
gluing to  75, 95
gray  136

See also groups
green  61
red  75

See also glue
resizing shapes or objects  110–111, 287
rotation handles  52, 64, 377
selection handles  52, 60–61, 377
snapping shapes to  68
turning off handle display  141

hard disk space, reducing file size  363–364
hardware, optimizing  362
height

displaying in text fields  184, 344
locking  162
page  210
resizing shapes with handles  110–111
ShapeSheet information  300
Size & Position options  153
text block  175

Height cell
formulas  305, 307–308, 310
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Height cell (continued)
shape resizing effects  303

Height option  157
help  18

accessing online help  18, 346
displaying by double-clicking shapes  163
Fax Information System  356
Quick Tour  24
technical support  355
ToolTips  37

Help button and menu  18
hiding

rulers  41
sections in ShapeSheets  312–313
shapes  148
ShapeSheet cells  312–313
status bar  41

high resolution monitors  16, 32–33, 333
highlighting. See selecting
holes in shapes  127, 128–129
home team wins rule  144
Horizontal Align button and option  70, 335
horizontal alignment

of shapes  59, 70–71
of text blocks  178, 180–181
ShapeSheet information  301

Horizontal Center Distribution button and option  78, 335
horizontal distribution of shapes  59, 78
Horizontal Ends Distribution button and option  78, 335
horizontal flipping  62–63
horizontal guides  72
horizontal page orientation  207, 210
horizontal resizing of shapes  153–155, 156–157
horizontal shape alignment buttons  334–335
horizontal text alignment buttons  35, 178, 338
hyphens  348

I-beam pointers  353
icon pencil tool  236, 341
Icon Update options  234
icons

displaying OLE objects as icons  270–271, 274
edit icon window  235–237
master shape icons. See master shape icons
stencil window display  41, 230, 233, 242
templates  25
Visio add-ons  328
Visio and Visio program group  24

Icons And Names button and command  36, 41, 340
Icons Only button and command  36, 41, 340
ID numbers for shapes  184
identifying files  46–47
Image Info section in ShapeSheet  300, 302
import filters  261, 281, 282, 284
importing

adding text to imported objects  170
comparing methods of bringing in files  260–261, 281
data to or from Lotus Notes  279–280
files into Visio  281–284
graphic options  283–284
tips for exchanging data  365–366

incomplete print jobs  357–358

Increase Font Size button  33, 35, 336
indents  181, 301
independent stencils. See stencils
inherited formulas  320–321
inheriting changes from masters  241
in-place editing

adjusting window size setting  369
creating and editing objects within Visio  261, 274
creating and editing Visio objects in other applications

267–268
enlarging drawing area  267

Insert Arguments option  319
Insert Function dialog box  319
Insert Name dialog box  318–319
Insert Object command and dialog box  268, 274–275
Insert Picture command and dialog box  282–283
Insert Section dialog box  314
inserting

drawings into other applications  10, 285–286
files into Visio  10, 275
ShapeSheet sections  314

insertion point  169, 172, 318, 353
installation  22

See also the README.TXT file in the Visio directory; the
Visio installation card

printer drivers  359
troubleshooting  357

instances  4, 375
See also master shapes; shapes
locking and unlocking shape behavior  161–162
of edited master shapes  239–241
of master shapes in drawing file stencil  58, 241
of one-dimensional master shapes  56
retaining or reverting to master’s format  146–147
stamping  125, 378
ungrouping  133

Interaction Style options  160
international No symbol  131
inventorying open drawings and pages  329–330
Inverse, Inverse Gray Scale, and Inverse Grays Only

importing options  284
invisible lines  148
invisible shapes  150, 169–170
Italic button  35, 178, 338
italic text  140, 345

joining shapes. See combining shapes; connectors; glue;
groups; uniting shapes

Justify Text button  35, 178, 338

key commands and keyboard shortcuts. See shortcuts
keys, navigating by  311–312
keywording files  46–47

labels on drawings  167, 176
landscape orientation  207, 210
languages, programming. See programming Visio
large drawings  209, 215

previewing printed drawings  216–218
reducing or enlarging  220–221
viewing page breaks  218–219

lasso tool  237, 341
Last Tile button  217, 342
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layering shapes  61–62, 89–90, 378
layers of pages  192, 198–204

See also background pages; foreground pages; pages
Left Align button and option  70, 334
Left Align Text button  35, 178, 338
Left color box  236, 237
Left Distribution option  78
left ruler zero point  77
Left/Right Alignment options  70
legends on drawings  167
length of one-dimensional shapes  153
lengthening shapes. See sizing
letters. See characters
libraries, OLE  326
libraries of shapes. See stencils
Line (1-dimensional) interaction style  160
Line command and dialog box  148, 346
line ends

arrowheads  97–98
formatting  147
preserving formatting  144
shapes saved in 2.0 version files  44

Line Ends button  33, 97, 336
Line Format section in ShapeSheet  301
Line option  253
Line Pattern button  33, 148, 336
line patterns  148, 301
line pointer  105
line spacing  180–181, 301
Line style list  34

applying all or selected style attributes  144, 145
applying styles  140
creating new styles for  250–253

Line style options
applying specific attributes in a style  145
Use Master’s Format option  146–147

line tool  104, 106, 337
displaying vertices  52
drawing segmented shapes  106–108
shortcut for choosing  344

Line Weight button  33, 336
line weights  148, 301
lines  102

See also line ends
applying colors or patterns  139, 144, 145, 148
arrowheads on  149
bowing into an arc  116–117
constraining to 45-degree angles  108
control points  53
creating shapes from intersecting  129–130
default attributes  253
dimensions  186–188
display problems  361–362
drawing  9, 104–106
formatting  139, 144, 145, 148–149
green lines in dialog boxes  252
in imported or exported files  365
invisible  148
line weights  148, 301
missing or printed incorrectly  360
one-dimensional shape behavior  160–161
rounded corners  127, 148

lines (continued)
selecting text block of  175
ShapeSheet information  301
styles

applying  139, 144, 145
creating new styles  250–253
imported objects  284, 289
Line style list  34

LineTo cells
formulas  305, 306–310
referring to other cells  306–307

linking  262–264, 375
See also OLE (object linking and embedding)
adding text to linked objects  170
breaking  279
comparing methods of

importing and exporting  260–261
converting linked objects to shapes  271, 290
displaying linked objects  270, 274
dragging and dropping  268–270
editing and updating linked objects  275–276
managing linked files  276–279
objects into Visio files  10, 270–276
opening files with linked objects  277
pasting as particular format  273–274
troubleshooting problems  364–365
unavailable OLE object applications  277
viewing and changing links  277–279
Visio objects into other applications  10, 264–270

Links command and dialog box  278, 279
List Files Of Type box and list  29
lists of installed Visio files. See the README.TXT file in the

Visio directory
local formatting  142, 253

applying with buttons  139
compared to styles  142
optimizing shape performance  363
preserving  146

local formulas  320–321
locations

of files in directories  29
of stencil files  31

locking
master shapes  242
shapes  53, 161–162
ShapeSheet information  301

Lotus Notes
exchanging data with Visio  279–280
fields  185, 280
files saved in Visio 2.0 version  44

Lotus Notes Fields command and dialog box  280
Lotus SmartSuite

button illustrations  17, 37–38, 333–342
menus and toolbars  11, 32

Macintosh PICT Format (.PCT)  282, 285
magenta control points  118, 119
magenta endpoints or vertices  112
magnetic pull. See snap
magnification  39–40, 346

shortcuts  40, 346
zooming selected text  178
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magnifying glass pointers  353
magnitude of eccentricity  118–119
mailing files  261, 291
main toolbar  31, 33, 333–342

See also toolbars
main window. See windows
Manual option  234
manually updating links  279
manually updating master shape icons  231, 234, 235
MAPI protocol  261, 291
margins

enclosing linked or embedded data  266–267
print margins  221–222
ShapeSheet information  301
text blocks  181

Master menu  228
master shape drawing window  228, 231–232, 240, 241
master shape icons  4

arranging  41, 230, 233
blank icons  228, 232
customizing or designing  233, 235–237, 243
edit icon window  235–237
editing tools  341
for new master shapes  228, 234
green squares on  120
interpreting  58
naming and sizing  230–231
peek-through icons  237
red bars on  58
replacing custom icons with automatic icons  234
shapes reflected on icon automatically  232
shapes with control handles  120
updating to reflect shape changes  234
yellow or gray backgrounds  58

master shapes  4, 32, 52, 54, 376
See also instances; master shape icons; shapes
arrowheads  96–98
as groups  132
connection points on  53
connectors  57, 79–80
control handles  53, 120–121
copying into other applications  268–270
creating new  228–232
deleting  241–242, 364
displaying name of shape’s master  184
double-clicking  171
dragging shapes with same style names into drawings

144
drawing scale influence on  212
editing and customizing  228–232, 239–241
icons. See master shape icons
in stencils

copying into another stencil  246
drawing file stencils  58, 238–239, 241
menus and tools for editing  36
saving shapes  9, 245, 246
stand-alone stencils  23, 238–241, 245, 246
standardizing design  243

inheriting formulas from  320–321
instances of. See instances
locked  53, 161, 242
master shape drawing window  228, 231–232, 240, 241

master shapes (continued)
names  184, 230
one- and two-dimensional shapes  52
optimizing file size with  363
placing in drawings  51, 54–57
protecting  249
retaining formatting in instances  146–147
ShapeSheets  297
SmartConnectors  5–6
special selection rectangles  134
stamping instances  124
status bar prompt information  231
trouble with editing masters  242
ungrouping instances of  133
using dynamic glue  83

Master Shapes option  242
math coprocessors  362
mathematical functions  302
Maximize button  40
maximizing windows  40
measurements

displaying shape measurements in text fields  184
drawing scale reflected in  211
grid line units  197–198
moving ruler zero points  77
page measurements  212
ruler units  197–198
setting system with templates  26
units of measure in ShapeSheets  304, 316

memory
OLE support requirements  264
optimizing  362
printer memory  358
reducing file size  363–364
required for undo actions  369
Visio requirements  362

menu bar and menus
activating  347
check marks on menus  41
connection tool menu  33
display differences  16, 31–33, 333
drawing tool menu  33
Edit <OLE object> command  276
editing Visio objects in other applications  267
Master menu  228
procedure steps  17
quick display of common commands  38–39
ShapeSheet window  36, 299
shortcuts for choosing

commands  194, 344–345, 346–347
standard, SmartSuite, and Office menus  11, 37–38
stencil window  36
supplemental tool menu  33
text tool menu  33
text toolbar  35

Messaging Application Program Interface (MAPI)  261, 291
metacharacters  348–350
metafiles

converting to shapes  290–291
exporting drawings as  281, 285
file size implications  363
importing into Visio  281, 282
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metafiles (continued)
linked objects after breaking links  279
pasting into Visio  273
representations of OLE objects  271

methods in scripts  327
metric system measurements  304
Microsoft Mail  261
Microsoft Office

button illustrations  17, 333–342
menus and toolbars  11, 32, 37–38

Microsoft Visual Basic  326
programming Visio  10
sample program  329–330

Microsoft Windows
checking display mode  361–362
default paper size settings  205
General Protection Faults  366–367
Graphics Device Interface  360
installing Visio  22
OLE problems  364–365
printing problems  359
sending files to a printer  224
shortcuts for choosing commands on menus  194
starting Visio  24–25
system resources needed for printing  359

Microsoft Windows for Workgroups buttons  16
Middle Align Text button  35, 339
Minimize button  40
minimizing windows  40
minus sign (-) in formulas  316
minus sign (-) pointers  313, 354
minutes (angles)  304
Miscellaneous section in ShapeSheet  302
monitors

adjusting Visio color settings  368
button and toolbar differences  333
display differences  16, 32–33
display problems  361–362

monochrome monitors  368
monochrome printers  222–223
mouse pointers  204, 270, 351–354

See also names of pointers
Move Up or Move Down options  195
moving

entire drawings  76
glued connectors to another point  81–83
guides  72
imported objects within frames  288
linked files  277
objects into other applications  268–270
panning objects within frames  287
pixels in edit icon window  237
reordering pages in drawing files  195
scrolling in drawing window  40
segments in connectors  95
shapes  66–67

connected shapes  86
control points  116–117
flipping connectors  11
glued shapes  91–92
groups  133
one-dimensional shapes  155–156

moving (continued)
shapes (continued)

onto page  54–57
onto pasteboard  67
ShapeSheet information  302
SmartConnectors  5–6
two-dimensional shapes  157–158
up or down in stacking order  61–62, 378
vertices  112–113
with pointer tool  7
with Size & Position options  155–156, 157–158
with text  7

text
away from shapes  176
insertion point  172

through pages  30
through ShapeSheet cells  311–312
zero points on rulers  77

multiple-path shapes  127, 128–129
multiple-segment shapes. See paths; segmented shapes

Name command  318
Name property  327
names. See naming
Names Only button and command  36, 41, 340
naming

exported files  286
files  42
new master shapes  230, 243
pages  193, 195
pasting cell names into formulas  318–319
printing names of each open drawing and page  329–330
stencil files  246
styles  252

duplicate names in shapes and files  144, 252
renaming styles  254–255

navigating
in drawing window  39–40
through pages  30
through ShapeSheet cells  311–312

negatives, photographic effect, in imported graphic objects
284

Network button  16
networks

See also the NETWORK.TXT and the README.TXT file in
the Visio directory; the Visio installation card

installation  357
running shared versions of Visio  355

New button  27, 28, 33, 334
New command and dialog box  24–25, 244

creating new stencils  244
descriptions of files  46
opening files  25, 27, 28
shortcuts for choosing  345

New Master command and dialog box  232, 234, 235
New Page command and dialog box  192–193, 194, 202
New Window button and command  36, 194, 340, 347
Next Page button  30, 33, 194, 334
Next Tile button and command  217, 342
No Formula in Scratch cell  321
No pointer  270, 354
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No Style option  252
No Template option  28
non-breaking backslashes, slashes, and hyphens  348
None option for invisible lines or shapes  150
non-printing grid. See grid lines
non-printing guides. See guides
Non-Printing Shape option  214
non-printing shapes  214
Normal importing option  284
Notes. See Lotus Notes
Notes fields  185
Number field  184
numbering pages  184
numbers  316

object handles. See selection handles
Object Info fields  184
object linking and embedding (OLE). See (OLE) object

linking and embedding
Object Linking and Embedding Programmer’s Reference  327
Object Transform section in ShapeSheet  299, 300
Object Type options  275
objects  17, 376

See also shapes
adding text to  170
borders around objects  288
breaking links  279
converting

objects to another file format  261, 287, 289–290
to metafiles  279
to shapes  271, 290–291

creating from within Visio  260–261, 274–275
creating Visio objects in other applications  268
cropping imported objects  287, 288
displaying icons for inserted objects  270–271, 274
editing and updating  264, 267–268
embedding or linking  262–276
formatting imported objects  289
gluing imported objects  95
graphic import options  283–284
importing into Visio  282–284
linking to original files  272–273
methods of importing and exporting  260–261
modifying in Visio  286–290
panning imported objects  287, 288
pasting into Visio  273–274
protecting  249
resizing imported objects  287
ShapeSheet information  300, 302
using in more than one drawing  272
viewing and changing links  277–279

Office. See Microsoft Office
offsetting

copies of shapes  122–124
shadows  151–152

OLE applications
container applications  264
unavailable  277

OLE (object linking and embedding)  10, 262–276, 376
See also embedding; linking; objects
comparing methods of importing and exporting  260–261
containers  263

OLE (continued)
displaying objects as icons  270–271, 274
drag and drop support  268
linking and embedding compared  262–264
linking or embedding drawings into other applications

264–270, 276–277
linking or embedding files into Visio  270–276

converting objects to another file format  271,
289–290

creating objects from within Visio  274–275
pasting into Visio  273–274
using objects in more than one drawing  272

objects defined  17
OLE 2.0 support  261
OLE Automation  326
relative linking  277
sending commands to Visio  326
troubleshooting  364–365
unavailable OLE object applications  277

one-dimensional shapes  52, 376
See also connectors; shapes; two-dimensional shapes
aligning with guides or guide points  72–75
beginning and ending points  52, 154–156
behavior  160–161
combining shapes  127–128
connecting to two-dimensional  89–90
control handle behavior  161
converting to two-dimensional  53, 160–161
display while dragging  55
flipping and rotating  62–65
fragmenting  127, 129–130
gluing  75, 91–92, 95
identifying master shape icons  58
moving  66–67, 91–92, 155–156
sizing and resizing

with handles  110–111
with Size & Position options  152–156

stamping  124
online help. See help
Open button  28, 33, 246, 334
Open command and dialog box  28–29

descriptions of files  46
opening files  25–26
shortcuts for choosing  345, 347

Open Group command  134, 135, 137, 290
Open Page In New Window option  193, 194, 204
open shapes  102, 127

See also one-dimensional shapes; shapes
Open Stencil button  30, 33, 240, 334
Open Stencil command and dialog box  26, 27, 30, 240

adding shapes to stencils  229
opening stencils  30–31

opening
files  24–30

as originals, copies, or read-only versions  29, 242
existing files  28–30
file types  25–26
new drawing files  27–28
original templates  31
other application files from within Visio  275
sent by mail  291
stencils  23, 27, 30–31, 229, 240
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opening (continued)
files (continued)

with linked objects  277
workspaces  23, 45

ShapeSheets  297–299
text blocks  171, 346
Visio  24–25, 268
windows

edit icon  235–236
full-size for in-place editing  369
group drawing  134–135
master shape drawing  231–232
more than one drawing window  193–194
new windows by double-clicking shapes  163
pages in new windows  194
print preview window  216

operators in ShapeSheets  302, 316
optimizing Visio performance  362–364
Options command and dialog box  69, 223
order

of pages  195
of printed pages  213
of selection  61

guide points on selected shapes  74
when aligning shapes  70
when combining or uniting shapes  127, 128
when connecting shapes  90

of shapes on pages  61–62, 89–90, 378
organization charts, creating  86–87
orientation of pages and printed drawings  207, 210
original files

opening  29
protecting stencils and templates  31

Original option  240
origins of coordinates  304, 376
ovals  109–110
overlapping shapes

breaking into parts  127, 129–130
combining into new shape  128–129
uniting into new shape  127–128

overriding style attributes  142–144
overwriting formulas  320–321

padlocks  53, 161, 242
page breaks  218–219
Page Breaks command  219
Page Info fields  184
page numbers  184
page origin coordinate references  304
Page Setup command and dialog box  202

changing measurement units  197–198
displaying information on drawings  184
function key shortcut  347
printing foreground pages only  214
setting options for current page  192

Page Setup Options dialog box  151–152
Page Setup Size/Scale dialog box

creating large or small pages  209–211
drawing and paper size options  206–208
drawing scale options  211–212
enlarging drawing area while editing in place  267
reflecting Print Setup options  207–208

page size
See also paper size; printed drawings
changing  206–211
custom  209–211
default size and scale  205
displaying  212
drawing scale and  191
large or small pages  209–211
printed size compared to  209–211

Page Width command  39
pages

See also drawing scale; drawings; page size; printed
drawings

centering drawings  76
copying shapes to another page  125
definition  376
deleting  196, 246, 248
displaying

in new windows  193–194
page information in text fields  184
specific pages  30

drawing page  32
foreground and background  192

assigning or canceling background pages  203
converting pages to backgrounds  202
differing page sizes and scales  201–202, 210, 212
viewing both simultaneously  203–204

linking or embedding into other applications  265–270
names  193, 195, 196
numbering pages  184
orientation  207, 210
page breaks  218–219
pasteboards  67
printing  213–224

current page  214
names of each page in open drawings  329–330
printable area  219
reflecting Print Setup options in drawing page

207–208
reordering pages  195
saving as part of template  247
scale

default size and scale  205, 207
designing master shapes for scale and grid  248
differing drawing scales  201–202, 212
setting drawing scale  211–212

scrolling automatically  40, 346
size. See page size
stacking order of shapes  61–62, 89–90, 378
template drawing pages  23
turning pages  30, 163, 194
types of  192
views

changing views  39–40
multiple pages  193–194
page breaks  218–219
shortcuts for  346
viewing background

and foreground pages  203–204
zooming selected text  178

paint bucket pointer  354
paint bucket tool  237, 341
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panning imported objects  287, 288, 376
paper size

See also page size; printed drawings
changing  206–211
defaults  205, 207
determining printed drawing size  205–206
fitting drawings on  218–219
large or small pages  209–211
reflecting Print Setup options  207–208

Paragraph command and dialog box  147, 179, 181, 347
Paragraph Format section in ShapeSheet  301
paragraph markers  348
paragraphs

See also text; text blocks
alignment  178, 179, 180–183
formatting  179, 180–183
line spacing  180–181
ShapeSheet information  301

passwords for files  249
Paste button  36, 339
Paste command

linking or embedding data  265, 266, 272
pasting shapes into another file or page  125
pasting text  169, 173
shortcuts for choosing  345
using in ShapeSheet cells  320

Paste Link command  266, 272
Paste Object command  265
Paste Special command and dialog box  265, 266, 272–274
pasteboards  32, 377
pasting  376

comparing methods of importing  260–261, 281
dragging and dropping  268–270
files into Visio  273–274
in ShapeSheet cells  318–320
pixels in edit icon window  237
shapes  122–126, 264–267
text  169, 173
Visio objects into other applications  264–267, 268–270

paths  102, 377
creating multiple-path shapes  127, 128–129
for linked files  277

patterns  150
See also fills
applying  150
gray fills and patterns  222
on imported objects  284, 289
ShapeSheet information  301

.PCT file format  282, 285

.PCX file format  282, 285
peek-through shapes  127, 128–129
pencil pointer  352, 354
pencil tool  8, 103–104, 337

See also drawing
adding or deleting vertices  113–115
displaying

control points  53, 106
eccentricity handles  118
vertices  52

drawing techniques  9, 104–105
editing lines and arcs  116
shortcut for choosing  344

pencil tool (edit icon window)  236
performance speed, optimizing  362–364
photographic negative effects, in imported objects  284
picas  304
PICT file format  282, 285
picture frame shapes  128–129
pin  297, 300

See also center of rotation
PinX and PinY cells  303
pixels  236, 377
plus sign (+)

ending points  52
in ShapeSheets  316

plus sign (+) pointers  270, 313, 352, 353, 354
pointer tool  8, 33, 337

dragging instances of master shapes  54–57
resizing shapes  110
selecting shapes  52, 60–61
shortcut for choosing  344

pointers
See also names of pointers
descriptions  351–354
drawing and stencil window pointers  352–354
during drag and drop operations  270
over background page items  204

points. See connection points; control points; coordinates;
guide points; vertices

Points bar  69
points (units of measure)  304
popup menus of common commands  38–39
portrait orientation  207, 210
positioning instances while dragging  55
PostScript files  282, 285
power-pasting shapes  122–123
Practice stencil shapes  16
predefined styles  142–143

See also styles
predefined text in shapes  168
predesigned shapes  10–11, 378

See also master shapes
Preserve Local Formatting option  146, 321
previewing print jobs  216–219
Previous Page button  30, 33, 194, 334
Previous Tile button and command  217, 342
primary selected shapes  61, 74
Print button  33, 214, 334
Print command and dialog box  213–215, 345, 347
print overruns  358
Print Preview button and command  33, 216–218, 334
print preview toolbar  342
print preview window  216–218
Print Range options  213
Print Setup command and dialog box

choosing printers  223
reducing or enlarging printed drawings  220–221
setting drawing size, printed size, and paper options

206–208
setting margins  221

Print To File option  224
printed drawings

See also pages; paper size
fills or lines printed incorrectly  360
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printed drawings (continued)
margins  221–222
missing or cut off shapes  357
orientation  207, 210
positioning small drawings  216
previewing  216–218
problems printing  357–358
reflecting Print Setup options in drawing pages  207–208
size

changing size  206–211
compared to drawing page  209–211
determining size and reduction  205–206
fitting on paper size  218–219
large or small pages  209–211

tiling large drawings  209, 215, 220–221, 380
viewing page breaks  218–219

printer drivers  223, 357, 359
printers

memory  358
problems with printing  357–360

printing  213–224
choosing printers  223
colors on a monochrome printer  222–223
default page size settings  205
fitting drawings on printable paper area  218–219
foreground and background pages  213–214
gray scale printing options  222–223
large or small drawings  215–216
margins  221–222
names of each open drawing and page  329–330
non-printing objects  214
page orientation  207, 210
previewing printed drawings  216–218
print date and time display  184
print quality  214
printable area  219
reducing or enlarging drawings  205–211, 220–221
saving settings as a template  247
system resources needed for printing  359
tiling  209, 215, 217, 220–221, 380
to a file  224
troubleshooting  357–360

printer unavailable  223
shapes disappear from printed drawing  222

viewing page breaks  218–219
problems running Visio  355–369
procedures  17
product serial numbers. See the Visio registration card
Program Manager  22, 24
programming Visio  10

controlling Visio through OLE Automation  326
objects, methods, and properties  327
running programs  328–329
sample program  329–330
writing and compiling programs  325, 327–329

Prompt For Document Information On Save option  43
prompts in status bar  231, 243
Properties command and dialog box  230

custom icon options  235
Icon Update options  234

properties in programs  327

proportional resizing
default ShapeSheet formulas  304–305
imported objects  287
locking shape aspect ratio  162

Protect Document command and dialog box  162, 249–250
protecting files  243
unlocking master shapes  242

protecting
files and settings  243, 249
locking shapes  53
shapes, pages, or backgrounds  161–162
ShapeSheet cells  304

Protection command and dialog box  161–162
Protection section in ShapeSheet  300, 301

quick keys. See shortcuts
Quick Tour online introduction to Visio  24
quitting

in-place editing  268
Visio  47

quotation marks  348

radians  304
RAM requirements  264, 362
Read From Notes option  280
Read Only option  250
read-only files  250

opening copies of files  29
protecting files  243
saving  31, 42–43, 250
stencils  31, 239, 245

rectangle pointers  352, 353
rectangle tool  109, 337, 344
rectangles

See also shapes; two-dimensional shapes
drawing  109–110
enclosing linked or embedded data  266–267

red bars on master shape icons  58
red handles or endpoints  75

See also glue
red X marks  71
Redo button and command  35, 36, 338, 345
Reduce/Enlarge options  220
reducing file size  363–364
registered trademark symbols  348
registering OLE application information  364–365
removing. See deleting
Rename dialog box  254
renaming

See also naming
source files for linked data  263
styles  254–255

Reorder Pages command and dialog box  195
Repeat button and command  36, 340, 346
repeating actions

copying or pasting text  173
formatting choices  141

repeating shapes on every page  192
replacing

characters or words in formulas  318
custom master shape icons with automatic icons  234
local formulas with inherited formulas 320–321
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replacing (continued)
object links  278
predefined text  168, 169
shape text with a field  185

Reposition Only option  137
repositioning. See moving
reshaping shapes  8, 52, 112–120
Resize Behavior options  137
resizing. See sizing
resolution

display differences  16, 32–33, 333
required printer memory  358

Restore button  40
restoring

deleted formulas  320–321
shape formatting  146–147
windows  40

Retain Background option  284
Retain Gradients options  284
Reverse Ends command  63, 92
reversing

actions. See canceling; Redo button and command;
Undo button and command; undoing

arrowhead direction  98
shape orientation  62–63
tones in imported graphic objects  284

reverting shape formatting to master’s format  146–147
revision dates, displaying in text fields  184
rewrapping text  175
Right Align button and option  70, 335
Right Align Text button  35, 178, 338
Right color box  236, 237
Right Distribution option  78
right mouse button shortcuts  38–39
Rotate Left and Rotate Right buttons  33, 336
Rotate Left and Rotate Right commands  63, 345
rotating

angle of arc eccentricity  119–120
center of rotation  64–65, 157, 158–159, 371
displaying angle in text fields  344
groups  133, 134–135, 136
shapes  8, 59, 63–65

displaying angle of rotation in text fields  184
effects on text  7, 168
glued shapes  91–92
locking shape rotation angles  162
one- or two-dimensional shapes  63–65
with Size & Position options  156

ShapeSheet information  297, 300, 302
text blocks  176–177

rotation handles  52, 64, 177, 377
rotation pointers  64, 352
rotation tool  8, 63–65, 337

changing center of rotation  159
rotating shapes  52
selecting shapes before rotating  60
shortcut for choosing  344

Round Corners option  148
rounded corners  127, 148–149
Row and Row After commands  315
rows in ShapeSheets  311, 314–315
rubberstamp pointer  352

rubberstamp tool  90–91, 124, 337
ruler subdivisions  59, 68, 379
rulers  77

aligning and spacing shapes  59, 66
dragging guides or guide points from  72, 73–74
moving zero points  77
reflecting drawing scale  211
setting measurement units  197–198
snapping to subdivisions  59, 68

Rulers command  41, 77
Run Add-on command and dialog box  328
Run Add-on option  328
Run command  22
running

Visio add-ons or programs  328–329
Visio installation program  22

Save As command and dialog box  42, 347
file saving options  31, 42–43
saving files as read only  250
saving stencils  245
saving templates  248

Save button and command  33, 42, 334, 345, 347
Save New Files In 2.0 Format option  44
Save Workspace command and dialog box  45, 347
saving

2.0 and 3.0 formats  43, 245, 363
add-ons in Add-on directory  328
closing Visio without saving changes  47
files  42–43, 47

as read-only  31, 245, 250
closing stencils before saving files  364
formats for smaller files  363
saving options  31, 42–43
styles and settings as templates  247–249

stencils  240–241, 245
Scale With Group behavior option  137
scaling drawings. See drawing scale
scaling shapes. See sizing
Scratch section in ShapeSheet  300, 301, 309–310
screen display

button and toolbar differences  16, 31–33, 333
of OLE objects  270–271, 289
ShapeSheet and dialog box text  320

scripts. See programming Visio; Visio’s online help
scrolling

display problems  361–362
page automatically  40, 346
through ShapeSheet window  311–312

seconds (angles)  304
section markers  348
Sections command and dialog box  313
sections in ShapeSheets  297, 299–302

adding or deleting  313–314
collapsing or expanding  312–313
deleting local formulas  321
titles of  313

segmented shapes  102
See also paths; shapes
adding or deleting segments  113–115
changing angles of segments  112–113
drawing  106–108
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segmented shapes (continued)
reshaping lines and arcs  116–120
rounding corners  148–149
segments defined  377

Select All command  60, 345
Select Special command  60
selecting  377

cells in ShapeSheet  311
characters or words  173
formula text  318
order of shape selection  61

selected shape guide points  74
when aligning shapes  70
when combining or uniting shapes  127, 128
when connecting shapes  90

pixels in master shape icons  236–237
rows in ShapeSheet  311
shapes  60–61

before aligning  70
before typing text  168
before zooming  39
created by control handles  121
in a group  136
multiple shapes  60
preventing selection  162

specific types of items  60
text  173, 318
text blocks  171

selection handles  52, 60–61, 377
See also handles; selecting
gluing to  95
order of selection or layer  61
resizing shapes  52
snapping shapes to  68

selection net  377
selection net tool  237, 341
selection order  61

guide points on selected shapes  74
when aligning shapes  70
when combining or uniting shapes  127, 128
when connecting shapes  90

selection rectangles  64, 134, 377
Send Backward and Send To Back commands  63, 345
Send command  291
sending files through electronic mail  261, 291
serial numbers. See the Visio registration card
setup

printer setup  359
troubleshooting  357

See also the Visio installation card
shading patterns in imported objects  284
Shadow button and dialog box  33, 141, 150, 336
shadows

adding to shapes  147
changing offset  151–152
foreground and background

colors and patterns  150–151
ShapeSheet information  301
Shape Handles option  94
Shape Vertices option  94
shapes  17, 102–103, 378

See also drawing; groups; instances; master shapes

shapes (continued)
aligning  59, 70–75
anatomy of shapes  52–54
arcs  104–106, 116–120
arranging on page  59
behavior  136–138, 160–161

associating with add-ons  329
double-click actions  162–163, 171
locking  161–162
one- and two-dimensional shapes  54
protecting  53, 161–162, 249

breaking into parts  127, 129–130
center of rotation  157, 158–159
centers of two-dimensional shapes  157
closed and open shapes  102, 107–108

See also one-dimensional shapes; two-dimensional
shapes

combining  127–129
connecting  56–57, 78–79, 85–86, 89–91
control handles  120–121
control points  106, 116–120, 372
converting objects to shapes  287, 289–291
coordinates. See coordinates
copying or duplicating  121–126
creating

complex shapes  127–131
dragging and dropping  54–57
master shapes  228–232
text-only shapes  169–170
Visio objects for other applications  264–270
with control handles  120–121
with intersecting lines  129–130

cutting, clearing, or deleting  126
cutting holes in  127
dimension lines  186–188
displaying

display problems  361–362
height or width in text fields  184
ID number and master shape name  184

distributing  59
dragging and dropping shapes  54–57, 125–126, 373
drawing  103–110
editing  8

adding or editing segments  112–115
individual shapes in a group  134–136
Size & Position options  152–159
updating by editing master shapes  239

embedding or pasting into other applications  264–270
exporting  285–286
file size implications  363
flipping  62–63
formatting

lines, fills, and text  138–152, 301
local  142, 253
multiple shapes  141, 142
preserving local formatting  146
removing styles  253–254
shadows  150–152
styles  139–140, 250–255
techniques  144–147

fragmenting  127, 129–130
gluing  71, 81–83
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shapes (continued)
grouping and ungrouping  132–138
instances  375

reflecting masters in drawing file stencil  58, 239,
241

retaining master shape’s formatting  146–147
linking or embedding into other applications  264–270
locking and unlocking  53, 161–162, 301
master. See master shapes
measurements  77, 184
missing or cut off on printed drawings  357
moving  7, 66–67

connected shapes  5–6
control points  116–120
glued shapes  91–92
groups  133
onto page  54–57
onto pasteboard  67
vertices  112–113

Name property  327
non-printing  214
objects. See objects
one- and two-dimensional  52

behavior  160–161
connecting automatically  89–90
resizing with handles  110–111
resizing with Size & Position options  152–158
stamping  124
switching between one- and two-dimensional

160–161
pasting  122–126, 264–267
paths  102, 301, 377
popup menus  38–39
recording shape information  184
repeating on several pages  199
reversing  62–63, 92
rotating  52, 63–65

glued shapes  91–92
shapes in a group  136

rounded corners  127, 148–149
saved in 2.0 version files  44
segments  112–115, 377
selecting  60–61, 70, 136
selection rectangles  64, 134, 377
ShapeSheets  297, 300–302
sizing

in a group  136–138
ShapeSheet values  303
with handles  52, 110–111
with Size & Position options  152–158

SmartShapes  10–11, 296–297, 378
snapping  67–68
stacking order on page  61–62, 89–90, 378
stamping  124, 378
switching between one- and two-dimensional  160-161
text  168

adding or changing text  167–188
changing master shape text  56
inserting text fields  183–188
opening text blocks  171
replacing pre-existing text  168
rotating or moving text blocks  176–177

shapes (continued)
text (continued)

switching between shapes and text blocks  171
uniting  127–128
updated by editing master shapes  239
vertices  106, 112–113, 380

ShapeSheet window  298–299
menus  36
navigating in  311–312
pointer descriptions  354

ShapeSheets  10, 295–321, 378
See also the Visio online help
anatomy  299–302
cells

copying and pasting formulas  318–320
displaying values or formulas  312
hiding  312–313
moving through cells  311–312
updating automatically  303

closing  299
coordinate systems  304
displaying  297–299
formulas  302–304

copying and pasting  318–320
displaying values or formulas  312
local and inherited  320–321
resizing  303

fragmented, combined, or united shapes  127, 128
groups  132
opening by double-clicking shapes  163
pointers  354
rows  311, 314–315
sections  297, 299–302

adding and deleting  313–314
collapsing, expanding, or hiding  312–313
titles of  313

shapes with multiple paths  301
text color  320
units of measure  304
values  312

Shapeware
See also the Visio online help
Fax Information System  356
technical support  355

shortcuts  343–350
accessing help  18
applying formatting  139–141
choosing commands on menus  18, 194
constraining lines to 45-degree angles  108
constraining shapes to squares and circles  110
copying and pasting shapes  122–123
deleting segments of shapes  109
dragging and dropping  125–126, 268–270
editing groups  136
function keys  346–347
keystroke commands  344–345
moving text insertion point  172
opening dialog boxes  194
page views  40, 346, 347
power-pasting  122–123
print preview window  218
printing current page  214
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shortcuts (continued)
quick display of common commands  38–39
repeating actions  141, 173, 346
selecting text  173
special and ANSI characters  348–350
style formatting  142, 251
switching between menu and tool sets  38
switching between shape and text block  171
toolbars and buttons  17, 333–342
turning pages  194, 347
viewing background and foreground pages  204

shortening shapes. See sizing
Show Master Shapes command  58, 241, 246
Show options  154
Show ShapeSheet command  298
Single Tile button and command  218, 342
Size & Position command and dialog box  152–159
size of files. See file size
size of paper or drawing. See drawings; page size; paper size;

printed drawings
sizing  378

arcs  116–120
arrowhead shapes  305–310
dimension lines  186–188
groups  133, 136–138
imported objects  287
master shape icons  235
pages. See page size
resizing accidentally  107
resizing proportionally  304–305
segments in shapes  112–113
shadows  151–152
ShapeSheet values reset by  303
text blocks  170–171, 174, 175
with handles  110–111
with Size & Position options  152–158

slash characters  348
small caps  345
small drawings  216, 220–221
smart formulas  296–297, 304–310
SmartConnectors  5–6, 79–80, 378
SmartIcons command  38
SmartShapes  10–11, 296–297, 378
SmartSuite. See Lotus SmartSuite
snap  59, 67–69, 378

problems adding vertices to shapes  114
saving settings in a template  247
setting snap strength  68–69

Snap & Glue Setup command and dialog box  67–68, 94–95,
347

Snap button and command  33, 68, 336, 347
Snap To options  68
solid glued connections  81–83, 92–93
sound files embedded or linked into drawings  270–271
source application registration  364–365
source data  263
spacing

between ruler subdivisions or grid lines  197–198
distributing shapes in even intervals  59, 77–78
paragraph line spacing  180–181

special characters  174, 348–350
Special dialog box  184
speed, optimizing Visio  362–364

splitting shapes  127, 129–130
spreadsheets for shapes. See ShapeSheets
squares  110
stacking order of shapes  61–62, 378

gluing automatically in stacking order  89–90
selected shape handle colors  61

stamping shapes  90–91, 124, 378
stand-alone stencils  238–241, 245–246, 379
standard toolbar  31, 33, 333–342
Start cell  305, 306, 308, 310
starting Visio  24–25
statistical functions  302
status bar  32, 37, 41, 379

angle of rotation display  64
contents  34
creating master shape prompts  231

Status Bar command  41
Status prompt text  34
stencil toolbar  36, 339–340
stencil window  31, 32, 36

adjusting color and size settings  368
changing display  41
pointer descriptions  352–354
toolbar  36, 339–340

stencils  4, 22–23, 379
See also master shapes
arranging and updating icons  230–231, 233, 235, 242
background color  237
closing  47, 364
copying master shapes to another stencil  246
creating new  243–246
deleting master shapes  241–242
drawing file stencils  58, 238–239, 241, 245–246, 373
duplicated style names  252
file extensions  29, 245, 246
file formats  44
icon background color  235
listing  31
listing stencil directories in VISIO.INI file  240
opening  21, 26, 30–31

additional stencils  27
original to add master shapes  229
read-only copies  242
with templates  23, 25, 26

problems editing masters  242
protecting  249
saving

as part of template  247
as read-only files  31, 250
drawing file stencils as stand-alone stencils  246
with workspaces  45

saving in 2.0 format  245
stand-alone  238–241, 245–246, 379
standardizing design  243
toolbar  36, 339–340

storing shapes on pasteboard  67
Style command and dialog box  144–147
styles  250–255, 379

See also formatting
applying  139–140, 142–147
basing on other styles  143
compared to local formatting  142
creating  224–227
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styles (continued)
default text, line, or fill attributes  253
deleting  364

formulas by applying  321
styles from files  253–254

duplicated style names in shapes and files  144, 252
editing  142–143, 144, 253–254
inheriting formulas from  320–321
optimizing performance with  363
preserving local formatting  146
protecting  249
referring to in ShapeSheets  316
renaming  254–255
retaining line styles in imported objects  284
saving  247
template settings  5, 23, 26, 243
text, line, and fill attributes  144–147, 252
using in ShapeSheets  321

Styles command and dialog box  177
Subdivision Spacing options  198
subdivisions, ruler  59, 68, 379
subjects of drawing files  46–47
Subscript button  35, 178, 338
subscripted text  140, 345
subselecting shapes in a group  136
subtraction operator (-)  316
Summary Info command and dialog box  46–47, 184

See also Doc Info command and dialog box
exchanging data with Lotus Notes  280
prompting for information  43

summary information  46–47, 184
prompting for  43
reading with other applications  44

Super VGA monitors  16, 32–33, 333, 361–362
Superscript button  35, 178, 338
superscripted text  140, 345
supplemental tool menu  33
switching menu and toolbar sets  11, 32, 37–38
symbols and special characters  174, 348–350
syntax in formulas  319
system configuration, optimizing  362
system requirements for OLE support  264
system resources needed for printing  359

Tab key  311
Tabs command and dialog box  147, 179, 181–182, 347
Tag Image File Format (.TIF)  282, 285
technical support  355, 356

See also the Visio online help
Template Path section in VISIO.INI file  240
templates  5, 22–23, 379

advantages of using  26
basing new drawings on  24–27
closing  47
creating  243, 247–249
deleting drawing pages from  248
designing master shapes and templates  243, 248
determining drawing size,

paper size, and scale  205–206, 207
editing originals  249
file extensions  27, 29, 248
file formats  44
opening  21, 26, 31

templates (continued)
protecting  249
saving

as read-only  31, 250
with stencils  247–248
with workspaces  45

styles in templates  143, 251
text  7–8, 167–188

See also fields; formatting; styles; text blocks
adding to groups  136, 168
aligning paragraphs  178, 179, 180–181
color

formatting  178, 180
of background  179

combined or united shapes  127, 128
connectors  96
control handle shapes  121
copying, cutting, and pasting  173
default attributes  253
editing  171–174
fields. See fields
fonts  178, 180
formatting  140, 147, 177–183, 345
freestanding text  169–170
in imported or exported files  365
inserting new text in existing text blocks  172
Lotus Notes text  279–280
margins  181, 182
master shape text  56, 168
measurements  304
moving

insertion points  172
text blocks  176

pasting into shapes  169
rewrapping in text blocks  175
rotating  168, 176–177
selecting

before editing  173
in formulas  318

ShapeSheet information  301
shortcuts  345, 347
size  178, 180, 301
special and extended characters  174, 348–350
styles  144–145, 250–253
tabs  181–182
text blocks. See text blocks
text toolbar  35, 140
toolbar  338–339
typing into shapes  56, 168

Text Background options  179, 187
Text Block command

and dialog box  147, 179, 182–183, 187, 347
Text Block Format section in ShapeSheet  301
text block tool  174–177, 337
text blocks  168, 380

See also fields; formatting; styles; text
aligning horizontally  178, 180–181
color  178, 180
connector text blocks  96
copying, cutting, and pasting  173
double-clicking master shapes to open  171
enhancing visibility  179
formatting  177–183, 345
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text blocks (continued)
freestanding text blocks  169–170
inserting fields  183–188
inserting new text in existing text blocks  172
line spacing  180–181
moving away or within shapes  176
opening  171, 346
pasting text into  169
rewrapping text  175
rotating  168, 176–177
selecting text in  171, 173
setting margins or tabs  181–183
ShapeSheet information  301
shortcuts  345
sizing  174, 175
switching between shape and text block  171
toolbar buttons  35, 140, 338–339

Text Color button  35, 178, 338
Text Field command and dialog box  185–186, 347
text fields. See fields
Text Fields section in ShapeSheet  301
text measurement systems  304
Text option  253
text size  140, 178, 180, 301
Text style list  34, 177, 178

applying all or selected style attributes  144–145
applying text formatting  178
creating new styles for  250–253

Text Style options
applying specific attributes in a style  145
Use Master’s Format option  146–147

text styles
See also formatting; styles; text
applying all or selected style attributes  144–145
creating new styles  250–253
ShapeSheet information  301

text tool  337
See also text; text blocks
adding text  7, 169–171
displaying text toolbar  178
opening text blocks  171
pasting text into shapes  169
shortcut for choosing  344
text tool menu  33

text toolbar  35, 140, 338–339
Text Transform section in ShapeSheet  301
.TIF file format  282, 285
Tightly Enclose Page’s Objects option  211
Tile button  36, 340
Tile command  40, 194, 347, 380
tiling

previewing printed drawings  216–218
print jobs  209, 215, 220–221, 380
switching between whole page and tiled view  218
viewing page breaks  218–219
windows  299, 368–369, 380

time, displaying in text fields  7, 183, 184
time functions  302
titles of files  46
titles of ShapeSheet sections  313
titling drawings  167

toolbars  31–36, 333–342, 380
edit icon toolbar  341
editing Visio objects in other applications  267
formula bar  299
print preview toolbar  342
procedure steps  17
screen resolution display differences  16, 32–33, 333
standard, SmartSuite, and Office toolbars  11, 37–38
standard toolbar  33
stencil toolbar  339–340
stencil window toolbar  36
switching between menu and tool sets  37–38
text toolbar  35, 140, 338–339

Toolbars command and dialog box  38
tools  333–342

See also buttons; toolbars
icon editing tools  236–237
missing on toolbars  31–33
shortcuts for choosing  344

ToolTips  37
Top Align button and option  70, 335
Top Align Text button  35, 178, 339
Top Distribution option  78
top ruler zero point  77
trademark symbols  348
transparent shapes  150, 169–170
trigonometric functions  302
troubleshooting  355–369

2.0 and 3.0 version files  44
cannot edit master shapes  242
cannot select shapes  204
error messages  366–367
formatting changes not evident  141
installation  357

See also the Visio installation card; the
README.TXT file in the Visio directory

OLE problems  364–365
printing problems  223, 357–360
shapes disappear from printed drawing  222
technical support  355, 356

See also the Visio online help
turning pages  30, 163, 194
two-dimensional shapes  52, 380

See also one-dimensional shapes; shapes
aligning with guide points  74
behavior  160–161
combining into new shapes  127–129
connecting automatically  89–90
control handle behavior  161
converting to one-dimensional  53, 160–161
display while dragging  55
flipping and rotating  62–65
fragmenting  127, 129–130
gluing  75, 81
moving  66–67, 157–158
selecting text blocks in  171, 174–175
sizing and resizing

with handles  111
with Size & Position options  156–157

stamping  124
two-headed arrow pointer  175, 352, 354
type measurement systems  304
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typefaces. See fonts
types of files. See file types
typing

See also text
formulas  317–318
freestanding text  169–170
placing and moving insertion points  172, 353
special characters  174, 348–350
text into connectors  96
text into shapes  7, 56, 168
zoom percentages  39

typographical measurements  304

Underline button  35, 178, 338
underlined text  140, 345
Undo button and command  35, 36, 173, 338

deleting segments from shapes  106, 109
setting number of reversible actions  369
ShapeSheet formula errors  321
shortcuts for choosing  345

undoing
See also canceling; restoring
drawn segments  108–109
master icon changes  235
mistakes  106
setting number of reversible actions  369
ShapeSheet formula errors  321
text changes  173

ungluing  91–92
Ungroup command  133

converting metafiles to shapes  290
shortcuts for choosing  345
ungrouping shapes and masters  133

uniform shape formatting  142
See also styles

uniformly spacing shapes  59, 77–78
Union command  127–128, 131
uniting shapes  127–128, 131
units of measure. See measurements; rulers
Universal connector master shape  57, 80, 380

adjusting bends  95
types of glue  83

unlocking shapes  161–162
Unprotect Document command  250
Update icon option  234
Update Page Names option  195, 196
updating

cells in ShapeSheets  303
information from other applications  260–261
instances of master shapes  58, 239, 241
linked objects  263, 275–276
links  277–279
Lotus Notes data  280
master shape icons  231, 234, 235
master shapes  241
page names  195, 196
shapes after editing styles  254

Up/Down Alignment options  70
Use Group’s Setting behavior option  137
Use Master’s Format option  146–147
Using Visio Help command  18

Values command  312
values in ShapeSheets  312, 315
vector-based applications  366
vertex. See vertices
Vertical Align button and option  70, 334
vertical alignment

of shapes  59, 70–71
of text blocks  178, 182–183

vertical alignment buttons  178
Vertical Center Distribution button and option  78, 335
vertical distribution of shapes  59
Vertical Ends Distribution button and option  78, 335
vertical flipping  62–63
vertical guides  72
vertical line spacing in paragraphs  180–181
vertical page orientation  207, 210
vertical resizing of shapes  153–155, 156–157
vertical shape alignment buttons  334–335
vertical shape distribution  59
vertical text alignment buttons  35, 339
vertices  8, 52, 296, 380

adding to shapes  113–114
changing angles of shape segments  112–113
coordinates  296, 304
deleting  114–115
gluing to  95
in segmented shapes  106, 107
magenta  112
moving  112–113
problems adding vertices to shapes  114
ShapeSheet information  301
snapping to  68

VGA monitors
checking display mode  361–362
display differences  16, 32–33

viewing
all open windows  194
changing views  39–40

shortcuts for  40, 346
typing text  168
zooming selected text  178

display problems  361–362
drawing file stencils  58
files sent by mail  291
links for a file  277–278
pages

background and foreground pages  203–204
more than one page  193–194

parts of drawings  200–201
previews of printed drawings  217
switching between whole page and tiled view  218
tiling or cascading windows  299

Visio
as vector-based application  366
closing and quitting  47
display options  37–38
Fax Information System  356
file formats  44
file summaries  46–47
file types  22–23
files from previous versions  44
glossary of terms  371–381
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Visio (continued)
help  18, 346
icons  24
installation  22

See also the Visio installation card; the
README.TXT file in the Visio directory

linking or embedding drawings into other applications
264–270

managing linked files  276–279
matching screen to manual illustrations  16, 32–33
OLE support  260–261, 264
optimizing performance  362–364
programming  10, 325–330
Quick Tour  24
saving files  42–43
saving in 2.0 format  43
shared versions  355
shortcuts  343–350
starting  24–25
technical support  355

See also the Visio online help
windows and window elements  31–37

Visio add-ons and programs
adding to program group  328
running  328–329

Visio program group  328
VISIO.INI file

adjusting settings in  367–369
listing directories for stencil files  240

Visual Basic. See Microsoft Visual Basic
.VSD extension  25, 29

See also drawing files
.VSS extension  29, 238, 245, 246

See also stencils
.VST extension  27, 29, 248

See also templates
.VSW extension  26, 29, 45, 46

See also workspaces

weights of lines  148, 301
Whole Page button and command  39, 218, 342, 345, 346
width

displaying in text fields  184, 344
line width  148
locking  162
page  210
resizing shapes with handles  110–111
resizing with Size & Position options  153–155
ShapeSheet information  300
text blocks  175

Width cell
formulas  305, 306–310
shape resizing effects  303

Width option  157
windows

activating windows  31, 228
adjusting color and size settings  368–369
adjusting in-place editing settings  369
closing  47
dragging shapes to another window  125–126
dragging to scroll drawing  40, 346
drawing file stencil window  241
edit icon window  235–237

windows (continued)
group drawing window  134–135, 137
master shape drawing window  231–232
matching manual illustrations  16, 32–33
opening

by double-clicking shapes  163
more than one drawing window  193–194
pages in new windows  194

print preview window  216–218
resizing or repositioning  40
saving arrangement as workspace  23
saving settings as a template  247
ShapeSheet window  36, 298–299, 311–312
stencil window  31, 36, 41
tiling  299, 380
viewing

all open windows  194
background and foreground pages  203–204

Visio main window and elements  31–37
Windows, Microsoft. See Microsoft Windows
Windows Bitmaps (.BMP)  282, 285
Windows Clipboard. See Clipboard
Windows Device-independent Bitmaps (.DIB or .BMP)  281,

282, 285
Windows for Workgroups buttons  16
Windows Metafiles (.WMF)

converting to groups  290
exporting drawings as  281, 285
file size implications  363
importing into Visio  281, 282
pasting into Visio  273
representations of OLE objects  271

Windows object linking and embedding. See OLE (object
linking and embedding)

Windows Program Manager  22, 24
.WMF file format  281, 282, 285

See also metafiles
workspaces  21, 23, 381

file extensions  26, 29
opening  26
saving  43, 45–46
two kinds of  45

wrapping text  175
Write To Notes option  280
writing programs  325, 327

x- and y-coordinates. See coordinates
X marks  52, 53, 71

See also beginning points; connection points

yellow backgrounds on master shape icons  58

zero points  77
Zoom box and list  34, 39
Zoom command and dialog box  39, 347
Zoom In and Zoom Out buttons  33, 39, 218, 337
Zoom Text 100% button  35, 178, 339
zooming  381

entering precise zoom percentage  39
selected text  178
shortcuts  40, 346
to change views  39–40, 346
to view previews of tiled pages  218

ZSoft PC Paintbrush Bitmap (.PCX)  282, 285



Shapeware Software License Agreement

Please read carefully before opening the disk package.

THIS IS AN AGREEMENT BETWEEN YOU AND SHAPEWARE CORPORATION. OPENING THE DISK PACKAGE INCLUDED WITH THIS
PRODUCT INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. IF YOU DO NOT AGREE WITH THEM, PROMPTLY
RETURN THE DISK PACKAGE AND ACCOMPANYING ITEMS (INCLUDING MANUALS AND BOX) TO THE PLACE YOU OBTAINED
THEM FOR A FULL REFUND.

For purposes of this license agreement, “software” refers to any and all executable files, add-ons, stencils, templates, SmartShapes, filters,
tutorials, and help files that accompany the specified version of this Shapeware product.

Grant of License for a Single Workstation

Grant of License. Shapeware grants you a non-exclusive license to load and use one copy of the specified version of the Shapeware software
contained in this package on a single designated computer. If one person uses a designated computer more than 80% of the time it is in use, then
that person may also use the software on a portable or home computer. You may not use the software on computers other than a designated
computer.

Transfer. You may transfer the software licensed under this Shapeware License Agreement to another designated computer, provided that it is
removed from the computer from which it is transferred, but not more often than once every thirty days. You will keep all documentation for the
software (including this License Agreement) at the designated computer.

Notice to Users. You shall inform all users of the software of the terms and conditions of this Shapeware License Agreement.

You may distribute print-outs and electronic files of drawings created using any of the master SmartShapes included with this Shapeware
product, but you may not permit anyone else to use any of the SmartShapes contained in the drawings for any purpose other than viewing or
modifying the drawings. You may modify or create derivatives of the master SmartShapes included with this Shapeware product for your own
use, but you may not distribute any modification or derivative of a master SmartShape included with this Shapeware product to anyone who
does not have a license from Shapeware to use the original master SmartShape.

Grant of Network License

If you are acquiring the software for use on a computer network, Shapeware grants you a non-exclusive license to load and use the specified
version of the Shapeware software contained in this package as provided below.

Computer Network Defined. A computer network is defined here as any combination of two or more computers that are electronically linked and
capable of sharing the use of a single software program.

Grant of License for Metered Concurrent Usage over a Network. You may load the software on a network and provide access such that the total
number of users who can access the software concurrently does not exceed the number of licenses you have for the software, provided there is a
software mechanism in place that monitors and controls the number of users concurrently accessing the software. The software mechanism must
have a meter capable of preventing additional users from accessing the software if the software is currently being accessed by the maximum
number of users permitted by your license(s). If a copy of the software covered under this or another Shapeware Software License Agreement is
transferred from the network server with the metering mechanism to a workstation (e.g., a laptop or a non-networked workstation), then that
workstation is assumed to have dedicated access to that copy of the software, and the number of concurrent users permitted by the meter
controlling the server access must be decreased by one.

Grant of License for Non-Metered Usage over a Network. You may load the software on a network that does not have a software metering
mechanism and permit network users to access the software, provided that the total number of workstations with access to the software on the
network does not exceed the number of licenses you have for the software. If one person uses a networked workstation with access to the
software more than 80% of the time the workstation is in use, then that person may also use the software on a portable or home computer. If a
copy of the software covered under this or another Shapeware Software License Agreement is transferred from the network server to a non-
networked workstation (e.g., a laptop or a stand-alone computer), then that workstation is a designated computer assumed to have dedicated
access to that copy of the software, and the total number of networked workstations with access to the software must be decreased by one. You
may change designated computers, but not more often than once every thirty days.

Notice to Users. You shall inform all users of the software of the terms and conditions of this Shapeware License Agreement.

Copyright

The software is owned by Shapeware Corporation and is protected by United States copyright laws and international treaty provisions. There is
no transfer to you of any title to or ownership of the software. You must treat the software like any other copyrighted material (e.g., a book or
musical recording) except that you may make one copy of the software solely for backup or archival purposes as long as you otherwise comply
with the terms and conditions of this License Agreement. You may not copy the written materials accompanying the software.



Other Restrictions

You may not rent or lease the software, but you may transfer your rights under this Agreement on a permanent basis provided you transfer this
License Agreement, the software, and all accompanying written materials and retain no copies, and the recipient agrees to the terms of this
Agreement. Any transfer of the software must include the most recent update and all prior versions. You may not modify, adapt, translate,
reverse-code, decompile, or disassemble the software, or make any attempt to discover the source code to the software.

This agreement constitutes the entire agreement between Shapeware and you and supersedes any and all prior agreements between Shapeware
and you concerning the contents of this package.

Term

This License is in effect until terminated. You may terminate it at any time by destroying the software and all copies you have made. It will also
terminate if you fail to comply with any term or condition of this Agreement. Upon such termination, you agree to destroy the software and all
copies you have made.

Limited Warranty

SHAPEWARE WARRANTS THAT THE SOFTWARE WILL PERFORM SUBSTANTIALLY ACCORDING TO THE ACCOMPANYING
WRITTEN MATERIALS FOR SIXTY (60) DAYS FROM THE DATE OF ORIGINAL PURCHASE. SHAPEWARE ALSO WARRANTS THAT THE
DISKS ON WHICH THE SOFTWARE IS FURNISHED ARE FREE FROM DEFECTS IN MATERIALS AND WORKMANSHIP, UNDER
NORMAL USE, FOR SIXTY (60) DAYS FROM THE DATE OF ORIGINAL PURCHASE.

Shapeware’s entire liability, and your exclusive remedy, shall be, at Shapeware’s option, either (1) return of the price paid, or (2) repair or
replacement of the software that does not meet Shapeware’s Limited Warranty and is returned to Shapeware with proof of purchase. This
Limited Warranty is void if failure of the software has resulted from accident, abuse, or misapplication. Any replacement software will be
warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer.

SHAPEWARE DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED (INCLUDING, WITHOUT LIMITATION, IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE), CONCERNING THIS SOFTWARE AND ITS
ACCOMPANYING WRITTEN MATERIALS. Some jurisdictions do not allow limitations on duration of an implied warranty, so the above
limitation may not apply to you. This limited warranty gives you specific legal rights. You may have others that vary by jurisdiction.

IN NO EVENT SHALL SHAPEWARE OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, BUT NOT
LIMITED TO, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR
OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THIS SHAPEWARE PRODUCT, EVEN IF
SHAPEWARE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Because some jurisdictions do not allow the exclusion or
limitation of liability for consequential or incidental damages, the above limitation may not apply to you.

U.S. Government Restricted Rights

The software and documentation are provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government are subject to
restrictions set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or
subparagraphs (c)(1) and (2) of the Commercial Computer Software—Restricted Rights at 48 CFR 52.227-19, as applicable. The contractor/
manufacturer is Shapeware Corporation, 520 Pike Street, Suite 1800, Seattle, Washington 98101-4001 USA.

This Agreement is governed by the laws of the State of Washington without reference to the 1980 UN
convention on the international sale of goods.

For more information about Shapeware’s licensing policies, please call Shapeware Product Licensing at (206) 521-4500, send a fax to Shapeware
Product Licensing at (206) 521-4501, or write: Shapeware Corporation, Attn: Product Licensing, 520 Pike Street, Suite 1800, Seattle, Washington
98101-4001 USA. For international information write: Shapeware International Ltd. 20-22 Lower Hatch Street, Dublin 2, Ireland or call +353 1
6612036. You can also send a fax attention: Shapeware International Product Licensing at +353 1 6612047.



Information in this document is subject to change without notice and does not represent a commitment on the part of

Shapeware Corporation. The software described in this document is subject to the license agreement that is included

with the product, which specifies the permitted and prohibited uses of the product. Any unauthorized duplication or

use of Visio, in whole or in part, in print, or in any other storage and retrieval system is prohibited. No part of this

publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language in

any form by any means for any purpose other than the purchaser’s personal use without express written permission of

Shapeware Corporation.

© 1994 Shapeware Corporation. All rights reserved.

Unless otherwise noted, all names of companies, products, street addresses, and persons contained herein are part of a

completely fictitious scenario or scenarios and are designed solely to document the use of a Shapeware product.

Shapeware, SmartShapes, and Visio are registered trademarks of Shapeware Corporation. Visio Shapes, ShapeSheet,  and

SmartConnectors are trademarks of Shapeware Corporation.

Adobe Illustrator and PostScript are registered trademarks of Adobe Systems, Inc. HP and LaserJet are registered

trademarks of Hewlett-Packard Corporation. Microsoft and MS-DOS are registered trademarks and Excel, Visual Basic,

and Windows are trademarks of Microsoft Corporation. Lotus Notes, SmartIcons, and SmartSuite are registered

trademarks of Lotus Development Corporation.

ImageStream Graphics Filters for AI/EPS, BMP, CGM, DXF, PCX, PICT, and TIFF formats copyright © 1994

ImageMark Software Labs, Inc. All rights reserved.

Some of the clip art used in this product is derived from images copyrighted ©1988-1994 3G Graphics, Inc. from their

IMAGES WITH IMPACT!® FOR WINDOWS™ Vol 1. These images are used here under a non-exclusive licensing

agreement between Shapeware Corporation and 3G Graphics, Inc., 114 Second Ave. South, Suite 104, Edmonds, WA

98020, USA.

The maps incorporated into this product are derived from images copyrighted by Cartesia Software. These images are

used here under a non-exclusive licensing agreement between Shapeware Corporation and Cartesia Software, P.O. Box

757, Lambertville, NJ 08530, USA.

Shapeware Corporation Shapeware International Limited

520 Pike Street, Suite 1800 20-22 Lower Hatch Street

Seattle, Washington 98101-4001 Dublin 2

USA  Ireland

For information about technical support and other Shapeware customer support services, including developer support

and worldwide support, see Technical support in the Visio online help.
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