
QuickStart To learn about a MediaPlus feature, click the corresponding topic at left 

 
To learn about MediaPlus tools and menus, simply move the mouse pointer around the workspace and watch the HintLine at the 
bottom of the screen for capsule descriptions. And don't forget to register your new copy, using the Serif Registration Wizard. 
That way, we can keep you apprised of new developments and future upgrades.



Selecting a screen layout

Especially when working with limited screen space, it's useful to display only the windows you actually need for the task at hand, 
and hide the ones that aren't essential. The Screen Layout dialog lets you select a starting arrangement suited to the task at 
hand. A typical screen layout consists of two or three tool windows (the Browser, Explorer, and/or Preview windows) docked at 
the edges of the workspace, and a central background region reserved for one or more album windows. 

                 

What's the difference between tool windows and album windows? Tool windows work like toolbars: they can either dock at the 
screen edge or float independently. Albums are MediaPlus documents that let you organize your media files. Album windows only 
float, so they can overlap each other or tile—but only within the region that's not occupied by docked tool windows. When you first 
open MediaPlus, the album region shows the contents of a Sample album.

Once you've chosen a starting layout, you can adjust windows individually as needed, and MediaPlus will "remember" your 
screen layout from one session to the next. You can adjust refine your MediaPlus environment even further using global program 
settings stored as preferences.

To select a starting screen layout:

1 Click the  Screen Layout button, press Ctrl+L, or choose Screen Layout... from the View menu.

2 In the dialog, select the basic layout that best fits your current task and screen size. All the layouts provide a region for working 
with MediaPlus albums. The diagrams below are color-coded and labeled to show which windows are available in each layout.
(E = Explorer      P = Preview      B = Browser      A = Album region)

 

Full View
All the windows are available in this layout, for maximum 
versatility. If screen size isn't an issue, this layout will serve you 
well in any situation.

 

Explore+Browse
This layout is geared for file management and album building. 
There's no Preview window, but you can still use fullscreen view to 
preview individual images.

 

Explore+Preview
Ideal for downloading Web files or digital camera images into new 
albums. You can preview images, but there's no Browser window. 

 

Preview Only
Choose this layout when you are simply working with MediaPlus 
albums. There's plenty of space to open multiple albums!

3 Check Show Information to display the floating Information window, which provides detailed data on image and multimedia 
files. (You can show and hide this window at any time by pressing Ctrl+I.)

4 Click OK when you're done.

Adjusting windows individually
To move a window:

n Drag the  move handle (on a docked window) or the title bar (on a floating window) to another location. 
Note: To keep a floating window from docking when you move it, press the Ctrl key while dragging.

To resize a window:

n Drag from a window edge or an album window corner.

n To maximize an album window within the background region, click its  Maximize button. To minimize it, click its 



 Minimize button. To restore the window in either case, click its 

 Restore button. 
n To arrange album windows within the background region, choose Tile Album Windows from the View menu.

Note: The Sample album initially appears maximized, so you don’t see its titlebar. To view the titlebar and control buttons, use 
the Tile Album Windows command.

To dock a tool window:

n Move it to the edge of the workspace or next to another docked window. Watch the outline to see where the window will end 
up. 

To float (detach) a docked tool window:

n Ctrl-click its move handle (the outline will contract to a small square), then drag to another location. Release the mouse button 
first to ensure the window stays undocked.
Note: You can also simply drag the window to a neutral location and hope that it floats—but using the Ctrl key ensures more 
predictable results.

n To cancel any move in mid-drag, press the Esc key.

n You can also double-click a window’s move handle to toggle between the docked and undocked states.

To close (hide) a window:

n Click its  Close button.

OR
n Uncheck the window name on the View menu.

Remaining tool windows adjust automatically.

To show a hidden window:

n Use the Screen Layout dialog (View/Screen Layout...) as described above.

OR
n Check the window name on the View menu.



Browsing and managing media files

The Explorer window and the Browser window (see Selecting a screen layout) make it easy to locate images and other media 
files stored in folders on local or network drives. Simply select any folder to view a thumbnail catalog—a set of small pictures 
representing the media files it contains. (For details on media file formats, see the Media format reference.) 

                 

This topic tells you how to manipulate Browser thumbnails to preview media content, view file properties, and carry out file 
operations like Move, Copy, and Delete (see the quick reference below). And to optimize your working view, be sure to check out the 
tips on arranging thumbnails! For in-depth coverage of other ways you can use thumbnails, see Building albums, Printing, Delivering 
a slideshow, Publishing Web galleries, and Making wallpaper and screensavers.

To display a thumbnail catalog of the media files in a folder:

1 Display the Browser window.

2 Navigate to the folder using any of these methods:

n Display the Explorer window and select the Folders tab, then select the folder name from the hierarchical "tree" view. 

n Select a folder or file you've previously added to the Explorer window's Favorites tab (see below).

n Click the  Back and 

 Forward buttons on the Standard toolbar to navigate through the visited folder sequence, or click the 

 Up button to move up through the folder hierarchy.
n Type the folder's full path into the Address toolbar and press Enter. You can also click the toolbar's down arrow button and 

select any previously visited folder from the drop-down list.

n Right-click a thumbnail in an open album window and choose Browse to Folder.

See the section on "Working with thumbnails" below for tips on manipulating thumbnails in the Browser folder.

To preview an image file:

n Display the Preview window and select the file's thumbnail. The image appears in the Preview window.

OR

n Right-click the file's thumbnail and choose View Fullscreen. (You can also click the  View Fullscreen button or choose 
View Fullscreen from the Actions menu.) The image appears in fullscreen view.

For full details, see Previewing content.

To preview a multimedia (sound or movie) file:

n Double-click the file's thumbnail.

The sound or movie plays in the default application.

Hint: You can press the arrow keys to step through the thumbnails in a window.

To view file properties:

n Display the Information window (press Ctrl+I or check the item on the View menu), then select the file's thumbnail. MediaPlus 
file data appears in the Information window. 

OR
n Right-click the file's thumbnail and choose Properties.... Standard Windows file data appears.

Note: You can annotate thumbnails that you've added to albums, but not to those that appear in the Browser window. For details, 
see Viewing and adding file information.



To add a file or folder to your MediaPlus Favorites list:

1 Right-click a thumbnail in the Browser window.
OR
Select a thumbnail and choose Favorites from the Edit menu, displaying the submenu.

2 To add the media file as a favorite, choose Add File(s) to Favorites.
OR
To add the folder as a favorite, choose Add Folder to Favorites.

3 Use the dialog to specify where to add the favorite.

The Explorer window's Favorites tab displays a shortcut to the file or folder you added. For details, see Managing MediaPlus 
favorites.

To select one or more media files:

n Click a single file's thumbnail to select it.

n Ctrl-click to select multiple files, or Shift-click to select a range of files.

n Press Ctrl+A to select all thumbnails in the window, and Ctrl+D to deselect all. (Or choose Edit/Select All or Edit/Select 
None.)

n Choose Invert Selection from the Edit menu to toggle the state of all thumbnails in the window. Selected thumbnails are 
deselected, and vice versa.

To catalog one or more media files in a MediaPlus album:

1 Open the album window.

2 Select the file thumbnail(s). (See above for the various selection options.)

3 Drag the thumbnail(s) into the album window and drop when you see the  cursor.

New thumbnail(s) in the album window appear as shortcuts to the selected file(s).

Note: You can also use the Copy and Paste into Album commands from the Edit menu. For details, see the next topic, Building 
albums.

Managing media files

 

Thumbnails that appear in the Browser window (unlike those 
that appear in albums) are not shortcuts to the file—they 
represent the file itself. In fact, you can think of them as pictorial 
equivalents of the file name, and so any operation you carry out 
on a Browser thumbnail takes effect on the file. This extra 
convenience also means you should be extra careful when 
manipulating Browser thumbnails!

To perform an operation on one or more media files:

n Select the file thumbnail(s) and choose a command from the Edit menu, Standard toolbar, or right-click menu.

Note: You can also hold the Shift key down and right-click on a selected thumbnail to display the standard Windows submenu, 
which offers some additional options. (Be sure to select the thumbnail first.)

Here's a quick summary of file operations you can carry out in the Browser window, showing toolbar buttons, menu commands, 
and shortcuts where applicable.  denotes that the item is also available from the thumbnail's right-click menu. 

 denotes the command works on original files via album windows as well. 
Using drag and drop
To move one or more files, drag their Browser thmbnail(s) into a folder on 
the Explorer window’s Folders tab (or Windows Explorer). Ctrl-drag to 
copy. Dragging an album thumbnail into a folder or the Browser window 
copies the file.

Edit/Cut       (Shortcut: Ctrl+X)
In the Browser window, marks the selected file(s) for deletion. The action is 
completed if a valid Paste command (for example, Paste into Current 
Folder or pasting into Serif PagePlus) is received. Otherwise, the file(s) will 
remain intact. 

Edit/Copy      (Shortcut: Ctrl+C)
In the Browser window, copies the selected file(s) to the Clipboard. 

Edit/Paste into Current Folder (Shortcut: Ctrl+Shift+D)
Inserts one or more file(s) from the Clipboard into the Current Folder, as 
displayed on the Folders tab and in the Browser window. Completes a 



previously issued Cut command.
Note: Use the Paste into Album and Paste into New Album commands 
(see the next topic) to place a thumbnail for a file into an album.

Edit/Delete File(s)        (Shortcut: Delete)
In the Browser window or an album window, deletes the selected original 
file(s) and thumbnail(s).
Note: To bypass the Recycle Bin, press Shift+Delete. In an album window, 
use Edit/Delete Thumbnail(s) to delete just an album thumbnail, not the 
file. 

Edit/Rotate>    (Shortcuts: Left: Ctrl+[, Right: Ctrl+])
Select the desired rotation (Left, Right, or 180) from the submenu to turn 
the selected original file(s). 
Note: This action affects the original file(s), whether issued from the 
Browser or an album window.

Edit/Flip>      
Select Horizontal or Vertical from the submenu to reverse the selected 
original file(s).
Note: As for Rotate (see above), this action affects the original file(s), not 
just the thumbnail.

Arranging thumbnails
MediaPlus thumbnails are designed to help you make the most of your screen space. When you mouse over a thumbnail, the 
file's format and dimensions appear in a popup tip. You can easily adjust the size of displayed thumbnails, sort the thumbnails 
according to various attributes (file name, size, etc.), and/or rearrange the sequence of specific thumbnails. These changes to 
the thumbnails don't affect the original media files.

To change the size of displayed thumbnails:

1    Hover the mouse pointer over any thumbnail until you see a 
small drag handle in the thumbnail's lower right corner.

2    Drag the handle in or out to adjust the thumbnail to a desired 
size.

3    Release the mouse button. All thumbnails in the window will 
adjust to the indicated size.

To sort all thumbnails:

1 Right-click any thumbnail and choose Sort. 
OR
Choose Sort from the Edit menu.

2 Choose an attribute and the sort order (Ascending or Descending) from the submenu.

To rearrange the thumbnail sequence:

n Select one or more thumbnails and drag 
to a new location in the window. 
Adjacent thumbnails shrink slightly to 
help you locate the "drop zone."

Note: Using File/General Preferences..., you can customize which file information appears in Browser tips and thumbnail 
captions, or set thumbnail size quantitatively. The Misc tab also includes global settings for thumbnails derived from animated 
media types (such as GIF and MPEG), and lets you customize which file types are shown. For example, you can switch off 
display of sound files if you like.



Building albums

An album is a collection of thumbnails saved as a separate MediaPlus document. While the Explorer and Browser windows (see 
the previous topic) let you view the actual media files stored in single folders, album thumbnails are shortcuts to media files. To 
create a shortcut, you simply drag from a Browser window thumbnail into an album window. One album can catalog files stored 
in diverse locations, and the same file can be represented in any number of albums! Albums are a great way to organize your 
media files into categories and groupings and categories that make sense to you, without moving the actual files around. 

                 

This topic covers all the basics of MediaPlus albums, in four general sections (click to jump to a section):

Working with album windows 

Working with album thumbnails 

Working with media files via album windows 

Locating a folder from an album thumbnail 

Album thumbnails are shortcuts, but you can use them just like Browser window thumbnails to preview media content, view file 
properties, and delete original files you no longer need. For in-depth coverage of other things you can do with both Browser and 
album thumbnails, see Printing, Delivering a slideshow, Publishing Web galleries, and Making wallpaper and screensavers.

Albums have some unique advantages, too. They're ideal for storing digital camera (TWAIN) images or media you've collected 
from the World Wide Web using MediaPlus. You can annotate album thumbnails with keywords and other descriptors. And you 
can use the Explorer window's powerful Search function across multiple albums to locate files that meet specific criteria—
including annotations you've added as comments!

Working with album windows
Each MediaPlus album file is a document stored in Serif's .SMA format. Initially, MediaPlus displays a window for the sample 
album, Sample.sma.

To create a new album:

n Choose New... from the File menu.

OR
n Copy one or more thumbnails to the Clipboard and choose Paste into New Album from the Edit menu. This creates a new 

album containing the copied thumbnail(s).

Note: When downloading, acquiring TWAIN images, or searching, you'll also have the option of creating a new album to catalog 
the retrieved items.

To open an existing album:

n Choose Open... from the File menu.

OR
n Select an album you've previously added to the Explorer window's Favorites tab (see below).

OR
n Browse to the folder where the album is located, and double-click its thumbnail in the Browser window.

To close an open album:

n Click its  Close button.

OR
n Choose Close from the File menu.

You'll be prompted to save changes, if any.

To save an album:



n Choose Save... from the File menu. (Choose Save As... to save under a different name.)

Hint: Consider saving your albums into a common folder. Not only will this make opening them more convenient, but you can 
perform a search across all the albums in a folder in a single pass.

You can have one or more albums open at a time in the rectangular, background region of the workspace. The actual number of 
album windows you can work with comfortably depends on the number of docked tool windows you have open, and of course on 

your monitor's screen area setting. Use the  Screen Layout button (see Selecting a screen layout) to optimize the 
arrangement of windows for the task at hand. For example, if you've opened an album but can't see its window, you may need to 
move one or more tool windows out of the way.

To work with a particular open album:

n Click its window or choose the album's name from the View menu.

To arrange the open album windows:

n Drag a window's edges to resize it individually, or drag its titlebar to move it. 

OR
n Choose Tile Album Windows from the View menu.

Note: The Sample album initially appears maximized, so you don’t see its titlebar. To view the titlebar and control buttons, use 
the Tile Album Windows command.

To add an album to your MediaPlus Favorites list:

1 Right-click in the album window.
OR
Choose Favorites from the Edit menu, displaying the submenu.

2 Choose Add Album to Favorites.

3 Use the dialog to specify where to add the favorite.

The Explorer window's Favorites tab displays a shortcut to the album you added. For full details, see Managing MediaPlus 
favorites.

To enter custom information for an album:

n Choose Album Details... from the File menu and type into the "Title," "Author," and/or "Notes" fields.

The data you enter is stored along with the album.

Working with album thumbnails

 

Unlike thumbnails in the Browser window (see the 
previous topic), album thumbnails are shortcuts. You can 
use album thumbnails to annotate a media file using 
descriptors and keywords. Otherwise, both kinds of 
thumbnails work in much the same way.

To select one or more thumbnails:

n Click a single thumbnail to select it.

n Ctrl-click to select multiple thumbnails, or Shift-click to select a range of thumbnails.

n Press Ctrl+A to select all thumbnails in the window, and Ctrl+D to deselect all. (Or choose Edit/Select All or Edit/Select 
None.)

n Choose Invert Selection from the Edit menu to toggle the state of all thumbnails in the window. Selected thumbnails are 
deselected, and vice versa.

To catalog media files or add thumbnails to a MediaPlus album:

1 Open the destination album window.

2 In the Browser window, select the media file thumbnails. 
OR
In a different album window, select exsiting album thumbnail(s). 
(See above for the various selection options.)

3 Drag the thumbnail(s) into the destination album window and drop when you see the  cursor.



Here's a quick summary of basic operations involving album thumbnails (see below for commands that affect original files).  
denotes that the item is also available from the thumbnail's right-click menu.

Using drag and drop
Dragging from the Browser window creates a new thumbnail shortcut to the 
original media file; it doesn’t disturb the original file. Dragging from one 
album window to another moves the thumbnail; to copy a thumbnail 
between albums, hold down the Ctrl key while dragging. Dragging an 
album thumbnail into the Browser window (or a folder on the Explorer 
window’s Folders tab) copies the original file to that folder.

Edit/Cut (Shortcut: Ctrl+X)
In an album window, deletes the selected thumbnail(s) and places a copy 
on the Clipboard.

Edit/Copy (Shortcut: Ctrl+C)
In an album window, copies the selected thumbnail(s) to the Clipboard. 

Edit/Paste into Album (Shortcut: Ctrl+V) 
Inserts one or more album thumbnail(s) from the Clipboard into the 
selected album window. As noted above, you can also select the 
thumbnail(s) and drag into an album window while holding down the Ctrl 
key.
Note: If you've copied a file from the Browser window, Paste into Album 
adds an album thumbnail, not a copy of the file.

Edit/Paste into New Album (Shortcut: Ctrl+Shift+V)
Creates a new album window and inserts one or more album thumbnail(s) 
from the Clipboard into the new window. 

Edit/Delete Thumbnail(s)      (Shortcut: Delete)
In an album window, deletes the selected thumbnail(s), not the original 
files.
Note: In the Browser window, pressing Delete is the same as Edit/Delete 
File(s).

 

Note: If an album thumbnail points to an original file that 
you’ve moved or deleted since the album was built, you’ll 
see a "broken link" symbol in its place. It’s up to you to 
remove these broken thumbnails by hand using Delete.

MediaPlus thumbnails are designed to help you make the most of your screen space. When you mouse over a thumbnail, the 
file's format and dimensions appear in a popup tip. You can easily adjust the size of displayed thumbnails, sort the thumbnails 
according to various attributes (file name, size, etc.), and/or rearrange the sequence of specific thumbnails. These changes to 
the thumbnails don't affect the original media files.

To change the size of displayed thumbnails:

1    Hover the mouse pointer over any thumbnail until you see a 
small drag handle in the thumbnail's lower right corner.

2    Drag the handle in or out to adjust the thumbnail to a desired 
size.

3    Release the mouse button. All thumbnails in the window will 
adjust to the indicated size.

To sort all thumbnails:

1 Right-click any thumbnail and choose Sort. 
OR
Choose Sort from the Edit menu.

2 Choose an attribute and the sort order (Ascending or Descending) from the submenu.

To rearrange the thumbnail sequence:



n Select one or more thumbnails and drag 
to a new location in the window. 
Adjacent thumbnails shrink slightly to 
help you locate the "drop zone."

Note: Using File/Album Preferences..., you can customize which file information appears in album tips and thumbnail captions, 
or set thumbnail size quantitatively.

Working with media files via album windows
You can use album thumbnails them just like Browser thumbnails to preview media content, view file properties, and delete original 
files you no longer need. In addition, you can annotate album thumbnails with keywords and other descriptors.

To preview an image file:

n Display the Preview window and select the file's thumbnail. The image appears in the Preview window.

OR

n Select the file’s thumbnail and click the  View Fullscreen button (or right-click the thumbnail and choose View 
Fullscreen). The image appears in fullscreen view.

For full details, see Previewing content.

To preview a multimedia (sound or movie) file:

n Double-click the file's thumbnail.

The sound or movie plays in the default application.

Hint: You can press the arrow keys to step through the thumbnails in a window.

To view file properties:

n Display the Information window (press Ctrl+I or check the item on the View menu), then select the file's album thumbnail. 
MediaPlus file data appears in the Information window. Annotations you've added (see below) appear on the window's 
Comments tab.

To annotate a file using descriptors and keywords:

n Right-click the file's album thumbnail and choose Add Comments.... 

OR
1 Select the album thumbnail.

2 Click the  Add Comments button or choose Add Comments... from the Actions menu. 
OR
Display the Information window's Comments tab and click the 

 Add Comments button.
For details on adding file comments, see Viewing and adding file information. See Searching albums and folders for coverage of 
the Explorer window's Search function, which helps you locate files based on comments and other criteria.

To add a media file to your MediaPlus Favorites list:

1 Right-click a thumbnail in the album window.
OR
Select a thumbnail and choose Favorites from the Edit menu, displaying the submenu.

2 Choose Add File(s) to Favorites.

3 Use the dialog to specify where to add the favorite.

The Explorer window's Favorites tab displays a shortcut to the file you added. For full details, see the next topic.

Although album thumbnails are shortcuts, you can carry out certain file operations in album windows just as you can in the 
Browser window (see the previous topic). Here's a summary of file operations you can carry out on selected album thumbnails. 

 denotes that the item is also available from the thumbnail's right-click menu.

Edit/Delete File(s)      



In the Browser window or an album window, deletes the selected original 
file(s) and thumbnail(s).
Hint: To bypass the Recycle Bin, press Shift+Delete.

Edit/Rotate> (Shortcuts: Left: Ctrl+[, Right: Ctrl+])
Select the desired rotation (Left, Right, or 180) from the submenu to turn 
the selected original file(s). 
Note: This action affects the original file(s), whether issued from the 
Browser or an album window. If an original image is read-only (as on a CD-
ROM) you'll be prompted to save the rotated image file elsewhere. 

Edit/Flip>
Select Horizontal or Vertical from the submenu to reverse the selected 
original file(s).
Note: As for Rotate (see above), this action affects the original file(s), not 
just the thumbnail.

 

Locating a folder from an album thumbnail
A single album can catalog files that are stored in diverse folder locations. Because the Explorer window's Folders tab and the 
Browser window operate independently of album windows, it's common for the various views to be "out of sync." But suppose 
you've located an interesting album thumbnail, and then want to view other media files that are stored in that particular file's parent 
folder (but which may not be included in the current album). Here's a convenient method of "browsing backwards" from an album 
thumbnail.

To locate the folder that contains a particular media file:

n Right-click the file's album thumbnail and choose Browse to Folder.

The "tree" on the Explorer window's Folders tab displays the file's parent folder (also shown as a path on the Address bar), and 
the Browser window displays thumbnails for the media files in the folder. Note: This is just a temporary correspondence; the 
Browser and album views will continue to operate independently of one another. 



Managing MediaPlus favorites

The Explorer window's Favorites tab lets you store shortcuts to media files, folders, and albums. For browsing sources you use 
frequently, it's a convenient alternative to the Folders tab. 

To add a media file, folder, or album to your MediaPlus Favorites list:

1 Right-click a thumbnail in the Browser or album window.
OR
Select one or more thumbnails and choose Favorites from the Edit menu, displaying the submenu.

2 Choose Add File(s) to Favorites, Add Folder to Favorites, or Add Album to Favorites.

A dialog appears displaying the contents of the MediaPlus Favorites folder. 

3 If you wish, you can type a different name for the item. The Create in button expands the view to let you add subfolders if you 
wish (by clicking New Folder...). Click as needed to open the folder where you want to add the favorite.

4 When you're done, click OK.

An icon representing a shortcut to the file, folder, or album appears on the Favorites tab.

5 If you selected multiple thumbnails, you'll be prompted again for each file (repeat steps 3 and 4).

To browse or view albums using MediaPlus Favorites:

1 Display the Browser window (and the Preview window, if previewing images).

2 Display the Explorer window and select the Favorites tab.

3 Select the file, folder, or album shortcut (click  in the "tree" as needed to open subfolders). 

When browsing to a file or folder, the contents of the Browser and Preview windows update just as if you'd browsed via the 
Folders tab. The file appears selected in the Browser window and its parent folder becomes selected on the Folders tab and 
address bar. Clicking an album shortcut opens the album window (or if already open, it becomes the selected album).

You can prune or rearrange the subfolder "tree" as needed. 

To reposition an item in the MediaPlus Favorites list:

n Drag it up or down as needed.

To organize MediaPlus Favorites:

1 Choose Favorites from the Edit menu (the Favorites tab need not be selected) and select Organize Favorites.... 

2 In the dialog's right-hand list, you can click folder icons to display their contents and select individual items.

3 Click Rename, Move to Folder..., or Delete to carry out an operation. Click Create Folder... to create a new subfolder. 

4 When you're done, click Close.

Note: Items you move up or down in this dialog won’t be updated in the MediaPlus Favorites list.



Previewing content

It's easy to preview images or multimedia (sound or movie) files via their thumbnails in either the Browser window or an album 
window. You can preview images either in the Preview window or in fullscreen view.

                 

To preview a multimedia file:

n Double-click the file's thumbnail in either the Browser window or an album window.

The sound or movie plays in the default application, such as Windows Media Player.

To preview an image in the Preview window:

n Display the Preview window. (See Selecting a screen layout for details on how to hide, show, and arrange the various 
MediaPlus windows.)

n Click the image thumbnail.

If more than one thumbnail is selected, only the most recently selected image appears in the Preview window.

To set the scaling of images in the Preview window:

n To display each image within the window's boundaries, click Auto Fit. You can also right-click the preview image and choose 
Auto Fit.
Note: When using Auto Fit, you can right-click the image and check Restrict to Full Size so larger images will shrink to fit but 
smaller images won't expand beyond their 100% size. If unchecked, all images will scale to fit the window.

OR
n To display each image at a fixed percentage, click Set Scale and adjust the slider to the desired factor (up to 200%). The 

adjustment factor will apply to each preview image. Images that are larger than the window will extend beyond it. 
Note: You can also right-click the preview image and choose Double Size, Full Size, Half Size, or Quarter Size to set a 
specific scaling factor. If a preview image is larger than the window, you can drag it (using the hand cursor) to pan the image in 
the window. 

Fullscreen view
Even if the Preview window isn't open, you can preview one or more images (or the entire contents of the Browser window or an 
album window) in a fullscreen view—essentially a slideshow under manual control, without preset transitions and timing.

To preview one or more images in fullscreen view:

1 If previewing a subset of images, first select their thumbnail(s). Ctrl-click to select additional thumbnails, or Shift-click to select 
a range including the initial selection.

2 Click the  View Fullscreen button. The button is context-sensitive, so if you have any thumbnails selected it will assume 
those are the ones you want to see. If none are selected, it will include the entire contents of the last window you were working 
in.
OR
Right-click in the window and choose View Fullscreen. If you click on a selected thumbnail, you can choose All (for the entire 
contents of the window) or Selected.
OR
Choose View Fullscreen from the Actions menu and choose From Selection..., From Folder... or From Album... on the 
submenu. From Folder means the current contents of the Browser window. If you have more than one album window open, 
From Album... will show the contents of the selected album.

The screen displays the first image in fullscreen view.

To control images in fullscreen view:

n You can right-click the preview image and choose Double Size, Full Size, Half Size, or Quarter Size to set a specific scaling 
factor, or choose Auto Fit to display all images within the screen area. 
Note: When using Auto Fit, you can also check Restrict to Full Size so larger images will shrink to fit but smaller images 



won't expand beyond their 100% size. If unchecked, all images will scale to fit the screen.

n When previewing multiple images, press the right arrow key to step forward through the sequence, or the left arrow key to step 
back. You can also right-click and choose Next or Previous.

n To exit fullscreen view, press the Esc or Enter key or right-click and choose Close.



Viewing and adding file information

The Infomation window provides detailed data on image and multimedia files. You can also annotate album thumbnails with 
keywords and text comments, and optionally include the descriptors when publishing a Web gallery or printing. The Explorer 
window's Search tab (see the next topic) lets you seek across multiple albums or folders to locate files that meet specific criteria
—including comments you've added to album thumbnails.

The Information window is designed to "float" all the time, rather than dock. This means you can bring it up whenever it’s 
needed, move it around onscreen, and put it away when you’re done with it.

You can also enter custom information for each MediaPlus album.

To view properties for a media file:

1 Display the Information window (press Ctrl+I or check the item on the View menu).

2 Select the file’s thumbnail in either the Browser window or an album window. 

OR
n To display standard Windows file data without using the Information window, right-click a thumbnail in the Browser window and 

choose Properties. 

Note: Using the Preferences settings, you can also customize tooltips in the Browser and album windows so they reveal 
additional information about files as you move the mouse over thumbnails.

The Information window displays MediaPlus file data for the currently selected thumbnail using three tabs: File, Image, and 
Comments. The Comments tab only appears for album thumbnails, and displays descriptors you’ve added. 

To annotate a file using descriptors and keywords:

n Right-click the file’s album thumbnail and choose Add Comments....

OR
1 Select the album thumbnail.

2 Click the  Add Comments button or choose Add Comments... from the Actions menu. 
OR
Display the Information window’s Comments tab and click the 

 Add Comments button.
The Add Comments dialog appears.

n To add descriptors, type into the "Caption," "Author," and/or "Notes" fields. Type Ctrl+Enter to insert a line break.

n To include a date (for example, identifying when a photo was taken), check the box in the "Date" field. Click the down arrow 
button and use the calendar to select a date, or click Today to assign today’s date. If you don’t want to include a date, 
uncheck the box.

n To add a new keyword, click <new keyword>, then type the word and click or press Enter. Keywords you assign are 

automatically compiled into a master list. To add a keyword from your list, click the  Add Keywords from List button and 
select the keyword(s) to apply (use the Ctrl key for separate keywords, or the Shift key for a range), then click 

 OK. Note: You can delete a word from your keyword list by selecting it and clicking the 

 Delete button.

To enter custom information for an album:

n Choose Album Details... from the File menu and type into the "Title," "Author," and/or "Notes" fields.

The data you enter is stored along with the album.



Searching albums and folders

The Explorer window’s Search tab lets you examine the contents of one or more albums or folders to locate media files that 
meet specific criteria—which can include descriptors and keywords you’ve added as comments to album thumbnails. (For details 
on adding file information, see the previous topic.)

To conduct a search:

1 Display the Explorer window and select the Search tab.

2 To search media files cataloged in open albums, first make sure one or more albums are open, then select Search Open 
Albums.
OR
To search media files in a folder (and optionally within its subfolders and/or albums), select Search Folders.

3 If searching more than one open album, select the specific albums from the list. (Ctrl-click to select separate albums, or Shift-
click to select a range.)
OR

For a folder search, specify the folder where you want to begin the search. (Click the  Browse button if necessary.) 
Besides searching media files in the starting folder, you can check options to include Subfolders and/or MediaPlus Albums 
within that folder. 
Note: Albums searched within folders don’t need to be open! This search method is especially powerful if you’ve stored 
multiple albums in a single folder.

4 Click the  Search Criteria button and use the dialog to specify the properties of files you want to find. Note that when you 
search albums, you can enter specific text to find in the Comments associated with the thumbnails.

Options include:

Text in filename Type the text (which can be all or part of the filename) 
you want to locate. 

File attributes To specify minimum and/or maximum values, check Min 
and/or Max and enter a cutoff value.

Format restrictions To restrict files to certain formats, click the Formats... 

button. In the dialog’s "file tree," click  to expand a 
category and view subsidiary items. Click any item to 
place a  to include, or  to exclude, that item and all 
its subsidiary items.

Creation date Check From and/or To and select cutoff date(s).

Comments 
    (Album search only)

Check Search for text, then type the text to search for 
and check which descriptor fields to include. 
OR
Check Search for keywords, then type keywords 
(separated by commas) or click the View Keywords 
button to select keywords from the master list.

5 When you’re done entering search criteria, click OK.

6 To create a new album to store the search results, select New album.
OR
To output the search results as new thumbnails in one of your open albums, select Existing album and (if necessary) choose 
the album name from the list.

7 Click Start to begin the search. 

8 The progress bar displays how the search is proceeding. (If you need to halt an incomplete search for any reason, click Stop.)

Thumbnails for all files found that meet your criteria appear in the designated album window.



Importing digital (TWAIN) images

If your digital camera or scanner supports the industry-wide TWAIN standard, you can bring pictures from these devices directly 
into MediaPlus, with the option of creating a new album for the imported image(s). Then you can use the Browser window or 
album windows to preview the images and carry out file operations—like weeding out unwanted images or rotating pictures for 
correct orientation. 

To set up your TWAIN device for importing:

n See the documentation supplied with the device for operating instructions. 

If you have more than one TWAIN-compatible device installed, you may need to select which source you wish to import from. 

To select a different TWAIN source:

n Choose Import from the File menu, then select Select TWAIN Source... from the submenu.

To import TWAIN images:

1 Choose Import from the File menu, then select File Settings... and use the dialog to specify a preferred location, filename 
prefix, and format for the imported images. 

· Use the  Browse button if necessary to locate a specified directory. 
· The imported file(s) will be named using the prefix you specify, plus sequential numbers as needed.
· Check New Album to create a new album with thumbnails for the imported images, or uncheck the box to import without 
creating an album.
· If you’re saving into a folder that already contains images, there’s a chance that a newly imported image’s generated name 
may duplicate an existing filename. To address this possibility,    check Don’t overwrite old files to create a different name for 
the imported image, or uncheck the box to approve replacement of existing files. 
Note: You can bypass this step to use your previous TWAIN import settings, or to accept the default MediaPlus settings.

2 Click the  TWAIN Acquire button on the Standard toolbar.
OR
Choose Import from the File menu, then select Acquire.... 

3 Complete the image acqusition process using the dialog associated with your selected TWAIN source.



Downloading Web media

The Explorer window’s Download tab automates the process of gathering media files from Web pages while assuring you full 
control over the end results. Downloading happens in three basic stages. Once you’ve set Preferences for the search and a 
target page, MediaPlus begins Exploring, following links outward from that starting page. Meanwhile, it builds a page queue—a 
list of pages remaining to be explored—and a file queue—a list of every media file it finds that meets the criteria you’ve set. The 
third stage is Collecting: bringing the files back home to your computer. 

We’ll cover each stage in turn. (Click a stage to jump to that section of the instructions.)

A    Selecting preferences 

B    Exploring pages 

C    Collecting files

Stage A: Selecting preferences
In this stage, you tell MediaPlus where to start the search, how wide a net to cast (the "search depth"), which criteria to use in 
selecting media files, where to store the downloaded files, whether to pause between the Exploring and Collecting stages, and 
so on.

1 Display the Explorer window and select the Download tab.

2 Enter the URL of the target page where you want to begin searching. You can type the Web address, click the  Favorites 
button to insert an address from your Internet Explorer Favorites list, or paste (Ctrl+V) a URL from the Clipboard. (For 
example, if you’re already viewing the target page in your Web browser, you could simply copy and paste its address here.)

3 Specify the folder where you want to store the files to be downloaded. Type the path or click the  Browse button to locate 
the destination folder.

4 Select the Options tab and review preferences for the search.

· Depth. This setting tells MediaPlus how many links away from the target page it should search. For example, if you set a 
depth of "0," only the target page will appear in the page queue. A depth of "1" will include the target page plus pages one link 
away from it, and so on.

· Filter. Check this box to include or exclude certain media files based on file attributes. Click the  Search Criteria button 
to set attributes. Options include:

Text in filename Type the text (which can be all or part of the filename) 
you want to locate. 

File attributes To specify minimum and/or maximum values, check Min 
and/or Max and enter a cutoff value.

Format restrictions To restrict files to certain formats, click the Formats... 

button.    In the dialog’s "file tree," click  to expand a 
category and view subsidiary items. Click any item to 

place a  to include, or  to exclude, that item and 

all its subsidiary items. For example, simply placing  
next to "Animation files" is enough to exclude all the file 
types listed under that category:

Creation date Check From and/or To and select cutoff date(s).

· Don’t leave server. Check this box to include only pages on the same server as the target page. This helps to restrict the 
search to a particular Web site and avoids getting diverted to externally linked pages.
· Pause before collecting. Check this box if you want to pause the downloading process between the Exploring and 
Collecting steps (see details below). Pausing gives you extra time to review the list of files located by MediaPlus before 
actually downloading them. If the box is unchecked, Exploring and Collecting happen concurrently concurrently.

5 Select the Save tab and review preferences for local storage.

· Preserve hierarchy. Check this box to have MediaPlus save files using a separate folder for each server it visits, with 
subfolders for each directory where files are stored on the server. This makes it easier to keep track of where the files have 
come from, and (depending on the original site’s structure) may preserve useful distinctions between various types of media 
files. If you leave the box unchecked, all files will be saved into one common folder.



· Don’t overwrite files. This option applies if you’re downloading files to a destination folder that already contains files, and 
MediaPlus needs to save a new file that has the same name as an old one. If you’ve checked the box, a new filename will be 
generated automatically. If not, the old file will be overwritten. (You could safely overwrite, for example, if you’d previously 
downloaded files from a site, and were now checking that same site again for new files, using the same destination folder.) 
Note: This setting only applies to "collisions" between new files and those previously in storage. If duplicate filenames occur 
within the batch currently being downloaded, MediaPlus generates new names as needed, so the whole batch gets saved. 

· Create album. Check this box to create a new album for your downloaded files. With this option, URL (file and source page) 
information will be stored as Comments for each downloaded file. If unchecked, you can still create an album from the saved 
files later on, but the URL information will be lost.

6 Select the Security tab and enter a User name and Password if MediaPlus will need this information to gain access to the 
page(s) you’ve asked it to search. You can skip this step if no special logon is required.

Now you’re ready to proceed with the next stage of downloading...

 

Stage B: Exploring pages
7 Before proceeding, make sure you’re connected to the Internet.

8 Click the Start button to begin the search. New controls appear that let you monitor and fine-tune the process. 

Off and running! MediaPlus first goes to the "target" Web page that you’ve designated, and begins building a page queue of 
pages remaining to explore, and a file queue of suitable media files to be collected. MediaPlus continues visiting pages listed in 
the page queue, and the process repeats until every link from the target page has been explored, out to the "depth" or number of 
links you’ve specified.

The progress bar and readout show how each process is going. The page queue values tend to fluctuate as each new page 
being explored will contribute new links. The file queue tends to build more rapidly, and then diminish gradually as files are 
collected.

Note: By default, MediaPlus allows 20 seconds to make a connection to each page. If this Download Timeout value is exceeded, 
it moves on to the next page. You can adjust this setting if necessary on the Misc tab of File/General Preferences....

At any point, you can inspect either queue and make changes as needed. 

9 To edit the list of pages remaining, click Edit Page Queue. 
OR
To edit the list of files remaining, click Edit File Queue. 

· Clicking either button to edit a queue pauses that particular process. 

· To rearrange items in a queue, select one or more items (use the Ctrl key for separate items or the Shift key to select a 
range) and then use drag and drop within the list. For example, you might decide to move certain images of greater interest to 
the top of the queue.

· To delete one or more selected items, press Delete. For example, if the file progress readout isn’t showing much activity, 
inspecting the page queue might allow you to remove some dull-sounding pages and move more promising ones to the top. 

10If you want to conclude downloading early, click Stop.

Assuming you don’t click the Stop button, exploration continues until the page queue is empty. At this point it makes a difference 
whether or not you checked the Pause before collecting option earlier on:

n Pause before collecting. If you did check this option, MediaPlus has so far refrained from actually collecting any files, and at 
this point the File Queue window will appear, displaying the complete list of files to be downloaded. You can inspect it at your 
leisure and make any necessary changes as described above. Note that you cannot save the file queue for later review; it’s 
assumed you’ll inspect it now, make your edits, and then proceed to the collecting stage. When you’re ready...

11 ...to start collecting files after the pause, click Collect. Note: If you selected this option but then change your mind, you can 
begin collecting (and skip the pause) by clicking the Collect button at any time during the exploration stage.

n No Pause before collecting. If you didn’t check this option, MediaPlus has been copying files to your computer concurrently 
while exploring, and collecting activity will just continue (see details below) until the file queue is empty. 

Stage C: Collecting files
File collection—the process of actually copying files to your computer—begins as soon as you click the Start button, unless you 
selected Pause before collecting, in which case (as noted above) it starts after you click Collect. 
n During collection, if you selected the Create album option, you’ll see thumbnails being added one by one into a new album 

window. Otherwise, the progress readout is your best indicator of how many files you’ve collected.

n As during exploration, you can edit the list of pages remaining (if any) by clicking Edit Page Queue. To edit the list of files 



remaining, click Edit File Queue. Clicking either button pauses that particular process.

n To suspend both exploration and collection, click Pause. Click Continue to resume downloading.

n You can begin previewing  and managing files as soon as they’ve arrived. Collection will continue as a background task, 
consuming little in the way of system resources. If you’ve created a new album for the files, MediaPlus records the source 
URL information in the Comments for each file (visible via the Add Comments menu item).

n Click Stop at any point if you want to conclude downloading early.

Assuming you don’t click the Stop button, collecting will continue until the file queue is empty. At that point the Download tab 
reverts to its initial state.



Delivering a slideshow

A slideshow lets you display selected images (or the entire contents of the Browser window or an album window) as a 
sequential, fullscreen presentation with preset transitions and timing. You can choose from a wide variety of transitions (Drip, 
Fade, Wipe, etc.) and combine them in any number of creative ways. During the slideshow itself, you’ll have both automatic and 
manual control.

Note: You can also preview fullscreen image sequences without preset transitions and timing using the View Fullscreen 
command. For details, see Previewing content.

To set slideshow options:

1 Choose Run Slideshow from the Actions menu and select Slideshow Settings... from the submenu.

2 Use the dialog to select options for the slideshow:

Options include:

Effect*
(see note below)

Click the marker next to any effect’s name to include

( ) or exclude ( ) it as a slideshow transition. 
Excluding all effects is the same as switching off 
transitions.

To rearrange the order in which effects are used, drag 
effect names up or down in the list. Effects will cycle 
through the listed sequence if you also choose "In 
sequence" as the Transitions setting (see below). 
To fine-tune an effect, select its name and use the 
central settings area to define the number of passes, 
speed, direction, and so on. 

Transitions Select In sequence or Random to set the order in 
which your selected effects will be used. The Random 
setting overrides any rearrangements you’ve made in 
the Effect list.

Slides Select In sequence or Random to set the order in 
which images will appear. 

Slide Time Select or type a value to set the duration (in seconds) 
that each image will stay onscreen before advancing 
automatically. During the slideshow, you can use manual 
Step and/or Pause controls (see below) to override this 
timing factor.

Play CD Check the box and select a track to play during the 
slideshow.

*Note: During the actual slideshow, MediaPlus obeys your settings for each transition Effect, with extra variations added into 
the mix. (For example, if you specify a "Simple Push" it will occur variously from the right, left, top, or bottom.) For certain 
Effects, you'll see check boxes that let you select which kinds of variations to include. The more boxes you check, the more 
variety MediaPlus can introduce in the slideshow. Unchecking all boxes is the same as switching off the Effect.

Once you've set your options, you can deliver a slideshow based on a group of selected images, the entire contents of the 
Browser window, or the entire contents of an album window.

To deliver a slideshow:

1 If you plan to show a subset of images, first select the image thumbnails you want to include. Ctrl-click to select additional 
thumbnails, or Shift-click to select a range including the initial selection. 

2 Click the  Run Slideshow button. if you have any thumbnails selected MediaPlus will assume those are the ones you 
want to show. If none are selected, it will include the entire contents of the last window you were working in.
OR
Right-click in the window and choose Run Slideshow. If you click on a selected thumbnail, you can choose All (for the entire 
contents of the window) or Selected.
OR
Choose Run Slideshow from the Actions menu and choose From Selection..., From Folder... or From Album... on the 
submenu. From Folder means the current contents of the Browser window. If you have more than one album window open, 
From Album... will show the contents of the selected album. 

To control images in a slideshow:

n You can right-click a "slide" and choose Double Size, Full Size, Half Size, or Quarter Size to set a specific scaling factor, or 



choose Auto Fit to display all images within the screen area.
Note: When using Auto Fit, you can also check Restrict to Full Size so larger images will shrink to fit but smaller images 
won't expand beyond their 100% size. If unchecked, all images will scale to fit the screen.

n Press the right arrow key to step forward through the sequence, or the left arrow key to step back. You can also right-click and 
choose Next or Previous. Unless you've paused the slideshow (see below), slides will continue to advance automatically per 
the Slide Time option you've set.

n Press the spacebar (or right-click and choose Pause/Resume) to suspend automatic slide advance. In paused mode, you can 
use Next or Previous to step through slides under manual control. Repeat the command to resume automatic advance.

n To access options, right-click and choose Slideshow Settings....

n To end the slideshow, press the Esc or Enter key or right-click and choose Close.



Making wallpaper and screensavers

You can use MediaPlus to instantly transform any image into a background picture to be used as desktop wallpaper, or turn 
multiple images into a screensaver sequence. 

To select a desktop wallpaper image:

1 Select the image thumbnail and choose Make Desktop Wallpaper from the Actions menu.
OR
Right-click the image thumbnail and choose Make Desktop Wallpaper.

2 Choose Centered, Tiled, or Stretched from the submenu. 
Note: Center displays the picture in the center of the screen, at actual size. Tile repeats the picture over the entire screen. 
Stretched adjusts the picture to cover the entire screen.

 
                Centered Tiled Stretched

You'll see the new image immediately on your desktop. If you don't care for the effect, you can restore the previous setting.

To restore the previous desktop wallpaper setting:

n Select the image thumbnail and choose Make Desktop Wallpaper from the Actions menu and Restore from the submenu.

OR
n Right-click the image thumbnail and choose Make Desktop Wallpaper>Restore.

Making a screensaver
With MediaPlus, you can turn any number of images into a personalized screen show, with a choice of display modes. 

To create a screensaver:

1 If you’ll be including a subset of images, first select the image thumbnails. Ctrl-click to select additional thumbnails, or Shift-
click to select a range including the initial selection. 

2 Click the  Make Screensaver button. if you have any thumbnails selected MediaPlus will assume those are the ones you 
want to include. If none are selected, it will include the entire contents of the last window you were working in.
OR
Right-click in the window and choose Make Screensaver. If you click on a selected thumbnail, you can choose All (for the 
entire window’s contents) or Selected.
OR
Choose Make Screensaver from the Actions menu and choose From Selection..., From Folder... or From Album... on the 
submenu. From Folder means the current contents of the Browser window. If you have more than one album window open, 
From Album... will include the contents of the selected album..

3 The MediaPlus Screen Saver dialog appears, with a preview of one screensaver type. To choose a different type, click the 
Settings... button. You can pick from three screensaver variants: "Flipbook," "Slide Show," and "Flying." Choose any one of 
these, adjust the parameters, and click OK.

4 To see the screensaver in action, click Preview. When you’re done, click OK. (Or click Cancel if you’re not satisfied and want 
to start over.)

 

Note: You can adjust the properties of an existing screensaver from the Display Properties dialog at any time. Simply right-click 
on the Windows desktop and choose Properties, then select the Screen Saver tab. Note, however, that if you make changes to 
an album upon which a screensaver is based, the changes won’t be reflected in the screensaver—in other words, to alter the 
images in a screensaver you’ll need to remake it.



Publishing Web galleries

Image galleries are a great way to present media files to a wider audience—typically over the World Wide Web, but just as 
easily via disk media. They’re convenient because they let viewers peruse a thumbnail index of what’s available and make 
selections without having to download or open all of the files. 

MediaPlus provides a wide range of preset page templates and styles that let you quickly compose a Web gallery from any 
selection or full window of file thumbnails (multimedia files as well as images). You can customize the layout as needed and then 
publish the gallery to a specific folder, either on a Web server or a local disk. Either way, MediaPlus takes care of building the 
HTML pages and exporting the designated files. 

You can also print out images and image galleries (see the next topic).

To publish an image gallery:

1 If publishing a subset of images, first select the thumbnails you want to include. Ctrl-click to select additional thumbnails, or 
Shift-click to select a range including the initial selection. 

2 Click the  Publish to Web button. If you have any thumbnails selected, these will be published; if not, the gallery will 
include the entire contents of the last window you were working in.
OR
Right-click in the window and choose Publish to Web. If you click on a selected thumbnail, you can choose All (for the entire 
window’s contents) or Selected. 
OR
Choose Publish to Web from the Actions menu, then choose From Selection..., From Folder... or From Album... on the 
submenu. From Folder means the current contents of the Browser window. If you have more than one album window open, 
From Album... will publish the contents of the selected album.

The Edit Web Page Layout window appears.

3 Use the window to select and customize your gallery layout as detailed in "Customizing the gallery layout" below.

4 To publish to a folder, simply click the Publish to Folder button and designate a target folder. To preview the page(s), use 
your Web browser to open INDEX.HTML.

If you’re publishing to the Web, continue with the following steps.

5 Make sure you’ve gathered information as covered in "Preparing to publish to the Web" below. Click the Publish to Web 
button and the Specify Account Details dialog appears.

6 In the dialog, enter the FTP address of your Web host and your pre-assigned Username and Password. Be sure to enter the 
password exactly as given to you, using correct upper- and lower-case spelling, or the host server will not recognize it. If 
publishing to your root directory, you can leave the Folder box blank.

7 Click OK. 

MediaPlus seeks an Internet connection or establishes a new one, and connects to the remote server. With some online 
services, you’ll need to use the service’s proprietary log-on software to establish a connection. You’ll see a message when all 
files have been successfully copied. 

8 To view your page(s) "live" on the Web, point your Web browser to the URL that includes the path to the host server plus the 
folder to which you published.

Note: If you’ve included thumbnails for multimedia files, the original files are exported just like image files when you publish the 
gallery. Clicking the gallery thumbnail for a multimedia file triggers playback of the original file. See the "Technical notes on Web 
galleries" section below for information on how to integrate MediaPlus gallery pages into existing Web sites. 

Customizing the gallery layout
The Edit Web Page Layout window is your command center for choosing and customizing a gallery layout. The window serves 
as a "live" preview area that lets you navigate by clicking thumbnails, as well as try out the various choices and customize them 
as needed. 

The first time you try publishing, you’ll certainly want to explore each of the various Templates—alternative ways of arranging 
pages and elements—shown as samples in the scrolling list at the upper right. Once you’ve selected a template, you can 
proceed to choose from Styles—different combinations of the various detailed elements that comprise each page (background 
color, thumbnail cell borders, and so on). Finally, you can customize individual elements of the layout. 

To preview a template:

1 Click any sample in the Templates list.

The Web page layout changes to use the selected template. Depending on the template, there will be either a single page where 
thumbnails scroll alongside a preview region, or a multi-page scheme with an index page for thumbnails with navigation to a 
separate page for each image.

2 Click the preview thumbnails to test the image display and page navigation. 



3 Use the  Back, 

 Forward, 

 Refresh, and 

 Home buttons as needed to traverse links or update page content.

To pick a preset style:

n Click in the Styles list (or press the arrow keys to step through the choices) to preview each sample. 

Don’t be distracted by color changes—remember that every element is customizable! The trick is to find the layout that will 
require the least additional fine-tuning. Perhaps you’ll be lucky and hit upon a preset style that’s precisely what you’re looking 
for. More likely, there will be some elements of the layout you’ll want to adjust at this point. Don’t be alarmed... but the number of 
possibilities is quite vast, given the customizability of the underlying HTML and style sheet code. The good news is that you don’t 
need to know a thing about HTML to make changes. 

To customize layout elements:

1 Choose items from the window’s Edit or Style menu. 
OR
Move the mouse around the preview window, watching as the Hintline at the bottom identifies customizable page elements. 
Right-click an element and choose the property you want to modify.

2 Make selections in the corresponding dialog. 

The dialogs provide lots of choices, and each starting layout is different—but instant updating means that a "try it and see" 
approach generally works best. Here’s a summary table of how specific commands relate to particular attributes: 

Edit menu (or right-click):
    Thumbnail Size... Width and height of thumbnails

    Description... Wording style of thumbnail caption

    Description Font... Text attributes of thumbnail caption

    Table Layout... Rows and columns, cell spacing, table width, 
thumbnail stretch, description position

Style menu (or right-click):
    Thumbnail Style...

    Thumbnail Cell Style...

    Description Cell Style...

    Table Style...

    Body Style...
 

Border style, border width, margin width, 
padding width, border color, alignment, 
background image or color (for the 
designated element)

Note: If you're conversant with HTML tags and style sheets, you can also prepare your own custom templates for MediaPlus 
albums—see the "Technical notes" section below.

Preparing to publish to the Web
The first time you publish to a particular server, you'll be prompted to enter basic information, such as server's URL. On many 
services, your personal publishing directory is just your screen (user) name appended to a standard URL.

However, if your account is with a specialized Internet service provider, or you're using a dial-up networking connection or some 
other arrangement, you may need to do a bit more research to determine the required information. For example, you should 
verify beforehand:

n The steps needed to connect to the server, whether via LAN (intranet) or Dial-up Networking connection

n Your user name and password

n Which transfer protocol the server supports: FTP or Windows file transfer

Technical notes on Web galleries
n Whether you publish to a folder or to the Web, the set of exported files typically consists of a main page, with a frameset page 

(INDEX.HTML) and one or more source pages (e.g. INDEX2.HTML), a style file (THUMBS.CSS), plus two folders (/IMAGES 
and /THUMBS) containing the media files and thumbnail images, and a subfolder with a page for each full-size image. Thus, 
the gallery constitutes its own mini-Web site and anyone who browses to INDEX.HTML will be able to view it.



n If you plan to incorporate the gallery into an existing site, it’s easy enough—but before publishing, check for duplicate file or 
folder names. (For example, you wouldn’t want to overwrite your existing INDEX.HTML page with the MediaPlus page of the 
same name!) A safe bet is to publish the whole MediaPlus gallery to its own separate subdirectory, so no conflicts arise. It’s 
fine to rename the gallery’s INDEX.HTML (say, as GALLERY.HTML), but don’t rename anything else unless you’re prepared 
to repair links within the source code. More proficient users wishing to integrate gallery files with an existing site structure can 
use Publish to Folder, rename and test locally as needed, and then use a separate FTP program to upload the files.

n When you publish a gallery, MediaPlus by default includes metadata tags that, while unseen by viewers, allow search 
engines to identify page content and build descriptions. On the Web Publishing tab of the File/General Preferences... 
dialog, you can set metadata options including which MediaPlus text (from thumbnail keywords, album Notes, and/or 
thumbnail Comments) search engines should use. You can specify how MediaPlus should export image files in non-Web-
compatible formats (you can convert these to GIFs or JPGs, or leave them as is).

n MediaPlus Web galleries are designed to take advantage of the flexibility afforded by Cascading Style Sheets. If you prefer a 
hands-on approach, you can edit the THUMBS.CSS file and create your own alternative templates for Web publishing. 



Printing

Beyond standard printing capabilities, MediaPlus affords versatile layout features that let you scale and arrange images on the 
printed page, customize text captions, and add headers and footers. It’s easy to print anything from a single image to multiple 
sheets with hundreds of thumbnails. As with slideshows and other actions, you can print the entire contents of a window, or just a 
subset of images. 

To print one or more images:

1 If publishing a subset of images, first select the thumbnails you want to include. Ctrl-click to select additional thumbnails, or 
Shift-click to select a range including the initial selection.

2 Click the  Print button. If you have any thumbnails selected, these will be printed; if not, the output will include the entire 
contents of the last window you were working in.
OR
Right-click in the window and choose Print. If you click on a selected thumbnail, you can choose All (for the entire window’s 
contents) or Selected. 
OR
Choose Print from the File menu, then choose From Selection..., From Folder... or From Album... on the submenu. From 
Folder means the current contents of the Browser window. If you have more than one album window open, From Album... 
will print the contents of the selected album.

The Print dialog appears. 

3 Use the dialog’s four tabs to tailor the output precisely to your needs. The preview region at the right displays the page 
margins and a reduced view of each page to be printed. Use the navigation and zoom buttons below the preview to step 
between pages and preview at various magnifications. 

n The Print Setup tab lets you define standard printer settings, print range, and number of copies.

n Whether you’re printing one image or many, use the Layout and Style tab to select how the pictures will scale to the 
printed page. You can define a grid using the Rows and Columns sliders, ranging from a 1x1 layout for a single image to 
16x16 for a sheet of tiny thumbnails. (MediaPlus automatically adjusts the number of pages.) The Choose Style drop-down 
list lets you select a preset combination of layout attributes. 
To customize particular page elements (such as the background or border of image cells or description cells), use the 
schematic layout region. Click the item you want to adjust as shown below, and make your selections while watching the 
preview region.

                        

n Use the Thumbnail Text tab to select a wording style and define text attributes for caption text. To remove captions entirely, 
select "Blank" from the list. 

n Finally, use the Headers and Footers tab to define optional text and/or page numbers in these regions at the top and 
bottom of each page.

4 When you’re done setting print options, click OK to proceed with printing.



Setting MediaPlus preferences

You can refine your MediaPlus environment using global program settings stored as preferences. For example, you can change 
the background color of windows—or even employ an image as a backdrop. Thumbnail size, description text, and tooltips are all 
under your control. 

To view or change general settings and non-album window options:

n Choose General Preferences... from the File menu.    See the table below for a list of options.

To set options for a particular album window:

n Select the window and choose Album Preferences... from the File menu. See the table below for a list of options.

General Preferences

Display Browser colors, optional background image

Background colors for slideshows, fullscreen view, 
Preview window

Thumbnail Size Width and height of Browser thumbnails 

Thumbnail Text Wording style of Browser thumbnail captions

Tooltips Wording style of Browser tooltips

Misc Thumbnail animation preferences

Timeout on page downloading

Which file types to display in Browser window

Display the last album at run-up (new session)

Web Publishing Metadata options, non-Web image options

Album Preferences

Display Window colors, optional background image

Thumbnail Size Width and height of thumbnails 

Thumbnail Text Wording style of thumbnail captions

Tooltips Wording style of tooltips



Troubleshooting and support

Troubleshooting a problem
Don't panic! Remember that all technical problems, no matter how bizarre they may seem, have a cause and a solution. By 
patiently applying a logical approach, you can often identify the source of the problem and fix it yourself. In general, try 
simplifying your PC's setup until the problem is no longer present. Then, incrementally restore the original setup, testing to see 
which component makes the problem recur. Be careful!

Initially, try to establish:

n Is the problem most likely arising within MediaPlus? 

n Is it a Windows problem? 

n Or is it a "hardware" problem having to do with your PC or its peripherals? 

n Have you made any recent changes to your system configuration that might be responsible for the problem?

If it's a MediaPlus issue, perhaps there's a procedure you need to know more about. Check online Help for information on the 
specific task you're trying to accomplish.

For Windows or hardware issues, click the Start button and choose Help for troubleshooting information—or check the specific 
manuals for the peripheral. 

Printing problems with Windows are generally caused by using an incorrect or outdated printer driver, or a third-party printer 
driver. Make sure that you use the Windows printer driver designed specifically for your printer. To check printer drivers, click 
Start, choose Settings > Printers.

Contacting Serif technical support
Our support mission is to provide fast, friendly technical advice and support from a team of on-call experts. Serif customers are 
entitled to free, unlimited phone support for the first 30 days following receipt of the product. After that time, pricing policies (per-
call or per-year) go into effect.

You can reach our main Web support page at http://www.serif.com/support.aspTechnical support is provided by telephone and e-
mail, as well as through FAQs and forums on our Web site (see below).

USA Technical Support (603) 886-6642

e-mail: support@serif.com

Europe Technical Support (0115) 914 9090

e-mail: support@serif.co.uk

International Technical Support +44 (115) 914 9090

Please do not fax technical support queries.

Additional Serif contact information
World Wide Web:

Serif Web Site http://www.serif.com 

Support http://www.serif.com/support.asp

Frequently Asked Questions http://www.serif.com/faq.asp

Forums http://www.serif.com/forums.asp

Main office (USA, Canada):

The Software Center, 13 Hampshire Drive, Unit 12, Hudson NH 03051, USA

Main (603) 889-8650

Registration (800) 794-6876

Sales (800) 55-SERIF or 557-3743

Customer Service (800) 489-6720

General Fax (603) 889-1127

Sales Fax (603) 886-4919

European office (UK, Europe):

The Software Centre, PO Box 2000, Nottingham, NG11 7GW, UK

Main (0115) 914 2000

Registration (0500) 454 645



Sales (0800) 376 7070

Customer Service (0115) 914 9090

General Fax (0115) 914 2020

International enquiries

Please contact our main or European office as apporopriate.
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