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Abstract

Use the Block Style (flush left) for the abstract.  It should be a single paragraph 

on a separate page.



Microsoft Word 4.0 Template for the Editorial Style

Required by the American Psychological Association

Much of this template is a review of the major aspects of APA style, itself 

formatted as the element being discussed is supposed to be formatted.  First, 

however, I want to present a brief user’s guide for this template.  The instructions 

are specific to the Macintosh version of Microsoft Word version 4.0.  The same 

functions are available in MS-DOS versions of Word, but the particular 

keystrokes to invoke the functions will be different.  These instructions apply both 

to documents not yet written and to documents previously written, to which you 

want to add APA formatting style.

1.  Open Microsoft Word, and your document (if it already exists).  Choose 

Full Menus from the Edit menu, if you haven’t already (the Full Menus selection 

will change to Short Menus).

2.  Choose Define Styles from the Format menu.  While the Define Styles 

dialog box is open, choose Open from the File menu, and open this template file. 

The styles from this template will be copied into your document and saved with it 

the next time you Save it.  Click OK to close the dialog box.  You only need to do 

this step once for each document to be formatted.



This step will redefine the Normal Style, but it doesn’t remove Right 

Justification if you have that specified (APA style specifies Left Justification only). 

If you are applying these Styles to an existing document that is already Right 

Justified, choose Define Styles from the Format menu, select the Normal Style, 

select Show Ruler from the Format menu, and click on the Left Justified icon.  

Click OK to close the dialog box.

3.  Choose Document from the Format menu and change the dialog box to 

look like the example Format/Document dialog box in Figure 1.  Click OK to close 

the dialog box.

Insert Figure 1 about here

4.  Choose Open Header from the Document menu and replace the text 

there with a short version of the paper title.  Close the Header’s window.

Insert Figure 2 about here

5.  Choose Section from the Format menu and change it to look like the 

example Section format dialog box in Figure 3 (note particularly that the Include 

Endnotes option is specified).  Click OK to close the dialog box.  (Note:  In my 

system, there is a discrepancy between the positioning of 



page numbers in the Page View mode on the screen and the printed 

version.  Printed page numbers come out 0.5 inches too far to the left.  If this 

happens to you, change the From Right specification in the Section format from 2 

in. to 1.5 in.)

Insert a Section Break after the Footnotes section of the document (if you 

have one), instead of a Page Break.  This will assure that any footnotes you use 

appear in the Footnotes page(s) of the document.  To insert a Section Break, 

hold down <Command> and type <Enter>.  After inserting the Section Break, 

check to make sure the Header is right in each Section by clicking inside the 

Section (before the Section Break for Section 1; after the Section Break for 

Section 2) and choosing Open Header under the Document menu in each place. 

Word allows Headers to be different in different Sections; they should be the 

same in all Sections of an APA-style document.

Insert Figure 3 about here

6.  Most of the rest of this manual is a discussion of the available styles 

and their appropriate uses.  You may want to read the rest of this manual now, 

and mark on a printed copy of your document which blocks of text should be 



formatted according to the various Styles available.  To format text 

according to a particular Style, make sure the insertion point (blinking vertical 

bar) is in the paragraph to be formatted, or the text to be formatted is selected 

(shows in light text on dark background, which happens when you click and drag 

over text).  Choose Styles from the Format menu, select the appropriate Style, 

and click on OK.  Alternatively, the Ruler shows a popup list of the available 

Styles in its lower left-hand corner; click and hold on this list, and drag to the 

appropriate selection.  Any selected text, or the paragraph in which the insertion 

point resides, will be reformatted according to your selection.

7.  To insert a Page Break into the document, click where you want it to 

go.  This places the insertion point (blinking vertical bar) there.  Hold down 

<Shift> and type the <Enter> key.  Page Breaks show as horizontal lines of dots. 

The ones inserted automatically by Word’s repagination feature (these are “soft” 

Page Breaks which move as you change your document) have more space 

between dots than the page break markers that appear when you put in a “hard” 

Page Break (one that doesn’t move unless you move it).

8.  If you are formatting an existing document, you may have already 

formatted it in ways that conflict with 



the techniques used in these Styles, and will therefore end up with a 

terrible-looking document when these Styles are applied.  For instance, you may 

have double-spaced by entering double Carriage Returns at the end of every 

line.  The Normal Style included with this template specifies Double Spacing, 

which means that your document will be quadruple-spaced.  For correct spacing, 

you should remove all Carriage Returns except those at the ends of paragraphs.

Another common problem is caused by using tabs or spaces to indent the 

first lines of paragraphs or whole paragraphs (for long quotes, for example).  The 

Styles included here use Word’s automatic indent feature, and paragraphs 

beginning with tabs or spaces will be double-indented.  Remove the tabs or 

spaces for best results.  Similarly, text or headings that have been centered by 

adding spaces or tabs to the beginning will not look good after application of the 

appropriate Style, unless the tabs or spaces are removed.

Tables should be created with Word’s powerful Table facility, instead of 

manually with spaces.  This is one of Word’s most powerful features, and is well 

worth the effort to learn.

9.  It is not necessary to enter your references in alphabetical order.  Just 

be sure that there is only one 



Carriage Return for each reference (at the end), select all your references, 

and choose Sort from the Utilities menu.  All selected references will be sorted 

alphabetically by the first characters in each reference, which should be the last 

name of the lead author.

The rest of this document is an overview of APA style, appropriately 

formatted, and information about the creation and distribution of this template.  

We begin with examples of the five different levels of headings:

LEVEL 1 HEADING:  CENTERED CAPS

Level 2 Heading:  Centered; Major Words Capitalized

Level 3 Hdg.:  Cntrd; Maj. Wrds Cap’d; Underl’d.

Level 4 Hdg.:  Flush Left; Maj. Wrds Cap’d; Underl’d.

Level 5 heading:  indented paragraph heading ending in a period (normal 

sentence), underlined.  There is a Style defined for each level of heading (Hdg 

Lvl 1, Hdg Lvl 2, etc.).  Underlining is removed in the Hdg Lvl 5 Style definition 

since that would apply underlining to the entire paragraph, and only the first 

sentence of the paragraph is to be underlined.  Underline the first sentence 

manually.

Make Level 2 the top level heading for papers requiring less than five 

headings.  For documents requiring two or three levels of headings, use Level 4 

headings as subordinate to Level 2, and Level 5 headings as subordinate to 

Level 4.  



If material under the Level 2 heading is short, or if many Level 4 headings 

are needed, Level 5 headings may be more appropriate than Level 4.  Level 5 

headings should apply to all the material between headings.  Use Level 3 

headings between Levels 2 and 4 only if four levels of headings are required.  

Use Level 1 headings only if five levels of headings are required.

This is an example of a quotation of more than 40 words.  It should be 

formatted in a free-standing block of lines, omitting the quotation marks.  

Start such a block quotation like this one, on a new line (i.e. immediately 

precede it with a <Return>), and apply the Long Quote Style. This will 

cause the quote to be indented five spaces from the left margin, double-

spaced on the new margin. Apply the Long Quote para 2 Style to the 

second and subsequent paragraphs, which will cause their first lines to be 

indented with respect to the new margin, unlike the first line of the first 

paragraph of a long quote.

When the long quote is imbedded in the middle of a paragraph of 

text, finish the long quote with a <Return> and format the following text 

with the Block Style (Normal Style without the first line indentation).



When quoting, always provide the author, year, and specific page 

citation in the text and include a complete reference in the reference list 

(e.g. Gardner, 1981, p. 75).

Insert Table 1 about here

Figure and table position markers, as above, consist of a blank line 

(<Return>), then the words Insert Figure/Table <n> about here, assigned the 

Figure/Table Position Style; this centers it and adds the required horizontal lines.

About This Template

This template was developed on a Macintosh 512E, Macintosh Plus, and 

Macintosh IIci, and ImageWriter I printer under Systems 4.1 - 6.04 and 

ImageWriter drivers 2.6 - 2.7, using Microsoft Word versions 3.01 and 4.0.  It has 

not been tested on other configurations.  The default font on my system, 

specified in the Normal Style, is Boston II-NY.  It carries the same font ID number 

as Apple’s New York font, and I assume without having tested it that this template 

will still work on systems without Boston II-NY.  The Boston II suite of fonts is 

arguably the best available for the ImageWriter printers, and may be obtained 

from major 



commercial and private users’ groups and electronic bulletin boards, or 

directly from the author (Charles E. Maurer, 31 Forsyth Avenue South, Hamilton, 

Ontario, L8S 2A4, Canada.  CIS PPN=74726,1201), for only $10.50 US.

Styles have been defined in this template for most major formats required 

by the Publication Manual of the American Psychological Association (3rd ed.) 

(1983), published by the American Psychological Association, Washington, DC.  

This manual (document number 2450056) may be ordered from the APA for 

$16.50 ($12.50 for APA members; prices subject to change without notice).  

Contact the APA Order Department, P.O. Box 2710, Hyattsville, MD 20784.  VISA 

or MasterCard orders may be placed at (703)247-7705 (collect calls cannot be 

accepted).  This template is not an official publication of the APA and does not 

represent the entire contents of the publication manual.  Users are urged to 

obtain their own copy of the current version of the manual, and to use it as the 

final authority.

I welcome suggestions for changes, especially bug reports.  I also 

welcome shareware contributions of $5 per user.  Send contributions and/or 

suggestions to Dan Henderson, Toby Solomon Counseling Associates, 5011 

Autumn Forest Drive, Houston, TX 77091-5001, (713)682-0358.  I can also be 

reached via electronic mail on CompuServe 



(72106,1460), GEnie (DHENDERSON), Delphi (DJHENDERSON), 

PsychNet (DJ.HENDERSON), CONNECT (DHENDERSON), America Online 

(DHENDERSON), or the Fielding Electronic Network on TeleNet’s TeleMail 

(DHENDERSON/HUMANOMICS).  I accept MasterCard and VISA.  If you wish 

to use a credit card, please tell me the type of card, account number, expiration 

date, and your name as it appears on the card.  For an extra $5 ($10 total), I will 

send you one of my disks with the current version of this file on it.  Please specify 

400K or 800K disk.

Change History:

V 1.1:  Added “Keep with next…” paragraph format to Heading Levels 1-4.

V 1.2:  Expanded the instructions for long quotes; added instructions for 

applying APA format to existing documents.

V 2.0:  Added more explicit user instructions (thanks to Professor Douglas 

Matheson, Ph.D., at University of the Pacific for the suggestion), cleared up the 

instructions for long quotes, and added examples of Figures.

V 4.0:  Converted to Microsoft Word version 4.0 (there was no version 3 of 

the template).

V 4.1:  Added many clarifications as a result of beta testing by other 

Fielding Institute students.
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Appendix

If there is more than one Appendix, start each on a separate page and 

identify it with a capital letter (Appendix A, Appendix B, etc.) in the order of 

mention in the text.



Author Notes

Author identification notes (acknowledgements, expanded affiliation or 

change of address, address for inquiries or requests for reprints) go here, unless 

the paper is to be blind reviewed, in which case these should appear on the title 

page (the manuscript is sent to reviewers without the title page).  (Manuscripts 

for blind review should also avoid including the author’s name in the short title, 

which is in the Header in this template, since the short title also appears on every 

page.)  Enter acknowledgements first, if any, then the author identification 

information.



Footnotes

The footnotes page ends with a section break instead of a page break 

(hold down <Command> and type <Enter>) since the Include Endnotes option is 

specified for footnotes in the Section Format dialog box, which places them at the 

end of the Section in which the footnotes appear.



Table 1

Table Title

Begin each table on a separate page.



Figure Captions

Figure 1.  Format/Document dialog box example.

Figure 2.  Document/Header dialog box example.

Figure 3.  Format/Section dialog box example.

Figure 4.  All figure captions go on one page; should be brief and clear.
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Figure 2.



Figure 3.


