
Extension Kit™ Online Manual

Welcome to Extension Kit.    This online help window provides all the information you should need to get the most out 
of Extension Kit.    If you are running System 7.0 or higher, you also have full balloon help available for most windows 
and menus.    These can be used as quick reminders if you get stuck using a particular feature.

Distribution Limitations

Of course, no package would be complete without legal notes, so here it goes.    Extension Kit™ is being provided to 
the Mac community as shareware.    However, I have been burned as a developer too many times in the past, and as 
many times as a consumer, by shareware fees.    Therefore, I am letting Extension Kit speak for itself.    If you find this 
utility useful, and you wish to see future enhancements to it, I expect for you to donate to the cause.    You set the 
amount, because you know what it is worth to your day to day uses.    I think this is extremely fair to the user 
community, and I only ask that your be fair in return.    Now, I'm sure most people also understand that shareware 
authors by and large get the short end of the stick, and never see a fair return on their work.    It doesn't help when 
outside organizations step in and take what isn't theirs. 

Therefore, distribution of Extension Kit™ on any media, by any organization or individual, and/or by itself or as part of 
any collection or group of software, must be provided free of charge to all users, and must be supplied fully intactMÜl 
notices and disclaimer information.    This distribution limitation strongly applies to CD-ROM collection distributors, 
such as EduComp.    I will, however, waive this restriction for online services such as CompuServe, America Online, 
Genie, and public bulletin board systems as long as no fee is charged directly for Extension Kit™ itself, outside of 
normal connect charges.    I also waive this restriction to public, non-profit Macintosh user groups which release disk-
of-the-month packages.    However, the total amount charged for any disk released by user groups containing 
Extension Kit™ must be less than $10.

If you wish to have Extension Kit™ shipped as part of a package or collection, you must receive the author's approval 
in writing before distributing any copies.    Send all inquiries to the address given at the end of this help text, or the 
address provided in the About box.

I'm now off of my soap box.    Onward, to the disclaimer!!

Disclaimer

Extension Kit™ is strictly provided AS-IS, with no warranty to its suitability for use in any circumstance.    I cannot be 
held responsible for bugs, incompatibilities, or any other problems you may find with this software.    You assume total 
risk for using this package.    I can, however, state that Extension Kit has been tested on a variety of machine 
configurations from the Mac Plus to the Quadra 750, running System 6.0.5, 6.0.7, 7.0, and 7.0.1 with various 
extensions and hardware combinations with no known problems.

Whew!    We made it.    The rest of this online guide actually tells you how to use Extension Kit!

Installation

Extension Kit comes as a three part program – one application and two extensions.    These files need to be placed in 
specific areas on your hard disk to function properly.    A description of each one, and the location to install it, are 
given below:

Extension Kit™:    The primary application.    This can be placed anywhere on your hard disk you like.    For System 7 
users, you may wish to create an alias to this application and place it in your Apple Menu Items folder for quick 
access.    This application is responsible for creating and editing kits.

Extension Kit™ Bootup:    The primary extension.    This extension needs to be placed in the Extensions folder within 
the System Folder for System 7.x users, and directly in the System Folder for System 6.0.x users.    This extension is 
responsible for turning extensions on and off, and allowing the user to specify the desired kit at startup.

Extension Reset:    An optional extension.    This extension needs to be placed directly in the System Folder for both 
System 6 and System 7 users.    It should not be placed in the Extensions folder.    This extension will turn all 
extensions back on after a reboot.    See Resetting Extensions for more information on this extension.

Overview



If you are new to the world of extensions, you may be wondering just why in the world you would need an extension 
manager in the first place.    The reason is that the extension mechanism is a method which provides software 
vendors the ability to add functionality to your Macintosh, usually without or as a companion to another application.    
Since most extensions need to be active until you shutdown your Macintosh, it is necessary to load them when you 
turn on your machine.    Apple realized this long ago, and provided developers with a way to add drop-in ‘INIT’ files, or 
extensions, to the System Folder to be loaded at boot time.

You may not realize how many extensions you currently have on your machine.    Although most extensions, 
previously known as INITs, reside either directly in your System Folder or in the Extensions folder, some actually are 
contained within Control Panel files, called cdev's.    Extension Kit will let you know all of the files which contain INIT 
code which is loaded at boot time, and will allow you to selectively turn on and off extensions.    Extensions can be 
grouped into “kits”, and you may choose any kit to load at boot time.    This concept has been around for awhile, and 
was previously available in a limited version of INIT-Kit for System 6.0.x machines.

Extension Kit allows you to define 10 kits, which should be enough for most users.    Any kit can be selected during 
the boot process, and individual items within a kit can be turned off temporarily without removing them from a kit.    
Any one of the ten kits may be marked as the default kit, which will be loaded if no selection is made at boot time.    
For more information on using Extension Kit during the boot process, see Using Extension Kit at Boot Time in a later 
section.

Finally, you may have noticed that Extension Kit is an application/extension set.    Most extension managers currently 
available are either extensions or control panels (normally control panels.)    Given the advances in the Mac OS in the 
past few years, it now makes much more sense (and gives much more freedom) to make Extension Kit an 
application.    By being an application, Extension Kit now operates the way you would expect a normal Macintosh 
application.    You can make as many changes as you want, but nothing is permanent until you say it is, by choosing 
Save from the File menu.    Alternately, you can revert your changes if you make a mistake.    Also, Extension Kit 
supports the required AppleEvents, and in the next release will allow retrieving of kit information and editing of kits 
through AppleEvents.    You can also have as many kit editing windows open at one time, instead of being restricted 
to kludging with the Control Panel.

The Extension Kit window

The Extension Kit window gives you a quick overview of all of the defined kits available to you.    The leftmost list in 
the window shows you the extensions and control panel files contained in the currently selected kit.    All of the 
available kits are shown in the larger list in the center of the window.    By clicking on a kit within the list, the contents 
list will change to show the items within the new selected kit.    You can quickly move between kits by using the mouse 
to click on a kit, or by using the up and down arrow keys to move through the kit list.    For each kit, you will see the kit 
number and name.

The kit contents list will tell you additional information about the kit.    Each item listed will be shown in either plain, 
italic, or gray text.    An italic item tells you the item shown is a System 7 alias to an extension or control panel, and a 
gray item tells you that a file is temporary disabled in the kit and will not be loaded at boot time.    You can click on 
individual items in the contents list, and the folder the item is contained within will be shown in the lower left corner of 
the kit window.

The kit window allows you to edit and set default kits, along with enabling and disabling kit items.    These features are 
explained in the following sections.

Setting the default kit

The default kit is shown in the kit list with a large checkmark beside it.    This kit will automatically be loaded at boot 
time if you do not make a keyboard choice as an overriding selection.    You may select any kit to be the default kit, 
although Extension Kit will default Kit #0 to the default kit when you first install the software.

To select a particular kit as the default kit, highlight the kit name, then click the Default Kit button.    The checkmark 
will be moved next to the kit name to show that it is the new default.    You may optionally hold down the shift key and 
double-click a kit to select it as the default.

Changes to the default kit selection will not be saved until you either quit Extension Kit and save your changes, or 
choose Save from the File menu.



Disabling/Enabling kit items

To disable or enable a kit item, double-click the name of the extension or control panel in the kit contents list.    The 
item will be displayed in a gray pattern if it is disabled, and in plain text if it is enabled.    No item will be loaded while 
disabled, and will not be re-enabled until you choose for it to be. 

Optionally, you can select a single item and choose Disable Extension from the Options menu, or you can using the 
shift- or command-key to select multiple items, and choose Toggle Extensions from the Options menu.    Either way, 
the items you select will be toggled to disabled or enabled state, depending on what state they were in when you 
made the selection.

Editing a kit

Editing kits is the primary purpose for Extension Kit.    When you first install Extension Kit, all kits are empty.    If you 
were to boot with an empty kit selected, none of your extensions would be loaded at all.    Therefore, it is a good idea 
to establish at least one kit to be used.    Normally, I define my first kit contain everything that is installed on my 
machine.    I then create combinations of kits with various subsets of the main kit.    However, you may want to look at 
the Combining Kits section for some kit setup ideas.

You can begin editing a kit in three ways.    One way is to highlight the number of the kit you wish to edit, then click the 
Edit Kit option.    The second way is to simply double-click the kit you wish to edit.    The third is to select the kit, then 
choose Edit Kit from the Options menu.    Any of the above will open a kit editing window, which allows you to specify 
the contents of the kit, plus give the kit a name.

Once the editing window is opened, you will see all of the extensions and control panels installed on your machine in 
the left list.    The right list shows the contents of the kit.    You can move items back and forth between these two lists 
until you have the kit in a configuration you like. 

To move an item into the kit, double-click the item in the left list.    The item will be added to the kit contents list on the 
right.    Optionally, you can select a single item by clicking on it, or a range by using shift- and command-click 
combinations.    Once selected, click the arrows pointing to the opposite side, and all selected items will be moved at 
once.    These operations work for either list to add and remove items from the kit.

You can name your kit anything you want by typing the name in the Kit Description area.    Try to keep the name as 
short as possible, because the name will be shown in the kit list.    Also, try to keep the description, well, descriptive.    
Names such as "Game Kit", "Work Kit", "Load Everything", etc., make it easy to select the kit you need without 
scanning all of the items in the kit itself.

Finally, the Extension Kit™ Bootup file will not appear in any of the kit item lists.    It is required for Extension Kit to 
operate, and will always be loaded.    Consider it as an “invisible” item which is always contained by all kits.

Combining Kits

You may combine any number of kits with another kit using the Add Items item from the Options menu.    From the kit 
window, select a kit you wish to add items to.    Choose Add Items, select all of the kits you wish to add items from, 
then click Add.    The contents of all of the selected kits will be added to the kit currently displayed in the kit window.    
Optionally, you can choose Add Items when you have an edit window as the frontmost window.    After choosing all of 
the kits to add from, all items from the selected kits will be placed into the kit you are editing.

This feature is extremely useful for creating default kit setups.    For example, say that you know you always need 
AppleShare, QuickMail, and the File Sharing Extension extensions loaded at startup.    You could create a kit with 
these three items by themselves, and name it something like “Just the basics.”    Then, when you create a new kit you 
can choose Add Items and select the “Just the basics” kit to copy from.    Your new empty kit will automatically contain 
the items in that kit.    You then can add the items which make this kit unique above and beyond the items in the kit 
you copied from.

By using this method, all the must have extensions can be updated in a single kit, then used as the foundation for all 
new kits. 

Setting Preferences

Extension Kit has simple preferences for startup.    To edit preferences, choose Preferences from the Edit menu.    You 



can choose whether Extension Kit is active or not, if you want a startup icon shown, and if you want the kit selection 
dialog automatically shown at startup.    By default, Extension Kit will be active, the startup icon will be shown, and the 
kit selection dialog will be off.

If Extension Kit is turned off, all extensions are automatically reset, and all will be loaded during the next boot cycle.

Shrinking/Expanding the application

If you wish to keep Extension Kit running, but you don't want the entire kit window displayed while you are not using 
it, you may choose Shrink from the Options window to shrink Extension Kit to a tiny 32x32 window.    You may later 
double-click this icon, or switch to Extension Kit and choose Expand from the Options menu to return to the kit 
window.

Resetting Extensions

Although this section is a little technical, it is important for users to understand what is taking place “behind the 
scenes.”    For Extension Kit to do it’s job, it needs to be able to activate and deactivate extensions during the startup 
process.    To accomplish this, Extension Kit sets a flag called the “No Inits” flag on each file which should be disabled. 
When the system sees a file with this flag set at startup, it ignores the file and skips it.    Disabled files retain the “No 
Inits” flag until the are enabled by the user by choosing a kit which contains the file.

However, if you copy a disabled kit to another machine, or copy the extension to a file server, the file still keeps the 
“No Init” flag.    If another user installs the extension, it will never load (unless, of course, that user is also using 
Extension Kit and adds the extension to their active kit.)    For most users this is not a problem.    However, if you wish 
to copy extensions between machines there are two ways to activate all extensions.    First, from within Extension Kit 
you can choose Reset Extensions from the Edit menu.    All disabled extensions will be enabled, and files can be 
copied without worrying if they are active.

As a secondary, optional solution, you may simply place the extension named Extension Reset into your System 
Folder.    This will automatically return all extensions to an active status at the end of the boot process.    This 
extension will add about a second to the boot process to quickly reset the files, but other than that it has no particular 
use to Extension Kit, and need not be present for Extension Kit to work properly.

There are alternative methods which have been used to “deactivate” and “activate” extensions.    I have looked at 
various ones, and prefer this one for simplicity.    Some other extension managers physically move disabled 
extensions to another folder within the System Folder.    This solves the “deactivate” problem, but makes it difficult for 
users to locate disabled extensions, since they will not be where the user expects them.    There are definitely pros 
and cons to all methods; I'm sure some people will not prefer this one.    However, it is a very clean solution, and very 
invisible to the user.

Printing a kit chart

Extension Kit allows you to print a quick reference chart showing all of your defined kits, and all items within each kit. 
This can be placed near your Mac for quick reference during startup to choose the kit you wish to use.    To print a 
chart, choose Print Kit Chart from the File menu.

Using Extension Kit at Boot Time

Extension Kit is really two programs in one – one runs as an application, and the other runs at boot time.    When your 
machine boots, the first item loaded will be the Extension Kit™ Bootup file.    During startup, you can choose a kit to 
load, choose a custom extension set to load, load all extensions, load no extensions, disable items within a kit, or 
simply do nothing and let the default kit load.

Choosing A Kit

When your machine starts up, determine which kit you wish to load.    If you do not wish for the default kit to load, 
press the numeric key for the key you wish to load, such as the ‘1’ key for Kit #1, or the ‘2’ key for Kit #2, etc.    Wait 
until you see the Extension Kit icon appear with the number of the kit you selected before releasing the key. 

Note: If you chose not to show the startup icon with the Preferences, you will not be able to tell when Extension Kit 
has activated the kit.    Also, be sure to hold the key down before Extension Kit™ ootup loads.    Otherwise, the default 
kit will be loaded.



You may optionally hold down the ‘+’ key to load all extensions, or the ‘-’ key to load no extensions.    You may use the 
numeric pad keys if you wish, and the ‘+’ need not be shifted.

Startup Dialog

If you hold down the space bar before Extension Kit™ ootup loads, you will be given a window to choose your kit 
options.    From the startup dialog, you will see a list of all of the kits you have defined in Extension Kit, and you can 
browse through the contents of each kit.    This window looks almost exactly like the main kit window in the Extension 
Kit application, but has a different series of buttons on the right side.

From this dialog, you can enable and disable kit items by double-clicking them.    You can choose a kit to load by 
double-clicking the kit, or by highlighting the kit and clicking the Load Kit button.    The Default Kit button can be used 
to set the default kit for the next boot, although you could set a new default, then double-click the kit to load it during 
the current boot.

You can use the All On and All Off buttons to turn all extensions on or off, respectively.    Finally, the Pick Now option 
allows you to choose a custom set of extensions to use for this boot only.    Once Pick Now is selected, you will be 
presented with a list of all of the extensions available.    All items disabled by the previous boot will be shown in gray; 
all active items in black.    You can selectively turn extensions on and off by double-clicking their names.    Once you 
are satisified with your selection, click OK to proceed with the boot, or Cancel to return to the kit selection dialog.

Timing Z Miscellanea

Extension Kit was originally written in January 1991, and pretty much looked the same way it does today.    I created it 
for the explicit reason that I needed a good extension manager for System 7.    Once I finished, I had no idea what I 
wanted to do with it.    I have contemplated all sorts of methods of freeware, shareware, commercial, etc., and for the 
past year and a half have just allowed my friends and co-workers free use of it.    I've received enough feedback from 
these folks to see that not everyone is pleased with the current offerings of extension managers, and not eveyone 
wants to pay the $$$ to get a program with just a few extras “power-users” features on it.

I welcome any and all feedback, comments, wish list items, complaints, bug reports, donations, etc.    I normally will 
only reply to electronic mail, since it is much less tedious for my busy schedule.    I am available on AOL and the 
Internet.    Most services, such as CompuServe and AppleLink, provide Internet gateways so you can send mail to my 
Internet address.    Check with your particular system for instructions.    Send all correspondence to:

          Richard Harvey
          Timing Z Softworks
          P.O. Box 118332
          Carrollton, TX    75011

or, electronically at:

          America Online: Banana6000
          Internet: banana6000@aol.com

Extension Kit™, Extension Kit™ Bootup, and Extension Reset are all copyright ©1991-92, by Richard Harvey.    All 
Rights Reserved.


