
Playing Hexominos

Introduction

Hexominos is a puzzle game.  There is no score to be kept; no fast action or animation.  A typical 
Hexominos puzzle has eight to twenty pieces.  There are no drawings on the puzzle pieces to aid in the 
puzzle's completion; the player must employ logic and/or trial-and-error to determine where the pieces 
need to be placed.  Simple puzzles might take from five minutes to an hour to solve.  More complicated 
ones can take hours, even days!

Puzzles can be saved at any time and recalled from disk.  In addition, Hexominos can be used to 
create and play new puzzles, as described later.

Starting Up the Game

As with most Mac applications, there are two standard ways to start up Hexominos.  The first is to 
double-click the Hex! icon from the Finder.  This brings up the "Canned Game" in Hexominos' game 
window.   Alternatively, you can double-click the icon of an existing Hexominos puzzle.  This will start up 
Hexominos with the selected puzzle in the game window.

Playing the Game

A typical Hexominos puzzle will start up showing a collection of puzzle pieces arranged on the 
screen, along with the game board where these pieces will fit when the puzzle is completed.  The game 
board is not necessarily square or rectangular, but it will always be a polygon with 90-degree corners.  
The same is true for the puzzle pieces.

To play this game, simply drag the puzzle pieces onto the board -- rotating them, if necessary, 
until all of the puzzle pieces fit onto the game board without overlapping, and with all of the gameboard 
area covered.  To rotate a puzzle piece, simply press the COMMAND key while clicking on it.  

The game board has a heavy black border around it, and has a pattern that is unique from that of 
the puzzle pieces.  The puzzle pieces may be dragged about, but the game board may not.  When a 
puzzle piece is dragged onto the game board, it is "snapped" to an invisible grid.  This helps in placing the 
parts and ensuring that they don't overlap.

Layers and Intersects

During the course of play, puzzle pieces will often overlap each other and may even end up in 
little piles or stacks.  Clicking on a puzzle piece (without pressing a modifier key such as SHIFT, OPTION 
or COMMAND) will bring that piece to the topmost layer.  However, rotating a piece (with COMMAND-
click) will leave the piece at its original layer.

When you are in the final stages of play, it is important to know that puzzle pieces on the game 
board are not overlapping and obscuring other pieces.  In the Menu 



Bar, the menu title Intersects will appear when there is an overlap of pieces anywhere on the screen.

The Intersects Menu has one item, which alternately appears as Show Intersects or Hide Intersects. 
Selecting Show Intersects will outline the overlapped regions with an unmistakable border pattern.  You 
can revert to a more "quiet" display by selecting Hide Intersects from the menu.

The File Menu

The File Menu in Hexominos is fairly standard, except that "Canned Game" appears in place of 
"New."  The File Menu options do more or less what you'd expect them to:

Canned Game brings up the default Hexominos game
Open... brings up standard dialog to open another puzzle file
Close closes the game window
Save save current puzzle under existing name
Save As... brings up standard dialog to save current puzzle
Quit leave the game

Hexominos will put up a dialog box if you try to leave or write over a puzzle without having just saved it.  
The dialog box asks, Save This Puzzle? and gives three choices:

Yes save the puzzle, then execute requested action from File menu
No don't save puzzle, but do execute requested action
Cancel abort the requested action

Help

Hexominos offers three Help screens under the Help Menu.  The first menu item covers the 
rudiments of game play.  The second item gives the basics for creating new games.  The third item 
discusses the Part Editor and Game Board Editor.  To dismiss any of the help screens, just click 
anywhere in the Help Window.

A Hint on Game Play and Game Design

While I'm no mathematician, I recall something about a "four-color" theory involving arbitrary 
maps.  The theory says that you can draw ANY map in the world using just four colors to denote individual 
"countries."  I applied this notion in the design of Hexominos and the puzzles I've created.

You'll notice that Hexominos puzzle pieces can have one of four patterns.  The puzzles that I've 
designed have followed one basic rule:  identical patterns never meet on part borders.  For example, a 
light-gray piece will never directly adjoin another light-gray piece.  The immediate neighbor of a white 
piece must be one of the other three shades: light gray, gray, or dark-gray.

This rule is your first and foremost clue in solving my Hexominos puzzles.  Of course, if you 
decide to create your own puzzles, you're not required to follow this rule.



Creating New Puzzles

The Options Menu

This menu has two items.  The first item alternatively appears as Enable Edit  or Disable Edit .  
Editing is disabled by default, so that casual players needn't worry about accidentally ruining a puzzle.  
No game modifications (other than movement and rotation of pieces) can occur until Edit is enabled with 
this menu item.

You've probably noticed that all Hexomino pieces can be built out of simple square tiles.  The Unit 
Size... dialog lets you set the dimensions of this this tile, and therefore the size of each piece in a given 
puzzle.  Unit Size also sets the "grid" on which the game board is laid out.

Within the dialog box, click one of the four radio buttons to select the desired size (the given units 
are screen pixels, or 1/72 of an inch.)  A sample puzzle piece shows the effect of your selection.  Small 
pieces allow for the creation of more complex puzzles, while larger pieces are better for simpler puzzles.  
The choice is yours.

Unit Size should be changed with care.  While the changes to the puzzle pieces are always 
reversible, the changes to the game board may not be, except by re-editing the game board.  See the 
recommendations below, under "Where To Start".

Modifier Keys

Hexominos makes extensive use of the modifier keys COMMAND, OPTION and SHIFT in the 
game-creation process.  The mod-keys indicate the desired action to take (e.g., clone or delete) while a 
mouse-click on a part indicates the "object" of that action.

All of the allowable mod-key combinations are discussed below.  There's no need to memorize 
these combinations, however, as Hexominos will tell you exactly what each one will do, before you're 
committed to doing it.

Try it.  Choose Enable Edit from the Options menu and start hitting combinations of COMMAND, 
OPTION and SHIFT.  If the keys form a valid "verb", the indicated action will appear in a status window on 
the left-hand side of the menu bar.  The desired action does not occur until you click the mouse on the 
thing that you want to affect.

Where To Start

You can begin the creation of a new puzzle at any time.  You do so by modifying an existing 
puzzle.  The "Canned Game" puzzle is always available for this purpose, or you can start with a puzzle of 
your own, or one you've been given.

When creating a new puzzle, select the unit size early in the process, in order to avoid frequent 
re-designs.  When you select a new unit size, Hexominos attempts to scale the game board to the new 
size.  In doing so, it may distort the gameboard shape.  Therefore, it's recommended that your first two 
steps in designing a new game are:

1. Select the desired Unit Size
2. Design the game board (see Editing, below)



The Mod-Key Verbs

There are five basic actions involved in making a new puzzle, and four mod-key combinations for 
invoking these actions, as listed in the table below.  In this section, I describe the three simplest actions: 
Clone, Delete, and New Pattern.

Verb or Action Mod-Key Combination
Clone a part COMMAND + OPTION
Delete a part COMMAND + SHIFT
Select a new pattern for a part OPTION + SHIFT

Edit a part OPTION
Edit game board OPTION

To apply one of these "verbs" to a puzzle piece, press the appropriate modifier keys and then click on that 
piece.  Editing is discussed in the final section of this manual.

Clone Part

Makes a duplicate of the selected part.  The duplicate is placed 1/2 unit below and to the right of the 
selected part.  Hexominos currently supports a maximum of 25 puzzle pieces; if you try to create more, 
you'll get an alert explaining that fact.

Delete Part

Deletes the selected part.  An alert will appear asking for confirmation.

New Pattern

Brings up a dialog asking you to pick a new pattern for the selected part.  Simply click on the desired 
pattern (or on CANCEL).

Editing

All of the activities discussed so far in this manual occur in Hexominos' Game Window.  Editing, 
however, occurs in one of two additional windows: the Part Editor, or the Game Board Editor.

The Part Editor is invoked when editing is enabled, the OPTION key is pressed, and a mouse-
click occurs on a puzzle piece.  The Game Board Editor is invoked when editing is enabled, the OPTION 
key is pressed, and a mouse-click occurs on an exposed region of the game board.

The two editors behave almost identically, but since they work on different types of objects, there 
are a few differences that you may want to note.  First, we'll list the features that they share, and then 
we'll discuss the peculiarities.



Features Common to Both Editors

• invoke editor via OPTION + click on the object to edit
• close editor by clicking in the close box of its window
• you can't activate the game window without first closing the editor
• edit window can be dragged to new locations
• supports moving, creating, deleting of corner points, as described below
• identical alert box on close of editor (Use ... as Edited?)

YES return to game window, use part as edited
NO return to game window, abandon edit
CANCEL return to edit window, resume editing

Moving Corner Points

Simply drag the desired corner point to its new location.  Don't worry about creating intermediate 
shapes with strange angles.  What matters is the shape of the part (or the game board) when you close 
the editor.

In fact, you can leave the editor with parts that have odd angles.  But you might be surprised (or 
amused) at their appearance when you return to the game window.  It's worth trying this once, just for 
chuckles.

Creating New Corner Points

Place the cursor over the boundary of the part , where the new point should go, and click.

Try to do this at least one unit away from any existing corner points; otherwise, the newly-created 
corner point may be "invisible", and you'll sit there thinking that nothing has happened.  What has  
happened here is that the newly-created corner point was placed directly on top of an adjacent corner 
point.  Try moving one of the adjacent points, and you'll find the new one that was just created.

Deleting Corner Points

As you may have gleaned from the last sub-section, you "delete" a corner point by placing it 
directly on top of an existing corner point.  There are some technicalities here that I won't go into in detail. 
Suffice to say, the point is not really deleted, at least not until you've quit the editor.  But the effect is the 
same; the shape of the part (or the game board) is determined only by the visible corner points.

Peculiarities of the Part Editor

1. The part editor prefers to work on wide parts, rather than tall ones.  This distinction won't concern 
you unless you get extremely creative in the design of puzzle pieces.  If you do decide to get 
fanciful, heed this advice.

2. There is a limit to wierdness in part shapes.  When you close the editor, it will let you know if 
you've gone too far.  If you want to "test the limits", try creating 



parts that have numerous, long vertical extensions; that's the kind of shape most likely to upset the 
part editor.

3. "Deleted" corner points are in fact deleted when you leave the part editor; you won't see them 
again if you re-edit the same part.  However, no part can have more than 50 corner points.

4. It's conceivable (though not likely) that certain parts are simply too complicated for the editor to 
input.  If this should happen, you'll get an alert as you OPTION-click on the part.

Peculiarities of the Game Board Editor

1. The Game Board is edited in a window that has the same size as the game window.  The Game 
Board is not necessarily centered in its editing window , but appears in the same location in both 
windows.  What you see is what you get.

2. Try not to create unnecessary corner points in the Game Board Editor, since redundant corner 
points in the game board polygon are never really deleted.  They don't hurt anything, but they do 
make further editing a bit more difficult.

3. You can in fact create rather arbitrary polygons with this editor.  The results are amusing but not 
very useful.

4. Game-board polygons can use no more than 50 corner points.



About Hexominos

Hexominos is shareware.  Honor system and all that.  So I'll simply say:  if this is something you like, and 
would like to see more of, send a token contribution, in any amount.  Your interest may have a bearing on 
new contributions from this author.  If you have comments or suggestions, please forward them to me, 
and I'll do my best to respond.  My name and address appear in the About Hex... item under the Apple 
Menu, and are repeated below:

Raphael Bustin
134 Kramer St.
Rochester, NY 14623

Hexominos is not my first program, but it is my first "serious" program for the Mac.  Listed below are some 
known limitations that you should be aware of:

• Has NOT been tested on any model Mac other than Mac Plus
• Has NOT been tested extensively under Multifinder
• Has NOT been tested in any networking environment

Hexominos was created using Think C  v3.01 (Symantec Corp.)  Resources were created with both 
RMaker and ResEdit.  Source code is available to interested developers and aspiring Mac programmers 
for a nominal fee.

Macintosh, Mac Plus, Finder, Multifinder, Resource Editor are trademarks of Apple Computer, Inc.  Think 
C is a trademark of Symantec Corp.


