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Introduction 

 Face*Maker program and documentation copyright (c) 1992 by Alan Page 

 Face*Maker is a program for producing images of faces using a library of pre-defined elements, e.g. 
heads, noses, eyes and mouths. You can also add a text caption to create an eye-catching sign. After you 
have produced your face, you can print it out or copy it to the clipboard as a bitmapped image. 

 The program can also 'animate' the display by randomly changing selections in each window. 

 Each of the head shapes has a number of hot spots for facial features such as a nose, a mouth, eyes, 
and hair. When you select a new head, the various features move to the proper locations on that head. If 
you click on a different selection of the same type (e.g. a different nose), then the new selection replaces 
any existing feature of the same type. 

 I wrote this program to help me learn to program for Microsoft Windows(tm) and to demonstrate my 
abilities to potential employers. The program was written in the C language using Borland C++ 2.0. The 
images used in this program were created in a separate drawing program that I also wrote. That program 
will be released at a later date. 

 Face*Maker is an MDI program, meaning that you can have many independant face windows on the 
screen at one time. 



Getting Started 

 Select Load Library from the File menu and choose the filename "FACELIB.CLK". It will take about 30-40 
seconds to load. 

 Select New Face from the File menu. 

 A listbox in the top left corner of the Face window will list the available item categories, e.g. "Nose", 
"Mouth" and "Eyes". Click on one of the category names. A strip of images will appear below the listbox. 

 Click on one of the images to select it. The selected image will appear full size in the main window. Use 
the up and down cursor keys to scroll through the available images. 

 Select a different category name to see a new set of images. In most cases you will select one image 
from each category; in the case of Eyes, select both a right and left eye. Note: "Hair" is a category that 
does not necessarily go with all possible heads. 

 The current selection (if any) is always highlighted in inverse video. To delete the current selection from 
the screen either press the Delete key or click the left mouse button on the Delete icon. This will delete 

any item(s) in the current category. 

 

 The Delete icon (pictured above) is a square box with an "X" inside. 



Face*Maker Keys 

 Related Topics 

 Text Editing Keys 

 Use the following keys when selecting images and categories: 

 Key(s) Function 

 Left or Up Arrow Selects previous image. 

 Right or Down Arrow Selects next image. 

 Delete Removes current selected image from screen. 

 Page Up Selects previous category in list box. 

 Page Down Selects next category in list box. 



Text Editing Keys 

 Use the following keys when editing text in the caption box: 
 (You may need to click inside the caption box to activate it.) 

 Movement Keys 

 Key(s) Function 

 Up Arrow Moves up one line. 

 Down Arrow Moves down one line. 

 Right Arrow Moves right one character. 

 Left Arrow Moves left one character. 

 Home Moves to start of line. 

 End Moves to end of line. 

 Ctrl+Home Moves to start of caption text. 

 Ctrl+End Moves to end of caption text. 

 Text Selection Keys 

 Key(s) Function 

 Shift+Right Arrow Selects text one character at a time to the right. If the character is 
already selected, cancels the selection. 

 Shift+Left Arrow Selects text one character at a time to the left. If the character is already 
selected, cancels the selection. 

 Shift+Up Arrow Selects text one line up. Or, if already selected, cancels the 
selection. 

 Shift+Down Arrow Selects text one line down. Or, if already selected, cancels the selection. 

 Shift+Home Selects text to start of line. 

 Shift+End Selects text to end of line. 

 Ctrl+Shift+Home Selects text to start of caption text. 

 Ctrl+Shift+End Selects text to end of caption text. 



Face*Maker Commands 

 To get help with a command, choose the appropriate menu. 

 File Menu 
        New Face 
        Open Library 
        Close 
        Print 
        Printer Setup 
        Exit 

 Edit Menu 
        Cut 
        Copy 
        Paste 
        Clear 
        Copy Bitmap 

 Text Menu 
        Normal 
        Bold 
        Italic 
        Underline 
        Fonts 
        Caption On (Caption Off) 

 Scale Menu 
        Fit Into Window 
        50 % 
        100 % 
      Portrait (Landscape) 

 Preferences Menu 
        Animate 



Procedures 

 The Procedures topics give more details on how to use Face*Maker. 

 Printing a picture 
 Editing Text 
 Moving and Sizing Caption Box 
 Changing Character Styles 



File Menu 

 New Face 
 Opens up a window for creating a face. You can open up as many Face windows as you want, subject to 
available memory and system resources. You cannot select this item until you open a Face*Maker library 
file. 

 Open Library 
 Opens a Face*Maker library file. Face*Maker uses a custom file format to contain both the graphic 
images and positioning information. 

 Exit 
 Closes all open windows and quits the program. 

 Once you have opened up at least one Face window, three new items appear on the File menu; Close, 
Print, and Printer Setup. 

 Close 
 Closes the current active window. You are prompted to confirm you want the window closed before the 
window is actually closed. Once you close a Face window, the selections you made to create a face are 
forgotten. 

 Print 
 Prints the contents of the current active window. In order to print, you must have a printer installed and 
active. See your Windows User's Guide on how to use the Control Panel to install a printer. 

 Printer Setup 
 Lets you select a printer and configure it. 

 Related Topics 

 Printing a picture 



Printing a Picture 

 You will notice that there is a rectangle around the face in the Face window. That rectangle is the page 
frame, intended to represent an 8 1/2" by 11" sheet of paper. How the contents of the page frame will be 
printed depends on how you have configured your printer. Depending on the printer driver, you may be 
able to select different paper sizes, different orientations (Landscape or Portrait) and various printing 
resolutions. 

 The area inside the page frame will be printed out as large as possible on your printer, without stretching 
or shrinking the image.    To assist this, you should select the same orientation (landscape or portrait) both 
within the Face*Maker program and in Printer Setup. You can choose different orientations for printer and 
program, but this will usually result in a smaller printout. 

 While the picture is printing, a dialog box is visible which displays the progress of the printing. Clicking on 
the "Cancel" button cancels the printing process. 



Edit Menu 

 The edit menu is used to cut and paste text from the text caption box to and from the Windows clipboard. 
It can also be used to copy the picture on the screen to the clipboard as a bitmapped image. 

 Related Topics 

 Editing Text 

 Cut 
 If you have selected some text in the caption box, Cut deletes the text and places it onto the Clipboard, 
erasing the previous Clipboard contents. 

 Copy 
 If you have selected some text in the caption box, Copy copies the text to the Clipboard, leaving the 
selected text intact. The previous clipboard contents are erased. 

 Paste 
 Pastes text from the Clipboard into the caption at the insertion point or replaces selected text in the 
caption. 

 Clear 
 Erases selected text from the caption, but does not copy the selection to the Clipboard. 

 Copy Bitmap 
 Takes a snapshot of the contents of the page frame and copies it to the Clipboard in bitmap format, 
suitable for pasting into paint programs such as Windows Paint. The bitmap is the same scale as the 
image in the current Face window. 



Editing Text 

 Most of the editing features are similar to those in Windows Notepad. If you already know how to edit text 
in Notepad, then you should have no difficulties. 

 Creating a Caption 
 If there is no caption box visible on the screen, choose Caption On from the Text menu to create a 
caption box. 

 Making the Caption Active 
 If you don't see the text caret inside the caption then click inside the caption box to make the caret 
appear. 

 To copy or cut text, first select the text. Choose Copy from the Edit menu to copy the selected text to the 
clipboard. Choose Cut to copy the text and then delete it from the caption. 

 Move the insertion point where you want the text to appear and choose Paste from the Edit menu. 

 To replace a section of text with text from the clipboard, first select the text to be replaced then choose 
Paste from the Edit menu. 

 Choose Clear to erase the selected text from the caption without copying it to the Clipboard. You can 
also press the delete or backspace key to erase selected text. 

 Related Topics 

 Edit Menu 
 Editing Keys 



Moving and Sizing Caption Box 

 The caption box can be sized and moved anywhere inside the window. However, any portion that 
extends beyond the page frame will not be printed. 

 Move the mouse pointer over one of the sizing handles located in the corners and sides of the caption 
box. You will see the mouse pointer change to a shape which indicates in what direction you can size the 
box. 

  

 
 
 Pointer shapes for sizing caption box. 

 Hold down the left mouse button and drag the outline to the desired size. Release the mouse button and 
the text will reformat itself to the new size. Note: You cannot size the box below a certain fixed size. 

 Moving the Caption Box 

 1. Position the mouse pointer near one of the sides of the caption box until the pointer changes to the 
shape of a hand. 

 2. Hold down the left mouse button and drag the box outline to the new location. 

 3. Release the left mouse button and the box will be redrawn in the new location. 

 Additional Features 

 Hold down the shift key while sizing and the box changes size equally in all directions. 

 To size the box to fix precisely around text: 
 1. Move the mouse pointer over the sizing handle in the bottom right corner. 
 2. Hold down the Control key and then drag the pointer diagonally towards the upper left corner. The 
caption box will shrink until it fits equally around the text on all four sides. 



Text Menu 

 Use the text menu to create and modify a text caption. You can position the caption anywhere in the 
window and alter its size. You can choose any available font for the caption and use bold, underline, and 
italic character styles for emphasis. 

 Normal 
 Sets the character style to normal. 

 Bold 
 Sets the character style to bold. 

 Italic 
 Sets the character style to italic. 

 Underline 
 Sets the character style to underline. 

 Related Topics 

 Changing Character Styles 

 Fonts 
 Opens a font selection box to select a different font or font size for the text caption. 

 Caption On (Caption Off) 
 Creates a text caption or, if a text caption exists, destroys it. 



Changing Character Styles 

 You can apply more than one character style to the same characters by selecting text and then choosing 
character styles from the Text menu. A check mark appears next to the current character styles. Selecting 
a character style with a check mark next to it will cancel that style. Selecting Normal cancels all styles. 

 You can mix character styles in the same text caption by selecting a portion of text and choosing a 
character style from the Text menu. The style you choose will be applied to the selected text. Or, if the 
style is already present in all the text you have selected (as indicated by a check mark next to the style in 
the menu) it will be removed from the selected text. 



Scale Menu 

 Use the Scale menu to choose what scaling to use for the current active Face window. The current 
selection is indicated with a check mark. 

 Fit Into Window 
 Scale the drawing so that it always fits into the current window. This is useful for sizing an image that you 
want to copy to the clipboard as a bitmap. 

 50% 
 Scale the drawing to appear approximately 50% of actual size. 

 100% 
 Scale the drawing to appear approximately actual size in the window. This is the scale at which the 
drawing was originally composed. It is not necessarily the scale at which it will be printed out, which 
depends also on how your printer is set up. 

 Portrait (Landscape) 
 Choosing Portrait or Landscape will cause the page frame to be adjusted to reflect the new selection. 
The program is based on an 8 1/2 inch by 11 inch page frame. However, if your printer uses smaller or 
larger paper, the final printout will be scaled to fit the actual paper size. 



Preferences Menu 

 Animate 
 Randomly changes the selections in each window to display a different face. The program will keep on 
animating the faces until you press a key. 



Multiple Document Interface (MDI) is a specification for Windows applications that handle multiple 
document windows. The Windows Program Manager is an example of an MDI application. Each Program 
Group window in the Program Manager is an MDI window. 

 Each window in an MDI application can be minimized into an icon (try minimizing a FACE window to see 
an interesting effect), tiled, or cascaded in a standard manner. 



A hot spot is a coordinate that indicates where something is to be positioned. 




