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1. Introduction

For ASCII text files there are plenty of editors around, but when it comes to editing binary files your choice is 
limited. Within this limited selection most binary editor directly edit the file in place, that is on the hard disk or 
floppy. This for one is sometimes very slowly, specially when you are scrolling or paging through the file, and 
second, it prevents direct inserting or deleting.

ARIS HexEdit takes a different approach, where the file is completely loaded into memory. Given that, you can 
scroll, page and search very fast in the entire file and it enables you to insert and delete portions of the file and to 
use the Windows clipboard for  the functions cut, copy and paste.

But to be honest, there is a minor drawback. You can only load and edit files that fit into the virtual memory 
provided by your Windows installation. As this is mostly big enough (and can be increased if necessary) you 
should not encounter such a case very often.
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2. Installation

Installing ARIS HexEit  to your hard disk is an easy process. Simply insert the disk into a floppy drive and run 
the setup program. To do this, select “Run” from the “File” menu of the Windows Program Manager and enter  
“A:SETUP”. If you have placed the installation disk into another drive than A: you have to subsitute the A with  
the letter of the drive you are using.

Now an automated installation procedure prompts you for a directory. If the default installation directory (C:
\ARISTOOL) does not suit you, simply type in another drive and/or directory. If the directory you are specifying 
does not yet exist it will be created by SETUP.

Now SETUP will  copy all  necessary  files  to  your  hard  disk.  Please  note  that  some DLLs (Dynamic  Link  
Libraries) will be copied to the system directory of your Windows installation if they do not already exist or if  
older versions of this DLLs are detected. These DLLs are placed in this Windows subdirectory rather than in the  
installation directory as some other programs use this DLLs too. In order to ensure that you have not multiple  
copies of the same DLL on your hard disk, they are installed to that directory.

3. Loading files

There are four ways in which you can instruct ARIS HexEdit to open an existing file. Each of these four methods 
is described in the following chapters.

3.1 The File open dialog

You can use the "File open" dialog to open a file. This dialog appears whenever you select the topic "Open..."  
from the File menu or when you click to the open symbol in the smart icon bar.
The picture below shows the smart icon bar of ARIS HexEdit.

(Picture of File Open dialog)

In the dialog box shown above you can now select one file to load. A single file can be loaded by selecting its  
name in the file list and pressing the OK button. Double clicking on a file name results also in this file being  
loaded.

3.2 Loading files by command line
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You can instruct ARIS HexEdit to load files immediately on startup by specifiying their names on the command 
line. This is specially useful if you want to have several copies of the ARIS HexEdit icon in various groups on 
your desktop, where each icon loads different files. You can copy the icon of ARIS HexEdit by clicking on one  
icon in a group of the Program Manager while holding the Ctrl key down and dragging it to another place. In the 
properties of such a copy you can now specify the files to load on the command line. In the picture below you  
see an example how to load the WIN.INI on startup.

Of course you can enter more than one file at this place. If the files you want to load do not exist in the specified  
working directory you must supply their full path names (i.e. C:\WINDOWS\WIN.INI).

3.3 Drag and drop

If you want to edit one or more files in an already running instance of ARIS HexEdit  you do not need to go  
through the file open dialog several times. You can simply grab the files from the Windows File Manager and  
drag them to the window (or icon if it runs minimized) of ARIS HexEdit while holding the left mouse button  
down. Once the cursor is above the window or icon you simply release the left mouse button (drop the files) and 
ARIS HexEdit will load them.

3.4 Using the MRU list

ARIS HexEdit  maintains a MRU list (Most Recently Used) of up to four files you edit. Each time you open a  
file it is moved to the top of that list while all other files will be moved one place down with the last file 
dropping out of the list if there are already four files in it.
If you load a file that is already in the list it also will be moved to the top of the list but with no file dropping out.
The list is maintained in the File menu just above the Exit topic. Now if you want to load a file you worked with  
recently just open the File menu and select the file's name from the list.
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3.5 Associating HexEdit with file types

Within the Windows file manager you can easily associate file types you frequently edit with ARIS HexEdit. As 
ARIS HexEdit registers itself in the Windows registration database all you have to do is to select the topic 
“Associate...” from the file managers File menu, enter an extension (i.e. .BIN) and choose “ARIS HexEdit” from 
the list of available applications.

From there on a simple double click on a file with such an extension in the Windows file manager automatically 
launches ARIS HexEdit with this file. Subsequent double clicks (with ARIS HexEdit already started) simply 
open additional windows within ARIS HexEdit, because its capabilities as a DDE server. 
You can even print with ARIS HexEdit without specifically launching it. Simply drag a file whose extension is 
associated with ARIS HexEdit to your Windows Print Manager. Windows will then launch ARIS HexEdit (or 
using an already running instance), instruct it to print the dragged file and terminate it in case it was not already 
running.

Note: You must start ARIS HexEdit at least once before you can associate a file extension to it, as it 
creates the entries in the Windows registration database on startup rather than during 
installation.
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4. The menus

The following chapter describes the menus and their topics of ARIS HexEdit. Please note that some menus and 
topics are only available if a file is opened for editing.

4.1 The File menu

The File menu contains all file related topics, such as opening, saving and printing.

- New This topic creates a new empty file. Please note that you must use the Insert function 
before you can edit such a newly created file. If you close the window containing the file or if 
you exit ARIS HexEdit you will be prompted for a filename for saving the file.

- Open... This topic opens a dialog box where you may select  a file for opening. After pressing the OK 
button, the file will be read into memory, a new window will be created for the file and the  
first page of the file will be displayed. For a deeper discussion of file opening please refer to  
chapter 3.

- Close This  function  closes  the  currently  active  window.  The  contents  of  the  window is 
discarded. If the file in that window has been changed after it was last saved, you will be 
prompted if you want to save it now. If you decide not to save your changes here, all changes 
will be lost.

- Save This topic saves the file in the current window under its original name. You will not be 
prompted for overwriting if this file already exists, since ARIS HexEdit assumes that you have 
loaded the file under this name.

- Save as... This menu item allows you save a file under a different name. If you specify a name of a file 
that already exists, you will be prompted for overwrite permission.

- Print... This menu item prints the file in the currently active window. Before the actual printing takes  
place you are able to change the printer and/or its setup.

- Print Preview This function shows you how the actual output on the printer will look like. This might be 
useful to locate the page which contains a certain information in order to print only this page. 
Please note  that  the amount  of  bytes  that  fit  on a  single  line depends here on the printer 
adjustments and paper sizes rather than on the width of the editing window.

- Print Setup... This topic allows you to change the printer and/or its setup you want to use for printing with 
ARIS HexEdit. These changes are only temporary and local to ARIS HexEdit. All other 
applications will still use the standard printer and its setup.

- MRU list Right before the Exit topic you find up to four file entries. These filenames reflect the last four 
files you edited with ARIS HexEdit. So if you want to open a file you recently edited this list is 
a good place to look at.

- Exit By selecting this menu topic you end your current session with ARIS HexEdit. All 
currently open windows will be closed at once. If any file in an open window has been changed 
you will be prompted for saving it.
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4.2 The Edit menu

The edit menu contains several topics for clipboard handling. It also enables you to reverse editing operations or 
to repeat reversed operations.
Please note that ARIS HexEdit uses a special format for copying binary information to the clipboard. It can 
however insert ANSI or OEM text from the clipboard to a binary file.

- Undo This function reverses the last editing operation. The amount of operations that can be 
reversed is limited to 100. If you find this to small from your experience, please contact our 
technical support.

- Redo This item reverses the last undo operation. Whenever you have used Undo too much 
you can easily recover your work.

- Cut This  function  copies  the  marked  area  from  the  currently  active  window  to  the 
clipboard. Additionally the marked region is deleted from the text. You may use this topic in  
combination with the Paste topic to move information from one location to another.

- Copy By using this topic the highlighted area from the currently active window is copied to 
the Windows clipboard. You can use the Paste function to insert this information in another file  
or in another location in the same file.

- Paste This topic inserts the contents of the Windows clipboard at the current cursor position 
in the active window. If you have marked an area while using this function, this highlighted 
portion of the file will be deleted before the contents of the clipbord is inserted. In other words 
you can replace one portion of a file by the contents of the clipboard.

- Find... This topic causes the Find dialog to pop up. Into this dialog you can either enter a simple string 
or a hexadecimal expression you want to search for.
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- Replace... By selecting this topic ARIS HexEdit   pops up the  Replace dialog. You can search for a 
specific string or hexadecimal pattern and, when found, decide for each occurance of the search 
expression whether to replace it by another expression or not.

Optionally you can also instruct ARIS HexEdit to replace all occurances of the search 
expression without further prompting.

- Insert bytes... With this function you can insert  a certain amount of bytes at  the current cursor location.  
Depending on the settings of ARIS HexEdits options you may get a warning before the bytes 
are actually inserted. The inserted bytes are padded to NULL.

- Delete bytes... This function enables you to shorten binary files by a specific number of bytes. The bytes are 
deleted from the current cursor position on. Depending on the settings in ARIS HexEdits 
options you may get a warning before the specified number of bytes is deleted.
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4.3 The View menu

The View menu allows you adjust the appearance of ARIS HexEdit and the current cursor location within the 
currently active window.

- Jump to offset... With this function you can easily move the cursor to a certain location within the active file. 
Simply enter the decimal offset in the file in the dialog box shown  below. Alternatively you 
can also enter the offset as a hexadecimal number. For that you must preceed the offset with 
an 0x’ (zero and the character x).

- Toolbar This menu item enables or disables the toolbar containing the smart icons. If you have a 
small screen and need more space for the file windows themselves, disable the toolbar and, 
optional, the status bar.

- Status Bar This option toggles the visibility of the status bar.
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4.4 The Options menu

The Options menu provides dialogs for several adjustments in the general behavior of ARIS HexEdit. Among 
other things you can set the font used for a window or the default font used at startup.

- Options... This menu item opens a dialog where you can set 

· if ARIS HexEdit should create backup copies of files you edit,
· if you will be warned when you either insert or delete portions of a file.
· the default font used for newly created windows,

- Font... With this topic you can change the font used for the currently active window. Which fonts you 
can choose from depends on your particular Windows installation. Please note that ARIS 
HexEdit only allows fixed pitch fonts.

4.5 The Window menu

The Window menu provides some functions to change the size and locations of the open file windows.

- New Window This menu topic creates a new window of the currently active file. You can have two or more 
windows (views) for the same physical file. Each view is updated immediately after you 
applied a change in another view window.

- Cascade The Cascade command arranges the windows on your desktop in a tiered or cascading fashion.

- Tile vertical The Tile  vertical  command redisplays  windows on your  desktop in  such a  way that  each 
window becomes the same size. However, this tiling occurs in such a way, that the windows 
are as high as possible.

- Tile horizontal The Tile horizontal command redisplays windows on your desktop in such a way that each 
window becomes the same size. However, this tiling occurs in such a way, that the windows 
are as wide as possible.

- Arrange icons The Arrange icons command rearranges the icons on your desktop into neat rows and columns.
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- List of open windows
Below the Arrange icons’ topic ARIS HexEdit lists all currently open window and 

places a checkmark to the currently active window. By selecting a file name from this list you 
can easily switch to another window even if it is totally obscured by other windows.

5. Using the Windows clipboard

With ARIS HexEdit you can use the Windows clipboard to copy or move portions of a file within a file or 
between different files.
Before you can copy anything to the clipboard you must highlight the part of the file you want to cut or copy. 
This can be done in several ways:

1. Hold down the Shift key while moving the caret with the arrow or page keys. The selection (shown 
according to your Windows color selection) will grow or shrink accordingly.

2. Place the caret at the first byte you want to select by clicking with the mouse onto that byte. Then scroll 
the last byte to select into view if necessary and click onto the byte immediately following while holding 
the Shift key down.

3. Position the mouse cursor at the first byte you want to select and drag (moving the mouse while holding 
the left button pressed) to the last byte to highlight. As you move the mouse you will see the highlighted 
area growing or shrinking accordingly. Whenever you move the mouse cursor above or beyond the 
current windows border ARIS HexEdit will start to scroll up or down while extending the selection.

After you have selected a portion of a file you can either cut it from the file or simply copy it to the clipboard. 
Cutting will still copy the selected area to the clipboard, but will also delete it from the current file. Copying 
leaves your file untouched.

As ARIS HexEdit handles binary information of any kind it needs a special clipboard format. Any information 
copied to the clipboard is only available for pasting within ARIS HexEdit. Other applications will not be able to 
handle this format.
You can, however, paste simple text into a ARIS HexEdit window, which you copied from another application.

Please note that pasting normally inserts the contents of the clipboard at the current caret location, which in fact 
will increase the size of your file. Use this function carefully, as inserting in binary file often makes the file 
unreadable for the application that uses this file.

Whenever you paste anything from the clipboard into a file with an area highlighted, the paste function will 
replace the highlighted portion of the file with the contents of the clipboard.
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6. The keyboard layout of HexEdit

ARIS HexeEdit uses a couple of key combinations that are common to most Windows programs. The following 
table describes the keys and their functions.

Clipboard functions:

Shift+Del Cut
Ctr+X Cut
Ctrl+Insert Copy
Ctrl+C Copy
Shift+Insert Paste
Ctrl+V Paste

Undo and redo functions:

Alt+Backspace Undo
Ctrl+Z Undo
Shift+Backspace Redo
Ctrl+A Redo

Menu accelerators:

Alt+F3 Invokes find function
Ctrl+J Jump to offset
Ctrl+N Create a new file
Ctrl+O Open an existing file
Ctrl+P Print the active file
Ctrl+S Save the current file

Editing keys:

Del Delete selected area
Tab Toggle ASCII/hex mode
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7. The smart icon bar

The smart icon bar is located just under the menu of ARIS HexEdit and allows single click access to several 
often used functions.

The picture above shows the icon bar completely. You will note that the spacing divides it into several sections.  
Each section belongs to a certain group of commands which will be explained in this chapter.

The first group consists of three buttons, which are all related to file operations. The first button creates a new 
empty window and thereby causes the same function as if you select "New" from the file menu. The second 
button corresponds to the topic "Open..." from the same menu and the third button saves the current file to disk.

The next group of three buttons corresponds to the major functions of the edit menu. To cut, copy or paste text  
simply press the according button.

The next two buttons are associated to the undo and redo commands of the edit menu. To undo the last editing 
operation press the first button in this group, to reverse the last undo operation press the second button.

This button initiates a search and therefore is similar to the item “Find...” from the “Edit” menu
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These three buttons rearrange the currently opened windows. The first button tiles the windows vertical and the 
second horizontal.  However,  with  a  large  number  of  open  windows pressing  each  button  may arrange  the  
windows in the same sizes and locations. The third button simply arranges the windows again stacked, just as  
they are ordered when you newly open them.

The first of the last two buttons prints the current file and thereby is equal to the topic "Print..." in the file menu. 
The second button shows you version and build information about ARIS HexEdit.
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8. The status bar

The status bar at the very bottom of the ARIS HexEdit window is divided into six panels. The following picture 
shows the purpose of each panel.

The message panel shows the full path name of the file in the active window and its length in bytes. This panel 
also shows a brief explanation of menu items as you click on them.

The file offset indicators show you the current caret position in the active file in hexadecimal and in decimal 
numbers.

The last three indicators reflect the state of the keys CAPS, NUM and SCROLL on your keyboard.
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9. ARIS HexEdit error messages and warnings

The file you tried to load into ARIS HexEdit is too large. Either close other currently running applications to free 
more memory or increase your swapfile size in order to supply more virtual memory for your system.

This message appears whenever ARIS HexEdit could not open a file and read it into memory. Possible causes for 
that are:

· Insufficient memory
· Insufficient available file handles
· Insufficient access rights on a network
· Corrupt file system

ARIS HexEdit failed to create a backup file of the file you loaded into it. Check if such a file already exists and 
is write protected.
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This warning appears every time you attempt to increase the length of a file by any operation if you checked the 
appropriate option in ARIS HexEdits options. Press Yes’ to proceed with the current operation or No’ to abort it.

This warning appears every time you attempt to decrease the length of a file by any operation if you checked the 
appropriate option in ARIS HexEdits options. Press Yes’ to proceed with the current operation or No’ to abort it.
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