
The protocol for moving hypertext files across the Internet. Requires an HTTP client program on one end, and an 
HTTP server program on the other end. HTTP is the protocol used by the World Wide Web (WWW).



The main communications protocol in the Internet suite of protocols that provides reliable, connection-oriented, full 
duplex streams and uses IP for delivery.



Action messages are brief descriptions of what you want the other users to picture you doing. For example, if 
another user says something funny, you might post the action message “Raven giggles”. Action message are 
automatically preceded by your nickname, so write your action in the third person. For example:

*Raven waves hello to everyone



Private action messages are sent only to the specified user, preceded by your nickname. For example:

*> Raven winks at you secretly ...

Your nickname does not appear in the Action field, but it will be the first word of your action message.



Points to a specific Web site.



A file that contains characters other than the standard ASCIIcharacters. Binary files cannot be read like text files; 
they are usually executable programs or compressed files.



An abbreviation for American Standard Code for Information Interchange. This standard code consists of 7 data 
bits (or binary values) per character. Letters, numbers, and special characters (for example, $,ÿ,#, %) are 
represented by different ASCII codes. The ASCII character set represents 96 printable characters and 32 non-
printable control characters.



A Cyberjack bookmark object that as acts a direct shortcut to an Internet site. You can create CyberLinks to your 
favorite sites, and send them to other users through email. Also, any URL you can takes you to another site when 
you double click it is also a CyberLink.



Hypertext Markup file. This file type can be read directly by Cyberjack Web.



A pointer to remote sources on the Internet.



Control the way you search by selecting Exact, Case Sensitive, Case Insensitive or Regular Expression.



When lurking, you are watching the chat to learn more information about the terms and expressions used in the 
chat.







For information on a specific topic, click the item. 



Type the Internet domain name or IP address of your news server.



Type the port number of your news server, or leave the default of 119.



For information on a specific topic, click the item.



Type the name of the newsgroup you want to read, or a search string to filter the newsgroup list.



Select the newsgroup you want to read.



A description of the newsgroup currently selected in the list as provided by the server. Note that some servers do not provide 
descriptions for their newsgroups.



The current state of the connection that is retrieving the list of newsgroups.



Enable to change the name given to the file when saving encoded binary attachments to disk.



Enable to reorder messages when attempting to save multipart articles to disk.



For information on a specific topic, click the item.



Click to hide header information when viewing an article.



Click to show all available header information when viewing an article.



Click to show only important header information.



For information on a specific topic, click the item.



Click to wrap lines longer than the specified number of characters to the next line.



Click to automatically wrap lines longer than the width of the window to the next line.



Type the maximum number of characters per line before the text is wrapped to the next line.



For information on a specific topic, click the item.



Enable to automatically detect attachments in articles.



Type the maximum number of lines per article before an article is presumed to contain an attachment.



Type the text you want to appear before text that you quote in a reply. You can also include the following variables:

%Author% the author’s name and address

%Subject% the subject of the article

%MsgID% the article’s message ID

%Date% the date the article was written (DD/MM/YY)

%LongDate% the date the article was written, in words

%Time% the local time the article was written

%TimeZone% The local time zone



For information on a specific topic, click the item.



Click to always quote the original article in your replies.



Click to never quote the original article in your replies.



Click to be prompted before quoting the original article in your replies.



Type the character to be inserted before each line of quoted text.



For information on a specific topic, click the item.



Enable to automatically include your signature file with each article you post.



The text of your signature file.



For information on a specific topic, click the item.



Type your full name.



Type your Internet email address.



Type the name of your company or organization.



Click to save the article list for the current newsgroup to your local drive.



The name of the current newsgroup.



The description of the newsgroup on the current news server.



For information on a specific topic, click the item.



The current news server.



The port number of the current server.



The email address of the current server’s administrator.



This is the news server that is used when writing replies to the newsgroup if a different server is required for replying.



Causes the reply host to be used when writing replies to the newsgroup.



The port number of the reply server. This is usually 119.



The subject of the selected article.



The author of the selected article.



The organization to which the author of the selected article belongs.



The newsgroups where the selected article was posted.



The date the selected article was written.



Type the name of your signature file.



Click to browse for your signature file.



Click to save the list of available newsgroups for your news server to your local drive.



The number of lines in the selected article.



This is where you specify what newsgroups your article will be posted to. You can add a new group by entering text in the edit box 
below.



You can enter a newsgroup name here to add it to the list.



The list of newsgroups that you article will be posted to. Right click on an item to delete or edit it, or alternatively press the <DEL> 
key.



For information on a specific topic, click the item.



Click to not split articles you post into smaller parts.



Click to automatically split articles you post into smaller parts.



Type the maximum number of lines allowed before an article you post is automatically split up into smaller parts.



The list of articles in the order they will be unencoded. Click OK to reorder the articles before decoding.



For information on a specific topic, click the item.



Click to not apply subject filters. All articles will be visible in the article list.



Click to hide articles containing the specified subject.



Click to show only those articles with the specified subject.



Type the subject or part of the subject you want to filter.



The list of subjects to be filtered. To remove a subject, select the subject and press DELETE.



For information on a specific topic, click the item.



Click to not apply author filters. All articles will be visible in the article list.



Click to hide articles by the specified author.



Click to show only those articles by the specified author.



Type the name of the author you want to filter.



The list of authors to be filtered. To remove an author’s name, select the name and press DELETE.



The list of header values associated with the current article.



The data corresponding to the header value currently selected in the listbox above.



The name of the news server used when writing replies to the newsgroup.



Enable to change the default name of files before downloading them. 



For information on a specific topic, click the item.



Type the name of your news server.



Type the port number of your news server, or leave the default of 119.



Launches the wizard to guide you through the process of opening a newsgroup.





Select the item to change its appearance.



Select a new size for the selected text item.



Select a new color for the selected text item.



Select a new font for the selected text item.



Returns the color, font and size of all items to their default settings.







The status of Cyberjack Ping’s search for the specified Internet address.



The result of Cyberjack Ping’s last data packet sent to the specified Internet address.



The average response time, in milliseconds, of a returned Cyberjack Ping data packet.



Click to have Cyberjack Ping send data packets to the specified site.



Type the site for Cyberjack Ping to diagnose.



Type the path and name of the folder to receive all downloaded files.



Enable to confirm overwriting existing files.



Enable to view partial images as they are downloading.



Enable to open files when they are downloaded.



Enable to show the Transfer Summary window    when files are downloaded. Use this window to open or delete files.



Enable to minimize the transfer dialog. The minimized dialog appears at the bottom of the screen.



Enable to change the default name of files before downloading them.



Enable to flash the icon of a minimized Cyberjack program on the Windows Task Bar when files are downloaded.



Enable to maximize a minimized Cyberjack program when files are downloaded.



Enable to play a Windows system sound when files are downloaded.



Enable to notify you when each file transfer in a group transfer is complete.



Enable to notify you when a group transfer is complete.



Enable to set up the type of notification you want when files are downloaded.



Specify how you want to be notified after group transfers.



Browses for the folder to receive all downloaded files.



Specify the options for file transfers.



Enable to check for viruses in the downloaded files.





Your password for the Guidebook.



Your password for the Guidebook.



Lists the folders and files in the selected location.



Lists the folders and files in the selected location.



Type the name of the file.



Type the name of the file.



Selects the type of file to save.



Selects the type of file to save.



Opens the file with the name, file type, and location you specified.



Saves the file with the name, file type, and location you specified.



Connects to a new newsgroup.



Opens News CyberLink.



Closes newsgroup.



Saves newsgroup to Guidebook.



Saves newsgroup to Guidebook with new name.



Email News CyberLink.



Displays newsgroup properties.



Closes the program.



Copies selected text or article to Clipboard.



Selects all articles or text.



Selects all articles of multipart attachment.



Selects all previously unselected items. 



Find specified text.



Repeat last find.



Toggles Toolbars.



Toggles Status Bar.



Repositions splitter bar.



Splits the window horizontally.



Splits the window vertically.



Displays articles in large icon format.



Displays articles in small icon format.



Displays articles in a list format.



Displays detailed list of articles.



Sorts articles by article number.



Sorts articles by subject.



Sorts articles by author.



Sorts articles by date.



Sorts dates and article numbers in reverse order.



Edits author names in filter list.



Edits subject titles in filter list.



Hides articles by the current author.



Hides articles with the current subject.



Hides previously read articles.



Toggles thread window.



Toggles ROT13 encryption.



Toggles display of ANSI colors.



Go to previous page.



Go to next page.



Reloads article list.



Diagnoses an Internet connection.



Displays contents of Download folder.



Displays previous article in list.



Displays    next article in list.



Displays previous article in thread list.



Displays next article in thread list.



Saves selected articles.



Decodes selected articles.



Marks selected articles as read.



Marks selected articles as unread.



Displays article header information.



Posts a reply to the current article.



Posts a new article.



Emails reply to article author.



Forwards the current article by email.



Changes News options.



Upgrades Cyberjack.



Displays index of News Help topics.



Displays index of Cyberjack Help topics.



Toggles the News Reader wizard.



Toggles Tip of the Day.



Displays program information. version number and copyright.



Stops data transfer.



Click the What's This button, and then click a menu command or screen component to receive context sensitive help.





Tell me about newsgroups

Newsgroups are forums where users from around the world discuss current events, ask questions 
about various topics, swap files, and exchange opinions about their favorite hobbies. Newsgroups 
function like public email—a user posts a message or article to the newsgroup, and other users can 
post replies. Anyone who accesses the newsgroup can read the posted messages and reply to them.

There are currently thousands of different newsgroups, with topics ranging from the technical aspects 
of computer engineering, to popular music and television shows. The number of newsgroups you can 
access depends on how many are offered by your Internet service provider.

Preparing to Use News

When you access a newsgroup, you will discover many new terms and expressions. The best way to 
learn is to read the articles in a newsgroup and watch others correspond. If you have never used 
newsgroups before, read these terms to help you prepare.

An article is a message posted to a newsgroup. Anyone who accesses the newsgroup can read the 
article and respond to it by posting a reply. Articles can also be cross-posted, which means it can be 
posted to several different, but related newsgroups.

Before posting an article, make sure you have all the right information about the group, and read the 
FAQ (Frequently Asked Questions) text file. FAQs contain answers to commonly asked questions, and 
are compiled regularly so that the newsgroup is not flooded repeatedly by requests for the same 
information. If you post the article to an inappropriate group or break the rules of netiquette, or Internet 
etiquette, you may receive negative replies, or flames, from other users.

Tip

If you are new to Cyberjack or the Internet, connect to the Cyberjack Web page. Check this site 
for updates, FAQs (Frequently Asked Questions) about Cyberjack, helpful hints and interesting places to 
visit. 

The Cyberjack Web page is available at:
http://www.cyberjack.com/



Show me lists of newsgroups

Newsgroup Hierarchies

The following is a list of a few newsgroup hierarchies: 

Name Type Sample

alt.* Alternative topics (broad range) alt.pave.the.earth

bionet.* Biology-oriented bionet.biology.n2-fixation

biz.* Business-oriented biz

comp.* Computer-oriented comp.programs

gnu.* Free Software Foundation gnu.emacs

k12.* K-12 education k12.chat.elementary

misc.* Miscellaneous discussions misc.writing.screenplays

news.* Newsgroup-oriented news.groups.questions

rec.* Recreational/Hobbies rec.travel.europe

sci.* Science-oriented sci.med.telemedicine

soc.* Society-oriented soc.culture.italian

talk.* Talk about various subjects talk.environment

Foreign Newsgroups

The following is a list of some foreign hierarchies:

Name Origin or Topic Sample

aus.* Australia aus.sport.aussie-rules

az.* Arizona az.internet

bermuda.* Bermuda bermuda.tourism

brasil.* Brazil brasil.esportes.futebol

ca.* California ca.earthquakes

can.* Canada can.infohighway

chile.* Chile chile.ciencia-ficcion

chinese.* China chinese.comp.software

de.* Germany de.soc.kultur

es.* Spanish es.talk.politica

fj.* Japan fj.soc.misc

fr.* French fr.rec.musiques

ie.* Ireland ie.announce

israel.* Israel israel.israel-news



nb.* New Brunswick nb.forsale

nc.* North Carolina nc.charlotte.entertainment

nj.* New Jersey nj.market.computers

nyc.* New York City nyc.food

nz.* New Zealand nz.soc.green

pl.* Poland pl.soc.polityka

pt.* Portugal pt.mercado

nlnet.* Netherlands nlnet.culinair

ont.* Ontario ont.bicycle

pa.* Pennsylvania pa.environment

sg.* Singapore sg.singnet.talk

tx.* Texas tx.motorcycles

uk.* United Kingdom uk.rec.gardening

za.* South Africa za.humour

Newsgroups for New Users

The following is a list of some of useful newsgroups:

Name Topic

news.admin.misc Miscellaneous news about administrative issues.

news.announce.newgroups Information about new newsgroups.

news.announce.newusers Useful information about newsgroups for new users.

news.answers Answers to frequently asked questions (FAQs) about 
newsgroups.

Note

 Service providers do not always carry all available newsgroups.



Tell me about emoticons, smileys and abbreviations

The following is a list of common emoticons and their meanings.

:) smile – user said something friendly

:( frown – user said something they are unhappy about

;) wink and a smile – user said something jokingly

:p sticking out tongue – user is teasing

These are basic smileys, but you can use your imagination to personalize them.

There is also a list of commonly understood abbreviations that are used in news articles. The following 
is a list of the most common abbreviations:

BTW By the way

FWIW For what it’s worth

FOAF Friend of a friend

FUD Fear, uncertainty, and doubt

FYI For your information

IMO, IMHO In my opinion, in my humble opinion

MOTOS Members of the opposite sex

MOTSS Members of the same sex

MOTAS Members of the appropriate sex

RFC Request for comment

RTFM Read the fine manual

PMJI Pardon my jumping in

TPTB The powers that be

YMMV Your mileage may vary (you may not have the same luck I did)

<G> or <g> Grin

<S> or <s> Smile

*word* Emphasis (where bold or italics can’t be used)

TTFN Ta-ta for now

TTYL Talk to you later

TIA Thanks in advance

In order to learn these and other abbreviations, read your favorite newsgroups regularly to see which 
are most commonly used.



Cyberjack News

To start a News session

1. When you start Cyberjack News for the first time, the Cyberjack News Wizard appears. Type the name of the 
news server in the field. This is your default news server. When you click Finish, the Newsgroup dialog 
appears.

2. On the Newsgroup menu, click New. The New Newsgroup dialog appears and displays the available 
newsgroups.

The first time you run News, wait for all the newsgroup names to load so that you have a complete list of 
newsgroups. Newsgroup names are placed in a cache for future use, so that you do not have to wait for the 
program to load the names each time you start News.

3. In the Newsgroup section, do one of the following:

 Wait until all newsgroup names have been loaded
 In the Filter field, type the name of the newsgroup you want to read.
4. To open a newsgroup, double click the newsgroup’s name and click OK. Cyberjack News loads the 

newsgroup and displays the articles in the article list.

Tips

If you do not know the name of your news server, contact your service provider.
 Since there are thousands of newsgroups, you may want to limit the number of newsgroups that appear in 
the list. Cyberjack News includes a filter program to isolate only those newsgroups that deal with the subjects that 
interest you. For example, if you want to find out more about news, you can have Cyberjack News list only those 
newsgroup titles that contain the term .. 

news

For details on filtering, click here 



Cyberjack News

To save a newsgroup to your Guidebook

1. On the Newsgroup menu, click Save. The Save As dialog appears. 

2. In the Save In field, click the Guidebook folder in which you want to save your News CyberLink. 



Cyberjack News

To filter (search) newsgroup names

1. In the Name field, type a search word for the subject that interests you. Cyberjack News displays the list of 
newsgroups containing the search word.

2. To open a newsgroup, double click the newsgroup’s name and click OK. Cyberjack News loads the 
newsgroup and displays the articles in the article list.



Cyberjack News

To read an article

 In the article list, double click the name of the article you want to read. The article appears in the display 
area.



Cyberjack News

To change the display to a vertical split

 On the View menu, click Vertical Split. The window is re-displayed, with a vertical split.

Tip

 To automatically wrap the text in the display area so that it fits the width of the window, enable Wrap to 
Window in the Articles tab of the Setup Options.



Cyberjack News

To post a public reply to an article

1. Select the article you want to reply to.

2. On the Compose menu, click Reply to Article. The Compose Reply to Article dialog appears, followed by the 
Reply Quote dialog. You can disable the Reply Quote dialog if you do not want to be prompted before quoting.

3. To display the original article, click Yes. The article appears in the display area of the Compose Reply to Article 
window.

4. In the compose area, type your reply.

5. On the File menu, click Send. Cyberjack News sends your reply.

Tips

 Before posting a public reply to a newsgroup, remember to check for grammar and spelling errors, and be 
sure the information you include is accurate.
 If you want to test posting replies or sending new articles, try sending them to alt.test. Avoid sending test 
messages to newsgroups unless they are test groups.

 Related Topics



Cyberjack News

To post a new article

1. Join the newsgroup where you want to post your article.

2. On the Compose menu, click New Article. The Compose New Article dialog appears. 

3. In the Subject field, type the topic of your article.

4. In the Email CC field, type the names of people you want to email your article to, or click Email CC to open 
your email address book.

5. In the compose area, type your article.

6. On the File menu, click Send. Cyberjack News sends your article to the newsgroup.

Tip

 Do not cross-post to all newsgroups. This is known as spamming and is considered poor netiquette by 
regular newsgroup readers. Only post your articles to newsgroups that relate to the subject of your article.

 Related Topics



Cyberjack News

To reply by email to the author of an article

1. On the Compose menu, click Reply by Email. The Reply by Email dialog appears.

2. In the compose area, type your message.

3. On the File menu, click Send. The email program sends your reply.

 Related Topics



Cyberjack News

To forward an article by email

1. On the Compose menu, click Forward by Email. The Forward by Email dialog appears.

2. In the To field, type the name of the person you want to forward the article to.

 Related Topics



Cyberjack News

To mark an article as read

1. Click the article you want to mark as read. 

2. On the Articles menu, click Mark as Read. The article subject, author and date are no longer bold, and the icon 
changes.

 Related Topics



Cyberjack News

To mark an article as unread

1. Click the article you want to mark as unread.

2. On the Articles menu, click Mark as Unread. The article subject, author and date change to bold, and the icon 
changes.

 Related Topics



Cyberjack News

To hide read articles

 On the View menu, point to Filter and click Hide Read. All articles marked as read are removed from the 
articles list.

 Related Topics



Tell me about encoding and decoding files

Newsgroups often contain articles that have encoded text. Encoded text is used to scramble offensive 
messages, or to embed files in articles.

Scrambled text is often written in Rotate 13 format, in which the letters of the text are shifted by 13 
letters. For example, the message, “This message is encoded”, using Rotate 13 would be:

Guvf zrffntr vf rapbquq.

Decoding Uuencoded Files

Some articles contain uuencoded files, which are usually picture files. With Cyberjack News, you can 
decode uuencoded files. The coded text may look like this:

begin 644 sibyl.jpg
M_]C_X` `02D9)1@ `! `0$”6 `)8 `

Any files you attach to your own messages are automatically uuencoded.

Decoding Multipart Articles

Often, large encoded files are divided among several articles. These articles typically have the same 
subject followed by the number of the part, for example:

cows.uue (0/3)

cows.uue (1/3)

cows.uue (2/3)

cows.uue (3/3)

Sometimes these articles are mixed with other articles in the newsgroup. Before trying to decode the 
file that is divided among the articles, reassemble the articles in their proper order.



Cyberjack News

To decode Rotate 13 encoded text

1. Open the encoded article.

2. On the View menu, click Rotate 13. Cyberjack News automatically decodes the Rotate 13 text.

 Related Topics



Cyberjack News

To encode text into Rotate 13 format

1. On the Compose menu, click New Article. 

2. In the compose area, type the text you want to encode.

3. On the View menu, click Rotate 13. Cyberjack News automatically encodes the text into Rotate 13 format.

4. On the File menu, click Send. The email program sends your message.

 Related Topics



Cyberjack News

To decode uuencoded files to disk

1. Click the title of the article, or anywhere on the encoded text.

2. On the Articles menu, click Save and Decode. Cyberjack News decodes the file and saves it to your default 
download folder.



Cyberjack News

To decode a multipart article

1. Click one of the articles in the multipart article.

2. On the Edit menu, click Select All Parts. All articles relating to the multipart article are highlighted.

3. On the Articles menu, click Save and Decode. The Reorder Articles window opens.

4. Click OK to reorder the articles. Cyberjack News reorders the articles and decodes the file to your default 
download folder.



Cyberjack News

To save the article text

1. Open the article you want to save.

2. On the Articles menu, click Save. Cyberjack News prompts you to name the new file and save it to a local 
folder.



Cyberjack News

To view an article thread

1. Click the article you want to view.

2. On the View menu, click Thread Window. The Thread View window opens.

3. In the Thread View window, view the names of the users who replied to the original post, and the subsequent 
replies to the post.

4. To view a reply, click the author’s name.

Note

 If you want to see all the replies since an article was posted, you can view the list of articles in the thread.



Cyberjack News

To filter articles by author

1. On the View menu, point to Filter, and click by Author. The Author Filter dialog appears.

2. Click one of the following:

 Show All Articles to show all current articles in the newsgroup.
 Do Not Show Articles From the Following Authors to hide articles written by the authors you specify. Type the 

author’s name in the field, and press ENTER. Repeat for other authors.
 Only Show Articles From the Following Authors to show articles written by the specified authors. Type the 

author’s name in the field, and press ENTER.

 Related Topics



Cyberjack News

To filter articles by subject

1. On the View menu, point to Filter, and click by Subject. The Subject Filter dialog appears.

2. Click one of the following:

 Show All Articles to show all current articles in the newsgroup.
 Do Not Show Articles With the Following Subjects to hide articles with the subjects you specify. Type the 

subjects in the field.
 Only Show Articles With the Following Subjects to have only those articles with the specified subjects 

appear in the articles list.

 Related Topics



Cyberjack News

To filter the current author

1. Click the name of the author whose articles you want removed from the article list.

2. On the View menu, point to Filter, and click Current Author. All articles by that author are removed from the 
article list.

 Related Topics



Cyberjack News

To filter the current subject

1. Click the subject of the article you want removed from the articles list.

2. On the View menu, point to Filter and click Current Subject. All articles with that subject are removed from the 
article list.

 Related Topics



Cyberjack News

To change the appearance of News messages

1. On the Setup menu, click Options. The News Options dialog appears.

2. Click the Appearance tab.

3. In the Item drop-down list, click any of the following:

 Standard Text to change the main body of the article.
 Quoted Text to change text quoted from another article.
 Header Labels to change the labels for each line of the header.
 Header Values to change the lines of information in the header.
 Signature Text to change the appearance of the signature text.
 Background to change the color of the display area.
4. In the Font drop-down list, select a new font for the selected text.

5. In the Size drop-down list, select a new size for the selected text.

6. In the Color drop-down list, select a new color for the selected text.

Note

To return to the original appearance settings, click Reset Defaults.



Cyberjack News

To change the file transfer settings

1. On the Setup menu, click Options. The News Options dialog appears.

2. Click the Transfers tab.

3. In the Download path field, type a new folder or click Browse to select a folder for downloading.

4. In the Options section, enable any of the following:

Confirm Before Overwriting Existing Files to be prompted before overwriting a file with the same name as 
the one you are trying to download.

View Images as They Download to display image files as they are being retrieved.
Check for Viruses in Downloaded Programs to automatically scan the files you are downloading for known 

viruses.
Automatically Launch Downloaded Files to start the appropriate program for the downloaded file.
Display Transfer History When Complete to let you know when a file transfer is complete.
Minimize Transfer Dialog to minimize the file transfer display on your screen.
Confirm File Name When Saving to be prompted to change the name of the file you are downloading.
Confirm File Name When Decoding to be prompted to change the name of the file you are decoding.
Reorder Messages Before Decoding to automatically place the files in the correct order before decoding.

Note

Changing the entry in the Download Path field changes the default download folder for all Cyberjack 
programs. To view the contents of the default download folder, click Open Download Folder on the Tools menu.



Cyberjack News

To change the notification settings

1. On the Setup menu, click Options. The News Options dialog appears.

2. Click the Notification tab.

3. In the When Transfer is Complete section, enable any of the following:

Flash Icon to have the Cyberjack News icon flash on the Taskbar (if Cyberjack News is minimized) to 
indicate a completed file transfer.

Restore Minimized Application to restore Cyberjack News to your screen when a file transfer is complete.
Play Sound to play a Windows system sound to notify you that a file transfer is complete.

4. In the Group Transfers section, enable any of the following:

Notify After Each Transfer to notify you when each individual file in a group is transferred.
Notify When All Transfers are Complete to notify you when all the files in a group are transferred.



Cyberjack News

To change article options

1. On the Setup menu, click Options. The News Options dialog appears.

2. Click the Articles tab.

3. In the Headers section, click one of the following:

Show None to display no header information.
Show All to display all header information.
Show Important to show only the author’s name, the subject of the article, other newsgroups where the 

article is posted and the date the article was posted.
4. In the Text wrapping section, click one of the following:

Wrap to Column to wrap long lines to the next line after the specified number of characters. Set the number 
of characters in the Column Position field.

Wrap to Window to automatically wrap long lines to the width of the window.
5. In the Attachments section, do the following:

Click Enable Recognition to detect article attachments. Cyberjack News also identifies articles longer than a 
specified number of lines as containing an attachment. 

In the Line Count field, set the minimum number of lines required for each article to be considered as having 
an attachment.



Cyberjack News

To change the posting settings

1. On the Setup menu, click Options. The News Options dialog appears

2. Click the Posting tab.

3. In the Multipart articles section, click one of the following:

Do Not Split Articles Into Smaller Parts to post articles in one piece only.
Split Articles Into Parts No Larger Than___Lines to break long articles into parts of the specified line length. 

Set the maximum number of lines for each article in the given field.
4. In the Signature section, enable Use File to automatically place your signature file at the end of each article 

you post. Type the name of your signature file in the given field.

Tip

Signature files are short messages you can place at the end of articles to personalize them. “Sig files” 
usually contain the author’s name, email address and a favorite quote or ASCII picture. Try to limit your sig file to four 
or five lines. You can create a sig file using ASCII (.txt) files.



Cyberjack News

To change the quoting settings

1. On the Setup menu, click Options. The News Options dialog appears.

2. Click the Quoting tab.

3. In the Quote header section, enter the text you want to appear in each article you quote. These are the 
variables you can insert automatically:

%Author% – the author’s name and address
%Subject% – the subject of the article
%MsgID% – the article’s message ID
%Date% – the date the article was written (DD/MM/YY)
%LongDate% – the date the article was written, in words
%Time% – the local time the article was written
%TimeZone% – the local time zone.

For example, the default quote header would appear as:

In article (123.abc@domain.com), Bill Bloggs wrote:

4. In the Quote content section, click one of the following:

Always Quote When Replying to always have the quote header included in your replies.
Never Quote When Replying to bypass the quote header.
Ask Before Quoting to be prompted whether or not you want to include the quote header.
Quote String to set the character you want to appear before each line of quoted text, to distinguish the 

quoted material from your reply.

 Related Topics



Cyberjack News

To change the default server and user details

1. On the Setup menu, click Options. The News Options dialog appears.

2. Click the General tab.

The name of your news server, as you entered it the first time you started News, appears in the Default server 
section.

3. In the User details section, type your full name, email address and organization name.

Notes

If you change Internet service providers, you may need to change your default news server.
Any changes you make to the Name and Email Address fields are reflected in all Cyberjack programs.



Cyberjack News

To change the cache settings

1. On the Setup menu, click Options. The News Options dialog appears.

2. Click the Caching tab.

3. Enable Cache Newsgroup Lists to save the list of newsgroups available from your server, so that the 
information does not have to be retrieved from the server each time you start News.

4. Enable Cache Article Headers to save the article list for the current newsgroup so that the list does not have to 
be retrieved from the server each time you access the newsgroup.

Note

Cyberjack News uses a cache on your hard drive to store newsgroup names. A cache is a temporary 
memory store that saves recently accessed data for faster retrieval. You can change the default cache settings to 
modify the type of information stored in this cache.







Enable any item in this list to display the selected toolbar. You can edit or delete any selected toolbar.



Click to edit the currently selected toolbar.



Click to create a new toolbar.



Click to delete the currently selected toolbar.



Enable to display buttons in color.



Enable to display Tooltips when the mouse cursor is placed over a button.



Enable to display large buttons.



Enable to display Delrina WinFax style buttons.



Enable to display Delrina WinFax style captions for buttons.



Add or remove buttons from the selected toolbar. Click the name of the toolbar to change its name.



Type a new name for the toolbar.



Use these buttons to make up your toolbar. You can drag them up to the toolbar, or click the Add button.



Adds the button highlighted in the available field to the toolbar above. 



Removes the button highlighted in the above toolbar.



Resets the toolbar to its original(default) settings.



Lists the menu options that can be assigned to the buttons.



Specifies the caption that is to be displayed when Delrina Classic button style is chosen with captions.



Specifies the tooltip that is to be displayed for the button.



Specifies the help text that is to be displayed for the button.



Save the changes to the toolbar and continue.



Throw away changes to this toolbar. 



Lists the available folders and files. 



Lists the folders and files in the selected location.



Type the name of the file.



Selects the type of file to save. 



Closes this dialog box without saving any changes you have made. 



Saves the file with the name, file type and location you specified.




