Tell me about using Image Manager

Image Manager is a Delrina program that you can use to view many different image types, including
Windows bitmaps, Paintbrush, JPEG, CompuServe Graphic, TIFF and others.

With Image Manager you can apply different graphics filters, enlarge or reduce an image, modify
image colors and perform many other tasks.



Image Manager
Starting Image Manager from within your Delrina program

On the Tools menu, click Image Manager. The Image Manager window appears.



Image Manager
Starting Image Manager as a separate program

. Click the Windows Start button, point to Programs, then point to either WinComm PRO 7.0 or Cyberjack 7.0,
and click Image Manager.



Image Manager

Opening an image

1. On the File menu, click Open. The Open Image File dialog appears.

2. In the File Name field, type the name and path of the image file you want to open.

3. Click Open. Your image opens and you now have access to all Image Manager menu commands.



Image Manager
Opening multiple images

1. On the File menu, click Open New. The first image remains open and a new Open Image File dialog appears
from which you can open a second image.

2. In the File Name field, type the name and path of the new image file you want to open, and click OK. The
second image displays in a separate Image Manager window over top of the first.



Image Manager

Saving an image

1. On the File menu, click Save As. The Save As dialog appears.

2. Inthe Save In field, select the folder where you want to save the image.

3. In the File Name field, type the name you want to save the file as.



Image Manager
Changing zoom factors

1. Open an image that you want to change.

2. On the View menu, do one of the following:

Note

To enlarge your image, point to Zoom In and click the appropriate percentage.

To decrease the size of your image, point to Zoom Out and click the appropriate percentage.
To make your image fit your window size, click Fit to Window.

To return the image to its original size, click Actual Size.

Changing the zoom factor does not change the image size, but only how it is displayed.



Image Manager

Copying an image to the Clipboard

1. Open the image you want to copy to the Clipboard.
2. On the Edit menu, click Copy. The entire image is copied to the Clipboard.



Image Manager
Pasting an image from the Clipboard

. On the Edit menu, click Paste. The Clipboard contents are pasted into Image Manager, replacing the current
image.



Image Manager
Converting an image to another format

1. Open the image you want to convert.

2. On the File menu, click Save As. The Save Image File dialog appears.
3.
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In the File Name field, type the name and path of the image file you want to convert.

In the Save As Type drop-down list, select the new image type.



Image Manager
Printing an image
1. Open the image you want to print.
2. On the File menu, click Print. The Print dialog appears.
3. Select your print options and click OK to print the image.
Tip
To achieve the best print quality for a color image on a non-color printer, first convert the image to grayscale.



Image Manager
Exiting Image Manager

. On the File menu, click Exit. Image Manager closes, and prompts you to save any changes to the current
image.



Image Manager
Flipping an image

On the Image menu, click Flip Horizontal to flip your image horizontally or Flip Vertical to flip your image
vertically.

Note

Flipping horizontally creates a mirrored image along the vertical axis. Flipping vertically creates a mirrored
image along the horizontal axis.



Image Manager
Rotating an image
1. On the Image menu, click Rotate. The Rotate dialog appears.

2. In the Enter the Rotation Factor in Degrees field, type the number of degrees you want to rotate your image.
To rotate an image counterclockwise, type a hyphen in front of the number to indicate a negative value.

3. Enable Resize Image to resize the rotated image to fit the window. Otherwise, the Image Manager window will
resize to fit the image.



Image Manager
Posterizing an image

1. On the Image menu, click Posterize. The Posterize dialog appears.

2. Use the slider to select the appropriate posterization level.



Image Manager
Turning an image into a mosaic

1. On the Image menu, click Mosaic. The Mosaic dialog appears.

2. Use the slider to select the appropriate mosaic tiling size.



Image Manager

Blurring an image

1. On the Image menu, click Blur. The Blur dialog appears.

2. Use the slider to select the appropriate blur level.

Tip
. You can also blur an image by clicking Blur in the Special Effect drop-down list on the toolbar. Use the slider
to the right of the list to change the image.



Image Manager
Reducing image noise

1. On the Image menu, click Noise Reduction. The Noise Reduction dialog appears.

2. Use the slider to select the appropriate noise reduction level.

Tip
. You can also reduce image noise by clicking Noise reduction in the Special Effect drop-down list on the
toolbar. Use the slider to the right of the list to change the image.



Image Manager

Softening or sharpening an image

1. On the Image menu, click Sharpness. The Sharpness dialog appears.

2. Use the slider to increase or decrease the image sharpness level.

Tip
. You can also soften an image by clicking Sharpness in the Special Effect drop-down list on the toolbar. Use
the slider to the right of the list to change the image.



Image Manager

Embossing an image

1. On the Image menu, click Emboss. The Emboss dialog appears.
2. Use the slider to increase or decrease the emboss level.

3. In the Direction section, click the direction from which you want the light source to originate.



Image Manager
Converting to grayscale

On the Color menu, click Grayscale. Image Manager changes the image to grayscale.



Converting to grayscale transforms color images into monochrome, where each color is changed into a shade of gray - the darker
the original color, the darker the corresponding gray.



Image Manager
Inverting colors

On the Color menu, click Invert. Image Manager creates a negative of the image.



Image Manager
Converting to halftone

On the Color menu, click Halftone. Image Manager converts your image to halftone.



Image Manager
Brightening or darkening an image

1. On the Color menu, click Brightness. The Brightness dialog appears.

2. Use the slider to increase or decrease the brightness.

Tip
. You can also brighten or darken an image by selecting Brightness in the Special Effect drop-down list on the
toolbar. Use the slider to the right of the list to lighten or darken your image.



Image Manager

Increasing or reducing contrast

1. On the Color menu, click Contrast. The Contrast dialog appears.

2. Use the slider to increase or decrease the contrast level.

Tip
. You can also increase or reduce contrast by clicking Contrast in the Special Effect drop-down list on the
toolbar. Use the slider to the right of the list to increase or reduce the image contrast.



Image Manager

Increasing or reducing saturation

1. On the Color menu, click Saturation. The Saturation dialog appears.

2. Use the slider to increase or decrease the color saturation level.

Tip
. You can also increase or reduce color saturation by clicking Saturation in the Special Effect drop-down list
on the toolbar. Use the slider to the right of the list to increase or decrease the color saturation of your image.



Image Manager

Changing hue

1. On the Color menu, click Hue. The Hue dialog appears.

2. Click the number of degrees that you want to shift the image through the color spectrum.

Tip
. You can also change the hue by clicking Hue on the Special Effect drop-down list on the toolbar. Use the
slider to the right of the list to change the image.



Image Manager
Viewing image properties

. On the File menu, click Properties. The Properties dialog appears.
Note

. Viewing image properties displays the image file name, size (in bytes), height and width (in pixels) and type
of compression used.



Image Manager

Resizing an image

1. On the Image menu, click Resize. The Resizing Image dialog appears.
2. Do one of the following:

In the X-Size and Y-Size fields, type the new image size, in pixels.
Click one of the four preset image sizes.
3. To fit the image into the specified dimensions without distortion, enable Preserve Aspect Ratio.



Image Manager
Changing color resolution

1. On the Color menu, click Color Resolution. The Color Resolution dialog appears.

2. In the New Bits Per Pixel section, click the new color resolution level.



Image Manager

Editing an existing toolbar

On the View menu, click Options.

Click the Toolbar tab. The Toolbar Setup dialog appears.

Click Edit. The Toolbar Properties dialog appears.

In the Available Buttons section, click the button you want to add.
Click Add. The button is added to the toolbar section.
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To change the properties for a button, select it in the Toolbar section. In the Button Assignment section, modify
the details as appropriate.



Image Manager

Removing a button from the toolbar

1. In the Toolbar Setup dialog, click the toolbar in the Toolbars field you want to edit.
2. Click Edit. The Toolbar Properties dialog appears.

3. In the Toolbar section, click the button you want to remove from the toolbar.
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. Click Remove. WinComm removes the button from the selected toolbar.



Image Manager

Configuring the toolbar appearance

1. On the View menu, click Options.

2. Click the Toolbars tab. The Toolbar Setup dialog appears.

3. Enable one or more of the following options:

. Color Buttons to display buttons in color instead of black and white.
- Large Buttons to increase the button sizes.
- Show ToolTips to display a text message explaining how to use a button. A message appears when you

point to a button.
. Delrina Classic Buttons to use the button styles from the WinComm PRO 1.1 toolbar.



Image Manager

Showing or hiding the toolbar

On the View menu, click Toolbar. The Toolbar is displayed or hidden.



Image Manager
Setting Image Manager options

1. On the View menu, click Options. The Image Manager Options dialog appears.

2. In the General section, do one of the following:

. To automatically resize the Image Manager window to fit the current image, enable Resize Window to Fit
Image.

- To center the image in the middle of the Image Manager window, enable Center Image in Window.

- To view an image while it is loaded into Image Manager, enable View Image While Loading. This option is

useful when viewing interlaced images.



Zoom In command (View menu)

Increases the magnification level by 100%.



Zoom Out command (View menu)

Decreases the magnification level by 10%.



Image Manager title bar. Shows the currently open file.



Scrolls an image left and right.



Click this to remove the selected button from the toolbar.



Click this to remove the selected toolbar from Image Manager. Only user-defined toolbars may be removed.



Scrolls an image up and down.



Minimizes the Image Manager window to the Windows task bar.



Maximizes the Image Manager window to take up the entire screen.



Resize the Image Manager window by dragging the border.



Moves the Image Manager window.



Minimizes the Image Manager window.



Maximizes the Image Manager window.



Closes Image Manager.



Restores Image Manager.



Displays the task list.



Open command (File menu)

Opens this image.



Open command (File menu)

Opens an image for viewing.



Closes Image Manager.



Save command (File menu)

Saves any changes made to the current image.



Save As command (File menu)

Saves any changes made to the current image using a new file name.



Print Setup command (File menu)

Sets up the current printer.



Print command (File menu)

Prints the current image.



Copy command (Edit menu)

Copies the current image to the Clipboard.



Cut command (Edit menu)

Cuts the selected text to the Clipboard.



Paste command (Edit menu)

Inserts a new image from the Clipboard into the current image.



Undo command (Edit menu)

Reverses any changes made to the image after the last time it was saved or opened.



Arrange Icons command (Window menu)

Arranges all minimized windows at the bottom of the screen.



Cascade command (Window menu)

Displays all open windows so that the title bar of each window is visible.



Tile command (Window menu)

Display all open windows side by side (horizontally).



Cascade command (Window menu)

Displays all open windows so that the title bar of each window is visible.



About Image Manager command (Help menu)

Displays the About Image Manager window.



Exit command (File menu)

Exits Image Manager and prompts to save the current image.



What’s This? command

Click the What's This button, and then click a menu command or screen component to receive context sensitive help.



Toolbar command (View menu)

Shows or hides the Image Manager toolbar.



Status Bar command (View menu)

Shows or hides the Image Manager Status Bar.



Brightness command (Color menu)

Brightens or darkens the image.



Hue command (Color menu)

Alters the image hue. Changing hue shifts all colors within an image by the selected degree.



Click this to shift the image colors 60 degrees.



Click this to shift the image colors 90 degrees.



Click this to shift the image colors 120 degrees.



Click this to shift the image colors 150 degrees.



Click this to shift the image colors 180 degrees.



Click this to shift the image colors 210 degrees.



Click this to shift the image colors 240 degrees.



Click this to shift the image colors 270 degrees.



Click this to shift the image colors 30 degrees.



Contrast command (Color menu)

Sets image contrast. Increasing contrast enhances the color difference between light and dark portions of an image. Decreasing
contrast reduces the color difference between light and dark portions of an image.



Grayscale command (Color menu)

Converts a color image to grayscale. Grayscale images use varying shades of gray to reproduce the effects of a color image.



Halftone command (Color menu)

Converts the image into a 2 color (black and white) image.



Invert command (Color menu)

Inverts the image. Color images are turned into negatives, and negatives are turned into color.



Saturation command (Color menu)

Increases or decreases image color levels.



Color Resolution command (Color menu)

Changes the image color depth. Reducing the number of colors in an image decreases the file size.



Resize command (Image menu)

Enlarges or shrinks the current image.



Exit All command (File menu)

Closes all instances of Image Manager.



Open New command (File menu)

Opens another instance of Image Manager.



WinComm Help Topics command (Help menu)

Displays the WinComm PRO Help Contents window.



Cyberjack Help Topics command (Help menu)

Displays the Cyberjack Help Contents window.



Blur command (Image menu)

Blurs or sharpens the image.



Emboss command (Image menu)

Creates a three dimensional, raised-relief effect.



Flip Horizontal command (Image menu)

Flips the image along the vertical axis.



Flip Vertical command (Image menu)

Flips the image along the horizontal axis.



Mosaic command (Image menu)

Converts the image into a tiled mosaic.



Noise Reduction command (Image menu)

Decreases image noise. Poor quality images can be improved by reducing noise caused during scanning or transmission.



Posterize command (Image menu)

Increases or decreases the color level in the image.



Properties command (File menu)

Displays the image properties.



Rotate command (Image menu)

Rotates the image the specified number of degrees.



Sharpness command (Image menu)

Sharpens or softens the image resolution.



Fit to Window command (View menu)

Resizes the image to fit the size of the Image Manager window.



Actual Size command (View menu)

Returns the image back to its original size.



Zoom In 200 % command (View menu)

Displays an image at 200% of its original size.



Zoom In 300 % command (View menu)

Displays an image at 300% of its original size.



Zoom In 400 % command (View menu)

Displays an image at 400% of its original size.



Zoom In 500 % command (View menu)

Displays an image at 500% of its original size.



Zoom In 600 % command (View menu)

Displays an image at 600% of its original size.



Zoom In 700 % command (View menu)

Displays an image at 700% of its original size.



Zoom In 800 % command (View menu)

Displays an image at 800% of its original size.



Zoom Out 90 % command (View menu)

Displays an image at 90% of its original size.



Zoom Out 80 % command (View menu)

Displays an image at 80% of its original size.



Zoom Out 70 % command (View menu)

Displays an image at 70% of its original size.



Zoom Out 60 % command (View menu)

Displays an image at 60% of its original size.



Zoom Out 50 % command (View menu)

Displays an image at 50% of its original size.



Zoom Out 40 % command (View menu)

Displays an image at 40% of its original size.



Zoom Out 30 % command (View menu)

Displays an image at 30% of its original size.



Image Manager Help Contents command (Help menu)

Displays the Image Manager Help Contents window.



Loaded images are displayed here.



Click this to apply the selected brightness level to the image without closing the dialog.



Move the slider to the appropriate blur level. The larger the selected value, the greater the blurring.



Move the slider to the appropriate brightness level.



Displays the current image color depth (bits per pixel). If enabled, indicates the current color level.



Click this to reduce the image color level to 1 bit per pixel. If enabled, indicates the current color level.



Click this to or increase reduce the image color level to 8 bits per pixel. If enabled, indicates the current color level.



Click this to increase or reduce the image color level to 16 bits per pixel. If enabled, indicates the current color level.



Click this to increase the image color level to 24 bits per pixel. If enabled, indicates the current color level.



Move the slider to the appropriate contrast level.



Move the slider to the appropriate emboss level.



Click this to set the emboss light source to this direction.



Click this to set the emboss light source to this direction.



Click this to set the emboss light source to this direction.



Click this to set the emboss light source to this direction.



Click this to set the emboss light source to this direction.



Click this to set the emboss light source to this direction.



Click this to set the emboss light source to this direction.



Click this to set the emboss light source to this direction.



Move the slider to the appropriate mosaic level. The larger the selected value, the larger each mosaic tile will be.



Move the slider to the appropriate level of noise reduction. The larger the selected value, the greater the noise reduction.



Enable this option to automatically center an image in the Image Manager window. If the Resize window to fit image is enabled, this
check box has no effect.



Enable this option to hide the Image Manager window until the image header is received.



Enable this option to prompt to save an image if it is modified. Otherwise, any changes made will be lost when the image is closed.



Enable this option to automatically resize the Image Manager window to fit the current image.



Enable this option to view an image while it is loaded into Image Manager.



Enable this option to automatically move the Image Manager window to the front when an image is being loaded.



Move the slider to the appropriate color level. The lower the selected color, the greater the effect.



Displays the color resolution, in bits per pixel. An image can be 2,4,8,16 or 24 bits per pixel. The larger the number, the more
memory required to display and store the image.



Displays the type of compression used to store the image.



Displays the file name of the current image.



Options command (View menu)

Changes Image Manager options and toolbars.



Displays the size, in K, of the current image.



This check box is enabled if the current image is grayscale.



Displays the image height, in pixels.



This check box is enabled if the current image is interlaced.



This check box is enabled if the current image has been modified since it was loaded.



Displays the color resolution.



Displays the image width, in pixels.



Click this to resize the image to 1024 pixels by 768 pixels.



Click this to resize the image to 640 pixels by 480 pixels.



Click this to resize the image to 800 pixels by 600 pixels.



Enable this check box to preserve the aspect ratio of the image when resizing. This option prevents an image from distorting when
resized.



Click this to resize the image to the same resolution as your screen.



Enter the new size, in pixels, for the horizontal edge.



Enter the new size, in pixels, for the vertical edge.



Enable this check box to resize the image to fit the Image Manager window when rotated. Otherwise, the window will resize to fit the
rotated image.



Type the number of degrees you want to rotate the image by. To rotate an image counterclockwise, enter a hyphen before the
number. For example, type “-45” to rotate an image 45 degrees counterclockwise.



Move the slider to the appropriate color saturation level.



Move the slider to the appropriate color saturation level.



Click this to apply the selected contrast level to the image without closing the dialog.



Click this to apply the selected saturation level to the image without closing the dialog.



Click this to apply the selected sharpness level to the image without closing the dialog.



Displays the toolbar being edited.



Displays the current toolbar. Edit the toolbar by dragging and dropping buttons from the Available Buttons section.



Adds the selected button to the toolbar.



Assigns a menu command to a toolbar button. Click the button you want to assign the command to, and select the appropriate
command from the drop-down list.



With Delrina Classic buttons, displays the button text.



Displays the TooolTip text for the selected button.



Displays the status bar text for the selected button.



Lists all defined toolbars. Toolbars currently visible are checked.



Click this to edit the selected toolbar.



Click this to create a new toolbar.



Click this to remove the selected toolbar.



Enable this option to display colored buttons on the toolbar.



Enable this option to display large buttons on the toolbar.



Enable this option to display ToolTip messages when you point at a toolbar button with the mouse pointer.



Enable this option to display classic WinComm PRO 1.1 and WinFax PRO 4.0 style buttons on the toolbar.



Enable this option to display captions with Delrina Classic buttons.



Click this to shift the image colors by 30 degrees.



Click this to shift the image colors by 60 degrees.



Click this to shift the image colors by 90 degrees.



Click this to shift the image colors by 120 degrees.



Click this to shift the image colors by 150 degrees.



Click this to shift the image colors by 180 degrees.



Click this to shift the image colors by 210 degrees.



Click this to shift the image colors by 240 degrees.



Click this to shift the image colors by 270 degrees.






