
Dialog Editor
Displaying and adjusting the grid

1. On the Edit menu, click Grid. The Grid dialog appears.

2. To display the grid in your dialog, select the Show grid check box.

3. To change the current X and Y settings, enter new values in the X and Y fields.

4. Click OK. Dialog Editor displays the grid with the settings you specified. With the grid displayed, you can line 
up the crosshairs on the mouse pointer with the dots on the grid to position controls precisely and align them 
with respect to other controls.

Note

The values of X and Y in the Grid dialog determine the grid's spacing. Assigning smaller X and Y values 
produces a more closely spaced grid, which enables you to move the mouse pointer in smaller horizontal and vertical 
increments as you position controls. Assigning larger X and Y values produces the opposite effect on both the grid's 
spacing and the movement of the mouse pointer. The X and Y settings entered in the Grid dialog remain in effect 
regardless of whether you choose to display the grid.



Dialog Editor
Changing titles and labels

1. Display the Information dialog for the dialog whose title you want to change or for the control whose label you 
want to change.

2. Enter the new title or label in the Text$ field. 

3. If the information in the Text$ field should be interpreted as a variable name rather than a literal string, select 
the Variable Name check box.

4. Click OK. The new title or label is now displayed on the title bar or on the control.

Note

Dialog titles and control labels are optional. Therefore, you can leave the Text$ field blank. 



Dialog Editor
Adding controls

1. From the toolbar, choose the tool corresponding to the type of control you want to add.

When you pass the mouse pointer over an area of the display where a control can be placed, the pointer 
becomes an image of the selected control with crosshairs (for positioning purposes) to its upper left. The name 
and position of the selected control appear on the status bar. When you you pass the pointer over an area of 
the display where a control cannot be placed, the pointer changes into a circle with a slash through it (the 
"prohibited" symbol). 

2. Place the pointer where you want the control to be positioned and click the mouse button.

The control you just created appears at the specified location. (To be more specific, the upper left corner of the 
control will correspond to the position of the pointer's crosshairs at the moment you clicked the mouse button.) 
The control is surrounded by a thick frame, which means that it is selected, and it may also have a default 
label.

After the new control has appeared, the mouse pointer becomes an arrow, to indicate that the Pick tool is 
active and you can once again select any of the controls in your dialog. 

3. To add another control of the same type as the one you just added, On the Edit menu, click Duplicate. A 
duplicate copy of the control appears. 

To add a different type of control, repeat steps 1 and 2.
To reactivate the Pick tool, click the arrow-shaped tool on the toolbar.

Note

You can only insert a control within the borders of the dialog you are creating. You cannot insert a control on 
the dialog's title bar or outside its borders. 



Dialog Editor
Duplicating controls

1. Select the control that you want to duplicate.

2. On the Edit menu, click Duplicate. A duplicate copy of the selected control appears in your dialog.

3. Repeat step 2 as many times as necessary to create the desired number of duplicate controls.



Dialog Editor
Selecting controls

With the Pick tool active, place the mouse pointer on the desired control and click the mouse button. The 
control is now surrounded by a thick frame to indicate that it is selected and you can edit it.



Dialog Editor
Selecting dialogs

With the Pick tool active, place the mouse pointer on the title bar of the dialog or on an empty area within the 
borders of the dialog (that is, on an area where there are no controls) and click the mouse button.



Dialog Editor
Repositioning items with the mouse

1. With the Pick tool active, place the mouse pointer on an empty area of the dialog or on a control.

2. Depress the mouse button and drag the dialog or control to the desired location. 

Note

The increments by which you can move a control with the mouse are governed by the grid setting. For 
example, if the grid's X setting is 4 and its Y setting is 6, you'll be able to move the control horizontally only in 
increments of 4 X units and vertically only in increments of 6 Y units. This feature is handy if you're trying to align 
controls in your dialog. If you want to move controls in smaller or larger increments, on the Edit menu, click Grid to 
display the Grid dialog and adjust the X and Y settings.



Dialog Editor
Repositioning items with the arrow keys

1. Select the dialog or control that you want to move.

2. Press an arrow key once to move the item by 1 X or Y unit in the desired direction.

Note

When you reposition an item with the arrow keys, a faint, partial afterimage of the item may remain visible in 
the item's original position. These afterimages are rare and will disappear once you test your dialog.



Dialog Editor
Repositioning dialogs with the Dialog Information dialog

1. Display the Dialog Information dialog.

2. Change the X and Y coordinates in the Position group box.

3. Click OK. If you specified X and Y coordinates, the dialog moves to that position. If you left the X coordinate 
blank, the dialog will be centered horizontally relative to the parent window of the dialog when the dialog is run. 
If you left the Y coordinate blank, the dialog will be centered vertically relative to the parent window of the 
dialog when the dialog is run.



Dialog Editor
Repositioning controls with the Information dialog

1. Display the Information dialog for the control that you want to move.

2. Change the X and Y coordinates in the Position group box.

3. Click OK. The control moves to the specified position.



Dialog Editor
Resizing items with the mouse

1. With the Pick tool active, select the dialog or control that you want to resize.

2. Place the mouse pointer over a border or corner of the item.

3. Depress the mouse button and drag the border or corner until the item reaches the desired size.



Dialog Editor
Resizing items with the Information dialog

1. Display the Information dialog for the dialog or control that you want to resize.

2. Change the Width and Height settings in the Size group box.

3. Click OK. The dialog or control is resized to the dimensions you specified.



Dialog Editor
Resizing selected items automatically

1. With the Pick tool active, select the option button, text control, push button, check box, or text box that you 
want to resize.

2. Press F2. The borders of the control will expand or contract to fit the text displayed on it.



Dialog Editor
Assigning accelerator keys

1. Display the Information dialog for the control to which you want to assign an accelerator key.

2. In the Text$ field, type an ampersand (&) before the letter you want to designate as the accelerator key.

3. Click OK. The letter you designated is now underlined on the control's label, and users will be able to access 
the control by pressing Alt + the underlined letter.



Dialog Editor
Capturing standard Windows dialogs

1. Display the dialog you want to capture.

2. Open Dialog Editor.

3. Choose the Capture Dialog command from the File menu. Dialog Editor's application window moves behind all 
other open application windows, and the dialog you displayed in step 1 reappears. The mouse pointer, 
previously an arrow, now looks like a butterfly net.

4. Place the mouse pointer over the dialog that you want to capture.

If the mouse pointer is over a standard Windows dialog that contains some standard Windows controls, a tiny 
dialog appears in front of the mouse pointer's butterfly net to indicate that the pointer has found controls that 
can be captured. If the mouse pointer is not over a standard Windows dialog that contains standard Windows 
controls, the butterfly net remains unchanged to indicate that the mouse pointer has not found controls that 
can be captured.

5. Click the mouse button. Dialog Editor's application window moves in front of all other open application 
windows and now displays the standard Windows controls from the target dialog. 

Note

Dialog Editor only supports standard Windows controls and standard Windows dialogs. Therefore, if the 
target dialog contains both standard Windows controls and custom controls, only the standard Windows controls will 
appear in Dialog Editor's application window. If the target dialog is not a standard Windows dialog, you will be unable 
to capture the dialog or any of its controls.



Dialog Editor
Specifying pictures from files

1. Display the Information dialog for the picture control or picture button control whose picture you want to 
specify.

2. In the Picture source option button group, select File.

3. In the Name$ field, enter the name of the file containing the picture you want to display in the picture control or 
picture button control.

4. Click OK. The picture control or picture button control now displays the picture you specified.

Note

By clicking the Browse button, you can display the Select a Picture File dialog and use it to find the file.



Dialog Editor
Specifying pictures from picture libraries

1. Display the Information dialog for the picture control or picture button control whose picture you want to 
specify.

2. In the Picture source option button group, select File.

3. In the Name$ field, enter the name of the file containing the picture you want to display in the picture control or 
picture button control.

4. Click OK. The picture control or picture button control now displays the picture you specified.

Note

By clicking the Browse button, you can display the Select a Picture File dialog and use it to find the file.



Dialog Editor
Pasting existing dialogs into Dialog Editor

1. Copy the entire Delrina Basic dialog template (from the Begin Dialog instruction to the End Dialog instruction) 
from your script to the Clipboard.

2. Open Dialog Editor.

3. On the Edit menu, click Paste.

4. When Dialog Editor asks whether you want to replace the existing dialog, click the Yes button. Dialog Editor 
creates a new dialog corresponding to the template contained on the Clipboard.



Dialog Editor
Pasting one or more controls from existing dialogs into Dialog Editor

1. Copy the Delrina Basic description of the control(s) from your script to the Clipboard.

2. Open Dialog Editor.

3. On the Edit menu, click Paste. Dialog Editor adds to your current dialog one or more controls corresponding to 
the description contained on the Clipboard.



Dialog Editor
Incorporating dialogs or controls into your script

Dialogs and dialog controls are communicated between Dialog Editor and your script via the Clipboard, where 
they are represented as Delrina Basic statements. To incorporate a dialog or control into your script:

1. Select the dialog or control that you want to incorporate into your script.

2. On the Edit menu, click Copy.

3. Open your script and paste in the contents of the Clipboard at the desired point. The dialog template or control 
is now described in Delrina Basic statements in your script, as shown in the following example.



Dialog Editor
Attributes you can adjust with the Dialog Information dialog

The Dialog Information dialog can be used to to check and adjust the following attributes, which pertain to the 
dialog as a whole.

Position (optional): X and Y coordinates on the display, in dialog units
Size (mandatory): width and height of the dialog, in dialog units
Style (optional): options that allow you to determine whether the close box and title bar are displayed 
Text$ (optional): text displayed on the title bar of the dialog
Name (mandatory): name by which you refer to this dialog template in your Delrina Basic code
.Function (optional): name of a Delrina Basic function in your dialog
Picture Library (optional): picture library from which one or more pictures in the dialog are obtained



Dialog Editor
Displaying the Dialog Information dialog

With the Pick tool active, place the mouse pointer on an area of the dialog where there are no controls and 
double-click the mouse button. The Dialog Information dialog appears.



Dialog Editor
Displaying the Information dialogs for controls

With the Pick tool active, place the mouse pointer on the desired control and double-click the mouse button. 
Dialog Editor displays an Information dialog corresponding to the control you selected. Here is an example:



Dialog Editor
Default OK Button Information dialog

The Default OK Button Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
.Identifier (optional): name by which you refer to a control in your Delrina Basic code



Dialog Editor
Default Cancel Button Information dialog

The Default Cancel Button Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
.Identifier (optional): name by which you refer to a control in your Delrina Basic code



Dialog Editor
Push Button Information dialog

The Push Button Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
Text$ (optional): text displayed on a control
.Identifier (optional): name by which you refer to a control in your Delrina Basic code



Dialog Editor
Option Button Information dialog

The Option Button Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
Text$ (optional): text displayed on a control
.Identifier (optional): name by which you refer to a control in your Delrina Basic code
.Option Group (mandatory): name by which you refer to a group of option buttons in your Delrina Basic code



Dialog Editor
Check Box Information dialog

The Check Box Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
Text$ (optional): text displayed on a control
.Identifier (mandatory): name by which you refer to a control in your Delrina Basic code; also contains the 

result of the control after the dialog has been processed



Dialog Editor
Group Box Information dialog

The Group Box Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
Text$ (optional): text displayed on a control
.Identifier (optional): name by which you refer to a control in your Delrina Basic code



Dialog Editor
Text Information dialog

The Text Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
Text$ (optional): text displayed on a control
Font (optional): font in which text is displayed
.Identifier (optional): name by which you refer to a control in your Delrina Basic code



Dialog Editor
Text Box Information dialog

The Text Box Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
Multiline (optional): option that allows you to determine whether users can enter a single line of text or 

multiple lines
.Identifier (mandatory): name by which you refer to a control in your Delrina Basic code; also contains the 

result of the control after the dialog has been processed



Dialog Editor
List Box Information dialog

The List Box Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
.Identifier (mandatory): name by which you refer to a control in your 
Delrina Basic code; also contains the result of the control after the dialog has been processed
Array$ (mandatory): name of an array variable in your Delrina Basic code



Dialog Editor
Combo Box Information dialog

The Combo Box Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
.Identifier (mandatory): name by which you refer to a control in your Delrina Basic code; also contains the 

result of the control after the dialog has been processed
Array$ (mandatory): name of an array variable in your Delrina Basic code



Dialog Editor
Drop List Box Information dialog

The Drop List Box Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
.Identifier (mandatory): name by which you refer to a control in your 
Delrina Basic code; also contains the result of the control after the dialog has been processed
Array$ (mandatory): name of an array variable in your Delrina Basic code



Dialog Editor
Picture Information dialog

The Picture Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
.Identifier (optional): name by which you refer to a control in your Delrina Basic code
.Identifier (optional): name of the file containing a picture that you want to display or the name of a picture 

that you want to display from a specified picture library
Frame (optional): option that allows you to display a 3-D frame



Dialog Editor
Picture Button Information dialog

The Default OK Button Information dialog can be used to to check and adjust the following attributes:

Position (mandatory): X and Y coordinates within the dialog, in dialog units
Size (mandatory): width and height of the control, in dialog units
.Identifier (optional): name by which you refer to a control in your Delrina Basic code
.Identifier (optional): name of the file containing a picture that you want to display or the name of a picture 

that you want to display from a specified picture library.



Dialog Editor
File selector dialog

Use this dialog to specify a file to open or save. Type file name and path in the File Name field, or browse for a file 
in the Folders list.




