What Is File Manager?

File Manager is a tool you can use to organize your files and directories. You can use File Manager to create and remove
directories; move, copy, and delete files; connect to directories shared on the network; share directories; secure files and
directories; and perform other disk, directory, and file management tasks.

In File Manager, your files and directories are displayed in a directory window. The directory window is split: the left half
displays the directory tree; the right half displays the contents of the current directory. When you select a different directory in
the directory tree, the contents of that directory are displayed in the right half of the window.

In the directory window, each filename has an icon next to it, graphically indicating what kind of file it is.
Directories.
E:‘ Shared directories. These are directories users can connect to on the network.

Program files, PIFs, and batch files. Their default flename extensions are .EXE, .COM, .PIF, and .BAT. These files start
applications.

Document files. These files are associated with applications. When you choose a document file, the application starts
and opens the file.

System or hidden files. These files have system or hidden attributes.
All other files.

File Manager displays a toolbar and drivebar below the menu bar. The toolbar provides quick access to File Manager
commands through buttons. The drivebar displays icons that represent available drives, including hard disk drives, floppy disk
drives, network drives, and CD-ROM drives. You can change to a different drive by selecting its drive icon.

To return to Contents for File Manager Help, choose the Contents button.



Starting and Quitting File Manager

By default, when you start File Manager, Windows NT displays the window as it was when you last quit File Manager. Settings
you make using the Options menu are always saved when you quit. The positions of directory windows and icons and the
settings on the View menu are saved as long as the Save Settings on Exit command is in effect when you quit.

To start File Manager
b Choose the File Manager icon in the Main Group.
Or select the File Manager icon and press Enter.
To quit File Manager
b Double-click the Control menu box.

Or from the File menu, choose Exit.



Customizing the Toolbar

You can add, remove, and rearrange the buttons on the toolbar. Every command available on File Manager menus has an
equivalent button.

To add, remove, move, or restore toolbar buttons

1 From the Options menu, choose Customize Toolbar.
Or double-click the background of the toolbar.

Windows NT displays the Customize Toolbar dialog box.

. To add a button, select the button that you want to add in the Available Buttons box or select Separator to add a space
between buttons. Choose the Add button.
u To remove a button, select the button or Separator you want to remove in the Toolbar Buttons box. Choose the

Remove button.

You can also press and hold down SHIFT while dragging the button off the toolbar.
u To move a button, select the button or Separator you want to move in the Toolbar Buttons box. To move the selection
to the left on the toolbar, choose the Move Up button. To move the selection to the right on the toolbar, choose the Move Down
button.

You can also press and hold down SHIFT while dragging the button to a new location on the toolbar.
. To restore the default toolbar buttons, choose the Reset button.

2 Choose the Close button when you finish customizing the toolbar.

For more information on these options, choose the Help button while using the dialog box.



Opening and Closing Directory Windows

You can open additional directory windows that display the contents of the same drive or a different drive. Opening multiple
directory windows makes it easy to move and copy files.

If you have two or more windows displaying the same drive and directory information, a number appears in the title bar of each
window, indicating that there is more than one window displaying that directory.

A new directory window inherits its display options from the previous one. For example, if you are working with a directory
window that shows only the directory tree, and you open a new directory window, the new window displays only the directory
tree.

To open a new directory window

b To open a window that displays information for the selected drive, double-click the drive icon or press TAB to select the
drivebar and use the arrow keys to select a drive icon. Then choose Open from the File menu, or press ENTER
¥ To open a window that displays the same information as the previous active window, choose New Window from the
Window menu. Or from the toolbar, click the New Window button.
b To open a window that displays only the contents pane for the selected directory, in the directory tree, press and hold
down SHIFT while double-clicking the directory icon. Or in the directory tree, select the directory icon, and then press
SHIFT+ENTER.

When you finish working with a directory window, you can close it to clear space on your screen. If you have only one directory

window open, you cannot close it.

To close the active directory window
¥ Double-click the Control menu box, located in the upper-left corner of the directory window. Or, from the Control menu,
choose Close.
File Manager automatically updates open directory windows. For example, when you save a new file from an application, File
Manager displays the new filename immediately. Sometimes File Manager cannot complete an update when, for example, you
are using network directories or you have changed floppy disks. You can update the active directory window manually when
this occurs.

To manually update a directory window
b Select the drive icon for the current drive, or choose Refresh from the Window menu.



Selecting and Arranging Directory Windows and Icons

Before you can work with the files and directories in a directory window, you must select the window. Selecting the window
makes it active; the title bar changes color or intensity and the window moves in front of the other open windows.

To select an open directory window
b Click anywhere in the window.
Or choose a window name from the list at the bottom of the Window menu.
Or press CTRL+F6 or CTRL+TAB until the window you want is selected.
If the window you want to select is hidden by another window, you can use the Cascade or Tile commands on the Window
menu to rearrange the open directory windows so that all of them are visible.

To arrange open directory windows

b To overlap windows so that each window's title remains visible, choose Cascade from the Window menu.

b To resize and arrange windows without overlap so that each window is wider than it is long, choose Tile Horizontally
from the Window menu.

b To resize and arrange windows without overlap so that each window is longer than it is wide, choose Tile Vertically from
the Window menu.

When you minimize a directory window, it becomes an icon. You can move icons individually by dragging them with the mouse,
or File Manager can arrange them evenly all at once.

To arrange icons
¥ From the Window menu, choose Arrange Icons.



Displaying the Directory Tree or Contents

When you first start File Manager, the directory window displays both the directory tree for the current drive and the contents of
the current directory. By using commands on the View menu, you can choose to display only the directory tree or only the
contents of the current directory. When both panes of a directory window are displayed, they are separated by a split bar that
you can move to change the widths of the panes.

To display the directory tree or directory contents

b To display only the directory tree for the current drive, choose Tree Only from the View menu.
b To display only the contents of the current directory, choose Directory Only from the View menu.
¥ To display the tree and contents for the current directory, choose Tree and Directory from the View menu.

To move the split bar

¥ Use the mouse to point to the split bar. The pointer turns into a double bar with two arrows. Drag the bar to its new
position.
¥ Or, choose Split from the View menu to display a vertical bar. Use the arrow keys to move the selection bar to where

you want to place the split bar, and then press ENTER.

If you decide you do not want to move the split bar, press ESC to cancel the command.



Changing the Font in File Manager

You can change the font that File Manager uses to display the names of your files and directories. You can also change the
style and size of the font. Changing the font affects all directory windows.

To change the font
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From the Options menu, choose Font.

In the Font box, select the font you want to use.

When you select a font, a style, or a size, the text in the Sample box changes to reflect your choice.

In the Font Style box, select a style option (for example, bold or italic).

In the Size box, select a point size; the larger the point size, the larger the character appears on your screen.

By default, file and directory names appear in lowercase letters on drives formatted to use the file allocation table(FAT) file
system. On drives formatted to use the Windows NT file system (NTFS), names appear as they were typed in uppercase and
lowercase.

To display names on FAT drives in uppercase, clear the Display Lowercase For FAT Drives check box.
To display names on all drives in lowercase, select the Display Lowercase For All Drives check box.
Choose the OK button.

For help with the Font dialog box, choose the Help button, or press F1 while using the dialog box.



Changing Disk Drives
A directory window shows the directory structure of the current drive. On the drivebar, the icon for the current drive is
surrounded by a rectangle. On the toolbar, the current drive is shown in the list box.

When you change to a different drive, the names of the files and directories on that drive are displayed in the directory window.
When File Manager searches the drive to display its contents, you can press ESC to stop the search. If you stop the search,
only a partial directory tree is displayed, as indicated by the status bar at the bottom of the File Manager window.

To change drive
Select a drive icon. representing the drive you want to use.
Or open the toolbar drive list box and select the drive.
Or press CTRL and the letter of the drive you want to change to.

Or from the Disk menu, choose Select Drive, or double-click the background of the drivebar to open the Select Drive dialog
box. Then select the drive you want and choose the OK button.

For help with the Select Drive dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

Changing Directories



Changing Directories
You can change directories using either the directory tree or the contents list.

In the directory tree,. the current directory is marked by the selection cursor, a dotted rectangle around the highlighted icon and
text. You can select only one directory at a time in the directory tree.

In the contents list, you can move up or down one level in the directory structure. You can go up one level by choosing the Up
icon, and you can change to a subdirectory by choosing its icon in the list.

To change directories in the directory tree
b Click the directory name you want to change to.
Or press TAB to move to the directory tree, and then use the arrow keys to select a directory.
Tip
¥ To quickly change to the root directory, press the HOME key.

To change directories by using the contents list

¥ To move down a level, choose the directory icon next to the subdirectory's name.
¥ To move up a level, choose the Up icon (the arrow at the top of the contents list), or press the BACKSPACE key.

See Also

Changing Disk Drives



Expanding and Collapsing the Directory Tree
When you first start File Manager, only the first level of directories is displayed in the directory tree.

When you expand a directory, the directory tree displays the names of the subdirectories in that directory. Like the structure of a
tree, subdirectories branch from directories. You can expand an entire directory branch, a single level of the branch, or all
branches in the tree. You can also collapse a directory so that the branch of subdirectories is not listed in the directory tree.

To expand or collapse a directory

¥ To expand one level of a directory, choose the icon or name of the directory you want to expand, or select the directory,
and then choose Expand One Level from the Tree menu.

b To expand an entire branch, select the directory, and then choose Expand Branch from the Tree menu.

¥ To expand all branches in the directory tree, choose Expand All from the Tree menu.

¥ To collapse a directory, choose the icon or name of the directory you want to collapse, or select the directory, and then

choose Collapse Branch from the Tree menu.
See Also

Changing Directories
Changing Disk Drives



Showing Which Directories Expand

If you want to know which directories have subdirectories, you can use the Indicate Expandable Branches command on the
Tree menu. When you use this command, a plus sign (+) marks each directory that has subdirectories. The plus sign means
you can expand the directory to display its subdirectories in the directory tree. After you expand a directory, the plus sign
changes to a minus sign (-), indicating that the directory is expanded and can be collapsed. If you choose the Indicate
Expandable Branches command, File Manager may take longer to create the directory tree.

To mark expandable directories in the directory tree
From the Tree menu, choose Indicate Expandable Branches.
A check mark appears next to the command in the Tree menu.

To turn off this feature, choose Indicate Expandable Branches again.



Connecting to and Disconnecting from a Network Drive

You can use File Manager to connect to and disconnect from network drives. Once you have connected to a network drive, you
can specify whether or not to reconnect to the drive each time you log on to Windows NT.

Computers in your computer's domain or workgroup are displayed automatically in the Shared Directories box. If you are
connecting over a slow network, for example connecting through Remote Access Service, you can switch this off by clearing the
Expand By Default check box.

When you connect to a network drive, File Manager opens a new window in which to display the directory information. You can
switch this feature off from the Options menu, by choosing the Open New Window On Connect command.

Important
¥ If you are logged on as a member of the Administrators, Server Operators, or Backup Operators groups, you can connect
to a computer's administrative root shares, for example \SALESERVER\C$. Administrative shares are not displayed by the Shared
Directories box in the Connect Network Drive dialog box.

To connect to a network drive

1 Choose Connect Network Drive from the Disk menu, or choose the Connect Drive button on the toolbar.

2 File Manager displays the first free drive letter in the Drive box. You can accept the displayed drive letter for the connection,
or choose another in the Drive box.

3 Select or type a network path in the Path box. A network path consists of a computer name followed by the name of a shared
directory; for example, \SHIPPING\PUBLIC.

¥ If you have connected to the directory before, select the path from the list displayed by the Path box. The Path box
displays the previous 10 paths.
¥ You can use the Shared Directories box to select a network path. In Microsoft Windows-based networking, you can

browse domains, workgroups, and computers to look for shared directories. Other networks may contain different options.
The networks, domains and workgroups, computers, and shared directories are organized in a tree structure. Choose an item
to expand the list: Choose a hetwork name to display available domains and workgroups, a domain or workgroup name to
display available computers, a computer name to display its shared directories. When you select a shared directory, File

Manager fills in the Path box with the name you selected.
¥ If you know the name of a computer, but need to see the names of its shared directories, you can type the computer name
in the Path box and choose the OK button. Preface the computer name with two backslashes (\\). Windows NT adds the name of
the computer's first shared directory to the Path box and displays all the computer's shared directories in the Shared Directories
box. To connect to a different directory, select it in the Shared Directories box.
¥ You can type the name of a computer and shared directory in the Path box. Preface the computer name with two
backslashes (\\) and separate the computer name from the shared directory's name with a single backslash (\), for example \
\SHIPPING\SALESQ1.

4 By default, you are connected under the username you used to log on. If you want to connect under a different username,
type it in the Connect As box.

On a Microsoft Windows-based network, you can connect using an account on a different domain by specifying the domain
and the username for the account. Separate the domain name from the username with a backslash, for example
PROJECTS\CHRISBR.

5 If you do not want to connect to the shared directory each time you log on, clear the Reconnect At Logon box.
6 Choose the OK button.

To disconnect from a network drive

1 Choose Disconnect Network Drive from the Disk menu, or choose the Disconnect Drive button on the toolbar.

2 In the Disconnect Network Drive dialog box, select one or more network drives and choose the OK button.



Displaying Information on Files

When you first start File Manager, only the names of directories and files are shown. In addition to names, you can also display
size, last modification date and time, and attributes of files in the contents list.

The MS-DOS (short) filename, file size, last modification date and time, and file attributes are displayed next to each filename

and directory name in the active directory window.

To display only names of files and directories
b From the View menu, choose Name, or choose the Name button on the toolbar.

To display complete information about each file
b From the View menu, choose All File Details, or choose the All File Details button on the toolbar.

To display selected information about each file

1 From the View menu, choose Partial Details.
2 Select the check boxes of options you want to display, and clear the check boxes of options you don't want to display.
3 Choose the OK button.

For help with the Partial Details dialog box, choose the Help button or press F1 while using the dialog box.



Sorting the Contents of a Directory

When you first start File Manager, File Manager lists directory contents alphabetically, with directories first, followed by
filenames. You can sort the files and directories by name, type, size, or the date the file was last modified. Sorting files and
directories affects only the contents list.

To sort the contents of a directory

b To sort contents alphabetically by name, choose Sort By Name from the View menu or the Sort By Name button on the
toolbar.

¥ To sort contents alphabetically by extension, choose Sort By Type from the View menu or the Sort By Type button on
the toolbar.

b To sort contents by file size, choose Sort By Size from the View menu or the Sort By Size button on the toolbar.

¥ To sort contents by date, choose Sort By Date from the View menu or the Sort By Date button on the toolbar.



Limiting the Files to Display

When you first start File Manager, the contents list displays the names of all the files and directories in the current directory,
except hidden and system files. You can specify whether File Manager displays only certain types of files, or groups of files with
similar filenames or extensions.

Caution

»

If you choose to display hidden and system files, be careful not to rename or delete them. Your computer may not start

or work properly without them.

To specify which types of files are displayed in a directory window

1
2

From the View menu, choose By File Type.
In the By File Type dialog box, use the Name box to limit the display to a single filename. Use wildcards to limit the display
to files with similar names.

A wildcard substitutes for one or more characters. Use an asterisk (*) to represent a group of characters. Use a question
mark (?) to represent a single character. The Name box default is *.*, meaning all files in the directory are listed. For
example, to display only those files with the extension .TXT, you can type *.txt.

Under File Type, select the types of files you want to display.
To display hidden and system files, select the Show Hidden/System Files check box.
Choose the OK button.

For help with the By File Type dialog box, choose the Help button or press F1 while using the dialog box.



Naming a File or Directory

On Windows NT, files on both the Windows NT file system (NTFS), and the file allocation table (FAT) file system can be up to
255 characters.

All of the following file naming rules apply to both NTFS and FAT:

b Names can be up to 255 characters long including extensions. Separate the extension from the name with a period.
¥ Names preserve case, but are not case sensitive. Windows NT retains your use of uppercase and lowercase letters;
however, Windows NT does not distinguish filenames by their case.

b Names can contain any uppercase or lowercase characters except the following: ? " / \ < > * |

When you create a long name, File Manager automatically creates a shorter, MS-DOS-style name. This allows MS-DOS-
based computers and applications that do not support long file names to use the directory or file. However, if you save a file
using an application that does not support long filenames, the long filename will be lost and the file will have only a short name.

When you create a long name on either NTFS or FAT, Windows NT follows these rules to create the short name:
¥ Spaces are removed.

b Periods are removed except for the last period in the filename that is followed by a character. Windows NT interprets this
period as marking the start of the filename's extension.
¥ The following characters, not allowed in MS-DOS-style names, are changed to underscores (_): + ., =11
¥ The name, not including its extension, is truncated to 6 characters and a tilde (~) and a number are appended
b The name's extension is truncated to 3 characters.
The creation of short names in NTFS and FAT is different in the following ways:
b On FAT, extended characters that are valid in the current code page can appear in short, MS-DOS-style names. On
NTFS, extended characters are never allowed in short names.
¥ On NTFS, if you give a file or directory a name that is also a valid short name, no separate short name is ever displayed.

On FAT, short names are always displayed, even when they are identical to the long names.



Creating a Directory

You can create a directory by using the Create Directory command. After you create a directory, you can copy files and
directories to it from other locations by using the Move and Copy commands.

To create a directory

1 In the directory tree, select the directory in which you want the new directory to appear.
2 From the File menu, choose Create Directory.
3 In the Name box, type a name for the new directory.

Use the same conventions for naming directories as you do for naming files. If you decide to create the directory somewhere
other than in the current directory, you can type the full path of the new directory.

4 Choose the OK button.
For help with the Create Directory dialog box, choose the Help button, or press F1 while using the dialog box.

See Also

Naming a File or Directory



Moving and Copying Files and Directories Using a Mouse

You can move and copy files and directories between directories and between drives. When you move or copy a directory, all
the files and subdirectories in it are moved or copied.

On drives formatted to use the Windows NT file system (NTFS), you must have permission to move or copy a file or directory.

Important
b When you copy files or directories, security permissions set on them are discarded as is ownership and auditing
information. They will inherit a new set of permissions from the directory into which they have been copied. In the case of files, if
the new directory does not specify permissions for files, only the file's owner (the person who copied the file) will have permission to
use the file. When you copy or move files or directories to a disk formatted to use the file allocation table (FAT) file system,
permissions are discarded and not replaced.

To move or copy files or directories by dragging

1 Make sure the source and destination locations are visible. You can use the Cascade or Tile command on the Window
menu to rearrange directory windows. The destination can be a directory icon, directory window, or drive icon. If the
destination is a drive icon, the file will be placed in the current directory of that drive.

2 Select the files or directories you want to move or copy. When you drag a selection to its new location, Windows NT
assumes you want to copy it when the destination is on a different drive and move it when the destination is on the same

drive.
To move to a location on the same drive, drag the selection.
To move to a location on any drive, press and hold down SHIFT while dragging the selection.
To copy to a location on a different drive, drag the selection.
To copy to a location on any drive, press and hold down CTRL while dragging the selection.

b

3 Release the mouse button. If you are dragging while pressing SHIFT or CTRL, release the mouse button before releasing
the key.

4 To complete moving or copying, choose the Yes button in the confirmation message box.

If the destination directory contains a file with the same name, a dialog box prompts you to verify that you want to replace the
existing file. Choose the Yes button to replace the existing file, or if you are moving or copying more than one file, choose the
Yes To All button. If you choose the Yes To All button, File Manager does not prompt you for each file that is replaced.

See Also

Moving and Copying Files and Directories Using Commands



Moving and Copying Files and Directories Using Commands

You can move and copy files and directories between directories and between drives. When you move or copy a directory, all
the files and subdirectories in it are moved or copied.

On drives formatted to use the Windows NT file system (NTFS), you must have permission to move or copy a file or directory.

Important
b When you copy files or directories, security permissions set on them are discarded as is ownership and auditing
information. They will inherit a new set of permissions from the directory into which they have been copied. In the case of files, if
the new directory does not specify permissions for files, only the file's owner (the person who copied the file) will have permission to
use the file. When you copy or move files or directories to a disk formatted to use the file allocation table (FAT) file system,
permissions are discarded and not replaced.

To move or copy files or directories using commands

1 Select the file or directory you want to move or copy.
You can select more than one file or directory.
2 To move, choose Move from the File menu. Or choose the Move button on the toolbar.
To copy, choose Copy from the File menu. Or choose the Copy button on the toolbar.
The name of the selected file or directory appears in the From box of the Move or Copy dialog box.

You can select a different file or directory by typing its name in the From box. If the file or directory is not in the current
directory, include the path.

3 In the To box, specify the destination drive or directory.
If you type a drive name without including a path, the file or directory will appear in the current directory of the drive.
If you type a new name, the original file or directory is renamed when it is moved or copied.

4 Choose the OK button.

If the destination directory contains a file with the same name, a message prompts you to verify that you want to replace the
existing file. Choose the Yes button to replace the existing file, or if you are moving or copying more than one file, choose the
Yes To All button. If you choose the Yes To All button, File Manager does not prompt you for each file that is replaced.

For help with the Move or Copy dialog boxes, choose the Help button, or press F1 while using the dialog boxes.

See Also

Moving and Copying Files and Directories Using a Mouse



Copying a File to the Clipboard

You can copy a file onto the Clipboard so that the file can be linked to or embedded in another document.
To copy a file to the Clipboard

1 Select the file you want to copy.

2 From the File menu, choose Copy to Clipboard.

The name of the selected file appears in the Copy to Clipboard box. You can copy a different file by typing its name in the
box. If the file is not in the current directory, include its path.

3 Choose the OK button.



Deleting a File or Directory

You can use File Manager to delete files and directories. By selecting multiple files or directories, you can delete them at one
time. When you delete a directory, all of its subdirectories and files are deleted.

Caution
¥ Once you delete files or directories, they cannot be recovered.

Important
b On drives formatted to use the Windows NT file system (NTFS), you must have permission to delete a file or directory.

To delete a file or directory

1 Select the file or directory you want to delete.
2 From the File menu, choose Delete.
Or choose the Delete button on the toolbar.
Or press the DEL key.

3 In the Delete dialog box, choose the OK button to delete the selected file or directory, or type the name of a different file or
directory you want to remove. If you type a long name that contains spaces, be sure to enclose the name in quotation marks.

4 File Manager prompts you to confirm the deletion. You can choose not to receive confirmation messages by using the
Confirmation command on the Options menu.

5 To delete a single file or directory, choose the Yes button. To delete more than one file or directory and without confirming
each deletion, choose the Yes To All button.

For help with the Delete dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

Setting Directory Permissions
Setting File Permissions



Renaming a File or Directory
You can rename any file or directory in File Manager.

Caution
¥ Be careful when you rename files. If you rename a file that your system requires, for example, any file that has an .SYS
extension, your system may not start or run correctly.

Important
¥ On drives formatted to use the Windows NT file system (NTFS), you must have permission to rename a file or directory.

To rename a file or directory
1 Select the file or directory you want to rename.
2 From the File menu, choose Rename.

The name of the selected file or directory appears in the From box of the Rename dialog box. If you decide to rename a
different file, type the name in the From box. To rename a group of files, use wildcards (for example, *.BAK).

3 In the To box of the Rename dialog box, type the new name.

Use a file or directory name that does not already exist in the destination directory. You can specify only one filename in the
To box. If you want to rename a group of files, you can only use wildcards (for example, *.TXT).

4 Choose the OK button.

For help with the Rename dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

Setting Directory Permissions
Setting File Permissions



Searching for a File or Directory

When you want to find a file or directory, use the Search command. You can select files and directories in the Search Results
window and use File menu commands to print, copy, move, delete, and rename them. You can view file details by using
commands on the View menu. Although you can move or copy files from the Search Results window, you cannot copy or
move files into it.

To search for a file or directory

1 Select the directory from which you want to start the search.
2 From the File menu, choose Search.

3 In the Search dialog box, type the name of the file or directory. Use wildcards to search for a group of files or directories with
similar names or extensions.

For example, to search for all files with the extension .WRI, you would type *.wri in the Search For box.

4 In the Start From box, the current directory is listed. To start the search from a different directory, type the directory name in
the Start From box.

5 By default, File Manager searches the directory listed in the Start From box, and all its subdirectories. If you do not want File
Manager to search the subdirectories, clear the Search All Subdirectories check box.

6 Choose the OK button.
To cancel the search, choose the Cancel button.
File Manager displays the progress of the search in a dialog box. You can work with File Manager while the search continues

in the background. To hide the dialog box while the search continues, choose the Hide button. When the search is complete, the
Search Results window appears, displaying all the filenames and directories found.

If you modify the drive on which the search was performed and the Search Results window is active (or is made active), a
message appears, asking whether you want to update the Search Results window. If you choose the Yes button, the search
is performed again on the modified drive.

For help with the Search dialog box, choose the Help button, or press F1 while using the dialog box.



Associating Files with an Application

Afile is associated with an application through the file's filename extension and the application's file type. Once a file is
associated with an application, you can choose any file with the same extension in the directory window to start the application
and load the file. A file extension can only be associated with one application; however, an application can be associated with
several different file extensions.

Many applications are associated with files when you install them. If an application does not automatically set up an
association, you can associate files with it by using the Associate command. If a file is associated with an application, there is a
document-file icon next to the filename in the directory window.

To create or change a file association

1 In adirectory window, select a file that has the extension you want to associate.
For example, to associate files that have a .DAT extension with an application, select any file that has a .DAT extension.
2 From the File menu, choose Associate.

3 The filename extension of the file you selected appears in the Files With Extension box. To associate a different filename
extension, or if no file was selected when you chose the Associate command, type the extension in the Files With Extension
box.

4 To associate the extension with a file type:
If the file type and program name appear in the Associate With list, select the file type and program name.

If the file type and program name do not appear in the Associate With list, type the program name including its extension in
the Associate With box. You can also use the Browse button to search for a program name. In the Browse dialog box,
selecting the program filename and choosing the OK button places the program name and its path in the Associate With box.

5 Choose the OK button.
To remove a file association

1 In adirectory window, select a file that has the extension you want to remove.
2 From the File menu, choose Associate.

3 The filename extension of the file you selected appears in the Files With Extension box. To remove the association for a
different filename extension, or if no file was selected when you chose the Associate command, type the extension in the
Files With Extension box.

4 Select (None) in the Associate With box and then choose the OK button.

For help with the Associate dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

Working with File Types



Working with File Types

File types are used when associating a file with an application. You can create, change, or delete file types. In the File Type
dialog, you can also change the file associations for the file type.

To create a file type, name the file type and then provide the information you want File Manager to use when opening or printing
a file of that type either by starting the program or by using dynamic data exchange (DDE).

When DDE is used, you can specify the following information:

b
b
»

DDE Message: Specifies the DDE command to use if the application is already running.
DDE Message Application Not Running: Specifies the DDE command to use if the application is not running.
Application: Specifies the DDE application string used to initiate a DDE conversation with the application specified in the

Command box.

b

box.

Topic: Specifies the DDE topic string used to initiate a DDE conversation with the application specified in the Command

To create a file type

1
2
3
4

7

From the File menu, choose the Associate command.

In the Associate dialog box, choose the New Type button.

In the New File Type dialog box, type the name of the file type in the File Type box.

In the Action box, choose Open or Print to specify the command File Manager executes when opening or printing files of that
type.

In the Command box, type the command for the Open or Print actions.

Commands start with the name of the program file followed by application-specific parameters and the %1 parameter. The %1
parameter represents the filename of the file currently selected in File Manager when the action is performed.

You can choose the Browse button to search for a program name.

If the application supports DDE, specify the name of the program file in the Command box. Then select the Uses DDE check
box and specify the application-specific DDE commands.

To associate an extension with the file type, type the extension in the New Extension box and choose the Add button. You
can add multiple extensions.

Choose the OK button.

Important

k

Some file types are protected. To change a protected file type, you must be logged on as a member of the Administrators,

Server Operators, or Power Users group.

To change a file type

1 From the File menu, choose the Associate command.

5

In the Associate dialog box, select the file type you want to change in the Associate With list, and then choose the Change
Type button.

In the Change File Type dialog box, make any changes to the file type name or the commands associated with the Open and
Print actions.

You can also add or remove extensions associated with the file type.

To associate an extension with the file type, type the extension in the New Extension box and choose the Add button. You
can add multiple extensions.

To remove an associated extension, select it in the Extensions box and choose the Remove button.
Choose the OK button.

To delete a file type

1
2

From the File menu, choose the Associate command.

In the Associate dialog box, select the file type you want to delete in the Associate With list, and then choose the Delete
Type button.

See Also

Associating Files with an Application



Starting an Application from File Manager

You can use File Manager to start your applications. You start an application by opening a program file or document file from a
directory window. Program files almost always have a .COM, .EXE, .PIF, .CMD or .BAT filename extension. Document files
are associated with applications and are represented by document-file icons in directory windows.

When you start an application that runs in a window, the window appears in front of any open File Manager windows. When you
start an application that uses the entire screen, the application replaces the File Manager window. If you want to reduce File
Manager to an icon each time you start an application, choose the Minimize On Use command from the Options menu.

To start an application from a program or document file
b In the directory window, choose the filename.
-Or-
b Select the filename in the directory window and choose Open from the File menu, or press ENTER
To start an application and open a file
¥ Drag the icon for the data file onto the icon for the program file.
-Or-
1 Select the program file for the application you want to use.
2 From the File menu, choose Run.
3 The name of the program file appears in the Command Line box. If you did not select a program file, or if you want to run a
different application, type the name (and path, if necessary) of the program file in the Command Line box.

Then, in the Command Line box, add the name of the data file after the program filename. Include the path if the data file is
not in the same directory as the program file.

4 If you want the application to start minimized, select the Run Minimized check box.
5 Choose the OK button.



Printing a File from File Manager

Using File Manager, you can print files that are associated with applications. You can either use the Print command, or drag the
file icon if you are using a mouse.

Note

¥ Some applications do not support printing through File Manager. If this is the case, or if a file is not associated with an
application, you must open the application and print the file from there.

To print a file by dragging the file icon

1 Click the Start button, point to Settings, and then click Printers.

2 Drag the document-file icon onto the icon of the appropriate printer.
To print a file by using the Print command

1 In the directory window, select the file you want to print.
2 From the File menu, choose Print.
3 Choose the OK button.

For help with the Print dialog box, choose the Help button, or press F1 while using the dialog box.

See Also

Associating Files with an Application



Turning Off Confirmation Messages

If you do not want a confirmation message to appear each time you delete or replace files and directories, you can change the
confirmation settings. You can also turn off messages that appear when you perform certain mouse actions, such as moving and
copying. If you turn off confirmation messages, File Manager carries out commands as soon as they are issued.

Caution

¥ If you clear the Directory Delete check box, remember that when you delete a directory, all files and directories in that
directory are deleted. Also, to avoid accidentally writing over files you want to keep, do not clear the File Replace check box.

To turn off confirmation messages

1 From the Options menu, choose Confirmation.

2 In the Confirmation dialog box, clear the check boxes for the tasks you want to perform without receiving confirmation
messages.

3 Choose the OK button.

For help with the Confirmation dialog box, choose the Help button, or press F1 while using the dialog box.



Setting File Attributes

In File Manager, you can change the properties of a file. These properties include file attributes such as read only, archive,
hidden, system, and compress. File attributes are part of the directory information the operation system maintains for each file.
This information helps the operating system identify a file and controls the kinds of tasks you can perform with the file. You can
see file attributes in a directory window by choosing the All File Details command on the View menu.

Important
On drives formatted to use the Windows NT file system (NTFS), you must have permission to change file attributes.

To change file attributes for one or more files

1 Select the files whose attributes you want to set.
2 From the File menu, choose Properties.
If you are using a network, more options may be available in the Properties dialog box.
3 In the Properties dialog box, select or clear the check boxes for the attribute settings.
When you select more than one file, check boxes appear gray if the attribute for the files is not set alike.
4 Choose the OK button.

For help with the Properties dialog box, choose the Help button, or press F1 while using the dialog box.

See Also

Setting File Permissions



Sharing a Directory

Share a directory when you want to make information located there available to others on the network. Before you can share a
directory, the Server service must be running. You can start the server service using the Services option in Control Panel.

Important
To share a directory, you must be logged on as a member of the Administrators, Server Operators, or Power Users group.

Windows NT automatically creates an administrative shared directory for the root directory of each drive on the computer and for
the Windows NT system root, for example C:\WINNT. Administrative shares created for drives are named using the drive letter
and a dollar sign, for example C$. The shared directory created for the system root is called ADMIN$. Members of the
Administrators Server Operators, or Backup Operators groups can connect to these shared directories. Only members of the
Administrators group can change properties for them.

To share a directory

1 Select the directory you want to share in either the tree or contents panes of the directory window.

If you are logged on as a member of the Administrators group, you can share a directory on a remote computer. First connect
to the computer's administrative shared directory, for example C$. Then select the directory you want to share.

2 From the Disk menu, choose Share As, or choose the Share Directory button on the toolbar.

If the directory you selected is already shared, the Shared Directories dialog box is displayed. Choose the New Share button
to create a share using the New Share dialog box.

3 The Share Name box shows the name users will specify to connect to the shared directory. By default, File Manager uses
the name of the directory you selected. If you want to share the directory using a different name, type a new share name in
the Share Name box. Share names can be up to 12 characters long.

4 The path for the directory you selected appears in the Path box. If you decide you want to share a different directory, you can
type a different path.

5 Type a comment in the Comment box.

Users will see the comment when connecting to the directory using the Connect Network Drive dialog box. A comment is
optional.

6 Set a limit on the number of users who can connect to the shared directory at one time in the User Limit box.
By default, no limit is set, (though there may be a limit on how many users can connect to this computer overall).
7 To set permissions on the shared directory, choose the Permissions button.

8 Choose the OK button.

File Manager shows that the directory is shared by displaying a shared directory icon next to the directory's name.

See Also

Setting Permissions Through Shared Directories



Stopping Directory Sharing

Once you stop sharing a directory, it is no longer available over the network. The Stop Sharing Directory dialog box displays
shared directories you have created as well as shared directories created by the system. In general, you should not stop
sharing directories created by the system, for example C$ or print$. Administrative shares that are deleted are recreated
automatically the next time the server service is started.

Caution
¥ If you choose to stop sharing a directory while users are connected, those users may lose their data.

Important
¥ To stop sharing a directory, you must be logged on as a member of the Administrators, Server Operators, or Power Users
group.

To stop sharing a directory

1 Select the drive containing the directories you want to stop sharing by selecting the drive's directory window or drivebar
button.

2 From the Disk menu, choose Stop Sharing. Or choose the Stop Sharing button on the toolbar.

3 The Stop Sharing dialog box shows the computer name of the selected drive and, in the Shared Directories On box, the
shared directories on the drive. For each share name, the directory path on the computer is shown. Select the directories you
want to stop sharing. If you selected a shared directory before opening the Stop Sharing Directory dialog box, the shared
directories corresponding to that directory are already selected.

4 Choose the OK button.

If any users are connected to a shared directory, File Manager will warn you before sharing is stopped.



Changing Share Properties

You can change the number of users allowed to connect to a shared directory, a shared directory's comment information, or the
shared directory's permissions.

Important
¥ To change a shared directory's properties, you must be logged on as a member of the Administrators, Server Operators,
or Power Users group. Members of the Administrators group can change share properties on administrative shares, for example C$.

To change a shared directory's properties

1 Select the shared directory whose properties you want to change in either the tree or contents panes of the directory window.
2 From the Disk menu, choose Share As. Or choose the Share Directory button on the toolbar.

3 If the directory has been shared more than once, select the name in the Share Name box of the shared directory whose

properties you want to change. You can then:
¥ Change the number of users allowed to connect to the directory at one time by selecting, under User Limit, the
Maximum Allowed option or the Users option. When you select the Users option, you can either type a limit or click the scroll
arrows to raise or lower the limit.

¥ Edit the Comment box to change the description that appears when users see the shared directory listed in the Network
Connections dialog box.
b Choose the Permissions button to change the permissions on the shared directory.

4 Choose the OK button.

See Also

Setting Permissions Through Shared Directories



Viewing or Closing Shared Files

Members of the Administrators, Server Operators, and Power Users groups can view who is using shared files and stop the use
of a file.

Caution
¥ When you close a file that is in use, changes made to that file are not saved.

Important
¥ To stop the use of shared files, you must be logged on as a member of the Administrators, Server Operators, or Power
Users group.

To view or close a shared file

1 Choose the file in the contents pane of the directory window.

2 From the File menu, choose Properties.

3 Choose the Open By button in the Properties dialog box.

4 To stop use by one or more users, select the user or users and choose the Close Selected button.
To stop use by all users, choose the Close All button.

5 Choose the OK button.



Setting Directory Permissions

Setting permissions on a directory specifies the access that a group or user has to the directory and, by default, its files. Existing
subdirectories and their files are not changed unless you specify to change them. However, when you create new files and
subdirectories in the directory, they inherit their permissions from the directory.

Permissions are cumulative except that the No Access permission overrides all other permissions. For example, if a user is a
member of a group with Read permission and a member of a group with Change permission, the user will have Change
permission.

Note

b Groups or users granted Full Control permission on a directory can delete files in that directory no matter what
permissions protect the files.

You can set directory permissions only on drives formatted to use the Windows NT file system (NTFS).

Important
b To change permissions on the directory, you must be the owner of the directory, or have been granted permission to do so
by the owner.

To view or change directory permissions

1 Select the directory in the directory window. You can select multiple directories.
2 From the Security menu, choose Permissions. Or choose the Permissions button on the toolbar.

3 By default, the Replace Permissions On Existing Files check box is selected, so the changes you make to permissions
apply to the directory and its files only.

Select both the Replace Permissions On Subdirectories and the Replace Permissions On Existing Files check boxes to
apply changed permissions to the directory and its files, and to existing subdirectories and their files.

To apply changed permissions to the directory only (not to existing files in the directory or to subdirectories and their existing
files), clear both the Replace Permissions On Subdirectories and Replace Permissions On Existing Files check boxes.

To apply changed permissions to the directory and subdirectories only (not to existing files in the directory or subdirectories),
select the Replace Permissions on Subdirectories check box and clear the Replace Permissions on Existing Files check
box.

4 Select the name of a group or user and choose a permission from the Type of Access box.
You can customize directory and file permissions by choosing Special Directory Access... or Special File Access....
5 Choose the OK button.

To remove directory permissions

¥ To remove directory permissions, select the name of the group or user in the Directory Permissions dialog box.
Choose the Remove button.

For help with any dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

Directory Access Permissions
Adding Users and Groups to Permissions and Auditing Lists



Setting File Permissions

Setting permissions on a file specifies the access that a group or user has to it. When a file is created in a directory, it inherits
its permissions from the directory.

Permissions are cumulative except that the No Access permission overrides all other permissions. For example, if a user is a
member of a group with Read permission and a member of a group with Change permission, the user will have Change
permission.

When you set a standard permission, a set of individual permissions is displayed next to it. For example, when you set Read

permission on a file, you see (RX), signifying Read and Execute permissions on the file.

Note
¥ Groups or users granted Full Control permission on the directory containing a file can delete the file no matter what
permissions protect it.

You can set file permissions only on drives formatted to use the Windows NT file system (NTFS).

Important

b To change permissions on the file, you must be the owner of the file, or have been granted permission to do so by the
owner.

To change permissions on a file

Select one or more files from the contents pane of the directory window.

Choose Permissions from the Security menu, or choose the Permissions button on the toolbar.

In the File Permissions dialog box, select the name of the group or user whose permission you want to change.
Choose a permission from the Type of Access box.

To customize the permissions set for the group or user, choose Special Access... from the Type of Access box.
Choose the OK button.

o o b~ W N

To remove file permissions

b To remove file permissions, select the name of the group or user in the File Permissions dialog box. Choose the
Remove button.

For help with any dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

File Access Permissions
Adding Users and Groups to Permissions and Auditing Lists



Setting Special Access Permissions

In general, the standard directory and file permissions are all you need to secure your directories and files. However, if you want
to create a custom set of permissions, you can use special access permissions. You can set special access permissions on
directories, on all the files in selected directories, or on selected files.

When you set special access permissions on a directory, the permissions affect the directory only. Current permissions on files in
the directory are not affected.

To set special access permissions

You can set special access permissions on directories, all files in directories, or selected files.

b To set permissions on directories, select them in the directory window.
¥ To set permissions on all the files in one or more directories, select the files' directories in the directory window.
¥ To set permissions on selected files, select the files in the contents pane of the directory window.

1 Choose Permissions from the Security menu, or choose the Permissions button on the toolbar.
2 In the Permissions dialog box, select the group or user you want to grant special access.

If no groups or users are shown, indicating that the directories or files you selected have differing permissions, add a group or
user before setting special access permissions.

3 Open the appropriate Special Access dialog box:

¥ To set permissions on directories, choose Special Directory Access from the Type of Access box or double-click the
name of the group or user.

¥ To set permissions on all the files in the selected directories, choose Special File Access from the Type of Access box.
¥ To set permissions on selected files, choose Special File Access from the Type of Access box or double-click the name

of the group or user.

The Special Access dialog box shows which access permissions have been granted based on the current standard or special
permissions setting.

4 To set special access permissions, select the check boxes for the access you want to grant.
To grant full control, select Full Control (All).

If you are setting permissions for all files in directories, you can select Access Not Specified. This removes permissions from
files in the selected directories and prevents files from inheriting permissions from their directories.

4 Choose the OK button.
For help with any dialog box, choose the Help button, or press F1 while using the dialog box.

See Also

Special Access Directory Permissions
Special Access File Permissions



Setting Permissions Through Shared Directories

You can set permissions through a shared directory whether the directory is on a drive formatted to use the Windows NT file

system (NTFS), FAT, or HPFS. To secure shared directories effectively, keep the following in mind:
¥ Permissions set through a shared directory are effective only when the directory is reached over the network.
b Permissions set through a shared directory apply to all files and subdirectories in the shared directory.
b Permissions set through a shared directory that is on an NTFS volume operate in addition to NTFS permissions set on the
directory itself. Shared directory permissions specify the maximum access allowed.

Important
¥ To work with shared directory permissions, you must be logged on as a member of the Administrators, Server Operators,
or Power Users group.

To view or change permissions set through a shared directory

1 Select the shared directory whose permissions you want to change in either the tree or contents panes of the directory
window.

2 From the Disk menu, choose Share As. Or choose the Share Directory button on the toolbar.

3 Choose the Permissions button.

4 Select the name of a group or user and choose a permission from the Type of Access box.

5 Choose the OK button.

To remove permissions set through a shared directory

b To remove permissions for a group or user, select the name of the group or user in the Shared Directory Permissions
dialog box and choose the Remove button.

For help with any dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

Shared Directory Permissions
Adding Users and Groups to Permissions and Auditing Lists



Auditing Files and Directories

Auditing files and directories allows you to track their usage. For a particular file or directory, you can specify which groups or
users and which actions to audit. You can audit both successful and failed actions. Windows NT stores the information generated
from auditing in a file.

To audit files and directories, you must set the audit policy to audit file and object access. Set audit policy in User Manager.

Important
To audit files and directories, you must be logged on as a member of the Administrators group.

To audit a file or directory

1 In the File Manager window, select the file or directory.
2 From the Security menu, choose Auditing.

3 If you are setting auditing on a directory, two check boxes allow you to control how auditing changes apply to existing files and
subdirectories.

By default, the Replace Auditing On Existing Files check box is selected, so the changes you make to auditing apply to the
directory and its files only.

Select both the Replace Auditing On Subdirectories and the Replace Auditing On Existing Files check boxes to apply
auditing changes to the directory and its files, and to existing subdirectories and their files.

To apply auditing changes to the directory only (not to existing files in the directory or to subdirectories and their existing files),
clear both the Replace Auditing On Subdirectories and Replace Auditing On Existing Files check boxes.

To apply auditing changes to the directory and subdirectories only (not to existing files in the directory or subdirectories), select
the Replace Auditing on Subdirectories check box and clear the Replace Auditing on Existing Files check box.

4 Set auditing for each group or user in the list:
Select the name of a group or user, and then select the events to audit for that group or user.
5 Choose the OK button.

To remove file or directory auditing for a group or user

1 Inthe Auditing dialog box, select the name of the group or user in the list.
2 Choose the Remove button.

3 For help with any dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

Audited Directory Events
Audited File Events

Adding Users and Groups to Permissions and Auditing Lists



Adding Users and Groups to Permissions and Auditing Lists

The Add Users And Groups dialog box is available from the dialog boxes that allow you to change and remove permissions
and auditing for users and groups. Use the dialog box to add users and groups to the permissions or auditing list, search for the
members of a group, and find the domain to which a group or user belongs.

The Add Users And Groups dialog box displays the groups on the computer or in the domain shown by the List Names From
box. Local groups are shown for the computer or domain whose name is followed by an asterisk (¥). You can select another
domain by using the List Names From box.

Domains appear only if your computer is a member of a domain on a Windows NT Server network. The domains shown have
a trust relationship.

To add a user or group to a permissions or auditing list

1 In the permissions or auditing dialog box, choose the Add button.

2 You can use options in the Add Users And Groups dialog box to display users, find the users in a group, or find the domain
to which a group or user belongs.

¥ To display the names of users on the selected computer or domain, choose the Show Users button.
b To see a group's content, select the group and choose the Members button. Users are listed in a new dialog box. On a
Windows NT Server network, global groups that are members of a local group appear in the list. To see a global group's users,
select the group and choose the Members button. To include the group in the Add Users and Groups dialog box, choose the Add
button. To include some of the group's users, select them and choose the Add button.
¥ To add a group or user, you must know the domain which contains the group's or user's account. On a Windows NT
Server network, choose the Search button to find the domain of a group or user. In the Find Account dialog box, type the name of
the group or user in the Find User Or Group box and specify the domains you want to search. Then choose the Search button. To
include the groups or users in the Add Users and Groups dialog box, select them in the Search Results box and choose the Add
button.

1 To add groups or users to the list, select them in the Names box and choose the Add button, or double-click the name of the

group or user. Or you can type the names of groups and users in the Add Names box. Separate names using a semicolon.

If the account of the group or user is not located on the computer or domain shown by the List Names From box, you must
specify the location. Type the computer or domain name followed by the group or user name and separate the names using
a backslash, for example SHIPPING\ERNESTA. You can type the name without waiting for Windows NT to list groups in the
Names box.

2 If you are adding users or groups to a permissions list, select the permission for the groups or users shown in the Add Names
box using the Type of Access box.

3 Choose the OK button.

4 For help with any dialog box, choose the Help button, or press F1 while using the dialog box.



Taking Ownership of Files or Directories

When you create a file or directory, you become the owner of it. By granting permissions, the owner controls how the file or
directory is used. The owner can grant permission to another user to take ownership of a file or directory. Otherwise, you must be
logged on as a member of the Administrators group to take ownership.

Although an administrator can take ownership, an administrator cannot transfer ownership to others. This preserves security. For
example, only an administrator who takes ownership and changes permissions can gain access to a file on which you have set
No Access permission. By checking the ownership of the file, you would see the ownership change and know who had violated
the permission you set on the file. To make sure that your files are secure, you should check their ownership regularly.

To take ownership of a file or directory

1 Select the file or directory in the File Manager window. You can select more than one file or directory at a time.
2 From the Security menu, choose Owner.
3 Choose the Take Ownership button.

If you have selected one or more directories, File Manager asks whether you want to take ownership of all files and
subdirectories in the trees of the selected directories. Choose Yes if you want to do so.

4 For help with the Owner dialog box, choose the Help button, or press F1 while using the dialog box.



Formatting a Floppy Disk

Formatting prepares a floppy disk so that information can be stored on it and retrieved from it. Windows NT uses the MS-DOS
file allocation table (FAT) file system when formatting a disk. When you format a disk, File Manager removes all the information
from it, writes new directory information to it, and checks for unusable portions called bad sectors.

Caution
You cannot recover information on a disk that has been accidentally formatted.

To format a floppy disk

1 Insert a disk into a drive.

2 From the Disk menu, choose Format Disk.

3 In the Disk In box, make sure that the drive shown is the one containing the floppy you want to format. If necessary, select the
correct drive.

4 In the Capacity box, select the size of the disk you want to format.

5 To give the disk a volume label, type a name in the Label box under Options.

6 To quickly reformat a disk that has been formatted previously, select the Quick Format check box. A quick format deletes
directory information in the file allocation table and root directory. The disk is not checked for bad sectors.

7 Choose the OK button.
A message prompts you to confirm that you want to format the disk. Formatting deletes all information on a disk, so make sure
the disk is the one you want to format before you choose the Yes button.
File Manager displays its progress in a dialog box as formatting proceeds. You can work with File Manager while formatting
continues in the background. To cancel formatting, choose the Cancel button. To hide the dialog box while formatting
continues, choose the Hide button.

After your disk is formatted, a message prompts you to indicate whether you want to format another disk.



Copying a Floppy Disk

You can make a copy of a floppy disk by using the Copy Disk command on the Disk menu. When you copy a floppy disk, both
disks must have the same storage capacity. For example, if the disk you are copying from (the source disk) has a capacity of
720K, the disk you are copying to (the destination disk) must also.

To copy an entire disk

1

Insert the source disk in the drive you want to copy from. If you have two floppy disk drives of the same size, insert the
destination disk in the drive you want to copy to.

From the Disk menu, choose Copy Disk.

If your computer has two floppy disk drives, select the letter of the source drive and the destination drive in the Copy Disk
dialog box. Then choose the OK button.

If your computer has only one floppy disk drive, you are not prompted to select drives.

A message prompts you to confirm that you want to copy the disk. There is ho way to recover information previously stored on
the destination disk, so make sure the disk in the destination drive is one you want to overwrite before you choose the Yes
button.

If you are making a copy using a single floppy disk drive, you are prompted to switch source and destination disks as
necessary.
A message appears, informing you of the percentage of your disk that has been copied.

File Manager displays its progress in a dialog box as the copy is made. You can work with File Manager while copying
continues in the background. To cancel copying, choose the Cancel button. To hide the dialog box while copying continues,
choose the Hide button.



Labeling a Disk
You can assign or change a label for a disk by selecting the Label Disk command on the Disk menu.
To assign or change a volume label

1 Click the drive icon for the disk you want to label.
2 From the Disk menu, choose Label Disk.
3 In the Label box, type the label for the disk.
Labels on NTFS disks can contain up to 32 characters. Labels on FAT and HPFS disks can contain up to 11 characters.
4 Choose the OK button.



Selecting Files Using the Select Files Command

Before you can work with a file or a directory, you must select it. When a file or directory is selected, its name and icon are
highlighted in the directory window.

To select files by using the Select Files command

1 From the File menu, choose Select Files.

2 In the Select Files dialog box, type the name of the file you want to select, and then choose the Select button. You can use
wildcards to select a group of files; for example, *.TXT. Repeat this step if you want to select more files.

You can choose the Deselect button at any time to cancel a selection. The Deselect button cancels the selected files that you
specify in the Files box.

3 Choose the Close button when you have selected all the files you want.

For help with the Select Files dialog box, choose the Help button, or press F1 while using the dialog box.
See Also

Selecting Files Using a Mouse
Selecting Files Using the Keyboard



Selecting Files Using a Mouse
You can use a mouse to select a file or group of files. Before you can select files, they must be visible in the directory window.

To select a file or directory
¥ Click the filename or directory name.

To select two or more items in sequence

1 Click the first file or directory you want to select.

2 Press and hold down SHIFT while you click the last file or directory in the group.

To select two or more items out of sequence
¥ Press and hold down CTRL while you click each file or directory.

To cancel a selection
b Press and hold down CTRL while you click the selected file or directory.

See Also

Selecting Files Using the Keyboard
Selecting Files Using the Select Files Command



Selecting Files Using the Keyboard

You can use the keyboard to select a file or group of files. Before you can select files, they must be visible in the directory
window.

To select a file or directory
Use the following keys to select a file or directory.

Press To select

UP or DOWN ARROW Afile above or below the current
selection.

END The last file in the list.

HOME The first file in the list.

PAGE UP The file at the top of the previous
screen.

PAGE DOWN The file at the bottom of the next
screen.

A character The next file that begins with that

letter or number.

To select two or more items in sequence

1 Use the arrow keys to move to the first file or directory you want to select.

2 Press and hold down SHIFT while you select the remaining items in the group.
To select two or more items out of sequence

1 Use the arrow keys to move to the first file or directory you want to select.
2 Press SHIFT+F8. The selection cursor begins to blink.

3 Move to the next item you want to select.

4 Press the SPACEBAR to select each file or directory.

5 Press SHIFT+F8 when you finish selecting files.

To cancel a selection

1 Press and release SHIFT+F8 so that the selection cursor begins to blink.
2 Move to the selection you want to cancel, and then press the SPACEBAR.
3 Press SHIFT+F8 when you finish canceling selections.

See Also

Selecting Files Using a Mouse
Selecting Files Using the Select Files Command



Directory Access Permissions

When you set a directory permission, two sets of abbreviations for individual permissions are displayed next to it: The
permissions set on the directory and the permissions set on files in the directory. For example, when you set Add & Read
permission on a directory, you see (RWX), signifying Read, Write, and Execute permissions on the directory, and (RX) signifying
Read and Execute permission on files in the directory.

When access to files is shown as (Not Specified), that group or user cannot use files in the directory unless access is granted by
another means; for example, by setting permissions that grant access on individual files.

An asterisk (*) following the set of directory permissions, for example (All)*, indicates that subdirectories do not inherit the
permissions granted to that group or user.

Note
¥ Groups or users granted Full Control permission on a directory can delete files in that directory no matter what
permissions protect the files.

You can set the following standard permissions on directories:

I No Access (None)(None)
L List (RX)(Not Specified)
LI Read (RX)(RX)
L1 Add (Wx)(Not Specified)

Add & Read (RWX)(RX)
1 change (RWXD)(RWXD)
1 Full control (Ally(All




File Access Permissions

When you set a file permission, a set of abbreviations for individual permissions is displayed next to it. For example, when you
set Read permission on a file, you see (RX) signifying Read and Execute permission.

Note
¥ Groups or users granted Full Control permission on the directory containing a file can delete the file no matter what

permissions protect it.

You can set the following standard permissions on files:

_| No Access (None)
F Read (RX)

¥ Change (RWXD)

¥ Full Control (All)



Special Access Directory Permissions

You can set the following individual directory permissions when creating special access permission for directories:
Read (R)

Allows viewing the names of files and subdirectories.
Write (W)

Allows adding files and subdirectories.

Execute (X)

Allows changing to subdirectories in the directory.
Delete (D)

Allows deleting the directory.

Change Permissions (P)

Allows changing the directory's permissions.

Take Ownership (O)

Allows taking ownership of the directory.



Special Access File Permissions

You can set the following individual file permissions when creating special access permission for files:
Read (R)

Allows viewing the file's data.

Write (W)

Allows changing the file's data.

Execute (X)

Allows running the file if it is a program file.
Delete (D)

Allows deleting the file.

Change Permissions (P)

Allows changing the file's permissions.
Take Ownership (O)

Allows taking ownership of the file.



Shared Directory Permissions

You can set the following permissions for files and directories through a shared directory:
k No Access (None)
k Read
¥ Change
¥ Full Control (All)



Audited Directory Events

You can select the following events to audit directory actions:

Read

Audits display of filenames, attributes, permissions, and owner.

Write

Audits creation of subdirectories and files, changes to attributes, and display of permissions and owner.
Execute

Audits display of attributes, permissions, and owner; and changing to subdirectories.
Delete

Audits deletion of the directory.

Change Permissions

Audits changes to directory permissions.

Take Ownership

Audits changes to directory ownership.



Audited File Events

You can select the following events to audit file actions:

Read

Audits display of the file's data, attributes, permissions, and owner.

Write

Audits changes to the file's data or attributes, and display of permissions and owner.
Execute

Audits running of program files and display of attributes, permissions, and owner.
Delete

Audits deletion of the file.

Change Permissions

Audits changes to the file's permissions.

Take Ownership

Audits changes to the file's ownership.



Open

Opens a directory window, expands a directory, starts an application, or opens a document that is associated with an
application.

See Also

Opening and Closing Directory Windows



Move

Moves one or more files or directories to a different directory or disk.

Choose one of the following buttons for information about the dialog box:
¥ From
kTo

See Also

Moving and Copying Files and Directories Using a Mouse
Moving and Copying Files and Directories Using Commands



Copy
Copies one or more files or directories. You can copy a file or directory to a different directory or disk.

Choose one of the following buttons for information about the dialog box:
¥ From
kTo

See Also

Moving and Copying Files and Directories Using a Mouse
Moving and Copying Files and Directories Using Commands



Copy to Clipboard

Copies a file onto the Clipboard so that the file can be linked to or embedded in another document.
The Copy To Clipboard dialog box has the following area:

Copy to Clipboard

This box shows the currently selected file.
b To copy a different file, type its name in this box. If the file is not in the current directory (listed at the top of the dialog box),
include the path.

See Also

Copying a File to the Clipboard



Delete
Deletes one or more files or directories.
The Delete dialog box has the following area:

Delete

This box shows the currently selected file or directory.
b To delete a different file or directory, type its name in this box. If the file is not in the current directory (listed at the top of

the dialog box), include the path.

Note
¥ When you delete a directory, all files and subdirectories in the directory are deleted.

See Also

Deleting a File or Directory



Rename

Renames a file or directory.

Choose one of the following buttons for information about the dialog box:
¥ From
kTo

See Also

Renaming a File or Directory



Properties

Sets file attributes and displays other file information.

Choose one of the following buttons for information about the dialog box:

¥ Read Only
¥ Archive
¥ Hidden
¥ System

¥ Compressed
¥ Version Information

¥ Open By Button

See Also

Setting File Attributes



Properties

Sets file attributes and displays information about the number and size of files selected.

Each option box has one of three settings:
Attribute is set for all selected files.
Attribute is not set for any of the selected files.
2] Attribute is set for some, but not all, of the selected files.

Choose one of the following buttons for information about a particular file attribute:

k Read Only
¥ Archive

¥ Hidden
b System
¥ Compressed

See Also

Setting File Attributes



Network Properties

Allows members of the Administrators, Server Operators, and Power Users groups to stop the use of a file and displays the

status of a shared file, including the following information:

Total Opens shows the total number of open files (including files open more than once) on the computer that the file is
n.

Total Locks shows the total number of locks on the computer that the file is on.

Open By shows the names of the users who have the file open.

For shows the type of access the user has to the file.

Locks shows the number of locks the user has on the file.

File ID shows the identification number of the file.

T T T W

Caution
b When you close a file that is in use, changes made to that file will not be saved.

Important
b To stop the use of shared files, you must be logged on as a member of the Administrators, Server Operators, or Power
Users group.

Close Selected
b To stop the use of a file by one or more users, select the users and choose the Close Selected button.

Close All
¥ To stop the use of a file by all users, choose the Close All button.



Compress

Compresses files on an NTFS partition for more efficient transmission or storage. You can compress one file, several files,
directories, and subdirectories. After compressing directories or subdirectories, the files you add to the directory or subdirectory
are compressed automatically.

If a file is copied from one directory to another, the compression attribute of the file is changed to that of the target directory
regardless of the file system.



Uncompress

Uncompresses a compressed file. You can uncompress one file, several files, directories, and subdirectories.



Run
Starts an application or opens a document that is associated with an application.
The Run dialog box has the following areas:

Command Line

This box displays the currently selected file.

b If a program file or document file is not selected, or if you want to start a different application, type the command and path.
Run Minimized

¥ Select this check box if you want the application to be reduced to an icon as soon as it starts.
See Also

Starting an Application from File Manager
Associating Files with an Application



Print
Prints a document file (a file that is associated with an application) on the default printer.

The Print dialog box has the following area:

Print
This box shows the name of the file to print.
b To print a different file, type its name in this box. If the file is not in the current directory, include the path.
Note
¥ If you want to print a file from File Manager, the file must be associated with an application.
See Also

Associating Files with an Application
Printing a File from File Manager



Associate

Associates a file with an application through the file's flename extension. Once you associate a file extension with an
application, you can open any file with that extension in File Manager and automatically start the associated application. If
supported by the application, you can also print the file from within File Manager. For example, suppose you associate files
that have the extension .CRD with Cardfile. When you open a .CRD file, Cardfile starts and loads the file.

Choose one of the following buttons for information about the dialog box:
b Files with Extension
F Associate With
F Browse Button
F New Type Button
¥ Change Type Button
¥ Delete Type Button

See Also

Associating Files with an Application



Create File Type

Use options in the dialog box to create a file type, and to associate the file type with one or more file extensions.

Choose one of the following buttons for information about the dialog box:
¥ File Type
¥ Action
¥ Command
¥ Browse Button
¥ Uses DDE
¥ DDE Message
¥ DDE Message Application Not Running
¥ Application
¥ Topic
¥ Extensions Associated with this File Type

See Also

Working with File Types



Change File Type
Use options in the dialog box to change a file type, and to add or remove the file type's file associations.

Important
¥ Some file types are protected. To change a protected file type, you must be logged on as a member of the Administrators,
Server Operators, or Power Users group.

Choose one of the following buttons for information about the dialog box:
¥ File Type
k Action
¥ Command
¥ Browse Button
k Uses DDE
¥ DDE Message
» DDE Message Application Not Running
k Application
¥ Topic
F Extensions Associated with this File Type

See Also

Working with File Types



Browse

Use this dialog box to select a program file.

Choose one of the following buttons for information about the dialog box:
¥ File Name
k¥ List Files of Type
Pk Directories
¥ Drives
¥ Network Button

See Also

Associating Files with an Application



Create Directory
Creates a directory. This directory becomes a subdirectory of the currently selected directory unless you specify a different path.

The Create Directory dialog box has the following area:

Name

¥ In this box, type the name of the new directory. If you don't want this directory to be in the current directory, include the
path.

See Also

Creating a Directory



Search

Searches for files and directories on all or part of the current drive. You can search for a single file, or you can use wildcards to
search for a group of files.

Choose one of the following buttons for information about the dialog box:
b Search For
¥ Start From
b Search All Subdirectories

See Also

Searching for a File or Directory



Select Files

Selects files and directories in a directory window. You can use this dialog box to quickly select a group of files that you want to
work with. You can also use this dialog box to cancel selections.
The Select Files dialog box has the following area:
File(s)
¥ Type a filename, or use wildcards to specify a group of files you want to select, and then choose the Select button.
Repeat this step as necessary to select more files.

If you want to cancel any of the selections you have made, specify the file or files in the File(s) box, and then choose the
Deselect button.

When you finish making your selections, choose the Close button.
See Also

Selecting Files Using the Select Files Command



Exit
Quits File Manager.

Make sure the Save Settings On Exit command on the Options menu has a check mark next to it if you want to retain the
positions and views of your open directory windows.



Copy Disk
Copies the contents of a floppy disk onto another floppy disk. Use this command to make a backup copy of a floppy disk.
If you have more than one floppy disk drive, the Copy Disk dialog box appears. It has the following areas:

Source In
¥ Select the letter of the drive you want to copy from.

Destination In
b Select the letter of the drive you want to copy to.

See Also

Copying a Floppy Disk



Label Disk
Assigns or changes the volume label for a floppy or hard disk.
The Label Disk dialog box has the following area:

Label
¥ Type the new volume label in this box. The label can contain up to 32 characters on NTFS volumes and up to 11
characters on FAT or HPFS volumes.

See Also

Labeling a Disk



Format Disk

Formats a floppy disk.

Choose one of the following buttons for information about the dialog box:
k Disk In

¥ Capacity
¥ Label

¥ Quick Format

See Also

Formatting a Floppy Disk



Connect Network Drive
Connects to shared directories on the network.

Choose one of the following buttons for information about the dialog box:
¥ Drive
¥ Path
P Connect As
¥ Reconnect at Logon

¥ Expand by Default
¥ Shared Directories

See Also

Connecting to and Disconnecting from a Network Drive



Disconnect Network Drive

Disconnects your computer from a network drive.
¥ Select the shared directories from which you want to disconnect and choose the OK button.

See Also

Connecting to and Disconnecting from a Network Drive



Share As

Shares the selected directory. If the selected directory is already shared, allows you to change share properties or share the
directory again under a different name.

Choose one of the following buttons for more information about the dialog box:
k Share Name
¥ Path
¥ Comment
k User Limit
F Permissions Button
¥ New Share Button

See Also

Sharing a Directory



Shared Directories

Allows you to change share properties or share the directory again under a different name.

Choose one of the following buttons for more information about the dialog box:
¥ Share Name
¥ Path
# Comment
¥ User Limit
¥ Permissions Button
k New Share Button

See Also

Changing Share Properties
Sharing a Directory



New Share

Shares the selected directory.

Choose one of the following buttons for more information about the dialog box:
¥ Share Name
¥ Path
# Comment
¥ User Limit
¥ Permissions Button

See Also

Sharing a Directory



Stop Sharing

Stops sharing directories. The Stop Sharing Directory dialog box displays shared directories you have created as well as
shared directories created by the system. In general, you should not stop sharing directories created by the system, for example
C$ or print$.

Select the shared directories that you want to stop sharing and choose the OK button.

See Also

Stopping Directory Sharing



Select Drive

Changes the drive displayed in the active directory window.
The Select Drive dialog box has the following area:

Drives
Select a drive from this list, and then choose the OK button to change to that drive in the active directory window.

See Also

Changing Disk Drives



Expand One Level

Expands one level of a collapsed directory in a directory tree. When you use this command, the first level of subdirectories in
the selected directory is displayed.

If the selected directory has no subdirectories or is already expanded, this command has no effect.
See Also

Expanding and Collapsing the Directory Tree



Expand Branch

Expands a collapsed directory, including all subdirectories, in a directory tree. When you use this command, all subdirectories of
the selected directory are displayed.

If the selected directory has no subdirectories or is already expanded, this command has no effect.
See Also

Expanding and Collapsing the Directory Tree



Expand All

Expands all the branches in a directory tree. When you use this command, all directories and subdirectories on the disk are

displayed in the directory tree.
See Also

Expanding and Collapsing the Directory Tree



Collapse Branch

Collapses directory levels beneath a selected directory in a directory tree.

When you use this command, the subdirectories of the selected directory are no longer displayed.
If the selected directory is already collapsed, this command has no effect.

See Also

Expanding and Collapsing the Directory Tree



Indicate Expandable Branches

Marks a directory icon with a plus sign (+) if the directory has subdirectories. When you expand a directory, the plus sign
changes to a minus sign (-).

To turn off this feature, choose the Indicate Expandable Branches command again.

Note
b If you use the Indicate Expandable Branches command to mark expandable directories, File Manager may take longer

to create the directory tree.
See Also

Showing Which Directories Expand



Tree and Directory

Displays both the directory tree and the contents of the current directory. This command affects the active directory window only.

See Also

Displaying the Directory Tree or Contents



Tree Only

Displays only the directory tree; the contents of the current directory are not displayed. This command affects the active
directory window only.

See Also

Displaying the Directory Tree or Contents



Directory Only

Displays only the contents of the current directory; the directory tree is not displayed. This command affects the active directory
window only.

See Also

Displaying the Directory Tree or Contents



Split
Splits a directory window. If the window is already split, this command moves the split bar to the left or right.

When you choose this command, a vertical bar appears in the window. Use the mouse or the arrow keys to move the bar, and
then either click the bar or press ENTER. You can press ESC to cancel the command.

See Also

Displaying the Directory Tree or Contents



Name
Displays only the names of files and directories in the active directory window.
See Also

Displaying Information on Files



All File Details

Displays all available information about files and directories in the active directory window.

This information includes the name, size, last modification date and time, and attributes of each file and directory.
See Also

Displaying Information on Files
Setting File Attributes



Partial Details

Displays specific file and directory information in the active directory window.

Choose one of the following buttons for more information about the dialog box:
b Size
¥ Last Modification Date
b Last Modification Time
k File Attributes
k MS-DOS File Names

See Also

Displaying Information on Files
Setting File Attributes



Sort by Name

Sorts files and directories alphabetically by name. Directories are listed first, then files. This command affects the contents list in
the active directory window only.

See Also

Sorting the Contents of a Directory



Sort by Type

Sorts files and directories alphabetically by extension. Directories are listed first, then files.
This command affects the contents list in the active directory window only.

See Also

Sorting the Contents of a Directory



Sort by Size

Sorts files by size, from largest to smallest.

This command affects the contents list in the active directory window only.
See Also

Sorting the Contents of a Directory



Sort by Date

Sorts files by last modification date, with the most recently modified files listed first.
This command affects the contents list in the active directory window only.

See Also

Sorting the Contents of a Directory



By File Type
Displays a group of files that you specify. This command affects the contents list in the active directory window only.

Choose one of the following buttons for more information about the dialog box:
F Name

¥ File Type
F Show Hidden/System Files

See Also

Limiting the Files to Display



Confirmation

Specifies whether confirmation messages are displayed.

Choose one of the following buttons for more information about the dialog box:
¥ File Delete
¥ Directory Delete
b File Replace
¥ Mouse Action
¥ Disk Commands
Pk Modifying System, Hidden, Read Only Files

See Also

Turning Off Confirmation Messages



Font

Changes the font in File Manager. The Font command affects all directory windows.

Choose one of the following buttons for more information about the dialog box:
¥ Font
¥ Font Style
k Size
¥ Sample
¥ Display Lowercase for FAT Drives
¥ Display Lowercase for All Drives

See Also

Changing the Font in File Manager



Customize Toolbar

Adds and removes buttons from the toolbar.

The dialog box also shows which command a button performs. Buttons currently displayed on the toolbar appear in the Toolbar
Buttons box. Buttons you can add to the toolbar appear in the Available Buttons box.

Choose one of the following buttons for more information about the dialog box:
# Add Button
k Remove Button
F Reset Button

¥ Move Up Button
F Move Down Button
See Also

Customizing the Toolbar



Toolbar

Displays the toolbar at the top of the File Manager window.

The toolbar provides quick access to frequently used File Manager commands.



Drivebar

Displays the drivebar at the top of the File Manager window.

The drivebar provides quick access to local and network drives.



Status Bar

Displays the status bar at the bottom of the File Manager window.

The status bar shows information about the current disk and directory.



Open New Window on Connect

Specifies whether a shared directory is displayed in a new window when you connect to it.



Minimize on Use

Reduces File Manager to an icon whenever you start an application.



Save Settings on Exit

Saves positions and views of open directory windows when you quit File Manager. When you restart File Manager, the open
directory windows are in the same positions and have the same View menu settings as when you last quit File Manager.



New Window

Opens a new directory window. The window displays the same drive and directory information as the directory window that was
active before you used this command.

See Also

Opening and Closing Directory Windows



Cascade

Arranges directory windows so that they overlap.

The title bar of each window remains visible, making it easy for you to select any window.
See Also

Selecting and Arranging Directory Windows and Icons



Tile Horizontally
Arranges directory windows without overlap so that each window is wider than it is long.
See Also

Selecting and Arranging Directory Windows and lcons



Tile Vertically
Arranges directory windows without overlap so that each window is longer than it is wide.
See Also

Selecting and Arranging Directory Windows and lcons



Arrange Icons
Arranges icons (reduced directory windows) so that they line up neatly and do not overlap.
See Also

Selecting and Arranging Directory Windows and lcons



Refresh

Updates the active directory window. You may want to update a directory window if you've switched floppy disks or if you've
connected to a network drive outside of File Manager.

See Also

Opening and Closing Directory Windows



Names of Open Windows

To make a directory window active, select its name from this list.

All directory windows are listed, even those that have been reduced to icons.

If there are more than 9 windows, choose More Windows to display the complete list of windows in the Select Window dialog
box.

See Also

Selecting and Arranging Directory Windows and lcons



Owner

Displays the owner of the selected file or directory.
¥ To take ownership of the file or directory, choose the Take Ownership button.

See Also

Taking Ownership of Files or Directories



Add Users and Groups

Use the Add Users And Groups dialog box to add a group or user to the permission list for a file or directory.

Choose one of the following buttons for information about the dialog box:
F List Names From
F Names
¥ Add Button
¥ Show Users Button
F Members Button
F Search Button
¥ Add Names

¥ Type of Access

See Also

Adding Users and Groups to Permissions and Auditing Lists



Local Group Membership

Displays the members of the local group selected in the Add Users And Groups dialog box.
¥ To include the group in the Add Names box in the Add Users And Groups dialog box, choose the Add button.
b To include some of the listed members in the Add Names box in the Add Users And Groups dialog box, select them and
choose the Add button.

On a Windows NT Server network, global groups that are members of a local group appear in the list.
¥ To see a global group's members, select the group and choose the Members button.

See Also

Adding Users and Groups to Permissions and Auditing Lists



Global Group Membership

Displays the members of the global group selected in the Add Users And Groups dialog box or in the Local Group

Membership dialog box.
¥ To include the group in the Add Names box in the Add Users And Groups dialog box, choose the Add button.
b To include some of the listed members in the Add Names box in the Add Users And Groups dialog box, select them and
choose the Add button.

See Also

Adding Users and Groups to Permissions and Auditing Lists



Find Account

When you add a user or group to the permissions or audit list, you must know the name of the domain that contains the user or
group's account. Use the Find Account dialog box to locate the domain of an account on a Windows NT Server network.

Choose one of the following buttons for information about the dialog box:

Pk Find User or Group
¥ Search All

¥ Search Only In

k Search Button

¥ Add Button
See Also

Adding Users and Groups to Permissions and Auditing Lists



File Permissions
Use the File Permissions dialog box to set or change permission for groups and users.

Choose one of the following buttons for information about the dialog box:
b File
F Owner
F Name
¥ Type of Access
¥ Add Button
# Remove Button

See Also

Setting File Permissions
File Access Permissions

Adding Users and Groups to Permissions and Auditing Lists



Directory Permissions
Use the Directory Permissions dialog box to set or change permission for groups and users.

Choose one of the following buttons for information about the dialog box:
¥ Directory
¥ Owner
F Replace Permissions on Subdirectories
¥ Replace Permissions on Existing Files
F Name
¥ Type of Access
¥ Add Button
F Remove Button

See Also

Setting Directory Permissions
Directory Access Permissions
Adding Users and Groups to Permissions and Auditing Lists



File or Directory Permissions

Sets file or directory permissions. When a file is selected, displays the File Permissions dialog box. When a directory is
selected, displays the Directory Permissions dialog box.

See Also

Directory Permissions
File Permissions



Special Access File Permissions

Use the Special Access dialog box to set special access permission for a group or user.

Choose one of the following buttons for information about the dialog box:
¥ File
¥ Name

¥ Full Control (All)
¥ Other

See Also

Setting Special Access Permissions
Special Access File Permissions



Special Directory Access

Use the Special Directory Access dialog box to set special access permission for a group or user.

Choose one of the following buttons for information about the dialog box:
¥ Directory
¥ Name

¥ Full Control (All)
¥ Other

See Also

Setting Special Access Permissions
Special Access Directory Permissions



Special File Access

Use the Special File Access dialog box to set special access permissions for a group or user.

Choose one of the following buttons for information about the dialog box:
¥ Directory
¥ Name
k Access Not Specified

¥ Full Control (All)
¥ Other

See Also

Setting Special Access Permissions
Special Access File Permissions



File Auditing

Use the File Auditing dialog box to audit the use of a file by groups and users. Choose one of the following buttons for

information about the dialog box:
k File
F Name
Pk Events to Audit
¥ Add Button
# Remove Button

See Also

Auditing Files and Directories
Audited File Events

Adding Users and Groups to Permissions and Auditing Lists



Directory Auditing

Use the Directory Auditing dialog box to audit the use of a directory by groups and users. Choose one of the following buttons

for information about the dialog box:
¥ Directory
k Replace Auditing on Subdirectories
k Replace Auditing on Existing Files
¥ Name
¥ Events to Audit
k Add Button
¥ Remove Button

See Also

Auditing Files and Directories
Audited Directory Events
Adding Users and Groups to Permissions and Auditing Lists



Add Users and Groups

Use the Add Users And Groups dialog box to add a group or user to the auditing list for a file or directory.

Choose one of the following buttons for information about the dialog box:
F List Names From
F Names
¥ Add Button
¥ Show Users Button
F Members Button
F Search Button
¥ Names

See Also

Adding Users and Groups to Permissions and Auditing Lists



Add

Use the Add dialog box to add a group or user to the permission list for a file or directory.

Choose one of the following buttons for information about the dialog box:

¥ File or Directory
¥ Name

¥ Type of Access




File Permissions [LAN Manager 2.x]

Use the File Permissions dialog box to set or change permission for groups and users.

Choose one of the following buttons for information about the dialog box:
b File
¥ Name
b Type of Access
¥ Add Button
F Remove Button




Directory Permissions [LAN Manager 2.x]

Use the Directory Permissions dialog box to set or change permission for groups and users.

Choose one of the following buttons for information about the dialog box:
¥ Directory
¥ Replace Permissions on Files/Subdirectories
¥ Name
¥ Type of Access
¥ Add Button
¥ Remove Button




Special Access

Use the Special Access dialog box to set special access permission for a group or user.

Choose one of the following buttons for information about the dialog box:
b File
¥ Name
P Permissions



Special Directory Access

Use the Special Access dialog box to set special access permission for a group or user.

Choose one of the following buttons for information about the dialog box:
¥ Directory
¥ Name
P Permissions



File Auditing [LAN Manager 2.x]

Use the File Auditing dialog box to audit the use of a file. Choose one of the following buttons for information about the dialog
box:

k File

k Events to Audit



Directory Auditing [LAN Manager 2.x]

Use the Directory Auditing dialog box to audit the use of a file. Choose one of the following buttons for information about the
dialog box:

¥ Directory
} Replace Auditing on Files/Subdirectories

k Events to Audit




Contents

Starts Help and displays the topics in File Manager Help.



Search for Help on

Opens the Search dialog box for File Manager Help. Using the Search dialog box, you can look up Help information by using
keywords.



How to Use Help

Describes how to use Help.



About File Manager

Displays version, mode, and copyright information about Windows NT.



Control Menu

The Control menu contains the following commands:

Restore

Restores the window to its former size after it has been maximized or minimized.
Move

Enables you to use the keyboard to move the window to another position.
Size

Enables you to use the keyboard to change the size of the window.
Minimize

Reduces the window to an icon.

Maximize

Enlarges the window to its maximum size.

Close

Quits an application, or closes a window or dialog box.

Next

Switches to the next window or icon.



Control Menu

The Control menu contains the following commands:

Restore

Restores the window to its former size after it has been maximized or minimized.
Move

Enables you to use the keyboard to move the window to another position.
Size

Enables you to use the keyboard to change the size of the window.
Minimize

Reduces the window to an icon.

Maximize

Enlarges the window to its maximum size.

Close

Quits an application, or closes a window or dialog box.

Switch To

Starts Task List, which you can use to switch between running applications and to rearrange their windows and icons.



From

This box shows the currently selected file or directory.

b To copy a different file or directory, type its name in this box. If the file is not in the current directory (listed at the top of the
dialog box), include the path.



To
b Type the path of the directory that you want to copy the file or directory to.
If you are copying a file to the current directory (listed at the top of the dialog box), you do not need to fill in the To box.



From

This box shows the currently selected file or directory.
b To move a different file or directory, type its name in this box. If the file is not in the current directory (listed at the top of the
dialog box), include the path.



To

b Type the name of the destination directory in this box. If the directory is not a subdirectory of the current directory, include
the path.

If you are moving a file to the current directory (listed at the top of the dialog box), you do not need to fill in the To box.
To rename the file when you move it, type the new name in the To box.



From

This box shows the currently selected file or directory.
b To rename a different file or directory, type its name in this box. If the file is not in the current directory, include the path. If
you want to rename a group of files, use wildcards; for example, *.TXT.



To

b Type the new name of the file or directory (the new name must not already exist in the directory). If the file or directory is
not in the current directory, include the path. However, you cannot specify a different directory to move the file to. If you are
renaming a group of files, use wildcards, for example, *. TXT.



Read Only
b Select this check box if you want to prevent a file from being changed.



Archive
b Select this check box if you want to mark a file that has changed since it was last backed up.
You may want to set the archive attribute if you use the Windows NT backup or restore command.



Hidden
b Select this check box if you don't want a particular file to appear in a directory window.

If you want to display a file that has the hidden attribute set, you can choose By File Type from the View menu and then select
the Show Hidden/System Files check box.



Compressed
b Select this check box if you want to compress a file.

After compressing directories or subdirectories, the files you add to the directory or subdirectory are compressed automatically.
On an NTFS patrtition, if a file is copied from one directory to another, the compression attribute of the file is changed to that of
the target directory. Files moved or copied from another file system to NTFS always inherit the compression attribute of the
target directory.



System
b Select this check box if you want to identify a file as a system file.

When you select this check box, the file does not appear in directory listings. If you want the file to appear in a directory window
in File Manager, you can choose By File Type from the View menu and then select the Show Hidden/System Files check box.



Version Information

Shows version information for files.
b Select the subject in the left box to display the information on the subject in the right box.



Open By

Shows who is using shared files and stops the use of the highlighted file or files. This button can only be used by members of the
Administrators, Server Operators, and Power Users groups.



Files with Extension

This box displays the filename extension of the selected file.
b To associate a file that has a different extension, type the extension in this box.



Associate With

b From the Associate With list, select the file type and program that you want to associate with the extension shown in the
Files With Extension box.

If the application you want to associate is not shown in the Associate With list, type the program filename including its extension
in the Associate With box. You can use the Browse button to search for a program file.

To cancel an association, select (None) in the Associate With list.



Browse Button
b Choose the Browse button to search for a program file.



New Type Button
b Choose this button to create a new file type that you can associate with a file extension.



Change Type Button

b Choose this button to edit the file type selected in the Associate With list. You can also add and delete associations when
you edit a file type.



Delete Type Button
b Choose this button to delete the file type selected in the Associate With list.



File Type
b Type a name for the file type.



File Type
b To change the name of the file type, type another name in the File Type box.



Action
b Choose the action, Open or Print, which executes the command in the Command box and the DDE options you specify.



Action
b Choose the action, Open or Print, whose command you want to change.



Command

Specifies the command for the action selected in the Action box.
¥ Type the name of the program file, including its extension, and any parameters. In commands, %1 represents the
filename of the file currently selected in File Manager. If the application supports DDE, specify the name of the program file in the
Command box and use the options in the DDE area to specify the DDE commands.
If the program is a Windows 3.1 application and you want it to run in a separate memory space from other Windows 3.1
applications, use the cmd /c start Iseparate c:\apppath\appname.exe syntax in the Command box (instead of just typing c:
\apppath\appname.exe).



Command

You can change the commands for the file type. In commands, %1 represents the filename of the file currently selected in File
Manager. If the application supports dynamic data exchange (DDE), specify the name of the program file in the Command box
and use the options in the DDE area to specify the DDE commands.
¥ To change the command for an action, choose the action in the Action box, and then edit the command in the Command
box.
If the application is a Windows 3.1 application and you want it to run in a separate memory space from other Windows 3.1
applications, use the cmd /c start Iseparate c:\apppath\appname.exe syntax in the Command box (instead of just typing c:
\apppath\appname.exe).



Browse Button
b Choose this button to open a dialog box you can use to select a program file to use as a command.



Uses DDE

Specifies that the application uses DDE commands to perform the action.



DDE Message

Specifies the DDE command to use if the application is already running.



DDE Message Application Not Running

Specifies the DDE command to use if the application is not running.



Application

Specifies the DDE application string used to initiate a DDE conversation with the application specified in the Command box.



Topic

Specifies the DDE topic string used to initiate a DDE conversation with the application specified in the Command box.



Extensions Associated with this File Type

Use options in the Extensions Associated With This File Type area to add extensions to or remove extensions from the list of

extensions associated with the file type shown in the File Type box.
To add an extension, type the extension in the New Extension box and choose the Add button.
To remove an extension, select it in the Extensions box and choose the Remove button.



File Name
b Select a filename, and then choose the OK button.

Or type a filename in this box, and then choose the OK button. If the file is not in the current directory, include the path.

If the program file you want is not in the File Name list, you may have to change directories by choosing a directory in the
Directories list.



List Files of Type
b Open the list, and then select the type of file you want to appear in the File Name box.



Directories

b Select the directory that contains the program file you want to use. The names of the files in that directory will appear in
the File Name box.

If the directory you want is not in the list, you may have to change drives by opening the Drives list and selecting a drive.



Drives

b Open the list, and then select the drive that contains the program file you want. The directories on that drive will appear in
the Directories box.



Network Button

Displays a dialog box that allows you to connect to shared directories on the network.



Search For

This box lists the extension of the currently selected file.
b To search for a different file, type its name in this box. Use wildcards to specify a group of files, for example, *. TXT.



Start From

This box displays the current directory.
b To start the search from a different directory, type its name in this box.



Search All Subdirectories
b Select this check box if you want to search all subdirectories of the directory listed in the Start From box.



Disk In
b Select the drive in which you want to format the floppy disk.



Capacity
b The capacity of your floppy disk drive is displayed in this box. If you are formatting a disk that has a capacity different from
your drive, open the list and select a capacity.



Label

b You can specify a volume label in this box. Labels for NTFS drives can contain up to 32 characters. Labels for FAT or
HPFS drives can contain up to 11 characters.



Quick Format
b Select this check box if you want to perform a quick format on a previously formatted disk. Use this option only for a disk
that doesn't have errors (bad sectors).

Note

: When you perform a quick format, the file allocation table and root directory of the disk are deleted, but the disk is not scanned
for bad sectors.



Drive

Lists available drive letters and displays the network path for each connected drive.
¥ By default, the first available drive letter for the connection is displayed in the Drive box. You can select another drive
letter. To connect without specifying a drive letter, select the (none) option.



Path

Specifies the network path for the connection. A network path consists of a computer name followed by the name of a shared

directory, for example \SHEPHERD\PUBLIC.
¥ You can:
F Select a previous network path from the Path box.
Pk Select a new network path from the Shared Directories list.
¥ Type the name of a computer and shared directory in the Path box.



Connect As
By default, you are connected under the username you used to log on.
¥ To connect under a username other than your logon name, type the username in the Connect As box.

On a Microsoft Windows-based network, you can connect using an account on a different domain by specifying the domain
and the username for the account. Separate the domain name from the username with a backslash, for example
PROJECTS\CHRISBR.



Reconnect at Logon

Allows you to connect to the shared directory automatically each time you log on.
¥ Select the check box to reconnect automatically. Clear the check box if you do not want to reconnect each time you log
on.

Connections made using the (none) option are not reconnected when you log on.



Shared Directories

Displays networks, domains and workgroups, computers, and shared directories organized in a tree structure.
¥ Double-click an item to expand the list. Selecting a shared directory places it in the Path box.



Expand by Default

By default, the list in the Shared Directories box expands to display the computers in your computer's domain or workgroup.
You may want to switch this off if you are connecting over a slow network; for example, connecting through Remote Access

Service.
To stop automatic expansion of the Shared Directories list, clear the Expand By Default check box.



Share Name

Shows the name users specify to connect to the shared directory. In order for MS-DOS computers to connect, the name must

conform to the MS-DOS 8.3 naming convention. On Windows NT networks, the name can be up to 12 characters long.
¥ By default, the name is the name of the selected directory. You can type a different name in the Share Name box.



Share Name

Shows the name users specify to connect to the shared directory. You cannot change the share name of a shared directory;

however, you can share the directory again under a different name.
¥ If the directory has been shared more than once, you can select the share name of the share whose properties you want
to change.



Path

Shows the path and name of the selected directory.
¥ By default, the path is the path of the selected directory. To share a different directory, type the directory's path and name.



Path

Shows the path and name of the selected shared directory.



Comment

The optional comment is displayed with the share name in the Connect Network Drive dialog box.
¥ Type a comment describing the shared directory.



Comment

Shows the comment for the currently selected share.
¥ To change the comment, type the changes in the Comment box.



User Limit

Sets the maximum number of users who can connect to the shared directory at one time. By default, no limit is set (though there

may be a limit on how many users can connect to this computer overall).
¥ To set a limit, choose the Allow button and set a limit in the Users box.



User Limit

Shows the user limit for the currently selected share.
¥ To set a limit, choose the Allow button and set a limit in the Users box.
b To remove the limit, choose the Maximum Allowed button.



Permissions Button

You can control access to a shared directory by setting permissions on it.
¥ To secure the directory, choose the Permissions button.



Permissions Button

Shows the permissions set on the currently selected share.
¥ To change the permissions set on the share, choose the Permissions button.



New Share Button

The New Share button appears only when the directory you have selected has already been shared.
¥ To share the directory under another share name, choose the New Share button.



New Share Button
b To share the directory under another share name, choose the New Share button.



Size
Select this option to display the size, in bytes, of every file.



Last Modification Date
b Select this option to display the date that a file was last changed, according to the system clock.



Last Modification Time
b Select this option to display the time of day that a file was last changed, according to the system clock.



File Attributes

b Select this option to display file attributes. The five types of attributes are hidden, read only, archive, system, and
compress.



MS-DOS File Names
b Select this option to display short, MS-DOS-style names for files and directories created with long filenames.



Name

b To display all files with similar names or extensions, use wildcards in the Name box. For example, to display only those
files that have the extension .TXT, type *.txt. When the default (*.*) is specified, all files are displayed.



File Type

Use these check boxes to specify which types of files to display.

Select
Directories

Programs

Documents

Other Files

To display
All directories in the current
directory.

All files that have
an .EXE, .COM, .PIF, or .BAT
extension.

All files that are associated
with an application.

All other files.

Show Hidden/System Files
¥ Select this check box to display hidden and system files in a directory window.



File Delete
b Clear this check box if you don't want to receive a confirmation message before deleting files.



Directory Delete

b Clear this check box if you don't want to receive a confirmation message before deleting a directory. When you delete a
directory, all the files and directories within it are deleted.



File Replace
b Clear this check box if you don't want to receive a confirmation message before replacing a file.

Note
It is recommended that you leave this option selected so that you don't inadvertently write over files you want to keep.



Mouse Action

b Clear this check box if you don't want to receive a confirmation message before moving or copying files by dragging them
with a mouse.



Disk Commands

b Clear this check box if you don't want to receive a confirmation message when you use disk commands, such as Format
Disk and Copy Disk.



Modifying System, Hidden, Read Only Files

b Clear this check box if you don't want to receive a confirmation message before deleting, replacing, or moving system,
hidden, and read-only files.



Font
b Select a font from the list.
The Sample box displays the font. You can also use this dialog box to change the size and style of the font.



Font Style
b Select a style for the font.
The Sample box displays the font style. You can also use this dialog box to change the type of font and its size.



Size
b Select a point size from the list: the larger the point size, the larger the character displayed on your screen.
The Sample box displays the font size. You can also use this dialog box to change the font and the font style.



Sample

This box shows what the currently selected font, style, and size would look like in your directory windows.



Display Lowercase for FAT Drives

b Select this option to display filenames on FAT drives in lowercase characters.
¥ Clear this option to display filenames on FAT drives in uppercase characters.



Display Lowercase for All Drives
b Select this option to display filenames on all drives in lowercase characters.



Add Button

b To add a button to the toolbar, select it in the Available Buttons box and choose the Add button.
¥ To add a space between buttons to the toolbar, select Separator in the Available Buttons box and choose the Add
button.



Remove Button

b To remove a button from the toolbar, select the button in the Toolbar Buttons box and choose the Remove button.
¥ To remove a space separating buttons from the toolbar, select the Separator in the Toolbar Buttons box and choose the
Remove button.



Reset Button
b To reset the toolbar to the default buttons and order, choose the Reset button.



Move Up Button

b To move a button or separator to the left on the toolbar, select it in the Toolbar Buttons box and choose the Move Up
button.



Move Down Button

b To move a button or separator to the right on the toolbar, select it in the Toolbar Buttons box and choose the Move
Down button.



List Names From

Displays the name of the domain or computer whose groups are shown in the Names box. An asterisk (*) following the name

indicates that local groups for that domain or computer are shown.
¥ To display groups and users in another domain or on the computer, select another domain or select the computer.



Names

Displays the groups or users belonging to the current domain or computer.
¥ To add groups or users to the permissions list, select them in the Names box and choose the Add button.



Names

Displays the groups or users belonging to the current domain or computer.
¥ To add groups and users to the auditing list, select them in the Names box and choose the Add button.



Add Button
b To add groups or users to the audit list, select them in the Names box and choose the Add button.



Members Button
b To see a group's content, select the group in the Names box and choose the Members button.



Search Button

To add a group or user, you must know the domain that contains the account for the group or user.
¥ To find the domain to which a group or user belongs, choose the Search button.



Add Names

Displays the hames of groups and users who you are adding to the audit list.
¥ To add groups or users to the Add Names box, select them in the Names box and choose the Add button.
b Or type the names of groups and users in the Add Names box. Separate names with a semicolon. If the account of the
group or user is not located on the computer or domain shown by the List Names From box, specify the location. Type the
computer or domain name followed by the group or user name and separate the names with a backslash.



Name

Displays the groups and users on the current server.
¥ To set a permission, select the group or user, and select a permission from the Type Of Access box. Then choose the OK
button.



Add Button
b To add groups or users to the permissions list, select them in the Names box and choose the Add button.



Show Users Button

b To display the names of users belonging to the current domain or computer in the Names box, choose the Show Users
button.



Members Button
b To see a group's content, select the group in the Names box and choose the Members button.



Search Button

To add a group or user, you must know the domain that contains the account for the group or user.
¥ To find the domain to which a group or user belongs, choose the Search button.



Add Names

Displays the nhames of groups and users who you are adding to the permissions list.
¥ To add groups or users to the Add Names box, select them in the Names box and choose the Add button.
b Or type the names of groups and users in the Add Names box. Separate names with a semicolon. If the account of the
group or user is not located on the computer or domain shown by the List Names From box, specify the location. Type the
computer or domain name followed by the group or user name and separate the names with a backslash.



Type of Access

Displays a list of available permissions.
¥ To set a permission for the groups and users listed in the Add Names box, select a permission. Then choose the OK
button.



Type of Access

Displays a list of available permissions.
¥ To set a permission, select the group or user from the Name box and select a permission. Then choose the OK button.



File

Displays the path and name of the selected file.



Directory

Displays the name of the selected directory.



Access Through Share

Displays the name of the shared directory through which access to files and directories is controlled.



File or Directory

Displays the name of the selected file or directory.



Owner

Displays the name of the owner of the file.



Owner

Displays the name of the owner of the directory.



Owner

The name of the owner of a shared directory is not displayed. Ownership of a shared directory does not affect who can set
permissions.



Replace Permissions on Subdirectories

By default, permissions you set apply only to the directory and its files.
¥ Select the check box to apply permissions to all subdirectories. If the Replace Permissions on Existing Files check
box is selected, permissions are changed on the files in subdirectories as well.



Replace Permissions on Existing Files

By default, permissions you set apply to files in the directory as well as to the directory itself.
¥ Clear the check box to apply permissions to the directory only. If the Replace Permissions on Subdirectories check
box is selected, permissions are changed on subdirectories as well.



Replace Permissions on Files/Subdirectories

Normally, permissions you set apply to the directory itself and to files that currently have no permissions set on them.
¥ Select the check box to apply permissions to all existing files and subdirectories.



Name

Displays the nhames of groups and users and their current permissions.
¥ To change a permission, select the group or user and select a permission from the Type Of Access box.



Type of Access

Displays a list of available permissions.
¥ To change a permission, select the group or user from the Name box and select a permission.



Type of Access

Displays a list of available permissions.
¥ To change a permission, select the group or user from the Name box and select a permission.



Type of Access

Displays a list of available permissions.
¥ To change a permission, select the group or user from the Name box and select a permission.



Type of Access

Displays a list of available permissions.
¥ To change a permission, select the group or user from the Name box and select a permission.



Type of Access

Displays a list of available permissions.
¥ To change a permission, select the group or user from the Name box and select a permission.



Type of Access

Displays a list of available permissions.
¥ To set a permission, select the group or user from the Name box and select a permission. Then choose the OK button.



Add Button
b To add groups or users to the permission list, choose the Add button.



Remove Button
b To remove a group or user from the permission list, select the group or user, and then choose the Remove button.



Find User or Group
b In the Find User Or Group box, type the name of the group or user whose account you want to find.



Search All
b To search for the account in all the listed domains, select the Search All button.



Search Only In
b To search for the account in one or more domains, select them in the Search Only In box.



Search Button
b After specifying a group or user and the domains to search, choose the Search button to start the search.



Add Button

b To add the user or group to the Add Names box in the Add Users And Groups dialog box, select the user or group in the
Search Results box and then choose the Add button.



File

Displays the path and name of the selected file.



Directory

Displays the name of the selected directory.



Share

Displays the share name of the selected share.



Name

Displays the nhame of the selected group or user.



Access Not Specified
b Select the Access Not Specified button to prevent files from inheriting permissions from the directory.



Full Control (All)
b Select Full Control (All) to grant the selected group or user Full Control of the file.



Full Control (All)
b Select Full Control (All) to grant the selected group or user Full Control of the directory.



Other
b Select the check boxes for the access you want to grant.



Other
b Select the check boxes for the access you want to grant.



Permissions
b Select the check boxes for the access you want to grant.



Permissions
b Select the check boxes for the access you want to grant.



Name

Displays the names of currently audited groups and users.



Replace Auditing on Subdirectories

By default, auditing changes apply only to the directory and its files.
¥ Select the check box to apply auditing to all subdirectories. If the Replace Auditing on Existing Files check box is
selected, auditing changes apply to the files in subdirectories as well.



Replace Auditing on Existing Files

By default, auditing changes apply to files in the directory as well as to the directory itself.
¥ Clear the check box to apply auditing changes to the directory only. If the Replace Auditing on Subdirectories check
box is selected, auditing changes apply to subdirectories as well.



Replace Auditing on Files/Subdirectories

Events you specify for auditing are audited for the directory itself and for files that are currently not audited.
¥ Select the check box to apply auditing to all existing files and subdirectories whether or not they are currently audited.



Events to Audit

For a particular file, you can audit events that succeed and those that fail.
¥ Select a group or user, and then select the events you want to audit for the file by selecting the appropriate check boxes.



Events to Audit

For a particular directory, you can audit events that succeed and those that fail.
¥ Select a group or user, and then select the events you want to audit for the directory by selecting the appropriate check
boxes.



Events to Audit

You can audit events that succeed and those that fail.
¥ Select the events you want to audit by selecting the appropriate check boxes.



Add Button
b To add groups or users to the auditing list, choose the Add button.



Remove Button
b To remove a group or user from the auditing list, select the group or user, and then choose the Remove button.



Enter Network Password

You must supply a password to connect to the shared directory.
¥ Type your password in the Password box and choose the OK button.



Restoring Network Connections

For the reason shown in the Restoring Network Connections dialog box, a network connection has not been restored.
¥ If you no longer want to restore this connection automatically, choose the Do Not Try To Restore The Connection In
The Future check box.



Warning -- Users are Connected

There are users connected to the directory you want to stop sharing. If you stop sharing the directory, those users will not be
able to save changes to the files they are working on. To be certain that users do not lose data, you should ask each user to
disconnect from the shared directory before you stop sharing it.

The dialog box shows the name of each user who is connected to the directory, the number of files each has open, and how long
each has been connected.

To stop sharing the directory, choose the OK button.

To continue sharing the directory, choose the Cancel button.



Access Through Share Permissions
Use the Access Through Share Permissions dialog box to set or change permissions for groups and users.

Choose one of the following buttons for information about the dialog box:
¥ Access Through Share
¥ Owner
F Name
¥ Type of Access
¥ Add Button
# Remove Button

See Also

Setting Permissions Through Shared Directories
Shared Directory Permissions
Adding Users and Groups to Permissions and Auditing Lists



Share Permissions (LAN Manager 2.x)

Use the Share Permissions dialog to set access and a password for a directory on a LAN Manager 2.x server with share-level
security.

Choose one of the following buttons for information about the dialog box:
k Access Type - Read Only
F Access Type - Change
k Access Type - Other
k Password




Add Users And Groups

Use the Add Users And Groups dialog box to add a group or user to the permission list for the share.

Choose one of the following buttons for information about the dialog box:
F List Names From
F Names
¥ Add Button
¥ Show Users Button
F Members Button
F Search Button
¥ Add Names

¥ Type of Access

See Also

Adding Users and Groups to Permissions and Auditing Lists



Share Properties

Use the Share Properties dialog box to change properties for a shared directory.

Choose one of the following buttons for information about the dialog box:
¥ Share Name
¥ Path
# Comment
¥ User Limit
¥ Permissions Button




New Share

Shares the selected directory.

Choose one of the following buttons for more information about the dialog box:
¥ Share Name
¥ Path
# Comment
¥ User Limit
¥ Permissions Button




Shared Directories

Allows you to create a new share, change share properties for a shared directory, or stop sharing a directory.

Choose one of the following buttons for more information about the dialog box:
¥ Shared Directories on
¥ New Share Button

¥ Properties Button
¥ Stop Sharing Button




Enter Password (LAN Manager 2.x)

To perform administrative tasks on the server, you must supply a password.
¥ To connect to the server, type the password in the Password box and choose the OK button.



Access Type -- Read Only
b To allow users to only read files and execute programs, select Read Only.



Access Type -- Change

b To allow users to read files, execute programs, change files, create and delete files and subdirectories, and set attributes;
select Change.



Access Type -- Other

b To specify access using individual permissions, type the abbreviation for each permission in the Other box. R (read), W
(write), X (execute), D (delete), C (create), A (set attributes), and P (set permissions).



Password
b To set a password that protects the directory, type the password in the Password box.



Share Name

Shows the share name of the selected shared directory.



Path

Shows the directory path for the currently selected share. By changing the path, you can change the directory you are sharing

under the current share name.
¥ To change the path, type the new path in the Path box.



Comment

Shows the comment for the currently selected share.
¥ To change the comment, type the changes in the Comment box.



User Limit

Shows the user limit for the currently selected share.
¥ To set a limit, choose the Allow button and set a limit in the Users box.
b To remove the limit, choose the Maximum Allowed button.



Permissions Button

Shows the permissions set on the currently selected share.
¥ To change the permissions set on the share, choose the Permissions button.



Share Name

The share name is the name users specify to connect to the shared directory. In order for MS-DOS computers to connect, the

name must conform to the MS-DOS 8.3 naming convention. On Windows NT networks, the name can be 12 characters long.
¥ Type a share name for the shared directory in the Share Name box.



Path
Type the path and name of the directory you want to share in the Path box.



Comment

The optional comment is displayed with the share name in the Connect Network Drive dialog box.
¥ Type a comment describing the shared directory in the Comment box.



User Limit

Sets the maximum number of users who can connect to the shared directory at one time. By default, no limit is set (though there

may be a limit on how many users can connect to this computer overall).
¥ To set a limit, choose the Allow button and set a limit in the Users box.



Permissions Button

You can control access to a shared directory by setting permissions for groups and users on it.
¥ To secure the directory, choose the Permissions button.



Shared Directories on

Displays the shared directories on the selected computer.



New Share Button

Allows you to share a directory. Selecting an administrative share on the computer before choosing the New Share button allows
you to share any directory on that drive. For example, selecting C$ allows you to share directories on the C: drive.



Properties Button
b Select the shared directory whose properties you want to change, and choose the Properties button.

You can change the following properties for the selected share:
The directory that is shared under that share name.
The comment displayed with the share name.
The number of users allowed to connect to the share at one time.
Permissions controlling access to the share.
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Stop Sharing Button
b Select the shared directory that you want to stop sharing and choose the Stop Sharing button.



No Access (None)(None)

Prevents any access to the directory and its files. Specifying No Access for a user prevents access even if that user belongs to
a group that has access to the directory.



List (RX)(Not Specified)

Allows:
¥ Viewing filenames and subdirectory names.
b Changing to the directory's subdirectories.

Does not allow:
¥ Access to files, unless granted by other directory or file permissions.



Read (RX)(RX)

Allows:
¥ Viewing filenames and subdirectory names.
b Changing to the directory's subdirectories.
¥ Viewing data in files and running applications.



Add (WX)(Not Specified)

Allows:
¥ Adding files and subdirectories to the directory.

Does not allow:
¥ Access to files, unless granted by other directory or file permissions.
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Add & Read (RWX)(RX)

Allows:

Viewing filenames and subdirectory names.
Changing to the directory's subdirectories.
Viewing data in files and running application files.
Adding files and subdirectories to the directory.
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Change (RWXD)(RWXD)

Allows:
Viewing filenames and subdirectory names.
Changing to the directory's subdirectories.
Viewing data in files and running application files.
Adding files and subdirectories to the directory.
Changing data in files.
Deleting the directory and its files.
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Full Control (All)(All)

Allows:
Viewing filenames and subdirectory names.
Changing to the directory's subdirectories.
Viewing data in files and running application files.
Adding files and subdirectories to the directory.
Changing data in files.
Deleting the directory and its files.
Changing permissions on the directory and its files.
Taking ownership of the directory and its files.



No Access (None)

Prevents any access to the file. Specifying No Access for a user prevents access even if that user belongs to a group that has
access to the file.



Read (RX)

Allows:
¥ Viewing the file's data.
b Running the file if it is a program file.
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Change (RWXD)

Allows:

Viewing the file's data.

Running the file if it is a program file.
Changing data in the file.

Deleting the file.
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Full Control (All)

Allows:
Viewing the file's data.
Running the file if it is a program file.
Changing data in the file.
Deleting the file.
Changing permissions on the file.
Taking ownership of the file.



No Access (None)

Prevents any access to the shared directory, its subdirectories, and its files.



Read

Allows:
¥ Viewing filenames and subdirectory names.
b Changing to the shared directory's subdirectories.
¥ Viewing data in files and running application files.
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Change

Allows:

Viewing filenames and subdirectory names.

Changing to the shared directory's subdirectories.
Viewing data in files and running application files.
Adding files and subdirectories to the shared directory.
Changing data in files.

Deleting subdirectories and files.
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Full Control (All)

Allows:
Viewing filenames and subdirectory names.
Changing to the shared directory's subdirectories.
Viewing data in files and running application files.
Adding files and subdirectories to the shared directory.
Changing data in files.
Deleting subdirectories and files.
Changing permissions (NTFS files and directories only).
Taking ownership (NTFS files and directories only).



Click Help topics for a list of Help topics.






