
The Windows Help Magician

Version 1.30

Demonstration Documentation

Introduction

This  zip  file  contains  a  demonstration  version  of  the  Windows Help  Magician.  This 
Windows Write  (Version 3.1 format) file contains the Tutorial Chapter from the Help 
Magician's manual. The demonstration version of the program is limited to seven pages,  
enough to complete the tutorial.

The zip file also includes the TUTOR.HLP file for those who do not yet have the help 
compiler  but  would  like  to  look  at  the  Help  Magician.  If  you  don't  have  the  help 
compiler, you can still run the help magician and get a feel for its functionality and you 
can view TUTOR.HLP by double clicking on it from the File Manager to see what can be 
accomplished with a simple Help Magician source file.

Features

The Help Magician automates the creation of Windows hypertext help system files. The 
Windows  Help  Magician  eliminates  the  hours  of  work  you  will  typically  devote  to 
creating custom help windows while developing your Microsoft Windows application. 
With this powerful tool at your disposal, you'll be able to create Windows help files in a 
single integrated environment. No need to wait forever for the RTF file to be written. 
(One competitor took 18 minutes to write an RTF file that the Help Magician blasted 
through in just 4 seconds!) No need to switch out to DOS to run the Help Compiler. With  
the Help Magician, you'll be able to create and test the functionality of your help file 
instantly - jumps, popups, bitmaps, browse sequences, you name it.

● Point and click to create a professional help system from typed or imported text 
and manuals

● First time users and seasoned professionals can save many hours using the Help 
Magician's timesaving features. No knowledge of Windows help is necessary. The 
Help Magician handles the entire project for you - transparently

● No programming knowledge or experience is required to create professional help 
systems with the Help Magician
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● The Help Magician handles all of the organization of the help system for you with 
point and click tables

● An integrated RTF reader imports existing Word for Windows help files, manuals, 
and RTF files written by the Help Magician

● Create jumps & popups from word or phrase links

● Use advanced editor functions: cut,  copy, paste,  find, find next,  find previous, 
replace, replace all, replace with verify

● Save time with hot keys

● Setup and reorder browse sequences seamlessly

● Create and assign custom fonts and colors

● Include bitmaps

● Make numbered lists with numbers, letters, characters, or phrases

● Create bulleted lists

● Indent words, paragraphs, or blocks of text

● Assign keywords and multiple keywords in a drop down box on main form

● Edit, test, write RTF and project files, and compile & call WINHELP.EXE in one 
integrated environment

● Import and export ASCII files

● Dynamic syntax checking ensures that the help system, generated by the Help 
Magician will function as you designed it when viewed with WINHELP.EXE

● Use the Help Magician's test mode to test your help system instantaneously

● Write RTF files with lightening speed

● Supports Windows 3.1 hotspots or "segmented hypergraphics"

● Printout complete help file, browse sequences, context relationships, and link lists
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● Maintain separate configurations for different help systems

● Works for any Windows development language

● Prevents the duplication of topic titles and context numbers automatically

● Maintains your build help directory and time date stamp automatically

● Import  existing  Word  for  Windows  help  files  and  complete  with  the  Help 
Magician's unparalleled capabilities

● Import Word for Windows manuals and convert to Windows help systems

Requirements:
Microsoft Windows 3.0 or 3.1
Windows Help Compiler 3.x
Windows ready IBM Compatible

The Help Magician works with Word for Windows but it  is not required - the  Help 
Magician  is  capable  of  creating  a  Windows  help  system  from  it's  own  integrated 
environment
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Ordering Information

We're so sure you'll like the Help Magician that we back up our claims with 
a full, 30 day, unconditional, money back guarantee.

The Windows Help Magician lists  for  $199.00,  a  very reasonable  price  for  the most 
powerful help creation application available.

Under the agreement between Vi Qual Software, the developer of the Help Magician, and 
Software Interphase, Inc., the distributor, Vi Qual Software may sell a limited number of 
copies of the Help Magician.

During this special offer, send a check or money order (in US currency) for:
US: $99.00 + $5.00 shipping and handling:
Foreign: $99.00 + $10.00 shipping and handling:

TO:

Vi Qual Software
28 Hill Drive
Rochester, NY 14626-1810
Phone: (716) 723-0123
FAX: (716) 227-9786

After this special offer, contact:
Software Interphase, Inc.
82 Cucumber Hill Road
Foster, RI 02825
Call (800) 542-2742
Fax order to: (401) 397-6814

The Windows Help Magician is also available with a German manual and help system  
from:
Zoschke Data GmbH
Bahnhofstr. 3W-2306 Schoenberg/Holst. (Germany)
Tel (01149) 4344-6166
FAX (01149) 4344-6162

The $99.00 special offer does not apply to German speaking countries.
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Installation

The  commercial  version  of  the  Help  Magician  includes  an  automated  installation 
procedure. In order to reduce the size of the zip file for Compuserve, we are asking that 
you install the program manually, which requires only a few simple steps.

(1) Make a sub directory called \HLPMAGIC.
(2) Copy or move the HLPMAG.ZIP file to that directory and un-zip it.
(3) Move HLPMAGIC.HLP and HLPMAGI.DLL to your Windows \SYTSEM 

directory.

Windows 3.0 users only: If you are running Windows 3.0, also move 
THREED.VBX and SS3D3.VBX to your Windows \SYTSEM directory.

IMPORTANT: Be carefull not to overwrite a version of a VBX file that you 
need for other applications.

(4) Execute the program by double clicking on the file name from the File Manager, 
or set up an icon in one of your program groups with the following method:

From the Windows Program Manager, select the target program group by clicking 
on it then select "File", "New", "Program Item" from the main menu. Enter the 
following information into the Program Item Properties form:

Description: Help Magician
Command Line: C:\HLPMAGIC\HLPMAGIC.EXE
Working Directory: C:\HLPMAGIC
Shortcut Key: None

Select OK and the Help Magician's icon will be placed in the program group.

Note that the Windows Help Magician requires VBRUN200.DLL. If you don't already 
have this DLL in your Windows \SYSTEM directory, it is available on Compuserve on 
the following forums:

MSBASIC / Visual Basic - Win
WINAPA / Micrografx
Zenith / Windows

If you don't have the Windows help compiler, it is alsoavailable on Compuserve in the 
WINSDK/WinHelp forum. HC.EXE is a compiler for Word for Windows 2.0 and 
Windows 3.0 and HCP.ZIP is an extended version of the Windows 3.1 compiler.
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When first  executed, the Help Magician will  write a HLPMAGIC.INI file with some 
defaults. You will be able to change these defaults from within the program. You may 
want to select Project Options from the Build Menu and set the directories for your help 
compiler and optional RTF word processor.

In the absence of the complete manual, we ask that you follow the tutorial and use the  
Help Magician's own on line help system.

6



Chapter 2 - Tutorial

Intro The tutorial is placed before the chapters describing the Help Magician 
components for those of us who are too impatient to read the manual before using 
the program. The tutorial will walk you through the creation of a Windows Help 
system, using some of the capabilities of the Help Magician.

TUTOR.HLP In the tutorial, we'll be building a help system called TUTOR.HLP. Start the Help 
Magician by double clicking on its icon in the program manager. The program 
will begin with a blank help file and a temporary title for the first page. Note that  
the terms page and topic will be interchanged throughout the manual, as each 
help topic or definition will be on a separate page in the editor. The tutorial help 
file will describe functions in a fictitious Edit Menu. This will be a simple help 
file for the purpose of learning the Help Magician.

Help Text The text to be entered into the editor, during the tutorial, will be in bold type to 
distinguish  it  from  the  tutorial  text.  Type  the  sentences  in  without  carriage 
returns. The editor will word wrap the text and the text will be word wrapped, in 
the compiled help system, depending on the size of the help window.

Page One Enter the following text into the editor:

tutor.bmp

The Edit Menu

The Edit Menu provides functions to cut, copy, and paste text to and from 
the Clipboard, as well as functions to search for and, optionally, replace text.

Related Topics
Cut
Copy
Paste
Find
Find Next

Bitmap Now, move the cursor to, or click on the file name, tutor.bmp. Select 
Bitmap  Marker  from  the  Marker  Menu.  The  default  option,  Character 
Justification,  will  be  selected.  Select  OK to  close  the  window.  Markers  will 
appear on both sides of the name of the Bitmap and the Status Bar will reflect the 
fact that the cursor is on a Bitmap reference with the notation, Bitmap C. Note 
that, if Bitmaps are not in the 'ROOT' directory for the current help build, the 
path can be included in the filename in the help text.
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Heading Change the font for the topic heading by highlighting the words, The Edit Menu, 
and selecting Font Style from the Marker Menu. Select Topic Heading from the 
list of Font Styles and click on OK.

Highlight the words, Related Topics, and change the font to Emphasized Help 
Text by selecting Font Style from the Marker Menu.

Title Every help page begins with a temporary title in the title text box in the 
Status Bar consisting of the text Temp Title and the page number. Lets change the 
title for page one of the tutorial help file. Click on the title text box and change  
the title to Tutorial Contents.

Keywords Click on the Keywords drop down box in the Utility area. Type Contents and 
press return.

Context # Because this will be the index page for the help file, it requires a context number. 
Click on the context number box, in the Utility Area, and enter the number 1.

Save File Before we move to the second page, lets give the file a name and save it to disk. 
From the File Menu, select Save As. With the File form, select the drive and path 
that the help file will be written to. This becomes the 'ROOT' directory for the 
help  build  as  described  in  the  Windows  Help  compiler  documentation.  The 
Bitmap, TUTOR.BMP, used in the tutorial must be located in this directory 
or you must include the path to the Bitmap in the filename in the help text.

Change the file name from DEFAULT.HLX to TUTOR.HLX and click on the 
OK button to save the file.

Popup Before we can create a link to another topic, or definition, the topic page 
must exist. Click on the ^PgDn button or press the Ctrl PgDn key combination. 
The current page is updated in the database in memory, but the file has not been 
written to disk.

Page Two Enter the following text into page two:

Clipboard
The Clipboard is a Windows utility that stores text or graphics that is cut or 
copied from an application running under Windows.

Heading Change the font for the topic heading by highlighting the word, Clipboard, and 
selecting Font Style from the Marker Menu. Select Topic Heading from the list of 
Font Styles and click on OK.

Title Change the title of the page to Clipboard Definition. No keywords will 
be added to this page because this is not a help topic but a definition for a Popup.
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Move back to page one by clicking on ^PgUp. Next, click on the word Clipboard 
in the help text. Select Popup from the Marker Menu. A table with a list of topic 
titles  will  appear.  The  only  title  in  the  table  at  this  point  will  be,  Clipboard 
Definition. Click on the OK button. Again, Markers will appear on both sides of 
the word Clipboard. The Status Bar will be updated to reflect that the cursor is on 
a Popup.

Test It's a little early but lets get some gratification from the work we have 
done to this point. Click on the Test button in the Status Bar. The Status Bar is  
replaced by the Test Mode command bar. Test Mode always begins on page one 
of  the  help  file.  Notice  that  some of  the  command buttons  are  gray and not 
selectable. Command buttons are selectable only when it is possible to perform 
the associated function. Click on the word, Clipboard. This enables the Popup 
button  in  the  Test  Mode  command  bar.  Click  on  the  Popup  button,  in  the 
command bar, and the definition of Clipboard should appear. Click anywhere in 
the help window to close the Popup.

Click on the word, tutor.bmp. This enables the Bitmap command button. Click on 
the Bitmap command button and, if the Bitmap is in the 'ROOT' directory for the 
current help build, or the path is included in the filename, the Bitmap is displayed 
on a form. Click anywhere in the help window to close the Bitmap viewer.

This is all the help system does so far, but we've only put a minute's worth of  
work into it. Click on the Design button to return to the design mode of the Help 
Magician.

Page Three     Move to page three and enter the following text into the editor:

Cutting Text

Select the text to be cut by holding the left mouse button and dragging over 
the text. Then select Cut from the Edit Menu or press Shift Del. The text is  
cut to the Windows Clipboard.

Heading Change the font for the topic heading by highlighting the words, Cutting Text, 
and selecting Font Style from the Marker Menu. Select Topic Heading from the 
list of Font Styles and click on OK.

Title Change the title from Temp Title 3 to Cutting Text and add the following 
keywords into the Keywords drop down box: Edit, Cut, Clipboard.

Page Four PgDn to page four and enter the following text:

Copying Text

Select the text to be copied by holding the left mouse button and dragging 
over the text. Then select Copy from the Edit Menu or press Ctrl Ins. The 
text is copied to the Windows Clipboard.
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Heading Change the font for the topic heading by highlighting the words, Copying Text, 
and selecting Font Style from the Marker Menu. Select Topic Heading from the 
list of Font Styles and click on OK.

Title Change  the  title  from  Temp  Title  4  to  Copying  Text  and  add  the 
following keywords into the Keywords drop down box: Edit, Copy, Clipboard.

Page Five      PgDn to page five and enter the following text:

Pasting Text

Place the cursor in the text where the text is to be inserted. Then select Paste 
from the Edit Menu or press Shift Ins. The text is copied from the Windows 
Clipboard  into the text.

Note that, if text is highlighted during a paste operation, it will be replaced 
by the pasted text.

Heading Change the font for the topic heading by highlighting the words, Pasting Text, 
and selecting Font Style from the Marker Menu. Select Topic Heading from the 
list of Font Styles and click on OK.

Title Change the title from Temp Title 5 to Pasting Text and add the following 
keywords into the Keywords drop down box: Edit, Paste, Clipboard.

Page Six PgDn to page six and enter the following text:

Find Text

Select Find from the Edit Menu to search for text in the current help file. 
There are options to search the current topic or all topics. The search can be 
case sensitive or case insensitive and can be limited to whole word.

Title Change the title from Temp Title 6 to Find Text and add the following 
keywords into the Keywords drop down box: Find, Search.

Page Seven PgDn to page seven and enter the following text:

Find Next

Select  Find  Next  from  the  Edit  Menu,  or  press  F3,  to  find  the  next 
occurrence of the search text in the current help file.
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Heading Change the font for the topic heading by highlighting the words, Find Next, and 
selecting Font Style from the Marker Menu. Select Topic Heading from the list of 
Font Styles and click on OK.

Title Change the title from Temp Title 7 to Find Next and add the following 
keywords into the Keywords drop down box: Find, Search, Next.

Create Jumps Move back to page one and click on the word Cut, in the list of edit functions, in 
the lower portion of text in the editor. There are two shortcuts to moving to a  
specific page. You can select Goto Title from the Edit Menu and select the page 
from the list or click on the page number text box, in the Status Bar, and enter the 
desired page number. Select Jump from the Marker Menu, or press Ctrl J, and 
select the title, Cutting Text, from the list of titles in the table. Click on the word  
Copy, select Jump from the Marker Menu, and select the title, Copying Text,  
from the table.

Click on the word Paste, select Jump from the Marker Menu, and select the title,  
Pasting Text, from the table.

In  the  same  manner,  create  Jumps  for  Find  and  Find  Next,  selecting  the 
appropriate title from the table. In order to select two or more words, as in the 
case of Find Next, you will  have to highlight both words by holding the left 
mouse button and dragging over the words. The highlighting need not be precise. 
The Help Magician will find the beginning and end of words for you.

Indents For a more professional appearance, go back through the help pages and 
indent the text paragraphs. Don't indent the titles or the headings, such as Related 
Topics. To indent the text, place the cursor anywhere in the paragraph and select 
Indent from the Marker Menu. Enter .2 as the indent and click on OK. Also,  
indent the Jumps on the first page by holding down the left mouse button and 
dragging the mouse cursor over the Jump words. Again, select Indent from the 
Marker Menu, enter .2, and click on OK.  

Add Browse Click on the Browse button in the utility area. A blank Browse Definitions form 
will appear. Add the Browse group names, Edit and Find, by clicking on the Add 
button under the Browse Groups table and entering the group names.

With the Edit group highlighted, click on the Add button, under the Titles table,  
select Cutting Text, and click on OK. In the same manner, add the titles, Copying 
Text, and Pasting Text to the Titles table.

With the Find group highlighted, click on the Add button, under the Titles table, 
select Find Text, and click on OK. In the same manner, add the title, Find Next, 
to the Titles table.

You have just created multiple Browse sequences. Click on the Exit button to 
close the Browse Definitions form.
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Done You have completed the tutorial help file. Save the help file by selecting 
Save from the File Menu. Now, let's go back into Test Mode and check what we 
have done. Click on the Test button in the Status Bar.

Test Click on Cut Text and press the Jump button on the command bar. This 
will display the Cut Text topic.

Browse Since  we have  created  a  Browse  group for  the  Edit  topics,  the  right 
Browse button ( >> ) will be enabled. Clicking on the button will display the 
Copy Text topic. The left Browse button ( << ) will now be enabled. Clicking on 
the right Browse button again will display the Paste help topic. Since this is the 
last topic in the Browse group, the right Browse button will be disabled.

History The history buffer has stored the help topics we have visited. Clicking on 
the History button will display the history window. You can select a topic to re-
visit by double clicking on the title or by selecting it and clicking on the OK 
button.  Click  anywhere  else  on  the  Help  Magicians  main  form to  close  the 
History window.

Misc. Check the Popups and the other capabilities of Test Mode and, when you 
have finished, click on the Design button to return to the design mode of the Help 
Magician.

Build Now,  lets  make  the  compiled  help  system  and  test  it  by  calling 
WINHELP.EXE. Open the Build Menu and select Rebuild All. This option will 
write  the  RTF and project  files  and  run  the  Windows help  compiler  without 
checking the time and date stamp on the files involved in the help build. You 
could use the Write RTF and the Run Compiler options individually to perform 
the operations separately and the files time and date stamps will be checked.

Compile Since the Windows help compiler is actually a DOS application, the screen will 
clear to a DOS screen. 

Messages In version 3.0 of the Windows help compiler, the output messages are directed to 
a file and the Help Magician displays the contents of the file in a window when 
compilation is complete. In version 3.1, the ERRORLOG option is used in the 
project file and the file is displayed in a window when compilation is complete. 
This allows scrolling back and forth through the messages instead of trying to 
view them as they scroll  by on the screen.  The messages can be sent  to the  
default printer by clicking on the Print button.

Note Version 3.00b of the Windows help compiler does not support redirection 
or the use of the ERRORLOG option. Therefore, it is not possible to display the 
messages in a window.

View If the compile was successful, you can view the help system by selecting 
Call WINHELP.EXE from the Build Menu. Everything should work the same as 
it did in the Test Mode of the Help Magician.
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Close When you are done viewing the help system, close the window. If the 
window is left open, by changing the focus to another application, and you edit 
and  re-compile  the  help  system,  WINHELP.EXE  will  display  an  warning 
message the next time you make a call to the help system. The message will  
indicate that the help file has changed and WINHELP.EXE will close the window 
for you.
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