REALbasic QuickStart

Welcome to REALbasic!

REALbasic is an application builder based on a modern version of the BASIC
programming language. The REALbasic development environment is made up of a
rich set of graphical user interface objects (commonly referred to as a GUI), an
object-oriented language, a debugger, and a compiler.

With the graphical user interface, you can build your application’s interface simply
by dragging and dropping interface objects into the application’s windows and
dialogs.

The object-oriented language, debugger, and cross-platform compiler make up the
rest of REALbasic’s Integrated Development Environment (IDE), designed to make
application prototyping and programming easy.

REALbasic provides you with all the tools you need to build virtually any
application you can imagine.

If you are new to programming, you will find that REALbasic makes it fun and easy
to create full-featured applications. If you are an intermediate or advanced program-
mer, you will appreciate REALbasic’s rich set of built-in tools.

This QuickStart is for people who are new to programming and new to REALbasic.
It will give you a gentle introduction to the REALbasic development environment,
lead you through the development of a real application, and show you what kinds of
other applications can be built with REALbasic.

It should take you no longer than 30 minutes to complete this QuickStart.
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Note If you have experience with other versions of the BASIC language or have experience

with other programming languages, you'll want to check out the Tutorial and User’s
Guide. In the Tutorial, you'll develop a more complete application, which includes
menus, dialog boxes, and objects called c/asses.

Presentation Conventions

The QuickStart uses screen snapshots taken from both the Windows and Macintosh
versions of REALbasic. The interface design and feature set are identical on both
platforms, so the differences between platforms are cosmetic and have to do with the
differences between the Macintosh’s “Panther” interface and Windows XP’s
standard appearance setting.

Italic type is used to emphasize the first time a new term is used, and to highlight
important concepts. In addition, titles of books, such as REALbasic User’s Guide, are
italicized.

When you are instructed to choose an item from one of REALbasic’s menus, you
will see something like “choose File » New”. This is equivalent to “choose New
from the File menu.”

The items within the parentheses are &eyboard shortcuts and consist of a sequence of
keys that should be pressed in the order they are listed. On Macintosh, the Com-
mand key is the modifier; on Windows, the Ctrl key is the modifier. For example,
the shortcut “3-0” is the Macintosh keyboard equivalent. It means to hold down
the Command key, press the “O” key, and then release the Command key. The
shortcut “Cerl+O” is the Windows keyboard equivalent and means to hold down
the Ctrl key, press the “O” key, and release the Ctrl key.

Bold is used to indicate text that you will type while using REALbasic.

Some steps ask you to enter lines of code into the REALbasic Code Editor. They
appear in Frutiger (a sans serif font) in a shaded box:

ShowURL SelectedURL.Text

When you enter code, please observe these guidelines:

Type each printed line on a separate line in the Code Editor. Don’t try to fit two or
more printed lines into the same line or split a long line into two or more lines.

Don’t add extra spaces where no spaces are indicated in the printed code.

Whenever you run your application, REALbasic first checks your code for syntax
errors. Syntax checking will direct your attention to the line of code that is causing
problems. Check the line against the printed line. The QuickStart also has
troubleshooting sections that help you handle syntax errors.
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Starting REALbasic

Starting REALbasic

If you haven’t done so already, install REALbasic on your computer. If you are using
the Macintosh version of REALbasic, drag the REALbasic application from your CD
to your Applications folder (or another folder of your choice). If you are using the
Windows version of REALbasic, use the REALbasic installer to install the product
and all the necessary files onto your computer.

Double-click the REALbasic application icon. In a few moments, the REALbasic
Integrated Development Environment appears. If you're using Windows, the
Project Window and Window Editor appear within the REALbasic IDE multiple
document interface window and the Properties Window and Controls Palette float
above this window.
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Starting REALbasic

Figure 1. The REALbasic IDE (Mac OS X and Windows XP).

Project Properties Controls
Window Window Palette

& REALbasic Mac 05 X File Edit Format | Debug Window Extras Help

0O 0O Untitled

Name: Window
Super: Window

Placement
Width:
Height:
MinWidth:
MinHeight
Maxiidth
Maxteight

Untitled

Frame:

Window
Editor

On Windows, the———— [
“REALbasic IDE” window
contains other REALbasic
windows e
(63l #ep

Composite:
HasBackColor:
BackColor.

Backdrop:
Tite:

Visible:
FullScreen;

MenuBarVisible

CloseBox:

Growlcon:
LiveResize:
Zoomicon:

nojaal®&

BalloonHelp:
MacProciD:
MenuBar:

Properties
D
Hame Windowl
Super Window
Pasition
Placement 0-Defauit
Widh 00
Height 300

Minlwich
MinHeight
Maswidth

64
64
2000

MaxHeight 32000
Appearance
Fiame 0-Document Window
® Untitled X Composite

HasBackColor
BackColor
Backdiop
Tie

Visible
FulScreen
MenuBatvisible
CloseBox
Growlcon
Zoorrlcon
EalloonHelp
MacProclD
MenuBar

Note In Figure 1, some windows have been moved from their default positions so you can
see them better.
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REALbasic’s Windows

REALbasic’'s Windows

As you can see in Figure 1 on page 4, there are four windows that open when you
start up REALbasic:

m The Project Window contains a list of all of the major items that make up your
REALbasic application. For example, the Project Window includes items for all the
windows that your application uses, the menu bars, and objects such as sounds,
pictures, databases, and movies. By default, the Project Window includes an item
for the application’s main window, Windowl, its default menu bar, MenuBarl, and
an item for code associated with the application as a whole, App. You double-click
an item in the Project Window to edit or view it.

m A Window Editor is where you build windows, dialog boxes, message boxes, and pal-
ettes for the application. Each such window is opened in its own Window Editor and
all the windows in the application are listed in the Project Window. By default, an
application has one window that opens automatically when you launch the applica-
tion. It’s called Windowl. In Figure 1, the Window Editor is empty because you
haven’t added any interface items yet.

m The Controls Palette contains icons representing interface objects that you can add to
a window. You build your application’s interface by dragging and dropping icons
from the Controls Palette to a Window Editor.

m The Properties Window lists the properties and their values of an item you select in a
Window Editor or a menu item in a MenuBar. You can add or modify an object’s
properties by editing the values in the Properties Window. In Figure 1, the main
window is selected, so the Properties Window shows the properties of this window.

In addition, the complete REALbasic Language Reference is online. Choose
Help P Language Reference to display the online reference. Use it as a convenient
alternative to the printed or electronic (PDF) version of the Language Reference.

Getting Started

In this QuickStart, you'll build an application that manages URLs and email
addresses. A URL (which stands for Uniform Resource Locator) is the address of a web
page that you type into the Address area in your web browser. This application will
launch your default web browser application and display the web page that you
entered.

Figure 2 shows a URL in a browser Address area:

Figure 2. A URL entered into a browser.

‘ Load address: ’\‘;i http: / /www.realsoftware.com '

If you enter an email address instead of a URL, the application will launch your
email application, create a new blank email, and enter the address into the “To” box.
Figure 3 shows how to enter an email address into a browser’s Address area.
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Getting Started

Figure 3. An email address entered into a browser's Address area.

' Load address: ?a‘i mailto:customerservice@realsoftware.com l

When you are finished, the application will look like Figure 4. In Figure 4, the
labels in bold indicate the types of controls that were used in creating the
application. The functions of the controls are described in plain type.

Figure 4. The finished URL Manager application.
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You use the EditField to enter the URL or email address you want and then click
the Connect pushbutton. To save it in the list, you click the Add button. To select a
URL in the ListBox, highlight it in the list and then click Connect. If you don’t
need the URL any more, highlight it in the list and then click the Delete button.

The application uses three types of prebuilt interface elements to do most of the
work for you:

A ListBox is the type of control that holds scrollable lists. It can hold both single-
and multiple-column lists and scroll horizontally and vertically.

An EditField is the type of control that holds text. It can be used to hold either a
single row of text (as it is here) or as a text editor.

A PushButton is a standard pushbutton. It is most often used to initiate an action
(as it is here).
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Creating the Interface

Creating the Interface

Your first task is to build the interface. You already have the REALbasic integrated
development environment open.

1 In the Controls palette, hold down the mouse button on the ListBox icon [=:f and
drag it to the top-left corner of the Window Editor.
As you drag toward the corner, alignment guides will appear, as shown in Figure 5.

Figure 5. Alignment guides help you position the ListBox and align other controls.
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2 Release the mouse button.
A square ListBox appears in the Window Editor.
3 Use the resizing handle in the bottom-right corner and drag diagonally to enlarge

the ListBox. When the alignment guide appears on the right, release the mouse
button, as shown in Figure 6.

Figure 6. Enlarging the ListBox.

866 Untitled

2

Center it in the upper area of the window, as in Figure 7.

REALbasic QuickStart 7



Creating the Interface

Figure 7. A ListBox added to the Window.
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2

4 Next, drag a Pushbutton control o) from the Controls Palette to the lower-left
portion of the window (where the “Add” button in Figure 4 on page 6 is).
As you drag toward the left edge of the ListBox, a vertical alignment guide appears.
Use the vertical alignment guide to position the Pushbutton, as shown in Figure 8.

Figure 8. Aligning the Add pushbutton.
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5 With the Pushbutton selected, press 8-D (Ctrl+D on Windows) or choose
Edit » Duplicate to make a copy of the Pushbutton. Move it to the right of the
previous button and align it with the right edge of the ListBox.
When you reach the approximate position, both vertical and horizontal alignment
guides appear. Align the baselines of the two PushButtons’ captions, as shown in
Figure 9.
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Creating the Interface

Figure 9. Aligning the Add and Connect pushbuttons.
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6 With this Pushbutton selected, hold down the Option key (Alt key on Windows)
and drag the PushButton vertically, just below the ListBox. Release the mouse
button when the horizontal alignment guide appears.

Figure 10. Adding the Delete button by Option-dragging the Connect button.
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7 In the Controls palette, hold down the mouse button on the EditField icon ]
and drag it into position in the window, midway between the Delete and Connect
buttons (see Figure 11 on page 10).

8 Align the left edge of the EditField with the left edge of the ListBox.

9 Use one of the EditField’s selection handles to stretch it so that its right edge aligns
with the ListBox.
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Creating the Interface

Figure 11. Aligning the right side of the EditField with the ListBox and Pushbuttons.
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Note You can also position a control by clicking on it and moving it one pixel at a time
using the arrow keys.

Your application’s interface is now complete! It should look like Figure 12:

Figure 12. The finished interface in the development environment.

€ Untitied o [=1E3]

Before going any further, save the project.

m Choose File » Save (8-S or Ctrl+S) and name it URL Manager.rb.

At this point, you can actually try it out. Of course it won’t do anything since we
haven’t told any of the interface elements what to do.

1 Just for fun, choose Run from the Debug menu.
REALbasic builds the application and opens it in its own window.
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Giving Objects Meaningful Names and Labels

The first version of the application should look like this:

Figure 13. The first version in the Runtime environment.
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In this state, the PushButtons work — that is, you can click them and they
highlight — but they don’t do anything because we haven’t told the PushButtons
what to do when they’re clicked. You can enter text into the EditField — but it
doesn’t go anywhere because there are no instructions to process this text. And the
ListBox is all set to display and scroll items but we don’t have any way to get text
into the ListBox yet.

But it’s a start. We need to go back to the development environment to get this
application operational.

2 Choose File » Exit on Windows or My Application » Quit (in Mac OS X) to return
to the integrated development environment. On Windows, you can also quit the
application by clicking the window’s Close box.

Giving Objects Meaningful Names and Labels

You've already noticed that quite a few objects have the default label “Untitled.”
They also have default names like PushButtonl, PushButton2, etc. Before getting
too far into the project, we should give the objects meaningful names and labels.
You refer to the object’s names in your REALbasic code and, of course, the labels are
presented to the user. You should give each object that you refer to in your code a
meaningful name at the start of the project.

1 Inthe REALbasic IDE, click on the surface of the window in the Window Editor —
not one of the controls in the window — and then take a look at the Properties
Window. (If the Properties Window is not onscreen, choose Window » Show
Properties.)
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Giving Objects Meaningful Names and Labels

The window has the default name “Window1”, which is shown in the first line. If it
shows some other name, then you clicked on one of the controls in the window
rather than the surface of the window itself.

Figure 14. Window1’s Properties Window.
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The text that appears in the Title bar of the window is the Title property. The
Name property is the name of the window that you use in your code to refer to the
window.

2 Select the default Title, “Untitled”, in the Properties Window and replace it with
URL Manager, and press the Return key. When you press Return, the new title
appears in the Title bar of the Window Editor as well as in the Properties window.

Figure 15. Changing Window1’s Title property.
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Giving Objects Meaningful Names and Labels

Similarly, we need to replace the default names and labels for the controls in the
window.

In the Window Editor, click on the Untitled button in the lower left.

Notice that the Properties Window changes to show the properties of this control.
The three PushButtons are named PushButtonl, PushButton2, and PushButton3.
They were named in the order they were created. We'll never remember which one
is which, so it’s best to rename them at the same time we’re entering their labels.

Change its Name property to AAdURL and its Caption property to Add. Press
Return to save each new property value.

Notice that the Caption text immediately replaces “Untitled” in the Window Edi-
tor when you press Return. When you are finished, the Properties Window for the
AddURL pushbutton should look like this.

Figure 16. The Properties Window for the Add button.
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Click on the Untitled button in the lower right to select it. It’s PushButton2. Use
the Properties Window to change its name to ConnectURL and its Caption
property to Connect.

Click on the Untitled pushbutton between the ListBox and the EditField and
change its Name property to DeleteURL and its Caption property to Delete.
Click on the EditField and change its name to SelectedURL.

Click on the ListBox and change its Name property to ListURL.
That takes care of it. The Properties windows for these objects should look as shown
in Figure 17.
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Making the URL Manager Do Something

10

Figure 17. The Properties Windows for the other controls.
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Check your work to be sure that the items are named correctly. If there is a spelling
error in a Name property, code that is supposed to refer to that item will not work.

The three buttons should now look like this:
Figure 18. The three PushButton controls after renaming.

Choose File » Save to save your changes. Choose Debug » Run to test it.
It doesn’t do any more than the last version, but at least all the interface elements
are labeled correctly.

Choose File » Exit (on Windows) or My Application » Quit (Mac OS X) to return
to the Development environment.

Be sure to quit out of the built application before resuming your work in the REAL-
basic Development environment. You can’t change anything in the Development
environment while the application itself is running. If you forget to quit out of the
test application before you resume work in the REALbasic IDE, REALbasic will
stop you and tell you that the test application is still running.

Making the URL Manager Do Something

Now that the interface is designed and its appearance is touched up, it’s time to
make the controls do their jobs. We'll start with the Connect button.

In the Window Editor, double-click the Connect button.

The Code Editor for the application window appears. This is where you write code
for the window and the controls contained in the window.

On the left side is a browser area that lists all the controls that we’ve added to the
window, among other things. (For the QuickStart, we only need to work with the
controls.) On the right side is the code editing area. It holds the code for the item
that is selected in the browser.

14
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Making the URL Manager Do Something

Right now the “Action” item for the Connect button is selected. It’s highlighted in
the Browser area and the first line in the editor gives the name of the event.

Figure 19. The Code Editor for Window1.
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In order to get the Connect button to do something, we need to write some code
that will run only when the button gets clicked. Fortunately, the REALbasic appli-
cation itself monitors all user interface activity while the application is running and
it knows whenever this happens. We need to write the instruction that connects the
user to the web site that the user enters into the EditField.

In the Browser area of the Code Editor, you'll see a list of events that REALbasic
continuously monitors while the application is running. The one we need is the
“Action” event. This event takes place when the user clicks the button.

On the right, you can write the code that runs automatically when the user clicks
the button. (Notice that the first line in the Code Editor, “Sub Action()”, indicates
which event the code is for). The instruction to open a web site in the user’s browser
(or open the email application) is simple. The instruction is ShowURL and its
syntax is:

ShowURL text

Where text is the URL (or email address).

As soon as you enter “ShowURL”, a “tips” window appears, showing the syntax. By
referring to the Tips window you can avoid having to look up a command’s syntax
in the Online Reference whenever you need help.

Figure 20. The ‘Tips' window showing the syntax for ShowURL.

IO o ShowURL Str

2 To test out this button, enter the following line in ConnectURL’s Action event:

ShowURL "http://www.realsoftware.com"
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Making the URL Manager Do Something

Be sure to enclose the URL in quote marks. The quote marks indicate that the text
in quotes is a string (rather than a number or some other type of data). Your Code
Editor should now look like this:

Figure 21. The code for ConnectURL's Action event.
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3 Choose Debug » Run to test out the Connect button.

Click the Connect button.

In a few moments, your default web browser will launch and bring up the REAL
Software home page. (This, of course, assumes your computer has a connection to
the Internet and you have a default browser application.)

Figure 22. The REAL Software home page.

806 REAL Software, Inc. =

 RELd @ ghl(p'Nwwwxea\snfmare,mm,’ =(Q~ Google )

| [ PubMed On-line Med . Dictionary What's New in SAS 9 SAS Documentation =
_REAL Software, Inc.

@ REAL Software Py o

REALbasic Download Store Support Community Company

Home Search + Sitemap

Create your
own software!

REALbasic is the powerful, easy-to-use
tool for creating your own software
for Macintosh and Windows.

H More Info & pemo HBuy

Bl pecember ]
REAL Software Announces Speakers, Dates, Location for REAL World 2004, The
REALbasic Developer Conference

REAL Software, Inc. announced today that REAL World 2004, The REALbasic User Conference, will be
held March 24-26, 2004 at the Austin Convention Center in Austin, Texas. Noted REALbasic authors
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present at the conference.

Registration Info

Of course, we need to modify the code so that the text passed to the ShowURL
command can be entered by the user while the application is running. When we use
ShowURL "http://www.realsoftware.com", the particular URL is “hardcoded.”
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Making the URL Manager Do Something

If you get a syntax error, check to make sure that you spelled the ShowURL
command correctly, that you enclosed the URL in double quote marks, and that it is
the correct URL.

Choose File » Exit on Windows (or My Application » Quit on Mac OS X) to return
to the Development environment.

We now need to replace the text used with the ShowURL command with the code
that refers to the contents of the EditField, SelectedURL.

Since the EditField is named “SelectedURL”, you might think that we could write:
ShowURL SelectedURL

but that won’t work because “SelectedURL” is the name of the object itself. It has
lots of properties — like its position in the window, whether it takes several lines of
text or just one, whether it can accept styled text, and so forth. If you use
“ShowURL SelectedURL"”, REALbasic would have no idea what you mean.

When you need to refer to one of an object’s properties, you write the name of the
object, followed by a dot, followed by the name of the property. In other words, you
use this syntax:

objectname.propertyname

It’s sometimes called “dot” notation.

In this case, the EditField is named “SelectedURL” and the EditField property that
we want is its “Text” property. This means the following expression accesses the
contents of the EditField:

SelectedURL.Text

That is, “SelectedURL” is the name of the object and “Text” is the name of the
object’s property that we need.

In the Code Editor for the Action event, modify the code to read:
ShowURL SelectedURL.Text

This expression SelectedURL.Text refers to the text property only.
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Making the URL Manager Do Something

In Case of
Difficulty

If the
Application
doesn’t run

Your Code Editor should now look like this:

Figure 23. The revised code for the Action event.
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If you have trouble entering this line of text, be sure you have quit out of the test
application before returning to the REALbasic Development environment (IDE). If

you try to add code while your test application is running, you will see a message
like this:

REAL basic IDE

'E The application "URL Manager” is being debugged by REALbasic and is still urning. IF you choose ko continue with this operation REALbasic will need ko stop the debug process, Do you wish to
. cantinue?

The application "URL Manager.rb” is being debugged

by REALbasic and is still running. If you choose 1o
@ continue with this operation REALbasic will need to

stop the debug process. Do you wish to continue?

Simply click OK (Continue on Mac OS X) to quit the test application and return to
the Development environment.

Save the project (File » Save) and switch over to the Runtime environment
(Debug » Run).

Enter a URL in the EditField, such as “www.realsoftware.com” and click Connect.
Your default web browser should launch and open the web page you entered.

When you're finished, quit out of the Runtime environment (File » Exit or
REALbasic » Quit) and go back to the Development environment.

If REALbasic was unable to switch to the Runtime environment, its because it
couldn’t recognize a term you entered into the Code Editor. For example, if you
misspelled either “ShowURL” or “SelectedURL,” REALbasic stops and points out
the term it doesn’t recognize. In Figure 24, a user has misspelled the name of the
EditField.
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Making the URL Manager Do Something

Figure 24. A misspelled object name.
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Since it can’t find an object called “Selected,” it can’t create the application for you.
REALbasic knows it would never be able to figure out what to do when a user clicks
the Connect button. Be sure you've renamed the controls as described and referred
to their correct names in the Code Editor. You'll also get this error if you wrote
ShowURL SelectedURL and left off the name of the property that contains the
contents of the EditField.

Another possibility is that you used the correct name in the Code Editor but did not
rename the EditField using the Properties Window as shown in Figure 17 on

page 14. In that case, the statement in the Code Editor as shown in Figure 23 on
page 18 ought to work, but there is no object named “SelectedURL” in the
application. This is illustrated in Figure 25 on page 19.

Figure 25. Forgetting to rename the EditField.
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If you get an error message, start by checking the highlighted term.

Now, we’ll make the other controls do their jobs.
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Making the URL Manager Do Something

The Add
Button

1

2

Note

The Delete
Button

1

2
The ListBox

1

The Add button is supposed to take the text in the EditField and add it to the end
of the list in the ListBox. That’s easy.

If the Code Editor for the window is not already open, double-click the Add button
in the window (If the Window Editor is not open, double-click its name in the
Project Window).

Enter the following code into the Add button’s Action event:
ListURL.Addrow SelectedURL.Text

The first part of the expression, ListURL.Addrow calls a built-in method belonging
to a ListBox. The AddRow method is a command that adds a row of text to the end
of whatever list is already in the ListBox. Not surprisingly, it needs to be passed the
text of the new item. We already know that SelectedURL.Text refers to the con-
tents of the EditField, so that is what we use.

A method is a command that performs an action. Technically, ShowURL is a global
method because it isn’t attached to any particular object. It can be called by any
object that can call a method. We just happen to be calling it from a PushButton.
(We could, for example, design the application so that ShowURL is called when the
user chooses a menu item instead of clicking a button.)

Just as objects can have properties (like their name, size, position, and label), they
can also have their own methods. AddRow is also a method but it “belongs” only to
ListBoxes. It has a specialized action that only makes sense when applied to lists in
ListBoxes.

The Delete button removes the selected item in the ListBox. It’s also pretty simple.

In the Code Editor, expand the DeleteURL item and highlight the Action item.

Enter the following line of code:
ListURL.RemoveRow ListURL.ListIndex

In this case, we are calling the built-in RemoveRow method of the ListBox. Instead
of text, it needs the number of the row (line) to delete. The ListIndex property con-
tains that number, so we pass that number to the RemoveRow method.

The ListBox itself has the job of copying the item the user selects into the EditField
so the user can connect to that URL or email address. You can easily do this by
writing an assignment statement that runs when the user highlights an item in the list.

With the Window Editor in the front, double-click on the ListBox.

The Code Editor window changes to select the ListBox’s Change event. The Change
event runs whenever a different item is highlighted in the ListBox.
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2 Enter the following code into the Change event:
SelectedURL.Text=ListURL.Text

The ListBox’s Text property contains the text of the highlighted item. The Text
property of SelectedURL contains the text that’s currently displayed. This assign-
ment statement copies this text into the Text property of the EditField.

Testing the Application
That’s the basics of this application. Now it’s time to test out all these features.

1 Choose File » Save to save your changes.

2 Choose Debug » Run and test it out.
The application looks the same as it did, but all the controls work! For example,
enter http://www.realsoftware.com into the EditField and click the Add but-
ton. Add a few other URLs to the ListBox in this manner and then highlight one in
the ListBox to move it to the EditField.

Figure 26. Clicking a URL to move it to the EditField.

e 0 URL Manager

www.realsoftware.com
www.webstar.com
www.realbasic.com X

f 1. )
{ Delete )

www.realbasic.com

£ . .. I -
[ Add ) [ Connec! |

You can:

m Enter a URL into the EditField and connect to the site using your default web
browser.

m Add the URL to the ListBox.
m Select any URL in the ListBox to copy it into the EditField.
m Delete the selected URL in the ListBox.

If you want to send an email, enter it in the following way:

mailto: username@domain.com
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If the
Application
doesn’t run

If something is wrong with your code, REALbasic stops and points out the first
error it finds when you choose Debug » Run. For example, in Figure 27 this user
has entered the name of a general class of objects (“ListBox”) rather than the
particular ListBox itself:

Figure 27. A vocabulary error.

806 Window1 Source Code
» [j Constants - —_
¥ [ Controls Sub Action()

ListURL.RemoveRow ListBox.Listindex
This method or property does not exist.  [Help]
i

@ AddURL

b @ ConnectURL

¥ @ DeleteURL
# |Action
 Close |
"™ DropObiject
™ GotFacus

™ LostFocus
™ MouseDown v

= = y
—

In most cases, you will find that errors are due to either misspelling the name of an
object or the name of a property. You will also get errors if you use the intended
name of an object but did not change the default name of the object in the
Properties Window. Start by checking the term that REALbasic highlights and
determine whether it is spelled correctly. If it is supposed to be the name of a
control, be sure the control as been renamed correctly. If it is the name of a method
(like “ListIndex”) be sure it is spelled correctly.

The error message tells you the term that REALbasic doesn’t understand; for more
information about the error, you can click the “Help” button within the error
message. REALbasic will then open the Online Reference to the entry for the error.
In this case, it displays the following page.

Figure 28. The error in the Online Reference.

006 Language Reference
Alpha N This Method, Property or Variable Does Not Exist Error 2
This Local Variable or Co_ 0 You used a syntax that implies that a term is a method o property, but it does not exist. It
“This Method Doesrit Ret.. alse occurs when you use a variable in an assignment statement but omit the equals sign,
This Method is Protected making It appear that it s 3 mathod or property
“This Method Reqires Fe. Examples
e Omitting an equals sign:
e e Bl myString as String

myString "Colubus”
Caliing a method that has not been defined
myCustontle thodl 7,5, 35 i

This Name is Already in
“This Property Has the Sa..

“This Property Has the Sa. Dim aFiles(3) as FolderTtem

This Property Has the Sa aFiles.List //no such thing

This Propeny s Protecte. 0 ASSigring a valiie to 4 variable that s not been declared using a Dim statement
i

This is the Action event handler of a PushButton; the user wants to display the caption
property of the PushButtan

You Cant Assign one Ar.

Type Mismatch error
VuanOﬂMnhemfm,m

You Can't Pass an Amay 1. MsaBox capiion //should be me caption*
ou Canit Pass an Bxpres. Frying 10 St in code a property that can only e Set in the Praperties window. The following

You Carit Use Super ec line of code tries to set the value of the Bold property of a Menuitem, but REALBasic does not
- recognize the Bold property in code.
SearchFind, Bold=irue |
Using Wie in 3 method or function that is not attached to an object. The following method tries
d

Can't Use the NewO.
You Canit Use This Varia...

c to return the caption property of the calling PushButton, but this is nat permite
‘Vou Cannot Use the New. Eunction myCaption(y as String
You Have Used an Opera. Return Me. Caption .
YouMust indicretheDa. [y | | +£04. function . ¥

Of course, you need to correct the error before the application can run. Each time
you test the application, REALbasic will stop at the first error, so there may be
others.
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Using
Autocomplete

How can the
Application

One way to avoid using incorrect terms is to take advantage of REALbasic’s
“autocomplete” feature. As you type, REALbasic tries to guess what you are typing.
If you type the first few characters of a REALbasic language object — either built in
or a variable, method, or property that you created — it shows its guess in light
gray type. If the guess is correct, press the Tab key to complete the entry.

Here is an example:

Figure 29. Autocomplete in action.

b @ AddURL

[SRSXS) Window1 Source Code
» [ Constants —
¥ [ Controls Suﬁgﬁwfn()

End Sub

a
b @ ConnectURL
¥ @@ DeleteURL

3 Action

™ Close ”
" DropObject
™ GotFacus

" LostFocus
™ MouseDown v

= Fl

é

The user has just typed “List” and REALbasic has suggested “ListURL”. Pressing
Tab completes the word.

If REALbasic knows several alternatives, it displays them in a contextual menu
when you press Tab. For example, after accepting “ListURL” and typing the period
key and the first two letters of the next term, REALbasic can suggest only four
possible correct matches. Press Tab when you see the ellipsis (“...”) and, when the
contextual menu appears, use the up or down arrow keys to select the correct term.
Press the Return key to select it.

Figure 30. A contextual autocomplete menu.

» @& AddURL

» & ConnectURL

¥ @ DeleteURL
3 Action
™ Close
" DropObject
™ GotFocus
| LostFocus
™ MouseDown

= El

{ﬂ

eoe Windowl Source Code
» [§ Constants =
v Eﬁ Controls Sub Action()
ListURL.RemoveRow ListURL. Listf List

End Sub

ListCount
Listindex
ListURL

Zl

Although all the controls do their jobs, they do their jobs when it is inappropriate

to do so. For example,

be improved?

If the EditField is blank, clicking the Add button adds a blank row to the ListBox

and clicking the Connect button tries to open a non-existent URL.
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If no item is selected in the ListBox, the Delete button tries to delete a non-existent
row.

We should make it impossible for the buttons to be clicked unless the conditions
are right or, at least, give the user some appropriate feedback.

Choose File » Exit on Windows or REALbasic » Quit (Mac OS X) to return to the
Development environment.

Double-click on the Connect button in the Window Editor to open the code for its
Action event.
It currently reads:

ShowURL SelectedURL.Text

We need to make this conditional — so that the line is executed only when there is
some text in the EditField. For now, we’ll have to assume that the user knows how
to enter a valid URL or email address.

Modify the code to read:

If SelectedURL.Text <> "" then

ShowURL SelectedURL.Text
Else

MsgBox "Please enter a URL or email address."
End if

There is no space between the double quote marks in the first line or between the
less than and greater than signs.

This code first tests to see whether the contents of the EditField is blank. The “<>”
symbol means “not equal to” and the quotes with nothing in between specify blank
text. If the EditField is blank, we use the MsgBox command to display an alert box
with an informative message.

Expand the DeleteURL item in the Code Editor and select the Action event.

We need to follow the same logic. This code should run only if the user has selected
an item in the ListBox—not all the time.

Modify the code to read as follows:

If ListURL.Text <> "" then
ListURL.RemoveRow ListURL.ListIndex
Else
MsgBox "Please select an item in the list."
End if

Expand the AddURL item in the Code Editor and select the Action event.

In this case, we can add an extra test. If the item is already selected, it doesn’t need
to be added, so we can test for that condition as well. The first test prevents the Add
button from adding a blank row and the second test prevents it from adding a

24
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duplicate row (We could also write a separate method that tests whether the new
item matches any item in the ListBox, but we will leave that as an exercise!)

7 Modify the code to read as follows:

If SelectedURL.Text <> ListURL.Text then
ListURL.Addrow SelectedURL.Text
Else
MsgBox "Please enter a different URL or email address."
End if

Next, we want to prevent the user from using the Add and Connect buttons if there
is nothing in the EditField.

8 Expand the SelectedURL item in the Code Editor and select the TextChange event
in the Browser area of the Code Editor.
The TextChange event runs whenever the text in the EditField has changed. We
want to take action based on the EditField’s state just after the text has changed. If
the EditField is now blank, we will disable these two buttons so the user can’t use
them. And, if there is text in the EditField, we will enable the buttons and make the
Connect button the default button. The default button has an outline around it on
Windows and Mac OS “classic” and it “throbs” on Mac OS X.

9 Enter the following code into the TextChange event.

If Me.Text <> "" then
ConnectURL.Enabled=True
ConnectURL.Default=True
AddURL.Enabled=True

Else
ConnectURL.Enabled=False
ConnectURL.Default=False
AddURL.Enabled=False

End if

One thing you notice about this code is that the first line uses the pronoun “Me”
instead of the name of the control. “Me” always refers to the control the code belongs
to; since we are inside the EditField, SelectedURL, “Me” refers to SelectedURL. In
other words, this line is the same as if we wrote If SelectedURL.Text....

The last step is to modify the code for the ListBox. This code needs to test whether
the user has highlighted an item before trying to copy text into the EditField. It
also should manage the Delete and Connect buttons. There’s no reason the user
should be able to click Delete if no item is selected.

10 Expand the ListURL item in the Code Editor and select the Change event.
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11

12
13

14

If the
Application
doesn’t run

Modify the code to read as follows:

If Me.Text <> "" then
SelectedURL.Text=ListURL.Text
ConnectURL.Enabled=True
DeleteURL.Enabled=True

Else
DeleteURL.Enabled=False

End if

Save the project.

Choose Debug » Run to test it out.

When you first open the application, you can test the alert messages that you've put
in each PushButton. Then add a URL and see how the application behaves.

When you're finished, return to the development environment.

This section introduces the If...Else...End if statement. The Code Editor automati-
cally indents the code within an If statement to make it easy to check your code. Be
sure that your code is indented as shown in the instructions. Be sure there is an “End
If” statement for each “If” and you didn’t type “Endif” instead of “End if” or “end
if’. Capitalization doesn’t matter, but the space between “End” and “if” does. Also,
check that each line that begins with an “If” statement ends with “then”. You
should not leave a blank space between the double quote marks or between the less
than and greater than signs.

Building A Standalone Application

Building Your
Application

Now that you have a finished version of the application, you're ready to create a
standalone application. The standalone version of the application runs just like the
application you've been testing, but it doesn’t require the REALbasic application
itself. It can be double-clicked from the desktop, just like a commercial application.

The Professional version of REALbasic can create standalone applications for the
Macintosh, Linux, and Windows platforms. The Standard version of REALbasic
builds standalone applications only for the platform on which the REALbasic
application is running. It also allows you to build demo versions for the platforms
on which REALbasic is #of running. A demo version is fully functional but quits
automatically after five minutes.

Building a stand-alone version of your project as an application couldn’t be easier
than it is in REALbasic.

Choose File » Build Application.

REALbasic compiles your project, creates a standalone application, and brings it to
the front window.
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Figure 31. The URL Manager built application icon (Mac OS X).

A

My Application (Mac OS X)

By default, it uses the name “My Application” or “My Application (Mac OS X)” for
the Mac OS X platform and uses your platform’s generic application icon. Both the
name and icon can be customized easily. Also, REALbasic opens the window that
contains the built application and brings it to the front.

2 Double-click the “My Application” icon and try out the program. When finished,
choose Quit to put away the URL Manager and go back to the REALbasic project.
Customizing Before building a standalone application, you can set several options. For example,
the Standalone you can change the application’s name, build for other platforms, set memory
Application requirements for Mac OS 8-9, and some other options. You use the Build Settings
dialog box for this. After choosing your options, the Build Application command
uses your current Build Settings automatically.
1 Choose File » Build Settings.
The Build Settings dialog box appears.
Figure 32. -The Build Settings dialog box.
Build far: [[JMac 05 %
[IMac 05 89 [Classic]
[¥] \windows 98/ME/NT /2000/<P The pop_up menu
(o controls what is
Wersion Information g dlSp|ayed |n the
bottom section of
vesee 177 the dialog box.
Release: | Development ™
Non-release: ’U_
Product Version: ‘
Copyright: ‘
Description: ‘
Region: | United States v
Language: | Diefault [System) v
The top area lists the target platforms for the build. Your choices are:
m Mac OS X

B Macintosh OS 8-9 “classic”— a version of the Mac OS prior to Mac OS X that runs

REALbasic.
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Any version of Windows from Windows 98 to XP Professional.
Linux for an x86 processor with GTK+ 2.0 or greater installed.

By default, the OS that you are currently running is selected. You can build for any
or all the platforms simultaneously.

(Optional) If you want to create standalone applications for other platforms, check
the appropriate “Build For” checkboxes for your target platforms in the top area of
the Build Settings dialog box.

If you're creating a version of the application for a Macintosh platform, choose
Mac OS Settings from the popup menu shown in Figure 32.

The Mac OS Settings panel enables you to enter the names of the Macintosh builds

and set memory requirements for the “classic” build (The Mac OS X application, of
course, manages memory dynamically).

Figure 33. The Mac OS Settings panel.

Build Settings.

Build for: ™ Mac 05 X
) Mac 05 8-9 (Classic)
I windows 98/ME/NT/2000/XP

_ Linux/x86

! Mac O5 Settings b ]
Mac OS X Name: My Application (Mac 05 X)

Mac OS 8-9 Name: My Application

Creator Code: 7777 (" Register }

Memory Settings:
Suggested: | 4096  k
Minimum: (2048 k
Compatibility: ) Mac 05 X only (Mach-0)

@ Mac 05 8-9 and X (PEF)

(lcons... ) ( Cancel )

4 Enter URL Manager as the name of the application for the version of the Mac OS

that you're using.

5 If you're creating a version of the application for Windows, choose Windows

Settings from the pop-up menu.
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N

10
11
12

13
14

Figure 34. The Windows Settings panel.

Build Settings

Buld for: []Mac 05 %
[ Mac 05 84 (Classic]
Windows SB/MENT/2000/%P
[ Linusrs86

Windows Settings =

Application Name: |y Application exe:

[ Multiple Document Interface

Captian:

Enter URLManager.exe in the Application Name area.
Click OK.

If you are creating a version of the application for Linux, choose Linux x86 Settings
from the pop-up menu.

This panel enables you to name the Linux build.

Enter URLManager as the name of the application.

Click OK to save your settings.

Choose File » Build Application.

Quit out of the REALbasic IDE (File » Exit on Windows) or URL Manager » Quit
on Mac OS X).

Double-click the new application and try it out.

If you built versions for other platforms, drag them to those platforms as well.

For example, F‘vi[gure 35 shows the application running under Linux and
Windows XP"".
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Figure 35. The Linux and Windows versions of the URL Manager application.

- X
Eile  Edit
www.realbasic.com
www.4D.com
www.redhat.com
o
[www.realsoftware.com
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il URL Manager rz|
File Edit
v realzoftware. com
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|www.realbasic.com
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What's Next

The QuickStart shows how easy it is to develop a simple application. In the Tutorial,
you build a more elaborate application — a text processor that supports styled text,
creating, opening, and saving files, and printing. It illustrates more REALbasic fea-
tures, including sheet windows and dialog boxes, menus and menu items, writing
and calling methods, and compiling platform-specific code.

With the skills you'll learn in the Tutorial, you'll be able to add a File menu to this
application with Open and Save items that will allow you to save URL lists to disk
and open saved lists. Another way to save URL lists is to use a database. REALbasic

includes a database that can be used for this purpose. It is described in the User’s
Guide.

Also, be sure to check out the REALbasic web site at http://www.realsoftware.com

for other tutorials and how-to’s.
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