User Guide
ScrapX™: Scrapbook for Mac OS X
Version 1.3 (including updates through v1.3.3)

This User Guide has information about using ScrapX 1.3. For instructions on
downloading, installing, registering, and updating ScrapX please see the Read Me
document. For a summary of new features see the What’s New document.

Snapshot of ScrapX 1.3

ScrapX from Aqueous Software LLC is a shareware scrapbook utility built for Mac OS X.
It requires Mac OS X v10.2 (Jaguar) or v10.3 (Panther). As a scrapbook”it allows
content to be collected from diverse sources, viewed (or listened to), annotated, searched
and sorted, and dispensed multiple times. Making ScrapX the premier scrapbook utility
remains our primary design objective, and version 1.3 adds an undo capability, image
zoom, slideshow view, enhanced source information including web page URL and title
when content is dropped from Safari, and simpler opening of URLs in item content. But,
the capabilities added to version 1.3 go beyond those of just a scrapbook and include rich
text editing and creation of text items, and addition of text types.

ScrapX stores, displays, and dispenses content that can be copied and pasted or drag-
and-dropped among Mac OS X and classic Mac OS applications, or that is imported
from classic Mac OS scrapbooks including those created with Scraplt. Content can be
text, images, movies, or sounds. Content is displayed if it is in one of the supported
data formats, which currently include: aGIF (animated GIF), BMP, GIF, HTML, JPEG,
PDF, PICT, PNG, RTF, RTFD, TIFF, URL, plain text, movie, sound, and (classic) sound
resource. Supported movie formats include QuickTime VR (with Panther) and sound
formats include .m4a (AAC) and .m4p (protected AAC). Multi-page or multi-image items
can be scrolled, and movies, sounds, and aGIFs can be "played." Items in supported
formats can be dragged to the desktop to create clippings or exported to files. But,
content with no supported type—Adobe lllustrator images or FileMaker objects, for
example—also can be placed in and dispensed from ScrapX.

Several users have told us that they would like to be able to edit text content within
ScrapX. Therefore, version 1.3 allows rich text to be edited. It also allows text items to
be created and text types to be added to items that have none. These new capabilities
are leveraged by allowing URLSs to be opened in a browser by simply clicking on an icon
that appears in three scrapbook views.

Scrapbooks can be searched and sorted using multiple criteria that now include
checkbox status and with Panther contents of items of type PDF. Items can be
displayed in three views, and presented in slideshows. Even when ScrapX is hidden
"Dropbox views" can be kept on the desktop and content or files dragged to them.
ScrapX 1.3 was localized in French by Ronald Leroux.

YOur criterion for a scrapbook is deceptively simple: moving content within or between applications via
the scrapbook produces the same result as moving it directly. So long as content is not modified, ScrapX
satisfies this criterion with one exception: when FileMaker objects are placed in ScrapX a portion of type
information is excluded so that the objects can be positioned more predictably when they are moved back
to a FileMaker layout.
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Quick Start

The Introductory Scrapbook

The Introductory Scrapbook included with ScrapX 1.3 is provided to illustrate basic
ScrapX features. Use it to try the steps in the Quick Start. The scrapbook is "locked"
and therefore is read-only. But, changes to it can be saved to a copy by using the File
> Save As... command.

Note: In ScrapX documentation ">" means "then select." For example, "File > Open"
means: go to "File" in the Menu bar, then select "Open."

Open ScrapX

1. Open ScrapX as you would any application: if there is a ScrapX icon in the Dock,
click on it. Otherwise, double-click on the icon for the ScrapX application.

The Introductory Scrapbook will open automatically the first time a major release of
ScrapX is opened; thereafter, the selection in the "Launch" section of the User
Preferences will determine which scrapbook opens. To open a particular scrapbook
use the File > Open, File > Open Primary Scrapbook, or File > Open Recent
commands. Or, double-click on the icon for a scrapbook. To import a classic Mac OS
scrapbook to ScrapX, including one created with Scraplt, use the File > Import Classic
Scrapbook command. ME"! You also can initiate import with the File > Open
command or by dragging a scrapbook onto the ScrapX icon in the Dock.

Note: You can use the trial form of ScrapX 1.3 to open scrapbooks saved with any
version of ScrapX. However, only the first ten items in the scrapbook will be displayed.
With the trial form up to two scrapbooks can be open simultaneously. These and other
limitations are removed when a Registration Key is entered.

Change ScrapX Views

2. Use the View Selector buttons—see the illustration below—to switch among the
Combined, Item, and Thumbnail views. Or, select a view under View in the Menu bar.
As the name implies, Combined view includes elements of the Item and Thumbnail
views.

Note: A User Preference determines which view is displayed when a scrapbook is
opened.

3. Resize a view by dragging the Resize handle that is in the lower-right corner of the
view. In the Combined and Item views this will resize the Item Window; in the
Thumbnail view it will resize the Thumbnails Window and change the thumbnail size.
(Thumbnail size changes in steps.)

Note: A User Preference determines the Thumbnail size displayed when a scrapbook is
opened.
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4. Select the Dropbox view by clicking on the yellow (minimize) button in the upper left
corner of a Combined, Item, or Thumbnail view. Or select the Dropbox view under
View in the Menu bar. Dropbox view is a miniature window that floats above all other
windows and, depending on how User Preferences are set, can be left on the desktop
even when the ScrapX application is hidden. It is qualitatively different than the other
views in that content can be dropped onto it, but not pasted to it or moved from it. See
the "Dropbox View" section of the Views chapter for additional information.
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Combined View with names of specific areas.

Switch back from Dropbox view by clicking on the green (maximize) button on the
Dropbox view. Or select the Combined, Item or Thumbnail view under View in the
Menu bar.

Note: A Scrapbook's Dropbox Mode must be enabled in order for Dropbox view to be
selectable. Enable Dropbox Mode by selecting View > Enable Dropbox Mode; disable
Dropbox Mode by selecting View > Disable Dropbox Mode. A User Preference allows
Dropbox Mode to be enabled automatically when new scrapbooks are created.
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Navigating Among Items

5. Move between items in the Combined or Item views by using the Item Selector slider
or arrow buttons. Or, in these views or the Thumbnail view, use the left (or up) and right
(or down) arrow keys to move to the previous and next item, respectively. MEW! Or, use

#-home and #-end to go to the first and last items in the scrapbook.

Dispensing Scrapbook Content

6. Open a new document in TextEdit. Now, go to the first item in the Introductory
Scrapbook and move a copy of the item from ScrapX to TextEdit. While in the
Combined, Item, or Thumbnail view, either:

» Make ScrapX the active application and select Edit > Copy (or press #-C); this
copies the item to the clipboard. Now paste the content into the TextEdit
document by going to the TextEdit window and selecting Edit > Paste (or pressing
#-V); or,

» Drag-and-drop the item from ScrapX onto the TextEdit document.

7. Export an item's content to a file. Select Export... under the Iltem menu. The format
of the file that is created will depend on the type selected at the time Export... is
selected. Therefore, if an item has more than one supported type, first select the type
you want to export. (This command is disabled in the trial form of ScrapX.)

Placing Content in ScrapX

8. Add an item to the scrapbook by reversing the processes in Step 6, above. While in
the Combined, Item, or Thumbnail view, either:

« Highlight some content in an application and select Edit > Copy to move the
content to the clipboard. Then in ScrapX select Edit > Paste to place the content
into a new item; or,

» Drag-and-drop content from an application onto an Item or Thumbnails Window; or,
» Copy and paste or drag-and-drop a file onto a ScrapX window.
Content or files also can be dropped onto a Dropbox view.

When content is dropped on ScrapX from Safari (pasting and other web browsers are
not supported at this time) the URL of the web page is placed in the Source field and
the page title is put in the Memo field.

When a file is dropped on ScrapX the filename is placed in the Source field. The path
to the file appears in a tooltip and the file can be found by selecting the Show Source
in Finder command either in the Source menu or in the contextual menu that appears
when the mouse button is pressed while the cursor is over the word "Source" in the
Combined or Item view.

Note: By default, the new item will be positioned immediately before (in front of) the
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current item. But, a User Preference determines whether new items will be inserted
before or after the current item, or at the beginning or end of the scrapbook.

9. Duplicate the current item using the Edit > Duplicate Item command.

10. Delete the current item using the Edit > Clear command or pressing the delete key.

11. Undo a change with the Edit > Undo command. Most changes to item content can
be undone. If no prior changes can be undone the Undo selection will be grayed out.

Understanding Item Information

12. Inspect the Item Information section of the Combined and Item views. It contains
the following fields:

* Item: the position of the current item and the number of items in the scrapbook.

MEW! « Checkbox: a checkbox used to mark an item. Checkbox status can be used as a

criterion when doing a Search or Sort, and can be used to select the items
included in a Slideshow.

*» Memo: a field that can be used to name, annotate or store keywords for a
scrapbook item. If content was dropped onto ScrapX from Safari, the title of the
web page is placed in the Memo field.

» Type: an item's supported data types that ScrapX can use to display the item and
the unsupported types, if any.

Note: For new items a User Preference determines whether ScrapX loads all the
types available on the clipboard or only supported types. A second User
Preference determines whether unsupported types are listed individually.

* Size: the memory size, pixel dimensions, and/or playing time of an item.
» Date: the dates and times an item was created and modified.

» Source: a filename if the item was created by dropping a file onto ScrapX or the
URL of the web page when content was dropped from Safari. In the former case,
the complete path to the file is displayed in a tooltip when the cursor is positioned
over the word "Source" in the Combined or Item view.

Note: The caption that appears in the Thumbnail view is based on the Memo field or, if
the Memo field is empty, on the Source field.

13. While in the Combined or Item view edit the Memo field by clicking in the Memo field
or by pressing the tab key. While memo editing is enabled the Memo field is outlined in
blue and the cursor is the shape of an I-beam. As you type, the up, down, left or right
arrow keys can be used to scroll the Memo field. When your entry is complete, press
the return key or click in the Item Window. Moving to a new item also will disable memo
editing. MEW! Pressing the esc (escape) key will disable memo editing without saving
any changes made to the Memo field.
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Viewing and Changing Type Information

14. In the Combined and Item views, the type being displayed is bolded in the type list.
By default, an item's Primary type is displayed, but an item can be displayed in any of
the supported types by clicking on a type. The Primary type is the default type that
ScrapX will use to display the item; it is the first to be encountered in the list: movie,
sound, sound resource, TIFF (including BMP, GIF, JPEG, and PNG), PICT, PDF,
HTML, RTFD, RTF, URL, and plain text. See the illustration below for an example.

Note: In the Thumbnail view the item's Primary type is always displayed.

Note: Changing how an item is displayed does not change the item itself. The result of
copy and paste or drag-and-drop from ScrapX is unaffected by which supported type is
displayed.
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Example of How Selection of "Type" Affects Display of an Item. The lower right image
shows a ScrapX item that has three supported types: RTFD, RTF, and plain text. It is displayed
as RTFD, which is the Primary type. In the center image the "RTF" type has been selected, so
only the text appears but it is formatted. In the top left image the "plain text" type has been
selected. Again only text appears, but in this case the font is the default plain text font and text
alignment has been lost. (The original content was created with TextEdit.)
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15. Use the three type stripping commands under Item in the Menu bar to remove
unwanted type information. For example, in the "Misty River" item in the Introductory
Scrapbook delete all types except PICT by selecting the PICT type and then selecting
the Item > Strip Other Types command. Because the content has been modified, a
"modified date" is appended to the Date field.

Caution: This type stripping capability is provided to make it possible to move content to
an application that would not accept it with all of the original type information. The strip
commands can be reversed with the Undo command, but it is recommended that you
duplicate an item before using the stripping commands.

Viewing Item Content

16. In the Item Window of the Combined and Item views images are displayed at actual
(100%) size unless they must be reduced to fit the window. Change the zoom level for
an image type using the controls in the image tool strip. Select a size from the pop-up

menu or click on the "+" and "-" magnifiers.

17. Use the scroll bar in the Item Window of a Combined or Item view to view a multi-
screen item. When they are needed, scroll bars appear with image, HTML, RTFD, RTF,
URL, plain text or PDF types. A multi-screen aGIF and multi-screen or multi-page PDF
items can be scrolled using arrow buttons in the tool strip. For these items you also can
use the page up or page down key to jump to the previous or next frame or page, and
the home or end key to jump to the first or last frame or page.

18. Play a movie or sound using the control bar in the Item Window of the Combined or
Item view. For an item of type: sound resource click on the Play button. To play an
aGIF click on the Play button, or to step through the component images, use the
controls in the tool strip.

19. Change the position of an item in the scrapbook. In the Thumbnails Window of the
Combined or Thumbnail view select the item you want to move and drag it to a new
position. You can move an item to any position in the scrapbook, including the first or
last.

20. Navigate to an item for which Open URL tool (the globe icon) in the Combined, Item,
or Thumbnail view appears blue/green, and click on it to open the URL in a web
browser. (The URL must be in an URL type; if an item does not have an URL type the
globe will be gray.)

Text Editing and Related Operations

21. While in the Combined or Item view, select a portion of text in an item of type HTML,
RTFD, RTF, URL, or plain text by clicking on the I-beam tool in the text tool strip. The
cursor will change to an I-beam shape. Select a segment of text, then copy and paste
or drag-and-drop it to another application or drag-and-drop it to the desktop. To disable
text selection click again on the I-beam tool or select the Item > Disable Text Selection
command. You also can disable text selection by moving to a different item, clicking on
a thumbnail, or pressing the esc (escape) key.

22. While in the Combined or Item view, edit text in an existing item. Text can be edited
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in the types HTML, RTF, URL, or plain text. When one of these types is selected a text
tool strip appears at the bottom of the Item Window. To enable text editing click on the
"T" tool in the tool strip or select Item > Enable Text Editing. Existing text can be
edited from the keyboard, by using tools in the text tool strip, by making selections in the
Text menu, or by pasting or dropping text from another source or by dropping a text
clipping. However, while text editing is enabled it is not possible to insert an image or
other "attachment," or to drop a file or a picture clipping into the item.

Note: ScrapX 1.3 does not allow text to be edited in an item that has the RTFD type. To
edit text of type RTFD, or to insert an image into text of type RTF or plain text, move the
item to TextEdit or an other word processing application.

Disable text editing by clicking on the "T" tool in the tool strip or selecting Item >
Disable Text Editing. Text editing also can be disabled by moving to another item,
clicking on a thumbnail, or clicking in the Memo field. Pressing the esc (escape) key will
disable text editing without saving any changes.

When text editing is disabled ScrapX determines the appropriate text type(s) for the
item and updates the Type field. To avoid potential incompatibilities, it also strips all
unsupported types. Because the content has been modified, a "modified date" is
appended to the Date field. These steps will occur when text editing is disabled even if
the content was not changed.

Note: If it is important that a text item be edited without the unsupported types being
stripped, edit the item in the application used to create the content.

23. While in the Combined or Item view, add a text type to an existing item that does not
include any by selecting the Item > Add Text Type command. A plain text type will be
added and text editing will be enabled. Text can be inserted and edited, and when
editing is disabled the type(s) will be determined as described in step 22, above.

24. Create a completely new item of the type: plain text by selecting the Edit > Create
New Item command. An item will be inserted into the scrapbook and text editing will be
enabled. Text can be inserted and edited as described in step 22, above.

Searching and Sorting

25. Search, sort, or randomize the items in a scrapbook by selecting the appropriate
command under the Scrapbook menu while in the Combined or Item view. Criteria for
searching and sorting can be based on the checkbox status, content of any of the Item
Information fields, or on the text content in items of type HTML, RTFD, RTF, URL, plain
text, or MEW! PDF when running Panther. Sort criteria can be retained and used to
keep a scrapbook sorted.

Slideshows

26. Present the content of a scrapbook in a slideshow format by clicking on the
Slideshow button in the Combined or Item views. This is the button with circular arrows
located to the right of the item selector buttons. Or, while in Combined, Item,
Thumbnail, or Dropbox view select View > Play Slideshow. Movies and sounds are
not included in slideshows; sound resources are.
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Slideshows use a Slideshow view that displays full size content against a background
color that fills the entire computer screen; all desktop images are hidden. When the
slideshow ends ScrapX will return to the view that was active when the slideshow was
started. Pause and restart a slideshow by pressing the spacebar. While a slideshow is
paused the page up, page down, home, and end keys can be used to scroll an item.
End a slideshow by pressing any key except those that have a specific slideshow
function, or by clicking in the background area.

Several options are available for display of slideshows, including manual operation; see
"Slideshows" in the More About Selected Operations chapter and "Slideshow View" in
the Views chapter.

User Preferences

27. To set User Preferences select ScrapX > Preferences from the Menu bar. For
more information see the User Preferences chapter.
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More About Selected Operations

Moving Content to and from ScrapX

As noted earlier, with one exception, moving content within or between applications via
ScrapX produces the same result as moving it directly. The exception involves
FileMaker objects. When they are placed in ScrapX a piece of type information is
excluded so that when the objects are put on a FileMaker layout they can be positioned
more predictably.

How Content is Moved. Content can be moved between an application and ScrapX
either by copying and pasting or by drag-and-dropping. You can depend on the
following:

* The result of copying and pasting from one application to another is the same as
the overall result of copying and pasting from the first application to ScrapX and
then from ScrapX to the second application.

* Likewise, the result of drag-and-dropping from one application to another is the
same as the overall result of drag-and-dropping from the first application to ScrapX
and then from ScrapX to the second application.

However, with some applications the result of copying and pasting may be different than
the result of drag-and-dropping. If you get an unexpected result when dragging content
from ScrapX to an application, try it again but use copying instead, or vice versa.

Other apparent exceptions might be encountered. Some of these are explained in the
section "Fine Points About Moving Content" at the end of this chapter.

Pasting or Dropping Files and Clippings to ScrapX

Files in supported formats can be copied and pasted or drag-and-dropped to ScrapX;
the contents will be inserted as new items and filename will be placed in the Source
field. This method can be used with files in formats corresponding to the supported
types plus others that are displayable as supported types:

» the QuickDraw image format .pct or .pict, which is displayed as type: PICT.

* the image formats .tif, or .tiff, plus .qtif (QuickTime image). All are displayed as
type: TIFF.

* the image formats .bmp, .gif, .jpg or .jpeg, and .png, which are displayed as types:
BMP, GIF or aGIF (animated GIF), JPEG, and PNG, respectively. The format .jfif
also is displayed as type: JPEG.

» the EXIF data format (used by many digital cameras for JPEG compression), which
is displayed as type: JPEG.

* the plain text formats .txt or .text, plus .xml, which are displayed as type: plain text.
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* the hypertext format .htm or .html, which is displayed as types: HTML and plain
text. (When text is selected the html source is displayed.)

« the rich text format .rtf, which is displayed as types: RTF and plain text.

* the rich text with attachments format .rtfd, which is displayed as types: RTFD, RTF
and plain text.

* the portable document format .pdf, which is displayed as type: PDF.

* the movie formats .mov or .moov, .movie, .mpg or .mpeg, .mp4, and .qt, which are
displayed as type: movie unless there is no image, in which case they are
displayed as type: sound. With Panther, support for the .mov format includes
QuickTime VR.

* the sound formats .aif or .aiff, .au, .m4a (AAC) and .m4p (protected AAC), .mp2,
.mp3, .snd, and .wav, which are displayed as type: sound.

» the classic sound format "snd", which is displayed as type: sound resource.

Clippings can be copied and pasted or drag-and-dropped to ScrapX; the contents will
be inserted as new items and filename will be placed in the Source field. This method
can be used with:

* the picture clipping format .pictClipping are displayed as the type: PICT plus the
type corresponding to the format of the original image. For example, a picture
clipping created from a GIF is displayed as the types: GIF, PICT.

* the text clippings format .textClipping are displayed as the type: plain text, and also
will include the type: RTF if they were created from styled text.

» the sound clippings format .sndClipping are displayed as the type: sound resource.

Note: Files in proprietary formats cannot be dragged to ScrapX. However, content
can be copied and pasted or drag-and-dropped to ScrapX from applications that use
proprietary formats.

Drag-and-drop even can be done with multiple files or with folders, in which case an
item is created for each file. Normally, a block of items is inserted according to the User
Preference for new items; within the block items are ordered alphabetically by filename.
However, if "Keep Sorted" is checked in the Sort panel the files will be inserted
according to the retained sort criteria.

Note: When an item created by dragging a file onto ScrapX is subsequently moved to
an application, the result is the same as when the file is dragged directly to the
application. (At least it is if the application will accept files dragged to it.)

Slideshows

Displaying the current scrapbook in slideshow format is as simple as clicking the
Slideshow button on the Combined or Item view or selecting the View > Play
Slideshow command. Slideshows are displayed in the Slideshow view; slides are the
size of the Item Window in the current Combined or Item view and are centered on a
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colored background. By default, the slideshow includes all of the items in the scrapbook
except movies and sounds, and uses default slideshow settings. See the Slideshow
Settings section below to learn how to customize the way the slides are displayed.

The slideshow operates and can be controlled as follows:
* The slideshow starts with the current item.

* A slideshow is paused and restarted by pressing the space bar. While a slideshow
is paused, slides can be manually advanced with the right or down arrow keys and
reversed with the left or up arrow keys. Pressing #-home or Z-end will move to
the first or last item, respectively. It is possible to move scroll bars and to "play”
items of type aGIFs and sound resource. Page up, page down, home and end
keys also can be used to scroll items. (Changes to display settings made while in
the Slideshow view are not retained.)

* Pressing any key except those that have a specific slideshow function ends the
slideshow and returns the scrapbook to the view being used when the slideshow
was started. Clicking the slideshow background also will end the slideshow.

Slideshow Settings. Slideshow settings determine how the slideshow operates for a
particular scrapbook. The settings are selected in a two step process. Default
slideshow settings for all new scrapbooks are selected in the Slideshows section of the
User Preferences. Second, slideshow settings for an individual scrapbook are selected
in the Slideshow Settings panel. This panel is opened by selecting the Scrapbook >
Show Slideshow Settings command. Initially this panel is populated with the default
settings from the User Preferences, but any of the settings can be changed and made
unique to the particular scrapbook. The following illustration shows a Slideshow
Settings panel.
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) Only Checked Itermns 7 item Number
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The Slideshow Settings panel includes the same list of options in the Slideshows User
Preferences, but has four additional buttons:
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Advance Each [ ] Seconds: select a value between 0 and 60 seconds; the default
is 2 seconds. If 0 seconds is selected the slideshow will be run totally under manual
control.

Items Displayed: Determines which items will be included in a slideshow:
All ltems: if selected, all items in the scrapbook will be included.

Only Checked Items: if selected, only items with a check in the checkbox will be
included.

Note: In either case, movies and sounds will not be included in slideshows.
Loop Continuously: if checked, the slideshow will run until it is stopped manually.
Background Color: used to select the slideshow background color.

Captions: if any of the captions options is selected captions will be displayed in a
white border around the slides.

Scrapbook Name: if checked, the scrapbook name will be displayed in the
border above each slide.

Iltem Number: If checked, the Item number will be displayed in the border under
each slide.

Memo or Source Field: if checked, the content of an item's Memo field will be
displayed in the border under each slide. Or, if the Memo field is blank, the
content of the Source field will be displayed.

The buttons on the Slideshow Settings panel are:

Revert to User Preferences: clicking this button makes the selection of options
match those currently selected in the Slideshows section of the User Preferences.

Cancel: closes the panel without saving changes.
Save Settings: closes the panel and saves the slideshow settings.

Play Slideshow: closes the panel, saves the slideshow settings, and starts the
slideshow.

Note: The Play Slideshow button will be grayed out if it is not possible to play a
slideshow. For example, the button will be grayed if the option: "Only Checked
Items" is selected but no items in the scrapbook are checked.

Customizing Slideshow Settings. ScrapX capabilities that have nothing to so with

slideshows per se can be used to further customize slideshow presentations. For
example:
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* Images can be zoomed and scrolled and these display settings will be retained in
the slideshow and saved when the scrapbook is saved. (However, changes to
display settings made while in Slideshow view are not saved.)

* Only some of the items in a scrapbook can be included in the slideshow. This can
be done manually by checking the checkboxes of the items to be included. Or, to
include only the image type items, a search can be done for image types and then
the commands in the Scrapbook menu can be used to check the checkboxes of
the found set.

Operations with Movies and Sounds

Results of some operations with movies and sounds are different than with other
supported types. The most significant difference is that items of type: movie or sound
(but not sound resource) are not portable. That is, if a scrapbook with movies or sounds
is moved to another computer those items don't go along. This is because items of type
movie or sound item have only references to the movie or sound; the complete content
is not copied into the scrapbook.

If a reference to a movie or sound file is broken because the file has been moved or
deleted, an image representing a broken link appears in the Item and Thumbnail
windows. If the file is put back in the referenced location the movie or sound again
becomes playable.

Certain operations with movies or sounds also produce unique behaviors:

« If you drag content onto an Item Window currently displaying a movie you must
drop content outside the image area for the current movie (watch for the "+" to
appear next to the cursor). Otherwise, the new content will not be inserted.

» Movies or sounds can be copied and pasted or drag-and-dropped between
FileMaker Pro container or AppleWorks database multimedia fields and ScrapX.
Dragging sound files to ScrapX also will create items that are playable sounds.
However, although you can copy and paste or drag-and-drop items of type: sound
between other applications and ScrapX you may not end up with an item in which
the sound is playable.

» Only a movie or sound that is the current item can be played; if a movie or sound is
playing when you move to another item in the same scrapbook the movie or sound
stops. However, movies or sounds in different scrapbooks can be played
simultaneously and the volume for each set independently. (If a sound is playing
when a scrapbook is switched to Dropbox view or when ScrapX is hidden it will
continue playing.)

Operations with Web Browsers and URLS

When an item includes an URL type and the URL begins "http://" or "https://" it is
possible to open the URL directly from ScrapX by clicking on the Open URL tool (globe
icon) in a tool strip or on a thumbnail.
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Methods for opening URL that worked in earlier versions of ScrapX also still can be
used with v1.3. Results will depend on which browser is used:

» Dragging the "@" or other symbol in the address line of the browser to ScrapX will
cause an item of type: URL to be created. If this item is dragged back to a browser
window (and in some cases to the address line) the browser will open the page
specified by the URL.

» Dragging a link that is in the form of an image or text from a browser to ScrapX
creates an item that includes the type: URL. Dragging this item to a browser
window will open the target page.

MEW! \When content is dragged (not pasted) from Safari to ScrapX the URL of the web page is

MHEW!

put in the Source field and the page title is placed in the Memo field.

Note: If the content is text, Safari must be the frontmost application. Because there is a
very brief delay between when ScrapX receives the content and when ScrapX receives
the web page URL and title, ScrapX will not record the web page information correctly if
the Safari window is closed before the URL is logged.

The URL can be opened using the Open Source URL command in the Source menu
or in the contextual menu that opens when the cursor is placed over the word "Source"
and the mouse button is pressed.

Note: ScrapX stores URLSs. in two places. A URL that is part of an item is stored as a
URL type and can be opened by clicking on the globe icon that appears in the
Combined, Item., and Thumbnail views. If content was dropped from a Safari page,
then the URL of the page is placed in the Source field (and the title of the page is placed
in the Memo field). This URL can be opened using the Open Source URL command.

Operations with Text

ScrapX 1.3 allows four kinds of text operations:

» Selecting a portion of text in an existing item of type HTML, RTFD, RTF, URL or
plain text;

* Rich text editing in an existing item of type HTML, RTF, URL, or plain text;
» Adding the plain text type to an item with no text types; and
* Creating a new item with the plain text type.

These operations, and combinations of them, are possible only when in the Combined
or Item view.

Selecting Text. Enabling text selection allows a portion of the text in an item of type
HTML, RTFD, RTF, URL, or plain text to be copied or dragged from the item. When
any of these types is selected, text selection is enabled by clicking the I-beam tool in the
text tool strip or by selecting the Item > Enable Text Selection command. When text
selection is enabled the I-beam tool in the text tool strip has a blue glow and the cursor
changes to an I-beam and a portion of text can be selected complete with formatting
information. Selected text then can be copied or dragged.
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Note: Text selection is performed on the selected type. By contrast, text editing is done
on the RTF type if present, and otherwise on the plain text type.

Text selection is disabled by clicking on the I-beam tool in the text tool strip or by
selecting the Item > Disable Text Selection command. Text selection also can be
disabled by moving to another item, clicking on a thumbnail, changing to the Thumbnail
or Dropbox view, or pressing the esc (escape) key.

Note: Pressing the esc (escape) key disables text selection, but does not undo any
operations completed while it was enabled.

Editing Text. Text in an existing item of type HTML, RTF, URL, or plain text (but not
RTFD) can be edited and formatted by selecting one of those types and then enabling
text editing by clicking the "T" tool in the text tool strip or by selecting the Item > Enable
Text Editing command. Regardless which type is selected when text editing is
enabled, editing is done on the RTF type if present, and otherwise is done on the plain
text type. While text editing is enabled the Item Window is outlined in blue (or at least
the sides of it are), the "T" tool has a blue glow, and the cursor changes to an I-beam.
Editing and formatting is done using the tools in the text tool strip or the commands in
the Text menu. Text editing can be enabled only when in the Combined or Item view.

Note: To edit text in an item with the RTFD type move it to an application like TextEdit.

Note: When text editing is enabled it is possible to select a portion of the text in an item
and copy it or drag it to another application or to the desktop. However, use of the text
selection capability will ensure that the item's content is not changed inadvertently.
When editing is complete, text editing can be disabled by clicking the "T" tool or
selecting the Item > Disable Text Editing command (or pressing #-G). Text editing
also can be disabled by moving to another item, clicking on a thumbnail, or clicking in
the Memo field. Pressing the esc (escape) key will disable text editing without saving
any changes. When text editing is disabled supported types are updated, unsupported
types are stripped, the Thumbnail is recreated, and a Modification Date is added even if
the item has not been changed.

Note: Unsupported types are stripped when text editing is disabled. This is done to
ensure that none of an item's type information becomes inconsistent as a result of the
edit. If it is essential that unsupported types be retained, edit the content in the
application used to create it.

Adding a Text Type. The command Item > Add Text Type (or shift-5-T) adds the
type plain text to the current item and enables text editing. This operation is possible
only if an item has no text type.

Creating a Text Iltem. The command Edit > Create Text Item (or shift-2-N) creates a
new item of type plain text and enables text editing. The message "Created in ScrapX"
is placed in the Source field. Content can be entered from the keyboard, or by pasting
or dropping text from another item or another application, and can be formatted using
commands in the Text menu or tools in the text tool strip. It is not possible to drop a file
or a clipping into the item or to insert an image or other "attachment.”
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Searching a Scrapbook

To search the current scrapbook, select Scrapbook > Search (or #-F). Construct up
to five (5) search criteria (two if a Registration Key has not been entered) by selecting
from among ME"! checkbox status, content of any of the Item Information fields, or the
content of text in items of type HTML, RTFD, RTF, URL, plain text, or ME"!! PDF when
running Panther. For each criterion select a Condition and, depending on the Condition,
a Value. See the table below for a complete list of Conditions.

Search current scrapboak for
Content ) (Contains %) | chicago SIe
All T! Type "2"] Includes "1': IPEG ¥ il- —
Date Tj Is After T! Monthis 17, ::l' -
%) Create Mew Scrapbook with Results
) View Results in Current Scrapbook
(_Clear Crieria ) (Cancel ) (Search:

Hint: If the criterion for text content is entered entirely in lower case, then both lower
case and upper case content satisfies the criterion. If the criterion is entered in upper
case, then only upper case content does.

When at least two criteria are specified, they can be linked by "All" or "Any" meaning
that all of the criteria must be satisfied, or that any of the criteria can be satisfied. "All"
is the default. Check the "Retain Search Criteria" box if you want to use the same
criteria for another search.

Next, select a radio button to determine whether search results will be viewed within the
current scrapbook or in a new scrapbook. If you want to edit some of the items, viewing
within the current scrapbook is the better choice. For example, you can search for
items that have an empty Memo field, then edit the Memo field for each item in the
found set. If you want to copy all items with certain characteristics, for example, all that
are images, then viewing search results in a new scrapbook may be the better choice.

When the criteria are ready click the "Search"” button. Results will be displayed in the
Combined view. If all items are found, or if none are found, you will be given the option
of modifying the search criteria or of canceling the search.

Note: Search results consist of the items that satisfy the search criteria. "Hits" within
items are not highlighted.

When results are viewed in a new scrapbook, the title bar will contain the name:
"<original name> Search Results" and if you select File > Save or File > Save As... this
will be the default name. Otherwise, the new scrapbook acts exactly like any other
scrapbook and all commands are available.

17 of 54 ScrapX 1.3 User Guide



Conditions for Search Criteria

Field Condition Value
Content, Memo, or Source Contains Enter string*
Does Not Contain
Is Exactly
Is Empty (none)
Is Not Empty
Type Includes Select from:
Does Not Include Movie
Sound
Image
BMP
GIF
JPEG
PDF
PICT
PNG
TIFF
Text
HTML
Plain Text
RTF
RTFD
URL
Unsupported
Size Is At Least Enter number | Select from:
Is At Most Bytes
KB
MB
Date Is Today (none)
Is Exactly Select: month, day, and year
Note: "Mod" date is not Is Before
included in searches or sorts. Is After
Checkbox Is Checked (none)
Is Not Checked

When results are viewed within the current scrapbook, the found set remains
accessible, but the omitted items are grayed out and cannot be selected. Also, three
tools appear above the thumbnails: Found, Omitted, and All. The grayed out items and
the tools are indications that the scrapbook is in "Search Mode." While the scrapbook is
in Search Mode items can be copied or dragged from it, but not to it.

Found 3 items

R =

| Found  Omitted All

1 @
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By clicking the first two tools, items in either the Found set or Omitted set can be made
active. Active items are editable, and the active set can be saved by doing a Save As...
(Doing a Save while in Search Mode saves the entire scrapbook.) Clicking on the All
tool closes Search Mode and makes all items in the scrapbook active.

Sorting a Scrapbook

To sort the current scrapbook, select Scrapbook > Sort (or #-R). Construct up to
three (3) sort criteria (one if a Registration Key has not been entered) by selecting from
among MEW! checkbox status, content of any of the Item Information fields, or the
content of text in items of type HTML, RTFD, RTF, URL, plain text, or ME!! PDF when
running Panther. For each criterion select an order: Ascending or Descending.

St current scrapboak by

Mamo :| in | Ascending :| order + j
Content  F#) in [Ascending 8 order (%) (=
_ Keep Sored

(_Clear Criteria ] (Cancel ) {EiSon)

To retain the sort order check the "Keep Sorted" box. When this box is checked the
retained sort criteria will override the User Preference for insertion of new items and be
used to order new items placed in the scrapbook or to re-order items that are modified.

When the criteria are ready click the "Sort" button.

After the "Sort" button has been clicked, a check will appear in front of the Keep Sorted
command in the Scrapbook menu (and the command no longer be grayed out). When
you no longer want to use the retained sort order, select the Scrapbook > Keep Sorted
command to uncheck it. (Or, uncheck Keep Sorted on the Sort panel.)

Display Settings

"Display settings" are the user-determined details about how a scrapbook and the items
in it are displayed. Examples of scrapbook display settings are the view and its position
on the computer screen. Examples of display settings for individual items are image
zoom setting, selected type, and scroll position. Several display settings are "retained,"
meaning that so long as the scrapbook is open they are not reset except by selecting
the Item > Initialize Display Settings or Scrapbook > Initialize Display Settings
commands. In addition, several display settings are saved along with item content
when a scrapbook is saved. Display settings are saved for:

* which item is the active or current item, the size and location of windows, and
whether Dropbox Mode is enabled; and
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* the checkbox status, item types selected, play positions and volume settings of
movies and sounds, image zoom levels, Fit Window/Fit Width selection for PDFs,
page/frame selection for PDFs and aGIFs, and scroll positions of each item in the
scrapbook.

When a scrapbook is opened, the saved display settings can be used, but they do not
have to be. This depends first on the selection made for display settings in the Launch
section of the User Preferences. There are three choices: Retain, Initialize, and Ask.
"Retain" means the saved display settings are always used when a scrapbook is
opened, and "Initialize" means the display settings are always initialized. "Ask" means
just that: when a scrapbook is opened the user is asked whether to Retain or Initialize
display settings for that scrapbook. "Retain" is the default selection.

Fine Points About Moving Content

As noted above in the section on Moving Content to and from ScrapX, there are
apparent exceptions to the generalization that moving content within or between
applications via ScrapX produces the same result as moving it directly. We stress the
word "apparent” because in all circumstances that we know of the unexpected
behaviors result because 1) content has been modified, or 2) the applications display
content differently than ScrapX does.

Operations with Modified Items. Content can be modified in ScrapX using commands
for type stripping, text editing including appending, text type addition, and text item
addition. It also can be modified when new items are created if the "Load Only
Supported Types" option is selected in the User Preferences. Items with modified
content can be identified by the "Mod. Date" appended to the Date field.

First it is important to realize that unexpected behavior exhibited by items with modified
content is not an exception to ScrapX operating as a true scrapbook. Basically,
operations that modify content void the comparison of moving content between
applications via ScrapX with moving it directly.

Nevertheless, the unexpected behaviors using modified content can be real enough.
So it is useful to understand what causes them. Usually they can be traced to the type
assignments. When content is moved to ScrapX the type information for the new item
is taken from the clipboard; these are the types declared by the application that is the
source of the content. If the item is not modified, the same list of types is put back on
the clipboard when content is moved from ScrapX. However, if an item has been
modified in ScrapX the type list is updated and might not be understood even by the
application originally used to create the content. This risk is particularly great if text
editing has been enabled and disabled (even if no changes were made). In that case
ScrapX has had to determine for itself which text types are present, and it has stripped
all unsupported types. The good news is that it is easy to work around unexpected
results that result from modified content: move unmodified content and make changes
in the destination application.

Special cases of modified content occur in two situations:

» Content is modified when a portion of text is selected from an item and moved. In
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that situation ScrapX copies only the HTML, RTF, URL, and plain text types to the
clipboard. Other supported types and all unsupported types are omitted.

» When content is placed on the clipboard OS X adds certain type information in
order to maintain compatibility of the content with OS 9 applications. For example,
if only the RTF type is present, the plain text type gets added, and certain
unsupported types also get added.

Other Special Cases. Generalizations not withstanding, experimentation may be
necessary to achieve the result you want. Not all applications handle data in exactly the
same way, so not all file formats and not all applications produce the expected result.
For example:

* When an item's content is moved from ScrapX to an application window, how the
content is displayed will depend on the capabilities of the application and on how
the application decides to display the content. It also might depend on how the
item is moved from ScrapX to the application—whether by copy and paste or drag-
and-drop.

» Sometimes it may be possible to influence how an application displays the content.
For example, if an image is drag-and-dropped from a web browser to ScrapX an
item is created of type: PICT, URL, plain text. If this item then is drag-and-dropped
into a container field of a FileMaker Pro database, an image is displayed.
However, if it is drag-and-dropped into a text field, an URL is displayed.

* When a ScrapX item's content is moved to an application other than the one in
which it was created, types not supported by the second application will be lost.
This is a function of the applications, not of ScrapX; information that would be lost
by moving content directly between applications also will be lost if it is moved via
ScrapX.

For example, if an item of type: PICT, URL, plain text is drag-and-dropped onto a
Photoshop Elements 2 window, and that content then is drag-and-dropped to
ScrapX, the item created is of type: PICT (only). The URL and text information is
lost because Photoshop Elements 2 does not support it. Likewise, if the image is
drag-and-dropped from the browser window directly to Photoshop Elements 2 and
the content then is drag-and-dropped to ScrapX, the new item is of type: PICT
(only).

* Occasionally, unsupported types may interfere with an item's content being moved
to an application other than the one in which it was created. In these cases it may
be useful to strip the unsupported type information. For more about stripping type
information see the Commands chapter.

Also see "Operations with Movies and Sounds" and "Operations with Web Browsers

and URLs" for unique behaviors with these item types. See the Known Issues chapter
for examples of anomalous behaviors seen with ScrapX and particular applications.
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Views

"Views" are ScrapX windows designed to accept, display, and/or dispense content.
ScrapX has five views: Combined, Item, Thumbnail, Dropbox, and MEw! Slideshow.
The first three can perform all three functions. Dropbox view can only accept content,
and Scrapbook view can only display it.

For a given scrapbook one view can be active at any time, but a different view can be
active for each open scrapbook. The view for a given scrapbook can be selected from
the View menu. The View Selector buttons also can be used to switch among the
Combined, Item, and Thumbnail views. This chapter describes the features and
advantages of each view.

Note: A User Preference determines which view is selected when a scrapbook is
created or opened.

ltem View

Item view is like the window in classic scrapbook. It has three sections, which top-to-
bottom are: the Item Window including the Tool Strip, Item Selector, and Item
Information. Details of the last two sections are discussed at the end of this chapter.
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In the Item Window the item is displayed in one of the supported types or, if there is
none, a question mark and the message: "Not Displayable by ScrapX" are displayed.
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Thumbnail View

The Thumbnail view displays item content in a thumbnail format using one of three
possible thumbnail sizes. When a scrapbook is opened the thumbnail size is based on
a User Preference; thereatfter, it can be changed by dragging the Resize Tab at the
lower right corner of the Thumbnail view. The caption under each thumbnail consists of
a portion of the Memo or Source field. C.f. "Item Information," below.
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The item is displayed in the Primary type or, if there is no supported type, a question
mark and the message: "Not Displayable by ScrapX" are displayed. Movies are
identified by a movie projector icon superimposed on a frame of the movie.

You can copy and paste or drag-and-drop content to and from the Thumbnail view, and
can drag-and-drop within it to re-order items in a scrapbook. However, in the Thumbnail
view you cannot play a movie, sound, or aGIF, and cannot scroll multi-screen items.
Items are displayed on a gray background, except the current item, which is displayed
on the "Highlight Color" selected in the General panel of System Preferences

under Jaguar or in the Appearances panel under Panther.

Note: If the background color shows through an image in the Thumbnail view you know
that the image has transparency; this is a handy indicator.
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Combined View

Combined view is a combination of the Item and Thumbnail views.
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Dropbox View

Dropbox view floats above other applications' windows and can remain visible even
when ScrapX is hidden. As you work in other applications you can drag content onto
the Dropbox view without having to select ScrapX. However, content cannot be pasted
to a Dropbox view, and cannot be moved from it.

SEEMN OM

eh

Note: When the cursor is placed over a Dropbox view, a tooltip appears with the
scrapbook’'s name.

The Dropbox view is available only when Dropbox Mode is enabled. It can be enabled
for the current scrapbook by selecting View > Enable Dropbox Mode. Dropbox Mode
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will be enabled automatically for all new scrapbooks if the option "Enable Dropbox Mode
in New Scrapbooks" is selected in the Views section of the User Preferences.

When Dropbox Mode is enabled, the view will change to the Dropbox view when the
yellow "minimize" button in the title bar of the Combined, Item, or Thumbnail view is
clicked. Clicking on the green "maximize" button in the title bar of the Dropbox view will
change the view back to the Combined, Item, or Thumbnail view (whichever was used
last). Or, a view can be selected under the View menu.

Note: Even in Dropbox Mode the key shortcut #-M has the minimize function that puts
the Combined, Item, or Thumbnail view into the Dock.

There is additional, special Dropbox behavior when "Display Dropbox View When
ScrapX is Hidden" is selected in the User Preferences. In that case hiding ScrapX
(selecting ScrapX > Hide ScrapX) causes each open scrapbook to be displayed on the
desktop as a Dropbox view. You can unhide ScrapX by clicking on the ScrapX icon in
the Dock. This will cause each scrapbook to change to the view being displayed when
ScrapX was hidden. You also can click on any of the Dropbox icons. In this case all of
the scrapbooks will remain in Dropbox views, but any one or more of them can be
returned to the Combined, Item, or Thumbnail view (whichever was displayed before
Dropbox view was selected or ScrapX was hidden) by clicking on the green (maximize)
button in the Dropbox title bar. Or, the Combined, Item, or Thumbnail view can be
selected under the View menu.

Note: The position of the Dropbox view on the screen is saved when a scrapbook is
saved. (The positions of other views are not saved.)

The image in the Dropbox view window remains the same regardless of a scrapbook's
current item. By default, the image displayed in the Dropbox view is the ScrapX icon.
But the Dropbox image for each scrapbook can be selected from any item in the
scrapbook. This is done by navigating to the item in the Combined, Item, or Thumbnail
view and then selecting View > Set Dropbox Image. The Dropbox Image is saved
separately from the item used to create it. Therefore, deleting the item from the
scrapbook has no effect on the appearance of the Dropbox view. In general, the
Dropbox image can be replaced but not deleted.

Slideshow View

The Slideshow view (see illustration below) is used only for slideshows. It displays full
size content against a background color that fills the entire computer screen; all desktop
images including Dropbox views are hidden. This view allows display only; content
cannot be moved to it or from it. For more information about slideshows see the
"Slideshows" section in the More About Selected Operations chapter.

Note: although the slideshow view totally fills the computer screen, it will not prevent the
display of special screens like the Force Quit panel.
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Item Selectors

The item selector slider and buttons allow moving between scrapbook items. The right
and down arrow keys also move to the next item, and the left and up arrow keys move
to the previous item. There are two other ways to change items. In the Combined or
Thumbnail view clicking on a thumbnail makes that item the current item. MEW! And, the
key shortcuts E-home and #-end allow jumping to the first and last items in the
scrapbook. This shortcut also can be used while a slideshow is paused or being
operated manually, but not while it is running under timed control.

Tool Strips

In the Combined and Item views a tool strip appears at the bottom of the Item Window.
The collection of tools available depends on the item type selected. If the selected type
is HTML, RTF, URL, or plain text, the text tool strip is displayed. If the type is RTFD the
tool strip has only the I-beam and Open URL tools. With the PDF type the PDF tool
strip is displayed. The image tool strip is displayed with all of the image types except
aGlIF; the latter type has a unique tool strip. For all movie and sound types, the tool
strip has only the Open URL (globe icon) tool.
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ltem Information
The Item Information section of the Item and Combined views contains the fields:

* Item: the position of the current item and the number of items in the scrapbook.
The position of the current item also is displayed in the Thumbnail view.

MEW! « Checkbox: a checkbox used to mark an item for ad hoc purposes. A Checkbox
also appears at the top left of each Thumbnail, so checkbox status can be seen
and changed in the Combined, Item, or Thumbnail views Checkbox status can be
used as a criterion when doing a search or sort and can be used to select items for
a slideshow. When a new item is created the checkbox is unchecked.

* Memo: a field of up to 255 characters that can be used to name, annotate, or
contain keywords for an item. Pressing the tab key or clicking on the Memo field
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enables memo editing. While memo editing is enabled the Memo field is outlined
in blue, the cursor is an I-beam, and the arrow keys can be used to scroll the field.
Text can be entered from the keyboard, or by pasting or dropping. Pressing the
return key, clicking in the Item Window or on a Thumbnail, or moving to another
item in the scrapbook disables memo editing. Pressing the esc (escape) key
disables memo editing without saving changes (if any).

If content was dropped onto ScrapX from Safari the title of the web page is placed
in the Memo field.

The information in the Memo field also is displayed as a caption in the Thumbnail
view. However, if the Memo field is empty the contents of the Source field are
displayed. The contents of the Memo field are retained when a duplicate item is
created either by copying and pasting an existing item within the scrapbook or by
selecting Edit > Duplicate Item.

» Type: a list of the item's data types that ScrapX supports and can use to display

the item plus the unsupported types, if any. The type being displayed is in bold.
C.f.: "More About Data Types," below.

Note: Unsupported types are displayed in the order in which they appear on the
clipboard. Either the classic or NeXTStep types may appear first.

» Size: there can be various dimensions to Size that are displayed as appropriate:

* the data size or memory requirement.

* the pixel dimensions of an image or movie when displayed at 100% resolution,
and the size displayed if the image or movie has been reduced for display.

* the duration (playing time) of an item of type: movie or sound. This information
is not available for sound resource items.

» Date: the date and time an item was created. Items created by copying and

pasting an existing item or by creating a new text item show the Date the new item
was created. The original date is shown if the new item is made by selecting Edit >
Duplicate Item. Creation date is never changed, but a modification date is
appended when an item is created with the "Load Only Supported Types" option
selected in the New Items section of the User Preferences, when type or item
source information is stripped, when text is edited, when a text item is created, or
when a text type is added.

Note: When a new item is created by selecting Edit > Create Text Item both a
creation date and modification date are recorded. The creation date is when the
item was created and the modification date when text editing was disabled.

» Source: a field that shows the source of the item if it was created by dropping a file

or content from a Safari page onto ScrapX or the message "Created in ScrapX" if
the item is the result of using the Edit > Create New Item command. In the former
case, the Source field will contain the name of the file or in the case of a
QuickTime file the name of the first file referenced.
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The complete path to the file is displayed in a tooltip when the cursor is positioned
over the word "Source" and the file can be found using the new Show Source in
Finder command in the Source menu or the contextual menu that opens when the
mouse button is pressed while the cursor is over the word "Source."

Note: the information in the Source field is not updated if the source file is deleted,
moved, or renamed.

Likewise, the complete URL of the Safari page from which content was dropped is
displayed in a tooltip when the cursor is positioned over the word "Source" and the
URL can be opened using the new Open Source URL command in the Source
menu or the contextual menu.

The content of the Source field is retained when a duplicate item is created either
by copying and pasting or by selecting Edit > Duplicate Item. The Source field
cannot be edited, but it can be cleared using the Item > Clear Source command.

The contents of the Source field are displayed as a caption in the Thumbnail view if
the Memo field is empty.
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Commands

The ScrapX Menu bar has the following commands:

ScrapX
In this menu there are three choices unique to ScrapX:

Register...: For an explanation of how to enter a Registration Key see the Read Me
document.

Preferences.... See the User Preferences chapter.

Set Primary Scrapbook: Makes the currently active scrapbook the Primary
scrapbook that can be opened via the File > Open Primary Scrapbook command,
and—if the Open Upon Launching preference is set to "Primary Scrapbook"—that
will be opened when ScrapX is opened or made active when no scrapbook is open.
A "bullet" appended to the scrapbook name at the top of the ScrapX window
identifies the Primary scrapbook.

Note: The Set Primary Scrapbook command is available only if the currently active
scrapbook has been saved.

File

Commands available are: New, Open..., Open Primary Scrapbook, Open Recent,
Import Classic Scrapbook..., Close, Save, Save As..., and Revert.

Open: In addition to the normal function of selecting a ScrapX scrapbook to open,
this command can be used to initiate the import of a classic or Scraplt scrapbook.
See the Import Classic Scrapbook... command for more information.

Note: With the registered form of ScrapX any number of scrapbooks can be open
simultaneously; with the trial form two scrapbooks can be open.

Open Primary Scrapbook: This command (or shift-2-0) opens the scrapbook
that the user has selected as the Primary scrapbook.

Import Classic Scrapbook...: Allows importing a scrapbook created with the
classic scrapbook or with classic versions of Scraplt. Use the File > Save or File >
Save As... command to save the imported scrapbook in the ScrapX format. Which
types are imported is determined by the "Type Loaded for New Items" Preferences
setting. When a classic scrapbook or a scrapbook created with classic versions of
Scraplt is imported the default filename is taken from the imported scrapbook.

There are additional ways to initiate the import classic or Scraplt scrapbook. You
can use the File > Open command, drag the scrapbook onto the ScrapX icon in the
Dock, or double-click the scrapbook icon after going to the Get Info panel and
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selecting ScrapX as the preferred application to open that scrapbook or all
scrapbooks created with these applications,

Note: Scrapbooks made with Scraplt Pro 5.5.2 and some earlier versions of Scraplt
can be imported. If a scrapbook cannot be imported a message will appear:
"Scrapbook Unreadable. It may be damaged or in a format not supported by
ScrapX."

Note: The importing of a scrapbook that includes movies or sounds will be slowed,
but not stopped, if the movies or sounds cannot be found. C.f. "Operations with
Movies and Sounds." in the More About Selected Operations chapter.

Save and Save As...: These commands are included because with the capability for
multiple scrapbook documents comes the requirement that scrapbooks be named
and changes saved when a scrapbook is closed.

Note: If a Registration Key has not been entered, the Save command is grayed out
for scrapbooks with more than ten items. This is done to prevent the original
scrapbook file from being overwritten unintentionally.

If changes are made to a locked scrapbook, when the scrapbook is closed a sheet
appears with the message: "Do you want to save the changes you made in the
document <scrapbook name>? Your changes will be lost if you don't save them."
Three options are offered: Don't Save, Cancel, and Save. Clicking "Save" opens a
Save As... dialogue. After the scrapbook is saved it then can be closed. This
behavior will be seen even if the save-on-close Preference is selected.

Note: The file format has been changed in ScrapX 1.3 in order to save display
settings. Even if you don't make changes to a scrapbook made with prior versions
you will be asked whether you want to save changes when you close it in version
1.3. Files saved using version 1.3 can be opened by ScrapX 1.1 and 1.2, and
ScrapX 1.3 can open files created by any version of ScrapX

Revert removes changes made to a scrapbook since it was last saved or closed.
The Revert command is grayed out unless the scrapbook has been named (and
saved).

Note: ScrapX 1.3 does not have a Print command. But there are several options for
printing an item: 1) make a screen shot; 2) export the item, then open and print the
file in the Preview utility; or 3) move the item’s content to an application that accepts
the item's type.

Edit

Commands available are: Undo, Redo, Cut, Copy, Paste, Clear, Duplicate Item,
Select All, and Create Text Item.

MEW! Undo: The command Edit > Undo (or #-Z) will undo most changes to items and
can be selected multiple times. However, most changes to a scrapbook—changes

31 of 54 ScrapX 1.3 User Guide



MHEW!

MHEW!

MHEW!

in window size or position, or changes to display settings or preferences, for
example—cannot be undone. Commands that cannot be undone and make
preceding changes undoable are Save and Save As..., Revert, Sort, Randomize
Order..., and Recreate All Thumbnails. The Undo command will be grayed out if
no changes or commands are undoable.

Redo: The command Edit > Redo (or shift-8-Z) will reverse one or more Undo
commands.

Append/Paste Special: The Edit > Append command is available when text editing
is not enabled. It pastes styled text at the end of the current item. This command
becomes Edit > Paste Special when editing of a text item is enabled. Paste
Special pastes styled text at the cursor. In either case the font and font size for the
pasted text is taken from the current item. The Append/Paste Special command is
grayed out unless the item Type includes a RTFD, HTML, RTF, URL, or plain text
type and the clipboard contains text.

Duplicate Item: Duplicates the current item. This command retains Date
information and can be used to copy an item before stripping type information (see
discussion of the Item commands).

Create Text Item: The command Edit > Create Text Item (or shift-2-N) creates a
new item of type plain text and enables text editing. Changes can be entered from
the keyboard, or by pasting or dropping in text from another item or another
application. It is not possible to drop a file or a clipping into the item or to insert an
image or other "attachment.”" The text can be formatted using commands in the
Text menu or using tools in the text tool strip. For more information about editing
and formatting text see the Text menu.

Note: When the active scrapbook is in the Dropbox view all of the Edit menu
commands are grayed out. To undo an operation executed while in Dropbox view
first change to the Combined, Item, or Thumbnail view.

Special Characters...: When running Panther, the command Edit > Special
Characters... opens the Character Palette and provides access to thousands of
special characters. Individual characters can be drag-and-dropped (but not copied
and pasted) from the palette to ScrapX either into new items or into an existing item
when text editing is enabled.

Note: The Character Palette also can be opened by clicking on the icon or flag in the
Menu bar to the right of "Help." See more information at the end of this chapter.

Hint: Use ScrapX to maintain a library of special characters you use often. You can
put one character per ScrapX item, or create phrases or patterns. The latter can be
particularly handy since it is possible to drag only one character at once from the
Character Palette.

Note: When you drag a special character from the Character Palette to ScrapX it will
be moved as plain text. If you want it to appear in a particular font or size, you can
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edit the character(s) once in ScrapX. Alternatively, you can move the characters to
ScrapX via TextEdit. In this case font information will be retained.

View

Commands in the View menu allow changing the active view for a scrapbook and
allows selecting view-related options:

MHEW!

MHEW!

Combined: The command View > Combined (or 8-1) selects the Combined view.
Item: The command View > Iltem (or #-2) selects the Item view.
Thumbnail: The command View > Thumbnail (or #-3) selects the Thumbnail view.

Dropbox: The command View > Dropbox (or #-4) selects the Dropbox view,
(Content can be dragged to this view but not moved from it.)

Enable/Disable Dropbox Mode: Click on this command to enable or disable
Dropbox Mode. When Dropbox Mode is enabled, clicking the yellow (minimize)
button in the title bar of an Combined, Item, or Thumbnail view will change the view
to the Dropbox view. And, clicking on the green (maximize) button in the title bar of
the Dropbox view will change the view back to Combined, Item, or Thumbnail view
(whichever was used last).

Set Dropbox Image: By default, the image displayed in the Dropbox view is the
ScrapX icon. But the Dropbox image for each scrapbook can be selected from any
item in the scrapbook. This is done by navigating to the item in the Combined, Item,
or Thumbnail view and selecting View > Set Dropbox Image. C.f. the Views
chapter for examples.

Note: When text editing is enabled the Set Dropbox Image command is grayed out.

Show Slideshow Settings: This command (or shift-£-K) opens the Slideshow
Settings panel. This command is grayed out if the active view is the Dropbox view.

Play Slideshow: This command (or #-K) plays the slideshow. It is available when
in the Combined, Item, Thumbnail, or Dropbox views.

Scrapbook

MEW! About this Scrapbook Panel: The command Scrapbook > About This Scrapbook
(or shift-2-1) opens a panel with information about the current scrapbook. See
example below. All fields in this panel except "Subject” and "Comments" are filled in
automatically. However, when a classic or Scraplt scrapbook is imported, "Created
from Classic Scrapbook <"scrapbook filename"> is automatically inserted in the
Comments field.
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Scraphook MName Intreductery Scrapbook 1.3.5c0ap

Subject: Intrgdudtion o Scrapk 1.3,
Created By Fritz Kokesh
Creation Date Jlanuary 24, 2004 02:18 P
Last Modified By Fritz Eokesh
Last Modified Date: Jlanuary 25, 2004 11:29 AM

Saved With ScrapX Version; 1.3

Humber of Hems; G
Tosal Size 440 KB
Commuenis This scrapbook s an update of SIintroductong
Sgrapbook 1.2°.
Introductory
“}L’E«
o
Scrapbook GO (el

Search: To search the current scrapbook, select Scrapbook > Search (or #-F).
This will open a search panel that allows constructing up to five (5) search criteria
(two without a Registration Key entered) by selecting from among MEW! checkbox
status, content of any of the Item Information fields, or the content of text in items of
type HTML, RTFD, RTF, URL, plain text, or MEW! PDF when running Panther. For
each criterion select a Condition and, depending on the Condition, a Value. See the
More About Selected Operations chapter for a complete list of Conditions.

Sort: To sort the current scrapbook, select Scrapbook > Sort (or #-R). This will
open a sort panel that allows constructing up to three (3) sort criteria (one without a
Registration Key entered) by selecting from among MEW! checkbox status, content
of any of the Item Information fields, or the content of text in items of type HTML,
RTFD, RTF, URL, plain text, or with Panther ME"! PDF. For each criterion select an
order: Ascending or Descending.

Randomize Order...: To scramble the order of items in a scrapbook select
Scrapbook > Randomize Order.... To prevent unintended randomizations, you will
be asked to confirm the command.

Check All Items: Checks the checkboxes of all items in the scrapbook.
Uncheck All Items: Unchecks the checkboxes of all items in the scrapbook.

Toggle All Checkboxes: Checks all checkboxes that were unchecked, and
unchecks all checkboxes that were checked.

Initialize Display Settings: This command initializes the display settings for the
scrapbook and all of the items in it except for Dropbox position and Dropbox Mode.
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(See: the "Display Settings" section in the More About Selected Operations
chapter.) To prevent unintended initializations of Display Settings, you will be asked
to confirm the command.

MEW! Recreate All Thumbnails: This command recreates all of the thumbnails in a
scrapbook. Use it if thumbnails have become corrupted (don't display correctly). To
recreate an individual thumbnail use the Item > Recreate Thumbnail command.

Item

MEW! Enable Text Selection (Disable Text Selection): Text selection is enabled by
selecting the command Item > Enable Text Selection or by clicking the I-beam tool
in the text tool strip. It can be disabled by selecting the Item > Disable Text
Selection command or by clicking on the I-beam tool. Text selection also can be
disabled by moving to another item, clicking on a thumbnail, changing to the
Thumbnail or Dropbox view, or pressing the esc (escape) key.

MEW! Enable Text Editing (Disable Text Editing): Text editing can be enabled by
selecting the command Item > Enable Text Editing command (or #-G) or by
clicking the "T" tool in the text tool strip. It can be disabled by selecting the Item >
Disable Text Editing command or by clicking the "T" tool. Text editing also can be
disabled by moving to another item, clicking on a thumbnail, or clicking in the Memo
field. Pressing the esc (escape) key will disable text editing without saving any
changes.

Note: Text editing can be enabled only when in the Combined or Item view,

MEW! Add Text Type: The command Item > Add Text Type (or shift=8-T) can be used
to add the plain text type or types if an item has no text type (including RTFD). This
command adds the type plain text to the item and enables text editing.

Export...: The command Iltem > Export... (or #-E) allows the content of the current
item to be saved as a file. The format of the file is the same as the selected type for
the item. So, if an item has more that one supported type, it can be saved in more
than one way. Note that in the case of items of type: movie or sound only a
reference is created.

Note: the Export... command is disabled in the trial form of ScrapX.
There are three commands that allow deletion of type information:

Strip Selected Type: The currently selected type will be stripped. All others
types (supported and unsupported) will be unchanged.

Strip Unsupported Types: All unsupported types will be stripped.

Strip Other Types: All types (supported and unsupported) except the selected
type will be stripped.

Note: One or more of these menu choices will be grayed out if no types are
available to be stripped.
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Note: Occasionally it may appear that nothing happens when you select "Strip
Selected Type." This is because the item’s type information includes the
selected type more than once. If this happens, select Strip Selected Type more
than once.

MEW! |nitialize Display Settings: This command initializes the item's saved display

MHEW!

settings. (See: the "Display Settings" section in the More About Selected
Operations chapter.)

Recreate Thumbnail: Recreates the thumbnail for the current item. (The thumbnail
for each item is saved in order to speed up scrapbook opening. If a thumbnail
becomes corrupted this command can be used to recreate it.)

Note: The thumbnail is recreated automatically when text editing is disabled.
Text

Commands under the Text menu are a subset of those available in the TextEdit
application, and editing text in ScrapX is like editing in TextEdit except image
attachments cannot be added. The commands format selected (highlighted) text. First
select the text you want to format then select a command to format it.

Show Fonts: Opens a font selection panel.

Note: When running under Jaguar, the Characters Palette can be opened by
selecting "Show Characters"” from the Extras... list at the bottom of the Fonts palette.
When running under Panther, the Characters Palette can be opened by selecting
"Characters..." from the Action menu (gear icon) in the lower left corner of the Fonts
palette. For more about the Characters Palette see Edit > Special Characters... in
the Commands chapter.

Bold: Text > Bold (or #-B) changes the selected text to bold (or removes the bold
style if already present). Clicking the "B" tool in the text tool strip produces the same
result.

Italic: Text > Italic (or 8-1) changes the selected text to italics (or removes the
italics style if already present). Clicking the "I" tool in the text tool strip produces the
same result.

Underline: Text > Underline (or #-U) changes the selected text to underlined (or
removes the underlined style if already present). Clicking the "U" tool in the text tool
strip produces the same result.

Note: The Bold and Italic commands will be grayed out if the current font does not
have the indicated style.

Bigger: Text > Bigger (or 8-+) increases the size of the selected text one point.
Note: To select "8 -+" depress the three keys: command, shift, and =.

Smaller: Text > Smaller (or 8--) decreases the size of the selected one point.
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Show Colors: Text > Show Colors (or shift-5-R) opens a font color panel.

Copy Style: Text > Copy Style (or option-2-C) copies only the style of the
selected text.

Paste Style: Text > Paste Style (or option-2-V) formats the selected text using
the style currently on the clipboard.

Align Left: Left justifies the selected text.
Center: Centers the selected text.
Justify: Justifies the selected text at both the left and right margins.

Align Right: Right justifies the selected text.
MEW! Source

Which commands are available in the Source menu depends on how the item was
created.

Show Source In Finder: If the Source field contains a filename, this command (or

shift-2-F) will open a Finder window, with the file selected. If the file or the folder
containing it has been moved or deleted, the command will select the farthest folder
of the source's path that it can.

Open Source URL: If the Source field contains a URL, this command (or shift-2&-
U) will open that URL in the user's default browser.

Clear Source: Clears the Source field.

Window. This shows a list of the currently open scrapbooks except those in Dropbox
view.

Help. For help with ScrapX see the User Guide and Read Me document or go to the
ScrapX support page: http://www.agueoussoftware.com/scrapx/support.html .

Character Palette Icon. When running Jaguar, the Characters Palette that
provides access to special characters may appear to the right of the Help menu item.
To make the icon appear, go to the International panel under System Preferences.
Select Input Menu, then check the box next to Character Palette.

Flag. When running Panther, the Characters Palette that provides access to special
characters may be accessed by holding down the cursor over the flag in the Menu
Extras to the right of the Help menu item. To make these selections possible, go to the
International panel under System Preferences. Select Input Menu, then check the box
next to Character Palette and the box at the bottom of the panel next to "Show input
menu in menu bar."

Note: For information about use of the Character Palette see Special Characters...
under the Edit menu.
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User Preferences

In Version 1.3 the User Preferences are organized in seven panels. New panels have
been added to select the default font used to display the plain text type and to select
default slideshow settings.

Launch

8 User Preferences

When Launching ScrapX Open;
= Most Recent Scrapbook
_ Primary Scrapbook
) New Scrapbook

When Opening Sorapbook:

¥ Use Combined View =} Retain Display Settings
_ Use Item View ) Initialize Display Settings
"l Use Thumbnall View T} Ask

Open Upon Launching: This preference determines which scrapbook opens when
ScrapX is launched or is made active when no scrapbook is open. There are three
options:

Most Recent Scrapbook: The scrapbook that opens is the scrapbook that was
opened or saved most recently and that is listed first under File > Open Recent.
This is the default selection.

Primary Scrapbook: The scrapbook that opens is the Primary scrapbook. (C.f.
the Scrapbook > Set Primary Scrapbook command in the Commands

chapter.)
New Scrapbook: A new (empty) scrapbook opens.

Note: If either of the first two options is selected and there is no Most Recent
Scrapbook or no Primary scrapbook has been set, then a new scrapbook is
opened.

Scrapbook View Upon Opening: Every scrapbook will open in the view selected
here. However, the View menu in the Menu bar and the View Selector buttons on
Combined, Item and Thumbnail views can be used to change the view for individual
scrapbooks.

MEW! Display Settings Upon Opening: This preference determines how saved display
settings will be handled when a scrapbook is opened. There are three options:
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Retain: For all scrapbooks use the values from the scrapbook file. This is the
default selection.

Initialize: For all scrapbooks initialize the display settings.

Ask: Decide scrapbook-by-scrapbook. When a scrapbook is opened a panel is
displayed that asks whether to Retain or Initialize the display settings.

New Iltems

8 User Preferences

Insert Mew [Tems: Types Loaded for Mew ltems:
=) Before Current ltem ) Al Available Types
| After Current Itemn _ Omly Supported Types

) A Beginning Of Scrapbook
) Ar End Of Scrapbook

Insert New Items: This preference determines where a new item is positioned in the
scrapbook.

Note: This User Preference will be overridden when items are placed in a scrapbook
for which the "Keep Sorted" option has been checked in the Sort panel.

Types Loaded for New Items:

All Available Types: ScrapX saves all type information associated with an item.
This is the default selection.

Only Supported Types: By checking the first box you can opt to load only
supported type information. When this option is selected new items include a
modification date. Checking the second box also (it cannot be checked unless
the first one is) causes only the Primary type to be loaded. The Primary type is
the default type that ScrapX will use to display the item; it is the first to be
encountered in the list: movie, sound, sound resource, TIFF (including BMP, GIF,
JPEG, and PNG), PICT, PDF, HTML, RTFD, RTF, URL, and plain text.

Note: This preference applies both when content is pasted to or dropped on
ScrapX, and when a classic scrapbook is imported.

Recommendation: Use the "All Available Types" setting unless you have a
specific reason to make a different choice. For example, in the case of images
additional type information (that in addition to the Primary type) may add
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significantly to the item Size. Therefore, if you are making a scrapbook of
images just for viewing purposes you can reduce the scrapbook file size by
selecting "Only Supported Types" and "Load Only Primary Type."

Item Information

8 User Preferences

Indication for Unsupported Types:
® “Unsupported” Only
Al Available Information

Indication for Unsupported Types: Type information for unsupported types can be
displayed in two ways:

"Unsupported” Only: The word "unsupported” will appear in the type list if an
item has one or more unsupported types. This is the default selection.

All Available Information: All available information about unsupported types will
be displayed. The word "unsupported" is followed by a list of the types in
parentheses. Classic Mac OS clipboard types are enclosed in single quotes.

Note: The following NeXTStep pasteboard types (Mac OS X pasteboard types)
are unsupported:

NeXTStep Pasteboard Type ScrapX Type Abbreviation
NSColorPboardType color
NSFileContentsPboardType contents
NSFontPboardType font
NSPostScriptPboardType eps
NSRulerPboardType ruler
NSTabularTextPboardType tabtext
NSVCardPhboardType vcard
NSFilesPromisePboardType promised

MEW! Text

Plain Text Display Font: This Preference determines the font used to display
content in the plain text type.
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Revert to Monaco 12: Click this button to reset the Plain Text Display Font to
Monaco 12.

User Preferences

I Launch ]’ Mew Items r Item Infio Fv mq VB T Llideshows ] Close |

Plain Text Display Font |~ Monaco ?-'! 12 Eq

{ Revert To Monaco 12 )

When the Plain Text Display Font is changed the font for display of the plain text
type is updated in the Item Window of the Combined and Item views and is used for
plain text in thumbnails created (or recreated) subsequently. To update the plain
text font in an existing thumbnail use the Item > Recreate Thumbnail command, or
update the font in all of the thumbnails using the Scrapbook > Recreate All
Thumbnails command.

Note: When the "Text" preference is selected the first time after ScrapX has been
opened it can take a minute or more for font information to be searched and loaded.
Progress is indicated by a progress wheel on the Preferences panel as well as by
the cursor changing to a spinning beach ball.

Views

User Preferences

I Launch ]’ Mew Items r Item Infio ! Text ['H‘Iqw:r* Llideshows ] Close |

E Display Dropbox View When ScrapX Is Hidden
# Enable Dropbox Mode In New Scrapbooks

Thumbnail Size (pixels)
128 x 128
9% x 06
) 64 x 64
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Display a Dropbox View When ScrapX Is Hidden: If this preference is checked,
scrapbooks for which Dropbox Mode is enabled will be displayed in Dropbox view
when ScrapX is hidden (that is, when ScrapX > Hide ScrapX is selected). By
default this option is checked.

Enable Dropbox Mode in New Scrapbooks: If checked, the Dropbox view is
enabled for all new scrapbooks. By default this option is checked.

Thumbnail Size: The Combined and Thumbnail views of every scrapbook will open
with the thumbnail size selected here. However, the thumbnail size for individual
scrapbooks can be changed by resizing the Thumbnail view. The default size is 128
x 128.

Slideshows

The values selected here become the default values for new scrapbooks and for
scrapbooks that opened the first time in ScrapX v1.3 or later. However, slideshow
settings for individual scrapbooks can be changed by selecting View > Show
Slideshow Settings.

() User Preferences

| Launch MHew [tems Item Info Text | Views [-~5Hdt:hm- Close

Advance Each | 2 & Seconds Background Color: | [

Iterms Displayed Captigns
= All Items | Scrapbook Mame
) Only Checked Items —tem Mumber

__ Memo or Source Field
_! Loop Continugushy

To change the slideshow serrings of an exising scrapbonk,
gelet “Shetrwy Slideshow Settings” ursder thi View mignu

Advance Each [ ] Seconds: Select a value between 0 and 60 seconds; if O
seconds is selected the slideshow will be run totally under manual control. The
default is 2 seconds.

Items Displayed: Determines which items will be included in a slideshow:

All ltems: If selected, all items in the scrapbook will be included. This is the
default selection.

Only Checked Items: If selected, only items with a check in the checkbox will be
included.

Loop Continuously: If checked, the slideshow will run until it is stopped manually.
By default this option is unchecked.
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Background Color: Used to select the slideshow background color. By default
black is selected.

Captions: If any of the options is selected captions will be displayed in a white
border around each slide. By default all of these options are unchecked.

Scrapbook Name: If checked, the scrapbook name will be displayed in the
border above each slide.

Iltem Number: If checked, the Item number will be displayed in the border under
each slide.

Memo or Source Field: If checked, the content of an item's Memo field will be
displayed in the border under each slide. Or, if the Memo field is blank, the
content of the Source field will be displayed.

Close

() User Preferences

| Launch MHew [tems Item Info Text | Views Slideshoses Close

_Abways Save Before Closing

Always Save Before Closing: If checked, scrapbooks will be automatically saved
when they are closed. Manual Save and Save As... commands still are available
and their operation is unchanged. By default this option is unchecked.

Note: Even if this User Preference is checked it is good practice to periodically save
changes to a scrapbook.

43 of 54 ScrapX 1.3 User Guide



Appendix A
Known Issues

The following issues that affect operation of ScrapX have been identified. Those in the
"Interactions” and "Other Applications" categories are only examples since ScrapX has
been tested with a limited number of other applications.

ScrapX. The following behavior is a result of limitations in ScrapX.

« If a scrapbook’s filename includes one or more "/" (forward slash) characters, when
the scrapbook is opened the name in the title bar of the ScrapX window will have
each "/" replaced by a ":" (colon). Nevertheless, when the scrapbook is saved
(automatically or manually) the name of the scrapbook file will include the "/" not
the ":" characters.

* When a file in the .html or .htm format includes a relative reference to an image,
that image is represented in ScrapX as a broken link (the image is replaced by a
box with the image filename). The image is displayed when the reference is
absolute, but it may be necessary to momentarily resize the ScrapX window before
it appears. In general, ScrapX is useful for storing segments of HTML code but will
operate very slowly and sometimes inconsistently when attempting to store HTML
with multiple references.

» With some commands Edit > Undo will reverse a change but will leave the
scrapbook "dirty," meaning that ScrapX thinks that the scrapbook contains
unsaved changes. For example, a scrapbook will be "dirty" after Edit > Duplicate
Item followed by Edit > Undo.

Interactions. The following anomalous behaviors seem to be the result of interactions
between ScrapX and other applications:

* Movies or sounds may unexpectedly stop playing or go silent (they do not actually
stop). Clicking on a window outside ScrapX will restore play. This is believed to
be caused by an interaction with QuickTime. (Sounds played in TextEdit also
occasionally go silent unexpectedly.)

Update: This problem can be fixed by using the newest versions of QuickTime (6.5
or later).

« If an item of type: RTFD that includes both an image and text is drag-and-dropped
from ScrapX to the desktop a text clipping file (not a picture clipping) is created; the
image is not included in the clipping.

Other Applications. The following behaviors by other applications affect ScrapX
operation but are not caused by ScrapX:

* As a result of changes to Photoshop made by Adobe in early 2004, content moved
from Photoshop to ScrapX, and then back to Photoshop may not be fully editable.
It appears that Photoshop now uses temporary data buffers rather than the
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clipboard to move some information during copy and paste or drag-and-drop
operations.

» GarageBand content cannot be inserted into ScrapX because GarageBand does
not use the standard clipboard.

* When running under Mac OS X 10.3 (Panther), dragging the "@" symbol or URL
from the address line in Internet Explorer to ScrapX will cause IE to quit
unexpectedly. This behavior also has been seen when dragging from IE to some
other, but not all, applications. It is believed that this is due to an incompatibility
between IE and Panther. IE 5.2.3 (the final release of |IE for the Mac) was released
before Panther was released.

» Occasionally visual artifacts are created when a Dropbox view overlaps or overlays
a classic window. For example, the Dropbox view does not float above windows of
Adobe Acrobat 4.0 (a classic app). When the Acrobat window is closed or moved
off the Dropbox view, the Dropbox view image is temporarily replaced by a portion
of the Acrobat window.

* When a selection from a Microsoft Word 98 document that begins with a URL is
copied and pasted or drag-and-dropped to ScrapX the URL does not appear in the
item as a URL type. This is because Word 98 does not put the URL type on the
clipboard. (If the same content is copied and pasted or drag-and-dropped within a
Word 98 document the URL appears correctly.)

* When a selection from an AppleWorks 6 word processing document that contains
both an image and text is copied and pasted or drag-and-dropped to ScrapX only
the text is inserted. The new item has the type: RTF, plain text; there is no image
information. (If the same content is dragged to the desktop the clipping has no
image.)

» AppleWorks 6 will not start up properly (it "quits unexpectedly") if a movie or sound
(but not a sound resource) is on the clipboard.

» Occasionally, when a file in the .gif or other image format with transparency is
dragged from the web browser Safari to ScrapX the item's background is set to
black when viewed as the type: PICT. (The same thing occasionally happens
when content is dragged from Safari to classic scrapbook.)

* It is not possible to drag-and-drop content from Acrobat Reader to ScrapX, but
content can be copied and pasted. (It also is not possible to drag-and-drop content
from Acrobat Reader to the desktop.)
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Appendix B

Trouble Shooting

Registration Cannot be Completed. The symptom is that a user is unable to enter a
Licensee Name and Registration Key in the ScrapX Registration panel. This occurs
because the user does not have the Mac OS X administrative permissions necessary to
write to the system Preferences folder. (As explained in the Read Me document, a user
without administrative permissions can install the unregistered form of ScrapX in his or
her Home folder. However, both installing the unregistered form in the system
Applications folder and registering ScrapX require administrative permissions.)

Blank Scrapbook Displayed. On some systems, when a scrapbook opens in the
Combined view the window is empty until the view is changed to Item view and then
back to Combined view. Otherwise, scrapbook operation is normal. In all cases where
testing was done it has been found that operation on the same computer was normal if
ScrapX was run from a "clean account” (see suggestion 4 in the section ScrapX Fails to
Start Up). Therefore, it seems that the problem is caused by a "haxie," code added to
the OS by another user-installed application. (In other words, the problem is the
equivalent of an extension conflict in classic Mac OS.)

Thumbnail Displays Incorrectly. Occasionally users have reported that one or more
thumbnail images have become distorted. To speed up ScrapX operations thumbnails
are saved in the scrapbook file; if a thumbnail becomes corrupted it has to be
"recreated.” For a single thumbnail select the Item > Recreate Thumbnail command,
or to recreate all of the thumbnails in a scrapbook select the Scrapbook > Recreate All
Thumbnails command.

ScrapX Fails to Start Up. Occasionally users have reported problems with starting
ScrapX after they have upgraded or updated their OS, updated ScrapX, or replaced
their computer. The following steps have resolved these problems.

1. Download a fresh copy of the latest version of ScrapX from
www.aqueoussoftware.com/scrapx/download.lasso .

2. Ensure that the scrapbook that is being opened is not corrupted. Open the
Introductory Scrapbook by dragging it onto the ScrapX application icon. If necessary,
get the Introductory Scrapbook from the ScrapX archive that you downloaded in step 1.

3. Delete the ScrapX preference files (there are two).

» The user preference file is named "com.aqueous.scrapx.plist* and is inside the
Preferences folder inside the Library folder inside your home folder.

» The system preference file also is named "com.aqueous.scrapx.plist” and can be
found inside the Preferences folder inside the Library folder in the root directory
(the directory where the Applications and System folders are).
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4. Check for conflicts with other programs. The simplest way to do this is to try running
ScrapX in a "clean" account. Open the System Preferences and under "System" select
"Accounts." Create a new user "Test." Select Log Out... under the & (Apple) menu,
then Log in as "Test," and try starting ScrapX.

5. Replace your copy of Stuffit Expander and then download and install a fresh copy of
ScrapX. (Some users who upgraded to G5's found this necessary.) You can download
Stuffit Expander at: http://www.stuffit.com/mac/expander/download.html .

If you have questions about these procedures or if none of them fixes your problem,
email support@aqueoussoftware.com .
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Appendix C

Release History

Version 1.3.3 Released 05/12/03: an update that logs Safari URLs and allows opening
of source URLSs; displays the complete address of a file dropped on ScrapX; and
indicates broken links to movie and sound files. Also: scrapbook window size and
location are retained, "Bigger" and "Smaller" commands are included in the Text menu,
Thumbnail captions are truncated by character instead of by word, large font characters
fit thumbnails, a progress indicator is added for Recreating All Thumbnails, and the
QuickTime VR format is supported when running Panther.

Version 1.3.2 Released 04/13/04: an update that adds an "Append/Paste Special”
command and the ability to open (not just import) classic and Scraplt scrapbooks. This
update improves the rendering of certain PICTs and retains the position and volume of
QuickTime movies and sounds when importing (as well as when exporting), It also fixes
the following bugs: a problem with Undo while editing text, a problem in which movies
and sounds did not stop when the view was changed, and occasional failure of the
Primary Scrapbook "bullet" to appear when running under Mac OS X 10.3 (Panther). All
documentation for version 1.3 now is available in French.

Version 1.3.1 Released 03/11/04: fixes a bug in which new scrapbooks created during
searches did not contain the correct items.

Version 1.3 Released 03/01/04: an update that adds several new features, including
undo and redo, editing and creation of text items, text selection, image zoom,
slideshow, searching within items of type: PDF, saving scrapbook display settings,
"checkboxes" useful for searching and slideshows, the capability to open URL types,
and a new "About This Scrapbook™ panel. Improves rendering of graphics. Fixes bugs
in which when a Save As... was done while in Search Mode all scrapbook items, not
just the active set, were saved and a bug in which items saved as movies sometimes
appeared as sounds when the scrapbook was re-opened.

Version 1.2.5 Released 02/20/04: fixes bugs that prevented the import of classic
scrapbooks that included items with certain combinations of types.

Version 1.2.4 Released 10/20/03: fixes a bug that prevented drag-and-drop of files or
folders onto a scrapbook in Mac OS X 10.3 (Panther).

Version 1.2.3 Released 09/23/03: fixes two bugs: a problem with displaying Dropbox
view when ScrapX is hidden (Apple fixed a bug in the Developer Tools that broke our
code) and revises and restores some localization information. Also adds a tooltip with
the scrapbook name to Dropbox views.

Version 1.2.2 Released 09/08/03: improves the handling of FileMaker Pro (FMP)
objects so they fall under the cursor when dropped onto a FMP layout; improves
support for PICTs and fixes a bug in which clippings created from some items of Type:
PICT appear to be empty; adds support for the EXIF format (which is used by many
digital cameras) so that when content in this format is pasted into or dragged onto
ScrapX it appears as the Type: JPEG rather than TIFF; fixes a bug in which scrapbooks
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did not update after the "Revert" command was selected; and removes (grays out) the
Revert command if the current scrapbook has not been changed. Incremental release
v1.2.2.1 (09/08/03) corrects a problem that occurred when a scrapbook contains a type
that ScrapX no longer loads. It was recommended that all ScrapX users download and
install this update.

Version 1.2.1 Released 08/14/03: fixes a bug in which the search results window did
not draw correctly if a search was executed from the Combined view when the
thumbnails were smaller than 128 x 128 pixels. Also adds "Show Found", "Show
Omitted"”, and "Show All" commands under the Scrapbook menu that have the same
effect as the buttons in the tool bar displayed in Search Mode.

Version 1.2 Released 07/02/03: an update that adds several new features, including
search, sort, Dropbox view, file export and redesigned User Preferences. Fixes a bug
in which ScrapX would hang when attempting to import some classic scrapbooks.

Version 1.1.6 Released 06/12/03: fixes a bug introduced during localization in which
display of movies and sounds could cause ScrapX to crash

Version 1.1.5 Released 06/09/03: adds French localization and documentation.

Version 1.1.4 Released 04/21/03: fixes three bugs: changes to Memo field were lost if a
new item was created by drag-and-dropping content or by duplicating the current item
before the return key was hit; in some cases the wrong license type was displayed in
the registration panel; and in some cases the item type was indicated to be
"unsupported ()." Support was added to allow dragging URL clippings (web Internet
location files) onto a ScrapX window, and additional information was added to the Help
panel.

Version 1.1.3 Released 04/14/03: fixes a bug in which changing the Memo field of an
item did not result in a reminder to save changes.

Version 1.1.2 Released 04/12/03: fixes three bugs: thumbnails did not immediately
update when an item was duplicated; the Type field did not immediately update when
"Indication for Unsupported Types" was changed in the Preferences panel; no indication
was given when an Import Classic SB command failed.

Version 1.1.1 Released 04/10/03: fixes two bugs: scrapbooks created with Scraplt were
grayed out in the Import Classic SB panel, and thumbnails did not immediately update
when an item was pasted or deleted.

Version 1.1 Released 04/09/03: an update that adds several new features, including
Combined and Thumbnail views. Fixes two bugs: dragging a folder or a folder
disguised as a file onto ScrapX 1.0 caused ScrapX to crash, and enlarging an empty
scrapbook did not change the size of the Item Window (only the frame area became
larger).

Version 1.0.2 Released 02/23/03: fixes a bug in which stripping of type information
could not be performed with duplicated items.

Version 1.0.1 Released 02/21/03: fixes a bug in which files in the .txt or .text format that
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contain extended characters could not be copied and pasted or drag-and-dropped to a
scrapbook.

Version 1.0 Released 02/17/03: the initial release of ScrapX.
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Appendix D

Comparison of ScrapX and the Classic Scrapbook

Until OS X, the Mac OS included a scrapbook utility that is referred to here as the
"classic scrapbook." Although it was the inspiration for ScrapX, the capabilities of even
version 1.1 of ScrapX far surpassed those of the classic scrapbook.

Similarities. ScrapX is similar to the classic scrapbook in several ways:

» Both can accept and dispense content via copy and paste or drag-and-drop
operations.

» Both can store, transfer, and display items in a limited number of data formats
called "supported types."

» Both can store and transfer, but not display, data in additional unsupported types
that include those proprietary to the applications used to create the content.

» With the exception of QuickDraw 3D, which is not supported by Mac OS X, ScrapX
displays all of the formats that the classic scrapbook does. Items in QuickDraw 3D
are displayed in ScrapX as PICTs.

Differences. But ScrapX has many additional capabilities; here are some of them:

» ScrapX allows content to be added by dropping one or more files in any of the
supported file formats onto a ScrapX window.

* All versions of ScrapX have allowed any number of scrapbooks to be open. (The
number is limited to two in the trial software.)

* All versions of ScrapX have allowed the user to select how an item is displayed
when it has more than one supported type. And, they have allowed supported and
unsupported type information to be "stripped"” (removed) from an item.

» ScrapX 1.1 allowed multiple scrapbook views: Item (like that in ScrapX 1.0 and
classic scrapbook), Thumbnail and Combined.

» ScrapX 1.2 allowed scrapbooks to be searched and sorted. It also allowed items to
be exported to files, and added a Dropbox view that remains on the desktop even
when ScrapX is hidden.

» ScrapX 1.3 allows text to be edited, images to be zoomed, URLs to be opened,
and scrapbooks to be displayed in slideshows.
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Appendix E

Keyboard Commands*

delete delete item

escape cancel editing/end slideshow
space pause/resume slideshow
tab edit Memo

return end editing of Memo
home go to beginning of item
end go to end of item

page up page up in item

page down page down in item

up arrow go to previous item

left arrow go to previous item
right arrow go to next item

down arrow go to next item
#-home go to first item

#-end go to last item

* When text editing is disabled. With the exception of 88-home and #-end, which are

disabled, and escape, the function of all of the keyboard commands assume standard
meaning when text editing is enabled.

Keyboard Combinations

#H-A Edit > Select All

#-B Text > Bold

#-C Edit > Copy

#-D Edit > Duplicate Item
#-E Item > Export Item
#=-F Scrapbook > Search
#-G Item > Edit Mode

#-H Hide ScrapX

-1 Text > Italics

#-K View > Play Slideshow
#-M Window > Minimize Window (does not switch to Dropbox view)
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#-N File > New Scrapbook

#-0 File > Open...

#-Q File > Quit ScrapX

#-R Scrapbook > Sort Scrapbook
#2-S File > Save

=#-T Text > Show Fonts

#-U Text > Underline

-V Edit > Paste

H2-W File > Close Scrapbook

##-X Edit > Cut

2-Y Edit > Clear/Clear All Text

-7 Edit > Undo

-, ScrapX > Preferences...

-7 ScrapX > Help

-+ Text > Bigger

B Text > Smaller

-1 View > Combined View

-2 View > Item View

-3 View > Thumbnail View

-4 View > Dropbox View

#-5 View > Play Slideshow
shift-5-C Text > Show Colors

shift-52-F Source > Show Source in Finder
shift-53-1 Scrapbook > About This Scrapbook
shift-5-K View > Show Slideshow Settings
shift-5-N Edit > Create Text Item
shift-5-0 File > Open Primary Scrapbook
shift-5-S File > Save As...

shift-5-T Item > Add Text Type
shift-5-U Source > Show Source URL in primary web browser
shift-5-V Edit > Append/Paste Special
shift-5-Z Edit > Redo

option-5-C Text > Copy Font

option--V Text > Paste Font
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Notices

ScrapX was written by Tim Kokesh and is a copyrighted work of Aqueous Software
LLC, all rights reserved. ScrapX is a trademark of Aqueous Software LLC.

Mac, Mac OS, AppleWorks, QuickDraw, QuickTime, ResEdit, Safari, and TextEdit are
trademarks of Apple Computer, Inc. The Scrapbook application for the classic Mac OS
was written for Apple Computer by Light Software. FileMaker is a trademark of
FileMaker, Inc. Adobe, Acrobat, and Photoshop are trademarks of Adobe Systems, Inc.
Scraplt is a product of John V. Holder, Software.

Copyright © 2003, 2004 Aqueous Software LLC.
All rights reserved.
www.aqueoussoftware.com

May 9, 2004
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