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Welcome to Transmit!

Transmit 2 is our next-generation FTP client for Mac OS X. With its famously clean 
drag-and-drop interface, Transmit makes maintaining files and folders through the 
FTP protocol as easy as, well, the Mac!

Shareware Limitations

You have 15 days to test Transmit with no features disabled. After 15 days, Transmit 
will limit your sessions to 10 minutes at a time. Additionally, your Favorites will no 
longer be accessible, although they'll still be saved for when you decide to purchase.

We hope 15 days is enough time to decide that you really, really like Transmit. :) The 
good news is that you can register Transmit instantly online, and for a really, 
really good price!

To purchase Transmit, visit: https://www.panic.com/transmit/buy.html

How do I use Transmit?

Transmit is incredibly easy to use. If you can use Mac OS X, you should have no 
trouble using Transmit to send your files via FTP. In fact, you probably don't even 
need to read this guide, but if you're curious, dig in!

First off, we'll touch on the basics: FTP stands for "File Transfer Protocol", and is a 
standard way to manage files between local and remote computers through the 
internet. If you maintain a web site, need to send a file to a friend who has FTP 
access turned on on his computer, or want to download an update or file from an 
FTP site, Transmit will help out in every way.

• Connecting

Launch Transmit, and type into the connection panel the information for the server 
you wish to connect to. Only the Server field is required. To connect anonymously to 
a server, just fill in Server and leave everything else blank. (The server address will 
look something like "ftp.hostname.com" — don't include an "ftp://" at the beginning.)



For servers that require authentication, you'll need to fill in the User Name and 
Password fields. These would be given to you by the server's system administrator.

For FTP servers that are running on a special port (usually written as 
"ftp.hostname.com:4545" where 4545 is the port), drop that in the Port field as well.

Finally, the Initial Path field indicates which remote folder you'd like Transmit to 
automatically take you to once the connection is made.

• Favorites / Rendezvous

In the upper-right hand corner of the connection panel is a Favorites pop-up menu 
which contains a list of all your favorite servers. Simply choose one, and all the 
connection information will be quickly and automatically filled out — all you have to 
do is click Connect!

If you have Rendezvous-capable FTP servers on your network, a Rendezvous pop-
up menu will appear to the left of the Favorites menu. It contains the names of all 
available FTP servers on your local network. Even if a FTP server on your local 
network has a frequently-changing dynamic IP address, you will be able to find it via 
this menu without having to look up its address manually. (The FTP server built in to 
Mac OS X 10.2.2 supports Rendezvous.)

• Navigating

Double click on a folder to go into it. Click the Parent (arrow up) button to go to the 
parent folder above the current folder. Use the Path Popup to see a history of all 
folders above the current one.

• Download / Uploading

Easy! Just drag a file (or a folder, or many files and folders) from Your Stuff to Their 
Stuff, or vice versa. The file will immediately begin to transfer. (Hit the Cancel 
toolbar item to, well, cancel.) You can also drag files or folders from the Finder or 
Desktop.

• Renaming

You already know how — just click on an item, then click on that item's name and 
wait.

• Managing Favorites

Choose Window -> Favorites Editor to add, edit, and manage your favorite servers, 
including the ability to specify a default "Your Stuff" for each favorite.



• Using Path Shortcuts

Path Shortcuts let you define any number of paths (folders) that you frequently find 
yourself accessing, both locally and remotely. Just select Go > Path Shortcuts > 
Add Shortcut for Current Path, and that path will then be added and easily 
accessible from the Path Shortcuts menu in the future. You can even add the Path 
Shortcuts to the toolbar to make them even easier to use!

Note that Path Shortcuts are only for shortcuts to paths — they don't depend on a 
particular server or favorite, and are only used to set Your Stuff or Their Stuff quickly 
and easily.

• Queueing / Batching

If your main window is tied up with a transfer, you're still free to navigate around the 
site you're connect to. Furthermore, you can queue additional transfers! Just perform 
a second operation — like dragging and dropping another file — and the transfer will 
automatically appear in the Queue drawer!    (The server must be configured by its 
administrator to allow multiple simultaneous connections in order for this to work.)

If you need to want to set up a set of transfers to run, say, overnight, choose 
Window > Batch Download. Then, drag and drop any items from Their Stuff into 
the batch download window as you navigate through sites. When you're ready, hit 
the Start button in the Batch Download window, and your files will be grabbed!

• Synchronizing

Maintain a web site? Want to automatically synchronize Their Stuff with Your Stuff? 
No problem. Simply set Their Stuff and Your Stuff to the two folders you want 
synchronized to each other, and select Transfer > Synchronize or click the 
Synchronize button. Transmit can automatically transfer all the newer files, and can 
also automatically delete any orphaned files — it's up to you.

• Much, Much More

- Choose File > Get Info to edit the permissions of a file and learn more about it.
- Drag a local or remote item to Transmit's Trash to delete it
- Choose View > Show Preview Drawer and click on a graphic file to preview it
- To debug Transmit, choose View > Show Transcript Drawer to see behind the 
scenes
- Try out File > Edit on a text file, to easily edit the text file without leaving Transmit!
- Want to see Their Stuff Only? Just drag the handle in the middle all the way to the 
left!

There's much, much more to Transmit. Explore the menus and toolbars, and enjoy!



Release Notes

Transmit 2.6.1

- Fixed a Panther-related bug that could make for difficult dragging and dropping
- Fixed the display of AM/PM in dates under Panther (sometimes)
- Fixed some issues with resizing windows and splitters
- Fixed a whole host of very, very picky Panther display bugs

Transmit 2.6

- Added SubEthaEdit (formerly "Hydra") as a supported text editor
- File lists now display the number of items in the list
- Improved the click-to-rename behavior to be a little less hyperactive
- Fixed a problem with spurious "NOOP command successful" messages
- Hopefully nailed an SFTP problem with 0 byte files being uploaded
- Fixed some SFTP problems that were caused by idle timeouts
- Fixed a problem where resuming would behave incorrectly, such as on Apple's 
seeding server
- The enter key now applies changes in the Get Info window
- Fixed an issue with broken symlinks to hidden files
- Fixed a problem where renaming a remote folder would cause the cache to be out-
of-sync
- Fixed a problem where renaming a local item wouldn't re-sort the list afterward
- Improved the responsiveness of the Preview Drawer
- Fixed the ability to delete a remote item via SFTP and AppleScript
- UI improvements for Mac OS X 10.3 (Panther)

Transmit 2.5.1

- Fixed an SFTP failure when trying to upload files on certain servers ("read error")
- Fixed a problem where SFTP uploads would be 0 bytes after a large number of 
files ("remote handle")
- Fixed the display of remote symbolic links
- Added a hidden preference to disable Transmit directory caching (see the Transmit 
Support web page)
- Fixed a small problem with the Spanish localization

Transmit 2.5

- Giant speed improvements!
- Retrieving long directory listings is significantly faster
- Transferring files via SFTP is also much, much faster
- Dragging large numbers of items is now nearly instant
- Directory listings are now cached each session for maximum performance

- New features!



- Added a "New File..." menu option which creates new, blank local or remote 
files

- Added a customizable redial delay, so the maximum can be set to any 
number

- Added a "Duplicate" button in the Favorites Editor to easily clone favorites
- Added support for TextWrangler and BBEdit Lite as text editor options

- Added the recent sessions menu to the Favorites pop-up for easier access
- Transmit no longer sends ".DS_Store" files by default (see the Transmit Support 
web page for more info)
- Added a "List Files" AppleScript command
- Transmit now uses Mac OS X Finder-style NaturalOrder sorting
- Edit in BBEdit no longer attempts to resume on save
- Transmit now shows the current date and time on a freshly uploaded item until 
refreshed
- Fixed a problem with a preview image displaying improperly if the drawer was too 
small
- Fixed a problem with shifting selections when setting permissions or renaming
- Transmit now warns if you click the close box of a window during an active transfer
- Fixed a problem where Transmit wouldn't recognize the unmount of a local volume
- Fixed a problem where sorting by date would break keyboard type-ahead
- Added fixes for a handful of quirky FTP and SFTP server behaviors
- Added list parsing support for Unitree servers
- Transmit no longer allows you to rename a file to an existing filename
- Transmit no longer reports an error if you rename a file by only changing the case
- Hopefully fixed a rare problem where Edit in BBEdit and SFTP could clobber files
- Fixed a problem with very dark progress bar shadows during rapid transfers
- Fixed a problem where 'Resume' was sometimes available when it shouldn't be

Transmit 2.3

- Added a new "Double Click Action" preference to configure Transmit's behavior 
when a file is double-clicked
- Fixed a problem where uploading simply wasn't working for some users
- Changed the method of deleting files for better compatibility with more servers
- Improved the reliability of "Edit in BBEdit"
- Add a workaround to support servers hosted at Strato (strato.de)
- Fixed a problem where the Synchronization report was not reporting deleted items
- Fixed a problem where "permission denied" errors weren't being given to the user
- Fixed a problem where "Get Info" now properly shows creation date for local files
- Added icons in the Go menu (like the Finder, yo)
- Improved Rendezvous support
- Transmit now ignores leading wildcards in "Bypass Proxy" settings
- Improved Japanese language support

Transmit 2.2



- Added support for Rendezvous via a pop-up menu that automatically lists all 
Rendezvous-capable local FTP servers
- Added an Edit in BBEdit button to the toolbar button choices
- Added the ability to automatically connect to your favorite server on launch
- Added a new preference to configure which file extensions use ASCII mode
- Fixed a potential situation where Transmit would use high CPU when idle
- It's now possible to 'Move' more than 6 files at a time
- Added ability to delete multiple favorites at a time in the Favorites Editor
- Fixed a problem with certain SFTP transfers failing due to too-large packet sizes
- Fixed a problem logging into certain SFTP servers (that send banners)
- Fixed a problem with certain SFTP servers adding an asterisk (*) after filenames
- Fixed a problem where you couldn't cancel a rename by hitting 'Escape'
- Fixed a problem where Transmit would redial certain servers, even when set to 
'never'
- Cancelled uploads now show only the amount transferred as the file's size
- It's now possible to Get Info on freshly uploaded files
- It's also possible to CD into freshly-created directories on WarFTPD servers
- Fixed a problem where you could create a duplicate local directory
- Clarified the error message seen if you try to delete a file without proper 
permissions
- (Hopefully) fixed a problem with Korean language support
- Spanish localization added

Transmit 2.1

- Added 'Edit in BBEdit' feature (yay!), accessible via the 'File' menu or contextual 
menu
- 'Edit in BBEdit' works over SSH connections (2.1a)
- Dragging items into a folder in 'Their Stuff' no longer creates 'phantom' items in the 
parent
- Passwords are no longer occasionally visible as plain text
- Fixed a problem with windows forgetting their positions (especially with dual 
monitors)
- Added support for MS-DOS-style file listings (when UNIX listings aren't available)
- Added keyboard shortcuts for setting ASCII and Binary modes
- Post-processing is disabled during synchronizations
- Transmit no longer gets confused if the Default Download directory is deleted
- Keyboard type-ahead now works for numbers and punctuation
- Uploading a file after a server closes a connection no longer fails
- Files in FTP:// URL's are now correctly downloaded
- Fixed a potential crash when commands fails on certain servers
- The latest Transcript is now written and kept in ~/Library/Logs/ for easier 
debugging
- Using AppleScript to connect now properly handles passwords
- Added an AppleScript-only command to suppress error dialogs
- Improved AppleScript error handling



- Fixed a problem with potential crashes after a server inactivity disconnection
- Transmit can now correctly FTP into an Xbox. :)
- French localization added

Contacting Panic

E-Mail: transmit@panic.com
Web: http://www.panic.com/transmit/
Support: http://www.panic.com/transmit/support.html

Licensed Software

SFTP Support

Portions of Transmit's SFTP support are derived from OpenSSH.

Copyright © 1995 Tatu Ylonen <ylo@cs.hut.fi>, Espoo, Finland.
Copyright © 1995-1999 Theo de Raadt. All rights reserved.
Copyright © 1998 CORE SDI S.A., Buenos Aires, Argentina.
Copyright © 1999-2001 Markus Friedl. All rights reserved.
Copyright © 1999-2002 Damien Miller. All rights reserved.
Copyright © 2000 Markus Friedl. All rights reserved.
Copyright © 2000 Niels Provos. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted 
provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and 
the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO 
EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGE.

Transmit is Copyright © 1997 - 2003 Panic
Transmit is a registered trademark of Panic, Inc.


