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Do Less and Accomplish More
Programming by Philippe Hupé. Manual by Adam Engst

iKey is an automation utility designed especially for Mac OS X. iKey lets you create
shortcuts to automate actions on your Mac. iKey shortcuts are made of 3 parts context(s),
launcher(s) and command(s). This is explained in detail in the manual which is available
from the Help menu which is available when iKey is open.

iKey is famous for being fast, powerful, inexpensive and easy to use. iKey is useful for all
Mac users and can be used by beginners through very advanced users. The purpose of iKey is
to reduce and eliminate the repetitive actions that we all face thousands of times a day. iKey
frees people from this repetitive drudgery. Don't become a menial slave to your computer
have it work for you. iKey can be used to maximize your time and utilize your full creative
potential.

Requirements

iKey 2.2 is a Universal Binary application. It works on all Power PC based Macintosh
computers running Mac OS X version 10.2.0 or later, and all Intel Based Macintosh
computers (not all the features have been tested on these Mac for this version of iKey).

Help

The extensive manual is available from the Help menu when iKey is open. It prints out
nicely. iKey's manual was written by TidBITS publisher and well-known Macintosh author
Adam C. Engst; it uses the same style and layout as the highly regarded Take Control ebook
series. As iKey is updated so is the manual.

How to install

To install iKey 2, just copy the folder named "iKey 2" to the "Applications" folder. You must
quit any previous version of iKey before running iKey 2.

The iKey menu icon can be changed please look in the manual for more details.

Upgrading from iKey 1.x

If you were using iKey 1.x, the first time you run iKey 2 you will be asked to convert all the
shortcuts to the new format.

If you don't convert the shortcuts at the first launch, it's possible to do it, but you will lose all
you have done in iKey 2. To do so, delete the folder named "iKey" located in the
"Preferences" folder of your "Library" folder.



After converting, you can continue to use iKey 1.x if you want, otherwise you can delete the
following files/folders located in the "Preferences" folder of your "Library" folder:

- iKey.plist

- iKey Editor.plist

- iKey Installer.plist

- iKey Folder

Upgrading from YoupiKey

If you were using YoupiKey, before running the first time iKey 2, you have to install and run
one time the latest version of iKey 1.

Purchasing

iKey 2 is $30 and can be bought online at: http://www.scriptsoftware.com

If you bought iKey 1 then log into the Script Software store to get a coupon you can use to
purchase iKey 2 for a discount.

What's new in iKey 2.2?
New Features:

- add "double key" key based launchers: to run one, press the modifier keys, then type the
fisrt key, then type the second key, finally release the modifier keys - the maximum delay
between the two keys is 1 second

- add "USB Device Event" based launchers: any USB device with buttons or wheels are
supported, like mice and xKeys keyboards; the specific drivers may have to be removed in
order for iKey to work properly with the devices; buttons work like keys of the keyboard,;
event of the wheel are generated when the user turns it by a specified increment

- "simultate mouse" command: add a "Drag by" movement

- commands of family "clipboard": add a "Save Clipboard" and "Restore Clipboard"
command

- add support for Apple Backup to save iKey settings

- show a message if a key based launcher uses the same hotkey as the system (Mac OS X
10.3.x and up), when launching the Editor or validating a launcher

- add a "New user" window

Improvements:

- shortcut and menu icon: add a contextual menu to select the icon from an image file or from
a file icon

- floating menus: now don't include any item of the system contextual menu items

- date/time based launchers: if the time is exceeded and the launcher has no object to fire, no
message is displayed

- "Upper Case Selection", "Lower Case Selection", "Capitalize Words of Selection" and



"Replace in Selection" commands: the content of the clipboard before the command is now
preserved after

Bug fixes:

- shortcut and menu icon: images dropped or pasted now keep the mask

- "simulate mouse" commands: correct a problem where dragging didn't work, and mouse
movements didn't take into account modifier keys state

- iKey works again properly under Mac OS X 10.2.x (not the case since version 2.1.0)

What's new in iKey 2.1?
New Features:

- editor: updated interface, with brushed metal color, and context based (like iKey 1)
- editor: create a library for existing commands, launchers, and contexts

. the library can be displayed from the "Window" menu, from a new button in the
toolbar, or with the "command L" hotkey

. it is a floating palette that can be displayed/hidden at any time

. commands, launchers and launchers can be added to any other objects (shortcuts,
menus and palette) from the library by drag and drop or copy and paste

. unused commands, launchers and contexts can be viewed and deleted if necessary
from it (remove the "Show unused parts" item from the "File" menu)

. unvalid commands can be viewed and edited if necessary (remove the "Show unvalid
commands" item in the "File" menu)

. there is a button in the "Used By" column that you can click on to see and edit the
objects that use the selected one . the location and size of the library is saved
- editor: shortcut editing window: replace the "Duplicate" item of the commands contextual
menu with a "Substitute with Copies" item
- editor: add a item in the shortcut's preferences : "Use copies of command when duplicating
a shortcut"
- command of type "Select menu item": there is now just one type of command to select any
item with any level of submenu
- command of type "sleep": add an option to automatically wake up the mac after a delay or
at a specific date/time (administrator authorizations must be activated)
- commands of family "iKey": add 2 new commands to run again the last and the next to last
iKey shortcut or command
- commands of family "iKey": add a command to test the edited command or shortcut: useful
when a command or shortcut depends on the front application
- command of type "wait window": add a command to wait for the change of the front
window
- command of type "Wait window": add an option to invert the condition, so that for example
the execution is paused until the title of the window isn't "xxx"
- menu in the menu bar: when a menu has just one item, this item is displayed directly in the
bar so that no menu appears now to access it (just click on it to run)
- brings compatibility with Mac OS X 10.4.x, alias Tiger:

.command "menu of preference pane": the menu is now displayed properly

.command "set default printer": now works

.command "run screensaver": works under Tiger



."menu of recent applications" command: now works

."menu of recent documents" command: now works

.editor: correct a cosmetic bug when displaying the preferences the first time
.editor: correct a problem where recent applications cannot be selected

Improvements:

- editor: improved interface when editing a shortcut, a menu or a palette:

. existing commands and launchers can now be added by drag and drop or copy and
paste from the library

. existing contexts can be added by drag and drop and copy paste from the context list
(also by dropping directly an object from the window on a context)

. shortcuts can be added to a menu or a palette by drag and drop or copy and paste from
the main window

. menus can be added to a menu by drag and drop or copy and paste from the main
window

. the popup button for adding launchers now contains all types of launcher with no
specific parameter

. you can now type the same keycombo for a new key based launcher: it will take the
existing one without a warning

. speed improvement when editing
- editor: when adding a new context, launcher or command: if one still exists with the same
parameters, it is used instead of the new one
- editor: when modifying a context, launcher or command: if one still exists with the same
parameters, a dialog is displayed to ask if you want to replace the edited one with the one that
already exists
- editor: improved launch speed
- editor: new search control in the toolbar under OS X 10.3 and up
- editor: add "command W" hotkey to close the main window
- editor: automatically delete shortcut, menus and palettes with no context and unused
- editor: iKey hotkeys are now automatically deactivated when a key based launcher is edited
(remove the corresponding item in the "File" menu)
- editor: correct a problem where selected preferences can change when moving the pointer
after selecting one
- editor: a sound is played when a location or an item is recorded
- editor: a message is now displayed when editing commands and launchers uses by several
objects: "Changes are applied to all"
- commands of type "display folder hierarchy": items are now displayed ordered by their
name in local language (OS X 10.3.x and up)
- palette and command in the menu bar: if a command in a palette or in the menu bar displays
a menu, the menu is now properly displayed on the bottom left corner of the button
- launcher: memory management improvement

Bug fixes:

- editor: correct a problem to display properly the label of key based launchers with keys
from the numeric keypad

- display folder hierarchy commands : correct a problem where ikey freeze after running it
from a hot key



What's new in iKey 2.0?

iKey 2.0 is a complete rewrite of the previous versions that enables to control much more of
commands and how they are run, and has many new options.

The application has been structured with the following objects:

- command: the based object to do a task (each command is based on a type that define the
task it can do - command types are grouped by family)

- context: it controls when a shortcut, a menu or a palette is available

- launcher: it run shortcuts, display menu and palettes depending on events (key, date,
application or system event)

- shortcut: it groups one or more comands, and controls how they run

- menu: to run shortcuts and commands (including in submenus)

- palettes: to run shortcuts and commands (many new options)

iKey application:

- can check automatically for new version (preferences)

- improved applescript support: run command, run shortcut, display floating menu, show/hide
palette

Editing iKey:

- new interface with brushed metal windows and toolbars

- all settings can be defined for one user and for all users of a Mac

- integrated help (nof fully implemented in beta 6)

- preferences inside (not in a preference pane)

- preferences include default settings for new objects (commands, shortcuts, menus and
palettes)

- preferences include delay before a palette is deactivated

- many examples of commands, shortcuts, contexts, launchers, menus and paletted for new
users

Commands:

- one command can be used in several shortcuts, palettes or menus

- any change in a command is transmitted to all objects that use it (shortcuts, palettes and
menus)

- each command can be tested inside the editor

- a list of non valid commands can be displayed

- new command types: family iKey (new): Quit iKey, Launch Editor, Open iKey Preference
Pane, System Keys (sound, eject)

- all commands of iKey 1.0.7

Shortcuts:

- each shortcut can be ran with several launchers (key combo event, date/time events,
application events and system events)

- each launcher can be deactivated temporarily for a specific shortcut (for test purpose for
example)

- each shortcut can be activated in several contexts (when various applications are on the
foreground)

- each context can be deactivated temporarily for a specific shortcut (for test purpose for
example)



- can run several commands by default

- each command inside a shortcut can be deactivated temporarily (for test purpose for
example)

- each command inside a shortcut has result parameters to specify what to do if the command
succeeds and if the command fails: continue, show a message, add to a report, stop or ask

- each command inside a shortcut has its specific run parameters: the number of times to run,
the delay to pause after each run

- commands can be shared with other shortcuts (like aliases), so that if changes are made in a
command, all shortcuts linked to it will be also changed

- each shortcut can be tested inside the editor

- can define how many times all the commands inside a shortcut need to be ran (one time,
several times, by infinite) and the delay between each run

- result of each command in a shortcut can be viewed in a report

Contexts:

- add new context types: when an application is on the background; when an application is
running; when an application isn't running

- ability to deactivate all key combo when a context is activated (for example: a specific
application is on the foreground)

- easier to deactivate one or more specific key combo when a context is activated (for
example: a specific application is on the foreground)

Launchers:

- one launcher can fire an unlimited number of objects (shortcuts, menus, palettes)

- for each key based launcher, specify if the event occurs the key combo is pressed or
released

- for each key based launcher, specify if the event is repeated when the keys remain pressed,
and the delay between each event

- key based launcher: more pertinent title of the key combo

- for each date based launcher, specify if the next planned date is exceeded (the Mac and/or
iKey wasn't running) what to do (fire, nothing or ask)

- system based launcher: before go to sleep: now really run shortcuts before going to sleep

Menus:
- each menu has new specific settings:
. to display in the menu bar, with an image and/or a name
. to display image of items
. to display key combo of items (shortcuts with key based launchers)
- several menus can be displayed in the menu bar
- menus can be used as submenus, with unlimited number of levels

Palettes:
- each palette has new specific settings:

. the origin of the default location (top/left, top/right, bottom/right or bottom left of
the screen)

. the type of buttons (image only, image top, image bottom, image right, image left,
image over, no image)

. the size of the image

. the size of the font to display the name
- palettes can be previewed from the editor



Preference Pane:
- now just for launching/quitting iKey and launching iKey Editor in case it cannot be found

For more information

First please read the help built into the application and also the FAQ. Then if you still have a
question, comment, bug or suggestion please write to:

ikey-info@scriptsoftware.com

We love to hear from you.



