
Dot-to-Dot Construction Set

This product is being distributed as shareware. It may be freely distributed on a non-commercial basis as long as 
the program and this documentation are not modified in any way. If after receiving this program, you wish to keep 
it, please send $17 (the shareware fee for this program) to:

SoftPlus
P.O. Box 2442
Gaithersburg, MD 20879

In return you will receive a disk with the latest version of Dot-to-Dot Construction Set (DDCS) along with 30+ 
ready-made dot-to-dots. In addition, you will be entitled to all future shareware upgrades to DDCS.

Warranty and Disclaimer

Neither SoftPlus nor the Author of this program make any warranties, either express or implied, with respect to 
this manual or to the software described in this manual, its quality, performance, merchantability or fitness for a 
particular purpose.  This software and manual are provided "as is."  In no event will SoftPlus be liable for direct, 
indirect, special, incidental or consequential damages resulting from any defect in the software, manual or 
associated documentation, even if advised of the possibility of such damages.

© 1986 by Paul Cozza.  All rights reserved.

Portions of this program ©1984, 1985, 1986 Consulair Corporation.  Portions of this program were written using 
Mac C™.  Mac C is a trademark of Consulair Corporation.
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Introduction

The Dot-to-Dot Construction Set (DDCS) is a shareware educational game which helps chidren learn numbers, 
letters, and words, and also helps to improve dexterity.  The age range for children using this game is about 4 to 
8, though younger or older children may also enjoy it.

The program itself is divided into two parts: a play mode and an edit mode.  In the play mode, dot-to dots are 
played out. In the edit mode, dot-to-dots are constructed from MacPaint pictures or from clipboard graphics. This 
documentation provides a tutorial for both modes of DDCS as well as details about all of the DDCS features.

Playing a Dot-to-dot

This section provides a short tutorial on playing a dot-to-dot. Let's assume that DDCS is located on a disk with 
some dot-to-dot puzzles. You have started up DDCS and have before you the play screen. There are three 
windows visible to you: the one on the left contains all the letters of the alphabet (some of which are darkened, 
and others grayed); the main large window is empty; the bottom window contains two custom controls.

To start playing a dot-to-dot, simply click on one of the darkened letters in the leftmost window. Three things will 
transpire: The letter which you clicked becomes inverted; the name of the dot-to-dot to be played appears in the 
lower window with only the clicked letter shown and all other letters displayed merely as underlines; and lastly, the 
dots outlining the picture are shown in the main window along with numbers identifying them.

To play a dot-to-dot, simply click on the dots starting from dot number one. As you click successive dots, lines will 
be drawn connecting the dots. Furthermore, the picture will be gradually filled in and as the picture fills music will 
encourage you on. When the dots are completed, the picture will completely fill in and a musical salute will signal 
your accomplishment.

If you wish to play another dot-to-dot, simply click on another letter in the alphabet window. If you wish to replay 
the same dot-to-dot, click on the left control in the bottom window, which shows the circular arrow. This is the redo 
button. If you wish to quit, you can click the stop button on the bottom right (with the policeman), or simply choose 
Quit from the file menu. That's all there is to playing a dot-to-dot!  Simple enough for a child!

Play Mode Features

There are a number of useful play-mode features available via menu selections.

Under the File menu are three items of interest. 'Open' allows you to open a particular dot-to dot for play. 'Page 
Setup' and 'Print' are used to print dot-to-dots for later play by a child. The 'Page Setup' item displays the normal 
setup dialog which allows you to configure the paper size, page orientation, and so forth. The 'Print' item displays 
a somewhat modified print dialog. Print dialog items which have no meaning in DDCS have been deleted. Also, 
two options have been added. The first lets you determine whether you wish a full, a partial, or no title to be 
printed under the dot-to-dot. The second allows you to select how you want the picture printed. A full picture, 
partial picture (of varying degrees), or no picture at all may be printed. (Note that dots are always printed.)  In 
general, a light or very light gray mask should be selected for best results.
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Under the Selection menu heading are five items. The first three determine how a dot-to-dot will be chosen when 
a letter is clicked: 'By first letter' will select a dot-to-dot whose first letter matches the one clicked. 'By last letter' 
will select a dot-to-dot by its last letter. 'By any letter' selects a dot-to-dot which has the clicked letter in any part of 
its name.

The next item is 'Auto file select'. When this option is turned on (by selecting it from the menu), a dot-to-dot is 
chosen automatically from the available selection whenever the currently displayed dot-to-dot is finished. In this 
mode of play, the alphabet window will not respond to any mouse clicks.

The last item under the Selection menu is 'Change search volume'. This allows you to determine which volume or 
subdirectory should be searched for dot-to-dots. Note that all subdirectories of the selected volume/directory are 
searched. For large volumes (such as hard disks) this can be a time consuming process. Because of this, we 
suggest that all dot-to-dots be stored in the same folder, and that this folder be chosen as the search 
volume/directory. When DDCS is started up, the folder in which DDCS is located is the default search volume. 
Putting dot-to-dots in the same folder as DDCS (or in one of its sub-folders) will cause these dot-to-dots to be 
searched and displayed in the alphabet window at start-up (only the letters of those dot-to-dots present in the 
search volume are darkened in the alphabet window).

The Options menu has two items. The first, 'Set play defaults', allows you to set a number of defaults that DDCS 
uses in the play mode. Show partial pictures determines whether the picture of a dot-to dot will be gradually 
displayed as the dot-to-dot is solved. If this is turned off, no part of the picture is seen until the puzzle is 
completely solved.

Show partial titles determines how the dot-to-dot title is displayed while the puzzle is being solved.  If this is turned 
off, the full title is always shown. If it is turned on, only the letter clicked in the alphabet window is shown until the 
dot-to-dot is solved.

Allow repetition of pictures determines whether puzzles which have been played during the current session can 
be selected again by clicking in the alphabet window. If this is turned on, the same puzzles may be selected 
repeatedly. If this is turned off, once a puzzle has been played, it will be removed from the pool of available dot-to-
dots (until either the next play session, or until 'Change search volume' in the Selection menu is used again).

Turn sound on determines whether music will accompany the playing of dot-to-dots (the volume of the music can 
be adjusted via the control panel desk accessory).

Start play with dot 2 determines which dot is to be clicked first when  a puzzle is being played. If this is turned off, 
dot 1 should be clicked first. If this is turned on, dot 2 should be clicked first (some children find it more intuitive to 
start clicking at dot 2).

Search for files at start-up determines whether DDCS will search the default search volume for dot-to-dots when it 
starts up. When this is turned off, 'Change search volume' must be explicitly selected from the Selection menu to 
get letters darkened in the alphabet window.

Number of dots determines the number of puzzle dots acceptable to DDCS when it searches for dot-to-dot files. 
The minimum is 3, and the maximum is 125. By limiting the range of dots, you can configure DDCS for your 
child's age and playing ability (generally speaking, the more the dots, the harder the puzzle).

The second item under Options is 'Solve'. When this is selected, the currently displayed dot-to-dot is solved 
point-by-point so the child can see the proper solution.
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Editing a Dot-to-dot

This section provides a tutorial on editing a dot-to-dot. To get to the edit mode of DDCS, start up the game, then 
select 'Turn editor on' from the Edit menu. DDCS will enter the edit mode. Five windows are present in the editor: 
The top left window determines whether the picture or the dots of a dot-to-dot are being edited. The middle left 
window provides a palette of tools for editing. The bottom left window selects the line thickness and number size  
for the dot display. The large middle window is the actual editing window. The bottom window is the puzzle title 
entry window.

To create a dot-to-dot, either open a MacPaint or other picture (preferably a copy of one) via the 'Open' command 
in the File menu, or transfer a graphics picture from the scrapbook, to the clipboard, then to the editing window 
using the standard Macintosh techniques. When pasting from the clipboard to the editing window, make sure that 
title window is not active (i.e. does not have the blinking insertion point) by clicking on some tool in the tool palette 
if necessary. The graphics will now be displayed in the main window. If the graphics are grayed, this means that 
dots are currently being edited. If so, click on the paintbrush in the upper left window. The graphics will then be 
displayed normally.

Click on the hand in tool palette. Click on the graphics in the editing window and drag it into the position you wish 
to be displayed when the puzzle is being played. (Note that graphics outside of the window will be clipped when 
the picture is stored, so it is best to position the graphics properly to begin with.) If you wish to erase any of the 
graphics, click on the eraser tool and erase the desired part just as you would in MacPaint. These are the only two 
tools available while the picture is being edited. For this reason the picture should be prepared as well as possible 
in MacPaint (or another graphics program) before using it for a dot-to-dot.

Click on the dot box in the upper left window. The graphics will now be grayed. Click on the tool which shows a 
dot at the end of a line. This is the tool to add new dots. Click in sequence around the graphics object you wish to 
outline in the dot-to-dot. Don't worry about exact dot placement, as dots may be easily moved even after being 
placed.

When you have finished placing dots, you may decide that you wish to move already placed dots, or insert dots, 
or add new dots. To move dots, click on the tool with the hand over a dot. Position the index finger of the hand 
over the dot to be moved, click (the dot should 'snap' under the hand), then drag to the proper position. If you wish 
to add new dots to the end of the current dot sequence, click on the tool for new dots. Then position and click just 
as described above. If you wish to insert new dots in between already existing dots, click on the tool which shows 
the dot in the middle of a line. Now move the tool over the line joining the two dots in between which you wish to 
insert a dot. Click on the line, then drag the new dot to the desired position. The previous dots will automatically 
be renumbered.

At this point, choose the line thickness/number size you desire by clicking in the appropriate box in the bottom left 
window. You may change this selection later if you wish. Now choose 'Smooth numbers' from the Edit menu. The 
numbers of the dots on the screen will be adjusted so that they fall within the editing window, yet not on the line 
coming into or out of the dot to which the number is joined. Most likely you will wish to adjust the numbers further 
so that they don't obscure any graphics. To do this, click on the tool with the hand over the number. Now move the 
mouse over the number to be adjusted, click, then drag (just as with moving dots above).

You are now ready to add some finishing touches. If you wish to outline certain portions of the dot-to-dot, you may 
do so by inserting lines or arcs into the puzzle. These lines and arcs will appear along with the dots while the 
puzzle is being solved. To add a line, click on the line tool. Move to the editing window and position the mouse at 
the starting point of the line you wish to add. Click, drag to the desired stop point, then release the mouse button. 
Arcs are added in an identical fashion after clicking the arc tool in the tool palette.
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If at any time you wish to delete a dot, line, or an arc, click on the eraser tool. For dots and lines, position the 
crosshairs over the object to be erased and click. For arcs, position the crosshairs inside the (invisible) rectangle 
which encloses the arc, then click. If at any time you wish to move all the dots, lines, and arcs together, use the 
plain hand tool.

The final step is to add the dot-to-dot title. Click in the text edit box in the title window, then type in the dot-to-dot 
name. All the text-edit functions (cut, copy, etc.) are available while editing the title. If you wish to change the 
graphics after clicking in the title box, click on a tool in the tool palette. This will deactivate the text-edit title box.

The dot-to-dot is now completed! You can use 'Save' or 'Save as' from the File menu to store the puzzle on disk 
for later play. If you wish to see how the puzzle will appear when played, select 'Turn editor off' from the Edit 
menu. The puzzle you have just completed will become the current one in the play mode.

Edit Mode Features

There are a number of useful edit-mode features available.

Under the File menu are a number of items of interest. 'New' clears the editing window of all dots and graphics to 
allow you to start a fresh dot-to-dot. 'Open', 'Save', 'Save as', 'Page Setup' , 'Print', and 'Quit' have been described 
above. The 'Revert to original' command allows you to undo any changes you have made to a previously stored 
dot-to-dot. It restores a dot-to-dot to its last filed version.

The tools may be enhanced by using certain key combinations in conjunction with the mouse. The key 
combinations currently available are:

Option key - hand tool: Moves graphics and dots together
Shift key - hand tool: Constrains movement to up/down or left/right
Shift key - graphics eraser: Constrains movement to up/down or left/right
Shift key - dot mover: Constrains movement to up/down or left/right
Shift key - number mover: Constrains movement to up/down or left/right
Shift key - dot adder: Constrains new dot to be on a vertical, horizontal, or diagonal from the 

last dot
Shift key - dot inserter: Constrains movement to up/down or left/right
Shift key - line tool: Constrains line to be vertical, horizontal, or diagonal
Shift key - arc tool: Constrains arc to be a circular segment (1/4 circle)

Double click graphics eraser: Erase all graphics in editing window
Double click dot eraser: Erase all dots, lines, and arcs
Shift key - double click dot eraser: Erase all dots only
Option key - double click any eraser: Erase all graphics and dots, etc.

In addition to the above features, the following items may be of interest. Once a dot-to-dot has been created, it 
may still be modified by MacPaint. The picture that appears in the DDCS editing window is stored in MacPaint  
format in a DDCS document. The additional dot information is stored as resources in the resource fork of a 
MacPaint type file. Consequently, MacPaint can open and modify the picture of a DDCS dot-to-dot. Just be sure 
to save the modified graphics back into the same file being modified. If you issue a 'Save as' command from 
MacPaint the accompanying dot information will not be present in the newly created file.
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Cut, Copy, and Paste become active when editing text. Paste is also useful when copying a picture from the 
Scrapbook to DDCS. Note the following: To paste text, the text edit title field must have been clicked to make it  
active. Otherwise DDCS will attempt to paste a picture. Conversely, to paste a picture, one of the editing tools  
must be active, otherwise the text edit field is active and DDCS will attempt to paste text. If you have copied a 
picture from the scrapbook and don't seem to be able to paste it to the edit window, first check to make sure one 
of the editing tools is active and not the text-edit field!

Lastly, when you are going from the editor to the play environment, all letters in the alpha window will be grayed  
out, because there is no longer a default volume. Using the editor may have changed the volume information  
considerably, so the old default is not stored. If you wish to search a volume for dot-to-dot files after leaving the 
editor,  you  must  use  the  'Change  default  volume'  command  explicitly.  This  should  not  normally  cause  an 
inconvenience since frequent travel between the editor and the play environment generally means that you are 
editing dot-to-dots and not playing a sequence of them. In such a case there is no need to have a default search 
volume active.
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