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Welcome to the TurboDraw Help.

From this page you can get Help on any of the TurboDraw features, tools and menu options, open a list 
of keyboard shortcuts, or learn more about the Help system itself.

Click on a button to make your choice.
          Beginners  
          How To ...  
          Toolbars  
          Menus  
          Keyboard shortcuts  
          Glossary  
          About IMSI  
          Stop Press!  

How to choose a Help topic

Point to your choice and click.

Use Tab or Shift Tab to highlight your choice, then press Enter.

For more information about using help, select How to Use Help from the Help menu.



How To ...

Click on a button for more Help with procedures in TurboDraw.
          Start work  
          Work with pictures  
          Use layers and templates  
          Draw  
          Create text  
          Arrange objects  
          Shape and blend objects  
          Transform objects  
          Use colors, lines and fills  
          Use TurboDraw with other applications  
          Print pictures  



Menus

There are nine menus in the TurboDraw menu bar.    Click on one of the options below to see a list of 
corresponding menu commands.

          File   menu  
          Edit   menu  
          View   menu  
          Object   menu  
          Line   menu  
          Fill   menu  
          Options   menu  
          Window   menu  
          Help   menu  

Note:

Some menu commands may appear in gray.    This indicates that they are not available at the 
moment, although they may become available once you have carried out another command.    For 
example, the Paste command in the Edit menu is not available until you have used the Cut or Copy 
command and therefore have an object to paste.

Some menu commands are followed by ..., which indicates that clicking on that command will display 
a dialog box. Other menu commands are followed by an arrowhead, which indicates that clicking on 
that command will display a submenu.

Many of the commands can also be carried out using the keyboard.    If a keyboard shortcut is 
available, it will be listed beside the command in the menu.    The ^ symbol represents Ctrl.



Keyboard shortcuts

If you are familiar with Windows, you will already know that there are many keyboard equivalents to 
using the mouse.

TurboDraw provides its own additional equivalents and shortcuts, and these are listed below.

Function key shortcuts

F1 Start the Help facility

Shift F1 Display the Help pointer so that you can ask for help

F2 Save the picture in the active window

F3 Undo the last command

F4 Redo the last Undo command

F5 Repeat the last transformation

F6 Toggle the display of the picture in the active window between outline and preview 
format

F7 Display the picture in the active window at its actual size 

Shift F7 Display the picture in the active window in whole page view

F8 Enlarge the picture in the active window (to the next standard magnification)

Shift F8 Reduce the picture in the active window (to the next standard magnification)

F10 Pass control to the menu bar

Additional keyboard shortcuts

Enter Select the pointer tool

Space Deselect all points (leaves paths selected)

Esc Deselect all selected objects

Del Delete all selected objects

Backspace Delete all selected points on paths

 ¯ ¬ ® When no object is selected, scroll the active window: Up, down, left or right

If scroll lock is off and one or more objects is selected, nudge the object(s)

PgUp Scroll the active window up by a screen

PgDn Scroll the active window down by a screen

Ctrl PgUp Scroll the active window left by a screen

Ctrl PgDn Scroll the active window right by a screen

Tab Select the next object in the stacking order

Shift Tab Select the previous object in the stacking order

Additional menu command shortcuts

Alt A Select all the objects in the picture in the active window

Ctrl A Display the Align dialog box

Ctrl B Move the selected objects to the back of the picture

Ctrl C Copy the selected objects to the Clipboard without removing them from the picture

Ctrl F Move the selected objects to the front of the picture

Ctrl G Group the selected objects



Ctrl H Hide the selected objects

Ctrl I Display the object properties dialog box for the selected object

Ctrl J Join two end points, or join text to a path

Ctrl L Lock the selected objects

Ctrl M Combine the selected paths to create a compound path

Ctrl N Unlock the selected objects

Ctrl P Print the current drawing

Ctrl S Split a path at the selected points, or separate text from a path

Ctrl U Ungroup the selected group

Ctrl V Paste the contents of the Clipboard into the picture in the active window

Ctrl W Show all hidden objects

Ctrl X Cut the selected objects from the picture to the Clipboard

Ctrl Y Redo the last action

Ctrl Z Undo the last action

Text editing shortcuts

These shortcuts are available only when the text tool is selected and the text cursor is placed within a 
text object.

Alt ¬ ® Rotate the text insertion point clockwise or counterclockwise to enter text at an angle

Enter Insert a line break

Space Insert a space

Esc Deselect any text and return the text insertion point to an upright position if it has been 
rotated

Del Delete the text selection or the character to the right of the text insertion point

Backspace Delete the text selection or the character to the left of the text insertion point

¬ ® Move the text insertion point left or right one character, or when there is a text 
selection, move the text insertion point to the start or end of the selection and deselect 
the text

 ¯ Move the text insertion point up or down one line

Shift click Select the text between the position of the text insertion point and the position of the 
click





Click on a tab for more glossary entries:

- A -

Active window

Alignment

Align to page

Align to rulers

Align

Arc

Arrowhead

Auto curvature

Auto scroll

Autotrace

Axis

- B -

Background

Baseline

Basic shape

Bezier path

Bevel

Bitmap

Blend

Blend stages

Bold

Box

Butt

- C -

Cascade

Character

Check box

Clipart

Clipboard

Closed path

CMYK



Color model

Color bar

Color palette

Color separation

Command

Compound path

Compress

Connect point

Container

Control lines

Control menu

Control points

Convert to path

Copy

Corner point

Corner radius

Crop marks

Curve point

Custom page

Cut

Cylindrical



Click on a tab for more glossary entries:

- D -

Defaults

Dialog box

Directory

Dither

Dock

DPI

Duplicate

- E -

Ellipse

Embed

Ends

EPSF

Expand

Export

- F -

File

File extension

File format

Fill style

First point

Fixed point

Floating toolbox

Font

Foreground

Freehand path

Frequency



Click on a tab for more glossary entries:

- G -

General Tools

Greeking

Grid

Group

- H -

Hairline

Halftone

Handles

Hidden objects

HLS

Hue

- I -

Icon

Import

Information line

In-place editing

Insertion point

Intersection area

Italic



Click on a tab for more glossary entries:

- J -

Join

Join range

Justification

- K -

Kerning

Keyboard alternatives

Keyboard shortcuts

- L -

Landscape

Layer zero

Leading

Letter spacing

Lightness

Line-art

Line style

Linear

Link

List box

Locked objects

Lower

Logarithmic

- M -

Magnification

Menu

Menu bar

Metafile

Miter

Multi-layer



Click on a tab for more glossary entries:

- N -

Negative

- O -

Object

OLE

Open path

Outline format

Overprint

- P -

Page box

PagePilot

Pantone

Paste

Paste inside

Path

Pattern

PCX

Pica

Picture window

Pie slice

Pixel

Point

Pointer

Polygon

Portrait

PostScript

PostScript fill style

PostScript line style

Preferences

Preview format

Preview box



Printable area

Printing to disk

Process color



Click on a tab for more glossary entries:

- R -

Radial

Raise

Redo

Reflect

Reflection axis

Registration

Registration marks

Reversed

RGB

Rotate

Round box

Round

Ruler

Ruler origin

- S -

Saturation

Scale factor

Scaling (printing)

Scanner

Screen

Scroll bar

Select

Selection frame

Selection range

Skew

Snap control

Spherical

Split path

Spot color

Square

Standard view size



Star



Click on a tab for more glossary entries:

- T -

Template

Text frame

Text object

Text on a path

Text Tools

TIFF

Tiling

Tint

Title bar

Toggle

Toolbox

Trace

Transform

Trap

Typeface

- U -

Undo

Ungroup

- V -

Vector font

Vector-based

View size



Click on a tab for more glossary entries:

- W -

Work area



Active window

The window or icon that you are currently using or that is currently selected.    Only one window or icon 
can be active at a time.    When a window is active, its title bar is highlighted to differentiate it from other 
windows; when an icon is active, its label is highlighted.



Alignment

The positioning of text: Left aligned, right aligned, centered or justified.



Align to page

A setting that makes the grid align with the top left-hand corner of the page.



Align to rulers

A setting that makes the grid align with the ruler origin.



Align

The positioning of objects relative to each other or to the page.



Arc

A curve that is a segment of the circumference of an ellipse.



Arrowhead

An arrow symbol that you can select for each end of a line style.



Auto curvature

The production of a smooth curve through a point that depends on the position of adjacent points.    A 
point has auto curvature when it is created.



Auto scroll

The ability of the picture window to scroll automatically when you drag the pointer beyond the borders.



Autotrace

To trace an outline around an imported bitmap automatically.



Axis

The line in which objects are reflected in a reflect transformation.    The reflection axis passes through 
the fixed point.



Background
The name of layer 10.
The unset bits in a bitmap.



Baseline

An imaginary line on which text rests.



Basic shape

A box, round box, ellipse, arc, pie slice, polygon or star, created with one of the shape tools.



Bezier curve

A smooth curve, defined by control points.



Bevel

A style of line join in which the corner is cut off.



Bitmap

A picture composed of individual pixels (dots) created with a paint program or with a scanner.    In 
contrast, TurboDraw creates pictures using vector-based graphics.



Blend

The insertion of intermediate paths between two paths or basic shapes, with a transition of line styles 
and fill styles from one end to the other.



Blend stages

One of the intermediate paths inserted between two paths or basic shapes during a blend operation.



Bold

A weight of text characterized by thick heavy lines.



Box

A rectangle or square drawn using the Box tool.



Butt

A squared-off end type for a line style, which does not project beyond the end of the line.



Cascade

An overlapping arrangement of windows on the desktop, with the title bar and left-hand edge of each 
window remaining visible.



Character

Any single letter, number, punctuation mark, or symbol.



Check box

A small, square box displayed in a dialog box that can be selected or cleared.    When a check box is 
selected, an X appears in the box.

A check box represents an option that you can turn on or off.



Clipart

Files imported into TurboDraw to provide convenient, ready-made components of pictures.



Clipboard

A temporary storage location used to transfer data within and between applications.    The Cut and Copy 
commands transfer data to the Clipboard, and the Paste command inserts the data at your selected 
position.



Closed path

A path with no end points.    Closed paths can be filled.



CMYK

A color model of subtractive mixing with cyan, magenta, yellow and black used to make any other color. 
Black is used to replace equal mixtures of the other three colors to produce better dark colors.



Color model

A method of describing a color as a mixture of other colors (e.g. RGB and CMYK), properties of the 
color (e.g. HLS) or with reference to a standard set of colors (e.g. Pantone).



Color bar

The line of colors shown at the foot of the TurboDraw window.    You can add colors to the color bar, edit 
existing colors and delete colors from it.    You can also change the number of tints of each color that are 
shown in the color bar.



Color palette

A set of colors available to your TurboDraw pictures.    You can create more colors to add to the color 
palette, or you can delete colors if you do not want to use them.    When you save a picture, the color 
palette is saved as part of the picture, with any changes that you have made.    Each picture can be 
saved with a different selection of colors in the palette, and the pictures palette is displayed in the color 
bar at the foot of the TurboDraw window.



Color separation

A technique used in color printing.    A color picture is separated into a number of components, each of 
which is printed using a single color.    The combination of separate components reconstitutes the 
original full color picture.

The color of each separation depends on the color model used.



Command

A word or phrase - usually found in a menu - that you choose to open a dialog box or carry out an 
action.



Compound path

A path made by combining a number of closed paths.



Compress

To compress the character width of your text selection, or to preset the width before entering text.



Connect point

The type of point drawn by the Connect tool to provide a smooth transition from a straight to a curved 
line.



Container

A Windows application, e.g. TurboPublisher, that can accept linked or embedded objects from other 
applications.



Control lines

Lines used to connect control points to points on paths.    The length and direction of the control lines 
control the direction and curvature of the path at the point.



Control menu

A standard Windows menu displayed by clicking on the bar-shaped icon at the top left-hand corner of 
any window.    The Control menu contains commands you can use to manipulate the window.

Icons and some dialog boxes also have a Control menu.



Control points

+-shaped handles at the end of control lines.    The handles are dragged to change the length and 
direction of the lines.



Convert to path

A command used to change basic shapes and text objects into paths.



Copy

To place a copy of the selected object(s) onto the Clipboard so that you can transfer it to another 
location.



Corner point

The type of point drawn by the Corner tool used to connect straight sections of a path.



Corner radius

The radius used to create the curvature of a round box.



Crop marks

Hairlines drawn on a printout to mark the edge of the picture when the printout is tiled or printed on 
paper larger than the picture.



Curve point

The type of point drawn by the Curve tool to connect curved sections of a path smoothly without a 
corner.



Custom page

A user-defined page size.



Cut

To move the selected object(s) from your picture onto the Clipboard so that you can transfer it to another 
location.



Cylindrical

A graduated fill style comprising of symmetrical bars fading from one color at each edge of the object to 
another color in the center.



Defaults

Settings that are supplied with TurboDraw.    For example, if you start a new picture without specifying a 
paper size, TurboDraw uses its default setting, that is Letter.



Dialog box

A window that appears temporarily to supply information to TurboDraw.    When a dialog box appears, all 
interaction with TurboDraw must be through the dialog box.



Directory

Part of a structure for organizing your files on a disk.    A directory can contain files and other directories 
called subdirectories.



Dither

To create the illusion of a color by placing dots of other colors very close together.    In TurboDraw, a 
color is dithered when the display device does not support that color.



Dock

You can move the toolbox and five toolbars around the desktop and leave them wherever you like.    
When they are attached to the edge of the window, they are docked.    When they are away from the 
edge and displayed in a box, they are floating.



DPI

The number of dots (pixels) per inch that a printer can produce.    Most laser printers print at 300 dpi.    
High-resolution phototypesetters provide 1270 and 2540 dpi.

The higher the dpi, the sharper the picture.



Duplicate

To make a copy of a TurboDraw object on the screen without using the Clipboard.



Ellipse

A regular oval drawn using the Ellipse tool.    The most regular oval is a circle.



Embed

To copy a TurboDraw object into another application, e.g. TurboPublisher, using OLE.    By embedding 
an object, you can edit it without having to leave the container application.

When you embed an object, a copy of the object file is made and stored within the container application: 
The original object file is not altered in any way and remains available for future use.



Ends

A component of a line style allowing the ends of an open path to be made round, square or butt.



Expand

To expand the character width of your text selection, or to preset the width before entering text.



EPSF

Encapsulated PostScript Format - a line-art format that can be handled by TurboDraw.



Export

To save all or part of a picture in one of a number of file formats used by other applications.



File

A picture or document stored on a hard or floppy disk, or any other media.



File extension

The full-stop and up to three characters at the end of a filename.    An extension usually identifies the 
kind of information a file contains.    For example, files that you create using TurboDraw have the .ART 
extension.



File format

The way in which information is structured in a file.    Applications always store files in a particular format. 
A format readable by one application may not be readable by another application.



Fill style

The attribute of closed paths, text objects and basic shapes specifying how the space enclosed by their 
outlines should be filled.    Fill styles can have different colors, and can be plain or graduated from one 
color to another in a number of different styles. 

Patterns comprising of tiled groups of objects can be used to define fill styles.    A range of predefined 
PostScript fill styles can be used with PostScript printers.



First point

The point on a path or basic shape that is used as the reference point for a blend if no points are 
selected.



Fixed point

The point around which the scale, rotate, reflect and skew transformations are performed.



Floating toolbox

The optional display of the TurboDraw toolbox in a moveable window.



Font

This is used in TurboDraw to mean the style of type e.g. Arial or Times New Roman.    Elsewhere this 
may be called a typeface, with the term 'font' reserved for a particular weight, size and style of typeface.



Foreground

The name of layer 100.

The set pixels of a bitmap.



Freehand path

A path drawn by dragging the Pencil tool.



Frequency

The density of dots used to produce a screen for halftone printing or color separation.



Greeking

The representation of text by simple strokes.



Grid

An optional overlay of crossed lines to help accurate positioning of an object in a picture.    Precise 
positioning is assisted by the option of making objects snap to the grid when they are created, moved or 
transformed.



Group

A set of objects grouped together so that they behave as a single object.



Hairline

A line displayed or printed at the finest resolution possible of the particular screen or printer.



Halftone

The printing of shades of gray on a black and white printer, using different densities of black dots.



Handles

Small boxes or circles that are displayed on selected objects.    Handles can be dragged to change the 
shape of the object.



Hidden objects

Objects that have been hidden using the Hide command.    You can choose whether or not to print 
hidden objects.



HLS

A color model using Hue, Lightness and Saturation to specify a color.



Hue

The position of a color along the color spectrum from 0 to 360 degrees where red is 0, yellow is 60, 
green is 120, cyan is 180, blue is 240, magenta is 300 and red is 360, again.



Icon

A graphical representation of a disk drive, a directory, an application, a picture window or other object 
that you can select and open.



Imagesetter

An electronic typesetter than can handle graphics as well as type.    Imagesetters typically have a 
resolution of 600 dpi (dots per inch) or better.



Import

To load a graphic into TurboDraw in one of a number of file formats used by other applications, usually 
to provide convenient, ready-made components of pictures.



Information line

A bar at the foot of the TurboDraw desktop giving information on layers and objects:



In-place editing

To edit an embedded TurboDraw object without having to open TurboDraw.    The TurboDraw menus, 
toolbars and other controls necessary to edit the object temporarily replace the existing menus and 
controls of the container application.

Linked TurboDraw objects cannot be edited in-place.



Insertion point

The vertical line that indicates where text editing will take place.



Intersection area

The point where the rulers intersect.    This intersection area displays the currently selected unit of 
measurement.



Italic

A style of text characterized by letters slanting to the right.



Join

A command joining together the open ends of paths or joining text to a path 

A property of a line style specifying how line segments are joined at corner points.



Join range

The distance used to determine whether end points should be joined together by a path using the Join 
command or when using a path tool.



Justification

The layout of text across a text frame or along a path so that it fills the width of the frame or the length of 
the path.    Justified text in a text frame will have straight left- and right-hand edges.



Kerning

Increasing or reducing the space between characters.



Keyboard alternatives

An alternative to using the mouse for selection.    Keyboard alternatives are shown on screen by 
underlining a letter in menu titles, dialog boxes and so on.



Keyboard shortcuts

A means of carrying out a command from the keyboard without displaying a menu first.    Shortcuts are a 
replacement for several mouse selection operations.    If there is a keyboard shortcut, it is shown after 
the command in the menu.    Not all menu commands have keyboard shortcuts.



Landscape

The orientation of a page in which the horizontal size is greater than the vertical.



Layer zero

The lowest layer in a picture.    Layer zero is used to store bitmaps for tracing or templates for 
positioning objects.

By default, layer zero is not printed.



Leading

The spacing between lines of text.    The name comes from the use of strips of lead to separate lines in 
traditional printing methods.



Letter spacing

The amount of space automatically inserted between characters to achieve justified lines of text.



Line-art

Pictures defined as a series of straight and curved lines rather than dots.    Drawing packages produce 
line-art.    Compare with bitmap.



Lightness

The percentage by which a color approaches black (0 percent) and white (100) percent.



Line style

The attribute of paths, text objects and basic shapes specifying how the line or outline should be drawn. 
Line styles can have different widths and colors. 

Custom line styles can be made up of different patterns of dashes.    A range of predefined PostScript 
line styles can be used with PostScript printers.



Linear

A graduated fill style flowing in a single direction fading from one color to another.



Link

To create a reference in a container application, e.g. TurboPublisher, to a TurboDraw object.

By creating links between files, you save time and ensure consistency in your work.    You can share 
information from one file with several others, and you need only maintain the original: The others are 
automatically updated.



List box

Within an application window or a dialog box, a type of box that lists available options.    If all the options 
do not fit in the list box, the box becomes scrollable.



Locked objects

Objects that have been locked using the Lock command.    Locked objects cannot be manipulated in 
any way, but they can be hidden.



Logarithmic

A graduated fill style where one color fades away quickly and then tapers off to the final color.



Lower

To lower the characters in your text selection below the baseline, or to preset the position before 
entering.



Magnification

The view size of the picture in the active window.



Menu

A list of available commands in TurboDraw.    Menu names are displayed in the menu bar near the top of 
the desktop.



Menu bar

The horizontal bar containing the names of the TurboDraw menus.    The menu bar is displayed below 
the title bar:



Metafile

A type of file format for line-art.



Miter

A style of line-join in which the lines extend to a point at the join.



Multi-layer

A TurboDraw picture with more than one layer.



Negative

A print option interchanging black and white.    This may be needed when printing to a file for use by a 
commercial printer.



Object

A basic shape, path, text object, imported bitmap or group.



OLE (Object Linking and Embedding)

A way to transfer and share files between applications.    OLE provides a means to create files consisting 
of multiple sources of information from different applications.



Open path

A path with two separate end points.



Outline format

A simplified picture display allowing rapid redrawing.



Overprint

A property that can be given to line styles and fill styles when the page format has color separation 
selected.    When a line or fill style without the overprint property overlaps another object, the color lying 
under the line or fill is removed when color separations are produced.    This is sometimes called under 
color removal.    However, if a line or fill style has the overprint property selected, it is printed on top of 
the underlying object without under color removal. 

Under color removal prevents the color of the foreground object being mixed with the underlying color, 
but imperfect registration of the color separations may produce a white hairline around the foreground 
object.    Overprinting can be used to make traps which prevent unwanted color mixing and offset the 
effects of imperfect registration.



Page box

The blue rectangular outline on the work area marking the position of the page, which is specified using 
the Page Format dialog box.



PagePilot

A PagePilot is a feature that can quickly create a certain kind of picture, such as a certificate. It does this 
by asking you questions and using your answers to automatically lay out and format the type of picture 
you specify. Each PagePilot gives you a choice of several picture templates.



Pantone

A color model in which colors are specified from a standard reference set.



Paste

To insert the contents of the Clipboard into a picture.



Paste inside

To paste an object that has been cut from a picture inside a closed path.    Paste inside inserts the object 
in the picture but makes visible only those parts of it lying within the closed path.



Path

A straight or curved line consisting of one or more segments joined together at points.



Pattern

A group of objects tiled to use as a fill style.



PCX

A standard file format for bitmaps.



Pica

A typesetting unit, equal to 1/6 inch.



Picture window

A window on the TurboDraw desktop containing a work area for a picture.    There can be several picture 
windows open on the desktop at the same time.    These may contain different pictures or different views 
of the same picture.



Pie slice

A segment of a circle or other ellipse, drawn using the Pie tool.



Pixel

One of the dots making up a picture displayed on the screen.



Point

The corner, curve and connector points used to define paths.

The unit used to measure text: 1 point = 1/72 inch



Pointer

The arrow-shaped cursor on the screen that follows the movement of the mouse and indicates which 
area of the screen will be affected when you press the mouse button.

The pointer will change shape when performing certain tasks and when changing tools.



Polygon

A regular shape with three or more sides, drawn using the Polygon tool.



Portrait

The orientation of a page in which the vertical size is greater than the horizontal.



PostScript

A language used to describe how text and graphics should be printed on a page.    PostScript printers 
are able to interpret the language to produce printed output.    The PostScript page description does not 
depend on the resolution or other properties of the printer, so the same PostScript description can be 
printed out on any PostScript printer, imagesetter or film recorder using its full resolution.



PostScript fill style

A fill style with a PostScript definition, which can be printed on a PostScript printer but not displayed on 
screen.



PostScript line style

A line style with a PostScript definition, which can be printed on a PostScript printer but not displayed on 
screen.



Preferences

A set of values and selections used to configure the desktop when TurboDraw starts up.



Preview format

A screen display representing the printed form of a picture as closely as possible.



Preview box

A box in some dialog boxes showing the effect of selecting items.



Printable area

The area of the page that the printer can print to, marked by the page box.



Printing to disk

To send output for printing to a disk instead of a printer so that the picture can be printed at another time 
or on specialist commercial printing equipment.



Process color

A color model of subtractive mixing with cyan, magenta, yellow and black used to make any other color. 
Black is used to replace equal mixtures of the other three colors to produce better dark colors.



Radial 

A graduated fill style comprising of circles with equal graduation intervals from the center to the 
circumference.



Raise

To raise the characters in your text selection above the baseline, or to preset the position before 
entering text.



Redo

To redo an edit or transformation that has been undone with the Undo command.



Reflect

A transformation performed with the Reflect tool or one of the reflect buttons in the Transform Tools.



Reflection axis

The line in which objects are reflected in a reflect transformation.    The reflection axis passes through 
the fixed point.



Registration

The alignment of the tiles in a tiled picture to make up the complete picture.

The alignment of color separations to reconstitute the full color version.



Registration marks

Marks on printouts used to assist registration.



Reversed

An option in printing producing a reversed bitmap.    This can be useful when preparing a picture for 
some kinds of commercial printing.



RGB

A color model for additive mixing, in which Red, Green and Blue are mixed to produce any color.



Rotate

A transformation performed with the Rotate tool or one of the rotate buttons in the Transform Tools.



Round box

A box with rounded corners.



Round

A type for the Join and Ends properties of a line style.



Ruler

Optionally displayed rules at the top and left-hand side of each picture window.



Ruler origin

The point on the desktop that measures zero on both horizontal and vertical rulers.



Saturation

The intensity of a color, or how much hue is present or absent.    Completely saturated color is color at 
its most intense (100 percent).    At its least intense, a color is gray (0 percent).



Scale

To increase or decrease the size of an imported bitmap or line-art.



Scale factor

The percentage by which a scaling operation changes the size of a picture or selected objects.    There 
may be different scale factors for the vertical and horizontal directions.



Scaling (printing)

The application of a scale factor to change the size of a picture when it is printed.



Scanner

A device used to convert a picture on paper to a bitmap in a computer.



Screen (printing)

Traditional printing technology uses a mesh screen in a process camera to convert shades of gray to 
different sized dots.    In electronic publishing the screen frequency, angle and type refer to the density, 
angle and shape of the dot pattern calculated to represent gray shades for black and white printing or 
different color intensities for color separations.



Scroll bar

A bar that is displayed at the bottom and/or right edge of a window whose contents are not entirely 
visible.



Select

Choose an object on which your next action will be carried out

Choose a command, option button or check box.



Selection frame

A rectangle dragged out with the Pointer tool to select any item in the rectangle when the mouse button 
is released.



Selection range

The distance around the Pointer tool within which an object will be selected if the mouse button is 
clicked.



General Tools

Tools that perform common commands such as Cut, Copy, Paste and Transform Again.    Click on a 
button to perform the command. 

The General Tools can be docked at any edge of the desktop, or they can be displayed in a floating box.



Skew

A transformation performed using the Skew tool or one of the skew buttons in the Transform Tools.



Slider

A box which allows you to adjust the tint of a color on a scale from 0% to 100% (or from 0 to 255 or 360) 
in drop-down color palettes.



Snap control

Force objects to align to the grid.



Spherical

A graduated fill style comprising of circles with increasing graduation intervals from the center to the 
circumference.



Split path

Break a path at a selected point.    An open path is split into two shorter open paths; a closed path 
becomes an open path; a compound path cannot be split until it has been ungrouped into separate 
paths; text on a path is separated from the path.



Spot color

A color specified as a spot color can have its own separation when it is printed instead of being made up 
of a mixture of process colors.



Square

One of the types for the Ends property of a line style.    Unlike the butt end style, square line ends 
project half the line's width beyond the end of the line.



Standard view size

You can view your picture at a custom magnification, or at one of the standard view sizes: 25%, 50%, 
100%, 2x, 4x, 8x, 16x, Whole Page, Page Width or Zoom To Selection.



Star

A regular shape with three or more radiating points, drawn using the Star tool.



Template

A file type for storing pictures used as a basis for other pictures.

The name of layer zero.



Text Tools

A set of text functions that are displayed when the Text tool is selected.    Use the Text Tools to set the 
font, size, style and alignment of text, to adjust the set width and kerning, to raise or lower the text, and 
to turn autokerning on or off. 

The Text Tools can be docked at the top or bottom of the desktop, or they can be displayed in a floating 
box. 



Text frame

A box marking the boundary of a text object.



Text object

A text item in a picture.    A text object can be manipulated in the picture in the same way as any other 
object.



Text on a path

Text flowing along a path.



TIFF

Tagged Image File Format - a standard file format, often used to store scanned bitmaps.



Tiling

Placing shapes adjacent to each other.    In TurboDraw objects can be tiled to make pattern fill styles, 
printouts can be tiled to produce a picture larger than the size of the paper, and picture windows can be 
tiled so that they are all visible on the desktop.



Tint

The proportion of hue in a defined object.    The remaining portion is white.



Title bar

The horizontal bar that contains the title of the window or dialog box.



Toggle

A command that is turned on or off using the same action.    For example, you can turn the display of the 
information line on and off by selecting Information Line from the submenu that appears when you 
select Show Controls from the View menu.



Toolbar

The display of TurboDraw buttons at the edge of the work area, or floating on the desktop. TurboDraw 
has five toolbars: The General Tools, the Transform Tools, the Align Tools, the Object Tools, and the Text 
Tools.



Toolbox

The display of TurboDraw tools at the edge of the work area, or in the floating toolbox.



Trace

To construct a path around a bitmap, either manually or automatically.



Transform

To edit an object by moving, scaling, skewing, rotating or reflecting it.



Trap

A device to overcome the effect of imperfect registration when printing spot color separations for 
superimposed objects.    The foreground object is given an overprinted outline (i.e. under color removal 
is not applied to the outline).    This must be wide enough to cover any gaps that might appear because 
of imperfect registration between the foreground and background separations.



Typeface

The style of type e.g. Arial.    TurboDraw more commonly uses the term font to refer to the style of type.



Undo

To undo the last edit or transformation and restore the picture to its former state.



Ungroup

Separate a group into individual objects

Change a basic shape into a path.



Vector font

A font using lines instead of filled outlines.



Vector-based

Describing a drawing as a series of lines and arcs instead of as a bitmap.



View size

The magnification of a TurboDraw picture.



WYSIWYG

What You See Is What You Get: The ability to show on screen an accurate representation of what will 
be printed.



Work area

The area within which a TurboDraw picture is created.





Beginners

Welcome to TurboDraw!    If you are new to desktop design, this section is just what you need to help 
you get started. Simply click on the topic you want to read and it will appear in this Help window.

For further information on using the Help, select How to Use Help from the Help menu.

   How do I start work?  

   What is everything on the desktop?  

   Can I customize the desktop?  

   How do I start to draw?  

   How do I color my picture?  

   How do I create special effects?  

   What if I make a mistake?  



How do I start work?

You can start work in any of the following ways:

By running a PagePilot

By creating a new picture from a template

By creating a new picture from a blank page

By opening an existing picture.

These options are all reached from the New Picture Options dialog box.    This dialog box appears 
when you start TurboDraw, and when you start a brand new picture.

If you have not used TurboDraw before, it is easiest to start work by either running a PagePilot or 
loading a template, because these options give you pre-defined guidelines within which you can work; 
i.e. some of the work involved in laying out the picture has already been done for you.

Running a PagePilot

Run a PagePilot to create a picture quickly and easily. Simply choose the type of picture you want to 
create and let the PagePilot guide you through some simple selections. Then watch the PagePilot 
create the picture for you. You can make changes to your picture when the PagePilot has created it.

Loading a template

You can load a template on which to base your new picture. This option is useful if you want to use a 
pre-defined layout for commonly used pictures, such as certificates or invitations. Several templates are 
supplied with TurboDraw to get you started; you can add to them by designing your own when you are 
ready.    If you use a particular template more frequently than any other, you may find it useful to make it 
the default template.

Starting from a blank page

Starting from a blank page gives you greater control over the layout of your picture than either templates 
or pilots, but it needs more initial planning. You can plan your layout and the size of your paper before 
you begin to draw, or you can change it afterwards in the Page Format dialog box.

Opening an existing picture

You can open an existing picture to continue working on it. There are several sample pictures supplied 
with TurboDraw. You can modify these for your own needs, or just look at them for ideas of what you can 
do in TurboDraw.



See also:

   Starting a new picture  

   New Picture Options   dialog box  

   Understanding PagePilots  

   Running a PagePilot  

   Starting a new picture from a template  

   Using templates  

   Opening an existing picture  

   Opening a recently used picture  

   Page Format   dialog box  



How do I start to draw?

Pictures in TurboDraw are made up of individual components, such as layers, text and graphics.    
Before you start work, you decide on the page, paper size and overall layout of your picture, either 
through using a template or PagePilot, or by designing your own page layout.    (However, you can 
change your mind about the page layout later, and change it in the Page Format dialog box.)

TurboDraw is WYSIWYG; this means that you can see what your picture will look like before you print it 
out.

You can build up your picture using a variety of techniques.    Most designs can be started from basic 
geometric shapes which you can reshape and manipulate: TurboDraw has tools for drawing all the basic 
shapes.    For precision drawing, you can use the Pencil tool, which is like using an ordinary pencil for 
drawing on paper.

Objects

TurboDraw pictures can consist of up to five types of object:

Basic shapes: Boxes, rounded boxes, ellipses, arcs, pie slices, polygons and stars. Basic shapes 
are created with the Shape tools.

Paths, consisting of straight or curved lines joined together at points. Paths are created with the 
Drawing tools.

Text objects, created with the Text tool.

Images: These are bitmap pictures created with a painting package and imported into TurboDraw.

Groups: These are sets of objects that you have grouped together so that operations apply to 
them as if they were a single object.

Drawing a simple shape

To draw a shape, click on the tool for that shape, and then click on the picture window and drag the 
shape to the size you want.

For instance, to draw a rectangle, click on the Box tool.    Then click on the picture, and drag the 
rectangle until it is the correct size.

To draw a line, select the Pencil tool, and then click and drag it on the picture.    To draw a straight line, 
hold down Shift while you drag.

Creating more complex shapes

With TurboDraw, you can create complex shapes and manipulate them to get exactly the result you 
want.    Most of the Drawing tools are self-explanatory, but some allow you to perform advanced drawing 
techniques.

The Corner tool is for drawing straight lines with right-angle turns in them.    The Curve tool is for drawing 
smoothly curved paths.    The Connect tool is used for making smooth connections between corner and 
curve points.    The Bezier tool is a combination of all three of these, and you use it to draw smoothly 
connecting straight lines and curves without having to change tools.

Using layers



TurboDraw allows you to build up your pictures in layers. A simple picture can be created on a single 
layer, but more complex pictures are easier to work with if you build them up over several layers.    You 
could, for example, use one layer for all the background objects, and another layer for the foreground 
objects.    Pictures such as technical drawing plans are easier to work with if they are created on several 
layers.

When you create a picture on several layers, you can work on one layer at a time.    Working with 
individual layers helps you to focus on precise details without being distracted by the rest of the picture. 
If you try to create a complex picture on a single layer, you will probably encounter problems when 
moving objects to different positions, selecting objects for patterns and colors, and trying to see objects 
that are hidden by others.



See also:

   Page Format   dialog box  

   Drawing a shape  

   Importing graphics  

   Using the Corner tool  

   Using the Curve tool  

   Using the Connect tool  

   Using the Bezier tool  

   Using layers  



How do I color my picture?

Adding color to your drawing is simple with the color bar.

TurboDraw shapes have a line style (the color of the edge) and a fill style (the color filling the shape).    
Of course, paths do not have fill styles, as they are simply lines.

To change the color of a shape's line style, select the shape and then click with the right mouse 
button on the color you want in the color bar.

To change the color of a shape's fill style, select the shape and then click with the left mouse 
button on the color you want in the color bar.

To remove a line or fill style from a shape, select the shape and then click with the appropriate 
mouse button on the X button at the end of the color bar.

Color and color separation

You can add color to any aspect of your picture. You can use and modify the colors supplied in the 
standard color palette, or start from scratch with no colors and mix your own. You can save colors with 
pictures and templates or within their own palette files.

If high quality color reproduction is important to you, when you have created your color picture, you can 
print it as color separations for professional printing.



See also:

   Applying color  



What is everything on the desktop?

At first glance the TurboDraw desktop may appear busy, but once you know what the tools and buttons 
represent, you will soon be able to find your way around.

The area in which you create pictures is called the picture window.

Across the top of the window is the title bar, showing the title of the picture you are working on.

Across the bottom of the window is the information line, used for displaying messages, tips and other 
information.

Just above the information line is the color bar, which shows the colors you can use in your picture.

Along the edges of the picture window are the rulers, to help you measure and position objects in your 
picture.

Down the left of the TurboDraw window (although you can put it wherever you like) is the toolbox.    This 
contains the tools you need to add things to your drawings.

To manipulate your drawing and perform numerous other functions, TurboDraw has five shortcut 
toolbars.    These toolbars are designed to help you work more quickly, as you do not need to open a 
menu each time you want to perform a task.

To find out what a tool does, point the cursor at it. After a few moments a yellow ToolTip appears, 
displaying the name of the tool or button you are pointing at. The tool name will also be displayed in the 
information line along the bottom of the TurboDraw desktop.

To get information about any part of the desktop, click on the What's This? tool, and then click on the 
relevant part of the desktop.



See also:

   Picture window  

   Title bar  

   Information line  

   Color bar  

   Rulers  

   Scroll bar  

   Sizing border  

   Nudge control  

   Minimize button  

   Maximize button  

   Restore button  

   Control menu  

   Toolbars  

   Toolbox  

   Menus  

   Can I customize the desktop?  



Can I customize the desktop?

Everyone has their own way of working, so the TurboDraw desktop can be changed and rearranged to 
suit your own preferences.

Moving the toolbox and toolbars

The toolbox and toolbars can be either 'docked' (attached to the edge of the picture window) or 'floating' 
(shown in a floating toolbox which can be positioned anywhere on the picture window itself).

To move the toolbox or a toolbar, click on it, hold down the mouse button and drag it to your preferred 
position.    If you drag it to the edge of the desktop, the toolbar will dock there; if you leave it in the 
middle of the desktop, it will float.

You can also determine the position of the toolbox or a toolbar by clicking on it with the right mouse 
button and choosing from the menu that appears.

If you prefer to use the TurboDraw default arrangement of the toolbars, select Reset Toolbars from the 
Options menu (or from the popup menu that appears when you right-click on any of the toolbars).    This 
moves the toolbars back to their default positions.

If you want to position the toolbars yourself, but would like each toolbar to be given a weighting so that, 
for instance, the more important ones are placed above and to the left of others, select Auto Arrange 
Toolbars from the Options menu (or from the popup menu that appears when you right-click on any of 
the toolbars).

Changing the size of the toolbox and toolbars

Each toolbar can also be viewed in various sizes.    To the right of each toolbar is a pair of buttons which 
you can use to change the size of the toolbar.    Click on the right change toolbar size button to expand 
the toolbar, and click on the left one to compress it.

If you cannot see the tool you want on a toolbar, it could well be that the toolbar is too small to display it. 
Expand the toolbar to display all of its tools.

Hiding and displaying the toolbox, toolbars and nudge control

To hide the toolbox, or a toolbar, or the nudge control, select Show Controls from the View menu.    If 
an item has a tick next to it, it will be displayed on the desktop.    Click on an item to remove its tick, and 
click again to replace it.

Arranging picture windows

You can have more than one picture open at once.    Having multiple pictures open allows you to cut, 
copy and paste objects between pictures with ease.    You can also drag an object from one picture, and 
drop it into another.

You can also open more than one window on a picture, by selecting New Window from the Window 
menu.    This lets you see different areas of the same picture at the same time.

When you open several picture windows at a time, some windows overlap or hide others.    You can use 
the Cascade and Tile commands in the Window menu to rearrange all the windows so that some part 
of each window is visible.



See also:

   Displaying your picture in multiple windows  

   Working with multiple pictures  

   Rearranging windows  



How do I create special effects?

One of the strengths of TurboDraw is the ease with which you can create eye-catching and professional-
looking special effects.    In most cases, you simply select the object you want to manipulate, and then 
select the effect you want.

Blending

By blending objects, you can create three-dimensional effects, highlight effects, and effects of one object 
transforming into another.    For example:

Transforming

TurboDraw offers four types of object transformation: Scaling, rotating, skewing and reflecting.    For 
example:

You can transform objects quickly by using the Transform Tools, or you can obtain more accurate effects 
by using the various transform dialog boxes.

Combining paths

By combining paths, you can create a compound path from two or more closed paths.    For example:

Joining text to a path



By joining text to a path, you can create the effect of text flowing around a circle, along a wavy line, or 
around any shape you have drawn.    For example:

You can easily separate the text and the path if you later change your mind

Creating patterns

You can create patterns from groups of objects in your picture.    TurboDraw creates the pattern by tiling 
the group of objects.    The patterns you create can be used as fill styles to fill other objects.    For 
example:



See also:

   Blending objects  

   Scaling an object  

   Rotating an object  

   Skewing an object  

   Reflecting an object  

   Combining paths (compound paths)  

   Joining text to a path  

   Creating patterns  



What if I make a mistake?

If you are new to design and illustration, particularly on a computer, you may need to try something more 
than once before you get the desired effect.    TurboDraw lets you undo commands so that you can try 
something different.

To undo the last command, select Undo from the Edit menu.    You can undo up to the last fifty 
commands.

If you undo a command and then change your mind, you can redo it by selecting Redo from the Edit 
menu.

Shortcuts:



See also:

   Using undo and redo  





    Edit Colors

This is an alternative to the Edit Colors command in the Edit menu.

Click on it to display the Edit Colors dialog box where you can add, modify or delete named colors.



    Fill Styles

This is an alternative to the Popup Fills command in the Fill menu.

Click on it to turn the display of the Fill Style popup on or off.



    Line Styles

This is an alternative to the Popup Lines command in the Line menu.

Click on it to turn the display of the Line Style popup on or off.



    Cut

This is an alternative to the Cut command in the Edit menu.

Click on it to remove selected objects from your picture and place them on the Clipboard, ready for 
pasting.

Keyboard shortcut:    Ctrl X



    Copy

This is an alternative to the Copy command in the Edit menu.

Click on it to copy selected objects from your picture and place them on the Clipboard, ready for 
pasting.

Keyboard shortcut:    Ctrl C



    Paste

This is an alternative to the Paste command in the Edit menu.

Click on it to paste the contents of the Clipboard into your picture.

Keyboard shortcut:    Ctrl V



    Undo

This is an alternative to the Undo command in the Edit menu.

Click on it to undo the last command.    You can undo up to the last fifty commands.

Keyboard shortcuts:    F3 or Ctrl Z



    Redo

This is an alternative to the Redo command in the Edit menu.

Click on it to redo the last command that was undone.

Keyboard shortcuts:    F4 or Ctrl Y



    Transform Again

This is an alternative to the Transform Again command in the Edit menu.

Click on it to repeat the last transformation on the selected object.

Keyboard shortcut:    F5



    Preview

This is an alternative to the Preview command in the View menu.

Click on it toggle between displaying the picture in the active window in preview or outline format.

Keyboard shortcut:    F6



    Actual Size

This is an alternative to the Actual Size command in the View menu.

Click on it to view the picture in the active window at its actual size.

Keyboard shortcut:    F7



    Whole Page

This is an alternative to the Whole Page command in the View menu.

Click on it to view the whole page of the picture in the active window.

Keyboard shortcut:    Shift F7



    Show Grid

This is an alternative to the Show Grid check box in the Grid dialog box.

Click on it to turn the display of the grid on or off for the picture in the active window.



    Snap To Grid

This is an alternative to the Snap to Grid check box in the Grid dialog box.

Click on it to turn snap control on or off for the picture in the active window.



    To Front

This is an alternative to the Bring To Front command in the Object menu.

Click on it to move the selected object(s) to the front of their layer.

Keyboard shortcut:    Ctrl F



    To Back

This is an alternative to the Send To Back command in the Object menu.

Click on it to move the selected object(s) to the back of their layer.

Keyboard shortcut:    Ctrl B



    Group

This is an alternative to the Group command in the Object menu.

Click on it to group the selected objects together.

Keyboard shortcut:    Ctrl G



    Ungroup

This is an alternative to the Ungroup command in the Object menu.

Click on it to ungroup the selected group.

Keyboard shortcut:    Ctrl U



    Join

This is an alternative to the Join command in the Object menu.

Click on it to join two paths together or to join text to a path.

Keyboard shortcut:    Ctrl J



    Split

This is an alternative to the Split command in the Object menu.

Click on it to split a path at the selected point or to split text from a path.

Keyboard shortcut:    Ctrl S



    Lock/Unlock

This is an alternative to the Lock and Unlock commands in the Object menu.

Click on it to lock objects so that they cannot be manipulated; click on it again to unlock the selected 
objects.

This is the same as clicking on the padlock in the information line.

Keyboard shortcuts:    Ctrl L and Ctrl N



    Align

This is an alternative to the Align command in the Object menu.

Click on it to display the Align dialog box for adjusting the alignment of the selected object(s).

Keyboard shortcut:    Ctrl A



    Utilities

Click on this button to drop-down a list of the utilities that you installed with TurboDraw.    You can then 
select the utility that you want to use.



    Object Properties

This is an alternative to the Properties command in the Object menu.

Click on it to display the Properties dialog box for the selected object; the options on this dialog box 
vary depending on the type of object selected.    If more than one object is selected the Multiple 
Objects dialog box appears informing you how many objects are currently selected.

Keyboard shortcut:    Ctrl I



    What's This?

This is an alternative to the What's This? command in the Help menu.

Click on it the display the help pointer.    Position the pointer over an item in the TurboDraw window, e.g. 
a tool or the information line, and click the mouse button.    A window of help information about the item 
you selected appears.

Keyboard shortcut:    Shift F1



    Typeface

Choose a different typeface for your text selection, or preset the typeface before entering text.

Click on the arrow next to the Typeface box to drop-down a list of the fonts that are available to your 
setup.    Click on the font that you want to use.



    Text Size

Choose a different point size for your text selection, or preset the point size before entering text.

Click on the arrows next to the Text Size box to increase or decrease the point size by one point; 
alternatively, enter the size directly.



    Bold

This Text tool is used to style your text selection in bold, or to preset the style of text before typing.

Click on it to turn bold text styling on or off.



    Italic

This Text tool is used to style your text selection in italic, or to preset the style of text before typing.

Click on it to turn italic text styling on or off.



    Autokern

This Text tool is used to automatically kern your text selection.

Click on it to turn autokerning on or off.



    Left-align Text

This Text tool is used to align the selected text object to the left, or to preset the alignment to the left 
before typing text.

Click on it to give your text a flushed left alignment.



    Center Text

This Text tool is used to align the selected text object to the center, or to preset the alignment to 
centered before typing text.

Click on it to give your text a centered alignment.



 Right-align Text

This Text tool is used to align the selected object to the right, or to preset the alignment to the right 
before typing text.

Click on it to give your text a flushed right alignment.



    Justify Text

This Text tool is used to align the selected object to the left and right, or to preset the alignment to the 
left and right before typing text.

Click on it to give your text a fully justified alignment.



    Increase Width

This Text tool is used to expand the characters in your text selection, or to preset the width before typing 
text.    You can only preset the width if the text insertion point is on the page.

Click on it to expand the characters by 10%.

When the Text Tools are fully expanded, you can enter the exact percentage by which you want to 
expand your text.



    Decrease Width

This Text tool is used to compress the characters in your text selection, or to preset the width before 
typing text. You can only preset the width if the text insertion point is on the page.

Click on it to compress the characters by 10%.

When the Text Tools are fully expanded, you can enter the precise percentage by which you want to 
compress your text.



    Raise Text

This Text tool is used to raise the characters in your text selection above the baseline, or to preset the 
position before typing text. You can only preset this if the text insertion point is on the page

Click on it to raise the characters by 1 point.

When the Text Tools are fully expanded, you can enter the precise number of points by which you want 
to raise your text.



    Lower Text

This Text tool is used to lower the characters in your text selection below the baseline, or to preset the 
position before typing text. You can only preset this if the text insertion point is on the page.

Click on it to lower the characters by 1 point.

When the Text Tools are fully expanded, you can enter the precise number of points by which you want 
to lower your text.



    Kern Together

This Text tool is used to reduce the space between the characters in your text selection, moving them 
closer together. You can only preset this if the text insertion point is on the page.

Click on it to reduce the space by 1%.

When the Text Tools are fully expanded, you can enter the precise percentage by which you want to 
reduce the space.



    Kern Apart

This Text tool is used to increase the space between the characters in your text selection, moving them 
wider apart. You can only preset this if the text insertion point is on the page.

Click on it to increase the space by 1%.

When the Text Tools are fully expanded, you can enter the precise percentage by which you want to 
increase the space.



    Text Spacing

This Text tool displays the Spacing dialog box.    From this dialog box you can set parameters 
controlling the spacing of letters, words and lines of a text object.



    KeyPad

This Text tool runs the separate KeyPad utility that is supplied with TurboDraw.

Use KeyPad to insert characters that are not available to your keyboard, eg. decorative characters from 
fonts such as Dingbats and Wingdings.



    Pointer tool

Use the Pointer tool to select objects and points on paths, and to manipulate objects by, for example, 
moving or stretching them.

Whichever tool is selected, if you click or drag using the right mouse button, you will be able to select 
and drag objects as though you had temporarily switched to the pointer tool.



    Text tool

Use the Text tool to create and style text.    You can then manipulate text objects like any other object in 
your picture, for example, skew, blend, color them etc.    When you select the text tool, the Text Tools are 
displayed.



    Box tool

Use the Box tool to draw squares and rectangles.



    Round Box tool

Use the Round Box tool to draw squares and rectangles with round corners.    The curvature of a round 
box can be increased to make the shape more circular, or decreased to make the shape more square.



    Ellipse tool

Use the Ellipse tool to draw ellipses such as ovals and circles.



    Arc tool

Use the Arc tool to draw arcs.    The direction in which you drag the mouse determines whether the arc is 
drawn clockwise or counterclockwise.

Arcs are quarter-ellipses when you first draw them.    You can adjust the start and end angles of an arc, 
making it more acute or obtuse.



    Pie tool

Use the Pie tool to draw pie slices.    The direction in which you drag the mouse determines whether the 
pie slice is drawn clockwise or counterclockwise.

Pie slices are quarter-ellipses when you first draw them.    You can adjust the start and end angles of a 
pie slice, making it more acute or obtuse.



    Polygon tool

Use the Polygon tool to draw polygons.    When you draw a polygon it is automatically given five sides.    
You can change the number of sides on a polygon before or after you draw it to give it a different shape.

Note:  The minimum number of sides is 3 and the maximum is 100.



    Star tool

Use the Star tool to draw stars.    When you draw a star it is automatically given five points.    You can 
change the number of points and the star's inner radius before or after you draw it to give it a different 
shape.

Note:    The minimum number of points is 3 and the maximum is 100.



    Pencil tool

The Pencil tool is like the pencil on your desk.    As you drag the Pencil tool around the desktop, a 
freehand path is drawn following the movements of the tool.



    Bezier tool

The Bezier tool combines the functions of the Corner, Curve and Connect tools in one tool.    Use the 
Bezier tool to draw straight lines and curves connecting smoothly without having to change tools.    By 
adjusting the points and control points you can change the shape of a bezier path. 

You can join the two ends of a bezier path to create a closed path that can then be given a fill style.



    Corner tool

Use the Corner tool to draw angular paths.    By adjusting the points you can change the shape of a 
path. 

You can join the two ends of a path to create a closed path that can then be given a fill style.



    Curve tool

Use the Curve tool to draw smoothly curved paths.    By adjusting the points and control points you can 
change the shape of the path. 

You can join the two ends of a path to create a closed path that can then be given a fill style.



    Connect tool

Use the Connect tool to make smooth connections between corner and curve points.    Normally, when 
you insert a curve point after a connect point, the line between them will be angular instead of a smooth 
progression from a straight to a curved line, but if you insert a connect point between a corner and a 
curve point, the three points will be joined smoothly.

You can join the two ends of a path to create a closed path that can then be given a fill style.



    Scale tool

Use the Scale tool to distort the objects in your picture by stretching or squeezing them. 

You can preserve the aspect ratio of an object that you scale and you can copy an object as you scale it.



    Rotate tool

Use the Rotate tool to move an object around the fixed point.    Rotating paths, text and other objects 
can create interesting effects.

You can constrain the angle of rotation to multiples of 45 degrees, and you can copy an object as you 
rotate it.



    Skew tool

Use the Skew tool, for example, to create three dimensional or shadow effects that look especially 
interesting when skewing text objects.

You can constrain the angle that you skew an object to multiples of 45 degrees, and you can copy an 
object as you skew it.



    Reflect tool

Use the Reflect tool to produce mirror images of objects.    Interesting effects can be achieved by 
reflecting text, paths, shapes and other objects.

You can constrain the angle of reflection to multiples of 45 degrees, and you can copy an object as you 
reflect it.



    Autotrace tool

Use the Autotrace tool to automatically trace a path around the outline of an imported bitmap.



    Magnifier tool

Use the Magnifier tool to magnify selected areas of your picture.



    Open

This is an alternative to the Open command in the File menu.

Click on it to open an existing picture.

Keyboard shortcut:    Ctrl O



    Save

This is an alternative to the Save command in the File menu.

Click on it to save the current picture under its current name.    If you have not yet given it a name, 
you will be asked for a name before the picture is saved.

Keyboard shortcut:    F2



    Load Default Template

Click on this tool to load the default template, ready to start a new picture.

You nominate which template is going to be the default one in the Start A New Picture tab of the New 
Picture Options dialog box.



    Import

This is an alternative to the Import File command in the File menu.

Click on it to import graphics from another source into your TurboDraw picture.



    Export

This is an alternative to the Export to File command in the File menu.

Click on it to export your TurboDraw picture to another application.



    Print

This is an alternative to the Print command in the File menu.

Click on it to print the picture in the current TurboDraw window.

Keyboard shortcut:    Ctrl P



    Reflect Horizontally

Use this tool to reflect the selected object in its horizontal axis.



    Reflect Vertically

Use this tool to reflect the selected object in its vertical axis.



    Rotate 45 Degrees Right

Use this tool to rotate the selected object 45 degrees to the right.



    Rotate 45 Degrees Left

Use this tool to rotate the selected object 45 degrees to the left.



    Rotate 90 Degrees Right

Use this tool to rotate the selected object 90 degrees to the right.



    Rotate 90 Degrees Left

Use this tool to rotate the selected object 90 degrees to the left.



    Rotate 180 Degrees

Use this tool to rotate the selected object 180 degrees.



    Double Size

Use this tool to double the size of the selected object.



    Halve Size

Use this tool to halve the size of the selected object.



    Skew Right

Use this tool to skew the selected object to the right.



    Skew Left

Use this tool to skew the selected object to the left.



    Skew Up

Use this tool to skew the selected object upwards.



    Skew Down

Use this tool to skew the selected object downwards.



    Align Objects Left

Use this tool to align selected objects to the left edge of the left-most of them.



    Align Objects Center

Use this tool to align selected objects to the horizontal center of the selection.



    Align Objects Right

Use this tool to align selected objects to the right edge of the right-most of them.



    Align Objects Top

Use this tool to align selected objects to the top edge of the top-most of them.



    Align Objects Middle

Use this tool to align selected objects to the vertical center of the selection.



    Align Objects Bottom

Use this tool to align selected objects to the bottom edge of the bottom-most of them.



    Align To Page Left

Use this tool to align selected objects to the left edge of the page.



    Align To Page Center

Use this tool to align selected objects to the horizontal center of the page.



    Align To Page Right

Use this tool to align selected objects to the right edge of the page.



    Align To Page Top

Use this tool to align selected objects to the top edge of the page.



    Align To Page Middle

Use this tool to align selected objects to the vertical middle of the page.



    Align To Page Bottom

Use this tool to align selected objects to the bottom edge of the page.



    Kern Text

This Text tool is used to set precisely the space between the characters in your text selection, moving 
them closer together or further apart.

Click on the arrows next to the Kern Text box to increase or decrease the point size by 1%; alternatively, 
enter the percentage directly.



    Text Width

This Text tool is used to precisely set the width of characters in your text selection, making them wider or 
narrower.

Click on the arrows next to the Text Width box to increase or decrease the character width by 1%; 
alternatively, enter the percentage directly.



    Raise/Lower Text

This Text tool is used to precisely raise the characters in your text selection above the baseline, or lower 
them below the baseline.

Click on the arrows next to the Raise/Lower Text box to raise or lower the text by one point; alternatively, 
enter the number of points directly.



    Change Toolbar Size

These buttons are used to change the size of the toolbar.

Click on the right-facing arrow to expand the toolbar.    When the toolbar is at its largest size, this button 
is disabled.

Click on the left-facing arrow to collapse the toolbar.    When the toolbar is at its smallest size, this button 
is disabled.



General Tools

The General Tools contain tools that you are likely to need whatever you are doing in the program, eg. 
Copy, Paste, and Undo.



Align Tools

The Align Tools contain tools for aligning objects, eg. Align Objects Left, Align To Page Center.



Transform Tools

The Transform Tools contain tools for manipulating objects, eg. Reflect Horizontally, Rotate 180 
Degrees, and Skew Down.



Object Tools

The Object Tools contain tools for rearranging and working with objects, eg. Bring To Front, Group, and 
Object Properties.



Text Tools

The Text Tools contain tools for working on text, eg. Typeface, Bold, Kern Together, and Text Spacing.





File menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



File menu: New

Select New to create a new picture. The New Picture Options dialog box appears, giving you a choice 
of running a pilot, loading a template, starting from a blank page, or reading more about these options in 
the New User Guide.    Make your choice, then click on OK.

An untitled picture window appears on the TurboDraw desktop, overlapping any existing picture 
windows.



See also:

   New Picture Options   dialog box  

   Starting a new picture  

   Starting a new picture from a template  



File menu: Open

Select Open to open a picture that you have previously saved. The Open dialog box appears unless 
you have changed the settings in the Preferences dialog box so that the Open an Existing File tab 
card of the New Picture Options dialog box appears.

Select the picture that you want to open.    After a few moments the picture appears in a picture window 
and you can resume work on it.

You can also open a recently used picture by selecting its name from the File menu.

Shortcut:



See also:

   Open   dialog box  

   New Picture Options   dialog box  

   New Picture Options   dialog box:   Open an Existing File   tab card  

   Preferences   dialog box  

   Opening an existing picture  

   Opening a recently used picture  



File menu: Save

Select Save to save the picture in the active window with its current filename.    If the picture is untitled, 
the Save As dialog box appears and you must enter a name for the picture.    Click on the Summary 
Info button if you want to save information about the picture, such as the creator, a title, and any 
keywords.

The picture remains displayed on the desktop for further editing.

Shortcut:



See also:

   Save As   dialog box  

   Summary Info   dialog box  

   Saving a picture  

   Creating a backup copy when saving  



File menu: Save As

Select Save As to name a new picture or to save the picture in the active window under a different 
filename.    The Save As dialog box appears.    Click on the Summary Info button if you want to save 
information about the picture, such as the creator, a title, and any keywords.

Choose a drive and directory in which to save the picture and enter a filename.



See also:

   Save As   dialog box  

   Summary Info   dialog box  

   Saving a picture  

   Creating a backup copy when saving  



File menu: Close

Select Close to close the active window.    If there are any unsaved changes, a message appears 
asking if you want to save the changes.    Click on Yes or No as appropriate, or Cancel to abandon the 
Close command.

If you have several windows open on one picture, selecting Close from the File menu will close all the 
windows open on that picture.

Shortcut:

Ctrl F4



See also:

   Closing a picture  



File menu: Import File

Select Import File to import a graphic file into your picture.    The Import from File dialog box appears. 
Select the format of the graphic that you want to import then select the filename.

Shortcut:



See also:

   Import from File   dialog box  

   Importing graphics  



File menu: Export to File

Select Export to File to save all or part of a picture in a variety of formats.    The Export to File dialog 
box appears.    Select the format in which you want to save the picture then enter a filename.    You can 
then import the file into other pictures or applications.

The quickest way to transfer an object from TurboDraw to another Windows application is to link or 
embed it using OLE.    Refer to the documentation of your other Windows applications to establish their 
level of OLE support.

Shortcut:



See also:

   Export to File   dialog box  

   Exporting graphics  



File menu: Summary Info

Select Summary Info to enter or view information about the current picture. The Summary Info dialog 
box appears.    You can also access this dialog box from the Save As dialog box so that you can enter 
information about the current picture when you save it, and from the Open dialog box.



See also:

   Summary Info   dialog box  

   Saving a picture  



File menu: Page Format

Select Page Format to choose the page format for the picture in the active window.    The Page Format 
dialog box appears.

Choose the page size and orientation, specify whether the picture will be single or multi-layered, and 
whether you will be using color separation.



See also:

   Page Format   dialog box  

   Starting a new picture  

   Using layers  

   Printing color separations  



File menu: Print

Select Print to print the picture in the active window.    The Print Options dialog box appears from 
where you can make several choices about how your picture is printed, e.g. number of copies to print, 
crop and registration marks, color separation etc.

If you want to print to a printer other than the one named in the Output group box, click on the Print 
Setup button to select the printer you prefer.

Shortcut:



See also:

   Print Options   dialog box  

   Printing a picture  

   Using crop and registration marks  

   Printing color separations  



File menu: Print Setup

Select Print Setup to choose which printer your picture is printed to and to control the printer's settings. 
The Print Setup dialog box appears. 

You can set up any of the printers listed on this dialog box to print your TurboDraw pictures.



See also:

   Print Setup   dialog box  

   Setting up your printer  



File menu: 1, 2, 3...20

These four commands are the filenames of the four most recently opened pictures.    Select the 
command that is associated to the picture that you want to open.    The picture will be displayed in a 
window on the TurboDraw desktop.

You can have up to 20 recently opened pictures listed in the File menu. Specify the number on 
the Startup tab card of the Preferences dialog box.



See also:

   Preferences   dialog box  

   Opening a recently used picture  



File menu: Exit TurboDraw

Select Exit TurboDraw to close TurboDraw.    If there are any open pictures with unsaved changes, a 
message appears giving you the option of saving the pictures before TurboDraw is closed.    Click on 
Yes or No as appropriate, or click on Cancel to abandon the Exit TurboDraw command.

Shortcut:

Ctrl F4



See also:

   Exiting TurboDraw  



Edit menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



Edit menu: Undo

Select Undo to abandon the last command.    You can undo up to fifty commands.

You cannot undo commands that do not change your pictures' content, e.g. opening a picture, scrolling 
the window, changing view size or making selections on a dialog box.

Shortcut:



See also:

   Using undo and redo  



Edit menu: Redo

Select Redo to abandon the previous Undo command.    You can redo up to fifty Undo commands.

Shortcut:



See also:

   Using undo and redo  



Edit menu: Cut

Select Cut to remove the selected objects from the picture and place them on the Clipboard ready to be 
pasted to another location.    Cut is available only when there are unlocked objects selected.

Shortcut:



See also:

   Cutting, copying and pasting objects  



Edit menu: Copy

Select Copy to copy the selected objects to the Clipboard without removing them from the picture.    
Copy is available only when there are unlocked objects selected.

Shortcut:



See also:

   Cutting, copying and pasting objects  



Edit menu: Paste

Select Paste to place the contents of the Clipboard into the active window.    You can repeatedly paste 
the contents of the Clipboard until you cut or copy another object.    Paste is available only when there is 
something on the Clipboard to be pasted.

Shortcut:



See also:

   Cutting, copying and pasting objects  



Edit menu: Cut+Paste Special

Select Cut+Paste Special to display a submenu that allows you to cut and paste objects relative to 
other objects, e.g. inside a closed path, in front of selected objects, or behind selected objects.

Cut+Paste Special submenu

   Paste Inside  

   Cut Contents  

   Paste in Front  

   Paste Behind  

   Clear Clipboard  



See also:

   Using Cut+Paste Special  



Cut+Paste Special submenu: Paste Inside

The Paste Inside command places the contents of the Clipboard inside the selected closed path.    The 
pasted objects will be clipped by the shape of the path.



See also:

   Using Cut+Paste Special  



Cut+Paste Special submenu: Cut Contents

The Cut Contents command removes the objects that were pasted inside the selected closed path and 
places them on the Clipboard.



See also:

   Using Cut+Paste Special  



Cut+Paste Special submenu: Paste in Front

The Paste in Front command places the contents of the Clipboard in front of the selected object, but 
behind any objects that are already in front of the selected object.



See also:

   Using Cut+Paste Special  



Cut+Paste Special submenu: Paste Behind

The Paste Behind command places the contents of the Clipboard behind the selected object, but in 
front of any objects that are already behind the selected object.



See also:

   Using Cut+Paste Special  



Cut+Paste Special submenu: Clear Clipboard

The Clear Clipboard command deletes the contents of the Clipboard.



See also:

   Using Cut+Paste Special  



Edit menu: Edit Colors

Select Edit Colors to add, modify or delete the colors in your picture.    The Edit Colors dialog box 
appears.

You can save color palettes that you can later load into new pictures that you create.

Shortcut:



See also:

   Edit Colors   dialog box  

   Applying color  

   Creating a new color  

   Deleting a color  



Edit menu: Select All

Select Select All to select all the objects in the active window except hidden objects and objects on 
layers that are not currently visible.

Shortcut:

Alt A



See also:

   Selecting/deselecting objects  



Edit menu: Transform Again

Select Transform Again to repeat the last transformation that you carried out.    The transformation is 
performed on the currently selected objects.    If the original transformation created a copy of the object 
while transforming, repeating it will also create a copy.

Shortcut:



See also:

   Repeating a transformation  



Edit menu: Blend

Select Blend to blend two selected objects together.    The Blend dialog box appears.    Enter the 
number of blend stages you require to determine the number of intermediate paths drawn between the 
two objects.    Any applied line styles, fill styles and colors will be blended.



See also:

   Blend   dialog box  

   Blending objects  



View menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



View menu: Preview

Select Preview to toggle between preview format and outline format for the picture in the active window. 
A picture displayed in preview format will show all applied line styles, fill styles and colors; a picture 
displayed in outline format will represent all objects in the same thin line style without any applied line 
styles, fill styles or colors.    When the command is checked, the picture is displayed in preview format.

Shortcut:



See also:

   Using preview and outline format  

   Viewing your picture  



View menu: Monochrome

Select Monochrome to display a picture's colors as shades of gray when displayed in preview format.    
This lets you see what the picture will look like when printed on a monochrome printer.    When the 
command is checked, the colors are displayed as shades of gray.



See also:

   Printing in halftone  

   Using preview and outline format  



View menu: Layer Zero

Select Layer Zero to toggle between hiding or displaying layer zero for the picture in the active window. 
Layer zero usually contains objects that you intend to trace around.    When the command is checked, 
layer zero is displayed.

The command is disabled if your picture has been drawn on a single layer only.



See also:

   Using layer zero  

   Using layers  



View menu: All Layers

Select All Layers to toggle between displaying all the layers or just the current layer of the picture in the 
active window.    When the command is checked, all the layers are displayed.

The command is disabled if your picture has been drawn on a single layer only.



See also:

   Using layers  



View menu: Actual Size

Select Actual Size to display the picture in the active window at its actual view size.

You can also achieve this by selecting 100% from the submenu that appears when you click on the Set 
View Size control at the left of the horizontal scroll bar.

Shortcut:



See also:

   Viewing your picture  



View Menu: Whole Page

Select Whole Page to display the picture in the active window so that its whole page is in view.

You can also select this command from the submenu that appears when you click on the Set View Size 
control at the left of the horizontal scroll bar.

Shortcut:



See also:

   Viewing your picture  



View menu: Enlarge

Select Enlarge to increase the view size of the picture in the active window to the next standard view 
size.

The command is disabled if the picture is already displayed at the largest available view size.

You can also enlarge the view size by clicking on the Zoom In control at the right of the Set View Size 
control (located at the left of the horizontal scroll bar).

Shortcut:

F8



See also:

   Viewing your picture  



View menu: Reduce

Select Reduce to decrease the view size of the picture in the active window to the next standard view 
size.

The command is disabled if the picture is already displayed at the smallest available view size.

You can also reduce the view size by clicking on the Zoom Out control at the left of the Set View Size 
control (located at the left of the horizontal scroll bar).

Shortcut:

Shift F8



See also:

   Viewing your picture  



View menu: Show Controls

Select Show Controls to display a submenu that allows you to change the display of the desktop.

Click on the command for which you want Help.

   General Tools  

   Transform Tools  

   Object Tools  

   Align Tools  

   Nudge  

   Rulers  

   Color Bar  

   Information Line  

   Hide All  



See also:

   What is everything on the desktop?  

   Can I customize the desktop?  



Show Controls submenu: General Tools

The General Tools command turns the display of the General Tools on and off.    This command is 
checked when the General Tools are displayed.



See also:

   Can I customize the desktop?  

   General Tools  



Show Controls submenu: Transform Tools

The Transform Tools command turns the display of the Transform Tools on and off.    This command is 
checked when the Transform Tools are displayed.



See also:

   Can I customize the desktop?  

   Transform Tools  



Show Controls submenu: Object Tools

The Object Tools command turns the display of the Object Tools on and off.    This command is 
checked when the Object Tools are displayed.



See also:

   Can I customize the desktop?  

   Object Tools  



Show Controls submenu: Align Tools

The Align Tools command turns the display of the Align Tools on and off.    This command is checked 
when the Align Tools are displayed.



See also:

   Can I customize the desktop?  

   Align Tools  



Show Controls submenu: Nudge

The Nudge command turns the display of the nudge control on and off.    Initially it is displayed at the top 
right of the TurboDraw window, but it can be made to float on the TurboDraw desktop.    This command 
is checked when the nudge control is displayed.



See also:

   Can I customize the desktop?  

   Moving objects  

   Moving a point  



Show Controls submenu: Rulers

The Rulers command turns the display of the rulers on or off for the picture in the active window.    
When the command is checked, the rulers are displayed along the top and down the left-hand side of 
the picture window.



See also:

   Can I customize the desktop?  

   Rulers  

   Using the rulers  



Show Controls submenu: Color Bar

The Color Bar command turns the display of the color bar on or off.    When the command is checked, 
the color bar is displayed at the bottom of the TurboDraw desktop.



See also:

   Can I customize the desktop?  

   Color bar  

   Displaying the color bar  



Show Controls submenu: Information Line

The Information Line command turns the display of the information line on or off.    When the command 
is checked, the information line is displayed at the bottom of the TurboDraw desktop.



See also:

   Can I customize the desktop?  

   Information line  



Show Controls submenu: Hide All

The Hide/Show All command turns the display of all controls on or off.



See also:

   Can I customize the desktop?  



View menu: Grid

Select Grid to display the Grid dialog box.    A grid can help you align objects and judge their size.    Any 
settings that you select apply to the picture in the active window only, you can have different settings for 
each picture window.    The grid does not form part of your picture and is not printed.

Shortcuts:

 



See also:

   Grid   dialog box  

   Using the grid and snap control  



View menu: Layers

Select Layers to add or delete layers, to rename a layer or to make another layer the current layer for 
the picture in the active window.    The Layers dialog box appears.

The command is disabled if your picture has been drawn on a single layer only.    It can be enabled by 
checking the Multi-layer check box in the Page Format dialog box.



See also:

   Layers   dialog box  

   Page Format   dialog box  

   Using layers  



Object menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



Object menu: Bring To Front

Select Bring To Front to move the selected objects to the front of their layer.

Shortcut:



See also:

   Overlapping objects  



Object menu: Send To Back

Select Send To Back to move the selected objects to the back of their layer. 

Shortcut:



See also:

   Overlapping objects  



Object menu: To Layer

Select To Layer to move the selected objects to a specific layer.    The Move Objects to Layer dialog 
box appears.    Select the layer to which you want to move the objects.    If the layer does not exist it will 
be created.

The command is disabled if your picture has been drawn on a single layer only.

Shortcut:

Ctrl T



See also:

   Move Objects to Layer   dialog box  

   Moving objects between layers  



Object menu: Group

Select Group to merge the selected objects into a group.    You can then manipulate all the objects 
together as a single object.

Locked objects cannot be grouped.

Shortcut:



See also:

   Grouping/ungrouping objects  



Object menu: Ungroup

Select Ungroup to separate a group of objects into its components.    The Ungroup command has 
different effects depending on the type of object that you have selected:

Ungrouping a group separates it into its constituent objects.

Ungrouping a shape converts it into a path.

Ungrouping a text object converts each character into a path.

Ungrouping a compound path converts it into a number of simple paths.

Shortcut:



See also:

   Grouping/ungrouping objects  



Object menu: Join

Select Join to join two objects together.    The Join command has different effects depending on the 
type of objects you have selected:

When the end points of open paths are selected and within the join range, the Join command 
joins the end points together.    When you join together the end points of an open path, it becomes a 
closed path.    The Join command will only work when you have two points selected that are within the 
join range.

When a text object and a path are selected, the Join command flows the text along the path.

Shortcut:



See also:

   Joining one path to another  

   Joining text to a path  



Object menu: Split

Select Split to break a path at the selected point or points.    An open path will be split into two shorter 
paths, while a closed path will become an open path.    You cannot split a compound path.

If you have text on a path selected, the Split command separates the text from the path. 

Shortcut:



See also:

   Splitting a path  

   Joining text to a path  



Object menu: Combine

Select Combine to combine two or more paths into a compound path, i.e. a path consisting of more 
than one contour.    The area that can be filled depends on the combination of subpaths.

Shortcut:

Ctrl M



See also:

   Combining paths (compound paths)  



Object menu: Lock

Select Lock to lock the selected objects in place.    A locked object cannot be moved, transformed or 
included in a group.    When you lock an object the color of its handles change to indicate that the object 
is locked.

Locked objects will remain locked when you save your picture.

Shortcut:



See also:

   Locking/unlocking objects  



Object menu: Unlock

Select Unlock to unlock the selected objects.

Shortcut:



See also:

   Locking/unlocking objects  



Object menu: Hide

Select Hide to hide the selected objects from view, making it easier to edit the picture behind and 
around the object.    Hidden objects cannot be selected.

When you save your picture the hide attribute is lost: When you next open the picture, the previously 
hidden objects will appear.

Shortcut:

Ctrl H



See also:

   Hiding/redisplaying objects  



Object menu: Show All

Select Show All to redisplay all the hidden objects in your picture.

Shortcut:

Ctrl W



See also:

   Hiding/redisplaying objects  



Object menu: Align

Select Align to align the selected objects to each other or to the page.    The Align dialog box appears.

You can also use the Align Tools to align objects to each other and to the page.

If one of the selected objects is locked when you align objects to each other, all the objects will align to 
the locked object.    If one of the selected objects is locked when you align objects to the page, the 
locked object will not be realigned.

Shortcuts:



See also:

   Align   dialog box  

   Align Tools  

   Aligning objects  



Object menu: Properties

Select Properties to display a dialog box providing information about the selected objects.    The 
information in this dialog box varies depending on the objects that are selected.

Shortcut:



See also:

   Shape Properties   dialog box  

   Path Properties   dialog box  

   Text Properties   dialog box  

   Text on a Path   dialog box  

   Element Properties - Bitmap Image   dialog box  

   Element Properties - PostScript   dialog box  

   Multiple Objects   dialog box  

   Group of Objects   dialog box  



Line menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



Line menu: Popup Lines

Select Popup Lines to display the Line Style popup.    This allows you to create, modify or delete line 
styles and apply them to selected objects.

The Line Style popup can be resized, allowing you to view more line styles simultaneously.    To close 
the popup, click on the Control menu bar.

Shortcut:



See also:

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: None

Select None to turn the line style off for the selected object, or for objects that you are about to draw.    
The command is checked when there is no line style selected.

You can also click on the X button at the left-hand end of the color bar to turn off the line style.



See also:

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: Solid

Select Solid to apply a solid line style to the selected object, or to objects that you are about to draw.    
The command is checked when a solid line style is selected.



See also:

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: Dashed

Select Dashed to apply a dashed line style to the selected object, or to objects that you are about to 
draw.    Select one of four dashed styles from the submenu that appears.    The command is checked 
when a dashed line style is selected.



See also:

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: Hairline

Select Hairline to apply a very fine line style to the selected object, or to objects that you are about to 
draw.    The command is checked when a hairline line style is selected.



See also:

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: 1pt

Select 1pt to apply a line style with a 1pt width to the selected object, or to objects that you are about to 
draw.    The command is checked when a 1pt line style is selected.



See also:

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: Width

Select Width to apply a different width to the line style of the selected object, or to objects that you are 
about to draw.    Select one of six widths from the submenu that appears.    The command is checked 
when one of these widths is selected.



See also:

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: Color

Select Color to display a drop-down color palette.    Click on a color within the palette to apply that color 
to the line style of the selected object, or to objects that you are about to draw.

When you want to create a new color, click on the + button.    The New Color dialog box appears from 
where you can mix the color that you want to add to your picture.



See also:

   New Color   dialog box  

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: Ends

Select Ends to display the Line Ends dialog box.    Choose the type of arrowhead design you want (if 
any) for each end of the line, and the shape of the line ends and joins.    Arrowheads are not displayed 
on closed paths and shapes.



See also:

   Line Ends   dialog box  

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Line menu: Named Style

Select Named Style to display a list of all the named line styles for the picture in the active window.    
Click on a line style within that list to apply it to the selected object, or to objects that you are about to 
draw.



See also:

   Line Style   popup  

   Applying line styles  

   Creating a new line style  

   Creating a PostScript line style  

   Deleting line and fill styles  



Fill menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



Fill menu: Popup Fills

Select Popup Fills to display the Fill Style popup.    This allows you to create, modify or delete fill styles 
and apply them to selected objects.

The Fill Style popup can be resized, allowing you to view more fill styles simultaneously.    To close the 
popup, click on the Control menu bar.

Shortcut:



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: None

Select None to turn the fill style off for the selected object, or for objects that you are about to draw.    
The command is checked when there is no fill style selected.

You can also click on the X button at the left-hand end of the color bar to turn off the fill style.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Plain

Select Plain to apply a plain fill style to the selected object, or to objects that you are about to draw.    
The command is checked when a plain fill style is selected.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Linear

Select Linear to apply a linear fill style to the selected object, or to objects that you are about to draw.    
The command is checked when a linear fill style is selected.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Logarithmic

Select Logarithmic to apply a logarithmic fill style to the selected object, or to objects that you are about 
to draw.    The command is checked when a logarithmic fill style is selected.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Cylindrical

Select Cylindrical to apply a cylindrical fill style to the selected object, or to objects that you are about 
to draw.    The command is checked when a cylindrical fill style is selected.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Radial

Select Radial to apply a radial fill style to the selected object, or to objects that you are about to draw.    
The command is checked when a radial fill style is selected.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Spherical

Select Spherical to apply a spherical fill style to the selected object, or to objects that you are about to 
draw.    The command is checked when    a spherical fill style is selected.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Random

Select Random to apply a random fill style to the selected object, or to objects that you are about to 
draw.    The command is checked when a random fill style is selected.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Pattern

Select Pattern to tile a selected group of objects and save them as a fill style.    The Tile Pattern dialog 
box appears.    Enter a name for the pattern and adjust the Scale and Angle values as required.    The 
pattern will be added to the list of fill styles and can be applied to a selected object in the same way as a 
fill style.

The command is disabled until you have selected one or more objects and grouped them.



See also:

   Tile Pattern   dialog box  

   Creating patterns  

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Color

Select Color to display the drop-down color palette.    Click on a color within the palette to apply that 
color to the fill style of the selected object, or to objects that you are about to draw.

When you want to create a new color, click on the + button.    The New Color dialog box appears from 
where you can mix the color that you want to add to your picture.

When applying a color to a graduated fill style, this is the 'from' color, i.e. the color of the fill style will 
fade 'from' this one to the next.



See also:

   New Color   dialog box  

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: To Color

Select To Color when applying a 'to' color to a graduated fill style.    The drop-down color palette 
appears.    Click on a color within the palette to apply that color to the fill style of the selected object, or 
to objects that you are about to draw.    The fill style will fade to this color according to your chosen 
graduation.

When you want to create a new color, click on the + button.    The New Color dialog box appears from 
where you can mix the color that you want to add to your picture.



See also:

   New Color   dialog box  

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Fill menu: Named Style

Select Named Style to display a list of all the named fill styles for the picture in the active window.    
Click on a fill style within that list to apply it to the selected object, or to objects that you are about to 
draw.



See also:

   Fill Style   popup  

   Applying fill styles  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  



Options menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



Options menu: Units

Select Units to display a submenu that allows you to choose the unit of measurement you want to use 
for the active picture.

Click on the command for which you want Help.

   Centimeters  

   Inches And Tenths  

   Inches And Eighths  

   Picas And Points  



See also:

   Using the rulers  

   Rulers  

   Ruler units  



Units submenu: Centimeters

The Centimeters command shows all rulers and measurements in centimeters.    This includes 
measurements given in dialog boxes.

Your choice of units applies only to the active picture, so you can use a different unit of measurement for 
each picture you have open, and the rulers and dialog boxes will change as you switch between 
pictures.



See also:

   Using the rulers  

   Rulers  

   Ruler units  

   Working with multiple pictures  

   Switching between windows  



Units submenu: Inches And Tenths

The Inches And Tenths command shows all rulers and measurements in inches divided into tenths.    
This includes measurements given in dialog boxes.

Your choice of units applies only to the active picture, so you can use a different unit of measurement for 
each picture you have open, and the rulers and dialog boxes will change as you switch between 
pictures.



See also:

   Using the rulers  

   Rulers  

   Ruler units  

   Working with multiple pictures  

   Switching between windows  



Units submenu: Inches And Eighths

The Inches And Eighths command shows all rulers and measurements in inches divided into eighths. 
This includes measurements given in dialog boxes.

Your choice of units applies only to the active picture, so you can use a different unit of measurement for 
each picture you have open, and the rulers and dialog boxes will change as you switch between 
pictures.



See also:

   Using the rulers  

   Rulers  

   Ruler units  

   Working with multiple pictures  

   Switching between windows  



Units submenu: Picas And Points

The Picas And Points command shows all rulers and measurements in picas and points.    This 
includes measurements given in dialog boxes.

Your choice of units applies only to the active picture, so you can use a different unit of measurement for 
each picture you have open, and the rulers and dialog boxes will change as you switch between 
pictures.



See also:

   Using the rulers  

   Rulers  

   Ruler units  

   Working with multiple pictures  

   Switching between windows  



Options menu: Preferences

Select Preferences to specify options that include the way in which TurboDraw starts up, the display of 
each new picture window opened, the display quality of a picture in preview format, and so on.    The 
Preferences dialog box appears.



See also:

   Preferences   dialog box  

   Setting your preferences  



Options menu: Reset Toolbars

The Reset Toolbars command returns the toolbars to their default positions and settings.    You can 
then drag them around to position them as you want.

This command is also available in the popup menu that appears when you right-click on any of the 
toolbars.



See also:

   Can I customize the desktop?  

   Toolbars  



Options menu: Auto Arrange Toolbars

The Auto Arrange Toolbars command gives each of the docked toolbars a weighting or importance.    
When auto arrangement is turned on and you drag the docked toolbars around, they snap to one end or 
the other of the docking area, depending on the toolbar.    This is designed to help you position the 
toolbars for ease of use.

This command is also available in the popup menu that appears when you right-click on any of the 
toolbars.



See also:

   Can I customize the desktop?  

   Toolbars  



Options menu: Switch Object And Text Tools

When you select the Text tool, the Text Tools appear.

Select Switch Object And Text Tools if you want the Text Tools to replace the Object Tools.    Deselect 
this option if you want the Text Tools to be shown in addition to the Object Tools.

You might want to do this so that the toolbars fit around the edge of the screen when you are using the 
Text tool (depending on the resolution of your screen).

This command is also available in the popup menu that appears when you right-click on the Text Tools 
or the Object Tools.



See also:

   Can I customize the desktop?  

   Object Tools  

   Text Tools  



Window menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



Window menu: New Window

Select New Window to open a new window on the current picture.

You can have up to eight windows open on any one picture, and up to twenty windows open in total.



See also:

   Displaying your picture in multiple windows  

   Working with multiple pictures  

   Rearranging windows  

   Switching between windows  

   Reducing a window to an icon  



Window menu: Cascade

Select Cascade to arrange the picture windows so that they overlap, with the title bar and left-hand 
edge of each window remaining visible.



See also:

   Displaying your picture in multiple windows  

   Working with multiple pictures  

   Rearranging windows  

   Switching between windows  

   Reducing a window to an icon  



Window menu: Tile

Select Tile to arrange the picture windows so that they are all visible on the desktop and do not overlap.



See also:

   Displaying your picture in multiple windows  

   Working with multiple pictures  

   Rearranging windows  

   Switching between windows  

   Reducing a window to an icon  



Window menu: 1, 2, 3, ....20

TurboDraw displays a listing of currently open picture windows at the bottom of the Window menu.    
Select one of these pictures to make that picture active.    The currently active window is marked with a 
check.

You can have up to twenty pictures, or twenty windows, open at any one time.



See also:

   Displaying your picture in multiple windows  

   Working with multiple pictures  

   Rearranging windows  

   Switching between windows  

   Reducing a window to an icon  



Help menu

Click on the command for which you want Help.

Hint: When you highlight a menu command in TurboDraw, the information line at the bottom of the 
desktop displays a prompt for how to use that command.



Help menu: Contents

Select Contents to display the Contents page of TurboDraw Help.    From the Contents page you can 
choose on which area of TurboDraw you want help.

Shortcut:

F1



Help menu: Search

Select Search to display the Search dialog box.    From this dialog box you can search for and select 
the specific subject on which you require help. It is similar to using the index of a book to look up a 
subject about which you want information.



Help menu: User Guide

Select User Guide to display a submenu that allows you to access different parts of the Help system.

User Guide submenu

   Beginners  

   How To  

   Toolbars  

   Menus  

   Shortcuts  

   Glossary  

   Stop Press!  



User Guide submenu: Beginners

The Beginners command gives information aimed specifically at new users of TurboDraw.



User Guide submenu: How To

The How To command displays a list of general topics that explain 'how to' carry out tasks in 
TurboDraw.    Choose the general topic you want to learn about then choose the more precise topic from 
the list that appears.



User Guide submenu: Toolbars

The Toolbars command explains what all the TurboDraw buttons do.    Choose whether you want to 
look at information about the toolbox, one of the toolbars or the nudge control.    The appropriate set of 
tools or buttons is then displayed; click on the buttons to popup a brief explanation of each one.



User Guide submenu: Menus

The Menus command gives Help on every menu command in TurboDraw.    Click on the menu that you 
want to look at, then select the specific command in that menu.    The information displayed will explain 
what the command is for and when to use it.



User Guide submenu: Shortcuts

The Shortcuts command displays a list of the keyboard alternatives and shortcuts available in 
TurboDraw.



User Guide submenu: Glossary

The Glossary command opens a small window containing definitions of all the terms and phrases you 
are likely to encounter when using TurboDraw.    Click on a word to popup its definition.

Close the Glossary window by clicking on the Exit button, or by double-clicking on the window's Control-
menu box.



User Guide submenu: Stop Press!

The Stop Press! command contains any last-minute information that is not explained in the TurboDraw 
main help.    We recommend that you read this information carefully.



Help menu: Using Help

Select Using Help to display information about using TurboDraw Help and learn how to navigate your 
way around the Help information available.



Help menu: What's This?

Select What's This? to display the Help pointer.    Position the pointer over an item on the TurboDraw 
desktop, for example, a tool or menu command, and click the mouse button.    Help appears about the 
item you select.

Shortcut:



Help menu: ToolTips

Select ToolTips to turn the display of the small yellow ToolTips on or off.    ToolTips appear when you 
rest the pointer over a button or tool for a couple of seconds, and they give the name of the button or 
tool.

This command is checked when the ToolTips are displayed.



Help menu: Getting Started Hints

Select Getting Started Hints to turn the display of the getting started hints on or off.    These hints 
appear when you select a tool from the toolbox.    This command is checked when the getting started 
hints are displayed.



Help menu: Cue Cards

Cue cards appear at the end of a PagePilot to help you with the basic steps of finalizing your picture.    
Select Cue Cards to turn the display of cue cards on or off.    When the command is checked, cue cards 
will appear at the end of a PagePilot.



Help menu: About TurboDraw

Select About TurboDraw to display the TurboDraw billboard.    This shows the version number of your 
copy of TurboDraw and a copyright notice.

Click on the About IMSI button to find out more about IMSI and our products.



Set View Size: 25%

Select 25% to display the picture in the active window at a quarter of its actual size.



See also:

   Viewing your picture  



Set View Size: 50%

Select 50% to display the picture in the active window at a half of its actual size.



See also:

   Viewing your picture  



Set View Size: 100%

Select 100% to display the picture in the active window at its actual size.

You can also achieve this view by selecting Actual Size from the View menu.

Shortcut:



See also:

   Viewing your picture  



Set View Size: 2x

Select 2x to display the picture in the active window at twice its actual size.



See also:

   Viewing your picture  



Set View Size: 4x

Select 4x to display the picture in the active window at four times its actual size.



See also:

   Viewing your picture  



Set View Size: 8x

Select 8x to display the picture in the active window at eight times its actual size.



See also:

   Viewing your picture  



Set View Size: 16x

Select 16x to display the picture in the active window at sixteen times its actual size.



See also:

   Viewing your picture  



Set View Size: Whole Page

Select Whole Page to display the picture in the active window so that its whole page is in view.

You can also achieve this view by selecting Whole Page from the View menu.

Shortcut:



See also:

   Viewing your picture  



Set View Size: Page Width

Select Page Width to display the picture in the active window so that the width of the page takes up the 
full width of the window.



See also:

   Viewing your picture  



Set View Size: Zoom To Selection

Select Zoom To Selection to display the picture in the active window so that the selected object(s) take 
up as much of the view as possible.    This command is disabled if you have no objects selected.



See also:

   Viewing your picture  





How To...

Start work

   Understanding PagePilots  

   Running a PagePilot  

   Start a new picture  

   Start a new picture from a template  



Understanding PagePilots

A PagePilot is a mechanism which guides you through making basic choices about the type of picture 
you want and how you want to lay it out; it is an easy way of creating a picture quickly when you don't 
know how to use TurboDraw.

TurboDraw has three PagePilots, each divided into several categories, providing you with many picture 
outlines.    The three PagePilots are:

Cards

Certificates

Logos

When you run a PagePilot, you are presented with a series of questions.    When you have chosen 
answers to these questions, the PagePilot automatically creates your picture to match the format and 
layout you have chosen.    When the PagePilot has finished, you can work on the picture, personalizing it 
to your exact needs.



See also:

   Running a PagePilot  



Running a PagePilot

If you are new to TurboDraw, running a PagePilot is probably the easiest way for you to create a picture. 
A PagePilot presents you with a series of questions about the picture you want to create, and then 
automatically creates the picture for you.

How to run a PagePilot

1. From the File menu, select New; the New Picture Options dialog box appears.

2. Select the Run A PagePilot tab to display the choice of PagePilots available.

3. Select the PagePilot you want to use.    Information about the PagePilot appears on the tab card.

4. Click on OK to run the PagePilot.

The PagePilot will now run and present you with the first question about the layout of your picture.    
Select the option you want and then continue through the remaining questions.    You can go back to an 
earlier question if you want to change something.

At the end of the PagePilot, you can choose to make the picture or go back through the questions and 
change the options you chose.    If you choose to make the picture, you can watch as TurboDraw brings 
all the items together to make your picture.

When your picture has been made, you can work on it in the same way as other TurboDraw pictures, 
tailoring it precisely to your needs.    Cue cards are provided to help you with the basic steps needed to 
complete your picture.



See also:

   Understanding PagePilots  

   New Picture Options   dialog box  



Starting a new picture

There are three different ways that you can start a new picture:

By running a PagePilot

By using a template

By starting from a blank page

To start a new picture, select New from the File menu. The New Picture Options dialog box appears 
giving you the three choices above. Select the tab card you want.

Running a PagePilot

Run a PagePilot if you would like TurboDraw to help you create your picture. You will be asked a series 
of questions about the layout and design of your picture, then TurboDraw will create it automatically for 
you. When the PagePilot has finished, you can edit the picture to tailor it precisely to your own needs.

Using a template

Templates are useful if you regularly create pictures using common elements. By saving the common 
elements in a template file, each time you need to draw another picture, you can load the template and 
use it as a basis instead of having to start completely from scratch. Use a template if you want to create 
a new picture based on a template that you have previously designed and saved.

Starting from a blank page

If you want to start completely from scratch, without any pre-set options, start your new picture from a 
blank page. You can specify the picture's page size, orientation and attributes using the Start A New 
Picture tab card.

You can modify your preferences to suit the way you start new pictures.

When your new picture window opens, if it hides other pictures that you already have open, select 
Tile or Cascade from the Window menu to bring these pictures back into view.
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Starting a new picture from a template

You can start a new picture from a template using one of the sample templates provided with TurboDraw 
or a template that you have created yourself.

How to load a template

1. From the File menu, select New; the New Picture Options dialog box appears.

2. Select the Start A New Picture tab.

3. From the Category group box, select Template.

4. From the Template list box, select the template you want to load.    A preview of the template 
appears in the dialog box, along with any notes that were saved with it.

At the bottom of the dialog box is the path and filename of the selected template.    You will need to 
know this if you want to copy the template.

5. If you want this template to become the default so that it is already selected whenever you choose 
to start a new picture, click on Make Default.    (You can also set TurboDraw to load the default 
template automatically whenever it starts up by changing your settings on the Preferences dialog 
box.)

6. Click on OK.    The template is loaded and you can begin to create your picture.

There is also a Browse button on the Start A New Picture tab card.    This button lets you load a 
template by its file name instead of through the category structure.

How to load a template through its file name

1. From the File menu, select New; the New Picture Options dialog box appears.

2. Select the Start A New Picture tab.

3. Click on Browse; the Open dialog box appears.

4. Open the directory in which the template was saved, and select the template.

5. Click on OK to load the template.
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Opening an existing picture

A picture that has already been created in TurboDraw can be reopened so that you can continue work 
on it.

The quickest way to open a picture is to select its filename from the list of recently used pictures in the 
File menu.

If the picture you want to open isn't listed in the File menu, select Open from the File menu and choose 
the picture you want using either the Open dialog box or the Open an Existing File tab card of the New 
Picture Options dialog box.

Use the Preferences dialog box to determine whether the Open dialog box or the Open an 
Existing File tab card appears when you select Open from the File menu(the Open dialog box is chosen 
by default).

When you first load TurboDraw, the New Picture Options dialog box may appear (depending on your 
preferences). From this dialog box you can open an existing picture by selecting the Open An Existing 
File tab card. This tab card lists the most recently used pictures; if the picture you want isn't listed, click 
on Browse and select the picture using the Open dialog box.

If there is an empty picture window selected when you open a picture, the picture is placed in this 
window.

The appearance of the picture window is determined by your preferences.    You can change your 
preferences using the Preferences dialog box.

If the picture window hides other pictures that you already have open, select Tile or Cascade 
from the Window menu to bring these pictures back into view.

If you need to open a backup file, change *.art in the File Name box to *.bak.

Shortcut:



See also:

   Open   dialog box  

   New Picture Options   dialog box  

   Preferences   dialog box  

   Rearranging windows  



Opening a recently used picture

TurboDraw remembers the pictures that you have most recently used, and lets you open them using a 
single menu command.

How to open a recently used picture

1. From the menu bar, select the File menu.

The pictures that you have used most recently are listed beneath the Print Setup command.

2. Click on the picture you want to open.

You can use the Preferences dialog box to change the number of pictures that are listed in the 
File menu.



See also:

   Preferences   dialog box  



Changing the page format

You can change the page format of a picture while you are working on it, but you may have to reposition 
objects on the page.    We recommend that you decide which page format to use before you begin a 
picture.

How to change the page format

1. From the File menu, select Page Format.    The Page Format dialog box appears.

2. The Page Sizes box lists the page sizes available.    Click on the page size that you want.

3. Select the picture orientation you want by clicking on the Portrait or Landscape option as 
appropriate.

4. If you intend to create a complicated picture using several layers, select Multi-Layer from the 
Picture Attributes group box.

5. Select Color Separation if you intend to print the picture using color separations.

6. To confirm your choices and return to the picture window, click on OK.

How to create a custom page size

If you do not want to use any of the pre-defined page sizes you can create a custom page size by 
following the steps below:

1. From the File menu, select Page Format.    The Page Format dialog box appears.

2. Enter a name for the new page size in the Page Sizes box.

3. Enter the dimensions you require in the Height and Width boxes in the Custom Page group box.    
You can change the current unit of measurement by selecting a different unit from the Units drop-
down list box.

4. To add the new page size to the list, click on the Add button.

The maximum page size you can create is 30 inches square.

How to delete a custom page size

You can delete custom page sizes by following the steps below.

1. From the Page Sizes list box, select the custom page size that you want to delete.

2. To delete the page size from the list, click on the Delete button.

3. To close the dialog box, click on OK.

You cannot delete the TurboDraw predefined page sizes; only custom page sizes can be deleted.
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Viewing your picture

TurboDraw can display your picture at a wide range of view sizes.    When you want to do close-up work 
on a detail in your picture, you can magnify the detail and later zoom back out to view the whole picture.

How to magnify the view of your picture

1. Select the Magnifier tool from the toolbox.

2. Click on the point of your picture that you want to appear at the center of the window.    Your picture 
is then magnified to the next standard view size.    Each subsequent click will increase the view size 
to twice the previous size. 

To magnify a specific area of the picture, select the Magnifier tool and drag the mouse pointer 
over the area that you want to magnify.

The maximum magnification is 1600%.

How to reduce the view of your picture

1. Select the Magnifier tool from the toolbox.

2. Hold down Shift and click on the point of your picture that you want to appear at the center of the 
window.    The picture is then reduced to the next standard view size.    Each subsequent click will 
display your picture at half its previous size.

The minimum magnification is 12%.

Alternative methods to view your picture

The Set View Size control on the horizontal scroll bar lets you change the view size of your whole 
picture.    Click on the Set View Size control and select one of the view sizes from the popup menu that 
appears.    The view sizes available are: 25%, 50%, 100%, 2x, 4x, 8x, 16x, Whole Page, Page Width 
and Zoom To Selection.

There are also four commands in the View menu that let you enlarge and reduce your whole picture.    
Selecting Actual Size will display the picture at its actual size, while Whole Page will display the whole 
page.    Selecting Enlarge or Reduce will display the picture at twice or half its original size respectively.

Double-clicking on the Magnifier tool will display the whole page of your picture.

Shortcuts:



See also:

   Displaying your picture in multiple windows  



Using preview and outline format

You can display your picture in either preview format or outline format.

When a picture is displayed in outline format, all the objects in the picture are drawn with the 
same thin line style, and without their colors, patterns, fill styles or other line styles.    This enables the 
screen to be redrawn quickly to update any edits that you make.

When a picture is displayed in preview format, all colors, patterns, fill styles and line styles 
applied to objects will be drawn.    This gives you a WYSIWYG display (What You See on the screen Is 
What You Get on the printed page).

We recommend that you display your picture in outline format as much as possible and only use 
preview format when it is essential that you see all the colors, patterns, fill styles and line styles.

How to toggle between preview and outline format

From the View menu, select Preview.    This command is checked when the picture is displayed in 
preview format.    Select the command again to remove the check mark and display the picture in outline 
format.

Shortcut:



Displaying your picture in multiple windows

You can have more than one window open on a picture.    For example, you could:

Highly magnify one window to make detailed changes, and view the effect of the changes on the 
whole picture in another window.

Work with the grid displayed in one window, and without it in another.

Work in outline format in one window to edit your picture quickly, and in preview format in the 
other window to give you a WYSIWYG display (What You See on the screen Is What You Get    on the 
printed page).

Work on a single layer in one window, with a view of the complete picture in another.

How to open a new window on your picture

From the Window menu, select New Window.    The picture appears in the new window, overlapping 
the original.

The title bar of the new window indicates which view of the picture it is.    For example, if the title of the 
original picture window is POSTER.ART, the new window is POSTER.ART:2, the next window 
POSTER.ART:3, and so on.

If the picture window hides other pictures that you already have open, select Tile or Cascade 
from the Window menu to bring these pictures back into view.

You can have up to eight windows open on any one picture.
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Working with multiple pictures

You can have more than one picture open at once.    Having multiple pictures open allows you to cut, 
copy and paste objects between pictures with ease.    You can also drag an object from one picture, and 
drop it into another.

How to open multiple pictures

Open the picture that you want to work on.    A new picture window is opened and becomes the active 
window.

If the picture window hides other pictures that you already have open, select Tile or Cascade 
from the Window menu to bring these pictures back into view.

The current preferences determine the appearance of the new window.

You can have up to twenty windows or twenty pictures open at once.
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Rearranging windows

When you open several picture windows at a time, some windows overlap or hide others.    You can use 
the Cascade and Tile commands in the Window menu to rearrange all the windows so that some part 
of each window is visible.

How to cascade windows

From the Window menu, select Cascade.    All the picture windows are resized and layered within the 
TurboDraw work area so that each title bar is visible, making it easy for you to select any of the 
windows:

How to tile windows

From the Window menu, select Tile.    All the picture windows are resized and arranged side-by-side in 
the TurboDraw work area so that no windows overlap and each window's contents are visible:

If you open another picture window after you use the Cascade or Tile command, it overlaps the 
rearranged windows.    To include it among the rearranged windows, select the Cascade or Tile command 
again.
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Switching between windows

TurboDraw operations apply only to the picture in the active window, so you need to be able to move 
from one window to another when you have multiple windows open. There are several ways to do this, 
the easiest method depends on how the windows are displayed.

How to switch between windows

When the pictures are tiled, click anywhere in the required window. The title bar of the previous 
window is disabled and the selected window is highlighted to show it is now the active window.

When the pictures are cascaded, either click on the title bar to bring the window you want to the 
front, or press Ctrl Tab to switch between windows.

When the pictures are full screen, use the Window menu to select the picture you want to view.

When you move from one window to another:

The tool that is currently selected does not change.

The current line, fill and color attributes are specific to a picture, so they may change from window 
to window if the window contains different pictures.

The information line changes to display information about the active window.
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Reducing a window to an icon

The desktop can become cluttered and unmanageable if there are too many windows open.    
TurboDraw allows you to reduce a window to an icon to keep your desktop 'tidy'.

How to reduce a window to an icon.

Click on the Minimize box, or select Minimize from the Control menu of the window that you want to 
iconize.    The window is iconized and placed at the bottom of the TurboDraw desktop.

Icons can be dragged around the desktop.    If the icon cannot be seen, it is probably hidden 
behind one of the open windows.

How to restore a window from an icon.

Click on the icon and select Restore from the Control menu, or double-click on the icon.    The window 
is displayed in the same position it was in before it was minimized.

Changes made to the picture while the window was reduced will also be displayed, e.g. if you 
have edited another window on the same picture.



Saving a picture

Saving a picture makes a permanent record of the picture on your hard disk.    None of the changes you 
make to a picture are recorded on disk until the picture is saved.    It is sensible to save your pictures 
regularly.

How to save a picture

From the File menu, select Save.    The picture in the active window is saved and remains open for 
editing.

If the picture is untitled when you try to save it, TurboDraw prompts you to specify a name for the 
picture by displaying the Save As dialog box.

How to save a picture to a new file

1. From the File menu, select Save As.    The Save As dialog box appears.

2. Select the file format in which you want to save the picture by selecting Picture or Template from 
the Save File as Type drop-down list box.

3. From the Directories list box, select the directory in which you want to save the picture.

4. Enter a name for the picture in the File Name box.    The file extension is added if you do not enter 
it.

5. Click on OK.    The picture is saved to the file of that name and the file name appears in the title bar.

If you enter a file name that already exists, you will be asked if you want to overwrite the existing 
file.    Click on Yes or No as appropriate.

You can save information about a picture by entering the details into the Summary Info dialog 
box.    You can open this dialog box by clicking on the Summary Info button in the Save As dialog box, or 
by selecting Summary Info from the File menu.    When you save the picture, the information in the 
Summary Info dialog box is saved as well.

Shortcut:
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Creating a backup copy when saving

You can have TurboDraw make a copy of the previous version of your picture, so that you always have 
a recent version to go back to if necessary.

How to make a backup

1. From the Options menu, select Preferences; the tabbed Preferences dialog box appears.

2. Select the General tab card.

3. In the File Options group box there is a check box labeled Create .BAK Files.    Check this box to 
create backup (.BAK) files.

When you next save your picture, the previous version is renamed as <FILENAME>.BAK and the latest 
version, with your most recent changes, is saved as <FILENAME>.ART (where <FILENAME> is the 
name of your picture).



See also:
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Closing a picture

When you have finished working on a picture you can close it.

How to close a picture

1. Select the window containing the picture that you want to close.

2. Select Close from the File menu or from the picture window's Control menu.    The window is 
removed from the desktop.

If the picture has been changed since it was last saved you are given the option to save your 
changes.    Clicking on Yes to save your changes will display the Save As dialog box if the picture has not 
been saved before.

When there is more than one window open on a picture, Close from the File menu will close all 
the windows displaying the picture; Close from the picture window's Control menu will close the current 
window only.

Shortcut:

Ctrl F4 closes the active window.
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Setting your preferences

You can modify TurboDraw to suit the way you work by changing the options on the Preferences dialog 
box. 

How to set your preferences

From the Options menu, select Preferences; the Preferences dialog box appears. This dialog box is 
divided into tab cards containing options for:

Behavior on startup

Behavior when you open a new picture window

The way your pictures are displayed

General settings.

Click on the tab card of the preferences you want to set.



See also:

   Preferences   dialog box  



Exiting TurboDraw

How to exit TurboDraw

From the File menu, select Exit TurboDraw.

If there are any open pictures with unsaved changes, a message will be displayed giving you the 
option to save the pictures before you exit TurboDraw.

You can also exit TurboDraw by selecting Close from the Control menu.

The layout of the desktop will be saved until you next run TurboDraw, e.g. the position of the 
toolbox and text controls will be remembered.

Shortcut:

Alt F4 exits TurboDraw.
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Using layers

A simple picture can be created on a single layer, but more complex pictures are easier to work with if 
you build them up over several layers, perhaps using one layer for all the background objects and 
another layer for all the foreground objects.

When you create a picture on several layers you can work on one layer at a time.    Working with 
individual layers helps you to focus on precise details without being distracted by the rest of your picture.

How to make your picture multi-layered

1. From the File menu, select Page Format.    The Page Format dialog box appears.

2. Check the Multi-layer check box, then click on OK.    The picture now has a default of three layers:

0:    Zero (template)

10:    Background

100:    Foreground
You can add up to 200 layers if you need them.

If you begin drawing a picture on a single layer and later decide that it would be easier to use several 
layers, you can still select Multi-layer as above.    However, if you change a multi-layered picture back to 
being single-layered, all objects not on layer 100 will be lost.
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Using layer zero

Every layered picture has a layer zero.    Layer zero has two main uses:

1. To contain objects that you want to trace around.

2. To create templates that you can save for use in future pictures.

When you import a graphic for tracing it is placed on layer zero.

Objects on layer zero are not printed out by default.

You can turn the display of layer zero on and off by selecting Layer Zero from the View menu.



See also:
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Adding layers

When you want to begin drawing on another layer, you need to add a layer to your picture.

How to add layers

1. From the View menu, select Layers.    The Layers dialog box appears.

All the layers of the picture in the active window are listed.

2. Select the number of the layer you want to add by clicking on the arrows next to the Layer Number 
box, or by entering the number directly into the box.

3. Click in the Name box and enter a name for the new layer.    This is not obligatory, but helps when 
there are a lot of layers.

4. Click on Add Layer to add the layer to the list in the Layers box.

5. To add the layer to your picture, click on OK.

The new layer becomes the current layer.

You can have up to two hundred layers in a picture.
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Moving between layers

When you have several layers in a picture, you will need to move between the layers to work on 
different sections of the picture.

How to move to another layer

1. From the View menu, select Layers.    The Layers dialog box appears.

2. Select the layer you want to move to in the Layers box.

3. Click on OK.    The selected layer becomes the current layer.

You can also move between layers by clicking on the layer box in the information line, and 
selecting the layer you want from the popup menu that appears.



See also:
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Displaying layers

When a picture consists of several layers, it is easier to work on the picture by displaying only the layer 
that you are currently working on, rather than all the layers simultaneously.

How to display the current layer only

In the View menu, deselect All Layers.    All the layers except the current layer will be hidden.    The All 
Layers command is checked when all the layers in your picture are displayed.

You can also turn the display of layer zero on or off by selecting Layer Zero from the View menu.



Deleting layers

You can delete a layer from your picture if there are no objects on it.    If there are any objects on the 
layer, you must delete them first before trying to delete the layer.

How to delete layers

1. From the View menu, select Layers.    The Layers dialog box appears.

2. Select the layer that you want to delete and click on Delete Layer.    The layer will be removed from 
the list of layers in the Layers box.

3. From the Layers box, select the layer that you want to become the current layer in your picture.    If 
you do not select a layer, TurboDraw will recreate the layer that you have just deleted and make it 
the current layer again.

4. To confirm that the appropriate layer has been deleted and return to your picture, click on OK

You cannot delete layer zero.

The information line displays the name and number of the current layer.



See also:
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Using templates

A template is a file that contains information about the page size and format you have chosen; any line 
styles, fill styles, patterns and colors that you have designed; any objects or graphics that you have 
saved on layer zero for tracing; and any objects that you have saved on other layers for printing.

Use a template to save time and effort if you regularly create pictures that are similar, e.g. using similar 
line styles, fill styles, patterns and colors, or using the same graphic as a logo. 

How to save a template

1. From the File menu, select Save As.    The Save As dialog box appears.

2. From the Save File as Type drop-down list box, select Template (*.tem).

3. Select a disk drive and directory in which to save the template.

4. Enter a name for the template in the File Name box.    The template will automatically be given the 
.TEM file extension, unless you specify an alternative.

5. If you want to make this template into the default template, which will then be loaded automatically 
whenever you start TurboDraw or open a new picture, check the Make Default Template check 
box.

6. If you want to save some information about the template, click on the Summary Info button to 
display the Summary Info dialog box.

7. To save the template, click on OK.

How to open a template

1. From the File menu, select Open.    The Open dialog box appears.

2. From the Save File as Type drop-down list box, select Template (*.tem).

3. Select the disk drive and directory in which you previously saved the template.    The templates in 
the selected directory will be listed in the File Name list box.

4. Select the name of the template that you want to open.    The template appears in the preview box.

5. To open the template, click on OK.

The template appears in the active window and you can now begin creating a new picture based upon 
this template.

If, at step 1 above, the New Picture Options dialog box appears, you have changed your 
preferences. You can open a template through this dialog box using the Start a New Picture tab card, for 
more information click on the See Also button above.

The original default template (DEFAULT.TEM) is saved in the IMSI\TDRAW\SAMPLES 
subdirectory. You can load this template again if you want to continue working with the original default 
template.

When you open a template, its filename remains "Untitled" until you save the picture.
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Drawing a shape

TurboDraw provides tools for drawing boxes, round boxes, ellipses, stars, polygons, arcs and pie slices. 
These shapes are all drawn using the same technique.

How to draw a basic shape

1. From the toolbox, select the shape tool that you want to use.    As you move the mouse pointer into 
the work area, it changes to a different shape, depending on the tool you have selected.

2. Press the left mouse button and drag the pointer diagonally across the desktop.    An outline of the 
shape is drawn as you drag the mouse.

3. Release the mouse button when the outline is the size and shape you want. 

The shape is drawn with the current line style and fill style (except arcs, which are not given fill 
styles).

Eight handles appear around the edge of the shape, indicating that the shape is selected.    When 
an ellipse, arc or pie slice is selected, the handles appear around an invisible box that follows the 
circumference of the shape.

When arcs and pie slices are selected, two hollow round handles at either end of their arc 
segment are also displayed.    These handles represent the start and end angles of the shape.

A basic shape can be ungrouped, which converts it into a path.

When you draw a shape extending beyond the displayed area of the picture, TurboDraw auto 
scrolls the work area to keep the shape in view.

Shape tools:
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Drawing a shape with equal dimensions

You can draw basic shapes so that their width is equal to their height.    This means that you can draw 
perfect squares, circles, polygons etc.

How to draw a shape with equal dimensions

1. From the toolbox, select the shape tool that you want to use.

2. Hold down Ctrl, then press the left mouse button and drag the pointer across the desktop.    Do not 
release Ctrl until you have released the mouse button.

You can press Ctrl part way through a drag, to ensure that the shape has equal dimensions.

You can press Ctrl and Shift simultaneously to draw a shape from its center and with equal 
dimensions.

Shape tools:
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Drawing a shape from its center

You can draw basic shapes from a fixed center point instead of from corner to corner.

How to draw a shape from the center

1. From the toolbox, select the shape tool that you want to use.

2. Hold down Shift, then press the left mouse button and drag the pointer across the desktop.    Do not 
release Shift until you have released the mouse button.    The shape is drawn with its center at the 
point where you began to drag.

You can press Shift part way through a drag, to ensure that the shape is drawn from its center.

You can press Shift and Ctrl simultaneously to draw a shape from its center and with equal 
dimensions.

Shape tools:
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Changing the curvature of a round box

The curvature of a round box is determined by its corner radius.    You can edit the corner radius to make 
the shape more circular or more square.    The curvature of a round box can be changed before or after 
you draw it.

How to change the curvature of a round box

To specify the curvature of a round box before you draw it:

1. In the toolbox, double-click on the Round Box tool.    The Rounded Box dialog box appears.

2. Enter the size of the corner radius you require in the Default Corner Radius box.

If you want, you can select an alternative unit of measurement from the Units drop-down list box.

3. Click on OK.

When you next draw a round box it will be given the corner radius that you have just specified.    For 
example:

The curvature that you specify will remain the same until you change it again; subsequent round boxes 
will be drawn with this curvature.

To change the curvature of a round box after you have drawn it:

1. Select the Pointer tool and double-click on the round box whose curvature you want to change.    
The basic shape popup menu appears.

2. Select Object Properties from the popup menu.    The Shape Properties dialog box appears.

3. Enter the curvature you require in the Corner Radius box, then click on OK.

The round box is redrawn with the curvature that you have just specified.

You can also display the Shape Properties dialog box by selecting the round box and then 
selecting Properties from the Object menu.

Shortcut:



See also:

   Rounded Box   dialog box  

   Shape Properties   dialog box  

   Drawing a shape  



Changing the number of sides on a polygon

When you draw a polygon it is automatically given five sides.    You can change the number of sides on a 
polygon before or after you draw it.

How to change the number of sides on a polygon

To specify the number of sides on a polygon before you draw it:

1. In the toolbox, double-click on the Polygon tool.    The Polygon dialog box appears.

2. Enter the number of sides you want the polygon to have (it must be a number between 3 and 100). 
The preview box illustrates what the polygon shape will be.

3. Click on OK to close the dialog box.

When you next draw a polygon it will be given the number of sides that you have just specified.

The number of sides that you specify will remain the same until you change them again; subsequent 
polygons will be drawn with this number of sides.

To change the number of sides on a polygon after you have drawn it:

1. Select the Pointer tool and double-click on the polygon whose shape you want to change.    The 
basic shape popup menu appears.

2. Select Object Properties from the popup menu.    The Shape Properties dialog box appears.

3. Enter the number of sides you require in the Sides box, then click on OK.

The polygon is redrawn with the number of sides that you have just specified.

You can also display the Shape Properties dialog box by selecting the polygon and then 
selecting Properties from the Object menu.

Shortcut:



See also:

   Polygon   dialog box  

   Shape Properties   dialog box  

   Drawing a shape  



Changing the number of points on a star

When you draw a star it is automatically given five points.    You can change the number of points on a 
star before or after you draw it.

How to change the number of points on a star

To specify the number of points on a star before you draw it:

1. In the toolbox, double-click on the Star tool.    The Star dialog box appears.

2. Enter the number of points you want the star to have in the No. of Points box (it must be a number 
between 3 and 100).    The preview box illustrates what the star will look like.

3. Click on OK to close the dialog box.

When you next draw a star it will be given the number of points that you have just specified.

The number of points that you specify will remain the same until you change them again; subsequent 
stars will be drawn with this number of points.

To change the number of points on a star after you have drawn it:

1. Select the Pointer tool and double-click on the star whose shape you want to change.    The basic 
shape popup menu appears.

2. Select Object Properties from the popup menu.    The Shape Properties dialog box appears.

3. Enter the number of points you require in the Points box, then click on OK.

The star is redrawn with the number of points that you have just specified.

You can also display the Shape Properties dialog box by selecting the star and then selecting 
Properties from the Object menu.

Shortcut:



See also:

   Star   dialog box  

   Shape Properties   dialog box  

   Drawing a shape  

   Changing the inner radius of a star  



Changing the inner radius of a star

You can change the inner radius of a star to make the points on the star more blunt or more pointed.    
You can change the inner radius of a star before or after you draw it.

How to change the inner radius of a star

To change the inner radius of a star before you draw it:

1. In the toolbox, double-click on the Star tool.    The Star dialog box appears.

2. Adjust the inner radius by dragging the scroll box or by entering the value in the Star Inner Radius 
box.    Increasing the value will make the points of the star less pointed.    The preview box illustrates 
what the star will look like.

3. Click on OK to close the dialog box.

When you next draw a star it will be given the inner radius that you have just specified.

The inner radius that you specify will remain the same until you change it again; subsequent stars will be 
drawn with this inner radius.

To change the inner radius of a star after you have drawn it:

1. Select the Pointer tool and double-click on the star whose shape you want to change.    The basic 
shape popup menu appears.

2. Select Object Properties from the popup menu.    The Shape Properties dialog box appears.

3. Enter the inner radius that you require in the Inner Radius box, then click on OK.

The star is redrawn with the inner radius that you have just specified.

You can also display the Shape Properties dialog box by selecting the star and then selecting 
Properties from the Object menu.

Shortcut:



See also:

   Star   dialog box  

   Shape Properties   dialog box  

   Drawing a shape  

   Changing the number of points on a star  



Changing the angle of an arc or pie slice

You can change the start and end angles of an arc or pie slice, making the arc segment of the shape 
larger or smaller.

How to change the angle of an arc or pie slice

1. Draw an arc or pie slice.    There is a round handle at either end of the arc or pie slice, representing 
the start and end angles.

2. Select the Pointer tool; press the left mouse button and drag the start or end handle to adjust the arc 
segment of the arc or pie slice. 

As you drag either of the handles, the information line displays the angle that you are adjusting.    
The information line also displays the percentage that the arc or pie slice occupies of the whole 
ellipse of which it is a segment.

3. When the arc or pie slice is the shape you require, release the mouse button.

You can also adjust the start and end angles of an arc or pie slice using the Shape Properties dialog 
box:

1. Select the Pointer tool and double-click on the arc or pie slice whose angle you want to change.    
The basic shape popup menu appears.

2. Select Object Properties from the popup menu.    The Shape Properties dialog box appears.

3. Enter the values you require in the Start Angle and End Angle boxes.    The percentage of the arc 
or pie slice is updated to reflect the changes you make to the start and end angles.

4. Click on OK to close the dialog box.

The arc or pie slice is redrawn with the start and end angle that you have just specified.

You can also display the Shape Properties dialog box by selecting the arc or pie slice and then 
selecting Properties from the Object menu.

Shortcut:



See also:

   Shape Properties   dialog box  

   Drawing a shape  



Using the Pencil tool

The Pencil tool is like the pencil on your desk.    As you drag the pencil around the desktop, a path is 
drawn following the movements of the tool.

How to use the Pencil tool

1. From the toolbox, select the Pencil tool.    The pointer changes shape to a pencil when you move it 
into the work area.

2. Press the left mouse button and drag the pencil around the work area in the shape of the path you 
want to draw.    A line is drawn, following the movements of the pencil.

When you release the mouse button, a path is created consisting of a number of line segments joined 
together at points; this is know as a freehand path.    Because the path is selected, these points are 
indicated by small black squares.

If no line is drawn through the points you have no line style selected. From the Line menu, select 
Solid.



See also:

   Drawing a straight path with the Pencil tool  

   Erasing a freehand path  

   Smoothing a freehand path  

   Drawing multiple paths  

   Using corners and curves together  

   Controlling the angle of a path  

   Creating a shape from a path (closing a path)  



Drawing a straight path with the Pencil tool

You can draw straight paths with the Pencil tool by holding down Shift as you drag.    A series of straight 
lines can be connected together in a single path.

How to connect a series of straight lines

1. From the toolbox, select the Pencil tool, and position the pointer where you want the first line to 
begin.

2. Hold down Shift, then press the left mouse button and drag the mouse pointer to where you want 
the first line segment to end. 

3. Still holding down Shift, release the mouse button.    A straight line is drawn between the two points. 
Without moving the mouse, press the button again and then drag to the next end point.

4. Repeat Step 3 until you have drawn the whole path, then release Shift.

Hold down Ctrl to restrict the angle of the path to multiples of 45 degrees.



See also:

   Using the Pencil tool  

   Erasing a freehand path  

   Smoothing a freehand path  
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   Controlling the angle of a path  

   Creating a shape from a path (closing a path)  



Erasing a freehand path

You can erase a freehand path while you are still drawing it.

How to erase a freehand path

Hold down Alt and move the pointer back over the path that you have just drawn.    The mouse pointer 
changes shape to an eraser.

The first point on the freehand path is not erased; to erase this point, ensure that no other objects 
are selected, then press Delete.

You cannot erase a freehand path in this way if you have already finished dragging the pointer 
and released the mouse button.



See also:

   Using the Pencil tool  



Smoothing a freehand path

You can adjust the smoothness of a freehand path before you draw it.

How to smooth a freehand path

1. In the toolbox, double-click on the Pencil tool.    The Freehand dialog box appears.

2. Adjust the smoothness value by clicking the arrows or by entering the required value in the 
Smoothness box.

3. Click on OK to confirm the new value.

The smoothness value determines how precisely a freehand path follows the movements of the pointer. 
A smoothness value of 1 will produce a path that follows the movements of the pointer closely, making 
the path appear rough with numerous points; a smoothness value of 9 will produce a path that does not 
follow the movements of the pointer closely but smoothes out the path so that it has fewer points.



See also:

   Using the Pencil tool  



Using the Corner tool

The Corner tool allows you to draw angular paths.

How to use the Corner tool

1. From the toolbox, select the Corner tool.    The pointer changes shape to a cross with a box at its 
center when you move it into the work area.

2. Position the pointer where you want to start the path and click the mouse button.    An empty box is 
displayed, indicating that a point has been drawn and is selected.

3. Move the pointer to the next position and press the mouse button.    A line is drawn from the 
previous end point to the pointer position, indicating where the line segment will be drawn.    You can 
drag the new point to place it anywhere on the work area, which will be scrolled if necessary.    When 
you release the mouse button, the new point is drawn and left selected; the previous point is 
deselected and drawn as a black box.    A path is drawn between the two points.

4. Repeat Step 3 until the path is complete, for example:

You can delete the last point you have drawn by pressing Backspace.

Hold down Ctrl to restrict the angle of the path to multiples of 45 degrees.

When you have finished drawing the path, you can deselect the last point by pressing the space 
bar, then continue drawing another path.    Pressing the space bar to separate paths is like pressing the 
space bar between words when entering text.    To deselect the whole path, press Esc.

If no line is drawn through the points you have no line style selected.    From the Line menu, 
select Solid.



See also:

   Drawing multiple paths  

   Using corners and curves together  

   Controlling the angle of a path  

   Creating a shape from a path (closing a path)  



Using the Curve tool

The Curve tool allows you to draw smoothly curved paths.

How to use the Curve tool

1. From the toolbox, select the Curve tool.    The pointer changes shape to a cross with a circle at its 
center when you move it into the work area.

2. Position the pointer where you want to start the path and click the mouse button.    A circle is 
displayed, indicating that a point has been drawn and is selected.

3. Move the pointer to the next position and press the mouse button.    A line is drawn from the 
previous end point to the pointer position, indicating where the line segment will be drawn.    You can 
drag the new point to place it anywhere on the work area, which will be scrolled if necessary.    When 
you release the mouse button, the new point is drawn and left selected; the previous point is 
deselected and drawn as a black box.    A path is drawn between the two points.

4. Repeat Step 3 until the path is complete, for example:

You can delete the last point you have drawn by pressing Backspace.

When you have finished drawing the path, you can deselect the last point by pressing the space 
bar, then continue drawing another path.    Pressing the space bar to separate paths is like pressing the 
space bar between words when entering text.    To deselect the whole path, press Esc.

If no line is drawn through the points you have no line style selected.    From the Line menu, 
select Solid.

You can change the curvature of the line between two points by adjusting the control points.



See also:

   Drawing multiple paths  

   Using corners and curves together  

   Controlling the angle of a path  

   Creating a shape from a path (closing a path)  

   Adjusting control points  



Using the Connect tool

You can use the Connect tool to make smooth connections between corner and curve points. 

How to use the Connect tool

Normally, when you insert a curve point after a corner point, the line between them will be angular 
instead of a smooth progression from a straight to a curved line.    When you insert a connect point 
between a corner and a curve point, the three points will be joined smoothly.

When you insert a connect point between a corner and a curve point, you can adjust how the 
curve joins into the straight line by selecting the connect point and dragging its control points.

If no line is drawn through the points you have no line style selected. From the Line menu, select 
Solid.



See also:

   Using the Corner tool  

   Using the Curve tool  

   Drawing multiple paths  

   Using corners and curves together  

   Controlling the angle of a path  

   Creating a shape from a path (closing a path)  

   Adjusting control points  



Using the Bezier tool

The Bezier tool combines the functions of the Corner, Curve and Connect tools into one tool.

How to use the Bezier tool

Using the Bezier tool, you can draw straight lines and curves connecting smoothly without having to 
change tools.    When you click the mouse button, it creates a corner point; when you drag the mouse, it 
creates a curve point.

It is also possible to control the curvature of curves going into and out of a corner point by using Shift:

1. From the toolbox, select the Bezier tool, then drag the pointer to create a curve point and define its 
incoming direction.

2. Notice that the point has two control points that rotate as you adjust them.    Without releasing the 
mouse button hold down Shift.    One of the control points is now stationary but the other can be 
moved.

3. Drag the pointer again to define the outgoing curve direction.    Release the mouse button and Shift 
to place the point.

The curve follows the direction of the control point that you adjusted.

When you hold down Ctrl while using the Bezier tool, the control lines are constrained to angles 
of 0, 45 or 90 degrees.    This helps you to determine the curvature of line segments in a bezier path.



See also:

   Drawing multiple paths  

   Creating a shape from a path (closing a path)  

   Adjusting control points  



Drawing multiple paths

When you want to end one path and start a new one of the same type, simply press the space bar.    
TurboDraw then deselects the last end point so that you can begin a new path that will not be joined to 
the previous end point.    Pressing the space bar to start new paths is similar to the way you would press 
the space bar to separate words if you were entering text.

You can also deselect the path by clicking the right mouse button away from the path, by selecting the 
Pointer tool and clicking away from the path, or by pressing Esc.



See also:

   Using corners and curves together  



Using corners and curves together

A path can be a mixture of corners and curves; it does not have to be either a curve path or a corner 
path.    You can create a path containing every type of point if you want.

How to use corners and curves together

When you are drawing a path and want to change from one Drawing tool to another:

1. Ensure that the last point on the path is selected.

2. From the toolbox, select the Drawing tool you want to use, and continue drawing the path.

The new points will join to the existing path.



Controlling the angle of a path

You can control freehand, corner, curve and connect paths so that the next point on the path is at an 
angle of 0, 45, or 90 degrees to the previous point.

How to control the angle of a path

Hold down Ctrl as you drag the mouse to draw the path.

When you hold down Ctrl while using the Bezier tool, the control lines will be constrained to 
angles of 0, 45 or 90 degrees.    This helps you to determine the curvature of line segments in a bezier 
path.

When you release Ctrl, you can continue drawing your path without any angle constraints.



Creating a shape from a path (closing a path)

When you are drawing a path you can close it to create a shape that can then be filled with a fill style, 
pattern or color.

How to close a path

1. Draw the path in the normal way using the Drawing tools.

2. As soon as you move the end point of the path within the join range of the start point, the path will 
close.    For example:

The path is automatically filled with the currently selected fill style.

The two end points will be joined together only if they are both within the join range.    You can edit 
the join range to make it larger or smaller in the Preferences dialog box.

You can also close a path using the Path Properties dialog box.    This method will close a path even if 
the open ends are not within the join range:

1. Select the Pointer tool and double-click on the path whose end points you want to join.    The path 
popup menu appears.

2. Select Object Properties from the popup menu.    The Path Properties dialog box appears.

3. Check the Path Closed check box, then click on OK.

You can also display the Path Properties dialog box by selecting the path and then selecting 
Properties from the Object menu.

Shortcut:



See also:

   Preferences   dialog box  

   Path Properties   dialog box  

   Joining one path to another  



Converting a shape into a path

Basic shapes such as boxes and ellipses, are formed from closed paths and can be converted into 
those paths.    Once a shape has been converted into a path, you can select and edit individual points on 
the path to modify the shape.

How to convert a shape into a path

1. Select the shape you want to convert into a path.

2. From the Object menu, select Ungroup.    The shape is converted into a path of the same shape, 
and the handles are replaced by points that can be edited.    For example:

You can also convert a shape into a path by double-clicking on the shape to display the basic shape 
popup menu, then selecting Convert to Path.

An ungrouped shape does not lose its fill style or color.

Shortcut:



See also:

   Grouping/ungrouping objects  



Using undo and redo

As you create a picture, you will inevitably want to undo some changes that you make.    TurboDraw lets 
you undo commands so that you can try something different.

How to use undo and redo

To undo the last command, select Undo from the Edit menu.

You can undo up to the last fifty commands.    If you undo a command by mistake, you can redo it.

To redo the last undo command, select Redo from the Edit menu.

There are some commands that cannot be undone or redone, for example, you cannot undo a 
change in view size.

Shortcuts:
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Entering text

You can create text objects in your picture, then manipulate them like any other object.

How to create a text object

1. From the toolbox, select the Text tool.    The pointer changes shape to an I-beam when you move it 
into the work area.    (Notice also that the Object Tools at the top of the desktop are replaced by the 
Text Tools, if you have selected this in the Options menu.)

2. Click the mouse button at the point where you want to insert the text object.    A thin vertical line is 
displayed; this is the text insertion point.

If you hold down Alt and press the left or right arrow key, you can change the angle of the I-beam so 
that when you click, you can enter text into your picture at an angle.    Each time you press the arrow 
keys, the cursor moves through 1/16th of a circle.    (Press Esc to move the I-beam back to an 
upright position.)

3. Type the text that you require.    The text that you type appears in the current line and fill styles.    To 
start a new line of text, press Enter.

The text you have typed becomes an object in its own right - a text object.

If you drag the I-beam, instead of clicking it, at Step 2 above, a text frame follows the movements 
of the mouse pointer and when you start entering text, the text is automatically formatted to fit the width of 
the frame.

Once you have created a text object, you can edit it by selecting the Text tool and clicking the I-
beam on the object that you want to edit.    The text insertion point is placed within the text.    If you have 
created rotated text, the text insertion point will be rotated and positioned in the text at the correct angle.

You can use the standard editing keys to edit the text, e.g. Backspace, Delete and the arrow 
keys to move up and down lines and between characters.    You can also cut, copy and paste highlighted 
text selections within your text objects.

You can choose to have both the Text Tools and the Object Tools displayed at the same time.    
Click the right mouse button over either bar, and deselect Switch Object And Text Tools from the popup 
menu that appears. 



See also:
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Using text from other applications

You can paste in text from your other Windows applications, e.g. Notepad, Write and other word-
processors.

How to paste text into TurboDraw

1. Open the application containing the text and cut or copy the text onto the Clipboard.

2. Open the TurboDraw picture into which you want to paste the text, then select the Text tool from the 
toolbox.

3. Click the mouse button at the point where you want to paste the text.    A thin vertical line is 
displayed; this is the text insertion point.

4. From the Edit menu, select Paste to insert the text into your picture.

The text can now be edited in the same way as text that you enter directly into your picture.

Shortcut:



See also:

   Resizing text  
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Resizing text

Once you have created a text object you can resize it.

How to resize text

1. Select the Pointer tool and select the text object whose size you want to change.    Handles are 
displayed around the text frame to show that the object is selected.

2. Drag one of the solid handles around the text frame.    Without releasing the mouse button, hold 
down Shift.

dragging a corner handle will resize the height and width of the text.

dragging a side handle will resize either the height or width of the text.

3. When the text frame is the correct size, release the mouse button, then the Shift key. 

If you hold down Ctrl instead of Shift, the text is resized while retaining its original proportions.

If you do not hold down either Shift or Ctrl, the text is reformatted to fit the new width of the text 
frame, not resized.

You can also resize a text object using the Text Properties dialog box:

1. Select the Pointer tool and double-click on the text object whose size you want to change.    The text 
popup menu appears.

2. Select Object Properties from the popup menu.    The Text Properties dialog box appears.

3. Enter the dimensions that you want in the Size group box.    Change the position of the text object 
by adjusting the dimensions in the Position group box.

4. Click on OK to close the Text Properties dialog box and redraw the text object at the size you have 
specified.

You can also display the Text Properties dialog box by selecting the text object and then 
selecting Properties from the Object menu.

Shortcut:



See also:
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Changing the font and point size

You can preset the font and point size of text before you enter it, or alter a selected block of existing text.

How to change the font and point size

1. From the toolbox, select the Text tool.    The pointer changes shape to an I-beam when you move it 
into the work area.    (Notice also that the Object Tools are replaced by the Text Tools, if you have 
selected this in the Options menu.) 

2. To preset the font and point size, go to Step 3 below.    To alter text that you have already created, 
drag the I-beam over the characters to select them.

3. To choose a font for your text, click on the arrow next to the Typeface box in the Text Tools.    A list 
of the font groups available on your setup drops down.

4. Click on the font group that you want to open, then select the font that you want to use. To close a 
font group, click on the category name (shown in bold).

5. To choose a point size for your text, either click on the arrows next to the Text Size box to increase 
or decrease the point size, or enter the required size directly in the box

When you preset the font and point size of text, any text that you type will take on the font and 
point size that you have chosen.    However, if you move the I-beam to another text object, any text that 
you type will take on the font and point size of the surrounding text.

If you select a small point size, TurboDraw may not be able to display the text and will simulate it 
by greeking.

You can choose to have both the Object Tools and the Text Tools displayed at the same time.    
Click the right mouse button over either bar, and deselect Switch Object And Text Tools from the popup 
menu that appears. 

Text tools:

  



See also:

   Entering text  



Using bold and italic

You can preset the style of text before you enter it, or alter a selected block of existing text.

How to style text in bold and italic

1. From the toolbox, select the Text tool.    The pointer changes shape to an I-beam when you move it 
into the work area.    (Notice also that the Object Tools are replaced by the Text Tools, if you have 
selected this in the Options menu.)

2. To preset the text style, go to Step 3 below.    To alter text that you have already created, drag the I-
beam over the characters to select them.

3. To style your text in bold, italic or bold italic, click on the Bold and/or Italic buttons from the Text 
Tools.

When you preset the text style, any text that you type will take on the style that you have chosen. 
However, if you move the I-beam to another text object, any text that you type will take on the style of the 
surrounding text.

You can choose to have both the Object Tools and the Text Tools displayed at the same time.    
Click the right mouse button over either bar, and deselect Switch Object And Text Tools from the popup 
menu that appears. 

Text tools:



See also:

   Entering text  



Changing the alignment of text

You can preset the alignment of text before you enter it, or alter existing text.

How to change the alignment

1. From the toolbox, select the Text tool.    The pointer changes shape to an I-beam when you move it 
into the work area. (Notice also that the Object Tools are replaced by the Text Tools, if you have 
selected this in the Options menu.)

2. To preset the alignment, go to Step 3 below.    To alter text that you have already created, place the 
text insertion point within the text.

3. Click on the button of the alignment that you require: Flushed left, centered, flushed right or justified.

When you preset the alignment, any text that you type will take on the alignment that you have 
chosen.    However, if you move the I-beam to another text object, any text that you type will take on the 
alignment of the surrounding text.

You cannot align individual characters; alignment settings apply to the whole text object only.

You can choose to have both the Object Tools and the Text Tools displayed at the same time.    
Click the right mouse button over either bar, and deselect Switch Object And Text Tools from the popup 
menu that appears. 

Text tools:



See also:

   Entering text  



Expanding and compressing text

You can preset the width of text before you enter it, or alter a selected block of existing text.

How to expand and compress text

1. From the toolbox, select the Text tool.    The pointer changes shape to an I-beam when you move it 
into the work area.    (Notice also that the Object Tools are replaced by the Text Tools, if you have 
selected this in the Options menu.)

2. To preset the width, go to Step 3 below.    To alter text that you have already created, drag the I-
beam over the characters to select them.

3. Click on the Increase Width button to make the characters wider; each click will expand the 
characters by 10%, or

Click on the Decrease Width button to make the characters narrower; each click will compress the 
characters by 10%.

You may need to expand the Text Tools to see these buttons.

When the Text Tools are fully expanded, you can enter the precise percentage by which you want 
to increase or decrease the width of the text.

When you preset the width of text, any text that you type will take on the width that you have 
chosen.    However, if you move the I-beam to another text object, any text that you type will take on the 
width of the surrounding text.

You can choose to have both the Object Tools and the Text Tools displayed at the same time.    
Click the right mouse button over either bar, and deselect Switch Object And Text Tools from the popup 
menu that appears. 

Text tools:

  



See also:

   Entering text  



Raising and lowering text

You can preset the position of text above or below the baseline, or alter a selected block of existing text.

How to raise and lower text

1. From the toolbox, select the Text tool.    The pointer changes shape to an I-beam when you move it 
into the work area.    (Notice also that the Object Tools are replaced by the Text Tools, if you have 
selected this in the Options menu.)

2. To preset the position of text, go to Step 3 below.    To alter text that you have already created, drag 
the I-beam over the characters to select them.

3. Click on the Raise Text button to raise the characters above the baseline; each click will raise the 
characters by 1 point, or

Click on the Lower Text button to lower the characters below the baseline; each click will lower the 
characters by 1 point.

You may need to expand the Text Tools to see these buttons.

When the Text Tools are fully expanded, you can enter the precise number of points by which you 
want to raise or lower the text.

When you preset the position of text, any text that you type will take on the position that you have 
chosen.    However, if you move the I-beam to another text object, any text that you type will take on the 
position of the surrounding text.

You can choose to have both the Object Tools and the Text Tools displayed at the same time.    
Click the right mouse button over either bar, and deselect Switch Object And Text Tools from the popup 
menu that appears. 

Text tools:

  



See also:

   Entering text  



Kerning text

Kerning is a term used for reducing or increasing the space between characters.    The kerning controls 
are useful for fine-tuning the appearance of text, particularly text in large point sizes such as headings.

How to kern text

1. From the toolbox, select the Text tool.    The pointer changes shape to an I-beam when you move it 
into the work area.    (Notice also that the Object Tools are replaced by the Text Tools, if you have 
selected this in the Options menu.)

2. Drag the I-beam over the characters that you want to kern, or place the text cursor between the two 
characters to be kerned.

3. Click on the Kern Together button to move the characters closer together; each click will decrease 
the space between the characters by 1%, or

Click on the Kern Apart button to move the characters wider apart; each click will increase the 
space between the characters by 1%.

You may need to expand the Text Tools to see these buttons.

When the Text Tools are fully expanded, you can enter the precise percentage by which you want 
to kern the text.

You cannot preset kerning values.

You can choose to have both the Object Tools and the Text Tools displayed at the same time.    
Click the right mouse button over either bar, and deselect Switch Object And Text Tools from the popup 
menu that appears.

Autokerning text

Some letter pairs are nearly always kerned to improve their appearance, e.g. VA, Ta.    Some fonts have 
kerning information built into them and will automatically kern letter pairs such as these is kerning is 
enabled.    To automatically kern these fonts, click on the Autokern button; click on it again to turn 
autokerning off.

Text tools:

  

  



See also:

   Entering text  



Changing the spacing of text

You can change the letter spacing, word spacing and line spacing of a text object.

How to change the letter spacing

1. Select the Pointer tool and select the text object whose spacing you want to change.    Handles are 
displayed around the text frame to show that the object is selected.

2. Press the left mouse button and drag one of the hollow handles on the left or right edges of the text 
frame.    The pointer changes shape to an A..B..C symbol.

drag the handle outwards to increase the letter spacing, or

drag the handle inwards to decrease the letter spacing.

3. Release the mouse button.    The text object is redrawn with the letter spacing you have chosen.    
For example:

As you drag the handle, the information line indicates by how much you are changing the letter 
spacing.

How to change word spacing

1. With the Pointer tool, select the text object whose word spacing you want to change.

2. Press the left mouse button and drag one of the hollow handles on the left or right edges of the text 
frame.    When you have begun the drag, hold down Shift.    The pointer changes shape to an 
AB..CD symbol.

drag the handle outwards to increase the word spacing, or

drag the handle inwards to decrease the word spacing.

3. Release the mouse button, then the Shift key.    The text object is redrawn with the word spacing 
you have chosen.    For example:



As you drag the handle, the information line indicates by how much you are changing the word 
spacing.

How to change line spacing

1. With the Pointer tool, select the text object whose line spacing you want to change.

2. Press the left mouse button and drag one of the hollow handles on the top or bottom edges of the 
text frame.    The pointer changes shape to several short horizontal lines.    (These handles are only 
visible when you have entered more than one line of text.)

drag the handle outwards to increase the line spacing, or

drag the handle inwards to decrease the line spacing.

3. Release the mouse button.    The text object is redrawn with the line spacing you have chosen.    For 
example:

As you drag the handle, the information line indicates by how much you are changing the line 
spacing.

For precise adjustments to letter spacing, word spacing and line spacing, double-click the Pointer tool 
on the text object whose spacing you want to change to display the text popup menu.    Select Text 
Spacing from the popup menu to display the Spacing dialog box, then set the values you want.

You can also click on the Text Spacing tool to display the Spacing dialog box.

Shortcut:



See also:

   Spacing   dialog box  

   Entering text  



Joining text to a path

You can join text to a path to create some interesting effects, for example, text flowing around a circle, 
along a wavy line, or around any shape that you have drawn.

How to join text to a path

1. Create a text object, preferably having only one line of text.

2. Draw the path or shape that you want to join the text to.

3. Select the Pointer tool, then hold down Shift and click on both the text object and the path to select 
them.

4. From the Object menu, select Join.    The text is redrawn flowing along the path, for example:

Text can be joined to an open path or a closed path.

If the text object has more than one line of text, only the first line will be joined to the path.

If you are in preview format, the path will not be displayed.    You can change this and other 
settings using the Text on a Path dialog box.

Shortcut:



See also:

   Text on a Path   dialog box  

   Editing text on a path  

   Splitting a path  



Editing text on a path

You can edit text that has been joined to a path.    You can also change the way in which the text object 
is joined to the path using the Text on a Path dialog box.

How to edit text on a path

1. From the toolbox, select the Text tool.    The pointer changes shape to an I-beam when you move it 
into the work area.

2. Click on the text object that you want to edit.

3. The selected text is hatched out and an upright copy appears temporarily while you carry out your 
edits.

4. Once you have finished editing, click elsewhere on the desktop, or press Esc.    The edited text will 
flow along the path again.

How to change the display of text along a path

1. From the toolbox, select the Pointer tool.    The pointer changes shape to an arrow when you move it 
into the work area.

2. Double-click on the text object that you have joined to a path to display the text popup menu.

3. Select Object Properties from the popup menu.    The Text on a Path dialog box appears.

4. Decide how the text should be joined to the path, whether the path should be displayed, in which 
direction the text should flow, how the text should align with the path, e.g. Top, 1/2 x-height etc. and 
what the text orientation should be.

5. Click on OK when you have made your changes.

Try experimenting with all the different options for text joined to a path so that you can see the 
different effects that it is possible to create.

If you want to have a gap between the text and the path on which it rests, you must raise the text 
above the baseline.

You can also display the Text on a Path dialog box by selecting the text object and then selecting 
Properties from the Object menu. 

Shortcut:



See also:

   Text on a Path   dialog box  

   Entering text  

   Raising and lowering text  



Converting text to paths

You can convert text objects into paths.    Once a text object has been converted into a path, you can 
select and edit individual points on the path to modify the shape of the characters.

How to convert text to paths

1. From the toolbox, select the Pointer tool, then select the text object that you want to convert into a 
path.

2. From the Object menu, select Ungroup.    The text object is redrawn as individual paths that can 
then be edited.

You can also convert a text object into a path by double-clicking the Pointer tool on the object to display 
the text popup menu, then selecting Convert to Paths.

An ungrouped text object does not lose its fill style or color.

Certain letters when ungrouped produce compound paths, e.g. B or D.    Ungroup these again to 
produce separate closed paths.

Shortcut:



See also:

   Grouping/ungrouping objects  
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Selecting/deselecting objects

You must select an object before you can manipulate it.    When an object is selected, handles are 
displayed around its outline.

How to select an object

1. From the toolbox, select the Pointer tool.    The pointer changes shape to an arrow when you move it 
into the work area.

2. Position the pointer over the object you want to select and click the left mouse button.    The object's 
handles are displayed, indicating that it is selected.

Any previously selected objects are deselected as soon as you select another object.

When you select an object, that object's line and fill styles become the default for any new objects 
that you create.

How to select additional objects

You can select several objects at the same time:

1. After selecting an object, point at the next object you want to select.

2. Hold down Shift, then click the Pointer tool on the objects in turn to make up the selection.

You can Shift and click on as many objects as you want.

How to select objects using the selection frame

With the Pointer tool selected, press the left mouse button and drag the pointer diagonally across the 
objects that you want to select.    A selection frame appears as you drag.    All the objects within (or 
partially within) this selection frame are selected when you release the mouse button.



You can select more objects without deselecting any already selected by holding down Shift 
while dragging a selection frame.

How to select objects using Tab

When you have selected a single object, you can use Tab to select the next object and Shift Tab to 
select the previous object.    When using Tab and Shift Tab to select objects, the objects are selected in 
their stacking order.

How to select all the objects in a picture

Select Select All from the Edit menu, or press Alt A.

Hidden objects and objects on layers that are not currently visible will not be selected.

How to deselect objects

Deselect individual objects by holding down Shift then clicking the Pointer tool on the objects that 
you want to deselect.

Deselect all selected objects by clicking away from them, or by pressing Esc.



See also:

   Selecting/deselecting points  



Selecting/deselecting points

Before you can move, adjust or delete points, they need to be selected.

How to select a point

1. From the toolbox, select the Pointer tool, then select the path containing the point.

2. Position the pointer over the point you want to select.    The pointer changes shape to an arrow with 
a solid black box at its base.

3. Click the Pointer tool on the point.

When a point is selected it is identified as a curve point, corner point or connect point by either a 
hollow circle, box or triangle.

How to select additional points

You can select several points at the same time:

1. After selecting a point, point at the next point you want to select.

2. Hold down Shift, then click the Pointer tool on the points in turn to make up the selection.

You can Shift and click on as many points as you want.

How to select points using the selection frame

With the Pointer tool selected, press the left mouse button and drag the pointer diagonally across the 
points that you want to select.    A selection frame appears as you drag.    All the points within this 
selection frame are selected when you release the mouse button.

You can select more points without deselecting any already selected by holding down Shift while 
dragging a selection frame.

How to deselect a point

Deselect individual points by holding down Shift then clicking on the points that you want to 
deselect.

Deselect all the selected points but leave the paths selected by pressing the space bar.

Deselect all the selected points and paths by clicking away from them, or by pressing Esc.





See also:

   Selecting/deselecting objects  



Grouping/ungrouping objects

You can group objects together, making it easier to manipulate a number of objects simultaneously, e.g. 
moving them all up the page.

How to group objects

1. From the toolbox, select the Pointer tool, then select all the objects you want to group.

2. From the Object menu, select Group.    The selected objects are grouped together and displayed 
within a surrounding box that has eight handles around it.

Once you have created a group, the objects within it can be manipulated as a whole, e.g. moved, 
transformed, copied and pasted.    You cannot blend groups of objects, or apply line and fill styles to them.

When a group is selected, the information line indicates that the selected object is a group, and 
how many objects are within the group.    If you have one group and one other object selected, the 
information line informs you that there are two objects selected.

Objects on different layers can be grouped into the same group.    The group is created at the top 
of the current layer.    The component objects are returned to their layers when you ungroup the group.

How to ungroup objects

1. Select the group that you want to ungroup.

2. From the Object menu, select Ungroup.    The group separates into its component objects, which 
remain selected.

You can also ungroup a group by double-clicking the Pointer tool on the group and selecting 
Ungroup from the popup menu that appears.

You can ungroup basic shapes and text to convert them into paths for editing.

Shortcuts:





See also:

   Selecting/deselecting objects  

   Converting a shape into a path  

   Converting text to paths  



Moving objects

You can move objects by dragging them around the picture.    For more precise work, you can specify in 
which direction and by how much you want to move the object.

How to move an object

1. From the toolbox, select the Pointer tool, then select the object that you want to move.

2. When the pointer changes shape to an arrow with a selected rectangle at its base, press the left 
mouse button and drag the object to its new position.    As you drag the object, the original object 
and an outline of its new position are displayed.

3. Release the mouse button to redraw the object in its new position.

The information line displays the displacement of the object, as you drag it.

Press Ctrl and drag the object to constrain movement of the object to an angle of 0, 45 or 90 
degrees.

Press Alt and drag the object to make a copy of it when you release the mouse button.

Using the nudge control

The nudge control lets you 'nudge' the selected object up and down, or left and right, in the same way 
as the cursor keys.

To nudge an object (or several objects, or group of objects), select it and then click on the required part 
of the nudge control, to move in the appropriate direction.

You can specify the way in which the nudge control works (whether objects are nudged to grid 
divisions, or by a specific amount) in the General tab card of the Preferences dialog box.

The nudge control is disabled when you do not have anything selected in your drawing.

How to move an object precisely

1. Double-click the Pointer tool on the object and select Move/Copy from the popup menu that 
appears.    The Move Objects dialog box appears.

2. Enter the horizontal and vertical dimensions by which you want to move the object and select the 
direction in which you want it to move.

3. To make a copy of the object and move the copy without moving the original, check the Copy 
Objects check box.

4. Click on OK to close the dialog box and move the object as you have specified.

You can also move multiple objects using this method.



You can create several copies of the same object and space them uniformly.    Use the Move 
Objects dialog box to create the first copy, specifying the position of the copy in relation to the original.    
Then select Transform Again from the Edit menu (or press F5) to create another copy that will be 
spaced equidistant from the previous object.    Keep pressing F5 until you have created all the copies that 
you need.

Shortcut:



See also:

   Move Objects   dialog box  

   Selecting/deselecting objects  

   Moving objects between layers  

   Setting your preferences  

   Preferences   dialog box:   General   tab card  

   Positioning objects  

   Using the rulers  

   Using the grid and snap control  



Positioning objects

You can position an object precisely in your picture by entering specific dimensions in the relevant object 
properties dialog box.

How to specify an object's position

1. From the toolbox, select the Pointer tool, then select the object that you want to position.

2. Double-click the Pointer tool on the object and select Object Properties from the popup menu that 
appears.    The object properties dialog box for the selected object appears.

3. In the Position group box, specify the exact position for the object.    The coordinates are specified 
from the ruler origin.

4. You can specify the position relative to the left, center or right of the object horizontally, and the top, 
middle or bottom of the object vertically.    Click on the drop-down list boxes to choose an option.

The coordinates are specified from the top left-hand corner of the page, i.e. top left is given the 
coordinate 0,0.

The relevant object properties dialog box can also be displayed by selecting Properties from the 
Object menu.

You cannot position multiple objects in this way.    (Although you can position a group of objects.)

Shortcut:



See also:

   Path Properties   dialog box  

   Text Properties   dialog box  

   Shape Properties   dialog box  

   Element Properties - Bitmap Image   dialog box  

   Element Properties - PostScript   dialog box  

   Group of Objects   dialog box  

   Selecting/deselecting objects  

   Moving objects  

   Moving objects between layers  

   Using the rulers  

   Using the grid and snap control  



Moving objects between layers

You can create objects in one layer, and move them to another.    This is useful when creating a complex 
picture.

How to move objects between layers

1. From the toolbox, select the Pointer tool, then select the object that you want to move to another 
layer.

2. From the Object menu, select To Layer, or press Ctrl T.    The Move Objects to Layer dialog box 
appears.

3. Select the target layer by clicking on the layer name in the Layer Names list box, or by selecting the 
layer number from the To Layer box.    If the layer does not exist it will be created.

4. Click on OK.

If you have created a new layer, its number will be added to the list of layers.

The object remains selected, and the current layer does not change.

If only the current layer is displayed, the object will be hidden from view (though its selection 
handles remain visible until it is deselected).

You can also move an object to another layer using the relevant object properties dialog box:

1. Select the object that you want to move to another layer.

2. Double-click the Pointer tool on the object and select Object Properties from the popup menu that 
appears.    The object properties dialog box for the selected object appears.

3. Specify the target layer number in the Layer Number box, then click on OK.    if the layer does not 
exist, it will be created.

You cannot move multiple objects in this way.

The relevant object properties dialog box can also be displayed by selecting Properties from the 
Object menu.

Shortcut:



See also:

   Move Objects to Layer   dialog box  

   Path Properties   dialog box  

   Text Properties   dialog box  

   Shape Properties   dialog box  

   Element Properties - Bitmap Image   dialog box  

   Element Properties - PostScript   dialog box  

   Group of Objects   dialog box  

   Selecting/deselecting objects  

   Moving between layers  



Using the rulers

You can use the rulers at the top and left-hand edges of your picture window to help size and position 
objects more accurately.

How to use the rulers

To display the rulers, select Rulers from the submenu that appears when you select Show Controls 
from the View menu.    The command is checked when the rulers are displayed.    You can choose 
whether or not to have the rulers displayed for each window.

When the rulers are displayed, the unit of measurement used by the rulers is indicated at the top left-
hand corner, where they intersect.    To change the ruler units, click in this intersection area.    A list of 
ruler options appears and you can select the unit of measurement that you prefer.

Alternatively, you can change the units by selecting Units from the Options menu, and selecting the 
unit you want from the submenu.

You can move the rulers' origin, which is useful for precise sizing and positioning of the objects in your 
picture.    To move the rulers' origin, click in the intersection area and select Adjust Ruler Origin, then 
click at the point where you want to origin to be, e.g. the top left-hand corner of the page box.

You can set the ruler origin back to its original position by clicking on the intersection area and 
selecting Reset Ruler Origin from the popup menu that appears.

Ruler units are assigned to a picture window.    Changing the units in one window will not affect 
the units in another window.

Any dialog boxes that refer to unit of measurement will automatically use the unit of the rulers in 
the active window.



See also:

   Using the grid and snap control  



Using the grid and snap control

When a grid is displayed it is easier to position objects on the page and size them relative to each other, 
especially when snap control is enabled.

How to use the grid and snap control

To define a grid for active window:

1. From the View menu, select Grid.    The Grid dialog box appears.

2. Check the Show Grid check box to display a grid.

3. Check the Snap to Grid check box to make objects align with the grid when the are drawn, moved 
or sized.

4. Check the Align to Page check box to make the grid align to the top left-hand corner of the page or 
check the Align to Ruler check box to align the grid to the ruler origin.    (If the ruler origin is at the 
top left-hand corner of the page, Align to Ruler is disabled.)

5. From the Units drop-down list box, select the unit of measurement that you want the grid to use.    
This can be a different unit from the one used in the rulers.

6. In the Spacing group box, enter the width and height of each grid cell and how many subdivisions 
there are across and down each cell.    The greater the number of grid divisions, the finer the 
snapping control.

7. Click on the Copy button to copy the horizontal settings to the vertical settings, creating a square 
grid.

8. Click on OK to close the dialog box and create the grid you have just specified.

When Snap to Grid is on, objects will 'jump' to align themselves to the grid dimensions whenever 
they are drawn, moved, resized or transformed.

Grid units are assigned to a picture window.    Changing the units in one window will not affect the 
units in another window.

Shortcuts:



See also:

   Grid   dialog box  



Locking/unlocking objects

You can lock objects so that they cannot be accidentally transformed, deleted or moved.    You can lock 
and unlock any type of object except individual points on a path.

How to lock an object.

1. From the toolbox, select the Pointer tool, then select the object that you want to lock.

2. From the Object menu, select Lock.    The objects' handles change color, and the padlock in the 
information line and Object Tools indicates that the object is now locked.

You can also lock an object using the relevant object properties dialog box:

1. Double-click the Pointer tool on the object that you want to lock, then select Object Properties from 
the popup menu.    The object properties dialog box for the selected object appears.

2. Check the Locked check box, then click on OK.

While an object is locked, you cannot manipulate it in any way.

Locked objects will remain locked when you save your picture.

How to unlock an object.

1. Select the object that you want to unlock.

2. From the Object menu, select Unlock. The objects' handles change back to their original color, and 
the padlock in the information line and Object Tools indicates that the object is unlocked.

As with locking, you can also unlock an object via its object properties dialog box.

Shortcuts:



See also:

   Path Properties   dialog box  

   Text Properties   dialog box  

   Shape Properties   dialog box  

   Element Properties - Bitmap Image   dialog box  

   Element Properties - PostScript   dialog box  

   Group of Objects   dialog box  

   Selecting/deselecting objects  



Hiding/redisplaying objects

You can temporarily hide an object making it easier to edit your picture behind and around the object.

1. From the toolbox, select the Pointer tool, then select the object that you want to hide.

2. From the Object menu, select Hide.    The selected object is no longer displayed, and everything 
behind the object is visible.

If you have more than one object selected when you select Hide, all the selected objects are 
hidden.

Locked objects can be hidden.

You cannot select a hidden object.

How to redisplay hidden objects.

From the Object menu, select Show All.    All hidden objects are redisplayed, and become selected.

If Show All is disabled, there are no hidden objects in your picture.

When you print a picture that contains hidden objects, you can choose whether they should be 
printed or not in the Print Options dialog box.

When you save your picture the hide attribute is lost: When you next open the picture, the 
previously hidden objects will be displayed.

Shortcuts:

Ctrl H hides the selected objects; Ctrl W redisplays them.



See also:

   Print Options   dialog box  

   Selecting/deselecting objects  



Aligning objects

You can align objects accurately using the Align Tools or the Align dialog box, instead of trying to align 
them manually, which can be difficult for precision work.

How to align objects with the Align Tools

1. From the toolbox, select the Pointer tool, then select the objects that you want to align.

2. From the Align Tools, click on the Align tool you require, e.g.:

 

 

 

Using the Align Tools you can align the object(s) to each other or to the page in a variety of ways.

How to align objects with the Align dialog box

1. From the toolbox, select the Pointer tool, then select the objects that you want to align.

2. From the Object menu, select Align.    The Align dialog box appears.

3. Select whether you want to align the objects to Each other or to the Page.

4. Make your selections from the Horizontal and Vertical group boxes.    The preview box illustrates 
how your objects will align given the selections that you have made.



5. Click on OK.    The objects are aligned according to your selections.

If only one object is selected, you can only align to page.

If one of the selected objects is locked when you align to each other, all the objects will align to 
the locked object; if one of the selected objects is locked when you align to the page, the locked object 
will not move to the new alignment position.

Shortcut:



See also:

   Align   dialog box  

   Selecting/deselecting objects  



Overlapping objects

You can control the order in which objects are displayed in your picture.

How to bring an object to the front

1. From the toolbox, select the Pointer tool, then select the object that you want to bring to the front of 
your picture.

2. From the Object menu, select Bring To Front.    The selected object is placed on top of the objects 
that previously overlapped it and remains selected.

How to send an object to the back

1. Select the object that you want to send to the back of your picture.

2. From the Object menu, select Send To Back.    The selected object is placed beneath the objects 
that it previously overlapped and remains selected.

When a picture has more than one layer, Bring To Front and Send To Back apply to the current 
layer only.    Sending an object to the back sends it to the back of the current layer.

Shortcuts:



See also:

   Selecting/deselecting objects  



Cutting, copying and pasting objects

You can use the Windows Clipboard to cut, copy and paste objects within your picture and between your 
Windows applications.

How to cut an object

Cutting an object removes it from your picture and places it on the Clipboard.    The object can then be 
placed back into the same picture or another by using the Paste command.

1. From the toolbox, select the Pointer tool, then select the object that you want to cut from the picture.

2. From the Edit menu select Cut.

The selected object is removed from the picture, and placed on the Clipboard.

How to copy an object

Copying an object makes a copy of the object in your picture and places it on the Clipboard without 
removing the object from your picture.    The copy of the object can then be placed back into the same 
picture or another by using the Paste command.    This is useful when a picture contains repetitions of 
the same object.

1. From the toolbox, select the Pointer tool, then select the object that you want to copy.

2. From the Edit menu, select Copy.

The selected object is copied to the Clipboard, but not removed from the picture.

To copy an object within TurboDraw, we suggest that you press Alt and drag and drop a copy of 
the object, rather than use the Clipboard.

How to paste an object

To paste an object, you must first cut or copy an object to the Clipboard, then select Paste from the Edit 
menu.    The object on the Clipboard is copied into the picture.

The Paste command places an object into the picture at the position from which it was copied or 
cut.    If the object is from a different picture, the object will be placed in the current picture at the same 
position.

You cannot use the cut, copy and paste commands on individual points on a path.    If you do 
have a point selected and use one of these commands, the whole path, not just the selected point, will be 
cut, copied or pasted.    To delete a point, select it and press Backspace.

Shortcuts:



See also:

   Selecting/deselecting objects  

   Using Cut+Paste Special  



Using Cut+Paste Special

Use the commands in the Cut+Paste Special menu to cut and paste relative to other objects, e.g.. 
inside a closed path, in front of selected objects, or behind selected objects.

How to paste inside

1. Cut or copy the object that you want to paste inside another object, onto the Clipboard.

2. Select the path that you want to paste the object inside.

3. From the Edit menu, select Cut+Paste Special.    The Cut+Paste Special submenu appears.

4. Select Paste Inside.    The object is pasted inside the closed path at its original position on the 
page.

If you cannot see the object inside the closed path, move the path over the position in which the 
object was placed before you cut it to the Clipboard.

5. Manipulate the path so that the object appears as you want it.    The object inside the path is not 
affected by dragging or transforming the path.

6. Convert the path to a group by selecting Group from the Object menu.    This freezes the object 
within the path.    Transformations will now affect the path and its contents.

If the Paste Inside command is disabled, either you do not have a single closed path selected, or 
the Clipboard is empty.

The selected path must be a closed path.

To paste inside a basic shape, e.g.. a star or a circle, ungroup the shape to a path first.

You cannot select or manipulate an object that has been pasted inside a path.

How to cut from inside

To undo a paste inside command, you can either use the Undo command or cut the object from inside 
the path.

1. Select the path you want to cut from.    The path must have had something pasted inside it.

2. From the Edit menu, select Cut+Paste Special.    The Cut+Paste Special submenu appears.

3. Select Cut Contents.    The object is removed from within the path, and copied to the Clipboard.    
The path remains selected.

To edit the object, paste it into your picture and make your edits.    If you want, you can then cut 



and paste it back inside the path as described above.

How to paste in front

You can paste an object in front of other objects in your picture.

1. Cut or copy the object that you want to paste onto the Clipboard.

2. Select the object that you want the pasted object to appear in front of.    Make sure you have only 
one object selected.

3. From the Edit menu, select Cut+Paste Special.    The Cut+Paste Special submenu appears.

4. Select Paste in Front.

The pasted object is displayed in front of the one you selected and behind any objects that were 
previously in front of the selected one.

How to paste behind

You can paste an object behind other objects in your picture.

1. Cut or copy the object that you want to paste onto the Clipboard.

2. Select the object that you want the pasted object to appear behind.    Make sure you have only one 
object selected.

3. From the Edit menu, select Cut+Paste Special.    The Cut+Paste Special submenu appears.

4. Select Paste Behind.

The pasted object is displayed behind the one you selected, and in front of any objects that were 
previously behind the selected one.

You can change the stacking order of the objects in your picture using Bring To Front and Send 
To Back.

Shortcuts:



See also:

   Selecting/deselecting objects  

   Grouping/ungrouping objects  

   Overlapping objects  

   Cutting, copying, pasting and deleting objects  



How To...

Shape and blend objects

   Inserting a point  

   Adding a point to the end of a path  

   Deleting a point  

   Moving a point  

   Adjusting control points  

   Changing a point style  

   Splitting a path  

   Joining one path to another  

   Combining paths (compound paths)  

   Blending objects  



Inserting a point

You can insert a point into an existing path, enabling you to control its shape more freely.

How to insert a point

1. From the toolbox, select the Pointer tool, then select the path that you want to edit.    The points on 
the path are displayed as small black boxes.

2. Select any of the drawing tools except the Pencil tool.    Which tool you use depends upon the type 
of point that you want to insert.    Use the Corner tool to insert a corner point, the Connect tool to 
insert a connect point, or the Curve tool to insert a curve point.

3. Position the tool on the path where you want to insert a point, and click the mouse button.    A point 
is inserted on the path.    The new point is selected and any other points on the path that were 
previously selected are deselected.    You can manipulate the point as you would any other.

If you do not click exactly on the path when you try to insert a point in it, the path is deselected 
and a point appears on its own.    The information line will indicate that there is an open path of 1 point.



See also:

   Selecting/deselecting points  



Adding a point to the end of a path

You can extend a path by adding a point to its end.

How to add a point to the end of an open path

1. From the toolbox, select the Pointer tool, then select the path to which you want to add a point.    
The points on the path are displayed as small black boxes.

2. Select the point at one end of the open path.    Ensure that only one point is selected.

3. Select the drawing tool for the point you want to add.    Use the Corner tool to add a corner point, the 
Connect tool to add a connect point, or the Curve tool to add a curve point.

4. Click where you want to add the point.    A point is added and the path drawn between the existing 
end point and the new point.    The new end point is selected and the old end point deselected.

To close an open path, repeat Steps 1 to 3 above, and then click on the other end point of the 
open path.



See also:

   Selecting/deselecting points  



Deleting a point

You can delete points from a path to change the shape of the path and make the path easier to 
manipulate.

How to delete a point from a path

1. From the toolbox, select the Pointer tool, then select the path from which you want to delete a point. 
The points on the path are displayed as small black boxes.

2. Select the point or points that you want to delete.

3. Double-click the pointer on one of the selected points to display the path popup menu.

4. Select Delete Points.    The selected points are deleted from the path and the path is redrawn 
without them.

You can also delete points by selecting the points that you want to delete, then pressing 
Backspace.

Deleting a point on a closed path does not convert it into an open path.



See also:

   Selecting/deselecting points  



Moving a point

You can move a point to change the shape of a path.

How to move a point

1. From the toolbox, select the Pointer tool, then press the left mouse button and drag the point to its 
new position.

2. Release the mouse button when the point is in the right place.    The path is redrawn through the 
new point.

While you drag the point, both the new path shape and the original are displayed.

When you have more than one point selected, drag one of them to its new position; the selected 
points remain in the same position relative to each other, and the other points are redrawn as required.

You cannot make a copy of an individual point on a path.    When you move a point, holding down 
Alt as you drag will make a copy of the whole path, even if you only move one of the points.

Using the nudge control

The nudge control lets you 'nudge' the selected point up and down, or left and right, in the same way as 
the cursor keys.

To nudge a point, select it and then click on the required part of the nudge control, to move in the 
appropriate direction.

You can specify the way in which the nudge control works (whether points and objects are 
nudged to grid divisions, or by a specific amount) in the General tab card of the Preferences dialog box.

The nudge control is disabled when you do not have anything selected in your drawing.



See also:

   Selecting/deselecting points  

   Setting your preferences  

   Preferences   dialog box:   General   tab card  



Adjusting control points

Control points are the small handles associated with a point on a path.    The control points control the 
direction of a path through a point, and therefore the shape of the path.    Control points are joined to a 
point on the path by control lines.    You can adjust these control points to change the shape of the path.

How to adjust control points

1. From the toolbox, select the Pointer tool, then select the point that you want to adjust.    The control 
points and control lines of the selected point appear.

2. Point at one of the control points, then press the left mouse button and drag the control point to its 
new position.    The new path and the original are displayed.

3. Release the mouse button when you have the shape you want.    The path is redrawn.

Not all points on a path have control points.    A curve point always has control points; a connect 
point may have one or two control points, depending upon the style of the adjacent points.    A corner point 
does not have control points by default.

If no control points are displayed when you select the point, either they do not exist, or they are 
hidden by the point to which they belong.    You can make the control points appear by holding Ctrl while 
you drag the pointer away from the point.



See also:

   Selecting/deselecting points  



Changing a point style

You can change a point style to change the shape of the path.

How to change the style of a point

1. From the toolbox, select the Pointer tool, then select the point or points that you want to change.

2. Double-click the Pointer tool on one of the selected points.    The path popup menu appears.

3. Select Object Properties from the path popup menu.    The Path Properties dialog box appears.

The Points Selected group box tells you how many points are selected and indicates their style.    If 
the selected points have different styles, the group box does not indicate a style.

4. Select the point style you require.

5. If you want the path to be drawn smoothly through the point, check the Auto Curvature check box.

6. Click on OK.    The style of the point is changed, and the path is redrawn if the style change affects 
it.    The points remain selected.

You can also display the Path Properties dialog box by selecting the point, then selecting 
Properties from the Object menu.

Shortcut:



See also:

   Path Properties   dialog box  

   Selecting/deselecting points  



Splitting a path

You can split a path into two or more sub-paths and manipulate each sub-path as a separate object.    A 
path can be split into as many sub-paths as you want.

How to split a path

1. From the toolbox, select the Pointer tool, then select the path that you want to split.

2. Select the point at which you want to split the path, or if there is no point at the place where you 
want to split the path, insert a point there.

3. Double-click the Pointer tool on the selected point.    The path popup menu appears.

4. Select Split Path from the path popup menu.    The two sub-paths are redrawn and the end points of 
the two new paths become selected.

The split path may still look like a single path, so deselect one of them.    Then drag one away 
from the other to avoid confusion.

You can turn a closed path into an open path by splitting the path.    This change is indicated in 
the information line.

You can also split a path by selecting the point at which you want to split it, then selecting Split 
from the Object menu.

If you have more than one point selected on a path, the Split command splits the path at all the 
selected points.    In this way you can split a path into a number of sub-paths in one command.

You cannot split points on a compound path: You must first ungroup it into separate paths.

Shortcut:



See also:

   Selecting/deselecting points  

   Inserting a point  



Joining one path to another

You can join one path to the end of another.

How to join paths

1. From the toolbox, select the Pointer tool.

2. Select a path, then press the left mouse button and drag the path so that the end point is close to 
the end point of the path to which you want to join it.

3. Select the two end points to be joined.

4. From the Object menu, select Join.    The two paths are joined together and become one object.

The end points of the paths must be within the user defined join range to enable the Join 
command.    You can change the join range in the Preferences dialog box.

You cannot join more than two paths together at the same point.

You can only join paths at their end points.

Shortcut:



See also:

   Preferences   dialog box  

   Selecting/deselecting points  



Combining paths (compound paths)

You can combine one path with one or more other paths to produce a compound path, i.e. a path 
consisting of more than one contour.

How to combine paths.

1. From the toolbox, select the Pointer tool, then select the paths that you want to combine.

2. From the Object menu, select Combine.    The paths are combined to produce a compound path.

The compound path may not appear any different to the original paths.    This depends upon what 
attributes you had selected for each path.    Fill styles and colors may change depending upon where the 
combined paths were in relation to each other, e.g.. inside or overlapping.

Compound paths can only be made up of closed paths.    You cannot combine an open path, a 
group, a bitmap, a basic shape or text (unless it is ungrouped).

Shortcut:

Ctrl M combines the selected paths.



See also:

   Selecting/deselecting objects  



Blending objects

Blend draws a series of paths between two selected paths or shapes.    You can create the effect of one 
object transforming into another by using the blend command. 

How to blend between two objects

1. From the toolbox, select the Pointer tool.

2. Hold down Shift and click to select the two paths or shapes that you want to blend.

3. From the Edit menu, select Blend.    The Blend dialog box appears.

4. Select the number of blend stages required by entering the number in the No. of Blend stages box, 
or by using the arrow keys.

5. Adjust the values of the First Stage and the Last Stage as required.    Normally these values should 
remain at the defaults, which depend on the number of blend stages.

6. Click on OK.    The Blend dialog box is removed and the two paths are blended together.

If the two objects are colored, each blend stage is given an intermediate color.    For example, if 
one object is black and the other is white, the objects at each of the blend stages are given different 
shades of gray, darker at the black end and lighter at the white end.    This applies to both line and fill 
styles.

The paths you use to blend can be open and/or closed.

You can only blend between two paths or shapes.    You cannot use blend on bitmaps, groups of 
objects, or text (unless it is ungrouped).

Always try a smaller rather than a larger number of blend stages first, because a blend with many 
stages may take a long time to display.

How to change the blend effect

You can change the effect of a blend by changing the reference points of a transformation.

1. Select the two paths to blend.

2. Select a point on one or both of the paths.    If you only specify one point, TurboDraw automatically 
uses the first point on the other path as the reference point.

3. From the Edit menu, select Blend, and continue as above.

If you do not specify a reference point, the first points on the paths are used.

You can achieve many effects using different reference points. 





See also:

   Blend   dialog box  

   Selecting/deselecting points  



How To...

Transform objects

   Scaling an object  

   Rotating an object  

   Skewing an object  

   Reflecting an object  

   Copying as you transform  

   Controlling the angle of transformation  

   Repeating a transformation  



Scaling an object

Scaling allows you to change the size of objects and distort the objects in your picture by stretching or 
squeezing them.

How to scale an object

1. Select the object that you want to scale, then select the Scale tool from the toolbox.

2. Press and hold the mouse button at the point where you want the fixed point to be.    The fixed point 
is the origin of the transformation and appears as a small +.    The fixed point can be anywhere in 
the picture window.

3. Drag the pointer in the appropriate direction:

To change the height of the object, drag the pointer vertically

To change the width of the object, drag the pointer horizontally

To change both the height and width, drag the pointer diagonally.

An outline of the scaled object follows the movements of the pointer so that you can see the effect 
you are creating.

4. Release the mouse button when the object is scaled as you want.    The object is redrawn with the 
scaling factor you have specified.

You can use the Double Size and Halve Size tools to exactly double or halve the size of a 
selected object (or several objects, or group of objects).

When you scale an object, the information line displays the current scaling factor in the horizontal 
(sx) and vertical (sy) directions.

If not all the points on a path are selected, only the selected points will be scaled.

You can scale the whole picture by selecting Select All from the Edit menu to select all the 
objects in the picture, then applying the transformation to them.

If the object you have scaled is a text object, you can still edit the text using the Text tool.



To scale an object more accurately, select the object then double-click the Scale tool anywhere in 
the picture window.    The Scale dialog box appears enabling you to make precise changes to the size of 
the object.

Scaling tools:



See also:

   Scale   dialog box  

   Selecting/deselecting objects  

   Selecting/deselecting points  

   Copying as you transform  

   Controlling the angle of transformation  

   Repeating a transformation  



Rotating an object

Rotating allows you to move an object around a fixed point.    Rotating paths, text and other objects can 
create interesting effects.

How to rotate an object with the Transform Tools

1. Select the object that you want to rotate.

2. From the Transform Tools, click on the rotate tool you require, e.g.:

Each tool rotates the object by a specified amount in a specified direction.

How to rotate an object with the Rotate tool

1. Select the object that you want to rotate, then select the Rotate tool from the toolbox.

2. Press and hold the mouse button at the point where you want the fixed point to be.    The fixed point 
is the origin of the transformation and appears as a small +.    The fixed point can be anywhere in 
the picture window.

3. Drag the pointer in any direction.    An outline of the rotated object follows the movements of the 
pointer so that you can see the effect you are creating.

4. Release the mouse button when the object is rotated as you want.    The object is redrawn with the 
rotation you have specified.

For greater control when rotating, drag the pointer further away from the fixed point.



When you rotate an object, the information line displays the current angle of rotation.

If not all the points on a path are selected, only the selected points will be rotated.

You can rotate the whole picture by selecting Select All from the Edit menu to select all the 
objects in the picture, then applying the transformation to them.

If the object you have rotated is a text object, you can still edit the text using the Text tool.

To rotate an object more accurately, select the object then double-click the Rotate tool anywhere 
in the picture window.    The Rotate dialog box appears enabling you to make precise changes to the 
angle of rotation.



See also:

   Transform Tools  

   Rotate   dialog box  

   Selecting/deselecting objects  

   Selecting/deselecting points  

   Copying as you transform  

   Controlling the angle of transformation  

   Repeating a transformation  



Skewing an object

Skewing allows you to create three dimensional or shadow effects that look especially interesting when 
skewing text objects.

How to skew an object with the Transform Tools

1. Select the object that you want to skew.

2. From the Transform Tools, click on the skew tool you require, e.g.:

Each tool skews the object in a specified direction.

How to skew an object with the Skew tool

1. Select the object that you want to skew, then select the Skew tool from the toolbox.

2. Press and hold the mouse button at the point where you want the fixed point to be.    The fixed point 
is the origin of the transformation and appears as a small +.    The fixed point can be anywhere in 
the picture window.

3. Drag the pointer in the appropriate direction:

Dragging the pointer to the right skews the points above the fixed point to the right, and points 
below the fixed point to the left.    Dragging to the left reverses this effect.

Dragging the pointer upwards skews the points to the right of the fixed point upwards, and points 
to the left of the fixed point downwards.    Dragging downwards reverses this effect.

An outline of the skewed object follows the movements of the pointer so that you can see the effect 
you are creating.

4. Release the mouse button when the object is skewed as you want.    The object is redrawn with the 
size and shape you have specified.



When you skew an object, the information line displays the current skew factor in the horizontal 
(sx) and vertical (sy) directions.

If not all the points on a path are selected, only the selected points will be skewed.

You can skew the whole picture by selecting Select All from the Edit menu to select all the 
objects in the picture, then applying the transformation to them.

If the object you have skewed is a text object, you can still edit the text using the Text tool.

To skew an object more accurately, select the object then double-click the Skew tool anywhere in 
the picture window.    The Skew dialog box appears enabling you to specify the exact horizontal and 
vertical skew factors you require.



See also:

   Transform Tools  

   Skew   dialog box  

   Selecting/deselecting objects  

   Selecting/deselecting points  

   Copying as you transform  

   Controlling the angle of transformation  

   Repeating a transformation  



Reflecting an object

Reflecting allows you to produce mirror images of objects.    Interesting effects can be achieved by 
reflecting text, paths, shapes and other objects.

How to reflect an object with the Transform Tools

1. Select the object that you want to reflect.

2. From the Transform Tools, click on the reflect tool you require, e.g.:

Each tool reflects the object across a specified axis.

How to reflect an object

1. Select the object that you want to reflect, then select the Reflect tool from the toolbox.

2. Press and hold the mouse button at the point where you want the fixed point to be.    The fixed point 
is the origin of the transformation and appears as a small +.    The fixed point can be anywhere in 
the picture window.

3. Drag the pointer in any direction.    An outline of the reflected object follows the movements of the 
pointer so that you can see the effect you are creating.

4. Release the mouse button when the object is reflected as you want.    The object is redrawn with the 
angle of reflection you have specified.

For greater control when reflecting, drag the pointer further away from the fixed point.

When you reflect an object, the information line displays the current angle of reflection.

If not all the points on a path are selected, only the selected points will be reflected.

You can reflect the whole picture by selecting Select All from the Edit menu to select all the 



objects in the picture, then applying the transformation to them.

If the object you have reflected is a text object, you can still edit the text using the Text tool.

To reflect an object more accurately, select the object then double-click the Reflect tool anywhere 
in the picture window.    The Reflect dialog box appears enabling you to specify which axis the object is 
reflected across.



See also:

   Transform Tools  

   Reflect   dialog box  

   Selecting/deselecting objects  

   Selecting/deselecting points  

   Copying as you transform  

   Controlling the angle of transformation  

   Repeating a transformation  



Copying as you transform

You can copy an object as you transform it.    This allows you to keep the original object unchanged but 
to create a transformed copy of it, for example to create a mirrored effect.

How to copy as you transform

Hold down Alt as you click on the required tool in the Transform Tools, or as you drag the pointer of the 
selected transform tool around the fixed point.

Release the mouse button before releasing Alt.

Holding down Alt and Ctrl while you drag creates a copy of the transformed object and restricts 
the angle of transformation to multiples of 45 degrees.



See also:

   Scaling an object  

   Rotating an object  

   Skewing an object  

   Reflecting an object  



Controlling the angle of transformation

You can restrict the angle of a transformation to a multiple of 45 degrees.

You can use the Transform Tools to quickly and easily transform objects by specified amounts at 
the click of a button.

How to control the angle of transformation

Hold down Ctrl as you drag the pointer of the selected Transform tool around the fixed point.

Release the mouse button before releasing Ctrl.

Holding down Ctrl and Alt while you drag restricts the angle of transformation to multiples of 45 
degrees and creates a copy of the transformed object.



See also:

   Transform Tools  

   Scaling an object  

   Rotating an object  

   Skewing an object  

   Reflecting an object  



Repeating a transformation

You can repeat a transformation as many times as you like.    For example, if you copy and rotate an 
object by 30 degrees 11 times, you will produce a circle of the same object.

How to repeat a transformation

From the Edit menu, select Transform Again.

If you hold down Alt during the original transformation, repeating the transformation again will 
produce a copy of the transformed object and transform it again.

You can repeat a transformation on another object.    For example, if you scale a polygon, you can 
then select a star and perform the same transformation on it by selecting Transform Again from the Edit 
menu.

Shortcut:



See also:

   Scaling an object  

   Rotating an object  

   Skewing an object  

   Reflecting an object  



How To...

Use colors, lines and fills

   Displaying the color bar  

   Using the color bar  

   Applying color  

   Creating a new color  

   Deleting an existing color  

   Saving a color palette  

   Loading a color palette  

   Applying line styles  

   Applying fill styles  

   Creating a new line style  

   Creating a PostScript line style  

   Creating a new fill style  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Deleting line and fill styles  

   Creating patterns  



Displaying the color bar

You can have a color bar open on your desktop that contains all the colors available in the color palette 
associated with the picture in the active window.    You can turn the display of the color bar on and off.

How to display the color bar

From the View menu, select Show Controls, then select Color Bar from the submenu that appears.    
The color bar appears when the command is checked.

To close the color bar, select Color Bar again.

Use the scroll arrows at either end of the color bar to browse through all the available colors.

The information line displays the name of the color currently under the mouse pointer.



See also:

   Using the color bar  

   Applying color  

   Creating a new color  

   Deleting an existing color  

   Saving a color palette  

   Loading a color palette  



Using the color bar

The color bar is displayed at the bottom of the desktop, and it contains the colors available to the picture 
in the active window.

Any new colors you create will be added to the color bar.

You can turn the color bar on and off by selecting Color Bar from the submenu that appears 
when you select Show Controls from the View menu.    The command is checked when the color bar is 
displayed.

The color bar displays a number of tints of each color; you can specify the number of tints in the 
Edit Colors dialog box.

How to use the color bar

To change the color of an object, select the object, then click the left mouse button on the color 
you require.

To give an object no fill style, select the object, then click the left mouse button on the X button at 
the left-hand end of the color bar.

To change the color of an objects line style, select the object, then click the right mouse button on 
the color you require.

To give an object no line style, select the object, then click the right mouse button on the X button 
at the left-hand end of the color bar.

To change the "to color" of a graduated fill style, select the object, hold down Shift, then click the 
left mouse button on the color you require.    (If you are using a mouse with three buttons and have a 
suitable Windows driver, you can use the middle button to select the "to color".)

To edit a color in the color bar, double-click on the color that you want to edit to display the Edit 
Color dialog box.

To add a new color to the color bar, click on the + button to display the New Color dialog box.



See also:

   Displaying the color bar  

   Edit Colors   dialog box  

   Edit Color   dialog box  

   New Color   dialog box  



Applying color

You can color the objects in your picture.

How to apply color

1. Select the object that you want to color.

2. To change the color of the object's line style, select Color from the Line menu to display the drop-
down color palette, then click on the color you want.

Alternatively, if you have the color bar displayed at the bottom of the desktop, click the right mouse 
button on the color you want.

3. To change the color of the object's fill style, select Color from the Fill menu to display the drop-
down color palette, then click on the color you want.    When an object has a graduated fill, i.e. a fill 
style fading from one color to another, select To Color from the Fill menu, then click on the 'to' color 
you want.

Alternatively, if you have the color bar displayed at the bottom of the desktop, click the left mouse 
button on the color you want.    When an object has a graduated fill, click the left mouse button on 
the 'from' color you require, then Shift-click on the 'to' color.

4. The selected object is given the colors you have specified.

If the colors aren't displayed, your picture is in outline format.    Select Preview from the View 
menu to change the display to preview format.

Clicking on the X button at the left-hand end of the color bar turns the fill or line style off 
depending on whether you click the left or right mouse button on it.

Shortcut:



See also:

   Displaying the color bar  

   Using the color bar  

   Applying line styles  

   Applying fill styles  



Creating a new color

You can modify existing colors or create a new color based on an existing color.

How to create a new color

1. From the Edit menu, select Edit Colors.    The Edit Colors dialog box appears.

2. Scroll through the list of colors and select the color on which you want to base your new color.    The 
selected color appears in the preview box.

3. To create a new color based on the selected color, click on Add.    To edit the selected color without 
creating a new color, click on Edit.    The New Color or Edit Color dialog box appears, depending 
on your choice.

4. If you clicked on Add you can enter a name for the color in the Name box, although this is not 
obligatory.

5. Select a color model from the Model group box, then modify the color as required.    Refer to the 
dialog box help for more information on mixing colors.    The preview box shows the new color as it 
is mixed or selected.

6. If your page format has been set up for color separation, the Spot Color check box appears on this 
dialog box.    Check this box to save the color as a spot color.    The color can then be printed as an 
individual separation giving a cleaner, brighter effect.

7. Click on OK to confirm the new color and return to the Edit Colors dialog box.

8. Click on OK in the Edit Colors dialog box to confirm your edits. 

When you create a new color, the color is added to the color bar.

When you edit an existing color, any objects styled with that color are redrawn and styled with the 
edited color.

The New Color dialog box can also be displayed by clicking on the + button to the right-hand end 
of the color bar; the Edit Color dialog box can also be displayed by double-clicking on a color in the color 
bar.

Shortcut:



See also:

   Edit Colors   dialog box  

   Edit Color   dialog box  

   New Color   dialog box  

   Using the color bar  

   Saving a color palette  

   Loading a color palette  

   Changing the page format  

   Printing color separations  



Deleting an existing color

You can delete any color except Black.    When you delete a color, it is removed from the color bar of the 
picture in the active window, and also from its associated color palette.

How to delete a color

1. From the Edit menu, select Edit Colors.    The Edit Colors dialog box appears.

2. Scroll through the list of colors in the Names box and select the color(s) that you want to delete.    
The color appears in the preview box.

3. Click on Delete.    The color is removed from the Names box and the preview box becomes empty.

4. Click on OK to confirm the deletion and remove the color from the color bar and palette.

When you delete a color that is applied to an object in your picture, the color used for the object is 
replaced with black.

Shortcut:



See also:

   Edit Colors   dialog box  



Saving a color palette

TurboDraw is supplied with a default color palette.    You can create more colors to add to this color 
palette or you can delete colors if you do not want to use them.    When you have edited the default color 
palette you can save it under a new name for future use.

The palette associated with the current drawing appears in the color bar, if you have it turned on.

How to save a color palette

1. From the Edit menu, select Edit Colors.    The Edit Colors dialog box appears.

2. Modify the color palette as required by adding new colors or deleting colors that you do not want to 
use.

3. When the color palette contains all the colors that you want to save, click on Save.    The Save 
Colors dialog box appears.

4. Select the disk drive and directory in which you want to save the color palette.

5. Enter a name for the color palette in the File Name box.    Color palettes are given the file extension 
.COL by default, but you can change this to another file extension if you prefer.

5. Click on OK to save the color palette and return to the Edit Colors dialog box.

6. Click on OK to close the Edit Colors dialog box and continue working with the color palette you 
have just saved.

You can load the saved palette into TurboDraw when you begin a new picture or when you want 
to add more colors to an existing picture.

Shortcut:



See also:

   Edit Colors   dialog box  

   Save Colors   dialog box  

   Creating a new color  

   Deleting an existing color  

   Loading a color palette  



Loading a color palette

You can load a color palette that you have previously saved when you begin a new picture, or when you 
want to add more colors to an existing picture.

How to load a color palette.

1. From the Edit menu, select Edit Colors.    The Edit Colors dialog box appears.

2. Click on Load.    The Load Colors dialog box appears.

3. Select the palette that you want to load and click on OK.

The colors in the palette are added to the list of colors in the Names box on the Edit Colors dialog 
box.

4. Click on OK to close the Edit Colors dialog box.

Colors in the palette that you are loading do not overwrite existing colors of the same name.

Shortcut:



See also:

   Edit Colors   dialog box  

   Load Colors   dialog box  

   Saving a color palette  



Applying line styles

Every object that you draw is automatically given the current default line style.    You can apply a 
different line style to an object.

How to apply a line style

1. Select the object that you want to style.

2. From the Line menu, select Popup Lines.    The Line Style popup appears.

3. Select a line style from those listed in the Line Style popup.

4. Click on Apply to give the line style to the selected object.

If you have multiple objects selected, the line style is given to all of them.

If the line style isn't displayed, the picture is in outline format.    Select Preview from the View 
menu to change the display to preview format.

You can choose not to have a line style for a selected object by selecting None from the Line 
menu, or by clicking the right mouse button on the X at the left-hand end of the color bar.

The current line style will remain selected until you choose another one; any objects that you 
draw subsequently will be given this line style.

You can also select a line style from the Named Style submenu in the Line menu.

Shortcuts:

 



See also:

   Line Style   popup  

   Creating a new line style  

   Deleting line and fill styles  



Applying fill styles

Every object that you draw is automatically given the current default fill style.    You can apply a different 
fill style to an object.

How to apply a fill style

1. Select the object that you want to style.

2. From the Fill menu, select Popup Fills.    The Fill Style popup appears.

3. Select a fill style from those listed in the Fill Style popup.

4. Click on Apply to give the fill style to the selected object.

If you have multiple objects selected, the fill style is given to all of them.

You cannot apply fill styles to open paths, arcs or groups.

If the fill style isn't displayed the picture is in outline format.    Select Preview from the View menu 
to change the display to preview format.

You can choose not to have a fill style for the selected object by selecting None from the Fill 
menu, or by clicking the left mouse button on the X at the left-hand end of the color bar.

The current fill style will remain selected until you choose another one; any objects that you draw 
subsequently will be given this fill style.

You can also select a fill style from the Named Style submenu in the Fill menu.

Shortcuts:

 



See also:

   Fill Style   popup  

   Creating a new fill style  

   Deleting line and fill styles  



Creating a new line style

You can modify an existing line style or create a new line style based on an existing one.

How to create a new line style

1. From the Line menu, select Popup Lines.    The Line Style popup appears.

2. Below the Name and Delete buttons are three Style drop-down list boxes.    From these list boxes 
choose the line style that you want and whether you want arrowheads at the beginning or end of the 
line. 

If you have selected Custom from the center drop-down list box, click on >> to expand the popup.    
You can then enter the lengths of the dashes and gaps for your new line style.

If you have selected PostScript from the center drop-down list box, click on >> to expand the 
popup, then click on PostScript.    The PostScript Styles dialog box appears allowing you to 
choose a PostScript line style.

3. Change the width of the line style by dragging the Width control, or by entering the precise size in 
the Width box.

4. From the drop-down color palette, select the color that you want.    The currently selected color is 
marked by a frame.    Change the tint of the color by dragging the Tint selector.

5. From the Ends drop-down list box, select the style of line end you want.    If you choose a dashed or 
dotted line style, the line end will apply to each dash or dot along the path.

6. From the Join drop-down list box, select the style of line join you want.    If you have selected a 
Miter line join, click on >> to expand the popup, then enter the minimum angle at which you want 
joins to be mitered.    Joins below this angle will be beveled instead of mitered.

7. If your page format has been set up for color separation, the Overprint check box appears.    Check 
this box to enable overprinting when producing color separations.

8. Click on Name.    The Name Style dialog box appears.    If required, enter a name for the line style in 
the Name box.

9. Click on OK to save the line style.    If you are overwriting an existing style a message appears 
asking you to confirm that you want to overwrite the style.    Click on Yes or No as appropriate.

When you create a new line style, the line style is added to the list in the Line Style popup.

When you edit an existing line style, any objects styled with that line style are redrawn with the 
edited style.

When you create a line style for a selected object, you do not have to give a name to the style.    
However, if you do not give the style a name, the style will not be added to the list in the Line Style 
popup.

When you save a picture, it is saved with the line styles currently listed in the Line Style popup.    
If you want to use the new line style in other pictures you must save it into a template.

Shortcuts:





See also:

   Line Style   popup  

   PostScript Styles   dialog box  

   Name Style   dialog box  

   Creating a PostScript line style  

   Using templates  



Creating a PostScript line style

If you intend to print your picture on a PostScript printer, you can create a PostScript line style and apply 
it to objects in your picture.

How to create a PostScript line style

1. From the Line menu, select Popup Lines.    The Line Style popup appears. 

2. Below the Name and Delete buttons are three Style drop-down list boxes.    From the center list box 
select PostScript.

3. Click on >> to expand the popup, then click on PostScript.    The PostScript Styles dialog box 
appears.

4. Scroll through the list of available PostScript line styles in the Styles list box and select a style.

5. If required, change the values in the boxes below the Description box.

6. Click on OK to confirm the PostScript line style you have selected and return to the Line Style 
popup.    Select the other settings on the Line Style popup as required.

7. Click on Name.    The Name Style dialog box appears.    Enter a name for the line style in the Name 
box.

8. Click on OK to save the line style.

The PostScript line style is added to the list of styles in the Line Style popup.    Since PostScript 
line styles cannot be displayed on screen it is represented by a crisscross line style.

Any object that is styled with that line style will be drawn with a crisscross line style, but it will print 
correctly.

You can only print PostScript line styles to PostScript printers.

Shortcut:



See also:

   Line Style   popup  

   PostScript Styles   dialog box  

   Name Style   dialog box  

   Creating a new line style  

   Changing the page format  

   Printing color separations  



Creating a new fill style

You can modify an existing fill style or create a new fill style based on an existing one.

How to create a new fill style

1. From the Fill menu, select Popup Fills.    The Fill Style popup appears.

2. Below the Name and Delete buttons is the Style list box.    From this list box choose the type of fill 
style that you want, e.g.. plain, linear or radial.

When you select a linear, logarithmic or cylindrical style, an arrow appears over the fill style in the 
preview box.    Press the left mouse button and drag this arrow to adjust the angle of the fill style.    
Press Ctrl while dragging to restrict the angle to multiples of 15 degrees.

If you have selected PostScript style, click on >> to expand the popup, then click on PostScript.    
The PostScript Styles dialog box appears allowing you to choose a PostScript fill style.

3. From the drop-down color palette, select the color that you want.    The currently selected color is 
marked by a frame.    Change the tint of the color by dragging the Tint selector.

If you have selected a graduated fill style, you can choose 'from' and 'to' colors for the fill style and 
specify the Tint of each.    The fill will then be a blend from one color to the other, graduated 
according to the selected style.

4. If your page format has been set up for color separation, the Overprint check box appears.    Check 
this box to enable overprinting when producing color separations.

5. Click on Name.    The Name Style dialog box appears.    If required, enter a name for the fill style in 
the Name box.

6. Click on OK to save the fill style.    If you are overwriting an existing style a message appears asking 
you to confirm that you want to overwrite the style.    Click on Yes or No as appropriate.

When you create a new fill style, the fill style is added to the list in the Fill Style popup.

When you edit an existing fill style, any objects styled with that fill style are redrawn with the 
edited style.

When you create a fill style for a selected object, you do not have to give a name to the style.    
However, if you do not give the style a name, the style will not be added to the list in the Fill Style popup.

When you save a picture, it is saved with the fill styles currently listed in the Fill Style popup.    If 
you want to use the new fill style in other pictures you must save it into a template.

Shortcut:



See also:

   Fill Style   popup  

   PostScript Styles   dialog box  

   Name Style   dialog box  

   Creating a halftone fill style  

   Creating a PostScript fill style  

   Creating patterns  

   Using templates  



Creating a halftone fill style

If you intend to print your picture on a PostScript printer, you can create a halftone fill style.    Halftones 
are useful when you want to print the fill style on a PostScript printer at the best possible quality.

How to create a halftone fill style

1. From the Fill menu, select Popup Fills.    The Fill Style popup appears.

2. Click on >> to expand the popup, then click on Halftone.    The PostScript Halftone Screen dialog 
box appears.    (If Halftone is disabled you have PostScript selected in the Style list box.)

3. If you do not want to use the default settings, clear the Default settings check box to enable the 
Screen group box available.

4. Scroll through the list in the Type box and select the shape you require.    (A PostScript printer can 
print a halftone in any of the shapes in this list box.    Each shape will produce a different effect.)

5. Change the frequency of the selected shape by clicking the arrows next to the Frequency box, or 
by entering a value directly into the box.    Change the angle at which the shape will be printed by 
clicking the arrows next to the Angle box, or by entering a value directly into the box.

6. Click on OK to confirm the halftone selections you have made and return to the Fill Style popup.    
Select the other settings on the Fill Style popup as required.

7. Click on Name.    The Name Style dialog box appears.    If required, enter a name for the fill style in 
the Name box.

8. Click on OK to save the fill style.

You can only print halftone fill styles to PostScript printers.

Shortcut:



See also:

   Fill Style   popup  

   PostScript Halftone Screen   dialog box  

   Name Style   dialog box  

   Creating a new fill style  

   Changing the page format  

   Printing color separations  



Creating a PostScript fill style

If you intend to print your picture on a PostScript printer, you can create a PostScript fill style and assign 
it to objects in your picture.

How to create a PostScript fill style

1. From the Fill menu, select Popup Fills.    The Fill Style popup appears.

2. Below the Name and Delete button is the Styles list box.    From this list box select PostScript.

3. Click on >> to expand the popup, then click on PostScript.    The PostScript Styles dialog box 
appears.

4. Scroll through the list of available PostScript fill styles and select a style.

5. If required, change the values in the boxes below the Description box. 

6. Click on OK to confirm the PostScript fill style you have selected and return to the Fill Style popup. 
Select the other settings on the Fill Style popup as required.

7. Click on Name.    The Name Style dialog box appears.    If required, enter a name for the fill style in 
the Name box.

8. Click on OK to save the fill style.

The PostScript fill style is added to the list of styles in the Fill Style popup.    Since PostScript fill 
styles cannot be displayed on screen it is represented by the letters PS on a black background.

Any object that is styled with a PostScript fill style will be represented on screen by a diagonal 
striped fill style, but it will be printed correctly.

You can only print PostScript fill styles to PostScript printers.

Shortcut:



See also:

   Fill Style   popup  

   PostScript Styles   dialog box  

   Name Style   dialog box  

   Creating a new fill style  

   Changing the page format  

   Printing color separations  



Deleting line and fill styles

You can delete line and fill styles.

How to delete line and fill styles

1. Select Popup Lines from the Line menu, or Popup Fills from the Fill menu, to display the Line or 
Fill Style popup.

2. Select the line or fill style that you want to delete.

3. Click on Delete to delete the style.    The style is then removed from the list of available styles.

When you delete a style that is applied to objects in your picture, the style is not lost from those 
objects but it becomes unnamed and is no longer listed in the popups.

Shortcuts:



See also:

   Line Style   popup  

   Fill Style   popup  



Creating patterns

You can create patterns from groups of objects in your picture.    TurboDraw creates a pattern by tiling 
the group of objects.    The patterns can be used as fill styles for other objects.

How to create a pattern

1. Select the group of objects you want to make into a pattern.

2. From the Fill menu, select Pattern.    The Tile Pattern dialog box appears.

3. Enter a name for the pattern in the Name box.

4. Make any adjustments you need to the scale, angle and offsets.

5. Click on OK.    The pattern is added to the list of fill styles in the Fill menu and the Fill Style popup.

The Pattern command is disabled if you do not have a group of objects selected.

To edit a pattern, select the pattern from the list in the Fill Style popup, then click on Pattern.    
The Tile Pattern dialog box appears.    Make the necessary changes and click on OK.

You can delete a pattern in the same way as any other fill style.

To make a pattern from a group of objects that includes an imported bitmap, you must first 
autotrace the bitmap then include the traced path in the group rather than the actual bitmap.

To make a pattern from a text object,    you must group the text object.



See also:

   Tile Pattern   dialog box  

   Fill Style   popup  

   Grouping/ungrouping objects  



How To...

Use TurboDraw with other applications

   Importing TurboDraw' clipart  

   Importing graphics  

   Coloring a bitmap  

   Transforming a bitmap  

   Autotracing a bitmap  

   Exporting graphics  

   Using OLE  

   Embedding a TurboDraw object  

   Linking a TurboDraw object  

   Dragging and dropping a TurboDraw object  



Importing TurboDraw' clipart

The clipart provided with TurboDraw can be imported into your picture using the Clipart Browser.

How to run the Clipart Browser

Click on the Utilities button in the General Tools and select the Clipart Browser icon.    Alternatively, you 
can run it from Program Manager.

From the Clipart Browser you can locate and select a piece of TurboDraw clipart to import into your 
picture.

The Clipart Browser is a separate utility that is supplied with TurboDraw.    Refer to the Help 
supplied with the Clipart Browser for further information on how to use it.

Shortcut:



See also:

   Importing graphics  



Importing graphics

You can import bitmap and line-art graphics from other illustration or paint programs into your 
TurboDraw picture.

How to import a graphic

1. From the File menu, select Import File.    The Import from File dialog box appears.

2. Select the disk drive and directory in which the graphic has been saved.

3. From the List Files of Type drop-down list box, select the type of file you want to import.    The files 
of that type in the current directory are displayed in the File Name list box.

4. From the File Name list box, select the file that you want to import and click on OK.

To import a bitmap for tracing, select For Tracing before clicking on OK.    This places the bitmap 
on layer zero (if the picture is multi-layered).

To smooth line-art during import, select Smoothing and an appropriate Smoothness setting 
before clicking on OK.    Use smoothing if you are likely to ungroup the line-art you are importing.

Imported line-art appears as a group of objects.

You can also drag a graphic file from Windows File Manager and drop it into your TurboDraw picture.    
Refer to your Microsoft Windows User's Guide for further information.

Importing the TurboDraw Clipart

The clipart provided with TurboDraw can be imported into your picture using the Clipart Browser.    To 
run the Clipart Browser, select its icon from the Utilities button. Refer to the Help supplied with the 
Clipart Browser for further information on how to use it.

Shortcut:

 



See also:

   Import from File   dialog box  

   Autotracing bitmaps  



Coloring a bitmap

An autotraced path can be manipulated and colored like any TurboDraw object, but the original bitmap 
can only have one foreground color and one background color.

You can only color monochrome bitmaps.

How to color a bitmap

1. Select the bitmap you want to color.

2. Select a color from the color bar.    The bitmap is redrawn in the selected color.

A second color can be applied by specifying a fill style for the bitmap:

1. Select the bitmap.

2. Give the bitmap a graduated fill style.    The foreground of the bitmap is colored with the "from" color, 
and the background is colored with the "to" color.



See also:

   Applying color  

   Applying line styles  



Transforming a bitmap

When you have imported a bitmap it can be transformed in the same way as any other TurboDraw 
object, but the effect of the skew, rotate and reflect transformations are not displayed.    These 
transformations are represented by a box rather than the transformed bitmap itself.

The box is labeled with the file name of the bitmap, and a flag indicates the current orientation.    If you 
print the picture, the bitmap will be transformed correctly.

Transformed bitmaps can only be printed to a PostScript printer.

Scaled bitmaps are displayed correctly.



See also:

   Scaling an object  

   Rotating an object  

   Skewing an object  

   Reflecting an object  



Autotracing a bitmap

You can autotrace an imported bitmap in much the same way as you would trace a picture using pencil 
and paper.    This creates a representation of the bitmap that can then be manipulated like any other 
object.

How to autotrace a bitmap

Select the Autotrace tool from the toolbox, then click on (or near) the edge of the bitmap.    A path is 
drawn around the bitmap.

If a fill style is selected, the path will be filled.

Only one area of the bitmap will be autotraced; if the bitmap consists of more than one area, the 
area nearest to the point at which you clicked will be autotraced.    You must autotrace each area 
individually.

You can autotrace a hole in a bitmap by clicking anywhere within the hole.    This creates a closed 
path.

If you click and drag across a section of the bitmap, only part of the bitmap will be autotraced.    
This creates an open path.

Not all bitmaps will autotrace well.    A high-contrast, well defined bitmap will autotrace well; a low-
contrast bitmap will not.

You can adjust the accuracy of the Autotrace tool by double-clicking on the tool in the toolbox.    
The Autotrace dialog box appears.    Adjust the smoothness value as required and click on OK.



See also:

   Autotrace   dialog box  



Exporting graphics

You can export objects and pictures in a number of different file formats.    This gives you the ability to 
produce pictures and objects that can be used in other applications.

How to export graphics

1. Select the objects that you want to export.

2. From the File menu, select Export to File.    The Export to File dialog box appears.

3. Select the disk drive and directory in which you want to save the graphic.

4. Select the file format to export to by clicking on the List Files of Type drop-down list box.    All the 
files of this type are listed in the File Name list box.

5. Select the number of colors in which you want to export the graphic from the Colors drop-down list 
box.

6. If you want to export the whole picture, check the All Objects check box.    If you leave this box 
cleared, only the selected objects will be exported.

7. If you are exporting in one of the bitmap file formats, you can specify its resolution.    Enter the 
required value in the Resolution box.    This box is disabled if the graphic is not being exported in a 
bitmap file format.

8. In the File Name box, enter the file name that you want to export the graphic to, then click on OK.

If you enter a file name that already exists, a message appears asking if you want to overwrite the 
existing file.    Click on Yes or No as appropriate.

The file extension is added if you omit it.

We recommend that you use OLE to transfer and copy TurboDraw objects to other Windows 
applications.    Where this isn't possible an alternative route is to use the Windows Clipboard.

Shortcut:



See also:

   Export to File   dialog box  



Using OLE

OLE is a feature that allows you to transfer and share files between Windows applications.    You can link 
or embed a TurboDraw picture into any application that accepts OLE objects, e.g.. TurboPublisher, and 
then edit it without leaving that application.

Applications that support OLE fall into two categories:

Applications whose objects can be embedded or linked into other files, called servers

Applications that can accept embedded or linked objects, called containers.

Some applications may be both a server and a container; others are either one or the other.    
TurboDraw is a server application only; you can link or embed TurboDraw pictures into a container, but 
you cannot embed other OLE objects into TurboDraw.

TurboDraw supports OLE 2, which allows in-place editing and dragging and dropping of TurboDraw 
objects into OLE containers.

Refer to the documentation of your other Windows applications to establish their level (if any) of 
OLE support.



See also:

   Embedding a TurboDraw object  

   Linking a TurboDraw object  

   Dragging and dropping a TurboDraw object  



Embedding a TurboDraw object

By embedding a TurboDraw object into a container, you gain fast access to the features of TurboDraw 
without having to run TurboDraw each time you want to edit the object.    The technique of embedding is 
simple; you copy an object from TurboDraw and insert it into another application.    The object that you 
insert is called an embedded object.

How to embed an existing TurboDraw object

1. Start TurboDraw and open the picture containing the object that you want to embed.

2. Select the object, then select Copy from the Edit menu.    If you want to embed the whole picture, 
select Select All from the Edit menu to select each object in the picture, then select Copy from the 
Edit menu.

3. If not already running start the OLE container, e.g.. TurboPublisher, and open the file into which you 
want to embed the object.

4. In the container, select Paste Special from the Edit menu.    The Paste Special dialog box appears.

5. Select TurboDraw Picture from the As list box, then click on Paste.

6. Click on OK to embed the object.

Most OLE containers will embed the object if you select Paste directly from the Edit menu; 
please refer to the documentation of your container for further details.

How to embed a new TurboDraw object

1. Start the OLE container and open the file into which you want to embed the TurboDraw object.

2. Select Insert Object from the Edit menu.    The Insert Object dialog box appears listing all the 
applications on your computer that support OLE.

3. Select TurboDraw Picture from the Object Type list box and click on OK.

TurboDraw will either be opened in a separate window for you to create your picture, or the TurboDraw 
menus and toolbars will replace those of the container, allowing you to create your picture within the 
container window; this is called in-place editing.    Please refer to the documentation of your OLE 
container for specific details of that particular application.

When you embed a TurboDraw object, a copy of the object file is made and stored within the OLE 
container:    The original file is not altered in any way and remains available for future use.

The command names in the container will differ when embedding to an OLE1 container; please 
refer to the documentation of your container for further details.

Please refer to the documentation of your OLE container for details of how to edit an embedded 
TurboDraw object.

Shortcut:



See also:

   Linking a TurboDraw object  

   Dragging and dropping a TurboDraw object  



Linking a TurboDraw object

By linking a TurboDraw object into a container you save time and ensure consistency in your work.    You 
can share information from one TurboDraw picture with several container applications, and you need 
only maintain the original picture.

How to link a TurboDraw object

1. Start TurboDraw and create the object, or open the picture that contains the object you want to link.

If you have opened an existing picture and do not want it changed, save it under a new name before 
proceeding.    If you are creating a new object, you must save it to a file before you can create a link 
with the container.

2. Select the object, then select Copy from the Edit menu.    If you want to link the whole picture, 
select Select All from the Edit menu to select each object in the picture, then select Copy from the 
Edit menu.

3. If not already running, start the OLE container and open the file into which you want to link the 
object.

4. In the OLE container, select Paste Special from the Edit menu.    The Paste Special dialog box 
appears.

5. Select TurboDraw Picture from the As list box, then click on Paste Link.

6. Click on OK to link the object.

The command names on the Paste Special dialog box will differ when linking to an OLE1 
container; please refer to the documentation of your container for further details.

Please refer to the documentation of your OLE container client application for details of how to 
edit a linked TurboDraw object.

Shortcut:



See also:

   Embedding a TurboDraw object  

   Dragging and dropping a TurboDraw object  



Dragging and dropping a TurboDraw object

TurboDraw provides an alternative way for you to link or embed TurboDraw objects into OLE 2 
containers.    This alternative method is known as "dragging and dropping" because you "drag" the 
object from TurboDraw, and "drop" it into the container.

How to drag and drop a TurboDraw object

1. Start TurboDraw and ensure that the OLE container is running either as a window or an icon.

2. Arrange the windows on your screen so that both TurboDraw and the container window or icon are 
visible.

3. In TurboDraw, create the object, or open the picture that contains the object you want to link or 
embed.

4. Select the object, then press the left mouse button and drag the object onto the container window or 
icon.

5. To embed the object in the container, release the mouse button; to link the object in the container, 
hold down Ctrl Shift and then release the mouse button.

Please refer to the documentation of your OLE container for full details of its drag and drop 
support; the precise method for dragging and dropping may differ slightly in some containers.    For 
example, you may find that the key-combination used for linking isn't Ctrl Shift.

You can also drag and drop objects between picture windows within TurboDraw.



See also:

   Embedding a TurboDraw object  

   Linking a TurboDraw object  



How To...

Print pictures

   Setting up your printer  

   Printing a picture  

   Printing to disk  

   Using crop and registration marks  

   Printing reversed and negative pictures  

   Printing in halftone  

   Printing color separations  

   Solving printing difficulties  



Setting up your printer

TurboDraw prints your picture to the printer that is currently selected.    When you want to use a different 
printer, you must change the printer setup.

How to change the printer setup

1. From the File menu, select Print Setup.    The Print Setup dialog box appears.

2. In the Printer group box, select the Default Printer or Specific Printer option.

If you select Specific Printer, select the printer you want to use from the drop-down list box.

3. From the Orientation group box, select portrait or landscape.

4. From the Size drop-down list box, specify the paper size that you want to print to, and from the 
Source drop-down list box, choose the paper source.

5. Click on Options to display a dialog box providing various options for the selected printer.    This 
dialog box originates from the printer driver and is specific to the selected printer. 

6. Select the appropriate options on this dialog box, then click on OK to return to the Print Setup 
dialog box.

7. Click on OK again.    The new printer will remain selected until you change it.

The default paper size depends on your printer drivers default paper size.

The Print Setup dialog box can also be displayed by clicking on Print Setup in the Print 
Options dialog box.



See also:

   Print Setup   dialog box  

   Print Options   dialog box  

   Printing a picture  



Printing a picture

You can select several options when you print your picture such as multiple copies, scaling, orientation, 
crop and registration marks and so on.

How to print a picture

1. From the File menu, select Print.    The Print Options dialog box appears.

2. From the Output group box choose whether to print the picture to disk, and the number of copies to 
be printed.

3. In the Scaling group box, choose the scale size that you want for your printed picture.    Select Fit 
Page to scale the picture so that the whole page fits into the printable area, select Actual Size to 
print the picture at its actual size or select Scale and enter a value to scale the picture to a specific 
size.

4. From the Layers group box, select which layers of the picture to print.    If you have not set your 
picture to be multi-layered (on the Page Format dialog box) the Layers group box is not available.

5. In the Picture to Page group box, the number of pages that your picture will be printed over is 
given. If this is more than one (e.g.. because the picture is larger than the paper, or you have scaled 
the picture to be larger than the paper) check the Allow Tiling box so that the picture is printed in 
tiles tiling over several pages.

Each tile of a tiled picture is printed with crop and registration marks, even if the Crop & 
registration marks check box is cleared, so that    you can align the tiles to create the complete 
picture.

From the same group box, you can check the Flip Orientation box if you need to print a landscape 
picture onto a portrait page, or vice versa.

6. From the Options group box, check the options that you require.

7. Click on OK to print the picture.    The Printing dialog box appears, indicating the progress of the 
print job.

To abandon the printout, click on Cancel in the Printing dialog box, or press Esc.

If part of your picture seems to be missing, check that all the objects in the picture are within the 
page box.

Shortcut:



See also:

   Print Options   dialog box  

   Printing to disk  

   Using crop and registration marks  

   Printing reversed and negative pictures  

   Printing in halftone  

   Printing color separations  

   Solving printing difficulties  



Printing to disk

You can print your picture to a file on a hard or floppy disk, then print it later using the DOS COPY 
command.    You will need to print your picture to disk as a PostScript file (.EPS) if you intend having it 
printed by a professional printer.

How to print to disk

1. From the File menu, select Print.    The Print Options dialog box appears.

2. In the Output group box, select Print to Disk.

3. Select any other options you require on this dialog box and click on OK.    The Print to Disk dialog 
box appears.

4. Specify a directory and name for the file and choose which format to save the file in from the Save 
File as Type drop-down list box.

5. Click on OK.    The file is printed to disk with the name you have chosen.

If you want to print the file out at a later date, exit to the DOS prompt and use the DOS COPY 
command to print the file.    (Refer to your DOS manual for details of the COPY command).

To print your picture to disk as a PostScript file you must have a PostScript printer driver selected.

Shortcut:



See also:

   Print Options   dialog box  

   Print to Disk   dialog box  

   Printing a picture  



Using crop and registration marks

A tiled picture is automatically given crop and registration marks even when they aren't selected.    These 
are marks printed on the paper that allow you to trim (crop) the tiles and align (register) one tile with 
another.    Crop marks can also be used when the picture is designed to fit on a page smaller than the 
paper it is printed on.

How to turn crop marks on

1. From the File menu, select Print.    The Print Options dialog box appears.

2. Check the Crop & registration marks check box in the Options group box.

3. Select any other options as required, then click on OK.

When the picture is printed you can cut along the crop marks to produce the correctly sized 
paper.    For example, when a picture designed to fit on an Organizer page is printed on Letter paper, the 
crop marks indicate where the paper must be cut.

Crop marks will be printed only if the picture is tiled or if the picture is smaller than the paper on 
which it is printed.

Shortcut:



See also:

   Print Options   dialog box  

   Printing a picture  



Printing reversed and negative pictures

When you prepare a picture for commercial printing, you may need to produce your artwork as a 
negative and/or reversed image.    Check with your commercial printer to determine the type of artwork 
necessary for your job.

How to print reversed and negative pictures

1. From the File menu, select Print.    The Print Options dialog box appears.

2. Check the Reversed and/or Negative check boxes as necessary in the Options group box.

3. Select any other options you need, then click on OK.

When printing to film, you will probably need to select Reversed and Negative; when printing to 
paper, you won't usually need either of these settings.

Reversed and Negative are only available when printing to a PostScript printer.

Shortcut:



See also:

   Print Options   dialog box  

   Printing a picture  



Printing in halftone

When printing a color picture on a monochrome printer, the gray scales that represent the colors are 
sometimes badly contrasted.    Creating a halftone screen improves the way that colors are represented 
to produce a smooth gray scale effect. 

How to print in halftone

1. From the File menu, select Print.    The Print Options dialog box appears.

2. Check the Halftone Screen check box in the Options group box.

3. Select any other options you need, then click on OK.

The Halftone Screen option is disabled when printing to a PostScript printer.    However, you can 
give individual fill styles halftone attributes using the PostScript Halftone Screen dialog box.

Shortcut:



See also:

   Print Options   dialog box  

   PostScript Halftone Screen   dialog box  

   Printing a picture  

   Creating a halftone fill style  



Printing color separations

You can prepare your picture for color separation and print the separation to disk or paper as required.    
Color separation is the process of separating a color picture into a number of different color 
components.    When the picture's color separations are superimposed, they reproduce the original color 
picture.

How to print a color separation

1. Ensure that the picture is prepared for color separation by checking the Color Separation check 
box in the Page Format dialog box.

2. If you want to print a color as an individual separation, ensure that it has been saved as a spot color 
in the Edit Colors dialog box.    To avoid misalignment of spot color separations, select overprinting 
for individual line and fill styles.

3. From the File menu, select Print.    The Print Options dialog box appears.

4. Check the Color Separation check box in the Options group box, and select any other options that 
you require.    If the check box is disabled, you do not have a PostScript printer selected.

5. Click on OK.    The Color Separation dialog box appears.    The four process colors and any spot 
colors that you have created are displayed in the Separations list box.

6. Select which separations you want to print by checking or clearing the This separation check box 
as necessary.    The separations selected for printing are indicated by an asterisk (*).

7. As each separation is selected, the Angle and Frequency of the separation appears in the 
Halftone Screen group box.    Do not adjust these figures unless advised to do so by your 
professional printer. 

8. When all the required separations are selected, click on OK.    If you have chosen to print the color 
separation to disk the Print to Disk dialog box appears.    Enter a filename and select PostScript 
(*.EPS) from the Save File as Type drop-down list box, then click on OK.    The Printing dialog box 
appears indicating the process of the print job.

Pantone colors are only displayed in the Separations list box when you have saved them as spot 
colors on the Edit Colors dialog box.

You can only print color separations to a PostScript printer or to disk as a PostScript file.

Shortcut:



See also:

   Page Format   dialog box  

   Edit Colors   dialog box  

   Print Options   dialog box  

   Color Separation   dialog box  

   Print to Disk   dialog box  

   Printing a picture  



Solving printing difficulties

When your printer won't print, the cause is often a simple mechanical problem such as the printer being 
disconnected or the paper being jammed.

How to locate printing difficulties

Use the following checklist to help find the problem:

Is the printer plugged in, switched on and on-line?

Is the correct printer selected on the Print Setup dialog box?

Are the settings correct?    For example, have you chosen a paper source that has paper in it?

Is the printer jammed, or do you need to add paper?

Is the printer active?    (Check this using the Windows Print Manager.)

Is the printer correctly set up on the Windows Control Panel?

Do you have the correct cable for your printer and is it properly connected to your computer?

Is the ribbon correctly threaded (if your printer uses one) or do you need to change it?    Do you 
need to change the ink cartridge?

If you complete this checklist and still can't print anything, quit TurboDraw and try to print a file from a 
different application.    If this prints correctly, contact Technical Support; it may be that TurboDraw is 
having difficulty printing to that particular printer.    However, if you can't print from another application the 
problem may lie in the printer, printer cable or your Windows setup.    Try connecting the printer again, 
and if that doesn't help, contact your printer manufacturer or dealer.



See also:

   Setting up your printer  





Toolbars

There are five toolbars and a toolbox in TurboDraw.    Click on one of the options below to see 
information on the corresponding tools.

   Toolbox  

   General Tools  

   Object Tools  

   Text Tools  

   Transform Tools  

   Align Tools  

If you click the right mouse button on a toolbar, a popup menu of options for configuring the 
toolbar and its position appears.

If you can't see all the tools in a toolbar, click on the right-pointing arrowhead to expand the 
toolbar.    To collapse a toolbar, click on the left-pointing arrowhead.

If you point at a button and leave the pointer there for a couple of seconds, a yellow ToolTip 
appears below the button, telling the name of the button.    You can turn ToolTips on and off in the Help 
menu.

If you point at a disabled button (i.e. one that is not currently available), a message appears in the 
information line explaining why the shortcut is disabled.    If you click on a disabled button, this message 
appears in a message box on the desktop.

You can choose which tools to display by selecting Show Controls from the View menu, and 
making your choice from the submenu that appears.    Tools that are displayed have a check mark next to 
them; click to remove the check mark, and click again to replace it.

If you want the Text Tools to replace the Object Tools when the Text tool is selected, select 
Switch Object And Text Tools from the Options menu.    If this option is not selected, the Text and 
Object toolbars will both be shown.

Some of the toolbars can be docked at any edge of the desktop, or displayed in floating boxes.    
To move a toolbar, click on it, hold down the mouse button and drag it to your preferred position.    If you 
drag it to the edge of the desktop, the toolbar will dock there; if you leave it in the middle of the desktop, it 
will float.



When you close TurboDraw, the position of the toolbars is remembered; when you next load 
TurboDraw they will be displayed in the same position.

Hint
When you point at a tool with the mouse pointer, the information line at the bottom of the desktop 
displays a prompt for how to use that tool.    If ToolTips are turned on, a yellow ToolTip also appears 
next to the tool.



Toolbox

There are four groups of tools in the TurboDraw toolbox.    The complete set of tools is listed below.    
Click on a tool to see a description of its function.

Shape tools

Drawing tools

Transformation tools



Other tools

Although only six tools are displayed initially down the left-hand side of the desktop, you can click 
on the black arrow symbol to the right of some of the tools, to display more tools within that group.

You can also display the full selection of tools by expanding the toolbox.    Click on the right 
Change Toolbar Size button to expand the toolbox.

The mouse pointer changes to a different shape depending on which tool is selected.



See also:

   Selecting/deselecting objects  

   Entering text  

   Drawing a shape  

   Using the Pencil tool  

   Using the Corner tool  

   Using the Curve tool  

   Using the Connect tool  

   Using the Bezier tool  

   Scaling an object  

   Rotating an object  

   Skewing an object  

   Reflecting an object  

   Viewing your picture  

   Autotracing a bitmap  



General Tools

The following are available in the General Tools.    Click on a button to see a description of its function.

 

 

 

 

 

 

 

 



 

 

The full selection of tools is available only when the toolbar is fully expanded.    Click on the right 
Change Toolbar Size button to expand the toolbar.



See also:

   Displaying the color bar  

   Creating a new color  

   Applying fill styles  

   Applying line styles  

   Cutting, copying and pasting objects  

   Using undo and redo  

   Redoing a transformation  

   Importing TurboDraw clipart  

   Using templates  

   Opening an existing picture  

   Saving a picture  

   Importing graphics  

   Exporting graphics  

   Viewing your picture  

   Printing a picture  

   Using preview and outline format  

   Using the grid and snap control  



Object Tools

The following are available in the Object Tools.    Click on a button to see a description of its function.

 

 

 



See also:

   Overlapping objects  

   Grouping/ungrouping objects  

   Joining one path to another  

   Splitting a path  

   Locking/unlocking objects  

   Positioning objects  



Transform Tools

The following are available in the Transform Tools.    Click on a button to see a description of its function.

 

 

 

 

The full selection of tools is available only when the toolbar is fully expanded.    Click on the right 
Change Toolbar Size button to expand the toolbar.



See also:

   Scaling an object  

   Rotating an object  

   Skewing an object  

   Reflecting an object  



Text Tools

The following are available in the Text Tools.    Click on a button to see a description of its function.

 

 

 

 

 

 

 

 

 

 

The full selection of tools is available only when the toolbar is fully expanded.    Click on the right 
Change Toolbar Size button to expand the toolbar.



When you expand the Text toolbar to its largest size, the Increase Width and Decrease Width shortcuts 
become a Text Width editable field.

Similarly, the Raise Text and Lower Text shortcuts become a Raise/Lower Text editable field.

And the Kern Together and Kern Apart shortcuts become a Kern Text editable field.



See also:

   Resizing text  

   Changing the font and point size  

   Using bold and italic  

   Changing the alignment  

   Expanding and compressing text  

   Raising and lowering text  

   Kerning text  

   Changing the spacing of text  



Align Tools

The following are available in the Align Tools.    Click on a button to see a description of its function.

 

 

 

 

 

The full selection of tools is available only when the toolbar is fully expanded.    Click on the right 
Change Toolbar Size button to expand the toolbar.



See also:

   Aligning objects  



Nudge control

The nudge control lets you 'nudge' the selected object up and down, or left and right; you can use the 
cursor keys for the same effect.    The nudge control can be hidden by selecting Nudge from the Show 
Controls submenu of the View menu.

The nudge control is disabled when you do not have anything selected in your drawing.



See also:

   Moving objects  



Picture window

The TurboDraw picture window is your 'drawing board'.    You can draw your pictures anywhere in the 
picture window, but only the objects in the page box will be printed out.

You can change the size of the picture window by dragging the sizing border.

You can make the picture window take up the full TurboDraw main window by clicking on the 
Maximize button.

You have more than one picture window open at a time.



Information line

The information line displays information about many aspects of the desktop and the picture on which 
you are currently working.

The information line changes depending upon what you are doing at the time and where on the 
desktop the mouse pointer is positioned.

You can turn the information line off by selecting Information Line from the submenu that 
appears when you select Show Controls from the View menu.    This is a toggle command: If you click 
on it when the information line is on, it turns it off; If you click on it when the information line is off, it turns 
it on.

You can choose whether to display the information line on startup by setting your preferences.

The information displayed is listed below:

When the pointer is in the work area

The position of the mouse pointer.

The format of any selected objects, e.g. box, star, open or closed path, etc. and the number of 
points on the path.    (Click on the object information to display the relevant object properties dialog box.)

The selected tool and hints on how to use it

The current active layer of your picture (only when the picture is multi-layer).

When the pointer is over the toolbox or toolbars

A prompt for how to reposition either the toolbox or the toolbars.

A prompt for how to use the tool at which you are pointing, or why the tool is currently disabled

When the pointer is over the color bar

Prompts for how to use the color bar.

The name of the color at which you are pointing.

A prompt for how to use the x and + buttons at either end of the color bar.

When a menu command is selected

A prompt for how to use the command that you have selected, or why the command is currently 



disabled.

During a dialog box

The name of the dialog box.

During a transformation

The skew or scale factors, or the angle of rotation or reflection, or the displacement of an object 
being moved.

When importing or exporting a graphic

The percentage of the import complete, or the path and filename of the exported file.



Rulers

The rulers help you to size and position the objects you draw.    They are displayed along the top, and 
down the left-hand side of the picture window.    As you move the mouse pointer, thin hairlines on the 
rulers indicate the pointer's current position.

You can turn the rulers on and off by selecting Rulers from the submenu that appears when you 
select Show Controls from the View menu.    The command is checked when the rulers are displayed.

You can choose whether to display the rulers for new windows that you open by setting your 
preferences from the Options menu.

You can change the units used by the ruler by clicking on the ruler units box and selecting the unit 
of measurement that you want.

The units available are :

Centimeters

Inches/tenths

Inches/eighths

Picas and points



Ruler units

You can change the unit of measurement used by the rulers by clicking on the units box and selecting 
the units of measurement that you want.

The units available are :

Centimeters

Inches/tenths

Inches/eighths

Picas and points

All the dialog boxes that you display after this change will default to the unit of measurement that 
you have chosen.



Color bar

The color bar is positioned at the bottom of the desktop, and it contains the colors available to the 
picture in the active window, e.g.:

Any new colors you create will be added to the color bar.

You can turn the color bar on and off by selecting Color Bar from the submenu that appears 
when you select Show Controls from the View menu.    The command is checked when the color bar is 
turned on.

The color bar displays a number of tints of each color; you can specify the number of tints in the 
Edit Colors dialog box.



See also:

   Displaying the color bar  

   Using the color bar  

   Edit Colors   dialog box  



Title bar

The title bar is at the top of each window and dialog box.

Drag the title bar if you want to move a window or dialog box around the desktop.

Double-click on the title bar to maximize the window, just as if you had clicked on the maximize 
button.



Minimize button

Click on this button to reduce the window to an icon.

You can then restore the window by double-clicking on the icon, or by clicking on the icon and 
selecting Restore from the popup menu that appears.

You can also minimize the window using the Control menu.



Maximize button

Click on this button to increase the window to its maximum size.

You can also maximize the window using the Control menu.



Restore button

Click on this button to restore the window to its original size and position.

You can also restore the window using the Control menu.



Control menu

The Control menu is represented by a box at the top-left corner of each window and dialog box. 

You use the Control menu's commands to position windows and dialog boxes.

The commands allow you to move windows, change their size and close them.



Scroll bar

The scroll bars are at the right, and at the bottom of the picture window, and are used to move different 
areas of the picture into view.    Use the scroll bar on the right for vertical movement, and the scroll bar at 
the bottom for horizontal movement.

The position of the scroll box in the scroll bar indicates the area of the page that is currently in view.    To 
scroll around the page you can either:

Drag the scroll box along the scroll bar; this moves the picture by the suggested amount in the 
direction you drag it.

Click on the scroll arrows at either end of the scroll bar; this moves the picture a small amount in 
the specified direction.

Click on the scroll bar itself beside the scroll box; this moves the picture one window to the left, to 
the right, up or down.



Sizing border

Drag the sizing border to change the size of the picture window.    The pointer changes to a two-way 
arrow when the sizing border is selected.

If you have grabbed the sizing border at one of the corners, you can size the window both horizontally 
and vertically at the same time.



Picture icon

This picture icon represents a picture that you have minimized.    To restore a picture from an icon, click 
on the icon and select Restore from the Control menu, or double-click on the icon.    The picture 
window appears in the same position as it was before it was minimized.    Changes made to the picture 
while the window was minimized will also be displayed, e.g.. if you have amended the picture via 
another window open on the same picture.

Icons can be dragged around the desktop.



See also:

   Reducing a window to an icon  





New Picture Options dialog box

This dialog box appears when you start TurboDraw, or when you select New from the File menu. It lets 
you choose how to start work on a new picture. The dialog box is divided into four tab cards.

   New Picture Options   dialog box:   Run A PagePilot   tab card  

   New Picture Options   dialog box:   Start A New Picture   tab card  

   New Picture Options   dialog box:   Open An Existing File   tab card  

   New Picture Options   dialog box:   New User Guide   tab card  

Click on Preferences to modify how TurboDraw starts up and starts a new picture, and to set general 
controls.



See also:

   Preferences   dialog box  



New Picture Options dialog box: Run a PagePilot tab card

Select a PagePilot list box

Select the PagePilot you want to run by clicking on its name in this list box.

Comments box

Displays information about the currently selected PagePilot.



See also:

   Running a PagePilot  



New Picture Options dialog box: New User Guide tab card

This tab appears when you click on the New User Guide tab in the New Picture Options dialog box.

It gives a brief introduction to each of the three tabbed functions in the dialog box.    These are:

Run A PagePilot tab

Start A New Picture tab

Open An Existing File tab.



See also:

   New Picture Options   dialog box:   Run A PagePilot   tab card  

   New Picture Options   dialog box:   Start A New Picture   tab card  

   New Picture Options   dialog box:   Open An Existing File   tab card  



New Picture Options dialog box: Start A New Picture tab card

Use this dialog box tab card to start a new picture, using either a blank page or a template.

Category group box

Choose to start your new picture with a blank page or a template.

Blank Page list box

This box is shown if you have chosen to start with a blank page.    Select a pre-defined page size, or 
click on Add to display the Custom Page Size dialog box so that you can create a new page size.

use the Add button to create your own custom page size.

use the Delete button to delete a selected page size.    The page size is then removed from the 
list of available sizes.    You cannot delete any of the pre-defined page sizes.

Orientation group box

This box is shown if you have chosen to start with a blank page.    Select the orientation of your picture, 
i.e. Portrait (vertical) or Landscape (horizontal).

Picture Attributes group box

This box is shown if you have chosen to start with a blank page.    Specify whether your picture will be 
single or multi-layered, and whether you will be using color separation.

Standard Colors check box

This check box is shown if you have chosen to start with a blank page.    Check this box if you want the 
standard selection of colors to be available in your new picture.

Template list box

This box is shown if you have chosen to start with a template.    Select a template by clicking on its 
description or filename in this list box. This box lists the templates you have added by using the Add 
button.

Add button

Click on the Add button if the template you want is not in the list box. The Select a template dialog box 
appears so that you can browse your disk drives and directories for the file that you want to add to the 
list.

Delete button

Click on the Delete button to remove the selected template from the list box. A message appears asking 
you to confirm that you want the template removing. If you click on Yes, the template is removed from 
this list; it is not deleted from disk.

Browse button

Click on the Browse button to display the Open dialog box, so that you can browse your disk drives and 
directories for the template that you want to load without adding it to the list of templates.

Template Description box

This box is shown if you have chosen to start with a template.    It displays information about the 



selected template.

Make Default check box

This check box is shown if you have chosen to start with a template.    Check the Make Default check 
box to make the selected template into the default template so that it is loaded automatically whenever 
you use the default template.

Path and filename box

This box is shown if you have chosen to start with a template.    It displays the path and filename of the 
selected template.



See also:

   Starting a new picture  

   Custom Page Size   dialog box  

   Starting a new picture from a template  

   Select a template   dialog box  

   Open   dialog box  



New Picture Options dialog box: Open an Existing File tab card

Select A File To Open: List box

Select the file you want to open by clicking on the filename in this list box. This box lists the twenty 
pictures you have most recently worked on.

Browse button

Click on the Browse button if the picture you want is not shown in the list box. The Open dialog box 
appears so that you can browse your disk drives and directories for the file you want to open.

Title: Displays the title that you have entered on the Summary Info dialog box.

Subject: Displays the subject that you have entered on the Summary Info dialog box.

Author: Displays the author's name that you have entered on the Summary Info dialog box.

Comments: Displays any comments you have entered on the Summary Info dialog box.



See also:

   Opening an existing picture  

   Open   dialog box  

   Summary Info   dialog box  



Custom Page Size dialog box

This dialog box appears when you select the Start a New Picture tab of the New Picture Options 
dialog box, choose to start with a blank page, and then click on the Add button.    It allows you to create 
your own custom page size.

Name box

Give your new page size a name, so that you will be able to recognize and choose it in future.

Dimensions group box

Specify the required Height and Width dimensions (the maximum values are 30 inches).    You can 
change the units for these dimensions by using the Units drop-down list box.



See also:

   New Picture Options   dialog box  



Select a template dialog box

This dialog box appears when you select Template from the Category group box on the New Picture 
Options dialog box, and then click on the Add button.

From this dialog box you can locate and load a template on which to base your picture. The template will 
be loaded and added to the list of templates on the New Picture Options dialog box.

File Name list box

Select the template you want to load by clicking on the filename in the File Name list box, or by entering 
the filename in the File Name box.

If necessary, use the scroll bar to display more files.

List Files of Type drop-down list box

Select the file format of the picture you want to open, i.e. Template.    Files of the selected format in the 
current directory are displayed in the File Name list box. 

Directories list box

Displays all the directories in the path from the root to the current directory, and a list of all sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory. 

Drives drop-down list box

Select a disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-down a list of 
all the disk drives available. 

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.

Summary Info button

Displays the Summary Info dialog box.



See also:

   New Picture Options   dialog box:   Start A New Picture   tab card  

   Summary Info   dialog box  

   Using templates  



Open dialog box

This dialog box appears when you select Template from the Category group box on the New Picture 
Options dialog box, and then click on the Browse button.

From this dialog box you can locate and load a template on which to base your picture. The template will 
be loaded but will not be added to the list of templates on the New Picture Options dialog box.

File Name list box

Select the template you want to load by clicking on the filename in the File Name list box, or by entering 
the filename in the File Name box.

If necessary, use the scroll bar to display more files.

List Files of Type drop-down list box

Select the file format of the picture you want to open, i.e. Template.    Files of the selected format in the 
current directory are displayed in the File Name list box. 

Directories list box

Displays all the directories in the path from the root to the current directory, and a list of all sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory. 

Drives drop-down list box

Select a disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-down a list of 
all the disk drives available. 

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.

Summary Info button

Displays the Summary Info dialog box.



See also:

   New Picture Options   dialog box:   Start A New Picture   tab card  

   Summary Info   dialog box  

   Using templates  



Open dialog box

This dialog box appears when you select Open from the File menu, or when you click on the Browse 
button on the Open An Existing File tab card of the New Picture Options dialog box.

Use the Preferences dialog box to determine whether the Open dialog box or the Open an 
Existing File tab card of the New Picture Options dialog box appears when you select Open from the 
File menu.

From this dialog box you can locate and load an existing picture so that you can continue to work on it.

File Name list box

Select the file you want to load by clicking on the filename in the File Name list box, or by entering the 
filename in the File Name box.

If necessary, use the scroll bar to display more files.

List Files of Type drop-down list box

Select the file format of the picture you want to open, i.e. Picture or Template.    Files of the selected 
format in the current directory are displayed in the File Name list box. 

Directories list box

Displays all the directories in the path from the root to the current directory, and a list of all sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory. 

Drives drop-down list box

Select a disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-down a list of 
all the disk drives available. 

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.

Summary Info button

Displays the Summary Info dialog box.

If you need to open a backup file, change *.art in the File Name box to *.bak.



See also:

   Opening an existing picture  

   Summary Info   dialog box  

   Preferences   dialog box  



Save As dialog box

This dialog box appears when you select Save As from the File menu, or when you select Save for an 
untitled picture.

From this dialog box you can specify the disk, directory and filename in which to save your picture.

File Name list box

Enter the filename in which you want to save your picture or, if the file already exists, select it by clicking 
on the filename in the File Name list box.

If necessary, use the scroll bar to display more files.

Save File as Type drop-down list box

Select the file format in which you want to save your picture, i.e. Picture or Template.    Files of the 
selected type in the current directory are displayed in the File Name list box but are disabled; when you 
click on OK TurboDraw warns you if you try to overwrite an existing file. 

Directories list box

Lists all the directories in the path from the root to the current directory, and a list of all the sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory. 

Drives drop down list box

Select a disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-down a list of 
all the disk drives available.

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.

Summary Info button

Click on this button if you want to enter more details about the picture you are saving. The Summary 
Info dialog box appears for you to enter the details you want.



See also:

   Summary Info   dialog box  

   Saving a picture  



Summary Info dialog box

This dialog box appears when you select Summary Info from the File menu, or when you are saving a 
picture using the Save As command and click on the Summary Info button on the Save As dialog box, 
or when you click on the Summary Info button on the Open dialog box.

The Summary Info dialog box lets you view information about the current picture.

File Name: Displays the name of the current picture.

Directory: Displays the directory in which the current picture has been saved.

Template: Displays the template (if any) associated with the picture.

Title box

Enter the title of the picture.

Subject box

Enter details of the picture's subject matter.

Author box

TurboDraw automatically inserts the name you entered during installation. You can edit this name if 
required.

Keywords box

Enter any keywords that you want to associate with the picture. Some utilities are able to search your 
system for files by looking for keywords.

Comments box

Enter any information that you want to note about the picture.

Created: Displays the date and time at which the picture was first saved.

Last Saved: Displays the date and time at which the picture was most recently saved.

Last Printed: Displays the date and time at which the picture was most recently printed.

Total Editing Time: Displays the total amount of time that has been spent editing the picture.



Export to File dialog box

This dialog box appears when you select Export to File from the File menu.

From this dialog box you can save all or part of your picture to a file in a variety of formats.    This file can 
then be imported into other pictures or applications.

File Name list box

Enter the filename in which you want to export your picture or, if the file already exists, select it by 
clicking on the filename in the File Name list box.

If necessary, use the scroll bar to display more files.

List Files of Type drop-down list box

Select the file format in which you want to export your picture.    The files of this format in the current 
directory are displayed in the File Name list box.

Directories list box

Displays all the directories in the path from the root to the current directory, and a list of all the sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory. 

Drives drop-down list box

Select a disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-down a list of 
all the disk drives available.

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.

All Objects check box

Available only if you selected an object before displaying the Export to File dialog box.    To export the 
selected objects only, clear the All Objects check box; to export the whole picture, check the All 
Objects check box.

Colors drop-down list box

Select the number of colors in which you want to export your picture.    Click on the arrow to the right-
hand side of the Colors list box to drop-down a list of all the options available. 

If you are exporting a color picture but want the colors to be converted into shades of gray in the 
exported file, select Monochrome.

Resolution box

If you have chosen to export the picture in a bitmap file format, you can specify the resolution of the file. 
Click in the box and enter the required resolution.    (Minimum resolution 10 dots per inch, maximum 
1000 dots per inch.)



See also:

   Exporting graphics  



Import from File dialog box

This dialog box appears when you select Import File from the File menu.

From this dialog box you can import a line-art or bitmap file into your picture.

File Name list box

Select the file you want to import by clicking on the filename in the list box, or by entering the name of 
the file into the File Name box.

If necessary, use the scroll bar to display more files.

List Files of Type drop-down list box

Select the file format of the file you want to import.    Files of the selected format found in the current 
directory are displayed in the File Name list box. 

Directories list box

Displays all the directories in the path from the root to the current directory, and a list of all the sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory. 

Drives drop-down list box

Select a disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-down a list of 
all the disk drives available.

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.

Smoothing check box

Check this box if you are importing a line-art file that you want to have smoothed.    Some line-art files 
represent curves with a series of short straight lines; smoothing the line-art file will smooth these straight 
lines into curves, making the image clearer.

This check box is enabled only when you are importing a line-art file.

Smoothness (1-9) box

This box is enabled if you have checked the Smoothing check box.    It controls the amount of 
smoothing: A larger number gives larger line segments and fewer points on each path.    Type in the 
number you want, or use the arrows to select it.



See also:

   Importing graphics  



Page Format dialog box

This dialog box appears when you select Page Format from the File menu.    From this dialog box you 
can specify the page size and related attributes for your picture.

Page Sizes list box

Select a pre-defined page size or enter a new name in the Page Sizes box to create a new page size.    
When you create a new page size you must specify its dimensions in the Custom Page group box.

Custom Page group box

Specify the dimensions of a your new page size and add the page size to the list in the Page Sizes list 
box, or delete a custom page size:

Specify the required Height and Width dimensions (the maximum values are 30 inches).    You 
can change the units for these dimensions using the Units drop-down list box. 

Use the Add button to add a new page size to the list in the Page Sizes list box.    You must enter 
a name for the new page size in the Page Sizes box for the Add button to be enabled.

Use the Delete button to delete a selected page size.    The page size is then removed from the 
list of available sizes.    You cannot delete any of the pre-defined page sizes.

Picture Orientation group box

Select the orientation of your picture, i.e. Portrait (vertical) or Landscape (horizontal).

Picture Attributes group box

Specify whether your picture will be single or multi-layered, and whether you will be using color 
separation.



See also:

   Preferences   dialog box  

   Changing the page format  



Print Options dialog box

This dialog box appears when you select Print from the File menu.

From this dialog box you can choose how to print your picture, e.g. to paper or to disk.

Output group box

Displays the currently selected printer.

Print to Disk: Select this option to print your picture to disk so that it can be printed at a later 
date, e.g. by a professional printer.    When you click on OK the Print to Disk dialog box appears from 
where you must specify a filename and directory in which to print the file.

Copies box: Enter the number of copies you want to print or use the arrows to set the number of 
copies you want.

Print Setup button: Click on this button to change the settings of the current printer or to select 
an alternative printer.    The Print Setup dialog box appears for you to set up the required printer.

Scaling  group box

Use scaling if you want to enlarge or reduce the size of the picture on printing.

Fit Page button: Click on this button to scale your picture so that it fits the paper size.    If your 
picture is larger than the paper, your picture will be scaled down; if your picture is smaller than the paper, 
your picture will be scaled up.

Actual Size button: Click on this button so that it prints at actual size.    You may need to use tiling 
to print the whole picture if your picture is larger than the paper size. 

Scale button: Click on this button then enter a scaling value into the % box or use the arrows to 
select the value you want.    When the picture is scaled, it is scaled by the same amount in both 
dimensions.

Layers group box

When you are printing a multi-layer picture, the Layers group box is enabled.

All button: Click on this to print all layers in the picture.

Current button: Click on this to print the current layer of the picture.

From button: Click on this button then enter the range of layers that you want to print.    To print 
one specific layer, enter the same layer number in both the From: and to: boxes.

Print Layer Zero check box: Select this check box to print layer zero of your picture.

Picture to Page group box



Picture: Displays the size of the picture.

Page: Displays the size of the paper currently selected for the default printer.

Number of Pages: Displays the number of pages on which the picture will be printed, e.g. If the picture 
is larger than the page, it will be printed as tiles over several pages.

Flip Orientation check box: Check this check box to change the orientation of the page between 
landscape and portrait without transforming the picture.

Allow Tiling check box: This box is automatically checked if your picture is larger than the paper 
it is being printed on. TurboDraw will then print your picture in portions (tiles) which you align using the 
crop and registration marks that are printed on each sheet. If your picture is larger than your paper size 
and you do not check the Allow Tiling box, TurboDraw will only print the top left-hand portion of the 
picture.

Options group box

Halftone Screen check box: Check this box to improve the quality of gray scales when printing a 
color picture on a monochrome printer.    This option is only available when you are printing to a non-
PostScript printer or a monochrome printer.

Include Hidden Objects check box: Check this box to print objects that have been hidden in 
your picture. 

Crop & Registration Marks check box: Check this box to print crop and registration marks.    
When tiling your picture, crop and registration marks will be printed even if this check box is cleared.

Reversed (Mirror Image) check box: Check this box to print your picture as a mirror image.    
This may be necessary when preparing a picture for commercial printing.    This option is only available 
when printing to a PostScript printer.

Negative (White-on-Black) check box: Check this box to print your picture as a negative image. 
This may be necessary when preparing a picture for commercial printing.    This option is only available 
when printing to a PostScript printer.

Color Separation check box: Check this box to print your picture as color separations.    When 
you click on OK the Color Separation dialog box appears from where you must choose the separations 
to print.    This option is only available when Color Separation has been specified on the Page Format 
dialog box, and is only available for PostScript.



See also:

   Print to Disk   dialog box  

   Print Setup   dialog box  

   Color Separation   dialog box  

   Printing a picture  



Color Separation dialog box

This dialog box appears when you check the Color Separation check box on the Print Options dialog 
box, then click on OK.

From this dialog box you can select which color separations you want to print.

To display this dialog box you must have checked the Color Separation box on the Page Format 
dialog box, and you must have a PostScript printer selected.

Separations list box

Displays the four process colors and any spot colors that you have created.    The selected separations 
are indicated by an asterisk (*).

Print group box

Select which separations you want to print.    Highlight the separation in the Separations list box and 
check the This separation check box to add it to the list.    To remove a separation from the list, select 
the separation and clear the This separation check box.

To add or remove all separations, check or clear the All or No separations check box as 
required.

Halftone Screen group box

Displays the Angle and Frequency of the selected separation.    These values can be adjusted if 
required by your professional printer.



See also:

   Print Options   dialog box  

   Printing color separations  



Preferences dialog box

This dialog box appears when you select Preferences from the Options menu, or click on the 
Preferences button on the New Picture Options dialog box. From this dialog box you can control 
various TurboDraw settings.

The dialog box is divided into tab cards. Click on the tab card that you want Help with:

   Preferences   dialog box:   Startup   tab card  

   Preferences   dialog box:   New Window   tab card  

   Preferences   dialog box:   Display   tab card  

   Preferences   dialog box:   General   tab card  



See also:

   Setting your preferences  



Preferences dialog box: Startup tab card

This tab card provides options to control the way TurboDraw starts up.

Startup Options group box

Display New Picture Options Dialog box button: Select this button to make the New Picture 
Options dialog box appear every time you run TurboDraw. This option is preferable if you are unsure how 
you want to start work, or if you do not always start work in the same way.

Load Default Template button: Select this button to make the default template be loaded 
automatically every time you run TurboDraw. 

Startup Display group box

Show Color Bar check box: Check this box to display the color bar along the bottom of the 
TurboDraw desktop.

Maximize Program Window check box: Check this box to display the TurboDraw window across 
the full area of your screen.

Show Info Line check box: Check this box to display the information line along the bottom of the 
TurboDraw desktop.

Number of Recently Used Files group box

In Dialog box: Enter the number of files you want listed on the New Picture Options dialog box 
when opening a template or an existing picture. You can enter any number between 0 and 20.

In File Menu box: Enter the number of recently used picture files you want listed in the File 
menu. You can enter any number between 0 and 20.



See also:

   Setting your preferences  



Preferences dialog box: New Window tab card

This tab card provides options to control TurboDraws' behavior when you open a new picture window.

New Window Settings group box

Provides options allowing you to control the display of each new picture window opened on the 
TurboDraw desktop.

Full Screen check box: Check this box to display the new window in the full area of the 
TurboDraw desktop.

Whole Page check box: Check this box to set the view size of the window to whole page view.

Preview check box: Check this box to display the new window in preview format.

Show Rulers check box: Check this box to display the rulers in the new window.

Show Grid check box: Check this box to display the grid in the new window.

Snap to Grid check box: Check this box to cause objects to align to the grid when they are 
drawn, sized or moved.

Open File group box

Provides options allowing you to determine what is displayed when you select Open from the File 
menu.

Standard 'Open File' dialog box check box: Check this box to display the Open dialog box 
when you select Open from the File menu (this is chosen by default).

'Open an Existing File' dialog box check box: Check this box to display the Open an Existing 
File tab card of the New Picture Options dialog box when you select Open from the File menu.



See also:

   Setting your preferences  

   Open   dialog box  

   New Picture Options   dialog box:   Open an Existing File   tab card  



Preferences dialog box: Display tab card

This tab card provides options to control how TurboDraw displays your work at various points in the 
program.

Preview group box

Display Page Outline check box: Clear this box to turn off the display of the blue page box  
when your picture is displayed in preview format.

Allow Greeking check box: Check this box to allow text to be greeked when your picture is 
displayed in preview format.

Display Fills group box

This option lets you control the display quality of your picture when working in preview format.

Faster button: Select this option to redraw your pictures more quickly but less accurately when 
displayed in preview format

Smoother button: Select this option to redraw your pictures more slowly but more accurately 
when displayed in preview format.

Text group box

Use Vector Font For Outline Text check box: Determines how text is displayed when viewing 
your picture in outline format.    If the box is checked, text is displayed using Windows vector fonts; if the 
box is cleared, text is displayed using its true outline.    Text will be redrawn quicker when Vector Font is 
checked, but more accurately when it is cleared.

Greek Below box: Displays the size (in pixels) below which text will be greeked. If you do not 
want text below this size to be greeked when your picture is displayed in preview format, clear this check 
box. Text below this point size will always be greeked when your picture is displayed in outline format. 
Greeking speeds up the redrawing of text by showing a character as a single line stroke instead of its true 
shape.



See also:

   Setting your preferences  



Preferences dialog box: General tab card

File Options group box

Create .BAK Files check box: Check this check box if you want TurboDraw to save a backup 
copy of your documents.

Nudge Settings group box

In this box, you specify how the nudge control is to work.

Nudge To Grid Divisions button: Select this if you want the nudge control to make items snap to 
the grid as you move them.

Nudge By button: Select this if you want the nudge control to move items by a specified amount, 
and enter the amount in the box. You can change the units for this using the Units drop-down list box.

Ranges group box

Selection Range box: Specifies the distance (in pixels) within which you must click in order to 
select the required object.    Enter a value or click the arrows to make the selection range larger or 
smaller.

Join Range box: Specifies how close together end points must be before TurboDraw will join 
them with a path.    Enter a value or click the arrows to make the join range larger or smaller.



See also:

   Setting your preferences  



Print to Disk dialog box

This dialog box appears when you check the Print to Disk check box on the Print Options dialog box, 
then click on OK.

From this dialog box you can print your picture to a file on a disk, instead of printing it to paper.    You will 
need to print your picture to disk if you intend having it printed by a professional printer.

File Name list box

Enter the name of the file to which you want to print your picture to or, if the file already exists, select it 
by clicking on the filename in the list box.

If necessary, use the scroll bar to display more files.

Save File as Type drop-down list box

Select the file format in which you want to print your file to disk.    The files of this format in the current 
directory are displayed in the File Name list box.

You must print your picture to disk as a PostScript file (.EPS) using a PostScript printer driver if 
you intend having it printed by a professional printer.

Directories list box

Displays all the directories in the path from the root to the current directory, and a list of all the sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory.

Drives drop-down list box

Select a different disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-
down a list of all the disk drives available.

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.



See also:

   Print Options   dialog box  

   Printing to disk  



Print Setup dialog box

This dialog box appears when you select Print Setup from the File menu, or when you click on the 
Print Setup button on the Print Options dialog box.

From this dialog box you can select and set up any of the printers you have installed to print your 
TurboDraw picture.

Printer group box

Default Printer: Select this option to print your picture to the default printer.    The name of the 
default printer is displayed below the Default Printer option.

Specific Printer: Select this option to print your picture to one of the other printers you have 
installed.    Click on the arrow to the right-hand side of the Specific Printer box to drop-down a list of the 
available printers.    Click on a printer name to select it.

Orientation group box

Portrait: Select this option to print your picture in portrait (vertical) orientation.

Landscape: Select this option to print your picture in landscape (horizontal) orientation.

Paper group box

Size drop-down list box: Click on the arrow to the right-hand side of the Size box to drop-down a 
list of available paper sizes.    Select the size of the paper loaded in your printer.

Source drop-down list box: Click on the arrow to the right-hand side of the Source box to drop-
down a list of available paper sources for your selected printer.    Select the source from which your printer 
loads paper.

Options button

Click on this button to display the Options dialog box for the printer you have selected.    The options on 
this dialog box depend on which printer is selected.



See also:

   Print Options   dialog box  

   Setting up your printer  



Blend dialog box

This dialog box appears when you select two objects, then select Blend from the Edit menu.

From this dialog box you can blend two objects together, controlling the number of blend stages.

No. of Blend stages box

Enter the number of blend stages you want, or use the arrows to adjust the value.

First Stage and Last Stage boxes

These values control by how much the object is transformed at the first and last blend stages 
respectively, i.e. the proportion of the transformation done in these steps.    The default values depend 
on the number of blend stages chosen and are calculated so that the blend will be even and gradual.    
Normally these values will not need to be changed but you can adjust them if required.



See also:

   Blending objects  



Grid dialog box

This dialog box appears when you select Grid from the View menu.

From this dialog box you can display a grid to help you align objects and judge their size when creating 
your picture.

Show Grid check box

Check this box to display a grid for the picture in the active window.

Snap to Grid check box

Check this box to ensure that objects align to the grid when they are drawn, moved or sized.

Align to Page check box

Check this box to align the grid to the top left-hand corner of the page.

Align to Ruler check box

Check this box to align the grid to the ruler origin.    If the ruler origin is at the top left-hand corner of the 
page, Align to Ruler will be disabled.

Units drop-down list box

Click on the arrow to the right-hand side of the Units box to drop-down a list of available units; select a 
unit of measurement for the grid.    The grid units can be different from the ruler units. 

Spacing group box

Use this group box to enter the width and height of each grid cell.    You can specify how many sub-
divisions there are across and down each cell.    Clicking on the Copy button will copy the horizontal 
settings to the vertical settings to create a square grid.



See also:

   Using the grid and snap control  



Layers dialog box

This dialog box appears when you select Layers from the View menu.    If your picture is not multi-
layered, the Layers command will be disabled.

From this dialog box you can add or delete layers, rename a layer, or make another layer the current 
layer.

Layers list box

Lists the currently available layers, with the current layer highlighted.    To make another layer the current 
layer, click on it in the list box.

Name box

Displays the name of the current layer.    To rename a layer, edit the name in this box; to add a new 
layer, enter a new name for the layer in this box.

Layer Number box

Displays the number of the current layer.    To add a new layer, enter a new layer number in this box or 
use the arrows to adjust the figure.

Add Layer button

Click on this button to add a new layer to the list in the Layers list box.

You must enter a name and number for the new layer in order to enable this command.

Delete Layer button

Click on this button to delete the current layer.    The layer will be removed from the Layers list box.

You cannot delete layer zero or any layer containing objects.

You must select another layer before clicking on OK, otherwise the deleted layer will be 
recreated.

Number of objects in layer: Displays the number of objects on the current layer.



See also:

   Using layers  



Align dialog box

This dialog box appears when you select Align from the Object menu.

From this dialog box you can align objects to each other or to the page.    You can align a number of 
objects to the left, center or right, and to the top, middle or bottom.    A preview box shows how the 
alignment will take effect.

Each other or Page

Click on Each other or Page to select whether objects are aligned to each other or to the page.

If one of the selected objects is locked when you align to each other, all the objects will align to 
the locked object.

If one of the selected objects is locked when you align to the page, the locked object will not 
move to the new position.

Horizontal group box

Click on Left, Center, Right, or Off.

The preview box illustrates how your objects will align, given the selection that you make.

Vertical group box

Click on Top, Middle, Bottom, or Off.

The preview box illustrates how your objects will align, given the selection that you make.



See also:

   Aligning objects  



Shape Properties dialog box

This dialog box appears when you select a basic shape, then select Properties from the Object menu. 
It also appears when you double-click or right-click the pointer tool on a basic shape and select Object 
Properties from the popup menu that appears.

From this dialog box you can view information about the selected shape and change some of its 
attributes.

Shape group box

Use this group box to change the attributes of the selected shape.

Shape drop-down list box: Displays the current shape of the selected object and allows you to 
change it with the drop-down list box.    Click on the arrow to the right-hand side of the Shape box to drop-
down a list of basic shapes; click on a shape to change the shape of the selected object.

Layer Number box: Displays the layer on which the selected object is currently displayed.    To 
move the object to another layer, enter the layer number in the Layer box.    If the layer number you enter 
does not exist, it will be created.    This option is only available when your picture is multi-layered.

Corner Radius box: This box is available when the selected object is a round box; it allows you 
to change the corner radius of the box.

Start Angle and End Angle boxes: These boxes are available when the selected object is an arc 
or a pie slice; they allow you to change the appearance of the shape by altering its angles.

Sides box: This box is available when the selected object is a polygon; it allows you to change 
the number of sides on the polygon.

Points and Inner Radius boxes: These boxes are available when the selected object is a star; 
they allow you to change the number of points on the star and specify how pointed it is.

Position group box

Displays the object's position.    Use this group box to specify exactly where the object should be 
positioned in your picture.    You can specify the position of the left, center or right of the object in the 
horizontal dimension, and the top, middle or bottom in the vertical dimension.    The coordinates are 
specified from the ruler origin.

Size group box

Displays the object's dimensions.    Use this group box to specify the exact dimensions of the object.    
Alter the value in the Width and Height boxes to resize the object precisely.

Locked check box

Check this box to lock the selected object.    When an object is locked, several options on this dialog box 
become disabled because they do not apply to a locked object.



Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes.    Click on the arrow to 
the right-hand side of the Units box to drop-down a list of available units.    You can then select a 
different unit of measurement.



See also:

   Selecting/deselecting objects  

   Positioning objects  

   Locking/unlocking objects  



Group of Objects dialog box

This dialog box appears when you select a group of objects, then select Properties from the Object 
menu.    It also appears when you double-click or right-click the pointer tool on a group of objects and 
select Object Properties from the popup menu that appears.

From this dialog box you can view information about the selected group and change some of its 
attributes.

Objects group box

Number of Objects in Group: Displays the number of objects in the group.

Locked check box: Check this box to lock the selected group.    When a group is locked several 
options on this dialog box become disabled because they do not apply to locked objects.

Layer Number box: Displays the layer on which the selected group is currently displayed.    To 
move the group to another layer, enter the layer number in the Layer box.    If the layer number you enter 
does not exist, it will be created.    This option is only available when your picture is multi-layered.

Position group box

Displays the group's position.    Use this group box to specify exactly where the group should be 
positioned in your picture.    You can specify the position to the left, center or right of the group in the 
horizontal dimension, and the top, middle or bottom in the vertical dimension.    The coordinates are 
specified from the ruler origin.

Size group box

Displays the group's dimensions.    Use this group box to specify the exact dimensions of the group.    
Alter the value in the Width and Height boxes to resize the group precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes.    Click on the arrow to 
the right-hand side of the Units box to drop-down a list of available units.    You can then select a 
different unit of measurement.



See also:

   Selecting/deselecting objects  

   Grouping/ungrouping objects  

   Positioning objects  

   Locking/unlocking objects  

   Using layers  



Element Properties - Bitmap Image dialog box

This dialog box appears when you select an imported bitmap, then select Properties from the Object 
menu.    It also appears when you double-click or right-click the pointer tool on an imported bitmap and 
select Object Properties from the popup menu that appears.

From this dialog box you can view information about the selected bitmap and change some of its 
attributes.

Bitmap group box

Filename: Displays the filename of the selected bitmap.

Size in pixels: Displays the size of the selected bitmap in pixels.

No. of colors: Displays the number of colors in the selected bitmap.

Layer Number box: Displays the layer on which the selected bitmap is currently displayed.    To 
move the bitmap to another layer, enter the layer number in the Layer box.    If the layer number you enter 
does not exist, it will be created.    This option is only available when your picture is multi-layered.

Negative check box: Check this box to invert the colors of the selected bitmap.    This option is 
only available when a two color bitmap is selected.

Locked check box: Check this box to lock the selected bitmap.    When a bitmap is locked several 
options on this dialog box become disabled because they do not apply to locked objects.

Position group box

Displays the bitmap's position.    Use this group box to specify exactly where the bitmap should be 
positioned in your picture.    You can specify the position of the left, center or right of the bitmap in the 
horizontal dimension, and the top, middle or bottom in the vertical dimension.    The coordinates are 
specified from the ruler origin.

Size group box

Displays the bitmap's dimensions.    Use this group box to specify the exact dimensions of the bitmap.    
Alter the value in the Width and Height boxes to resize the bitmap precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes.    Click on the arrow to 
the right-hand side of the Units box to drop-down a list of available units.    You can then select a 
different unit of measurement.



See also:

   Importing graphics  

   Selecting/deselecting objects  

   Positioning objects  

   Locking/unlocking objects  

   Using layers  



Element Properties - PostScript dialog box

This dialog box appears when you select an imported PostScript EPSF (.EPS) file, then select 
Properties from the Object menu.    It also appears when you double-click or right-click the pointer tool 
on an imported EPS file and select Object Properties from the popup menu that appears.

From this dialog box you can view information about the selected EPS file and change some of its 
attributes.

PostScript group box

Filename: Displays the filename of the selected EPS file.

Layer Number box: Displays the layer on which the selected EPS file is currently displayed.    To 
move the EPS file to another layer, enter the layer number in the Layer box.    If the layer number you 
enter does not exist, it will be created.    This option is only available when your picture is multi-layered.

Locked check box: Check this box to lock the selected EPS file.    When an object is locked 
several options on this dialog box become disabled because they do not apply to locked objects.

Position group box

Displays the EPS file's position.    Use this group box to specify exactly where the EPS file should be 
positioned in your picture.    You can specify the position of the left, center or right of the EPS file in the 
horizontal dimension, and the top, middle or bottom in the vertical dimension.    The coordinates are 
specified from the ruler origin.

Size group box

Displays the EPS file's dimensions.    Use this group box to specify the exact dimensions of the EPS file. 
Alter the value in the Width and Height boxes to resize the EPS file precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes.    Click on the arrow to 
the right-hand side of the Units box to drop-down a list of available units.    You can then select a 
different unit of measurement.



See also:

   Selecting/deselecting objects  

   Positioning objects  

   Locking/unlocking objects  

   Using layers  



Path Properties dialog box

This dialog box appears when you select a path or a point on a path, then select Properties from the 
Object menu.    It also appears when you double-click or right-click the pointer tool on a path or point 
and select Object Properties from the popup menu that appears.

From this dialog box you can view information about the selected path and change some of its 
attributes.

Path group box

Pasted: Indicates how many objects (if any) are pasted inside the closed path.

Contours: Indicates how paths are within a path.    This is useful when a compound path is 
selected.

Layer No. box: Displays the layer on which the selected path is currently displayed.    To move 
the path to another layer, enter the layer number in the Layer box.    If the layer number you enter does 
not exist, it will be created.    This option is only available when your picture is multi-layered.

Winding Fill check box: Check this box to apply the current fill style to all the enclosed areas that 
have been created by the path crossing over itself.    This option is enabled only when a closed path is 
selected.

Locked check box: Check this box to lock the selected path.    When the path is locked, several 
options on this dialog box become disabled because they do not apply to locked objects.

Path Closed check box: Check this to close an open path.

No. Points Selected group box

When the path has some points selected, this group box indicates how many points are selected and of 
which type.    You can change the type of selected points, e.g. from corner points to connector points.    
You can also turn the auto curvature of the selected points on or off.    Turning Auto curvature off lets 
you edit points without the path being constrained to TurboDraws' automatic curvature.

Position group box

Displays the path's position.    Use this group box to specify exactly where the path should be positioned 
in your picture.    You can specify the position of the left, center or right of the path in the horizontal 
dimension, and the top, middle or bottom in the vertical dimension.    The coordinates are specified from 
the ruler origin.

Size group box

Displays the path's dimensions.    Use this group box to specify the exact dimensions of the path.    Alter 
the value in the Width and Height boxes to resize the path precisely.

Units drop-down list box



Displays the unit of measurement used in the Position and Size group boxes.    Click on the arrow to 
the right-hand side of the Units box to drop-down a list of available units.    You can then select a 
different unit of measurement.



See also:

   Selecting/deselecting objects  

   Positioning objects  

   Locking/unlocking objects  

   Using layers  

   Using Cut+Paste Special  



Text on a Path dialog box

This dialog box appears when you select text on a path, then select Properties from the Object menu. 
It also appears when you double-click or right-click the pointer tool on the text on a path and select 
Object Properties from the popup menu that appears.

From this dialog box you can view information about the selected text on a path and change some of its 
attributes.

Options group box

Show Path check box: Check this box to display the path to which the text is joined.

Joined check box: Clear this box to split the text and the path back into two separate objects.

Reverse Direction check box: Check this box to reverse the direction in which the text flows 
along the path.

Locked check box: Check this box to lock the selected path.    When the path is locked, several 
options on this dialog box become disabled because they do not apply to locked objects.

Align text to path using group box

Use this group box to change the way in which text flows along the path by selecting a different 
alignment position.

Top: Produces the effect of the characters hanging down from the path.

1/2 Cap-height: Produces the effect of the path running through the characters at half the height 
of the upper case characters in the selected font.

Baseline: Produces the effect of the characters standing on the path.    (This is the default 
alignment).

x-height: Produces the effect of the path running through the characters at the height of the top 
of a lower case x character in the selected font.

1/2 x-height: Produces the effect of the path running through the characters at half the height of 
a lower case x character in the selected font.

Descender: Produces the effect of the path following the bottom of the descender characters in 
the selected font.

Text Orientation group box

Use this group box to create different effects by changing the text orientation.



Rotate baseline: The characters are positioned perpendicular to the path.    (This is the default 
orientation).

Skew baseline: The vertical elements of the characters remain vertical while the horizontal 
elements are parallel to the path.

Upright: The characters follow the path but remain upright.

Skew vertical: The horizontal elements of the characters remain horizontal while the vertical 
elements are at right angles to the path.

Spacing button

Click on this button to display the Spacing dialog box from where you can change the spacing of the 
text.

Path Info button

Click on this button to display the Path Properties dialog box for the path to which the text is joined.



See also:

   Spacing   dialog box  

   Path Properties   dialog box  

   Selecting/deselecting objects  

   Positioning objects  



Spacing dialog box

This dialog box appears when you double-click or right-click the pointer tool on a text object, then select 
Text Spacing from the popup menu that appears.    It also appears when you click on the Spacing 
button in the Text Properties and the Text on a Path dialog boxes.

From this dialog box you can set parameters controlling the spacing of letters, words and lines of a text 
object.

All the options on this dialog box can be changed by entering the value in the appropriate box, or 
by using the arrows to scroll to the value you need.

Leading box

Adjust the leading (spacing) between the lines of text. 

Word Space boxes

Adjust the minimum and maximum spacing between the words in the text.

Letterspace boxes

Adjust the minimum and maximum spacing between the letters in the text. 

Reset button

Click on this button to set all the values back to their defaults.



See also:

   Changing the spacing of text  

   Selecting/deselecting objects  

   Positioning objects  



Text Properties dialog box

This dialog box appears when you select a text object, then select Properties from the Object menu.    
It also appears when you double-click or right-click the pointer tool on a text object and select Object 
Properties from the popup menu that appears.

From this dialog box you can view information about the selected text object and change some of its 
attributes.

Text group box

Spacing button: Click on this button to display the Spacing dialog box from where you can 
change the spacing of the text object.

Layer Number box: Displays the layer on which the selected text object is currently displayed.    
To move the object to another layer, enter the layer number in the Layer box.    If the layer number you 
enter does not exist, it will be created.    This option is only available when your picture is multi-layered.

Locked check box: Check this box to lock the selected text object.    When an object is locked, 
several options on this dialog box become disabled because they do not apply to locked objects.

Position group box

Displays the object's position.    Use this group box to specify exactly where the object should be 
positioned in your picture.    You can specify the position of the left, center or right of the object in the 
horizontal dimension, and the top, middle or bottom in the vertical dimension.    The coordinates are 
specified from the ruler origin.

Size group box

Displays the object's dimensions.    Use this group box to specify the exact dimensions of the object.    
Alter the value in the Width and Height boxes to resize the object precisely.

Units drop-down list box

Displays the unit of measurement used in the Position and Size group boxes.    Click on the arrow to 
the right-hand side of the Units box to drop-down a list of available units.    You can then select a 
different unit of measurement.



See also:

   Spacing   dialog box  

   Selecting/deselecting objects  

   Positioning objects  



Multiple Objects dialog box

This dialog box appears when you select more than one object, then select Properties from the Object 
menu.    It also appears when you double-click or right-click the pointer tool on two or more selected 
objects and select Object Properties from the popup menu that appears.

From this dialog box you can see how many objects are currently selected, and the range of layers in 
which they are positioned.



See also:

   Selecting/deselecting objects  

   Positioning objects  



Move Objects to Layer dialog box

This dialog box appears when you select To Layer from the Object menu, or when you press Ctrl T.    If 
your picture is not multi-layered, or you have not selected an object, the To Layer command will be 
disabled.

From this dialog box you can move selected objects to a specific layer.

To Layer box

Displays the layer on which the selected objects are currently displayed.    To move the objects to 
another layer, enter the layer number in the To Layer box.    If the layer number you enter does not exist, 
it will be created.

Layer Names list box

Displays all the layers in your picture.    To move the selected objects to another layer, click on the layer 
name to which you want to move them.



See also:

   Moving objects between layers  

   Selecting/deselecting objects  

   Positioning objects  



Reflect dialog box

This dialog box appears when you double-click the Reflect tool on one or more selected objects.

From this dialog box you can reflect object(s) across a reflection axis.

Reflect across group box

Select the axis that you want the object(s) to be reflected across.    This can be a Vertical or Horizontal 
axis, or if you select Angled Axis, you can specify an angle in the box provided, or drag the radius in 
the circle.

Fixed Point group box

Select the origin (fixed point) of the reflection.

Mouse Click: Reflects the object(s) at the point where you double-clicked the mouse to display 
this dialog box

Center of Selection: Reflects the object(s) at the central point of the selection.

XY Location: Reflects the object(s) at the precise position specified in the Across and Down 
boxes.

Units drop-down list box: Displays the unit of measurement used in the Across and Down 
boxes.    Click on the arrow to the right-hand side of the Units box to drop-down a list of available units.    
You can then select a different unit of measurement.

Copy Objects check box

Check this box to reflect a copy of the selected object(s) while leaving the original unchanged.



See also:

   Reflecting an object  



Rotate dialog box

This dialog box appears when you double-click the Rotate tool on one or more selected objects.

From this dialog box you can rotate object(s) accurately.

Rotation group box

Specify the angle of rotation.    You can enter the angle into the Angle box, use the arrows to increase or 
decrease the value, or drag the radius in the circle.

Fixed Point group box

Select the origin (fixed point) of the rotation.

Mouse Click: Rotates the object(s) at the point where you double-clicked the mouse to display 
this dialog box

Center of Selection: Rotates the object(s) at the central point of the selection.

XY Location: Rotates the object(s) at the precise position specified in the Across and Down 
boxes.

Units drop-down list box: Displays the unit of measurement used in the Across and Down 
boxes.    Click on the arrow to the right-hand side of the Units box to drop-down a list of available units.    
You can then select a different unit of measurement.

Copy Objects check box

Check this box to rotate a copy of the selected object(s) while leaving the original unchanged.



See also:

   Rotating an object  



Skew dialog box

This dialog box appears when you double-click the Skew tool on one or more selected objects.

From this dialog box you can skew object(s) accurately.

Skew group box

Specify the Horizontal and Vertical skew factors by entering a value directly into the boxes or by using 
the arrows to increase or decrease the value.

Fixed Point group box

Select the origin (fixed point) of the skew.

Mouse Click: Skews the object(s) at the point where you double-clicked the mouse to display this 
dialog box

Center of Selection: Skews the object(s) at the central point of the selection.

XY Location: Skews the object(s) at the precise position specified in the Across and Down 
boxes.

Units drop-down list box: Displays the unit of measurement used in the Across and Down 
boxes.    Click on the arrow to the right-hand side of the Units box to drop-down a list of available units.    
You can then select a different unit of measurement.

Copy Objects check box

Check this box to skew a copy of the selected object(s) while leaving the original unchanged.



See also:

   Skewing an object  



Scale dialog box

This dialog box appears when you double-click the Scale tool on one or more selected objects.

From this dialog box you can change the size of object(s) accurately.

Scaling group box

Select Uniform to scale the object(s) equally in both vertical and horizontal directions, then set the 
percentage by which you want to scale.    Select Non Uniform to scale the object(s) differently in vertical 
and horizontal directions, then set the horizontal (X) and the vertical (Y) scale factors separately.

Fixed Point group box

Select the origin (fixed point) of the scale.

Mouse Click: Scales the object(s) at the point where you double-clicked the mouse to display 
this dialog box

Center of Selection: Scales the object(s) at the central point of the selection.

XY Location: Scales the object(s) at the precise position specified in the Across and Down 
boxes.

Units drop-down list box: Displays the unit of measurement used in the Across and Down 
boxes.    Click on the arrow to the right-hand side of the Units box to drop-down a list of available units.    
You can then select a different unit of measurement.

Copy Objects check box

Check this box to scale a copy of the selected object(s) while leaving the original unchanged.



See also:

   Scaling an object  



Move Objects dialog box

This dialog box appears when you double-click or right-click the pointer tool on one or more selected 
objects, then select Move/Copy from the popup menu that appears, or when you select an object, then 
double-click on the pointer tool in the toolbox.

From this dialog box you can move and position object(s) accurately. 

Horizontal group box

Enter the amount by which you want to move the object(s) horizontally and select whether they should 
move to the left or the right.

Vertical group box

Enter the amount by which you want to move the object(s) vertically and select whether they should 
move upwards or downwards.

To move the object(s) in a diagonal direction, move the objects both horizontally and vertically.

Units drop-down list box

Displays the unit of measurement used in the Horizontal and Vertical group boxes.    Click on the arrow 
to the right-hand side of the Units box to drop-down a list of available units.    You can then select a 
different unit of measurement.

Copy Objects check box

Check this box to move a copy of the selected object(s) while leaving the original unchanged.



See also:

   Moving objects  



Rounded Box dialog box

This dialog box appears when you double-click on the Round Box tool.

From this dialog box you can adjust the curvature (corner radius) given to a round box when it is drawn.

Default Corner Radius box

Enter the corner radius required.

Reduce the corner radius to make the box more square; increase the corner radius to make the 
box more circular.

Units drop-down list box

Displays the unit of measurement used in the Default Corner Radius box.    Click on the arrow to the 
right-hand side of the Units box to drop-down a list of available units.    You can then select a different 
unit of measurement.

Any round boxes that you now draw will be given the corner radius that you have specified until 
you change it again.

To change the corner radius of an existing round box, double-click the pointer tool on the round 
box and select Object Properties from the popup menu that appears.    You can then change the corner 
radius of the box in the Shape Properties dialog box. 



See also:

   Shape Properties   dialog box  

   Changing the curvature of a round box  



Freehand dialog box

This dialog box appears when you double-click on the Pencil tool.

From this dialog box you can adjust the smoothness value; this determines the accuracy at which a path 
follows the movements of the pencil.

Smoothness box

Enter the required smoothness value in the box or use the arrows to increase or decrease the value.

Decreasing the smoothness will produce a path that closely follows the movements of the pencil 
tool, making the path appear rough with many points. 

Increasing the smoothness will produce a path that does not follow the movements of the pencil 
tool so closely, but smoothes out the path so that it has fewer points.

Any freehand paths that you now draw will be given the smoothness value that you have 
specified until you change it again.



See also:

   Smoothing a freehand path  



Autotrace dialog box

This dialog box appears when you double-click on the Autotrace tool.

From this dialog box you can adjust the smoothness value; this determines the accuracy at which a path 
is autotraced.

Smoothness box

Enter the required smoothness value in the box or use the arrows to increase or decrease the value.

Decreasing the smoothness will produce a path that closely follows the original bitmap.

Increasing the smoothness will produce a path that does not follow the original bitmap so closely 
but smoothes out the path so that it has fewer points.

Any paths that you now autotrace will be given the smoothness value that you have specified until 
you change it again.



See also:

   Autotracing a bitmap  



Polygon dialog box

This dialog box appears when you double-click on the Polygon tool.

From this dialog box you can specify the number of sides given to a polygon when it is drawn.

No. of Sides box

Enter the number of sides required, or use the arrows to increase or decrease the number. 

The preview box illustrates the shape that your polygon will adopt.

Any polygons that you now draw will be given the number of sides that you have specified until 
you change them again.

To change the number of sides on an existing polygon, double-click or right-click the pointer tool 
on the polygon and select Object Properties from the popup menu that appears.    You can then change 
the number of sides in the Shape Properties dialog box.



See also:

   Shape Properties   dialog box  

   Changing the number of sides on a polygon  



Star dialog box

This dialog box appears when you double-click on the Star tool.

From this dialog box you can specify the number of points given to a star when it is drawn and how 
pointed the star will be.

No. of Points box

Enter the number of points required, or use the arrows to increase or decrease the number of points.

Star Inner Radius box

Enter the inner radius required, or drag the scroll bar to increase or decrease the inner radius.

Reduce the inner radius to make the star more pointed; increase the inner radius to make the star 
less pointed.

The preview box illustrates the shape that the star will adopt.

Any stars that you now draw will be given the number of points and the inner radius that you have 
specified until you change them again.

To change the number of points and the inner radius of an existing star, double-click or right-click 
the pointer tool on the star and select Object Properties from the popup menu that appears.    You can 
then change the number of points and the inner radius in the Shape Properties dialog box. 



See also:

   Shape Properties   dialog box  

   Changing the number of points on a star  

   Changing the inner radius of a star  



Line Ends dialog box

This dialog box appears when you select Ends from the Line menu.

From this dialog box you can specify the way the ends of the selected line style, and any subsequent 
line styles, are drawn.

Arrowheads drop-down list boxes

Click on the arrow to the right-hand side of each list box to drop-down a list of available arrowheads.    
You can then choose the type of arrowhead you want (if any) for either end of the line style.

Ends drop-down list box

Click on the arrow to the right-hand side of the list box to drop-down a list of available end styles.    You 
can then choose the required end for the line style: Butt, round or square.

Join drop-down list box

Click on the arrow to the right-hand side of the list box to drop-down a list of available join styles.    You 
can then choose the required join for the line style: Miter, round or bevel.

Do not Miter angles below box

Displays the minimum angle at which joins will be mitered when the selected join style is Miter.    Specify 
the angle that you require by typing it in the box.    Joins below this angle will be beveled instead of 
mitered.

The line style of any objects that you now draw will be given the line ends that you have specified 
until you change them again.



See also:

   Applying line styles  

   Creating a new line style  



Edit Color dialog box

This dialog box appears when you select Edit Colors from the Edit menu, then select the color that you 
want to edit and click on the Edit button.    It also appears when you double-click on a color in the color 
bar.

From this dialog box you can modify an existing color.    The color appears in the preview box, which 
illustrates your changes as you edit the color.

Name box

Displays the name of the selected color, or indicates that the color is unnamed.    If you want the rename 
the color, enter a new name in the Name box.

Model group box

Select the color model that you want to use.

RGB: This color model uses a proportion of red, green and blue to mix any other color.

CMYK: This color model uses a percentage of cyan, magenta, yellow and black to mix any other 
color.

HLS: This color model uses hue, lightness and saturation to mix any other color.

PANTONE:    The PANTONE MATCHING SYSTEM is used world-wide as the standard for color 
reproduction.    By using a PANTONE color you can be sure that your commercial printer will be able to 
reproduce exactly the color you have in mind.    It is important to have a PANTONE printed color guide to 
refer to when selecting the colors in TurboDraw, since the screen can only simulate PANTONE colors.    
Choose the color from the PANTONE printed color guide, then select the color in TurboDraw.    The color 
used by your commercial printer for the final quality printout will match the PANTONE color.

Slider controls

Use the slider controls to mix the color that you want.

If you are using PANTONE colors, use the slider control to find the color that you want, then 
select it.    The preview box displays the color as it is mixed or selected.

Remember, the PANTONE video simulation of the color may not be a true representation of the 
final printed color.

Color blocks

Eight color blocks are displayed around the preview box.    You can click on these color blocks as an 
alternative to choosing a color model and mixing a color.    For example, click on the blue color block to 
make your color more blue.

Spot Color check box

This appears only when your picture has been set up for color separation.    Check this box to save the 
color as a spot color.    The color can then be printed as an individual separation giving a cleaner, 
brighter effect.



To save a color as a spot color, the color must be named.

When you click on OK, any objects already using the color you have edited will be redrawn with 
the edited color.



See also:

   Edit Colors   dialog box  

   Creating a new color  



New Color dialog box

This dialog box appears when you select Edit Colors from the Edit menu, then click on the Add button 
in the Edit Colors dialog box.    It also appears when you click on the + button at the right-hand end of 
the color bar.

From this dialog box you can create a new color.    The color you create appears in the preview box, 
which illustrates your changes as you mix the color.

Name box

Enter a name for the color in the Name box.    If you do not name your color, it will still be added to the 
color bar and marked as unnamed.

Model group box

Select the color model that you want to use.

RGB: This color model uses a proportion of red, green and blue to mix any other color.

CMYK: This color model uses a percentage of cyan, magenta, yellow and black to mix any other 
color.

HLS: This color model uses hue, lightness and saturation to mix any other color.

PANTONE:    The PANTONE MATCHING SYSTEM is used world-wide as the standard for color 
reproduction.    By using a PANTONE color you can be sure that your commercial printer will be able to 
reproduce exactly the color you have in mind.    It is important to have a PANTONE printed color guide to 
refer to when selecting the colors in TurboDraw, since the screen can only simulate PANTONE colors.    
Choose the color from the PANTONE printed color guide, then select the color in TurboDraw.    The color 
used by your commercial printer for the final quality printout will match the PANTONE color.

Slider controls

Use the slider controls to mix the color that you want.

If you are using PANTONE colors, use the slider control to find the color that you want, then 
select it.    The preview box displays the color as it is mixed or selected.

Remember, the PANTONE video simulation of the color may not be a true representation of the 
final printed color.

Color blocks

Eight color blocks are displayed around the preview box.    You can click on these color blocks as an 
alternative to choosing a color model and mixing a color.    For example, click on the blue color block to 
make your color more blue.

Spot Color check box

This appears only when your page format has been set up for color separation.    Check this box to save 
the color as a spot color.    The color can then be printed as an individual separation giving a cleaner, 
brighter effect.



To save a color as a spot color, the color must be named.

When you click on OK, the color is added to the color bar and can be applied to objects in your 
picture.



See also:

   Edit Colors   dialog box  

   Creating a new color  



Tile Pattern dialog box

This dialog box appears when you select Pattern from the Fill menu.    It also appears when you select 
an existing pattern in the Fill Style popup and click on the Pattern button.

From this dialog box you can create a pattern from a group of objects by tiling the group into a fill style, 
or you can edit an existing pattern.

Name box

Enter a name for the pattern.

Scale box

Specify the size of the tiles by entering a percentage in the box, or by using the arrows to increase or 
decrease the percentage.    The preview box will display the pattern you are creating.

When you enter a low percentage, a message may be displayed in the preview box stating that 
the pattern is too small to be displayed on screen.    The pattern will however be printed correctly.

Angle box

Specify the angle of the tiles by entering a value in the box, or by using the arrows to increase or 
decrease the angle.    You can also adjust the angle by dragging the radius of the circle.

Offset group box

Horizontal and Vertical boxes: Set the horizontal and vertical offsets of the pattern by entering a 
value in each box.    The offsets determine the alignment of the pattern when it is applied to an object.    By 
adjusting the offsets of patterns, you can change the way in which patterns align with each other when 
they are applied to overlapping objects.

Units drop-down list box: Displays the unit of measurement used in the Horizontal and Vertical 
boxes.    Click on the arrow to the right-hand side of the Units box to drop-down a list of available units.    
You can then select a different unit of measurement.



See also:

   Creating patterns  



PostScript Halftone Screen dialog box

This dialog box appears when you expand the Fill Styles popup and click on the Halftone button.    The 
Halftone button is disabled when you have a PostScript fill style selected.

From this dialog box you can create a halftone fill style.    This is useful when you want to print the fill 
style on a PostScript printer at the best possible quality.

Default Settings check box

Clear this box to enable the Screen group box; you can then enter values other than the defaults.

Screen group box

Type list box: Select the shape you want.    A PostScript printer can print a halftone fill style in any 
of the shapes listed; each shape will produce a different effect.

Frequency box: Change the frequency of the selected shape by clicking the arrows next to the 
box, or by entering a value directly into the box.    The frequency determines the density of the shape.

Angle box:    Change the angle of the selected shape by clicking the arrows next to the box, or by 
entering a value directly into the box.    The angle determines the position at which the shape will be 
printed.



See also:

   Creating a halftone fill style  



PostScript Styles dialog box

This dialog box appears when you expand the Line or Fill Style popup, then click on the PostScript 
button.

From this dialog box you can create a PostScript line or fill style.    PostScript styles cannot be displayed 
on screen and can only be printed to a PostScript printer.

Styles list box

Select a PostScript style from the list box.

Description group box

Displays information about the selected style; not all styles have associated information.

Parameter boxes

Display style-specific parameters that can be edited; not all styles have associated parameters.

The available parameters depend on the selected style.    Many styles allow you to edit their 
length and width; some styles provide other parameters that can be edited.    For example, the Bricks fill 
style displays information about the width and height of each brick and the thickness of the mortar 
between the bricks.    You can edit these values to create a different pattern.



See also:

   Creating a PostScript line style  

   Creating a PostScript fill style  



Load Colors dialog box

This dialog box appears when you select Edit Colors from the Edit menu, then click on the Load button 
on the Edit Colors dialog box.

From this dialog box you can load a color palette.

File Name list box

Select the color palette you want to load by clicking on its filename in the File Name list box, or by 
entering the filename in the File Name box.

If necessary, use the scroll bar to display more files.

List Files of Type drop-down list box

As color palettes are all saved as .COL files, this is the only file format available.    All .COL files in the 
current directory are displayed in the File Name list box.

Directories list box

Displays all the directories in the path from the root to the current directory, and a list of all sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory.

Drives drop-down list box

Select a disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-down a list of 
all the disk drives available.

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.



See also:

   Edit Colors   dialog box  

   Loading a color palette  



Save Colors dialog box

This dialog box appears when you select Edit Colors from the Edit menu, then click on the Save button 
on the Edit Colors dialog box.

From this dialog box you can specify the disk drive, directory and filename in which to save a color 
palette.

File Name list box

Enter the filename in which you want to save your color palette.

Save File as Type drop-down list box

As color palettes are all saved as .COL files, this is the only file format available.    All .COL files in the 
current directory are displayed in the File Name list box but are disabled; when you click on OK, 
TurboDraw warns you if you try to overwrite an existing file. 

Directories list box

Lists all the directories in the path from the root to the current directory, and a list of all the sub-
directories contained in the current directory.    Click on any directory to select it; double-click to make it 
the current directory. 

Drives drop down list box

Select a disk drive.    Click on the arrow to the right-hand side of the Drives list box to drop-down a list of 
all the disk drives available.

If necessary, use the scroll bar to scroll through the list of drives and select the one you want.



See also:

   Edit Colors   dialog box  

   Saving a color palette  



Name Style dialog box

This dialog box appears when you click on the Name button in the Line Style or the Fill Style popup.

From this dialog box you can save a line or fill style with a name.

Name box

Enter a name for the new line or fill style.

When you save a picture, it is saved with the line and fill styles that have been named.    If you 
want to use these line and fill styles in other pictures, you must save them into a template.

You do not have to name a line or fill style.    However, if you do not name a style it will not be 
added to the list in the menu or popup and will not be saved as part of a template.



See also:

   Line Style   popup  

   Fill Style   popup  

   Creating a new line style  

   Creating a new fill style  



Edit Colors dialog box

This dialog box appears when you select Edit Colors from the Edit menu.

From this dialog box you can create new colors, edit existing colors, delete colors, save colors in a color 
palette and load an existing color palette.

This dialog box allows you to select several colors at once, which is useful when you want to delete 
more than one at a time.

Names list box

Displays the color palette for the active window.    Select the color that you want to edit or delete.    Spot 
colors are indicated by a dot next to their names.    The selected color appears in the preview box at the 
bottom of the dialog box.

If necessary, use the scroll bar to view more colors.

Sort by name/Sort by color buttons

Choose the order in which to sort the colors in the Names list box by clicking on your preferred option.

Color Bar group box

Tints of each color box: Specify the number of tints of each color you would like shown on the 
color bar.

Add button

Click on this button to display the New Color dialog box.    From this dialog box you can create a new 
color.

Edit button

Click on this button to display the Edit Color dialog box.    From this dialog box you can edit the color 
selected in the Names list box.

Delete button

Click on this button to delete the color(s) selected in the Names list box.    You cannot delete the color 
Black.

Load button

Click on this button to display the Load Colors dialog box.    From this dialog box you can load a saved 
palette.    This will be merged in with your existing colors.

Save button

Click on this button to display the Save Colors dialog box.    From this dialog box you can save the color 
palette for use with other pictures.



See also:

   Edit Color   dialog box  

   Creating a new color  

   New Color   dialog box  

   Deleting an existing color  

   Loading a color palette  

   Load Colors   dialog box  

   Saving a color palette  

   Save Colors   dialog box  



PANTONE Statement

PANTONE(R) Computer Video simulations displayed may not match PANTONE-identified solid 
color standards.    Use current PANTONE Color Reference Manuals for accurate color.    
"PANTONE Color Computer Graphics" (C) Pantone, Inc.1986,1991.

This message is to notify you that the PANTONE colors displayed on the TurboDraw screen may not 
exactly match the official PANTONE colors.    When using PANTONE for professional color printing, we 
recommend that you use a PANTONE Color Reference Manual to choose the color and quote its 
number to your professional printer when you brief them.    The color displayed in TurboDraw should 
only be taken as a guide to the final color, not an exact color match.



Line Style popup

This popup appears when you select Popup Lines from the Line menu.

From this popup you can apply a line style to selected objects, or create and name a new line style.    
Click on an area of the popup below to see a description of its function.

The Line Style popup is left open on the desktop and can be resized and positioned as you want.    To 
close the popup, click on its control-menu box.

The current line style will remain selected until you choose another one; any objects that you 
draw subsequently will be given this line style.



See also:

   Name Style   dialog box  

   PostScript Styles   dialog box  

   Applying line styles  

   Creating a new line style  



Named Style drop-down list box

Displays the named line styles available to the picture in the active window.    Click on a named style to 
apply it to a selected object, or select the style that you want to edit or base a new style on.



Name button

Click on this button to display the Name Style dialog box.    From this dialog box you can name a new 
line style, or rename an existing style that you have modified. 

For more information on the Name Style dialog box, refer to its Help.



Delete button

Click on this button to delete the line style currently selected in the Named Style drop-down list box.



Style drop-down list boxes

Set a separate style for the left end, body and right end of the line; click on the section you require to 
drop-down a list of available styles.    Each line end can have one of eleven styles, including different 
arrowheads.    The body can have one of eight styles, including custom and PostScript.

As you specify aspects of the line style, these three section boxes act as a preview box to display 
the line style you have set.



Width control

Drag the slider along the scale to alter the width of the line.    The width that you choose appears in units 
in the Width box: You can enter directly into this box to obtain a precise line width.



Width box

Displays the precise line width for the selected line style.    Edit the value in this box to change the line 
width precisely



Color palette and tint control

Click on the arrow to drop-down the color palette, then select the color that you want.    The currently 
selected color is marked by a frame.

Drag the slider along the tint selector to increase or decrease the density of color.    Hold down Ctrl while 
dragging the slider to change the tint by increments of 10%.    The tint that you choose appears in the 
Tint box as a percentage.



Ends drop-down list box

Click on the arrow to the right-hand side of the list box to drop-down a list of available end styles.    You 
can then choose the required end for the line style: Butt, round and square.

If you choose a dashed or dotted line style, the line end will apply to each dash or dot along the 
path.



Join drop-down list box

Click on the arrow to the right-hand side of the list box to drop-down a list of available join styles.    You 
can then choose the required join for the line style: Miter, round or bevel.



Do not Miter angles below box

Displays the minimum angle at which joins will be mitered when the selected join style is Miter.    Specify 
the angle that you want by entering it in the box.    Joins below this angle will be beveled instead of 
mitered.



Apply button

Click on this button to apply the current line style to any selected objects.    This line style is then the 
default style and is applied to any new objects that you draw.



<< button

Click on this button to reduce the Line Style popup.    When the popup is reduced, click on the >> button 
to expand it.



Dash and Gap boxes

These boxes are enabled only when you have selected Custom for the body of the line.    Use these 
boxes to specify the length of the dashes and gaps for your custom line style.



PostScript button

This button is enabled only when you have selected PostScript for the body of the line.    Click on this 
button to display the PostScript Styles dialog box from where you can select a PostScript line style.

For more information on the PostScript Styles dialog box, refer to its Help.



Overprint check box

This check box is only displayed when the page format has been set up for color separation.    Check 
this box to enable overprinting when producing color separations.



Fill Style popup

This popup appears when you select Popup Fills from the Fill menu.

From this popup you can apply a fill style to selected objects, or create and name a new fill style.    Click 
on an area of the popup below to see a description of its function.

The Fill Style popup is left open on the desktop and can be resized and positioned as you want.    To 
close the popup, click on its control-menu box.

The current fill style will remain selected until you choose another one; any objects that you draw 
subsequently will be given this fill style.



See also:

   Name Style   dialog box  

   PostScript Styles   dialog box  

   PostScript Halftone Screen   dialog box  

   Applying fill styles  

   Creating a new fill style  



Named Style drop-down list box

Displays the named fill styles available to the picture in the active window.    Click on a named style to 
apply it to a selected object, or select the style that you want to edit or base a new style on.



Name button

Click on this button to display the Name Style dialog box.    From this dialog box you can name a new fill 
style, or rename an existing style that you have modified.

For more information on the Name Style dialog box, refer to its Help.



Delete button

Click on this button to delete the fill style currently selected in the Named Style drop-down list box.



Style list box

Choose one of nine fill styles: None, plain, linear, logarithmic, cylindrical, radial, spherical, random or 
PostScript.



Preview box

Displays the fill style you have chosen.    If you have chosen a linear, logarithmic or cylindrical style, an 
arrow appears over the fill style in the preview box.    Drag this arrow to adjust the angle of the fill style.    
The angle is given in the angle box.

Press Ctrl while dragging the arrow to restrict the angle to multiples of 15 degrees.



Angle box

Displays the angle of rotation for the selected linear, logarithmic or cylindrical line style.    Edit the value 
in this box to give the fill style a precise rotation.



Color palette

Click on the arrow to drop-down the color palette, then select the color you want.    The currently 
selected color is marked by a frame.

Drag the slider along the tint selector to increase or decrease the density of color.    Hold down Ctrl while 
dragging the slider to change the tint by increments of 10%.    The tint that you choose appears in the 
Tint box as a percentage.



To Color palette

If you have selected a graduated fill style, a second color palette appears.    Click on the arrow to drop-
down the color palette, then select the "to color" you want.    The currently selected color is marked by a 
frame.    The color of the fill style will then fade from the other color to this color according to the selected 
graduation.

Drag the slider along the tint selector to increase or decrease the density of the "to color".    Hold down 
Ctrl while dragging the slider to change the tint by increments of 10%.    The tint that you choose 
appears in the Tint box as a percentage.



Apply button

Click on this button to apply the current fill style to any selected objects.    This fill style is then the default 
style and is applied to any new objects that you draw.



<< button

Click on this button to reduce the Fill Style popup.    When the popup is reduced click on the >> button 
to expand it.



PostScript button

This button is enabled only when you have selected a PostScript fill style.    Click on this button to 
display the PostScript Styles dialog box from where you can select a PostScript fill style.

For more information on the PostScript Styles dialog box, refer to its Help.



Halftone button

Click on this button to display the PostScript Halftone Screen dialog box from where you can set up a 
halftone fill style.    This button is disabled when you have selected a PostScript fill style. 

For more information on the Halftone Screen dialog box, refer to its Help.



Overprint check box

This check box is only displayed when the page format has been set up for color separation.    Check 
this box to enable overprinting when producing color separations.



IMSI Software
for Home and Small Business

Presidents Letter.-

IMSIs goal is to provide you with the highest quality software products at affordable prices.    Since 1983, 
millions of our award-winning products have been purchased throughout the world.    This catalog 
presents our most popular titles.    Most are Windows 95 compatible.    Some of these products are on 
the CD you have just purchased, and can be accessed by simply calling us!    Other products can be 
tried for FREE by downloading them from our Internet WEB site.    We invite you to try them and enjoy 
them.

Sincerely,

Martin Sacks, CEO and President

Instant Access to IMSI Products via CD Unlocking & Internet Downloading:

You may find several other IMSI software products on your CD!    These products can be unlocked by a 
simple phone call to us to purchase your special access code.    Check your CD today! Some IMSI 
software can also be downloaded for FREE on the Internet at http:\\www.imsisoft.com.

Two Special Offers to Our Customers!

A 25% discount off the retail price for any purchase directly from IMSI of any products in this catalog. 

And a FREE -MasterClips 1000 (award-winning color clip art - $19.95 value) with every order!

Where to Find Information 

Internet WEB Site http:\\www.imsisoft.com

CompuServe GO IMSI, GO TURBOCAD, GO FORMTOOL

FAX INFO 415-257-3000 ext. 4

Technical support 415-257-3000 ext. 3
support@imsisoft.com

Sales Orders 800-833-8082 

FAX 415-257-3565

Bulletin Board 415-257-8468 N-8-1

GST Technology Ltd is a worldwide software developer at the leading edge of user interface design for 
desktop publishing and graphics technology under Windows.    GST is the author of TurboDraw, 
developed specifically for IMSI and licensed to them.

GST has a range of other products in the desktop publishing and graphics fields sold worldwide by a 
variety of licensees.

GST contacts are:

Europe

GST Technology Ltd, Meadow Lane, St. Ives, Huntingdon, Cambridgeshire, PE17 4LG, UK.
Telephone: +44 (0)1480 496789
Fax: +44 (0)1480 496189
Email: postmaster@gst-soft.demon.co.uk

USA

GST USA representative office, PO Box 5224, Englewood, CO 80155-5224, USA.
Telephone: +001 (303) 680 9121



Fax: +001 (303) 680 5611

Copyright © 1995 GST Technology Limited.





Stop Press!

Please read the following information carefully because it is not provided elsewhere in the TurboDraw 
documentation.

   ATM and TrueType  

   Bitmap and vector graphics  

   Imports and exports  

   Printing  



ATM and TrueType

The fonts that are supplied with TurboDraw are TrueType fonts, but TurboDraw can also use ATM fonts. 
However, if you have the same font installed in both ATM format and TrueType format, you should 
remove the ATM version of the font to ensure you obtain the best possible performance from 
TurboDraw.

To remove ATM fonts from your setup:

1. In the ATM Control Panel, select the fonts you want to remove.

2. Click on the Remove button.    A message appears for each selected font asking you to confirm 
that you want to remove the font.

3. Click on Yes to remove the font. 

4. To remove the remaining fonts without confirming each one, check the No confirmation to 
remove fonts box.

5. When all the fonts have been removed, click on the Exit button to close the ATM Control Panel, 
then exit Windows.

When you restart Windows the new ATM settings will take effect.



Bitmap and vector graphics

There are many different graphics packages currently available for the PC: Art packages, illustration 
packages, painting packages, drawing packages, design packages and many more. These packages 
handle graphics in different ways. One of the main distinctions between them is how they create and 
manipulate graphics.

There are currently two types of graphics you should be aware of: Bitmap and vector.

Most graphics-handling programs are optimized towards one of these two types. Programs that draw 
are normally best at handling vector graphics, while programs that paint prefer bitmap graphics. 
TurboDraw is optimized towards vector-based graphics, although it can also handle bitmapped graphics.

Bitmaps are simpler than vector graphics, but are much less flexible and generally of poorer quality.

Your screen display

To understand the difference between bitmaps and vector graphics, you need to understand how your 
computer screen display an image.

Your screen display is made up of thousands of tiny dots called pixels. An image is generated by 
coloring or filling in these pixels. The more pixels your display contains, the more detail it can show. The 
amount of detail your display can show is usually called the resolution.

Bitmapped images

Bitmapped images are created by filling individual pixels with color. The location and color of every pixel 
is recorded as a unique item or 'bit' of information in a 'bit mapped' graphics file.

If you reduce the size of a bitmap image on your screen, your PC will try to squeeze the bitmap into the 
smaller area by ignoring some of the pixels. The smaller image will consequently lose its crispness, and 
the overall appearance will probably not be as good.

You get a similar effect if you display bitmaps generated at low resolution on screens with a higher 
resolution.

However, there are various programs that allow you to tidy up or edit bitmaps, such as Microsoft 
Paintbrush, which is supplied with Windows.

Vector-based graphics

A vector is a path between two points. It has certain properties, such as length, shape and thickness. A 
vector-based graphics file - which may contain hundreds of vector paths - tells your PC exactly how to 
plot and draw each path individually.

The PC recalculates and redraws each path individually whenever you enlarge, reduce or otherwise 
manipulate the graphic. This means that the properties of each path are maintained however you 
manipulate the image, or whatever resolution of screen you are using.



Imports and exports

This section provides information about the import and export formats that are supported by TurboDraw.

Imports

Adobe Illustrator (.ai, eps)
This import format is for reading clipart files saved in the Adobe Illustrator format. It can handle graphics, 
but any text in the file is ignored.

CGM Metafile (.cgm)
This import format is for reading clipart files saved in the 'Computer Graphics Metafile' (CGM) format, 
based on ISO 8632. Text font information is not preserved.

EPSF PostScript (.eps)
When you import an EPSF file, it is kept internally by the program in EPSF format. EPSF files can only 
be printed properly on a PostScript printer.

GEM Image (.img)
This import format is for bitmaps saved from GEM programs. It can handle black-and-white images and 
16-colour images, provided they do not exceed 64k bytes in size.

GEM Metafile (.gem)
There are various different versions of this standard (relating to different versions of GEM), but this 
import format can handle them all. Text font information is not preserved.

GIF Bitmap (.gif)
This import format is for reading bitmap files saved in all formats of GIF (GIF 87a, 89a and GIFLITE both 
interlaced and non-interlaced). It can handle images up to 256-colours.    When importing a multiple 
image in GIF format, only the first image will be imported.

JPEG Bitmap (.jpg)
This import format is for reading bitmap files saved in JFIF formats of JPEG. It can handle gray scale 
and 24-bit images.

PC Paintbrush (.pcx)
This import format can handle black-and-white, 8-color, 16-color, 256-color and 24-bit files.

Targa Bitmap (.tga)
This import format can handle all formats of Targa files. It can handle 8-bit, 16-bit, 24-bit and 32-bit 
compressed and uncompressed files.

Tiff Bitmap (.tif)
This import format can handle black-and-white, gray scale, palette-color, and 24-bit rgb files.    It can 
accept files using the 'packbits', 'ccitt' and LZW compression.

Tiff part of EPS file (.eps)
Some EPSF postscript files include a TIFF version of the picture, this import format allows you to read 
that part of the file. 

Windows Bitmap (.bmp)
This import format can read black-and-white, 16-color, 256-color, and 24-bit rgb files.

Windows Metafile
Text font information is not preserved.



Exports

Bitmap Formats
When exporting to a bitmap format, the results should match the original picture accurately. If you 
choose to export 'selected objects only' then the bitmap will be just big enough for those objects. If you 
do not, it will enclose the whole page. Remember that the higher the resolution you select, the larger the 
file produced. A Letter page in black-and-white at 300dpi will take up about 1 megabyte of disk space.

Line-Art formats
TurboDraw has some features that are not supported by many line-art file formats. Most cannot 
represent graduated fills, thick dotted lines, custom line styles, patterns, or objects that have been 
pasted inside other objects.

CGM Metafile (.cgm)
No graduated fills. No thick, dotted lines. No custom line styles.    No patterns,    No objects that have 
been pasted inside other objects.    Bezier curves are converted into sequences of straight lines.

EPSF PostScript (.eps)
Everything except 'Random Fill' is supported.

GEM Artline 1.0 (.gem)
No graduated fills. No thick, dotted lines. No custom line styles. No patterns,    No objects that have been 
pasted inside other objects.    Bezier curves are represented as curves in this format.

GEM Artline 2.0 (.gem)
Linear and Radial graduated fills are supported.    No thick, dotted lines. No custom line styles. No 
patterns,    No objects that have been pasted inside other objects.    Bezier curves are represented as 
curves in this format.

GEM Draw (.gem)
No graduated fills. No thick, dotted lines. No custom line styles. No patterns,    No objects that have been 
pasted inside other objects.    Bezier curves are converted into sequences of straight lines.

GEM Image (.img)
Black-and-white and 16-colour files only.

GIF Bitmap (.gif)
Black-and-white, 16-colour and 256-colour files only.

PC Paintbrush (.pcx)
Black-and-white, 16-colour and 256-colour files only. 

Targa Bitmap (.tga)
256-colour files only.

Tiff Bitmap (.tif)
Black-and-white, 16-colour and 256-colour files only.

Windows Bitmap (.bmp)
Black-and-white, 16-colour and 256-colour files only.

Windows Metafile
This format does not actually support graduated fills, but they are simulated by the export code, and 
should work in most cases. No patterns,    No objects that have been pasted inside other objects.    
Bezier curves are converted into sequences of straight lines. Bitmaps are not preserved.



Printing

Microsoft Windows Printing System

This printer driver does not support ATM fonts. If you want to print TurboDraw pictures using ATM fonts, 
you must first ungroup the text into a path.

PostScript Printers

The program has been tested with the normal Windows driver for PostScript (v3.5). The 'random' pattern 
fill prints as plain gray: Use the special PostScript textures if required. 

If you are printing to a PostScript printer which does not have the usual set of built-in fonts, you may 
need to modify the TDRAW.INI file to make some fonts work properly. We assume that PostScript 
printers have the following fonts:    Courier, Times, Helvetica, Avant Garde, Bookman, Century 
Schoolbook, Helvetica Narrow, Palatino, Symbols, Zapf Chancery and Zapf Dingbats.

If your PostScript printer does not contain one or more of these fonts, you can make TurboDraw print the 
fonts correctly by removing the corresponding line from TDRAW.INI. The program will then download the 
font to the printer, rather than assume that the font is built-in.

For example, if your printer does not have Helvetica Narrow, open your TDRAW.INI file and delete or 
comment out the line in the [PSfonts] section referring to that font (insert a semicolon at the start of the 
line to comment out the line):

[PSfonts]
; Sans Narrow=Helvetica-Narrow,,-Bold,-Oblique,-BoldOblique

Note that because TurboDraw downloads fonts to the printer, a job containing many different fonts may 
take a long time to print, or even exhaust the printer's memory. We suggest you avoid including many 
different fonts in a job printed on a PostScript printer.

General notes for other printers

If you do not get good results with the printer driver supplied with your printer, you may find that one of 
the standard drivers supplied by Windows would work better - for example most 24-pin dot matrix 
printers can be driven using the standard Epson 24-pin (LQ-compatible) driver.





Message Box

 A Fill style with this name already exists.    Do you want to overwrite it?

You have tried to save a fill style with a name that youve already used.    If you do not want to overwrite 
the existing file, click on No then enter a different name on the Name Style dialog box.    If you do want 
to overwrite the existing file, click on Yes; any objects filled with the original style will now be filled with 
the new fill style.



Message Box

A Line style with this name already exists. Do you want to overwrite it?

You have tried to save a line style with a name that youve already used.    If you do not want to overwrite 
the existing line style, click on No then enter a different name on the Name Style dialog box.    If you do 
want to overwrite the existing line style, click on Yes; any objects drawn with the original style will now 
be drawn with the new line style.



Message Box

Abandon Printout?

Your picture has not yet finished printing - do you really want to abandon it? Click on No to let printing 
resume.    Click on Yes to abandon printing.



Message Box

Bitmap too complex for Autotrace

TurboDraw has run out of memory while trying to trace a path over the bitmap you are autotracing.    Try 
to free more memory for TurboDraw then autotrace the bitmap again.    If you still get this message, try 
any of the following:

Autotracing the bitmap in sections

Increasing the smoothness of the autotrace tool to make the traced path less detailed (double-
click    on the Autotrace tool to display the Autotrace dialog box)

Tracing the bitmap manually using the drawing tools.



Message Box

Cannot Align: No objects selected

You have not selected any objects so there are no objects to align.    Select the objects you want to align 
then try using the Align command again.    Bear in mind that if one of the selected objects is locked, it 
will not move; instead the other objects will align to it.



Message Box

Cannot Copy: No unlocked objects selected

You havent selected any objects to copy, or the objects that you have selected are locked.    Either select 
the objects you want to copy, or unlock the objects that you have already selected.    Then try the Copy 
command again.



Message Box

Cannot create Printer Device Context!

TurboDraw has tried to print your picture but couldnt.    This could be for several reasons:

You do not have a printer selected

You have too many files open in TurboDraw or Windows so there is not enough memory for 
TurboDraw to print the picture

Your Windows system resources are running low so there is not enough memory for TurboDraw 
to print the picture

Your printer driver is causing the error

There are several measures you can take to try to fix this problem.    Start with the first suggestion then if 
it doesnt fix the problem, work your way through the other suggestions:

Set up your printer again using the Print Setup command in the TurboDraw File menu

Close TurboDraw then restart it and try printing the picture again

Close TurboDraw and Windows, the restart them and try printing the picture again

Try printing another Windows application such as Write.    If that doesnt work the problem lies in 
your printer driver, not TurboDraw.    Try reinstalling your printer driver.    If the problem persists, contact 
your printer manufacturer for assistance



Message Box

Cannot Cut: No unlocked objects selected

You havent selected any objects to cut, or the objects that you have selected are locked.    Either select 
the objects that you want to cut, or unlock the objects that you have already selected.    Then try the Cut 
command again.



Message Box

Cannot Group: No objects selected

You havent selected any objects to group, or the objects that you have selected are locked.    Either 
select the objects you want to group, or unlock the objects that you have already selected.    Then try the 
Group command again.



Message Box

Cannot Join: Select two nearby path ends, or path and text

This message can be displayed for several reasons:

The end points on the path that you are trying to join are not close enough together.    Either move 
the points closer together or adjust the Join Range setting on the General tab of the Preferences dialog 
box so that they are within the range for being joined.

You do not have any end points on the paths selected.    Except when joining text to a path, you 
must select an end point on each path that you want to join; the two points will be replaced with one point, 
joining the paths together.

You have tried to join more than two paths together.    In this case make sure you only have two 
paths selected then try the Join command again.

The objects you have tried to join are not open paths, e.g. they may be shapes that havent been 
ungrouped.    In this case, select each object and click on the Ungroup button to ensure that each object 
is an open path, not a shape. If one of the objects is text, do not ungroup it.    Now try the Join 
command again.



Message Box

Cannot Lock or Unlock: No objects selected

You havent selected any objects to be locked or unlocked.    Select some objects then try again.



Message Box

Cannot Move To Back: No unlocked objects selected

You havent selected any objects to move to the back, or the objects that you have selected are locked. 
Either select the objects that you want to move, or unlock the objects that you have already selected.    
Then try the Send To Back command again.



Message Box

Cannot Move To Front: No unlocked objects selected

You havent selected any objects to move to the front, or the objects that you have selected are locked.    
Either select the objects that you want to move or unlock the objects that you have already selected.    
Then try the Bring To Front command again.



Message Box

Cannot Paste: Nothing on clipboard to paste

Theres nothing on the clipboard for TurboDraw to paste into the picture.    Either you havent yet cut or 
copied anything to the clipboard, so theres nothing for TurboDraw to paste.    Or maybe you deleted an 
object instead of cutting it; deleted objects cannot be pasted back into the picture.

Alternatively, TurboDraw may not be able to interpret the item on the clipboard.



Message Box

Cannot perform Print Setup. Check that a printer is selected in the Windows Control Panel.

TurboDraw has been unable to find a printer in your Windows setup.    Using the Windows Control 
Panel, check that you have installed at least one printer and that one is setup as the default printer.    
When you have setup a default printer, try selecting the Print Setup command again.



Message Box

Cannot read FILENAME!

This message occurs when TurboDraw cannot find one of its program files.    The file might have been 
deleted after you installed TurboDraw or the installation was not completed successfully.    To overcome 
this problem, reinstall the TurboDraw program.



Message Box

Cannot Redo: There is nothing to redo.

You have not yet done a command that can be redone.    Commands that cannot be undone or redone 
include file operations, changing view size, selecting tools, moving the floating toolbox and toolbars, and 
moving between picture windows.



Message Box

Cannot Show Object Properties: No objects selected

You have not selected an object so TurboDraw cannot display the relevant object properties dialog box. 
Select the object that you want information about, then try the Properties command again.



Message Box

Cannot Split: Select text on a path or the point at which to split path

This message can appear for a couple of reasons

You have selected a path but not the point at which you want to split the path.    Select the point 
on the path and then try the Split command again.

The object that you are trying to split is not a path.    It maybe a shape that has not yet been 
ungrouped into a path.    Ungroup the object and select at least one point on it, then try the Split 
command again.



Message Box

Cannot Transform Again: No transformation to repeat

You have not yet carried out a transform command (rotating, reflecting, skewing, scaling or moving) so 
there is no transformation for TurboDraw to repeat.    When you have transformed an object, try the 
Transform Again command again.



Message Box

Cannot Undo: There is nothing to undo.

You have not yet carried out a command that can be undone.    Commands that cannot be undone or 
redone include file operations, changing view size, selecting tools, moving the floating toolbox and 
toolbars, and moving between picture windows.



Message Box

Cannot Ungroup: Select an unlocked group or shape to ungroup

This message can appear for several reasons:

You havent selected any objects to ungroup, or the objects that you have selected are locked.    
Either select the objects that you want to ungroup, or unlock the objects that you have selected.    Then try 
the Ungroup command again.

The object that you have selected is already ungrouped.

The object cannot be ungrouped, e.g. bitmap images or EPSF files.



Message Box

CommDlg error code

This message may occur if your computer system is very short of memory or other system resources 
when you try to open or save a file.

Your copy of the file COMMDLG.DLL is out of date.    You have probably installed some software after 
TurboDraw and it has copied an old version of COMMDLG.DLL into your \WINDOWS\SYSTEM 
directory.    Install the TurboDraw program again to copy the latest file back onto your Windows setup.    
Also, check that there isnt a version of COMMDLG.DLL in your \WINDOWS directory or elsewhere in 
your search path - if there is, delete it.



Message Box

Error - unable to ... create window/undo command/redo command

There is not enough memory for TurboDraw to carry out your command.    Free some memory then try 
again.

Error - unable to execute command.

This message can appear for three reasons:

You have tried to open a faulty file.

There is not enough memory for TurboDraw to carry out your command.    Free some memory 
then try again.

There is a problem with the TurboDraw program.    If the message persists, contact IMSI 
Technical Support noting precisely what it is you do that causes the message to appear.



Message Box

Error code NNN

This message can occur for two reasons:

There is not enough memory for TurboDraw to carry out your command.    Free some memory 
then try again.

There is a problem with the TurboDraw program.    If the message persists, note precisely what 
you do before the message appears and the error number displayed on the message, then contact IMSI 
Technical Support.



Message Box

Error during registration: File FILENAME not found. Check installation.

Some files are missing from your TurboDraw installation.    TurboDraw may be able to run without them, 
but you will not be able to use TurboDraw OLE features or run any of its PagePilots.    We recommend 
that you reinstall the TurboDraw program to ensure that the files are installed and TurboDraw can run 
properly.



Message Box

Error: This file needs a more up-to-date version of the program!

The picture you are trying to open was created in a later version of TurboDraw and cannot be opened in 
this version.    Either upgrade your copy of TurboDraw or work on the picture using the copy of 
TurboDraw in which it was created.

For upgrade details, contact IMSI Technical Support.



Message Box

Error: Too many objects to cut or copy

The objects you have selected are too large.    Select fewer objects then try the cut or copy command 
again.



 Message Box

Error: Unable to print

This message can occur for a number of reasons.    Use the checklist below to work out what is going 
wrong:

Is the printer plugged in, switched on and on-line?

Is the correct printer selected on the Print Setup dialog box? Are the settings correct? For 
example, have you chosen a paper source that has paper in it?

Is the printer jammed, or do you need to add paper?

Is the printer active? (Check this using the Windows Print Manager.)

Is the printer correctly set up on the Windows Control Panel?

Is the printer capable of printing graphics?

Do you have the correct cable for your printer and is it properly connected to your computer?

Is the ribbon correctly threaded (if your printer uses one) or do you need to change it? Do you 
need to change the ink cartridge?

Are your system resources running low? Have you got loads of files and programs open? If 
necessary, close Windows, restart TurboDraw, and then try printing again.

If you complete this checklist and still cant print anything, quit TurboDraw and try to print a text file from 
Notepad or Write in the Windows Accessories program group.    If this prints correctly, contact IMSI 
Technical Support; it may be that TurboDraw is having difficulty printing to that particular printer.    
However, if you cant print from Notepad or Write the problem may lie in the printer, cable or your 
Windows setup.    Try connecting the printer again, and if that doesnt help, contact your printer 
manufacturer or dealer.



Message Box

File FILENAME is the wrong version - please check your installation

The filename specified is out of date.    Somehow, an old .ART file has replaced the latest version of the 
same file.    To correct this, reinstall the TurboDraw program to ensure that you are using the latest 
version.



Message Box

Incorrect File Type!

You have tried to import a file but you have selected the wrong file format on the Import From File 
dialog box.    Import the file again selecting All Files from the List Files of Type on the Import from File 
dialog box.    If this message appears again, then the file may have been saved with a misleading 
filename extension, e.g. it may be a .BMP file but have the extension *.TIF.    Make sure that the 
filename extension reflects the true format of the file then import it again.



Message Box

No default printer selected. Use the Windows Control Panel to select a printer. Until you select a 
printer, text will be formatted using the screen only.

This message appears if you do not have a default printer set up in Windows.    Use the Windows 
Control Panel to set up a default printer.    Until you set up a default printer, you will not be able to see 
the page box indicating the printable area of the page in TurboDraw and if you are using a PostScript 
printer you will not be able to select options for printing color separations.    Also, you will not be able to 
print from TurboDraw until you have set up a default printer.



Message Box

Not enough disk space to print

When TurboDraw prints a picture, it creates temporary files on your hard disk.    These temporary files 
are created on the disk pointed to by the SET TEMP command in your AUTOEXEC.BAT file.    At the 
moment there is not enough free space for these temporary files.

If your SET TEMP command points to a RAM disk, we recommend that you change the SET TEMP 
command to point to an area on your hard disk.    If your SET TEMP command already points to an area 
on your hard disk, clear some disk space and try to print again.    (For details of how to edit your 
AUTOEXEC.BAT file, refer to your DOS manual.)

Bear in mind that the more complicated your picture (e.g. the more fonts and clipart in it), the more disk 
space TurboDraw will need to print it.



Message Box

Not enough memory for freehand/trace

There is not enough memory for TurboDraw to carry out your command.    Free some memory then try 
again.



Message Box

Not enough memory to ... create window/execute command/undo command/redo command.

There is not enough memory for TurboDraw to carry out your command.    Free some memory then try 
again.



Message Box

Not enough memory to perform Blend

There is not enough memory to carry out your command.    Free some memory then try again.



Message Box

Not enough memory to print

There is not enough memory to carry out your command.    Free some memory then try again.



Message Box

Note - file FILENAME is read only

The file you are opening is read-only.    If you make any changes to it, they cannot be saved under the 
same filename.

The file may be read-only because it is on a network or because you have set it to read-only by mistake. 
If you have the appropriate rights to the file, you can change it from being read-only by using Windows 
File Manager (using the Properties command in the File menu).



Message Box

Object Too Complex

You have tried to import a line-art file (metafile) that is too complicated for TurboDraw to handle.    You 
will not be able to import this file into TurboDraw.



Message Box

OLE libraries are out of date

Some of the TurboDraw program files are out of date.    Install the TurboDraw program again to ensure 
that you have the appropriate versions of these files.



Message Box

Only Paths and Shapes can be Blended

The objects you are trying to blend are not paths or shapes.    If you are trying to blend an imported file, 
you must ungroup it into paths first then select the two paths that you want to blend.



Message Box

Only Paths with more than one point can be Blended

You are trying to blend a path of one point with another path or shape.    A single point cannot be 
blended with another path or shape.    Either select a different path, or join more points to the single 
point before trying the Blend command again.



Message Box

Only the first 500 fonts will be used

You have over 500 fonts in your Windows setup but TurboDraw will only use the first 500.    If there are 
some fonts that you cannot see, remove some other ones so that they become available.    Use the ATM 
Control Panel to remove ATM fonts and the Windows Control Panel to remove TrueType fonts.



Message Box

Replacing font <name1> with <name2>

This message appears when you open a picture that used fonts which are currently not available on 
your setup.    The message shows you which font on your setup is being used to replace each font 
originally in the picture.    When you save the picture, the current fonts will be saved in it, replacing the 
original fonts.



Message Box

Resolution must be between 10 and 1000 dpi

You must set a resolution value between 10 and 1000 when exporting bitmaps from TurboDraw.    Try 
again with an appropriate value.



Message Box

Save clipboard?

You have copied something onto the clipboard.    Do you want to save it before closing the current 
picture? If you choose to save the contents of the clipboard, you will be able to paste it back into a 
picture when you next run TurboDraw or into another application.



Message Box

Spot colors must be named

You must name any spot colors so that you can select them when printing color separations.



Message Box

There is already a fill style FILL NAME

This message appears when you create a fill style and try to give it a name youve already used for 
another fill style.    Try again with a different name.



Message Box

There is too much text on the clipboard to paste.

You are trying to paste too much text into TurboDraw at once.    Try again by breaking down the text into 
several sections then copying each section to the clipboard in turn and pasting it into TurboDraw one at 
a time.



Message Box

This color already exists in the palette.

This message can appear in two instances:

You have already created an unnamed color with the same RGB value as another unnamed color 
already in the palette, i.e. the color already exists but is unnamed.

From the Edit Colors dialog box, you have chosen to Add a color then entered a name that 
already exists.    Try again with a different name.

Click on OK to overwrite the existing color, or click on Cancel to give the new color a different name.



Message Box

This file was created using one or more fonts which are not currently installed. Substitute fonts 
will be used. If you save the file, these substitutions will be made permanent.

The picture you are opening was created using fonts that are not currently available on your setup.    
TurboDraw will substitute the unavailable fonts with the closest match it can find.    If you save the 
picture, the original fonts will be permanently replaced by the matching fonts available on your setup.



 Message box

This line style must be given a name

Enter a name for the line style you have created before clicking OK.



Message Box

This name is too long - truncate to xxx?

The name you have entered for the line style, fill style or color is too long.    TurboDraw will truncate it if 
you click on Yes; or you can enter a different name if you click on No.



Message Box

This program may only be used by one network user at any one time

TurboDraw can only be run by one user at a time when it is installed on a network - another user is 
currently running TurboDraw, so you cannot run another copy.    Contact your network supervisor if you 
need to run TurboDraw urgently.



Message Box

Too many people are already running TurboDraw on the network - contact network supervisor

TurboDraw can only be run by one user at a time when it is installed on a network - another user is 
currently running TurboDraw, so you cannot run another copy. Contact your network supervisor if you 
need to run TurboDraw urgently.



Message Box

Unable to create dialog box

There is not enough memory for TurboDraw to carry out your command.    Free some then try again.

If the message persists, restart Windows and TurboDraw.



Message Box

Unable to create main window

There is not enough memory for TurboDraw to carry out your command.    Free some memory then try 
again.



Message Box

Unable to create toolbars - please check your installation

Either your installation of TurboDraw has been unsuccessful, or some component has been erased or 
corrupted.    Install the TurboDraw program again.



Message Box

Unable to find a match for font <name1>:using <name2> as a replacement.

TurboDraw has been unable to find a similar font on your setup to replace that originally used in the 
picture.    Another font will be used that may not be a good match for the original.    When the picture is 
open you can change the fonts yourself.



Message Box

Unable to find fonts - please check your installation

TurboDraw has been unable to find any fonts on your setup.    Check that you havent turned off both 
your TrueType and ATM fonts.    If they are enabled, run the TurboDraw installation again and choose 
the initial fonts.



Message Box

Unable to find import libraries - please check your installation

Either your installation of TurboDraw has been unsuccessful, or some component has been erased or 
corrupted.    Install the TurboDraw program again.



Message Box

Unable to import file FILENAME: Unknown or ambiguous file type

When importing the file, you have selected the wrong file format on the Import From File dialog box.    
Import the file again, choosing the true file format from the List Files of Type box on the Import from 
File dialog box.



Message Box

Unable to load Automation Type Library: Check Installation

Either your installation of TurboDraw has been unsuccessful, or some component of it has been erased 
or corrupted.    Install the TurboDraw program again.



Message Box

Unable to lock file FILENAME - file in use

The file you are trying to open is already being used by another user.    Try again later.



Message Box

Unable to open file

An error has occurred when trying to read TurboDraw from the network.    Install TurboDraw again and 
inform your network administrator of this error.



Message Box

Unable to open FILENAME, because it is already being used by another program or user

The file you are trying to open is already being used by another user.    Try again later.



Message box

Unable to open more than 8 windows for a single file

You cannot open more than eight windows on a picture.    Close any that you dont need so that you can 
then open another one.



Message Box

Unable to run because SHARE is not installed. Include the line SHARE /L:500 /F:5100 in your 
AUTOEXEC.BAT field. Refer to your DOS manual for more information.

TurboDraw cannot run properly unless SHARE.EXE is set up on your PC.    SHARE.EXE is supplied 
with DOS.    For full details of how to check if SHARE.EXE is installed on your PC and how to set it up in 
your AUTOEXEC.BAT file, read the README file that gets installed with TurboDraw in the IMSI program 
group.



Message Box

Warning: This file is in an out-of-date format (but it should work!)

The picture you are opening was created in an earlier version of TurboDraw but it should work in this 
version.    For safety, save it under a different filename so that you have the original file to go back to if 
necessary.



Message Box

You should select at least one color to be printed.

You have chosen to print spot colors but you havent selected any of the spot colors for printing.    
Choose the spot colors that you want to print then try again.



Message Box

You must give this fill style a name

Enter a name for the fill style you have created before clicking OK.



Freeing Memory

In many instances, TurboDraw displays an error message because there is not enough memory to carry 
out your command.    There are several things you can do to free up more memory:

Close any unnecessary picture windows

Close any unnecessary applications

Remove any unnecessary fonts from your Windows setup

Close and restart Windows

If you are using ATM, reduce the size of its font cache

Increase the amount of virtual memory using the Windows Control Panel

If you regularly experience memory problems, you should consider adding more memory to your 
computer.    The more memory your computer has, the better your applications will perform.    Contact 
your computer dealer for details of upgrading your memory.



Message Box

Are you sure you want to remove this template from the list?

You have chosen to remove the selected templates from the list of templates available.    Do you really 
want to remove it from the list? Clicking on Yes will remove the template from the list but will not delete 
the actual template from the disk, so you could add it again later.



Message Box

There is already a line style LINE NAME

This message appears when you create a line style and try to give it a name youve already used for 
another line.    Try again with a different name.



Message Box

Cannot set Text Spacing: No unlocked text objects selected.

The text object whose spacing you are trying to adjust is locked.    Unlock it and try again.



Message Box

Cannot run Keypad: KEYPAD.EXE not found.

The Keypad program cannot be found on your system.    Check that the installation is complete.

If you have not installed Keypad, run the TurboDraw install program again and choose to install 
Keypad.

If Keypad is already installed, re-install it to ensure that the installation is complete and has not 
become corrupted.



Message Box

Cannot run SnapShot: SNAPSHOT.EXE not found.

The SnapShot program cannot be found on your system.    Check that the installation is complete.

If you have not installed SnapShot, run the TurboDraw install program again and choose to install 
SnapShot.

If SnapShot is already installed, re-install it to ensure that the installation is complete and has not 
become corrupted.



Message Box

Save changes in FILENAME?

You have tried to quit TurboDraw or close a drawing without saving the changes you have made.

To save the changes

Click on Yes.

To discard the changes

Click on No.

To continue without quitting TurboDraw or saving the changes

Click on Cancel.



Message Box

Are you sure you want to remove this page size from the list?

You have selected a custom page size in the Start A New Picture tab of the New Picture Options 
dialog box, and then clicked on the Delete button to remove the custom page size from the list.

To remove the page from the list

Click on Yes.

To leave the page in the list

Click on No.



Message Box

Cannot Align Objects Left: Select two or more objects to align

In order to use the Align Objects Left tool, you need to have two or more objects selected.      Select the 
objects you want to align then try using the Align Objects Left tool again.    Bear in mind that if one of 
the selected objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the left of the page, use the Align To Page Left tool instead.



Message Box

Cannot Align Objects Center: Select two or more objects to align

In order to use the Align Objects Center tool, you need to have two or more objects selected.    Select 
the objects you want to align then try using the Align Objects Center tool again.    Bear in mind that if 
one of the selected objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the center of the page, use the Align To Page Center tool 
instead.



Message Box

Cannot Align Objects Right: Select two or more objects to align

In order to use the Align Objects Right tool, you need to have two or more objects selected.    Select 
the objects you want to align then try using the Align Objects Right tool again.    Bear in mind that if 
one of the selected objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the right of the page, use the Align To Page Right tool instead.



Message Box

Cannot Align Objects Top: Select two or more objects to align

In order to use the Align Objects Top tool, you need to have two or more objects selected.    Select the 
objects you want to align then try using the Align Objects Top tool again.    Bear in mind that if one of 
the selected objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the top of the page, use the Align To Page Top tool instead.



Message Box

Cannot Align Objects Middle: Select two or more objects to align

In order to use the Align Objects Middle tool, you need to have two or more objects selected.    Select 
the objects you want to align then try using the Align Objects Middle tool again.    Bear in mind that if 
one of the selected objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the middle of the page, use the Align To Page Middle tool 
instead.



Message Box

Cannot Align Objects Bottom: Select two or more objects to align

In order to use the Align Objects Bottom tool, you need to have two or more objects selected.    Select 
the objects you want to align then try using the Align Objects Bottom tool again.    Bear in mind that if 
one of the selected objects is locked, it will not move; instead the other objects will align to it.

If you want to align an object to the bottom of the page, use the Align To Page Bottom tool 
instead.



Message Box

Cannot Align To Page Left: No unlocked objects selected

You havent selected any objects to align, or the objects that you have selected are locked.    Either 
select the objects you want to align, or unlock the objects that you have already selected.    Then try to 
align them again.



Message Box

Cannot Align To Page Center: No unlocked objects selected

You havent selected any objects to align, or the objects that you have selected are locked.    Either 
select the objects you want to align, or unlock the objects that you have already selected.    Then try to 
align them again.



Message Box

Cannot Align To Page Right: No unlocked objects selected

You havent selected any objects to align, or the objects that you have selected are locked.    Either 
select the objects you want to align, or unlock the objects that you have already selected.    Then try to 
align them again.



Message Box

Cannot Align To Page Top: No unlocked objects selected

You havent selected any objects to align, or the objects that you have selected are locked.    Either 
select the objects you want to align, or unlock the objects that you have already selected.    Then try to 
align them again.



Message Box

Cannot Align To Page Middle: No unlocked objects selected

You havent selected any objects to align, or the objects that you have selected are locked.    Either 
select the objects you want to align, or unlock the objects that you have already selected.    Then try to 
align them again.



Message Box

Cannot Align To Page Bottom: No unlocked objects selected

You havent selected any objects to align, or the objects that you have selected are locked.    Either 
select the objects you want to align, or unlock the objects that you have already selected.    Then try to 
align them again.



Message Box

Cannot Reflect Horizontally: No unlocked objects selected

You havent selected any objects to reflect, or the objects that you have selected are locked.    Either 
select the objects you want to reflect, or unlock the objects that you have already selected.    Then try to 
reflect them again.



Message Box

Cannot Reflect Vertically: No unlocked objects selected

You havent selected any objects to reflect, or the objects that you have selected are locked.    Either 
select the objects you want to reflect, or unlock the objects that you have already selected.    Then try to 
reflect them again.



Message Box

Cannot Rotate 45 Degrees Left: No unlocked objects selected

You havent selected any objects to rotate, or the objects that you have selected are locked.    Either 
select the objects you want to rotate, or unlock the objects that you have already selected.    Then try to 
rotate them again.



Message Box

Cannot Rotate 45 Degrees Right: No unlocked objects selected

You havent selected any objects to rotate, or the objects that you have selected are locked.    Either 
select the objects you want to rotate, or unlock the objects that you have already selected.    Then try to 
rotate them again.



Message Box

Cannot Rotate 90 Degrees Left: No unlocked objects selected

You havent selected any objects to rotate, or the objects that you have selected are locked.    Either 
select the objects you want to rotate, or unlock the objects that you have already selected.    Then try to 
rotate them again.



Message Box

Cannot Rotate 90 Degrees Right: No unlocked objects selected

You havent selected any objects to rotate, or the objects that you have selected are locked.    Either 
select the objects you want to rotate, or unlock the objects that you have already selected.    Then try to 
rotate them again.



Message Box

Cannot Rotate 180 Degrees: No unlocked objects selected

You havent selected any objects to rotate, or the objects that you have selected are locked.    Either 
select the objects you want to rotate, or unlock the objects that you have already selected.    Then try to 
rotate them again.



Message Box

Cannot Double Size: No unlocked objects selected

You havent selected any objects to double in size, or the objects that you have selected are locked.    
Either select the objects whose size you want to double, or unlock the objects that you have already 
selected.    Then try to double their size again.



Message Box

Cannot Halve Size: No unlocked objects selected

You havent selected any objects to halve in size, or the objects that you have selected are locked.    
Either select the objects whose size you want to halve, or unlock the objects that you have already 
selected.    Then try to halve their size again.



Message Box

Cannot Skew Left: No unlocked objects selected

You havent selected any objects to skew, or the objects that you have selected are locked.    Either 
select the objects you want to skew, or unlock the objects that you have already selected.    Then try to 
skew them again.



Message Box

Cannot Skew Right: No unlocked objects selected

You havent selected any objects to skew, or the objects that you have selected are locked.    Either 
select the objects you want to skew, or unlock the objects that you have already selected.    Then try to 
skew them again.



Message Box

Cannot Skew Up: No unlocked objects selected

You havent selected any objects to skew, or the objects that you have selected are locked.    Either 
select the objects you want to skew, or unlock the objects that you have already selected.    Then try to 
skew them again.



Message Box

Cannot Skew Down: No unlocked objects selected

You havent selected any objects to skew, or the objects that you have selected are locked.    Either 
select the objects you want to skew, or unlock the objects that you have already selected.    Then try to 
skew them again.



 Message Box

Error - page size too large

The maximum page size you can create is 30 x 30 inches. You have entered dimensions greater than 
this - try again with smaller dimensions.



 Message Box

You must give this page size a name

You have not given your custom page size a name.    Click on OK to return to the Custom Page Size 
dialog box, and then enter a name for your page size.



 Message Box

A page size with this name already exists

You have tried to save a page size with a name that is already used for one of the standard page sizes. 
You cannot overwrite the standard page sizes that are provided with TurboDraw.    Click on OK to return 
to the Custom Page Size dialog box, and then enter a different name.



 Message Box

You must enter a non-zero size for the page

The width and/or the height dimension of your custom page size is zero.    You must enter a non-zero 
size for the page.    Click on OK to return to the Custom Page Size dialog box, and then amend the 
height and/or width dimensions of your page as appropriate.



 Message Box

You must give a Halftone fill style a name

You have not given your halftone fill style a name.    Click on OK to return to the Name Style dialog box, 
and then enter a name for your fill style.



 Message Box

You must give a PostScript fill style a name

You have not given your PostScript fill style a name.    Click on OK to return to the Name Style dialog 
box, and then enter a name for your fill style.



 Message Box

A custom line style must have some dashes and gaps

You have not given your custom line style any dashes and gaps.    This results in no line style being 
created.    Click on OK to return to the Line Style popup, and then enter some dash and gap values as 
appropriate.



 Message Box

A PostScript line style must be given a name

You have not given your PostScript line style a name. Click on OK to return to the Name Style dialog 
box, and then enter a name for your line style.



 Message Box

There is insufficient memory to display the <name> dialog box

There is not enough memory for TurboDraw to display this dialog box.    Free some memory and then try 
again.



 Message Box

The full path name of the print-to-disk file must not exceed 31 characters

You have entered a path name for your print-to-disk file that is too long; you must enter a path name that 
does not exceed the 31 characters allowed by Windows' printer drivers.    A path name includes the drive 
(e.g. C:\), the directory (e.g. \IMSI\TDRAW) and the file name and extension (e.g. MYFILE.EPS).

Click on OK to return to the Print To Disk dialog box, then enter a path name that contains 31 
characters or less.



 Message Box

A page size with this name already exists. Do you want to replace it?

You have tried to save a page size with a name that you've used already. If you do not want to overwrite 
the existing page size, click on No then enter a different name in the Custom Page Size dialog box. If 
you do want to overwrite the existing page size, click on Yes.    Any pictures based on the original page 
size will now be based on the new page size.



 Message Box

Printout Aborted

You have chosen to abandon your printout.    TurboDraw displays this message to confirm that your 
printout has been aborted.



 Message Box

Not enough disc space to ... create window/execute command/undo command/redo command

While you are working in TurboDraw, it creates temporary files on your hard disk.    These temporary 
files are created on the disk pointed to by the SET TEMP command in your AUTOEXEC.BAT file.    At 
the moment there is not enough free space for these temporary files.

If your SET TEMP command points to a RAM disk, we recommend that you change the SET TEMP 
command to point to an area on your hard disk.    If your SET TEMP command already points to an area 
on your hard disk, clear some disk space and try again.    (For details of how to edit your 
AUTOEXEC.BAT file, refer to your DOS manual.)



 Message Box

Error - unable to ... create window/execute command/undo command/redo command - text object 
would be too large

You have tried to perform a text edit that would result in your text object being taller or wider than the 
work area. 



See also:

   Freeing Memory  




