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Overview

BattleGrid is a game of strategy between two players to locate ships placed on a grid by the opposing 
player.    It is very similar to a classic board game with a similar name.    Among the many differences in 
this version is the fact that the computer can play one or both sides of the contest.    In addition, there 
are no playing pieces to lose!

The basic premise of the game is twofold. First, a player must place five ships of different sizes on a 10 
by 10 grid with hopes that an opponent will have difficulty locating all of them.    Secondly, the player 
must attempt to locate all ships placed by their opponent.    Scoring is determined by the number of 
shots taken during the game.    Basically, if you are familiar with the classic game, then you already know 
how to play.



Playing BattleGrid

BattleGrid begins with a blank grid screen.    Open the File menu and select Player Name.    A dialog will 
appear. Type in your name or handle in the editbox below Left Player.    This will be the name which is 
appended to any scores you place in the best score list.    If you will be regularly playing against a 
particular person, enter their name in the editbox below Right Player.    To make these changes 
permanent, press the OK button.    Press the Cancel button to leave the names as they were.

BattleGrid can be played in three ways.    To choose the game you wish to play, select the Numer Of 
Players item in the Options menu.    The following choices will apear in a sub-menu:

-Human vs. Human:    the conventional two player game.    The player names are determined 
by the entries in the Player Name dialog.

-Human vs. Computer: the conventional one player game.    When this option is selected, a 
dialog will appear prompting for you to select the opponent you wish to play against.    Hal and Eliza are 
very competent players and use efficient but different strategies in their approach.    The Bob player is 
rather crude and methodical.    Play against Bob if you
are on a losing streak.

-Computer vs. Computer: this mode is an interesting simulation of gameplay.    The players will 
always be Hal and Eliza (who wants to see Bob get beat up anyway!).    If you press the BattleGrid 
window minimize button (in the upper right corner), the window will be reduced to an icon.    The game 
will continue, and the score will be updated on the icon.

There are three ways of varying the way the game will play.    These can be controlled by choosing menu 
items in the Options menu.    They are:

-Fast Mode: when checked, the computer player(s) will play at high speed.    You can barely see 
the turns being taken, but it is helpful for impatient players and for the simulation mode.    If Fast Mode is 
checked during simulation mode, a new game will start automatically when one player wins.    Otherwise, 
you must press the OK button in a dialog to proceed.

-Reveal Mode: also known as cheat mode.    Normally when a hit is made on an opponents 
ship, it is shown as a colorful circle.    However, if Reveal Mode is active, the actual part of the ship 
which was struck is shown.    This makes it quite easy to decide where the next shot should be taken.    
This mode cannot be used to handicap one player, since it affects both grids.    The computer players do 
not use this information in any way, so it can give you an advantage when playing the    computer.

-Shots Per Round: selecting this menu item, will present a dialog box prompting the user to 
select the number of shots each player will take during their turn.    The choices range from one to five 
shots.    The classic game was based on alternating single shots, however this could get tedious when 
only one mouse must be shared.

Probably the best way to describe how to play BattleGrid is to provide a walk-thru of a game of you 
against the computer.

Open the Options menu and select Number of Players.    A submenu will open.    Choose Human vs. 
Comp.    Now a dialog will open, prompting for your opponent.    Select Bob and press OK.    Open the 
File menu and select New Game.    Under the left grid, a message box will appear.    It will indicate "Set 
the Battleship".    Move your mouse to any square in the grid and press the mouse button.    The marker 
that appears shows the front location of the Battleship.    The directions it can be placed in are indicated 
by the arrow buttons surrounding the marker.    Press one of these arrow buttons to place the ship.    This 
process continues for all of the ships in your fleet in the following order:

Battleship -- 5 blocks long
Carrier ----- 4 blocks long
Frigate ----- 4 blocks long



Destroyer --- 3 blocks long
Submarine --- 2 blocks long

The message box below the left grid should now indicate: "Left Shots Taken: 0".    This is your clue that 
the war has begun.    Begin taking shots on the left grid.    When the mouse cursor becomes an 
hourglass, the computer will take it's shots at your fleet on the right grid.    Hits are indicated by the hit 
marker and misses are shown with waves.

When all the hits on a particular ship are made, the ship sinks, and is displayed in full.    When all five 
ships are displayed, a dialog will appear showing the winner's name and the number of shots taken.    If 
the shot count is less than any of those in the Best Scores list it will be added to it.    You can see this 
list by selecting Best Scores in the menubar.

Once the game ends, the Show Boats item in the File menu is enabled.    If you select this, all 
undiscovered boats are shown.



Strategy

There are as many strategies to playing BattleGrid as there are players.    Every one of those beta-
testing BattleGrid developed their own methods to reaching the best score possible.    Each was as 
correct as the next.    There are however several undisputable techniques to get you started:

Locating Ships

Before you can sink a ship, you must find one in that vast ocean.    On an empty grid, space random 
shots equally about.    Once the grid is filled with various hits and misses, you can make judgements 
about where the remaining ships might be hiding.    In other words, don't click in a two block opening 
when the only ship you need to win is a Carrier (four blocks).

Sinking Ships

Once you have a hit, you must determine direction by making selections around the hit.    These should 
be North, South, East, and West since ships cannot reside on diagonals.    When one of these directions 
hits, you have your boat.    Continue in this direction until you miss, then reverse direction to the beyond 
the first hit.    If you have gone as far as you can in both directions and still haven't sunk a ship, you're in 
luck!    It means that your shots have hit the middle of several other ships.    This situation comes as a 
result of poor ship placement by your opponent.    Consider this when placing your own ships.    The 
computer players may make this mistake in their own placements.



Notes

During any game, the New Game menu item is not available.    To start a new game, you must terminate 
the current game by selecting End Game from the File menu.

As games are played, a running total is kept in the title bar of the window.    The scores can be reset to 
zero by selecting the Reset Score item in the Option menu.

If you have changed some of the game controls or a new best score has made it to the top ten list, you 
will be prompted to save this information into the BATLGRID.INI file when you exit BattleGrid.    Select 
Yes to make the changes permanent and exit, or No to ignore the changes and just exit.    If you do not 
wish to exit at this time press Cancel.



Registering BattleGrid

BattleGrid is copyright 1991, 1992, 1993 by Bob Dolan

BattleGrid is distributed as shareware.    This means that if you regularly use the product and benefit 
from it, you should register with the author (address below).    The software you now have is not crippled 
in any way.    This indicates a basic trust of the shareware concept by myself and other shareware 
authors who provide useful products with the hope of some type of return for their efforts.    Basic 
registration is $10.

If you are a shareware author, you can register by mailing to me a registered version of your product.

Please print the registration form and fill in the requested information.    Mail it with a check or money 
order in U.S. funds and made payable to Bob Dolan to this address:

Bob Dolan
P.O. Box 16514
Rochester, New York 14616

You may reach me on GEnie at the 
following EMail address: DOLAN

Distribution

If you distribute BattleGrid to friends, associates, or to a computer bulletin board system (BBS),    you 
may only distribute the compressed file including the copyright and disclaimer.

Disclaimer

The Copyright Owner hereby disclaims all warranties relating to this software, whether express or 
implied, including without limitation any implied warranties of merchantability or fitness for a particular 
purpose. The Copyright Owner will not be liable for any special, incidental, consequential, indirect or 
similar damages due to loss of data or any other reason, even if The Copyright owner or an agent of The 
Copyright Owner has been advised of the possibility of such damages.    In no event shall The Copyright 
Owner's liability for any damages ever exceed the price paid for the license to use the software, 
regardless of the form of the claim.    The person using the software bears all risk as to the quality and 
performance of the software.



Registration Form

To print this registration form, open the File menu and select Print Topic.

Please register me as a satisfied user of BattleGrid    (ver 2.0):

Amount Enclosed: 
                                  $10 [    ]    Registration No disk included 

                                  $15 [    ]    Register w/upgrade. [    ]3.5      [    ]5.25

Please note that 720K 3.5 disks will be used unless you request otherwise.
For orders from outside of the U.S., please add $3 to cover additional postage.

Can you UNZIP files?    Yes________    No________

Name:_____________________________________________________

Address:___________________________________________________

City:______________________State:_______Zip:__________________

Phone(optional):_____________________________________________

GEnie/CompuServe/Internet mail address:_______________________

Where did you get BattleGrid ?___________________________

___________________________________________________________

Comments:_________________________________________________

___________________________________________________________

___________________________________________________________

___________________________________________________________

___________________________________________________________



Other Products from Bob Dolan

DeskMenu --    A slimmed down Program Manager for Windows
Version 1.20 - May 1993

An efficient replacement or addition to the Program Manager.    Provides a menubar at the top of the 
Windows desktop with menu headings defined by you to represent the categories of applications you 
typically need to access.    A simple interface allows you to customize the look and feel of this useful 
system utility.

Shareware.........$10

WinGo! --    The classic Bingo for Windows
Version 1.0 - May 1993

Finally Bingo has arrived for Windows!    You match wits with Rosie, an alert and cunning adversary.    
You can play with as many cards as you can handle at the speed you like.    Fully configurable to adapt 
to your playing style.    The registered version includes digitized voice calling for the most realistic Bingo 
play possible.

Shareware.........$10

WinDial -- A    Windows Phone Book that dials
Version 1.0 - May 1993

An easy to use phone book that will automatically dial any selected number as long as you have a 
modem.    When a busy signal is detected, you can tell WinDial to retry until someone answers.    Other 
busy attempts can be placed into a queue, and all will be retried in order.

Shareware.........$10

Mister Clean -- Clean up your hard drive
Version 1.00 -- March 1993

One of the most efficient ways to clean up those hidden but unwanted or unused files that take up 
needed space.    A slick Windows 3.x user interface makes this utility a must have for your toolbox.    
Mister Clean finds files the you specify and sorts them by size.    You click on the ones you want deleted 
and then off they go, one-by-one (to be safe) or all at once.    Not sure what the file is?    Then run it right 
from Mister Clean and check it out before dumping it!    Truly a unique way of managing precious disk 
space.

Shareware.........$10

<softWAREhouse> -- A warehouse for all of your software
Version 1.00 -- January 23, 1993

<softWAREhouse> provides your system with the ability to access more applications than it can hold at 
one time.    This is made possible by storing installed applications offline until they are needed.    When 
required, they are put back on the user's machine in the same condition and location as they were when 
originally stored.    All of this power is surrounded by an easy to use point and shoot menu interface.



Shareware.........$15

Yacht-Z    --    A dice strategy game for Windows
Version 2.2 -- May 1993

Yacht-Z is a version of the classic dice game.    Now, in addition to triple scoring, single scoring is 
included for quicker, simpler games.    Due to popular request, up to four players can now play at one 
time.    A new look to all dialogs gives the program new life in the world of Windows 3.1

Shareware.........$10

BattleGrid -- War in a window -- Battleship for Windows 3.x
Version 2.0 -- May 1993

BattleGrid is a version of the classic board game.    Play against the computer or another person.    
Watch the computer play against itself using different strategies.    Several levels of a computer 
opponent are available, from idiot to genius. 

Shareware.........$10

MagnaFile -- A DOS user interface 
Version 2.2 -- October 1992

MagnaFile is a DOS shell which is directed at a wide range of users from the DOS beginner to the most 
prolific DOS power users. MagnaFile provides services to the user to simplify access to DOS.    It also 
increases the efficiency of doing many of the more tedious operations DOS requires.

MagnaFile commands are carried out using a one-key interface.      Most operations are associated with 
a very obvious key, such as <C> for the Copy command.

The most useful utilities provided by MagnaFile are:

                For Single Files or Groups of Files:
                        Copying
                        Moving
                        Deleting.
                        Attributes
                        Printing

                File Descriptions (40 characters)
                File Viewing & Editing
                File execution
                Disk navigation
                File & Directory Renaming

                File Archiving, Unarchiving, and Archive viewing
                Command line interface
                Mouse handling
                Screen saver and password protection
                Run programs from a smart menu interface
  
MagnaFile is similar to Norton Commander(NC). Users of this product say that MagnaFile will be an 
important tool on your computer, no matter what level user you are.



Shareware..........$20

Smart Solitaire -- The Smart way to play Solitaire
Version 1.01 -- November 9, 1989

A text mode klondike solitaire card game which uses the mouse.    Features BOSS mode and smart 
playing features, such as automatic card placement in obvious situations.    Very addicting and fun!

Shareware.........$10

                                  FreeWare

VLINES    Version 1.0 - May, 24 1990

VLINES is a flying lines demo that runs on VGA adapters.    It can produce some interesting moire 
patterns as well as brilliant color combinations.

TCAL    Version 1.0 -- June 24, 1990

The TSR Calendar (TCAL) is a resident popup calendar which is useful for viewing any month of any 
year by controlling the PgUp, PgDn, and arrow keys.

Laser Fireworks    Version 1.0 - August 11, 1990

Laser Fireworks is a pyro like demo program which utilizes lasers having the effects of fireworks.    Hard 
to explain, fun to watch!

Phone Base    Version 2.0 --    November 8, 1990

Phone Base is a program that includes a small dedicated database with just two fields.    Any two field 
database requirement you have can be filled by Phone Base.    However, the primary intention of this 
application is the storing and dialing of phone numbers.

DcD    Version 1.1 -- October 1991

DcD is a utility to assist DOS users in moving about a Hard disk drive directory structure.    When you 
run DcD, it scans your disk and builds a tree which reflects the directory relationships that exist.    Once 
this is done, DcD can present you with this tree, displayed in a graphical nature.      You may move a 
cursor to other directories and change to them by pressing the <Enter> key.

TLines    Version 1.0 -- October 1991

A moving lines demo, similar to VLINES, this program runs in text mode and draws lines using several 
types of text characters.

FreeView    Version 1.0 -- October 7, 1991

FreeView is a hex or text file viewer.    FreeView provides text searching functions and can handle files 
up to 5000 lines in length.

Idle    Version 1.0 -- October 1991



Idle is a text mode screen saver, which will display a message you specify.    The message is shown in a 
box which moves around the screen until a keystroke interrupts it.    The user is returned back to DOS if 
the correct password is entered.    All parameters are user specified.

Starz    Version 1.0 -- October 1991

A user controllable starfield.    If a mouse is connected, the user can steer the display.    Occasional 
speed changes and swirls make this an interesting screen saver.

BackYard Football    Version 1.00 -- November 16, 1991

A DOS text mode real-time football game for one or two players.    Modeled after the old hand held 
football games.    Complete running stats, and challenging control of passing, running and kicking make 
this a fun game.    Games can be saved and loaded in progress.



History of BattleGrid

Version 1.00 -- October 31, 1991

First release.

Version 1.01 -- January 15, 1992

Shots per round dialog did not retain the user selected value.    This has been fixed.

Version 2.0 -- May, 1993

-Online Help system added.
-Microsoft 3D control library added.
-A grid is now shown at startup.




