
 LEADVIEW for Windows Main Help
Help topics are divided up into eight areas. Select the topic you want to know more about.

To select a topic, move the mouse pointer over the topic and click on the left mouse button.
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 Conversion
LEADVIEW for Windows allows you conversion of various graphics file formats. Images can also be 
resized during the conversion process.

 It is important to keep a copy of the original image until you achieve the desired results.

Converting to 24-bit or higher images

When converting a 24-bit true color, image to another 24-bit image format, the image retains all the 
original information. If the image is resized or the bits per pixel is changed, then the original information 
will be altered as well.

Converting to 8-bit images

Converting to 8-bit images allows you to have a maximum of 256 colors. Note that when you convert a 
16, 24, or 32-bit image down to an 8-bit image, you are loosing color information during the conversion 
process. Once the image have been converted down to an 8-bit image, the original 24-bit color 
information is lost.

Related Topics:

Graphics File Formats

How To Convert An Image

Reszie

Color Reduction



 Screens
This is the main window of LEADVIEW along with a sample photo album. More information about each 
menu and screen item can be found by clicking on various parts of the window below.

Click on any part of the main window screen to learn more about its function.



File Menu
The File pull down menu allows you to view and save images to disk. It also allows you to print images 
to the printer.

For more information, select the desired menu item:

Open...

Save As...

Close

Convert/Compress...

Print

Printer Setup

Preference



File Open Command
The File Open command allows to view a single or multiple images on the screen. You can use the File 
Open command to load images or use the drag and drop method to view images. Viewing images 
allows you to see what the image looks like before attempting to do any conversion and compression. 
After the image is loaded, you may then save it to any of the supported file formats. 

The File Open command also alows you to load multiple images to the screen. Also, this command can 
provide you with a way to view images in a sequenctial order.

Click on the part of the screen you want to know more about.

 



Window Size
This area allows you to set the window size parameters. You can either allow the display window to fit 
with the image, or force the image to fit within the window.



Delay Between Images
This area lets you define how the program load up images during a View Sequence command. This 
option is only valid if View Sequence is checked. You can set display options of no delay, change on the 
mouse/keyboard, or at a certain time interval.



Show Errors
When this box is selected, LEADVIEW will display any error it encounters while trying to load an image 
in sequence. If this option is not checked, then all errors will be ignored and the next file will be loaded. If 
this option is checked during a View Sequence cycle the image that caused an error will not be loaded.



Fit Image To Window
This option forces the image that is being loaded to fit into the predefined window that is defined in the 
Window Size selection area. The aspect ratio will be maintained.



Background Loading
This option allows you to give other Windows application processing time while image(s) are being 
loaded. This option also allows you to perform other tasks while the program executes.



Paint While Loading
Displays the image as it is loaded. When this check box is selected, you will see the image as it is being 
loaded into memory. This painting of the image is done in horizontal "strips."



Refresh Windows
This option is only meaningful if View Sequence is checked. Having this option checked will make the 
previously loaded image to be erased before the next image is painted to the screen.



Cycle Until Stopped
This option is used with the Sequence command. When this box is checked, the selected image will 
cycle continuously. Once the sequence finished displaying the last image, it will then start displaying the 
selected images starting from the first image. To stop the sequence, press any key or mouse button.



Sequence
When this check box is selected, then LEADVIEW will display all the selected files in sequential order. 
This command is used to display multiple images in sequence. Options that is dependent on this 
selection are:

Cycle Until Stopped

Refresh Window

Wait for Key/Mouse click

Wait for ??? seconds

Fixed Size



List Files of Type Box
This drop down list show all the supported file that LEADVIEW for Windows supports. If ALL is selected, 
then all the files in the current directory will be shown in the File List Box.



File Directory and Drive Boxes
This list the available drives and directories on the current drive. The directory list is dependent on the 
drive that is selected in the Drives drop down list.



Information Box
Clicking on the Information button will display the file information about the highlighted file(s). The dialog 
box will display the file name, width, height, and bits per pixel.



File Names List
Lists files in the current directory. Also you can use the mouse to click on the file name to open. This list 
is dependent of the types of files you want to list as well as the List File of Type drop down list.



Minimized Icon
This is a minimized icon of an open image. Use the Minimize button to reduce the image down to icon 
size. Double click on the icon to bring back the image to its previous size.



LEADVIEW Workspace

This is the main working area of LEADVIEW for Windows. This program uses the Multiple Document 
Interface (MDI) to display its windows. Any child window that gets open will exist within this main 
window.



Title Bar
The Main Title Bar shows the name of the Windows application. Here, it is shown as LEADVIEW for 
Windows.



Keep Two Images
This options lets you keep two copies of an image. This is practical if you are using a 256 or 16 color 
device driver but want to modify the image in its true color form. With this option set, you will see the 
"modified" image that suits your color driver but modification that are done to the image will affect both 
the original data as well as the "modified" image. This option only applies to users with 256 colors or less 
video drivers. Use this option only if you want to modify the image. Do not use this option if you just want 
to view the image. Also, do not have this option set if you are viewing images sequence.



Open Using Drag And Drop
LEADVIEW for Windows accepts dropped files. Using the File Manager or another File Shell program, 
you can select one or more files and drag them to LEADVIEW and drop them in the Main Window. 
LEADVIEW will automatically load the file(s) for viewing.

If LEADVIEW is an icon, when the files are dropped, LEADVIEW for Windows will open and then load 
the dropped file automatically.The image loads based on the last viewing option used.

See Also ...

Viewing the Original Image



 How To . . .
This section gives you step by step instructions for various image processes.

Conversion & Compression 

Change The Qfactor

Compress Images(s)

Convert Image(s)

Capture

Capture A Screen

Save Captured File

Printing

Print An Image

Image Manipulation

Change An Image To Gray Scale

Change The Intensity

Crop An Image

Flip an image

Perform Color Reduction

Resize An Image

Reverse an image

Rotate An Image

Clipboard

Copy Using The Clipboard

Paste From The Clipboard

File Processing

Delete File(s)

Saving An Image

View Images

Drag And Drop Files



How To Convert An Image
There are two methods of converting an image.
·    File to file conversion

·    Convert from the screen
 To Convert file to file:

1. Select "File" from the Main Menu.

2. Choose Convert/Compress. The "Convert: Source File Name" dialog box appears.

3. Type or click on the source file name to convert. 
If you want to convert more than one file, click on the first file, then hold down the CTRL key while 
clicking on each additional file you want to convert. Click on the file again do remove the file from 
the conversion process.

4. Click on OK when you have the correct name(s).The "Convert: Destination File Name" dialog box 
appears.

5. Next, select the format you want to save the image(s).

6. Click on OK when you are ready to perform the conversion.
 To Convert from the screen:

1. Load up an image.

2. Select "File" from the Main Menu.

3. Choose Save As.

4. Type the name of the save to save.

5. Choose the output file format to convert.

6. Click on OK when you are ready to start the conversion process.



How To View Image(s)
Viewing an image is the same as loading an image. You can view more than one image by either 
loading the images one at a time or loading all at the same time into separate windows.

LEADVIEW will also allow you to view images from the Photo Album by double-clicking on the individual 
thumbnails of the image.
 To load a singe image

1. Select "File" from the Main Window.

2. Choose Open.

3. Type or select the file name to open.

4. Click on OK or hit the Enter key when you are ready to load the image.
 To load multiple images

1. Select "File" from the Main Window.

2. Choose "Open".

3. Hold down the CTRL key while clicking on individual file names to load. If you make a mistake, 
click on the file name again to deselect the file.

4. To load the image in sequential order, click on the Sequence check box.

5. Click on OK or hit the Enter key when you are ready to load the image.



How To Change The Qfactor
Change the Qfactor to determine the compression level. You must have an image selected or loaded to 
change the Qfactor. The Qfactor can only be changed when you are saving or compressing an image 
from the "Save As" or "Convert/Compress" command of the File menu.

For optimum compression, start with the predefined option "Quality and Size Equally Important" for 
LEAD CMP and "Good Quality Compression" for JPEG. Work your way up or down the pre-defined 
setting to suit your compression and image quality needs. 

For batch compression, the selected compression setting will apply to all selected images.

The Qfactor can be set during:
·    File to file compression

·    Saving the loaded image as a compressed file

See Also ...

File Menu



How To Compress Images
Compressing images is the same as saving the image. There are two methods of compressing images:
·    File to file compression

·    Saving the loaded image as a compressed file



How To Delete File(s)
Deleting a files means the same as the DOS delete command. Make sure you are certain that you want 
to remove the file(s) from the drive.
 To Delete File(s):

1. From the Main Window, select File.

2. Choose "Delete".

3. Click on the file you want to delete.

4. For multiple files, hold down the CRTL key while clicking on file names. Click on the file name 
again to de-select the file.

5. Click on OK when you are ready to delete the selected files.



How To Print An Image
 To Print An Image

1. Open the file you want to print.

2. Make sure the printer is set up correctly. Use Printer Setup to prepare the printer for printing.

3. Select "Print" from the Main Window.



How To Copy Using The Clipboard
Copying an image (or part of an image) to the clipboard requires you to have an image loaded on the 
screen. There are two methods of copying data to the clipboard:

Copying the entire image

Copying out a section of the image
 Copying the entire image:

1. Open the image you want to copy.

2. If there are more than one image loaded, make sure that the image you want to copy is on top.

3. Choose "Copy" from the Edit Menu. The entire image should be now placed on the clipboard for 
pasting.

 Copying out a section of the image:

1. Open the image you want to copy to the clipboard.

2. If there are more than one image loaded, make sure that the image you want to copy is on top.

3. Make the child window large enough to contain the part of the image you want to cut out.

4. Using the mouse, drag out the area you want to copy from the image. This will define out the area 
that you want to copy.

5. Choose "Copy" from the Edit menu. The image should be now placed on the clipboard to be 
pasted.



How To Paste From The Clipboard
Pasting from the clipboard requires you to have an image data on to the clipboard. Images that are 
placed on the clipboard can come from any Windows application that can put a bitmap image onto the 
clipboard. 
 To Paste from the Clipboard:

1. From the Main Menu, choose the Edit Menu.

2. Select "Paste". This will paste an image from the clipboard to a window in LEADVIEW.



How To Rotate An Image
 To rotate an image:

1. With an image loaded. Select "Rotate" from the Image Menu.

2. Enter in a rotation angle from 1 to 360 degrees.

3. Select the rotation direction; either clockwise or counter-clockwise rotation.

4. Check on the Clip Corners check box if you want to crop out the corners during the rotation 
process. If this option is not check, then the image is resize to fit within the original width and 
height.



How To Resize An Image
Resizing an image will physically change the width and height of the image.
 To resize an image:

1. Make the window with the image you want to rotate as the active window.

2. Make sure that you are in Normal view from the View Menu.

3. Select "Resize" from the Image Menu. This will bring up the Resize Image option dialog box.

4. Select the new width and height of the image in pixel units. Note that you cannot change the 
height of the image if the Keep Aspect Ratio check box is checked. When this box is checked, 
the height is predetermined by the width.

5. Click on OK when you ready to resize the image.



How To Flip An Image
Flipping an image requires you to have an image loaded.
 To flip an image:

1. Make the window with the image you want to flip as the active window.

2. Select "Flip" from the Image Menu. This will flip the image contained in the active window.



How To Crop An Image
Cropping an image means that you want to throw away a part of the image. You must have an image 
loaded to perform the cropping feature.
 To Crop an image:

1. With the image loaded, position the window so that the portion of the image that you want to save 
is shown.

2. Next, drag out the area you want to keep.

3. Select "Crop" from the Image Menu. This will throw away all of the image except the selected 
area. You now have a new image to work with.



How To Change The Intensity
Changing the intensity of an image is the same as increasing or decreasing its brightness.
 To Change intensity:

1. Open the image.

2. Select Intensity from the Color Menu.

3. Use the scroll bar to select the change in intensity.

4. Next, choose whether you want to lighten or darken the image.

5. When you are ready, click on OK to begin the process.



How To Convert An Image To Gray Scale
 To Convert to gray scale:

1. Open the image.

2. Select "Gray Scale" from the Color Menu. This will convert all types of image into a gray scale 
format.



How To Perform Color Reduction
Color reduction can decrease the amount of colors in an image while trying to maintain optimum quality. 
Reducing the number of colors in an image can also reduce the file size of the image when stored on 
disk.

 Doing color reduction on large size image can take some time. 
 To perform color reduction:

1. Open an image.

2. Select one of the color or bits selection from the Color Menu.

3. Next, select the Palette to use during the color reduction phase. Use "Nearest Color" for the 
highest quality image. 

4. Choose a Dithering method.

5. When you are ready, click on OK.



How To Capture A Screen

There are two capturing methods;
· Marked area

·    Entire desktop screen
 Capturing a Marked area:

1. From the "Capture" menu, check on how the LEADVIEW Main Window should appear during 
capture. This selects the capture option you want to use.

2. Prepare the target capture area the way you want it to look.

3. Select "Marked Area" from the Capture menu. This will change the mouse pointer into a capture 
cursor; .

4. Drag out the area you want to capture. When you release the mouse button, you will get a child 
window with the capture area.

    Capturing Entire desktop screen:

1. From the "Capture" menu, check on how the LEADVIEW Main Window should appear during 
capture. This selects the capture option you want to use.

2. Prepare the target capture screen the way you want it to look.

3. Select "Desktop" from the Capture menu. This will capture the entire desktop area as shown on 
the current screen. You will get    a child window with the captured screen.



How To Save A Captured Screen
 To save a captured image:

1. Make sure that the window you want to save is the top window

2. Select Save As from the File menu.

3. Select the file name to want to save the captured screen as.

4. Next, choose the file format to save the image. You can save the image as any supported file 
format.

5. Type in the new width and height of the image in pixel units. Leave these fields blank if you want 
to keep the original width and height.

6. Click on OK when you are ready to save the image.



How To Save An Image
When an image is opened, you can save it into any supported graphics file format.
 To save an image:

1. Open the image.

2. From the Main Window, select "Save As" from the File menu.

3. Select the file name to want to save the captured screen as.

4. Next, choose the file format to save the image. You can save the image as any supported file 
format.

5. Type in the new width and height of the image in pixel units. Leave these fields blank if you want 
to keep the original width and height.

6. Click on OK when you are ready to save the image.



How To Reverse An Image
Reversing, or transposing, an image will turn the image from right to left.
 To transpose an image:

1. Make the window with the image you want to flip as the active window.

2. Select "Transpose" from the Image Menu. This fill reverse the image in the active window.



 Commands
Available menu commands in the Main Window are:

File Menu

Edit Menu

View Menu

Image Menu

Color Menu

Capture Menu

Photo Album

Window Menu

Help



File Menu

Open Retrieve file(s) for viewing and processing.

Save As Saves the current image to a particular file format.

Close Close the current window.

Delete Delete file(s) on disk.

Convert/Compress Convert and/or compress images.

Print Print the current image.

Printer Setup Configure and setup the printer.

Preference Select default Video and Palette information.

Exit Quit LEADVIEW for Windows.



Open
Opens the selected file(s) to be viewed. Note that you can select more than one file by holding down the 
Ctrl key and clicking on the file name.

To "unselect" a file, move the mouse cursor over the file name, hold down the CTRL key and click on the 
file name. You will notice that the file is no longer highlighted.

Click on the part of the Open screen you want to know more about.

See Also . . .

How To View Images

Open Using Drag And Drop



Save As
The Save As commands allows you to save the current image in the current window or active window 
into any supported file formats including compressed formats. You must have an image loaded to use 
this command.

If you had the Keep Two Images Option set, when the image was opened, then the original image data 
will be saved. 

Click on the part of the Save As screen you want to know more about.

See Also . . .

Compression

Conversion

Graphics File Formats

How To Save An Image



Save File Name

This is where you need to type in your file name. Also, you can select the file name already shown by 
clicking on the file name in the File List Box. The file names in this list are located in the current drive 
and directory shown in the Drive and Directory List Boxes.



Save File List

This list shows all the selected files in the current directory. The file names in this list are located in the 
current drive and directory shown in the Drive and Directory List Boxes.



List File By Type

This Drop Down List lists all the files in the current directory with the same file type as the one selected 
in this box. Use ALL to show all files in the current directory. For a list of supported file types see 
Convert.



Directories and Drives Box

These two drop list box shows the current working drive and directory.



Bits Per Pixel

This box allows you to select the Bits Per Pixel for the image. Note that some file format have limited bits 
per pixel selection. For more information, see the list of supported graphics file formats.



Width And Height Selection

These two boxes lets you select the resulting with and height of the image. Do not change this selection 
if you do not want to resize the image during the save process. See Resize for more information.



Save Palette

This save the VGA palette along with the compressed image. Note that this option only works when 
compressing images using LEAD CMP compression. See also Compression.



Load Image

If this option is set, then LEADVIEW will load the image that you just saved. This option is useful if you 
would like to see the image after the save process.



Don't Resize

Select this option if you do not wish to resize the image during the save process. If this option is not set, 
then the image will be resized according to the Width and Height box.



Qfactor

This area lets you change the desired Qfactor. The Qfactor only applies to compressed formats such as 
LEAD CMP and JPEG. The higher the Qfactor the smaller the file size. Also, setting a high Qfactor 
number will affect the quality of the resulting image. See also Compression.



OK Button

Click on the OK button once you have selected the desired file name and save method.



Cancel Button

Click on the Cancel button to abort the process. This will take you back to the main LEADVIEW window.



Close
This command closes out the current image window. You must have a window selected for this 
command to work. Save the file before closing if you want to save any changes made to the image.



Convert/Compress
This command performs file to file conversion and compression. You can select multiple files for 
conversion and compression. When compressing and converting file to file, you can only apply one 
single compression or conversion option. That is, compression or conversion will be done to all the 
selected file(s) using the same options.

You can select multiple files for conversion and compression by holding down the CTRL key and 
pressing the left mouse button on the desired file names. Release the CTRL key when all the files have 
been selected. When you are ready to perform the compression or conversion process, click on the OK 
button.

See Also . . .

Screens

Conversion

How To Convert Images

How To Compress Imagess



Printer Setup
This allows you to properly configure the printer to print images in LEADVIEW for Windows. Once you 
have defined you print options select Print to start your print job.



Print
This command prints out the current image. You must select a valid printer in the Printer Setup to print 
images.



Preference
This screen lets you select the default video and palette information.

Device Load Options

Due to various implementation of video boards, some video boards uses RGB (Red-Green-Blue) rather 
than BGR (Blue-Green-Blue) video order. If you find that your image tends to be more "reddish" then 
select the BGR color order. You can only use one of the above selections.

Palette

LEADVIEW for Windows can display images using a Fixed Palette. For users with 256 color drivers, 
having this option set will increase display time for 16-bit or higher images. However, the quality of the 
resulting displaying image will be affected. For users with higher than 256 color display, this option will 
not have any affect on the quality of the image.

If Default Palette is selected then all images will use its own unique palette. For users with 256 color 
drivers, having this option set will slow down display time for 16-bit or higher images. The advantage of 
using Default Palette is to allow you to view the image with its own unique color palette.

For users with a 32K or higher graphics driver, the Palette information will not apply.



Edit Menu
The Edit Menu performs copy and paste operations on to the clipboard.

Undo Undo the last command performed.

Copy Copies the current image into the Windows clipboard.

Paste Paste from the clipboard into a new windows.

Empty Clipboard Empties all contents of the clipboard.

See Also . . .

Copying and Pasting from the clipboard.

Screens



Edit Menu Commands

Undo

Undo the last command performed on the image. LEADVIEW for Windows will keep in memory the last 
command performed. 

Copy

Copies the content of the current image into the Windows clipboard. This command will allow you to use 
the clipboard to move images from one Windows application to another.

Paste

Paste the contents of the clipboard into a new window. This will allow you to use the clipboard to copy 
from another Windows application and paste into LEADVIEW for Windows. Note that the contents of the 
clipboard must be a bitmap object.

Empty Clipboard

Empties out the current contents of the clipboard. Since the clipboard's contents reduces the amount of 
available memory, it is recommended that you empty out the clipboard to free up memory for Windows 
to use. 



Copying To and Pasting From the Clipboard
Once an image is loaded, you can copy and paste bitmap images to and from the clipboard. LEADVIEW 
for Windows allows you to define an area within an image to be copied and placed on to the clipboard.

When an image is loaded, use the mouse to drag out an area to be place to the clipboard. Once the 
image is on the clipboard you can select Paste from the Edit Menu to place the cut section to another 
window. You can also use the clipboard to paste the section into other windows application.

See Also . . .

How To Copy Using the Clipboard

How To Paste Using the Clipboard

Paste



View Menu

Snap Window to Image

Force the window border to align with the image size.

Normal Use default windows window size.

Fit Image to Window

Make the image to fit within the specified window.

Zoom In Zoom in 2x into the image.

Zoom Out

Zoom out to the previous magnification.

Full Screen

View the image full screen.

Fit Image to Full Screen

Fill in the entire screen with the current image.



Snap Window To Image

This command forces the window border to be flush with the edge of the image. If the window is larger 
than the current screen resolution, then scroll bars will automatically be place on the main window.



Normal View

This uses the default windows screen to view the image. If the image is too large to fit within the main 
window then scroll bars will automatically be placed. You can then use the scroll bars to move around 
within the child window.



Fit Image To Window

This command forces the current image to fit within the child window. You can resize the child window 
and the image will automatically fit within the resized window. Use this command to resize the image. 
Note that the aspect ratio of the image is maintained.



Zoom In

In Zoom Mode, use the left button to zoom in and the right mouse button to zoom out. During the zoom 
mode, you cannot do image manipulation. The title bar will tell you the current magnification factor.

This command will "zoom in" on the image. Each time you select Zoom In, the image will be magnified. 
Each successive zoom magnifies the image even greater. The maximum magnification is 9X. Use the 
scroll bars to move around the magnified area.

Use the Zoom Out command to return to the previous zoom magnification. To return back to normal 
view, select Normal from the View Menu. This will take you out of the magnification mode.



Zoom Out

In Zoom Mode, use the left button to zoom in and the right mouse button to zoom out. During the zoom 
mode, you cannot do image manipulation. The Title bar will tell you the current magnification factor.

This command takes you back to the previous magnification level. Use the Zoom In command to 
magnify the image. Each time you select Zoom In, the magnification level is increase and is shown on 
the title bar.

To return back to normal view, select Normal from the View Menu. This will take you out of the 
magnification mode.



View Full Screen

This will view the image full screen. This command will display the image without any windows 
properties. To force the image to fit to current video mode at full screen use the Fit Image to Full Screen 
command from the View Menu.

Click the mouse button or hit any key to return back to the Windows desktop.



Fit Image to Full Screen

This will force the image to fit into the current video mode. It will also not display any windows 
properties. To view the picture in full screen mode without a forced resize, use the View Full Screen 
command from the View Menu.

Click the mouse button or hit any key to return back to the Windows desktop.



Color Menu
The color menu allows you to transform the current image into different color formats.

Intensity Change the intensity of the image.

Gray Scale Convert the image into a gray scale image.

2 color (1-bit) Convert to a black and white half tone image.

16 color (4-bit) Convert to a 16 color image.

256 colors (8-bit) Convert to a 256 color mapped image.

32K color (16-bit) Convert to a 32,000 color image.

16 million (24-bit) Convert to a 24-bit True Color image.



Intensity

This changes the intensity, or brightness of the image. You can either darken or lighten the appearance 
of the image.

Gray Scale

Converts the image into a black and white gray scale image. All color attributes of the image is 
transformed into a gray mapped image.

See Also . . .

How to convert to gray scale

How to change intensity



Image Menu
The Image Menu allows you to do fundamental manipulation of images.

Image Info Get information about the image.

Transpose Flips the image vertically.

Mirror Moves the image from right to left.

Rotate Rotates the image.

Resize Resizes the image to a new width and height.

Crop Crops the image and keeps only the selected area.

See Also . . .

Edit Menu



Image Info
Getting image information provides you with technical information about the image. When you select 
"File Info" from the Image menu a message box will appear showing the complete information about the 
image.

File Name - This is the complete file name of the image.

Format - Original file format of the image.

Width - Describes the width of the image expressed in pixels.

Height - Describes the height of the image expressed in pixels.

Bits Per Pixel - This is the image depth of the image. The bits per pixel can be either 1, 4, 8, 16, 24 or 
32.

Size on Disk - The physical file size stored on disk.

Size in Memory - Total amount of memory the image will take up in memory.

Compression - This field will show the compression method used in the file (if any).



Rotate

LEADVIEW for Windows allows you to rotate the image to any single degree increments. Also, you can 
select the direction of rotation.

The rotation process can be very complex and could take some time to process on larger size images.

Note that since rotation involves moving data from one location to another, the rotation process can 
affect the quality of the resulting image.

See Also . . .

How to rotate images



Resize

LEADVIEW for Windows lets you resize the current image to any width and height (in pixels units). By 
default, the aspect ratio is maintained. That is, the height of the image is automatically determined by 
the width. If you want to manually control the width and height, deselect the keeps aspect check box.

 It is important to keep a copy of the original scan or capture until you achieve the desired results.

Each time an image is resized, pixels of data are added in some areas and removed from other areas. If 
you resize the same image several times, the image quality will deteriorate.

See Also . . .

How to resize images



Crop

Cropping allows you to select a portion of the image to keep while the remaining part is discarded. This 
option is only available when you select an area to be cropped and in the Normal View mode.

The area to be cropped can be defined by moving the mouse to click and drag out the area.

See Also . . .

Edit Menu

How to Copy to the Clipboard

How to Paste from the Clipboard



256 Color Reduction

Since 32, 24, and 16-bit images can store more than 256 colors, LEADVIEW for Windows will allow you 
to reduce these images down to 8-bit, or 256 colors. There are various ways to optimize down to a 256 
color palette.

To obtained the best quality during optimization, select Optimize under the Palette area. This process 
will select the best possible color palette for the selected image. For optimization using LEAD's Fixed 
Palette, select Fixed instead. You can also choose to include the standard 16 windows colors by 
checking the Include System Palette check box.

 If the resulting image is unsatisfactory, select Undo from the Edit menu.

See Also . . . 

Dithering

Graphics File Formats



Dithering

LEADVIEW for Windows provides various dithering methods for color reduction. Using different dithering 
methods affects the resulting image. The dithering methods supported are known algorithms that 
provides high quality images.

Applying different types of dithering algorithm will result in various level of image quality. Make sure to 
keep a copy of the original image until you get the desired result.

LEADVIEW for Windows supports:

Flyod-Stein Dithering

Burkes Dithering

Stucki Dithering

Sierra Dithering

Stevenson Dithering



Window Menu
The Window menu allows you to manipulate all open windows within LEADVIEW. Windows can be 
minimized, maximized, closed, and arranged.    Menu items include:

Cascade Arrange all open windows with the title bar of each window shown.

Title Arrange all open windows so that no windows overlapping each other.

Arrange Icons Arrange all minimized icons to be shown. 

Close All Close all windows. This closes all open and minimize opened file(s).

(open file list) Shows all files that are currently open. Select the file listed to quickly open the 
window.



Photo Album Menu
The photo album menu allows you to create and open albums.

New Create a new photo album.

Open Open an existing album.

See Also . . . 

Photo Album

Creating a New Photo Album

Opening an Existing Photo Album
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 Glossary
The following are available glossary terms for LEADVIEW for Windows. For additional information, 
please see the LEADVIEW for Windows User's Guide and the Microsoft Windows User's Guide.

active window

aspect ratio

bits per pixel

capture cursor

click and drag

client application (OLE)

clipboard

color mapped

Desktop Area

Fixed Palette

Icon

LZW Compression

Optimize

Palette

Photo Album Category

pixels

Run Length Encoding Compression

server application (OLE)

thumbnail

true color

window properties



bits per pixel

The number of bits used to define color in a pixel of image information. While 8 bits per pixel means that 
there a maximum of 256 colors, 24 bits per pixel means that there are a maximum of 16 million possible 
colors.



color mapped

Table of predefined color values assigned to the image. Most 8-bit file formats are color mapped images 
which provides a "look-up" tables to describe the available colors in the image.



Run Length Encoding Compression

RLE compression relies on long stretches of repeating data and is most effective when an image's pixel 
values change infrequently. Some file formats such as PCX, TGA and BMP uses RLE type compression.



LZW Compression

Also known as LZ77 or LZ87, it is one of the best lossless compression techniques developed. This 
compression technique was the start of all dictionary based methods. The dictionary consists of all the 
strings in a window into the previously read input stream. Some file formats such as GIF uses the LZW 
scheme to store image data.



Desktop Area

The desktop area is defined as the entire screen of the Windows environment. Any open windows, icons 
and DOS screen will be capture if you choose to capture the desktop area.



Click And Drag

The term click and drag is the process of holding down the left mouse button and moving the mouse to 
define an area. Once you have defined the area to capture, release the left mouse button.



 Capture Cursor
This is the capture cursor. When you want to capture a marked area, the mouse pointer will change into 
this shape.



client aplipcation

A client application is the Windows application that contains the embedded object within its working 
environment. The embedded object can be any object such as a sound or image file that can be 
associated with a Windows application. Some Windows application can be both a server and client OLE 
application.



windows properties

Windows properties are items such as the title bar, control box, menu items, and dialog boxes.



pixel

The smallest unit of measurement for graphic images that can be displayed on the screen. LEADVIEW 
for Windows uses pixel as its unit of measurement when resizing and saving.



aspect ratio

The aspect ratio is determined by the proportion of width versus height. For example, an image with a 
width of 100 and height of 200 pixel has an aspect ration of .5.



Clipboard

A temporary storage location used to transfer data between applications.



Optimize

The process of reducing an image to the best 256 color to represent the image. See also palette.



Palette

A "look-up" table that contains (at most) 256 color entries that best represents the colors contained in 
the image.



Fixed Palette

The fixed palette is a predefined 256 color palette that comes within LEADVIEW for Windows.



Icon

Graphical representation of various Windows elements.



True Color

True color are also referred to as 24-bit images. These type of images contain the highest possible color 
ranges for a file format. 24-bit images can contain up to 16.7 million colors within the image. 



active window

The window that you are currently using or that is currently selected. Only one active window can be 
activated at any time.



image description

Each image in the album can have a description attached to it. This desctiption can be a single line 
giving additional information about the image. You can type any one-line description about the image 
here.



category

You can place all images that have common reference in a single category (e.g. boats.)    You can have 
more than one category within a single album. 



server application (OLE)

A server application is the application providing support for the embedded object. LEADVIEW is a server 
OLE application. It supports the graphical files formats embedded in a Windows application supporting 
OLE features.



thumbnail

A small represenation of a larger image. Thumbnail images are usually low resolution images.



Index
The following are topics found in this on-line help file.
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Compression
Image compression is very image dependent. Compressing different type of images yields different 
results. The less colors and less complex the image, the more the image will compress. Conversely, if 
the image contains many colors and is complex, then compression will be less. In either case, the 
compressed size will still be considerably less than the original file size.

LEADVIEW for Windows supports various types of compression formats. Different compression scheme 
will apply to certain types of images. 

LEADVIEW for Windows supports compression of:

JPEG

LEAD CMP

CCITT Group 3 & 4

LEAD Extended 1-bit

TIFF with LZW

Related Topics:

Qfactor

Alpha Channel

Compression Limitations

How To Change The Qfactor

How To Compress Images



JPEG Compression

JPEG stands for the Joint Photographers Experts Group and grew out of two standardized groups; 
CCITT and ISO. The purpose of JPEG compression is to provide a unified standard under which 
hardware and software developers can operate. Images with JPEG compression can be exchanged 
between a wide variety of hardware platforms and applications.

LEADVIEW for Windows supports various versions of JPEG compression. Two most popular methods 
are JPEG/JFIF (JPEG File Interchange format), more commonly known as JPG, and JPEG/TIFF. All 
LEAD JPEG formats are fully compliant. The LEAD1JTIF, LEAD2JTIF, LEAD1JFIF, and LEAD2JFIF are 
also JPEG compliant file formats. The JPEG compression method does not support 1-bit black and 
white images. The LEADVIEW for Windows User's Guide provides technical information about JPEG file 
formats.

LEAD1JFIF JPEG File Interchange File Format using the Y:U:V 4:1:1 color space and will produce the 
smallest file.

LEAD2JFIF JPEG File Interchange File Format using the Y:U:V 4:2:2 color space and will produce the 
second smallest file size.

JFIF JPEG File Interchange Format using the Y:U:V 4:4:4 full color space and will produce the 
largest file size.

LEAD1JTIF JPEG TIFF using the Y:U:V 4:1:1 color space and will produce the smallest file.

LEAD2JTIF JPEG TIFF using the Y:U:V 4:2:2 color space and will produce the second smallest file 
size.

JTIF JPEG TIFF using the Y:U:V 4:4:4 full color space and will produce the largest file size.

Color Images

The LEAD CMP format will always save color images as 24-bit color information. If the image is not a 
24-bit (i.e. 8-bit 256 color) then the image is internaly converted to 24-bit before compression starts. To 
produce a smaller file size than the original use a higher Qfactor such as "Quality and Size Equally 
Important". Choose the "JFIF" compression option to compress color images.

Gray Scale Images

The LEAD CMP format will recognize true gray sclale image. True gray scale implies that the image 
contains ONLY 256 levels of gray shades within the palette. Choose the "JFIF" compression option to 
compress gray scale images.

See Also . . .

Qfactor

LEAD CMP

How To Compress Images

How To Change The Qfactor



Qfactor
The Qfactor is a number that determines the degree of loss in the compression process. The Qfactor 
can be a value from 2 to 255. For the maximum compression option, use a Qfactor value of 255. 
Conversely, use a Qfactor of 2 for the least amount of compression. JPEG and LEAD CMP compression 
will use this Qfactor value to determine the degree of compression. For LEAD CMP and JPEG 
compression process, it is recommended that you use the pre-defined compression options. The pre-
defined compression options are provided to achieve maximum compression while maintaining the 
highest possible image quality. Some of the following settings are not available for JPEG compression.

Perfect Quality 1
This option compresses all colors of a 24-bit file and maintains the quality of the original 
image at a smaller file size. When viewing the image, all the original colors are 
preserved. This option will produce the exact image when decompressing back to the 
original file format.

Perfect Quality 2
This option is virtually the same as Perfect Quality 1. This option will keep the original 
colors intact but will not save any unnecessary information about the image.

Quality Far More Important than Size
This option removes colors not noticed by the human eye. Most viewers cannot tell the 
difference between an image compressed at this level compared to the original image.

Quality More Important Than Size
While more colors are removed, most of them are colors or shades that are close to one 
another. The compressed image will appear very much like the uncompressed image.

Quality and Size Equally Important
This option provides the most compression while maintaining good image quality. Try this 
option first, then move up or down the list accordingly to obtain acceptable compression 
size and image quality.

Size More Important Than Quality (Sharp)
This option is recommended for images that have sharp edges. For example, an image 
that has a text overlay or images with many straight lines. While it creates a large file 
than the next option, it retains better edges.

Size More Important Than Quality (Less Sharp)
The option produces less blocks in the image that the previous options. However, it may 
distort text or straight lines. It is a good option for image database applications.

Give Maximum Compression Keeping Quality
This option provides maximum compression while maintaining as high as possible image 
quality

Maximum Compression
This is a full compression implementation using the highest available compression.

See Also . . .

How To Change The Qfactor

JPEG

LEAD CMP



LEAD CMP
This format delivers a much smaller file size and better image quality than any other compression 
techniques, including JPEG. The LEAD CMP format produces smaller files size as well as higher quality 
resolution. The CMP file can only be read by software that supports the LEAD compression format.

When compressing using LEAD CMP compression, you should use the pre-defined Qfactor to achieve 
higher compression and image quality. An image that has been compressed using LEAD CMP can be 
converted to any supported file format.

The LEAD CMP format can compress:
·    8, 16, and 24-bit color images

·    8-bit gray scale images

·    1-bit black and white images.

Color Images

The LEAD CMP format will always save color images as 24-bit color information. If the image is not a 
24-bit (i.e. 8-bit 256 color) then the image is internaly converted to 24-bit before compression starts. To 
produce a smaller file size than the original use a higher Qfactor such as "Quality and Size Equally 
Important". Choose the "LEAD" compression option to compress color images.

Gray Scale Images

The LEAD CMP format will recognize true gray sclale image. True gray scale implies that the image 
contains ONLY 256 levels of gray shades within the palette. Choose the "LEAD" compression option to 
compress gray scale images.

Black and White Images

The LEAD 1-bit CMP will produce a smaller file size than CCITT Group 3 or 4 compression. Choose the 
"LEAD 1-bit CMP" compression option to compress black and white images.

See Also . . .

Qfactor

JPEG



Alpha Channel

LEADVIEW for Windows will compress 32-bit TGA files while saving the Alpha channel. The alpha 
channel will be in a separate file with the same file name but will have a .ALF extension. Note that when 
compressing 32-TGA file using JPEG, the alpha channel will be stripped.

If you want to convert the CMP file back to the original 32-bit TGA format (including the alpha channel), 
make sure the saved alpha channel file (ALF) is in the same directory as the CMP file. If there is not an 
alpha channel file present, LEADVIEW will fill the alpha channel with zeroes.



CCITT Group 3 & 4 Compression
LEADVIEW for Windows supports compression of 1-bit black and white images. These types of images 
are usually found in FAX and document imaging applications. CCITT Group 3 and 4 compression 
standard is defined under the guidelines of the TIFF 6.0 specification. Supported compression for 1-bit 
images include:

·    TIFF CCITT Group 3 unmodified compression scheme.

·    TIFF CCITT Group 3 1D facsimile compression scheme.

·    TIFF CCITT Group 3 2D facsimile compression scheme.

·    TIFF CCITT Group 4 facsimile compression scheme.

See Also . . .

Compression

JPEG

LEAD CMP



LEAD Extended 1-bit Compression

LEADVIEW for Windows can also compress 1-bit black and white images. These images can either be 
1-bit uncompressed formats or TIFF CCITT Group 3 or 4. This compression method is suitable only for 
compressing and decompressing black and white images.

When compressing using "LEAD 1-bit CMP" compression, you can use any of the following predefined 
compression settings:

LEAD Lossless Compression

LEAD Excelent Compression



Compression Limitations & Considerations
There are some considerations when compressing images. This section will give you some technical 
information about the compression process and its limitation.

JPEG Compliant

LEADVIEW for Windows is fully JPEG compliant. Any file using the JPEG compliant compression can 
be view and converted. LEADVIEW supports JPEG color spacing of RGB, YCbCr, YYbCr, and YCbCr.

4-bit and 1-bit Images

Image compression is geared more toward high resolutions images. As a result, it is impractical to 
compress 4-bit and 1-bit images using JPEG compression. Due to internal conversion processes, the 
resulting image will probably be larger than the original image. However, LEAD CMP 1-bit and CCITT 
Group 3 and 4 compression method can compress black and white (1-bit) images. The TIFF LZW format 
can compress 1 and 4-bit images.

8 and 24-bit Images

The JPEG and LEAD CMP compression process must convert the image data into raw RGB 24-bit 
information before the compression process begin. As a result, 8-bit images will take longer than true 
24-bit images (TGA and TIFF). Also, if the original file is a 24-bit format, then the compressed file will 
give a higher quality and smaller size than converting the file to an 8-bit format and then compressing it.

Built-in Compression

Some graphics format already have built-in compression schemes. These internal compression scheme 
will affect the compression time and results. During compression, the data must be decoded for the 
compression process to start. For example, GIF image will have built-in compression scheme that will 
affect the compression time.

Gray Scale Images

Both JPEG and LEAD CMP will recognize gray scale images and treat them accordingly. Types of gray 
scale images includes the TIFF file format. True gray scale images are images that have the same RGB 
values for each component in the palette.



TIFF with LZW Compression
LEADVIEW can save your image files using the TIFF LZW compression format. This format will give you 
a TIFF compatible file that is smaller in size. The image file can be any pixel depth.

See Also . . .

Conversion

Graphics File Formats

How To Save An Image



File to file Compression
This is the recommended method for compressing images. This is done by selecting Convert/Compress 
from the File menu. This will provide the quickest and highest quality images since the image will not be 
loaded and dithered to the screen to match you screen resolution.

This method will also allow you to do batch conversion and compression. Select multiple files by holding 
down the CTRL key while clicking on the file names you want to convert or compress. Click on the file 
name again to de-select the file.
 File to file compression:

1. Select "File" from the Main Window.

2. Choose Convert/Compress. The "Convert: Sourve Image File(s)" dialog box appears.

3. Change to the directory as needed. 

4. Hold down the CRTL key while clicking on individual file names to compress.

5. Continue to click on individual files until you have selected all the files to convert/compress.

6. Click on OK or hit the Enter key when you are ready to continue. The "Convert: Destination Image 
File" dialog box appears.

7. Next, select the compression type from the List Files of Type drop down list. Supported 
compression are: LEAD, JFIF, JTIF LEAD1JFIF, LEAD2JFIF, LEAD1JTIF, LEAD2TIF, LEAD 1-bit 
CMP, CCITT, and TIFF LZW.

8. Enter in a new width and height in pixels units. If you want the original width and height, then 
check the "Do not Resize" checked.

9. Select the Qfactor for compression. For LEAD CMP or JPEG compression, you can use a Qfactor 
number or use any of the predefined options.

10. Click on OK when you want to begin file to file compression.



Saving the loaded image as a compressed file

This method will compress the image data currently in memory. If you are not using a true color video 
driver, the image data in memory will change according to your video driver's number of colors. In most 
cases the image will have be dithered down to meet your graphics card requirements. 

To save the original color information while working with a low color driver, use the Keep Two Images 
Option when the image is loaded. This will slow the view time but lets you work with the original image 
data. Do not have this option set if you just want to quickly view images without modifications. This will 
give you fastest display time since LEADVIEW does not have to make two copies of the image data.

 If you are not working with a true color video driver (16 or 256 color driver), the image data in memory 
will be changed to match you video resolution.

 Saving from a loaded image:

1. Open an image for viewing with the Keep Two Image option selected. 

2. After the image has been loaded to the screen, select File from the Main Window. 

3. Choose Save As.

4. Type or select the file name to save.

5. Choose the compression scheme to compress.

6. Select the compression Qfactor.

7. Click on OK or hit the Enter key when you are ready to save the image to a compressed format.



Graphics File Formats
LEADVIEW for Windows supports numerous bitmap based file formats. The following list the formats the 
LEADVIEW for Windows can process.

Due to the many version of bitmap based formats, some version of a particular format might not be 
supported.

File Format Description

TGA Format created by Truevision Inc., and is also referred to as TARGA files. Most TARGA 
files are true color and contains up to 16 million colors. The file format also supports 16-
bit which can contain up to 32,000 colors and 8-bit color mapped formats. LEADVIEW for 
Windows supports all uncompressed and RLE compressed TGA formats as well as gray 
scale formats.

TIFF This is a tag-based file format designed to promote the more universal interchange of 
digital image data. TIFF is capable of storing 1, 4, 8, 16, and 24-bits per pixel images. 
LEADVIEW for Windows supports the TIFF 6.0, CCITT and LZW compression 
specification for TIFF formats.

BMP Format used mostly in Windows based applications that can store 1, 4, 8, and 24-bits per 
pixel images. Also, some BMP images are compressed using RLE compression within 
the file. LEADVIEW for Windows supports all version of BMP formats.

PCX This format was created by ZSoft. The PCX file format can store 1, 4, 8, and 24-bits per 
pixel images. This format compresses its image data using RLE type compression. 
LEADVIEW for Windows supports the compression of 24-bit, and 8-bit color and gray 
scale images. For conversion and viewing images, LEADVIEW for Windows can read 4 
and 1-bit images as well.

GIF The Graphics Interchange Format (GIF) was created by CompuServe for storing and 
exchanging color raster images. GIF files can store 1, 4, and 8-bit color information. This 
format compressed its image data with the LZW compression scheme. LEADVIEW for 
Windows supports compression of 8-bit gray scale and color files. For conversion and 
viewing, it will support 1 and 4-bit images.

WMF Windows Metatfile consists of a collection of "functions" that describes the image. Hence, 
WMF files are not bitmap based. LEADVIEW for Windows can only write out to this file 
format.

EPS This is the Encapsulated Postscript format. This format can be used in any Postscript or 
compatible printers. LEADVIEW for Windows can only write to this format.

See Also . . .

Compression

JPEG
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 Capture Images
LEADVIEW for Windows allows you to capture screen from any windows based applications. You can 
capture the entire desktop area or just a marked area.

When an image is capture, the captured area will be placed in its own window within the LEADVIEW for 
Windows workspace. From there, you can save the image to a file or manipulate the image.

Related Topics:

Capture Options

Capture Methods

Saving Captured Files

How To Capture Screens



Capture Options

Hide Window On Capture

This option completely hides the LEADVIEW for Windows opened window and icon during the 
capture process.

Keep Window On Capture

This option will keep the LEADVIEW for Windows opened window in its current position during the 
capture process

Minimize Window On Capture

This option will minimize the LEADVIEW for Window program into an icon.

See Also . . .

Capture Methods

How To Capture Screens



Capture Methods
You can capture screen using two methods:
·    In a Marked Area

·    Entire Desktop Area

Marked Area

When you capture a marked area, the mouse cursor will change into a "pointer". The pointer will 
define the capture area based on the next mouse click and drag. Once you have dragged out the 
area, LEADVIEW for windows will capture the defined area.

Desktop Area

Capturing the entire desktop area will essentially do an entire screen capture of the current windows 
screen.

See Also . . . 

Capture Options

How To Capture Screens



 Photo Album
The Photo Album allows you to organize your images. These images can be organized into collections 
known as albums. Albums can have categories and descriptions of each image in the album. Each 
images shown in its "thumbnail" form. These thumbnails images provides you with a small 
representation of the image.

Features of the photo album include:

·    Display image name, resolution, category, description, and file format

·    Copy or move thumbnails from one album to another

·    Copy or move thumbnails from one category to another

·    Search for each thumbnail images by description, filename, and category

·    "Always on top" feature

·    "Drag and Drop" images to and from applications that supports drag and drops methods including 
LEADVIEW

See Also ...

Working With the Photo Album

Menu Commands

Album Screens



Photo Album Commands
The LEADVIEW Photo Album gives you additional commands to manipulate and manage your images. 
Commands that are available when using the photo album are:

File Command

Category Command

Image Command



Photo Album File Command
The File command allows you to save the current album. Available menu items are:

Save

Saves the album as its current name. If the current name is "untitled," then LEADVIEW will prompt 
you for a file name to save.

Save As ...

Save the album as a new name. LEADVIEW will prompt you for a new file name to save the photo 
album as.



Photo Album Category Command
The Category Command allows you to sort and describe each thumbnail images in the album. Each 
album can have more than one category. Each category can contain a set of images and descriptions. 
Each image in the category can also contain a single line description about the image.

Add

Add an additional category to the album. You will be asked to enter in a new category name.

Modify

Change the name of an existing category. Changing the name of the category will also change the 
thumbnails that are associated with the category to the new category name.

Search by File Name

Search the entire category for an image based on the file name of the image. This is not a case 
sensitive search.

Search by Description

Search the entire category for an image based on its description. You can search with or withour case 
sensitivity.

Next

Perform the next search based on the last search method.



Photo Album Image Command
This command allows you to insert, delete, and replace thumbnails within the photo album.

File Info - CTRL I

Displays a dialog box showing information about the image.

Insert - Ins

Insert an new image at the current position. The current position is shown as a highlighted yellow 
square around the thumbnail image. The Insert key can also be used to add a new image. The 
inserted image will be place after the selected image and the preceeding thumbnails will be moved 
down.

Delete - Del

Delete the current image. All images after the deleted image will be moved up to replace the empty 
slot.



Photo Album Name

The title bar will display the name of the photo album. If the photo album does not have a name the the 
album will be named "untitiled."



Photo Album File

This is the file command. This allows you to save your photo album to the same file name or as another 
file.

See Also ...

File Command



Photo Album Category

This command allows you to modify, rename, search, or delete a category.

See Also ...

Category Command



Photo Album Image

This command allows you to insert, delete, and replace images within the photo album.

See Also ...

Image Command



Photo Album Thumbnail Images

These are the "thumbnail" images. The enclosed square signify that this is the current, or selected, 
thumbnail image. Squares that do not show a thumbnail image are empty slots.



Photo Album Source Category

This is the current category that the photo album has displayed. This is a drop down list box that can be 
used to select the current category. When the category is selected, all thumbnails associated with the 
category will be displayed. Each category will contain its own set of thumbnails associated with the 
category.



Photo Album Destination Category

This is the destination category. This is a drop down list box that will display all available categories 
within the photo album. Use this to copy thumbnails from one category to another. You can drag on a 
thumbnail and place it on top of the destination category to put the thumbnail image into a new category.



Previous Page

This arrow allows you to move from page to page within the photo album. If there more images to be 
displayed, this arrow will be available.



Next Page

This arrow allows you to move from page to page within the photo album. If there more images to be 
displayed, this arrow will be available.



Image File Name

This shows the complete file name of the image currently being represented by the thumbnail image.



Image Description

This shows a brief description associated with the image. You can enter any description you want in this 
field.



Control Menu

This is the standard Windows control menu. The control menu contains menu items that allows you to 
control the look of the current window. You will find the "Always On Top" command in this menu. The 
"Always On Top" check box will force the photo album window to always stay on top as the active 
window.



Working with the Photo Album
This topic contains procedures and information that will help you while working with the photo album. 
Click on the topic for additional information.

Album Management

Creating a New Photo Album

Opening an Existing Photo Album

Closing an Album

Saving a Photo Album

Moving Thumbnails between Albums

"Always on Top" Feature

Thumbnail Management

Selecting thumbnails

Adding Images into the Album

Moving Thumbnails in Albums

Moving Around in a Category

Adding a Description to the Thumbnail

Searching Thumbnails for an Image

Getting Thumbnail Information

Viewing the Original Image

Category Managemnt

Adding a Category

Deleteing A Category

Moving & Copying Thumbnails Between Categories

Modifying a Category

Searching Thumbnails for an Image

Drag and Drop Features

Using Drag and Drop

Moving and Copying Thumbnails



Adding a New Photo Album
A new photo album can be created by selecting "New" from the Photo Album menu in LEADVIEW's 
main window. Multiple photo albums can be opened allowing you to cut and copy between any number 
of opened photo albums.
 To add a new photo album:

1. From the LEADVIEW main window, select "New" from the Photo Album menu.

2. You will then be asked to enter a new category for the album. Every photo album must have at 
least one category.

3. A new photo album will be displayed. The new album will be named "untitled" until you save it to a 
file name. You will then be given the chance to add new images into the photo album.

See also...

Adding Images into the Album



"Always on Top" Feature
The "Always on Top" feature can be found in the control menu of every photo album window. When this 
option is checked, the photo album will always be shown as the top-most window. This allows you to 
move images from one place to another more efficiently. Note that you can only have one photo album 
that will be always on top at any time.



Opening An Existing Album

Album can be opened and close as needed. Multiple albums can also be opened allowing you to copy 
and insert from one album to another.
 To open an album:

1. Start LEADVIEW if it is not already running.

2. Select "Open" from the Photo Album menu.

3. Choose the name of the album you want to open. LEADVIEW's photo albums will have a default 
extension of ALB.

4. Click on "OK" when you are ready to open the album.

5. Repeat the steps again if you want to open another photo album.



Closing an Album
To close the album, double-click on its control menu box or select "Close" from the control menu of the 
photo album window.



Adding Images into the Album

When you add an image to the album, LEADVIEW will generate a thumbnail image. This thumbnail 
image is used to represent the original image. The thumbnail image can then be moved and/or copied to 
a new category or another album. LEADVIEW recognizes any supported image file formats.

Thumbnails image can also have a description associated with the image. You can enter a single line of 
text describing in more details about the image.

The generated thumbnail image will be inserted before the currently selected image. The preceding 
images will be moved to make room for the new image.

You can add image to the photo album two ways:

·    Select "Insert" from the Image menu

·    Moving thumbnail images from one album to another

·    Drag and drop files from another application

See Also ...

Moving & Copying Thumbnails Between Categories

How to insert images into an album

Adding a Description to the Thumbnail



How to Insert Images Into an Album
 To Insert from the Image menu:

1. Select the album and category to place the new image.

2. Select the position in the photo album where you want the images to be placed, If you are 
inserting over an existing image, the image will be move back to make room the new image(s). If 
the photo album is empty, then the first empty space is used.

3. Select "Insert" from the Image Menu of the Photo Album window. Alternatively, you can press the 
Insert (or Ins) key to insert the new image at the current location in the photo album.

4. Next, select the file(s) that you want to add into the album. You can select one or more image to 
place in the album. To select multiple file, hold down the CTRL key while selecting the files you 
want to add. To deselect an image, click on the file again. Also, you can use the mouse to select 
multiple file by dragging the mouse over the beginning and ending file names.

5. Select "OK" when you are ready to add the images to the photo album. Depending on the number 
of images you select, LEADVIEW will then generate thumbnail images for each of the files and 
then place them into the album under the selected category.

6. Select the album and category to place the new image.

 To Insert an Image using Drag and Drop:

1. Select the album and category to place the new image.

2. Select the position in the photo album where you want the images to be placed, If you are 
inserting over an existing image, the image will be move back to make room the new image(s). If 
the photo album is empty, then the first empty space is used.

3. From another application such as the File Manager, select the file name of the image to insert into 
the photo album. You can select more than one file name.

4. Hold down the left mouse button and drag it to any space in the photo album. The selected image 
will be placed in the new photo album at the current location of the photo album.

See Also ...

Moving Around in a Category



Saving a Photo Album

You can save a photo album to its original file name or save it as a new file name.
 To Save an Album:

1. Select the album that you want to save.

2. Next, choose the "Save" from the File. This will save the album to the current file name.
 To Save an Album to another name:

1. Select the album that you want to save.

2. Next, choose the "Save As" from the File menu.

3. Type in the new file name and click on "OK".



Selecting Thumbnails
Before you move and arrange a thumbnail image, you must first select the thumbnail. To select an 
image, just simply click on the thumbnail image. After clicking on the image, a yellow border will be 
around the image. 



Placing Thumbnails in an Album
The photo album allows you to move and add images to an album. Every time you add an image to the 
album, a thumbnail image is generated. The generated thumbnail is then inserted into the current 
location in the album. 

See Also ...

Adding Images into the Album

Moving & Copying Thumbnails Between Categories



Moving Thumbnails in Albums
You can move thumbnails from any location in an album to another location, category, or even to 
another photo album. Selected thumbnails can be moved by simply clicking and dragging them to a new 
position within the album or to another album.

Note that you can copy the thumbnail by holding down the CTRL key while dragging the thumbnail to its 
new locations. This allows you to have two copies of the thumbnail images at different location. 
However, these thumbnails still reference the same file name.

See Also ...

Moving Thumbnails Between Categories



Moving Around in a Category

There are two ways to move around in a photo album:
·    Page to Page

·    Single Thumbnails

Page to Page

If there are more thumbnails to be shown, the photo album will make available to you a left and right 
arrow as shown below. You can use these arrows to move entire pages at a time.

Single Thumbnails

The cursor keys can be used to move from one thumbnail to another. When you press the cursor key, 
the yellow border (representing the selected thumbnail) will move accordingly. If the next thumbnail is 
on another page, then the photo album will shift the thumbnails over to display the next column of 
thumbnails.

See Also ...

Moving Thumbnails Between Categories



Adding a Description to the Thumbnail
You can attach a description to any thumbnail images. Each description can be up to 256 characters. 
These description can be to used remind you of some particular even or subject. The description can 
also be as a search criteria.

Once you enter a description, it will then appear at the bottom of the window every time you select the 
thumbnail image. When you move the thumbnail image, the description will be moved as well.

See Also ...

Searching Thumbnails for an Image



Searching Thumbnails for an Image
There are two ways to search for a thumbnail within an album:
·    Search by description

·    Search by file name
 To search based on description:

1. Select the album that you want to search.

2. Next, "Search by Description" from the Category menu.

3. Type in the search string you want to search on. Check the "Match Case" check box if you want 
the search to be case sensitive.

4. Click on "Find Next" when you are ready to start the search. When LEADVIEW encounters a 
match, the thumbnail image will be selected. The selected image will be shown with a yellow 
border.

5. To continue to search, click on "Next" from the Category menu.
 To search based on file name:

1. Select the album that you want to search.

2. Next, "Search by File Name" from the Category menu.

3. Type in the file name you want to search on.

4. Click on "Find Next" when you are ready to start the search. When LEADVIEW encounters a 
match, the thumbnail image will be selected. The selected image will be shown with a yellow 
border.

5. To continue to search, click on "Next" from the Category menu.



Getting Thumbnail Information
Getting thumbnail information provides you with technical information about the image. When you select 
"File Info" from the Image menu a message box will appear showing the complete information about the 
image.

File Name - This is the complete file name of the image.

Format - Original file format of the image.

Width - Describes the width of the image expressed in pixels.

Height - Describes the height of the image expressed in pixels.

Bits Per Pixel - This is the image depth of the image. The bits per pixel can be either 1, 4, 8, 16, 24 or 
32.

Size on Disk - The physical file size stored on disk.

Size in Memory - Total amount of memory the image will take up in RAM.

Compression - This field will show the compression method used in the file (if any).

See Also ...

How to get file information



How To Get File Information
 To get file information:

1. Select the album and thumbnail that you want to get information about. Once you select the 
thumbnail image, a yellow border will be shown around the thumbnail image.

2. Next, choose "File Info" from the Image menu. Alternatively, you can hit CTRL+I to get the 
information.



Viewing the Original Image
The Photo Album allows you to the original images from the thumbnail. There are two methods for 
viewing an image:
·    Viewing from LEADVIEW

·    Viewing from another application

Viewing from LEADVIEW

You can view the images using the LEADVIEW application. Just double click on the thumbnail image 
and the image will then be opened in LEADVIEW. Also, you can drag the thumbnail image from the 
photo album and place it on the LEADVIEW main window. This will signal LEADVIEW to open the 
image.

Viewing from another application

LEADVIEW's Photo Album uses Windows 3.1 drag and drop features. Any application supporting drag 
and drop capabilities can be used to open and view the original files. To open an image in another 
application, simply drag the thumbnail image from the photo album and place it in the application icon or 
main window.
Note that not all application supports "drag and drop" features. Check with its documentation to see 

whether the application has this feature.



Adding a Category
A photo album can have more that one category. Every time you add a new category, the category will 
add added to the category drop-down list box at the bottom of the photo album window. Use the drop-
drop down list to select the current and destination category.

Once the category has been added, there will be no thumbnails associated with the category. You will 
then need to add images to the category as needed.

 To add a new category:

1. Select the photo album you want to add the category.

2. Next, choose "Add" from the Category menu. The "Add Category" dialog box will appear.

3. Enter the name of the category. This name must be unique to the album. That is, no duplicates 
are allowed.

4. Click on "OK" when you are ready to add the category to the album.

See Also ...

Adding Images into the Album

Moving & Copying Thumbnails Between Categories



Deleting A Category
Deleting the category will remove the name from the list of categories in the current album.

Deleting the category will also delete the thumbnail(s) associated with the category. It does not affect the 
original image file.
 To add a delete category:

1. Select the photo album you want to delete the category.

2. Select the name of the category that you want to delete by making sure that the album is 
displaying the category. The category name will be shown in the source category drop-down list 
box.

3. Next, choose "Delete" from the Category menu. This will delete the category from the photo 
album.



Moving Thumbnails Between Categories
Moving thumbnails is based on the drag and drop features of Windows and LEADVIEW. Note that drag 
and drops features are only available in Windows version 3.1 only.

Moving the thumbnails from one category to another can be done by clicking and dragging the desired 
thumbnail image and moving the thumbnail to the destination category drop-down list box. Release the 
mouse button on while the mouse pointer is over the destination drop-down list box to place the 
thumbnail to that category.

The category on the left is the current (or displaying) category. The category on the right is the destination 
category. Any thumbnail that you drag and place on top of the destination category will be copies into that 
category.

Note that you can also copy thumbnail images between category by holding down the CTRL key while 
dragging and releasing the thumbnail over the destination category.
 To move a thumbnail to another category:

1. Select the photo album.

2. Display the category that the thumbnail is in by choosing the category from the left category drop-
down list box. The thumbnails for the category will appear in the album.

3. Next choose the destination category on the right category drop-down list. You will notice that the 
thumbnail associated with the destination category is not displayed.

4. Find the thumbnail that you want to move by using the cursor keys or the mouse.

5. Click and drag on the thumbnail from the photo album to the destination category and release the 
mouse button. If you want to make a copy of the thumbnail, hold down the CTRL key while 
dragging the thumbnail to the destination category.

See Also ...

Moving Around in a Category



Modifying a Category
Any category an be renamed. Any thumbnail that was associated with the category will also be renamed 
to match the new category.
 To modify category:

1. Select the photo album.

2. Choose the category that you want to modify by selecting the category from the Category drop-
down list. You will notice that the thumbnails associated with the category will be displayed.

3. Next choose "Modify" from the Category menu.

4. Enter the new category name.

5. Click on "OK" when you are ready to change the category.



Moving Thumbnails Between Albums

Thumbnails can be moved from a category of one album and be placed in another photo album. You 
must have both albums open to copy or move the thumbnails.

Note that you can also copy thumbnail images between albums by holding down the CTRL key while 
dragging and releasing the thumbnail over the destination album.
 To move thumbnails between albums:

1. Open the source photo album by selecting "Open" from the Photo Album menu in LEADVIEW 
and locate the thumbnail you want to move.

2. Open the destination photo album by selecting "Open" from the Photo Album menu in 
LEADVIEW and locate the position you want to place the thumbnail.

3. From the source album, click and drag (with the left mouse button) the thumbnail and place it 
over the destination album at the location you want to insert the thumbnail.

4. Release the mouse button when you are ready to move the thumbnail image to the new album.

See Also ...

Moving Around in a Category



Using Drag and Drop With Photo Album
"Drag and drop" features can help you work more efficiently while using the photo album. Copying and 
moving thumbnails can be done by simply holding down the mouse button while dragging the thumbnail 
and dropping it on the destination area.

Moving Thumbnails

When moving thumbnails, just click and hold down the left mouse button while dragging to its desired 
new location. When you are ready to insert the thumbnail, release the mouse button.

Copying Thumbnails

When copying thumbnails hold the CTRL key while clicking and dragging the thumbnail to it new 
locations.




